Previous page

Next page

Locate page in Contents

Print this page

Working in Coherence

Coherence is a visual mode of working with Windows virtual machines. This mode provides the highest level of integration between Mac OS X and the guest operating systems.

You may find Coherence especially useful when you want to work with the virtual machine applications side by side with your Mac OS X applications. The point is that if you switch a virtual machine with one or more running applications to Coherence, the virtual machine will disappear and you will see only the windows of these applications on the background of your Mac OS X desktop. Now if you start one or more Mac OS X applications, you will be able to switch between the windows of Mac OS X applications and windows of the guest OS applications as if the later were also Mac OS X applications.

Coherence View

To switch a virtual machine to Coherence, do one of the following:

  • Click the Coherence button Coherence button in the Parallels Desktop toolbar;
  • Choose Coherence from the View menu;
  • Use the appropriate hot key combination (Ctrl+Cmd+Return by default); or

    Note: The default hot key combinations can be configured in the Keyboard pane of the Preferences dialog.

  • Click the Coherence button The small Coherence button in the virtual machine status bar.

You can also configure your virtual machine to always start in Coherence by editing the Startup and Shutdown settings in the Virtual Machine Configuration dialog.

To switch the virtual machine from Coherence to another view mode:

  • Click the View menu and choose the view mode to which you want to switch your virtual machine;
  • Use the appropriate hot key combination (Ctrl+Cmd+Return by default); or
  • Right-click the Parallels Desktop icon in the Dock, point to the View item, and choose the view mode to which you want to switch your virtual machine.

When you work in Coherence, you can use the following features to make your work more efficient:

  • Use the Dock to open Windows guest OS applications;
  • Leave the Windows taskbar visible on the Mac OS X desktop when the virtual machine window disappears;
  • Use Mac OS X applications to open your Windows guest OS files and vice versa;
  • Use the Windows applications folder available in the Dock to start the applications installed in the Windows guest OS;
  • Use the Trash in Mac OS X to remove your Windows guest OS files;
  • Use Mac OS X Application Switcher to switch between your running Mac OS X and Windows guest OS applications;
  • Use Mac OS X Expose to navigate between the windows of the Mac OS X and Windows guest OS applications; and
  • Move the windows of your Windows guest OS applications from one display to another (if you have more than one display).

Using the Dock in Coherence

You can open Windows guest OS applications directly from the Dock by clicking their icons. As you start a Windows application, its icon appears in the Dock. When you close the application or shut down the virtual machine, the application icon disappears from the Dock.

To keep the icon in the Dock:

  1. Right-click (Control-click) the Windows application icon in the Dock.
  2. Choose Keep in Dock from the shortcut menu.

Clicking a Windows application icon in the Dock starts the virtual machine and the application in it. The virtual machine is automatically switched to Coherence.

Using the Windows Taskbar

By default, both Windows taskbar and Mac OS X Dock are visible. You can use any of the Windows taskbar elements right from Mac OS X Desktop. You can hide the Windows taskbar by choosing View > Hide Windows Taskbar. When the Windows taskbar is hidden, it is convenient to use the Start button icon in the Dock. If you click this icon, the Windows Start menu appears. To display this icon, select the Use Start button icon in Coherence option in the Parallels Desktop general preferences.

PD6_Start Button

Sharing your Windows and Mac applications

You can use Mac OS X applications to open the files in your Windows guest OS and vice versa. The list of Parallels Shared Applications is created during the Parallels Tools installation. This list includes your Mac OS X applications and is available when you choose All Programs > Parallels Shared Applications from the Windows Start menu. You can select any application from the list and start it.

Right-click a file in Mac OS X or Windows and choose any available Mac OS X or Windows application from the Open With list.

Note: To share your Mac OS X and Windows applications, you need to disable the Isolate Mac from Windows option in the Security pane of the Virtual Machine Configuration dialog.

Windows Applications Folder in the Dock

If you selected the Show Windows applications folder in Dock option in the Applications pane of the Virtual Machine Configuration dialog, the folder with all applications installed in your Windows virtual machine will be displayed in the Dock. You can use this folder to quickly access your Windows applications.

PD_Coherence_WindowsApps

Using Mac OS X Trash

You can remove files and folders that you do not need any more by simply dragging them from your virtual machine to the Trash in Mac OS X. After a file or folder is removed, it is automatically placed to Windows Recycle Bin and can be viewed by choosing Windows Recycle Bin from the View menu. You can then restore the file/folder by right-clicking it and selecting Restore. If you wish to empty the Recycle Bin contents, choose Empty Windows Recycle Bin from the File menu.

Using Application Switcher

You can switch between any of the running Mac OS X and Windows applications by using Application Switcher.

  1. While holding down the Command key on the keyboard, press Tab. You will see the Application Switcher bar across the desktop with all applications running in both Windows and Mac OS X.
  2. Select the application by clicking its icon in the bar.

Application Switcher Bar

Using Expose With Your Windows Applications

When working in Coherence, you can use Expose to navigate between the windows of the Mac OS X and guest OS applications opened on your desktop. To activate Expose, press the F9 key (on portable Macintosh computers, use the Fn+F9 key combination instead).

If the F9 key does not activate Expose, refer to Mac Help for information about changing the Mac OS X shortcuts.

Sharing Windows System Tray Icons With Mac OS X

When you are working with a Windows virtual machine in the Coherence view mode or its variation - Crystal - you may need to manage the guest operating system or its applications using the icons from the Windows notification area. Parallels Desktop 6 allows you to display these icons in the Mac menu bar which makes it easier to access them. To make the icons available in the Windows notification area also available in the Mac menu bar, select Show Windows notification area in menu bar in the Coherence pane. For Windows 7 virtual machines with this option enabled and working in Coherence, Windows notification area icons are available in the following menu:

PD6 - WinTray icons in Mac menubar

To open this menu, click the down-pointing white triangle.

If you click Customize in the menu or click the white triangle when there are no notification area icons in the Windows 7 guest OS, you will be able to specify what icons you want to be displayed and how they will be displayed.

Using Windows 7 Jump Lists in Coherence

When you are working with a Windows 7 virtual machine in the Coherence view mode or its variation - Crystal - you can view the Jump List for an application that is currently running in Windows 7 by right-clicking this application's icon in the Dock and choosing Show Jump List. To open an item on the Jump List, click the specific item.

Note: If an application is running in the guest operating system but the application's icon does not appear in the Dock, make sure the Share Windows applications with Mac option is enabled in the Applications pane of the Virtual Machine Configuration dialog.

Related Topics

Keyboard Preferences

Status Bar

Startup and Shutdown Settings

General Preferences

Security Settings

Applications Settings

Crystal Mode