## Contents

**Welcome to Parallels Desktop** .............................................................. 8
  - What You Can Do ................................................................................. 9
  - Set Up Your Mac to Use Windows Programs ....................................... 9
  - Other Operating Systems .................................................................... 10

**Install or Upgrade Parallels Desktop** ......................................................... 11
  - What You Need .................................................................................... 12
  - Install Parallels Desktop ........................................................................ 13
  - Activate Parallels Desktop ..................................................................... 13
  - Register Parallels Desktop ..................................................................... 14
  - Upgrade Parallels Desktop ..................................................................... 14
    - Install Software Updates ..................................................................... 15
    - Set the Language ............................................................................... 16

**Install or Import Windows** ................................................................. 17
  - Install Windows from an Installation Disc ........................................... 18
  - Import Your Data from a PC ................................................................. 19
    - Overview of Methods for Importing .................................................. 19
    - Requirements for Importing Your Data ............................................... 20
    - Step 1: Install Parallels Transporter Agent on Your Windows PC .......... 20
    - Step 2: Import Your Data ................................................................... 20
    - Solving Problems .............................................................................. 29
  - Use Boot Camp with Parallels Desktop ................................................. 33
  - Import from an Earlier Parallels Desktop or Other Virtualization Application .................................................. 34

**Use Windows on Your Mac** ................................................................. 35
  - Get Started ......................................................................................... 35
    - Start Windows ................................................................................. 36
    - Open a Windows Program ............................................................... 37
    - Install Windows Programs .............................................................. 41
    - Shut Down or Suspend Windows ....................................................... 42
  - Set How Windows Works with Mac OS X ........................................... 45
    - Merge Windows and Mac OS X ....................................................... 46
Contents

Set Windows to Appear in a Single Window ................................................................. 50
Set Windows to Take Up the Whole Screen ............................................................... 53
About Using Windows 8 with Parallels Desktop ....................................................... 57
Set Windows to Look Like Mac OS X Desktop .......................................................... 60
Copy and Paste Between Mac OS X and Windows .................................................. 60
Set a Program to Open When You Insert a CD or DVD ....................................... 61
Share Items Between Mac OS X and Windows ....................................................... 61
Apply Mac OS X Parental Controls to Windows .................................................... 73

Mouse, Trackpad, and Keyboard ................................................................................. 73
Set Your Mouse or Trackpad to Right(Middle)-Click ........................................... 74
Control Programs with Trackpad Gestures or the Apple Remote .......................... 76
Customize Keyboard Shortcuts ............................................................................. 79
Create New Keyboard Shortcuts .......................................................................... 82
See and Change Windows Input Language In OS X ............................................. 83

Connect USB Devices ............................................................................................... 84
Adjust USB Settings ............................................................................................... 85

Connect Bluetooth Devices ..................................................................................... 87
Print from Windows ................................................................................................. 87
Share a Printer Connected to Your Mac ............................................................... 88
Set Up a Printer Using Bonjour ............................................................................. 90
Set Up a Network Printer ...................................................................................... 92
Set Up a USB Printer ............................................................................................. 95

Use the Built-in iSight Camera or Another Webcam ............................................ 96
Show a Presentation on an External Monitor or Projector ................................... 97

Protect Your Data .................................................................................................... 98
Protect Your Data from Viruses ........................................................................... 99
Isolate Mac OS X from Windows ......................................................................... 100
Work in Windows Without Saving Changes ...................................................... 100
Set Password Requirements .............................................................................. 101
Encrypt Windows to Protect It from Unauthorized Use ..................................... 102

Connect to the Internet or a Network .................................................................... 103
Share Network Settings Between Mac OS X and Windows .............................. 103
Apply Separate Network Settings to Windows .................................................... 104
Use Host-Only Network Settings ......................................................................... 105
Use Wi-Fi with Windows ...................................................................................... 107
Install Windows 98 .............................................................................................................. 144
Improve Graphics Performance in Windows NT/98/ME....................................................... 147
Customize the Keyboard for the Guest OS ..........................................................................148
Use OS X as a Guest OS .....................................................................................................150
Install or Update Parallels Tools ..................................................................................... 152
Parallels Tools Overview ......................................................................................................153
Parallels Tools for Windows .................................................................................................155
Parallels Tools for Linux .......................................................................................................157
Parallels Tools for Mac ........................................................................................................162
Install Sound Driver in OS/2 and eComStation .................................................................163
Modality Mode .............................................................................................................. 164
Hide and Show Parallels Desktop .................................................................................. 166
Remove Parallels Desktop ............................................................................................. 166
Advanced Preferences ..................................................................................................167
Shared Networking Settings .............................................................................................170
Host-Only Networking Settings ..........................................................................................173
Advanced Settings ..............................................................................................................174
Adding and Removing Devices ...................................................................................... 177
Support for Virtual and Real Disks ..................................................................................179
Initialize a Newly Added Disk ...........................................................................................181
Hardware Settings ........................................................................................................ 183
Boot Order ..........................................................................................................................183
Video ...................................................................................................................................185
Floppy Disk ..........................................................................................................................187
CD/DVD-ROM .....................................................................................................................189
Hard Disk ............................................................................................................................191
Network Adapter .................................................................................................................194
Printer Port ..........................................................................................................................196
Serial Port ............................................................................................................................198
Sound ...................................................................................................................................200
USB & Bluetooth ............................................................................................................202
Tips and Troubleshooting ................................................................. 203
  Install Parallels Tools for Seamless Operation Between Windows and Mac OS X ...... 204
  I Can’t Activate Parallels Desktop .................................................................. 204
    Activate Parallels Desktop When Your Mac Isn’t Connected to the Internet ........ 205
  Memory Usage Problems .............................................................................. 207
  Windows Seems Slow .................................................................................... 208
  Pressing Ctrl+Alt+Del ....................................................................................... 209
  My Password Isn’t Working ........................................................................... 209
  I’m Having Problems Connecting to the Internet ............................................ 210
  Configure 5.1 or 7.1 Surround Sound in a Virtual Machine ............................ 211
  I’m Having Problems with Antivirus Software ................................................. 213
  The F8 Key Isn’t Working Correctly .................................................................. 213
  A Password is Required to Open the Virtual Machine Configuration ............... 213
  Configuring a Network in Linux ...................................................................... 214
  Installing the GCC Package and Kernel Sources in Linux ................................ 215
  Checking the Build Number .......................................................................... 215
  Report a Problem and Request Support ......................................................... 216

More Resources ....................................................................................... 218
  Visit the Parallels Desktop Twitter and Facebook Pages .................................. 218
  Visit the Parallels Convenience Store ............................................................. 219

Glossary .................................................................................................... 220

Index ....................................................................................................... 224
Congratulations on purchasing Parallels Desktop 8 for Mac. You no longer have to choose between the Mac or the PC. Parallels Desktop lets you use Windows side-by-side with Mac OS X on your Mac.

Use this guide to quickly set up and start using Parallels Desktop.

In This Chapter

What You Can Do .......................................................................................................................... 9
Set Up Your Mac to Use Windows Programs .............................................................................. 9
Other Operating Systems ............................................................................................................. 10
What You Can Do

With Parallels Desktop, you can:

- Open Windows programs side-by-side with your Mac OS X applications, without having to restart
- Copy and paste text and drag and drop objects between Mac and Windows applications
- Run Windows games and other 3D programs
- Transfer all your data from a PC and use it on your Mac
- Easily share files, devices, and other resources between Windows and the Mac
- Install other operating systems, such as Linux, Google Chrome OS, another copy of OS X Mountain Lion, and Mac OS X Server, and use them together
- And much more

Set Up Your Mac to Use Windows Programs

After just a few steps, you can begin using Windows programs on your Mac. Setting up your Mac to run Windows programs involves the following steps:

**Step 1:** Install Parallels Desktop (p. 11).

**Step 2:** Install Windows on your Mac (p. 17).

**Step 3:** Install your Windows programs (p. 41).

You only need to follow these steps once. Then you can open and use your Windows programs on your Mac anytime you like, just as you do with your Mac applications.
Other Operating Systems

**Important:** This guide is focused on using Parallels Desktop with Windows XP or Windows 7.

Using Parallels Desktop 8 for Mac you can run several other kinds of operating systems (p. 119) on your Mac, such as several flavors of Linux and Unix, Mac OS X Server, Windows 8, older versions of Windows, and more.

**Finding Information On Running Other Operating Systems**

You can find much more information and details on using Parallels Desktop to run other operating systems on your Mac by checking the resources listed in More Resources (p. 218).

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply to supported operating systems other than Windows XP and Windows 7. And some important instructions relating to other operating systems are in the Advanced Topics (p. 118) section.
Follow the instructions in this chapter to install or upgrade Parallels Desktop.

**Note:** You can either purchase a boxed version of Parallels Desktop 8 or download it from the Parallels website.

**In This Chapter**

- What You Need ........................................................................................................ 12
- Install Parallels Desktop .......................................................................................... 13
- Activate Parallels Desktop ....................................................................................... 13
- Register Parallels Desktop ....................................................................................... 14
- Upgrade Parallels Desktop ....................................................................................... 14
- Set the Language ..................................................................................................... 16
Install or Upgrade Parallels Desktop

What You Need

To install and set up Parallels Desktop 8 for Mac, you need:

- A Mac computer with:
  - An Intel Core 2 Duo processor or better
  - At least 2GB of RAM (4GB recommended to run Windows 7)

Note: Your Mac must have enough RAM memory to use Mac OS X and its applications plus the memory required for each additional operating system (and its programs) that you want to use simultaneously.

- At least 700 MB of space available on the boot volume (the volume that has Mac OS X) for Parallels Desktop installation
- Enough free disk space for each virtual machine and its applications (at least 15 GB for each installation of Windows)
- OS X 10.8 Mountain Lion or later, OS X Lion 10.7.4 or later, or Mac OS X Snow Leopard v10.6.8 or later

To identify your computer’s processor, memory, and Mac OS X version, choose Apple menu > About This Mac.

- Internet connection required for product activation, select features, and online updates
- One of the following:
  - A Windows installation disc, or other installation media for the operating systems you want to use alongside Mac OS X
  - An Internet connection to download and install freely available operating system such as Ubuntu or Google Chrome.
  - If you’re using OS X Lion or later, you can set up a second copy of OS X to be used as a guest operating system alongside your main system, without having to purchase or download another copy of OS X.

For a list of operating systems that Parallels Desktop supports for use with your Mac, see Supported Guest Operating Systems (p. 119) or go to http://www.parallels.com/products/desktop/system-requirements/.
Install Parallels Desktop

You can be up and running with Parallels Desktop in a few easy steps:

1. Make sure you have the latest version of Mac OS X by choosing Apple menu > Software Update (you must have an Internet connection).
   If a later version of Mac OS X is available, select it and click Install.

2. Do one of the following:
   - If you downloaded Parallels Desktop from the Parallels website, double-click the disk image file, most likely in your Downloads folder (the file has the extension "*.dmg" at the end).
   - If you purchased a boxed copy of Parallels Desktop, insert the installation disc.

   **Note:** If your Mac doesn’t have a DVD-ROM, you can use the download link, available in the retail box, to download Parallels Desktop over the Internet.

3. Double-click the Install icon and follow the onscreen instructions to install Parallels Desktop.

Activate Parallels Desktop

Once the installation is finished, you must enter your Product Activation Key to activate Parallels Desktop.

If you purchased Parallels Desktop from the Parallels Online Store, a key was sent to the email address you provided. If you bought a boxed copy, you can find your key printed on the installation disc sleeve.

   **Note:** If you bypass the activation dialog, you can activate Parallels Desktop later by choosing Parallels Desktop > Activate Product and entering your Product Activation Key.

If You Don't Have A Product Activation Key

If you don’t have a key already, you can get one by choosing Parallels Desktop > Activate Product. Then, to get a free trial Product Activation Key so you can try out Parallels Desktop for a limited time, click Get Trial. Or to purchase a key that lets you use Parallels Desktop permanently, click Buy.

If Your Mac Isn't Connected to the Internet

It’s easiest to activate Parallels Desktop when your Mac is connected to the Internet, but if you have another computer or device that’s connected, you can use that (p. 205).
Install or Upgrade Parallels Desktop

Register Parallels Desktop

After activation, you’re presented with the opportunity to register Parallels Desktop. Registering allows you to:

- Automatically download and install the latest Parallels Desktop updates.
- Create a backup copy of the product key on the Parallels web server and restore it at any time.
- Easily contact the Parallels support team, using the support code.
- Stay informed about Parallels news and announcements.

**Note:** If you choose not to register Parallels Desktop after installation, you can register anytime by choosing Parallels Desktop > Register Product when the application is open.

Upgrade Parallels Desktop

If you already have Parallels Desktop 6 or 7 follow these steps to upgrade to Parallels Desktop 8.

1. If you haven’t already done so, purchase and download a "Parallels Desktop 8 for Mac Upgrade," available from the Parallels Online Store at www.parallels.com/buyonline.
   A Product Activation Key is sent to the email address you provide.

2. If Parallels Desktop is open, quit Parallels Desktop.

3. Follow the instructions to install Parallels Desktop 8. See Install Parallels Desktop (p. 13).
   During installation, the previous version of Parallels Desktop is automatically removed from your computer.

4. Open Parallels Desktop and enter your upgrade Product Activation Key.
   If you were using a trial version of Parallels Desktop or you purchased a previous version but haven’t installed it on your computer, you will also be prompted to enter a full or upgrade key for that version.

**Note:** To upgrade from Parallels Desktop 2, 3, 4, or 5 you must purchase Parallels Desktop 8 at full retail price.

Solving Problems

If you have any problems upgrading Parallels Desktop, you can find troubleshooting information at www.parallels.com/support/free/troubleshooter or by opening Parallels Desktop and choosing Help > Troubleshooting Guide.
Install or Upgrade Parallels Desktop

Install Software Updates

Periodically, Parallels provides free software updates to improve Parallels Desktop.

By default, Parallels Desktop is configured to automatically check for and download available software updates once a week. When an update is available, Parallels Desktop prompts you to install it. Simply follow the onscreen instructions.

Adjust Software Update Settings

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences. Then click General.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences, and then click General.
2 Do one of the following:

- To adjust the frequency that Parallels checks for software updates, choose Never, Once a Day, Once a Week, or Once a Month from the Check for Updates menu.
- To choose whether you want Parallels Desktop to download updates automatically, select or deselect Download updates automatically.

If you choose not to download updates automatically, Parallels Desktop notifies you when an update is available and asks whether you want to download it.

**Check for an Update Manually**

- Follow the instructions in step 1 above and then click Check Now. You can also choose Check for Updates from the Parallels Desktop application menu.

**Note:** To check for updates and download them, your Mac must be connected to the Internet and you must register your copy of Parallels Desktop (p. 13).

**Set the Language**

You can set which language the Parallels Desktop interface uses by doing the following:

1 Quit Parallels Desktop.
2 Choose Apple menu > System Preferences, click Language & Text, and then click Language.
3 Drag the language you want to the top of the list. If you don’t see the language you want to use in the list, click Edit List.
4 Open Parallels Desktop.

If the primary language you chose is supported by Parallels Desktop, the menus and interface text appear in that language. If the primary language you selected isn’t supported, menus appear in the first language listed that Parallels Desktop supports.
There are a few ways to get Windows up and running on your Mac:

- Install Windows from a Windows installation disc (p. 18)
- Import your data from a Windows PC (p. 19)
- Use Windows that you already have installed from a Boot Camp partition (p. 33)
- Import Windows from a previous version of Parallels Desktop or other virtualization software (p. 34)

In This Chapter

- Install Windows from an Installation Disc ................................................................. 18
- Import Your Data from a PC .................................................................................... 19
- Use Boot Camp with Parallels Desktop .................................................................... 33
- Import from an Earlier Parallels Desktop or Other Virtualization Application ......... 34
Install Windows from an Installation Disc

If you have a Windows installation DVD and a valid Windows product key, you can install Windows from the disc and use it with Parallels Desktop.

To install Windows:

1. Open Parallels Desktop (in the Applications folder) and choose File > New.
2. Insert the Windows installation disc.
3. Click Install Windows from DVD or image file.
4. Select the Windows installation disc from the Install from menu.
5. Be sure to leave Express installation selected.

Note: If you deselect Express installation, you'll need to install Parallels Tools (p. 204) after the installation to allow the most seamless operation between Windows and Mac OS X.

6. If you are installing a recent version of Windows, select how you want to use Windows:
   - Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. Documents and media from Mac OS X and Windows are kept together on your Mac.
   - Like a PC: The Windows desktop and programs appear in a single window, separate from Mac applications. You can drag and drop objects between Windows and the Mac.

7. Choose where you want to store Windows from the Location menu.

   By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To allow all users of your computer to have access to this installation of Windows, select Share with other users of this Mac.

8. If you want to pre-set things like how much memory Windows uses or whether it starts automatically when you open Parallels Desktop, select Customize settings before installation. You can also adjust these settings after the operating system is installed.

9. Click Continue.

   The assistant installs Windows.

Once Windows is installed, you can start it up by opening a Windows program (p. 37) or by clicking the power button in the Parallels Virtual Machines list.
Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels Tools are installed, you’re prompted to restart Windows.

If you didn’t select Express installation in step 5 above, you must install Parallels Tools manually (p. 204).

When you install Windows, Parallels Desktop creates an administrator account with a blank password. Once the installation is complete, it is recommended that you change this password.

Note: You can also install Windows from a disk image file of an installation disc. Simply choose the disk image file in step 4 above.

Import Your Data from a PC

You can import all your data from a Windows PC to Parallels Desktop on your Mac. Then you can continue to work with all your Windows programs, files, and data, side-by-side with Mac OS X.

Overview of Methods for Importing

You can import your data using one of the following:

- **Parallels USB cable (p. 21):** If you have Parallels Desktop 8 Switch to Mac Edition™, you can use the included Parallels USB cable. This is the simplest way to import your data. The Windows PC and your Mac must be close to one another.

- **Network (p. 24):** If both the Windows PC and your Mac are connected to a network, you can import your data over the network.

- **External storage device (p. 27):** You can transfer the data from a Windows PC to an external storage device, such as an external hard drive. Then, you can connect the device to your Mac and import your data into Parallels Desktop.
Requirements for Importing Your Data

To import your data to your Mac, you need a Windows computer with:

• Windows XP with Service Pack 2 or later, Windows Vista, or Windows 7.

  **Note:** You can also use a computer running Windows Server 2008 R2 (64-bit only), Windows Server 2008, or Windows 2000 Professional (32-bit only).

• An Intel or AMD (700 MHz or higher) x86 or x64 processor
• At least 256 MB of RAM
• At least 70 MB of hard disk space for installing Parallels Transporter Agent
• One of the following:
  • An Ethernet port for transferring your data over network
  • A USB port for transferring your data using the Parallels USB cable
  • An external storage device, such as a USB hard disk

  **Note:** Parallels Desktop does not support migrating Windows dynamic volumes. These are volumes which size is not fixed as in basic volumes. They are migrated as data disks only. You can later add them (p. 177) to an already existing virtual machine.

Step 1: Install Parallels Transporter Agent on Your Windows PC

To import your data you must first install the Parallels Transporter Agent software on the Windows PC.

To install Parallels Transporter Agent:

10 Do one of the following:

  • If you purchased a physical copy of Parallels Desktop, insert the Parallels Desktop installation DVD into your Windows PC. If the installation doesn’t start automatically, locate and double-click the Parallels Transporter Agent.exe file on the disc.

  • Download Parallels Transporter Agent for Windows from the Parallels website at http://www.parallels.com/download/desktop/ and double-click the installation file.

If your computer is connected to the Internet, Parallels Transporter Agent checks for available updates. If an update is available, click Download and Install New Version.

11 Follow the onscreen instructions to install Parallels Transporter Agent.

Step 2: Import Your Data

Follow one of the methods below to import your data from your PC to your Mac.
Using a Parallels USB Cable

**Important:** After importing your data from your PC, you may need to reactivate some of your Windows programs using the activation keys you received when you purchased the programs.

The Parallels USB cable required for this method is included with Parallels Desktop Switch to Mac Edition. If you don't have the Parallels USB cable, import your data using one of the other methods.

**To import your data from your PC using the Parallels USB Cable:**

1. Turn on your Mac and your Windows PC and log in to both computers.
2. On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.
Install or Import Windows

3. Connect the Parallels USB cable to your Windows PC and to your Mac.
4. If the Windows PC is running Windows XP, the **Found New Hardware** wizard opens. In this wizard:
   a. Select **Yes, this time only**, and click **Next**.
   b. Select **Install the software automatically (Recommended)**, and click **Next**.
   c. A **Hardware Installation** warning appears. Click **Continue Anyway**.
   d. Drivers for the Parallels USB cable are installed. Click **Finish** to exit the wizard.
5. On your Mac, open Parallels Desktop and choose **File > New**.
6. Select **Migrate from a PC** and click **Continue**.
7. Select **Parallels USB cable** and click **Continue**. Parallels Transporter starts collecting the information about the source computer.
8 If the Windows Installation Files window appears, insert the Windows installation disc into your Mac and click Continue.

9 If you don’t want to log in to Windows automatically whenever you start up Windows, select Do not enable Automatic Logon. When ready, click Continue.

10 Choose whether you want to migrate all your files and data or only Windows applications. When ready, click Continue.

11 Select how you want to use Windows:
   - Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. Documents and media from Mac OS X and Windows are kept together on your Mac.
   - Like a PC: The Windows desktop and programs appear in a single window, separate from Mac applications. You can drag and drop objects between Windows and the Mac.

12 Choose where you want to install your data. You can also click Customize and select which Windows volumes to migrate.
Install or Import Windows

When ready, click **Continue**.

13 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select **I want to continue** and click **Continue**.

14 Once the migration is complete, click **Done**.

15 **Start Windows** (p. 36).

16 Once Windows starts up, choose **Virtual Machine** > **Install Parallels Tools** and follow the onscreen instructions.

**Note:** To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Over a Network

**Important:** After importing your data, you may need to reactivate some of your Windows programs using the activation keys you received when you purchased the programs.

To import your data from a PC over a network:

1 Turn on your Mac and your Windows PC and log in. Make sure that the computers are connected over the same network.

2 Make sure that **Windows Firewall** (p. 31) is turned off. You can turn it on again after the import is finished.

3 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing **All Programs** > **Parallels** > **Parallels Transporter Agent**.
4 On your Mac, open Parallels Desktop and choose File > New.

5 Select Migrate from a PC and click Continue.

6 Select Network and click Continue.

7 Find the passcode displayed in Parallels Wizard on your Mac and enter it in Parallels Transporter Agent on your Windows PC.

You can also connect to the source Windows PC using its name or IP address. To do so, click Use IP address instead, select the Windows PC name from the list or type the IP address, and click Continue.
8 If you have chosen to use the computer name or IP address, provide the Windows administrator credentials. Parallels Desktop connects to Parallels Transporter Agent and starts collecting information about the source computer.

9 If the Windows Installation Files window appears, insert the Windows installation disc into your Mac and click Continue.

10 If you don’t want to log in to Windows automatically whenever you start up Windows, select Do not enable Automatic Logon. When ready, click Continue.

11 Choose whether you want to migrate all your files and data or only Windows applications. When ready, click Continue.

12 Select how you want to use Windows:

   • **Like a Mac**: Windows programs appear on the Mac desktop, just like Mac applications. Documents and media from Mac OS X and Windows are kept together on your Mac.

   • **Like a PC**: The Windows desktop and programs appear in a single window, separate from Mac applications. You can drag and drop objects between Windows and the Mac.

13 Choose where you want to install your data. You can also click Customize and select which Windows volumes to migrate.
When ready, click **Continue**.

14 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select **I want to continue** and click **Continue**.

15 Once the migration is complete, click **Done**.

16 **Start Windows** (p. 36).

17 When Windows boots up, choose **Virtual Machine > Install Parallels Tools** and follow the onscreen instructions.

**Note:** To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

### Using an External Storage Device

**Important:** After importing your data, you may need to reactivate some of your Windows programs using the activation keys you received when you purchased the programs.

To import your data from a PC using an external storage device:

1. Connect an external storage device to your Windows PC.
2. On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing **All Programs > Parallels > Parallels Transporter Agent**.
3. Click the external storage device icon.
4 Click **Next**. Parallels Transporter Agent collects information about the Windows PC.

5 If you don’t want to log in to Windows automatically whenever you start up Windows, select **Do not enable Automatic Logon**. When ready, click **Next**.

6 Choose whether you want to migrate all your files and data or only Windows applications. When ready, click **Next**.

7 Choose where you want to store your data. You can also click **Customize** and select which Windows volumes to migrate.
When ready, click Next.

8 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select I want to continue and click Next.

9 Once the migration is complete, click Done to quit Parallels Transporter Agent.

10 Disconnect the storage device from the Windows PC and connect it to your Mac.

11 On your Mac, open Parallels Desktop and choose File > New.

12 Select Migrate from a PC and click Continue.

13 Select External Storage Device and click Continue.

14 Click Choose and locate where you chose to store your data in step 7. Then click Continue.

15 Select how you want to use Windows:

   • Like a Mac: Windows programs appear on the Mac desktop, just like Mac applications. Documents and media from Mac OS X and Windows are kept together on your Mac.

   • Like a PC: The Windows desktop and programs appear in a single window, separate from Mac applications. You can drag and drop objects between Windows and the Mac.

16 Choose where you want to install Windows and your data, and then click Continue.

17 Once the migration is complete, click Done.

18 Start Windows (p. 36).

19 When Windows boots up, choose Virtual Machine > Install Parallels Tools and follow the onscreen instructions.

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Solving Problems

Read this section if you have problems importing your data from a Windows PC.
General Tips

This section provides solutions to some errors that may occur during the import process.

Parallels Transporter Agent Doesn't Work Correctly

If you experience any problems while importing, make sure that the snapman.sys driver is installed in C:\WINDOWS\system32\drivers\.

If the snapman.sys driver is not installed, follow these steps:

1. Uninstall Parallels Transporter Agent.
2. Restart your Windows PC.
3. Reinstall Parallels Transporter Agent.
4. Restart your Windows PC again.
5. Try to import Windows and your data again.

Import is Interrupted by an Error

If the import process is interrupted by an error, do the following:

1. From the Start menu, choose My Computer.
2. In the Hard Disk Drives pane, right-click the volume you want to import, and choose Properties.
3. In the Properties pane, click the Tools tab, and in the Error Checking section, click the Check Now button.
4. In the Check Disk window, select Automatically fix file system errors and Scan for and attempt recovery of bad sectors, and then click Start.
5. Wait till the disk is scanned and errors are fixed.

Dynamic Volumes are not Imported

Only basic volumes can be imported. You can't import dynamic volumes using Parallels Desktop.

The only way to import the data stored on a dynamic disk is to copy the data to a basic disk on your Mac and then import the basic disk.
If Your Mac Fails to Connect with Parallels Transporter Agent

Firewall applications may block connections between your Mac and Parallels Transporter Agent on the Windows PC.

Firewall problems in Mac OS X

If your Mac fails to connect with Parallels Transporter Agent on your Windows PC, the reason may be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent.

To enable connections between your Mac and Parallels Transporter Agent and prevent further blocking, you can configure the firewall settings in Mac OS X by doing the following:

1. From the Apple menu, choose **System Preferences**, and then click **Security**.
2. Click the **Firewall** tab.
3. Configure the necessary settings.

If you try to search for Parallels Transporter Agent by typing the Windows PC IP address manually, you may receive a message saying that Parallels Transporter Agent is blocked. Click the **Unblock** button.

Firewall problems in Windows

Microsoft Windows operating system has a built-in firewall that blocks connections to and from other computers. When starting Parallels Transporter Agent for the first time, you may see a message saying that Windows Firewall has blocked some features of the program.

To enable the connection between your Mac and Parallels Transporter Agent, click **Unblock**.

To prevent this problem from happening again, add Parallels Desktop and/or Parallels Transporter Agent to the firewall exceptions (the list of applications allowed to communicate through the firewall):

1. From the **Start** menu, choose **Control Panel > Network Connections**.
2. In the **Network Tasks** pane, click **Change Windows Firewall Settings**.
3. Add Parallels Desktop and/or Transporter Agent to the firewall exceptions list.

If Parallels Doesn’t Detect Windows Correctly

If Parallels Desktop detects the source operating system (Microsoft Windows XP or Windows Vista computer) incorrectly, make sure that neither of your Windows programs are running in compatibility mode - a special mode of Windows allowing you to run applications that are incompatible with your version of Windows.

See Windows Help for more information.
Problems Using a Program After an Import

Programs that depend on specific hardware may not work in Parallels Desktop.

If you import from several source volumes, the disk drive letters are changed. Make sure that the program paths are set correctly. See Windows Help for more information.
Use Boot Camp with Parallels Desktop

Boot Camp is a feature of Mac OS X that lets you start up your Mac in Windows. If you have already installed Windows 7, Windows Vista, or Windows XP on your Mac using Boot Camp, you can set Parallels Desktop to work with Boot Camp using either of these two options:

• **Set Parallels Desktop to run Windows from the Boot Camp partition:** Changes you make in Windows programs either while working in Mac OS X or when you start up your Mac in Windows using Boot Camp will be reflected in both places.

  Windows running from Boot Camp has the following limitations:
  • It can't be paused
  • It can't be saved as a snapshot (p. 131)
  • It can't run in Safe Mode
  • It can't be compressed

• **Import Windows and your data from Boot Camp into Parallels Desktop:** Windows running from Parallels Desktop doesn't have the above listed limitations. Boot Camp and Parallels Desktop are separate. Changes you make in Windows programs while working in Mac OS X are not reflected when you start up your Mac in Windows using Boot Camp.

**Set Parallels Desktop to run Windows from the Boot Camp Partition**

1. Open Parallels Desktop (in the Applications folder) and choose File > New.
2. Click Boot Camp, and then follow the onscreen instructions.

  **Note:** If you plan to start up in Windows using Boot Camp, it is recommended that you shut down Windows in Parallels Desktop rather than suspending Windows.

**Import Windows and Your Data from Boot Camp into Parallels Desktop**

1. Set Parallels Desktop to use Boot Camp, as described in the steps above.
2. Right-click (Control-click) the Boot Camp version of Windows in the Parallels Virtual Machines list and choose Import Boot Camp.

  **Note:** Windows must be shut down.

3. Click Import.
4. Locate where you want to store Windows and your data, and then click Choose.

Windows and all your data are imported from Boot Camp. You can still use the original Boot Camp Windows installation, separately from Parallels Desktop.
Install or Import Windows

**Important:** The first time you start Windows after setting Parallels Desktop to work with Boot Camp, Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels Tools are installed, you’re prompted to restart Windows.

---

**Import from an Earlier Parallels Desktop or Other Virtualization Application**

With Parallels Desktop 8 for Mac you can use Windows that you set up using earlier versions of Parallels Desktop, as well as VMware Fusion, Microsoft Virtual PC, and Virtualbox:

1. Open Parallels Desktop (in the Applications folder) and choose **File > Open**.
2. Select the Windows data file you want to import, then click **Open**.
   - Parallels Desktop data files end with `.pvm`.
   - VMware files end with `.vmx`.
   - Virtual PC files end with `.vmc`.
   - VirtualBox files end with `.xml` or `.vbox`.
   
   You can also simply drag a Parallels `.pvm` file to the **Parallels Virtual Machines** list to add it to Parallels Desktop.
4. Choose **Virtual Machine > Install Parallels Tools** and follow the onscreen instructions.
Use Windows on Your Mac

Read this chapter to find out all about using Windows programs on your Mac. Learn how to get started using Windows programs, set how Windows programs work with Mac OS X, share applications, files, and folders between Mac OS X and Windows, connect devices, print, customize your keyboard, and more.

In This Chapter

Get Started .............................................................................................................. 35
Set How Windows Works with Mac OS X................................................................. 45
Mouse, Trackpad, and Keyboard ............................................................................. 73
Connect USB Devices .............................................................................................. 84
Connect Bluetooth Devices ...................................................................................... 87
Print from Windows .................................................................................................. 87
Use the Built-in iSight Camera or Another Webcam.................................................. 96
Show a Presentation on an External Monitor or Projector ......................................... 97
Protect Your Data..................................................................................................... 98
Connect to the Internet or a Network........................................................................ 103
Optimize Performance .............................................................................................. 108
Use Windows on Your iPad, iPhone, or iPod touch .................................................. 115
Save a Picture of the Screen .................................................................................... 116
Set the Appearance of the Parallels Desktop Dock Icon ........................................... 117

Get Started

In this section, learn how to start Windows, open a Windows program, install more Windows programs, and shut down or suspend Windows.
Start Windows

To use Windows programs on your Mac, Windows must be running.

The simplest way to start Windows is to open a Windows program (p. 37). If Windows isn't already running when you open a Windows program, it starts automatically in Coherence mode (p. 46).

**Important:** If Windows was previously shut down, you may need to enter your Windows password.

You can also start Windows by doing the following:

1. Open Parallels Desktop.
2. In the Parallels Virtual Machines window, click the Power Button next to Windows.
3. Click anywhere in the Windows window that appears.

Windows starts and you can begin using Windows programs alongside Mac OS X.
Open a Windows Program

Opening a Windows program is as easy as opening a Mac application. Here are several ways to open Windows programs:

- From the Windows Applications folder in the Dock
- From the Windows Start menu
- From the Mac OS X Finder
- From the Dock
- Using Spotlight searching
- Using Launchpad (if you are using Mac OS X Lion or later)

**Note:** All Windows program icons can be easily identified by the Parallels Desktop symbol in the lower-right corner of the icon.

Windows Applications Folder

If you opted to use Windows "Like a Mac" when you first installed Windows, a **Windows Applications** folder is in the Mac OS X Dock.

This folder contains all your Windows programs. As you install more programs, they are automatically added.
To open a Windows program using the Windows Applications folder:

- Click the folder, and then choose a program.

To add the Windows applications folder to the Dock:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Options and then click Applications.

3. Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

Windows Start Menu

To open a Windows program from the Start menu:

1. Click the Parallels icon in the menu bar and choose Windows Start Menu.
Use Windows on Your Mac

**Note:** You can also Command-click or Right-click the Parallels icon.

2. Click the program you want.

**Mac OS X Finder**

You can also open a program by double-clicking its icon in the Finder.

To find Windows programs in the Finder:

- Double-click the Windows volume on the desktop, and then open the Program Files folder.

**Note:** To show the Windows volume on the desktop, the Mac OS X Finder must be enabled to show connected servers. Click anywhere on the desktop and choose **Finder > Preferences**, and then select **Connected servers**.

You can make an alias for a Windows program on the Mac OS X desktop, then double-click it anytime to open the program.

To make an alias for a Windows program on the Mac OS X desktop:

- Select the program in the Finder and choose **File > Make Alias**. Then drag the alias icon to the desktop.

**Program Icon in the Dock**

When you open a Windows program, its icon appears in the Mac OS X Dock at the bottom of the screen. By default when you close the program, the icon disappears from the Dock. Keeping a program's icon in the Dock provides a quick way to open the program anytime.

To keep a Windows program's icon in the Dock, do one of the following:

- Right-click or Control-click the Windows program icon in the Dock and choose **Keep in Dock** from the shortcut menu.
- Drag the program's icon from the Finder to the Dock.

Now you can open the program again anytime by clicking the icon in the Dock.
Spotlight

You can search for and open Windows programs using Spotlight:

- Click the Spotlight icon in the upper-right corner of your screen, or press Command-Space bar on your keyboard. Then type the name of the program and select it from the list.

Launchpad

If you're using Mac OS X Lion or later, you can see a full screen display of all your Windows programs and Mac applications using Launchpad. Just click the Launchpad icon (looks like a rocket) in the Dock. You can then click any Mac OS X application to open it. To open a Windows program, click the Windows folder and then click the program you want.

**Note:** The Windows folder is available in Launchpad only if sharing Windows programs (p. 67) is enabled.

To move a Windows program from the Windows folder to a main Launchpad page, do one of the following:

- From Launchpad, click the folder containing your Windows programs and drag a program to the Launchpad icon in the Dock.
- Start the Windows program you want, right-click its icon in the Dock, and choose **Add to Launchpad**.

To remove a Windows program from Launchpad, start the program, right-click its icon in the Dock, and choose **Remove from Launchpad**.
Install Windows Programs

You install Windows programs on your Mac just as you would on a Windows PC. The two most common ways of installing programs are:

- Using a CD or DVD installation disc
- Downloading the program or installation file from the Internet or a network

Install a Program from a CD or DVD Installation Disc

1. Start Windows (p. 36).
2. Insert the installation disc.
3. In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then follow the onscreen instructions.

For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM (p. 189).

Install a Program from the Internet or a Network

- Download the program or installation file and follow the instructions from the program’s source.

In most cases, you can either run the installation file and follow the onscreen instructions, or simply open the downloaded program.

For more information about connecting to the Internet and networks, see Connect to the Internet or a Network (p. 103).
Shut Down or Suspend Windows

When you’re finished using Windows programs, you can leave Windows running in the background as you work with your Mac applications. Or you may want to stop Windows from running so more of your computer’s resources are available for your Mac applications. There are a few ways to stop Windows. You can:

- Suspend Windows
- Pause Windows
- Shut down Windows
- Stop Windows

Suspend Windows

Suspending Windows conveniently freezes all running Windows programs and settings in their current state.

Do one of the following:

- If you are using OS X Lion or Mountain Lion, quit Parallels Desktop.
- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Actions > Suspend.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Suspend.

The next time you start Windows or open a Windows program, you resume your progress from exactly where you left off.

When Windows is suspended, you can safely quit Parallels Desktop and resume your progress later.

Note: If you are using Mac OS X Lion or later and you shut down or restart your computer, or quit Parallels Desktop, Windows is automatically suspended. The next time you start up Parallels Desktop, you can resume working with Windows from where you left off. If your Windows is encrypted (p. 102), you will have to resume it manually.

Pause Windows

You can temporarily pause from using Windows and free your computer’s resources, such as RAM and processor cycles, to be used by your Mac applications by doing one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Actions > Pause.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Pause.
To resume using Windows after pausing it, do one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Actions > Resume**.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Resume**.

If you quit Parallels Desktop while Windows is paused, you’re prompted to either Suspend or Stop Windows first.

**Shut Down Windows**

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. All Windows programs close, giving you the opportunity to save your progress if necessary, and Windows stops running.

To shut down Windows, do one of the following.

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Actions > Shut Down**.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Shut Down**.

**Stop Windows**

To stop Windows and all open Windows programs immediately, do one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Actions > Stop**.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Stop**.

**Important:** When you stop Windows this way, none of your data or progress is saved.

**Window Menu**

If Windows is set to appear in a separate window, you can also choose any of the above options from the menu at the bottom of the window:
Startup and Shutdown Settings

Using Startup and Shutdown settings, you can:

• Set whether Windows starts automatically when you open Parallels Desktop
• Set which view mode (Coherence, Window, or Full Screen) Windows starts up in when you open it from the Parallels Virtual Machines list.
• Set what happens when you shut down Windows
• Set what happens when you close the Parallels Desktop window

To access Startup and Shutdown settings:

1. Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Options and select Startup and Shutdown.

Set Whether Windows Starts Automatically

Choose one of the following from the Start Automatically menu:

• Never: Windows never starts automatically.
• When window opens: Windows starts automatically when you open it from the Parallels Virtual Machines list.
• When Parallels Desktop starts: Windows starts automatically when you start Parallels Desktop.

Note: Windows starts when you open a Windows program (p. 37) regardless of this setting.
Set the Startup View

This setting affects the Windows view mode only when you open Windows from the Parallels Virtual Machines list. If you start Windows by opening a Windows program, it always starts in Coherence view.

- From the Startup View menu, choose Coherence, Window, Full Screen, Modality or Same as last time.

Set What Happens When You Shut Down Windows

Choose one of the following from the On Shutdown menu:

- **Keep window open**: If Windows is set to appear in a separate window, the window stays open when you stop or shut down Windows.
- **Close window**: If Windows is set to appear in a separate window, the window closes when you stop or shut down Windows.
- **Quit Parallels Desktop**: Parallels Desktop quits when you stop or shut down Windows.

Set What Happens When You Close the Parallels Desktop Window

These settings affect what happens only when Windows is set to appear in a separate window.

From the On Window Close menu, choose Suspend, Force to stop, or Ask me what to do.

Set How Windows Works with Mac OS X

Parallels Desktop 8 for Mac allows you to work seamlessly between Windows and Mac OS X. For example, you can cut and paste text, and share files, between the two.

There are a number of ways that you can set the level of integration between Windows and Mac OS X. For example, you may want your Windows programs to behave just like Mac applications, appearing side-by-side with them on the Mac desktop. Or you may wish to keep the Windows desktop and programs in a separate window.

Read on to learn more about setting how Windows works together with Mac OS X.
Merge Windows and Mac OS X

You can set Windows and Mac OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, Windows programs appear on the Mac desktop next to your Mac applications, and documents from Windows programs and Mac applications are stored in the same folders.

If you opted to use Windows "Like a Mac" when you first installed Windows, Parallels Desktop is already set to Coherence mode.

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

- Click the Coherence icon in the top right corner of the virtual machine window.
• Choose View > Enter Coherence.
• Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

• Press Control-Command-F to exit Full Screen. Then click View > Enter Coherence.
• Move the pointer to the top of the screen until the OS X menu bar appears and click View > Exit Full Screen. Then open the View menu once again and click Enter Coherence. If you're using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 54), press Control-Option (Alt) to display the Mac menu bar.
• If the Parallels hot corners (p. 54) are active, move the pointer to the upper-left corner of the screen until the corner peels back and click Exit Full Screen.

Then choose View > Enter Coherence.

**Note:** To enable the Coherence view mode, Parallels Tools must be installed (p. 204). In most cases, Parallels Tools are installed by default.

**Parallels Menu**

When in Coherence mode, the Parallels menu appears in the menu bar at the top of the screen.
Use Windows on Your Mac

Use the menu for these common functions:

- **Click** the Parallels icon [□] to open a basic menu that provides the following items:
  - **Windows Start Menu**: Access the Windows Start menu.
  - **Devices**: Manage hardware devices like printers and DVD drives.
  - **Exit Coherence**: Switch to Window mode
  - **Request Support**: Fill out a problem report and request support from Parallels Desktop.
  - **Parallels Desktop Help**: Access onscreen help.
  - **Quit**: Quit Parallels Desktop.
- **Right-click** the icon to open the Windows start menu.
- **Click** the Parallels icon [□], and press and hold the Option (Alt) key to open an extended menu. The extended menu includes additional options, including Report a Problem, Configure, Preferences, and many others.

**Important:** When in Coherence mode, to quit Parallels Desktop, click the Parallels icon [□] in the menu bar and choose Quit Parallels Desktop.

**Windows System Tray**

When Parallels Desktop is in Coherence mode, the Windows system tray icons are in the Mac OS X menu bar at the top of the screen.

![Windows System Tray](image)

You can use the system tray icons just as you would from the Windows Desktop.

**Move Windows Programs Between Desktops (Spaces)**

When Windows is working in Coherence, you can easily move windows of guest OS programs between Mac OS X desktops (spaces).

- **Click** the title bar of the window you want to move and while holding down the mouse button, press Control-# (# is the number of the desktop (space) you want to move the window to).
Adjust Coherence Settings

You can customize how Windows appears and behaves when in Coherence mode.

To customize Coherence mode:

3  Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure > Options.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Configure, and then click Options.

4  Click Coherence.
Select or deselect any of the following:

- **Use Crystal Mode**: Deselect to disable Crystal mode. With Crystal mode disabled, the Parallels Desktop menu bar becomes visible, and the level of integration between Mac OS X and Windows is reduced.

- **Show Windows notification area in menu bar**: Select to display the Windows system tray icons in the Mac OS X menu bar.

- **Allow applications to switch to full screen**: Some programs, most notably 3D games, work best when running at full screen. Select this option to allow such programs to take over the full screen when you open them while in **Coherence** mode.

- **Disable Windows Aero**: The Windows Aero theme includes elements such as translucent title bars and animations. Select this option to disable the Aero theme, for better performance.

### Set Windows to Appear in a Single Window

You can set the Windows and programs to appear together in their own window. If you opted to use Windows "Like a PC" when you first installed Windows, Parallels Desktop is already set to Window mode.
To switch to Window mode from Coherence mode, do one of the following:

- Click the Parallels icon in the menu bar, then choose Exit Coherence.
- If the Parallels Desktop menus are available in the Mac menu bar, click View > Exit Coherence.

To switch to Window mode from Full Screen mode, do one of the following:

- Press Command-Control-F.
- Move the pointer to the top of the screen until the OS X menu bar appears and click View > Exit Full Screen. If you’re using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 54), press Control-Option (Alt) to display the Mac menu bar.

Status Bar

When using Parallels Desktop in Window mode, the status bar at the bottom of the window shows clickable icons. The icons are shortcuts that let you control various functions. Most of the icons let you connect and disconnect hardware devices to and from Windows.

![Status Bar](image)

**Note:** If you don’t see the status bar, click the triangle next to the gear icon.

The following devices have the icons on the status bar:

- Keyboard
- Floppy disk drive
- CD/DVD drive
- Hard disk
- Network adapter
- Sound card
- USB controller
- Shared folders
- Serial port
- Parallel port
Use Windows on Your Mac

If the icon appears in the status bar, Parallels Tools are installed.

To connect or disconnect a device, such as the DVD drive, from Windows, click the device icon to display its shortcut menu and select the command.

You can also connect images of discs to Windows as if they were physical DVDs, CDs, or floppy disks. To do so, drag the image file over the CD/DVD-ROM drive or floppy disk icon on the status bar.

Hide/Show Status Bar

If you don’t need the status bar while working with Windows, you can hide it (click View > Hide Status Bar) and make visible again when necessary (click View > Show Status Bar).

Adjust Window Mode Settings

You can customize how Parallels Desktop appears and behaves when in Window mode.

Set Whether Windows Programs Show in the Dock:

You can choose whether or not to show icons for Windows programs in the Mac OS X Dock when in Window mode. If you prefer to work with programs by manipulating them on the Windows desktop, you may not want to be distracted by seeing them in the Dock alongside your Mac OS X application icons.

6 Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

7 Click Options and then click Applications.

8 To show Windows program icons in the Dock when in Window mode, deselect Show Dock icons in Coherence only.
Monitoring Windows in a Scalable Window

You can set Windows to appear in a window that can be resized to any size so that the content scales in size with the window. This is called Modality mode. Modality mode can be useful if you want to monitor programs and other tasks running in Windows as you work in Mac OS X.

To switch to Modality mode:

• From Window mode, choose View > Modality.

For more information on Modality mode, see the Modality mode settings topic (p. 164).

Set Windows to Take Up the Whole Screen

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a Windows PC. In Full Screen mode, Mac OS X and all of the Parallels Desktop controls are hidden.

To switch to Full Screen mode, do one of the following:

• From Coherence mode, click the Parallels icon in the menu bar, then choose Exit Coherence. Then click the View menu and select Enter Full Screen.

• From Window mode, choose View > Enter Full Screen or click the Full Screen icon in the top right corner of the virtual machine window.

To exit Full Screen mode, do one of the following:

• Press Command-Control-F.

• Move the pointer to the top of the screen until the OS X menu bar appears and click View > Exit Full Screen. If you’re using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 54), press Control-Option (Alt) to display the Mac menu bar.

• If the Parallels hot corners (p. 54) are active, move the pointer to the upper-left corner of the screen until the corner peels back and click Exit Full Screen.
Use Windows on Your Mac

If you are using Mac OS X Lion and one of the screen corners is set to show the menu bar (p. 54), move the pointer to that corner and then click the Full Screen button in the top-right corner of the menu.

Adjust Full Screen Settings

You can customize how Windows appears and behaves when in Full Screen mode.

To access Full Screen settings:

1. Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure > Options.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure, and then click Options.

2. Click Full Screen.
3 In this **Full Screen** pane, you can adjust any of the settings listed below.

**Choose Which Full Screen Mode to Use**

By default, when you switch Windows to Full Screen, Windows is set to operate in the OS X native Full Screen mode. This means that it becomes displayed on a separate space and when you move the mouse pointer to the top or bottom of the screen, the OS X menu bar or Dock appears correspondingly.

If you don’t want the menu bar and Dock to appear (for example, when playing games or working with Windows applications in Full Screen), clear the **Use Mac OS X Full Screen** option. In this case, Windows will work in Full Screen designed by Parallels. In this mode, a separate space won’t be allocated for Windows and the OS X menu bar or Dock won’t appear when you move the mouse pointer to the top or bottom of the screen.

**Set Actions for Screen Corners**

Parallels active screen corners allow you to exit Full Screen, display the Mac OS X menu bar and Dock.

If you set Windows to operate in Full Screen designed by Parallels, Parallels active screen corners become enabled by default. If you prefer Windows to operate in the native OS X Full Screen but want to use Parallels active screen corners instead of Mac OS X hot corners, select **Active Screen Corners**.

To set which action is performed for a screen corner, select one of the following from the menu near that corner:

- **Exit Full Screen**: Moving the pointer to the corner until it peels back and then clicking **Exit Full Screen** switches the view to **Window mode** (p. 50).
- **Show menu bar**: Moving the pointer to the corner shows the Mac OS X menu bar.
- **Show Dock**: Moving the pointer to the corner shows the Mac OS X Dock.

**Note:** If you’re using Mac OS X Snow Leopard and active screen corners such as Expose or Screen Saver are set in Mac OS X preferences, those settings take precedence over Full Screen mode active screen corner settings. You must deactivate Mac OS X active screen corners to enable Full Screen mode active screen corners. See Mac Help for more information.

**Scale to fit screen**

Using the **Scale to fit screen** menu, you can configure how Windows is displayed when working in Full Screen:

- **Off.** If **Parallels Tools** (p. 152) are installed, Windows resolution matches that of the Mac. If **Parallels Tools** (p. 152) aren’t installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows has scroll bars.
• **Auto.** If Parallels Tools (p. 152) are installed, Windows resolution matches that of the Mac. If Parallels Tools (p. 152) aren’t installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.

• **Keep ratio:** No matter whether Parallels Tools (p. 152) are installed or not, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.

• **Stretch:** No matter whether Parallels Tools (p. 152) are installed or not, Windows resolution remains unchanged but Windows is stretched to occupy the whole screen.

**Set What Shows on Displays Connected to Your Mac**

If you have a second display connected to your Mac, by default when you switch to Full Screen mode, Windows is displayed on the primary display and Mac OS X on the secondary.

You can choose which display Windows is shown on by dragging its window to that display and then clicking the Full Screen icon.

To extend Windows across all your displays, select **Use all displays in full screen.**

**Note:** To prevent unauthorized changes to Full Screen settings, click the Lock icon at the bottom of the window. Once locked, an administrator’s password is required to make further changes.
About Using Windows 8 with Parallels Desktop

As you probably know, Windows 8 features two environments; the new Metro interface; and the classic Windows desktop interface, accessible by clicking Windows Explorer on the Start screen or clicking Start in the Charm Bar.

Metro Applications Run in Full Screen

On a Windows PC, Metro-style applications and the Start screen take up the full screen, rather than running in a separate window. So even when you’re using Windows 8 in Coherence mode (p. 46), Metro applications still use most of the screen.
When Windows 8 is in **Window mode** (p. 50), the Metro interface takes up the full window.

**Using the Edges and Corners of the Screen**

In Windows 8, you must click in the edges and corners of the screen to access various features. For example, to access the Charm Bar, which contains icons for accessing settings, searching, and more, you must move the pointer to the upper- or lower-right corner of the screen.
And to see thumbnails of all your open Metro-style applications, you move the mouse pointer to the upper- or lower-left corner until you see a thumbnail, then slide up or down. Click an application to make it active.

When you’re using Windows 8 in Window mode, it can be tricky to find the exact corner or edge of the screen with the mouse pointer. So Parallels Desktop 8 allows you to set the mouse pointer to "stick" to the edges of the screen (p. 174) when you move it slowly. To move past the edge, just move the mouse quickly. This feature, enabled by default, makes it easy to use Windows 8.
Set Windows to Look Like Mac OS X

If you aren’t used to working with Windows, you can make your Windows 7, Windows Vista and Windows XP look like Mac OS X. Windows icons, fonts, colors, and other elements take on a Mac-like appearance.

To set Windows to look like Mac OS X:

1. In Parallels Desktop, start Windows (p. 36).
2. Once Windows starts, do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose View > Use MacLook.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose View > Use MacLook.

To revert to a Windows appearance, repeat step 2 above to deselect Use MacLook.

Copy and Paste Between Mac OS X and Windows

Parallels Desktop allows you to copy and paste pictures, formatted text (italic, bold, or underlined, of various colors, fonts, and sizes) between Mac OS X applications and Windows programs.

If you opted to use Windows "Like a Mac" when you first installed Windows, copying and pasting between Mac OS X and Windows is already enabled.

To enable copying and pasting between Mac OS X and Windows:

3. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.
4. Click Options > Advanced.
5. Select Share Mac clipboard.
6. To preserve text formatting when copying and pasting text, select Preserve text formatting.

**Note:** To enable copying and pasting between Mac OS X and Windows, Parallels Tools (p. 204) must be installed. In most cases, Parallels Tools are installed by default. Copying and pasting between Mac OS X and Windows is unavailable if you isolate Mac OS X from Windows.
Set a Program to Open When You Insert a CD or DVD

You can set the Windows program of your choice to open when you insert a music CD, picture CD, video DVD, or a blank CD or DVD.

1. From the Mac OS X Finder, choose Apple menu > System Preferences.
2. Click CDs & DVDs.
3. From the disc type menu of your choice, choose Open other application.
4. Choose a Windows program from /username/Applications (Parallels)/Windows Applications.

When you insert a disc of the type you selected, the Windows program you chose automatically opens.

**Note:**
1. If you’re unable to set a Windows program to open when you insert a CD or DVD, be sure that sharing Mac OS X applications (p. 67) is enabled and that Mac OS X CD/DVD-ROM is not selected in CD/DVD Preferences (p. 189).
2. To enable a Windows program to open when you insert a CD or DVD, Parallels Tools must be installed (p. 204). In most cases, Parallels Tools are installed by default.

Share Items Between Mac OS X and Windows

Parallels Desktop allows you to easily access your Mac OS X files using Windows programs, and also to access Windows files using Mac OS X applications.

Read on to learn about all the ways you can share folders, files, and applications between Mac OS X and Windows.
Share Files and Folders

Parallels Desktop allows you to share folders between the Mac OS X and Windows file systems, so you can easily open Mac OS X files from Windows applications and Windows files from Mac OS X applications.

**Note:** These instructions apply to sharing folders between OS X and Linux as well.

Set Mac OS X and Windows to Use the Same Folders

You can set Mac OS X and Windows to use the same folders for things like music, documents, pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, it will be in the Documents folder whether you’re using a Mac OS X application or a Windows program.

**Note:** If you selected “Like a Mac” when you installed and set up Windows, Mac OS X and Windows are already set to use the same folders.

1. **Start Windows.** (p. 36)
2. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine** > **Configure**.
3. **Click Options** and select **Sharing**.
4. **Select Share Mac user folders with Windows.**
   Your Mac OS X Desktop, Documents, Pictures, Music, Movies, and Downloads folders are merged with the corresponding Windows folders, and the Mac OS X Trash is merged with the Windows Recycle Bin.
5. If you only want to map some of the folders, click **Configure** and select the folders you want.
   To map the Mac OS Trash to the Windows Recycle Bin, select **Merge Recycle Bin with Trash**.

Access a Mac OS X Folder or File from a Windows Program

With folder sharing enabled, you can navigate to any shared Mac OS X folder from within a Windows program. When you open a file (for example, by choosing *File > Open* in many programs), your shared Mac OS X folders appear as network shared directories labeled "psf."

**Note:** If you selected "Like a Mac" when you installed and set up Windows, the folders in your Mac OS X Home folder are already shared and accessible from Windows programs.

To enable Mac OS X folders for sharing with Windows programs:
1  **Start Windows.** (p. 36)

2  Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

3  Click **Options** and select **Sharing**.

![Sharing settings in Parallels Desktop](image-url)
4  Do one of the following:
   • To share just the folders in your Home folder, choose **Home folder only** from the **Shared Folders** menu.
   • To share all your Mac OS X folders, choose **All disks** from the **Shared Folders** menu.
   • To share any folder you want, click **Custom Folders** and click the add (+) button, then choose the folder you want to share. You can add more folders by clicking the add (+) button again.

Once you share a Mac OS X folder with Windows you can:
   • Disable the folder sharing by deselecting **On**.
   • Change the folder name that will be displayed in Windows by double-clicking the folder name in the **Name** column and typing another name.
   • Restrict writing to this folder by clicking **Read & Write** in the **Permissions** folder and choosing **Read only**. You will not be able to add items to the folder.

5  Click **OK**.

**Note:**
1. To enable folder sharing, the **Isolate Mac from Windows** option must be disabled in the **Security** pane of the **Configuration** dialog.
2. If you’re running Linux, shared folders are mounted to the /media/psf or /mnt/psf directory.
Show an Item from Windows in the Finder

If Windows is set to appear in a separate window or in full screen mode (p. 50), you can show an item from Windows in the Mac OS X Finder.

• In Windows, right-click (or Control-click) a file or folder and choose Show in Finder from the shortcut menu.

From the Finder you could, for example, apply a color label to an item, or easily drag it to another location in the Finder.

**Note:** You can only perform these actions with files stored in shared folders (p. 62).

Access a Windows Folder or File from a Mac OS X Application

By default, you can navigate to all your Windows folders and files from Mac OS X. Windows disks are mounted to /Volumes. At the same time, Windows appears as a hard disk mounted on the Mac OS X desktop.

• Double-click the icon to access Windows folders and files. You can also navigate to this disk from within Mac OS X applications.

**Note:** If the Windows disk icon doesn't appear on the Mac OS X desktop, from the Finder choose Apple menu > Preferences and click General, and then make sure that Connected servers is selected.
To unmount Windows from the desktop:

1. Start Windows. (p. 36)

2. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Then click Options and select Sharing.

   **Note:** If Windows is running in Window mode (p. 50), choose Configure from the Virtual Machine menu.

3. Deselect Mount virtual disks to Mac desktop.

   **Note:** The Windows disk disappears from the desktop and the Finder, but you can still access all of the Windows files and folders via the Windows PVM file and Terminal (/Volumes). By default, the PVM file is either in /Users/<Username>/Documents/Parallels/ or /Users/Shared. You can also find the PVM file by right-clicking Windows in the Parallels Virtual Machines list (or in the virtual machine window when Windows is shut down) and selecting Show in Finder. To access Windows files and folders, right-click the PVM file, select Show Package Contents from the context menu, and open the Windows Disks folder. To disable the ability to navigate to Windows files and folders, deselect Access Windows folders from Mac in step 3 above.
Share Applications and Programs

You can access Mac OS X applications from within Windows and you can access Windows programs from Mac OS X. For example, if you locate a file using the Open menu in a Windows program and decide you would rather open the file using a Mac OS X application, you can.

If you opted to use Windows "Like a Mac" when you first installed Windows, sharing applications is already enabled.

Enable Sharing Mac OS X Applications

When sharing Mac OS X applications is enabled, you can open Mac OS X Applications from within Windows or Windows programs.

If not, you can enable it at any time by doing the following:

1. Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Options and click Applications.

3. Select Share Mac applications with Windows.

Once sharing Mac OS X applications is enabled, you can do the tasks below.

Open a File from Windows in a Mac OS X Application

You can open a file in a Mac OS X application from Windows Explorer, from the Open dialog in most Windows programs, or from Windows Desktop if Windows is set to appear in a separate Window or at full screen (p. 50). You may want to do this if you don’t have a Windows program that can open the file.

• In Windows, right-click (or Control-click) a file and do one of the following:
  • Choose Open on Mac from the shortcut menu. The file opens in the default Mac OS X application for that file type.
  • Choose Open With from the shortcut menu, and then choose an application.

Note: You can only perform these actions with files stored in shared folders (p. 62).

Open a Mac Application from the Windows Start Menu

From the Windows Start menu, do one of the following:

• Choose All Programs > Parallels Shared Applications, and then choose an application.
Use Windows on Your Mac

- Type the name of the application you’re looking for in the search field, then choose the application from the list.

Enable Sharing Windows Programs

When sharing Windows programs is enabled, you can open Windows programs from the Mac OS X Finder. You can also choose to add a folder to the Dock containing all your Windows programs for easy access.

4 Do one of the following:
   - Click the Parallels icon  in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

5 Click Options and click Applications.

6 Select Share Windows applications with Mac.

Add a Windows Applications Folder to the Dock

1 Do one of the following:
   - Click the Parallels icon  in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2 Click Options and then click Applications.

3 Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

Force Quit Windows Programs

If your running Windows guest OS program doesn't respond and freezes, you can easily force quit it as you can do with any Mac OS X application. To force quit a Windows program, do one of the following:

- Right-click the icon of the Windows program available in the Dock, press Option (Alt), and choose Force Quit.
- Press Option + Command + Esc (Alt + Command + Esc), select the name of the Windows program you want to quit, and click Force Quit.

Note: To be able to force quit Windows guest OS programs, Parallels Tools must be installed (p. 204). If you selected Like a Mac when you first installed Windows, Parallels Tools should already be installed.
Set Files to Open in the Application or Program of Your Choice

You can set files of a particular type that you open from the Mac OS X Finder to open in the Windows program of your choice. For example, you could set files ending in `.txt` to always open in Windows Notepad.

You can also set files opened from Windows to always open in the Mac OS X application of your choice.

Set Mac OS X Files of a Particular Type to Open in a Windows Program

To open a Mac OS X file once with a Windows program:

1. Right-click (or Control-click) the file in the Finder and choose **Open With** from the shortcut menu.
2. Select a Windows program.
   - If you don’t see the program you want, click **Other** and choose a Windows program from `/username/Applications (Parallels)/Windows Applications`.

You can also open a Mac OS X file in a Windows program by dragging it to the program’s icon in the Dock.

To set files of a particular type to always open in a Windows program:

1. Right-click (or Control-click) a file and choose **Get Info** from the shortcut menu.
2. Click the triangle next to "Open with" to expand the section.
3. Choose a Windows program from the pop-up menu.
   - If you don’t see the program you want, choose **Other** and choose a Windows program from `/username/Applications (Parallels)/Windows Applications`.
4. Click **Change All**.

From this point on, double-clicking a file of this type (.txt in the example above) in the Mac OS X Finder opens the file in the Windows program. If Windows is shut down, suspended, or paused, double-clicking the file starts or resumes Windows in Coherence mode. When Windows starts up, the file opens in the Windows program.

Set Windows Files of a Particular Type to Open in a Mac OS X Application

To open a Windows file with a Mac OS X application only this time:

- Right-click (or Control-click) the file in Windows, choose **Open With** from the shortcut menu, and choose an application.

To set all files of a particular file type to open in a Mac OS X application:
1. Right-click (or Control-click) a file in Windows, choose **Open With** from the shortcut menu, and click **Choose default program**.

2. Select an application, choose **Always use the selected program to open this kind of file**, and click **OK**.

**Note:** To set files to open in the application or program of your choice, **Parallels Tools must be installed** (p. 204). In most cases, Parallels Tools are installed by default. Also, the **Isolate Mac from Windows** (p. 100) option must be disabled, and **Windows application sharing** (p. 67) must be enabled.
Setting Internet Links to Always Open in Mac OS X or Windows

By default, clicking a link (such as a web page URL) in Windows opens the default Windows program for that link type, and clicking a link in Mac OS X opens the default Mac OS X application.

You can set links of a particular type to always open in Mac OS X or in Windows. For example, you could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a Mac OS X application.

**Note:** To set Internet links to open in Mac OS X or Windows, Parallels Tools must be installed (p. 204). In most cases, Parallels Tools are installed by default.

To set Internet links to open in Mac OS X or Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine** > **Configure**.

2. Click **Options** and select **Applications**.

3. Click the menu for the type of link you want to set. If you don’t see the link type you want, click **More Applications**. The following types of links can be set:
   - **Web pages**: Web pages accessible through the HTTP and HTTPS protocols.
   - **E-mail**: Links in the mailto format that open a pre-addressed email.
   - **Newsgroups**: Links in the news. format that typically open a newsreader program.
   - **FTP**: File upload and download locations accessible through the FTP protocol.
   - **RSS**: Episodic content, such as blogs and podcasts.
   - **Remote access**: Locations accessible through the Telnet and Secure Shell (SSH) protocols.

4. Choose one of the following:
   - **Default**: The link opens in the application or program set as default in the operating system (Mac OS X or Windows) where you click the link.
   - **Open in Windows**: Links clicked in Mac OS X or Windows open in the default Windows program for that link type.
   - **Open in Mac**: Links clicked in Mac OS X or Windows open in the default Mac OS X application for that link type.
Open the Current Safari Page in Internet Explorer

Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in Mac OS X using Safari, you can quickly open the current page in Internet Explorer by doing the following:

1. In Safari, click the Open in IE button in the toolbar.

If Windows isn’t already open, it starts up and the page opens in Internet Explorer.

Share External Storage Devices and Volumes

When you connect an external storage device, such as a USB drive, to your Mac, you can access the contents from Mac OS X applications.

Using SmartMount, you can set Parallels Desktop to automatically mount storage devices and volumes to Windows. That way, you can access the contents from both Mac OS X and Windows.

With SmartMount enabled, these items are automatically mounted to Windows:

- **Removable drives**: External storage devices, such as USB hard disks and USB flash drives.
- **CD/DVD drives**: CD and DVD drives or CD/DVD images (files most commonly ending in `.dmg`, `.iso`, and `.img`).
- **Network folders**: Folders shared over the network.

To enable SmartMount:

5. **Start Windows.** (p. 36)

6. Do one of the following:

   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

7. Click Options and select Sharing.

8. Select **Map Mac volumes to Windows**.

When you connect a storage device or volume, it is mounted as a network drive. For example, a USB flash drive plugged in to your Mac will be accessible from both the `/Volumes` folder in Mac OS X and My Computer in Windows.

**Note:** Permissions for accessing the mounted device from Windows are the same as permission settings for the device in Mac OS X. For example, if you can read from and write to a USB flash drive in Mac OS X, you can also read from and write to it in Windows. One exception: Mac OS X can’t write to NTFS volumes, regardless of permissions.
Apply Mac OS X Parental Controls to Windows

If you have administrator rights in Mac OS X, you can use parental controls to prevent others with accounts on your Mac from using certain Windows programs or accessing certain web sites.

To apply parental control settings:

1. In Mac OS X, choose Apple menu > System Preferences and click Parental Controls.
2. Click the lock if it’s not unlocked, and then enter an administrator name and password.
3. Select the account that you want to restrict, click Enable Parental Controls, and set up the controls. If you want the user to be able to use some Windows programs, be sure to select Parallels Desktop in the list of allowed applications.

For more information on using parental controls, see Mac Help.

Mouse, Trackpad, and Keyboard

Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the way you want them to.

You can also use trackpad gestures or the optional Apple Remote to control Windows programs just as you can with Mac OS X applications.

Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows programs.
Use Windows on Your Mac

Set Your Mouse or Trackpad to Right(Middle)-Click

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking.

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click the mouse. You can change which key combination triggers a right-click.

You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse (included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current Apple desktop computers), you can set the mouse to allow right-clicking.

Most other mice are pre-configured for right-clicking.

Set the Trackpad for Right-Clicking.

1. Choose Apple menu > System Preferences and click Trackpad.
2. Select Secondary Tap.

Now you can tap the trackpad with two fingers to imitate a right-click.

Set an Apple Mighty Mouse for Right-Clicking

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Choose Secondary Button from the menu to the right of the mouse.

Now you can press the right side of the mouse to right-click.

Set an Apple Magic Mouse for Right-Clicking

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Select Secondary click.

Now you can press the right side of the mouse to right-click.

Set Which Key Combination Triggers a Right-Click or a Middle-Click

1. Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.
2. Click Shortcuts.
3. If necessary, click the lock icon and enter an administrator password.
4 Select **Mouse Shortcuts** in the sidebar.

5 Select **Secondary click** (for right-click) or **Middle click**.

6 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.

You can use any combination of the Control, Option (Alt), Shift, and Command keys.
Control Programs with Trackpad Gestures or the Apple Remote

You can use the Apple Remote to control some Windows programs. If you have an Apple portable computer, such as a Macbook, or if you have an Apple Magic Trackpad, you can use gestures, such as swiping left or right across the trackpad, to control some Windows programs.

**Note:** You can control some Windows programs using three-finger swipes only if you’re using Parallels Desktop with Mac OS X Snow Leopard. In OS X Lion and later, three-finger swipes are used by default to move between full-screen apps and spaces.

To use the Apple Remote, you must first enable it by doing the following:

1. **Start Windows** (p. 36).
2. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine** > **Configure**.
3. Click **Options**, and then click **Advanced**.
4. Select **Enable** next to **Apple Remote**.

The following table provides commands to control some of the more popular Windows programs.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard and Mouse Combination</th>
<th>Apple Remote</th>
<th>Touchpad Gesture</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scroll</td>
<td>Up, down, left, or right arrow</td>
<td>n/a</td>
<td>Swipe up, down, left, or right with two fingers</td>
</tr>
<tr>
<td><strong>Microsoft Power Point</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start slide show</td>
<td>F5</td>
<td>![Play button]</td>
<td>n/a</td>
</tr>
<tr>
<td>End slide show</td>
<td>Esc</td>
<td>![Menu button]</td>
<td>n/a</td>
</tr>
<tr>
<td>Perform the next animation or advance to the next slide</td>
<td>N, Enter, Page Down, Right Arrow, Down Arrow, Space (or click the mouse)</td>
<td>![Next button]</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Perform the previous animation or return to the previous slide</td>
<td>P, Page Up, Left Arrow, Up Arrow, Backspace</td>
<td>![Previous button]</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up /Ctrl+wheel down</td>
<td>n/a</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Microsoft Word/Excel</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up /Ctrl+wheel down</td>
<td>n/a</td>
<td>Pinch open/pinch close</td>
</tr>
</tbody>
</table>

Windows Media Player
<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start/pause playback</td>
<td>Space</td>
<td>n/a</td>
</tr>
<tr>
<td>Skip to the next song</td>
<td>Ctrl+F</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Play the previous song</td>
<td>Ctrl+B</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
</tbody>
</table>

**Media Player Classic (k-lite)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start playback/pause</td>
<td>Space</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
</tbody>
</table>

**Winamp**

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start playback/pause</td>
<td>X to start, C to pause</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume up</td>
<td>Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
</tbody>
</table>

**Microsoft Internet Explorer**

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page back</td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>n/a or Swipe right with three fingers</td>
</tr>
<tr>
<td>Page forward</td>
<td>Option+Right Arrow (Alt+Right Arrow)</td>
<td>n/a or Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/Ctrl+wheel down</td>
<td>n/a or Pinch open/pinch close</td>
</tr>
</tbody>
</table>

**Mozilla Firefox**

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page back</td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>n/a or Swipe right with three fingers</td>
</tr>
<tr>
<td>Page forward</td>
<td>Option+Right Arrow (Alt+Right Arrow)</td>
<td>n/a or Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl-wheee up/Ctrl-wheel down or Ctrl-&quot;+&quot;/Ctrl-&quot;-&quot;</td>
<td>n/a or Pinch open/pinch close</td>
</tr>
</tbody>
</table>

**Windows Picture and Fax Viewer**

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard/Trackpad/Touch</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next image</td>
<td>Right Arrow</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Previous image</td>
<td>Left Arrow</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>&quot;+&quot;/&quot;-&quot;</td>
<td>or Pinch open/pinch close</td>
</tr>
</tbody>
</table>
## Use Windows on Your Mac

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard Shortcut</th>
<th>Touchpad Action</th>
<th>Other Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate clockwise</td>
<td>Ctrl+K</td>
<td>n/a</td>
<td>Rotate right with two fingers</td>
</tr>
<tr>
<td>Rotate counterclockwise</td>
<td>Ctrl+L</td>
<td>n/a</td>
<td>Rotate left with two fingers</td>
</tr>
</tbody>
</table>
Customize Keyboard Shortcuts

Both Mac OS X and Windows provide extensive keyboard shortcuts. For example, in Mac OS X you can hold down the Command key and press Q (Command-Q) to quit the current application.

By default, Parallels Desktop maps common Mac OS X keyboard shortcut key combinations to the equivalent Windows key combinations. That way if you’re used to, for example, pressing Command-C to copy text in Mac OS X, you don’t have to switch to the Windows equivalent, Control-C.

You can also use and customize keyboard shortcuts for switching between Coherence, Full Screen, and Window view modes, and for showing and hiding Parallels Desktop.

Customize Keyboard Shortcuts

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.

2. Click Shortcuts

3. Select Windows from the Virtual Machines list in the sidebar.

Or if you’re using another operating system with Parallels Desktop and you want to customize keyboard shortcuts for it, select it in the sidebar.
When you're using a Windows application, pressing a key combination in the From column above triggers the key combination in the To column.

4  If the lock icon is locked, click it and enter an administrator password.

5  Do one of the following:

- To edit an existing key combination, double-click the key combination or select it and click the Edit button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.
Use Windows on Your Mac

- To delete a key combination, select it and click the Remove button.
- To add a new key combination, click the Add button.

If you’re using multiple operating systems with Parallels Desktop, you can create keyboard profiles for each OS (p. 148).

**Note:**
1. Some key combinations can’t be edited or deleted.
2. There are Mac shortcuts that do not have similar shortcuts in Windows. For example, you can use the F11 key or Fn+F11 combination to see your Mac OS desktop with Expose, but in Windows there are no keys or key combinations that enable you to perform the same action, because there is no Expose in Windows.

Enable or Disable Mac OS X System Shortcuts

In Mac OS X the function keys on your keyboard (F1, F2, F3 and so on) control functions like activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. By default, when a Windows application is active the function keys and other Mac system shortcut key combinations (such as pressing Cmd + Tab to switch between open applications) continue to activate Mac OS X functions.

To set whether function keys and OS X system shortcut key combinations activate functions in OS X or Windows:

6. Click System Shortcuts in the sidebar.
7. Select one of the following from the Send system shortcuts menu:
   - **Always:** When Windows or Windows applications are active, function keys and other system shortcuts always trigger functions in Windows.
   - **Never:** Function keys and other system shortcuts always trigger functions in OS X.
   - **On Condition:** If you’re working with Windows, system shortcuts that don’t function in Windows (for example, Control-Up Arrow button to display Mission Control) trigger functions in OS X. If you’re using OS X as a guest OS and a guest OS or its application is active, system shortcuts that are typical only to OS X trigger functions in the guest version of OS X.
Create New Keyboard Shortcuts

You can press certain key combinations, called keyboard shortcuts, to quickly trigger various actions in Parallels Desktop. For example, you can press Command-Control-F to switch Windows to Full Screen mode. You can use existing keyboard shortcuts (you can see them in the Parallels Desktop > Preferences > Shortcuts > Application Shortcuts pane), and you can also create your own.

To create a new keyboard shortcut:

1. Make a note of the name for the command you want a shortcut for as it appears in a menu in Parallels Desktop. For example, if you want to create a new shortcut for switching to Full Screen mode, you can see by opening the View menu in Parallels Desktop that the name of the menu item is Enter Full Screen:

2. In Mac OS X, choose Apple Menu > System Preferences.

3. In System Preferences, click Keyboard and click Keyboard Shortcuts.

4. Select Application Shortcuts in the sidebar and click the Add button.

5. If you want a new shortcut to work only for Parallels Desktop, choose Parallels Desktop from the Application menu. If you leave All Applications selected, the shortcut will work for any application that has the same command name and is currently active.

6. Enter the menu item name from Step 1.

    **Important:** You must enter the command name exactly as it appears in the Parallels Desktop menu or your new shortcut won’t work.

7. In the Keyboard Shortcut field, press the key combination that you want to trigger the action.

**Notes:**

1. You must create separate shortcuts for commands that change in the menu depending on the state of Parallels Desktop, such as Enter Full Screen and Exit Full Screen.

2. You can also create keyboard shortcuts to work with Windows (and other guest OS) applications running in Coherence mode (p. 46). To find out what a command for a Windows application is called, launch the application, switch Windows to Coherence mode, and check the application menus as described in Step 1 above.
See and Change Windows Input Language In OS X

While you’re working with Windows or any Windows applications, Parallels Desktop shows the input language set in Windows in OS X menu bar. You may find it useful while working with Windows in Coherence (p. 46) when the guest OS desktop is hidden.

As soon as you switch to Mac, the input language in OS X menu bar changes back to the language that was set before you started working with Windows.

To make this feature work properly, Parallels Tools (p. 155) must be installed and the same input languages must be available in Windows and OS X. To learn how to add input languages, please refer to the help resources for these operating systems.

Change Windows Input Language From OS X Menu Bar

To change the Windows input language from the OS X menu bar:

1. Click Windows or your Windows application to make it active.
2. Choose the language you need from the Input menu available in the OS X menu bar.

Note: The language you're selecting from the Input menu must be also available in Windows. To learn how to add a language to the list of input sources in Windows, please refer to the Windows help resources.

If the Input menu isn't available in OS X menu bar, you can set it to show by doing the following:

1. In Mac OS X, choose Apple menu > System Preferences and click Language & Text.
2. Click Input Sources.
3. Select the language or languages you want to use from the sidebar.
4. Select Show input menu in menu bar.
Connect USB Devices

Many USB devices, such as mice and printers, are available by default to both Windows and Mac OS X when you connect them to your Mac.

Some USB devices, such as an Apple iPhone, can only be used with either Mac OS X applications or Windows programs, but not both at the same time. When you connect such a device, you can choose whether you want to use it with Mac OS X or Windows.

To connect a USB device:

1. Connect the device to a USB port on your Mac.
2. If Windows is running and the device can’t be used with both Windows and Mac OS X at the same time, you’re prompted to choose which one you want to use it with. To use the device with Mac OS X applications, click the Mac icon. To use it with Windows programs, click the Windows screen.
Use Windows on Your Mac

You can connect up to 15 USB 2.0 and 32 USB 1.1 devices to your Mac and use them with Windows. You can connect and use up to 30 USB printers.

**Important:** To be able to use a USB device with Windows programs, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer’s website.

You can also set what happens when any new USB device is connected and set particular USB devices to always be used with either Mac OS X or Windows (p. 85).

**Connect a Common Access Card reader**

A Common Access Card (CAC) reader can work simultaneously in Mac OS X and Windows.

1. Connect the CAC reader to your Mac.
2. When you’re prompted to choose Windows or the Mac, click the Windows screen. The CAC reader becomes available to both Windows and Mac OS X.

**Adjust USB Settings**

In the **USB** pane of Parallels Desktop Preferences, you can:

- Set what happens when you connect any new USB device to your Mac.
- Set a particular USB device to always be used with either Mac OS X or Windows.
To access USB Settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.

2. Click USB.

Set What Happens When You Connect a New USB Device to Your Mac

Choose one of the following:

- **Connect it to my Mac.** New USB devices are automatically available for use with Mac OS X applications.
- **Connect it to the active virtual machine.** New USB devices are automatically available for use with Windows programs. If Windows isn't running, the USB device is connected to Mac OS X.
- **Ask me what to do.** Each time you connect a USB device, you’re prompted to choose whether you want to connect the device to Windows or the Mac.

Set a Particular USB Device to Always Be Used With Mac OS X or Windows

If you know you always want a particular USB device to be available to either Mac OS X or Windows, you can set it to do so by following the instructions below. The device must already have been connected to your Mac at least once.

1. Click the Add (+) button towards the bottom of the window.
2. Select the device from the list.
3. Double-click the word (either Computer or some form of Windows) in the Connect To column. The word becomes a pop-up menu.
4. Do one of the following:
   - To set the device to always be available to Mac OS X applications, choose Computer from the menu.
   - To set the device to always be available to Windows programs, choose Windows from the menu.

To remove an existing assignment, so that the device no longer automatically connects to Mac OS X or Windows, select the device in the USB Device column and click the Remove (-) button.

**Important:** To be able to use a USB device with Windows programs, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer’s website.
Connect Bluetooth Devices

Parallels Desktop lets you connect Bluetooth devices directly to Windows.

Before connecting a Bluetooth device, Bluetooth must be enabled.

To enable Bluetooth:

5 If Bluetooth is turned off in Mac OS X, turn it on. Choose Apple menu > System Preferences and click Bluetooth. Then select On.

6 In Parallels Desktop, start Windows (p. 36) if it isn’t already started.

7 Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

8 Click Hardware and click USB & Bluetooth in the sidebar.

9 Select Bluetooth devices.

Once you’ve enabled Bluetooth, you can pair Bluetooth devices with your computer and they’ll work with both Windows and Mac OS X. For instructions on pairing a Bluetooth device with your computer, see the documentation that came with the device.

In Windows 7, you can send a file to a paired Bluetooth device that’s capable of receiving files by right-clicking the file and choosing Send to > Bluetooth.

Besides Windows, you can connect Bluetooth devices to any guest operating systems (Linux or Mac OS X) that support USB Bluetooth adapters.

Print from Windows

By default, Windows is set to use the same printer that you use with Mac OS X. Simply print from a Windows program the way you normally would.

You can also set Windows to use a different printer. There are a few ways to set up printing in Windows:

• Share any of the printers connected to your Mac.
• Connect to a local printer using Apple Bonjour.
• Connect to a network printer.
• Connect a USB printer directly to Windows.
Share a Printer Connected to Your Mac

If you selected "Like a Mac" when you installed and set up Windows, you can use any printer connected to your Mac with Windows programs. (If you selected "Like a PC", see below for instructions on sharing printers connected to your Mac.)

To print a document from a Windows program:

- Open the document and simply print it the way you normally would (for example, choose **File > Print**).

In the print window, you can choose any printer that’s connected to your Mac.

Set a New Default Printer

By default, Windows is set to use the same default printer as your Mac. To use a different default printer for Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. Click **Hardware** and select **Print**.

   **Note:** The **Print** pane is available for Windows 2000 and newer versions of Windows.

3. Deselect **Synchronize default printer**.

   Now you can set a new default printer in Windows the way you normally would.

Share Printers Connected to Your Mac

If you didn’t select "Like a Mac" when you installed and set up Windows, you can set printers connected to your Mac to be available to Windows programs by doing the following:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. Click **Hardware** and select **Print**.

3. Select **Add all Mac printers**.
Add a printer in Linux

The procedure of adding a printer in a Linux guest operating system depends on the Linux distribution. In this example, we describe how to add a printer to a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to add a printer to a Linux virtual machine:

1. Start the Linux virtual machine and log in when the guest operating system boots up.
   
   **Note:** You must log in as root or acquire root privileges after successful login. If you don't do that, you will be required to enter the root password when starting the `system-config-printer` administration tool in the next step.

2. Start the `system-config-printer` administration tool by doing one of the following:
   - Click **System > Administration > Printing**; or
   - Start the Terminal and enter the following command:

```
system-config-printer
```

3. In the displayed window, click **New Printer**.

4. In the next window, you must type a printer name. Under this name the printer will be displayed in your Linux guest operating system. You can also enter the printer description and location. When ready, click **Forward**.

5. Now you have to specify how your Mac printer will be shared with the virtual machine. As the printer is connected to the virtual machine printer port, select **LPT #1** (or another port to which the printer is connected) and click **Forward**.

6. Then specify the printer manufacturer and model. No matter what printer you have, choose either HP Color LaserJet 8500 PS or Apple Color LW 12/660 PS. When ready, click **Forward**.

7. Click **Apply** to finish setting up the printer.

Now the printer is properly configured and you can use it to print documents from your Linux virtual machine.
Set Up a Printer Using Bonjour

If you have more than one Mac connected to your home network, you can use Apple Bonjour for Windows to share any printer connected to any of them.

To see the list of all Windows operating systems supported by Bonjour, please refer to http://support.apple.com/kb/dl999.

**Important:** To share a Mac printer with Windows via Apple Bonjour, Windows must be configured to work in the Bridged networking mode.

To set up a printer via Bonjour:

1. Be sure the printer you want to use is set to be shared on your Mac. To share a printer, in Mac OS X choose **Apple menu > System Preferences** and click **Print & Fax**. Then select the printer and select **Share this printer**.

2. Open Parallels Desktop and start Windows.


4. In Windows, start the Bonjour installation by launching the `BonjourPSSetup.exe` file from the folder in which it was downloaded.

5. Follow the onscreen instructions to install Bonjour for Windows.

6. Start the Bonjour Printer wizard either by double-clicking its icon on the desktop or by selecting **Start -> All Programs -> Bonjour Print Services -> Bonjour Printer Wizard**.

7. In the **Browse for Bonjour Printers** window, select the printer that you want to use and click **Next**.

8. If the next window you see is **Completing the Bonjour Printer Wizard**, then the driver required by this printer is available in the Windows driver library and the printer has been successfully configured. Click **Finish** and you can start using the newly added printer to print documents from Windows programs.

However, if the next window you see is **Install Bonjour Printer**, you must choose the printer manufacturer and model.
If the required printer model is not listed, you can do one of the following:

- Install the printer drivers in Windows. Then click Have Disk button in the Install Bonjour Printer window and specify the path to the .inf file located in the folder where you installed the printer drivers.

- In the Install Bonjour Printer window, select Generic in the Manufacturer list and Generic/Postscript in the Model list.

Click Next.

In the Completing the Bonjour Printer Wizard window, click Finish. You can start using the newly added printer to print documents from Windows programs.
Set Up a Network Printer

You can install a network printer directly into Windows.

Before installing a network printer in Windows, make sure that:

- Your Mac can access the Internet.
- Windows is configured to work in either the Shared networking mode (p. 103) or Bridged networking mode and can access the Internet too.
- The user account in Windows has permission to access the network printer.
- You know the printer IP address.

After that, you can log in to Windows and install a network printer.

In Windows

Before adding a network printer in Windows, download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer documentation.

To add a network printer in Windows 7 or Windows Vista:

1. Open the Windows Start menu and select Control Panel.
2. In the Control Panel window, select Hardware and Sound and click Add a printer in the Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens.
3. In the first window, click Add a network, wireless or Bluetooth printer.
4. In the next window, click The printer that I want isn't listed.
5. In the Find a printer by name or TCP/IP address window, select Add a printer using a TCP/IP address or hostname and click Next.
6. In the Type a printer hostname or IP address window, do the following:
   1. Select TCP/IP Device from the Device type menu.
   2. Specify the printer IP address in the Hostname or IP address field.
   3. Clear the Query the printer and automatically select the driver to use option if it is selected.
   4. When ready, click Next.
If prompted to specify additional port information, choose Standard, select Generic Network Card from the list, and click Next.

In the Install Printer Software window, specify the manufacturer and model of the network printer.

If the required printer model is not listed, click Have Disk button and specify the path to the .inf file located in the folder where you installed the printer driver.

When ready, click Next.

Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.

To add a network printer in Windows XP:

1. Open the Windows Start menu and select Control Panel.
2. In the Control Panel window, double-click the Printers and Faxes item.
3. Click the Add a printer link to open the Add Printer wizard.
4. In the Welcome to the Add Printer Wizard window, click Next.
5. In the Local or Network Printer window, select Local printer attached to this computer and clear the Automatically detect and install my Plug and Play printer option if it is also selected. When ready, click Next.
6. In the Select a Printer Port window, select Create a new port and specify Standard TCP/IP Port as the port type. When ready, click Next.
7. In the Welcome to the Add Standard TCP/IP Printer Port Wizard window, click Next.
8. In the Add Port window, specify the network printer IP address and click Next.
9. If prompted to specify additional port information, choose Standard, select Generic Network Card from the list, and click Next.
10. In the Completing the Add Standard TCP/IP Printer Port Wizard window, click Finish.
11. In the Install Printer Software window, specify the manufacturer and model of the network printer.

If the required printer model is not listed, click Have Disk button and specify the path to the .inf file located in the folder where you installed the printer driver.

When ready, click Next.

Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.
In Linux

The procedure of setting up a network printer in a Linux or FreeBSD guest operating system depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set up a network printer in a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to set up a network printer in a Linux or FreeBSD virtual machine.

Note: For more detailed information, refer to the CUPS documentation.

To set up a network printer:

1. Start the virtual machine.
2. Make sure the following components are installed in the guest operating system:
   - Common UNIX Printing System (CUPS). Installation instructions can be found at CUPS site;
   - Samba service. Installation instructions can be found at Samba site; and
   - A Web browser, since we consider controlling CUPS via web interface.

   Note: To set up a network printer, you should have root privileges.

3. Download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer’s documentation.

4. Start Common UNIX Printing System. In the Terminal, type the command:
   
   /etc/init.d/cups start

5. Start a web browser and type either the IP address of your virtual machine or http://127.0.0.1:631.

6. Click the Add Printer button.

7. In the Add New Printer window, specify a printer name. Under this name the printer will be displayed in the guest operating system. You can also enter the printer description and location. When ready, click Forward.

8. In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click Continue.

9. In the Device URI for <Printer Name> window, specify the printer IP address in the following format:
   
   socket://<printer IP address>

   When ready, click Continue.

10. In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your printer and click Continue.

11. In the Model/Driver for <Printer Name> window, select the model of your printer and click Add Printer.

12. Enter the root password when prompted.
CUPS performs the installation. If the installation is successful, the "Printer <name> has been configured successfully" message is displayed. Now you can use this printer to print documents from the virtual machine.

**Set Up a USB Printer**

You can connect a USB printer directly to Windows. In this case, the printer isn’t available to Mac OS X. If you want to use the printer to print both from Mac OS X and from Windows, see [Share a Mac Printer](p. 88).

To connect a USB printer directly to Windows:

1. In Parallels Desktop, start Windows.
2. When Windows starts, install the printer driver. For detailed information on how to do that, refer to the printer manufacturer’s documentation. Typically you can find drivers on the manufacture’s website.
3. Do one of the following:
   • If the USB printer is already connected to your Mac:
     • If Windows is in Coherence, click the Parallels icon in the menu bar, choose **Devices > USB** and select this printer from the list.
     • If Windows is working in a separate window, click the USB controller icon in the Windows status bar and select this printer from the list.
   • If the USB printer is not connected to your Mac, connect it. In the **New USB device detected** window, connect the printer to Windows.
4. In Windows, follow the **Add New Hardware** wizard instructions.
Use the Built-in iSight Camera or Another Webcam

If your Mac or display has a built-in iSight camera, or if you connect a compatible external webcam, by default you can use it with Windows.

To use a built-in iSight or external camera with Windows:

- Simply open a Windows program that uses a camera, you should be able to select the iSight or external camera for use with the program.

**Note:** If you are running a guest OS other than Windows XP Service Pack 2 or later, Windows Vista, or Windows 7, be sure you have USB video device class (UVC) drivers installed.

Disable Camera Sharing

If you don’t want Windows programs to be able use connected webcams or the built-in iSight camera, you can disable camera sharing by doing the following:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.
2. Click **Hardware** and click **USB & Bluetooth**.
3. Deselect **Web cameras**.
Show a Presentation on an External Monitor or Projector

You can easily connect your Mac to an external monitor or projector and show a presentation from a Windows application, with little configuration needed.

To do so:

1. **Start Windows** (p. 36) if it isn’t already running.
2. Connect your Mac to the external monitor or projector as you normally would. A message appears asking if you’re going to show a presentation.
3 If you want to show the exact contents of your computer’s display on the external display or projector, select **Use Mirroring**.

If you don’t select **Use Mirroring**, certain applications, such as Microsoft Powerpoint, may show a presenter view on your computer while showing only the presentation on the external display or projector.

4 Click **Yes**. Windows switches to Presentation mode, displayed at full screen on both your computer’s display and external display or projector. After that, you can start showing your presentation.

**Note:** To learn how to choose on which display the presentation is shown, please refer to Help of the application you’re using for presentations.

**Important!** While you’re working in Presentation mode, changing display settings in Windows may cause the presentation to malfunction.

### Protect Your Data

You probably have important documents, photos, and more on your Mac. When running Windows on your Mac, it’s especially important to protect your data from viruses and unauthorized use. Read this section to learn how.
Protect Your Data from Viruses

Parallels Desktop offers complementary trial subscriptions to Norton and Kaspersky antivirus software for both Mac OS X and Windows.

To take advantage of these offers, you download and install either Norton Internet Security or Kaspersky Security for Windows and for the Mac. When the trial periods expire, you can purchase permanent activation keys.

Download and Install Antivirus Protection for Windows

1. Open Parallels Desktop and start Windows.
2. If Parallels Desktop is set to Coherence mode, click the Parallels icon in the menu bar and choose Exit Coherence.
4. Select which antivirus protection you want to install, either Norton Internet Security or Kaspersky Security, click Install, and follow the onscreen instructions.

Note: To install antivirus protection for Windows, Parallels Tools must be installed (p. 204). In most cases, Parallels Tools are installed by default.

Remove Antivirus Protection from Windows

To remove Norton Internet Security or Kaspersky Security, remove it the same way you’d remove any other Windows application. See Windows Help and Support for more information.

Download and Install Antivirus Protection for Mac

1. If Parallels Desktop is set to Coherence mode, click the Parallels icon in the menu bar and choose Exit Coherence.
2. Choose File > Install Antivirus for Mac.
3. Select which antivirus protection you want to install, either Norton Internet Security or Kaspersky Security, click Install, and follow the onscreen instructions.

Remove Antivirus Protection for Mac

Choose Uninstall Antivirus for Mac from the File menu and enter your administrator name and password.
Isolate Mac OS X from Windows

You can isolate Mac OS X from Windows, so that they no longer share folders, profiles, and applications, connected external devices are no longer automatically accessible by Windows, and you can no longer copy or move objects between Windows and Mac OS X. Isolating Mac OS X from Windows may provide a higher level of security by not allowing compromised items from one OS to come into contact with the other.

To isolate Mac OS X from Windows

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.
2. Click Options and select Security.
3. Select Isolate Mac from Windows.

Work in Windows Without Saving Changes

If you don’t want Windows to store the changes you make to it during the working session (for example, when testing some Windows programs that may damage Windows), you can start Windows in Safe Mode:

1. Open Parallels Desktop.
2. From the Parallels Virtual Machines list select Windows that you want to start in Safe Mode and click Virtual Machine > Safe Mode.

Set Windows to Always Start in Safe Mode

If you want Windows to always start in Safe Mode:

1. Open Parallels Desktop.
2. From the Parallels Virtual Machines list select Windows and click Virtual Machine > Configure > Options > Security.
3. Choose Ask me what to do from the Undo Disks menu and click OK.

Note: If you have the automatic compression of virtual disks (p. 111) enabled, it will become disabled after you enable Undo Disks.
Set Password Requirements

For added security, you can set Parallels Desktop to require an administrator password to perform certain functions.

1. Do one of the following:
   - Click the Parallels icon  in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Options and select Security.

3. Select one or more of the following to require a Mac OS X administrator password to perform the selected action:
   - Exit full screen mode: A password is required to exit full screen mode (p. 50).
   - Change virtual machine state: A password is required to start, stop, suspend, pause, or shut down (p. 42) Windows.
   - Manage snapshots: A password is required to create or delete a snapshot (p. 131), or revert to a snapshot.
Encrypt Windows to Protect It from Unauthorized Use

If you store any important data using Windows programs, it is highly recommended that you encrypt Windows to protect your data from any unauthorized use.

Encrypt Windows

To encrypt Windows (it must be shut down):

2. In the Security pane, click Turn On, specify a password, and click OK.

**Warning:** The specified password is very important. You must record it. Without this password, you can't start Windows.

Change Your Password

To change the password for an encrypted Windows (it must be shut down):

2. In the Security pane, click Change Password, specify a new password, and click OK.

Remove Encryption from Windows

To remove encryption from Windows (it must be shut down):

2. In the Security pane, click Turn Off.
Connect to the Internet or a Network

Parallels Desktop allows you to use three types of networking with Windows:

- **Shared Networking**: Windows programs share a network connection with Mac OS X. This is the default setting.
- **Bridged Ethernet**: Windows can use one of your Mac's network adapters. This makes Windows appear as a separate computer on the network.
- **Host-only networking**: Windows can access only your Mac.

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows programs have access to the same network and the Internet.

The Bridged Ethernet networking mode is more complex and you may need to contact your system administrator to set it up properly.

Read on for detailed information on these types of networking and how to configure them.

Share Network Settings Between Mac OS X and Windows

By default, Windows is set to share network settings with Mac OS X. Windows programs can access other computers on your local network and the Internet by using the IP address of your Mac. Windows does not have its own IP address on the network.

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows programs have access to the same network and the Internet.
Use Windows on Your Mac

You may wish to use Shared Network mode in the following cases:

• Your Mac accesses the Internet via a modem or another non-Ethernet device.
• You need to access the Internet from inside Windows but are concerned about security.
• You have problems with working in the Bridged Ethernet mode.

To configure Windows to use Shared Networking:

1. Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Connected and Shared Network options are selected.

   **Note:** In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows on your Mac. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base [http://kb.parallels.com/](http://kb.parallels.com/) available at the Parallels website.

### Apply Separate Network Settings to Windows

When operating in the Bridged Ethernet mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.

**Note:** The Bridged Ethernet networking mode is more complex than the Shared Networking mode and you may need to contact your system administrator to configure it properly.
To configure Windows to work in the Bridged Ethernet mode:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Connected option is selected.

4. Select the appropriate network adapter from the list. To connect the virtual machine’s adapter to the active network adapter of your Mac, choose Default Adapter.

   **Note:** In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

If you can't configure Windows to function in the Bridged Ethernet mode, consider using Shared Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

### Use Host-Only Network Settings

Parallels Desktop provides a closed network that is accessible only to Mac OS X and Windows. Mac OS X is connected to this network via the Parallels Host-Only Networking adapter automatically created on your Mac during the Parallels Desktop installation. The addresses for Windows are provided by the Parallels DHCP server.
To configure Windows to use Host-Only Networking:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Connected and Host-Only Network options are selected.

   Note: In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.
Use Wi-Fi with Windows

If your Mac is already connected to the Internet wirelessly, by default Windows is also set to access the Internet wirelessly, with no setup required.

If you change your network setup, you can reconfigure a Wi-Fi connection using the Bridged Ethernet mode. When operating in this mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.

To configure Windows to access the Internet through Wi-Fi:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Connected option is selected.

4. Choose AirPort from the list.

After you perform these steps, Windows is able to connect to the Internet through the AirPort adapter of your Mac.

If you can’t configure your virtual machine to function in the Bridged Ethernet mode, consider using Shared Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.
Connect Windows to a VLAN

If your Mac is a VLAN (virtual local area network) member, Parallels Desktop allows you to bridge Windows to this VLAN.

To bridge Windows to the VLAN, do one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

5 Click Hardware and then click Network.

6 Select Bridged Network > VLAN from the Type list and make sure the Connected option is enabled.

Windows is bridged to the selected VLAN.

Optimize Performance

If Windows isn’t working as speedily as you’d like, there are several simple ways you can optimize its performance. This section contains many helpful instructions for doing just that.

Read this section to find out how you can tune Windows for speed.
Set How Much Memory is Allocated to Windows

Parallels Desktop is set to allocate a certain amount of your Mac’s available RAM memory to Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause Windows programs to slow down because they’re running on top of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS X applications may run well but Windows programs might slow down.

To optimize the performance of both Windows and Mac OS X, set the memory allocated to Windows to be somewhere within the recommended range.

To set how much memory is allocated to Windows:

2. Choose Virtual Machine > Configure, and then click General.
3 Move the memory slider to somewhere within the recommended range, indicated by the graphic under the slider (see above).

If you use Windows programs that require lots of memory, like 3D or video production programs, it's best to set the memory allocation towards the high end of the range (move the slider to the right). If not, it's usually best to set it closer to the middle.

**Note:** No matter how much memory (RAM) your Mac has, the maximum amount of memory that can be assigned to Windows is 16 GB.

If you change this setting and then you don't like how Windows is performing, then try a different setting.

**Note:** If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Optimization Settings

Using **Optimization** settings, you can:

- Optimize performance for either Mac OS X applications or Windows programs
- Tune Windows for speedier performance or more graphical features
- If you’re using a MacBook or other portable computer, optimize your computer for better battery life or higher performance
- Conserve disk space
- Enable virtualization support in Windows (for Windows 8 and Windows Server 2012 only)

To access **Optimization** settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. Click **Options** and select **Optimization**.
Optimize Performance for Mac OS X Applications or Windows Programs

Choose one of the following from the Performance menu:

- **Faster virtual machine**: More of your computer’s resources are given to Windows. The performance of Windows programs may be increased significantly, but Mac OS X applications may slow down.

- **Faster Mac**: More of your computer’s resources are given to Mac OS X. The performance of Mac OS X applications may be increased significantly, but Windows programs may slow down.

To set Parallels Desktop to automatically optimize performance for Mac OS X or Windows depending on which application or program you’re working with at the moment:

- Select **Enable Adaptive Hypervisor**. When you’re using a Windows program, more resources are given to Windows, and when you’re using a Mac OS X application, more resources are given to Mac OS X.

Tune Windows for Speedier Performance

- Select **Tune Windows for speed**.

Some Windows features that tend to slow down performance, such as animations during startup, are disabled.

Optimize your MacBook for Longer Battery Life or Higher Performance

The Power menu contains the power and performance related options:

- **Longer battery life**: If you have a portable Mac that you often use unplugged, you can choose this option to lower power consumption for longer battery life. This may slightly reduce Windows performance.

- **Better performance**: This option (selected by default) maximizes Windows performance, but uses more power.

  **Note**: If you change options in the Power menu when Windows is running, you must shut down Windows and start it again for the changes to take effect.

To show battery status in Windows:

- Select **Show battery in Windows**.

When your MacBook or other portable computer is running on battery power, the battery status is displayed in the menu bar.
Automatically Conserve Disk Space

In most cases, the space that Windows takes up on your hard disk expands as you add files and other data, but isn’t reduced when you delete data. To set Parallels Desktop to automatically reduce disk space periodically:

- Select **Automatically compress virtual disks**.

Twice a day, Parallels Desktop reviews disk space. If unused space takes up more than 50 percent of the Windows hard disk image size, the disk space is freed up for your use.

You can also free up hard disk space manually. And you can quickly remove unnecessary files that have built up in the system (p. 142) to free up disk space.

**Note:** Compressing can be done only if you haven’t saved a snapshot and if the Undo disks option is disabled.

Enable virtualization support in Windows

To be able to run virtual machines in an operating system, the system must support hardware virtualization and have some virtualization product installed.

Parallels Desktop 8 allows you to run virtual machines in Windows 8 and Windows Server 2012. To enable virtualization support in these guest operating systems:

- Select **Nested VT-x/EPT**.

**Warning:** If you choose to create and run Hyper-V virtual machines, do not use them in production. Such virtual machines may work unstable because Microsoft® doesn't support nesting Hyper-V.

**Note:** Running a virtual machine in a virtual machine may slightly slow down the hosting virtual machine performance.

Optimize 3D Graphics Performance on a MacBook Pro

Some new MacBook Pro computers have two video adapters. By default, the slower video adapter that saves energy is used.

To use the faster video adapter for better 3D graphics performance:

1. In the Mac OS X Finder, select **Apple menu > System Preferences** and click **Energy Saver**.
2. Click **Higher performance**.

Setting graphics to higher performance uses battery life faster.
**Speed Up Games and Graphics Programs**

With Parallels Desktop, you can run games and programs that require video cards with DirectX or OpenGL support. To do so, you must enable 3D acceleration.

For information on whether a program requires DirectX or OpenGL support, see the materials that came with the game or program.

To enable 3D acceleration:

1. **Shut down the virtual machine.** (p. 42)
2. Choose **Virtual Machine > Configure**.
3. In the **Video** pane, select **On** or select a version of DirectX from the **3D acceleration** menu.

**Note:** Parallels Tools must be installed (p. 204) before you can enable 3D acceleration. Parallels Tools are installed by default when you set up Windows.

**Pause Windows When No Programs Are Open**

You can conserve your computer’s resources by setting Windows to pause automatically when no Windows programs are open. That way, more resources such as RAM and CPU can be used for Mac OS X applications.

To set Windows to pause when no programs are open:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.
2. Click **Options** and select **Applications**.
3. Be sure **Share Windows applications with Mac** is selected, and then select **Pause Windows when no applications are open**.
Use Windows on Your iPad, iPhone, or iPod touch

You can use the Parallels Mobile app to access and control Windows remotely from your iPad, iPhone, or iPod touch.

Parallels Mobile lets you:

• Use any of your Windows programs on your iPad, iPhone, or iPod touch
• Remotely start, stop, and reset Windows
• Connect over Wi-Fi or 3G
• Access Windows from anywhere over the Internet

Get Started

Before you can use Parallels Mobile, you must do the following:

1 Be sure you have registered to use Parallels Desktop (p. 13).
2 On your iPad, iPhone, or iPod touch, download and install Parallels Mobile from the App Store.
3 Be sure you have installed Windows on your Mac (p. 18).
4 In Parallels Desktop, do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   • If Windows is running in Window mode (p. 50), choose Parallels Desktop > Preferences.
5 Click Mobile.
6 Log in to your Parallels account using the email and password you used to register Parallels Desktop.

You only have to do these steps once.

Access Windows from your iPad, iPhone, or iPod touch

1 Turn on your Mac.
   Your Mac must be on for Parallels Mobile to access and use Windows.
2 Open Parallels Mobile on your iPad, iPhone, or iPod touch and log in to your account using the same email and password you used to register Parallels Desktop.
3 Tap your Mac in the list of available Macs.

When you access Windows for the first time, you see tips about gestures you can use to control Windows. Tap Close to go to the Windows desktop.
Use Windows on Your Mac

Connect Directly to Your Mac for a Faster Experience

If your Mac and your iOS device are on the same Wi-Fi network, you can bypass the Internet and connect your device directly to your Mac for a faster experience.

1. In Parallels Desktop on your Mac, do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   • If Windows is running in Window mode (p. 50), choose Parallels Desktop > Preferences.
2. Click Mobile.
3. Make sure Connect Parallels Mobile directly to my Mac is selected, and then write down the IP Address listed under the checkbox.
4. On your iOS device, open the Settings app, and then scroll down and tap Parallels.
5. Be sure Direct Connection is turned on.
6. Press the Home button and then open Parallels Mobile on your iOS device.
7. Tap Direct and tap the plus (+) icon.
8. Enter a name for your Mac and enter the IP address from the Mobile preferences pane.
9. Enter the user name and password you use for your Mac (your login password).
10. Tap Connect.

For more information about using Parallels Mobile, see the Parallels Mobile Quick Start guide, available on the Parallels website.

Save a Picture of the Screen

To save a picture of Windows in Window Mode:

• Choose View > Make Screenshot.

A file named Parallels Picture.png is saved on the Mac OS X desktop.

You can also take a picture of the entire screen at any time by pressing Command-Shift-3. By default, pictures are saved to the Mac OS X desktop.
Set the Appearance of the Parallels Desktop Dock Icon

You can choose which type of icon appears in the Mac OS X Dock when Parallels Desktop is open.

1 Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences. Then click General.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences, and then click General.

2 From the Dock Icon menu, choose one of the following:
   - Live Screenshot: The Dock icon shows a miniature image of what you see in Windows.
   - Parallels Desktop: The Dock icon appears as a static Parallels Desktop symbol.

3 To set whether the icon appears as a Windows Start button when in Coherence mode, select or deselect Use Start button icon in Coherence.

**Note:** No matter which type of Dock icon you choose, clicking the icon when in Coherence mode displays the Windows Start menu.
This chapter is intended to give you additional information on how to work with Parallels Desktop and virtual machines.

In This Chapter

Work with Virtual Machines ................................................................. 118
Use Other Operating Systems on Your Mac ........................................... 142
Install or Update Parallels Tools ............................................................. 152
Modality Mode ...................................................................................... 164
Hide and Show Parallels Desktop ............................................................ 166
Remove Parallels Desktop ...................................................................... 166
Advanced Preferences ........................................................................... 167
Adding and Removing Devices ............................................................... 177
Hardware Settings .................................................................................. 183

Work with Virtual Machines

Read this section for basic information about working with virtual machines.
## Supported Guest Operating Systems

Any of the following guest operating systems can be installed in Parallels Desktop virtual machines.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>32-bit</th>
<th>64-bit</th>
<th>Express Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 8</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 7 SP1</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows Server 2012</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows Server® 2008 SP0, SP1, SP2, R2</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows Vista® Home, Business, Ultimate, Enterprise SP0, SP1, SP2</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows Server® 2003 SP0, SP1, SP2, R2</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows XP Home SP0, SP1, SP2, SP3</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows XP Professional SP0, SP1, SP2, SP3</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows XP Professional SP2</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 2000 Professional SP4</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 2000 Server SP4</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows NT 4.0 Server SP6, Workstation SP6</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows ME</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 98 SE</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 95</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 3.11</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>MS-DOS 6.22</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td><strong>Linux</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ubuntu® Linux 10.04, 10.10, 11.04, 11.10, 12.04</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Red Hat® Enterprise Linux 5.x, 6</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux 4.x</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>CentOS Linux 5.x, 6.x</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Fedora™ Linux 15, 16, 17</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>SUSE® Linux Enterprise Server 11 SP2, Desktop 11 SP2</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Advanced Topics</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OpenSUSE Linux 11.4, 12.1</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mandriva™ Linux 2010, 2011</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Debian® Linux 5.0, 6.0</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Mac OS</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X Mountain Lion 10.8.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X Lion 10.7.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X Lion Server 10.7.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X Snow Leopard Server 10.6.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X Leopard Server 10.5.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Chrome</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chrome OS</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Solaris</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Solaris 2009.06</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Solaris® 10</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Oracle Solaris 11</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>BSD</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FreeBSD® 7.x, 8.x</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>OS/2</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OS/2® Warp 4.5, 4</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>eComStation™ 1.2</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Android</strong></td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Android OS</td>
<td>![ ] ![ ]</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Please note that Parallels Desktop does not include operating system installation discs or their images. You should purchase them separately.
About Virtual Machines

To add Windows or another operating system to your Mac, Parallels Desktop creates a "virtual machine," or a virtual copy of a computer, inside your Mac. You can then install Windows in the virtual machine, just as you would install an operating system on a regular computer.

Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can install as many virtual machines as you like, and install a different operating system in each of them. That way you can use multiple operating systems together at the same time on your Mac. And just like with a regular computer, you can turn virtual machines on and off, configure them, and install and use programs.
Default Configurations

A typical virtual machine has the following basic virtual hardware: CPU, memory, hard disk drive, floppy disk drive, sound device, CD/DVD drive, network adapter, USB controller, serial port, printer port connected to the printer set as the default in Mac OS.

**Note:** Apart from the basic hardware, you can add new devices to your virtual machine using the *Virtual Machine Configuration* dialog (p. 177).

The amount of memory and the size of hard disks vary for different guest OSs. Refer to the table below to learn the memory and hard disk values that are allocated to a virtual machine depending on the guest operating system that will be installed in it. Virtual hard disks for typical virtual machines are always created in the *expanding format* (p. 179).

<table>
<thead>
<tr>
<th>Guest Operating systems</th>
<th>Memory, MB</th>
<th>Video Memory, MB</th>
<th>Hard Disk, MB</th>
<th>Floppy Drive</th>
<th>CD/DVD Drive</th>
<th>Network Adapter</th>
<th>Sound Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mac OS X</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 7</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>1024</td>
<td>128</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows Vista</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows XP</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 2003</td>
<td>1024</td>
<td>64</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 2000</td>
<td>256</td>
<td>256</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows ME</td>
<td>256</td>
<td>32</td>
<td>8,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows NT</td>
<td>256</td>
<td>32</td>
<td>4,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 98</td>
<td>256</td>
<td>32</td>
<td>8,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 95</td>
<td>128</td>
<td>32</td>
<td>2,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 3.11</td>
<td>64</td>
<td>32</td>
<td>2,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Windows</td>
<td>1024</td>
<td>128</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Red Hat Enterprise Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SUSE Linux Enterprise</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Debian GNU/Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ubuntu Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fedora Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CentOS Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Set Where New Virtual Machines Are Stored

By default, Parallels Desktop stores virtual machines in ~/Documents/Parallels.

To change the default location for new virtual machine installations:

1  Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences. Then click General.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences, and then click General.

2  Choose a location from the Virtual Machines Folder menu.

All newly created virtual machines are stored in the new location. Any existing virtual machines remain in their original locations.
Change the Virtual Machine Name

The name of a virtual machine is displayed in the Parallels Virtual Machines list and, at the top of the guest OS window when you are running in Window mode.

To change the virtual machine name:

1. Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.
2. Click General and type a new name in the Name field.

The length of the name is limited to 50 characters.

Clone a Virtual Machine

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual machine fully identical to the original one. To make a clone:

1. Start Parallels Desktop.
2. In the Parallels Virtual Machines list select the virtual machine you want to clone (it must be shut down) and choose File > Clone.
3. Choose where you want to store the clone.
   - By default, Parallels Desktop stores clones in your Documents > Parallels folder.
4. Click Save to start cloning the virtual machine.
Back Up a Virtual Machine

Most people don’t seriously consider regular backups as a necessity until they have experienced a significant data loss. You should create your own backup strategy to protect yourself from data loss. Virtual machines are as vulnerable to crashes as physical computers.

You can back up your virtual machine using one or several of the following methods:

- Configure the regular backup settings in the Backup pane of the Virtual Machine Configuration dialog.
- Use third-party backup utilities like Acronis Online Backup (p. 141).
- Clone the virtual machine with the help of Clone Virtual Machine Assistant. Give a descriptive name to the clone and save it in a location specially designated for backups.
- Copy the virtual machine files manually.

Configure Regular Backups

In the Backup pane of the Virtual Machine Configuration dialog, you can choose how to back up your virtual machine regularly. You can configure how the virtual machine snapshots will be created or choose to back up the virtual machine with Time Machine.

If you choose to back up your virtual machine with Time Machine, your virtual machine’s PVM file will be automatically backed up together with other files stored in Mac OS. As a consequence, files stored on your virtual machine’s hard disk will be also backed up, since the virtual hard disk file (HDD) is stored inside the virtual machine bundle file (PVM).

**Warning:** Time Machine backups can guarantee safety only when your Parallels virtual machines were stopped or suspended during the backup.

To restore some of your Windows files:

1. From within the Finder (and not within Time Machine), locate the backup copy of your virtual machine’s file (PVM) on your backup disk.
2. Right-click the file, and choose Show Package Contents.
3. In the virtual machine contents window, right-click the virtual hard disk file (HDD) that is usually named `<VirtualMachine'sName>.hdd` and choose Open With > Parallels Mounter.
4. Using Parallels Mounter, browse the contents of your virtual machine’s hard disk to find the files you need to restore.

Use Third-Party Backup Utilities

You can use any third-party backup utilities you like. Registered Parallels Desktop users can use Acronis Online Backup (p. 141) to back up their Windows virtual machines.
Clone the Virtual Machine

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For details, see Clone a Virtual Machine (p. 124).

Copying the Virtual Machine Files

You can locate your virtual machine in Finder and create a backup copy of the virtual machine file (PVM).

1. In the Parallels Virtual Machines list (or in the virtual machine window if it is shut down), right-click the virtual machine name and select Show in Finder from the context menu. In Finder, go to the folder where your virtual machine is stored.

2. Locate the required virtual machine PVM file.

   Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file (HDD), and other files. For more information about the virtual machine files, see About Virtual Machines (p. 121).

3. Copy the virtual machine’s PVM file to a safe location.
Browse Virtual Hard Disks in Mac OS X

For easy access to Windows files, you can mount the virtual hard disk (on which Windows is installed) in Mac OS X.

Mount a Virtual Hard Disk to the Mac OS X Desktop

If you need the virtual hard disk (on which Windows is installed) to be mounted to the Mac OS X desktop when Windows is running, open Finder, choose Finder > Preferences > General and select the Connected servers option.

For easy access to your virtual machines files, you can mount their hard disks in Mac OS X Finder together with other disks and storage devices.

If you want your virtual hard disks to be mounted to the Mac OS X desktop when the virtual machine is running, perform the following actions:

1. Open the Sharing pane of the Virtual Machine Configuration dialog and enable the Mount virtual disks to Mac desktop option.

   **Note:** To be able to edit the settings in the Sharing pane, you must have Parallels Tools (p. 152) installed in the virtual machine and the Isolate Mac from Windows option disabled in the Security pane.

2. Open the Finder Preferences, click the General tab and select the Connected servers option in the list of items displayed on the desktop.

If you want to manage the virtual machine content without starting the virtual machine, you can mount the virtual hard disks manually using Parallels Mounter:

1. Browse the virtual machine files in Finder. For Parallels virtual machines, right-click the virtual machine name in the Parallels Virtual Machines list (or in the virtual machine window if it is shut down) and select Show in Finder from the context menu.

   The default paths for storing Parallels virtual machines are /Users/<UserName>/Documents/Parallels/ and /Users/Shared.

2. To mount the hard disk of a particular virtual machine, right-click this virtual machine’s file and choose Open With > Parallels Mounter or Open With > Other > Library > Parallels > Parallels Mounter from the shortcut menu. You can mount the following virtual machines and hard disks:
   - Parallels bundle (.pvm) or configuration file (.pvs) or virtual hard disk file (.hdd).
   - VMware configuration file (.vmx, .vmwarevm) or virtual hard disk file (.vmdk).
   - Virtual PC configuration file (.vmc, .vpc7) or virtual hard disk file (.vhd).
   - VirtualBox configuration file (.xml) or virtual hard disk file (.vdi).
If you choose the PVM file of a Parallels virtual machine or the configuration file of a third-party virtual machine that has several virtual hard disks, all its volumes will appear as mounted in Finder.

If you want to mount a single virtual hard disk, double-click the virtual hard disk file to mount it with Parallels Mounter. The icon for the selected hard disk appears in the sidebar of the Finder window, together with other Mac OS X icons.

3 To browse the contents of a volume, click its icon in the sidebar of the Finder window.

You can manage the virtual machine files just as you manage your Mac OS X files in Finder windows.

**Note:** If you are browsing the contents of a suspended virtual machine in Finder, you cannot delete, move, or otherwise modify its files.

4 To unmount the volume, use the **Eject** button next to the disk icon.

**Note:** If a hard disk that has several volumes was mounted and you want to open it or the virtual machine using it in Parallels Desktop, you should disconnect its volumes one by one by clicking the **Eject** button.
Create and Use Virtual Machine Templates

On the basis of your virtual machines you can create templates. Later you can use them to create multiple identical virtual machines. To create a virtual machine template, you can:

- convert a virtual machine to a template; or
- clone a virtual machine to a template.

The difference between these two ways is that when you convert a virtual machine to a template, you can’t run it until you convert the template back to the virtual machine. And when you clone a virtual machine to a template, the template appears separately from the virtual machine and you can work with both.

A template, in its turn, can be converted or deployed back to the virtual machine. When you convert a template, it turns back to the virtual machine. And when you deploy it, the resulting virtual machine appears separately from the template and you can work with both.

**Convert a Virtual Machine to a Template**

To convert a virtual machine to a template:

1. Start Parallels Desktop.
2. In the Parallels Virtual Machines list, select the virtual machine you want to convert (it must be shut down) and choose File > Convert to Template.

**Convert a Template to the Virtual Machine**

To convert a template back to the virtual machine:

1. Start Parallels Desktop.
2. In the Parallels Virtual Machines list, right-click the template you want to convert and choose Convert to Virtual Machine.

**Clone a Virtual machine to a Template**

To clone a virtual machine to a template:

1. Start Parallels Desktop.
2. In the Parallels Virtual Machines list, select the virtual machine you want to clone (it must be shut down) and choose File > Clone to Template.
3. Choose where you want to store the resulting template.
   - By default, Parallels Desktop stores templates in your Documents > Parallels folder.
4. Click Save to start cloning the virtual machine to the template.
Deploy a Template to the Virtual Machine

To deploy a template back to the virtual machine:

1. Start Parallels Desktop.
2. In the Parallels Virtual Machines list, right-click the template you want to deploy and choose Deploy to Virtual Machine.
3. Choose where you want to store the resulting virtual machine.
   By default, Parallels Desktop stores virtual machines in your Documents > Parallels folder.
4. Click Save to start deploying the template to the virtual machine.
Save Snapshots of a Virtual Machine

A snapshot is a saved state of the guest OS. It’s useful to create snapshots, for example, before:
- you’re going to run some programs that may damage the guest OS; or
- if you’re going to configure some guest OS software that requires a lot of settings; or
- if you want to mark milestones in the development process.

**Note:**
1. Snapshots cannot be created for Windows virtual machines that use the Boot Camp partition.
2. If your virtual machine has one or more snapshots, you can neither compress nor resize the virtual hard disk.

If something goes wrong, you can revert the changes back to any of your snapshots and continue working with the guest OS.

**Create a Snapshot**

1. Start Parallels Desktop.
2. In the **Parallels Virtual Machines** list, select the virtual machine for which you want to create a snapshot.
3. Click **Virtual Machine > Manage Snapshots.**
4. Click **New**, specify the snapshot name and click **OK.**

**Automate the Creation of Snapshots**

The SmartGuard functionality allows you to automate snapshots creation.

**Note:** SmartGuard is available only when the **Undo Disks** feature is disabled and the virtual machine is not running in **Safe Mode**.

To access settings for automating snapshots:

1. Start Parallels Desktop.
2. In the **Parallels Virtual Machines** list, select the virtual machine for which you want to create a snapshot.
3. Click **Virtual Machine > Configure.**
4. Click **Options > Backup.**
To automate snapshots, click the **SmartGuard** menu and choose one of the following:

- **Optimize for Time Machine**. If you select this option, a snapshot will be taken every 48 hours. Time Machine, when backing up your Mac, will not back up the entire virtual machine, but only its latest snapshot. This allows you to reduce the amount of data that Time Machine backs up, to reduce the time Time Machine spends backing up the virtual hard disk(s), and to minimize the risk of data loss or corruption when restoring the virtual machine hard disk(s) from the Time Machine backup.

- **Custom**. If you select this option, you will be able to manually set the snapshots frequency and maximum number of snapshots to keep.

If you want to know when it is time to make the next snapshot and to be able to reject the snapshot creation, enable the **Notify me before snapshot creation** option.

**Note**: If you use Time Machine to back up your Mac, you can configure the virtual machine so that Time Machine would back up not its whole hard disk but only the changes made since the latest snapshot. Choose **Optimize for Time Machine** and click **OK**.
To set how often snapshots are made:

- Use the **Take a Snapshot Every** field. You can set from one to 48 hours.

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest daily, weekly and monthly snapshot.

To limit how many snapshots are stored:

- Use the **Snapshots to Keep** field to set the maximum number of snapshots that can be stored on your Mac.

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit for snapshots and needs to make a new one over limit, it deletes the oldest snapshot.

**Revert to a Snapshot**

To revert to a snapshot:

1. Start Parallels Desktop.
2. In the **Parallels Virtual Machines** list, select the virtual machine that you want to revert.
3. Click **Virtual Machine > Manage Snapshots**.
4. Select the snapshot to which you want to revert and click **Go To**.

**Delete a Snapshot**

To delete a snapshot:

1. Start Parallels Desktop.
2. In the **Parallels Virtual Machines** list, select the virtual machine which snapshot you want to delete.
3. Click **Virtual Machine > Manage Snapshots**.
4. Select the snapshot you want to delete and click **Delete**.

When you delete an intermediate snapshot, the information it contains is merged into the next snapshot.
Change Virtual Machine Configuration at Runtime

Parallels Desktop allows you to connect or disconnect certain devices at runtime or switch some of them for using other media.

 Generally, the following virtual devices can be connected or disconnected at runtime:

- Floppy disk drive
- CD/DVD-ROM drives
- Network adapter
- Sound device
- USB device
- Shared folders

If printer and serial ports are present in the virtual machine configuration, you can also manage them at runtime.

You can configure any of these devices in one of the following ways:

- Use the necessary command from the Devices menu in the menu bar. This menu is available only when the virtual machine is running.
- Click a device icon on the status bar and choose the command from a device shortcut menu. The status bar displays the devices information when the virtual machine is running.
- Drag an image file (*.iso or *.fdd) or a shared folder on the appropriate device icon in the status bar. This option is available only for CD/DVD-ROM drives, floppy drives and shared folders.

Connecting a CD/DVD-ROM or a Floppy Drive

If you have several CD/DVD-ROM drives connected to your virtual machine, in the Devices menu they are listed in the same order as they were connected. The first CD/DVD-ROM drive will be CD/DVD-ROM 1, the second will be CD/DVD-ROM 2, and so on.

Connecting a Network Adapter

You can set up any of the three network modes: Shared Networking, Bridged Networking, or Host-Only Networking.

Connecting a Sound Device

To connect or disconnect a sound device, choose the Activate or Mute options respectively. You can also choose the type of output and input devices.
Connecting a USB Device

Parallels Desktop automatically detects all USB devices plugged into your Mac computer. The devices that are currently connected to the virtual machine appear in the list from the Device menu. You cannot use a USB device in Mac OS X while it is being used by the virtual machine.

Connecting a Shared Folder

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine Configuration dialog.

You can

- share all Mac disks or Home Folder only with the virtual machine
- share Windows guest operating system disks with Mac OS X
- add a new shared folder

Connecting a Serial Port

To connect or disconnect a serial port, do the following:

- Click the Devices menu, select the corresponding serial port, and choose the appropriate command in the displayed menu.

- Right-click the serial port icon in the status bar to display the shortcut menu and choose the appropriate command.

Connecting a Printer Port

To connect or disconnect a printer port or to connect a printer or an output file to a printer port, do the following:

- Click the Devices menu, select the corresponding printer port, and choose the appropriate command in the displayed menu.

- Right-click the printer port icon in the status bar to display the shortcut menu and choose the appropriate command.
Use Keyboard Shortcuts

If you want to send a key combination to a running virtual machine, do one of the following:

- Press the key combination that you want to send to your virtual machine when the keyboard input is captured inside the virtual machine window;
- Click the keyboard icon in the virtual machine status bar and click the key combination that you want to send to your virtual machine; or
- Click the Devices menu, point to the Keyboard item, and click the key combination that you want to send to your virtual machine.

Using Keyboard shortcuts in MacBook and MacBook Pro

- To use the F1-F12 keys in your virtual machine, press the Fn+(F1-F12) key combination instead.

Use Mouse Wheel Horizontal Scrolling

You can use the mouse wheel horizontal scrolling when working with windows of virtual machine applications. This feature is available only if Parallels Tools (p. 204) are installed in the virtual machine.
Remove a Virtual Machine

Remove a Virtual Machine from your Mac

If you don’t need a virtual machine any more, you can permanently remove it from your Mac:

**Warning:** Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are used by other virtual machines. If you remove a Boot Camp virtual machine, the Boot Camp partition with Windows installed remains available on your Mac.

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Parallels Virtual Machines list and choose Remove.
2. Click Move to Trash.

Remove a Virtual Machine from the Parallels Virtual Machines List

To temporarily remove a virtual machine from the Parallels Virtual Machines list:

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Parallels Virtual Machines list and choose Remove.
2. Click Keep Files.

When you need this virtual machine again, you can easily import it in Parallels Desktop (p. 34).
Download Pre-configured Virtual Appliances

If you don’t have enough time to create a new virtual machine with the required configuration, you can download a ready-to-use virtual machine with a predefined configuration.

Downloading Parallels Virtual Appliances

Parallels Virtual Appliances are pre-built Ubuntu and Android virtual machines.

To download such an appliance and use it with Parallels Desktop:

2. Select Download Ubuntu or Download Android and click Continue.
3. In the next step, click Download. Once the download starts, you can pause it anytime by clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the virtual appliance in Parallels Desktop.

Downloading Google Chrome Virtual Appliance

To download the Google Chrome virtual appliance from Parallels Desktop:

2. Select Download Chrome and click Continue.
3. In the next step, click Download. Once the download starts, you can pause it anytime by clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the Google Chrome virtual appliance in Parallels Desktop. To log in to Chrome OS, you need an internet connection, as well as your Google account name and password.
Set the Guest OS Type and Version

You can change which guest OS a virtual machine is configured to work with. You need to change it in the following cases:

- If you upgrade the guest operating system (for example, from Windows XP to Windows 7), you need to change the guest OS type and version correspondingly or Parallels Tools (p. 152) may start working incorrectly.
- If you create a virtual machine without installing an operating system, and then decide to use it with a different operating system than the one you initially specified.

To set the guest OS type and version:

1. Shut down the virtual machine. (p. 42)
2. Open the Virtual Machine menu and choose Configure.
3. Click General and select an OS from the menu just under the Name field.

Set How Many Processors are Allocated to a Virtual Machine

You can change the number of virtual CPUs that will be used to handle the processes running in a virtual machine. Parallels Desktop automatically calculates the maximum allowable number of virtual CPU. The calculation is based on the number of physical CPUs available to your Mac OS X computer.

Note: It is reasonable to use more than one CPU in your guest OS if you are going to use applications that perform better under multi-core processors.

To set how many processors are allocated to a virtual machine:

1. Shut down the virtual machine. (p. 42)
2. Open the Virtual Machine menu and choose Configure.
3. Click General and select a number from the CPUs menu.

Check Your Virtual Machine CPU and Memory Usage

While working with a virtual machine, you may need to check how much memory and CPU time of your Mac it is currently using. If the virtual machine is consuming too much and your running Mac applications become slow, you can easily reduce the number of CPUs (p. 139) and amount of memory (p. 109) assigned to the virtual machine.

To check the current CPU and memory usage, choose View > Show Resource Usage.
Enable Spoken Commands

You can work with Windows or other guest OSs using the following spoken commands:

<table>
<thead>
<tr>
<th>Commands</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start</strong></td>
<td>Starts a virtual machine.</td>
</tr>
<tr>
<td><strong>Suspend</strong></td>
<td>Suspends a virtual machine.</td>
</tr>
<tr>
<td><strong>Shut Down</strong></td>
<td>Shuts down a virtual machine.</td>
</tr>
<tr>
<td><strong>Pause</strong></td>
<td>Pauses a virtual machine.</td>
</tr>
<tr>
<td><strong>Stop</strong></td>
<td>Stops a virtual machine.</td>
</tr>
<tr>
<td><strong>Reset</strong></td>
<td>Resets a virtual machine.</td>
</tr>
<tr>
<td><strong>Snapshot</strong></td>
<td>Opens the <strong>Snapshot Manager</strong> window.</td>
</tr>
<tr>
<td><strong>Make Screenshot</strong></td>
<td>Makes a screenshot of the Guest OS window and stores it on the Mac OS X Desktop.</td>
</tr>
<tr>
<td><strong>Make Clip</strong></td>
<td>Makes a clip.</td>
</tr>
<tr>
<td><strong>Switch to Coherence</strong></td>
<td>Switches to the Coherence view mode.</td>
</tr>
<tr>
<td><strong>Switch to Full Screen</strong></td>
<td>Switches to the Full Screen view mode.</td>
</tr>
<tr>
<td><strong>Switch to Window</strong></td>
<td>Switches to the Window view mode.</td>
</tr>
<tr>
<td><strong>Edit Configuration</strong></td>
<td>Opens the <strong>Virtual Machine Configuration</strong> dialog.</td>
</tr>
<tr>
<td><strong>New</strong></td>
<td>Creates a new virtual machine.</td>
</tr>
<tr>
<td><strong>Open</strong></td>
<td>Opens a virtual machine.</td>
</tr>
<tr>
<td><strong>About Parallels Desktop</strong></td>
<td>Opens the About Parallels Desktop menu.</td>
</tr>
<tr>
<td><strong>Install Parallels Tools</strong></td>
<td>Launches the installation of Parallels Tools in the running virtual machine.</td>
</tr>
<tr>
<td><strong>Report a Problem</strong></td>
<td>Opens the <strong>Parallels Problem Report</strong> window.</td>
</tr>
<tr>
<td><strong>Open</strong></td>
<td>Opens an existing virtual machine and registers it in Parallels Desktop.</td>
</tr>
<tr>
<td><strong>Open Directory</strong></td>
<td>Opens the <strong>Parallels Virtual Machines</strong> window.</td>
</tr>
</tbody>
</table>

To enable the spoken commands, choose **Parallels Desktop > Preferences > Advanced** and select **Enable spoken commands**. If necessary, tune the speech settings on the corresponding tab of Mac OS X System Preferences.
Get Acronis Online Backup

As an additional benefit, Parallels provides you with Acronis Online Backup. It is an online backup tool for Windows 7, Windows Vista, and Windows XP. Acronis Online Backup allows you to back up your Windows data up to 250 GB with full security and protection. For Parallels Desktop users, Acronis Online Backup is free for 90 days.

To download Acronis Online Backup, do one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Exit Coherence. Then choose Virtual Machine > Get Acronis Online Backup.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Get Acronis Online Backup.

Use AppleScript with the Guest OS

You can use AppleScript to open various files and websites in the guest OS applications. You may need this when creating automated workflows.

To make the explanation more vivid, let’s assume that you need to open some .txt file in Windows Notepad using AppleScript (in AppleScript Editor). The syntax of this command is as follows:

```applescript
tell application "Notepad"
open "//Users/username/somefile.txt"
end tell
```

As an example of opening a website in the guest OS application, let’s assume that you need to open "www.parallels.com" in Internet Explorer. The syntax of this command is as follows:

```applescript
tell application "Internet Explorer"
open "//www.parallels.com"
end tell
```
Quickly Free Up Disk Space

With the click of a button you can compress the virtual machine hard disk(s) and remove various unnecessary files to free up disk space.

To quickly compress the disk(s), remove unnecessary files, and free up disk space:

1. Shut down the virtual machine.
2. Choose Virtual Machine > Reclaim Disk Space.
   A message tells you how much extra disk space you’ll gain by performing the procedure.
3. Click Yes.

Parallels Desktop compresses the virtual machine hard disk(s) and removes various unnecessary files such as statistical, memory dump, and crash dump files, which are generated during the virtual machine life cycle.

You can also conserve disk space by compressing virtual disks manually (p. 191).

Use Other Operating Systems on Your Mac

This section has topics with information that’s specific to certain operating systems other than Windows XP, Windows Vista, or Windows 7.

Import Linux and Your Data from a PC

You can import Linux and your data from a PC over a network or using an external storage device. These procedures are identical to the same ways of importing Windows (p. 19).

You can import the following Linux operating systems:

<table>
<thead>
<tr>
<th>OS Name</th>
<th>32-bit</th>
<th>64-bit</th>
<th>Migration Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Hat® Enterprise Linux 5</td>
<td>✔️</td>
<td>✔️</td>
<td>Network, External Storage</td>
</tr>
<tr>
<td>Ubuntu® Linux 8.04</td>
<td>✔️</td>
<td>✔️</td>
<td>Network, External Storage</td>
</tr>
</tbody>
</table>

Supported File Systems

- Ext2
- Ext3
- Ext4
Use Linux in Coherence Mode

You can set Linux and Mac OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, Linux programs appear on the Mac desktop next to your Mac applications.

To enable the Coherence view mode:

- **Parallels Tools must be installed** (p. 157).
- Disable Linux 3D effects. The way you can do this depends on your Linux distribution. For example, in Fedora 14 click **System > Preferences > Desktop Effects** and select **Standard**. To learn how to disable Linux 3D effects in other Linux OSs, refer to the operating system documentation.
Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

- Choose View > Enter Coherence.
- Press Control-Command-Return.

To switch from Full Screen mode to Coherence mode, do one of the following:

- Press Control-Option (Alt), click the View menu and select Exit Full Screen. Then open the View menu and select Enter Coherence.
- Move the pointer to the upper-left corner of the screen until the corner peels back and click Exit Full Screen. Then choose View > Enter Coherence.

Install Windows 98

All Windows 95 and some of Windows 98 installation packages include a bootable floppy (a startup floppy disk). The floppy is used to perform disk partitioning and formatting by means of MS-DOS. Since modern Macs have no floppy drives, you will need an external USB floppy drive or an image of a bootable floppy disk. Such an image can be created using third-party tools.

If you have a bootable CD with Windows 98 installation, you can use it as is or create an ISO image of it.

Below we describe how to install Windows 98, the case when you have a startup floppy image and a CD with the installation files. The installation of Windows 95 is similar to that.

Prepare a Virtual Machine for Windows 95/98 Installation

1. Create a Windows 98 virtual machine using New Virtual Machine Assistant. Select the Customize settings before installation option in the Name and Location window.

2. In the Virtual Machine Configuration dialog, click Hardware > Boot Order, and configure the floppy disk to be the first boot device.

3. Below the Boot Order item, select Floppy Disk to open the virtual floppy disk drive settings. In the Floppy Disk pane, do the following:
   1. Make sure the Connected option is selected.
2. Specify the floppy disc image in the **Source** menu.

4. Click **OK** to save the virtual machine configuration.

**Initial Partitioning and Formatting**

1. Start the virtual machine. You will see the black screen and messages indicating the process of booting to MS DOS.

2. When prompted, enter the following command:

```
fdisk
```

Fdisk (MS-DOS utility) is used to partition hard disks and floppy disks.

3. The **Fdisk** options will be listed. Choose the operation to perform (the default choice is 1) and press Return (Enter) to continue.

4. **Fdisk** prompts you to create a partition. Select the **Create Primary DOS Partition** option if you are going to have only one partition or less than four, and enter:

```
1
```

Other choices are for the case when you want to create more than four partitions.

5. Then **Fdisk** prompts you to define the size of the primary partition. Press Return (Enter) if you wish to create a partition of the maximum size available.

To define other size type **N** and press Return (Enter). You will be prompted to specify the size.

6. **Fdisk** creates the partition and then prompts you to restart the computer (virtual machine).

7. Reboot the virtual machine using the same image of the boot floppy disk. That is, press Ctrl+Option (Ctrl+Alt) to release the keyboard input and then click the **Shut Down** button to stop the virtual machine. Then click the **Start** button.

8. When the booting is complete, you should format the system drive **C:**.

Enter the following command:

```
format c:
```

Confirm that you want to format the disk **C:** when prompted. Type **Y** and press Return (Enter).

You may be prompted to choose how exactly to format your disk. Windows 95/98 supports FAT16 and FAT32 file systems.

FAT16 partition cannot be greater than 2 GB. Larger disks can be formatted with FAT32. But do not use larger disks if you are going to run legacy applications.

The program starts formatting the disk **C:**.

Format other disks too (if you created more than one primary partition or if you created a custom virtual machine with more than one disk). Use **E:**, **F:** drive letters.

9. Enter a label for each disk (11 character string). The label is optional, you can press Return (Enter) to skip this step.

10. Shut down the virtual machine.

Now you are ready to start the installation of the Windows 98 operating system.
Advanced Topics

General Steps of Windows 98 Installation

1. Start the virtual machine using the same bootable floppy image.
2. Insert the Windows 98 installation CD or connect an ISO image of the installation disc choosing CD/DVD > Connect Image from the Devices menu.
3. If you created only one primary partition (disk C:), by default, your CD/DVD drive will have the drive letter D:. Type the command:
   \D:\setup.exe
   and press Return(Enter). The installation starts and the files are copied from the CD to the virtual hard disk.
4. Follow the on-screen instructions of the Setup. Note that you can add or remove some options later.
5. Read and accept the License Agreement. Enter the license key.
6. Confirm the default system directory or specify another one.
7. In the Setup options dialog choose the type of installation. Typical is recommended.
8. (only for Windows 98) If you are going to use networking, select the network card when prompted.
9. Turn off the virtual machine.
10. Eject the installation CD or disconnect the ISO image.
11. Choose Configure from the Virtual Machine menu, go to Hardware > Boot Order, and select the hard disk to be the first boot device. Click OK to save the configuration.
12. Restart the virtual machine. This time, it will boot from the hard disk.
Improve Graphics Performance in Windows NT/98/ME

If you have Windows NT, Windows 98, or Windows ME installed on your Mac, you can improve graphics performance by installing a video driver.

To install a video driver in Windows 98 and Windows ME:

1. Start Windows 98, or Windows ME.
2. When the guest OS boots up, choose Virtual Machine > Install Parallels Tools.
3. In Windows, click Start > Settings > Control Panel > Display.
4. In the Display Properties dialog, go to the Settings tab and click the Advanced button.
5. On the Adapter tab, click Change. The wizard opens.
6. In the wizard, click Next.
7. Select Search for a better driver than the one your device is using now and click Next.
8. Select Specify a location option. Click Browse. Locate the \Drivers\Video\Win9x folder on the CD-ROM drive and click OK.
9. Click Next in the Update Device Driver Wizard and then, when the driver is found, click Next again.
10. Click Finish and then Close to close the Update Device Driver Wizard.
11. Click Close to exit the Display Properties dialog box.
12. When you are prompted to restart the guest OS in the System Settings Change dialog box, click Yes.

The new settings are applied once the virtual machine is restarted.

To install a video driver in Windows NT:

1. Start Windows NT.
2. When the guest OS boots up, choose Virtual Machine > Install Parallels Tools.
3. In Windows, click Start > Settings > Control Panel > Display.
4. In the Display Properties dialog, go to the Settings tab and click the Display Type button.
5. In the Adapter Type section, click Change. The Change Display window opens.
6. In this window, click Have Disk.
7. Click Browse. Select the \Drivers\Video\NT4 folder on the CD-ROM drive and click Open twice.
8. In the Install From Disk window, click OK.
9. In the Change Display window, click OK.
10 Confirm that you want to install the video driver.

11 When you are prompted to restart the guest OS in the System Settings Change dialog box, click Yes.

The new settings are applied once the virtual machine is restarted.

**Customize the Keyboard for the Guest OS**

By default, Parallels Desktop contains four profiles that represent sets of key combinations typical for the following OSs:

- Windows
- Linux
- Mac OS X
- Generic (for other guest OSs)

When you create or register a virtual machine, one of these profiles, depending on the guest operating system, is assigned to the machine by default. You can create your own profile and assign it to your virtual machines.

To create a custom keyboard profile or edit the existing profiles:

1 Do one of the following:
   - Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Preferences.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.

2 Click Shortcuts.
3 Select a virtual machine from the sidebar, click the Profile menu, and select Edit profiles list.

![Profile menu](image)

4 Do one of the following:

- To add a new profile, click the Add button. Specify the new profile name and select the base profile from the list. After the profile is created, you can submit the changes by clicking OK. Then select this new profile in the Profile list and configure its shortcuts.

- To remove one of the existing custom profiles, select it and click the Remove button.

- To duplicate or rename one of the existing profiles, select this profile, click the button, and select the corresponding action from the menu.

  **Note:** You can rename or remove your custom profiles only.

In the Shortcuts pane of Parallels Desktop Preferences, you can also assign profiles to your virtual machines.

To change a profile assigned to a virtual machine:

- Select a virtual machine and choose a profile from the Profile menu.

**Emulate a Mouse Right-Click or Middle-Click**

To emulate a mouse right-click or middle-click:

1 Select Mouse Shortcuts in the sidebar.

2 Select Secondary click (for right-click) or Middle click.

3 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.

You can use any combination of the Control, Option (Alt), Shift, and Command keys to specify the key combination that will be used to emulate a mouse right-click or middle-click in the virtual machine.
Use OS X as a Guest OS

If you are using OS X Lion or Mountain Lion, you can install a copy of OS X in a virtual machine and use it as a guest operating system. This can be useful, for example, if you want to test software in a fresh version of OS X without having to log in and out of your main account.

By default, an installation of OS X is stored in a recovery partition on your Mac. You can easily install OS X into a virtual machine from that partition without having to purchase or download another copy of OS X.

To install OS X in a virtual machine:

2. Select Install OS X Using the Recovery Partition, click Continue, and follow the onscreen instructions.

When using Lion or Mountain Lion as a guest OS, you can use it in Coherence mode (p. 46), so that guest OS application windows appear on the host OS desktop alongside host OS applications.

You can also copy and paste text and drag and drop files between host and guest Mac OS X, just as you can when using Windows as a guest OS.

You can set whether function keys and other system shortcuts trigger actions in the host or guest version of OS X (p. 79).
Use OS X in Coherence Mode

You can set an OS X virtual machine and OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, guest OS X applications appear on the host OS X desktop next to your host applications.

To enable the Coherence view mode, Parallels Tools must be installed (p. 162).

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

• Click the Coherence icon in the top right corner of the virtual machine window.

• Choose View > Enter Coherence.

• Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

• Press Control-Command-F to exit Full Screen. Then open the View menu and select Enter Coherence.
Install or Update Parallels Tools

Parallels Tools are a suite of behind-the-scenes tools that allow seamless operating between Mac OS X and Windows or another guest operating system.

This section gives an overview of Parallels Tools, and has information about how to install them for various guest operating systems.
Parallels Tools Overview

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly between the virtual machine and your Mac, change the virtual machine’s screen resolution by simply resizing its window, synchronize your virtual machine’s time and date settings with the time settings of the host computer, share your Mac’s disks and folders with its virtual machines, copy text and drag and drop objects from Mac OS to a virtual machine and vice versa.

Parallels Tools are available for the most popular Windows, Linux, and Mac OS X operating systems, and include the utilities listed below. All utilities supported by your guest OS are installed in your virtual machine as a single package when you install Parallels Tools.

<table>
<thead>
<tr>
<th>Utility</th>
<th>Available for</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mouse Synchronization Tool</td>
<td>Windows, Linux, Mac OS X</td>
<td>Mouse Synchronization Tool captures the mouse input in the virtual machine each time the pointer moves over its window and automatically releases the input when the pointer moves outside the window.</td>
</tr>
</tbody>
</table>
| Time Synchronization Tool | Windows, Linux, Mac OS X | Time Synchronization Tool enables you to customize your virtual machine time settings. You can:  
  • Automatically synchronize the time settings of your virtual machine with your Mac time settings.  
  • Set up and maintain the time difference between your Mac and your virtual machine. |
| Drag-and-Drop Tool | Windows | Drag-and-Drop Tool allows dragging and dropping files between your virtual machines and Mac OS. |
| Clipboard Synchronization Tool | Windows, Linux | Clipboard Synchronization Tool enables you to easily exchange texts between:  
  • the virtual machine and your Mac.  
  • different virtual machines irrespective of the guest operating systems installed in them.  
  To copy and paste text, you should use the standard procedure for the current operating system. For example, to copy some text in the Windows guest OS, select the text, and press Ctrl+C. To paste this text in Mac OS X, press Cmd+V, or select Paste from the shortcut menu. |
| Dynamic Resolution Tool | Windows, Linux, Mac OS X | Dynamic Resolution Tool enables you to work with dynamic resolution. When you resize the guest OS window by dragging its lower right corner, the guest OS window resolution changes automatically. |
Shared Folders Tool | Windows | Linux | Mac OS X | Shared Folders Tool enables you to share Mac folders with the virtual machine and vice versa. With this tool, you can access your Mac folders from the virtual machine and virtual machine folders from Mac OS X.

Coherence Tool | Windows | Linux | | The Coherence tool allows you to work with your Windows or Linux applications like if they were Mac applications. It hides the virtual machine’s window leaving only guest OS and Mac applications visible.

Shared Profile Tool | Windows | | | Shared Profile Tool enables you to share your Mac desktop, pictures, documents, downloads, music and videos with your virtual machine, which allows you to access them right from Windows.

Shared Applications Tool | Windows | | | Shared Applications Tool enables you to specify default applications for certain types of files, so that you can open some types of files in Windows applications by default, and others - in Mac OS.

Shared Internet Applications Tool | Windows | | | Shared Internet Applications Tool enables you to specify default Internet browsers, including those installed in the virtual machine, for different types of Internet pages. For example, you may set the Internet pages to open in your default Mac OS X Internet browser, and FTP pages to open in your virtual machine Internet browser.

SmartMount | Windows | Linux | Mac OS X | SmartMount automatically detects volumes connected to your Mac and makes them available to the virtual machine as well.

Printing Tool | Windows | | | Printing Tool allows you to synchronize the host and guest OS printers.

Tray Integration Tool | Windows | | | Tray Integration Tool allows you to use Windows tray icons in the Mac menu bar.

Parallels Tools are located on disc images that are installed together with Parallels Desktop. There is a separate Parallels Tools disc image for each type of the supported guest operating systems.

- prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems.
- prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems.
- prl-tools-mac.iso - disc image with Parallels Tools for Mac OS X guest operating systems.

These disc images can be found in the following location on your Mac: <username>/Applications/Parallels Desktop/Contents/Resources/Tools.
Parallels Tools for Windows

**Important:** To take advantage of much of the functionality Parallels Desktop offers, Parallels Tools must be installed.

Parallels Tools can be installed in the following Windows guest operating systems:

- Windows 7
- Windows Server 2008
- Windows Vista
- Windows XP
- Windows Server 2003
- Windows 2000

**Installing Parallels Tools**

If you chose **Express Installation** when you first installed Windows, Parallels Tools were installed automatically after the installation.

If you didn't choose **Express Installation**, do the following to install Parallels Tools:

1. Start Windows (p. 36).
2. When Windows boots up, choose **Install Parallels Tools** from the **Virtual Machine** menu.

   **Note:** After you choose **Install Parallels Tools** in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

3. Click **Continue** to connect the ISO image with Parallels Tools for Windows to the virtual machine’s CD/DVD-ROM drive.
4. Click **Install Parallels Tools** to start the installation.

   **Note:** After you click **Install Parallels Tools** in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

5. When the installation is complete, click **Restart** to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

If the Parallels Tools ISO image doesn’t autoplay after you click **Continue**, the CD/DVD autorun must be disabled in your virtual machine. In this case, do the following to install Parallels Tools:

1. Open **My Computer**, right-click the Parallels Tools disc and choose **Open**.
2. Double-click the **PTAgent** file to start the installation.
3 When the installation is complete, click Restart to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the Virtual Machine Configuration dialog.

Reinstall or Update Parallels Tools

To reinstall Parallels Tools:

1 Start Windows (p. 36).

   Once Windows starts, if Parallels Desktop is in Coherence mode, click the Parallels icon in the menu bar and choose Exit Coherence.

2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.

   This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you will see the Update Parallels Tools option instead.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine’s window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.
Parallels Tools for Linux

Parallels Tools can be installed in Linux guest operating systems that comply with the following requirements:

- glibc 2.3.4 and later
- libstdc++ 3.4.6 and later (libstdc++.so.6)
- gcc 3.4.6 and later (including C++ support)
- make 3.80
- X Window System X11R6.7, X11R6.8, X11R6.8.99, X11R7.0, X11R7.1, X11R7.2 (1.3), X11R7.3 (1.4)
- kernel sources or development package

**Note:** Some of Parallels Tools, like Shared Folders Tool and Time Synchronization Tool, may also work in the Linux operating systems that do not comply with the requirements listed above.

Preparing for installation

Before installing Parallels Tools in a Linux virtual machine, perform the following actions:

- Close all applications running on the virtual machine.
- If you use a 3D accelerated window manager, disable it.
- Make sure that you have the gcc package and kernel sources installed. If these packages are not installed, the Parallels Tools installer will inform you about this. The kernel sources package name depends on the type of Linux operating system you use: it can be kernel-devel, or kernel-headers, or something else. For more information about the kernel sources, refer to Installing the GCC package and Kernel Sources in Linux (p. 215).

**Note:** To install Parallels Tools in your virtual machine, you must have the root privileges.

Installing Parallels Tools in the most recent versions of Linux systems

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) in your virtual machine, the prl-tools-lin.iso image file will be mounted automatically after you connect it to the CD/DVD drive. To install Parallels Tools, do the following:

1. Start the virtual machine.
2. When the operating system boots up, click Virtual Machine and choose Install Parallels Tools.

**Note:** If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements listed above.

The prl-tools-lin.iso image file will be mounted to the virtual machine's CD/DVD drive.
You can connect and mount the Parallels Tools ISO image file manually. Right-click the CD/DVD drive icon in the virtual machine’s window status bar and choose Connect Image. In the Finder window, go to the hard disk folder (normally named “Macintosh HD”), select the /Library/Parallels/Tools/ folder, select the prl-tools-lin.iso file, and click Open to connect it to the virtual machine.

3 Start a terminal in your Linux guest OS. Type the following command to gain the root privileges:

```
su
```

4 Change the directory to the CD/DVD drive directory using

```
cd /media/cdrom/
```

Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear as /media/Parallels\ Tools/.

5 In the CD/DVD drive directory, enter the following command to launch Parallels Tools installation:

```
./install
```

6 Follow the Parallels Tools Installer instructions to complete the installation.

7 When the installation of Parallels Tools is complete, restart your virtual machine.

Installing Parallels Tools in other versions of Linux guest OSs

To install Parallels Tools in the older versions of Linux OSs, you have to mount the prl-tools-lin.iso image file manually. Do the following:

1 Start the virtual machine.

2 When the guest OS boots up, choose Install Parallels Tools from the Virtual Machine menu.

   Note: If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements for Parallels Tools installation.

   The prl-tools-lin.iso image file will be connected to the virtual machine’s CD/DVD drive.

3 Start a terminal in your Linux guest OS. Type the following command to gain the root privileges:

```
su
```

4 Check if the Parallels Tools CD image is mounted by entering

```
mount | grep iso9660
```

   If this command does not return anything, proceed to the next step.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
   ```

   skip the next step and proceed to the following one.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0)
   ```

   with the noexec option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:
umount /dev/cdrom

To mount the Parallels Tools installation disc image, enter the following:

```
mount -o exec /dev/cdrom /media/cdrom
```

**Note:** `/dev/cdrom` is the virtual machine's CD/DVD drive and `/media/cdrom` is the mount point for this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as `/dev/hdb` and the mount point `/mnt/cdrom`. Some Linux OSs do not have the CD/DVD drive mount point. In this case, you should create the mount point directory manually.

6. When the installation disc image is mounted, change the directory to the CD/DVD drive directory using

```
cd /media/cdrom/
```

7. In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:

```
./install
```

**Note:** You must have the `root` privileges to run this command.

8. Follow the Parallels Tools Installer instructions to complete the installation.

9. When the installation of Parallels Tools is complete, restart your virtual machine.

**Note:** If X Server fails to start in your virtual machine, you can install Parallels Tools manually in text mode.

To edit the settings of Parallels Tools installed in your virtual machine, use the **Options** tab in the **Virtual Machine Configuration** dialog.

## How to check if Parallels Tools have been installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.

## Troubleshooting

Parallels Tools installer can be blocked by SELinux. To solve this problem:

1. Start a terminal and determine your version of kernel by entering

```
uname -r
```

```
2.6.18-8.el5
```

2.6.18-8.el5 is the version of your kernel.

2. Open the `/boot/grub/grub.conf` file or `/boot/grub/menu.lst` (depends on the version of your Linux operating system) and find the entry that corresponds to your version of kernel.

```
title Red Hat Enterprise Linux Server (2.6.18-8.el5)
root (hd0,0)
kernels/vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd/initrd-2.6.18-8.el5.img
```

---

159
3 Type the following text at the end of the entry:

```
selinux=0
```

and the whole entry will be:

```
kernl /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet selinux=0
```

4 Save the file and restart the virtual machine.

After the restart, mount the Parallels Tools disc image and try to install Parallels Tools.

**Update Parallels Tools**

Before updating Parallels Tools, you should perform the following actions:

- Close all applications in the guest operating system.
- Disable the 3D accelerated window manager if you have any.

In Linux guest operating systems, you should check for Parallels Tools updates manually from time to time.

To update Parallels Tools:

1 Start the virtual machine.
2 Choose **Update Parallels Tools** from the **Virtual Machine** menu and follow the instructions.
3 When the update is complete, restart your virtual machine.

**Reinstall Parallels Tools**

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them once again.
Installing and Upgrading Parallels Tools in Text Mode in Linux

After upgrading to Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix the problem, you need to install Parallels Tools in text mode.

1. Start the virtual machine.
2. When you see a message that X Server failed to start, switch to another virtual console using Ctrl+Option+F1 (Ctrl+Alt+F1) and enter your login details.
3. Choose **Install Parallels Tools** from the **Virtual Machine** menu to connect the Parallels Tools ISO image to your virtual machine.

   **Note:** If the **Install Parallels Tools** option is grayed out, make sure that Parallels Tools can be installed in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the **Parallels Tools Overview** section in *Parallels Desktop User’s Guide*.

   The *prl-tools-lin.iso* image file will be connected to the virtual machine’s CD/DVD drive.

4. In the virtual machine console, type the following command to gain the root privileges:

   ```
   su
   ```

5. Check if the Parallels Tools CD image is mounted by entering:

   ```
   mount | grep iso9660
   ```

   If this command does not return anything, proceed to the next step.

   If this command returns anything like:

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
   ```

   skip the next step and proceed to the following one.

   If this command returns anything like:

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0)
   ```

   with the **noexec** option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:

   ```
   umount /dev/cdrom
   ```

6. To mount the Parallels Tools installation disc image, enter the following:

   ```
   mount -o exec /dev/cdrom /media/cdrom
   ```

   **Note:** `/dev/cdrom` is the virtual machine's CD/DVD drive and `/media/cdrom` is the mount point for this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as `/dev/hdb` and the mount point `/mnt/cdrom`. Some Linux OSs do not have the CD/DVD drive mount point. In this case, you should create the mount point directory manually.

7. When the installation disc image is mounted, change the directory to the CD/DVD drive directory using:

   ```
   cd /media/cdrom/
   ```

8. In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:

   ```
   ./install
   ```

   **Note:** You must have the root privileges to run this command.

9. Follow the Parallels Tools Installer instructions to complete the installation.
10 When the installation of Parallels Tools is complete, restart your virtual machine.

For general information on installing Parallels Tools in Linux, refer to Installing Parallels Tools in a Linux Guest OS.

Parallels Tools for Mac

Install Parallels Tools

To install Parallels Tools in an OS X virtual machine:

1 Start the OS X virtual machine.
2 When OS X boots up, choose Virtual Machine > Install Parallels Tools and follow the onscreen instructions.

Reinstall Parallels Tools

To reinstall Parallels Tools:

1 Start your OS X virtual machine (p. 36).
2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.

Update Parallels Tools

If a newer version of Parallels Tools for Mac is available, Parallels Tools update automatically.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard. They are released automatically.
Install Sound Driver in OS/2 and eComStation

Sound driver for OS/2 and eComStation can be installed from the prl-tools-other.iso CD image. Before starting the installation, connect the CD image with Parallels Tools to your virtual machine's CD/DVD drive. Choose Install Parallels Tools from the Virtual Machine menu.

Before installing Sound Driver, make sure you have the multimedia support installed in the guest operating system.

To install Sound Driver:

1. Click the System Setup icon on the system panel.
2. Select Install/Remove line and then select Multimedia Application Install.
3. In the IBM Multimedia Presentation Manager/2 - Installation window choose the CD/DVD drive, then the <CD-ROM drive>\Drivers\Sound\OS2 directory. Select the ALC Codec feature and click the Install button.
4. Restart the guest operating system.
Modality Mode

When you switch to Modality, you can resize the virtual machine windows and place them side by side with your Mac’s applications.

In the Modality mode, you can:

- Resize the Windows window while keeping its shape by dragging its lower-right corner.
- Resize the Windows window by pressing and holding the Option (Alt) key and dragging the lower-right corner of the window.
- Resize the Windows window and dynamically adjust the screen resolution by pressing and holding the Shift and dragging the lower-right corner of the window.

Using the Modality settings, you can configure the virtual machine appearance and behavior when it is running in the Modality mode. In the Modality mode, you can resize the virtual machine windows and place them side by side with your Mac applications. A Modality window can be scaled to any size, and its content will still be active. This allows you to monitor the tasks running inside the virtual machine while you are working on the Mac side.

To edit these settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. In the Virtual Machine Configuration window, click Options and select the settings name in the sidebar.

You can configure the settings in this pane even when the virtual machine is running.
In the Modality mode, the virtual machine window becomes transparent by default. You can specify the level of visibility in the **Opacity** field by dragging the slider between **Transparent** and **Opaque**. You can change the level of transparency for your virtual machine that is running when it is in the Modality mode.

To manage the behavior of the virtual machine window in the Modality mode, use the following options selected by default:

- **Keep on top of other windows**. Clear this option if you do not want the virtual machine window to appear on top of all other open windows when the virtual machine is in Modality.

- **Capture keyboard and mouse on click**. Clear this option if you do not want the virtual machine to capture the keyboard and mouse input when in Modality.
Hide and Show Parallels Desktop

When Parallels Desktop is running, you can hide and show it and all its windows by holding down the Function (Fn) key and pressing the F6 key.

If Parallels Desktop is visible but running in the background, pressing Fn-F6 brings Parallels Desktop and all its windows to focus.

Note: Most function keys (F1, F2, and so on) on Mac keyboards serve as specific control keys, such as volume and brightness controls, and you must hold down the Fn key as you press the function key to trigger an alternate, application-specific function. If you want to set function keys to be used for alternate functions without having to press the Fn key, choose Apple menu > System Preferences and click Keyboard. Then click the Keyboard tab and choose Use all F1, F2, etc. keys as standard function keys.

Remove Parallels Desktop

To remove Parallels Desktop, open your Applications folder and drag the Parallels Desktop application to the Trash.
Advanced Preferences

In the Advanced pane of Parallels Desktop Preferences, you can configure some additional settings.

Configuring Network Preferences

In the Advanced pane of Parallels Desktop Preferences, you can configure a number of network-related settings for Parallels Desktop and your virtual machines. Click Change settings and the window with network settings will appear. You can configure the range of IP addresses to be assigned to your virtual machines when they are operating in the host-only and shared networking modes.

For details on configuring the host-only networking settings, refer to Host-Only Networking Settings (p. 173).

For details on configuring the shared networking settings, refer to Shared Networking Settings (p. 170).
Using Third-party Plugins

To be able to encrypt Windows (p. 102) using third-party plugins, select **Allow third-party plugins**.

**Note:** This option is available in Parallels Desktop Enterprise Edition only.

Requiring Password

In the **Require password to** section of the **Advanced** pane, you can set restrictions on the following operations for non-administrator users:

- **Create a new virtual machine.** You will have to provide your administrator password to create a new virtual machine.
- **Add an existing virtual machine.** You will have to provide your administrator password to add an existing virtual machine to the **Parallels Virtual Machines** list.
- **Remove a virtual machine.** You will have to provide your administrator password to remove your virtual machines from the **Parallels Virtual Machines** list.
- **Clone or convert a virtual machine or template.** You will have to provide your administrator password to clone a virtual machine, to create a template, to convert a template into a virtual machine, and to deploy a template into a new virtual machine.

Speech

Parallels Desktop allows you to operate your virtual machine by using the speech commands. If you want to do that, select **Enable spoken commands** and make sure that:

- the virtual machine window is active, and
- the speech settings are properly tuned on the corresponding tab of Mac OS X System Preferences

If the speech settings are not tuned, you will see the 'To enable this option, you should turn on speakable items in System Preferences' warning message. To tune the speech settings, click **System Preferences**.

To view the list of all spoken commands available to manage your virtual machines, please refer to **Enable Spoken Commands**.

Feedback

To participate in the Customer Experience Program, select the corresponding option. If you join this program, Parallels will collect information about your Mac and virtual machines configuration. The collected information will help us to make the product better fit your needs.

If you join, only the following types of data will be collected:
• hardware configuration of your Mac
• software configuration of your Mac and virtual machines (the names and versions of the operating systems and software installed in them)
• configuration files of virtual machines

Any types of private information like your name, e-mail, address, phone number, and keyboard input will not be collected.

For more details, visit the Customer Experience Program page at the Parallels website (follow the link in the pane).

Troubleshooting

While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels support team for solving problems and improving the product. If you select the Use detailed log messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

Resetting Hidden Messages

Some Parallels Desktop dialogs and wizard windows are provided with the Do not show this message again option. If you select this option, the corresponding dialog will not appear next time you perform the same operation. Using the Reset button, you can reset all dialogs and wizard windows with this option selected so that they would be displayed again each time you initiate the corresponding operation.

Locking Parallels Desktop Preferences

If you want to prevent Parallels Desktop Preferences from further unauthorized changes, click the Lock icon at the bottom of the window. The next time anybody wants to change the settings in any pane of Parallels Desktop Preferences, an administrator’s password will be required.
Shared Networking Settings

To make changes the shared networking settings, click **Network: Change settings** in the **Advanced** pane of Parallels Desktop Preferences and select the **Shared** tab. You will see the following window:
In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your virtual machines operating in the shared networking mode. To disable any of these servers, clear the corresponding option.

For more information about configuring shared networking, refer to Share Network Settings Between Mac OS X and Windows (p. 103).

Port Forwarding

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from external computers. The port forwarding functionality allows computers on your local network and on the Internet to transfer data to any of your virtual machines that use the shared networking mode. The data sent to a specific port on your Mac will be redirected to a specific port of your virtual machine according to the port-forwarding rule.

To add a port forwarding rule:

1. Click the Add button below the Port forwarding rules list.
2. In the displayed window, do the following:
   - In the Port Type field, specify the port type you want to use for establishing network connections. You can choose between the TCP or UDP port types.
   - In the Incoming Port field, type the number of the incoming port on your Mac.
   - In the IP Address field, indicate the IP address of the virtual machine you want to connect.
   - In the Destination Port field, type the port on the virtual machine to which the data will be transferred.
3  Click **OK** to add the rule.

When the rule is added, use the following IP address combination for external connections to your virtual machine: `<you Mac's IP address>`:<`Incoming port>`.

To edit a rule, select it in the **Port forwarding rules** list, click the **Edit** button, modify the necessary settings, and click **OK** to apply them.

To remove a port forwarding rule, select it in the **Port forwarding rules** list and click the **Remove** button.

Click **OK** to save the changes, otherwise, click **Cancel**. To restore the default settings, click **Restore Defaults**.
Host-Only Networking Settings

To make changes to the host-only networking settings, click **Network: Change settings** in the **Advanced** pane of Parallels Desktop Preferences. The following window will appear:

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to the virtual machines operating in the host-only networking mode. To disable any of these servers, clear the corresponding option.

Click **OK** to save the changes, otherwise, click **Cancel**. To restore the default settings, click **Restore Defaults**.

For more information on configuring the host-only networking settings, refer to Use Host-Only Network Settings (p. 105).
Advanced Settings

In the Advanced pane, you can configure the Parallels Desktop additional settings.

To edit these settings, do the following:

1. Open the Virtual Machine menu or Option+click (Alt+click) the Parallels icon in the Mac menu bar (in the Coherence view mode) and click Configure.

2. In the Virtual Machine Configuration window, click Options and select the settings name in the sidebar.
SmartMouse

The SmartMouse option allows the mouse to move smoothly between the virtual machine and your Mac. With this option enabled, Parallels Desktop automatically grabs the mouse input when you move the pointer to the virtual machine, and releases it when you move it back to Mac OS.

- If you select On, the mouse input will be automatically captured in the virtual machine window when the mouse pointer hovers over it and then released when it moves back to Mac OS, which will make the mouse move seamlessly between your Mac and the virtual machine.
- If you select Off, you will need to click inside the virtual machine window to capture the mouse input, and press Ctrl+Option (Ctrl+Alt) to release it back to your Mac.

**Note:** Ctrl+-Option (Ctrl+Alt) is the default key combination. You can define another key combination for releasing the mouse in the **Keyboard** pane of Parallels Desktop Preferences.

- If you select Auto, the option will automatically become disabled (Off) each time you use a game, graphic application, or any other program that uses its own mouse pointer instead of using the operating system pointer. The option will be automatically enabled (On) after you quit the application.

**Important:** In Coherence mode, SmartMouse is automatically enabled. If you’re using a program that uses its own pointer and requires SmartMouse to be disabled, you must switch to Window or Full Screen mode.

Mouse Pointer Sticks at Edges

When working with a virtual machine in **Window view mode** (p. 50), you may often need to move the mouse pointer to the edges of the virtual machine window to display various guest OS items: for example, to display the Start menu in Windows 8, hidden taskbar in Windows XP, or OS X menu bar when any of the guest OS X applications is running in full screen.

The **Mouse pointer sticks at window edges** option makes the mouse pointer pause for a while at the edges of the virtual machine window and you won’t move the mouse outside of the virtual machine window by mistake. To move past the edge, just move the mouse quickly.

Modifier Keys Optimization

Enable **Optimize modifier keys for games** if you actively use modifier keys (Option (Alt), Ctrl, Shift) in action games. If you enable this option, signals from these keys will be processed faster.

Apple Remote

Enable the **Apple Remote** option to use the Apple Remote to control some Windows applications.

For detailed information on using Apple Remote, see **Control Programs with Trackpad Gestures** or the **Apple Remote**.
Time Synchronization

Select **Sync from Mac OS X** to synchronize Windows time settings with those of your Mac.

If you want Windows and Mac OS X time settings to always be the same, select **Sync from either OS**. With this option selected, if you manually change the time settings in Windows, they are changed accordingly in Mac OS X and vice versa.

If the time zone set in your virtual machine differs from that of your Mac, you can maintain this time difference by selecting **Do not sync**.

Copy & Paste

If you want to copy and paste data between the host and guest operating systems, select **Share Mac clipboard**. If the data you copy and paste between Mac OS X and your virtual machine is text and you want to preserve text formatting, select **Preserve text formatting**.

**Note:** This functionality is available only for virtual machines with **Parallels Tools installed** (p. 204).

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Adding and Removing Devices

Adding new devices to a virtual machine is easier than connecting new devices to a real computer. Removing or disconnecting devices is also easy. The following virtual devices can be added to the configuration or removed from it:

- virtual hard disk drive
- CD/DVD drive
- floppy disk drive
- network adapter
- serial port
- printer port
- sound device
- USB controller

Any of the aforementioned devices can be added to the corresponding virtual machine only when it is stopped.

**Note:** To be able to connect any virtual device to a real one, you should have system privileges to access the real device. Otherwise, the real device will not appear in the list of available devices even though it is installed on your computer.

Adding a New Device to a Virtual Machine

1. Choose **Configure** from the **Virtual Machine** menu to open Virtual Machine Configuration.
2. Click the **Hardware** button at the top of the **Virtual Machine Configuration** dialog to open the pane for editing hardware devices.
3. Click the **Add** button in the bottom part of the **Virtual Machine Configuration** dialog and select the device to be added to your virtual machine.

**Note:** The **Add** button is disabled when the virtual machine is running. You need to stop the virtual machine before you can use this button.
If you selected any device except for a hard disk, the corresponding device with a typical configuration is added at once and ready for use.

If you selected a hard disk, you should specify some parameters:

- The hard disk type: a new image file or an existing one. Select Boot Camp if you want to add an existing Boot Camp partition as a hard disk to your virtual machine.

- The hard disk location. Provide the path on your Mac to the existing image file or the path and name for the new image file. By default, Parallels Desktop offers to save the new image file in the virtual machine PVM bundle.

- The hard disk size for the new hard disk image file.

- For the new hard disk image file, you can choose one of the following formats: Expanding or Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk, clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split the disk image to 2 GB files option. For more information on hard disk formats, refer to Support for Virtual and Real Disks (p. 179).

Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it. For detailed information on how to initialize the newly added hard disk, see Initializing the Newly Added Disk (p. 181).

After the new device is added, you can manage its properties as usual and start using it.

**Removing Devices From the Virtual Machine Configuration**

1. Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration.

2. Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the pane for editing hardware devices.

3. Select the device you want to remove and click the Remove button in the bottom part of the Virtual Machine Configuration dialog.
Support for Virtual and Real Disks

This section lists the types of disks that can be used by Parallels virtual machines and provides the information about basic operations you can perform on these disks.

Supported Types of Hard Disks

Parallels virtual machines can use either virtual hard disks or Boot Camp partitions as their hard disks.

Virtual Hard Disks

The capacity of a virtual hard disk can be set from 100 MB to 2 TB.

Virtual hard disks can be of either plain or expanding format.

<table>
<thead>
<tr>
<th>plain</th>
<th>A plain virtual hard disk image file has a fixed size. The size is determined when the disk is created. Plain disks can be created with the help of New Virtual Machine wizard (the Custom mode.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>expanding</td>
<td>An expanding virtual hard disk image file is small initially. Its size grows as you add applications and data to the virtual hard disk in the guest OS.</td>
</tr>
</tbody>
</table>

When you create a virtual machine, the disk is created in the expanding format. You can change the disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain hard disk to your virtual machine, clear the Expanding disk option when adding a hard disk to the virtual machine.

Split disks

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB pieces and is stored as a single .hdd file.

Boot Camp Partitions

With Parallels Desktop, you can choose how to use your Boot Camp Windows XP, Windows Vista, or Windows 7 operating system: to boot in it natively (via Boot Camp) or in a virtual machine (via Parallels Desktop). A Boot Camp Windows partition can be used as a bootable disk or as a data disk in Parallels virtual machines. For detailed information, see Using the Boot Camp Partition in a Virtual Machine.

**Note:** You cannot create snapshots or use the Undo Disks option for a virtual machine that uses the Boot Camp partition.
CD/DVD Discs and Their Images

Parallels Desktop can access real CD/DVD discs and images of CD/DVD discs.

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can play back audio CDs without any limitations on copy-protected discs.

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a virtual machine.

Parallels Desktop supports CD/DVD disc images in the ISO, CUE, and CCD formats.

**Note:** DMG disk images made with Mac OS X Disk Utility are also supported by Parallels Desktop. When creating such an image, make sure you create a *read-only* and *uncompressed* image without any encryption.

Floppy Disks and Floppy Disk Images

Parallels Desktop can use two types of floppy disks:

- Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine.
- Floppy disk image files having the `.fdd` extension and connected to the virtual machine.

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy disk image files that have the `.fdd` extension and 1.44 MB size.
Initialize a Newly Added Disk

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it.

Initializing the New Virtual Hard Disk in Windows

To initialize a new virtual hard disk in a Windows guest OS, you will need the Disk Management utility available. For example, in Windows 7 and Windows XP you can access this utility by doing the following:

- In Windows 7, click Start > Control Panel > System and Security > Administrative Tools > Computer Management > Storage > Disk Management.
- In Windows XP, click Start > Control Panel > Administrative Tools > Computer Management > Storage > Disk Management.

When you open the Disk Management utility, it automatically detects that a new hard disk was added to the configuration and launches the Initialize and Convert Disk wizard:

1. In the introduction window, click Next.
2. In the Select Disks to Initialize window, select the newly added disk and click Next.
3. In the Select Disks to Convert window, select the newly added disk and click Finish.

The added disk will appear as a new disk in the Disk Management utility window, but its memory space will be unallocated. To allocate the disk memory, right-click this disk name in the Disk Management utility window and select New Simple Volume in Windows Vista or New Volume in Windows XP. The New Simple Volume Wizard/New Volume Wizard window will appear. Follow the steps of the wizard and create a new volume in the newly added disk.

After that your disk will become visible in Computer/My Computer and you will be able to use it as a data disk inside your virtual machine.

Initializing the New Virtual Hard Disk in Linux

Initializing a new virtual hard disk in a Linux guest OS comprises two steps: (1) allocating the virtual hard disk space and (2) mounting this disk in the guest OS.

To allocate the space, you need to create a new partition on this virtual hard disk using the fdisk utility:

```
Note: To use the fdisk utility, you need the root privileges.
```

1. Launch a terminal window.
2. To list the IDE disk devices present in your virtual machine configuration, enter:

```
fdisk /dev/hd*
```
## Advanced Topics

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Command/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>By default, the second virtual hard disk appears as <code>/dev/hdc</code> in your Linux virtual machine. To work with this device, enter:</td>
<td><code>fdisk /dev/hdc</code></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If this is a SCSI disk, use the <code>fdisk /dev/sdc</code> command instead.</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>To get detailed information about the disk, enter:</td>
<td><code>p</code></td>
</tr>
<tr>
<td>5</td>
<td>To create a new partition, enter:</td>
<td><code>n</code></td>
</tr>
<tr>
<td>6</td>
<td>To create the primary partition, enter:</td>
<td><code>p</code></td>
</tr>
<tr>
<td>7</td>
<td>Specify the partition number. By default, it is 1.</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Specify the first cylinder. If you want to create a single partition on this hard disk, use the default value.</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Specify the last cylinder. If you want to create a single partition on this hard disk, use the default value.</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>To create a partition with the specified settings, enter:</td>
<td><code>w</code></td>
</tr>
</tbody>
</table>

When you allocated the space on the newly added virtual hard disk, you should format it by entering the following command in the terminal:

```
mkfs -t <FileSystem> /dev/hdc1
```

**Note:** `<FileSystem>` stands for the file system you want to use on this disk. It is recommended to use ext3 or ext2.

When the added virtual hard disk is formatted, you can mount it in the guest OS.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Command/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>To create a mount point for the new virtual hard disk, enter:</td>
<td><code>mkdir /mnt/hdc1</code></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You can specify a different mount point.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>To mount the new virtual hard disk to the specified mount point, enter:</td>
<td><code>mount /dev/hdc1 /mnt/hdc1</code></td>
</tr>
</tbody>
</table>

When you mounted the virtual hard disk, you can use its space in your virtual machine.
Hardware Settings

Using the **Virtual Machine Configuration** dialog, you can configure the virtual hardware available in your virtual machine:

- Configure the devices currently available inside the virtual machine.
- Add or remove devices.
- Configure the boot order of your virtual machine.

Boot Order

Using the **Boot Order** settings, you can configure the virtual machine boot sequence, that is, the order in which the virtual machine will try to load the operating system from different boot devices.

**Note:** These settings cannot be changed when the virtual machine is running.

To edit the **Boot Order** settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select **Boot Order** in the sidebar.
Advanced Topics

The currently supported boot devices are listed below:

- **Hard Disk.** Select this device if you want the virtual machine to boot up from its virtual hard disk drive.

- **CD/DVD-ROM.** Select this device if you want the virtual machine to boot up from the media connected to its virtual CD/DVD-ROM drive.

  **Note:** The virtual machine will use the CD/DVD-ROM drive specified as **CD/DVD-ROM 1** in its configuration.

- **Floppy Disk.** Select this device if you want the virtual machine to boot up from a floppy disk image connected to its virtual floppy disk drive.

- **Network Adapter.** Select this device if you want your virtual machine to boot from a network adapter using PXE (Pre-Execution Environment).

  **Note:** The virtual machine will use the network adapter specified as **Network Adapter 1** in its configuration.

Every time you start the virtual machine, it tries to boot from the device specified as the first one in the **Boot Order** list. If the virtual machine cannot boot from the first device (for example, no media is connected to it), the virtual machine proceeds to the second device in the list and tries to boot from this device, and so on.

In this pane, you can perform the following operations:

- Change the currently set boot sequence by selecting the name of the corresponding boot device in the **Boot Order** list and moving it up or down using the arrows to the right of the list.

- Remove a boot device from the sequence by clearing the check box next to its name.

If you choose the **Select boot device on startup** option, you will see the following message at the virtual machine startup: "Press ESC to select boot device". If you press ESC pending 5 seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will try to boot from the devices specified in the **Boot Order** list.

  **Note:** Make sure that the device you wish to use for your virtual machine booting (hard disk drive, CD-ROM drive, floppy disk drive, or network adapter) is available to the virtual machine and configured properly. If you do not have any boot devices configured in your virtual machine, you will see the following error message after you start the virtual machine: “No boot device is available”. In this case, you should stop the virtual machine and configure at least one boot device for it.

The **Boot flags** field is intended for specifying the flags that can change the virtual machine system behavior. The system flags can be used by the Parallels customer support team in cases when something goes wrong in your virtual machine. It is not recommended to type anything into this field without being instructed to do so by the customer support staff.
If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Video**

To view and configure the amount of video memory available to the virtual machine video card, use the Video settings.

To edit these settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select Video in the sidebar.

**Note:** These settings cannot be changed when the virtual machine is running.
In the Video memory field, you can set the amount of video memory that will be available to the virtual machine.

To configure the video memory limit, do one of the following:

- Drag the slider
- Use the spin box arrows
- Type the value directly into the Video memory field

**Enabling 3D Acceleration**

If you want to use Windows Aero in your Windows virtual machines or use games and applications that require video cards that support DirectX or OpenGL, select On or the version of DirectX you need from the 3D acceleration menu.

**Enabling Vertical Synchronization**

Sometimes in games and 3D applications, a newly rendered frame may overlap a previously rendered one and then screen tearing happens. This occurs when the video card or the software using it begins updating the actively-displayed memory in a manner that is out of sync with the monitor’s refresh rate. To prevent screen tearing, select the Enable vertical synchronization option.

**Working with Windows on Retina Display**

For Windows 8 and Windows 7:

If you’re working with Windows 7 or Windows 8 on a Mac with a Retina display, you can choose how Windows is displayed on the screen:

- **More Space.** Windows resolution matches that of the Retina display but the DPI (dots per inch) setting doesn’t change. As a result, Windows interface elements and text are clear and sharp, but small. This option is for those who prefer to have more space on the desktop.

- **Best for Retina.** Windows resolution matches that of the Retina display and the DPI setting increases. Windows interface elements and text are clear, sharp, and at full size. This option is supported by Windows 7 and 8 only.

- **Scaled.** Windows resolution and DPI setting don’t change. Instead, Windows is scaled to full size. As a result, Windows interface elements and text are not sharp. This option is useful for Windows applications that don’t support high-DPI settings and appear small onscreen.

For Windows XP:

If you’re working with Windows XP on a Mac with a Retina display, Windows becomes scaled but its resolution doesn’t change. As a result, Windows interface elements and text are not sharp.
However, you can enable full (2880x1800) Retina resolution for Windows by selecting **Enable Retina resolution**. At such a high resolution, Windows interface elements and text become sharp but small.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Floppy Disk**

To view and configure the virtual machine floppy disk drive settings, use the **Floppy Disk** settings.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.
Select the **Connected** option if you want the floppy disk drive or floppy disk image to be automatically connected to the virtual machine on its startup.

In the **Source** field, specify the source device or image file that will emulate the virtual machine floppy disk drive:

- If you want to use a real floppy disk drive, click the **Source** field and select the real device name from the list.
- If you want to use a floppy disk image, click the **Source** field, click **Choose an image file**, and specify the path to the desired floppy disk image file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
CD/DVD-ROM

To configure the virtual machine CD/DVD drive settings, use the **CD/DVD** settings. Virtual CD/DVD drives can be connected either to physical CD/DVD drives or to CD/DVD images.

**Note:** You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog and has its own number.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.
2. In the Virtual Machine Configuration dialog, click **Hardware** and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.
Select the **Connected** option if you want the CD/DVD drive to be automatically connected to the virtual machine on its startup.

To emulate the virtual CD/DVD drive, you can connect one of the real CD/DVD drives on your physical computer or a CD/DVD image file to the virtual machine.

**Note:** Parallels virtual machines support ISO and DMG image files and may support CUE and CCD image files.

In the **Connect to** field, the source device or image file that emulates the virtual machine CD/DVD drive is specified. You can change the source device:

- To use a real CD/DVD drive as the virtual machine CD/DVD drive, click the **Connect to** field and select the real device name from the list.
- To use an image file as the virtual machine CD/DVD drive, click the **Connect to** field and choose the image file from the list, or click **Choose an image file** and specify the path to the desired image file on your Mac.

In the **Location** field, you can specify the type of interface for connecting the device:

- **IDE.** Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD drives).
- **SATA.** Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD drives).

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
**Hard Disk**

To view and configure the virtual hard disk settings, use the **Hard Disk** pane of Virtual Machine Configuration. Parallels Desktop allows virtual machines to use hard disk images in the `.hdd` format and Windows Boot Camp partitions.

**Note:** You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI devices to a virtual machine. Each device is listed separately in the **Virtual Machine Configuration** dialog and has its own number.

To edit the device settings, do the following:

1. Shut down the virtual machine. (p. 42)
2. Open the **Virtual Machine** menu and choose **Configure**.
3. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.
Advanced Topics

In the **Source** field, the virtual hard disk file (\*.hdd) that emulates the virtual machine hard disk is specified. You can change the hard disk source:

- To use the Boot Camp partition as the virtual machine hard disk, click the **Source** field and select the Boot Camp partition name from the list.
- To use a virtual hard disk file as the virtual machine hard disk, click the **Source** field and choose the virtual hard disk file from the list, or click **Choose an image file** and specify the path to the desired image file (\*.hdd) on your Mac.

In the **Location** field, you can specify the type of interface for connecting the device:

- **IDE**. Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD drives).
- **SATA**. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD drives).
- **SCSI**. Using this interface type, you can connect up to 15 virtual devices (hard disks or CD/DVD drives).

**Note 1**: The Mac OS X guest OS does not support the SCSI controller. In the latest Linux distributions (e.g. RHEL 5.3), the SCSI driver may be not installed. In this case, you should install this driver in your Linux guest OS to be able to use the SCSI controller.

**Note 2**: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller itself.

**Compressing the Disk**

If you use an expanding (p. 179) virtual hard disk in your virtual machine, its image file size on the physical hard disk increases as you add new data to the virtual hard disk. When you delete some data from this virtual hard disk, free unused space appears on the disk, but the amount of space your virtual machine occupies on the hard disk of your Mac does not reduce. To free the unused space back to Mac, click the **Compress** button. The virtual hard disk will be compressed and the hard disk image file size will be decreased. As a result, there will be more free space on your Mac hard disk.

**Note**: Compressing can be performed for virtual machines without snapshots and with the Undo disks option disabled.

In the **Optimization** pane of Virtual Machine Configuration, you can enable regular automatic disk compression.

**Editing the Disk**

If you find that the capacity of your virtual machine hard disk does not fit your needs anymore, you can change its size. Click the **Edit** button and the dialog for changing the disk size will appear.
**Note:** If your virtual machine is running, has snapshots, or uses a Boot Camp partition as a hard disk, its virtual hard disks cannot be resized.

To change the disk size, drag the slider or type the new size in the **Size** field. Select the **Resize file system** option if you want to change the file system size:

- If you select the **Resize file system** option when increasing the disk size, the additional disk space will be added to the last volume. If you clear the **Resize file system** option, the added space will appear as unallocated space and will be invisible to the guest operating system. To allocate this space, you will have to either create a new partition or expand an existing partition. For instructions on allocating the added space, please refer to the guest OS documentation.

- If you select the **Resize file system** option when decreasing the disk size, the disk will be decreased via removing the unallocated space and decreasing the size of the disk partitions. If you clear the **Resize file system** option when decreasing the disk size, you will be able to remove the unallocated space of the disk only and the disk partitions will remain untouched.

If the format of the virtual hard disk is *expanding*, you can convert it to *plain* by clearing the **Expanding disk** option.

If you want the virtual hard disk to be split, select the **Split the disk image into 2 GB files option** option.

**Note:** For more information about virtual hard disk types, please refer to *Support for Virtual and Real Disks* (p. 179).

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Network Adapter

Using the Network settings, you can change the network type used in your virtual machine.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.
Select the **Connected** option if you want the virtual machine to start up with this network adapter connected.

You can choose one of the following network types for the virtual machine network adapter:

- **Shared Network.** Select this option to enable the Network Address Translation (NAT) feature for the virtual machine. In this case, your virtual machine will share whatever network connection is currently used by the host computer.
  
  See [Shared Network](#) to learn how to configure this network type.

- **Bridged Network.** Select this option to allow the virtual machine to access the local network and Internet through one of the network adapters installed on the host computer. In this case, the virtual machine is treated as a stand-alone computer on the network and should be configured in the same way as a real one. You can choose the physical adapter where the virtual machine adapter will be bridged in the list below the **Bridged Network** option.

  See [Bridged Ethernet Network](#) to learn how to configure this network type.

- **Host-Only Network.** Select this option to allow the virtual machine to connect to the host computer and the virtual machines residing on it and to make it invisible outside the host computer.

  See [Host-Only Network](p. 105) to learn how to configure this network type.

In the **MAC address** field, you can change the MAC address currently assigned to the virtual machine. MAC addresses are automatically generated during the virtual machine creation. However, you can modify the default MAC address by typing another value in the **MAC address** field or clicking the **Generate** button. When entering a new MAC address, make sure that it is unique within your network.

### Wi-Fi Bridging Support

To be able to connect to wireless networks from your virtual machine:

1. Click the **Type** field.
2. Choose the **AirPort** adapter from the **Bridged Network** list, and click **OK** to apply the changes.

After you perform these steps, your virtual machine will be able to connect to the Internet through the AirPort adapter of your Mac.

When you try to connect to the Internet via Wi-Fi, and the Wi-Fi Access Point has the **Validate DHCP packets** option enabled, you may experience problems connecting to the Internet. In this case, enable the **Send the host's MAC address to DHCP server** option to ensure that your virtual machine gets an IP address for accessing the Internet.

**Note:** Enabling the **Send the host's MAC address to DHCP server** option will not work with some DHCP servers - your virtual machine may get the same IP address as the physical computer.
Advanced Topics

If you cannot configure your virtual machine to work in the Bridged Ethernet mode, you can consider using another network mode: Shared Network mode or Host-Only Network mode.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

Printer Port

Using the Printer Port settings, you can configure the virtual machine printer port settings. A virtual machine can have up to three printer ports.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.
Select the **Connected** option if you want the virtual machine to start up with the printer port connected.

In the **Port** field, choose the port type. If available, you're recommended to use the **USB** port type. Connecting a printer to a virtual machine via USB ensures faster data transfer rate than connecting it via LPT.

**Notes:**

1. You can connect up to 6 USB and up to 3 LPT printers to a single virtual machine.

2. You can connect a USB printer only if your virtual machine has a **USB controller** (p. 202). If not, you can easily add it (p. 177).

In the **Source** field, the source device that emulates this printer port is specified. A printer port can be emulated by one of the following devices:

- **Printers.** You can use any of the printers connected to your Mac in your virtual machine. Click the **Source** field and select the appropriate printer from the list.

  For the detailed information on how to set up a printer in your virtual machine, please refer to **Print from Windows** (p. 87).

- **Real printer port.** If your Mac has a physical printer port, you can connect it to your virtual machine. Click the **Source** field and select the physical port name from the list.

- **Output File.** You can emulate the virtual machine printer port by using an output file. Click the **Source** field and choose an output file from the list, or click **Choose an output file** and specify the path to the desired output file on your Mac.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the **Lock** icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Serial Port

In the Serial Port pane, you can configure the virtual machine serial port settings.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.

   **Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.

Using serial ports, you can establish a connection between:

- The virtual machine and the host computer devices (using a real port); or
- Between two virtual machines located on the same host computer (using a socket).

If you want to connect your virtual machine to the host computer device, you should create a serial port emulated by a real port. The Source list comprises the devices on the host computer that are available for connection. The connected device, being used in any virtual machine, cannot be used by the host computer. To be able to use it in the host computer, you should first disconnect it from the virtual machine. To do that, use the virtual machine status bar.

If you want to connect two virtual machines with each other, you need to create a serial port emulated by a socket in each virtual machine. The names of the serial ports should be identical. The connection between the virtual machines via serial ports is bidirectional. It means that the working modes of the sockets set during the port creation can be changed later in the Serial Port pane.

If you need to log the performance activity of your virtual machine or to record the data from it and use this information later on, you can connect your virtual machine serial port to an output file on the physical computer. You will be able to view and analyze the activity history of the virtual machine any time you need by exploring this file.

You can add a new serial port to your virtual machine using Add Hardware Assistant. For the instruction on how to add serial ports, refer to Adding and Removing Devices.

   **Note:** You can connect up to four serial ports to a virtual machine.
Select the **Connected** option if you want the virtual machine to start up with the serial port connected.

In the **Source** field, the source device that emulates this serial port is specified. Serial ports can be emulated by the following devices:

- **Real Port.** To connect the virtual machine serial port to one of the existing serial ports on the host computer, choose the appropriate port on the host computer in the **Source** list.

- **Socket.** To connect two virtual machines through the sockets, click the **Source** list and choose the appropriate socket. If there are no sockets available, click **New socket** and specify its name in the **Enter a socket name** field.

You should also configure the role the virtual machine will play in the connection by selecting the necessary role in the **Mode** list. Selecting **Server** enables you to use this virtual machine to direct the other one. Selecting **Client** enables you to direct this virtual machine from the other one.

**Note:** If you change the socket mode of the first virtual machine, make sure the socket mode of the second virtual machine is also modified.

- **Output File.** To connect the virtual machine serial port to an output file, click the **Source** list and choose the appropriate output file. You can also click **Choose an output file** to locate the necessary file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Advanced Topics

Sound

The **Sound** pane of Virtual Machine Configuration allows you to configure the virtual machine sound device parameters.

To edit the device settings, do the following:

1. Click the Parallels icon \(\text{\textregistered}\) in the menu bar, press and hold the Option (Alt) key and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Virtual Machine > Configure**.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.

![Windows 7 - Hardware](image)
Select the **Connected** option to have the sound device automatically connected on the virtual machine startup.

Use the **Input** list to choose the necessary device. You can choose one of the following devices:

- **Default.** Select this option if you want to use the input device set as default in Mac OS.
- **Built-in Microphone.** Select this option if you want to use the built-in microphone.
- **Built-in Input.** Select this option if you want to use one of the input devices from your Mac.
- **Null device.** Select this option if you want to mute the input device.

Use the **Output** list to choose the necessary device. You can choose one of the following devices:

- **Default.** Select this option if you want to use the output device set as default in Mac OS.
- **Built-in Output.** Select this option if you want to use one of the output devices from your Mac.
- **Null device.** Select this option if you want to mute the output device.

Note: If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac, you can use it in Windows (p. 211).

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
USB & Bluetooth

A virtual machine can emulate only one USB controller, which provides you with the possibility to connect up to eight USB 2.0 and five USB 1.1 devices to the virtual machine.

To edit the device settings, do the following:

1. Open the Virtual Machine menu or Alt-click (Option-click) the Parallels icon in the Mac menu bar (in the Crystal view mode) and choose Configure.
2. In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.

In the USB & Bluetooth pane, you can:

- disable camera sharing, and
- enable Bluetooth devices sharing.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Chapter 6

Tips and Troubleshooting

If you’re having trouble using Parallels Desktop, check this section for possible solutions.

If you don’t find the solution to your problem here, see More Resources (p. 218).

In This Chapter

Install Parallels Tools for Seamless Operation Between Windows and Mac OS X...... 204
I Can’t Activate Parallels Desktop ................................................................. 204
Memory Usage Problems ........................................................................ 207
Windows Seems Slow ............................................................................. 208
Pressing Ctrl+Alt+Del ............................................................................. 209
My Password Isn’t Working .................................................................... 209
I’m Having Problems Connecting to the Internet ..................................... 210
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine ................... 211
I’m Having Problems with Antivirus Software ......................................... 213
The F8 Key Isn’t Working Correctly ......................................................... 213
A Password is Required to Open the Virtual Machine Configuration .... 213
Configuring a Network in Linux ............................................................. 214
Installing the GCC Package and Kernel Sources in Linux ..................... 215
Checking the Build Number .................................................................. 215
Report a Problem and Request Support ................................................. 216
Install Parallels Tools for Seamless Operation Between Windows and Mac OS X

Many issues with using Parallels Desktop can be solved by installing Parallels Tools.

Parallels Tools help you work with Windows in the most comfortable and efficient way. With Parallels Tools, you can:

- Move the mouse seamlessly between Windows and Mac OS X
- Synchronize the Windows time and date settings with those of Mac OS X
- Share your Mac OS X disks and folders with Windows
- Copy text and drag and drop objects from Mac OS X to Windows and vice versa

**Important:** Once you install Parallels Tools and restart Windows, you don’t have to do anything else. Parallels Tools automatically just work, without any action or configuration on your part.

To install Parallels Tools:

1. Start Windows (p. 36).
2. Choose Virtual Machine > Install Parallels Tools and follow the onscreen instructions.

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p. 155).

I Can't Activate Parallels Desktop

You must activate Parallels Desktop to be able to use all of its features.

If you are having trouble activating Parallels Desktop, try the following:

- Make sure the activation key you’re using is for the version of the software being installed.
- Make sure you’re entering the key correctly.
  - If you purchased and downloaded Parallels Desktop from the Internet, you received an activation key via email. For best results, copy and paste the key from the email.
  - If you have a boxed copy of Parallels Desktop, the key is printed on the DVD sleeve. Make sure you enter the entire key (30 characters). Dashes are added automatically.
- If your Mac isn’t connected to the Internet, connect it. If you can't connect it, see Activate Parallels Desktop When Your Mac Isn't Connected to the Internet (p. 205).
- If still can’t activate Parallels Desktop, check this Knowledge Base Article for an extended list of solutions.
Activate Parallels Desktop When Your Mac Isn't Connected to the Internet

It's easiest to activate Parallels Desktop if your Mac is connected to the Internet. When you enter your Product Activation Key, Parallels Desktop verifies the key over the Internet. But if your Mac isn't connected to the Internet, there are other ways to activate Parallels Desktop.

If your Mac isn't connected to the Internet when you enter your Product Activation Key, the following window appears:

![Activate Parallels Desktop window](image-url)
Tips and Troubleshooting

To activate Parallels Desktop without an Internet connection, do one of the following:

- If your Mac can or will be connected to the Internet in the future, click **Work Offline** and connect later. You can use Parallels Desktop for 14 days without activating it. Later when you connect to the Internet, Parallels Desktop verifies the key and activates itself.

- Make a note of your activation ID (see above) or copy it to a text file on an external storage device, then do one of the following:
  - From another computer or device that’s connected to the Internet, send the activation ID to the email address shown in the Activation screen (see above). You will receive a Confirmation Code via email. In Parallels Desktop on your Mac, choose **Parallels Desktop > Activate Product** and enter the Confirmation Code.
  - In a web browser on a computer or device with an Internet connection, go to the web address shown in the Activation screen (see above) and enter the activation ID to generate a Confirmation Code. In Parallels Desktop on your Mac, choose **Parallels Desktop > Activate Product** and enter the Confirmation Code.

To change your Product Activation Key, click **Change Key**
**Memory Usage Problems**

The amount of Mac’s physical memory required for each virtual machine operation can be represented as follows:

Virtual Machine Memory = \( \text{Guest OS Memory} + \text{Video Memory} + \text{Virtual Machine Monitor Memory} \)

- **Guest OS Memory** is the amount of RAM available to your guest operating system. You can configure the guest OS memory amount in the General pane (p. 109) of the virtual machine configuration dialog.

- **Video Memory** is the amount of physical memory available to the virtual machine’s video card. You can adjust the video memory amount in the Video pane (p. 185) of the virtual machine configuration dialog.

- **Virtual Machine Monitor** is the module responsible for the guest operating system virtualization. It consumes memory to perform operations of guest virtual devices and performs virtual paging emulation. The amount of memory required for the Virtual Machine Monitor operation depends on the guest OS and varies from 50 MB to 200 MB.

**Memory Overcommitment**

If you have several virtual machines running simultaneously and you are trying to start one more virtual machine, you may come across the memory overcommit. If so, Parallels Desktop informs you with the corresponding message. If you start one more virtual machine, this may significantly slow down all your virtual machines. To solve this problem, you can:

- Stop one or several of your running virtual machines; or
- Edit your virtual machines’ configurations so they consume less memory.
Windows Seems Slow

If Windows performance seems slow, try the following:

- **Quit applications and programs you aren't using:** If you run a number of memory-consuming applications and programs simultaneously, Windows performance may become slow. Quit any applications that you aren’t using. You can also use Activity Monitor (located in the Mac OS X Finder in Applications > Utilities) to see how much of your Mac’s memory each application is using. That way, you’ll have a better idea of which applications cause performance to degrade the most.

- **Change how much memory is allocated to Windows:** Parallels Desktop is set to allocate a certain amount of your Mac’s available RAM memory to Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause Windows programs to slow down because they’re running on top of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS X applications may run well but Windows programs might slow down.

To optimize the performance of both Windows and Mac OS X, set the memory allocated to Windows (p. 109) to be somewhere within the recommended range, indicated by the graphic under the memory slider in the General configuration panel (see below).
• **Antivirus software may slow down your virtual machine**: Windows may become slower after you install antivirus software. To be protected, you have to sacrifice performance.

  **Note**: Do not install more than one Windows antivirus program.

• **Run fewer virtual machines at once**: If you are running multiple operating systems at once using Parallels Desktop, stop one or more of them to improve performance of the others.

• **Run Windows locally**: If you start Windows stored on an external storage device connected to your Mac (for example, an external USB disk drive), its performance will be lower than if it were stored on your Mac.

• **Tune Windows for speed**: To speed up Windows, select **Tune Windows for speed** in the **Optimization** pane (p. 111).

• **Disable log messages**: If you select **Use detailed log messages** in the Advanced pane of Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

### Pressing Ctrl+Alt+Del

As a Windows user, you might know that you can press the Ctrl+Alt+Del key combination to make available troubleshooting options, such as starting the Task Manager or changing a password.

To mimic pressing Ctrl+Alt+Del in Parallels Desktop:

• Press fn+Ctrl+Option+Del.

### My Password Isn't Working

If Parallels Desktop doesn’t accept your password, try the following:

• Be sure that Caps Lock is not on. If Caps Lock is on, an indicator appears in the password field. To turn Caps Lock off, press the Caps Lock key.

• Be sure that the keyboard is set to the correct language. If the keyboard is set to a language that doesn’t belong to the group of Romance languages, an icon in the password field indicates the keyboard language setting.
I'm Having Problems Connecting to the Internet

When you install Windows, it is automatically configured to share your Mac's Internet connection. For details on configuring Windows' network and Internet connection, see the section on connecting to the Internet or a network (p. 103).
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine

If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac (via USB or FireWire), you can use it in your virtual machine. Follow these steps:

Step 1. Configure the sound card in Mac OS X.

Step 2. Select the sound card as the sound output device in the virtual machine configuration.

Step 3. Configure the sound card in the guest operating system.

Configure the sound card in Mac OS X

To configure a sound card in Mac OS X:

3 Start the Audio MIDI Setup application (you can find it in /Applications/Utilities).

4 Select your 5.1 or 7.1 surround-capable sound card and choose the necessary sample rate and bit depth from the Format pop-up menus.

   Note: Make sure these settings match the appropriate settings for the sound card.

5 Click Configure Speakers, select Multichannel and choose the necessary type of output from the pop-up menu.

6 Set this sound card as the default output device in Mac OS X: select it in System Preferences > Sound > Output.

Select the sound card as the sound output device in the virtual machine configuration

After you have configured the sound card in Mac OS X, select it as the sound output device in the virtual machine configuration:

1 Do one of the following:
   • Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Virtual Machine > Configure.

2 Click Hardware and select Sound.

3 Make sure the Connected option is selected.

4 Choose Default from the Output menu.
Configure the sound card in the guest operating system

Configure the sound card in the guest operating system.

In Windows 7/Vista:

1. Click **Start** > **Control Panel** > **Hardware and Sound** > **Sound**.
2. On the **Playback** tab, select **Parallels Audio Controller** and click **Configure**.
3. Select **5.1 Surround** or **7.1 Surround** (depends on your sound card), click **Next** several times, and then click **Finish**.
4. On the **Playback** tab, select **Parallels Audio Controller** again and click **Properties**.
5. Click the **Advanced** tab and choose the sample rate and bit depth.

**Note:** The specified settings shouldn’t be higher than the same settings specified in the Audio MIDI Setup application in Mac OS X (described above).

6. When ready, click **OK** twice.

In Windows XP:

1. Click **Start** > **Control Panel** and double-click **Sound and Audio Devices**.
2. On the **Volume** tab, click **Advanced** in the **Speaker settings** section.
3. On the **Speakers** tab, select the necessary speaker setup.

In Linux:

You can try to follow these general guidelines to use the 5.1 or 7.1 surround-capable sound card in Linux:

1. Click **System** > **Preferences** > **Sound**.
2. On the **Hardware** tab, choose the necessary speaker setup from the **Profile** menu.
I'm Having Problems with Antivirus Software

Because of the close integration between Parallels Desktop and Mac OS X, some Parallels Desktop processes may be detected as malicious by antivirus software installed on your Mac.

To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system scan using the antivirus software, and then if no viruses are detected, add the Parallels Desktop processes to the list of trusted processes. For information on how to do this, refer to your antivirus software Help.

**Important:** The names of Parallels Desktop processes usually start with `prl` or `parallels`.

The F8 Key Isn't Working Correctly

In Mac OS X, the F8 key and Ctrl+arrow key combination are reserved for triggering Spaces (a feature that lets you organize your windows on multiple desktops). Because of this, the F8 key and Ctrl+arrow key may not function correctly with Windows programs.

If you are experiencing this problem, change the Spaces hotkeys settings. See Mac Help for more information. From the Finder, choose Help > Mac Help or Help > Help Center and search for "Spaces."

A Password is Required to Open the Virtual Machine Configuration

In Parallels Desktop 8 activated with the volume license product key, virtual machine configuration can be password protected from being viewed and edited.

So if you’re requested to enter the password to open the virtual machine configuration and you don’t know it, contact the person who gave you this virtual machine (in most cases, it’s your system administrator).
Configuring a Network in Linux

When setting up network in Linux, you may need to configure the DHCP client to send the virtual machine's ID in DHCP requests. For information on how to configure your DHCP client, refer to the DHCP client documentation.

For example, in Red Hat Linux guest OSs, you need to edit the DHCP client configuration file.

1. Open the `dhclient.conf` file and make sure that the following lines are present.

   ```
   interface "eth0" {
       send dhcp-client-identifier 1:<MAC address>;
   }
   ```

2. If there are no such lines, add them manually to the file and save it.

When the `dhclient.conf` file contains these lines, DHCP client sends the virtual machine’s ID to the DHCP server. The DHCP server sends an IP address in response.

Tip

To locate the `dhclient.conf` file, in a terminal, enter:

```bash
strings /sbin/dhclient | grep etc | grep dhclient.conf
```

or:

```bash
rpm -ql dhclient
```
Installing the GCC Package and Kernel Sources in Linux

When installing or upgrading Parallels Tools in a Linux virtual machine, you may need to install the gcc package and kernel sources in your Linux guest OS. Kernel sources can be either downloaded from the Internet or installed from Linux distribution disks.

To install the gcc package and kernel sources in the RHEL/Fedora/CentOS Linux distribution, enter the following command in a terminal:

```
yum install gcc kernel-devel make
```

To install the gcc package and kernel sources in the Debian/Ubuntu Linux distribution, enter the following command in a terminal:

```
apt-get install gcc make linux-headers-$(uname -r)
```

For information on how to install the gcc package and kernel sources in other Linux distributions, refer to the documentation for these distributions.

If you still experience any problems, try to find a solution in Parallels Knowledge Base (http://kb.parallels.com/) or refer to the Parallels support team http://www.parallels.com/en/support/desktop/.

Checking the Build Number

To check the version and build number of the Parallels Desktop software you are using, do one of the following:

- Click the Parallels icon \[\text{Ⅱ}\] in the menu bar, press and hold the Option (Alt) key and choose About Parallels Desktop.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > About Parallels Desktop.

A window appears showing the build number.

**Note:** The window that appears also provides you with other useful information about your copy of Parallels Desktop, including the licensing information and a link to the Parallels support web page.
Report a Problem and Request Support

To help improve the quality of Parallels Desktop, you can send problem reports to Parallels.

If Windows is forced to shut down because of an error, Parallels Desktop automatically opens a **Problem Report for Parallels Desktop** form. If you notice unusual behavior in Parallels Desktop, you can also create a report manually.

To create a problem report:

1. If Parallels Desktop is in Coherence mode, click the Parallels icon in the menu bar and choose **Exit Coherence**.
2. Choose **Help > Report a Problem**.

   Parallels Desktop creates a status report and a screenshot of the software.
3 Select the type of problem you're having from the Specify the problem type menu, and fill out the form.

**Note:** You can review the problem report components that will be sent to the Parallels support team and deselect some of them in the Parallels Problem Report Details window, if desired. To open this window, click See Details.

4 Click Send Report.

Parallels team uses error reports to improve the product quality but doesn't respond to them unless you request support (see below).

**Request Support**

To contact the Parallels support team to request help with your problem:

1 Follow the steps above to create and send a problem report.

2 Click Request Support.

3 Your support code is displayed. Write it down for reference in case you are contacted by Parallels Support.

4 Click Get Support.
For more information and help using Parallels Desktop, see the following resources:

- **Parallels support website**: The Parallels support website (http://www.parallels.com/support/) includes product help files and a FAQ section.

- **Parallels Knowledge Base**: This online resource (http://kb.parallels.com/) has valuable articles about using Parallels Desktop and other Parallels products.

- **Online documentation**: You can find PDF user guides for Parallels Desktop and Parallels Transporter online by choosing Help > Online Documentation.

- **Parallels Command Line Reference Guide**: This document, available on the Parallels Online documentation page, has information on using the prlctl command line utility to manage Parallels Desktop and its virtual machines from a terminal.

- **Parallels API references and the SDK programmer's guide**: These guides for IT-professionals can be found on the Parallels Online documentation page.

**Feedback**

- Parallels welcomes your feedback on how to make our documentation more helpful. You can submit feedback using the Documentation Feedback form on our website (http://www.parallels.com/en/support/usersdoc/).

**In This Chapter**

Visit the Parallels Desktop Twitter and Facebook Pages............................................ 218
Visit the Parallels Convenience Store......................................................................... 219

**Visit the Parallels Desktop Twitter and Facebook Pages**

To keep up with the latest news and updates, you can visit the Parallels Desktop Twitter and Facebook pages. Choose Parallels Desktop > About Parallels Desktop and click Our Twitter or Facebook page.
Visit the Parallels Convenience Store

In the Parallels Convenience store, you can purchase and download various commercial and free applications.

To access this store, do one of the following:

- Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Convenience Store.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose File > Convenience Store.
This glossary defines terms and spells out abbreviations used in Parallels Desktop documentation. References to terms defined elsewhere in the glossary appear in italics.

**Administrator.** A user with administrative privileges.

**Activation key.** A unique set of symbols that activates the Parallels Desktop application on your Mac and lets you use the Parallels Desktop functionality to its full extent.

**Active operating system.** The operating system where Parallels Transporter Agent is launched.

**Active volume:** The volume of the physical source computer that is used as a boot volume for the active operating system.

**Bootable hard disk.** A disk used by the operating system to boot from, usually a disk that has an operating system installed.

**Boot Volume.** A hard disk partition from which the operating system boots.

**Boot Camp partition.** A partition on the hard disk of your Mac that can be used for installing a Windows operating system on it (for Mac host computers only).

**Bridged networking.** Virtual machine network connection mode that enables the virtual machine to appear as any other computer on the network, with its own IP address and network name.

**Coherence.** One of the view modes you can use to work with Windows. When Windows is in Coherence, its desktop is hidden and Windows applications appear on the Mac desktop next to your Mac applications, as if they were all part of a single operating system.

**Configuration file.** A file specifies the virtual machine’s hardware configuration, the devices it uses, and other settings. It is created automatically when you create a new virtual machine. See also PVS file.

**CPU.** Stands for central processing unit. It is an internal part of the computer. See also Processor.

**Crystal.** A variation of the Coherence view mode which provides even tighter integration between Windows and OS X. Not only is the Windows desktop hidden, but also Parallels Desktop menus are not shown in the Mac menu bar. You can easily access settings for Windows and Parallels Desktop using the Parallels icon in the Mac menu bar.

**Disks in the old format.** Disks of virtual machines that were created in Parallels Desktop 2.5 and earlier or Parallels Workstation 2.2.
**Disks in the new format.** Disks of virtual machines that were created or used in Parallels hardware virtualization products starting from version 3.0.

**Expanding format.** A virtual hard disk format. An expanding virtual hard disk image file resides on your host computer and is small initially. Its size grows as you add applications and data to the virtual machine.

**FireWire connection.** A wired connection that enables a high-speed data transmission between computers.

**Guest operating system (guest OS).** An operating system installed inside your virtual machine.

**Host computer:** The computer that is used to run virtual machines. In case of Parallels Desktop for Mac, it is your Mac. In case of Parallels Desktop for Windows or Parallels Desktop for Linux, it is the Windows- or Linux-based physical computer where Parallels Desktop is installed. In the Parallels Transporter documentation, this term may define the computer that hosts the result of migration.

**Hot key.** A user-defined key or combination of keys that provides quick access to applications and commands. See also *Shortcut*.

**HDD file.** During the creation, the virtual machine acquires a virtual hard disk file with the `.hdd` extension. See also *virtual hard disk file*.

**Host-only networking.** Virtual machine network connection mode that creates a private network between the host computer and its virtual machines, which makes the virtual machines available from the host computer only.

**ISO image.** A special file that contains the entire contents of a CD or DVD disc commonly used to install an operating system.

**Image file.** A single file containing the complete contents and structure of a data storage medium or device, such as a hard disk drive, CD, or DVD.

**IP address.** A unique address that is assigned to a physical computer or a virtual machine that participates in computer networking.

**Linux computer.** A physical computer that has a Linux operating system installed.

**Merged disk.** A split disk whose parts were merged into a single disk.

**Migration.** The process of transferring data from a physical computer or a third-party virtual machine into a Parallels virtual machine or virtual disk.

**Modality.** One of the view modes you can use to work with Windows. In Modality mode, the Windows desktop appears in a window and scales in size as you resize the window. Also, you can set this window to always stay on top of other windows, and you can adjust its transparency level so you can see through it when you’re working with other applications.

**OS.** Operating system.
Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual machines on your Mac.

Parallels Mounter. An application that enables you to browse the contents of your virtual machines and virtual hard disks directly in Mac OS X Finder.

Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the primary and the guest operating systems.

Parallels Transporter. An application that uses data of a physical or virtual computer for creating a Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be used with Parallels Desktop.

Parallels Transporter Agent. An application that collects data on a physical computer and transfers it to Parallels Transporter installed on your Mac.

Plain format. A virtual hard disk format. A plain virtual hard disk image file resides on the host computer and has a fixed size that cannot be changed.

Preboot Execution Environment (PXE). An environment to boot computers using a network interface independently of available data storage devices (like hard disks) or installed operating systems.

Primary operating system (primary OS). Operating system that controls the I/O devices of the computer and that is loaded when the physical computer is turned on. It is the operating system of the physical computer where the Parallels Desktop application is installed.

Processor. The central processing unit, or CPU. It is an internal part of the computer.

PVS file. A virtual machine configuration file that contains information about the virtual machine resources, devices and other settings.

Shared networking. Virtual machine network connection mode that allows the virtual machine to use the host computer network connections. In this mode, the virtual machine is invisible to other computers on the network the host computer belongs to.

Shortcut. A user-defined key or combination of keys that provides quick access to applications and commands. See also Hot key.

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to snapshots are stored in a special subfolder in the virtual machine’s folder.

Source computer. The computer from which you are going to migrate data using Parallels Transporter.

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow you to transfer the data stored on a split disk piece by piece using a USB drive or other media that have limited space and cannot store a large virtual hard disk image file.
**Terminal.** In Mac OS and GNU/Linux operating systems, a utility that enables you to access the command line.

**Third-party virtual machine.** A virtual machine created in a third-party virtualization product, that can be converted to a Parallels virtual machine with the help of Parallels Transporter.

**Virtual hard disk (virtual disk).** A file that emulates the virtual machine’s hard disk.

**Virtual Machine.** The computer emulated using Parallels Desktop. A virtual machine has its own virtual hardware and requires an operating system to control its hardware. The installed operating system and its applications are isolated inside the virtual machine and share physical hardware resources of the **host computer**.

**Virtual Machine Configuration.** Like any physical computer, a virtual machine has its own configuration which is set during the creation and can be later modified. The virtual machine configuration settings are stored in a **PVS file**.

**Virtual machine files.** Files stored in a virtual machine folder. A virtual machine has at least two files: **configuration file** and **virtual hard disk file**.

**Virtual hard disk file.** During the creation, the virtual machine acquires a virtual hard disk file with the .hdd extension. This file performs the functions of a real hard disk. See also **HDD file**.

**Virtual machine template.** A virtual machine that can be cloned to multiple virtual machines that will have the same configuration and data that the virtual machine template had.

**VM.** See **Virtual Machine**.

**Windows computer.** A physical computer that has a Windows operating system installed.
Index

3
3D acceleration - 113, 114, 185

A
A Password is Required to Open the Virtual Machine Configuration - 213
About Parallels Desktop - 8
About Using Windows 8 with Parallels Desktop - 57
About Virtual Machines - 121, 126
Acronis Online Backup - 141
Activate Parallels Desktop - 13
Activate Parallels Desktop When Your Mac Isn’t Connected to the Internet - 13, 204, 205
Activating Parallels Desktop - 13
Active corners - 53, 54
Active volume - 220
Adaptive hypervisor - 111
Adding and Removing Devices - 20, 122, 177, 197
Adding devices - 177
Adding virtual machine - 34
Address
   IP address - 24, 31, 92, 103, 104, 107, 115, 167, 170, 173, 194, 214
   MAC address - 103, 104, 105, 194
Adjust Coherence Settings - 49
Adjust Full Screen Settings - 47, 51, 53, 54
Adjust USB Settings - 85
Adjust Window Mode Settings - 52
Administrator - 220
Advanced Preferences - 167
Advanced Settings - 59, 174
Advanced Topics - 10, 118
AirPort, using in virtual machine - 107
Antivirus for Mac - 99
Antivirus for Windows - 99
Apple Remote - 76

Apply Mac OS X Parental Controls to Windows - 73
Apply Separate Network Settings to Windows - 104
Automatic update check - 15

B
Back Up a Virtual Machine - 125
Back up virtual machines - 125
Battery life - 111
Bonjour Printer - 90
Boot Camp partition
   Boot Camp virtual machine - 33
   Importing Boot Camp - 33
Boot order - 183
Boot Order - 183
Bridged Ethernet networking - 104
Browse Virtual Hard Disks in Mac OS X - 127
Browsing virtual machines and disks - 127
Build number - 215

C
CD/DVD-ROM - 41, 61, 189
CD/DVD-ROM drive
   adding/removing - 177
   connecting/disconnecting - 134, 189
   setting up - 189
Change the Virtual Machine Name - 124
Change Virtual Machine Configuration at Runtime - 134
Changing
   configuration at runtime - 134
   default folder for virtual machines - 123
Changing hard disk format - 191
Check Your Virtual Machine CPU and Memory Usage - 139
Checking the Build Number - 215
Chrome OS - 138
Cleaning up unused space - 191
Clone a Virtual Machine - 124, 126
Cloning virtual machine - 124
Coherence - 46, 49
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine - 201, 211
Configuring a Network in Linux - 214
Connect Bluetooth Devices - 87
Connect to the Internet or a Network - 41, 103, 210
Connect USB Devices - 84
Connect Windows to a VLAN - 108
Connecting devices - 51, 177
Connecting USB devices - 84
Control Programs with Trackpad Gestures or the Apple Remote - 76
Converting third-party virtual machines - 34
Copy and Paste Between Mac OS X and Windows - 60
Copying and pasting - 174
CPU, virtual - 139
Create and Use Virtual Machine Templates - 129
Create New Keyboard Shortcuts - 82
Crystal view - 49
Customize Keyboard Shortcuts - 79, 150
Customize the Keyboard for the Guest OS - 81, 148

D
Default Configurations - 122
Default folder for virtual machines - 123
Default key combinations - 79
Deleting virtual machine - 137
Devices
adding - 177
removing from virtual machine - 177
Disk format - 179, 191
Disk size, changing - 191
Dock
adding Windows application to - 37
Documentation feedback - 218
Download Pre-configured Virtual Appliances - 138
DVD-ROM drive
adding - 177
configuring - 189
connecting/disconnecting - 189
removing - 177

E
Enable Spoken Commands - 140
Enabling 3D acceleration - 114
Encrypt Windows to Protect It from Unauthorized Use - 42, 102, 168
Encrypting virtual machine - 102
Exchanging data - 61, 62, 67, 72
Expanding disks - 191

F
Faster virtual machine - 111
Files
sharing files - 62
Firewall problems - 31
Floppy Disk - 187
Floppy disk drive - 187
Folder
for virtual machines - 123
sharing folders - 62
Windows Applications folder - 37
Full Screen mode - 53, 54

G
Gaming - 49, 114, 174, 185
General Tips - 30
Gestures - 76
Get Acronis Online Backup - 125, 141
Get Started - 35
Getting support - 216, 218
Glossary - 220
Guest operating system - 119
definition - 220
installing - 17
supported guest operating systems - 119

H
Hard disk
adding - 177
compressing hard disk - 191
configuring - 191
formats and types - 179
resizing - 191
using Boot Camp as hard disk - 33
viewing hard disk content - 127

Hard Disk - 142, 191
Hardware - 183
Hardware Settings - 183
Hidden messages - 167
Hide and Show Parallels Desktop - 166
Host computer
definition - 220
hardware requirements - 12
software requirements - 12
Host-only network - 105
Host-Only Networking Settings - 167, 173
Hot keys - 79

I
I Can't Activate Parallels Desktop - 204
If Parallels Doesn't Detect Windows Correctly - 31
If Your Mac Fails to Connect with Parallels
Transporter Agent - 24, 31
I'm Having Problems Connecting to the Internet - 210
I'm Having Problems with Antivirus Software - 213
Import from an Earlier Parallels Desktop or Other Virtualization Application - 17, 34, 137
Import Linux and Your Data from a PC - 142
Import Your Data from a PC - 17, 19, 142
 Improve Graphics Performance in Windows NT/98/ME - 147
Increasing hard disk capacity - 191
Initialize a Newly Added Disk - 178, 181
Install or Import Windows - 9, 17
Install or Update Parallels Tools - 55, 56, 127, 139, 152
Install or Upgrade Parallels Desktop - 9, 11
Install Parallels Desktop - 13, 14, 16, 115
Install Parallels Tools for Seamless Operation Between Windows and Mac OS X - 18, 19, 47, 60, 61, 68, 70, 71, 99, 114, 136, 176, 204
Install Software Updates - 15
Install Sound Driver in OS/2 and eComStation - 163
Install Windows 98 - 144
Install Windows from an Installation Disc - 17, 18, 115
Install Windows Programs - 9, 41
Installing
guest operating system - 17
Parallels Desktop - 13
Parallels Tools - 155, 157, 162, 163
Parallels Transporter Agent - 20
Windows 98 - 144
Windows applications - 41
Installing and Upgrading Parallels Tools in Text Mode in Linux - 161
Installing the GCC Package and Kernel Sources in Linux - 157, 215
Internet access - 103
IP address - 24, 92, 103, 104, 115, 167, 170, 173, 194
iPhone - 115
iSight camera - 96
Isolate Mac OS X from Windows - 70, 100
Isolating virtual machine - 100

K
Keyboard and mouse
keyboard preferences - 79
keyboard profiles - 148
keyboard shortcuts - 79, 136
Keyboard shortcuts - 79, 136

L
Linux
installing Parallels Tools - 157
printers in - 87
supported versions - 119
Log messages - 167

M
MAC address - 103, 104, 105, 194
MacLook theme - 60
Making snapshots - 131
Manual update check - 15
Memory
Index

in virtual machine - 109
required on host computer - 12
troubleshooting - 208
video memory - 185
Memory Usage Problems - 207
Merge Windows and Mac OS X - 36, 46, 57, 82, 83, 150
Migration - 19
  over network or FireWire - 24
  through USB cable - 21
  using external storage device - 27
Migration from PC - 19
Modality Mode - 53, 164
Modality view - 164
Monitoring Windows in a Scalable Window - 53
More Resources - 10, 203, 218
Mouse, Trackpad, and Keyboard - 73
My Password Isn’t Working - 209

N
Network adapter
  adding - 177
  connecting and disconnecting - 194
  networking in virtual machine - 103
Network Adapter - 194
Network printer - 92
Networking
  Bridged - 104
  Host-only - 105
  Shared (NAT) - 103
  WiFi - 107

O
Open a Windows Program - 18, 36, 37, 44
Open the Current Safari Page in Internet Explorer - 72
OpenGL - 114, 185
Operating system
  installing in virtual machine - 17
  supported guest OSs - 119
Optimization Settings - 100, 111, 209
Optimize 3D Graphics Performance on a MacBook Pro - 113
Optimize Performance - 108
Other Operating Systems - 10
Over a Network - 19, 24
Overview of Methods for Importing - 19

P
Parallels Desktop
  activating - 13
  installing - 13
  registering - 13
  uninstalling - 166
  updating - 15
  upgrading - 14
Parallels Mounter - 125
Parallels network adapter - 194
Parallels Tools
  installing in Linux - 157
  installing in Mac OS X - 162
  installing in Windows - 155
Parallels Tools for Linux - 143, 157
Parallels Tools for Mac - 151, 162
Parallels Tools for Windows - 83, 155, 204
Parallels Tools Overview - 153
Parallels Transporter Agent - 20
  installing - 20
Parallels virtual appliances - 138
Parental control - 73
Password protection - 101, 102
Pause Windows When No Programs Are Open - 114
Pausing virtual machines - 42
Permanent activation key - 13
Plain disks - 179
Power, saving - 111
Pre-configured virtual appliances - 138
Pressing Ctrl+Alt+Del - 209
Primary operating system
  definition - 220
  supported primary OSs - 12
Print from Windows - 87, 197
Printer
  setting up a Bonjour printer - 90
  setting up a network printer - 92
  setting up a USB printer - 95
  sharing Mac printer - 88
Printer port - 196
Printer Port - 196
Problem report - 216
Problems Using a Program After an Import - 32
Protect Your Data - 98
Protect Your Data from Viruses - 99
Protecting virtual machine by password - 101, 102

Q
Quickly Free Up Disk Space - 113, 142

R
Reducing disk size - 191
Register Parallels Desktop - 14
Registration - 13
Remapping keys - 79
Remove a Virtual Machine - 137
Remove Parallels Desktop - 166
Removing devices - 177
Parallels Desktop - 166
virtual machine - 137
Report a Problem and Request Support - 216
Reporting problems - 216
Requirements for Importing Your Data - 20
Resuming virtual machines - 42

S
Safe Mode - 100
Save a Picture of the Screen - 116
Save Snapshots of a Virtual Machine - 33, 101, 131
Screen Resolution - 54, 185
Screen shots for problem reports - 216
Screen tearing prevention - 185
Searching Parallels disks - 127
Security settings - 100, 101, 102
See and Change Windows Input Language In OS X - 83
Serial port - 198
Serial Port - 198
Set a Program to Open When You Insert a CD or DVD - 61
Set Files to Open in the Application or Program of Your Choice - 69
Set How Many Processors are Allocated to a Virtual Machine - 139
Set How Much Memory is Allocated to Windows - 109, 139, 207, 208
Set How Windows Works with Mac OS X - 45
Set Password Requirements - 101
Set the Appearance of the Parallels Desktop Dock Icon - 117
Set the Guest OS Type and Version - 139
Set the Language - 16
Set Up a Network Printer - 92
Set Up a Printer Using Bonjour - 90
Set Up a USB Printer - 95
Set Up Your Mac to Use Windows Programs - 9
Set Where New Virtual Machines Are Stored - 123
Set Windows to Look Like Mac OS X - 60
Set Windows to Take Up the Whole Screen - 53
Set Your Mouse or Trackpad to Right(Middle)-Click - 74
Setting Internet Links to Always Open in Mac OS X or Windows - 71
Setting up a printer - 87, 88, 90, 92, 95
Share a Printer Connected to Your Mac - 88, 95
Share Applications and Programs - 40, 61, 67, 70
Share External Storage Devices and Volumes - 72
Share Files and Folders - 62, 65, 67
Share Items Between Mac OS X and Windows - 61
Share Network Settings Between Mac OS X and Windows - 92, 103, 171
Shared applications - 67
Shared folders - 62
Shared network (NAT) - 103
Shared Networking Settings - 167, 170
Shared web applications - 71
Sharing files and folders - 62
Windows disks to Mac - 62
Shortcuts for applications - 79, 136
Show a Presentation on an External Monitor or Projector - 97
Show applications in the Dock - 37
Shut Down or Suspend Windows - 42, 101, 109, 114, 139, 191
Shutting down virtual machine - 42
Virtual hard disk
  - adding new virtual disk - 177
  - backing up data - 125, 131
  - changing format - 191
  - configuring - 191
  - increasing capacity - 191
  - types of disks - 179

Virtual machine
  - backing up - 125
  - cloning - 124
  - creating - 17
  - deleting - 137
  - pausing - 42
  - resuming - 42
  - saving state - 131
  - shutting down - 42
  - starting - 36
  - suspending - 42
  - typical configurations - 122

Virus protection - 99

Visit the Parallels Convenience Store - 219
Visit the Parallels Desktop Twitter and Facebook Pages - 218

VMware virtual machine
  - using in Parallels Desktop - 34

W

Web applications - 71
Welcome to Parallels Desktop - 8
What You Can Do - 9
What You Need - 12
WiFi - 107, 115, 194
Window view mode - 50, 51, 52
Windows Aero - 49, 185
Windows applications
  - adding to Dock - 37
  - Windows applications folder - 37
Windows Seems Slow - 208
Work in Windows Without Saving Changes - 100
Work with Virtual Machines - 118