Contents

Welcome to Parallels Desktop ................................................................. 9
  What You Can Do ................................................................................. 9
  Set Up Your Mac to Use Windows Applications ............................... 10
  Other Operating Systems ................................................................. 10
Install or Upgrade Parallels Desktop ...................................................... 11
  What You Need .................................................................................. 11
  Install Parallels Desktop ................................................................. 12
  Activate and Register Parallels Desktop .......................................... 12
  Purchase Parallels Desktop ............................................................. 14
  Upgrade Parallels Desktop ............................................................... 14
    Install Software Updates .............................................................. 15
Set the Language .................................................................................. 16
Install or Import Windows ...................................................................... 17
  Install Windows ............................................................................... 17
Import Your Data from a PC ............................................................... 19
  Overview of Methods for Importing .............................................. 19
  Requirements for Importing Your Data ......................................... 19
  Step 1: Install Parallels Transporter Agent on Your Windows PC ........ 19
  Step 2: Import Your Data ................................................................. 20
Solving Problems .................................................................................. 25
Use Boot Camp with Parallels Desktop ............................................. 27
Import from an Earlier Parallels Desktop or Other Virtualization Application ......................................................... 29
Download and Install Windows From Microsoft ........................... 29
Use Windows on Your Mac ............................................................... 30
  Get Started....................................................................................... 30
    Start Windows ............................................................................... 30
    Open a Windows Application ...................................................... 31
    Install Windows Applications ....................................................... 34
    Shut Down or Suspend Windows .................................................. 35
Set How Windows Works with macOS ........................................... 38
    Merge Windows and macOS ...................................................... 39
Contents

Set Windows to Appear in a Single Window ................................................................. 41
Set Windows to Take Up the Whole Screen .............................................................. 42
Set an Application to Open When You Insert a CD or DVD ..................................... 46
Share Items Between macOS and Windows .............................................................. 46
Apply macOS Parental Controls to Windows ............................................................ 62
Mouse, Trackpad, and Keyboard ............................................................................. 62
Set Your Mouse or Trackpad to Right-Click and Middle-Click ................................ 63
Control Applications with Trackpad Gestures ......................................................... 64
Use Keyboard Shortcuts ......................................................................................... 66
Customize Keyboard Shortcuts ................................................................................ 66
Create New Keyboard Shortcuts ............................................................................. 69
See and Change Windows Input Language In macOS ............................................. 70
Mouse & Keyboard Settings ..................................................................................... 71
Connect External Devices ........................................................................................ 73
Adjust Devices Settings .......................................................................................... 75
Connect Bluetooth Devices .................................................................................... 77
Print from Windows .................................................................................................. 78
Share a Printer Connected to Your Mac ................................................................... 78
Set Up a Printer Using Bonjour ................................................................................ 80
Set Up a Network Printer ......................................................................................... 81
Set Up a USB Printer ............................................................................................... 84
Create a PDF File ...................................................................................................... 85
Use the Built-in iSight Camera or Another Webcam ............................................... 85
Show a Presentation on an External Monitor or Projector ...................................... 86
Protect Your Data ...................................................................................................... 87
Isolate Windows from Mac ....................................................................................... 87
Work in Windows Without Saving Changes ............................................................. 87
Set Password Requirements .................................................................................... 88
Encrypt Windows to Protect It from Unauthorized Use ........................................... 88
Connect to the Internet or a Network ...................................................................... 89
Share Network Access Between macOS and Windows ........................................... 89
Apply Separate Network Settings to Windows ....................................................... 90
Use Host-Only Network Settings ........................................................................... 92
Use Wi-Fi with Windows .......................................................................................... 92
Connect Windows to a VLAN .................................................................................. 93
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shortcuts Preferences</td>
<td>154</td>
</tr>
<tr>
<td>Devices Preferences</td>
<td>159</td>
</tr>
<tr>
<td>Security Preferences</td>
<td>161</td>
</tr>
<tr>
<td>Network Preferences</td>
<td>162</td>
</tr>
<tr>
<td>Advanced Preferences</td>
<td>166</td>
</tr>
<tr>
<td>Parallels Toolbox</td>
<td>167</td>
</tr>
<tr>
<td>Parallels Access</td>
<td>168</td>
</tr>
<tr>
<td>Virtual Machine Settings</td>
<td>169</td>
</tr>
<tr>
<td>General Settings</td>
<td>169</td>
</tr>
<tr>
<td>Options</td>
<td>170</td>
</tr>
<tr>
<td>Hardware Settings</td>
<td>191</td>
</tr>
<tr>
<td>Security Settings</td>
<td>209</td>
</tr>
<tr>
<td>Backup Settings</td>
<td>211</td>
</tr>
<tr>
<td>Adding and Removing Devices</td>
<td>212</td>
</tr>
<tr>
<td>Support for Virtual and Real Disks</td>
<td>214</td>
</tr>
<tr>
<td>Initialize a Newly Added Disk</td>
<td>216</td>
</tr>
</tbody>
</table>
Tips and Troubleshooting ........................................................................................................219
  Install Parallels Tools for Seamless Operation Between Windows and macOS ..................219
  Find Settings .....................................................................................................................220
  Restore Virtual Machine Default Settings .......................................................................220
  Memory Usage Problems .................................................................................................221
  Windows Seems Slow .....................................................................................................221
  Pressing Ctrl+Alt+Del ....................................................................................................222
  My Password Isn't Working ...........................................................................................222
  Boot Windows Securely .................................................................................................223
  My Virtual Machine Doesn't Boot ..................................................................................223
  I'm Having Problems Connecting to the Internet ............................................................223
  I'm Having Problems with Antivirus Software ...............................................................224
  The F8 Key Isn't Working Correctly .................................................................................224
  A Password is Required to Open the Virtual Machine Configuration ..............................224
  Windows or Windows Applications Ask for Reactivation ...............................................224
  Manage Virtual Machines via Command Line Interface ................................................225
  Change Password in Windows via Command Line Interface ........................................226
  Checking the Build Number ..........................................................................................226
  Send Technical Data to Parallels ....................................................................................226

More Resources ...................................................................................................................228
  Visit the Parallels Desktop Twitter and Facebook Pages ..............................................228

Glossary ..............................................................................................................................229

Index ................................................................................................................................233
You no longer have to choose between the Mac and the PC. Parallels Desktop lets you use Windows side-by-side with macOS on your Mac.

Use this guide to quickly set up and start using Parallels Desktop 14 for Mac.

In This Chapter

What You Can Do ................................................................. 9
Set Up Your Mac to Use Windows Applications ....................... 10
Other Operating Systems ...................................................... 10

What You Can Do

With Parallels Desktop, you can:
Welcome to Parallels Desktop

- Open Windows applications side-by-side with your macOS applications, without having to restart
- Copy and paste text and drag and drop files between Mac and Windows applications
- Run Windows games and other 3D applications
- Transfer all your data from a PC and use it on your Mac
- Easily share files, devices, and other resources between Windows and the Mac
- Install different operating systems, such as Windows, Linux, macOS, free virtual appliances and use them together
- And much more

Set Up Your Mac to Use Windows Applications

After just a few steps, you can begin using Windows applications on your Mac. Setting up your Mac to run Windows applications involves the following steps:

Step 1: Install Parallels Desktop on your Mac (p. 11).

Step 2: Install Windows in a virtual machine (p. 17).

Step 3: Install your Windows applications in Windows (p. 34).

You only need to follow these steps once. Then you can open and use your Windows applications on your Mac anytime you like, just as you do with your Mac applications.

Other Operating Systems

**Important:** This guide is focused on using Parallels Desktop with Windows.

Using Parallels Desktop for Mac you can run several other kinds of operating systems (p. 104) on your Mac, such as several flavors of Linux and Unix, macOS Server, Windows 10 and earlier versions of Windows, and more.

Finding Information On Running Other Operating Systems

You can find much more information and details on using Parallels Desktop to run other operating systems on your Mac by checking the resources listed in More Resources (p. 228).

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply to supported operating systems other than Windows. And some important instructions relating to other operating systems are in the Advanced Topics (p. 104) section.
Follow the instructions in this chapter to install or upgrade Parallels Desktop.

**Note:** You can either purchase a boxed version of Parallels Desktop or purchase and download it from the Parallels website.

**In This Chapter**

- What You Need ..................................................................................................... 11
- Install Parallels Desktop ......................................................................................... 12
- Activate and Register Parallels Desktop ................................................................ 12
- Purchase Parallels Desktop ................................................................................... 14
- Upgrade Parallels Desktop .................................................................................... 14
- Set the Language .................................................................................................... 16

**What You Need**

To install and set up Parallels Desktop 14 for Mac, you need:

- A Mac computer with:
  - A Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7, Intel Core M or Xeon processor.
  - At least 4GB of RAM (8GB recommended)
  - At least 850 MB of space available on the boot volume (the volume that has macOS) for Parallels Desktop installation
  - Enough free disk space for each virtual machine and its applications (at least 15 GB for each installation of Windows)
  - macOS High Sierra 10.13 (when available), macOS Sierra 10.12 or later, OS X El Capitan 10.11.5 or later.
    To identify your computer's processor, memory, and macOS version, choose Apple menu > About This Mac.
  - Internet connection required for product activation, select features, and online updates
- One of the following:
  - Windows installation media.

**Note:** If you don't have Windows, Parallels Desktop can help you download and install Windows 10.
Install or Upgrade Parallels Desktop

- An Internet connection to download and install freely available operating systems such as Ubuntu, Fedora or other Linux systems supported by Parallels Desktop.
- A macOS recovery partition that can be used to create a virtual machine with the guest version of macOS.
- A Windows computer to transfer to a virtual machine and use it on your Mac alongside macOS.
- The Boot Camp partition with Windows to create a Boot Camp-based virtual machine.

For a list of operating systems that Parallels Desktop supports for use with your Mac, see Supported Guest Operating Systems (p. 104) or go to http://www.parallels.com/products/desktop/system-requirements/.

Install Parallels Desktop

You can be up and running with Parallels Desktop in a few easy steps:

1 Make sure you have the latest version of macOS.

2 Do one of the following:
   - If you downloaded Parallels Desktop from the Parallels website, double-click the disk image file, most likely in your Downloads folder.
   - If you purchased a boxed copy of Parallels Desktop with a USB thumb drive, connect the drive to your Mac, open it and double-click the disk image file.
   - If you purchased a boxed copy with a link to the installation file, open the link in your web browser, download Parallels Desktop and double-click the disk image file.
   - If you purchased a boxed copy with an installation disc, insert the disc.

   **Note:** If your Mac doesn't have a DVD-ROM, you can use the download link, available in the retail box, to download Parallels Desktop over the Internet.

3 Double-click the Install icon and follow the onscreen instructions to install Parallels Desktop.

Activate and Register Parallels Desktop

After the installation, activate and register Parallels Desktop. Do the following:
1 Sign in to your Parallels account:

Parallels account allows you to:

- store your product activation keys - you will never forget or lose them;
- prevent anyone but you from using your license keys;
- manage your subscriptions to Parallels products;
- contact the Parallels Support and track your support requests;
- download the latest versions of Parallels products and accompanying documentation;
- get info about the latest updates to your products and beta versions of new products;
- work with remote computers via a web browser (as a Parallels Desktop user, you will get Parallels Access for free);
- manage Parallels Desktop licenses on the Macs belonging to your company (if you use Parallels Desktop for Mac Business Edition).

To sign in, do one of the following:

- If you have an account, select I have a password, enter your email and password and click Sign In.
- If you don't have a Parallels account, select I am a new user, enter an email address that will be used to create the account, your name, password and click Create Account.

2 In the next step, enter your Product Activation Key to activate Parallels Desktop.

Note: If you purchased Parallels Desktop from the Parallels Online Store, a key was sent to the email address you provided. If you bought a boxed copy, you can find your key printed on the installation disc sleeve.
Install or Upgrade Parallels Desktop

If you already have a license available and associated with your account, just select the license and click Activate.

If You Don't Have A Product Activation Key

If you don't have a key already, you can get a free trial Product Activation Key so you can try out Parallels Desktop for a limited time, click Try Free for 14 days. Or to purchase a key that lets you use Parallels Desktop permanently, click Buy.

Purchase Parallels Desktop

If you're using a trial version of Parallels Desktop 14, you can easily purchase the full version right from the application interface. To do so:

1  Click Buy in the About Parallels Desktop window or when you see the promo.
2  Choose one of the following:
   •  Upgrade: Select this option to upgrade your current version of Parallels Desktop. Please keep in mind that you will need the activation key for your previous version. If the Upgrade option is selected by default, Parallels Desktop has already automatically detected the key for the previous version. If not, please make sure you have it.
   
   **Note:** Only Parallels Desktop 12 and 13 can be upgraded to Parallels Desktop 14.
   •  Buy Full Version: Select this option to purchase Parallels Desktop if you have never used it before or your version cannot be upgraded.
3  Follow the onscreen instructions. You may need to scroll down to see all the information.

Upgrade Parallels Desktop

If you already have Parallels Desktop 12 or 13 follow these steps to upgrade to Parallels Desktop 14.

1  If you haven't already done so, purchase and download a "Parallels Desktop 14 for Mac Upgrade," available from the Parallels Online Store at www.parallels.com/buyonline. A Product Activation Key is sent to the email address you provide.
2  If Parallels Desktop is open, quit Parallels Desktop.
3  Follow the instructions to install Parallels Desktop 14. See Install Parallels Desktop. During installation, the previous version of Parallels Desktop is automatically removed from your computer.
4  Open Parallels Desktop and enter your upgrade Product Activation Key.
Install or Upgrade Parallels Desktop

If you were using a trial version of Parallels Desktop or you purchased a previous version but haven’t installed it on your computer, you will also be prompted to enter a full or upgrade key for that version.

**Note:** To upgrade from Parallels Desktop 2, 3, 4, 5, 6, 7, 8, 9, 10 or 11 you must purchase Parallels Desktop 14 at full retail price.

Troubleshooting

If you have any problems upgrading Parallels Desktop, you can find troubleshooting information at http://www.parallels.com/products/desktop/support/.

Install Software Updates

Periodically, Parallels provides free software updates to improve Parallels Desktop.

By default, Parallels Desktop is configured to automatically check for and download available software updates once a week. When an update is available, Parallels Desktop prompts you to install it. Simply follow the onscreen instructions.

Adjust Software Update Settings

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click General.

2. Do one of the following:
Install or Upgrade Parallels Desktop

- To adjust the frequency that Parallels checks for software updates, choose Never, Once a Day, Once a Week, or Once a Month from the Check for Updates menu.
- To choose whether you want Parallels Desktop to download updates automatically, select or deselect Download updates automatically.

  If you choose not to download updates automatically, Parallels Desktop notifies you when an update is available and asks whether you want to download it.

Check for an Update Manually

- Follow the instructions in step 1 above and then click Check Now. You can also choose Check for Updates from the Parallels Desktop application menu.

  Note: To check for updates and download them, your Mac must be connected to the Internet.

Set the Language

You can set which language the Parallels Desktop interface uses by doing the following:

1. Quit Parallels Desktop.
2. Choose Apple menu > System Preferences > Language & Region.
3. Drag the language you want to the top of the list. If you don't see the language you want to use in the list, click the Add button.
4. Open Parallels Desktop.

  If the primary language you chose is supported by Parallels Desktop, the menus and interface text appear in that language. If the primary language you selected isn't supported, menus appear in the first language listed that Parallels Desktop supports.
There are a few ways to get Windows up and running on your Mac:

- Install Windows (p. 17)
- Import your data from a Windows PC (p. 19)
- Use Windows that you already have installed from a Boot Camp partition (p. 27)
- Import Windows from a previous version of Parallels Desktop or other virtualization software (p. 29)

**In This Chapter**

- Install Windows ................................................................. 17
- Import Your Data from a PC .................................................. 19
- Use Boot Camp with Parallels Desktop ................................. 27
- Import from an Earlier Parallels Desktop or Other Virtualization Application ....................... 29
- Download and Install Windows From Microsoft ...................... 29

**Install Windows**

If you have a Windows installation source (a DVD disc, an image file, or a USB storage) and a valid Windows product key, you can install Windows on your Mac and use it with Parallels Desktop.

To install Windows:

1. Open Parallels Desktop (in the Applications folder) and choose File > New.
2. If you have a Windows installation disc, insert it into the DVD drive. If you have a USB storage with Windows, connect the storage to the Mac.
3. Click Install Windows or another OS from a DVD or image file.
4. Parallels Desktop scans for and lists installable operating systems. If you see the version of Windows you want to install, select it, click Continue and go to step 6.
5. If the Windows installation source didn't show up automatically in Step 4, click Choose Manually to browse for it manually. You can browse from the following sources:
   - DVD: If you have a Windows DVD, insert it into the DVD drive. Once Windows is detected, click Continue. If your Mac doesn't have a DVD drive, you can use an Apple SuperDrive, another Mac's DVD drive via Remote Disc, or make an image from the disc.
Install or Import Windows

- Image File: If you have a Windows image file, click Image File and drag the image to the Parallels Wizard window. Once Windows is detected, click Continue.
- USB Drive: If you have a bootable USB installer with Windows, click USB Drive and connect the drive to the Mac. Once Windows is detected, click Continue.

**Note:** Parallels Desktop may fail to detect some operating systems (for example, the latest Linux distributions). If this happens but you're sure that the operating system can be installed, click Continue, specify the OS type manually (if it's not listed, choose Other), and follow the onscreen instructions.

6 Choose what you're going to primarily use Windows. Its settings will be tuned to best fit your needs.

7 Choose where you want to store Windows from the Location menu.

   By default, Parallels Desktop stores Windows in the `/Users/<username>/Parallels` folder.

8 If you want to pre-set things like how much memory Windows uses or whether it starts automatically when you open Parallels Desktop, select Customize settings before installation. You can also adjust these settings after the operating system is installed.

9 Click Continue.

   The assistant installs Windows.

Once Windows is installed, you can start it up by opening a Windows application (p. 31) or by clicking the power button in Control Center.

![Control Center](image)

**Important:** The first time you start Windows, Parallels Tools are installed to allow seamless operation between Windows and macOS. Once Parallels Tools are installed, you're prompted to restart Windows.

When you install Windows, Parallels Desktop creates an administrator account with a blank password. Once the installation is complete, it is recommended that you change this password.

**Note:** You can also install Windows from a disk image file (p. 214) of an installation disc. Simply choose the disk image file in step 4 above. Parallels Desktop supports ISO, DMG, CUE, and CCD disk images.
Import Your Data from a PC

You can import all your data from a Windows PC to Parallels Desktop on your Mac. Then you can continue to work with all your Windows applications, files, and data, side-by-side with macOS.

Overview of Methods for Importing

You can import your data using one of the following:

- Network (p. 20): If both the Windows PC and your Mac are connected to a network, you can import your data over the network.
- External storage device (p. 23): You can transfer the data from a Windows PC to an external storage device, such as an external hard drive. Then, you can connect the device to your Mac and import your data into Parallels Desktop.

Requirements for Importing Your Data

To import your data to your Mac, you need a Windows computer with:

  
  **Note:** You can also use a computer running Windows Server 2008 R2 (64-bit only), Windows Server 2008, or Windows 2000 Professional (32-bit only).
- An Intel or AMD (700 MHz or higher) x86 or x64 processor
- At least 256 MB of RAM
- At least 70 MB of hard disk space for installing Parallels Transporter Agent
- One of the following:
  - An Ethernet port for transferring your data over network
  - An external storage device, such as a USB hard disk

  **Note:** Parallels Desktop does not support migrating Windows dynamic volumes. These are volumes which size is not fixed as in basic volumes. They are migrated as data disks only. You can later add them (p. 212) to an already existing virtual machine.

Step 1: Install Parallels Transporter Agent on Your Windows PC

To import your data you must first install the Parallels Transporter Agent software on the Windows PC.

To install Parallels Transporter Agent:
1 Do one of the following:
   • If you purchased a physical copy of Parallels Desktop, insert the Parallels Desktop installation DVD into your Windows PC. If the installation doesn't start automatically, locate and double-click the `Parallels Transporter Agent.exe` file on the disc.
   • Download Parallels Transporter Agent for Windows from the Parallels website at http://www.parallels.com/download/desktop/ and double-click the installation file.

   If your computer is connected to the Internet, Parallels Transporter Agent checks for available updates. If an update is available, click Download and Install New Version.

2 Follow the onscreen instructions to install Parallels Transporter Agent.

Step 2: Import Your Data

Follow one of the methods below to import your data from your PC to your Mac.

Over a Network

`Important:` After importing your data, you may need to reactivate some of your Windows applications using the activation keys you received when you purchased the applications.

To import your data from a PC over a network:

1 Turn on your Mac and your Windows PC and log in.
2 Make sure that Windows Firewall (p. 26) is turned off. You can turn it on again after the import is finished.
3 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing All Applications > Parallels > Parallels Transporter Agent.

In Parallels Transporter Agent, select Network and click Continue.

4 On your Mac, open Parallels Desktop and choose File > New.

5 Select Transfer Windows from a PC and click Continue.

6 Select Network and click Continue.

7 Find the passcode displayed in Parallels Wizard on your Mac and enter it in Parallels Transporter Agent on your Windows PC.
Install or Import Windows

If the remote PC and Mac are not connected to the same network, you can transfer the remote PC using its name or IP address. To do so, click Connect using IP address, select the Windows PC name from the list or type the IP address, and click Continue.

If you have chosen to use the computer name or IP address, provide the Windows administrator credentials. Parallels Desktop connects to Parallels Transporter Agent and starts collecting information about the source computer.

If you want to log in to Windows automatically whenever you start up Windows, select Enable Automatic Logon. When ready, click Continue.

Choose what you want to transfer;

- System only: this option allows you to transfer the operating system and applications only.
- System and documents: this option allows you to transfer the operating system, applications, and user's files like pictures, documents, downloads, music, videos, etc.

If you choose System only in step 10, you will have to use Apple Migration Assistant to transfer the user's files.
12 Choose where you want to install your data.

When ready, click Continue.

13 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select I want to continue and click Continue.

14 Once the transfer is complete, click Done.

15 Start Windows (p. 30).

16 When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen instructions.

**Note:** To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

**Using an External Storage Device**

**Important:** After importing your data, you may need to reactivate some of your Windows applications using the activation keys you received when you purchased the applications.

To import your data from a PC using an external storage device:

1 Connect an external storage device to your Windows PC.
2 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing All Applications > Parallels > Parallels Transporter Agent.

3 Select External storage and click Continue. Parallels Transporter Agent collects information about the Windows PC.

4 If you want to log in to Windows automatically whenever you start up Windows, select Enable Automatic Logon and specify the Administrator's password. When ready, click Continue.

5 Choose what you want to transfer;
   • System only: this option allows you to transfer the operating system and applications only.
   • System and documents: this option allows you to transfer the operating system, applications, and user's files like pictures, documents, downloads, music, videos, etc.

6 If you choose System only in step 5, you will have to use Apple Migration Assistant to transfer the user’s files.

7 Choose where you want to store your data. You can also click Customize and select which Windows volumes to migrate.

When ready, click Continue.

8 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select I want to continue and click Continue.
9  Once the migration is complete, click Done to quit Parallels Transporter Agent.
10  Disconnect the storage device from the Windows PC and connect it to your Mac.
11  On your Mac, open Parallels Desktop and choose File > New.
12  Select Transfer Windows from a PC and click Continue.
13  Select External storage and click Continue.
14  Parallels Desktop scans the connected storages for the newly created virtual machine. If Parallels Desktop cannot find it, select the virtual machine manually. Then click Continue.
15  Choose where you want to install Windows and your data, and then click Continue.
16  Once the transfer is complete, click Done.
17  Start Windows (p. 30).
18  When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen instructions.

**Note:** To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

### Solving Problems

Read this section if you have problems importing your data from a Windows PC.

#### General Tips

This section provides solutions to some errors that may occur during the import process.

#### Parallels Transporter Agent Doesn’t Work Correctly

If you experience any problems while importing, make sure that the `snapman.sys` driver is installed in `C:\WINDOWS\system32\drivers\`.

If the `snapman.sys` driver is not installed, follow these steps:

1  Uninstall Parallels Transporter Agent.
2  Restart your Windows PC.
3  Reinstall Parallels Transporter Agent.
4  Restart your Windows PC again.
5  Try to import Windows and your data again.

#### Import is Interrupted by an Error

If the import process is interrupted by an error, do the following:

1  From the Start menu, choose My Computer.
2 In the Hard Disk Drives pane, right-click the volume you want to import, and choose Properties.

3 In the Properties pane, click the Tools tab, and in the Error Checking section, click the Check Now button.

4 In the Check Disk window, select Automatically fix file system errors and Scan for and attempt recovery of bad sectors, and then click Start.

5 Wait till the disk is scanned and errors are fixed.

Dynamic Volumes are not Imported

Only basic volumes can be imported. You can't import dynamic volumes using Parallels Desktop.

The only way to import the data stored on a dynamic disk is to copy the data to a basic disk on your Mac and then import the basic disk.

If Your Mac Fails to Connect with Parallels Transporter Agent

Firewall applications may block connections between your Mac and Parallels Transporter Agent on the Windows PC.

Firewall problems in macOS

If your Mac fails to connect with Parallels Transporter Agent on your Windows PC, the reason may be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent.

To enable connections between your Mac and Parallels Transporter Agent and prevent further blocking, you can configure the firewall settings in macOS by doing the following:

1 From the Apple menu, choose System Preferences, and then click Security.

2 Click the Firewall tab.

3 Configure the necessary settings.

If you try to search for Parallels Transporter Agent by typing the Windows PC IP address manually, you may receive a message saying that Parallels Transporter Agent is blocked. Click the Unblock button.

Firewall problems in Windows

Microsoft Windows operating system has a built-in firewall that blocks connections to and from other computers. When starting Parallels Transporter Agent for the first time, you may see a message saying that Windows Firewall has blocked some features of the application.

To enable the connection between your Mac and Parallels Transporter Agent, click Unblock.
To prevent this problem from happening again, add Parallels Desktop and/or Parallels Transporter Agent to the firewall exceptions (the list of applications allowed to communicate through the firewall):

1. From the Start menu, choose Control Panel > Network Connections.
2. In the Network Tasks pane, click Change Windows Firewall Settings.
3. Add Parallels Desktop and/or Transporter Agent to the firewall exceptions list.

If Parallels Doesn't Detect Windows Correctly

If Parallels Desktop detects the source operating system (Microsoft Windows XP or Windows Vista computer) incorrectly, make sure that neither of your Windows applications are running in compatibility mode - a special mode of Windows allowing you to run applications that are incompatible with your version of Windows.

See Windows Help for more information.

Problems Using a Application After an Import

Applications that depend on specific hardware may not work in Parallels Desktop.

If you import from several source volumes, the disk drive letters are changed. Make sure that the application paths are set correctly. See Windows Help for more information.

Use Boot Camp with Parallels Desktop

Boot Camp is a feature of macOS that lets you start up your Mac in Windows. If you have already installed Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Vista, or Windows XP on your Mac using Boot Camp, you can set Parallels Desktop to work with Boot Camp using either of these two options:

• Set Parallels Desktop to run Windows from the Boot Camp partition: Changes you make in Windows applications either while working in macOS or when you start up your Mac in Windows using Boot Camp will be reflected in both places.

  **Note:** Parallels Desktop supports Boot Camp created using Boot Camp Assistant on the same disk where macOS is installed.

Windows running from Boot Camp has the following limitations:

• It can't be paused
• It can't be saved as a snapshot (p. 114)
• It can't run in Rollback Mode (p. 87)
• It can't be compressed
Install or Import Windows

- Import Windows and your data from Boot Camp into Parallels Desktop: Windows running from Parallels Desktop doesn't have the above listed limitations. Boot Camp and Parallels Desktop are separate. Changes you make in Windows applications while working in macOS are not reflected when you start up your Mac in Windows using Boot Camp.

When you import Windows from Boot Camp, Parallels Desktop creates an expanding .hdd file and copies all the contents from Boot Camp to it. During this operation, initial Windows on Boot Camp doesn't get changed. All you need is just enough free disk space on the Mac's hard disk.

Set Parallels Desktop to run Windows from the Boot Camp Partition

1. Open Parallels Desktop (in the Applications folder) and choose File > New.
2. Click Boot Camp, and then follow the onscreen instructions.

   **Note:** If you plan to start up in Windows using Boot Camp, it is recommended that you shut down Windows in Parallels Desktop rather than suspending Windows.

Import Windows and Your Data from Boot Camp into Parallels Desktop

1. Set Parallels Desktop to use Boot Camp, as described in the steps above.
2. Right-click (Control-click) the Boot Camp version of Windows in Control Center and choose Import Boot Camp.

   **Note:** Windows must be shut down.

3. Click Import.
4. Locate where you want to store Windows and your data, and then click Choose.

   Windows and all your data are imported from Boot Camp. You can still use the original Boot Camp Windows installation, separately from Parallels Desktop.

   **Important:** The first time you start Windows after setting Parallels Desktop to work with Boot Camp, Parallels Tools are installed to allow seamless operation between Windows and macOS. Once Parallels Tools are installed, you're prompted to restart Windows.

Save Disk Space with Parallels Desktop

You can save disk space on your Mac by importing Windows from Boot Camp into Parallels Desktop and then deleting the Boot Camp partition. Here is how it works:

1. For example, you have a 40 GB Boot Camp partition and only 20 GB are taken by Windows and its files. Other 20 GB are not used.

2. You choose to import Boot Camp. Parallels Desktop copies Windows and all its files from Boot Camp into a new virtual machine. This virtual machine will occupy only 20 GB of disk space.

3. Once the import is complete, delete the Boot Camp partition and save 20 GB of disk space.
Note: The hard disk of the resulting virtual machine is not limited to 20 GB. It is expanding which means that you can continue installing applications, downloading movies, music, etc. The disk will grow in size proportionally. For example, if you download a 5 GB movie to this virtual machine, it will occupy 25 GB of disk space.

Import from an Earlier Parallels Desktop or Other Virtualization Application

With Parallels Desktop for Mac you can use Windows that you set up using earlier versions of Parallels Desktop, as well as VMware Fusion, Microsoft Virtual PC, and VirtualBox:

1. Open Parallels Desktop (in the Applications folder) and choose File > Open.
2. Select the Windows data file you want to import, then click Open and follow the onscreen instructions.
   - Parallels Desktop data files end with .pvm.
   - VMware files end with .vmx.
   - Virtual PC files end with .vmc.
   - VirtualBox files end with .xml or .vbox.

You can also simply drag a Parallels .pvm file to Control Center to add it to Parallels Desktop.
4. Choose Actions > Install Parallels Tools and follow the onscreen instructions.

Download and Install Windows From Microsoft

If you don’t have Windows, you can download and install it from Microsoft. To do so, please follow the onscreen instructions.
Use Windows on Your Mac

Read this chapter to find out all about using Windows applications on your Mac. Learn how to get started using Windows applications, set how Windows applications work with macOS, share applications, files, and folders between macOS and Windows, connect devices, print, customize your keyboard, and more.

In This Chapter

Get Started ............................................................................................................ 30
Set How Windows Works with macOS ................................................................. 38
Mouse, Trackpad, and Keyboard ........................................................................... 62
Connect External Devices ..................................................................................... 73
Connect Bluetooth Devices ................................................................................... 77
Print from Windows ............................................................................................... 78
Use the Built-in iSight Camera or Another Webcam .............................................. 85
Show a Presentation on an External Monitor or Projector ...................................... 86
Protect Your Data .................................................................................................. 87
Connect to the Internet or a Network ..................................................................... 89
Optimize Performance ........................................................................................... 93
Use Windows on Your iPad, iPhone, or Android Device ........................................ 99
Save Time With Parallels Toolbox ......................................................................... 100
Save a Picture of the Screen ................................................................................ 100
Set the Appearance of Virtual Machine Dock Icons ............................................ 101
Allow Windows Updates While Your Mac is Sleeping .......................................... 101
Translate Words in Windows ................................................................................ 102
Use the Touch Bar with Windows ......................................................................... 102

Get Started

In this section, learn how to start Windows, open a Windows application, install more Windows applications, and shut down or suspend Windows.

Start Windows

To use Windows applications on your Mac, Windows must be running.

The simplest way to start Windows is to open a Windows application (p. 31). If Windows isn't already running when you open a Windows application, it starts automatically in Coherence mode (p. 39).
**Important:** If Windows was previously shut down, you may need to enter your Windows password.

You can also start Windows by doing the following:

1. Open Parallels Desktop.
2. In Control Center, click the Power Button below Windows.

3. Click anywhere in the Windows window that appears.

Windows starts and you can begin using Windows applications alongside macOS.

**Open a Windows Application**

Opening a Windows application is as easy as opening a Mac application. Here are several ways to open Windows applications:

- From the Windows Applications folder in the Dock
- From the Windows Start menu
- From the macOS Finder
- From the Dock
- Using Spotlight searching
- Using Launchpad

**Note:** All Windows application icons can be easily identified by the Parallels Desktop symbol in the lower-right corner of the icon.
Windows Applications Folder

This folder is available in the macOS Dock and contains all your Windows applications. As you install more applications, they are automatically added.

To open a Windows application using the Windows Applications folder:

- Click the folder, and then choose a application.

To add the Windows applications folder to the Dock:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and then click Applications.
3. Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

Windows Start Menu

To open a Windows application from the Start menu:

1. Do one of the following:
• Click the Parallels icon \(\text{ⅰ}\) in the menu bar and choose Windows Start Menu.

• If Windows is in Full Screen or Window mode, open the Start Menu as you normally would.

| Note: You can also Control-click or Right-click the Parallels icon. |

2 Click the application you want.

Application Icon in the Dock

When you open a Windows application, its icon appears in the macOS Dock at the bottom of the screen. By default when you close the application, the icon disappears from the Dock. Keeping a application's icon in the Dock provides a quick way to open the application anytime.

To keep a Windows application's icon in the Dock, do one of the following:

• Right-click or Control-click the Windows application icon in the Dock and choose Keep in Dock from the shortcut menu.

• Drag the application's icon from the Finder to the Dock.

Now you can open the application again anytime by clicking the icon in the Dock.

Spotlight

You can search for and open Windows applications using Spotlight:
Use Windows on Your Mac

• Click the Spotlight icon in the upper-right corner of your screen, or press Command-Space bar on your keyboard. Then type the name of the application and select it from the list.

Launchpad

You can see a full screen display of all your Windows applications and Mac applications using Launchpad. Just click the Launchpad icon (looks like a rocket) in the Dock. You can then click any macOS application to open it. To open a Windows application, click the Windows folder and then click the application you want.

Note: The Windows folder is available in Launchpad only if sharing Windows applications (p. 53) is enabled.

To move a Windows application from the Windows folder to a main Launchpad page, do one of the following:

• From Launchpad, click the folder containing your Windows applications and drag a application to the Launchpad icon in the Dock.
• Start the Windows application you want, right-click its icon in the Dock, and choose Add to Launchpad.

To remove a Windows application from Launchpad, start the application, right-click its icon in the Dock, and choose Remove from Launchpad.

Install Windows Applications

You install Windows applications on your Mac just as you would on a Windows PC. The two most common ways of installing applications are:

• Using a CD or DVD installation disc
• Downloading the application or installation file from the Internet or a network

Install a Application from a CD or DVD Installation Disc

1 Start Windows (p. 30).
2 Insert the installation disc.
3 In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then follow the onscreen instructions.

For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM.

Install a Application from the Internet or a Network

• Download the application or installation file and follow the instructions from the application's source.
In most cases, you can either run the installation file and follow the onscreen instructions, or simply open the downloaded application.

For more information about connecting to the Internet and networks, see Connect to the Internet or a Network (p. 89).

**Shut Down or Suspend Windows**

When you're finished using Windows applications, you can leave Windows running in the background as you work with your Mac applications. Or you may want to stop Windows from running so more of your computer's resources are available for your Mac applications. There are a few ways to stop Windows. You can:

- Suspend Windows
- Pause Windows
- Shut down Windows
- Stop Windows

**Suspend Windows**

Suspending Windows conveniently freezes all running Windows applications and settings in their current state.

Do one of the following:

- Quit Parallels Desktop.
- Click the Parallels icon ![Parallels Desktop icon] in the menu bar and choose Actions > Suspend.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Suspend.

The next time you start Windows or open a Windows application, you resume your progress from exactly where you left off.

When Windows is suspended, you can safely quit Parallels Desktop and resume your progress later.

**Note:** If you are using macOS Lion or later and you shut down or restart your computer, or quit Parallels Desktop, Windows is automatically suspended. The next time you start up Parallels Desktop, you can resume working with Windows from where you left off. If your Windows is encrypted (p. 88), you will have to resume it manually.

**Pause Windows**

You can temporarily pause from using Windows and free your computer’s resources, such as RAM and processor cycles, to be used by your Mac applications by doing one of the following:
Use Windows on Your Mac

- Click the Parallels icon in the menu bar and choose Actions > Pause.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Pause.

To resume using Windows after pausing it, do one of the following:

- Click the Parallels icon in the menu bar and choose Actions > Resume.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Resume.

If you quit Parallels Desktop while Windows is paused, you’re prompted to either Suspend or Stop Windows first.

Shut Down Windows

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. All Windows applications close, giving you the opportunity to save your progress if necessary, and Windows stops running.

To shut down Windows, do one of the following.

- Click the Parallels icon in the menu bar and choose Actions > Shut Down.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Shut Down.

Stop Windows

To stop Windows and all open Windows applications immediately, do one of the following:

- Click the Parallels icon in the menu bar and choose Actions > Stop.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Stop.

**Important:** When you stop Windows this way, none of your data or progress is saved.

Startup and Shutdown Settings

Using Startup and Shutdown settings, you can choose how to start and shut down the virtual machine.

To access Startup and Shutdown settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and select Startup and Shutdown.
Set to Start and Shut Down the Virtual Machine Manually

If you want to always start and shut down the virtual machine manually, select Start up and shut down manually.

Configure the Virtual Machine to Start Automatically

If you want to make the virtual machine start automatically when the Mac starts, select Always ready in background.

Specify More Details How to Start and Shut Down the Virtual Machine Automatically

If you want to specify not only how the virtual machine starts or shuts down but also the view mode and what happens on closing the virtual machine window, select Custom and do the following:

Set Whether Windows Starts Automatically

Choose one of the following from the Start Automatically menu:

- **Never**: Windows never starts automatically.
- **When window opens**: Windows starts automatically when you open it from Control Center.
- **When Parallels Desktop starts**: Windows starts automatically when you start Parallels Desktop.
- **When Mac starts**: Windows starts automatically when you start the Mac. If you select this option, you can also configure the virtual machine to delay the startup.
  
  **Note**: This feature is available in Parallels Desktop for Mac Pro Edition only.
- **When user logs in**: Windows starts automatically when the macOS user logs in to macOS on the Mac startup.

Set the Startup View

This setting affects in which view mode Windows starts when you start the virtual machine or guest OS application.

- From the Startup View menu, choose Coherence, Window, Full Screen, Picture in Picture, Headless or Same as last time.

  **Note**: Headless mode is available in Parallels Desktop for Mac Pro Edition only.
Set What Happens When You Shut Down Windows

Choose one of the following from the On VM Shutdown menu:

- **Keep window open:** If Windows is set to appear in a separate window (p. 41), the window stays open when you stop or shut down Windows.
- **Close window:** If Windows is set to appear in a separate window, the window closes when you stop or shut down Windows.
- **Quit Parallels Desktop:** Parallels Desktop quits when you stop or shut down Windows.

Set What Happens When You Shut Down Your Mac

These settings affect what happens when you shut down the Mac.

From the On Mac Shutdown menu, choose Stop, Shut Down, or Suspend.

Set What Happens When You Close the Parallels Desktop Window

These settings affect what happens only when Windows is set to appear in a separate window (p. 41).

From the On Window Close menu, choose Suspend, Shut Down, Force to stop, Keep running in background or Ask me what to do.

Pause Windows When Possible

Select Pause Windows when possible to save your Mac's resources (p. 96).

Set How Windows Works with macOS

Parallels Desktop for Mac allows you to work seamlessly between Windows and macOS. For example, you can cut and paste text, and share files, between the two.

There are a number of ways that you can set the level of integration between Windows and macOS. For example, you may want your Windows applications to behave just like Mac applications, appearing side-by-side with them on the Mac desktop. Or you may wish to keep the Windows desktop and applications in a separate window.

Read on to learn more about setting how Windows works together with macOS.
Merge Windows and macOS

You can set Windows and macOS to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, Windows applications appear on the Mac desktop next to your Mac applications, and documents from Windows applications and Mac applications are stored in the same folders.

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

- Click the Coherence icon in the top left corner of the virtual machine window.
- Choose View > Enter Coherence.
- Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

- Press Control-Command-F to exit Full Screen. Then click View > Enter Coherence.
Use Windows on Your Mac

- Move the pointer to the top of the screen until the macOS menu bar appears and click View > Exit Full Screen. Then open the View menu once again and click Enter Coherence. If you’re using Full Screen optimized for games, press Control-Option (Alt) to display the Mac menu bar.

**Note:** To enable the Coherence view mode, Parallels Tools must be installed (p. 219). In most cases, Parallels Tools are installed by default.

Parallels Menu

When in Coherence mode, the Parallels menu appears in the menu bar at the top of the screen.

Use the menu for these common functions:

- Click the Parallels icon to open a basic menu that provides the following items:
  - Windows Start Menu: Access the Windows Start menu.
  - View: Change the virtual machine view mode.
  - Actions: Use this menu to perform various actions.
  - Devices: Manage hardware devices like printers and DVD drives.
  - Configure: Open the virtual machine configuration dialog.
  - Control Center: Open the Parallels Desktop Control Center.
  - New: Create a new virtual machine.
  - Open: Open an already existing virtual machine.
  - Preferences: Open the Parallels Desktop preferences.
• and more...
• Right-click the icon to open the Windows start menu.

**Important:** When in Coherence mode, to quit Parallels Desktop, click the Parallels icon in the menu bar and choose Quit Parallels Desktop.

Windows System Tray

When Parallels Desktop is in Coherence mode, the Windows system tray icons are in the macOS menu bar at the top of the screen.

You can use the system tray icons just as you would from the Windows Desktop.

Move Windows Applications Between Desktops (Spaces)

When Windows is working in Coherence, you can easily move windows of guest OS applications between macOS desktops (spaces).

Set Windows to Appear in a Single Window

You can set the Windows and applications to appear together in their own window.

To switch to Window mode from Coherence mode, do one of the following:

• Click the Parallels icon in the menu bar, then choose View > Exit Coherence.
Use Windows on Your Mac

• If the Parallels Desktop menus are available in the Mac menu bar, click View > Exit Coherence.

To switch to Window mode from Full Screen mode, do one of the following:

• Press Command-Control-F.
• Move the pointer to the top of the screen until the macOS menu bar appears and click View > Exit Full Screen. If you’re using Full Screen optimized for games, press Control-Option (Alt) to display the Mac menu bar.

Adjust Window Mode Settings

You can customize how Parallels Desktop appears and behaves when in Window mode.

Set Whether Windows Applications Show in the Dock:

You can choose whether or not to show icons for Windows applications in the macOS Dock when in Window mode. If you prefer to work with applications by manipulating them on the Windows desktop, you may not want to be distracted by seeing them in the Dock alongside your macOS application icons.

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Options and then click Applications.

3 To show Windows application icons in the Dock when in Window mode, deselect Show Dock icons in Coherence only.

Monitoring Windows in a Scalable Window

You can set Windows to appear in a window that can be resized to any size so that the content scales in size with the window. This is called Picture in Picture mode. This mode can be useful if you want to monitor applications and other tasks running in Windows as you work in macOS.

To switch to Picture in Picture mode:

• From Window mode, choose View > Enter Picture in Picture.

For more information on Picture in Picture mode, see the Picture in Picture mode settings topic (p. 141).

Set Windows to Take Up the Whole Screen

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a Windows PC. In Full Screen mode, macOS and all of the Parallels Desktop controls are hidden.
To switch to Full Screen mode, do one of the following:

• From Coherence mode, click the Parallels icon  in the menu bar, then choose View > Exit Coherence. Then click the View menu and select Enter Full Screen.

• From Window mode, choose View > Enter Full Screen or click the Full Screen icon  in the top left corner of the virtual machine window.

To exit Full Screen mode, do one of the following:

• Press Command-Control-F.

• Move the pointer to the top of the screen until the macOS menu bar appears and click View > Exit Full Screen. If you’re using Full Screen optimized for games, press Control-Option (Alt) to display the Mac menu bar.

Adjust Full Screen Settings

You can customize how Windows appears and behaves when in Full Screen mode.

To access Full Screen settings:

1 Do one of the following:

   • Click the Parallels icon  in the menu bar and choose Configure > Options.

   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure, and then click Options.
Use Windows on Your Mac

2  Click Full Screen.

3  Click the lock to prevent further changes.

4  In this Full Screen pane, you can adjust any of the settings listed below.

Set What Shows on Displays Connected to Your Mac

If you have a second display connected to your Mac, by default when you switch to Full Screen mode, Windows is displayed on the primary display and macOS on the secondary.

You can choose which display Windows is shown on by dragging its window to that display and then clicking the Full Screen icon 📺.
To extend Windows across all your displays, select Use all displays in full screen.

When Use all displays in full screen is selected, you can also choose Activating virtual machine shows all its spaces. With this option selected, click the virtual machine on any of your displays and it will appear on all displays. It's useful when you switched some of your displays to a space that doesn't belong to the virtual machine and then decide to return to the virtual machine and make it displayed on all connected monitors again.

Optimize Full Screen for Games

If you use a virtual machine to play video games in Full Screen view mode, select Optimize full screen for games. With this option selected, macOS Dock, menu bar and notifications will not be displayed when you move the mouse pointer to the top and bottom of the screen.

Allow Windows to set display gamma

If you're using Windows to play video games, Windows may need to temporarily change your Mac's display gamma setting to properly display different visual effects. To allow Windows to change gamma settings, select Use Windows gamma settings.

Scale to fit screen

Using the Scale to fit screen menu, you can configure how Windows is displayed when working in Full Screen:

- Off. If Parallels Tools (p. 128) are installed, Windows resolution matches that of the Mac. If Parallels Tools (p. 128) aren't installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows has scroll bars.

- Auto. If Parallels Tools (p. 128) are installed, Windows resolution matches that of the Mac. If Parallels Tools (p. 128) aren't installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.

- Keep ratio: No matter whether Parallels Tools (p. 128) are installed or not, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.
• Stretch: No matter whether Parallels Tools (p. 128) are installed or not, Windows resolution remains unchanged but Windows is stretched to occupy the whole screen.

**Note:** To prevent unauthorized changes to Full Screen settings, click the Lock icon at the bottom of the window. Once locked, an administrator's password is required to make further changes.

---

**Set an Application to Open When You Insert a CD or DVD**

You can set the Windows application of your choice to open when you insert a music CD, picture CD, video DVD, or a blank CD or DVD.

1. From the macOS Finder, choose Apple menu > System Preferences.
2. Click CDs & DVDs.
3. From the disc type menu of your choice, choose Open other application.
4. Choose a Windows application from /username/Applications (Parallels)/Windows Applications.

When you insert a disc of the type you selected, the Windows application you chose automatically opens.

**Note:**

1. If you're unable to set a Windows application to open when you insert a CD or DVD, be sure that sharing macOS applications (p. 53) is enabled and that macOS CD/DVD-ROM is not selected in CD/DVD Preferences.
2. To enable a Windows application to open when you insert a CD or DVD, Parallels Tools must be installed (p. 219). In most cases, Parallels Tools are installed by default.

---

**Share Items Between macOS and Windows**

Parallels Desktop allows you to easily access your macOS files using Windows applications, and also to access Windows files using macOS applications.

Read on to learn about all the ways you can share folders, files, and applications between macOS and Windows.

**Copy and Paste Between macOS and Windows**

Parallels Desktop allows you to copy and paste images and formatted text (italic, bold, underlined, and of various colors, fonts, and sizes) between macOS and Windows applications.

To enable copying and pasting between macOS and Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Options > More Options.

3 Select Share Mac clipboard.

4 To preserve text formatting when copying and pasting text, select Preserve text formatting.

**Note:** To enable copying and pasting between macOS and Windows, Parallels Tools (p. 219) must be installed. In most cases, Parallels Tools are installed by default. Copying and pasting between macOS and Windows is unavailable if you isolate macOS from Windows.

**Copy and Paste Files**

You can easily copy and paste files between Windows and macOS by doing the following:

1 Select a file (or multiple files) and press Command+C on your keyboard to copy it.

2 Open a folder or click the desktop in the other operating system and press Command-V to paste the file.

**Notes:**

1. To enable copying and pasting files between macOS and Windows, in Sharing settings (p. 47) All disks or Home folder only must be chosen from the Share Folders menu, and Access Windows folders from Mac must be selected. In most cases all of these options selected by default.

2. If Home folder only is selected in the Share Folders menu (p. 47), you will be able to copy and paste files from the Mac to Windows only from the Mac home folder.

**Share Files and Folders**

Parallels Desktop allows you to share folders between the macOS and Windows file systems, so you can easily open macOS files from Windows applications and Windows files from macOS applications.

**Note:** These instructions apply to sharing folders between macOS and Linux as well.

**Access a macOS Folder or File from a Windows Application**

With folder sharing enabled, you can navigate to any shared macOS folder from within a Windows application. When you open a file (for example, by choosing File > Open in many applications), your shared macOS folders appear as network shared directories labeled "psf."

To enable macOS folders for sharing with Windows applications:

1 Start Windows. (p. 30)

2 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
Use Windows on Your Mac

- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

3. Click Options and select Sharing > Share Mac.

4. Click the lock to prevent further changes.

5. Do one of the following:
   - To share just the folders in your Home folder, choose Home folder only from the Shared Folders menu.
   - To share all your macOS folders, choose All disks from the Shared Folders menu.
• To share any folder you want, click Custom Folders and click the add (+) button, then choose the folder you want to share. You can add more folders by clicking the add (+) button again.

Once you share a macOS folder with Windows you can:

• Disable the folder sharing by deselecting On.

• Change the folder name that will be displayed in Windows by double-clicking the folder name in the Name column and typing another name.

• Restrict writing to this folder by clicking Read & Write in the Permissions folder and choosing Read only. You will not be able to add items to the folder.

**Note:**

1. To enable folder sharing, the Isolate Windows from Mac option must be disabled on the Security tab of the Configuration dialog.

2. If you’re running Linux, shared folders are mounted to the `/media/psf` or `/mnt/psf` directory.

Set macOS and Windows to Use the Same Folders

You can set macOS and Windows to use the same folders for things like music, documents, pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, it will be in the Documents folder whether you're using a macOS application or a Windows application.

1 Start Windows. (p. 30)
2 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
3 Click Options and select Sharing.
4 Click the Share Mac tab and select Share Mac user folders with Windows.
Your **macOS** Desktop, **Documents, Pictures, Music, Movies, and Downloads folders** are merged with the corresponding Windows folders, and the macOS Trash is merged with the Windows Recycle Bin.

If you only want to map some of the folders, click Configure and select the folders you want. To map the macOS Trash to the Windows Recycle Bin, select **Merge Recycle Bin with Trash.**

**Show an Item from Windows in the Finder**

You can show an item from Windows in the macOS Finder.

- In Windows, right-click (or Control-click) a file or folder and choose Show in Finder from the shortcut menu.

From the Finder you could, for example, apply a color label to an item, or easily drag it to another location in the Finder.

**Note:** You can only perform these actions with files stored in shared folders (p. 47).

**Share a file from Windows via Mac services**

You can share files from Windows via Mac services like AirDrop, Mail, Twitter, Facebook.

In Windows, right-click (or Control-click) a file or folder and choose Share on from the shortcut menu.

**Note:** You can only perform these actions with files stored in shared folders.

**Use Quicklook in Windows File Explorer**

You can quickly preview a file or set of files using the macOS Quick Look functionality.

- In Windows, select a file or set of files to preview and press the Space key.
- If you're using a touchpad, select a file and use the three-finger tap gesture (or force-press gesture on newer Macbooks).

**Note:** You can only perform these actions with files stored in shared folders.

**Access Windows Disks from the Finder or Desktop**

If you need to have a quick access to Windows disks, you can add them to the Finder or desktop. Do the following:

**Note:** To add Windows disks to the Finder or desktop, the virtual machine must be running and the Connected servers option selected on the General tab of Finder Preferences.

1. Open the Finder and select All in the Shared section.
Find and expand your virtual machine.

Double-click the disk you want to add to the Finder or desktop. The disk gets mounted and shown on the desktop. Then you can do the following:

• To add the disk to the Finder, drag it from the desktop to the Favorites section in the Finder.

• To make the disk display on the desktop, create an alias for it. Right-click the disk and select Make Alias.

Share iCloud, Dropbox, or Google Drive Folders with Windows

If you're using iCloud, Dropbox, or Google Drive cloud storage in macOS, you can easily share their macOS folders with Windows. Once sharing is enabled, you can upload, download, and sync files from any of these services from within Windows without duplicating any of their files on your hard disk.

**Notes:**

1. This functionality is also available for Linux virtual machines.
2. To be able to use this functionality, Parallels Tools (p. 128) must be installed.

To share macOS iCloud, Dropbox, or Google Drive folders with Windows, do the following:

**Note:** In Parallels Desktop for Mac Pro Edition, you can also share your Dropbox for Business, Box and OneDrive for Business folders with Windows.

1. If you haven't already, set up iCloud, Dropbox, or Google Drive in macOS.
2. Start Windows (p. 30).
3. Do one of the following:

   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

4. Click Options and select Sharing > Share Mac.
5. Select Share cloud folders with Windows.
6 Log in to Windows and open Computer. Folders for iCloud, Dropbox, or Google Drive are available in the Favorites section (or Quick Access section in Windows 10). You can use them to upload and download files to and from the cloud.

Share Windows OneDrive Folders with macOS

If you're using Microsoft OneDrive to store files in the cloud, you can easily share your OneDrive folders with macOS. Then you can upload or download OneDrive files in macOS without duplicating any of the files on your hard disk.

Notes:

1. To share OneDrive folders with macOS, the OneDrive desktop app must be installed in Windows. If you're using the preinstalled OneDrive app, OneDrive folders are not shared because this app doesn't create any local folders and works directly with the cloud storage.

2. This feature is available only when Parallels Tools are installed (p. 130) in Windows.

To share your Windows OneDrive folders with macOS, do the following:

1 If OneDrive isn't already set up in Windows, set it up. For more information, go to http://windows.microsoft.com/en-us/skydrive/download.

2 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

3 Click Options and select Sharing > Share Windows.

4 Select Access Windows folders from Mac and Share OneDrive with Mac.

5 In the macOS Finder, choose Finder > Preferences and select Connected servers.

6 Open the Finder and click your virtual machine in the Shared section. The virtual machine must be running.
7 Double-click the OneDrive disk. The disk gets mounted and shown on the desktop.
8 Drag the OneDrive disk from the desktop to the Favorites section in the Finder.

Now OneDrive from Windows is always available in the Finder. You can use it to download or upload files to OneDrive from macOS.

**Note:** To use OneDrive, Windows must be running.

**Share Applications**

You can access macOS applications from within Windows and you can access Windows applications from macOS. For example, if you locate a file using the Open menu in a Windows application and decide you would rather open the file using a macOS application, you can.
Use Windows on Your Mac

**Note**: Provided that Parallels Tools are installed in Linux (p. 131), you can also open macOS files using Linux applications.

Enable Sharing macOS Applications

When sharing macOS applications is enabled, you can open macOS Applications from within Windows or Windows applications.

If not, you can enable it at any time by doing the following:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and click Applications.

3. Select Share Mac applications with Windows.

Once sharing macOS applications is enabled, you can do the tasks below.

Open a File from Windows in a macOS Application

You can open a file in a macOS application from Windows Explorer, from the Open dialog in most Windows applications, or from Windows Desktop if Windows is set to appear in a separate Window (p. 41) or at full screen (p. 42). You may want to do this if you don't have a Windows application that can open the file.

   - In Windows, right-click (or Control-click) a file and do one of the following:
     - Choose Open on Mac from the shortcut menu. The file opens in the default macOS application for that file type.
     - Choose Open With from the shortcut menu, and then choose an application.

**Note**: You can only perform these actions with files stored in shared folders (p. 47).

Open a Mac Application from the Windows Start Menu

From the Windows Start menu, do one of the following:

- Choose All Applications > Parallels Shared Applications, and then choose an application.
- Type the name of the application you're looking for in the search field, then choose the application from the list.
Enable Sharing Windows Applications

When sharing Windows applications is enabled, you can open Windows applications from the macOS Finder. You can also choose to add a folder to the Dock containing all your Windows applications for easy access.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and click Applications.

3. Select Share Windows applications with Mac.

Add a Windows Applications Folder to the Dock

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and then click Applications.

3. Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

Configure Whether Dock Icons Bounce to Alert

When a Windows application icon in the taskbar would normally flash to alert you to something, such as a new message in Skype or a notification in Microsoft Outlook, by default its icon also bounces repeatedly in the macOS Dock.

To enable or disable Windows application icons bouncing to alert:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and click Applications.

3. Select or deselect Dock icons bounce to alert.

Note: Icon bouncing is available for Windows with Parallels Tools installed (p. 219) provided that Share Windows applications with Mac is selected in the Applications pane.
Force Quit Windows Applications

If your running Windows guest OS application doesn't respond and freezes, you can easily force quit it as you can do with any macOS application. To force quit a Windows application, do one of the following:

- Right-click the icon of the Windows application available in the Dock, press Option (Alt), and choose Force Quit.
- Press Option + Command + Esc (Alt + Command + Esc), select the name of the Windows application you want to quit, and click Force Quit.

**Note:** To be able to force quit Windows guest OS applications, Parallels Tools must be installed (p. 219).

Add Applications to Launchpad

When you install any applications in Windows (except temporary apps), you can choose to automatically add their icons to Launchpad.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and click Applications.
3. Select Add new applications to Launchpad.

Set Files to Open in the Application or Application of Your Choice

You can set files of a particular type that you open from the macOS Finder to open in the Windows application of your choice. For example, you could set files ending in .txt to always open in Windows Notepad.

You can also set files opened from Windows to always open in the macOS application of your choice.

Set macOS Files of a Particular Type to Open in a Windows Application

To open a macOS file once with a Windows application:

1. Right-click (or Control-click) the file in the Finder and choose Open With from the shortcut menu.
2. Select a Windows application.
   - If you don't see the application you want, click Other and choose a Windows application from /username/Applications (Parallels)/Windows Applications.
You can also open a macOS file in a Windows application by dragging it to the application's icon in the Dock.

To set files of a particular type to always open in a Windows application:

1. Right-click (or Control-click) a file and choose Get Info from the shortcut menu.
2. Click the triangle next to "Open with" to expand the section.
3. Choose a Windows application from the pop-up menu.
   - If you don't see the application you want, choose Other and choose a Windows application from /username/Applications (Parallels)/Windows Applications.
4. Click Change All.

From this point on, double-clicking a file of this type (.txt in the example above) in the macOS Finder opens the file in the Windows application. If Windows is shut down, suspended, or paused, double-clicking the file starts or resumes Windows in Coherence mode. When Windows starts up, the file opens in the Windows application.

Set Windows Files of a Particular Type to Open in a macOS Application

To open a Windows file with a macOS application only this time:

- Right-click (or Control-click) the file in Windows, choose Open With from the shortcut menu, and choose an application.

To set all files of a particular file type to open in a macOS application:

1. Right-click (or Control-click) a file in Windows, choose Open With from the shortcut menu, and click Choose default application.
2. Select an application, choose Always use the selected application to open this kind of file, and click OK.

**Note:** To set files to open in the application or application of your choice, Parallels Tools must be installed (p. 219). In most cases, Parallels Tools are installed by default. Also, the Isolate Mac from Windows (p. 87) option must be disabled, and Windows application sharing (p. 53) must be enabled.

Set Internet Links to Always Open in macOS or Windows

By default, clicking a link (such as a web page URL) in Windows opens the default Windows application for that link type, and clicking a link in macOS opens the default macOS application.

You can set links of a particular type to always open in macOS or in Windows. For example, you could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a macOS application.

**Note:** To set Internet links to open in macOS or Windows, Parallels Tools must be installed (p. 219). In most cases, Parallels Tools are installed by default.
To set Internet links to open in macOS or Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and select Web & Email.
3. Click the menu for the type of link you want to set. If you don't see the link type you want, click More Applications. The following types of links can be set:
   - Web Pages: Web pages accessible through the HTTP and HTTPS protocols.
   - Email: Links in the mailto format that open a pre-addressed email.
   - Newsgroups: Links in the news. format that typically open a newsreader application.
   - FTP: File upload and download locations accessible through the FTP protocol.
   - RSS: Episodic content, such as blogs and podcasts.
   - Remote Access: Locations accessible through the Telnet and Secure Shell (SSH) protocols.
4. Choose one of the following:
   - Default: The link opens in the application or application set as default in the operating system (macOS or Windows) where you click the link.
   - Open in Windows: Links clicked in macOS or Windows open in the default Windows application for that link type.
   - Open in Mac: Links clicked in macOS or Windows open in the default macOS application for that link type.

Open the Current Safari Page in Internet Explorer

Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in macOS using Safari, you can quickly open the current page in Internet Explorer by doing the following:

1. First you need to install the "Open in Internet Explorer" plugin. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and select Web & Email.
3. Click Install Plugin.
4. Once the plugin is installed, click the Open in IE button in the toolbar.

If Windows isn't already open, it starts up and the page opens in Internet Explorer.
Share External Storage Devices and Volumes

When you connect an external storage device, such as a USB drive, to your Mac, you can access the contents from macOS applications.

You can set Parallels Desktop to automatically mount storage devices and volumes to Windows. That way, you can access the contents from both macOS and Windows.

The following items can be mounted to Windows:

- Removable drives: External storage devices, such as USB hard disks and USB flash drives.
- CD/DVD drives: CD and DVD drives or CD/DVD images (files most commonly ending in `.dmg`, `.iso`, and `.img`).
- Network folders: Folders shared over the network.

To make these items mount to Windows automatically, do the following:

1. Start Windows. (p. 30)
2. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
3. Click Options and select Sharing > Share Mac.
4. Select Map Mac volumes to Windows.

When you connect a storage device or volume, it is mounted as a network drive. For example, a USB flash drive plugged in to your Mac will be accessible from both the `/Volumes` folder in macOS and `My Computer` in Windows.

**Note:** Permissions for accessing the mounted device from Windows are the same as permission settings for the device in macOS. For example, if you can read from and write to a USB flash drive in macOS, you can also read from and write to it in Windows. One exception: macOS can't write to NTFS volumes, regardless of permissions.

Share Windows External and Network Drives with Mac

When you connect an external NTFS drive to Windows or connect to a network drive in Windows, you can make these drives available in macOS as well.

Do the following:

1. Start Windows. (p. 30)
2. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

3 Click Options and select Sharing > Share Windows.

4 Select Share Windows network drives with Mac and Share Windows-connected drives with Mac.

When you connect to a network drive in Windows or connect an NTFS drive to Windows, these drives become available in macOS. To access them, go to the Finder sidebar > Shared section and click the virtual machine name.

Use a Disk Image with the Virtual DVD Drive

While working in Windows, you can select a disk image file to be used with the virtual Windows DVD drive, as if it was a DVD inside a real drive. To do so:

1 In Windows Explorer, open Computer or This PC, right-click the DVD drive icon, and choose Select disk image.

2 Locate the disk image you want to use and click Open.

Note: This functionality is available only for Windows with Parallels Tools installed (p. 219).

Save Internet Passwords in Mac Keychain

Nowadays, users don't have to remember numerous passwords to various social media accounts and websites. Your Mac can store and automatically fill them in when necessary.

If you browse the Internet in Windows using Internet Explorer or Microsoft Edge, you can set to store your passwords in Mac keychain. If you do so, the passwords you enter in Internet Explorer or Microsoft Edge will be saved to Mac keychain and you will be able to auto fill them from these browsers. These passwords won't be accessible to any other applications and won't be lost if Windows gets corrupted or reinstalled.

To store Internet passwords in Mac keychain:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.

2 Click Options and select Web & Email.

3 Select Store Internet passwords in Mac keychain.

Add Windows Disks to the Finder

If you often work with Windows, you can add Windows disks to the Finder to keep Windows files always at hand.
Do the following:

1. First of all, make sure that Windows disks are shared with macOS. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the menu bar is visible at the top of the screen, choose Actions > Configure.
   Then click Options and select Sharing > Share Windows.
   Make sure that Access Windows folders from Mac is selected. If you want to share Windows OneDrive too, select Share OneDrive with Mac.

2. In the next step, you need to allow Windows disks to be mounted to the macOS desktop.
   Open the Finder, choose Finder > Preferences and select Connected servers.

3. Now you need to mount Windows disks to the macOS desktop. In the Finder, click your virtual machine - it should be available in the Shared section. The virtual machine must be running.

   **Note:** In macOS 10.14 Mojave (when it is officially released), you can find your virtual machine in the Network section.

Then double-click any of Windows disks. The disk gets mounted and shown on the desktop.
4 Drag the disk from the desktop to the Favorites section in the Finder.

Now this Windows disk is always available in the Finder. You can use it to access Windows files.

**Note:** To use the disk, Windows must be running.

### Apply macOS Parental Controls to Windows

If you have administrator rights in macOS, you can use parental controls to prevent others with accounts on your Mac from using certain Windows applications or accessing certain web sites.

To apply parental control settings:

1. In macOS, choose Apple menu > System Preferences and click Parental Controls.
2. Click the lock if it's not unlocked, and then enter an administrator name and password.
3. Select the account that you want to restrict, click Enable Parental Controls, and set up the controls. If you want the user to be able to use some Windows applications, be sure to select Parallels Desktop in the list of allowed applications.

For more information on using parental controls, see Mac Help.

### Mouse, Trackpad, and Keyboard

Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the way you want them to.

You can also use trackpad gestures to control Windows applications just as you can with macOS applications.
Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows applications.

**Set Your Mouse or Trackpad to Right-Click and Middle-Click**

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking.

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click the mouse. You can change which key combination triggers a right-click.

You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse (included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current Apple desktop computers), you can set the mouse to allow right-clicking.

Most other mice are pre-configured for right-clicking.

**Set the Trackpad for Right-Clicking.**

1. Choose Apple menu > System Preferences and click Trackpad.
2. Select Secondary Tap.

Now you can tap the trackpad with two fingers to imitate a right-click.

**Set an Apple Mighty Mouse for Right-Clicking**

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Choose Secondary Button from the menu to the right of the mouse.

Now you can press the right side of the mouse to right-click.

**Set an Apple Magic Mouse for Right-Clicking**

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Select Secondary click.

Now you can press the right side of the mouse to right-click.

**Set Which Key Combination Triggers a Right-Click or a Middle-Click**

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2. Click Shortcuts.
3. If necessary, click the lock icon and enter an administrator password.
4 Select Mouse Shortcuts in the sidebar.

5 Click the lock to prevent further changes.

6 Select Secondary click (for right-click) or Middle click.

7 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.

You can use any combination of the Control, Option (Alt), Shift, and Command keys.

Control Applications with Trackpad Gestures

If you have an Apple portable computer, such as a Macbook, or if you have an Apple Magic Trackpad, you can use gestures, such as swiping left or right across the trackpad, to control some Windows applications.

Note: You can control some Windows applications using three-finger swipes only if you’re using Parallels Desktop with macOS Snow Leopard. In macOS Lion and later, three-finger swipes are used by default to move between full-screen apps and spaces.

The following table provides commands to control some of the more popular Windows applications.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard and Mouse Combination</th>
<th>Touchpad Gesture</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Use Windows on Your Mac

<table>
<thead>
<tr>
<th>Action Description</th>
<th>Shortcuts</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Scroll</strong></td>
<td>Up, down, left, or right arrow</td>
<td>Swipe up, down, left, or right with two fingers</td>
</tr>
<tr>
<td><strong>Microsoft PowerPoint</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start slide show</td>
<td>F5</td>
<td>n/a</td>
</tr>
<tr>
<td>End slide show</td>
<td>Esc</td>
<td>n/a</td>
</tr>
<tr>
<td>Perform the next animation or advance to the next slide</td>
<td>N, Enter, Page Down, Right Arrow, Down Arrow, Space (or click the mouse)</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Perform the previous animation or return to the previous slide</td>
<td>P, Page Up, Left Arrow, Up Arrow, Backspace</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/ Ctrl+wheel down</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Microsoft Word/Excel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/ Ctrl+wheel down</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Windows Media Player</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start/pause playback</td>
<td>Space</td>
<td>n/a</td>
</tr>
<tr>
<td>Skip to the next song</td>
<td>Ctrl+F</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Play the previous song</td>
<td>Ctrl+B</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
<tr>
<td><strong>Media Player Classic (k-lite)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start playback/pause</td>
<td>Space</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
<tr>
<td><strong>Winamp</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start playback/pause</td>
<td>X to start, C to pause</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume up</td>
<td>Up Arrow, wheel up</td>
<td>n/a</td>
</tr>
<tr>
<td>Volume down</td>
<td>Down Arrow, wheel down</td>
<td>n/a</td>
</tr>
<tr>
<td><strong>Microsoft Internet Explorer</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page back</td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Page forward</td>
<td>Option+Right Arrow (Alt+Right Arrow)</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/Ctrl+wheel down</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Mozilla Firefox</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page back</td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>Swipe right with three fingers</td>
</tr>
</tbody>
</table>
Use Windows on Your Mac

<table>
<thead>
<tr>
<th>Page forward</th>
<th>Option+Right Arrow (Alt+Right Arrow)</th>
<th>Swipe left with three fingers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl-wheel up/ Ctrl-wheel down or Ctrl.&quot;+&quot;/&quot;Ctrl.&quot;-&quot;</td>
<td>Pinch open/pinch close</td>
</tr>
</tbody>
</table>

**Windows Picture and Fax Viewer**

<table>
<thead>
<tr>
<th>Next image</th>
<th>Right Arrow</th>
<th>Swipe right with three fingers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous image</td>
<td>Left Arrow</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>&quot;+&quot;/&quot;-&quot;</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td>Rotate clockwise</td>
<td>Ctrl+K</td>
<td>Rotate right with two fingers</td>
</tr>
<tr>
<td>Rotate counterclockwise</td>
<td>Ctrl+L</td>
<td>Rotate left with two fingers</td>
</tr>
</tbody>
</table>

**Use Keyboard Shortcuts**

Both macOS and Windows provide extensive keyboard shortcuts. For example, in macOS you can hold down the Command key and press Q (Command-Q) to quit the current application.

To enter a keyboard shortcut, simply press a key combination on your keyboard.

You can also enter keyboard shortcuts by doing one of the following:

- Click the Parallels icon in the menu bar, then choose Devices > Keyboard and choose a key combination.
- Choose Devices > Keyboard and choose a key combination.

These methods are most useful for using keyboard shortcuts that include keys not included on a Mac keyboard, such as Alt + PrintScreen.

**Note:** To use the F1-F12 keys on a MacBook, press and hold the Fn key and then press an F key.

**Customize Keyboard Shortcuts**

By default, Parallels Desktop maps common macOS keyboard shortcut key combinations to the equivalent Windows key combinations. That way if you're used to, for example, pressing Command-C to copy text in macOS, you don't have to switch to the Windows equivalent, Control-C.

You can also use and customize keyboard shortcuts for switching between Coherence, Full Screen, and Window view modes, and for showing and hiding Parallels Desktop.
Customize Keyboard Shortcuts

1. Do one of the following:
   - Click the Parallels icon on the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2. Click Shortcuts

3. Select Windows from the Virtual Machines list in the sidebar.
   Or if you're using another operating system with Parallels Desktop and you want to customize keyboard shortcuts for it, select it in the sidebar.

When you're using a Windows application, pressing a key combination in the From column above triggers the key combination in the To column.

4. If the lock icon is locked, click it and enter an administrator password.

5. Do one of the following:
Use Windows on Your Mac

• To edit an existing key combination, double-click the key combination or select it and click the Edit button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

• To delete a key combination, select it and click the Remove button.

• To add a new key combination, click the Add button.

If you're using multiple operating systems with Parallels Desktop, you can create keyboard profiles for each OS (p. 124).

Note: 1. Some key combinations can't be edited or deleted.

2. There are Mac shortcuts that do not have similar shortcuts in Windows. For example, you can use the F11 key or Fn+F11 combination to see your macOS desktop with Expose, but in Windows there are no keys or key combinations that enable you to perform the same action, because there is no Expose in Windows.

Enable or Disable macOS System Shortcuts

In macOS the function keys on your keyboard (F1, F2, F3 and so on) control functions like activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. By default, when a Windows application is active the function keys and other Mac system shortcut key combinations (such as pressing Cmd + Tab to switch between open applications) continue to activate macOS functions.

To set whether function keys and macOS system shortcut key combinations activate functions in macOS or Windows:

1. Click macOS system shortcuts in the sidebar.

2. Select one of the following from the Send macOS system shortcuts menu:
   • Always: When Windows or Windows applications are active, function keys and other system shortcuts always trigger functions in Windows.
   • Never: Function keys and other system shortcuts always trigger functions in macOS.
   • Auto: If you're working with Windows, system shortcuts that don't function in Windows (for example, Control-Up Arrow button to display Mission Control) trigger functions in macOS. If you're using macOS as a guest OS and a guest OS or its application is active, system shortcuts that are typical only to macOS trigger functions in the guest version of macOS.
Customize Keyboard Menu

In Window mode you can enter key combinations by choosing Devices > Keyboard and then choosing a key combination. To customize available key combinations, do the following:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.

2. Click Shortcuts > Keyboard Menu.

3. If the lock icon is locked, click it and enter an administrator password.

4. Do one of the following:
   - To add a new key combination, click the Add button.
   - To remove a key combination from the Keyboard menu, select it and click the Remove button.
   - To edit an existing key combination, double-click the key combination or select it and click the Edit button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

Create New Keyboard Shortcuts

You can press certain key combinations, called keyboard shortcuts, to quickly trigger various actions in Parallels Desktop. For example, you can press Command-Control-F to switch Windows to Full Screen mode. You can use existing keyboard shortcuts (you can see them in the Parallels Desktop > Preferences > Shortcuts > Application Shortcuts pane), and you can also create your own.

To create a new keyboard shortcut:
1 Make a note of the name for the command you want a shortcut for as it appears in a menu in Parallels Desktop. For example, if you want to create a new shortcut for switching to Full Screen mode, you can see by opening the View menu in Parallels Desktop that the name of the menu item is Enter Full Screen:

2 In macOS, choose Apple Menu > System Preferences.
3 In System Preferences, click Keyboard and click Shortcuts.
4 Select App Shortcuts in the sidebar and click the Add button.
5 If you want a new shortcut to work only for Parallels Desktop, choose Parallels Desktop from the Application menu. If you leave All Applications selected, the shortcut will work for any application that has the same command name and is currently active.
6 Enter the menu item name from Step 1.
   **Important:** You must enter the command name exactly as it appears in the Parallels Desktop menu or your new shortcut won't work.
7 In the Keyboard Shortcut field, press the key combination that you want to trigger the action.
   **Note:** You must create separate shortcuts for commands that change in the menu depending on the state of Parallels Desktop, such as Enter Full Screen and Exit Full Screen.

See and Change Windows Input Language In macOS

While you're working with Windows or any Windows applications, Parallels Desktop shows the input language set in Windows in macOS menu bar. You may find it useful while working with Windows in Coherence (p. 39) when the guest OS desktop is hidden.

As soon as you switch to Mac, the input language in macOS menu bar changes back to the language that was set before you started working with Windows.

To make this feature work properly, Parallels Tools (p. 130) must be installed and the same input languages must be available in Windows and macOS. To learn how to add input languages, please refer to the help resources for these operating systems.
Use Windows on Your Mac

Change Windows Input Language From macOS Menu Bar

To change the Windows input language from the macOS menu bar:

1. Click Windows or your Windows application to make it active.
2. Choose the language you need from the Input menu available in the macOS menu bar.

![Input menu in macOS](image)

**Note:** The language you’re selecting from the Input menu must be also available in Windows. To learn how to add a language to the list of input sources in Windows, please refer to the Windows help resources.

If the Input menu isn't available in macOS menu bar, you can set it to show by doing the following:

1. In macOS, choose Apple menu > System Preferences and click Language & Text.
2. Click Input Sources.
3. Select the language or languages you want to use from the sidebar.
4. Select Show input menu in menu bar.

Mouse & Keyboard Settings

Use Mouse & Keyboard settings, you can:

- Set whether the mouse pointer behavior is optimized for games.
- Set whether the mouse pointer sticks at the edges of the window in Window mode (p. 41).
- Set whether modifier keys are optimized for games.
- Set whether edge swipe gestures are enabled.

To access Mouse & Keyboard settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Click Hardware and select Mouse & Keyboard in the sidebar.

Mouse

If you play games in a virtual machine, the Mouse menu allows you to set how to use a mouse:

- **Auto-detect for games.** This is a recommended default setting. If you're working with a guest OS application, the mouse moves freely between the guest operating system and macOS. However, when you start a game, SmartMouse automatically captures the mouse input in the virtual machine so that you couldn't move the mouse to macOS by mistake and automatically releases the mouse when you quit the game.

- **Optimize for games.** If your mouse accidentally moves to macOS when you're playing a game, select this option to make the mouse work in the virtual machine only.

- **Don't optimize for games.** In some rare cases, SmartMouse may detect an application as a game and the mouse starts working incorrectly with the application. If you have this problem, choose Don't optimize for games.

Modifier Keys Optimization

Choose Optimize for games from the Keyboard menu if you actively use the modifier keys Option (Alt), Ctrl, and Shift in action games. If you choose this option, signals from these keys will be processed faster.

Note: You're not recommended to optimize keyboard for games when not playing games.
Mouse Pointer Sticks at Edges

When working with a virtual machine in Window view mode (p. 41), you may often need to move the mouse pointer to the edges of the virtual machine window to display various guest OS items: for example, to display the Start menu in Windows 8, hidden taskbar in Windows XP, or macOS menu bar when any of the guest macOS applications is running in full screen.

The Mouse pointer sticks at window edges option makes the mouse pointer pause for a while at the edges of the virtual machine window and you won't move the mouse outside of the virtual machine window by mistake. To move past the edge, just move the mouse quickly.

Windows Touchpad Gestures

Select Enable swipe from edges to enable edge swipe gestures, for example, swiping from the right edge of the touchpad to show the Charm Bar, when working with Windows.

Note: This option is available for Windows 8 and later.

If you often accidentally swipe from the edges of the touchpad and activate features, you may want to disable edge swipe gestures by deselecting this option.

Connect External Devices

Parallels Desktop allows you to use USB, Thunderbolt, and FireWire devices with Windows.

Many external devices, such as mice and printers, are available by default to both Windows and macOS when you connect them to your Mac.

Some external devices, such as an Apple iPhone, can only be used with either macOS applications or Windows applications, but not both at the same time. When you connect such a device, you can choose whether you want to use it with macOS or Windows.

To connect an external device:

1. Connect the device to your Mac.
2 If Windows is running and the device can't be used with both Windows and macOS at the same time, you're prompted to choose which one you want to use it with. If you want Parallels Desktop to remember your choice, select the corresponding checkbox. To use the device with macOS applications, click the Mac icon. To use it with Windows applications, click the Windows screen.

**Important:** To be able to use a USB device with Windows applications, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer's website.

You can also set what happens when any new external device is connected and set particular external devices to always be used with either macOS or Windows (p. 75).

If you have a USB device that is already connected to the Mac, you can do the following to connect it to Windows:
• If Windows is running in the Full Screen or Window mode, move the mouse pointer to the top of the screen, click Devices > USB & Bluetooth > and select the device you want to connect.

• If Windows is running in Coherence, click the Parallels icon in the menu bar > Devices > USB & Bluetooth > and select the device you want to connect.

**Note:** If the device you’re trying to connect is being used by some macOS application, you will see a warning. In this case, first you need to quit this application and then try to connect the device again.

**Connect a Common Access Card reader**

A Common Access Card (CAC) reader can work simultaneously in macOS and Windows.

1. Connect the CAC reader to your Mac.
2. When you’re prompted to choose Windows or the Mac, click the Windows screen. The CAC reader becomes available to both Windows and macOS.

**Adjust Devices Settings**

In the Devices pane of Parallels Desktop Preferences, you can:

• Set what happens when you connect any new USB, Thunderbolt, or FireWire device to your Mac.
• Set a particular external device to always be used with either macOS or Windows.
Choose to mount Windows-connected external NTFS drives to Mac.

To access Devices Settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2. Click Devices.

Set What Happens When You Connect a New External Device to Your Mac

Choose one of the following:

- Connect it to my Mac. New external devices are automatically available for use with macOS applications.
- Connect it to the active virtual machine. New external devices are automatically available for use with Windows applications. If Windows isn't running, the external device is connected to macOS.
- Ask me what to do. Each time you connect an external device, you're prompted to choose whether you want to connect the device to Windows or the Mac.
Set a Particular External Device to Always Be Used With macOS or Windows

If you know you always want a particular external device to be available to either macOS or Windows, you can set it to do so by following the instructions below. The device must already have been connected to your Mac at least once.

1. Click the Add (+) button towards the bottom of the window.
2. Select the device from the list.
3. Double-click the word (either Computer or some form of Windows) in the Connect To column. The word becomes a pop-up menu.
4. Do one of the following:
   - To set the device to always be available to macOS applications, choose Computer from the menu.
   - To set the device to always be available to Windows applications, choose Windows from the menu.

To remove an existing assignment, so that the device no longer automatically connects to macOS or Windows, select the device in the External Device column and click the Remove (-) button.

Important: To be able to use an external device with Windows applications, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer's website.

Connect Bluetooth Devices

Parallels Desktop lets you connect Bluetooth devices directly to Windows.

Before connecting a Bluetooth device, Bluetooth must be enabled.

To enable Bluetooth:

1. If Bluetooth is turned off in macOS, turn it on. Choose Apple menu > System Preferences and click Bluetooth. Then select On.
2. In Parallels Desktop, start Windows (p. 30) if it isn't already started.
3. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
4. Click Hardware and click USB & Bluetooth in the sidebar.
5. Select Bluetooth devices.
Use Windows on Your Mac

Once you’ve enabled Bluetooth, you can pair Bluetooth devices with your computer and they’ll work with both Windows and macOS. For instructions on pairing a Bluetooth device with your computer, see the documentation that came with the device.

In Windows 7, you can send a file to a paired Bluetooth device that’s capable of receiving files by right-clicking the file and choosing Send to > Bluetooth.

Besides Windows, you can connect Bluetooth devices to any guest operating systems (Linux or macOS) that support USB Bluetooth adapters.

Print from Windows

By default, Windows is set to use the same printer that you use with macOS. Simply print from a Windows application the way you normally would.

You can also set Windows to use a different printer. There are a few ways to set up printing in Windows:

- Share any of the printers connected to your Mac.
- Connect to a network printer.
- Connect a USB printer directly to Windows.

Share a Printer Connected to Your Mac

You can use any printer connected to your Mac with Windows applications.

**Note:** This functionality is also available for Linux with Parallels Tools installed (p. 131).

To print a document from a Windows application:

- Open the document and simply print it the way you normally would (for example, choose File > Print).

In the print window, you can choose any printer that’s connected to your Mac.

Share Printers Connected to Your Mac

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and select Shared Printers.

**Note:** The Shared Printers pane is available for Windows 2000 and newer versions of Windows.
3 Select Share Mac printers with Windows.

Set a New Default Printer

By default, Windows is set to use the same default printer as your Mac. To use a different default printer for Windows.

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Hardware and select Shared Printers.

3 Deselect Synchronize default printer.

Now you can set a new default printer in Windows the way you normally would.

Show Page Setup Before Printing

When you choose to print a document from Windows, first you need to set how the document will be printed. You usually have to specify various printing settings, such as orientation, page size, whether to print the document on one or both sides, etc. Once everything is ready and you click Print in Windows, the macOS window with printing settings appears as well. It's done by default for you just to ensure that the document will be printed exactly the way you want.

To make the documents print without showing this macOS page setup window:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Hardware and select Shared Printers.

3 Deselect Show page setup options before printing.

Add a Printer in Linux

The procedure of adding a printer in a Linux guest operating system depends on the Linux distribution. In this example, we describe how to add a printer to a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to add a printer to a Linux virtual machine:

1 Start the Linux virtual machine and log in when the guest operating system boots up.

   Note: You must log in as root or acquire root privileges after successful login. If you don't do that, you will be required to enter the root password when starting the system-config-printer administration tool in the next step.
Use Windows on Your Mac

2 Start the `system-config-printer` administration tool by doing one of the following:
   • Click System > Administration > Printing; or
   • Start the Terminal and enter the following command:

```
system-config-printer
```

3 In the displayed window, click New Printer.

4 In the next window, you must type a printer name. Under this name the printer will be displayed in your Linux guest operating system. You can also enter the printer description and location. When ready, click Forward.

5 Now you have to specify how your Mac printer will be shared with the virtual machine. As the printer is connected to the virtual machine printer port, select LPT #1 (or another port to which the printer is connected) and click Forward.

6 Then specify the printer manufacturer and model. No matter what printer you have, choose either HP Color LaserJet 8500 PS or Apple Color LW 12/660 PS. When ready, click Forward.

7 Click Apply to finish setting up the printer.

Now the printer is properly configured and you can use it to print documents from your Linux virtual machine.

Set Up a Printer Using Bonjour

If you have more than one Mac connected to your home network, you can use Apple Bonjour for Windows to share any printer connected to any of them.

To see the list of all Windows operating systems supported by Bonjour, please refer to http://support.apple.com/kb/dl999.

**Important:** To share a Mac printer with Windows via Apple Bonjour, Windows must be configured to work in the Bridged networking mode (p. 90).

To set up a printer via Bonjour:

1 Be sure the printer you want to use is set to be shared on your Mac. To share a printer, in macOS choose Apple menu > System Preferences and click Print & Fax. Then select the printer and select Share this printer.

2 Open Parallels Desktop and start Windows.

3 When Windows starts, go to http://support.apple.com/kb/dl999 and download the Bonjour for Windows installation package.

4 In Windows, start the Bonjour installation by launching the `BonjourPSSetup.exe` file from the folder in which it was downloaded.

5 Follow the onscreen instructions to install Bonjour for Windows.

6 Start the Bonjour Printer wizard either by double-clicking its icon on the desktop or by selecting Start -> All Applications -> Bonjour Print Services -> Bonjour Printer Wizard.
7 In the Browse for Bonjour Printers window, select the printer that you want to use and click Next.

8 If the next window you see is Completing the Bonjour Printer Wizard, then the driver required by this printer is available in the Windows driver library and the printer has been successfully configured. Click Finish and you can start using the newly added printer to print documents from Windows applications.

However, if the next window you see is Install Bonjour Printer, you must choose the printer manufacturer and model.

If the required printer model is not listed, you can do one of the following:

- Install the printer drivers in Windows. Then click Have Disk button in the Install Bonjour Printer window and specify the path to the .inf file located in the folder where you installed the printer drivers.

- In the Install Bonjour Printer window, select Generic in the Manufacturer list and Generic/Postscript in the Model list.

  Click Next.

9 In the Completing the Bonjour Printer Wizard window, click Finish. You can start using the newly added printer to print documents from Windows applications.

**Set Up a Network Printer**

You can install a network printer directly into Windows.

Before installing a network printer in Windows, make sure that:
Use Windows on Your Mac

- Your Mac can access the Internet.
- Windows is configured to work in either the Shared networking mode (p. 89) or Bridged networking mode (p. 90) and can access the Internet too.
- The user account in Windows has permission to access the network printer.
- You know the printer IP address.

After that, you can log in to Windows and install a network printer.

In Windows

Before adding a network printer in Windows, download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer documentation.

To add a network printer in Windows 7 or Windows Vista:

1. Open the Windows Start menu and select Control Panel.
2. In the Control Panel window, select Hardware and Sound and click Add a printer in the Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens.
3. In the first window, click Add a network, wireless or Bluetooth printer.
4. In the next window, click The printer that I want isn't listed.
5. In the Find a printer by name or TCP/IP address window, select Add a printer using a TCP/IP address or hostname and click Next.
6. In the Type a printer hostname or IP address window, do the following:
   1. Select TCP/IP Device from the Device type menu.
   2. Specify the printer IP address in the Hostname or IP address field.
   3. Clear the Query the printer and automatically select the driver to use option if it is selected.
   4. When ready, click Next.
7. If prompted to specify additional port information, choose Standard, select Generic Network Card from the list, and click Next.
8. In the Install Printer Software window, specify the manufacturer and model of the network printer.
   If the required printer model is not listed, click Have Disk button and specify the path to the .inf file located in the folder where you installed the printer driver.
   When ready, click Next.
9. Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.

To add a network printer in Windows XP:

1. Open the Windows Start menu and select Control Panel.
Use Windows on Your Mac

2 In the Control Panel window, double-click the Printers and Faxes item.
3 Click the Add a printer link to open the Add Printer wizard.
4 In the Welcome to the Add Printer Wizard window, click Next.
5 In the Local or Network Printer window, select Local printer attached to this computer and clear the Automatically detect and install my Plug and Play printer option if it is also selected. When ready, click Next.
6 In the Select a Printer Port window, select Create a new port and specify Standard TCP/IP Port as the port type. When ready, click Next.
7 In the Welcome to the Add Standard TCP/IP Printer Port Wizard window, click Next.
8 In the Add Port window, specify the network printer IP address and click Next.
9 If prompted to specify additional port information, choose Standard, select Generic Network Card from the list, and click Next.
10 In the Completing the Add Standard TCP/IP Printer Port Wizard window, click Finish.
11 In the Install Printer Software window, specify the manufacturer and model of the network printer.
   If the required printer model is not listed, click Have Disk button and specify the path to the .inf file located in the folder where you installed the printer driver.
   When ready, click Next.
12 Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.

In Linux

The procedure of setting up a network printer in a Linux or FreeBSD guest operating system depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set up a network printer in a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to set up a network printer in a Linux or FreeBSD virtual machine.

Note: For more detailed information, refer to the CUPS documentation.

To set up a network printer:
1 Start the virtual machine.
2 Make sure the following components are installed in the guest operating system:
   • Common UNIX Printing System (CUPS). Installation instructions can be found at CUPS site;
   • Samba service. Installation instructions can be found at Samba site; and
   • A Web browser, since we consider controlling CUPS via web interface.
Use Windows on Your Mac

**Note:** To set up a network printer, you should have root privileges.

3 Download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer's documentation.

4 Start Common UNIX Printing System. In the Terminal, type the command:

```
/etc/init.d/cups start
```

5 Start a web browser and type either the IP address of your virtual machine or http://127.0.0.1:631.

6 Click the Add Printer button.

7 In the Add New Printer window, specify a printer name. Under this name the printer will be displayed in the guest operating system. You can also enter the printer description and location. When ready, click Forward.

8 In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click Continue.

9 In the Device URI for <Printer Name> window, specify the printer IP address in the following format:

```
socket://<printer IP address>
```

When ready, click Continue.

10 In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your printer and click Continue.

11 In the Model/Driver for <Printer Name> window, select the model of your printer and click Add Printer.

12 Enter the root password when prompted.

CUPS performs the installation. If the installation is successful, the "Printer <name> has been configured successfully" message is displayed. Now you can use this printer to print documents from the virtual machine.

**Set Up a USB Printer**

You can connect a USB printer directly to Windows. In this case, the printer isn't available to macOS. If you want to use the printer to print both from macOS and from Windows, see Share a Mac Printer (p. 78).

To connect a USB printer directly to Windows:

1 In Parallels Desktop, start Windows.

2 When Windows starts, install the printer driver. For detailed information on how to do that, refer to the printer manufacturer's documentation. Typically you can find drivers on the manufacture's website.

3 Do one of the following:
   - If the USB printer is already connected to your Mac:
If Windows is in Coherence, click the Parallels icon in the menu bar, choose Devices > USB and select this printer from the list.

If Windows is working in a separate window, in the Mac menu bar click Devices > Printer > Printer and select this printer from the list.

• If the USB printer is not connected to your Mac, connect it. In the New USB device detected window, connect the printer to Windows.

4 In Windows, follow the Add New Hardware wizard instructions.

Create a PDF File

When working with a text document, web page, or other file, you may wish to create a Portable Document Format (PDF) file out of it. A PDF file preserves the format and layout of a document, so others can see it as if it were printed on the page.

To create a PDF file, select Print to PDF (Mac Desktop) when choosing a printer. A PDF file is saved on the Mac desktop.

**Note:** This functionality is available for Windows guest operating systems provided that Parallels Tools are installed (p. 128) and all Mac printers are shared (p. 78) with Windows.

Use the Built-in iSight Camera or Another Webcam

If your Mac or display has a built-in iSight camera, or if you connect a compatible external webcam, by default you can use it with Windows.

To use a built-in iSight or external camera with Windows:

• Simply open a Windows application that uses a camera, you should be able to select the iSight or external camera for use with the application.

**Note:** If you are running a guest OS other than Windows XP Service Pack 2 or later, Windows Vista, or Windows 7, be sure you have USB video device class (UVC) drivers installed.

Disable Camera Sharing

If you don’t want Windows applications to be able use connected webcams or the built-in iSight camera, you can disable camera sharing by doing the following:

1 Do one of the following:

• Click the Parallels icon in the menu bar and choose Configure.

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Click Hardware and click USB & Bluetooth.
3 Deselect Web cameras.

Show a Presentation on an External Monitor or Projector

You can easily connect your Mac to an external monitor or projector and show a presentation from a Windows application, with little configuration needed.

To do so:
1 Start Windows (p. 30) if it isn't already running.
2 Connect your Mac to the external monitor or projector as you normally would. A message appears asking if you're going to show a presentation.

3 If you want to show the exact contents of your computer's display on the external display or projector, select Mirror display.

If you don't select Mirror display, certain applications, such as Microsoft Powerpoint, may show a presenter view on your computer while showing only the presentation on the external display or projector.
4 Click Yes. Windows switches to Presentation mode, displayed at full screen on both your computer's display and external display or projector. After that, you can start showing your presentation.

**Note:** To learn how to choose on which display the presentation is shown, please refer to Help of the application you're using for presentations.

**Important!** While you're working in Presentation mode, changing display settings in Windows may cause the presentation to malfunction.

---

## Protect Your Data

You probably have important documents, photos, and more on your Mac. When running Windows on your Mac, it's especially important to protect your data from viruses and unauthorized use. Read this section to learn how.

### Isolate Windows from Mac

You can isolate Windows from macOS, so that they no longer share folders, profiles, and applications, connected external devices are no longer automatically accessible by Windows, Windows and Mac no longer synchronize volume, and you can no longer copy or move objects between Windows and macOS. Isolating Windows from macOS may provide a higher level of security by not allowing compromised items from one OS to come into contact with the other.

To isolate Windows from macOS

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Security.
3. Select Isolate Windows from Mac.

### Work in Windows Without Saving Changes

If you don't want Windows to store the changes you make to it during the working session (for example, when testing some Windows applications that may damage Windows), you can start Windows in Rollback Mode:

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

1. Open Parallels Desktop.
2. From Control Center select Windows that you want to start in Rollback Mode and click Actions > Start in Rollback Mode.
Set Windows to Always Start in Rollback Mode

If you want Windows to always start in Rollback Mode:

1. Open Parallels Desktop.
2. From Control Center select Windows and click Actions > Configure > Security.
3. Choose Ask me what to do from the Rollback Mode menu.

**Note:** If you have the automatic compression of virtual disks (p. 94) enabled, it will become disabled after you enable Rollback Mode.

Set Password Requirements

For added security, you can set Parallels Desktop to require an administrator password to perform certain functions.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Security.
3. Select one or more of the following to require a macOS administrator password to perform the selected action:
   - Change virtual machine state: A password is required to start, stop, suspend, pause, or shut down (p. 35) Windows.
   - Exit full screen mode: A password is required to exit full screen mode (p. 42).
   - Manage snapshots: A password is required to create or delete a snapshot (p. 114), or revert to a snapshot.
   - Change virtual machine configuration: A password is required to change the virtual machine configuration.

Encrypt Windows to Protect It from Unauthorized Use

If you store any important data using Windows applications, it is highly recommended that you encrypt Windows to protect your data from any unauthorized use.

Encrypt Windows

To encrypt Windows (it must be shut down):

2. On the Security tab, click Turn On, specify a password, and click OK.
**Warning:** The specified password is very important. You must record it. Without this password, you can't start Windows.

Change Your Password

To change the password for an encrypted Windows (it must be shut down):

2. On the Security tab, click Change Password, specify a new password, and click OK.

Remove Encryption from Windows

To remove encryption from Windows (it must be shut down):

2. On the Security tab, click Turn Off.

Connect to the Internet or a Network

Parallels Desktop allows you to use three types of networking with Windows:

- **Shared Networking:** Windows applications share a network connection with macOS. This is the default setting.
- **Bridged Ethernet:** Windows can use one of your Mac's network adapters. This makes Windows appear as a separate computer on the network.
- **Host-only networking:** Windows can access only your Mac.

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows applications have access to the same network and the Internet.

The Bridged Ethernet networking mode is more complex and you may need to contact your system administrator to set it up properly.

Read on for detailed information on these types of networking and how to configure them.

Share Network Access Between macOS and Windows

By default, Windows is set to access the network via macOS. Windows applications can access other computers on your local network and the Internet by using the IP address of your Mac. Windows does not have its own IP address on the network.
In most cases, you don’t need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows applications have access to the same networks and the Internet.

You may wish to use Shared Network mode in the following cases:

- Your Mac accesses the Internet via a modem or another non-Ethernet device.
- You need to access the Internet from inside Windows but are concerned about security.
- You have problems with working in the Bridged Ethernet mode.

To configure Windows to use Shared Networking:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Shared Network option is selected.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

Apply Separate Network Settings to Windows

When operating in the Bridged Ethernet mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.
Note: The Bridged Ethernet networking mode is more complex than the Shared Networking mode and you may need to contact your system administrator to configure it properly.

To configure Windows to work in the Bridged Ethernet mode:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, select the appropriate network adapter from the list. To connect the virtual machine’s adapter to the active network adapter of your Mac, choose Default Adapter.

   Note: In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

If you can't configure Windows to function in the Bridged Ethernet mode, consider using Shared Networking (p. 89).

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.
Use Windows on Your Mac

Use Host-Only Network Settings

Parallels Desktop provides a closed network that is accessible only to macOS and Windows. macOS is connected to this network via the Parallels Host-Only Networking adapter automatically created on your Mac during the Parallels Desktop installation. The addresses for Windows are provided by the Parallels DHCP server.

To configure Windows to use Host-Only Networking:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Hardware and then click Network.
3. In the Network pane, make sure that the Host-Only option is selected.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

Use Wi-Fi with Windows

If your Mac is already connected to the Internet wirelessly, by default Windows is also set to access the Internet wirelessly, with no setup required.

You can also bridge your virtual machine to Wi-Fi. When operating in this mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.

To bridge the virtual machine to Wi-Fi:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
Use Windows on Your Mac

- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Hardware and then click Network.

3 In the Network pane, choose Wi-Fi from the list.

After you perform these steps, Windows is able to connect to the Internet through the Wi-Fi adapter of your Mac.

If you can't configure your virtual machine to function in the Bridged Ethernet mode, consider using Shared Networking (p. 89).

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

Connect Windows to a VLAN

If your Mac is a VLAN (virtual local area network) member, Parallels Desktop allows you to bridge Windows to this VLAN.

To bridge Windows to the VLAN, do one of the following:

- Click the Parallels icon in the menu bar and choose Configure.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

1 Click Hardware and then click Network.

2 Select Bridged Network > VLAN from the Source list.

Windows is bridged to the selected VLAN.

Optimize Performance

If Windows isn't working as speedily as you'd like, there are several simple ways you can optimize its performance. This section contains many helpful instructions for doing just that.

Set How Much Memory is Allocated to Windows

Parallels Desktop is set to allocate a certain amount of your Mac's available RAM memory to Windows and the rest to macOS. If too much memory is allocated to Windows, macOS may slow down, which in turn can cause Windows applications to slow down because they're running on top of macOS. If, on the other hand, too much memory is allocated to macOS, then macOS applications may run well but Windows applications might slow down.

To optimize the performance of both Windows and macOS, set the memory allocated to Windows to be somewhere within the recommended range.
To set how much memory is allocated to Windows:

1. Shut down Windows (p. 35).
2. Choose Actions > Configure > Hardware > CPU & Memory.
3. Move the memory slider to somewhere within the recommended range, indicated by the graphic under the slider (see above).

If you use Windows applications that require lots of memory, like 3D or video production applications, it's best to set the memory allocation towards the high end of the range (move the slider to the right). If not, it's usually best to set it closer to the middle.

**Note:** No matter how much memory (RAM) your Mac has, the maximum amount of memory that can be assigned to Windows is 8 GB. However, if you're using Parallels Desktop for Mac Pro Edition, the maximum amount of memory that can be assigned to Windows is 64 GB.

If you change this setting and then you don't like how Windows is performing, then try a different setting.

**Note:** If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator's password will be required.

### Optimization Settings

Using Optimization settings, you can limit the virtual machine resource usage.

**Note:** The Optimization pane is available in Parallels Desktop for Mac Pro and Business Editions only.

To access Optimization settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Click Options and select Optimization.

If your Mac lacks resources for running two or more virtual machines at a time, you can limit the virtual machine resource usage for the virtual machine doing more important work to have more resources. Drag the slider between Low, Medium, and No limit points. If you change this setting and then don't like how Windows is performing, then try a different setting.

**Speed Up Games and Graphics Applications**

With Parallels Desktop, you can run games and applications that require video cards with DirectX or OpenGL support. To do so, you must enable 3D acceleration.

For information on whether a application requires DirectX or OpenGL support, see the materials that came with the game or application.

To enable 3D acceleration:

1 Shut down the virtual machine. (p. 35)
2 Choose Actions > Configure > Hardware.
3 In the Graphics pane, select a version of DirectX from the 3D acceleration menu.

**Note:** Parallels Tools must be installed (p. 219) before you can enable 3D acceleration. Parallels Tools are installed by default when you set up Windows.
Pause Windows When No Applications Are Open

You can conserve your computer's resources by setting Windows to pause automatically when no Windows applications are open. That way, more resources such as RAM and CPU can be used for macOS applications.

To set Windows to pause when no applications are open:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Options and select Startup and Shutdown.

3. Select Pause Windows when possible.

Optimize Virtual Machine for Games, Graphics, Productivity, or Development

When creating a virtual machine, you can optimize it according to your needs. You can choose to configure the virtual machine for:

- Productivity. Choose this profile if you're using the virtual machine for your everyday work with text editors, email, web browsers, etc.
- Games only. Choose this profile if you're using the virtual machine to play PC games on your Mac.

If you're using Parallels Desktop for Mac Pro Edition, you can configure your virtual machine also for:

- Design. Choose this profile if you're using the virtual machine to work with graphics applications.
- Software development. Choose this profile if you're using the virtual machine to develop and test software.
- Software testing. Choose this profile if you're using the virtual machine to test software in an isolated environment.

You can change this setting after the virtual machine is created:

1. Start Parallels Desktop.
2. In Control Center, right-click the virtual machine (it must be shut down) and choose Configure.
3. On the General tab, click Change.
4. Select the profile that best fits your need.
Use Windows on Your Mac

Note: If you made any changes to the virtual machine configuration and then select a new profile, your changes may be reset to this profile default values.

Work with Windows in Travel Mode

If you often travel with your MacBook, you must have come across the situations when you had no power adapter at hand to charge the Mac’s batteries or experienced some problems when connecting to public networks.

Travel Mode makes Windows use less energy to extend the Mac’s battery life and adjusts settings to connect to public networks.

Enter Travel Mode

To switch Windows to Travel Mode, do one of the following:

• If Windows is running in the Full Screen or Window mode, move the mouse pointer to the top of the screen and click Actions > Enter Travel Mode.

• If Windows is running in Coherence, click the Parallels icon in the menu bar and choose Actions > Enter Travel Mode.

Quit Travel Mode

To quit Travel Mode, do one of the following:

• If Windows is running in the Full Screen or Window mode, move the mouse pointer to the top of the screen and click Actions > Quit Travel Mode.

• If Windows is running in Coherence, click the Parallels icon in the menu bar and choose Actions > Quit Travel Mode.
Enter and Quit Travel Mode Automatically

You can also configure your virtual machine to enter and quit Travel Mode automatically:

1  Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.

2  Click Options and select Travel Mode.

3  To enter Travel Mode automatically, choose one of the following:
   • Always when on battery power: The virtual machine enters Travel Mode when the Mac starts working on battery power.
   • When battery power is: Choose from the menu when you want your virtual machine to enter Travel Mode.
   • Never: The virtual machine never enters Travel Mode automatically.

4  To quit Travel Mode automatically, choose one of the following:
   • When connected to power: The virtual machine quits Travel Mode when you connect your Mac to power.
   • Never: The virtual machine never quits Travel Mode automatically.

Schedule Windows Maintenance

From time to time, Windows needs to do various maintenance tasks like installing updates, cleaning and defragmenting the disk(s), etc. When Windows is doing these tasks, performance may slow down.

To avoid low performance when you're busy with important tasks, schedule Windows to run maintenance when you're away or at any time you like:

1  Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.

2  Click Options and select Maintenance.

3  Select Start maintenance and choose the day and time from the corresponding menus.

Once ready, Windows will do maintenance at the specified time.
Use Windows on Your iPad, iPhone, or Android Device

Parallels Access is a product created by Parallels that allows you to work with your Mac or Windows PC and their applications remotely from your iPad, iPhone or Android device. It also allows you to work with a remote computer via a web browser.

If you have Parallels Desktop installed on your Mac, you can use the Parallels Access app to access and control Windows.

Parallels Access lets you:

• Use any of your Windows applications on your mobile device
• Remotely start, stop, and reset Windows
• Connect over Wi-Fi or 3G
• Access Windows from anywhere over the Internet

Get Started

Before you can use Parallels Access, you must do the following:

1 On your iPad, iPhone or Android device, download and install Parallels Access from the App Store or Google play.
2 Be sure you have installed Windows on your Mac (p. 17).
3 In Parallels Desktop, do one of the following:
   • Click the Parallels icon in the menu bar and choose Preferences.
   • Right-click the Parallels Desktop icon in the Dock and choose Preferences.
4 Click Access.
5 Install the Parallels Access agent on your Mac by clicking Install.

You only have to do these steps once.

Access Windows from your iPad, iPhone or Android device

1 Turn on your Mac.
   Your Mac must be on for Parallels Access to access and use Windows.
2 Open Parallels Access on your iPad, iPhone or Android device and log in to your account using the same email and password you used to register Parallels Desktop.
3 Tap your Mac in the list of available Macs.
Use Windows on Your Mac

When you access Windows for the first time, you see tips about gestures you can use to control Windows. Tap Close to go to the Windows desktop.

For more information about using Parallels Access, please see here.

Save Time With Parallels Toolbox

Parallels Toolbox is a set of handy tools that may help you to save time during your daily routine. With Parallels Toolbox, you can:

- take screenshots;
- record audio;
- archive and unarchive files;
- block the Mac's camera and mute the microphone to prevent them from unauthorized access;
- set a countdown to count down days to a specific event;
- lock the Mac's screen to ensure that other users cannot access your desktop while you're away;
- prevent your Mac from going to sleep;
- and much more.

Please refer to the *Parallels Toolbox User's Guide* available online for the detailed information on what and how you can do with Parallels Toolbox.

Install Parallels Toolbox on your Mac

To install Parallels Toolbox:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click Toolbox.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click Toolbox.

2. Click Install and follow the onscreen instructions.

Save a Picture of the Screen

To save a picture of Windows in Window Mode:

- Choose View > Take Screenshot.

A file named *Parallels Picture.png* is saved on the macOS desktop.

100
You can also take a picture of the entire screen at any time by pressing Command-Shift-3. By default, pictures are saved to the macOS desktop.

**Set the Appearance of Virtual Machine Dock Icons**

You can choose which type of icon appears in the macOS Dock when your virtual machine is open or running.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click General.

2. From the Virtual Machine Dock Icons menu, choose one of the following:
   - **OS Icon:** The Dock icon shows the icon of the operating system installed in the virtual machine.
   - **Live Screenshot:** The Dock icon shows a miniature image of what you see in the virtual machine.
   - **None:** Virtual machines don't have separate icons in the Dock.

**Allow Windows Updates While Your Mac is Sleeping**

Parallels Desktop supports the macOS Power Nap technology, which lets you keep aspects of Windows up-to-date even while your Mac is sleeping. When Power Nap is enabled, services that usually update information after Windows wakes from sleep (for example, new emails in email applications and new event updates in Calendar) will update while your Mac is in sleep.

To use Power Nap, your computer must be compatible. See https://support.apple.com/HT204032 for more information.

To enable Power Nap:

1. On your Mac, choose Apple menu > System Preferences and click Energy Saver.

2. Depending on whether your Mac is working on batteries or is plugged, make sure Enable Power Nap while on battery power or Enable Power Nap while plugged into a power adapter is selected.

**Note:** To learn more about Power Nap, please refer to the macOS help resources.
Translate Words in Windows

If you're working with Windows and come across a word you don't know, you can easily look it up in macOS Dictionary. Just hover the mouse cursor over the word and either press Control-Command-D or tap (don't click) the touchpad with three fingers.

Notes:

1. Parallels Tools (p. 130) must be installed in Windows.
2. When you hover the mouse over a word, the mouse cursor should change from arrow \( \rightarrow \) to text selection \( \underline{\text{I}} \). You cannot look for words depicted on pictures.

Use the Touch Bar with Windows

If you have a MacBook with the Touch Bar, you can use it to work with Windows and Windows applications.

Note: This functionality is available for Windows 7 and later with Parallels Tools installed (p. 130).

When you're working with Windows and there's no application in the forefront, the Touch Bar shows the applications in the Windows Taskbar:

If you open some app or bring it to front, the Touch Bar shows the most commonly used buttons for this app. For example, if Microsoft Outlook is selected, the Touch Bar may look like as follows:

Customize the Touch Bar for a Windows Application

You can customize the Touch Bar according to your needs. To add new controls to the Touch Bar or remove them from it:

1. Do one of the following:
   - If Windows is running in the Window or Full Screen view mode, select the app for which you want to customize the Touch Bar, click View in the macOS menu bar and choose Customize Touch Bar for <app_name>.
   - If Windows is running in Coherence, select the app for which you want to customize the Touch Bar, click View in the macOS menu bar and choose Customize Touch Bar.

2. The customization window appears. Do one of the following:
• If you want to add new controls to the Touch Bar, select the item you need and drag it to the bottom until it appears on the Touch Bar. You can also drag the item left and right to rearrange it.

• If you want to remove some controls, move the mouse cursor to the bottom of the screen. As you move the cursor above the controls, they light up. Select the control you want to remove and drag it upward, back into the tool panel.

3 Once ready, tap Done.
This chapter is intended to give you additional information on how to work with Parallels Desktop and virtual machines.

In This Chapter

Work with Virtual Machines ................................................................. 104
Use Other Operating Systems on Your Mac............................................... 123
Install or Update Parallels Tools ............................................................... 128
For Software Developers ........................................................................... 136
Set File Type Associations ....................................................................... 140
Picture in Picture Mode ............................................................................. 141
Hide and Show Parallels Desktop ............................................................... 143
Remove Parallels Desktop ........................................................................... 144
Advanced Preferences ................................................................................ 144
Shared Networking Settings ....................................................................... 146
Host-Only Networking Settings ................................................................. 148
Create a Custom Host-Only Network........................................................... 149

Work with Virtual Machines

Read this section for basic information about working with virtual machines.

Supported Guest Operating Systems

You can install the following guest operating systems into Parallels Desktop virtual machines:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Parallels Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td></td>
</tr>
<tr>
<td>Windows 10</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 8.1</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 8</td>
<td>✔</td>
</tr>
<tr>
<td>Windows Server 2012 R2</td>
<td>✔</td>
</tr>
<tr>
<td>Windows 7 (SP0-SP1)</td>
<td>✔</td>
</tr>
<tr>
<td>Operating System</td>
<td>Compatibility</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Windows Server 2008 R2 (SP0-SP2)</td>
<td>✓</td>
</tr>
<tr>
<td>Windows Vista (Home, Pro, Business, Ultimate) (SP0-SP2)</td>
<td>✓</td>
</tr>
<tr>
<td>Windows Server 2003 R2 (SP0-SP2)</td>
<td>✓</td>
</tr>
<tr>
<td>Windows XP (Pro, Home) (SP0-SP3)</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 2000 (Pro, Server) SP4</td>
<td>✓</td>
</tr>
<tr>
<td>Windows NT 4.0 (Workstation, Server) SP6</td>
<td>✓</td>
</tr>
<tr>
<td>Windows ME</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 98 SE</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 95</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 3.11</td>
<td>✓</td>
</tr>
<tr>
<td>MS DOS 6.22</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Linux</strong></td>
<td>✓</td>
</tr>
<tr>
<td>Ubuntu 17.04**</td>
<td>✓</td>
</tr>
<tr>
<td>Linux Mint 18, 17, 16, 13</td>
<td>✓</td>
</tr>
<tr>
<td>Zorin OS 12.1*</td>
<td>✓</td>
</tr>
<tr>
<td>Debian GNU/Linux 9, 8, 7, 6, 5</td>
<td>✓</td>
</tr>
<tr>
<td>elementary OS 0.4</td>
<td>✓</td>
</tr>
<tr>
<td>Kali Linux 2</td>
<td>✓</td>
</tr>
<tr>
<td>RHEL 7, 6, 5</td>
<td>✓</td>
</tr>
<tr>
<td>CentOS 7, 6, 5</td>
<td>✓</td>
</tr>
<tr>
<td>Fedora 27, 26, 25, 24, 23, 22, 21, 20, 19</td>
<td>✓</td>
</tr>
<tr>
<td>OpenVZ 7</td>
<td>✓</td>
</tr>
<tr>
<td>Mageia 5, 4, 3</td>
<td>✓</td>
</tr>
<tr>
<td>OpenSUSE 42.2*, 13.2*</td>
<td>✓</td>
</tr>
<tr>
<td>OpenSUSE 42.1**</td>
<td>✓</td>
</tr>
<tr>
<td>OpenSUSE 13.1, 12.3</td>
<td>✓</td>
</tr>
<tr>
<td>SUSE Linux Enterprise Server 11 (SP2, SP3)</td>
<td>✓</td>
</tr>
<tr>
<td>Gentoo Linux**</td>
<td>✓</td>
</tr>
<tr>
<td>Manjaro Linux 16.10*</td>
<td>✓</td>
</tr>
<tr>
<td>Boot2Docker</td>
<td>✓</td>
</tr>
</tbody>
</table>
### About Virtual Machines

To add Windows or another operating system to your Mac, Parallels Desktop creates a "virtual machine," or a virtual copy of a computer, inside your Mac. You can then install Windows in the virtual machine, just as you would install an operating system on a regular computer.

* - operating systems marked with this sign can theoretically be installed in virtual machines but they haven't been tested yet.

** - operating systems marked with this sign can be installed in virtual machines but they are not officially supported.

Please note that Parallels Desktop does not include operating system installation discs or their images. You should purchase them separately.
Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can install as many virtual machines as you like, and install a different operating system in each of them. That way you can use multiple operating systems together at the same time on your Mac. And just like with a regular computer, you can turn virtual machines on and off, configure them, and install and use applications.

Set Where New Virtual Machines Are Stored

By default, Parallels Desktop stores virtual machines in ~/Parallels.

To change the default location for new virtual machine installations:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click General.

2. Choose a location from the Virtual Machines Folder menu.

All newly created virtual machines are stored in the new location. Any existing virtual machines remain in their original locations.

Arrange Virtual Machines

If you have many virtual machines, the Control Center window may get overloaded and inconvenient to work with.

You can configure Control Center to show the minimum information - only virtual machine names and icons. To do so, click the Parallels Desktop icon in the Dock and choose View > Compact View in the macOS menu bar.

Or if you're using Parallels Desktop for Mac Pro Edition, you can change how your virtual machines are arranged. Click the Parallels Desktop icon in the Dock, click View > Arrange By and choose how you want to list the virtual machines.

Make Virtual Machines Distinctive

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines running simultaneously, the icons of all applications running in the virtual machines are usually present in the Dock. You can easily get confused to which virtual machine the app icon belongs. To distinguish one virtual machine from others, you can mark it with some color. Do one of the following:

- Right-click a virtual machine in Control Center and choose the color you want at the bottom of the context menu.
Advanced Topics

- Right-click your virtual machine in macOS (virtual machines are usually stored in the ~/Parallels folder) and choose the color you want from the context menu.

If you choose, for example, red, the Dock icons of this virtual machine applications will be marked with a red spot.

Change the Virtual Machine Icon

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines with the same guest operating system, their Dock icons look the same and you may get confused. To change the virtual machine icon, do the following:

1. Copy a new icon you want to use to the clipboard (select the icon and press Command + C).
2. Right-click the virtual machine which icon you want to change (virtual machines are usually stored in the ~/Parallels folder) and click Get Info.
3. Click the virtual machine icon in the top left corner and paste the new icon from the clipboard by pressing Command + V. The icon will change in Finder and in the Dock.

To return the default icon, repeat step 2, click the virtual machine icon and press Backspace.

Change the Virtual Machine Name

The name of a virtual machine is displayed in Control Center and, at the top of the guest OS window when you are running in Window mode.

To change the virtual machine name:

1. Do one of the following:
   - Click the Parallels icon  in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click General and type a new name in the Name field.

The length of the name is limited to 50 characters.
Clone a Virtual Machine

Clone a Virtual Machine

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual machine fully identical to the original one. To make a clone:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > Clone.
3. Choose where you want to store the clone.
   By default, Parallels Desktop stores clones in the ~/Parallels folder.
4. Click Save to start cloning the virtual machine.

Create a Linked Clone of a Virtual Machine

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

A linked clone is a virtual machine that shares virtual hard disks with the parent virtual machine. This technology allows multiple virtual machines to use the software installed on the parent virtual machine hard disk. This way, users can save space on the Mac's hard disk. To create a linked clone:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > New Linked Clone.
3. Choose where you want to store the clone.
   By default, Parallels Desktop stores linked clones in the folder where the original virtual machine is located.
4. Click Save to start cloning the virtual machine.

Back Up a Virtual Machine

Most people don't seriously consider regular backups as a necessity until they have experienced a significant data loss. You should create your own backup strategy to protect yourself from data loss. Virtual machines are as vulnerable to crashes as physical computers.

You can back up your virtual machine using one or several of the following methods:

- Configure the regular backup settings on the Backup tab of the Virtual Machine Configuration dialog.
- Use third-party backup utilities like Acronis True Image (p. 121).
• Clone the virtual machine with the help of Clone Virtual Machine Assistant (p. 109). Give a descriptive name to the clone and save it in a location specially designated for backups.

• Copy the virtual machine files manually.

• Create virtual machine snapshots (p. 114).

Configure Regular Backups

On the Backup tab of the Virtual Machine Configuration dialog, you can choose how to back up your virtual machine regularly. You can configure how the virtual machine snapshots (p. 114) will be created or choose to back up the virtual machine with Time Machine.

If you choose to back up your virtual machine with Time Machine, your virtual machine's PVM file will be automatically backed up together with other files stored in macOS. As a consequence, files stored on your virtual machine's hard disk will be also backed up, since the virtual hard disk file (HDD) is stored inside the virtual machine bundle file (PVM).

**Warning:** Time Machine backups can guarantee safety only when your Parallels virtual machines were stopped or suspended during the backup.

To restore some of your Windows files:

1. From within the Finder (and not within Time Machine), locate the backup copy of your virtual machine’s file (PVM) on your backup disk.

2. Right-click the file, and choose Show Package Contents.

3. In the virtual machine contents window, right-click the virtual hard disk file (HDD) that is usually named `<VirtualMachine'sName>.hdd` and choose Open With > Parallels Mounter.

4. Using Parallels Mounter, browse the contents of your virtual machine’s hard disk to find the files you need to restore.

Use Third-Party Backup Utilities

You can use any third-party backup utilities you like. Registered Parallels Desktop users can use Acronis True Image (p. 121) to back up their Windows virtual machines.

**Note:** Acronis doesn't support backing up virtual machines that use Boot Camp as their hard disks.

Clone the Virtual Machine

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For details, see Clone a Virtual Machine (p. 109).
Copying the Virtual Machine Files

You can locate your virtual machine in Finder and create a backup copy of the virtual machine file (PVM).

1. In Control Center (or in the virtual machine window if it is shut down), right-click the virtual machine name and select Show in Finder from the context menu. In Finder, go to the folder where your virtual machine is stored.

2. Locate the required virtual machine PVM file.

   **Note:** PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file (HDD), and other files. For more information about the virtual machine files, see About Virtual Machines (p. 106).

3. Copy the virtual machine's PVM file to a safe location.

Browse Virtual Hard Disks in macOS

For easy access to Windows files, you can mount the virtual hard disk (on which Windows is installed) in macOS.

Mount a Virtual Hard Disk to the macOS Desktop

If you need the virtual hard disk (on which Windows is installed) to be mounted to the macOS desktop when Windows is running, open Finder, choose Finder > Preferences > General and select the Connected servers option.

For easy access to your virtual machines files, you can mount their hard disks in macOS Finder together with other disks and storage devices.

If you want your virtual hard disks to be mounted to the macOS desktop when the virtual machine is running, perform the following actions:

1. Open the Sharing pane (p. 47) of the Virtual Machine Configuration dialog, switch to the Share Windows tab and enable the Access Windows folders from Mac option. Optionally, you can also mount the Windows OneDrive disk to Mac.

   **Note:** To be able to edit the settings in the Sharing pane, you must have Parallels Tools (p. 128) installed in the virtual machine and the Isolate Mac from Windows option disabled in the Security pane.

2. Open the Finder Preferences, click the General tab and select the Connected servers option in the list of items displayed on the desktop.

If you want to manage the virtual machine content without starting the virtual machine, you can mount the virtual hard disks manually using Parallels Mounter:

1. Browse the virtual machine files in Finder. For Parallels virtual machines, right-click the virtual machine name in Control Center (or in the virtual machine window if it is shut down) and select Show in Finder from the context menu.
Advanced Topics

The default paths for storing Parallels virtual machines are /Users/<UserName>/Parallels/ and /Users/Shared.

2 To mount the hard disk of a particular virtual machine, right-click this virtual machine’s file and choose Open With > Parallels Mounter (or Open With > Other and search for Parallels Mounter in the Applications folder) from the shortcut menu. You can mount the following virtual machines and hard disks:

- Parallels bundle (.pvm) or configuration file (.pvs) or virtual hard disk file (.hdd).
- VMware configuration file (.vmx, .vmwarevm) or virtual hard disk file (.vmdk).
- Virtual PC configuration file (.vmc, .vpc7) or virtual hard disk file (.vhd).
- VirtualBox configuration file (.xml) or virtual hard disk file (.vdi).

If you choose the PVM file of a Parallels virtual machine or the configuration file of a third-party virtual machine that has several virtual hard disks, all its volumes will appear as mounted in Finder.

If you want to mount a single virtual hard disk, double-click the virtual hard disk file to mount it with Parallels Mounter. The icon for the selected hard disk appears in the sidebar of the Finder window, together with other macOS icons.

3 To browse the contents of a volume, click its icon in the sidebar of the Finder window.

You can manage the virtual machine files just as you manage your macOS files in Finder windows.

Note: If you are browsing the contents of a suspended virtual machine in Finder, you cannot delete, move, or otherwise modify its files.

4 To unmount the volume, use the Eject button next to the disk icon.

Note: If a hard disk that has several volumes was mounted and you want to open it or the virtual machine using it in Parallels Desktop, you should disconnect its volumes one by one by clicking the Eject button.

Create and Use Virtual Machine Templates

On the basis of your virtual machines you can create templates. Later you can use them to create multiple identical virtual machines. To create a virtual machine template, you can:

Note: Virtual machine templates are available in Parallels Desktop for Mac Pro Edition only.

- convert a virtual machine to a template; or
- clone a virtual machine to a template.

The difference between these two ways is that when you convert a virtual machine to a template, you can't run it until you convert the template back to the virtual machine. And when you clone a virtual machine to a template, the template appears separately from the virtual machine and you can work with both.
A template, in its turn, can be converted or deployed back to the virtual machine. When you convert a template, it turns back to the virtual machine. And when you deploy it, the resulting virtual machine appears separately from the template and you can work with both.

**Convert a Virtual Machine to a Template**

To convert a virtual machine to a template:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to convert (it must be shut down) and choose File > Convert to Template.

**Convert a Template to the Virtual Machine**

To convert a template back to the virtual machine:

1. Start Parallels Desktop.
2. In Control Center, right-click the template you want to convert and choose Convert to Virtual Machine.

**Clone a Virtual machine to a Template**

To clone a virtual machine to a template:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > Clone to Template.
3. Choose where you want to store the resulting template.
   By default, Parallels Desktop stores templates in the ~/Parallels folder.
4. Click Save to start cloning the virtual machine to the template.

**Deploy a Template to the Virtual Machine**

To deploy a template back to the virtual machine:

1. Start Parallels Desktop.
2. In Control Center, right-click the template you want to deploy and choose Deploy to Virtual Machine.
3. Choose where you want to store the resulting virtual machine.
   By default, Parallels Desktop stores virtual machines in the ~/Parallels folder.
4. Click Save to start deploying the template to the virtual machine.
Save Snapshots of a Virtual Machine

A snapshot is a saved state of the guest OS. It's useful to create snapshots, for example, before:

- you're going to run some applications that may damage the guest OS; or
- if you're going to configure some guest OS software that requires a lot of settings; or
- if you want to mark milestones in the development process.

**Notes:**
1. Snapshots cannot be created for Windows virtual machines that use the Boot Camp partition.
2. If your virtual machine has one or more snapshots, you can neither compress nor resize the virtual hard disk.
3. Creating a snapshot increases the size of the virtual machine .pvm bundle.

If something goes wrong, you can revert the changes back to any of your snapshots and continue working with the guest OS.

Create a Snapshot

**Note:** When the virtual machine is active, Snapshot Manager is available from the Actions menu in the macOS menu bar, from the Parallels menu in the macOS menu bar, and from the Parallels Desktop context menu in the Dock.

1. Start Parallels Desktop.
2. In Control Center, right-click the virtual machine for which you want to create a snapshot and choose Manage Snapshots.
3. Click New, specify the snapshot name and click OK.

Automate the Creation of Snapshots

The SmartGuard functionality allows you to automate snapshots creation.

**Note:** SmartGuard is available only when the virtual machine is not running in Rollback Mode (p. 87).

To access settings for automating snapshots:

1. Start Parallels Desktop.
2. In Control Center, right-click the virtual machine for which you want to create a snapshot and choose Configure.
3 Click Backup.

4 To automate snapshots, enable SmartGuard, click Details, and do one of the following:

- Select Optimize for Time Machine. If you select this option, a snapshot will be taken every 48 hours. Time Machine, when backing up your Mac, will not back up the entire virtual machine, but only its latest snapshot. This allows you to reduce the amount of data that Time Machine backs up, to reduce the time Time Machine spends backing up the virtual hard disk(s), and to minimize the risk of data loss or corruption when restoring the virtual machine hard disk(s) from the Time Machine backup.

- Manually set the snapshots frequency and maximum number of snapshots to keep. If you want to know when it is time to make the next snapshot and to be able to reject the snapshot creation, select Notify me before snapshot creation.

To set how often snapshots are made:

- Use the Take a Snapshot Every field. You can set from one to 48 hours.

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest daily, weekly and monthly snapshot.

To limit how many snapshots are stored:

- Use the Snapshots to Keep field to set the maximum number of snapshots that can be stored on your Mac.

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit for snapshots and needs to make a new one over limit, it deletes the oldest snapshot.
Revert to a Snapshot

To revert to a snapshot:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine that you want to revert and click the snapshots icon \[snapshot\].
3. Select the snapshot to which you want to revert and click Go To.

Delete a Snapshot

To delete a snapshot:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine which snapshot you want to delete and click the snapshots icon \[snapshot\].
3. Select the snapshot you want to delete and click Delete.

When you delete an intermediate snapshot, the information it contains is merged into the next snapshot.

Change Virtual Machine Configuration at Runtime

Parallels Desktop allows you to connect or disconnect certain devices at runtime or switch some of them for using other media.

Generally, the following virtual devices can be connected or disconnected at runtime:

- Floppy disk drive
- CD/DVD-ROM drives
- Network adapter
- Sound device
- USB device
- Shared folders

If printer and serial ports are present in the virtual machine configuration, you can also manage them at runtime.

To configure any of these devices, use the necessary command from the Devices menu in the menu bar. This menu is available only when the virtual machine is running.
Connecting a CD/DVD or a Floppy Drive

If you have several CD/DVD drives connected to your virtual machine, in the Devices menu they are listed in the same order as they were connected. The first CD/DVD drive will be CD/DVD 1, the second will be CD/DVD 2, and so on.

Connecting a Network Adapter

You can set up any of the three network modes: Shared Networking, Bridged Networking, or Host-Only Networking.

Connecting a Sound Device

To connect or disconnect a sound device, choose the type of output (or input) device or Mute option respectively.

Connecting a USB Device

Parallels Desktop automatically detects all USB devices plugged into your Mac computer. The devices that are currently connected to the virtual machine appear in the list from the Device menu. You cannot use a USB device in macOS while it is being used by the virtual machine.

Connecting a Shared Folder

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine Configuration dialog.

You can

- share all Mac disks or Home Folder only with the virtual machine
- share Windows guest operating system disks with macOS
- add a new shared folder

Connecting a Serial Port

To connect or disconnect a serial port, click the Devices menu, select the corresponding serial port, and choose the appropriate command in the displayed menu.

Connecting a Printer Port

To connect or disconnect a printer port or to connect a printer or an output file to a printer port, click the Devices menu, select the corresponding printer port, and choose the appropriate command in the displayed menu.
Use Mouse Wheel Horizontal Scrolling

You can use the mouse wheel horizontal scrolling when working with windows of virtual machine applications. This feature is available only if Parallels Tools (p. 219) are installed in the virtual machine.

Remove a Virtual Machine

Remove a Virtual Machine from your Mac

If you don't need a virtual machine any more, you can permanently remove it from your Mac:

**Warning:** Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are used by other virtual machines. If you remove a Boot Camp virtual machine, the Boot Camp partition with Windows installed remains available on your Mac.

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Control Center and choose Remove.

2. Click Move to Trash.

Remove a Virtual Machine from Control Center

To temporarily remove a virtual machine from Control Center:

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Control Center and choose Remove.

2. Click Keep Files.

When you need this virtual machine again, you can easily import it in Parallels Desktop (p. 29).

Download Pre-configured Virtual Appliances

If you don't have enough time to create a new virtual machine with the required configuration, you can download a ready-to-use virtual machine with a predefined configuration.

Downloading Parallels Virtual Appliances

Parallels Virtual Appliances are pre-built Modern.IE, Ubuntu Linux, Fedora Linux, CentOS Linux, Debian GNU/Linux, Mint Linux, Chromium OS and Android virtual machines.

To download such an appliance and use it with Parallels Desktop:

2 Select the appliance you need in the Free Systems section and click Continue.

3 In the next step, click Download. Once the download starts, you can pause it anytime by clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the virtual appliance in Parallels Desktop.

Downloading Chromium OS Virtual Appliance

To download the Chromium OS virtual appliance from Parallels Desktop:

1 Choose File > New.
2 Select Download Chromium OS and click Continue.
3 In the next step, click Download. Once the download starts, you can pause it anytime by clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the Chromium OS virtual appliance in Parallels Desktop.

Downloading Modern.IE Virtual Appliances

The Modern.IE virtual appliances allow web developers to check how websites are displayed and functioning in different versions of Internet Explorer on different versions of Windows.

To download such an appliance and use it with Parallels Desktop:

1 Choose File > New.
2 Select Modern.IE and click Continue.
3 In the next step, select the version of Internet Explorer and Windows you'd like to work with and follow the onscreen instructions.

Once the download is complete, you can start working with the virtual appliance in Parallels Desktop.

Set the Guest OS Type and Version

You can change which guest OS a virtual machine is configured to work with. You need to change it in the following cases:

• If you upgrade the guest operating system (for example, from Windows XP to Windows 7), you need to change the guest OS type and version correspondingly or Parallels Tools (p. 128) may start working incorrectly.

• If you create a virtual machine without installing an operating system, and then decide to use it with a different operating system than the one you initially specified.

To set the guest OS type and version:
Advanced Topics

1. Shut down the virtual machine. (p. 35)
2. Open the Actions menu and choose Configure.
3. Click General and select an OS from the menu just above the Name field.

Set How Many Processors are Allocated to a Virtual Machine

You can change the number of virtual CPUs that will be used to handle the processes running in a virtual machine. Parallels Desktop automatically calculates the maximum allowable number of virtual CPU. The calculation is based on the number of physical CPUs available to your macOS computer.

**Note:** It is reasonable to use more than one CPU in your guest OS if you are going to use applications that perform better under multi-core processors.

To set how many processors are allocated to a virtual machine:

1. Shut down the virtual machine. (p. 35)
2. Open the Actions menu and choose Configure.
3. Click Hardware > CPU & Memory and select a number from the Processors menu.

**Note:** In Parallels Desktop for Mac, you can assign up to 4 CPUs to a virtual machine. In Parallels Desktop for Mac Pro Edition, you can assign up to 16 CPUs.

Check Your Virtual Machine CPU and Memory Usage

While working with a virtual machine, you may need to check how much memory and CPU time of your Mac it is currently using. If the virtual machine is consuming too much and your running Mac applications become slow, you can easily reduce the number of CPUs (p. 120) and amount of memory (p. 93) assigned to the virtual machine.

To check the current CPU and memory usage, choose Window > Show Resource Monitor:

**Note:** you may notice that an amount of memory consumed by a virtual machine is higher than the amount of memory allocated to this virtual machine on the CPU & Memory tab (p. 191). It's normal, the resource monitor shows memory consumption of all virtual machine processes.
Enable Spoken Commands

You can work with Windows or other guest OSs using the following spoken commands:

<table>
<thead>
<tr>
<th>Commands</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>Starts a virtual machine.</td>
</tr>
<tr>
<td>Suspend</td>
<td>Suspends a virtual machine.</td>
</tr>
<tr>
<td>Shut Down</td>
<td>Shuts down a virtual machine.</td>
</tr>
<tr>
<td>Pause</td>
<td>Pauses a virtual machine.</td>
</tr>
<tr>
<td>Stop</td>
<td>Stops a virtual machine.</td>
</tr>
<tr>
<td>Reset</td>
<td>Resets a virtual machine.</td>
</tr>
<tr>
<td>Snapshot</td>
<td>Opens the Snapshot Manager window.</td>
</tr>
<tr>
<td>Make Screenshot</td>
<td>Makes a screenshot of the Guest OS window and stores it on the macOS Desktop.</td>
</tr>
<tr>
<td>Make Clip</td>
<td>Makes a clip.</td>
</tr>
<tr>
<td>Switch to Coherence</td>
<td>Switches to the Coherence view mode.</td>
</tr>
<tr>
<td>Switch to Full Screen</td>
<td>Switches to the Full Screen view mode.</td>
</tr>
<tr>
<td>Switch to Window</td>
<td>Switches to the Window view mode.</td>
</tr>
<tr>
<td>Edit Configuration</td>
<td>Opens the Virtual Machine Configuration dialog.</td>
</tr>
<tr>
<td>New</td>
<td>Creates a new virtual machine.</td>
</tr>
<tr>
<td>Open</td>
<td>Opens a virtual machine.</td>
</tr>
<tr>
<td>About Parallels Desktop</td>
<td>Opens the About Parallels Desktop menu.</td>
</tr>
<tr>
<td>Install Parallels Tools</td>
<td>Launches the installation of Parallels Tools in the running virtual machine.</td>
</tr>
<tr>
<td>Report a Problem</td>
<td>Opens the Parallels Problem Report window.</td>
</tr>
<tr>
<td>Open</td>
<td>Opens an existing virtual machine and registers it in Parallels Desktop.</td>
</tr>
<tr>
<td>Open Directory</td>
<td>Opens the Parallels Virtual Machines window.</td>
</tr>
</tbody>
</table>

To enable the spoken commands, choose Parallels Desktop > Preferences > Advanced and select Enable spoken commands. If necessary, tune the speech settings on the corresponding tab of macOS System Preferences.

Get Acronis True Image

As an additional benefit, Parallels provides you with Acronis True Image. It is an online backup tool for Windows and macOS. For Parallels Desktop users, Acronis True Image is free for 30 days.

For instructions on backing up your Mac and virtual machines, please refer to the Acronis True Image documentation.
Install Acronis True Image

To install Acronis True Image, choose Parallels Desktop > Backup with Acronis True Image... and follow the onscreen instructions.

Or you can also install Acronis True Image from the virtual machine configuration:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Backup > Install Acronis True Image and follow the onscreen instructions.

Start Acronis True Image

To start Acronis True Image:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Backup > Start Acronis True Image and follow the onscreen instructions.

Use AppleScript with the Guest OS

You can use AppleScript to open various files and websites in the guest OS applications. You may need this when creating automated workflows.

To make the explanation more vivid, let's assume that you need to open some .txt file in Windows Notepad using AppleScript (in AppleScript Editor). The syntax of this command is as follows:

```
tell application "Notepad"
open "/Users/username/somefile.txt"
end tell
```

As an example of opening a website in the guest OS application, let's assume that you need to open "www.parallels.com" in Internet Explorer. The syntax of this command is as follows:

```
tell application "Internet Explorer"
open "//www.parallels.com"
end tell
```

Quickly Free Up Disk Space

Using Free Disk Space Wizard, you can compress the virtual machine hard disk(s) and remove various unnecessary files to free up disk space.
To quickly compress the disk(s), remove unnecessary files, and free up disk space:

1. Shut down the virtual machine.
2. Choose File > Free Up Disk Space.

Free Disk Space Wizard shows whether you can reclaim any disk space by removing the virtual machine snapshots, cache files and various unnecessary files such as statistical, memory dump, and crash dump files, which are generated during the virtual machine life cycle.

You can also conserve disk space by compressing virtual disks manually or clicking Reclaim on the General tab of virtual machine configuration.

**Archive and Unarchive Virtual Machines**

If you have two or more virtual machines, you may notice that there's not enough space on your Mac. If you seldom use a virtual machine or don't use it at all, archive it to make the virtual machine occupy significantly less disk space on the Mac's hard disk.

**Archive a Virtual Machine**

To archive a virtual machine, do the following:

1. Right-click the Parallels Desktop icon in the Dock and choose Control Center.
2. Right-click a virtual machine and select Archive.

**Unarchive a Virtual Machine**

Archived virtual machines cannot be started. To start an archived virtual machine, first you should unarchive it. Do the following:

1. Right-click the Parallels Desktop icon in the Dock and choose Control Center.
2. Right-click an archived virtual machine and select Start.
3. In the dialog prompting to unarchive the virtual machine, click Unarchive.

**Use Other Operating Systems on Your Mac**

Read this section for the information that's specific to certain operating systems other than Windows XP or later.

**Use Linux in Coherence Mode**

You can set Linux and macOS to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, Linux applications appear on the Mac desktop next to your Mac applications.
To enable the Coherence view mode, Parallels Tools must be installed in the guest operating system. Some Linux distributions may also require to disable 3D effects. To learn how to do this, please refer to the operating system documentation.

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

• Choose View > Enter Coherence.
• Press Control-Command-Return.

To switch from Full Screen mode to Coherence mode, press Control-Option (Alt), click the View menu and select Exit Full Screen. Then open the View menu and select Enter Coherence.

Customize the Keyboard for the Guest OS

By default, Parallels Desktop contains four profiles that represent sets of key combinations typical for the following OSs:

• Windows
• Linux
• macOS
• Generic (for other guest OSs)

When you create or register a virtual machine, one of these profiles, depending on the guest operating system, is assigned to the machine by default. You can create your own profile and assign it to your virtual machines.

To create a custom keyboard profile or edit the existing profiles:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Preferences.
   • Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2 Click Shortcuts.

3

4 Select a virtual machine from the sidebar, click the Profile menu, and select Edit profiles list.

5 Do one of the following:

- To add a new profile, click the Add button \( \text{+} \). Specify the new profile name and select the base profile from the list. After the profile is created, you can submit the changes by clicking OK. Then select this new profile in the Profile list and configure its shortcuts.

- To remove one of the existing custom profiles, select it and click the Remove button \( \text{-} \).

- To duplicate or rename one of the existing profiles, select this profile, click the button \( \text{≈} \), and select the corresponding action from the menu.
Note: You can rename or remove your custom profiles only.

In the Shortcuts pane of Parallels Desktop Preferences, you can also assign profiles to your virtual machines.

To change a profile assigned to a virtual machine:

- Select a virtual machine and choose a profile from the Profile menu.

Use macOS as a Guest OS

You can install a copy of macOS in a virtual machine and use it as a guest operating system. This can be useful, for example, if you want to test software in a fresh version of macOS without having to log in and out of your main account.

By default, an installation of macOS is stored in a recovery partition on your Mac. You can easily install macOS into a virtual machine from that partition without having to purchase or download another copy of macOS.

To install macOS in a virtual machine:

2. Select Install macOS Using the Recovery Partition, click Continue, and follow the onscreen instructions.

When using OS X Lion or later as a guest OS, you can use it in Coherence mode (p. 39), so that guest OS application windows appear on the host OS desktop alongside host OS applications.

You can also copy and paste text and drag and drop files between host and guest macOS, just as you can when using Windows as a guest OS.

You can set whether function keys and other system shortcuts trigger actions in the host or guest version of macOS (p. 66).
Use macOS in Coherence Mode

You can set a macOS virtual machine and macOS to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, guest macOS applications appear on the host macOS desktop next to your host applications.

To enable the Coherence view mode, Parallels Tools must be installed (p. 135).

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

• Click the Coherence icon in the top right corner of the virtual machine window.

• Choose View > Enter Coherence.

• Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

• Press Control-Command-F to exit Full Screen. Then open the View menu and select Enter Coherence.
Install or Update Parallels Tools

Parallels Tools are a suite of behind-the-scenes tools that allow seamless operating between macOS and Windows or another guest operating system.

This section gives an overview of Parallels Tools, and has information about how to install them for various guest operating systems.

Parallels Tools Overview

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly between the virtual machine and your Mac, change the virtual machine’s screen resolution by simply resizing its window, synchronize your virtual machine's time and date settings with the time settings of the host computer, share your Mac's disks and folders with its virtual machines, copy text and drag and drop objects from macOS to a virtual machine and vice versa.

Parallels Tools are available for the most popular Windows, Linux, and macOS operating systems, and include the utilities listed below. All utilities supported by your guest OS are installed in your virtual machine as a single package when you install Parallels Tools.

<table>
<thead>
<tr>
<th>Utility</th>
<th>Available for</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mouse Synchronization Tool</td>
<td>Windows, Linux, macOS</td>
<td>Mouse Synchronization Tool captures the mouse input in the virtual machine each time the pointer moves over its window and automatically releases the input when the pointer moves outside the window.</td>
</tr>
</tbody>
</table>
| Time Synchronization Tool | Windows, Linux, macOS | Time Synchronization Tool enables you to customize your virtual machine time settings. You can:  
  • Automatically synchronize the time settings of your virtual machine with your Mac time settings.  
  • Set up and maintain the time difference between your Mac and your virtual machine. |
<p>| Drag-and-Drop Tool    | Windows, Linux, macOS | Drag-and-Drop Tool allows dragging and dropping files between your virtual machines and macOS.                                                |</p>
<table>
<thead>
<tr>
<th>Tool</th>
<th>Windows</th>
<th>Linux</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Clipboard Synchronization Tool</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Windows</td>
<td>Linux</td>
<td>macOS</td>
</tr>
<tr>
<td></td>
<td>Clipboard Synchronization Tool enables you to easily exchange texts between:</td>
<td>Clipboard Synchronization Tool enables you to easily exchange texts between:</td>
<td><strong>Clipboard Synchronization Tool</strong> enables you to easily exchange texts between:</td>
</tr>
<tr>
<td></td>
<td>• the virtual machine and your Mac.</td>
<td>• different virtual machines irrespective of the guest operating systems installed in them.</td>
<td><strong>Clipboard Synchronization Tool</strong> enables you to easily exchange texts between:</td>
</tr>
<tr>
<td></td>
<td>• different virtual machines irrespective of the guest operating systems installed in them.</td>
<td>To copy and paste text, you should use the standard procedure for the current operating system. For example, to copy some text in the Windows guest OS, select the text, and press Ctrl+C. To paste this text in macOS, press Cmd+V, or select Paste from the shortcut menu.</td>
<td></td>
</tr>
<tr>
<td><strong>Dynamic Resolution Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td>macOS</td>
</tr>
<tr>
<td></td>
<td>Dynamic Resolution Tool enables you to work with dynamic resolution. When you resize the guest OS window by dragging its lower right corner, the guest OS window resolution changes automatically.</td>
<td>Dynamic Resolution Tool enables you to work with dynamic resolution. When you resize the guest OS window by dragging its lower right corner, the guest OS window resolution changes automatically.</td>
<td></td>
</tr>
<tr>
<td><strong>Shared Folders Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td>macOS</td>
</tr>
<tr>
<td></td>
<td>Shared Folders Tool enables you to share Mac folders with the virtual machine and vice versa. With this tool, you can access your Mac folders from the virtual machine.</td>
<td>Shared Folders Tool enables you to share Mac folders with the virtual machine and vice versa. With this tool, you can access your Mac folders from the virtual machine.</td>
<td></td>
</tr>
<tr>
<td><strong>Coherence Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td>macOS</td>
</tr>
<tr>
<td></td>
<td>The Coherence tool allows you to work with your Windows or Linux applications like if they were Mac applications. It hides the virtual machine's window leaving only guest OS and Mac applications visible.</td>
<td>The Coherence tool allows you to work with your Windows or Linux applications like if they were Mac applications. It hides the virtual machine's window leaving only guest OS and Mac applications visible.</td>
<td></td>
</tr>
<tr>
<td><strong>Shared Profile Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shared Profile Tool enables you to share your Mac desktop, pictures, documents, downloads, music and videos with your virtual machine, which allows you to access them right from the guest OS.</td>
<td>Shared Profile Tool enables you to share your Mac desktop, pictures, documents, downloads, music and videos with your virtual machine, which allows you to access them right from the guest OS.</td>
<td></td>
</tr>
<tr>
<td><strong>Shared Applications Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shared Applications Tool enables you to specify default applications for certain types of files, so that you can open some types of files in Windows or Linux applications by default, and others - in macOS.</td>
<td>Shared Applications Tool enables you to specify default applications for certain types of files, so that you can open some types of files in Windows or Linux applications by default, and others - in macOS.</td>
<td></td>
</tr>
<tr>
<td><strong>Shared Internet Applications Tool</strong></td>
<td>Windows</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shared Internet Applications Tool enables you to specify default Internet browsers, including those installed in the virtual machine, for different types of Internet pages. For example, you may set the Internet pages to open in your default macOS Internet browser, and FTP pages to open in your virtual machine Internet browser.</td>
<td>Shared Internet Applications Tool enables you to specify default Internet browsers, including those installed in the virtual machine, for different types of Internet pages. For example, you may set the Internet pages to open in your default macOS Internet browser, and FTP pages to open in your virtual machine Internet browser.</td>
<td></td>
</tr>
<tr>
<td><strong>SmartMount</strong></td>
<td>Windows</td>
<td>Linux</td>
<td>macOS</td>
</tr>
<tr>
<td></td>
<td>SmartMount automatically detects volumes connected to your Mac and makes them available to the virtual machine as well.</td>
<td>SmartMount automatically detects volumes connected to your Mac and makes them available to the virtual machine as well.</td>
<td></td>
</tr>
<tr>
<td><strong>Printing Tool</strong></td>
<td>Windows</td>
<td>Linux</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Printing Tool allows you to synchronize the host and guest OS printers.</td>
<td>Printing Tool allows you to synchronize the host and guest OS printers.</td>
<td></td>
</tr>
<tr>
<td><strong>Tray Integration Tool</strong></td>
<td>Windows</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tray Integration Tool allows you to use Windows tray icons in the Mac menu bar.</td>
<td>Tray Integration Tool allows you to use Windows tray icons in the Mac menu bar.</td>
<td></td>
</tr>
</tbody>
</table>
Parallels Tools are located on disc images that are installed together with Parallels Desktop. There is a separate Parallels Tools disc image for each type of the supported guest operating systems.

- prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems.
- prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems.
- prl-tools-mac.iso - disc image with Parallels Tools for macOS guest operating systems.

These disc images can be found in the following location on your Mac:
/Applications/Parallels Desktop.app/Contents/Resources/Tools.

Parallels Tools for Windows

**Important:** To take advantage of much of the functionality Parallels Desktop offers, Parallels Tools must be installed.

Parallels Tools can be installed in the following Windows guest operating systems:

- Windows 10
- Windows 8, 8.1
- Windows 7
- Windows Server 2008
- Windows Vista
- Windows XP
- Windows Server 2003
- Windows 2000

Installing Parallels Tools

If you chose Express Installation when you first installed Windows, Parallels Tools were installed automatically after the installation.

If you didn't choose Express Installation, do the following to install Parallels Tools:

1. Start Windows (p. 30).
2. When Windows boots up, choose Install Parallels Tools from the Virtual Machine menu.

   **Note:** After you choose Install Parallels Tools in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

3. Click Continue to connect the ISO image with Parallels Tools for Windows to the virtual machine’s CD/DVD-ROM drive.
4  Click Install Parallels Tools to start the installation.

   **Note:** After you click Install Parallels Tools in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

5  When the installation is complete, click Restart to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

If the Parallels Tools ISO image doesn't autoplay after you click Continue, the CD/DVD autorun must be disabled in your virtual machine. In this case, do the following to install Parallels Tools:

1  Open My Computer, right-click the Parallels Tools disc and choose Open.

2  Double-click the **PTAgent** file to start the installation.

3  When the installation is complete, click Restart to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the Virtual Machine Configuration dialog.

Reinstall or Update Parallels Tools

To reinstall Parallels Tools:

1  Start Windows (p. 30).

   Once Windows starts, if Parallels Desktop is in Coherence mode, click the Parallels icon in the menu bar and choose Exit Coherence.

2  When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.

   This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you will see the Update Parallels Tools option instead.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.

Parallels Tools for Linux

To install Parallels Tools for Linux, you must have the following packages:

- gcc;
- make;
- kernel development package; and
Advanced Topics

- checkpolicy (for SELinux-enabled systems).

You may also need the following optional packages:

- dkms;
- HP Color LaserJet 8500 Postscript driver.

The Parallels Tools installer installs these packages automatically from the distribution repository. However, if the package repository is not configured or not available, you need to install all the mandatory packages manually. To learn how to do this, please refer to the Linux distribution documentation.

Preparing for installation

Before installing Parallels Tools in a Linux virtual machine, perform the following actions:

- Close all applications running on the virtual machine.
- If you use a 3D accelerated window manager, disable it.
- Make sure that you have all the mandatory packages available in the system.

Note: To install Parallels Tools in your virtual machine, you must have the root privileges.

Installing Parallels Tools in the most recent versions of Linux systems

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) with graphical interface, the prl-tools-lin.iso image file will be mounted automatically after you connect it to the CD/DVD drive. To install Parallels Tools, do the following:

1. Start the virtual machine and log in to the graphical session.
2. When the operating system boots up, click Actions and choose Install Parallels Tools.

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements listed above.

The prl-tools-lin.iso image file will be mounted to the virtual machine's CD/DVD drive.

You can connect and mount the Parallels Tools ISO image file manually. In the Mac menu bar, click Devices > CD/DVD > Connect Image. In the Finder window, go to the hard disk folder (normally named "Macintosh HD"), select the /Applications/Parallels Desktop.app/Contents/Resources/Tools/ folder, select the prl-tools-lin.iso file, and click Open to connect it to the virtual machine.

3. Once the Parallels Tools ISO image is automatically mounted, open the window with the Parallels Tools volume.
5. Enter the proper su or sudo credentials to install Parallels Tools under the root.
6. When the installation of Parallels Tools is complete, restart your virtual machine.
Installing Parallels Tools in other versions of Linux guest OSs

To install Parallels Tools in the older versions of Linux OSs or systems without graphical interface, you have to mount the prl-tools-lin.iso image file manually. Do the following:

1. Start the virtual machine.
2. When the guest OS boots up, choose Install Parallels Tools from the Actions menu.

   **Note:** If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements for Parallels Tools installation.

   The prl-tools-lin.iso image file will be connected to the virtual machine’s CD/DVD drive.

3. Start a terminal in your Linux guest OS. Type the following command to gain the root privileges:

   ```
su
   ```

4. Check if the Parallels Tools CD image is mounted by entering

   ```
   mount | grep iso9660
   ```

   If this command does not return anything, proceed to the next step.

   If this command returns anything like
   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
   ```

   skip the next step and proceed to the following one.

   If this command returns anything like
   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodv,uid=0)
   ```

   with the noexec option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:

   ```
   umount /dev/cdrom
   ```

5. To mount the Parallels Tools installation disc image, enter the following:

   ```
   mount -o exec /dev/cdrom /media/cdrom
   ```

   **Note:** /dev/cdrom is the virtual machine’s CD/DVD drive and /media/cdrom is the mount point for this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this case, you should create the mount point directory manually.

6. When the installation disc image is mounted, change the directory to the CD/DVD drive directory using

   ```
   cd /media/cdrom/
   ```

7. In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:

   ```
   ./install
   ```

   **Note:** You must have the root privileges to run this command.

8. Follow the Parallels Tools Installer instructions to complete the installation.

9. When the installation of Parallels Tools is complete, restart your virtual machine.
To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the Virtual Machine Configuration dialog.

How to check if Parallels Tools have been installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.

Troubleshooting

Parallels Tools may fail to install because not all mandatory packages are available. Check the /var/log/parallels-tools-install.log file in the guest OS for error messages, install the missing packages and try to install Parallels Tools again.

For more information on installing Parallels Tools, please refer to the Parallels Knowledge Base available at http://kb.parallels.com.

Update Parallels Tools

If a newer version of Parallels Tools for Linux is available, the Parallels Tools Installation Agent window appears. You're prompted to choose the command to gain root privileges and enter the password (if su - root password, if sudo - your user's password). After that, Parallels Tools update automatically.

Reinstall Parallels Tools

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them once again.

Installing and Upgrading Parallels Tools in Text Mode in Linux

After upgrading to Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix the problem, you need to install Parallels Tools in text mode.

1 Start the virtual machine.
2 When you see a message that X Server failed to start, switch to another virtual console using Ctrl+Option+F1 (Ctrl+Alt+F1) or Ctrl+Option+F2 (Ctrl+Alt+F2) and enter your login details.
3 Choose Install Parallels Tools from the Actions menu to connect the Parallels Tools ISO image to your virtual machine.
Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the Parallels Tools Overview section (p. 128) in Parallels Desktop User's Guide.

The prl-tools-lin.iso image file will be connected to the virtual machine’s CD/DVD drive.

4 In the virtual machine console, type the following command to gain the root privileges:

```
su
```

5 Check if the Parallels Tools CD image is mounted by entering

```
mount | grep iso9660
```

If this command does not return anything, proceed to the next step.

If this command returns anything like

```
/dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
```

skip the next step and proceed to the following one.

If this command returns anything like

```
/dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0)
```

with the noexec option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:

```
umount /dev/cdrom
```

6 To mount the Parallels Tools installation disc image, enter the following:

```
mount -o exec /dev/cdrom /media/cdrom
```

Note: /dev/cdrom is the virtual machine’s CD/DVD drive and /media/cdrom is the mount point for this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/sr0 or /dev/hdb and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this case, you should create the mount point directory manually.

7 When the installation disc image is mounted, change the directory to the CD/DVD drive directory using

```
cd /media/cdrom/
```

8 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:

```
./install
```

Note: You must have the root privileges to run this command.

9 Follow the Parallels Tools Installer instructions to complete the installation.

10 When the installation of Parallels Tools is complete, restart your virtual machine.

For general information on installing Parallels Tools in Linux, refer to Installing Parallels Tools in a Linux Guest OS (p. 131).

**Parallels Tools for Mac**

**Install Parallels Tools**

To install Parallels Tools in a macOS virtual machine:
1 Start the macOS virtual machine.
2 When macOS boots up, choose Actions > Install Parallels Tools. The Parallels Tools ISO image gets connected to the virtual machine CD/DVD drive. The guest OS mounts it automatically.
3 Open the Parallels Tools volume folder in Finder and double-click Install.
4 When prompted, enter the administrator password.
5 When the installation of Parallels Tools is complete, restart your virtual machine.

Reinstall Parallels Tools

To reinstall Parallels Tools:
1 Start your macOS virtual machine (p. 30).
2 When macOS boots up, log in to the graphical session and choose Reinstall Parallels Tools from the Virtual Machine menu. Parallels Tools will be reinstalled automatically.

Update Parallels Tools

If a newer version of Parallels Tools for Mac is available, Parallels Tools update automatically.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard. They are released automatically.

For Software Developers

This section contains the topics with the information for software developers.

Optimize Remote Debugging

The Parallels plugin for Visual Studio allows you to develop software in one virtual machine and test it in other virtual machines with just one click.

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

Requirements

To use this plugin, you need the following:
• A Windows 7 (or later) virtual machine with Visual Studio Professional/Enterprise 2013 (or later).
• Other running virtual machines (with Windows 7 or later) in which you will test the project.
• The virtual machine with Visual Studio and other virtual machines must belong to the same pool of IP addresses, or just configured to use the shared network (p. 146).
• All virtual machines must have Parallels Tools (p. 128) installed.
• The virtual machine with Visual Studio must have the Access Windows folders from Mac option (p. 47) selected.
• Other virtual machines must have the Share Folders: All disks option (p. 47) selected.
• The user accounts logged in to the virtual machines in which you’re going to test your project must have both username and password and you must know them.

Install the Parallels Plugin for Visual Studio

To install the Parallels plugin, do the following:

1. In the virtual machine with Visual Studio, navigate to the directory where Parallels Tools are installed. In most cases, it is C:\Application Files (x86)\Parallels\Parallels Tools\DevTools.

2. Double-click the VMDebugHelper.vsix file. The plugin for Visual Studio will be installed automatically.

How It’s Working

To start remote debugging of your project, follow these steps:

1. In the virtual machine where Visual Studio is installed, open Visual Studio and open your project.

2. Build the project and test it locally.

3. Click PARALLELS > Start Debugging in VM and select the virtual machine you need (this virtual machine must be running).

You project will open in the selected virtual machine.

Generate a Core Dump

| Note: This functionality is available in Parallels Desktop for Mac Pro Edition only. | 137 |
Advanced Topics

If you need to generate the virtual machine memory dump, you can do this from Parallels Desktop. When the virtual machine is running, click the Develop menu in the macOS menu bar and choose Generate Core Dump. For more details on where the dump is stored and how to convert it to the Linux, Windows or macOS format, please refer to the prlcore2dmp topic of the Parallels Desktop Pro Edition Command-Line Reference Guide available online.

Start a Debugging Session

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

You can start a debugging session directly from Parallels Desktop. When the virtual machine is running, click the Develop menu in the macOS menu bar and choose Start Debugging Session.

**Note:** Parallels Desktop supports lldb as a debugging front end. It should be installed with the XCode command line tools or XCode and you must accept the lldb license agreement.

Integration With Chef/Ohai

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you're using Chef to provision your Parallels virtual machines or host systems running Parallels Desktop, you can check in the recipe that the type of system virtualization being used is virtualization from Parallels. To do this, use the node['virtualization'] attribute. This attribute is set by Ohai during the chef-client run.

**Note:** The Ohai version must be 8.6.0 or later.

You will see the following in the host system:

```
"virtualization": {
  "systems": {
    "parallels": "host"
  },
  "system": "parallels",
  "role": "host"
}
```

And the following in the guest system:

```
"virtualization": {
  "systems": {
    "parallels": "guest"
  },
  "system": "parallels",
  "role": "guest"
}
```
Integration With Docker

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

Parallels Desktop allows you to run and manage Docker containers as if they were running directly on your Mac. You just need a Linux-based virtual machine (Boot2Docker) that will host your containers.

For more details, please refer to the Docker Machine official documentation:
https://docs.docker.com/machine/

**Note:** When this topic was being written, Docker Machine didn't fully support Parallels Desktop. While we’re still working and improving this feature, you can use our custom-built executable file available here.

Use Virtual Machine Names as DNS Names

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

When you start a virtual machine operating in the shared (p. 146) or host-only (p. 148) networking mode and it gets an IP address via DHCP, the virtual machine gets registered in the macOS `etc/hosts` file and you can use its name to connect from the host operating system or other virtual machine operating in the shared (p. 146) or host-only (p. 148) networking mode.

For example, after starting such a virtual machine, your `etc/hosts` file may look as follows:

```
10.211.55.3     windows-8.1.shared windows-8.1 #prl_hostonly shared
```

You can use the virtual machine name (`windows-8.1.shared`) to connect to this virtual machine. For example, if you execute the following command in the macOS Terminal:

```
ping windows-8.1.shared
```

you will start pinging 10.211.55.3.

When such a virtual machine is shut down, its registration entry is removed from the `etc/hosts` file.

Resolve Guest OS DNS Requests Using `etc/hosts`

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

When a virtual machine operating in the shared networking mode (p. 146) sends a DNS request, the request is now resolved also using the macOS `etc/hosts` file.

For example, if your macOS `etc/hosts` file contains the following entry:

```
1.2.3.5 testh
```
and you start pinging *testh* in a virtual machine, the guest OS will check the macOS *etc/hosts* file first and start pinging 1.2.3.5.

**Quickly Change the Screen Resolution**

If you're working with a virtual machine in the Window or Full Screen view mode, you can easily and quickly change the virtual machine screen resolution. Simply click the View menu in the macOS menu bar, point to Set Resolution and choose the screen resolution you need.

*Note:* Set Resolution is available only in Parallels Desktop for Mac Pro Edition for virtual machines with Parallels Tools installed (p. 128). And the Show developer tools option must be enabled in the More Options pane of the virtual machine configuration.

If you're working with the virtual machine in Full Screen on multiple displays, the screen resolution is changed on the monitor where you selected a new resolution.

**Other Actions**

Using Parallels Desktop, you can also:

- Optimize your virtual machine for software development (p. 96);
- Simulate various Internet connectivity speeds;
- Download pre-configured virtual appliances (p. 118);
- Enable nested virtualization support; and
- Enable PMU virtualization support.

**Set File Type Associations**

When working with Parallels Desktop, you may need to open a macOS file in some Windows application or a Windows file in some macOS app. If you often need to do so, change the file association for the file.

*Note:* This functionality is available only for Windows XP and later versions with Parallels Tools installed (p. 130).

**Associate macOS files with a Windows application**

To make some type of macOS files always open in a Windows application, do the following:

1. Right-click a macOS file in Finder, point to Open with and click Other.
2. Navigate to Macintosh HD > Users > <user name> > Applications (Parallels) and open the required virtual machine folder.
3 Select a Windows application you want and click Open.

4 Parallels Desktop shows a macOS notification asking whether you want to make the application default for this type of files. Click Make. Now all files of this type will open in the selected Windows application.

You can also make some type of macOS files always open in a Windows application the following way:

1 Right-click a macOS file and choose Get Info.
2 In the Open with section, click the Open with menu and choose Other.
3 Navigate to Macintosh HD > Users > <user name> > Applications (Parallels) and open the required virtual machine folder.
4 Select a Windows application you want, choose Always Open With and click Add.
5 Click Change All and close the file info menu. Now all files of this type will open in the selected Windows application.

Associate Windows files with a macOS application

For Windows 10:

To make some type of Windows files always open in a macOS application, do the following:

1 Right-click a Windows file and choose Open with > Choose another app.
2 Select the macOS application you want to use with that type of file and make sure Always use this app to open <file_extension> files is selected. Now all files of this type will open in the selected macOS application.

For Windows 8 and Windows 7:

To make some type of Windows files always open in a macOS application, do the following:

1 Right-click a Windows file and choose Open with > Choose default application.
2 Select the macOS application you want to use with that type of file and make sure Use this app for all <file_extension> files is selected. Now all files of this type will open in the selected macOS application.

Picture in Picture Mode

When you switch to Picture in Picture, you can resize the virtual machine windows and place them side by side with your Mac’s applications.

In the Picture in Picture mode, you can:

• Resize the Windows window while keeping its shape by dragging its lower-right corner.
Advanced Topics

• Resize the Windows window by pressing and holding the Option (Alt) key and dragging the lower-right corner of the window.

• Resize the Windows window and dynamically adjust the screen resolution by pressing and holding the Shift and dragging the lower-right corner of the window.

Using the Picture in Picture settings, you can configure the virtual machine appearance and behavior when it is running in the Picture in Picture mode. In the Picture in Picture mode, you can resize the virtual machine windows and place them side by side with your Mac applications. A Picture in Picture window can be scaled to any size, and its content will still be active. This allows you to monitor the tasks running inside the virtual machine while you are working on the Mac side.

To edit these settings, do the following:

1. Click the Parallels icon in the menu bar and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. In the Virtual Machine Configuration window, click Options and select the settings name in the sidebar.

You can configure the settings in this pane even when the virtual machine is running.

In the Picture in Picture mode, the virtual machine window becomes transparent by default. You can specify the level of visibility in the Opacity field by dragging the slider between Transparent and Opaque. You can change the level of transparency for your virtual machine that is running when it is in the Picture in Picture mode.
To manage the behavior of the virtual machine window in the Picture in Picture mode, use the following options selected by default:

- Keep on top of other windows. Clear this option if you do not want the virtual machine window to appear on top of all other open windows when the virtual machine is in Picture in Picture mode.
- Show window on all Spaces. Clear this option if you don’t want the virtual machine window to be displayed on all Spaces.
- Activate window by Dock icon only. Select this option if you want to make the virtual machine window inactive. When selected, you will click “through” the window. If you need to make the window active again and capture the mouse or keyboard input, click the virtual machine icon in the Dock.

**Hide and Show Parallels Desktop**

When Parallels Desktop is running, you can hide and show it and all its windows by holding down the Function (Fn) key and pressing the F6 key.

If Parallels Desktop is visible but running in the background, pressing Fn-F6 brings Parallels Desktop and all its windows to focus. The key to show and hide Parallels Desktop can be configured on the Shortcuts tab of Parallels Desktop Preferences:
**Advanced Topics**

**Note:** Most function keys (F1, F2, and so on) on Mac keyboards serve as specific control keys, such as volume and brightness controls, and you must hold down the Fn key as you press the function key to trigger an alternate, application-specific function. If you want to set function keys to be used for alternate functions without having to press the Fn key, choose Apple menu > System Preferences and click Keyboard. Then click the Keyboard tab and choose Use all F1, F2, etc. keys as standard function keys.

---

**Remove Parallels Desktop**

To remove Parallels Desktop, open your Applications folder and drag the Parallels Desktop application to the Trash.

---

**Advanced Preferences**

In the Advanced pane of Parallels Desktop Preferences, you can configure some additional settings.

![Parallels Desktop Preferences](image)

**Speech**

Parallels Desktop allows you to operate your virtual machine by using the speech commands. If you want to do that, select Enable spoken commands and make sure that:

- the virtual machine window is active, and
- the speech settings are properly tuned on the corresponding tab of macOS System Preferences
If the speech settings are not tuned on, you will see the 'To enable this option, you should turn on speakable items in System Preferences' warning message. To tune the speech settings, click System Preferences.

To view the list of all spoken commands available to manage your virtual machines, please refer to Enable Spoken Commands (p. 121).

Feedback

To participate in the Customer Experience Application, select the corresponding option. If you join this application, Parallels will collect information about your Mac and virtual machines configuration. The collected information will help us to make the product better fit your needs.

If you join, only the following types of data will be collected:

- hardware configuration of your Mac
- software configuration of your Mac and virtual machines (the names and versions of the operating systems and software installed in them)
- configuration files of virtual machines

Any types of private information like your name, e-mail, address, phone number, and keyboard input will not be collected.

For more details, visit the Customer Experience Application page at the Parallels website (follow the link in the pane).

Troubleshooting

While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels support team for solving problems and improving the product. If you select the Use detailed log messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

Resetting Hidden Messages

Some Parallels Desktop dialogs and windows are provided with the Do not show this message again option. If you select this option, the corresponding dialog will not appear next time you perform the same operation. Using the Reset Warnings button, you can reset all dialogs and windows with this option selected so that they would be displayed again each time you initiate the corresponding operation.
Locking Parallels Desktop Preferences

If you want to prevent Parallels Desktop Preferences from further unauthorized changes, click the Lock icon at the bottom of the window. The next time anybody wants to change the settings in any pane of Parallels Desktop Preferences, an administrator’s password will be required.

Shared Networking Settings

**Note:** Shared network settings are available in Parallels Desktop for Mac Pro Edition only.

To change the shared networking settings, select the Network tab of Parallels Desktop Preferences and click Shared. You will see the following window:
In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your virtual machines operating in the shared networking mode. To disable any of these servers, clear the corresponding option.

For more information about configuring shared networking, refer to Share Network Settings Between macOS and Windows (p. 89).

Port Forwarding

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from external computers. The port forwarding functionality allows computers on your local network and on the Internet to transfer data to any of your virtual machines that use the shared networking mode. The data sent to a specific port on your Mac will be redirected to a specific port of your virtual machine according to the port-forwarding rule.

To add a port forwarding rule:

1. Click the Add button below the Port forwarding rules list.
2. In the displayed window, do the following:
   - In the Protocol field, specify the port type you want to use for establishing network connections. You can choose between the TCP or UDP port types.
   - In the Source Port field, type the number of the incoming port on your Mac.
   - In the Forward to section, indicate the name or IP address of the virtual machine you want to connect.
   - In the Destination Port field, type the port on the virtual machine to which the data will be transferred.
3. Click OK to add the rule.
When the rule is added, use the following IP address combination for external connections to your virtual machine: <you Mac's IP address>:<Incoming port>.

To edit a rule, select it in the Port forwarding rules list, click the Edit button, modify the necessary settings, and click OK to apply them.

To remove a port forwarding rule, select it in the Port forwarding rules list and click the Remove button.

To restore the default settings, click Restore Defaults.

Host-Only Networking Settings

Note: Host-Only network settings are available in Parallels Desktop for Mac Pro Edition only.
To change the host-only networking settings, select the Network tab of Parallels Desktop Preferences and click Host-Only. You will see the following window:

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to the virtual machines operating in the host-only networking mode. To disable any of these servers, clear the corresponding option.

To restore the default settings, click Restore Defaults.

For more information on configuring the host-only networking settings, refer to Use Host-Only Network Settings (p. 92).

Create a Custom Host-Only Network

When working with Parallels Desktop, you can use an already configured shared or host-only networks. If you need to manage network traffic between virtual machines, you can add a new host-only network.
Note: You can add new host-only networks in Parallels Desktop for Mac Pro Edition only.

To add a new host-only network:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click Network.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click Network.

2. Click the Add button. Once a new host-only network is added, configure its settings the way you need.

To remove a custom host-only network, select it and click the Remove button.
Read this chapter to learn which options are available in the Parallels Desktop Preferences and virtual machine settings, how these options work, and how to add new devices, such as hard disk or DVD-drive, to the virtual machine configuration.

To access Parallels Desktop Preferences, right-click the Parallels Desktop icon in the Dock and choose Preferences.

To access your virtual machine settings, do one of the following:
Parallels Desktop Preferences and Virtual Machine Settings

- If the virtual machine is running in Full Screen or Window view mode, move the mouse pointer to the top of the screen, click Actions and choose Configure.

- If the virtual machine is running in Coherence view mode, click the Parallels icon in the top right corner of the macOS menu bar and choose Configure.

In This Chapter

Parallels Desktop Preferences ................................................................. 152
Virtual Machine Settings ........................................................................ 169
Adding and Removing Devices .............................................................. 212

Parallels Desktop Preferences

General Preferences

Use General Preferences to specify whether the Parallels menu is available in the macOS menu bar, change the folder where your virtual machines are stored, and more.
To open these preferences, choose Parallels Desktop > Preferences, then click General.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td>Use this menu to choose the color scheme of the Parallels Desktop wizards and Control Center.</td>
</tr>
<tr>
<td>Parallels menu</td>
<td>Choose whether the Parallels menu is available in the macOS menu bar. This menu provides a quick access to the Parallels Desktop menus, Preferences, Control Center, help resources, virtual machine actions, and more.</td>
</tr>
<tr>
<td>Virtual machines folder</td>
<td>Set where new virtual machines are stored. By default, they are saved to the Parallels folder inside the user's home folder.</td>
</tr>
<tr>
<td>Virtual machine Dock icons</td>
<td>Choose which type of icons your virtual machines have in the Dock:</td>
</tr>
<tr>
<td></td>
<td>• OS Icon. The Dock icon shows the type of the guest operating system.</td>
</tr>
<tr>
<td></td>
<td>• Live Screenshot. The Dock icon shows a miniature image of what you see in the guest operating system.</td>
</tr>
<tr>
<td></td>
<td>• None. The virtual machine has no icon in the Dock.</td>
</tr>
<tr>
<td>Check for updates</td>
<td>Set the frequency that Parallels Desktop checks for software updates.</td>
</tr>
<tr>
<td>Download updates automatically</td>
<td>When this option is selected, Parallels Desktop downloads updates automatically and asks whether you want to install them.</td>
</tr>
<tr>
<td>Check Now</td>
<td>Click this button to check for updates manually. You can also choose Check for Updates from the Parallels Desktop application menu.</td>
</tr>
</tbody>
</table>
Shortcuts Preferences

Use Shortcuts Preferences to customize keyboard shortcuts, create keyboard profiles for multiple operating systems, enable or disable macOS system shortcuts, and more.

To open these preferences, choose Parallels Desktop > Preferences, then click Shortcuts.

Application Shortcuts

You can perform various actions in Parallels Desktop either by choosing menu items from the corresponding menus or by pressing key combinations. For example, you can open an existing virtual machine either by clicking File > Open or by pressing Command + O. However, if you deselect this key combination, the shortcut will not work.

To customize which actions can be performed by pressing key combinations, do the following:

1. Choose Application Shortcuts on the Shortcuts tab.
2. Enable or disable actions that can be performed by pressing key combinations.
macOS System Shortcuts

In macOS the function keys on your keyboard (F1, F2, F3 and so on) control functions like activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. By default, when a Windows application is active the function keys and other Mac system shortcut key combinations (such as pressing Cmd + Tab to switch between open applications) continue to activate macOS functions.

To set whether function keys and macOS system shortcut key combinations activate functions in macOS or Windows:

1. Choose macOS System Shortcuts on the Shortcuts tab.
2. Select one of the following from the Send macOS system shortcuts menu:
   - Auto: If you’re working with Windows, system shortcuts that don’t function in Windows (for example, Control-Up Arrow button to display Mission Control) trigger functions in macOS. If you’re using macOS as a guest OS and a guest OS or its application is active, system shortcuts that are typical only to macOS trigger functions in the guest version of macOS.
• Always: When Windows or Windows applications are active, function keys and other system shortcuts always trigger functions in Windows.
• Never: Function keys and other system shortcuts always trigger functions in macOS.

To show and hide Parallels Desktop, use the Fn + F6 key combination. To use any other key instead of F6, click the corresponding text field and press the key you want.

Mouse Shortcuts

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking. By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click the mouse. You can change which key combination triggers a right-click. Do the following:

1 Choose Mouse Shortcuts on the Shortcuts tab.
2 Select Secondary click (for right-click) or Middle click.
3 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.
You can use any combination of the Control, Option (Alt), Shift, and Command keys.

Keyboard Menu

While working with a virtual machine, you can enter key combinations by choosing Devices in the macOS menu bar > Keyboard and then choosing a key combination. To customize available key combinations, do the following:

1. Choose Keyboard Menu on the Shortcuts tab.
2. Do one of the following:
   - To add a new key combination, click the Add button.
   - To remove a key combination from the Keyboard menu, select it and click the Remove button.
To edit an existing key combination, double-click the key combination or select it and click the Edit button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

Virtual Machine Shortcuts

By default, Parallels Desktop maps common macOS keyboard shortcut key combinations to the equivalent Windows key combinations. That way if you’re used to, for example, pressing Command-C to copy text in macOS, you don't have to switch to the Windows equivalent, Control-C.
To customize keyboard shortcuts, do the following:

1. Select your virtual machine from the VIRTUAL MACHINES list on the Shortcuts tab. When you're using a Windows application, pressing a key combination in the From macOS column above triggers the key combination in the To Windows column.

2. If the lock icon is locked, click it and enter an administrator password.

3. Do one of the following:
   - To edit an existing key combination, double-click the key combination or select it and click the Edit button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

   ![Keyboard Shortcut Editor Screenshot]

   Click OK to save the changes.
   - To delete a key combination, select it and click the Remove button.
   - To add a new key combination, click the Add button.

**Devices Preferences**

Use Devices Preferences to specify where to connect new external devices and permanently assign devices to Mac or a virtual machine.
Parallels Desktop Preferences and Virtual Machine Settings

To open these preferences, choose Parallels Desktop > Preferences, then click Devices.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| When a new external device is detected | Choose what to do when a new external device is connected to your Mac:  
  - Connect it to my Mac. New external devices are automatically connected to your Mac and become available for use with macOS applications. If you want to connect such a device to a virtual machine, use the Devices > USB & Bluetooth menu.  
  - Connect it to the active virtual machine. New external devices are automatically connected to the virtual machine you're currently working with and become available for use with the guest OS applications. If no virtual machine is running, the external device is connected to macOS.  
  - Ask me what to do. Each time you connect an external device, you're prompted to choose whether you want to connect the device to your virtual machine or Mac. |
### Permanent assignments
If you want a particular external device to be always available to either Mac or a virtual machine, do the following:

1. Click the **Add (+)** button towards the bottom of the window.
2. Select the device from the list.
3. Double-click the word (either **Your Mac** or some virtual machine) in the **Connect To** column. The word becomes a pop-up menu.
4. Do one of the following:
   - To set the device to always be available to the Mac, choose **Your Mac** from the menu.
   - To set the device to always be available to a virtual machine, choose the virtual machine from the menu.

To remove an existing assignment, so that the device no longer automatically connects to the Mac or virtual machine, select the device in the Devices column and click the **Remove (-)** button.

### Security Preferences
Use Security Preferences to set password requirements and encrypt your virtual machines using third-party plugins.

To open these preferences, choose Parallels Desktop > Preferences, then click **Security**.

---

**Parallels Desktop Preferences**

- **Require password to:**
  - Create new virtual machines
  - Add an existing virtual machine
  - Remove virtual machines
  - Clone or convert virtual machines to a template
  - Open Parallels Desktop preferences

- **Custom password:**
  - Turn Off...
  - Change Password...

- You can also deploy these settings to other computers. Learn more...

- **Encryption engine:**
  - Allow third-party plugins

  To learn more about external plugins, see here.

- **Click the lock to prevent further changes.**

<table>
<thead>
<tr>
<th>General</th>
<th>Shortcuts</th>
<th>Devices</th>
<th>Security</th>
<th>Network</th>
<th>Advanced</th>
<th>Toolbox</th>
<th>Access</th>
</tr>
</thead>
</table>

---

**Note:**

- The content above is a natural text representation of the document. It is not a direct copy of the image content.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Require password to</td>
<td>In this section, you can select the actions for which Parallels Desktop will require an administrator password.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Open Parallels Desktop preferences is available in Parallels Desktop for Mac Pro and Business Editions only.</td>
</tr>
<tr>
<td>Custom password (available in Parallels Desktop for Mac Pro and Business Editions only)</td>
<td>You can create a custom password to restrict the above operations. Select the operations you want to protect with this password, click Turn On and specify the password. To change or turn off the password, click Change Password or Turn Off.</td>
</tr>
<tr>
<td>Encryption engine (available in Parallels Desktop for Mac Pro and Business Editions only)</td>
<td>To be able to encrypt your virtual machines using third-party plugins, select Allow third-party plugins.</td>
</tr>
</tbody>
</table>

Network Preferences

Use Network Preferences to change the shared and host-only network settings or to add a new host-only network.

To open these preferences, choose Parallels Desktop > Preferences, then click Network.
Note: This tab is available in Parallels Desktop for Mac Pro and Business Editions only.

Shared Network

By default, virtual machines are set to share network settings with macOS. When a virtual machine is connected to the shared network, it can access the Mac, other virtual machines on the Mac, computers on your local network, and the Internet.

To change the shared network settings, click Shared and make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your virtual machines operating in the shared networking mode.

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from external computers. The port forwarding functionality allows computers on your local network and on the Internet to transfer data to any of your virtual machines that use the shared networking mode. The data sent to a specific port on your Mac will be redirected to a specific port of your virtual machine according to the port-forwarding rule.
To add a port forwarding rule:

1. Click the Add button below the Port forwarding rules list.
2. In the displayed window, do the following:
   - In the Protocol field, specify the port type you want to use for establishing network connections. You can choose between the TCP or UDP port types.
   - In the Source Port field, type the number of the incoming port on your Mac.
   - In the Forward to section, indicate the name or IP address of the virtual machine you want to connect.
   - In the Destination Port field, type the port on the virtual machine to which the data will be transferred.

![Port Forwarding Rule Window]

3. Click OK to add the rule.

When the rule is added, use the following IP address combination for external connections to your virtual machine: `<you Mac's IP address>:<Incoming port>`.

![Network Diagram]

To edit a rule, select it in the Port forwarding rules list, click the Edit button, modify the necessary settings, and click OK to apply them.
To remove a port forwarding rule, select it in the Port forwarding rules list and click the Remove button.

**Host-Only Network**

When a virtual machine is connected to a host-only network, it can access the Mac and other virtual machines on the Mac.

To change the host-only network settings, click Host-Only and make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your virtual machines operating in the host-only networking mode.
Add a New Host-Only Network

If you need to manage network traffic between virtual machines, you can add a new host-only network.

To add a new host-only network, click the Add button ![Add button](image). Once a new host-only network is added, configure its settings the way you need.

To remove a custom host-only network, select it and click the Remove button ![Remove button](image).

Advanced Preferences

Use Advanced Preferences to enable spoken commands, participate in the customer experience program, reset hidden messages, and more.

To open these preferences, choose Parallels Desktop > Preferences, then click Advanced.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Speech</td>
<td>Parallels Desktop allows you to operate your virtual machine by using the speech commands. If you want to do that, select Enable spoken commands. To view the list of all spoken commands available to manage your virtual machines, please refer to Parallels Desktop User's Guide.</td>
</tr>
<tr>
<td>Feedback</td>
<td>If you want to help us make Parallels Desktop better fit your needs, please select Participate in the Customer Experience Program. Parallels will collect information about your Mac and virtual machines configuration. Note: Any types of private information like your name, e-mail, address, phone number, and keyboard input will not be collected.</td>
</tr>
</tbody>
</table>
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Troubleshooting</th>
<th>While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels support team for solving problems and improving the product. If you select the Use detailed log messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may lower the system performance. You're not recommended to enable this option until you're asked to do so by the Parallels support team.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reset all dialog warnings</td>
<td>Some Parallels Desktop dialogs and windows are provided with the Do not show this message again option. If you select this option, the corresponding dialog will not appear next time you perform the same operation. Using the Reset Warnings button, you can reset all dialogs and windows with this option selected so that they would be displayed again each time you initiate the corresponding operation.</td>
</tr>
</tbody>
</table>

Parallels Toolbox

Parallels Desktop customers get a complimentary subscription to Parallels Toolbox. It's a set of tools that greatly simplify your everyday tasks.

From the Toolbox tab, you can install Parallels Toolbox on your Mac. To open this tab, choose Parallels Desktop > Preferences, then click Toolbox.

If you don't have Parallels Toolbox installed, click Install. If Parallels Toolbox is already installed, click Open to open the whole list of tools.

Using Parallels Toolbox, you can do lots of tasks with just one click:
Parallels Desktop Preferences and Virtual Machine Settings

- Download videos from the Internet;
- Take screenshots;
- Record the screen;
- Record audio;
- Mute the mic;
- Disable camera;
- And much more...

For the detailed information about Parallels Toolbox, please refer to the Parallels Toolbox User's Guide available online.

Parallels Access

Parallels Desktop customers get a complimentary subscription to Parallels Access. This app allows users to work with their Mac and Windows applications from iOS and Android devices or via a web browser.

From the Access tab, you can install Parallels Access agent on your Mac. To open this tab, choose Parallels Desktop > Preferences, then click Access.

If you don't have Parallels Access installed, click Install. If Parallels Access is already installed, click Open to open the Parallels Access window.

Parallels Access lets you:
• Use any of your Mac and Windows applications on your mobile device;
• Remotely start, stop, and reset Windows or Mac;
• Connect over Wi-Fi or 3G;
• Access Windows and Mac from anywhere over the Internet;
• And more...

For more information about using Parallels Access, please see here.

**Virtual Machine Settings**

**General Settings**

On the General tab of virtual machine configuration, you can edit the virtual machine name, configure the virtual machine to better fit your needs, reduce the virtual machine size, and more…

To open these settings, choose Actions > Configure, then click General.
### Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest OS type</td>
<td>Click the menu at the top of the General tab to change the guest OS type and version. You may need to do this after upgrading the operating system (for example, from Windows 7 to Windows 10). The OS indicated in this menu must match the OS that is actually installed in the virtual machine. Otherwise, Parallels Tools may start working incorrectly.</td>
</tr>
<tr>
<td>Name</td>
<td>In this field, you can edit the virtual machine name.</td>
</tr>
<tr>
<td>Description</td>
<td>Use this field to add some description to your virtual machine. The description is displayed in Control Center together with the virtual machine name.</td>
</tr>
<tr>
<td>Configure for</td>
<td>Use this option to choose a profile that better fits your needs. Click Change and select what for you usually use the virtual machine. The virtual machine settings will be optimized according to your needs.</td>
</tr>
<tr>
<td>Total size</td>
<td>Click Reclaim to compress the virtual machine hard disk(s) and remove unnecessary files to free up disk space.</td>
</tr>
</tbody>
</table>

### Options

#### Startup and Shutdown Settings

In the Startup and Shutdown pane, you can configure how the virtual machine starts or shuts down.

To open these settings, choose Actions > Configure > Options, then click Startup and Shutdown.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start up and shut down manually</td>
<td>Select this option if you want to always start and shut down the virtual machine manually.</td>
</tr>
<tr>
<td>Always ready in background</td>
<td>Select this option if you want to make the virtual machine start automatically when the Mac starts.</td>
</tr>
</tbody>
</table>
### Custom

If you want to specify not only how the virtual machine starts or shuts down but also the view mode and what happens on closing the virtual machine window, select Custom and specify the following:

- **Start Automatically.** Use this menu to set whether the virtual machine starts automatically:
  - **Never:** The virtual machine never starts automatically.
  - **When window opens:** The virtual machine starts automatically when you open it from Control Center.
  - **When Parallels Desktop starts:** The virtual machine starts automatically when you start Parallels Desktop.
  - **When Mac starts:** The virtual machine starts automatically when you start the Mac. If you select this option, you can also configure the virtual machine to delay the startup.
  - **When user logs in:** Windows starts automatically when the macOS user logs in to macOS on the Mac startup.

- **Startup view.** Use this menu to choose in which mode the virtual machine starts when you start the virtual machine or guest OS application.

- **On VM Shutdown.** Use this menu to set what happens when you shut down your virtual machine:
  - **Keep window open:** If the virtual machine is set to appear in a separate window, the window stays open when you stop or shut down the virtual machine.
  - **Close window:** If the virtual machine is set to appear in a separate window, the window closes when you stop or shut down the virtual machine.
  - **Quit Parallels Desktop:** Parallels Desktop quits when you stop or shut down the virtual machine.

- **On Mac Shutdown.** Use this menu to specify what happens when you shut down your Mac (available in Parallels Desktop for Mac Pro and Business Editions only).

- **On Window Close.** Use this menu to set what happens when you close the Parallels Desktop window. These settings affect what happens only when the virtual machine is set to appear in a separate window.

### Pause Windows when possible

Select this option to conserve your Mac's resources by setting the virtual machine to pause automatically when no Windows applications are open. That way, more resources such as RAM and CPU can be used for macOS applications.
Optimization Settings

In the Optimization pane, you can limit the virtual machine resource usage.

To open these settings, choose Actions > Configure > Options, then click Optimization.

**Note:** This tab is available in Parallels Desktop for Mac Pro and Business Editions only.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource usage</td>
<td>If your Mac lacks resources for running two or more virtual machines at a time, you can limit the virtual machine resource usage for the virtual machine doing more important work to have more resources. Drag the slider between Low, Medium, and No limit points. If you change this setting and then don't like how Windows is performing, then try a different setting.</td>
</tr>
</tbody>
</table>

Sharing Settings

In the Sharing pane, you can view and configure the virtual machine sharing settings.
To open these settings, choose Actions > Configure > Options, then click Sharing.

Share Mac
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share folders</td>
<td>With folder sharing enabled, you can navigate to any shared macOS folder from within a Windows application. When you open a file (for example, by choosing File &gt; Open in many applications), your shared macOS folders appear as network shared directories labeled &quot;\Mac&quot;.</td>
</tr>
<tr>
<td></td>
<td>To enable macOS folders for sharing with Windows applications, do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To share just the folders in your Home folder, choose Home folder only from the Share folders menu.</td>
</tr>
<tr>
<td></td>
<td>• To share all your macOS folders, choose All disks from the Share folders menu.</td>
</tr>
<tr>
<td></td>
<td>• To share any folder you want, click Custom Folders and click the add (+) button, then choose the folder you want to share. You can add more folders by clicking the add (+) button again. Once you share a macOS folder with Windows you can:</td>
</tr>
<tr>
<td></td>
<td>• Disable the folder sharing by deselecting On.</td>
</tr>
<tr>
<td></td>
<td>• Change the folder name that will be displayed in Windows by double-clicking the folder name in the Name column and typing another name.</td>
</tr>
<tr>
<td></td>
<td>• Restrict writing to this folder by clicking Read &amp; Write in the Permissions folder and choosing Read only. You will not be able to add items to the folder.</td>
</tr>
<tr>
<td>Shared profile</td>
<td>You can set macOS and Windows to use the same folders for things like music, documents, pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, it will be in the Documents folder whether you’re using a macOS application or a Windows application.</td>
</tr>
<tr>
<td></td>
<td>To enable this functionality, select Share Mac user folders with Windows.</td>
</tr>
<tr>
<td></td>
<td>Your macOS Desktop, Documents, Pictures, Music, Movies, and Downloads folders are merged with the corresponding Windows folders, and the macOS Trash is merged with the Windows Recycle Bin.</td>
</tr>
<tr>
<td></td>
<td>If you only want to map some of the folders, click Configure and select the folders you want. To map the macOS Trash to the Windows Recycle Bin, select Merge Recycle Bin with Trash.</td>
</tr>
</tbody>
</table>
## Parallels Desktop Preferences and Virtual Machine Settings

| Share cloud folders with Windows (in macOS virtual machines, this option is called Share cloud folders with virtual machine) | If you're using iCloud, Dropbox, or Google Drive cloud storage in macOS, you can easily share their macOS folders with Windows. Once sharing is enabled, you can upload, download, and sync files from any of these services from within Windows without duplicating any of their files on your hard disk.

To share macOS iCloud, Dropbox, or Google Drive folders with Windows, do the following:

**Note:** In Parallels Desktop for Mac Pro Edition, you can also share your Dropbox for Business, Box and OneDrive for Business folders with Windows.

If you haven't already, set up iCloud, Dropbox, or Google Drive in macOS.

Select Share cloud folders with Windows.

Log in to Windows and open Computer. Folders for iCloud, Dropbox, or Google Drive are available in the Quick access (or Favorites) section. You can use them to upload and download files to and from the cloud. |
| --- | --- |
| Map Mac volumes to Windows (in macOS virtual machines, this option is called Map Mac volumes to virtual machine) | When you connect an external storage device, such as a USB drive, to your Mac, you can access the contents from macOS applications.

You can set Parallels Desktop to automatically mount storage devices and volumes to Windows. That way, you can access the contents from both macOS and Windows.

The following items can be mounted to Windows:

- **Removable drives:** External storage devices, such as USB hard disks and USB flash drives.
- **CD/DVD drives:** CD and DVD drives or mounted CD/DVD images.
- **Network folders:** Folders shared over the network.

To make these items mount to Windows automatically, select Map Mac volumes to Windows.

When you connect a storage device or volume, it is mounted as a network drive. For example, a USB flash drive plugged in to your Mac will be accessible from both the /Volumes folder in macOS and My Computer in Windows. |
Assign a drive letter to shared folders (available in Parallels Desktop for Mac Pro and Business Editions only)

Select this option to assign a drive letter to all Mac folders shared with Windows. When a Mac shared folder has a letter, you can easily access it in Windows - such folders are displayed in the "This PC" section of "File Explorer".

Allow creating executables (available in Parallels Desktop for Mac Pro and Business Editions only)

Select this option to create executable files in the Mac folders shared with Windows. When this option is selected, all newly created files become executable.

Enable DOS 8.3 filenames (available in Parallels Desktop for Mac Pro and Business Editions only)

Files created in macOS don't have DOS 8.3 names and some Windows applications may work incorrectly with such files. Select this option to create additional DOS 8.3 names for the files located in the Mac folders shared with Windows.

Share Windows

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access Windows folders from Mac</td>
<td>Select this option to allow access to Windows folders from Mac.</td>
</tr>
</tbody>
</table>
### Share OneDrive with Mac

If you're using Microsoft OneDrive to store files in the cloud, you can easily share your OneDrive folders with macOS. Then you can upload or download OneDrive files in macOS without duplicating any of the files on your hard disk.

**Note:** To share OneDrive folders with macOS, the OneDrive desktop app must be installed in Windows. If you're using the preinstalled OneDrive app, OneDrive folders are not shared because this app doesn't create any local folders and works directly with the cloud storage.

To share your Windows OneDrive folders with macOS, do the following:
- If OneDrive isn't already set up in Windows, set it up.
- Select **Access Windows folders from Mac** and **Share OneDrive with Mac**.
- In the macOS Finder, choose **Finder > Preferences** and select **Connected servers**.
- Once selected, Microsoft OneDrive folders appear as hard disks on the macOS desktop. You can use them to upload and download files to and from OneDrive.

**Note:** These shared folders are visible on the macOS desktop and you can use them to upload files from macOS only when Windows is running.

### Share Windows network drives with Mac (available in Parallels Desktop for Mac Pro and Business Editions only)

Once selected, when you connect to a network drive in Windows, these drives become available in macOS. To access them, go to the Finder sidebar > Shared section and click the virtual machine name.

**Note:** To access these drives in macOS 10.14 Mojave (when it is out), go to the Finder sidebar > Network section and click the virtual machine name.

### Share Windows-connected drives with Mac

Once selected, when you connect an external drive to Windows, these drives become available in macOS. To access them, go to the Finder sidebar > Shared section and click the virtual machine name.

**Note:** To access these drives in macOS 10.14 Mojave (when it is out), go to the Finder sidebar > Network section and click the virtual machine name.

## Applications Settings

In the Applications pane, you can choose whether Windows applications are shared with macOS and macOS applications with Windows, add a folder containing Windows applications to the Dock, set whether Windows applications bounce in the Dock to alert, and more.
To open these settings, choose Actions > Configure > Options, then click Applications.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share Windows applications with Mac</td>
<td>When sharing Windows applications is enabled, you can open Windows applications from the macOS Finder. You can also choose to add a folder to the Dock containing all your Windows applications for easy access.</td>
</tr>
</tbody>
</table>
### Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Windows applications folder in Dock</td>
<td>Select this option to add a Windows Applications Folder to the Dock. This folder is available in the macOS Dock and contains all your Windows applications. As you install more applications, they are automatically added.</td>
</tr>
<tr>
<td>Show Dock icons in Coherence only</td>
<td>You can choose whether or not to show icons for Windows applications in the macOS Dock when in Window or Full Screen mode. If you prefer to work with applications by manipulating them on the Windows desktop, you may not want to be distracted by seeing them in the Dock alongside your macOS application icons. To show Windows application icons in the Dock when in Window or Full Screen mode, deselect Show Dock icons in Coherence only.</td>
</tr>
<tr>
<td>Dock icons bounce to alert</td>
<td>When a Windows application icon in the Windows taskbar would normally flash to alert you to something, such as a new message in Skype or a notification in Microsoft Outlook, by default its icon also bounces repeatedly in the macOS Dock. To enable or disable Windows application icons bouncing to alert, select or deselect Dock icons bounce to alert.</td>
</tr>
<tr>
<td>Add new applications to Launchpad</td>
<td>With this option selected, when you install any applications in Windows (except temporary apps), their icons are automatically added to Launchpad.</td>
</tr>
<tr>
<td>Show Windows notification area in Mac menu bar</td>
<td>Select this option to display the Windows system tray icons in the macOS menu bar.</td>
</tr>
<tr>
<td>Allow apps to auto-switch to full screen</td>
<td>Some applications, most notably 3D games, work best when running at full screen. Select this option to allow such applications to take over the full screen when you open them while in Coherence view mode.</td>
</tr>
<tr>
<td>Share Mac applications with Windows</td>
<td>Select this option to enable sharing macOS applications. When enabled, you can open macOS applications from within Windows or Windows applications.</td>
</tr>
</tbody>
</table>
Full Screen Settings

In the Full Screen pane, you can configure this view mode-related settings.

To open these settings, choose Actions > Configure > Options, then click Full Screen.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use all displays in full screen</td>
<td>If you have a second display connected to your Mac, by default when you switch to Full Screen mode, Windows is displayed only on one display. You can choose which display Windows is shown on by dragging its window to that display and then clicking the Full Screen icon. To extend Windows across all your displays, select Use all displays in full screen.</td>
</tr>
<tr>
<td>Activating virtual machine shows all its spaces</td>
<td>When Use all displays in full screen is selected, you can also choose Activating virtual machine shows all its spaces. With this option selected, click the virtual machine on any of your displays and it will appear on all displays. It's useful when you switched some of your displays to a space that doesn't belong to the virtual machine and then decide to return to the virtual machine and make it displayed on all connected monitors again.</td>
</tr>
<tr>
<td>Optimize full screen for games</td>
<td>If you use a virtual machine to play video games in Full Screen view mode, select Optimize full screen for games. With this option selected, macOS Dock, menu bar and notifications will not be displayed. To release the mouse input, press Ctrl + Alt.</td>
</tr>
<tr>
<td>Use Windows gamma settings</td>
<td>If you're using the virtual machine to play video games, the virtual machine may need to temporarily change your Mac's display gamma setting to properly display different visual effects. To allow the virtual machine to change gamma settings, select Use Windows gamma settings. This option works in the Full Screen view mode only.</td>
</tr>
</tbody>
</table>
**Scale to fit screen**

Use this menu to configure how the virtual machine is displayed when working in Full Screen:

- **Off.** If Parallels Tools are installed, the virtual machine resolution matches that of the Mac. If Parallels Tools aren't installed, the virtual machine resolution remains unchanged. If it is lower than that of the Mac, the virtual machine is displayed on the black background. If higher, the virtual machine has scroll bars.

- **Auto.** If Parallels Tools are installed, the virtual machine resolution matches that of the Mac. If Parallels Tools aren't installed, the virtual machine resolution remains unchanged. If it is lower than that of the Mac, the virtual machine is displayed on the black background. If higher, the virtual machine is entirely displayed on the screen without any scroll bars.

- **Keep ratio:** No matter whether Parallels Tools are installed or not, the virtual machine resolution remains unchanged. If it is lower than that of the Mac, the virtual machine is displayed on the black background. If higher, the virtual machine is entirely displayed on the screen without any scroll bars.

- **Stretch:** No matter whether Parallels Tools are installed or not, the virtual machine resolution remains unchanged but the virtual machine is stretched to occupy the whole screen.

---

**Picture in Picture Settings**

In the Picture in Picture pane, you can configure this view mode-related settings.
Parallels Desktop Preferences and Virtual Machine Settings

To open these settings, choose Actions > Configure > Options, then click Picture in Picture.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opacity</td>
<td>In the Picture in Picture mode, the virtual machine window becomes transparent by default. You can specify the level of visibility in the Opacity field by dragging the slider between Transparent and Opaque.</td>
</tr>
<tr>
<td>Keep on top of other windows</td>
<td>Clear this option if you do not want the virtual machine window to appear on top of all other open windows when the virtual machine is in Picture in Picture mode.</td>
</tr>
<tr>
<td>Show window on all Spaces</td>
<td>Clear this option if you don't want the virtual machine window to be displayed on all Spaces.</td>
</tr>
<tr>
<td>Activate window by Dock icon only</td>
<td>Select this option if you want to make the virtual machine window inactive. When selected, you will click &quot;through&quot; the window. If you need to make the window active again and capture the mouse or keyboard input, click the virtual machine icon in the Dock.</td>
</tr>
</tbody>
</table>

Web & Email Settings

In the Web & Email pane, you can choose where to open web pages and emails, install the plugin for Safari to open web pages in Internet Explorer, set whether to store Internet passwords in Mac keychain, and more.
To open these settings, choose Actions > Configure > Options, then click Web & Email.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Web pages       | By default, clicking a link (such as a web page URL) in Windows opens the default Windows application for that link type, and clicking a link in macOS opens the default macOS application.  
You can set links of a particular type to always open in macOS or in Windows. For example, you could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a macOS application.  
To set Internet links to open in macOS or Windows:  
Click the menu for the type of link you want to set.  
If you don’t see the link type you want, click More Applications. The following types of links can be set:  
- Web Pages: Web pages accessible through the HTTP and HTTPS protocols.  
- Email: Links in the mailto format that open a pre-addressed email.  
- Newsgroups: Links in the news. format that typically open a newsreader application.  
- FTP: File upload and download locations accessible through the FTP protocol.  
- RSS: Episodic content, such as blogs and podcasts.  
- Remote Access: Locations accessible through the Telnet and Secure Shell (SSH) protocols.  
Choose one of the following:  
- Default: The link opens in the application or application set as default in the operating system (macOS or Windows) where you click the link.  
- Open in Windows: Links clicked in macOS or Windows open in the default Windows application for that link type.  
- Open in Mac: Links clicked in macOS or Windows open in the default macOS application for that link type. |
| Safari plugin   | Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in macOS using Safari, you can quickly open the current page in Internet Explorer by doing the following:  
Click Install Plugin to install the "Open in Internet Explorer" plugin.  
Once the plugin is installed, click the Open in IE button in the toolbar.  
If Windows isn’t already open, it starts up and the page opens in Internet Explorer. |
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store Internet passwords in Mac keychain</td>
<td>If you browse the Internet in Windows using Internet Explorer or Microsoft Edge, you can set to store your passwords in Mac keychain. If you do so, the passwords you enter in Internet Explorer or Microsoft Edge will be saved to Mac keychain. These passwords won't be accessible to any other applications and won't be lost if Windows gets corrupted or reinstalled. To store Internet passwords in Mac keychain, select Store Internet passwords in Mac keychain.</td>
</tr>
</tbody>
</table>

Maintenance Settings

In the Maintenance pane, you can specify the time when Windows is allowed to download and install updates and do other maintenance tasks.

To open these settings, choose Actions > Configure > Options, then click Maintenance.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Start maintenance | Select this option and specify when Windows is allowed to do maintenance tasks. It is recommended that you specify the time when your Mac is on and you’re not busy with important work.  

**Note:** The virtual machine must be running at the specified time.
Travel Mode Settings

Work with your virtual machine in Travel Mode to extend the battery life of your Mac. This mode is useful when you're traveling and often use your Mac on battery.

In the Travel Mode pane, you can configure when your virtual machine enters and quits Travel Mode. To open these settings, choose Actions > Configure > Options, then click Travel Mode.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter automatically</td>
<td>In this section, select when your virtual machine automatically enters Travel Mode. Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Always when on battery power. Select this option if you want to switch the virtual machine to Travel Mode always when the Mac is unplugged and starts working on battery power.</td>
</tr>
<tr>
<td></td>
<td>• When battery power is Less than 30%.</td>
</tr>
<tr>
<td></td>
<td>• Never. Select this option if you never want the virtual machine to switch to Travel Mode.</td>
</tr>
</tbody>
</table>
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Quit automatically</th>
<th>In this section, select when your virtual machine automatically quits Travel Mode. Choose one of the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• When connected to power. Select this option if you want the virtual machine to quit Travel Mode when the Mac is connected to power.</td>
</tr>
<tr>
<td></td>
<td>• Never. Select this option if you never want the virtual machine to quit Travel Mode automatically. Only manual interaction is allowed.</td>
</tr>
</tbody>
</table>

More Options

In the More Options pane, you can allow the virtual machine to access the Mac's current location, choose whether to share the Mac clipboard, set whether to sync time from macOS, and more.

To open these settings, choose Actions > Configure > Options, then click More Options.
### Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Time**                                                               | Select Sync from Mac to synchronize the virtual machine time settings with those of your Mac.  
If you want the virtual machine and macOS time settings to always be the same, select Sync from either OS. With this option selected, if you manually change the time settings in the virtual machine, they are changed accordingly in macOS and vice versa.  
If the time zone set in your virtual machine differs from that of your Mac, you can maintain this time difference by selecting Do not sync. |
| **Share Mac clipboard**                                                | If you want to copy and paste data between the host and guest operating systems, select Share Mac clipboard. If the data you copy and paste between macOS and your virtual machine is text and you want to preserve text formatting, select Preserve text formatting. |
| **Allow Windows to access your Mac’s current location**                | Some of the guest OS applications may ask your permission to use your current location. To allow this, select Allow Windows to access your Mac’s current location.                              |
| **Show developer tools (available in Parallels Desktop for Mac Pro and Business Editions only)** | Parallels Desktop has several useful features for software developers. Select this option to display the Develop menu in the macOS menu bar. From this menu, you can:  
  • Start an SSH session;  
  • Open the virtual machine IP address in the macOS default web browser;  
  • Start a debugging session;  
  • Generate the virtual machine memory dump;  
Next points are available only for Windows virtual machines (some of the point may not be shown - this depends on the version of Windows):  
  • Open the list of All Tasks (aka "God Mode");  
  • Start Steps Recorder;  
  • Open Registry Editor;  
  • Open Command Prompt; and  
  • Open the Run window. |
| **Update Parallels Tools automatically (available in Parallels Desktop for Mac Pro and Business Editions only)** | Select this option to update Parallels Tools automatically.                                                                                                                                                     |
| **Asset tag (available in Parallels Desktop for Mac Pro and Business Editions only)** | Asset tags help identify, control, and track computer assets in an organization. Parallels Desktop provides the ability to set an asset tag in the virtual machine BIOS, which can then be read using the standard tools of the guest operating system. To set an asset tag, enter the desired tag in to the corresponding field. |

---

190
Hardware Settings

CPU & Memory Settings

In the CPU & Memory pane, you can view and configure the CPU- and memory-related settings.

To open these settings, choose Actions > Configure > Hardware, then click CPU & Memory.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processors</td>
<td>Use this menu to change the number of virtual CPUs allocated to your virtual machine.</td>
</tr>
<tr>
<td>Memory</td>
<td>Use this menu or slider to change the amount of memory allocated to your virtual machine. To optimize the performance of both the virtual machine and macOS, set the memory allocated to the virtual machine to be somewhere within the recommended range.</td>
</tr>
<tr>
<td>Extended memory limit (available in Parallels Desktop for Mac Pro Edition only)</td>
<td>This option allows you to allocate more memory to a virtual machine than your Mac physically has. Use this option with care (or your system may significantly slow down) and only in rare cases. For example, when you're trying to install a database in to the virtual machine and the installer claims that you don't have enough memory.</td>
</tr>
<tr>
<td>Hypervisor</td>
<td>In this menu, you can choose whether to use the hypervisor from Parallels or from Apple. You're recommended to use the Parallels hypervisor.</td>
</tr>
</tbody>
</table>
### Adaptive Hypervisor
Select this option to set Parallels Desktop to automatically optimize performance for the virtual machine or macOS depending on which application you're working with at the moment. When you're using a virtual machine app, more resources are given to the virtual machine, and when you're using a macOS application, more resources are given to macOS.

---

### Enable nested virtualization (available in Parallels Desktop for Mac Pro and Business Editions only)
Select this option to enable nested virtualization support. Parallels Desktop allows you to run:
- Hyper-V virtual machines inside Windows 8, Windows 10 and Windows Server 2012 virtual machines;
- VMware ESXi virtual machines;
- Xen and kernel-based virtual machines in versions of Linux that support Xen and KVM.

**Note:** Running a virtual machine within a virtual machine may dramatically slow down the macOS and virtual machine performance.

If you use Parallels virtual machines to build, debug and test applications, enable nested virtualization to install and work in:
- Android emulator for Visual Studio;
- iPhone emulator for Visual Studio;
- Xamarin.Android;
- Android Studio;
- Embarcadero RAD Studio;
- Docker for Windows;
- Microsoft Visual Studio + TwinCat 3 (support for TwinCat 3 is being tested and there may be some bugs).

---

### PMU virtualization (available in Parallels Desktop for Mac Pro and Business Editions only)
If you're using virtual machines for software development, you can use a performance monitoring tool, such as Intel VTune Amplifier or OProfile, to optimize the code.

**To get started using a performance monitoring tool:**
Enable PMU (Performance Monitoring Unit) virtualization support by selecting **PMU virtualization**.
Start your virtual machine.
Either start using a built-in profiling utility or download and install any performance monitoring tool you like.

**Notes:**
1. PMU virtualization support can be enabled in Windows (starting from Windows XP) and Linux virtual machines.
2. Enabling PMU virtualization support may slightly slow down your virtual machine performance.
Graphics Settings

In the Graphics pane, you can view and configure the amount of video memory available to the virtual machine video card, set resolution, and more.

To open these settings, choose Actions > Configure > Hardware, then click Graphics.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>Use this field to set the amount of video memory that will be available to the virtual machine. Auto is recommended. When Auto is selected, Windows may use system memory as graphics memory. If any of your Windows applications reports that it lacks graphics memory, please increase the amount of system memory (p. 191) within the recommended range.</td>
</tr>
</tbody>
</table>
### Resolution

If you're working with Windows 7 or later on a Mac with a Retina display, you can choose how Windows is displayed on the screen:

- **Best for Retina display.** Windows resolution matches that of the Retina display and the DPI setting increases. Windows interface elements and text are clear, sharp, and at full size. This option is supported by Windows 7 and later.

- **Scaled.** Windows resolution and DPI setting don't change. Instead, Windows is scaled to full size. As a result, Windows interface elements and text are not sharp. This option is useful for Windows applications that don't support high-DPI settings and appear small onscreen.

- **Best for external displays.** Use this option if you're working with Windows on multiple displays one of which is non-Retina. The option is supported by Windows 8 and Windows 10.

For Windows XP:

If you're working with Windows XP on a Mac with a Retina display, Windows becomes scaled but its resolution doesn't change. As a result, Windows interface elements and text are not sharp.

However, you can enable full (2880x1800) Retina resolution for Windows by selecting Enable Retina resolution. At such a high resolution, Windows interface elements and text become sharp but small.

### 3D acceleration

If you want to use games and applications that require video cards that support DirectX or OpenGL, select On or the version of DirectX you need from the 3D acceleration menu.

Parallels Desktop supports the following versions of DirectX and OpenGL:

- **DirectX 10.1** - for Windows Vista and later.

- **OpenGL 3.3** - for Windows guest operating systems. Please note that support for OpenGL 3.3 is being tested and some applications may not work now.

- **OpenGL 2.1** - for Linux guest operating systems.

If any of your Windows or Linux apps claims that it requires a higher version of DirectX or OpenGL, please let us know about this application on the Parallels forum. To access the forum, either click Help > Suggest a Feature or use the following direct links:

- for DirectX - https://forum.parallels.com/threads/directx-11-support-list-of-titles.340556/

- for OpenGL - https://forum.parallels.com/threads/opengl-3-support-list-of-app-titles.340621/

### Vertical synchronization

Sometimes in games and 3D applications, a newly rendered frame may overlap a previously rendered one and then screen tearing happens. This occurs when the video card or the software using it begins updating the actively-displayed memory in a manner that is out of sync with the monitor's refresh rate. To prevent screen tearing, select the Vertical synchronization option.

### Automatic graphics switching

This option is visible only if your Mac supports graphics switching. Select this option for better battery life or clear for better performance.
Mouse & Keyboard Settings

In the Mouse & Keyboard pane, you can view and configure the mouse- and keyboard-related settings.

To open these settings, choose Actions > Configure > Hardware, then click Mouse & Keyboard.
### Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mouse</strong></td>
<td>If you play games in a virtual machine, the Mouse menu allows you to set how to use a mouse:</td>
</tr>
<tr>
<td></td>
<td>• Auto-detect for games. This is a recommended default setting. If you're working with a guest OS application, the mouse moves freely between the guest operating system and macOS. However, when you start a game, the mouse input is automatically captured in the virtual machine so that you couldn't move the mouse to macOS by mistake and automatically released when you quit the game.</td>
</tr>
<tr>
<td></td>
<td>• Optimize for games. If your mouse accidentally moves to macOS when you're playing a game, select this option to make the mouse work in the virtual machine only. To release the mouse input and switch to macOS, press Ctrl + Alt.</td>
</tr>
<tr>
<td></td>
<td>• Don't optimize for games. In some rare cases, Parallels Desktop may detect an application as a game and the mouse starts working incorrectly with the application. If you have this problem, choose Don't optimize for games.</td>
</tr>
<tr>
<td><strong>Keyboard</strong></td>
<td>Choose Optimize for games from the Keyboard menu if you actively use the modifier keys Option (Alt), Ctrl, and Shift in action games. When this option is selected, signals from these keys are processed immediately.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You're not recommended to optimize keyboard for games when not playing games. Some key combinations with the Ctrl, Alt, Shift or Option keys may not work.</td>
</tr>
<tr>
<td><strong>Mouse pointer sticks at window edges</strong></td>
<td>When working with a virtual machine in Window view mode, you may often need to move the mouse pointer to the edges of the virtual machine window to display various guest OS items: for example, to display the Start menu in Windows 8, hidden taskbar in Windows XP, or macOS menu bar when any of the guest macOS applications is running in full screen.</td>
</tr>
<tr>
<td></td>
<td>The Mouse pointer sticks at window edges option makes the mouse pointer pause for a while at the edges of the virtual machine window and you won't move the mouse outside of the virtual machine window by mistake. To move past the edge, just move the mouse quickly.</td>
</tr>
<tr>
<td><strong>Smooth scrolling</strong></td>
<td>Select this option for the mouse to scroll smoothly.</td>
</tr>
<tr>
<td><strong>Enable swipe from edges</strong></td>
<td>Select this option to enable edge swipe gestures, for example, swiping from the right edge of the touchpad to show the Charm Bar, when working with Windows.</td>
</tr>
<tr>
<td></td>
<td>If you often accidentally swipe from the edges of the touchpad and activate features, you may want to disable edge swipe gestures by deselecting this option.</td>
</tr>
</tbody>
</table>

### Shared Printers Settings

In the Shared Printers pane, you can share the Mac printer with the virtual machine, sync the default printer, and more.
To open these settings, choose Actions > Configure > Hardware, then click Shared Printers.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share Mac printers with Windows</td>
<td>Select this option to share the printer connected to your Mac with the virtual machine.</td>
</tr>
<tr>
<td>Synchronize default printer</td>
<td>By default, virtual machines are set to use the same default printer as your Mac. To use a different default printer for your virtual machine, deselect Synchronize default printer. After that, you can set a new default printer in the guest OS the way you normally would.</td>
</tr>
<tr>
<td>Show page setup options before printing</td>
<td>When you choose to print a document from the virtual machine, first you need to set how the document will be printed. You usually have to specify various printing settings, such as orientation, page size, whether to print the document on one or both sides, etc. Once everything is ready and you click Print in the virtual machine, the macOS window with printing settings appears as well. It's done by default for you just to ensure that the document will be printed exactly the way you want. Or you can specify additional settings, for example, select to Save as PDF instead of printing. To make the documents print without showing this macOS page setup window, deselect Show page setup options before printing.</td>
</tr>
</tbody>
</table>
Network Settings

In the Network pane, you can view and configure the virtual machine network adapter-related settings.

To open these settings, choose Actions > Configure > Hardware, then click Network.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Source | Use this menu to choose one of the following network types for the virtual machine network adapter:  
  • Shared Network. Select this option to enable the Network Address Translation (NAT) feature for the virtual machine. In this case, your virtual machine will share whatever network connection is currently used by your Mac.  
  • Bridged Network. Select this option to allow the virtual machine to access the local network and Internet through one of the network adapters installed on your Mac. In this case, the virtual machine is treated as a stand-alone computer on the network and should be configured in the same way as a real one. You can choose the physical adapter where the virtual machine adapter will be bridged in the list below the Bridged Network option.  
  • Host-Only Network. Select this option to allow the virtual machine to connect to your Mac and the virtual machines residing on it and to make it invisible outside the Mac. If this option is selected, the virtual machine cannot connect to the Internet. |
| Network Conditioner (available in Parallels Desktop for Mac Pro and Business Editions only) | If you’re a software developer, you can simulate various Internet connectivity speeds to test your applications. To do this, select Network Conditioner and choose a pre-configured profile that is specific to the network conditions you want to test. Or click Configure and specify the Inbound and Outbound settings according to your needs. |
| MAC | In the MAC field, you can change the MAC address currently assigned to the virtual machine. MAC addresses are automatically generated during the virtual machine creation. However, you can modify the default MAC address by typing another value in the MAC field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network. This option is for advanced users only. |
| Type | In this menu, you can change the type of the network interface card. You’re not recommended to change the default setting unless you’re told to do so by the Parallels support team. This option is for advanced users only. |

Sound Settings

In the Sound pane, you can view and configure the virtual machine sound device parameters.
To open these settings, choose Actions > Configure > Hardware, then click Sound.

![Image of Parallels Desktop settings](image)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output</strong></td>
<td>Use the Output list to choose the necessary device:</td>
</tr>
<tr>
<td></td>
<td>• Default. Select this option if you want to use the output device set as default in macOS.</td>
</tr>
<tr>
<td></td>
<td>• Built-in Output. Select this option if you want to use one of the output devices from your Mac.</td>
</tr>
<tr>
<td></td>
<td>• Mute. Select this option if you want to mute the output device.</td>
</tr>
<tr>
<td><strong>Input</strong></td>
<td>Use the Input list to choose the necessary device:</td>
</tr>
<tr>
<td></td>
<td>• Default. Select this option if you want to use the input device set as default in macOS.</td>
</tr>
<tr>
<td></td>
<td>• Built-in Microphone. Select this option if you want to use the built-in microphone.</td>
</tr>
<tr>
<td></td>
<td>• Mute. Select this option if you want to mute the input device.</td>
</tr>
<tr>
<td><strong>Sync volume with Mac</strong></td>
<td>For Windows XP and later with Parallels Tools installed, you can set Windows and macOS volume levels to always be the same. With the Sync volume with Mac option selected, if you manually change the volume level in Windows, it is changed accordingly in macOS and vice versa.</td>
</tr>
</tbody>
</table>

If Parallels Tools are not installed, this option is called Use Mac sound volume. When it is selected, Windows has the same sound volume as in macOS.
USB & Bluetooth Settings

In the USB & Bluetooth pane, you can view and configure the USB- and Bluetooth-related settings.

To open these settings, choose Actions > Configure > Hardware, then click USB & Bluetooth.

![USB & Bluetooth Settings](image)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share Mac camera with Windows</td>
<td>Use this option to enable or disable camera sharing.</td>
</tr>
<tr>
<td>Share Bluetooth devices with Windows</td>
<td>Use this option to enable or disable Bluetooth devices sharing.</td>
</tr>
<tr>
<td>Share smart card readers with Windows</td>
<td>When this option is selected, you can use your Mac's smart card readers in Windows. Please note that you will be able to use only those smart card readers that function properly in macOS (i.e. have the necessary drivers installed). If your smart card reader works in macOS but for some reason doesn't appear in Windows, please try to connect it using the Devices &gt; USB &amp; Bluetooth menu as described here (p. 73).</td>
</tr>
</tbody>
</table>
Parallels Desktop Preferences and Virtual Machine Settings

| Allow external devices (available in Parallels Desktop for Mac Business Edition only) | Use this list to specify what devices can be connected to the virtual machine via USB. |
| Enable USB 3.0 | Use this option to enable or disable USB 3.0 support. |

Hard Disk Settings

In the Hard Disk pane, you can view and configure the virtual machine hard disk-related settings.

To open these settings, choose Actions > Configure > Hardware, then click Hard Disk.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Use this field to specify the virtual hard disk file (.hdd) that emulates the virtual machine hard disk:</td>
</tr>
<tr>
<td></td>
<td>• To use the Boot Camp partition as the virtual machine hard disk, select the Boot Camp partition name from the list.</td>
</tr>
<tr>
<td></td>
<td>• To use a virtual hard disk file as the virtual machine hard disk, choose the virtual hard disk file from the list, or click Choose an image file and specify the path to the desired image file (.hdd).</td>
</tr>
</tbody>
</table>
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Properties</th>
<th>Click this button to edit the hard disk properties:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Size. Use this field or slider to change the disk size.</td>
</tr>
<tr>
<td></td>
<td>• Expanding disk. Deselect this option to convert the disk format from <em>expanding to plain</em>.</td>
</tr>
<tr>
<td></td>
<td>• Split the disk image into 2 GB files. Select this option if you want the virtual hard disk to be split.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Location</th>
<th>Use this field to specify the type of interface for connecting the hard disk. This option is for advanced users only.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable TRIM</td>
<td>In most cases, the space that the virtual machine takes up on your hard disk expands as you add files and other data, but isn’t reduced when you delete data. To set Parallels Desktop to automatically reduce disk space, select Enable TRIM. This option may affect performance on HDD (not SSD) disks.</td>
</tr>
</tbody>
</table>

**CD/DVD Settings**

In the CD/DVD pane, you can view and configure the virtual machine CD/DVD-ROM settings.

To open these settings, choose Actions > Configure > Hardware, then click CD/DVD.
## Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source</strong></td>
<td>Use this field to specify the source device or image file that emulates the virtual machine CD/DVD drive:</td>
</tr>
<tr>
<td></td>
<td>• To use a physical CD/DVD drive as the virtual machine CD/DVD drive, select the physical device name from the list.</td>
</tr>
<tr>
<td></td>
<td>• To use an image file as the virtual machine CD/DVD drive, choose the image file from the list, or click Choose an image file and specify the path to the desired image file.</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td>Use this field to specify the type of interface for connecting the device. This option is for advanced users only.</td>
</tr>
</tbody>
</table>

## Boot Order Settings

In the Boot Order pane, you can view and configure the virtual machine boot sequence, that is, the order in which the virtual machine will try to load the operating system from different boot devices.

To open these settings, choose Actions > Configure > Hardware, then click Boot Order.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Boot order             | Use this list to edit the boot order settings. The currently supported boot devices are listed below:  
  - Hard Disk. Select this device if you want the virtual machine to boot up from its virtual hard disk drive.  
  - CD/DVD-ROM. Select this device if you want the virtual machine to boot up from the media connected to its virtual CD/DVD-ROM drive.  
  
  **Note:** The virtual machine will use the CD/DVD-ROM drive specified as CD/DVD-ROM in its configuration.  
  
  - External device. Select this device if you want the virtual machine to boot up from a bootable external device (USB, FireWire, Thunderbolt, etc.) connected to your Mac. Once selected, choose the device from the External boot device menu located below.  
  
  - Floppy Disk. Select this device if you want the virtual machine to boot up from a floppy disk image connected to its virtual floppy disk drive.  
  
  - Network. Select this device if you want your virtual machine to boot from a network adapter using PXE (Pre-Execution Environment).  
  
  **Note:** The virtual machine will use the network adapter specified as Network in its configuration.  
  
  Every time you start the virtual machine, it tries to boot from the device specified as the first one in the Boot order list. If the virtual machine cannot boot from the first device (for example, no media is connected to it), the virtual machine proceeds to the second device in the list and tries to boot from this device, and so on.  
  
  In this list, you can perform the following operations:  
  
  - Change the currently set boot sequence by selecting the name of the corresponding boot device and moving it up or down using the arrows to the right of the list.  
  
  - Remove a boot device from the sequence by clearing the check box next to its name.  
| External boot device    | If you chose External device from the Boot order menu, use this menu to select the external boot device.                                                                                                                                                                                                                                                             |
### Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Select boot device on startup</th>
<th>If you choose this option, you will see the following message at the virtual machine startup: &quot;Press ESC to select boot device&quot;. If you press ESC pending 5 seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will try to boot from the devices specified in the Boot order list. <strong>Note:</strong> Make sure that the device you wish to use for your virtual machine booting (hard disk drive, CD-ROM drive, floppy disk drive, or network adapter) is available to the virtual machine and configured properly. If you do not have any boot devices configured in your virtual machine, you will see the following error message after you start the virtual machine: &quot;No boot device is available&quot;. In this case, you should stop the virtual machine and configure at least one boot device for it.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boot flags</td>
<td>The Boot flags field is intended for specifying the flags that can change the virtual machine system behavior. The system flags can be used by the Parallels customer support team in cases when something goes wrong in your virtual machine. It is not recommended to type anything into this field without being instructed to do so by the customer support staff.</td>
</tr>
</tbody>
</table>

### Printer Settings

In the Printer pane, you can view and configure the virtual machine printer port settings.

To open these settings, choose Actions > Configure > Hardware, then click Printer.
### Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Source   | In the Source field, specify the source device that emulates this printer port:  
  - Printers. You can use any of the printers connected to your Mac in your virtual machine. Select the appropriate printer from the list.  
  - Output File. You can emulate the virtual machine printer port by using an output file. Choose an output file from the list or click Choose an output file and specify the path to the desired output file. |
| Port     | In the Port field, choose the port type. If available, you’re recommended to use the USB port type. Connecting a printer to a virtual machine via USB ensures faster data transfer rate than connecting it via LPT. |

### Floppy Disk Settings

In the Floppy Disk pane, you can view and configure the virtual machine floppy disk drive settings.

To open these settings, choose Actions > Configure > Hardware, then click Floppy Disk.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>In the Source field, specify the source device or image file that will emulate the virtual machine floppy disk drive:</td>
</tr>
<tr>
<td></td>
<td>• If you want to use a physical floppy disk drive, click the Source field and select the physical device name from the list.</td>
</tr>
<tr>
<td></td>
<td>• If you want to use a floppy disk image, click the Source field, click Choose an image file, and specify the path to the desired floppy</td>
</tr>
<tr>
<td></td>
<td>disk image file.</td>
</tr>
</tbody>
</table>

Serial Port Settings

In the Serial Port pane, you can view and configure the virtual machine serial port settings.

To open these settings, choose Actions > Configure > Hardware, then click Serial Port.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Source   | In the Source field, select the source device that emulates this serial port:  
  - Physical Serial Port. To connect the virtual machine serial port to one of the existing serial ports on your Mac, choose the appropriate port.  
  - Socket. To connect two virtual machines through the sockets, choose the appropriate socket. If there are no sockets available, click New socket and specify its name in the Enter a socket name field. You should also configure the role the virtual machine will play in the connection by selecting the necessary role in the Mode list. Selecting Server enables you to use this virtual machine to direct the other one. Selecting Client enables you to direct this virtual machine from the other one.  
  - Output File. To connect the virtual machine serial port to an output file, choose the appropriate output file or click Choose an output file to locate the necessary file. |

Security Settings

On the Security tab of virtual machine configuration, you can isolate the virtual machine from Mac, choose whether to save or discard the changes you made while working with the virtual machine, set password requirements for certain tasks, and more.
## Parallels Desktop Preferences and Virtual Machine Settings

To open these settings, choose Actions > Configure, then click Security.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encrypt with password</td>
<td>Use this setting to specify, change or turn off the password your virtual machine is encrypted with.</td>
</tr>
<tr>
<td>Expiration date (available in Parallels Desktop for Mac Business Edition only)</td>
<td>If your virtual machine is encrypted, you can set an expiration date after which the virtual machine becomes expired.</td>
</tr>
<tr>
<td>Allow changing guest OS password in Terminal (available in Parallels Desktop for Mac Business Edition only)</td>
<td>Select this option to be able to change the guest OS password in Terminal.</td>
</tr>
<tr>
<td>Always lock Windows on suspend (available in Parallels Desktop for Mac Business Edition only)</td>
<td>Select this option if you want to lock Windows on suspend. Once the virtual machine is resumed, you’ll have to log in to Windows to unlock it.</td>
</tr>
<tr>
<td>Isolate Windows from Mac</td>
<td>Select this option to isolate the virtual machine from macOS, so that they no longer share folders, profiles, and applications, connected external devices are no longer automatically accessible by the guest OS, the virtual machine and Mac no longer synchronize volume, and you can no longer copy or move objects between the virtual machine and macOS. Isolating your virtual machine from macOS may provide a higher level of security by not allowing compromised items from one OS to come into contact with the other.</td>
</tr>
</tbody>
</table>
Rollback mode (available in Parallels Desktop for Mac Pro and Business Editions only)

Use this menu to specify whether the virtual machine is started in Rollback mode. This mode allows you to save or discard the changes you made while working with the virtual machine:

- **Disable.** Select this option if you don’t want to work with the virtual machine in Rollback mode.
- **Discard changes.** Select this one if you don’t want to save the changes.
- **Ask me what to do.** Select this option if you want to decide whether to save the changes. When shutting down the virtual machine, you will be shown a message asking whether to save or discard the changes.

Require password to

For added security, you can select the actions for which Parallels Desktop will require an administrator password.

Custom password (available in Parallels Desktop for Mac Pro and Business Editions only)

Use this setting to provide a custom password that will be required to perform the actions from the Require password to section.

### Backup Settings

On the Backup tab of virtual machine configuration, you can automate saving the virtual machine snapshots and choose whether the virtual machine is backed up with Time Machine.

To open these settings, choose Actions > Configure, then click Backup.
Parallels Desktop Preferences and Virtual Machine Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SmartGuard</td>
<td>If you want to create virtual machine snapshots automatically, select</td>
</tr>
<tr>
<td></td>
<td>SmartGuard &gt; Details and specify how often snapshots are made, how many</td>
</tr>
<tr>
<td></td>
<td>snapshots are stored, and whether you want to be notified before a new</td>
</tr>
<tr>
<td></td>
<td>snapshot is created.</td>
</tr>
<tr>
<td>Do not back up with Time Machine</td>
<td>By default, Time Machine automatically backs up your virtual machine</td>
</tr>
<tr>
<td></td>
<td>together with macOS files. Select this option if you back up your virtual</td>
</tr>
<tr>
<td></td>
<td>machine some other way and want to exclude it from Time Machine backups.</td>
</tr>
<tr>
<td>Install Acronis True Image...</td>
<td>Use this option to install Acronis True Image and back up both your Mac and</td>
</tr>
<tr>
<td></td>
<td>virtual machines.</td>
</tr>
</tbody>
</table>

Adding and Removing Devices

Adding new devices to a virtual machine is easier than connecting new devices to a real computer. Removing or disconnecting devices is also easy. The following virtual devices can be added to the configuration or removed from it:

- virtual hard disk drive
- CD/DVD drive
- floppy disk drive
- network adapter
- serial port
- printer port
- sound device
- USB controller

Any of the aforementioned devices can be added to the corresponding virtual machine only when it is stopped.

**Note:** To be able to connect any virtual device to a real one, you should have system privileges to access the real device. Otherwise, the real device will not appear in the list of available devices even though it is installed on your computer.

Adding a New Device to a Virtual Machine

1. Choose Configure from the Actions menu to open Virtual Machine Configuration.
2. Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the pane for editing hardware devices.
3. Click the Add button and select the device to be added to your virtual machine.
Note: The Add button is disabled when the virtual machine is running. You need to stop the virtual machine before you can use this button.

If you selected any device except for a hard disk, the corresponding device with a typical configuration is added at once and ready for use.

If you selected a hard disk, you should specify some parameters:

- The hard disk type: a new image file or an existing one. Select Boot Camp if you want to add an existing Boot Camp partition as a hard disk to your virtual machine.
- The hard disk location. Provide the path on your Mac to the existing image file or the path and name for the new image file. By default, Parallels Desktop offers to save the new image file in the virtual machine PVM bundle.
- The hard disk size for the new hard disk image file.
Parallels Desktop Preferences and Virtual Machine Settings

- For the new hard disk image file, you can choose one of the following formats: *Expanding* or *Plain*. By default, the hard disk will have the *Expanding* format. To create a *Plain* hard disk, clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split the disk image to 2 GB files option. For more information on hard disk formats, refer to Support for Virtual and Real Disks (p. 214).

![Image of new image file dialog]

Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it. For detailed information on how to initialize the newly added hard disk, see Initializing the Newly Added Disk (p. 216).

After the new device is added, you can manage its properties as usual and start using it.

Removing Devices From the Virtual Machine Configuration

1. Choose Configure from the Actions menu to open Virtual Machine Configuration.
2. Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the pane for editing hardware devices.
3. Select the device you want to remove and click the Remove button in the bottom part of the Virtual Machine Configuration dialog.

Support for Virtual and Real Disks

This section lists the types of disks that can be used by Parallels virtual machines and provides the information about basic operations you can perform on these disks.
Supported Types of Hard Disks

Parallels virtual machines can use either virtual hard disks or Boot Camp partitions as their hard disks.

Virtual Hard Disks

The capacity of a virtual hard disk can be set from 100 MB to 2 TB.

Virtual hard disks can be of either plain or expanding format.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plain</td>
<td>A plain virtual hard disk image file has a fixed size. The size is determined when the disk is created.</td>
</tr>
<tr>
<td>expanding</td>
<td>An expanding virtual hard disk image file is small initially. Its size grows as you add applications and data to the virtual hard disk in the guest OS.</td>
</tr>
</tbody>
</table>

When you create a virtual machine, the disk is created in the expanding format. You can change the disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain hard disk to your virtual machine, clear the Expanding disk option when adding a hard disk to the virtual machine (p. 212).

Split disks

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB pieces and is stored as a single .hdd file.

**Note:** In most cases, you don't need this type of disks. They are needed only for virtual machines residing on FAT32 drives.

Boot Camp Partitions

With Parallels Desktop, you can choose how to use your Boot Camp Windows XP (or later) operating system: to boot in it natively (via Boot Camp) or in a virtual machine (via Parallels Desktop). A Boot Camp Windows partition can be used as a bootable disk or as a data disk in Parallels virtual machines. For detailed information, see Using the Boot Camp Partition in a Virtual Machine (p. 27).

**Note:** You cannot create snapshots or use the Undo Disks option for a virtual machine that uses the Boot Camp partition.

CD/DVD Discs and Their Images

Parallels Desktop can access real CD/DVD discs and images of CD/DVD discs.

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can play back audio CDs without any limitations on copy-protected discs.
If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a virtual machine.

Parallels Desktop supports CD/DVD disc images in the ISO, CUE, and CCD formats.

**Note:** DMG disk images made with macOS Disk Utility are also supported by Parallels Desktop. When creating such an image, make sure you create a read-only and uncompressed image without any encryption.

Floppy Disks and Floppy Disk Images

Parallels Desktop can use two types of floppy disks:

- Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine.
- Floppy disk image files having the `.fdd` extension and connected to the virtual machine.

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy disk image files that have the `.fdd` extension and 1.44 MB size.

**Initialize a Newly Added Disk**

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it.

**Initializing the New Virtual Hard Disk in Windows**

To initialize a new virtual hard disk in a Windows guest OS, you will need the Disk Management utility available. For example, in Windows 7 and Windows XP you can access this utility by doing the following:

- In Windows 7, click Start > Control Panel > System and Security > Administrative Tools > Computer Management Storage > Disk Management.
- In Windows XP, click Start > Control Panel > Administrative Tools > Computer Management > Storage > Disk Management.

When you open the Disk Management utility, it automatically detects that a new hard disk was added to the configuration and launches the Initialize and Convert Disk wizard:

1. In the introduction window, click Next.
2. In the Select Disks to Initialize window, select the newly added disk and click Next.
3. In the Select Disks to Convert window, select the newly added disk and click Finish.
The added disk will appear as a new disk in the Disk Management utility window, but its memory space will be unallocated. To allocate the disk memory, right-click this disk name in the Disk Management utility window and select New Simple Volume in Windows Vista or New Volume in Windows XP. The New Simple Volume Wizard/New Volume Wizard window will appear. Follow the steps of the wizard and create a new volume in the newly added disk.

After that your disk will become visible in Computer/My Computer and you will be able to use it as a data disk inside your virtual machine.

Initializing the New Virtual Hard Disk in Linux

Initializing a new virtual hard disk in a Linux guest OS comprises two steps: (1) allocating the virtual hard disk space and (2) mounting this disk in the guest OS.

To allocate the space, you need to create a new partition on this virtual hard disk using the \texttt{fdisk} utility:

\begin{quote}
\textbf{Note:} To use the \texttt{fdisk} utility, you need the root privileges.
\end{quote}

1. Launch a terminal window.
2. To list the IDE disk devices present in your virtual machine configuration, enter:
   \texttt{fdisk /dev/hd*}
   \begin{quote}
   \textbf{Note:} If you added a SCSI disk to the virtual machine configuration, use the \texttt{fdisk /dev/sd*} command instead.
   \end{quote}
3. By default, the second virtual hard disk appears as \texttt{/dev/hdc} in your Linux virtual machine. To work with this device, enter:
   \texttt{fdisk /dev/hdc}
   \begin{quote}
   \textbf{Note:} If this is a SCSI disk, use the \texttt{fdisk /dev/sdc} command instead.
   \end{quote}
4. To get detailed information about the disk, enter:
   \texttt{p}
5. To create a new partition, enter:
   \texttt{n}
6. To create the primary partition, enter:
   \texttt{p}
7. Specify the partition number. By default, it is 1.
8. Specify the first cylinder. If you want to create a single partition on this hard disk, use the default value.
9. Specify the last cylinder. If you want to create a single partition on this hard disk, use the default value.
10. To create a partition with the specified settings, enter:
    \texttt{w}

When you allocated the space on the newly added virtual hard disk, you should format it by entering the following command in the terminal:
Parallels Desktop Preferences and Virtual Machine Settings

```
mkfs -t <FileSystem> /dev/hdc1
```

**Note:** `<FileSystem>` stands for the file system you want to use on this disk. It is recommended to use `ext3` or `ext2`.

When the added virtual hard disk is formatted, you can mount it in the guest OS.

1. To create a mount point for the new virtual hard disk, enter:
   ```
   mkdir /mnt/hdc1
   
   **Note:** You can specify a different mount point.
   ```

2. To mount the new virtual hard disk to the specified mount point, enter:
   ```
   mount /dev/hdc1 /mnt/hdc1
   ```

When you mounted the virtual hard disk, you can use its space in your virtual machine.
Chapter 7

Tips and Troubleshooting

If you're having trouble using Parallels Desktop, check this section for possible solutions.

In This Chapter

Install Parallels Tools for Seamless Operation Between Windows and macOS ..... 219
Find Settings ......................................................................................................... 220
Restore Virtual Machine Default Settings .............................................................. 220
Memory Usage Problems ...................................................................................... 221
Windows Seems Slow ........................................................................................... 221
Pressing Ctrl+Alt+Del ............................................................................................ 222
My Password Isn't Working ................................................................................... 222
Boot Windows Securely.......................................................................................... 223
My Virtual Machine Doesn't Boot............................................................................ 223
I'm Having Problems Connecting to the Internet.................................................... 223
I'm Having Problems with Antivirus Software ......................................................... 224
The F8 Key Isn't Working Correctly ....................................................................... 224
A Password is Required to Open the Virtual Machine Configuration ...................... 224
Windows or Windows Applications Ask for Reactivation ........................................ 224
Manage Virtual Machines via Command Line Interface ......................................... 225
Change Password in Windows via Command Line Interface .................................. 226
Checking the Build Number ................................................................................... 226
Send Technical Data to Parallels............................................................................ 226

Install Parallels Tools for Seamless Operation Between Windows and macOS

Many issues with using Parallels Desktop can be solved by installing Parallels Tools.

Parallels Tools help you work with Windows in the most comfortable and efficient way. With Parallels Tools, you can:

• Move the mouse seamlessly between Windows and macOS
• Synchronize the Windows time and date settings with those of macOS
• Share your macOS disks and folders with Windows
• Copy text and drag and drop files from macOS to Windows and vice versa
Important: Once you install Parallels Tools and restart Windows, you don't have to do anything else. Parallels Tools automatically just work, without any action or configuration on your part.

To install Parallels Tools:

1. Start Windows (p. 30).
2. Choose Actions > Install Parallels Tools and follow the onscreen instructions.

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p. 130).

Find Settings

If you want to change a setting in Parallels Desktop but you aren't sure where to find the setting, you can search for it by doing the following:

1. Do one of the following:
   - Click the Parallels icon \( \text{\textbullet} \) in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Type a word or phrase in the search field. Any settings related to your search are highlighted.

   For example, if you want to find out whether you can change settings related to the Dock, type "dock" in the search field and options that make Dock icons bounce to alert and allow you to access Windows apps from the Dock are highlighted.

Restore Virtual Machine Default Settings

When working with a virtual machine, you can change different virtual machine settings, such as an amount of memory, video memory, number of CPUs, sharing settings, etc. To restore default settings:

1. Do one of the following (the virtual machine must be shut down):
   - In Control Center, right-click the virtual machine you want to configure and click Configure.
   - If the virtual machine window is open, click Actions > Configure.

2. In the virtual machine configuration dialog, find the pane with the settings that you want to restore and click Restore Defaults.

Note: You cannot undo this action.
Memory Usage Problems

The amount of Mac's physical memory required for each virtual machine operation can be represented as follows:

Virtual Machine Memory = Guest OS Memory + Video Memory

- **Guest OS Memory** is the amount of RAM available to your guest operating system. You can configure the guest OS memory amount in the CPU & Memory pane of the virtual machine configuration dialog.
- **Video Memory** is the amount of physical memory available to the virtual machine's video card. You can adjust the video memory amount in the Graphics pane of the virtual machine configuration dialog.

**Note:** We recommend that you use the default values for memory.

Memory Overcommitment

If you have several virtual machines running simultaneously and you are trying to start one more virtual machine, you may come across the memory over commit. If so, Parallels Desktop informs you with the corresponding message. If you start one more virtual machine, this may significantly slow down all your virtual machines. To solve this problem, you can:

- Stop one or several of your running virtual machines; or
- Edit your virtual machines' configurations so they consume less memory.

Windows Seems Slow

If Windows performance seems slow, try the following:

- Quit applications and applications you aren't using: If you run a number of memory-consuming applications and applications simultaneously, Windows performance may become slow. Quit any applications that you aren't using. You can also use Activity Monitor (located in the macOS Finder in Applications > Utilities) to see how much of your Mac's memory each application is using. That way, you'll have a better idea of which applications cause performance to degrade the most.
- Change how much memory is allocated to Windows: Parallels Desktop is set to allocate a certain amount of your Mac's available RAM memory to Windows and the rest to macOS. If too much memory is allocated to Windows, macOS may slow down, which in turn can cause Windows applications to slow down because they're running on top of macOS. If, on the other hand, too much memory is allocated to macOS, then macOS applications may run well but Windows applications might slow down. Use the Restore Defaults button.
To optimize the performance of both Windows and macOS, set the memory allocated to Windows (p. 93) to be somewhere within the recommended range, indicated by the graphic under the memory slider in the CPU & Memory configuration panel. Use the Restore Defaults button.

- Antivirus software may slow down your virtual machine: Windows may become slower after you install antivirus software. To be protected, you have to sacrifice performance.

  **Note:** Do not install more than one Windows antivirus application.

- Run fewer virtual machines at once: If you are running multiple operating systems at once using Parallels Desktop, stop one or more of them to improve performance of the others.

- Run Windows locally: If you start Windows stored on an external storage device connected to your Mac (for example, an external USB disk drive), its performance will be lower than if it were stored on your Mac.

- Disable log messages: If you select Use detailed log messages in the Advanced pane (p. 144) of Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

### Pressing Ctrl+Alt+Del

As a Windows user, you might know that you can press the Ctrl+Alt+Del key combination to make available troubleshooting options, such as starting the Task Manager or changing a password.

To mimic pressing Ctrl+Alt+Del in Parallels Desktop:

- Press fn+Ctrl+Option+Del.

### My Password Isn't Working

If Parallels Desktop doesn't accept your password, try the following:

- Be sure that Caps Lock is not on. If Caps Lock is on, an indicator appears in the password field. To turn Caps Lock off, press the Caps Lock key.

- Be sure that the keyboard is set to the correct language. If the keyboard is set to a language that doesn't belong to the group of Romance languages, an icon in the password field indicates the keyboard language setting.
Tips and Troubleshooting

Boot Windows Securely

Pirated versions of Windows may have backdoors through which hackers have full access to the system and data. If you're going to install Windows 8 or later on your Mac, you can configure Windows to check the boot loader on startup. This helps to prevent the execution of unsigned and potentially dangerous code.

To configure Windows to boot securely, do the following:

1. Select Customize settings before installation during the Windows installation.
2. In the virtual machine configuration dialog, select the Hardware tab and click Boot Order.
3. Select EFI Secure Boot in the Advanced Settings section.

If a user tries to start a virtual machine with an illegal version of Windows, Secure Boot detects unauthorized changes to the firmware, operating system, or UEFI drivers and prevents such an operating system from starting.

My Virtual Machine Doesn't Boot

If your virtual machine doesn't boot correctly, most probably it's because there isn't any operating system installed. To install an operating system, do the following:

1. Prepare the OS installation media:
   - If you have an OS installation disk, insert it into the DVD drive of your Mac.
   - If you have a USB drive with the OS installation files, connect it to your Mac.
   - If you have a disk image, copy it to your Mac.
2. Restart the virtual machine by doing one of the following:
   - Click Actions > Restart.
   - Click the Parallels icon in the menu bar and choose Actions > Restart.
3. And follow the onscreen instructions.

I'm Having Problems Connecting to the Internet

When you install Windows, it is automatically configured to share your Mac's Internet connection. For details on configuring Windows' network and Internet connection, see the section on connecting to the Internet or a network (p. 89). You can also use the Restore Defaults button.
I'm Having Problems with Antivirus Software

Because of the close integration between Parallels Desktop and macOS, some Parallels Desktop processes may be detected as malicious by antivirus software installed on your Mac.

To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system scan using the antivirus software, and then if no viruses are detected, add the Parallels Desktop processes to the list of trusted processes. For information on how to do this, refer to your antivirus software Help.

Important: The names of Parallels Desktop processes usually start with prl or parallels.

The F8 Key Isn't Working Correctly

In macOS, the F3 key and Ctrl+arrow key combination are reserved for triggering Spaces (a feature that lets you organize your windows on multiple desktops). Because of this, the F3 key and Ctrl+arrow key may not function correctly with Windows applications.

If you are experiencing this problem, change the Spaces hotkeys settings. See Mac Help for more information. From the Finder, choose Help > Mac Help or Help > Help Center and search for "Spaces."

A Password is Required to Open the Virtual Machine Configuration

In Parallels Desktop activated with the volume license product key, virtual machine configuration can be password protected from being viewed and edited.

So if you're requested to enter the password to open the virtual machine configuration and you don't know it, contact the person who gave you this virtual machine (in most cases, it's your system administrator).

Windows or Windows Applications Ask for Reactivation

When you first install Windows on a PC, Boot Camp partition, or virtual machine, you must activate Windows to use it. You can activate Windows over the Internet or by phone.
Once activated, every time you start Windows it checks whether it is running on the same hardware on which it was originally installed. When you import Windows to Parallels Desktop from a PC or create a Boot Camp virtual machine, Windows detects that the virtual hardware is different and may require reactivation, depending on the version of Windows you’re using and Microsoft’s licensing policy.

Windows or Microsoft Office asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine and Windows or Microsoft Office asks for reactivation, try to reactivate it over the Internet or by phone with Microsoft Support.

**Note:** For the detailed information on how you can reactivate Windows or Microsoft Office, please refer to the Windows/Microsoft Office help resources.

If Windows or Microsoft Office has reached the activation limit, you won’t be able to use it in a virtual machine. In this case, you can do one of the following:

- If Windows cannot be reactivated in a Boot Camp virtual machine, work with Windows by booting your Mac directly into Windows.
- Buy a new activation key to activate Windows in a virtual machine.

Third-party application asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine, some third-party applications that are tied to the hardware on which they were originally installed may ask for reactivation. In this case, you can do one of the following:

- If you choose to work with an application in a virtual machine, contact the application vendor for help. The vendor may give you another activation key or offer to deactivate the application on the PC or Boot Camp and activate it in the virtual machine.

**Important:** If the vendor gives you or you decide to purchase a new activation key, please note that reactivating an application with a new key in a virtual machine may break its activation on the Boot Camp. It means that if you later decide to work with the application by booting your Mac directly into Windows, it will require reactivation.

- If an application asks for reactivation in a Boot Camp virtual machine, work with the application by booting your Mac directly into Windows.

Manage Virtual Machines via Command Line Interface

In Parallels Desktop for Mac Pro Edition, you can create and manage your virtual machines via the command line interface. To learn more about the commands and options, please refer to the *Parallels Desktop Pro Edition Command-Line Reference* guide available online.
Change Password in Windows via Command Line Interface

To change your Windows account password via CLI, do the following:

**Note:** You can do this in Parallels Desktop for Mac Pro Edition only.

1. Start Windows (p. 30).

2. Launch Terminal in macOS (Applications > Utilities > Terminal) and find out Windows UUID (Universally Unique Identifier) by executing the following command:

   ```bash
   prlctl list --all
   ```

   The output may be as follows:

<table>
<thead>
<tr>
<th>UUID</th>
<th>STATUS</th>
<th>IP_ADDR</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>{6f05fe58-2ef6-4049-847a-c393f1077658}</td>
<td>running</td>
<td>-</td>
<td>Windows 7</td>
</tr>
</tbody>
</table>

   6f05fe58-2ef6-4049-847a-c393f1077658 is the Windows UUID.

3. Change your Windows account password by executing the following command:

   ```bash
   prlctl set <Windows UUID> --userpasswd <account_name>:<new_password>
   ```

   This command may look as follows:

   ```bash
   prlctl set 6f05fe58-2ef6-4049-847a-c393f1077658 --userpasswd Appleseed:qwerty
   ```

   If you see the following output, the password has been changed successfully:

   `authentication tokens updated successfully.`

Checking the Build Number

To check the version and build number of the Parallels Desktop software you are using, do one of the following:

- Click the Parallels icon in the menu bar and choose About Parallels Desktop.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > About Parallels Desktop.

A window appears showing the build number.

**Note:** The window that appears also provides you with other useful information about your copy of Parallels Desktop, including the licensing information and a link to the Parallels support web page.

Send Technical Data to Parallels

To help improve the quality of Parallels Desktop, you can send technical data to Parallels.
If Windows is forced to shut down because of an error, Parallels Desktop automatically opens a Send Technical Data form. If you notice unusual behavior in Parallels Desktop, you can also send technical data manually.

To send technical data:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Help > Send Technical Data.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Help > Send Technical Data.

2. Describe what you were doing when the problem occurred, and fill out the form.

   **Note:** You can review the problem report components that will be sent to the Parallels support team and deselect some of them in the Parallels Problem Report Details window, if desired. To open this window, click See Details.

3. Click Send Report.

Parallels team uses error reports to improve the product quality but doesn't respond to them.
More Resources

For more information and help using Parallels Desktop, see the following resources:

- Parallels support website: The Parallels support website includes product help files and a FAQ section.
- Parallels Knowledge Base: This online resource has valuable articles about using Parallels Desktop and other Parallels products.
- Online documentation: You can find PDF user guides for Parallels Desktop and Parallels Transporter online by choosing Help > Online Documentation.
- Parallels Command Line Reference Guide: This document, available on the Parallels Online documentation page, has information on using the `prlctl` command line utility to manage Parallels Desktop and its virtual machines from a terminal.
- Parallels API references and the SDK programmer’s guide: These guides for IT-professionals can be found on the Parallels Online documentation page.

Feedback

- Parallels welcomes your feedback on how to make our documentation more helpful. You can submit feedback using the Documentation Feedback form on our website (http://www.parallels.com/products/desktop/support/).

In This Chapter

Visit the Parallels Desktop Twitter and Facebook Pages.................................................228

Visit the Parallels Desktop Twitter and Facebook Pages

To keep up with the latest news and updates, you can visit the Parallels Desktop Twitter and Facebook pages. Choose Parallels Desktop > About Parallels Desktop and click Our Twitter or Facebook page.
This glossary defines terms and spells out abbreviations used in Parallels Desktop documentation. References to terms defined elsewhere in the glossary appear in italics.

Administrator. A user with administrative privileges.

Activation key. A unique set of symbols that activates the Parallels Desktop application on your Mac and lets you use the Parallels Desktop functionality to its full extent.

Active operating system. The operating system where Parallels Transporter Agent is launched.

Active volume: The volume of the physical source computer that is used as a boot volume for the active operating system.

Bootable hard disk. A disk used by the operating system to boot from, usually a disk that has an operating system installed.

Boot Volume. A hard disk partition from which the operating system boots.

Boot Camp partition. A partition on the hard disk of your Mac that can be used for installing a Windows operating system on it (for Mac host computers only).

Bridged networking. Virtual machine network connection mode that enables the virtual machine to appear as any other computer on the network, with its own IP address and network name.

Coherence. One of the view modes you can use to work with Windows. When Windows is in Coherence, its desktop is hidden and Windows applications appear on the Mac desktop next to your Mac applications, as if they were all part of a single operating system.

Configuration file. A file specifies the virtual machine’s hardware configuration, the devices it uses, and other settings. It is created automatically when you create a new virtual machine. See also PVS file.

CPU. Stands for central processing unit. It is an internal part of the computer. See also Processor.

Disks in the old format. Disks of virtual machines that were created in Parallels Desktop 2.5 and earlier.

Disks in the new format. Disks of virtual machines that were created or used in Parallels hardware virtualization products starting from version 3.0.
Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on your host computer and is small initially. Its size grows as you add applications and data to the virtual machine.

FireWire connection. A wired connection that enables a high-speed data transmission between computers.

Guest operating system (guest OS). An operating system installed inside your virtual machine.

Host computer: The computer that is used to run virtual machines. In case of Parallels Desktop for Mac, it is your Mac. In case of Parallels Desktop for Windows or Parallels Desktop for Linux, it is the Windows- or Linux-based physical computer where Parallels Desktop is installed. In the Parallels Transporter documentation, this term may define the computer that hosts the result of migration.

Hot key. A user-defined key or combination of keys that provides quick access to applications and commands. See also Shortcut.

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd extension. See also virtual hard disk file.

Host-only networking. Virtual machine network connection mode that creates a private network between the host computer and its virtual machines, which makes the virtual machines available from the host computer only.

ISO image. A special file that contains the entire contents of a CD or DVD disc commonly used to install an operating system.

Image file. A single file containing the complete contents and structure of a data storage medium or device, such as a hard disk drive, CD, or DVD.

IP address. A unique address that is assigned to a physical computer or a virtual machine that participates in computer networking.

Linux computer. A physical computer that has a Linux operating system installed.

Merged disk. A split disk whose parts were merged into a single disk.

Migration. The process of transferring data from a physical computer or a third-party virtual machine into a Parallels virtual machine or virtual disk.

OS. Operating system.

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual machines on your Mac.

Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the primary and the guest operating systems.
Parallels Transporter. An application that uses data of a physical or virtual computer for creating a Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be used with Parallels Desktop.

Parallels Transporter Agent. An application that collects data on a physical computer and transfers it to Parallels Transporter installed on your Mac.

Picture in Picture. One of the view modes you can use to work with Windows. In Picture in Picture mode, the Windows desktop appears in a window and scales in size as you resize the window. Also, you can set this window to always stay on top of other windows, and you can adjust its transparency level so you can see through it when you're working with other applications.

Plain format. A virtual hard disk format. A plain virtual hard disk image file resides on the host computer and has a fixed size that cannot be changed.

Preboot Execution Environment (PXE). An environment to boot computers using a network interface independently of available data storage devices (like hard disks) or installed operating systems.

Primary operating system (primary OS). Operating system that controls the I/O devices of the computer and that is loaded when the physical computer is turned on. It is the operating system of the physical computer where the Parallels Desktop application is installed.

Processor. The central processing unit, or CPU. It is an internal part of the computer.

PVS file. A virtual machine configuration file that contains information about the virtual machine resources, devices and other settings.

Shared networking. Virtual machine network connection mode that allows the virtual machine to use the host computer network connections. In this mode, the virtual machine is invisible to other computers on the network the host computer belongs to.

Shortcut. A user-defined key or combination of keys that provides quick access to applications and commands. See also Hot key.

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to snapshots are stored in a special subfolder in the virtual machine's folder.

Source computer. The computer from which you are going to migrate data using Parallels Transporter.

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow you to transfer the data stored on a split disk piece by piece using a USB drive or other media that have limited space and cannot store a large virtual hard disk image file.

Terminal. In macOS and GNU/Linux operating systems, a utility that enables you to access the command line.
Third-party virtual machine. A virtual machine created in a third-party virtualization product, that can be converted to a Parallels virtual machine with the help of Parallels Transporter.

Virtual hard disk (virtual disk). A file that emulates the virtual machine's hard disk.

Virtual Machine. The computer emulated using Parallels Desktop. A virtual machine has its own virtual hardware and requires an operating system to control its hardware. The installed operating system and its applications are isolated inside the virtual machine and share physical hardware resources of the host computer.

Virtual Machine Configuration. Like any physical computer, a virtual machine has its own configuration which is set during the creation and can be later modified. The virtual machine configuration settings are stored in a PVS file.

Virtual machine files. Files stored in a virtual machine folder. A virtual machine has at least two files: configuration file and virtual hard disk file.

Virtual hard disk file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd extension. This file performs the functions of a real hard disk. See also HDD file.

Virtual machine template. A virtual machine that can be cloned to multiple virtual machines that will have the same configuration and data that the virtual machine template had.

VM. See Virtual Machine.

Windows computer. A physical computer that has a Windows operating system installed.
Index

A
A Password is Required to Open the Virtual Machine Configuration - 226
About Virtual Machines - 107, 112
Activate and Register Parallels Desktop - 12
Add Windows Disks to the Finder - 62
Adding and Removing Devices - 20, 214, 217
Address
   IP address - 27
Adjust Devices Settings - 75, 76
Adjust Full Screen Settings - 44
Adjust Window Mode Settings - 43
Advanced Preferences - 145, 167, 224
Advanced Topics - 10, 105
Allow Windows Updates While Your Mac is Sleeping - 102
Applications Settings - 179
Apply macOS Parental Controls to Windows - 63
Apply Separate Network Settings to Windows - 81, 83, 91
Archive and Unarchive Virtual Machines - 124
Arrange Virtual Machines - 108

B
Back Up a Virtual Machine - 110
Backup Settings - 213
Bonjour Printer - 81
Boot Order Settings - 205
Boot Windows Securely - 225
Browse Virtual Hard Disks in macOS - 112

C
CD/DVD Settings - 204
Change Password in Windows via Command Line Interface - 228
Change the Virtual Machine Icon - 109
Change the Virtual Machine Name - 109
Change Virtual Machine Configuration at Runtime - 117
Check Your Virtual Machine CPU and Memory Usage - 121
Checking the Build Number - 228
Clone a Virtual Machine - 110, 111
Connect Bluetooth Devices - 78
Connect External Devices - 74, 203
Connect to the Internet or a Network - 36, 90, 225
Connect Windows to a VLAN - 94
Control Applications with Trackpad Gestures - 65
Copy and Paste Between macOS and Windows - 47
CPU & Memory Settings - 121, 192, 194
Create a Custom Host-Only Network - 150
Create a PDF File - 86
Create and Use Virtual Machine Templates - 113
Create New Keyboard Shortcuts - 70
Customize Keyboard Shortcuts - 67, 127
Customize the Keyboard for the Guest OS - 69, 125

D
Devices Preferences - 160
Download and Install Windows From Microsoft - 30
Download Pre-configured Virtual Appliances - 119, 141

E
Enable Spoken Commands - 122, 146
Encrypt Windows to Protect It from Unauthorized Use - 36, 89

F
Find Settings - 222
Firewall problems - 27
Floppy Disk Settings - 209
For Software Developers - 137
Index

Full Screen Settings - 182

G

General Preferences - 153
General Settings - 170
General Tips - 26
Generate a Core Dump - 138
Get Acronis True Image - 110, 111, 122
Get Started - 31
Glossary - 231
Graphics Settings - 194

H

Hard Disk Settings - 203
Hardware Settings - 192
Hide and Show Parallels Desktop - 144
Host-Only Networking Settings - 140, 149

I

If Parallels Doesn't Detect Windows Correctly - 28
If Your Mac Fails to Connect with Parallels Transporter Agent - 21, 27
I'm Having Problems Connecting to the Internet - 225
I'm Having Problems with Antivirus Software - 226
Import from an Earlier Parallels Desktop or Other Virtualization Application - 18, 30, 119
Import Your Data from a PC - 18, 19
Initialize a Newly Added Disk - 216, 218
Install or Import Windows - 10, 18
Install or Update Parallels Tools - 46, 47, 52, 86, 112, 120, 129, 138, 141
Install or Upgrade Parallels Desktop - 10, 11
Install Parallels Desktop - 12
Install Parallels Tools for Seamless Operation Between Windows and macOS - 41, 47, 48, 56, 57, 58, 61, 96, 119, 221
Install Software Updates - 15
Install Windows - 18, 100
Install Windows Applications - 10, 35
Installing and Upgrading Parallels Tools in Text Mode in Linux - 135
Integration With Chef/Ohai - 139
Integration With Docker - 140
Isolate Windows from Mac - 58, 88

L

Linux printers in - 79

M

Maintenance Settings - 188
Make Virtual Machines Distinctive - 108
Manage Virtual Machines via Command Line Interface - 228
Memory Usage Problems - 223
Merge Windows and macOS - 32, 40, 71, 127
Monitoring Windows in a Scalable Window - 43
More Options - 190
More Resources - 10, 230
Mouse & Keyboard Settings - 72, 196
Mouse, Trackpad, and Keyboard - 63
My Password Isn't Working - 224
My Virtual Machine Doesn't Boot - 225

N

Network Preferences - 163
Network Settings - 199

O

Open a Windows Application - 19, 32, 38
Open the Current Safari Page in Internet Explorer - 59
Optimization Settings - 89, 95, 174
Optimize Performance - 94
Optimize Remote Debugging - 137
Optimize Virtual Machine for Games, Graphics, Productivity, or Development - 97, 141
Options - 172
Other Actions - 141
Other Operating Systems - 10
Over a Network - 20, 21
Overview of Methods for Importing - 20

P

Parallels Access - 169
Parallels Desktop Preferences - 153
Parallels Desktop Preferences and Virtual Machine Settings - 152
Parallels Toolbox - 168
Parallels Tools for Mac - 128, 136
Parallels Tools for Windows - 53, 71, 103, 131, 141, 222
Parallels Tools Overview - 129, 136
Pause Windows When No Applications Are Open - 39, 97
Picture in Picture Mode - 43, 142
Picture in Picture Settings - 184
Pressing Ctrl+Alt+Del - 224
Print from Windows - 79
Printer
setting up a Bonjour printer - 81
Printer Settings - 208
Problems Using a Application After an Import - 28
Protect Your Data - 88
Purchase Parallels Desktop - 14
Q
Quickly Change the Screen Resolution - 141
Quickly Free Up Disk Space - 124
R
Remove a Virtual Machine - 119
Remove Parallels Desktop - 145
Requirements for Importing Your Data - 20
Resolve Guest OS DNS Requests Using etc/hosts - 140
Restore Virtual Machine Default Settings - 222
S
Save a Picture of the Screen - 101
Save Internet Passwords in Mac Keychain - 61
Save Snapshots of a Virtual Machine - 28, 89, 111, 115
Save Time With Parallels Toolbox - 101
Schedule Windows Maintenance - 99
Security Preferences - 162
Security Settings - 212
See and Change Windows Input Language In macOS - 71
Send Technical Data to Parallels - 229
Serial Port Settings - 210
Set an Application to Open When You Insert a CD or DVD - 47
Set File Type Associations - 141
Set Files to Open in the Application or Application of Your Choice - 57
Set How Many Processors are Allocated to a Virtual Machine - 121
Set How Much Memory is Allocated to Windows - 94, 121, 224
Set How Windows Works with macOS - 39
Set Internet Links to Always Open in macOS or Windows - 58
Set Password Requirements - 89
Set the Appearance of Virtual Machine Dock Icons - 102
Set the Guest OS Type and Version - 120
Set the Language - 16
Set Up a Network Printer - 82
Set Up a Printer Using Bonjour - 81
Set Up a USB Printer - 85
Set Up Your Mac to Use Windows Applications - 10
Set Where New Virtual Machines Are Stored - 108
Set Windows to Appear in a Single Window - 39, 42, 55, 72, 74
Set Windows to Take Up the Whole Screen - 43, 55, 89
Set Your Mouse or Trackpad to Right-Click and Middle-Click - 64
Setting up a printer - 79, 81
Share a Printer Connected to Your Mac - 79, 85, 86
Share Applications - 35, 47, 54, 58
Share External Storage Devices and Volumes - 60
Share Files and Folders - 48, 51, 55, 112, 138
Share iCloud, Dropbox, or Google Drive Folders with Windows - 52
Share Items Between macOS and Windows - 47
Share Network Access Between macOS and Windows - 83, 91, 92, 94, 148
Share Windows External and Network Drives with Mac - 60
Share Windows OneDrive Folders with macOS - 53
Shared Networking Settings - 138, 140, 147
Shared Printers Settings - 197
Sharing Settings - 174
Shortcuts Preferences - 155
Show a Presentation on an External Monitor or Projector - 87
Shut Down or Suspend Windows - 36, 89, 95, 96, 121
Solving Problems - 26
Sound Settings - 200
Speed Up Games and Graphics Applications - 96
Start a Debugging Session - 139
Start Windows - 24, 26, 30, 31, 35, 48, 50, 52, 60, 78, 87, 131, 132, 137, 222, 228
Startup and Shutdown Settings - 37, 172
Step 1
  Install Parallels Transporter Agent on Your Windows PC - 20
Step 2
  Import Your Data - 21
Support for Virtual and Real Disks - 19, 216
Supported Guest Operating Systems - 10, 12, 105

T
The F8 Key Isn't Working Correctly - 226
Tips and Troubleshooting - 221
Translate Words in Windows - 103
Travel Mode Settings - 189

U
Upgrade Parallels Desktop - 14
USB & Bluetooth Settings - 202
Use a Disk Image with the Virtual DVD Drive - 61
Use AppleScript with the Guest OS - 123
Use Boot Camp with Parallels Desktop - 18, 28, 217
Use Host-Only Network Settings - 93, 150
Use Keyboard Shortcuts - 67
Use Linux in Coherence Mode - 125
Use macOS as a Guest OS - 127
Use macOS in Coherence Mode - 128
Use Mouse Wheel Horizontal Scrolling - 119
Use Other Operating Systems on Your Mac - 124
Use the Built-in iSight Camera or Another Webcam - 86
Use the Touch Bar with Windows - 103
Use Virtual Machine Names as DNS Names - 140
Use Wi-Fi with Windows - 93
Use Windows on Your iPad, iPhone, or Android Device - 100
Use Windows on Your Mac - 31

Using an External Storage Device - 20, 24
Virtual Machine Settings - 170
Visit the Parallels Desktop Twitter and Facebook Pages - 230

W
Web & Email Settings - 185
Welcome to Parallels Desktop - 9
What You Can Do - 9
What You Need - 11
Windows or Windows Applications Ask for Reactivation - 226
Windows Seems Slow - 223
Work in Windows Without Saving Changes - 28, 88, 115
Work with Virtual Machines - 105
Work with Windows in Travel Mode - 98