Contents

Welcome to Parallels Desktop ................................................................. 9
  What You Can Do .................................................................................. 10
  Set Up Your Mac to Use Windows Programs ........................................... 10
  Other Operating Systems ........................................................................ 10

Install or Upgrade Parallels Desktop ....................................................... 12
  What You Need ..................................................................................... 12
  Install Parallels Desktop ........................................................................ 13
  Activate and Register Parallels Desktop .................................................. 13
  Purchase Parallels Desktop ................................................................... 14
  Upgrade Parallels Desktop .................................................................... 14
    Install Software Updates .................................................................... 15
    Set the Language .............................................................................. 17

Install or Import Windows ........................................................................ 18
  Install Windows ................................................................................... 18
  Import Your Data from a PC ................................................................. 20
    Overview of Methods for Importing .................................................... 20
    Requirements for Importing Your Data ............................................... 20
    Step 1: Install Parallels Transporter Agent on Your Windows PC ............. 21
    Step 2: Import Your Data .................................................................... 21
    Solving Problems .............................................................................. 27
  Use Boot Camp with Parallels Desktop .................................................. 29
  Import from an Earlier Parallels Desktop or Other Virtualization Application .................................................................................. 30

Use Windows on Your Mac ...................................................................... 31
  Get Started ......................................................................................... 31
    Start Windows ................................................................................... 31
    Open a Windows Program ................................................................. 32
    Install Windows Programs .................................................................. 36
    Shut Down or Suspend Windows ......................................................... 36
  Set How Windows Works with Mac OS X ................................................. 40
    Merge Windows and Mac OS X .......................................................... 41
Apply Separate Network Settings to Windows ................................................................. 96
Use Host-Only Network Settings ...................................................................................... 98
Use Wi-Fi with Windows ..................................................................................................... 98
Connect Windows to a VLAN ............................................................................................ 99
Optimize Performance ...................................................................................................... 99
Set How Much Memory is Allocated to Windows ............................................................ 100
Optimization Settings ...................................................................................................... 100
Optimize 3D Graphics Performance on a MacBook Pro .................................................. 102
Speed Up Games and Graphics Programs ....................................................................... 103
Pause Windows When No Programs Are Open ................................................................ 103
Optimize Virtual Machine for Games, Graphics, Productivity, or Development .......... 104
Work with Windows in Travel Mode ................................................................................ 104
Schedule Windows Maintenance ...................................................................................... 105
Use Windows on Your iPad, iPhone, or Android Device ................................................. 106
Save Time With Parallels Toolbox .................................................................................. 107
Save a Picture of the Screen ............................................................................................ 108
Set the Appearance of Virtual Machine Dock Icons ...................................................... 108
Allow Windows Updates While Your Mac is Sleeping ................................................... 108
Translate Words in Windows ............................................................................................ 109
Advanced Topics .............................................................................................................. 110
Work with Virtual Machines .......................................................................................... 110
Supported Guest Operating Systems .............................................................................. 110
About Virtual Machines .................................................................................................. 112
Arrange Virtual Machines .............................................................................................. 115
Make Virtual Machines Distinctive ................................................................................ 115
Change the Virtual Machine Icon ................................................................................... 115
Change the Virtual Machine Name ................................................................................ 116
Clone a Virtual Machine ................................................................................................. 116
Back Up a Virtual Machine ............................................................................................. 117
Browse Virtual Hard Disks in Mac OS X ......................................................................... 118
Create and Use Virtual Machine Templates .................................................................. 120
Save Snapshots of a Virtual Machine ............................................................................. 121
Change Virtual Machine Configuration at Runtime ...................................................... 123
Use Mouse Wheel Horizontal Scrolling .......................................................................... 125
## Contents

- Remove a Virtual Machine ................................................................. 125
- Download Pre-configured Virtual Appliances .................................... 125
- Set the Guest OS Type and Version .................................................. 126
- Set How Many Processors are Allocated to a Virtual Machine .......... 127
- Check Your Virtual Machine CPU and Memory Usage...................... 127
- Enable Spoken Commands ................................................................. 127
- Get Acronis True Image ................................................................. 128
- Use AppleScript with the Guest OS .................................................. 129
- Quickly Free Up Disk Space .............................................................. 129
- Archive and Unarchive Virtual Machines ........................................... 130
- Use Other Operating Systems on Your Mac ...................................... 130
  - Import Linux and Your Data from a PC ........................................ 130
  - Use Linux in Coherence Mode ...................................................... 131
  - Install Windows 98 ................................................................. 132
  - Improve Graphics Performance in Windows NT/98/ME ................. 134
  - Customize the Keyboard for the Guest OS ................................. 135
  - Use OS X as a Guest OS ........................................................... 138
- Install or Update Parallels Tools ....................................................... 140
  - Parallels Tools Overview .......................................................... 140
  - Parallels Tools for Windows ...................................................... 142
  - Parallels Tools for Linux ........................................................... 143
  - Parallels Tools for Mac ............................................................ 148
- Install Sound Driver in OS/2 and eComStation ................................. 149
- For Software Developers ................................................................. 149
  - Optimize Remote Debugging ....................................................... 149
  - Run Windows Phone Emulator .................................................... 150
  - Generate a Core Dump ............................................................... 153
  - Start a Debugging Session .......................................................... 154
- Integration With Chef/Ohai .............................................................. 154
- Integration With Docker ................................................................. 154
- Use Virtual Machine Names as DNS Names .................................... 155
- Resolve Guest OS DNS Requests Using etc/hosts .......................... 155
- Other Actions ................................................................................. 156
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set File Type Associations</td>
<td>156</td>
</tr>
<tr>
<td>Modality Mode</td>
<td>157</td>
</tr>
<tr>
<td>Hide and Show Parallels Desktop</td>
<td>158</td>
</tr>
<tr>
<td>Disable Automatically Suspending Windows</td>
<td>159</td>
</tr>
<tr>
<td>Remove Parallels Desktop</td>
<td>159</td>
</tr>
<tr>
<td>Advanced Preferences</td>
<td>160</td>
</tr>
<tr>
<td>Shared Networking Settings</td>
<td>162</td>
</tr>
<tr>
<td>Host-Only Networking Settings</td>
<td>166</td>
</tr>
<tr>
<td>Create a Custom Host-Only Network</td>
<td>168</td>
</tr>
<tr>
<td>More Options</td>
<td>168</td>
</tr>
<tr>
<td>Adding and Removing Devices</td>
<td>170</td>
</tr>
<tr>
<td>Support for Virtual and Real Disks</td>
<td>172</td>
</tr>
<tr>
<td>Initialize a Newly Added Disk</td>
<td>174</td>
</tr>
<tr>
<td>Hardware Settings</td>
<td>176</td>
</tr>
<tr>
<td>CPU and Memory</td>
<td>176</td>
</tr>
<tr>
<td>Boot Order</td>
<td>177</td>
</tr>
<tr>
<td>Graphics</td>
<td>180</td>
</tr>
<tr>
<td>Floppy Disk</td>
<td>182</td>
</tr>
<tr>
<td>CD/DVD-ROM</td>
<td>183</td>
</tr>
<tr>
<td>Hard Disk</td>
<td>185</td>
</tr>
<tr>
<td>Network</td>
<td>189</td>
</tr>
<tr>
<td>Printer</td>
<td>191</td>
</tr>
<tr>
<td>Serial Port</td>
<td>193</td>
</tr>
<tr>
<td>Sound</td>
<td>195</td>
</tr>
<tr>
<td>USB &amp; Bluetooth</td>
<td>196</td>
</tr>
</tbody>
</table>
Congratulations on purchasing Parallels Desktop 12 for Mac. You no longer have to choose between the Mac and the PC. Parallels Desktop lets you use Windows side-by-side with OS X on your Mac.

Use this guide to quickly set up and start using Parallels Desktop.

In This Chapter

What You Can Do .................................................................................................... 10
Set Up Your Mac to Use Windows Programs ........................................................... 10
Other Operating Systems ......................................................................................... 10
Welcome to Parallels Desktop

What You Can Do

With Parallels Desktop, you can:

• Open Windows applications side-by-side with your Mac OS X applications, without having to restart
• Copy and paste text and drag and drop objects between Mac and Windows applications
• Run Windows games and other 3D programs
• Transfer all your data from a PC and use it on your Mac
• Easily share files, devices, and other resources between Windows and the Mac
• Install other operating systems, such as trial versions of Windows, Linux, another copy of OS X, and free virtual appliances; and use them together
• And much more

Set Up Your Mac to Use Windows Programs

After just a few steps, you can begin using Windows programs on your Mac. Setting up your Mac to run Windows programs involves the following steps:

Step 1: Install Parallels Desktop (p. 12).

Step 2: Install Windows on your Mac (p. 18).

Step 3: Install your Windows programs (p. 36).

You only need to follow these steps once. Then you can open and use your Windows programs on your Mac anytime you like, just as you do with your Mac applications.

Other Operating Systems

Important: This guide is focused on using Parallels Desktop with Windows.

Using Parallels Desktop 12 for Mac you can run several other kinds of operating systems (p. 110) on your Mac, such as several flavors of Linux and Unix, Mac OS X Server, Windows 8, older versions of Windows, and more.
Finding Information On Running Other Operating Systems

You can find much more information and details on using Parallels Desktop to run other operating systems on your Mac by checking the resources listed in More Resources (p. 211).

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply to supported operating systems other than Windows. And some important instructions relating to other operating systems are in the Advanced Topics (p. 110) section.
Install or Upgrade Parallels Desktop

Follow the instructions in this chapter to install or upgrade Parallels Desktop.

**Note:** You can either purchase a boxed version of Parallels Desktop 12 or purchase and download it from the Parallels website.

**In This Chapter**

What You Need ........................................................................................................12
Install Parallels Desktop ............................................................................................ 13
Activate and Register Parallels Desktop ....................................................................13
Purchase Parallels Desktop ...................................................................................... 14
Upgrade Parallels Desktop........................................................................................ 14
Set the Language ..................................................................................................... 17

**What You Need**

To install and set up Parallels Desktop 12 for Mac, you need:

- A Mac computer with:
  - An Intel Core 2 Duo, Core i3, Core i5, Core i7, Intel Core M or Xeon processor (Core Solo and Core Duo processors are no longer supported).
  
  **Note:** Parallels Desktop can only be installed on Intel-based Macs running the 64-bit kernel. Please see http://support.apple.com/kb/HT3770 for more details.

  - At least 2GB of RAM (4GB recommended)

  **Note:** Your Mac must have enough RAM memory to use Mac OS X and its applications plus the memory required for each additional operating system (and its programs) that you want to use simultaneously.

  - At least 850 MB of space available on the boot volume (the volume that has OS X) for Parallels Desktop installation

  - Enough free disk space for each virtual machine and its applications (at least 15 GB for each installation of Windows)

  - OS X Yosemite 10.10 or later, OS X Mavericks 10.9.4 or later

  To identify your computer's processor, memory, and OS X version, choose **Apple menu > About This Mac**.
Install or Upgrade Parallels Desktop

- Internet connection required for product activation, select features, and online updates
- One of the following:
  - A Windows installation disc, or other installation media for the operating systems you want to use alongside OS X
  - An Internet connection to download and install freely available operating system such as Ubuntu or Google Chrome.
  - If you’re using OS X Lion or later, you can set up a second copy of OS X to be used as a guest operating system alongside your main system, without having to purchase or download another copy of OS X.

For a list of operating systems that Parallels Desktop supports for use with your Mac, see Supported Guest Operating Systems (p. 110) or go to http://www.parallels.com/products/desktop/system-requirements/.

Install Parallels Desktop

You can be up and running with Parallels Desktop in a few easy steps:

1. Make sure you have the latest version of OS X.
2. Do one of the following:
   - If you downloaded Parallels Desktop from the Parallels website, double-click the disk image file, most likely in your Downloads folder (the file has the extension ".dmg" at the end).
   - If you purchased a boxed copy of Parallels Desktop with a USB thumb drive, connect the drive to your Mac, open it and double-click the disk image file.
   - If you purchased a boxed copy with a link to the installation file, open the link in your web browser, download Parallels Desktop and double-click the disk image file.
   - If you purchased a boxed copy with an installation disc, insert the disc.

   **Note:** If your Mac doesn’t have a DVD-ROM, you can use the download link, available in the retail box, to download Parallels Desktop over the Internet.

3. Double-click the Install icon and follow the onscreen instructions to install Parallels Desktop.

Activate and Register Parallels Desktop

Once Parallels Desktop is installed, you need to activate it and register. Do the following:

1. First you need to sign in to your Parallels account:
   - If you have an account, enter your email address, select I have a password, enter the password and click Sign In.
Install or Upgrade Parallels Desktop

1. If you don’t have a Parallels account, enter an email address that will be used to create the account, select I’m a new user, click Sign In and follow the onscreen instructions.

2. In the next step, you must enter your Product Activation Key to activate Parallels Desktop.

   Note: If you purchased Parallels Desktop from the Parallels Online Store, a key was sent to the email address you provided. If you bought a boxed copy, you can find your key printed on the installation disc sleeve.

If you already have a license available and associated with your account, just select the license and click Activate.

If You Don’t Have A Product Activation Key

If you don’t have a key already, you can get a free trial Product Activation Key so you can try out Parallels Desktop for a limited time, click Try Free for 14 days. Or to purchase a key that lets you use Parallels Desktop permanently, click Buy.

Purchase Parallels Desktop

If you’re using a trial version of Parallels Desktop 12, you can easily purchase the full version right from the application interface. To do so:

1. Click Buy in the About Parallels Desktop window or when you see the promo.

2. Choose one of the following:

   • **Upgrade**: Select this option to upgrade your current version of Parallels Desktop. Please keep in mind that you will need the activation key for your previous version. If the Upgrade option is selected by default, Parallels Desktop has already automatically detected the key for the previous version. If not, please make sure you have it.

   Note: Only Parallels Desktop 10 and 11 can be upgraded to Parallels Desktop 12.

   • **Buy Full Version**: Select this option to purchase Parallels Desktop if you have never used it before or your version cannot be upgraded.

3. Follow the onscreen instructions. You may need to scroll down to see all the information.

Upgrade Parallels Desktop

If you already have Parallels Desktop 10 or 11 follow these steps to upgrade to Parallels Desktop 12.

1. If you haven’t already done so, purchase and download a “Parallels Desktop 12 for Mac Upgrade,” available from the Parallels Online Store at www.parallels.com/buyonline.

   A Product Activation Key is sent to the email address you provide.
2 If Parallels Desktop is open, quit Parallels Desktop.
3 Follow the instructions to install Parallels Desktop 12. See Install Parallels Desktop (p. 13).
   During installation, the previous version of Parallels Desktop is automatically removed from your computer.
4 Open Parallels Desktop and enter your upgrade Product Activation Key.
   If you were using a trial version of Parallels Desktop or you purchased a previous version but haven’t installed it on your computer, you will also be prompted to enter a full or upgrade key for that version.

**Note:** To upgrade from Parallels Desktop 2, 3, 4, 5, 6, 7, 8 or 9 you must purchase Parallels Desktop 12 at full retail price.

**Troubleshooting**

If you have any problems upgrading Parallels Desktop, you can find troubleshooting information at http://www.parallels.com/products/desktop/support/.

**Install Software Updates**

Periodically, Parallels provides free software updates to improve Parallels Desktop.

By default, Parallels Desktop is configured to automatically check for and download available software updates once a week. When an update is available, Parallels Desktop prompts you to install it. Simply follow the onscreen instructions.

**Adjust Software Update Settings**

1 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
Install or Upgrade Parallels Desktop

- Right-click the Parallels Desktop icon in the Dock and choose **Preferences**. Then click **General**.

![Parallels Desktop Preferences](image)

**Parallels menu:** Show Parallels icon in menu bar

Virtual Machines Folder: **Parallels**

Virtual Machine Dock Icons: **Live Screenshot**

Check for Updates: **Once a week**

- **Download updates automatically**
- **Check Now**

OS X Resume: **Disable for Parallels Desktop**

Virtual machines shut down according to their startup and shutdown settings.

Click the lock to prevent further changes.

2  Do one of the following:

- To adjust the frequency that Parallels checks for software updates, choose **Never**, **Once a Day**, **Once a Week**, or **Once a Month** from the **Check for Updates** menu.

- To choose whether you want Parallels Desktop to download updates automatically, select or deselect **Download updates automatically**.

If you choose not to download updates automatically, Parallels Desktop notifies you when an update is available and asks whether you want to download it.

**Check for an Update Manually**

- Follow the instructions in step 1 above and then click **Check Now**. You can also choose **Check for Updates** from the **Parallels Desktop** application menu.

**Note:** To check for updates and download them, your Mac must be connected to the Internet.
Set the Language

You can set which language the Parallels Desktop interface uses by doing the following:

1. Quit Parallels Desktop.
2. Choose **Apple menu > System Preferences > Language & Region**.
3. Drag the language you want to the top of the list. If you don’t see the language you want to use in the list, click the **Add** button.
4. Open Parallels Desktop.

   If the primary language you chose is supported by Parallels Desktop, the menus and interface text appear in that language. If the primary language you selected isn’t supported, menus appear in the first language listed that Parallels Desktop supports.
Install or Import Windows

There are a few ways to get Windows up and running on your Mac:

- Install Windows (p. 18)
- Import your data from a Windows PC (p. 20)
- Use Windows that you already have installed from a Boot Camp partition (p. 29)
- Import Windows from a previous version of Parallels Desktop or other virtualization software (p. 30)

In This Chapter

- Install Windows ......................................................................................................... 18
- Import Your Data from a PC ..................................................................................... 20
- Use Boot Camp with Parallels Desktop..................................................................... 29
- Import from an Earlier Parallels Desktop or Other Virtualization Application.......... 30

Install Windows

If you have a Windows installation source (a DVD disc, an image file, or a USB storage) and a valid Windows product key, you can install Windows on your Mac and use it with Parallels Desktop.

To install Windows:

1. Open Parallels Desktop (in the Applications folder) and choose File > New.
2. If you have a Windows installation disc, insert it into the DVD drive. If you have a USB storage with Windows, connect the storage to the Mac.
3. Click Install Windows or another OS from a DVD or image file.
4. Parallels Desktop scans for and lists installable operating systems. If you see the version of Windows you want to install, select it, click Continue and go to step 6.
5. If the Windows installation source didn't show up automatically in Step 4, click Locate manually to browse for it manually. You can browse from the following sources:
   - DVD: If you have a Windows DVD, insert it into the DVD drive. Once Windows is detected, click Continue. If your Mac doesn't have a DVD drive, you can use an Apple SuperDrive, another Mac's DVD drive via Remote Disc, or make an image from the disc.
Install or Import Windows

- **Image File:** If you have a Windows image file, click **Image File** and drag the image to the Parallels Wizard window. Once Windows is detected, click **Continue**.

- **USB Drive:** If you have a bootable USB installer with Windows, click **USB Drive** and connect the drive to the Mac. Once Windows is detected, click **Continue**.

  **Note:** Parallels Desktop may fail to detect some operating systems (for example, the latest Linux distributions). If this happens but you’re sure that the operating system can be installed, click **Continue**, specify the OS type manually (if it’s not listed, choose **Other**), and follow the onscreen instructions.

6. Be sure to leave **Express installation** selected.

  **Note:** If you deselect **Express installation**, you’ll need to install Parallels Tools (p. 199) after the installation to allow the most seamless operation between Windows and Mac OS X.

7. Choose what for you’re going to primarily use Windows. Its settings will be tuned to best fit your needs.

8. Choose where you want to store Windows from the **Location** menu.

   By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To allow all users of your computer to have access to this installation of Windows, select **Share with other users of this Mac**.

9. If you want to pre-set things like how much memory Windows uses or whether it starts automatically when you open Parallels Desktop, select **Customize settings before installation**. You can also adjust these settings after the operating system is installed.

10. Click **Continue**.

    The assistant installs Windows.

Once Windows is installed, you can start it up by opening a Windows program (p. 32) or by clicking the power button in **Control Center**.
Install or Import Windows

**Important:** The first time you start Windows, Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels Tools are installed, you’re prompted to restart Windows.

If you didn’t select *Express installation* in step 6 above, you must install Parallels Tools manually (p. 199).

When you install Windows, Parallels Desktop creates an administrator account with a blank password. Once the installation is complete, it is recommended that you change this password.

**Note:** You can also install Windows from a disk image file (p. 172) of an installation disc. Simply choose the disk image file in step 4 above. Parallels Desktop supports ISO, DMG, CUE, and CCD disk images.

Import Your Data from a PC

You can import all your data from a Windows PC to Parallels Desktop on your Mac. Then you can continue to work with all your Windows programs, files, and data, side-by-side with Mac OS X.

**Overview of Methods for Importing**

You can import your data using one of the following:

- **Network (p. 21):** If both the Windows PC and your Mac are connected to a network, you can import your data over the network.

- **External storage device (p. 24):** You can transfer the data from a Windows PC to an external storage device, such as an external hard drive. Then, you can connect the device to your Mac and import your data into Parallels Desktop.

**Requirements for Importing Your Data**

To import your data to your Mac, you need a Windows computer with:

- Windows 10, Windows 8, Windows 7, Windows Vista, or Windows XP with Service Pack 2 or later.

  **Note:** You can also use a computer running Windows Server 2008 R2 (64-bit only), Windows Server 2008, or Windows 2000 Professional (32-bit only).

- An Intel or AMD (700 MHz or higher) x86 or x64 processor
- At least 256 MB of RAM
- At least 70 MB of hard disk space for installing Parallels Transporter Agent
- One of the following:
  - An Ethernet port for transferring your data over network
• An external storage device, such as a USB hard disk

**Note:** Parallels Desktop does not support migrating Windows dynamic volumes. These are volumes which size is not fixed as in basic volumes. They are migrated as data disks only. You can later add them (p. 170) to an already existing virtual machine.

**Step 1: Install Parallels Transporter Agent on Your Windows PC**

To import your data you must first install the Parallels Transporter Agent software on the Windows PC.

To install Parallels Transporter Agent:

1. Do one of the following:
   - If you purchased a physical copy of Parallels Desktop, insert the Parallels Desktop installation DVD into your Windows PC. If the installation doesn’t start automatically, locate and double-click the *Parallels Transporter Agent.exe* file on the disc.

   If your computer is connected to the Internet, Parallels Transporter Agent checks for available updates. If an update is available, click **Download and Install New Version**.

2. Follow the onscreen instructions to install Parallels Transporter Agent.

**Step 2: Import Your Data**

Follow one of the methods below to import your data from your PC to your Mac.

**Over a Network**

**Important:** After importing your data, you may need to reactivate some of your Windows programs using the activation keys you received when you purchased the programs.

*To import your data from a PC over a network:*

1. Turn on your Mac and your Windows PC and log in.
2. Make sure that Windows Firewall (p. 28) is turned off. You can turn it on again after the import is finished.
3 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.

4 On your Mac, open Parallels Desktop and choose File > New.

5 Select Transfer Windows from a PC and click Continue.

6 Select Network and click Continue.

7 Find the passcode displayed in Parallels Wizard on your Mac and enter it in Parallels Transporter Agent on your Windows PC.
If the remote PC and Mac are not connected to the same network, you can transfer the remote PC using its name or IP address. To do so, click **Connect using IP address**, select the Windows PC name from the list or type the IP address, and click **Continue**.

8 If you have chosen to use the computer name or IP address, provide the Windows administrator credentials. Parallels Desktop connects to Parallels Transporter Agent and starts collecting information about the source computer.

9 If you want to log in to Windows automatically whenever you start up Windows, select **Enable Automatic Logon**. When ready, click **Continue**.

10 Choose what you want to transfer;
   - **System only**: this option allows you to transfer the operating system and applications only. If you choose it, go to step 12.
   - **System and documents**: this option allows you to transfer the operating system, applications, and user’s files like pictures, documents, downloads, music, videos, etc.

11 If you chose to transfer system and documents in the previous step, choose how you want to transfer the user’s files:
   - **Transfer to Windows**: If you choose this option, the user’s files will be transferred to the resulting virtual machine and will not be accessible from OS X. You can make them accessible from OS X later by sharing Windows with OS X (p. 52).
   - **Transfer to Mac**: If you choose this option, the user’s files will be transferred to the corresponding folders in OS X. The resulting virtual machine will have access to these files as well because it will be configured to share folders with OS X.

This way of transferring the user’s files requires additional steps with Apple Migration Assistant. Follow the link in the screen for more information.
12 Choose where you want to install your data.

When ready, click Continue.

13 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select I want to continue and click Continue.

14 Once the transfer is complete, click Done.

15 Start Windows (p. 31).

16 When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen instructions.

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Using an External Storage Device

Important: After importing your data, you may need to reactivate some of your Windows programs using the activation keys you received when you purchased the programs.

To import your data from a PC using an external storage device:

1 Connect an external storage device to your Windows PC.
2. On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.

3. Select External storage and click Continue. Parallels Transporter Agent collects information about the Windows PC.

4. If you want to log in to Windows automatically whenever you start up Windows, select Enable Automatic Logon and specify the Administrator's password. When ready, click Continue.

5. Choose what you want to transfer;
   - **System only**: this option allows you to transfer the operating system and applications only. If you choose it, go to step 7.
   - **System and documents**: this option allows you to transfer the operating system, applications, and user's files like pictures, documents, downloads, music, videos, etc.

6. If you chose to transfer system and documents in the previous step, choose how you want to transfer the user's files:
   - **Transfer to Windows**: If you choose this option, the user's files will be transferred to the resulting virtual machine and will not be accessible from OS X. You can make them accessible from OS X later by sharing Windows with OS X (p. 52).
   - **Transfer to Mac**: If you choose this option, the user's files will be transferred to the corresponding folders in OS X. The resulting virtual machine will have access to these files as well because it will be configured to share folders with OS X.

   This way of transferring the user's files requires additional steps with Apple Migration Assistant. Follow the link in the screen for more information.
7 Choose where you want to store your data. You can also click Customize and select which Windows volumes to migrate.

When ready, click Continue.

8 In the next step there’s a warning about Windows activation that might be required when you start using it. To proceed, read this message, select I want to continue and click Continue.

9 Once the migration is complete, click Done to quit Parallels Transporter Agent.

10 Disconnect the storage device from the Windows PC and connect it to your Mac.

11 On your Mac, open Parallels Desktop and choose File > New.

12 Select Transfer Windows from a PC and click Continue.

13 Select External storage and click Continue.

14 Parallels Desktop scans the connected storages for the newly created virtual machine. If Parallels Desktop cannot find it, select the virtual machine manually. Then click Continue.

15 Choose where you want to install Windows and your data, and then click Continue.

16 Once the transfer is complete, click Done.

17 Start Windows (p. 31).

18 When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen instructions.
Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Solving Problems

Read this section if you have problems importing your data from a Windows PC.

General Tips

This section provides solutions to some errors that may occur during the import process.

Parallels Transporter Agent Doesn't Work Correctly

If you experience any problems while importing, make sure that the snapman.sys driver is installed in C:WINDOWS\system32\drivers\.

If the snapman.sys driver is not installed, follow these steps:

1. Uninstall Parallels Transporter Agent.
2. Restart your Windows PC.
3. Reinstall Parallels Transporter Agent.
4. Restart your Windows PC again.
5. Try to import Windows and your data again.

Import is Interrupted by an Error

If the import process is interrupted by an error, do the following:

1. From the Start menu, choose My Computer.
2. In the Hard Disk Drives pane, right-click the volume you want to import, and choose Properties.
3. In the Properties pane, click the Tools tab, and in the Error Checking section, click the Check Now button.
4. In the Check Disk window, select Automatically fix file system errors and Scan for and attempt recovery of bad sectors, and then click Start.
5. Wait till the disk is scanned and errors are fixed.

Dynamic Volumes are not Imported

Only basic volumes can be imported. You can’t import dynamic volumes using Parallels Desktop.

The only way to import the data stored on a dynamic disk is to copy the data to a basic disk on your Mac and then import the basic disk.
If Your Mac Fails to Connect with Parallels Transporter Agent

Firewall applications may block connections between your Mac and Parallels Transporter Agent on the Windows PC.

Firewall problems in Mac OS X

If your Mac fails to connect with Parallels Transporter Agent on your Windows PC, the reason may be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent.

To enable connections between your Mac and Parallels Transporter Agent and prevent further blocking, you can configure the firewall settings in Mac OS X by doing the following:

1. From the Apple menu, choose System Preferences, and then click Security.
2. Click the Firewall tab.
3. Configure the necessary settings.

If you try to search for Parallels Transporter Agent by typing the Windows PC IP address manually, you may receive a message saying that Parallels Transporter Agent is blocked. Click the Unblock button.

Firewall problems in Windows

Microsoft Windows operating system has a built-in firewall that blocks connections to and from other computers. When starting Parallels Transporter Agent for the first time, you may see a message saying that Windows Firewall has blocked some features of the program.

To enable the connection between your Mac and Parallels Transporter Agent, click Unblock.

To prevent this problem from happening again, add Parallels Desktop and/or Parallels Transporter Agent to the firewall exceptions (the list of applications allowed to communicate through the firewall):

1. From the Start menu, choose Control Panel > Network Connections.
2. In the Network Tasks pane, click Change Windows Firewall Settings.
3. Add Parallels Desktop and/or Transporter Agent to the firewall exceptions list.

If Parallels Doesn't Detect Windows Correctly

If Parallels Desktop detects the source operating system (Microsoft Windows XP or Windows Vista computer) incorrectly, make sure that neither of your Windows programs are running in compatibility mode - a special mode of Windows allowing you to run applications that are incompatible with your version of Windows.

See Windows Help for more information.
Problems Using a Program After an Import

Programs that depend on specific hardware may not work in Parallels Desktop.

If you import from several source volumes, the disk drive letters are changed. Make sure that the program paths are set correctly. See Windows Help for more information.

Use Boot Camp with Parallels Desktop

Boot Camp is a feature of Mac OS X that lets you start up your Mac in Windows. If you have already installed Windows 8, Windows 7, Windows Vista, or Windows XP on your Mac using Boot Camp, you can set Parallels Desktop to work with Boot Camp using either of these two options:

- **Set Parallels Desktop to run Windows from the Boot Camp partition:** Changes you make in Windows programs either while working in Mac OS X or when you start up your Mac in Windows using Boot Camp will be reflected in both places.

  Windows running from Boot Camp has the following limitations:
  
  - It can't be paused
  - It can't be saved as a snapshot (p. 121)
  - It can't run in Rollback Mode (p. 93)
  - It can’t be compressed

- **Import Windows and your data from Boot Camp into Parallels Desktop:** Windows running from Parallels Desktop doesn’t have the above listed limitations. Boot Camp and Parallels Desktop are separate. Changes you make in Windows programs while working in Mac OS X are not reflected when you start up your Mac in Windows using Boot Camp.

Set Parallels Desktop to run Windows from the Boot Camp Partition

1. Open Parallels Desktop (in the Applications folder) and choose **File > New**.
2. Click **Boot Camp**, and then follow the onscreen instructions.

   **Note:** If you plan to start up in Windows using Boot Camp, it is recommended that you shut down Windows in Parallels Desktop rather than suspending Windows.

Import Windows and Your Data from Boot Camp into Parallels Desktop

1. Set Parallels Desktop to use Boot Camp, as described in the steps above.
2. Right-click (Control-click) the Boot Camp version of Windows in **Control Center** and choose **Import Boot Camp**.

   **Note:** Windows must be shut down.

3. Click **Import**.
Install or Import Windows

4 Locate where you want to store Windows and your data, and then click Choose.

Windows and all your data are imported from Boot Camp. You can still use the original Boot Camp Windows installation, separately from Parallels Desktop.

**Important:** The first time you start Windows after setting Parallels Desktop to work with Boot Camp, Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels Tools are installed, you’re prompted to restart Windows.

Import from an Earlier Parallels Desktop or Other Virtualization Application

With Parallels Desktop 12 for Mac you can use Windows that you set up using earlier versions of Parallels Desktop, as well as VMware Fusion, Microsoft Virtual PC, and VirtualBox:

1 Open Parallels Desktop (in the Applications folder) and choose File > Open.

2 Select the Windows data file you want to import, then click Open and follow the onscreen instructions.
   - Parallels Desktop data files end with .pvm.
   - VMware files end with .vmx.
   - Virtual PC files end with .vmc.
   - VirtualBox files end with .xml or .vbox.

You can also simply drag a Parallels .pvm file to Control Center to add it to Parallels Desktop.

3 Start Windows (p. 31).

4 Choose Actions > Install Parallels Tools and follow the onscreen instructions.
Use Windows on Your Mac

Read this chapter to find out all about using Windows programs on your Mac. Learn how to get started using Windows programs, set how Windows programs work with Mac OS X, share applications, files, and folders between Mac OS X and Windows, connect devices, print, customize your keyboard, and more.

In This Chapter

Get Started .............................................................................................................. 31
Set How Windows Works with Mac OS X................................................................. 40
Set Media Files to Open in Windows 8 Apps ............................................................ 65
Mouse, Trackpad, and Keyboard ............................................................................. 65
Connect External Devices......................................................................................... 77
Connect Bluetooth Devices ...................................................................................... 81
Print from Windows.................................................................................................. 82
Use the Built-in iSight Camera or Another Webcam............................................... 90
Show a Presentation on an External Monitor or Projector....................................... 90
Protect Your Data..................................................................................................... 91
Connect to the Internet or a Network........................................................................ 95
Optimize Performance.............................................................................................. 99
Use Windows on Your iPad, iPhone, or Android Device............................................ 106
Save Time With Parallels Toolbox ........................................................................... 107
Save a Picture of the Screen .................................................................................... 108
Set the Appearance of Virtual Machine Dock Icons............................................... 108
Allow Windows Updates While Your Mac is Sleeping............................................. 108
Translate Words in Windows .................................................................................... 109

Get Started

In this section, learn how to start Windows, open a Windows program, install more Windows programs, and shut down or suspend Windows.

Start Windows

To use Windows programs on your Mac, Windows must be running.

The simplest way to start Windows is to open a Windows program (p. 32). If Windows isn’t already running when you open a Windows program, it starts automatically in Coherence mode (p. 41).
Use Windows on Your Mac

**Important:** If Windows was previously shut down, you may need to enter your Windows password.

You can also start Windows by doing the following:

1. Open Parallels Desktop.
2. In Control Center, click the Power Button below Windows.
3. Click anywhere in the Windows window that appears.

Windows starts and you can begin using Windows programs alongside Mac OS X.

**Open a Windows Program**

Opening a Windows program is as easy as opening a Mac application. Here are several ways to open Windows programs:

- From the Windows Applications folder in the Dock
- From the Windows Start menu
- From the Mac OS X Finder
- From the Dock
- Using Spotlight searching
- Using Launchpad (if you are using Mac OS X Lion or later)

**Note:** All Windows program icons can be easily identified by the Parallels Desktop symbol in the lower-right corner of the icon.
Windows Applications Folder

This folder is available in the OS X Dock and contains all your Windows programs. As you install more programs, they are automatically added.

To open a Windows program using the Windows Applications folder:

- Click the folder, and then choose a program.

To add the Windows applications folder to the Dock:

1. Do one of the following:
   - Click the Parallels icon 🏠 in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and then click Applications.
3. Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

Windows Start Menu

To open a Windows program from the Start menu:

1. Do one of the following:
• Click the Parallels icon in the menu bar and choose Windows Start Menu.

• If Windows is in Full Screen or Window mode, open the Start Menu as you normally would.

Note: You can also Command-click or Right-click the Parallels icon.

2 Click the program you want.

Mac OS X Finder

You can also open a program by double-clicking its icon in the Finder.

To find Windows programs in the Finder:

• Double-click the Windows volume on the desktop, and then open the Program Files folder.
Use Windows on Your Mac

Note: To show the Windows volume on the desktop, the Mac OS X Finder must be enabled to show connected servers. Click anywhere on the desktop and choose Finder > Preferences, and then select Connected servers.

You can make an alias for a Windows program on the Mac OS X desktop, then double-click it anytime to open the program.

To make an alias for a Windows program on the Mac OS X desktop:

• Select the program in the Finder and choose File > Make Alias. Then drag the alias icon to the desktop.

Program Icon in the Dock

When you open a Windows program, its icon appears in the Mac OS X Dock at the bottom of the screen. By default when you close the program, the icon disappears from the Dock. Keeping a program's icon in the Dock provides a quick way to open the program anytime.

To keep a Windows program’s icon in the Dock, do one of the following:

• Right-click or Control-click the Windows program icon in the Dock and choose Keep in Dock from the shortcut menu.
• Drag the program’s icon from the Finder to the Dock.

Now you can open the program again anytime by clicking the icon in the Dock.

Spotlight

You can search for and open Windows programs using Spotlight:

• Click the Spotlight icon in the upper-right corner of your screen, or press Command-Space bar on your keyboard. Then type the name of the program and select it from the list.

Launchpad

If you’re using Mac OS X Lion or later, you can see a full screen display of all your Windows programs and Mac applications using Launchpad. Just click the Launchpad icon (looks like a rocket) in the Dock. You can then click any Mac OS X application to open it. To open a Windows program, click the Windows folder and then click the program you want.

Note: The Windows folder is available in Launchpad only if sharing Windows programs (p. 58) is enabled.

To move a Windows program from the Windows folder to a main Launchpad page, do one of the following:

• From Launchpad, click the folder containing your Windows programs and drag a program to the Launchpad icon in the Dock.
Use Windows on Your Mac

• Start the Windows program you want, right-click its icon in the Dock, and choose Add to Launchpad.

To remove a Windows program from Launchpad, start the program, right-click its icon in the Dock, and choose Remove from Launchpad.

Install Windows Programs

You install Windows programs on your Mac just as you would on a Windows PC. The two most common ways of installing programs are:

• Using a CD or DVD installation disc
• Downloading the program or installation file from the Internet or a network

Install a Program from a CD or DVD Installation Disc

1 Start Windows (p. 31).
2 Insert the installation disc.
3 In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then follow the onscreen instructions.

For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM (p. 183).

Install a Program from the Internet or a Network

• Download the program or installation file and follow the instructions from the program’s source.

In most cases, you can either run the installation file and follow the onscreen instructions, or simply open the downloaded program.

For more information about connecting to the Internet and networks, see Connect to the Internet or a Network (p. 95).

Shut Down or Suspend Windows

When you’re finished using Windows programs, you can leave Windows running in the background as you work with your Mac applications. Or you may want to stop Windows from running so more of your computer’s resources are available for your Mac applications. There are a few ways to stop Windows. You can:

• Suspend Windows
• Pause Windows
• Shut down Windows
• Stop Windows

36
Suspend Windows

SUSPENDING WINDOWS CONVENIENTLY FREEZES ALL RUNNING WINDOWS PROGRAMS AND SETTINGS IN THEIR CURRENT STATE.

DO ONE OF THE FOLLOWING:

• Quit Parallels Desktop.
• Click the Parallels icon in the menu bar and choose Actions > Suspend.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Suspend.

THE NEXT TIME YOU START WINDOWS OR OPEN A WINDOWS PROGRAM, YOU RESUME YOUR PROGRESS FROM EXACTLY WHERE YOU LEFT OFF.

WHEN WINDOWS IS SUSPENDED, YOU CAN SAFELY QUIT PARALLELS DESKTOP AND RESUME YOUR PROGRESS LATER.

NOTE: If you are using Mac OS X Lion or later and you shut down or restart your computer, or quit Parallels Desktop, Windows is automatically suspended. The next time you start up Parallels Desktop, you can resume working with Windows from where you left off. If your Windows is encrypted (p. 94), you will have to resume it manually.

Pause Windows

You can temporarily pause from using Windows and free your computer’s resources, such as RAM and processor cycles, to be used by your Mac applications by doing one of the following:

• Click the Parallels icon in the menu bar and choose Actions > Pause.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Pause.

TO RESUME USING WINDOWS AFTER PAUSING IT, DO ONE OF THE FOLLOWING:

• Click the Parallels icon in the menu bar and choose Actions > Resume.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Resume.

If you quit Parallels Desktop while Windows is paused, you’re prompted to either Suspend or Stop Windows first.

Shut Down Windows

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. All Windows programs close, giving you the opportunity to save your progress if necessary, and Windows stops running.

To shut down Windows, do one of the following.
Use Windows on Your Mac

- Click the Parallels icon in the menu bar and choose Actions > Shut Down.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Shut Down.

Stop Windows

To stop Windows and all open Windows programs immediately, do one of the following:

- Click the Parallels icon in the menu bar and choose Actions > Stop.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Stop.

**Important:** When you stop Windows this way, none of your data or progress is saved.

Window Menu

If Windows is set to appear in a separate window, you can also choose any of the above options from the menu at the bottom of the window:

![Window Menu](image)

Startup and Shutdown Settings

Using **Startup and Shutdown** settings, you can choose how to start and shut down the virtual machine.

To access **Startup and Shutdown** settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > **Configure**.

2. Click **Options** and select **Startup and Shutdown**.
Set to Start and Shut Down the Virtual Machine Manually

If you want to always start and shut down the virtual machine manually, select **Start up and shut down manually**.

Configure the Virtual Machine to Start Automatically

If you want to make the virtual machine start automatically when the Mac starts, select **Always ready in background**.

Specify More Details How to Start and Shut Down the Virtual Machine Automatically

If you want to specify not only how the virtual machine starts or shuts down but also the view mode and what happens on closing the virtual machine window, select **Custom** and do the following:

Set Whether Windows Starts Automatically

Choose one of the following from the **Start Automatically** menu:

- **Never**: Windows never starts automatically.
- **When window opens**: Windows starts automatically when you open it from **Control Center**.
- **When Parallels Desktop starts**: Windows starts automatically when you start Parallels Desktop.
- **When Mac starts**: Windows starts automatically when you start the Mac. If you select this option, you can also configure the virtual machine to delay the startup.

  **Note**: This feature is available in Parallels Desktop for Mac Pro Edition only.

- **When user logs in**: Windows starts automatically when the OS X user logs in to OS X on the Mac startup.

Set the Startup View

This setting affects in which view mode Windows starts when you start the virtual machine or guest OS application.

- From the **Startup View** menu, choose **Coherence**, **Window**, **Full Screen**, **Modality**, **Headless** or **Same as last time**.

  **Note**: Headless mode is available in Parallels Desktop for Mac Pro Edition only.
Set What Happens When You Shut Down Windows

Choose one of the following from the On VM Shutdown menu:

- **Keep window open**: If Windows is set to appear in a separate window, the window stays open when you stop or shut down Windows.
- **Close window**: If Windows is set to appear in a separate window, the window closes when you stop or shut down Windows.
- **Quit Parallels Desktop**: Parallels Desktop quits when you stop or shut down Windows.

Set What Happens When You Shut Down Your Mac

These settings affect what happens when you shut down the Mac.

From the On Mac Shutdown menu, choose **Stop**, **Shut Down**, or **Suspend**.

Set What Happens When You Close the Parallels Desktop Window

These settings affect what happens only when Windows is set to appear in a separate window.

From the On Window Close menu, choose **Suspend**, **Shut Down**, **Force to stop**, **Keep running in background** or **Ask me what to do**.

Set How Windows Works with Mac OS X

Parallels Desktop 12 for Mac allows you to work seamlessly between Windows and Mac OS X. For example, you can cut and paste text, and share files, between the two.

There are a number of ways that you can set the level of integration between Windows and Mac OS X. For example, you may want your Windows programs to behave just like Mac applications, appearing side-by-side with them on the Mac desktop. Or you may wish to keep the Windows desktop and programs in a separate window.

Read on to learn more about setting how Windows works together with Mac OS X.
Merge Windows and Mac OS X

You can set Windows and Mac OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, Windows programs appear on the Mac desktop next to your Mac applications, and documents from Windows programs and Mac applications are stored in the same folders.

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

- Click the Coherence icon in the top left corner of the virtual machine window.
- Choose View > Enter Coherence.
- Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

- Press Control-Command-F to exit Full Screen. Then click View > Enter Coherence.
Use Windows on Your Mac

- Move the pointer to the top of the screen until the OS X menu bar appears and click **View > Exit Full Screen**. Then open the **View** menu once again and click **Enter Coherence**. If you’re using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 45), press Control-Option (Alt) to display the Mac menu bar.

- If the Parallels hot corners (p. 45) are active, move the pointer to the upper-left corner of the screen until the corner peels back and click **Exit Full Screen**.

Then choose **View > Enter Coherence**.

**Note:** To enable the Coherence view mode, Parallels Tools must be installed (p. 199). In most cases, Parallels Tools are installed by default.

Parallels Menu

When in Coherence mode, the Parallels menu  appears in the menu bar at the top of the screen.

Use the menu for these common functions:

- **Click** the Parallels icon  to open a basic menu that provides the following items:
  - **Windows Start Menu:** Access the Windows Start menu.
  - **Devices:** Manage hardware devices like printers and DVD drives.
  - **Exit Coherence:** Switch to Window mode
  - **Request Support:** Fill out a problem report and request support from Parallels Desktop.
  - **Parallels Desktop Help:** Access onscreen help.
  - **Quit:** Quit Parallels Desktop.

- **Right-click** the icon to open the Windows start menu.
Important: When in Coherence mode, to quit Parallels Desktop, click the Parallels icon in the menu bar and choose Quit Parallels Desktop.

Windows System Tray

When Parallels Desktop is in Coherence mode, the Windows system tray icons are in the Mac OS X menu bar at the top of the screen.

You can use the system tray icons just as you would from the Windows Desktop.

Move Windows Programs Between Desktops (Spaces)

When Windows is working in Coherence, you can easily move windows of guest OS programs between Mac OS X desktops (spaces).

• Click the title bar of the window you want to move and while holding down the mouse button, press Control-# (# is the number of the desktop (space) you want to move the window to).

Set Windows to Appear in a Single Window

You can set the Windows and programs to appear together in their own window.

To switch to Window mode from Coherence mode, do one of the following:

• Click the Parallels icon in the menu bar, then choose View > Exit Coherence.
Use Windows on Your Mac

• If the Parallels Desktop menus are available in the Mac menu bar, click View > Exit Coherence.

To switch to Window mode from Full Screen mode, do one of the following:

• Press Command-Control-F.
• Move the pointer to the top of the screen until the OS X menu bar appears and click View > Exit Full Screen. If you’re using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 45), press Control-Option (Alt) to display the Mac menu bar.

Adjust Window Mode Settings

You can customize how Parallels Desktop appears and behaves when in Window mode.

Set Whether Windows Programs Show in the Dock:

You can choose whether or not to show icons for Windows programs in the Mac OS X Dock when in Window mode. If you prefer to work with programs by manipulating them on the Windows desktop, you may not want to be distracted by seeing them in the Dock alongside your Mac OS X application icons.

3 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

4 Click Options and then click Applications.

5 To show Windows program icons in the Dock when in Window mode, deselect Show Dock icons in Coherence only.

Monitoring Windows in a Scalable Window

You can set Windows to appear in a window that can be resized to any size so that the content scales in size with the window. This is called Modality mode. Modality mode can be useful if you want to monitor programs and other tasks running in Windows as you work in Mac OS X.

To switch to Modality mode:

• From Window mode, choose View > Enter Modality.

For more information on Modality mode, see the Modality mode settings topic (p. 157).

Set Windows to Take Up the Whole Screen

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a Windows PC. In Full Screen mode, Mac OS X and all of the Parallels Desktop controls are hidden.
To switch to Full Screen mode, do one of the following:

- From Coherence mode, click the Parallels icon in the menu bar, then choose View > Exit Coherence. Then click the View menu and select Enter Full Screen.
- From Window mode, choose View > Enter Full Screen or click the Full Screen icon in the top left corner of the virtual machine window.

To exit Full Screen mode, do one of the following:

- Press Command-Control-F.
- Move the pointer to the top of the screen until the OS X menu bar appears and click View > Exit Full Screen. If you’re using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 45), press Control-Option (Alt) to display the Mac menu bar.
- If the Parallels hot corners (p. 45) are active, move the pointer to the upper-left corner of the screen until the corner peels back and click Exit Full Screen.

If you are using Mac OS X Lion and one of the screen corners is set to show the menu bar (p. 45), move the pointer to that corner and then click the Full Screen button in the top-right corner of the menu.

**Adjust Full Screen Settings**

You can customize how Windows appears and behaves when in Full Screen mode.

To access Full Screen settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure > Options.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure, and then click Options.
2 Click **Full Screen**.

3 In this **Full Screen** pane, you can adjust any of the settings listed below.

**Set What Shows on Displays Connected to Your Mac**

If you have a second display connected to your Mac, by default when you switch to Full Screen mode, Windows is displayed on the primary display and Mac OS X on the secondary.
You can choose which display Windows is shown on by dragging its window to that display and then clicking the Full Screen icon 🎧.

To extend Windows across all your displays, select **Use all displays in full screen**.

**Optimize Full Screen for Games**

If you use a virtual machine to play video games in Full Screen view mode, select **Optimize full screen for games**. With this option selected, OS X Dock, menu bar and notifications will not be displayed when you move the mouse pointer to the top and bottom of the screen.

**Allow Windows to set display gamma**

If you're using Windows to play video games, Windows may need to temporarily change your Mac’s display gamma setting to properly display different visual effects. To allow Windows to change gamma settings, select **Allow Windows to set display gamma**.

**Scale to fit screen**

Using the **Scale to fit screen** menu, you can configure how Windows is displayed when working in Full Screen:

- **Off**: If Parallels Tools (p. 140) are installed, Windows resolution matches that of the Mac. If Parallels Tools (p. 140) aren't installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows has scroll bars.

- **Auto**: If Parallels Tools (p. 140) are installed, Windows resolution matches that of the Mac. If Parallels Tools (p. 140) aren't installed, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.

- **Keep ratio**: No matter whether Parallels Tools (p. 140) are installed or not, Windows resolution remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black background. If higher, Windows is entirely displayed on the screen without any scroll bars.

- **Stretch**: No matter whether Parallels Tools (p. 140) are installed or not, Windows resolution remains unchanged but Windows is stretched to occupy the whole screen.
About Using Windows 8 with Parallels Desktop

As you probably know, Windows 8 features two environments; the new Metro interface; and the classic Windows desktop interface, accessible by clicking Windows Explorer on the Start screen or clicking Start in the Charm Bar.

Metro Applications Run in Full Screen

On a Windows PC, Metro-style applications and the Start screen take up the full screen, rather than running in a separate window. So even when you’re using Windows 8 in Coherence mode (p. 41), Metro applications still use most of the screen.
When Windows 8 is in Window mode (p. 43), the Metro interface takes up the full window.

Using the Edges and Corners of the Screen

In Windows 8, you must click in the edges and corners of the screen to access various features. For example, to access the Charm Bar, which contains icons for accessing settings, searching, and more, you must move the pointer to the upper- or lower-right corner of the screen.
And to see thumbnails of all your open Metro-style applications, you move the mouse pointer to the upper- or lower-left corner until you see a thumbnail, then slide up or down. Click an application to make it active.

When you’re using Windows 8 in Window mode, it can be tricky to find the exact corner or edge of the screen with the mouse pointer. So Parallels Desktop 12 allows you to set the mouse pointer to "stick" to the edges of the screen (p. 168) when you move it slowly. To move past the edge, just move the mouse quickly. This feature, enabled by default, makes it easy to use Windows 8.

**Set Windows 8 to Work Like Windows 7**

As you might know, Windows 8 differs considerable from its previous versions: Windows 8 boots to a tiled "Start screen" rather than the traditional Windows desktop, modern Windows 8 apps are all full screen only, and the Windows 8 desktop has no Start menu.

If you prefer the classic Windows environment where Windows boots to the desktop, Windows applications run in resizable windows, and a fully functional Start menu is available from the desktop, you can easily apply this Windows classic style to Windows 8. To do so:

1. In Parallels Desktop, start Windows (p. 31).
2. If Windows is running in Coherence, click the Parallels icon in the menu bar and click View > Exit Coherence.
3. Choose View > Use Windows 7 Look.
To revert to Windows 8 experience, repeat the steps above and deselect Use Windows 7 Look.

Set a Program to Open When You Insert a CD or DVD

You can set the Windows program of your choice to open when you insert a music CD, picture CD, video DVD, or a blank CD or DVD.

1. From the Mac OS X Finder, choose Apple menu > System Preferences.
2. Click CDs & DVDs.
3. From the disc type menu of your choice, choose Open other application.
4. Choose a Windows program from /username/Applications (Parallels)/Windows Applications.

When you insert a disc of the type you selected, the Windows program you chose automatically opens.

**Note:**
1. If you're unable to set a Windows program to open when you insert a CD or DVD, be sure that sharing Mac OS X applications (p. 58) is enabled and that Mac OS X CD/DVD-ROM is not selected in CD/DVD Preferences (p. 183).
2. To enable a Windows program to open when you insert a CD or DVD, Parallels Tools must be installed (p. 199). In most cases, Parallels Tools are installed by default.

Share Items Between Mac OS X and Windows

Parallels Desktop allows you to easily access your Mac OS X files using Windows programs, and also to access Windows files using Mac OS X applications.

Read on to learn about all the ways you can share folders, files, and applications between Mac OS X and Windows.

Copy and Paste Between Mac OS X and Windows

Parallels Desktop allows you to copy and paste images and formatted text (italic, bold, underlined, and of various colors, fonts, and sizes) between Mac OS X and Windows applications.

To enable copying and pasting between Mac OS X and Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options > Advanced.
Use Windows on Your Mac

3  Select Share Mac clipboard.
4  To preserve text formatting when copying and pasting text, select Preserve text formatting.

**Note:** To enable copying and pasting between Mac OS X and Windows, Parallels Tools (p. 199) must be installed. In most cases, Parallels Tools are installed by default. Copying and pasting between Mac OS X and Windows is unavailable if you isolate Mac OS X from Windows.

Copy and Paste Files

You can easily copy and paste files between Windows and Mac OS X by doing the following:

1  Select a file (or multiple files) and press Command+C on your keyboard to copy it.
2  Open a folder or click the desktop in the other operating system and press Command-V to paste the file.

**Notes:**

1. To enable copying and pasting files between Mac OS X and Windows, in Sharing settings (p. 52) All disks or Home folder only must be chosen from the Share Folders menu, and Access Windows folders from Mac must be selected. In most cases all of these options selected by default.

2. If Home folder only is selected in the Share Folders menu (p. 52), you will be able to copy and paste files from the Mac to Windows only from the Mac home folder.

Share Files and Folders

Parallels Desktop allows you to share folders between the Mac OS X and Windows file systems, so you can easily open Mac OS X files from Windows applications and Windows files from Mac OS X applications.

**Note:** These instructions apply to sharing folders between OS X and Linux as well.

Access a Mac OS X Folder or File from a Windows Program

With folder sharing enabled, you can navigate to any shared Mac OS X folder from within a Windows program. When you open a file (for example, by choosing File > Open in many programs), your shared Mac OS X folders appear as network shared directories labeled "psf."

To enable Mac OS X folders for sharing with Windows programs:

1  Start Windows. (p. 31)
2  Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
3 Click **Options** and select **Sharing > Share Mac**.

4 Do one of the following:
   - To share just the folders in your Home folder, choose **Home folder only** from the **Shared Folders** menu.
   - To share all your Mac OS X folders, choose **All disks** from the **Shared Folders** menu.
• To share any folder you want, click **Custom Folders** and click the add (+) button, then choose the folder you want to share. You can add more folders by clicking the add (+) button again.

Once you share a Mac OS X folder with Windows you can:

• Disable the folder sharing by deselecting **On**.
• Change the folder name that will be displayed in Windows by double-clicking the folder name in the **Name** column and typing another name.
• Restrict writing to this folder by clicking **Read & Write** in the **Permissions** folder and choosing **Read only**. You will not be able to add items to the folder.

**Note:** 1. To enable folder sharing, the **Isolate Windows from Mac** option must be disabled on the **Security** tab of the **Configuration** dialog.
2. If you're running Linux, shared folders are mounted to the /media/psf or /mnt/psf directory.

**Set Mac OS X and Windows to Use the Same Folders**

You can set Mac OS X and Windows to use the same folders for things like music, documents, pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, it will be in the Documents folder whether you're using a Mac OS X application or a Windows program.

5 Start Windows. (p. 31)
6 Do one of the following:
   • Click the Parallels icon in the menu bar and choose **Configure**.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.
7 Click **Options** and select **Sharing**.
8 Click the **Share Mac** tab and select **Share Mac user folders with Windows**.

Your Mac OS X Desktop, Documents, Pictures, Music, Movies, and Downloads folders are merged with the corresponding Windows folders, and the Mac OS X Trash is merged with the Windows Recycle Bin.

9 If you only want to map some of the folders, click **Configure** and select the folders you want. To map the Mac OS Trash to the Windows Recycle Bin, select **Merge Recycle Bin with Trash**.

### Show an Item from Windows in the Finder

If Windows is set to appear in a separate window or in full screen mode (p. 43), you can show an item from Windows in the Mac OS X Finder.

- In Windows, right-click (or Control-click) a file or folder and choose **Show in Finder** from the shortcut menu.

From the Finder you could, for example, apply a color label to an item, or easily drag it to another location in the Finder.

**Note:** You can only perform these actions with files stored in shared folders (p. 52).

### Access a Windows Folder or File from a Mac OS X Application

By default, you can navigate to all your Windows folders and files from Mac OS X. Windows disks are mounted to `/Volumes`. At the same time, Windows appears as a hard disk mounted on the Mac OS X desktop.

- Double-click the icon to access Windows folders and files. You can also navigate to this disk from within Mac OS X applications.

**Note:** If the Windows disk icon doesn't appear on the Mac OS X desktop, from the Finder choose **Apple menu > Preferences** and click **General**, and then make sure that **Connected servers** is selected.

To unmount Windows from the desktop:

1 Start Windows. (p. 31)
2 Click the Parallels icon in the menu bar and choose Configure. Then click Options and select Sharing > Share Windows.

Note: If Windows is running in Window mode (p. 43), choose Configure from the Actions menu.

3 Deselect Shortcuts to virtual disks on Mac desktop.

Note: The Windows disk disappears from the desktop and the Finder, but you can still access all of the Windows files and folders via the Windows PVM file and Terminal (/Volumes). By default, the PVM file is either in /Users/<Username>/Documents/Parallels/ or /Users/Shared. You can also find the PVM file by right-clicking Windows in Control Center (or in the virtual machine window when Windows is shut down) and selecting Show in Finder. To access Windows files and folders, right-click the PVM file, select Show Package Contents from the context menu, and open the Windows Disks folder. To disable the ability to navigate to Windows files and folders, deselect Access Windows folders from Mac in step 3 above.

Share iCloud, Dropbox, or Google Drive Folders with Windows

If you’re using iCloud, Dropbox, or Google Drive cloud storage in OS X, you can easily share their OS X folders with Windows. Once sharing is enabled, you can upload, download, and sync files from any of these services from within Windows without duplicating any of their files on your hard disk.

Notes:

1. This functionality is also available for Linux virtual machines.
2. To be able to use this functionality, Parallels Tools (p. 140) must be installed.

To share OS X iCloud, Dropbox, or Google Drive folders with Windows, do the following:

Note: In Parallels Desktop for Mac Pro Edition, you can also share your Dropbox for Business, Box and OneDrive for Business folders with Windows.

1 If you haven’t already, set up iCloud, Dropbox, or Google Drive in OS X.
2 Start Windows (p. 31).
3 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
4 Click Options and select Sharing > Share Mac.
5 Select Share cloud folders with Windows.
6 Log in to Windows and open **Computer**. Folders for iCloud, Dropbox, or Google Drive are available in the **Favorites** section. You can use them to upload and download files to and from the cloud.

---

**Share Windows OneDrive Folders with Mac OS X**

If you’re using Microsoft OneDrive to store files in the cloud, you can easily share your OneDrive folders with Mac OS X. Then you can upload or download OneDrive files in Mac OS X without duplicating any of the files on your hard disk.

**Notes:**

1. To share OneDrive folders with Mac OS X, the OneDrive desktop app must be installed in Windows. If you’re using the preinstalled Windows 8 OneDrive app, OneDrive folders are not shared because this app doesn’t create any local folders and works directly with the cloud storage.

2. This feature is available only when Parallels Tools are installed (p. 142) in Windows.

To share your Windows OneDrive folders with OS X, do the following:

1. If OneDrive isn’t already set up in Windows, set it up. For more information, go to [http://windows.microsoft.com/en-us/skydrive/download](http://windows.microsoft.com/en-us/skydrive/download).

2. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

3. Click **Options** and select **Sharing > Share Windows**.

4. Select **Access Windows folders from Mac** and **Share OneDrive with Mac**.
5 In the Mac OS X Finder, choose Finder > Preferences and select Connected servers.

Once selected, Microsoft OneDrive folders appear as hard disks on the OS X desktop. You can use them to upload and download files to and from OneDrive.

**Note:** These shared folders are visible on the OS X desktop and you can use them to upload files from OS X only when Windows is running.

### Share Applications and Programs

You can access Mac OS X applications from within Windows and you can access Windows programs from Mac OS X. For example, if you locate a file using the Open menu in a Windows program and decide you would rather open the file using a Mac OS X application, you can.

**Note:** Provided that Parallels Tools are installed in Linux (p. 143), you can also open Mac OS X files using Linux applications.

### Enable Sharing Mac OS X Applications

When sharing Mac OS X applications is enabled, you can open Mac OS X Applications from within Windows or Windows programs.

If not, you can enable it at any time by doing the following:

1 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Click Options and click Applications.
3 Select Share Mac applications with Windows.

Once sharing Mac OS X applications is enabled, you can do the tasks below.

### Open a File from Windows in a Mac OS X Application

You can open a file in a Mac OS X application from Windows Explorer, from the Open dialog in most Windows programs, or from Windows Desktop if Windows is set to appear in a separate Window or at full screen (p. 43). You may want to do this if you don’t have a Windows program that can open the file.

- In Windows, right-click (or Control-click) a file and do one of the following:
  - Choose Open on Mac from the shortcut menu. The file opens in the default Mac OS X application for that file type.
  - Choose Open With from the shortcut menu, and then choose an application.
**Open a Mac Application from the Windows Start Menu**

From the Windows Start menu, do one of the following:

- Choose All Programs > Parallels Shared Applications, and then choose an application.
- Type the name of the application you’re looking for in the search field, then choose the application from the list.

**Enable Sharing Windows Programs**

When sharing Windows programs is enabled, you can open Windows programs from the Mac OS X Finder. You can also choose to add a folder to the Dock containing all your Windows programs for easy access.

4 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

5 Click Options and click Applications.

6 Select Share Windows applications with Mac.

**Add a Windows Applications Folder to the Dock**

1 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Options and then click Applications.

3 Be sure Share Windows applications with Mac is selected, and then select Show Windows applications folder in Dock.

**Configure Whether Dock Icons Bounce to Alert**

When a Windows application icon in the taskbar would normally flash to alert you to something, such as a new message in Skype or a notification in Microsoft Outlook, by default its icon also bounces repeatedly in the OS X Dock.

To enable or disable Windows application icons bouncing to alert:

1 Do one of the following:
Click the Parallels icon II in the menu bar and choose Configure.
If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Options and click Applications.

3 Select or deselect Dock icons bounce to alert.

**Note:** Icon bouncing is available for Windows with Parallels Tools installed (p. 199) provided that Share Windows applications with Mac is selected in the Applications pane.

### Force Quit Windows Programs

If your running Windows guest OS program doesn’t respond and freezes, you can easily force quit it as you can do with any Mac OS X application. To force quit a Windows program, do one of the following:

- Right-click the icon of the Windows program available in the Dock, press Option (Alt), and choose Force Quit.
- Press Option + Command + Esc (Alt + Command + Esc), select the name of the Windows program you want to quit, and click Force Quit.

**Note:** To be able to force quit Windows guest OS programs, Parallels Tools must be installed (p. 199).

### Add Applications to Launchpad

When you install any applications in Windows (except temporary apps), you can choose to automatically add their icons to Launchpad.

1 Do one of the following:
   - Click the Parallels icon II in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click Options and click Applications.

3 Select Add new applications to Launchpad.

### Set Files to Open in the Application or Program of Your Choice

You can set files of a particular type that you open from the Mac OS X Finder to open in the Windows program of your choice. For example, you could set files ending in .txt to always open in Windows Notepad.

You can also set files opened from Windows to always open in the Mac OS X application of your choice.
Set Mac OS X Files of a Particular Type to Open in a Windows Program

To open a Mac OS X file once with a Windows program:

1. Right-click (or Control-click) the file in the Finder and choose Open With from the shortcut menu.
2. Select a Windows program.
   - If you don’t see the program you want, click Other and choose a Windows program from /username/Applications (Parallels)/Windows Applications.

You can also open a Mac OS X file in a Windows program by dragging it to the program's icon in the Dock.

To set files of a particular type to always open in a Windows program:

1. Right-click (or Control-click) a file and choose Get Info from the shortcut menu.
2. Click the triangle next to "Open with" to expand the section.
3. Choose a Windows program from the pop-up menu.
   - If you don’t see the program you want, choose Other and choose a Windows program from /username/Applications (Parallels)/Windows Applications.
4. Click Change All.

From this point on, double-clicking a file of this type (e.g., .txt in the example above) in the Mac OS X Finder opens the file in the Windows program. If Windows is shut down, suspended, or paused, double-clicking the file starts or resumes Windows in Coherence mode. When Windows starts up, the file opens in the Windows program.

Set Windows Files of a Particular Type to Open in a Mac OS X Application

To open a Windows file with a Mac OS X application only this time:

- Right-click (or Control-click) the file in Windows, choose Open With from the shortcut menu, and choose an application.

To set all files of a particular file type to open in a Mac OS X application:

1. Right-click (or Control-click) a file in Windows, choose Open With from the shortcut menu, and click Choose default program.
2. Select an application, choose Always use the selected program to open this kind of file, and click OK.

Note: To set files to open in the application or program of your choice, Parallels Tools must be installed (p. 199). In most cases, Parallels Tools are installed by default. Also, the Isolate Mac from Windows (p. 93) option must be disabled, and Windows application sharing (p. 58) must be enabled.
Set Internet Links to Always Open in Mac OS X or Windows

By default, clicking a link (such as a web page URL) in Windows opens the default Windows program for that link type, and clicking a link in Mac OS X opens the default Mac OS X application.

You can set links of a particular type to always open in Mac OS X or in Windows. For example, you could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a Mac OS X application.

**Note:** To set Internet links to open in Mac OS X or Windows, Parallels Tools must be installed (p. 199). In most cases, Parallels Tools are installed by default.

To set Internet links to open in Mac OS X or Windows:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

2. Click **Options** and select **Web & Email**.

3. Click the menu for the type of link you want to set. If you don’t see the link type you want, click **More Applications**. The following types of links can be set:
   - **Web Pages**: Web pages accessible through the HTTP and HTTPS protocols.
   - **Email**: Links in the mailto format that open a pre-addressed email.
   - **Newsgroups**: Links in the news. format that typically open a newsreader program.
   - **FTP**: File upload and download locations accessible through the FTP protocol.
   - **RSS**: Episodic content, such as blogs and podcasts.
   - **Remote Access**: Locations accessible through the Telnet and Secure Shell (SSH) protocols.

4. Choose one of the following:
   - **Default**: The link opens in the application or program set as default in the operating system (Mac OS X or Windows) where you click the link.
   - **Open in Windows**: Links clicked in Mac OS X or Windows open in the default Windows program for that link type.
   - **Open in Mac**: Links clicked in Mac OS X or Windows open in the default Mac OS X application for that link type.

Open the Current Safari Page in Internet Explorer

Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in Mac OS X using Safari, you can quickly open the current page in Internet Explorer by doing the following:
First you need to install the “Open in Internet Explorer” plugin. Do one of the following:

- Click the Parallels icon in the menu bar and choose Configure.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

Click Options and select Web & Email.

Click Install Plugin.

Once the plugin is installed, click the Open in IE button in the toolbar.

If Windows isn’t already open, it starts up and the page opens in Internet Explorer.

Share External Storage Devices and Volumes

When you connect an external storage device, such as a USB drive, to your Mac, you can access the contents from Mac OS X applications.

Using SmartMount, you can set Parallels Desktop to automatically mount storage devices and volumes to Windows. That way, you can access the contents from both Mac OS X and Windows.

With SmartMount enabled, these items are automatically mounted to Windows:

- **Removable drives**: External storage devices, such as USB hard disks and USB flash drives.
- **CD/DVD drives**: CD and DVD drives or CD/DVD images (files most commonly ending in `.dmg`, `.iso`, and `.img`).
- **Network folders**: Folders shared over the network.

To enable SmartMount:

1. Start Windows. (p. 31)
2. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
3. Click Options and select Sharing > Share Mac.
4. Select Map Mac volumes to Windows.

When you connect a storage device or volume, it is mounted as a network drive. For example, a USB flash drive plugged in to your Mac will be accessible from both the `/Volumes` folder in Mac OS X and My Computer in Windows.
Use Windows on Your Mac

Note: Permissions for accessing the mounted device from Windows are the same as permission settings for the device in Mac OS X. For example, if you can read from and write to a USB flash drive in Mac OS X, you can also read from and write to it in Windows. One exception: Mac OS X can’t write to NTFS volumes, regardless of permissions.

Use a Disk Image with the Virtual DVD Drive

While working in Windows, you can select a disk image file to be used with the virtual Windows DVD drive, as if it was a DVD inside a real drive. To do so:

1 In Windows Explorer, open Computer or This PC, right-click the DVD drive icon, and choose Select disk image.
2 Locate the disk image you want to use and click Open.

Note: This functionality is available only for Windows with Parallels Tools installed (p. 199).

Save Internet Passwords in Mac Keychain

Nowadays, users don’t have to remember numerous passwords to various social media accounts and websites. Your Mac can store and automatically fill them in when necessary.

If you browse the Internet in Windows using Internet Explorer or Microsoft Edge, you can set to store your passwords in Mac keychain. If you do so, the passwords you enter in Internet Explorer or Microsoft Edge will be saved to Mac keychain and you will be able to auto fill them from these browsers. These passwords won’t be accessible to any other applications and won’t be lost if Windows gets corrupted or reinstalled.

To store Internet passwords in Mac keychain:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.
2 Click Options and select Web & Email.
3 Select Store Internet passwords in Mac keychain.

Apply Mac OS X Parental Controls to Windows

If you have administrator rights in Mac OS X, you can use parental controls to prevent others with accounts on your Mac from using certain Windows programs or accessing certain web sites.

To apply parental control settings:

1 In Mac OS X, choose Apple menu > System Preferences and click Parental Controls.
2 Click the lock if it’s not unlocked, and then enter an administrator name and password.
3 Select the account that you want to restrict, click **Enable Parental Controls**, and set up the controls. If you want the user to be able to use some Windows programs, be sure to select Parallels Desktop in the list of allowed applications.

For more information on using parental controls, see Mac Help.

**Set Media Files to Open in Windows 8 Apps**

When you install Windows 8, Parallels Desktop sets most types of media files (photos, pictures, music, and video) to open in classic Windows desktop applications.

To set media files to open in Windows 8 apps by default, do the following:

1 Start Windows 8.
2 From the Start screen, right-click or Control-click anywhere on the screen and click **All Apps**.
3 Open **Control Panel**.
4 Choose **Programs > Default Programs > Associate a file type or protocol with a program**.
5 In the list of file extensions, select the file extension for which you want to change the default program, then select **Change program** and select the program you want to use with that type of file.

**Mouse, Trackpad, and Keyboard**

Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the way you want them to.

You can also use trackpad gestures or the optional Apple Remote to control Windows programs just as you can with Mac OS X applications.

Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows programs.

**Set Your Mouse or Trackpad to Right-Click and Middle-Click**

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking.

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click the mouse. You can change which key combination triggers a right-click.

You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse (included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current Apple desktop computers), you can set the mouse to allow right-clicking.
Most other mice are pre-configured for right-clicking.

**Set the Trackpad for Right-Clicking.**

1. Choose Apple menu > System Preferences and click Trackpad.
2. Select Secondary Tap.

Now you can tap the trackpad with two fingers to imitate a right-click.

**Set an Apple Mighty Mouse for Right-Clicking**

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Choose Secondary Button from the menu to the right of the mouse.

Now you can press the right side of the mouse to right-click.

**Set an Apple Magic Mouse for Right-Clicking**

1. Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.
2. Select Secondary click.

Now you can press the right side of the mouse to right-click.

**Set Which Key Combination Triggers a Right-Click or a Middle-Click**

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2. Click Shortcuts.
3. If necessary, click the lock icon and enter an administrator password.
4 Select **Mouse Shortcuts** in the sidebar.

5 Select **Secondary click** (for right-click) or **Middle click**.

6 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.

You can use any combination of the Control, Option (Alt), Shift, and Command keys.

**Control Programs with Trackpad Gestures or the Apple Remote**

You can use the Apple Remote to control some Windows programs. If you have an Apple portable computer, such as a Macbook, or if you have an Apple Magic Trackpad, you can use gestures, such as swiping left or right across the trackpad, to control some Windows programs.

**Note:** You can control some Windows programs using three-finger swipes only if you’re using Parallels Desktop with Mac OS X Snow Leopard. In OS X Lion and later, three-finger swipes are used by default to move between full-screen apps and spaces.
To use the Apple Remote, you must first enable it by doing the following:

1. Start Windows (p. 31).
2. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
3. Click Options, and then click Advanced.
4. Select Enable next to Apple Remote.

The following table provides commands to control some of the more popular Windows programs.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard and Mouse Combination</th>
<th>Apple Remote</th>
<th>Touchpad Gesture</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scroll</td>
<td>Up, down, left, or right arrow</td>
<td>n/a</td>
<td>Swipe up, down, left, or right with two fingers</td>
</tr>
<tr>
<td><strong>Microsoft Power Point</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start slide show</td>
<td>F5</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>End slide show</td>
<td>Esc</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Perform the next animation or advance to the next slide</td>
<td>N, Enter, Page Down, Right Arrow, Down Arrow, Space (or click the mouse)</td>
<td>n/a</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Perform the previous animation or return to the previous slide</td>
<td>P, Page Up, Left Arrow, Up Arrow, Backspace</td>
<td>n/a</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up /Ctrl+wheel down</td>
<td>n/a</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Microsoft Word/Excel</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up /Ctrl+wheel down</td>
<td>n/a</td>
<td>Pinch open/pinch close</td>
</tr>
<tr>
<td><strong>Windows Media Player</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start/pause playback</td>
<td>Space</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Skip to the next song</td>
<td>Ctrl+F</td>
<td>n/a</td>
<td>Swipe right with three fingers</td>
</tr>
<tr>
<td>Play the previous song</td>
<td>Ctrl+B</td>
<td>n/a</td>
<td>Swipe left with three fingers</td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td><strong>Media Player Classic (k-lite)</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start playback/pause</td>
<td>Space</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Shortcuts</td>
<td>Notes</td>
<td></td>
</tr>
<tr>
<td>---------------------------</td>
<td>--------------------------------</td>
<td>----------------------------</td>
<td></td>
</tr>
<tr>
<td>Volume up</td>
<td>F8, Up Arrow, wheel up</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Volume down</td>
<td>F9, Down Arrow, wheel down</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td><strong>Winamp</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start playback/pause</td>
<td>X to start, C to pause</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Volume up</td>
<td>Up Arrow, wheel up</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Volume down</td>
<td>Down Arrow, wheel down</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td><strong>Microsoft Internet Explorer</strong></td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>n/a or Swipe right with three fingers</td>
<td></td>
</tr>
<tr>
<td>Page back</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page forward</td>
<td>Option+Right Arrow (Alt+Right Arrow)</td>
<td>n/a or Swipe left with three fingers</td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/Ctrl+wheel down</td>
<td>n/a or Pinch open/pinch close</td>
<td></td>
</tr>
<tr>
<td><strong>Mozilla Firefox</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page back</td>
<td>Backspace, Option+Left Arrow (Alt+Left Arrow)</td>
<td>n/a or Swipe right with three fingers</td>
<td></td>
</tr>
<tr>
<td>Page forward</td>
<td>Option+Right Arrow (Alt+Right Arrow)</td>
<td>n/a or Swipe left with three fingers</td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>Ctrl+wheel up/ Ctrl+wheel down or Ctrl+”/Ctrl-“</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Windows Picture and Fax Viewer</strong></td>
<td>Right Arrow</td>
<td>n/a or Swipe right with three fingers</td>
<td></td>
</tr>
<tr>
<td>Next image</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Previous image</td>
<td>Left Arrow</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom in/zoom out</td>
<td>“/” or Pinch open/pinch close</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Rotate clockwise</td>
<td>Ctrl+K</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Rotate counterclockwise</td>
<td>Ctrl+L</td>
<td>n/a</td>
<td></td>
</tr>
</tbody>
</table>

### Use Keyboard Shortcuts

Both Mac OS X and Windows provide extensive keyboard shortcuts. For example, in Mac OS X you can hold down the Command key and press Q (Command-Q) to quit the current application.

To enter a keyboard shortcut, simply press a key combination on your keyboard.
Use Windows on Your Mac

You can also enter keyboard shortcuts by doing one of the following:

• Click the Parallels icon in the menu bar, then choose Devices > Keyboard and choose a key combination.
• Choose Devices > Keyboard and choose a key combination.

These methods are most useful for using keyboard shortcuts that include keys not included on a Mac keyboard, such as Alt + PrintScreen.

Note: To use the F1-F12 keys on a MacBook, press and hold the Fn key and then press an F key.

Customize Keyboard Shortcuts

By default, Parallels Desktop maps common Mac OS X keyboard shortcut key combinations to the equivalent Windows key combinations. That way if you’re used to, for example, pressing Command-C to copy text in Mac OS X, you don’t have to switch to the Windows equivalent, Control-C.

You can also use and customize keyboard shortcuts for switching between Coherence, Full Screen, and Window view modes, and for showing and hiding Parallels Desktop.

Customize Keyboard Shortcuts

1. Do one of the following:
   • Click the Parallels icon in the menu bar and choose Preferences.
   • Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2. Click Shortcuts
3. Select Windows from the Virtual Machines list in the sidebar.
Or if you're using another operating system with Parallels Desktop and you want to customize keyboard shortcuts for it, select it in the sidebar.

![Screenshot of Parallels Desktop shortcuts]

When you're using a Windows application, pressing a key combination in the From column above triggers the key combination in the To column.

4 If the lock icon is locked, click it and enter an administrator password.

5 Do one of the following:
Use Windows on Your Mac

- To edit an existing key combination, double-click the key combination or select it and click the **Edit** button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

- To delete a key combination, select it and click the **Remove** button.

- To add a new key combination, click the **Add** button.

If you’re using multiple operating systems with Parallels Desktop, you can create keyboard profiles for each OS (p. 135).

**Note:** 1. Some key combinations can’t be edited or deleted.

2. There are Mac shortcuts that do not have similar shortcuts in Windows For example, you can use the F11 key or Fn+F11 combination to see your Mac OS desktop with Expose, but in Windows there are no keys or key combinations that enable you to perform the same action, because there is no Expose in Windows.

Enable or Disable Mac OS X System Shortcuts

In Mac OS X the function keys on your keyboard (F1, F2, F3 and so on) control functions like activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. By default, when a Windows application is active the function keys and other Mac system shortcut key combinations (such as pressing Cmd + Tab to switch between open applications) continue to activate Mac OS X functions.

To set whether function keys and OS X system shortcut key combinations activate functions in OS X or Windows:

6. **Click OS X system shortcuts** in the sidebar.

7. Select one of the following from the **Send OS X system shortcuts** menu:
   - **Always:** When Windows or Windows applications are active, function keys and other system shortcuts always trigger functions in Windows.
   - **Never:** Function keys and other system shortcuts always trigger functions in OS X.
   - **Auto:** If you’re working with Windows, system shortcuts that don’t function in Windows (for example, Control-Up Arrow button to display Mission Control) trigger functions in OS X. If you’re using OS X as a guest OS and a guest OS or its application is active, system shortcuts that are typical only to OS X trigger functions in the guest version of OS X.
Customize Keyboard Menu

In Window mode you can enter key combinations by choosing **Devices > Keyboard** and then choosing a key combination. To customize available key combinations, do the following:

8. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Preferences**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Parallels Desktop > Preferences**.

9. Click **Shortcuts > Keyboard Menu**.

10. If the lock icon is locked, click it and enter an administrator password.

11. Do one of the following:
   - To add a new key combination, click the **Add** button.
   - To remove a key combination from the Keyboard menu, select it and click the **Remove** button.
   - To edit an existing key combination, double-click the key combination or select it and click the **Edit** button. Click modifier keys to select or deselect them. If you wish, change the character in the text field.

Create New Keyboard Shortcuts

You can press certain key combinations, called keyboard shortcuts, to quickly trigger various actions in Parallels Desktop. For example, you can press Command-Control-F to switch Windows to Full Screen mode. You can use existing keyboard shortcuts (you can see them in the **Parallels Desktop > Preferences > Shortcuts > Application Shortcuts** pane), and you can also create your own.

To create a new keyboard shortcut:
1 Make a note of the name for the command you want a shortcut for as it appears in a menu in Parallels Desktop. For example, if you want to create a new shortcut for switching to Full Screen mode, you can see by opening the View menu in Parallels Desktop that the name of the menu item is *Enter Full Screen*:

![Parallels Desktop View menu](image)

2 In Mac OS X, choose **Apple Menu > System Preferences.**

3 In System Preferences, click **Keyboard** and click **Shortcuts.**

4 Select **App Shortcuts** in the sidebar and click the Add button.

5 If you want a new shortcut to work only for Parallels Desktop, choose Parallels Desktop from the **Application** menu. If you leave **All Applications** selected, the shortcut will work for any application that has the same command name and is currently active.

6 Enter the menu item name from Step 1.

   **Important:** You must enter the command name exactly as it appears in the Parallels Desktop menu or your new shortcut won’t work.

7 In the **Keyboard Shortcut** field, press the key combination that you want to trigger the action.

   **Note:** You must create separate shortcuts for commands that change in the menu depending on the state of Parallels Desktop, such as **Enter Full Screen** and **Exit Full Screen.**

---

## See and Change Windows Input Language In OS X

While you’re working with Windows or any Windows applications, Parallels Desktop shows the input language set in Windows in OS X menu bar. You may find it useful while working with Windows in Coherence (p. 41) when the guest OS desktop is hidden.

![Parallels Desktop menu bar](image)

As soon as you switch to Mac, the input language in OS X menu bar changes back to the language that was set before you started working with Windows.

To make this feature work properly, Parallels Tools (p. 142) must be installed and the same input languages must be available in Windows and OS X. To learn how to add input languages, please refer to the help resources for these operating systems.
Change Windows Input Language From OS X Menu Bar

To change the Windows input language from the OS X menu bar:

1. Click Windows or your Windows application to make it active.
2. Choose the language you need from the Input menu available in the OS X menu bar.

**Note:** The language you’re selecting from the Input menu must be also available in Windows. To learn how to add a language to the list of input sources in Windows, please refer to the Windows help resources.

If the Input menu isn’t available in OS X menu bar, you can set it to show by doing the following:

1. In Mac OS X, choose Apple menu > System Preferences and click Language & Text.
2. Click Input Sources.
3. Select the language or languages you want to use from the sidebar.
4. Select Show input menu in menu bar.

Mouse & Keyboard Settings

Use Mouse & Keyboard settings, you can:

- Set whether the mouse pointer behavior is optimized for games.
- Set whether the mouse pointer sticks at the edges of the window in Window mode (p. 43).
- Set whether modifier keys are optimized for games.

To access Mouse & Keyboard settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Click **Hardware** and select **Mouse & Keyboard** in the sidebar.

Mouse

If you play games in a virtual machine, the **Mouse** menu allows you to set how to use a mouse:

- **Auto-detect for games.** This is a recommended default setting. If you’re working with a guest OS application, the mouse moves freely between the guest operating system and Mac OS X. However, when you start a game, SmartMouse automatically captures the mouse input in the virtual machine so that you couldn’t move the mouse to Mac OS X by mistake and automatically releases the mouse when you quit the game.

- **Optimize for games.** If your mouse accidentally moves to Mac OS X when you’re playing a game, select this option to make the mouse work in the virtual machine only.

- **Don't optimize for games.** In some rare cases, SmartMouse may detect an application as a game and the mouse starts working incorrectly with the application. If you have this problem, choose **Don't optimize for games.**
Mouse Pointer Sticks at Edges

When working with a virtual machine in Window view mode (p. 43), you may often need to move the mouse pointer to the edges of the virtual machine window to display various guest OS items: for example, to display the Start menu in Windows 8, hidden taskbar in Windows XP, or OS X menu bar when any of the guest OS X applications is running in full screen.

The Mouse pointer sticks at window edges option makes the mouse pointer pause for a while at the edges of the virtual machine window and you won’t move the mouse outside of the virtual machine window by mistake. To move past the edge, just move the mouse quickly.

Modifier Keys Optimization

Choose Optimize for games from the Keyboard menu if you actively use the modifier keys Option (Alt), Ctrl, and Shift in action games. If you choose this option, signals from these keys will be processed faster.

Note: You’re not recommended to optimize keyboard for games when not playing games.

Connect External Devices

Parallels Desktop allows you to use USB, Thunderbolt, and FireWire devices with Windows.

Many external devices, such as mice and printers, are available by default to both Windows and Mac OS X when you connect them to your Mac.

Some external devices, such as an Apple iPhone, can only be used with either Mac OS X applications or Windows programs, but not both at the same time. When you connect such a device, you can choose whether you want to use it with Mac OS X or Windows.

To connect an external device:

1. Connect the device to your Mac.
2 If Windows is running and the device can’t be used with both Windows and Mac OS X at the same time, you’re prompted to choose which one you want to use it with. To use the device with Mac OS X applications, click the Mac icon. To use it with Windows programs, click the Windows screen.

You can connect up to 12 USB 3.0 (p. 196), 15 USB 2.0 and 32 USB 1.1 devices to your Mac and use them with Windows. You can connect and use up to 30 USB printers.

**Important:** To be able to use a USB device with Windows programs, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer’s website.

You can also set what happens when any new external device is connected and set particular external devices to always be used with either Mac OS X or Windows (p. 79).
Connect a Common Access Card reader

A Common Access Card (CAC) reader can work simultaneously in Mac OS X and Windows.

1. Connect the CAC reader to your Mac.
2. When you're prompted to choose Windows or the Mac, click the Windows screen. The CAC reader becomes available to both Windows and Mac OS X.

Adjust Devices Settings

In the **Devices** pane of Parallels Desktop Preferences, you can:

- Set what happens when you connect any new USB, Thunderbolt, or FireWire device to your Mac.
- Set a particular external device to always be used with either Mac OS X or Windows.
Use Windows on Your Mac

• Choose to mount Windows-connected external NTFS drives to Mac.

To access Devices Settings:

1. Do one of the following:
   • Click the Parallels icon ‼️ in the menu bar and choose Preferences.
   • Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2. Click Devices.

Set What Happens When You Connect a New External Device to Your Mac

Choose one of the following:

• Connect it to my Mac. New external devices are automatically available for use with Mac OS X applications.
• **Connect it to the active virtual machine.** New external devices are automatically available for use with Windows programs. If Windows isn’t running, the external device is connected to Mac OS X.

• **Ask me what to do.** Each time you connect an external device, you’re prompted to choose whether you want to connect the device to Windows or the Mac.

### Set a Particular External Device to Always Be Used With Mac OS X or Windows

If you know you always want a particular external device to be available to either Mac OS X or Windows, you can set it to do so by following the instructions below. The device must already have been connected to your Mac at least once.

1. Click the **Add (+)** button towards the bottom of the window.
2. Select the device from the list.
3. Double-click the word (either **Computer** or some form of **Windows**) in the **Connect To** column. The word becomes a pop-up menu.
4. Do one of the following:
   - To set the device to always be available to Mac OS X applications, choose **Computer** from the menu.
   - To set the device to always be available to Windows programs, choose **Windows** from the menu.

To remove an existing assignment, so that the device no longer automatically connects to Mac OS X or Windows, select the device in the **External Device** column and click the **Remove (-)** button.

**Important:** To be able to use an external device with Windows programs, you may need to install Windows drivers for the device. Typically you can download drivers from the manufacturer’s website.

### Mount Windows-connected external NTFS drives to Mac

If you connect an external NTFS drive to Windows, you can make it available in OS X as well. To do so, choose **Mirror Windows-connected drives on Mac**.

### Connect Bluetooth Devices

Parallels Desktop lets you connect Bluetooth devices directly to Windows.

Before connecting a Bluetooth device, Bluetooth must be enabled.

To enable Bluetooth:

5. If Bluetooth is turned off in Mac OS X, turn it on. Choose **Apple menu > System Preferences** and click **Bluetooth**. Then select **On**.
6 In Parallels Desktop, start Windows (p. 31) if it isn’t already started.

7 Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

8 Click Hardware and click USB & Bluetooth in the sidebar.

9 Select Bluetooth devices.

Once you’ve enabled Bluetooth, you can pair Bluetooth devices with your computer and they’ll work with both Windows and Mac OS X. For instructions on pairing a Bluetooth device with your computer, see the documentation that came with the device.

In Windows 7, you can send a file to a paired Bluetooth device that’s capable of receiving files by right-clicking the file and choosing Send to > Bluetooth.

Besides Windows, you can connect Bluetooth devices to any guest operating systems (Linux or Mac OS X) that support USB Bluetooth adapters.

Print from Windows

By default, Windows is set to use the same printer that you use with Mac OS X. Simply print from a Windows program the way you normally would.

You can also set Windows to use a different printer. There are a few ways to set up printing in Windows:

- Share any of the printers connected to your Mac.
- Connect to a network printer.
- Connect a USB printer directly to Windows.

Share a Printer Connected to Your Mac

You can use any printer connected to your Mac with Windows programs.

Note: This functionality is also available for Linux with Parallels Tools installed (p. 143).

To print a document from a Windows program:

- Open the document and simply print it the way you normally would (for example, choose File > Print).

In the print window, you can choose any printer that’s connected to your Mac.
Share Printers Connected to Your Mac

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and select Shared Printers.

   **Note:** The Shared Printers pane is available for Windows 2000 and newer versions of Windows.


Set a New Default Printer

By default, Windows is set to use the same default printer as your Mac. To use a different default printer for Windows.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and select Shared Printers.

3. Deselect Synchronize default printer.

Now you can set a new default printer in Windows the way you normally would.

Show Page Setup Before Printing

When you choose to print a document from Windows, first you need to set how the document will be printed. You usually have to specify various printing settings, such as orientation, page size, whether to print the document on one or both sides, etc. Once everything is ready and you click Print in Windows, the OS X window with printing settings appears as well. It’s done by default for you just to ensure that the document will be printed exactly the way you want.

To make the documents print without showing this OS X page setup window:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and select Shared Printers.

3. Deselect Show page setup options before printing.
Add a Printer in Linux

The procedure of adding a printer in a Linux guest operating system depends on the Linux distribution. In this example, we describe how to add a printer to a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to add a printer to a Linux virtual machine:

1. Start the Linux virtual machine and log in when the guest operating system boots up.

   **Note:** You must log in as root or acquire root privileges after successful login. If you don’t do that, you will be required to enter the root password when starting the `system-config-printer` administration tool in the next step.

2. Start the `system-config-printer` administration tool by doing one of the following:
   - Click **System > Administration > Printing**; or
   - Start the Terminal and enter the following command:

```
   system-config-printer
```

3. In the displayed window, click **New Printer**.

4. In the next window, you must type a printer name. Under this name the printer will be displayed in your Linux guest operating system. You can also enter the printer description and location. When ready, click **Forward**.

5. Now you have to specify how your Mac printer will be shared with the virtual machine. As the printer is connected to the virtual machine printer port, select **LPT #1** (or another port to which the printer is connected) and click **Forward**.

6. Then specify the printer manufacturer and model. No matter what printer you have, choose either **HP Color LaserJet 8500 PS** or **Apple Color LW 12/660 PS**. When ready, click **Forward**.

7. Click **Apply** to finish setting up the printer.

Now the printer is properly configured and you can use it to print documents from your Linux virtual machine.

Set Up a Printer Using Bonjour

If you have more than one Mac connected to your home network, you can use Apple Bonjour for Windows to share any printer connected to any of them.

To see the list of all Windows operating systems supported by Bonjour, please refer to [http://support.apple.com/kb/dl999](http://support.apple.com/kb/dl999).

**Important:** To share a Mac printer with Windows via Apple Bonjour, Windows must be configured to work in the Bridged networking mode.

To set up a printer via Bonjour:
Use Windows on Your Mac

1. Be sure the printer you want to use is set to be shared on your Mac. To share a printer, in Mac OS X choose **Apple menu > System Preferences** and click **Print & Fax**. Then select the printer and select **Share this printer**.

2. Open Parallels Desktop and start Windows.


4. In Windows, start the Bonjour installation by launching the **BonjourPSSetup.exe** file from the folder in which it was downloaded.

5. Follow the onscreen instructions to install Bonjour for Windows.

6. Start the Bonjour Printer wizard either by double-clicking its icon on the desktop or by selecting **Start -> All Programs -> Bonjour Print Services -> Bonjour Printer Wizard**.

7. In the **Browse for Bonjour Printers** window, select the printer that you want to use and click **Next**.

8. If the next window you see is **Completing the Bonjour Printer Wizard**, then the driver required by this printer is available in the Windows driver library and the printer has been successfully configured. Click **Finish** and you can start using the newly added printer to print documents from Windows programs.

   However, if the next window you see is **Install Bonjour Printer**, you must choose the printer manufacturer and model.

   ![Bonjour Printer Wizard](image)

   If the required printer model is not listed, you can do one of the following:
• Install the printer drivers in Windows. Then click **Have Disk** button in the **Install Bonjour Printer** window and specify the path to the `.inf` file located in the folder where you installed the printer drivers.

• In the **Install Bonjour Printer** window, select **Generic** in the **Manufacturer** list and **Generic/Postscript** in the **Model** list.

Click **Next**.

9 In the **Completing the Bonjour Printer Wizard** window, click **Finish**. You can start using the newly added printer to print documents from Windows programs.

### Set Up a Network Printer

You can install a network printer directly into Windows.

Before installing a network printer in Windows, make sure that:

• Your Mac can access the Internet.

• Windows is configured to work in either the Shared networking mode (p. 95) or Bridged networking mode and can access the Internet too.

• The user account in Windows has permission to access the network printer.

• You know the printer IP address.

After that, you can log in to Windows and install a network printer.

### In Windows

Before adding a network printer in Windows, download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer documentation.

To add a network printer in Windows 7 or Windows Vista:

1. Open the Windows **Start** menu and select **Control Panel**.

2. In the **Control Panel** window, select **Hardware and Sound** and click **Add a printer** in the **Devices and Printers** section (**Printers** in Windows Vista). The Add Printer wizard opens.

3. In the first window, click **Add a network, wireless or Bluetooth printer**.

4. In the next window, click **The printer that I want isn't listed**.

5. In the **Find a printer by name or TCP/IP address** window, select **Add a printer using a TCP/IP address or hostname** and click **Next**.

6. In the **Type a printer hostname or IP address** window, do the following:
   1. Select **TCP/IP Device** from the **Device type** menu.
   2. Specify the printer IP address in the **Hostname or IP address** field.
3. Clear the **Query the printer and automatically select the driver to use** option if it is selected.

4. When ready, click **Next**.

7 If prompted to specify additional port information, choose **Standard**, select **Generic Network Card** from the list, and click **Next**.

8 In the **Install Printer Software** window, specify the manufacturer and model of the network printer.

   If the required printer model is not listed, click **Have Disk** button and specify the path to the .inf file located in the folder where you installed the printer driver.

   When ready, click **Next**.

9 Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.

To add a network printer in Windows XP:

1 Open the Windows **Start** menu and select **Control Panel**.

2 In the **Control Panel** window, double-click the **Printers and Faxes** item.

3 Click the **Add a printer** link to open the Add Printer wizard.

4 In the **Welcome to the Add Printer Wizard** window, click **Next**.

5 In the **Local or Network Printer** window, select **Local printer attached to this computer** and clear the **Automatically detect and install my Plug and Play printer** option if it is also selected. When ready, click **Next**.

6 In the **Select a Printer Port** window, select **Create a new port** and specify **Standard TCP/IP Port** as the port type. When ready, click **Next**.

7 In the **Welcome to the Add Standard TCP/IP Printer Port Wizard** window, click **Next**.

8 In the **Add Port** window, specify the network printer IP address and click **Next**.

9 If prompted to specify additional port information, choose **Standard**, select **Generic Network Card** from the list, and click **Next**.

10 In the **Completing the Add Standard TCP/IP Printer Port Wizard** window, click **Finish**.

11 In the **Install Printer Software** window, specify the manufacturer and model of the network printer.

   If the required printer model is not listed, click **Have Disk** button and specify the path to the .inf file located in the folder where you installed the printer driver.

   When ready, click **Next**.

12 Continue with the printer configuration procedure. When the printer is added to Windows, you can use it to print documents from Windows XP.
In Linux

The procedure of setting up a network printer in a Linux or FreeBSD guest operating system depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set up a network printer in a virtual machine running RHEL 5.4 Server. However, you can use these guidelines as general instructions on how to set up a network printer in a Linux or FreeBSD virtual machine.

Note: For more detailed information, refer to the CUPS documentation.

To set up a network printer:

1. Start the virtual machine.
2. Make sure the following components are installed in the guest operating system:
   • Common UNIX Printing System (CUPS). Installation instructions can be found at CUPS site;
   • Samba service. Installation instructions can be found at Samba site; and
   • A Web browser, since we consider controlling CUPS via web interface.
   
   Note: To set up a network printer, you should have root privileges.

3. Download and install an appropriate printer driver. For detailed information on installing the printer driver, refer to the printer manufacturer’s documentation.

4. Start Common UNIX Printing System. In the Terminal, type the command:
   
   /etc/init.d/cups start

5. Start a web browser and type either the IP address of your virtual machine or http://127.0.0.1:631.

6. Click the Add Printer button.

7. In the Add New Printer window, specify a printer name. Under this name the printer will be displayed in the guest operating system. You can also enter the printer description and location. When ready, click Forward.

8. In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click Continue.

9. In the Device URI for <Printer Name> window, specify the printer IP address in the following format:
   
   socket://<printer IP address>

   When ready, click Continue.

10. In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your printer and click Continue.

11. In the Model/Driver for <Printer Name> window, select the model of your printer and click Add Printer.

12. Enter the root password when prompted.
CUPS performs the installation. If the installation is successful, the "Printer <name> has been configured successfully" message is displayed. Now you can use this printer to print documents from the virtual machine.

Set Up a USB Printer

You can connect a USB printer directly to Windows. In this case, the printer isn’t available to Mac OS X. If you want to use the printer to print both from Mac OS X and from Windows, see Share a Mac Printer (p. 82).

To connect a USB printer directly to Windows:

1. In Parallels Desktop, start Windows.
2. When Windows starts, install the printer driver. For detailed information on how to do that, refer to the printer manufacturer’s documentation. Typically you can find drivers on the manufacture’s website.
3. Do one of the following:
   • If the USB printer is already connected to your Mac:
     • If Windows is in Coherence, click the Parallels icon in the menu bar, choose Devices > USB and select this printer from the list.
     • If Windows is working in a separate window, in the Mac menu bar click Devices > Printer > Printer and select this printer from the list.
     • If the USB printer is not connected to your Mac, connect it. In the New USB device detected window, connect the printer to Windows.
4. In Windows, follow the Add New Hardware wizard instructions.

Create a PDF File

When working with a text document, web page, or other file, you may wish to create a Portable Document Format (PDF) file out of it. A PDF file preserves the format and layout of a document, so others can see it as if it were printed on the page.

To create a PDF file, select Print to PDF (Mac Desktop) when choosing a printer. A PDF file is saved on the Mac desktop.

**Note:** This functionality is available for Windows guest operating systems provided that Parallels Tools are installed (p. 140) and all Mac printers are shared (p. 82) with Windows.
Use Windows on Your Mac

Use the Built-in iSight Camera or Another Webcam

If your Mac or display has a built-in iSight camera, or if you connect a compatible external webcam, by default you can use it with Windows.

To use a built-in iSight or external camera with Windows:

- Simply open a Windows program that uses a camera, you should be able to select the iSight or external camera for use with the program.

**Note:** If you are running a guest OS other than Windows XP Service Pack 2 or later, Windows Vista, or Windows 7, be sure you have USB video device class (UVC) drivers installed.

Disable Camera Sharing

If you don’t want Windows programs to be able use connected webcams or the built-in iSight camera, you can disable camera sharing by doing the following:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Hardware and click USB & Bluetooth.
3. Deselect Web cameras.

Show a Presentation on an External Monitor or Projector

You can easily connect your Mac to an external monitor or projector and show a presentation from a Windows application, with little configuration needed.

To do so:

1. Start Windows (p. 31) if it isn’t already running.
2  Connect your Mac to the external monitor or projector as you normally would. A message appears asking if you’re going to show a presentation.

3  If you want to show the exact contents of your computer’s display on the external display or projector, select **Use Mirroring**.

   If you don’t select **Use Mirroring**, certain applications, such as Microsoft Powerpoint, may show a presenter view on your computer while showing only the presentation on the external display or projector.

4  Click **Yes**. Windows switches to Presentation mode, displayed at full screen on both your computer’s display and external display or projector. After that, you can start showing your presentation.

   **Note:** To learn how to choose on which display the presentation is shown, please refer to Help of the application you’re using for presentations.

   **Important!** While you’re working in Presentation mode, changing display settings in Windows may cause the presentation to malfunction.

**Protect Your Data**

You probably have important documents, photos, and more on your Mac. When running Windows on your Mac, it’s especially important to protect your data from viruses and unauthorized use. Read this section to learn how.
In This Section

Protect Your Data from Viruses ................................................................................ 92
Isolate Windows from Mac ....................................................................................... 93
Work in Windows Without Saving Changes .............................................................. 93
Set Password Requirements .................................................................................... 94
Encrypt Windows to Protect It from Unauthorized Use ............................................. 94

Protect Your Data from Viruses

Parallels Desktop offers complementary trial subscription to Kaspersky antivirus software for both Mac OS X and Windows.

To take advantage of this offer, you download and install Kaspersky Internet Security for Windows and for the Mac. When the trial period expires, you can purchase a permanent activation key.

Download and Install Antivirus Protection for Windows

1. Open Parallels Desktop and start Windows.
2. Click the Parallels icon in the menu bar and choose Actions > Install Internet Security and follow the onscreen instructions.

**Note:** To install antivirus protection for Windows, Parallels Tools must be installed (p. 199). In most cases, Parallels Tools are installed by default.

Remove Antivirus Protection from Windows

To remove Kaspersky Internet Security, remove it the same way you’d remove any other Windows application. See Windows Help and Support for more information.

Download and Install Antivirus Protection for Mac

1. If Parallels Desktop is set to Coherence mode, click the Parallels icon in the menu bar and choose View > Exit Coherence.
2. Choose Parallels Desktop > Install Antivirus for Mac and follow the onscreen instructions.

Remove Antivirus Protection for Mac

Choose Uninstall Antivirus for Mac from the Parallels Desktop menu and enter your administrator name and password.
Isolate Windows from Mac

You can isolate Windows from OS X, so that they no longer share folders, profiles, and applications, connected external devices are no longer automatically accessible by Windows, Windows and Mac no longer synchronize volume, and you can no longer copy or move objects between Windows and OS X. Isolating Windows from OS X may provide a higher level of security by not allowing compromised items from one OS to come into contact with the other.

To isolate Windows from OS X

1  Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2  Click Security.
3  Select Isolate Windows from Mac.

Work in Windows Without Saving Changes

If you don’t want Windows to store the changes you make to it during the working session (for example, when testing some Windows programs that may damage Windows), you can start Windows in Rollback Mode:

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

1  Open Parallels Desktop.
2  From Control Center select Windows that you want to start in Rollback Mode and click Actions > Start in Rollback Mode.

Set Windows to Always Start in Rollback Mode

If you want Windows to always start in Rollback Mode:

1  Open Parallels Desktop.
2  From Control Center select Windows and click Actions > Configure > Security.
3  Choose Ask me what to do from the Rollback Mode menu.

**Note:** If you have the automatic compression of virtual disks (p. 100) enabled, it will become disabled after you enable Rollback Mode.
Set Password Requirements

For added security, you can set Parallels Desktop to require an administrator password to perform certain functions.

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Security.

3. Select one or more of the following to require a Mac OS X administrator password to perform the selected action:
   - **Exit full screen mode**: A password is required to exit full screen mode (p. 43).
   - **Change virtual machine state**: A password is required to start, stop, suspend, pause, or shut down (p. 36) Windows.
   - **Manage snapshots**: A password is required to create or delete a snapshot (p. 121), or revert to a snapshot.

Encrypt Windows to Protect It from Unauthorized Use

If you store any important data using Windows programs, it is highly recommended that you encrypt Windows to protect your data from any unauthorized use.

Encrypt Windows

To encrypt Windows (it must be shut down):


2. On the Security tab, click Turn On, specify a password, and click OK.

**Warning:** The specified password is very important. You must record it. Without this password, you can't start Windows.

Change Your Password

To change the password for an encrypted Windows (it must be shut down):


2. On the Security tab, click Change Password, specify a new password, and click OK.
Remove Encryption from Windows

To remove encryption from Windows (it must be shut down):

1. Select Windows and click **Actions > Configure > Security**.
2. On the **Security** tab, click **Turn Off**.

Connect to the Internet or a Network

Parallels Desktop allows you to use three types of networking with Windows:

- **Shared Networking**: Windows programs share a network connection with Mac OS X. This is the default setting.
- **Bridged Ethernet**: Windows can use one of your Mac’s network adapters. This makes Windows appear as a separate computer on the network.
- **Host-only networking**: Windows can access only your Mac.

In most cases, you don’t need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows programs have access to the same network and the Internet.

The Bridged Ethernet networking mode is more complex and you may need to contact your system administrator to set it up properly.

Read on for detailed information on these types of networking and how to configure them.

Share Network Settings Between Mac OS X and Windows

By default, Windows is set to share network settings with Mac OS X. Windows programs can access other computers on your local network and the Internet by using the IP address of your Mac. Windows does not have its own IP address on the network.
In most cases, you don’t need to adjust network settings. If your Mac is set to connect to a network or to the Internet, Windows programs have access to the same network and the Internet.

You may wish to use Shared Network mode in the following cases:

- Your Mac accesses the Internet via a modem or another non-Ethernet device.
- You need to access the Internet from inside Windows but are concerned about security.
- You have problems with working in the Bridged Ethernet mode.

To configure Windows to use Shared Networking:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Shared Network option is selected.

   **Note:** In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows on your Mac. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

### Apply Separate Network Settings to Windows

When operating in the Bridged Ethernet mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.
Use Windows on Your Mac

Note: The Bridged Ethernet networking mode is more complex than the Shared Networking mode and you may need to contact your system administrator to configure it properly.

To configure Windows to work in the Bridged Ethernet mode:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, select the appropriate network adapter from the list. To connect the virtual machine’s adapter to the active network adapter of your Mac, choose Default Adapter.

   Note: In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

If you can’t configure Windows to function in the Bridged Ethernet mode, consider using Shared Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.
Use Windows on Your Mac

Use Host-Only Network Settings

Parallels Desktop provides a closed network that is accessible only to Mac OS X and Windows. Mac OS X is connected to this network via the Parallels Host-Only Networking adapter automatically created on your Mac during the Parallels Desktop installation. The addresses for Windows are provided by the Parallels DHCP server.

To configure Windows to use Host-Only Networking:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. Click Hardware and then click Network.

3. In the Network pane, make sure that the Host-Only option is selected.

   **Note:** In the MAC address field, you can change the MAC address currently assigned to Windows. MAC addresses are automatically generated when you first set up Windows. However, you can modify the default MAC address by typing another value in the MAC address field or clicking the Generate button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

Use Wi-Fi with Windows

If your Mac is already connected to the Internet wirelessly, by default Windows is also set to access the Internet wirelessly, with no setup required.

If you change your network setup, you can reconfigure a Wi-Fi connection using the Bridged Ethernet mode. When operating in this mode, Windows appears on the network as a stand-alone computer with its own IP address and network name.
To configure Windows to access the Internet through Wi-Fi:

1  Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2  Click Hardware and then click Network.
3  In the Network pane, choose Wi-Fi from the list.

After you perform these steps, Windows is able to connect to the Internet through the Wi-Fi adapter of your Mac.

If you can’t configure your virtual machine to function in the Bridged Ethernet mode, consider using Shared Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge base http://kb.parallels.com/ available at the Parallels website.

**Connect Windows to a VLAN**

If your Mac is a VLAN (virtual local area network) member, Parallels Desktop allows you to bridge Windows to this VLAN.

To bridge Windows to the VLAN, do one of the following:

- Click the Parallels icon in the menu bar and choose Configure.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

4  Click Hardware and then click Network.
5  Select Bridged Network > VLAN from the Source list.

Windows is bridged to the selected VLAN.

**Optimize Performance**

If Windows isn’t working as speedily as you’d like, there are several simple ways you can optimize its performance. This section contains many helpful instructions for doing just that.

Read this section to find out how you can tune Windows for speed.
Set How Much Memory is Allocated to Windows

Parallels Desktop is set to allocate a certain amount of your Mac’s available RAM memory to Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause Windows programs to slow down because they’re running on top of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS X applications may run well but Windows programs might slow down.

To optimize the performance of both Windows and Mac OS X, set the memory allocated to Windows to be somewhere within the recommended range.

To set how much memory is allocated to Windows:

1. Shut down Windows (p. 36).
2. Choose Actions > Configure > Hardware > CPU & Memory.
3. Move the memory slider to somewhere within the recommended range, indicated by the graphic under the slider (see above).

If you use Windows programs that require lots of memory, like 3D or video production programs, it’s best to set the memory allocation towards the high end of the range (move the slider to the right). If not, it’s usually best to set it closer to the middle.

**Note:** No matter how much memory (RAM) your Mac has, the maximum amount of memory that can be assigned to Windows is 8 GB. However, if you’re using Parallels Desktop for Mac Pro Edition, the maximum amount of memory that can be assigned to Windows is 64 GB.

If you change this setting and then you don’t like how Windows is performing, then try a different setting.

**Note:** If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

Optimization Settings

Using Optimization settings, you can:

- Optimize performance for either Mac OS X applications or Windows programs
- Tune Windows for speedier performance or more graphical features
- Set Windows to pause when no programs are open (p. 103)
- If you’re using a MacBook or other portable computer, optimize your computer for better battery life or higher performance
- Limit the virtual machine resource usage
To access **Optimization** settings:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

2. Click **Options** and select **Optimization**.

---

**Optimize Performance for Mac OS X Applications or Windows Programs**

Choose one of the following from the **Performance** menu:

- **Faster virtual machine**: More of your computer’s resources are given to Windows. The performance of Windows programs may be increased significantly, but Mac OS X applications may slow down.
Use Windows on Your Mac

- **Faster Mac**: More of your computer’s resources are given to Mac OS X. The performance of Mac OS X applications may be increased significantly, but Windows programs may slow down.

To set Parallels Desktop to automatically optimize performance for Mac OS X or Windows depending on which application or program you’re working with at the moment:

- Select **Adaptive Hypervisor**. When you’re using a Windows program, more resources are given to Windows, and when you’re using a Mac OS X application, more resources are given to Mac OS X.

### Tune Windows for Speedier Performance

- Select **Tune Windows for speed**.

Some Windows features that tend to slow down performance, such as animations during startup, are disabled.

### Optimize your MacBook for Longer Battery Life or Higher Performance

The **Power** menu contains the power and performance related options:

- **Longer battery life**: If you have a portable Mac that you often use unplugged, you can choose this option to lower power consumption for longer battery life. This may slightly reduce Windows performance.

- **Better performance**: This option (selected by default) maximizes Windows performance, but uses more power.

**Note**: If you change options in the **Power** menu when Windows is running, you must shut down Windows and start it again for the changes to take effect.

To show battery status in Windows:

- Select **Show battery in Windows**.

When your MacBook or other portable computer is running on battery power, the battery status is displayed in the menu bar.

### Limit the Virtual Machine Resource Usage

If your Mac lacks resources for running two or more virtual machines at a time, you can limit the virtual machine resource usage for the virtual machine doing more important work to have more resources. Drag the slider between **Low**, **Medium**, and **No limit** points. If you change this setting and then don’t like how Windows is performing, then try a different setting.

### Optimize 3D Graphics Performance on a MacBook Pro

Some new MacBook Pro computers have two video adapters. By default, the slower video adapter that saves energy is used.
To use the faster video adapter for better 3D graphics performance:

1. In the Mac OS X Finder, select Apple menu > System Preferences and click Energy Saver.
2. Click Higher performance.

Setting graphics to higher performance uses battery life faster.

**Speed Up Games and Graphics Programs**

With Parallels Desktop, you can run games and programs that require video cards with DirectX or OpenGL support. To do so, you must enable 3D acceleration.

For information on whether a program requires DirectX or OpenGL support, see the materials that came with the game or program.

To enable 3D acceleration:

1. Shut down the virtual machine. (p. 36)
2. Choose Actions > Configure.
3. In the Video pane, select On or select a version of DirectX from the 3D acceleration menu.

**Note:** Parallels Tools must be installed (p. 199) before you can enable 3D acceleration. Parallels Tools are installed by default when you set up Windows.

**Pause Windows When No Programs Are Open**

You can conserve your computer’s resources by setting Windows to pause automatically when no Windows programs are open. That way, more resources such as RAM and CPU can be used for Mac OS X applications.

To set Windows to pause when no programs are open:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2. Click Options and select Optimization.
3. Select Pause Windows when possible.
Optimize Virtual Machine for Games, Graphics, Productivity, or Development

When creating a virtual machine, you can optimize it according to your needs. You can choose to configure the virtual machine for:

- **Productivity.** Choose this profile if you’re using the virtual machine for your everyday work with text editors, email, web browsers, etc.
- **Games only.** Choose this profile if you’re using the virtual machine to play PC games on your Mac.

If you’re using Parallels Desktop for Mac Pro Edition, you can configure your virtual machine also for:

- **Design.** Choose this profile if you’re using the virtual machine to work with graphics applications.
- **Software development.** Choose this profile if you’re using the virtual machine to develop and test software.
- **Software testing.** Choose this profile if you’re using the virtual machine to test software in an isolated environment.

You can change this setting after the virtual machine is created:

1. Start Parallels Desktop.
2. In Control Center, right-click the virtual machine (it must be shut down) and choose Configure.
3. On the General tab, click Change.
4. Select the profile that best fits your need.

Work with Windows in Travel Mode

If you often travel with your MacBook, you must have come across the situations when you had no power adapter at hand to charge the Mac’s batteries or experienced some problems when connecting to public networks.

Travel Mode makes Windows use less energy to extend the Mac’s battery life and adjusts settings to connect to public networks.

Enter Travel Mode

To switch Windows to Travel Mode, do the following:

1. Start your virtual machine (p. 31).
2. When Windows boots up, do one of the following:
• Click the Parallels icon † † in the menu bar and choose Actions > Enter Travel Mode.
• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Enter Travel Mode.

Quit Travel Mode

To quit Travel Mode, do one of the following:

• Click the Parallels icon † † in the menu bar and choose Actions > Quit Travel Mode.
• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Quit Travel Mode.

Enter and Quit Travel Mode Automatically

You can also configure your virtual machine to enter and quit Travel Mode automatically:

3 Do one of the following:
  • Click the Parallels icon † † in the menu bar and choose Configure.
  • Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.

4 Click Options and select Travel Mode.

5 To enter Travel Mode automatically, choose one of the following:
  • Always when on battery power: The virtual machine enters Travel Mode when the Mac starts working on battery power.
  • When battery power is: Choose from the menu when you want your virtual machine to enter Travel Mode.
  • Never: The virtual machine never enters Travel Mode automatically.

6 To quit Travel Mode automatically, choose one of the following:
  • When connected to power: The virtual machine quits Travel Mode when you connect your Mac to power.
  • Never: The virtual machine never quits Travel Mode automatically.

Schedule Windows Maintenance

From time to time, Windows needs to do various maintenance tasks like installing updates, cleaning and defragmenting the disk(s), etc. When Windows is doing these tasks, performance may slow down.

To avoid low performance when you’re busy with important tasks, schedule Windows to run maintenance when you’re away or at any time you like:

7 Do one of the following:
Use Windows on Your Mac

- Click the Parallels icon in the menu bar and choose Configure.
- Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Configure.

8 Click Options and select Maintenance.
9 Select Start maintenance and choose the day and time from the corresponding menus.

Once ready, Windows will do maintenance at the specified time.

Use Windows on Your iPad, iPhone, or Android Device

Parallels Access is a product created by Parallels that allows you to work with your Mac or Windows PC and their applications remotely from your iPad, iPhone or Android device. It also allows you to work with a remote computer via a web browser.

If you have Parallels Desktop installed on your Mac, you can use the Parallels Access app to access and control Windows.

Parallels Access lets you:
- Use any of your Windows programs on your mobile device
- Remotely start, stop, and reset Windows
- Connect over Wi-Fi or 3G
- Access Windows from anywhere over the Internet

Get Started

Before you can use Parallels Access, you must do the following:
1 On your iPad, iPhone or Android device, download and install Parallels Access from the App Store or Google play.
2 Be sure you have installed Windows on your Mac (p. 18).
3 In Parallels Desktop, do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.
4 Click Access.
5 Install the Parallels Access agent on your Mac by clicking Install.

You only have to do these steps once.
Access Windows from your iPad, iPhone or Android device

1. Turn on your Mac.
   Your Mac must be on for Parallels Access to access and use Windows.
2. Open Parallels Access on your iPad, iPhone or Android device and log in to your account using the same email and password you used to register Parallels Desktop.
3. Tap your Mac in the list of available Macs.

When you access Windows for the first time, you see tips about gestures you can use to control Windows. Tap Close to go to the Windows desktop.

For more information about using Parallels Access, see Parallels Access User’s Guide, available online.

Save Time With Parallels Toolbox

Parallels Toolbox is a set of handy tools that may help you to save time during your daily routine. With Parallels Toolbox, you can:

- take screenshots;
- record audio;
- archive and unarchive files;
- block the Mac’s camera and mute the microphone to prevent them from unauthorized access;
- set a countdown to count down days to a specific event;
- lock the Mac’s screen to ensure that other users cannot access your desktop while you’re away;
- prevent your Mac from going to sleep;
- and much more.

Please refer to the Parallels Toolbox User’s Guide available online for the detailed information on what and how you can do with Parallels Toolbox.

Install Parallels Toolbox on your Mac

To install Parallels Toolbox:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click Toolbox.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click Toolbox.
Use Windows on Your Mac

2  Click **Install** and follow the onscreen instructions.

**Save a Picture of the Screen**

To save a picture of Windows in Window Mode:

- Choose **View > Make Screenshot**.

A file named *Parallels Picture.png* is saved on the Mac OS X desktop.

You can also take a picture of the entire screen at any time by pressing Command-Shift-3. By default, pictures are saved to the Mac OS X desktop.

**Set the Appearance of Virtual Machine Dock Icons**

You can choose which type of icon appears in the Mac OS X Dock when your virtual machine is open or running.

1  Do one of the following:

- Click the Parallels icon in the menu bar and choose **Preferences**. Then click **General**.
- Right-click the Parallels Desktop icon in the Dock and choose **Preferences**. Then click **General**.

2  From the **Virtual Machine Dock Icons** menu, choose one of the following:

- **OS Icon**: The Dock icon shows the icon of the operating system installed in the virtual machine.
- **Live Screenshot**: The Dock icon shows a miniature image of what you see in Windows.
- **None**: Virtual machines running in Window, Full Screen or Modality modes don’t have separate icons in the Dock.

**Allow Windows Updates While Your Mac is Sleeping**

Parallels Desktop supports OS X Power nap, which lets you keep aspects of Windows up-to-date even while your Mac is sleeping. When Power Nap is enabled, services that usually update information after Windows wakes from sleep (for example, new emails in email applications and new event updates in Calendar) will update while your Mac is in sleep.

To use Power Nap, your computer must be compatible. See Apple.com for more information.
To enable Power Nap:

1. On your Mac, choose Apple menu > System Preferences and click Energy Saver.

2. Depending on whether your Mac is working on batteries or is plugged, make sure Enable Power Nap while on battery power or Enable Power Nap while plugged into a power adapter is selected.

**Note:** To learn more about Power Nap, please refer to the OS X help resources.

**Translate Words in Windows**

If you’re working with Windows and come across a word you don’t know, you can easily look it up in Mac OS X Dictionary. Just hover the mouse cursor over the word and either press Control-Command-D or tap (don’t click) the touchpad with three fingers.

**Notes:**

1. Parallels Tools (p. 142) must be installed in Windows.

2. When you hover the mouse over a word, the mouse cursor should change from arrow to text selection. You cannot look for words depicted on pictures.
Advanced Topics

This chapter is intended to give you additional information on how to work with Parallels Desktop and virtual machines.

In This Chapter

Work with Virtual Machines ................................................................. 110
Use Other Operating Systems on Your Mac .............................................. 130
Install or Update Parallels Tools ............................................................... 140
For Software Developers ........................................................................ 149
Set File Type Associations .................................................................... 156
Modality Mode ...................................................................................... 157
Hide and Show Parallels Desktop ............................................................. 158
Disable Automatically Suspending Windows .......................................... 159
Remove Parallels Desktop ...................................................................... 159
Advanced Preferences .......................................................................... 160
Shared Networking Settings .................................................................. 162
Host-Only Networking Settings ............................................................... 166
Create a Custom Host-Only Network ..................................................... 168
More Options ...................................................................................... 168
Adding and Removing Devices .............................................................. 170
Hardware Settings ............................................................................... 176

Work with Virtual Machines

Read this section for basic information about working with virtual machines.

Supported Guest Operating Systems

Any of the following guest operating systems can be installed in Parallels Desktop virtual machines.

<table>
<thead>
<tr>
<th></th>
<th>32-bit</th>
<th>64-bit</th>
<th>Express Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 10</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 8.1</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Advanced Topics</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Windows 8 | | |
| Windows Server 2012 SP0, R2 | | |
| Windows 7 SP0, SP1 | | |
| Windows Server® 2008 SP0, SP1, SP2, R2 | | |
| Windows Vista® Home, Business, Ultimate, Enterprise SP0, SP1, SP2 | | |
| Windows Server® 2003 SP0, SP1, SP2, R2 | | |
| Windows XP Home SP0, SP1, SP2, SP3 | | |
| Windows XP Professional SP0, SP1, SP2, SP3 | | |
| Windows XP Professional SP2 | | |
| Windows 2000 Professional SP4 | | |
| Windows 2000 Server SP4 | | |
| Windows NT 4.0 Server SP6, Workstation SP6 | | |
| Windows ME | | |
| Windows 98 SE | | |
| Windows 95 | | |
| Windows 3.11 | | |
| MS-DOS 6.22 | | |

<table>
<thead>
<tr>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Hat® Enterprise Linux 5.x, 6.x, 7.x</td>
</tr>
<tr>
<td>CentOS Linux 5.x, 6.x, 7.0</td>
</tr>
<tr>
<td>Fedora™ Linux 19, 20, 21, 22, 23, 24</td>
</tr>
<tr>
<td>SUSE® Linux Enterprise Server 11 SP2, SP3</td>
</tr>
<tr>
<td>OpenSUSE Linux 12.3, 13.1, 13.2, 42.1</td>
</tr>
<tr>
<td>Linux Mint 13, 16, 17, 17.2, 17.3</td>
</tr>
<tr>
<td>Mageia 3, 4.1, 5</td>
</tr>
<tr>
<td>Debian® Linux 7.x, 8.x</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS X Yosemite 10.10.x</td>
</tr>
<tr>
<td>OS X Mavericks 10.9.x</td>
</tr>
</tbody>
</table>
Advanced Topics

<table>
<thead>
<tr>
<th>OS X Mountain Lion 10.8.x</th>
<th>✔️</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS X Lion 10.7.x</td>
<td>✔️</td>
</tr>
<tr>
<td>OS X Lion Server 10.7.x</td>
<td>✔️</td>
</tr>
<tr>
<td>Mac OS X Snow Leopard Server 10.6.x</td>
<td>✔️ ✔️</td>
</tr>
<tr>
<td>Mac OS X Leopard Server 10.5.x</td>
<td>✔️ ✔️</td>
</tr>
</tbody>
</table>

**Chrome**

| Chrome OS* | ✔️ |

**Solaris**

| Solaris® 10, 11 | ✔️ |

**BSD**

| FreeBSD® 8.x, 9.x, 10, 10.1 | ✔️ |

**OS/2**

| OS/2® Warp 4.5, 4 | ✔️ |
| eComStation™ 1.2, 2.x  | ✔️ |

**Android**

| Android OS* | ✔️ |

*Chrome and Android OSs - we currently support these operating systems as guest operating systems only if you downloaded them as virtual appliances (p. 125) using New Virtual Machine Wizard.

Please note that Parallels Desktop does not include operating system installation discs or their images. You should purchase them separately.

## About Virtual Machines

To add Windows or another operating system to your Mac, Parallels Desktop creates a "virtual machine," or a virtual copy of a computer, inside your Mac. You can then install Windows in the virtual machine, just as you would install an operating system on a regular computer.

Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can install as many virtual machines as you like, and install a different operating system in each of them. That way you can use multiple operating systems together at the same time on your Mac. And just like with a regular computer, you can turn virtual machines on and off, configure them, and install and use programs.
Default Configurations

A typical virtual machine has the following basic virtual hardware: CPU, memory, hard disk drive, floppy disk drive, sound device, CD/DVD drive, network adapter, USB controller, serial port, printer port connected to the printer set as the default in Mac OS.

Note: Apart from the basic hardware, you can add new devices to your virtual machine using the Virtual Machine Configuration dialog (p. 170).

The amount of memory and the size of hard disks vary for different guest OSs. Refer to the table below to learn the memory and hard disk values that are allocated to a virtual machine depending on the guest operating system that will be installed in it. Virtual hard disks for typical virtual machines are always created in the expanding format (p. 172).

<table>
<thead>
<tr>
<th>Guest Operating systems</th>
<th>Memory, MB</th>
<th>Video Memory, MB</th>
<th>Hard Disk, MB</th>
<th>Floppy Drive</th>
<th>CD/DVD Drive</th>
<th>Network Adapter</th>
<th>Sound Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mac OS X</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 7</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>1024</td>
<td>128</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows XP</td>
<td>1024</td>
<td>256</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows 2003</td>
<td>1024</td>
<td>64</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>256</td>
<td>256</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows ME</td>
<td>256</td>
<td>32</td>
<td>8,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows NT</td>
<td>256</td>
<td>32</td>
<td>4,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows 98</td>
<td>256</td>
<td>32</td>
<td>8,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows 95</td>
<td>128</td>
<td>32</td>
<td>2,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Windows 3.11</td>
<td>64</td>
<td>32</td>
<td>2,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Other Windows</td>
<td>1024</td>
<td>128</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>SUSE Linux Enterprise</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Debian GNU/Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Ubuntu Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Fedora Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>CentOS Linux</td>
<td>1024</td>
<td>32</td>
<td>64,000</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
</tbody>
</table>
### Set Where New Virtual Machines Are Stored

By default, Parallels Desktop stores virtual machines in ~/Documents/Parallels.

To change the default location for new virtual machine installations:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click General.

2. Choose a location from the Virtual Machines Folder menu.

All newly created virtual machines are stored in the new location. Any existing virtual machines remain in their original locations.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Physical Memory</th>
<th>Virtual Memory</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenSUSE Linux</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Mandriva Linux</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other Linux kernel 2.6</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other Linux kernel 2.4</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other Linux</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>FreeBSD 8.x</td>
<td>256</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>FreeBSD 7.x</td>
<td>256</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other FreeBSD</td>
<td>256</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>OS/2 Warp 4.5</td>
<td>256</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>OS/2 Warp 4</td>
<td>128</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>eComStation 1.2</td>
<td>256</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other OS/2</td>
<td>128</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>MS-DOS 6.22</td>
<td>64</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other DOS</td>
<td>32</td>
<td>2,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Solaris 10</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>OpenSolaris</td>
<td>256</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other Solaris</td>
<td>1024</td>
<td>64,000</td>
<td>✔️</td>
</tr>
<tr>
<td>Other</td>
<td>256</td>
<td>8,000</td>
<td>✔️</td>
</tr>
</tbody>
</table>
Arrange Virtual Machines

If you have many virtual machines, the Control Center window may get overloaded and inconvenient to work with.

You can configure Control Center to show the minimum information - only virtual machine names and icons. To do so, click the Parallels Desktop icon in the Dock and choose View > Compact View in the OS X menu bar.

Or if you’re using Parallels Desktop for Mac Pro Edition, you can change how your virtual machines are arranged. Click the Parallels Desktop icon in the Dock, click View > Arrange By and choose how you want to list the virtual machines.

Make Virtual Machines Distinctive

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines running simultaneously, the icons of all applications running in the virtual machines are usually present in the Dock. You can easily get confused to which virtual machine the app icon belongs. To distinguish one virtual machine from others, you can mark it with some color. Do one of the following:

• Right-click a virtual machine in Control Center and choose the color you want at the bottom of the context menu.
• Right-click your virtual machine in OS X (virtual machines are usually stored in the Documents/Parallels folder) and choose the color you want from the context menu.

If you choose, for example, red, the Dock icons of this virtual machine applications will be marked with a red spot.

Change the Virtual Machine Icon

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines with the same guest operating system, their Dock icons look the same and you may get confused. To change the virtual machine icon, do the following:

1. Copy a new icon you want to use to the clipboard (select the icon and press Command + C).
2. Right-click the virtual machine which icon you want to change (virtual machine are usually stored in the Documents/Parallels folder) and click Get Info.
3 Click the virtual machine icon in the top left corner and paste the new icon from the clipboard by pressing Command + V. The icon will change in Finder and in the Dock.

To return the default icon, repeat step 2, click the virtual machine icon and press Backspace.

### Change the Virtual Machine Name

The name of a virtual machine is displayed in Control Center and, at the top of the guest OS window when you are running in Window mode.

To change the virtual machine name:

1 Do one of the following:
   1. Click the Parallels icon in the menu bar and choose Configure.
   2. If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2 Click General and type a new name in the Name field.

The length of the name is limited to 50 characters.

### Clone a Virtual Machine

**Clone a Virtual Machine**

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual machine fully identical to the original one. To make a clone:

1 Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > Clone.

3 Choose where you want to store the clone.
   By default, Parallels Desktop stores clones in your Documents > Parallels folder.

4 Click Save to start cloning the virtual machine.

### Create a Linked Clone of a Virtual Machine

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

A linked clone is a virtual machine that shares virtual hard disks with the parent virtual machine. This technology allows multiple virtual machines to use the software installed on the parent virtual machine hard disk. This way, users can save space on the Mac’s hard disk. To create a linked clone:
1 Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > New Linked Clone.

3 Choose where you want to store the clone.
   By default, Parallels Desktop stores clones in your Documents > Parallels folder.

4 Click Save to start cloning the virtual machine.

Back Up a Virtual Machine

Most people don’t seriously consider regular backups as a necessity until they have experienced a significant data loss. You should create your own backup strategy to protect yourself from data loss. Virtual machines are as vulnerable to crashes as physical computers.

You can back up your virtual machine using one or several of the following methods:

- Configure the regular backup settings on the Backup tab of the Virtual Machine Configuration dialog.
- Use third-party backup utilities like Acronis True Image (p. 128).
- Clone the virtual machine with the help of Clone Virtual Machine Assistant. Give a descriptive name to the clone and save it in a location specially designated for backups.
- Copy the virtual machine files manually.

Configure Regular Backups

On the Backup tab of the Virtual Machine Configuration dialog, you can choose how to back up your virtual machine regularly. You can configure how the virtual machine snapshots will be created or choose to back up the virtual machine with Time Machine.

If you choose to back up your virtual machine with Time Machine, your virtual machine’s PVM file will be automatically backed up together with other files stored in Mac OS. As a consequence, files stored on your virtual machine’s hard disk will be also backed up, since the virtual hard disk file (HDD) is stored inside the virtual machine bundle file (PVM).

**Warning:** Time Machine backups can guarantee safety only when your Parallels virtual machines were stopped or suspended during the backup.

To restore some of your Windows files:

1 From within the Finder (and not within Time Machine), locate the backup copy of your virtual machine’s file (PVM) on your backup disk.

2 Right-click the file, and choose Show Package Contents.

3 In the virtual machine contents window, right-click the virtual hard disk file (HDD) that is usually named `<VirtualMachine'sName>.hdd` and choose Open With > Parallels Mounter.
4 Using Parallels Mounter, browse the contents of your virtual machine’s hard disk to find the files you need to restore.

**Use Third-Party Backup Utilities**

You can use any third-party backup utilities you like. Registered Parallels Desktop users can use Acronis True Image (p. 128) to back up their Windows virtual machines.

*Note: Acronis doesn't support backing up virtual machines that use Boot Camp as their hard disks.*

**Clone the Virtual Machine**

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For details, see *Clone a Virtual Machine* (p. 116).

**Copying the Virtual Machine Files**

You can locate your virtual machine in Finder and create a backup copy of the virtual machine file (PVM).

1 In Control Center (or in the virtual machine window if it is shut down), right-click the virtual machine name and select *Show in Finder* from the context menu. In Finder, go to the folder where your virtual machine is stored.

2 Locate the required virtual machine PVM file.

*Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file (HDD), and other files. For more information about the virtual machine files, see *About Virtual Machines* (p. 112).*

3 Copy the virtual machine’s PVM file to a safe location.

**Browse Virtual Hard Disks in Mac OS X**

For easy access to Windows files, you can mount the virtual hard disk (on which Windows is installed) in Mac OS X.

**Mount a Virtual Hard Disk to the Mac OS X Desktop**

If you need the virtual hard disk (on which Windows is installed) to be mounted to the Mac OS X desktop when Windows is running, open Finder, choose *Finder > Preferences > General* and select the *Connected servers* option.

For easy access to your virtual machines files, you can mount their hard disks in Mac OS X Finder together with other disks and storage devices.
If you want your virtual hard disks to be mounted to the Mac OS X desktop when the virtual machine is running, perform the following actions:

1. Open the Sharing pane of the Virtual Machine Configuration dialog and enable the Mount virtual disks to Mac desktop option.

   **Note:** To be able to edit the settings in the Sharing pane, you must have Parallels Tools (p. 140) installed in the virtual machine and the Isolate Mac from Windows option disabled in the Security pane.

2. Open the Finder Preferences, click the General tab and select the Connected servers option in the list of items displayed on the desktop.

If you want to manage the virtual machine content without starting the virtual machine, you can mount the virtual hard disks manually using Parallels Mounter:

1. Browse the virtual machine files in Finder. For Parallels virtual machines, right-click the virtual machine name in Control Center (or in the virtual machine window if it is shut down) and select Show in Finder from the context menu.

   The default paths for storing Parallels virtual machines are /Users/<UserName>/Documents/Parallels/ and /Users/Shared.

2. To mount the hard disk of a particular virtual machine, right-click this virtual machine’s file and choose Open With > Parallels Mounter or Open With > Other > Library > Parallels > Parallels Mounter from the shortcut menu. You can mount the following virtual machines and hard disks:

   - Parallels bundle (.pvm) or configuration file (.pvs) or virtual hard disk file (.hdd).
   - VMware configuration file (.vmx, .vmwarevm) or virtual hard disk file (.vmdk).
   - Virtual PC configuration file (.vmc, .vpc7) or virtual hard disk file (.vhd).
   - VirtualBox configuration file (.xml) or virtual hard disk file (.vdi).

   If you choose the PVM file of a Parallels virtual machine or the configuration file of a third-party virtual machine that has several virtual hard disks, all its volumes will appear as mounted in Finder.

   If you want to mount a single virtual hard disk, double-click the virtual hard disk file to mount it with Parallels Mounter. The icon for the selected hard disk appears in the sidebar of the Finder window, together with other Mac OS X icons.

3. To browse the contents of a volume, click its icon in the sidebar of the Finder window.

   You can manage the virtual machine files just as you manage your Mac OS X files in Finder windows.

   **Note:** If you are browsing the contents of a suspended virtual machine in Finder, you cannot delete, move, or otherwise modify its files.

4. To unmount the volume, use the Eject button next to the disk icon.
Create and Use Virtual Machine Templates

On the basis of your virtual machines you can create templates. Later you can use them to create multiple identical virtual machines. To create a virtual machine template, you can:

- convert a virtual machine to a template; or
- clone a virtual machine to a template.

The difference between these two ways is that when you convert a virtual machine to a template, you can’t run it until you convert the template back to the virtual machine. And when you clone a virtual machine to a template, the template appears separately from the virtual machine and you can work with both.

A template, in its turn, can be converted or deployed back to the virtual machine. When you convert a template, it turns back to the virtual machine. And when you deploy it, the resulting virtual machine appears separately from the template and you can work with both.

Convert a Virtual Machine to a Template

To convert a virtual machine to a template:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to convert (it must be shut down) and choose File > Convert to Template.

Convert a Template to the Virtual Machine

To convert a template back to the virtual machine:

1. Start Parallels Desktop.
2. In Control Center, right-click the template you want to convert and choose Convert to Virtual Machine.

Clone a Virtual machine to a Template

To clone a virtual machine to a template:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine you want to clone (it must be shut down) and choose File > Clone to Template.
3 Choose where you want to store the resulting template.
   By default, Parallels Desktop stores templates in your Documents > Parallels folder.
4 Click Save to start cloning the virtual machine to the template.

**Deploy a Template to the Virtual Machine**

To deploy a template back to the virtual machine:

1 Start Parallels Desktop.
2 In Control Center, right-click the template you want to deploy and choose **Deploy to Virtual Machine**.
3 Choose where you want to store the resulting virtual machine.
   By default, Parallels Desktop stores virtual machines in your Documents > Parallels folder.
4 Click Save to start deploying the template to the virtual machine.

**Save Snapshots of a Virtual Machine**

A snapshot is a saved state of the guest OS. It’s useful to create snapshots, for example, before:

- you’re going to run some programs that may damage the guest OS; or
- if you’re going to configure some guest OS software that requires a lot of settings; or
- if you want to mark milestones in the development process.

**Notes:**
1. Snapshots cannot be created for Windows virtual machines that use the Boot Camp partition.
2. If your virtual machine has one or more snapshots, you can neither compress nor resize the virtual hard disk.
3. Creating a snapshot increases the size of the virtual machine .pvm bundle.

If something goes wrong, you can revert the changes back to any of your snapshots and continue working with the guest OS.

**Create a Snapshot**

1 Start Parallels Desktop.
2 In Control Center, select the virtual machine for which you want to create a snapshot.
3 Click Actions > Manage Snapshots.
4 Click New, specify the snapshot name and click OK.

**Automate the Creation of Snapshots**

The SmartGuard functionality allows you to automate snapshots creation.
Advanced Topics

**Note:** SmartGuard is available only when the virtual machine is not running in **Rollback Mode** (p. 93).

To access settings for automating snapshots:

1. Start Parallels Desktop.
2. In **Control Center**, right-click the virtual machine for which you want to create a snapshot and choose **Configure**.
3. Click **Backup**.

To automate snapshots, enable SmartGuard, click **Details**, and do one of the following:

- Select **Optimize for Time Machine**. If you select this option, a snapshot will be taken every 48 hours. Time Machine, when backing up your Mac, will not back up the entire virtual machine, but only its latest snapshot. This allows you to reduce the amount of data that Time Machine backs up, to reduce the time Time Machine spends backing up the virtual hard disk(s), and to minimize the risk of data loss or corruption when restoring the virtual machine hard disk(s) from the Time Machine backup.

- Manually set the snapshots frequency and maximum number of snapshots to keep. If you want to know when it is time to make the next snapshot and to be able to reject the snapshot creation, select **Notify me before snapshot creation**.

To set how often snapshots are made:

- Use the **Take a Snapshot Every** field. You can set from one to 48 hours.

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest daily, weekly and monthly snapshot.

To limit how many snapshots are stored:

- Use the **Snapshots to Keep** field to set the maximum number of snapshots that can be stored on your Mac.

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit for snapshots and needs to make a new one over limit, it deletes the oldest snapshot.
Revert to a Snapshot

To revert to a snapshot:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine that you want to revert.
3. Click Actions > Manage Snapshots.
4. Select the snapshot to which you want to revert and click Go To.

Delete a Snapshot

To delete a snapshot:

1. Start Parallels Desktop.
2. In Control Center, select the virtual machine which snapshot you want to delete.
3. Click Actions > Manage Snapshots.
4. Select the snapshot you want to delete and click Delete.

When you delete an intermediate snapshot, the information it contains is merged into the next snapshot.

Change Virtual Machine Configuration at Runtime

Parallels Desktop allows you to connect or disconnect certain devices at runtime or switch some of them for using other media.

Generally, the following virtual devices can be connected or disconnected at runtime:

- Floppy disk drive
- CD/DVD-ROM drives
- Network adapter
- Sound device
- USB device
- Shared folders

If printer and serial ports are present in the virtual machine configuration, you can also manage them at runtime.

To configure any of these devices, use the necessary command from the Devices menu in the menu bar. This menu is available only when the virtual machine is running.
Connecting a CD/DVD-ROM or a Floppy Drive

If you have several CD/DVD-ROM drives connected to your virtual machine, in the Devices menu they are listed in the same order as they were connected. The first CD/DVD-ROM drive will be CD/DVD-ROM 1, the second will be CD/DVD-ROM 2, and so on.

Connecting a Network Adapter

You can set up any of the three network modes: Shared Networking, Bridged Networking, or Host-Only Networking.

Connecting a Sound Device

To connect or disconnect a sound device, choose the Activate or Mute options respectively. You can also choose the type of output and input devices.

Connecting a USB Device

Parallels Desktop automatically detects all USB devices plugged into your Mac computer. The devices that are currently connected to the virtual machine appear in the list from the Device menu. You cannot use a USB device in Mac OS X while it is being used by the virtual machine.

Connecting a Shared Folder

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine Configuration dialog.

You can

- share all Mac disks or Home Folder only with the virtual machine
- share Windows guest operating system disks with Mac OS X
- add a new shared folder

Connecting a Serial Port

To connect or disconnect a serial port, click the Devices menu, select the corresponding serial port, and choose the appropriate command in the displayed menu.

Connecting a Printer Port

To connect or disconnect a printer port or to connect a printer or an output file to a printer port, click the Devices menu, select the corresponding printer port, and choose the appropriate command in the displayed menu.
Use Mouse Wheel Horizontal Scrolling

You can use the mouse wheel horizontal scrolling when working with windows of virtual machine applications. This feature is available only if Parallels Tools (p. 199) are installed in the virtual machine.

Remove a Virtual Machine

Remove a Virtual Machine from your Mac

If you don’t need a virtual machine any more, you can permanently remove it from your Mac:

**Warning:** Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are used by other virtual machines. If you remove a Boot Camp virtual machine, the Boot Camp partition with Windows installed remains available on your Mac.

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Control Center and choose Remove.
2. Click Move to Trash.

Remove a Virtual Machine from Control Center

To temporarily remove a virtual machine from Control Center:

1. Shut down the virtual machine if it is running, right-click in the virtual machine window and choose Remove. You can also click File > Remove or right-click this virtual machine in the Control Center and choose Remove.
2. Click Keep Files.

When you need this virtual machine again, you can easily import it in Parallels Desktop (p. 30).

Download Pre-configured Virtual Appliances

If you don’t have enough time to create a new virtual machine with the required configuration, you can download a ready-to-use virtual machine with a predefined configuration.

Downloading Parallels Virtual Appliances

Parallels Virtual Appliances are pre-built Ubuntu, Fedora Linux, CentOS Linux, Debian GNU/Linux, and Android virtual machines.

To download such an appliance and use it with Parallels Desktop:
1 Choose **File > New**.
2 Select the appliance you need in the **Free Systems** section and click **Continue**.
3 In the next step, click **Download**. Once the download starts, you can pause it anytime by clicking **Pause**. To resume the download, click **Resume**.

Once the download is complete, you can start working with the virtual appliance in Parallels Desktop.

### Downloading Chromium OS Virtual Appliance

To download the Chromium OS virtual appliance from Parallels Desktop:

1 Choose **File > New**.
2 Select **Download Chromium OS** and click **Continue**.
3 In the next step, click **Download**. Once the download starts, you can pause it anytime by clicking **Pause**. To resume the download, click **Resume**.

Once the download is complete, you can start working with the Chromium OS virtual appliance in Parallels Desktop.

### Downloading Modern.IE Virtual Appliances

The Modern.IE virtual appliances allow web developers to check how websites are displayed and functioning in different versions of Internet Explorer on different versions of Windows.

To download such an appliance and use it with Parallels Desktop:

1 Choose **File > New**.
2 Select **Modern.IE** and click **Continue**.
3 In the next step, select the version of Internet Explorer and Windows you’d like to work with and follow the onscreen instructions.

Once the download is complete, you can start working with the virtual appliance in Parallels Desktop.

### Set the Guest OS Type and Version

You can change which guest OS a virtual machine is configured to work with. You need to change it in the following cases:

- If you upgrade the guest operating system (for example, from Windows XP to Windows 7), you need to change the guest OS type and version correspondingly or Parallels Tools (p. 140) may start working incorrectly.
- If you create a virtual machine without installing an operating system, and then decide to use it with a different operating system than the one you initially specified.
To set the guest OS type and version:

1. Shut down the virtual machine. (p. 36)
2. Open the Actions menu and choose Configure.
3. Click General and select an OS from the menu just above the Name field.

**Set How Many Processors are Allocated to a Virtual Machine**

You can change the number of virtual CPUs that will be used to handle the processes running in a virtual machine. Parallels Desktop automatically calculates the maximum allowable number of virtual CPU. The calculation is based on the number of physical CPUs available to your Mac OS X computer.

*Note:* It is reasonable to use more than one CPU in your guest OS if you are going to use applications that perform better under multi-core processors.

To set how many processors are allocated to a virtual machine:

1. Shut down the virtual machine. (p. 36)
2. Open the Actions menu and choose Configure.
3. Click Hardware > CPU & Memory and select a number from the Processors menu.

*Note:* In Parallels Desktop for Mac, you can assign up to 4 CPUs to a virtual machine. In Parallels Desktop for Mac Pro Edition, you can assign up to 16 CPUs.

**Check Your Virtual Machine CPU and Memory Usage**

While working with a virtual machine, you may need to check how much memory and CPU time of your Mac it is currently using. If the virtual machine is consuming too much and your running Mac applications become slow, you can easily reduce the number of CPUs (p. 127) and amount of memory (p. 100) assigned to the virtual machine.

To check the current CPU and memory usage, choose Window > Show Resource Usage.

**Enable Spoken Commands**

You can work with Windows or other guest OSs using the following spoken commands:

<table>
<thead>
<tr>
<th>Commands</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>Starts a virtual machine.</td>
</tr>
<tr>
<td>Suspend</td>
<td>Suspends a virtual machine.</td>
</tr>
<tr>
<td>Shut Down</td>
<td>Shuts down a virtual machine.</td>
</tr>
<tr>
<td>Pause</td>
<td>Pauses a virtual machine.</td>
</tr>
</tbody>
</table>
Stop
- Stops a virtual machine.

Reset
- Resets a virtual machine.

Snapshot
- Opens the Snapshot Manager window.

Make Screenshot
- Makes a screenshot of the Guest OS window and stores it on the Mac OS X Desktop.

Make Clip
- Makes a clip.

Switch to Coherence
- Switches to the Coherence view mode.

Switch to Full Screen
- Switches to the Full Screen view mode.

Switch to Window
- Switches to the Window view mode.

Edit Configuration
- Opens the Virtual Machine Configuration dialog.

New
- Creates a new virtual machine.

Open
- Opens a virtual machine.

Download

About Parallels Desktop
- Opens the About Parallels Desktop menu.

Install Parallels Tools
- Launches the installation of Parallels Tools in the running virtual machine.

Report a Problem
- Opens the Parallels Problem Report window.

Open
- Opens an existing virtual machine and registers it in Parallels Desktop.

Open Directory
- Opens the Parallels Virtual Machines window.

To enable the spoken commands, choose Parallels Desktop > Preferences > Advanced and select Enable spoken commands. If necessary, tune the speech settings on the corresponding tab of Mac OS X System Preferences.

Get Acronis True Image

As an additional benefit, Parallels provides you with Acronis True Image. It is an online backup tool for Windows and OS X. For Parallels Desktop users, Acronis True Image is free for 30 days.

For instructions on backing up your Mac and virtual machines, please refer to the Acronis True Image documentation.

Install Acronis True Image

To install Acronis True Image, choose Parallels Desktop > Backup with Acronis True Image... and follow the onscreen instructions.

Or you can also install Acronis True Image from the virtual machine configuration:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Configure.
• If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

2 Click **Backup > Install Acronis True Image** and follow the onscreen instructions.

**Start Acronis True Image**

To start Acronis True Image:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose **Configure**.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

2 Click **Backup > Start Acronis True Image** and follow the onscreen instructions.

**Use AppleScript with the Guest OS**

You can use AppleScript to open various files and websites in the guest OS applications. You may need this when creating automated workflows.

To make the explanation more vivid, let’s assume that you need to open some .txt file in Windows Notepad using AppleScript (in AppleScript Editor). The syntax of this command is as follows:

```plaintext
tell application "Notepad"
  open "/Users/username/somefile.txt"
end tell
```

As an example of opening a website in the guest OS application, let’s assume that you need to open "www.parallels.com" in Internet Explorer. The syntax of this command is as follows:

```plaintext
tell application "Internet Explorer"
  open "/www.parallels.com"
end tell
```

**Quickly Free Up Disk Space**

Using **Free Disk Space Wizard**, you can compress the virtual machine hard disk(s) and remove various unnecessary files to free up disk space.

To quickly compress the disk(s), remove unnecessary files, and free up disk space:

1 Shut down the virtual machine.

2 Choose **File > Free Up Disk Space**.
   
   **Free Disk Space Wizard** shows whether you can reclaim any disk space by removing the virtual machine snapshots, cache files and various unnecessary files such as statistical, memory dump, and crash dump files, which are generated during the virtual machine life cycle.

You can also conserve disk space by compressing virtual disks manually (p. 185) or clicking **Reclaim** on the **General** tab of virtual machine configuration.
Archive and Unarchive Virtual Machines

If you have two or more virtual machines, you may notice that there's not enough space on your Mac. If you seldom use a virtual machine or don't use it at all, archive it to make the virtual machine occupy significantly less disk space on the Mac’s hard disk.

Archive a Virtual Machine

To archive a virtual machine, do the following:

1. Right-click the Parallels Desktop icon in the Dock and choose Control Center.
2. Right-click a virtual machine and select Archive.

Unarchive a Virtual Machine

Archived virtual machines cannot be started. To start an archived virtual machine, first you should unarchive it. Do the following:

1. Right-click the Parallels Desktop icon in the Dock and choose Control Center.
2. Right-click an archived virtual machine and select Start.
3. In the dialog prompting to unarchive the virtual machine, click Unarchive.

Use Other Operating Systems on Your Mac

Read this section for the information that's specific to certain operating systems other than Windows XP or later.

Import Linux and Your Data from a PC

You can import Linux and your data from a PC over a network or using an external storage device. These procedures are identical to the same ways of importing Windows (p. 20).

You can import the following Linux operating systems:

<table>
<thead>
<tr>
<th>OS Name</th>
<th>32-bit</th>
<th>64-bit</th>
<th>Migration Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Hat® Enterprise Linux 5</td>
<td>![checkmark]</td>
<td>![checkmark]</td>
<td>Network, External Storage</td>
</tr>
<tr>
<td>Ubuntu® Linux 8.04</td>
<td>![checkmark]</td>
<td>![checkmark]</td>
<td>Network, External Storage</td>
</tr>
</tbody>
</table>

Supported File Systems

- Ext2
- Ext3
Use Linux in Coherence Mode

You can set Linux and Mac OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called **Coherence** mode, Linux programs appear on the Mac desktop next to your Mac applications.

To enable the Coherence view mode:

- Parallels Tools must be installed (p. 143).
- Disable Linux 3D effects. The way you can do this depends on your Linux distribution. For example, in Fedora 14 click **System > Preferences > Desktop Effects** and select **Standard**. To learn how to disable Linux 3D effects in other Linux OSs, refer to the operating system documentation.

**Switch to Coherence Mode**

To switch from Window mode to Coherence mode, do one of the following:

- Choose **View > Enter Coherence**.
- Press Control-Command-Return.

To switch from Full Screen mode to Coherence mode, do one of the following:
Install Windows 98

All Windows 95 and some of Windows 98 installation packages include a bootable floppy (a startup floppy disk). The floppy is used to perform disk partitioning and formatting by means of MS-DOS. Since modern Macs have no floppy drives, you will need an external USB floppy drive or an image of a bootable floppy disk. Such an image can be created using third-party tools.

If you have a bootable CD with Windows 98 installation, you can use it as is or create an ISO image of it.

Below we describe how to install Windows 98, the case when you have a startup floppy image and a CD with the installation files. The installation of Windows 95 is similar to that.

Prepare a Virtual Machine for Windows 95/98 Installation

1. Create a Windows 98 virtual machine using New Virtual Machine Assistant. Select the Customize settings before installation option in the Name and Location window.

2. In the Virtual Machine Configuration dialog, click Hardware > Boot Order, and configure the floppy disk to be the first boot device.

3. Below the Boot Order item, select Floppy Disk to open the virtual floppy disk drive settings. In the Floppy Disk pane, do the following:
   1. Make sure the Connected option is selected.
   2. Specify the floppy disc image in the Source menu.

4. Click OK to save the virtual machine configuration.

Initial Partitioning and Formatting

1. Start the virtual machine. You will see the black screen and messages indicating the process of booting to MS DOS.

2. When prompted, enter the following command:
**fdisk**

Fdisk (MS-DOS utility) is used to partition hard disks and floppy disks.

3 The Fdisk options will be listed. Choose the operation to perform (the default choice is 1) and press Return (Enter) to continue.

4 Fdisk prompts you to create a partition. Select the Create Primary DOS Partition option if you are going to have only one partition or less than four, and enter:

- Other choices are for the case when you want to create more than four partitions.

5 Then Fdisk prompts you to define the size of the primary partition. Press Return (Enter) if you wish to create a partition of the maximum size available.

- To define other size type N and press Return (Enter). You will be prompted to specify the size.

6 Fdisk creates the partition and then prompts you to restart the computer (virtual machine).

7 Reboot the virtual machine using the same image of the boot floppy disk. That is, press Ctrl+Option (Ctrl+Alt) to release the keyboard input and then click the Shut Down button to stop the virtual machine. Then click the Start button.

8 When the booting is complete, you should format the system drive C:.

   Enter the following command:

   ```
   format c:
   ```

   Confirm that you want to format the disk C: when prompted. Type y and press Return(Enter).

   You may be prompted to choose how exactly to format your disk. Windows 95/98 supports FAT16 and FAT32 file systems.

   FAT16 partition cannot be greater than 2 GB. Larger disks can be formatted with FAT32. But do not use larger disks if you are going to run legacy applications.

   - The program starts formatting the disk C:.

   Format other disks too (if you created more than one primary partition or if you created a custom virtual machine with more than one disk). Use E:, F: drive letters.

9 Enter a label for each disk (11 character string). The label is optional, you can press Return (Enter) to skip this step.

10 Shut down the virtual machine.

Now you are ready to start the installation of the Windows 98 operating system.

**General Steps of Windows 98 Installation**

1 Start the virtual machine using the same bootable floppy image.

2 Insert the Windows 98 installation CD or connect an ISO image of the installation disc choosing CD/DVD > Connect Image from the Devices menu.

3 If you created only one primary partition (disk C:), by default, your CD/DVD drive will have the drive letter D:. Type the command:

   ```
   D:\setup.exe
   ```
and press Return(Enter). The installation starts and the files are copied from the CD to the virtual hard disk.

4 Follow the on-screen instructions of the Setup. Note that you can add or remove some options later.

5 Read and accept the License Agreement. Enter the license key.

6 Confirm the default system directory or specify another one.

7 In the Setup options dialog choose the type of installation. Typical is recommended.

8 (only for Windows 98) If you are going to use networking, select the network card when prompted.

9 Turn off the virtual machine.

10 Eject the installation CD or disconnect the ISO image.

11 Choose Configure from the Virtual Machine menu, go to Hardware > Boot Order, and select the hard disk to be the first boot device. Click OK to save the configuration.

12 Restart the virtual machine. This time, it will boot from the hard disk.

Improve Graphics Performance in Windows NT/98/ME

If you have Windows NT, Windows 98, or Windows ME installed on your Mac, you can improve graphics performance by installing a video driver.

To install a video driver in Windows 98 and Windows ME:

1 Start Windows 98, or Windows ME.

2 When the guest OS boots up, in the Mac menu bar click Devices > CD/DVD > Connect Image.

3 Click Applications, double-click Parallels Desktop > Contents > Resources > Tools, select prl-tools-other.iso, and click Open.

4 In Windows, click Start > Settings > Control Panel > Display.

5 In the Display Properties dialog, go to the Settings tab and click the Advanced button.

6 On the Adapter tab, click Change. The wizard opens.

7 In the wizard, click Next.

8 Select Search for a better driver than the one your device is using now and click Next.

9 Select Specify a location option. Click Browse. Locate the \Drivers\Video\Win9x folder on the CD-ROM drive and click OK.

10 Click Next in the Update Device Driver Wizard and then, when the driver is found, click Next again.

11 Click Finish and then Close to close the Update Device Driver Wizard.
To install a video driver in Windows NT:

1. Start Windows NT.
2. When the guest OS boots up, in the Mac menu bar click **Devices > CD/DVD > Connect Image**.
3. Click **Applications**, double-click **Parallels Desktop > Contents > Resources > Tools**, select **prl-tools-other.iso**, and click **Open**.
4. In Windows, click **Start > Settings > Control Panel > Display**.
5. In the **Display Properties** dialog, go to the **Settings** tab and click the **Display Type** button.
6. In the **Adapter Type** section, click **Change**. The **Change Display** window opens.
7. In this window, click **Have Disk**.
8. Click **Browse**. Select the **\Drivers\Video\Nt4** folder on the CD-ROM drive and click **Open** twice.
9. In the **Install From Disk** window, click **OK**.
10. In the **Change Display** window, click **OK**.
11. Confirm that you want to install the video driver.
12. When you are prompted to restart the guest OS in the **System Settings Change** dialog box, click **Yes**.

The new settings are applied once the virtual machine is restarted.

### Customize the Keyboard for the Guest OS

By default, Parallels Desktop contains four profiles that represent sets of key combinations typical for the following OSs:

- Windows
- Linux
- Mac OS X
- Generic (for other guest OSs)
When you create or register a virtual machine, one of these profiles, depending on the guest operating system, is assigned to the machine by default. You can create your own profile and assign it to your virtual machines.

To create a custom keyboard profile or edit the existing profiles:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2. Click Shortcuts.
3 Select a virtual machine from the sidebar, click the **Profile** menu, and select **Edit profiles list**.

4 Do one of the following:

- To add a new profile, click the **Add** button. Specify the new profile name and select the base profile from the list. After the profile is created, you can submit the changes by clicking **OK**. Then select this new profile in the **Profile** list and configure its shortcuts.

- To remove one of the existing custom profiles, select it and click the **Remove** button.

- To duplicate or rename one of the existing profiles, select this profile, click the button, and select the corresponding action from the menu.

**Note:** You can rename or remove your custom profiles only.

In the **Shortcuts** pane of Parallels Desktop Preferences, you can also assign profiles to your virtual machines.

To change a profile assigned to a virtual machine:

- Select a virtual machine and choose a profile from the **Profile** menu.

**Emulate a Mouse Right-Click or Middle-Click**

To emulate a mouse right-click or middle-click:

1 Select **Mouse Shortcuts** in the sidebar.

2 Select **Secondary click** (for right-click) or **Middle click**.

3 Click in the corresponding text field and press the key or combination of keys that you want to use with a mouse click to trigger a right-click or middle-click.
You can use any combination of the Control, Option (Alt), Shift, and Command keys to specify the key combination that will be used to emulate a mouse right-click or middle-click in the virtual machine.

**Use OS X as a Guest OS**

If you are using OS X Lion or Mountain Lion, you can install a copy of OS X in a virtual machine and use it as a guest operating system. This can be useful, for example, if you want to test software in a fresh version of OS X without having to log in and out of your main account.

By default, an installation of OS X is stored in a recovery partition on your Mac. You can easily install OS X into a virtual machine from that partition without having to purchase or download another copy of OS X.

To install OS X in a virtual machine:

1. Open Parallels Desktop and choose **File > New**.
2. Select **Install OS X Using the Recovery Partition**, click **Continue**, and follow the onscreen instructions.

When using Lion or Mountain Lion as a guest OS, you can use it in Coherence mode (p. 41), so that guest OS application windows appear on the host OS desktop alongside host OS applications.

You can also copy and paste text and drag and drop files between host and guest Mac OS X, just as you can when using Windows as a guest OS.

You can set whether function keys and other system shortcuts trigger actions in the host or guest version of OS X (p. 70).
Use OS X in Coherence Mode

You can set an OS X virtual machine and OS X to work seamlessly together, as if they were part of a single operating system. In this mode, called Coherence mode, guest OS X applications appear on the host OS X desktop next to your host applications.

To enable the Coherence view mode, Parallels Tools must be installed (p. 148).

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

- Click the Coherence icon in the top right corner of the virtual machine window.
- Choose View > Enter Coherence.
- Press Control-Command-C.

To switch from Full Screen mode to Coherence mode, do one of the following:

- Press Control-Command-F to exit Full Screen. Then open the View menu and select Enter Coherence.
Install or Update Parallels Tools

Parallels Tools are a suite of behind-the-scenes tools that allow seamless operating between Mac OS X and Windows or another guest operating system.

This section gives an overview of Parallels Tools, and has information about how to install them for various guest operating systems.

Parallels Tools Overview

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly between the virtual machine and your Mac, change the virtual machine’s screen resolution by simply resizing its window, synchronize your virtual machine’s time and date settings with the time settings of the host computer, share your Mac’s disks and folders with its virtual machines, copy text and drag and drop objects from Mac OS to a virtual machine and vice versa.

Parallels Tools are available for the most popular Windows, Linux, and Mac OS X operating systems, and include the utilities listed below. All utilities supported by your guest OS are installed in your virtual machine as a single package when you install Parallels Tools.

<table>
<thead>
<tr>
<th>Utility</th>
<th>Available for</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mouse Synchronization Tool</td>
<td>Windows, Linux, Mac OS X</td>
<td>Mouse Synchronization Tool captures the mouse input in the virtual machine each time the pointer moves over its window and automatically releases the input when the pointer moves outside the window.</td>
</tr>
</tbody>
</table>
| Time Synchronization Tool     | Windows, Linux, Mac OS X | Time Synchronization Tool enables you to customize your virtual machine time settings. You can:  
  • Automatically synchronize the time settings of your virtual machine with your Mac time settings.  
  • Set up and maintain the time difference between your Mac and your virtual machine. |
<p>| Drag-and-Drop Tool            | Windows       | Drag-and-Drop Tool allows dragging and dropping files between your virtual machines and Mac OS. |</p>
<table>
<thead>
<tr>
<th>Tool</th>
<th>Platforms</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clipboard Synchronization</td>
<td>Windows, Linux</td>
<td>Enables you to easily exchange texts between:</td>
</tr>
<tr>
<td>Tool</td>
<td></td>
<td>• the virtual machine and your Mac.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• different virtual machines irrespective of the guest operating systems</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installed in them.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To copy and paste text, you should use the standard procedure for the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>current operating system. For example, to copy some text in the Windows</td>
</tr>
<tr>
<td></td>
<td></td>
<td>guest OS, select the text, and press Ctrl+C. To paste this text in Mac OS X,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>press Cmd+V, or select <strong>Paste</strong> from the shortcut menu.</td>
</tr>
<tr>
<td>Dynamic Resolution Tool</td>
<td>Windows, Linux, Mac OS X</td>
<td>Enables you to work with dynamic resolution. When you resize the guest OS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>window by dragging its lower right corner, the guest OS window</td>
</tr>
<tr>
<td></td>
<td></td>
<td>resolution changes automatically.</td>
</tr>
<tr>
<td>Shared Folders Tool</td>
<td>Windows, Linux, Mac OS X</td>
<td>Enables you to share Mac folders with the virtual machine and vice versa.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>With this tool, you can access your Mac folders from the virtual machine</td>
</tr>
<tr>
<td></td>
<td></td>
<td>and virtual machine folders from Mac OS X.</td>
</tr>
<tr>
<td>Coherence Tool</td>
<td>Windows, Linux</td>
<td>The Coherence tool allows you to work with your Windows or Linux applications like if they were Mac applications. It hides the virtual machine’s window leaving only guest OS and Mac applications visible.</td>
</tr>
<tr>
<td>Shared Profile Tool</td>
<td>Windows</td>
<td>Enables you to share your Mac desktop, pictures, documents, downloads,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>music and videos with your virtual machine, which allows you to access them</td>
</tr>
<tr>
<td></td>
<td></td>
<td>right from Windows.</td>
</tr>
<tr>
<td>Shared Applications Tool</td>
<td>Windows</td>
<td>Enables you to specify default applications for certain types of files, so</td>
</tr>
<tr>
<td></td>
<td></td>
<td>that you can open some types of files in Windows applications by default, and others - in Mac OS.</td>
</tr>
<tr>
<td>Shared Internet Applications</td>
<td>Windows</td>
<td>Enables you to specify default Internet browsers, including those installed</td>
</tr>
<tr>
<td>Tool</td>
<td></td>
<td>in the virtual machine, for different types of Internet pages. For example,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>you may set the Internet pages to open in your default Mac OS X Internet</td>
</tr>
<tr>
<td></td>
<td></td>
<td>browser, and FTP pages to open in your virtual machine Internet browser.</td>
</tr>
<tr>
<td>SmartMount</td>
<td>Windows, Linux, Mac OS X</td>
<td>Automatically detects volumes connected to your Mac and makes them available to the virtual machine as well.</td>
</tr>
<tr>
<td>Printing Tool</td>
<td>Windows</td>
<td>Allows you to synchronize the host and guest OS printers.</td>
</tr>
<tr>
<td>Tray Integration Tool</td>
<td>Windows</td>
<td>Allows you to use Windows tray icons in the Mac menu bar.</td>
</tr>
</tbody>
</table>
Parallels Tools are located on disc images that are installed together with Parallels Desktop. There is a separate Parallels Tools disc image for each type of the supported guest operating systems.

- prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems.
- prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems.
- prl-tools-mac.iso - disc image with Parallels Tools for Mac OS X guest operating systems.

These disc images can be found in the following location on your Mac:
<username>/Applications/Parallels Desktop/Contents/Resources/Tools.

Parallels Tools for Windows

**Important:** To take advantage of much of the functionality Parallels Desktop offers, Parallels Tools must be installed.

Parallels Tools can be installed in the following Windows guest operating systems:

- Windows 8
- Windows 7
- Windows Server 2008
- Windows Vista
- Windows XP
- Windows Server 2003
- Windows 2000

Installing Parallels Tools

If you chose **Express Installation** when you first installed Windows, Parallels Tools were installed automatically after the installation.

If you didn't choose **Express Installation**, do the following to install Parallels Tools:

1. Start Windows (p. 31).
2. When Windows boots up, choose **Install Parallels Tools** from the **Virtual Machine** menu.

   **Note:** After you choose **Install Parallels Tools** in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

3. Click **Continue** to connect the ISO image with Parallels Tools for Windows to the virtual machine's CD/DVD-ROM drive.
4. Click **Install Parallels Tools** to start the installation.
After you click Install Parallels Tools in Windows 7 and Windows Vista, User Access Control (UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to allow the installation.

5 When the installation is complete, click Restart to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

If the Parallels Tools ISO image doesn’t autoplay after you click Continue, the CD/DVD autorun must be disabled in your virtual machine. In this case, do the following to install Parallels Tools:

1 Open My Computer, right-click the Parallels Tools disc and choose Open.
2 Double-click the PTAgent file to start the installation.
3 When the installation is complete, click Restart to restart the virtual machine or wait for about 2 minutes and it will be restarted automatically.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the Virtual Machine Configuration dialog.

Reinstall or Update Parallels Tools

To reinstall Parallels Tools:

1 Start Windows (p. 31).
   Once Windows starts, if Parallels Desktop is in Coherence mode, click the Parallels icon in the menu bar and choose Exit Coherence.
2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.
   This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you will see the Update Parallels Tools option instead.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine’s window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.

Parallels Tools for Linux

Parallels Tools can be installed in Linux guest operating systems that comply with the following requirements:

- glibc 2.3.4 and later
- libstdc++ 3.4.6 and later (libstdc++.so.6)
- gcc 3.4.6 and later (including C++ support)
Preparation for installation

Before installing Parallels Tools in a Linux virtual machine, perform the following actions:

- Close all applications running on the virtual machine.
- If you use a 3D accelerated window manager, disable it.
- Make sure that you have the gcc package and kernel sources installed. If these packages are not installed, the Parallels Tools installer will inform you about this. The kernel sources package name depends on the type of Linux operating system you use: it can be `kernel-devel`, or `kernel-headers`, or something else. For more information about the kernel sources, refer to Installing the GCC package and Kernel Sources in Linux (p. 209).

Note: Some of Parallels Tools, like Shared Folders Tool and Time Synchronization Tool, may also work in the Linux operating systems that do not comply with the requirements listed above.

Note: To install Parallels Tools in your virtual machine, you must have the root privileges.

Installing Parallels Tools in the most recent versions of Linux systems

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) in your virtual machine, the `prl-tools-lin.iso` image file will be mounted automatically after you connect it to the CD/DVD drive. To install Parallels Tools, do the following:

1. Start the virtual machine.
2. When the operating system boots up, click Actions and choose Install Parallels Tools.

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements listed above.

The `prl-tools-lin.iso` image file will be mounted to the virtual machine's CD/DVD drive.

You can connect and mount the Parallels Tools ISO image file manually. In the Mac menu bar, click Devices > CD/DVD > Connect Image. In the Finder window, go to the hard disk folder (normally named “Macintosh HD”), select the /Library/Parallels/Tools/ folder, select the `prl-tools-lin.iso` file, and click Open to connect it to the virtual machine.

3. Start a terminal in your Linux guest OS. Type the following command to gain the root privileges:

   ```sh
su
   ```

4. Change the directory to the CD/DVD drive directory using

   ```sh
cd /media/cdrom/
   ```
Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear as `/media/Parallels\ Tools/.

5 In the CD/DVD drive directory, enter the following command to launch Parallels Tools installation:

```
./install
```

6 Follow the Parallels Tools Installer instructions to complete the installation.

7 When the installation of Parallels Tools is complete, restart your virtual machine.

### Installing Parallels Tools in other versions of Linux guest OSs

To install Parallels Tools in the older versions of Linux OSs, you have to mount the `prl-tools-lin.iso` image file manually. Do the following:

1 Start the virtual machine.

2 When the guest OS boots up, choose Install Parallels Tools from the Actions menu.

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system complies with the requirements for Parallels Tools installation.

The `prl-tools-lin.iso` image file will be connected to the virtual machine’s CD/DVD drive.

3 Start a terminal in your Linux guest OS. Type the following command to gain the root privileges:

```
su
```

4 Check if the Parallels Tools CD image is mounted by entering

```
mount | grep iso9660
```

   If this command does not return anything, proceed to the next step.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
   ```

   skip the next step and proceed to the following one.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0)
   ```

   with the noexec option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:

   ```
   umount /dev/cdrom
   ```

5 To mount the Parallels Tools installation disc image, enter the following:

```
mount -o exec /dev/cdrom /media/cdrom
```

Note: `/dev/cdrom` is the virtual machine’s CD/DVD drive and `/media/cdrom` is the mount point for this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as `/dev/hdb` and the mount point `/mnt/cdrom`. Some Linux OSs do not have the CD/DVD drive mount point. In this case, you should create the mount point directory manually.

6 When the installation disc image is mounted, change the directory to the CD/DVD drive directory using

```
cd /media/cdrom/
```
7 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:

```
./install
```

**Note:** You must have the root privileges to run this command.

8 Follow the Parallels Tools Installer instructions to complete the installation.

9 When the installation of Parallels Tools is complete, restart your virtual machine.

**Note:** If X Server fails to start in your virtual machine, you can install Parallels Tools manually in text mode.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the Virtual Machine Configuration dialog.

### How to check if Parallels Tools have been installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine’s window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard - they are released automatically.

### Troubleshooting

Parallels Tools installer can be blocked by SELinux. To solve this problem:

1 Start a terminal and determine your version of kernel by entering

```
uname -r
```

```
2.6.18-8.el5
```

2.6.18-8.el5 is the version of your kernel.

2 Open the `/boot/grub/grub.conf` file or `/boot/grub/menu.lst` (depends on the version of your Linux operating system) and find the entry that corresponds to your version of kernel.

```
title Red Hat Enterprise Linux Server (2.6.18-8.el5)
root (hd0,0)
k kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-8.el5.img
```

3 Type the following text at the end of the entry:

```
se linux=0
```

and the whole entry will be:

```
k kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet selinux=0
```

4 Save the file and restart the virtual machine.

After the restart, mount the Parallels Tools disc image and try to install Parallels Tools.
Update Parallels Tools

If a newer version of Parallels Tools for Linux is available, the Parallels Tools Installation Agent window appears. You’re prompted to choose the command to gain root privileges and enter the password (if `su` - root password, if `sudo` - your user’s password). After that, Parallels Tools update automatically.

Reinstall Parallels Tools

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them once again.

Installing and Upgrading Parallels Tools in Text Mode in Linux

After upgrading to Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix the problem, you need to install Parallels Tools in text mode.

1. Start the virtual machine.
2. When you see a message that X Server failed to start, switch to another virtual console using Ctrl+Option+F1 (Ctrl+Alt+F1) and enter your login details.
3. Choose Install Parallels Tools from the Actions menu to connect the Parallels Tools ISO image to your virtual machine.

   **Note:** If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the Parallels Tools Overview section in Parallels Desktop User's Guide.

   The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive.

4. In the virtual machine console, type the following command to gain the root privileges:

   ```
su
   ```

5. Check if the Parallels Tools CD image is mounted by entering

   ```
   mount | grep iso9660
   ```

   If this command does not return anything, proceed to the next step.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0),
   ```

   skip the next step and proceed to the following one.

   If this command returns anything like

   ```
   /dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0)
   ```

   with the noexec option present in parentheses, you need to unmount the disc using the following command and then proceed to the next step:

   ```
   umount /dev/cdrom
   ```

6. To mount the Parallels Tools installation disc image, enter the following:

   ```
   mount -o exec /dev/cdrom /media/cdrom
   ```
When the installation disc image is mounted, change the directory to the CD/DVD drive directory using:
```
cd /media/cdrom/
```

In the CD/DVD drive directory, enter the following to launch Parallels Tools installation:
```
./install
```

**Note:** You must have the `root` privileges to run this command.

Follow the Parallels Tools Installer instructions to complete the installation.

When the installation of Parallels Tools is complete, restart your virtual machine.

For general information on installing Parallels Tools in Linux, refer to *Installing Parallels Tools in a Linux Guest OS*.

### Parallels Tools for Mac

#### Install Parallels Tools

To install Parallels Tools in an OS X virtual machine:

1. Start the OS X virtual machine.
2. When OS X boots up, choose `Actions > Install Parallels Tools` and follow the onscreen instructions.

#### Reinstall Parallels Tools

To reinstall Parallels Tools:

1. Start your OS X virtual machine (p. 31).
2. When Windows boots up, choose `Reinstall Parallels Tools` from the `Virtual Machine` menu.

#### Update Parallels Tools

If a newer version of Parallels Tools for Mac is available, Parallels Tools update automatically.
Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears in the status bar of the virtual machine’s window, this means that Parallels Tools were not installed. When Parallels Tools are installed, you do not need to press any key to release the mouse and keyboard. They are released automatically.

Install Sound Driver in OS/2 and eComStation

Sound driver for OS/2 and eComStation can be installed from the prl-tools-other.iso CD image. Before starting the installation, connect the CD image with Parallels Tools to your virtual machine’s CD/DVD drive. Choose Install Parallels Tools from the Actions menu.

Before installing Sound Driver, make sure you have the multimedia support installed in the guest operating system.

To install Sound Driver:

1. Click the System Setup icon on the system panel.
2. Select Install/Remove line and then select Multimedia Application Install.
3. In the IBM Multimedia Presentation Manager/2 - Installation window choose the CD/DVD drive, then the <CD-ROM drive>\Drivers\Sound\OS2 directory. Select the ALC Codec feature and click the Install button.
4. Restart the guest operating system.

For Software Developers

This section contains the topics with the information for software developers.

Optimize Remote Debugging

The Parallels plugin for Visual Studio allows you to develop software in one virtual machine and test it in other virtual machines with just one click.

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

Requirements

To use this plugin, you need the following:
Advanced Topics

- A Windows 7 (or later) virtual machine with Visual Studio Professional/Enterprise 2013 (or later).
- Other running virtual machines (with Windows 7 or later) in which you will test the project.
- The virtual machine with Visual Studio and other virtual machines must belong to the same pool of IP addresses, or just configured to use the shared network (p. 162).
- All virtual machines must have Parallels Tools (p. 140) installed.
- The virtual machine with Visual Studio must have the **Access Windows folders from Mac** option (p. 52) selected.
- Other virtual machines must have the **Share Folders: All disks** option (p. 52) selected.
- The user accounts logged in to the virtual machines in which you’re going to test your project must have both username and password and you must know them.

**Install the Parallels Plugin for Visual Studio**

To install the Parallels plugin, do the following:

1. In the virtual machine with Visual Studio, navigate to the directory where Parallels Tools are installed. In most cases, it is **C:\Program Files (x86)\Parallels\Parallels Tools\DevTools**.
2. Double-click the **VMDebugHelper.vsix** file. The plugin for Visual Studio will be installed automatically.

**How It's Working**

To start remote debugging of your project, follow these steps:

1. In the virtual machine where Visual Studio is installed, open Visual Studio and open your project.
2. Build the project and test it locally.
3. Click **PARALLELS > Start Debugging in VM** and select the virtual machine you need (this virtual machine must be running).

![Start Debugging in VM](image)

You project will open in the selected virtual machine.

**Run Windows Phone Emulator**

Parallels Desktop allows you to develop and test software for Windows Phone on your Mac. You need the following:

- A Mac computer with at least 4 GB of memory (more is better)
To find out how much memory your Mac has, click the Apple menu and choose **About This Mac**.

- The latest version of Parallels Desktop 12 for Mac installed.

To check whether an update is available, open Parallels Desktop and click **Parallels Desktop > Check for Updates**. If an update is available, install it.

- A Windows 8 Professional (64-bit) or Windows Server 2012 (64-bit) virtual machine with 1 CPU and 2 GB of memory (4 GB recommended if your Mac has 8 GB).

  **Note:** Windows with 2 CPUs or more may perform unstably. Parallels is currently working to fix this issue.

To learn how to install Windows on your Mac, see **Install Windows from an Installation Disc** (p. 18). To learn how to set Windows to use 1 CPU and 2 GB of memory, see **Set How Much Memory is Allocated to Windows** (p. 100) and **Set How Many Processors are Allocated to a Virtual Machine** (p. 127).

### Configure Windows to Run Windows Phone Emulator

Once your system meets the above requirements, do the following to configure Windows to run Windows Phone emulator:

1. Select **Enable** next to **Nested Virtualization** in the **Optimization** pane (p. 100) to enable Hyper-V support in Windows.

   **Note:** Enabling Hyper-V support may slightly slow down your Windows performance. If you don’t use Hyper-V anymore, it is recommended to disable this option.

2. Start Windows and make sure you have Windows Phone SDK installed. If necessary, you can download the SDK here.
3 Open Visual Studio for Windows Phone, create a new project, and start Windows Phone emulator. In this step, you may get the following error:

4 If so, close Visual Studio and start Hyper-V Manager.
5 Select the virtual machine you’re going to use to develop or test software for Windows Phone (the default virtual machine is **Emulator WVGA 512MB**), open the virtual machine configuration settings, and change the number of processors from 2 to 1.

![Hyper-V Manager](image)

*Note:* If you didn’t set Windows to use 1 CPU as recommended above, do not change the number of processors in the Hyper-V virtual machine.

6 After these steps, you can open Visual Studio and start creating or testing Windows Phone applications.

![Visual Studio](image)

**Generate a Core Dump**

*Note:* This functionality is available in Parallels Desktop for Mac Pro Edition only.
Advanced Topics

If you need to generate the virtual machine memory dump, you can do this from Parallels Desktop. When the virtual machine is running, click the Develop menu (p. 160) in the OS X menu bar and choose Generate Core Dump. For more details on where the dump is stored and how to convert it to the Linux, Windows or OS X format, please refer to the prlcore2dmp topic of the Parallels Desktop Pro Edition Command-Line Reference Guide available online.

Start a Debugging Session

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

You can start a debugging session directly from Parallels Desktop. When the virtual machine is running, click the Develop menu (p. 160) in the OS X menu bar and choose Start Debugging Session.

Integration With Chef/Ohai

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you're using Chef to provision your Parallels virtual machines or host systems running Parallels Desktop, you can check in the recipe that the type of system virtualization being used is virtualization from Parallels. To do this, use the node['virtualization'] attribute. This attribute is set by Ohai during the chef-client run.

**Note:** The Ohai version must be 8.6.0 or later.

You will see the following in the host system:

```
"virtualization": {
  "systems": {
    "parallels": "host"
  },
  "system": "parallels",
  "role": "host"
}
```

And the following in the guest system:

```
"virtualization": {
  "systems": {
    "parallels": "guest"
  },
  "system": "parallels",
  "role": "guest"
}
```

Integration With Docker

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.
Parallels Desktop allows you to run and manage Docker containers as if they were running directly on your Mac. You just need a Linux-based virtual machine (Boot2Docker) that will host your containers.

For more details, please refer to the Docker Machine official documentation: https://docs.docker.com/machine/

**Note:** When this topic was being written, Docker Machine didn’t fully support Parallels Desktop. While we’re still working and improving this feature, you can use our custom-built executable file available here.

Use Virtual Machine Names as DNS Names

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

When you start a virtual machine operating in the shared (p. 162) or host-only (p. 166) networking mode and it gets an IP address via DHCP, the virtual machine gets registered in the OS X `etc/hosts` file and you can use its name to connect from the host operating system or other virtual machine operating in the shared (p. 162) or host-only (p. 166) networking mode.

For example, after starting such a virtual machine, your `etc/hosts` file may look as follows:

```
10.211.55.3     windows-8.1.shared windows-8.1 #prl_hostonly shared
```

You can use the virtual machine name (`windows-8.1.shared`) to connect to this virtual machine. For example, if you execute the following command in the OS X Terminal:

```
ping windows-8.1.shared
```

you will start pinging 10.211.55.3.

When such a virtual machine is shut down, its registration entry is removed from the `etc/hosts` file.

Resolve Guest OS DNS Requests Using `etc/hosts`

**Note:** This functionality is available in Parallels Desktop for Mac Pro Edition only.

When a virtual machine operating in the shared networking mode (p. 162) sends a DNS request, the request is now resolved also using the OS X `etc/hosts` file.

For example, if your OS X `etc/hosts` file contains the following entry:

```
1.2.3.5         testh
```

and you start pinging `testh` in a virtual machine, the guest OS will check the OS X `etc/hosts` file first and start pinging 1.2.3.5.
Other Actions

Using Parallels Desktop, you can also:

- Optimize your virtual machine for software development (p. 104);
- Simulate various Internet connectivity speeds (p. 189);
- Download pre-configured virtual appliances (p. 125);
- Enable nested virtualization support (p. 176); and
- Enable PMU virtualization support (p. 176).

Set File Type Associations

When working with Parallels Desktop, you may need to open an OS X file in some Windows application or a Windows file in some OS X app. If you often need to do so, SmartSelect allows you to make your OS X files always open in Windows applications as well as make your Windows files always open in OS X apps.

**Note:** This functionality is available only for Windows XP and later versions with Parallels Tools installed (p. 140).

**Associate OS X files with a Windows application**

To make some type of OS X files always open in a Windows application, do the following:

1. Right-click an OS X file, point to **Open with** and click **Other**.
2. Navigate to **Macintosh HD > Users > <user name> > Applications (Parallels)** and open the required virtual machine folder.
3. Select a Windows application you want and click **Open**.
4. Parallels Desktop shows an OS X notification asking whether you want to make the application default for this type of files. Click **Make**. Now all files of this type will open in the selected Windows application.

You can also make some type of OS X files always open in a Windows application the following way:

1. Right-click an OS X file and choose **Get Info**.
2. In the **Open with** section, click the **Open with** menu and choose **Other**.
3. Navigate to **Macintosh HD > Users > <user name> > Applications (Parallels)** and open the required virtual machine folder.
4. Select a Windows application you want, choose **Always Open With** and click **Add**.
5 Click Change All and close the file info menu. Now all files of this type will open in the selected Windows application.

**Associate Windows files with an OS X application**

For Windows 10:

To make some type of Windows files always open in an OS X application, do the following:

1. Right-click a Windows file and choose Open with > Choose another app.
2. Select the OS X application you want to use with that type of file and make sure Always use this app to open `<file_extension>` files is selected. Now all files of this type will open in the selected OS X application.

For Windows 8 and Windows 7:

To make some type of Windows files always open in an OS X application, do the following:

1. Right-click a Windows file and choose Open with > Choose default program.
2. Select the OS X application you want to use with that type of file and make sure Use this app for all `<file_extension>` files is selected. Now all files of this type will open in the selected OS X application.

**Modality Mode**

When you switch to Modality, you can resize the virtual machine windows and place them side by side with your Mac’s applications.

In the Modality mode, you can:

- Resize the Windows window while keeping its shape by dragging its lower-right corner.
- Resize the Windows window by pressing and holding the Option (Alt) key and dragging the lower-right corner of the window.
- Resize the Windows window and dynamically adjust the screen resolution by pressing and holding the Shift and dragging the lower-right corner of the window.

Using the Modality settings, you can configure the virtual machine appearance and behavior when it is running in the Modality mode. In the Modality mode, you can resize the virtual machine windows and place them side by side with your Mac applications. A Modality window can be scaled to any size, and its content will still be active. This allows you to monitor the tasks running inside the virtual machine while you are working on the Mac side.

To edit these settings, do the following:

1. Click the Parallels icon in the menu bar and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 In the Virtual Machine Configuration window, click Options and select the settings name in the sidebar.

You can configure the settings in this pane even when the virtual machine is running.

In the Modality mode, the virtual machine window becomes transparent by default. You can specify the level of visibility in the Opacity field by dragging the slider between Transparent and Opaque. You can change the level of transparency for your virtual machine that is running when it is in the Modality mode.

To manage the behavior of the virtual machine window in the Modality mode, use the following options selected by default:

- **Keep on top of other windows**. Clear this option if you do not want the virtual machine window to appear on top of all other open windows when the virtual machine is in Modality.
- **Capture keyboard and mouse on click**. Clear this option if you do not want the virtual machine to capture the keyboard and mouse input when in Modality.

**Hide and Show Parallels Desktop**

When Parallels Desktop is running, you can hide and show it and all its windows by holding down the Function (Fn) key and pressing the F6 key.

If Parallels Desktop is visible but running in the background, pressing Fn-F6 brings Parallels Desktop and all its windows to focus.
Note: Most function keys (F1, F2, and so on) on Mac keyboards serve as specific control keys, such as volume and brightness controls, and you must hold down the Fn key as you press the function key to trigger an alternate, application-specific function. If you want to set function keys to be used for alternate functions without having to press the Fn key, choose Apple menu > System Preferences and click Keyboard. Then click the Keyboard tab and choose Use all F1, F2, etc. keys as standard function keys.

Disable Automatically Suspending Windows

By default, when you quit Parallels Desktop, Windows is suspended, and the next time you open Parallels Desktop Windows resumes exactly from where you left off.

If more than one person uses Windows on your Mac, then a user can access the account in Windows suspended by the previous user. To avoid this, you can disable automatically suspending Parallels Desktop.

To disable automatically suspending Parallels Desktop:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Preferences. Then click General.
   - Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click General.

2. Select OS X Resume: Disable for Parallels Desktop.

Once automatically suspending Windows is disabled, each time you quit Parallels Desktop you can specify how you want Windows to shut down (p. 36). And if you close the Parallels Desktop window, Windows shuts down according to how it’s set in shutdown settings (p. 38). To ensure that another user can’t access your Windows account, set windows to shut down or stop (rather than suspend).

Remove Parallels Desktop

To remove Parallels Desktop, open your Applications folder and drag the Parallels Desktop application to the Trash.
Advanced Preferences

In the Advanced pane of Parallels Desktop Preferences, you can configure some additional settings.

Speech

Parallels Desktop allows you to operate your virtual machine by using the speech commands. If you want to do that, select Enable spoken commands and make sure that:

- the virtual machine window is active, and
- the speech settings are properly tuned on the corresponding tab of Mac OS X System Preferences

If the speech settings are not tuned, you will see the 'To enable this option, you should turn on speakable items in System Preferences' warning message. To tune the speech settings, click System Preferences.

To view the list of all spoken commands available to manage your virtual machines, please refer to Enable Spoken Commands (p. 127).
Feedback

To participate in the Customer Experience Program, select the corresponding option. If you join this program, Parallels will collect information about your Mac and virtual machines configuration. The collected information will help us to make the product better fit your needs.

If you join, only the following types of data will be collected:

• hardware configuration of your Mac
• software configuration of your Mac and virtual machines (the names and versions of the operating systems and software installed in them)
• configuration files of virtual machines

Any types of private information like your name, e-mail, address, phone number, and keyboard input will not be collected.

For more details, visit the Customer Experience Program page at the Parallels website (follow the link in the pane).

Troubleshooting

While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels support team for solving problems and improving the product. If you select the Use detailed log messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

Resetting Hidden Messages

Some Parallels Desktop dialogs and windows are provided with the Do not show this message again option. If you select this option, the corresponding dialog will not appear next time you perform the same operation. Using the Reset Warnings button, you can reset all dialogs and windows with this option selected so that they would be displayed again each time you initiate the corresponding operation.

Developer Tools

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

Parallels Desktop has several useful features for software developers. If you select the Show developer tools option, the Develop menu will be available in the OS X menu bar. From this menu, you can:

• Start an SSH session;
• Open the virtual machine IP address in the OS X default web browser;
• Start a debugging session, or
• Generate the virtual machine memory dump.

**Locking Parallels Desktop Preferences**

If you want to prevent Parallels Desktop Preferences from further unauthorized changes, click the Lock icon at the bottom of the window. The next time anybody wants to change the settings in any pane of Parallels Desktop Preferences, an administrator's password will be required.

**Shared Networking Settings**

*Note: Shared network settings are available in Parallels Desktop for Mac Pro Edition only.*
To change the shared networking settings, select the **Network** tab of Parallels Desktop Preferences and click **Shared**. You will see the following window:

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your virtual machines operating in the shared networking mode. To disable any of these servers, clear the corresponding option.
For more information about configuring shared networking, refer to Share Network Settings Between Mac OS X and Windows (p. 95).

**Port Forwarding**

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from external computers. The port forwarding functionality allows computers on your local network and on the Internet to transfer data to any of your virtual machines that use the shared networking mode. The data sent to a specific port on your Mac will be redirected to a specific port of your virtual machine according to the port-forwarding rule.

To add a port forwarding rule:

1. Click the Add button below the Port forwarding rules list.
2. In the displayed window, do the following:
   - In the Protocol field, specify the port type you want to use for establishing network connections. You can choose between the TCP or UDP port types.
   - In the Source Port field, type the number of the incoming port on your Mac.
   - In the Forward to section, indicate the name or IP address of the virtual machine you want to connect.
• In the Destination Port field, type the port on the virtual machine to which the data will be transferred.

3 Click OK to add the rule.

When the rule is added, use the following IP address combination for external connections to your virtual machine: <you Mac's IP address>:<Incoming port>.
To edit a rule, select it in the Port forwarding rules list, click the Edit button, modify the necessary settings, and click OK to apply them.

To remove a port forwarding rule, select it in the Port forwarding rules list and click the Remove button.

To restore the default settings, click Restore Defaults.

Host-Only Networking Settings

Note: Host-Only network settings are available in Parallels Desktop for Mac Pro Edition only.
To change the host-only networking settings, select the **Network** tab of Parallels Desktop Preferences and click **Host-Only**. You will see the following window:

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to the virtual machines operating in the host-only networking mode. To disable any of these servers, clear the corresponding option.
Advanced Topics

To restore the default settings, click **Restore Defaults**.

For more information on configuring the host-only networking settings, refer to **Use Host-Only Network Settings** (p. 98).

## Create a Custom Host-Only Network

When working with Parallels Desktop, you can use an already configured shared or host-only networks. If you need to manage network traffic between virtual machines, you can add a new host-only network.

**Note:** You can add new host-only networks in Parallels Desktop for Mac Pro Edition only.

To add a new host-only network:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Preferences**. Then click **Network**.
   - Right-click the Parallels Desktop icon in the Dock and choose **Preferences**. Then click **Network**.

2. Click the **Add** button. Once a new host-only network is added, configure its settings the way you need.

To remove a custom host-only network, select it and click the **Remove** button.

## More Options

In the **More Options** pane, you can configure the Parallels Desktop additional settings.

To edit these settings, do the following:

1. Open the **Actions** menu or click the Parallels icon in the Mac menu bar and click **Configure**.
In the **Virtual Machine Configuration** window, click **Options** and select the settings name in the sidebar.

**Time Synchronization**

Select **Sync from OS X** to synchronize Windows time settings with those of your Mac.

If you want Windows and Mac OS X time settings to always be the same, select **Sync from either OS**. With this option selected, if you manually change the time settings in Windows, they are changed accordingly in Mac OS X and vice versa.

If the time zone set in your virtual machine differs from that of your Mac, you can maintain this time difference by selecting **Do not sync**.

**Copy & Paste**

If you want to copy and paste data between the host and guest operating systems, select **Share Mac clipboard**. If the data you copy and paste between Mac OS X and your virtual machine is text and you want to preserve text formatting, select ** Preserve text formatting**.

**Note:** This functionality is available only for virtual machines with Parallels Tools installed (p. 199).

**Windows Touchpad Gestures**

Select **Enable swipe from edges** to enable edge swipe gestures, for example, swiping from the right edge of the touchpad to show the Charm Bar, when working with Windows.

**Note:** This option is available for Windows 8 and later.
If you often accidentally swipe from the edges of the touchpad and activate features, you may want to disable edge swipe gestures by deselecting this option.

**Apple Remote**

Select **Enable Apple Remote** to use the Apple Remote to control some Windows applications.

For detailed information on using Apple Remote, see *Control Programs with Trackpad Gestures* or the *Apple Remote*.

**Current Location**

Some of Windows applications may ask your permission to use your current location. To allow this, select **Allow Windows to access your Mac's current location**.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Adding and Removing Devices**

Adding new devices to a virtual machine is easier than connecting new devices to a real computer. Removing or disconnecting devices is also easy. The following virtual devices can be added to the configuration or removed from it:

- virtual hard disk drive
- CD/DVD drive
- floppy disk drive
- network adapter
- serial port
- printer port
- sound device
- USB controller

Any of the aforementioned devices can be added to the corresponding virtual machine only when it is stopped.

**Note:** To be able to connect any virtual device to a real one, you should have system privileges to access the real device. Otherwise, the real device will not appear in the list of available devices even though it is installed on your computer.
Adding a New Device to a Virtual Machine

1. Choose **Configure** from the **Actions** menu to open Virtual Machine Configuration.

2. Click the **Hardware** button at the top of the **Virtual Machine Configuration** dialog to open the pane for editing hardware devices.

3. Click the **Add** button in the bottom part of the **Virtual Machine Configuration** dialog and select the device to be added to your virtual machine.

   **Note:** The **Add** button is disabled when the virtual machine is running. You need to stop the virtual machine before you can use this button.

4. If you selected any device except for a hard disk, the corresponding device with a typical configuration is added at once and ready for use.

   If you selected a hard disk, you should specify some parameters:
   - The hard disk type: a new image file or an existing one. Select Boot Camp if you want to add an existing Boot Camp partition as a hard disk to your virtual machine.
   - The hard disk location. Provide the path on your Mac to the existing image file or the path and name for the new image file. By default, Parallels Desktop offers to save the new image file in the virtual machine PVM bundle.
   - The hard disk size for the new hard disk image file.
For the new hard disk image file, you can choose one of the following formats: Expanding or Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk, clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split the disk image to 2 GB files option. For more information on hard disk formats, refer to Support for Virtual and Real Disks (p. 172).

Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it. For detailed information on how to initialize the newly added hard disk, see Initializing the Newly Added Disk (p. 174).

After the new device is added, you can manage its properties as usual and start using it.

Removing Devices From the Virtual Machine Configuration

1 Choose Configure from the Actions menu to open Virtual Machine Configuration.
2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the pane for editing hardware devices.
3 Select the device you want to remove and click the Remove button in the bottom part of the Virtual Machine Configuration dialog.

Support for Virtual and Real Disks

This section lists the types of disks that can be used by Parallels virtual machines and provides the information about basic operations you can perform on these disks.
Supported Types of Hard Disks

Parallels virtual machines can use either virtual hard disks or Boot Camp partitions as their hard disks.

Virtual Hard Disks

The capacity of a virtual hard disk can be set from 100 MB to 2 TB.

Virtual hard disks can be of either plain or expanding format.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plain</td>
<td>A plain virtual hard disk image file has a fixed size. The size is determined when the disk is created.</td>
</tr>
<tr>
<td>expanding</td>
<td>An expanding virtual hard disk image file is small initially. Its size grows as you add applications and data to the virtual hard disk in the guest OS.</td>
</tr>
</tbody>
</table>

When you create a virtual machine, the disk is created in the expanding format. You can change the disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain hard disk to your virtual machine, clear the Expanding disk option when adding a hard disk to the virtual machine.

Split disks

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB pieces and is stored as a single .hdd file.

Boot Camp Partitions

With Parallels Desktop, you can choose how to use your Boot Camp Windows XP, Windows Vista, or Windows 7 operating system: to boot in it natively (via Boot Camp) or in a virtual machine (via Parallels Desktop). A Boot Camp Windows partition can be used as a bootable disk or as a data disk in Parallels virtual machines. For detailed information, see Using the Boot Camp Partition in a Virtual Machine.

Note: You cannot create snapshots or use the Undo Disks option for a virtual machine that uses the Boot Camp partition.

CD/DVD Discs and Their Images

Parallels Desktop can access real CD/DVD discs and images of CD/DVD discs.

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can play back audio CDs without any limitations on copy-protected discs.
Advanced Topics

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a virtual machine.

Parallels Desktop supports CD/DVD disc images in the ISO, CUE, and CCD formats.

**Note:** DMG disk images made with Mac OS X Disk Utility are also supported by Parallels Desktop. When creating such an image, make sure you create a read-only and uncompressed image without any encryption.

Floppy Disks and Floppy Disk Images

Parallels Desktop can use two types of floppy disks:

- Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine.
- Floppy disk image files having the .fdd extension and connected to the virtual machine.

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy disk image files that have the .fdd extension and 1.44 MB size.

Initialize a Newly Added Disk

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible to the operating system installed inside the virtual machine until the moment you initialize it.

**Initializing the New Virtual Hard Disk in Windows**

To initialize a new virtual hard disk in a Windows guest OS, you will need the Disk Management utility available. For example, in Windows 7 and Windows XP you can access this utility by doing the following:

- In Windows 7, click Start > Control Panel > System and Security > Administrative Tools > Computer Management Storage > Disk Management.
- In Windows XP, click Start > Control Panel > Administrative Tools > Computer Management > Storage > Disk Management.

When you open the Disk Management utility, it automatically detects that a new hard disk was added to the configuration and launches the **Initialize and Convert Disk** wizard:

1. In the introduction window, click Next.
2. In the Select Disks to Initialize window, select the newly added disk and click Next.
3. In the Select Disks to Convert window, select the newly added disk and click Finish.
The added disk will appear as a new disk in the Disk Management utility window, but its memory space will be unallocated. To allocate the disk memory, right-click this disk name in the Disk Management utility window and select **New Simple Volume** in Windows Vista or **New Volume** in Windows XP. The **New Simple Volume Wizard/New Volume Wizard** window will appear. Follow the steps of the wizard and create a new volume in the newly added disk.

After that your disk will become visible in **Computer/My Computer** and you will be able to use it as a data disk inside your virtual machine.

**Initializing the New Virtual Hard Disk in Linux**

Initializing a new virtual hard disk in a Linux guest OS comprises two steps: (1) allocating the virtual hard disk space and (2) mounting this disk in the guest OS.

To allocate the space, you need to create a new partition on this virtual hard disk using the **fdisk** utility:

**Note:** To use the **fdisk** utility, you need the **root** privileges.

1. Launch a terminal window.
2. To list the IDE disk devices present in your virtual machine configuration, enter:
   
   ```
   fdisk /dev/hd*
   ```

   **Note:** If you added a SCSI disk to the virtual machine configuration, use the **fdisk /dev/sd*** command instead.

3. By default, the second virtual hard disk appears as **/dev/hdc** in your Linux virtual machine. To work with this device, enter:

   ```
   fdisk /dev/hdc
   ```

   **Note:** If this is a SCSI disk, use the **fdisk /dev/sdc** command instead.

4. To get detailed information about the disk, enter:
   
   ```
   p
   ```

5. To create a new partition, enter:
   
   ```
   n
   ```

6. To create the primary partition, enter:
   
   ```
   p
   ```

7. Specify the partition number. By default, it is 1.

8. Specify the first cylinder. If you want to create a single partition on this hard disk, use the default value.

9. Specify the last cylinder. If you want to create a single partition on this hard disk, use the default value.

10. To create a partition with the specified settings, enter:

    ```
    w
    ```
Advanced Topics

When you allocated the space on the newly added virtual hard disk, you should format it by entering the following command in the terminal:

```bash
mkfs -t <FileSystem> /dev/hdc1
```

**Note:** `<FileSystem>` stands for the file system you want to use on this disk. It is recommended to use ext3 or ext2.

When the added virtual hard disk is formatted, you can mount it in the guest OS.

1. To create a mount point for the new virtual hard disk, enter:

```bash
mkdir /mnt/hdc1
```

**Note:** You can specify a different mount point.

2. To mount the new virtual hard disk to the specified mount point, enter:

```bash
mount /dev/hdc1 /mnt/hdc1
```

When you mounted the virtual hard disk, you can use its space in your virtual machine.

**Hardware Settings**

Using the **Virtual Machine Configuration** dialog, you can configure the virtual hardware available in your virtual machine:

- Configure the devices currently available inside the virtual machine.
- Add or remove devices.
- Configure the boot order of your virtual machine.

**CPU and Memory**

Using **CPU&Memory** settings, you can:

- Set how many processors are allocated to Windows (p. 127)
- Set how much memory is allocated to Windows (p. 100)
- Enable virtualization support in Windows (for Windows 8 and Windows Server 2012 only)

**Enable nested virtualization support**

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

Parallels Desktop 12 allows you to run Hyper-V virtual machines inside Windows 8 and Windows Server 2012 virtual machines, and to run Xen and kernel-based virtual machines in versions of Linux that support Xen and KVM.
To enable nested virtualization support, select **Enable nested virtualization**.

If you want to create or test applications for Windows Phone, first configure Windows to run Windows Phone emulator (p. 150).

**Warning:** Do not use Hyper-V virtual machines in a production environment. Microsoft® doesn't support nesting Hyper-V, and so such virtual machines may be unstable.

**Enable PMU virtualization support**

**Note:** This feature is available in Parallels Desktop for Mac Pro Edition only.

If you’re using virtual machines for software development, you can use a performance monitoring tool, such as Intel VTune Amplifier or OProfile, to optimize the code.

To get started using a performance monitoring tool:

1. Enable PMU (Performance Monitoring Unit) virtualization support by selecting **PMU virtualization**.
2. Start your virtual machine.
3. Either start using a built-in profiling utility or download and install any performance monitoring tool you like.

**Notes:**

1. PMU virtualization support can be enabled in Windows (starting from Windows XP) and Linux virtual machines.
2. Enabling PMU virtualization support may slightly slow down your virtual machine performance.

**Boot Order**

Using the **Boot Order** settings, you can configure the virtual machine boot sequence, that is, the order in which the virtual machine will try to load the operating system from different boot devices.

**Note:** These settings cannot be changed when the virtual machine is running.

To edit the **Boot Order** settings, do the following:

1. Click the Parallels icon in the menu bar and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.
2 In the Virtual Machine Configuration dialog, click Hardware and select Boot Order in the sidebar.

The currently supported boot devices are listed below:

- **Hard Disk.** Select this device if you want the virtual machine to boot up from its virtual hard disk drive.
- **CD/DVD-ROM.** Select this device if you want the virtual machine to boot up from the media connected to its virtual CD/DVD-ROM drive.
  
  **Note:** The virtual machine will use the CD/DVD-ROM drive specified as **CD/DVD-ROM 1** in its configuration.

- **External device.** Select this device if you want the virtual machine to boot up from a bootable external device (USB, FireWire, Thunderbolt, etc.) connected to your Mac. Once selected, choose the device from the External boot device menu located below.

- **Floppy Disk.** Select this device if you want the virtual machine to boot up from a floppy disk image connected to its virtual floppy disk drive.
• **Network.** Select this device if you want your virtual machine to boot from a network adapter using PXE (Pre-Execution Environment).

  **Note:** The virtual machine will use the network adapter specified as **Network 1** in its configuration.

Every time you start the virtual machine, it tries to boot from the device specified as the first one in the **Boot Order** list. If the virtual machine cannot boot from the first device (for example, no media is connected to it), the virtual machine proceeds to the second device in the list and tries to boot from this device, and so on.

In this pane, you can perform the following operations:

• Change the currently set boot sequence by selecting the name of the corresponding boot device in the **Boot Order** list and moving it up or down using the arrows to the right of the list.

• Remove a boot device from the sequence by clearing the check box next to its name.

If you choose the **Select boot device on startup** option, you will see the following message at the virtual machine startup: "Press ESC to select boot device". If you press ESC pending 5 seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will try to boot from the devices specified in the **Boot Order** list.

  **Note:** Make sure that the device you wish to use for your virtual machine booting (hard disk drive, CD-ROM drive, floppy disk drive, or network adapter) is available to the virtual machine and configured properly. If you do not have any boot devices configured in your virtual machine, you will see the following error message after you start the virtual machine: "No boot device is available". In this case, you should stop the virtual machine and configure at least one boot device for it.

**Boot Windows Securely**

Pirated versions of Windows may have backdoors through which hackers have full access to the system and data. If you’re working with Windows 8 or later in Parallels Desktop for Mac Pro Edition, you can configure Windows to check the boot loader on startup. This allows to prevent the execution of unsigned and potentially dangerous code.

To configure Windows to boot securely, select **EFI Secure Boot**. If a user tries to start a virtual machine with an illegal version of Windows, Secure Boot detects unauthorized changes to the firmware, operating system, or UEFI drivers and prevents such an operating system from starting.

**Boot Flags**

The **Boot flags** field is intended for specifying the flags that can change the virtual machine system behavior. The system flags can be used by the Parallels customer support team in cases when something goes wrong in your virtual machine. It is not recommended to type anything into this field without being instructed to do so by the customer support staff.
Advanced Topics

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

Graphics

To view and configure the amount of video memory available to the virtual machine video card, use the Graphics settings.

To edit these settings, do the following:

1. Click the Parallels icon in the menu bar and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select Graphics in the sidebar.
**Note:** These settings cannot be changed when the virtual machine is running.

In the **Memory** field, you can set the amount of video memory that will be available to the virtual machine.

To configure the video memory limit, do one of the following:

- Drag the slider
- Use the spin box arrows
- Type the value directly into the **Memory** field

**Working with Windows on Retina Display**

If you’re working with Windows 7 or later on a Mac with a Retina display, you can choose how Windows is displayed on the screen:
**Advanced Topics**

- **Best for Retina display.** Windows resolution matches that of the Retina display and the DPI setting increases. Windows interface elements and text are clear, sharp, and at full size. This option is supported by Windows 7 and later.

- **Scaled.** Windows resolution and DPI setting don’t change. Instead, Windows is scaled to full size. As a result, Windows interface elements and text are not sharp. This option is useful for Windows applications that don’t support high-DPI settings and appear small onscreen.

- **Best for external displays.** Use this option if you’re working with Windows on multiple displays one of which is non-Retina. The option is supported by Windows 8 and Windows 10.

For Windows XP:

If you’re working with Windows XP on a Mac with a Retina display, Windows becomes scaled but its resolution doesn’t change. As a result, Windows interface elements and text are not sharp.

However, you can enable full (2880x1800) Retina resolution for Windows by selecting **Enable Retina resolution.** At such a high resolution, Windows interface elements and text become sharp but small.

**Enabling 3D Acceleration**

If you want to use Windows Aero in your Windows virtual machines or use games and applications that require video cards that support DirectX or OpenGL, select **On** or the version of DirectX you need from the **3D acceleration** menu.

**Enabling Vertical Synchronization**

Sometimes in games and 3D applications, a newly rendered frame may overlap a previously rendered one and then screen tearing happens. This occurs when the video card or the software using it begins updating the actively-displayed memory in a manner that is out of sync with the monitor’s refresh rate. To prevent screen tearing, select the **Vertical synchronization** option.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Floppy Disk**

To view and configure the virtual machine floppy disk drive settings, use the **Floppy Disk** settings.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar and choose **Configure.** Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure.**
2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.

In the **Source** field, specify the source device or image file that will emulate the virtual machine floppy disk drive:

- If you want to use a real floppy disk drive, click the **Source** field and select the real device name from the list.
- If you want to use a floppy disk image, click the **Source** field, click **Choose an image file**, and specify the path to the desired floppy disk image file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**CD/DVD-ROM**

To configure the virtual machine CD/DVD drive settings, use the **CD/DVD** settings. Virtual CD/DVD drives can be connected either to physical CD/DVD drives or to CD/DVD images.

**Note:** You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog and has its own number.

To edit the device settings, do the following:
1. Click the Parallels icon in the menu bar and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

   **Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.

   ![Parallels Desktop Hardware Configuration](image)

   To emulate the virtual CD/DVD drive, you can connect one of the real CD/DVD drives on your physical computer or a CD/DVD image file to the virtual machine.

   **Note:** Parallels virtual machines support ISO and DMG image files and may support CUE and CCD image files.

   In the **Source** field, the source device or image file that emulates the virtual machine CD/DVD drive is specified. You can change the source device:

   - To use a real CD/DVD drive as the virtual machine CD/DVD drive, click the **Source** field and select the real device name from the list.
   - To use an image file as the virtual machine CD/DVD drive, click the **Source** field and choose the image file from the list, or click **Choose an image file** and specify the path to the desired image file on your Mac.

   In the **Location** field, you can specify the type of interface for connecting the device:

   - **IDE.** Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD drives).
   - **SATA.** Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD drives).
If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Hard Disk**

To view and configure the virtual hard disk settings, use the **Hard Disk** pane of Virtual Machine Configuration. Parallels Desktop allows virtual machines to use hard disk images in the .hdd format and Windows Boot Camp partitions.

**Note:** You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI devices to a virtual machine. Each device is listed separately in the **Virtual Machine Configuration** dialog and has its own number.

To edit the device settings, do the following:

1. Shut down the virtual machine. (p. 36)
2. Open the **Actions** menu and choose **Configure**.
3. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.
**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to *Adding and Removing Devices*.

In the **Source** field, the virtual hard disk file (`.hdd`) that emulates the virtual machine hard disk is specified. You can change the hard disk source:

- To use the Boot Camp partition as the virtual machine hard disk, click the **Source** field and select the Boot Camp partition name from the list.
- To use a virtual hard disk file as the virtual machine hard disk, click the **Source** field and choose the virtual hard disk file from the list, or click **Choose an image file** and specify the path to the desired image file (`.hdd`) on your Mac.

In the **Location** field, you can specify the type of interface for connecting the device:

- **IDE.** Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD drives).
• **SATA**. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD drives).

• **SCSI**. Using this interface type, you can connect up to 15 virtual devices (hard disks or CD/DVD drives).

**Note 1:** The Mac OS X guest OS does not support the SCSI controller. In the latest Linux distributions, the SCSI driver may be not installed. In this case, you should install this driver in your Linux guest OS to be able to use the SCSI controller.

**Note 2:** The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller itself.

### Compressing the Disk

If you use an expanding (p. 172) virtual hard disk in your virtual machine, its image file size on the physical hard disk increases as you add new data to the virtual hard disk. When you delete some data from this virtual hard disk, free unused space appears on the disk, but the amount of space your virtual machine occupies on the hard disk of your Mac does not reduce. To free the unused space back to Mac, click the **Compress** button. The virtual hard disk will be compressed and the hard disk image file size will be decreased. As a result, there will be more free space on your Mac hard disk.

**Note:** Compressing can be performed for virtual machines without snapshots and with the Rollback Mode option (p. 93) disabled.

### Editing the Disk

If you find that the capacity of your virtual machine hard disk no longer fits your needs, you can change its size.

**Important:**

1. Resizing a hard disk can be potentially dangerous to your data. Before you start, it is highly recommended that you properly shut down the virtual machine (using the shutdown procedure of its guest operating system) and back up the data. To learn how to make a backup, please see Back Up a Virtual Machine (p. 117).

2. Resizing may take some time. It is not recommended that you interrupt the process.

3. If your MacBook is running on battery, connect it to a power source or make sure the battery is fully charged. A power outage while writing changes to the disk may cause data loss.

   To change the disk size:
1. Click **Edit**.

   ![Disk Resize Interface]

   **Note:** If your virtual machine is running, has snapshots, or uses a Boot Camp partition as a hard disk, its virtual hard disks cannot be resized.

2. Drag the slider or enter a new size in the **Size** field.

3. Select **Resize file system** if you want to change the file system size:
   - If you select **Resize file system** when increasing the disk size, the additional disk space will be added to the last volume. If you deselect **Resize file system**, the added space will appear as unallocated space and will be invisible to the guest operating system. To allocate this space, you will have to either create a new partition or expand an existing partition. For instructions on allocating the added space, please refer to the guest OS documentation.
   - If you select **Resize file system** when decreasing the disk size, the disk will be decreased by removing the unallocated space and decreasing the size of the disk partitions. If you deselect **Resize file system** when decreasing the disk size, you will be able to remove the unallocated space of the disk only and the disk partitions will remain untouched.

   If the format of the virtual hard disk is **expanding**, you can convert it to **plain** by deselecting **Expanding disk**.

   If you want the virtual hard disk to be split, select **Split the disk image into 2 GB files option**.

   **Note:** For more information about virtual hard disk types, please refer to **Support for Virtual and Real Disks** (p. 172).
Automatically Conserve Disk Space

In most cases, the space that Windows takes up on your hard disk expands as you add files and other data, but isn’t reduced when you delete data. To set Parallels Desktop to automatically reduce disk space:

- Select Real time virtual disk optimization.

You can also quickly remove unnecessary files that have built up in the system (p. 129) to free up disk space.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

Network

Using the Network settings, you can change the network type used in your virtual machine.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar and choose Configure. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.

2. In the Virtual Machine Configuration dialog, click Hardware and select this device name in the sidebar.
**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to [Adding and Removing Devices](#).

You can choose one of the following network types for the virtual machine network adapter:

- **Shared Network.** Select this option to enable the Network Address Translation (NAT) feature for the virtual machine. In this case, your virtual machine will share whatever network connection is currently used by the host computer.
  
  See [Shared Network](#) to learn how to configure this network type.

- **Bridged Network.** Select this option to allow the virtual machine to access the local network and Internet through one of the network adapters installed on the host computer. In this case, the virtual machine is treated as a stand-alone computer on the network and should be configured in the same way as a real one. You can choose the physical adapter where the virtual machine adapter will be bridged in the list below the **Bridged Network** option.
  
  See [Bridged Ethernet Network](#) to learn how to configure this network type.
• **Host-Only Network.** Select this option to allow the virtual machine to connect to the host computer and the virtual machines residing on it and to make it invisible outside the host computer.

  See [Host-Only Network](p. 98) to learn how to configure this network type.

**Network Conditioner**

| Note: This feature is available in Parallels Desktop for Mac Pro Edition only. |

If you're a software developer, you can simulate various Internet connectivity speeds to test your applications. To do this, select *Network Conditioner* and choose a pre-configured profile that is specific to the network conditions you want to test. Or click *Configure* and specify the *Inbound* and *Outbound* settings according to your needs.

**MAC Address**

In the **MAC address** field, you can change the MAC address currently assigned to the virtual machine. MAC addresses are automatically generated during the virtual machine creation. However, you can modify the default MAC address by typing another value in the *MAC address* field or clicking the *Generate* button. When entering a new MAC address, make sure that it is unique within your network.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Printer**

Using the **Printer** settings, you can configure the virtual machine printer port settings. A virtual machine can have up to three printer ports.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar and choose *Configure*. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose *Actions > Configure*.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.
Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.

In the Port field, choose the port type. If available, you're recommended to use the USB port type. Connecting a printer to a virtual machine via USB ensures faster data transfer rate than connecting it via LPT.

Notes:

1. You can connect up to 6 USB and up to 3 LPT printers to a single virtual machine.

2. You can connect a USB printer only if your virtual machine has a USB controller (p. 196). If not, you can easily add it (p. 170).

In the Source field, the source device that emulates this printer port is specified. A printer port can be emulated by one of the following devices:

- **Printers.** You can use any of the printers connected to your Mac in your virtual machine. Click the Source field and select the appropriate printer from the list.
  
  For the detailed information on how to set up a printer in your virtual machine, please refer to Print from Windows (p. 82).

- **Real printer port.** If your Mac has a physical printer port, you can connect it to your virtual machine. Click the Source field and select the physical port name from the list.

- **Output File.** You can emulate the virtual machine printer port by using an output file. Click the Source field and choose an output file from the list, or click Choose an output file and specify the path to the desired output file on your Mac.
If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**Serial Port**

In the **Serial Port** pane, you can configure the virtual machine serial port settings.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.
2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

   **Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.

Using serial ports, you can establish a connection between:

- The virtual machine and the host computer devices (using a real port); or
- Between two virtual machines located on the same host computer (using a socket).

If you want to connect your virtual machine to the host computer device, you should create a serial port emulated by a real port. The **Source** list comprises the devices on the host computer that are available for connection. The connected device, being used in any virtual machine, cannot be used by the host computer. To be able to use it in the host computer, you should first disconnect it from the virtual machine. To do that, use the **Devices** menu in the Mac menu bar.

If you want to connect two virtual machines with each other, you need to create a serial port emulated by a socket in each virtual machine. The names of the serial ports should be identical. The connection between the virtual machines via serial ports is bidirectional. It means that the working modes of the sockets set during the port creation can be changed later in the **Serial Port** pane.

If you need to log the performance activity of your virtual machine or to record the data from it and use this information later on, you can connect your virtual machine serial port to an output file on the physical computer. You will be able to view and analyze the activity history of the virtual machine any time you need by exploring this file.

You can add a new serial port to your virtual machine using Add Hardware Assistant. For the instruction on how to add serial ports, refer to **Adding and Removing Devices**.
Advanced Topics

**Note**: You can connect up to four serial ports to a virtual machine.

In the **Source** field, the source device that emulates this serial port is specified. Serial ports can be emulated by the following devices:

- **Physical Serial Port**. To connect the virtual machine serial port to one of the existing serial ports on the host computer, choose the appropriate port on the host computer in the **Source** list.

- **Socket**. To connect two virtual machines through the sockets, click the **Source** list and choose the appropriate socket. If there are no sockets available, click **New socket** and specify its name in the **Enter a socket name** field.

You should also configure the role the virtual machine will play in the connection by selecting the necessary role in the **Mode** list. Selecting **Server** enables you to use this virtual machine to direct the other one. Selecting **Client** enables you to direct this virtual machine from the other one.

**Note**: If you change the socket mode of the first virtual machine, make sure the socket mode of the second virtual machine is also modified.

- **Output File**. To connect the virtual machine serial port to an output file, click the **Source** list and choose the appropriate output file. You can also click **Choose an output file** to locate the necessary file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Sound

The **Sound** pane of Virtual Machine Configuration allows you to configure the virtual machine sound device parameters.

To edit the device settings, do the following:

1. Click the Parallels icon in the menu bar and choose **Configure**. Or if the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions > Configure**.
2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.

**Note:** If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to **Adding and Removing Devices**.

![Virtual Machine Configuration dialog](image)

Use the **Output** list to choose the necessary device. You can choose one of the following devices:

- **Default.** Select this option if you want to use the output device set as default in Mac OS.
- **Built-in Output.** Select this option if you want to use one of the output devices from your Mac.
- **Mute.** Select this option if you want to mute the output device.

**Note:** If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac, you can use it in Windows (p. 204).

Use the **Input** list to choose the necessary device. You can choose one of the following devices:

- **Default.** Select this option if you want to use the input device set as default in Mac OS.
- **Built-in Microphone.** Select this option if you want to use the built-in microphone.
• **Mute.** Select this option if you want to mute the input device.

**Sync volume level**

For Windows XP and later with Parallels Tools (p. 140) installed, you can set Windows and OS X volume levels to always be the same. With the **Sync volume with Mac** option selected, if you manually change the volume level in Windows, it is changed accordingly in OS X and vice versa.

If your virtual machine doesn’t have Parallels Tools installed, the guest operating system syncs the volume level from OS X. If you want to set another volume level in the virtual machine, disable **Use Mac volume**.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.

**USB & Bluetooth**

A virtual machine can emulate only one USB controller, which provides you with the possibility to connect up to 12 USB 3.0, 15 USB 2.0, and 32 USB 1.1 devices to the virtual machine.

To edit the device settings, do the following:

1. Open the **Actions** menu or click the Parallels icon in the Mac menu bar and choose **Configure**.

2. In the **Virtual Machine Configuration** dialog, click **Hardware** and select this device name in the sidebar.
Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on how to add a device, refer to Adding and Removing Devices.

In the **USB & Bluetooth** pane, you can:

- Disable camera sharing.
- Enable Bluetooth devices sharing.
- Enable USB 3.0 support.

Once USB 3.0 support is enabled, you can immediately start using USB 3.0 devices with Windows 8 and Windows Server 2012. To be able to use USB 3.0 devices with Windows 7/Vista/XP, you must also install the USB 3.0 driver in Windows. The driver can be found here.

Note: You can also use USB 3.0 devices in the guest versions of OS X 10.7.4 with the latest updates installed, OS X 10.8, and Linux guest operating systems that support USB 3.0.
If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock icon at the bottom of the window. The next time someone wants to change the settings in any pane of Virtual Machine Configuration, an administrator’s password will be required.
Chapter 6

Tips and Troubleshooting

If you’re having trouble using Parallels Desktop, check this section for possible solutions.

In This Chapter

Install Parallels Tools for Seamless Operation Between Windows and Mac OS X...... 199
Find Settings ................................................................. 200
Restore Virtual Machine Default Settings .......................................................... 200
I Can’t Activate Parallels Desktop ......................................................................... 201
Memory Usage Problems ....................................................................................... 201
Windows Seems Slow ......................................................................................... 202
Pressing Ctrl+Alt+Del ............................................................................................ 202
My Password Isn’t Working .................................................................................. 203
My Virtual Machine Doesn’t Boot ......................................................................... 203
I’m Having Problems Connecting to the Internet.................................................... 203
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine.................................... 204
I’m Having Problems with Antivirus Software ...................................................... 205
The F8 Key Isn’t Working Correctly ....................................................................... 206
A Password is Required to Open the Virtual Machine Configuration.................... 206
Windows or Windows Programs Ask for Reactivation .......................................... 206
Manage Virtual Machines via Command Line Interface ....................................... 207
Change Password in Windows via Command Line Interface ................................ 208
Configuring a Network in Linux .......................................................................... 208
Installing the GCC Package and Kernel Sources in Linux................................. 209
Checking the Build Number ................................................................................. 209
Send Technical Data to Parallels .......................................................................... 210
Request Support .................................................................................................... 210

Install Parallels Tools for Seamless Operation Between Windows and Mac OS X

Many issues with using Parallels Desktop can be solved by installing Parallels Tools.

Parallels Tools help you work with Windows in the most comfortable and efficient way. With Parallels Tools, you can:

- Move the mouse seamlessly between Windows and Mac OS X
- Synchronize the Windows time and date settings with those of Mac OS X
Tips and Troubleshooting

• Share your Mac OS X disks and folders with Windows
• Copy text and drag and drop objects from Mac OS X to Windows and vice versa

Important: Once you install Parallels Tools and restart Windows, you don't have to do anything else. Parallels Tools automatically just work, without any action or configuration on your part.

To install Parallels Tools:

1 Start Windows (p. 31).
2 Choose Actions > Install Parallels Tools and follow the onscreen instructions.

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p. 142).

Find Settings

If you want to change a setting in Parallels Desktop but you aren’t sure where to find the setting, you can search for it by doing the following:

1 Do one of the following:
   • Click the Parallels icon in the menu bar and choose Configure.
   • If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Configure.
2 Type a word or phrase in the search field. Any settings related to your search are highlighted.
   For example, if you want to find out whether you can change settings related to the Dock, type "dock" in the search field and options that make Dock icons bounce to alert and allow you to access Windows apps from the Dock are highlighted.

Restore Virtual Machine Default Settings

Read When working with a virtual machine, you can change different virtual machine settings, such as an amount of memory, video memory, number of CPUs, sharing settings, etc. To restore default settings:

1 Do one of the following (the virtual machine must be shut down):
   • In Control Center, right-click the virtual machine you want to configure and click Configure.
   • If the virtual machine window is open, click Actions > Configure.
2 In the virtual machine configuration dialog, find the pane with the settings that you want to restore and click Restore Defaults.
I Can't Activate Parallels Desktop

You must activate Parallels Desktop to be able to use all of its features.

If you are having trouble activating Parallels Desktop, try the following:

- Make sure the activation key you’re using is for the version of the software being installed.
- Make sure you’re entering the key correctly.

  If you purchased and downloaded Parallels Desktop from the Internet, you received an activation key via email. For best results, copy and paste the key from the email.

  If you have a boxed copy of Parallels Desktop, the key is printed on the DVD sleeve. Make sure you enter the entire key (30 characters). Dashes are added automatically.

- If still can't activate Parallels Desktop, check this Knowledge Base Article for an extended list of solutions.

Memory Usage Problems

The amount of Mac’s physical memory required for each virtual machine operation can be represented as follows:

Virtual Machine Memory = Guest OS Memory + Video Memory + Virtual Machine Monitor Memory

- **Guest OS Memory** is the amount of RAM available to your guest operating system. You can configure the guest OS memory amount in the **CPU & Memory** pane of the virtual machine configuration dialog.

- **Video Memory** is the amount of physical memory available to the virtual machine’s video card. You can adjust the video memory amount in the **Graphics** pane of the virtual machine configuration dialog.

- **Virtual Machine Monitor** is the module responsible for the guest operating system virtualization. It consumes memory to perform operations of guest virtual devices and performs virtual paging emulation. The amount of memory required for the Virtual Machine Monitor operation depends on the guest OS and varies from 50 MB to 200 MB.

Memory Overcommitment

If you have several virtual machines running simultaneously and you are trying to start one more virtual machine, you may come across the memory overcommit. If so, Parallels Desktop informs you with the corresponding message. If you start one more virtual machine, this may significantly slow down all your virtual machines. To solve this problem, you can:

- Stop one or several of your running virtual machines; or
- Edit your virtual machines' configurations so they consume less memory.
Windows Seems Slow

If Windows performance seems slow, try the following:

- **Quit applications and programs you aren't using:** If you run a number of memory-consuming applications and programs simultaneously, Windows performance may become slow. Quit any applications that you aren’t using. You can also use Activity Monitor (located in the Mac OS X Finder in Applications > Utilities) to see how much of your Mac’s memory each application is using. That way, you’ll have a better idea of which applications cause performance to degrade the most.

- **Change how much memory is allocated to Windows:** Parallels Desktop is set to allocate a certain amount of your Mac’s available RAM memory to Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause Windows programs to slow down because they’re running on top of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS X applications may run well but Windows programs might slow down.

  To optimize the performance of both Windows and Mac OS X, set the memory allocated to Windows (p. 100) to be somewhere within the recommended range, indicated by the graphic under the memory slider in the CPU & Memory configuration panel.

- **Antivirus software may slow down your virtual machine:** Windows may become slower after you install antivirus software. To be protected, you have to sacrifice performance.  

  **Note:** Do not install more than one Windows antivirus program.

- **Run fewer virtual machines at once:** If you are running multiple operating systems at once using Parallels Desktop, stop one or more of them to improve performance of the others.

- **Run Windows locally:** If you start Windows stored on an external storage device connected to your Mac (for example, an external USB disk drive), its performance will be lower than if it were stored on your Mac.

- **Tune Windows for speed:** To speed up Windows, select **Tune Windows for speed** in the Optimization pane (p. 100).

- **Disable log messages:** If you select **Use detailed log messages** in the Advanced pane of Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It can be helpful for the Parallels support team, but uses more hard disk space and may slightly lower the system performance.

Pressing Ctrl+Alt+Del

As a Windows user, you might know that you can press the Ctrl+Alt+Del key combination to make available troubleshooting options, such as starting the Task Manager or changing a password.

To mimic pressing Ctrl+Alt+Del in Parallels Desktop:
• Press fn+Ctrl+Option+Del.

My Password Isn't Working

If Parallels Desktop doesn’t accept your password, try the following:

• Be sure that Caps Lock is not on. If Caps Lock is on, an indicator appears in the password field. To turn Caps Lock off, press the Caps Lock key.

• Be sure that the keyboard is set to the correct language. If the keyboard is set to a language that doesn’t belong to the group of Romance languages, an icon in the password field indicates the keyboard language setting.

My Virtual Machine Doesn't Boot

If your virtual machine doesn’t boot correctly, most probably it’s because there isn’t any operating system installed. To install an operating system, do the following:

1 Prepare the OS installation media:
   • If you have an OS installation disk, insert it into the DVD drive of your Mac.
   • If you have a USB drive with the OS installation files, connect it to your Mac.
   • If you have a disk image, copy it to your Mac.

2 Restart the virtual machine by doing one of the following:
   • Click Actions > Restart.
   • Click the Parallels icon in the menu bar and choose Actions > Restart.

3 And follow the onscreen instructions.

I'm Having Problems Connecting to the Internet

When you install Windows, it is automatically configured to share your Mac’s Internet connection. For details on configuring Windows’ network and Internet connection, see the section on connecting to the Internet or a network (p. 95).
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine

If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac (via USB or FireWire), you can use it in your virtual machine. Follow these steps:

**Step 1.** Configure the sound card in Mac OS X.

**Step 2.** Select the sound card as the sound output device in the virtual machine configuration.

**Step 3.** Configure the sound card in the guest operating system.

**Configure the sound card in Mac OS X**

To configure a sound card in Mac OS X:

1. Start the Audio MIDI Setup application (you can find it in /Applications/Utilities).
2. Select your 5.1 or 7.1 surround-capable sound card and choose the necessary sample rate and bit depth from the **Format** pop-up menus.

   **Note:** Make sure these settings match the appropriate settings for the sound card.

3. Click **Configure Speakers**, select **Multichannel** and choose the necessary type of output from the pop-up menu.
4. Set this sound card as the default output device in Mac OS X: select it in **System Preferences** > **Sound** > **Output**.

**Select the sound card as the sound output device in the virtual machine configuration**

After you have configured the sound card in Mac OS X, select it as the sound output device in the virtual machine configuration:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose **Configure**.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose **Actions** > **Configure**.
2. Click **Hardware** and select **Sound**.
3. Make sure the **Connected** option is selected.
4. Choose **Default** from the **Output** menu.
Configure the sound card in the guest operating system

Configure the sound card in the guest operating system.

In Windows 7/Vista:

1. Click `Start > Control Panel > Hardware and Sound > Sound`.
2. On the `Playback` tab, select `Parallels Audio Controller` and click `Configure`.
3. Select `5.1 Surround` or `7.1 Surround` (depends on your sound card), click `Next` several times, and then click `Finish`.
4. On the `Playback` tab, select `Parallels Audio Controller` again and click `Properties`.
5. Click the `Advanced` tab and choose the sample rate and bit depth.

**Note:** The specified settings shouldn’t be higher than the same settings specified in the Audio MIDI Setup application in Mac OS X (described above).

6. When ready, click `OK` twice.

In Windows XP:

1. Click `Start > Control Panel` and double-click `Sound and Audio Devices`.
2. On the `Volume` tab, click `Advanced` in the `Speaker settings` section.
3. On the `Speakers` tab, select the necessary speaker setup.

In Linux:

You can try to follow these general guidelines to use the 5.1 or 7.1 surround-capable sound card in Linux:

1. Click `System > Preferences > Sound`.
2. On the `Hardware` tab, choose the necessary speaker setup from the `Profile` menu.

**I'm Having Problems with Antivirus Software**

Because of the close integration between Parallels Desktop and Mac OS X, some Parallels Desktop processes may be detected as malicious by antivirus software installed on your Mac.
Tips and Troubleshooting

To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system scan using the antivirus software, and then if no viruses are detected, add the Parallels Desktop processes to the list of trusted processes. For information on how to do this, refer to your antivirus software Help.

**Important:** The names of Parallels Desktop processes usually start with `prl` or `parallels`.

The F8 Key Isn't Working Correctly

In Mac OS X, the F8 key and Ctrl+arrow key combination are reserved for triggering Spaces (a feature that lets you organize your windows on multiple desktops). Because of this, the F8 key and Ctrl+arrow key may not function correctly with Windows programs.

If you are experiencing this problem, change the Spaces hotkeys settings. See Mac Help for more information. From the Finder, choose Help > Mac Help or Help > Help Center and search for “Spaces.”

A Password is Required to Open the Virtual Machine Configuration

In Parallels Desktop 12 activated with the volume license product key, virtual machine configuration can be password protected from being viewed and edited.

So if you’re requested to enter the password to open the virtual machine configuration and you don’t know it, contact the person who gave you this virtual machine (in most cases, it’s your system administrator).

Windows or Windows Programs Ask for Reactivation

When you first install Windows on a PC, Boot Camp partition, or virtual machine, you must activate Windows to use it. You can activate Windows over the Internet or by phone.

Once activated, every time you start Windows it checks whether it is running on the same hardware on which it was originally installed. When you import Windows to Parallels Desktop from a PC or create a Boot Camp virtual machine, Windows detects that the virtual hardware is different and may require reactivation, depending on the version of Windows you’re using and Microsoft’s licensing policy.
Windows or Microsoft Office asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine and Windows or Microsoft Office asks for reactivation, try to reactivate it over the Internet or by phone with Microsoft Support.

**Note:** For the detailed information on how you can reactivate Windows or Microsoft Office, please refer to the Windows/Microsoft Office help resources.

If Windows or Microsoft Office has reached the activation limit, you won’t be able to use it in a virtual machine. In this case, you can do one of the following:

- If Windows cannot be reactivated in a Boot Camp virtual machine, work with Windows by booting your Mac directly into Windows.
- Buy a new activation key to activate Windows in a virtual machine.

Third-party application asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine, some third-party applications that are tied to the hardware on which they were originally installed may ask for reactivation. In this case, you can do one of the following:

- If you choose to work with an application in a virtual machine, contact the application vendor for help. The vendor may give you another activation key or offer to deactivate the application on the PC or Boot Camp and activate it in the virtual machine.

**Important:** If the vendor gives you or you decide to purchase a new activation key, please note that reactivating an application with a new key in a virtual machine may break its activation on the Boot Camp. It means that if you later decide to work with the application by booting your Mac directly into Windows, it will require reactivation.

- If an application asks for reactivation in a Boot Camp virtual machine, work with the application by booting your Mac directly into Windows.

Manage Virtual Machines via Command Line Interface

In Parallels Desktop for Mac Pro Edition, you can create and manage your virtual machines via the command line interface. To learn more about the commands and options, please refer to the *Parallels Desktop Pro Edition Command-Line Reference* guide available online.
Change Password in Windows via Command Line Interface

To change your Windows account password via CLI, do the following:

**Note:** You can do this in Parallels Desktop for Mac Pro Edition only.

1. Start Windows (p. 31).
2. Launch Terminal in OS X (Applications > Utilities > Terminal) and find out Windows UUID (Universally Unique Identifier) by executing the following command:

   ```bash
   prlctl list --all
   ```

   The output may be as follows:

<table>
<thead>
<tr>
<th>UUID</th>
<th>STATUS</th>
<th>IP_ADDR</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>{6f05fe58-2ef6-4049-847a-c393f1077658}</td>
<td>running</td>
<td>-</td>
<td>Windows 7</td>
</tr>
</tbody>
</table>

   6f05fe58-2ef6-4049-847a-c393f1077658 is the Windows UUID.

3. Change your Windows account password by executing the following command:

   ```bash
   prlctl set <Windows UUID> --userpasswd <account_name>:<new_password>
   ```

   This command may look as follows:

   ```bash
   prlctl set 6f05fe58-2ef6-4049-847a-c393f1077658 --userpasswd Appleseed:qwerty
   ```

   If you see the following output, the password has been changed successfully:

   ```bash
   authentication tokens updated successfully.
   ```

Configuring a Network in Linux

When setting up network in Linux, you may need to configure the DHCP client to send the virtual machine’s ID in DHCP requests. For information on how to configure your DHCP client, refer to the DHCP client documentation.

For example, in Red Hat Linux guest OSs, you need to edit the DHCP client configuration file.

1. Open the `dhclient.conf` file and make sure that the following lines are present.

   ```
   interface "eth0" {
      send dhcp-client-identifier 1:<MAC address>;
   }
   ```

2. If there are no such lines, add them manually to the file and save it.

   When the `dhclient.conf` file contains these lines, DHCP client sends the virtual machine’s ID to the DHCP server. The DHCP server sends an IP address in response.

**Tip**

To locate the `dhclient.conf` file, in a terminal, enter:
strings /sbin/dhclient | grep etc | grep dhclient.conf

or:

rpm -ql dhclient

Installing the GCC Package and Kernel Sources in Linux

When installing or upgrading Parallels Tools in a Linux virtual machine, you may need to install the gcc package and kernel sources in your Linux guest OS. Kernel sources can be either downloaded from the Internet or installed from Linux distribution disks.

To install the gcc package and kernel sources in the RHEL/Fedora/CentOS Linux distribution, enter the following command in a terminal:

```bash
yum install gcc kernel-devel make
```

To install the gcc package and kernel sources in the Debian/Ubuntu Linux distribution, enter the following command in a terminal:

```bash
apt-get install gcc make linux-headers-$(uname -r)
```

For information on how to install the gcc package and kernel sources in other Linux distributions, refer to the documentation for these distributions.

If you still experience any problems, try to find a solution in Parallels Knowledge Base or refer to the Parallels support team http://www.parallels.com/en/support/desktop/.

Checking the Build Number

To check the version and build number of the Parallels Desktop software you are using, do one of the following:

- Click the Parallels icon in the menu bar and choose About Parallels Desktop.
- If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > About Parallels Desktop.

A window appears showing the build number.

**Note:** The window that appears also provides you with other useful information about your copy of Parallels Desktop, including the licensing information and a link to the Parallels support web page.
**Send Technical Data to Parallels**

To help improve the quality of Parallels Desktop, you can send technical data to Parallels.

If Windows is forced to shut down because of an error, Parallels Desktop automatically opens a Send Technical Data form. If you notice unusual behavior in Parallels Desktop, you can also send technical data manually.

To send technical data:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Help > Send Technical Data.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Help > Send Technical Data.
2. Describe what you were doing when the problem occurred, and fill out the form.
   - **Note:** You can review the problem report components that will be sent to the Parallels support team and deselect some of them in the Parallels Problem Report Details window, if desired. To open this window, click See Details.
   - If Parallels Desktop auto-generates a problem report, the report window contains the Send a solution to me when available option. After the report is sent, Parallels engineers start investigating the problem. When they find any workaround or get any news about the reported issue, you will be notified by email.
3. Click Send Report.

Parallels team uses error reports to improve the product quality but doesn't respond to them.

**Request Support**

To contact the Parallels support team for assistance:

1. Do one of the following:
   - Click the Parallels icon in the menu bar and choose Help > Request Support.
   - If the Parallels Desktop menu bar is visible at the top of the screen, choose Help > Request Support.
2. Follow the onscreen instructions.
More Resources

For more information and help using Parallels Desktop, see the following resources:

• **Parallels support website:** The Parallels support website includes product help files and a FAQ section.

• **Parallels Knowledge Base:** This online resource has valuable articles about using Parallels Desktop and other Parallels products.

• **Online documentation:** You can find PDF user guides for Parallels Desktop and Parallels Transporter online by choosing Help > Online Documentation.

• **Parallels Command Line Reference Guide:** This document, available on the Parallels Online documentation page, has information on using the prlctl command line utility to manage Parallels Desktop and its virtual machines from a terminal.

• **Parallels API references and the SDK programmer's guide:** These guides for IT-professionals can be found on the Parallels Online documentation page.

Feedback

• Parallels welcomes your feedback on how to make our documentation more helpful. You can submit feedback using the Documentation Feedback form on our website (http://www.parallels.com/products/desktop/support/).

**In This Chapter**

Visit the Parallels Desktop Twitter and Facebook Pages............................................ 211

Visit the Parallels Desktop Twitter and Facebook Pages

To keep up with the latest news and updates, you can visit the Parallels Desktop Twitter and Facebook pages. Choose Parallels Desktop > About Parallels Desktop and click Our Twitter or Facebook page.
Glossary

This glossary defines terms and spells out abbreviations used in Parallels Desktop documentation. References to terms defined elsewhere in the glossary appear in *italics*.

**Administrator.** A user with administrative privileges.

**Activation key.** A unique set of symbols that activates the Parallels Desktop application on your Mac and lets you use the Parallels Desktop functionality to its full extent.

**Active operating system.** The operating system where Parallels Transporter Agent is launched.

**Active volume.** The volume of the physical source computer that is used as a *boot volume* for the active operating system.

**Bootable hard disk.** A disk used by the operating system to boot from, usually a disk that has an operating system installed.

**Boot Volume.** A hard disk partition from which the operating system boots.

**Boot Camp partition.** A partition on the hard disk of your Mac that can be used for installing a Windows operating system on it (for Mac host computers only).

**Bridged networking.** Virtual machine network connection mode that enables the virtual machine to appear as any other computer on the network, with its own IP address and network name.

**Coherence.** One of the view modes you can use to work with Windows. When Windows is in Coherence, its desktop is hidden and Windows applications appear on the Mac desktop next to your Mac applications, as if they were all part of a single operating system.

**Configuration file.** A file specifies the virtual machine’s hardware configuration, the devices it uses, and other settings. It is created automatically when you create a new virtual machine. See also *PVS file*.

**CPU.** Stands for central processing unit. It is an internal part of the computer. See also *Processor*.

**Disks in the old format.** Disks of virtual machines that were created in Parallels Desktop 2.5 and earlier or Parallels Workstation 2.2.

**Disks in the new format.** Disks of virtual machines that were created or used in Parallels hardware virtualization products starting from version 3.0.
Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on your host computer and is small initially. Its size grows as you add applications and data to the virtual machine.

FireWire connection. A wired connection that enables a high-speed data transmission between computers.

Guest operating system (guest OS). An operating system installed inside your virtual machine.

Host computer: The computer that is used to run virtual machines. In case of Parallels Desktop for Mac, it is your Mac. In case of Parallels Desktop for Windows or Parallels Desktop for Linux, it is the Windows- or Linux-based physical computer where Parallels Desktop is installed. In the Parallels Transporter documentation, this term may define the computer that hosts the result of migration.

Hot key. A user-defined key or combination of keys that provides quick access to applications and commands. See also Shortcut.

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd extension. See also virtual hard disk file.

Host-only networking. Virtual machine network connection mode that creates a private network between the host computer and its virtual machines, which makes the virtual machines available from the host computer only.

ISO image. A special file that contains the entire contents of a CD or DVD disc commonly used to install an operating system.

Image file. A single file containing the complete contents and structure of a data storage medium or device, such as a hard disk drive, CD, or DVD.

IP address. A unique address that is assigned to a physical computer or a virtual machine that participates in computer networking.

Linux computer. A physical computer that has a Linux operating system installed.

Merged disk. A split disk whose parts were merged into a single disk.

Migration. The process of transferring data from a physical computer or a third-party virtual machine into a Parallels virtual machine or virtual disk.

Modality. One of the view modes you can use to work with Windows. In Modality mode, the Windows desktop appears in a window and scales in size as you resize the window. Also, you can set this window to always stay on top of other windows, and you can adjust its transparency level so you can see through it when you’re working with other applications.

OS. Operating system.

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual machines on your Mac.
**Parallels Tools.** A set of Parallels utilities that ensures a high level of integration between the *primary* and the *guest* operating systems.

**Parallels Transporter.** An application that uses data of a physical or virtual computer for creating a Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be used with Parallels Desktop.

**Parallels Transporter Agent.** An application that collects data on a physical computer and transfers it to Parallels Transporter installed on your Mac.

**Plain format.** A virtual hard disk format. A plain virtual hard disk image file resides on the *host computer* and has a fixed size that cannot be changed.

**Preboot Execution Environment (PXE).** An environment to boot computers using a network interface independently of available data storage devices (like hard disks) or installed operating systems.

**Primary operating system (primary OS).** Operating system that controls the I/O devices of the computer and that is loaded when the physical computer is turned on. It is the operating system of the physical computer where the Parallels Desktop application is installed.

**Processor.** The central processing unit, or *CPU*. It is an internal part of the computer.

**PVS file.** A virtual machine *configuration file* that contains information about the virtual machine resources, devices and other settings.

**Shared networking.** Virtual machine network connection mode that allows the *virtual machine* to use the *host computer* network connections. In this mode, the virtual machine is invisible to other computers on the network the host computer belongs to.

**Shortcut.** A user-defined key or combination of keys that provides quick access to applications and commands. See also *Hot key*.

**Snapshot.** A copy of the virtual machine state at a particular point of time. The files related to snapshots are stored in a special subfolder in the virtual machine’s folder.

**Source computer.** The computer from which you are going to migrate data using *Parallels Transporter*.

**Split disk.** A split disk is cut into 2 GB pieces, but is stored as a single *HDD file*. Split disks allow you to transfer the data stored on a split disk piece by piece using a USB drive or other media that have limited space and cannot store a large virtual hard disk image file.

**Terminal.** In Mac OS and GNU/Linux operating systems, a utility that enables you to access the command line.

**Third-party virtual machine.** A virtual machine created in a third-party virtualization product, that can be converted to a Parallels virtual machine with the help of Parallels Transporter.
**Virtual hard disk (virtual disk).** A file that emulates the virtual machine’s hard disk.

**Virtual Machine.** The computer emulated using Parallels Desktop. A virtual machine has its own virtual hardware and requires an operating system to control its hardware. The installed operating system and its applications are isolated inside the virtual machine and share physical hardware resources of the *host computer*.

**Virtual Machine Configuration.** Like any physical computer, a *virtual machine* has its own configuration which is set during the creation and can be later modified. The virtual machine configuration settings are stored in a *PVS file*.

**Virtual machine files.** Files stored in a *virtual machine* folder. A virtual machine has at least two files: *configuration file* and *virtual hard disk file*.

**Virtual hard disk file.** During the creation, the *virtual machine* acquires a virtual hard disk file with the `.hdd` extension. This file performs the functions of a real hard disk. See also *HDD file*.

**Virtual machine template.** A virtual machine that can be cloned to multiple virtual machines that will have the same configuration and data that the virtual machine template had.

**VM.** See *Virtual Machine*.

**Windows computer.** A physical computer that has a Windows operating system installed.
Index

3
3D acceleration - 102, 103, 180

A
A Password is Required to Open the Virtual Machine Configuration - 206
About Parallels Desktop - 9
About Using Windows 8 with Parallels Desktop - 48
About Virtual Machines - 112, 118
Acronis Online Backup - 128
Activate and Register Parallels Desktop - 13
Activating Parallels Desktop - 13
Active corners - 44, 45
Active volume - 212
Adaptive hypervisor - 100
Adding and Removing Devices - 21, 113, 170, 192
Adding devices - 170
Adding virtual machine - 30
Address
   IP address - 21, 28, 86, 95, 96, 98, 106, 160, 162, 166, 189, 208
   MAC address - 95, 96, 98, 189
Adjust Devices Settings - 78, 79
Adjust Full Screen Settings - 42, 44, 45
Adjust Window Mode Settings - 44
Administrator - 212
Advanced Preferences - 154, 160
Advanced Topics - 11, 110
AirPort, using in virtual machine - 98
Allow Windows Updates While Your Mac is Sleeping - 108
Antivirus for Mac - 92
Antivirus for Windows - 92
Apple Remote - 67
Apply Mac OS X Parental Controls to Windows - 64
Apply Separate Network Settings to Windows - 96
Archive and Unarchive Virtual Machines - 130
Arrange Virtual Machines - 115
Automatic update check - 15

B
Back Up a Virtual Machine - 117, 187
Backing up virtual machines - 117
Battery life - 100
Bonjour Printer - 84
Boot Camp partition
   Boot Camp virtual machine - 29
   Importing Boot Camp - 29
Boot order - 177
Boot Order - 177
Bridged Ethernet networking - 96
Browse Virtual Hard Disks in Mac OS X - 118
Browsing virtual machines and disks - 118
Build number - 209

C
CD/DVD-ROM - 36, 51, 183
CD/DVD-ROM drive
   adding/removing - 170
   connecting/disconnecting - 123, 183
   setting up - 183
Change Password in Windows via Command Line Interface - 208
Change the Virtual Machine Icon - 115
Change the Virtual Machine Name - 116
Change Virtual Machine Configuration at Runtime - 123
Changing
   configuration at runtime - 123
   default folder for virtual machines - 114
Changing hard disk format - 185
Check Your Virtual Machine CPU and Memory Usage - 127
Checking the Build Number - 209
Chrome OS - 125
Cleaning up unused space - 185
Clone a Virtual Machine - 116, 118
Cloning virtual machine - 116
Coherence - 41
Configure 5.1 or 7.1 Surround Sound in a Virtual Machine - 195, 204
Configuring a Network in Linux - 208
Connect Bluetooth Devices - 81
Connect External Devices - 77
Connect to the Internet or a Network - 36, 95, 203
Connect Windows to a VLAN - 99
Connecting devices - 170
Connecting USB devices - 77
Control Programs with Trackpad Gestures or the Apple Remote - 67
Converting third-party virtual machines - 30
Copy and Paste Between Mac OS X and Windows - 51
Copying and pasting - 168
CPU and Memory - 156, 176
CPU, virtual - 127
Create a Custom Host-Only Network - 168
Create a PDF File - 89
Create and Use Virtual Machine Templates - 120
Create New Keyboard Shortcuts - 73
Customize Keyboard Shortcuts - 70, 138
Customize the Keyboard for the Guest OS - 72, 135

D
Default Configurations - 113
Default folder for virtual machines - 114
Default key combinations - 70
Deleting virtual machine - 125
Devices
adding - 170
removing from virtual machine - 170
Disable Automatically Suspending Windows - 159
Disk format - 172, 185
Disk size, changing - 185
Dock
adding Windows application to - 32
Documentation feedback - 211
Download Pre-configured Virtual Appliances - 112, 125, 156
DVD-ROM drive
adding - 170
configuring - 183
connecting/disconnecting - 183
removing - 170

E
Enable Spoken Commands - 127, 160
Enabling 3D acceleration - 103
Encrypt Windows to Protect It from Unauthorized Use - 37, 94
Encrypting virtual machine - 94
Exchanging data - 51, 52, 58, 63
Expanding disks - 185

F
Faster virtual machine - 100
Files
sharing files - 52
Find Settings - 200
Firewall problems - 28
Floppy Disk - 182
Floppy disk drive - 182
Folder
for virtual machines - 114
sharing folders - 52
Windows Applications folder - 32
For Software Developers - 149
Full Screen mode - 44, 45

G
Gaming - 103, 168, 180
General Tips - 27
Generate a Core Dump - 153
Gestures - 67
Get Acronis True Image - 117, 118, 128
Get Started - 31
Getting support - 210, 211
Glossary - 212
Graphics - 180
Guest operating system - 110
definition - 212
installing - 18
supported guest operating systems - 110

H
Hard disk
adding - 170
compressing hard disk - 185
configuring - 185
formats and types - 172
resizing - 185
using Boot Camp as hard disk - 29
viewing hard disk content - 118
Hard Disk - 129, 185
Hardware - 176
Hardware Settings - 176
Hidden messages - 160
Hide and Show Parallels Desktop - 158
Host computer
definition - 212
hardware requirements - 12
software requirements - 12
Host-only network - 98
Host-Only Networking Settings - 155, 166
Hot keys - 70
I
I Can't Activate Parallels Desktop - 201
If Parallels Doesn't Detect Windows Correctly - 28
If Your Mac Fails to Connect with Parallels Transporter Agent - 21, 28
I'm Having Problems Connecting to the Internet - 203
I'm Having Problems with Antivirus Software - 205
Import from an Earlier Parallels Desktop or Other Virtualization Application - 18, 30, 125
Import Linux and Your Data from a PC - 130
Import Your Data from a PC - 18, 20, 130
Improve Graphics Performance in Windows NT/98/ME - 134
Increasing hard disk capacity - 185
Initialize a Newly Added Disk - 172, 174
Install or Import Windows - 10, 18
Install or Update Parallels Tools - 47, 56, 89, 119, 126, 140, 150, 156, 196
Install or Upgrade Parallels Desktop - 10, 12
Install Parallels Desktop - 13, 15
Install Parallels Tools for Seamless Operation Between Windows and Mac OS X - 19, 20, 42, 51, 52, 60, 61, 62, 64, 92, 103, 125, 169, 199
Install Software Updates - 15
Install Sound Driver in OS/2 and eComStation - 149
Install Windows - 18, 106, 151
Install Windows 98 - 132
Install Windows Programs - 10, 36
Installing
guest operating system - 18
Parallels Desktop - 13
Parallels Tools - 142, 143, 148, 149
Parallels Transporter Agent - 21
Windows 98 - 132
Windows applications - 36
Installing and Upgrading Parallels Tools in Text Mode in Linux - 147
Installing the GCC Package and Kernel Sources in Linux - 144, 209
Integration With Chef/Ohai - 154
Integration With Docker - 154
Internet access - 95
IP address - 21, 86, 95, 96, 106, 160, 162, 166, 189
iPhone - 106
iSight camera - 90
Isolate Windows from Mac - 61, 93
Isolating virtual machine - 93
K
Keyboard and mouse
keyboard preferences - 70
keyboard profiles - 135
keyboard shortcuts - 69, 70
Keyboard shortcuts - 69, 70
L
Linux
installing Parallels Tools - 143
printers in - 82
supported versions - 110
Log messages - 160
M
MAC address - 95, 96, 98, 189
Make Virtual Machines Distinctive - 115
Making snapshots - 121
Manage Virtual Machines via Command Line Interface - 207
Manual update check - 15
Memory
  in virtual machine - 100
  required on host computer - 12
  troubleshooting - 202
  video memory - 180
Memory Usage Problems - 201
Merge Windows and Mac OS X - 31, 41, 48, 74, 138
Migration - 20
  over network or FireWire - 21
  using external storage device - 24
Migration from PC - 20
Modality Mode - 44, 157
Modality view - 157
Monitoring Windows in a Scalable Window - 44
More Options - 50, 168
More Resources - 11, 211
Mouse & Keyboard Settings - 75
Mouse, Trackpad, and Keyboard - 65
My Password Isn't Working - 203
My Virtual Machine Doesn't Boot - 203

N
Network - 156, 189
Network adapter
  adding - 170
  connecting and disconnecting - 189
  networking in virtual machine - 95
Network printer - 86
Networking
  Bridged - 96
  Host-only - 98
  Shared (NAT) - 95
  WiFi - 98

O
Open a Windows Program - 19, 31, 32, 39
Open the Current Safari Page in Internet Explorer - 62
OpenGL - 103, 180
Operating system
  installing in virtual machine - 18
  supported guest OSs - 110
Optimization Settings - 93, 100, 151, 202
Optimize 3D Graphics Performance on a MacBook Pro - 102
Optimize Performance - 99
Optimize Remote Debugging - 149
Optimize Virtual Machine for Games, Graphics, Productivity, or Development - 104, 156
Other Actions - 156
Other Operating Systems - 10
Over a Network - 20, 21
Overview of Methods for Importing - 20

P
Parallels Desktop
  activating - 13
  installing - 13
  registering - 13
  uninstalling - 159
  updating - 15
  upgrading - 14
Parallels Mounter - 117
Parallels network adapter - 189
Parallels Tools
  installing in Linux - 143
  installing in Mac OS X - 148
  installing in Windows - 142
Parallels Tools for Linux - 58, 82, 131, 143
Parallels Tools for Mac - 139, 148
Parallels Tools for Windows - 57, 74, 109, 142, 200
Parallels Tools Overview - 140
Parallels Transporter Agent - 21
  installing - 21
Parallels virtual appliances - 125
Parental control - 64
Password protection - 94
Pause Windows When No Programs Are Open - 100, 103
Pausing virtual machines - 36
Permanent activation key - 13
Plain disks - 172
Power, saving - 100
Pre-configured virtual appliances - 125
Pressing Ctrl+Alt+Del - 202
Primary operating system
  definition - 212
  supported primary OSs - 12
Print from Windows - 82, 192
Printer - 191
Index

setting up a Bonjour printer - 84
setting up a network printer - 86
setting up a USB printer - 89
sharing Mac printer - 82
Printer port - 191
Problem report - 210
Problems Using a Program After an Import - 29
Protect Your Data - 91
Protect Your Data from Viruses - 92
Protecting virtual machine by password - 94
Purchase Parallels Desktop - 14
Q
Quickly Free Up Disk Space - 129, 189
R
Reducing disk size - 185
Registration - 13
Remapping keys - 70
Remove a Virtual Machine - 125
Remove Parallels Desktop - 159
Removing
  devices - 170
  Parallels Desktop - 159
  virtual machine - 125
Reporting problems - 210
Request Support - 210
Requirements for Importing Your Data - 20
Resolve Guest OS DNS Requests Using etc/hosts - 155
Restore Virtual Machine Default Settings - 200
Resuming virtual machines - 36
Run Windows Phone Emulator - 150, 177
S
Safe Mode - 93
Save a Picture of the Screen - 108
Save Internet Passwords in Mac Keychain - 64
Save Snapshots of a Virtual Machine - 29, 94, 121
Save Time With Parallels Toolbox - 107
Schedule Windows Maintenance - 105
Screen Resolution - 45, 180
Screen shots
for problem reports - 210
Screen tearing prevention - 180
Searching Parallels disks - 118
Security settings - 93, 94
See and Change Windows Input Language In OS X - 74
Send Technical Data to Parallels - 210
Serial port - 193
Serial Port - 193
Set a Program to Open When You Insert a CD or DVD - 51
Set File Type Associations - 156
Set Files to Open in the Application or Program of Your Choice - 60
Set How Many Processors are Allocated to a Virtual Machine - 127, 151, 176
Set How Much Memory is Allocated to Windows - 100, 127, 151, 176, 202
Set How Windows Works with Mac OS X - 40
Set Internet Links to Always Open in Mac OS X or Windows - 62
Set Media Files to Open in Windows 8 Apps - 65
Set Password Requirements - 94
Set the Appearance of Virtual Machine Dock Icons - 108
Set the Guest OS Type and Version - 126
Set the Language - 17
Set Up a Network Printer - 86
Set Up a Printer Using Bonjour - 84
Set Up a USB Printer - 89
Set Up Your Mac to Use Windows Programs - 10
Set Where New Virtual Machines Are Stored - 114
Set Windows 8 to Work Like Windows 7 - 50
Set Windows to Appear in a Single Window - 43, 49, 55, 56, 58, 75, 77, 94
Set Windows to Take Up the Whole Screen - 44
Set Your Mouse or Trackpad to Right-Click and Middle-Click - 65
Setting up a printer - 82, 84, 86, 89
Share a Printer Connected to Your Mac - 82, 89
Share Applications and Programs - 35, 51, 58, 61
Index

Share External Storage Devices and Volumes - 63
Share Files and Folders - 23, 25, 52, 55, 59, 150
Share iCloud, Dropbox, or Google Drive Folders with Windows - 56
Share Items Between Mac OS X and Windows - 51
Share Network Settings Between Mac OS X and Windows - 86, 95, 164
Share Windows OneDrive Folders with Mac OS X - 57
Shared applications - 58
Shared folders - 52
Shared network (NAT) - 95
Shared Networking Settings - 150, 155, 162
Shared web applications - 62
Sharing files and folders - 52
Windows disks to Mac OS - 52
Shortcuts for applications - 69, 70
Show a Presentation on an External Monitor or Projector - 90
Show applications in the Dock - 32
Shut Down or Suspend Windows - 36, 94, 100, 103, 127, 159, 185
Shutting down virtual machine - 36
SmartGuard - 121
SmartMount - 63
SmartMouse - 168
Snapshots - 121
Software requirements - 12
Solving Problems - 27
Sound - 195
Sound device - 195
Speed Up Games and Graphics Programs - 103
Split disks - 172
Spotlight support - 32
Start a Debugging Session - 154
Start Windows - 24, 26, 30, 31, 36, 50, 52, 54, 55, 56, 63, 68, 82, 90, 104, 142, 143, 148, 200, 208
Starting virtual machine - 31
Startup and Shutdown Settings - 38, 159
Startup mode - 38
Status bar

connecting and disconnecting devices - 123
Step 1
Install Parallels Transporter Agent on Your Windows PC - 21
Step 2
Import Your Data - 21
Stopping virtual machine - 36
Support - 210, 211
Support for Virtual and Real Disks - 20, 113, 172, 187, 188
Supported guest operating systems - 110
Supported Guest Operating Systems - 10, 13, 110
Suspending virtual machine - 36
Switching to Coherence - 41
Switching to Full Screen - 44
Synchronizing
  Screen vertical synchronization - 180
System requirements - 12

T
Technical support - 210, 211
The F8 Key Isn't Working Correctly - 206
Third-party virtual machines - 30
Time Machine backup - 117, 121
Time synchronization - 168
Tips and Troubleshooting - 199
Touchpad gestures - 67
Translate Words in Windows - 109
Transporter Agent for Windows - 21
Trial activation key - 13
Troubleshooting - 199
Turning off virtual machine - 36
Typical virtual machines - 113

U
Unused space, cleaning up - 185
Update check - 15
Updating Parallels Desktop - 15
  automatically - 15
  manually - 15
Updating Parallels Tools - 142, 143, 148
Upgrade Parallels Desktop - 14
Upgrading from previous versions - 14
Upgrading Parallels Tools - 142, 143, 148
USB
<table>
<thead>
<tr>
<th><strong>Index</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>configuring USB - 79, 196</td>
</tr>
<tr>
<td>using USB devices in virtual machine - 77</td>
</tr>
<tr>
<td>USB &amp; Bluetooth - 78, 192, 196</td>
</tr>
<tr>
<td>Use a Disk Image with the Virtual DVD Drive - 64</td>
</tr>
<tr>
<td>Use AppleScript with the Guest OS - 129</td>
</tr>
<tr>
<td>Use Boot Camp with Parallels Desktop - 18, 29</td>
</tr>
<tr>
<td>Use Host-Only Network Settings - 98, 168, 191</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts - 69</td>
</tr>
<tr>
<td>Use Linux in Coherence Mode - 131</td>
</tr>
<tr>
<td>Use Mouse Wheel Horizontal Scrolling - 125</td>
</tr>
<tr>
<td>Use OS X as a Guest OS - 138</td>
</tr>
<tr>
<td>Use OS X in Coherence Mode - 139</td>
</tr>
<tr>
<td>Use Other Operating Systems on Your Mac - 130</td>
</tr>
<tr>
<td>Use the Built-in iSight Camera or Another Webcam - 90</td>
</tr>
<tr>
<td>Use Virtual Machine Names as DNS Names - 155</td>
</tr>
<tr>
<td>Use Wi-Fi with Windows - 98</td>
</tr>
<tr>
<td>Use Windows on Your iPad, iPhone, or Android Device - 106</td>
</tr>
<tr>
<td>Use Windows on Your Mac - 31</td>
</tr>
<tr>
<td>Using an External Storage Device - 20, 24</td>
</tr>
<tr>
<td><strong>V</strong></td>
</tr>
<tr>
<td>Video memory - 180</td>
</tr>
<tr>
<td>View modes - 41, 43, 44</td>
</tr>
<tr>
<td>Virtual appliances - 125</td>
</tr>
<tr>
<td>Virtual hard disk</td>
</tr>
<tr>
<td>adding new virtual disk - 170</td>
</tr>
<tr>
<td>backing up data - 117, 121</td>
</tr>
<tr>
<td>changing format - 185</td>
</tr>
<tr>
<td>configuring - 185</td>
</tr>
<tr>
<td>increasing capacity - 185</td>
</tr>
<tr>
<td>types of disks - 172</td>
</tr>
</tbody>
</table>