About This Guide

Parallels Desktop® 10 for Mac — C API Reference Guide
About This Guide

This document is a part of the Parallels Virtualization SDK. It contains the Parallels C API reference including information about handles (classes), functions, types, structures, enumerations, and other technical information.

Please note that this document does not provide general information on how to use the Parallels Virtualization SDK. For the detailed explanation of how to start using the SDK and how to create your own programs using the provided APIs, please read the Parallels Virtualization SDK Programmer's Guide, which is a companion book to this one.

To understand the material provided in this guide, you should have a basic knowledge of the ANSI C programming language and some experience working with application programming interfaces (API) written in C.

Copyright © 1999-2015 Parallels IP Holdings GmbH and its affiliates. All rights reserved.
Contents | Index
What do you think about this topic? Send feedback!


Organization of This Guide

Organization of This Guide

This guide is organized into the following chapters:

Functions by Handle. Contains sections describing handles and their respective functions. A handle is a reference to an object that can be operated on using the provided functions. Objects include a physical server, a virtual machine, a virtual machine configuration parameter set, a device, a process, etc. Each section contains information about the purpose of a handle and how to create it. Function subsections contain the usual reference information such as syntax, parameters, return codes, and remarks. You can search the guide for a specific function or a keyword, or you can scroll through the handle list, find the handle providing the functionality you need, and then look for a specific function that performs the required task.

Common Functions. Contains information about common and system functions.

Remote Desktop Access. Contains information about functions that can be used to remotely capture screenshots of a virtual machine desktop and to send keyboard and mouse commands to it.

Callback Prototypes. Describes callback function prototypes that are used to implement your own callback functions for use in asynchronous calls.

Types. Contains a list of types used throughout the API.

Structs, Records, Enums. Contains information about structures, records, and enumerations used throughout the API.

Macros. Describes macros used in the API.


How to Use This Guide

How to Use This Guide

As a demonstration, let's select a task and see how you can use this guide to find the technical information that will help you to implement it. We will use the task of starting a virtual machine. Follow these steps:

  1. Everything in the Parallels C API begins with a handle. If you want to perform a task, you need to know the name of the handle that provides the corresponding functionality (you can browse the Functions by Handle chapter and read the summary for each handle). In our case, the name of the handle is PHT_VIRTUAL_MACHINE.
  2. Read the handle description and find the information about how to obtain it. In this case, the handle is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. Follow the link to the PrlSrv_GetVmList function.
  3. When the topic describing the PrlSrv_GetVmList function is displayed, you will see a detailed description of the function and a sample demonstrating how to use it. The function accepts a handle of type PHT_SERVER as a parameter. Follow its link to see how it is obtained (or see the included code sample). The PHT_JOB object that the PrlSrv_GetVmList function returns will contain the PHT_VIRTUAL_MACHINE handle that we want. The information on how to extract the handle from the Job object is included in the function description. You can also follow the PHT_JOB link and see more info about it.
  4. Now that you know how to obtain the PHT_VIRTUAL_MACHINE handle, go back to its topic (use the document viewer options or click the link if it's available on the current page).
  5. In the PHT_VIRTUAL_MACHINE function list, find the PrlVm_Start function (functions are listed alphabetically). This is the function that starts a virtual machine. Follow its link and see the syntax, parameters, and return codes. As you can see, the function accepts a single parameter, which is a handle of type PHT_VIRTUAL_MACHINE that we've obtained in the previous steps. You now have all the information needed to implement the task in your program.

Once again, if you are just starting with the Parallels Virtualization SDK, your best source of information is Parallels Virtualization SDK Programmer's Guide. It explain the concepts and provides descriptions and step-by-step instructions on how to use the API to perform the most common tasks. Once you are familiar with the basic principles of the SDK design, you will find it easy to work with both guides and the API itself.


Functions by Handle

Functions by Handle
Topics

This chapter contains a list of handles. Each section describes a handle and contains subsections describing functions that can operate on the handle. Handle types are defined in the PRL_HANDLE_TYPE enumeration.

Topics
Name | Description
PHT_ACCESS_RIGHTS | The PHT_ACCESS_RIGHTS handle is used to obtain and modify the virtual machine access rights information.
PHT_BACKUP_RESULT | The PHT_BACKUP_RESULT handle is a container that contains the results of a backup operation. The handle is returned by the PrlSrv_CreateVmBackup function call (the handle is returned as the first parameter of the Job object).
PHT_BOOT_DEVICE | The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.
PHT_CT_TEMPLATE | The PHT_CT_TEMPLATE handle is used to manage operating system templates on which Containers are based.
PHT_CVSRC | The PHT_CVSRC handle is used to capture data from a video source on the host computer and display in the guest operating system.
PHT_DESKTOP_CONTROL | The PHT_DESKTOP_CONTROL handle is used to remotely access the desktop of the physical host computer. Use the PrlSrv_CreateDesktopControl to create the handle. See the Remote Desktop Access section for the list of functions that support this functionality.
PHT_DISP_CONFIG | The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.
PHT_EVENT | The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.
PHT_EVENT_PARAMETER | The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.
PHT_FIREWALL_RULE | The PHT_FIREWALL_RULE handle is used to create and modify firewall rules.
PHT_FOUND_VM_INFO | The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.
PHT_GUEST_OSES_MATRIX | The PHT_GUEST_OSES_MATRIX handle is a container that contains a list of operating system names and versions that are supported on a given server. To obtain the handle, use the PrlSrv_GetSupportedOses function.
PHT_HANDLES_LIST | The PHT_HANDLES_LIST handle is a generic container that can hold a list of other handles. It is typically used to pass a list of handles to a function in a single parameter. The handles in the container can be of the same type or of different types. A new handle is created by making the PrlApi_CreateHandlesList function call.
PHT_HW_GENERIC_DEVICE | PHT_HW_GENERIC_DEVICE is a base handle used to manage physical devices. A physical device can be a real physical device installed on the host computer or, in some cases, a device in a virtual machine as seen by the guest operating system (this handle should not be confused with handles that are used to manage virtual devices).
PHT_HW_GENERIC_PCI_DEVICE | The PHT_HW_GENERIC_PCI_DEVICE handle is used to obtain information about a generic PCI device installed in the host machine. The handle is obtained by calling the PrlSrvCfg_GetGenericPciDevice function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.
PHT_HW_HARD_DISK | The PHT_HW_HARD_DISK handle is used to manage physical hard disks installed on the host computer. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.
PHT_HW_HARD_DISK_PARTITION | The PHT_HW_HARD_DISK_PARTITION handle is used to manage partitions of a physical hard disk installed on the host computer. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional functions.
PHT_HW_NET_ADAPTER | The PHT_HW_NET_ADAPTER handle is used to manage network adapters installed on the host computer or in a guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional functions.
PHT_IPPRIV_NET | The PHT_IPPRIV_NET handle is used to create and configure IP private networks.
PHT_JOB | The PHT_JOB handle provides methods for managing asynchronous operations.
PHT_LICENSE | The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.
PHT_LOGIN_RESPONSE | The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.
PHT_NET_SERVICE_STATUS | The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.
PHT_NETWORK_CLASS | The PHT_NETWORK_CLASS handle is used to configure network accounting. To use the handle, first create it using the PrlNetworkClass_Create function and then use the handle function to manage network classes configuration.
PHT_NETWORK_RATE | The PHT_NETWORK_RATE handle is used to configure the virtual machine output bandwidth. The handle is obtained using the PrlNetworkRate_Create function.
PHT_NETWORK_SHAPING | The PHT_NETWORK_SHAPING handle is used to configure network shaping. The handle is obtained using the PrlNetworkShapingEntry_Create function.
PHT_NETWORK_SHAPING_BANDWIDTH | The PHT_NETWORK_SHAPING_BANDWIDTH handle is used to create network shaping configuration.
PHT_NETWORK_SHAPING_CONFIG | The PHT_NETWORK_SHAPING_CONFIG handle is used to configure network shaping.
PHT_OFFLINE_SERVICE | The PHT_OFFLINE_SERVICE handle is used to configure offline services. When creating a new offline service configuration, use the PrlOffmgmtService_Create to create the handle. When managing existing offline services configurations, use the PrlSrv_GetOfflineServicesList function to obtain the list of handles.
PHT_OPAQUE_TYPE_LIST | The PHT_OPAQUE_TYPE_LIST handle is a container for storing type lists.
PHT_PLUGIN_INFO | The PHT_PLUGIN_INFO handle is a container that contains information about a third-party plug-in installed in Parallels Service. To obtain the list of installed plug-ins use the PrlSrv_GetPluginsList function.
PHT_PORT_FORWARDING | The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP or UDP port in the host machine to the specified port in a virtual machine.
PHT_PROBLEM_REPORT | The PHT_PROBLEM_REPORT handle is used to obtain and manage Parallels Problem Reports. To obtain the handle, use the PrlApi_CreateProblemReport function.
PHT_REMOTE_FILESYSTEM_ENTRY | The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.
PHT_REMOTE_FILESYSTEM_INFO | The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.
PHT_RESULT | The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.
PHT_RUNNING_TASK | The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.
PHT_SCREEN_RESOLUTION | The PHT_SCREEN_RESOLUTION handle is used to modify the list of screen resolutions available in a virtual machine. By default, only the most common resolutions are supported in a virtual machine. Using this handle, you can add additional resolutions and modify the existing ones if needed. The handle is obtained using the PrlVm_CreateScrRes or the PrlVm_GetScrRes function. The additional screen resolution support can be enabled or disabled in a virtual machine. To determine the status of the feature, use the PrlVmCfg_IsScrResEnabled function.
PHT_SERVER | At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.
PHT_SERVER_CONFIG | The PHT_SERVER_CONFIG handle is used to obtain the host computer configuration information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call. The handle can also be used to obtain network settings of a guest operating system installed in a virtual machine. In this case, the handle is obtained using the PrlVmGuest_GetNetworkSettings function.
PHT_SERVER_INFO | The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.
PHT_SHARE | The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.
PHT_STRINGS_LIST | The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.
PHT_SYSTEM_STATISTICS | The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.
PHT_SYSTEM_STATISTICS_CPU | The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.
PHT_SYSTEM_STATISTICS_DISK | The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.
PHT_SYSTEM_STATISTICS_DISK_PARTITION | The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.
PHT_SYSTEM_STATISTICS_IFACE | The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.
PHT_SYSTEM_STATISTICS_PROCESS | The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.
PHT_SYSTEM_STATISTICS_USER_SESSION | The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.
PHT_UIEMU_INPUT |
PHT_USB_IDENTITY |
PHT_USER_INFO | The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.
PHT_USER_PROFILE | The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.
PHT_VIRTUAL_DEV_FLOPPY | The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.
PHT_VIRTUAL_DEV_HARD_DISK | The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.
PHT_VIRTUAL_DEV_HD_PARTITION | The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.
PHT_VIRTUAL_DEV_NET_ADAPTER | The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.
PHT_VIRTUAL_DEV_OPTICAL_DISK | The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.
PHT_VIRTUAL_DEV_PARALLEL_PORT | The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.
PHT_VIRTUAL_DEV_SERIAL_PORT | The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.
PHT_VIRTUAL_DEV_SOUND | The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.
PHT_VIRTUAL_DEV_USB_DEVICE | The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.
PHT_VIRTUAL_DISK | The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files including a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and the files that are used for data storage. Once created, a virtual disk can be connected to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk or... more
PHT_VIRTUAL_MACHINE | PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.
PHT_VIRTUAL_NETWORK | The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.
PHT_VM_CONFIGURATION | The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.
PHT_VM_GUEST_SESSION | The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle can also be used to obtain some of the guest operating system configuration information. The handle is obtained using the PrlVm_LoginInGuest function.
PHT_VM_INFO | The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.
PHT_VM_TOOLS_INFO | The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.
Links
Topics


PHT_ACCESS_RIGHTS

PHT_ACCESS_RIGHTS
Functions Functions by Handle Legend

The PHT_ACCESS_RIGHTS handle is used to obtain and modify the virtual machine access rights information.

Description

By default, only the owner of a virtual machine has full access to it. All other users are completely unaware of the machine (it will not even appear in the list of the available virtual machines for them). The owner of the virtual machine can change this by setting the virtual machine access rights for other users. The access rights include no-access, view, run, full access (see PRL_VM_ACCESS_FOR_OTHERS for the complete list).

The PHT_ACCESS_RIGHTS handle is obtained by calling the PrlVmCfg_GetAccessRights or the PrlVmInfo_GetAccessRights function. An object returned by either function will contain access rights information for a specific virtual machine. You can use either function to obtain a handle depending on the application logic.

Functions
Name | Description
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.
Links
Functions, Functions by Handle, Legend


PHT_BACKUP_RESULT

PHT_BACKUP_RESULT
Functions Functions by Handle Legend

The PHT_BACKUP_RESULT handle is a container that contains the results of a backup operation. The handle is returned by the PrlSrv_CreateVmBackup function call (the handle is returned as the first parameter of the Job object).

Functions
Name | Description
PrlBackupResult_GetBackupUuid | Returns the UUID (universally unique ID) of the created backup
Links
Functions, Functions by Handle, Legend


PHT_BOOT_DEVICE

PHT_BOOT_DEVICE
Functions Functions by Handle Legend

The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.

Description

A virtual machine can boot from a variety of devices, such as hard disk drives, floppy drives, removable drives, network etc. The PHT_BOOT_DEVICE object provides functions that can be used to obtain the information about and to modify a device in the boot priority list.

Each device in the boot priority list is uniquely identified by type (see PRL_DEVICE_TYPE) and index (a numeric ID). This allows to include more than one device of a particular type in the list (e.g more than one hard disk drive). Please note that each virtual device has an index assigned to it in the main virtual machine configuration. The same index is used to identify a device in the boot priority list.

The position of the device in the list is determined by a sequence index assigned to it, starting from 0 and up. The highest boot priority index (the first device to boot from) is 0.

When creating a virtual machine using a default configuration, the boot device priority list is configured automatically.

Note: Any boot device list modification must begin with the PrlVm_BeginEdit and end with the PrlVm_Commit call. These two functions are used to detect collisions with other clients trying to make similar modifications to the same virtual machine. See PrlBootDev_SetSequenceIndex for code sample.
Functions
Name | Description
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.
Links
Functions, Functions by Handle, Legend


PHT_CT_TEMPLATE

PHT_CT_TEMPLATE
Functions Functions by Handle Legend

The PHT_CT_TEMPLATE handle is used to manage operating system templates on which Containers are based.

Functions
Name | Description
PrlCtTemplate_GetCpuMode | Determines the specified template CPU mode (32 bit or 64 bit).
PrlCtTemplate_GetDescription | Returns description of the Container's template.
PrlCtTemplate_GetName | Returns name of the Container's template.
PrlCtTemplate_GetOsTemplate | Returns the version of the operating system template for which the specified application template is.
PrlCtTemplate_GetOsType | Returns the type of the operating system for which the specified template is.
PrlCtTemplate_GetOsVersion | Returns the version of the operating system for which the specified template is running.
PrlCtTemplate_GetType | Returns the type of the specified template.
PrlCtTemplate_GetVersion | Returns version of the Container's template.
PrlCtTemplate_IsCached | Determines whether the template cached.
Links
Functions, Functions by Handle, Legend


PHT_CVSRC

PHT_CVSRC
Functions Functions by Handle Legend

The PHT_CVSRC handle is used to capture data from a video source on the host computer and display in the guest operating system.

Functions
Name | Description
PrlCVSrc_Close | Close channel previously opened with PrlCVSrc_Open().
PrlCVSrc_Connect | Connects source to Vm.
PrlCVSrc_Disconnect | Disconnects source from Vm.
PrlCVSrc_GetBuffer | Returns frame buffer pointer and size.
PrlCVSrc_GetOpenMode | Returns current mode obtained after call to PrlCVSrc_Open().
PrlCVSrc_LockBuffer | Locks access to frame buffer.
PrlCVSrc_Open | Open channel to supply frames to Vm.
PrlCVSrc_SetLocalizedName | Set source name.
PrlCVSrc_SetUniqueId | Set source unique id.
PrlCVSrc_UnlockBuffer | Unlocks access to frame buffer and submits changes to Vm.
Links
Functions, Functions by Handle, Legend


PHT_DESKTOP_CONTROL

PHT_DESKTOP_CONTROL
Functions by Handle

The PHT_DESKTOP_CONTROL handle is used to remotely access the desktop of the physical host computer. Use the PrlSrv_CreateDesktopControl to create the handle. See the Remote Desktop Access section for the list of functions that support this functionality.

Links
Functions by Handle


PHT_DISP_CONFIG

PHT_DISP_CONFIG
Functions Functions by Handle Legend

The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.

Description

Parallels Service preferences include memory, network, default virtual machine folder, and some other settings. The following describes how to modify the memory and network settings as a demonstration of the handle usage.

First, you have to obtain a handle of type PHT_DISP_CONFIG by making the PrlSrv_GetCommonPrefs function call.

To make the memory modification:

  1. Call PrlSrv_CommonPrefsBeginEdit to mark the beginning of the operation.
  2. Call one or more of the memory management functions from the PHT_DISP_CONFIG group to modify the desired settings.
  3. Call PrlSrv_CommonPrefsCommit to save the changes to the Parallels Service configuration.

The network adapter changes are performed outside of the begin/commit block. To modify an existing or to create a new virtual network adapter, use the following steps:

  1. First, obtain a handle of type PHT_DISP_NET_ADAPTER by calling the PrlDispCfg_GetDispNet or the PrlDispCfg_CreateDispNet function. The first function obtains a handle to an existing adapter and is used when modifying an adapter. The second function creates and returns a new handle and is used when adding a new virtual adapter to the Parallels Service configuration.
  2. Populate or modify the necessary network adapter properties using functions from the PHT_DISP_NET_ADAPTER group.
  3. If you are creating a new adapter, call PrlSrv_AddNetAdapter to add the adapter to the Parallels Service configuration. If you are modifying an existing adapter, call PrlSrv_UpdateNetAdapter to save the changes. If you would like to delete an adapter from the Parallels Service configuration, call the PrlSrv_DeleteNetAdapter function.
Functions
Name | Description
PrlDispCfg_ArePluginsEnabled | Determines whether the plugins enabled or not
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_EnablePlugins | Enable or disable the plugins support
PrlDispCfg_GetBackupTimeout | Get backup timeout in seconds.
PrlDispCfg_GetBackupTmpDir | Returns the backup temporary directory.
PrlDispCfg_GetBackupUserLogin | Returns the backup user login.
PrlDispCfg_GetConfirmationsList | Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )
PrlDispCfg_GetCpuFeaturesMaskEx | Allows to get the CPU features masks from dispatcher config.
PrlDispCfg_GetDefaultBackupDirectory | Returns PATH to the default backup directory.
PrlDispCfg_GetDefaultBackupServer | Returns the default backup server host name or IP address.
PrlDispCfg_GetDefaultCtDir | Obtains path of the directory in which new Container are created by default.
PrlDispCfg_GetDefaultEncryptionPluginId | Returns default encryption plugin Id.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetMobileAdvancedAuthMode | Get the advanced authorization mode for Parallels Access clients.
PrlDispCfg_GetProxyConnectionStatus | Determines proxy connection status or error code of last proxy operation.
PrlDispCfg_GetProxyConnectionUser | Returns the name of user associated with current proxy connection.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetUsbIdentity | Returns handle of type PHT_USB_IDENTITY storing information of USB device with specified index.
PrlDispCfg_GetUsbIdentityCount | Determines number of USB devices known to the Parallels Service.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_IsAllowAttachScreenshotsEnabled | Determines whether the allow attach screenshots is enabled for problem report.
PrlDispCfg_IsAllowDirectMobile | Determines whether the Allow Direct Mobile Connections option is enabled.
PrlDispCfg_IsAllowMobileClients | Determines whether the Allow Mobile Clients option is enabled.
PrlDispCfg_IsAllowMultiplePMC | Determines whether the Allow Multiple PMC option is enabled.
PrlDispCfg_IsBackupUserPasswordEnabled | Returns the backup user password enabling sign.
PrlDispCfg_IsLogRotationEnabled | Determines whether the log rotation is enabled for dispatcher and virtual machine logs.
PrlDispCfg_IsProxyEnabled | Determines whether dispatcher should connect to the mobile proxy server by default.
PrlDispCfg_IsSendStatisticReport | Determines whether send statistics reports (CEP) mechanism activated.
PrlDispCfg_IsVerboseLogEnabled | Determines whether the verbose log level is configured for dispatcher and virtual machines processes.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetAllowAttachScreenshotsEnabled | Enables or disables the allow attach screenshots for problem report.
PrlDispCfg_SetAllowDirectMobile | Enables or disables the Allow Direct Mobile option.
PrlDispCfg_SetAllowMultiplePMC | Enables or disables the Allow Multiple PMC option.
PrlDispCfg_SetBackupTimeout | Set backup timeout in seconds.
PrlDispCfg_SetBackupTmpDir | Sets the backup temporary directory.
PrlDispCfg_SetBackupUserLogin | Sets the backup user login.
PrlDispCfg_SetBackupUserPassword | Sets the backup user password.
PrlDispCfg_SetBackupUserPasswordEnabled | Sets the backup user password.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetConfirmationsList | Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )
PrlDispCfg_SetCpuFeaturesMaskEx | Allows to set the CPU features masks.
PrlDispCfg_SetDefaultBackupDirectory | Sets PATH to the default backup directory.
PrlDispCfg_SetDefaultBackupServer | Sets the default backup server host name or IP address.
PrlDispCfg_SetDefaultEncryptionPluginId | Sets default encryption plugin Id.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetLogRotationEnabled | Enables or disables the log rotation for dispatcher and virtual machine logs.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetMobileAdvancedAuthMode | Set the advanced authorization mode for Parallels Access clients.
PrlDispCfg_SetProxyConnectionCreds | Specifies credentials for establishing a proxy connection.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetSendStatisticReport | Allows to switch on/off mechanism of sending statistics reports (CEP).
PrlDispCfg_SetUsbIdentAssociation | (Un)Associates USB device with given Vm.
PrlDispCfg_SetVerboseLogEnabled | Enables or disables the verbose log level for dispatcher and virtual machines processes.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.
Links
Functions, Functions by Handle, Legend


PHT_EVENT

PHT_EVENT
Functions Functions by Handle Legend

The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.

Description

When the PHT_EVENT object is used as an event data container, a handle to it is obtained through callback functionality (a handle is passed as a parameter to a callback function). When the object is used as an extended error information container in asynchronous functions, a handle to it is obtained from the PHT_JOB object returned by a function by calling the PrlJob_GetError function.

The common steps in processing an event in a callback function are as follows:

  1. Determine the type of the event by calling the PrlEvent_GetType function passing the event handle to it. The event types are defined in the PRL_EVENT_TYPE enumeration. This will tell you what happened on the Parallels Service side. For example, a virtual machine state has changed, the host configuration has been updated, etc.
  2. Determine the event source by calling the PrlEvent_GetIssuerType function. The function returns the event issuer type that you can look up in the PRL_EVENT_ISSUER_TYPE enumeration. This will tell you if the event was generated by the host, a virtual machine, a web service, etc.
  3. If an event was generated by the Parallels Service or a virtual machine, you can obtain the server or the virtual machine handle by using the PrlEvent_GetServer or the PrlEvent_GetVm function respectively. Depending on the event type, you may use a handle to access the Parallels Service or a virtual machine and perform some operations on them if needed.
  4. An event object may contain additional parameters, which can be retrieved from it using the PrlEvent_GetParam function. The function returns a handle of type PHT_EVENT_PARAMETER containing an individual parameter data. There may be multiple parameters in a given event object, so the function must be called once for each of the available parameters. To determine the number of parameters, use the PrlEvent_GetParamsCount function. Once you've obtained a PHT_EVENT_PARAMETER handle, you can use its functions to retrieve the parameter values.
Functions
Name | Description
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.
Links
Functions, Functions by Handle, Legend


PHT_EVENT_PARAMETER

PHT_EVENT_PARAMETER
Functions Functions by Handle Legend

The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.

Description

The event parameter container contains the following information:

  1. Parameter name. To retrieve the name, use the PrlEvtPrm_GetName function.
  2. Parameter data type. Depending on the event type, a parameter can be of any type defined in the PRL_PARAM_FIELD_DATA_TYPE_PTR enumeration. To retrieve the parameter data type, use the PrlEvtPrm_GetType function.
  3. Parameter value. Depending on the parameter data type, the value must be retrieved using an appropriate function from the PHT_EVENT_PARAMETER group (see the function list below). For example, a boolean value must be retrieved using the PrlEvtPrm_ToBoolean function, the string value must be retrieved using the PrlEvtPrm_ToString function, if a parameter contains a handle, it must be obtained using the PrlEvtPrm_ToHandle, etc. The meaning of the value is usually different for different event types.
Functions
Name | Description
PrlEvtPrm_GetBuffer | Returns the event parameter value as binary buffer.
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToInt64 | Returns the event parameter value as PRL_INT64.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.
PrlEvtPrm_ToUint64 | Returns the event parameter value as PRL_UINT64.
Links
Functions, Functions by Handle, Legend


PHT_FIREWALL_RULE

PHT_FIREWALL_RULE
Functions Functions by Handle Legend

The PHT_FIREWALL_RULE handle is used to create and modify firewall rules.

Functions
Name | Description
PrlFirewallRule_Create | Creates a new handle of type PHT_FIREWALL_RULE.
PrlFirewallRule_GetLocalNetAddress | Returns the local address of the specified firewall rule entry.
PrlFirewallRule_GetLocalPort | Returns the local port.
PrlFirewallRule_GetProtocol | Returns the protocol of the specified firewall rule entry.
PrlFirewallRule_GetRemoteNetAddress | Returns the remote address of the specified firewall rule entry.
PrlFirewallRule_GetRemotePort | Returns the remote port.
PrlFirewallRule_SetLocalNetAddress | Sets the specified firewall rule entry local address.
PrlFirewallRule_SetLocalPort | Sets the specified local port.
PrlFirewallRule_SetProtocol | Sets the specified firewall rule entry protocol.
PrlFirewallRule_SetRemoteNetAddress | Sets the specified firewall rule entry remote address.
PrlFirewallRule_SetRemotePort | Sets the specified remote port.
Links
Functions, Functions by Handle, Legend


PHT_FOUND_VM_INFO

PHT_FOUND_VM_INFO
Functions Functions by Handle Legend

The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.

Functions
Name | Description
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.
Links
Functions, Functions by Handle, Legend


PHT_GUEST_OSES_MATRIX

PHT_GUEST_OSES_MATRIX
Functions Functions by Handle Legend

The PHT_GUEST_OSES_MATRIX handle is a container that contains a list of operating system names and versions that are supported on a given server. To obtain the handle, use the PrlSrv_GetSupportedOses function.

Functions
Name | Description
PrlOsesMatrix_GetDefaultOsVersion | Returns default guest OS version for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).
PrlOsesMatrix_GetSupportedOsesTypes | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list retrieved from remote server (see PrlSrv_GetSupportedOses).
PrlOsesMatrix_GetSupportedOsesVersions | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).
Links
Functions, Functions by Handle, Legend


PHT_HANDLES_LIST

PHT_HANDLES_LIST
Functions Functions by Handle Legend

The PHT_HANDLES_LIST handle is a generic container that can hold a list of other handles. It is typically used to pass a list of handles to a function in a single parameter. The handles in the container can be of the same type or of different types. A new handle is created by making the PrlApi_CreateHandlesList function call.

Functions
Name | Description
PrlHndlList_AddItem | Adds the specified handle to the container.
PrlHndlList_GetItem | Retrieves a handle from the container.
PrlHndlList_GetItemsCount | Determines the total number of handles in the specified container.
PrlHndlList_RemoveItem | Removes a handle from the container.
Links
Functions, Functions by Handle, Legend


PHT_HW_GENERIC_DEVICE

PHT_HW_GENERIC_DEVICE
Functions Functions by Handle Legend

PHT_HW_GENERIC_DEVICE is a base handle used to manage physical devices. A physical device can be a real physical device installed on the host computer or, in some cases, a device in a virtual machine as seen by the guest operating system (this handle should not be confused with handles that are used to manage virtual devices).

Description

To obtain a handle identifying a specific device of a particular type, an appropriate function from the PHT_SERVER_CONFIG group must be used. For example, to obtain a handle identifying a floppy disk drive, the PrlSrvCfg_GetFloppyDisk function must be used; to obtain an optical disk drive handle, use the PrlSrvCfg_GetOpticalDisk (other functions are named similarly). Some of these functions obtain a handle of type PHT_HW_GENERIC_DEVICE described here. Others obtain a different handle specific to the device type. These other handles are derived from the PHT_HW_GENERIC_DEVICE handle and contain additional functions. For example, the PHT_HW_HARD_DISK handle is derived from PHT_HW_GENERIC_DEVICE and contains additional functions, such as functions for getting the disk partition information. All of the functions provided by the PHT_HW_GENERIC_DEVICE handle can also be used with derived handles, which means that a derived handle can be passed as a parameter to any of the functions described in this section.

The following is the list of handles that are derived from PHT_HW_GENERIC_DEVICE:

PHT_HW_HARD_DISK

PHT_HW_HARD_DISK_PARTITION

PHT_HW_NET_ADAPTER

PHT_HW_GENERIC_PCI_DEVICE

Functions
Name | Description
PrlSrvCfgDev_GetDeviceState | Determines whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.
PrlSrvCfgDev_GetId | Obtains the device ID.
PrlSrvCfgDev_GetName | Obtains the device name.
PrlSrvCfgDev_GetType | Obtains the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to a virtual machine.
PrlSrvCfgDev_SetDeviceState | Allows to specify whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.
Links
Functions, Functions by Handle, Legend


PHT_HW_GENERIC_PCI_DEVICE

PHT_HW_GENERIC_PCI_DEVICE
Functions Functions by Handle Legend

The PHT_HW_GENERIC_PCI_DEVICE handle is used to obtain information about a generic PCI device installed in the host machine. The handle is obtained by calling the PrlSrvCfg_GetGenericPciDevice function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.

Description

Generic PCI devices managed by this handle include devices that can be accessed directly by a virtual machine using the IOMMU technology, such as Intel's Vt-d. If you have a system with a PCI device that support the technology, you can choose the device assignment from one of the following options:

Host Computer. If you select this assignment, the PCI device will be available to the host computer only.

Virtual Machines. If you select this assignment, a pass-through driver will be automatically installed in the host operating system, which will make the device invisible to it. This will make it possible to assign the device directly to a virtual machine.

To select the PCI device assignment, follows these steps:

1. Call the PrlSrvCfg_GetGenericPciDevicesCount function to determine the number of PCI devices installed in the host.

2. Iterate through the device list calling the PrlSrvCfg_GetGenericPciDevice function in each iteration. The function obtains a handle of type PHT_HW_GENERIC_PCI_DEVICE containing information about an individual device.

3. Call the PrlSrvCfgPci_GetDeviceClass to determine the type of the device (video, network, sound). Choose the device(s) of interest and call the PrlSrvCfgDev_SetDeviceState function for each one passing a value indicating the desired assignment type.

4. Populate the PHT_HANDLES_LIST handle with PHT_HW_GENERIC_PCI_DEVICE handles that you've selected in step 3.

5. Call the PrlSrv_ConfigureGenericPci function passing the PHT_HANDLES_LIST handle as a parameter to submit the changes to the Parallels Service.

6. If you've selected the "Virtual Machines" assignment, you can now add the device to the virtual machine(s) of your choice. Please note that the device can be added to multiple virtual machines but it can be used only by a single machine at any given time. Once the device is added to the virtual machine, the latest device drivers should be installed in it (provided by the device manufacturer) the usual way.

Functions
Name | Description
PrlSrvCfgPci_GetDeviceClass | Obtains the class of the PCI device (network, display, sound, etc.).
Links
Functions, Functions by Handle, Legend


PHT_HW_HARD_DISK

PHT_HW_HARD_DISK
Functions Functions by Handle Legend

The PHT_HW_HARD_DISK handle is used to manage physical hard disks installed on the host computer. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.

Functions
Name | Description
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.
Links
Functions, Functions by Handle, Legend


PHT_HW_HARD_DISK_PARTITION

PHT_HW_HARD_DISK_PARTITION
Functions Functions by Handle Legend

The PHT_HW_HARD_DISK_PARTITION handle is used to manage partitions of a physical hard disk installed on the host computer. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional functions.

Functions
Name | Description
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.
Links
Functions, Functions by Handle, Legend


PHT_HW_NET_ADAPTER

PHT_HW_NET_ADAPTER
Functions Functions by Handle Legend

The PHT_HW_NET_ADAPTER handle is used to manage network adapters installed on the host computer or in a guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional functions.

Functions
Name | Description
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDefaultGatewayIPv6 | Returns the default IPv6 gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_GetVlanTag | Returns the VLAN tag of the specified network adapter.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsConfigureWithDhcpIPv6 | Determines whether the adapter IPv6 network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.
Links
Functions, Functions by Handle, Legend


PHT_IPPRIV_NET

PHT_IPPRIV_NET
Functions Functions by Handle Legend

The PHT_IPPRIV_NET handle is used to create and configure IP private networks.

Functions
Name | Description
PrlIPPrivNet_Create | Creates a new handle of type PHT_IPPRIV_NET.
PrlIPPrivNet_GetName | Returns the name of the specified private network.
PrlIPPrivNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a private network.
PrlIPPrivNet_IsGlobal | Determines the mode (global or not) of the specified private network.
PrlIPPrivNet_SetGlobal | Sets the mode (global or not) of the specified private network.
PrlIPPrivNet_SetName | Sets the specified private network ID.
PrlIPPrivNet_SetNetAddresses | Allows to set IP addresses/Subnet masks to a private network.
Links
Functions, Functions by Handle, Legend


PHT_JOB

PHT_JOB
Functions Functions by Handle Legend

The PHT_JOB handle provides methods for managing asynchronous operations.

Description

Every asynchronous function in the Parallels API returns a handle of type PHT_JOB. An asynchronous function returns immediately and the corresponding task is processed in a background thread. The returned job object is used as a reference to the job. While the operation is running, the job object can be used to find out the status of the operation, to get a progress report, or to cancel the job if needed. When the job completes, the job object is populated with the operation return code and the operation result (where applicable). The methods provided by the object can be used to extract this information. Once you are done processing the results, you must destroy the job object using the PrlHandle_Free function. For detailed information about jobs and asynchronous functions, please also see the Parallels Virtualization SDK Programmer's Guide.

Functions
Name | Description
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_IsRequestWasSent | Returns the sign whether request was sent to remote side or was aborted by some local reasons (wrong params passed or something else).
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.
Links
Functions, Functions by Handle, Legend


PHT_LICENSE

PHT_LICENSE
Functions Functions by Handle Legend

The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.

Functions
Name | Description
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.
Links
Functions, Functions by Handle, Legend


PHT_LOGIN_RESPONSE

PHT_LOGIN_RESPONSE
Functions Functions by Handle Legend

The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.

Functions
Name | Description
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).
Links
Functions, Functions by Handle, Legend


PHT_NET_SERVICE_STATUS

PHT_NET_SERVICE_STATUS
Functions Functions by Handle Legend

The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.

Functions
Name | Description
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.
Links
Functions, Functions by Handle, Legend


PHT_NETWORK_CLASS

PHT_NETWORK_CLASS
Functions Functions by Handle Legend

The PHT_NETWORK_CLASS handle is used to configure network accounting. To use the handle, first create it using the PrlNetworkClass_Create function and then use the handle function to manage network classes configuration.

Functions
Name | Description
PrlNetworkClass_Create | Creates a new handle of type PHT_NETWORK_CLASS.
PrlNetworkClass_GetClassId | Returns the network class id.
PrlNetworkClass_GetNetworkList | Returns the list of networks for specified network class entry.
PrlNetworkClass_SetClassId | Sets the network class id.
PrlNetworkClass_SetNetworkList | Sets the list of networks for specified network class entry.
Links
Functions, Functions by Handle, Legend


PHT_NETWORK_RATE

PHT_NETWORK_RATE
Functions Functions by Handle Legend

The PHT_NETWORK_RATE handle is used to configure the virtual machine output bandwidth. The handle is obtained using the PrlNetworkRate_Create function.

Functions
Name | Description
PrlNetworkRate_Create | Creates a new handle of type PHT_NETWORK_RATE.
PrlNetworkRate_GetClassId | Returns the network rate entry class id.
PrlNetworkRate_GetRate | Returns the network rate entry Rate value.
Links
Functions, Functions by Handle, Legend


PHT_NETWORK_SHAPING

PHT_NETWORK_SHAPING
Functions Functions by Handle Legend

The PHT_NETWORK_SHAPING handle is used to configure network shaping. The handle is obtained using the PrlNetworkShapingEntry_Create function.

Functions
Name | Description
PrlNetworkShapingEntry_Create | Creates a new handle of type PHT_NETWORK_SHAPING.
PrlNetworkShapingEntry_GetClassId | Returns the network class id.
PrlNetworkShapingEntry_GetDevice | Returns the network device for specified shaping entry.
PrlNetworkShapingEntry_GetRate | Returns the default rate for specified shaping entry.
PrlNetworkShapingEntry_GetTotalRate | Returns the total rate for specified shaping entry.
PrlNetworkShapingEntry_SetClassId | Sets the network class id for specified shaping entry.
PrlNetworkShapingEntry_SetDevice | Sets the specified network device.
PrlNetworkShapingEntry_SetRate | Sets the default network guaranteed rate.
PrlNetworkShapingEntry_SetTotalRate | Sets the total rate for specified shaping entry.
Links
Functions, Functions by Handle, Legend


PHT_NETWORK_SHAPING_BANDWIDTH

PHT_NETWORK_SHAPING_BANDWIDTH
Functions Functions by Handle Legend

The PHT_NETWORK_SHAPING_BANDWIDTH handle is used to create network shaping configuration.

Functions
Name | Description
PrlNetworkShapingBandwidthEntry_Create | Creates a new handle of type PHT_NETWORK_SHAPING_BANDWIDTH.
PrlNetworkShapingBandwidthEntry_GetBandwidth | Returns the network device bandwidth for specified shaping entry.
PrlNetworkShapingBandwidthEntry_GetDevice | Returns the network device name for specified shaping entry.
PrlNetworkShapingBandwidthEntry_SetBandwidth | Sets the network device bandwidth for specified shaping entry.
PrlNetworkShapingBandwidthEntry_SetDevice | Sets the network device name for specified shaping entry.
Links
Functions, Functions by Handle, Legend


PHT_NETWORK_SHAPING_CONFIG

PHT_NETWORK_SHAPING_CONFIG
Functions Functions by Handle Legend

The PHT_NETWORK_SHAPING_CONFIG handle is used to configure network shaping.

Functions
Name | Description
PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList | Obtains a list of network shaping bandwidth entries represents the network shaping configuration.
PrlNetworkShapingConfig_GetNetworkShapingList | Obtains a list of network shaping entries represents the network shaping configuration.
PrlNetworkShapingConfig_IsEnabled | Determines whether the network shaping is enabled or disabled.
PrlNetworkShapingConfig_SetEnabled | Allows to enable or disable the network shaping.
PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList | Update the list of network device bandwidth represents the network shaping configuration.
PrlNetworkShapingConfig_SetNetworkShapingList | Update the list of network shaping entries represents the network shaping configuration.
Links
Functions, Functions by Handle, Legend


PHT_OFFLINE_SERVICE

PHT_OFFLINE_SERVICE
Functions Functions by Handle Legend

The PHT_OFFLINE_SERVICE handle is used to configure offline services. When creating a new offline service configuration, use the PrlOffmgmtService_Create to create the handle. When managing existing offline services configurations, use the PrlSrv_GetOfflineServicesList function to obtain the list of handles.

Functions
Name | Description
PrlOffmgmtService_Create | Creates a new handle of type PHT_OFFLINE_SRVICE.
PrlOffmgmtService_GetName | Returns the name of the specified offline service.
PrlOffmgmtService_GetPort | Returns the port of the specified offline service.
PrlOffmgmtService_IsUsedByDefault | Returns the type of the flag of the specified offline service used by default.
PrlOffmgmtService_SetName | Sets the specified offline service name.
PrlOffmgmtService_SetPort | Sets the specified offline service port.
PrlOffmgmtService_SetUsedByDefault | Sets the default flag type for the specified offline service.
Links
Functions, Functions by Handle, Legend


PHT_OPAQUE_TYPE_LIST

PHT_OPAQUE_TYPE_LIST
Functions Functions by Handle Legend

The PHT_OPAQUE_TYPE_LIST handle is a container for storing type lists.

Functions
Name | Description
PrlOpTypeList_AddItem | Adds a new item to the container.
PrlOpTypeList_GetItem | Extracts the specified item from the container.
PrlOpTypeList_GetItemsCount | Determines the number of items in the container.
PrlOpTypeList_GetTypeSize | Extracts the size of type of items storing in container.
PrlOpTypeList_RemoveItem | Removes the specified item from the container.
Links
Functions, Functions by Handle, Legend


PHT_PLUGIN_INFO

PHT_PLUGIN_INFO
Functions Functions by Handle Legend

The PHT_PLUGIN_INFO handle is a container that contains information about a third-party plug-in installed in Parallels Service. To obtain the list of installed plug-ins use the PrlSrv_GetPluginsList function.

Functions
Name | Description
PrlPluginInfo_GetCopyright | Returns copyright of the plugin.
PrlPluginInfo_GetId | Returns identificator of the plugin in GUID format.
PrlPluginInfo_GetLongDescription | Returns long description about the plugin.
PrlPluginInfo_GetShortDescription | Returns short description about the plugin.
PrlPluginInfo_GetVendor | Returns the vendor of the plugin.
PrlPluginInfo_GetVersion | Returns the version of the plugin.
Links
Functions, Functions by Handle, Legend


PHT_PORT_FORWARDING

PHT_PORT_FORWARDING
Functions Functions by Handle Legend

The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP or UDP port in the host machine to the specified port in a virtual machine.

Description

Port forwarding is used when you have a virtual machine communicating with the outside world using shared networking and would like other computers to be able to access certain services running in it (e.g. HTTP server, FTP server, or any other service listening for client requests on a particular port). In order to do so, you have to tell the host machine to forward all data that it receives on a certain port to the appropriate port in the virtual machine. This is accomplished by creating a port forwarding entry using the PHT_PORT_FORWARDING handle. A port forwarding entry has the following properties:

  • The source port number in the host computer. All data that the host computer receives on this port will be forwarded to the virtual machine.
  • The destination virtual machine identified by its IP address. The address can be determined using the standard tools of the guest operating system.
  • The destination port number in the virtual machine. All data will be forwarded from the source port on the host machine to this port.

To obtain a list of the handles containing information about existing port forwarding entries, use the PrlVirtNet_GetPortForwardList function. To create a new port forwarding entry, use PrlPortFwd_Create to create a new handle. Use the functions describes in this section to define or modify the port forwarding entry properties and then use the PrlVirtNet_SetPortForwardList function to save it.

Functions
Name | Description
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_GetRedirectVm | Returns the redirect virtual machine identifier of the specified port forward entry.
PrlPortFwd_GetRuleName | Returns the rule name of the specified port forward entry.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.
PrlPortFwd_SetRedirectVm | Sets the specified port forward entry virtual machine identifier.
PrlPortFwd_SetRuleName | Sets the specified port forward entry rule name.
Links
Functions, Functions by Handle, Legend


PHT_PROBLEM_REPORT

PHT_PROBLEM_REPORT
Functions Functions by Handle Legend

The PHT_PROBLEM_REPORT handle is used to obtain and manage Parallels Problem Reports. To obtain the handle, use the PrlApi_CreateProblemReport function.

Functions
Name | Description
PrlReport_Assembly | Assembles the problem report.
PrlReport_AsString | Returns XML based string representation of problem report.
PrlReport_GetArchiveFileName | Returns problem report archive file name which can be used for further problem report data saving and processing.
PrlReport_GetCombinedReportId | Gets problem report's CombineReportId which is used to match several reports on a server side.
PrlReport_GetData | Returns the binary representation of problem report.
PrlReport_GetDescription | Obtains the problem report description.
PrlReport_GetRating | Gets rating of product using.
PrlReport_GetReason | Obtains the value of the property, identifying the reason for this project report.
PrlReport_GetScheme | Determines the scheme used by the problem report object.
PrlReport_GetType | Determines the type of the problem report object.
PrlReport_GetUserEmail | Obtains the e-mail address of the user on the problem report.
PrlReport_GetUserName | Obtains the name of the user on the problem report.
PrlReport_Send | The PrlReport_Send function is provided for convenience.
PrlReport_SetCombinedReportId | Sets problem report's CombineReportId which is used to match two reports on a server side.
PrlReport_SetDescription | Sets the specified problem report description.
PrlReport_SetRating | Sets rating of product using.
PrlReport_SetReason | Sets the value of the object property, identifying the reason for this problem report.
PrlReport_SetType | Sets the problem report object type.
PrlReport_SetUserEmail | Sets the e-mail address of the user on the problem report.
PrlReport_SetUserName | Sets the name of the user on the problem report.
Links
Functions, Functions by Handle, Legend


PHT_REMOTE_FILESYSTEM_ENTRY

PHT_REMOTE_FILESYSTEM_ENTRY
Functions Functions by Handle Legend

The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.

Functions
Name | Description
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).
Links
Functions, Functions by Handle, Legend


PHT_REMOTE_FILESYSTEM_INFO

PHT_REMOTE_FILESYSTEM_INFO
Functions Functions by Handle Legend

The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.

Description

To browse the file system on the host, first obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO using PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function. The object will contain the information about the specified file system entry and all its child entries. Use the functions provided by the PHT_REMOTE_FILESYSTEM_INFO object to obtain a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing the detailed information about the parent entry or any of its child entries. Use the functions provided by the PHT_REMOTE_FILESYSTEM_ENTRY to get the individual properties of the entry.

Functions
Name | Description
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.
Links
Functions, Functions by Handle, Legend


PHT_RESULT

PHT_RESULT
Functions Functions by Handle Legend

The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.

Description

To obtain a handle, use the PrlJob_GetResult function call after the job completes. Once you have the handle, use functions from this group to extract the results of the corresponding asynchronous operation. The PHT_RESULT object can contain a string, an array of strings, a handle, or an array of handles.

If you are expecting a single result, then, depending on the result type (a string or a handle), use the PrlResult_GetParamAsString or the PrlResult_GetParam function respectively.

If the function returns multiple results, first, use the PrlResult_GetParamsCount function to get the number of the results. Then use the PrlResult_GetParamByIndex or the PrlResult_GetParamByIndexAsString function to get individual results. The index of the array begins at 0.

For more information, please also see the Parallels Virtualization SDK Programmer's Guide.

Functions
Name | Description
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.
Links
Functions, Functions by Handle, Legend


PHT_RUNNING_TASK

PHT_RUNNING_TASK
Functions Functions by Handle Legend

The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.

Functions
Name | Description
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).
Links
Functions, Functions by Handle, Legend


PHT_SCREEN_RESOLUTION

PHT_SCREEN_RESOLUTION
Functions Functions by Handle Legend

The PHT_SCREEN_RESOLUTION handle is used to modify the list of screen resolutions available in a virtual machine. By default, only the most common resolutions are supported in a virtual machine. Using this handle, you can add additional resolutions and modify the existing ones if needed. The handle is obtained using the PrlVm_CreateScrRes or the PrlVm_GetScrRes function. The additional screen resolution support can be enabled or disabled in a virtual machine. To determine the status of the feature, use the PrlVmCfg_IsScrResEnabled function.

Functions
Name | Description
PrlScrRes_GetHeight | Returns the height of the specified screen resolution.
PrlScrRes_GetWidth | Returns width of the specified screen resolution.
PrlScrRes_IsEnabled | Determines whether the screen resolution is enabled or not.
PrlScrRes_Remove | Removes the specified screen resolution from the virtual machine.
PrlScrRes_SetEnabled | Enables or disables the specified screen resolution.
PrlScrRes_SetHeight | Modifies the specified screen resolution height.
PrlScrRes_SetWidth | Modifies the specified screen resolution width.
Links
Functions, Functions by Handle, Legend


PHT_SERVER

PHT_SERVER
Functions Functions by Handle Legend

At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.

Functions
Name
Description
PrlSrv_ActivateInstalledLicenseOffline
Offline activation of installed Parallels license.
PrlSrv_ActivateInstalledLicenseOnline
Online activation of installed Parallels license.
PrlSrv_AddIPPrivateNetwork
Adds a new private network to the Parallels Service configuration.
PrlSrv_AddVirtualNetwork
Adds a new virtual network to the Parallels Service configuration.
PrlSrv_AttachToLostTask
The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CancelInstallAppliance
Cancels the appliance installation previously started with the PrlSrv_InstallAppliance function call.
PrlSrv_CheckParallelsServerAlive
Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CheckParallelsServerAliveEx
The same functionality as previos version of call except follow things:

  • provides asynch interface;
  • using TCP connection instead of UDP.
PrlSrv_CommonPrefsBeginEdit
The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit
The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommitEx
PrlSrv_ConfigureGenericPci
Configures the PCI device assignment.
PrlSrv_CopyCtTemplate
Copy the specified Containers template to the specified server.
PrlSrv_Create
Creates a new handle of type PHT_SERVER.
PrlSrv_CreateDesktopControl
Creates Desktop Control object.
PrlSrv_CreateUnattendedCd
Creates a bootable ISO-image for unattended Linux installation.
PrlSrv_CreateVm
Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_CreateVmBackup
Backup an existing virtual machine to backup server.
PrlSrv_DeactivateInstalledLicense
Deactivate installed Parallels license.
PrlSrv_DeleteOfflineService
Removes an existing offline service configuration.
PrlSrv_DeleteVirtualNetwork
Removes an existing virtual network from the Parallels Service configuration.
PrlSrv_DisableConfirmationMode
Disable administrator confirmation mode for the session.
PrlSrv_EnableConfirmationMode
Enable administrator confirmation mode for the session.
PrlSrv_FsCanCreateFile
Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir
Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName
Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries
Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList
Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry
Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry
Renames a file system entry on the host.
PrlSrv_GetAllHostUsers
Obtains a list of handles of type PHT_EVENT containing in its parameters information about all registered host users.
PrlSrv_GetBackupTree
Get backups tree from backup server.
PrlSrv_GetCommonPrefs
Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetCtTemplateList
Retrieves a list of Containers templates registered with the specified Parallels Service.
PrlSrv_GetDefaultVmConfig
Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_GetDiskFreeSpace
Get available disk space for path.
PrlSrv_GetDisplayEncodingList
Returns currently supported display encodings both by server and client.
PrlSrv_GetIPPrivateNetworksList
Obtains a list of handles of type PHT_IPPRIV_NET containing information about all existing private networks.
PrlSrv_GetLicenseInfo
Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus
Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetNetworkClassesList
Obtains a list of handles of type PHT_HANDLES_LIST containing the list of handles of type PHT_NETWORK_CLASS.
PrlSrv_GetNetworkShapingConfig
Obtains the network shaping configuration.
PrlSrv_GetOfflineServicesList
Obtains a list of handles of type PHT_OFFLINE_SERVICE containing information about all existing services.
PrlSrv_GetPackedProblemReport
Allows to receive a packed problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetPerfStats
Obtains a handle of type PHT_EVENT containing the perfomance statistics.
PrlSrv_GetPluginsList
Gets plugin list with plugin info entries.
PrlSrv_GetProblemReport
Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions
The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetRegisteredHostsOnProxy
Do authentication on proxy server and returns list of registered hosts on this proxy.
PrlSrv_GetRestrictionInfo
Gets restriction info.
PrlSrv_GetServerInfo
Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig
Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics
Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetSupportedOses
Extracts supported guest OSes matrix from remote server (it's more proper way instead of using local synch API in case when client and server interoperate remotely).
PrlSrv_GetUserInfo
Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList
Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile
Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList
Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmConfig
Get VM config by given UUID or name.
PrlSrv_GetVmList
Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_GetVmListEx
Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_HasRestriction
Determines having restriction.
PrlSrv_InstallAppliance
Sends an appliance configuration to the Parallels Service in order to install the corresponding appliance from Parallels download service.
PrlSrv_IsConfirmationModeEnabled
Determines confirmation mode for the session
PrlSrv_IsConnected
Determines if the connection to the specified Parallels Service is active.
PrlSrv_IsFeatureSupported
Checks whether specified feature supported by remote side.
PrlSrv_IsNonInteractiveSession
Determines if the session is noninteractive or interactive.
PrlSrv_IsProxyConnection
Determines if the connection to the specified Parallels Service is a proxy connection.
PrlSrv_Login
Performs a remote login operation using the specified parameters.
PrlSrv_LoginEx
PrlSrv_LoginLocal
Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_LoginLocalEx
PrlSrv_Logoff
Logs off the Parallels Service.
PrlSrv_LookupParallelsServers
Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart
Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults
Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart
Starts the Parallels network service.
PrlSrv_NetServiceStop
Stops the Parallels network service.
PrlSrv_ProxyLogin
Performs a remote proxy login operation using the specified parameters.
PrlSrv_ProxyLoginEx
PrlSrv_RefreshPlugins
Refreshes states of installed parallels plugins.
PrlSrv_RegEventHandler
Registers an event handler.
PrlSrv_Register3rdPartyVm
Registers an existing 3rd party virtual machine with Parallels Service.
PrlSrv_RegisterVm
Registers an existing virtual machine with Parallels Service.
PrlSrv_RegisterVmEx
Registers an existing virtual machine with Parallels Service.
PrlSrv_RegisterVmWithUuid
Registers an existing virtual machine with custom Vm UUID.
PrlSrv_RemoveCtTemplate
Removes the specified Containers template.
PrlSrv_RemoveIPPrivateNetwork
Removes an existing private network from the Parallels Service configuration.
PrlSrv_RemoveVmBackup
Remove backup of the virtual machine from backup server.
PrlSrv_RestoreVmBackup
Restore backup of the virtual machine from backup server.
PrlSrv_SecureLogin
Performs a remote login operation using the specified parameters.
PrlSrv_SecureProxyLogin
Performs a remote proxy login operation using the specified parameters.
PrlSrv_SendAnswer
Sends an answer to the Parallels Service in response to a question.
PrlSrv_SendProblemReport
Requests a server to send a problem report with possibility to append also the problem report assemblied at the client's side.
PrlSrv_SetCertificateRevocationDateTime
Sets the revocation date time for SSL certificates, used in trusted channel connection.
PrlSrv_SetGlobalDateTime
Sets the current trusted time, that will be used for SSL certificate check.
PrlSrv_SetNonInteractiveSession
Sets the session in noninteractive or interactive mode.
PrlSrv_SetVNCEncryption
Set VNC encryption.
PrlSrv_Shutdown
Shuts down the Parallels Service.
PrlSrv_ShutdownEx
PrlSrv_StartSearchVms
Searches for unregistered virtual machines at the specified location(s).
PrlSrv_StopInstallAppliance
Stops the appliance installation previously started with the PrlSrv_InstallAppliance function call.
PrlSrv_SubscribeToHostStatistics
Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_SubscribeToPerfStats
Allows to subscribe to periodically receive perfomance statistics.
PrlSrv_UnregEventHandler
Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics
Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats
Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateIPPrivateNetwork
Updates parameters of an existing private network.
PrlSrv_UpdateLicense
Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateLicenseEx
PrlSrv_UpdateNetworkClassesList
Update network class classes configuration.
PrlSrv_UpdateNetworkShapingConfig
Update the network shaping configuration.
PrlSrv_UpdateOfflineService
Add/Updates parameters of an offline management service.
PrlSrv_UpdateSessionInfo
Updates parameters of opened session.
PrlSrv_UpdateVirtualNetwork
Updates parameters of an existing virtual network.
PrlSrv_UserProfileBeginEdit
Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit
Saves (commits) user profile changes to the Parallels Service.
Links
Functions, Functions by Handle, Legend


PHT_SERVER_CONFIG

PHT_SERVER_CONFIG
Functions Functions by Handle Legend

The PHT_SERVER_CONFIG handle is used to obtain the host computer configuration information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call. The handle can also be used to obtain network settings of a guest operating system installed in a virtual machine. In this case, the handle is obtained using the PrlVmGuest_GetNetworkSettings function.

Functions
Name | Description
PrlSrvCfg_Create | Creates a new handle of type PHT_SERVER_CONFIG.
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuFeatures | To get the CPU features from server hSrvConfig : A handle of type PRL_HANDLE.
PrlSrvCfg_GetCpuFeaturesEx | Allows to get the CPU features from server.
PrlSrvCfg_GetCpuFeaturesMaskingCapabilities | Allows to get the CPU features masking capabilities from server
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDefaultGateway | Obtains the global default gateway address of the specified host or guest.
PrlSrvCfg_GetDefaultGatewayIPv6 | Obtains the global default IPv6 gateway address of the specified host or guest.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers for the specified host or guest.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the hostname of the specified host or guest.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetMaxHostNetAdapters | Returns max possible Parallels network adapters on the host.
PrlSrvCfg_GetMaxVmNetAdapters | Returns max possible Parallels virtual network adapters which can be applied per VM.
PrlSrvCfg_GetNetAdapter | Obtains a handle of type PHT_HW_NET_ADAPTER containing information about a network adapter installed in the host or guest.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of printer ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains for the specified host or guest.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.
PrlSrvCfgPci_IsPrimaryDevice | Determines whether a specified PCI device (network adapter, display adapter, sound card, etc.) is the primary adapter in the system.
Links
Functions, Functions by Handle, Legend


PHT_SERVER_INFO

PHT_SERVER_INFO
Functions Functions by Handle Legend

The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.

Functions
Name | Description
PrlSrvInfo_GetApplicationMode | Returns the application mode of server.
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).
PrlSrvInfo_GetStartTime | Returns the service start time in milliseconds since Epoch (01-01-1970).
PrlSrvInfo_GetStartTimeMonotonic | Returns the service start time in milliseconds (monotonic time clock).
Links
Functions, Functions by Handle, Legend


PHT_SHARE

PHT_SHARE
Functions Functions by Handle Legend

The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.

Description

To create a new share:

  1. Call the PrlVm_BeginEdit function to mark the beginning of the operation (this is essentially a virtual machine configuration modification, so it must be done within the begin/commit block).
  2. Use the PrlVmCfg_CreateShare function to obtain the handle.
  3. Use functions provided by this object to set the desired new share properties.
  4. Call the PrlVm_Commit to finalize the changes.
  5. Enabled the host sharing feature in the virtual machine by calling the PrlVm_SetHostSharingEnabled function.

To modify an existing share, use the PrlVmCfg_GetShare function to obtain a handle containing the share information. Then repeat the steps described above.

Functions
Name | Description
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.
Links
Functions, Functions by Handle, Legend


PHT_STRINGS_LIST

PHT_STRINGS_LIST
Functions Functions by Handle Legend

The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.

Functions
Name | Description
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS

PHT_SYSTEM_STATISTICS
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.

Description

There are two main methods for obtaining a handle of type PHT_SYSTEM_STATISTICS:

  1. Using PrlSrv_GetStatistics (for host statistics) or PrlVm_GetStatistics (for virtual machine statistics).
  2. Using PrlSrv_SubscribeToHostStatistics (for host statistics) or PrlVm_SubscribeToGuestStatistics (for virtual machine statistics) to receive statistics events, and PrlSrv_UnsubscribeFromHostStatistics or PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics events. A callback function (event handler) implementation is required to use subscriptions.

The PHT_SYSTEM_STATISTICS object provides methods for obtaining handles to objects containing the performance data of a specific type. It also provides methods for obtaining memory statistics directly from it. The steps in obtaining the performance data are as follows:

  1. Obtain a handle of type PHT_SYSTEM_STATISTICS.
  2. To obtain memory statistics, use the functions provided by the object.
  3. For other statistics (CPU, disk, network, etc.), first use a corresponding function to obtain a handle of a particular type, and then use the functions of the received object to get the statistics.
Functions
Name | Description
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns the total virtual machine usage time in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetRealRamSize | Returns the amount of physical memory, in bytes, currently occupied by the virtual machine.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.
PrlStat_GetVmDataStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_VM_DATA containing the specified system VM data statistic.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_CPU

PHT_SYSTEM_STATISTICS_CPU
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.

Functions
Name | Description
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_DISK

PHT_SYSTEM_STATISTICS_DISK
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.

Functions
Name | Description
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_DISK_PARTITION

PHT_SYSTEM_STATISTICS_DISK_PARTITION
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.

Functions
Name | Description
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_IFACE

PHT_SYSTEM_STATISTICS_IFACE
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.

Functions
Name | Description
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_PROCESS

PHT_SYSTEM_STATISTICS_PROCESS
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.

Functions
Name | Description
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_USER_SESSION

PHT_SYSTEM_STATISTICS_USER_SESSION
Functions Functions by Handle Legend

The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.

Functions
Name | Description
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.
Links
Functions, Functions by Handle, Legend


PHT_UIEMU_INPUT

PHT_UIEMU_INPUT
Functions Functions by Handle Legend
Functions
Name | Description
PrlUIEmuInput_AddText | Add text to input object.
PrlUIEmuInput_AddVKeys | Add virtual keys to input object.
PrlUIEmuInput_Create | Creates input object.
Links
Functions, Functions by Handle, Legend


PHT_USB_IDENTITY

PHT_USB_IDENTITY
Functions Functions by Handle Legend
Functions
Name | Description
PrlUsbIdent_GetFriendlyName | Returns user friendly name of USB device.
PrlUsbIdent_GetSystemName | Returns system name for USB device.
PrlUsbIdent_GetVmUuidAssociation | Returns Uuid of Vm associated with USB device or empty string if no association is specified.
Links
Functions, Functions by Handle, Legend


PHT_USER_INFO

PHT_USER_INFO
Functions Functions by Handle Legend

The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.

Functions
Name | Description
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).
Links
Functions, Functions by Handle, Legend


PHT_USER_PROFILE

PHT_USER_PROFILE
Functions Functions by Handle Legend

The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.

Description

All modifications to the user profile must begin with the PrlSrv_UserProfileBeginEdit function call and end with the PrlSrv_UserProfileCommit call. The functions are used to detect collisions with other clients trying to modify the profile of the same user at the same time. The functions do not lock the profile being edited. If a collision is detected on commit, the changes are rejected.

Functions
Name | Description
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_IsLocalAdministrator | Determines if the user is a local administrator account on the host where Parallels Service started.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_DEV_FLOPPY

PHT_VIRTUAL_DEV_FLOPPY
Functions by Handle See Also

The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_HARD_DISK

PHT_VIRTUAL_DEV_HARD_DISK
Functions Functions by Handle Legend See Also

The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.

Functions
Name | Description
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_CheckPassword | Checks whether specified for encrypted virtual hard disk password matched to the current one.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetMountPoint | Returns the mount point of the specified virtual hard disk.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_GetStorageURL | Return custom storage URL.
PrlVmDevHd_IsAutoCompressEnabled | Returns the auto compress flag of the specified virtual hard disk.
PrlVmDevHd_IsEncrypted | Returns sign whether virtual hard disk device is encrypted.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetAutoCompressEnabled | Sets the auto compress sign flag of the specified virtual hard disk.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetMountPoint | Sets the mount point of the specified virtual hard disk.
PrlVmDevHd_SetPassword | Lets to setup password for virtual hard disk device in case if last one is encrypted (this password uses then at calls PrlVmDevHd_CheckPassword and PrlVm_Commit)
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.
PrlVmDevHd_SetStorageURL | Set custom storage URL.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_HD_PARTITION

PHT_VIRTUAL_DEV_HD_PARTITION
Functions Functions by Handle Legend

The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.

Functions
Name | Description
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_DEV_NET_ADAPTER

PHT_VIRTUAL_DEV_NET_ADAPTER
Functions Functions by Handle Legend See Also

The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.

Functions
Name | Description
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetAdapterType | Obtain the adapter type assigned to a virtual network adapter.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDefaultGatewayIPv6 | Obtains the default gateway (IPv6) assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetFirewallDefaultPolicy | Gets an adapter firewall default policy.
PrlVmDevNet_GetFirewallRuleList | Returns the firewall rule entries list.
PrlVmDevNet_GetHostInterfaceName | Obtains the custom host adapter name.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine (in Parallels format XXXXXXXXXXXX).
PrlVmDevNet_GetMacAddressCanonical | Returns the MAC address of a virtual network adapter inside a virtual machine (in human-friendly format xx:xx:xx:xx:xx:xx).
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetVirtualNetworkId | Obtains the virtual network ID assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_IsAutoApply | Determines if the specified network adapter is configured to automatically apply network settings inside guest.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_IsConfigureWithDhcpIPv6 | Determines if the specified network adapter is configured through DHCP (IPv6) on the guest OS side.
PrlVmDevNet_IsFirewallEnabled | Gets state switched on or off of the adapter firewall.
PrlVmDevNet_IsPktFilterPreventIpSpoof | Determines if the specified network adapter is configured to filter net packages and send packages only from IP addresses in the adapter NetAdrresses list.
PrlVmDevNet_IsPktFilterPreventMacSpoof | Determines if the specified network adapter is configured to filter net packages and send packages only from its own MAC address.
PrlVmDevNet_SetAdapterType | Allows to manually assign adapter type to a network adapter.
PrlVmDevNet_SetAutoApply | Allows to specify whether a network adapter in a virtual machine should be automatically configured.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetConfigureWithDhcpIPv6 | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP (IPv6) or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDefaultGatewayIPv6 | Allows to manually set the default gateway address (IPv6) for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetFirewallDefaultPolicy | Sets an adapter firewall default policy.
PrlVmDevNet_SetFirewallEnabled | Sets state switched on or off of the adapter firewall.
PrlVmDevNet_SetFirewallRuleList | Sets the firewall rule entries list.
PrlVmDevNet_SetHostInterfaceName | Sets the custom host adapter name in a bridged networking mode, (autogenerated if not set) hVmDev : A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetPktFilterPreventIpSpoof | Allows to specify whether a network adapter in a virtual machine should perform the filtration by IP addresses.
PrlVmDevNet_SetPktFilterPreventMacSpoof | Allows to specify whether a network adapter in a virtual machine should filter packets through MAC address spoofing.
PrlVmDevNet_SetPktFilterPreventPromisc | Allows to specify whether a network adapter in a virtual machine should receive packets sent not to VM.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.
PrlVmDevNet_SetVirtualNetworkId | Allows to set the virtual network ID for a network adapter in a virtual machine.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_OPTICAL_DISK

PHT_VIRTUAL_DEV_OPTICAL_DISK
Functions by Handle See Also

The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_PARALLEL_PORT

PHT_VIRTUAL_DEV_PARALLEL_PORT
Functions by Handle See Also

The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_SERIAL_PORT

PHT_VIRTUAL_DEV_SERIAL_PORT
Functions Functions by Handle Legend See Also

The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.

Description

The following describes how to create new or modify an existing serial port on a virtual machine.

First, you have to set the emulation type using the PrlVmDev_SetEmulatedType function. The available types are:

  • PDT_USE_REAL_DEVICE - real port.
  • PDT_USE_OUTPUT_FILE - output file.
  • PDT_USE_OTHER - socket.

Second, you must call the PrlVmDev_SetSysName and the PrlVmDev_SetFriendlyName functions. These functions are used differently depending on the emulation type that you chose in the first step.

Real port

  1. Choose a real port and pass its ID to the PrlVmDev_SetSysName function.
  2. Pass the physical port name to the PrlVmDev_SetFriendlyName function.

Output file

  1. Choose an output file name and path, then pass it to both functions as a parameter.

Socket

  1. Choose a socket name and path, then pass it to both functions as a parameter.
  2. Call the PrlVmDevSerial_SetSocketMode function to set the socket mode.
Functions
Name | Description
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_SOUND

PHT_VIRTUAL_DEV_SOUND
Functions Functions by Handle Legend See Also

The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.

Functions
Name | Description
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_USB_DEVICE

PHT_VIRTUAL_DEV_USB_DEVICE
Functions Functions by Handle Legend See Also

The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.

Functions
Name | Description
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DISK

PHT_VIRTUAL_DISK
Functions Functions by Handle Legend

The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files including a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and the files that are used for data storage. Once created, a virtual disk can be connected to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk or PrlDisk_OpenDisk_Local. You must always free the handle using the PrlDisk_Free function when the handle is no longer needed. Failure to do so will result in memory leak.

Notes

The functionality provided by this handle offers more low-level control over new and existing virtual disks. You can use it to create standalone new disks and then decide on the virtual machine to which the disk should be connected. You can also manage existing disks, including those used by virtual machines. If, however, all you want to do is create a virtual machine and a virtual disk at the same time, or add a virtual disk to a virtual machine in a few easy steps, you can use the functionality provided by the PHT_VIRTUAL_MACHINE and PHT_VM_CONFIGURATION handles. You can also consult Virtualization SDK Programmer's Guide for a detailed explanation and code samples on how to create a new virtual machine and how to add a virtual disk to an existing virtual machine.

Functions
Name | Description
PrlDisk_ChangeKey | This function used to change the key of the encrypted disk
PrlDisk_Coagulate | Combines all available disk snapshots into a single entity.
PrlDisk_CommitUnfinishedOp | Commits unfinished state operation (interrupted).
PrlDisk_Compact | This method is deprecated now.
PrlDisk_CompactByBitmap | Compacts a virtual disk with free blocks map.
PrlDisk_ConvertToCHS | This function used to convert disk size in blocks to the Cylinders-Heads-Sectors (CHS) format, used at disk creation
PrlDisk_ConvertToCurrent | Converts virtual disks that were created with an older version of Parallels Service to the current version.
PrlDisk_ConvertToCurrent_Local | Converts virtual disks that were created with an older version of Parallels Service to the current version.
PrlDisk_ConvertToExtendFormat | Convert all Expanding images to Extend_Expanding
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Takes a snapshot of the specified virtual disk.
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_Decrypt | This function used to encrypt whole disk
PrlDisk_DeleteState | Deletes the specified virtual disk snapshot.
PrlDisk_Encrypt | This function used to encrypt whole disk
PrlDisk_FixConsistency | Checks and fixes consistency of a virtual disk.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | Frees the PHT_VIRTUAL_DISK handle.
PrlDisk_GetDefaultBlockSize | This function used to get default block size of disk
PrlDisk_GetDiskInfo | Obtains the information about the specified virtual disk.
PrlDisk_GetIdentify | This function used to get HDD identify information as it shown in guest OS
PrlDisk_GetSnapshotsCount | Determines the number of snapshots of the specified virtual disk.
PrlDisk_GetSnapshotsTree | Obtains the entire snapshot tree for the specified virtual disk.
PrlDisk_GetSplitPartSize | This function used to get splitted disk part size
PrlDisk_GetUserParameter | Retrieves user-defined parameter values stored on a virtual disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsBootable_Local | This function used to check is the disk bootable or not
PrlDisk_IsCompactable | Determines if the specified virtual disk can be compacted.
PrlDisk_IsEncrypted | This function used to check is the disk encrypted or not
PrlDisk_LinkedClone_Local | This function used to create a linked clone disk
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk on a local machine.
PrlDisk_Read | Reads data from the specified virtual disk.
PrlDisk_SetCachingPolicy | Set the caching policy for a virtual disk.
PrlDisk_SetKey | This function used to set the key to the encrypted disk
PrlDisk_SetSharedDirectory | Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.
PrlDisk_SetSharedDirectory_Local | Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.
PrlDisk_SetUserParameter | Stores user-defined parameter values on a virtual disk.
PrlDisk_SwitchToState | Reverts a virtual disk to the specified snapshot.
PrlDisk_WaitForCompletion | Waits for the background thread to finish executing before returning control to the client.
PrlDisk_Write | Writes data to the specified virtual disk.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_MACHINE

PHT_VIRTUAL_MACHINE
Functions Functions by Handle Legend

PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.

Functions
Name | Description
PrlVm_Authorise | Authorises current session against encrypted virtual machine.
PrlVm_AuthWithGuestSecurityDb | Performs an attempt to authenticate the user through the guest OS security database.
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompact | Finishes process of optimization of virtual hard disk.
PrlVm_CancelConvertDisks | Finishes process of conversion of the virtual hard disk(s).
PrlVm_ChangePassword | Changes current password of encrypted virtual machine on new one.
PrlVm_ChangeSid | Generates and assigns a new Windows SID to the specified virtual machine running Windows guest OS.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_CloneEx | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CommitEx | The PrlVm_CommitEx function is the same as PrlVm_Commit function but with the flags
PrlVm_Compact | Start process of optimization of virtual hard disk.
PrlVm_Connect | Connect to remote desktop.
PrlVm_ConvertDisks | Start process conversion of the virtual hard disk(s).
PrlVm_CreateCVSrc | Creates video source object.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateP2PTransport | Create handle of type PHT_VIDEO_RECEIVER.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedDisk | Creates a disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Decrypt | Decrypts earlier encrypted with some secret password phrase virtual machine.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_Disconnect | Disconnect from remote desktop.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_Encrypt | Encrypts virtual machine data using specified secret password phrase.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetPackedProblemReport | The PrlVm_GetPackedProblemReport function obtains a Packed problem report on abnormal virtual machine termination.
PrlVm_GetPerfStats | Obtains a handle of type PHT_EVENT containing the virtual machine performance statistics.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetSnapshotsTreeEx |
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetStatisticsEx | The PrlVm_GetStatisticsEx function is the same as PrlVm_GetStatistics function but with the flags
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LinkedClone | Clones an existing virtual machine based on given snapshot.
PrlVm_Lock | Lets to exclusively lock VM for current session.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_MigrateWithRename | Migrates an existing virtual machine to another host.
PrlVm_MigrateWithRenameEx | Migrates an existing virtual machine to another host.
PrlVm_Mount | Mount the specified virtual machine Virtual Disks.
PrlVm_Move | Move bundle of virtual machine or private area of container.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_PtmExec | Executes an remote procedure.
PrlVm_PtmQuery | Query object properties .
PrlVm_PtmSet | Set object properties .
PrlVm_PtmSubscribe | Subscribe on object properties changes.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | See also PrlVm_RegEx
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_RegEx | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RemoveProtection | Removes protection from virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_ResetUptime | Resets the virtual machine uptime counter (start date and counter itself).
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_SendClipboardRequest | @brief Requests clipboard buffer from Vm @note This call is intended to be asynchronious with possibility to be synchroneous.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_SetProtection | Protects virtual machine using specified secret password phrase.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopEx | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_SubscribeToPerfStats | Allows to subscribe to periodicaly receive virtual machine perfomance statistics.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_SwitchToSnapshotEx | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_TisSubscribe | Subscribe on TIS database updates.
PrlVm_TisUnsubscribe | Unsubscribe from TIS database updates.
PrlVm_ToolsGetShutdownCapabilities | Obtains the available capabilities of a graceful virtual machine shutdown using Parallels Tools.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_ToolsSetTaskBarVisibility | brief Show/Hide task bar in guest.
PrlVm_UIEmuQueryCaretInfo | Posts "get caret info" query to guest User Input Emulation tool.
PrlVm_UIEmuQueryElementAtPos | Posts "get info on element at specified position" query to guest User Input Emulation tool.
PrlVm_UIEmuQueryNearestElementAtPos | Posts "get info on nearest element at specified position" query to guest User Input Emulation tool.
PrlVm_UIEmuSendClick | Send mouse click event to User Input Emulation.
PrlVm_UIEmuSendGestureEvent | Sends a gesture event to guest User Input Emulation tool.
PrlVm_UIEmuSendInput | Send input to guest.
PrlVm_UIEmuSendMultimediaKey | Sends a multimedia key to guest User Input Emulation tool.
PrlVm_UIEmuSendScroll | Send scroll event to User Input Emulation.
PrlVm_UIEmuSendText | Send specified UTF8 text to guest User Input Emulation tool.
PrlVm_Umount | Unmount the specified virtual machine Virtual Disks.
PrlVm_Unlock | Lets to unlock previously locked with PrlVm_Lock call VM.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.
Links
Functions, Functions by Handle, Legend


PrlVm_MigrateWithRenameEx Function

PrlVm_MigrateWithRenameEx Function
PHT_VIRTUAL_MACHINE

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_MigrateWithRenameEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR target_host,
    PRL_UINT32 target_port,
    PRL_CONST_STR target_session_id,
    PRL_CONST_STR target_name,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
target_host
The name of the target host machine.
target_port
The port number on the target host.
target_session_id
The target Parallels Service session ID. This ID can be retrieved with PrlLoginResponse_GetSessionUuid from the response of the login request.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVMT_COLD_MIGRATION, PVMT_WARM_MIGRATION, PVMT_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This is an extended version of PrlVm_MigrateWithRename function that allows to initiate VM migration process without active connection to target Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PHT_VIRTUAL_NETWORK

PHT_VIRTUAL_NETWORK
Functions Functions by Handle Legend

The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.

Functions
Name | Description
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundAdapterInfo | Obtains physical adapter info which bound to the virtual network object.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIP6Address | Returns the DCHP IPv6 address of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIP6Address | Returns the host IPv6 address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIP6NetMask | Returns the IPv6 net mask of the specified virtual network.
PrlVirtNet_GetIP6ScopeEnd | Returns the DHCP end IPv6 address of the specified virtual network.
PrlVirtNet_GetIP6ScopeStart | Returns the DHCP start IPv6 address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_GetVlanTag | Returns the VLAN tag of the specified virtual network.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCP6ServerEnabled | Determines whether the specified virtual network DHCPv6 server is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDHCP6ServerEnabled | Allows to enable or disable a specified virtual network DHCPv6 server.
PrlVirtNet_SetDhcpIP6Address | Sets the specified virtual network DHCP IPv6 address.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIP6Address | Sets the specified virtual network host IPv6 address.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIP6NetMask | Sets the specified virtual network IPv6 net mask.
PrlVirtNet_SetIP6ScopeEnd | Sets the specified virtual network DHCP end IPv6 address.
PrlVirtNet_SetIP6ScopeStart | Sets the specified virtual network DHCP start IPv6 address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.
PrlVirtNet_SetVlanTag | Sets the VLAN tag for the specified virtual network.
Links
Functions, Functions by Handle, Legend


PHT_VM_CONFIGURATION

PHT_VM_CONFIGURATION
Functions Functions by Handle Legend

The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.

Functions
Name
Description
PrlVmCfg_AddDefaultDevice
The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_AddDefaultDeviceEx
The PrlVmCfg_AddDefaultDeviceEx function automates the task of setting devices in a virtual machine.
PrlVmCfg_ApplyConfigSample
Specify the Configuration sample file
PrlVmCfg_CreateBootDev
Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes
Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare
Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev
Creates a new virtual device handle of the specified type.
PrlVmCfg_Get3DAccelerationMode
Gets 3D graphical acceleration technology mode for the specified virtual machine.
PrlVmCfg_GetAccessRights
Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetActionOnStopMode
Gets action on stop mode.
PrlVmCfg_GetActionOnWindowClose
Determines the action on Parallels Application window close for the specified virtual machine.
PrlVmCfg_GetAllDevices
Obtains a handles list of all virtual devices in a virtual machine.
PrlVmCfg_GetAppInDockMode
Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAppTemplateList
Returns the list of application templates installed for the specified Container.
PrlVmCfg_GetAssetId
Returns the specified virtual machine asset id.
PrlVmCfg_GetAutoCompressInterval
Determines the interval at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_GetAutoStart
Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay
Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop
Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority
Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev
Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount
Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetCapabilitiesMask
Returns a capabilities mask specified inside the CT.
PrlVmCfg_GetCoherenceButtonVisibility
Determines if a "Coherence Button" for the specified virtual machine should be shown when a user points to a Windows Start button
PrlVmCfg_GetConfigValidity
The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetConfirmationsList
Obtains a handles list of operations with virtual machine which required administrator confirmation
PrlVmCfg_GetCpuAccelLevel
Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount
Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuLimit
Determines the CPU usage limit of a virtual machine, in percent.
PrlVmCfg_GetCpuLimitEx
Determines the specified virtual machine CPU limit.
PrlVmCfg_GetCpuMask
Returns the specified virtual machine CPU affinity mask
PrlVmCfg_GetCpuMode
Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits
Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty
Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize
The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize
The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDefaultVideoRamSize
The PrlVmCfg_GetDefaultVideoRamSize function returns the default video RAM size for the specified OS type and version.
PrlVmCfg_GetDescription
Returns the specified virtual machine description.
PrlVmCfg_GetDevByType
Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount
Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType
Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDisplayDev
Obtains a handle of type PHT_VIRTUAL_DEV_DISPLAY containing information about a display device in a virtual machine.
PrlVmCfg_GetDisplayDevsCount
Determines the number of display devices in a virtual machine.
PrlVmCfg_GetDnsServers
Obtains the list of of globally defined DNS servers which is assigned to a Virtuozzo Container.
PrlVmCfg_GetDockIconType
Returns the virtual machine dock icon type.
PrlVmCfg_GetEnvId
Returns the Container id of the specified virtual machine.
PrlVmCfg_GetExpirationDate
Gets expiration date.
PrlVmCfg_GetExpirationNote
Gets expiration note.
PrlVmCfg_GetExpirationOfflineTimeToLive
Gets the offline time of working with virtual machine.
PrlVmCfg_GetExpirationTimeCheckInterval
Gets the time interval to check on expiration date.
PrlVmCfg_GetExpirationTrustedTimeServer
Gets trusted time server.
PrlVmCfg_GetExternalBootDevice
Returns an external boot device system name.
PrlVmCfg_GetFeaturesMask
Returns a features mask specified inside the CT.
PrlVmCfg_GetFloppyDisk
Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount
Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority
Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetFreeDiskSpaceRatio
Determines the free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_GetGenericPciDev
Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount
Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev
Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount
Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk
Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount
Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHighAvailabilityPriority
Determines the priority of the virtual machine in the High Availability Cluster.
PrlVmCfg_GetHomePath
Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostMemQuotaMax
Returns the maximal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.
PrlVmCfg_GetHostMemQuotaMin
Returns the minimal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.
PrlVmCfg_GetHostMemQuotaPriority
Returns the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.
PrlVmCfg_GetHostname
Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon
Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetIoLimit
Determines the specified virtual machine I/O limit.
PrlVmCfg_GetIoPriority
Determines the specified virtual machine I/O priority.
PrlVmCfg_GetIopsLimit
Determines the specified virtual machine IOPS limit.
PrlVmCfg_GetLastModifiedDate
Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName
Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetLinkedVmUuid
Returns the UUID (universally unique ID) of the parent virtual machine which was used to create current linked cloned virtual machine (if last one is linked clone of some virtual machine - this value will be empty otherwise).
PrlVmCfg_GetLocation
Returns the virtual machine files location type.
PrlVmCfg_GetMaxBalloonSize
Returns the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.
PrlVmCfg_GetName
Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter
Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount
Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetNetfilterMode
Returns netfilter mode specified inside the CT.
PrlVmCfg_GetNetworkRateList
Obtains the list of shaping rated
PrlVmCfg_GetOfflineServices
Obtains the list of services available in the virtual machine offline management.
PrlVmCfg_GetOpticalDisk
Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount
Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOptimizeModifiersMode
Gets optimize modifiers mode.
PrlVmCfg_GetOsTemplate
Returns Operation System template name the Parallels Virtuozzo Container were created on.
PrlVmCfg_GetOsType
Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion
Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort
Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual printer port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount
Determines the number of virtual printer ports in the specified virtual machine.
PrlVmCfg_GetProfile
Get current VM profile.
PrlVmCfg_GetRamSize
Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetResource
Returns beancounters barrier and limit for specified resource id.
PrlVmCfg_GetScrRes
Obtains a handle of type PHT_SCREEN_RESOLUTION identifying the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount
Determines the total number of screen resolutions available in a virtual machine.
PrlVmCfg_GetSearchDomains
Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort
Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount
Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost
Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid
Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare
Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount
Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSmartGuardInterval
Determines the interval at which snapshots are taken by SmartGuard.
PrlVmCfg_GetSmartGuardMaxSnapshotsCount
Determines the maximum snapshot count, a SmartGuard setting.
PrlVmCfg_GetSoundDev
Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount
Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode
Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin
Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags
Returns the virtual machine system flags.
PrlVmCfg_GetTimeSyncInterval
Obtains the time synchronization interval between the host and a guest OS.
PrlVmCfg_GetUnattendedInstallEdition
Returns edition for unattended installation.
PrlVmCfg_GetUnattendedInstallLocale
Returns locale for unattended installation.
PrlVmCfg_GetUndoDisksMode
Determines the current undo-disks mode for the specified virtual machine.
PrlVmCfg_GetUptime
Returns the virtual machine uptime in seconds since some datetime (see PrlVmCfg_GetUptimeStartDate).
PrlVmCfg_GetUptimeStartDate
Returns the date and time when uptime counter calculation was started for the specified virtual machine.
PrlVmCfg_GetUsbDevice
Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount
Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid
Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize
Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVmInfo
Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVmCfg_GetVmType
Get the Virtual Machine type.
PrlVmCfg_GetVNCHostName
Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode
Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword
Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort
Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode
Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsAdaptiveHypervisorEnabled
Determines disable or enable adaptive hypervisor.
PrlVmCfg_IsAllowSelectBootDevice
Determines whether select boot device should be shown on virtual machine startup.
PrlVmCfg_IsAutoApplyIpOnly
Determines if the Guest configured to automatically apply IP addrs network settings inside guest.
PrlVmCfg_IsAutoCaptureReleaseMouse
Determines whether the automatic capture and release of the mouse pointer is enabled or not.
PrlVmCfg_IsAutoCompressEnabled
Determines whether the Automatic HDD compress feature is enabled or not in a virtual machine.
PrlVmCfg_IsBatteryStatusEnabled
Determines disable or enable battery status.
PrlVmCfg_IsCloseAppOnShutdown
Determines whether the Parallels application (such as Parallels Desktop) will be automatically closed on the virtual machine shutdown.
PrlVmCfg_IsConfigInvalid
The PrlVmCfg_IsConfigInvalid function is used to check the

  • error code of PrlVmCfg_GetConfigValidity function that
  • indicates the invalid status of the config:
  • config doesn't exist, parsing error, invalid server uuid,
  • invalid VM uuid.
  • Parameters
  • nErrCode : The nErrCode value from PrlVmCfg_GetConfigValidity()
  • pbInvalid : [out] validity sign.
PrlVmCfg_IsCpuHotplugEnabled
Determines whether the CPU hotplug is available in the virtual machine.
PrlVmCfg_IsCpuVtxEnabled
Determines whether the x86 virtualization (such as Vt-x) is available in the virtual machine CPU.
PrlVmCfg_IsCustomProfile
Determines were settings modified after profile was applied or not.
PrlVmCfg_IsDefaultDeviceNeeded
Determines whether the virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC
Determines whether the APIC is enabled or disabled during the virtual machine runtime.
PrlVmCfg_IsDisableSpeaker
Determines whether the speaker is enabled or disabled during the virtual machine runtime.
PrlVmCfg_IsDiskCacheWriteBack
Determines if disk cache write-back is enabled in the specified virtual machine.
PrlVmCfg_IsEfiEnabled
Determines whether EFI boot is switched on.
PrlVmCfg_IsEncrypted
Determines whether the virtual machine is in encrypted state
PrlVmCfg_IsExcludeDock
Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsExpirationDateEnabled
Gets expiration date status.
PrlVmCfg_IsGuestSharingAutoMount
Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled
Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight
Determines if the virtual disks in a virtual machine will be added to Spotlight search subsystem (OS X feature).
PrlVmCfg_IsHideMinimizedWindowsEnabled
Determines disable or enable hiding minimized windows.
PrlVmCfg_IsHighAvailabilityEnabled
Determines whether the High Availability feature is enabled or not for a virtual machine.
PrlVmCfg_IsHighResolutionEnabled
Determines disable or enable high resolution video mode for the specified virtual machine.
PrlVmCfg_IsHostMemAutoQuota
Determines whether the automatic calculation of the host's memory (RAM) consumption parameters enabled for the virtual machine.
PrlVmCfg_IsHostSharingEnabled
Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsIsolatedVmEnabled
Determines disable or enable isolated VM.
PrlVmCfg_IsLockGuestOnSuspendEnabled
Determines disable or enable lock guest on suspend.
PrlVmCfg_IsLockInFullScreenMode
Determines whether the lock in screen mode sign is set or not in a virtual machine configuration.
PrlVmCfg_IsLongerBatteryLifeEnabled
Determines disable or enable longer battery life.
PrlVmCfg_IsMapSharedFoldersOnLetters
Determines whether host disks shared with the guest Windows OS will be mapped to drive letters.
PrlVmCfg_IsMultiDisplay
Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsNestedVirtualizationEnabled
Determines disable or enable nested virtualization.
PrlVmCfg_IsOfflineManagementEnabled
Determines whether the offline management feature is enabled for a virtual machine.
PrlVmCfg_IsOsResInFullScrMode
Determines wether the virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsPauseWhenIdle
Determines if the VM pauses automatically when it becomes idle (i.e.
PrlVmCfg_IsPMUVirtualizationEnabled
Determines disable or enable PMU virtualization.
PrlVmCfg_IsProtected
Determines whether the virtual machine is in protected state
PrlVmCfg_IsRamHotplugEnabled
Determines whether the memory (RAM) hotplug is available in the virtual machine.
PrlVmCfg_IsRateBound
Determines whether the ratebound is enabled or not.
PrlVmCfg_IsRelocateTaskBar
Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled
Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks
Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsShareClipboard
Determines whether the clipboard sharing feature is enabled or disabled in a virtual machine.
PrlVmCfg_IsSharedAppsGuestToHost
Determines whether the guest applications shared to host or not.
PrlVmCfg_IsSharedAppsHostToGuest
Determines whether the host applications shared to guest or not.
PrlVmCfg_IsSharedBluetoothEnabled
Determines disable or enable bluetooth camera.
PrlVmCfg_IsSharedCameraEnabled
Determines disable or enable shared camera.
PrlVmCfg_IsSharedCloudEnabled
Determines whether shared cloud is enabled or disabled.
PrlVmCfg_IsSharedProfileEnabled
Determines whether the Shared Profile feature is enabled in a virtual machine.
PrlVmCfg_IsShareUserHomeDir
Determines whether the host user home directory will be available in the guest OS as a share.
PrlVmCfg_IsShowTaskBar
Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsShowWindowsAppInDock
Determines whether the "Show Windows Applications folder in Dock" feature is enabled or not.
PrlVmCfg_IsSmartGuardEnabled
Determines whether the SmartGuard feature is enabled or not in a virtual machine.
PrlVmCfg_IsSmartGuardNotifyBeforeCreation
Determines whether the user will be notified on automatic snapshot creation, a SmartGaurd setting.
PrlVmCfg_IsSmartMountDVDsEnabled
Determines whether the SmartMount CD/DVD drives is enabled or not.
PrlVmCfg_IsSmartMountEnabled
Determines whether the SmartMount feature is enabled or not.
PrlVmCfg_IsSmartMountNetworkSharesEnabled
Determines whether the SmartMount network shares is enabled or not.
PrlVmCfg_IsSmartMountRemovableDrivesEnabled
Determines whether the SmartMount removable drives is enabled or not.
PrlVmCfg_IsSmartMouseEnabled
Determines disable or enable smart mouse.
PrlVmCfg_IsStartInDetachedWindowEnabled
Determines disable or enable start in detached window.
PrlVmCfg_IsStickyMouseEnabled
Determines disable or enable sticky mouse.
PrlVmCfg_IsSupportUsb30Enabled
Gets support status USB 3.0.
PrlVmCfg_IsSwitchOffAeroEnabled
Determines disable or enable switching off aero.
PrlVmCfg_IsSwitchOffWindowsLogoEnabled
Determines disable or enable Windows logo.
PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled
Determines disable or enable switching to full screen on demand.
PrlVmCfg_IsSyncDefaultPrinter
Gets synchronization default printer option.
PrlVmCfg_IsTemplate
Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsTimeSynchronizationEnabled
Determines whether the time synchronization feature is enabled in a virtual machine.
PrlVmCfg_IsTimeSyncSmartModeEnabled
Determines whether the smart time synchronization is enabled in a virtual machine.
PrlVmCfg_IsToolsAutoUpdateEnabled
Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.
PrlVmCfg_IsUseDefaultAnswers
Determines whether the use default answers mechanism active for the virtual machine.
PrlVmCfg_IsUseDesktop
Determines whether the "use desktop in shared profile" feature is enabled or not.
PrlVmCfg_IsUseDocuments
Determines whether "use documents in shared profile" feature is enabled or not.
PrlVmCfg_IsUseDownloads
Determines whether the "used downloads in shared profile" feature is enabled or not.
PrlVmCfg_IsUseHostPrinters
Gets use host printers option.
PrlVmCfg_IsUseMovies
Determines whether the "used movies in shared profile" feature is enabled or not.
PrlVmCfg_IsUseMusic
Determines whether the "use music in shared profile" feature is enabled or not.
PrlVmCfg_IsUsePictures
Determines whether the "used pictures in shared profile" feature is enabled or not.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled
Determines whether the user-defined shared folders are enabled or not.
PrlVmCfg_IsVerticalSynchronizationEnabled
Determines disable or enable vertical synchronization video mode for the specified virtual machine.
PrlVmCfg_IsVirtualLinksEnabled
Determines whether the Virtual Links feature is enabled in a virtual machine.
PrlVmCfg_IsWinSystrayInMacMenuEnabled
Determines disable or enable Windows systray in Mac menu.
PrlVmCfg_Set3DAccelerationMode
Sets 3D graphical acceleration technology mode for the specified virtual machine.
PrlVmCfg_SetActionOnStopMode
Sets action on stop mode.
PrlVmCfg_SetActionOnWindowClose
Allows to set the action on Parallels Application window close for the specified virtual machine.
PrlVmCfg_SetAdaptiveHypervisorEnabled
Disables or enables adaptive hypervisor.
PrlVmCfg_SetAllowSelectBootDevice
Switches on/off select boot device dialog on virtual machine startup.
PrlVmCfg_SetAppInDockMode
Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAppTemplateList
Specify application templates list which will be used in the specified Parallels Virtuozzo Container.
PrlVmCfg_SetAssetId
Sets the virtual machine asset id.
PrlVmCfg_SetAutoApplyIpOnly
Allows to specify whether a virtual machine should be automatically configured for IP addrs.
PrlVmCfg_SetAutoCaptureReleaseMouse
Enables or disables the automatic capture and release of the mouse pointer in a virtual machine.
PrlVmCfg_SetAutoCompressEnabled
Enables the Automatic HDD compress feature in a virtual machine.
PrlVmCfg_SetAutoCompressInterval
Sets the time interval at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_SetAutoStart
Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay
Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop
Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority
Sets the virtual machine background processes priority.
PrlVmCfg_SetBatteryStatusEnabled
Disables or enables battery status.
PrlVmCfg_SetCapabilitiesMask
Sets a capabilities inside the CT.
PrlVmCfg_SetCloseAppOnShutdown
Allows to specify whether the Parallels application (such Parallels Desktop) will be closed on the virtual machine shutdown.
PrlVmCfg_SetCoherenceButtonVisibility
Sets the virtual machine "Coherence Button visibility" option.
PrlVmCfg_SetConfirmationsList
Determines a list of operations with virtual machine which required administrator confirmation
PrlVmCfg_SetCpuAccelLevel
Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount
Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuHotplugEnabled
Sets CPU hotplug mode (enabled or disabled) for the specified virtual machine.
PrlVmCfg_SetCpuLimit
Sets the CPU usage limit (in percent) for a virtual machine.
PrlVmCfg_SetCpuLimitEx
Sets limit of CPU usage for the virtual machine in Mhz.
PrlVmCfg_SetCpuMask
Sets the CPU affinity for a virtual machine.
PrlVmCfg_SetCpuMode
Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits
Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty
Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig
The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription
Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign
Allows to specify whether the virtual machine should be using APIC during runtime.
PrlVmCfg_SetDisableSpeakerSign
Allows to specify whether the virtual machine should be using speaker during runtime.
PrlVmCfg_SetDiskCacheWriteBack
Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers
Allows to manually assign DNS servers a virtual machine.
PrlVmCfg_SetDockIconType
Sets the virtual machine dock icon type.
PrlVmCfg_SetEfiEnabled
Sets EFI boot for the virtual machine.
PrlVmCfg_SetExcludeDock
Sets the exclude dock option.
PrlVmCfg_SetExpirationDate
Sets expiration date.
PrlVmCfg_SetExpirationDateEnabled
Sets expiration date enabled/disabled.
PrlVmCfg_SetExpirationNote
Sets expiration note.
PrlVmCfg_SetExpirationOfflineTimeToLive
Sets the offline time of working with virtual machine.
PrlVmCfg_SetExpirationTimeCheckInterval
Sets the time interval to check on expiration date.
PrlVmCfg_SetExpirationTrustedTimeServer
Sets trusted time server.
PrlVmCfg_SetExternalBootDevice
Sets an external boot device system name.
PrlVmCfg_SetFeaturesMask
Sets a features inside the CT.
PrlVmCfg_SetForegroundPriority
Sets the virtual machine foreground processes priority.
PrlVmCfg_SetFreeDiskSpaceRatio
Sets the time free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_SetGuestSharingAutoMount
Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled
Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight
Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHideMinimizedWindowsEnabled
Disables or enables hiding minimized windows.
PrlVmCfg_SetHighAvailabilityEnabled
Enables or disables the High Availability feature for a virtual machine.
PrlVmCfg_SetHighAvailabilityPriority
Sets the priority of the virtual machine in the High Availability Cluster.
PrlVmCfg_SetHighResolutionEnabled
Disables or enables high resolution video mode for the specified virtual machine.
PrlVmCfg_SetHostMemAutoQuota
Enables or disables the automatic calculation of the host's memory (RAM) consumption parameters for the virtual machine.
PrlVmCfg_SetHostMemQuotaMax
Sets the maximal size of the host's memory (RAM) consumption by the virtual machine.
PrlVmCfg_SetHostMemQuotaMin
Sets the minimal size of the host's memory (RAM) consumption by the virtual machine.
PrlVmCfg_SetHostMemQuotaPriority
Sets the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.
PrlVmCfg_SetHostname
Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled
Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon
Sets the virtual machine icon.
PrlVmCfg_SetIoLimit
Sets limit of I/O usage for the virtual machine in Bytes/s.
PrlVmCfg_SetIoPriority
Sets the specified virtual machine I/O priority.
PrlVmCfg_SetIopsLimit
Sets the specified virtual machine IOPS limit.
PrlVmCfg_SetIsolatedVmEnabled
Disables or enables shared camera isolated VM.
PrlVmCfg_SetLockGuestOnSuspendEnabled
Disables or enables shared camera lock guest on suspend.
PrlVmCfg_SetLockInFullScreenMode
Enables or disables the lock in screen mode feature in a virtual machine configuration.
PrlVmCfg_SetLongerBatteryLifeEnabled
Disables or enables longer battery life.
PrlVmCfg_SetMapSharedFoldersOnLetters
Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMaxBalloonSize
Sets the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.
PrlVmCfg_SetMultiDisplay
Sets the virtual machine multi-display option.
PrlVmCfg_SetName
Sets the specified virtual machine name.
PrlVmCfg_SetNestedVirtualizationEnabled
Disables or enables nested virtualization.
PrlVmCfg_SetNetfilterMode
Allows to set netfilter mode inside the CT.
PrlVmCfg_SetNetworkRateList
Add the specified rates list to the Vm configuration.
PrlVmCfg_SetOfflineManagementEnabled
Enables or disables the offline management feature for a virtual machine.
PrlVmCfg_SetOfflineServices
Allows to manually set offline services that will be available in the virtual machine offline management.
PrlVmCfg_SetOptimizeModifiersMode
Sets optimize modifiers mode.
PrlVmCfg_SetOsResInFullScrMode
Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsTemplate
Specify the Virtual Machine Operation System template name which will be used to create new Parallels Virtuozzo Container.
PrlVmCfg_SetOsVersion
Sets the virtual machine guest OS version.
PrlVmCfg_SetPauseWhenIdle
Sets the virtual machine "Pause Idle VM" option.
PrlVmCfg_SetPMUVirtualizationEnabled
Disables or enables PMU virtualization.
PrlVmCfg_SetProfile
Set one of predefined VM profiles.
PrlVmCfg_SetRamHotplugEnabled
Sets the virtual machine memory (RAM) hotplug mode (enabled or disabled).
PrlVmCfg_SetRamSize
Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRateBound
Sets the ratebound flag.
PrlVmCfg_SetRelocateTaskBar
Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetResource
Sets barrier and limit for various user beancounters.
PrlVmCfg_SetScrResEnabled
Enables or disables the additional screen resolution support in a virtual machine.
PrlVmCfg_SetSearchDomains
Allows to manually set the global search domain list that will be assigned to the Virtuozzo Container.
PrlVmCfg_SetShareAllHostDisks
Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetShareClipboard
Enables or disables the clipboard sharing feature.
PrlVmCfg_SetSharedAppsGuestToHost
Lets to share the guest applications to host.
PrlVmCfg_SetSharedAppsHostToGuest
Lets to share the host applications to guest.
PrlVmCfg_SetSharedBluetoothEnabled
Disables or enables bluetooth camera.
PrlVmCfg_SetSharedCameraEnabled
Disables or enables shared camera.
PrlVmCfg_SetSharedCloudEnabled
Enables or disables shared cloud.
PrlVmCfg_SetSharedProfileEnabled
Enables or disables the Shared Profile feature in a virtual machine.
PrlVmCfg_SetShareUserHomeDir
Enables or disables sharing of the host user home directory in the specified virtual machine.
PrlVmCfg_SetShowTaskBar
Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetShowWindowsAppInDock
Lets to set show windows applications folder in Dock enabling sign.
PrlVmCfg_SetSmartGuardEnabled
Enables the SmartGuard feature in a virtual machine.
PrlVmCfg_SetSmartGuardInterval
Sets the time interval at which snapshots are taken by SmartGuard.
PrlVmCfg_SetSmartGuardMaxSnapshotsCount
Sets the maximum snapshot count, a SmartGuard feature.
PrlVmCfg_SetSmartGuardNotifyBeforeCreation
Enables or disables notification of automatic snapshot creation, a SmartGuard feature.
PrlVmCfg_SetSmartMountDVDsEnabled
Enables or disables the SmartMount CD/DVD drives.
PrlVmCfg_SetSmartMountEnabled
Enables or disables the SmartMount feature.
PrlVmCfg_SetSmartMountNetworkSharesEnabled
Enables or disables the SmartMount network shares.
PrlVmCfg_SetSmartMountRemovableDrivesEnabled
Enables or disables the SmartMount removable drives.
PrlVmCfg_SetSmartMouseEnabled
Disables or enables smart mouse.
PrlVmCfg_SetStartInDetachedWindowEnabled
Disables or enables start in detached window.
PrlVmCfg_SetStartLoginMode
Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds
Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetStickyMouseEnabled
Disables or enables sticky mouse.
PrlVmCfg_SetSupportUsb30Enabled
Sets support status USB 3.0.
PrlVmCfg_SetSwitchOffAeroEnabled
Disables or enables switching off aero.
PrlVmCfg_SetSwitchOffWindowsLogoEnabled
Disables or enables Windows logo.
PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled
Disables or enables switching to full screen on demand.
PrlVmCfg_SetSyncDefaultPrinter
Sets synchronization default printer option.
PrlVmCfg_SetSystemFlags
Sets the virtual machine system flags.
PrlVmCfg_SetTemplateSign
Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetTimeSynchronizationEnabled
Enables or disables the time synchronization feature in a virtual machine.
PrlVmCfg_SetTimeSyncInterval
Allows to set the time interval at which the time in the virtual machine will be synchronized with the time in the host OS.
PrlVmCfg_SetTimeSyncSmartModeEnabled
Enables or disables the smart time-synchronization mode in a virtual machine.
PrlVmCfg_SetToolsAutoUpdateEnabled
Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.
PrlVmCfg_SetUnattendedInstallEdition
Sets edition for unattended installation.
PrlVmCfg_SetUnattendedInstallLocale
Sets locale for unattended installation.
PrlVmCfg_SetUndoDisksMode
Sets the undo-disks mode for the virtual machine.
PrlVmCfg_SetUseDefaultAnswers
Enables the use default answers mechanism in a virtual machine.
PrlVmCfg_SetUseDesktop
Enables or disables the "undo-desktop" feature in the shared profile.
PrlVmCfg_SetUseDocuments
Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseDownloads
Lets to set use downloads in shared profile enabling sign.
PrlVmCfg_SetUseHostPrinters
Sets use host printers option.
PrlVmCfg_SetUseMovies
Lets to set use movies in shared profile enabling sign.
PrlVmCfg_SetUseMusic
Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures
Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled
Enables or disables user-defined shared folders.
PrlVmCfg_SetUuid
Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVerticalSynchronizationEnabled
Disables or enables vertical synchronization video mode for the specified virtual machine.
PrlVmCfg_SetVideoRamSize
Sets the virtual machine video memory size.
PrlVmCfg_SetVirtualLinksEnabled
Enables or disables the Virtual Links feature in a virtual machine.
PrlVmCfg_SetVmType
Specify the Virtual Machine type on create action.
PrlVmCfg_SetVNCHostName
Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode
Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword
Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort
Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode
Sets the virtual machine window mode.
PrlVmCfg_SetWinSystrayInMacMenuEnabled
Disables or enables Windows systray in Mac menu.
Links
Functions, Functions by Handle, Legend


PHT_VM_GUEST_SESSION

PHT_VM_GUEST_SESSION
Functions Functions by Handle Legend

The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle can also be used to obtain some of the guest operating system configuration information. The handle is obtained using the PrlVm_LoginInGuest function.

Functions
Name | Description
PrlVmGuest_GetNetworkSettings | Obtains network settings of a guest operating system running in a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.
Links
Functions, Functions by Handle, Legend


PHT_VM_INFO

PHT_VM_INFO
Functions Functions by Handle Legend

The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.

Functions
Name | Description
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetAdditionState | Returns the virtual machine addition state information.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsInvalidEx | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVmWaitingForAnswer | Determines if the specified virtual machine is waiting for answer on self question.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.
Links
Functions, Functions by Handle, Legend


PHT_VM_TOOLS_INFO

PHT_VM_TOOLS_INFO
Functions Functions by Handle Legend

The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.

Functions
Name | Description
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.
Links
Functions, Functions by Handle, Legend


Common Functions

Common Functions
Topics

This chapter contains information about common API functions.

Topics
Name | Description
System Functions | Common Parallels API system functions.
API Debug Functions | API debug functions.
Handle Functions | Functions that perform operations on handles.
Virtual Device Functions | This section describes common virtual device management functions.
PrlBuffer |
Links
Topics


System Functions

System Functions
Functions Common Functions Legend Topics

Common Parallels API system functions.

Functions
Name | Description
PrlApi_CalcIconHash | Calculates hash for specified icon data which can be used later in PrlApi_ValidateInCache.
PrlApi_CreateCredentials | Create credentials (certificate signing request / private key) for user.
PrlApi_CreateHandlesList | Creates a new handle of type PRL_HANDLES_LIST.
PrlApi_CreateOpTypeList | Creates a new handle of type PHT_OPAQUE_TYPE_LIST.
PrlApi_CreateProblemReport | Creates and returns a handle of type PHT_PROBLEM_REPORT, which is used to obtain and manage Parallels problem reports.
PrlApi_CreateRemoteCommand |
PrlApi_CreateStringsList | Creates a new handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetCrashDumpsPath | Returns the name and path of the directory where Parallels crash dumps are stored.
PrlApi_GetDefaultOsVersion | Returns default guest OS version for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetSupportedOsesTypes | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list for current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetSupportedOsesVersions | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetUserData | Allows to get arbitrary data from the cloud user storage.
PrlApi_GetUserKeys | Allows to get arbitrary data keys from the cloud user storage.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitCrashHandler | Initiates the standard Parallels crash dump handler.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_PutIcon | Allows to put arbitrary icon to the cloud user storage.
PrlApi_PutUserData | Allows to put arbitrary data to the cloud user storage.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_RemoveUserData | Allows to remove arbitrary data from the cloud user storage.
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendPackedProblemReport | The PrlApi_SendPackedProblemReport lets to send previously extracted with PrlSrv_GetPackedProblemReport or PrlVm_GetPackedProblemReport calls problem report to the Parallels support server.
PrlApi_SendProblemReport | The PrlApi_SendProblemReport lets to send previously extracted with PrlSrv_GetProblemReport or PrlVm_GetProblemReport calls problem report to the Parallels support server.
PrlApi_SendRemoteCommand |
PrlApi_SignCertificate | Sign user certificate on manager CA .
PrlApi_SignCertificateEx | Sign user certificate on manager CA.
PrlApi_SubscribeOnRegistration | Allows to sign for postponed notification about desired host registration on Manager.
PrlApi_SwitchConsoleLogging | Turn on/off print logging messages on console PRL_ERR_SUCCESS - function completed successfully.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.
PrlApi_ValidateInCache | Allows to check whether the specified icon hashes are present in the cache.
PrlAppliance_Create | Creates a new handle of type PHT_APPLIANCE_CONFIG.
Topics
Name | Description
PrlApi_AddRemoteDevCommandBuffer@PRL_HANDLE@PRL_VOID_PTR@PRL_UINT32 |
PrlApi_AddRemoteDevCommandParam@PRL_HANDLE@PRL_UINT32 |
Links
Functions, Common Functions, Legend, Topics


API Debug Functions

API Debug Functions
Functions Common Functions Legend

API debug functions.

Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.
Links
Functions, Common Functions, Legend


Handle Functions

Handle Functions
Functions Common Functions Legend

Functions that perform operations on handles.

Functions
Name | Description
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetChannelStatistics | Retrieves IO channel statistics (throughput, delay) for correspond virtual machine or remote desktop control object.
PrlHandle_GetPackageId | Returns the numeric identifier of the package that caused the event.
PrlHandle_GetType | Returns the type of the specified handle.
PrlHandle_RegEventHandler | Registers event handler.
PrlHandle_UnregEventHandler | Unregisters event handler.
Links
Functions, Common Functions, Legend


Virtual Device Functions

Virtual Device Functions
Functions Common Functions Legend

This section describes common virtual device management functions.

Description

Common virtual device management functions can operate on virtual devices of the following types:

PHT_VIRTUAL_DEV_FLOPPY

PHT_VIRTUAL_DEV_HARD_DISK

PHT_VIRTUAL_DEV_NET_ADAPTER

PHT_VIRTUAL_DEV_OPTICAL_DISK

PHT_VIRTUAL_DEV_PARALLEL_PORT

PHT_VIRTUAL_DEV_SERIAL_PORT

PHT_VIRTUAL_DEV_SOUND

PHT_VIRTUAL_DEV_USB_DEVICE

Each common function accepts a handle of type PRL_HANDLE identifying the virtual device to operate on. The actual handle passed can be of any type from the list above. In addition to common function described here, most of the individual virtual devices have functions specific to their respective types. For device-type specific functions, follow links to virtual device handles in the list above.

Functions
Name | Description
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_CopyImage | Copies a virtual device image to another custom location.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSubType | Returns the virtual device subtype.
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_ResizeImage | Resize a virtual device image.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSubType | Sets the virtual device subtype.
PrlVmDev_SetSysName | Sets virtual device system name.
Links
Functions, Common Functions, Legend


PrlBuffer

PrlBuffer
Functions Common Functions Legend
Functions
Name | Description
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.
Links
Functions, Common Functions, Legend


Remote Desktop Access

Remote Desktop Access
Topics

This chapter contains information about functions that can be used to remotely capture screen shots of a virtual machine desktop and to send keyboard and mouse commands to it.

Description

With this functionality, you can programmatically connect to a remote virtual machine and run its applications as if you were sitting at the virtual machine's console. The typical uses of the Remote Desktop Access functionality are:

  1. Creating automation scripts for unattended operating system and other software installations.
  2. Creating your own remote desktop applications with graphical user interfaces.

There are four groups of functions comprising the Remote Desktop Access API :

  1. Primary display capture. These functions allow to capture a region or an entire screen of the remote virtual machine. In scripts, you can take a snapshot of a particular screen in advance and then compare it to the screen captured at runtime. If comparison operation determines that you've got the screen of interest, you can interact with it by sending mouse or keyboard commands (pressing buttons, making selections, etc.). In a GUI application, you can constantly capture screens (or screen regions) and display them to the user of your application, thus providing a real-time remote desktop access to a virtual machine.
  2. Secondary display capture. This group of functions is almost identical to the Primary Display Capture group with the exception that it operates on a secondary display(s) if one is installed in a virtual machine.
  3. Mouse control. These functions provide control over the mouse in a virtual machine. You can change the position of the mouse pointer, press and release mouse buttons, and use a scroll wheel. In GUI applications, you can capture mouse events in the host OS where the application is running and then transmit those events to the virtual machine. In scripts, you can move a mouse pointer to the coordinates you know in advance (coordinates of a button, an edit control, etc.) and perform an action.
  4. Keyboard control. These functions simply send a key/action code combination to the virtual machine. In scripts, you can use these functions to interact with controls on a window opened inside a virtual machine (pressing buttons, selecting options, etc.). In a typical GUI application, essential visual controls usually have keyboard shortcuts (accelerator keys) assigned to them. If a control doesn't have a shortcut, then you will have to use mouse control functions to position a mouse pointer over the control to select it.

Every remote desktop access session must begin with PrlDevDisplay_ConnectToVm function call and end with the PrlDevDisplay_DisconnectFromVm call.

For more information and code samples, please see Parallels Virtualization SDK Programmer's Guide.

Topics
Name | Description
Audio Playback | Functions in this group provide functionality for remote sound playback.
Keyboard Control | Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.
Mouse Control | Functions in this group provide functionality for sending mouse commands to a remote virtual machine.
Primary Display Capture | Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.
Secondary Display Capture | Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.
Links
Topics


Audio Playback

Audio Playback
Functions Remote Desktop Access Legend

Functions in this group provide functionality for remote sound playback.

Functions
Name | Description
PrlDevAudio_GetSwitcherState | Get state of the audio switcher from host.
PrlDevAudio_SetSwitcherState | Set state of the audio switcher.
PrlDevAudio_StartStream | Starts audio stream from client to Vm.
PrlDevAudio_StopStream | Stops audio stream.
Links
Functions, Remote Desktop Access, Legend


Keyboard Control

Keyboard Control
Functions Remote Desktop Access Legend

Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.

Functions
Name | Description
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.
PrlDevKeyboard_SendKeyEventEx | Sends a keyboard key event to a virtual machine.
PrlDevKeyboard_SendKeyPressedAndReleased | Sends a keyboard key pressed and released to a virtual machine.
Links
Functions, Remote Desktop Access, Legend


Mouse Control

Mouse Control
Functions Remote Desktop Access Legend

Functions in this group provide functionality for sending mouse commands to a remote virtual machine.

Functions
Name | Description
PrlDevMouse_AsyncMove | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_AsyncSetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevMouse_Event | Sends absolute or relative mouse event with specified parameters within the virtual machine display coordinate grid.
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_MoveEx | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPosEx | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
Links
Functions, Remote Desktop Access, Legend


Primary Display Capture

Primary Display Capture
Functions Remote Desktop Access Legend

Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.

Functions
Name | Description
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_ConnectToVmEx | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetAvailableDisplaysCount | Returns available displays count of a remote virtual machine desktop.
PrlDevDisplay_GetDisplayEncoding | Gets current encoding of specified Vm.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetConfiguration | Sends a request to a virtual machine to set guest display configuration to specified values.
PrlDevDisplay_SetDisplayEncoding | Sets display encoding for specified Vm.
PrlDevDisplay_SetDpiConfiguration | Sends a request to a virtual machine to set guest DPI display configuration to specified values.
PrlDevDisplay_SetScreenSurface |
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.
Links
Functions, Remote Desktop Access, Legend


Secondary Display Capture

Secondary Display Capture
Functions Remote Desktop Access Legend

Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.

Functions
Name | Description
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenBufferEx | Returns the contents of the screen buffer of the secondary display and mapping handle on Windows host (on Unix host hMapping parameter will be always equal to buffer).
PrlDevSecondaryDisplay_GetScreenBufferFormat | Returns format of internal screen buffer.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
Links
Functions, Remote Desktop Access, Legend


Callback Prototypes

Callback Prototypes
Topics

This chapter describes callback function prototypes that are used to implement your own callback functions for use in asynchronous calls.

Topics
Name | Description
PRL_DISK_CALLBACK | PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
PRL_EVENT_HANDLER_PTR | PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.
PRL_STATES_CALLBACK | PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
Links
Topics


PRL_DISK_CALLBACK

PRL_DISK_CALLBACK
Callback Prototypes

PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.

Syntax
typedef PRL_BOOL (PRL_CALL *PRL_DISK_CALLBACK)(PRL_INT32 iComplete, PRL_INT32 iTotal, PRL_VOID_PTR pParam);
Parameters

iComplete
An integer value indicating the state of the disk operation completion. Values range from 0 to the value contained in the iTotal parameter. A value greater than 0 and less than iTotal indicates that the operation is still in progress and can be used to determine the state (percentage) of completion. A value greater than iTotal indicates that the operation completed successfully. A negative value indicates an error.
iTotal
An integer value indicating the upper bound of the disk operation completion range.
pParam
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


PRL_EVENT_HANDLER_PTR

PRL_EVENT_HANDLER_PTR
Callback Prototypes

PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.

Syntax
typedef PRL_METHOD_PTR( PRL_EVENT_HANDLER_PTR ) ( PRL_HANDLE hEvent, PRL_VOID_PTR data );
Parameters

hEvent
A handle of type PHT_EVENT or PHT_JOB. The PHT_EVENT type indicates that the callback function was called by a system event. If the type is PHT_JOB then the callback function was called by an asynchronous job. The type can be determined using the PrlHandle_GetType function. For more information and code samples see Parallels Virtualization SDK Programmer's Guide.

Note: You must always free the handle before exiting from the function regardless of whether you actually used it or not. Failure to do so will result in a memory leak.

data
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


PRL_STATES_CALLBACK

PRL_STATES_CALLBACK
Callback Prototypes

PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.

Syntax
typedef PRL_BOOL (PRL_CALL *PRL_STATES_CALLBACK)(PRL_STATES_CALLBACK_TYPE iCallbackType, PRL_INT32 iProgress, PRL_VOID_PTR pParameter);
Parameters

iCallbackType
Callback type. At the time of this writing the only supported callback type is PRL_STATE_DISK_CALLBACK.
iProgress
An integer value indicating the state of the disk operation completion. To determine the state (e.g. percentage of completion), compare the received value to the following constants:

PRL_STATE_PROGRESS_MIN -- The lower bound of the operation completion range.

PRL_STATE_PROGRESS_MAX -- The upper bound of the operation completion range.

PRL_STATE_PROGRESS_COMPLETED -- Indicates that the operation completed successfully.

A value between PRL_STATE_PROGRESS_MIN and PRL_STATE_PROGRESS_MAX indicates that the operation is still in progress. A value greater than PRL_STATE_PROGRESS_COMPLETED indicates that the operation completed successfully. A negative value indicates an error.

pParameter
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


Types

Types
Topics
Topics
Name | Description
PRL_BOOL Types |
PRL_CHAR Types |
PRL_CONST Types |
PRL_DEVICE Types |
PRL_DISK Types |
PRL_DOUBLE Types |
PRL_FILE Types |
PRL_INT Types |
PRL_IO Types |
PRL_TIS Types |
PRL_TOOLS Types |
PRL_UINT Types |
PRL_VM Types |
PRL_VOID Types |
Other Types |
Links
Topics


PRL_BOOL Types

PRL_BOOL Types
Types Types
Types
Name | Description
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |
Links
Types, Types


PRL_CHAR Types

PRL_CHAR Types
Types Types
Types
Name | Description
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |
Links
Types, Types


PRL_CONST Types

PRL_CONST Types
Types Types
Types
Name | Description
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_CARET_INFO_PTR |
PRL_CONST_CPU_FEATURES_MASK_PTR |
PRL_CONST_CPULIMIT_DATA_PTR |
PRL_CONST_CVSRC_OPEN_MODE |
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_DOUBLE_PTR |
PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_IOLIMIT_DATA_PTR |
PRL_CONST_MAKEUP_HINTING_RGN_PTR |
PRL_CONST_SELECTION_HINTING_RGN_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UIEMU_AUTOKEYBOARD_PTR |
PRL_CONST_UIEMU_CURSOR_DESC_PTR |
PRL_CONST_UIEMU_CURSOR_FORMAT_PTR |
PRL_CONST_UIEMU_CURSOR_POS_PTR |
PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR |
PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR |
PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR |
PRL_CONST_UIEMU_GESTURE_EVENT_PTR |
PRL_CONST_UIEMU_INPUT_INFO_PTR |
PRL_CONST_UIEMU_VKEY_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR |
PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR |
PRL_CONST_VOID_PTR |
Links
Types, Types


PRL_DEVICE Types

PRL_DEVICE Types
Types Types
Types
Name | Description
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |
Links
Types, Types


PRL_DISK Types

PRL_DISK Types
Types Types
Types
Name | Description
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |
Links
Types, Types


PRL_DOUBLE Types

PRL_DOUBLE Types
Types Types
Types
Name | Description
PRL_DOUBLE | Double type
PRL_DOUBLE_PTR |
PRL_DOUBLE_PTR_PTR |
Links
Types, Types


PRL_FILE Types

PRL_FILE Types
Types Types
Types
Name | Description
PRL_FILE_DESC | File descriptor type
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |
Links
Types, Types


PRL_INT Types

PRL_INT Types
Types Types
Types
Name | Description
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |
Links
Types, Types


PRL_IO Types

PRL_IO Types
Types Types
Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUDIO_DATA_PTR |
PRL_IO_AUDIO_ENCODING_LIST_PTR |
PRL_IO_AUDIO_ENCODING_PTR |
PRL_IO_AUDIO_ENCODING_RESPONSE_PTR |
PRL_IO_AUTH_EXEC_REQUEST_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_AVAILABLE_DISPLAYS_PTR |
PRL_IO_CHANNEL_STAT_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISCONNECT_REASON_PTR |
PRL_IO_DISPLAY_ENCODING_LIST_PTR |
PRL_IO_DISPLAY_ENCODING_PTR |
PRL_IO_DISPLAY_GAMMA_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_LANGUAGE_HOTKEYS_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_EX_PTR |
PRL_IO_MOUSE_EVENT_EX2_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SHUTDOWN_RESULT_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_SSO_CLIENT_VM_PACKET_PTR |
PRL_IO_STATE_PTR |
PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR |
PRL_IO_TOOLS_DISPLAY_INDENT_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |
PRL_IOLIMIT_DATA_PTR |
Links
Types, Types


PRL_TIS Types

PRL_TIS Types
Types Types
Types
Name | Description
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_FIELD_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TIS_VERSION_PTR |
Links
Types, Types


PRL_TOOLS Types

PRL_TOOLS Types
Types Types
Types
Name | Description
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |
Links
Types, Types


PRL_UINT Types

PRL_UINT Types
Types Types
Types
Name | Description
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |
Links
Types, Types


PRL_VM Types

PRL_VM Types
Types Types
Types
Name | Description
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_STOP_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_ACTION_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BACKUP_TYPE_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_COLOR_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_LOCATION_PTR |
PRL_VM_NET_ADAPTER_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_SMARTGUARD_SCHEMA_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_TYPE_PTR |
PRL_VM_WINDOW_MODE_PTR |
Links
Types, Types


PRL_VOID Types

PRL_VOID Types
Types Types
Types
Name | Description
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |
Links
Types, Types


Other Types

Other Types
Types Types
Types
Name | Description
ICryptInfoPtr |
IPluginInfoPtr |
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_API_COMMAND_FLAGS_PTR |
PRL_API_INIT_FLAGS_PTR |
PRL_API_METHOD_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLIANCE_DOWNLOAD_STATUS_PTR |
PRL_APPLICATION_MODE_PTR |
PRL_AUDIO_STREAM_TYPE_PTR |
PRL_BIOS_TYPE_PTR |
PRL_CHS_PTR |
PRL_CLONE_VM_FLAGS_PTR |
PRL_CLUSTERED_DEVICE_SUBTYPE_PTR |
PRL_COMPACT_MODE_PTR |
PRL_CORNER_ACTIONS_PTR |
PRL_CPU_FEATURES_MASK_PTR |
PRL_CPU_FEATURES_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_CPU_VTX_MODE |
PRL_CPU_VTX_MODE_PTR |
PRL_CPULIMIT_DATA_PTR |
PRL_CREATE_DISK_IMAGE_FLAGS_PTR |
PRL_CT_CAPMASK_PTR |
PRL_CT_TEMPLATE_TYPE_PTR |
PRL_CVSRC_OPEN_MODE_PTR |
PRL_DATA_STATISTIC_SEGMENTS_PTR |
PRL_DISPLAY_BUFFER_FORMAT_PTR |
PRL_DISPLAY_CONFIG_MODE_PTR |
PRL_DISTRO_MEDIA_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_ENCRYPTION_FLAGS_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_EVENT_TYPE_PTR |
PRL_EXTERNAL_VM_TYPE_PTR |
PRL_FEATURES_MATRIX_PTR |
PRL_FIREWALL_DIRECTION_PTR |
PRL_FIREWALL_POLICY_PTR |
PRL_GENERIC_DEVICE_STATE_PTR |
PRL_GENERIC_PCI_DEVICE_CLASS_PTR |
PRL_GET_VM_CONFIG_FLAGS_PTR |
PRL_GET_VM_CONFIG_PARAM_DATA_PTR |
PRL_GET_VM_LIST_FLAGS_PTR |
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_IFACE_MASK_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_INFO_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_LICENSE_RESTRICTION_KEY_PTR |
PRL_LOGIN_LOCAL_FLAGS_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOBILE_ADVANCED_AUTH_MODE_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_NETFILTER_MODE_PTR |
PRL_ONLINE_COMPACT_MODE_PTR |
PRL_OPTIMIZE_MODIFIERS_MODE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PRINTER_INTERFACE_TYPE_PTR |
PRL_PRIVATE_EVENT_TYPE_PTR |
PRL_PROBLEM_REPORT_FLAGS_PTR |
PRL_PROBLEM_REPORT_REASON_PTR |
PRL_PROBLEM_REPORT_SCHEME_PTR |
PRL_PROBLEM_REPORT_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_PROXY_CLIENT_INFO_PTR |
PRL_PROXY_CONNECTION_STATUS_PTR |
PRL_PROXY_DATA_KEY_PTR |
PRL_PROXY_GEO_INFO_PTR |
PRL_PROXY_HOST_INFO_EXT_PTR |
PRL_PROXY_HOST_INFO_PTR |
PRL_PROXY_REGISTRATION_INFO_PTR |
PRL_PROXY_USER_DATA_PTR |
PRL_PTM_CONST_OBJECT_PTR |
PRL_PTM_CONST_PROPERTY_PTR |
PRL_PTM_OBJECT_PTR |
PRL_PTM_PROPERTY_PTR |
PRL_QUERY_ELEMENT_FLAGS_PTR |
PRL_REGISTER_3PARTY_VM_FLAGS_PTR |
PRL_REGISTER_NEW_VM_PTR |
PRL_REGISTER_VM_FLAGS_PTR |
PRL_RESIZE_IMAGE_FLAGS_PTR |
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SCALE_VIEW_MODE_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_SET_PROXY_CONNECTION_FLAGS_PTR |
PRL_SET_USERPASSWD_FLAGS_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_SOUND_CHANNEL_TYPE_PTR |
PRL_SRV_SHUTDOWN_FLAGS_PTR |
PRL_STAT_NET_TRAFFIC_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |
PRL_STR |
PRL_UIEMU_AUTOKEYBOARD_PTR |
PRL_UIEMU_CARET_INFO_PTR |
PRL_UIEMU_CURSOR_DESC_PTR |
PRL_UIEMU_CURSOR_FORMAT_PTR |
PRL_UIEMU_CURSOR_POS_PTR |
PRL_UIEMU_ELEMENT_AT_POS_PTR |
PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR |
PRL_UIEMU_GESTURE_DATA_PINCH_PTR |
PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR |
PRL_UIEMU_GESTURE_EVENT_PTR |
PRL_UIEMU_GESTURE_STATE_PTR |
PRL_UIEMU_GESTURE_TYPE_PTR |
PRL_UIEMU_INPUT_INFO_PTR |
PRL_UIEMU_MAKEUP_HINTING_RGN_PTR |
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR |
PRL_UIEMU_MMKEY_PTR |
PRL_UIEMU_MOUSE_CLICK_PTR |
PRL_UIEMU_SCROLL_FLAGS_PTR |
PRL_UIEMU_SCROLL_UNITS_PTR |
PRL_UIEMU_SELECTION_HINTING_RGN_PTR |
PRL_UIEMU_VKEY_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_UPDATE_LICENSE_FLAGS_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_USB_DEVICE_TYPE_PTR |
PRL_VERSION_ENUM_PTR |
PRL_VIDEO_3D_ACCELERATION_PTR |
PRL_VIDEO_RECEIVER_CONFIG_PTR |
PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR |
PRL_VIDEO_RECEIVER_FRAME_DESC_PTR |
PRL_VIDEO_RECEIVER_FRAME_PTR |
PRL_VIDEO_RECEIVER_STATISTICS_PTR |
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR |
PRL_VIRTUAL_MACHINE_PROFILE_PTR |
PRL_VM_MOUSE_CURSOR_STATE_PTR |
PRL_VM_MOUSE_STATE_PTR |
PRL_VM_NET_ADAPTER_WIFI_RULE_PTR |
PRL_VM_NORMAL_START_FLAGS_PTR |
PRL_VM_STATISTICS_FLAGS_PTR |
PRL_VMCTG_EVENT_PTR |
PRL_VMCTG_TOOL_DATA_RECEIVED_PTR |
PRL_VMCTG_TOOL_DESC_PTR |
PRL_VTD_STATUS_CODE_PTR |
PRL_WINDOW_CORNERS_PTR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_ADDITION_STATE_PTR |
VIRTUAL_MACHINE_STATE_PTR |
Links
Types, Types


Structs, Records, Enums

Structs, Records, Enums
Topics
Topics
Name | Description
PRL_IO Structs |
PRL_VM Structs |
Other Structs |
Links
Topics


PRL_IO Structs

PRL_IO Structs
Enumerations Structs, Records, Enums Legend Structures
Enumerations
Name | Description
_PRL_IO_DISCONNECT_REASON | Specifies the reason of closing IO connection
PRL_IO_CLIENT_FLAGS | Flags which determines peer client while login to dispatcher and while attach to vm.
PRL_IO_STATE |
PRL_IOLIMIT_TYPE |
Structures
Name
Description
_PRL_IO_CHANNEL_STAT
_PRL_IO_DISPLAY_ENCODING
Since 6.3 IO protocol version.
_PRL_IO_DISPLAY_ENCODING_LIST
Since 6.3 IO protocol version.
_PRL_IO_DISPLAY_GAMMA
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
_PRL_IO_DPI_DISPLAY_SCREEN_SIZE
_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
_PRL_IO_MOUSE_EVENT_EX
_PRL_IO_MOUSE_EVENT_EX2
_PRL_IO_TOOLS_DISPLAY_INDENT
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUDIO_DATA
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING_LIST
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING_RESPONSE
Audio support since 6.6 IO protocol version.
PRL_IO_AUTH_EXEC_REQUEST
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_AVAILABLE_DISPLAYS
PRL_IO_CHANNEL_STAT
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_ENCODING
Since 6.3 IO protocol version.
PRL_IO_DISPLAY_ENCODING_LIST
Since 6.3 IO protocol version.
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DPI_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
PRL_IO_ENCODING_RESPONSE
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_LANGUAGE_HOTKEYS
PRL_IO_MEMORY_INFO
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_MOUSE_EVENT_EX
PRL_IO_MOUSE_EVENT_EX2
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SHUTDOWN_RESULT
PRL_IO_SLIDING_MOUSE
PRL_IO_SSO_CLIENT_VM_PACKET
PRL_IO_TOOLS_ADJUST_WORKING_AREA
PRL_IO_TOOLS_DISPLAY_INDENT
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
PRL_IOLIMIT_DATA
Links
Enumerations, Structs, Records, Enums, Legend, Structures


PRL_VM Structs

PRL_VM Structs
Enumerations Structs, Records, Enums Legend
Enumerations
Name | Description
_PRL_VM_ACTION_ON_STOP | Action when VM gets stopped
_PRL_VM_COLOR | VM colors
_PRL_VM_LOCATION | VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive
_PRL_VM_NET_ADAPTER_TYPE |
_PRL_VM_SMARTGUARD_SCHEMA | SmartGuard schema
_PRL_VM_STOP_FLAGS | Virtual machine shutdown options.
_PRL_VM_STOP_MODE | Vm stop modes
_PRL_VM_TYPE |
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION |
PRL_VM_ACTION_ON_STOP | Action when VM gets stopped
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BACKUP_FLAGS | VM backup functionality flags set
PRL_VM_BACKUP_TYPE | Hint about the type of VE inside a backup archive
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_COLOR | VM colors
PRL_VM_COMMIT_FLAGS | PrlVm_CommitEx flags
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest
PRL_VM_LOCATION | VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive
PRL_VM_MIGRATION_FLAGS | VM migration functionality flags set
PRL_VM_MOUSE_CURSOR_STATE |
PRL_VM_MOUSE_STATE |
PRL_VM_NET_ADAPTER_TYPE |
PRL_VM_NET_ADAPTER_WIFI_RULE |
PRL_VM_NORMAL_START_FLAGS | VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_SMARTGUARD_SCHEMA | SmartGuard schema
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation
PRL_VM_STATISTICS_FLAGS | PrlVm_GetStatisticsEx flags
PRL_VM_STOP_FLAGS | Virtual machine shutdown options.
PRL_VM_STOP_MODE | Vm stop modes
PRL_VM_STORE_VALUE_FLAGS | Store value by specified keys on server options.
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_TYPE |
PRL_VM_TYPE_FLAGS |
PRL_VM_WINDOW_MODE | VM window mode
Links
Enumerations, Structs, Records, Enums, Legend


Other Structs

Other Structs
Enumerations Structs, Records, Enums Legend Structures
Enumerations
Name
Description
_PRL_ADAPTER_INDEX
Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index
_PRL_ALLOWED_VM_COMMAND
Allowed vm commands enumeration
_PRL_API_COMMAND_FLAGS
Common operations flags set.
_PRL_API_INIT_FLAGS
Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode
_PRL_APP_IN_DOCK_MODE
VM application in Dock mode
_PRL_APPLIANCE_DOWNLOAD_STATUS
Appliance download status
_PRL_APPLICATION_MODE
Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode
_PRL_BIOS_TYPE
BIOS type
_PRL_CLONE_VM_FLAGS
PrlVm_CloneEx command flags set
PCVF_DETACH_EXTERNAL_VIRTUAL_HDD

  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
_PRL_CLUSTERED_DEVICE_SUBTYPE
Clustered device subtype
_PRL_COMPACT_MODE
Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files
_PRL_CONVERT_VIRTUAL_DISK
Convert virtual disk

  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
_PRL_COPY_CT_TEMPLATE_FLAGS
copy of CT templates functionality flags set
_PRL_CORNER_ACTIONS
Window corner actions
_PRL_CPU_FEATURES_EX
_PRL_CPU_HVT
CPU mode
_PRL_CPU_MODE
CPU mode
_PRL_CPULIMIT_TYPE
_PRL_CPUUNITS
_PRL_CREATE_DISK_IMAGE_FLAGS
Create image flags
_PRL_CREATE_SNAPSHOT_FLAGS
VM snapshot creation flags set
_PRL_CT_CAPMASK
Capabilities list
_PRL_CT_FEATURES
CT Features
_PRL_CT_RESOURCE
_PRL_CT_TEMPLATE_TYPE
Container templates types
_PRL_DATA_STATISTIC_SEGMENTS
Data statistic segments
_PRL_DELETE_SNAPSHOT_FLAGS

  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
_PRL_DEVICE_ACTION
Device in use Action
_PRL_DEVICE_TYPE
Device type
_PRL_DISPLAY_BUFFER_FORMAT
Format of display buffer
_PRL_DISPLAY_CODEC_COMPRESSION
Obsolete enum.
_PRL_DISPLAY_CODEC_QUALITY
Obsolete enum.
_PRL_DISPLAY_CODEC_TYPE
Obsolete enum.
_PRL_DISPLAY_CONFIG_MODE
Display(s) configuration mode
_PRL_DISTRO_MEDIA_TYPE
_PRL_DOCK_ICON_TYPE
VM application icon type in Dock
_PRL_ENCRYPTION_FLAGS
Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations
_PRL_EVENT_ISSUER_TYPE
Event issuer type
_PRL_EVENT_TYPE
Different event types are identified by these event codes.
_PRL_EXTERNAL_VM_TYPE
External VM type for supporting native VM
_PRL_FEATURES_MATRIX
Features matrix list
_PRL_FILE_SYSTEM_ELEMENT_TYPE
File system element type
_PRL_FILE_SYSTEM_FS_TYPE
_PRL_FILE_SYSTEM_TYPE
File system general type
_PRL_FIREWALL_DIRECTION
Firewall direction
_PRL_FIREWALL_POLICY
Firewall policy
_PRL_GENERIC_DEVICE_STATE
Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started
_PRL_GENERIC_PCI_DEVICE_CLASS
Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device
_PRL_GET_SNAPSHOT_TREE_FLAGS
PrlVm_GetSnapshotsTreeEx flags
_PRL_GET_VM_CONFIG_FLAGS
Find VM operations:
_PRL_GET_VM_LIST_FLAGS
List operations: Uses for PrlSrv_GetVmListEx operation
_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
_PRL_GRACEFUL_SHUTDOWN_KIND
Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM
Windows installation distributive type.
_PRL_HANDLE_TYPE
The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_IFACE_MASK
Hard disk interfce mask enum
_PRL_HARD_DISK_INTERNAL_FORMAT
Hard disk image type
_PRL_HOST_OS_TYPE
Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE
Network adapter types in hardware info list
_PRL_IMAGE_FORMAT
_PRL_INSTALL_APPLIANCE_FLAGS
Install appliance options

  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
_PRL_IO_CLIENT_FLAGS
Flags which determines peer client while login to dispatcher and while attach to vm.
_PRL_IO_STATE
_PRL_IOLIMIT_TYPE
_PRL_IOPRIO
_PRL_ISCSI_STORAGE_CMD_FLAGS
iSCSI storage management flags
_PRL_ISCSI_STORAGE_FSTYPE_FLAGS
iSCSI storage filesystem type
_PRL_JOB_OPERATION_CODE
Job operation codes
_PRL_JOB_STATUS
Job status enumeration
_PRL_KEY
Parallels virtual keycodes.
_PRL_KEY_EVENT
_PRL_LICENSE_RESTRICTION_KEY
License restriction options
_PRL_LOGIN_LOCAL_FLAGS
PrlSrv_LoginLocal flags
_PRL_MASS_STORAGE_INTERFACE_TYPE
Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM
Message type enumeration.
_PRL_MOBILE_ADVANCED_AUTH_MODE
Authorization mode, when mobile client establishing remote access to the host.
_PRL_MOUNT_VIRTUAL_DISK
Mount virtual disk flags
_PRL_MOUSE_BUTTON
_PRL_NET_ADAPTER_EMULATED_TYPE
Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE
Virtual Network type.
_PRL_NETFILTER_MODE
Netfilter modes list
_PRL_ONLINE_COMPACT_MODE
Online compact mode for virtual machine disks
_PRL_OPTIMIZE_MODIFIERS_MODE
Determines the mode of modifiers handling inside the guest
_PRL_PARAM_FIELD_DATA_TYPE
Event parameters fields types
_PRL_PORT_FORWARDING_TYPE
Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PRINTER_INTERFACE_TYPE
Printer device interface type
_PRL_PRIVATE_EVENT_TYPE
Private event types.
_PRL_PROBLEM_REPORT_FLAGS
Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report
_PRL_PROBLEM_REPORT_REASON
Problem report reason enumeration
_PRL_PROBLEM_REPORT_SCHEME
Problem report scheme enumaration
_PRL_PROBLEM_REPORT_TYPE
Problem report type enumeration
_PRL_PROCESS_STATE_TYPE
Process state element
_PRL_PRODUCT_ENUM
Parallels license products enumeration.
_PRL_PROXY_CONNECTION_STATUS
Proxy connection status
_PRL_QUERY_ELEMENT_FLAGS
Query element flags
_PRL_REGISTER_3PARTY_VM_FLAGS
PrlSrv_Register3rdPartyVm command flags set
_PRL_REGISTER_NEW_VM
PrlVm_RegEx flags
_PRL_REGISTER_VM_FLAGS
PrlSrv_RegisterVmEx command flags set
_PRL_RESIZE_IMAGE_FLAGS
PrlVmDev_ResizeImage command flags set
_PRL_RUNNING_TASK_TYPE_ENUM
Running task type enumeration.
_PRL_SCALE_VIEW_MODE
Aspect ratio mode
_PRL_SECURITY_LEVEL
Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM
Parallels service statuses
_PRL_SET_PROXY_CONNECTION_FLAGS
PrlDispCfg_SetProxyConnectionCreds flags
_PRL_SET_USERPASSWD_FLAGS
PrlVmGuest_SetUserPasswd flags
_PRL_SOUND_CHANNEL_TYPE
Sound channel type
_PRL_SRV_SHUTDOWN_FLAGS
PrlSrv_ShutdownEx flags
_PRL_SWITCH_SNAPSHOT_FLAGS
PrlVm_SwitchSnapshotEx flags
_PRL_TASKBAR_STATES
Taskbar states
_PRL_TIS_RECORD_FIELD
Parallels Tools Information Service record fields
_PRL_TIS_RECORD_STATE
Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES
Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG
Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID
Parallels Tools Utility commands identifiers
_PRL_UIEMU_ELEMENT_CONTROL_TYPE
_PRL_UIEMU_GESTURE_STATE
_PRL_UIEMU_GESTURE_TYPE
_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
_PRL_UIEMU_MMKEY
_PRL_UIEMU_MOUSE_CLICK
_PRL_UIEMU_SCROLL_FLAGS
_PRL_UIEMU_SCROLL_UNITS
_PRL_UNDO_DISKS_MODE
VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_UPDATE_LICENSE_FLAGS
Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION
USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON
USB device connect/disconnect reason
_PRL_USB_DEVICE_TYPE
USB device type
_PRL_VERSION_ENUM
Parallels license versions enumeration.
_PRL_VIDEO_3D_ACCELERATION
Video 3D acceleration
_PRL_VIRTUAL_MACHINE_PROFILE
Virtual machine profiles enum
_PRL_VM_ACCELERATION_LEVEL
Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS
Specifies virtual machine access rights.
_PRL_VM_ACTION
_PRL_VM_ACTION_ON_WINDOW_CLOSE
Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION
VM autostart options
_PRL_VM_AUTOSTOP_OPTION
VM autostop options
_PRL_VM_BACKUP_FLAGS
VM backup functionality flags set
_PRL_VM_BACKUP_TYPE
Hint about the type of VE inside a backup archive
_PRL_VM_BOOT_ORDER
VM boot order
_PRL_VM_COMMIT_FLAGS
PrlVm_CommitEx flags
_PRL_VM_CONFIG_SECTIONS
VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE
VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR
App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES
Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest
_PRL_VM_MIGRATION_FLAGS
VM migration functionality flags set
_PRL_VM_MOUSE_CURSOR_STATE
_PRL_VM_MOUSE_STATE
_PRL_VM_NET_ADAPTER_WIFI_RULE
_PRL_VM_NORMAL_START_FLAGS
VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)
_PRL_VM_PRIORITY
Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE
Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE
VM start login mode
_PRL_VM_START_MODE
VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation
_PRL_VM_STATISTICS_FLAGS
PrlVm_GetStatisticsEx flags
_PRL_VM_STORE_VALUE_FLAGS
Store value by specified keys on server options.
_PRL_VM_TOOLS_STATE
Virtual machine tools states enumeration
_PRL_VM_TYPE_FLAGS
_PRL_VM_WINDOW_MODE
VM window mode
_PRL_VMCTG_EVENT
Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)
_PRL_VTD_STATUS_CODE
VTD status code
_PRL_WINDOW_CORNERS
Window corners
_PRL_WINDOW_EDGE_MASK
Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_ADDITION_STATE
Virtual machine addition states enumeration, may be combined with bitwise
_VIRTUAL_MACHINE_STATE
Virtual machine states enumeration
PRL_ADAPTER_INDEX
Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index
PRL_ALLOWED_VM_COMMAND
Allowed vm commands enumeration
PRL_API_COMMAND_FLAGS
Common operations flags set.
PRL_API_INIT_FLAGS
Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode
PRL_APP_IN_DOCK_MODE
VM application in Dock mode
PRL_APPLIANCE_DOWNLOAD_STATUS
Appliance download status
PRL_APPLICATION_MODE
Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode
PRL_AUDIO_STREAM_TYPE
Audio stream type
PRL_BIOS_TYPE
BIOS type
PRL_CLONE_VM_FLAGS
PrlVm_CloneEx command flags set
PCVF_DETACH_EXTERNAL_VIRTUAL_HDD

  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
PRL_CLUSTERED_DEVICE_SUBTYPE
Clustered device subtype
PRL_COMPACT_MODE
Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files
PRL_CONVERT_VIRTUAL_DISK
Convert virtual disk

  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
PRL_COPY_CT_TEMPLATE_FLAGS
copy of CT templates functionality flags set
PRL_CORNER_ACTIONS
Window corner actions
PRL_CPU_FEATURES_EX
PRL_CPU_HVT
CPU mode
PRL_CPU_MODE
CPU mode
PRL_CPULIMIT_TYPE
PRL_CPUUITS
PRL_CREATE_DISK_IMAGE_FLAGS
Create image flags
PRL_CREATE_SNAPSHOT_FLAGS
VM snapshot creation flags set
PRL_CT_CAPMASK
Capabilities list
PRL_CT_FEATURES
CT Features
PRL_CT_RESOURCE
PRL_CT_TEMPLATE_TYPE
Container templates types
PRL_DATA_STATISTIC_SEGMENTS
Data statistic segments
PRL_DELETE_SNAPSHOT_FLAGS

  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
PRL_DEVICE_ACTION
Device in use Action
PRL_DEVICE_TYPE
Device type
PRL_DISPLAY_BUFFER_FORMAT
Format of display buffer
PRL_DISPLAY_CODEC_COMPRESSION
Obsolete enum.
PRL_DISPLAY_CODEC_QUALITY
Obsolete enum.
PRL_DISPLAY_CODEC_TYPE
Obsolete enum.
PRL_DISPLAY_CONFIG_MODE
Display(s) configuration mode
PRL_DISTRO_MEDIA_TYPE
PRL_DOCK_ICON_TYPE
VM application icon type in Dock
PRL_ENCRYPTION_FLAGS
Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations
PRL_EVENT_ISSUER_TYPE
Event issuer type
PRL_EVENT_TYPE
Different event types are identified by these event codes.
PRL_EXTERNAL_VM_TYPE
External VM type for supporting native VM
PRL_FEATURES_MATRIX
Features matrix list
PRL_FILE_SYSTEM_ELEMENT_TYPE
File system element type
PRL_FILE_SYSTEM_FS_TYPE
PRL_FILE_SYSTEM_TYPE
File system general type
PRL_FIREWALL_DIRECTION
Firewall direction
PRL_FIREWALL_POLICY
Firewall policy
PRL_GENERIC_DEVICE_STATE
Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started
PRL_GENERIC_PCI_DEVICE_CLASS
Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device
PRL_GET_SNAPSHOT_TREE_FLAGS
PrlVm_GetSnapshotsTreeEx flags
PRL_GET_VM_CONFIG_FLAGS
Find VM operations:
PRL_GET_VM_LIST_FLAGS
List operations: Uses for PrlSrv_GetVmListEx operation
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
PRL_GRACEFUL_SHUTDOWN_KIND
Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM
Windows installation distributive type.
PRL_HANDLE_TYPE
The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_IFACE_MASK
Hard disk interfce mask enum
PRL_HARD_DISK_INTERNAL_FORMAT
Hard disk image type
PRL_HOST_OS_TYPE
Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE
Network adapter types in hardware info list
PRL_IMAGE_FORMAT
PRL_INSTALL_APPLIANCE_FLAGS
Install appliance options

  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
PRL_IO_DISCONNECT_REASON
Specifies the reason of closing IO connection
PRL_IOPRIO
PRL_ISCSI_STORAGE_CMD_FLAGS
iSCSI storage management flags
PRL_ISCSI_STORAGE_FSTYPE_FLAGS
iSCSI storage filesystem type
PRL_JOB_OPERATION_CODE
Job operation codes
PRL_JOB_STATUS
Job status enumeration
PRL_KEY
Parallels virtual keycodes.
PRL_KEY_EVENT
PRL_LICENSE_RESTRICTION_KEY
License restriction options
PRL_LOGIN_LOCAL_FLAGS
PrlSrv_LoginLocal flags
PRL_MASS_STORAGE_INTERFACE_TYPE
Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM
Message type enumeration.
PRL_MOBILE_ADVANCED_AUTH_MODE
Authorization mode, when mobile client establishing remote access to the host.
PRL_MOUNT_VIRTUAL_DISK
Mount virtual disk flags
PRL_MOUSE_BUTTON
PRL_NET_ADAPTER_EMULATED_TYPE
Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE
Virtual Network type.
PRL_NETFILTER_MODE
Netfilter modes list
PRL_ONLINE_COMPACT_MODE
Online compact mode for virtual machine disks
PRL_OPTIMIZE_MODIFIERS_MODE
Determines the mode of modifiers handling inside the guest
PRL_PARAM_FIELD_DATA_TYPE
Event parameters fields types
PRL_PORT_FORWARDING_TYPE
Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PRINTER_INTERFACE_TYPE
Printer device interface type
PRL_PRIVATE_EVENT_TYPE
Private event types.
PRL_PROBLEM_REPORT_FLAGS
Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report
PRL_PROBLEM_REPORT_REASON
Problem report reason enumeration
PRL_PROBLEM_REPORT_SCHEME
Problem report scheme enumaration
PRL_PROBLEM_REPORT_TYPE
Problem report type enumeration
PRL_PROCESS_STATE_TYPE
Process state element
PRL_PRODUCT_ENUM
Parallels license products enumeration.
PRL_PROXY_CONNECTION_STATUS
Proxy connection status
PRL_QUERY_ELEMENT_FLAGS
Query element flags
PRL_REGISTER_3PARTY_VM_FLAGS
PrlSrv_Register3rdPartyVm command flags set
PRL_REGISTER_NEW_VM
PrlVm_RegEx flags
PRL_REGISTER_VM_FLAGS
PrlSrv_RegisterVmEx command flags set
PRL_RESIZE_IMAGE_FLAGS
PrlVmDev_ResizeImage command flags set
PRL_RUNNING_TASK_TYPE_ENUM
Running task type enumeration.
PRL_SCALE_VIEW_MODE
Aspect ratio mode
PRL_SECURITY_LEVEL
Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM
Parallels service statuses
PRL_SET_PROXY_CONNECTION_FLAGS
PrlDispCfg_SetProxyConnectionCreds flags
PRL_SET_USERPASSWD_FLAGS
PrlVmGuest_SetUserPasswd flags
PRL_SOUND_CHANNEL_TYPE
Sound channel type
PRL_SRV_SHUTDOWN_FLAGS
PrlSrv_ShutdownEx flags
PRL_SWITCH_SNAPSHOT_FLAGS
PrlVm_SwitchSnapshotEx flags
PRL_TASKBAR_STATES
Taskbar states
PRL_TIS_RECORD_FIELD
Parallels Tools Information Service record fields
PRL_TIS_RECORD_STATE
Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES
Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG
Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID
Parallels Tools Utility commands identifiers
PRL_UIEMU_ELEMENT_CONTROL_TYPE
PRL_UIEMU_GESTURE_STATE
PRL_UIEMU_GESTURE_TYPE
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
PRL_UIEMU_MMKEY
PRL_UIEMU_MOUSE_CLICK
PRL_UIEMU_SCROLL_FLAGS
PRL_UIEMU_SCROLL_UNITS
PRL_UNDO_DISKS_MODE
VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_UPDATE_LICENSE_FLAGS
Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation
PRL_USB_DEVICE_AUTO_CONNECT_OPTION
USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON
USB device connect/disconnect reason
PRL_USB_DEVICE_TYPE
USB device type
PRL_VERSION_ENUM
Parallels license versions enumeration.
PRL_VIDEO_3D_ACCELERATION
Video 3D acceleration
PRL_VIDEO_RECEIVER_CONNECTION_STATE
Streaming connection status enum
PRL_VIRTUAL_MACHINE_PROFILE
Virtual machine profiles enum
PRL_VMCTG_EVENT
Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)
PRL_VTD_STATUS_CODE
VTD status code
PRL_WINDOW_CORNERS
Window corners
PRL_WINDOW_EDGE_MASK
Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_ADDITION_STATE
Virtual machine addition states enumeration, may be combined with bitwise
VIRTUAL_MACHINE_STATE
Virtual machine states enumeration
Structures
Name
Description
__PRL_DISK_PARAMETERS
Parallels disk parameters.
__PRL_IMAGE_PARAMETERS
Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
_ICryptInfo
Information about encryption plugin
_IPluginInfo
Generic information about plugin
_PRL_API_METHOD
Parallels API method
_PRL_CHS
CHS format of disk
_PRL_CPU_FEATURES
_PRL_CPU_FEATURES_MASK
_PRL_CPULIMIT_DATA
_PRL_CVSRC_OPEN_MODE
_PRL_GET_VM_CONFIG_PARAM_DATA
_PRL_GUID
Global unique identifier
_PRL_HOST_OS_INFO
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUDIO_DATA
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING_LIST
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING_RESPONSE
Audio support since 6.6 IO protocol version.
_PRL_IO_AUTH_EXEC_REQUEST
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_AVAILABLE_DISPLAYS
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
_PRL_IO_ENCODING_RESPONSE
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_LANGUAGE_HOTKEYS
_PRL_IO_MEMORY_INFO
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SHUTDOWN_RESULT
_PRL_IO_SLIDING_MOUSE
_PRL_IO_SSO_CLIENT_VM_PACKET
_PRL_IO_TOOLS_ADJUST_WORKING_AREA
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_IOLIMIT_DATA
_PRL_PROXY_CLIENT_INFO
_PRL_PROXY_DATA_KEY
_PRL_PROXY_GEO_INFO
_PRL_PROXY_HOST_INFO
_PRL_PROXY_HOST_INFO_EXT
_PRL_PROXY_REGISTRATION_INFO
_PRL_PROXY_USER_DATA
_PRL_PTM_OBJECT
structure describes the object properties used by SetProperties and by PET_PTM_EVT_PROPERTY_CHANGED event
_PRL_PTM_PROPERTY
structure describes object property
_PRL_STAT_NET_TRAFFIC
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
_PRL_UIEMU_AUTOKEYBOARD
_PRL_UIEMU_CARET_INFO
_PRL_UIEMU_CURSOR_DESC
_PRL_UIEMU_CURSOR_FORMAT
_PRL_UIEMU_CURSOR_POS
_PRL_UIEMU_ELEMENT_AT_POS
_PRL_UIEMU_GESTURE_DATA_PINCH
_PRL_UIEMU_GESTURE_DATA_SMARTZOOM
_PRL_UIEMU_GESTURE_EVENT
_PRL_UIEMU_INPUT_INFO
_PRL_UIEMU_MAKEUP_HINTING_RGN
_PRL_UIEMU_SELECTION_HINTING_RGN
brief Rect as a part of region
_PRL_UIEMU_VKEY
_PRL_VMCTG_TOOL_DATA_RECEIVED
_PRL_VMCTG_TOOL_DESC
Describes the tool to be registered @see PrlVm_RegisterTool()
PRL_CHS
CHS format of disk
PRL_CPU_FEATURES
PRL_CPU_FEATURES_MASK
PRL_CPULIMIT_DATA
PRL_CVSRC_OPEN_MODE
PRL_DISK_PARAMETERS
Parallels disk parameters.
PRL_GET_VM_CONFIG_PARAM_DATA
PRL_HOST_OS_INFO
PRL_IMAGE_PARAMETERS
Parallels storage parameters
PRL_IO_DISPLAY_GAMMA
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
PRL_PROXY_CLIENT_INFO
PRL_PROXY_DATA_KEY
PRL_PROXY_GEO_INFO
PRL_PROXY_HOST_INFO
PRL_PROXY_HOST_INFO_EXT
PRL_PROXY_REGISTRATION_INFO
PRL_PROXY_USER_DATA
PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
PRL_STAT_NET_TRAFFIC
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_UIEMU_AUTOKEYBOARD
PRL_UIEMU_CARET_INFO
PRL_UIEMU_CURSOR_DESC
PRL_UIEMU_CURSOR_FORMAT
PRL_UIEMU_CURSOR_POS
PRL_UIEMU_ELEMENT_AT_POS
PRL_UIEMU_GESTURE_DATA_PINCH
PRL_UIEMU_GESTURE_DATA_SMARTZOOM
PRL_UIEMU_GESTURE_EVENT
PRL_UIEMU_INPUT_INFO
PRL_UIEMU_VKEY
PRL_VIDEO_RECEIVER_CONFIG
PRL_VIDEO_RECEIVER_FRAME
PRL_VIDEO_RECEIVER_FRAME_DESC
PRL_VIDEO_RECEIVER_STATISTICS
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY
PRL_VMCTG_TOOL_DATA_RECEIVED
PRL_VMCTG_TOOL_DESC
Describes the tool to be registered @see PrlVm_RegisterTool()
Links
Enumerations, Structs, Records, Enums, Legend, Structures


Macros

Macros
Topics
Topics
Name | Description
__Parallels_API Macros |
__PTM Macros |
GUI_ERR Macros |
GUI_INFO Macros |
Other Macros |
PET Macros |
PRL_DISK Macros |
PRL_ERR Macros |
PRL_PTM Macros |
PRL_SCAN_CODE Macros |
PVS_GUEST Macros |
Links
Topics


__Parallels_API Macros

__Parallels_API Macros
Macros Macros
Macros
Name | Description
__PARALLELS_API_APP_MANAGER_ENUMS_H__ |
__PARALLELS_API_COMMANDS_FLAGS_H__ |
__PARALLELS_API_CORE_H__ |
__PARALLELS_API_DESKTOP_PARAMETERS_H__ |
__PARALLELS_API_DISPATCHER_H__ |
__PARALLELS_API_INPUT_EMU_H__ |
__PARALLELS_API_MANAGER_H__ |
__PARALLELS_API_NET_H__ |
__PARALLELS_API_PORTS_H__ |
__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__ |
__PARALLELS_API_PTM_H__ |
__PARALLELS_API_PTM_TYPES_H__ |
__PARALLELS_API_REMOTE_DEV_H__ |
__PARALLELS_API_SECURITY_H__ |
__PARALLELS_API_STATISTIC_H__ |
__PARALLELS_API_VIDEO_RECEIVER_H__ |
__PARALLELS_API_VM_H__ |
Links
Macros, Macros


__PTM Macros

__PTM Macros
Macros Macros
Macros
Name | Description
__PTM_ACCESS |
__PTM_ACCESS_IN |
__PTM_ACCESS_INOUT |
__PTM_ACCESS_N | N,R,W,RW access for data objects; IN,OUT,INOUT for procedural objects
__PTM_ACCESS_OUT |
__PTM_ACCESS_R |
__PTM_ACCESS_RW |
__PTM_ACCESS_W |
__PTM_SEND |
__PTM_SEND_ALL | properties delivery control on property change/query: is default mark to deliver most recent property values, discarding property changes that have not been sent yet and waiting in send queue.
__PTM_SEND_NOSELF |
__PTM_SEND_PRI |
__PTM_SEND_PRI_HIGH |
__PTM_SEND_PRI_IDLE | objects may be splitted on parts and delivered with appropriate sending priority
__PTM_SEND_PRI_LOW |
__PTM_SEND_PRI_NORMAL |
__PTM_SEND_STREAM |
__PTM_TYPE |
__PTM_TYPE_BIN |
__PTM_TYPE_I32 | proeprty types
__PTM_TYPE_I64 |
__PTM_TYPE_STR |
__PTM_TYPE_STRLST |
__PTM_TYPE_STRUCT |
__PTM_TYPE_U32 |
__PTM_TYPE_U64 |
Links
Macros, Macros


GUI_ERR Macros

GUI_ERR Macros
Macros Macros
Macros
Name
Description
GUI_ERR_ACTION_CANCELLED
GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED
GUI_ERR_APP_ALREADY_RUNNING
GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED
GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED
GUI_ERR_APP_BUNDLE_INIT_ABORTED
GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_INIT_FAILURE
GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED
GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION
GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT
GUI_ERR_APP_COULD_NOT_BE_STARTED
GUI_ERR_APP_EULA_DECLINED
GUI_ERR_APP_NEED_REINSTALL
GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW
GUI_ERR_APP_RESUME_INIT_BUNDLE
GUI_ERR_APP_RESUME_INSTALLING_UPDATE
GUI_ERR_APP_RESUME_INVALID_CONTEXT
GUI_ERR_APP_RESUME_SERVER_DISCONNECTED
GUI_ERR_APP_RESUME_SILENT_START
GUI_ERR_APP_RESUME_TIMEOUT
GUI_ERR_APP_RESUME_VM_ENCRYPTED
GUI_ERR_BACKUP_FAILED_GENERAL_MSG
GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE
GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT
GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM
GUI_ERR_CANNOT_DELETE_DISK_FILES
GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE
GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH
GUI_ERR_CANNOT_MOVE_VM_TO_TRASH
GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE
GUI_ERR_CANNOT_RUN_LINKED_CLONE
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE
GUI_ERR_CANT_ADD_PCI_INSTANTLY

  • Gui messages

+++ ALIGNED VALUE TO 15000

GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_RUN_ON_THIS_SYSTEM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_CANT_START_UTW7_AGENT
GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY
GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED
GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR
GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY
GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE
GUI_ERR_CONVERT_FAILED
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_UNKNOWN
End of obsolete codes scope
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE
GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION
GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE
GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH
GUI_ERR_DLCITEM_DWNLD_UNEXPECTED
GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION
GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED
GUI_ERR_DOWNLOADING_FAILED
GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED
GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED
GUI_ERR_DOWNLOADING_PIS_FAILED
GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED
GUI_ERR_FAILED_TO_INIT_SDK_LIB
GUI_ERR_HOST_NOT_SUPPORTED
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED
GUI_ERR_INSTALLATION_DOWNLOADING_FAILED
GUI_ERR_INSTALLING_FAILED
GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_INVALID_ADAPTER_ADDRESS
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_IVALID_VM_UUID_MISMATCH
GUI_ERR_LEGACY_HDD_NOT_SUPPORTED
GUI_ERR_MIGRATE_PC_ALREADY_RUNNING
GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM
GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE
GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED
GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN
GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_NET_ADAPTER_EXISTS
GUI_ERR_NET_ADAPTER_NAME_EMPTY
GUI_ERR_NEWER_APP_ALREADY_RUNNING
GUI_ERR_NO_EMAIL_ACCOUNT
GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL
GUI_ERR_NO_INSTALLATION_DISC
GUI_ERR_NO_INSTALLER_FILE
GUI_ERR_NO_OPTICAL_DRIVE
GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE
GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OLDER_APP_ALREADY_RUNNING
GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_OS_IMG_DWNLD_UNEXPECTED
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION
GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION
GUI_ERR_PARENT_LINKED_VM_NOT_FOUND
GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR
GUI_ERR_PAX_AGENT_INSTALL_FAILURE
GUI_ERR_PAX_AGENT_NO_CONNECTION
GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED
GUI_ERR_PMC_INVALID_CREDENTIALS
Obsolete error codes - use ones with prefix PRL_ERR_PPC
GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT
GUI_ERR_PMC_SERVER_BUSY
GUI_ERR_PMC_UNABLE_TO_CONNECT
GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE
GUI_ERR_POST_REPORT
GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER
GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION
GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR
GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED
GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START
GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_SUSPEND_VM_WITH_VTD
GUI_ERR_UID_0_DUPLICATION
GUI_ERR_UNABLE_START_LYM
GUI_ERR_UNABLE_START_TRANSPORTER
GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD
GUI_ERR_UNABLE_TO_START_SERVICES
GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_UPDATE_INSTALL_FAILED
GUI_ERR_UPDATE_UNABLE_TO_CHECK
GUI_ERR_UPDATER_NO_CONNECTION
GUI_ERR_UPDATER_NO_FILE
GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE
GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR
GUI_ERR_UPGRADE_REQUEST_UNEXPECTED
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_VOLUME_LICENSE_EXPIRED
GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES
GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES
GUI_ERR_WEB_STORE_INVALID_DATA
GUI_ERR_WEB_STORE_NO_CONNECTION
GUI_ERR_WEB_STORE_NO_DATA
GUI_ERR_WEB_STORE_UNEXPECTED
GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL
GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN
GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN
GUI_ERR_WRONG_BACKUP_PATH
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_FEATURE_RESTRICTED
GUI_INFO_IN_FULLSCREEN_NOTIFICATION
GUI_INFO_IN_SEAMLESS_NOTIFICATION
GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_REINSTALL_TOOLS_LIN
GUI_INFO_REINSTALL_TOOLS_MAC
GUI_INFO_REINSTALL_TOOLS_OTHER
GUI_INFO_REINSTALL_TOOLS_WIN
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_UPDATE_TOOLS_LIN
GUI_INFO_UPDATE_TOOLS_MAC
GUI_INFO_UPDATE_TOOLS_OTHER
GUI_INFO_UPDATE_TOOLS_WIN
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DELETE_VM_IMMEDIATELY
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_MOVE_TO_TRASH_DISK
GUI_QUESTION_MOVE_TO_TRASH_VM
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN
GUI_QUESTION_STOP_SUSPENDED_VM
GUI_QUESTION_TRIAL_EXPIRES_TEXT1
GUI_QUESTION_TRIAL_EXPIRES_TEXT2
GUI_QUESTION_TRIAL_EXPIRES_TEXT3
GUI_QUESTION_TRIAL_EXPIRES_TEXT4
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_INVALID_IPV6_ADDRESS
GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
Links
Macros, Macros


GUI_INFO Macros

GUI_INFO Macros
Macros Macros
Macros
Name
Description
GUI_ANSWER_RUN_FREE_SPACE_WIZARD

  • GUI Answers

+++ ALIGNED VALUE TO 53000

GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL
GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL
GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM
GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK
GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM
GUI_INFO_CLEAN_UP_DISK_SPACE
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST
GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D
GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY
GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS
GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY
GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED
GUI_INFO_COHERENCE_CANNOTSTART_SMOFF
GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_STOPPED_LINUX_3D
GUI_INFO_COHERENCE_STOPPED_LOWMEMORY
GUI_INFO_CONFIGURING_THE_DOCK
GUI_INFO_CONVERT_SUCCEDED_OTHER_OS
GUI_INFO_CTRL_ALT_DEL_FROM_MENU
GUI_INFO_CTRL_ALT_DEL_PRESSED
GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED
GUI_INFO_ENTER_IN_POWERSAVE_MODE
GUI_INFO_ENTER_TO_PRESENTATION_MODE
GUI_INFO_EXIT_FROM_PRESENTATION_MODE
GUI_INFO_EXPRESS_INSTALLATION_FINISHED
GUI_INFO_FEEDBACK_SUCCESS
GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE
GUI_INFO_GUEST_HIRES_OPTION_CHANGED
GUI_INFO_HIDDEN_MESSAGES_RESTORED
GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE
GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON
GUI_INFO_INSTALLED_GUEST_APPS_DIALOG
GUI_INFO_INVALID_LOGIN_OR_PASS
GUI_INFO_IPN_MESSAGE
GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM
GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY
GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL
GUI_INFO_NEW_VERSION_AVAILABLE
GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT
GUI_INFO_OFFICE_SHARED_CLOUDS_KB
GUI_INFO_PASSWORD_RESET_CHECK_EMAIL
GUI_INFO_PASSWORD_RESET_ENTER_EMAIL
GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY
GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY
GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED
GUI_INFO_REG_ALREADY_REGISTERED
GUI_INFO_REG_CONNECTION
GUI_INFO_REG_GENERAL_ERROR
GUI_INFO_REG_INVALID_EMAIL
GUI_INFO_REG_INVALID_KEY
GUI_INFO_REG_INVALID_USER
GUI_INFO_REG_OK
GUI_INFO_REG_REQUIRED_FIELDS
GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED
GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMOTE_SESSION_ACTIVE
GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED
GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER
GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM
GUI_INFO_SNAPSHOT_DELETE_FINISHED
GUI_INFO_SOFTWARE_UP_TO_DATE
GUI_INFO_TASK_ALREADY_RUNNING
GUI_INFO_TASK_STEP_SKIPPED
GUI_INFO_TRIAL_GUEST_WARNING
GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS
GUI_INFO_UPDATE_FINISHED
GUI_INFO_UPGRADE_FINISHED
GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER
GUI_INFO_USB3_DRIVERS_REQUIRED_WIN
GUI_INFO_USER_REGISTRATION_DLG_SEND_OK
GUI_INFO_VM_CLEANUP_NOTHING_TO_DO
GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC
GUI_INFO_VM_COMPACTING_FINISHED
GUI_INFO_VM_DECRYPTED_SUCCESSFULLY
GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY
GUI_INFO_VM_IN_ISOLATION_MAC
GUI_INFO_VM_IN_ISOLATION_WIN
GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS
GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT
GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD
GUI_QUESTION_CANCEL_INSTALL_DELETE
GUI_QUESTION_CANCEL_INSTALL_SUSUPEND
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING
GUI_QUESTION_CLOSE_VM_WINDOW
GUI_QUESTION_CONFIRM_UPDATE_CANCEL
GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED
GUI_QUESTION_CONVERT_SUCCEDED
GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER
GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS
GUI_QUESTION_DELETE_CREATED_VM
GUI_QUESTION_DELETE_OLD_VM
GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT
GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES
GUI_QUESTION_DESKTOP_IS_UNREGISTERED
GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS
GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS
GUI_QUESTION_DISABLE_HOST_SLEEP
GUI_QUESTION_DISABLE_OPTIONS
GUI_QUESTION_DISABLE_VERBOSE_LOG
GUI_QUESTION_DISABLE_WINDOWS7_LOOK
GUI_QUESTION_DONT_USE_DIRECT_CONECTION
GUI_QUESTION_DWNLD_RETRY
GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE
GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION
GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE
GUI_QUESTION_ENABLE_BACKGROUND_UPDATE
GUI_QUESTION_ENABLE_CEP
GUI_QUESTION_ENABLE_GUEST_SHARING
GUI_QUESTION_ENABLE_PMU_SUPPORT
GUI_QUESTION_ENABLE_SHARED_APPS
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH
GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT
GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE
GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START
GUI_QUESTION_INSTALL_MAJOR_UPDATE
GUI_QUESTION_INSTALL_WINDOWS7_LOOK
GUI_QUESTION_INVALID_VM_CORRUPTED
GUI_QUESTION_INVALID_VM_NOT_AVAILABLE
GUI_QUESTION_ISOLATE_VM
GUI_QUESTION_ISOLATE_VM_LIN
GUI_QUESTION_MANUAL_INSTALL
GUI_QUESTION_NO_BACKUP
GUI_QUESTION_NO_FREE_SPACE
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8
GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE
GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE
GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS
GUI_QUESTION_POSTPONE_UPGRADE
GUI_QUESTION_PREPARE_MAVERICK_IMAGE
GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED
GUI_QUESTION_PROFILE_DELETE
GUI_QUESTION_QUIT_PARALLELS_ACCESS
GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM
GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_QUESTION_REMOVE_BACKUP
GUI_QUESTION_REMOVE_PREVIOUS_VERSION
GUI_QUESTION_REPLACE_PREVIOUS_VERSION
GUI_QUESTION_RESET_VIRTUAL_NETWORK
GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE
GUI_QUESTION_RESTORE_FROM_BACKUP
GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS
GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG
GUI_QUESTION_SM_ENABLE_SHARED_APPS
GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR
GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS
GUI_QUESTION_SNAPSHOT_SINGLE_DELETE
GUI_QUESTION_STOP_APPLIANCE
GUI_QUESTION_UPDATER_NO_CONNECTION
GUI_QUESTION_USB_CONTROLLER_REMOVE
GUI_QUESTION_VM_CLEANUP_CONFIRM
GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE
GUI_TRY_DISCONNECT_CONNECTING_USB
GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST
GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE
GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS
GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS
GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS
GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS
GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT
GUI_WRN_DESKTOP_IS_TRIAL
GUI_WRN_DEVICE_ALREADY_EXIST
GUI_WRN_DHCP_END_IP_ADDRESS
GUI_WRN_DHCP_START_IP_ADDRESS
GUI_WRN_DUPLICATE_VIRTUAL_NETWORK
GUI_WRN_ENCRYPTED_DISK_NOT_ADDED
GUI_WRN_FS_RESIZE_NOT_SUPPORTED
GUI_WRN_HOST_IP_ADDRESS
GUI_WRN_INVALID_VM_BUNDLE
GUI_WRN_INVALID_VM_FOLDER
GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED
GUI_WRN_LOCAL_PATH_NOT_SPECIFIED
GUI_WRN_LOCAL_PATH_WRONG
GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL
GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE
GUI_WRN_NEW_PROFILE_NAME_EMPTY
GUI_WRN_NO_BACKUP_FOLDER
GUI_WRN_NO_USB_DEVICES_AVAILABLE
GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS
GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS
GUI_WRN_PARTITION_NOT_SPECIFIED
GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT
GUI_WRN_PORT_MAPPING_IP_INCORRECT
GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT
GUI_WRN_PRODUCT_KEY_INCOMPLETE
GUI_WRN_PRODUCT_KEY_WRONG_LENGTH
GUI_WRN_PROFILE_NAME_ALREADY_IN_USE
GUI_WRN_PURCHASE_MISSING_KEY
GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED
GUI_WRN_SERVER_ALREADY_CONNECTED
GUI_WRN_SERVER_NAME_NOT_SPECIFIED
GUI_WRN_SERVER_NAME_WRONG
GUI_WRN_SOURCE_FOR_DEVICE_IS_USED
GUI_WRN_SUBNET_MASK
GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG
GUI_WRN_UNABLE_REQUEST_TRIAL_KEY
GUI_WRN_UNATTENDED_LINUX_NO_IMAGE
GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE
GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY
GUI_WRN_USER_NAME_ILLEGAL
GUI_WRN_USER_NAME_NOT_SPECIFIED
GUI_WRN_USER_NAME_RESERVED_BY_GUEST
GUI_WRN_USER_PASS_DO_NOT_MATCH
GUI_WRN_USER_PASS_NOT_SPECIFIED
GUI_WRN_USER_PASS_TOO_SHORT
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI
GUI_WRN_VIRTUAL_NETWORK_WRONG
Links
Macros, Macros


Other Macros

Other Macros
Macros Macros
Macros
Name
Description
__PARALLELS_PERF_COUNTERS_H__
__PRL_PLUGINS_CLASSES_DEFINED__
CAPDEFAULTMASK
FS_PERM_EXECUTE
FS_PERM_READ
FS_PERM_WRITE
GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION
GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS
GUID_CLS_BASE_STR
GUID_CLS_ENCRYPTION_STR
IS_ANDROID
IS_CHROMEOS
IS_FREEBSD
IS_FS_EXECUTE_PERMITTED
IS_FS_READ_PERMITTED
IS_FS_WRITE_PERMITTED
IS_LINUX
IS_MACOS
IS_MSDOS
IS_NETWARE
IS_OS2
IS_OTHER
IS_SOLARIS
IS_VALID_ANDROID_VERSION
IS_VALID_CHROMEOS_VERSION
IS_VALID_FREEBSD_VERSION
IS_VALID_LINUX_VERSION
IS_VALID_MACOS_VERSION
IS_VALID_MSDOS_VERSION
IS_VALID_NETWARE_VERSION
IS_VALID_OS2_VERSION
IS_VALID_OTHER_OS_VERSION
IS_VALID_SOLARIS_VERSION
IS_VALID_WINDOWS_VERSION
IS_WIN_VER_BELOW
PVS_GUEST_VER_WIN_OTHER is used for legacy guest OS (9x and below), but has maximal number 0xFF.
IS_WINDOWS
PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_SRV_METHOD_DECL
PRL_BSD_PARTITION
Free BSD partition.
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID

  • Disk validation errors

+++ ALIGNED VALUE TO 25000

PRL_CURRENT_GUEST_OS_SESSION
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_DISK_NO_IMAGE_CREATION
So not create image when creating disk, just put reference to file in XML
PRL_DISPATCHER_LISTEN_PORT
PRL_DISPATCHER_LISTEN_PORT_PMOBILE
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_FAILED
PRL_FALSE
PRL_HDD_FIRMWARE_LEN
PRL_HDD_MODEL_LEN
Definitions of length of incoming strings to PrlDisk_GetIdentify function.
PRL_HDD_SERIAL_LEN
PRL_IDE_READ_REQUESTS_PTRN
Total count of read requests to IDE controller
PRL_IDE_READ_TOTAL_PTRN
Total count of read bytes through IDE controller
PRL_IDE_WRITE_REQUESTS_PTRN
Total count of write requests to IDE controller
PRL_IDE_WRITE_TOTAL_PTRN
Total count of write bytes through IDE controller
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_BOOTCAMP_FAKE
FAKE Bootcamp, for test purposes
PRL_IMAGE_BOOTCAMP_UID
Bootcamp set by UID
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_IMAGE_VHD_DIFF
PRL_IMAGE_VHD_DYNAMIC
PRL_IMAGE_VHD_DYNAMIC_PART
PRL_IMAGE_VHD_PLAIN
Limited Microsoft VHD support
PRL_IMAGE_VHD_PLAIN_PART
PRL_IMAGE_VMDK_EXTENT_2GB_FLAT
PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE
PRL_IMAGE_VMDK_MONOLITHIC_FLAT
VMware VMDK support
PRL_IMAGE_VMDK_MONOLITHIC_SPARSE
PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED
PRL_INVALID_FILE_DESCRIPTOR
Invalid file descriptor
PRL_INVALID_HANDLE
PRL_INVALID_PARTITION
Invalid partition
PRL_INVALID_VLAN_TAG
constant for invalid VLAN tag
PRL_IO_GAMMARAMP_DEFAULT
PRL_IO_GAMMARAMP_RGB256x3x16
PRL_IO_MAX_AUDIO_ENCODINGS
PRL_IO_MAX_DISPLAYS
PRL_IO_MAX_ENCODINGS
PRL_LICENSE_IS_EXPIRED
PRL_LICENSE_IS_VALID
Success license state
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_BOOT_PARTITION
PRL_MACOS_PARTITION
Mac OS
PRL_MAX_VLAN_TAG
constant for maximum valid VLAN tag (4095)
PRL_METHOD
Default method decoration
PRL_METHOD_DECL
Default method declaration for the header files
PRL_METHOD_PTR
PRL_MSDOS_EXTENDED_PARTITION

  • Disk partition types

Extended partitions

PRL_NET_ADAPTER_ALREADY_USED
Unable to use adapter because it is already used by another virtual network
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_BYTES_IN_PTRN
PRL_NET_BYTES_OUT_PTRN
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CLASSFUL_TRAFFIC_PTRN
Classful network traffic counting info.
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME
PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR

  • Network

+++ ALIGNED VALUE TO 4000

PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST
PRL_NET_IPPRIVATE_NETWORK_INVALID_IP
PRL_NET_OFFMGMT_ERROR
Failed to setup offline-management configuration for VM
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PKTS_IN_PTRN
PRL_NET_PKTS_OUT_PTRN
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS
Invalid DHCP scope ip addresses format
PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN
Minimum ip addresses in scope range are 16
PRL_NET_VALID_FAILURE
+++ ALIGNED VALUE TO 4200 +++ Broken network config
PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK
Mask must match DHCP scope ip addresses
PRL_NET_VALID_WRONG_DHCP_IP_ADDR
Invalid DHCP ip address format
PRL_NET_VALID_WRONG_HOST_IP_ADDR
Invalid host ip address format
PRL_NET_VALID_WRONG_NET_MASK
Invalid network mask format
PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS
PRL_NET_VIRTUAL_NETWORK_NOT_FOUND
PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS
Unable to add shared network because it is already exists
PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED
Shared network prohibited on server
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_NULL
NULL (invalid) handle
PRL_PRIVILEGED_GUEST_OS_SESSION
Guest OS sessions types and constants declarations
PRL_PROXY_MAX_HOSTS
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD
PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE
PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE
PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS
PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH
PRL_QUESTION_FINALIZE_VM_PROCESS
PRL_QUESTION_REVERT_TOO_LARGE_MEM
PRL_QUESTION_SETUP_YANDEX_SEARCH
PRL_RESULT_DECLARE_ERROR
Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS
PRL_SATA_READ_REQUESTS_PTRN
Total count of read requests to SATA controller
PRL_SATA_READ_TOTAL_PTRN
Total count of read bytes through SATA controller
PRL_SATA_WRITE_REQUESTS_PTRN
Total count of write requests to SATA controller
PRL_SATA_WRITE_TOTAL_PTRN
Total count of write bytes through SATA controller
PRL_SCSI_READ_REQUESTS_PTRN
Total count of read requests to SCSI controller
PRL_SCSI_READ_TOTAL_PTRN
Total count of read bytes through SCSI controller
PRL_SCSI_WRITE_REQUESTS_PTRN
Total count of write requests to SCSI controller
PRL_SCSI_WRITE_TOTAL_PTRN
Total count of write bytes through SCSI controller
PRL_SDK_WRAP_FOR_EACH_MANAGER
PRL_SRV_METHOD_DECL
PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_STRUCT
Default structure definition
PRL_SUCCEEDED
Success and failure result codes
PRL_TC_CLASS_MAX
PRL_TERNARY_FALSE
PRL_TERNARY_TRUE
PRL_TERNARY_UNDEF
PRL_TRUE
PRL_VM_STOP_MODE_MASK
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND is keep only for compatibility with previous versions of dispatcher (PSBM)
PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE
PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP
PRL_WARN_BACKUP_NON_IMAGE_HDD
PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_CANNOT_MOUNT_BACK_PARTITION
PRL_WARN_CANT_CONNECT_VOLUME
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_DEV_USB_CONNECT_FAILED
PRL_WARN_DEV_USB_OPEN_FAILED
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_LICENSE_RESTRICTED_RKU
PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE
PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT
PRL_WARN_NOT_SYMMETRIC_CPU
PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE
PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VERBOSE_LOGGING
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DISCONNECT_SATA_HDD
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED
PRL_WARN_WINDOWS_UPDATE_WORKING
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions
PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED
PRL_WNG_START_VM_ON_MOUNTED_DISK
PRL_WRN_IT_CANT_RESIZE_LDM_DISK
PRL_WRN_IT_CANT_RESIZE_VOLUME
PRL_WRN_IT_EMPTY_MBR
PRL_WRN_IT_FIRST_WARNING
vi disk tool errors +++ ALIGNED VALUE TO 46000
PRL_WRN_IT_VOLUME_RESIZING
PRL_WS_RECLAIMABLE_PTRN
PVM_GET_SECURITY_LEVEL
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_TYPE
PVS_GUEST_VER_FREE_BSD
PVS_MAKE_GUEST_VER
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_ENABLED
SET_FS_READ_DISABLED
SET_FS_READ_ENABLED
SET_FS_WRITE_DISABLED
SET_FS_WRITE_ENABLED
Links
Macros, Macros


PET Macros

PET Macros
Macros Macros
Macros
Name
Description
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_BROWSE
PET_ANSWER_CANCEL
PET_ANSWER_CHANGE
PET_ANSWER_COMMIT
PET_ANSWER_COMPACT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_DONT_CHANGE
PET_ANSWER_LATER
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK

  • Answers

+++ ALIGNED VALUE TO 16000

PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_RESTART
PET_ANSWER_RESTART_NOW
PET_ANSWER_RESTORE
PET_ANSWER_RESUME
PET_ANSWER_RETRY
PET_ANSWER_REVERT
PET_ANSWER_SET_RECOMMENDED
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_STOP_AND_RESTORE
PET_ANSWER_SUSPEND
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_USE_MAX_ALLOWED
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_COMMON_HDD_ERROR
PET_QUESTION_COMPACT_VM_DISKS
PET_QUESTION_CONTINUE_IF_HVT_DISABLED
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART
PET_QUESTION_DELAYED_COMPACT_VM_DISKS
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FORCE_COMPACT_VM_DISKS
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_ON_QUERY_END_SESSION
PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1

  • Questions

+++ ALIGNED VALUE TO 13000

PET_QUESTION_SAMPLE_2
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU
PET_QUESTION_STOP_VM_TO_COMPACT
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU
PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE
PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS
PRL_CPU_UNLIMITED
constant for unlimited CPU number
Links
Macros, Macros


PRL_DISK Macros

PRL_DISK Macros
Macros Macros
Macros
Name
Description
PRL_DISK_ALIGN_REQUESTS
Incoming requests to read/write async must be gathered and aligned
PRL_DISK_ALLOW_DATA_MODIFY
Allow inplace data modification to reduce memory copying and allocation
PRL_DISK_CACHE_DEFAULT
Disk cache default.
PRL_DISK_CACHE_DISABLED
Uncached access to disk image.
PRL_DISK_CACHE_ENABLED
Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ
Cached write/uncached read.
PRL_DISK_CACHE_UNCACHED_SEQ_READ
Like PRL_DISK_CACHE_UNCACHED_READ, but cache is enabled for

  • small and random/reordered requests.
PRL_DISK_DEFAULT_FLAG
Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN
Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT
Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK
Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING
DEPRECATED! Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED
DEPRECATED! Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL
DEPRECATED! Normal access mode (default os)
PRL_DISK_FOPS_PCS
DEPRECATED! Access mode to files on PCS storage
PRL_DISK_IGNORE_PROTECTION
Ignore storages read only flag (useful at disk creation)
PRL_DISK_INVALID
Last (invalid).
PRL_DISK_NO_ERROR_CHECKING
Force open of disk for reading without error checking
PRL_DISK_NO_SPACE_CHECKS
Do not check host free space
PRL_DISK_NOT_LIMIT_HANDLES
Do not use handle pool for disk image handles
PRL_DISK_NOTHING
Nothing.
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MIN
States progress definition.
PRL_DISK_READ
Read
PRL_DISK_READ_LOCK
ReadLock
PRL_DISK_USE_RAW_DISK
Use raw disk for BootCamp partition (/dev/rdisk instead of /dev/disk)
PRL_DISK_WRITE
Write
PRL_DISK_XML_CHANGE
This parameter is used when user need to change XML data but not access to the drive itself.
Links
Macros, Macros


PRL_ERR Macros

PRL_ERR Macros
Macros Macros
Macros
Name
Description
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TO_VM_HDD_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT
PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_ACTIVATE_TRIAL_LICENSE
PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED
PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_ACTIVATION_SERVER_ERROR
PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED
PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_ACTIVATION_UPDATE_FAILED
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT
  • license activation errors
* +++ ALIGNED VALUE TO 11700
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE
PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5
PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER
PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM
PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS
PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED
PRL_ERR_APPLIANCE_EXIT_WITH_ERROR
PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS
PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED
PRL_ERR_APPLIANCE_INVALID_CONFIG
Install appliance task errors +++ ALIGNED VALUE TO 41500
PRL_ERR_APPLIANCE_MISMATCH_MD5
PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE
PRL_ERR_APPLIANCE_NO_VM_BUNDLE
PRL_ERR_APPLIANCE_USER_NOT_FOUND
PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED
PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED
PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR
Attach backup as a block device errors +++ ALIGNED VALUE TO 54000
PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL
PRL_ERR_ATTACH_BACKUP_PROTO_ERROR
PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED
PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED
PRL_ERR_BACKUP_ACRONIS_ERR
PRL_ERR_BACKUP_BACKUP_CMD_FAILED
PRL_ERR_BACKUP_BACKUP_NOT_FOUND
PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND
PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS
PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED
PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST
PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_INTERNAL_ERROR
PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR
VM Backup errors +++ ALIGNED VALUE TO 37000
PRL_ERR_BACKUP_LOCKED_FOR_READING
PRL_ERR_BACKUP_LOCKED_FOR_WRITING
PRL_ERR_BACKUP_REGISTER_VM_FAILED
PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED
PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD
PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_RESTORE_CMD_FAILED
PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR
PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR
PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED
PRL_ERR_BACKUP_RESTORE_VM_RUNNING
PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM
PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED
PRL_ERR_BACKUP_TIMEOUT_EXCEEDED
PRL_ERR_BACKUP_TOOL_CANNOT_START
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_BUSE_ENTRY_ALREADY_EXIST
PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED
PRL_ERR_BUSE_ENTRY_INVALID
PRL_ERR_BUSE_ENTRY_IO_ERROR
PRL_ERR_BUSE_INTERNAL_ERROR
PRL_ERR_BUSE_NOT_MOUNTED
BUSE filesystem errors +++ ALIGNED VALUE TO 52000
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE
PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_HOST_ID
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY
PRL_ERR_CANT_CONVERT_CONFIG
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_DISK_IMAGE
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE
PRL_ERR_CANT_RECONFIG_GUEST_OS
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_RESIZE_HDD
PRL_ERR_CANT_RESOLVE_HOSTNAME
PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT
PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER
PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UNPACK_ARCHIVE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CHANGESID_FAILED
Vm changeSID errors +++ ALIGNED VALUE TO 41200
PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_CHANGESID_NOT_AVAILABLE
PRL_ERR_CHANGESID_NOT_SUPPORTED
PRL_ERR_CHANGESID_VM_START_FAILED
PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM
PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL
Copy device image errors +++ ALIGNED VALUE TO 46700
PRL_ERR_CI_PERMISSIONS_DENIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_CLUSTER_RESOURCE_ERROR
Cluster resource manipulation errors +++ ALIGNED VALUE TO 46900
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_COMPACT_ALREADY_SWITCHED_ON
PRL_ERR_COMPACT_WRONG_VM_STATE
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN
PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED
PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED
PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN
confirmation errors +++ ALIGNED VALUE TO 41100
PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED
PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID
PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED
PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED
PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID
PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED
PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL
PRL_ERR_CONNECT_TO_MOUNTER
PRL_ERR_CONV_HD_CONFLICT
PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED
PRL_ERR_CONV_HD_EXIT_WITH_ERROR
PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION
PRL_ERR_CONV_HD_WRONG_VM_STATE
Convert disks task errors +++ ALIGNED VALUE TO 41600
PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED
Vm convert errors +++ ALIGNED VALUE TO 41300
PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE
PRL_ERR_CONVERT_EFI_CONFIG_INVALID
PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED
PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND
PRL_ERR_CONVERT_NO_GUEST_OS_FOUND
PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR
PRL_ERR_COPY_VM_INFO_FILE
PRL_ERR_CORE_STATE_CANCELLED
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON
  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000
PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_CORE_STATE_NO_FILE
PRL_ERR_CORE_STATE_VM_WOULD_RESTART
PRL_ERR_CORE_STATE_VM_WOULD_STOP
PRL_ERR_COULD_NOT_START_FIREWALL_TOOL
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_BOOTABLE_ISO
Unattended ISO errors +++ ALIGNED VALUE TO 40000
PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_CT_IS_RUNNING
PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST
PRL_ERR_CT_MIGRATE_INTERNAL_ERROR
PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS
PRL_ERR_CT_NOT_FOUND
PRL_ERR_CVSRC_IO_ERROR
Captured Video Source errors +++ ALIGNED VALUE TO 46800
PRL_ERR_CVSRC_NO_CHANNEL
PRL_ERR_CVSRC_NO_OPEN_REQUEST
PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_DEACTIVATE_TRIAL_LICENSE
PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND
PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_DEACTIVATION_SERVER_ERROR
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_DELETE_UNFINISHED_STATE_FAILED
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED
  • Common Devices Errors

+++ ALIGNED VALUE TO 9000
PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED
  • Other

+++ ALIGNED VALUE TO 10000
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED
  • Parallel Port

+++ ALIGNED VALUE TO 7000
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_PRINTER_OVERFLOW
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED
  • Serial Port

+++ ALIGNED VALUE TO 6000
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_BUSY
PRL_ERR_DEV_USB_CHANGEPID
PRL_ERR_DEV_USB_CONNECT_DENIED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_NOT_CONFIGURED
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED
  • USB

+++ ALIGNED VALUE TO 8000
PRL_ERR_DEV_USB_REUSE
PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND
  • User parameters errors
* +++ ALIGNED VALUE TO 23000
PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR
  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000
PRL_ERR_DISK_GET_MOUNTPATH_FAILED
  • Bootcamp errors
* +++ ALIGNED VALUE TO 24000
PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GET_SIZE_FAILED
PRL_ERR_DISK_GPT_MBR_NOT_EQUAL
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_MOUNTED_OVERLAP
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_RESIZE_FAILED
PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW
PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED
PRL_ERR_DISK_RESIZER_NOT_FOUND
VM image resizer errors +++ ALIGNED VALUE TO 41000
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SET_FILE_SIZE_FAILED
PRL_ERR_DISK_SHARED_BLOCK
  • Compressing errors
* +++ ALIGNED VALUE TO 22000
PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TOOL_NOT_FOUND
PRL_ERR_DISK_TOOL_PROCESS_ERROR
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNCOMMITED_OPERATION
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_DIFFERS_FROM_REAL
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_MISSING
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_PARTITION_NOT_FOUND
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE
PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED
PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP_VM_IS_NOT_STOPPED
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED
PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_HDD_CANT_OPEN
PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED
PRL_ERR_ENC_HDD_IS_UNENCRYPTED
PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE
PRL_ERR_ENC_KEY_NOT_SET
  • Encryption engine errors

+++ ALIGNED VALUE TO 43000
PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED
PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY
PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE
PRL_ERR_ENC_WRONG_HDD_PASSWORD
PRL_ERR_ENC_WRONG_KEY
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_EXT_DISK_ALREADY_EXISTS
PRL_ERR_EXT_DISK_CANT_RENAME
PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER
PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FAILURE_ON_VM_DESTROYED
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF
File Manager errors +++ ALIGNED VALUE TO 51000
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED
  • File Transfer errors

+++ ALIGNED VALUE TO 26000
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FILECOPY_CANT_CREATE_DIR
PRL_ERR_FILECOPY_CANT_OPEN_FILE
PRL_ERR_FILECOPY_CANT_WRITE
PRL_ERR_FILECOPY_DIR_EXIST
PRL_ERR_FILECOPY_FILE_EXIST
PRL_ERR_FILECOPY_INTERNAL
PRL_ERR_FILECOPY_PROTOCOL
PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_DISK_FREE_SPACE_FAILED
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_GUEST_USB_REQUIRED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HTTP_AUTH_REQUIRED
PRL_ERR_HTTP_CONNECTION_REFUSED
PRL_ERR_HTTP_HOST_NOT_FOUND
Problem report send errors set +++ ALIGNED VALUE TO 38000
PRL_ERR_HTTP_INVALID_RESPONSE_HEADER
PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE
PRL_ERR_HTTP_PROXY_AUTH_REQUIRED
PRL_ERR_HTTP_REQUEST_FAILED
PRL_ERR_HTTP_UNEXPECTED_CLOSE
PRL_ERR_HTTP_WRONG_CONTENT_LENGTH
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_DISABLED_WARNING
PRL_ERR_HVT_NOT_AVAILABLE_WARNING
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_NOT_PRESENT_WARNING
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IAP_INVALID_PRODUCT_ID
PRL_ERR_IAP_PAYMENT_FAILED
PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED
PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED
PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID
PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED
PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED
PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED
PRL_ERR_IAP_STORE_NO_CONNECTION
InApp purchase errors +++ ALIGNED VALUE TO 48000
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED
PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ACTION_REQUESTED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_GUARANTEE
PRL_ERR_INVALID_MEMORY_QUOTA
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_OS_TYPE
PRL_ERR_INVALID_PARALLELS_DISK
  • Hard Drive

+++ ALIGNED VALUE TO 2000
PRL_ERR_INVALID_PARAM
PRL_ERR_INVALID_TOTAL_LIMIT
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IOSERVICE_COMPRESS
PRL_ERR_IPC_ATTACH_FAILED
PRL_ERR_IPC_CREATE_MAP_FAILED
PRL_ERR_IPC_FTOK_FAILED
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED
  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED
PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT
PRL_ERR_ISCSI_STORAGE_CREATE
PRL_ERR_ISCSI_STORAGE_EXTEND
PRL_ERR_ISCSI_STORAGE_GET_STATE
PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE
PRL_ERR_ISCSI_STORAGE_LIBRARY
iscsi storages errors +++ ALIGNED VALUE TO 44400
PRL_ERR_ISCSI_STORAGE_MOUNT
PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS
PRL_ERR_ISCSI_STORAGE_MOUNTED
PRL_ERR_ISCSI_STORAGE_NOT_FOUND
PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED
PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED
PRL_ERR_ISCSI_STORAGE_REMOVE
PRL_ERR_ISCSI_STORAGE_START
PRL_ERR_ISCSI_STORAGE_UMOUNT
PRL_ERR_IT_CANT_COMPACT
compact
PRL_ERR_IT_CANT_COMPACT_LDM_DISK
PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK
PRL_ERR_IT_CANT_GET_BITMAP
PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE
PRL_ERR_IT_CANT_OPEN_IMAGE
PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_IT_CANT_RECONFIG
PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP
PRL_ERR_IT_CANT_RESIZE_LDM_DISK
PRL_ERR_IT_CANT_RESIZE_VOLUME
resize
PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP
reconfig
PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR
convert
PRL_ERR_IT_DISK_SMALL_FOR_SPLIT
PRL_ERR_IT_FAST_RESIZE_FAILURE
PRL_ERR_IT_FIRST_ERROR
ALIGNED VALUE TO 46200
PRL_ERR_IT_FIRST_FAILURE
ALIGNED VALUE TO 46100
PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE
PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE
guest tools
PRL_ERR_IT_HAL_NOT_FOUND
PRL_ERR_IT_RECONFIG_PATH_NEEDED
PRL_ERR_IT_ROLLBACK_FAILURE
PRL_ERR_IT_SIZE_CHANGED
PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED
merge
PRL_ERR_IT_UNKNOWN_OS
PRL_ERR_IT_USER_INTERRUPTED
PRL_ERR_LIC_REGISTRATION_COMMON_ERROR
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_BLACKLISTED
PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION
PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_GRACED
PRL_ERR_LICENSE_IS_NOT_VOLUME
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT
PRL_ERR_LICENSE_RESTRICTED_GUEST_OS
PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER
PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH
PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM
PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE
PRL_ERR_LICENSE_TOO_MANY_MEMORY
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION
PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID
  • License

+++ ALIGNED VALUE TO 11000
PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM
PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM
PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND
PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE
PRL_ERR_LOW_MEMORY_LIMIT
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_MEM_EXCEED_PHY_SPACE
PRL_ERR_MEMFILE_DECRYPT_FAILED
PRL_ERR_MEMFILE_ENCRYPT_FAILED
PRL_ERR_MEMORY_ALLOC_ERROR
PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT
PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE
  • MobileFileSharing (MFS) errors

+++ ALIGNED VALUE TO 55000
PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED
PRL_ERR_MOUNTER_LIST_NO_OBJECT
PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ADAPTER_NOT_FOUND
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_GUEST_OS_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_UNATTENDED_DISK
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE
PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK
PRL_ERR_NOT_SENTILLION_CLIENT
Sentillion errors +++ ALIGNED VALUE TO 39000
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_BAD_INTERFACE
PRL_ERR_OBJECT_CLASS_NOT_FOUND
PRL_ERR_OBJECT_DUPLICATE_CLASS
PRL_ERR_OBJECT_DUPLICATE_UID
PRL_ERR_OBJECT_LIB_CANT_GET_PERMS
PRL_ERR_OBJECT_LIB_LOAD_ERROR
PRL_ERR_OBJECT_LIB_NO_FUNCTIONS
PRL_ERR_OBJECT_LIB_WRONG_PERMS
PRL_ERR_OBJECT_NOT_FOUND
  • Shared objects manipulation errors

+++ ALIGNED VALUE TO 42000
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_FAILED
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OS_RECONFIG_DATA_ABSENT
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARALLEL_PORT_NO_RASTERIZER
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED
PRL_ERR_PATH_IS_NOT_DIRECTORY
PRL_ERR_PAX_ACCESS_FORBIDDEN
PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED
PRL_ERR_PAX_LOGIN_MISMATCH_ERROR
PRL_ERR_PCMOVER_EXEC_FAILED
PRL_ERR_PCMOVER_MIGRATE_FAILED
PRL_ERR_PCMOVER_NOT_INSTALLED
PCmover managment library errors +++ ALIGNED VALUE TO 43100
PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR
PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR
PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED
PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST
PRL_ERR_PERFORM_MOUNTER_COMMAND
PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE
PRL_ERR_PPC_INVALID_CREDENTIALS
  • Proxy connection errors

+++ ALIGNED VALUE TO 600
PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT
PRL_ERR_PPC_SERVER_BUSY
PRL_ERR_PPC_UNABLE_TO_CONNECT
PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_PROXY_HANDSHAKE_FAILED
PRL_ERR_PROXY_PEER_NOT_FOUND
PRL_ERR_PROXY_WRONG_PORT_NUMBER
PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION
PRL_ERR_RCC_CONNECT_DESKTOP_ERROR
PRL_ERR_RCC_CONNECT_SERVER_ERROR
PRL_ERR_RCC_DESKTOP_SUSPENDED
PRL_ERR_RCC_DEVICE_BLACKLISTED
PRL_ERR_RCC_DEVICE_GREYLISTED
PRL_ERR_RCC_OPEN_APP_ERROR
PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED
PRL_ERR_RCC_PAX_LOGIN_ERROR
RCC errors +++ ALIGNED VALUE TO 49000
PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED
PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE
PRL_ERR_RCC_WAKEUP_SERVER_ERROR
PRL_ERR_READ_FAILED
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS
PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_RUN_VM_ACTION_SCRIPT
PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC
PRL_ERR_SAMPLE_CONFIG_NOT_FOUND
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SDK_TRY_AGAIN
SDK errors +++ ALIGNED VALUE TO 50000
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SERVICE_BUSY
PRL_ERR_SET_CPULIMIT
Virtuozzo specific error +++ ALIGNED VALUE TO 44000
PRL_ERR_SET_CPUMASK
PRL_ERR_SET_CPUUNITS
PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED
PRL_ERR_SET_IOLIMIT
PRL_ERR_SET_IOPRIO
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SET_NETWORK_SETTINGS_FAILED
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED
PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_BAD_EMULATION_TYPE
PRL_ERR_SOUND_DEVICE_WRITE_FAILED
  • Sound

+++ ALIGNED VALUE TO 5000
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_STAND_BY_VM_PAUSED
PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_START_SAFE_MODE_UNSUPPORTED
PRL_ERR_START_VM_BY_NOT_AUTH_USER
PRL_ERR_START_VM_BY_NOT_DEFINED_USER
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR
  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000
PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK
PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED
PRL_ERR_SUSPEND_REJECTED_BY_GUEST
PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_SUSPEND_VM_VTD_PAUSED
VM error codes +++ ALIGNED VALUE TO 36000
PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_WITH_USB_BOOTDISK
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TEMPLATE_HAS_APPS
containers templates errors +++ ALIGNED VALUE TO 46400
PRL_ERR_TEMPLATE_NOT_FOUND
PRL_ERR_TEST_TEXT_MESSAGES
Test errors +++ ALIGNED VALUE TO 43200
PRL_ERR_TEST_TEXT_MESSAGES_PS
PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID
  • TIS errors

+++ ALIGNED VALUE TO 27800
PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE
PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS
PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION
PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED
PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION
PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE
PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED
PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD
PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION
PRL_ERR_UNABLE_TO_SEND_REQUEST
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER
PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED
PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNNAMED_CT_MOVE
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE
VI convert errors +++ ALIGNED VALUE TO 45000
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG
  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000
PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG
  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000
PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_ENCRYPTED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN
PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_HARD_DISK_FAILED
PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS
PRL_ERR_VM_COMPACT_PROCESSING
  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED
PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED
PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE
PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE
PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE
PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_FROZEN_STATE
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_IN_WAKING_UP_STATE
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED
PRL_ERR_VM_IS_NOT_LOCKED
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LIFETIME_IS_EXPIRED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP
PRL_ERR_VM_LOCKED_FOR_BACKUP
PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL
PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD
PRL_ERR_VM_LOCKED_FOR_CLONE
Dispatcher 'locked' error codes +++ ALIGNED VALUE TO 38100
PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DECRYPT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT
PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT
PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_ENCRYPT
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_MOVE
PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION
PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP
PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED
PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION
PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY
PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM
PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM
PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED
PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED
PRL_ERR_VM_MIGRATE_RESUME_FAILED
PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE
PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED
PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE
PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MOUNT
VM hdd mount/umount +++ ALIGNED VALUE TO 46600
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW
PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SHUTDOWN_FAILED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED
PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED
PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SNAPSHOT_NOT_FOUND
PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOL_NOT_AVAILABLE
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UNMOUNT
PRL_ERR_VM_UNPAUSE_FAILED
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
Unused PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_MASK_INVALID
PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND
PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE is unused
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT
PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS
PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT
PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET
PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME
PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS
PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT
ALIGNED VALUE TO 27770
PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT
PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE
PRL_ERR_VMCONF_RESTRICTED_OS_VERSION
  • Validation VM configuration error

+++ ALIGNED VALUE TO 26500
PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD
PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS
PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
+++ ALIGNED VALUE TO 27550 +++ Unused PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
Unused PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED
ALIGNED VALUE TO 27000
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED
PRL_ERR_VMCONF_VIDEO_NOT_ENABLED
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VMHELPER_CREATEVM_FAILED
STW7 VmHelper errors +++ ALIGNED VALUE TO 41400
PRL_ERR_VMHELPER_DIR_PATH_INVALID
PRL_ERR_VMHELPER_DISK_MOUNT_FAILED
PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED
PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST
PRL_ERR_VTD_DEVICE_NOT_MAPPED
  • VT-d

+++ ALIGNED VALUE TO 12000
PRL_ERR_VTD_DEVICE_TROUBLESHOOT
PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT
PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT
PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_INSTALLATION_FAILED
PRL_ERR_VTD_HOOK_INVALID_CONFIG
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_HOOK_REVERT_FAILED
PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_VZ_API_NOT_INITIALIZED
PRL_ERR_VZ_OPERATION_FAILED
PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND
PRL_ERR_VZCTL_OPERATION_FAILED
PRL_ERR_VZLICENSE_ACTIVATION_KEY
PRL_ERR_VZLICENSE_CANCEL
PRL_ERR_VZLICENSE_EACCES
PRL_ERR_VZLICENSE_ERR_KA
PRL_ERR_VZLICENSE_EXIST
PRL_ERR_VZLICENSE_FATAL
PRL_ERR_VZLICENSE_INVAL
PRL_ERR_VZLICENSE_INVALID_HWID
PRL_ERR_VZLICENSE_IO
PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED
PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH
PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED
PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET
PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED
PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE
PRL_ERR_VZLICENSE_LOCK
PRL_ERR_VZLICENSE_NETWORK
PRL_ERR_VZLICENSE_NODATA
PRL_ERR_VZLICENSE_NOENT
PRL_ERR_VZLICENSE_NOINIT
PRL_ERR_VZLICENSE_NOMEM
PRL_ERR_VZLICENSE_NOTSUP
PRL_ERR_VZLICENSE_PROXY
PRL_ERR_VZLICENSE_PROXY_AUTH
PRL_ERR_VZLICENSE_TASK_ALREADY_RUN
PRL_ERR_VZLICENSE_TIMEOUT
PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP
PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED
PRL_ERR_VZLICENSE_WRONG
PRL_ERR_WEB_PORTAL_ACCEPTED
PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS
PRL_ERR_WEB_PORTAL_BAD_REQUEST
errors
PRL_ERR_WEB_PORTAL_CONFLICT
PRL_ERR_WEB_PORTAL_CREATED
PRL_ERR_WEB_PORTAL_FORBIDDEN
PRL_ERR_WEB_PORTAL_INVALID_EMAIL
PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS
PRL_ERR_WEB_PORTAL_INVALID_PASSWORD
PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED
PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED
PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_NO_CONTENT
PRL_ERR_WEB_PORTAL_NOT_FOUND
PRL_ERR_WEB_PORTAL_OK
success
PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED
PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT
PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL
PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT
PRL_ERR_WEB_PORTAL_UNAUTHORIZED
PRL_ERR_WEB_PORTAL_UNEXPECTED
PRL_ERR_WIN_AERO_DISABLED
isn't used now
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRITE_FAILED
PRL_ERR_WRONG_CIPHER_ID_FORMAT
PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT
PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM
Encryption Vm errors +++ ALIGNED VALUE TO 44200
PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WRONG_TRANSACTION_STATE
PRL_ERR_WRONG_VM_STATE
PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP
PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE
PRL_ERR_XMLRPC_INTERNAL_ERROR
PRL_ERR_XMLRPC_INVALID_CREDENTIALS
PRL_ERR_XMLRPC_INVALID_REQUEST_INFO
PRL_ERR_XMLRPC_LIMITS_EXHAUSTED
PRL_ERR_XMLRPC_WRONG_METHOD_CALL
Links
Macros, Macros


PRL_PTM Macros

PRL_PTM Macros
Macros Macros
Macros
Name | Description
PRL_PTM_DECLARE_PROPERTY |
PRL_PTM_INIT_PROPERTY |
PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS | Objects Section
PRL_PTM_NAMESPACE_APPMNG_CHANNELS |
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM |
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS |
PRL_PTM_NAMESPACE_APPMNG_IMAGES |
PRL_PTM_NAMESPACE_APPMNG_OPERATIONS |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES |
PRL_PTM_NAMESPACE_APPMNG_PROCESSES |
PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE |
PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON | RPC section
PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL |
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT |
PRL_PTM_NAMESPACE_APPMNG_SHARES |
PRL_PTM_NAMESPACE_DESKTOP |
PRL_PTM_NAMESPACE_DESKTOP_CLIENT |
PRL_PTM_NAMESPACE_DESKTOP_MENU |
PRL_PTM_NAMESPACE_DESKTOP_SESSION |
PRL_PTM_NAMESPACE_DESKTOP_UI |
PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES |
PRL_PTM_NAMESPACE_HINTING |
PRL_PTM_NAMESPACE_HINTING_SELECTION |
PRL_PTM_NAMESPACE_INPUT |
PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD |
PRL_PTM_NAMESPACE_INPUT_CARET |
PRL_PTM_NAMESPACE_INPUT_CURSOR |
PRL_PTM_NAMESPACE_INPUT_INFO |
PRL_PTM_NAMESPACE_PRIVATE |
PRL_PTM_NAMESPACE_RPC | namespace definitions
PRL_PTM_NAMESPACE_RPC_CANCEL |
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER |
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE |
PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW |
PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE |
PRL_PTM_NAMESPACE_RPC_HINTING_CARET |
PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP |
PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON |
PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION |
PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE |
PRL_PTM_NAMESPACE_RPC_QUERY |
PRL_PTM_NAMESPACE_RPC_SET |
PRL_PTM_NAMESPACE_RPC_SUBSCRIBE |
Links
Macros, Macros


PRL_SCAN_CODE Macros

PRL_SCAN_CODE Macros
Macros Macros
Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_APP_CALCULATOR |
PRL_SCAN_CODE_APP_MAIL |
PRL_SCAN_CODE_APP_MY_COMPUTER |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_BRAZILIAN_KEYPAD |
PRL_SCAN_CODE_BREAK |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOLLAR |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_EJECT |
PRL_SCAN_CODE_END |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | PS/2 scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_EURO |
PRL_SCAN_CODE_EUROPE_1 |
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F13 |
PRL_SCAN_CODE_F14 |
PRL_SCAN_CODE_F15 |
PRL_SCAN_CODE_F16 |
PRL_SCAN_CODE_F17 |
PRL_SCAN_CODE_F18 |
PRL_SCAN_CODE_F19 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F20 |
PRL_SCAN_CODE_F21 |
PRL_SCAN_CODE_F22 |
PRL_SCAN_CODE_F23 |
PRL_SCAN_CODE_F24 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_HANGUEL |
PRL_SCAN_CODE_HANJA |
PRL_SCAN_CODE_HENKAN |
PRL_SCAN_CODE_HIRAGANA |
PRL_SCAN_CODE_HIRAGANA_KATAKANA |
PRL_SCAN_CODE_HOME |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_KATAKANA |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_LESS_GREATER |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MEDIA_NEXT_TRACK |
PRL_SCAN_CODE_MEDIA_PLAY_PAUSE |
PRL_SCAN_CODE_MEDIA_PREV_TRACK |
PRL_SCAN_CODE_MEDIA_SELECT |
PRL_SCAN_CODE_MEDIA_STOP |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_MUHENKAN |
PRL_SCAN_CODE_MUTE |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_EQUAL |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAGE_DOWN |
PRL_SCAN_CODE_PAGE_UP |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PC9800_KEYPAD |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_PRINT_SCREEN2 |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_RO |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_SYSRQ |
PRL_SCAN_CODE_SYSTEM_POWER |
PRL_SCAN_CODE_SYSTEM_SLEEP |
PRL_SCAN_CODE_SYSTEM_WAKE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_VOLUME_DOWN |
PRL_SCAN_CODE_VOLUME_UP |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_WWW_BACK |
PRL_SCAN_CODE_WWW_FAVORITES |
PRL_SCAN_CODE_WWW_FORWARD |
PRL_SCAN_CODE_WWW_HOME |
PRL_SCAN_CODE_WWW_REFRESH |
PRL_SCAN_CODE_WWW_SEARCH |
PRL_SCAN_CODE_WWW_STOP |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_YEN |
PRL_SCAN_CODE_Z |
PRL_SCAN_CODE_ZENKAKU_HANKAKU |
Links
Macros, Macros


PVS_GUEST Macros

PVS_GUEST Macros
Macros Macros
Macros
Name | Description
PRL_GUEST_CPU_USAGE_PTRN | Guest OS CPU usage in percents (modulated to 100%)
PRL_GUEST_RAM_CACHED_PTRN |
PRL_GUEST_RAM_USAGE_PTRN | Guest OS RAM usage in megabytes
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_ANDROID |
PVS_GUEST_TYPE_CHROMEOS |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_ANDROID |
PVS_GUEST_TYPE_NAME_CHROMEOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_ANDROID_2_x |
PVS_GUEST_VER_ANDROID_3_x |
PVS_GUEST_VER_ANDROID_4_0 |
PVS_GUEST_VER_ANDROID_LAST |
PVS_GUEST_VER_ANDROID_OTHER |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_8X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_CHROMEOS_1x |
PVS_GUEST_VER_CHROMEOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_CHROMEOS_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_CENTOS_7 |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MAGEIA |
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_MINT |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_PSBM |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_REDHAT_7 |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_MACOS_UNIVERSAL |
PVS_GUEST_VER_NAME_ANDROID_4_0 |
PVS_GUEST_VER_NAME_ANDROID_OTHER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_8X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_CHROMEOS_1x |
PVS_GUEST_VER_NAME_CHROMEOS_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_FREE_BSD |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MAGEIA |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_MINT |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_PSBM |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_BSD |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OPEN_BSD |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OPEN |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_TRUSTED_BSD |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2012 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS_10 |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_WINDOWS8 |
PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_BSD |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OPEN_BSD |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OPEN | OpenSolaris
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_TRUSTED_BSD |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2012 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS_10 |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_WINDOWS8 |
PVS_GUEST_VER_WIN_WINDOWS8_1 |
PVS_GUEST_VER_WIN_XP |
Links
Macros, Macros


Functions

Functions
Functions Legend Topics
Functions
Name | Description
PrlSessionInfo_Create | Creates a new handle of type PHT_SESSION_INFO.
PrlStatVmData_GetSegmentCapacity | Returns VM data segment capacity in bytes.
Topics
Name | Description
Unknown or Unneeded |
Links
Functions, Legend, Topics


Functions

Functions
Functions Legend
Functions
Name | Description
PrlSessionInfo_Create | Creates a new handle of type PHT_SESSION_INFO.
PrlStatVmData_GetSegmentCapacity | Returns VM data segment capacity in bytes.


Functions

Legend
Legend
Method


Legend

Legend
Functions
Legend
Method


Topics

Topics
Functions
Topics
Name | Description
Unknown or Unneeded |


Topics

Topics
Macros
Topics
Name | Description
__Parallels_API Macros |
__PTM Macros |
GUI_ERR Macros |
GUI_INFO Macros |
Other Macros |
PET Macros |
PRL_DISK Macros |
PRL_ERR Macros |
PRL_PTM Macros |
PRL_SCAN_CODE Macros |
PVS_GUEST Macros |


Topics

Topics
Structs, Records, Enums
Topics
Name | Description
PRL_IO Structs |
PRL_VM Structs |
Other Structs |


Topics

Topics
Types
Topics
Name | Description
PRL_BOOL Types |
PRL_CHAR Types |
PRL_CONST Types |
PRL_DEVICE Types |
PRL_DISK Types |
PRL_DOUBLE Types |
PRL_FILE Types |
PRL_INT Types |
PRL_IO Types |
PRL_TIS Types |
PRL_TOOLS Types |
PRL_UINT Types |
PRL_VM Types |
PRL_VOID Types |
Other Types |


__Parallels_API Macros Macros

__Parallels_API Macros Macros
__Parallels_API Macros
Macros
Name | Description
__PARALLELS_API_APP_MANAGER_ENUMS_H__ |
__PARALLELS_API_COMMANDS_FLAGS_H__ |
__PARALLELS_API_CORE_H__ |
__PARALLELS_API_DESKTOP_PARAMETERS_H__ |
__PARALLELS_API_DISPATCHER_H__ |
__PARALLELS_API_INPUT_EMU_H__ |
__PARALLELS_API_MANAGER_H__ |
__PARALLELS_API_NET_H__ |
__PARALLELS_API_PORTS_H__ |
__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__ |
__PARALLELS_API_PTM_H__ |
__PARALLELS_API_PTM_TYPES_H__ |
__PARALLELS_API_REMOTE_DEV_H__ |
__PARALLELS_API_SECURITY_H__ |
__PARALLELS_API_STATISTIC_H__ |
__PARALLELS_API_VIDEO_RECEIVER_H__ |
__PARALLELS_API_VM_H__ |


__PTM Macros Macros

__PTM Macros Macros
__PTM Macros
Macros
Name | Description
__PTM_ACCESS |
__PTM_ACCESS_IN |
__PTM_ACCESS_INOUT |
__PTM_ACCESS_N | N,R,W,RW access for data objects; IN,OUT,INOUT for procedural objects
__PTM_ACCESS_OUT |
__PTM_ACCESS_R |
__PTM_ACCESS_RW |
__PTM_ACCESS_W |
__PTM_SEND |
__PTM_SEND_ALL | properties delivery control on property change/query: is default mark to deliver most recent property values, discarding property changes that have not been sent yet and waiting in send queue.
__PTM_SEND_NOSELF |
__PTM_SEND_PRI |
__PTM_SEND_PRI_HIGH |
__PTM_SEND_PRI_IDLE | objects may be splitted on parts and delivered with appropriate sending priority
__PTM_SEND_PRI_LOW |
__PTM_SEND_PRI_NORMAL |
__PTM_SEND_STREAM |
__PTM_TYPE |
__PTM_TYPE_BIN |
__PTM_TYPE_I32 | proeprty types
__PTM_TYPE_I64 |
__PTM_TYPE_STR |
__PTM_TYPE_STRLST |
__PTM_TYPE_STRUCT |
__PTM_TYPE_U32 |
__PTM_TYPE_U64 |


__PARALLELS_API_APP_MANAGER_ENUMS_H__ Macro

__PARALLELS_API_APP_MANAGER_ENUMS_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_APP_MANAGER_ENUMS_H__
File

PrlApiAppManagerEnums.h

Links
__Parallels_API Macros


__PARALLELS_API_COMMANDS_FLAGS_H__ Macro

__PARALLELS_API_COMMANDS_FLAGS_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_COMMANDS_FLAGS_H__
File

PrlCommandsFlags.h

Links
__Parallels_API Macros


__PARALLELS_API_CORE_H__ Macro

__PARALLELS_API_CORE_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_CORE_H__
File

PrlApiCore.h

Links
__Parallels_API Macros


__PARALLELS_API_DESKTOP_PARAMETERS_H__ Macro

__PARALLELS_API_DESKTOP_PARAMETERS_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_DESKTOP_PARAMETERS_H__
File

PrlApiDesktopParameters.h

Links
__Parallels_API Macros


__PARALLELS_API_DISPATCHER_H__ Macro

__PARALLELS_API_DISPATCHER_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_DISPATCHER_H__
File

PrlApiDisp.h

Links
__Parallels_API Macros


__PARALLELS_API_INPUT_EMU_H__ Macro

__PARALLELS_API_INPUT_EMU_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_INPUT_EMU_H__
File

PrlApiInputEmu.h

Links
__Parallels_API Macros


__PARALLELS_API_MANAGER_H__ Macro

__PARALLELS_API_MANAGER_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_MANAGER_H__
File

PrlApiManager.h

Links
__Parallels_API Macros


__PARALLELS_API_NET_H__ Macro

__PARALLELS_API_NET_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_NET_H__
File

PrlApiNet.h

Links
__Parallels_API Macros


__PARALLELS_API_PORTS_H__ Macro

__PARALLELS_API_PORTS_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_PORTS_H__
File

PrlPorts.h

Links
__Parallels_API Macros


__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__ Macro

__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_PRIVATE_ERRORS_VALUES_H__
File

PrlPrivateErrorsValues.h

Links
__Parallels_API Macros


__PARALLELS_API_PTM_H__ Macro

__PARALLELS_API_PTM_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_PTM_H__
File

PrlApiPtm.h

Links
__Parallels_API Macros


__PARALLELS_API_PTM_TYPES_H__ Macro

__PARALLELS_API_PTM_TYPES_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_PTM_TYPES_H__
File

PrlApiPtmTypes.h

Links
__Parallels_API Macros


__PARALLELS_API_REMOTE_DEV_H__ Macro

__PARALLELS_API_REMOTE_DEV_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_REMOTE_DEV_H__
File

PrlApiRemoteDev.h

Links
__Parallels_API Macros


__PARALLELS_API_SECURITY_H__ Macro

__PARALLELS_API_SECURITY_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_SECURITY_H__
File

PrlApiSecurity.h

Links
__Parallels_API Macros


__PARALLELS_API_STATISTIC_H__ Macro

__PARALLELS_API_STATISTIC_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_STATISTIC_H__
File

PrlApiStat.h

Links
__Parallels_API Macros


__PARALLELS_API_VIDEO_RECEIVER_H__ Macro

__PARALLELS_API_VIDEO_RECEIVER_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_VIDEO_RECEIVER_H__
File

PrlApiVideoReceiver.h

Links
__Parallels_API Macros


__PARALLELS_API_VM_H__ Macro

__PARALLELS_API_VM_H__ Macro
__Parallels_API Macros
Syntax
#define __PARALLELS_API_VM_H__
File

PrlApiVm.h

Links
__Parallels_API Macros


__PARALLELS_PERF_COUNTERS_H__ Macro

__PARALLELS_PERF_COUNTERS_H__ Macro
Other Macros
Syntax
#define __PARALLELS_PERF_COUNTERS_H__
File

PrlPerfCounters.h

Links
Other Macros


__PRL_DISK_PARAMETERS Structure

__PRL_DISK_PARAMETERS Structure
Other Structs

Parallels disk parameters.

Syntax
struct __PRL_DISK_PARAMETERS {
  PRL_UINT32 m_Heads;
  PRL_UINT32 m_Cylinders;
  PRL_UINT32 m_Sectors;
  PRL_UINT64 m_SizeInSectors;
  PRL_UINT32 m_BlockSize;
  PRL_UINT32 m_Parts;
  PRL_IMAGE_PARAMETERS_PTR m_Storages;
  PRL_GUID Uid;
  PRL_CHAR_PTR Name;
};
File

PrlDisk.h

Members

m_Storages
Following parameters are available only at SDK v3.

Remarks

Differs from internal due to lists classes

Links
Other Structs


__PRL_IMAGE_PARAMETERS Structure

__PRL_IMAGE_PARAMETERS Structure
Other Structs

Parallels storage parameters

Syntax
struct __PRL_IMAGE_PARAMETERS {
  PRL_IMAGE_TYPE Type;
  PRL_UINT64 uStart;
  PRL_UINT64 uSize;
  PRL_CHAR_PTR pFileName;
};
File

PrlDisk.h

Links
Other Structs


__PRL_PLUGINS_CLASSES_DEFINED__ Macro

__PRL_PLUGINS_CLASSES_DEFINED__ Macro
Other Macros
Syntax
#define __PRL_PLUGINS_CLASSES_DEFINED__
File

PrlPluginClasses.h

Links
Other Macros


__PRL_SNAPSHOT_ELEMENT Structure

__PRL_SNAPSHOT_ELEMENT Structure
Other Structs

Parallels snapshot tree element

Syntax
struct __PRL_SNAPSHOT_ELEMENT {
  PRL_GUID m_GUID;
  struct __PRL_SNAPSHOT_ELEMENT* m_pNext;
  struct __PRL_SNAPSHOT_ELEMENT* m_pChild;
};
File

PrlDisk.h

Links
Other Structs


__PTM_ACCESS Macro

__PTM_ACCESS Macro
__PTM Macros
Syntax
#define __PTM_ACCESS 0xE0000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_IN Macro

__PTM_ACCESS_IN Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_IN 0x80000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_INOUT Macro

__PTM_ACCESS_INOUT Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_INOUT 0xE0000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_N Macro

__PTM_ACCESS_N Macro
__PTM Macros

N,R,W,RW access for data objects; IN,OUT,INOUT for procedural objects

Syntax
#define __PTM_ACCESS_N 0x00000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_OUT Macro

__PTM_ACCESS_OUT Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_OUT 0x60000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_R Macro

__PTM_ACCESS_R Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_R 0x40000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_RW Macro

__PTM_ACCESS_RW Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_RW 0xC0000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_ACCESS_W Macro

__PTM_ACCESS_W Macro
__PTM Macros
Syntax
#define __PTM_ACCESS_W 0x80000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND Macro

__PTM_SEND Macro
__PTM Macros
Syntax
#define __PTM_SEND 0x1C000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_ALL Macro

__PTM_SEND_ALL Macro
__PTM Macros

properties delivery control on property change/query: is default mark to deliver most recent property values, discarding property changes that have not been sent yet and waiting in send queue.

Syntax
#define __PTM_SEND_ALL 0x04000000
File

PrlApiPtmTypes.h

Remarks

ALL: should be used when property requires tracking of ALL its changes. NOSELF: property changes made by client should NOT be broadcasted back to that client STREAM: binary property can be delivered in chunks, instead of gathering full original property

Links
__PTM Macros


__PTM_SEND_NOSELF Macro

__PTM_SEND_NOSELF Macro
__PTM Macros
Syntax
#define __PTM_SEND_NOSELF 0x08000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_PRI Macro

__PTM_SEND_PRI Macro
__PTM Macros
Syntax
#define __PTM_SEND_PRI 0x03000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_PRI_HIGH Macro

__PTM_SEND_PRI_HIGH Macro
__PTM Macros
Syntax
#define __PTM_SEND_PRI_HIGH 0x03000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_PRI_IDLE Macro

__PTM_SEND_PRI_IDLE Macro
__PTM Macros

objects may be splitted on parts and delivered with appropriate sending priority

Syntax
#define __PTM_SEND_PRI_IDLE 0x01000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_PRI_LOW Macro

__PTM_SEND_PRI_LOW Macro
__PTM Macros
Syntax
#define __PTM_SEND_PRI_LOW 0x02000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_PRI_NORMAL Macro

__PTM_SEND_PRI_NORMAL Macro
__PTM Macros
Syntax
#define __PTM_SEND_PRI_NORMAL 0x00000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_SEND_STREAM Macro

__PTM_SEND_STREAM Macro
__PTM Macros
Syntax
#define __PTM_SEND_STREAM 0x10000000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE Macro

__PTM_TYPE Macro
__PTM Macros
Syntax
#define __PTM_TYPE 0x00FF0000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_BIN Macro

__PTM_TYPE_BIN Macro
__PTM Macros
Syntax
#define __PTM_TYPE_BIN 0x00200000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_I32 Macro

__PTM_TYPE_I32 Macro
__PTM Macros

proeprty types

Syntax
#define __PTM_TYPE_I32 0x00010000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_I64 Macro

__PTM_TYPE_I64 Macro
__PTM Macros
Syntax
#define __PTM_TYPE_I64 0x00020000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_STR Macro

__PTM_TYPE_STR Macro
__PTM Macros
Syntax
#define __PTM_TYPE_STR 0x00100000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_STRLST Macro

__PTM_TYPE_STRLST Macro
__PTM Macros
Syntax
#define __PTM_TYPE_STRLST 0x00400000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_STRUCT Macro

__PTM_TYPE_STRUCT Macro
__PTM Macros
Syntax
#define __PTM_TYPE_STRUCT 0x00A00000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_U32 Macro

__PTM_TYPE_U32 Macro
__PTM Macros
Syntax
#define __PTM_TYPE_U32 0x00040000
File

PrlApiPtmTypes.h

Links
__PTM Macros


__PTM_TYPE_U64 Macro

__PTM_TYPE_U64 Macro
__PTM Macros
Syntax
#define __PTM_TYPE_U64 0x00080000
File

PrlApiPtmTypes.h

Links
__PTM Macros


API Debug Functions Functions

API Debug Functions Functions
API Debug Functions Legend
Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.


Legend

Legend
API Debug Functions
Legend
Method


Audio Playback Functions

Audio Playback Functions
Audio Playback Legend
Functions
Name | Description
PrlDevAudio_GetSwitcherState | Get state of the audio switcher from host.
PrlDevAudio_SetSwitcherState | Set state of the audio switcher.
PrlDevAudio_StartStream | Starts audio stream from client to Vm.
PrlDevAudio_StopStream | Stops audio stream.


Legend

Legend
Audio Playback
Legend
Method


Topics

Topics
Callback Prototypes
Topics
Name | Description
PRL_DISK_CALLBACK | PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
PRL_EVENT_HANDLER_PTR | PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.
PRL_STATES_CALLBACK | PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.


Topics

Topics
Common Functions
Topics
Name | Description
System Functions | Common Parallels API system functions.
API Debug Functions | API debug functions.
Handle Functions | Functions that perform operations on handles.
Virtual Device Functions | This section describes common virtual device management functions.
PrlBuffer |


Topics

Topics
Functions by Handle
Topics
Name | Description
PHT_ACCESS_RIGHTS | The PHT_ACCESS_RIGHTS handle is used to obtain and modify the virtual machine access rights information.
PHT_BACKUP_RESULT | The PHT_BACKUP_RESULT handle is a container that contains the results of a backup operation. The handle is returned by the PrlSrv_CreateVmBackup function call (the handle is returned as the first parameter of the Job object).
PHT_BOOT_DEVICE | The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.
PHT_CT_TEMPLATE | The PHT_CT_TEMPLATE handle is used to manage operating system templates on which Containers are based.
PHT_CVSRC | The PHT_CVSRC handle is used to capture data from a video source on the host computer and display in the guest operating system.
PHT_DESKTOP_CONTROL | The PHT_DESKTOP_CONTROL handle is used to remotely access the desktop of the physical host computer. Use the PrlSrv_CreateDesktopControl to create the handle. See the Remote Desktop Access section for the list of functions that support this functionality.
PHT_DISP_CONFIG | The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.
PHT_EVENT | The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.
PHT_EVENT_PARAMETER | The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.
PHT_FIREWALL_RULE | The PHT_FIREWALL_RULE handle is used to create and modify firewall rules.
PHT_FOUND_VM_INFO | The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.
PHT_GUEST_OSES_MATRIX | The PHT_GUEST_OSES_MATRIX handle is a container that contains a list of operating system names and versions that are supported on a given server. To obtain the handle, use the PrlSrv_GetSupportedOses function.
PHT_HANDLES_LIST | The PHT_HANDLES_LIST handle is a generic container that can hold a list of other handles. It is typically used to pass a list of handles to a function in a single parameter. The handles in the container can be of the same type or of different types. A new handle is created by making the PrlApi_CreateHandlesList function call.
PHT_HW_GENERIC_DEVICE | PHT_HW_GENERIC_DEVICE is a base handle used to manage physical devices. A physical device can be a real physical device installed on the host computer or, in some cases, a device in a virtual machine as seen by the guest operating system (this handle should not be confused with handles that are used to manage virtual devices).
PHT_HW_GENERIC_PCI_DEVICE | The PHT_HW_GENERIC_PCI_DEVICE handle is used to obtain information about a generic PCI device installed in the host machine. The handle is obtained by calling the PrlSrvCfg_GetGenericPciDevice function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.
PHT_HW_HARD_DISK | The PHT_HW_HARD_DISK handle is used to manage physical hard disks installed on the host computer. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional functions.
PHT_HW_HARD_DISK_PARTITION | The PHT_HW_HARD_DISK_PARTITION handle is used to manage partitions of a physical hard disk installed on the host computer. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional functions.
PHT_HW_NET_ADAPTER | The PHT_HW_NET_ADAPTER handle is used to manage network adapters installed on the host computer or in a guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional functions.
PHT_IPPRIV_NET | The PHT_IPPRIV_NET handle is used to create and configure IP private networks.
PHT_JOB | The PHT_JOB handle provides methods for managing asynchronous operations.
PHT_LICENSE | The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.
PHT_LOGIN_RESPONSE | The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.
PHT_NET_SERVICE_STATUS | The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.
PHT_NETWORK_CLASS | The PHT_NETWORK_CLASS handle is used to configure network accounting. To use the handle, first create it using the PrlNetworkClass_Create function and then use the handle function to manage network classes configuration.
PHT_NETWORK_RATE | The PHT_NETWORK_RATE handle is used to configure the virtual machine output bandwidth. The handle is obtained using the PrlNetworkRate_Create function.
PHT_NETWORK_SHAPING | The PHT_NETWORK_SHAPING handle is used to configure network shaping. The handle is obtained using the PrlNetworkShapingEntry_Create function.
PHT_NETWORK_SHAPING_BANDWIDTH | The PHT_NETWORK_SHAPING_BANDWIDTH handle is used to create network shaping configuration.
PHT_NETWORK_SHAPING_CONFIG | The PHT_NETWORK_SHAPING_CONFIG handle is used to configure network shaping.
PHT_OFFLINE_SERVICE | The PHT_OFFLINE_SERVICE handle is used to configure offline services. When creating a new offline service configuration, use the PrlOffmgmtService_Create to create the handle. When managing existing offline services configurations, use the PrlSrv_GetOfflineServicesList function to obtain the list of handles.
PHT_OPAQUE_TYPE_LIST | The PHT_OPAQUE_TYPE_LIST handle is a container for storing type lists.
PHT_PLUGIN_INFO | The PHT_PLUGIN_INFO handle is a container that contains information about a third-party plug-in installed in Parallels Service. To obtain the list of installed plug-ins use the PrlSrv_GetPluginsList function.
PHT_PORT_FORWARDING | The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP or UDP port in the host machine to the specified port in a virtual machine.
PHT_PROBLEM_REPORT | The PHT_PROBLEM_REPORT handle is used to obtain and manage Parallels Problem Reports. To obtain the handle, use the PrlApi_CreateProblemReport function.
PHT_REMOTE_FILESYSTEM_ENTRY | The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.
PHT_REMOTE_FILESYSTEM_INFO | The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.
PHT_RESULT | The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.
PHT_RUNNING_TASK | The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.
PHT_SCREEN_RESOLUTION | The PHT_SCREEN_RESOLUTION handle is used to modify the list of screen resolutions available in a virtual machine. By default, only the most common resolutions are supported in a virtual machine. Using this handle, you can add additional resolutions and modify the existing ones if needed. The handle is obtained using the PrlVm_CreateScrRes or the PrlVm_GetScrRes function. The additional screen resolution support can be enabled or disabled in a virtual machine. To determine the status of the feature, use the PrlVmCfg_IsScrResEnabled function.
PHT_SERVER | At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.
PHT_SERVER_CONFIG | The PHT_SERVER_CONFIG handle is used to obtain the host computer configuration information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call. The handle can also be used to obtain network settings of a guest operating system installed in a virtual machine. In this case, the handle is obtained using the PrlVmGuest_GetNetworkSettings function.
PHT_SERVER_INFO | The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.
PHT_SHARE | The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.
PHT_STRINGS_LIST | The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.
PHT_SYSTEM_STATISTICS | The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.
PHT_SYSTEM_STATISTICS_CPU | The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.
PHT_SYSTEM_STATISTICS_DISK | The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.
PHT_SYSTEM_STATISTICS_DISK_PARTITION | The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.
PHT_SYSTEM_STATISTICS_IFACE | The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.
PHT_SYSTEM_STATISTICS_PROCESS | The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.
PHT_SYSTEM_STATISTICS_USER_SESSION | The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.
PHT_UIEMU_INPUT |
PHT_USB_IDENTITY |
PHT_USER_INFO | The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.
PHT_USER_PROFILE | The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.
PHT_VIRTUAL_DEV_FLOPPY | The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.
PHT_VIRTUAL_DEV_HARD_DISK | The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.
PHT_VIRTUAL_DEV_HD_PARTITION | The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.
PHT_VIRTUAL_DEV_NET_ADAPTER | The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.
PHT_VIRTUAL_DEV_OPTICAL_DISK | The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.
PHT_VIRTUAL_DEV_PARALLEL_PORT | The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.
PHT_VIRTUAL_DEV_SERIAL_PORT | The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.
PHT_VIRTUAL_DEV_SOUND | The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.
PHT_VIRTUAL_DEV_USB_DEVICE | The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.
PHT_VIRTUAL_DISK | The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files including a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and the files that are used for data storage. Once created, a virtual disk can be connected to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk or... more
PHT_VIRTUAL_MACHINE | PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.
PHT_VIRTUAL_NETWORK | The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.
PHT_VM_CONFIGURATION | The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.
PHT_VM_GUEST_SESSION | The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle can also be used to obtain some of the guest operating system configuration information. The handle is obtained using the PrlVm_LoginInGuest function.
PHT_VM_INFO | The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.
PHT_VM_TOOLS_INFO | The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.


GUI_ERR Macros Macros

GUI_ERR Macros Macros
GUI_ERR Macros
Macros
Name
Description
GUI_ERR_ACTION_CANCELLED
GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED
GUI_ERR_APP_ALREADY_RUNNING
GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED
GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED
GUI_ERR_APP_BUNDLE_INIT_ABORTED
GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_INIT_FAILURE
GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED
GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION
GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT
GUI_ERR_APP_COULD_NOT_BE_STARTED
GUI_ERR_APP_EULA_DECLINED
GUI_ERR_APP_NEED_REINSTALL
GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW
GUI_ERR_APP_RESUME_INIT_BUNDLE
GUI_ERR_APP_RESUME_INSTALLING_UPDATE
GUI_ERR_APP_RESUME_INVALID_CONTEXT
GUI_ERR_APP_RESUME_SERVER_DISCONNECTED
GUI_ERR_APP_RESUME_SILENT_START
GUI_ERR_APP_RESUME_TIMEOUT
GUI_ERR_APP_RESUME_VM_ENCRYPTED
GUI_ERR_BACKUP_FAILED_GENERAL_MSG
GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE
GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT
GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM
GUI_ERR_CANNOT_DELETE_DISK_FILES
GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE
GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH
GUI_ERR_CANNOT_MOVE_VM_TO_TRASH
GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE
GUI_ERR_CANNOT_RUN_LINKED_CLONE
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE
GUI_ERR_CANT_ADD_PCI_INSTANTLY
  • Gui messages

+++ ALIGNED VALUE TO 15000
GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_RUN_ON_THIS_SYSTEM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_CANT_START_UTW7_AGENT
GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY
GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED
GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR
GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY
GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE
GUI_ERR_CONVERT_FAILED
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_UNKNOWN
End of obsolete codes scope
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE
GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION
GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE
GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH
GUI_ERR_DLCITEM_DWNLD_UNEXPECTED
GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION
GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED
GUI_ERR_DOWNLOADING_FAILED
GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED
GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED
GUI_ERR_DOWNLOADING_PIS_FAILED
GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED
GUI_ERR_FAILED_TO_INIT_SDK_LIB
GUI_ERR_HOST_NOT_SUPPORTED
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED
GUI_ERR_INSTALLATION_DOWNLOADING_FAILED
GUI_ERR_INSTALLING_FAILED
GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_INVALID_ADAPTER_ADDRESS
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_IVALID_VM_UUID_MISMATCH
GUI_ERR_LEGACY_HDD_NOT_SUPPORTED
GUI_ERR_MIGRATE_PC_ALREADY_RUNNING
GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM
GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE
GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED
GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN
GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_NET_ADAPTER_EXISTS
GUI_ERR_NET_ADAPTER_NAME_EMPTY
GUI_ERR_NEWER_APP_ALREADY_RUNNING
GUI_ERR_NO_EMAIL_ACCOUNT
GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL
GUI_ERR_NO_INSTALLATION_DISC
GUI_ERR_NO_INSTALLER_FILE
GUI_ERR_NO_OPTICAL_DRIVE
GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE
GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OLDER_APP_ALREADY_RUNNING
GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_OS_IMG_DWNLD_UNEXPECTED
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION
GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION
GUI_ERR_PARENT_LINKED_VM_NOT_FOUND
GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR
GUI_ERR_PAX_AGENT_INSTALL_FAILURE
GUI_ERR_PAX_AGENT_NO_CONNECTION
GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED
GUI_ERR_PMC_INVALID_CREDENTIALS
Obsolete error codes - use ones with prefix PRL_ERR_PPC
GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT
GUI_ERR_PMC_SERVER_BUSY
GUI_ERR_PMC_UNABLE_TO_CONNECT
GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE
GUI_ERR_POST_REPORT
GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER
GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION
GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR
GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED
GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START
GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_SUSPEND_VM_WITH_VTD
GUI_ERR_UID_0_DUPLICATION
GUI_ERR_UNABLE_START_LYM
GUI_ERR_UNABLE_START_TRANSPORTER
GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD
GUI_ERR_UNABLE_TO_START_SERVICES
GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_UPDATE_INSTALL_FAILED
GUI_ERR_UPDATE_UNABLE_TO_CHECK
GUI_ERR_UPDATER_NO_CONNECTION
GUI_ERR_UPDATER_NO_FILE
GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE
GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR
GUI_ERR_UPGRADE_REQUEST_UNEXPECTED
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_VOLUME_LICENSE_EXPIRED
GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES
GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES
GUI_ERR_WEB_STORE_INVALID_DATA
GUI_ERR_WEB_STORE_NO_CONNECTION
GUI_ERR_WEB_STORE_NO_DATA
GUI_ERR_WEB_STORE_UNEXPECTED
GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL
GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN
GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN
GUI_ERR_WRONG_BACKUP_PATH
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_FEATURE_RESTRICTED
GUI_INFO_IN_FULLSCREEN_NOTIFICATION
GUI_INFO_IN_SEAMLESS_NOTIFICATION
GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_REINSTALL_TOOLS_LIN
GUI_INFO_REINSTALL_TOOLS_MAC
GUI_INFO_REINSTALL_TOOLS_OTHER
GUI_INFO_REINSTALL_TOOLS_WIN
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_UPDATE_TOOLS_LIN
GUI_INFO_UPDATE_TOOLS_MAC
GUI_INFO_UPDATE_TOOLS_OTHER
GUI_INFO_UPDATE_TOOLS_WIN
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DELETE_VM_IMMEDIATELY
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_MOVE_TO_TRASH_DISK
GUI_QUESTION_MOVE_TO_TRASH_VM
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN
GUI_QUESTION_STOP_SUSPENDED_VM
GUI_QUESTION_TRIAL_EXPIRES_TEXT1
GUI_QUESTION_TRIAL_EXPIRES_TEXT2
GUI_QUESTION_TRIAL_EXPIRES_TEXT3
GUI_QUESTION_TRIAL_EXPIRES_TEXT4
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_INVALID_IPV6_ADDRESS
GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS


GUI_INFO Macros Macros

GUI_INFO Macros Macros
GUI_INFO Macros
Macros
Name
Description
GUI_ANSWER_RUN_FREE_SPACE_WIZARD
  • GUI Answers

+++ ALIGNED VALUE TO 53000
GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL
GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL
GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM
GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK
GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM
GUI_INFO_CLEAN_UP_DISK_SPACE
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST
GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D
GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY
GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS
GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY
GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED
GUI_INFO_COHERENCE_CANNOTSTART_SMOFF
GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_STOPPED_LINUX_3D
GUI_INFO_COHERENCE_STOPPED_LOWMEMORY
GUI_INFO_CONFIGURING_THE_DOCK
GUI_INFO_CONVERT_SUCCEDED_OTHER_OS
GUI_INFO_CTRL_ALT_DEL_FROM_MENU
GUI_INFO_CTRL_ALT_DEL_PRESSED
GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED
GUI_INFO_ENTER_IN_POWERSAVE_MODE
GUI_INFO_ENTER_TO_PRESENTATION_MODE
GUI_INFO_EXIT_FROM_PRESENTATION_MODE
GUI_INFO_EXPRESS_INSTALLATION_FINISHED
GUI_INFO_FEEDBACK_SUCCESS
GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE
GUI_INFO_GUEST_HIRES_OPTION_CHANGED
GUI_INFO_HIDDEN_MESSAGES_RESTORED
GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE
GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON
GUI_INFO_INSTALLED_GUEST_APPS_DIALOG
GUI_INFO_INVALID_LOGIN_OR_PASS
GUI_INFO_IPN_MESSAGE
GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM
GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY
GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL
GUI_INFO_NEW_VERSION_AVAILABLE
GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT
GUI_INFO_OFFICE_SHARED_CLOUDS_KB
GUI_INFO_PASSWORD_RESET_CHECK_EMAIL
GUI_INFO_PASSWORD_RESET_ENTER_EMAIL
GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY
GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY
GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED
GUI_INFO_REG_ALREADY_REGISTERED
GUI_INFO_REG_CONNECTION
GUI_INFO_REG_GENERAL_ERROR
GUI_INFO_REG_INVALID_EMAIL
GUI_INFO_REG_INVALID_KEY
GUI_INFO_REG_INVALID_USER
GUI_INFO_REG_OK
GUI_INFO_REG_REQUIRED_FIELDS
GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED
GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMOTE_SESSION_ACTIVE
GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED
GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER
GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM
GUI_INFO_SNAPSHOT_DELETE_FINISHED
GUI_INFO_SOFTWARE_UP_TO_DATE
GUI_INFO_TASK_ALREADY_RUNNING
GUI_INFO_TASK_STEP_SKIPPED
GUI_INFO_TRIAL_GUEST_WARNING
GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS
GUI_INFO_UPDATE_FINISHED
GUI_INFO_UPGRADE_FINISHED
GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER
GUI_INFO_USB3_DRIVERS_REQUIRED_WIN
GUI_INFO_USER_REGISTRATION_DLG_SEND_OK
GUI_INFO_VM_CLEANUP_NOTHING_TO_DO
GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC
GUI_INFO_VM_COMPACTING_FINISHED
GUI_INFO_VM_DECRYPTED_SUCCESSFULLY
GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY
GUI_INFO_VM_IN_ISOLATION_MAC
GUI_INFO_VM_IN_ISOLATION_WIN
GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS
GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT
GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD
GUI_QUESTION_CANCEL_INSTALL_DELETE
GUI_QUESTION_CANCEL_INSTALL_SUSUPEND
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING
GUI_QUESTION_CLOSE_VM_WINDOW
GUI_QUESTION_CONFIRM_UPDATE_CANCEL
GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED
GUI_QUESTION_CONVERT_SUCCEDED
GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER
GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS
GUI_QUESTION_DELETE_CREATED_VM
GUI_QUESTION_DELETE_OLD_VM
GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT
GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES
GUI_QUESTION_DESKTOP_IS_UNREGISTERED
GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS
GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS
GUI_QUESTION_DISABLE_HOST_SLEEP
GUI_QUESTION_DISABLE_OPTIONS
GUI_QUESTION_DISABLE_VERBOSE_LOG
GUI_QUESTION_DISABLE_WINDOWS7_LOOK
GUI_QUESTION_DONT_USE_DIRECT_CONECTION
GUI_QUESTION_DWNLD_RETRY
GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE
GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION
GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE
GUI_QUESTION_ENABLE_BACKGROUND_UPDATE
GUI_QUESTION_ENABLE_CEP
GUI_QUESTION_ENABLE_GUEST_SHARING
GUI_QUESTION_ENABLE_PMU_SUPPORT
GUI_QUESTION_ENABLE_SHARED_APPS
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH
GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT
GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE
GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START
GUI_QUESTION_INSTALL_MAJOR_UPDATE
GUI_QUESTION_INSTALL_WINDOWS7_LOOK
GUI_QUESTION_INVALID_VM_CORRUPTED
GUI_QUESTION_INVALID_VM_NOT_AVAILABLE
GUI_QUESTION_ISOLATE_VM
GUI_QUESTION_ISOLATE_VM_LIN
GUI_QUESTION_MANUAL_INSTALL
GUI_QUESTION_NO_BACKUP
GUI_QUESTION_NO_FREE_SPACE
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8
GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE
GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE
GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS
GUI_QUESTION_POSTPONE_UPGRADE
GUI_QUESTION_PREPARE_MAVERICK_IMAGE
GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED
GUI_QUESTION_PROFILE_DELETE
GUI_QUESTION_QUIT_PARALLELS_ACCESS
GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM
GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_QUESTION_REMOVE_BACKUP
GUI_QUESTION_REMOVE_PREVIOUS_VERSION
GUI_QUESTION_REPLACE_PREVIOUS_VERSION
GUI_QUESTION_RESET_VIRTUAL_NETWORK
GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE
GUI_QUESTION_RESTORE_FROM_BACKUP
GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS
GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG
GUI_QUESTION_SM_ENABLE_SHARED_APPS
GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR
GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS
GUI_QUESTION_SNAPSHOT_SINGLE_DELETE
GUI_QUESTION_STOP_APPLIANCE
GUI_QUESTION_UPDATER_NO_CONNECTION
GUI_QUESTION_USB_CONTROLLER_REMOVE
GUI_QUESTION_VM_CLEANUP_CONFIRM
GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE
GUI_TRY_DISCONNECT_CONNECTING_USB
GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST
GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE
GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS
GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS
GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS
GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS
GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT
GUI_WRN_DESKTOP_IS_TRIAL
GUI_WRN_DEVICE_ALREADY_EXIST
GUI_WRN_DHCP_END_IP_ADDRESS
GUI_WRN_DHCP_START_IP_ADDRESS
GUI_WRN_DUPLICATE_VIRTUAL_NETWORK
GUI_WRN_ENCRYPTED_DISK_NOT_ADDED
GUI_WRN_FS_RESIZE_NOT_SUPPORTED
GUI_WRN_HOST_IP_ADDRESS
GUI_WRN_INVALID_VM_BUNDLE
GUI_WRN_INVALID_VM_FOLDER
GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED
GUI_WRN_LOCAL_PATH_NOT_SPECIFIED
GUI_WRN_LOCAL_PATH_WRONG
GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL
GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE
GUI_WRN_NEW_PROFILE_NAME_EMPTY
GUI_WRN_NO_BACKUP_FOLDER
GUI_WRN_NO_USB_DEVICES_AVAILABLE
GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS
GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS
GUI_WRN_PARTITION_NOT_SPECIFIED
GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT
GUI_WRN_PORT_MAPPING_IP_INCORRECT
GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT
GUI_WRN_PRODUCT_KEY_INCOMPLETE
GUI_WRN_PRODUCT_KEY_WRONG_LENGTH
GUI_WRN_PROFILE_NAME_ALREADY_IN_USE
GUI_WRN_PURCHASE_MISSING_KEY
GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED
GUI_WRN_SERVER_ALREADY_CONNECTED
GUI_WRN_SERVER_NAME_NOT_SPECIFIED
GUI_WRN_SERVER_NAME_WRONG
GUI_WRN_SOURCE_FOR_DEVICE_IS_USED
GUI_WRN_SUBNET_MASK
GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG
GUI_WRN_UNABLE_REQUEST_TRIAL_KEY
GUI_WRN_UNATTENDED_LINUX_NO_IMAGE
GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE
GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY
GUI_WRN_USER_NAME_ILLEGAL
GUI_WRN_USER_NAME_NOT_SPECIFIED
GUI_WRN_USER_NAME_RESERVED_BY_GUEST
GUI_WRN_USER_PASS_DO_NOT_MATCH
GUI_WRN_USER_PASS_NOT_SPECIFIED
GUI_WRN_USER_PASS_TOO_SHORT
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI
GUI_WRN_VIRTUAL_NETWORK_WRONG


Handle Functions Functions

Handle Functions Functions
Handle Functions Legend
Functions
Name | Description
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetChannelStatistics | Retrieves IO channel statistics (throughput, delay) for correspond virtual machine or remote desktop control object.
PrlHandle_GetPackageId | Returns the numeric identifier of the package that caused the event.
PrlHandle_GetType | Returns the type of the specified handle.
PrlHandle_RegEventHandler | Registers event handler.
PrlHandle_UnregEventHandler | Unregisters event handler.


Legend

Legend
Handle Functions
Legend
Method


_ICryptInfo Structure

_ICryptInfo Structure
Other Structs

Information about encryption plugin

Syntax
struct _ICryptInfo {
  IPluginInfo PluginInfo;
  PRL_UINT32 KeySize;
  PRL_UINT32 BlockSize;
};
File

PrlPluginClasses.h

Links
Other Structs


_IPluginInfo Structure

_IPluginInfo Structure
Other Structs

Generic information about plugin

Syntax
struct _IPluginInfo {
  PRL_CONST_STR Vendor;
  PRL_CONST_STR Copyright;
  PRL_CONST_STR DescShort;
  PRL_CONST_STR DescLong;
  PRL_UINT32 Major;
  PRL_UINT32 Minor;
  PRL_UINT32 Build;
  PRL_GUID Type;
};
File

PrlPluginClasses.h

Links
Other Structs


Keyboard Control Functions

Keyboard Control Functions
Keyboard Control Legend
Functions
Name | Description
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.
PrlDevKeyboard_SendKeyEventEx | Sends a keyboard key event to a virtual machine.
PrlDevKeyboard_SendKeyPressedAndReleased | Sends a keyboard key pressed and released to a virtual machine.


Legend

Legend
Keyboard Control
Legend
Method


Mouse Control Functions

Mouse Control Functions
Mouse Control Legend
Functions
Name | Description
PrlDevMouse_AsyncMove | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_AsyncSetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevMouse_Event | Sends absolute or relative mouse event with specified parameters within the virtual machine display coordinate grid.
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_MoveEx | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPosEx | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).


Legend

Legend
Mouse Control
Legend
Method


Other Macros Macros

Other Macros Macros
Other Macros
Macros
Name
Description
__PARALLELS_PERF_COUNTERS_H__
__PRL_PLUGINS_CLASSES_DEFINED__
CAPDEFAULTMASK
FS_PERM_EXECUTE
FS_PERM_READ
FS_PERM_WRITE
GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION
GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS
GUID_CLS_BASE_STR
GUID_CLS_ENCRYPTION_STR
IS_ANDROID
IS_CHROMEOS
IS_FREEBSD
IS_FS_EXECUTE_PERMITTED
IS_FS_READ_PERMITTED
IS_FS_WRITE_PERMITTED
IS_LINUX
IS_MACOS
IS_MSDOS
IS_NETWARE
IS_OS2
IS_OTHER
IS_SOLARIS
IS_VALID_ANDROID_VERSION
IS_VALID_CHROMEOS_VERSION
IS_VALID_FREEBSD_VERSION
IS_VALID_LINUX_VERSION
IS_VALID_MACOS_VERSION
IS_VALID_MSDOS_VERSION
IS_VALID_NETWARE_VERSION
IS_VALID_OS2_VERSION
IS_VALID_OTHER_OS_VERSION
IS_VALID_SOLARIS_VERSION
IS_VALID_WINDOWS_VERSION
IS_WIN_VER_BELOW
PVS_GUEST_VER_WIN_OTHER is used for legacy guest OS (9x and below), but has maximal number 0xFF.
IS_WINDOWS
PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_SRV_METHOD_DECL
PRL_BSD_PARTITION
Free BSD partition.
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID
  • Disk validation errors

+++ ALIGNED VALUE TO 25000
PRL_CURRENT_GUEST_OS_SESSION
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_DISK_NO_IMAGE_CREATION
So not create image when creating disk, just put reference to file in XML
PRL_DISPATCHER_LISTEN_PORT
PRL_DISPATCHER_LISTEN_PORT_PMOBILE
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_FAILED
PRL_FALSE
PRL_HDD_FIRMWARE_LEN
PRL_HDD_MODEL_LEN
Definitions of length of incoming strings to PrlDisk_GetIdentify function.
PRL_HDD_SERIAL_LEN
PRL_IDE_READ_REQUESTS_PTRN
Total count of read requests to IDE controller
PRL_IDE_READ_TOTAL_PTRN
Total count of read bytes through IDE controller
PRL_IDE_WRITE_REQUESTS_PTRN
Total count of write requests to IDE controller
PRL_IDE_WRITE_TOTAL_PTRN
Total count of write bytes through IDE controller
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_BOOTCAMP_FAKE
FAKE Bootcamp, for test purposes
PRL_IMAGE_BOOTCAMP_UID
Bootcamp set by UID
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_IMAGE_VHD_DIFF
PRL_IMAGE_VHD_DYNAMIC
PRL_IMAGE_VHD_DYNAMIC_PART
PRL_IMAGE_VHD_PLAIN
Limited Microsoft VHD support
PRL_IMAGE_VHD_PLAIN_PART
PRL_IMAGE_VMDK_EXTENT_2GB_FLAT
PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE
PRL_IMAGE_VMDK_MONOLITHIC_FLAT
VMware VMDK support
PRL_IMAGE_VMDK_MONOLITHIC_SPARSE
PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED
PRL_INVALID_FILE_DESCRIPTOR
Invalid file descriptor
PRL_INVALID_HANDLE
PRL_INVALID_PARTITION
Invalid partition
PRL_INVALID_VLAN_TAG
constant for invalid VLAN tag
PRL_IO_GAMMARAMP_DEFAULT
PRL_IO_GAMMARAMP_RGB256x3x16
PRL_IO_MAX_AUDIO_ENCODINGS
PRL_IO_MAX_DISPLAYS
PRL_IO_MAX_ENCODINGS
PRL_LICENSE_IS_EXPIRED
PRL_LICENSE_IS_VALID
Success license state
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_BOOT_PARTITION
PRL_MACOS_PARTITION
Mac OS
PRL_MAX_VLAN_TAG
constant for maximum valid VLAN tag (4095)
PRL_METHOD
Default method decoration
PRL_METHOD_DECL
Default method declaration for the header files
PRL_METHOD_PTR
PRL_MSDOS_EXTENDED_PARTITION
  • Disk partition types

Extended partitions
PRL_NET_ADAPTER_ALREADY_USED
Unable to use adapter because it is already used by another virtual network
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_BYTES_IN_PTRN
PRL_NET_BYTES_OUT_PTRN
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CLASSFUL_TRAFFIC_PTRN
Classful network traffic counting info.
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME
PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR
  • Network

+++ ALIGNED VALUE TO 4000
PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST
PRL_NET_IPPRIVATE_NETWORK_INVALID_IP
PRL_NET_OFFMGMT_ERROR
Failed to setup offline-management configuration for VM
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PKTS_IN_PTRN
PRL_NET_PKTS_OUT_PTRN
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS
Invalid DHCP scope ip addresses format
PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN
Minimum ip addresses in scope range are 16
PRL_NET_VALID_FAILURE
+++ ALIGNED VALUE TO 4200 +++ Broken network config
PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK
Mask must match DHCP scope ip addresses
PRL_NET_VALID_WRONG_DHCP_IP_ADDR
Invalid DHCP ip address format
PRL_NET_VALID_WRONG_HOST_IP_ADDR
Invalid host ip address format
PRL_NET_VALID_WRONG_NET_MASK
Invalid network mask format
PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS
PRL_NET_VIRTUAL_NETWORK_NOT_FOUND
PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS
Unable to add shared network because it is already exists
PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED
Shared network prohibited on server
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_NULL
NULL (invalid) handle
PRL_PRIVILEGED_GUEST_OS_SESSION
Guest OS sessions types and constants declarations
PRL_PROXY_MAX_HOSTS
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD
PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE
PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE
PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS
PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH
PRL_QUESTION_FINALIZE_VM_PROCESS
PRL_QUESTION_REVERT_TOO_LARGE_MEM
PRL_QUESTION_SETUP_YANDEX_SEARCH
PRL_RESULT_DECLARE_ERROR
Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS
PRL_SATA_READ_REQUESTS_PTRN
Total count of read requests to SATA controller
PRL_SATA_READ_TOTAL_PTRN
Total count of read bytes through SATA controller
PRL_SATA_WRITE_REQUESTS_PTRN
Total count of write requests to SATA controller
PRL_SATA_WRITE_TOTAL_PTRN
Total count of write bytes through SATA controller
PRL_SCSI_READ_REQUESTS_PTRN
Total count of read requests to SCSI controller
PRL_SCSI_READ_TOTAL_PTRN
Total count of read bytes through SCSI controller
PRL_SCSI_WRITE_REQUESTS_PTRN
Total count of write requests to SCSI controller
PRL_SCSI_WRITE_TOTAL_PTRN
Total count of write bytes through SCSI controller
PRL_SDK_WRAP_FOR_EACH_MANAGER
PRL_SRV_METHOD_DECL
PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_STRUCT
Default structure definition
PRL_SUCCEEDED
Success and failure result codes
PRL_TC_CLASS_MAX
PRL_TERNARY_FALSE
PRL_TERNARY_TRUE
PRL_TERNARY_UNDEF
PRL_TRUE
PRL_VM_STOP_MODE_MASK
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND is keep only for compatibility with previous versions of dispatcher (PSBM)
PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE
PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP
PRL_WARN_BACKUP_NON_IMAGE_HDD
PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_CANNOT_MOUNT_BACK_PARTITION
PRL_WARN_CANT_CONNECT_VOLUME
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_DEV_USB_CONNECT_FAILED
PRL_WARN_DEV_USB_OPEN_FAILED
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_LICENSE_RESTRICTED_RKU
PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE
PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT
PRL_WARN_NOT_SYMMETRIC_CPU
PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE
PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VERBOSE_LOGGING
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DISCONNECT_SATA_HDD
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED
PRL_WARN_WINDOWS_UPDATE_WORKING
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions
PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED
PRL_WNG_START_VM_ON_MOUNTED_DISK
PRL_WRN_IT_CANT_RESIZE_LDM_DISK
PRL_WRN_IT_CANT_RESIZE_VOLUME
PRL_WRN_IT_EMPTY_MBR
PRL_WRN_IT_FIRST_WARNING
vi disk tool errors +++ ALIGNED VALUE TO 46000
PRL_WRN_IT_VOLUME_RESIZING
PRL_WS_RECLAIMABLE_PTRN
PVM_GET_SECURITY_LEVEL
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_TYPE
PVS_GUEST_VER_FREE_BSD
PVS_MAKE_GUEST_VER
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_ENABLED
SET_FS_READ_DISABLED
SET_FS_READ_ENABLED
SET_FS_WRITE_DISABLED
SET_FS_WRITE_ENABLED


Other Structs Enumerations

Other Structs Enumerations
Other Structs Legend
Enumerations
Name
Description
_PRL_ADAPTER_INDEX
Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index
_PRL_ALLOWED_VM_COMMAND
Allowed vm commands enumeration
_PRL_API_COMMAND_FLAGS
Common operations flags set.
_PRL_API_INIT_FLAGS
Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode
_PRL_APP_IN_DOCK_MODE
VM application in Dock mode
_PRL_APPLIANCE_DOWNLOAD_STATUS
Appliance download status
_PRL_APPLICATION_MODE
Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode
_PRL_BIOS_TYPE
BIOS type
_PRL_CLONE_VM_FLAGS
PrlVm_CloneEx command flags set
PCVF_DETACH_EXTERNAL_VIRTUAL_HDD
  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
_PRL_CLUSTERED_DEVICE_SUBTYPE
Clustered device subtype
_PRL_COMPACT_MODE
Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files
_PRL_CONVERT_VIRTUAL_DISK
Convert virtual disk
  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
_PRL_COPY_CT_TEMPLATE_FLAGS
copy of CT templates functionality flags set
_PRL_CORNER_ACTIONS
Window corner actions
_PRL_CPU_FEATURES_EX
_PRL_CPU_HVT
CPU mode
_PRL_CPU_MODE
CPU mode
_PRL_CPULIMIT_TYPE
_PRL_CPUUNITS
_PRL_CREATE_DISK_IMAGE_FLAGS
Create image flags
_PRL_CREATE_SNAPSHOT_FLAGS
VM snapshot creation flags set
_PRL_CT_CAPMASK
Capabilities list
_PRL_CT_FEATURES
CT Features
_PRL_CT_RESOURCE
_PRL_CT_TEMPLATE_TYPE
Container templates types
_PRL_DATA_STATISTIC_SEGMENTS
Data statistic segments
_PRL_DELETE_SNAPSHOT_FLAGS
  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
_PRL_DEVICE_ACTION
Device in use Action
_PRL_DEVICE_TYPE
Device type
_PRL_DISPLAY_BUFFER_FORMAT
Format of display buffer
_PRL_DISPLAY_CODEC_COMPRESSION
Obsolete enum.
_PRL_DISPLAY_CODEC_QUALITY
Obsolete enum.
_PRL_DISPLAY_CODEC_TYPE
Obsolete enum.
_PRL_DISPLAY_CONFIG_MODE
Display(s) configuration mode
_PRL_DISTRO_MEDIA_TYPE
_PRL_DOCK_ICON_TYPE
VM application icon type in Dock
_PRL_ENCRYPTION_FLAGS
Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations
_PRL_EVENT_ISSUER_TYPE
Event issuer type
_PRL_EVENT_TYPE
Different event types are identified by these event codes.
_PRL_EXTERNAL_VM_TYPE
External VM type for supporting native VM
_PRL_FEATURES_MATRIX
Features matrix list
_PRL_FILE_SYSTEM_ELEMENT_TYPE
File system element type
_PRL_FILE_SYSTEM_FS_TYPE
_PRL_FILE_SYSTEM_TYPE
File system general type
_PRL_FIREWALL_DIRECTION
Firewall direction
_PRL_FIREWALL_POLICY
Firewall policy
_PRL_GENERIC_DEVICE_STATE
Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started
_PRL_GENERIC_PCI_DEVICE_CLASS
Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device
_PRL_GET_SNAPSHOT_TREE_FLAGS
PrlVm_GetSnapshotsTreeEx flags
_PRL_GET_VM_CONFIG_FLAGS
Find VM operations:
_PRL_GET_VM_LIST_FLAGS
List operations: Uses for PrlSrv_GetVmListEx operation
_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
_PRL_GRACEFUL_SHUTDOWN_KIND
Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM
Windows installation distributive type.
_PRL_HANDLE_TYPE
The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_IFACE_MASK
Hard disk interfce mask enum
_PRL_HARD_DISK_INTERNAL_FORMAT
Hard disk image type
_PRL_HOST_OS_TYPE
Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE
Network adapter types in hardware info list
_PRL_IMAGE_FORMAT
_PRL_INSTALL_APPLIANCE_FLAGS
Install appliance options
  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
_PRL_IO_CLIENT_FLAGS
Flags which determines peer client while login to dispatcher and while attach to vm.
_PRL_IO_STATE
_PRL_IOLIMIT_TYPE
_PRL_IOPRIO
_PRL_ISCSI_STORAGE_CMD_FLAGS
iSCSI storage management flags
_PRL_ISCSI_STORAGE_FSTYPE_FLAGS
iSCSI storage filesystem type
_PRL_JOB_OPERATION_CODE
Job operation codes
_PRL_JOB_STATUS
Job status enumeration
_PRL_KEY
Parallels virtual keycodes.
_PRL_KEY_EVENT
_PRL_LICENSE_RESTRICTION_KEY
License restriction options
_PRL_LOGIN_LOCAL_FLAGS
PrlSrv_LoginLocal flags
_PRL_MASS_STORAGE_INTERFACE_TYPE
Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM
Message type enumeration.
_PRL_MOBILE_ADVANCED_AUTH_MODE
Authorization mode, when mobile client establishing remote access to the host.
_PRL_MOUNT_VIRTUAL_DISK
Mount virtual disk flags
_PRL_MOUSE_BUTTON
_PRL_NET_ADAPTER_EMULATED_TYPE
Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE
Virtual Network type.
_PRL_NETFILTER_MODE
Netfilter modes list
_PRL_ONLINE_COMPACT_MODE
Online compact mode for virtual machine disks
_PRL_OPTIMIZE_MODIFIERS_MODE
Determines the mode of modifiers handling inside the guest
_PRL_PARAM_FIELD_DATA_TYPE
Event parameters fields types
_PRL_PORT_FORWARDING_TYPE
Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PRINTER_INTERFACE_TYPE
Printer device interface type
_PRL_PRIVATE_EVENT_TYPE
Private event types.
_PRL_PROBLEM_REPORT_FLAGS
Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report
_PRL_PROBLEM_REPORT_REASON
Problem report reason enumeration
_PRL_PROBLEM_REPORT_SCHEME
Problem report scheme enumaration
_PRL_PROBLEM_REPORT_TYPE
Problem report type enumeration
_PRL_PROCESS_STATE_TYPE
Process state element
_PRL_PRODUCT_ENUM
Parallels license products enumeration.
_PRL_PROXY_CONNECTION_STATUS
Proxy connection status
_PRL_QUERY_ELEMENT_FLAGS
Query element flags
_PRL_REGISTER_3PARTY_VM_FLAGS
PrlSrv_Register3rdPartyVm command flags set
_PRL_REGISTER_NEW_VM
PrlVm_RegEx flags
_PRL_REGISTER_VM_FLAGS
PrlSrv_RegisterVmEx command flags set
_PRL_RESIZE_IMAGE_FLAGS
PrlVmDev_ResizeImage command flags set
_PRL_RUNNING_TASK_TYPE_ENUM
Running task type enumeration.
_PRL_SCALE_VIEW_MODE
Aspect ratio mode
_PRL_SECURITY_LEVEL
Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM
Parallels service statuses
_PRL_SET_PROXY_CONNECTION_FLAGS
PrlDispCfg_SetProxyConnectionCreds flags
_PRL_SET_USERPASSWD_FLAGS
PrlVmGuest_SetUserPasswd flags
_PRL_SOUND_CHANNEL_TYPE
Sound channel type
_PRL_SRV_SHUTDOWN_FLAGS
PrlSrv_ShutdownEx flags
_PRL_SWITCH_SNAPSHOT_FLAGS
PrlVm_SwitchSnapshotEx flags
_PRL_TASKBAR_STATES
Taskbar states
_PRL_TIS_RECORD_FIELD
Parallels Tools Information Service record fields
_PRL_TIS_RECORD_STATE
Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES
Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG
Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID
Parallels Tools Utility commands identifiers
_PRL_UIEMU_ELEMENT_CONTROL_TYPE
_PRL_UIEMU_GESTURE_STATE
_PRL_UIEMU_GESTURE_TYPE
_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
_PRL_UIEMU_MMKEY
_PRL_UIEMU_MOUSE_CLICK
_PRL_UIEMU_SCROLL_FLAGS
_PRL_UIEMU_SCROLL_UNITS
_PRL_UNDO_DISKS_MODE
VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_UPDATE_LICENSE_FLAGS
Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION
USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON
USB device connect/disconnect reason
_PRL_USB_DEVICE_TYPE
USB device type
_PRL_VERSION_ENUM
Parallels license versions enumeration.
_PRL_VIDEO_3D_ACCELERATION
Video 3D acceleration
_PRL_VIRTUAL_MACHINE_PROFILE
Virtual machine profiles enum
_PRL_VM_ACCELERATION_LEVEL
Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS
Specifies virtual machine access rights.
_PRL_VM_ACTION
_PRL_VM_ACTION_ON_WINDOW_CLOSE
Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION
VM autostart options
_PRL_VM_AUTOSTOP_OPTION
VM autostop options
_PRL_VM_BACKUP_FLAGS
VM backup functionality flags set
_PRL_VM_BACKUP_TYPE
Hint about the type of VE inside a backup archive
_PRL_VM_BOOT_ORDER
VM boot order
_PRL_VM_COMMIT_FLAGS
PrlVm_CommitEx flags
_PRL_VM_CONFIG_SECTIONS
VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE
VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR
App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES
Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest
_PRL_VM_MIGRATION_FLAGS
VM migration functionality flags set
_PRL_VM_MOUSE_CURSOR_STATE
_PRL_VM_MOUSE_STATE
_PRL_VM_NET_ADAPTER_WIFI_RULE
_PRL_VM_NORMAL_START_FLAGS
VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)
_PRL_VM_PRIORITY
Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE
Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE
VM start login mode
_PRL_VM_START_MODE
VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation
_PRL_VM_STATISTICS_FLAGS
PrlVm_GetStatisticsEx flags
_PRL_VM_STORE_VALUE_FLAGS
Store value by specified keys on server options.
_PRL_VM_TOOLS_STATE
Virtual machine tools states enumeration
_PRL_VM_TYPE_FLAGS
_PRL_VM_WINDOW_MODE
VM window mode
_PRL_VMCTG_EVENT
Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)
_PRL_VTD_STATUS_CODE
VTD status code
_PRL_WINDOW_CORNERS
Window corners
_PRL_WINDOW_EDGE_MASK
Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_ADDITION_STATE
Virtual machine addition states enumeration, may be combined with bitwise
_VIRTUAL_MACHINE_STATE
Virtual machine states enumeration
PRL_ADAPTER_INDEX
Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index
PRL_ALLOWED_VM_COMMAND
Allowed vm commands enumeration
PRL_API_COMMAND_FLAGS
Common operations flags set.
PRL_API_INIT_FLAGS
Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode
PRL_APP_IN_DOCK_MODE
VM application in Dock mode
PRL_APPLIANCE_DOWNLOAD_STATUS
Appliance download status
PRL_APPLICATION_MODE
Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode
PRL_AUDIO_STREAM_TYPE
Audio stream type
PRL_BIOS_TYPE
BIOS type
PRL_CLONE_VM_FLAGS
PrlVm_CloneEx command flags set
PCVF_DETACH_EXTERNAL_VIRTUAL_HDD
  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
PRL_CLUSTERED_DEVICE_SUBTYPE
Clustered device subtype
PRL_COMPACT_MODE
Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files
PRL_CONVERT_VIRTUAL_DISK
Convert virtual disk
  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
PRL_COPY_CT_TEMPLATE_FLAGS
copy of CT templates functionality flags set
PRL_CORNER_ACTIONS
Window corner actions
PRL_CPU_FEATURES_EX
PRL_CPU_HVT
CPU mode
PRL_CPU_MODE
CPU mode
PRL_CPULIMIT_TYPE
PRL_CPUUITS
PRL_CREATE_DISK_IMAGE_FLAGS
Create image flags
PRL_CREATE_SNAPSHOT_FLAGS
VM snapshot creation flags set
PRL_CT_CAPMASK
Capabilities list
PRL_CT_FEATURES
CT Features
PRL_CT_RESOURCE
PRL_CT_TEMPLATE_TYPE
Container templates types
PRL_DATA_STATISTIC_SEGMENTS
Data statistic segments
PRL_DELETE_SNAPSHOT_FLAGS
  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
PRL_DEVICE_ACTION
Device in use Action
PRL_DEVICE_TYPE
Device type
PRL_DISPLAY_BUFFER_FORMAT
Format of display buffer
PRL_DISPLAY_CODEC_COMPRESSION
Obsolete enum.
PRL_DISPLAY_CODEC_QUALITY
Obsolete enum.
PRL_DISPLAY_CODEC_TYPE
Obsolete enum.
PRL_DISPLAY_CONFIG_MODE
Display(s) configuration mode
PRL_DISTRO_MEDIA_TYPE
PRL_DOCK_ICON_TYPE
VM application icon type in Dock
PRL_ENCRYPTION_FLAGS
Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations
PRL_EVENT_ISSUER_TYPE
Event issuer type
PRL_EVENT_TYPE
Different event types are identified by these event codes.
PRL_EXTERNAL_VM_TYPE
External VM type for supporting native VM
PRL_FEATURES_MATRIX
Features matrix list
PRL_FILE_SYSTEM_ELEMENT_TYPE
File system element type
PRL_FILE_SYSTEM_FS_TYPE
PRL_FILE_SYSTEM_TYPE
File system general type
PRL_FIREWALL_DIRECTION
Firewall direction
PRL_FIREWALL_POLICY
Firewall policy
PRL_GENERIC_DEVICE_STATE
Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started
PRL_GENERIC_PCI_DEVICE_CLASS
Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device
PRL_GET_SNAPSHOT_TREE_FLAGS
PrlVm_GetSnapshotsTreeEx flags
PRL_GET_VM_CONFIG_FLAGS
Find VM operations:
PRL_GET_VM_LIST_FLAGS
List operations: Uses for PrlSrv_GetVmListEx operation
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
PRL_GRACEFUL_SHUTDOWN_KIND
Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM
Windows installation distributive type.
PRL_HANDLE_TYPE
The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_IFACE_MASK
Hard disk interfce mask enum
PRL_HARD_DISK_INTERNAL_FORMAT
Hard disk image type
PRL_HOST_OS_TYPE
Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE
Network adapter types in hardware info list
PRL_IMAGE_FORMAT
PRL_INSTALL_APPLIANCE_FLAGS
Install appliance options
  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
PRL_IO_DISCONNECT_REASON
Specifies the reason of closing IO connection
PRL_IOPRIO
PRL_ISCSI_STORAGE_CMD_FLAGS
iSCSI storage management flags
PRL_ISCSI_STORAGE_FSTYPE_FLAGS
iSCSI storage filesystem type
PRL_JOB_OPERATION_CODE
Job operation codes
PRL_JOB_STATUS
Job status enumeration
PRL_KEY
Parallels virtual keycodes.
PRL_KEY_EVENT
PRL_LICENSE_RESTRICTION_KEY
License restriction options
PRL_LOGIN_LOCAL_FLAGS
PrlSrv_LoginLocal flags
PRL_MASS_STORAGE_INTERFACE_TYPE
Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM
Message type enumeration.
PRL_MOBILE_ADVANCED_AUTH_MODE
Authorization mode, when mobile client establishing remote access to the host.
PRL_MOUNT_VIRTUAL_DISK
Mount virtual disk flags
PRL_MOUSE_BUTTON
PRL_NET_ADAPTER_EMULATED_TYPE
Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE
Virtual Network type.
PRL_NETFILTER_MODE
Netfilter modes list
PRL_ONLINE_COMPACT_MODE
Online compact mode for virtual machine disks
PRL_OPTIMIZE_MODIFIERS_MODE
Determines the mode of modifiers handling inside the guest
PRL_PARAM_FIELD_DATA_TYPE
Event parameters fields types
PRL_PORT_FORWARDING_TYPE
Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PRINTER_INTERFACE_TYPE
Printer device interface type
PRL_PRIVATE_EVENT_TYPE
Private event types.
PRL_PROBLEM_REPORT_FLAGS
Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report
PRL_PROBLEM_REPORT_REASON
Problem report reason enumeration
PRL_PROBLEM_REPORT_SCHEME
Problem report scheme enumaration
PRL_PROBLEM_REPORT_TYPE
Problem report type enumeration
PRL_PROCESS_STATE_TYPE
Process state element
PRL_PRODUCT_ENUM
Parallels license products enumeration.
PRL_PROXY_CONNECTION_STATUS
Proxy connection status
PRL_QUERY_ELEMENT_FLAGS
Query element flags
PRL_REGISTER_3PARTY_VM_FLAGS
PrlSrv_Register3rdPartyVm command flags set
PRL_REGISTER_NEW_VM
PrlVm_RegEx flags
PRL_REGISTER_VM_FLAGS
PrlSrv_RegisterVmEx command flags set
PRL_RESIZE_IMAGE_FLAGS
PrlVmDev_ResizeImage command flags set
PRL_RUNNING_TASK_TYPE_ENUM
Running task type enumeration.
PRL_SCALE_VIEW_MODE
Aspect ratio mode
PRL_SECURITY_LEVEL
Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM
Parallels service statuses
PRL_SET_PROXY_CONNECTION_FLAGS
PrlDispCfg_SetProxyConnectionCreds flags
PRL_SET_USERPASSWD_FLAGS
PrlVmGuest_SetUserPasswd flags
PRL_SOUND_CHANNEL_TYPE
Sound channel type
PRL_SRV_SHUTDOWN_FLAGS
PrlSrv_ShutdownEx flags
PRL_SWITCH_SNAPSHOT_FLAGS
PrlVm_SwitchSnapshotEx flags
PRL_TASKBAR_STATES
Taskbar states
PRL_TIS_RECORD_FIELD
Parallels Tools Information Service record fields
PRL_TIS_RECORD_STATE
Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES
Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG
Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID
Parallels Tools Utility commands identifiers
PRL_UIEMU_ELEMENT_CONTROL_TYPE
PRL_UIEMU_GESTURE_STATE
PRL_UIEMU_GESTURE_TYPE
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
PRL_UIEMU_MMKEY
PRL_UIEMU_MOUSE_CLICK
PRL_UIEMU_SCROLL_FLAGS
PRL_UIEMU_SCROLL_UNITS
PRL_UNDO_DISKS_MODE
VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_UPDATE_LICENSE_FLAGS
Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation
PRL_USB_DEVICE_AUTO_CONNECT_OPTION
USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON
USB device connect/disconnect reason
PRL_USB_DEVICE_TYPE
USB device type
PRL_VERSION_ENUM
Parallels license versions enumeration.
PRL_VIDEO_3D_ACCELERATION
Video 3D acceleration
PRL_VIDEO_RECEIVER_CONNECTION_STATE
Streaming connection status enum
PRL_VIRTUAL_MACHINE_PROFILE
Virtual machine profiles enum
PRL_VMCTG_EVENT
Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)
PRL_VTD_STATUS_CODE
VTD status code
PRL_WINDOW_CORNERS
Window corners
PRL_WINDOW_EDGE_MASK
Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_ADDITION_STATE
Virtual machine addition states enumeration, may be combined with bitwise
VIRTUAL_MACHINE_STATE
Virtual machine states enumeration


Enumerations

Legend
Legend
Enumeration


Legend

Legend
Other Structs
Legend
Structure
Enumeration


Other Structs Structures

Other Structs Structures
Other Structs Legend
Structures
Name
Description
__PRL_DISK_PARAMETERS
Parallels disk parameters.
__PRL_IMAGE_PARAMETERS
Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
_ICryptInfo
Information about encryption plugin
_IPluginInfo
Generic information about plugin
_PRL_API_METHOD
Parallels API method
_PRL_CHS
CHS format of disk
_PRL_CPU_FEATURES
_PRL_CPU_FEATURES_MASK
_PRL_CPULIMIT_DATA
_PRL_CVSRC_OPEN_MODE
_PRL_GET_VM_CONFIG_PARAM_DATA
_PRL_GUID
Global unique identifier
_PRL_HOST_OS_INFO
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUDIO_DATA
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING_LIST
Audio support since 6.6 IO protocol version.
_PRL_IO_AUDIO_ENCODING_RESPONSE
Audio support since 6.6 IO protocol version.
_PRL_IO_AUTH_EXEC_REQUEST
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_AVAILABLE_DISPLAYS
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
_PRL_IO_ENCODING_RESPONSE
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_LANGUAGE_HOTKEYS
_PRL_IO_MEMORY_INFO
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SHUTDOWN_RESULT
_PRL_IO_SLIDING_MOUSE
_PRL_IO_SSO_CLIENT_VM_PACKET
_PRL_IO_TOOLS_ADJUST_WORKING_AREA
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data
  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command
  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_IOLIMIT_DATA
_PRL_PROXY_CLIENT_INFO
_PRL_PROXY_DATA_KEY
_PRL_PROXY_GEO_INFO
_PRL_PROXY_HOST_INFO
_PRL_PROXY_HOST_INFO_EXT
_PRL_PROXY_REGISTRATION_INFO
_PRL_PROXY_USER_DATA
_PRL_PTM_OBJECT
structure describes the object properties used by SetProperties and by PET_PTM_EVT_PROPERTY_CHANGED event
_PRL_PTM_PROPERTY
structure describes object property
_PRL_STAT_NET_TRAFFIC
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
_PRL_UIEMU_AUTOKEYBOARD
_PRL_UIEMU_CARET_INFO
_PRL_UIEMU_CURSOR_DESC
_PRL_UIEMU_CURSOR_FORMAT
_PRL_UIEMU_CURSOR_POS
_PRL_UIEMU_ELEMENT_AT_POS
_PRL_UIEMU_GESTURE_DATA_PINCH
_PRL_UIEMU_GESTURE_DATA_SMARTZOOM
_PRL_UIEMU_GESTURE_EVENT
_PRL_UIEMU_INPUT_INFO
_PRL_UIEMU_MAKEUP_HINTING_RGN
_PRL_UIEMU_SELECTION_HINTING_RGN
brief Rect as a part of region
_PRL_UIEMU_VKEY
_PRL_VMCTG_TOOL_DATA_RECEIVED
_PRL_VMCTG_TOOL_DESC
Describes the tool to be registered @see PrlVm_RegisterTool()
PRL_CHS
CHS format of disk
PRL_CPU_FEATURES
PRL_CPU_FEATURES_MASK
PRL_CPULIMIT_DATA
PRL_CVSRC_OPEN_MODE
PRL_DISK_PARAMETERS
Parallels disk parameters.
PRL_GET_VM_CONFIG_PARAM_DATA
PRL_HOST_OS_INFO
PRL_IMAGE_PARAMETERS
Parallels storage parameters
PRL_IO_DISPLAY_GAMMA
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
PRL_PROXY_CLIENT_INFO
PRL_PROXY_DATA_KEY
PRL_PROXY_GEO_INFO
PRL_PROXY_HOST_INFO
PRL_PROXY_HOST_INFO_EXT
PRL_PROXY_REGISTRATION_INFO
PRL_PROXY_USER_DATA
PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
PRL_STAT_NET_TRAFFIC
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *
  • TIS - Tools Information Service
*
  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_UIEMU_AUTOKEYBOARD
PRL_UIEMU_CARET_INFO
PRL_UIEMU_CURSOR_DESC
PRL_UIEMU_CURSOR_FORMAT
PRL_UIEMU_CURSOR_POS
PRL_UIEMU_ELEMENT_AT_POS
PRL_UIEMU_GESTURE_DATA_PINCH
PRL_UIEMU_GESTURE_DATA_SMARTZOOM
PRL_UIEMU_GESTURE_EVENT
PRL_UIEMU_INPUT_INFO
PRL_UIEMU_VKEY
PRL_VIDEO_RECEIVER_CONFIG
PRL_VIDEO_RECEIVER_FRAME
PRL_VIDEO_RECEIVER_FRAME_DESC
PRL_VIDEO_RECEIVER_STATISTICS
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY
PRL_VMCTG_TOOL_DATA_RECEIVED
PRL_VMCTG_TOOL_DESC
Describes the tool to be registered @see PrlVm_RegisterTool()


Structures

Legend
Legend
Structure


Other Types Types

Other Types Types
Other Types
Types
Name | Description
ICryptInfoPtr |
IPluginInfoPtr |
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_API_COMMAND_FLAGS_PTR |
PRL_API_INIT_FLAGS_PTR |
PRL_API_METHOD_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLIANCE_DOWNLOAD_STATUS_PTR |
PRL_APPLICATION_MODE_PTR |
PRL_AUDIO_STREAM_TYPE_PTR |
PRL_BIOS_TYPE_PTR |
PRL_CHS_PTR |
PRL_CLONE_VM_FLAGS_PTR |
PRL_CLUSTERED_DEVICE_SUBTYPE_PTR |
PRL_COMPACT_MODE_PTR |
PRL_CORNER_ACTIONS_PTR |
PRL_CPU_FEATURES_MASK_PTR |
PRL_CPU_FEATURES_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_CPU_VTX_MODE |
PRL_CPU_VTX_MODE_PTR |
PRL_CPULIMIT_DATA_PTR |
PRL_CREATE_DISK_IMAGE_FLAGS_PTR |
PRL_CT_CAPMASK_PTR |
PRL_CT_TEMPLATE_TYPE_PTR |
PRL_CVSRC_OPEN_MODE_PTR |
PRL_DATA_STATISTIC_SEGMENTS_PTR |
PRL_DISPLAY_BUFFER_FORMAT_PTR |
PRL_DISPLAY_CONFIG_MODE_PTR |
PRL_DISTRO_MEDIA_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_ENCRYPTION_FLAGS_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_EVENT_TYPE_PTR |
PRL_EXTERNAL_VM_TYPE_PTR |
PRL_FEATURES_MATRIX_PTR |
PRL_FIREWALL_DIRECTION_PTR |
PRL_FIREWALL_POLICY_PTR |
PRL_GENERIC_DEVICE_STATE_PTR |
PRL_GENERIC_PCI_DEVICE_CLASS_PTR |
PRL_GET_VM_CONFIG_FLAGS_PTR |
PRL_GET_VM_CONFIG_PARAM_DATA_PTR |
PRL_GET_VM_LIST_FLAGS_PTR |
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_IFACE_MASK_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_INFO_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_LICENSE_RESTRICTION_KEY_PTR |
PRL_LOGIN_LOCAL_FLAGS_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOBILE_ADVANCED_AUTH_MODE_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_NETFILTER_MODE_PTR |
PRL_ONLINE_COMPACT_MODE_PTR |
PRL_OPTIMIZE_MODIFIERS_MODE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PRINTER_INTERFACE_TYPE_PTR |
PRL_PRIVATE_EVENT_TYPE_PTR |
PRL_PROBLEM_REPORT_FLAGS_PTR |
PRL_PROBLEM_REPORT_REASON_PTR |
PRL_PROBLEM_REPORT_SCHEME_PTR |
PRL_PROBLEM_REPORT_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_PROXY_CLIENT_INFO_PTR |
PRL_PROXY_CONNECTION_STATUS_PTR |
PRL_PROXY_DATA_KEY_PTR |
PRL_PROXY_GEO_INFO_PTR |
PRL_PROXY_HOST_INFO_EXT_PTR |
PRL_PROXY_HOST_INFO_PTR |
PRL_PROXY_REGISTRATION_INFO_PTR |
PRL_PROXY_USER_DATA_PTR |
PRL_PTM_CONST_OBJECT_PTR |
PRL_PTM_CONST_PROPERTY_PTR |
PRL_PTM_OBJECT_PTR |
PRL_PTM_PROPERTY_PTR |
PRL_QUERY_ELEMENT_FLAGS_PTR |
PRL_REGISTER_3PARTY_VM_FLAGS_PTR |
PRL_REGISTER_NEW_VM_PTR |
PRL_REGISTER_VM_FLAGS_PTR |
PRL_RESIZE_IMAGE_FLAGS_PTR |
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SCALE_VIEW_MODE_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_SET_PROXY_CONNECTION_FLAGS_PTR |
PRL_SET_USERPASSWD_FLAGS_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_SOUND_CHANNEL_TYPE_PTR |
PRL_SRV_SHUTDOWN_FLAGS_PTR |
PRL_STAT_NET_TRAFFIC_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |
PRL_STR |
PRL_UIEMU_AUTOKEYBOARD_PTR |
PRL_UIEMU_CARET_INFO_PTR |
PRL_UIEMU_CURSOR_DESC_PTR |
PRL_UIEMU_CURSOR_FORMAT_PTR |
PRL_UIEMU_CURSOR_POS_PTR |
PRL_UIEMU_ELEMENT_AT_POS_PTR |
PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR |
PRL_UIEMU_GESTURE_DATA_PINCH_PTR |
PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR |
PRL_UIEMU_GESTURE_EVENT_PTR |
PRL_UIEMU_GESTURE_STATE_PTR |
PRL_UIEMU_GESTURE_TYPE_PTR |
PRL_UIEMU_INPUT_INFO_PTR |
PRL_UIEMU_MAKEUP_HINTING_RGN_PTR |
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR |
PRL_UIEMU_MMKEY_PTR |
PRL_UIEMU_MOUSE_CLICK_PTR |
PRL_UIEMU_SCROLL_FLAGS_PTR |
PRL_UIEMU_SCROLL_UNITS_PTR |
PRL_UIEMU_SELECTION_HINTING_RGN_PTR |
PRL_UIEMU_VKEY_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_UPDATE_LICENSE_FLAGS_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_USB_DEVICE_TYPE_PTR |
PRL_VERSION_ENUM_PTR |
PRL_VIDEO_3D_ACCELERATION_PTR |
PRL_VIDEO_RECEIVER_CONFIG_PTR |
PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR |
PRL_VIDEO_RECEIVER_FRAME_DESC_PTR |
PRL_VIDEO_RECEIVER_FRAME_PTR |
PRL_VIDEO_RECEIVER_STATISTICS_PTR |
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR |
PRL_VIRTUAL_MACHINE_PROFILE_PTR |
PRL_VM_MOUSE_CURSOR_STATE_PTR |
PRL_VM_MOUSE_STATE_PTR |
PRL_VM_NET_ADAPTER_WIFI_RULE_PTR |
PRL_VM_NORMAL_START_FLAGS_PTR |
PRL_VM_STATISTICS_FLAGS_PTR |
PRL_VMCTG_EVENT_PTR |
PRL_VMCTG_TOOL_DATA_RECEIVED_PTR |
PRL_VMCTG_TOOL_DESC_PTR |
PRL_VTD_STATUS_CODE_PTR |
PRL_WINDOW_CORNERS_PTR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_ADDITION_STATE_PTR |
VIRTUAL_MACHINE_STATE_PTR |


PET Macros Macros

PET Macros Macros
PET Macros
Macros
Name
Description
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_BROWSE
PET_ANSWER_CANCEL
PET_ANSWER_CHANGE
PET_ANSWER_COMMIT
PET_ANSWER_COMPACT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_DONT_CHANGE
PET_ANSWER_LATER
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK
  • Answers

+++ ALIGNED VALUE TO 16000
PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_RESTART
PET_ANSWER_RESTART_NOW
PET_ANSWER_RESTORE
PET_ANSWER_RESUME
PET_ANSWER_RETRY
PET_ANSWER_REVERT
PET_ANSWER_SET_RECOMMENDED
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_STOP_AND_RESTORE
PET_ANSWER_SUSPEND
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_USE_MAX_ALLOWED
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_COMMON_HDD_ERROR
PET_QUESTION_COMPACT_VM_DISKS
PET_QUESTION_CONTINUE_IF_HVT_DISABLED
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART
PET_QUESTION_DELAYED_COMPACT_VM_DISKS
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FORCE_COMPACT_VM_DISKS
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_ON_QUERY_END_SESSION
PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1
  • Questions

+++ ALIGNED VALUE TO 13000
PET_QUESTION_SAMPLE_2
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU
PET_QUESTION_STOP_VM_TO_COMPACT
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU
PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE
PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS
PRL_CPU_UNLIMITED
constant for unlimited CPU number


PHT_ACCESS_RIGHTS Functions

PHT_ACCESS_RIGHTS Functions
PHT_ACCESS_RIGHTS Legend
Functions
Name | Description
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.


Legend

Legend
PHT_ACCESS_RIGHTS
Legend
Method


PHT_BACKUP_RESULT Functions

PHT_BACKUP_RESULT Functions
PHT_BACKUP_RESULT Legend
Functions
Name | Description
PrlBackupResult_GetBackupUuid | Returns the UUID (universally unique ID) of the created backup


Legend

Legend
PHT_BACKUP_RESULT
Legend
Method


PHT_BOOT_DEVICE Functions

PHT_BOOT_DEVICE Functions
PHT_BOOT_DEVICE Legend
Functions
Name | Description
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.


Legend

Legend
PHT_BOOT_DEVICE
Legend
Method


PHT_CT_TEMPLATE Functions

PHT_CT_TEMPLATE Functions
PHT_CT_TEMPLATE Legend
Functions
Name | Description
PrlCtTemplate_GetCpuMode | Determines the specified template CPU mode (32 bit or 64 bit).
PrlCtTemplate_GetDescription | Returns description of the Container's template.
PrlCtTemplate_GetName | Returns name of the Container's template.
PrlCtTemplate_GetOsTemplate | Returns the version of the operating system template for which the specified application template is.
PrlCtTemplate_GetOsType | Returns the type of the operating system for which the specified template is.
PrlCtTemplate_GetOsVersion | Returns the version of the operating system for which the specified template is running.
PrlCtTemplate_GetType | Returns the type of the specified template.
PrlCtTemplate_GetVersion | Returns version of the Container's template.
PrlCtTemplate_IsCached | Determines whether the template cached.


Legend

Legend
PHT_CT_TEMPLATE
Legend
Method


PHT_CVSRC Functions

PHT_CVSRC Functions
PHT_CVSRC Legend
Functions
Name | Description
PrlCVSrc_Close | Close channel previously opened with PrlCVSrc_Open().
PrlCVSrc_Connect | Connects source to Vm.
PrlCVSrc_Disconnect | Disconnects source from Vm.
PrlCVSrc_GetBuffer | Returns frame buffer pointer and size.
PrlCVSrc_GetOpenMode | Returns current mode obtained after call to PrlCVSrc_Open().
PrlCVSrc_LockBuffer | Locks access to frame buffer.
PrlCVSrc_Open | Open channel to supply frames to Vm.
PrlCVSrc_SetLocalizedName | Set source name.
PrlCVSrc_SetUniqueId | Set source unique id.
PrlCVSrc_UnlockBuffer | Unlocks access to frame buffer and submits changes to Vm.


Legend

Legend
PHT_CVSRC
Legend
Method


PHT_DISP_CONFIG Functions

PHT_DISP_CONFIG Functions
PHT_DISP_CONFIG Legend
Functions
Name | Description
PrlDispCfg_ArePluginsEnabled | Determines whether the plugins enabled or not
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_EnablePlugins | Enable or disable the plugins support
PrlDispCfg_GetBackupTimeout | Get backup timeout in seconds.
PrlDispCfg_GetBackupTmpDir | Returns the backup temporary directory.
PrlDispCfg_GetBackupUserLogin | Returns the backup user login.
PrlDispCfg_GetConfirmationsList | Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )
PrlDispCfg_GetCpuFeaturesMaskEx | Allows to get the CPU features masks from dispatcher config.
PrlDispCfg_GetDefaultBackupDirectory | Returns PATH to the default backup directory.
PrlDispCfg_GetDefaultBackupServer | Returns the default backup server host name or IP address.
PrlDispCfg_GetDefaultCtDir | Obtains path of the directory in which new Container are created by default.
PrlDispCfg_GetDefaultEncryptionPluginId | Returns default encryption plugin Id.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetMobileAdvancedAuthMode | Get the advanced authorization mode for Parallels Access clients.
PrlDispCfg_GetProxyConnectionStatus | Determines proxy connection status or error code of last proxy operation.
PrlDispCfg_GetProxyConnectionUser | Returns the name of user associated with current proxy connection.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetUsbIdentity | Returns handle of type PHT_USB_IDENTITY storing information of USB device with specified index.
PrlDispCfg_GetUsbIdentityCount | Determines number of USB devices known to the Parallels Service.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_IsAllowAttachScreenshotsEnabled | Determines whether the allow attach screenshots is enabled for problem report.
PrlDispCfg_IsAllowDirectMobile | Determines whether the Allow Direct Mobile Connections option is enabled.
PrlDispCfg_IsAllowMobileClients | Determines whether the Allow Mobile Clients option is enabled.
PrlDispCfg_IsAllowMultiplePMC | Determines whether the Allow Multiple PMC option is enabled.
PrlDispCfg_IsBackupUserPasswordEnabled | Returns the backup user password enabling sign.
PrlDispCfg_IsLogRotationEnabled | Determines whether the log rotation is enabled for dispatcher and virtual machine logs.
PrlDispCfg_IsProxyEnabled | Determines whether dispatcher should connect to the mobile proxy server by default.
PrlDispCfg_IsSendStatisticReport | Determines whether send statistics reports (CEP) mechanism activated.
PrlDispCfg_IsVerboseLogEnabled | Determines whether the verbose log level is configured for dispatcher and virtual machines processes.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetAllowAttachScreenshotsEnabled | Enables or disables the allow attach screenshots for problem report.
PrlDispCfg_SetAllowDirectMobile | Enables or disables the Allow Direct Mobile option.
PrlDispCfg_SetAllowMultiplePMC | Enables or disables the Allow Multiple PMC option.
PrlDispCfg_SetBackupTimeout | Set backup timeout in seconds.
PrlDispCfg_SetBackupTmpDir | Sets the backup temporary directory.
PrlDispCfg_SetBackupUserLogin | Sets the backup user login.
PrlDispCfg_SetBackupUserPassword | Sets the backup user password.
PrlDispCfg_SetBackupUserPasswordEnabled | Sets the backup user password.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetConfirmationsList | Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )
PrlDispCfg_SetCpuFeaturesMaskEx | Allows to set the CPU features masks.
PrlDispCfg_SetDefaultBackupDirectory | Sets PATH to the default backup directory.
PrlDispCfg_SetDefaultBackupServer | Sets the default backup server host name or IP address.
PrlDispCfg_SetDefaultEncryptionPluginId | Sets default encryption plugin Id.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetLogRotationEnabled | Enables or disables the log rotation for dispatcher and virtual machine logs.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetMobileAdvancedAuthMode | Set the advanced authorization mode for Parallels Access clients.
PrlDispCfg_SetProxyConnectionCreds | Specifies credentials for establishing a proxy connection.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetSendStatisticReport | Allows to switch on/off mechanism of sending statistics reports (CEP).
PrlDispCfg_SetUsbIdentAssociation | (Un)Associates USB device with given Vm.
PrlDispCfg_SetVerboseLogEnabled | Enables or disables the verbose log level for dispatcher and virtual machines processes.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.


Legend

Legend
PHT_DISP_CONFIG
Legend
Method


PHT_EVENT Functions

PHT_EVENT Functions
PHT_EVENT Legend
Functions
Name | Description
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.


Legend

Legend
PHT_EVENT
Legend
Method


PHT_EVENT_PARAMETER Functions

PHT_EVENT_PARAMETER Functions
PHT_EVENT_PARAMETER Legend
Functions
Name | Description
PrlEvtPrm_GetBuffer | Returns the event parameter value as binary buffer.
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToInt64 | Returns the event parameter value as PRL_INT64.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.
PrlEvtPrm_ToUint64 | Returns the event parameter value as PRL_UINT64.


Legend

Legend
PHT_EVENT_PARAMETER
Legend
Method


PHT_FIREWALL_RULE Functions

PHT_FIREWALL_RULE Functions
PHT_FIREWALL_RULE Legend
Functions
Name | Description
PrlFirewallRule_Create | Creates a new handle of type PHT_FIREWALL_RULE.
PrlFirewallRule_GetLocalNetAddress | Returns the local address of the specified firewall rule entry.
PrlFirewallRule_GetLocalPort | Returns the local port.
PrlFirewallRule_GetProtocol | Returns the protocol of the specified firewall rule entry.
PrlFirewallRule_GetRemoteNetAddress | Returns the remote address of the specified firewall rule entry.
PrlFirewallRule_GetRemotePort | Returns the remote port.
PrlFirewallRule_SetLocalNetAddress | Sets the specified firewall rule entry local address.
PrlFirewallRule_SetLocalPort | Sets the specified local port.
PrlFirewallRule_SetProtocol | Sets the specified firewall rule entry protocol.
PrlFirewallRule_SetRemoteNetAddress | Sets the specified firewall rule entry remote address.
PrlFirewallRule_SetRemotePort | Sets the specified remote port.


Legend

Legend
PHT_FIREWALL_RULE
Legend
Method


PHT_FOUND_VM_INFO Functions

PHT_FOUND_VM_INFO Functions
PHT_FOUND_VM_INFO Legend
Functions
Name | Description
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.


Legend

Legend
PHT_FOUND_VM_INFO
Legend
Method


PHT_GUEST_OSES_MATRIX Functions

PHT_GUEST_OSES_MATRIX Functions
PHT_GUEST_OSES_MATRIX Legend
Functions
Name | Description
PrlOsesMatrix_GetDefaultOsVersion | Returns default guest OS version for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).
PrlOsesMatrix_GetSupportedOsesTypes | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list retrieved from remote server (see PrlSrv_GetSupportedOses).
PrlOsesMatrix_GetSupportedOsesVersions | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).


Legend

Legend
PHT_GUEST_OSES_MATRIX
Legend
Method


PHT_HANDLES_LIST Functions

PHT_HANDLES_LIST Functions
PHT_HANDLES_LIST Legend
Functions
Name | Description
PrlHndlList_AddItem | Adds the specified handle to the container.
PrlHndlList_GetItem | Retrieves a handle from the container.
PrlHndlList_GetItemsCount | Determines the total number of handles in the specified container.
PrlHndlList_RemoveItem | Removes a handle from the container.


Legend

Legend
PHT_HANDLES_LIST
Legend
Method


PHT_HW_GENERIC_DEVICE Functions

PHT_HW_GENERIC_DEVICE Functions
PHT_HW_GENERIC_DEVICE Legend
Functions
Name | Description
PrlSrvCfgDev_GetDeviceState | Determines whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.
PrlSrvCfgDev_GetId | Obtains the device ID.
PrlSrvCfgDev_GetName | Obtains the device name.
PrlSrvCfgDev_GetType | Obtains the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to a virtual machine.
PrlSrvCfgDev_SetDeviceState | Allows to specify whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.


Legend

Legend
PHT_HW_GENERIC_DEVICE
Legend
Method


PHT_HW_GENERIC_PCI_DEVICE Functions

PHT_HW_GENERIC_PCI_DEVICE Functions
PHT_HW_GENERIC_PCI_DEVICE Legend
Functions
Name | Description
PrlSrvCfgPci_GetDeviceClass | Obtains the class of the PCI device (network, display, sound, etc.).


Legend

Legend
PHT_HW_GENERIC_PCI_DEVICE
Legend
Method


PHT_HW_HARD_DISK Functions

PHT_HW_HARD_DISK Functions
PHT_HW_HARD_DISK Legend
Functions
Name | Description
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.


Legend

Legend
PHT_HW_HARD_DISK
Legend
Method


PHT_HW_HARD_DISK_PARTITION Functions

PHT_HW_HARD_DISK_PARTITION Functions
PHT_HW_HARD_DISK_PARTITION Legend
Functions
Name | Description
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.


Legend

Legend
PHT_HW_HARD_DISK_PARTITION
Legend
Method


PHT_HW_NET_ADAPTER Functions

PHT_HW_NET_ADAPTER Functions
PHT_HW_NET_ADAPTER Legend
Functions
Name | Description
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDefaultGatewayIPv6 | Returns the default IPv6 gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_GetVlanTag | Returns the VLAN tag of the specified network adapter.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsConfigureWithDhcpIPv6 | Determines whether the adapter IPv6 network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.


Legend

Legend
PHT_HW_NET_ADAPTER
Legend
Method


PHT_IPPRIV_NET Functions

PHT_IPPRIV_NET Functions
PHT_IPPRIV_NET Legend
Functions
Name | Description
PrlIPPrivNet_Create | Creates a new handle of type PHT_IPPRIV_NET.
PrlIPPrivNet_GetName | Returns the name of the specified private network.
PrlIPPrivNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a private network.
PrlIPPrivNet_IsGlobal | Determines the mode (global or not) of the specified private network.
PrlIPPrivNet_SetGlobal | Sets the mode (global or not) of the specified private network.
PrlIPPrivNet_SetName | Sets the specified private network ID.
PrlIPPrivNet_SetNetAddresses | Allows to set IP addresses/Subnet masks to a private network.


Legend

Legend
PHT_IPPRIV_NET
Legend
Method


PHT_JOB Functions

PHT_JOB Functions
PHT_JOB Legend
Functions
Name | Description
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_IsRequestWasSent | Returns the sign whether request was sent to remote side or was aborted by some local reasons (wrong params passed or something else).
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.


Legend

Legend
PHT_JOB
Legend
Method


PHT_LICENSE Functions

PHT_LICENSE Functions
PHT_LICENSE Legend
Functions
Name | Description
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.


Legend

Legend
PHT_LICENSE
Legend
Method


PHT_LOGIN_RESPONSE Functions

PHT_LOGIN_RESPONSE Functions
PHT_LOGIN_RESPONSE Legend
Functions
Name | Description
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).


Legend

Legend
PHT_LOGIN_RESPONSE
Legend
Method


PHT_NET_SERVICE_STATUS Functions

PHT_NET_SERVICE_STATUS Functions
PHT_NET_SERVICE_STATUS Legend
Functions
Name | Description
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.


Legend

Legend
PHT_NET_SERVICE_STATUS
Legend
Method


PHT_NETWORK_CLASS Functions

PHT_NETWORK_CLASS Functions
PHT_NETWORK_CLASS Legend
Functions
Name | Description
PrlNetworkClass_Create | Creates a new handle of type PHT_NETWORK_CLASS.
PrlNetworkClass_GetClassId | Returns the network class id.
PrlNetworkClass_GetNetworkList | Returns the list of networks for specified network class entry.
PrlNetworkClass_SetClassId | Sets the network class id.
PrlNetworkClass_SetNetworkList | Sets the list of networks for specified network class entry.


Legend

Legend
PHT_NETWORK_CLASS
Legend
Method


PHT_NETWORK_RATE Functions

PHT_NETWORK_RATE Functions
PHT_NETWORK_RATE Legend
Functions
Name | Description
PrlNetworkRate_Create | Creates a new handle of type PHT_NETWORK_RATE.
PrlNetworkRate_GetClassId | Returns the network rate entry class id.
PrlNetworkRate_GetRate | Returns the network rate entry Rate value.


Legend

Legend
PHT_NETWORK_RATE
Legend
Method


PHT_NETWORK_SHAPING Functions

PHT_NETWORK_SHAPING Functions
PHT_NETWORK_SHAPING Legend
Functions
Name | Description
PrlNetworkShapingEntry_Create | Creates a new handle of type PHT_NETWORK_SHAPING.
PrlNetworkShapingEntry_GetClassId | Returns the network class id.
PrlNetworkShapingEntry_GetDevice | Returns the network device for specified shaping entry.
PrlNetworkShapingEntry_GetRate | Returns the default rate for specified shaping entry.
PrlNetworkShapingEntry_GetTotalRate | Returns the total rate for specified shaping entry.
PrlNetworkShapingEntry_SetClassId | Sets the network class id for specified shaping entry.
PrlNetworkShapingEntry_SetDevice | Sets the specified network device.
PrlNetworkShapingEntry_SetRate | Sets the default network guaranteed rate.
PrlNetworkShapingEntry_SetTotalRate | Sets the total rate for specified shaping entry.


Legend

Legend
PHT_NETWORK_SHAPING
Legend
Method


PHT_NETWORK_SHAPING_BANDWIDTH Functions

PHT_NETWORK_SHAPING_BANDWIDTH Functions
PHT_NETWORK_SHAPING_BANDWIDTH Legend
Functions
Name | Description
PrlNetworkShapingBandwidthEntry_Create | Creates a new handle of type PHT_NETWORK_SHAPING_BANDWIDTH.
PrlNetworkShapingBandwidthEntry_GetBandwidth | Returns the network device bandwidth for specified shaping entry.
PrlNetworkShapingBandwidthEntry_GetDevice | Returns the network device name for specified shaping entry.
PrlNetworkShapingBandwidthEntry_SetBandwidth | Sets the network device bandwidth for specified shaping entry.
PrlNetworkShapingBandwidthEntry_SetDevice | Sets the network device name for specified shaping entry.


Legend

Legend
PHT_NETWORK_SHAPING_BANDWIDTH
Legend
Method


PHT_NETWORK_SHAPING_CONFIG Functions

PHT_NETWORK_SHAPING_CONFIG Functions
PHT_NETWORK_SHAPING_CONFIG Legend
Functions
Name | Description
PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList | Obtains a list of network shaping bandwidth entries represents the network shaping configuration.
PrlNetworkShapingConfig_GetNetworkShapingList | Obtains a list of network shaping entries represents the network shaping configuration.
PrlNetworkShapingConfig_IsEnabled | Determines whether the network shaping is enabled or disabled.
PrlNetworkShapingConfig_SetEnabled | Allows to enable or disable the network shaping.
PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList | Update the list of network device bandwidth represents the network shaping configuration.
PrlNetworkShapingConfig_SetNetworkShapingList | Update the list of network shaping entries represents the network shaping configuration.


Legend

Legend
PHT_NETWORK_SHAPING_CONFIG
Legend
Method


PHT_OFFLINE_SERVICE Functions

PHT_OFFLINE_SERVICE Functions
PHT_OFFLINE_SERVICE Legend
Functions
Name | Description
PrlOffmgmtService_Create | Creates a new handle of type PHT_OFFLINE_SRVICE.
PrlOffmgmtService_GetName | Returns the name of the specified offline service.
PrlOffmgmtService_GetPort | Returns the port of the specified offline service.
PrlOffmgmtService_IsUsedByDefault | Returns the type of the flag of the specified offline service used by default.
PrlOffmgmtService_SetName | Sets the specified offline service name.
PrlOffmgmtService_SetPort | Sets the specified offline service port.
PrlOffmgmtService_SetUsedByDefault | Sets the default flag type for the specified offline service.


Legend

Legend
PHT_OFFLINE_SERVICE
Legend
Method


PHT_OPAQUE_TYPE_LIST Functions

PHT_OPAQUE_TYPE_LIST Functions
PHT_OPAQUE_TYPE_LIST Legend
Functions
Name | Description
PrlOpTypeList_AddItem | Adds a new item to the container.
PrlOpTypeList_GetItem | Extracts the specified item from the container.
PrlOpTypeList_GetItemsCount | Determines the number of items in the container.
PrlOpTypeList_GetTypeSize | Extracts the size of type of items storing in container.
PrlOpTypeList_RemoveItem | Removes the specified item from the container.


Legend

Legend
PHT_OPAQUE_TYPE_LIST
Legend
Method


PHT_PLUGIN_INFO Functions

PHT_PLUGIN_INFO Functions
PHT_PLUGIN_INFO Legend
Functions
Name | Description
PrlPluginInfo_GetCopyright | Returns copyright of the plugin.
PrlPluginInfo_GetId | Returns identificator of the plugin in GUID format.
PrlPluginInfo_GetLongDescription | Returns long description about the plugin.
PrlPluginInfo_GetShortDescription | Returns short description about the plugin.
PrlPluginInfo_GetVendor | Returns the vendor of the plugin.
PrlPluginInfo_GetVersion | Returns the version of the plugin.


Legend

Legend
PHT_PLUGIN_INFO
Legend
Method


PHT_PORT_FORWARDING Functions

PHT_PORT_FORWARDING Functions
PHT_PORT_FORWARDING Legend
Functions
Name | Description
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_GetRedirectVm | Returns the redirect virtual machine identifier of the specified port forward entry.
PrlPortFwd_GetRuleName | Returns the rule name of the specified port forward entry.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.
PrlPortFwd_SetRedirectVm | Sets the specified port forward entry virtual machine identifier.
PrlPortFwd_SetRuleName | Sets the specified port forward entry rule name.


Legend

Legend
PHT_PORT_FORWARDING
Legend
Method


PHT_PROBLEM_REPORT Functions

PHT_PROBLEM_REPORT Functions
PHT_PROBLEM_REPORT Legend
Functions
Name | Description
PrlReport_Assembly | Assembles the problem report.
PrlReport_AsString | Returns XML based string representation of problem report.
PrlReport_GetArchiveFileName | Returns problem report archive file name which can be used for further problem report data saving and processing.
PrlReport_GetCombinedReportId | Gets problem report's CombineReportId which is used to match several reports on a server side.
PrlReport_GetData | Returns the binary representation of problem report.
PrlReport_GetDescription | Obtains the problem report description.
PrlReport_GetRating | Gets rating of product using.
PrlReport_GetReason | Obtains the value of the property, identifying the reason for this project report.
PrlReport_GetScheme | Determines the scheme used by the problem report object.
PrlReport_GetType | Determines the type of the problem report object.
PrlReport_GetUserEmail | Obtains the e-mail address of the user on the problem report.
PrlReport_GetUserName | Obtains the name of the user on the problem report.
PrlReport_Send | The PrlReport_Send function is provided for convenience.
PrlReport_SetCombinedReportId | Sets problem report's CombineReportId which is used to match two reports on a server side.
PrlReport_SetDescription | Sets the specified problem report description.
PrlReport_SetRating | Sets rating of product using.
PrlReport_SetReason | Sets the value of the object property, identifying the reason for this problem report.
PrlReport_SetType | Sets the problem report object type.
PrlReport_SetUserEmail | Sets the e-mail address of the user on the problem report.
PrlReport_SetUserName | Sets the name of the user on the problem report.


Legend

Legend
PHT_PROBLEM_REPORT
Legend
Method


PHT_REMOTE_FILESYSTEM_ENTRY Functions

PHT_REMOTE_FILESYSTEM_ENTRY Functions
PHT_REMOTE_FILESYSTEM_ENTRY Legend
Functions
Name | Description
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).


Legend

Legend
PHT_REMOTE_FILESYSTEM_ENTRY
Legend
Method


PHT_REMOTE_FILESYSTEM_INFO Functions

PHT_REMOTE_FILESYSTEM_INFO Functions
PHT_REMOTE_FILESYSTEM_INFO Legend
Functions
Name | Description
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.


Legend

Legend
PHT_REMOTE_FILESYSTEM_INFO
Legend
Method


PHT_RESULT Functions

PHT_RESULT Functions
PHT_RESULT Legend
Functions
Name | Description
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.


Legend

Legend
PHT_RESULT
Legend
Method


PHT_RUNNING_TASK Functions

PHT_RUNNING_TASK Functions
PHT_RUNNING_TASK Legend
Functions
Name | Description
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).


Legend

Legend
PHT_RUNNING_TASK
Legend
Method


PHT_SCREEN_RESOLUTION Functions

PHT_SCREEN_RESOLUTION Functions
PHT_SCREEN_RESOLUTION Legend
Functions
Name | Description
PrlScrRes_GetHeight | Returns the height of the specified screen resolution.
PrlScrRes_GetWidth | Returns width of the specified screen resolution.
PrlScrRes_IsEnabled | Determines whether the screen resolution is enabled or not.
PrlScrRes_Remove | Removes the specified screen resolution from the virtual machine.
PrlScrRes_SetEnabled | Enables or disables the specified screen resolution.
PrlScrRes_SetHeight | Modifies the specified screen resolution height.
PrlScrRes_SetWidth | Modifies the specified screen resolution width.


Legend

Legend
PHT_SCREEN_RESOLUTION
Legend
Method


PHT_SERVER Functions

PHT_SERVER Functions
PHT_SERVER Legend
Functions
Name
Description
PrlSrv_ActivateInstalledLicenseOffline
Offline activation of installed Parallels license.
PrlSrv_ActivateInstalledLicenseOnline
Online activation of installed Parallels license.
PrlSrv_AddIPPrivateNetwork
Adds a new private network to the Parallels Service configuration.
PrlSrv_AddVirtualNetwork
Adds a new virtual network to the Parallels Service configuration.
PrlSrv_AttachToLostTask
The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CancelInstallAppliance
Cancels the appliance installation previously started with the PrlSrv_InstallAppliance function call.
PrlSrv_CheckParallelsServerAlive
Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CheckParallelsServerAliveEx
The same functionality as previos version of call except follow things:
  • provides asynch interface;
  • using TCP connection instead of UDP.
PrlSrv_CommonPrefsBeginEdit
The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit
The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommitEx
PrlSrv_ConfigureGenericPci
Configures the PCI device assignment.
PrlSrv_CopyCtTemplate
Copy the specified Containers template to the specified server.
PrlSrv_Create
Creates a new handle of type PHT_SERVER.
PrlSrv_CreateDesktopControl
Creates Desktop Control object.
PrlSrv_CreateUnattendedCd
Creates a bootable ISO-image for unattended Linux installation.
PrlSrv_CreateVm
Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_CreateVmBackup
Backup an existing virtual machine to backup server.
PrlSrv_DeactivateInstalledLicense
Deactivate installed Parallels license.
PrlSrv_DeleteOfflineService
Removes an existing offline service configuration.
PrlSrv_DeleteVirtualNetwork
Removes an existing virtual network from the Parallels Service configuration.
PrlSrv_DisableConfirmationMode
Disable administrator confirmation mode for the session.
PrlSrv_EnableConfirmationMode
Enable administrator confirmation mode for the session.
PrlSrv_FsCanCreateFile
Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir
Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName
Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries
Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList
Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry
Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry
Renames a file system entry on the host.
PrlSrv_GetAllHostUsers
Obtains a list of handles of type PHT_EVENT containing in its parameters information about all registered host users.
PrlSrv_GetBackupTree
Get backups tree from backup server.
PrlSrv_GetCommonPrefs
Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetCtTemplateList
Retrieves a list of Containers templates registered with the specified Parallels Service.
PrlSrv_GetDefaultVmConfig
Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_GetDiskFreeSpace
Get available disk space for path.
PrlSrv_GetDisplayEncodingList
Returns currently supported display encodings both by server and client.
PrlSrv_GetIPPrivateNetworksList
Obtains a list of handles of type PHT_IPPRIV_NET containing information about all existing private networks.
PrlSrv_GetLicenseInfo
Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus
Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetNetworkClassesList
Obtains a list of handles of type PHT_HANDLES_LIST containing the list of handles of type PHT_NETWORK_CLASS.
PrlSrv_GetNetworkShapingConfig
Obtains the network shaping configuration.
PrlSrv_GetOfflineServicesList
Obtains a list of handles of type PHT_OFFLINE_SERVICE containing information about all existing services.
PrlSrv_GetPackedProblemReport
Allows to receive a packed problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetPerfStats
Obtains a handle of type PHT_EVENT containing the perfomance statistics.
PrlSrv_GetPluginsList
Gets plugin list with plugin info entries.
PrlSrv_GetProblemReport
Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions
The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetRegisteredHostsOnProxy
Do authentication on proxy server and returns list of registered hosts on this proxy.
PrlSrv_GetRestrictionInfo
Gets restriction info.
PrlSrv_GetServerInfo
Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig
Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics
Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetSupportedOses
Extracts supported guest OSes matrix from remote server (it's more proper way instead of using local synch API in case when client and server interoperate remotely).
PrlSrv_GetUserInfo
Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList
Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile
Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList
Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmConfig
Get VM config by given UUID or name.
PrlSrv_GetVmList
Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_GetVmListEx
Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_HasRestriction
Determines having restriction.
PrlSrv_InstallAppliance
Sends an appliance configuration to the Parallels Service in order to install the corresponding appliance from Parallels download service.
PrlSrv_IsConfirmationModeEnabled
Determines confirmation mode for the session
PrlSrv_IsConnected
Determines if the connection to the specified Parallels Service is active.
PrlSrv_IsFeatureSupported
Checks whether specified feature supported by remote side.
PrlSrv_IsNonInteractiveSession
Determines if the session is noninteractive or interactive.
PrlSrv_IsProxyConnection
Determines if the connection to the specified Parallels Service is a proxy connection.
PrlSrv_Login
Performs a remote login operation using the specified parameters.
PrlSrv_LoginEx
PrlSrv_LoginLocal
Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_LoginLocalEx
PrlSrv_Logoff
Logs off the Parallels Service.
PrlSrv_LookupParallelsServers
Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart
Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults
Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart
Starts the Parallels network service.
PrlSrv_NetServiceStop
Stops the Parallels network service.
PrlSrv_ProxyLogin
Performs a remote proxy login operation using the specified parameters.
PrlSrv_ProxyLoginEx
PrlSrv_RefreshPlugins
Refreshes states of installed parallels plugins.
PrlSrv_RegEventHandler
Registers an event handler.
PrlSrv_Register3rdPartyVm
Registers an existing 3rd party virtual machine with Parallels Service.
PrlSrv_RegisterVm
Registers an existing virtual machine with Parallels Service.
PrlSrv_RegisterVmEx
Registers an existing virtual machine with Parallels Service.
PrlSrv_RegisterVmWithUuid
Registers an existing virtual machine with custom Vm UUID.
PrlSrv_RemoveCtTemplate
Removes the specified Containers template.
PrlSrv_RemoveIPPrivateNetwork
Removes an existing private network from the Parallels Service configuration.
PrlSrv_RemoveVmBackup
Remove backup of the virtual machine from backup server.
PrlSrv_RestoreVmBackup
Restore backup of the virtual machine from backup server.
PrlSrv_SecureLogin
Performs a remote login operation using the specified parameters.
PrlSrv_SecureProxyLogin
Performs a remote proxy login operation using the specified parameters.
PrlSrv_SendAnswer
Sends an answer to the Parallels Service in response to a question.
PrlSrv_SendProblemReport
Requests a server to send a problem report with possibility to append also the problem report assemblied at the client's side.
PrlSrv_SetCertificateRevocationDateTime
Sets the revocation date time for SSL certificates, used in trusted channel connection.
PrlSrv_SetGlobalDateTime
Sets the current trusted time, that will be used for SSL certificate check.
PrlSrv_SetNonInteractiveSession
Sets the session in noninteractive or interactive mode.
PrlSrv_SetVNCEncryption
Set VNC encryption.
PrlSrv_Shutdown
Shuts down the Parallels Service.
PrlSrv_ShutdownEx
PrlSrv_StartSearchVms
Searches for unregistered virtual machines at the specified location(s).
PrlSrv_StopInstallAppliance
Stops the appliance installation previously started with the PrlSrv_InstallAppliance function call.
PrlSrv_SubscribeToHostStatistics
Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_SubscribeToPerfStats
Allows to subscribe to periodically receive perfomance statistics.
PrlSrv_UnregEventHandler
Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics
Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats
Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateIPPrivateNetwork
Updates parameters of an existing private network.
PrlSrv_UpdateLicense
Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateLicenseEx
PrlSrv_UpdateNetworkClassesList
Update network class classes configuration.
PrlSrv_UpdateNetworkShapingConfig
Update the network shaping configuration.
PrlSrv_UpdateOfflineService
Add/Updates parameters of an offline management service.
PrlSrv_UpdateSessionInfo
Updates parameters of opened session.
PrlSrv_UpdateVirtualNetwork
Updates parameters of an existing virtual network.
PrlSrv_UserProfileBeginEdit
Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit
Saves (commits) user profile changes to the Parallels Service.


Legend

Legend
PHT_SERVER
Legend
Method


PHT_SERVER_CONFIG Functions

PHT_SERVER_CONFIG Functions
PHT_SERVER_CONFIG Legend
Functions
Name | Description
PrlSrvCfg_Create | Creates a new handle of type PHT_SERVER_CONFIG.
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuFeatures | To get the CPU features from server hSrvConfig : A handle of type PRL_HANDLE.
PrlSrvCfg_GetCpuFeaturesEx | Allows to get the CPU features from server.
PrlSrvCfg_GetCpuFeaturesMaskingCapabilities | Allows to get the CPU features masking capabilities from server
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDefaultGateway | Obtains the global default gateway address of the specified host or guest.
PrlSrvCfg_GetDefaultGatewayIPv6 | Obtains the global default IPv6 gateway address of the specified host or guest.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers for the specified host or guest.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the hostname of the specified host or guest.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetMaxHostNetAdapters | Returns max possible Parallels network adapters on the host.
PrlSrvCfg_GetMaxVmNetAdapters | Returns max possible Parallels virtual network adapters which can be applied per VM.
PrlSrvCfg_GetNetAdapter | Obtains a handle of type PHT_HW_NET_ADAPTER containing information about a network adapter installed in the host or guest.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of printer ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains for the specified host or guest.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.
PrlSrvCfgPci_IsPrimaryDevice | Determines whether a specified PCI device (network adapter, display adapter, sound card, etc.) is the primary adapter in the system.


Legend

Legend
PHT_SERVER_CONFIG
Legend
Method


PHT_SERVER_INFO Functions

PHT_SERVER_INFO Functions
PHT_SERVER_INFO Legend
Functions
Name | Description
PrlSrvInfo_GetApplicationMode | Returns the application mode of server.
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).
PrlSrvInfo_GetStartTime | Returns the service start time in milliseconds since Epoch (01-01-1970).
PrlSrvInfo_GetStartTimeMonotonic | Returns the service start time in milliseconds (monotonic time clock).


Legend

Legend
PHT_SERVER_INFO
Legend
Method


PHT_SHARE Functions

PHT_SHARE Functions
PHT_SHARE Legend
Functions
Name | Description
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.


Legend

Legend
PHT_SHARE
Legend
Method


PHT_STRINGS_LIST Functions

PHT_STRINGS_LIST Functions
PHT_STRINGS_LIST Legend
Functions
Name | Description
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.


Legend

Legend
PHT_STRINGS_LIST
Legend
Method


PHT_SYSTEM_STATISTICS Functions

PHT_SYSTEM_STATISTICS Functions
PHT_SYSTEM_STATISTICS Legend
Functions
Name | Description
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns the total virtual machine usage time in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetRealRamSize | Returns the amount of physical memory, in bytes, currently occupied by the virtual machine.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.
PrlStat_GetVmDataStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_VM_DATA containing the specified system VM data statistic.


Legend

Legend
PHT_SYSTEM_STATISTICS
Legend
Method


PHT_SYSTEM_STATISTICS_CPU Functions

PHT_SYSTEM_STATISTICS_CPU Functions
PHT_SYSTEM_STATISTICS_CPU Legend
Functions
Name | Description
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.


Legend

Legend
PHT_SYSTEM_STATISTICS_CPU
Legend
Method


PHT_SYSTEM_STATISTICS_DISK Functions

PHT_SYSTEM_STATISTICS_DISK Functions
PHT_SYSTEM_STATISTICS_DISK Legend
Functions
Name | Description
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_DISK
Legend
Method


PHT_SYSTEM_STATISTICS_DISK_PARTITION Functions

PHT_SYSTEM_STATISTICS_DISK_PARTITION Functions
PHT_SYSTEM_STATISTICS_DISK_PARTITION Legend
Functions
Name | Description
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_DISK_PARTITION
Legend
Method


PHT_SYSTEM_STATISTICS_IFACE Functions

PHT_SYSTEM_STATISTICS_IFACE Functions
PHT_SYSTEM_STATISTICS_IFACE Legend
Functions
Name | Description
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.


Legend

Legend
PHT_SYSTEM_STATISTICS_IFACE
Legend
Method


PHT_SYSTEM_STATISTICS_PROCESS Functions

PHT_SYSTEM_STATISTICS_PROCESS Functions
PHT_SYSTEM_STATISTICS_PROCESS Legend
Functions
Name | Description
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_PROCESS
Legend
Method


PHT_SYSTEM_STATISTICS_USER_SESSION Functions

PHT_SYSTEM_STATISTICS_USER_SESSION Functions
PHT_SYSTEM_STATISTICS_USER_SESSION Legend
Functions
Name | Description
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.


Legend

Legend
PHT_SYSTEM_STATISTICS_USER_SESSION
Legend
Method


PHT_UIEMU_INPUT Functions

PHT_UIEMU_INPUT Functions
PHT_UIEMU_INPUT Legend
Functions
Name | Description
PrlUIEmuInput_AddText | Add text to input object.
PrlUIEmuInput_AddVKeys | Add virtual keys to input object.
PrlUIEmuInput_Create | Creates input object.


Legend

Legend
PHT_UIEMU_INPUT
Legend
Method


PHT_USB_IDENTITY Functions

PHT_USB_IDENTITY Functions
PHT_USB_IDENTITY Legend
Functions
Name | Description
PrlUsbIdent_GetFriendlyName | Returns user friendly name of USB device.
PrlUsbIdent_GetSystemName | Returns system name for USB device.
PrlUsbIdent_GetVmUuidAssociation | Returns Uuid of Vm associated with USB device or empty string if no association is specified.


Legend

Legend
PHT_USB_IDENTITY
Legend
Method


PHT_USER_INFO Functions

PHT_USER_INFO Functions
PHT_USER_INFO Legend
Functions
Name | Description
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).


Legend

Legend
PHT_USER_INFO
Legend
Method


PHT_USER_PROFILE Functions

PHT_USER_PROFILE Functions
PHT_USER_PROFILE Legend
Functions
Name | Description
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_IsLocalAdministrator | Determines if the user is a local administrator account on the host where Parallels Service started.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.


Legend

Legend
PHT_USER_PROFILE
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_FLOPPY
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_HARD_DISK
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_HARD_DISK Functions

PHT_VIRTUAL_DEV_HARD_DISK Functions
PHT_VIRTUAL_DEV_HARD_DISK Legend
Functions
Name | Description
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_CheckPassword | Checks whether specified for encrypted virtual hard disk password matched to the current one.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetMountPoint | Returns the mount point of the specified virtual hard disk.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_GetStorageURL | Return custom storage URL.
PrlVmDevHd_IsAutoCompressEnabled | Returns the auto compress flag of the specified virtual hard disk.
PrlVmDevHd_IsEncrypted | Returns sign whether virtual hard disk device is encrypted.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetAutoCompressEnabled | Sets the auto compress sign flag of the specified virtual hard disk.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetMountPoint | Sets the mount point of the specified virtual hard disk.
PrlVmDevHd_SetPassword | Lets to setup password for virtual hard disk device in case if last one is encrypted (this password uses then at calls PrlVmDevHd_CheckPassword and PrlVm_Commit)
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.
PrlVmDevHd_SetStorageURL | Set custom storage URL.


Legend

Legend
PHT_VIRTUAL_DEV_HARD_DISK
Legend
Method


PHT_VIRTUAL_DEV_HD_PARTITION Functions

PHT_VIRTUAL_DEV_HD_PARTITION Functions
PHT_VIRTUAL_DEV_HD_PARTITION Legend
Functions
Name | Description
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.


Legend

Legend
PHT_VIRTUAL_DEV_HD_PARTITION
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_NET_ADAPTER
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_NET_ADAPTER Functions

PHT_VIRTUAL_DEV_NET_ADAPTER Functions
PHT_VIRTUAL_DEV_NET_ADAPTER Legend
Functions
Name | Description
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetAdapterType | Obtain the adapter type assigned to a virtual network adapter.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDefaultGatewayIPv6 | Obtains the default gateway (IPv6) assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetFirewallDefaultPolicy | Gets an adapter firewall default policy.
PrlVmDevNet_GetFirewallRuleList | Returns the firewall rule entries list.
PrlVmDevNet_GetHostInterfaceName | Obtains the custom host adapter name.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine (in Parallels format XXXXXXXXXXXX).
PrlVmDevNet_GetMacAddressCanonical | Returns the MAC address of a virtual network adapter inside a virtual machine (in human-friendly format xx:xx:xx:xx:xx:xx).
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetVirtualNetworkId | Obtains the virtual network ID assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_IsAutoApply | Determines if the specified network adapter is configured to automatically apply network settings inside guest.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_IsConfigureWithDhcpIPv6 | Determines if the specified network adapter is configured through DHCP (IPv6) on the guest OS side.
PrlVmDevNet_IsFirewallEnabled | Gets state switched on or off of the adapter firewall.
PrlVmDevNet_IsPktFilterPreventIpSpoof | Determines if the specified network adapter is configured to filter net packages and send packages only from IP addresses in the adapter NetAdrresses list.
PrlVmDevNet_IsPktFilterPreventMacSpoof | Determines if the specified network adapter is configured to filter net packages and send packages only from its own MAC address.
PrlVmDevNet_SetAdapterType | Allows to manually assign adapter type to a network adapter.
PrlVmDevNet_SetAutoApply | Allows to specify whether a network adapter in a virtual machine should be automatically configured.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetConfigureWithDhcpIPv6 | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP (IPv6) or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDefaultGatewayIPv6 | Allows to manually set the default gateway address (IPv6) for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetFirewallDefaultPolicy | Sets an adapter firewall default policy.
PrlVmDevNet_SetFirewallEnabled | Sets state switched on or off of the adapter firewall.
PrlVmDevNet_SetFirewallRuleList | Sets the firewall rule entries list.
PrlVmDevNet_SetHostInterfaceName | Sets the custom host adapter name in a bridged networking mode, (autogenerated if not set) hVmDev : A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetPktFilterPreventIpSpoof | Allows to specify whether a network adapter in a virtual machine should perform the filtration by IP addresses.
PrlVmDevNet_SetPktFilterPreventMacSpoof | Allows to specify whether a network adapter in a virtual machine should filter packets through MAC address spoofing.
PrlVmDevNet_SetPktFilterPreventPromisc | Allows to specify whether a network adapter in a virtual machine should receive packets sent not to VM.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.
PrlVmDevNet_SetVirtualNetworkId | Allows to set the virtual network ID for a network adapter in a virtual machine.


Legend

Legend
PHT_VIRTUAL_DEV_NET_ADAPTER
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_OPTICAL_DISK
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_PARALLEL_PORT
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_SERIAL_PORT
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_SERIAL_PORT Functions

PHT_VIRTUAL_DEV_SERIAL_PORT Functions
PHT_VIRTUAL_DEV_SERIAL_PORT Legend
Functions
Name | Description
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.


Legend

Legend
PHT_VIRTUAL_DEV_SERIAL_PORT
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_SOUND
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_SOUND Functions

PHT_VIRTUAL_DEV_SOUND Functions
PHT_VIRTUAL_DEV_SOUND Legend
Functions
Name | Description
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.


Legend

Legend
PHT_VIRTUAL_DEV_SOUND
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_USB_DEVICE
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_USB_DEVICE Functions

PHT_VIRTUAL_DEV_USB_DEVICE Functions
PHT_VIRTUAL_DEV_USB_DEVICE Legend
Functions
Name | Description
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.


Legend

Legend
PHT_VIRTUAL_DEV_USB_DEVICE
Legend
Method


PHT_VIRTUAL_DISK Functions

PHT_VIRTUAL_DISK Functions
PHT_VIRTUAL_DISK Legend
Functions
Name | Description
PrlDisk_ChangeKey | This function used to change the key of the encrypted disk
PrlDisk_Coagulate | Combines all available disk snapshots into a single entity.
PrlDisk_CommitUnfinishedOp | Commits unfinished state operation (interrupted).
PrlDisk_Compact | This method is deprecated now.
PrlDisk_CompactByBitmap | Compacts a virtual disk with free blocks map.
PrlDisk_ConvertToCHS | This function used to convert disk size in blocks to the Cylinders-Heads-Sectors (CHS) format, used at disk creation
PrlDisk_ConvertToCurrent | Converts virtual disks that were created with an older version of Parallels Service to the current version.
PrlDisk_ConvertToCurrent_Local | Converts virtual disks that were created with an older version of Parallels Service to the current version.
PrlDisk_ConvertToExtendFormat | Convert all Expanding images to Extend_Expanding
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Takes a snapshot of the specified virtual disk.
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_Decrypt | This function used to encrypt whole disk
PrlDisk_DeleteState | Deletes the specified virtual disk snapshot.
PrlDisk_Encrypt | This function used to encrypt whole disk
PrlDisk_FixConsistency | Checks and fixes consistency of a virtual disk.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | Frees the PHT_VIRTUAL_DISK handle.
PrlDisk_GetDefaultBlockSize | This function used to get default block size of disk
PrlDisk_GetDiskInfo | Obtains the information about the specified virtual disk.
PrlDisk_GetIdentify | This function used to get HDD identify information as it shown in guest OS
PrlDisk_GetSnapshotsCount | Determines the number of snapshots of the specified virtual disk.
PrlDisk_GetSnapshotsTree | Obtains the entire snapshot tree for the specified virtual disk.
PrlDisk_GetSplitPartSize | This function used to get splitted disk part size
PrlDisk_GetUserParameter | Retrieves user-defined parameter values stored on a virtual disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsBootable_Local | This function used to check is the disk bootable or not
PrlDisk_IsCompactable | Determines if the specified virtual disk can be compacted.
PrlDisk_IsEncrypted | This function used to check is the disk encrypted or not
PrlDisk_LinkedClone_Local | This function used to create a linked clone disk
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk on a local machine.
PrlDisk_Read | Reads data from the specified virtual disk.
PrlDisk_SetCachingPolicy | Set the caching policy for a virtual disk.
PrlDisk_SetKey | This function used to set the key to the encrypted disk
PrlDisk_SetSharedDirectory | Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.
PrlDisk_SetSharedDirectory_Local | Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.
PrlDisk_SetUserParameter | Stores user-defined parameter values on a virtual disk.
PrlDisk_SwitchToState | Reverts a virtual disk to the specified snapshot.
PrlDisk_WaitForCompletion | Waits for the background thread to finish executing before returning control to the client.
PrlDisk_Write | Writes data to the specified virtual disk.


Legend

Legend
PHT_VIRTUAL_DISK
Legend
Method


PHT_VIRTUAL_MACHINE Functions

PHT_VIRTUAL_MACHINE Functions
PHT_VIRTUAL_MACHINE Legend
Functions
Name | Description
PrlVm_Authorise | Authorises current session against encrypted virtual machine.
PrlVm_AuthWithGuestSecurityDb | Performs an attempt to authenticate the user through the guest OS security database.
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompact | Finishes process of optimization of virtual hard disk.
PrlVm_CancelConvertDisks | Finishes process of conversion of the virtual hard disk(s).
PrlVm_ChangePassword | Changes current password of encrypted virtual machine on new one.
PrlVm_ChangeSid | Generates and assigns a new Windows SID to the specified virtual machine running Windows guest OS.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_CloneEx | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CommitEx | The PrlVm_CommitEx function is the same as PrlVm_Commit function but with the flags
PrlVm_Compact | Start process of optimization of virtual hard disk.
PrlVm_Connect | Connect to remote desktop.
PrlVm_ConvertDisks | Start process conversion of the virtual hard disk(s).
PrlVm_CreateCVSrc | Creates video source object.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateP2PTransport | Create handle of type PHT_VIDEO_RECEIVER.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedDisk | Creates a disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Decrypt | Decrypts earlier encrypted with some secret password phrase virtual machine.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_Disconnect | Disconnect from remote desktop.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_Encrypt | Encrypts virtual machine data using specified secret password phrase.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetPackedProblemReport | The PrlVm_GetPackedProblemReport function obtains a Packed problem report on abnormal virtual machine termination.
PrlVm_GetPerfStats | Obtains a handle of type PHT_EVENT containing the virtual machine performance statistics.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetSnapshotsTreeEx |
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetStatisticsEx | The PrlVm_GetStatisticsEx function is the same as PrlVm_GetStatistics function but with the flags
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LinkedClone | Clones an existing virtual machine based on given snapshot.
PrlVm_Lock | Lets to exclusively lock VM for current session.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_MigrateWithRename | Migrates an existing virtual machine to another host.
PrlVm_MigrateWithRenameEx | Migrates an existing virtual machine to another host.
PrlVm_Mount | Mount the specified virtual machine Virtual Disks.
PrlVm_Move | Move bundle of virtual machine or private area of container.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_PtmExec | Executes an remote procedure.
PrlVm_PtmQuery | Query object properties .
PrlVm_PtmSet | Set object properties .
PrlVm_PtmSubscribe | Subscribe on object properties changes.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | See also PrlVm_RegEx
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_RegEx | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RemoveProtection | Removes protection from virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_ResetUptime | Resets the virtual machine uptime counter (start date and counter itself).
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_SendClipboardRequest | @brief Requests clipboard buffer from Vm @note This call is intended to be asynchronious with possibility to be synchroneous.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_SetProtection | Protects virtual machine using specified secret password phrase.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopEx | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_SubscribeToPerfStats | Allows to subscribe to periodicaly receive virtual machine perfomance statistics.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_SwitchToSnapshotEx | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_TisSubscribe | Subscribe on TIS database updates.
PrlVm_TisUnsubscribe | Unsubscribe from TIS database updates.
PrlVm_ToolsGetShutdownCapabilities | Obtains the available capabilities of a graceful virtual machine shutdown using Parallels Tools.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_ToolsSetTaskBarVisibility | brief Show/Hide task bar in guest.
PrlVm_UIEmuQueryCaretInfo | Posts "get caret info" query to guest User Input Emulation tool.
PrlVm_UIEmuQueryElementAtPos | Posts "get info on element at specified position" query to guest User Input Emulation tool.
PrlVm_UIEmuQueryNearestElementAtPos | Posts "get info on nearest element at specified position" query to guest User Input Emulation tool.
PrlVm_UIEmuSendClick | Send mouse click event to User Input Emulation.
PrlVm_UIEmuSendGestureEvent | Sends a gesture event to guest User Input Emulation tool.
PrlVm_UIEmuSendInput | Send input to guest.
PrlVm_UIEmuSendMultimediaKey | Sends a multimedia key to guest User Input Emulation tool.
PrlVm_UIEmuSendScroll | Send scroll event to User Input Emulation.
PrlVm_UIEmuSendText | Send specified UTF8 text to guest User Input Emulation tool.
PrlVm_Umount | Unmount the specified virtual machine Virtual Disks.
PrlVm_Unlock | Lets to unlock previously locked with PrlVm_Lock call VM.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.


Legend

Legend
PHT_VIRTUAL_MACHINE
Legend
Method


PHT_VIRTUAL_NETWORK Functions

PHT_VIRTUAL_NETWORK Functions
PHT_VIRTUAL_NETWORK Legend
Functions
Name | Description
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundAdapterInfo | Obtains physical adapter info which bound to the virtual network object.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIP6Address | Returns the DCHP IPv6 address of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIP6Address | Returns the host IPv6 address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIP6NetMask | Returns the IPv6 net mask of the specified virtual network.
PrlVirtNet_GetIP6ScopeEnd | Returns the DHCP end IPv6 address of the specified virtual network.
PrlVirtNet_GetIP6ScopeStart | Returns the DHCP start IPv6 address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_GetVlanTag | Returns the VLAN tag of the specified virtual network.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCP6ServerEnabled | Determines whether the specified virtual network DHCPv6 server is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDHCP6ServerEnabled | Allows to enable or disable a specified virtual network DHCPv6 server.
PrlVirtNet_SetDhcpIP6Address | Sets the specified virtual network DHCP IPv6 address.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIP6Address | Sets the specified virtual network host IPv6 address.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIP6NetMask | Sets the specified virtual network IPv6 net mask.
PrlVirtNet_SetIP6ScopeEnd | Sets the specified virtual network DHCP end IPv6 address.
PrlVirtNet_SetIP6ScopeStart | Sets the specified virtual network DHCP start IPv6 address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.
PrlVirtNet_SetVlanTag | Sets the VLAN tag for the specified virtual network.


Legend

Legend
PHT_VIRTUAL_NETWORK
Legend
Method


PHT_VM_CONFIGURATION Functions

PHT_VM_CONFIGURATION Functions
PHT_VM_CONFIGURATION Legend
Functions
Name
Description
PrlVmCfg_AddDefaultDevice
The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_AddDefaultDeviceEx
The PrlVmCfg_AddDefaultDeviceEx function automates the task of setting devices in a virtual machine.
PrlVmCfg_ApplyConfigSample
Specify the Configuration sample file
PrlVmCfg_CreateBootDev
Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes
Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare
Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev
Creates a new virtual device handle of the specified type.
PrlVmCfg_Get3DAccelerationMode
Gets 3D graphical acceleration technology mode for the specified virtual machine.
PrlVmCfg_GetAccessRights
Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetActionOnStopMode
Gets action on stop mode.
PrlVmCfg_GetActionOnWindowClose
Determines the action on Parallels Application window close for the specified virtual machine.
PrlVmCfg_GetAllDevices
Obtains a handles list of all virtual devices in a virtual machine.
PrlVmCfg_GetAppInDockMode
Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAppTemplateList
Returns the list of application templates installed for the specified Container.
PrlVmCfg_GetAssetId
Returns the specified virtual machine asset id.
PrlVmCfg_GetAutoCompressInterval
Determines the interval at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_GetAutoStart
Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay
Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop
Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority
Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev
Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount
Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetCapabilitiesMask
Returns a capabilities mask specified inside the CT.
PrlVmCfg_GetCoherenceButtonVisibility
Determines if a "Coherence Button" for the specified virtual machine should be shown when a user points to a Windows Start button
PrlVmCfg_GetConfigValidity
The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetConfirmationsList
Obtains a handles list of operations with virtual machine which required administrator confirmation
PrlVmCfg_GetCpuAccelLevel
Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount
Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuLimit
Determines the CPU usage limit of a virtual machine, in percent.
PrlVmCfg_GetCpuLimitEx
Determines the specified virtual machine CPU limit.
PrlVmCfg_GetCpuMask
Returns the specified virtual machine CPU affinity mask
PrlVmCfg_GetCpuMode
Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits
Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty
Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize
The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize
The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDefaultVideoRamSize
The PrlVmCfg_GetDefaultVideoRamSize function returns the default video RAM size for the specified OS type and version.
PrlVmCfg_GetDescription
Returns the specified virtual machine description.
PrlVmCfg_GetDevByType
Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount
Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType
Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDisplayDev
Obtains a handle of type PHT_VIRTUAL_DEV_DISPLAY containing information about a display device in a virtual machine.
PrlVmCfg_GetDisplayDevsCount
Determines the number of display devices in a virtual machine.
PrlVmCfg_GetDnsServers
Obtains the list of of globally defined DNS servers which is assigned to a Virtuozzo Container.
PrlVmCfg_GetDockIconType
Returns the virtual machine dock icon type.
PrlVmCfg_GetEnvId
Returns the Container id of the specified virtual machine.
PrlVmCfg_GetExpirationDate
Gets expiration date.
PrlVmCfg_GetExpirationNote
Gets expiration note.
PrlVmCfg_GetExpirationOfflineTimeToLive
Gets the offline time of working with virtual machine.
PrlVmCfg_GetExpirationTimeCheckInterval
Gets the time interval to check on expiration date.
PrlVmCfg_GetExpirationTrustedTimeServer
Gets trusted time server.
PrlVmCfg_GetExternalBootDevice
Returns an external boot device system name.
PrlVmCfg_GetFeaturesMask
Returns a features mask specified inside the CT.
PrlVmCfg_GetFloppyDisk
Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount
Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority
Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetFreeDiskSpaceRatio
Determines the free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_GetGenericPciDev
Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount
Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev
Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount
Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk
Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount
Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHighAvailabilityPriority
Determines the priority of the virtual machine in the High Availability Cluster.
PrlVmCfg_GetHomePath
Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostMemQuotaMax
Returns the maximal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.
PrlVmCfg_GetHostMemQuotaMin
Returns the minimal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.
PrlVmCfg_GetHostMemQuotaPriority
Returns the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.
PrlVmCfg_GetHostname
Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon
Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetIoLimit
Determines the specified virtual machine I/O limit.
PrlVmCfg_GetIoPriority
Determines the specified virtual machine I/O priority.
PrlVmCfg_GetIopsLimit
Determines the specified virtual machine IOPS limit.
PrlVmCfg_GetLastModifiedDate
Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName
Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetLinkedVmUuid
Returns the UUID (universally unique ID) of the parent virtual machine which was used to create current linked cloned virtual machine (if last one is linked clone of some virtual machine - this value will be empty otherwise).
PrlVmCfg_GetLocation
Returns the virtual machine files location type.
PrlVmCfg_GetMaxBalloonSize
Returns the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.
PrlVmCfg_GetName
Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter
Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount
Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetNetfilterMode
Returns netfilter mode specified inside the CT.
PrlVmCfg_GetNetworkRateList
Obtains the list of shaping rated
PrlVmCfg_GetOfflineServices
Obtains the list of services available in the virtual machine offline management.
PrlVmCfg_GetOpticalDisk
Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount
Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOptimizeModifiersMode
Gets optimize modifiers mode.
PrlVmCfg_GetOsTemplate
Returns Operation System template name the Parallels Virtuozzo Container were created on.
PrlVmCfg_GetOsType
Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion
Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort
Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual printer port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount
Determines the number of virtual printer ports in the specified virtual machine.
PrlVmCfg_GetProfile
Get current VM profile.
PrlVmCfg_GetRamSize
Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetResource
Returns beancounters barrier and limit for specified resource id.
PrlVmCfg_GetScrRes
Obtains a handle of type PHT_SCREEN_RESOLUTION identifying the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount
Determines the total number of screen resolutions available in a virtual machine.
PrlVmCfg_GetSearchDomains
Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort
Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount
Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost
Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid
Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare
Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount
Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSmartGuardInterval
Determines the interval at which snapshots are taken by SmartGuard.
PrlVmCfg_GetSmartGuardMaxSnapshotsCount
Determines the maximum snapshot count, a SmartGuard setting.
PrlVmCfg_GetSoundDev
Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount
Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode
Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin
Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags
Returns the virtual machine system flags.
PrlVmCfg_GetTimeSyncInterval
Obtains the time synchronization interval between the host and a guest OS.
PrlVmCfg_GetUnattendedInstallEdition
Returns edition for unattended installation.
PrlVmCfg_GetUnattendedInstallLocale
Returns locale for unattended installation.
PrlVmCfg_GetUndoDisksMode
Determines the current undo-disks mode for the specified virtual machine.
PrlVmCfg_GetUptime
Returns the virtual machine uptime in seconds since some datetime (see PrlVmCfg_GetUptimeStartDate).
PrlVmCfg_GetUptimeStartDate
Returns the date and time when uptime counter calculation was started for the specified virtual machine.
PrlVmCfg_GetUsbDevice
Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount
Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid
Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize
Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVmInfo
Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVmCfg_GetVmType
Get the Virtual Machine type.
PrlVmCfg_GetVNCHostName
Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode
Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword
Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort
Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode
Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsAdaptiveHypervisorEnabled
Determines disable or enable adaptive hypervisor.
PrlVmCfg_IsAllowSelectBootDevice
Determines whether select boot device should be shown on virtual machine startup.
PrlVmCfg_IsAutoApplyIpOnly
Determines if the Guest configured to automatically apply IP addrs network settings inside guest.
PrlVmCfg_IsAutoCaptureReleaseMouse
Determines whether the automatic capture and release of the mouse pointer is enabled or not.
PrlVmCfg_IsAutoCompressEnabled
Determines whether the Automatic HDD compress feature is enabled or not in a virtual machine.
PrlVmCfg_IsBatteryStatusEnabled
Determines disable or enable battery status.
PrlVmCfg_IsCloseAppOnShutdown
Determines whether the Parallels application (such as Parallels Desktop) will be automatically closed on the virtual machine shutdown.
PrlVmCfg_IsConfigInvalid
The PrlVmCfg_IsConfigInvalid function is used to check the
  • error code of PrlVmCfg_GetConfigValidity function that
  • indicates the invalid status of the config:
  • config doesn't exist, parsing error, invalid server uuid,
  • invalid VM uuid.
  • Parameters
  • nErrCode : The nErrCode value from PrlVmCfg_GetConfigValidity()
  • pbInvalid : [out] validity sign.
PrlVmCfg_IsCpuHotplugEnabled
Determines whether the CPU hotplug is available in the virtual machine.
PrlVmCfg_IsCpuVtxEnabled
Determines whether the x86 virtualization (such as Vt-x) is available in the virtual machine CPU.
PrlVmCfg_IsCustomProfile
Determines were settings modified after profile was applied or not.
PrlVmCfg_IsDefaultDeviceNeeded
Determines whether the virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC
Determines whether the APIC is enabled or disabled during the virtual machine runtime.
PrlVmCfg_IsDisableSpeaker
Determines whether the speaker is enabled or disabled during the virtual machine runtime.
PrlVmCfg_IsDiskCacheWriteBack
Determines if disk cache write-back is enabled in the specified virtual machine.
PrlVmCfg_IsEfiEnabled
Determines whether EFI boot is switched on.
PrlVmCfg_IsEncrypted
Determines whether the virtual machine is in encrypted state
PrlVmCfg_IsExcludeDock
Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsExpirationDateEnabled
Gets expiration date status.
PrlVmCfg_IsGuestSharingAutoMount
Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled
Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight
Determines if the virtual disks in a virtual machine will be added to Spotlight search subsystem (OS X feature).
PrlVmCfg_IsHideMinimizedWindowsEnabled
Determines disable or enable hiding minimized windows.
PrlVmCfg_IsHighAvailabilityEnabled
Determines whether the High Availability feature is enabled or not for a virtual machine.
PrlVmCfg_IsHighResolutionEnabled
Determines disable or enable high resolution video mode for the specified virtual machine.
PrlVmCfg_IsHostMemAutoQuota
Determines whether the automatic calculation of the host's memory (RAM) consumption parameters enabled for the virtual machine.
PrlVmCfg_IsHostSharingEnabled
Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsIsolatedVmEnabled
Determines disable or enable isolated VM.
PrlVmCfg_IsLockGuestOnSuspendEnabled
Determines disable or enable lock guest on suspend.
PrlVmCfg_IsLockInFullScreenMode
Determines whether the lock in screen mode sign is set or not in a virtual machine configuration.
PrlVmCfg_IsLongerBatteryLifeEnabled
Determines disable or enable longer battery life.
PrlVmCfg_IsMapSharedFoldersOnLetters
Determines whether host disks shared with the guest Windows OS will be mapped to drive letters.
PrlVmCfg_IsMultiDisplay
Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsNestedVirtualizationEnabled
Determines disable or enable nested virtualization.
PrlVmCfg_IsOfflineManagementEnabled
Determines whether the offline management feature is enabled for a virtual machine.
PrlVmCfg_IsOsResInFullScrMode
Determines wether the virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsPauseWhenIdle
Determines if the VM pauses automatically when it becomes idle (i.e.
PrlVmCfg_IsPMUVirtualizationEnabled
Determines disable or enable PMU virtualization.
PrlVmCfg_IsProtected
Determines whether the virtual machine is in protected state
PrlVmCfg_IsRamHotplugEnabled
Determines whether the memory (RAM) hotplug is available in the virtual machine.
PrlVmCfg_IsRateBound
Determines whether the ratebound is enabled or not.
PrlVmCfg_IsRelocateTaskBar
Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled
Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks
Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsShareClipboard
Determines whether the clipboard sharing feature is enabled or disabled in a virtual machine.
PrlVmCfg_IsSharedAppsGuestToHost
Determines whether the guest applications shared to host or not.
PrlVmCfg_IsSharedAppsHostToGuest
Determines whether the host applications shared to guest or not.
PrlVmCfg_IsSharedBluetoothEnabled
Determines disable or enable bluetooth camera.
PrlVmCfg_IsSharedCameraEnabled
Determines disable or enable shared camera.
PrlVmCfg_IsSharedCloudEnabled
Determines whether shared cloud is enabled or disabled.
PrlVmCfg_IsSharedProfileEnabled
Determines whether the Shared Profile feature is enabled in a virtual machine.
PrlVmCfg_IsShareUserHomeDir
Determines whether the host user home directory will be available in the guest OS as a share.
PrlVmCfg_IsShowTaskBar
Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsShowWindowsAppInDock
Determines whether the "Show Windows Applications folder in Dock" feature is enabled or not.
PrlVmCfg_IsSmartGuardEnabled
Determines whether the SmartGuard feature is enabled or not in a virtual machine.
PrlVmCfg_IsSmartGuardNotifyBeforeCreation
Determines whether the user will be notified on automatic snapshot creation, a SmartGaurd setting.
PrlVmCfg_IsSmartMountDVDsEnabled
Determines whether the SmartMount CD/DVD drives is enabled or not.
PrlVmCfg_IsSmartMountEnabled
Determines whether the SmartMount feature is enabled or not.
PrlVmCfg_IsSmartMountNetworkSharesEnabled
Determines whether the SmartMount network shares is enabled or not.
PrlVmCfg_IsSmartMountRemovableDrivesEnabled
Determines whether the SmartMount removable drives is enabled or not.
PrlVmCfg_IsSmartMouseEnabled
Determines disable or enable smart mouse.
PrlVmCfg_IsStartInDetachedWindowEnabled
Determines disable or enable start in detached window.
PrlVmCfg_IsStickyMouseEnabled
Determines disable or enable sticky mouse.
PrlVmCfg_IsSupportUsb30Enabled
Gets support status USB 3.0.
PrlVmCfg_IsSwitchOffAeroEnabled
Determines disable or enable switching off aero.
PrlVmCfg_IsSwitchOffWindowsLogoEnabled
Determines disable or enable Windows logo.
PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled
Determines disable or enable switching to full screen on demand.
PrlVmCfg_IsSyncDefaultPrinter
Gets synchronization default printer option.
PrlVmCfg_IsTemplate
Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsTimeSynchronizationEnabled
Determines whether the time synchronization feature is enabled in a virtual machine.
PrlVmCfg_IsTimeSyncSmartModeEnabled
Determines whether the smart time synchronization is enabled in a virtual machine.
PrlVmCfg_IsToolsAutoUpdateEnabled
Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.
PrlVmCfg_IsUseDefaultAnswers
Determines whether the use default answers mechanism active for the virtual machine.
PrlVmCfg_IsUseDesktop
Determines whether the "use desktop in shared profile" feature is enabled or not.
PrlVmCfg_IsUseDocuments
Determines whether "use documents in shared profile" feature is enabled or not.
PrlVmCfg_IsUseDownloads
Determines whether the "used downloads in shared profile" feature is enabled or not.
PrlVmCfg_IsUseHostPrinters
Gets use host printers option.
PrlVmCfg_IsUseMovies
Determines whether the "used movies in shared profile" feature is enabled or not.
PrlVmCfg_IsUseMusic
Determines whether the "use music in shared profile" feature is enabled or not.
PrlVmCfg_IsUsePictures
Determines whether the "used pictures in shared profile" feature is enabled or not.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled
Determines whether the user-defined shared folders are enabled or not.
PrlVmCfg_IsVerticalSynchronizationEnabled
Determines disable or enable vertical synchronization video mode for the specified virtual machine.
PrlVmCfg_IsVirtualLinksEnabled
Determines whether the Virtual Links feature is enabled in a virtual machine.
PrlVmCfg_IsWinSystrayInMacMenuEnabled
Determines disable or enable Windows systray in Mac menu.
PrlVmCfg_Set3DAccelerationMode
Sets 3D graphical acceleration technology mode for the specified virtual machine.
PrlVmCfg_SetActionOnStopMode
Sets action on stop mode.
PrlVmCfg_SetActionOnWindowClose
Allows to set the action on Parallels Application window close for the specified virtual machine.
PrlVmCfg_SetAdaptiveHypervisorEnabled
Disables or enables adaptive hypervisor.
PrlVmCfg_SetAllowSelectBootDevice
Switches on/off select boot device dialog on virtual machine startup.
PrlVmCfg_SetAppInDockMode
Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAppTemplateList
Specify application templates list which will be used in the specified Parallels Virtuozzo Container.
PrlVmCfg_SetAssetId
Sets the virtual machine asset id.
PrlVmCfg_SetAutoApplyIpOnly
Allows to specify whether a virtual machine should be automatically configured for IP addrs.
PrlVmCfg_SetAutoCaptureReleaseMouse
Enables or disables the automatic capture and release of the mouse pointer in a virtual machine.
PrlVmCfg_SetAutoCompressEnabled
Enables the Automatic HDD compress feature in a virtual machine.
PrlVmCfg_SetAutoCompressInterval
Sets the time interval at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_SetAutoStart
Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay
Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop
Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority
Sets the virtual machine background processes priority.
PrlVmCfg_SetBatteryStatusEnabled
Disables or enables battery status.
PrlVmCfg_SetCapabilitiesMask
Sets a capabilities inside the CT.
PrlVmCfg_SetCloseAppOnShutdown
Allows to specify whether the Parallels application (such Parallels Desktop) will be closed on the virtual machine shutdown.
PrlVmCfg_SetCoherenceButtonVisibility
Sets the virtual machine "Coherence Button visibility" option.
PrlVmCfg_SetConfirmationsList
Determines a list of operations with virtual machine which required administrator confirmation
PrlVmCfg_SetCpuAccelLevel
Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount
Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuHotplugEnabled
Sets CPU hotplug mode (enabled or disabled) for the specified virtual machine.
PrlVmCfg_SetCpuLimit
Sets the CPU usage limit (in percent) for a virtual machine.
PrlVmCfg_SetCpuLimitEx
Sets limit of CPU usage for the virtual machine in Mhz.
PrlVmCfg_SetCpuMask
Sets the CPU affinity for a virtual machine.
PrlVmCfg_SetCpuMode
Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits
Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty
Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig
The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription
Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign
Allows to specify whether the virtual machine should be using APIC during runtime.
PrlVmCfg_SetDisableSpeakerSign
Allows to specify whether the virtual machine should be using speaker during runtime.
PrlVmCfg_SetDiskCacheWriteBack
Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers
Allows to manually assign DNS servers a virtual machine.
PrlVmCfg_SetDockIconType
Sets the virtual machine dock icon type.
PrlVmCfg_SetEfiEnabled
Sets EFI boot for the virtual machine.
PrlVmCfg_SetExcludeDock
Sets the exclude dock option.
PrlVmCfg_SetExpirationDate
Sets expiration date.
PrlVmCfg_SetExpirationDateEnabled
Sets expiration date enabled/disabled.
PrlVmCfg_SetExpirationNote
Sets expiration note.
PrlVmCfg_SetExpirationOfflineTimeToLive
Sets the offline time of working with virtual machine.
PrlVmCfg_SetExpirationTimeCheckInterval
Sets the time interval to check on expiration date.
PrlVmCfg_SetExpirationTrustedTimeServer
Sets trusted time server.
PrlVmCfg_SetExternalBootDevice
Sets an external boot device system name.
PrlVmCfg_SetFeaturesMask
Sets a features inside the CT.
PrlVmCfg_SetForegroundPriority
Sets the virtual machine foreground processes priority.
PrlVmCfg_SetFreeDiskSpaceRatio
Sets the time free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.
PrlVmCfg_SetGuestSharingAutoMount
Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled
Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight
Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHideMinimizedWindowsEnabled
Disables or enables hiding minimized windows.
PrlVmCfg_SetHighAvailabilityEnabled
Enables or disables the High Availability feature for a virtual machine.
PrlVmCfg_SetHighAvailabilityPriority
Sets the priority of the virtual machine in the High Availability Cluster.
PrlVmCfg_SetHighResolutionEnabled
Disables or enables high resolution video mode for the specified virtual machine.
PrlVmCfg_SetHostMemAutoQuota
Enables or disables the automatic calculation of the host's memory (RAM) consumption parameters for the virtual machine.
PrlVmCfg_SetHostMemQuotaMax
Sets the maximal size of the host's memory (RAM) consumption by the virtual machine.
PrlVmCfg_SetHostMemQuotaMin
Sets the minimal size of the host's memory (RAM) consumption by the virtual machine.
PrlVmCfg_SetHostMemQuotaPriority
Sets the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.
PrlVmCfg_SetHostname
Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled
Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon
Sets the virtual machine icon.
PrlVmCfg_SetIoLimit
Sets limit of I/O usage for the virtual machine in Bytes/s.
PrlVmCfg_SetIoPriority
Sets the specified virtual machine I/O priority.
PrlVmCfg_SetIopsLimit
Sets the specified virtual machine IOPS limit.
PrlVmCfg_SetIsolatedVmEnabled
Disables or enables shared camera isolated VM.
PrlVmCfg_SetLockGuestOnSuspendEnabled
Disables or enables shared camera lock guest on suspend.
PrlVmCfg_SetLockInFullScreenMode
Enables or disables the lock in screen mode feature in a virtual machine configuration.
PrlVmCfg_SetLongerBatteryLifeEnabled
Disables or enables longer battery life.
PrlVmCfg_SetMapSharedFoldersOnLetters
Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMaxBalloonSize
Sets the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.
PrlVmCfg_SetMultiDisplay
Sets the virtual machine multi-display option.
PrlVmCfg_SetName
Sets the specified virtual machine name.
PrlVmCfg_SetNestedVirtualizationEnabled
Disables or enables nested virtualization.
PrlVmCfg_SetNetfilterMode
Allows to set netfilter mode inside the CT.
PrlVmCfg_SetNetworkRateList
Add the specified rates list to the Vm configuration.
PrlVmCfg_SetOfflineManagementEnabled
Enables or disables the offline management feature for a virtual machine.
PrlVmCfg_SetOfflineServices
Allows to manually set offline services that will be available in the virtual machine offline management.
PrlVmCfg_SetOptimizeModifiersMode
Sets optimize modifiers mode.
PrlVmCfg_SetOsResInFullScrMode
Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsTemplate
Specify the Virtual Machine Operation System template name which will be used to create new Parallels Virtuozzo Container.
PrlVmCfg_SetOsVersion
Sets the virtual machine guest OS version.
PrlVmCfg_SetPauseWhenIdle
Sets the virtual machine "Pause Idle VM" option.
PrlVmCfg_SetPMUVirtualizationEnabled
Disables or enables PMU virtualization.
PrlVmCfg_SetProfile
Set one of predefined VM profiles.
PrlVmCfg_SetRamHotplugEnabled
Sets the virtual machine memory (RAM) hotplug mode (enabled or disabled).
PrlVmCfg_SetRamSize
Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRateBound
Sets the ratebound flag.
PrlVmCfg_SetRelocateTaskBar
Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetResource
Sets barrier and limit for various user beancounters.
PrlVmCfg_SetScrResEnabled
Enables or disables the additional screen resolution support in a virtual machine.
PrlVmCfg_SetSearchDomains
Allows to manually set the global search domain list that will be assigned to the Virtuozzo Container.
PrlVmCfg_SetShareAllHostDisks
Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetShareClipboard
Enables or disables the clipboard sharing feature.
PrlVmCfg_SetSharedAppsGuestToHost
Lets to share the guest applications to host.
PrlVmCfg_SetSharedAppsHostToGuest
Lets to share the host applications to guest.
PrlVmCfg_SetSharedBluetoothEnabled
Disables or enables bluetooth camera.
PrlVmCfg_SetSharedCameraEnabled
Disables or enables shared camera.
PrlVmCfg_SetSharedCloudEnabled
Enables or disables shared cloud.
PrlVmCfg_SetSharedProfileEnabled
Enables or disables the Shared Profile feature in a virtual machine.
PrlVmCfg_SetShareUserHomeDir
Enables or disables sharing of the host user home directory in the specified virtual machine.
PrlVmCfg_SetShowTaskBar
Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetShowWindowsAppInDock
Lets to set show windows applications folder in Dock enabling sign.
PrlVmCfg_SetSmartGuardEnabled
Enables the SmartGuard feature in a virtual machine.
PrlVmCfg_SetSmartGuardInterval
Sets the time interval at which snapshots are taken by SmartGuard.
PrlVmCfg_SetSmartGuardMaxSnapshotsCount
Sets the maximum snapshot count, a SmartGuard feature.
PrlVmCfg_SetSmartGuardNotifyBeforeCreation
Enables or disables notification of automatic snapshot creation, a SmartGuard feature.
PrlVmCfg_SetSmartMountDVDsEnabled
Enables or disables the SmartMount CD/DVD drives.
PrlVmCfg_SetSmartMountEnabled
Enables or disables the SmartMount feature.
PrlVmCfg_SetSmartMountNetworkSharesEnabled
Enables or disables the SmartMount network shares.
PrlVmCfg_SetSmartMountRemovableDrivesEnabled
Enables or disables the SmartMount removable drives.
PrlVmCfg_SetSmartMouseEnabled
Disables or enables smart mouse.
PrlVmCfg_SetStartInDetachedWindowEnabled
Disables or enables start in detached window.
PrlVmCfg_SetStartLoginMode
Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds
Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetStickyMouseEnabled
Disables or enables sticky mouse.
PrlVmCfg_SetSupportUsb30Enabled
Sets support status USB 3.0.
PrlVmCfg_SetSwitchOffAeroEnabled
Disables or enables switching off aero.
PrlVmCfg_SetSwitchOffWindowsLogoEnabled
Disables or enables Windows logo.
PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled
Disables or enables switching to full screen on demand.
PrlVmCfg_SetSyncDefaultPrinter
Sets synchronization default printer option.
PrlVmCfg_SetSystemFlags
Sets the virtual machine system flags.
PrlVmCfg_SetTemplateSign
Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetTimeSynchronizationEnabled
Enables or disables the time synchronization feature in a virtual machine.
PrlVmCfg_SetTimeSyncInterval
Allows to set the time interval at which the time in the virtual machine will be synchronized with the time in the host OS.
PrlVmCfg_SetTimeSyncSmartModeEnabled
Enables or disables the smart time-synchronization mode in a virtual machine.
PrlVmCfg_SetToolsAutoUpdateEnabled
Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.
PrlVmCfg_SetUnattendedInstallEdition
Sets edition for unattended installation.
PrlVmCfg_SetUnattendedInstallLocale
Sets locale for unattended installation.
PrlVmCfg_SetUndoDisksMode
Sets the undo-disks mode for the virtual machine.
PrlVmCfg_SetUseDefaultAnswers
Enables the use default answers mechanism in a virtual machine.
PrlVmCfg_SetUseDesktop
Enables or disables the "undo-desktop" feature in the shared profile.
PrlVmCfg_SetUseDocuments
Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseDownloads
Lets to set use downloads in shared profile enabling sign.
PrlVmCfg_SetUseHostPrinters
Sets use host printers option.
PrlVmCfg_SetUseMovies
Lets to set use movies in shared profile enabling sign.
PrlVmCfg_SetUseMusic
Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures
Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled
Enables or disables user-defined shared folders.
PrlVmCfg_SetUuid
Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVerticalSynchronizationEnabled
Disables or enables vertical synchronization video mode for the specified virtual machine.
PrlVmCfg_SetVideoRamSize
Sets the virtual machine video memory size.
PrlVmCfg_SetVirtualLinksEnabled
Enables or disables the Virtual Links feature in a virtual machine.
PrlVmCfg_SetVmType
Specify the Virtual Machine type on create action.
PrlVmCfg_SetVNCHostName
Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode
Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword
Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort
Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode
Sets the virtual machine window mode.
PrlVmCfg_SetWinSystrayInMacMenuEnabled
Disables or enables Windows systray in Mac menu.


Legend

Legend
PHT_VM_CONFIGURATION
Legend
Method


PHT_VM_GUEST_SESSION Functions

PHT_VM_GUEST_SESSION Functions
PHT_VM_GUEST_SESSION Legend
Functions
Name | Description
PrlVmGuest_GetNetworkSettings | Obtains network settings of a guest operating system running in a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.


Legend

Legend
PHT_VM_GUEST_SESSION
Legend
Method


PHT_VM_INFO Functions

PHT_VM_INFO Functions
PHT_VM_INFO Legend
Functions
Name | Description
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetAdditionState | Returns the virtual machine addition state information.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsInvalidEx | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVmWaitingForAnswer | Determines if the specified virtual machine is waiting for answer on self question.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.


Legend

Legend
PHT_VM_INFO
Legend
Method


PHT_VM_TOOLS_INFO Functions

PHT_VM_TOOLS_INFO Functions
PHT_VM_TOOLS_INFO Legend
Functions
Name | Description
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.


Legend

Legend
PHT_VM_TOOLS_INFO
Legend
Method


Primary Display Capture Functions

Primary Display Capture Functions
Primary Display Capture Legend
Functions
Name | Description
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_ConnectToVmEx | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetAvailableDisplaysCount | Returns available displays count of a remote virtual machine desktop.
PrlDevDisplay_GetDisplayEncoding | Gets current encoding of specified Vm.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetConfiguration | Sends a request to a virtual machine to set guest display configuration to specified values.
PrlDevDisplay_SetDisplayEncoding | Sets display encoding for specified Vm.
PrlDevDisplay_SetDpiConfiguration | Sends a request to a virtual machine to set guest DPI display configuration to specified values.
PrlDevDisplay_SetScreenSurface |
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.


Legend

Legend
Primary Display Capture
Legend
Method


_PRL_ADAPTER_INDEX Enumeration

_PRL_ADAPTER_INDEX Enumeration
Other Structs

Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index

Syntax
enum _PRL_ADAPTER_INDEX {
  PAI_INVALID_ADAPTER = -1,
  PAI_GENERATE_INDEX = -2
};
File

PrlEnums.h

Links
Other Structs


_PRL_ALLOWED_VM_COMMAND Enumeration

_PRL_ALLOWED_VM_COMMAND Enumeration
Other Structs

Allowed vm commands enumeration

Syntax
enum _PRL_ALLOWED_VM_COMMAND {
  PAR_VM_START_ACCESS = 0,
  PAR_VM_STOP_ACCESS = 1,
  PAR_VM_PAUSE_ACCESS = 2,
  PAR_VM_RESET_ACCESS = 3,
  PAR_VM_SUSPEND_ACCESS = 4,
  PAR_VM_RESUME_ACCESS = 5,
  PAR_VM_DROPSUSPENDEDSTATE_ACCESS = 6,
  PAR_VM_CLONE_ACCESS = 7,
  PAR_VM_DELETE_ACCESS = 8,
  PAR_VM_GETPROBLEMREPORT_ACCESS = 9,
  PAR_VM_GETCONFIG_ACCESS = 10,
  PAR_VM_GETSTATISTICS_ACCESS = 11,
  PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS = 12,
  PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNREG_ACCESS = 13,
  PAR_VM_COMMIT_ACCESS = 14,
  PAR_VM_EDITING_ACCESS = PAR_VM_COMMIT_ACCESS,
  PAR_VMDEV_CONNECT_ACCESS = 15,
  PAR_VMDEV_DISCONNECT_ACCESS = 16,
  PAR_VMDEV_CREATEIMAGE_ACCESS = 17,
  PAR_VM_SEND_ANSWER_ACCESS = 18,
  PAR_VM_GET_VMINFO_ACCESS = 19,
  PAR_VM_INSTALL_TOOLS_ACCESS = 20,
  PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS = 21,
  PAR_VM_UPDATE_SECURITY_ACCESS = 22,
  PAR_VM_CANCEL_COMPACT_ACCESS = 23,
  PAR_VM_REGISTER_ACCESS = 24,
  PAR_VM_MIGRATE_ACCESS = 25,
  PAR_VM_START_STOP_VNC_SERVER = 26,
  PAR_VM_GET_SUSPENDED_SCREEN_ACCESS = 27,
  PAR_VM_PERFSTAT_ACCESS = 28,
  PAR_VM_LOCK_ACCESS = 29,
  PAR_VM_MIGRATE_CANCEL_ACCESS = PAR_VM_MIGRATE_ACCESS,
  PAR_VM_RUN_COMPRESSOR_ACCESS = 31,
  PAR_VM_CANCEL_COMPRESSOR_ACCESS = 32,
  PAR_VM_CREATE_SNAPSHOT_ACCESS = 33,
  PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS = 34,
  PAR_VM_DELETE_SNAPSHOT_ACCESS = 35,
  PAR_VM_START_EX_ACCESS = 36,
  PAR_VM_UNLOCK_ACCESS = 37,
  PAR_VM_RESTART_GUEST_ACCESS = 38,
  PAR_VM_INSTALL_UTILITY_ACCESS = 39,
  PAR_VM_UPDATE_TOOLS_SECTION = 40,
  PAR_VM_RESTORE_ACCESS = 41,
  PAR_VM_CREATE_BACKUP_ACCESS = 42,
  PAR_VM_RESIZE_DISK_ACCESS = 43,
  PAR_VM_CREATE_ACCESS = 44,
  PAR_SRV_USER_PROFILE_BEGINEDIT_ACCESS = 45,
  PAR_SRV_USER_PROFILE_COMMIT_ACCESS = 46,
  PAR_SRV_SERVER_PROFILE_BEGINEDIT_ACCESS = 47,
  PAR_SRV_SERVER_PROFILE_COMMIT_ACCESS = 48,
  PAR_VM_GUI_VIEW_MODE_CHANGE_ACCESS = 49,
  PAR_VM_BEGINEDIT_ACCESS = 50,
  PAR_VM_RESTORE_BACKUP_ACCESS = 51,
  PAR_VM_COMPACT_ACCESS = 52,
  PAR_VM_CHANGE_SID_ACCESS = 53,
  PAR_VM_RESET_UPTIME_ACCESS = 54,
  PAR_VM_INTERNAL_CMD_ACCESS = 55,
  PAR_VM_GET_VIRT_DEV_INFO = 56,
  PAR_VM_GET_TOOLS_INFO = 57,
  PAR_VM_CONVERT_DISKS_ACCESS = 58,
  PAR_VM_ENCRYPT_OPERATION_ACCESS = 59,
  PAR_VM_CHANGE_PASSWORD_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_ENCRYPT_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_DECRYPT_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_SET_PROTECTION_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_REMOVE_PROTECTION_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_AUTHORISE_ACCESS = 60,
  PAR_VMDEV_COPY_IMAGE_ACCESS = 61,
  PAR_VM_MOUNT_ACCESS = 62,
  PAR_VM_MOVE_ACCESS = 63,
  PAR_VM_CHANGE_GUEST_OS_PASSWORD_ACCESS = 64,
  PAR_SRV_SENDPROBLEMREPORT_ACCESS = 65,
  PAR_MAX
};
File

PrlEnums.h

Members

PAR_MAX
should be the last

Links
Other Structs


_PRL_API_COMMAND_FLAGS Enumeration

_PRL_API_COMMAND_FLAGS Enumeration
Other Structs

Common operations flags set.

Syntax
enum _PRL_API_COMMAND_FLAGS {
  PACF_NORMAL_SECURITY = PSL_NORMAL_SECURITY,
  PACF_HIGH_SECURITY = PSL_HIGH_SECURITY,
  PACF_NON_INTERACTIVE_MODE = 1<<2,
  PACF_CANCEL_TASK_ON_END_SESSION = 1<<3,
  PACF_MAX = 10,
  PACF_LAST = 1<<PACF_MAX
};
File

PrlCommandsFlags.h

Members

PACF_NORMAL_SECURITY
Client connection security mode
PACF_NON_INTERACTIVE_MODE
Session interactive mode
PACF_CANCEL_TASK_ON_END_SESSION
Cancel long-term operation by session disconnect
PACF_MAX
Interval from here to PACF_LAST reserved for further purposes.

Remarks

Please do not override values

Links
Other Structs


_PRL_API_INIT_FLAGS Enumeration

_PRL_API_INIT_FLAGS Enumeration
Other Structs

Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode

Syntax
enum _PRL_API_INIT_FLAGS {
  PAIF_USE_GRAPHIC_MODE = 1<<(PACF_MAX+1),
  PAIF_INIT_AS_APPSTORE_CLIENT = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_API_METHOD Structure

_PRL_API_METHOD Structure
Other Structs

Parallels API method

Syntax
struct _PRL_API_METHOD {
  PRL_CONST_STR MethodName;
  PRL_UINT32 MethodAPIVersion;
  PRL_VOID_PTR MethodPtr;
  PRL_BOOL MethodIsDeprecated;
  PRL_BOOL MethodIsAsync;
  PRL_BOOL MethodIsSrv;
  PRL_UINT32 ReservedA;
  PRL_UINT32 ReservedB;
  PRL_UINT32 ReservedC;
  PRL_UINT32 ReservedD;
};
File

PrlTypes.h

Members

ReservedA
Reserved for future use

Links
Other Structs


_PRL_APP_IN_DOCK_MODE Enumeration

_PRL_APP_IN_DOCK_MODE Enumeration
Other Structs

VM application in Dock mode

Syntax
enum _PRL_APP_IN_DOCK_MODE {
  PDM_APP_IN_DOCK_NEVER = 0,
  PDM_APP_IN_DOCK_COHERENCE_ONLY = 1,
  PDM_APP_IN_DOCK_ALWAYS = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_APPLIANCE_DOWNLOAD_STATUS Enumeration

_PRL_APPLIANCE_DOWNLOAD_STATUS Enumeration
Other Structs

Appliance download status

Syntax
enum _PRL_APPLIANCE_DOWNLOAD_STATUS {
  PADS_NOT_STARTED = 1,
  PADS_STOPPED = 2,
  PADS_DOWNLOADING = 3,
  PADS_DOWNLOADED = 4,
  PADS_UNPACKED = 5,
  PADS_MOVED = 6,
  PADS_REGISTERED = 7,
  PADS_CANCELED = 8
};
File

PrlEnums.h

Links
Other Structs


_PRL_APPLICATION_MODE Enumeration

_PRL_APPLICATION_MODE Enumeration
Other Structs

Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode

Syntax
enum _PRL_APPLICATION_MODE {
  PAM_UNKNOWN = 0xffff,
  PAM_SERVER = 0,
  PAM_DESKTOP_MAC = 1,
  PAM_WORKSTATION_EXTREME = 2,
  PAM_PLAYER = 3,
  PAM_DESKTOP_STM = PAM_DESKTOP_MAC,
  PAM_DESKTOP_WL = 5,
  PAM_MOBILE = 6,
  PAM_LAST = PAM_MOBILE,
  PAM_DESKTOP_STM_OBSOLETE = 4,
  PAM_DESKTOP = PAM_DESKTOP_MAC,
  PAM_WORKSTATION = PAM_WORKSTATION_EXTREME,
  PAM_STM = PAM_DESKTOP_STM_OBSOLETE
};
File

PrlEnums.h

Members

PAM_LAST
PAM_LAST should be always last entry in enum !
PAM_DESKTOP_STM_OBSOLETE
OBSOLETE CONSTANTS (for compatibility only)

Links
Other Structs


_PRL_BIOS_TYPE Enumeration

_PRL_BIOS_TYPE Enumeration
Other Structs

BIOS type

Syntax
enum _PRL_BIOS_TYPE {
  PBT_LEGACY = 0,
  PBT_EFI = 1
};
File

PrlEnums.h

Links
Other Structs


PRL_BOOL Types Types

PRL_BOOL Types Types
PRL_BOOL Types
Types
Name | Description
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |


PRL_CHAR Types Types

PRL_CHAR Types Types
PRL_CHAR Types
Types
Name | Description
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |


_PRL_CHS Structure

_PRL_CHS Structure
Other Structs

CHS format of disk

Syntax
struct _PRL_CHS {
  PRL_UINT32 Sectors;
  PRL_UINT32 Heads;
  PRL_UINT32 Cylinders;
};
File

PrlDisk.h

Links
Other Structs


_PRL_CLONE_VM_FLAGS Enumeration

_PRL_CLONE_VM_FLAGS Enumeration
Other Structs

PrlVm_CloneEx command flags set

PCVF_DETACH_EXTERNAL_VIRTUAL_HDD

  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
Syntax
enum _PRL_CLONE_VM_FLAGS {
  PCVF_CLONE_TO_TEMPLATE = 1<<(PACF_MAX+1),
  PCVF_CHANGE_SID = 1<<(PACF_MAX+2),
  PCVF_LINKED_CLONE = 1<<(PACF_MAX+3),
  PCVF_IMPORT_BOOT_CAMP = 1<<(PACF_MAX+4),
  PCVF_DETACH_EXTERNAL_VIRTUAL_HDD = 1<<(PACF_MAX+5),
  PCVF_REGENERATE_SRC_VM_UUID = 1<<(PACF_MAX+6)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_CLUSTERED_DEVICE_SUBTYPE Enumeration

_PRL_CLUSTERED_DEVICE_SUBTYPE Enumeration
Other Structs

Clustered device subtype

Syntax
enum _PRL_CLUSTERED_DEVICE_SUBTYPE {
  PCD_BUSLOGIC = 0,
  PCD_LSI_SPI = 1,
  PCD_LSI_SAS = 2,
  PCD_UNKNOWN_DEVICE = 255
};
File

PrlEnums.h

Links
Other Structs


_PRL_COMPACT_MODE Enumeration

_PRL_COMPACT_MODE Enumeration
Other Structs

Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files

Syntax
enum _PRL_COMPACT_MODE {
  PCM_COMPACT_WITH_HARD_DISKS_INFO = 1<<(PACF_MAX+1),
  PCM_HARD_DISKS_INFO = 1<<(PACF_MAX+2),
  PCM_FULL_CLEAN_UP_VM = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


PRL_CONST Types Types

PRL_CONST Types Types
PRL_CONST Types
Types
Name | Description
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_CARET_INFO_PTR |
PRL_CONST_CPU_FEATURES_MASK_PTR |
PRL_CONST_CPULIMIT_DATA_PTR |
PRL_CONST_CVSRC_OPEN_MODE |
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_DOUBLE_PTR |
PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_IOLIMIT_DATA_PTR |
PRL_CONST_MAKEUP_HINTING_RGN_PTR |
PRL_CONST_SELECTION_HINTING_RGN_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UIEMU_AUTOKEYBOARD_PTR |
PRL_CONST_UIEMU_CURSOR_DESC_PTR |
PRL_CONST_UIEMU_CURSOR_FORMAT_PTR |
PRL_CONST_UIEMU_CURSOR_POS_PTR |
PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR |
PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR |
PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR |
PRL_CONST_UIEMU_GESTURE_EVENT_PTR |
PRL_CONST_UIEMU_INPUT_INFO_PTR |
PRL_CONST_UIEMU_VKEY_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR |
PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR |
PRL_CONST_VOID_PTR |


_PRL_CONVERT_VIRTUAL_DISK Enumeration

_PRL_CONVERT_VIRTUAL_DISK Enumeration
Other Structs

Convert virtual disk

  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
Syntax
enum _PRL_CONVERT_VIRTUAL_DISK {
  PCVD_CANCEL = 1<<(PACF_MAX+1),
  PCVD_TO_PLAIN_DISK = 1<<(PACF_MAX+2),
  PCVD_TO_EXPANDING_DISK = 1<<(PACF_MAX+3),
  PCVD_TO_SPLIT_DISK = 1<<(PACF_MAX+4),
  PCVD_TO_NON_SPLIT_DISK = 1<<(PACF_MAX+5),
  PCVD_MERGE_ALL_SNAPSHOTS = 1<<(PACF_MAX+6)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_COPY_CT_TEMPLATE_FLAGS Enumeration

_PRL_COPY_CT_TEMPLATE_FLAGS Enumeration
Other Structs

copy of CT templates functionality flags set

Syntax
enum _PRL_COPY_CT_TEMPLATE_FLAGS {
  PCTMP_LOW_SECURITY = PSL_LOW_SECURITY,
  PCTMP_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PCTMP_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PCTMPL_FORCE = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Type Parameters

PCTMPL_FORCE
force template copy

Links
Other Structs


_PRL_CORNER_ACTIONS Enumeration

_PRL_CORNER_ACTIONS Enumeration
Other Structs

Window corner actions

Syntax
enum _PRL_CORNER_ACTIONS {
  PCA_NO_ACTION = 0,
  PCA_WINDOWED = 1,
  PCA_COHERENCE = 2,
  PCA_SEAMLESS = 3,
  PCA_MODALITY = 4,
  PCA_HIDE_APPLICATION = 5,
  PCA_UNGRAB_INPUT = 6,
  PCA_CRYSTAL = 7
};
File

PrlEnums.h

Links
Other Structs


_PRL_CPU_FEATURES Structure

_PRL_CPU_FEATURES Structure
Other Structs
Syntax
struct _PRL_CPU_FEATURES {
  PRL_UINT32 nFEATURES;
  PRL_UINT32 nEXT_FEATURES;
  PRL_UINT32 nEXT_00000007_EBX;
  PRL_UINT32 nEXT_80000001_ECX;
  PRL_UINT32 nEXT_80000001_EDX;
  PRL_UINT32 nEXT_80000007_EDX;
  PRL_UINT32 nEXT_80000008_EAX;
  PRL_UINT32 nEXT_0000000D_EAX;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_CPU_FEATURES_EX Enumeration

_PRL_CPU_FEATURES_EX Enumeration
Other Structs
Syntax
enum _PRL_CPU_FEATURES_EX {
  PCFE_FEATURES = 0,
  PCFE_EXT_FEATURES = 1,
  PCFE_EXT_00000007_EBX = 2,
  PCFE_EXT_80000001_ECX = 3,
  PCFE_EXT_80000001_EDX = 4,
  PCFE_EXT_80000007_EDX = 5,
  PCFE_EXT_80000008_EAX = 6,
  PCFE_EXT_0000000D_EAX = 7,
  PCFE_MAX
};
File

PrlEnums.h

Members

PCFE_MAX
have to be the last.

Links
Other Structs


_PRL_CPU_FEATURES_MASK Structure

_PRL_CPU_FEATURES_MASK Structure
Other Structs
Syntax
struct _PRL_CPU_FEATURES_MASK {
  PRL_UINT32 nFEATURES_MASK;
  PRL_UINT32 nEXT_FEATURES_MASK;
  PRL_UINT32 nEXT_00000007_EBX_MASK;
  PRL_UINT32 nEXT_80000001_ECX_MASK;
  PRL_UINT32 nEXT_80000001_EDX_MASK;
  PRL_UINT32 nEXT_80000007_EDX_MASK;
  PRL_UINT32 nEXT_80000008_EAX;
  PRL_UINT32 nEXT_0000000D_EAX_MASK;
  PRL_UINT32 bIsValid;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_CPU_HVT Enumeration

_PRL_CPU_HVT Enumeration
Other Structs

CPU mode

Syntax
enum _PRL_CPU_HVT {
  PCM_CPU_NONE_HV = 0,
  PCM_CPU_INTEL_VT_X,
  PCM_CPU_AMD_V
};
File

PrlEnums.h

Links
Other Structs


_PRL_CPU_MODE Enumeration

_PRL_CPU_MODE Enumeration
Other Structs

CPU mode

Syntax
enum _PRL_CPU_MODE {
  PCM_CPU_MODE_32 = 0,
  PCM_CPU_MODE_64 = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_CPULIMIT_DATA Structure

_PRL_CPULIMIT_DATA Structure
Other Structs
Syntax
struct _PRL_CPULIMIT_DATA {
  PRL_UINT32 value;
  PRL_CPULIMIT_TYPE type;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_CPULIMIT_TYPE Enumeration

_PRL_CPULIMIT_TYPE Enumeration
Other Structs
Syntax
enum _PRL_CPULIMIT_TYPE {
  PRL_CPULIMIT_PERCENTS100 = 1,
  PRL_CPULIMIT_MHZ = 2,
  PRL_CPULIMIT_PERCENTS = 3,
  PRL_CPULIMIT_PERCENTS_TO_MHZ = 4
};
File

PrlEnums.h

Members

PRL_CPULIMIT_PERCENTS100
cpulimit 0-100
PRL_CPULIMIT_PERCENTS
cpulimit 0-100 * nCpu
PRL_CPULIMIT_PERCENTS_TO_MHZ
The limit in % convert to Mhz

Links
Other Structs


_PRL_CPUUNITS Enumeration

_PRL_CPUUNITS Enumeration
Other Structs
Syntax
enum _PRL_CPUUNITS {
  PRL_CPUUNITS_MIN = 10,
  PRL_CPUUNITS_DEFAULT = 1000,
  PRL_CPUUNITS_MAX = 500000
};
File

PrlEnums.h

Links
Other Structs


_PRL_CREATE_DISK_IMAGE_FLAGS Enumeration

_PRL_CREATE_DISK_IMAGE_FLAGS Enumeration
Other Structs

Create image flags

Syntax
enum _PRL_CREATE_DISK_IMAGE_FLAGS {
  PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Members

PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION
create from lion recovery

Links
Other Structs


_PRL_CREATE_SNAPSHOT_FLAGS Enumeration

_PRL_CREATE_SNAPSHOT_FLAGS Enumeration
Other Structs

VM snapshot creation flags set

Syntax
enum _PRL_CREATE_SNAPSHOT_FLAGS {
  PCSF_DISK_ONLY = 1<<(PACF_MAX+1),
  PCSF_BACKUP = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Members

PCSF_DISK_ONLY
internal flag
PCSF_BACKUP
internal flag

Type Parameters

PCSF_DISK_ONLY
to snapshot hdd's only for running Vm
PCSF_BACKUP
create snapshot for backup

Links
Other Structs


_PRL_CT_CAPMASK Enumeration

_PRL_CT_CAPMASK Enumeration
Other Structs

Capabilities list

Syntax
enum _PRL_CT_CAPMASK {
  PCC_CHOWN = (1 << 0),
  PCC_FS_MASK = PCC_CHOWN,
  PCC_DAC_OVERRIDE = (1 << 1),
  PCC_DAC_READ_SEARCH = (1 << 2),
  PCC_FOWNER = (1 << 3),
  PCC_FSETID = (1 << 4),
  PCC_KILL = (1 << 5),
  PCC_SETGID = (1 << 6),
  PCC_SETUID = (1 << 7),
  PCC_SETPCAP = (1 << 8),
  PCC_LINUX_IMMUTABLE = (1 << 9),
  PCC_NET_BIND_SERVICE = (1 << 10),
  PCC_NET_BROADCAST = (1 << 11),
  PCC_NET_ADMIN = (1 << 12),
  PCC_NET_RAW = (1 << 13),
  PCC_IPC_LOCK = (1 << 14),
  PCC_IPC_OWNER = (1 << 15),
  PCC_SYS_MODULE = (1 << 16),
  PCC_SYS_RAWIO = (1 << 17),
  PCC_SYS_CHROOT = (1 << 18),
  PCC_SYS_PTRACE = (1 << 19),
  PCC_SYS_PACCT = (1 << 20),
  PCC_SYS_ADMIN = (1 << 21),
  PCC_SYS_BOOT = (1 << 22),
  PCC_SYS_NICE = (1 << 23),
  PCC_SYS_RESOURCE = (1 << 24),
  PCC_SYS_TIME = (1 << 25),
  PCC_SYS_TTY_CONFIG = (1 << 26),
  PCC_MKNOD = (1 << 27),
  PCC_LEASE = (1 << 28),
  PCC_AUDIT_WRITE = (1 << 29),
  PCC_VE_ADMIN = (1 << 30),
  PCC_SETFCAP = (1 << 31)
};
File

PrlEnums.h

Members

PCC_FS_MASK
FIXME: real value of PCC_FS_MASK?

Links
Other Structs


_PRL_CT_FEATURES Enumeration

_PRL_CT_FEATURES Enumeration
Other Structs

CT Features

Syntax
enum _PRL_CT_FEATURES {
  PCF_FEATURE_SYSFS = (1 << 0),
  PCF_FEATURE_NFS = (1 << 1),
  PCF_FEATURE_DEF_PERM = (1 << 2),
  PCF_FEATURE_SIT = (1 << 3),
  PCF_FEATURE_IPIP = (1 << 4),
  PCF_FEATURE_PPP = (1 << 5),
  PCF_FEATURE_IPGRE = (1 << 6),
  PCF_FEATURE_BRIDGE = (1 << 7),
  PCF_FEATURE_NFSD = (1 << 8)
};
File

PrlEnums.h

Links
Other Structs


_PRL_CT_RESOURCE Enumeration

_PRL_CT_RESOURCE Enumeration
Other Structs
Syntax
enum _PRL_CT_RESOURCE {
  PCR_KMEMSIZE = 1,
  PCR_LOCKEDPAGES = 2,
  PCR_PRIVVMPAGES = 3,
  PCR_SHMPAGES = 4,
  PCR_NUMPROC = 5,
  PCR_PHYSPAGES = 6,
  PCR_VMGUARPAGES = 7,
  PCR_OOMGUARPAGES = 8,
  PCR_NUMTCPSOCK = 9,
  PCR_NUMFLOCK = 10,
  PCR_NUMPTY = 11,
  PCR_NUMSIGINFO = 12,
  PCR_TCPSNDBUF = 13,
  PCR_TCPRCVBUF = 14,
  PCR_OTHERSOCKBUF = 15,
  PCR_DGRAMRCVBUF = 16,
  PCR_NUMOTHERSOCK = 17,
  PCR_DCACHESIZE = 18,
  PCR_NUMFILE = 19,
  PCR_NUMIPTENT = 20,
  PCR_SWAPPAGES = 21,
  PCR_QUOTAUGIDLIMIT = 22,
  PCR_LAST = PCR_QUOTAUGIDLIMIT
};
File

PrlEnums.h

Links
Other Structs


_PRL_CT_TEMPLATE_TYPE Enumeration

_PRL_CT_TEMPLATE_TYPE Enumeration
Other Structs

Container templates types

Syntax
enum _PRL_CT_TEMPLATE_TYPE {
  PCT_TYPE_EZ_OS = 0,
  PCT_TYPE_EZ_APP = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_CVSRC_OPEN_MODE Structure

_PRL_CVSRC_OPEN_MODE Structure
Other Structs
Syntax
struct _PRL_CVSRC_OPEN_MODE {
  PRL_UINT32 sessionId;
  PRL_UINT32 frameFormat;
  PRL_UINT32 frameWidth;
  PRL_UINT32 frameHeight;
  PRL_UINT32 frameBytesPerRow;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_DATA_STATISTIC_SEGMENTS Enumeration

_PRL_DATA_STATISTIC_SEGMENTS Enumeration
Other Structs

Data statistic segments

Syntax
enum _PRL_DATA_STATISTIC_SEGMENTS {
  PDSS_UNKNOWN = 0,
  PDSS_VM_MISCELLANEOUS_SPACE = 1,
  PDSS_VM_RECLAIM_SPACE = 2,
  PDSS_VM_SNAPSHOTS_SPACE = 3,
  PDSS_VM_DISK_DATA_SPACE = 4,
  PDSS_VM_FULL_SPACE = 5
};
File

PrlEnums.h

Links
Other Structs


_PRL_DELETE_SNAPSHOT_FLAGS Enumeration

_PRL_DELETE_SNAPSHOT_FLAGS Enumeration
Other Structs
  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
Syntax
enum _PRL_DELETE_SNAPSHOT_FLAGS {
  PDSF_SKIP_SPACE_CHECK = 1<<(PACF_MAX+1),
  PDSF_BACKUP = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Members

PDSF_SKIP_SPACE_CHECK
skip space check
PDSF_BACKUP
internal flag

Links
Other Structs


_PRL_DEVICE_ACTION Enumeration

_PRL_DEVICE_ACTION Enumeration
Other Structs

Device in use Action

Syntax
enum _PRL_DEVICE_ACTION {
  PDA_DEVICE_IDLE = 0,
  PDA_DEVICE_READ = 1,
  PDA_DEVICE_WRITE = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_DEVICE_TYPE Enumeration

_PRL_DEVICE_TYPE Enumeration
Other Structs

Device type

Syntax
enum _PRL_DEVICE_TYPE {
  PDE_GENERIC_DEVICE = 0,
  PDE_CLUSTERED_DEVICE = 1,
  PDE_STORAGE_DEVICE = 2,
  PDE_FLOPPY_DISK = 3,
  PDE_MASSSTORAGE_DEVICE = 4,
  PDE_OPTICAL_DISK = 5,
  PDE_HARD_DISK = 6,
  PDE_GENERIC_NETWORK_ADAPTER = 8,
  PDE_GENERIC_PORT = 9,
  PDE_SERIAL_PORT = 10,
  PDE_PARALLEL_PORT = 11,
  PDE_SOUND_DEVICE = 12,
  PDE_MIXER_DEVICE = 13,
  PDE_USB_DEVICE = 15,
  PDE_PRINTER = 16,
  PDE_GENERIC_PCI_DEVICE = 17,
  PDE_GENERIC_SCSI_DEVICE = 18,
  PDE_VIRTUAL_SNAPSHOT_DEVICE = 19,
  PDE_PCI_VIDEO_ADAPTER = 20,
  PDE_VIRTUAL_SHARED_FOLDERS_DEVICE = 21,
  PDE_MAX
};
File

PrlEnums.h

Links
Other Structs


PRL_DEVICE Types Types

PRL_DEVICE Types Types
PRL_DEVICE Types
Types
Name | Description
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |


PRL_DISK Macros Macros

PRL_DISK Macros Macros
PRL_DISK Macros
Macros
Name
Description
PRL_DISK_ALIGN_REQUESTS
Incoming requests to read/write async must be gathered and aligned
PRL_DISK_ALLOW_DATA_MODIFY
Allow inplace data modification to reduce memory copying and allocation
PRL_DISK_CACHE_DEFAULT
Disk cache default.
PRL_DISK_CACHE_DISABLED
Uncached access to disk image.
PRL_DISK_CACHE_ENABLED
Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ
Cached write/uncached read.
PRL_DISK_CACHE_UNCACHED_SEQ_READ
Like PRL_DISK_CACHE_UNCACHED_READ, but cache is enabled for
  • small and random/reordered requests.
PRL_DISK_DEFAULT_FLAG
Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN
Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT
Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK
Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING
DEPRECATED! Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED
DEPRECATED! Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL
DEPRECATED! Normal access mode (default os)
PRL_DISK_FOPS_PCS
DEPRECATED! Access mode to files on PCS storage
PRL_DISK_IGNORE_PROTECTION
Ignore storages read only flag (useful at disk creation)
PRL_DISK_INVALID
Last (invalid).
PRL_DISK_NO_ERROR_CHECKING
Force open of disk for reading without error checking
PRL_DISK_NO_SPACE_CHECKS
Do not check host free space
PRL_DISK_NOT_LIMIT_HANDLES
Do not use handle pool for disk image handles
PRL_DISK_NOTHING
Nothing.
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MIN
States progress definition.
PRL_DISK_READ
Read
PRL_DISK_READ_LOCK
ReadLock
PRL_DISK_USE_RAW_DISK
Use raw disk for BootCamp partition (/dev/rdisk instead of /dev/disk)
PRL_DISK_WRITE
Write
PRL_DISK_XML_CHANGE
This parameter is used when user need to change XML data but not access to the drive itself.


PRL_DISK Types Types

PRL_DISK Types Types
PRL_DISK Types
Types
Name | Description
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |


_PRL_DISPLAY_BUFFER_FORMAT Enumeration

_PRL_DISPLAY_BUFFER_FORMAT Enumeration
Other Structs

Format of display buffer

Syntax
enum _PRL_DISPLAY_BUFFER_FORMAT {
  PDBF_NO_CONVERSION = 0,
  PDBF_INDEX8 = 1,
  PDBF_RGB15 = 2,
  PDBF_RGB16 = 3,
  PDBF_RGB24 = 4,
  PDBF_BGR32 = 5,
  PDBF_RGB32 = 6,
  PDBF_YUV422x8 = 10,
  PDBF_YUV422x6 = 11,
  PDBF_YUV422x4 = 12,
  PDBF_YUV420 = 16
};
File

PrlEnums.h

Links
Other Structs


_PRL_DISPLAY_CODEC_COMPRESSION Enumeration

_PRL_DISPLAY_CODEC_COMPRESSION Enumeration
Other Structs

Obsolete enum.

Syntax
enum _PRL_DISPLAY_CODEC_COMPRESSION {
  PDCC_HIGH_COMPRESSION = 1<<15,
  PDCC_MEDIUM_COMPRESSION = 1<<16,
  PDCC_LOW_COMPRESSION = 1<<17,
  PDCC_NO_COMPRESSION = 1<<18
};
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec compression

Links
Other Structs


_PRL_DISPLAY_CODEC_QUALITY Enumeration

_PRL_DISPLAY_CODEC_QUALITY Enumeration
Other Structs

Obsolete enum.

Syntax
enum _PRL_DISPLAY_CODEC_QUALITY {
  PDCQ_HIGH_QUALITY = 1<<0,
  PDCQ_MEDIUM_QUALITY = 1<<1,
  PDCQ_LOW_QUALITY = 1<<2
};
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec quality.

Links
Other Structs


_PRL_DISPLAY_CODEC_TYPE Enumeration

_PRL_DISPLAY_CODEC_TYPE Enumeration
Other Structs

Obsolete enum.

Syntax
enum _PRL_DISPLAY_CODEC_TYPE {
  PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_HIGH_QUALITY_WITH_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITH_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_LOW_QUALITY_WITHOUT_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_LOW_QUALITY_WITH_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_MEDIUM_COMPRESSION
};
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec types

Links
Other Structs


_PRL_DISPLAY_CONFIG_MODE Enumeration

_PRL_DISPLAY_CONFIG_MODE Enumeration
Other Structs

Display(s) configuration mode

Syntax
enum _PRL_DISPLAY_CONFIG_MODE {
  PDCM_CLIENT_DISPLAY_INFO = (1 << 0),
  PDCM_HAS_HIDPI_DISPLAY = (1 << 1),
  PDCM_DO_NOT_RESTORE = (1 << 2),
  PDCM_RESTORE_DEFAULT = (1 << 3),
  PDCM_DISABLE_HIDPI_ADJUSTMENT = (1 << 4),
  PDCM_RETINA_MODE = (1 << 5),
  PDCM_ENABLE_HEADS = (1 << 6)
};
File

PrlEnums.h

Links
Other Structs


_PRL_DISTRO_MEDIA_TYPE Enumeration

_PRL_DISTRO_MEDIA_TYPE Enumeration
Other Structs
Syntax
enum _PRL_DISTRO_MEDIA_TYPE {
  DMT_DISTRO = 0,
  DMT_LIVE_CD,
  DMT_MBR
};
File

PrlEnums.h

Members

DMT_DISTRO
Ordinary distro
DMT_LIVE_CD
LiveCD
DMT_MBR
Media has Master Boot Record

Links
Other Structs


_PRL_DOCK_ICON_TYPE Enumeration

_PRL_DOCK_ICON_TYPE Enumeration
Other Structs

VM application icon type in Dock

Syntax
enum _PRL_DOCK_ICON_TYPE {
  PIT_DOCK_ICON_SYSTEM = 0,
  PIT_DOCK_ICON_LIVE_SCREEN_SHOT = 1,
  PIT_DOCK_ICON_START_MENU = 2
};
File

PrlEnums.h

Links
Other Structs


PRL_DOUBLE Types Types

PRL_DOUBLE Types Types
PRL_DOUBLE Types
Types
Name | Description
PRL_DOUBLE | Double type
PRL_DOUBLE_PTR |
PRL_DOUBLE_PTR_PTR |


_PRL_ENCRYPTION_FLAGS Enumeration

_PRL_ENCRYPTION_FLAGS Enumeration
Other Structs

Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations

Syntax
enum _PRL_ENCRYPTION_FLAGS {
  PEF_CHECK_PRECONDITIONS_ONLY = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Links
Other Structs


PRL_ERR Macros Macros

PRL_ERR Macros Macros
PRL_ERR Macros
Macros
Name
Description
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TO_VM_HDD_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT
PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_ACTIVATE_TRIAL_LICENSE
PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED
PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_ACTIVATION_SERVER_ERROR
PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED
PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_ACTIVATION_UPDATE_FAILED
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT
  • license activation errors
* +++ ALIGNED VALUE TO 11700
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE
PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5
PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER
PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM
PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS
PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED
PRL_ERR_APPLIANCE_EXIT_WITH_ERROR
PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS
PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED
PRL_ERR_APPLIANCE_INVALID_CONFIG
Install appliance task errors +++ ALIGNED VALUE TO 41500
PRL_ERR_APPLIANCE_MISMATCH_MD5
PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE
PRL_ERR_APPLIANCE_NO_VM_BUNDLE
PRL_ERR_APPLIANCE_USER_NOT_FOUND
PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED
PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED
PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR
Attach backup as a block device errors +++ ALIGNED VALUE TO 54000
PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL
PRL_ERR_ATTACH_BACKUP_PROTO_ERROR
PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED
PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED
PRL_ERR_BACKUP_ACRONIS_ERR
PRL_ERR_BACKUP_BACKUP_CMD_FAILED
PRL_ERR_BACKUP_BACKUP_NOT_FOUND
PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND
PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS
PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED
PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST
PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_INTERNAL_ERROR
PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR
VM Backup errors +++ ALIGNED VALUE TO 37000
PRL_ERR_BACKUP_LOCKED_FOR_READING
PRL_ERR_BACKUP_LOCKED_FOR_WRITING
PRL_ERR_BACKUP_REGISTER_VM_FAILED
PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED
PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD
PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_RESTORE_CMD_FAILED
PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR
PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR
PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED
PRL_ERR_BACKUP_RESTORE_VM_RUNNING
PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM
PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED
PRL_ERR_BACKUP_TIMEOUT_EXCEEDED
PRL_ERR_BACKUP_TOOL_CANNOT_START
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_BUSE_ENTRY_ALREADY_EXIST
PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED
PRL_ERR_BUSE_ENTRY_INVALID
PRL_ERR_BUSE_ENTRY_IO_ERROR
PRL_ERR_BUSE_INTERNAL_ERROR
PRL_ERR_BUSE_NOT_MOUNTED
BUSE filesystem errors +++ ALIGNED VALUE TO 52000
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE
PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_HOST_ID
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY
PRL_ERR_CANT_CONVERT_CONFIG
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_DISK_IMAGE
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE
PRL_ERR_CANT_RECONFIG_GUEST_OS
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_RESIZE_HDD
PRL_ERR_CANT_RESOLVE_HOSTNAME
PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT
PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER
PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UNPACK_ARCHIVE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CHANGESID_FAILED
Vm changeSID errors +++ ALIGNED VALUE TO 41200
PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_CHANGESID_NOT_AVAILABLE
PRL_ERR_CHANGESID_NOT_SUPPORTED
PRL_ERR_CHANGESID_VM_START_FAILED
PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM
PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL
Copy device image errors +++ ALIGNED VALUE TO 46700
PRL_ERR_CI_PERMISSIONS_DENIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_CLUSTER_RESOURCE_ERROR
Cluster resource manipulation errors +++ ALIGNED VALUE TO 46900
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_COMPACT_ALREADY_SWITCHED_ON
PRL_ERR_COMPACT_WRONG_VM_STATE
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN
PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED
PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED
PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN
confirmation errors +++ ALIGNED VALUE TO 41100
PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED
PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID
PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED
PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED
PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID
PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED
PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL
PRL_ERR_CONNECT_TO_MOUNTER
PRL_ERR_CONV_HD_CONFLICT
PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED
PRL_ERR_CONV_HD_EXIT_WITH_ERROR
PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION
PRL_ERR_CONV_HD_WRONG_VM_STATE
Convert disks task errors +++ ALIGNED VALUE TO 41600
PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED
Vm convert errors +++ ALIGNED VALUE TO 41300
PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE
PRL_ERR_CONVERT_EFI_CONFIG_INVALID
PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED
PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND
PRL_ERR_CONVERT_NO_GUEST_OS_FOUND
PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR
PRL_ERR_COPY_VM_INFO_FILE
PRL_ERR_CORE_STATE_CANCELLED
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON
  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000
PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_CORE_STATE_NO_FILE
PRL_ERR_CORE_STATE_VM_WOULD_RESTART
PRL_ERR_CORE_STATE_VM_WOULD_STOP
PRL_ERR_COULD_NOT_START_FIREWALL_TOOL
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_BOOTABLE_ISO
Unattended ISO errors +++ ALIGNED VALUE TO 40000
PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_CT_IS_RUNNING
PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST
PRL_ERR_CT_MIGRATE_INTERNAL_ERROR
PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS
PRL_ERR_CT_NOT_FOUND
PRL_ERR_CVSRC_IO_ERROR
Captured Video Source errors +++ ALIGNED VALUE TO 46800
PRL_ERR_CVSRC_NO_CHANNEL
PRL_ERR_CVSRC_NO_OPEN_REQUEST
PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_DEACTIVATE_TRIAL_LICENSE
PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND
PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_DEACTIVATION_SERVER_ERROR
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_DELETE_UNFINISHED_STATE_FAILED
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED
  • Common Devices Errors

+++ ALIGNED VALUE TO 9000
PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED
  • Other

+++ ALIGNED VALUE TO 10000
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED
  • Parallel Port

+++ ALIGNED VALUE TO 7000
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_PRINTER_OVERFLOW
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED
  • Serial Port

+++ ALIGNED VALUE TO 6000
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_BUSY
PRL_ERR_DEV_USB_CHANGEPID
PRL_ERR_DEV_USB_CONNECT_DENIED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_NOT_CONFIGURED
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED
  • USB

+++ ALIGNED VALUE TO 8000
PRL_ERR_DEV_USB_REUSE
PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND
  • User parameters errors
* +++ ALIGNED VALUE TO 23000
PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR
  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000
PRL_ERR_DISK_GET_MOUNTPATH_FAILED
  • Bootcamp errors
* +++ ALIGNED VALUE TO 24000
PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GET_SIZE_FAILED
PRL_ERR_DISK_GPT_MBR_NOT_EQUAL
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_MOUNTED_OVERLAP
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_RESIZE_FAILED
PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW
PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED
PRL_ERR_DISK_RESIZER_NOT_FOUND
VM image resizer errors +++ ALIGNED VALUE TO 41000
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SET_FILE_SIZE_FAILED
PRL_ERR_DISK_SHARED_BLOCK
  • Compressing errors
* +++ ALIGNED VALUE TO 22000
PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TOOL_NOT_FOUND
PRL_ERR_DISK_TOOL_PROCESS_ERROR
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNCOMMITED_OPERATION
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_DIFFERS_FROM_REAL
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_MISSING
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_PARTITION_NOT_FOUND
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE
PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED
PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP_VM_IS_NOT_STOPPED
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED
PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_HDD_CANT_OPEN
PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED
PRL_ERR_ENC_HDD_IS_UNENCRYPTED
PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE
PRL_ERR_ENC_KEY_NOT_SET
  • Encryption engine errors

+++ ALIGNED VALUE TO 43000
PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED
PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY
PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE
PRL_ERR_ENC_WRONG_HDD_PASSWORD
PRL_ERR_ENC_WRONG_KEY
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_EXT_DISK_ALREADY_EXISTS
PRL_ERR_EXT_DISK_CANT_RENAME
PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER
PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FAILURE_ON_VM_DESTROYED
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF
File Manager errors +++ ALIGNED VALUE TO 51000
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED
  • File Transfer errors

+++ ALIGNED VALUE TO 26000
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FILECOPY_CANT_CREATE_DIR
PRL_ERR_FILECOPY_CANT_OPEN_FILE
PRL_ERR_FILECOPY_CANT_WRITE
PRL_ERR_FILECOPY_DIR_EXIST
PRL_ERR_FILECOPY_FILE_EXIST
PRL_ERR_FILECOPY_INTERNAL
PRL_ERR_FILECOPY_PROTOCOL
PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_DISK_FREE_SPACE_FAILED
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_GUEST_USB_REQUIRED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HTTP_AUTH_REQUIRED
PRL_ERR_HTTP_CONNECTION_REFUSED
PRL_ERR_HTTP_HOST_NOT_FOUND
Problem report send errors set +++ ALIGNED VALUE TO 38000
PRL_ERR_HTTP_INVALID_RESPONSE_HEADER
PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE
PRL_ERR_HTTP_PROXY_AUTH_REQUIRED
PRL_ERR_HTTP_REQUEST_FAILED
PRL_ERR_HTTP_UNEXPECTED_CLOSE
PRL_ERR_HTTP_WRONG_CONTENT_LENGTH
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_DISABLED_WARNING
PRL_ERR_HVT_NOT_AVAILABLE_WARNING
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_NOT_PRESENT_WARNING
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IAP_INVALID_PRODUCT_ID
PRL_ERR_IAP_PAYMENT_FAILED
PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED
PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED
PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID
PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED
PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED
PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED
PRL_ERR_IAP_STORE_NO_CONNECTION
InApp purchase errors +++ ALIGNED VALUE TO 48000
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED
PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ACTION_REQUESTED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_GUARANTEE
PRL_ERR_INVALID_MEMORY_QUOTA
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_OS_TYPE
PRL_ERR_INVALID_PARALLELS_DISK
  • Hard Drive

+++ ALIGNED VALUE TO 2000
PRL_ERR_INVALID_PARAM
PRL_ERR_INVALID_TOTAL_LIMIT
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IOSERVICE_COMPRESS
PRL_ERR_IPC_ATTACH_FAILED
PRL_ERR_IPC_CREATE_MAP_FAILED
PRL_ERR_IPC_FTOK_FAILED
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED
  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED
PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT
PRL_ERR_ISCSI_STORAGE_CREATE
PRL_ERR_ISCSI_STORAGE_EXTEND
PRL_ERR_ISCSI_STORAGE_GET_STATE
PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE
PRL_ERR_ISCSI_STORAGE_LIBRARY
iscsi storages errors +++ ALIGNED VALUE TO 44400
PRL_ERR_ISCSI_STORAGE_MOUNT
PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS
PRL_ERR_ISCSI_STORAGE_MOUNTED
PRL_ERR_ISCSI_STORAGE_NOT_FOUND
PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED
PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED
PRL_ERR_ISCSI_STORAGE_REMOVE
PRL_ERR_ISCSI_STORAGE_START
PRL_ERR_ISCSI_STORAGE_UMOUNT
PRL_ERR_IT_CANT_COMPACT
compact
PRL_ERR_IT_CANT_COMPACT_LDM_DISK
PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK
PRL_ERR_IT_CANT_GET_BITMAP
PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE
PRL_ERR_IT_CANT_OPEN_IMAGE
PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_IT_CANT_RECONFIG
PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP
PRL_ERR_IT_CANT_RESIZE_LDM_DISK
PRL_ERR_IT_CANT_RESIZE_VOLUME
resize
PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP
reconfig
PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR
convert
PRL_ERR_IT_DISK_SMALL_FOR_SPLIT
PRL_ERR_IT_FAST_RESIZE_FAILURE
PRL_ERR_IT_FIRST_ERROR
ALIGNED VALUE TO 46200
PRL_ERR_IT_FIRST_FAILURE
ALIGNED VALUE TO 46100
PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE
PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE
guest tools
PRL_ERR_IT_HAL_NOT_FOUND
PRL_ERR_IT_RECONFIG_PATH_NEEDED
PRL_ERR_IT_ROLLBACK_FAILURE
PRL_ERR_IT_SIZE_CHANGED
PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED
merge
PRL_ERR_IT_UNKNOWN_OS
PRL_ERR_IT_USER_INTERRUPTED
PRL_ERR_LIC_REGISTRATION_COMMON_ERROR
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_BLACKLISTED
PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION
PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_GRACED
PRL_ERR_LICENSE_IS_NOT_VOLUME
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT
PRL_ERR_LICENSE_RESTRICTED_GUEST_OS
PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER
PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH
PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM
PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE
PRL_ERR_LICENSE_TOO_MANY_MEMORY
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION
PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID
  • License

+++ ALIGNED VALUE TO 11000
PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM
PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM
PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND
PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE
PRL_ERR_LOW_MEMORY_LIMIT
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_MEM_EXCEED_PHY_SPACE
PRL_ERR_MEMFILE_DECRYPT_FAILED
PRL_ERR_MEMFILE_ENCRYPT_FAILED
PRL_ERR_MEMORY_ALLOC_ERROR
PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT
PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE
  • MobileFileSharing (MFS) errors

+++ ALIGNED VALUE TO 55000
PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED
PRL_ERR_MOUNTER_LIST_NO_OBJECT
PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ADAPTER_NOT_FOUND
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_GUEST_OS_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_UNATTENDED_DISK
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE
PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK
PRL_ERR_NOT_SENTILLION_CLIENT
Sentillion errors +++ ALIGNED VALUE TO 39000
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_BAD_INTERFACE
PRL_ERR_OBJECT_CLASS_NOT_FOUND
PRL_ERR_OBJECT_DUPLICATE_CLASS
PRL_ERR_OBJECT_DUPLICATE_UID
PRL_ERR_OBJECT_LIB_CANT_GET_PERMS
PRL_ERR_OBJECT_LIB_LOAD_ERROR
PRL_ERR_OBJECT_LIB_NO_FUNCTIONS
PRL_ERR_OBJECT_LIB_WRONG_PERMS
PRL_ERR_OBJECT_NOT_FOUND
  • Shared objects manipulation errors

+++ ALIGNED VALUE TO 42000
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_FAILED
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OS_RECONFIG_DATA_ABSENT
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARALLEL_PORT_NO_RASTERIZER
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED
PRL_ERR_PATH_IS_NOT_DIRECTORY
PRL_ERR_PAX_ACCESS_FORBIDDEN
PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED
PRL_ERR_PAX_LOGIN_MISMATCH_ERROR
PRL_ERR_PCMOVER_EXEC_FAILED
PRL_ERR_PCMOVER_MIGRATE_FAILED
PRL_ERR_PCMOVER_NOT_INSTALLED
PCmover managment library errors +++ ALIGNED VALUE TO 43100
PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR
PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR
PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED
PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST
PRL_ERR_PERFORM_MOUNTER_COMMAND
PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE
PRL_ERR_PPC_INVALID_CREDENTIALS
  • Proxy connection errors

+++ ALIGNED VALUE TO 600
PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT
PRL_ERR_PPC_SERVER_BUSY
PRL_ERR_PPC_UNABLE_TO_CONNECT
PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_PROXY_HANDSHAKE_FAILED
PRL_ERR_PROXY_PEER_NOT_FOUND
PRL_ERR_PROXY_WRONG_PORT_NUMBER
PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION
PRL_ERR_RCC_CONNECT_DESKTOP_ERROR
PRL_ERR_RCC_CONNECT_SERVER_ERROR
PRL_ERR_RCC_DESKTOP_SUSPENDED
PRL_ERR_RCC_DEVICE_BLACKLISTED
PRL_ERR_RCC_DEVICE_GREYLISTED
PRL_ERR_RCC_OPEN_APP_ERROR
PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED
PRL_ERR_RCC_PAX_LOGIN_ERROR
RCC errors +++ ALIGNED VALUE TO 49000
PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED
PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE
PRL_ERR_RCC_WAKEUP_SERVER_ERROR
PRL_ERR_READ_FAILED
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS
PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_RUN_VM_ACTION_SCRIPT
PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC
PRL_ERR_SAMPLE_CONFIG_NOT_FOUND
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SDK_TRY_AGAIN
SDK errors +++ ALIGNED VALUE TO 50000
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SERVICE_BUSY
PRL_ERR_SET_CPULIMIT
Virtuozzo specific error +++ ALIGNED VALUE TO 44000
PRL_ERR_SET_CPUMASK
PRL_ERR_SET_CPUUNITS
PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED
PRL_ERR_SET_IOLIMIT
PRL_ERR_SET_IOPRIO
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SET_NETWORK_SETTINGS_FAILED
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED
PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_BAD_EMULATION_TYPE
PRL_ERR_SOUND_DEVICE_WRITE_FAILED
  • Sound

+++ ALIGNED VALUE TO 5000
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_STAND_BY_VM_PAUSED
PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_START_SAFE_MODE_UNSUPPORTED
PRL_ERR_START_VM_BY_NOT_AUTH_USER
PRL_ERR_START_VM_BY_NOT_DEFINED_USER
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR
  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000
PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK
PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED
PRL_ERR_SUSPEND_REJECTED_BY_GUEST
PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_SUSPEND_VM_VTD_PAUSED
VM error codes +++ ALIGNED VALUE TO 36000
PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_WITH_USB_BOOTDISK
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TEMPLATE_HAS_APPS
containers templates errors +++ ALIGNED VALUE TO 46400
PRL_ERR_TEMPLATE_NOT_FOUND
PRL_ERR_TEST_TEXT_MESSAGES
Test errors +++ ALIGNED VALUE TO 43200
PRL_ERR_TEST_TEXT_MESSAGES_PS
PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID
  • TIS errors

+++ ALIGNED VALUE TO 27800
PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE
PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS
PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION
PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED
PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION
PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE
PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED
PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD
PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION
PRL_ERR_UNABLE_TO_SEND_REQUEST
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER
PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED
PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNNAMED_CT_MOVE
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE
VI convert errors +++ ALIGNED VALUE TO 45000
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG
  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000
PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG
  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000
PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_ENCRYPTED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN
PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_HARD_DISK_FAILED
PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS
PRL_ERR_VM_COMPACT_PROCESSING
  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED
PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED
PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE
PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE
PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE
PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_FROZEN_STATE
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_IN_WAKING_UP_STATE
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED
PRL_ERR_VM_IS_NOT_LOCKED
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LIFETIME_IS_EXPIRED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP
PRL_ERR_VM_LOCKED_FOR_BACKUP
PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL
PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD
PRL_ERR_VM_LOCKED_FOR_CLONE
Dispatcher 'locked' error codes +++ ALIGNED VALUE TO 38100
PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DECRYPT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT
PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT
PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_ENCRYPT
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_MOVE
PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION
PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP
PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED
PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION
PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY
PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM
PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM
PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED
PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED
PRL_ERR_VM_MIGRATE_RESUME_FAILED
PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE
PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED
PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE
PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MOUNT
VM hdd mount/umount +++ ALIGNED VALUE TO 46600
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW
PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SHUTDOWN_FAILED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED
PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED
PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SNAPSHOT_NOT_FOUND
PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOL_NOT_AVAILABLE
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UNMOUNT
PRL_ERR_VM_UNPAUSE_FAILED
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
Unused PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_MASK_INVALID
PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND
PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE is unused
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT
PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS
PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT
PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET
PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME
PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS
PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT
ALIGNED VALUE TO 27770
PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT
PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE
PRL_ERR_VMCONF_RESTRICTED_OS_VERSION
  • Validation VM configuration error

+++ ALIGNED VALUE TO 26500
PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD
PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS
PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
+++ ALIGNED VALUE TO 27550 +++ Unused PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
Unused PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED
ALIGNED VALUE TO 27000
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED
PRL_ERR_VMCONF_VIDEO_NOT_ENABLED
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VMHELPER_CREATEVM_FAILED
STW7 VmHelper errors +++ ALIGNED VALUE TO 41400
PRL_ERR_VMHELPER_DIR_PATH_INVALID
PRL_ERR_VMHELPER_DISK_MOUNT_FAILED
PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED
PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST
PRL_ERR_VTD_DEVICE_NOT_MAPPED
  • VT-d

+++ ALIGNED VALUE TO 12000
PRL_ERR_VTD_DEVICE_TROUBLESHOOT
PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT
PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT
PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_INSTALLATION_FAILED
PRL_ERR_VTD_HOOK_INVALID_CONFIG
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_HOOK_REVERT_FAILED
PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_VZ_API_NOT_INITIALIZED
PRL_ERR_VZ_OPERATION_FAILED
PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND
PRL_ERR_VZCTL_OPERATION_FAILED
PRL_ERR_VZLICENSE_ACTIVATION_KEY
PRL_ERR_VZLICENSE_CANCEL
PRL_ERR_VZLICENSE_EACCES
PRL_ERR_VZLICENSE_ERR_KA
PRL_ERR_VZLICENSE_EXIST
PRL_ERR_VZLICENSE_FATAL
PRL_ERR_VZLICENSE_INVAL
PRL_ERR_VZLICENSE_INVALID_HWID
PRL_ERR_VZLICENSE_IO
PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED
PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH
PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED
PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET
PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED
PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE
PRL_ERR_VZLICENSE_LOCK
PRL_ERR_VZLICENSE_NETWORK
PRL_ERR_VZLICENSE_NODATA
PRL_ERR_VZLICENSE_NOENT
PRL_ERR_VZLICENSE_NOINIT
PRL_ERR_VZLICENSE_NOMEM
PRL_ERR_VZLICENSE_NOTSUP
PRL_ERR_VZLICENSE_PROXY
PRL_ERR_VZLICENSE_PROXY_AUTH
PRL_ERR_VZLICENSE_TASK_ALREADY_RUN
PRL_ERR_VZLICENSE_TIMEOUT
PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP
PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED
PRL_ERR_VZLICENSE_WRONG
PRL_ERR_WEB_PORTAL_ACCEPTED
PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS
PRL_ERR_WEB_PORTAL_BAD_REQUEST
errors
PRL_ERR_WEB_PORTAL_CONFLICT
PRL_ERR_WEB_PORTAL_CREATED
PRL_ERR_WEB_PORTAL_FORBIDDEN
PRL_ERR_WEB_PORTAL_INVALID_EMAIL
PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS
PRL_ERR_WEB_PORTAL_INVALID_PASSWORD
PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED
PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED
PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_NO_CONTENT
PRL_ERR_WEB_PORTAL_NOT_FOUND
PRL_ERR_WEB_PORTAL_OK
success
PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED
PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT
PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL
PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT
PRL_ERR_WEB_PORTAL_UNAUTHORIZED
PRL_ERR_WEB_PORTAL_UNEXPECTED
PRL_ERR_WIN_AERO_DISABLED
isn't used now
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRITE_FAILED
PRL_ERR_WRONG_CIPHER_ID_FORMAT
PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT
PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM
Encryption Vm errors +++ ALIGNED VALUE TO 44200
PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WRONG_TRANSACTION_STATE
PRL_ERR_WRONG_VM_STATE
PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP
PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE
PRL_ERR_XMLRPC_INTERNAL_ERROR
PRL_ERR_XMLRPC_INVALID_CREDENTIALS
PRL_ERR_XMLRPC_INVALID_REQUEST_INFO
PRL_ERR_XMLRPC_LIMITS_EXHAUSTED
PRL_ERR_XMLRPC_WRONG_METHOD_CALL


_PRL_EVENT_ISSUER_TYPE Enumeration

_PRL_EVENT_ISSUER_TYPE Enumeration
Other Structs

Event issuer type

Syntax
enum _PRL_EVENT_ISSUER_TYPE {
  PIE_VIRTUAL_MACHINE = 0,
  PIE_DISPATCHER = 1,
  PIE_IO_SERVICE = 2,
  PIE_WEB_SERVICE = 3,
  PIE_UNKNOWN = 0xFF
};
File

PrlEnums.h

Links
Other Structs


_PRL_EVENT_TYPE Enumeration

_PRL_EVENT_TYPE Enumeration
Other Structs

Different event types are identified by these event codes.

Syntax
enum _PRL_EVENT_TYPE {
  PET_VM_INF_UNINITIALIZED_EVENT_CODE = 100000,
  PET_DSP_EVT_VM_STATE_CHANGED = 100001,
  PET_DSP_EVT_VM_CONFIG_CHANGED = 100002,
  PET_DSP_EVT_VM_DEV_STATE_CHANGED = 100003,
  PET_DSP_EVT_VM_CREATED = 100004,
  PET_DSP_EVT_VM_ADDED = 100005,
  PET_DSP_EVT_VM_DELETED = 100006,
  PET_DSP_EVT_VM_STARTED = 100007,
  PET_DSP_EVT_VM_STOPPED = 100008,
  PET_DSP_EVT_VM_ABORTED = 100009,
  PET_DSP_EVT_VM_RESETED = 100010,
  PET_DSP_EVT_VM_SUSPENDING = 100011,
  PET_DSP_EVT_VM_SUSPENDED = 100012,
  PET_DSP_EVT_VM_RESUMING = 100013,
  PET_DSP_EVT_VM_RESUMED = 100014,
  PET_DSP_EVT_VM_START_IO_FLOW = 100015,
  PET_DSP_EVT_VM_SNAPSHOTED = 100016,
  PET_DSP_EVT_VM_STATESAVED = PET_DSP_EVT_VM_SNAPSHOTED,
  PET_DSP_EVT_VM_RESTORED = 100017,
  PET_DSP_EVT_VM_STATERESTORED = PET_DSP_EVT_VM_RESTORED,
  PET_DSP_EVT_VM_NET_RECONNECTED = 100018,
  PET_DSP_EVT_VM_PAUSED = 100019,
  PET_DSP_EVT_VM_CONTINUED = 100020,
  PET_DSP_EVT_VM_CONFIG_APPLIED = 100021,
  PET_DSP_EVT_VM_STATISTICS_UPDATED = 100022,
  PET_DSP_EVT_VM_PROBLEM_REPORT_CREATED = 100023,
  PET_DSP_EVT_VM_ABOUT_TO_RESET = 100024,
  PET_DSP_EVT_VM_SECURITY_CHANGED = 100025,
  PET_DSP_EVT_VM_UNREGISTERED = 100026,
  PET_DSP_EVT_VM_REMOTE_DEV_READY_TO_START = 100027,
  PET_VM_EVT_VM_CONFIG_CHANGED = 100028,
  PET_VM_EVT_REQUEST_FILE_OPEN = 100029,
  PET_DSP_EVT_VM_MIGRATE_STARTED = 100030,
  PET_DSP_EVT_VM_MIGRATE_CANCELLED = 100031,
  PET_DSP_EVT_VM_MIGRATE_FINISHED = 100032,
  PET_DSP_EVT_VM_MIGRATE_PROGRESS_CHANGED = 100033,
  PET_DSP_EVT_VM_SNAPSHOTING = 100034,
  PET_DSP_EVT_VM_RESTORING = 100035,
  PET_DSP_EVT_VM_SNAPSHOTS_TREE_CHANGED = 100036,
  PET_DSP_EVT_VM_DELETING_STATE = 100037,
  PET_DSP_EVT_VM_STATE_DELETED = 100038,
  PET_DSP_EVT_VM_ABOUT_TO_START_DEINIT = 100039,
  PET_DSP_EVT_VM_ABOUT_TO_START_INIT = 100040,
  PET_DSP_EVT_VM_MEMORY_SWAPPING_STARTED = 100041,
  PET_DSP_EVT_VM_MEMORY_SWAPPING_FINISHED = 100042,
  PET_VM_EVT_UNMOUNT = 100043,
  PET_VM_EVT_MOUNT = 100044,
  PET_DSP_EVT_REBOOT_HOST = 100045,
  PET_DSP_EVT_REBOOT_HOST_MANUAL_TO_INIT_VTD_DEVICES = 100046,
  PET_DSP_EVT_BACKUP_STARTED = 100047,
  PET_DSP_EVT_BACKUP_CANCELLED = 100048,
  PET_DSP_EVT_CREATE_BACKUP_FINISHED = 100049,
  PET_DSP_EVT_BACKUP_PROGRESS_CHANGED = 100050,
  PET_DSP_EVT_JOB_PROGRESS_CHANGED = 100051,
  PET_DSP_EVT_RESTORE_PROGRESS_CHANGED = 100052,
  PET_DSP_EVT_DISK_RESIZE_STARTED = 100053,
  PET_DSP_EVT_DISK_RESIZE_FINISHED = 100054,
  PET_DSP_EVT_DISK_RESIZE_PROGRESS_CHANGED = 100055,
  PET_DSP_EVT_VM_ADDITION_STATE_CHANGED = 100056,
  PET_DSP_EVT_RESTORE_BACKUP_FINISHED = 100057,
  PET_DSP_EVT_REMOVE_BACKUP_FINISHED = 100058,
  PET_DSP_EVT_VM_MIGRATE_CANCELLED_DISP = 100059,
  PET_DSP_EVT_VM_MIGRATE_FINISHED_DISP = 100060,
  PET_DSP_EVT_TIME_MACHINE_BACKUP_IS_OVER = 100061,
  PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_CHANGED = 100062,
  PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_FINISHED = 100063,
  PET_DSP_EVT_CONVERT_THIRD_PARTY_PROGRESS_CHANGED = 100064,
  PET_DSP_EVT_CONNECTED_TO_PROXY = 100065,
  PET_DSP_EVT_DISCONNECTED_FROM_PROXY = 100066,
  PET_DSP_EVT_CONNECTING_TO_PROXY = 100067,
  PET_DSP_EVT_RECONFIG_VM_PROGRESS_CHANGED = 100068,
  PET_DSP_EVT_VM_MIGRATE_WAIT_REMOUNT = 100069,
  PET_DSP_EVT_VM_CONFIG_APPLY_FINISHED = 100070,
  PET_DSP_EVT_VM_IO_CLIENT_STATISTICTS = 100071,
  PET_DSP_EVT_VM_SET_HOST_TIME = 100072,
  PET_DSP_EVT_VM_LOW_HOST_MEMORY = 100073,
  PET_DSP_EVT_VM_MAC_OS_VER = 100074,
  PET_DSP_EVT_VM_PAUSED_BY_HOST_SLEEP = 100075,
  PET_DSP_EVT_VM_CONTINUED_BY_HOST_WAKEUP = 100076,
  PET_DSP_EVT_VM_FROZEN = 100077,
  PET_DSP_EVT_VM_UNFROZEN = 100078,
  PET_DSP_EVT_CONNECTION_CLIENT_INFO_WAS_SET = 100079,
  PET_DSP_EVT_CONNECTION_WAS_CLOSED = 100080,
  PET_DSP_EVT_HOST_CLEANUP = 100081,
  PET_DSP_EVT_HTTP_PROXY_AUTH_REQUIRED = 100082,
  PET_DSP_EVT_OP_ACCEPTED = 100100,
  PET_DSP_EVT_OP_REJECTED = 100101,
  PET_DSP_EVT_OP_RESULT = 100102,
  PET_DSP_EVT_DIR_STATE_CHANGED = 100200,
  PET_DSP_EVT_HOST_STATISTICS_UPDATED = 100201,
  PET_DSP_EVT_HW_CONFIG_CHANGED = 100202,
  PET_DSP_EVT_CLIENT_CONNECTED = 100300,
  PET_DSP_EVT_CLIENT_DISCONNECTED = 100301,
  PET_DSP_EVT_CLIENT_REJECTED = 100302,
  PET_DSP_EVT_FOUND_LOST_VM_CONFIG = 100400,
  PET_DSP_EVT_HAS_EVENT = 100401,
  PET_DSP_EVT_RECONNECT = 100402,
  PET_DSP_EVT_DISP_CONNECTION_CLOSED = 100403,
  PET_DSP_EVT_DISP_SHUTDOWN = 100404,
  PET_DSP_EVT_USER_PROFILE_CHANGED = 100500,
  PET_DSP_EVT_COMMON_PREFS_CHANGED = 100501,
  PET_DSP_EVT_VM_MESSAGE = 100502,
  PET_DSP_EVT_VM_QUESTION = 100503,
  PET_JOB_DELETE_VM_PROGRESS_CHANGED = 100504,
  PET_VM_INF_START_FILE_COPYING = 100505,
  PET_VM_INF_END_FILE_COPYING = 100506,
  PET_DSP_EVT_ERROR_MESSAGE = 100507,
  PET_DSP_EVT_WARNING_MESSAGE = 100508,
  PET_JOB_HDD_CREATE_PROGRESS_CHANGED = 100509,
  PET_JOB_FILE_COPY_PROGRESS_CHANGED = 100510,
  PET_JOB_SUSPEND_PROGRESS_CHANGED = 100511,
  PET_JOB_RESUME_PROGRESS_CHANGED = 100512,
  PET_DSP_EVT_ANSWER_TO_VM_WAS_DONE = 100513,
  PET_DSP_EVT_LICENSE_CHANGED = 100514,
  PET_JOB_CREATE_SNAPSHOT_PROGRESS_CHANGED = 100515,
  PET_JOB_SWITCH_TO_SNAPSHOT_PROGRESS_CHANGED = 100516,
  PET_JOB_DELETE_SNAPSHOT_PROGRESS_CHANGED = 100517,
  PET_JOB_COMMIT_UNFINISHED_DISK_OP_PROGRESS_CHANGED = 100518,
  PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_STARTED = 100519,
  PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_FINISHED = 100520,
  PET_DSP_EVT_VM_ENCRYPT_PROGRESS_CHANGED = 100521,
  PET_DSP_EVT_VM_DECRYPT_PROGRESS_CHANGED = 100522,
  PET_JOB_STAGE_PROGRESS_CHANGED = 100523,
  PET_VM_INF_START_BUNCH_COPYING = 100524,
  PET_VM_INF_END_BUNCH_COPYING = 100525,
  PET_DSP_EVT_LICENSE_WAS_DEACTIVATED = 100526,
  PET_DSP_EVT_SMC_USER_FORCE_DISCONNECTED = 100600,
  PET_DSP_EVT_SMC_CANCEL_USER_COMMAND = 100601,
  PET_DSP_EVT_SMC_DISPATCHER_SHUTDOWN = 100602,
  PET_IO_SCREEN_SIZE = 100700,
  PET_IO_SLIDING_MOUSE_FLAG = 100702,
  PET_IO_DEVICE_IS_IN_USE = 100703,
  PET_IO_KEYBOARD_LEDS = 100704,
  PET_IO_STATE = 100705,
  PET_IO_SCREEN_CAPTURED = 100706,
  PET_IO_BEFORE_SCREEN_SIZE = 100707,
  PET_IO_REMOTE_COMMAND = 100708,
  PET_IO_MOUSE_CURSOR_CHANGED = 100709,
  PET_IO_MOUSE_CURSOR_HID = 100710,
  PET_IO_MOUSE_CURSOR_SET = 100711,
  PET_IO_DYNRES_TOOL_STATUS = 100712,
  PET_IO_TOOLS_UTILITY_COMMAND = 100713,
  PET_IO_TOOLS_VM_SHUTDOWN = 100714,
  PET_IO_TOOLS_CLIPBOARD_DATA = 100715,
  PET_IO_SCREEN_SURFACE_DETACHED = 100716,
  PET_IO_TOOLS_SIA_DATA = 100717,
  PET_IO_TOOLS_VMCTG_COMMAND = 100718,
  PET_IO_TOOLS_DRAGDROP_DATA = 100719,
  PET_IO_TOOLS_GENERAL_COMMAND = 100720,
  PET_IO_TOOLS_DESKTOP_UTILITY_STATE = 100721,
  PET_IO_DISPLAY_SCREEN_SIZE = 100722,
  PET_IO_DISPLAY_BEFORE_SCREEN_SIZE = 100723,
  PET_IO_DISPLAY_SCREEN_CAPTURED = 100724,
  PET_IO_SWITCH_VESA_MODE = 100725,
  PET_IO_TOOLS_LANGUAGE_HOTKEY_CHANGED = 100726,
  PET_IO_AVAILABLE_DISPLAYS = 100727,
  PET_IO_SCREEN_SURFACE_ATTACHED = 100728,
  PET_IO_UIEMU_ELEMENT_AT_POS = 100729,
  PET_IO_AUDIO_OUTPUT_DATA = 100730,
  PET_IO_AUDIO_OUTPUT_ENCODING_SET = 100731,
  PET_IO_AUDIO_OUTPUT_STREAM_STARTED = 100732,
  PET_IO_AUDIO_OUTPUT_STOP = 100734,
  PET_IO_CVSRC_OPEN = 100735,
  PET_IO_CVSRC_CLOSE = 100736,
  PET_IO_SSO_GET_CREDENTIALS = 100737,
  PET_IO_MOUSE_CURSOR_MOVED = 100738,
  PET_IO_UIEMU_CARET_INFO = 100739,
  PET_IO_DISPLAY_GAMMA_CHANGED = 100740,
  PET_DSP_EVT_VM_TOOLS_STATE_CHANGED = 100800,
  PET_DSP_EVT_VM_COMPACT_PROCESSING = 100801,
  PET_DSP_EVT_VM_COMPACT_FINISHED = 100802,
  PET_DSP_EVT_VM_COMPRESSOR_FINISHED = 100803,
  PET_DSP_EVT_VM_COMPRESSOR_CONTINUED = 100804,
  PET_DSP_EVT_VM_SOFTWARE_INSTALLED = 100805,
  PET_DSP_EVT_VM_PIS_NOTIFICATION_ASK_TO_INSTALL = 100806,
  PET_DSP_EVT_VM_VIRTUAL_DEVICES_STATE_CHANGED = 100807,
  PET_DSP_EVT_PERFSTATS = 100900,
  PET_DSP_EVT_VM_PERFSTATS = 100901,
  PET_DSP_EVT_VM_UPGRADE_INIT = 101000,
  PET_DSP_EVT_VM_UPGRADE_INIT_TIMEOUT = 101001,
  PET_DSP_EVT_VM_UPGRADE_STAGE_1 = 101002,
  PET_DSP_EVT_VM_UPGRADE_STAGE_2 = 101003,
  PET_DSP_EVT_VM_UPGRADE_STAGE_3 = 101004,
  PET_DSP_EVT_VM_UPGRADE_COMPLETED = 101005,
  PET_DSP_EVT_VM_UPGRADE_UNKNOWN_ERROR = 101006,
  PET_DSP_EVT_VM_UPGRADE_INIT_VMW = 101007,
  PET_DSP_EVT_VM_UPGRADE_INIT_PHY = 101008,
  PET_IO_READY_TO_ACCEPT_STDIN_PKGS = 101100,
  PET_VM_READY_TO_BOOT = 101200,
  PET_VM_READY_TO_PRINT = 101201,
  PET_VM_DEFAULT_SOUND_RECONNECTED = 101202,
  PET_VM_EVT_UNMOUNT_USB_MEDIA = 101203,
  PET_VM_EVT_UNMOUNT_DVD_MEDIA = 101204,
  PET_DSP_EVT_APPLIANCE_DOWNLOAD_PROGRESS_CHANGED = 101300,
  PET_DSP_EVT_APPLIANCE_DOWNLOAD_FINISHED = 101301,
  PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_STARTED = 101302,
  PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_FINISHED = 101303,
  PET_DSP_EVT_APPLIANCE_REGISTER_VM_STARTED = 101304,
  PET_DSP_EVT_APPLIANCE_REGISTER_VM_FINISHED = 101305,
  PET_DSP_EVT_CEP_WRITE_STRING = 101400,
  PET_DSP_COHERENCE_FAKE_STUB_NOTIFICATION = 101401,
  PET_DSP_EVT_VM_WAS_ENCRYPTED = 101500,
  PET_DSP_EVT_VM_WAS_DECRYPTED = 101501,
  PET_DSP_EVT_ENCRYPTED_VM_PASSWORD_CHANGED = 101502,
  PET_DSP_EVT_ENCRYPTED_VM_NEED_AUTH_AGAIN = 101503,
  PET_DSP_EVT_VM_WAS_PROTECTED = 101504,
  PET_DSP_EVT_VM_WAS_UNPROTECTED = 101505,
  PET_VM_EVT_TIS_BACKUP_WRITE = 101600,
  PET_IO_EVT_DISCONNECT_WITH_REASON = 101700,
  PET_VIDEO_RECEIVER_FORMAT = 101800,
  PET_VIDEO_RECEIVER_FRAME = 101801,
  PET_VIDEO_RECEIVER_CLOSED = 101802,
  PET_VIDEO_CAPTURE_GEOMETRY = 101803,
  PET_VIDEO_RECEIVER_CONNECTION_STATE = 101804,
  PET_PTM_EVT_PROPERTY_CHANGED = 101900,
  PET_PTM_EVT_OBJECT_DELETED = 101901,
  PET_PTM_EVT_OBJECT_CREATED = 101902,
  PET_PTM_EVT_SUBSCRIBED = 101903,
  PET_PTM_EVT_RPC_COMPLETED = 101904
};
File

PrlEventsValues.h

Members

PET_VM_INF_UNINITIALIZED_EVENT_CODE
BASE VALUE SET TO 100000
PET_DSP_EVT_OP_ACCEPTED
ALIGNED VALUE TO 100100
PET_DSP_EVT_DIR_STATE_CHANGED
ALIGNED VALUE TO 100200
PET_DSP_EVT_CLIENT_CONNECTED
ALIGNED VALUE TO 100300
PET_DSP_EVT_FOUND_LOST_VM_CONFIG
ALIGNED VALUE TO 100400
PET_DSP_EVT_USER_PROFILE_CHANGED
ALIGNED VALUE TO 100500
PET_DSP_EVT_SMC_USER_FORCE_DISCONNECTED
ALIGNED VALUE TO 100600
PET_IO_SCREEN_SIZE
ALIGNED VALUE TO 100700
PET_DSP_EVT_VM_TOOLS_STATE_CHANGED
ALIGNED VALUE TO 100800
PET_DSP_EVT_PERFSTATS
ALIGNED VALUE TO 100900
PET_DSP_EVT_VM_UPGRADE_INIT
ALIGNED VALUE TO 101000
PET_IO_READY_TO_ACCEPT_STDIN_PKGS
ALIGNED VALUE TO 101100
PET_VM_READY_TO_BOOT
ALIGNED VALUE TO 101200
PET_DSP_EVT_APPLIANCE_DOWNLOAD_PROGRESS_CHANGED
ALIGNED VALUE TO 101300
PET_DSP_EVT_CEP_WRITE_STRING
ALIGNED VALUE TO 101400
PET_DSP_EVT_VM_WAS_ENCRYPTED
ALIGNED VALUE TO 101500
PET_VM_EVT_TIS_BACKUP_WRITE
ALIGNED VALUE TO 101600
PET_IO_EVT_DISCONNECT_WITH_REASON
ALIGNED VALUE TO 101700
PET_VIDEO_RECEIVER_FORMAT
ALIGNED VALUE TO 101800
PET_PTM_EVT_PROPERTY_CHANGED
ALIGNED VALUE TO 101900

Remarks

Client can query event handle with the PrlEvent_GetType call to get this code. @see PrlEvent_GetType

Links
Other Structs


_PRL_EXTERNAL_VM_TYPE Enumeration

_PRL_EXTERNAL_VM_TYPE Enumeration
Other Structs

External VM type for supporting native VM

Syntax
enum _PRL_EXTERNAL_VM_TYPE {
  PEVT_VM_UNKNOWN = 0,
  PEVT_NATIVE_VM = PEVT_VM_UNKNOWN,
  PEVT_VMWARE = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_FEATURES_MATRIX Enumeration

_PRL_FEATURES_MATRIX Enumeration
Other Structs

Features matrix list

Syntax
enum _PRL_FEATURES_MATRIX {
  PFSM_UNKNOWN_FEATURE = 0,
  PFSM_SATA_HOTPLUG_SUPPORT = 1,
  PFSM_DEFAULT_SATA_ALLOWED = PFSM_SATA_HOTPLUG_SUPPORT,
  PFSM_VM_CONFIG_MERGE_SUPPORT = 2,
  PFSM_PSBM5 = 3,
  PFSM_AUTOSTART_VM_AS_OWNER = 4,
  PFSM_DEFAULT_PLAINDISK_ALLOWED = 5,
  PFSM_NO_SHARED_NETWORKING = 6,
  PFSM_DISK_IO_LIMITS = 7,
  PFSM_FINE_CPU_LIMITS = 8,
  PFSM_ROUTED_NETWORKING = 9,
  PFSM_RAM_HOTPLUG_SUPPORT = 10,
  PFSM_CPU_HOTPLUG_SUPPORT = 11,
  PFSM_IPV6_SUPPORT = 12,
  PFSM_USB_PRINTER_SUPPORT = 13,
  PFSM_NIC_CHANGE_ALLOWED = 14,
  PFSM_DESKTOP_CONTROL_SUPPORT = 15,
  PFSM_PAX_FEATURE_RANGE_START = 1000,
  PFSM_PAX_FEATURE_MATRIX_SUPPORT = PFSM_PAX_FEATURE_RANGE_START,
  PFSM_PAX_FEATURE_RANGE_END
};
File

PrlEnums.h

Links
Other Structs


_PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration

_PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration
Other Structs

File system element type

Syntax
enum _PRL_FILE_SYSTEM_ELEMENT_TYPE {
  PSE_DRIVE = 0,
  PSE_DIRECTORY = 1,
  PSE_FILE = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_FILE_SYSTEM_FS_TYPE Enumeration

_PRL_FILE_SYSTEM_FS_TYPE Enumeration
Other Structs
Syntax
enum _PRL_FILE_SYSTEM_FS_TYPE {
  PRL_FS_INVALID = 0,
  PRL_FS_FAT = 1,
  PRL_FS_FAT32 = 2,
  PRL_FS_NTFS = 3,
  PRL_FS_HFS = 4,
  PRL_FS_ADFS = 5,
  PRL_FS_AFFS = 6,
  PRL_FS_AFS = 7,
  PRL_FS_AUTOFS = 8,
  PRL_FS_CODA = 9,
  PRL_FS_EFS = 10,
  PRL_FS_EXTFS = 11,
  PRL_FS_HPFS = 12,
  PRL_FS_ISOFS = 13,
  PRL_FS_JFFS2 = 14,
  PRL_FS_NFS = 15,
  PRL_FS_QNX4 = 16,
  PRL_FS_REISERFS = 17,
  PRL_FS_SMBFS = 18,
  PRL_FS_GFS = 19,
  PRL_FS_FUSE = 20,
  PRL_FS_UNSPECIFIED = 0xFF
};
File

PrlEnums.h

Links
Other Structs


_PRL_FILE_SYSTEM_TYPE Enumeration

_PRL_FILE_SYSTEM_TYPE Enumeration
Other Structs

File system general type

Syntax
enum _PRL_FILE_SYSTEM_TYPE {
  PFS_WINDOWS_LIKE_FS = 0,
  PFS_UNIX_LIKE_FS = 1
};
File

PrlEnums.h

Links
Other Structs


PRL_FILE Types Types

PRL_FILE Types Types
PRL_FILE Types
Types
Name | Description
PRL_FILE_DESC | File descriptor type
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |


_PRL_FIREWALL_DIRECTION Enumeration

_PRL_FIREWALL_DIRECTION Enumeration
Other Structs

Firewall direction

Syntax
enum _PRL_FIREWALL_DIRECTION {
  PFD_INCOMING = 0,
  PFD_OUTGOING = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_FIREWALL_POLICY Enumeration

_PRL_FIREWALL_POLICY Enumeration
Other Structs

Firewall policy

Syntax
enum _PRL_FIREWALL_POLICY {
  PFP_ACCEPT = 0,
  PFP_DENY = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_GENERIC_DEVICE_STATE Enumeration

_PRL_GENERIC_DEVICE_STATE Enumeration
Other Structs

Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started

Syntax
enum _PRL_GENERIC_DEVICE_STATE {
  PGS_CONNECTED_TO_HOST = 0,
  PGS_CONNECTED_TO_VM = 1,
  PGS_RESERVED = 2,
  PGS_NON_CONTROLLED_USB = PGS_RESERVED,
  PGS_CONNECTING_TO_VM = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_GENERIC_PCI_DEVICE_CLASS Enumeration

_PRL_GENERIC_PCI_DEVICE_CLASS Enumeration
Other Structs

Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device

Syntax
enum _PRL_GENERIC_PCI_DEVICE_CLASS {
  PGD_PCI_NETWORK = 0,
  PGD_PCI_DISPLAY = 1,
  PGD_PCI_SOUND = 2,
  PGD_PCI_OTHER = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_GET_SNAPSHOT_TREE_FLAGS Enumeration

_PRL_GET_SNAPSHOT_TREE_FLAGS Enumeration
Other Structs

PrlVm_GetSnapshotsTreeEx flags

Syntax
enum _PRL_GET_SNAPSHOT_TREE_FLAGS {
  PGST_FULL_SIZE_SCREENSHOTS = 1<<(PACF_MAX+1),
  PGST_WITHOUT_SCREENSHOTS = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Members

PGST_FULL_SIZE_SCREENSHOTS
return screenshots in full size
PGST_WITHOUT_SCREENSHOTS
fast way to request snapshots tree

Links
Other Structs


_PRL_GET_VM_CONFIG_FLAGS Enumeration

_PRL_GET_VM_CONFIG_FLAGS Enumeration
Other Structs

Find VM operations:

Syntax
enum _PRL_GET_VM_CONFIG_FLAGS {
  PGVC_SEARCH_BY_UUID = 1<<(PACF_MAX+1),
  PGVC_SEARCH_BY_NAME = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_GET_VM_CONFIG_PARAM_DATA Structure

_PRL_GET_VM_CONFIG_PARAM_DATA Structure
Other Structs
Syntax
struct _PRL_GET_VM_CONFIG_PARAM_DATA {
  PRL_VM_TYPE nVmType;
  PRL_CONST_STR sConfigSample;
  PRL_UINT32 nOsVersion;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_GET_VM_LIST_FLAGS Enumeration

_PRL_GET_VM_LIST_FLAGS Enumeration
Other Structs

List operations: Uses for PrlSrv_GetVmListEx operation

Syntax
enum _PRL_GET_VM_LIST_FLAGS {
  PGVLF_GET_ONLY_VM = PVTF_VM,
  PGVLF_GET_ONLY_CT = PVTF_CT,
  PGVLF_GET_ONLY_IDENTITY_INFO = 1<<(PACF_MAX+3),
  PGVLF_GET_STATE_INFO = 1<<(PACF_MAX+4)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES Enumeration

_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES Enumeration
Other Structs
Syntax
enum _PRL_GRACEFUL_SHUTDOWN_CAPABILITIES {
  PGST_CAPABILITY_SHUTDOWN = 0x1,
  PGST_CAPABILITY_REBOOT = 0x2,
  PGST_CAPABILITY_SUSPEND = 0x4,
  PGST_CAPABILITY_HIBERNATE = 0x8
};
File

PrlEnums.h

Links
Other Structs


_PRL_GRACEFUL_SHUTDOWN_KIND Enumeration

_PRL_GRACEFUL_SHUTDOWN_KIND Enumeration
Other Structs

Graceful Shutdown types

Syntax
enum _PRL_GRACEFUL_SHUTDOWN_KIND {
  PST_VM_SHUTDOWN = 0,
  PST_VM_REBOOT = 1,
  PST_VM_HIBERNATE = 2,
  PST_VM_SUSPEND = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_GUEST_DISTRO_VERSION_ENUM Enumeration

_PRL_GUEST_DISTRO_VERSION_ENUM Enumeration
Other Structs

Windows installation distributive type.

Syntax
enum _PRL_GUEST_DISTRO_VERSION_ENUM {
  PGD_UNKNOWN = 0,
  PGD_WINDOWS_VISTA = 1,
  PGD_WINDOWS_XP = 2,
  PGD_WINDOWS_XP_32 = PGD_WINDOWS_XP,
  PGD_WINDOWS_XP_64 = 3,
  PGD_WINDOWS_VISTA_32 = PGD_WINDOWS_VISTA,
  PGD_WINDOWS_VISTA_64 = 4,
  PGD_WINDOWS_10_32 = 5,
  PGD_WINDOWS_10_64 = 6
};
File

PrlEnums.h

Links
Other Structs


_PRL_GUID Structure

_PRL_GUID Structure
Other Structs

Global unique identifier

Syntax
struct _PRL_GUID {
  PRL_UINT32 Data1;
  PRL_UINT16 Data2;
  PRL_UINT16 Data3;
  PRL_UINT8 Data4[8];
};
File

PrlTypes.h

Links
Other Structs


_PRL_HANDLE_TYPE Enumeration

_PRL_HANDLE_TYPE Enumeration
Other Structs

The _PRL_HANDLE_TYPE enumeration defines handle types.

Syntax
enum _PRL_HANDLE_TYPE {
  PHT_ERROR = 0,
  PHT_SERVER = 0x10000001,
  PHT_SERVER_CONFIG = 0x10000002,
  PHT_REMOTE_FILESYSTEM_INFO = 0x10000003,
  PHT_REMOTE_FILESYSTEM_ENTRY = 0x10000004,
  PHT_VIRTUAL_MACHINE = 0x10000005,
  PHT_VIRTUAL_DEV_DISPLAY = 0x10000006,
  PHT_VIRTUAL_DEV_KEYBOARD = 0x10000007,
  PHT_VIRTUAL_DEV_MOUSE = 0x10000008,
  PHT_VIRTUAL_DEV_FLOPPY = 0x10000009,
  PHT_VIRTUAL_DEV_HARD_DISK = 0x1000000A,
  PHT_VIRTUAL_DEV_NET_ADAPTER = 0x1000000B,
  PHT_VIRTUAL_DEV_PARALLEL_PORT = 0x1000000C,
  PHT_VIRTUAL_DEV_SERIAL_PORT = 0x1000000D,
  PHT_VIRTUAL_DEV_OPTICAL_DISK = 0x1000000E,
  PHT_VIRTUAL_DEV_USB_DEVICE = 0x1000000F,
  PHT_VIRTUAL_DEV_SOUND = 0x10000010,
  PHT_JOB = 0x10000011,
  PHT_EVENT = 0x10000012,
  PHT_RESULT = 0x10000013,
  PHT_VM_INFO = 0x10000014,
  PHT_USER_PROFILE = 0x10000015,
  PHT_DISP_CONFIG = 0x10000016,
  PHT_SHARE = 0x10000017,
  PHT_SCREEN_RESOLUTION = 0x10000018,
  PHT_DISP_NET_ADAPTER = 0x10000019,
  PHT_HW_GENERIC_DEVICE = 0x1000001A,
  PHT_HW_HARD_DISK = 0x1000001B,
  PHT_HW_HARD_DISK_PARTITION = 0x1000001C,
  PHT_HW_NET_ADAPTER = 0x1000001D,
  PHT_EVENT_PARAMETER = 0x1000001E,
  PHT_REMOTEDEV_CMD = 0x1000001F,
  PHT_SYSTEM_STATISTICS = 0x10000020,
  PHT_SYSTEM_STATISTICS_CPU = 0x10000021,
  PHT_SYSTEM_STATISTICS_IFACE = 0x10000022,
  PHT_SYSTEM_STATISTICS_USER_SESSION = 0x10000023,
  PHT_SYSTEM_STATISTICS_DISK = 0x10000024,
  PHT_SYSTEM_STATISTICS_DISK_PARTITION = 0x10000025,
  PHT_SYSTEM_STATISTICS_PROCESS = 0x10000026,
  PHT_LICENSE = 0x10000027,
  PHT_SERVER_INFO = 0x10000028,
  PHT_BOOT_DEVICE = 0x10000029,
  PHT_STRINGS_LIST = 0x1000002A,
  PHT_LOGIN_RESPONSE = 0x1000002B,
  PHT_RUNNING_TASK = 0x1000002C,
  PHT_NET_SERVICE_STATUS = 0x1000002D,
  PHT_HANDLES_LIST = 0x1000002E,
  PHT_VIRTUAL_DISK = 0x1000002F,
  PHT_ACCESS_RIGHTS = 0x10000030,
  PHT_VM_TOOLS_INFO = 0x10000031,
  PHT_FOUND_VM_INFO = 0x10000032,
  PHT_TIS_RECORD = 0x10000033,
  PHT_USER_INFO = 0x10000034,
  PHT_VM_CONFIGURATION = PHT_VIRTUAL_MACHINE,
  PHT_TIS_EMITTER = 0x10000036,
  PHT_TOOL = 0x10000037,
  PHT_VIRTUAL_DEV_HD_PARTITION = 0x10000038,
  PHT_VIRTUAL_DEV_GENERIC_PCI = 0x10000039,
  PHT_VIRTUAL_DEV_GENERIC_SCSI = 0x1000003A,
  PHT_VM_GUEST_SESSION = 0x1000003B,
  PHT_VIRTUAL_NETWORK = 0x1000003C,
  PHT_PORT_FORWARDING = 0x1000003D,
  PHT_HW_GENERIC_PCI_DEVICE = 0x1000003E,
  PHT_OPAQUE_TYPE_LIST = 0x1000003F,
  PHT_GUEST_OSES_MATRIX = 0x10000040,
  PHT_PROBLEM_REPORT = 0x10000041,
  PHT_APPLIANCE_CONFIG = 0x10000042,
  PHT_OFFLINE_SERVICE = 0x10000043,
  PHT_VM_VIRTUAL_DEVICES_INFO = 0x10000044,
  PHT_NETWORK_CLASS = 0x10000045,
  PHT_NETWORK_SHAPING = 0x10000046,
  PHT_NETWORK_RATE = 0x10000047,
  PHT_ISCSI_LUN = 0x10000048,
  PHT_CT_TEMPLATE = 0x10000049,
  PHT_UIEMU_INPUT = 0x10000050,
  PHT_USB_IDENTITY = 0x10000051,
  PHT_FIREWALL_RULE = 0x10000052,
  PHT_IPPRIV_NET = 0x10000053,
  PHT_PLUGIN_INFO = 0x10000054,
  PHT_CVSRC = 0x10000055,
  PHT_DESKTOP_CONTROL = 0x10000056,
  PHT_BACKUP_RESULT = 0x10000057,
  PHT_NETWORK_SHAPING_CONFIG = 0x10000058,
  PHT_NETWORK_SHAPING_BANDWIDTH = 0x10000059,
  PHT_SYSTEM_STATISTICS_VM_DATA = 0x1000005A,
  PHT_VIDEO_RECEIVER = 0x1000005B,
  PHT_SESSION_INFO = 0x1000005C,
  PHT_CPU_FEATURES = 0x1000005D,
  PHT_LAST = PHT_CPU_FEATURES
};
File

PrlEnums.h

Members

PHT_LAST
should be set to last

Remarks

Each handle type and the functions that operate on it is described in detail in the "Functions by Handle" chapter of the Parallels C API Reference guide.

Links
Other Structs


_PRL_HARD_DISK_IFACE_MASK Enumeration

_PRL_HARD_DISK_IFACE_MASK Enumeration
Other Structs

Hard disk interfce mask enum

Syntax
enum _PRL_HARD_DISK_IFACE_MASK {
  PIM_IDE_0_0 = (0x1L<<0),
  PIM_IDE_0_1 = (0x1L<<1),
  PIM_IDE_1_0 = (0x1L<<2),
  PIM_IDE_1_1 = (0x1L<<3),
  PIM_SCSI_0_0 = (0x1L<<4),
  PIM_SCSI_1_0 = (0x1L<<5),
  PIM_SCSI_2_0 = (0x1L<<6),
  PIM_SCSI_3_0 = (0x1L<<7),
  PIM_SCSI_4_0 = (0x1L<<8),
  PIM_SCSI_5_0 = (0x1L<<9),
  PIM_SCSI_6_0 = (0x1L<<10),
  PIM_SCSI_7_0 = (0x1L<<11),
  PIM_SCSI_8_0 = (0x1L<<12),
  PIM_SCSI_9_0 = (0x1L<<13),
  PIM_SCSI_10_0 = (0x1L<<14),
  PIM_SCSI_11_0 = (0x1L<<15),
  PIM_SCSI_12_0 = (0x1L<<16),
  PIM_SCSI_13_0 = (0x1L<<17),
  PIM_SCSI_14_0 = (0x1L<<18),
  PIM_SCSI_15_0 = (0x1L<<19),
  PIM_SATA_0_0 = (0x1L<<20),
  PIM_SATA_0_1 = (0x1L<<21),
  PIM_SATA_0_2 = (0x1L<<22),
  PIM_SATA_0_3 = (0x1L<<23),
  PIM_SATA_0_4 = (0x1L<<24),
  PIM_SATA_0_5 = (0x1L<<25),
  PIM_ALL_DISKS = ((0x1L<<26) - 1),
  PIM_COMPACT_DELAYED = (0x1L<<31),
  PIM_IDE_MASK_OFFSET = PIM_IDE_0_0,
  PIM_SCSI_MASK_OFFSET = PIM_SCSI_0_0,
  PIM_SATA_MASK_OFFSET = PIM_SATA_0_0
};
File

PrlEnums.h

Links
Other Structs


_PRL_HARD_DISK_INTERNAL_FORMAT Enumeration

_PRL_HARD_DISK_INTERNAL_FORMAT Enumeration
Other Structs

Hard disk image type

Syntax
enum _PRL_HARD_DISK_INTERNAL_FORMAT {
  PHD_PLAIN_HARD_DISK = 0,
  PHD_EXPANDING_HARD_DISK = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_HOST_OS_INFO Structure

_PRL_HOST_OS_INFO Structure
Other Structs
Syntax
struct _PRL_HOST_OS_INFO {
  PRL_UINT32 hostOSType;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_HOST_OS_TYPE Enumeration

_PRL_HOST_OS_TYPE Enumeration
Other Structs

Host OS type

Syntax
enum _PRL_HOST_OS_TYPE {
  PHO_MAC = 0,
  PHO_LIN = 1,
  PHO_WIN = 2,
  PHO_UNKNOWN = 0xFF
};
File

PrlEnums.h

Links
Other Structs


_PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration

_PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration
Other Structs

Network adapter types in hardware info list

Syntax
enum _PRL_HW_INFO_NET_ADAPTER_TYPE {
  PHI_REAL_NET_ADAPTER = 0,
  PHI_VIRTUAL_NET_ADAPTER = 1,
  PHY_WIFI_REAL_NET_ADAPTER = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_IMAGE_FORMAT Enumeration

_PRL_IMAGE_FORMAT Enumeration
Other Structs
Syntax
enum _PRL_IMAGE_FORMAT {
  PIF_RAW = 0x50000008,
  PIF_BMP = 0x50000009,
  PIF_JPG = 0x5000000A,
  PIF_PNG = 0x5000000B
};
File

PrlEnums.h

Links
Other Structs


_PRL_INSTALL_APPLIANCE_FLAGS Enumeration

_PRL_INSTALL_APPLIANCE_FLAGS Enumeration
Other Structs

Install appliance options

  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
Syntax
enum _PRL_INSTALL_APPLIANCE_FLAGS {
  PIAF_CANCEL = 1<<(PACF_MAX+1),
  PIAF_FORCE = 1<<(PACF_MAX+2),
  PIAF_STOP = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


PRL_INT Types Types

PRL_INT Types Types
PRL_INT Types
Types
Name | Description
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |


_PRL_IO_ATTACH_REQUEST Structure

_PRL_IO_ATTACH_REQUEST Structure
Other Structs
Syntax
struct _PRL_IO_ATTACH_REQUEST {
  PRL_UINT32 isClientLocal;
  PRL_UINT32 encodingType;
  PRL_UINT8 vmUuid[16];
  PRL_UINT32 attachFlags;
};
File

PrlIoStructs.h

Members

attachFlags
Since 6.4 IO protocol version

Links
Other Structs


_PRL_IO_ATTACH_RESPONSE Structure

_PRL_IO_ATTACH_RESPONSE Structure
Other Structs
Syntax
struct _PRL_IO_ATTACH_RESPONSE {
  PRL_UINT32 attachResult;
  PRL_UINT32 encodingResult;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AUDIO_DATA Structure

_PRL_IO_AUDIO_DATA Structure
Other Structs

Audio support since 6.6 IO protocol version.

Syntax
struct _PRL_IO_AUDIO_DATA {
  PRL_UINT64 framesCounter;
  PRL_UINT16 framesNum;
  PRL_UINT16* frameSize;
  PRL_VOID* frameData;
};
File

PrlIoStructs.h

Notes

this struct is visible only on client side and nobody sends/reads it from network.

Links
Other Structs


_PRL_IO_AUDIO_ENCODING Structure

_PRL_IO_AUDIO_ENCODING Structure
Other Structs

Audio support since 6.6 IO protocol version.

Syntax
struct _PRL_IO_AUDIO_ENCODING {
  PRL_UINT32 encodingType;
  PRL_UINT32 encodingQuality;
  PRL_UINT32 inout_bitRate;
  PRL_UINT32 inout_channelsNum;
  PRL_UINT32 inout_sampleRate;
  PRL_UINT32 inout_bitsPerChannel;
  PRL_UINT32 unused1;
  PRL_UINT32 unused2;
  PRL_UINT32 out_magicCookieSize;
  PRL_CHAR out_magicCookie[4];
};
File

PrlIoStructs.h

Members

inout_bitRate
< if 0 in request - correct value should be choosen by Vm side
inout_channelsNum
< if 0 in request - correct value should be choosen by Vm side
inout_sampleRate
< if 0 in request - correct value should be choosen by Vm side
inout_bitsPerChannel
< if 0 in request - correct value should be choosen by Vm side

Links
Other Structs


_PRL_IO_AUDIO_ENCODING_LIST Structure

_PRL_IO_AUDIO_ENCODING_LIST Structure
Other Structs

Audio support since 6.6 IO protocol version.

Syntax
struct _PRL_IO_AUDIO_ENCODING_LIST {
  PRL_UINT32 encodingListSz;
  PRL_UINT32 defaultEncodingIdx;
  PRL_IO_AUDIO_ENCODING encodingList[PRL_IO_MAX_AUDIO_ENCODINGS];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AUDIO_ENCODING_RESPONSE Structure

_PRL_IO_AUDIO_ENCODING_RESPONSE Structure
Other Structs

Audio support since 6.6 IO protocol version.

Syntax
struct _PRL_IO_AUDIO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
  PRL_IO_AUDIO_ENCODING encoding;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AUTH_EXEC_REQUEST Structure

_PRL_IO_AUTH_EXEC_REQUEST Structure
Other Structs
Syntax
struct _PRL_IO_AUTH_EXEC_REQUEST {
  PRL_UINT8 sessionUuid[16];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AUTH_REQUEST Structure

_PRL_IO_AUTH_REQUEST Structure
Other Structs
Syntax
struct _PRL_IO_AUTH_REQUEST {
  PRL_UINT8 sessionUuid[16];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AUTH_RESPONSE Structure

_PRL_IO_AUTH_RESPONSE Structure
Other Structs
Syntax
struct _PRL_IO_AUTH_RESPONSE {
  PRL_UINT32 authResult;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_AVAILABLE_DISPLAYS Structure

_PRL_IO_AVAILABLE_DISPLAYS Structure
Other Structs
Syntax
struct _PRL_IO_AVAILABLE_DISPLAYS {
  PRL_UINT32 availableDisplays;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_CHANNEL_STAT Structure

_PRL_IO_CHANNEL_STAT Structure
PRL_IO Structs
Syntax
struct _PRL_IO_CHANNEL_STAT {
  PRL_UINT32 delay;
  PRL_UINT32 upload;
  PRL_UINT32 download;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
  PRL_UINT32 reserved3;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_CLIENT_FLAGS Enumeration

_PRL_IO_CLIENT_FLAGS Enumeration
Other Structs

Flags which determines peer client while login to dispatcher and while attach to vm.

Syntax
enum _PRL_IO_CLIENT_FLAGS {
  PCF_ORIGINAL_CLIENT = 1<<(PACF_MAX+1),
  PCF_LIGHTWEIGHT_CLIENT = 1<<(PACF_MAX+2),
  PCF_TRUSTED_CHANNEL = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Members

PCF_ORIGINAL_CLIENT
Client with all features
PCF_LIGHTWEIGHT_CLIENT

  • Lightweight client (iPhone/iPad) which

does not subscribe on heavy packages

PCF_TRUSTED_CHANNEL

  • Login over trusted channel

(no need in username/password)

Links
Other Structs


_PRL_IO_DESKTOP_UTILITIES_STATE Structure

_PRL_IO_DESKTOP_UTILITIES_STATE Structure
Other Structs
Syntax
struct _PRL_IO_DESKTOP_UTILITIES_STATE {
  PRL_UINT32 bDesktopShown;
  PRL_UINT32 bTaskbarShown;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_DEVICE_USED Structure

_PRL_IO_DEVICE_USED Structure
Other Structs
Syntax
struct _PRL_IO_DEVICE_USED {
  PRL_UINT32 devType;
  PRL_UINT32 devIndex;
  PRL_UINT32 devAction;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_DISCONNECT_REASON Enumeration

_PRL_IO_DISCONNECT_REASON Enumeration
PRL_IO Structs

Specifies the reason of closing IO connection

Syntax
enum _PRL_IO_DISCONNECT_REASON {
  PDR_UNSPECIFIED = 0,
  PDR_RECONNECT = 1,
  PDR_HOST_USER_LOGGED_IN = 2,
  PDR_HOST_USER_INPUT_DETECTED = 3,
  PDR_ANOTHER_CLIENT_CONNECTED = 4,
  PDR_SESSION_BECOME_INACTIVE = 5
};
File

PrlEnums.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_ENCODING Structure

_PRL_IO_DISPLAY_ENCODING Structure
PRL_IO Structs

Since 6.3 IO protocol version.

Syntax
struct _PRL_IO_DISPLAY_ENCODING {
  PRL_UINT32 encodingType;
  PRL_UINT32 encodingQuality;
  PRL_CHAR encodingName[32];
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_ENCODING_LIST Structure

_PRL_IO_DISPLAY_ENCODING_LIST Structure
PRL_IO Structs

Since 6.3 IO protocol version.

Syntax
struct _PRL_IO_DISPLAY_ENCODING_LIST {
  PRL_UINT32 encodingListSz;
  PRL_UINT32 defaultEncodingIdx;
  PRL_IO_DISPLAY_ENCODING encodingList[PRL_IO_MAX_ENCODINGS];
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_GAMMA Structure

_PRL_IO_DISPLAY_GAMMA Structure
PRL_IO Structs
Syntax
struct _PRL_IO_DISPLAY_GAMMA {
  PRL_UINT32 display;
  PRL_UINT32 type;
  PRL_UINT32 gammaSize;
  PRL_UINT32 reserved;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_PALETTE Structure

_PRL_IO_DISPLAY_PALETTE Structure
Other Structs
Syntax
struct _PRL_IO_DISPLAY_PALETTE {
  PRL_IO_PALETTE palette;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION Structure

_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION Structure
PRL_IO Structs
Syntax
struct _PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION {
  PRL_BOOL success;
  PRL_UINT32 flags;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX Structure

_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX Structure
PRL_IO Structs
Syntax
struct _PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX {
  PRL_BOOL success;
  PRL_UINT32 flags;
  PRL_UINT64 timestamp;
  PRL_UINT8 reserved[64];
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DISPLAY_SCREEN_REGION Structure

_PRL_IO_DISPLAY_SCREEN_REGION Structure
Other Structs
Syntax
struct _PRL_IO_DISPLAY_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_DISPLAY_SCREEN_SIZE Structure

_PRL_IO_DISPLAY_SCREEN_SIZE Structure
Other Structs
Syntax
struct _PRL_IO_DISPLAY_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
  PRL_UINT32 display;
  PRL_INT32 displayX;
  PRL_INT32 displayY;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_DPI_DISPLAY_SCREEN_SIZE Structure

_PRL_IO_DPI_DISPLAY_SCREEN_SIZE Structure
PRL_IO Structs
Syntax
struct _PRL_IO_DPI_DISPLAY_SCREEN_SIZE {
  PRL_IO_DISPLAY_SCREEN_SIZE display;
  PRL_INT32 dpi;
  PRL_UINT32 flags;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_DYNRES_TOOLS_STATUS Structure

_PRL_IO_DYNRES_TOOLS_STATUS Structure
Other Structs
Syntax
struct _PRL_IO_DYNRES_TOOLS_STATUS {
  PRL_UINT32 status;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_ENCODING_REQUEST Structure

_PRL_IO_ENCODING_REQUEST Structure
Other Structs

This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.

Syntax
struct _PRL_IO_ENCODING_REQUEST {
  PRL_UINT32 encodingType;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_ENCODING_RESPONSE Structure

_PRL_IO_ENCODING_RESPONSE Structure
Other Structs

This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.

Syntax
struct _PRL_IO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
  PRL_UINT32 requestedEncodingType;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_GENERIC_BUFFER Structure

_PRL_IO_GENERIC_BUFFER Structure
Other Structs
Syntax
struct _PRL_IO_GENERIC_BUFFER {
  PRL_UINT32 size;
  PRL_VOID_PTR data;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_GRACEFUL_SHUTDOWN Structure

_PRL_IO_GRACEFUL_SHUTDOWN Structure
Other Structs
Syntax
struct _PRL_IO_GRACEFUL_SHUTDOWN {
  PRL_UINT32 kind;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE Structure

_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE Structure
PRL_IO Structs
Syntax
struct _PRL_IO_GUEST_NOTIFY_COHERENCE_STATE {
  PRL_UINT32 bCoherenceDisabled;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_KEYBOARD_LEDS Structure

_PRL_IO_KEYBOARD_LEDS Structure
Other Structs
Syntax
struct _PRL_IO_KEYBOARD_LEDS {
  PRL_UINT32 ledsState;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_KEYBOARD_SCANCODE Structure

_PRL_IO_KEYBOARD_SCANCODE Structure
Other Structs
Syntax
struct _PRL_IO_KEYBOARD_SCANCODE {
  PRL_UINT16 key;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_LANGUAGE_HOTKEYS Structure

_PRL_IO_LANGUAGE_HOTKEYS Structure
Other Structs
Syntax
struct _PRL_IO_LANGUAGE_HOTKEYS {
  PRL_UINT32 LanguageHotkey;
  PRL_UINT32 LayoutHotkey;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_MEMORY_INFO Structure

_PRL_IO_MEMORY_INFO Structure
Other Structs
Syntax
struct _PRL_IO_MEMORY_INFO {
  PRL_UINT64 ramOffset;
  PRL_UINT64 ramSize;
  PRL_UINT64 vramOffset;
  PRL_UINT64 vramSize;
  PRL_UINT32 filenameSize;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_MOUSE_CURSOR Structure

_PRL_IO_MOUSE_CURSOR Structure
Other Structs
Syntax
struct _PRL_IO_MOUSE_CURSOR {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 hotSpotX;
  PRL_UINT32 hotSpotY;
  PRL_UINT32 width;
  PRL_UINT32 height;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_MOUSE_EVENT Structure

_PRL_IO_MOUSE_EVENT Structure
Other Structs
Syntax
struct _PRL_IO_MOUSE_EVENT {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_MOUSE_EVENT_EX Structure

_PRL_IO_MOUSE_EVENT_EX Structure
PRL_IO Structs
Syntax
struct _PRL_IO_MOUSE_EVENT_EX {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
  PRL_INT32 w;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_MOUSE_EVENT_EX2 Structure

_PRL_IO_MOUSE_EVENT_EX2 Structure
PRL_IO Structs
Syntax
struct _PRL_IO_MOUSE_EVENT_EX2 {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
  PRL_INT32 w;
  PRL_INT32 z120;
  PRL_INT32 w120;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_SCREEN_BUFFER_REGION Structure

_PRL_IO_SCREEN_BUFFER_REGION Structure
Other Structs
Syntax
struct _PRL_IO_SCREEN_BUFFER_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 scaleWidth;
  PRL_UINT32 scaleHeight;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SCREEN_REGION Structure

_PRL_IO_SCREEN_REGION Structure
Other Structs
Syntax
struct _PRL_IO_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SCREEN_SIZE Structure

_PRL_IO_SCREEN_SIZE Structure
Other Structs
Syntax
struct _PRL_IO_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SCREEN_SURFACE Structure

_PRL_IO_SCREEN_SURFACE Structure
Other Structs
Syntax
struct _PRL_IO_SCREEN_SURFACE {
  PRL_UINT32 windowId;
  PRL_UINT32 surfaceId;
  PRL_INT32 scrollX;
  PRL_INT32 scrollY;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SCREEN_UPDATE Structure

_PRL_IO_SCREEN_UPDATE Structure
Other Structs
Syntax
struct _PRL_IO_SCREEN_UPDATE {
  PRL_UINT32 offset;
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SET_TASKBAR_VISIBILITY Structure

_PRL_IO_SET_TASKBAR_VISIBILITY Structure
Other Structs
Syntax
struct _PRL_IO_SET_TASKBAR_VISIBILITY {
  PRL_UINT32 visibility;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SHUTDOWN_RESULT Structure

_PRL_IO_SHUTDOWN_RESULT Structure
Other Structs
Syntax
struct _PRL_IO_SHUTDOWN_RESULT {
  PRL_UINT32 uRefused;
  PRL_UINT32 uResult;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SLIDING_MOUSE Structure

_PRL_IO_SLIDING_MOUSE Structure
Other Structs
Syntax
struct _PRL_IO_SLIDING_MOUSE {
  PRL_UINT32 state;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_SSO_CLIENT_VM_PACKET Structure

_PRL_IO_SSO_CLIENT_VM_PACKET Structure
Other Structs
Syntax
struct _PRL_IO_SSO_CLIENT_VM_PACKET {
  PRL_UINT8 credentialsRequestUUID[16];
  PRL_UINT32 reserved[12];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_STATE Enumeration

_PRL_IO_STATE Enumeration
Other Structs
Syntax
enum _PRL_IO_STATE {
  IOS_DISABLED = 0,
  IOS_STARTED = 1,
  IOS_STOPPED = 2,
  IOS_UNKNOWN_VM_UUID = 3,
  IOS_CONNECTION_TIMEOUT = 4,
  IOS_AUTH_FAILED = 5
};
File

PrlEnums.h

Members

IOS_DISABLED
< Desktop has not been enabled
IOS_STARTED
< Successfully started.(local and remote)
IOS_STOPPED
< Is stopped.
IOS_UNKNOWN_VM_UUID
< Unknown uuid.
IOS_CONNECTION_TIMEOUT
< Connection timeout.
IOS_AUTH_FAILED
< Authentication failed.

Links
Other Structs


PRL_IO Structs Enumerations

PRL_IO Structs Enumerations
PRL_IO Structs Legend
Enumerations
Name | Description
_PRL_IO_DISCONNECT_REASON | Specifies the reason of closing IO connection
PRL_IO_CLIENT_FLAGS | Flags which determines peer client while login to dispatcher and while attach to vm.
PRL_IO_STATE |
PRL_IOLIMIT_TYPE |


Legend

Legend
PRL_IO Structs
Legend
Structure
Enumeration


PRL_IO Structs Structures

PRL_IO Structs Structures
PRL_IO Structs Legend
Structures
Name
Description
_PRL_IO_CHANNEL_STAT
_PRL_IO_DISPLAY_ENCODING
Since 6.3 IO protocol version.
_PRL_IO_DISPLAY_ENCODING_LIST
Since 6.3 IO protocol version.
_PRL_IO_DISPLAY_GAMMA
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
_PRL_IO_DPI_DISPLAY_SCREEN_SIZE
_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
_PRL_IO_MOUSE_EVENT_EX
_PRL_IO_MOUSE_EVENT_EX2
_PRL_IO_TOOLS_DISPLAY_INDENT
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUDIO_DATA
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING_LIST
Audio support since 6.6 IO protocol version.
PRL_IO_AUDIO_ENCODING_RESPONSE
Audio support since 6.6 IO protocol version.
PRL_IO_AUTH_EXEC_REQUEST
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_AVAILABLE_DISPLAYS
PRL_IO_CHANNEL_STAT
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_ENCODING
Since 6.3 IO protocol version.
PRL_IO_DISPLAY_ENCODING_LIST
Since 6.3 IO protocol version.
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DPI_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
PRL_IO_ENCODING_RESPONSE
This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_LANGUAGE_HOTKEYS
PRL_IO_MEMORY_INFO
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_MOUSE_EVENT_EX
PRL_IO_MOUSE_EVENT_EX2
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SHUTDOWN_RESULT
PRL_IO_SLIDING_MOUSE
PRL_IO_SSO_CLIENT_VM_PACKET
PRL_IO_TOOLS_ADJUST_WORKING_AREA
PRL_IO_TOOLS_DISPLAY_INDENT
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data
  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command
  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
PRL_IOLIMIT_DATA


_PRL_IO_TOOLS_ADJUST_WORKING_AREA Structure

_PRL_IO_TOOLS_ADJUST_WORKING_AREA Structure
Other Structs
Syntax
struct _PRL_IO_TOOLS_ADJUST_WORKING_AREA {
  PRL_UINT32 bIsOn;
  PRL_UINT32 uDockEdge;
  PRL_INT32 iDockLeft;
  PRL_INT32 iDockTop;
  PRL_INT32 iDockRight;
  PRL_INT32 iDockBottom;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_TOOLS_DISPLAY_INDENT Structure

_PRL_IO_TOOLS_DISPLAY_INDENT Structure
PRL_IO Structs
Syntax
struct _PRL_IO_TOOLS_DISPLAY_INDENT {
  PRL_INT32 displayX;
  PRL_INT32 displayY;
  PRL_UINT32 leftIndentSize;
  PRL_UINT32 topIndentSize;
  PRL_UINT32 rightIndentSize;
  PRL_UINT32 bottomIndentSize;
};
File

PrlIoStructs.h

Links
PRL_IO Structs


_PRL_IO_TOOLS_MOVE_TASKBAR Structure

_PRL_IO_TOOLS_MOVE_TASKBAR Structure
Other Structs
Syntax
struct _PRL_IO_TOOLS_MOVE_TASKBAR {
  PRL_BOOL bCoherenceOn;
  PRL_BOOL bRelocateTaskBar;
  PRL_UINT32 uDockEdge;
  PRL_UINT32 uEdgeMask;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_TOOLS_SIA_DATA Structure

_PRL_IO_TOOLS_SIA_DATA Structure
Other Structs

@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
Syntax
struct _PRL_IO_TOOLS_SIA_DATA {
  PRL_UINT32 ver;
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 size;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IO_TOOLS_UTILITY_COMMAND Structure

_PRL_IO_TOOLS_UTILITY_COMMAND Structure
Other Structs

@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
Syntax
struct _PRL_IO_TOOLS_UTILITY_COMMAND {
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 dataSize;
};
File

PrlIoStructs.h

Links
Other Structs


PRL_IO Types Types

PRL_IO Types Types
PRL_IO Types
Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUDIO_DATA_PTR |
PRL_IO_AUDIO_ENCODING_LIST_PTR |
PRL_IO_AUDIO_ENCODING_PTR |
PRL_IO_AUDIO_ENCODING_RESPONSE_PTR |
PRL_IO_AUTH_EXEC_REQUEST_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_AVAILABLE_DISPLAYS_PTR |
PRL_IO_CHANNEL_STAT_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISCONNECT_REASON_PTR |
PRL_IO_DISPLAY_ENCODING_LIST_PTR |
PRL_IO_DISPLAY_ENCODING_PTR |
PRL_IO_DISPLAY_GAMMA_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_LANGUAGE_HOTKEYS_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_EX_PTR |
PRL_IO_MOUSE_EVENT_EX2_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SHUTDOWN_RESULT_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_SSO_CLIENT_VM_PACKET_PTR |
PRL_IO_STATE_PTR |
PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR |
PRL_IO_TOOLS_DISPLAY_INDENT_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |
PRL_IOLIMIT_DATA_PTR |


_PRL_IOLIMIT_DATA Structure

_PRL_IOLIMIT_DATA Structure
Other Structs
Syntax
struct _PRL_IOLIMIT_DATA {
  PRL_UINT32 value;
  PRL_IOLIMIT_TYPE type;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_IOLIMIT_TYPE Enumeration

_PRL_IOLIMIT_TYPE Enumeration
Other Structs
Syntax
enum _PRL_IOLIMIT_TYPE {
  PRL_IOLIMIT_BS = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_IOPRIO Enumeration

_PRL_IOPRIO Enumeration
Other Structs
Syntax
enum _PRL_IOPRIO {
  PRL_IOPRIO_MIN = 0,
  PRL_IOPRIO_DEFAULT = 4,
  PRL_IOPRIO_MAX = 7
};
File

PrlEnums.h

Links
Other Structs


_PRL_ISCSI_STORAGE_CMD_FLAGS Enumeration

_PRL_ISCSI_STORAGE_CMD_FLAGS Enumeration
Other Structs

iSCSI storage management flags

Syntax
enum _PRL_ISCSI_STORAGE_CMD_FLAGS {
  PISCSI_STORAGE_CREATE = 1<<(PACF_MAX+1),
  PISCSI_STORAGE_REMOVE = 1<<(PACF_MAX+2),
  PISCSI_STORAGE_MOUNT_RDONLY = 1<<(PACF_MAX+3),
  PISCSI_STORAGE_REMOUNT = 1<<(PACF_MAX+4),
  PISCSI_STORAGE_MOUNT = 1<<(PACF_MAX+5)
};
File

PrlCommandsFlags.h

Members

PISCSI_STORAGE_CREATE
To create storage on register
PISCSI_STORAGE_REMOVE
To remove storage on unregister
PISCSI_STORAGE_MOUNT_RDONLY
To mount storage by read-only
PISCSI_STORAGE_REMOUNT
To remount storage
PISCSI_STORAGE_MOUNT
To mount storage on register

Links
Other Structs


_PRL_ISCSI_STORAGE_FSTYPE_FLAGS Enumeration

_PRL_ISCSI_STORAGE_FSTYPE_FLAGS Enumeration
Other Structs

iSCSI storage filesystem type

Syntax
enum _PRL_ISCSI_STORAGE_FSTYPE_FLAGS {
  PISCSI_STORAGE_EXT3 = 1<<(PACF_MAX+1),
  PISCSI_STORAGE_EXT4 = 1<<(PACF_MAX+2),
  PISCSI_STORAGE_NTFS = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_JOB_OPERATION_CODE Enumeration

_PRL_JOB_OPERATION_CODE Enumeration
Other Structs

Job operation codes

Syntax
enum _PRL_JOB_OPERATION_CODE {
  PJOC_UNKNOWN = 0,
  PJOC_JOB_CANCEL = 1,
  PJOC_SRV_LOOKUP_PARALLELS_SERVERS = 2,
  PJOC_SRV_LOGIN = 3,
  PJOC_SRV_LOGIN_LOCAL = 4,
  PJOC_SRV_LOGOFF = 5,
  PJOC_SRV_GET_SRV_CONFIG = 6,
  PJOC_SRV_GET_COMMON_PREFS = 7,
  PJOC_SRV_COMMON_PREFS_BEGIN_EDIT = 8,
  PJOC_SRV_COMMON_PREFS_COMMIT = 9,
  PJOC_SRV_GET_USER_PROFILE = 10,
  PJOC_SRV_GET_STATISTICS = 11,
  PJOC_SRV_USER_PROFILE_BEGIN_EDIT = 12,
  PJOC_SRV_USER_PROFILE_COMMIT = 13,
  PJOC_SRV_REGISTER_VM = 14,
  PJOC_SRV_REGISTER_VM_EX = PJOC_SRV_REGISTER_VM,
  PJOC_SRV_GET_VM_LIST = 15,
  PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS = 16,
  PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS = 17,
  PJOC_SRV_SHUTDOWN = 18,
  PJOC_SRV_FS_GET_DISK_LIST = 19,
  PJOC_SRV_FS_GET_DIR_ENTRIES = 20,
  PJOC_SRV_FS_CREATE_DIR = 21,
  PJOC_SRV_FS_REMOVE_ENTRY = 22,
  PJOC_SRV_FS_CAN_CREATE_FILE = 23,
  PJOC_SRV_FS_RENAME_ENTRY = 24,
  PJOC_SRV_FS_GENERATE_ENTRY_NAME = 25,
  PJOC_SRV_UPDATE_LICENSE = 26,
  PJOC_SRV_GET_LICENSE_INFO = 27,
  PJOC_SRV_SEND_ANSWER = 28,
  PJOC_SRV_START_SEARCH_VMS = 29,
  PJOC_SRV_NET_SERVICE_START = 30,
  PJOC_SRV_NET_SERVICE_STOP = 31,
  PJOC_SRV_NET_SERVICE_RESTART = 32,
  PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS = 33,
  PJOC_SRV_GET_NET_SERVICE_STATUS = 34,
  PJOC_SRV_ADD_NET_ADAPTER = 35,
  PJOC_SRV_DELETE_NET_ADAPTER = 36,
  PJOC_SRV_UPDATE_NET_ADAPTER = 37,
  PJOC_SRV_GET_PROBLEM_REPORT = 38,
  PJOC_SRV_ATTACH_TO_LOST_TASK = 39,
  PJOC_SRV_GET_USER_INFO_LIST = 40,
  PJOC_SRV_GET_USER_INFO = 41,
  PJOC_VM_START = 42,
  PJOC_VM_STOP = 43,
  PJOC_VM_PAUSE = 44,
  PJOC_VM_RESET = 45,
  PJOC_VM_SUSPEND = 46,
  PJOC_VM_RESUME = PJOC_VM_START,
  PJOC_VM_DROP_SUSPENDED_STATE = 49,
  PJOC_VM_CLONE = 50,
  PJOC_VM_DELETE = 51,
  PJOC_VM_GET_PROBLEM_REPORT = 52,
  PJOC_VM_GET_STATE = 53,
  PJOC_VM_GENERATE_VM_DEV_FILENAME = 54,
  PJOC_VM_GET_TOOLS_STATE = 55,
  PJOC_VM_REFRESH_CONFIG = 56,
  PJOC_VM_GET_STATISTICS = 57,
  PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS = 58,
  PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS = 59,
  PJOC_VM_REG = 60,
  PJOC_VM_UNREG = 61,
  PJOC_VM_BEGIN_EDIT = 62,
  PJOC_VM_COMMIT = 63,
  PJOC_VM_CREATE_UNATTENDED_FLOPPY = 64,
  PJOC_VM_CREATE_UNATTENDED_DISK = PJOC_VM_CREATE_UNATTENDED_FLOPPY,
  PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS = 65,
  PJOC_VM_UPDATE_SECURITY = 66,
  PJOC_VM_VALIDATE_CONFIG = 67,
  PJOC_VM_DEV_CONNECT = 68,
  PJOC_VM_DEV_DISCONNECT = 69,
  PJOC_VM_DEV_CREATE_IMAGE = 70,
  PJOC_VM_INSTALL_TOOLS = 71,
  PJOC_VM_SEND_SHUTDOWN_COMMAND = 72,
  PJOC_VM_SEND_CLIPBOARD_REQUEST = 73,
  PJOC_VM_CONNECT_TO_VM = 74,
  PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN = 75,
  PJOC_VM_MIGRATE = 76,
  PJOC_VM_SEND_DRAGDROP_COMMAND = 77,
  PJOC_VM_GUEST_RUN_PROGRAM = 78,
  PJOC_VM_GUEST_LOGOUT = 79,
  PJOC_SRV_SUBSCRIBE_PERFSTATS = 80,
  PJOC_SRV_UNSUBSCRIBE_PERFSTATS = 81,
  PJOC_SRV_GET_PERFSTATS = 82,
  PJOC_VM_SUBSCRIBE_PERFSTATS = 83,
  PJOC_VM_UNSUBSCRIBE_PERFSTATS = 84,
  PJOC_VM_GET_PERFSTATS = 85,
  PJOC_VM_GET_SUSPENDED_SCREEN = 86,
  PJOC_VM_MIGRATE_CANCEL = 87,
  PJOC_VM_RUN_COMPRESSOR = 88,
  PJOC_VM_CANCEL_COMPRESSOR = 89,
  PJOC_VM_CREATE_SNAPSHOT = 90,
  PJOC_VM_SWITCH_TO_SNAPSHOT = 91,
  PJOC_VM_DELETE_SNAPSHOT = 92,
  PJOC_VM_GET_SNAPSHOTS_TREE = 93,
  PJOC_VM_START_EX = 94,
  PJOC_VM_LOGIN_IN_GUEST = 95,
  PJOC_VM_UPDATE_SNAPSHOT_DATA = 96,
  PJOC_VM_RESTART = 97,
  PJOC_VM_INSTALL_UTILITY = 98,
  PJOC_VM_UPDATE_TOOLS_SECTION = 99,
  PJOC_SRV_GET_ALL_HOST_USERS = 100,
  PJOC_VM_RESTORE = 101,
  PJOC_VM_START_VNC_SERVER = 102,
  PJOC_VM_STOP_VNC_SERVER = 103,
  PJOC_VM_GUEST_GET_NETWORK_SETTINGS = 104,
  PJOC_SRV_GET_VIRTUAL_NETWORK_LIST = 105,
  PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB = 106,
  PJOC_VM_GUEST_SET_USER_PASSWD = 107,
  PJOC_SRV_ADD_VIRTUAL_NETWORK = 108,
  PJOC_SRV_UPDATE_VIRTUAL_NETWORK = 109,
  PJOC_SRV_DELETE_VIRTUAL_NETWORK = 110,
  PJOC_SRV_CONFIGURE_GENERIC_PCI = 111,
  PJOC_SRV_PREPARE_FOR_HIBERNATE = 112,
  PJOC_SRV_AFTER_HOST_RESUME = 113,
  PJOC_SRV_GET_BACKUP_TREE = 114,
  PJOC_SRV_CREATE_VM_BACKUP = 115,
  PJOC_SRV_RESTORE_VM_BACKUP = 116,
  PJOC_API_SEND_PROBLEM_REPORT = 117,
  PJOC_VM_LOCK = 118,
  PJOC_VM_UNLOCK = 119,
  PJOC_SRV_SET_NON_INTERACTIVE_SESSION = 120,
  PJOC_SRV_CREATE_UNATTENDED_CD = 121,
  PJOC_SRV_REMOVE_VM_BACKUP = 122,
  PJOC_VM_RESIZE_DISK_IMAGE = 123,
  PJOC_SRV_SET_SESSION_CONFIRMATION_MODE = 124,
  PJOC_SRV_STORE_VALUE_BY_KEY = 125,
  PJOC_VM_STORE_VALUE_BY_KEY = 126,
  PJOC_VM_COMPACT = 127,
  PJOC_VM_CANCEL_COMPACT = 128,
  PJOC_SRV_SEND_CLIENT_STATISTICS = 129,
  PJOC_VM_GET_PACKED_PROBLEM_REPORT = 130,
  PJOC_SRV_GET_PACKED_PROBLEM_REPORT = 131,
  PJOC_API_SEND_PACKED_PROBLEM_REPORT = 132,
  PJOC_SRV_UPDATE_USB_ASSOC_LIST = 133,
  PJOC_SRV_REGISTER_3RD_PARTY_VM = 134,
  PJOC_VM_CHANGE_SID = 135,
  PJOC_VM_RESET_UPTIME = 136,
  PJOC_REPORT_ASSEMBLY = 137,
  PJOC_SRV_INSTALL_APPLIANCE = 138,
  PJOC_SRV_UPDATE_OFFLINE_SERVICE = 139,
  PJOC_SRV_DELETE_OFFLINE_SERVICE = 140,
  PJOC_SRV_GET_OFFLINE_SERVICES_LIST = 141,
  PJOC_SRV_START_CLUSTER_SERVICE = 142,
  PJOC_SRV_STOP_CLUSTER_SERVICE = 143,
  PJOC_VM_CMD_INTERNAL = 144,
  PJOC_VM_GET_VIRTUAL_DEVICES_INFO = 145,
  PJOC_VM_CONVERT_DISKS = 146,
  PJOC_VM_DEV_HD_CHECK_PASSWORD = 147,
  PJOC_VM_AUTHORISE = 148,
  PJOC_VM_CHANGE_PASSWORD = 149,
  PJOC_VM_ENCRYPT = 150,
  PJOC_VM_DECRYPT = 151,
  PJOC_SRV_UPDATE_NETWORK_CLASSES_CONFIG = 152,
  PJOC_SRV_GET_NETWORK_CLASSES_LIST = 153,
  PJOC_SRV_UPDATE_NETWORK_SHAPING_CONFIG = 154,
  PJOC_SRV_GET_NETWORK_SHAPING_CONFIG = 155,
  PJOC_SRV_RESTART_NETWORK_SHAPING = 156,
  PJOC_SRV_PROXY_GET_REGISTERED_HOSTS = 157,
  PJOC_SRV_REGISTER_ISCSI_STORAGE = 158,
  PJOC_SRV_UNREGISTER_ISCSI_STORAGE = 159,
  PJOC_SRV_EXTEND_ISCSI_STORAGE = 160,
  PJOC_SRV_GET_CT_TEMPLATE_LIST = 161,
  PJOC_SRV_CHECK_ALIVE = 162,
  PJOC_SRV_GET_DEFAULT_VM_CONFIG = 163,
  PJOC_SRV_REMOVE_CT_TEMPLATE = 164,
  PJOC_SRV_COPY_CT_TEMPLATE = 165,
  PJOC_SRV_ADD_IPPRIVATE_NETWORK = 166,
  PJOC_SRV_REMOVE_IPPRIVATE_NETWORK = 167,
  PJOC_SRV_UPDATE_IPPRIVATE_NETWORK = 168,
  PJOC_SRV_GET_IPPRIVATE_NETWORKS_LIST = 169,
  PJOC_VM_DEV_COPY_IMAGE = 170,
  PJOC_SRV_REFRESH_PLUGINS = 171,
  PJOC_VM_MOUNT = 172,
  PJOC_VM_UMOUNT = 173,
  PJOC_SRV_GET_PLUGINS_LIST = 174,
  PJOC_SRV_GET_DISK_FREE_SPACE = 175,
  PJOC_DESKTOP_CONTROL_CONNECT = 176,
  PJOC_VM_MOVE = 177,
  PJOC_SRV_GENERATE_CSR = 178,
  PJOC_SRV_SIGN_CERTIFICATION_REQUEST = 179,
  PJOC_SRV_GET_VM_CONFIG = 180,
  PJOC_PTM_RPC = 181,
  PJOC_API_PUT_USER_DATA = 182,
  PJOC_API_GET_USER_DATA = 183,
  PJOC_API_GET_USER_KEYS = 184,
  PJOC_API_REMOVE_USER_DATA = 185,
  PJOC_API_PUT_ICON = 186,
  PJOC_API_VALIDATE_IN_CACHE = 187,
  PJOC_SRV_UPDATE_SESSION_INFO = 188,
  PJOC_API_SUBSCRIBE_ON_REGISTRATION = 189,
  PJOC_SRV_SEND_PROBLEM_REPORT = 190,
  PJOC_VM_SEND_PROBLEM_REPORT = 191,
  PJOC_VM_SET_PROTECTION = 192,
  PJOC_VM_REMOVE_PROTECTION = 193
};
File

PrlEnums.h

Links
Other Structs


_PRL_JOB_STATUS Enumeration

_PRL_JOB_STATUS Enumeration
Other Structs

Job status enumeration

Syntax
enum _PRL_JOB_STATUS {
  PJS_UNKNOWN = 0,
  PJS_RUNNING = 0xD0000001,
  PJS_FINISHED = 0xD0000002
};
File

PrlEnums.h

Links
Other Structs


_PRL_KEY Enumeration

_PRL_KEY Enumeration
Other Structs

Parallels virtual keycodes.

Syntax
enum _PRL_KEY {
  PRL_KEY_INVALID = 0,
  PRL_KEY_WILDCARD_ANY = 1,
  PRL_KEY_WILDCARD_KEYBOARD = 2,
  PRL_KEY_WILDCARD_MOUSE = 3,
  PRL_KEY_WILDCARD_SHIFT = 4,
  PRL_KEY_WILDCARD_CTRL = 5,
  PRL_KEY_WILDCARD_ALT = 6,
  PRL_KEY_WILDCARD_WIN = 7,
  PRL_KEY_ESCAPE = 9,
  PRL_KEY_1 = 10,
  PRL_KEY_2 = 11,
  PRL_KEY_3 = 12,
  PRL_KEY_4 = 13,
  PRL_KEY_5 = 14,
  PRL_KEY_6 = 15,
  PRL_KEY_7 = 16,
  PRL_KEY_8 = 17,
  PRL_KEY_9 = 18,
  PRL_KEY_0 = 19,
  PRL_KEY_MINUS = 20,
  PRL_KEY_EQUAL = 21,
  PRL_KEY_BACKSPACE = 22,
  PRL_KEY_TAB = 23,
  PRL_KEY_Q = 24,
  PRL_KEY_W = 25,
  PRL_KEY_E = 26,
  PRL_KEY_R = 27,
  PRL_KEY_T = 28,
  PRL_KEY_Y = 29,
  PRL_KEY_U = 30,
  PRL_KEY_I = 31,
  PRL_KEY_O = 32,
  PRL_KEY_P = 33,
  PRL_KEY_LEFT_BRACKET = 34,
  PRL_KEY_RIGHT_BRACKET = 35,
  PRL_KEY_ENTER = 36,
  PRL_KEY_LEFT_CONTROL = 37,
  PRL_KEY_A = 38,
  PRL_KEY_S = 39,
  PRL_KEY_D = 40,
  PRL_KEY_F = 41,
  PRL_KEY_G = 42,
  PRL_KEY_H = 43,
  PRL_KEY_J = 44,
  PRL_KEY_K = 45,
  PRL_KEY_L = 46,
  PRL_KEY_SEMICOLON = 47,
  PRL_KEY_QUOTE = 48,
  PRL_KEY_TILDA = 49,
  PRL_KEY_LEFT_SHIFT = 50,
  PRL_KEY_BACKSLASH = 51,
  PRL_KEY_Z = 52,
  PRL_KEY_X = 53,
  PRL_KEY_C = 54,
  PRL_KEY_V = 55,
  PRL_KEY_B = 56,
  PRL_KEY_N = 57,
  PRL_KEY_M = 58,
  PRL_KEY_COMMA = 59,
  PRL_KEY_DOT = 60,
  PRL_KEY_SLASH = 61,
  PRL_KEY_RIGHT_SHIFT = 62,
  PRL_KEY_NP_STAR = 63,
  PRL_KEY_LEFT_ALT = 64,
  PRL_KEY_SPACE = 65,
  PRL_KEY_CAPS_LOCK = 66,
  PRL_KEY_F1 = 67,
  PRL_KEY_F2 = 68,
  PRL_KEY_F3 = 69,
  PRL_KEY_F4 = 70,
  PRL_KEY_F5 = 71,
  PRL_KEY_F6 = 72,
  PRL_KEY_F7 = 73,
  PRL_KEY_F8 = 74,
  PRL_KEY_F9 = 75,
  PRL_KEY_F10 = 76,
  PRL_KEY_NUM_LOCK = 77,
  PRL_KEY_SCROLL_LOCK = 78,
  PRL_KEY_NP_7 = 79,
  PRL_KEY_NP_8 = 80,
  PRL_KEY_NP_9 = 81,
  PRL_KEY_NP_MINUS = 82,
  PRL_KEY_NP_4 = 83,
  PRL_KEY_NP_5 = 84,
  PRL_KEY_NP_6 = 85,
  PRL_KEY_NP_PLUS = 86,
  PRL_KEY_NP_1 = 87,
  PRL_KEY_NP_2 = 88,
  PRL_KEY_NP_3 = 89,
  PRL_KEY_NP_0 = 90,
  PRL_KEY_NP_DELETE = 91,
  PRL_KEY_PRINT = 92,
  PRL_KEY_EUROPE_1 = 93,
  PRL_KEY_EUROPE_2 = 94,
  PRL_KEY_F11 = 95,
  PRL_KEY_F12 = 96,
  PRL_KEY_HOME = 97,
  PRL_KEY_UP = 98,
  PRL_KEY_PAGE_UP = 99,
  PRL_KEY_LEFT = 100,
  PRL_KEY_RIGHT = 102,
  PRL_KEY_END = 103,
  PRL_KEY_DOWN = 104,
  PRL_KEY_PAGE_DOWN = 105,
  PRL_KEY_INSERT = 106,
  PRL_KEY_DELETE = 107,
  PRL_KEY_NP_ENTER = 108,
  PRL_KEY_RIGHT_CONTROL = 109,
  PRL_KEY_PAUSE = 110,
  PRL_KEY_NP_SLASH = 112,
  PRL_KEY_RIGHT_ALT = 113,
  PRL_KEY_LEFT_WIN = 115,
  PRL_KEY_RIGHT_WIN = 116,
  PRL_KEY_MENU = 117,
  PRL_KEY_MEDIA_NEXT_TRACK = 118,
  PRL_KEY_MEDIA_PREV_TRACK = 119,
  PRL_KEY_MEDIA_STOP = 120,
  PRL_KEY_MEDIA_PLAY_PAUSE = 121,
  PRL_KEY_MUTE = 122,
  PRL_KEY_VOLUME_UP = 123,
  PRL_KEY_VOLUME_DOWN = 124,
  PRL_KEY_MEDIA_SELECT = 125,
  PRL_KEY_APP_MAIL = 126,
  PRL_KEY_APP_CALCULATOR = 127,
  PRL_KEY_APP_MY_COMPUTER = 128,
  PRL_KEY_WWW_SEARCH = 129,
  PRL_KEY_WWW_HOME = 130,
  PRL_KEY_WWW_BACK = 131,
  PRL_KEY_WWW_FORWARD = 132,
  PRL_KEY_WWW_STOP = 133,
  PRL_KEY_WWW_REFRESH = 134,
  PRL_KEY_WWW_FAVORITES = 135,
  PRL_KEY_EJECT = 136,
  PRL_KEY_SYSTEM_POWER = 137,
  PRL_KEY_SYSTEM_SLEEP = 138,
  PRL_KEY_SYSTEM_WAKE = 139,
  PRL_KEY_BRAZILIAN_KEYPAD = 140,
  PRL_KEY_RO = 141,
  PRL_KEY_HIRAGANA_KATAKANA = 142,
  PRL_KEY_YEN = 143,
  PRL_KEY_HENKAN = 144,
  PRL_KEY_MUHENKAN = 145,
  PRL_KEY_PC9800_KEYPAD = 146,
  PRL_KEY_HANGUEL = 147,
  PRL_KEY_HANJA = 148,
  PRL_KEY_KATAKANA = 149,
  PRL_KEY_HIRAGANA = 150,
  PRL_KEY_ZENKAKU_HANKAKU = 151,
  PRL_KEY_F13 = 152,
  PRL_KEY_F14 = 153,
  PRL_KEY_F15 = 154,
  PRL_KEY_F16 = 155,
  PRL_KEY_F17 = 156,
  PRL_KEY_F18 = 157,
  PRL_KEY_F19 = 158,
  PRL_KEY_F20 = 159,
  PRL_KEY_F21 = 160,
  PRL_KEY_F22 = 161,
  PRL_KEY_F23 = 162,
  PRL_KEY_F24 = 163,
  PRL_KEY_NP_EQUAL = 164,
  PRL_KEY_BREAK = 165,
  PRL_KEY_PRINT_WITH_MODIFIER = 166,
  PRL_KEY_SYSRQ = 167,
  PRL_KEY_FN = 168,
  PRL_KEY_EURO = 169,
  PRL_KEY_DOLLAR = 170,
  PRL_KEY_MON_BRIGHTNESS_DOWN = 171,
  PRL_KEY_MON_BRIGHTNESS_UP = 172,
  PRL_KEY_APP_EXPOSE = 173,
  PRL_KEY_APP_DASHBOARD = 174,
  PRL_KEY_KBD_BRIGHTNESS_DOWN = 175,
  PRL_KEY_KBD_BRIGHTNESS_UP = 176,
  PRL_KEY_MAC129 = 177,
  PRL_KEY_LEFT_BUTTON = 178,
  PRL_KEY_MIDDLE_BUTTON = 179,
  PRL_KEY_RIGHT_BUTTON = 180,
  PRL_KEY_MOVE_UP_LEFT = 181,
  PRL_KEY_MOVE_UP = 182,
  PRL_KEY_MOVE_UP_RIGHT = 183,
  PRL_KEY_MOVE_LEFT = 184,
  PRL_KEY_MOVE_RIGHT = 185,
  PRL_KEY_MOVE_DOWN_LEFT = 186,
  PRL_KEY_MOVE_DOWN = 187,
  PRL_KEY_MOVE_DOWN_RIGHT = 188,
  PRL_KEY_WHEEL_UP = 189,
  PRL_KEY_WHEEL_DOWN = 190,
  PRL_KEY_WHEEL_LEFT = 191,
  PRL_KEY_WHEEL_RIGHT = 192,
  PRL_KEY_MAX = 193
};
File

PrlKeys.h

Links
Other Structs


_PRL_KEY_EVENT Enumeration

_PRL_KEY_EVENT Enumeration
Other Structs
Syntax
enum _PRL_KEY_EVENT {
  PKE_PRESS = 0x0,
  PKE_RELEASE = 0x80
};
File

PrlEnums.h

Links
Other Structs


_PRL_LICENSE_RESTRICTION_KEY Enumeration

_PRL_LICENSE_RESTRICTION_KEY Enumeration
Other Structs

License restriction options

Syntax
enum _PRL_LICENSE_RESTRICTION_KEY {
  PLRK_UNKNOWN = 0,
  PLRK_VM_CPU_LIMIT = 1,
  PLRK_VM_MEMORY_LIMIT = 2,
  PLRK_VM_VTD_AVAILABLE = 3,
  PLRK_ALLOWED_GUEST_OS_VERSIONS = 4,
  PLRK_RUNNING_VMS_LIMIT = 5,
  PLRK_VM_CREATE = 6,
  PLRK_VM_REGISTER = 7,
  PLRK_VM_IMPORT_3RD_PARTY = 8,
  PLRK_VM_CLONE = 9,
  PLRK_VM_CONVERT_TO_TEMPLATE = 10,
  PLRK_VM_CONVERT_FROM_TEMPLATE = 11,
  PLRK_VM_DOWNLOAD = 12,
  PLRK_VM_SUSPEND = 13,
  PLRK_VM_PAUSE = 14,
  PLRK_VM_SNAPSHOT_CREATE = 15,
  PLRK_VM_SNAPSHOT_SWITCH = 16,
  PLRK_VM_SNAPSHOT_DELETE = 17,
  PLRK_VM_SNAPSHOT_TREE = 18,
  PLRK_VM_UNDODISK_FEATURE = 19,
  PLRK_VM_SAFEMODE_FEATURE = 20,
  PLRK_VM_SMARTGUARD_FEATURE = 21,
  PLRK_VM_SHOW_FULLSCREEN = 22,
  PLRK_RUNNING_VMS_LIMIT_PER_USER = 23
};
File

PrlEnums.h

Members

PLRK_UNKNOWN
NOTE to Parallels Developers:

  • DO NOT CHANGE ANY MEMBER NAME BECAUSE IT USES IN INTERNAL PROTOCOL( ParallelsDomModel.h )

PLRK_VM_CPU_LIMIT
Value is PRL_UINT32
PLRK_VM_MEMORY_LIMIT
Value is PRL_UINT32 in Mb
PLRK_VM_VTD_AVAILABLE
Value is PRL_UINT32
PLRK_ALLOWED_GUEST_OS_VERSIONS
Value is PHT_OPAQUE_TYPE_LIST of Os version values from PrlOses.h
PLRK_RUNNING_VMS_LIMIT
Value is PRL_UINT32 (max count on the host)
PLRK_VM_CREATE
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_REGISTER
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_IMPORT_3RD_PARTY
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_CLONE
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_CONVERT_TO_TEMPLATE
Value is PRL_UINT32
PLRK_VM_CONVERT_FROM_TEMPLATE
Value is PRL_UINT32
PLRK_VM_DOWNLOAD
Value is PRL_UINT32
PLRK_VM_SUSPEND
Value is PRL_UINT32
PLRK_VM_PAUSE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_CREATE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_SWITCH
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_DELETE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_TREE
Value is PRL_UINT32
PLRK_VM_UNDODISK_FEATURE
Value is PRL_UINT32
PLRK_VM_SAFEMODE_FEATURE
Value is PRL_UINT32
PLRK_VM_SMARTGUARD_FEATURE
Value is PRL_UINT32
PLRK_VM_SHOW_FULLSCREEN
Value is PRL_UINT32
PLRK_RUNNING_VMS_LIMIT_PER_USER
Value is PRL_UINT32 Look also at PLRK_RUNNING_VMS_LIMIT

Links
Other Structs


_PRL_LOGIN_LOCAL_FLAGS Enumeration

_PRL_LOGIN_LOCAL_FLAGS Enumeration
Other Structs

PrlSrv_LoginLocal flags

Syntax
enum _PRL_LOGIN_LOCAL_FLAGS {
  PLLF_LOGIN_WITH_DELAYED_CONNECTION = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration

_PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration
Other Structs

Mass storage device interface type

Syntax
enum _PRL_MASS_STORAGE_INTERFACE_TYPE {
  PMS_IDE_DEVICE = 0,
  PMS_SCSI_DEVICE = 1,
  PMS_SATA_DEVICE = 2,
  PMS_UNKNOWN_DEVICE = 255
};
File

PrlEnums.h

Links
Other Structs


_PRL_MESSAGE_TYPE_ENUM Enumeration

_PRL_MESSAGE_TYPE_ENUM Enumeration
Other Structs

Message type enumeration.

Syntax
enum _PRL_MESSAGE_TYPE_ENUM {
  PMT_WARNING = 0,
  PMT_INFORMATION = 1,
  PMT_CRITICAL = 2,
  PMT_QUESTION = 3,
  PMT_ANSWER = 4
};
File

PrlEnums.h

Links
Other Structs


_PRL_MOBILE_ADVANCED_AUTH_MODE Enumeration

_PRL_MOBILE_ADVANCED_AUTH_MODE Enumeration
Other Structs

Authorization mode, when mobile client establishing remote access to the host.

Syntax
enum _PRL_MOBILE_ADVANCED_AUTH_MODE {
  PMAA_NO_ADVANCED_AUTH_NEEDED = 0,
  PMAA_USE_SYSTEM_CREDENTIALS = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_MOUNT_VIRTUAL_DISK Enumeration

_PRL_MOUNT_VIRTUAL_DISK Enumeration
Other Structs

Mount virtual disk flags

Syntax
enum _PRL_MOUNT_VIRTUAL_DISK {
  PMVD_READ_ONLY = 1<<(PACF_MAX+1),
  PMVD_READ_WRITE = 1<<(PACF_MAX+2),
  PMVD_INFO = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_MOUSE_BUTTON Enumeration

_PRL_MOUSE_BUTTON Enumeration
Other Structs
Syntax
enum _PRL_MOUSE_BUTTON {
  PMB_NOBUTTON = 0,
  PMB_LEFT_BUTTON = 1<<0,
  PMB_RIGHT_BUTTON = 1<<1,
  PMB_MIDDLE_BUTTON = 1<<2,
  PMB_XBUTTON1 = 1<<3,
  PMB_XBUTTON2 = 1<<4,
  PMB_XBUTTON3 = 1<<5,
  PMB_XBUTTON4 = 1<<6,
  PMB_XBUTTON5 = 1<<7
};
File

PrlEnums.h

Links
Other Structs


_PRL_NET_ADAPTER_EMULATED_TYPE Enumeration

_PRL_NET_ADAPTER_EMULATED_TYPE Enumeration
Other Structs

Network adapter emulated type

Syntax
enum _PRL_NET_ADAPTER_EMULATED_TYPE {
  PNA_HOST_ONLY = 0,
  PNA_SHARED = 1,
  PNA_BRIDGED_ETHERNET = 2,
  PNA_DIRECT_ASSIGN = 4,
  PNA_ROUTED = 5
};
File

PrlEnums.h

Members

PNA_DIRECT_ASSIGN
PNA_CUSTOM= 3 // not currently supported!

Links
Other Structs


_PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration

_PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration
Other Structs

Virtual Network type.

Syntax
enum _PRL_NET_VIRTUAL_NETWORK_TYPE {
  PVN_BRIDGED_ETHERNET = 0,
  PVN_HOST_ONLY = 1
};
File

PrlEnums.h

Remarks

Should match values in LibrariesPrlNetworkingprl_netconfig.h

Links
Other Structs


_PRL_NETFILTER_MODE Enumeration

_PRL_NETFILTER_MODE Enumeration
Other Structs

Netfilter modes list

Syntax
enum _PRL_NETFILTER_MODE {
  PCNM_NOT_SET = 0,
  PCNM_DISABLED = 1,
  PCNM_STATELESS = 2,
  PCNM_STATEFUL = 3,
  PCNM_FULL = 4
};
File

PrlEnums.h

Links
Other Structs


_PRL_ONLINE_COMPACT_MODE Enumeration

_PRL_ONLINE_COMPACT_MODE Enumeration
Other Structs

Online compact mode for virtual machine disks

Syntax
enum _PRL_ONLINE_COMPACT_MODE {
  POCM_DISABLED = 0,
  POCM_ENABLED = 1,
  POCM_AUTO = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_OPTIMIZE_MODIFIERS_MODE Enumeration

_PRL_OPTIMIZE_MODIFIERS_MODE Enumeration
Other Structs

Determines the mode of modifiers handling inside the guest

Syntax
enum _PRL_OPTIMIZE_MODIFIERS_MODE {
  POD_STANDARD = 0,
  POD_OPTIMIZE_FOR_GAMES = 1,
  POD_OPTIMIZE_FOR_ACCESSIBILITY = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_PARAM_FIELD_DATA_TYPE Enumeration

_PRL_PARAM_FIELD_DATA_TYPE Enumeration
Other Structs

Event parameters fields types

Syntax
enum _PRL_PARAM_FIELD_DATA_TYPE {
  PFD_UINT32 = 0,
  PFD_STRING = 1,
  PFD_INT32 = 2,
  PFD_CDATA = 3,
  PFD_BOOLEAN = 4,
  PFD_ENTITY = 5,
  PFD_ENUMERATION = 6,
  PFD_INT64 = 7,
  PFD_UINT64 = 8,
  PFD_BINARY = 9,
  PFD_UNKNOWN = 0xFF
};
File

PrlEnums.h

Links
Other Structs


_PRL_PORT_FORWARDING_TYPE Enumeration

_PRL_PORT_FORWARDING_TYPE Enumeration
Other Structs

Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding

Syntax
enum _PRL_PORT_FORWARDING_TYPE {
  PPF_TCP = 0,
  PPF_UDP = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_PRINTER_INTERFACE_TYPE Enumeration

_PRL_PRINTER_INTERFACE_TYPE Enumeration
Other Structs

Printer device interface type

Syntax
enum _PRL_PRINTER_INTERFACE_TYPE {
  PRN_LPT_DEVICE = 0,
  PRN_USB_DEVICE = 1,
  PRN_UNKNOWN_DEVICE = 255
};
File

PrlEnums.h

Links
Other Structs


_PRL_PRIVATE_EVENT_TYPE Enumeration

_PRL_PRIVATE_EVENT_TYPE Enumeration
Other Structs

Private event types.

Syntax
enum _PRL_PRIVATE_EVENT_TYPE {
  PET_IO_DISPLAY_PALETTE_CHANGED = 200000,
  PET_IO_TOOLS_TIS_QUERY = 200001,
  PET_IO_SCREEN_UPDATED = 200002,
  PET_IO_AUTH_RESPONSE = 200003,
  PET_IO_ATTACH_RESPONSE = 200004,
  PET_IO_ENCODING_RESPONSE = 200005,
  PET_IO_MEMORY_INFO = 200006,
  PET_IO_SCREEN_CAPTURED_BUFFER = 200007,
  PET_IO_TOOLS_TIS_SUBSCRIBE = 200008,
  PET_IO_TOOLS_TIS_UNSUBSCRIBE = 200009,
  PET_IO_CLI_AUTHENTICATE_SESSION = 200100,
  PET_IO_CLI_ATTACH_TO_VM = 200101,
  PET_IO_CLI_ENCODING_REQUEST = 200102,
  PET_IO_CLI_SCREEN_WATCH_UPDATES = 200103,
  PET_IO_CLI_SCREEN_CAPTURE_BUFFER = 200104,
  PET_IO_CLI_SCREEN_SIZE = 200105,
  PET_IO_CLI_KEYBOARD_SCANCODE = 200106,
  PET_IO_CLI_MOUSE_SETPOS = 200107,
  PET_IO_CLI_MOUSE_MOVE = 200108,
  PET_IO_CLI_MOUSE_NEED_CURSOR = 200109,
  PET_IO_CLI_GRACEFUL_SHUTDOWN = 200110,
  PET_IO_CLI_SCREEN_SET_SURFACE = 200111,
  PET_IO_CLI_REMOTE_COMMAND = 200112,
  PET_IO_CLI_TOOLS_UTILITY_COMMAND = 200113,
  PET_IO_CLI_TOOLS_TIS_QUERY = 200114,
  PET_IO_CLI_TOOLS_CLIPBOARD_DATA = 200115,
  PET_IO_CLI_TOOLS_SIA_DATA = 200116,
  PET_IO_CLI_TOOLS_VMCTG_COMMAND = 200117,
  PET_IO_CLI_TOOLS_GENERAL_COMMAND = 200118,
  PET_IO_CLI_TOOLS_EMPTY_RECYCLE_BIN = 200119,
  PET_IO_CLI_TOOLS_SET_TASKBAR_VISIBILITY = 200120,
  PET_IO_CLI_TOOLS_TOGGLE_DESKTOP = 200121,
  PET_IO_CLI_TOOLS_MOVE_TASKBAR = 200122,
  PET_IO_CLI_TOOLS_SHOW_RECYCLE_BIN = 200123,
  PET_IO_CLI_TOOLS_NOTIFY_COHERENCE_STATE = 200124,
  PET_IO_CLI_TOOLS_ADJUST_WORKING_AREA = 200125,
  PET_IO_CLI_KEYBOARD_KEY = 200126,
  PET_IO_CLI_TOOLS_UIEMU = 200127,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_START = 200128,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_STOP = 200129,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_SET_ENCODING = 200130,
  PET_IO_CLI_CVSRC_CONNECT = 200131,
  PET_IO_CLI_CVSRC_DISCONNECT = 200132,
  PET_IO_CLI_AUTHENTICATE_EXEC_SESSION = 200133,
  PET_IO_CLI_SWITCH_SLIDING_MOUSE = 200134,
  PET_IO_CLI_SSO_SET_CREDENTIALS = 200135,
  PET_IO_CLI_SSO_SET_CREDENTIALS_ASYNC = 200136,
  PET_IO_CLI_SSO_LOCKED = 200137,
  PET_IO_CLI_SSO_UNLOCKED = 200138,
  PET_IO_CLI_DPI_SCREEN_SIZE = 200139,
  PET_IO_CLI_TOOLS_SET_INDENTS = 200140,
  PET_IO_CLI_AUDIO_RECORDING_STREAM_START = 200141,
  PET_IO_CLI_AUDIO_RECORDING_STREAM_STOP = 200142,
  PET_IO_CLI_AUDIO_PLAYOUT_STREAM_START = 200143,
  PET_IO_CLI_AUDIO_PLAYOUT_STREAM_STOP = 200144,
  PET_IO_CLI_TOOLS_OPEN_FILE_BROWSER = 200145,
  PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS = 200146,
  PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS_RESPONSE = 200147,
  PET_IO_CLI_SET_AUDIO_SWITCH_SETTINGS = 200148,
  PET_IO_STDIN_PORTION = 200200,
  PET_IO_STDOUT_PORTION = 200201,
  PET_IO_STDERR_PORTION = 200202,
  PET_IO_READY_TO_ACCEPT_STDOUT_STDERR_PKGS = 200203,
  PET_IO_FIN_TO_TRANSMIT_STDOUT_STDERR = 200204,
  PET_IO_CLIENT_PROCESSED_ALL_DESCS_DATA = 200205,
  PET_IO_TTY_SETTINGS_REQUIRED = 200206,
  PET_IO_TTY_SETTINGS_PROVIDED = 200207,
  PET_IO_STDIN_WAS_CLOSED = 200208,
  PET_IT_RECONFIG_BOOTCAMP_START = 200300,
  PET_IT_VALIDATE_BOOTCAMP_START = 200301,
  PET_IT_CONVERT_TO_OLD_START = 200302,
  PET_IT_CONVERT_TO_CURRENT_START = 200303,
  PET_IT_RECONFIG_START = 200304,
  PET_IT_MERGE_SNAPSHOTS_START = 200305,
  PET_IT_MAKE_PLAIN_START = 200306,
  PET_IT_MAKE_EXPANDING_START = 200307,
  PET_IT_MAKE_SPLIT_START = 200308,
  PET_IT_MAKE_NON_SPLIT_START = 200309,
  PET_IT_GET_RESIZE_INFORMATION_START = 200310,
  PET_IT_INCREASE_LAST_VOLUME_START = 200311,
  PET_IT_RESIZING_START = 200312,
  PET_IT_DECREASING_START = 200313,
  PET_IT_COMPACTING_START = 200314,
  PET_IT_FIX_CONSISTENCY_START = 200315,
  PET_IT_CONVERT_TO_EXTEND_START = 200316,
  PET_DESKCTL_SESSION_AUTH = 200400,
  PET_DESKCTL_SESSION_AUTH_FIN = 200401,
  PET_DESKCTL_ATTACH = 200402,
  PET_DESKCTL_ATTACH_FIN = 200403,
  PET_DESKCTL_LOCAL_AUTH = 200404,
  PET_DESKCTL_LOCAL_AUTH_QUEST = 200405,
  PET_DESKCTL_LOCAL_AUTH_ANSWER = 200406,
  PET_DESKCTL_LOCAL_AUTH_FIN = 200407,
  PET_DESKCTL_ACCEPT_CLIENTS = 200408,
  PET_DESKCTL_REJECT_CLIENTS = 200409,
  PET_DESKCTL_CONFIG = 200410,
  PET_DESKCTL_CONFIG_QUERY = 200411,
  PET_DESKCTL_SEND_SAS = 200412,
  PET_DESKCTL_STATUS_CHANGE = 200413,
  PET_DESKCTL_SHARES_SHARE = 200414,
  PET_DESKCTL_SHARES_UNSHARE = 200415,
  PET_DESKCTL_SHARES_ENUMERATE = 200416,
  PET_IO_DISCONNECT_WITH_REASON = 200500,
  PET_IO_DISPLAY_RESOLUTION_SET = 200510,
  PET_VIDEO_STREAM_START = 200600,
  PET_VIDEO_STREAM_CLOSE = 200601,
  PET_VIDEO_STREAM_FORMAT = 200602,
  PET_VIDEO_STREAM_DATA = 200603,
  PET_VIDEO_STREAM_CLOSED = 200604,
  PET_VIDEO_STREAM_ACK_FRAME = 200605,
  PET_VIDEO_STREAM_OPEN = 200606,
  PET_VIDEO_DATA_CHANNEL_CTL = 200607,
  PET_VIDEO_STREAM_STOP = 200608,
  PET_IO_PTM_PROTOCOL = 200700,
  PET_IO_IOSERVICE_CHANNELS_PROTOCOL = 200800
};
File

PrlEventsValues.h

Members

PET_IO_DISPLAY_PALETTE_CHANGED
BASE VALUE SET TO 200000
PET_IO_CLI_AUTHENTICATE_SESSION
ALIGNED VALUE TO 200100
PET_IO_STDIN_PORTION
ALIGNED VALUE TO 200200
PET_IT_RECONFIG_BOOTCAMP_START
ALIGNED VALUE TO 200300
PET_DESKCTL_SESSION_AUTH
ALIGNED VALUE TO 200400
PET_IO_DISCONNECT_WITH_REASON
ALIGNED VALUE TO 200500
PET_IO_DISPLAY_RESOLUTION_SET
ALIGNED VALUE TO 200510
PET_VIDEO_STREAM_START
ALIGNED VALUE TO 200600
PET_IO_PTM_PROTOCOL
ALIGNED VALUE TO 200700
PET_IO_IOSERVICE_CHANNELS_PROTOCOL
ALIGNED VALUE TO 200800

Remarks

Is NOT a part of public API.

Links
Other Structs


_PRL_PROBLEM_REPORT_FLAGS Enumeration

_PRL_PROBLEM_REPORT_FLAGS Enumeration
Other Structs

Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report

Syntax
enum _PRL_PROBLEM_REPORT_FLAGS {
  PPRF_ADD_CLIENT_PART = 1<<(PACF_MAX+1),
  PPRF_ADD_SERVER_PART = 1<<(PACF_MAX+2),
  PPRF_DO_NOT_CREATE_HOST_SCREENSHOT = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_PROBLEM_REPORT_REASON Enumeration

_PRL_PROBLEM_REPORT_REASON Enumeration
Other Structs

Problem report reason enumeration

Syntax
enum _PRL_PROBLEM_REPORT_REASON {
  PRR_UNKNOWN = 0,
  PRR_BOOT_CAMP = 1,
  PRR_HANG_LOCKUP = 2,
  PRR_KEYBOARD = 3,
  PRR_NETWORK = 4,
  PRR_PARALLELS_TOOLS = 5,
  PRR_PERFORMANCE = 6,
  PRR_PRODUCT_REGISTRATION = 7,
  PRR_SNAPSHOTS = 8,
  PRR_SOUND = 9,
  PRR_SUPPORT_REQUEST = 10,
  PRR_USB = 11,
  PRR_VIDEO_3D_GRAPHICS = 12,
  PRR_OTHER = 13,
  PRR_BACKUP = 14,
  PRR_MIGRATION = 15,
  PRR_CONNECTION = 16,
  PRR_LAST = PRR_CONNECTION
};
File

PrlEnums.h

Members

PRR_LAST
Should equals to the last item

Links
Other Structs


_PRL_PROBLEM_REPORT_SCHEME Enumeration

_PRL_PROBLEM_REPORT_SCHEME Enumeration
Other Structs

Problem report scheme enumaration

Syntax
enum _PRL_PROBLEM_REPORT_SCHEME {
  PRS_OLD_XML_BASED = 0,
  PRS_NEW_PACKED = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_PROBLEM_REPORT_TYPE Enumeration

_PRL_PROBLEM_REPORT_TYPE Enumeration
Other Structs

Problem report type enumeration

Syntax
enum _PRL_PROBLEM_REPORT_TYPE {
  PRT_REPORT_TYPE_UNDEFINED = 0,
  PRT_AUTOMATIC_VM_GENERATED_REPORT = 1,
  PRT_AUTOMATIC_DISPATCHER_GENERATED_REPORT = 2,
  PRT_USER_DEFINED_ON_STOPPED_VM_REPORT = 3,
  PRT_USER_DEFINED_ON_RUNNING_VM_REPORT = 4,
  PRT_USER_DEFINED_ON_CONNECTED_SERVER = 5,
  PRT_USER_DEFINED_ON_DISCONNECTED_SERVER = 6,
  PRT_USER_DEFINED_ON_NOT_RESPONDING_VM_REPORT = 7,
  PRT_AUTOMATIC_DETECTED_REPORT = 8,
  PRT_AUTOMATIC_STATISTICS_REPORT = 9,
  PRT_AUTOMATIC_INSTALLED_SOFTWARE_REPORT = 10,
  PRT_AUTOMATIC_VZ_STATISTICS_REPORT = 11,
  PRT_AUTOMATIC_UTW7AGENT_PRE_MIGRATION = 12,
  PRT_AUTOMATIC_UTW7AGENT_POST_MIGRATION = 13,
  PRT_AUTOMATIC_TRANSPORTER_REPORT = 14,
  PRT_USER_DEFINED_TRANSPORTER_REPORT = 15,
  PRT_AUTOMATIC_GUEST_GENERATED_REPORT = 16,
  PRT_USER_DEFINED_ON_CONTAINER_REPORT = 17,
  PRT_USER_DEFINED_ON_MOBILE_REPORT = 18,
  PRT_USER_DEFINED_ON_MOBILE_FEEDBACK_REPORT = 19,
  PRT_LAST = PRT_USER_DEFINED_ON_MOBILE_FEEDBACK_REPORT
};
File

PrlEnums.h

Members

PRT_LAST
Should equals to the last item

Links
Other Structs


_PRL_PROCESS_STATE_TYPE Enumeration

_PRL_PROCESS_STATE_TYPE Enumeration
Other Structs

Process state element

Syntax
enum _PRL_PROCESS_STATE_TYPE {
  PPS_PROC_SLEEP = 0,
  PPS_PROC_RUN = 1,
  PPS_PROC_STOP = 2,
  PPS_PROC_ZOMBIE = 3,
  PPS_PROC_IDLE = 4
};
File

PrlEnums.h

Links
Other Structs


_PRL_PRODUCT_ENUM Enumeration

_PRL_PRODUCT_ENUM Enumeration
Other Structs

Parallels license products enumeration.

Syntax
enum _PRL_PRODUCT_ENUM {
  PRL_PRODUCT_ANY = 0,
  PRL_PRODUCT_DESKTOP = 1,
  PRL_PRODUCT_SERVER = 2,
  PRL_PRODUCT_WORKSTATION = 3,
  PRL_PRODUCT_STM = 4,
  PRL_PRODUCT_PLAYER = 5,
  PRL_PRODUCT_DESKTOP_WL = 6,
  PRL_PRODUCT_DESKTOP_PDE = 7
};
File

PrlEnums.h

Links
Other Structs


_PRL_PROXY_CLIENT_INFO Structure

_PRL_PROXY_CLIENT_INFO Structure
Other Structs
Syntax
struct _PRL_PROXY_CLIENT_INFO {
  PRL_UINT32 structSize;
  PRL_CHAR clientOptions[64];
  PRL_UINT8 customerSupportUUID[16];
  PRL_CHAR managerURL[256];
};
File

PrlIoStructs.h

Members

structSize
< Should be filled by the caller with actual structure size
clientOptions
< Reserved
customerSupportUUID
< Reserved
managerURL
< Reserved

Links
Other Structs


_PRL_PROXY_CONNECTION_STATUS Enumeration

_PRL_PROXY_CONNECTION_STATUS Enumeration
Other Structs

Proxy connection status

Syntax
enum _PRL_PROXY_CONNECTION_STATUS {
  PCS_DISCONNECTED = 0,
  PCS_CONNECTED = 1,
  PCS_CONNECTING = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_PROXY_DATA_KEY Structure

_PRL_PROXY_DATA_KEY Structure
Other Structs
Syntax
struct _PRL_PROXY_DATA_KEY {
  PRL_STR dataKey;
  PRL_INT32 dataVersion;
  struct _PRL_PROXY_DATA_KEY * next;
};
File

PrlIoStructs.h

Members

dataKey
< Data identifier
dataVersion
< Data version
next
< Pointer to the next element

Links
Other Structs


_PRL_PROXY_GEO_INFO Structure

_PRL_PROXY_GEO_INFO Structure
Other Structs
Syntax
struct _PRL_PROXY_GEO_INFO {
  PRL_CHAR countryName[64];
  PRL_CHAR countryCode[3];
  PRL_CHAR region[3];
  PRL_CHAR city[64];
  PRL_CHAR postalCode[10];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_PROXY_HOST_INFO Structure

_PRL_PROXY_HOST_INFO Structure
Other Structs
Syntax
struct _PRL_PROXY_HOST_INFO {
  PRL_UINT8 hostUUID[16];
  PRL_CHAR brokerAddresses[PRL_PROXY_MAX_HOSTS][64];
  PRL_INT32 brokerAddressesSz;
  PRL_PROXY_REGISTRATION_INFO info;
};
File

PrlIoStructs.h

Members

hostUUID
< Proxy host uuid
brokerAddresses
< Broker addresses to which connection should be established
brokerAddressesSz
< Broker addresses size
info
< Host registration info

Links
Other Structs


_PRL_PROXY_HOST_INFO_EXT Structure

_PRL_PROXY_HOST_INFO_EXT Structure
Other Structs
Syntax
struct _PRL_PROXY_HOST_INFO_EXT {
  PRL_PROXY_HOST_INFO hostInfo;
  PRL_BOOL isOnline;
  PRL_PROXY_GEO_INFO_PTR geoInfo;
  struct _PRL_PROXY_HOST_INFO_EXT * next;
};
File

PrlIoStructs.h

Members

isOnline
Sign which specifies whether appropriate host online

Links
Other Structs


_PRL_PROXY_REGISTRATION_INFO Structure

_PRL_PROXY_REGISTRATION_INFO Structure
Other Structs
Syntax
struct _PRL_PROXY_REGISTRATION_INFO {
  PRL_CHAR hostAddresses[PRL_PROXY_MAX_HOSTS][64];
  PRL_INT32 hostAddressesSz;
  PRL_CHAR hostName[64];
  PRL_UINT8 appUUID[16];
  PRL_CHAR appVersion[32];
  PRL_CHAR hostOptions[33];
  PRL_CHAR hostOsName[63];
  PRL_CHAR isoTimestamp[32];
};
File

PrlIoStructs.h

Members

hostAddresses
< Host addresses which host listens to
hostAddressesSz
< Size of host addresses
hostName
< Short host name
appUUID
< Application uuid
appVersion
< Application version
hostOptions
< Using for host icon hash transport
hostOsName
< Reserved
isoTimestamp
< Reserved

Links
Other Structs


_PRL_PROXY_USER_DATA Structure

_PRL_PROXY_USER_DATA Structure
Other Structs
Syntax
struct _PRL_PROXY_USER_DATA {
  PRL_STR dataKey;
  PRL_INT32 dataVersion;
  PRL_VOID_PTR data;
  PRL_UINT32 dataSize;
  struct _PRL_PROXY_USER_DATA * next;
};
File

PrlIoStructs.h

Members

dataKey
< Data identifier
dataVersion
< Data version
data
< Pointer to the data buffer
dataSize
< Data size
next
< Pointer to the next element

Links
Other Structs


PRL_PTM Macros Macros

PRL_PTM Macros Macros
PRL_PTM Macros
Macros
Name | Description
PRL_PTM_DECLARE_PROPERTY |
PRL_PTM_INIT_PROPERTY |
PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS | Objects Section
PRL_PTM_NAMESPACE_APPMNG_CHANNELS |
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM |
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS |
PRL_PTM_NAMESPACE_APPMNG_IMAGES |
PRL_PTM_NAMESPACE_APPMNG_OPERATIONS |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM |
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES |
PRL_PTM_NAMESPACE_APPMNG_PROCESSES |
PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT |
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE |
PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON | RPC section
PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL |
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE |
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT |
PRL_PTM_NAMESPACE_APPMNG_SHARES |
PRL_PTM_NAMESPACE_DESKTOP |
PRL_PTM_NAMESPACE_DESKTOP_CLIENT |
PRL_PTM_NAMESPACE_DESKTOP_MENU |
PRL_PTM_NAMESPACE_DESKTOP_SESSION |
PRL_PTM_NAMESPACE_DESKTOP_UI |
PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES |
PRL_PTM_NAMESPACE_HINTING |
PRL_PTM_NAMESPACE_HINTING_SELECTION |
PRL_PTM_NAMESPACE_INPUT |
PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD |
PRL_PTM_NAMESPACE_INPUT_CARET |
PRL_PTM_NAMESPACE_INPUT_CURSOR |
PRL_PTM_NAMESPACE_INPUT_INFO |
PRL_PTM_NAMESPACE_PRIVATE |
PRL_PTM_NAMESPACE_RPC | namespace definitions
PRL_PTM_NAMESPACE_RPC_CANCEL |
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER |
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE |
PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW |
PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE |
PRL_PTM_NAMESPACE_RPC_HINTING_CARET |
PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP |
PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON |
PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION |
PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE |
PRL_PTM_NAMESPACE_RPC_QUERY |
PRL_PTM_NAMESPACE_RPC_SET |
PRL_PTM_NAMESPACE_RPC_SUBSCRIBE |


_PRL_PTM_OBJECT Structure

_PRL_PTM_OBJECT Structure
Other Structs

structure describes the object properties used by SetProperties and by PET_PTM_EVT_PROPERTY_CHANGED event

Syntax
struct _PRL_PTM_OBJECT {
  PRL_CONST_STR objectName;
  PRL_PTM_PROPERTY_PTR properties;
  PRL_UINT32 propertyCount;
};
File

PrlApiPtmTypes.h

Links
Other Structs


_PRL_PTM_PROPERTY Structure

_PRL_PTM_PROPERTY Structure
Other Structs

structure describes object property

Syntax
struct _PRL_PTM_PROPERTY {
  PRL_UINT32 id;
  PRL_VOID_PTR data;
  PRL_UINT32 size;
};
File

PrlApiPtmTypes.h

Links
Other Structs


_PRL_QUERY_ELEMENT_FLAGS Enumeration

_PRL_QUERY_ELEMENT_FLAGS Enumeration
Other Structs

Query element flags

Syntax
enum _PRL_QUERY_ELEMENT_FLAGS {
  PRL_UIEMU_ELEMENT_SEARCH_AREA_WINDOW = 0,
  PRL_UIEMU_ELEMENT_SEARCH_AREA_GLOBAL = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_REGISTER_3PARTY_VM_FLAGS Enumeration

_PRL_REGISTER_3PARTY_VM_FLAGS Enumeration
Other Structs

PrlSrv_Register3rdPartyVm command flags set

Syntax
enum _PRL_REGISTER_3PARTY_VM_FLAGS {
  PR3F_ALLOW_UNKNOWN_OS = 1<<(PACF_MAX+1),
  PR3F_CREATE_SHADOW_VM = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_REGISTER_NEW_VM Enumeration

_PRL_REGISTER_NEW_VM Enumeration
Other Structs

PrlVm_RegEx flags

Syntax
enum _PRL_REGISTER_NEW_VM {
  PRNVM_CREATE_FROM_LION_RECOVERY_PARTITION = PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION,
  PRNVM_ALLOW_TO_AUTO_DECREASE_HDD_SIZE = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_REGISTER_VM_FLAGS Enumeration

_PRL_REGISTER_VM_FLAGS Enumeration
Other Structs

PrlSrv_RegisterVmEx command flags set

Syntax
enum _PRL_REGISTER_VM_FLAGS {
  PRVF_REGENERATE_VM_UUID = 1<<(PACF_MAX+1),
  PRVF_KEEP_OTHERS_PERMISSIONS = 1<<(PACF_MAX+2),
  PRCF_FORCE = 1<<(PACF_MAX+3),
  PRVF_REGENERATE_SRC_VM_UUID = 1<<(PACF_MAX+4),
  PRVF_IGNORE_HA_CLUSTER = 1<<(PACF_MAX+5),
  PRCF_UNREG_PRESERVE = 1<<(PACF_MAX+6)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_RESIZE_IMAGE_FLAGS Enumeration

_PRL_RESIZE_IMAGE_FLAGS Enumeration
Other Structs

PrlVmDev_ResizeImage command flags set

Syntax
enum _PRL_RESIZE_IMAGE_FLAGS {
  PRIF_RESIZE_LAST_PARTITION = 1<<(PACF_MAX+1),
  PRIF_DISK_INFO = 1<<(PACF_MAX+2),
  PRIF_RESIZE_OFFLINE = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_RUNNING_TASK_TYPE_ENUM Enumeration

_PRL_RUNNING_TASK_TYPE_ENUM Enumeration
Other Structs

Running task type enumeration.

Syntax
enum _PRL_RUNNING_TASK_TYPE_ENUM {
  RTT_RUNNING_TASK_UNKNOWN = 0,
  RTT_RUNNING_TASK_CREATE_VM = 1,
  RTT_RUNNING_TASK_REGISTER_VM = 2,
  RTT_RUNNING_TASK_CLONE_VM = 3,
  RTT_RUNNING_TASK_DELETE_VM = 4,
  RTT_RUNNING_TASK_UNREG_VM = 5,
  RTT_RUNNING_TASK_CREATE_IMAGE = 6,
  RTT_RUNNING_TASK_RESTORE_VM = 7,
  RTT_RUNNING_TASK_MIGRATE_VM = 8,
  RTT_RUNNING_TASK_COPY_IMAGE = 9
};
File

PrlEnums.h

Links
Other Structs


_PRL_SCALE_VIEW_MODE Enumeration

_PRL_SCALE_VIEW_MODE Enumeration
Other Structs

Aspect ratio mode

Syntax
enum _PRL_SCALE_VIEW_MODE {
  PSVM_OFF = 0,
  PSVM_AUTO = 1,
  PSVM_KEEP_ASPECT_RATIO = 2,
  PSVM_KEEP_ASPECT_RATIO_BY_EXPANDING = 3,
  PSVM_IGNORE_ASPECT_RATIO = 4
};
File

PrlEnums.h

Links
Other Structs


PRL_SCAN_CODE Macros Macros

PRL_SCAN_CODE Macros Macros
PRL_SCAN_CODE Macros
Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_APP_CALCULATOR |
PRL_SCAN_CODE_APP_MAIL |
PRL_SCAN_CODE_APP_MY_COMPUTER |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_BRAZILIAN_KEYPAD |
PRL_SCAN_CODE_BREAK |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOLLAR |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_EJECT |
PRL_SCAN_CODE_END |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | PS/2 scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_EURO |
PRL_SCAN_CODE_EUROPE_1 |
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F13 |
PRL_SCAN_CODE_F14 |
PRL_SCAN_CODE_F15 |
PRL_SCAN_CODE_F16 |
PRL_SCAN_CODE_F17 |
PRL_SCAN_CODE_F18 |
PRL_SCAN_CODE_F19 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F20 |
PRL_SCAN_CODE_F21 |
PRL_SCAN_CODE_F22 |
PRL_SCAN_CODE_F23 |
PRL_SCAN_CODE_F24 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_HANGUEL |
PRL_SCAN_CODE_HANJA |
PRL_SCAN_CODE_HENKAN |
PRL_SCAN_CODE_HIRAGANA |
PRL_SCAN_CODE_HIRAGANA_KATAKANA |
PRL_SCAN_CODE_HOME |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_KATAKANA |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_LESS_GREATER |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MEDIA_NEXT_TRACK |
PRL_SCAN_CODE_MEDIA_PLAY_PAUSE |
PRL_SCAN_CODE_MEDIA_PREV_TRACK |
PRL_SCAN_CODE_MEDIA_SELECT |
PRL_SCAN_CODE_MEDIA_STOP |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_MUHENKAN |
PRL_SCAN_CODE_MUTE |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_EQUAL |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAGE_DOWN |
PRL_SCAN_CODE_PAGE_UP |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PC9800_KEYPAD |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_PRINT_SCREEN2 |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_RO |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_SYSRQ |
PRL_SCAN_CODE_SYSTEM_POWER |
PRL_SCAN_CODE_SYSTEM_SLEEP |
PRL_SCAN_CODE_SYSTEM_WAKE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_VOLUME_DOWN |
PRL_SCAN_CODE_VOLUME_UP |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_WWW_BACK |
PRL_SCAN_CODE_WWW_FAVORITES |
PRL_SCAN_CODE_WWW_FORWARD |
PRL_SCAN_CODE_WWW_HOME |
PRL_SCAN_CODE_WWW_REFRESH |
PRL_SCAN_CODE_WWW_SEARCH |
PRL_SCAN_CODE_WWW_STOP |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_YEN |
PRL_SCAN_CODE_Z |
PRL_SCAN_CODE_ZENKAKU_HANKAKU |


_PRL_SECURITY_LEVEL Enumeration

_PRL_SECURITY_LEVEL Enumeration
Other Structs

Security level enumeration.

Syntax
enum _PRL_SECURITY_LEVEL {
  PSL_LOW_SECURITY = 0,
  PSL_NORMAL_SECURITY = 1<<0,
  PSL_HIGH_SECURITY = 1<<1
};
File

PrlCommandsFlags.h

Type Parameters

PSL_LOW_SECURITY
Plain TCP/IP (no encryption).
PSL_NORMAL_SECURITY
Most important data is sent and received using SSL over TCP/IP (user credentials during login, guest OS clipboard, etc.) Other data is sent and receive using plain TCP/IP with no encryption.
PSL_HIGH_SECURITY
All of the data is sent and received using SSL.

Remarks

Defines levels of security that can be used in client/server communications.

Links
Other Structs


_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration

_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration
Other Structs

Serial port operation mode when on socket

Syntax
enum _PRL_SERIAL_PORT_SOCKET_OPERATION_MODE {
  PSP_SERIAL_SOCKET_SERVER = 0,
  PSP_SERIAL_SOCKET_CLIENT = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_SERVICE_STATUS_ENUM Enumeration

_PRL_SERVICE_STATUS_ENUM Enumeration
Other Structs

Parallels service statuses

Syntax
enum _PRL_SERVICE_STATUS_ENUM {
  PSS_STARTED = 0,
  PSS_STOPPED = 1,
  PSS_NOT_INSTALLED = 2,
  PSS_UNKNOWN
};
File

PrlEnums.h

Links
Other Structs


_PRL_SET_PROXY_CONNECTION_FLAGS Enumeration

_PRL_SET_PROXY_CONNECTION_FLAGS Enumeration
Other Structs

PrlDispCfg_SetProxyConnectionCreds flags

Syntax
enum _PRL_SET_PROXY_CONNECTION_FLAGS {
  PSPCF_DO_NOT_CLEAN_CREDS = 1<<(PACF_MAX+1),
  PSPCF_REUSE_AVAILABLE_CREDS = 1<<(PACF_MAX+2),
  PSPCF_CLEANUP_CREDS = 1<<(PACF_MAX+3),
  PSPCF_USE_DEPLOY_ID = 1<<(PACF_MAX+4),
  PSPCF_REGISTER_HOST_ONLY = 1<<(PACF_MAX+5),
  PSPCF_USE_FACEBOOK_TOKEN = 1<<(PACF_MAX+6),
  PSPCF_USE_GOOGLE_TOKEN = 1<<(PACF_MAX+7)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_SET_USERPASSWD_FLAGS Enumeration

_PRL_SET_USERPASSWD_FLAGS Enumeration
Other Structs

PrlVmGuest_SetUserPasswd flags

Syntax
enum _PRL_SET_USERPASSWD_FLAGS {
  PSPF_PASSWD_CRYPTED = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Members

PSPF_PASSWD_CRYPTED
passwords are encrypted

Links
Other Structs


_PRL_SOUND_CHANNEL_TYPE Enumeration

_PRL_SOUND_CHANNEL_TYPE Enumeration
Other Structs

Sound channel type

Syntax
enum _PRL_SOUND_CHANNEL_TYPE {
  PSCT_AUTO = 0,
  PSCT_STEREO = 1,
  PSCT_SURROUND_5_1 = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_SRV_SHUTDOWN_FLAGS Enumeration

_PRL_SRV_SHUTDOWN_FLAGS Enumeration
Other Structs

PrlSrv_ShutdownEx flags

Syntax
enum _PRL_SRV_SHUTDOWN_FLAGS {
  PSHF_FORCE_SHUTDOWN = 1<<(PACF_MAX+1),
  PSHF_DONT_WAIT_TO_COMPLETE = 1<<(PACF_MAX+2),
  PSHF_SUSPEND_VM_TO_PRAM = 1<<(PACF_MAX+3)
};
File

PrlCommandsFlags.h

Members

PSHF_FORCE_SHUTDOWN
Allow shutdown with active users sessions and running vms
PSHF_DONT_WAIT_TO_COMPLETE
Send response immediately when shutdown started
PSHF_SUSPEND_VM_TO_PRAM
Use PRAM to suspend/resume VM if available

Links
Other Structs


_PRL_STAT_NET_TRAFFIC Structure

_PRL_STAT_NET_TRAFFIC Structure
Other Structs
Syntax
struct _PRL_STAT_NET_TRAFFIC {
  PRL_UINT64 incoming[PRL_TC_CLASS_MAX];
  PRL_UINT64 outgoing[PRL_TC_CLASS_MAX];
  PRL_UINT32 incoming_pkt[PRL_TC_CLASS_MAX];
  PRL_UINT32 outgoing_pkt[PRL_TC_CLASS_MAX];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_SWITCH_SNAPSHOT_FLAGS Enumeration

_PRL_SWITCH_SNAPSHOT_FLAGS Enumeration
Other Structs

PrlVm_SwitchSnapshotEx flags

Syntax
enum _PRL_SWITCH_SNAPSHOT_FLAGS {
  PSSF_SKIP_RESUME = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Members

PSSF_SKIP_RESUME
skip resume stage for Vm in the

  • running/paused state in the snapshot

Links
Other Structs


_PRL_TASKBAR_STATES Enumeration

_PRL_TASKBAR_STATES Enumeration
Other Structs

Taskbar states

Syntax
enum _PRL_TASKBAR_STATES {
  PTBS_UNKNOWN = -1,
  PTBS_HIDE = 0,
  PTBS_SHOW = 1,
  PTBS_DEFAULT = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_TIS_INT_VERSION Structure

_PRL_TIS_INT_VERSION Structure
Other Structs

@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
Syntax
struct _PRL_TIS_INT_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_TIS_RECORD_FIELD Enumeration

_PRL_TIS_RECORD_FIELD Enumeration
Other Structs

Parallels Tools Information Service record fields

Syntax
enum _PRL_TIS_RECORD_FIELD {
  PTIS_RECORD_UID = 1<<0,
  PTIS_RECORD_NAME = 1<<1,
  PTIS_RECORD_INFO = 1<<2,
  PTIS_RECORD_TEXT = 1<<3,
  PTIS_RECORD_DATA = 1<<4,
  PTIS_RECORD_STATE = 1<<5,
  PTIS_RECORD_TIME = 1<<6,
  PTIS_RECORD_OWNER = 1<<7,
  PTIS_RECORD_FLAGS = 1<<8,
  PTIS_RECORD_REMOVED = 1<<30,
  PTIS_RECORD_CLEARED = 1<<31
};
File

PrlEnums.h

Members

PTIS_RECORD_REMOVED
set when record removed
PTIS_RECORD_CLEARED
set only with PTIS_RECORD_REMOVED bit when entire database was cleared

Links
Other Structs


_PRL_TIS_RECORD_INFO Structure

_PRL_TIS_RECORD_INFO Structure
Other Structs

@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
Syntax
struct _PRL_TIS_RECORD_INFO {
  PRL_TIS_VERSION version;
  PRL_TIS_INT_VERSION intVersion;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_TIS_RECORD_STATE Enumeration

_PRL_TIS_RECORD_STATE Enumeration
Other Structs

Parallels Tools Information Service record states

Syntax
enum _PRL_TIS_RECORD_STATE {
  PTIS_RECORD_EMPTY = 0,
  PTIS_RECORD_ACTIVE = 1,
  PTIS_RECORD_CANCELED = 2
};
File

PrlEnums.h

Links
Other Structs


PRL_TIS Types Types

PRL_TIS Types Types
PRL_TIS Types
Types
Name | Description
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_FIELD_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TIS_VERSION_PTR |


_PRL_TIS_VERSION Structure

_PRL_TIS_VERSION Structure
Other Structs

@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
Syntax
struct _PRL_TIS_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
  PRL_UINT32 bld;
  PRL_UINT32 rev;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration

_PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration
Other Structs

Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;

Syntax
enum _PRL_TOOLS_SIA_OPEN_IN_TYPES {
  PSIA_OPEN_DEFAULT = 0,
  PSIA_OPEN_IN_GUEST = 1,
  PSIA_OPEN_IN_HOST = 2
};
File

PrlEnums.h

Links
Other Structs


PRL_TOOLS Types Types

PRL_TOOLS Types Types
PRL_TOOLS Types
Types
Name | Description
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |


_PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration

_PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration
Other Structs

Parallels Tools Utility command flags

Syntax
enum _PRL_TOOLS_UTILITY_COMMAND_FLAG {
  PTU_FLG_ZERO = (1 << 0)
};
File

PrlCommandsFlags.h

Members

PTU_FLG_ZERO
@brief Flag is useless now, but placed here to show how and where it must be

Links
Other Structs


_PRL_TOOLS_UTILITY_COMMAND_ID Enumeration

_PRL_TOOLS_UTILITY_COMMAND_ID Enumeration
Other Structs

Parallels Tools Utility commands identifiers

Syntax
enum _PRL_TOOLS_UTILITY_COMMAND_ID {
  PTU_CMD_INVALID = 0,
  PTU_CMD_PTU_ALIVE = 1
};
File

PrlEnums.h

Members

PTU_CMD_INVALID
brief Identifier of invalid command
PTU_CMD_PTU_ALIVE
@brief Can be sent to indicate that Parallels Tools Utility subsystem is alive and ready to work

Links
Other Structs


_PRL_UIEMU_AUTOKEYBOARD Structure

_PRL_UIEMU_AUTOKEYBOARD Structure
Other Structs
Syntax
struct _PRL_UIEMU_AUTOKEYBOARD {
  PRL_UINT8 showKeyboardState;
  PRL_UINT8 reserved[3+4*4];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_CARET_INFO Structure

_PRL_UIEMU_CARET_INFO Structure
Other Structs
Syntax
struct _PRL_UIEMU_CARET_INFO {
  PRL_INT32 queryId;
  PRL_UINT32 queryFlags;
  PRL_UINT32 caretRectIsAvailable;
  PRL_UINT32 caretIsOutOfView;
  PRL_INT32 caretRectLeft;
  PRL_INT32 caretRectTop;
  PRL_INT32 caretRectRight;
  PRL_INT32 caretRectBottom;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_CURSOR_DESC Structure

_PRL_UIEMU_CURSOR_DESC Structure
Other Structs
Syntax
struct _PRL_UIEMU_CURSOR_DESC {
  PRL_DOUBLE width;
  PRL_DOUBLE height;
  PRL_DOUBLE hotx;
  PRL_DOUBLE hoty;
  PRL_UINT8 imageHash[8];
  PRL_UINT8 reserved[6*4];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_CURSOR_FORMAT Structure

_PRL_UIEMU_CURSOR_FORMAT Structure
Other Structs
Syntax
struct _PRL_UIEMU_CURSOR_FORMAT {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 alphaXor;
  PRL_UINT32 frames;
  PRL_UINT32 framet;
  PRL_UINT8 reserved[3*4];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_CURSOR_POS Structure

_PRL_UIEMU_CURSOR_POS Structure
Other Structs
Syntax
struct _PRL_UIEMU_CURSOR_POS {
  PRL_DOUBLE x;
  PRL_DOUBLE y;
  PRL_UINT8 reserved[4*4];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_ELEMENT_AT_POS Structure

_PRL_UIEMU_ELEMENT_AT_POS Structure
Other Structs
Syntax
struct _PRL_UIEMU_ELEMENT_AT_POS {
  PRL_INT32 queryId;
  PRL_UINT32 queryFlags;
  PRL_INT32 posX;
  PRL_INT32 posY;
  PRL_INT32 propRectLeft;
  PRL_INT32 propRectTop;
  PRL_INT32 propRectRight;
  PRL_INT32 propRectBottom;
  PRL_UINT32 propControlType;
  PRL_UINT8 propIsControl;
  PRL_UINT8 propIsKbdFocusable;
  PRL_UINT8 propIsEnabled;
  PRL_UINT8 propValueIsReadOnly;
  PRL_UINT8 propRngValueIsReadOnly;
  PRL_UINT8 propIsTextEdit;
  PRL_UINT8 propCanInputTextGlobal;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_ELEMENT_CONTROL_TYPE Enumeration

_PRL_UIEMU_ELEMENT_CONTROL_TYPE Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_ELEMENT_CONTROL_TYPE {
  PRL_UIEMU_ELEMENT_CONTROL_NONE = 0,
  PRL_UIEMU_ELEMENT_CONTROL_OTHER = 1,
  PRL_UIEMU_ELEMENT_CONTROL_EDIT = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_GESTURE_DATA_PINCH Structure

_PRL_UIEMU_GESTURE_DATA_PINCH Structure
Other Structs
Syntax
struct _PRL_UIEMU_GESTURE_DATA_PINCH {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_DOUBLE scale;
  PRL_DOUBLE velocity;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_GESTURE_DATA_SMARTZOOM Structure

_PRL_UIEMU_GESTURE_DATA_SMARTZOOM Structure
Other Structs
Syntax
struct _PRL_UIEMU_GESTURE_DATA_SMARTZOOM {
  PRL_INT32 x;
  PRL_INT32 y;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_GESTURE_EVENT Structure

_PRL_UIEMU_GESTURE_EVENT Structure
Other Structs
Syntax
struct _PRL_UIEMU_GESTURE_EVENT {
  PRL_UIEMU_GESTURE_TYPE type;
  PRL_UIEMU_GESTURE_STATE state;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
  PRL_UINT8 gestureData[48];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_GESTURE_STATE Enumeration

_PRL_UIEMU_GESTURE_STATE Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_GESTURE_STATE {
  PRL_UIEMU_GESTURE_STATE_BEGIN = 1,
  PRL_UIEMU_GESTURE_STATE_CHANGE = 2,
  PRL_UIEMU_GESTURE_STATE_END = 3,
  PRL_UIEMU_GESTURE_STATE_CANCEL = 4
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_GESTURE_TYPE Enumeration

_PRL_UIEMU_GESTURE_TYPE Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_GESTURE_TYPE {
  PRL_UIEMU_GESTURE_TYPE_PINCH = 1,
  PRL_UIEMU_GESTURE_TYPE_SMARTZOOM = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_INPUT_INFO Structure

_PRL_UIEMU_INPUT_INFO Structure
Other Structs
Syntax
struct _PRL_UIEMU_INPUT_INFO {
  PRL_UINT32 keyboardInputAvailable;
  PRL_UINT32 focusVersion;
  PRL_INT32 focusElemRectLeft;
  PRL_INT32 focusElemRectTop;
  PRL_INT32 focusElemRectRight;
  PRL_INT32 focusElemRectBottom;
  PRL_UINT8 reserved[4+4*4];
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_UIEMU_MAKEUP_HINTING_RGN Structure

_PRL_UIEMU_MAKEUP_HINTING_RGN Structure
Other Structs
Syntax
struct _PRL_UIEMU_MAKEUP_HINTING_RGN {
  PRL_INT32 rgnRectLeft;
  PRL_INT32 rgnRectTop;
  PRL_INT32 rgnRectRight;
  PRL_INT32 rgnRectBottom;
  PRL_UINT32 rgnType;
};
File

PrlApiHinting.h

Members

rgnType
brief See PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE enum for possible 'rgnType' values

Links
Other Structs


_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE Enumeration

_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE {
  PUMHRT_TEXT = 0,
  PUMHRT_IMAGE = 1
};
File

PrlApiHinting.h

Links
Other Structs


_PRL_UIEMU_MMKEY Enumeration

_PRL_UIEMU_MMKEY Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_MMKEY {
  PRL_UIEMU_MMKEY_SWIPE_LEFT_EDGE = 19,
  PRL_UIEMU_MMKEY_SWIPE_RIGHT_EDGE = 20,
  PRL_UIEMU_MMKEY_SWIPE_TOP_EDGE = 21,
  PRL_UIEMU_MMKEY_SWIPE_BOTTOM_EDGE = 22
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_MOUSE_CLICK Enumeration

_PRL_UIEMU_MOUSE_CLICK Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_MOUSE_CLICK {
  PMB_UIEMU_SINGLE_CLICK = 1,
  PMB_UIEMU_DOUBLE_CLICK = 2,
  PMB_UIEMU_TRIPLE_CLICK = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_SCROLL_FLAGS Enumeration

_PRL_UIEMU_SCROLL_FLAGS Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_SCROLL_FLAGS {
  PRL_UIEMU_SCROLL_FLAG_APPEND = 0,
  PRL_UIEMU_SCROLL_FLAG_NEW = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_SCROLL_UNITS Enumeration

_PRL_UIEMU_SCROLL_UNITS Enumeration
Other Structs
Syntax
enum _PRL_UIEMU_SCROLL_UNITS {
  PRL_UIEMU_SCROLL_PIXELS = 1,
  PRL_UIEMU_SCROLL_LINES = 2,
  PRL_UIEMU_SCROLL_POINTS = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_UIEMU_SELECTION_HINTING_RGN Structure

_PRL_UIEMU_SELECTION_HINTING_RGN Structure
Other Structs

brief Rect as a part of region

Syntax
struct _PRL_UIEMU_SELECTION_HINTING_RGN {
  PRL_INT32 rgnRectLeft;
  PRL_INT32 rgnRectTop;
  PRL_INT32 rgnRectRight;
  PRL_INT32 rgnRectBottom;
};
File

PrlApiHinting.h

Links
Other Structs


_PRL_UIEMU_VKEY Structure

_PRL_UIEMU_VKEY Structure
Other Structs
Syntax
struct _PRL_UIEMU_VKEY {
  PRL_UINT16 key;
  PRL_UINT16 ev;
  PRL_UINT32 reserved;
};
File

PrlIoStructs.h

Links
Other Structs


PRL_UINT Types Types

PRL_UINT Types Types
PRL_UINT Types
Types
Name | Description
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |


_PRL_UNDO_DISKS_MODE Enumeration

_PRL_UNDO_DISKS_MODE Enumeration
Other Structs

VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied

Syntax
enum _PRL_UNDO_DISKS_MODE {
  PUD_DISABLE_UNDO_DISKS = 0,
  PUD_REVERSE_CHANGES = 1,
  PUD_COMMIT_CHANGES = 2,
  PUD_PROMPT_BEHAVIOUR = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_UPDATE_LICENSE_FLAGS Enumeration

_PRL_UPDATE_LICENSE_FLAGS Enumeration
Other Structs

Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation

Syntax
enum _PRL_UPDATE_LICENSE_FLAGS {
  PUPLF_PROLONGATE_LICENSE = 1<<(PACF_MAX+1),
  PUPLF_KICK_TO_UDPATE_CURR_FILE_LICENSE = PUPLF_PROLONGATE_LICENSE,
  PUPLF_ACTIVATE_PERMANENT_LICENSE_ONLINE = 1<<(PACF_MAX+2),
  PUPLF_ACTIVATE_PERMANENT_LICENSE_OFFLINE = 1<<(PACF_MAX+3),
  PUPLF_CHECK_KEY_ONLY = 1<<(PACF_MAX+4),
  PUPLF_DEACTIVATE_CURRENT_LICENSE = 1<<(PACF_MAX+5),
  PUPLF_ACTIVATE_PRECACHED_KEY = 1<<(PACF_MAX+6),
  PUPLF_STORE_PRECACHED_KEY = 1<<(PACF_MAX+7),
  PUPLF_REMOVE_PRECACHED_KEY = 1<<(PACF_MAX+8),
  PUPLF_DEACTIVATE_CURRENT_LICENSE_OFFLINE_ALLOWED = 1<<(PACF_MAX+9),
  PUPLF_CHECK_KEY_ONLY_VOLUME = 1<<(PACF_MAX+10),
  PUPLF_REGISTER_CURRENT_LICENSE = 1<<(PACF_MAX+11)
};
File

PrlCommandsFlags.h

Members

PUPLF_KICK_TO_UDPATE_CURR_FILE_LICENSE
obsolete

Links
Other Structs


_PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration

_PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration
Other Structs

USB autoconnect devices options

Syntax
enum _PRL_USB_DEVICE_AUTO_CONNECT_OPTION {
  PUD_CONNECT_TO_PRIMARY_OS = 0,
  PUD_CONNECT_TO_GUEST_OS = 1,
  PUD_ASK_USER_WHAT_TODO = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_USB_DEVICE_CONNECT_REASON Enumeration

_PRL_USB_DEVICE_CONNECT_REASON Enumeration
Other Structs

USB device connect/disconnect reason

Syntax
enum _PRL_USB_DEVICE_CONNECT_REASON {
  PUD_CONNECTED_MANUALLY = 0,
  PUD_CONNECTED_AUTOMATICALLY = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_USB_DEVICE_TYPE Enumeration

_PRL_USB_DEVICE_TYPE Enumeration
Other Structs

USB device type

Syntax
enum _PRL_USB_DEVICE_TYPE {
  PUDT_OTHER = 0,
  PUDT_HUB = 1,
  PUDT_VIDEO = 2,
  PUDT_FOTO = 3,
  PUDT_AUDIO = 4,
  PUDT_PRINTER = 5,
  PUDT_SCANNER = 6,
  PUDT_BLUETOOTH = 7,
  PUDT_WIRELESS = 8,
  PUDT_COMMUNICATION = 9,
  PUDT_KEYBOARD = 10,
  PUDT_MOUSE = 11,
  PUDT_SMART_CARD = 12,
  PUDT_DISK_STORAGE = 13,
  PUDT_ATAPI_STORAGE = 14,
  PUDT_APPLE_IPHONE = 1000,
  PUDT_APPLE_IPOD = 1001,
  PUDT_APPLE_IPAD = 1002,
  PUDT_APPLE_IETH = 1003,
  PUDT_RIM_BLACKBERRY = 2000,
  PUDT_GARMIN_GPS = 3000
};
File

PrlEnums.h

Members

PUDT_OTHER
unknown device type
PUDT_HUB
usb hub
PUDT_VIDEO
streaming usb video device
PUDT_FOTO
still image usb video device
PUDT_AUDIO
usb audio device
PUDT_PRINTER
usb printer
PUDT_SCANNER
usb scaner
PUDT_BLUETOOTH
usb bluetooth
PUDT_WIRELESS
usb wireless device
PUDT_COMMUNICATION
other usb communication device
PUDT_KEYBOARD
usb keyboard
PUDT_MOUSE
usb mouse
PUDT_SMART_CARD
usb smartcard reader
PUDT_DISK_STORAGE
usb storage
PUDT_ATAPI_STORAGE
usb CD/DVD-ROMs Some vendor specific usb device classes
PUDT_APPLE_IPHONE
apple iphone
PUDT_APPLE_IPOD
apple ipod
PUDT_APPLE_IPAD
apple ipad
PUDT_APPLE_IETH
apple ieth
PUDT_RIM_BLACKBERRY
rim blackberry
PUDT_GARMIN_GPS
garmin gps

Links
Other Structs


_PRL_VERSION_ENUM Enumeration

_PRL_VERSION_ENUM Enumeration
Other Structs

Parallels license versions enumeration.

Syntax
enum _PRL_VERSION_ENUM {
  PRL_VERSION_ANY = 0,
  PRL_VERSION_3X = 1,
  PRL_VERSION_4X = 2,
  PRL_VERSION_5X = 3,
  PRL_VERSION_6X = 4,
  PRL_VERSION_7X = 5,
  PRL_VERSION_8X = 6,
  PRL_VERSION_9X = 7,
  PRL_VERSION_10X = 8,
  PRL_VERSION_11X = 9
};
File

PrlEnums.h

Links
Other Structs


_PRL_VIDEO_3D_ACCELERATION Enumeration

_PRL_VIDEO_3D_ACCELERATION Enumeration
Other Structs

Video 3D acceleration

Syntax
enum _PRL_VIDEO_3D_ACCELERATION {
  P3D_DISABLED = 0,
  P3D_ENABLED_HIGHEST = 1,
  P3D_ENABLED_DX9 = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VIRTUAL_MACHINE_PROFILE Enumeration

_PRL_VIRTUAL_MACHINE_PROFILE Enumeration
Other Structs

Virtual machine profiles enum

Syntax
enum _PRL_VIRTUAL_MACHINE_PROFILE {
  VMP_PRODUCTIVITY = 0,
  VMP_GAMES = 1,
  VMP_SOFTWARE_DEVELOPER = 2,
  VMP_DESIGNER = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_ACCELERATION_LEVEL Enumeration

_PRL_VM_ACCELERATION_LEVEL Enumeration
Other Structs

Acceleration level

Syntax
enum _PRL_VM_ACCELERATION_LEVEL {
  PVA_ACCELERATION_DISABLED = 0,
  PVA_ACCELERATION_NORMAL = 1,
  PVA_ACCELERATION_HIGH = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_ACCESS_FOR_OTHERS Enumeration

_PRL_VM_ACCESS_FOR_OTHERS Enumeration
Other Structs

Specifies virtual machine access rights.

Syntax
enum _PRL_VM_ACCESS_FOR_OTHERS {
  PAO_VM_NOT_SHARED = 0,
  PAO_VM_SHARED_ON_VIEW,
  PAO_VM_SHARED_ON_VIEW_AND_RUN,
  PAO_VM_SHARED_ON_FULL_ACCESS
};
File

PrlEnums.h

Type Parameters

PAO_VM_NOT_SHARED
Only the owner of the virtual machine has access to it. The machine will be hidden from all other users.
PAO_VM_SHARED_ON_VIEW
Other users can see the machine but they cannot run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_VIEW_AND_RUN
Other users can see the machine and they can also run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_FULL_ACCESS
Other users have full access to the virtual machine.

Links
Other Structs


_PRL_VM_ACTION Enumeration

_PRL_VM_ACTION Enumeration
Other Structs
Syntax
enum _PRL_VM_ACTION {
  PVA_PRESTART = 0,
  PVA_POSTSTART = 1,
  PVA_PRESTOP = 2,
  PVA_POSTSTOP = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_ACTION_ON_STOP Enumeration

_PRL_VM_ACTION_ON_STOP Enumeration
PRL_VM Structs

Action when VM gets stopped

Syntax
enum _PRL_VM_ACTION_ON_STOP {
  PAS_KEEP_VM_WINDOW_OPEN = 0,
  PAS_CLOSE_VM_WINDOW = 1,
  PAS_QUIT_APPLICATION = 2
};
File

PrlEnums.h

Links
PRL_VM Structs


_PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration

_PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration
Other Structs

Action on VM when VM window gets closed

Syntax
enum _PRL_VM_ACTION_ON_WINDOW_CLOSE {
  PWC_VM_UNKNOWN_ACTION = 0xffff,
  PWC_VM_STOP = 0,
  PWC_VM_SUSPEND = 1,
  PWC_VM_ASK_USER = 2,
  PWC_VM_PAUSE = 3,
  PWC_VM_SHUTDOWN = 4,
  PWC_VM_DO_NOTHING = 5
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_AUTOSTART_OPTION Enumeration

_PRL_VM_AUTOSTART_OPTION Enumeration
Other Structs

VM autostart options

Syntax
enum _PRL_VM_AUTOSTART_OPTION {
  PAO_VM_START_MANUAL = 0,
  PAO_VM_START_ON_LOAD = 1,
  PAO_VM_START_ON_RELOAD = 2,
  PAO_VM_START_ON_GUI_APP_STARTUP = 3,
  PAO_VM_START_ON_GUI_VM_WINDOW_OPEN = 4,
  PAO_VM_START_ON_GUI_WINDOW_LOAD = PAO_VM_START_ON_GUI_APP_STARTUP
};
File

PrlEnums.h

Members

PAO_VM_START_ON_GUI_WINDOW_LOAD
OBSOLETE CONSTANTS

Links
Other Structs


_PRL_VM_AUTOSTOP_OPTION Enumeration

_PRL_VM_AUTOSTOP_OPTION Enumeration
Other Structs

VM autostop options

Syntax
enum _PRL_VM_AUTOSTOP_OPTION {
  PAO_VM_STOP = 0,
  PAO_VM_SUSPEND = 1,
  PAO_VM_SHUTDOWN = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_BACKUP_FLAGS Enumeration

_PRL_VM_BACKUP_FLAGS Enumeration
Other Structs

VM backup functionality flags set

Syntax
enum _PRL_VM_BACKUP_FLAGS {
  PBSL_LOW_SECURITY = PSL_LOW_SECURITY,
  PBSL_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PBSL_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PBT_FULL = 1<<(PACF_MAX+1),
  PBT_INCREMENTAL = 1<<(PACF_MAX+2),
  PBT_DIFFERENTIAL = 1<<(PACF_MAX+3),
  PBT_RESTORE_TO_COPY = 1<<(PACF_MAX+4),
  PBT_IGNORE_NOT_EXISTS = 1<<(PACF_MAX+5),
  PBT_UNCOMPRESSED = 1<<(PACF_MAX+6),
  PBT_VM = 1<<(PACF_MAX+7),
  PBT_CT = 1<<(PACF_MAX+8),
  PBT_BACKUP_ID = 1<<(PACF_MAX+9),
  PBT_CHAIN = 1<<(PACF_MAX+10)
};
File

PrlCommandsFlags.h

Type Parameters

PBT_FULL
full backup
PBT_INCREMENTAL
incremental backup
PBT_DIFFERENTAL
differental backup
PBT_RESTORE_TO_COPY
change Vm name/uuid/MAC address on restore
PBT_UNCOMPRESSED
uncompressed backup
PBT_VM
for virtual mashines
PBT_CT
for containers
PBT_BACKUP_ID
get information about a certain backup
PBT_CHAIN
get information about the whole backup chain for a certain backup

Links
Other Structs


_PRL_VM_BACKUP_TYPE Enumeration

_PRL_VM_BACKUP_TYPE Enumeration
Other Structs

Hint about the type of VE inside a backup archive

Syntax
enum _PRL_VM_BACKUP_TYPE {
  PVBT_VM = 0,
  PVBT_CT_VZFS = 1,
  PVBT_CT_PLOOP = 2,
  PVBT_CT_VZWIN = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_BOOT_ORDER Enumeration

_PRL_VM_BOOT_ORDER Enumeration
Other Structs

VM boot order

Syntax
enum _PRL_VM_BOOT_ORDER {
  PBO_HDD_CD_FLOPPY = 0,
  PBO_FLOPPY_HDD_CD = 1,
  PBO_CD_HDD_FLOPPY = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_COLOR Enumeration

_PRL_VM_COLOR Enumeration
PRL_VM Structs

VM colors

Syntax
enum _PRL_VM_COLOR {
  PVC_COLOR_RED = 0x00FA645A,
  PVC_COLOR_ORANGE = 0x00F6AA44,
  PVC_COLOR_YELLOW = 0x00EFDB47,
  PVC_COLOR_GREEN = 0x00B4D747,
  PVC_COLOR_BLUE = 0x005AA3FF,
  PVC_COLOR_PURPLE = 0x00C08ED8,
  PVC_COLOR_GREY = 0x00808080,
  PVC_NO_COLOR = 0x00000000
};
File

PrlEnums.h

Links
PRL_VM Structs


_PRL_VM_COMMIT_FLAGS Enumeration

_PRL_VM_COMMIT_FLAGS Enumeration
Other Structs

PrlVm_CommitEx flags

Syntax
enum _PRL_VM_COMMIT_FLAGS {
  PVCF_DESTROY_HDD_BUNDLE = 1<<(PACF_MAX+1),
  PVCF_WAIT_FOR_APPLY = 1<<(PACF_MAX+2),
  PEVF_WAIT_FOR_APPLY = PVCF_WAIT_FOR_APPLY,
  PVCF_DESTROY_HDD_BUNDLE_FORCE = 1<<(PACF_MAX+3),
  PVCF_DETACH_HDD_BUNDLE = 1<<(PACF_MAX+4),
  PVCF_RENAME_EXT_DISKS = 1<<(PACF_MAX+5)
};
File

PrlCommandsFlags.h

Members

PVCF_DESTROY_HDD_BUNDLE
specifies to destroy HDD bundle physically on hard disk remove operation
PVCF_WAIT_FOR_APPLY
wait for apply
PEVF_WAIT_FOR_APPLY
to provide compatibility
PVCF_DESTROY_HDD_BUNDLE_FORCE
destroy HDD bundle physically even if used in snapshots

Links
Other Structs


_PRL_VM_CONFIG_SECTIONS Enumeration

_PRL_VM_CONFIG_SECTIONS Enumeration
Other Structs

VM configuration sections

Syntax
enum _PRL_VM_CONFIG_SECTIONS {
  PVC_VALIDATE_CHANGES_ONLY = 0,
  PVC_ALL = 1,
  PVC_GENERAL_PARAMETERS = 2,
  PVC_BOOT_OPTION = 3,
  PVC_REMOTE_DISPLAY = 4,
  PVC_SHARED_FOLDERS = 5,
  PVC_CPU = 6,
  PVC_MAIN_MEMORY = 7,
  PVC_VIDEO_MEMORY = 8,
  PVC_FLOPPY_DISK = 9,
  PVC_CD_DVD_ROM = 10,
  PVC_HARD_DISK = 11,
  PVC_NETWORK_ADAPTER = 12,
  PVC_SOUND = 13,
  PVC_SERIAL_PORT = 14,
  PVC_PARALLEL_PORT = 15,
  PVC_IDE_DEVICES = 16,
  PVC_SCSI_DEVICES = 17,
  PVC_GENERIC_PCI = 18,
  PVC_OFFLINE_MANAGEMENT_SETTINGS = 19,
  PVC_LICENSE_RESTRICTIONS = 20,
  PVC_SATA_DEVICES = 21,
  PVC_LAST_SECTION = PVC_SATA_DEVICES
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_DEV_EMULATION_TYPE Enumeration

_PRL_VM_DEV_EMULATION_TYPE Enumeration
Other Structs

VM device emulation type

Syntax
enum _PRL_VM_DEV_EMULATION_TYPE {
  PDT_ANY_TYPE = 0xffff,
  PDT_USE_REAL_DEVICE = 0,
  PDT_USE_IMAGE_FILE = 1,
  PDT_USE_OUTPUT_FILE = 2,
  PDT_USE_OTHER = 3,
  PDT_USE_DIRECT_ASSIGN = 4,
  PDT_USE_FILE_SYSTEM = 5,
  PDT_USE_REAL_FLOPPY = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_HDD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_CDDVD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_SERIAL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_SERIAL_PORT_SOCKET_MODE = PDT_USE_OTHER,
  PDT_USE_REAL_PARALLEL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_PARALLEL_PORT_PRINTER_MODE = PDT_USE_OTHER,
  PDT_USE_PARALLEL_PORT_PRINT_TO_PDF_MODE = PDT_USE_IMAGE_FILE,
  PDT_USE_HOST_ONLY_NETWORK = PDT_USE_REAL_DEVICE,
  PDT_USE_SHARED_NETWORK = PDT_USE_IMAGE_FILE,
  PDT_USE_BRIDGE_ETHERNET = PDT_USE_OUTPUT_FILE,
  PDT_USE_AC97_SOUND = PDT_USE_REAL_DEVICE,
  PDT_USE_CREATIVE_SB16_SOUND = PDT_USE_IMAGE_FILE,
  PDT_USE_REAL_USB_CONTROLLER = PDT_USE_REAL_DEVICE,
  PDT_USE_BOOTCAMP = PDT_USE_OTHER
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration

_PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration
Other Structs

App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app

Syntax
enum _PRL_VM_EXEC_APP_FILE_DESCRIPTOR {
  PFD_STDOUT = 1<<(PACF_MAX+1),
  PFD_STDERR = 1<<(PACF_MAX+2),
  PFD_STDIN = 1<<(PACF_MAX+3),
  PFD_ALL = (PFD_STDOUT | PFD_STDERR | PFD_STDIN)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration

_PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration
Other Structs

Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest

Syntax
enum _PRL_VM_EXEC_RUN_PROGRAM_MODES {
  PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY = 1<<(PACF_MAX+4),
  PRPM_RUN_PROGRAM_IN_SHELL = 1<<(PACF_MAX+5),
  PRPM_RUN_PROGRAM_ENTER = 1<<(PACF_MAX+6)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_VM_LOCATION Enumeration

_PRL_VM_LOCATION Enumeration
PRL_VM Structs

VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive

Syntax
enum _PRL_VM_LOCATION {
  PVL_UNKNOWN = 0,
  PVL_LOCAL_FS = 1,
  PVL_REMOTE_FS = 2,
  PVL_USB_DRIVE = 3,
  PVL_FIREWIRE_DRIVE = 4
};
File

PrlEnums.h

Links
PRL_VM Structs


_PRL_VM_MIGRATION_FLAGS Enumeration

_PRL_VM_MIGRATION_FLAGS Enumeration
Other Structs

VM migration functionality flags set

Syntax
enum _PRL_VM_MIGRATION_FLAGS {
  PVMSL_LOW_SECURITY = PSL_LOW_SECURITY,
  PVMSL_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PVMSL_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PVMT_COLD_MIGRATION = 1<<(PACF_MAX+1),
  PVMT_WARM_MIGRATION = 1<<(PACF_MAX+2),
  PVMT_HOT_MIGRATION = 1<<(PACF_MAX+3),
  PVM_DONT_RESUME_VM = 1<<(PACF_MAX+4),
  PVMT_DONT_RESUME_VM = PVM_DONT_RESUME_VM,
  PVMT_CLONE_MODE = 1<<(PACF_MAX+5),
  PVMT_SWITCH_TEMPLATE = 1<<(PACF_MAX+6),
  PVMT_CHANGE_SID = 1<<(PACF_MAX+7),
  PVMT_IGNORE_EXISTING_BUNDLE = 1<<(PACF_MAX+8),
  PVMT_REMOVE_SOURCE_BUNDLE = 1<<(PACF_MAX+9)
};
File

PrlCommandsFlags.h

Type Parameters

PVMT_COLD_MIGRATION
VM migration with interruption of VM services (VM will be stopped on migration time).
PVMT_WARM_MIGRATION
VM services will have quite long downtime during migration but won't be interrupted.
PVMT_HOT_MIGRATION
VM services will have short downtime during migration without any interruption.
PVMT_DONT_RESUME_VM
do not start running VM after migration
PVMT_CLONE_MODE
preserves source VM
PVMT_SWITCH_TEMPLATE
applable just in clone mode - lets to clone remotely VM to template
PVMT_CHANGE_SID
for Windows VMs/containers lets to change SID after remote clone
PVMT_IGNORE_EXISTING_BUNDLE
do not fail if Vm bundle exist. For clone Vm on mounted iSCSI storage

Links
Other Structs


_PRL_VM_MOUSE_CURSOR_STATE Enumeration

_PRL_VM_MOUSE_CURSOR_STATE Enumeration
Other Structs
Syntax
enum _PRL_VM_MOUSE_CURSOR_STATE {
  PTS_NO_CURSOR = 0,
  PTS_SLIDING_CURSOR = 1,
  PTS_MOVING_CURSOR = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_MOUSE_STATE Enumeration

_PRL_VM_MOUSE_STATE Enumeration
Other Structs
Syntax
enum _PRL_VM_MOUSE_STATE {
  PTS_RELATIVE_MOUSE = 0,
  PTS_SLIDING_MOUSE = 1,
  PTS_ABSOLUTE_MOUSE = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_NET_ADAPTER_TYPE Enumeration

_PRL_VM_NET_ADAPTER_TYPE Enumeration
PRL_VM Structs
Syntax
enum _PRL_VM_NET_ADAPTER_TYPE {
  PNT_UNDEFINED = 0,
  PNT_RTL = 1,
  PNT_E1000 = 2,
  PNT_VIRTIO = 3,
  PNT_E1000E = 4
};
File

PrlEnums.h

Links
PRL_VM Structs


_PRL_VM_NET_ADAPTER_WIFI_RULE Enumeration

_PRL_VM_NET_ADAPTER_WIFI_RULE Enumeration
Other Structs
Syntax
enum _PRL_VM_NET_ADAPTER_WIFI_RULE {
  PNWR_GENERATED_MAC = 0,
  PNWR_HOST_MAC = 1,
  PNWR_AUTO = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_NORMAL_START_FLAGS Enumeration

_PRL_VM_NORMAL_START_FLAGS Enumeration
Other Structs

VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)

Syntax
enum _PRL_VM_NORMAL_START_FLAGS {
  PNSF_VM_START_WAIT = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Members

PNSF_VM_START_WAIT
PNSF_VM_START_IGNORE_HA_CLUSTER = 1<<(PACF_MAX+1), This flag is unused

Links
Other Structs


_PRL_VM_PRIORITY Enumeration

_PRL_VM_PRIORITY Enumeration
Other Structs

Background/foreground VM processes priority

Syntax
enum _PRL_VM_PRIORITY {
  PVR_PRIORITY_LOW = 0,
  PVR_PRIORITY_NORMAL = 1,
  PVR_PRIORITY_HIGH = 2
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_REMOTE_DISPLAY_MODE Enumeration

_PRL_VM_REMOTE_DISPLAY_MODE Enumeration
Other Structs

Parallels remote desktop modes

Syntax
enum _PRL_VM_REMOTE_DISPLAY_MODE {
  PRD_DISABLED = 0,
  PRD_AUTO,
  PRD_MANUAL
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_SMARTGUARD_SCHEMA Enumeration

_PRL_VM_SMARTGUARD_SCHEMA Enumeration
PRL_VM Structs

SmartGuard schema

Syntax
enum _PRL_VM_SMARTGUARD_SCHEMA {
  PVSS_OPTIMIZED_FOR_TIME_MACHINE = 1,
  PVSS_CUSTOM = 2
};
File

PrlEnums.h

Members

PVSS_OPTIMIZED_FOR_TIME_MACHINE
Automatic schema for time machine
PVSS_CUSTOM
User defined schema

Links
PRL_VM Structs


_PRL_VM_START_LOGIN_MODE Enumeration

_PRL_VM_START_LOGIN_MODE Enumeration
Other Structs

VM start login mode

Syntax
enum _PRL_VM_START_LOGIN_MODE {
  PLM_START_ACCOUNT = 0,
  PLM_ROOT_ACCOUNT = 1,
  PLM_USER_ACCOUNT = 2,
  PLM_START_ACOUNT = PLM_START_ACCOUNT,
  PLM_ROOT_ACOUNT = PLM_ROOT_ACCOUNT,
  PLM_USER_ACOUNT = PLM_USER_ACCOUNT
};
File

PrlEnums.h

Members

PLM_START_ACOUNT
Obsolete values for compatibility

Links
Other Structs


_PRL_VM_START_MODE Enumeration

_PRL_VM_START_MODE Enumeration
Other Structs

VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation

Syntax
enum _PRL_VM_START_MODE {
  PSM_VM_START = 1<<(PACF_MAX+1),
  PSM_VM_SAFE_START = 1<<(PACF_MAX+2),
  PSM_VM_START_FOR_COMPACT = 1<<(PACF_MAX+3),
  PSM_VM_START_LAST_ITEM = PSM_VM_START_FOR_COMPACT
};
File

PrlCommandsFlags.h

Members

PSM_VM_START_LAST_ITEM
PSM_VM_START_LAST_ITEM has to be equal the last mode

Links
Other Structs


_PRL_VM_STATISTICS_FLAGS Enumeration

_PRL_VM_STATISTICS_FLAGS Enumeration
Other Structs

PrlVm_GetStatisticsEx flags

Syntax
enum _PRL_VM_STATISTICS_FLAGS {
  PVMSF_HOST_DISK_SPACE_USAGE_ONLY = 1<<(PACF_MAX+1),
  PVMSF_GUEST_OS_INFORMATION_ONLY = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


_PRL_VM_STOP_FLAGS Enumeration

_PRL_VM_STOP_FLAGS Enumeration
PRL_VM Structs

Virtual machine shutdown options.

Syntax
enum _PRL_VM_STOP_FLAGS {
  PSF_FORCE = 1<<(PACF_MAX+1),
  PSF_NOFORCE = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Remarks
  • PSF_FORCE : forcibly stop the virtual machine if shutdown timed out.
  • PSF_NOFORCE : do nothing if the virtual machine shutdown timed out.
Links
PRL_VM Structs


_PRL_VM_STOP_MODE Enumeration

_PRL_VM_STOP_MODE Enumeration
PRL_VM Structs

Vm stop modes

Syntax
enum _PRL_VM_STOP_MODE {
  PSM_KILL = 0,
  PSM_SHUTDOWN = 1,
  PSM_ACPI = 2,
  PSM_LAST = PSM_ACPI
};
File

PrlEnums.h

Members

PSM_LAST
Should equals to the last item

Links
PRL_VM Structs


_PRL_VM_STORE_VALUE_FLAGS Enumeration

_PRL_VM_STORE_VALUE_FLAGS Enumeration
Other Structs

Store value by specified keys on server options.

Syntax
enum _PRL_VM_STORE_VALUE_FLAGS {
  PSV_CALC_BOOT_CAMP_SIZE = 1<<(PACF_MAX+1)
};
File

PrlCommandsFlags.h

Remarks
  • PSV_CALC_BOOT_CAMP : calculate VM size with Boot Camp disks
Links
Other Structs


PRL_VM Structs Enumerations

PRL_VM Structs Enumerations
PRL_VM Structs Legend
Enumerations
Name | Description
_PRL_VM_ACTION_ON_STOP | Action when VM gets stopped
_PRL_VM_COLOR | VM colors
_PRL_VM_LOCATION | VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive
_PRL_VM_NET_ADAPTER_TYPE |
_PRL_VM_SMARTGUARD_SCHEMA | SmartGuard schema
_PRL_VM_STOP_FLAGS | Virtual machine shutdown options.
_PRL_VM_STOP_MODE | Vm stop modes
_PRL_VM_TYPE |
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION |
PRL_VM_ACTION_ON_STOP | Action when VM gets stopped
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BACKUP_FLAGS | VM backup functionality flags set
PRL_VM_BACKUP_TYPE | Hint about the type of VE inside a backup archive
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_COLOR | VM colors
PRL_VM_COMMIT_FLAGS | PrlVm_CommitEx flags
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest
PRL_VM_LOCATION | VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive
PRL_VM_MIGRATION_FLAGS | VM migration functionality flags set
PRL_VM_MOUSE_CURSOR_STATE |
PRL_VM_MOUSE_STATE |
PRL_VM_NET_ADAPTER_TYPE |
PRL_VM_NET_ADAPTER_WIFI_RULE |
PRL_VM_NORMAL_START_FLAGS | VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_SMARTGUARD_SCHEMA | SmartGuard schema
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation
PRL_VM_STATISTICS_FLAGS | PrlVm_GetStatisticsEx flags
PRL_VM_STOP_FLAGS | Virtual machine shutdown options.
PRL_VM_STOP_MODE | Vm stop modes
PRL_VM_STORE_VALUE_FLAGS | Store value by specified keys on server options.
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_TYPE |
PRL_VM_TYPE_FLAGS |
PRL_VM_WINDOW_MODE | VM window mode


Legend

Legend
PRL_VM Structs
Legend
Enumeration


_PRL_VM_TOOLS_STATE Enumeration

_PRL_VM_TOOLS_STATE Enumeration
Other Structs

Virtual machine tools states enumeration

Syntax
enum _PRL_VM_TOOLS_STATE {
  PTS_UNKNOWN = 0,
  PTS_POSSIBLY_INSTALLED = PTS_UNKNOWN,
  PTS_NOT_INSTALLED = 1,
  PTS_INSTALLED = 2,
  PTS_OUTDATED = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_VM_TYPE Enumeration

_PRL_VM_TYPE Enumeration
PRL_VM Structs
Syntax
enum _PRL_VM_TYPE {
  PVT_VM = 0,
  PVT_CT = 1
};
File

PrlEnums.h

Links
PRL_VM Structs


_PRL_VM_TYPE_FLAGS Enumeration

_PRL_VM_TYPE_FLAGS Enumeration
Other Structs
Syntax
enum _PRL_VM_TYPE_FLAGS {
  PVTF_VM = 1<<(PACF_MAX+1),
  PVTF_CT = 1<<(PACF_MAX+2)
};
File

PrlCommandsFlags.h

Links
Other Structs


PRL_VM Types Types

PRL_VM Types Types
PRL_VM Types
Types
Name | Description
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_STOP_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_ACTION_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BACKUP_TYPE_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_COLOR_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_LOCATION_PTR |
PRL_VM_NET_ADAPTER_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_SMARTGUARD_SCHEMA_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_TYPE_PTR |
PRL_VM_WINDOW_MODE_PTR |


_PRL_VM_WINDOW_MODE Enumeration

_PRL_VM_WINDOW_MODE Enumeration
Other Structs

VM window mode

Syntax
enum _PRL_VM_WINDOW_MODE {
  PWM_DEFAULT_WINDOW_MODE = 0,
  PWM_WINDOWED_WINDOW_MODE = 1,
  PWM_FULL_SCREEN_WINDOW_MODE = 2,
  PWM_COHERENCE_WINDOW_MODE = 3,
  PWM_MODALITY_WINDOW_MODE = 4
};
File

PrlEnums.h

Links
Other Structs


_PRL_VMCTG_EVENT Enumeration

_PRL_VMCTG_EVENT Enumeration
Other Structs

Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)

Syntax
enum _PRL_VMCTG_EVENT {
  TEV_DATA_RECEIVED,
  TEV_CONNECTED,
  TEV_DISCONNECTED
};
File

PrlEnums.h

Members

TEV_DATA_RECEIVED
pData is PRL_TOOL_DATA_RECEIVED
TEV_CONNECTED
pData is null
TEV_DISCONNECTED
pData is null

Links
Other Structs


_PRL_VMCTG_TOOL_DATA_RECEIVED Structure

_PRL_VMCTG_TOOL_DATA_RECEIVED Structure
Other Structs
Syntax
struct _PRL_VMCTG_TOOL_DATA_RECEIVED {
  PRL_SIZE uSize;
  PRL_VOID_PTR pData;
  PRL_BOOL bKeepBuffer;
};
File

PrlIoStructs.h

Links
Other Structs


_PRL_VMCTG_TOOL_DESC Structure

_PRL_VMCTG_TOOL_DESC Structure
Other Structs

Describes the tool to be registered @see PrlVm_RegisterTool()

Syntax
struct _PRL_VMCTG_TOOL_DESC {
  PRL_SIZE uSize;
  PRL_UINT32 nToolId;
  PRL_VMCTG_TOOL_HANDLER_PTR pCallBack;
  PRL_VOID_PTR pUserData;
};
File

PrlIoStructs.h

Links
Other Structs


PRL_VOID Types Types

PRL_VOID Types Types
PRL_VOID Types
Types
Name | Description
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |


_PRL_VTD_STATUS_CODE Enumeration

_PRL_VTD_STATUS_CODE Enumeration
Other Structs

VTD status code

Syntax
enum _PRL_VTD_STATUS_CODE {
  PVSC_DMAR_NOT_FOUND = -5,
  PVSC_DMAR_ERROR = -4,
  PVSC_ACPI_ERROR = -3,
  PVSC_HARDWARE_ERROR = -2,
  PVSC_INTERNAL_ERROR = -1,
  PVSC_NOT_PRESENT = 0,
  PVSC_ENABLED = 1
};
File

PrlEnums.h

Links
Other Structs


_PRL_WINDOW_CORNERS Enumeration

_PRL_WINDOW_CORNERS Enumeration
Other Structs

Window corners

Syntax
enum _PRL_WINDOW_CORNERS {
  PWC_TOP_LEFT_CORNER = 0,
  PWC_TOP_RIGHT_CORNER = 1,
  PWC_BOTTOM_LEFT_CORNER = 2,
  PWC_BOTTOM_RIGHT_CORNER = 3
};
File

PrlEnums.h

Links
Other Structs


_PRL_WINDOW_EDGE_MASK Enumeration

_PRL_WINDOW_EDGE_MASK Enumeration
Other Structs

Edges where taskbar can be placed (in coherence mode).

Syntax
enum _PRL_WINDOW_EDGE_MASK {
  WINDOW_LEFT_EDGE_MASK = (0x1L << 0),
  WINDOW_TOP_EDGE_MASK = (0x1L << 1),
  WINDOW_RIGHT_EDGE_MASK = (0x1L << 2),
  WINDOW_BOTTOM_EDGE_MASK = (0x1L << 3),
  WINDOW_ALL_EDGE_MASK = WINDOW_LEFT_EDGE_MASK|WINDOW_TOP_EDGE_MASK|WINDOW_RIGHT_EDGE_MASK|WINDOW_BOTTOM_EDGE_MASK
};
File

PrlEnums.h

Links
Other Structs


See Also

See Also
PrlAcl_GetAccessForOthers Function
See Also

PrlAcl_SetAccessForOthers


See Also

See Also
PrlAcl_GetOwnerName Function
See Also

PrlAcl_IsCurrentSessionOwner


See Also

See Also
PrlAcl_SetAccessForOthers Function
See Also

PrlAcl_GetAccessForOthers


See Also

See Also
PrlApi_CreateCredentials Function
See Also

PrlSrv_SignCertificate


See Also

See Also
PrlApi_Deinit Function
See Also

PrlApi_Init


Example

Example
PrlApi_Init Function

The following example illustrates how to perform the necessary API library initialization.

The first step is to load the dynamic link library using the SdkWrap_Load function from the supplied wrapper library (SdkWrap is a helper library that contains just two functions for loading and unloading the API dynamic link library; the library is not documented in this guide).

The second step is to initialize the Parallels API using the PrlApi_Init function.

Once the above steps are completed, you are ready to make other API calls, such as PrlSrv_Login and others.

On program exit, you must cal the PrlApi_Deinit function to deinitialize the API, and the SdkWrap_Unload function to unload the dynamic link libraries.

int main(int argc, char* argv[])
{
   // Pick the correct dynamic library depending on the platform.
   #ifdef _WIN_
      #define SDK_LIB_NAME "prl_sdk.dll"
   #elif defined(_LIN_)
      #define SDK_LIB_NAME "libprl_sdk.so"
   #elif defined(_MAC_)
      #define SDK_LIB_NAME "libprl_sdk.dylib"
   #endif

   // Load the dynamic library.
   // If the library cannot be found, try searching for it.
   if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
      PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
   {
      fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
      return -1;
   }

   // Initialize the API.
   PRL_RESULT ret;
   ret = PrlApi_Init(PARALLELS_API_VER);
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Init returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // your program code goes here...

   // Deinitialize the API.
   ret = PrlApi_Deinit();
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Deinit returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // Unload dynamic link libraries.
   SdkWrap_Unload();
   return 0;
}


See Also

See Also
PrlApi_Init Function
See Also

PrlApi_Deinit


See Also

See Also
PrlApi_InitEx Function
See Also

PrlApi_Deinit PrlApi_Init


See Also

See Also
PrlBootDev_GetIndex Function
See Also

PrlBootDev_SetIndex


See Also

See Also
PrlBootDev_GetSequenceIndex Function
See Also

PrlBootDev_SetSequenceIndex


See Also

See Also
PrlBootDev_GetType Function
See Also

PrlBootDev_SetType


See Also

See Also
PrlBootDev_IsInUse Function
See Also

PrlBootDev_SetInUse


See Also

See Also
PrlBootDev_SetIndex Function
See Also

PrlBootDev_GetIndex


See Also

See Also
PrlBootDev_SetInUse Function
See Also

PrlBootDev_IsInUse

PrlBootDev_Remove


Example

Example
PrlBootDev_SetSequenceIndex Function
PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);
ret = PrlJob_Wait(hJobBeginEdit, 10000);
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// Modify boot options.
// Set boot device list as follows:
// 0. CD/DVD drive.
// 1. Hard disk.
// 2. Network adapter.
// 3. Floppy disk drive.
//
PRL_UINT32 nDevCount; // Device count.
PRL_HANDLE hDevice;   // A handle to the device.
PRL_DEVICE_TYPE devType; // Device type.

// Get the total number of devices.
ret = PrlVm_GetBootDevCount(hVm, &nDevCount);

// Iterate through the device list.
// Get a handle for each available device.
// Set an index for a device in the boot list.
for (int i = 0; i < nDevCount; ++i)
{
    ret = PrlVm_GetBootDev(hVm, i, &hDevice);
    ret = PrlBootDev_GetType(hDevice, &devType);

    if (devType == PDE_OPTICAL_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 0);
    }
    if (devType == PDE_HARD_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 1);
    }
    else if (devType == PDE_GENERIC_NETWORK_ADAPTER)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 2);
    }
    else if (devType == PDE_FLOPPY_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 3);
    }
    else
    {
        PrlBootDev_Remove(hDevice);
    }
}

// Commit the changes.
hJobCommit = PrlVm_Commit(hVm);

// Check the results of the commit operation.
ret = PrlJob_Wait(hJobCommit, 10000);
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


See Also

See Also
PrlBootDev_SetSequenceIndex Function
See Also

PrlBootDev_GetSequenceIndex


See Also

See Also
PrlBootDev_SetType Function
See Also

PrlBootDev_GetType


PrlBuffer Functions

PrlBuffer Functions
PrlBuffer Legend
Functions
Name | Description
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.


Legend

Legend
PrlBuffer
Legend
Method


See Also

See Also
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_AsyncCaptureScreenRegionToFile Function
See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_SyncCaptureScreenRegionToFile Function
See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile


See Also

See Also
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile


See Also

See Also
PrlDisk_Coagulate Function
See Also

PrlDisk_GetSnapshotsTree

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState


See Also

See Also
PrlDisk_Compact Function
See Also

PrlDisk_IsCompactable


See Also

See Also
PrlDisk_ConvertToCurrent Function
See Also

PrlDisk_ConvertToCurrent_Local


See Also

See Also
PrlDisk_ConvertToCurrent_Local Function
See Also

PrlDisk_ConvertToCurrent


See Also

See Also
PrlDisk_CreateDisk Function
See Also

PrlDisk_CreateDisk_Local

PrlDisk_Free


See Also

See Also
PrlDisk_CreateDisk_Local Function
See Also

PrlDisk_CreateDisk

PrlDisk_Free


See Also

See Also
PrlDisk_CreateState Function
See Also

PrlDisk_SwitchToState

PrlDisk_DeleteState


See Also

See Also
PrlDisk_DecreaseCapacity Function
See Also

PrlDisk_IncreaseCapacity


See Also

See Also
PrlDisk_DeleteState Function
See Also

PrlDisk_CreateState

PrlDisk_SwitchToState


See Also

See Also
PrlDisk_GetSnapshotsCount Function
See Also

PrlDisk_GetSnapshotsTree

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState


See Also

See Also
PrlDisk_GetSnapshotsTree Function
See Also

PrlDisk_GetSnapshotsCount

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState


See Also

See Also
PrlDisk_GetUserParameter Function
See Also

PrlDisk_SetUserParameter


See Also

See Also
PrlDisk_IncreaseCapacity Function
See Also

PrlDisk_DecreaseCapacity


See Also

See Also
PrlDisk_IsCompactable Function
See Also

PrlDisk_Compact


See Also

See Also
PrlDisk_OpenDisk Function
See Also

PrlDisk_OpenDisk_Local

PrlDisk_Free


See Also

See Also
PrlDisk_OpenDisk_Local Function
See Also

PrlDisk_OpenDisk

PrlDisk_Free


See Also

See Also
PrlDisk_Read Function
See Also

PrlDisk_Write


See Also

See Also
PrlDisk_SetSharedDirectory Function
See Also

PrlDisk_SetSharedDirectory_Local


See Also

See Also
PrlDisk_SetSharedDirectory_Local Function
See Also

PrlDisk_SetSharedDirectory


See Also

See Also
PrlDisk_SetUserParameter Function
See Also

PrlDisk_GetUserParameter


See Also

See Also
PrlDisk_SwitchToState Function
See Also

PrlDisk_CreateState

PrlDisk_DeleteState

PrlDisk_GetSnapshotsTree


See Also

See Also
PrlDisk_Write Function
See Also

PrlDisk_Read


See Also

See Also
PrlDispCfg_CanChangeDefaultSettings Function
See Also

PrlDispCfg_SetCanChangeDefaultSettings


See Also

See Also
PrlDispCfg_GetConfirmationsList Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


See Also

See Also
PrlDispCfg_GetCpuFeaturesMaskEx Function
See Also

PrlDispCfg_SetCpuFeaturesMaskEx


See Also

See Also
PrlDispCfg_GetMaxReservMemLimit Function
See Also

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_GetMaxVmMem Function
See Also

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetMinReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_GetMinSecurityLevel Function
See Also

PrlDispCfg_SetMinSecurityLevel

PrlSrv_Login

PrlSrv_LoginLocal


See Also

See Also
PrlDispCfg_GetMinVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetMobileAdvancedAuthMode Function
See Also

PrlDispCfg_SetMobileAdvancedAuthMode


See Also

See Also
PrlDispCfg_GetRecommendMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetReservedMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_IsAdjustMemAuto Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_IsProxyEnabled Function
See Also

PrlDispCfg_SetProxyConnectionCreds


See Also

See Also
PrlDispCfg_IsSendStatisticReport Function
See Also

PrlDispCfg_SetSendStatisticReport


See Also

See Also
PrlDispCfg_SetAdjustMemAuto Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto


See Also

See Also
PrlDispCfg_SetCanChangeDefaultSettings Function
See Also

PrlDispCfg_CanChangeDefaultSettings


See Also

See Also
PrlDispCfg_SetConfirmationsList Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


See Also

See Also
PrlDispCfg_SetCpuFeaturesMaskEx Function
See Also

PrlDispCfg_GetCpuFeaturesMaskEx


See Also

See Also
PrlDispCfg_SetMaxReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_SetMinReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetMinSecurityLevel Function
See Also

PrlDispCfg_GetMinSecurityLevel


See Also

See Also
PrlDispCfg_SetMinVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_SetMobileAdvancedAuthMode Function
See Also

PrlDispCfg_GetMobileAdvancedAuthMode


See Also

See Also
PrlDispCfg_SetRecommendMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem


See Also

See Also
PrlDispCfg_SetReservedMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetSendStatisticReport Function
See Also

PrlDispCfg_IsSendStatisticReport


Example

Example
PrlEvent_CreateAnswerEvent Function

The following is a complete example that demonstrates how to handle events and how to answer to Parallels Service questions. In the example, we create a blank virtual machine and try to add a virtual hard drive to it with the size larger than the free disk space available on the physical drive. This will trigger an event on the Parallels Service side and a question will be sent to the client asking if we really want to create a drive like that. The virtual machine creation operation will not continue unless we send an answer to the Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>
#include <stdlib.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

#define MY_JOB_TIMEOUT 10000 // Default timeout to use in the PrlJob_Wait function.
#define MY_HDD_SIZE 70*1024 // The size of the new hard drive.
#define MY_STR_BUF_SIZE 1024 // The default buffer size to use for string output.

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event on the
// Parallels Service, which will result in Service sending us a question.
static PRL_RESULT create_big_hdd(PRL_HANDLE hVm);

// The callback function (event handler).
static PRL_RESULT callback(PRL_HANDLE, PRL_VOID_PTR);

////////////////////////////////////////////////////////////////////////////////

int main(int argc, char* argv[])
{
    // Pick the correct dynamic library file depending on the platform.
    #ifdef _WIN_
        #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
        #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
        #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the dynamic library.
    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        // Error handling goes here...
        return -1;
    }

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;
    PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
    PRL_HANDLE hServer = PRL_INVALID_HANDLE;

    // Initialize API library.
    err = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(err))
    {
        // Error handling goes here...
        return -1;
    }

    // Create server object.
    PrlSrv_Create(&hServer);

    // Log in.
    hJob = PrlSrv_Login(
        hServer, // Server handle
        "10.30.22.82", // Host IP address
        "jdoe", // User
        "secret", // Password
        0, // Previous session ID
        0, // Port number
        0, // Timeout
        PSL_NORMAL_SECURITY); // Security

    ret = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if (PRL_FAILED( nJobResult))
    {
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Create a new virtual machine.
    PRL_HANDLE hVm;
    PrlSrv_CreateVm(hServer, &hVm);
    PrlVm_SetName(hVm, "My simple VM");

    // Register the virtual machine with the Parallels Service.
    hJob = PrlVm_Reg(hVm, "", PRL_FALSE);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    // Register the event handler with the Service.
    // The second parameter is a pointer to our callback function.
    PrlSrv_RegEventHandler(hServer, &callback, NULL);

    // Try creating a virtual hard drive larger than the
    // free space available (increase MY_HDD_SIZE value if needed).
    // This should produce an event that will
    // contain a question from the Parallels Service.
    create_big_hdd(hVm);

    //
    // At this point, the background thread should call the
    // callback function.
    //

    // We can now clean up and exit the program.
    // Unregister the event handler and log off.
    PrlSrv_UnregEventHandler(hServer, &callback, NULL);
    hJob = PrlSrv_Logoff(hServer);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );
    PrlApi_Deinit();
    SdkWrap_Unload();
    return 0;
}

////////////////////////////////////////////////////////////////////////////////
// The callback function implementation.
// The event handling is demonstrated here.
//
static PRL_RESULT callback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType(hEvent, &nHandleType);

    // A callback function will be called more than once.
    // It will be called for every job that we initiate and it
    // will be called for the event that we intentionally trigger.
    // In this example, we are interested in events only.
    if (nHandleType != PHT_EVENT)
    {
        return PrlHandle_Free(hEvent);
    }

    // Get the type of the event received.
    PRL_EVENT_TYPE type;
    PrlEvent_GetType(hEvent, &type);

    // See if the received event is a "question".
    if (type == PET_DSP_EVT_VM_QUESTION)
    {
        PRL_UINT32 nParamsCount = 0;
        PRL_RESULT err = PRL_ERR_UNINITIALIZED;

        // Extract the text of the question and display it on the screen.
        // The question is stored in the object in the "event message" property.
        PRL_BOOL bIsBriefMessage = true;
        char errMsg [MY_STR_BUF_SIZE];
        PRL_UINT32 nBufSize = MY_STR_BUF_SIZE;

        PrlEvent_GetErrString(hEvent, bIsBriefMessage, errMsg, &nBufSize);
        printf("Question: %s\n\n", errMsg);

        // Extract answer choices. They are stored in the
        // hEvent object as event parameters.
        // First, determine the number of parameters.
        err = PrlEvent_GetParamsCount(hEvent, &nParamsCount);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[3]%.8X: %s\n", err,
                PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Declare an array to hold the choices information.
        PRL_UINT32_PTR choices =(PRL_UINT32_PTR)
            malloc(nParamsCount * sizeof(PRL_UINT32));

        // Now, itereate through the parameter list obtaining a
        // handle of type PHT_EVENT_PARAMETER that will contain
        // an individual parameter data.
        for(PRL_UINT32 nParamIndex = 0; nParamIndex < nParamsCount; ++nParamIndex)
        {
            PRL_HANDLE hParam; // this will receive the event parameter handle.
            PRL_RESULT err = PRL_ERR_UNINITIALIZED;

            // The PrlEvent_GetParam function obtains a handle of type
            // PHT_EVENT_PARAMETER containing (in this case) an answer choice.
            err = PrlEvent_GetParam(hEvent, nParamIndex, &hParam);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[4]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Get the answer description that can be shown to the user.
            // First, obtain the event parameter value.
            err = PrlEvtPrm_ToUint32(hParam, &choices[nParamIndex]);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[9]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Now, get the answer description using the
            // event parameter value as input in the following call.
            char sDesc [MY_STR_BUF_SIZE];
            err = PrlApi_GetResultDescription(choices[nParamIndex], true, sDesc, &nBufSize);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[8]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Display the answer choice on the screen.
            printf("Answer choice: %s\n", sDesc);
            PrlHandle_Free(hParam);
        }

        // Select an answer choice (we are using the "No" answer here) and
        // create a valid answer object (hAnswer).
        PRL_HANDLE hAnswer;
        err = PrlEvent_CreateAnswerEvent(hEvent, &hAnswer, choices[1]);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[A]%.8X: %s\n", err, PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Obtain a server handle.
        PRL_HANDLE hServer;
        PrlEvent_GetServer(hEvent, &hServer);

        // Send the answer handle to the Parallels Service.
        PrlSrv_SendAnswer(hServer, hAnswer);

        free(choices);
        PrlHandle_Free(hServer);
        PrlHandle_Free(hAnswer);
    }
    else // other event type
    {
        PrlHandle_Free(hEvent);
    }

    return PRL_ERR_SUCCESS;
}

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event.
PRL_RESULT create_big_hdd(PRL_HANDLE hVm)
{
    PRL_HANDLE hJobBeginEdit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobCommit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;

    // Timestamp the beginning of the configuration changes operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    err = PrlJob_Wait(hJobBeginEdit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[B]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Create a new device handle.
    // This will be our new virtual hard disk.
    PRL_HANDLE hHDD;
    err = PrlVm_CreateVmDev(
            hVm, // Target virtual machine.
            PDE_HARD_DISK, // Device type.
            &hHDD ); // Device handle.

    // Set disk type to "expanding".
    err = PrlVmDevHd_SetDiskType(hHDD, PHD_EXPANDING_HARD_DISK);

    // Set max disk size, in megabytes.
    err = PrlVmDevHd_SetDiskSize(hHDD, MY_HDD_SIZE);

    // This option determines whether the image file will be split
    // into chunks or created as a single file.
    err = PrlVmDevHd_SetSplitted(hHDD, PRL_FALSE);

    // Choose and set the name for the new image file.
    err = PrlVmDev_SetFriendlyName(hHDD, "harddisk4.hdd");
    err = PrlVmDev_SetSysName(hHDD, "harddisk4.hdd");

    // Set the emulation type.
    err = PrlVmDev_SetEmulatedType(hHDD, PDT_USE_IMAGE_FILE);

    // Enable the new disk on successful creation.
    err = PrlVmDev_SetEnabled(hHDD, PRL_TRUE);

    // Create the new image file.
    hJob = PrlVmDev_CreateImage(hHDD,
            PRL_TRUE, // Do not overwrite if file exists.
            PRL_FALSE ); // Use non-interactive mode.

    err = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    if (PRL_FAILED(err))
    {
        fprintf(stderr, "[C]%.8X: %s\n", err,
            PRL_RESULT_TO_STRING(err));
        PrlHandle_Free(hJob);
        return err;
    }

    // Commit the changes.
    hJobCommit = PrlVm_Commit(hVm);
    err = PrlJob_Wait(hJobCommit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[D]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING( nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }
    return PRL_ERR_SUCCESS;
}


See Also

See Also
PrlHandle_AddRef Function
See Also

PrlHandle_Free


See Also

See Also
PrlHandle_GetPackageId Function
See Also

PrlSrvInfo_GetStartTime PrlSrvInfo_GetStartTimeMonotonic


Example

Example
PrlJob_GetResult Function

The following code illustrates how to obtain a result from the job object using the login operation as an example.

// Log in to a Parallels Service.
hJob =
PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );

// Wait for the job to complete.
PrlJob_Wait( hJob, 10000 );

// Get a handle of type PHT_RESULT containing the results
// of the operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlJob_Wait Function
// Log in to Parallels Service.
// This is an asynchronous call.
// Returns a handle to the Job object.
PRL_HANDLE hJob = PrlSrv_Login(
    hServer, "10.30.23.105", "miket", "1q2w3e",
    0, 0, 0, PRL_SECURITY_LEVEL::PSL_LOW_SECURITY);

// Wait for the Job object to receive the results of the operation.
ret = PrlJob_Wait( hJob, 1000 );
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait returned with error (%s)\n",
        PRL_RESULT_TO_STRING(ret));
    return -1;
}

// Get the results from the Job object.
PRL_RESULT nJobResult;
ret = PrlJob_GetRetCode( hJob, &nJobResult );
if (PRL_FAILED( nJobResult ))
{
    printf("login job returned with error (%s)\n",
        PRL_RESULT_TO_STRING( nJobResult ));
    return -1;
}
else
    printf( "Login succeeded.\n" );

// Delete the Job handle.
PrlHandle_Free( hJob );


See Also

See Also
PrlReport_GetCombinedReportId Function
See Also

PrlReport_SetCombinedReportId


See Also

See Also
PrlReport_GetRating Function
See Also

PrlReport_SetRating


Example

Example
PrlResult_GetParam Function

The following example demonstrates using asynchronous function PrlSrv_GetSrvConfig synchronously, and the steps involved in obtaining a handle to an object of type PHT_SERVER_CONFIG (which is returned by PrlSrv_GetSrvConfig):

PRL_HANDLE hJob = PrlSrv_GetSrvConfig(hServer);

// Step 1 - emulate a synchronous call using PrlJob_Wait.

PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 2 - determine if PrlSrv_GetSrvConfig succeeded or failed
// using PrlJob_GetRetCode.

PrlJob_GetRetCode(hJob, &nJobResult);
if (PRL_FAILED(nJobResult))
{
    printf("PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 3 - Obtain a handle to the result object (a handle
// of type PHT_RESULT) using PrlJob_GetResult.

PRL_HANDLE hResult;
ret = PrlJob_GetResult(hJob, &hResult);
PrlHandle_Free(hJob); // hJob no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlJob_GetResult for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hResult);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 4 - Get a handle to the final result (in this case,
// a handle of type PHT_SERVER_CONFIG) using PrlResult_GetParam.
// For PHT_RESULT handles that contain more than one result, first use
// PrlResult_GetParamsCount, then use PrlResult_GetParamByIndex.

PRL_HANDLE hServerConfig;
ret = PrlResult_GetParam(hResult, &hServerConfig);
PrlHandle_Free(hResult); // hResult no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlResult_GetParam for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hServerConfig);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();

    return -1;
}

// At this point, a handle of type PHT_SERVER_CONFIG is available, and
// functions that operate on PHT_SERVER_CONFIG handles can be used on
// the handle.

PRL_UINT32 nCpuCount = 0;
PrlSrvCfg_GetCpuCount(hServerConfig, &nCpuCount);
printf("Number of CPUs: %d\n", nCpuCount);

PRL_CPU_MODE CpuMode;
PrlSrvCfg_GetCpuMode(hServerConfig, &CpuMode);
printf("CPU Mode: %d bit\n", CpuMode == PCM_CPU_MODE_32 ? 32 : 64);

PRL_CHAR szCpuModel[1024];
PRL_UINT32 nCpuModelSize = sizeof(szCpuModel);
memset(szCpuModel, 0, nCpuModelSize);
PrlSrvCfg_GetCpuModel(hServerConfig, szCpuModel, &nCpuModelSize);
printf("CPU Model: %s\n", szCpuModel);

PRL_UINT32 nCpuSpeed = 0;
PrlSrvCfg_GetCpuSpeed(hServerConfig, &nCpuSpeed);
printf("CPU Speed: %.3f MHz\n", nCpuSpeed / 1000.0);

PRL_CHAR szHostOsString[1024];
PRL_UINT32 nHostOsStringSize = sizeof(szHostOsString);
PrlSrvCfg_GetHostOsStrPresentation(hServerConfig, szHostOsString, &nHostOsStringSize);
printf("Host OS: %s\n", szHostOsString);

PrlHandle_Free(hServerConfig);


Example

Example
PrlResult_GetParamByIndex Function

The following example demonstrates using asynchronous function PrlSrv_GetVmList (getting the list of virtual machines), and the steps involved in obtaining handles to objects of type PHT_VIRTUAL_MACHINE returned by PrlSrv_GetVmList (each object contains information about an individual virtual machine):

PRL_RESULT DisplayVmList(const PRL_HANDLE &hServer)
{
    PRL_HANDLE hResult;
    PRL_RESULT nJobResult;

    // Get a list of virtual machines.
    PRL_HANDLE hJob = PrlSrv_GetVmList(hServer);

    // Wait for the job to complete.
    PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Check the results of PrlSrv_GetVmList.
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Get the results of PrlSrv_GetVmList.
    ret = PrlJob_GetResult(hJob, &hResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetResult returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hResult);
        PrlHandle_Free(hJob);
        return ret;
    }

    // Handle to result object is available,
    // job handle is not longer needed, so free it.
    PrlHandle_Free(hJob);

    // Iteratre through the result list.
    PRL_UINT32 nParamsCount = 0;
    ret = PrlResult_GetParamsCount(hResult, &nParamsCount);

    for (PRL_UINT32 i = 0; i < nParamsCount; ++i)
    {
        PRL_HANDLE hVm;

        // Get a handle to result at index i.
        PrlResult_GetParamByIndex(hResult, i, &hVm);

        // Get the name of the virtual machine for result i.
        char szVmNameReturned[1024];
        PRL_UINT32 nBufSize = sizeof(szVmNameReturned);
        ret = PrlVm_GetName(hVm, szVmNameReturned, &nBufSize);

        if (PRL_FAILED(ret))
        {
            printf("PrlVm_GetName returned with error (%s)\n",
                PRL_RESULT_TO_STRING(ret));
        }
        else
        {
            printf("Virtual machine '%s' is available.\n\n", szVmNameReturned);
        }

        // Free the virtual machine handle.
        PrlHandle_Free(hVm);
    }

    return PRL_ERR_SUCCESS;
}


See Also

See Also
PrlShare_GetDescription Function
See Also

PrlShare_SetDescription


See Also

See Also
PrlShare_GetName Function
See Also

PrlShare_SetName


See Also

See Also
PrlShare_GetPath Function
See Also

PrlShare_SetPath


See Also

See Also
PrlShare_IsEnabled Function
See Also

PrlShare_SetEnabled


See Also

See Also
PrlShare_IsReadOnly Function
See Also

PrlShare_SetReadOnly


See Also

See Also
PrlShare_SetDescription Function
See Also

PrlShare_GetDescription


See Also

See Also
PrlShare_SetEnabled Function
See Also

PrlShare_IsEnabled


See Also

See Also
PrlShare_SetName Function
See Also

PrlShare_GetName


See Also

See Also
PrlShare_SetPath Function
See Also

PrlShare_GetPath


See Also

See Also
PrlShare_SetReadOnly Function
See Also

PrlShare_IsReadOnly


See Also

See Also
PrlSrv_AddIPPrivateNetwork Function
See Also

PrlSrv_GetIPPrivateNetworkList

PrlSrv_DeleteIPPrivateNetwork

PrlSrv_UpdateIPPrivateNetwork


See Also

See Also
PrlSrv_AddVirtualNetwork Function
See Also

PrlSrv_GetVirtualNetworkList

PrlSrv_DeleteVirtualNetwork

PrlSrv_UpdateVirtualNetwork


See Also

See Also
PrlSrv_ConfigureGenericPci Function
See Also

PHT_HW_GENERIC_PCI_DEVICE


Example

Example
PrlSrv_Create Function

The following example illustrates how to create a handle of type PHT_SERVER.

PRL_HANDLE hServer;

PRL_RESULT ret = PrlSrv_Create( &hServer );
if ( PRL_FAILED(ret) )
{
    printf( "PrlSrv_Create returned with error: %s\n",
    PRL_RESULT_TO_STRING(ret) );
}

// Free hServer handle when it's no longer needed.
PrlHandle_Free( hServer );


See Also

See Also
PrlSrv_Create Function
See Also

PrlSrv_LoginLocal

PrlSrv_Login


Example

Example
PrlSrv_CreateVm Function
// Create a new virtual machine handle
// (assumes hServer is a valid handle obtained using PrlSrv_Create,
// and a successful Parallels Service login was made using PrlSrv_Login).
PRL_HANDLE hNewVm;
ret = PrlSrv_CreateVm(hServer, &hNewVm);
if (PRL_FAILED(ret))
{
    printf("PrlSvr_CreateVm call failed with: %s.\n", PRL_RESULT_TO_STRING(ret));
    return ret;
}
printf("PrlSvr_CreateVm completed successfully.\n");


See Also

See Also
PrlSrv_DeleteOfflineService Function
See Also

PrlSrv_DeleteOfflineService

PrlSrv_GetOfflineServicesList


See Also

See Also
PrlSrv_DeleteVirtualNetwork Function
See Also

PrlSrv_AddVirtualNetwork

PrlSrv_GetVirtualNetworkList

PrlSrv_UpdateVirtualNetwork


See Also

See Also
PrlSrv_DisableConfirmationMode Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


See Also

See Also
PrlSrv_EnableConfirmationMode Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


Example

Example
PrlSrv_FsGetDiskList Function

The following example illustrates how to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO.

hJob =
PrlSrv_FsGetDiskList( hServer );
PrlJob_Wait( hJob, JOB_TIMEOUT );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_REMOTE_FILESYSTEM_INFO handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetCommonPrefs Function

The following example illustrates how to obtain a handle of type PHT_DISP_CONFIG.

hJob =
PrlSrv_GetCommonPrefs( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_DISP_CONFIG handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetLicenseInfo Function

The following example illustrates how to obtain a handle of type PHT_LICENSE.

hJob =
PrlSrv_GetLicenseInfo( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LICENSE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetNetServiceStatus Function

The following example illustrates how to obtain a handle of type PHT_NET_SERVICE_STATUS containing the Parallels Service network service status.

hJob =
PrlSrv_GetNetServiceStatus( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_NET_SERVICE_STATUS handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


See Also

See Also
PrlSrv_GetRestrictionInfo Function
See Also

PrlSrv_HasRestriction


Example

Example
PrlSrv_GetSrvConfig Function

The following example illustrates how to obtain a handle of type PHT_SERVER_CONFIG from the PHT_SERVER object (the example assumes that you've already obtained a server handle).

hJob =
PrlSrv_GetSrvConfig( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_SERVER_CONFIG handle from the result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetStatistics Function

The following example illustrates how to obtain a handle of type PHT_SYSTEM_STATISTICS.

PRL_RESULT err = PRL_ERR_UNINITIALIZED;
PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
PRL_HANDLE hJob = PRL_INVALID_HANDLE;
PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
PRL_HANDLE hServer = PRL_INVALID_HANDLE;

// Initialize API library.
err = PrlApi_Init(PARALLELS_API_VER);
if (PRL_FAILED(err))
{
    // Error handling goes here...
    return -1;
}

// Create server handle.
err = PrlSrv_Create(&hServer);

// if (err != PRL_ERR_SUCCESS), process the error here.

hJob = PrlSrv_Login(
    hServer, // Server handle
    "10.30.21.243", // Server IP address
    "jdoe", // User
    "secret", // Password
    0, // Previous session ID
    0, // Port number
    0, // Timeout
    PSL_LOW_SECURITY); // Security

// Wait for the job to complete.
err = PrlJob_Wait(hJob, 1000);

// if (err != PRL_ERR_SUCCESS), process the error here.

// Get job return code.
err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

// Free job handle.
PrlHandle_Free(hJob);

// Get statistics.
hJob = PrlSrv_GetStatistics(hServer);
err = PrlJob_Wait(hJob, 10000);

// if (err != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

// Get the PHT_SYSTEM_STATISTICS handle.
PRL_HANDLE hHandle = PRL_INVALID_HANDLE;
err = PrlResult_GetParam(hJobResult, &hHandle);

// if (err != PRL_ERR_SUCCESS), process the error here.

PrlHandle_Free(hJobResult);


See Also

See Also
PrlSrv_GetUserInfo Function
See Also

PrlSrv_GetUserInfoList


Example

Example
PrlSrv_GetUserProfile Function

The following example shows how to obtain a handle of type PHT_USER_PROFILE.

hJob =
PrlSrv_GetUserProfile( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_USER_PROFILE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetVmList Function

The following example illustrates how to obtain a list of virtual machine registered on the specified Parallels Service. The examples assumes that we've already obtain a handle of type PHT_SERVER (the hServer variable) identifying the Parallels Service.

hJob =
PrlSrv_GetVmList( hServer );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;

// Get the number of the virtual machines
// in the list.
PrlResult_GetParamsCount( hJobResult, &nCount );

// Iterate through the list.
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    // Get virtual machine name.
    nRetCode =
    PrlVm_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s.\n", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );


See Also

See Also
PrlSrv_HasRestriction Function
See Also

PrlSrv_GetRestrictionInfo


See Also

See Also
PrlSrv_IsConfirmationModeEnabled Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


Example

Example
PrlSrv_Login Function

The following is a complete sample program that illustrates how to log in to a remote Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szVmName = "Windows XP";
const char *szServer = "127.0.0.1";
const char *szUsername = "SomeUserName";
const char *szPassword = "SomePassword";

int main( int argc, char* argv[] )
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the SDK library.
    if ( PRL_FAILED( SdkWrap_Load( SDK_LIB_NAME ) ) &&
        PRL_FAILED( SdkWrap_Load( "./" SDK_LIB_NAME ) ) )
    {
        fprintf( stderr, "Failed to load " SDK_LIB_NAME "\n" );
        return -1;
    }

    // Initialize the API.
    ret = PrlApi_Init( PARALLELS_API_VER );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create( &hServer );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (asynchronous call).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer,            // PRL_HANDLE of type PHT_SERVER.
            szServer,           // Name and IP address of the host machine.
            szUsername,         // User name.
            szPassword,         // Password.
            0,                  // Previuos session ID (0 if not used).
            0,                  // Port number (0 for default port).
            0,                  // Timeout value (0 for default timeout).
            PSL_LOW_SECURITY ); // Security level.

    // Wait for a maximum of 10 seconds for
    // the job to complete.
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING( ret) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( nJobResult ) )
    {
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Login was successful.\n" );

    // Log off.
    hJob = PrlSrv_Logoff( hServer );
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if ( PRL_FAILED( nJobResult ) )
    {
        fprintf( stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Logoff was successful.\n" );

    // Free handles that are no longer required.
    PrlHandle_Free( hVm );
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    printf( "\n\nEnd of program.\n\n" );
    char c;
    scanf( &c, "%c" );

    return 0;
}


See Also

See Also
PrlSrv_Login Function
See Also

PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_LoginLocal Function

The following example illustrates how to log in to locally running Parallels Service and to obtain a handle of type PHT_LOGIN_RESPONSE.

// Log in.
hJob = PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );
PrlJob_Wait( hJob, 10000 );

// Get the results of the login operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


See Also

See Also
PrlSrv_LoginLocal Function
See Also

PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_LookupParallelsServers Function

The following example illustrates how to call the PrlSrv_LookupParallelsServers synchronously.

hJob =
PrlSrv_LookupParallelsServers(
    10000,  // timeout
    NULL,   // callback function (not used)
    NULL    // user object pointer (not used)
);

printf("Searching for Parallels Services...\n");

nRetCode =
PrlJob_Wait(hJob, 100000);

if (PRL_FAILED(nRetCode))
{
    fprintf(stderr, "PrlJob_Wait returned with error: %s.\n",
        PRL_RESULT_TO_STRING( nRetCode));
    PrlApi_Deinit();
    SdkWrap_Unload();
    return nRetCode;
}

PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount(hJobResult, &nCount);

for (nIndex = 0; nIndex < nCount ; nIndex++)
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex(hJobResult, nIndex, &hParam);

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof(sBuf);

    nRetCode =
    PrlSrvInfo_GetHostName(hParam, sBuf, &nBufSize);

    if (PRL_SUCCEEDED(nRetCode))
        printf("Found Service: %s.\n", &sBuf[0]);
    else
        fprintf(stderr, "PrlSrvInfo_GetHostName failed, error: %s. \n",
            PRL_RESULT_TO_STRING(nRetCode));

    PrlHandle_Free(hParam);
}

PrlHandle_Free(hJobResult);

In the following example, the PrlSrv_LookupParallelsServers is called asynchronously. In order to that, we first have to implement a callback function (let's call it ourCallback):

static PRL_RESULT ourCallback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    printf("%s: ", pUserData);

    // Get the name of the host machine.
    PRL_UINT32 nBufSize = 1024;
    PRL_CHAR sBuf[nBufSize];
    PrlSrvInfo_GetHostName(hEvent, sBuf, &nBufSize);

    // Get the other properties and process them here...

    // The handle must be freed.
    PrlHandle_Free(hEvent);
    return rc;
}

The PrlSrv_LookupParallelsServers function can now be called as follows:

hJob =
PrlSrv_LookupParallelsServers(
    1000,
    &ourCallback,
    (PRL_VOID_PTR)("callback")
);


See Also

See Also
PrlSrv_ProxyLogin Function
See Also

PrlSrv_GetRegisteredHostsOnProxy PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_RegisterVm Function

The following sample function demonstrates how to add an existing virtual machine to the Parallels Service. The function takes a handle of type PHT_SERVER and a string specifying the name and path of the virtual machine directory. It registers the virtual machine with the Service and then modifies the MAC address of every virtual network adapter installed in it.

PRL_RESULT RegisterExistingVM(PRL_HANDLE hServer, PRL_CONST_STR sVmDirectory)
{
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;

    // Register the virtual machine with the Parallels Service.
    hJob = PrlSrv_RegisterVm(
        hServer,
        sVmDirectory,
        PRL_TRUE);  // Using non-interactive mode.

    ret = PrlJob_Wait(hJob, 10000);

    // Check the return code of PrlSrv_RegisterVm.
    PrlJob_GetRetCode(hJob, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        printf("PrlSrv_RegisterVm returned error: %s\n",
            prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJob);
        return -1;
    }

    // Obtain the virtual machine handle from the job object.
    // We will use the handle later to modify the virtual machine
    // configuration.
    PRL_HANDLE hVm = PRL_INVALID_HANDLE;
    ret = PrlJob_GetResult(hJob, &hJobResult);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    ret = PrlResult_GetParam(hJobResult, &hVm);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    PrlHandle_Free(hJob);
    PrlHandle_Free(hJobResult);

    printf("Virtual machine '%s' was successfully registered.",
            sVmDirectory);

    // The following code will generate and set a new MAC address
    // for every virtual network adapter that exists in the virtual machine.
    // This step is optional and should normally be performed when the virtual
    // machine is a copy of another virtual machine.

    PRL_HANDLE hJobBeginEdit;
    PRL_HANDLE hJobCommit;

    // Begin the virtual machine editing operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    ret = PrlJob_Wait(hJobBeginEdit, 10000);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Obtain a handle of type PHT_VM_CONFIGURATION containing the
    // virtual machine configuration data.
    PRL_HANDLE hVmCfg = PRL_INVALID_HANDLE;
    ret = PrlVm_GetConfig(hVm, &hVmCfg);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Determine the number of the network adapters
    // installed in the machine.
    PRL_UINT32 nCount = PRL_ERR_UNINITIALIZED;
    ret = PrlVmCfg_GetNetAdaptersCount(hVmCfg, &nCount);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Itereate through the adapter list.
    PRL_HANDLE hNetAdapter = PRL_INVALID_HANDLE;
    for (PRL_UINT32 i = 0; i < nCount; ++i)
    {
        ret = PrlVmCfg_GetNetAdapter(hVmCfg, i, &hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }

        // Automatically generate new MAC address for the current adapter.
        // The address will be updated in the configuration object.
        ret = PrlVmDevNet_GenerateMacAddr(hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }
    }

    // Commit the changes to the virtual machine.
    hJobCommit = PrlVm_Commit(hVm);

    // Check the results of the commit operation.
    ret = PrlJob_Wait(hJobCommit, 10000);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Commit error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }

    PrlHandle_Free(hNetAdapter);
    PrlHandle_Free(hVm);
    PrlHandle_Free(hVmCfg);
    PrlHandle_Free(hJobCommit);
    PrlHandle_Free(hJobBeginEdit);

    return 0;
}


See Also

See Also
PrlSrv_RemoveIPPrivateNetwork Function
See Also

PrlSrv_AddIPPrivateNetwork

PrlSrv_GetIPPrivateNetworkList

PrlSrv_UpdateIPPrivateNetwork


See Also

See Also
PrlSrv_SecureLogin Function
See Also

PrlDispCfg_GetMinSecurityLevel


See Also

See Also
PrlSrv_SecureProxyLogin Function
See Also

PrlSrv_GetRegisteredHostsOnProxy PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_StartSearchVms Function
PRL_HANDLE hStringList;
PrlApi_CreateStringsList( &hStringList );
PrlStrList_AddItem( hStringList, "/Users/Shared/Parallels/" );

hJob =
PrlSrv_StartSearchVms( hServer, hStringList );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount( hJobResult, &nCount );
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType( hParam, &nHandleType );

    printf( "Handle Type: %s\n",
        PRL_HANDLE_TYPE_TO_STRING( nHandleType ));

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    nRetCode =
    PrlFoundVmInfo_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s\n.", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
PrlHandle_Free( hStringList );


Example

Example
PrlSrv_SubscribeToHostStatistics Function

The following is a complete example that demonstrates how to obtain statistics data asynchronously using PrlSrv_SubscribeToHostStatistics. Note that the same code could be used to receive statistics data for a virtual machine, instead of the host computer, by using PrlVm_SubscribeToGuestStatistics instead of PrlSrv_SubscribeToHostStatistics, and passing it a handle to a virtual machine that is running. This would also require using PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics data for the virtual machine.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szServer = "123.123.123.123";
const char *szUsername = "Your Username";
const char *szPassword = "Your Password";

// -------------------------------------------------------------------------
// Event handler.
// -------------------------------------------------------------------------
// 1. Check for events of type PET_DSP_EVT_HOST_STATISTICS_UPDATES.
// 2. Display a header if first call to this event handler.
// 3. Get the event param (PHT_EVENT_PARAMETER) from the PHT_EVENT handle.
// 4. Convert event param to a handle (will be type PHT_SYSTEM_STATISTICS).
// 5. Use PHT_SYSTEM_STATISTICS handle to obtain CPU usage, memory usage,
// and disk usage data.
// -------------------------------------------------------------------------
static PRL_RESULT OurCallback(PRL_HANDLE handle, void *pData)
{
    PRL_HANDLE_TYPE nHandleType;
    PRL_RESULT ret = PrlHandle_GetType(handle, &nHandleType);

    // Check for PrlHandle_GetType error here.
    if (nHandleType == PHT_EVENT)
    {
        PRL_EVENT_TYPE EventType;
        PrlEvent_GetType(handle, &EventType);

        // Check if the event type is a statistics update.
        if (EventType == PET_DSP_EVT_HOST_STATISTICS_UPDATED)
        {
            // Output a header if first call to this function.
            static PRL_BOOL bHeaderHasBeenPrinted = PRL_FALSE;
            if (!bHeaderHasBeenPrinted)
            {
                bHeaderHasBeenPrinted = PRL_TRUE;
                printf("CPU (%%) Used RAM (MB) Free RAM (MB) Used Disk Space (MB)"
                       " Free Disk Space (MB)\n");
                printf("---------------------------------------------------------"
                       "--------------------\n");
            }

            PRL_HANDLE hEventParameters;
            PRL_HANDLE hServerStatistics;

            // Get the event parameter (PHT_EVENT_PARAMETER) from the event handle.
            PrlEvent_GetParam(handle, 0, &hEventParameters);

            // Convert the event parameter to a handle (PHT_SYSTEM_STATISTICS).
            PrlEvtPrm_ToHandle(hEventParameters, &hServerStatistics);

            // Get CPU statistics (usage in %).
            PRL_HANDLE hCpuStatistics;
            ret = PrlStat_GetCpuStat(hServerStatistics, 0, &hCpuStatistics);
            PRL_UINT32 nCpuUsage = 0;
            ret = PrlStatCpu_GetCpuUsage(hCpuStatistics, &nCpuUsage);

            // Get RAM statistics.
            PRL_UINT64 nUsedRam, nFreeRam;
            PrlStat_GetFreeRamSize(hServerStatistics, &nFreeRam);
            PrlStat_GetUsageRamSize(hServerStatistics, &nUsedRam);
            nUsedRam /= (1024 * 1024);
            nFreeRam /= (1024 * 1024);

            // Get disk space statistics.
            PRL_UINT64 nFreeDiskSpace, nUsedDiskSpace;
            PRL_HANDLE hDiskStatistics;
            PrlStat_GetDiskStat(hServerStatistics, 0, &hDiskStatistics);
            PrlStatDisk_GetFreeDiskSpace(hDiskStatistics, &nFreeDiskSpace);
            PrlStatDisk_GetUsageDiskSpace(hDiskStatistics, &nUsedDiskSpace);
            nUsedDiskSpace /= (1024 * 1024);
            nFreeDiskSpace /= (1024 * 1024);

            printf("%7d %10lld %13lld %20lld %20lld\n",
                nCpuUsage, nUsedRam, nFreeRam, nUsedDiskSpace, nFreeDiskSpace);

            PrlHandle_Free(hDiskStatistics);
            PrlHandle_Free(hCpuStatistics);
            PrlHandle_Free(hServerStatistics);
            PrlHandle_Free(hEventParameters);
        }
    }

    PrlHandle_Free(handle);

    return PRL_ERR_SUCCESS;
}

// -------------------------------
// Program entry point.
// -------------------------------

int main(int argc, char* argv[])
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
        return -1;
    }

    // Initialize the Parallels API.
    ret = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING(ret));
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create(&hServer);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (PrlSrv is asynchronous).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer, // PRL_HANDLE of type PHT_SERVER.
            szServer, // Server hostname or IP address.
            szUsername, // Username.
            szPassword, // Password.
            0, // Deprecated - UUID of previous session.
            0, // Optional - port number (0 for default).
            0, // Optional - timeout value (0 for default).
            PSL_LOW_SECURITY); // Security level

    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        printf("Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Login was successful.\n");
    // ----------------------------------------------------------------------------
    // 1. Register our event handler (OurCallback function).
    // 2. Subscribe to host machine statistics events.
    // 3. Keep receiving events until user presses <enter> key.
    // 4. Unsubscribe from statistics events.
    // 5. Un-register out event handler.
    // ----------------------------------------------------------------------------
    PrlSrv_RegEventHandler(hServer, OurCallback, NULL);
    PrlSrv_SubscribeToHostStatistics(hServer);
    char c;
    scanf(&c, 1);
    PrlSrv_UnsubscribeFromHostStatistics(hServer);
    PrlSrv_UnregEventHandler(hServer, OurCallback, NULL);
    // ----------------------------------------------------------------------------

    // Log off.
    hJob = PrlSrv_Logoff(hServer);
    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Logoff was successful.\n");

    // Free handles that are no longer required.
    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    return 0;
}


See Also

See Also
PrlSrv_UpdateIPPrivateNetwork Function
See Also

PrlSrv_AddIPPrivateNetwork

PrlSrv_GetIPPrivateNetworksList

PrlSrv_DeleteIPPrivateNetwork


See Also

See Also
PrlSrv_UpdateNetworkClassesList Function
See Also

PrlSrv_GetNetworkClassesList


See Also

See Also
PrlSrv_UpdateNetworkShapingConfig Function
See Also

PrlSrv_GetNetworkShapingConfig


See Also

See Also
PrlSrv_UpdateOfflineService Function
See Also

PrlSrv_DeleteOfflineService

PrlSrv_GetOfflineServicesList


See Also

See Also
PrlSrv_UpdateVirtualNetwork Function
See Also

PrlSrv_AddVirtualNetwork

PrlSrv_GetVirtualNetworkList

PrlSrv_DeleteVirtualNetwork


See Also

See Also
PrlSrvCfg_GetGenericPciDevice Function
See Also

PrlSrvCfg_GetGenericPciDevicesCount


See Also

See Also
PrlSrvCfg_GetGenericPciDevicesCount Function
See Also

PrlSrvCfg_GetGenericPciDevice


See Also

See Also
PrlSrvCfgDev_GetDeviceState Function
See Also

PrlSrvCfgDev_SetDeviceState


See Also

See Also
PrlSrvCfgDev_SetDeviceState Function
See Also

PrlSrvCfgDev_GetDeviceState


See Also

See Also
PrlSrvInfo_GetStartTime Function
See Also

PrlSrvInfo_GetStartTimeMonotonic PrlHandle_GetPackageId


See Also

See Also
PrlSrvInfo_GetStartTimeMonotonic Function
See Also

PrlSrvInfo_GetStartTime PrlHandle_GetPackageId


See Also

See Also
PrlStat_GetCpusStatsCount Function
See Also

PrlStat_GetCpuStat


See Also

See Also
PrlStat_GetDisksStatsCount Function
See Also

PrlStat_GetDiskStat


See Also

See Also
PrlStat_GetIfacesStatsCount Function
See Also

PrlStat_GetIfaceStat


See Also

See Also
PrlStat_GetProcsStatsCount Function
See Also

PrlStat_GetProcStat


See Also

See Also
PrlStat_GetUsersStatsCount Function
See Also

PrlStat_GetUserStat


See Also

See Also
PrlStatDisk_GetPartsStatsCount Function
See Also

PrlStatDisk_GetPartStat


See Also

See Also
PrlUsrCfg_CanChangeSrvSets Function
See Also

PrlDispCfg_CanChangeDefaultSettings

PrlDispCfg_SetCanChangeDefaultSettings


See Also

See Also
PrlUsrCfg_GetDefaultVmFolder Function
See Also

PrlUsrCfg_SetDefaultVmFolder


See Also

See Also
PrlUsrInfo_GetDefaultVmFolder Function
See Also

PrlUsrCfg_SetDefaultVmFolder


Example

Example
PrlVm_BeginEdit Function

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


Example

Example
PrlVm_Commit Function

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


See Also

See Also
PrlVm_CreateSnapshot Function
See Also

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData


See Also

See Also
PrlVm_DeleteSnapshot Function
See Also

PrlVm_CreateSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData


See Also

See Also
PrlVm_GetSnapshotsTree Function
See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData


Example

Example
PrlVm_GetState Function
hJob =
PrlVm_GetState( hVm );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the handle from job
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlVm_GetToolsState Function

The following example illustrates how to obtain a handle of type PHT_VM_TOOLS_INFO. The hVm variable is a handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

PRL_HANDLE hJob, hResult, hVmToolsInfo;

hJob = PrlVm_GetToolsState( hVm );
PrlJob_Wait( hJob, 1000 );

PrlJob_GetResult( hJob, &hResult );
PrlHandle_Free( hJob );

PrlResult_GetParam( hJobResult, &hVmToolsInfo );
PrlHandle_Free( hJobResult );


See Also

See Also
PrlVm_LoginInGuest Function
See Also

PrlVmGuest_RunProgram

PrlVmGuest_Logout


See Also

See Also
PrlVm_Pause Function
See Also

PrlVm_Start


Example

Example
PrlVm_Reg Function

The following example shows how to create a new virtual machine. The sample assumes that the client program has already obtained a server object handle (hServer) and performed the Parallels Service login operation.

PRL_HANDLE hVm;
PRL_HANDLE hResult;
PRL_RESULT nJobRetCode;
PRL_RESULT ret;

// Obtain a new virtual machine handle.
ret = PrlSrv_CreateVm(hServer, &hVm);
if (PRL_FAILED(ret))
{
    // Error handling goes here...
    return ret;
}

// Get the host config info.
hJob = PrlSrv_GetSrvConfig(hServer);
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlSrv_GetSrvConfig.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Get a handle to the object containing the result of PrlSrv_GetSrvConfig,
// and then get a handle to the server configuration object from it.
ret = PrlJob_GetResult(hJob, &hResult);
PRL_HANDLE hSrvCfg;
PrlResult_GetParam(hResult, &hSrvCfg);

// Delete the job and the result handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hResult);

// Now that we have the host machine configuration data,
// we can set the default configuration for the new virtual machine.
ret = PrlVm_SetDefaultConfig(
                hVm, // VM handle.
                hSrvCfg, // Host config data.
                PVS_GUEST_TYPE_WINDOWS, // Target OS type.
                PVS_GUEST_VER_WIN_2003, // Target OS version.
                PRL_TRUE); // Create and connect devices.

if (PRL_FAILED(ret))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hSrvCfg);
    PrlHandle_Free(hVm);
    return ret;
}

PrlHandle_Free(hSrvCfg);

// Set the virtual machine name.
ret = PrlVm_SetName(hVm, "My Windows Server 2003");

// The following two calls demonstrate how to modify
// some of the default values of the virtual machine configuration.
// These calls are optional. You may remove them to use the default values.

// Set the RAM size for the machine to 256 MB.
ret = PrlVm_SetRamSize(hVm, 256);

// Set the virtual hard disk size to 20 GB.
// First, get the handle to the hard disk object using the
// PrlVm_GetHardDisk function. The index of 0 is used
// because the default configuration has just one virtual hard disk.
// After that, use the handle to set the disk size to the desired value.

PRL_HANDLE hHDD;
ret = PrlVm_GetHardDisk(hVm, 0, &hHDD);
ret = PrlVmDevHd_SetDiskSize(hHDD, 20000);

// Create and register the machine with the Parallels Service.
hJob = PrlVm_Reg(hVm, // VM handle.
                 "", // VM root directory (using default).
                 PRL_TRUE); // Using non-interactive mode.

// Wait for the operation to complete.
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlVm_Reg.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Delete handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hVm);


See Also

See Also
PrlVm_Resume Function
See Also

PrlVm_Suspend


See Also

See Also
PrlVm_Start Function
See Also

PrlVm_Pause


See Also

See Also
PrlVm_StartVncServer Function
See Also

PrlVm_StopVncServer


See Also

See Also
PrlVm_StopVncServer Function
See Also

PrlVm_StartVncServer


See Also

See Also
PrlVm_SubscribeToGuestStatistics Function
See Also

PrlSrv_SubscribeToHostStatistics


See Also

See Also
PrlVm_Suspend Function
See Also

PrlVm_Resume

PrlVm_DropSuspendedState


See Also

See Also
PrlVm_SwitchToSnapshot Function
See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_UpdateSnapshotData


See Also

See Also
PrlVm_SwitchToSnapshotEx Function
See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_UpdateSnapshotData


See Also

See Also
PrlVm_TisGetIdentifiers Function
See Also

PrlVm_TisGetRecord


See Also

See Also
PrlVm_TisGetRecord Function
See Also

PrlVm_TisGetIdentifiers


See Also

See Also
PrlVm_UpdateSnapshotData Function
See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot


See Also

See Also
PrlVmCfg_CreateScrRes Function
See Also

PrlVmCfg_IsScrResEnabled


See Also

See Also
PrlVmCfg_GetAutoCompressInterval Function
See Also

PrlVmCfg_SetAutoCompressInterval


See Also

See Also
PrlVmCfg_GetCapabilitiesMask Function
See Also

PrlVmCfg_SetCapabilitiesMask


See Also

See Also
PrlVmCfg_GetConfirmationsList Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


See Also

See Also
PrlVmCfg_GetCpuLimit Function
See Also

PrlVmCfg_SetCpuLimit


See Also

See Also
PrlVmCfg_GetCpuUnits Function
See Also

PrlVmCfg_SetCpuUnits


See Also

See Also
PrlVmCfg_GetCustomProperty Function
See Also

PrlVmCfg_SetCustomProperty


See Also

See Also
PrlVmCfg_GetDevByType Function
See Also

PrlVmCfg_GetDevsCountByType


See Also

See Also
PrlVmCfg_GetDevsCount Function
See Also

PrlVmCfg_GetDevsList


See Also

See Also
PrlVmCfg_GetDevsCountByType Function
See Also

PrlVmCfg_GetDevByType


See Also

See Also
PrlVmCfg_GetDisplayDev Function
See Also

PrlVmCfg_GetDisplayDevsCount


See Also

See Also
PrlVmCfg_GetDisplayDevsCount Function
See Also

PrlVmCfg_GetDisplayDev


See Also

See Also
PrlVmCfg_GetFeaturesMask Function
See Also

PrlVmCfg_SetCapabilitiesMask


See Also

See Also
PrlVmCfg_GetFreeDiskSpaceRatio Function
See Also

PrlVmCfg_SetFreeDiskSpaceRatio


See Also

See Also
PrlVmCfg_GetGenericPciDev Function
See Also

PrlVmCfg_GetGenericPciDevsCount


See Also

See Also
PrlVmCfg_GetGenericPciDevsCount Function
See Also

PrlVmCfg_GetGenericPciDev


See Also

See Also
PrlVmCfg_GetGenericScsiDev Function
See Also

PrlVmCfg_GetGenericScsiDevsCount


See Also

See Also
PrlVmCfg_GetGenericScsiDevsCount Function
See Also

PrlVmCfg_GetGenericScsiDev


See Also

See Also
PrlVmCfg_GetHighAvailabilityPriority Function
See Also

PrlVmCfg_SetHighAvailabilityPriority


See Also

See Also
PrlVmCfg_GetNetfilterMode Function
See Also

PrlVmCfg_SetNetfilterMode


See Also

See Also
PrlVmCfg_GetNetworkRateList Function
See Also

PrlVmCfg_SetSearchDomains


See Also

See Also
PrlVmCfg_GetOfflineServices Function
See Also

PrlVmCfg_SetOfflineManagementEnabled

PrlVmCfg_SetOfflineServices


See Also

See Also
PrlVmCfg_GetScrRes Function
See Also

PrlVmCfg_GetScrResCount


See Also

See Also
PrlVmCfg_GetScrResCount Function
See Also

PrlVmCfg_GetScrRes


See Also

See Also
PrlVmCfg_GetSearchDomains Function
See Also

PrlVmCfg_SetSearchDomains


See Also

See Also
PrlVmCfg_GetSmartGuardInterval Function
See Also

PrlVmCfg_SetSmartGuardInterval


See Also

See Also
PrlVmCfg_GetTimeSyncInterval Function
See Also

PrlVmCfg_SetTimeSyncInterval


See Also

See Also
PrlVmCfg_IsAllowSelectBootDevice Function
See Also

PrlVmCfg_SetAllowSelectBootDevice


See Also

See Also
PrlVmCfg_IsAutoCompressEnabled Function
See Also

PrlVmCfg_SetAutoCompressEnabled


See Also

See Also
PrlVmCfg_IsDiskCacheWriteBack Function
See Also

PrlVmCfg_SetDiskCacheWriteBack


See Also

See Also
PrlVmCfg_IsEncrypted Function
See Also

PrlVmCfg_SetSmartGuardEnabled


See Also

See Also
PrlVmCfg_IsHighAvailabilityEnabled Function
See Also

PrlVmCfg_SetHighAvailabilityEnabled


See Also

See Also
PrlVmCfg_IsLockInFullScreenMode Function
See Also

PrlVmCfg_SetLockInFullScreenMode


See Also

See Also
PrlVmCfg_IsOfflineManagementEnabled Function
See Also

PrlVmCfg_SetOfflineManagementEnabled


See Also

See Also
PrlVmCfg_IsSharedProfileEnabled Function
See Also

PrlVmCfg_IsSharedProfileEnabled


See Also

See Also
PrlVmCfg_IsSmartGuardEnabled Function
See Also

PrlVmCfg_SetSmartGuardEnabled


See Also

See Also
PrlVmCfg_IsSmartGuardNotifyBeforeCreation Function
See Also

PrlVmCfg_SetSmartGuardNotifyBeforeCreation


See Also

See Also
PrlVmCfg_IsTimeSynchronizationEnabled Function
See Also

PrlVmCfg_SetTimeSynchronizationEnabled


See Also

See Also
PrlVmCfg_IsUseDefaultAnswers Function
See Also

PrlVmCfg_SetUseDefaultAnswers


See Also

See Also
PrlVmCfg_SetAllowSelectBootDevice Function
See Also

PrlVmCfg_IsAllowSelectBootDevice


See Also

See Also
PrlVmCfg_SetAutoCompressEnabled Function
See Also

PrlVmCfg_SetAutoCompressdInterval PrlVmCfg_SetFreeDiskSpaceRatio


See Also

See Also
PrlVmCfg_SetAutoCompressInterval Function
See Also

PrlVmCfg_GetAutoCompressInterval


See Also

See Also
PrlVmCfg_SetCapabilitiesMask Function
See Also

PrlVmCfg_GetCapabilitiesMask


See Also

See Also
PrlVmCfg_SetCloseAppOnShutdown Function
See Also

PrlVmCfg_IsCloseAppOnShutdown


See Also

See Also
PrlVmCfg_SetConfirmationsList Function
See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()


See Also

See Also
PrlVmCfg_SetCpuLimit Function
See Also

PrlVmCfg_GetCpuLimit


See Also

See Also
PrlVmCfg_SetCpuMask Function
See Also

PrlVmCfg_GetCpuLimit


See Also

See Also
PrlVmCfg_SetCpuUnits Function
See Also

PrlVmCfg_GetCpuUnits


See Also

See Also
PrlVmCfg_SetDisableAPICSign Function
See Also

PrlVmCfg_IsDisableAPIC


See Also

See Also
PrlVmCfg_SetDisableSpeakerSign Function
See Also

PrlVmCfg_IsDisableSpeaker


See Also

See Also
PrlVmCfg_SetFeaturesMask Function
See Also

PrlVmCfg_GetCapabilitiesMask


See Also

See Also
PrlVmCfg_SetFreeDiskSpaceRatio Function
See Also

PrlVmCfg_GetFreeDiskSpaceRatio


See Also

See Also
PrlVmCfg_SetHighAvailabilityEnabled Function
See Also

PrlVmCfg_IsHighAvailabilityEnabled


See Also

See Also
PrlVmCfg_SetHighAvailabilityPriority Function
See Also

PrlVmCfg_GetHighAvailabilityPriority


See Also

See Also
PrlVmCfg_SetLockInFullScreenMode Function
See Also

PrlVmCfg_IsLockInFullScreenMode


See Also

See Also
PrlVmCfg_SetNetfilterMode Function
See Also

PrlVmCfg_GetNetfilterMode


See Also

See Also
PrlVmCfg_SetNetworkRateList Function
See Also

PrlSrv_GetNetworkShapingConfig


See Also

See Also
PrlVmCfg_SetOfflineServices Function
See Also

PrlVmCfg_GetOfflineServices


See Also

See Also
PrlVmCfg_SetScrResEnabled Function
See Also

PrlVmCfg_IsScrResEnabled


See Also

See Also
PrlVmCfg_SetSearchDomains Function
See Also

PrlVmCfg_GetSearchDomains


See Also

See Also
PrlVmCfg_SetSharedProfileEnabled Function
See Also

PrlVmCfg_IsSharedProfileEnabled


See Also

See Also
PrlVmCfg_SetSmartGuardEnabled Function
See Also

PrlVmCfg_SetSmartGuardInterval

PrlVmCfg_SetSmartGuardMaxSnapshotsCount

PrlVmCfg_SetSmartGuardNotifyBeforeCreation


See Also

See Also
PrlVmCfg_SetSmartGuardInterval Function
See Also

PrlVmCfg_GetSmartGuardInterval


See Also

See Also
PrlVmCfg_SetSmartGuardNotifyBeforeCreation Function
See Also

PrlVmCfg_IsSmartGuardNotifyBeforeCreation


See Also

See Also
PrlVmCfg_SetTimeSynchronizationEnabled Function
See Also

PrlVmCfg_SetTimeSyncSmartModeEnabled


See Also

See Also
PrlVmCfg_SetTimeSyncInterval Function
See Also

PrlVmCfg_GetTimeSyncInterval


See Also

See Also
PrlVmCfg_SetTimeSyncSmartModeEnabled Function
See Also

PrlVmCfg_SetTimeSynchronizationEnabled

PrlVmCfg_SetTimeSyncInterval


See Also

See Also
PrlVmCfg_SetUseDefaultAnswers Function
See Also

PrlVmCfg_IsUseDefaultAnswers


See Also

See Also
PrlVmCfg_SetVirtualLinksEnabled Function
See Also

PrlVmCfg_IsVirtualLinksEnabled


See Also

See Also
PrlVmDev_GetDescription Function
See Also

PrlVmDev_SetDescription


See Also

See Also
PrlVmDev_SetDescription Function
See Also

PrlVmDev_GetDescription


See Also

See Also
PrlVmDevHd_GetDiskSize Function
See Also

PrlVmDevHd_SetDiskSize


See Also

See Also
PrlVmDevHd_GetDiskType Function
See Also

PrlVmDevHd_SetDiskType


See Also

See Also
PrlVmDevHd_GetMountPoint Function
See Also

PrlVmDevHd_SetMountPoint,


See Also

See Also
PrlVmDevHd_GetPartition Function
See Also

PrlVmDevHd_GetPartitionsCount


See Also

See Also
PrlVmDevHd_GetPartitionsCount Function
See Also

PrlVmDevHd_GetPartition


See Also

See Also
PrlVmDevHd_GetStorageURL Function
See Also

PrlVmDevHd_SetStorageURL


See Also

See Also
PrlVmDevHd_IsAutoCompressEnabled Function
See Also

PrlVmDevHd_IsAutoCompressEnabled,


See Also

See Also
PrlVmDevHd_IsEncrypted Function
See Also

PrlVmDevHd_CheckPassword PrlVmDev_UpdateInfo PrlVm_Commit


See Also

See Also
PrlVmDevHd_IsSplitted Function
See Also

PrlVmDevHd_SetSplitted


See Also

See Also
PrlVmDevHd_SetAutoCompressEnabled Function
See Also

PrlVmDevHd_GetMountPoint


See Also

See Also
PrlVmDevHd_SetDiskSize Function
See Also

PrlVmDevHd_GetDiskSize


See Also

See Also
PrlVmDevHd_SetDiskType Function
See Also

PrlVmDevHd_GetDiskType


See Also

See Also
PrlVmDevHd_SetMountPoint Function
See Also

PrlVmDevHd_GetMountPoint


See Also

See Also
PrlVmDevHd_SetPassword Function
See Also

PrlVmDevHd_CheckPassword PrlVm_Commit


See Also

See Also
PrlVmDevHd_SetSplitted Function
See Also

PrlVmDevHd_IsSplitted


See Also

See Also
PrlVmDevHd_SetStorageURL Function
See Also

PrlVmDevHd_GetStorageURL


See Also

See Also
PrlVmDevHdPart_GetSysName Function
See Also

PrlVmDevHdPart_SetSysName


See Also

See Also
PrlVmDevHdPart_SetSysName Function
See Also

PrlVmDevHdPart_GetSysName


See Also

See Also
PrlVmDevNet_GetAdapterType Function
See Also

PrlVmDevNet_SetAdapterType


See Also

See Also
PrlVmDevNet_GetBoundAdapterIndex Function
See Also

PrlVmDevNet_SetBoundAdapterIndex


See Also

See Also
PrlVmDevNet_GetBoundAdapterName Function
See Also

PrlVmDevNet_SetBoundAdapterName


See Also

See Also
PrlVmDevNet_GetDefaultGateway Function
See Also

PrlVmDevNet_SetDefaultGateway


See Also

See Also
PrlVmDevNet_GetDefaultGatewayIPv6 Function
See Also

PrlVmDevNet_SetDefaultGateway


See Also

See Also
PrlVmDevNet_GetDnsServers Function
See Also

PrlVmDevNet_SetDnsServers


See Also

See Also
PrlVmDevNet_GetMacAddress Function
See Also

PrlVmDevNet_GetMacAddressCanonical, PrlVmDevNet_SetMacAddress


See Also

See Also
PrlVmDevNet_GetMacAddressCanonical Function
See Also

PrlVmDevNet_SetMacAddress


See Also

See Also
PrlVmDevNet_GetNetAddresses Function
See Also

PrlVmDevNet_SetNetAddresses


See Also

See Also
PrlVmDevNet_GetSearchDomains Function
See Also

PrlVmDevNet_SetSearchDomains


See Also

See Also
PrlVmDevNet_GetVirtualNetworkId Function
See Also

PrlVmDevNet_SetVirtualNetworkId


See Also

See Also
PrlVmDevNet_SetAdapterType Function
See Also

PrlVmDevNet_GetAdapterType


See Also

See Also
PrlVmDevNet_SetBoundAdapterIndex Function
See Also

PrlVmDevNet_GetBoundAdapterIndex


See Also

See Also
PrlVmDevNet_SetBoundAdapterName Function
See Also

PrlVmDevNet_GetBoundAdapterName


See Also

See Also
PrlVmDevNet_SetConfigureWithDhcp Function
See Also

PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetConfigureWithDhcpIPv6 Function
See Also

PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetDefaultGateway Function
See Also

PrlVmDevNet_GetDefaultGateway PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetDefaultGatewayIPv6 Function
See Also

PrlVmDevNet_GetDefaultGateway PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetDnsServers Function
See Also

PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetMacAddress Function
See Also

PrlVmDevNet_GetMacAddress


See Also

See Also
PrlVmDevNet_SetNetAddresses Function
See Also

PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetSearchDomains Function
See Also

PrlVmDevNet_SetAutoApply


See Also

See Also
PrlVmDevNet_SetVirtualNetworkId Function
See Also

PrlVmDevNet_GetVirtualNetworkId


See Also

See Also
PrlVmDevSerial_GetSocketMode Function
See Also

PrlVmDevSerial_SetSocketMode


See Also

See Also
PrlVmDevSerial_SetSocketMode Function
See Also

PrlVmDevSerial_GetSocketMode


See Also

See Also
PrlVmDevSound_GetMixerDev Function
See Also

PrlVmDevSound_SetMixerDev


See Also

See Also
PrlVmDevSound_GetOutputDev Function
See Also

PrlVmDevSound_SetOutputDev


See Also

See Also
PrlVmDevSound_SetMixerDev Function
See Also

PrlVmDevSound_GetMixerDev


See Also

See Also
PrlVmDevSound_SetOutputDev Function
See Also

PrlVmDevSound_GetOutputDev


See Also

See Also
PrlVmDevUsb_GetAutoconnectOption Function
See Also

PrlVmDevUsb_SetAutoconnectOption


See Also

See Also
PrlVmDevUsb_SetAutoconnectOption Function
See Also

PrlVmDevUsb_GetAutoconnectOption


See Also

See Also
PrlVmGuest_Logout Function
See Also

PrlVm_LoginInGuest


See Also

See Also
PrlVmGuest_SetUserPasswd Function
See Also

PrlVm_LoginInGuest


See Also

See Also
PrlVmInfo_IsVncServerStarted Function
See Also

PrlVm_StartVncServer

PrlVm_StopVncServer


PVS_GUEST Macros Macros

PVS_GUEST Macros Macros
PVS_GUEST Macros
Macros
Name | Description
PRL_GUEST_CPU_USAGE_PTRN | Guest OS CPU usage in percents (modulated to 100%)
PRL_GUEST_RAM_CACHED_PTRN |
PRL_GUEST_RAM_USAGE_PTRN | Guest OS RAM usage in megabytes
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_ANDROID |
PVS_GUEST_TYPE_CHROMEOS |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_ANDROID |
PVS_GUEST_TYPE_NAME_CHROMEOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_ANDROID_2_x |
PVS_GUEST_VER_ANDROID_3_x |
PVS_GUEST_VER_ANDROID_4_0 |
PVS_GUEST_VER_ANDROID_LAST |
PVS_GUEST_VER_ANDROID_OTHER |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_8X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_CHROMEOS_1x |
PVS_GUEST_VER_CHROMEOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_CHROMEOS_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_CENTOS_7 |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MAGEIA |
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_MINT |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_PSBM |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_REDHAT_7 |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_MACOS_UNIVERSAL |
PVS_GUEST_VER_NAME_ANDROID_4_0 |
PVS_GUEST_VER_NAME_ANDROID_OTHER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_8X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_CHROMEOS_1x |
PVS_GUEST_VER_NAME_CHROMEOS_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_FREE_BSD |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MAGEIA |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_MINT |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_PSBM |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_BSD |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OPEN_BSD |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OPEN |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_TRUSTED_BSD |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2012 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS_10 |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_WINDOWS8 |
PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_BSD |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OPEN_BSD |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OPEN | OpenSolaris
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_TRUSTED_BSD |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2012 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS_10 |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_WINDOWS8 |
PVS_GUEST_VER_WIN_WINDOWS8_1 |
PVS_GUEST_VER_WIN_XP |


Topics

Topics
Remote Desktop Access
Topics
Name | Description
Audio Playback | Functions in this group provide functionality for remote sound playback.
Keyboard Control | Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.
Mouse Control | Functions in this group provide functionality for sending mouse commands to a remote virtual machine.
Primary Display Capture | Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.
Secondary Display Capture | Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.


Secondary Display Capture Functions

Secondary Display Capture Functions
Secondary Display Capture Legend
Functions
Name | Description
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenBufferEx | Returns the contents of the screen buffer of the secondary display and mapping handle on Windows host (on Unix host hMapping parameter will be always equal to buffer).
PrlDevSecondaryDisplay_GetScreenBufferFormat | Returns format of internal screen buffer.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.


Legend

Legend
Secondary Display Capture
Legend
Method


System Functions Functions

System Functions Functions
System Functions Legend
Functions
Name | Description
PrlApi_CalcIconHash | Calculates hash for specified icon data which can be used later in PrlApi_ValidateInCache.
PrlApi_CreateCredentials | Create credentials (certificate signing request / private key) for user.
PrlApi_CreateHandlesList | Creates a new handle of type PRL_HANDLES_LIST.
PrlApi_CreateOpTypeList | Creates a new handle of type PHT_OPAQUE_TYPE_LIST.
PrlApi_CreateProblemReport | Creates and returns a handle of type PHT_PROBLEM_REPORT, which is used to obtain and manage Parallels problem reports.
PrlApi_CreateRemoteCommand |
PrlApi_CreateStringsList | Creates a new handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetCrashDumpsPath | Returns the name and path of the directory where Parallels crash dumps are stored.
PrlApi_GetDefaultOsVersion | Returns default guest OS version for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetSupportedOsesTypes | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list for current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetSupportedOsesVersions | Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).
PrlApi_GetUserData | Allows to get arbitrary data from the cloud user storage.
PrlApi_GetUserKeys | Allows to get arbitrary data keys from the cloud user storage.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitCrashHandler | Initiates the standard Parallels crash dump handler.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_PutIcon | Allows to put arbitrary icon to the cloud user storage.
PrlApi_PutUserData | Allows to put arbitrary data to the cloud user storage.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_RemoveUserData | Allows to remove arbitrary data from the cloud user storage.
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendPackedProblemReport | The PrlApi_SendPackedProblemReport lets to send previously extracted with PrlSrv_GetPackedProblemReport or PrlVm_GetPackedProblemReport calls problem report to the Parallels support server.
PrlApi_SendProblemReport | The PrlApi_SendProblemReport lets to send previously extracted with PrlSrv_GetProblemReport or PrlVm_GetProblemReport calls problem report to the Parallels support server.
PrlApi_SendRemoteCommand |
PrlApi_SignCertificate | Sign user certificate on manager CA .
PrlApi_SignCertificateEx | Sign user certificate on manager CA.
PrlApi_SubscribeOnRegistration | Allows to sign for postponed notification about desired host registration on Manager.
PrlApi_SwitchConsoleLogging | Turn on/off print logging messages on console PRL_ERR_SUCCESS - function completed successfully.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.
PrlApi_ValidateInCache | Allows to check whether the specified icon hashes are present in the cache.
PrlAppliance_Create | Creates a new handle of type PHT_APPLIANCE_CONFIG.


Legend

Legend
System Functions
Legend
Method


Topics

Topics
System Functions
Topics
Name | Description
PrlApi_AddRemoteDevCommandBuffer@PRL_HANDLE@PRL_VOID_PTR@PRL_UINT32 |
PrlApi_AddRemoteDevCommandParam@PRL_HANDLE@PRL_UINT32 |


Virtual Device Functions Functions

Virtual Device Functions Functions
Virtual Device Functions Legend
Functions
Name | Description
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_CopyImage | Copies a virtual device image to another custom location.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSubType | Returns the virtual device subtype.
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_ResizeImage | Resize a virtual device image.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSubType | Sets the virtual device subtype.
PrlVmDev_SetSysName | Sets virtual device system name.


Legend

Legend
Virtual Device Functions
Legend
Method


_VIRTUAL_MACHINE_ADDITION_STATE Enumeration

_VIRTUAL_MACHINE_ADDITION_STATE Enumeration
Other Structs

Virtual machine addition states enumeration, may be combined with bitwise

Syntax
enum _VIRTUAL_MACHINE_ADDITION_STATE {
  VMAS_NOSTATE = 1<<0,
  VMAS_BACKUPING = 1<<1,
  VMAS_RESTORING_FROM_BACKUP = 1<<2,
  VMAS_ENCRYPTING = 1<<3,
  VMAS_DECRYPTING = 1<<4,
  VMAS_CLONING = 1<<5,
  VMAS_MOVING = 1<<6,
  VMAS_MAX = 1<<31
};
File

PrlEnums.h

Links
Other Structs


_VIRTUAL_MACHINE_STATE Enumeration

_VIRTUAL_MACHINE_STATE Enumeration
Other Structs

Virtual machine states enumeration

Syntax
enum _VIRTUAL_MACHINE_STATE {
  VMS_UNKNOWN = 0,
  VMS_STOPPED = 0x30000001,
  VMS_STARTING = 0x30000002,
  VMS_RESTORING = 0x30000003,
  VMS_RUNNING = 0x30000004,
  VMS_PAUSED = 0x30000005,
  VMS_SUSPENDING = 0x30000006,
  VMS_STOPPING = 0x30000007,
  VMS_COMPACTING = 0x30000008,
  VMS_SUSPENDED = 0x30000009,
  VMS_SNAPSHOTING = 0x3000000A,
  VMS_RESETTING = 0x3000000B,
  VMS_PAUSING = 0x3000000C,
  VMS_CONTINUING = 0x3000000D,
  VMS_MIGRATING = 0x3000000E,
  VMS_DELETING_STATE = 0x3000000F,
  VMS_RESUMING = 0x30000010,
  VMS_SUSPENDING_SYNC = 0x30000011,
  VMS_RECONNECTING = 0x30000012,
  VMS_MOUNTED = 0x30000013
};
File

PrlEnums.h

Links
Other Structs


CAPDEFAULTMASK Macro

CAPDEFAULTMASK Macro
Other Macros
Syntax
#define CAPDEFAULTMASK ( \
    PCC_CHOWN        | \
    PCC_DAC_OVERRIDE    | \
    PCC_DAC_READ_SEARCH    | \
    PCC_FOWNER        | \
    PCC_FSETID        | \
    PCC_KILL        | \
    PCC_SETGID        | \
    PCC_SETUID        | \
    PCC_LINUX_IMMUTABLE    | \
    PCC_NET_BIND_SERVICE    | \
    PCC_NET_BROADCAST    | \
    PCC_NET_RAW        | \
    PCC_IPC_LOCK        | \
    PCC_IPC_OWNER        | \
    PCC_SYS_CHROOT        | \
    PCC_SYS_PTRACE        | \
    PCC_SYS_BOOT        | \
    PCC_SYS_NICE        | \
    PCC_SYS_RESOURCE    | \
    PCC_SYS_TTY_CONFIG    | \
    PCC_MKNOD        | \
    PCC_LEASE        | \
    PCC_VE_ADMIN        | \
    PCC_SETPCAP        | \
    PCC_SETFCAP        | \
    PCC_AUDIT_WRITE    )
File

PrlEnums.h

Links
Other Macros


Contents

Contents
Introduction
About This Guide
Organization of This Guide
How to Use This Guide
Functions by Handle
PHT_ACCESS_RIGHTS
PHT_BACKUP_RESULT
PHT_BOOT_DEVICE
PHT_CT_TEMPLATE
PHT_CVSRC
PHT_DESKTOP_CONTROL
PHT_DISP_CONFIG
PHT_EVENT
PHT_EVENT_PARAMETER
PHT_FIREWALL_RULE
PHT_FOUND_VM_INFO
PHT_GUEST_OSES_MATRIX
PHT_HANDLES_LIST
PHT_HW_GENERIC_DEVICE
PHT_HW_GENERIC_PCI_DEVICE
PHT_HW_HARD_DISK
PHT_HW_HARD_DISK_PARTITION
PHT_HW_NET_ADAPTER
PHT_IPPRIV_NET
PHT_JOB
PHT_LICENSE
PHT_LOGIN_RESPONSE
PHT_NET_SERVICE_STATUS
PHT_NETWORK_CLASS
PHT_NETWORK_RATE
PHT_NETWORK_SHAPING
PHT_NETWORK_SHAPING_BANDWIDTH
PHT_NETWORK_SHAPING_CONFIG
PHT_OFFLINE_SERVICE
PHT_OPAQUE_TYPE_LIST
PHT_PLUGIN_INFO
PHT_PORT_FORWARDING
PHT_PROBLEM_REPORT
PHT_REMOTE_FILESYSTEM_ENTRY
PHT_REMOTE_FILESYSTEM_INFO
PHT_RESULT
PHT_RUNNING_TASK
PHT_SCREEN_RESOLUTION
PHT_SERVER
PHT_SERVER_CONFIG
PHT_SERVER_INFO
PHT_SHARE
PHT_STRINGS_LIST
PHT_SYSTEM_STATISTICS
PHT_SYSTEM_STATISTICS_CPU
PHT_SYSTEM_STATISTICS_DISK
PHT_SYSTEM_STATISTICS_DISK_PARTITION
PHT_SYSTEM_STATISTICS_IFACE
PHT_SYSTEM_STATISTICS_PROCESS
PHT_SYSTEM_STATISTICS_USER_SESSION
PHT_UIEMU_INPUT
PHT_USB_IDENTITY
PHT_USER_INFO
PHT_USER_PROFILE
PHT_VIRTUAL_DEV_FLOPPY
PHT_VIRTUAL_DEV_HARD_DISK
PHT_VIRTUAL_DEV_HD_PARTITION
PHT_VIRTUAL_DEV_NET_ADAPTER
PHT_VIRTUAL_DEV_OPTICAL_DISK
PHT_VIRTUAL_DEV_PARALLEL_PORT
PHT_VIRTUAL_DEV_SERIAL_PORT
PHT_VIRTUAL_DEV_SOUND
PHT_VIRTUAL_DEV_USB_DEVICE
PHT_VIRTUAL_DISK
PHT_VIRTUAL_MACHINE
PrlVm_MigrateWithRenameEx Function
PHT_VIRTUAL_NETWORK
PHT_VM_CONFIGURATION
PHT_VM_GUEST_SESSION
PHT_VM_INFO
PHT_VM_TOOLS_INFO
Common Functions
System Functions
API Debug Functions
Handle Functions
Virtual Device Functions
PrlBuffer
Remote Desktop Access
Audio Playback
Keyboard Control
Mouse Control
Primary Display Capture
Secondary Display Capture
Callback Prototypes
PRL_DISK_CALLBACK
PRL_EVENT_HANDLER_PTR
PRL_STATES_CALLBACK
Types
PRL_BOOL Types
PRL_CHAR Types
PRL_CONST Types
PRL_DEVICE Types
PRL_DISK Types
PRL_DOUBLE Types
PRL_FILE Types
PRL_INT Types
PRL_IO Types
PRL_TIS Types
PRL_TOOLS Types
PRL_UINT Types
PRL_VM Types
PRL_VOID Types
Other Types
Structs, Records, Enums
PRL_IO Structs
PRL_VM Structs
Other Structs
Macros
__Parallels_API Macros
__PTM Macros
GUI_ERR Macros
GUI_INFO Macros
Other Macros
PET Macros
PRL_DISK Macros
PRL_ERR Macros
PRL_PTM Macros
PRL_SCAN_CODE Macros
PVS_GUEST Macros


event_type_to_string Function

event_type_to_string Function
API Debug Functions

This inline function returns a readable string representation of the specified event type.

Syntax
static inline const char * event_type_to_string(
    PRL_EVENT_TYPE value
);
File

PrlApiCore.h

Parameters

value
The event type.

Links
API Debug Functions


FS_PERM_EXECUTE Macro

FS_PERM_EXECUTE Macro
Other Macros
Syntax
#define FS_PERM_EXECUTE 0x1
File

PrlFs.h

Links
Other Macros


FS_PERM_READ Macro

FS_PERM_READ Macro
Other Macros
Syntax
#define FS_PERM_READ 0x2
File

PrlFs.h

Links
Other Macros


FS_PERM_WRITE Macro

FS_PERM_WRITE Macro
Other Macros
Syntax
#define FS_PERM_WRITE 0x4
File

PrlFs.h

Links
Other Macros


GUI_ANSWER_RUN_FREE_SPACE_WIZARD Macro

GUI_ANSWER_RUN_FREE_SPACE_WIZARD Macro
GUI_INFO Macros
  • GUI Answers

+++ ALIGNED VALUE TO 53000

Syntax
#define GUI_ANSWER_RUN_FREE_SPACE_WIZARD PRL_RESULT_DECLARE_SUCCESS(53000)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_ERR_ACTION_CANCELLED Macro

GUI_ERR_ACTION_CANCELLED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ACTION_CANCELLED PRL_RESULT_DECLARE_ERROR(15131)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION Macro

GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15409)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED Macro

GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15408)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE PRL_RESULT_DECLARE_ERROR(15422)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH PRL_RESULT_DECLARE_ERROR(15426)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR PRL_RESULT_DECLARE_ERROR(15421)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15424)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE PRL_RESULT_DECLARE_ERROR(15423)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH PRL_RESULT_DECLARE_ERROR(15425)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED Macro

GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15420)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_ALREADY_RUNNING Macro

GUI_ERR_APP_ALREADY_RUNNING Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(15352)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED Macro

GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED PRL_RESULT_DECLARE_ERROR(15368)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START Macro

GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START PRL_RESULT_DECLARE_ERROR(15367)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED Macro

GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED PRL_RESULT_DECLARE_ERROR(15366)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_INIT_ABORTED Macro

GUI_ERR_APP_BUNDLE_INIT_ABORTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_INIT_ABORTED PRL_RESULT_DECLARE_ERROR(15371)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START Macro

GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START PRL_RESULT_DECLARE_ERROR(15370)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_INIT_FAILURE Macro

GUI_ERR_APP_BUNDLE_INIT_FAILURE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_INIT_FAILURE PRL_RESULT_DECLARE_ERROR(15369)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED Macro

GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED PRL_RESULT_DECLARE_ERROR(15434)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION Macro

GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION PRL_RESULT_DECLARE_ERROR(15384)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT Macro

GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT PRL_RESULT_DECLARE_ERROR(15433)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_COULD_NOT_BE_STARTED Macro

GUI_ERR_APP_COULD_NOT_BE_STARTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_COULD_NOT_BE_STARTED PRL_RESULT_DECLARE_ERROR(15380)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_EULA_DECLINED Macro

GUI_ERR_APP_EULA_DECLINED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_EULA_DECLINED PRL_RESULT_DECLARE_ERROR(15372)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_NEED_REINSTALL Macro

GUI_ERR_APP_NEED_REINSTALL Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_NEED_REINSTALL PRL_RESULT_DECLARE_ERROR(15431)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW Macro

GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW PRL_RESULT_DECLARE_ERROR(15344)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_INIT_BUNDLE Macro

GUI_ERR_APP_RESUME_INIT_BUNDLE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_INIT_BUNDLE PRL_RESULT_DECLARE_ERROR(15388)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_INSTALLING_UPDATE Macro

GUI_ERR_APP_RESUME_INSTALLING_UPDATE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_INSTALLING_UPDATE PRL_RESULT_DECLARE_ERROR(15355)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_INVALID_CONTEXT Macro

GUI_ERR_APP_RESUME_INVALID_CONTEXT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_INVALID_CONTEXT PRL_RESULT_DECLARE_ERROR(15342)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_SERVER_DISCONNECTED Macro

GUI_ERR_APP_RESUME_SERVER_DISCONNECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_SERVER_DISCONNECTED PRL_RESULT_DECLARE_ERROR(15340)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_SILENT_START Macro

GUI_ERR_APP_RESUME_SILENT_START Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_SILENT_START PRL_RESULT_DECLARE_ERROR(15343)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_TIMEOUT Macro

GUI_ERR_APP_RESUME_TIMEOUT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_TIMEOUT PRL_RESULT_DECLARE_ERROR(15339)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_APP_RESUME_VM_ENCRYPTED Macro

GUI_ERR_APP_RESUME_VM_ENCRYPTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_APP_RESUME_VM_ENCRYPTED PRL_RESULT_DECLARE_ERROR(15341)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_BACKUP_FAILED_GENERAL_MSG Macro

GUI_ERR_BACKUP_FAILED_GENERAL_MSG Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_BACKUP_FAILED_GENERAL_MSG PRL_RESULT_DECLARE_SUCCESS(15104)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE Macro

GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE PRL_RESULT_DECLARE_SUCCESS(15103)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT Macro

GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT PRL_RESULT_DECLARE_SUCCESS(15102)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM Macro

GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM PRL_RESULT_DECLARE_ERROR(15464)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_DELETE_DISK_FILES Macro

GUI_ERR_CANNOT_DELETE_DISK_FILES Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_DELETE_DISK_FILES PRL_RESULT_DECLARE_SUCCESS(15133)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE Macro

GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE PRL_RESULT_DECLARE_ERROR(15346)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH Macro

GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH PRL_RESULT_DECLARE_SUCCESS(15132)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_MOVE_VM_TO_TRASH Macro

GUI_ERR_CANNOT_MOVE_VM_TO_TRASH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_MOVE_VM_TO_TRASH PRL_RESULT_DECLARE_SUCCESS(15127)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE Macro

GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE PRL_RESULT_DECLARE_ERROR(15450)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_RUN_LINKED_CLONE Macro

GUI_ERR_CANNOT_RUN_LINKED_CLONE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_RUN_LINKED_CLONE PRL_RESULT_DECLARE_ERROR(15466)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP Macro

GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP PRL_RESULT_DECLARE_SUCCESS(15117)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE Macro

GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE PRL_RESULT_DECLARE_SUCCESS(15118)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_ADD_PCI_INSTANTLY Macro

GUI_ERR_CANT_ADD_PCI_INSTANTLY Macro
GUI_ERR Macros
  • Gui messages

+++ ALIGNED VALUE TO 15000

Syntax
#define GUI_ERR_CANT_ADD_PCI_INSTANTLY PRL_RESULT_DECLARE_SUCCESS(15000)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY Macro

GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY PRL_RESULT_DECLARE_SUCCESS(15106)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION Macro

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION PRL_RESULT_DECLARE_SUCCESS(15038)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_CHANGE_SHARED_FOLDER Macro

GUI_ERR_CANT_CHANGE_SHARED_FOLDER Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_CHANGE_SHARED_FOLDER PRL_RESULT_DECLARE_SUCCESS(15036)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_CLONE_SUSPENDED_VM Macro

GUI_ERR_CANT_CLONE_SUSPENDED_VM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_CLONE_SUSPENDED_VM PRL_RESULT_DECLARE_SUCCESS(15033)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_RUN_ON_THIS_SYSTEM Macro

GUI_ERR_CANT_RUN_ON_THIS_SYSTEM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_RUN_ON_THIS_SYSTEM PRL_RESULT_DECLARE_ERROR(15477)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED Macro

GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED PRL_RESULT_DECLARE_ERROR(15042)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CANT_START_UTW7_AGENT Macro

GUI_ERR_CANT_START_UTW7_AGENT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CANT_START_UTW7_AGENT PRL_RESULT_DECLARE_ERROR(15197)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY Macro

GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY PRL_RESULT_DECLARE_ERROR(15268)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED Macro

GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED PRL_RESULT_DECLARE_ERROR(15265)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR Macro

GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR PRL_RESULT_DECLARE_ERROR(15266)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY Macro

GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY PRL_RESULT_DECLARE_ERROR(15267)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY Macro

GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY PRL_RESULT_DECLARE_ERROR(15269)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST Macro

GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_SUCCESS(15068)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE Macro

GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE PRL_RESULT_DECLARE_ERROR(15316)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_CONVERT_FAILED Macro

GUI_ERR_CONVERT_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_CONVERT_FAILED PRL_RESULT_DECLARE_ERROR(15218)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_END_IP Macro

GUI_ERR_DHCP_INCORRECT_END_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_INCORRECT_END_IP PRL_RESULT_DECLARE_SUCCESS(15048)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_MASK_IP Macro

GUI_ERR_DHCP_INCORRECT_MASK_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_INCORRECT_MASK_IP PRL_RESULT_DECLARE_SUCCESS(15049)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_START_IP Macro

GUI_ERR_DHCP_INCORRECT_START_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_INCORRECT_START_IP PRL_RESULT_DECLARE_SUCCESS(15047)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET Macro

GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET PRL_RESULT_DECLARE_SUCCESS(15056)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP Macro

GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP PRL_RESULT_DECLARE_SUCCESS(15055)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_UNKNOWN Macro

GUI_ERR_DHCP_UNKNOWN Macro
GUI_ERR Macros

End of obsolete codes scope

Syntax
#define GUI_ERR_DHCP_UNKNOWN PRL_RESULT_DECLARE_ERROR(15276)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP PRL_RESULT_DECLARE_SUCCESS(15051)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP PRL_RESULT_DECLARE_SUCCESS(15052)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP PRL_RESULT_DECLARE_SUCCESS(15050)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP Macro

GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP PRL_RESULT_DECLARE_SUCCESS(15054)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP Macro

GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP PRL_RESULT_DECLARE_SUCCESS(15053)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE Macro

GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE PRL_RESULT_DECLARE_ERROR(15415)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH Macro

GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH PRL_RESULT_DECLARE_ERROR(15419)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR Macro

GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR PRL_RESULT_DECLARE_ERROR(15414)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION Macro

GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15417)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE Macro

GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE PRL_RESULT_DECLARE_ERROR(15416)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH Macro

GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH PRL_RESULT_DECLARE_ERROR(15418)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DLCITEM_DWNLD_UNEXPECTED Macro

GUI_ERR_DLCITEM_DWNLD_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DLCITEM_DWNLD_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15413)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION Macro

GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION PRL_RESULT_DECLARE_ERROR(15357)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED Macro

GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED PRL_RESULT_DECLARE_ERROR(15338)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_FAILED Macro

GUI_ERR_DOWNLOADING_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_FAILED PRL_RESULT_DECLARE_ERROR(15470)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED Macro

GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED PRL_RESULT_DECLARE_ERROR(15255)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED Macro

GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED PRL_RESULT_DECLARE_ERROR(15259)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_PIS_FAILED Macro

GUI_ERR_DOWNLOADING_PIS_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_PIS_FAILED PRL_RESULT_DECLARE_ERROR(15254)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED Macro

GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED PRL_RESULT_DECLARE_ERROR(15439)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_FAILED_TO_INIT_SDK_LIB Macro

GUI_ERR_FAILED_TO_INIT_SDK_LIB Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_FAILED_TO_INIT_SDK_LIB PRL_RESULT_DECLARE_ERROR(15353)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_HOST_NOT_SUPPORTED Macro

GUI_ERR_HOST_NOT_SUPPORTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_HOST_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(15462)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_IMAGE_PATH_NOT_SPECIFIED Macro

GUI_ERR_IMAGE_PATH_NOT_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_IMAGE_PATH_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15028)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INCORRECT_SHARED_FOLDER_NAME Macro

GUI_ERR_INCORRECT_SHARED_FOLDER_NAME Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INCORRECT_SHARED_FOLDER_NAME PRL_RESULT_DECLARE_SUCCESS(15044)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INCORRECT_SHARED_FOLDER_PATH Macro

GUI_ERR_INCORRECT_SHARED_FOLDER_PATH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INCORRECT_SHARED_FOLDER_PATH PRL_RESULT_DECLARE_SUCCESS(15064)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED Macro

GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED PRL_RESULT_DECLARE_ERROR(15168)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INSTALLATION_DOWNLOADING_FAILED Macro

GUI_ERR_INSTALLATION_DOWNLOADING_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INSTALLATION_DOWNLOADING_FAILED PRL_RESULT_DECLARE_ERROR(15471)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INSTALLING_FAILED Macro

GUI_ERR_INSTALLING_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INSTALLING_FAILED PRL_RESULT_DECLARE_ERROR(15472)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED Macro

GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED PRL_RESULT_DECLARE_ERROR(15256)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INVALID_ADAPTER_ADDRESS Macro

GUI_ERR_INVALID_ADAPTER_ADDRESS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INVALID_ADAPTER_ADDRESS PRL_RESULT_DECLARE_ERROR(15162)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INVALID_MAC_ADDRESS Macro

GUI_ERR_INVALID_MAC_ADDRESS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INVALID_MAC_ADDRESS PRL_RESULT_DECLARE_SUCCESS(15060)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INVALID_OUTPUT_PATH Macro

GUI_ERR_INVALID_OUTPUT_PATH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INVALID_OUTPUT_PATH PRL_RESULT_DECLARE_SUCCESS(15026)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INVALID_SHARED_FOLDER_PATH Macro

GUI_ERR_INVALID_SHARED_FOLDER_PATH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INVALID_SHARED_FOLDER_PATH PRL_RESULT_DECLARE_SUCCESS(15035)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_INVALID_VM_NAME_SPECIFIED Macro

GUI_ERR_INVALID_VM_NAME_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_INVALID_VM_NAME_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15045)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_IVALID_VM_UUID_MISMATCH Macro

GUI_ERR_IVALID_VM_UUID_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_IVALID_VM_UUID_MISMATCH PRL_RESULT_DECLARE_ERROR(15194)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_LEGACY_HDD_NOT_SUPPORTED Macro

GUI_ERR_LEGACY_HDD_NOT_SUPPORTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_LEGACY_HDD_NOT_SUPPORTED PRL_RESULT_DECLARE_SUCCESS(15112)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_MIGRATE_PC_ALREADY_RUNNING Macro

GUI_ERR_MIGRATE_PC_ALREADY_RUNNING Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_MIGRATE_PC_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(15337)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM Macro

GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM PRL_RESULT_DECLARE_ERROR(15336)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE Macro

GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE PRL_RESULT_DECLARE_ERROR(15335)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED Macro

GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED PRL_RESULT_DECLARE_ERROR(15261)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN Macro

GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN PRL_RESULT_DECLARE_ERROR(15263)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED Macro

GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED PRL_RESULT_DECLARE_ERROR(15260)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN Macro

GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN PRL_RESULT_DECLARE_ERROR(15264)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS Macro

GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS PRL_RESULT_DECLARE_SUCCESS(15039)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH Macro

GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH PRL_RESULT_DECLARE_SUCCESS(15040)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE Macro

GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE PRL_RESULT_DECLARE_SUCCESS(15041)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NET_ADAPTER_EXISTS Macro

GUI_ERR_NET_ADAPTER_EXISTS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NET_ADAPTER_EXISTS PRL_RESULT_DECLARE_ERROR(15199)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NET_ADAPTER_NAME_EMPTY Macro

GUI_ERR_NET_ADAPTER_NAME_EMPTY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NET_ADAPTER_NAME_EMPTY PRL_RESULT_DECLARE_ERROR(15200)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NEWER_APP_ALREADY_RUNNING Macro

GUI_ERR_NEWER_APP_ALREADY_RUNNING Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NEWER_APP_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(15373)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_EMAIL_ACCOUNT Macro

GUI_ERR_NO_EMAIL_ACCOUNT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_EMAIL_ACCOUNT PRL_RESULT_DECLARE_ERROR(15279)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL Macro

GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL PRL_RESULT_DECLARE_ERROR(15475)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_INSTALLATION_DISC Macro

GUI_ERR_NO_INSTALLATION_DISC Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_INSTALLATION_DISC PRL_RESULT_DECLARE_ERROR(15277)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_INSTALLER_FILE Macro

GUI_ERR_NO_INSTALLER_FILE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_INSTALLER_FILE PRL_RESULT_DECLARE_ERROR(15208)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_OPTICAL_DRIVE Macro

GUI_ERR_NO_OPTICAL_DRIVE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_OPTICAL_DRIVE PRL_RESULT_DECLARE_ERROR(15349)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE Macro

GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE PRL_RESULT_DECLARE_SUCCESS(15116)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE Macro

GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE PRL_RESULT_DECLARE_SUCCESS(15115)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID Macro

GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID PRL_RESULT_DECLARE_SUCCESS(15091)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR Macro

GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR PRL_RESULT_DECLARE_SUCCESS(15090)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE Macro

GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE PRL_RESULT_DECLARE_SUCCESS(15089)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OLDER_APP_ALREADY_RUNNING Macro

GUI_ERR_OLDER_APP_ALREADY_RUNNING Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OLDER_APP_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(15374)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE Macro

GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE PRL_RESULT_DECLARE_ERROR(15327)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH Macro

GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH PRL_RESULT_DECLARE_ERROR(15331)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR Macro

GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR PRL_RESULT_DECLARE_ERROR(15326)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION Macro

GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15329)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE Macro

GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE PRL_RESULT_DECLARE_ERROR(15328)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH Macro

GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH PRL_RESULT_DECLARE_ERROR(15330)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OS_IMG_DWNLD_UNEXPECTED Macro

GUI_ERR_OS_IMG_DWNLD_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OS_IMG_DWNLD_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15325)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED Macro

GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15030)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION Macro

GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION PRL_RESULT_DECLARE_SUCCESS(15110)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION Macro

GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION PRL_RESULT_DECLARE_SUCCESS(15111)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PARENT_LINKED_VM_NOT_FOUND Macro

GUI_ERR_PARENT_LINKED_VM_NOT_FOUND Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PARENT_LINKED_VM_NOT_FOUND PRL_RESULT_DECLARE_ERROR(15467)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR Macro

GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR PRL_RESULT_DECLARE_ERROR(15438)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PAX_AGENT_INSTALL_FAILURE Macro

GUI_ERR_PAX_AGENT_INSTALL_FAILURE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PAX_AGENT_INSTALL_FAILURE PRL_RESULT_DECLARE_ERROR(15445)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PAX_AGENT_NO_CONNECTION Macro

GUI_ERR_PAX_AGENT_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PAX_AGENT_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15437)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED Macro

GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED PRL_RESULT_DECLARE_ERROR(15412)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PMC_INVALID_CREDENTIALS Macro

GUI_ERR_PMC_INVALID_CREDENTIALS Macro
GUI_ERR Macros

Obsolete error codes - use ones with prefix PRL_ERR_PPC

Syntax
#define GUI_ERR_PMC_INVALID_CREDENTIALS PRL_RESULT_DECLARE_ERROR(15272)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT Macro

GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT PRL_RESULT_DECLARE_ERROR(15273)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PMC_SERVER_BUSY Macro

GUI_ERR_PMC_SERVER_BUSY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PMC_SERVER_BUSY PRL_RESULT_DECLARE_ERROR(15274)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PMC_UNABLE_TO_CONNECT Macro

GUI_ERR_PMC_UNABLE_TO_CONNECT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PMC_UNABLE_TO_CONNECT PRL_RESULT_DECLARE_ERROR(15275)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE Macro

GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE PRL_RESULT_DECLARE_ERROR(15160)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_POST_REPORT Macro

GUI_ERR_POST_REPORT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_POST_REPORT PRL_RESULT_DECLARE_SUCCESS(15140)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED Macro

GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED PRL_RESULT_DECLARE_ERROR(15271)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE Macro

GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE PRL_RESULT_DECLARE_SUCCESS(15097)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER Macro

GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER PRL_RESULT_DECLARE_ERROR(15247)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION Macro

GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION PRL_RESULT_DECLARE_ERROR(15239)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR Macro

GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR PRL_RESULT_DECLARE_ERROR(15241)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL Macro

GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL PRL_RESULT_DECLARE_ERROR(15240)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR Macro

GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR PRL_RESULT_DECLARE_ERROR(15242)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR Macro

GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR PRL_RESULT_DECLARE_ERROR(15345)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED Macro

GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED PRL_RESULT_DECLARE_ERROR(15379)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START Macro

GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START PRL_RESULT_DECLARE_ERROR(15378)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE Macro

GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE PRL_RESULT_DECLARE_ERROR(15377)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SERVER_CUSTOM_NAME_EMPTY Macro

GUI_ERR_SERVER_CUSTOM_NAME_EMPTY Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SERVER_CUSTOM_NAME_EMPTY PRL_RESULT_DECLARE_SUCCESS(15031)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SERVER_CUSTOM_NAME_EXISTS Macro

GUI_ERR_SERVER_CUSTOM_NAME_EXISTS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SERVER_CUSTOM_NAME_EXISTS PRL_RESULT_DECLARE_SUCCESS(15027)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SERVER_WRONG_CUSTOM_NAME Macro

GUI_ERR_SERVER_WRONG_CUSTOM_NAME Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SERVER_WRONG_CUSTOM_NAME PRL_RESULT_DECLARE_SUCCESS(15037)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_EXISTS Macro

GUI_ERR_SHARED_FOLDER_NAME_EXISTS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_EXISTS PRL_RESULT_DECLARE_SUCCESS(15017)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED Macro

GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15062)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM Macro

GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM PRL_RESULT_DECLARE_SUCCESS(15046)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_PATH_EXISTS Macro

GUI_ERR_SHARED_FOLDER_PATH_EXISTS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHARED_FOLDER_PATH_EXISTS PRL_RESULT_DECLARE_SUCCESS(15018)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED Macro

GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15063)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS Macro

GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS PRL_RESULT_DECLARE_SUCCESS(15024)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP Macro

GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_SUCCESS(15073)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SNAPSHOT_VM_WITH_VTD Macro

GUI_ERR_SNAPSHOT_VM_WITH_VTD Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SNAPSHOT_VM_WITH_VTD PRL_RESULT_DECLARE_SUCCESS(15094)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SOCKET_NOT_SPECIFIED Macro

GUI_ERR_SOCKET_NOT_SPECIFIED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SOCKET_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15029)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST Macro

GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_SUCCESS(15095)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_SUCCESS(15096)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_SUSPEND_VM_WITH_VTD Macro

GUI_ERR_SUSPEND_VM_WITH_VTD Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_SUSPEND_VM_WITH_VTD PRL_RESULT_DECLARE_SUCCESS(15107)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UID_0_DUPLICATION Macro

GUI_ERR_UID_0_DUPLICATION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UID_0_DUPLICATION PRL_RESULT_DECLARE_ERROR(15476)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UNABLE_START_LYM Macro

GUI_ERR_UNABLE_START_LYM Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UNABLE_START_LYM PRL_RESULT_DECLARE_ERROR(15234)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UNABLE_START_TRANSPORTER Macro

GUI_ERR_UNABLE_START_TRANSPORTER Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UNABLE_START_TRANSPORTER PRL_RESULT_DECLARE_ERROR(15233)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD Macro

GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD PRL_RESULT_DECLARE_ERROR(15278)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UNABLE_TO_START_SERVICES Macro

GUI_ERR_UNABLE_TO_START_SERVICES Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UNABLE_TO_START_SERVICES PRL_RESULT_DECLARE_ERROR(15381)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED Macro

GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED PRL_RESULT_DECLARE_ERROR(15258)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPDATE_INSTALL_FAILED Macro

GUI_ERR_UPDATE_INSTALL_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPDATE_INSTALL_FAILED PRL_RESULT_DECLARE_ERROR(15209)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPDATE_UNABLE_TO_CHECK Macro

GUI_ERR_UPDATE_UNABLE_TO_CHECK Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPDATE_UNABLE_TO_CHECK PRL_RESULT_DECLARE_ERROR(15210)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPDATER_NO_CONNECTION Macro

GUI_ERR_UPDATER_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPDATER_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15207)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPDATER_NO_FILE Macro

GUI_ERR_UPDATER_NO_FILE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPDATER_NO_FILE PRL_RESULT_DECLARE_ERROR(15206)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE Macro

GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE PRL_RESULT_DECLARE_ERROR(15407)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR Macro

GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR PRL_RESULT_DECLARE_ERROR(15406)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_UPGRADE_REQUEST_UNEXPECTED Macro

GUI_ERR_UPGRADE_REQUEST_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_UPGRADE_REQUEST_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15405)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT Macro

GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT PRL_RESULT_DECLARE_SUCCESS(15082)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR Macro

GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR PRL_RESULT_DECLARE_SUCCESS(15081)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT Macro

GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT PRL_RESULT_DECLARE_SUCCESS(15086)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR Macro

GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR PRL_RESULT_DECLARE_SUCCESS(15085)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VOLUME_LICENSE_EXPIRED Macro

GUI_ERR_VOLUME_LICENSE_EXPIRED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VOLUME_LICENSE_EXPIRED PRL_RESULT_DECLARE_ERROR(15430)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE Macro

GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE PRL_RESULT_DECLARE_SUCCESS(15114)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES Macro

GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES PRL_RESULT_DECLARE_SUCCESS(15108)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES Macro

GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES PRL_RESULT_DECLARE_SUCCESS(15109)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WEB_STORE_INVALID_DATA Macro

GUI_ERR_WEB_STORE_INVALID_DATA Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WEB_STORE_INVALID_DATA PRL_RESULT_DECLARE_ERROR(15324)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WEB_STORE_NO_CONNECTION Macro

GUI_ERR_WEB_STORE_NO_CONNECTION Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WEB_STORE_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(15322)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WEB_STORE_NO_DATA Macro

GUI_ERR_WEB_STORE_NO_DATA Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WEB_STORE_NO_DATA PRL_RESULT_DECLARE_ERROR(15323)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WEB_STORE_UNEXPECTED Macro

GUI_ERR_WEB_STORE_UNEXPECTED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WEB_STORE_UNEXPECTED PRL_RESULT_DECLARE_ERROR(15321)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL Macro

GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL PRL_RESULT_DECLARE_ERROR(15442)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED Macro

GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED PRL_RESULT_DECLARE_ERROR(15441)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN Macro

GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN PRL_RESULT_DECLARE_ERROR(15443)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED Macro

GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED PRL_RESULT_DECLARE_ERROR(15440)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN Macro

GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN PRL_RESULT_DECLARE_ERROR(15444)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WRONG_BACKUP_PATH Macro

GUI_ERR_WRONG_BACKUP_PATH Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WRONG_BACKUP_PATH PRL_RESULT_DECLARE_ERROR(15214)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERR_WRONG_NUMBER_OF_CPU Macro

GUI_ERR_WRONG_NUMBER_OF_CPU Macro
GUI_ERR Macros
Syntax
#define GUI_ERR_WRONG_NUMBER_OF_CPU PRL_RESULT_DECLARE_ERROR(15020)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL Macro

GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL Macro
GUI_INFO Macros
Syntax
#define GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL PRL_RESULT_DECLARE_ERROR(15262)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI Macro

GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI Macro
GUI_ERR Macros
Syntax
#define GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI PRL_RESULT_DECLARE_SUCCESS(15130)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL Macro

GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL PRL_RESULT_DECLARE_SUCCESS(15427)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK Macro

GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK PRL_RESULT_DECLARE_SUCCESS(15125)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK Macro

GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK PRL_RESULT_DECLARE_SUCCESS(15126)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM Macro

GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM PRL_RESULT_DECLARE_SUCCESS(15154)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK Macro

GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK PRL_RESULT_DECLARE_SUCCESS(15152)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM Macro

GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM PRL_RESULT_DECLARE_SUCCESS(15156)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_CANT_DISPLAY_HELP_TOPIC Macro

GUI_INFO_CANT_DISPLAY_HELP_TOPIC Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_CANT_DISPLAY_HELP_TOPIC PRL_RESULT_DECLARE_SUCCESS(15043)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD Macro

GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD PRL_RESULT_DECLARE_SUCCESS(15019)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD Macro

GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD PRL_RESULT_DECLARE_SUCCESS(15066)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_CLEAN_UP_DISK_SPACE Macro

GUI_INFO_CLEAN_UP_DISK_SPACE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_CLEAN_UP_DISK_SPACE PRL_RESULT_DECLARE_SUCCESS(15468)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST Macro

GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST PRL_RESULT_DECLARE_ERROR(15228)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST Macro

GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST PRL_RESULT_DECLARE_ERROR(15229)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D Macro

GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D PRL_RESULT_DECLARE_ERROR(15303)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY Macro

GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY PRL_RESULT_DECLARE_ERROR(15224)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS Macro

GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS PRL_RESULT_DECLARE_ERROR(15231)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY Macro

GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY PRL_RESULT_DECLARE_ERROR(15232)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED Macro

GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED PRL_RESULT_DECLARE_ERROR(15227)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_CANNOTSTART_SMOFF Macro

GUI_INFO_COHERENCE_CANNOTSTART_SMOFF Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_CANNOTSTART_SMOFF PRL_RESULT_DECLARE_ERROR(15226)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST Macro

GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST PRL_RESULT_DECLARE_ERROR(15230)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_STOPPED_LINUX_3D Macro

GUI_INFO_COHERENCE_STOPPED_LINUX_3D Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_STOPPED_LINUX_3D PRL_RESULT_DECLARE_ERROR(15304)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_COHERENCE_STOPPED_LOWMEMORY Macro

GUI_INFO_COHERENCE_STOPPED_LOWMEMORY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_COHERENCE_STOPPED_LOWMEMORY PRL_RESULT_DECLARE_ERROR(15225)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_CONFIGURING_THE_DOCK Macro

GUI_INFO_CONFIGURING_THE_DOCK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_CONFIGURING_THE_DOCK PRL_RESULT_DECLARE_SUCCESS(15120)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_CONVERT_SUCCEDED_OTHER_OS Macro

GUI_INFO_CONVERT_SUCCEDED_OTHER_OS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_CONVERT_SUCCEDED_OTHER_OS PRL_RESULT_DECLARE_SUCCESS(15216)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_CTRL_ALT_DEL_FROM_MENU Macro

GUI_INFO_CTRL_ALT_DEL_FROM_MENU Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_CTRL_ALT_DEL_FROM_MENU PRL_RESULT_DECLARE_SUCCESS(15385)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_CTRL_ALT_DEL_PRESSED Macro

GUI_INFO_CTRL_ALT_DEL_PRESSED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_CTRL_ALT_DEL_PRESSED PRL_RESULT_DECLARE_SUCCESS(15157)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED Macro

GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED PRL_RESULT_DECLARE_SUCCESS(15394)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_ENTER_IN_POWERSAVE_MODE Macro

GUI_INFO_ENTER_IN_POWERSAVE_MODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_ENTER_IN_POWERSAVE_MODE PRL_RESULT_DECLARE_SUCCESS(15399)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_ENTER_TO_PRESENTATION_MODE Macro

GUI_INFO_ENTER_TO_PRESENTATION_MODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_ENTER_TO_PRESENTATION_MODE PRL_RESULT_DECLARE_SUCCESS(15402)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_EXIT_FROM_PRESENTATION_MODE Macro

GUI_INFO_EXIT_FROM_PRESENTATION_MODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_EXIT_FROM_PRESENTATION_MODE PRL_RESULT_DECLARE_SUCCESS(15398)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_EXPRESS_INSTALLATION_FINISHED Macro

GUI_INFO_EXPRESS_INSTALLATION_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_EXPRESS_INSTALLATION_FINISHED PRL_RESULT_DECLARE_SUCCESS(15395)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_FEATURE_RESTRICTED Macro

GUI_INFO_FEATURE_RESTRICTED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_FEATURE_RESTRICTED PRL_RESULT_DECLARE_SUCCESS(15139)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_FEEDBACK_SUCCESS Macro

GUI_INFO_FEEDBACK_SUCCESS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_FEEDBACK_SUCCESS PRL_RESULT_DECLARE_SUCCESS(15458)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE Macro

GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE PRL_RESULT_DECLARE_SUCCESS(15376)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_GUEST_HIRES_OPTION_CHANGED Macro

GUI_INFO_GUEST_HIRES_OPTION_CHANGED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_GUEST_HIRES_OPTION_CHANGED PRL_RESULT_DECLARE_SUCCESS(15410)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_HIDDEN_MESSAGES_RESTORED Macro

GUI_INFO_HIDDEN_MESSAGES_RESTORED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_HIDDEN_MESSAGES_RESTORED PRL_RESULT_DECLARE_SUCCESS(15158)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_IN_FULLSCREEN_NOTIFICATION Macro

GUI_INFO_IN_FULLSCREEN_NOTIFICATION Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_IN_FULLSCREEN_NOTIFICATION PRL_RESULT_DECLARE_SUCCESS(15128)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE Macro

GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE PRL_RESULT_DECLARE_SUCCESS(15480)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_IN_SEAMLESS_NOTIFICATION Macro

GUI_INFO_IN_SEAMLESS_NOTIFICATION Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_IN_SEAMLESS_NOTIFICATION PRL_RESULT_DECLARE_SUCCESS(15124)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON Macro

GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON PRL_RESULT_DECLARE_SUCCESS(15448)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST Macro

GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST PRL_RESULT_DECLARE_SUCCESS(15141)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_LIN Macro

GUI_INFO_INSTALL_TOOLS_LIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_INSTALL_TOOLS_LIN PRL_RESULT_DECLARE_SUCCESS(15023)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_MAC Macro

GUI_INFO_INSTALL_TOOLS_MAC Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_INSTALL_TOOLS_MAC PRL_RESULT_DECLARE_SUCCESS(15022)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_WIN Macro

GUI_INFO_INSTALL_TOOLS_WIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_INSTALL_TOOLS_WIN PRL_RESULT_DECLARE_SUCCESS(15021)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_INSTALLED_GUEST_APPS_DIALOG Macro

GUI_INFO_INSTALLED_GUEST_APPS_DIALOG Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_INSTALLED_GUEST_APPS_DIALOG PRL_RESULT_DECLARE_SUCCESS(15457)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_INVALID_LOGIN_OR_PASS Macro

GUI_INFO_INVALID_LOGIN_OR_PASS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_INVALID_LOGIN_OR_PASS PRL_RESULT_DECLARE_ERROR(15301)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_IPN_MESSAGE Macro

GUI_INFO_IPN_MESSAGE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_IPN_MESSAGE PRL_RESULT_DECLARE_SUCCESS(15456)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM Macro

GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM PRL_RESULT_DECLARE_SUCCESS(15155)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY Macro

GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY PRL_RESULT_DECLARE_SUCCESS(15474)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION Macro

GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION PRL_RESULT_DECLARE_SUCCESS(15129)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL Macro

GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL PRL_RESULT_DECLARE_SUCCESS(15454)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED Macro

GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED PRL_RESULT_DECLARE_SUCCESS(15092)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_NEW_VERSION_AVAILABLE Macro

GUI_INFO_NEW_VERSION_AVAILABLE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_NEW_VERSION_AVAILABLE PRL_RESULT_DECLARE_SUCCESS(15452)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT Macro

GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT PRL_RESULT_DECLARE_SUCCESS(15478)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_OFFICE_SHARED_CLOUDS_KB Macro

GUI_INFO_OFFICE_SHARED_CLOUDS_KB Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_OFFICE_SHARED_CLOUDS_KB PRL_RESULT_DECLARE_SUCCESS(15461)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_PASSWORD_RESET_CHECK_EMAIL Macro

GUI_INFO_PASSWORD_RESET_CHECK_EMAIL Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_PASSWORD_RESET_CHECK_EMAIL PRL_RESULT_DECLARE_SUCCESS(15286)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_PASSWORD_RESET_ENTER_EMAIL Macro

GUI_INFO_PASSWORD_RESET_ENTER_EMAIL Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_PASSWORD_RESET_ENTER_EMAIL PRL_RESULT_DECLARE_SUCCESS(15285)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY Macro

GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY PRL_RESULT_DECLARE_SUCCESS(15105)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY Macro

GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY PRL_RESULT_DECLARE_SUCCESS(15473)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED Macro

GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED PRL_RESULT_DECLARE_SUCCESS(15482)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_ALREADY_REGISTERED Macro

GUI_INFO_REG_ALREADY_REGISTERED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_ALREADY_REGISTERED PRL_RESULT_DECLARE_ERROR(15297)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_CONNECTION Macro

GUI_INFO_REG_CONNECTION Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_CONNECTION PRL_RESULT_DECLARE_ERROR(15300)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_GENERAL_ERROR Macro

GUI_INFO_REG_GENERAL_ERROR Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_GENERAL_ERROR PRL_RESULT_DECLARE_ERROR(15302)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_INVALID_EMAIL Macro

GUI_INFO_REG_INVALID_EMAIL Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_INVALID_EMAIL PRL_RESULT_DECLARE_ERROR(15296)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_INVALID_KEY Macro

GUI_INFO_REG_INVALID_KEY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_INVALID_KEY PRL_RESULT_DECLARE_ERROR(15295)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_INVALID_USER Macro

GUI_INFO_REG_INVALID_USER Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_INVALID_USER PRL_RESULT_DECLARE_ERROR(15299)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_OK Macro

GUI_INFO_REG_OK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_OK PRL_RESULT_DECLARE_SUCCESS(15294)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REG_REQUIRED_FIELDS Macro

GUI_INFO_REG_REQUIRED_FIELDS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REG_REQUIRED_FIELDS PRL_RESULT_DECLARE_ERROR(15298)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED Macro

GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED PRL_RESULT_DECLARE_ERROR(15287)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED Macro

GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED PRL_RESULT_DECLARE_SUCCESS(15248)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK Macro

GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK PRL_RESULT_DECLARE_SUCCESS(15243)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE Macro

GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE PRL_RESULT_DECLARE_ERROR(15244)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED Macro

GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED PRL_RESULT_DECLARE_SUCCESS(15245)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE Macro

GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE PRL_RESULT_DECLARE_ERROR(15246)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REINSTALL_TOOLS_LIN Macro

GUI_INFO_REINSTALL_TOOLS_LIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_REINSTALL_TOOLS_LIN PRL_RESULT_DECLARE_SUCCESS(15146)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_REINSTALL_TOOLS_MAC Macro

GUI_INFO_REINSTALL_TOOLS_MAC Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_REINSTALL_TOOLS_MAC PRL_RESULT_DECLARE_SUCCESS(15145)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_REINSTALL_TOOLS_OTHER Macro

GUI_INFO_REINSTALL_TOOLS_OTHER Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_REINSTALL_TOOLS_OTHER PRL_RESULT_DECLARE_SUCCESS(15147)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_REINSTALL_TOOLS_WIN Macro

GUI_INFO_REINSTALL_TOOLS_WIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_REINSTALL_TOOLS_WIN PRL_RESULT_DECLARE_SUCCESS(15144)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT Macro

GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT PRL_RESULT_DECLARE_ERROR(15238)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT Macro

GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT PRL_RESULT_DECLARE_ERROR(15237)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT Macro

GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT PRL_RESULT_DECLARE_ERROR(15236)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_REMOTE_SESSION_ACTIVE Macro

GUI_INFO_REMOTE_SESSION_ACTIVE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_REMOTE_SESSION_ACTIVE PRL_RESULT_DECLARE_SUCCESS(15481)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_RUN_COMPRESSOR_WIN Macro

GUI_INFO_RUN_COMPRESSOR_WIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_RUN_COMPRESSOR_WIN PRL_RESULT_DECLARE_SUCCESS(15067)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM Macro

GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM PRL_RESULT_DECLARE_SUCCESS(15113)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_SERVER_RESTART_IS_NEEDED Macro

GUI_INFO_SERVER_RESTART_IS_NEEDED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_SERVER_RESTART_IS_NEEDED PRL_RESULT_DECLARE_SUCCESS(15034)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED Macro

GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED PRL_RESULT_DECLARE_SUCCESS(15460)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED Macro

GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED PRL_RESULT_DECLARE_SUCCESS(15123)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER Macro

GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER PRL_RESULT_DECLARE_SUCCESS(15311)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM Macro

GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM PRL_RESULT_DECLARE_SUCCESS(15193)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_SNAPSHOT_DELETE_FINISHED Macro

GUI_INFO_SNAPSHOT_DELETE_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_SNAPSHOT_DELETE_FINISHED PRL_RESULT_DECLARE_SUCCESS(15397)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_SOFTWARE_UP_TO_DATE Macro

GUI_INFO_SOFTWARE_UP_TO_DATE Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_SOFTWARE_UP_TO_DATE PRL_RESULT_DECLARE_SUCCESS(15282)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_SWITCH_TO_FULLSCREEN Macro

GUI_INFO_SWITCH_TO_FULLSCREEN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_SWITCH_TO_FULLSCREEN PRL_RESULT_DECLARE_SUCCESS(15065)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_TASK_ALREADY_RUNNING Macro

GUI_INFO_TASK_ALREADY_RUNNING Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_TASK_ALREADY_RUNNING PRL_RESULT_DECLARE_SUCCESS(15404)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_TASK_STEP_SKIPPED Macro

GUI_INFO_TASK_STEP_SKIPPED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_TASK_STEP_SKIPPED PRL_RESULT_DECLARE_SUCCESS(15354)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_TOOLS_INSTALL_OTHER Macro

GUI_INFO_TOOLS_INSTALL_OTHER Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_TOOLS_INSTALL_OTHER PRL_RESULT_DECLARE_SUCCESS(15075)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_TRIAL_GUEST_WARNING Macro

GUI_INFO_TRIAL_GUEST_WARNING Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_TRIAL_GUEST_WARNING PRL_RESULT_DECLARE_SUCCESS(15463)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS Macro

GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS PRL_RESULT_DECLARE_SUCCESS(15257)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_UPDATE_FINISHED Macro

GUI_INFO_UPDATE_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_UPDATE_FINISHED PRL_RESULT_DECLARE_SUCCESS(15400)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_UPDATE_TOOLS_LIN Macro

GUI_INFO_UPDATE_TOOLS_LIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_UPDATE_TOOLS_LIN PRL_RESULT_DECLARE_SUCCESS(15150)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_UPDATE_TOOLS_MAC Macro

GUI_INFO_UPDATE_TOOLS_MAC Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_UPDATE_TOOLS_MAC PRL_RESULT_DECLARE_SUCCESS(15149)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_UPDATE_TOOLS_OTHER Macro

GUI_INFO_UPDATE_TOOLS_OTHER Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_UPDATE_TOOLS_OTHER PRL_RESULT_DECLARE_SUCCESS(15151)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_UPDATE_TOOLS_WIN Macro

GUI_INFO_UPDATE_TOOLS_WIN Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_UPDATE_TOOLS_WIN PRL_RESULT_DECLARE_SUCCESS(15148)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_UPGRADE_FINISHED Macro

GUI_INFO_UPGRADE_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_UPGRADE_FINISHED PRL_RESULT_DECLARE_SUCCESS(15401)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER Macro

GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER PRL_RESULT_DECLARE_SUCCESS(15429)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_USB3_DRIVERS_REQUIRED_WIN Macro

GUI_INFO_USB3_DRIVERS_REQUIRED_WIN Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_USB3_DRIVERS_REQUIRED_WIN PRL_RESULT_DECLARE_SUCCESS(15428)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_USER_REGISTRATION_DLG_SEND_OK Macro

GUI_INFO_USER_REGISTRATION_DLG_SEND_OK Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_USER_REGISTRATION_DLG_SEND_OK PRL_RESULT_DECLARE_SUCCESS(15159)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_CLEANUP_NOTHING_TO_DO Macro

GUI_INFO_VM_CLEANUP_NOTHING_TO_DO Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_CLEANUP_NOTHING_TO_DO PRL_RESULT_DECLARE_SUCCESS(15392)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC Macro

GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC PRL_RESULT_DECLARE_SUCCESS(15479)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_COMPACTING_FINISHED Macro

GUI_INFO_VM_COMPACTING_FINISHED Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_COMPACTING_FINISHED PRL_RESULT_DECLARE_SUCCESS(15396)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_DECRYPTED_SUCCESSFULLY Macro

GUI_INFO_VM_DECRYPTED_SUCCESSFULLY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_DECRYPTED_SUCCESSFULLY PRL_RESULT_DECLARE_SUCCESS(15283)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY Macro

GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY PRL_RESULT_DECLARE_SUCCESS(15284)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_HW_UPGRADE_COMPLETED Macro

GUI_INFO_VM_HW_UPGRADE_COMPLETED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_VM_HW_UPGRADE_COMPLETED PRL_RESULT_DECLARE_SUCCESS(15080)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED Macro

GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED PRL_RESULT_DECLARE_SUCCESS(15084)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_VM_IN_ISOLATION_MAC Macro

GUI_INFO_VM_IN_ISOLATION_MAC Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_IN_ISOLATION_MAC PRL_RESULT_DECLARE_SUCCESS(15122)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_IN_ISOLATION_WIN Macro

GUI_INFO_VM_IN_ISOLATION_WIN Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_VM_IN_ISOLATION_WIN PRL_RESULT_DECLARE_SUCCESS(15121)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_INFO_VM_SHUTDOWN_CONDITIONS Macro

GUI_INFO_VM_SHUTDOWN_CONDITIONS Macro
GUI_ERR Macros
Syntax
#define GUI_INFO_VM_SHUTDOWN_CONDITIONS PRL_RESULT_DECLARE_SUCCESS(15025)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS Macro

GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS Macro
GUI_INFO Macros
Syntax
#define GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS PRL_RESULT_DECLARE_SUCCESS(15455)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT Macro

GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT Macro
GUI_INFO Macros
Syntax
#define GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT PRL_RESULT_DECLARE_SUCCESS(14039)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD Macro

GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD PRL_RESULT_DECLARE_SUCCESS(15198)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro

GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro
GUI_ERR Macros

GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now

Syntax
#define GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION PRL_RESULT_DECLARE_SUCCESS(15057)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_CANCEL_DEPLOY_OPERATION Macro

GUI_QUESTION_CANCEL_DEPLOY_OPERATION Macro
GUI_ERR Macros

GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now

Syntax
#define GUI_QUESTION_CANCEL_DEPLOY_OPERATION PRL_RESULT_DECLARE_SUCCESS(14010)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_CANCEL_INSTALL_DELETE Macro

GUI_QUESTION_CANCEL_INSTALL_DELETE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CANCEL_INSTALL_DELETE PRL_RESULT_DECLARE_SUCCESS(15313)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CANCEL_INSTALL_SUSUPEND Macro

GUI_QUESTION_CANCEL_INSTALL_SUSUPEND Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CANCEL_INSTALL_SUSUPEND PRL_RESULT_DECLARE_SUCCESS(15312)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST Macro

GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST PRL_RESULT_DECLARE_SUCCESS(15061)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG Macro

GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG PRL_RESULT_DECLARE_SUCCESS(15362)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING Macro

GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING PRL_RESULT_DECLARE_SUCCESS(15363)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CLOSE_VM_WINDOW Macro

GUI_QUESTION_CLOSE_VM_WINDOW Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CLOSE_VM_WINDOW PRL_RESULT_DECLARE_ERROR(15356)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_COHERENCE_NOTIFICATION Macro

GUI_QUESTION_COHERENCE_NOTIFICATION Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_COHERENCE_NOTIFICATION PRL_RESULT_DECLARE_SUCCESS(15077)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE Macro

GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE PRL_RESULT_DECLARE_SUCCESS(14011)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_CONFIRM_UPDATE_CANCEL Macro

GUI_QUESTION_CONFIRM_UPDATE_CANCEL Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CONFIRM_UPDATE_CANCEL PRL_RESULT_DECLARE_SUCCESS(15390)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED Macro

GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED PRL_RESULT_DECLARE_SUCCESS(15213)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED Macro

GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED PRL_RESULT_DECLARE_SUCCESS(15217)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED Macro

GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED PRL_RESULT_DECLARE_SUCCESS(15215)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CONVERT_SUCCEDED Macro

GUI_QUESTION_CONVERT_SUCCEDED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CONVERT_SUCCEDED PRL_RESULT_DECLARE_SUCCESS(15212)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER Macro

GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER PRL_RESULT_DECLARE_SUCCESS(15375)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS Macro

GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS PRL_RESULT_DECLARE_SUCCESS(15318)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DELETE_CREATED_VM Macro

GUI_QUESTION_DELETE_CREATED_VM Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DELETE_CREATED_VM PRL_RESULT_DECLARE_SUCCESS(15317)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DELETE_OLD_VM Macro

GUI_QUESTION_DELETE_OLD_VM Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DELETE_OLD_VM PRL_RESULT_DECLARE_SUCCESS(15220)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT Macro

GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14048)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DELETE_VM_IMMEDIATELY Macro

GUI_QUESTION_DELETE_VM_IMMEDIATELY Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_DELETE_VM_IMMEDIATELY PRL_RESULT_DECLARE_SUCCESS(14027)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES Macro

GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES PRL_RESULT_DECLARE_SUCCESS(14046)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DESKTOP_IS_UNREGISTERED Macro

GUI_QUESTION_DESKTOP_IS_UNREGISTERED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DESKTOP_IS_UNREGISTERED PRL_RESULT_DECLARE_ERROR(15252)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS Macro

GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS PRL_RESULT_DECLARE_SUCCESS(14036)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS Macro

GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS PRL_RESULT_DECLARE_SUCCESS(14037)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_HOST_SLEEP Macro

GUI_QUESTION_DISABLE_HOST_SLEEP Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_HOST_SLEEP PRL_RESULT_DECLARE_SUCCESS(14035)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_OPTIONS Macro

GUI_QUESTION_DISABLE_OPTIONS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_OPTIONS PRL_RESULT_DECLARE_SUCCESS(15167)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_VERBOSE_LOG Macro

GUI_QUESTION_DISABLE_VERBOSE_LOG Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_VERBOSE_LOG PRL_RESULT_DECLARE_SUCCESS(14041)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLE_WINDOWS7_LOOK Macro

GUI_QUESTION_DISABLE_WINDOWS7_LOOK Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DISABLE_WINDOWS7_LOOK PRL_RESULT_DECLARE_SUCCESS(15446)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME Macro

GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME PRL_RESULT_DECLARE_SUCCESS(14020)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_DONT_USE_DIRECT_CONECTION Macro

GUI_QUESTION_DONT_USE_DIRECT_CONECTION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DONT_USE_DIRECT_CONECTION PRL_RESULT_DECLARE_SUCCESS(15288)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR Macro

GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR PRL_RESULT_DECLARE_SUCCESS(15058)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS Macro

GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS PRL_RESULT_DECLARE_SUCCESS(15059)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_DWNLD_RETRY Macro

GUI_QUESTION_DWNLD_RETRY Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DWNLD_RETRY PRL_RESULT_DECLARE_SUCCESS(15358)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE Macro

GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE PRL_RESULT_DECLARE_SUCCESS(15359)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH Macro

GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH PRL_RESULT_DECLARE_SUCCESS(15361)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION Macro

GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION PRL_RESULT_DECLARE_SUCCESS(15360)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_EDIT_SUSPENDED_VM Macro

GUI_QUESTION_EDIT_SUSPENDED_VM Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_EDIT_SUSPENDED_VM PRL_RESULT_DECLARE_SUCCESS(15093)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE Macro

GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE PRL_RESULT_DECLARE_SUCCESS(15435)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_BACKGROUND_UPDATE Macro

GUI_QUESTION_ENABLE_BACKGROUND_UPDATE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_BACKGROUND_UPDATE PRL_RESULT_DECLARE_SUCCESS(15453)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_CEP Macro

GUI_QUESTION_ENABLE_CEP Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_CEP PRL_RESULT_DECLARE_SUCCESS(14044)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING Macro

GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING PRL_RESULT_DECLARE_SUCCESS(14013)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_ENABLE_GUEST_SHARING Macro

GUI_QUESTION_ENABLE_GUEST_SHARING Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_GUEST_SHARING PRL_RESULT_DECLARE_SUCCESS(14045)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING Macro

GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING PRL_RESULT_DECLARE_SUCCESS(14014)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP Macro

GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP PRL_RESULT_DECLARE_SUCCESS(14017)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_ENABLE_PMU_SUPPORT Macro

GUI_QUESTION_ENABLE_PMU_SUPPORT Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_PMU_SUPPORT PRL_RESULT_DECLARE_SUCCESS(14038)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_SHARED_APPS Macro

GUI_QUESTION_ENABLE_SHARED_APPS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_SHARED_APPS PRL_RESULT_DECLARE_SUCCESS(15166)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION Macro

GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION PRL_RESULT_DECLARE_SUCCESS(15347)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH Macro

GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH PRL_RESULT_DECLARE_SUCCESS(15348)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION Macro

GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION Macro
Other Macros
Syntax
#define GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION PRL_RESULT_DECLARE_SUCCESS(14049)
File

PrlPrivateErrorsValues.h

Links
Other Macros


GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT Macro

GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT PRL_RESULT_DECLARE_SUCCESS(14034)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro

GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK PRL_RESULT_DECLARE_SUCCESS(15387)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro

GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14030)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE Macro

GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE PRL_RESULT_DECLARE_SUCCESS(15223)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START Macro

GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START PRL_RESULT_DECLARE_SUCCESS(15222)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_INSTALL_MAJOR_UPDATE Macro

GUI_QUESTION_INSTALL_MAJOR_UPDATE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_INSTALL_MAJOR_UPDATE PRL_RESULT_DECLARE_SUCCESS(14040)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_INSTALL_WINDOWS7_LOOK Macro

GUI_QUESTION_INSTALL_WINDOWS7_LOOK Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_INSTALL_WINDOWS7_LOOK PRL_RESULT_DECLARE_SUCCESS(15449)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_INVALID_VM_CORRUPTED Macro

GUI_QUESTION_INVALID_VM_CORRUPTED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_INVALID_VM_CORRUPTED PRL_RESULT_DECLARE_ERROR(15315)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_INVALID_VM_NOT_AVAILABLE Macro

GUI_QUESTION_INVALID_VM_NOT_AVAILABLE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_INVALID_VM_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(15314)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ISOLATE_VM Macro

GUI_QUESTION_ISOLATE_VM Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ISOLATE_VM PRL_RESULT_DECLARE_SUCCESS(15165)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_ISOLATE_VM_LIN Macro

GUI_QUESTION_ISOLATE_VM_LIN Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_ISOLATE_VM_LIN PRL_RESULT_DECLARE_SUCCESS(15319)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING Macro

GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING PRL_RESULT_DECLARE_SUCCESS(15078)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY Macro

GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY PRL_RESULT_DECLARE_SUCCESS(15087)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_LOST_TASK_CONTINUE Macro

GUI_QUESTION_LOST_TASK_CONTINUE Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_LOST_TASK_CONTINUE PRL_RESULT_DECLARE_SUCCESS(14012)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_MANUAL_INSTALL Macro

GUI_QUESTION_MANUAL_INSTALL Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_MANUAL_INSTALL PRL_RESULT_DECLARE_SUCCESS(15320)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_MOVE_TO_TRASH_DISK Macro

GUI_QUESTION_MOVE_TO_TRASH_DISK Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_MOVE_TO_TRASH_DISK PRL_RESULT_DECLARE_SUCCESS(14028)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_MOVE_TO_TRASH_VM Macro

GUI_QUESTION_MOVE_TO_TRASH_VM Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_MOVE_TO_TRASH_VM PRL_RESULT_DECLARE_SUCCESS(14029)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE Macro

GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE PRL_RESULT_DECLARE_SUCCESS(14018)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER Macro

GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER PRL_RESULT_DECLARE_SUCCESS(14019)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_NO_BACKUP Macro

GUI_QUESTION_NO_BACKUP Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_NO_BACKUP PRL_RESULT_DECLARE_SUCCESS(15219)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_NO_FREE_SPACE Macro

GUI_QUESTION_NO_FREE_SPACE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_NO_FREE_SPACE PRL_RESULT_DECLARE_ERROR(15351)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW Macro

GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW PRL_RESULT_DECLARE_SUCCESS(15334)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8 Macro

GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8 Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8 PRL_RESULT_DECLARE_SUCCESS(15391)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE Macro

GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE PRL_RESULT_DECLARE_SUCCESS(15333)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH Macro

GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH PRL_RESULT_DECLARE_SUCCESS(15332)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_OVERWRITE_HDD_IMAGE Macro

GUI_QUESTION_OVERWRITE_HDD_IMAGE Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_OVERWRITE_HDD_IMAGE PRL_RESULT_DECLARE_SUCCESS(14008)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE Macro

GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE PRL_RESULT_DECLARE_SUCCESS(14047)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS Macro

GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS PRL_RESULT_DECLARE_SUCCESS(15447)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_POSTPONE_UPGRADE Macro

GUI_QUESTION_POSTPONE_UPGRADE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_POSTPONE_UPGRADE PRL_RESULT_DECLARE_SUCCESS(15364)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_PREPARE_MAVERICK_IMAGE Macro

GUI_QUESTION_PREPARE_MAVERICK_IMAGE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_PREPARE_MAVERICK_IMAGE PRL_RESULT_DECLARE_SUCCESS(14043)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED Macro

GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED PRL_RESULT_DECLARE_ERROR(15270)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_PROFILE_DELETE Macro

GUI_QUESTION_PROFILE_DELETE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_PROFILE_DELETE PRL_RESULT_DECLARE_SUCCESS(15251)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_QUIT_PARALLELS_ACCESS Macro

GUI_QUESTION_QUIT_PARALLELS_ACCESS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_QUIT_PARALLELS_ACCESS PRL_RESULT_DECLARE_SUCCESS(14042)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM Macro

GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM PRL_RESULT_DECLARE_SUCCESS(14022)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT Macro

GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT PRL_RESULT_DECLARE_SUCCESS(15235)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_REMOVE_BACKUP Macro

GUI_QUESTION_REMOVE_BACKUP Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_REMOVE_BACKUP PRL_RESULT_DECLARE_SUCCESS(14024)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_REMOVE_PREVIOUS_VERSION Macro

GUI_QUESTION_REMOVE_PREVIOUS_VERSION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_REMOVE_PREVIOUS_VERSION PRL_RESULT_DECLARE_SUCCESS(15386)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_REMOVE_SERVER_FROM_LIST Macro

GUI_QUESTION_REMOVE_SERVER_FROM_LIST Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_REMOVE_SERVER_FROM_LIST PRL_RESULT_DECLARE_SUCCESS(14009)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_REPLACE_PREVIOUS_VERSION Macro

GUI_QUESTION_REPLACE_PREVIOUS_VERSION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_REPLACE_PREVIOUS_VERSION PRL_RESULT_DECLARE_ERROR(15389)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_RESET_VIRTUAL_NETWORK Macro

GUI_QUESTION_RESET_VIRTUAL_NETWORK Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_RESET_VIRTUAL_NETWORK PRL_RESULT_DECLARE_SUCCESS(15205)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE Macro

GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE PRL_RESULT_DECLARE_SUCCESS(15451)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_RESTORE_FROM_BACKUP Macro

GUI_QUESTION_RESTORE_FROM_BACKUP Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_RESTORE_FROM_BACKUP PRL_RESULT_DECLARE_SUCCESS(14025)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT Macro

GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14016)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT Macro

GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14015)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS Macro

GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS PRL_RESULT_DECLARE_SUCCESS(14032)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN Macro

GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN PRL_RESULT_DECLARE_SUCCESS(14021)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING Macro

GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING PRL_RESULT_DECLARE_SUCCESS(15306)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING Macro

GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING PRL_RESULT_DECLARE_SUCCESS(15305)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING Macro

GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING PRL_RESULT_DECLARE_SUCCESS(15307)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS Macro

GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS PRL_RESULT_DECLARE_SUCCESS(15308)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG Macro

GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG PRL_RESULT_DECLARE_SUCCESS(15310)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SM_ENABLE_SHARED_APPS Macro

GUI_QUESTION_SM_ENABLE_SHARED_APPS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SM_ENABLE_SHARED_APPS PRL_RESULT_DECLARE_SUCCESS(15161)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR Macro

GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR PRL_RESULT_DECLARE_SUCCESS(15309)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS Macro

GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS PRL_RESULT_DECLARE_SUCCESS(15191)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_SNAPSHOT_SINGLE_DELETE Macro

GUI_QUESTION_SNAPSHOT_SINGLE_DELETE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_SNAPSHOT_SINGLE_DELETE PRL_RESULT_DECLARE_SUCCESS(15190)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_STOP_APPLIANCE Macro

GUI_QUESTION_STOP_APPLIANCE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_STOP_APPLIANCE PRL_RESULT_DECLARE_SUCCESS(14031)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_STOP_SUSPENDED_VM Macro

GUI_QUESTION_STOP_SUSPENDED_VM Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_STOP_SUSPENDED_VM PRL_RESULT_DECLARE_SUCCESS(15142)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_TRIAL_EXPIRES_TEXT1 Macro

GUI_QUESTION_TRIAL_EXPIRES_TEXT1 Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_TRIAL_EXPIRES_TEXT1 PRL_RESULT_DECLARE_SUCCESS(15134)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_TRIAL_EXPIRES_TEXT2 Macro

GUI_QUESTION_TRIAL_EXPIRES_TEXT2 Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_TRIAL_EXPIRES_TEXT2 PRL_RESULT_DECLARE_SUCCESS(15135)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_TRIAL_EXPIRES_TEXT3 Macro

GUI_QUESTION_TRIAL_EXPIRES_TEXT3 Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_TRIAL_EXPIRES_TEXT3 PRL_RESULT_DECLARE_SUCCESS(15136)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_TRIAL_EXPIRES_TEXT4 Macro

GUI_QUESTION_TRIAL_EXPIRES_TEXT4 Macro
GUI_ERR Macros
Syntax
#define GUI_QUESTION_TRIAL_EXPIRES_TEXT4 PRL_RESULT_DECLARE_SUCCESS(15137)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_QUESTION_UPDATER_NO_CONNECTION Macro

GUI_QUESTION_UPDATER_NO_CONNECTION Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_UPDATER_NO_CONNECTION PRL_RESULT_DECLARE_SUCCESS(15403)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_USB_CONTROLLER_REMOVE Macro

GUI_QUESTION_USB_CONTROLLER_REMOVE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_USB_CONTROLLER_REMOVE PRL_RESULT_DECLARE_SUCCESS(14033)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_VM_CLEANUP_CONFIRM Macro

GUI_QUESTION_VM_CLEANUP_CONFIRM Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_VM_CLEANUP_CONFIRM PRL_RESULT_DECLARE_SUCCESS(15393)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE Macro

GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE Macro
GUI_INFO Macros
Syntax
#define GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE PRL_RESULT_DECLARE_SUCCESS(15211)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_TRY_DISCONNECT_CONNECTING_USB Macro

GUI_TRY_DISCONNECT_CONNECTING_USB Macro
GUI_INFO Macros
Syntax
#define GUI_TRY_DISCONNECT_CONNECTING_USB PRL_RESULT_DECLARE_SUCCESS(14023)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST Macro

GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST Macro
GUI_ERR Macros
Syntax
#define GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST PRL_RESULT_DECLARE_SUCCESS(15071)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WNG_AUTOCONNECT_HID_USB_DEVICE Macro

GUI_WNG_AUTOCONNECT_HID_USB_DEVICE Macro
GUI_ERR Macros
Syntax
#define GUI_WNG_AUTOCONNECT_HID_USB_DEVICE PRL_RESULT_DECLARE_SUCCESS(15070)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WNG_CONNECT_HID_USB_DEVICE Macro

GUI_WNG_CONNECT_HID_USB_DEVICE Macro
GUI_ERR Macros
Syntax
#define GUI_WNG_CONNECT_HID_USB_DEVICE PRL_RESULT_DECLARE_SUCCESS(15069)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST Macro

GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST Macro
GUI_INFO Macros
Syntax
#define GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST PRL_RESULT_DECLARE_SUCCESS(14026)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WNG_STOP_VM_WITH_BOOTCAMP Macro

GUI_WNG_STOP_VM_WITH_BOOTCAMP Macro
GUI_ERR Macros
Syntax
#define GUI_WNG_STOP_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_SUCCESS(15072)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION Macro

GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION PRL_RESULT_DECLARE_SUCCESS(15153)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT Macro

GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT PRL_RESULT_DECLARE_ERROR(15163)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE Macro

GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE PRL_RESULT_DECLARE_ERROR(15164)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS Macro

GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15098)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS Macro

GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15101)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS Macro

GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15100)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS Macro

GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15099)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT Macro

GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT PRL_RESULT_DECLARE_ERROR(15188)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_DESKTOP_IS_TRIAL Macro

GUI_WRN_DESKTOP_IS_TRIAL Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_DESKTOP_IS_TRIAL PRL_RESULT_DECLARE_ERROR(15253)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_DEVICE_ALREADY_EXIST Macro

GUI_WRN_DEVICE_ALREADY_EXIST Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_DEVICE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(15192)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_DHCP_END_IP_ADDRESS Macro

GUI_WRN_DHCP_END_IP_ADDRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_DHCP_END_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(15185)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_DHCP_START_IP_ADDRESS Macro

GUI_WRN_DHCP_START_IP_ADDRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_DHCP_START_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(15184)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_DUPLICATE_VIRTUAL_NETWORK Macro

GUI_WRN_DUPLICATE_VIRTUAL_NETWORK Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_DUPLICATE_VIRTUAL_NETWORK PRL_RESULT_DECLARE_ERROR(15186)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_ENCRYPTED_DISK_NOT_ADDED Macro

GUI_WRN_ENCRYPTED_DISK_NOT_ADDED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_ENCRYPTED_DISK_NOT_ADDED PRL_RESULT_DECLARE_ERROR(15290)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_FS_RESIZE_NOT_SUPPORTED Macro

GUI_WRN_FS_RESIZE_NOT_SUPPORTED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_FS_RESIZE_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(15350)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_HOST_IP_ADDRESS Macro

GUI_WRN_HOST_IP_ADDRESS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_HOST_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(15182)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_INVALID_IPV6_ADDRESS Macro

GUI_WRN_INVALID_IPV6_ADDRESS Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_INVALID_IPV6_ADDRESS PRL_RESULT_DECLARE_ERROR(15143)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_INVALID_VM_BUNDLE Macro

GUI_WRN_INVALID_VM_BUNDLE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_INVALID_VM_BUNDLE PRL_RESULT_DECLARE_ERROR(15195)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_INVALID_VM_FOLDER Macro

GUI_WRN_INVALID_VM_FOLDER Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_INVALID_VM_FOLDER PRL_RESULT_DECLARE_ERROR(15196)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED Macro

GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED PRL_RESULT_DECLARE_ERROR(15289)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_LOCAL_PATH_NOT_SPECIFIED Macro

GUI_WRN_LOCAL_PATH_NOT_SPECIFIED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_LOCAL_PATH_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(15177)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_LOCAL_PATH_WRONG Macro

GUI_WRN_LOCAL_PATH_WRONG Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_LOCAL_PATH_WRONG PRL_RESULT_DECLARE_ERROR(15178)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL Macro

GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL PRL_RESULT_DECLARE_SUCCESS(15119)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE Macro

GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE PRL_RESULT_DECLARE_ERROR(15432)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D Macro

GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D PRL_RESULT_DECLARE_SUCCESS(15138)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_NEW_PROFILE_NAME_EMPTY Macro

GUI_WRN_NEW_PROFILE_NAME_EMPTY Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_NEW_PROFILE_NAME_EMPTY PRL_RESULT_DECLARE_ERROR(15249)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_NO_BACKUP_FOLDER Macro

GUI_WRN_NO_BACKUP_FOLDER Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_NO_BACKUP_FOLDER PRL_RESULT_DECLARE_ERROR(15221)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_NO_USB_DEVICES_AVAILABLE Macro

GUI_WRN_NO_USB_DEVICES_AVAILABLE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_NO_USB_DEVICES_AVAILABLE PRL_RESULT_DECLARE_ERROR(15204)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS Macro

GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS PRL_RESULT_DECLARE_ERROR(15383)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS Macro

GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS PRL_RESULT_DECLARE_ERROR(15459)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS Macro

GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS Macro
Other Macros
Syntax
#define GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS PRL_RESULT_DECLARE_ERROR(15483)
File

PrlPrivateErrorsValues.h

Links
Other Macros


GUI_WRN_PARTITION_NOT_SPECIFIED Macro

GUI_WRN_PARTITION_NOT_SPECIFIED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PARTITION_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(15170)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT Macro

GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT PRL_RESULT_DECLARE_ERROR(15201)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PORT_MAPPING_IP_INCORRECT Macro

GUI_WRN_PORT_MAPPING_IP_INCORRECT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PORT_MAPPING_IP_INCORRECT PRL_RESULT_DECLARE_ERROR(15203)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT Macro

GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT PRL_RESULT_DECLARE_ERROR(15202)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PRODUCT_KEY_INCOMPLETE Macro

GUI_WRN_PRODUCT_KEY_INCOMPLETE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PRODUCT_KEY_INCOMPLETE PRL_RESULT_DECLARE_ERROR(15171)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PRODUCT_KEY_WRONG_LENGTH Macro

GUI_WRN_PRODUCT_KEY_WRONG_LENGTH Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PRODUCT_KEY_WRONG_LENGTH PRL_RESULT_DECLARE_ERROR(15189)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PROFILE_NAME_ALREADY_IN_USE Macro

GUI_WRN_PROFILE_NAME_ALREADY_IN_USE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PROFILE_NAME_ALREADY_IN_USE PRL_RESULT_DECLARE_ERROR(15250)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_PURCHASE_MISSING_KEY Macro

GUI_WRN_PURCHASE_MISSING_KEY Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_PURCHASE_MISSING_KEY PRL_RESULT_DECLARE_ERROR(15436)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED Macro

GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED PRL_RESULT_DECLARE_ERROR(15169)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_SERVER_ALREADY_CONNECTED Macro

GUI_WRN_SERVER_ALREADY_CONNECTED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_SERVER_ALREADY_CONNECTED PRL_RESULT_DECLARE_ERROR(15181)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_SERVER_NAME_NOT_SPECIFIED Macro

GUI_WRN_SERVER_NAME_NOT_SPECIFIED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_SERVER_NAME_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(15179)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_SERVER_NAME_WRONG Macro

GUI_WRN_SERVER_NAME_WRONG Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_SERVER_NAME_WRONG PRL_RESULT_DECLARE_ERROR(15180)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_SNAPSHOT_NAME_IS_EMPTY Macro

GUI_WRN_SNAPSHOT_NAME_IS_EMPTY Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_SNAPSHOT_NAME_IS_EMPTY PRL_RESULT_DECLARE_SUCCESS(15083)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_SOURCE_FOR_DEVICE_IS_USED Macro

GUI_WRN_SOURCE_FOR_DEVICE_IS_USED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_SOURCE_FOR_DEVICE_IS_USED PRL_RESULT_DECLARE_ERROR(15291)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_SUBNET_MASK Macro

GUI_WRN_SUBNET_MASK Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_SUBNET_MASK PRL_RESULT_DECLARE_ERROR(15183)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG Macro

GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG PRL_RESULT_DECLARE_ERROR(15280)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_UNABLE_REQUEST_TRIAL_KEY Macro

GUI_WRN_UNABLE_REQUEST_TRIAL_KEY Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_UNABLE_REQUEST_TRIAL_KEY PRL_RESULT_DECLARE_ERROR(15281)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_UNATTENDED_LINUX_NO_IMAGE Macro

GUI_WRN_UNATTENDED_LINUX_NO_IMAGE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_UNATTENDED_LINUX_NO_IMAGE PRL_RESULT_DECLARE_ERROR(15292)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE Macro

GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE PRL_RESULT_DECLARE_ERROR(15293)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY Macro

GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY PRL_RESULT_DECLARE_ERROR(15365)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_NAME_ILLEGAL Macro

GUI_WRN_USER_NAME_ILLEGAL Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_NAME_ILLEGAL PRL_RESULT_DECLARE_ERROR(15173)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_NAME_NOT_SPECIFIED Macro

GUI_WRN_USER_NAME_NOT_SPECIFIED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_NAME_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(15172)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_NAME_RESERVED_BY_GUEST Macro

GUI_WRN_USER_NAME_RESERVED_BY_GUEST Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_NAME_RESERVED_BY_GUEST PRL_RESULT_DECLARE_ERROR(15382)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_PASS_DO_NOT_MATCH Macro

GUI_WRN_USER_PASS_DO_NOT_MATCH Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_PASS_DO_NOT_MATCH PRL_RESULT_DECLARE_ERROR(15175)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_PASS_NOT_SPECIFIED Macro

GUI_WRN_USER_PASS_NOT_SPECIFIED Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_PASS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(15174)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_USER_PASS_TOO_SHORT Macro

GUI_WRN_USER_PASS_TOO_SHORT Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_USER_PASS_TOO_SHORT PRL_RESULT_DECLARE_ERROR(15176)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW Macro

GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW PRL_RESULT_DECLARE_SUCCESS(15074)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI Macro

GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI PRL_RESULT_DECLARE_SUCCESS(15411)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_VIRTUAL_NETWORK_WRONG Macro

GUI_WRN_VIRTUAL_NETWORK_WRONG Macro
GUI_INFO Macros
Syntax
#define GUI_WRN_VIRTUAL_NETWORK_WRONG PRL_RESULT_DECLARE_ERROR(15187)
File

PrlPrivateErrorsValues.h

Links
GUI_INFO Macros


GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS Macro

GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15079)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS Macro

GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS Macro
GUI_ERR Macros
Syntax
#define GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(15088)
File

PrlPrivateErrorsValues.h

Links
GUI_ERR Macros


GUID_CLS_BASE_STR Macro

GUID_CLS_BASE_STR Macro
Other Macros
Syntax
#define GUID_CLS_BASE_STR "{823067ea-8e15-474f-a3ae-c6a068461256}"
File

PrlPluginClasses.h

Links
Other Macros


GUID_CLS_ENCRYPTION_STR Macro

GUID_CLS_ENCRYPTION_STR Macro
Other Macros
Syntax
#define GUID_CLS_ENCRYPTION_STR "{564820fc-e265-4d69-9fb0-3d18396f1f8d}"
File

PrlPluginClasses.h

Links
Other Macros


handle_type_to_string Function

handle_type_to_string Function
API Debug Functions

This inline function returns a readable string representation of the specified handle type.

Syntax
static inline const char * handle_type_to_string(
    PRL_HANDLE_TYPE value
);
File

PrlApiCore.h

Parameters

value
The handle type.

Links
API Debug Functions


ICryptInfoPtr Type

ICryptInfoPtr Type
Other Types
Syntax
typedef ICryptInfo* ICryptInfoPtr;
File

PrlPluginClasses.h

Links
Other Types


Index

Index
_ | A | C | D | E | F | G | H | I | K | M | O | P | R | S | T | U | V | W
_
__Parallels_API Macros
__PARALLELS_API_APP_MANAGER_ENUMS_H__
__PARALLELS_API_APP_MANAGER_ENUMS_H__ macro
__PARALLELS_API_COMMANDS_FLAGS_H__
__PARALLELS_API_COMMANDS_FLAGS_H__ macro
__PARALLELS_API_CORE_H__
__PARALLELS_API_CORE_H__ macro
__PARALLELS_API_DESKTOP_PARAMETERS_H__
__PARALLELS_API_DESKTOP_PARAMETERS_H__ macro
__PARALLELS_API_DISPATCHER_H__
__PARALLELS_API_DISPATCHER_H__ macro
__PARALLELS_API_INPUT_EMU_H__
__PARALLELS_API_INPUT_EMU_H__ macro
__PARALLELS_API_MANAGER_H__
__PARALLELS_API_MANAGER_H__ macro
__PARALLELS_API_NET_H__
__PARALLELS_API_NET_H__ macro
__PARALLELS_API_PORTS_H__
__PARALLELS_API_PORTS_H__ macro
__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__
__PARALLELS_API_PRIVATE_ERRORS_VALUES_H__ macro
__PARALLELS_API_PTM_H__
__PARALLELS_API_PTM_H__ macro
__PARALLELS_API_PTM_TYPES_H__
__PARALLELS_API_PTM_TYPES_H__ macro
__PARALLELS_API_REMOTE_DEV_H__
__PARALLELS_API_REMOTE_DEV_H__ macro
__PARALLELS_API_SECURITY_H__
__PARALLELS_API_SECURITY_H__ macro
__PARALLELS_API_STATISTIC_H__
__PARALLELS_API_STATISTIC_H__ macro
__PARALLELS_API_VIDEO_RECEIVER_H__
__PARALLELS_API_VIDEO_RECEIVER_H__ macro
__PARALLELS_API_VM_H__
__PARALLELS_API_VM_H__ macro
__PARALLELS_PERF_COUNTERS_H__
__PARALLELS_PERF_COUNTERS_H__ macro
__PRL_DISK_PARAMETERS
__PRL_DISK_PARAMETERS structure
__PRL_IMAGE_PARAMETERS
__PRL_IMAGE_PARAMETERS structure
__PRL_PLUGINS_CLASSES_DEFINED__
__PRL_PLUGINS_CLASSES_DEFINED__ macro
__PRL_SNAPSHOT_ELEMENT
__PRL_SNAPSHOT_ELEMENT structure
__PTM Macros
__PTM_ACCESS
__PTM_ACCESS macro
__PTM_ACCESS_IN
__PTM_ACCESS_IN macro
__PTM_ACCESS_INOUT
__PTM_ACCESS_INOUT macro
__PTM_ACCESS_N
__PTM_ACCESS_N macro
__PTM_ACCESS_OUT
__PTM_ACCESS_OUT macro
__PTM_ACCESS_R
__PTM_ACCESS_R macro
__PTM_ACCESS_RW
__PTM_ACCESS_RW macro
__PTM_ACCESS_W
__PTM_ACCESS_W macro
__PTM_SEND
__PTM_SEND macro
__PTM_SEND_ALL
__PTM_SEND_ALL macro
__PTM_SEND_NOSELF
__PTM_SEND_NOSELF macro
__PTM_SEND_PRI
__PTM_SEND_PRI macro
__PTM_SEND_PRI_HIGH
__PTM_SEND_PRI_HIGH macro
__PTM_SEND_PRI_IDLE
__PTM_SEND_PRI_IDLE macro
__PTM_SEND_PRI_LOW
__PTM_SEND_PRI_LOW macro
__PTM_SEND_PRI_NORMAL
__PTM_SEND_PRI_NORMAL macro
__PTM_SEND_STREAM
__PTM_SEND_STREAM macro
__PTM_TYPE
__PTM_TYPE macro
__PTM_TYPE_BIN
__PTM_TYPE_BIN macro
__PTM_TYPE_I32
__PTM_TYPE_I32 macro
__PTM_TYPE_I64
__PTM_TYPE_I64 macro
__PTM_TYPE_STR
__PTM_TYPE_STR macro
__PTM_TYPE_STRLST
__PTM_TYPE_STRLST macro
__PTM_TYPE_STRUCT
__PTM_TYPE_STRUCT macro
__PTM_TYPE_U32
__PTM_TYPE_U32 macro
__PTM_TYPE_U64
__PTM_TYPE_U64 macro
_ICryptInfo
_ICryptInfo structure
_IPluginInfo
_IPluginInfo structure
_PRL_ADAPTER_INDEX
_PRL_ADAPTER_INDEX enumeration
_PRL_ALLOWED_VM_COMMAND
_PRL_ALLOWED_VM_COMMAND enumeration
_PRL_API_COMMAND_FLAGS
_PRL_API_COMMAND_FLAGS enumeration
_PRL_API_INIT_FLAGS
_PRL_API_INIT_FLAGS enumeration
_PRL_API_METHOD
_PRL_API_METHOD structure
_PRL_APP_IN_DOCK_MODE
_PRL_APP_IN_DOCK_MODE enumeration
_PRL_APPLIANCE_DOWNLOAD_STATUS
_PRL_APPLIANCE_DOWNLOAD_STATUS enumeration
_PRL_APPLICATION_MODE
_PRL_APPLICATION_MODE enumeration
_PRL_BIOS_TYPE
_PRL_BIOS_TYPE enumeration
_PRL_CHS
_PRL_CHS structure
_PRL_CLONE_VM_FLAGS
_PRL_CLONE_VM_FLAGS enumeration
_PRL_CLUSTERED_DEVICE_SUBTYPE
_PRL_CLUSTERED_DEVICE_SUBTYPE enumeration
_PRL_COMPACT_MODE
_PRL_COMPACT_MODE enumeration
_PRL_CONVERT_VIRTUAL_DISK
_PRL_CONVERT_VIRTUAL_DISK enumeration
_PRL_COPY_CT_TEMPLATE_FLAGS
_PRL_COPY_CT_TEMPLATE_FLAGS enumeration
_PRL_CORNER_ACTIONS
_PRL_CORNER_ACTIONS enumeration
_PRL_CPU_FEATURES
_PRL_CPU_FEATURES structure
_PRL_CPU_FEATURES_EX
_PRL_CPU_FEATURES_EX enumeration
_PRL_CPU_FEATURES_MASK
_PRL_CPU_FEATURES_MASK structure
_PRL_CPU_HVT
_PRL_CPU_HVT enumeration
_PRL_CPU_MODE
_PRL_CPU_MODE enumeration
_PRL_CPULIMIT_DATA
_PRL_CPULIMIT_DATA structure
_PRL_CPULIMIT_TYPE
_PRL_CPULIMIT_TYPE enumeration
_PRL_CPUUNITS
_PRL_CPUUNITS enumeration
_PRL_CREATE_DISK_IMAGE_FLAGS
_PRL_CREATE_DISK_IMAGE_FLAGS enumeration
_PRL_CREATE_SNAPSHOT_FLAGS
_PRL_CREATE_SNAPSHOT_FLAGS enumeration
_PRL_CT_CAPMASK
_PRL_CT_CAPMASK enumeration
_PRL_CT_FEATURES
_PRL_CT_FEATURES enumeration
_PRL_CT_RESOURCE
_PRL_CT_RESOURCE enumeration
_PRL_CT_TEMPLATE_TYPE
_PRL_CT_TEMPLATE_TYPE enumeration
_PRL_CVSRC_OPEN_MODE
_PRL_CVSRC_OPEN_MODE structure
_PRL_DATA_STATISTIC_SEGMENTS
_PRL_DATA_STATISTIC_SEGMENTS enumeration
_PRL_DELETE_SNAPSHOT_FLAGS
_PRL_DELETE_SNAPSHOT_FLAGS enumeration
_PRL_DEVICE_ACTION
_PRL_DEVICE_ACTION enumeration
_PRL_DEVICE_TYPE
_PRL_DEVICE_TYPE enumeration
_PRL_DISPLAY_BUFFER_FORMAT
_PRL_DISPLAY_BUFFER_FORMAT enumeration
_PRL_DISPLAY_CODEC_COMPRESSION
_PRL_DISPLAY_CODEC_COMPRESSION enumeration
_PRL_DISPLAY_CODEC_QUALITY
_PRL_DISPLAY_CODEC_QUALITY enumeration
_PRL_DISPLAY_CODEC_TYPE
_PRL_DISPLAY_CODEC_TYPE enumeration
_PRL_DISPLAY_CONFIG_MODE
_PRL_DISPLAY_CONFIG_MODE enumeration
_PRL_DISTRO_MEDIA_TYPE
_PRL_DISTRO_MEDIA_TYPE enumeration
_PRL_DOCK_ICON_TYPE
_PRL_DOCK_ICON_TYPE enumeration
_PRL_ENCRYPTION_FLAGS
_PRL_ENCRYPTION_FLAGS enumeration
_PRL_EVENT_ISSUER_TYPE
_PRL_EVENT_ISSUER_TYPE enumeration
_PRL_EVENT_TYPE
_PRL_EVENT_TYPE enumeration
_PRL_EXTERNAL_VM_TYPE
_PRL_EXTERNAL_VM_TYPE enumeration
_PRL_FEATURES_MATRIX
_PRL_FEATURES_MATRIX enumeration
_PRL_FILE_SYSTEM_ELEMENT_TYPE
_PRL_FILE_SYSTEM_ELEMENT_TYPE enumeration
_PRL_FILE_SYSTEM_FS_TYPE
_PRL_FILE_SYSTEM_FS_TYPE enumeration
_PRL_FILE_SYSTEM_TYPE
_PRL_FILE_SYSTEM_TYPE enumeration
_PRL_FIREWALL_DIRECTION
_PRL_FIREWALL_DIRECTION enumeration
_PRL_FIREWALL_POLICY
_PRL_FIREWALL_POLICY enumeration
_PRL_GENERIC_DEVICE_STATE
_PRL_GENERIC_DEVICE_STATE enumeration
_PRL_GENERIC_PCI_DEVICE_CLASS
_PRL_GENERIC_PCI_DEVICE_CLASS enumeration
_PRL_GET_SNAPSHOT_TREE_FLAGS
_PRL_GET_SNAPSHOT_TREE_FLAGS enumeration
_PRL_GET_VM_CONFIG_FLAGS
_PRL_GET_VM_CONFIG_FLAGS enumeration
_PRL_GET_VM_CONFIG_PARAM_DATA
_PRL_GET_VM_CONFIG_PARAM_DATA structure
_PRL_GET_VM_LIST_FLAGS
_PRL_GET_VM_LIST_FLAGS enumeration
_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
_PRL_GRACEFUL_SHUTDOWN_CAPABILITIES enumeration
_PRL_GRACEFUL_SHUTDOWN_KIND
_PRL_GRACEFUL_SHUTDOWN_KIND enumeration
_PRL_GUEST_DISTRO_VERSION_ENUM
_PRL_GUEST_DISTRO_VERSION_ENUM enumeration
_PRL_GUID
_PRL_GUID structure
_PRL_HANDLE_TYPE
_PRL_HANDLE_TYPE enumeration
_PRL_HARD_DISK_IFACE_MASK
_PRL_HARD_DISK_IFACE_MASK enumeration
_PRL_HARD_DISK_INTERNAL_FORMAT
_PRL_HARD_DISK_INTERNAL_FORMAT enumeration
_PRL_HOST_OS_INFO
_PRL_HOST_OS_INFO structure
_PRL_HOST_OS_TYPE
_PRL_HOST_OS_TYPE enumeration
_PRL_HW_INFO_NET_ADAPTER_TYPE
_PRL_HW_INFO_NET_ADAPTER_TYPE enumeration
_PRL_IMAGE_FORMAT
_PRL_IMAGE_FORMAT enumeration
_PRL_INSTALL_APPLIANCE_FLAGS
_PRL_INSTALL_APPLIANCE_FLAGS enumeration
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_REQUEST structure
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_ATTACH_RESPONSE structure
_PRL_IO_AUDIO_DATA
_PRL_IO_AUDIO_DATA structure
_PRL_IO_AUDIO_ENCODING
_PRL_IO_AUDIO_ENCODING structure
_PRL_IO_AUDIO_ENCODING_LIST
_PRL_IO_AUDIO_ENCODING_LIST structure
_PRL_IO_AUDIO_ENCODING_RESPONSE
_PRL_IO_AUDIO_ENCODING_RESPONSE structure
_PRL_IO_AUTH_EXEC_REQUEST
_PRL_IO_AUTH_EXEC_REQUEST structure
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_REQUEST structure
_PRL_IO_AUTH_RESPONSE
_PRL_IO_AUTH_RESPONSE structure
_PRL_IO_AVAILABLE_DISPLAYS
_PRL_IO_AVAILABLE_DISPLAYS structure
_PRL_IO_CHANNEL_STAT
_PRL_IO_CHANNEL_STAT structure
_PRL_IO_CLIENT_FLAGS
_PRL_IO_CLIENT_FLAGS enumeration
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DESKTOP_UTILITIES_STATE structure
_PRL_IO_DEVICE_USED
_PRL_IO_DEVICE_USED structure
_PRL_IO_DISCONNECT_REASON
_PRL_IO_DISCONNECT_REASON enumeration
_PRL_IO_DISPLAY_ENCODING
_PRL_IO_DISPLAY_ENCODING structure
_PRL_IO_DISPLAY_ENCODING_LIST
_PRL_IO_DISPLAY_ENCODING_LIST structure
_PRL_IO_DISPLAY_GAMMA
_PRL_IO_DISPLAY_GAMMA structure
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_PALETTE structure
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION structure
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
_PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX structure
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_REGION structure
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DISPLAY_SCREEN_SIZE structure
_PRL_IO_DPI_DISPLAY_SCREEN_SIZE
_PRL_IO_DPI_DISPLAY_SCREEN_SIZE structure
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_DYNRES_TOOLS_STATUS structure
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_REQUEST structure
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_ENCODING_RESPONSE structure
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GENERIC_BUFFER structure
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GRACEFUL_SHUTDOWN structure
_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
_PRL_IO_GUEST_NOTIFY_COHERENCE_STATE structure
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_LEDS structure
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_KEYBOARD_SCANCODE structure
_PRL_IO_LANGUAGE_HOTKEYS
_PRL_IO_LANGUAGE_HOTKEYS structure
_PRL_IO_MEMORY_INFO
_PRL_IO_MEMORY_INFO structure
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_CURSOR structure
_PRL_IO_MOUSE_EVENT
_PRL_IO_MOUSE_EVENT structure
_PRL_IO_MOUSE_EVENT_EX
_PRL_IO_MOUSE_EVENT_EX structure
_PRL_IO_MOUSE_EVENT_EX2
_PRL_IO_MOUSE_EVENT_EX2 structure
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_BUFFER_REGION structure
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_REGION structure
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SIZE structure
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_SURFACE structure
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SCREEN_UPDATE structure
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SET_TASKBAR_VISIBILITY structure
_PRL_IO_SHUTDOWN_RESULT
_PRL_IO_SHUTDOWN_RESULT structure
_PRL_IO_SLIDING_MOUSE
_PRL_IO_SLIDING_MOUSE structure
_PRL_IO_SSO_CLIENT_VM_PACKET
_PRL_IO_SSO_CLIENT_VM_PACKET structure
_PRL_IO_STATE
_PRL_IO_STATE enumeration
_PRL_IO_TOOLS_ADJUST_WORKING_AREA
_PRL_IO_TOOLS_ADJUST_WORKING_AREA structure
_PRL_IO_TOOLS_DISPLAY_INDENT
_PRL_IO_TOOLS_DISPLAY_INDENT structure
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_MOVE_TASKBAR structure
_PRL_IO_TOOLS_SIA_DATA
_PRL_IO_TOOLS_SIA_DATA structure
_PRL_IO_TOOLS_UTILITY_COMMAND
_PRL_IO_TOOLS_UTILITY_COMMAND structure
_PRL_IOLIMIT_DATA
_PRL_IOLIMIT_DATA structure
_PRL_IOLIMIT_TYPE
_PRL_IOLIMIT_TYPE enumeration
_PRL_IOPRIO
_PRL_IOPRIO enumeration
_PRL_ISCSI_STORAGE_CMD_FLAGS
_PRL_ISCSI_STORAGE_CMD_FLAGS enumeration
_PRL_ISCSI_STORAGE_FSTYPE_FLAGS
_PRL_ISCSI_STORAGE_FSTYPE_FLAGS enumeration
_PRL_JOB_OPERATION_CODE
_PRL_JOB_OPERATION_CODE enumeration
_PRL_JOB_STATUS
_PRL_JOB_STATUS enumeration
_PRL_KEY
_PRL_KEY enumeration
_PRL_KEY_EVENT
_PRL_KEY_EVENT enumeration
_PRL_LICENSE_RESTRICTION_KEY
_PRL_LICENSE_RESTRICTION_KEY enumeration
_PRL_LOGIN_LOCAL_FLAGS
_PRL_LOGIN_LOCAL_FLAGS enumeration
_PRL_MASS_STORAGE_INTERFACE_TYPE
_PRL_MASS_STORAGE_INTERFACE_TYPE enumeration
_PRL_MESSAGE_TYPE_ENUM
_PRL_MESSAGE_TYPE_ENUM enumeration
_PRL_MOBILE_ADVANCED_AUTH_MODE
_PRL_MOBILE_ADVANCED_AUTH_MODE enumeration
_PRL_MOUNT_VIRTUAL_DISK
_PRL_MOUNT_VIRTUAL_DISK enumeration
_PRL_MOUSE_BUTTON
_PRL_MOUSE_BUTTON enumeration
_PRL_NET_ADAPTER_EMULATED_TYPE
_PRL_NET_ADAPTER_EMULATED_TYPE enumeration
_PRL_NET_VIRTUAL_NETWORK_TYPE
_PRL_NET_VIRTUAL_NETWORK_TYPE enumeration
_PRL_NETFILTER_MODE
_PRL_NETFILTER_MODE enumeration
_PRL_ONLINE_COMPACT_MODE
_PRL_ONLINE_COMPACT_MODE enumeration
_PRL_OPTIMIZE_MODIFIERS_MODE
_PRL_OPTIMIZE_MODIFIERS_MODE enumeration
_PRL_PARAM_FIELD_DATA_TYPE
_PRL_PARAM_FIELD_DATA_TYPE enumeration
_PRL_PORT_FORWARDING_TYPE
_PRL_PORT_FORWARDING_TYPE enumeration
_PRL_PRINTER_INTERFACE_TYPE
_PRL_PRINTER_INTERFACE_TYPE enumeration
_PRL_PRIVATE_EVENT_TYPE
_PRL_PRIVATE_EVENT_TYPE enumeration
_PRL_PROBLEM_REPORT_FLAGS
_PRL_PROBLEM_REPORT_FLAGS enumeration
_PRL_PROBLEM_REPORT_REASON
_PRL_PROBLEM_REPORT_REASON enumeration
_PRL_PROBLEM_REPORT_SCHEME
_PRL_PROBLEM_REPORT_SCHEME enumeration
_PRL_PROBLEM_REPORT_TYPE
_PRL_PROBLEM_REPORT_TYPE enumeration
_PRL_PROCESS_STATE_TYPE
_PRL_PROCESS_STATE_TYPE enumeration
_PRL_PRODUCT_ENUM
_PRL_PRODUCT_ENUM enumeration
_PRL_PROXY_CLIENT_INFO
_PRL_PROXY_CLIENT_INFO structure
_PRL_PROXY_CONNECTION_STATUS
_PRL_PROXY_CONNECTION_STATUS enumeration
_PRL_PROXY_DATA_KEY
_PRL_PROXY_DATA_KEY structure
_PRL_PROXY_GEO_INFO
_PRL_PROXY_GEO_INFO structure
_PRL_PROXY_HOST_INFO
_PRL_PROXY_HOST_INFO structure
_PRL_PROXY_HOST_INFO_EXT
_PRL_PROXY_HOST_INFO_EXT structure
_PRL_PROXY_REGISTRATION_INFO
_PRL_PROXY_REGISTRATION_INFO structure
_PRL_PROXY_USER_DATA
_PRL_PROXY_USER_DATA structure
_PRL_PTM_OBJECT
_PRL_PTM_OBJECT structure
_PRL_PTM_PROPERTY
_PRL_PTM_PROPERTY structure
_PRL_QUERY_ELEMENT_FLAGS
_PRL_QUERY_ELEMENT_FLAGS enumeration
_PRL_REGISTER_3PARTY_VM_FLAGS
_PRL_REGISTER_3PARTY_VM_FLAGS enumeration
_PRL_REGISTER_NEW_VM
_PRL_REGISTER_NEW_VM enumeration
_PRL_REGISTER_VM_FLAGS
_PRL_REGISTER_VM_FLAGS enumeration
_PRL_RESIZE_IMAGE_FLAGS
_PRL_RESIZE_IMAGE_FLAGS enumeration
_PRL_RUNNING_TASK_TYPE_ENUM
_PRL_RUNNING_TASK_TYPE_ENUM enumeration
_PRL_SCALE_VIEW_MODE
_PRL_SCALE_VIEW_MODE enumeration
_PRL_SECURITY_LEVEL
_PRL_SECURITY_LEVEL enumeration
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE enumeration
_PRL_SERVICE_STATUS_ENUM
_PRL_SERVICE_STATUS_ENUM enumeration
_PRL_SET_PROXY_CONNECTION_FLAGS
_PRL_SET_PROXY_CONNECTION_FLAGS enumeration
_PRL_SET_USERPASSWD_FLAGS
_PRL_SET_USERPASSWD_FLAGS enumeration
_PRL_SOUND_CHANNEL_TYPE
_PRL_SOUND_CHANNEL_TYPE enumeration
_PRL_SRV_SHUTDOWN_FLAGS
_PRL_SRV_SHUTDOWN_FLAGS enumeration
_PRL_STAT_NET_TRAFFIC
_PRL_STAT_NET_TRAFFIC structure
_PRL_SWITCH_SNAPSHOT_FLAGS
_PRL_SWITCH_SNAPSHOT_FLAGS enumeration
_PRL_TASKBAR_STATES
_PRL_TASKBAR_STATES enumeration
_PRL_TIS_INT_VERSION
_PRL_TIS_INT_VERSION structure
_PRL_TIS_RECORD_FIELD
_PRL_TIS_RECORD_FIELD enumeration
_PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO structure
_PRL_TIS_RECORD_STATE
_PRL_TIS_RECORD_STATE enumeration
_PRL_TIS_VERSION
_PRL_TIS_VERSION structure
_PRL_TOOLS_SIA_OPEN_IN_TYPES
_PRL_TOOLS_SIA_OPEN_IN_TYPES enumeration
_PRL_TOOLS_UTILITY_COMMAND_FLAG
_PRL_TOOLS_UTILITY_COMMAND_FLAG enumeration
_PRL_TOOLS_UTILITY_COMMAND_ID
_PRL_TOOLS_UTILITY_COMMAND_ID enumeration
_PRL_UIEMU_AUTOKEYBOARD
_PRL_UIEMU_AUTOKEYBOARD structure
_PRL_UIEMU_CARET_INFO
_PRL_UIEMU_CARET_INFO structure
_PRL_UIEMU_CURSOR_DESC
_PRL_UIEMU_CURSOR_DESC structure
_PRL_UIEMU_CURSOR_FORMAT
_PRL_UIEMU_CURSOR_FORMAT structure
_PRL_UIEMU_CURSOR_POS
_PRL_UIEMU_CURSOR_POS structure
_PRL_UIEMU_ELEMENT_AT_POS
_PRL_UIEMU_ELEMENT_AT_POS structure
_PRL_UIEMU_ELEMENT_CONTROL_TYPE
_PRL_UIEMU_ELEMENT_CONTROL_TYPE enumeration
_PRL_UIEMU_GESTURE_DATA_PINCH
_PRL_UIEMU_GESTURE_DATA_PINCH structure
_PRL_UIEMU_GESTURE_DATA_SMARTZOOM
_PRL_UIEMU_GESTURE_DATA_SMARTZOOM structure
_PRL_UIEMU_GESTURE_EVENT
_PRL_UIEMU_GESTURE_EVENT structure
_PRL_UIEMU_GESTURE_STATE
_PRL_UIEMU_GESTURE_STATE enumeration
_PRL_UIEMU_GESTURE_TYPE
_PRL_UIEMU_GESTURE_TYPE enumeration
_PRL_UIEMU_INPUT_INFO
_PRL_UIEMU_INPUT_INFO structure
_PRL_UIEMU_MAKEUP_HINTING_RGN
_PRL_UIEMU_MAKEUP_HINTING_RGN structure
_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
_PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE enumeration
_PRL_UIEMU_MMKEY
_PRL_UIEMU_MMKEY enumeration
_PRL_UIEMU_MOUSE_CLICK
_PRL_UIEMU_MOUSE_CLICK enumeration
_PRL_UIEMU_SCROLL_FLAGS
_PRL_UIEMU_SCROLL_FLAGS enumeration
_PRL_UIEMU_SCROLL_UNITS
_PRL_UIEMU_SCROLL_UNITS enumeration
_PRL_UIEMU_SELECTION_HINTING_RGN
_PRL_UIEMU_SELECTION_HINTING_RGN structure
_PRL_UIEMU_VKEY
_PRL_UIEMU_VKEY structure
_PRL_UNDO_DISKS_MODE
_PRL_UNDO_DISKS_MODE enumeration
_PRL_UPDATE_LICENSE_FLAGS
_PRL_UPDATE_LICENSE_FLAGS enumeration
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION enumeration
_PRL_USB_DEVICE_CONNECT_REASON
_PRL_USB_DEVICE_CONNECT_REASON enumeration
_PRL_USB_DEVICE_TYPE
_PRL_USB_DEVICE_TYPE enumeration
_PRL_VERSION_ENUM
_PRL_VERSION_ENUM enumeration
_PRL_VIDEO_3D_ACCELERATION
_PRL_VIDEO_3D_ACCELERATION enumeration
_PRL_VIRTUAL_MACHINE_PROFILE
_PRL_VIRTUAL_MACHINE_PROFILE enumeration
_PRL_VM_ACCELERATION_LEVEL
_PRL_VM_ACCELERATION_LEVEL enumeration
_PRL_VM_ACCESS_FOR_OTHERS
_PRL_VM_ACCESS_FOR_OTHERS enumeration
_PRL_VM_ACTION
_PRL_VM_ACTION enumeration
_PRL_VM_ACTION_ON_STOP
_PRL_VM_ACTION_ON_STOP enumeration
_PRL_VM_ACTION_ON_WINDOW_CLOSE
_PRL_VM_ACTION_ON_WINDOW_CLOSE enumeration
_PRL_VM_AUTOSTART_OPTION
_PRL_VM_AUTOSTART_OPTION enumeration
_PRL_VM_AUTOSTOP_OPTION
_PRL_VM_AUTOSTOP_OPTION enumeration
_PRL_VM_BACKUP_FLAGS
_PRL_VM_BACKUP_FLAGS enumeration
_PRL_VM_BACKUP_TYPE
_PRL_VM_BACKUP_TYPE enumeration
_PRL_VM_BOOT_ORDER
_PRL_VM_BOOT_ORDER enumeration
_PRL_VM_COLOR
_PRL_VM_COLOR enumeration
_PRL_VM_COMMIT_FLAGS
_PRL_VM_COMMIT_FLAGS enumeration
_PRL_VM_CONFIG_SECTIONS
_PRL_VM_CONFIG_SECTIONS enumeration
_PRL_VM_DEV_EMULATION_TYPE
_PRL_VM_DEV_EMULATION_TYPE enumeration
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR enumeration
_PRL_VM_EXEC_RUN_PROGRAM_MODES
_PRL_VM_EXEC_RUN_PROGRAM_MODES enumeration
_PRL_VM_LOCATION
_PRL_VM_LOCATION enumeration
_PRL_VM_MIGRATION_FLAGS
_PRL_VM_MIGRATION_FLAGS enumeration
_PRL_VM_MOUSE_CURSOR_STATE
_PRL_VM_MOUSE_CURSOR_STATE enumeration
_PRL_VM_MOUSE_STATE
_PRL_VM_MOUSE_STATE enumeration
_PRL_VM_NET_ADAPTER_TYPE
_PRL_VM_NET_ADAPTER_TYPE enumeration
_PRL_VM_NET_ADAPTER_WIFI_RULE
_PRL_VM_NET_ADAPTER_WIFI_RULE enumeration
_PRL_VM_NORMAL_START_FLAGS
_PRL_VM_NORMAL_START_FLAGS enumeration
_PRL_VM_PRIORITY
_PRL_VM_PRIORITY enumeration
_PRL_VM_REMOTE_DISPLAY_MODE
_PRL_VM_REMOTE_DISPLAY_MODE enumeration
_PRL_VM_SMARTGUARD_SCHEMA
_PRL_VM_SMARTGUARD_SCHEMA enumeration
_PRL_VM_START_LOGIN_MODE
_PRL_VM_START_LOGIN_MODE enumeration
_PRL_VM_START_MODE
_PRL_VM_START_MODE enumeration
_PRL_VM_STATISTICS_FLAGS
_PRL_VM_STATISTICS_FLAGS enumeration
_PRL_VM_STOP_FLAGS
_PRL_VM_STOP_FLAGS enumeration
_PRL_VM_STOP_MODE
_PRL_VM_STOP_MODE enumeration
_PRL_VM_STORE_VALUE_FLAGS
_PRL_VM_STORE_VALUE_FLAGS enumeration
_PRL_VM_TOOLS_STATE
_PRL_VM_TOOLS_STATE enumeration
_PRL_VM_TYPE
_PRL_VM_TYPE enumeration
_PRL_VM_TYPE_FLAGS
_PRL_VM_TYPE_FLAGS enumeration
_PRL_VM_WINDOW_MODE
_PRL_VM_WINDOW_MODE enumeration
_PRL_VMCTG_EVENT
_PRL_VMCTG_EVENT enumeration
_PRL_VMCTG_TOOL_DATA_RECEIVED
_PRL_VMCTG_TOOL_DATA_RECEIVED structure
_PRL_VMCTG_TOOL_DESC
_PRL_VMCTG_TOOL_DESC structure
_PRL_VTD_STATUS_CODE
_PRL_VTD_STATUS_CODE enumeration
_PRL_WINDOW_CORNERS
_PRL_WINDOW_CORNERS enumeration
_PRL_WINDOW_EDGE_MASK
_PRL_WINDOW_EDGE_MASK enumeration
_VIRTUAL_MACHINE_ADDITION_STATE
_VIRTUAL_MACHINE_ADDITION_STATE enumeration
_VIRTUAL_MACHINE_STATE
_VIRTUAL_MACHINE_STATE enumeration
A
About This Guide
API Debug Functions
Audio Playback
C
Callback Prototypes
CAPDEFAULTMASK
CAPDEFAULTMASK macro
Common Functions
D
DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_SET_ENCODING enumeration member
DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_START enumeration member
DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_STOP enumeration member
DMT_DISTRO enumeration member
DMT_LIVE_CD enumeration member
DMT_MBR enumeration member
E
event_type_to_string
event_type_to_string function
F
FS_PERM_EXECUTE
FS_PERM_EXECUTE macro
FS_PERM_READ
FS_PERM_READ macro
FS_PERM_WRITE
FS_PERM_WRITE macro
Functions
Functions by Handle
G
GUI_ANSWER_RUN_FREE_SPACE_WIZARD
GUI_ANSWER_RUN_FREE_SPACE_WIZARD macro
GUI_ERR Macros
GUI_ERR_ACTION_CANCELLED
GUI_ERR_ACTION_CANCELLED macro
GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_DOWNLOAD_NO_CONNECTION macro
GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED
GUI_ERR_ANTIVIRUS_DOWNLOAD_UNEXPECTED macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CANNOT_SAVE macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_CHECKSUM_MISMATCH macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_ANTIVIRUS_IMG_DWNLD_INVALID_DESCRIPTOR macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_CONNECTION macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_ANTIVIRUS_IMG_DWNLD_NO_FREE_SPACE macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_ANTIVIRUS_IMG_DWNLD_SIZE_MISMATCH macro
GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED
GUI_ERR_ANTIVIRUS_IMG_DWNLD_UNEXPECTED macro
GUI_ERR_APP_ALREADY_RUNNING
GUI_ERR_APP_ALREADY_RUNNING macro
GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED
GUI_ERR_APP_BUNDLE_CHECK_INIT_ABORTED macro
GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_CHECK_INIT_FAILED_TO_START macro
GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED
GUI_ERR_APP_BUNDLE_CHECK_INIT_REQUIRED macro
GUI_ERR_APP_BUNDLE_INIT_ABORTED
GUI_ERR_APP_BUNDLE_INIT_ABORTED macro
GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START
GUI_ERR_APP_BUNDLE_INIT_FAILED_TO_START macro
GUI_ERR_APP_BUNDLE_INIT_FAILURE
GUI_ERR_APP_BUNDLE_INIT_FAILURE macro
GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED
GUI_ERR_APP_BUNDLE_INIT_SOUND_DRIVER_LOCKED macro
GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION
GUI_ERR_APP_CAN_NOT_BE_STARTED_FROM_LOCATION macro
GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT
GUI_ERR_APP_CAN_NOT_BE_STARTED_IN_SAFE_BOOT macro
GUI_ERR_APP_COULD_NOT_BE_STARTED
GUI_ERR_APP_COULD_NOT_BE_STARTED macro
GUI_ERR_APP_EULA_DECLINED
GUI_ERR_APP_EULA_DECLINED macro
GUI_ERR_APP_NEED_REINSTALL
GUI_ERR_APP_NEED_REINSTALL macro
GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW
GUI_ERR_APP_RESUME_CANT_CREATE_WINDOW macro
GUI_ERR_APP_RESUME_INIT_BUNDLE
GUI_ERR_APP_RESUME_INIT_BUNDLE macro
GUI_ERR_APP_RESUME_INSTALLING_UPDATE
GUI_ERR_APP_RESUME_INSTALLING_UPDATE macro
GUI_ERR_APP_RESUME_INVALID_CONTEXT
GUI_ERR_APP_RESUME_INVALID_CONTEXT macro
GUI_ERR_APP_RESUME_SERVER_DISCONNECTED
GUI_ERR_APP_RESUME_SERVER_DISCONNECTED macro
GUI_ERR_APP_RESUME_SILENT_START
GUI_ERR_APP_RESUME_SILENT_START macro
GUI_ERR_APP_RESUME_TIMEOUT
GUI_ERR_APP_RESUME_TIMEOUT macro
GUI_ERR_APP_RESUME_VM_ENCRYPTED
GUI_ERR_APP_RESUME_VM_ENCRYPTED macro
GUI_ERR_BACKUP_FAILED_GENERAL_MSG
GUI_ERR_BACKUP_FAILED_GENERAL_MSG macro
GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE
GUI_ERR_BACKUP_FAILED_NOT_ENOUGH_SPACE macro
GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT
GUI_ERR_BACKUP_FAILED_TOO_LARGE_FOR_FAT macro
GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM
GUI_ERR_CANNOT_COMPACT_BOOTCAMP_VM macro
GUI_ERR_CANNOT_DELETE_DISK_FILES
GUI_ERR_CANNOT_DELETE_DISK_FILES macro
GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE
GUI_ERR_CANNOT_FIND_ASSINGED_TO_VMS_PCI_DEVICE macro
GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH
GUI_ERR_CANNOT_MOVE_DISK_TO_TRASH macro
GUI_ERR_CANNOT_MOVE_VM_TO_TRASH
GUI_ERR_CANNOT_MOVE_VM_TO_TRASH macro
GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE
GUI_ERR_CANNOT_PACK_MAVERICK_IMAGE macro
GUI_ERR_CANNOT_RUN_LINKED_CLONE
GUI_ERR_CANNOT_RUN_LINKED_CLONE macro
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_BACKUP macro
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE
GUI_ERR_CANNOT_RUN_SNAPSHOT_OPERATION_ON_VM_RESTORE macro
GUI_ERR_CANT_ADD_PCI_INSTANTLY
GUI_ERR_CANT_ADD_PCI_INSTANTLY macro
GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY
GUI_ERR_CANT_ADD_VIDEO_ADAPTER_INSTANTLY macro
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION macro
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CHANGE_SHARED_FOLDER macro
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_CLONE_SUSPENDED_VM macro
GUI_ERR_CANT_RUN_ON_THIS_SYSTEM
GUI_ERR_CANT_RUN_ON_THIS_SYSTEM macro
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED macro
GUI_ERR_CANT_START_UTW7_AGENT
GUI_ERR_CANT_START_UTW7_AGENT macro
GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY
GUI_ERR_CHECK_LICENSE_ERR_BETTA_KEY macro
GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED
GUI_ERR_CHECK_LICENSE_ERR_CONNECTION_FAILED macro
GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR
GUI_ERR_CHECK_LICENSE_ERR_GENERAL_ERROR macro
GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY
GUI_ERR_CHECK_LICENSE_ERR_INVALID_KEY macro
GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY
GUI_ERR_CHECK_LICENSE_ERR_TRIAL_KEY macro
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST macro
GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE
GUI_ERR_CONTACT_ADMIN_FOR_ASSISTANCE macro
GUI_ERR_CONVERT_FAILED
GUI_ERR_CONVERT_FAILED macro
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_END_IP macro
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP macro
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_INCORRECT_START_IP macro
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET macro
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP macro
GUI_ERR_DHCP_UNKNOWN
GUI_ERR_DHCP_UNKNOWN macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP macro
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP macro
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP macro
GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE
GUI_ERR_DLCITEM_DWNLD_CANNOT_SAVE macro
GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_DLCITEM_DWNLD_CHECKSUM_MISMATCH macro
GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_DLCITEM_DWNLD_INVALID_DESCRIPTOR macro
GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION
GUI_ERR_DLCITEM_DWNLD_NO_CONNECTION macro
GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE
GUI_ERR_DLCITEM_DWNLD_NO_FREE_SPACE macro
GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH
GUI_ERR_DLCITEM_DWNLD_SIZE_MISMATCH macro
GUI_ERR_DLCITEM_DWNLD_UNEXPECTED
GUI_ERR_DLCITEM_DWNLD_UNEXPECTED macro
GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION
GUI_ERR_DOWNLOAD_NO_FILE_PERMISSION macro
GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED
GUI_ERR_DOWNLOADING_APPLIANCE_DESCRIPTOR_FAILED macro
GUI_ERR_DOWNLOADING_FAILED
GUI_ERR_DOWNLOADING_FAILED macro
GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED
GUI_ERR_DOWNLOADING_HOST_ANTIVIRUS_FAILED macro
GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED
GUI_ERR_DOWNLOADING_NATIVE_LOOK_FAILED macro
GUI_ERR_DOWNLOADING_PIS_FAILED
GUI_ERR_DOWNLOADING_PIS_FAILED macro
GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED
GUI_ERR_DOWNLOADING_WINDOWS7_LOOK_FAILED macro
GUI_ERR_FAILED_TO_INIT_SDK_LIB
GUI_ERR_FAILED_TO_INIT_SDK_LIB macro
GUI_ERR_HOST_NOT_SUPPORTED
GUI_ERR_HOST_NOT_SUPPORTED macro
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED macro
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME macro
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH macro
GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED
GUI_ERR_INSTALLATION_CD_IS_NOT_INSERTED macro
GUI_ERR_INSTALLATION_DOWNLOADING_FAILED
GUI_ERR_INSTALLATION_DOWNLOADING_FAILED macro
GUI_ERR_INSTALLING_FAILED
GUI_ERR_INSTALLING_FAILED macro
GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_INSTALLING_HOST_ANTIVIRUS_FAILED macro
GUI_ERR_INVALID_ADAPTER_ADDRESS
GUI_ERR_INVALID_ADAPTER_ADDRESS macro
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_MAC_ADDRESS macro
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_OUTPUT_PATH macro
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH macro
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_INVALID_VM_NAME_SPECIFIED macro
GUI_ERR_IVALID_VM_UUID_MISMATCH
GUI_ERR_IVALID_VM_UUID_MISMATCH macro
GUI_ERR_LEGACY_HDD_NOT_SUPPORTED
GUI_ERR_LEGACY_HDD_NOT_SUPPORTED macro
GUI_ERR_MIGRATE_PC_ALREADY_RUNNING
GUI_ERR_MIGRATE_PC_ALREADY_RUNNING macro
GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM
GUI_ERR_MIGRATE_PC_FAILED_TO_REGISTER_VM macro
GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE
GUI_ERR_MIGRATE_PC_TRANSPORTER_INIT_FAILURE macro
GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED
GUI_ERR_NATIVE_LOOK_ERR_INSTALL_FAILED macro
GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN
GUI_ERR_NATIVE_LOOK_ERR_NON_ADMIN macro
GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_NATIVE_LOOK_ERR_TRANSFER_FAILED macro
GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN
GUI_ERR_NATIVE_LOOK_ERR_UNKNOWN macro
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS macro
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH macro
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE macro
GUI_ERR_NET_ADAPTER_EXISTS
GUI_ERR_NET_ADAPTER_EXISTS macro
GUI_ERR_NET_ADAPTER_NAME_EMPTY
GUI_ERR_NET_ADAPTER_NAME_EMPTY macro
GUI_ERR_NEWER_APP_ALREADY_RUNNING
GUI_ERR_NEWER_APP_ALREADY_RUNNING macro
GUI_ERR_NO_EMAIL_ACCOUNT
GUI_ERR_NO_EMAIL_ACCOUNT macro
GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL
GUI_ERR_NO_FREE_DISK_SPACE_TO_INSTALL macro
GUI_ERR_NO_INSTALLATION_DISC
GUI_ERR_NO_INSTALLATION_DISC macro
GUI_ERR_NO_INSTALLER_FILE
GUI_ERR_NO_INSTALLER_FILE macro
GUI_ERR_NO_OPTICAL_DRIVE
GUI_ERR_NO_OPTICAL_DRIVE macro
GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE
GUI_ERR_NO_PVS_FILE_SPECIFIED_IN_PLAYER_MODE macro
GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE
GUI_ERR_NO_TEMPLATE_SUPPORT_IN_PLAYER_MODE macro
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID macro
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR macro
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE macro
GUI_ERR_OLDER_APP_ALREADY_RUNNING
GUI_ERR_OLDER_APP_ALREADY_RUNNING macro
GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE
GUI_ERR_OS_IMG_DWNLD_CANNOT_SAVE macro
GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH
GUI_ERR_OS_IMG_DWNLD_CHECKSUM_MISMATCH macro
GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR
GUI_ERR_OS_IMG_DWNLD_INVALID_DESCRIPTOR macro
GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION
GUI_ERR_OS_IMG_DWNLD_NO_CONNECTION macro
GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE
GUI_ERR_OS_IMG_DWNLD_NO_FREE_SPACE macro
GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH
GUI_ERR_OS_IMG_DWNLD_SIZE_MISMATCH macro
GUI_ERR_OS_IMG_DWNLD_UNEXPECTED
GUI_ERR_OS_IMG_DWNLD_UNEXPECTED macro
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED macro
GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION
GUI_ERR_PARALLELS_IMAGE_INTERNET_LOCATION macro
GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION
GUI_ERR_PARALLELS_OUTPUT_FILE_INTERNET_LOCATION macro
GUI_ERR_PARENT_LINKED_VM_NOT_FOUND
GUI_ERR_PARENT_LINKED_VM_NOT_FOUND macro
GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR
GUI_ERR_PAX_AGENT_DOWNLOAD_ERROR macro
GUI_ERR_PAX_AGENT_INSTALL_FAILURE
GUI_ERR_PAX_AGENT_INSTALL_FAILURE macro
GUI_ERR_PAX_AGENT_NO_CONNECTION
GUI_ERR_PAX_AGENT_NO_CONNECTION macro
GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED
GUI_ERR_PENDING_SWITCH_VIEW_MODE_CANCELED macro
GUI_ERR_PMC_INVALID_CREDENTIALS
GUI_ERR_PMC_INVALID_CREDENTIALS macro
GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT
GUI_ERR_PMC_INVALID_CREDENTIALS_ON_RECONNECT macro
GUI_ERR_PMC_SERVER_BUSY
GUI_ERR_PMC_SERVER_BUSY macro
GUI_ERR_PMC_UNABLE_TO_CONNECT
GUI_ERR_PMC_UNABLE_TO_CONNECT macro
GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE
GUI_ERR_PORT_FORWARD_OUT_OF_SCOPE macro
GUI_ERR_POST_REPORT
GUI_ERR_POST_REPORT macro
GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED
GUI_ERR_PRODUCT_UPGRADE_PURCHASE_ORDER_FAILED macro
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE macro
GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER
GUI_ERR_REGISTRATION_PRODUCT_ALREADY_REGISTERED_ON_ANOTHER_USER macro
GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION
GUI_ERR_REGISTRATION_PRODUCT_ERR_CONNECTION macro
GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_GENERAL_ERROR macro
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_EMAIL macro
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_INVALID_KEY_ERROR macro
GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR
GUI_ERR_REGISTRATION_PRODUCT_ERR_TRIAL_KEY_ERROR macro
GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED
GUI_ERR_RUN_SERVICES_SCRIPT_ABORTED macro
GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START
GUI_ERR_RUN_SERVICES_SCRIPT_FAILED_TO_START macro
GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE
GUI_ERR_RUN_SERVICES_SCRIPT_FAILURE macro
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY macro
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS macro
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SERVER_WRONG_CUSTOM_NAME macro
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_EXISTS macro
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED macro
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM macro
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_EXISTS macro
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED macro
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS macro
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP macro
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SNAPSHOT_VM_WITH_VTD macro
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SOCKET_NOT_SPECIFIED macro
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST macro
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
GUI_ERR_SUSPEND_VM_WITH_VTD
GUI_ERR_SUSPEND_VM_WITH_VTD macro
GUI_ERR_UID_0_DUPLICATION
GUI_ERR_UID_0_DUPLICATION macro
GUI_ERR_UNABLE_START_LYM
GUI_ERR_UNABLE_START_LYM macro
GUI_ERR_UNABLE_START_TRANSPORTER
GUI_ERR_UNABLE_START_TRANSPORTER macro
GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD
GUI_ERR_UNABLE_TO_RETRIEVE_PASSWORD macro
GUI_ERR_UNABLE_TO_START_SERVICES
GUI_ERR_UNABLE_TO_START_SERVICES macro
GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED
GUI_ERR_UNINSTALLING_HOST_ANTIVIRUS_FAILED macro
GUI_ERR_UPDATE_INSTALL_FAILED
GUI_ERR_UPDATE_INSTALL_FAILED macro
GUI_ERR_UPDATE_UNABLE_TO_CHECK
GUI_ERR_UPDATE_UNABLE_TO_CHECK macro
GUI_ERR_UPDATER_NO_CONNECTION
GUI_ERR_UPDATER_NO_CONNECTION macro
GUI_ERR_UPDATER_NO_FILE
GUI_ERR_UPDATER_NO_FILE macro
GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE
GUI_ERR_UPGRADE_REQUEST_INVALID_RESPONSE macro
GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR
GUI_ERR_UPGRADE_REQUEST_NETWORK_ERROR macro
GUI_ERR_UPGRADE_REQUEST_UNEXPECTED
GUI_ERR_UPGRADE_REQUEST_UNEXPECTED macro
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT macro
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR macro
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT macro
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR macro
GUI_ERR_VOLUME_LICENSE_EXPIRED
GUI_ERR_VOLUME_LICENSE_EXPIRED macro
GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
GUI_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE macro
GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES
GUI_ERR_VTD_INSTALLATION_FAILED_FOR_DEVICES macro
GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES
GUI_ERR_VTD_REVERT_FAILED_FOR_DEVICES macro
GUI_ERR_WEB_STORE_INVALID_DATA
GUI_ERR_WEB_STORE_INVALID_DATA macro
GUI_ERR_WEB_STORE_NO_CONNECTION
GUI_ERR_WEB_STORE_NO_CONNECTION macro
GUI_ERR_WEB_STORE_NO_DATA
GUI_ERR_WEB_STORE_NO_DATA macro
GUI_ERR_WEB_STORE_UNEXPECTED
GUI_ERR_WEB_STORE_UNEXPECTED macro
GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL
GUI_ERR_WINDOWS7_LOOK_ERR_CANNOT_START_INSTALL macro
GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_INSTALL_FAILED macro
GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN
GUI_ERR_WINDOWS7_LOOK_ERR_NON_ADMIN macro
GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED
GUI_ERR_WINDOWS7_LOOK_ERR_TRANSFER_FAILED macro
GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN
GUI_ERR_WINDOWS7_LOOK_ERR_UNKNOWN macro
GUI_ERR_WRONG_BACKUP_PATH
GUI_ERR_WRONG_BACKUP_PATH macro
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_ERR_WRONG_NUMBER_OF_CPU macro
GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL
GUI_ERRNATIVE_LOOK_ERR_CANNOT_START_INSTALL macro
GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI
GUI_ID_WRNG_CDROM_CANNOT_CONNECT_FROM_CLIENT_SCSI macro
GUI_INFO Macros
GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL
GUI_INFO_ANTIVIRUS_DETECTED_ON_INSTALL macro
GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK
GUI_INFO_APPS_FOLDER_ADDED_TO_DOCK macro
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK macro
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM
GUI_INFO_APPS_FOLDER_REMOVED_FROM_DOCK_NO_VM macro
GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK
GUI_INFO_APPS_FOLDER_UPDATED_IN_DOCK macro
GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM
GUI_INFO_BLUETOOTH_USB_CONTROLLER_CONNECT_TO_VM macro
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_DISPLAY_HELP_TOPIC macro
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD macro
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD macro
GUI_INFO_CLEAN_UP_DISK_SPACE
GUI_INFO_CLEAN_UP_DISK_SPACE macro
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_GUEST macro
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST
GUI_INFO_COHERENCE_CANNOTSTART_DSPCFGERROR_HOST macro
GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D
GUI_INFO_COHERENCE_CANNOTSTART_LINUX_3D macro
GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY
GUI_INFO_COHERENCE_CANNOTSTART_LOWMEMORY macro
GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS
GUI_INFO_COHERENCE_CANNOTSTART_NOTENOUGHDISPLAYS macro
GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY
GUI_INFO_COHERENCE_CANNOTSTART_SERVERBUSY macro
GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED
GUI_INFO_COHERENCE_CANNOTSTART_SMDISABLED macro
GUI_INFO_COHERENCE_CANNOTSTART_SMOFF
GUI_INFO_COHERENCE_CANNOTSTART_SMOFF macro
GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST
GUI_INFO_COHERENCE_STOPPED_DSPCFGERROR_GUEST macro
GUI_INFO_COHERENCE_STOPPED_LINUX_3D
GUI_INFO_COHERENCE_STOPPED_LINUX_3D macro
GUI_INFO_COHERENCE_STOPPED_LOWMEMORY
GUI_INFO_COHERENCE_STOPPED_LOWMEMORY macro
GUI_INFO_CONFIGURING_THE_DOCK
GUI_INFO_CONFIGURING_THE_DOCK macro
GUI_INFO_CONVERT_SUCCEDED_OTHER_OS
GUI_INFO_CONVERT_SUCCEDED_OTHER_OS macro
GUI_INFO_CTRL_ALT_DEL_FROM_MENU
GUI_INFO_CTRL_ALT_DEL_FROM_MENU macro
GUI_INFO_CTRL_ALT_DEL_PRESSED
GUI_INFO_CTRL_ALT_DEL_PRESSED macro
GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED
GUI_INFO_DOWNLOAD_APPLIANCE_FINISHED macro
GUI_INFO_ENTER_IN_POWERSAVE_MODE
GUI_INFO_ENTER_IN_POWERSAVE_MODE macro
GUI_INFO_ENTER_TO_PRESENTATION_MODE
GUI_INFO_ENTER_TO_PRESENTATION_MODE macro
GUI_INFO_EXIT_FROM_PRESENTATION_MODE
GUI_INFO_EXIT_FROM_PRESENTATION_MODE macro
GUI_INFO_EXPRESS_INSTALLATION_FINISHED
GUI_INFO_EXPRESS_INSTALLATION_FINISHED macro
GUI_INFO_FEATURE_RESTRICTED
GUI_INFO_FEATURE_RESTRICTED macro
GUI_INFO_FEEDBACK_SUCCESS
GUI_INFO_FEEDBACK_SUCCESS macro
GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE
GUI_INFO_FIREWALL_MAY_BLOCK_REMOTE_MANAGE macro
GUI_INFO_GUEST_HIRES_OPTION_CHANGED
GUI_INFO_GUEST_HIRES_OPTION_CHANGED macro
GUI_INFO_HIDDEN_MESSAGES_RESTORED
GUI_INFO_HIDDEN_MESSAGES_RESTORED macro
GUI_INFO_IN_FULLSCREEN_NOTIFICATION
GUI_INFO_IN_FULLSCREEN_NOTIFICATION macro
GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE
GUI_INFO_IN_FULLSCREEN_NOTIFICATION_IN_GAME_MODE macro
GUI_INFO_IN_SEAMLESS_NOTIFICATION
GUI_INFO_IN_SEAMLESS_NOTIFICATION macro
GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON
GUI_INFO_IN_SEAMLESS_NOTIFICATION_DOCK_ICON macro
GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST
GUI_INFO_INSTALL_GHOSTSCRIPT_ON_HOST macro
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_LIN macro
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_MAC macro
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_INSTALL_TOOLS_WIN macro
GUI_INFO_INSTALLED_GUEST_APPS_DIALOG
GUI_INFO_INSTALLED_GUEST_APPS_DIALOG macro
GUI_INFO_INVALID_LOGIN_OR_PASS
GUI_INFO_INVALID_LOGIN_OR_PASS macro
GUI_INFO_IPN_MESSAGE
GUI_INFO_IPN_MESSAGE macro
GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM
GUI_INFO_ISIGHT_CAMERA_CONNECT_TO_VM macro
GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY
GUI_INFO_LICENSE_RENEWED_SUCCESSFULLY macro
GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION
GUI_INFO_LOCK_IN_FULLSCREEN_RELEASE_INPUT_NOTIFICATION macro
GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL
GUI_INFO_MOUNT_SOURCE_READY_TO_INSTALL macro
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED macro
GUI_INFO_NEW_VERSION_AVAILABLE
GUI_INFO_NEW_VERSION_AVAILABLE macro
GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT
GUI_INFO_OFFER_TO_INSTALL_PARALLELS_VAGRANT macro
GUI_INFO_OFFICE_SHARED_CLOUDS_KB
GUI_INFO_OFFICE_SHARED_CLOUDS_KB macro
GUI_INFO_PASSWORD_RESET_CHECK_EMAIL
GUI_INFO_PASSWORD_RESET_CHECK_EMAIL macro
GUI_INFO_PASSWORD_RESET_ENTER_EMAIL
GUI_INFO_PASSWORD_RESET_ENTER_EMAIL macro
GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY
GUI_INFO_PRODUCT_ACTIVATED_SUCCESSFULLY macro
GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY
GUI_INFO_PRODUCT_DEACTIVATED_SUCCESSFULLY macro
GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED
GUI_INFO_PROXY_AUTHENTIFICATION_REQUIRED macro
GUI_INFO_REG_ALREADY_REGISTERED
GUI_INFO_REG_ALREADY_REGISTERED macro
GUI_INFO_REG_CONNECTION
GUI_INFO_REG_CONNECTION macro
GUI_INFO_REG_GENERAL_ERROR
GUI_INFO_REG_GENERAL_ERROR macro
GUI_INFO_REG_INVALID_EMAIL
GUI_INFO_REG_INVALID_EMAIL macro
GUI_INFO_REG_INVALID_KEY
GUI_INFO_REG_INVALID_KEY macro
GUI_INFO_REG_INVALID_USER
GUI_INFO_REG_INVALID_USER macro
GUI_INFO_REG_OK
GUI_INFO_REG_OK macro
GUI_INFO_REG_REQUIRED_FIELDS
GUI_INFO_REG_REQUIRED_FIELDS macro
GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED
GUI_INFO_REGISTRATION_ACCOUNT_ALREADY_USED macro
GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED
GUI_INFO_REGISTRATION_ACCOUNT_SUCCESSFULLY_UPDATED macro
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK macro
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE
GUI_INFO_REGISTRATION_PRODUCT_ACTIVATED_OK_NO_SUPPORT_CODE macro
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED macro
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE
GUI_INFO_REGISTRATION_PRODUCT_ALREADY_REGISTERED_NO_SUPPORT_CODE macro
GUI_INFO_REINSTALL_TOOLS_LIN
GUI_INFO_REINSTALL_TOOLS_LIN macro
GUI_INFO_REINSTALL_TOOLS_MAC
GUI_INFO_REINSTALL_TOOLS_MAC macro
GUI_INFO_REINSTALL_TOOLS_OTHER
GUI_INFO_REINSTALL_TOOLS_OTHER macro
GUI_INFO_REINSTALL_TOOLS_WIN
GUI_INFO_REINSTALL_TOOLS_WIN macro
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT macro
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_INFO_REMAP_PD_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT macro
GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT
GUI_INFO_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_PD_SHORTCUT macro
GUI_INFO_REMOTE_SESSION_ACTIVE
GUI_INFO_REMOTE_SESSION_ACTIVE macro
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_RUN_COMPRESSOR_WIN macro
GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM
GUI_INFO_RUNNING_UNDER_UNSUPPORTED_WM macro
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SERVER_RESTART_IS_NEEDED macro
GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED
GUI_INFO_SHARE_APPS_GUEST_TOOLS_NOT_INSTALLED macro
GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED
GUI_INFO_SHARE_WIN_APPLICATIONS_DISABLED macro
GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER
GUI_INFO_SHARED_GUEST_APPS_OPEN_DOC_NEED_ADD_USER_SHARED_FOLDER macro
GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM
GUI_INFO_SHARED_PROFILE_FOR_BOOTCAMP_VM macro
GUI_INFO_SNAPSHOT_DELETE_FINISHED
GUI_INFO_SNAPSHOT_DELETE_FINISHED macro
GUI_INFO_SOFTWARE_UP_TO_DATE
GUI_INFO_SOFTWARE_UP_TO_DATE macro
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_SWITCH_TO_FULLSCREEN macro
GUI_INFO_TASK_ALREADY_RUNNING
GUI_INFO_TASK_ALREADY_RUNNING macro
GUI_INFO_TASK_STEP_SKIPPED
GUI_INFO_TASK_STEP_SKIPPED macro
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_TOOLS_INSTALL_OTHER macro
GUI_INFO_TRIAL_GUEST_WARNING
GUI_INFO_TRIAL_GUEST_WARNING macro
GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS
GUI_INFO_UNINSTALLING_HOST_ANTIVIRUS_SUCCESS macro
GUI_INFO_UPDATE_FINISHED
GUI_INFO_UPDATE_FINISHED macro
GUI_INFO_UPDATE_TOOLS_LIN
GUI_INFO_UPDATE_TOOLS_LIN macro
GUI_INFO_UPDATE_TOOLS_MAC
GUI_INFO_UPDATE_TOOLS_MAC macro
GUI_INFO_UPDATE_TOOLS_OTHER
GUI_INFO_UPDATE_TOOLS_OTHER macro
GUI_INFO_UPDATE_TOOLS_WIN
GUI_INFO_UPDATE_TOOLS_WIN macro
GUI_INFO_UPGRADE_FINISHED
GUI_INFO_UPGRADE_FINISHED macro
GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER
GUI_INFO_USB3_DRIVERS_REQUIRED_OTHER macro
GUI_INFO_USB3_DRIVERS_REQUIRED_WIN
GUI_INFO_USB3_DRIVERS_REQUIRED_WIN macro
GUI_INFO_USER_REGISTRATION_DLG_SEND_OK
GUI_INFO_USER_REGISTRATION_DLG_SEND_OK macro
GUI_INFO_VM_CLEANUP_NOTHING_TO_DO
GUI_INFO_VM_CLEANUP_NOTHING_TO_DO macro
GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC
GUI_INFO_VM_CLEANUP_RUN_AUTOMATIC macro
GUI_INFO_VM_COMPACTING_FINISHED
GUI_INFO_VM_COMPACTING_FINISHED macro
GUI_INFO_VM_DECRYPTED_SUCCESSFULLY
GUI_INFO_VM_DECRYPTED_SUCCESSFULLY macro
GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY
GUI_INFO_VM_ENCRYPTED_SUCCESSFULLY macro
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_COMPLETED macro
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED macro
GUI_INFO_VM_IN_ISOLATION_MAC
GUI_INFO_VM_IN_ISOLATION_MAC macro
GUI_INFO_VM_IN_ISOLATION_WIN
GUI_INFO_VM_IN_ISOLATION_WIN macro
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_INFO_VM_SHUTDOWN_CONDITIONS macro
GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS
GUI_INFO_WINDOWS_UPDATE_IN_PROGRESS macro
GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT
GUI_OTHER_VM_HAS_SAME_EXTERNAl_BOOT macro
GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD
GUI_QUESTION_ASK_TO_CANCEL_TUTORIAL_DOWNLOAD macro
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION macro
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION macro
GUI_QUESTION_CANCEL_INSTALL_DELETE
GUI_QUESTION_CANCEL_INSTALL_DELETE macro
GUI_QUESTION_CANCEL_INSTALL_SUSUPEND
GUI_QUESTION_CANCEL_INSTALL_SUSUPEND macro
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST macro
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG macro
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING
GUI_QUESTION_CLOSE_UPGRADE_PURCHASE_DIALOG_WHILE_PURCHASE_PROCESSING macro
GUI_QUESTION_CLOSE_VM_WINDOW
GUI_QUESTION_CLOSE_VM_WINDOW macro
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COHERENCE_NOTIFICATION macro
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE macro
GUI_QUESTION_CONFIRM_UPDATE_CANCEL
GUI_QUESTION_CONFIRM_UPDATE_CANCEL macro
GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED
GUI_QUESTION_CONVERT_3RDPARTY_VM_SUCCEDED macro
GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_OTHER_OS_SUCCEDED macro
GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED
GUI_QUESTION_CONVERT_AND_BACKUP_SUCCEDED macro
GUI_QUESTION_CONVERT_SUCCEDED
GUI_QUESTION_CONVERT_SUCCEDED macro
GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER
GUI_QUESTION_COPY_APP_TO_LOCAL_FOLDER macro
GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS
GUI_QUESTION_CREATE_SNAPSHOT_WITH_ENABLED_AUTOCOMPRESS macro
GUI_QUESTION_DELETE_CREATED_VM
GUI_QUESTION_DELETE_CREATED_VM macro
GUI_QUESTION_DELETE_OLD_VM
GUI_QUESTION_DELETE_OLD_VM macro
GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT
GUI_QUESTION_DELETE_PARENT_LINKED_SNAPSHOT macro
GUI_QUESTION_DELETE_VM_IMMEDIATELY
GUI_QUESTION_DELETE_VM_IMMEDIATELY macro
GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES
GUI_QUESTION_DELETE_VM_WITH_LINKED_CLONES macro
GUI_QUESTION_DESKTOP_IS_UNREGISTERED
GUI_QUESTION_DESKTOP_IS_UNREGISTERED macro
GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS
GUI_QUESTION_DISABLE_COPY_PAST_ALL_DISKS macro
GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS
GUI_QUESTION_DISABLE_COPY_PAST_SHARE_WINDOWS macro
GUI_QUESTION_DISABLE_HOST_SLEEP
GUI_QUESTION_DISABLE_HOST_SLEEP macro
GUI_QUESTION_DISABLE_OPTIONS
GUI_QUESTION_DISABLE_OPTIONS macro
GUI_QUESTION_DISABLE_VERBOSE_LOG
GUI_QUESTION_DISABLE_VERBOSE_LOG macro
GUI_QUESTION_DISABLE_WINDOWS7_LOOK
GUI_QUESTION_DISABLE_WINDOWS7_LOOK macro
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME macro
GUI_QUESTION_DONT_USE_DIRECT_CONECTION
GUI_QUESTION_DONT_USE_DIRECT_CONECTION macro
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR macro
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS macro
GUI_QUESTION_DWNLD_RETRY
GUI_QUESTION_DWNLD_RETRY macro
GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE
GUI_QUESTION_DWNLD_RETRY_ON_CANNOT_SAVE macro
GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_DWNLD_RETRY_ON_CHECKSUM_MISMATCH macro
GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION
GUI_QUESTION_DWNLD_RETRY_ON_NO_CONNECTION macro
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_EDIT_SUSPENDED_VM macro
GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE
GUI_QUESTION_ENABLE_ACCESSIBILITY_MODE macro
GUI_QUESTION_ENABLE_BACKGROUND_UPDATE
GUI_QUESTION_ENABLE_BACKGROUND_UPDATE macro
GUI_QUESTION_ENABLE_CEP
GUI_QUESTION_ENABLE_CEP macro
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING macro
GUI_QUESTION_ENABLE_GUEST_SHARING
GUI_QUESTION_ENABLE_GUEST_SHARING macro
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING macro
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP macro
GUI_QUESTION_ENABLE_PMU_SUPPORT
GUI_QUESTION_ENABLE_PMU_SUPPORT macro
GUI_QUESTION_ENABLE_SHARED_APPS
GUI_QUESTION_ENABLE_SHARED_APPS macro
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION macro
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH
GUI_QUESTION_ENABLE_VIDEO_POWER_OPTIMIZATION_ON_BATTERY_SWITCH macro
GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION
GUI_QUESTION_ENABLE_VIRTUAL_DISK_OPTIMIZATION macro
GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT
GUI_QUESTION_ENABLE_VTX_EPT_SUPPORT macro
GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
GUI_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK macro
GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
GUI_QUESTION_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT macro
GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE
GUI_QUESTION_IMPORT_BOOTCAMP_VM_COMPLETE macro
GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START
GUI_QUESTION_IMPORT_BOOTCAMP_VM_SUCCEDED_AND_START macro
GUI_QUESTION_INSTALL_MAJOR_UPDATE
GUI_QUESTION_INSTALL_MAJOR_UPDATE macro
GUI_QUESTION_INSTALL_WINDOWS7_LOOK
GUI_QUESTION_INSTALL_WINDOWS7_LOOK macro
GUI_QUESTION_INVALID_VM_CORRUPTED
GUI_QUESTION_INVALID_VM_CORRUPTED macro
GUI_QUESTION_INVALID_VM_NOT_AVAILABLE
GUI_QUESTION_INVALID_VM_NOT_AVAILABLE macro
GUI_QUESTION_ISOLATE_VM
GUI_QUESTION_ISOLATE_VM macro
GUI_QUESTION_ISOLATE_VM_LIN
GUI_QUESTION_ISOLATE_VM_LIN macro
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING macro
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY macro
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_LOST_TASK_CONTINUE macro
GUI_QUESTION_MANUAL_INSTALL
GUI_QUESTION_MANUAL_INSTALL macro
GUI_QUESTION_MOVE_TO_TRASH_DISK
GUI_QUESTION_MOVE_TO_TRASH_DISK macro
GUI_QUESTION_MOVE_TO_TRASH_VM
GUI_QUESTION_MOVE_TO_TRASH_VM macro
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE macro
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER macro
GUI_QUESTION_NO_BACKUP
GUI_QUESTION_NO_BACKUP macro
GUI_QUESTION_NO_FREE_SPACE
GUI_QUESTION_NO_FREE_SPACE macro
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW macro
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8
GUI_QUESTION_OS_IMG_DWNLD_CLOSE_WINDOW_WIN8 macro
GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE
GUI_QUESTION_OS_IMG_DWNLD_NO_FREE_DISK_SPACE macro
GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH
GUI_QUESTION_OS_IMG_DWNLD_RETRY_ON_CHECKSUM_MISMATCH macro
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_OVERWRITE_HDD_IMAGE macro
GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE
GUI_QUESTION_PARENT_LINKED_VM_NOT_AVAILABLE macro
GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS
GUI_QUESTION_PAX_ENABLE_REMOTE_ACCESS macro
GUI_QUESTION_POSTPONE_UPGRADE
GUI_QUESTION_POSTPONE_UPGRADE macro
GUI_QUESTION_PREPARE_MAVERICK_IMAGE
GUI_QUESTION_PREPARE_MAVERICK_IMAGE macro
GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED
GUI_QUESTION_PRODUCT_UPGRADE_DOWNLOAD_FAILED macro
GUI_QUESTION_PROFILE_DELETE
GUI_QUESTION_PROFILE_DELETE macro
GUI_QUESTION_QUIT_PARALLELS_ACCESS
GUI_QUESTION_QUIT_PARALLELS_ACCESS macro
GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM
GUI_QUESTION_RECONNECT_USB_TO_ANOTHER_VM macro
GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT
GUI_QUESTION_REMAP_VM_KEY_SEQUENCE_ALREADY_USED_BY_VM_SHORTCUT macro
GUI_QUESTION_REMOVE_BACKUP
GUI_QUESTION_REMOVE_BACKUP macro
GUI_QUESTION_REMOVE_PREVIOUS_VERSION
GUI_QUESTION_REMOVE_PREVIOUS_VERSION macro
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REMOVE_SERVER_FROM_LIST macro
GUI_QUESTION_REPLACE_PREVIOUS_VERSION
GUI_QUESTION_REPLACE_PREVIOUS_VERSION macro
GUI_QUESTION_RESET_VIRTUAL_NETWORK
GUI_QUESTION_RESET_VIRTUAL_NETWORK macro
GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE
GUI_QUESTION_RESTART_PD_ON_HEADLESS_CHANGE macro
GUI_QUESTION_RESTORE_FROM_BACKUP
GUI_QUESTION_RESTORE_FROM_BACKUP macro
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT macro
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT macro
GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS
GUI_QUESTION_RUN_VM_FOR_INSTALL_ANTIVIRUS macro
GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN
GUI_QUESTION_SAME_FUNCTION_NET_ASSIGN macro
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GLOBAL_SHARING macro
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_GUEST_SHARING macro
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_LOCAL_SHARING macro
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS
GUI_QUESTION_SHARED_GUEST_APPS_OPEN_DOC_NEED_USER_SHARED_FOLDERS macro
GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG
GUI_QUESTION_SHARED_HOST_APPS_ASK_TO_ENABLE_DLG macro
GUI_QUESTION_SM_ENABLE_SHARED_APPS
GUI_QUESTION_SM_ENABLE_SHARED_APPS macro
GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR
GUI_QUESTION_SMART_SELECT_ASK_TO_ENABLE_FOR macro
GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS
GUI_QUESTION_SNAPSHOT_DELETE_WITH_CHILDRENS macro
GUI_QUESTION_SNAPSHOT_SINGLE_DELETE
GUI_QUESTION_SNAPSHOT_SINGLE_DELETE macro
GUI_QUESTION_STOP_APPLIANCE
GUI_QUESTION_STOP_APPLIANCE macro
GUI_QUESTION_STOP_SUSPENDED_VM
GUI_QUESTION_STOP_SUSPENDED_VM macro
GUI_QUESTION_TRIAL_EXPIRES_TEXT1
GUI_QUESTION_TRIAL_EXPIRES_TEXT1 macro
GUI_QUESTION_TRIAL_EXPIRES_TEXT2
GUI_QUESTION_TRIAL_EXPIRES_TEXT2 macro
GUI_QUESTION_TRIAL_EXPIRES_TEXT3
GUI_QUESTION_TRIAL_EXPIRES_TEXT3 macro
GUI_QUESTION_TRIAL_EXPIRES_TEXT4
GUI_QUESTION_TRIAL_EXPIRES_TEXT4 macro
GUI_QUESTION_UPDATER_NO_CONNECTION
GUI_QUESTION_UPDATER_NO_CONNECTION macro
GUI_QUESTION_USB_CONTROLLER_REMOVE
GUI_QUESTION_USB_CONTROLLER_REMOVE macro
GUI_QUESTION_VM_CLEANUP_CONFIRM
GUI_QUESTION_VM_CLEANUP_CONFIRM macro
GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE
GUI_QUESTION_VM_DIR_CANT_START_TEMPLATE macro
GUI_TRY_DISCONNECT_CONNECTING_USB
GUI_TRY_DISCONNECT_CONNECTING_USB macro
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST macro
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE macro
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE macro
GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST
GUI_WNG_NO_FREE_NETWORK_ADAPTERS_FOR_HOST macro
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WNG_STOP_VM_WITH_BOOTCAMP macro
GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION
GUI_WRN_AUTOPLAY_CD_NOT_PRESENT_IN_CONFIGURATION macro
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT macro
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE
GUI_WRN_BOOT_CAMP_NEEDS_FREE_SLOT_IDE macro
GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS
GUI_WRN_CANT_CLOSE_CONVERSION_IN_PROGRESS macro
GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS
GUI_WRN_CANT_CLOSE_DELETING_STATE_IN_PROGRESS macro
GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS
GUI_WRN_CANT_CLOSE_REVERTING_IN_PROGRESS macro
GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS
GUI_WRN_CANT_CLOSE_SNAPSHOTING_IN_PROGRESS macro
GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT
GUI_WRN_CANT_REVERT_ABSENT_SNAPSHOT macro
GUI_WRN_DESKTOP_IS_TRIAL
GUI_WRN_DESKTOP_IS_TRIAL macro
GUI_WRN_DEVICE_ALREADY_EXIST
GUI_WRN_DEVICE_ALREADY_EXIST macro
GUI_WRN_DHCP_END_IP_ADDRESS
GUI_WRN_DHCP_END_IP_ADDRESS macro
GUI_WRN_DHCP_START_IP_ADDRESS
GUI_WRN_DHCP_START_IP_ADDRESS macro
GUI_WRN_DUPLICATE_VIRTUAL_NETWORK
GUI_WRN_DUPLICATE_VIRTUAL_NETWORK macro
GUI_WRN_ENCRYPTED_DISK_NOT_ADDED
GUI_WRN_ENCRYPTED_DISK_NOT_ADDED macro
GUI_WRN_FS_RESIZE_NOT_SUPPORTED
GUI_WRN_FS_RESIZE_NOT_SUPPORTED macro
GUI_WRN_HOST_IP_ADDRESS
GUI_WRN_HOST_IP_ADDRESS macro
GUI_WRN_INVALID_IPV6_ADDRESS
GUI_WRN_INVALID_IPV6_ADDRESS macro
GUI_WRN_INVALID_VM_BUNDLE
GUI_WRN_INVALID_VM_BUNDLE macro
GUI_WRN_INVALID_VM_FOLDER
GUI_WRN_INVALID_VM_FOLDER macro
GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED
GUI_WRN_KEY_NOT_BE_AUTO_REGISTRED macro
GUI_WRN_LOCAL_PATH_NOT_SPECIFIED
GUI_WRN_LOCAL_PATH_NOT_SPECIFIED macro
GUI_WRN_LOCAL_PATH_WRONG
GUI_WRN_LOCAL_PATH_WRONG macro
GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL
GUI_WRN_MAIN_MEMORY_IS_NOT_OPTIMAL macro
GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE
GUI_WRN_MAKE_BACKUP_BEFORE_DISK_RESIZE macro
GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D
GUI_WRN_MOUSE_SYNC_OFF_FOR_LINUX_WITH3D macro
GUI_WRN_NEW_PROFILE_NAME_EMPTY
GUI_WRN_NEW_PROFILE_NAME_EMPTY macro
GUI_WRN_NO_BACKUP_FOLDER
GUI_WRN_NO_BACKUP_FOLDER macro
GUI_WRN_NO_USB_DEVICES_AVAILABLE
GUI_WRN_NO_USB_DEVICES_AVAILABLE macro
GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS
GUI_WRN_OPEN_IN_IE_NO_RUNNING_WINDOWS_VMS macro
GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS
GUI_WRN_OPEN_IN_WIN_EXPLORER_NO_RUNNING_WINDOWS_VMS macro
GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS
GUI_WRN_OPEN_IN_WIN_NO_RUNNING_WINDOWS_VMS macro
GUI_WRN_PARTITION_NOT_SPECIFIED
GUI_WRN_PARTITION_NOT_SPECIFIED macro
GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT
GUI_WRN_PORT_MAPPING_INC_PORT_INCORRECT macro
GUI_WRN_PORT_MAPPING_IP_INCORRECT
GUI_WRN_PORT_MAPPING_IP_INCORRECT macro
GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT
GUI_WRN_PORT_MAPPING_VM_PORT_INCORRECT macro
GUI_WRN_PRODUCT_KEY_INCOMPLETE
GUI_WRN_PRODUCT_KEY_INCOMPLETE macro
GUI_WRN_PRODUCT_KEY_WRONG_LENGTH
GUI_WRN_PRODUCT_KEY_WRONG_LENGTH macro
GUI_WRN_PROFILE_NAME_ALREADY_IN_USE
GUI_WRN_PROFILE_NAME_ALREADY_IN_USE macro
GUI_WRN_PURCHASE_MISSING_KEY
GUI_WRN_PURCHASE_MISSING_KEY macro
GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED
GUI_WRN_REGISTER_VM_WIZ_COMPLETE_PAGE_TITLE_CREATION_FAILED macro
GUI_WRN_SERVER_ALREADY_CONNECTED
GUI_WRN_SERVER_ALREADY_CONNECTED macro
GUI_WRN_SERVER_NAME_NOT_SPECIFIED
GUI_WRN_SERVER_NAME_NOT_SPECIFIED macro
GUI_WRN_SERVER_NAME_WRONG
GUI_WRN_SERVER_NAME_WRONG macro
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY macro
GUI_WRN_SOURCE_FOR_DEVICE_IS_USED
GUI_WRN_SOURCE_FOR_DEVICE_IS_USED macro
GUI_WRN_SUBNET_MASK
GUI_WRN_SUBNET_MASK macro
GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG
GUI_WRN_UNABLE_OPEN_FEEDBACK_DLG macro
GUI_WRN_UNABLE_REQUEST_TRIAL_KEY
GUI_WRN_UNABLE_REQUEST_TRIAL_KEY macro
GUI_WRN_UNATTENDED_LINUX_NO_IMAGE
GUI_WRN_UNATTENDED_LINUX_NO_IMAGE macro
GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE
GUI_WRN_UNATTENDED_WINDOWS_NO_IMAGE macro
GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY
GUI_WRN_UPGRADE_PURCHASE_MISSING_KEY macro
GUI_WRN_USER_NAME_ILLEGAL
GUI_WRN_USER_NAME_ILLEGAL macro
GUI_WRN_USER_NAME_NOT_SPECIFIED
GUI_WRN_USER_NAME_NOT_SPECIFIED macro
GUI_WRN_USER_NAME_RESERVED_BY_GUEST
GUI_WRN_USER_NAME_RESERVED_BY_GUEST macro
GUI_WRN_USER_PASS_DO_NOT_MATCH
GUI_WRN_USER_PASS_DO_NOT_MATCH macro
GUI_WRN_USER_PASS_NOT_SPECIFIED
GUI_WRN_USER_PASS_NOT_SPECIFIED macro
GUI_WRN_USER_PASS_TOO_SHORT
GUI_WRN_USER_PASS_TOO_SHORT macro
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW macro
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW_FOR_HIDPI macro
GUI_WRN_VIRTUAL_NETWORK_WRONG
GUI_WRN_VIRTUAL_NETWORK_WRONG macro
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS macro
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS macro
GUID_CLS_BASE_STR
GUID_CLS_BASE_STR macro
GUID_CLS_ENCRYPTION_STR
GUID_CLS_ENCRYPTION_STR macro
H
Handle Functions
handle_type_to_string
handle_type_to_string function
How to Use This Guide
I
ICryptInfoPtr
ICryptInfoPtr type
IOS_AUTH_FAILED enumeration member
IOS_CONNECTION_TIMEOUT enumeration member
IOS_DISABLED enumeration member
IOS_STARTED enumeration member
IOS_STOPPED enumeration member
IOS_UNKNOWN_VM_UUID enumeration member
IPluginInfoPtr
IPluginInfoPtr type
IS_ANDROID
IS_ANDROID macro
IS_CHROMEOS
IS_CHROMEOS macro
IS_FREEBSD
IS_FREEBSD macro
IS_FS_EXECUTE_PERMITTED
IS_FS_EXECUTE_PERMITTED macro
IS_FS_READ_PERMITTED
IS_FS_READ_PERMITTED macro
IS_FS_WRITE_PERMITTED
IS_FS_WRITE_PERMITTED macro
IS_LINUX
IS_LINUX macro
IS_MACOS
IS_MACOS macro
IS_MSDOS
IS_MSDOS macro
IS_NETWARE
IS_NETWARE macro
IS_OS2
IS_OS2 macro
IS_OTHER
IS_OTHER macro
IS_SOLARIS
IS_SOLARIS macro
IS_VALID_ANDROID_VERSION
IS_VALID_ANDROID_VERSION macro
IS_VALID_CHROMEOS_VERSION
IS_VALID_CHROMEOS_VERSION macro
IS_VALID_FREEBSD_VERSION
IS_VALID_FREEBSD_VERSION macro
IS_VALID_LINUX_VERSION
IS_VALID_LINUX_VERSION macro
IS_VALID_MACOS_VERSION
IS_VALID_MACOS_VERSION macro
IS_VALID_MSDOS_VERSION
IS_VALID_MSDOS_VERSION macro
IS_VALID_NETWARE_VERSION
IS_VALID_NETWARE_VERSION macro
IS_VALID_OS2_VERSION
IS_VALID_OS2_VERSION macro
IS_VALID_OTHER_OS_VERSION
IS_VALID_OTHER_OS_VERSION macro
IS_VALID_SOLARIS_VERSION
IS_VALID_SOLARIS_VERSION macro
IS_VALID_WINDOWS_VERSION
IS_VALID_WINDOWS_VERSION macro
IS_WIN_VER_BELOW
IS_WIN_VER_BELOW macro
IS_WINDOWS
IS_WINDOWS macro
K
Keyboard Control
M
Macros
Mouse Control
O
Organization of This Guide
Other Macros
Other Structs
Other Types
P
P3D_DISABLED enumeration member
P3D_ENABLED_DX9 enumeration member
P3D_ENABLED_HIGHEST enumeration member
PACF_CANCEL_TASK_ON_END_SESSION enumeration member
PACF_HIGH_SECURITY enumeration member
PACF_LAST enumeration member
PACF_MAX enumeration member
PACF_NON_INTERACTIVE_MODE enumeration member
PACF_NORMAL_SECURITY enumeration member
PADS_CANCELED enumeration member
PADS_DOWNLOADED enumeration member
PADS_DOWNLOADING enumeration member
PADS_MOVED enumeration member
PADS_NOT_STARTED enumeration member
PADS_REGISTERED enumeration member
PADS_STOPPED enumeration member
PADS_UNPACKED enumeration member
PAI_GENERATE_INDEX enumeration member
PAI_INVALID_ADAPTER enumeration member
PAIF_INIT_AS_APPSTORE_CLIENT enumeration member
PAIF_USE_GRAPHIC_MODE enumeration member
PAM_DESKTOP enumeration member
PAM_DESKTOP_MAC enumeration member
PAM_DESKTOP_STM enumeration member
PAM_DESKTOP_STM_OBSOLETE enumeration member
PAM_DESKTOP_WL enumeration member
PAM_LAST enumeration member
PAM_MOBILE enumeration member
PAM_PLAYER enumeration member
PAM_SERVER enumeration member
PAM_STM enumeration member
PAM_UNKNOWN enumeration member
PAM_WORKSTATION enumeration member
PAM_WORKSTATION_EXTREME enumeration member
PAO_VM_NOT_SHARED enumeration member
PAO_VM_SHARED_ON_FULL_ACCESS enumeration member
PAO_VM_SHARED_ON_VIEW enumeration member
PAO_VM_SHARED_ON_VIEW_AND_RUN enumeration member
PAO_VM_SHUTDOWN enumeration member
PAO_VM_START_MANUAL enumeration member
PAO_VM_START_ON_GUI_APP_STARTUP enumeration member
PAO_VM_START_ON_GUI_VM_WINDOW_OPEN enumeration member
PAO_VM_START_ON_GUI_WINDOW_LOAD enumeration member
PAO_VM_START_ON_LOAD enumeration member
PAO_VM_START_ON_RELOAD enumeration member
PAO_VM_STOP enumeration member
PAO_VM_SUSPEND enumeration member
PAR_MAX enumeration member
PAR_SRV_SENDPROBLEMREPORT_ACCESS enumeration member
PAR_SRV_SERVER_PROFILE_BEGINEDIT_ACCESS enumeration member
PAR_SRV_SERVER_PROFILE_COMMIT_ACCESS enumeration member
PAR_SRV_USER_PROFILE_BEGINEDIT_ACCESS enumeration member
PAR_SRV_USER_PROFILE_COMMIT_ACCESS enumeration member
PAR_VM_AUTHORISE_ACCESS enumeration member
PAR_VM_BEGINEDIT_ACCESS enumeration member
PAR_VM_CANCEL_COMPACT_ACCESS enumeration member
PAR_VM_CANCEL_COMPRESSOR_ACCESS enumeration member
PAR_VM_CHANGE_GUEST_OS_PASSWORD_ACCESS enumeration member
PAR_VM_CHANGE_PASSWORD_ACCESS enumeration member
PAR_VM_CHANGE_SID_ACCESS enumeration member
PAR_VM_CLONE_ACCESS enumeration member
PAR_VM_COMMIT_ACCESS enumeration member
PAR_VM_COMPACT_ACCESS enumeration member
PAR_VM_CONVERT_DISKS_ACCESS enumeration member
PAR_VM_CREATE_ACCESS enumeration member
PAR_VM_CREATE_BACKUP_ACCESS enumeration member
PAR_VM_CREATE_SNAPSHOT_ACCESS enumeration member
PAR_VM_DECRYPT_ACCESS enumeration member
PAR_VM_DELETE_ACCESS enumeration member
PAR_VM_DELETE_SNAPSHOT_ACCESS enumeration member
PAR_VM_DROPSUSPENDEDSTATE_ACCESS enumeration member
PAR_VM_EDITING_ACCESS enumeration member
PAR_VM_ENCRYPT_ACCESS enumeration member
PAR_VM_ENCRYPT_OPERATION_ACCESS enumeration member
PAR_VM_GET_SUSPENDED_SCREEN_ACCESS enumeration member
PAR_VM_GET_TOOLS_INFO enumeration member
PAR_VM_GET_VIRT_DEV_INFO enumeration member
PAR_VM_GET_VMINFO_ACCESS enumeration member
PAR_VM_GETCONFIG_ACCESS enumeration member
PAR_VM_GETPROBLEMREPORT_ACCESS enumeration member
PAR_VM_GETSTATISTICS_ACCESS enumeration member
PAR_VM_GUI_VIEW_MODE_CHANGE_ACCESS enumeration member
PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS enumeration member
PAR_VM_INSTALL_TOOLS_ACCESS enumeration member
PAR_VM_INSTALL_UTILITY_ACCESS enumeration member
PAR_VM_INTERNAL_CMD_ACCESS enumeration member
PAR_VM_LOCK_ACCESS enumeration member
PAR_VM_MIGRATE_ACCESS enumeration member
PAR_VM_MIGRATE_CANCEL_ACCESS enumeration member
PAR_VM_MOUNT_ACCESS enumeration member
PAR_VM_MOVE_ACCESS enumeration member
PAR_VM_PAUSE_ACCESS enumeration member
PAR_VM_PERFSTAT_ACCESS enumeration member
PAR_VM_REGISTER_ACCESS enumeration member
PAR_VM_REMOVE_PROTECTION_ACCESS enumeration member
PAR_VM_RESET_ACCESS enumeration member
PAR_VM_RESET_UPTIME_ACCESS enumeration member
PAR_VM_RESIZE_DISK_ACCESS enumeration member
PAR_VM_RESTART_GUEST_ACCESS enumeration member
PAR_VM_RESTORE_ACCESS enumeration member
PAR_VM_RESTORE_BACKUP_ACCESS enumeration member
PAR_VM_RESUME_ACCESS enumeration member
PAR_VM_RUN_COMPRESSOR_ACCESS enumeration member
PAR_VM_SEND_ANSWER_ACCESS enumeration member
PAR_VM_SET_PROTECTION_ACCESS enumeration member
PAR_VM_START_ACCESS enumeration member
PAR_VM_START_EX_ACCESS enumeration member
PAR_VM_START_STOP_VNC_SERVER enumeration member
PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS enumeration member
PAR_VM_STOP_ACCESS enumeration member
PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS enumeration member
PAR_VM_SUSPEND_ACCESS enumeration member
PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS enumeration member
PAR_VM_UNLOCK_ACCESS enumeration member
PAR_VM_UNREG_ACCESS enumeration member
PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS enumeration member
PAR_VM_UPDATE_SECURITY_ACCESS enumeration member
PAR_VM_UPDATE_TOOLS_SECTION enumeration member
PAR_VMDEV_CONNECT_ACCESS enumeration member
PAR_VMDEV_COPY_IMAGE_ACCESS enumeration member
PAR_VMDEV_CREATEIMAGE_ACCESS enumeration member
PAR_VMDEV_DISCONNECT_ACCESS enumeration member
PAS_CLOSE_VM_WINDOW enumeration member
PAS_KEEP_VM_WINDOW_OPEN enumeration member
PAS_QUIT_APPLICATION enumeration member
PAUST_PLAYOUT enumeration member
PAUST_RECORDING enumeration member
PBO_CD_HDD_FLOPPY enumeration member
PBO_FLOPPY_HDD_CD enumeration member
PBO_HDD_CD_FLOPPY enumeration member
PBSL_HIGH_SECURITY enumeration member
PBSL_LOW_SECURITY enumeration member
PBSL_NORMAL_SECURITY enumeration member
PBT_BACKUP_ID enumeration member
PBT_CHAIN enumeration member
PBT_CT enumeration member
PBT_DIFFERENTIAL enumeration member
PBT_EFI enumeration member
PBT_FULL enumeration member
PBT_IGNORE_NOT_EXISTS enumeration member
PBT_INCREMENTAL enumeration member
PBT_LEGACY enumeration member
PBT_RESTORE_TO_COPY enumeration member
PBT_UNCOMPRESSED enumeration member
PBT_VM enumeration member
PCA_COHERENCE enumeration member
PCA_CRYSTAL enumeration member
PCA_HIDE_APPLICATION enumeration member
PCA_MODALITY enumeration member
PCA_NO_ACTION enumeration member
PCA_SEAMLESS enumeration member
PCA_UNGRAB_INPUT enumeration member
PCA_WINDOWED enumeration member
PCC_AUDIT_WRITE enumeration member
PCC_CHOWN enumeration member
PCC_DAC_OVERRIDE enumeration member
PCC_DAC_READ_SEARCH enumeration member
PCC_FOWNER enumeration member
PCC_FS_MASK enumeration member
PCC_FSETID enumeration member
PCC_IPC_LOCK enumeration member
PCC_IPC_OWNER enumeration member
PCC_KILL enumeration member
PCC_LEASE enumeration member
PCC_LINUX_IMMUTABLE enumeration member
PCC_MKNOD enumeration member
PCC_NET_ADMIN enumeration member
PCC_NET_BIND_SERVICE enumeration member
PCC_NET_BROADCAST enumeration member
PCC_NET_RAW enumeration member
PCC_SETFCAP enumeration member
PCC_SETGID enumeration member
PCC_SETPCAP enumeration member
PCC_SETUID enumeration member
PCC_SYS_ADMIN enumeration member
PCC_SYS_BOOT enumeration member
PCC_SYS_CHROOT enumeration member
PCC_SYS_MODULE enumeration member
PCC_SYS_NICE enumeration member
PCC_SYS_PACCT enumeration member
PCC_SYS_PTRACE enumeration member
PCC_SYS_RAWIO enumeration member
PCC_SYS_RESOURCE enumeration member
PCC_SYS_TIME enumeration member
PCC_SYS_TTY_CONFIG enumeration member
PCC_VE_ADMIN enumeration member
PCD_BUSLOGIC enumeration member
PCD_LSI_SAS enumeration member
PCD_LSI_SPI enumeration member
PCD_UNKNOWN_DEVICE enumeration member
PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION enumeration member
PCF_FEATURE_BRIDGE enumeration member
PCF_FEATURE_DEF_PERM enumeration member
PCF_FEATURE_IPGRE enumeration member
PCF_FEATURE_IPIP enumeration member
PCF_FEATURE_NFS enumeration member
PCF_FEATURE_NFSD enumeration member
PCF_FEATURE_PPP enumeration member
PCF_FEATURE_SIT enumeration member
PCF_FEATURE_SYSFS enumeration member
PCF_LIGHTWEIGHT_CLIENT enumeration member
PCF_ORIGINAL_CLIENT enumeration member
PCF_TRUSTED_CHANNEL enumeration member
PCFE_EXT_00000007_EBX enumeration member
PCFE_EXT_0000000D_EAX enumeration member
PCFE_EXT_80000001_ECX enumeration member
PCFE_EXT_80000001_EDX enumeration member
PCFE_EXT_80000007_EDX enumeration member
PCFE_EXT_80000008_EAX enumeration member
PCFE_EXT_FEATURES enumeration member
PCFE_FEATURES enumeration member
PCFE_MAX enumeration member
PCM_COMPACT_WITH_HARD_DISKS_INFO enumeration member
PCM_CPU_AMD_V enumeration member
PCM_CPU_INTEL_VT_X enumeration member
PCM_CPU_MODE_32 enumeration member
PCM_CPU_MODE_64 enumeration member
PCM_CPU_NONE_HV enumeration member
PCM_FULL_CLEAN_UP_VM enumeration member
PCM_HARD_DISKS_INFO enumeration member
PCNM_DISABLED enumeration member
PCNM_FULL enumeration member
PCNM_NOT_SET enumeration member
PCNM_STATEFUL enumeration member
PCNM_STATELESS enumeration member
PCR_DCACHESIZE enumeration member
PCR_DGRAMRCVBUF enumeration member
PCR_KMEMSIZE enumeration member
PCR_LAST enumeration member
PCR_LOCKEDPAGES enumeration member
PCR_NUMFILE enumeration member
PCR_NUMFLOCK enumeration member
PCR_NUMIPTENT enumeration member
PCR_NUMOTHERSOCK enumeration member
PCR_NUMPROC enumeration member
PCR_NUMPTY enumeration member
PCR_NUMSIGINFO enumeration member
PCR_NUMTCPSOCK enumeration member
PCR_OOMGUARPAGES enumeration member
PCR_OTHERSOCKBUF enumeration member
PCR_PHYSPAGES enumeration member
PCR_PRIVVMPAGES enumeration member
PCR_QUOTAUGIDLIMIT enumeration member
PCR_SHMPAGES enumeration member
PCR_SWAPPAGES enumeration member
PCR_TCPRCVBUF enumeration member
PCR_TCPSNDBUF enumeration member
PCR_VMGUARPAGES enumeration member
PCS_CONNECTED enumeration member
PCS_CONNECTING enumeration member
PCS_DISCONNECTED enumeration member
PCSF_BACKUP enumeration member
PCSF_DISK_ONLY enumeration member
PCT_TYPE_EZ_APP enumeration member
PCT_TYPE_EZ_OS enumeration member
PCTMP_HIGH_SECURITY enumeration member
PCTMP_LOW_SECURITY enumeration member
PCTMP_NORMAL_SECURITY enumeration member
PCTMPL_FORCE enumeration member
PCVD_CANCEL enumeration member
PCVD_MERGE_ALL_SNAPSHOTS enumeration member
PCVD_TO_EXPANDING_DISK enumeration member
PCVD_TO_NON_SPLIT_DISK enumeration member
PCVD_TO_PLAIN_DISK enumeration member
PCVD_TO_SPLIT_DISK enumeration member
PCVF_CHANGE_SID enumeration member
PCVF_CLONE_TO_TEMPLATE enumeration member
PCVF_DETACH_EXTERNAL_VIRTUAL_HDD enumeration member
PCVF_IMPORT_BOOT_CAMP enumeration member
PCVF_LINKED_CLONE enumeration member
PCVF_REGENERATE_SRC_VM_UUID enumeration member
PDA_DEVICE_IDLE enumeration member
PDA_DEVICE_READ enumeration member
PDA_DEVICE_WRITE enumeration member
PDBF_BGR32 enumeration member
PDBF_INDEX8 enumeration member
PDBF_NO_CONVERSION enumeration member
PDBF_RGB15 enumeration member
PDBF_RGB16 enumeration member
PDBF_RGB24 enumeration member
PDBF_RGB32 enumeration member
PDBF_YUV420 enumeration member
PDBF_YUV422x4 enumeration member
PDBF_YUV422x6 enumeration member
PDBF_YUV422x8 enumeration member
PDCC_HIGH_COMPRESSION enumeration member
PDCC_LOW_COMPRESSION enumeration member
PDCC_MEDIUM_COMPRESSION enumeration member
PDCC_NO_COMPRESSION enumeration member
PDCM_CLIENT_DISPLAY_INFO enumeration member
PDCM_DISABLE_HIDPI_ADJUSTMENT enumeration member
PDCM_DO_NOT_RESTORE enumeration member
PDCM_ENABLE_HEADS enumeration member
PDCM_HAS_HIDPI_DISPLAY enumeration member
PDCM_RESTORE_DEFAULT enumeration member
PDCM_RETINA_MODE enumeration member
PDCQ_HIGH_QUALITY enumeration member
PDCQ_LOW_QUALITY enumeration member
PDCQ_MEDIUM_QUALITY enumeration member
PDCT_HIGH_QUALITY_WITH_COMPRESSION enumeration member
PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION enumeration member
PDCT_LOW_QUALITY_WITH_COMPRESSION enumeration member
PDCT_LOW_QUALITY_WITHOUT_COMPRESSION enumeration member
PDCT_MEDIUM_QUALITY_WITH_COMPRESSION enumeration member
PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION enumeration member
PDE_CLUSTERED_DEVICE enumeration member
PDE_FLOPPY_DISK enumeration member
PDE_GENERIC_DEVICE enumeration member
PDE_GENERIC_NETWORK_ADAPTER enumeration member
PDE_GENERIC_PCI_DEVICE enumeration member
PDE_GENERIC_PORT enumeration member
PDE_GENERIC_SCSI_DEVICE enumeration member
PDE_HARD_DISK enumeration member
PDE_MASSSTORAGE_DEVICE enumeration member
PDE_MAX enumeration member
PDE_MIXER_DEVICE enumeration member
PDE_OPTICAL_DISK enumeration member
PDE_PARALLEL_PORT enumeration member
PDE_PCI_VIDEO_ADAPTER enumeration member
PDE_PRINTER enumeration member
PDE_SERIAL_PORT enumeration member
PDE_SOUND_DEVICE enumeration member
PDE_STORAGE_DEVICE enumeration member
PDE_USB_DEVICE enumeration member
PDE_VIRTUAL_SHARED_FOLDERS_DEVICE enumeration member
PDE_VIRTUAL_SNAPSHOT_DEVICE enumeration member
PDM_APP_IN_DOCK_ALWAYS enumeration member
PDM_APP_IN_DOCK_COHERENCE_ONLY enumeration member
PDM_APP_IN_DOCK_NEVER enumeration member
PDR_ANOTHER_CLIENT_CONNECTED enumeration member
PDR_HOST_USER_INPUT_DETECTED enumeration member
PDR_HOST_USER_LOGGED_IN enumeration member
PDR_RECONNECT enumeration member
PDR_SESSION_BECOME_INACTIVE enumeration member
PDR_UNSPECIFIED enumeration member
PDSF_BACKUP enumeration member
PDSF_SKIP_SPACE_CHECK enumeration member
PDSS_UNKNOWN enumeration member
PDSS_VM_DISK_DATA_SPACE enumeration member
PDSS_VM_FULL_SPACE enumeration member
PDSS_VM_MISCELLANEOUS_SPACE enumeration member
PDSS_VM_RECLAIM_SPACE enumeration member
PDSS_VM_SNAPSHOTS_SPACE enumeration member
PDT_ANY_TYPE enumeration member
PDT_USE_AC97_SOUND enumeration member
PDT_USE_BOOTCAMP enumeration member
PDT_USE_BRIDGE_ETHERNET enumeration member
PDT_USE_CREATIVE_SB16_SOUND enumeration member
PDT_USE_DIRECT_ASSIGN enumeration member
PDT_USE_FILE_SYSTEM enumeration member
PDT_USE_HOST_ONLY_NETWORK enumeration member
PDT_USE_IMAGE_FILE enumeration member
PDT_USE_OTHER enumeration member
PDT_USE_OUTPUT_FILE enumeration member
PDT_USE_PARALLEL_PORT_PRINT_TO_PDF_MODE enumeration member
PDT_USE_PARALLEL_PORT_PRINTER_MODE enumeration member
PDT_USE_REAL_CDDVD enumeration member
PDT_USE_REAL_DEVICE enumeration member
PDT_USE_REAL_FLOPPY enumeration member
PDT_USE_REAL_HDD enumeration member
PDT_USE_REAL_PARALLEL_PORT enumeration member
PDT_USE_REAL_SERIAL_PORT enumeration member
PDT_USE_REAL_USB_CONTROLLER enumeration member
PDT_USE_SERIAL_PORT_SOCKET_MODE enumeration member
PDT_USE_SHARED_NETWORK enumeration member
PEF_CHECK_PRECONDITIONS_ONLY enumeration member
PET Macros
PET_ANSWER_APPEND
PET_ANSWER_APPEND macro
PET_ANSWER_BREAK
PET_ANSWER_BREAK macro
PET_ANSWER_BROWSE
PET_ANSWER_BROWSE macro
PET_ANSWER_CANCEL
PET_ANSWER_CANCEL macro
PET_ANSWER_CHANGE
PET_ANSWER_CHANGE macro
PET_ANSWER_COMMIT
PET_ANSWER_COMMIT macro
PET_ANSWER_COMPACT
PET_ANSWER_COMPACT macro
PET_ANSWER_CONTINUE
PET_ANSWER_CONTINUE macro
PET_ANSWER_COPIED
PET_ANSWER_COPIED macro
PET_ANSWER_CREATE
PET_ANSWER_CREATE macro
PET_ANSWER_CREATE_NEW
PET_ANSWER_CREATE_NEW macro
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_DISCONNECT_ANYWAY macro
PET_ANSWER_DONT_CHANGE
PET_ANSWER_DONT_CHANGE macro
PET_ANSWER_LATER
PET_ANSWER_LATER macro
PET_ANSWER_MOVED
PET_ANSWER_MOVED macro
PET_ANSWER_NO
PET_ANSWER_NO macro
PET_ANSWER_OK
PET_ANSWER_OK macro
PET_ANSWER_OVERIDE
PET_ANSWER_OVERIDE macro
PET_ANSWER_REPLACE
PET_ANSWER_REPLACE macro
PET_ANSWER_RESTART
PET_ANSWER_RESTART macro
PET_ANSWER_RESTART_NOW
PET_ANSWER_RESTART_NOW macro
PET_ANSWER_RESTORE
PET_ANSWER_RESTORE macro
PET_ANSWER_RESUME
PET_ANSWER_RESUME macro
PET_ANSWER_RETRY
PET_ANSWER_RETRY macro
PET_ANSWER_REVERT
PET_ANSWER_REVERT macro
PET_ANSWER_SET_RECOMMENDED
PET_ANSWER_SET_RECOMMENDED macro
PET_ANSWER_SHUTDOWN
PET_ANSWER_SHUTDOWN macro
PET_ANSWER_SKIP
PET_ANSWER_SKIP macro
PET_ANSWER_STARTVM
PET_ANSWER_STARTVM macro
PET_ANSWER_STOP
PET_ANSWER_STOP macro
PET_ANSWER_STOP_AND_RESTORE
PET_ANSWER_STOP_AND_RESTORE macro
PET_ANSWER_SUSPEND
PET_ANSWER_SUSPEND macro
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_SUSPEND_ANYWAY macro
PET_ANSWER_USE_CURRENT
PET_ANSWER_USE_CURRENT macro
PET_ANSWER_USE_MAX_ALLOWED
PET_ANSWER_USE_MAX_ALLOWED macro
PET_ANSWER_YES
PET_ANSWER_YES macro
PET_DESKCTL_ACCEPT_CLIENTS enumeration member
PET_DESKCTL_ATTACH enumeration member
PET_DESKCTL_ATTACH_FIN enumeration member
PET_DESKCTL_CONFIG enumeration member
PET_DESKCTL_CONFIG_QUERY enumeration member
PET_DESKCTL_LOCAL_AUTH enumeration member
PET_DESKCTL_LOCAL_AUTH_ANSWER enumeration member
PET_DESKCTL_LOCAL_AUTH_FIN enumeration member
PET_DESKCTL_LOCAL_AUTH_QUEST enumeration member
PET_DESKCTL_REJECT_CLIENTS enumeration member
PET_DESKCTL_SEND_SAS enumeration member
PET_DESKCTL_SESSION_AUTH enumeration member
PET_DESKCTL_SESSION_AUTH_FIN enumeration member
PET_DESKCTL_SHARES_ENUMERATE enumeration member
PET_DESKCTL_SHARES_SHARE enumeration member
PET_DESKCTL_SHARES_UNSHARE enumeration member
PET_DESKCTL_STATUS_CHANGE enumeration member
PET_DSP_COHERENCE_FAKE_STUB_NOTIFICATION enumeration member
PET_DSP_EVT_ANSWER_TO_VM_WAS_DONE enumeration member
PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_FINISHED enumeration member
PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_STARTED enumeration member
PET_DSP_EVT_APPLIANCE_DOWNLOAD_FINISHED enumeration member
PET_DSP_EVT_APPLIANCE_DOWNLOAD_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_APPLIANCE_REGISTER_VM_FINISHED enumeration member
PET_DSP_EVT_APPLIANCE_REGISTER_VM_STARTED enumeration member
PET_DSP_EVT_BACKUP_CANCELLED enumeration member
PET_DSP_EVT_BACKUP_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_BACKUP_STARTED enumeration member
PET_DSP_EVT_CEP_WRITE_STRING enumeration member
PET_DSP_EVT_CLIENT_CONNECTED enumeration member
PET_DSP_EVT_CLIENT_DISCONNECTED enumeration member
PET_DSP_EVT_CLIENT_REJECTED enumeration member
PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_FINISHED enumeration member
PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_STARTED enumeration member
PET_DSP_EVT_COMMON_PREFS_CHANGED enumeration member
PET_DSP_EVT_CONNECTED_TO_PROXY enumeration member
PET_DSP_EVT_CONNECTING_TO_PROXY enumeration member
PET_DSP_EVT_CONNECTION_CLIENT_INFO_WAS_SET enumeration member
PET_DSP_EVT_CONNECTION_WAS_CLOSED enumeration member
PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_FINISHED enumeration member
PET_DSP_EVT_CONVERT_THIRD_PARTY_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_CREATE_BACKUP_FINISHED enumeration member
PET_DSP_EVT_DIR_STATE_CHANGED enumeration member
PET_DSP_EVT_DISCONNECTED_FROM_PROXY enumeration member
PET_DSP_EVT_DISK_RESIZE_FINISHED enumeration member
PET_DSP_EVT_DISK_RESIZE_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_DISK_RESIZE_STARTED enumeration member
PET_DSP_EVT_DISP_CONNECTION_CLOSED enumeration member
PET_DSP_EVT_DISP_SHUTDOWN enumeration member
PET_DSP_EVT_ENCRYPTED_VM_NEED_AUTH_AGAIN enumeration member
PET_DSP_EVT_ENCRYPTED_VM_PASSWORD_CHANGED enumeration member
PET_DSP_EVT_ERROR_MESSAGE enumeration member
PET_DSP_EVT_FOUND_LOST_VM_CONFIG enumeration member
PET_DSP_EVT_HAS_EVENT enumeration member
PET_DSP_EVT_HOST_CLEANUP enumeration member
PET_DSP_EVT_HOST_STATISTICS_UPDATED enumeration member
PET_DSP_EVT_HTTP_PROXY_AUTH_REQUIRED enumeration member
PET_DSP_EVT_HW_CONFIG_CHANGED enumeration member
PET_DSP_EVT_JOB_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_LICENSE_CHANGED enumeration member
PET_DSP_EVT_LICENSE_WAS_DEACTIVATED enumeration member
PET_DSP_EVT_OP_ACCEPTED enumeration member
PET_DSP_EVT_OP_REJECTED enumeration member
PET_DSP_EVT_OP_RESULT enumeration member
PET_DSP_EVT_PERFSTATS enumeration member
PET_DSP_EVT_REBOOT_HOST enumeration member
PET_DSP_EVT_REBOOT_HOST_MANUAL_TO_INIT_VTD_DEVICES enumeration member
PET_DSP_EVT_RECONFIG_VM_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_RECONNECT enumeration member
PET_DSP_EVT_REMOVE_BACKUP_FINISHED enumeration member
PET_DSP_EVT_RESTORE_BACKUP_FINISHED enumeration member
PET_DSP_EVT_RESTORE_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_SMC_CANCEL_USER_COMMAND enumeration member
PET_DSP_EVT_SMC_DISPATCHER_SHUTDOWN enumeration member
PET_DSP_EVT_SMC_USER_FORCE_DISCONNECTED enumeration member
PET_DSP_EVT_TIME_MACHINE_BACKUP_IS_OVER enumeration member
PET_DSP_EVT_USER_PROFILE_CHANGED enumeration member
PET_DSP_EVT_VM_ABORTED enumeration member
PET_DSP_EVT_VM_ABOUT_TO_RESET enumeration member
PET_DSP_EVT_VM_ABOUT_TO_START_DEINIT enumeration member
PET_DSP_EVT_VM_ABOUT_TO_START_INIT enumeration member
PET_DSP_EVT_VM_ADDED enumeration member
PET_DSP_EVT_VM_ADDITION_STATE_CHANGED enumeration member
PET_DSP_EVT_VM_COMPACT_FINISHED enumeration member
PET_DSP_EVT_VM_COMPACT_PROCESSING enumeration member
PET_DSP_EVT_VM_COMPRESSOR_CONTINUED enumeration member
PET_DSP_EVT_VM_COMPRESSOR_FINISHED enumeration member
PET_DSP_EVT_VM_CONFIG_APPLIED enumeration member
PET_DSP_EVT_VM_CONFIG_APPLY_FINISHED enumeration member
PET_DSP_EVT_VM_CONFIG_CHANGED enumeration member
PET_DSP_EVT_VM_CONTINUED enumeration member
PET_DSP_EVT_VM_CONTINUED_BY_HOST_WAKEUP enumeration member
PET_DSP_EVT_VM_CREATED enumeration member
PET_DSP_EVT_VM_DECRYPT_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_VM_DELETED enumeration member
PET_DSP_EVT_VM_DELETING_STATE enumeration member
PET_DSP_EVT_VM_DEV_STATE_CHANGED enumeration member
PET_DSP_EVT_VM_ENCRYPT_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_VM_FROZEN enumeration member
PET_DSP_EVT_VM_IO_CLIENT_STATISTICTS enumeration member
PET_DSP_EVT_VM_LOW_HOST_MEMORY enumeration member
PET_DSP_EVT_VM_MAC_OS_VER enumeration member
PET_DSP_EVT_VM_MEMORY_SWAPPING_FINISHED enumeration member
PET_DSP_EVT_VM_MEMORY_SWAPPING_STARTED enumeration member
PET_DSP_EVT_VM_MESSAGE enumeration member
PET_DSP_EVT_VM_MIGRATE_CANCELLED enumeration member
PET_DSP_EVT_VM_MIGRATE_CANCELLED_DISP enumeration member
PET_DSP_EVT_VM_MIGRATE_FINISHED enumeration member
PET_DSP_EVT_VM_MIGRATE_FINISHED_DISP enumeration member
PET_DSP_EVT_VM_MIGRATE_PROGRESS_CHANGED enumeration member
PET_DSP_EVT_VM_MIGRATE_STARTED enumeration member
PET_DSP_EVT_VM_MIGRATE_WAIT_REMOUNT enumeration member
PET_DSP_EVT_VM_NET_RECONNECTED enumeration member
PET_DSP_EVT_VM_PAUSED enumeration member
PET_DSP_EVT_VM_PAUSED_BY_HOST_SLEEP enumeration member
PET_DSP_EVT_VM_PERFSTATS enumeration member
PET_DSP_EVT_VM_PIS_NOTIFICATION_ASK_TO_INSTALL enumeration member
PET_DSP_EVT_VM_PROBLEM_REPORT_CREATED enumeration member
PET_DSP_EVT_VM_QUESTION enumeration member
PET_DSP_EVT_VM_REMOTE_DEV_READY_TO_START enumeration member
PET_DSP_EVT_VM_RESETED enumeration member
PET_DSP_EVT_VM_RESTORED enumeration member
PET_DSP_EVT_VM_RESTORING enumeration member
PET_DSP_EVT_VM_RESUMED enumeration member
PET_DSP_EVT_VM_RESUMING enumeration member
PET_DSP_EVT_VM_SECURITY_CHANGED enumeration member
PET_DSP_EVT_VM_SET_HOST_TIME enumeration member
PET_DSP_EVT_VM_SNAPSHOTED enumeration member
PET_DSP_EVT_VM_SNAPSHOTING enumeration member
PET_DSP_EVT_VM_SNAPSHOTS_TREE_CHANGED enumeration member
PET_DSP_EVT_VM_SOFTWARE_INSTALLED enumeration member
PET_DSP_EVT_VM_START_IO_FLOW enumeration member
PET_DSP_EVT_VM_STARTED enumeration member
PET_DSP_EVT_VM_STATE_CHANGED enumeration member
PET_DSP_EVT_VM_STATE_DELETED enumeration member
PET_DSP_EVT_VM_STATERESTORED enumeration member
PET_DSP_EVT_VM_STATESAVED enumeration member
PET_DSP_EVT_VM_STATISTICS_UPDATED enumeration member
PET_DSP_EVT_VM_STOPPED enumeration member
PET_DSP_EVT_VM_SUSPENDED enumeration member
PET_DSP_EVT_VM_SUSPENDING enumeration member
PET_DSP_EVT_VM_TOOLS_STATE_CHANGED enumeration member
PET_DSP_EVT_VM_UNFROZEN enumeration member
PET_DSP_EVT_VM_UNREGISTERED enumeration member
PET_DSP_EVT_VM_UPGRADE_COMPLETED enumeration member
PET_DSP_EVT_VM_UPGRADE_INIT enumeration member
PET_DSP_EVT_VM_UPGRADE_INIT_PHY enumeration member
PET_DSP_EVT_VM_UPGRADE_INIT_TIMEOUT enumeration member
PET_DSP_EVT_VM_UPGRADE_INIT_VMW enumeration member
PET_DSP_EVT_VM_UPGRADE_STAGE_1 enumeration member
PET_DSP_EVT_VM_UPGRADE_STAGE_2 enumeration member
PET_DSP_EVT_VM_UPGRADE_STAGE_3 enumeration member
PET_DSP_EVT_VM_UPGRADE_UNKNOWN_ERROR enumeration member
PET_DSP_EVT_VM_VIRTUAL_DEVICES_STATE_CHANGED enumeration member
PET_DSP_EVT_VM_WAS_DECRYPTED enumeration member
PET_DSP_EVT_VM_WAS_ENCRYPTED enumeration member
PET_DSP_EVT_VM_WAS_PROTECTED enumeration member
PET_DSP_EVT_VM_WAS_UNPROTECTED enumeration member
PET_DSP_EVT_WARNING_MESSAGE enumeration member
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM macro
PET_IO_ATTACH_RESPONSE enumeration member
PET_IO_AUDIO_OUTPUT_DATA enumeration member
PET_IO_AUDIO_OUTPUT_ENCODING_SET enumeration member
PET_IO_AUDIO_OUTPUT_STOP enumeration member
PET_IO_AUDIO_OUTPUT_STREAM_STARTED enumeration member
PET_IO_AUTH_RESPONSE enumeration member
PET_IO_AVAILABLE_DISPLAYS enumeration member
PET_IO_BEFORE_SCREEN_SIZE enumeration member
PET_IO_CLI_ATTACH_TO_VM enumeration member
PET_IO_CLI_AUDIO_PLAYOUT_STREAM_START enumeration member
PET_IO_CLI_AUDIO_PLAYOUT_STREAM_STOP enumeration member
PET_IO_CLI_AUDIO_RECORDING_STREAM_START enumeration member
PET_IO_CLI_AUDIO_RECORDING_STREAM_STOP enumeration member
PET_IO_CLI_AUTHENTICATE_EXEC_SESSION enumeration member
PET_IO_CLI_AUTHENTICATE_SESSION enumeration member
PET_IO_CLI_CVSRC_CONNECT enumeration member
PET_IO_CLI_CVSRC_DISCONNECT enumeration member
PET_IO_CLI_DPI_SCREEN_SIZE enumeration member
PET_IO_CLI_ENCODING_REQUEST enumeration member
PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS enumeration member
PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS_RESPONSE enumeration member
PET_IO_CLI_GRACEFUL_SHUTDOWN enumeration member
PET_IO_CLI_KEYBOARD_KEY enumeration member
PET_IO_CLI_KEYBOARD_SCANCODE enumeration member
PET_IO_CLI_MOUSE_MOVE enumeration member
PET_IO_CLI_MOUSE_NEED_CURSOR enumeration member
PET_IO_CLI_MOUSE_SETPOS enumeration member
PET_IO_CLI_REMOTE_COMMAND enumeration member
PET_IO_CLI_SCREEN_CAPTURE_BUFFER enumeration member
PET_IO_CLI_SCREEN_SET_SURFACE enumeration member
PET_IO_CLI_SCREEN_SIZE enumeration member
PET_IO_CLI_SCREEN_WATCH_UPDATES enumeration member
PET_IO_CLI_SET_AUDIO_SWITCH_SETTINGS enumeration member
PET_IO_CLI_SSO_LOCKED enumeration member
PET_IO_CLI_SSO_SET_CREDENTIALS enumeration member
PET_IO_CLI_SSO_SET_CREDENTIALS_ASYNC enumeration member
PET_IO_CLI_SSO_UNLOCKED enumeration member
PET_IO_CLI_SWITCH_SLIDING_MOUSE enumeration member
PET_IO_CLI_TOOLS_ADJUST_WORKING_AREA enumeration member
PET_IO_CLI_TOOLS_CLIPBOARD_DATA enumeration member
PET_IO_CLI_TOOLS_EMPTY_RECYCLE_BIN enumeration member
PET_IO_CLI_TOOLS_GENERAL_COMMAND enumeration member
PET_IO_CLI_TOOLS_MOVE_TASKBAR enumeration member
PET_IO_CLI_TOOLS_NOTIFY_COHERENCE_STATE enumeration member
PET_IO_CLI_TOOLS_OPEN_FILE_BROWSER enumeration member
PET_IO_CLI_TOOLS_SET_INDENTS enumeration member
PET_IO_CLI_TOOLS_SET_TASKBAR_VISIBILITY enumeration member
PET_IO_CLI_TOOLS_SHOW_RECYCLE_BIN enumeration member
PET_IO_CLI_TOOLS_SIA_DATA enumeration member
PET_IO_CLI_TOOLS_TIS_QUERY enumeration member
PET_IO_CLI_TOOLS_TOGGLE_DESKTOP enumeration member
PET_IO_CLI_TOOLS_UIEMU enumeration member
PET_IO_CLI_TOOLS_UTILITY_COMMAND enumeration member
PET_IO_CLI_TOOLS_VMCTG_COMMAND enumeration member
PET_IO_CLIENT_PROCESSED_ALL_DESCS_DATA enumeration member
PET_IO_CVSRC_CLOSE enumeration member
PET_IO_CVSRC_OPEN enumeration member
PET_IO_DEVICE_IS_IN_USE enumeration member
PET_IO_DISCONNECT_WITH_REASON enumeration member
PET_IO_DISPLAY_BEFORE_SCREEN_SIZE enumeration member
PET_IO_DISPLAY_GAMMA_CHANGED enumeration member
PET_IO_DISPLAY_PALETTE_CHANGED enumeration member
PET_IO_DISPLAY_RESOLUTION_SET enumeration member
PET_IO_DISPLAY_SCREEN_CAPTURED enumeration member
PET_IO_DISPLAY_SCREEN_SIZE enumeration member
PET_IO_DYNRES_TOOL_STATUS enumeration member
PET_IO_ENCODING_RESPONSE enumeration member
PET_IO_EVT_DISCONNECT_WITH_REASON enumeration member
PET_IO_FIN_TO_TRANSMIT_STDOUT_STDERR enumeration member
PET_IO_IOSERVICE_CHANNELS_PROTOCOL enumeration member
PET_IO_KEYBOARD_LEDS enumeration member
PET_IO_MEMORY_INFO enumeration member
PET_IO_MOUSE_CURSOR_CHANGED enumeration member
PET_IO_MOUSE_CURSOR_HID enumeration member
PET_IO_MOUSE_CURSOR_MOVED enumeration member
PET_IO_MOUSE_CURSOR_SET enumeration member
PET_IO_PTM_PROTOCOL enumeration member
PET_IO_READY_TO_ACCEPT_STDIN_PKGS enumeration member
PET_IO_READY_TO_ACCEPT_STDOUT_STDERR_PKGS enumeration member
PET_IO_REMOTE_COMMAND enumeration member
PET_IO_SCREEN_CAPTURED enumeration member
PET_IO_SCREEN_CAPTURED_BUFFER enumeration member
PET_IO_SCREEN_SIZE enumeration member
PET_IO_SCREEN_SURFACE_ATTACHED enumeration member
PET_IO_SCREEN_SURFACE_DETACHED enumeration member
PET_IO_SCREEN_UPDATED enumeration member
PET_IO_SLIDING_MOUSE_FLAG enumeration member
PET_IO_SSO_GET_CREDENTIALS enumeration member
PET_IO_STATE enumeration member
PET_IO_STDERR_PORTION enumeration member
PET_IO_STDIN_PORTION enumeration member
PET_IO_STDIN_WAS_CLOSED enumeration member
PET_IO_STDOUT_PORTION enumeration member
PET_IO_SWITCH_VESA_MODE enumeration member
PET_IO_TOOLS_CLIPBOARD_DATA enumeration member
PET_IO_TOOLS_DESKTOP_UTILITY_STATE enumeration member
PET_IO_TOOLS_DRAGDROP_DATA enumeration member
PET_IO_TOOLS_GENERAL_COMMAND enumeration member
PET_IO_TOOLS_LANGUAGE_HOTKEY_CHANGED enumeration member
PET_IO_TOOLS_SIA_DATA enumeration member
PET_IO_TOOLS_TIS_QUERY enumeration member
PET_IO_TOOLS_TIS_SUBSCRIBE enumeration member
PET_IO_TOOLS_TIS_UNSUBSCRIBE enumeration member
PET_IO_TOOLS_UTILITY_COMMAND enumeration member
PET_IO_TOOLS_VM_SHUTDOWN enumeration member
PET_IO_TOOLS_VMCTG_COMMAND enumeration member
PET_IO_TTY_SETTINGS_PROVIDED enumeration member
PET_IO_TTY_SETTINGS_REQUIRED enumeration member
PET_IO_UIEMU_CARET_INFO enumeration member
PET_IO_UIEMU_ELEMENT_AT_POS enumeration member
PET_IT_COMPACTING_START enumeration member
PET_IT_CONVERT_TO_CURRENT_START enumeration member
PET_IT_CONVERT_TO_EXTEND_START enumeration member
PET_IT_CONVERT_TO_OLD_START enumeration member
PET_IT_DECREASING_START enumeration member
PET_IT_FIX_CONSISTENCY_START enumeration member
PET_IT_GET_RESIZE_INFORMATION_START enumeration member
PET_IT_INCREASE_LAST_VOLUME_START enumeration member
PET_IT_MAKE_EXPANDING_START enumeration member
PET_IT_MAKE_NON_SPLIT_START enumeration member
PET_IT_MAKE_PLAIN_START enumeration member
PET_IT_MAKE_SPLIT_START enumeration member
PET_IT_MERGE_SNAPSHOTS_START enumeration member
PET_IT_RECONFIG_BOOTCAMP_START enumeration member
PET_IT_RECONFIG_START enumeration member
PET_IT_RESIZING_START enumeration member
PET_IT_VALIDATE_BOOTCAMP_START enumeration member
PET_JOB_COMMIT_UNFINISHED_DISK_OP_PROGRESS_CHANGED enumeration member
PET_JOB_CREATE_SNAPSHOT_PROGRESS_CHANGED enumeration member
PET_JOB_DELETE_SNAPSHOT_PROGRESS_CHANGED enumeration member
PET_JOB_DELETE_VM_PROGRESS_CHANGED enumeration member
PET_JOB_FILE_COPY_PROGRESS_CHANGED enumeration member
PET_JOB_HDD_CREATE_PROGRESS_CHANGED enumeration member
PET_JOB_RESUME_PROGRESS_CHANGED enumeration member
PET_JOB_STAGE_PROGRESS_CHANGED enumeration member
PET_JOB_SUSPEND_PROGRESS_CHANGED enumeration member
PET_JOB_SWITCH_TO_SNAPSHOT_PROGRESS_CHANGED enumeration member
PET_PTM_EVT_OBJECT_CREATED enumeration member
PET_PTM_EVT_OBJECT_DELETED enumeration member
PET_PTM_EVT_PROPERTY_CHANGED enumeration member
PET_PTM_EVT_RPC_COMPLETED enumeration member
PET_PTM_EVT_SUBSCRIBED enumeration member
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK macro
PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION
PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION macro
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM macro
PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE macro
PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE macro
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE macro
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED macro
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_OPERATION macro
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION macro
PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION
PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION macro
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION macro
PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION
PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION macro
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE macro
PET_QUESTION_COMMON_HDD_ERROR
PET_QUESTION_COMMON_HDD_ERROR macro
PET_QUESTION_COMPACT_VM_DISKS
PET_QUESTION_COMPACT_VM_DISKS macro
PET_QUESTION_CONTINUE_IF_HVT_DISABLED
PET_QUESTION_CONTINUE_IF_HVT_DISABLED macro
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_NEW_MAC_ADDRESS macro
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE macro
PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART
PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART macro
PET_QUESTION_DELAYED_COMPACT_VM_DISKS
PET_QUESTION_DELAYED_COMPACT_VM_DISKS macro
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR macro
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR macro
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG macro
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE macro
PET_QUESTION_FORCE_COMPACT_VM_DISKS
PET_QUESTION_FORCE_COMPACT_VM_DISKS macro
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK macro
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG macro
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_OLD_CONFIG_CONVERTION macro
PET_QUESTION_ON_QUERY_END_SESSION
PET_QUESTION_ON_QUERY_END_SESSION macro
PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED
PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED macro
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE macro
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM macro
PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT
PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT macro
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_USED_VM macro
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_REGISTER_VM_TEMPLATE macro
PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT
PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT macro
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP macro
PET_QUESTION_SAMPLE_1
PET_QUESTION_SAMPLE_1 macro
PET_QUESTION_SAMPLE_2
PET_QUESTION_SAMPLE_2 macro
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE macro
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU
PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU macro
PET_QUESTION_STOP_VM_TO_COMPACT
PET_QUESTION_STOP_VM_TO_COMPACT macro
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE macro
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU
PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU macro
PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS
PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS macro
PET_QUESTION_TXT_ERROR
PET_QUESTION_TXT_ERROR macro
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_UNDO_DISKS_MODE macro
PET_QUESTION_VM_COPY_OR_MOVE
PET_QUESTION_VM_COPY_OR_MOVE macro
PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS
PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS macro
PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS
PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS macro
PET_VIDEO_CAPTURE_GEOMETRY enumeration member
PET_VIDEO_DATA_CHANNEL_CTL enumeration member
PET_VIDEO_RECEIVER_CLOSED enumeration member
PET_VIDEO_RECEIVER_CONNECTION_STATE enumeration member
PET_VIDEO_RECEIVER_FORMAT enumeration member
PET_VIDEO_RECEIVER_FRAME enumeration member
PET_VIDEO_STREAM_ACK_FRAME enumeration member
PET_VIDEO_STREAM_CLOSE enumeration member
PET_VIDEO_STREAM_CLOSED enumeration member
PET_VIDEO_STREAM_DATA enumeration member
PET_VIDEO_STREAM_FORMAT enumeration member
PET_VIDEO_STREAM_OPEN enumeration member
PET_VIDEO_STREAM_START enumeration member
PET_VIDEO_STREAM_STOP enumeration member
PET_VM_DEFAULT_SOUND_RECONNECTED enumeration member
PET_VM_EVT_MOUNT enumeration member
PET_VM_EVT_REQUEST_FILE_OPEN enumeration member
PET_VM_EVT_TIS_BACKUP_WRITE enumeration member
PET_VM_EVT_UNMOUNT enumeration member
PET_VM_EVT_UNMOUNT_DVD_MEDIA enumeration member
PET_VM_EVT_UNMOUNT_USB_MEDIA enumeration member
PET_VM_EVT_VM_CONFIG_CHANGED enumeration member
PET_VM_INF_END_BUNCH_COPYING enumeration member
PET_VM_INF_END_FILE_COPYING enumeration member
PET_VM_INF_START_BUNCH_COPYING enumeration member
PET_VM_INF_START_FILE_COPYING enumeration member
PET_VM_INF_UNINITIALIZED_EVENT_CODE enumeration member
PET_VM_READY_TO_BOOT enumeration member
PET_VM_READY_TO_PRINT enumeration member
PEVF_WAIT_FOR_APPLY enumeration member
PEVT_NATIVE_VM enumeration member
PEVT_VM_UNKNOWN enumeration member
PEVT_VMWARE enumeration member
PFD_ALL enumeration member
PFD_BINARY enumeration member
PFD_BOOLEAN enumeration member
PFD_CDATA enumeration member
PFD_ENTITY enumeration member
PFD_ENUMERATION enumeration member
PFD_INCOMING enumeration member
PFD_INT32 enumeration member
PFD_INT64 enumeration member
PFD_OUTGOING enumeration member
PFD_STDERR enumeration member
PFD_STDIN enumeration member
PFD_STDOUT enumeration member
PFD_STRING enumeration member
PFD_UINT32 enumeration member
PFD_UINT64 enumeration member
PFD_UNKNOWN enumeration member
PFP_ACCEPT enumeration member
PFP_DENY enumeration member
PFS_UNIX_LIKE_FS enumeration member
PFS_WINDOWS_LIKE_FS enumeration member
PFSM_AUTOSTART_VM_AS_OWNER enumeration member
PFSM_CPU_HOTPLUG_SUPPORT enumeration member
PFSM_DEFAULT_PLAINDISK_ALLOWED enumeration member
PFSM_DEFAULT_SATA_ALLOWED enumeration member
PFSM_DESKTOP_CONTROL_SUPPORT enumeration member
PFSM_DISK_IO_LIMITS enumeration member
PFSM_FINE_CPU_LIMITS enumeration member
PFSM_IPV6_SUPPORT enumeration member
PFSM_NIC_CHANGE_ALLOWED enumeration member
PFSM_NO_SHARED_NETWORKING enumeration member
PFSM_PAX_FEATURE_MATRIX_SUPPORT enumeration member
PFSM_PAX_FEATURE_RANGE_END enumeration member
PFSM_PAX_FEATURE_RANGE_START enumeration member
PFSM_PSBM5 enumeration member
PFSM_RAM_HOTPLUG_SUPPORT enumeration member
PFSM_ROUTED_NETWORKING enumeration member
PFSM_SATA_HOTPLUG_SUPPORT enumeration member
PFSM_UNKNOWN_FEATURE enumeration member
PFSM_USB_PRINTER_SUPPORT enumeration member
PFSM_VM_CONFIG_MERGE_SUPPORT enumeration member
PGD_PCI_DISPLAY enumeration member
PGD_PCI_NETWORK enumeration member
PGD_PCI_OTHER enumeration member
PGD_PCI_SOUND enumeration member
PGD_UNKNOWN enumeration member
PGD_WINDOWS_10_32 enumeration member
PGD_WINDOWS_10_64 enumeration member
PGD_WINDOWS_VISTA enumeration member
PGD_WINDOWS_VISTA_32 enumeration member
PGD_WINDOWS_VISTA_64 enumeration member
PGD_WINDOWS_XP enumeration member
PGD_WINDOWS_XP_32 enumeration member
PGD_WINDOWS_XP_64 enumeration member
PGS_CONNECTED_TO_HOST enumeration member
PGS_CONNECTED_TO_VM enumeration member
PGS_CONNECTING_TO_VM enumeration member
PGS_NON_CONTROLLED_USB enumeration member
PGS_RESERVED enumeration member
PGST_CAPABILITY_HIBERNATE enumeration member
PGST_CAPABILITY_REBOOT enumeration member
PGST_CAPABILITY_SHUTDOWN enumeration member
PGST_CAPABILITY_SUSPEND enumeration member
PGST_FULL_SIZE_SCREENSHOTS enumeration member
PGST_WITHOUT_SCREENSHOTS enumeration member
PGVC_SEARCH_BY_NAME enumeration member
PGVC_SEARCH_BY_UUID enumeration member
PGVLF_GET_ONLY_CT enumeration member
PGVLF_GET_ONLY_IDENTITY_INFO enumeration member
PGVLF_GET_ONLY_VM enumeration member
PGVLF_GET_STATE_INFO enumeration member
PHD_EXPANDING_HARD_DISK enumeration member
PHD_PLAIN_HARD_DISK enumeration member
PHI_REAL_NET_ADAPTER enumeration member
PHI_VIRTUAL_NET_ADAPTER enumeration member
PHO_LIN enumeration member
PHO_MAC enumeration member
PHO_UNKNOWN enumeration member
PHO_WIN enumeration member
PHT_ACCESS_RIGHTS
PHT_ACCESS_RIGHTS enumeration member
PHT_APPLIANCE_CONFIG enumeration member
PHT_BACKUP_RESULT
PHT_BACKUP_RESULT enumeration member
PHT_BOOT_DEVICE
PHT_BOOT_DEVICE enumeration member
PHT_CPU_FEATURES enumeration member
PHT_CT_TEMPLATE
PHT_CT_TEMPLATE enumeration member
PHT_CVSRC
PHT_CVSRC enumeration member
PHT_DESKTOP_CONTROL
PHT_DESKTOP_CONTROL enumeration member
PHT_DISP_CONFIG
PHT_DISP_CONFIG enumeration member
PHT_DISP_NET_ADAPTER enumeration member
PHT_ERROR enumeration member
PHT_EVENT
PHT_EVENT enumeration member
PHT_EVENT_PARAMETER
PHT_EVENT_PARAMETER enumeration member
PHT_FIREWALL_RULE
PHT_FIREWALL_RULE enumeration member
PHT_FOUND_VM_INFO
PHT_FOUND_VM_INFO enumeration member
PHT_GUEST_OSES_MATRIX
PHT_GUEST_OSES_MATRIX enumeration member
PHT_HANDLES_LIST
PHT_HANDLES_LIST enumeration member
PHT_HW_GENERIC_DEVICE
PHT_HW_GENERIC_DEVICE enumeration member
PHT_HW_GENERIC_PCI_DEVICE
PHT_HW_GENERIC_PCI_DEVICE enumeration member
PHT_HW_HARD_DISK
PHT_HW_HARD_DISK enumeration member
PHT_HW_HARD_DISK_PARTITION
PHT_HW_HARD_DISK_PARTITION enumeration member
PHT_HW_NET_ADAPTER
PHT_HW_NET_ADAPTER enumeration member
PHT_IPPRIV_NET
PHT_IPPRIV_NET enumeration member
PHT_ISCSI_LUN enumeration member
PHT_JOB
PHT_JOB enumeration member
PHT_LAST enumeration member
PHT_LICENSE
PHT_LICENSE enumeration member
PHT_LOGIN_RESPONSE
PHT_LOGIN_RESPONSE enumeration member
PHT_NET_SERVICE_STATUS
PHT_NET_SERVICE_STATUS enumeration member
PHT_NETWORK_CLASS
PHT_NETWORK_CLASS enumeration member
PHT_NETWORK_RATE
PHT_NETWORK_RATE enumeration member
PHT_NETWORK_SHAPING
PHT_NETWORK_SHAPING enumeration member
PHT_NETWORK_SHAPING_BANDWIDTH
PHT_NETWORK_SHAPING_BANDWIDTH enumeration member
PHT_NETWORK_SHAPING_CONFIG
PHT_NETWORK_SHAPING_CONFIG enumeration member
PHT_OFFLINE_SERVICE
PHT_OFFLINE_SERVICE enumeration member
PHT_OPAQUE_TYPE_LIST
PHT_OPAQUE_TYPE_LIST enumeration member
PHT_PLUGIN_INFO
PHT_PLUGIN_INFO enumeration member
PHT_PORT_FORWARDING
PHT_PORT_FORWARDING enumeration member
PHT_PROBLEM_REPORT
PHT_PROBLEM_REPORT enumeration member
PHT_REMOTE_FILESYSTEM_ENTRY
PHT_REMOTE_FILESYSTEM_ENTRY enumeration member
PHT_REMOTE_FILESYSTEM_INFO
PHT_REMOTE_FILESYSTEM_INFO enumeration member
PHT_REMOTEDEV_CMD enumeration member
PHT_RESULT
PHT_RESULT enumeration member
PHT_RUNNING_TASK
PHT_RUNNING_TASK enumeration member
PHT_SCREEN_RESOLUTION
PHT_SCREEN_RESOLUTION enumeration member
PHT_SERVER
PHT_SERVER enumeration member
PHT_SERVER_CONFIG
PHT_SERVER_CONFIG enumeration member
PHT_SERVER_INFO
PHT_SERVER_INFO enumeration member
PHT_SESSION_INFO enumeration member
PHT_SHARE
PHT_SHARE enumeration member
PHT_STRINGS_LIST
PHT_STRINGS_LIST enumeration member
PHT_SYSTEM_STATISTICS
PHT_SYSTEM_STATISTICS enumeration member
PHT_SYSTEM_STATISTICS_CPU
PHT_SYSTEM_STATISTICS_CPU enumeration member
PHT_SYSTEM_STATISTICS_DISK
PHT_SYSTEM_STATISTICS_DISK enumeration member
PHT_SYSTEM_STATISTICS_DISK_PARTITION
PHT_SYSTEM_STATISTICS_DISK_PARTITION enumeration member
PHT_SYSTEM_STATISTICS_IFACE
PHT_SYSTEM_STATISTICS_IFACE enumeration member
PHT_SYSTEM_STATISTICS_PROCESS
PHT_SYSTEM_STATISTICS_PROCESS enumeration member
PHT_SYSTEM_STATISTICS_USER_SESSION
PHT_SYSTEM_STATISTICS_USER_SESSION enumeration member
PHT_SYSTEM_STATISTICS_VM_DATA enumeration member
PHT_TIS_EMITTER enumeration member
PHT_TIS_RECORD enumeration member
PHT_TOOL enumeration member
PHT_UIEMU_INPUT
PHT_UIEMU_INPUT enumeration member
PHT_USB_IDENTITY
PHT_USB_IDENTITY enumeration member
PHT_USER_INFO
PHT_USER_INFO enumeration member
PHT_USER_PROFILE
PHT_USER_PROFILE enumeration member
PHT_VIDEO_RECEIVER enumeration member
PHT_VIRTUAL_DEV_DISPLAY enumeration member
PHT_VIRTUAL_DEV_FLOPPY
PHT_VIRTUAL_DEV_FLOPPY enumeration member
PHT_VIRTUAL_DEV_GENERIC_PCI enumeration member
PHT_VIRTUAL_DEV_GENERIC_SCSI enumeration member
PHT_VIRTUAL_DEV_HARD_DISK
PHT_VIRTUAL_DEV_HARD_DISK enumeration member
PHT_VIRTUAL_DEV_HD_PARTITION
PHT_VIRTUAL_DEV_HD_PARTITION enumeration member
PHT_VIRTUAL_DEV_KEYBOARD enumeration member
PHT_VIRTUAL_DEV_MOUSE enumeration member
PHT_VIRTUAL_DEV_NET_ADAPTER
PHT_VIRTUAL_DEV_NET_ADAPTER enumeration member
PHT_VIRTUAL_DEV_OPTICAL_DISK
PHT_VIRTUAL_DEV_OPTICAL_DISK enumeration member
PHT_VIRTUAL_DEV_PARALLEL_PORT
PHT_VIRTUAL_DEV_PARALLEL_PORT enumeration member
PHT_VIRTUAL_DEV_SERIAL_PORT
PHT_VIRTUAL_DEV_SERIAL_PORT enumeration member
PHT_VIRTUAL_DEV_SOUND
PHT_VIRTUAL_DEV_SOUND enumeration member
PHT_VIRTUAL_DEV_USB_DEVICE
PHT_VIRTUAL_DEV_USB_DEVICE enumeration member
PHT_VIRTUAL_DISK
PHT_VIRTUAL_DISK enumeration member
PHT_VIRTUAL_MACHINE
PHT_VIRTUAL_MACHINE enumeration member
PHT_VIRTUAL_NETWORK
PHT_VIRTUAL_NETWORK enumeration member
PHT_VM_CONFIGURATION
PHT_VM_CONFIGURATION enumeration member
PHT_VM_GUEST_SESSION
PHT_VM_GUEST_SESSION enumeration member
PHT_VM_INFO
PHT_VM_INFO enumeration member
PHT_VM_TOOLS_INFO
PHT_VM_TOOLS_INFO enumeration member
PHT_VM_VIRTUAL_DEVICES_INFO enumeration member
PHY_WIFI_REAL_NET_ADAPTER enumeration member
PIAF_CANCEL enumeration member
PIAF_FORCE enumeration member
PIAF_STOP enumeration member
PIE_DISPATCHER enumeration member
PIE_IO_SERVICE enumeration member
PIE_UNKNOWN enumeration member
PIE_VIRTUAL_MACHINE enumeration member
PIE_WEB_SERVICE enumeration member
PIF_BMP enumeration member
PIF_JPG enumeration member
PIF_PNG enumeration member
PIF_RAW enumeration member
PIM_ALL_DISKS enumeration member
PIM_COMPACT_DELAYED enumeration member
PIM_IDE_0_0 enumeration member
PIM_IDE_0_1 enumeration member
PIM_IDE_1_0 enumeration member
PIM_IDE_1_1 enumeration member
PIM_IDE_MASK_OFFSET enumeration member
PIM_SATA_0_0 enumeration member
PIM_SATA_0_1 enumeration member
PIM_SATA_0_2 enumeration member
PIM_SATA_0_3 enumeration member
PIM_SATA_0_4 enumeration member
PIM_SATA_0_5 enumeration member
PIM_SATA_MASK_OFFSET enumeration member
PIM_SCSI_0_0 enumeration member
PIM_SCSI_1_0 enumeration member
PIM_SCSI_10_0 enumeration member
PIM_SCSI_11_0 enumeration member
PIM_SCSI_12_0 enumeration member
PIM_SCSI_13_0 enumeration member
PIM_SCSI_14_0 enumeration member
PIM_SCSI_15_0 enumeration member
PIM_SCSI_2_0 enumeration member
PIM_SCSI_3_0 enumeration member
PIM_SCSI_4_0 enumeration member
PIM_SCSI_5_0 enumeration member
PIM_SCSI_6_0 enumeration member
PIM_SCSI_7_0 enumeration member
PIM_SCSI_8_0 enumeration member
PIM_SCSI_9_0 enumeration member
PIM_SCSI_MASK_OFFSET enumeration member
PISCSI_STORAGE_CREATE enumeration member
PISCSI_STORAGE_EXT3 enumeration member
PISCSI_STORAGE_EXT4 enumeration member
PISCSI_STORAGE_MOUNT enumeration member
PISCSI_STORAGE_MOUNT_RDONLY enumeration member
PISCSI_STORAGE_NTFS enumeration member
PISCSI_STORAGE_REMOUNT enumeration member
PISCSI_STORAGE_REMOVE enumeration member
PIT_DOCK_ICON_LIVE_SCREEN_SHOT enumeration member
PIT_DOCK_ICON_START_MENU enumeration member
PIT_DOCK_ICON_SYSTEM enumeration member
PJOC_API_GET_USER_DATA enumeration member
PJOC_API_GET_USER_KEYS enumeration member
PJOC_API_PUT_ICON enumeration member
PJOC_API_PUT_USER_DATA enumeration member
PJOC_API_REMOVE_USER_DATA enumeration member
PJOC_API_SEND_PACKED_PROBLEM_REPORT enumeration member
PJOC_API_SEND_PROBLEM_REPORT enumeration member
PJOC_API_SUBSCRIBE_ON_REGISTRATION enumeration member
PJOC_API_VALIDATE_IN_CACHE enumeration member
PJOC_DESKTOP_CONTROL_CONNECT enumeration member
PJOC_JOB_CANCEL enumeration member
PJOC_PTM_RPC enumeration member
PJOC_REPORT_ASSEMBLY enumeration member
PJOC_SRV_ADD_IPPRIVATE_NETWORK enumeration member
PJOC_SRV_ADD_NET_ADAPTER enumeration member
PJOC_SRV_ADD_VIRTUAL_NETWORK enumeration member
PJOC_SRV_AFTER_HOST_RESUME enumeration member
PJOC_SRV_ATTACH_TO_LOST_TASK enumeration member
PJOC_SRV_CHECK_ALIVE enumeration member
PJOC_SRV_COMMON_PREFS_BEGIN_EDIT enumeration member
PJOC_SRV_COMMON_PREFS_COMMIT enumeration member
PJOC_SRV_CONFIGURE_GENERIC_PCI enumeration member
PJOC_SRV_COPY_CT_TEMPLATE enumeration member
PJOC_SRV_CREATE_UNATTENDED_CD enumeration member
PJOC_SRV_CREATE_VM_BACKUP enumeration member
PJOC_SRV_DELETE_NET_ADAPTER enumeration member
PJOC_SRV_DELETE_OFFLINE_SERVICE enumeration member
PJOC_SRV_DELETE_VIRTUAL_NETWORK enumeration member
PJOC_SRV_EXTEND_ISCSI_STORAGE enumeration member
PJOC_SRV_FS_CAN_CREATE_FILE enumeration member
PJOC_SRV_FS_CREATE_DIR enumeration member
PJOC_SRV_FS_GENERATE_ENTRY_NAME enumeration member
PJOC_SRV_FS_GET_DIR_ENTRIES enumeration member
PJOC_SRV_FS_GET_DISK_LIST enumeration member
PJOC_SRV_FS_REMOVE_ENTRY enumeration member
PJOC_SRV_FS_RENAME_ENTRY enumeration member
PJOC_SRV_GENERATE_CSR enumeration member
PJOC_SRV_GET_ALL_HOST_USERS enumeration member
PJOC_SRV_GET_BACKUP_TREE enumeration member
PJOC_SRV_GET_COMMON_PREFS enumeration member
PJOC_SRV_GET_CT_TEMPLATE_LIST enumeration member
PJOC_SRV_GET_DEFAULT_VM_CONFIG enumeration member
PJOC_SRV_GET_DISK_FREE_SPACE enumeration member
PJOC_SRV_GET_IPPRIVATE_NETWORKS_LIST enumeration member
PJOC_SRV_GET_LICENSE_INFO enumeration member
PJOC_SRV_GET_NET_SERVICE_STATUS enumeration member
PJOC_SRV_GET_NETWORK_CLASSES_LIST enumeration member
PJOC_SRV_GET_NETWORK_SHAPING_CONFIG enumeration member
PJOC_SRV_GET_OFFLINE_SERVICES_LIST enumeration member
PJOC_SRV_GET_PACKED_PROBLEM_REPORT enumeration member
PJOC_SRV_GET_PERFSTATS enumeration member
PJOC_SRV_GET_PLUGINS_LIST enumeration member
PJOC_SRV_GET_PROBLEM_REPORT enumeration member
PJOC_SRV_GET_SRV_CONFIG enumeration member
PJOC_SRV_GET_STATISTICS enumeration member
PJOC_SRV_GET_USER_INFO enumeration member
PJOC_SRV_GET_USER_INFO_LIST enumeration member
PJOC_SRV_GET_USER_PROFILE enumeration member
PJOC_SRV_GET_VIRTUAL_NETWORK_LIST enumeration member
PJOC_SRV_GET_VM_CONFIG enumeration member
PJOC_SRV_GET_VM_LIST enumeration member
PJOC_SRV_INSTALL_APPLIANCE enumeration member
PJOC_SRV_LOGIN enumeration member
PJOC_SRV_LOGIN_LOCAL enumeration member
PJOC_SRV_LOGOFF enumeration member
PJOC_SRV_LOOKUP_PARALLELS_SERVERS enumeration member
PJOC_SRV_NET_SERVICE_RESTART enumeration member
PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS enumeration member
PJOC_SRV_NET_SERVICE_START enumeration member
PJOC_SRV_NET_SERVICE_STOP enumeration member
PJOC_SRV_PREPARE_FOR_HIBERNATE enumeration member
PJOC_SRV_PROXY_GET_REGISTERED_HOSTS enumeration member
PJOC_SRV_REFRESH_PLUGINS enumeration member
PJOC_SRV_REGISTER_3RD_PARTY_VM enumeration member
PJOC_SRV_REGISTER_ISCSI_STORAGE enumeration member
PJOC_SRV_REGISTER_VM enumeration member
PJOC_SRV_REGISTER_VM_EX enumeration member
PJOC_SRV_REMOVE_CT_TEMPLATE enumeration member
PJOC_SRV_REMOVE_IPPRIVATE_NETWORK enumeration member
PJOC_SRV_REMOVE_VM_BACKUP enumeration member
PJOC_SRV_RESTART_NETWORK_SHAPING enumeration member
PJOC_SRV_RESTORE_VM_BACKUP enumeration member
PJOC_SRV_SEND_ANSWER enumeration member
PJOC_SRV_SEND_CLIENT_STATISTICS enumeration member
PJOC_SRV_SEND_PROBLEM_REPORT enumeration member
PJOC_SRV_SET_NON_INTERACTIVE_SESSION enumeration member
PJOC_SRV_SET_SESSION_CONFIRMATION_MODE enumeration member
PJOC_SRV_SHUTDOWN enumeration member
PJOC_SRV_SIGN_CERTIFICATION_REQUEST enumeration member
PJOC_SRV_START_CLUSTER_SERVICE enumeration member
PJOC_SRV_START_SEARCH_VMS enumeration member
PJOC_SRV_STOP_CLUSTER_SERVICE enumeration member
PJOC_SRV_STORE_VALUE_BY_KEY enumeration member
PJOC_SRV_SUBSCRIBE_PERFSTATS enumeration member
PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS enumeration member
PJOC_SRV_UNREGISTER_ISCSI_STORAGE enumeration member
PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS enumeration member
PJOC_SRV_UNSUBSCRIBE_PERFSTATS enumeration member
PJOC_SRV_UPDATE_IPPRIVATE_NETWORK enumeration member
PJOC_SRV_UPDATE_LICENSE enumeration member
PJOC_SRV_UPDATE_NET_ADAPTER enumeration member
PJOC_SRV_UPDATE_NETWORK_CLASSES_CONFIG enumeration member
PJOC_SRV_UPDATE_NETWORK_SHAPING_CONFIG enumeration member
PJOC_SRV_UPDATE_OFFLINE_SERVICE enumeration member
PJOC_SRV_UPDATE_SESSION_INFO enumeration member
PJOC_SRV_UPDATE_USB_ASSOC_LIST enumeration member
PJOC_SRV_UPDATE_VIRTUAL_NETWORK enumeration member
PJOC_SRV_USER_PROFILE_BEGIN_EDIT enumeration member
PJOC_SRV_USER_PROFILE_COMMIT enumeration member
PJOC_UNKNOWN enumeration member
PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB enumeration member
PJOC_VM_AUTHORISE enumeration member
PJOC_VM_BEGIN_EDIT enumeration member
PJOC_VM_CANCEL_COMPACT enumeration member
PJOC_VM_CANCEL_COMPRESSOR enumeration member
PJOC_VM_CHANGE_PASSWORD enumeration member
PJOC_VM_CHANGE_SID enumeration member
PJOC_VM_CLONE enumeration member
PJOC_VM_CMD_INTERNAL enumeration member
PJOC_VM_COMMIT enumeration member
PJOC_VM_COMPACT enumeration member
PJOC_VM_CONNECT_TO_VM enumeration member
PJOC_VM_CONVERT_DISKS enumeration member
PJOC_VM_CREATE_SNAPSHOT enumeration member
PJOC_VM_CREATE_UNATTENDED_DISK enumeration member
PJOC_VM_CREATE_UNATTENDED_FLOPPY enumeration member
PJOC_VM_DECRYPT enumeration member
PJOC_VM_DELETE enumeration member
PJOC_VM_DELETE_SNAPSHOT enumeration member
PJOC_VM_DEV_CONNECT enumeration member
PJOC_VM_DEV_COPY_IMAGE enumeration member
PJOC_VM_DEV_CREATE_IMAGE enumeration member
PJOC_VM_DEV_DISCONNECT enumeration member
PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN enumeration member
PJOC_VM_DEV_HD_CHECK_PASSWORD enumeration member
PJOC_VM_DROP_SUSPENDED_STATE enumeration member
PJOC_VM_ENCRYPT enumeration member
PJOC_VM_GENERATE_VM_DEV_FILENAME enumeration member
PJOC_VM_GET_PACKED_PROBLEM_REPORT enumeration member
PJOC_VM_GET_PERFSTATS enumeration member
PJOC_VM_GET_PROBLEM_REPORT enumeration member
PJOC_VM_GET_SNAPSHOTS_TREE enumeration member
PJOC_VM_GET_STATE enumeration member
PJOC_VM_GET_STATISTICS enumeration member
PJOC_VM_GET_SUSPENDED_SCREEN enumeration member
PJOC_VM_GET_TOOLS_STATE enumeration member
PJOC_VM_GET_VIRTUAL_DEVICES_INFO enumeration member
PJOC_VM_GUEST_GET_NETWORK_SETTINGS enumeration member
PJOC_VM_GUEST_LOGOUT enumeration member
PJOC_VM_GUEST_RUN_PROGRAM enumeration member
PJOC_VM_GUEST_SET_USER_PASSWD enumeration member
PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS enumeration member
PJOC_VM_INSTALL_TOOLS enumeration member
PJOC_VM_INSTALL_UTILITY enumeration member
PJOC_VM_LOCK enumeration member
PJOC_VM_LOGIN_IN_GUEST enumeration member
PJOC_VM_MIGRATE enumeration member
PJOC_VM_MIGRATE_CANCEL enumeration member
PJOC_VM_MOUNT enumeration member
PJOC_VM_MOVE enumeration member
PJOC_VM_PAUSE enumeration member
PJOC_VM_REFRESH_CONFIG enumeration member
PJOC_VM_REG enumeration member
PJOC_VM_REMOVE_PROTECTION enumeration member
PJOC_VM_RESET enumeration member
PJOC_VM_RESET_UPTIME enumeration member
PJOC_VM_RESIZE_DISK_IMAGE enumeration member
PJOC_VM_RESTART enumeration member
PJOC_VM_RESTORE enumeration member
PJOC_VM_RESUME enumeration member
PJOC_VM_RUN_COMPRESSOR enumeration member
PJOC_VM_SEND_CLIPBOARD_REQUEST enumeration member
PJOC_VM_SEND_DRAGDROP_COMMAND enumeration member
PJOC_VM_SEND_PROBLEM_REPORT enumeration member
PJOC_VM_SEND_SHUTDOWN_COMMAND enumeration member
PJOC_VM_SET_PROTECTION enumeration member
PJOC_VM_START enumeration member
PJOC_VM_START_EX enumeration member
PJOC_VM_START_VNC_SERVER enumeration member
PJOC_VM_STOP enumeration member
PJOC_VM_STOP_VNC_SERVER enumeration member
PJOC_VM_STORE_VALUE_BY_KEY enumeration member
PJOC_VM_SUBSCRIBE_PERFSTATS enumeration member
PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS enumeration member
PJOC_VM_SUSPEND enumeration member
PJOC_VM_SWITCH_TO_SNAPSHOT enumeration member
PJOC_VM_UMOUNT enumeration member
PJOC_VM_UNLOCK enumeration member
PJOC_VM_UNREG enumeration member
PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS enumeration member
PJOC_VM_UNSUBSCRIBE_PERFSTATS enumeration member
PJOC_VM_UPDATE_SECURITY enumeration member
PJOC_VM_UPDATE_SNAPSHOT_DATA enumeration member
PJOC_VM_UPDATE_TOOLS_SECTION enumeration member
PJOC_VM_VALIDATE_CONFIG enumeration member
PJS_FINISHED enumeration member
PJS_RUNNING enumeration member
PJS_UNKNOWN enumeration member
PKE_PRESS enumeration member
PKE_RELEASE enumeration member
PLLF_LOGIN_WITH_DELAYED_CONNECTION enumeration member
PLM_ROOT_ACCOUNT enumeration member
PLM_ROOT_ACOUNT enumeration member
PLM_START_ACCOUNT enumeration member
PLM_START_ACOUNT enumeration member
PLM_USER_ACCOUNT enumeration member
PLM_USER_ACOUNT enumeration member
PLRK_ALLOWED_GUEST_OS_VERSIONS enumeration member
PLRK_RUNNING_VMS_LIMIT enumeration member
PLRK_RUNNING_VMS_LIMIT_PER_USER enumeration member
PLRK_UNKNOWN enumeration member
PLRK_VM_CLONE enumeration member
PLRK_VM_CONVERT_FROM_TEMPLATE enumeration member
PLRK_VM_CONVERT_TO_TEMPLATE enumeration member
PLRK_VM_CPU_LIMIT enumeration member
PLRK_VM_CREATE enumeration member
PLRK_VM_DOWNLOAD enumeration member
PLRK_VM_IMPORT_3RD_PARTY enumeration member
PLRK_VM_MEMORY_LIMIT enumeration member
PLRK_VM_PAUSE enumeration member
PLRK_VM_REGISTER enumeration member
PLRK_VM_SAFEMODE_FEATURE enumeration member
PLRK_VM_SHOW_FULLSCREEN enumeration member
PLRK_VM_SMARTGUARD_FEATURE enumeration member
PLRK_VM_SNAPSHOT_CREATE enumeration member
PLRK_VM_SNAPSHOT_DELETE enumeration member
PLRK_VM_SNAPSHOT_SWITCH enumeration member
PLRK_VM_SNAPSHOT_TREE enumeration member
PLRK_VM_SUSPEND enumeration member
PLRK_VM_UNDODISK_FEATURE enumeration member
PLRK_VM_VTD_AVAILABLE enumeration member
PMAA_NO_ADVANCED_AUTH_NEEDED enumeration member
PMAA_USE_SYSTEM_CREDENTIALS enumeration member
PMB_LEFT_BUTTON enumeration member
PMB_MIDDLE_BUTTON enumeration member
PMB_NOBUTTON enumeration member
PMB_RIGHT_BUTTON enumeration member
PMB_UIEMU_DOUBLE_CLICK enumeration member
PMB_UIEMU_SINGLE_CLICK enumeration member
PMB_UIEMU_TRIPLE_CLICK enumeration member
PMB_XBUTTON1 enumeration member
PMB_XBUTTON2 enumeration member
PMB_XBUTTON3 enumeration member
PMB_XBUTTON4 enumeration member
PMB_XBUTTON5 enumeration member
PMS_IDE_DEVICE enumeration member
PMS_SATA_DEVICE enumeration member
PMS_SCSI_DEVICE enumeration member
PMS_UNKNOWN_DEVICE enumeration member
PMT_ANSWER enumeration member
PMT_CRITICAL enumeration member
PMT_INFORMATION enumeration member
PMT_QUESTION enumeration member
PMT_WARNING enumeration member
PMVD_INFO enumeration member
PMVD_READ_ONLY enumeration member
PMVD_READ_WRITE enumeration member
PNA_BRIDGED_ETHERNET enumeration member
PNA_DIRECT_ASSIGN enumeration member
PNA_HOST_ONLY enumeration member
PNA_ROUTED enumeration member
PNA_SHARED enumeration member
PNSF_VM_START_WAIT enumeration member
PNT_E1000 enumeration member
PNT_E1000E enumeration member
PNT_RTL enumeration member
PNT_UNDEFINED enumeration member
PNT_VIRTIO enumeration member
PNWR_AUTO enumeration member
PNWR_GENERATED_MAC enumeration member
PNWR_HOST_MAC enumeration member
POCM_AUTO enumeration member
POCM_DISABLED enumeration member
POCM_ENABLED enumeration member
POD_OPTIMIZE_FOR_ACCESSIBILITY enumeration member
POD_OPTIMIZE_FOR_GAMES enumeration member
POD_STANDARD enumeration member
PPF_TCP enumeration member
PPF_UDP enumeration member
PPRF_ADD_CLIENT_PART enumeration member
PPRF_ADD_SERVER_PART enumeration member
PPRF_DO_NOT_CREATE_HOST_SCREENSHOT enumeration member
PPS_PROC_IDLE enumeration member
PPS_PROC_RUN enumeration member
PPS_PROC_SLEEP enumeration member
PPS_PROC_STOP enumeration member
PPS_PROC_ZOMBIE enumeration member
PR3F_ALLOW_UNKNOWN_OS enumeration member
PR3F_CREATE_SHADOW_VM enumeration member
PRCF_FORCE enumeration member
PRCF_UNREG_PRESERVE enumeration member
PRD_AUTO enumeration member
PRD_DISABLED enumeration member
PRD_MANUAL enumeration member
PRIF_DISK_INFO enumeration member
PRIF_RESIZE_LAST_PARTITION enumeration member
PRIF_RESIZE_OFFLINE enumeration member
Primary Display Capture
PRL_ADAPTER_INDEX
PRL_ADAPTER_INDEX enumeration
PRL_ALLOWED_VM_COMMAND
PRL_ALLOWED_VM_COMMAND enumeration
PRL_ALLOWED_VM_COMMAND_PTR
PRL_ALLOWED_VM_COMMAND_PTR type
PRL_API_COMMAND_FLAGS
PRL_API_COMMAND_FLAGS enumeration
PRL_API_COMMAND_FLAGS_PTR
PRL_API_COMMAND_FLAGS_PTR type
PRL_API_INIT_FLAGS
PRL_API_INIT_FLAGS enumeration
PRL_API_INIT_FLAGS_PTR
PRL_API_INIT_FLAGS_PTR type
PRL_API_METHOD_PTR
PRL_API_METHOD_PTR type
PRL_APP_IN_DOCK_MODE
PRL_APP_IN_DOCK_MODE enumeration
PRL_APP_IN_DOCK_MODE_PTR
PRL_APP_IN_DOCK_MODE_PTR type
PRL_APPLIANCE_DOWNLOAD_STATUS
PRL_APPLIANCE_DOWNLOAD_STATUS enumeration
PRL_APPLIANCE_DOWNLOAD_STATUS_PTR
PRL_APPLIANCE_DOWNLOAD_STATUS_PTR type
PRL_APPLICATION_MODE
PRL_APPLICATION_MODE enumeration
PRL_APPLICATION_MODE_PTR
PRL_APPLICATION_MODE_PTR type
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD macro
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_DECL macro
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_METHOD_PTR macro
PRL_ASYNC_SRV_METHOD_DECL
PRL_ASYNC_SRV_METHOD_DECL macro
PRL_AUDIO_STREAM_TYPE
PRL_AUDIO_STREAM_TYPE enumeration
PRL_AUDIO_STREAM_TYPE_PTR
PRL_AUDIO_STREAM_TYPE_PTR type
PRL_BIOS_TYPE
PRL_BIOS_TYPE enumeration
PRL_BIOS_TYPE_PTR
PRL_BIOS_TYPE_PTR type
PRL_BOOL
PRL_BOOL type
PRL_BOOL Types
PRL_BOOL_PTR
PRL_BOOL_PTR type
PRL_BSD_PARTITION
PRL_BSD_PARTITION macro
PRL_CHAR
PRL_CHAR type
PRL_CHAR Types
PRL_CHAR_PTR
PRL_CHAR_PTR type
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_INVALID macro
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_OLD_VERSION macro
PRL_CHECKED_DISK_VALID
PRL_CHECKED_DISK_VALID macro
PRL_CHS
PRL_CHS structure
PRL_CHS_PTR
PRL_CHS_PTR type
PRL_CLONE_VM_FLAGS
PRL_CLONE_VM_FLAGS enumeration
PRL_CLONE_VM_FLAGS_PTR
PRL_CLONE_VM_FLAGS_PTR type
PRL_CLUSTERED_DEVICE_SUBTYPE
PRL_CLUSTERED_DEVICE_SUBTYPE enumeration
PRL_CLUSTERED_DEVICE_SUBTYPE_PTR
PRL_CLUSTERED_DEVICE_SUBTYPE_PTR type
PRL_COMPACT_MODE
PRL_COMPACT_MODE enumeration
PRL_COMPACT_MODE_PTR
PRL_COMPACT_MODE_PTR type
PRL_CONST Types
PRL_CONST_API_METHOD_PTR
PRL_CONST_API_METHOD_PTR type
PRL_CONST_BOOL_PTR
PRL_CONST_BOOL_PTR type
PRL_CONST_CARET_INFO_PTR
PRL_CONST_CARET_INFO_PTR type
PRL_CONST_CPU_FEATURES_MASK_PTR
PRL_CONST_CPU_FEATURES_MASK_PTR type
PRL_CONST_CPULIMIT_DATA_PTR
PRL_CONST_CPULIMIT_DATA_PTR type
PRL_CONST_CVSRC_OPEN_MODE
PRL_CONST_CVSRC_OPEN_MODE type
PRL_CONST_DISK_OPEN_FLAGS_PTR
PRL_CONST_DISK_OPEN_FLAGS_PTR type
PRL_CONST_DISK_PARAMETERS_PTR
PRL_CONST_DISK_PARAMETERS_PTR type
PRL_CONST_DOUBLE_PTR
PRL_CONST_DOUBLE_PTR type
PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR
PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR type
PRL_CONST_GUID_PTR
PRL_CONST_GUID_PTR type
PRL_CONST_HANDLE_PTR
PRL_CONST_HANDLE_PTR type
PRL_CONST_INT16_PTR
PRL_CONST_INT16_PTR type
PRL_CONST_INT32_PTR
PRL_CONST_INT32_PTR type
PRL_CONST_INT64_PTR
PRL_CONST_INT64_PTR type
PRL_CONST_INT8_PTR
PRL_CONST_INT8_PTR type
PRL_CONST_IOLIMIT_DATA_PTR
PRL_CONST_IOLIMIT_DATA_PTR type
PRL_CONST_MAKEUP_HINTING_RGN_PTR
PRL_CONST_MAKEUP_HINTING_RGN_PTR type
PRL_CONST_SELECTION_HINTING_RGN_PTR
PRL_CONST_SELECTION_HINTING_RGN_PTR type
PRL_CONST_SIZE_PTR
PRL_CONST_SIZE_PTR type
PRL_CONST_SNAPSHOT_ELEMENT_PTR
PRL_CONST_SNAPSHOT_ELEMENT_PTR type
PRL_CONST_STR
PRL_CONST_STR type
PRL_CONST_STR_PTR
PRL_CONST_STR_PTR type
PRL_CONST_UIEMU_AUTOKEYBOARD_PTR
PRL_CONST_UIEMU_AUTOKEYBOARD_PTR type
PRL_CONST_UIEMU_CURSOR_DESC_PTR
PRL_CONST_UIEMU_CURSOR_DESC_PTR type
PRL_CONST_UIEMU_CURSOR_FORMAT_PTR
PRL_CONST_UIEMU_CURSOR_FORMAT_PTR type
PRL_CONST_UIEMU_CURSOR_POS_PTR
PRL_CONST_UIEMU_CURSOR_POS_PTR type
PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR
PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR type
PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR
PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR type
PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR
PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR type
PRL_CONST_UIEMU_GESTURE_EVENT_PTR
PRL_CONST_UIEMU_GESTURE_EVENT_PTR type
PRL_CONST_UIEMU_INPUT_INFO_PTR
PRL_CONST_UIEMU_INPUT_INFO_PTR type
PRL_CONST_UIEMU_VKEY_PTR
PRL_CONST_UIEMU_VKEY_PTR type
PRL_CONST_UINT16_PTR
PRL_CONST_UINT16_PTR type
PRL_CONST_UINT32_PTR
PRL_CONST_UINT32_PTR type
PRL_CONST_UINT64_PTR
PRL_CONST_UINT64_PTR type
PRL_CONST_UINT8_PTR
PRL_CONST_UINT8_PTR type
PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR
PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR type
PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR
PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR type
PRL_CONST_VOID_PTR
PRL_CONST_VOID_PTR type
PRL_CONVERT_VIRTUAL_DISK
PRL_CONVERT_VIRTUAL_DISK enumeration
PRL_COPY_CT_TEMPLATE_FLAGS
PRL_COPY_CT_TEMPLATE_FLAGS enumeration
PRL_CORNER_ACTIONS
PRL_CORNER_ACTIONS enumeration
PRL_CORNER_ACTIONS_PTR
PRL_CORNER_ACTIONS_PTR type
PRL_CPU_FEATURES
PRL_CPU_FEATURES structure
PRL_CPU_FEATURES_EX
PRL_CPU_FEATURES_EX enumeration
PRL_CPU_FEATURES_MASK
PRL_CPU_FEATURES_MASK structure
PRL_CPU_FEATURES_MASK_PTR
PRL_CPU_FEATURES_MASK_PTR type
PRL_CPU_FEATURES_PTR
PRL_CPU_FEATURES_PTR type
PRL_CPU_HVT
PRL_CPU_HVT enumeration
PRL_CPU_HVT_PTR
PRL_CPU_HVT_PTR type
PRL_CPU_MODE
PRL_CPU_MODE enumeration
PRL_CPU_MODE_PTR
PRL_CPU_MODE_PTR type
PRL_CPU_UNLIMITED
PRL_CPU_UNLIMITED macro
PRL_CPU_VTX_MODE
PRL_CPU_VTX_MODE type
PRL_CPU_VTX_MODE_PTR
PRL_CPU_VTX_MODE_PTR type
PRL_CPULIMIT_DATA
PRL_CPULIMIT_DATA structure
PRL_CPULIMIT_DATA_PTR
PRL_CPULIMIT_DATA_PTR type
PRL_CPULIMIT_MHZ enumeration member
PRL_CPULIMIT_PERCENTS enumeration member
PRL_CPULIMIT_PERCENTS_TO_MHZ enumeration member
PRL_CPULIMIT_PERCENTS100 enumeration member
PRL_CPULIMIT_TYPE
PRL_CPULIMIT_TYPE enumeration
PRL_CPUUITS
PRL_CPUUITS enumeration
PRL_CPUUNITS_DEFAULT enumeration member
PRL_CPUUNITS_MAX enumeration member
PRL_CPUUNITS_MIN enumeration member
PRL_CREATE_DISK_IMAGE_FLAGS
PRL_CREATE_DISK_IMAGE_FLAGS enumeration
PRL_CREATE_DISK_IMAGE_FLAGS_PTR
PRL_CREATE_DISK_IMAGE_FLAGS_PTR type
PRL_CREATE_SNAPSHOT_FLAGS
PRL_CREATE_SNAPSHOT_FLAGS enumeration
PRL_CT_CAPMASK
PRL_CT_CAPMASK enumeration
PRL_CT_CAPMASK_PTR
PRL_CT_CAPMASK_PTR type
PRL_CT_FEATURES
PRL_CT_FEATURES enumeration
PRL_CT_RESOURCE
PRL_CT_RESOURCE enumeration
PRL_CT_TEMPLATE_TYPE
PRL_CT_TEMPLATE_TYPE enumeration
PRL_CT_TEMPLATE_TYPE_PTR
PRL_CT_TEMPLATE_TYPE_PTR type
PRL_CURRENT_GUEST_OS_SESSION
PRL_CURRENT_GUEST_OS_SESSION macro
PRL_CVSRC_OPEN_MODE
PRL_CVSRC_OPEN_MODE structure
PRL_CVSRC_OPEN_MODE_PTR
PRL_CVSRC_OPEN_MODE_PTR type
PRL_DATA_PARTITION
PRL_DATA_PARTITION macro
PRL_DATA_STATISTIC_SEGMENTS
PRL_DATA_STATISTIC_SEGMENTS enumeration
PRL_DATA_STATISTIC_SEGMENTS_PTR
PRL_DATA_STATISTIC_SEGMENTS_PTR type
PRL_DELETE_SNAPSHOT_FLAGS
PRL_DELETE_SNAPSHOT_FLAGS enumeration
PRL_DEVICE Types
PRL_DEVICE_ACTION
PRL_DEVICE_ACTION enumeration
PRL_DEVICE_ACTION_PTR
PRL_DEVICE_ACTION_PTR type
PRL_DEVICE_TYPE
PRL_DEVICE_TYPE enumeration
PRL_DEVICE_TYPE_PTR
PRL_DEVICE_TYPE_PTR type
PRL_DISK Macros
PRL_DISK Types
PRL_DISK_ALIGN_REQUESTS
PRL_DISK_ALIGN_REQUESTS macro
PRL_DISK_ALLOW_DATA_MODIFY
PRL_DISK_ALLOW_DATA_MODIFY macro
PRL_DISK_CACHE_DEFAULT
PRL_DISK_CACHE_DEFAULT macro
PRL_DISK_CACHE_DISABLED
PRL_DISK_CACHE_DISABLED macro
PRL_DISK_CACHE_ENABLED
PRL_DISK_CACHE_ENABLED macro
PRL_DISK_CACHE_UNCACHED_READ
PRL_DISK_CACHE_UNCACHED_READ macro
PRL_DISK_CACHE_UNCACHED_SEQ_READ
PRL_DISK_CACHE_UNCACHED_SEQ_READ macro
PRL_DISK_CALLBACK
PRL_DISK_DEFAULT_FLAG
PRL_DISK_DEFAULT_FLAG macro
PRL_DISK_FAKE_OPEN
PRL_DISK_FAKE_OPEN macro
PRL_DISK_FOPS_DEFAULT
PRL_DISK_FOPS_DEFAULT macro
PRL_DISK_FOPS_MASK
PRL_DISK_FOPS_MASK macro
PRL_DISK_FOPS_MERGING
PRL_DISK_FOPS_MERGING macro
PRL_DISK_FOPS_NONCACHED
PRL_DISK_FOPS_NONCACHED macro
PRL_DISK_FOPS_NORMAL
PRL_DISK_FOPS_NORMAL macro
PRL_DISK_FOPS_PCS
PRL_DISK_FOPS_PCS macro
PRL_DISK_IGNORE_PROTECTION
PRL_DISK_IGNORE_PROTECTION macro
PRL_DISK_INVALID
PRL_DISK_INVALID macro
PRL_DISK_NO_ERROR_CHECKING
PRL_DISK_NO_ERROR_CHECKING macro
PRL_DISK_NO_IMAGE_CREATION
PRL_DISK_NO_IMAGE_CREATION macro
PRL_DISK_NO_SPACE_CHECKS
PRL_DISK_NO_SPACE_CHECKS macro
PRL_DISK_NOT_LIMIT_HANDLES
PRL_DISK_NOT_LIMIT_HANDLES macro
PRL_DISK_NOTHING
PRL_DISK_NOTHING macro
PRL_DISK_OPEN_FLAGS
PRL_DISK_OPEN_FLAGS type
PRL_DISK_OPEN_FLAGS_PTR
PRL_DISK_OPEN_FLAGS_PTR type
PRL_DISK_PARAMETERS
PRL_DISK_PARAMETERS structure
PRL_DISK_PARAMETERS_PTR
PRL_DISK_PARAMETERS_PTR type
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_COMPLETED macro
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MAX macro
PRL_DISK_PROGRESS_MIN
PRL_DISK_PROGRESS_MIN macro
PRL_DISK_READ
PRL_DISK_READ macro
PRL_DISK_READ_LOCK
PRL_DISK_READ_LOCK macro
PRL_DISK_USE_RAW_DISK
PRL_DISK_USE_RAW_DISK macro
PRL_DISK_WRITE
PRL_DISK_WRITE macro
PRL_DISK_XML_CHANGE
PRL_DISK_XML_CHANGE macro
PRL_DISPATCHER_LISTEN_PORT
PRL_DISPATCHER_LISTEN_PORT macro
PRL_DISPATCHER_LISTEN_PORT_PMOBILE
PRL_DISPATCHER_LISTEN_PORT_PMOBILE macro
PRL_DISPLAY_BUFFER_FORMAT
PRL_DISPLAY_BUFFER_FORMAT enumeration
PRL_DISPLAY_BUFFER_FORMAT_PTR
PRL_DISPLAY_BUFFER_FORMAT_PTR type
PRL_DISPLAY_CODEC_COMPRESSION
PRL_DISPLAY_CODEC_COMPRESSION enumeration
PRL_DISPLAY_CODEC_QUALITY
PRL_DISPLAY_CODEC_QUALITY enumeration
PRL_DISPLAY_CODEC_TYPE
PRL_DISPLAY_CODEC_TYPE enumeration
PRL_DISPLAY_CONFIG_MODE
PRL_DISPLAY_CONFIG_MODE enumeration
PRL_DISPLAY_CONFIG_MODE_PTR
PRL_DISPLAY_CONFIG_MODE_PTR type
PRL_DISTRO_MEDIA_TYPE
PRL_DISTRO_MEDIA_TYPE enumeration
PRL_DISTRO_MEDIA_TYPE_PTR
PRL_DISTRO_MEDIA_TYPE_PTR type
PRL_DOCK_ICON_TYPE
PRL_DOCK_ICON_TYPE enumeration
PRL_DOCK_ICON_TYPE_PTR
PRL_DOCK_ICON_TYPE_PTR type
PRL_DOUBLE
PRL_DOUBLE type
PRL_DOUBLE Types
PRL_DOUBLE_PTR
PRL_DOUBLE_PTR type
PRL_DOUBLE_PTR_PTR
PRL_DOUBLE_PTR_PTR type
PRL_EFI_PARTITION
PRL_EFI_PARTITION macro
PRL_EFI_PARTITION_GPT
PRL_EFI_PARTITION_GPT macro
PRL_EMPTY_PARTITION
PRL_EMPTY_PARTITION macro
PRL_ENCRYPTION_FLAGS
PRL_ENCRYPTION_FLAGS enumeration
PRL_ENCRYPTION_FLAGS_PTR
PRL_ENCRYPTION_FLAGS_PTR type
PRL_ERR Macros
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR macro
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED macro
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS macro
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE macro
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD macro
PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED
PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED macro
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TO_VM_DENIED macro
PRL_ERR_ACCESS_TO_VM_HDD_DENIED
PRL_ERR_ACCESS_TO_VM_HDD_DENIED macro
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ACCESS_TOKEN_INVALID macro
PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT
PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT macro
PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE macro
PRL_ERR_ACTIVATE_TRIAL_LICENSE
PRL_ERR_ACTIVATE_TRIAL_LICENSE macro
PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE macro
PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR macro
PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED macro
PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED
PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED macro
PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID macro
PRL_ERR_ACTIVATION_SERVER_ERROR
PRL_ERR_ACTIVATION_SERVER_ERROR macro
PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED
PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED macro
PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED macro
PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID macro
PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST macro
PRL_ERR_ACTIVATION_UPDATE_FAILED
PRL_ERR_ACTIVATION_UPDATE_FAILED macro
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT macro
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE macro
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE
PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE macro
PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE macro
PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM
PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM macro
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED macro
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED macro
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION macro
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION
PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION macro
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALIGN_ON_4 macro
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER macro
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT macro
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_INCOMPATIBLE macro
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_API_WASNT_INITIALIZED macro
PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5
PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5 macro
PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER
PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER macro
PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM
PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM macro
PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE
PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE macro
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR macro
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS
PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS macro
PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE
PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE macro
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND macro
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED
PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED macro
PRL_ERR_APPLIANCE_EXIT_WITH_ERROR
PRL_ERR_APPLIANCE_EXIT_WITH_ERROR macro
PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS
PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS macro
PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED
PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED macro
PRL_ERR_APPLIANCE_INVALID_CONFIG
PRL_ERR_APPLIANCE_INVALID_CONFIG macro
PRL_ERR_APPLIANCE_MISMATCH_MD5
PRL_ERR_APPLIANCE_MISMATCH_MD5 macro
PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE
PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE macro
PRL_ERR_APPLIANCE_NO_VM_BUNDLE
PRL_ERR_APPLIANCE_NO_VM_BUNDLE macro
PRL_ERR_APPLIANCE_USER_NOT_FOUND
PRL_ERR_APPLIANCE_USER_NOT_FOUND macro
PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED
PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED macro
PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED
PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED macro
PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED macro
PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED
PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED macro
PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR
PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR macro
PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL
PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL macro
PRL_ERR_ATTACH_BACKUP_PROTO_ERROR
PRL_ERR_ATTACH_BACKUP_PROTO_ERROR macro
PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED
PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED macro
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION macro
PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED
PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED macro
PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM
PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM macro
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_AUTHENTICATION_FAILED macro
PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED
PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED macro
PRL_ERR_BACKUP_ACRONIS_ERR
PRL_ERR_BACKUP_ACRONIS_ERR macro
PRL_ERR_BACKUP_BACKUP_CMD_FAILED
PRL_ERR_BACKUP_BACKUP_CMD_FAILED macro
PRL_ERR_BACKUP_BACKUP_NOT_FOUND
PRL_ERR_BACKUP_BACKUP_NOT_FOUND macro
PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND
PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND macro
PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY macro
PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY
PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY macro
PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS
PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS macro
PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE macro
PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED
PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED macro
PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST
PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST macro
PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST macro
PRL_ERR_BACKUP_INTERNAL_ERROR
PRL_ERR_BACKUP_INTERNAL_ERROR macro
PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR
PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR macro
PRL_ERR_BACKUP_LOCKED_FOR_READING
PRL_ERR_BACKUP_LOCKED_FOR_READING macro
PRL_ERR_BACKUP_LOCKED_FOR_WRITING
PRL_ERR_BACKUP_LOCKED_FOR_WRITING macro
PRL_ERR_BACKUP_REGISTER_VM_FAILED
PRL_ERR_BACKUP_REGISTER_VM_FAILED macro
PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED
PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED macro
PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD
PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD macro
PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY
PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY macro
PRL_ERR_BACKUP_RESTORE_CMD_FAILED
PRL_ERR_BACKUP_RESTORE_CMD_FAILED macro
PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST
PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST macro
PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR
PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR macro
PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR
PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR macro
PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE
PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE macro
PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED
PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED macro
PRL_ERR_BACKUP_RESTORE_VM_RUNNING
PRL_ERR_BACKUP_RESTORE_VM_RUNNING macro
PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM
PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM macro
PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED
PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED macro
PRL_ERR_BACKUP_TIMEOUT_EXCEEDED
PRL_ERR_BACKUP_TIMEOUT_EXCEEDED macro
PRL_ERR_BACKUP_TOOL_CANNOT_START
PRL_ERR_BACKUP_TOOL_CANNOT_START macro
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_PARAMETERS macro
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_BUFFER_OVERRUN macro
PRL_ERR_BUSE_ENTRY_ALREADY_EXIST
PRL_ERR_BUSE_ENTRY_ALREADY_EXIST macro
PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED
PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED macro
PRL_ERR_BUSE_ENTRY_INVALID
PRL_ERR_BUSE_ENTRY_INVALID macro
PRL_ERR_BUSE_ENTRY_IO_ERROR
PRL_ERR_BUSE_ENTRY_IO_ERROR macro
PRL_ERR_BUSE_INTERNAL_ERROR
PRL_ERR_BUSE_INTERNAL_ERROR macro
PRL_ERR_BUSE_NOT_MOUNTED
PRL_ERR_BUSE_NOT_MOUNTED macro
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE macro
PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM macro
PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE
PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE macro
PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM
PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM macro
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM macro
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM macro
PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM
PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM macro
PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE
PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE macro
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY macro
PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN
PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN macro
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS macro
PRL_ERR_CANT_CHANGE_HOST_ID
PRL_ERR_CANT_CHANGE_HOST_ID macro
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE macro
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE macro
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE macro
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL macro
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER macro
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN macro
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER
PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER macro
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD macro
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD macro
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONNECT_TO_DISPATCHER macro
PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY
PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY macro
PRL_ERR_CANT_CONVERT_CONFIG
PRL_ERR_CANT_CONVERT_CONFIG macro
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE macro
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS macro
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD macro
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM
PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM macro
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT macro
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT macro
PRL_ERR_CANT_CREATE_DISK_IMAGE
PRL_ERR_CANT_CREATE_DISK_IMAGE macro
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE macro
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE macro
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE macro
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE macro
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE macro
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_DELETE_FILE macro
PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED
PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED macro
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_EDIT_SUSPENDED_VM macro
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_GET_FILE_PERMISSIONS macro
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_INIT_REAL_CPUS_INFO macro
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_DISP_EVENT macro
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_PARSE_VM_CONFIG macro
PRL_ERR_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_CANT_PREPARE_RECONFIG_DATA macro
PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE
PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE macro
PRL_ERR_CANT_RECONFIG_GUEST_OS
PRL_ERR_CANT_RECONFIG_GUEST_OS macro
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_RECREATE_HDD macro
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_DIR_ENTRY macro
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY macro
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN macro
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_DIR_ENTRY macro
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_RENAME_ENTRY macro
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE macro
PRL_ERR_CANT_RESIZE_HDD
PRL_ERR_CANT_RESIZE_HDD macro
PRL_ERR_CANT_RESOLVE_HOSTNAME
PRL_ERR_CANT_RESOLVE_HOSTNAME macro
PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED macro
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN macro
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT
PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT macro
PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER
PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER macro
PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED
PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED macro
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP macro
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION macro
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_TO_START_VM_TEMPLATE macro
PRL_ERR_CANT_UNPACK_ARCHIVE
PRL_ERR_CANT_UNPACK_ARCHIVE macro
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANT_UPDATE_DEVICE_INFO macro
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT macro
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 macro
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_CHANGESID_FAILED
PRL_ERR_CHANGESID_FAILED macro
PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE macro
PRL_ERR_CHANGESID_NOT_AVAILABLE
PRL_ERR_CHANGESID_NOT_AVAILABLE macro
PRL_ERR_CHANGESID_NOT_SUPPORTED
PRL_ERR_CHANGESID_NOT_SUPPORTED macro
PRL_ERR_CHANGESID_VM_START_FAILED
PRL_ERR_CHANGESID_VM_START_FAILED macro
PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM
PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM macro
PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL
PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL macro
PRL_ERR_CI_PERMISSIONS_DENIED
PRL_ERR_CI_PERMISSIONS_DENIED macro
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_CLONE_OPERATION_CANCELED macro
PRL_ERR_CLUSTER_RESOURCE_ERROR
PRL_ERR_CLUSTER_RESOURCE_ERROR macro
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_DEVICE_ALREADY_EXIST macro
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED macro
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST macro
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE macro
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE macro
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED macro
PRL_ERR_COMPACT_ALREADY_SWITCHED_ON
PRL_ERR_COMPACT_ALREADY_SWITCHED_ON macro
PRL_ERR_COMPACT_WRONG_VM_STATE
PRL_ERR_COMPACT_WRONG_VM_STATE macro
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONCURRENT_COMMAND_EXECUTING macro
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID macro
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID macro
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_EDIT_COLLISION macro
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CONFIG_FILE_NOT_SET macro
PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN
PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN macro
PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED
PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED macro
PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED
PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED macro
PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN
PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN macro
PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED
PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED macro
PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID
PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID macro
PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED
PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED macro
PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED
PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED macro
PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID
PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID macro
PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED
PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED macro
PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL
PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL macro
PRL_ERR_CONNECT_TO_MOUNTER
PRL_ERR_CONNECT_TO_MOUNTER macro
PRL_ERR_CONV_HD_CONFLICT
PRL_ERR_CONV_HD_CONFLICT macro
PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED
PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED macro
PRL_ERR_CONV_HD_EXIT_WITH_ERROR
PRL_ERR_CONV_HD_EXIT_WITH_ERROR macro
PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION
PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION macro
PRL_ERR_CONV_HD_WRONG_VM_STATE
PRL_ERR_CONV_HD_WRONG_VM_STATE macro
PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED
PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED macro
PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE
PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE macro
PRL_ERR_CONVERT_EFI_CONFIG_INVALID
PRL_ERR_CONVERT_EFI_CONFIG_INVALID macro
PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED
PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED macro
PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED macro
PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND
PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND macro
PRL_ERR_CONVERT_NO_GUEST_OS_FOUND
PRL_ERR_CONVERT_NO_GUEST_OS_FOUND macro
PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR
PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR macro
PRL_ERR_COPY_VM_INFO_FILE
PRL_ERR_COPY_VM_INFO_FILE macro
PRL_ERR_CORE_STATE_CANCELLED
PRL_ERR_CORE_STATE_CANCELLED macro
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG macro
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE macro
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE macro
PRL_ERR_CORE_STATE_ERROR_COMMON
PRL_ERR_CORE_STATE_ERROR_COMMON macro
PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_CORE_STATE_INV_SAV_VERSION macro
PRL_ERR_CORE_STATE_NO_FILE
PRL_ERR_CORE_STATE_NO_FILE macro
PRL_ERR_CORE_STATE_VM_WOULD_RESTART
PRL_ERR_CORE_STATE_VM_WOULD_RESTART macro
PRL_ERR_CORE_STATE_VM_WOULD_STOP
PRL_ERR_CORE_STATE_VM_WOULD_STOP macro
PRL_ERR_COULD_NOT_START_FIREWALL_TOOL
PRL_ERR_COULD_NOT_START_FIREWALL_TOOL macro
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE macro
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE macro
PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE
PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE macro
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_RESTART macro
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CPU_SHUTDOWN macro
PRL_ERR_CREATE_BOOTABLE_ISO
PRL_ERR_CREATE_BOOTABLE_ISO macro
PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE
PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE macro
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_CREATE_PRIVELEGED_PROCESS macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS macro
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
PRL_ERR_CT_IS_RUNNING
PRL_ERR_CT_IS_RUNNING macro
PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST
PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST macro
PRL_ERR_CT_MIGRATE_INTERNAL_ERROR
PRL_ERR_CT_MIGRATE_INTERNAL_ERROR macro
PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS
PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS macro
PRL_ERR_CT_NOT_FOUND
PRL_ERR_CT_NOT_FOUND macro
PRL_ERR_CVSRC_IO_ERROR
PRL_ERR_CVSRC_IO_ERROR macro
PRL_ERR_CVSRC_NO_CHANNEL
PRL_ERR_CVSRC_NO_CHANNEL macro
PRL_ERR_CVSRC_NO_OPEN_REQUEST
PRL_ERR_CVSRC_NO_OPEN_REQUEST macro
PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE
PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE macro
PRL_ERR_DEACTIVATE_TRIAL_LICENSE
PRL_ERR_DEACTIVATE_TRIAL_LICENSE macro
PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE
PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE macro
PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR
PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR macro
PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED
PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED macro
PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND
PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND macro
PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID
PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID macro
PRL_ERR_DEACTIVATION_SERVER_ERROR
PRL_ERR_DEACTIVATION_SERVER_ERROR macro
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED macro
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID
PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID macro
PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST
PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST macro
PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE
PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE macro
PRL_ERR_DELETE_UNFINISHED_STATE_FAILED
PRL_ERR_DELETE_UNFINISHED_STATE_FAILED macro
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DELETING_VM_FROM_CATALOGUE macro
PRL_ERR_DEV_ALREADY_CONNECTED
PRL_ERR_DEV_ALREADY_CONNECTED macro
PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_ALREADY_DISCONNECTED macro
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_DISABLE_AFTER_LOST macro
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED macro
PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII
PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII macro
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED macro
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED macro
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED macro
PRL_ERR_DEV_PRINTER_OVERFLOW
PRL_ERR_DEV_PRINTER_OVERFLOW macro
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED macro
PRL_ERR_DEV_USB_BUSY
PRL_ERR_DEV_USB_BUSY macro
PRL_ERR_DEV_USB_CHANGEPID
PRL_ERR_DEV_USB_CHANGEPID macro
PRL_ERR_DEV_USB_CONNECT_DENIED
PRL_ERR_DEV_USB_CONNECT_DENIED macro
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED macro
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2 macro
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED macro
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_NO_FREE_PORTS macro
PRL_ERR_DEV_USB_NOT_CONFIGURED
PRL_ERR_DEV_USB_NOT_CONFIGURED macro
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED macro
PRL_ERR_DEV_USB_REUSE
PRL_ERR_DEV_USB_REUSE macro
PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DIRECTORY_DOES_NOT_EXIST macro
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_CREATED macro
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED macro
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED macro
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BLOCK_SKIPPED macro
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR macro
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE macro
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY macro
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_CREATE_IMAGE_ERROR macro
PRL_ERR_DISK_DATA_NOT_FOUND
PRL_ERR_DISK_DATA_NOT_FOUND macro
PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DIR_CREATE_ERROR macro
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_DISK_NOT_OPENED macro
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_ENLARGE_FAILED macro
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED macro
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_CREATE_ERROR macro
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_EXISTS macro
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FILE_OPEN_ERROR macro
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FSYNC_FAILED macro
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED macro
PRL_ERR_DISK_GENERIC_ERROR
PRL_ERR_DISK_GENERIC_ERROR macro
PRL_ERR_DISK_GET_MOUNTPATH_FAILED
PRL_ERR_DISK_GET_MOUNTPATH_FAILED macro
PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GET_PARAMS_FAILED macro
PRL_ERR_DISK_GET_SIZE_FAILED
PRL_ERR_DISK_GET_SIZE_FAILED macro
PRL_ERR_DISK_GPT_MBR_NOT_EQUAL
PRL_ERR_DISK_GPT_MBR_NOT_EQUAL macro
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_GROUP_INTERSECT macro
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IDENTIFY_FAILED macro
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGE_BUSY macro
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMAGES_CORRUPTED macro
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_IMPERSONATE_FAILED macro
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INCORRECTLY_CLOSED macro
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INSUFFICIENT_SPACE macro
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INTERNAL_CLASS_ERROR macro
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_BLOCKSIZE macro
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_FORMAT macro
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_INVALID_PARAMETERS macro
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MEMORY_ERROR macro
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_MOUNT_FAILED macro
PRL_ERR_DISK_MOUNTED_OVERLAP
PRL_ERR_DISK_MOUNTED_OVERLAP macro
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_IMPLEMENTED macro
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_PERMITTED macro
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NOT_VALID_OFFSET macro
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_NULL_PART_SIZE macro
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OFFSETS_FIXED macro
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_ABORTED macro
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_IN_PROGRESS macro
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_OPERATION_NOT_ALLOWED macro
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_INVALID_NAME macro
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITION_NOT_FOUND macro
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE macro
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POINTERS_MIXED_UP macro
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_POSSIBLE_OVERRUN macro
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_FAILED macro
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_READ_OUT_DISK macro
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RENAME_ERROR macro
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_RESERVED_WORD macro
PRL_ERR_DISK_RESIZE_FAILED
PRL_ERR_DISK_RESIZE_FAILED macro
PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW
PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW macro
PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED
PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED macro
PRL_ERR_DISK_RESIZER_NOT_FOUND
PRL_ERR_DISK_RESIZER_NOT_FOUND macro
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SET_CACHING_FAILED macro
PRL_ERR_DISK_SET_FILE_SIZE_FAILED
PRL_ERR_DISK_SET_FILE_SIZE_FAILED macro
PRL_ERR_DISK_SHARED_BLOCK
PRL_ERR_DISK_SHARED_BLOCK macro
PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SHARING_VIOLATION macro
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SMALL_IMAGE_SIZE macro
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED macro
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STATES_ERROR macro
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_STORAGE_CORRUPTED macro
PRL_ERR_DISK_TOOL_NOT_FOUND
PRL_ERR_DISK_TOOL_NOT_FOUND macro
PRL_ERR_DISK_TOOL_PROCESS_ERROR
PRL_ERR_DISK_TOOL_PROCESS_ERROR macro
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_TRUNCATE_FAILED macro
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNALIGNED macro
PRL_ERR_DISK_UNCOMMITED_OPERATION
PRL_ERR_DISK_UNCOMMITED_OPERATION macro
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_UNMOUNT_FAILED macro
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_USER_INTERRUPTED macro
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_FAILED macro
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_OUT_DISK macro
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_WRITE_REAL_FAILED macro
PRL_ERR_DISK_XML_DIFFERS_FROM_REAL
PRL_ERR_DISK_XML_DIFFERS_FROM_REAL macro
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID macro
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_INVALID_VERSION macro
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LARGE_FILE macro
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_LOCKED macro
PRL_ERR_DISK_XML_MISSING
PRL_ERR_DISK_XML_MISSING macro
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_OPEN_FAILED macro
PRL_ERR_DISK_XML_PARTITION_NOT_FOUND
PRL_ERR_DISK_XML_PARTITION_NOT_FOUND macro
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_ERROR macro
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR macro
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR macro
PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE
PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE macro
PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK
PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK macro
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS macro
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_FILE_NOT_SET macro
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_CONFIG_WRITE_ERR macro
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT macro
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS macro
PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED
PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED macro
PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING
PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING macro
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED macro
PRL_ERR_DISP_VM_IS_NOT_STARTED
PRL_ERR_DISP_VM_IS_NOT_STARTED macro
PRL_ERR_DISP_VM_IS_NOT_STOPPED
PRL_ERR_DISP_VM_IS_NOT_STOPPED macro
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED macro
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID macro
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DISPATCHER_SERVICE_MODE macro
PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED
PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED macro
PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED
PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED macro
PRL_ERR_DOUBLE_INIT
PRL_ERR_DOUBLE_INIT macro
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST macro
PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED macro
PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED macro
PRL_ERR_ENC_HDD_CANT_OPEN
PRL_ERR_ENC_HDD_CANT_OPEN macro
PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED
PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED macro
PRL_ERR_ENC_HDD_IS_UNENCRYPTED
PRL_ERR_ENC_HDD_IS_UNENCRYPTED macro
PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE
PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE macro
PRL_ERR_ENC_KEY_NOT_SET
PRL_ERR_ENC_KEY_NOT_SET macro
PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND
PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND macro
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED macro
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED macro
PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED
PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED macro
PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY
PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY macro
PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED
PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED macro
PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE
PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE macro
PRL_ERR_ENC_WRONG_HDD_PASSWORD
PRL_ERR_ENC_WRONG_HDD_PASSWORD macro
PRL_ERR_ENC_WRONG_KEY
PRL_ERR_ENC_WRONG_KEY macro
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_ALREADY_EXISTS macro
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS macro
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST macro
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST macro
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS macro
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_EXCEED_MEMORY_LIMIT macro
PRL_ERR_EXT_DISK_ALREADY_EXISTS
PRL_ERR_EXT_DISK_ALREADY_EXISTS macro
PRL_ERR_EXT_DISK_CANT_RENAME
PRL_ERR_EXT_DISK_CANT_RENAME macro
PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER
PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER macro
PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER
PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER macro
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_START_VNC_SERVER macro
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER macro
PRL_ERR_FAILURE
PRL_ERR_FAILURE macro
PRL_ERR_FAILURE_ON_VM_DESTROYED
PRL_ERR_FAILURE_ON_VM_DESTROYED macro
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF macro
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_COPY macro
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_DISK_SPACE_ERROR macro
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF macro
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION
PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION macro
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_EXIST macro
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_NOT_FOUND macro
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS macro
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_READ_ERROR macro
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE macro
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED macro
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST macro
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS macro
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS macro
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED macro
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER macro
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FILE_WRITE_ERROR macro
PRL_ERR_FILECOPY_CANT_CREATE_DIR
PRL_ERR_FILECOPY_CANT_CREATE_DIR macro
PRL_ERR_FILECOPY_CANT_OPEN_FILE
PRL_ERR_FILECOPY_CANT_OPEN_FILE macro
PRL_ERR_FILECOPY_CANT_WRITE
PRL_ERR_FILECOPY_CANT_WRITE macro
PRL_ERR_FILECOPY_DIR_EXIST
PRL_ERR_FILECOPY_DIR_EXIST macro
PRL_ERR_FILECOPY_FILE_EXIST
PRL_ERR_FILECOPY_FILE_EXIST macro
PRL_ERR_FILECOPY_INTERNAL
PRL_ERR_FILECOPY_INTERNAL macro
PRL_ERR_FILECOPY_PROTOCOL
PRL_ERR_FILECOPY_PROTOCOL macro
PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR
PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR macro
PRL_ERR_FIXME
PRL_ERR_FIXME macro
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_DRIVE_INVALID macro
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST macro
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST macro
PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED
PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED macro
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE macro
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT macro
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT macro
PRL_ERR_GET_DISK_FREE_SPACE_FAILED
PRL_ERR_GET_DISK_FREE_SPACE_FAILED macro
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_LICENSE_INVALID_ARG macro
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG macro
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED macro
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED macro
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED macro
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG macro
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED macro
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GET_USER_HOME_DIR macro
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_INVALID_VERSION macro
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY macro
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST macro
PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED
PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED macro
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED macro
PRL_ERR_GUEST_USB_REQUIRED
PRL_ERR_GUEST_USB_REQUIRED macro
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HANDSHAKE_FAILED macro
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED macro
PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED
PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED macro
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF macro
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_COPY macro
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST macro
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST macro
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HOST_AMD_GUEST_MAC macro
PRL_ERR_HTTP_AUTH_REQUIRED
PRL_ERR_HTTP_AUTH_REQUIRED macro
PRL_ERR_HTTP_CONNECTION_REFUSED
PRL_ERR_HTTP_CONNECTION_REFUSED macro
PRL_ERR_HTTP_HOST_NOT_FOUND
PRL_ERR_HTTP_HOST_NOT_FOUND macro
PRL_ERR_HTTP_INVALID_RESPONSE_HEADER
PRL_ERR_HTTP_INVALID_RESPONSE_HEADER macro
PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE
PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE macro
PRL_ERR_HTTP_PROXY_AUTH_REQUIRED
PRL_ERR_HTTP_PROXY_AUTH_REQUIRED macro
PRL_ERR_HTTP_REQUEST_FAILED
PRL_ERR_HTTP_REQUEST_FAILED macro
PRL_ERR_HTTP_UNEXPECTED_CLOSE
PRL_ERR_HTTP_UNEXPECTED_CLOSE macro
PRL_ERR_HTTP_WRONG_CONTENT_LENGTH
PRL_ERR_HTTP_WRONG_CONTENT_LENGTH macro
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_DISABLED macro
PRL_ERR_HVT_DISABLED_WARNING
PRL_ERR_HVT_DISABLED_WARNING macro
PRL_ERR_HVT_NOT_AVAILABLE_WARNING
PRL_ERR_HVT_NOT_AVAILABLE_WARNING macro
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_NOT_PRESENT macro
PRL_ERR_HVT_NOT_PRESENT_WARNING
PRL_ERR_HVT_NOT_PRESENT_WARNING macro
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG macro
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_HYP_ALLOC_VMS_MEMORY macro
PRL_ERR_IAP_INVALID_PRODUCT_ID
PRL_ERR_IAP_INVALID_PRODUCT_ID macro
PRL_ERR_IAP_PAYMENT_FAILED
PRL_ERR_IAP_PAYMENT_FAILED macro
PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED
PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED macro
PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED
PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED macro
PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID
PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID macro
PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED
PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED macro
PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED
PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED macro
PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED
PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED macro
PRL_ERR_IAP_STORE_NO_CONNECTION
PRL_ERR_IAP_STORE_NO_CONNECTION macro
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMAGE_NEED_TO_CONVERT macro
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_IMPERSONATE_FAILED macro
PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED
PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED macro
PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE
PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE macro
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCONSISTENCY_VM_CONFIG macro
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_CDROM_PATH macro
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_FDD_PATH macro
PRL_ERR_INCORRECT_PATH
PRL_ERR_INCORRECT_PATH macro
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSERTING_VM_TO_CATALOGUE macro
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INSTALLATION_PROBLEM macro
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED macro
PRL_ERR_INVALID_ACTION_REQUESTED
PRL_ERR_INVALID_ACTION_REQUESTED macro
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_ARG macro
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_CONFIGURATION macro
PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS
PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS macro
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HANDLE macro
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_HDD_GEOMETRY macro
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED macro
PRL_ERR_INVALID_MEMORY_GUARANTEE
PRL_ERR_INVALID_MEMORY_GUARANTEE macro
PRL_ERR_INVALID_MEMORY_QUOTA
PRL_ERR_INVALID_MEMORY_QUOTA macro
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_MEMORY_SIZE macro
PRL_ERR_INVALID_OS_TYPE
PRL_ERR_INVALID_OS_TYPE macro
PRL_ERR_INVALID_PARALLELS_DISK
PRL_ERR_INVALID_PARALLELS_DISK macro
PRL_ERR_INVALID_PARAM
PRL_ERR_INVALID_PARAM macro
PRL_ERR_INVALID_TOTAL_LIMIT
PRL_ERR_INVALID_TOTAL_LIMIT macro
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_AUTHENTICATION_FAILED macro
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_CONNECTION_TIMEOUT macro
PRL_ERR_IO_DISABLED
PRL_ERR_IO_DISABLED macro
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_INVALID_POINTER_ACCESS macro
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_NO_CONNECTION macro
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_SEND_QUEUE_IS_FULL macro
PRL_ERR_IO_STOPPED
PRL_ERR_IO_STOPPED macro
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IO_UNKNOWN_VM_ID macro
PRL_ERR_IOSERVICE_COMPRESS
PRL_ERR_IOSERVICE_COMPRESS macro
PRL_ERR_IPC_ATTACH_FAILED
PRL_ERR_IPC_ATTACH_FAILED macro
PRL_ERR_IPC_CREATE_MAP_FAILED
PRL_ERR_IPC_CREATE_MAP_FAILED macro
PRL_ERR_IPC_FTOK_FAILED
PRL_ERR_IPC_FTOK_FAILED macro
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_INVALID_MODE macro
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_RECEIVE_FAILED macro
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SEND_FAILED macro
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED macro
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED macro
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED macro
PRL_ERR_IPFO_SOCKET_CREATE_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED macro
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED macro
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPFO_SOCKET_NOT_OPENED macro
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED macro
PRL_ERR_IPHONE_PROXY_CANNOT_START
PRL_ERR_IPHONE_PROXY_CANNOT_START macro
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_IPHONE_PROXY_CANNOT_STOP macro
PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED
PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED macro
PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT
PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT macro
PRL_ERR_ISCSI_STORAGE_CREATE
PRL_ERR_ISCSI_STORAGE_CREATE macro
PRL_ERR_ISCSI_STORAGE_EXTEND
PRL_ERR_ISCSI_STORAGE_EXTEND macro
PRL_ERR_ISCSI_STORAGE_GET_STATE
PRL_ERR_ISCSI_STORAGE_GET_STATE macro
PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE
PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE macro
PRL_ERR_ISCSI_STORAGE_LIBRARY
PRL_ERR_ISCSI_STORAGE_LIBRARY macro
PRL_ERR_ISCSI_STORAGE_MOUNT
PRL_ERR_ISCSI_STORAGE_MOUNT macro
PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS
PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS macro
PRL_ERR_ISCSI_STORAGE_MOUNTED
PRL_ERR_ISCSI_STORAGE_MOUNTED macro
PRL_ERR_ISCSI_STORAGE_NOT_FOUND
PRL_ERR_ISCSI_STORAGE_NOT_FOUND macro
PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED
PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED macro
PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED
PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED macro
PRL_ERR_ISCSI_STORAGE_REMOVE
PRL_ERR_ISCSI_STORAGE_REMOVE macro
PRL_ERR_ISCSI_STORAGE_START
PRL_ERR_ISCSI_STORAGE_START macro
PRL_ERR_ISCSI_STORAGE_UMOUNT
PRL_ERR_ISCSI_STORAGE_UMOUNT macro
PRL_ERR_IT_CANT_COMPACT
PRL_ERR_IT_CANT_COMPACT macro
PRL_ERR_IT_CANT_COMPACT_LDM_DISK
PRL_ERR_IT_CANT_COMPACT_LDM_DISK macro
PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK
PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK macro
PRL_ERR_IT_CANT_GET_BITMAP
PRL_ERR_IT_CANT_GET_BITMAP macro
PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE
PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE macro
PRL_ERR_IT_CANT_OPEN_IMAGE
PRL_ERR_IT_CANT_OPEN_IMAGE macro
PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA
PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA macro
PRL_ERR_IT_CANT_RECONFIG
PRL_ERR_IT_CANT_RECONFIG macro
PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP
PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP macro
PRL_ERR_IT_CANT_RESIZE_LDM_DISK
PRL_ERR_IT_CANT_RESIZE_LDM_DISK macro
PRL_ERR_IT_CANT_RESIZE_VOLUME
PRL_ERR_IT_CANT_RESIZE_VOLUME macro
PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP
PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP macro
PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR
PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR macro
PRL_ERR_IT_DISK_SMALL_FOR_SPLIT
PRL_ERR_IT_DISK_SMALL_FOR_SPLIT macro
PRL_ERR_IT_FAST_RESIZE_FAILURE
PRL_ERR_IT_FAST_RESIZE_FAILURE macro
PRL_ERR_IT_FIRST_ERROR
PRL_ERR_IT_FIRST_ERROR macro
PRL_ERR_IT_FIRST_FAILURE
PRL_ERR_IT_FIRST_FAILURE macro
PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE
PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE macro
PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE
PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE macro
PRL_ERR_IT_HAL_NOT_FOUND
PRL_ERR_IT_HAL_NOT_FOUND macro
PRL_ERR_IT_RECONFIG_PATH_NEEDED
PRL_ERR_IT_RECONFIG_PATH_NEEDED macro
PRL_ERR_IT_ROLLBACK_FAILURE
PRL_ERR_IT_ROLLBACK_FAILURE macro
PRL_ERR_IT_SIZE_CHANGED
PRL_ERR_IT_SIZE_CHANGED macro
PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED
PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED macro
PRL_ERR_IT_UNKNOWN_OS
PRL_ERR_IT_UNKNOWN_OS macro
PRL_ERR_IT_USER_INTERRUPTED
PRL_ERR_IT_USER_INTERRUPTED macro
PRL_ERR_LIC_REGISTRATION_COMMON_ERROR
PRL_ERR_LIC_REGISTRATION_COMMON_ERROR macro
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_AUTH_FAILED macro
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT macro
PRL_ERR_LICENSE_BLACKLISTED
PRL_ERR_LICENSE_BLACKLISTED macro
PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION
PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION macro
PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND
PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND macro
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_EXPIRED macro
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_FILE_WRITE_FAILED macro
PRL_ERR_LICENSE_GRACED
PRL_ERR_LICENSE_GRACED macro
PRL_ERR_LICENSE_IS_NOT_VOLUME
PRL_ERR_LICENSE_IS_NOT_VOLUME macro
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_STARTED macro
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_NOT_VALID macro
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT macro
PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT
PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT macro
PRL_ERR_LICENSE_RESTRICTED_GUEST_OS
PRL_ERR_LICENSE_RESTRICTED_GUEST_OS macro
PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE macro
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE
PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE macro
PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM
PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM
PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT macro
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER
PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER macro
PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE macro
PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE macro
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE macro
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE macro
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE macro
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH
PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH macro
PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM
PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM macro
PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE
PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE macro
PRL_ERR_LICENSE_TOO_MANY_MEMORY
PRL_ERR_LICENSE_TOO_MANY_MEMORY macro
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_TOO_MANY_VCPUS macro
PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION
PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION macro
PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE
PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE macro
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE macro
PRL_ERR_LICENSE_VALID
PRL_ERR_LICENSE_VALID macro
PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES
PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES macro
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD macro
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR macro
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_LANGUAGE macro
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PLATFORM macro
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_PRODUCT macro
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LICENSE_WRONG_VERSION macro
PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM
PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM macro
PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM
PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM macro
PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND
PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND macro
PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE
PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE macro
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LOCAL_AUTHENTICATION_FAILED macro
PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE
PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE macro
PRL_ERR_LOW_MEMORY_LIMIT
PRL_ERR_LOW_MEMORY_LIMIT macro
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_DEVICE_ALREADY_EXIST macro
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED macro
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST macro
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH macro
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_INCORRECT macro
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_IS_EMPTY macro
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START macro
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS macro
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS macro
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_MAKE_DIRECTORY macro
PRL_ERR_MEM_EXCEED_PHY_SPACE
PRL_ERR_MEM_EXCEED_PHY_SPACE macro
PRL_ERR_MEMFILE_DECRYPT_FAILED
PRL_ERR_MEMFILE_DECRYPT_FAILED macro
PRL_ERR_MEMFILE_ENCRYPT_FAILED
PRL_ERR_MEMFILE_ENCRYPT_FAILED macro
PRL_ERR_MEMORY_ALLOC_ERROR
PRL_ERR_MEMORY_ALLOC_ERROR macro
PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT
PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT macro
PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE
PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE macro
PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED
PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED macro
PRL_ERR_MOUNTER_LIST_NO_OBJECT
PRL_ERR_MOUNTER_LIST_NO_OBJECT macro
PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST
PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST macro
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NEED_KILL_PREV_SETTING macro
PRL_ERR_NETWORK_ADAPTER_NOT_FOUND
PRL_ERR_NETWORK_ADAPTER_NOT_FOUND macro
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NETWORK_ROLLBACK_FAILED macro
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED macro
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_CD_DRIVE_AVAILABLE macro
PRL_ERR_NO_DATA
PRL_ERR_NO_DATA macro
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_DISP_CONFIG_FOUND macro
PRL_ERR_NO_GUEST_OS_FOUND
PRL_ERR_NO_GUEST_OS_FOUND macro
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS macro
PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS
PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS macro
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_PROBLEM_REPORT_FOUND macro
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED macro
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED macro
PRL_ERR_NO_UNATTENDED_DISK
PRL_ERR_NO_UNATTENDED_DISK macro
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NO_VM_DIR_CONFIG_FOUND macro
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_ALL_FILES_WAS_DELETED macro
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER macro
PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER
PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER macro
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE macro
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE macro
PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE
PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE macro
PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK
PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK macro
PRL_ERR_NOT_SENTILLION_CLIENT
PRL_ERR_NOT_SENTILLION_CLIENT macro
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_NVRAM_FILE_COPY macro
PRL_ERR_OBJECT_BAD_INTERFACE
PRL_ERR_OBJECT_BAD_INTERFACE macro
PRL_ERR_OBJECT_CLASS_NOT_FOUND
PRL_ERR_OBJECT_CLASS_NOT_FOUND macro
PRL_ERR_OBJECT_DUPLICATE_CLASS
PRL_ERR_OBJECT_DUPLICATE_CLASS macro
PRL_ERR_OBJECT_DUPLICATE_UID
PRL_ERR_OBJECT_DUPLICATE_UID macro
PRL_ERR_OBJECT_LIB_CANT_GET_PERMS
PRL_ERR_OBJECT_LIB_CANT_GET_PERMS macro
PRL_ERR_OBJECT_LIB_LOAD_ERROR
PRL_ERR_OBJECT_LIB_LOAD_ERROR macro
PRL_ERR_OBJECT_LIB_NO_FUNCTIONS
PRL_ERR_OBJECT_LIB_NO_FUNCTIONS macro
PRL_ERR_OBJECT_LIB_WRONG_PERMS
PRL_ERR_OBJECT_LIB_WRONG_PERMS macro
PRL_ERR_OBJECT_NOT_FOUND
PRL_ERR_OBJECT_NOT_FOUND macro
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_OBJECT_WAS_REMOVED macro
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT macro
PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING
PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING macro
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION macro
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_READ macro
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_DISP_CONFIG_WRITE macro
PRL_ERR_OPEN_FAILED
PRL_ERR_OPEN_FAILED macro
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_PROBLEM_REPORT_READ macro
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_READ macro
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_CONFIG_WRITE macro
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_READ macro
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE macro
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_FAILED macro
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_PENDING macro
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OPERATION_WAS_CANCELED macro
PRL_ERR_OS_RECONFIG_DATA_ABSENT
PRL_ERR_OS_RECONFIG_DATA_ABSENT macro
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_DISK_SPACE macro
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_OUT_OF_MEMORY macro
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST macro
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARALLEL_PORT_IMG_COPY macro
PRL_ERR_PARALLEL_PORT_NO_RASTERIZER
PRL_ERR_PARALLEL_PORT_NO_RASTERIZER macro
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARAM_NOT_FOUND macro
PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST
PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST macro
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_CLIENT_PREFS macro
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS macro
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_DISP_CONFIG macro
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_FILESYSTEM_INFO macro
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO macro
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO macro
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_PROBLEM_REPORT macro
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_STATISTICS macro
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_USER_PROFILE macro
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_CONFIG macro
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG macro
PRL_ERR_PARSING_EVENT
PRL_ERR_PARSING_EVENT macro
PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED
PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED macro
PRL_ERR_PATH_IS_NOT_DIRECTORY
PRL_ERR_PATH_IS_NOT_DIRECTORY macro
PRL_ERR_PAX_ACCESS_FORBIDDEN
PRL_ERR_PAX_ACCESS_FORBIDDEN macro
PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED
PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED macro
PRL_ERR_PAX_LOGIN_MISMATCH_ERROR
PRL_ERR_PAX_LOGIN_MISMATCH_ERROR macro
PRL_ERR_PCMOVER_EXEC_FAILED
PRL_ERR_PCMOVER_EXEC_FAILED macro
PRL_ERR_PCMOVER_MIGRATE_FAILED
PRL_ERR_PCMOVER_MIGRATE_FAILED macro
PRL_ERR_PCMOVER_NOT_INSTALLED
PRL_ERR_PCMOVER_NOT_INSTALLED macro
PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR macro
PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR
PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR macro
PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR
PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR macro
PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR
PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR macro
PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED
PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED macro
PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST
PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST macro
PRL_ERR_PERFORM_MOUNTER_COMMAND
PRL_ERR_PERFORM_MOUNTER_COMMAND macro
PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE
PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE macro
PRL_ERR_PPC_INVALID_CREDENTIALS
PRL_ERR_PPC_INVALID_CREDENTIALS macro
PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT
PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT macro
PRL_ERR_PPC_SERVER_BUSY
PRL_ERR_PPC_SERVER_BUSY macro
PRL_ERR_PPC_UNABLE_TO_CONNECT
PRL_ERR_PPC_UNABLE_TO_CONNECT macro
PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN
PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN macro
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY macro
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS macro
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE
PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE macro
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PREV_SESSION_IS_ACTIVE macro
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS macro
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET macro
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_PROBLEM_REPORT_WRITE macro
PRL_ERR_PROXY_HANDSHAKE_FAILED
PRL_ERR_PROXY_HANDSHAKE_FAILED macro
PRL_ERR_PROXY_PEER_NOT_FOUND
PRL_ERR_PROXY_PEER_NOT_FOUND macro
PRL_ERR_PROXY_WRONG_PORT_NUMBER
PRL_ERR_PROXY_WRONG_PORT_NUMBER macro
PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION
PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION macro
PRL_ERR_RCC_CONNECT_DESKTOP_ERROR
PRL_ERR_RCC_CONNECT_DESKTOP_ERROR macro
PRL_ERR_RCC_CONNECT_SERVER_ERROR
PRL_ERR_RCC_CONNECT_SERVER_ERROR macro
PRL_ERR_RCC_DESKTOP_SUSPENDED
PRL_ERR_RCC_DESKTOP_SUSPENDED macro
PRL_ERR_RCC_DEVICE_BLACKLISTED
PRL_ERR_RCC_DEVICE_BLACKLISTED macro
PRL_ERR_RCC_DEVICE_GREYLISTED
PRL_ERR_RCC_DEVICE_GREYLISTED macro
PRL_ERR_RCC_OPEN_APP_ERROR
PRL_ERR_RCC_OPEN_APP_ERROR macro
PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED
PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED macro
PRL_ERR_RCC_PAX_LOGIN_ERROR
PRL_ERR_RCC_PAX_LOGIN_ERROR macro
PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED
PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED macro
PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE
PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE macro
PRL_ERR_RCC_WAKEUP_SERVER_ERROR
PRL_ERR_RCC_WAKEUP_SERVER_ERROR macro
PRL_ERR_READ_FAILED
PRL_ERR_READ_FAILED macro
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READ_XML_CONTENT macro
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_READONLY_FILESYSTEM macro
PRL_ERR_REBOOT_HOST
PRL_ERR_REBOOT_HOST macro
PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS
PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS macro
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_EXIST macro
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST macro
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED macro
PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD macro
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED macro
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER macro
PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS
PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS macro
PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM
PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM macro
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETRIEVE_VM_CONFIG macro
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_RETURN_CODE_RANG_EEND macro
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_REVERT_IMPERSONATE_FAILED macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS macro
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
PRL_ERR_RUN_VM_ACTION_SCRIPT
PRL_ERR_RUN_VM_ACTION_SCRIPT macro
PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC
PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC macro
PRL_ERR_SAMPLE_CONFIG_NOT_FOUND
PRL_ERR_SAMPLE_CONFIG_NOT_FOUND macro
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CATALOG macro
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SAVE_VM_CONFIG macro
PRL_ERR_SDK_TRY_AGAIN
PRL_ERR_SDK_TRY_AGAIN macro
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED macro
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SEND_COMMAND_TOWS_FAILED macro
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_COPY macro
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_IMG_NOT_FOUND macro
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST macro
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_GOES_DOWN macro
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SERVER_PREFS_EDIT_COLLISION macro
PRL_ERR_SERVICE_BUSY
PRL_ERR_SERVICE_BUSY macro
PRL_ERR_SET_CPULIMIT
PRL_ERR_SET_CPULIMIT macro
PRL_ERR_SET_CPUMASK
PRL_ERR_SET_CPUMASK macro
PRL_ERR_SET_CPUUNITS
PRL_ERR_SET_CPUUNITS macro
PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED
PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED macro
PRL_ERR_SET_IOLIMIT
PRL_ERR_SET_IOLIMIT macro
PRL_ERR_SET_IOPRIO
PRL_ERR_SET_IOPRIO macro
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_ARG macro
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SET_LICENSE_INVALID_KEY macro
PRL_ERR_SET_NETWORK_SETTINGS_FAILED
PRL_ERR_SET_NETWORK_SETTINGS_FAILED macro
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE macro
PRL_ERR_SMC_ERROR
PRL_ERR_SMC_ERROR macro
PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED
PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED macro
PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT
PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT macro
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SNAPSHOTS_COPY macro
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_TASKS_PRESENT macro
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOME_VMS_RUNNING macro
PRL_ERR_SOUND_BAD_EMULATION_TYPE
PRL_ERR_SOUND_BAD_EMULATION_TYPE macro
PRL_ERR_SOUND_DEVICE_WRITE_FAILED
PRL_ERR_SOUND_DEVICE_WRITE_FAILED macro
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED macro
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED macro
PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK
PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK macro
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED macro
PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT macro
PRL_ERR_STAND_BY_VM_PAUSED
PRL_ERR_STAND_BY_VM_PAUSED macro
PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL macro
PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL macro
PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
PRL_ERR_START_SAFE_MODE_UNSUPPORTED
PRL_ERR_START_SAFE_MODE_UNSUPPORTED macro
PRL_ERR_START_VM_BY_NOT_AUTH_USER
PRL_ERR_START_VM_BY_NOT_AUTH_USER macro
PRL_ERR_START_VM_BY_NOT_DEFINED_USER
PRL_ERR_START_VM_BY_NOT_DEFINED_USER macro
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_ALREADY_EXISTS macro
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG macro
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE macro
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_IMAGE macro
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_OPEN_LOCKED macro
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED macro
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_DELETE_NONCLOSED macro
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_CREATE_IMAGE macro
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE macro
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_FULL_DELETE_FAILED macro
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED macro
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INT_CORRUPTED macro
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_IMAGE_TYPE macro
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_INVALID_PARAMETERS macro
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MEMORY_ERROR macro
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_FAILED macro
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_MERGE_NO_SPACE macro
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_DISKS macro
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NO_STATE macro
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_OPENED macro
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_PERMITTED macro
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_NOT_RELEASED macro
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_PROCESS_RUNNING macro
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_ERROR macro
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS macro
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STATFS_FAILED macro
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_STOPPING_STATE macro
PRL_ERR_STATE_UNEXPECTED_ERROR
PRL_ERR_STATE_UNEXPECTED_ERROR macro
PRL_ERR_SUCCESS
PRL_ERR_SUCCESS macro
PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK
PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK macro
PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED
PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED macro
PRL_ERR_SUSPEND_REJECTED_BY_GUEST
PRL_ERR_SUSPEND_REJECTED_BY_GUEST macro
PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT
PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT macro
PRL_ERR_SUSPEND_VM_VTD_PAUSED
PRL_ERR_SUSPEND_VM_VTD_PAUSED macro
PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL macro
PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL macro
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS macro
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
PRL_ERR_SUSPEND_WITH_USB_BOOTDISK
PRL_ERR_SUSPEND_WITH_USB_BOOTDISK macro
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_SYMBOL_NOT_FOUND macro
PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED
PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED macro
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED macro
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY macro
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TASK_NOT_FOUND macro
PRL_ERR_TEMPLATE_HAS_APPS
PRL_ERR_TEMPLATE_HAS_APPS macro
PRL_ERR_TEMPLATE_NOT_FOUND
PRL_ERR_TEMPLATE_NOT_FOUND macro
PRL_ERR_TEST_TEXT_MESSAGES
PRL_ERR_TEST_TEXT_MESSAGES macro
PRL_ERR_TEST_TEXT_MESSAGES_PS
PRL_ERR_TEST_TEXT_MESSAGES_PS macro
PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP
PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP macro
PRL_ERR_TIMEOUT
PRL_ERR_TIMEOUT macro
PRL_ERR_TIS_INVALID_UID
PRL_ERR_TIS_INVALID_UID macro
PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOO_LOW_HDD_SIZE macro
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TOOLS_UNSUPPORTED_GUEST macro
PRL_ERR_TRY_AGAIN
PRL_ERR_TRY_AGAIN macro
PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE
PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE macro
PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT
PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT macro
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE macro
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNABLE_SEND_REQUEST macro
PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS
PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS macro
PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION macro
PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION
PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION macro
PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED
PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED macro
PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM
PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM macro
PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM macro
PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM macro
PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM macro
PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM
PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM macro
PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION
PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION macro
PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE
PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE macro
PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM
PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM macro
PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED
PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED macro
PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD
PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD macro
PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION
PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION macro
PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION
PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION macro
PRL_ERR_UNABLE_TO_SEND_REQUEST
PRL_ERR_UNABLE_TO_SEND_REQUEST macro
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE macro
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER
PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER macro
PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED
PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED macro
PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST
PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST macro
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNDER_OLD_HYPERVISOR macro
PRL_ERR_UNEXPECTED
PRL_ERR_UNEXPECTED macro
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNIMPLEMENTED macro
PRL_ERR_UNINITIALIZED
PRL_ERR_UNINITIALIZED macro
PRL_ERR_UNNAMED_CT_MOVE
PRL_ERR_UNNAMED_CT_MOVE macro
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNRECOGNIZED_REQUEST macro
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_DEVICE_TYPE macro
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_FILE_SYSTEM macro
PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE
PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE macro
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM macro
PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE
PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE macro
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED macro
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED macro
PRL_ERR_UPD_UPDATER_CONFIG
PRL_ERR_UPD_UPDATER_CONFIG macro
PRL_ERR_UPD_UPDATES
PRL_ERR_UPD_UPDATES macro
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED macro
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE macro
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART macro
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE macro
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_DIRECTORY_NOT_SET macro
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_IS_ALREADY_LOGGED macro
PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR
PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR macro
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR macro
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS macro
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM macro
PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES
PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES macro
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES macro
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_NOT_FOUND macro
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_OPERATION_NOT_AUTHORISED macro
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_USER_PROFILE_WAS_CHANGED macro
PRL_ERR_VA_CONFIG
PRL_ERR_VA_CONFIG macro
PRL_ERR_VM_ABORT
PRL_ERR_VM_ABORT macro
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED macro
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALLOC_VM_MEMORY macro
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CONNECTED macro
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_CREATED macro
PRL_ERR_VM_ALREADY_ENCRYPTED
PRL_ERR_VM_ALREADY_ENCRYPTED macro
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED macro
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID macro
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RESUMED macro
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_RUNNING macro
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ALREADY_SUSPENDED macro
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE macro
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CHANGES_PENDING macro
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_FAILED macro
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT macro
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR macro
PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN
PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN macro
PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE macro
PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE
PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE macro
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_BAD_OS_TYPE macro
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_HDD_MISSING macro
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_CLONE_RUNNING macro
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING macro
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING macro
PRL_ERR_VM_COMPACT_HARD_DISK_FAILED
PRL_ERR_VM_COMPACT_HARD_DISK_FAILED macro
PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS
PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS macro
PRL_ERR_VM_COMPACT_PROCESSING
PRL_ERR_VM_COMPACT_PROCESSING macro
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG macro
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED macro
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED macro
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV macro
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_ALREADY_EXISTS macro
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED macro
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_DOESNT_EXIST macro
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID macro
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID macro
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID macro
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_CONFIG_WAS_CHANGED macro
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER macro
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG macro
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE macro
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_INVALID_ARG macro
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED macro
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED macro
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED macro
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED macro
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED macro
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED macro
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED macro
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS macro
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIR_FILE_NOT_SET macro
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST macro
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST macro
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED macro
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DOES_NOT_STOPPED macro
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED macro
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS macro
PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE
PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE macro
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE macro
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE macro
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE macro
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE macro
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND macro
PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED
PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED macro
PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED
PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED macro
PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE
PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE macro
PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE
PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE macro
PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD
PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD macro
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FILES_ALREADY_REMOVED macro
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_FREE_VM_MEMORY macro
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_FAILED macro
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_INVALID_ARG macro
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED macro
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED macro
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG macro
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN macro
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG macro
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED macro
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING macro
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED macro
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED macro
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED macro
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING macro
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_FAILED macro
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GET_STATUS_INVALID_ARG macro
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUEST_SESSION_EXPIRED macro
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_GUESTMEM_FAIL macro
PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE
PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE macro
PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED macro
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HDD_SIZE macro
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY macro
PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH
PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH macro
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_HYPERVIZOR_COMM macro
PRL_ERR_VM_IN_FROZEN_STATE
PRL_ERR_VM_IN_FROZEN_STATE macro
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_IN_HDD_CONSTRUCTOR macro
PRL_ERR_VM_IN_WAKING_UP_STATE
PRL_ERR_VM_IN_WAKING_UP_STATE macro
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_MONITOR macro
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INIT_VCPU macro
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERACT_PRLS_DRIVER macro
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INTERNAL_OS_ERROR macro
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_INVALID_SWAP_REGION macro
PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED
PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED macro
PRL_ERR_VM_IS_NOT_LOCKED
PRL_ERR_VM_IS_NOT_LOCKED macro
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_IS_NOT_SUSPENDED macro
PRL_ERR_VM_LIFETIME_IS_EXPIRED
PRL_ERR_VM_LIFETIME_IS_EXPIRED macro
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_BINARY_FAILED macro
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOAD_MONITOR macro
PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP
PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP macro
PRL_ERR_VM_LOCKED_FOR_BACKUP
PRL_ERR_VM_LOCKED_FOR_BACKUP macro
PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL
PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL macro
PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD
PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD macro
PRL_ERR_VM_LOCKED_FOR_CLONE
PRL_ERR_VM_LOCKED_FOR_CLONE macro
PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE
PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE macro
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_DECRYPT
PRL_ERR_VM_LOCKED_FOR_DECRYPT macro
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE macro
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT
PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT macro
PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT
PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT macro
PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE
PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE macro
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT macro
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME macro
PRL_ERR_VM_LOCKED_FOR_ENCRYPT
PRL_ERR_VM_LOCKED_FOR_ENCRYPT macro
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE macro
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX macro
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON macro
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_MIGRATE macro
PRL_ERR_VM_LOCKED_FOR_MOVE
PRL_ERR_VM_LOCKED_FOR_MOVE macro
PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION
PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION macro
PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP
PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP macro
PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION
PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION macro
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UNREGISTER macro
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY macro
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MAP_VM_MEM0 macro
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS macro
PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED
PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED macro
PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION
PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION macro
PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY
PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY macro
PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM
PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM macro
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED macro
PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED
PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED macro
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION macro
PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE
PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE macro
PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM
PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM macro
PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM
PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM macro
PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED
PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED macro
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE
PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE macro
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET macro
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET macro
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED
PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED macro
PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED
PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED macro
PRL_ERR_VM_MIGRATE_RESUME_FAILED
PRL_ERR_VM_MIGRATE_RESUME_FAILED macro
PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED
PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED macro
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE
PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE macro
PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED
PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED macro
PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE
PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE macro
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS macro
PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE
PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE macro
PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE
PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE macro
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET macro
PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED
PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED macro
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MONITOR macro
PRL_ERR_VM_MOUNT
PRL_ERR_VM_MOUNT macro
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING macro
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES macro
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NAME_IS_EMPTY macro
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_NOT_CREATED macro
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_OPERATION_FAILED macro
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED macro
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_FAILED macro
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_CREATED macro
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_PAUSE_NOT_STARTED macro
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_OFF_FAILED macro
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_POWER_ON_FAILED macro
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM macro
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_PROCESS_IS_NOT_STARTED macro
PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW
PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW macro
PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY
PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY macro
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED macro
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESET_FAILED macro
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED macro
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_CREATED macro
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTART_NOT_STARTED macro
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESTORE_STATE_FAILED macro
PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED
PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED macro
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_FAILED macro
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME macro
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SAVE_STATE_FAILED macro
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED macro
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING macro
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED macro
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED macro
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING macro
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_PAUSED macro
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED macro
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING macro
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED macro
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_FAILED macro
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_CONFIG_INVALID_ARG macro
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_LICENSE_FAILED macro
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED macro
PRL_ERR_VM_SHUTDOWN_FAILED
PRL_ERR_VM_SHUTDOWN_FAILED macro
PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED macro
PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED
PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED macro
PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED
PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED macro
PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED
PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED macro
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG macro
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE macro
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE macro
PRL_ERR_VM_SNAPSHOT_NOT_FOUND
PRL_ERR_VM_SNAPSHOT_NOT_FOUND macro
PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND
PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND macro
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES macro
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_FAILED macro
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CONFIGURED macro
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_START_NOT_CREATED macro
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED macro
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG macro
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_SUSPEND_FAILED macro
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED macro
PRL_ERR_VM_TOOL_NOT_AVAILABLE
PRL_ERR_VM_TOOL_NOT_AVAILABLE macro
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS macro
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART macro
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM macro
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR macro
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_CREATE_TIMER macro
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_GET_GUEST_CPU macro
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE macro
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_SEND_REQUEST macro
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE macro
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UNDEFINED_API_CALL macro
PRL_ERR_VM_UNMOUNT
PRL_ERR_VM_UNMOUNT macro
PRL_ERR_VM_UNPAUSE_FAILED
PRL_ERR_VM_UNPAUSE_FAILED macro
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED macro
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED macro
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_EMPTY macro
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_UUID_NOT_FOUND macro
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_MON_BODY macro
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VALLOC_PE_IMG macro
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG macro
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_CREATED macro
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING macro
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN macro
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS macro
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE macro
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME macro
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET macro
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS macro
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME macro
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT macro
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT macro
PRL_ERR_VMCONF_CPU_MASK_INVALID
PRL_ERR_VMCONF_CPU_MASK_INVALID macro
PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM
PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM macro
PRL_ERR_VMCONF_CPU_ZERO_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT macro
PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED macro
PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED
PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED macro
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES macro
PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS macro
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID macro
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE macro
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME macro
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED macro
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM macro
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED macro
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND macro
PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME macro
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE macro
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE macro
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT
PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT macro
PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE
PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE macro
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME macro
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID macro
PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION macro
PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK
PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK macro
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET macro
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS
PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS macro
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS
PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS macro
PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME macro
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION macro
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM
PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM macro
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE macro
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX macro
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW macro
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX macro
PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED macro
PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED macro
PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED
PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED macro
PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT
PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT macro
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE macro
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE macro
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE macro
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE macro
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO
PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO macro
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE macro
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE macro
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX macro
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED macro
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE macro
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART macro
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP macro
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT
PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET
PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE
PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS macro
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD macro
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS
PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS macro
PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS
PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS macro
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE macro
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE macro
PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT
PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT macro
PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS
PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS macro
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME macro
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD
PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG
PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO macro
PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT
PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT macro
PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE
PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE macro
PRL_ERR_VMCONF_RESTRICTED_OS_VERSION
PRL_ERR_VMCONF_RESTRICTED_OS_VERSION macro
PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD
PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD macro
PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS
PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS macro
PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE macro
PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX macro
PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED
PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED macro
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE macro
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX macro
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME
PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME macro
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME macro
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH macro
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME macro
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH macro
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY macro
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY macro
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE macro
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION macro
PRL_ERR_VMCONF_VALIDATION_FAILED
PRL_ERR_VMCONF_VALIDATION_FAILED macro
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE macro
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX macro
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED
PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED macro
PRL_ERR_VMCONF_VIDEO_NOT_ENABLED
PRL_ERR_VMCONF_VIDEO_NOT_ENABLED macro
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY macro
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_INVALID_PATH macro
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE macro
PRL_ERR_VMHELPER_CREATEVM_FAILED
PRL_ERR_VMHELPER_CREATEVM_FAILED macro
PRL_ERR_VMHELPER_DIR_PATH_INVALID
PRL_ERR_VMHELPER_DIR_PATH_INVALID macro
PRL_ERR_VMHELPER_DISK_MOUNT_FAILED
PRL_ERR_VMHELPER_DISK_MOUNT_FAILED macro
PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED
PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED macro
PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED
PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED macro
PRL_ERR_VNC_SERVER_ALREADY_STARTED
PRL_ERR_VNC_SERVER_ALREADY_STARTED macro
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED macro
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_DISABLED macro
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VNC_SERVER_NOT_STARTED macro
PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT
PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT macro
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED macro
PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST
PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST macro
PRL_ERR_VTD_DEVICE_NOT_MAPPED
PRL_ERR_VTD_DEVICE_NOT_MAPPED macro
PRL_ERR_VTD_DEVICE_TROUBLESHOOT
PRL_ERR_VTD_DEVICE_TROUBLESHOOT macro
PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT
PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT macro
PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT
PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT macro
PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE
PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE macro
PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_FAILED macro
PRL_ERR_VTD_HOOK_INSTALLATION_FAILED
PRL_ERR_VTD_HOOK_INSTALLATION_FAILED macro
PRL_ERR_VTD_HOOK_INVALID_CONFIG
PRL_ERR_VTD_HOOK_INVALID_CONFIG macro
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED macro
PRL_ERR_VTD_HOOK_REVERT_FAILED
PRL_ERR_VTD_HOOK_REVERT_FAILED macro
PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE
PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE macro
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED macro
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTD_WAIT_ASR macro
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX macro
PRL_ERR_VZ_API_NOT_INITIALIZED
PRL_ERR_VZ_API_NOT_INITIALIZED macro
PRL_ERR_VZ_OPERATION_FAILED
PRL_ERR_VZ_OPERATION_FAILED macro
PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND
PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND macro
PRL_ERR_VZCTL_OPERATION_FAILED
PRL_ERR_VZCTL_OPERATION_FAILED macro
PRL_ERR_VZLICENSE_ACTIVATION_KEY
PRL_ERR_VZLICENSE_ACTIVATION_KEY macro
PRL_ERR_VZLICENSE_CANCEL
PRL_ERR_VZLICENSE_CANCEL macro
PRL_ERR_VZLICENSE_EACCES
PRL_ERR_VZLICENSE_EACCES macro
PRL_ERR_VZLICENSE_ERR_KA
PRL_ERR_VZLICENSE_ERR_KA macro
PRL_ERR_VZLICENSE_EXIST
PRL_ERR_VZLICENSE_EXIST macro
PRL_ERR_VZLICENSE_FATAL
PRL_ERR_VZLICENSE_FATAL macro
PRL_ERR_VZLICENSE_INVAL
PRL_ERR_VZLICENSE_INVAL macro
PRL_ERR_VZLICENSE_INVALID_HWID
PRL_ERR_VZLICENSE_INVALID_HWID macro
PRL_ERR_VZLICENSE_IO
PRL_ERR_VZLICENSE_IO macro
PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED
PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED macro
PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH
PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH macro
PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED
PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED macro
PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET
PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET macro
PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED
PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED macro
PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE
PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE macro
PRL_ERR_VZLICENSE_LOCK
PRL_ERR_VZLICENSE_LOCK macro
PRL_ERR_VZLICENSE_NETWORK
PRL_ERR_VZLICENSE_NETWORK macro
PRL_ERR_VZLICENSE_NODATA
PRL_ERR_VZLICENSE_NODATA macro
PRL_ERR_VZLICENSE_NOENT
PRL_ERR_VZLICENSE_NOENT macro
PRL_ERR_VZLICENSE_NOINIT
PRL_ERR_VZLICENSE_NOINIT macro
PRL_ERR_VZLICENSE_NOMEM
PRL_ERR_VZLICENSE_NOMEM macro
PRL_ERR_VZLICENSE_NOTSUP
PRL_ERR_VZLICENSE_NOTSUP macro
PRL_ERR_VZLICENSE_PROXY
PRL_ERR_VZLICENSE_PROXY macro
PRL_ERR_VZLICENSE_PROXY_AUTH
PRL_ERR_VZLICENSE_PROXY_AUTH macro
PRL_ERR_VZLICENSE_TASK_ALREADY_RUN
PRL_ERR_VZLICENSE_TASK_ALREADY_RUN macro
PRL_ERR_VZLICENSE_TIMEOUT
PRL_ERR_VZLICENSE_TIMEOUT macro
PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE macro
PRL_ERR_VZLICENSE_UNSUPPORTED_MODE
PRL_ERR_VZLICENSE_UNSUPPORTED_MODE macro
PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP
PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP macro
PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED
PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED macro
PRL_ERR_VZLICENSE_WRONG
PRL_ERR_VZLICENSE_WRONG macro
PRL_ERR_WEB_PORTAL_ACCEPTED
PRL_ERR_WEB_PORTAL_ACCEPTED macro
PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS
PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS macro
PRL_ERR_WEB_PORTAL_BAD_REQUEST
PRL_ERR_WEB_PORTAL_BAD_REQUEST macro
PRL_ERR_WEB_PORTAL_CONFLICT
PRL_ERR_WEB_PORTAL_CONFLICT macro
PRL_ERR_WEB_PORTAL_CREATED
PRL_ERR_WEB_PORTAL_CREATED macro
PRL_ERR_WEB_PORTAL_FORBIDDEN
PRL_ERR_WEB_PORTAL_FORBIDDEN macro
PRL_ERR_WEB_PORTAL_INVALID_EMAIL
PRL_ERR_WEB_PORTAL_INVALID_EMAIL macro
PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS
PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS macro
PRL_ERR_WEB_PORTAL_INVALID_PASSWORD
PRL_ERR_WEB_PORTAL_INVALID_PASSWORD macro
PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR
PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR macro
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED macro
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED
PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED macro
PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID macro
PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID macro
PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE
PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE macro
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED macro
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED macro
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID macro
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED
PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED macro
PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID
PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID macro
PRL_ERR_WEB_PORTAL_NO_CONTENT
PRL_ERR_WEB_PORTAL_NO_CONTENT macro
PRL_ERR_WEB_PORTAL_NOT_FOUND
PRL_ERR_WEB_PORTAL_NOT_FOUND macro
PRL_ERR_WEB_PORTAL_OK
PRL_ERR_WEB_PORTAL_OK macro
PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE macro
PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED
PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED macro
PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT
PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT macro
PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL
PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL macro
PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA
PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA macro
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE macro
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE
PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE macro
PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT
PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT macro
PRL_ERR_WEB_PORTAL_UNAUTHORIZED
PRL_ERR_WEB_PORTAL_UNAUTHORIZED macro
PRL_ERR_WEB_PORTAL_UNEXPECTED
PRL_ERR_WEB_PORTAL_UNEXPECTED macro
PRL_ERR_WIN_AERO_DISABLED
PRL_ERR_WIN_AERO_DISABLED macro
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY macro
PRL_ERR_WRITE_FAILED
PRL_ERR_WRITE_FAILED macro
PRL_ERR_WRONG_CIPHER_ID_FORMAT
PRL_ERR_WRONG_CIPHER_ID_FORMAT macro
PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG
PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG macro
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL macro
PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT
PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT macro
PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT
PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT macro
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD macro
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM
PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM macro
PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM
PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM macro
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WRONG_PROTOCOL_VERSION macro
PRL_ERR_WRONG_TRANSACTION_STATE
PRL_ERR_WRONG_TRANSACTION_STATE macro
PRL_ERR_WRONG_VM_STATE
PRL_ERR_WRONG_VM_STATE macro
PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP
PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP macro
PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP
PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP macro
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_WS_DISP_CONNECTION_CLOSED macro
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X32HOST macro
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED macro
PRL_ERR_XML_WRITE_FILE
PRL_ERR_XML_WRITE_FILE macro
PRL_ERR_XMLRPC_INTERNAL_ERROR
PRL_ERR_XMLRPC_INTERNAL_ERROR macro
PRL_ERR_XMLRPC_INVALID_CREDENTIALS
PRL_ERR_XMLRPC_INVALID_CREDENTIALS macro
PRL_ERR_XMLRPC_INVALID_REQUEST_INFO
PRL_ERR_XMLRPC_INVALID_REQUEST_INFO macro
PRL_ERR_XMLRPC_LIMITS_EXHAUSTED
PRL_ERR_XMLRPC_LIMITS_EXHAUSTED macro
PRL_ERR_XMLRPC_WRONG_METHOD_CALL
PRL_ERR_XMLRPC_WRONG_METHOD_CALL macro
PRL_EVENT_HANDLER_PTR
PRL_EVENT_ISSUER_TYPE
PRL_EVENT_ISSUER_TYPE enumeration
PRL_EVENT_ISSUER_TYPE_PTR
PRL_EVENT_ISSUER_TYPE_PTR type
PRL_EVENT_TYPE
PRL_EVENT_TYPE enumeration
PRL_EVENT_TYPE_PTR
PRL_EVENT_TYPE_PTR type
PRL_EXTERNAL_VM_TYPE
PRL_EXTERNAL_VM_TYPE enumeration
PRL_EXTERNAL_VM_TYPE_PTR
PRL_EXTERNAL_VM_TYPE_PTR type
PRL_FAILED
PRL_FAILED macro
PRL_FALSE
PRL_FALSE macro
PRL_FEATURES_MATRIX
PRL_FEATURES_MATRIX enumeration
PRL_FEATURES_MATRIX_PTR
PRL_FEATURES_MATRIX_PTR type
PRL_FILE Types
PRL_FILE_DESC
PRL_FILE_DESC type
PRL_FILE_SYSTEM_ELEMENT_TYPE
PRL_FILE_SYSTEM_ELEMENT_TYPE enumeration
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR type
PRL_FILE_SYSTEM_FS_TYPE
PRL_FILE_SYSTEM_FS_TYPE enumeration
PRL_FILE_SYSTEM_FS_TYPE_PTR
PRL_FILE_SYSTEM_FS_TYPE_PTR type
PRL_FILE_SYSTEM_TYPE
PRL_FILE_SYSTEM_TYPE enumeration
PRL_FILE_SYSTEM_TYPE_PTR
PRL_FILE_SYSTEM_TYPE_PTR type
PRL_FIREWALL_DIRECTION
PRL_FIREWALL_DIRECTION enumeration
PRL_FIREWALL_DIRECTION_PTR
PRL_FIREWALL_DIRECTION_PTR type
PRL_FIREWALL_POLICY
PRL_FIREWALL_POLICY enumeration
PRL_FIREWALL_POLICY_PTR
PRL_FIREWALL_POLICY_PTR type
PRL_FS_ADFS enumeration member
PRL_FS_AFFS enumeration member
PRL_FS_AFS enumeration member
PRL_FS_AUTOFS enumeration member
PRL_FS_CODA enumeration member
PRL_FS_EFS enumeration member
PRL_FS_EXTFS enumeration member
PRL_FS_FAT enumeration member
PRL_FS_FAT32 enumeration member
PRL_FS_FUSE enumeration member
PRL_FS_GFS enumeration member
PRL_FS_HFS enumeration member
PRL_FS_HPFS enumeration member
PRL_FS_INVALID enumeration member
PRL_FS_ISOFS enumeration member
PRL_FS_JFFS2 enumeration member
PRL_FS_NFS enumeration member
PRL_FS_NTFS enumeration member
PRL_FS_QNX4 enumeration member
PRL_FS_REISERFS enumeration member
PRL_FS_SMBFS enumeration member
PRL_FS_UNSPECIFIED enumeration member
PRL_GENERIC_DEVICE_STATE
PRL_GENERIC_DEVICE_STATE enumeration
PRL_GENERIC_DEVICE_STATE_PTR
PRL_GENERIC_DEVICE_STATE_PTR type
PRL_GENERIC_PCI_DEVICE_CLASS
PRL_GENERIC_PCI_DEVICE_CLASS enumeration
PRL_GENERIC_PCI_DEVICE_CLASS_PTR
PRL_GENERIC_PCI_DEVICE_CLASS_PTR type
PRL_GET_SNAPSHOT_TREE_FLAGS
PRL_GET_SNAPSHOT_TREE_FLAGS enumeration
PRL_GET_VM_CONFIG_FLAGS
PRL_GET_VM_CONFIG_FLAGS enumeration
PRL_GET_VM_CONFIG_FLAGS_PTR
PRL_GET_VM_CONFIG_FLAGS_PTR type
PRL_GET_VM_CONFIG_PARAM_DATA
PRL_GET_VM_CONFIG_PARAM_DATA structure
PRL_GET_VM_CONFIG_PARAM_DATA_PTR
PRL_GET_VM_CONFIG_PARAM_DATA_PTR type
PRL_GET_VM_LIST_FLAGS
PRL_GET_VM_LIST_FLAGS enumeration
PRL_GET_VM_LIST_FLAGS_PTR
PRL_GET_VM_LIST_FLAGS_PTR type
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES enumeration
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR
PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR type
PRL_GRACEFUL_SHUTDOWN_KIND
PRL_GRACEFUL_SHUTDOWN_KIND enumeration
PRL_GRACEFUL_SHUTDOWN_KIND_PTR
PRL_GRACEFUL_SHUTDOWN_KIND_PTR type
PRL_GUEST_CPU_USAGE_PTRN
PRL_GUEST_CPU_USAGE_PTRN macro
PRL_GUEST_DISTRO_VERSION_ENUM
PRL_GUEST_DISTRO_VERSION_ENUM enumeration
PRL_GUEST_DISTRO_VERSION_ENUM_PTR
PRL_GUEST_DISTRO_VERSION_ENUM_PTR type
PRL_GUEST_RAM_CACHED_PTRN
PRL_GUEST_RAM_CACHED_PTRN macro
PRL_GUEST_RAM_USAGE_PTRN
PRL_GUEST_RAM_USAGE_PTRN macro
PRL_GUID_PTR
PRL_GUID_PTR type
PRL_HANDLE
PRL_HANDLE type
PRL_HANDLE_PTR
PRL_HANDLE_PTR type
PRL_HANDLE_TYPE
PRL_HANDLE_TYPE enumeration
PRL_HANDLE_TYPE_PTR
PRL_HANDLE_TYPE_PTR type
PRL_HARD_DISK_IFACE_MASK
PRL_HARD_DISK_IFACE_MASK enumeration
PRL_HARD_DISK_IFACE_MASK_PTR
PRL_HARD_DISK_IFACE_MASK_PTR type
PRL_HARD_DISK_INTERNAL_FORMAT
PRL_HARD_DISK_INTERNAL_FORMAT enumeration
PRL_HARD_DISK_INTERNAL_FORMAT_PTR
PRL_HARD_DISK_INTERNAL_FORMAT_PTR type
PRL_HDD_FIRMWARE_LEN
PRL_HDD_FIRMWARE_LEN macro
PRL_HDD_MODEL_LEN
PRL_HDD_MODEL_LEN macro
PRL_HDD_SERIAL_LEN
PRL_HDD_SERIAL_LEN macro
PRL_HOST_OS_INFO
PRL_HOST_OS_INFO structure
PRL_HOST_OS_INFO_PTR
PRL_HOST_OS_INFO_PTR type
PRL_HOST_OS_TYPE
PRL_HOST_OS_TYPE enumeration
PRL_HOST_OS_TYPE_PTR
PRL_HOST_OS_TYPE_PTR type
PRL_HW_INFO_NET_ADAPTER_TYPE
PRL_HW_INFO_NET_ADAPTER_TYPE enumeration
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR type
PRL_IDE_READ_REQUESTS_PTRN
PRL_IDE_READ_REQUESTS_PTRN macro
PRL_IDE_READ_TOTAL_PTRN
PRL_IDE_READ_TOTAL_PTRN macro
PRL_IDE_WRITE_REQUESTS_PTRN
PRL_IDE_WRITE_REQUESTS_PTRN macro
PRL_IDE_WRITE_TOTAL_PTRN
PRL_IDE_WRITE_TOTAL_PTRN macro
PRL_IMAGE_BOOTCAMP
PRL_IMAGE_BOOTCAMP macro
PRL_IMAGE_BOOTCAMP_FAKE
PRL_IMAGE_BOOTCAMP_FAKE macro
PRL_IMAGE_BOOTCAMP_UID
PRL_IMAGE_BOOTCAMP_UID macro
PRL_IMAGE_COMPRESSED
PRL_IMAGE_COMPRESSED macro
PRL_IMAGE_FORMAT
PRL_IMAGE_FORMAT enumeration
PRL_IMAGE_FORMAT_PTR
PRL_IMAGE_FORMAT_PTR type
PRL_IMAGE_INVALID
PRL_IMAGE_INVALID macro
PRL_IMAGE_LAST_INVALID
PRL_IMAGE_LAST_INVALID macro
PRL_IMAGE_PARAMETERS
PRL_IMAGE_PARAMETERS structure
PRL_IMAGE_PARAMETERS_PTR
PRL_IMAGE_PARAMETERS_PTR type
PRL_IMAGE_PARTITION
PRL_IMAGE_PARTITION macro
PRL_IMAGE_PHYSICAL
PRL_IMAGE_PHYSICAL macro
PRL_IMAGE_PLAIN
PRL_IMAGE_PLAIN macro
PRL_IMAGE_TRY_GUESS
PRL_IMAGE_TRY_GUESS macro
PRL_IMAGE_TYPE
PRL_IMAGE_TYPE type
PRL_IMAGE_TYPE_PTR
PRL_IMAGE_TYPE_PTR type
PRL_IMAGE_VHD_DIFF
PRL_IMAGE_VHD_DIFF macro
PRL_IMAGE_VHD_DYNAMIC
PRL_IMAGE_VHD_DYNAMIC macro
PRL_IMAGE_VHD_DYNAMIC_PART
PRL_IMAGE_VHD_DYNAMIC_PART macro
PRL_IMAGE_VHD_PLAIN
PRL_IMAGE_VHD_PLAIN macro
PRL_IMAGE_VHD_PLAIN_PART
PRL_IMAGE_VHD_PLAIN_PART macro
PRL_IMAGE_VMDK_EXTENT_2GB_FLAT
PRL_IMAGE_VMDK_EXTENT_2GB_FLAT macro
PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE
PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE macro
PRL_IMAGE_VMDK_MONOLITHIC_FLAT
PRL_IMAGE_VMDK_MONOLITHIC_FLAT macro
PRL_IMAGE_VMDK_MONOLITHIC_SPARSE
PRL_IMAGE_VMDK_MONOLITHIC_SPARSE macro
PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED
PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED macro
PRL_INSTALL_APPLIANCE_FLAGS
PRL_INSTALL_APPLIANCE_FLAGS enumeration
PRL_INT Types
PRL_INT16
PRL_INT16 type
PRL_INT16_PTR
PRL_INT16_PTR type
PRL_INT16_PTR_PTR
PRL_INT16_PTR_PTR type
PRL_INT32
PRL_INT32 type
PRL_INT32_PTR
PRL_INT32_PTR type
PRL_INT32_PTR_PTR
PRL_INT32_PTR_PTR type
PRL_INT64
PRL_INT64 type
PRL_INT64_PTR
PRL_INT64_PTR type
PRL_INT64_PTR_PTR
PRL_INT64_PTR_PTR type
PRL_INT8
PRL_INT8 type
PRL_INT8_PTR
PRL_INT8_PTR type
PRL_INT8_PTR_PTR
PRL_INT8_PTR_PTR type
PRL_INVALID_FILE_DESCRIPTOR
PRL_INVALID_FILE_DESCRIPTOR macro
PRL_INVALID_HANDLE
PRL_INVALID_HANDLE macro
PRL_INVALID_PARTITION
PRL_INVALID_PARTITION macro
PRL_INVALID_VLAN_TAG
PRL_INVALID_VLAN_TAG macro
PRL_IO Structs
PRL_IO Types
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_REQUEST structure
PRL_IO_ATTACH_REQUEST_PTR
PRL_IO_ATTACH_REQUEST_PTR type
PRL_IO_ATTACH_RESPONSE
PRL_IO_ATTACH_RESPONSE structure
PRL_IO_ATTACH_RESPONSE_PTR
PRL_IO_ATTACH_RESPONSE_PTR type
PRL_IO_AUDIO_DATA
PRL_IO_AUDIO_DATA structure
PRL_IO_AUDIO_DATA_PTR
PRL_IO_AUDIO_DATA_PTR type
PRL_IO_AUDIO_ENCODING
PRL_IO_AUDIO_ENCODING structure
PRL_IO_AUDIO_ENCODING_LIST
PRL_IO_AUDIO_ENCODING_LIST structure
PRL_IO_AUDIO_ENCODING_LIST_PTR
PRL_IO_AUDIO_ENCODING_LIST_PTR type
PRL_IO_AUDIO_ENCODING_PTR
PRL_IO_AUDIO_ENCODING_PTR type
PRL_IO_AUDIO_ENCODING_RESPONSE
PRL_IO_AUDIO_ENCODING_RESPONSE structure
PRL_IO_AUDIO_ENCODING_RESPONSE_PTR
PRL_IO_AUDIO_ENCODING_RESPONSE_PTR type
PRL_IO_AUTH_EXEC_REQUEST
PRL_IO_AUTH_EXEC_REQUEST structure
PRL_IO_AUTH_EXEC_REQUEST_PTR
PRL_IO_AUTH_EXEC_REQUEST_PTR type
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_REQUEST structure
PRL_IO_AUTH_REQUEST_PTR
PRL_IO_AUTH_REQUEST_PTR type
PRL_IO_AUTH_RESPONSE
PRL_IO_AUTH_RESPONSE structure
PRL_IO_AUTH_RESPONSE_PTR
PRL_IO_AUTH_RESPONSE_PTR type
PRL_IO_AVAILABLE_DISPLAYS
PRL_IO_AVAILABLE_DISPLAYS structure
PRL_IO_AVAILABLE_DISPLAYS_PTR
PRL_IO_AVAILABLE_DISPLAYS_PTR type
PRL_IO_CHANNEL_STAT
PRL_IO_CHANNEL_STAT structure
PRL_IO_CHANNEL_STAT_PTR
PRL_IO_CHANNEL_STAT_PTR type
PRL_IO_CLIENT_FLAGS
PRL_IO_CLIENT_FLAGS enumeration
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DESKTOP_UTILITIES_STATE structure
PRL_IO_DESKTOP_UTILITIES_STATE_PTR
PRL_IO_DESKTOP_UTILITIES_STATE_PTR type
PRL_IO_DEVICE_USED
PRL_IO_DEVICE_USED structure
PRL_IO_DEVICE_USED_PTR
PRL_IO_DEVICE_USED_PTR type
PRL_IO_DISCONNECT_REASON
PRL_IO_DISCONNECT_REASON enumeration
PRL_IO_DISCONNECT_REASON_PTR
PRL_IO_DISCONNECT_REASON_PTR type
PRL_IO_DISPLAY_ENCODING
PRL_IO_DISPLAY_ENCODING structure
PRL_IO_DISPLAY_ENCODING_LIST
PRL_IO_DISPLAY_ENCODING_LIST structure
PRL_IO_DISPLAY_ENCODING_LIST_PTR
PRL_IO_DISPLAY_ENCODING_LIST_PTR type
PRL_IO_DISPLAY_ENCODING_PTR
PRL_IO_DISPLAY_ENCODING_PTR type
PRL_IO_DISPLAY_GAMMA
PRL_IO_DISPLAY_GAMMA structure
PRL_IO_DISPLAY_GAMMA_PTR
PRL_IO_DISPLAY_GAMMA_PTR type
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_PALETTE structure
PRL_IO_DISPLAY_PALETTE_PTR
PRL_IO_DISPLAY_PALETTE_PTR type
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION structure
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX
PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX structure
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_REGION structure
PRL_IO_DISPLAY_SCREEN_REGION_PTR
PRL_IO_DISPLAY_SCREEN_REGION_PTR type
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DISPLAY_SCREEN_SIZE structure
PRL_IO_DISPLAY_SCREEN_SIZE_PTR
PRL_IO_DISPLAY_SCREEN_SIZE_PTR type
PRL_IO_DPI_DISPLAY_SCREEN_SIZE
PRL_IO_DPI_DISPLAY_SCREEN_SIZE structure
PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR
PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR type
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_DYNRES_TOOLS_STATUS structure
PRL_IO_DYNRES_TOOLS_STATUS_PTR
PRL_IO_DYNRES_TOOLS_STATUS_PTR type
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_REQUEST structure
PRL_IO_ENCODING_REQUEST_PTR
PRL_IO_ENCODING_REQUEST_PTR type
PRL_IO_ENCODING_RESPONSE
PRL_IO_ENCODING_RESPONSE structure
PRL_IO_ENCODING_RESPONSE_PTR
PRL_IO_ENCODING_RESPONSE_PTR type
PRL_IO_GAMMARAMP_DEFAULT
PRL_IO_GAMMARAMP_DEFAULT macro
PRL_IO_GAMMARAMP_RGB256x3x16
PRL_IO_GAMMARAMP_RGB256x3x16 macro
PRL_IO_GENERIC_BUFFER
PRL_IO_GENERIC_BUFFER structure
PRL_IO_GENERIC_BUFFER_PTR
PRL_IO_GENERIC_BUFFER_PTR type
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GRACEFUL_SHUTDOWN structure
PRL_IO_GRACEFUL_SHUTDOWN_PTR
PRL_IO_GRACEFUL_SHUTDOWN_PTR type
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE structure
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR
PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR type
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_LEDS structure
PRL_IO_KEYBOARD_LEDS_PTR
PRL_IO_KEYBOARD_LEDS_PTR type
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_KEYBOARD_SCANCODE structure
PRL_IO_KEYBOARD_SCANCODE_PTR
PRL_IO_KEYBOARD_SCANCODE_PTR type
PRL_IO_LANGUAGE_HOTKEYS
PRL_IO_LANGUAGE_HOTKEYS structure
PRL_IO_LANGUAGE_HOTKEYS_PTR
PRL_IO_LANGUAGE_HOTKEYS_PTR type
PRL_IO_MAX_AUDIO_ENCODINGS
PRL_IO_MAX_AUDIO_ENCODINGS macro
PRL_IO_MAX_DISPLAYS
PRL_IO_MAX_DISPLAYS macro
PRL_IO_MAX_ENCODINGS
PRL_IO_MAX_ENCODINGS macro
PRL_IO_MEMORY_INFO
PRL_IO_MEMORY_INFO structure
PRL_IO_MEMORY_INFO_PTR
PRL_IO_MEMORY_INFO_PTR type
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_CURSOR structure
PRL_IO_MOUSE_CURSOR_PTR
PRL_IO_MOUSE_CURSOR_PTR type
PRL_IO_MOUSE_EVENT
PRL_IO_MOUSE_EVENT structure
PRL_IO_MOUSE_EVENT_EX
PRL_IO_MOUSE_EVENT_EX structure
PRL_IO_MOUSE_EVENT_EX_PTR
PRL_IO_MOUSE_EVENT_EX_PTR type
PRL_IO_MOUSE_EVENT_EX2
PRL_IO_MOUSE_EVENT_EX2 structure
PRL_IO_MOUSE_EVENT_EX2_PTR
PRL_IO_MOUSE_EVENT_EX2_PTR type
PRL_IO_MOUSE_EVENT_PTR
PRL_IO_MOUSE_EVENT_PTR type
PRL_IO_PALETTE
PRL_IO_PALETTE type
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_BUFFER_REGION structure
PRL_IO_SCREEN_BUFFER_REGION_PTR
PRL_IO_SCREEN_BUFFER_REGION_PTR type
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_REGION structure
PRL_IO_SCREEN_REGION_PTR
PRL_IO_SCREEN_REGION_PTR type
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SIZE structure
PRL_IO_SCREEN_SIZE_PTR
PRL_IO_SCREEN_SIZE_PTR type
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_SURFACE structure
PRL_IO_SCREEN_SURFACE_PTR
PRL_IO_SCREEN_SURFACE_PTR type
PRL_IO_SCREEN_UPDATE
PRL_IO_SCREEN_UPDATE structure
PRL_IO_SCREEN_UPDATE_PTR
PRL_IO_SCREEN_UPDATE_PTR type
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SET_TASKBAR_VISIBILITY structure
PRL_IO_SET_TASKBAR_VISIBILITY_PTR
PRL_IO_SET_TASKBAR_VISIBILITY_PTR type
PRL_IO_SHUTDOWN_RESULT
PRL_IO_SHUTDOWN_RESULT structure
PRL_IO_SHUTDOWN_RESULT_PTR
PRL_IO_SHUTDOWN_RESULT_PTR type
PRL_IO_SLIDING_MOUSE
PRL_IO_SLIDING_MOUSE structure
PRL_IO_SLIDING_MOUSE_PTR
PRL_IO_SLIDING_MOUSE_PTR type
PRL_IO_SSO_CLIENT_VM_PACKET
PRL_IO_SSO_CLIENT_VM_PACKET structure
PRL_IO_SSO_CLIENT_VM_PACKET_PTR
PRL_IO_SSO_CLIENT_VM_PACKET_PTR type
PRL_IO_STATE
PRL_IO_STATE enumeration
PRL_IO_STATE_PTR
PRL_IO_STATE_PTR type
PRL_IO_TOOLS_ADJUST_WORKING_AREA
PRL_IO_TOOLS_ADJUST_WORKING_AREA structure
PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR
PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR type
PRL_IO_TOOLS_DISPLAY_INDENT
PRL_IO_TOOLS_DISPLAY_INDENT structure
PRL_IO_TOOLS_DISPLAY_INDENT_PTR
PRL_IO_TOOLS_DISPLAY_INDENT_PTR type
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_MOVE_TASKBAR structure
PRL_IO_TOOLS_MOVE_TASKBAR_PTR
PRL_IO_TOOLS_MOVE_TASKBAR_PTR type
PRL_IO_TOOLS_SIA_DATA
PRL_IO_TOOLS_SIA_DATA structure
PRL_IO_TOOLS_SIA_DATA_PTR
PRL_IO_TOOLS_SIA_DATA_PTR type
PRL_IO_TOOLS_UTILITY_COMMAND
PRL_IO_TOOLS_UTILITY_COMMAND structure
PRL_IO_TOOLS_UTILITY_COMMAND_PTR
PRL_IO_TOOLS_UTILITY_COMMAND_PTR type
PRL_IOLIMIT_BS enumeration member
PRL_IOLIMIT_DATA
PRL_IOLIMIT_DATA structure
PRL_IOLIMIT_DATA_PTR
PRL_IOLIMIT_DATA_PTR type
PRL_IOLIMIT_TYPE
PRL_IOLIMIT_TYPE enumeration
PRL_IOPRIO
PRL_IOPRIO enumeration
PRL_IOPRIO_DEFAULT enumeration member
PRL_IOPRIO_MAX enumeration member
PRL_IOPRIO_MIN enumeration member
PRL_ISCSI_STORAGE_CMD_FLAGS
PRL_ISCSI_STORAGE_CMD_FLAGS enumeration
PRL_ISCSI_STORAGE_FSTYPE_FLAGS
PRL_ISCSI_STORAGE_FSTYPE_FLAGS enumeration
PRL_JOB_OPERATION_CODE
PRL_JOB_OPERATION_CODE enumeration
PRL_JOB_OPERATION_CODE_PTR
PRL_JOB_OPERATION_CODE_PTR type
PRL_JOB_STATUS
PRL_JOB_STATUS enumeration
PRL_JOB_STATUS_PTR
PRL_JOB_STATUS_PTR type
PRL_KEY
PRL_KEY enumeration
PRL_KEY_0 enumeration member
PRL_KEY_1 enumeration member
PRL_KEY_2 enumeration member
PRL_KEY_3 enumeration member
PRL_KEY_4 enumeration member
PRL_KEY_5 enumeration member
PRL_KEY_6 enumeration member
PRL_KEY_7 enumeration member
PRL_KEY_8 enumeration member
PRL_KEY_9 enumeration member
PRL_KEY_A enumeration member
PRL_KEY_APP_CALCULATOR enumeration member
PRL_KEY_APP_DASHBOARD enumeration member
PRL_KEY_APP_EXPOSE enumeration member
PRL_KEY_APP_MAIL enumeration member
PRL_KEY_APP_MY_COMPUTER enumeration member
PRL_KEY_B enumeration member
PRL_KEY_BACKSLASH enumeration member
PRL_KEY_BACKSPACE enumeration member
PRL_KEY_BRAZILIAN_KEYPAD enumeration member
PRL_KEY_BREAK enumeration member
PRL_KEY_C enumeration member
PRL_KEY_CAPS_LOCK enumeration member
PRL_KEY_COMMA enumeration member
PRL_KEY_D enumeration member
PRL_KEY_DELETE enumeration member
PRL_KEY_DOLLAR enumeration member
PRL_KEY_DOT enumeration member
PRL_KEY_DOWN enumeration member
PRL_KEY_E enumeration member
PRL_KEY_EJECT enumeration member
PRL_KEY_END enumeration member
PRL_KEY_ENTER enumeration member
PRL_KEY_EQUAL enumeration member
PRL_KEY_ESCAPE enumeration member
PRL_KEY_EURO enumeration member
PRL_KEY_EUROPE_1 enumeration member
PRL_KEY_EUROPE_2 enumeration member
PRL_KEY_EVENT
PRL_KEY_EVENT enumeration
PRL_KEY_EVENT_PTR
PRL_KEY_EVENT_PTR type
PRL_KEY_F enumeration member
PRL_KEY_F1 enumeration member
PRL_KEY_F10 enumeration member
PRL_KEY_F11 enumeration member
PRL_KEY_F12 enumeration member
PRL_KEY_F13 enumeration member
PRL_KEY_F14 enumeration member
PRL_KEY_F15 enumeration member
PRL_KEY_F16 enumeration member
PRL_KEY_F17 enumeration member
PRL_KEY_F18 enumeration member
PRL_KEY_F19 enumeration member
PRL_KEY_F2 enumeration member
PRL_KEY_F20 enumeration member
PRL_KEY_F21 enumeration member
PRL_KEY_F22 enumeration member
PRL_KEY_F23 enumeration member
PRL_KEY_F24 enumeration member
PRL_KEY_F3 enumeration member
PRL_KEY_F4 enumeration member
PRL_KEY_F5 enumeration member
PRL_KEY_F6 enumeration member
PRL_KEY_F7 enumeration member
PRL_KEY_F8 enumeration member
PRL_KEY_F9 enumeration member
PRL_KEY_FN enumeration member
PRL_KEY_G enumeration member
PRL_KEY_H enumeration member
PRL_KEY_HANGUEL enumeration member
PRL_KEY_HANJA enumeration member
PRL_KEY_HENKAN enumeration member
PRL_KEY_HIRAGANA enumeration member
PRL_KEY_HIRAGANA_KATAKANA enumeration member
PRL_KEY_HOME enumeration member
PRL_KEY_I enumeration member
PRL_KEY_INSERT enumeration member
PRL_KEY_INVALID enumeration member
PRL_KEY_J enumeration member
PRL_KEY_K enumeration member
PRL_KEY_KATAKANA enumeration member
PRL_KEY_KBD_BRIGHTNESS_DOWN enumeration member
PRL_KEY_KBD_BRIGHTNESS_UP enumeration member
PRL_KEY_L enumeration member
PRL_KEY_LEFT enumeration member
PRL_KEY_LEFT_ALT enumeration member
PRL_KEY_LEFT_BRACKET enumeration member
PRL_KEY_LEFT_BUTTON enumeration member
PRL_KEY_LEFT_CONTROL enumeration member
PRL_KEY_LEFT_SHIFT enumeration member
PRL_KEY_LEFT_WIN enumeration member
PRL_KEY_M enumeration member
PRL_KEY_MAC129 enumeration member
PRL_KEY_MAX enumeration member
PRL_KEY_MEDIA_NEXT_TRACK enumeration member
PRL_KEY_MEDIA_PLAY_PAUSE enumeration member
PRL_KEY_MEDIA_PREV_TRACK enumeration member
PRL_KEY_MEDIA_SELECT enumeration member
PRL_KEY_MEDIA_STOP enumeration member
PRL_KEY_MENU enumeration member
PRL_KEY_MIDDLE_BUTTON enumeration member
PRL_KEY_MINUS enumeration member
PRL_KEY_MON_BRIGHTNESS_DOWN enumeration member
PRL_KEY_MON_BRIGHTNESS_UP enumeration member
PRL_KEY_MOVE_DOWN enumeration member
PRL_KEY_MOVE_DOWN_LEFT enumeration member
PRL_KEY_MOVE_DOWN_RIGHT enumeration member
PRL_KEY_MOVE_LEFT enumeration member
PRL_KEY_MOVE_RIGHT enumeration member
PRL_KEY_MOVE_UP enumeration member
PRL_KEY_MOVE_UP_LEFT enumeration member
PRL_KEY_MOVE_UP_RIGHT enumeration member
PRL_KEY_MUHENKAN enumeration member
PRL_KEY_MUTE enumeration member
PRL_KEY_N enumeration member
PRL_KEY_NP_0 enumeration member
PRL_KEY_NP_1 enumeration member
PRL_KEY_NP_2 enumeration member
PRL_KEY_NP_3 enumeration member
PRL_KEY_NP_4 enumeration member
PRL_KEY_NP_5 enumeration member
PRL_KEY_NP_6 enumeration member
PRL_KEY_NP_7 enumeration member
PRL_KEY_NP_8 enumeration member
PRL_KEY_NP_9 enumeration member
PRL_KEY_NP_DELETE enumeration member
PRL_KEY_NP_ENTER enumeration member
PRL_KEY_NP_EQUAL enumeration member
PRL_KEY_NP_MINUS enumeration member
PRL_KEY_NP_PLUS enumeration member
PRL_KEY_NP_SLASH enumeration member
PRL_KEY_NP_STAR enumeration member
PRL_KEY_NUM_LOCK enumeration member
PRL_KEY_O enumeration member
PRL_KEY_P enumeration member
PRL_KEY_PAGE_DOWN enumeration member
PRL_KEY_PAGE_UP enumeration member
PRL_KEY_PAUSE enumeration member
PRL_KEY_PC9800_KEYPAD enumeration member
PRL_KEY_PRINT enumeration member
PRL_KEY_PRINT_WITH_MODIFIER enumeration member
PRL_KEY_Q enumeration member
PRL_KEY_QUOTE enumeration member
PRL_KEY_R enumeration member
PRL_KEY_RIGHT enumeration member
PRL_KEY_RIGHT_ALT enumeration member
PRL_KEY_RIGHT_BRACKET enumeration member
PRL_KEY_RIGHT_BUTTON enumeration member
PRL_KEY_RIGHT_CONTROL enumeration member
PRL_KEY_RIGHT_SHIFT enumeration member
PRL_KEY_RIGHT_WIN enumeration member
PRL_KEY_RO enumeration member
PRL_KEY_S enumeration member
PRL_KEY_SCROLL_LOCK enumeration member
PRL_KEY_SEMICOLON enumeration member
PRL_KEY_SLASH enumeration member
PRL_KEY_SPACE enumeration member
PRL_KEY_SYSRQ enumeration member
PRL_KEY_SYSTEM_POWER enumeration member
PRL_KEY_SYSTEM_SLEEP enumeration member
PRL_KEY_SYSTEM_WAKE enumeration member
PRL_KEY_T enumeration member
PRL_KEY_TAB enumeration member
PRL_KEY_TILDA enumeration member
PRL_KEY_U enumeration member
PRL_KEY_UP enumeration member
PRL_KEY_V enumeration member
PRL_KEY_VOLUME_DOWN enumeration member
PRL_KEY_VOLUME_UP enumeration member
PRL_KEY_W enumeration member
PRL_KEY_WHEEL_DOWN enumeration member
PRL_KEY_WHEEL_LEFT enumeration member
PRL_KEY_WHEEL_RIGHT enumeration member
PRL_KEY_WHEEL_UP enumeration member
PRL_KEY_WILDCARD_ALT enumeration member
PRL_KEY_WILDCARD_ANY enumeration member
PRL_KEY_WILDCARD_CTRL enumeration member
PRL_KEY_WILDCARD_KEYBOARD enumeration member
PRL_KEY_WILDCARD_MOUSE enumeration member
PRL_KEY_WILDCARD_SHIFT enumeration member
PRL_KEY_WILDCARD_WIN enumeration member
PRL_KEY_WWW_BACK enumeration member
PRL_KEY_WWW_FAVORITES enumeration member
PRL_KEY_WWW_FORWARD enumeration member
PRL_KEY_WWW_HOME enumeration member
PRL_KEY_WWW_REFRESH enumeration member
PRL_KEY_WWW_SEARCH enumeration member
PRL_KEY_WWW_STOP enumeration member
PRL_KEY_X enumeration member
PRL_KEY_Y enumeration member
PRL_KEY_YEN enumeration member
PRL_KEY_Z enumeration member
PRL_KEY_ZENKAKU_HANKAKU enumeration member
PRL_LICENSE_IS_EXPIRED
PRL_LICENSE_IS_EXPIRED macro
PRL_LICENSE_IS_VALID
PRL_LICENSE_IS_VALID macro
PRL_LICENSE_RESTRICTION_KEY
PRL_LICENSE_RESTRICTION_KEY enumeration
PRL_LICENSE_RESTRICTION_KEY_PTR
PRL_LICENSE_RESTRICTION_KEY_PTR type
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_EXTENDED_PARTITION macro
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_DATA macro
PRL_LINUX_PARTITION_SWAP
PRL_LINUX_PARTITION_SWAP macro
PRL_LOGIN_LOCAL_FLAGS
PRL_LOGIN_LOCAL_FLAGS enumeration
PRL_LOGIN_LOCAL_FLAGS_PTR
PRL_LOGIN_LOCAL_FLAGS_PTR type
PRL_MACOS_BOOT_PARTITION
PRL_MACOS_BOOT_PARTITION macro
PRL_MACOS_PARTITION
PRL_MACOS_PARTITION macro
PRL_MASS_STORAGE_INTERFACE_TYPE
PRL_MASS_STORAGE_INTERFACE_TYPE enumeration
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR type
PRL_MAX_VLAN_TAG
PRL_MAX_VLAN_TAG macro
PRL_MESSAGE_TYPE_ENUM
PRL_MESSAGE_TYPE_ENUM enumeration
PRL_MESSAGE_TYPE_ENUM_PTR
PRL_MESSAGE_TYPE_ENUM_PTR type
PRL_METHOD
PRL_METHOD macro
PRL_METHOD_DECL
PRL_METHOD_DECL macro
PRL_METHOD_PTR
PRL_METHOD_PTR macro
PRL_MOBILE_ADVANCED_AUTH_MODE
PRL_MOBILE_ADVANCED_AUTH_MODE enumeration
PRL_MOBILE_ADVANCED_AUTH_MODE_PTR
PRL_MOBILE_ADVANCED_AUTH_MODE_PTR type
PRL_MOUNT_VIRTUAL_DISK
PRL_MOUNT_VIRTUAL_DISK enumeration
PRL_MOUSE_BUTTON
PRL_MOUSE_BUTTON enumeration
PRL_MOUSE_BUTTON_PTR
PRL_MOUSE_BUTTON_PTR type
PRL_MSDOS_EXTENDED_PARTITION
PRL_MSDOS_EXTENDED_PARTITION macro
PRL_NET_ADAPTER_ALREADY_USED
PRL_NET_ADAPTER_ALREADY_USED macro
PRL_NET_ADAPTER_EMULATED_TYPE
PRL_NET_ADAPTER_EMULATED_TYPE enumeration
PRL_NET_ADAPTER_EMULATED_TYPE_PTR
PRL_NET_ADAPTER_EMULATED_TYPE_PTR type
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_ADAPTER_NOT_EXIST macro
PRL_NET_BIND_FAILED
PRL_NET_BIND_FAILED macro
PRL_NET_BYTES_IN_PTRN
PRL_NET_BYTES_IN_PTRN macro
PRL_NET_BYTES_OUT_PTRN
PRL_NET_BYTES_OUT_PTRN macro
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CABLE_DISCONNECTED macro
PRL_NET_CLASSFUL_TRAFFIC_PTRN
PRL_NET_CLASSFUL_TRAFFIC_PTRN macro
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_CONNECTION_SHARING_CONFLICT macro
PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME
PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME macro
PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID
PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID macro
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ADAPTER_CONFIG macro
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER macro
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER macro
PRL_NET_ETHLIST_CREATE_ERROR
PRL_NET_ETHLIST_CREATE_ERROR macro
PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_FAILED macro
PRL_NET_INSTALL_TIMEOUT
PRL_NET_INSTALL_TIMEOUT macro
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING macro
PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST
PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST macro
PRL_NET_IPPRIVATE_NETWORK_INVALID_IP
PRL_NET_IPPRIVATE_NETWORK_INVALID_IP macro
PRL_NET_OFFMGMT_ERROR
PRL_NET_OFFMGMT_ERROR macro
PRL_NET_PKTFILTER_ERROR
PRL_NET_PKTFILTER_ERROR macro
PRL_NET_PKTS_IN_PTRN
PRL_NET_PKTS_IN_PTRN macro
PRL_NET_PKTS_OUT_PTRN
PRL_NET_PKTS_OUT_PTRN macro
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_PRLNET_OPEN_FAILED macro
PRL_NET_RENAME_FAILED
PRL_NET_RENAME_FAILED macro
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS macro
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SRV_NOTIFY_ERROR macro
PRL_NET_SYSTEM_ERROR
PRL_NET_SYSTEM_ERROR macro
PRL_NET_UNINSTALL_FAILED
PRL_NET_UNINSTALL_FAILED macro
PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS
PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS macro
PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN
PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN macro
PRL_NET_VALID_FAILURE
PRL_NET_VALID_FAILURE macro
PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK
PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK macro
PRL_NET_VALID_WRONG_DHCP_IP_ADDR
PRL_NET_VALID_WRONG_DHCP_IP_ADDR macro
PRL_NET_VALID_WRONG_HOST_IP_ADDR
PRL_NET_VALID_WRONG_HOST_IP_ADDR macro
PRL_NET_VALID_WRONG_NET_MASK
PRL_NET_VALID_WRONG_NET_MASK macro
PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS
PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS macro
PRL_NET_VIRTUAL_NETWORK_NOT_FOUND
PRL_NET_VIRTUAL_NETWORK_NOT_FOUND macro
PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS
PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS macro
PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED
PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED macro
PRL_NET_VIRTUAL_NETWORK_TYPE
PRL_NET_VIRTUAL_NETWORK_TYPE enumeration
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR type
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST macro
PRL_NET_WINSCM_OPEN_ERROR
PRL_NET_WINSCM_OPEN_ERROR macro
PRL_NETFILTER_MODE
PRL_NETFILTER_MODE enumeration
PRL_NETFILTER_MODE_PTR
PRL_NETFILTER_MODE_PTR type
PRL_NULL
PRL_NULL macro
PRL_ONLINE_COMPACT_MODE
PRL_ONLINE_COMPACT_MODE enumeration
PRL_ONLINE_COMPACT_MODE_PTR
PRL_ONLINE_COMPACT_MODE_PTR type
PRL_OPTIMIZE_MODIFIERS_MODE
PRL_OPTIMIZE_MODIFIERS_MODE enumeration
PRL_OPTIMIZE_MODIFIERS_MODE_PTR
PRL_OPTIMIZE_MODIFIERS_MODE_PTR type
PRL_PARAM_FIELD_DATA_TYPE
PRL_PARAM_FIELD_DATA_TYPE enumeration
PRL_PARAM_FIELD_DATA_TYPE_PTR
PRL_PARAM_FIELD_DATA_TYPE_PTR type
PRL_PORT_FORWARDING_TYPE
PRL_PORT_FORWARDING_TYPE enumeration
PRL_PORT_FORWARDING_TYPE_PTR
PRL_PORT_FORWARDING_TYPE_PTR type
PRL_PRINTER_INTERFACE_TYPE
PRL_PRINTER_INTERFACE_TYPE enumeration
PRL_PRINTER_INTERFACE_TYPE_PTR
PRL_PRINTER_INTERFACE_TYPE_PTR type
PRL_PRIVATE_EVENT_TYPE
PRL_PRIVATE_EVENT_TYPE enumeration
PRL_PRIVATE_EVENT_TYPE_PTR
PRL_PRIVATE_EVENT_TYPE_PTR type
PRL_PRIVILEGED_GUEST_OS_SESSION
PRL_PRIVILEGED_GUEST_OS_SESSION macro
PRL_PROBLEM_REPORT_FLAGS
PRL_PROBLEM_REPORT_FLAGS enumeration
PRL_PROBLEM_REPORT_FLAGS_PTR
PRL_PROBLEM_REPORT_FLAGS_PTR type
PRL_PROBLEM_REPORT_REASON
PRL_PROBLEM_REPORT_REASON enumeration
PRL_PROBLEM_REPORT_REASON_PTR
PRL_PROBLEM_REPORT_REASON_PTR type
PRL_PROBLEM_REPORT_SCHEME
PRL_PROBLEM_REPORT_SCHEME enumeration
PRL_PROBLEM_REPORT_SCHEME_PTR
PRL_PROBLEM_REPORT_SCHEME_PTR type
PRL_PROBLEM_REPORT_TYPE
PRL_PROBLEM_REPORT_TYPE enumeration
PRL_PROBLEM_REPORT_TYPE_PTR
PRL_PROBLEM_REPORT_TYPE_PTR type
PRL_PROCESS_STATE_TYPE
PRL_PROCESS_STATE_TYPE enumeration
PRL_PROCESS_STATE_TYPE_PTR
PRL_PROCESS_STATE_TYPE_PTR type
PRL_PRODUCT_ANY enumeration member
PRL_PRODUCT_DESKTOP enumeration member
PRL_PRODUCT_DESKTOP_PDE enumeration member
PRL_PRODUCT_DESKTOP_WL enumeration member
PRL_PRODUCT_ENUM
PRL_PRODUCT_ENUM enumeration
PRL_PRODUCT_ENUM_PTR
PRL_PRODUCT_ENUM_PTR type
PRL_PRODUCT_PLAYER enumeration member
PRL_PRODUCT_SERVER enumeration member
PRL_PRODUCT_STM enumeration member
PRL_PRODUCT_WORKSTATION enumeration member
PRL_PROXY_CLIENT_INFO
PRL_PROXY_CLIENT_INFO structure
PRL_PROXY_CLIENT_INFO_PTR
PRL_PROXY_CLIENT_INFO_PTR type
PRL_PROXY_CONNECTION_STATUS
PRL_PROXY_CONNECTION_STATUS enumeration
PRL_PROXY_CONNECTION_STATUS_PTR
PRL_PROXY_CONNECTION_STATUS_PTR type
PRL_PROXY_DATA_KEY
PRL_PROXY_DATA_KEY structure
PRL_PROXY_DATA_KEY_PTR
PRL_PROXY_DATA_KEY_PTR type
PRL_PROXY_GEO_INFO
PRL_PROXY_GEO_INFO structure
PRL_PROXY_GEO_INFO_PTR
PRL_PROXY_GEO_INFO_PTR type
PRL_PROXY_HOST_INFO
PRL_PROXY_HOST_INFO structure
PRL_PROXY_HOST_INFO_EXT
PRL_PROXY_HOST_INFO_EXT structure
PRL_PROXY_HOST_INFO_EXT_PTR
PRL_PROXY_HOST_INFO_EXT_PTR type
PRL_PROXY_HOST_INFO_PTR
PRL_PROXY_HOST_INFO_PTR type
PRL_PROXY_MAX_HOSTS
PRL_PROXY_MAX_HOSTS macro
PRL_PROXY_REGISTRATION_INFO
PRL_PROXY_REGISTRATION_INFO structure
PRL_PROXY_REGISTRATION_INFO_PTR
PRL_PROXY_REGISTRATION_INFO_PTR type
PRL_PROXY_USER_DATA
PRL_PROXY_USER_DATA structure
PRL_PROXY_USER_DATA_PTR
PRL_PROXY_USER_DATA_PTR type
PRL_PTM Macros
PRL_PTM_CONST_OBJECT_PTR
PRL_PTM_CONST_OBJECT_PTR type
PRL_PTM_CONST_PROPERTY_PTR
PRL_PTM_CONST_PROPERTY_PTR type
PRL_PTM_DECLARE_PROPERTY
PRL_PTM_DECLARE_PROPERTY macro
PRL_PTM_INIT_PROPERTY
PRL_PTM_INIT_PROPERTY macro
PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS
PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS macro
PRL_PTM_NAMESPACE_APPMNG_CHANNELS
PRL_PTM_NAMESPACE_APPMNG_CHANNELS macro
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM macro
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS
PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS macro
PRL_PTM_NAMESPACE_APPMNG_IMAGES
PRL_PTM_NAMESPACE_APPMNG_IMAGES macro
PRL_PTM_NAMESPACE_APPMNG_OPERATIONS
PRL_PTM_NAMESPACE_APPMNG_OPERATIONS macro
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS macro
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM macro
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES
PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES macro
PRL_PTM_NAMESPACE_APPMNG_PROCESSES
PRL_PTM_NAMESPACE_APPMNG_PROCESSES macro
PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE
PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT macro
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE
PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON
PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON macro
PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL
PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL macro
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL
PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL macro
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE macro
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT
PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT macro
PRL_PTM_NAMESPACE_APPMNG_SHARES
PRL_PTM_NAMESPACE_APPMNG_SHARES macro
PRL_PTM_NAMESPACE_DESKTOP
PRL_PTM_NAMESPACE_DESKTOP macro
PRL_PTM_NAMESPACE_DESKTOP_CLIENT
PRL_PTM_NAMESPACE_DESKTOP_CLIENT macro
PRL_PTM_NAMESPACE_DESKTOP_MENU
PRL_PTM_NAMESPACE_DESKTOP_MENU macro
PRL_PTM_NAMESPACE_DESKTOP_SESSION
PRL_PTM_NAMESPACE_DESKTOP_SESSION macro
PRL_PTM_NAMESPACE_DESKTOP_UI
PRL_PTM_NAMESPACE_DESKTOP_UI macro
PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES
PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES macro
PRL_PTM_NAMESPACE_HINTING
PRL_PTM_NAMESPACE_HINTING macro
PRL_PTM_NAMESPACE_HINTING_SELECTION
PRL_PTM_NAMESPACE_HINTING_SELECTION macro
PRL_PTM_NAMESPACE_INPUT
PRL_PTM_NAMESPACE_INPUT macro
PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD
PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD macro
PRL_PTM_NAMESPACE_INPUT_CARET
PRL_PTM_NAMESPACE_INPUT_CARET macro
PRL_PTM_NAMESPACE_INPUT_CURSOR
PRL_PTM_NAMESPACE_INPUT_CURSOR macro
PRL_PTM_NAMESPACE_INPUT_INFO
PRL_PTM_NAMESPACE_INPUT_INFO macro
PRL_PTM_NAMESPACE_PRIVATE
PRL_PTM_NAMESPACE_PRIVATE macro
PRL_PTM_NAMESPACE_RPC
PRL_PTM_NAMESPACE_RPC macro
PRL_PTM_NAMESPACE_RPC_CANCEL
PRL_PTM_NAMESPACE_RPC_CANCEL macro
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER macro
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE
PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE macro
PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW
PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW macro
PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE
PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE macro
PRL_PTM_NAMESPACE_RPC_HINTING_CARET
PRL_PTM_NAMESPACE_RPC_HINTING_CARET macro
PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP
PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP macro
PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON
PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON macro
PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION
PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION macro
PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE
PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE macro
PRL_PTM_NAMESPACE_RPC_QUERY
PRL_PTM_NAMESPACE_RPC_QUERY macro
PRL_PTM_NAMESPACE_RPC_SET
PRL_PTM_NAMESPACE_RPC_SET macro
PRL_PTM_NAMESPACE_RPC_SUBSCRIBE
PRL_PTM_NAMESPACE_RPC_SUBSCRIBE macro
PRL_PTM_OBJECT_PTR
PRL_PTM_OBJECT_PTR type
PRL_PTM_PROPERTY_PTR
PRL_PTM_PROPERTY_PTR type
PRL_QUERY_ELEMENT_FLAGS
PRL_QUERY_ELEMENT_FLAGS enumeration
PRL_QUERY_ELEMENT_FLAGS_PTR
PRL_QUERY_ELEMENT_FLAGS_PTR type
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CD_DRIVE_NOT_EXIST macro
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST macro
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY macro
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_DRIVE_NOT_EXIST macro
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST macro
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST macro
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_HDD_SAME_IMAGE macro
PRL_QUEST_POWER_OFF
PRL_QUEST_POWER_OFF macro
PRL_QUEST_RESET
PRL_QUEST_RESET macro
PRL_QUEST_RESTART
PRL_QUEST_RESTART macro
PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD
PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD macro
PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE
PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE macro
PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE
PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE macro
PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED
PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED macro
PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS
PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS macro
PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH
PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH macro
PRL_QUESTION_FINALIZE_VM_PROCESS
PRL_QUESTION_FINALIZE_VM_PROCESS macro
PRL_QUESTION_REVERT_TOO_LARGE_MEM
PRL_QUESTION_REVERT_TOO_LARGE_MEM macro
PRL_QUESTION_SETUP_YANDEX_SEARCH
PRL_QUESTION_SETUP_YANDEX_SEARCH macro
PRL_REGISTER_3PARTY_VM_FLAGS
PRL_REGISTER_3PARTY_VM_FLAGS enumeration
PRL_REGISTER_3PARTY_VM_FLAGS_PTR
PRL_REGISTER_3PARTY_VM_FLAGS_PTR type
PRL_REGISTER_NEW_VM
PRL_REGISTER_NEW_VM enumeration
PRL_REGISTER_NEW_VM_PTR
PRL_REGISTER_NEW_VM_PTR type
PRL_REGISTER_VM_FLAGS
PRL_REGISTER_VM_FLAGS enumeration
PRL_REGISTER_VM_FLAGS_PTR
PRL_REGISTER_VM_FLAGS_PTR type
PRL_RESIZE_IMAGE_FLAGS
PRL_RESIZE_IMAGE_FLAGS enumeration
PRL_RESIZE_IMAGE_FLAGS_PTR
PRL_RESIZE_IMAGE_FLAGS_PTR type
PRL_RESULT
PRL_RESULT type
PRL_RESULT_DECLARE_ERROR
PRL_RESULT_DECLARE_ERROR macro
PRL_RESULT_DECLARE_SUCCESS
PRL_RESULT_DECLARE_SUCCESS macro
PRL_RESULT_PTR
PRL_RESULT_PTR type
prl_result_to_string
prl_result_to_string function
PRL_RUNNING_TASK_TYPE_ENUM
PRL_RUNNING_TASK_TYPE_ENUM enumeration
PRL_RUNNING_TASK_TYPE_ENUM_PTR
PRL_RUNNING_TASK_TYPE_ENUM_PTR type
PRL_SATA_READ_REQUESTS_PTRN
PRL_SATA_READ_REQUESTS_PTRN macro
PRL_SATA_READ_TOTAL_PTRN
PRL_SATA_READ_TOTAL_PTRN macro
PRL_SATA_WRITE_REQUESTS_PTRN
PRL_SATA_WRITE_REQUESTS_PTRN macro
PRL_SATA_WRITE_TOTAL_PTRN
PRL_SATA_WRITE_TOTAL_PTRN macro
PRL_SCALE_VIEW_MODE
PRL_SCALE_VIEW_MODE enumeration
PRL_SCALE_VIEW_MODE_PTR
PRL_SCALE_VIEW_MODE_PTR type
PRL_SCAN_CODE Macros
PRL_SCAN_CODE_0
PRL_SCAN_CODE_0 macro
PRL_SCAN_CODE_1
PRL_SCAN_CODE_1 macro
PRL_SCAN_CODE_2
PRL_SCAN_CODE_2 macro
PRL_SCAN_CODE_3
PRL_SCAN_CODE_3 macro
PRL_SCAN_CODE_4
PRL_SCAN_CODE_4 macro
PRL_SCAN_CODE_5
PRL_SCAN_CODE_5 macro
PRL_SCAN_CODE_6
PRL_SCAN_CODE_6 macro
PRL_SCAN_CODE_7
PRL_SCAN_CODE_7 macro
PRL_SCAN_CODE_8
PRL_SCAN_CODE_8 macro
PRL_SCAN_CODE_9
PRL_SCAN_CODE_9 macro
PRL_SCAN_CODE_A
PRL_SCAN_CODE_A macro
PRL_SCAN_CODE_ALT_LEFT
PRL_SCAN_CODE_ALT_LEFT macro
PRL_SCAN_CODE_ALT_RIGHT
PRL_SCAN_CODE_ALT_RIGHT macro
PRL_SCAN_CODE_APP_CALCULATOR
PRL_SCAN_CODE_APP_CALCULATOR macro
PRL_SCAN_CODE_APP_MAIL
PRL_SCAN_CODE_APP_MAIL macro
PRL_SCAN_CODE_APP_MY_COMPUTER
PRL_SCAN_CODE_APP_MY_COMPUTER macro
PRL_SCAN_CODE_B
PRL_SCAN_CODE_B macro
PRL_SCAN_CODE_BACKSLASH
PRL_SCAN_CODE_BACKSLASH macro
PRL_SCAN_CODE_BACKSPACE
PRL_SCAN_CODE_BACKSPACE macro
PRL_SCAN_CODE_BRAZILIAN_KEYPAD
PRL_SCAN_CODE_BRAZILIAN_KEYPAD macro
PRL_SCAN_CODE_BREAK
PRL_SCAN_CODE_BREAK macro
PRL_SCAN_CODE_C
PRL_SCAN_CODE_C macro
PRL_SCAN_CODE_CAPS_LOCK
PRL_SCAN_CODE_CAPS_LOCK macro
PRL_SCAN_CODE_CBRACE_LEFT
PRL_SCAN_CODE_CBRACE_LEFT macro
PRL_SCAN_CODE_CBRACE_RIGHT
PRL_SCAN_CODE_CBRACE_RIGHT macro
PRL_SCAN_CODE_CMD_LEFT
PRL_SCAN_CODE_CMD_LEFT macro
PRL_SCAN_CODE_CMD_RIGHT
PRL_SCAN_CODE_CMD_RIGHT macro
PRL_SCAN_CODE_COLON
PRL_SCAN_CODE_COLON macro
PRL_SCAN_CODE_CTRL_LEFT
PRL_SCAN_CODE_CTRL_LEFT macro
PRL_SCAN_CODE_CTRL_RIGHT
PRL_SCAN_CODE_CTRL_RIGHT macro
PRL_SCAN_CODE_D
PRL_SCAN_CODE_D macro
PRL_SCAN_CODE_DELETE
PRL_SCAN_CODE_DELETE macro
PRL_SCAN_CODE_DOLLAR
PRL_SCAN_CODE_DOLLAR macro
PRL_SCAN_CODE_DOWN
PRL_SCAN_CODE_DOWN macro
PRL_SCAN_CODE_E
PRL_SCAN_CODE_E macro
PRL_SCAN_CODE_EJECT
PRL_SCAN_CODE_EJECT macro
PRL_SCAN_CODE_END
PRL_SCAN_CODE_END macro
PRL_SCAN_CODE_ENTER
PRL_SCAN_CODE_ENTER macro
PRL_SCAN_CODE_ESC
PRL_SCAN_CODE_ESC macro
PRL_SCAN_CODE_EURO
PRL_SCAN_CODE_EURO macro
PRL_SCAN_CODE_EUROPE_1
PRL_SCAN_CODE_EUROPE_1 macro
PRL_SCAN_CODE_F
PRL_SCAN_CODE_F macro
PRL_SCAN_CODE_F1
PRL_SCAN_CODE_F1 macro
PRL_SCAN_CODE_F10
PRL_SCAN_CODE_F10 macro
PRL_SCAN_CODE_F11
PRL_SCAN_CODE_F11 macro
PRL_SCAN_CODE_F12
PRL_SCAN_CODE_F12 macro
PRL_SCAN_CODE_F13
PRL_SCAN_CODE_F13 macro
PRL_SCAN_CODE_F14
PRL_SCAN_CODE_F14 macro
PRL_SCAN_CODE_F15
PRL_SCAN_CODE_F15 macro
PRL_SCAN_CODE_F16
PRL_SCAN_CODE_F16 macro
PRL_SCAN_CODE_F17
PRL_SCAN_CODE_F17 macro
PRL_SCAN_CODE_F18
PRL_SCAN_CODE_F18 macro
PRL_SCAN_CODE_F19
PRL_SCAN_CODE_F19 macro
PRL_SCAN_CODE_F2
PRL_SCAN_CODE_F2 macro
PRL_SCAN_CODE_F20
PRL_SCAN_CODE_F20 macro
PRL_SCAN_CODE_F21
PRL_SCAN_CODE_F21 macro
PRL_SCAN_CODE_F22
PRL_SCAN_CODE_F22 macro
PRL_SCAN_CODE_F23
PRL_SCAN_CODE_F23 macro
PRL_SCAN_CODE_F24
PRL_SCAN_CODE_F24 macro
PRL_SCAN_CODE_F3
PRL_SCAN_CODE_F3 macro
PRL_SCAN_CODE_F4
PRL_SCAN_CODE_F4 macro
PRL_SCAN_CODE_F5
PRL_SCAN_CODE_F5 macro
PRL_SCAN_CODE_F6
PRL_SCAN_CODE_F6 macro
PRL_SCAN_CODE_F7
PRL_SCAN_CODE_F7 macro
PRL_SCAN_CODE_F8
PRL_SCAN_CODE_F8 macro
PRL_SCAN_CODE_F9
PRL_SCAN_CODE_F9 macro
PRL_SCAN_CODE_G
PRL_SCAN_CODE_G macro
PRL_SCAN_CODE_GREATER
PRL_SCAN_CODE_GREATER macro
PRL_SCAN_CODE_H
PRL_SCAN_CODE_H macro
PRL_SCAN_CODE_HANGUEL
PRL_SCAN_CODE_HANGUEL macro
PRL_SCAN_CODE_HANJA
PRL_SCAN_CODE_HANJA macro
PRL_SCAN_CODE_HENKAN
PRL_SCAN_CODE_HENKAN macro
PRL_SCAN_CODE_HIRAGANA
PRL_SCAN_CODE_HIRAGANA macro
PRL_SCAN_CODE_HIRAGANA_KATAKANA
PRL_SCAN_CODE_HIRAGANA_KATAKANA macro
PRL_SCAN_CODE_HOME
PRL_SCAN_CODE_HOME macro
PRL_SCAN_CODE_I
PRL_SCAN_CODE_I macro
PRL_SCAN_CODE_INSERT
PRL_SCAN_CODE_INSERT macro
PRL_SCAN_CODE_J
PRL_SCAN_CODE_J macro
PRL_SCAN_CODE_K
PRL_SCAN_CODE_K macro
PRL_SCAN_CODE_KATAKANA
PRL_SCAN_CODE_KATAKANA macro
PRL_SCAN_CODE_L
PRL_SCAN_CODE_L macro
PRL_SCAN_CODE_LEFT
PRL_SCAN_CODE_LEFT macro
PRL_SCAN_CODE_LESS
PRL_SCAN_CODE_LESS macro
PRL_SCAN_CODE_LESS_GREATER
PRL_SCAN_CODE_LESS_GREATER macro
PRL_SCAN_CODE_M
PRL_SCAN_CODE_M macro
PRL_SCAN_CODE_MEDIA_NEXT_TRACK
PRL_SCAN_CODE_MEDIA_NEXT_TRACK macro
PRL_SCAN_CODE_MEDIA_PLAY_PAUSE
PRL_SCAN_CODE_MEDIA_PLAY_PAUSE macro
PRL_SCAN_CODE_MEDIA_PREV_TRACK
PRL_SCAN_CODE_MEDIA_PREV_TRACK macro
PRL_SCAN_CODE_MEDIA_SELECT
PRL_SCAN_CODE_MEDIA_SELECT macro
PRL_SCAN_CODE_MEDIA_STOP
PRL_SCAN_CODE_MEDIA_STOP macro
PRL_SCAN_CODE_MENU
PRL_SCAN_CODE_MENU macro
PRL_SCAN_CODE_MINUS
PRL_SCAN_CODE_MINUS macro
PRL_SCAN_CODE_MUHENKAN
PRL_SCAN_CODE_MUHENKAN macro
PRL_SCAN_CODE_MUTE
PRL_SCAN_CODE_MUTE macro
PRL_SCAN_CODE_N
PRL_SCAN_CODE_N macro
PRL_SCAN_CODE_NUM_LOCK
PRL_SCAN_CODE_NUM_LOCK macro
PRL_SCAN_CODE_O
PRL_SCAN_CODE_O macro
PRL_SCAN_CODE_P
PRL_SCAN_CODE_P macro
PRL_SCAN_CODE_PAD_0
PRL_SCAN_CODE_PAD_0 macro
PRL_SCAN_CODE_PAD_1
PRL_SCAN_CODE_PAD_1 macro
PRL_SCAN_CODE_PAD_2
PRL_SCAN_CODE_PAD_2 macro
PRL_SCAN_CODE_PAD_3
PRL_SCAN_CODE_PAD_3 macro
PRL_SCAN_CODE_PAD_4
PRL_SCAN_CODE_PAD_4 macro
PRL_SCAN_CODE_PAD_5
PRL_SCAN_CODE_PAD_5 macro
PRL_SCAN_CODE_PAD_6
PRL_SCAN_CODE_PAD_6 macro
PRL_SCAN_CODE_PAD_7
PRL_SCAN_CODE_PAD_7 macro
PRL_SCAN_CODE_PAD_8
PRL_SCAN_CODE_PAD_8 macro
PRL_SCAN_CODE_PAD_9
PRL_SCAN_CODE_PAD_9 macro
PRL_SCAN_CODE_PAD_DEL
PRL_SCAN_CODE_PAD_DEL macro
PRL_SCAN_CODE_PAD_ENTER
PRL_SCAN_CODE_PAD_ENTER macro
PRL_SCAN_CODE_PAD_EQUAL
PRL_SCAN_CODE_PAD_EQUAL macro
PRL_SCAN_CODE_PAD_MINUS
PRL_SCAN_CODE_PAD_MINUS macro
PRL_SCAN_CODE_PAD_PLUS
PRL_SCAN_CODE_PAD_PLUS macro
PRL_SCAN_CODE_PAD_SLASH
PRL_SCAN_CODE_PAD_SLASH macro
PRL_SCAN_CODE_PAD_STAR
PRL_SCAN_CODE_PAD_STAR macro
PRL_SCAN_CODE_PAGE_DOWN
PRL_SCAN_CODE_PAGE_DOWN macro
PRL_SCAN_CODE_PAGE_UP
PRL_SCAN_CODE_PAGE_UP macro
PRL_SCAN_CODE_PAUSE_BREAK
PRL_SCAN_CODE_PAUSE_BREAK macro
PRL_SCAN_CODE_PC9800_KEYPAD
PRL_SCAN_CODE_PC9800_KEYPAD macro
PRL_SCAN_CODE_PLUS
PRL_SCAN_CODE_PLUS macro
PRL_SCAN_CODE_PRINT_SCREEN
PRL_SCAN_CODE_PRINT_SCREEN macro
PRL_SCAN_CODE_PRINT_SCREEN2
PRL_SCAN_CODE_PRINT_SCREEN2 macro
PRL_SCAN_CODE_Q
PRL_SCAN_CODE_Q macro
PRL_SCAN_CODE_QUOTE
PRL_SCAN_CODE_QUOTE macro
PRL_SCAN_CODE_R
PRL_SCAN_CODE_R macro
PRL_SCAN_CODE_RIGHT
PRL_SCAN_CODE_RIGHT macro
PRL_SCAN_CODE_RO
PRL_SCAN_CODE_RO macro
PRL_SCAN_CODE_S
PRL_SCAN_CODE_S macro
PRL_SCAN_CODE_SCROLL_LOCK
PRL_SCAN_CODE_SCROLL_LOCK macro
PRL_SCAN_CODE_SHIFT_LEFT
PRL_SCAN_CODE_SHIFT_LEFT macro
PRL_SCAN_CODE_SHIFT_RIGHT
PRL_SCAN_CODE_SHIFT_RIGHT macro
PRL_SCAN_CODE_SLASH
PRL_SCAN_CODE_SLASH macro
PRL_SCAN_CODE_SPACE
PRL_SCAN_CODE_SPACE macro
PRL_SCAN_CODE_SYSRQ
PRL_SCAN_CODE_SYSRQ macro
PRL_SCAN_CODE_SYSTEM_POWER
PRL_SCAN_CODE_SYSTEM_POWER macro
PRL_SCAN_CODE_SYSTEM_SLEEP
PRL_SCAN_CODE_SYSTEM_SLEEP macro
PRL_SCAN_CODE_SYSTEM_WAKE
PRL_SCAN_CODE_SYSTEM_WAKE macro
PRL_SCAN_CODE_T
PRL_SCAN_CODE_T macro
PRL_SCAN_CODE_TAB
PRL_SCAN_CODE_TAB macro
PRL_SCAN_CODE_TILDA
PRL_SCAN_CODE_TILDA macro
PRL_SCAN_CODE_U
PRL_SCAN_CODE_U macro
PRL_SCAN_CODE_UP
PRL_SCAN_CODE_UP macro
PRL_SCAN_CODE_V
PRL_SCAN_CODE_V macro
PRL_SCAN_CODE_VOLUME_DOWN
PRL_SCAN_CODE_VOLUME_DOWN macro
PRL_SCAN_CODE_VOLUME_UP
PRL_SCAN_CODE_VOLUME_UP macro
PRL_SCAN_CODE_W
PRL_SCAN_CODE_W macro
PRL_SCAN_CODE_WWW_BACK
PRL_SCAN_CODE_WWW_BACK macro
PRL_SCAN_CODE_WWW_FAVORITES
PRL_SCAN_CODE_WWW_FAVORITES macro
PRL_SCAN_CODE_WWW_FORWARD
PRL_SCAN_CODE_WWW_FORWARD macro
PRL_SCAN_CODE_WWW_HOME
PRL_SCAN_CODE_WWW_HOME macro
PRL_SCAN_CODE_WWW_REFRESH
PRL_SCAN_CODE_WWW_REFRESH macro
PRL_SCAN_CODE_WWW_SEARCH
PRL_SCAN_CODE_WWW_SEARCH macro
PRL_SCAN_CODE_WWW_STOP
PRL_SCAN_CODE_WWW_STOP macro
PRL_SCAN_CODE_X
PRL_SCAN_CODE_X macro
PRL_SCAN_CODE_Y
PRL_SCAN_CODE_Y macro
PRL_SCAN_CODE_YEN
PRL_SCAN_CODE_YEN macro
PRL_SCAN_CODE_Z
PRL_SCAN_CODE_Z macro
PRL_SCAN_CODE_ZENKAKU_HANKAKU
PRL_SCAN_CODE_ZENKAKU_HANKAKU macro
PRL_SCSI_READ_REQUESTS_PTRN
PRL_SCSI_READ_REQUESTS_PTRN macro
PRL_SCSI_READ_TOTAL_PTRN
PRL_SCSI_READ_TOTAL_PTRN macro
PRL_SCSI_WRITE_REQUESTS_PTRN
PRL_SCSI_WRITE_REQUESTS_PTRN macro
PRL_SCSI_WRITE_TOTAL_PTRN
PRL_SCSI_WRITE_TOTAL_PTRN macro
PRL_SDK_WRAP_FOR_EACH_MANAGER
PRL_SDK_WRAP_FOR_EACH_MANAGER macro
PRL_SECURITY_LEVEL
PRL_SECURITY_LEVEL enumeration
PRL_SECURITY_LEVEL_PTR
PRL_SECURITY_LEVEL_PTR type
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE enumeration
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR type
PRL_SERVICE_STATUS_ENUM
PRL_SERVICE_STATUS_ENUM enumeration
PRL_SERVICE_STATUS_ENUM_PTR
PRL_SERVICE_STATUS_ENUM_PTR type
PRL_SET_PROXY_CONNECTION_FLAGS
PRL_SET_PROXY_CONNECTION_FLAGS enumeration
PRL_SET_PROXY_CONNECTION_FLAGS_PTR
PRL_SET_PROXY_CONNECTION_FLAGS_PTR type
PRL_SET_USERPASSWD_FLAGS
PRL_SET_USERPASSWD_FLAGS enumeration
PRL_SET_USERPASSWD_FLAGS_PTR
PRL_SET_USERPASSWD_FLAGS_PTR type
PRL_SIZE
PRL_SIZE type
PRL_SIZE_PTR
PRL_SIZE_PTR type
PRL_SIZE_PTR_PTR
PRL_SIZE_PTR_PTR type
PRL_SNAPSHOT_ELEMENT
PRL_SNAPSHOT_ELEMENT structure
PRL_SNAPSHOT_ELEMENT_PTR
PRL_SNAPSHOT_ELEMENT_PTR type
PRL_SOUND_CHANNEL_TYPE
PRL_SOUND_CHANNEL_TYPE enumeration
PRL_SOUND_CHANNEL_TYPE_PTR
PRL_SOUND_CHANNEL_TYPE_PTR type
PRL_SRV_METHOD_DECL
PRL_SRV_METHOD_DECL macro
PRL_SRV_SHUTDOWN_FLAGS
PRL_SRV_SHUTDOWN_FLAGS enumeration
PRL_SRV_SHUTDOWN_FLAGS_PTR
PRL_SRV_SHUTDOWN_FLAGS_PTR type
PRL_STAT_NET_TRAFFIC
PRL_STAT_NET_TRAFFIC structure
PRL_STAT_NET_TRAFFIC_PTR
PRL_STAT_NET_TRAFFIC_PTR type
PRL_STATE_CALLBACK_INVALID
PRL_STATE_CALLBACK_INVALID macro
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK macro
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK macro
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK macro
PRL_STATE_DISK_CALLBACK
PRL_STATE_DISK_CALLBACK macro
PRL_STATE_DISK_CALLBACK_STAGE_CPL
PRL_STATE_DISK_CALLBACK_STAGE_CPL macro
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_COMPLETED macro
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MAX macro
PRL_STATE_PROGRESS_MIN
PRL_STATE_PROGRESS_MIN macro
PRL_STATES_CALLBACK
PRL_STATES_CALLBACK_TYPE
PRL_STATES_CALLBACK_TYPE type
PRL_STATES_CALLBACK_TYPE_PTR
PRL_STATES_CALLBACK_TYPE_PTR type
PRL_STR
PRL_STR type
PRL_STRUCT
PRL_STRUCT macro
PRL_SUCCEEDED
PRL_SUCCEEDED macro
PRL_SWITCH_SNAPSHOT_FLAGS
PRL_SWITCH_SNAPSHOT_FLAGS enumeration
PRL_TASKBAR_STATES
PRL_TASKBAR_STATES enumeration
PRL_TC_CLASS_MAX
PRL_TC_CLASS_MAX macro
PRL_TERNARY_FALSE
PRL_TERNARY_FALSE macro
PRL_TERNARY_TRUE
PRL_TERNARY_TRUE macro
PRL_TERNARY_UNDEF
PRL_TERNARY_UNDEF macro
PRL_TIS Types
PRL_TIS_INT_VERSION
PRL_TIS_INT_VERSION structure
PRL_TIS_INT_VERSION_PTR
PRL_TIS_INT_VERSION_PTR type
PRL_TIS_RECORD_FIELD
PRL_TIS_RECORD_FIELD enumeration
PRL_TIS_RECORD_FIELD_PTR
PRL_TIS_RECORD_FIELD_PTR type
PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO structure
PRL_TIS_RECORD_INFO_PTR
PRL_TIS_RECORD_INFO_PTR type
PRL_TIS_RECORD_STATE
PRL_TIS_RECORD_STATE enumeration
PRL_TIS_RECORD_STATE_PTR
PRL_TIS_RECORD_STATE_PTR type
PRL_TIS_VERSION
PRL_TIS_VERSION structure
PRL_TIS_VERSION_PTR
PRL_TIS_VERSION_PTR type
PRL_TOOLS Types
PRL_TOOLS_SIA_OPEN_IN_TYPES
PRL_TOOLS_SIA_OPEN_IN_TYPES enumeration
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR type
PRL_TOOLS_UTILITY_COMMAND_FLAG
PRL_TOOLS_UTILITY_COMMAND_FLAG enumeration
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR type
PRL_TOOLS_UTILITY_COMMAND_ID
PRL_TOOLS_UTILITY_COMMAND_ID enumeration
PRL_TOOLS_UTILITY_COMMAND_ID_PTR
PRL_TOOLS_UTILITY_COMMAND_ID_PTR type
PRL_TRUE
PRL_TRUE macro
PRL_UIEMU_AUTOKEYBOARD
PRL_UIEMU_AUTOKEYBOARD structure
PRL_UIEMU_AUTOKEYBOARD_PTR
PRL_UIEMU_AUTOKEYBOARD_PTR type
PRL_UIEMU_CARET_INFO
PRL_UIEMU_CARET_INFO structure
PRL_UIEMU_CARET_INFO_PTR
PRL_UIEMU_CARET_INFO_PTR type
PRL_UIEMU_CURSOR_DESC
PRL_UIEMU_CURSOR_DESC structure
PRL_UIEMU_CURSOR_DESC_PTR
PRL_UIEMU_CURSOR_DESC_PTR type
PRL_UIEMU_CURSOR_FORMAT
PRL_UIEMU_CURSOR_FORMAT structure
PRL_UIEMU_CURSOR_FORMAT_PTR
PRL_UIEMU_CURSOR_FORMAT_PTR type
PRL_UIEMU_CURSOR_POS
PRL_UIEMU_CURSOR_POS structure
PRL_UIEMU_CURSOR_POS_PTR
PRL_UIEMU_CURSOR_POS_PTR type
PRL_UIEMU_ELEMENT_AT_POS
PRL_UIEMU_ELEMENT_AT_POS structure
PRL_UIEMU_ELEMENT_AT_POS_PTR
PRL_UIEMU_ELEMENT_AT_POS_PTR type
PRL_UIEMU_ELEMENT_CONTROL_EDIT enumeration member
PRL_UIEMU_ELEMENT_CONTROL_NONE enumeration member
PRL_UIEMU_ELEMENT_CONTROL_OTHER enumeration member
PRL_UIEMU_ELEMENT_CONTROL_TYPE
PRL_UIEMU_ELEMENT_CONTROL_TYPE enumeration
PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR
PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR type
PRL_UIEMU_ELEMENT_SEARCH_AREA_GLOBAL enumeration member
PRL_UIEMU_ELEMENT_SEARCH_AREA_WINDOW enumeration member
PRL_UIEMU_GESTURE_DATA_PINCH
PRL_UIEMU_GESTURE_DATA_PINCH structure
PRL_UIEMU_GESTURE_DATA_PINCH_PTR
PRL_UIEMU_GESTURE_DATA_PINCH_PTR type
PRL_UIEMU_GESTURE_DATA_SMARTZOOM
PRL_UIEMU_GESTURE_DATA_SMARTZOOM structure
PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR
PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR type
PRL_UIEMU_GESTURE_EVENT
PRL_UIEMU_GESTURE_EVENT structure
PRL_UIEMU_GESTURE_EVENT_PTR
PRL_UIEMU_GESTURE_EVENT_PTR type
PRL_UIEMU_GESTURE_STATE
PRL_UIEMU_GESTURE_STATE enumeration
PRL_UIEMU_GESTURE_STATE_BEGIN enumeration member
PRL_UIEMU_GESTURE_STATE_CANCEL enumeration member
PRL_UIEMU_GESTURE_STATE_CHANGE enumeration member
PRL_UIEMU_GESTURE_STATE_END enumeration member
PRL_UIEMU_GESTURE_STATE_PTR
PRL_UIEMU_GESTURE_STATE_PTR type
PRL_UIEMU_GESTURE_TYPE
PRL_UIEMU_GESTURE_TYPE enumeration
PRL_UIEMU_GESTURE_TYPE_PINCH enumeration member
PRL_UIEMU_GESTURE_TYPE_PTR
PRL_UIEMU_GESTURE_TYPE_PTR type
PRL_UIEMU_GESTURE_TYPE_SMARTZOOM enumeration member
PRL_UIEMU_INPUT_INFO
PRL_UIEMU_INPUT_INFO structure
PRL_UIEMU_INPUT_INFO_PTR
PRL_UIEMU_INPUT_INFO_PTR type
PRL_UIEMU_MAKEUP_HINTING_RGN_PTR
PRL_UIEMU_MAKEUP_HINTING_RGN_PTR type
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE enumeration
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR
PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR type
PRL_UIEMU_MMKEY
PRL_UIEMU_MMKEY enumeration
PRL_UIEMU_MMKEY_PTR
PRL_UIEMU_MMKEY_PTR type
PRL_UIEMU_MMKEY_SWIPE_BOTTOM_EDGE enumeration member
PRL_UIEMU_MMKEY_SWIPE_LEFT_EDGE enumeration member
PRL_UIEMU_MMKEY_SWIPE_RIGHT_EDGE enumeration member
PRL_UIEMU_MMKEY_SWIPE_TOP_EDGE enumeration member
PRL_UIEMU_MOUSE_CLICK
PRL_UIEMU_MOUSE_CLICK enumeration
PRL_UIEMU_MOUSE_CLICK_PTR
PRL_UIEMU_MOUSE_CLICK_PTR type
PRL_UIEMU_SCROLL_FLAG_APPEND enumeration member
PRL_UIEMU_SCROLL_FLAG_NEW enumeration member
PRL_UIEMU_SCROLL_FLAGS
PRL_UIEMU_SCROLL_FLAGS enumeration
PRL_UIEMU_SCROLL_FLAGS_PTR
PRL_UIEMU_SCROLL_FLAGS_PTR type
PRL_UIEMU_SCROLL_LINES enumeration member
PRL_UIEMU_SCROLL_PIXELS enumeration member
PRL_UIEMU_SCROLL_POINTS enumeration member
PRL_UIEMU_SCROLL_UNITS
PRL_UIEMU_SCROLL_UNITS enumeration
PRL_UIEMU_SCROLL_UNITS_PTR
PRL_UIEMU_SCROLL_UNITS_PTR type
PRL_UIEMU_SELECTION_HINTING_RGN_PTR
PRL_UIEMU_SELECTION_HINTING_RGN_PTR type
PRL_UIEMU_VKEY
PRL_UIEMU_VKEY structure
PRL_UIEMU_VKEY_PTR
PRL_UIEMU_VKEY_PTR type
PRL_UINT Types
PRL_UINT16
PRL_UINT16 type
PRL_UINT16_PTR
PRL_UINT16_PTR type
PRL_UINT16_PTR_PTR
PRL_UINT16_PTR_PTR type
PRL_UINT32
PRL_UINT32 type
PRL_UINT32_PTR
PRL_UINT32_PTR type
PRL_UINT32_PTR_PTR
PRL_UINT32_PTR_PTR type
PRL_UINT64
PRL_UINT64 type
PRL_UINT64_PTR
PRL_UINT64_PTR type
PRL_UINT64_PTR_PTR
PRL_UINT64_PTR_PTR type
PRL_UINT8
PRL_UINT8 type
PRL_UINT8_PTR
PRL_UINT8_PTR type
PRL_UINT8_PTR_PTR
PRL_UINT8_PTR_PTR type
PRL_UNDO_DISKS_MODE
PRL_UNDO_DISKS_MODE enumeration
PRL_UNDO_DISKS_MODE_PTR
PRL_UNDO_DISKS_MODE_PTR type
PRL_UPDATE_LICENSE_FLAGS
PRL_UPDATE_LICENSE_FLAGS enumeration
PRL_UPDATE_LICENSE_FLAGS_PTR
PRL_UPDATE_LICENSE_FLAGS_PTR type
PRL_USB_DEVICE_AUTO_CONNECT_OPTION
PRL_USB_DEVICE_AUTO_CONNECT_OPTION enumeration
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR type
PRL_USB_DEVICE_CONNECT_REASON
PRL_USB_DEVICE_CONNECT_REASON enumeration
PRL_USB_DEVICE_CONNECT_REASON_PTR
PRL_USB_DEVICE_CONNECT_REASON_PTR type
PRL_USB_DEVICE_TYPE
PRL_USB_DEVICE_TYPE enumeration
PRL_USB_DEVICE_TYPE_PTR
PRL_USB_DEVICE_TYPE_PTR type
PRL_VERSION_10X enumeration member
PRL_VERSION_11X enumeration member
PRL_VERSION_3X enumeration member
PRL_VERSION_4X enumeration member
PRL_VERSION_5X enumeration member
PRL_VERSION_6X enumeration member
PRL_VERSION_7X enumeration member
PRL_VERSION_8X enumeration member
PRL_VERSION_9X enumeration member
PRL_VERSION_ANY enumeration member
PRL_VERSION_ENUM
PRL_VERSION_ENUM enumeration
PRL_VERSION_ENUM_PTR
PRL_VERSION_ENUM_PTR type
PRL_VIDEO_3D_ACCELERATION
PRL_VIDEO_3D_ACCELERATION enumeration
PRL_VIDEO_3D_ACCELERATION_PTR
PRL_VIDEO_3D_ACCELERATION_PTR type
PRL_VIDEO_RECEIVER_CONFIG
PRL_VIDEO_RECEIVER_CONFIG structure
PRL_VIDEO_RECEIVER_CONFIG_PTR
PRL_VIDEO_RECEIVER_CONFIG_PTR type
PRL_VIDEO_RECEIVER_CONNECTION_STATE
PRL_VIDEO_RECEIVER_CONNECTION_STATE enumeration
PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR
PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR type
PRL_VIDEO_RECEIVER_FRAME
PRL_VIDEO_RECEIVER_FRAME structure
PRL_VIDEO_RECEIVER_FRAME_DESC
PRL_VIDEO_RECEIVER_FRAME_DESC structure
PRL_VIDEO_RECEIVER_FRAME_DESC_PTR
PRL_VIDEO_RECEIVER_FRAME_DESC_PTR type
PRL_VIDEO_RECEIVER_FRAME_PTR
PRL_VIDEO_RECEIVER_FRAME_PTR type
PRL_VIDEO_RECEIVER_STATISTICS
PRL_VIDEO_RECEIVER_STATISTICS structure
PRL_VIDEO_RECEIVER_STATISTICS_PTR
PRL_VIDEO_RECEIVER_STATISTICS_PTR type
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY structure
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR
PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR type
PRL_VIRTUAL_MACHINE_PROFILE
PRL_VIRTUAL_MACHINE_PROFILE enumeration
PRL_VIRTUAL_MACHINE_PROFILE_PTR
PRL_VIRTUAL_MACHINE_PROFILE_PTR type
PRL_VM Structs
PRL_VM Types
PRL_VM_ACCELERATION_LEVEL
PRL_VM_ACCELERATION_LEVEL enumeration
PRL_VM_ACCELERATION_LEVEL_PTR
PRL_VM_ACCELERATION_LEVEL_PTR type
PRL_VM_ACCESS_FOR_OTHERS
PRL_VM_ACCESS_FOR_OTHERS enumeration
PRL_VM_ACCESS_FOR_OTHERS_PTR
PRL_VM_ACCESS_FOR_OTHERS_PTR type
PRL_VM_ACTION
PRL_VM_ACTION enumeration
PRL_VM_ACTION_ON_STOP
PRL_VM_ACTION_ON_STOP enumeration
PRL_VM_ACTION_ON_STOP_PTR
PRL_VM_ACTION_ON_STOP_PTR type
PRL_VM_ACTION_ON_WINDOW_CLOSE
PRL_VM_ACTION_ON_WINDOW_CLOSE enumeration
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR type
PRL_VM_ACTION_PTR
PRL_VM_ACTION_PTR type
PRL_VM_AUTOSTART_OPTION
PRL_VM_AUTOSTART_OPTION enumeration
PRL_VM_AUTOSTART_OPTION_PTR
PRL_VM_AUTOSTART_OPTION_PTR type
PRL_VM_AUTOSTOP_OPTION
PRL_VM_AUTOSTOP_OPTION enumeration
PRL_VM_AUTOSTOP_OPTION_PTR
PRL_VM_AUTOSTOP_OPTION_PTR type
PRL_VM_BACKUP_FLAGS
PRL_VM_BACKUP_FLAGS enumeration
PRL_VM_BACKUP_TYPE
PRL_VM_BACKUP_TYPE enumeration
PRL_VM_BACKUP_TYPE_PTR
PRL_VM_BACKUP_TYPE_PTR type
PRL_VM_BOOT_ORDER
PRL_VM_BOOT_ORDER enumeration
PRL_VM_BOOT_ORDER_PTR
PRL_VM_BOOT_ORDER_PTR type
PRL_VM_COLOR
PRL_VM_COLOR enumeration
PRL_VM_COLOR_PTR
PRL_VM_COLOR_PTR type
PRL_VM_COMMIT_FLAGS
PRL_VM_COMMIT_FLAGS enumeration
PRL_VM_CONFIG_SECTIONS
PRL_VM_CONFIG_SECTIONS enumeration
PRL_VM_CONFIG_SECTIONS_PTR
PRL_VM_CONFIG_SECTIONS_PTR type
PRL_VM_DEV_EMULATION_TYPE
PRL_VM_DEV_EMULATION_TYPE enumeration
PRL_VM_DEV_EMULATION_TYPE_PTR
PRL_VM_DEV_EMULATION_TYPE_PTR type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR
PRL_VM_EXEC_APP_FILE_DESCRIPTOR enumeration
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR type
PRL_VM_EXEC_RUN_PROGRAM_MODES
PRL_VM_EXEC_RUN_PROGRAM_MODES enumeration
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR type
PRL_VM_LOCATION
PRL_VM_LOCATION enumeration
PRL_VM_LOCATION_PTR
PRL_VM_LOCATION_PTR type
PRL_VM_MIGRATION_FLAGS
PRL_VM_MIGRATION_FLAGS enumeration
PRL_VM_MOUSE_CURSOR_STATE
PRL_VM_MOUSE_CURSOR_STATE enumeration
PRL_VM_MOUSE_CURSOR_STATE_PTR
PRL_VM_MOUSE_CURSOR_STATE_PTR type
PRL_VM_MOUSE_STATE
PRL_VM_MOUSE_STATE enumeration
PRL_VM_MOUSE_STATE_PTR
PRL_VM_MOUSE_STATE_PTR type
PRL_VM_NET_ADAPTER_TYPE
PRL_VM_NET_ADAPTER_TYPE enumeration
PRL_VM_NET_ADAPTER_TYPE_PTR
PRL_VM_NET_ADAPTER_TYPE_PTR type
PRL_VM_NET_ADAPTER_WIFI_RULE
PRL_VM_NET_ADAPTER_WIFI_RULE enumeration
PRL_VM_NET_ADAPTER_WIFI_RULE_PTR
PRL_VM_NET_ADAPTER_WIFI_RULE_PTR type
PRL_VM_NORMAL_START_FLAGS
PRL_VM_NORMAL_START_FLAGS enumeration
PRL_VM_NORMAL_START_FLAGS_PTR
PRL_VM_NORMAL_START_FLAGS_PTR type
PRL_VM_PRIORITY
PRL_VM_PRIORITY enumeration
PRL_VM_PRIORITY_PTR
PRL_VM_PRIORITY_PTR type
PRL_VM_REMOTE_DISPLAY_MODE
PRL_VM_REMOTE_DISPLAY_MODE enumeration
PRL_VM_REMOTE_DISPLAY_MODE_PTR
PRL_VM_REMOTE_DISPLAY_MODE_PTR type
PRL_VM_SMARTGUARD_SCHEMA
PRL_VM_SMARTGUARD_SCHEMA enumeration
PRL_VM_SMARTGUARD_SCHEMA_PTR
PRL_VM_SMARTGUARD_SCHEMA_PTR type
PRL_VM_START_LOGIN_MODE
PRL_VM_START_LOGIN_MODE enumeration
PRL_VM_START_LOGIN_MODE_PTR
PRL_VM_START_LOGIN_MODE_PTR type
PRL_VM_START_MODE
PRL_VM_START_MODE enumeration
PRL_VM_START_MODE_PTR
PRL_VM_START_MODE_PTR type
PRL_VM_STATISTICS_FLAGS
PRL_VM_STATISTICS_FLAGS enumeration
PRL_VM_STATISTICS_FLAGS_PTR
PRL_VM_STATISTICS_FLAGS_PTR type
PRL_VM_STOP_FLAGS
PRL_VM_STOP_FLAGS enumeration
PRL_VM_STOP_MODE
PRL_VM_STOP_MODE enumeration
PRL_VM_STOP_MODE_MASK
PRL_VM_STOP_MODE_MASK macro
PRL_VM_STORE_VALUE_FLAGS
PRL_VM_STORE_VALUE_FLAGS enumeration
PRL_VM_TOOLS_STATE
PRL_VM_TOOLS_STATE enumeration
PRL_VM_TOOLS_STATE_PTR
PRL_VM_TOOLS_STATE_PTR type
PRL_VM_TYPE
PRL_VM_TYPE enumeration
PRL_VM_TYPE_FLAGS
PRL_VM_TYPE_FLAGS enumeration
PRL_VM_TYPE_PTR
PRL_VM_TYPE_PTR type
PRL_VM_WINDOW_MODE
PRL_VM_WINDOW_MODE enumeration
PRL_VM_WINDOW_MODE_PTR
PRL_VM_WINDOW_MODE_PTR type
PRL_VMCTG_EVENT
PRL_VMCTG_EVENT enumeration
PRL_VMCTG_EVENT_PTR
PRL_VMCTG_EVENT_PTR type
PRL_VMCTG_TOOL_DATA_RECEIVED
PRL_VMCTG_TOOL_DATA_RECEIVED structure
PRL_VMCTG_TOOL_DATA_RECEIVED_PTR
PRL_VMCTG_TOOL_DATA_RECEIVED_PTR type
PRL_VMCTG_TOOL_DESC
PRL_VMCTG_TOOL_DESC structure
PRL_VMCTG_TOOL_DESC_PTR
PRL_VMCTG_TOOL_DESC_PTR type
PRL_VOID
PRL_VOID type
PRL_VOID Types
PRL_VOID_PTR
PRL_VOID_PTR type
PRL_VOID_PTR_PTR
PRL_VOID_PTR_PTR type
PRL_VTD_STATUS_CODE
PRL_VTD_STATUS_CODE enumeration
PRL_VTD_STATUS_CODE_PTR
PRL_VTD_STATUS_CODE_PTR type
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND
PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND macro
PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED macro
PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE
PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE macro
PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP
PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP macro
PRL_WARN_BACKUP_NON_IMAGE_HDD
PRL_WARN_BACKUP_NON_IMAGE_HDD macro
PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED
PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED macro
PRL_WARN_CANNOT_MOUNT_BACK_PARTITION
PRL_WARN_CANNOT_MOUNT_BACK_PARTITION macro
PRL_WARN_CANT_CONNECT_VOLUME
PRL_WARN_CANT_CONNECT_VOLUME macro
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_DESTRUCTIVE macro
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_COMPACT_THROUGH_COPY macro
PRL_WARN_DEV_USB_CONNECT_FAILED
PRL_WARN_DEV_USB_CONNECT_FAILED macro
PRL_WARN_DEV_USB_OPEN_FAILED
PRL_WARN_DEV_USB_OPEN_FAILED macro
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAILED_TO_START_VNC_SERVER macro
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_FAT32_FILE_OVERRUN macro
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT macro
PRL_WARN_HDD_ERROR
PRL_WARN_HDD_ERROR macro
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_IMAGE_IS_STOLEN macro
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_LAN_NOT_CONNECTED macro
PRL_WARN_LICENSE_RESTRICTED_RKU
PRL_WARN_LICENSE_RESTRICTED_RKU macro
PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE
PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE macro
PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT
PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT macro
PRL_WARN_NOT_SYMMETRIC_CPU
PRL_WARN_NOT_SYMMETRIC_CPU macro
PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE
PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE macro
PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP
PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP macro
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TARGET_HOST_DISK_IS_FULL macro
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_TOO_LOW_HDD_SIZE macro
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE macro
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNABLE_OPEN_DEVICE_NAME macro
PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM
PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM macro
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE macro
PRL_WARN_VERBOSE_LOGGING
PRL_WARN_VERBOSE_LOGGING macro
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_BOOTCAMP_MODE macro
PRL_WARN_VM_DISCONNECT_SATA_HDD
PRL_WARN_VM_DISCONNECT_SATA_HDD macro
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV macro
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST macro
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_MODE macro
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE macro
PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED
PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED macro
PRL_WARN_WINDOWS_UPDATE_WORKING
PRL_WARN_WINDOWS_UPDATE_WORKING macro
PRL_WIN_EXTENDED_PARTITION
PRL_WIN_EXTENDED_PARTITION macro
PRL_WINDOW_CORNERS
PRL_WINDOW_CORNERS enumeration
PRL_WINDOW_CORNERS_PTR
PRL_WINDOW_CORNERS_PTR type
PRL_WINDOW_EDGE_MASK
PRL_WINDOW_EDGE_MASK enumeration
PRL_WINDOW_EDGE_MASK_PTR
PRL_WINDOW_EDGE_MASK_PTR type
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT macro
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32 macro
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_FAT32_LBA macro
PRL_WINDOWS_PARTITION_NTFS
PRL_WINDOWS_PARTITION_NTFS macro
PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED
PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED macro
PRL_WNG_START_VM_ON_MOUNTED_DISK
PRL_WNG_START_VM_ON_MOUNTED_DISK macro
PRL_WRN_IT_CANT_RESIZE_LDM_DISK
PRL_WRN_IT_CANT_RESIZE_LDM_DISK macro
PRL_WRN_IT_CANT_RESIZE_VOLUME
PRL_WRN_IT_CANT_RESIZE_VOLUME macro
PRL_WRN_IT_EMPTY_MBR
PRL_WRN_IT_EMPTY_MBR macro
PRL_WRN_IT_FIRST_WARNING
PRL_WRN_IT_FIRST_WARNING macro
PRL_WRN_IT_VOLUME_RESIZING
PRL_WRN_IT_VOLUME_RESIZING macro
PRL_WS_RECLAIMABLE_PTRN
PRL_WS_RECLAIMABLE_PTRN macro
PrlAcl_GetAccessForOthers
PrlAcl_GetAccessForOthers function
PrlAcl_GetOwnerName
PrlAcl_GetOwnerName function
PrlAcl_IsAllowed
PrlAcl_IsAllowed function
PrlAcl_IsCurrentSessionOwner
PrlAcl_IsCurrentSessionOwner function
PrlAcl_SetAccessForOthers
PrlAcl_SetAccessForOthers function
PrlApi_AddRemoteDevCommandBuffer@PRL_HANDLE@PRL_VOID_PTR@PRL_UINT32
PrlApi_AddRemoteDevCommandParam@PRL_HANDLE@PRL_UINT32
PrlApi_CalcIconHash
PrlApi_CalcIconHash function
PrlApi_CreateCredentials
PrlApi_CreateCredentials function
PrlApi_CreateHandlesList
PrlApi_CreateHandlesList function
PrlApi_CreateOpTypeList
PrlApi_CreateOpTypeList function
PrlApi_CreateProblemReport
PrlApi_CreateProblemReport function
PrlApi_CreateRemoteCommand
PrlApi_CreateRemoteCommand function
PrlApi_CreateStringsList
PrlApi_CreateStringsList function
PrlApi_Deinit
PrlApi_Deinit function
PrlApi_GetAppMode
PrlApi_GetAppMode function
PrlApi_GetCrashDumpsPath
PrlApi_GetCrashDumpsPath function
PrlApi_GetDefaultOsVersion
PrlApi_GetDefaultOsVersion function
PrlApi_GetMessageType
PrlApi_GetMessageType function
PrlApi_GetRecommendMinVmMem
PrlApi_GetRecommendMinVmMem function
PrlApi_GetRemoteCommandBuffer
PrlApi_GetRemoteCommandBuffer function
PrlApi_GetRemoteCommandCode
PrlApi_GetRemoteCommandCode function
PrlApi_GetRemoteCommandIndex
PrlApi_GetRemoteCommandIndex function
PrlApi_GetRemoteCommandTarget
PrlApi_GetRemoteCommandTarget function
PrlApi_GetRemoteDeviceRegistration
PrlApi_GetRemoteDeviceRegistration function
PrlApi_GetResultDescription
PrlApi_GetResultDescription function
PrlApi_GetSupportedOsesTypes
PrlApi_GetSupportedOsesTypes function
PrlApi_GetSupportedOsesVersions
PrlApi_GetSupportedOsesVersions function
PrlApi_GetUserData
PrlApi_GetUserData function
PrlApi_GetUserKeys
PrlApi_GetUserKeys function
PrlApi_GetVersion
PrlApi_GetVersion function
PrlApi_Init
PrlApi_Init function
PrlApi_InitCrashHandler
PrlApi_InitCrashHandler function
PrlApi_InitEx
PrlApi_InitEx function
PrlApi_MsgCanBeIgnored
PrlApi_MsgCanBeIgnored function
PrlApi_PutIcon
PrlApi_PutIcon function
PrlApi_PutUserData
PrlApi_PutUserData function
PrlApi_RegisterRemoteDevice
PrlApi_RegisterRemoteDevice function
PrlApi_RemoveUserData
PrlApi_RemoveUserData function
PrlApi_ScaleImage
PrlApi_ScaleImage function
PrlApi_SendPackedProblemReport
PrlApi_SendPackedProblemReport function
PrlApi_SendProblemReport
PrlApi_SendProblemReport function
PrlApi_SendRemoteCommand
PrlApi_SendRemoteCommand function
PrlApi_SignCertificate
PrlApi_SignCertificate function
PrlApi_SignCertificateEx
PrlApi_SignCertificateEx function
PrlApi_SubscribeOnRegistration
PrlApi_SubscribeOnRegistration function
PrlApi_SwitchConsoleLogging
PrlApi_SwitchConsoleLogging function
PrlApi_UnregisterRemoteDevice
PrlApi_UnregisterRemoteDevice function
PrlApi_ValidateInCache
PrlApi_ValidateInCache function
PrlAppliance_Create
PrlAppliance_Create function
PrlBackupResult_GetBackupUuid
PrlBackupResult_GetBackupUuid function
PrlBootDev_GetIndex
PrlBootDev_GetIndex function
PrlBootDev_GetSequenceIndex
PrlBootDev_GetSequenceIndex function
PrlBootDev_GetType
PrlBootDev_GetType function
PrlBootDev_IsInUse
PrlBootDev_IsInUse function
PrlBootDev_Remove
PrlBootDev_Remove function
PrlBootDev_SetIndex
PrlBootDev_SetIndex function
PrlBootDev_SetInUse
PrlBootDev_SetInUse function
PrlBootDev_SetSequenceIndex
PrlBootDev_SetSequenceIndex function
PrlBootDev_SetType
PrlBootDev_SetType function
PrlBuffer
PrlBuffer_Free
PrlBuffer_Free function
PrlCtTemplate_GetCpuMode
PrlCtTemplate_GetCpuMode function
PrlCtTemplate_GetDescription
PrlCtTemplate_GetDescription function
PrlCtTemplate_GetName
PrlCtTemplate_GetName function
PrlCtTemplate_GetOsTemplate
PrlCtTemplate_GetOsTemplate function
PrlCtTemplate_GetOsType
PrlCtTemplate_GetOsType function
PrlCtTemplate_GetOsVersion
PrlCtTemplate_GetOsVersion function
PrlCtTemplate_GetType
PrlCtTemplate_GetType function
PrlCtTemplate_GetVersion
PrlCtTemplate_GetVersion function
PrlCtTemplate_IsCached
PrlCtTemplate_IsCached function
PrlCVSrc_Close
PrlCVSrc_Close function
PrlCVSrc_Connect
PrlCVSrc_Connect function
PrlCVSrc_Disconnect
PrlCVSrc_Disconnect function
PrlCVSrc_GetBuffer
PrlCVSrc_GetBuffer function
PrlCVSrc_GetOpenMode
PrlCVSrc_GetOpenMode function
PrlCVSrc_LockBuffer
PrlCVSrc_LockBuffer function
PrlCVSrc_Open
PrlCVSrc_Open function
PrlCVSrc_SetLocalizedName
PrlCVSrc_SetLocalizedName function
PrlCVSrc_SetUniqueId
PrlCVSrc_SetUniqueId function
PrlCVSrc_UnlockBuffer
PrlCVSrc_UnlockBuffer function
PrlDbg_EventTypeToString
PrlDbg_EventTypeToString function
PrlDbg_GetHandlesNum
PrlDbg_GetHandlesNum function
PrlDbg_HandleTypeToString
PrlDbg_HandleTypeToString function
PrlDbg_PrlResultToString
PrlDbg_PrlResultToString function
PrlDevAudio_GetSwitcherState
PrlDevAudio_GetSwitcherState function
PrlDevAudio_SetSwitcherState
PrlDevAudio_SetSwitcherState function
PrlDevAudio_StartStream
PrlDevAudio_StartStream function
PrlDevAudio_StopStream
PrlDevAudio_StopStream function
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer function
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile function
PrlDevDisplay_AsyncCaptureScreenRegionToFile
PrlDevDisplay_AsyncCaptureScreenRegionToFile function
PrlDevDisplay_ConnectToVm
PrlDevDisplay_ConnectToVm function
PrlDevDisplay_ConnectToVmEx
PrlDevDisplay_ConnectToVmEx function
PrlDevDisplay_DisconnectFromVm
PrlDevDisplay_DisconnectFromVm function
PrlDevDisplay_GetAvailableDisplaysCount
PrlDevDisplay_GetAvailableDisplaysCount function
PrlDevDisplay_GetDisplayEncoding
PrlDevDisplay_GetDisplayEncoding function
PrlDevDisplay_GetDynResToolStatus
PrlDevDisplay_GetDynResToolStatus function
PrlDevDisplay_GetScreenBuffer
PrlDevDisplay_GetScreenBuffer function
PrlDevDisplay_GetScreenSize
PrlDevDisplay_GetScreenSize function
PrlDevDisplay_IsSlidingMouseEnabled
PrlDevDisplay_IsSlidingMouseEnabled function
PrlDevDisplay_LockForRead
PrlDevDisplay_LockForRead function
PrlDevDisplay_NeedCursorData
PrlDevDisplay_NeedCursorData function
PrlDevDisplay_SendCaptureScreenRequest
PrlDevDisplay_SendCaptureScreenRequest function
PrlDevDisplay_SendScreenSizeEvent
PrlDevDisplay_SendScreenSizeEvent function
PrlDevDisplay_SetConfiguration
PrlDevDisplay_SetConfiguration function
PrlDevDisplay_SetDisplayEncoding
PrlDevDisplay_SetDisplayEncoding function
PrlDevDisplay_SetDpiConfiguration
PrlDevDisplay_SetDpiConfiguration function
PrlDevDisplay_SetScreenSurface
PrlDevDisplay_SetScreenSurface function
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer function
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile function
PrlDevDisplay_SyncCaptureScreenRegionToFile
PrlDevDisplay_SyncCaptureScreenRegionToFile function
PrlDevDisplay_Unlock
PrlDevDisplay_Unlock function
PrlDevKeyboard_SendKeyEvent
PrlDevKeyboard_SendKeyEvent function
PrlDevKeyboard_SendKeyEventEx
PrlDevKeyboard_SendKeyEventEx function
PrlDevKeyboard_SendKeyPressedAndReleased
PrlDevKeyboard_SendKeyPressedAndReleased function
PrlDevMouse_AsyncMove
PrlDevMouse_AsyncMove function
PrlDevMouse_AsyncSetPos
PrlDevMouse_AsyncSetPos function
PrlDevMouse_Event
PrlDevMouse_Event function
PrlDevMouse_Move
PrlDevMouse_Move function
PrlDevMouse_MoveEx
PrlDevMouse_MoveEx function
PrlDevMouse_SetPos
PrlDevMouse_SetPos function
PrlDevMouse_SetPosEx
PrlDevMouse_SetPosEx function
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer function
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile function
PrlDevSecondaryDisplay_GetScreenBuffer
PrlDevSecondaryDisplay_GetScreenBuffer function
PrlDevSecondaryDisplay_GetScreenBufferEx
PrlDevSecondaryDisplay_GetScreenBufferEx function
PrlDevSecondaryDisplay_GetScreenBufferFormat
PrlDevSecondaryDisplay_GetScreenBufferFormat function
PrlDevSecondaryDisplay_GetScreenSize
PrlDevSecondaryDisplay_GetScreenSize function
PrlDevSecondaryDisplay_SendCaptureScreenRequest
PrlDevSecondaryDisplay_SendCaptureScreenRequest function
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer function
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile function
PrlDisk_ChangeKey
PrlDisk_ChangeKey function
PrlDisk_Coagulate
PrlDisk_Coagulate function
PrlDisk_CommitUnfinishedOp
PrlDisk_CommitUnfinishedOp function
PrlDisk_Compact
PrlDisk_Compact function
PrlDisk_CompactByBitmap
PrlDisk_CompactByBitmap function
PrlDisk_ConvertToCHS
PrlDisk_ConvertToCHS function
PrlDisk_ConvertToCurrent
PrlDisk_ConvertToCurrent function
PrlDisk_ConvertToCurrent_Local
PrlDisk_ConvertToCurrent_Local function
PrlDisk_ConvertToExtendFormat
PrlDisk_ConvertToExtendFormat function
PrlDisk_CreateDisk
PrlDisk_CreateDisk function
PrlDisk_CreateDisk_Local
PrlDisk_CreateDisk_Local function
PrlDisk_CreateState
PrlDisk_CreateState function
PrlDisk_DecreaseCapacity
PrlDisk_DecreaseCapacity function
PrlDisk_Decrypt
PrlDisk_Decrypt function
PrlDisk_DeleteState
PrlDisk_DeleteState function
PrlDisk_Encrypt
PrlDisk_Encrypt function
PrlDisk_FixConsistency
PrlDisk_FixConsistency function
PrlDisk_FlushCache
PrlDisk_FlushCache function
PrlDisk_Free
PrlDisk_Free function
PrlDisk_GetDefaultBlockSize
PrlDisk_GetDefaultBlockSize function
PrlDisk_GetDiskInfo
PrlDisk_GetDiskInfo function
PrlDisk_GetIdentify
PrlDisk_GetIdentify function
PrlDisk_GetSnapshotsCount
PrlDisk_GetSnapshotsCount function
PrlDisk_GetSnapshotsTree
PrlDisk_GetSnapshotsTree function
PrlDisk_GetSplitPartSize
PrlDisk_GetSplitPartSize function
PrlDisk_GetUserParameter
PrlDisk_GetUserParameter function
PrlDisk_IncreaseCapacity
PrlDisk_IncreaseCapacity function
PrlDisk_IsBootable_Local
PrlDisk_IsBootable_Local function
PrlDisk_IsCompactable
PrlDisk_IsCompactable function
PrlDisk_IsEncrypted
PrlDisk_IsEncrypted function
PrlDisk_LinkedClone_Local
PrlDisk_LinkedClone_Local function
PrlDisk_OpenDisk
PrlDisk_OpenDisk function
PrlDisk_OpenDisk_Local
PrlDisk_OpenDisk_Local function
PrlDisk_Read
PrlDisk_Read function
PrlDisk_SetCachingPolicy
PrlDisk_SetCachingPolicy function
PrlDisk_SetKey
PrlDisk_SetKey function
PrlDisk_SetSharedDirectory
PrlDisk_SetSharedDirectory function
PrlDisk_SetSharedDirectory_Local
PrlDisk_SetSharedDirectory_Local function
PrlDisk_SetUserParameter
PrlDisk_SetUserParameter function
PrlDisk_SwitchToState
PrlDisk_SwitchToState function
PrlDisk_WaitForCompletion
PrlDisk_WaitForCompletion function
PrlDisk_Write
PrlDisk_Write function
PrlDispCfg_ArePluginsEnabled
PrlDispCfg_ArePluginsEnabled function
PrlDispCfg_CanChangeDefaultSettings
PrlDispCfg_CanChangeDefaultSettings function
PrlDispCfg_EnablePlugins
PrlDispCfg_EnablePlugins function
PrlDispCfg_GetBackupTimeout
PrlDispCfg_GetBackupTimeout function
PrlDispCfg_GetBackupTmpDir
PrlDispCfg_GetBackupTmpDir function
PrlDispCfg_GetBackupUserLogin
PrlDispCfg_GetBackupUserLogin function
PrlDispCfg_GetConfirmationsList
PrlDispCfg_GetConfirmationsList function
PrlDispCfg_GetCpuFeaturesMaskEx
PrlDispCfg_GetCpuFeaturesMaskEx function
PrlDispCfg_GetDefaultBackupDirectory
PrlDispCfg_GetDefaultBackupDirectory function
PrlDispCfg_GetDefaultBackupServer
PrlDispCfg_GetDefaultBackupServer function
PrlDispCfg_GetDefaultCtDir
PrlDispCfg_GetDefaultCtDir function
PrlDispCfg_GetDefaultEncryptionPluginId
PrlDispCfg_GetDefaultEncryptionPluginId function
PrlDispCfg_GetDefaultVmDir
PrlDispCfg_GetDefaultVmDir function
PrlDispCfg_GetDefaultVNCHostName
PrlDispCfg_GetDefaultVNCHostName function
PrlDispCfg_GetMaxReservMemLimit
PrlDispCfg_GetMaxReservMemLimit function
PrlDispCfg_GetMaxVmMem
PrlDispCfg_GetMaxVmMem function
PrlDispCfg_GetMinReservMemLimit
PrlDispCfg_GetMinReservMemLimit function
PrlDispCfg_GetMinSecurityLevel
PrlDispCfg_GetMinSecurityLevel function
PrlDispCfg_GetMinVmMem
PrlDispCfg_GetMinVmMem function
PrlDispCfg_GetMobileAdvancedAuthMode
PrlDispCfg_GetMobileAdvancedAuthMode function
PrlDispCfg_GetProxyConnectionStatus
PrlDispCfg_GetProxyConnectionStatus function
PrlDispCfg_GetProxyConnectionUser
PrlDispCfg_GetProxyConnectionUser function
PrlDispCfg_GetRecommendMaxVmMem
PrlDispCfg_GetRecommendMaxVmMem function
PrlDispCfg_GetReservedMemLimit
PrlDispCfg_GetReservedMemLimit function
PrlDispCfg_GetUsbIdentity
PrlDispCfg_GetUsbIdentity function
PrlDispCfg_GetUsbIdentityCount
PrlDispCfg_GetUsbIdentityCount function
PrlDispCfg_GetVNCBasePort
PrlDispCfg_GetVNCBasePort function
PrlDispCfg_IsAdjustMemAuto
PrlDispCfg_IsAdjustMemAuto function
PrlDispCfg_IsAllowAttachScreenshotsEnabled
PrlDispCfg_IsAllowAttachScreenshotsEnabled function
PrlDispCfg_IsAllowDirectMobile
PrlDispCfg_IsAllowDirectMobile function
PrlDispCfg_IsAllowMobileClients
PrlDispCfg_IsAllowMobileClients function
PrlDispCfg_IsAllowMultiplePMC
PrlDispCfg_IsAllowMultiplePMC function
PrlDispCfg_IsBackupUserPasswordEnabled
PrlDispCfg_IsBackupUserPasswordEnabled function
PrlDispCfg_IsLogRotationEnabled
PrlDispCfg_IsLogRotationEnabled function
PrlDispCfg_IsProxyEnabled
PrlDispCfg_IsProxyEnabled function
PrlDispCfg_IsSendStatisticReport
PrlDispCfg_IsSendStatisticReport function
PrlDispCfg_IsVerboseLogEnabled
PrlDispCfg_IsVerboseLogEnabled function
PrlDispCfg_SetAdjustMemAuto
PrlDispCfg_SetAdjustMemAuto function
PrlDispCfg_SetAllowAttachScreenshotsEnabled
PrlDispCfg_SetAllowAttachScreenshotsEnabled function
PrlDispCfg_SetAllowDirectMobile
PrlDispCfg_SetAllowDirectMobile function
PrlDispCfg_SetAllowMultiplePMC
PrlDispCfg_SetAllowMultiplePMC function
PrlDispCfg_SetBackupTimeout
PrlDispCfg_SetBackupTimeout function
PrlDispCfg_SetBackupTmpDir
PrlDispCfg_SetBackupTmpDir function
PrlDispCfg_SetBackupUserLogin
PrlDispCfg_SetBackupUserLogin function
PrlDispCfg_SetBackupUserPassword
PrlDispCfg_SetBackupUserPassword function
PrlDispCfg_SetBackupUserPasswordEnabled
PrlDispCfg_SetBackupUserPasswordEnabled function
PrlDispCfg_SetCanChangeDefaultSettings
PrlDispCfg_SetCanChangeDefaultSettings function
PrlDispCfg_SetConfirmationsList
PrlDispCfg_SetConfirmationsList function
PrlDispCfg_SetCpuFeaturesMaskEx
PrlDispCfg_SetCpuFeaturesMaskEx function
PrlDispCfg_SetDefaultBackupDirectory
PrlDispCfg_SetDefaultBackupDirectory function
PrlDispCfg_SetDefaultBackupServer
PrlDispCfg_SetDefaultBackupServer function
PrlDispCfg_SetDefaultEncryptionPluginId
PrlDispCfg_SetDefaultEncryptionPluginId function
PrlDispCfg_SetDefaultVNCHostName
PrlDispCfg_SetDefaultVNCHostName function
PrlDispCfg_SetLogRotationEnabled
PrlDispCfg_SetLogRotationEnabled function
PrlDispCfg_SetMaxReservMemLimit
PrlDispCfg_SetMaxReservMemLimit function
PrlDispCfg_SetMaxVmMem
PrlDispCfg_SetMaxVmMem function
PrlDispCfg_SetMinReservMemLimit
PrlDispCfg_SetMinReservMemLimit function
PrlDispCfg_SetMinSecurityLevel
PrlDispCfg_SetMinSecurityLevel function
PrlDispCfg_SetMinVmMem
PrlDispCfg_SetMinVmMem function
PrlDispCfg_SetMobileAdvancedAuthMode
PrlDispCfg_SetMobileAdvancedAuthMode function
PrlDispCfg_SetProxyConnectionCreds
PrlDispCfg_SetProxyConnectionCreds function
PrlDispCfg_SetRecommendMaxVmMem
PrlDispCfg_SetRecommendMaxVmMem function
PrlDispCfg_SetReservedMemLimit
PrlDispCfg_SetReservedMemLimit function
PrlDispCfg_SetSendStatisticReport
PrlDispCfg_SetSendStatisticReport function
PrlDispCfg_SetUsbIdentAssociation
PrlDispCfg_SetUsbIdentAssociation function
PrlDispCfg_SetVerboseLogEnabled
PrlDispCfg_SetVerboseLogEnabled function
PrlDispCfg_SetVNCBasePort
PrlDispCfg_SetVNCBasePort function
PrlEvent_CanBeIgnored
PrlEvent_CanBeIgnored function
PrlEvent_CreateAnswerEvent
PrlEvent_CreateAnswerEvent function
PrlEvent_GetDataPtr
PrlEvent_GetDataPtr function
PrlEvent_GetErrCode
PrlEvent_GetErrCode function
PrlEvent_GetErrString
PrlEvent_GetErrString function
PrlEvent_GetIssuerId
PrlEvent_GetIssuerId function
PrlEvent_GetIssuerType
PrlEvent_GetIssuerType function
PrlEvent_GetJob
PrlEvent_GetJob function
PrlEvent_GetParam
PrlEvent_GetParam function
PrlEvent_GetParamByName
PrlEvent_GetParamByName function
PrlEvent_GetParamsCount
PrlEvent_GetParamsCount function
PrlEvent_GetServer
PrlEvent_GetServer function
PrlEvent_GetType
PrlEvent_GetType function
PrlEvent_GetVm
PrlEvent_GetVm function
PrlEvent_IsAnswerRequired
PrlEvent_IsAnswerRequired function
PrlEvtPrm_GetBuffer
PrlEvtPrm_GetBuffer function
PrlEvtPrm_GetName
PrlEvtPrm_GetName function
PrlEvtPrm_GetType
PrlEvtPrm_GetType function
PrlEvtPrm_ToBoolean
PrlEvtPrm_ToBoolean function
PrlEvtPrm_ToCData
PrlEvtPrm_ToCData function
PrlEvtPrm_ToHandle
PrlEvtPrm_ToHandle function
PrlEvtPrm_ToInt32
PrlEvtPrm_ToInt32 function
PrlEvtPrm_ToInt64
PrlEvtPrm_ToInt64 function
PrlEvtPrm_ToString
PrlEvtPrm_ToString function
PrlEvtPrm_ToUint32
PrlEvtPrm_ToUint32 function
PrlEvtPrm_ToUint64
PrlEvtPrm_ToUint64 function
PrlFirewallRule_Create
PrlFirewallRule_Create function
PrlFirewallRule_GetLocalNetAddress
PrlFirewallRule_GetLocalNetAddress function
PrlFirewallRule_GetLocalPort
PrlFirewallRule_GetLocalPort function
PrlFirewallRule_GetProtocol
PrlFirewallRule_GetProtocol function
PrlFirewallRule_GetRemoteNetAddress
PrlFirewallRule_GetRemoteNetAddress function
PrlFirewallRule_GetRemotePort
PrlFirewallRule_GetRemotePort function
PrlFirewallRule_SetLocalNetAddress
PrlFirewallRule_SetLocalNetAddress function
PrlFirewallRule_SetLocalPort
PrlFirewallRule_SetLocalPort function
PrlFirewallRule_SetProtocol
PrlFirewallRule_SetProtocol function
PrlFirewallRule_SetRemoteNetAddress
PrlFirewallRule_SetRemoteNetAddress function
PrlFirewallRule_SetRemotePort
PrlFirewallRule_SetRemotePort function
PrlFoundVmInfo_GetConfigPath
PrlFoundVmInfo_GetConfigPath function
PrlFoundVmInfo_GetName
PrlFoundVmInfo_GetName function
PrlFoundVmInfo_GetOSVersion
PrlFoundVmInfo_GetOSVersion function
PrlFoundVmInfo_IsOldConfig
PrlFoundVmInfo_IsOldConfig function
PrlFoundVmInfo_IsTemplate
PrlFoundVmInfo_IsTemplate function
PrlFsEntry_GetAbsolutePath
PrlFsEntry_GetAbsolutePath function
PrlFsEntry_GetLastModifiedDate
PrlFsEntry_GetLastModifiedDate function
PrlFsEntry_GetPermissions
PrlFsEntry_GetPermissions function
PrlFsEntry_GetRelativeName
PrlFsEntry_GetRelativeName function
PrlFsEntry_GetSize
PrlFsEntry_GetSize function
PrlFsEntry_GetType
PrlFsEntry_GetType function
PrlFsInfo_GetChildEntriesCount
PrlFsInfo_GetChildEntriesCount function
PrlFsInfo_GetChildEntry
PrlFsInfo_GetChildEntry function
PrlFsInfo_GetFsType
PrlFsInfo_GetFsType function
PrlFsInfo_GetParentEntry
PrlFsInfo_GetParentEntry function
PrlFsInfo_GetType
PrlFsInfo_GetType function
PrlHandle_AddRef
PrlHandle_AddRef function
PrlHandle_Free
PrlHandle_Free function
PrlHandle_GetChannelStatistics
PrlHandle_GetChannelStatistics function
PrlHandle_GetPackageId
PrlHandle_GetPackageId function
PrlHandle_GetType
PrlHandle_GetType function
PrlHandle_RegEventHandler
PrlHandle_RegEventHandler function
PrlHandle_UnregEventHandler
PrlHandle_UnregEventHandler function
PrlHndlList_AddItem
PrlHndlList_AddItem function
PrlHndlList_GetItem
PrlHndlList_GetItem function
PrlHndlList_GetItemsCount
PrlHndlList_GetItemsCount function
PrlHndlList_RemoveItem
PrlHndlList_RemoveItem function
PrlIPPrivNet_Create
PrlIPPrivNet_Create function
PrlIPPrivNet_GetName
PrlIPPrivNet_GetName function
PrlIPPrivNet_GetNetAddresses
PrlIPPrivNet_GetNetAddresses function
PrlIPPrivNet_IsGlobal
PrlIPPrivNet_IsGlobal function
PrlIPPrivNet_SetGlobal
PrlIPPrivNet_SetGlobal function
PrlIPPrivNet_SetName
PrlIPPrivNet_SetName function
PrlIPPrivNet_SetNetAddresses
PrlIPPrivNet_SetNetAddresses function
PrlJob_Cancel
PrlJob_Cancel function
PrlJob_GetDataPtr
PrlJob_GetDataPtr function
PrlJob_GetError
PrlJob_GetError function
PrlJob_GetOpCode
PrlJob_GetOpCode function
PrlJob_GetProgress
PrlJob_GetProgress function
PrlJob_GetResult
PrlJob_GetResult function
PrlJob_GetRetCode
PrlJob_GetRetCode function
PrlJob_GetStatus
PrlJob_GetStatus function
PrlJob_IsRequestWasSent
PrlJob_IsRequestWasSent function
PrlJob_Wait
PrlJob_Wait function
PrlLic_GetCompanyName
PrlLic_GetCompanyName function
PrlLic_GetLicenseKey
PrlLic_GetLicenseKey function
PrlLic_GetStatus
PrlLic_GetStatus function
PrlLic_GetUserName
PrlLic_GetUserName function
PrlLic_IsValid
PrlLic_IsValid function
PrlLoginResponse_GetHostOsVersion
PrlLoginResponse_GetHostOsVersion function
PrlLoginResponse_GetProductVersion
PrlLoginResponse_GetProductVersion function
PrlLoginResponse_GetRunningTaskByIndex
PrlLoginResponse_GetRunningTaskByIndex function
PrlLoginResponse_GetRunningTaskCount
PrlLoginResponse_GetRunningTaskCount function
PrlLoginResponse_GetServerUuid
PrlLoginResponse_GetServerUuid function
PrlLoginResponse_GetSessionUuid
PrlLoginResponse_GetSessionUuid function
PrlNetSvc_GetStatus
PrlNetSvc_GetStatus function
PrlNetworkClass_Create
PrlNetworkClass_Create function
PrlNetworkClass_GetClassId
PrlNetworkClass_GetClassId function
PrlNetworkClass_GetNetworkList
PrlNetworkClass_GetNetworkList function
PrlNetworkClass_SetClassId
PrlNetworkClass_SetClassId function
PrlNetworkClass_SetNetworkList
PrlNetworkClass_SetNetworkList function
PrlNetworkRate_Create
PrlNetworkRate_Create function
PrlNetworkRate_GetClassId
PrlNetworkRate_GetClassId function
PrlNetworkRate_GetRate
PrlNetworkRate_GetRate function
PrlNetworkShapingBandwidthEntry_Create
PrlNetworkShapingBandwidthEntry_Create function
PrlNetworkShapingBandwidthEntry_GetBandwidth
PrlNetworkShapingBandwidthEntry_GetBandwidth function
PrlNetworkShapingBandwidthEntry_GetDevice
PrlNetworkShapingBandwidthEntry_GetDevice function
PrlNetworkShapingBandwidthEntry_SetBandwidth
PrlNetworkShapingBandwidthEntry_SetBandwidth function
PrlNetworkShapingBandwidthEntry_SetDevice
PrlNetworkShapingBandwidthEntry_SetDevice function
PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList
PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList function
PrlNetworkShapingConfig_GetNetworkShapingList
PrlNetworkShapingConfig_GetNetworkShapingList function
PrlNetworkShapingConfig_IsEnabled
PrlNetworkShapingConfig_IsEnabled function
PrlNetworkShapingConfig_SetEnabled
PrlNetworkShapingConfig_SetEnabled function
PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList
PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList function
PrlNetworkShapingConfig_SetNetworkShapingList
PrlNetworkShapingConfig_SetNetworkShapingList function
PrlNetworkShapingEntry_Create
PrlNetworkShapingEntry_Create function
PrlNetworkShapingEntry_GetClassId
PrlNetworkShapingEntry_GetClassId function
PrlNetworkShapingEntry_GetDevice
PrlNetworkShapingEntry_GetDevice function
PrlNetworkShapingEntry_GetRate
PrlNetworkShapingEntry_GetRate function
PrlNetworkShapingEntry_GetTotalRate
PrlNetworkShapingEntry_GetTotalRate function
PrlNetworkShapingEntry_SetClassId
PrlNetworkShapingEntry_SetClassId function
PrlNetworkShapingEntry_SetDevice
PrlNetworkShapingEntry_SetDevice function
PrlNetworkShapingEntry_SetRate
PrlNetworkShapingEntry_SetRate function
PrlNetworkShapingEntry_SetTotalRate
PrlNetworkShapingEntry_SetTotalRate function
PrlOffmgmtService_Create
PrlOffmgmtService_Create function
PrlOffmgmtService_GetName
PrlOffmgmtService_GetName function
PrlOffmgmtService_GetPort
PrlOffmgmtService_GetPort function
PrlOffmgmtService_IsUsedByDefault
PrlOffmgmtService_IsUsedByDefault function
PrlOffmgmtService_SetName
PrlOffmgmtService_SetName function
PrlOffmgmtService_SetPort
PrlOffmgmtService_SetPort function
PrlOffmgmtService_SetUsedByDefault
PrlOffmgmtService_SetUsedByDefault function
PrlOpTypeList_AddItem
PrlOpTypeList_AddItem function
PrlOpTypeList_GetItem
PrlOpTypeList_GetItem function
PrlOpTypeList_GetItemsCount
PrlOpTypeList_GetItemsCount function
PrlOpTypeList_GetTypeSize
PrlOpTypeList_GetTypeSize function
PrlOpTypeList_RemoveItem
PrlOpTypeList_RemoveItem function
PrlOsesMatrix_GetDefaultOsVersion
PrlOsesMatrix_GetDefaultOsVersion function
PrlOsesMatrix_GetSupportedOsesTypes
PrlOsesMatrix_GetSupportedOsesTypes function
PrlOsesMatrix_GetSupportedOsesVersions
PrlOsesMatrix_GetSupportedOsesVersions function
PrlPluginInfo_GetCopyright
PrlPluginInfo_GetCopyright function
PrlPluginInfo_GetId
PrlPluginInfo_GetId function
PrlPluginInfo_GetLongDescription
PrlPluginInfo_GetLongDescription function
PrlPluginInfo_GetShortDescription
PrlPluginInfo_GetShortDescription function
PrlPluginInfo_GetVendor
PrlPluginInfo_GetVendor function
PrlPluginInfo_GetVersion
PrlPluginInfo_GetVersion function
PrlPortFwd_Create
PrlPortFwd_Create function
PrlPortFwd_GetIncomingPort
PrlPortFwd_GetIncomingPort function
PrlPortFwd_GetRedirectIPAddress
PrlPortFwd_GetRedirectIPAddress function
PrlPortFwd_GetRedirectPort
PrlPortFwd_GetRedirectPort function
PrlPortFwd_GetRedirectVm
PrlPortFwd_GetRedirectVm function
PrlPortFwd_GetRuleName
PrlPortFwd_GetRuleName function
PrlPortFwd_SetIncomingPort
PrlPortFwd_SetIncomingPort function
PrlPortFwd_SetRedirectIPAddress
PrlPortFwd_SetRedirectIPAddress function
PrlPortFwd_SetRedirectPort
PrlPortFwd_SetRedirectPort function
PrlPortFwd_SetRedirectVm
PrlPortFwd_SetRedirectVm function
PrlPortFwd_SetRuleName
PrlPortFwd_SetRuleName function
PrlReport_Assembly
PrlReport_Assembly function
PrlReport_AsString
PrlReport_AsString function
PrlReport_GetArchiveFileName
PrlReport_GetArchiveFileName function
PrlReport_GetCombinedReportId
PrlReport_GetCombinedReportId function
PrlReport_GetData
PrlReport_GetData function
PrlReport_GetDescription
PrlReport_GetDescription function
PrlReport_GetRating
PrlReport_GetRating function
PrlReport_GetReason
PrlReport_GetReason function
PrlReport_GetScheme
PrlReport_GetScheme function
PrlReport_GetType
PrlReport_GetType function
PrlReport_GetUserEmail
PrlReport_GetUserEmail function
PrlReport_GetUserName
PrlReport_GetUserName function
PrlReport_Send
PrlReport_Send function
PrlReport_SetCombinedReportId
PrlReport_SetCombinedReportId function
PrlReport_SetDescription
PrlReport_SetDescription function
PrlReport_SetRating
PrlReport_SetRating function
PrlReport_SetReason
PrlReport_SetReason function
PrlReport_SetType
PrlReport_SetType function
PrlReport_SetUserEmail
PrlReport_SetUserEmail function
PrlReport_SetUserName
PrlReport_SetUserName function
PrlResult_GetParam
PrlResult_GetParam function
PrlResult_GetParamAsString
PrlResult_GetParamAsString function
PrlResult_GetParamByIndex
PrlResult_GetParamByIndex function
PrlResult_GetParamByIndexAsString
PrlResult_GetParamByIndexAsString function
PrlResult_GetParamsCount
PrlResult_GetParamsCount function
PrlRunningTask_GetTaskParametersAsString
PrlRunningTask_GetTaskParametersAsString function
PrlRunningTask_GetTaskType
PrlRunningTask_GetTaskType function
PrlRunningTask_GetTaskUuid
PrlRunningTask_GetTaskUuid function
PrlScrRes_GetHeight
PrlScrRes_GetHeight function
PrlScrRes_GetWidth
PrlScrRes_GetWidth function
PrlScrRes_IsEnabled
PrlScrRes_IsEnabled function
PrlScrRes_Remove
PrlScrRes_Remove function
PrlScrRes_SetEnabled
PrlScrRes_SetEnabled function
PrlScrRes_SetHeight
PrlScrRes_SetHeight function
PrlScrRes_SetWidth
PrlScrRes_SetWidth function
PrlSessionInfo_Create
PrlSessionInfo_Create function
PrlShare_GetDescription
PrlShare_GetDescription function
PrlShare_GetName
PrlShare_GetName function
PrlShare_GetPath
PrlShare_GetPath function
PrlShare_IsEnabled
PrlShare_IsEnabled function
PrlShare_IsReadOnly
PrlShare_IsReadOnly function
PrlShare_Remove
PrlShare_Remove function
PrlShare_SetDescription
PrlShare_SetDescription function
PrlShare_SetEnabled
PrlShare_SetEnabled function
PrlShare_SetName
PrlShare_SetName function
PrlShare_SetPath
PrlShare_SetPath function
PrlShare_SetReadOnly
PrlShare_SetReadOnly function
PrlSrv_ActivateInstalledLicenseOffline
PrlSrv_ActivateInstalledLicenseOffline function
PrlSrv_ActivateInstalledLicenseOnline
PrlSrv_ActivateInstalledLicenseOnline function
PrlSrv_AddIPPrivateNetwork
PrlSrv_AddIPPrivateNetwork function
PrlSrv_AddVirtualNetwork
PrlSrv_AddVirtualNetwork function
PrlSrv_AttachToLostTask
PrlSrv_AttachToLostTask function
PrlSrv_CancelInstallAppliance
PrlSrv_CancelInstallAppliance function
PrlSrv_CheckParallelsServerAlive
PrlSrv_CheckParallelsServerAlive function
PrlSrv_CheckParallelsServerAliveEx
PrlSrv_CheckParallelsServerAliveEx function
PrlSrv_CommonPrefsBeginEdit
PrlSrv_CommonPrefsBeginEdit function
PrlSrv_CommonPrefsCommit
PrlSrv_CommonPrefsCommit function
PrlSrv_CommonPrefsCommitEx
PrlSrv_CommonPrefsCommitEx function
PrlSrv_ConfigureGenericPci
PrlSrv_ConfigureGenericPci function
PrlSrv_CopyCtTemplate
PrlSrv_CopyCtTemplate function
PrlSrv_Create
PrlSrv_Create function
PrlSrv_CreateDesktopControl
PrlSrv_CreateDesktopControl function
PrlSrv_CreateUnattendedCd
PrlSrv_CreateUnattendedCd function
PrlSrv_CreateVm
PrlSrv_CreateVm function
PrlSrv_CreateVmBackup
PrlSrv_CreateVmBackup function
PrlSrv_DeactivateInstalledLicense
PrlSrv_DeactivateInstalledLicense function
PrlSrv_DeleteOfflineService
PrlSrv_DeleteOfflineService function
PrlSrv_DeleteVirtualNetwork
PrlSrv_DeleteVirtualNetwork function
PrlSrv_DisableConfirmationMode
PrlSrv_DisableConfirmationMode function
PrlSrv_EnableConfirmationMode
PrlSrv_EnableConfirmationMode function
PrlSrv_FsCanCreateFile
PrlSrv_FsCanCreateFile function
PrlSrv_FsCreateDir
PrlSrv_FsCreateDir function
PrlSrv_FsGenerateEntryName
PrlSrv_FsGenerateEntryName function
PrlSrv_FsGetDirEntries
PrlSrv_FsGetDirEntries function
PrlSrv_FsGetDiskList
PrlSrv_FsGetDiskList function
PrlSrv_FsRemoveEntry
PrlSrv_FsRemoveEntry function
PrlSrv_FsRenameEntry
PrlSrv_FsRenameEntry function
PrlSrv_GetAllHostUsers
PrlSrv_GetAllHostUsers function
PrlSrv_GetBackupTree
PrlSrv_GetBackupTree function
PrlSrv_GetCommonPrefs
PrlSrv_GetCommonPrefs function
PrlSrv_GetCtTemplateList
PrlSrv_GetCtTemplateList function
PrlSrv_GetDefaultVmConfig
PrlSrv_GetDefaultVmConfig function
PrlSrv_GetDiskFreeSpace
PrlSrv_GetDiskFreeSpace function
PrlSrv_GetDisplayEncodingList
PrlSrv_GetDisplayEncodingList function
PrlSrv_GetIPPrivateNetworksList
PrlSrv_GetIPPrivateNetworksList function
PrlSrv_GetLicenseInfo
PrlSrv_GetLicenseInfo function
PrlSrv_GetNetServiceStatus
PrlSrv_GetNetServiceStatus function
PrlSrv_GetNetworkClassesList
PrlSrv_GetNetworkClassesList function
PrlSrv_GetNetworkShapingConfig
PrlSrv_GetNetworkShapingConfig function
PrlSrv_GetOfflineServicesList
PrlSrv_GetOfflineServicesList function
PrlSrv_GetPackedProblemReport
PrlSrv_GetPackedProblemReport function
PrlSrv_GetPerfStats
PrlSrv_GetPerfStats function
PrlSrv_GetPluginsList
PrlSrv_GetPluginsList function
PrlSrv_GetProblemReport
PrlSrv_GetProblemReport function
PrlSrv_GetQuestions
PrlSrv_GetQuestions function
PrlSrv_GetRegisteredHostsOnProxy
PrlSrv_GetRegisteredHostsOnProxy function
PrlSrv_GetRestrictionInfo
PrlSrv_GetRestrictionInfo function
PrlSrv_GetServerInfo
PrlSrv_GetServerInfo function
PrlSrv_GetSrvConfig
PrlSrv_GetSrvConfig function
PrlSrv_GetStatistics
PrlSrv_GetStatistics function
PrlSrv_GetSupportedOses
PrlSrv_GetSupportedOses function
PrlSrv_GetUserInfo
PrlSrv_GetUserInfo function
PrlSrv_GetUserInfoList
PrlSrv_GetUserInfoList function
PrlSrv_GetUserProfile
PrlSrv_GetUserProfile function
PrlSrv_GetVirtualNetworkList
PrlSrv_GetVirtualNetworkList function
PrlSrv_GetVmConfig
PrlSrv_GetVmConfig function
PrlSrv_GetVmList
PrlSrv_GetVmList function
PrlSrv_GetVmListEx
PrlSrv_GetVmListEx function
PrlSrv_HasRestriction
PrlSrv_HasRestriction function
PrlSrv_InstallAppliance
PrlSrv_InstallAppliance function
PrlSrv_IsConfirmationModeEnabled
PrlSrv_IsConfirmationModeEnabled function
PrlSrv_IsConnected
PrlSrv_IsConnected function
PrlSrv_IsFeatureSupported
PrlSrv_IsFeatureSupported function
PrlSrv_IsNonInteractiveSession
PrlSrv_IsNonInteractiveSession function
PrlSrv_IsProxyConnection
PrlSrv_IsProxyConnection function
PrlSrv_Login
PrlSrv_Login function
PrlSrv_LoginEx
PrlSrv_LoginEx function
PrlSrv_LoginLocal
PrlSrv_LoginLocal function
PrlSrv_LoginLocalEx
PrlSrv_LoginLocalEx function
PrlSrv_Logoff
PrlSrv_Logoff function
PrlSrv_LookupParallelsServers
PrlSrv_LookupParallelsServers function
PrlSrv_NetServiceRestart
PrlSrv_NetServiceRestart function
PrlSrv_NetServiceRestoreDefaults
PrlSrv_NetServiceRestoreDefaults function
PrlSrv_NetServiceStart
PrlSrv_NetServiceStart function
PrlSrv_NetServiceStop
PrlSrv_NetServiceStop function
PrlSrv_ProxyLogin
PrlSrv_ProxyLogin function
PrlSrv_ProxyLoginEx
PrlSrv_ProxyLoginEx function
PrlSrv_RefreshPlugins
PrlSrv_RefreshPlugins function
PrlSrv_RegEventHandler
PrlSrv_RegEventHandler function
PrlSrv_Register3rdPartyVm
PrlSrv_Register3rdPartyVm function
PrlSrv_RegisterVm
PrlSrv_RegisterVm function
PrlSrv_RegisterVmEx
PrlSrv_RegisterVmEx function
PrlSrv_RegisterVmWithUuid
PrlSrv_RegisterVmWithUuid function
PrlSrv_RemoveCtTemplate
PrlSrv_RemoveCtTemplate function
PrlSrv_RemoveIPPrivateNetwork
PrlSrv_RemoveIPPrivateNetwork function
PrlSrv_RemoveVmBackup
PrlSrv_RemoveVmBackup function
PrlSrv_RestoreVmBackup
PrlSrv_RestoreVmBackup function
PrlSrv_SecureLogin
PrlSrv_SecureLogin function
PrlSrv_SecureProxyLogin
PrlSrv_SecureProxyLogin function
PrlSrv_SendAnswer
PrlSrv_SendAnswer function
PrlSrv_SendProblemReport
PrlSrv_SendProblemReport function
PrlSrv_SetCertificateRevocationDateTime
PrlSrv_SetCertificateRevocationDateTime function
PrlSrv_SetGlobalDateTime
PrlSrv_SetGlobalDateTime function
PrlSrv_SetNonInteractiveSession
PrlSrv_SetNonInteractiveSession function
PrlSrv_SetVNCEncryption
PrlSrv_SetVNCEncryption function
PrlSrv_Shutdown
PrlSrv_Shutdown function
PrlSrv_ShutdownEx
PrlSrv_ShutdownEx function
PrlSrv_StartSearchVms
PrlSrv_StartSearchVms function
PrlSrv_StopInstallAppliance
PrlSrv_StopInstallAppliance function
PrlSrv_SubscribeToHostStatistics
PrlSrv_SubscribeToHostStatistics function
PrlSrv_SubscribeToPerfStats
PrlSrv_SubscribeToPerfStats function
PrlSrv_UnregEventHandler
PrlSrv_UnregEventHandler function
PrlSrv_UnsubscribeFromHostStatistics
PrlSrv_UnsubscribeFromHostStatistics function
PrlSrv_UnsubscribeFromPerfStats
PrlSrv_UnsubscribeFromPerfStats function
PrlSrv_UpdateIPPrivateNetwork
PrlSrv_UpdateIPPrivateNetwork function
PrlSrv_UpdateLicense
PrlSrv_UpdateLicense function
PrlSrv_UpdateLicenseEx
PrlSrv_UpdateLicenseEx function
PrlSrv_UpdateNetworkClassesList
PrlSrv_UpdateNetworkClassesList function
PrlSrv_UpdateNetworkShapingConfig
PrlSrv_UpdateNetworkShapingConfig function
PrlSrv_UpdateOfflineService
PrlSrv_UpdateOfflineService function
PrlSrv_UpdateSessionInfo
PrlSrv_UpdateSessionInfo function
PrlSrv_UpdateVirtualNetwork
PrlSrv_UpdateVirtualNetwork function
PrlSrv_UserProfileBeginEdit
PrlSrv_UserProfileBeginEdit function
PrlSrv_UserProfileCommit
PrlSrv_UserProfileCommit function
PrlSrvCfg_Create
PrlSrvCfg_Create function
PrlSrvCfg_GetCpuCount
PrlSrvCfg_GetCpuCount function
PrlSrvCfg_GetCpuFeatures
PrlSrvCfg_GetCpuFeatures function
PrlSrvCfg_GetCpuFeaturesEx
PrlSrvCfg_GetCpuFeaturesEx function
PrlSrvCfg_GetCpuFeaturesMaskingCapabilities
PrlSrvCfg_GetCpuFeaturesMaskingCapabilities function
PrlSrvCfg_GetCpuHvt
PrlSrvCfg_GetCpuHvt function
PrlSrvCfg_GetCpuMode
PrlSrvCfg_GetCpuMode function
PrlSrvCfg_GetCpuModel
PrlSrvCfg_GetCpuModel function
PrlSrvCfg_GetCpuSpeed
PrlSrvCfg_GetCpuSpeed function
PrlSrvCfg_GetDefaultGateway
PrlSrvCfg_GetDefaultGateway function
PrlSrvCfg_GetDefaultGatewayIPv6
PrlSrvCfg_GetDefaultGatewayIPv6 function
PrlSrvCfg_GetDnsServers
PrlSrvCfg_GetDnsServers function
PrlSrvCfg_GetFloppyDisk
PrlSrvCfg_GetFloppyDisk function
PrlSrvCfg_GetFloppyDisksCount
PrlSrvCfg_GetFloppyDisksCount function
PrlSrvCfg_GetGenericPciDevice
PrlSrvCfg_GetGenericPciDevice function
PrlSrvCfg_GetGenericPciDevicesCount
PrlSrvCfg_GetGenericPciDevicesCount function
PrlSrvCfg_GetGenericScsiDevice
PrlSrvCfg_GetGenericScsiDevice function
PrlSrvCfg_GetGenericScsiDevicesCount
PrlSrvCfg_GetGenericScsiDevicesCount function
PrlSrvCfg_GetHardDisk
PrlSrvCfg_GetHardDisk function
PrlSrvCfg_GetHardDisksCount
PrlSrvCfg_GetHardDisksCount function
PrlSrvCfg_GetHostname
PrlSrvCfg_GetHostname function
PrlSrvCfg_GetHostOsMajor
PrlSrvCfg_GetHostOsMajor function
PrlSrvCfg_GetHostOsMinor
PrlSrvCfg_GetHostOsMinor function
PrlSrvCfg_GetHostOsStrPresentation
PrlSrvCfg_GetHostOsStrPresentation function
PrlSrvCfg_GetHostOsSubMinor
PrlSrvCfg_GetHostOsSubMinor function
PrlSrvCfg_GetHostOsType
PrlSrvCfg_GetHostOsType function
PrlSrvCfg_GetHostRamSize
PrlSrvCfg_GetHostRamSize function
PrlSrvCfg_GetMaxHostNetAdapters
PrlSrvCfg_GetMaxHostNetAdapters function
PrlSrvCfg_GetMaxVmNetAdapters
PrlSrvCfg_GetMaxVmNetAdapters function
PrlSrvCfg_GetNetAdapter
PrlSrvCfg_GetNetAdapter function
PrlSrvCfg_GetNetAdaptersCount
PrlSrvCfg_GetNetAdaptersCount function
PrlSrvCfg_GetOpticalDisk
PrlSrvCfg_GetOpticalDisk function
PrlSrvCfg_GetOpticalDisksCount
PrlSrvCfg_GetOpticalDisksCount function
PrlSrvCfg_GetParallelPort
PrlSrvCfg_GetParallelPort function
PrlSrvCfg_GetParallelPortsCount
PrlSrvCfg_GetParallelPortsCount function
PrlSrvCfg_GetPrinter
PrlSrvCfg_GetPrinter function
PrlSrvCfg_GetPrintersCount
PrlSrvCfg_GetPrintersCount function
PrlSrvCfg_GetSearchDomains
PrlSrvCfg_GetSearchDomains function
PrlSrvCfg_GetSerialPort
PrlSrvCfg_GetSerialPort function
PrlSrvCfg_GetSerialPortsCount
PrlSrvCfg_GetSerialPortsCount function
PrlSrvCfg_GetSoundMixerDev
PrlSrvCfg_GetSoundMixerDev function
PrlSrvCfg_GetSoundMixerDevsCount
PrlSrvCfg_GetSoundMixerDevsCount function
PrlSrvCfg_GetSoundOutputDev
PrlSrvCfg_GetSoundOutputDev function
PrlSrvCfg_GetSoundOutputDevsCount
PrlSrvCfg_GetSoundOutputDevsCount function
PrlSrvCfg_GetUsbDev
PrlSrvCfg_GetUsbDev function
PrlSrvCfg_GetUsbDevsCount
PrlSrvCfg_GetUsbDevsCount function
PrlSrvCfg_IsSoundDefaultEnabled
PrlSrvCfg_IsSoundDefaultEnabled function
PrlSrvCfg_IsUsbSupported
PrlSrvCfg_IsUsbSupported function
PrlSrvCfg_IsVtdSupported
PrlSrvCfg_IsVtdSupported function
PrlSrvCfgDev_GetDeviceState
PrlSrvCfgDev_GetDeviceState function
PrlSrvCfgDev_GetId
PrlSrvCfgDev_GetId function
PrlSrvCfgDev_GetName
PrlSrvCfgDev_GetName function
PrlSrvCfgDev_GetType
PrlSrvCfgDev_GetType function
PrlSrvCfgDev_IsConnectedToVm
PrlSrvCfgDev_IsConnectedToVm function
PrlSrvCfgDev_SetDeviceState
PrlSrvCfgDev_SetDeviceState function
PrlSrvCfgHdd_GetDevId
PrlSrvCfgHdd_GetDevId function
PrlSrvCfgHdd_GetDevName
PrlSrvCfgHdd_GetDevName function
PrlSrvCfgHdd_GetDevSize
PrlSrvCfgHdd_GetDevSize function
PrlSrvCfgHdd_GetDiskIndex
PrlSrvCfgHdd_GetDiskIndex function
PrlSrvCfgHdd_GetPart
PrlSrvCfgHdd_GetPart function
PrlSrvCfgHdd_GetPartsCount
PrlSrvCfgHdd_GetPartsCount function
PrlSrvCfgHddPart_GetIndex
PrlSrvCfgHddPart_GetIndex function
PrlSrvCfgHddPart_GetName
PrlSrvCfgHddPart_GetName function
PrlSrvCfgHddPart_GetSize
PrlSrvCfgHddPart_GetSize function
PrlSrvCfgHddPart_GetSysName
PrlSrvCfgHddPart_GetSysName function
PrlSrvCfgHddPart_GetType
PrlSrvCfgHddPart_GetType function
PrlSrvCfgHddPart_IsActive
PrlSrvCfgHddPart_IsActive function
PrlSrvCfgHddPart_IsInUse
PrlSrvCfgHddPart_IsInUse function
PrlSrvCfgHddPart_IsLogical
PrlSrvCfgHddPart_IsLogical function
PrlSrvCfgNet_GetDefaultGateway
PrlSrvCfgNet_GetDefaultGateway function
PrlSrvCfgNet_GetDefaultGatewayIPv6
PrlSrvCfgNet_GetDefaultGatewayIPv6 function
PrlSrvCfgNet_GetDnsServers
PrlSrvCfgNet_GetDnsServers function
PrlSrvCfgNet_GetMacAddress
PrlSrvCfgNet_GetMacAddress function
PrlSrvCfgNet_GetNetAdapterType
PrlSrvCfgNet_GetNetAdapterType function
PrlSrvCfgNet_GetNetAddresses
PrlSrvCfgNet_GetNetAddresses function
PrlSrvCfgNet_GetSearchDomains
PrlSrvCfgNet_GetSearchDomains function
PrlSrvCfgNet_GetSysIndex
PrlSrvCfgNet_GetSysIndex function
PrlSrvCfgNet_GetVlanTag
PrlSrvCfgNet_GetVlanTag function
PrlSrvCfgNet_IsConfigureWithDhcp
PrlSrvCfgNet_IsConfigureWithDhcp function
PrlSrvCfgNet_IsConfigureWithDhcpIPv6
PrlSrvCfgNet_IsConfigureWithDhcpIPv6 function
PrlSrvCfgNet_IsEnabled
PrlSrvCfgNet_IsEnabled function
PrlSrvCfgPci_GetDeviceClass
PrlSrvCfgPci_GetDeviceClass function
PrlSrvCfgPci_IsPrimaryDevice
PrlSrvCfgPci_IsPrimaryDevice function
PrlSrvInfo_GetApplicationMode
PrlSrvInfo_GetApplicationMode function
PrlSrvInfo_GetCmdPort
PrlSrvInfo_GetCmdPort function
PrlSrvInfo_GetHostName
PrlSrvInfo_GetHostName function
PrlSrvInfo_GetOsVersion
PrlSrvInfo_GetOsVersion function
PrlSrvInfo_GetProductVersion
PrlSrvInfo_GetProductVersion function
PrlSrvInfo_GetServerUuid
PrlSrvInfo_GetServerUuid function
PrlSrvInfo_GetStartTime
PrlSrvInfo_GetStartTime function
PrlSrvInfo_GetStartTimeMonotonic
PrlSrvInfo_GetStartTimeMonotonic function
PrlStat_GetCpusStatsCount
PrlStat_GetCpusStatsCount function
PrlStat_GetCpuStat
PrlStat_GetCpuStat function
PrlStat_GetDisksStatsCount
PrlStat_GetDisksStatsCount function
PrlStat_GetDiskStat
PrlStat_GetDiskStat function
PrlStat_GetDispUptime
PrlStat_GetDispUptime function
PrlStat_GetFreeRamSize
PrlStat_GetFreeRamSize function
PrlStat_GetFreeSwapSize
PrlStat_GetFreeSwapSize function
PrlStat_GetIfacesStatsCount
PrlStat_GetIfacesStatsCount function
PrlStat_GetIfaceStat
PrlStat_GetIfaceStat function
PrlStat_GetOsUptime
PrlStat_GetOsUptime function
PrlStat_GetProcsStatsCount
PrlStat_GetProcsStatsCount function
PrlStat_GetProcStat
PrlStat_GetProcStat function
PrlStat_GetRealRamSize
PrlStat_GetRealRamSize function
PrlStat_GetTotalRamSize
PrlStat_GetTotalRamSize function
PrlStat_GetTotalSwapSize
PrlStat_GetTotalSwapSize function
PrlStat_GetUsageRamSize
PrlStat_GetUsageRamSize function
PrlStat_GetUsageSwapSize
PrlStat_GetUsageSwapSize function
PrlStat_GetUsersStatsCount
PrlStat_GetUsersStatsCount function
PrlStat_GetUserStat
PrlStat_GetUserStat function
PrlStat_GetVmDataStat
PrlStat_GetVmDataStat function
PrlStatCpu_GetCpuUsage
PrlStatCpu_GetCpuUsage function
PrlStatCpu_GetSystemTime
PrlStatCpu_GetSystemTime function
PrlStatCpu_GetTotalTime
PrlStatCpu_GetTotalTime function
PrlStatCpu_GetUserTime
PrlStatCpu_GetUserTime function
PrlStatDisk_GetFreeDiskSpace
PrlStatDisk_GetFreeDiskSpace function
PrlStatDisk_GetPartsStatsCount
PrlStatDisk_GetPartsStatsCount function
PrlStatDisk_GetPartStat
PrlStatDisk_GetPartStat function
PrlStatDisk_GetSystemName
PrlStatDisk_GetSystemName function
PrlStatDisk_GetUsageDiskSpace
PrlStatDisk_GetUsageDiskSpace function
PrlStatDiskPart_GetFreeDiskSpace
PrlStatDiskPart_GetFreeDiskSpace function
PrlStatDiskPart_GetSystemName
PrlStatDiskPart_GetSystemName function
PrlStatDiskPart_GetUsageDiskSpace
PrlStatDiskPart_GetUsageDiskSpace function
PrlStatIface_GetInDataSize
PrlStatIface_GetInDataSize function
PrlStatIface_GetInPkgsCount
PrlStatIface_GetInPkgsCount function
PrlStatIface_GetOutDataSize
PrlStatIface_GetOutDataSize function
PrlStatIface_GetOutPkgsCount
PrlStatIface_GetOutPkgsCount function
PrlStatIface_GetSystemName
PrlStatIface_GetSystemName function
PrlStatProc_GetCommandName
PrlStatProc_GetCommandName function
PrlStatProc_GetCpuUsage
PrlStatProc_GetCpuUsage function
PrlStatProc_GetId
PrlStatProc_GetId function
PrlStatProc_GetOwnerUserName
PrlStatProc_GetOwnerUserName function
PrlStatProc_GetRealMemUsage
PrlStatProc_GetRealMemUsage function
PrlStatProc_GetStartTime
PrlStatProc_GetStartTime function
PrlStatProc_GetState
PrlStatProc_GetState function
PrlStatProc_GetSystemTime
PrlStatProc_GetSystemTime function
PrlStatProc_GetTotalMemUsage
PrlStatProc_GetTotalMemUsage function
PrlStatProc_GetTotalTime
PrlStatProc_GetTotalTime function
PrlStatProc_GetUserTime
PrlStatProc_GetUserTime function
PrlStatProc_GetVirtMemUsage
PrlStatProc_GetVirtMemUsage function
PrlStatUser_GetHostName
PrlStatUser_GetHostName function
PrlStatUser_GetServiceName
PrlStatUser_GetServiceName function
PrlStatUser_GetSessionTime
PrlStatUser_GetSessionTime function
PrlStatUser_GetUserName
PrlStatUser_GetUserName function
PrlStatVmData_GetSegmentCapacity
PrlStatVmData_GetSegmentCapacity function
PrlStrList_AddItem
PrlStrList_AddItem function
PrlStrList_GetItem
PrlStrList_GetItem function
PrlStrList_GetItemsCount
PrlStrList_GetItemsCount function
PrlStrList_RemoveItem
PrlStrList_RemoveItem function
PrlUIEmuInput_AddText
PrlUIEmuInput_AddText function
PrlUIEmuInput_AddVKeys
PrlUIEmuInput_AddVKeys function
PrlUIEmuInput_Create
PrlUIEmuInput_Create function
PrlUsbIdent_GetFriendlyName
PrlUsbIdent_GetFriendlyName function
PrlUsbIdent_GetSystemName
PrlUsbIdent_GetSystemName function
PrlUsbIdent_GetVmUuidAssociation
PrlUsbIdent_GetVmUuidAssociation function
PrlUsrCfg_CanChangeSrvSets
PrlUsrCfg_CanChangeSrvSets function
PrlUsrCfg_CanUseMngConsole
PrlUsrCfg_CanUseMngConsole function
PrlUsrCfg_GetDefaultVmFolder
PrlUsrCfg_GetDefaultVmFolder function
PrlUsrCfg_GetVmDirUuid
PrlUsrCfg_GetVmDirUuid function
PrlUsrCfg_IsLocalAdministrator
PrlUsrCfg_IsLocalAdministrator function
PrlUsrCfg_SetDefaultVmFolder
PrlUsrCfg_SetDefaultVmFolder function
PrlUsrCfg_SetVmDirUuid
PrlUsrCfg_SetVmDirUuid function
PrlUsrInfo_CanChangeSrvSets
PrlUsrInfo_CanChangeSrvSets function
PrlUsrInfo_GetDefaultVmFolder
PrlUsrInfo_GetDefaultVmFolder function
PrlUsrInfo_GetName
PrlUsrInfo_GetName function
PrlUsrInfo_GetSessionCount
PrlUsrInfo_GetSessionCount function
PrlUsrInfo_GetUuid
PrlUsrInfo_GetUuid function
PrlVirtNet_Create
PrlVirtNet_Create function
PrlVirtNet_GetAdapterIndex
PrlVirtNet_GetAdapterIndex function
PrlVirtNet_GetAdapterName
PrlVirtNet_GetAdapterName function
PrlVirtNet_GetBoundAdapterInfo
PrlVirtNet_GetBoundAdapterInfo function
PrlVirtNet_GetBoundCardMac
PrlVirtNet_GetBoundCardMac function
PrlVirtNet_GetDescription
PrlVirtNet_GetDescription function
PrlVirtNet_GetDhcpIP6Address
PrlVirtNet_GetDhcpIP6Address function
PrlVirtNet_GetDhcpIPAddress
PrlVirtNet_GetDhcpIPAddress function
PrlVirtNet_GetHostIP6Address
PrlVirtNet_GetHostIP6Address function
PrlVirtNet_GetHostIPAddress
PrlVirtNet_GetHostIPAddress function
PrlVirtNet_GetIP6NetMask
PrlVirtNet_GetIP6NetMask function
PrlVirtNet_GetIP6ScopeEnd
PrlVirtNet_GetIP6ScopeEnd function
PrlVirtNet_GetIP6ScopeStart
PrlVirtNet_GetIP6ScopeStart function
PrlVirtNet_GetIPNetMask
PrlVirtNet_GetIPNetMask function
PrlVirtNet_GetIPScopeEnd
PrlVirtNet_GetIPScopeEnd function
PrlVirtNet_GetIPScopeStart
PrlVirtNet_GetIPScopeStart function
PrlVirtNet_GetNetworkId
PrlVirtNet_GetNetworkId function
PrlVirtNet_GetNetworkType
PrlVirtNet_GetNetworkType function
PrlVirtNet_GetPortForwardList
PrlVirtNet_GetPortForwardList function
PrlVirtNet_GetVlanTag
PrlVirtNet_GetVlanTag function
PrlVirtNet_IsAdapterEnabled
PrlVirtNet_IsAdapterEnabled function
PrlVirtNet_IsDHCP6ServerEnabled
PrlVirtNet_IsDHCP6ServerEnabled function
PrlVirtNet_IsDHCPServerEnabled
PrlVirtNet_IsDHCPServerEnabled function
PrlVirtNet_IsEnabled
PrlVirtNet_IsEnabled function
PrlVirtNet_IsNATServerEnabled
PrlVirtNet_IsNATServerEnabled function
PrlVirtNet_SetAdapterEnabled
PrlVirtNet_SetAdapterEnabled function
PrlVirtNet_SetAdapterIndex
PrlVirtNet_SetAdapterIndex function
PrlVirtNet_SetAdapterName
PrlVirtNet_SetAdapterName function
PrlVirtNet_SetBoundCardMac
PrlVirtNet_SetBoundCardMac function
PrlVirtNet_SetDescription
PrlVirtNet_SetDescription function
PrlVirtNet_SetDHCP6ServerEnabled
PrlVirtNet_SetDHCP6ServerEnabled function
PrlVirtNet_SetDhcpIP6Address
PrlVirtNet_SetDhcpIP6Address function
PrlVirtNet_SetDhcpIPAddress
PrlVirtNet_SetDhcpIPAddress function
PrlVirtNet_SetDHCPServerEnabled
PrlVirtNet_SetDHCPServerEnabled function
PrlVirtNet_SetEnabled
PrlVirtNet_SetEnabled function
PrlVirtNet_SetHostIP6Address
PrlVirtNet_SetHostIP6Address function
PrlVirtNet_SetHostIPAddress
PrlVirtNet_SetHostIPAddress function
PrlVirtNet_SetIP6NetMask
PrlVirtNet_SetIP6NetMask function
PrlVirtNet_SetIP6ScopeEnd
PrlVirtNet_SetIP6ScopeEnd function
PrlVirtNet_SetIP6ScopeStart
PrlVirtNet_SetIP6ScopeStart function
PrlVirtNet_SetIPNetMask
PrlVirtNet_SetIPNetMask function
PrlVirtNet_SetIPScopeEnd
PrlVirtNet_SetIPScopeEnd function
PrlVirtNet_SetIPScopeStart
PrlVirtNet_SetIPScopeStart function
PrlVirtNet_SetNATServerEnabled
PrlVirtNet_SetNATServerEnabled function
PrlVirtNet_SetNetworkId
PrlVirtNet_SetNetworkId function
PrlVirtNet_SetNetworkType
PrlVirtNet_SetNetworkType function
PrlVirtNet_SetPortForwardList
PrlVirtNet_SetPortForwardList function
PrlVirtNet_SetVlanTag
PrlVirtNet_SetVlanTag function
PrlVm_Authorise
PrlVm_Authorise function
PrlVm_AuthWithGuestSecurityDb
PrlVm_AuthWithGuestSecurityDb function
PrlVm_BeginEdit
PrlVm_BeginEdit function
PrlVm_CancelCompact
PrlVm_CancelCompact function
PrlVm_CancelConvertDisks
PrlVm_CancelConvertDisks function
PrlVm_ChangePassword
PrlVm_ChangePassword function
PrlVm_ChangeSid
PrlVm_ChangeSid function
PrlVm_Clone
PrlVm_Clone function
PrlVm_CloneEx
PrlVm_CloneEx function
PrlVm_Commit
PrlVm_Commit function
PrlVm_CommitEx
PrlVm_CommitEx function
PrlVm_Compact
PrlVm_Compact function
PrlVm_Connect
PrlVm_Connect function
PrlVm_ConvertDisks
PrlVm_ConvertDisks function
PrlVm_CreateCVSrc
PrlVm_CreateCVSrc function
PrlVm_CreateEvent
PrlVm_CreateEvent function
PrlVm_CreateP2PTransport
PrlVm_CreateP2PTransport function
PrlVm_CreateSnapshot
PrlVm_CreateSnapshot function
PrlVm_CreateUnattendedDisk
PrlVm_CreateUnattendedDisk function
PrlVm_CreateUnattendedFloppy
PrlVm_CreateUnattendedFloppy function
PrlVm_Decrypt
PrlVm_Decrypt function
PrlVm_Delete
PrlVm_Delete function
PrlVm_DeleteSnapshot
PrlVm_DeleteSnapshot function
PrlVm_Disconnect
PrlVm_Disconnect function
PrlVm_DropSuspendedState
PrlVm_DropSuspendedState function
PrlVm_Encrypt
PrlVm_Encrypt function
PrlVm_GenerateVmDevFilename
PrlVm_GenerateVmDevFilename function
PrlVm_GetConfig
PrlVm_GetConfig function
PrlVm_GetPackedProblemReport
PrlVm_GetPackedProblemReport function
PrlVm_GetPerfStats
PrlVm_GetPerfStats function
PrlVm_GetProblemReport
PrlVm_GetProblemReport function
PrlVm_GetQuestions
PrlVm_GetQuestions function
PrlVm_GetSnapshotsTree
PrlVm_GetSnapshotsTree function
PrlVm_GetSnapshotsTreeEx
PrlVm_GetSnapshotsTreeEx function
PrlVm_GetState
PrlVm_GetState function
PrlVm_GetStatistics
PrlVm_GetStatistics function
PrlVm_GetStatisticsEx
PrlVm_GetStatisticsEx function
PrlVm_GetSuspendedScreen
PrlVm_GetSuspendedScreen function
PrlVm_GetToolsState
PrlVm_GetToolsState function
PrlVm_InitiateDevStateNotifications
PrlVm_InitiateDevStateNotifications function
PrlVm_InstallTools
PrlVm_InstallTools function
PrlVm_InstallUtility
PrlVm_InstallUtility function
PrlVm_LinkedClone
PrlVm_LinkedClone function
PrlVm_Lock
PrlVm_Lock function
PrlVm_LoginInGuest
PrlVm_LoginInGuest function
PrlVm_Migrate
PrlVm_Migrate function
PrlVm_MigrateCancel
PrlVm_MigrateCancel function
PrlVm_MigrateEx
PrlVm_MigrateEx function
PrlVm_MigrateWithRename
PrlVm_MigrateWithRename function
PrlVm_MigrateWithRenameEx
PrlVm_MigrateWithRenameEx function
PrlVm_Mount
PrlVm_Mount function
PrlVm_Move
PrlVm_Move function
PrlVm_Pause
PrlVm_Pause function
PrlVm_PtmExec
PrlVm_PtmExec function
PrlVm_PtmQuery
PrlVm_PtmQuery function
PrlVm_PtmSet
PrlVm_PtmSet function
PrlVm_PtmSubscribe
PrlVm_PtmSubscribe function
PrlVm_RefreshConfig
PrlVm_RefreshConfig function
PrlVm_Reg
PrlVm_Reg function
PrlVm_RegEventHandler
PrlVm_RegEventHandler function
PrlVm_RegEx
PrlVm_RegEx function
PrlVm_RemoveProtection
PrlVm_RemoveProtection function
PrlVm_Reset
PrlVm_Reset function
PrlVm_ResetUptime
PrlVm_ResetUptime function
PrlVm_Restart
PrlVm_Restart function
PrlVm_Restore
PrlVm_Restore function
PrlVm_Resume
PrlVm_Resume function
PrlVm_SendClipboardRequest
PrlVm_SendClipboardRequest function
PrlVm_SetConfig
PrlVm_SetConfig function
PrlVm_SetProtection
PrlVm_SetProtection function
PrlVm_Start
PrlVm_Start function
PrlVm_StartEx
PrlVm_StartEx function
PrlVm_StartVncServer
PrlVm_StartVncServer function
PrlVm_Stop
PrlVm_Stop function
PrlVm_StopEx
PrlVm_StopEx function
PrlVm_StopVncServer
PrlVm_StopVncServer function
PrlVm_SubscribeToGuestStatistics
PrlVm_SubscribeToGuestStatistics function
PrlVm_SubscribeToPerfStats
PrlVm_SubscribeToPerfStats function
PrlVm_Suspend
PrlVm_Suspend function
PrlVm_SwitchToSnapshot
PrlVm_SwitchToSnapshot function
PrlVm_SwitchToSnapshotEx
PrlVm_SwitchToSnapshotEx function
PrlVm_TisGetIdentifiers
PrlVm_TisGetIdentifiers function
PrlVm_TisGetRecord
PrlVm_TisGetRecord function
PrlVm_TisSubscribe
PrlVm_TisSubscribe function
PrlVm_TisUnsubscribe
PrlVm_TisUnsubscribe function
PrlVm_ToolsGetShutdownCapabilities
PrlVm_ToolsGetShutdownCapabilities function
PrlVm_ToolsSendShutdown
PrlVm_ToolsSendShutdown function
PrlVm_ToolsSetTaskBarVisibility
PrlVm_ToolsSetTaskBarVisibility function
PrlVm_UIEmuQueryCaretInfo
PrlVm_UIEmuQueryCaretInfo function
PrlVm_UIEmuQueryElementAtPos
PrlVm_UIEmuQueryElementAtPos function
PrlVm_UIEmuQueryNearestElementAtPos
PrlVm_UIEmuQueryNearestElementAtPos function
PrlVm_UIEmuSendClick
PrlVm_UIEmuSendClick function
PrlVm_UIEmuSendGestureEvent
PrlVm_UIEmuSendGestureEvent function
PrlVm_UIEmuSendInput
PrlVm_UIEmuSendInput function
PrlVm_UIEmuSendMultimediaKey
PrlVm_UIEmuSendMultimediaKey function
PrlVm_UIEmuSendScroll
PrlVm_UIEmuSendScroll function
PrlVm_UIEmuSendText
PrlVm_UIEmuSendText function
PrlVm_Umount
PrlVm_Umount function
PrlVm_Unlock
PrlVm_Unlock function
PrlVm_Unreg
PrlVm_Unreg function
PrlVm_UnregEventHandler
PrlVm_UnregEventHandler function
PrlVm_UnsubscribeFromGuestStatistics
PrlVm_UnsubscribeFromGuestStatistics function
PrlVm_UnsubscribeFromPerfStats
PrlVm_UnsubscribeFromPerfStats function
PrlVm_UpdateSecurity
PrlVm_UpdateSecurity function
PrlVm_UpdateSnapshotData
PrlVm_UpdateSnapshotData function
PrlVm_ValidateConfig
PrlVm_ValidateConfig function
PrlVmCfg_AddDefaultDevice
PrlVmCfg_AddDefaultDevice function
PrlVmCfg_AddDefaultDeviceEx
PrlVmCfg_AddDefaultDeviceEx function
PrlVmCfg_ApplyConfigSample
PrlVmCfg_ApplyConfigSample function
PrlVmCfg_CreateBootDev
PrlVmCfg_CreateBootDev function
PrlVmCfg_CreateScrRes
PrlVmCfg_CreateScrRes function
PrlVmCfg_CreateShare
PrlVmCfg_CreateShare function
PrlVmCfg_CreateVmDev
PrlVmCfg_CreateVmDev function
PrlVmCfg_Get3DAccelerationMode
PrlVmCfg_Get3DAccelerationMode function
PrlVmCfg_GetAccessRights
PrlVmCfg_GetAccessRights function
PrlVmCfg_GetActionOnStopMode
PrlVmCfg_GetActionOnStopMode function
PrlVmCfg_GetActionOnWindowClose
PrlVmCfg_GetActionOnWindowClose function
PrlVmCfg_GetAllDevices
PrlVmCfg_GetAllDevices function
PrlVmCfg_GetAppInDockMode
PrlVmCfg_GetAppInDockMode function
PrlVmCfg_GetAppTemplateList
PrlVmCfg_GetAppTemplateList function
PrlVmCfg_GetAssetId
PrlVmCfg_GetAssetId function
PrlVmCfg_GetAutoCompressInterval
PrlVmCfg_GetAutoCompressInterval function
PrlVmCfg_GetAutoStart
PrlVmCfg_GetAutoStart function
PrlVmCfg_GetAutoStartDelay
PrlVmCfg_GetAutoStartDelay function
PrlVmCfg_GetAutoStop
PrlVmCfg_GetAutoStop function
PrlVmCfg_GetBackgroundPriority
PrlVmCfg_GetBackgroundPriority function
PrlVmCfg_GetBootDev
PrlVmCfg_GetBootDev function
PrlVmCfg_GetBootDevCount
PrlVmCfg_GetBootDevCount function
PrlVmCfg_GetCapabilitiesMask
PrlVmCfg_GetCapabilitiesMask function
PrlVmCfg_GetCoherenceButtonVisibility
PrlVmCfg_GetCoherenceButtonVisibility function
PrlVmCfg_GetConfigValidity
PrlVmCfg_GetConfigValidity function
PrlVmCfg_GetConfirmationsList
PrlVmCfg_GetConfirmationsList function
PrlVmCfg_GetCpuAccelLevel
PrlVmCfg_GetCpuAccelLevel function
PrlVmCfg_GetCpuCount
PrlVmCfg_GetCpuCount function
PrlVmCfg_GetCpuLimit
PrlVmCfg_GetCpuLimit function
PrlVmCfg_GetCpuLimitEx
PrlVmCfg_GetCpuLimitEx function
PrlVmCfg_GetCpuMask
PrlVmCfg_GetCpuMask function
PrlVmCfg_GetCpuMode
PrlVmCfg_GetCpuMode function
PrlVmCfg_GetCpuUnits
PrlVmCfg_GetCpuUnits function
PrlVmCfg_GetCustomProperty
PrlVmCfg_GetCustomProperty function
PrlVmCfg_GetDefaultHddSize
PrlVmCfg_GetDefaultHddSize function
PrlVmCfg_GetDefaultMemSize
PrlVmCfg_GetDefaultMemSize function
PrlVmCfg_GetDefaultVideoRamSize
PrlVmCfg_GetDefaultVideoRamSize function
PrlVmCfg_GetDescription
PrlVmCfg_GetDescription function
PrlVmCfg_GetDevByType
PrlVmCfg_GetDevByType function
PrlVmCfg_GetDevsCount
PrlVmCfg_GetDevsCount function
PrlVmCfg_GetDevsCountByType
PrlVmCfg_GetDevsCountByType function
PrlVmCfg_GetDisplayDev
PrlVmCfg_GetDisplayDev function
PrlVmCfg_GetDisplayDevsCount
PrlVmCfg_GetDisplayDevsCount function
PrlVmCfg_GetDnsServers
PrlVmCfg_GetDnsServers function
PrlVmCfg_GetDockIconType
PrlVmCfg_GetDockIconType function
PrlVmCfg_GetEnvId
PrlVmCfg_GetEnvId function
PrlVmCfg_GetExpirationDate
PrlVmCfg_GetExpirationDate function
PrlVmCfg_GetExpirationNote
PrlVmCfg_GetExpirationNote function
PrlVmCfg_GetExpirationOfflineTimeToLive
PrlVmCfg_GetExpirationOfflineTimeToLive function
PrlVmCfg_GetExpirationTimeCheckInterval
PrlVmCfg_GetExpirationTimeCheckInterval function
PrlVmCfg_GetExpirationTrustedTimeServer
PrlVmCfg_GetExpirationTrustedTimeServer function
PrlVmCfg_GetExternalBootDevice
PrlVmCfg_GetExternalBootDevice function
PrlVmCfg_GetFeaturesMask
PrlVmCfg_GetFeaturesMask function
PrlVmCfg_GetFloppyDisk
PrlVmCfg_GetFloppyDisk function
PrlVmCfg_GetFloppyDisksCount
PrlVmCfg_GetFloppyDisksCount function
PrlVmCfg_GetForegroundPriority
PrlVmCfg_GetForegroundPriority function
PrlVmCfg_GetFreeDiskSpaceRatio
PrlVmCfg_GetFreeDiskSpaceRatio function
PrlVmCfg_GetGenericPciDev
PrlVmCfg_GetGenericPciDev function
PrlVmCfg_GetGenericPciDevsCount
PrlVmCfg_GetGenericPciDevsCount function
PrlVmCfg_GetGenericScsiDev
PrlVmCfg_GetGenericScsiDev function
PrlVmCfg_GetGenericScsiDevsCount
PrlVmCfg_GetGenericScsiDevsCount function
PrlVmCfg_GetHardDisk
PrlVmCfg_GetHardDisk function
PrlVmCfg_GetHardDisksCount
PrlVmCfg_GetHardDisksCount function
PrlVmCfg_GetHighAvailabilityPriority
PrlVmCfg_GetHighAvailabilityPriority function
PrlVmCfg_GetHomePath
PrlVmCfg_GetHomePath function
PrlVmCfg_GetHostMemQuotaMax
PrlVmCfg_GetHostMemQuotaMax function
PrlVmCfg_GetHostMemQuotaMin
PrlVmCfg_GetHostMemQuotaMin function
PrlVmCfg_GetHostMemQuotaPriority
PrlVmCfg_GetHostMemQuotaPriority function
PrlVmCfg_GetHostname
PrlVmCfg_GetHostname function
PrlVmCfg_GetIcon
PrlVmCfg_GetIcon function
PrlVmCfg_GetIoLimit
PrlVmCfg_GetIoLimit function
PrlVmCfg_GetIoPriority
PrlVmCfg_GetIoPriority function
PrlVmCfg_GetIopsLimit
PrlVmCfg_GetIopsLimit function
PrlVmCfg_GetLastModifiedDate
PrlVmCfg_GetLastModifiedDate function
PrlVmCfg_GetLastModifierName
PrlVmCfg_GetLastModifierName function
PrlVmCfg_GetLinkedVmUuid
PrlVmCfg_GetLinkedVmUuid function
PrlVmCfg_GetLocation
PrlVmCfg_GetLocation function
PrlVmCfg_GetMaxBalloonSize
PrlVmCfg_GetMaxBalloonSize function
PrlVmCfg_GetName
PrlVmCfg_GetName function
PrlVmCfg_GetNetAdapter
PrlVmCfg_GetNetAdapter function
PrlVmCfg_GetNetAdaptersCount
PrlVmCfg_GetNetAdaptersCount function
PrlVmCfg_GetNetfilterMode
PrlVmCfg_GetNetfilterMode function
PrlVmCfg_GetNetworkRateList
PrlVmCfg_GetNetworkRateList function
PrlVmCfg_GetOfflineServices
PrlVmCfg_GetOfflineServices function
PrlVmCfg_GetOpticalDisk
PrlVmCfg_GetOpticalDisk function
PrlVmCfg_GetOpticalDisksCount
PrlVmCfg_GetOpticalDisksCount function
PrlVmCfg_GetOptimizeModifiersMode
PrlVmCfg_GetOptimizeModifiersMode function
PrlVmCfg_GetOsTemplate
PrlVmCfg_GetOsTemplate function
PrlVmCfg_GetOsType
PrlVmCfg_GetOsType function
PrlVmCfg_GetOsVersion
PrlVmCfg_GetOsVersion function
PrlVmCfg_GetParallelPort
PrlVmCfg_GetParallelPort function
PrlVmCfg_GetParallelPortsCount
PrlVmCfg_GetParallelPortsCount function
PrlVmCfg_GetProfile
PrlVmCfg_GetProfile function
PrlVmCfg_GetRamSize
PrlVmCfg_GetRamSize function
PrlVmCfg_GetResource
PrlVmCfg_GetResource function
PrlVmCfg_GetScrRes
PrlVmCfg_GetScrRes function
PrlVmCfg_GetScrResCount
PrlVmCfg_GetScrResCount function
PrlVmCfg_GetSearchDomains
PrlVmCfg_GetSearchDomains function
PrlVmCfg_GetSerialPort
PrlVmCfg_GetSerialPort function
PrlVmCfg_GetSerialPortsCount
PrlVmCfg_GetSerialPortsCount function
PrlVmCfg_GetServerHost
PrlVmCfg_GetServerHost function
PrlVmCfg_GetServerUuid
PrlVmCfg_GetServerUuid function
PrlVmCfg_GetShare
PrlVmCfg_GetShare function
PrlVmCfg_GetSharesCount
PrlVmCfg_GetSharesCount function
PrlVmCfg_GetSmartGuardInterval
PrlVmCfg_GetSmartGuardInterval function
PrlVmCfg_GetSmartGuardMaxSnapshotsCount
PrlVmCfg_GetSmartGuardMaxSnapshotsCount function
PrlVmCfg_GetSoundDev
PrlVmCfg_GetSoundDev function
PrlVmCfg_GetSoundDevsCount
PrlVmCfg_GetSoundDevsCount function
PrlVmCfg_GetStartLoginMode
PrlVmCfg_GetStartLoginMode function
PrlVmCfg_GetStartUserLogin
PrlVmCfg_GetStartUserLogin function
PrlVmCfg_GetSystemFlags
PrlVmCfg_GetSystemFlags function
PrlVmCfg_GetTimeSyncInterval
PrlVmCfg_GetTimeSyncInterval function
PrlVmCfg_GetUnattendedInstallEdition
PrlVmCfg_GetUnattendedInstallEdition function
PrlVmCfg_GetUnattendedInstallLocale
PrlVmCfg_GetUnattendedInstallLocale function
PrlVmCfg_GetUndoDisksMode
PrlVmCfg_GetUndoDisksMode function
PrlVmCfg_GetUptime
PrlVmCfg_GetUptime function
PrlVmCfg_GetUptimeStartDate
PrlVmCfg_GetUptimeStartDate function
PrlVmCfg_GetUsbDevice
PrlVmCfg_GetUsbDevice function
PrlVmCfg_GetUsbDevicesCount
PrlVmCfg_GetUsbDevicesCount function
PrlVmCfg_GetUuid
PrlVmCfg_GetUuid function
PrlVmCfg_GetVideoRamSize
PrlVmCfg_GetVideoRamSize function
PrlVmCfg_GetVmInfo
PrlVmCfg_GetVmInfo function
PrlVmCfg_GetVmType
PrlVmCfg_GetVmType function
PrlVmCfg_GetVNCHostName
PrlVmCfg_GetVNCHostName function
PrlVmCfg_GetVNCMode
PrlVmCfg_GetVNCMode function
PrlVmCfg_GetVNCPassword
PrlVmCfg_GetVNCPassword function
PrlVmCfg_GetVNCPort
PrlVmCfg_GetVNCPort function
PrlVmCfg_GetWindowMode
PrlVmCfg_GetWindowMode function
PrlVmCfg_IsAdaptiveHypervisorEnabled
PrlVmCfg_IsAdaptiveHypervisorEnabled function
PrlVmCfg_IsAllowSelectBootDevice
PrlVmCfg_IsAllowSelectBootDevice function
PrlVmCfg_IsAutoApplyIpOnly
PrlVmCfg_IsAutoApplyIpOnly function
PrlVmCfg_IsAutoCaptureReleaseMouse
PrlVmCfg_IsAutoCaptureReleaseMouse function
PrlVmCfg_IsAutoCompressEnabled
PrlVmCfg_IsAutoCompressEnabled function
PrlVmCfg_IsBatteryStatusEnabled
PrlVmCfg_IsBatteryStatusEnabled function
PrlVmCfg_IsCloseAppOnShutdown
PrlVmCfg_IsCloseAppOnShutdown function
PrlVmCfg_IsConfigInvalid
PrlVmCfg_IsConfigInvalid function
PrlVmCfg_IsCpuHotplugEnabled
PrlVmCfg_IsCpuHotplugEnabled function
PrlVmCfg_IsCpuVtxEnabled
PrlVmCfg_IsCpuVtxEnabled function
PrlVmCfg_IsCustomProfile
PrlVmCfg_IsCustomProfile function
PrlVmCfg_IsDefaultDeviceNeeded
PrlVmCfg_IsDefaultDeviceNeeded function
PrlVmCfg_IsDisableAPIC
PrlVmCfg_IsDisableAPIC function
PrlVmCfg_IsDisableSpeaker
PrlVmCfg_IsDisableSpeaker function
PrlVmCfg_IsDiskCacheWriteBack
PrlVmCfg_IsDiskCacheWriteBack function
PrlVmCfg_IsEfiEnabled
PrlVmCfg_IsEfiEnabled function
PrlVmCfg_IsEncrypted
PrlVmCfg_IsEncrypted function
PrlVmCfg_IsExcludeDock
PrlVmCfg_IsExcludeDock function
PrlVmCfg_IsExpirationDateEnabled
PrlVmCfg_IsExpirationDateEnabled function
PrlVmCfg_IsGuestSharingAutoMount
PrlVmCfg_IsGuestSharingAutoMount function
PrlVmCfg_IsGuestSharingEnabled
PrlVmCfg_IsGuestSharingEnabled function
PrlVmCfg_IsGuestSharingEnableSpotlight
PrlVmCfg_IsGuestSharingEnableSpotlight function
PrlVmCfg_IsHideMinimizedWindowsEnabled
PrlVmCfg_IsHideMinimizedWindowsEnabled function
PrlVmCfg_IsHighAvailabilityEnabled
PrlVmCfg_IsHighAvailabilityEnabled function
PrlVmCfg_IsHighResolutionEnabled
PrlVmCfg_IsHighResolutionEnabled function
PrlVmCfg_IsHostMemAutoQuota
PrlVmCfg_IsHostMemAutoQuota function
PrlVmCfg_IsHostSharingEnabled
PrlVmCfg_IsHostSharingEnabled function
PrlVmCfg_IsIsolatedVmEnabled
PrlVmCfg_IsIsolatedVmEnabled function
PrlVmCfg_IsLockGuestOnSuspendEnabled
PrlVmCfg_IsLockGuestOnSuspendEnabled function
PrlVmCfg_IsLockInFullScreenMode
PrlVmCfg_IsLockInFullScreenMode function
PrlVmCfg_IsLongerBatteryLifeEnabled
PrlVmCfg_IsLongerBatteryLifeEnabled function
PrlVmCfg_IsMapSharedFoldersOnLetters
PrlVmCfg_IsMapSharedFoldersOnLetters function
PrlVmCfg_IsMultiDisplay
PrlVmCfg_IsMultiDisplay function
PrlVmCfg_IsNestedVirtualizationEnabled
PrlVmCfg_IsNestedVirtualizationEnabled function
PrlVmCfg_IsOfflineManagementEnabled
PrlVmCfg_IsOfflineManagementEnabled function
PrlVmCfg_IsOsResInFullScrMode
PrlVmCfg_IsOsResInFullScrMode function
PrlVmCfg_IsPauseWhenIdle
PrlVmCfg_IsPauseWhenIdle function
PrlVmCfg_IsPMUVirtualizationEnabled
PrlVmCfg_IsPMUVirtualizationEnabled function
PrlVmCfg_IsProtected
PrlVmCfg_IsProtected function
PrlVmCfg_IsRamHotplugEnabled
PrlVmCfg_IsRamHotplugEnabled function
PrlVmCfg_IsRateBound
PrlVmCfg_IsRateBound function
PrlVmCfg_IsRelocateTaskBar
PrlVmCfg_IsRelocateTaskBar function
PrlVmCfg_IsScrResEnabled
PrlVmCfg_IsScrResEnabled function
PrlVmCfg_IsShareAllHostDisks
PrlVmCfg_IsShareAllHostDisks function
PrlVmCfg_IsShareClipboard
PrlVmCfg_IsShareClipboard function
PrlVmCfg_IsSharedAppsGuestToHost
PrlVmCfg_IsSharedAppsGuestToHost function
PrlVmCfg_IsSharedAppsHostToGuest
PrlVmCfg_IsSharedAppsHostToGuest function
PrlVmCfg_IsSharedBluetoothEnabled
PrlVmCfg_IsSharedBluetoothEnabled function
PrlVmCfg_IsSharedCameraEnabled
PrlVmCfg_IsSharedCameraEnabled function
PrlVmCfg_IsSharedCloudEnabled
PrlVmCfg_IsSharedCloudEnabled function
PrlVmCfg_IsSharedProfileEnabled
PrlVmCfg_IsSharedProfileEnabled function
PrlVmCfg_IsShareUserHomeDir
PrlVmCfg_IsShareUserHomeDir function
PrlVmCfg_IsShowTaskBar
PrlVmCfg_IsShowTaskBar function
PrlVmCfg_IsShowWindowsAppInDock
PrlVmCfg_IsShowWindowsAppInDock function
PrlVmCfg_IsSmartGuardEnabled
PrlVmCfg_IsSmartGuardEnabled function
PrlVmCfg_IsSmartGuardNotifyBeforeCreation
PrlVmCfg_IsSmartGuardNotifyBeforeCreation function
PrlVmCfg_IsSmartMountDVDsEnabled
PrlVmCfg_IsSmartMountDVDsEnabled function
PrlVmCfg_IsSmartMountEnabled
PrlVmCfg_IsSmartMountEnabled function
PrlVmCfg_IsSmartMountNetworkSharesEnabled
PrlVmCfg_IsSmartMountNetworkSharesEnabled function
PrlVmCfg_IsSmartMountRemovableDrivesEnabled
PrlVmCfg_IsSmartMountRemovableDrivesEnabled function
PrlVmCfg_IsSmartMouseEnabled
PrlVmCfg_IsSmartMouseEnabled function
PrlVmCfg_IsStartInDetachedWindowEnabled
PrlVmCfg_IsStartInDetachedWindowEnabled function
PrlVmCfg_IsStickyMouseEnabled
PrlVmCfg_IsStickyMouseEnabled function
PrlVmCfg_IsSupportUsb30Enabled
PrlVmCfg_IsSupportUsb30Enabled function
PrlVmCfg_IsSwitchOffAeroEnabled
PrlVmCfg_IsSwitchOffAeroEnabled function
PrlVmCfg_IsSwitchOffWindowsLogoEnabled
PrlVmCfg_IsSwitchOffWindowsLogoEnabled function
PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled
PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled function
PrlVmCfg_IsSyncDefaultPrinter
PrlVmCfg_IsSyncDefaultPrinter function
PrlVmCfg_IsTemplate
PrlVmCfg_IsTemplate function
PrlVmCfg_IsTimeSynchronizationEnabled
PrlVmCfg_IsTimeSynchronizationEnabled function
PrlVmCfg_IsTimeSyncSmartModeEnabled
PrlVmCfg_IsTimeSyncSmartModeEnabled function
PrlVmCfg_IsToolsAutoUpdateEnabled
PrlVmCfg_IsToolsAutoUpdateEnabled function
PrlVmCfg_IsUseDefaultAnswers
PrlVmCfg_IsUseDefaultAnswers function
PrlVmCfg_IsUseDesktop
PrlVmCfg_IsUseDesktop function
PrlVmCfg_IsUseDocuments
PrlVmCfg_IsUseDocuments function
PrlVmCfg_IsUseDownloads
PrlVmCfg_IsUseDownloads function
PrlVmCfg_IsUseHostPrinters
PrlVmCfg_IsUseHostPrinters function
PrlVmCfg_IsUseMovies
PrlVmCfg_IsUseMovies function
PrlVmCfg_IsUseMusic
PrlVmCfg_IsUseMusic function
PrlVmCfg_IsUsePictures
PrlVmCfg_IsUsePictures function
PrlVmCfg_IsUserDefinedSharedFoldersEnabled
PrlVmCfg_IsUserDefinedSharedFoldersEnabled function
PrlVmCfg_IsVerticalSynchronizationEnabled
PrlVmCfg_IsVerticalSynchronizationEnabled function
PrlVmCfg_IsVirtualLinksEnabled
PrlVmCfg_IsVirtualLinksEnabled function
PrlVmCfg_IsWinSystrayInMacMenuEnabled
PrlVmCfg_IsWinSystrayInMacMenuEnabled function
PrlVmCfg_Set3DAccelerationMode
PrlVmCfg_Set3DAccelerationMode function
PrlVmCfg_SetActionOnStopMode
PrlVmCfg_SetActionOnStopMode function
PrlVmCfg_SetActionOnWindowClose
PrlVmCfg_SetActionOnWindowClose function
PrlVmCfg_SetAdaptiveHypervisorEnabled
PrlVmCfg_SetAdaptiveHypervisorEnabled function
PrlVmCfg_SetAllowSelectBootDevice
PrlVmCfg_SetAllowSelectBootDevice function
PrlVmCfg_SetAppInDockMode
PrlVmCfg_SetAppInDockMode function
PrlVmCfg_SetAppTemplateList
PrlVmCfg_SetAppTemplateList function
PrlVmCfg_SetAssetId
PrlVmCfg_SetAssetId function
PrlVmCfg_SetAutoApplyIpOnly
PrlVmCfg_SetAutoApplyIpOnly function
PrlVmCfg_SetAutoCaptureReleaseMouse
PrlVmCfg_SetAutoCaptureReleaseMouse function
PrlVmCfg_SetAutoCompressEnabled
PrlVmCfg_SetAutoCompressEnabled function
PrlVmCfg_SetAutoCompressInterval
PrlVmCfg_SetAutoCompressInterval function
PrlVmCfg_SetAutoStart
PrlVmCfg_SetAutoStart function
PrlVmCfg_SetAutoStartDelay
PrlVmCfg_SetAutoStartDelay function
PrlVmCfg_SetAutoStop
PrlVmCfg_SetAutoStop function
PrlVmCfg_SetBackgroundPriority
PrlVmCfg_SetBackgroundPriority function
PrlVmCfg_SetBatteryStatusEnabled
PrlVmCfg_SetBatteryStatusEnabled function
PrlVmCfg_SetCapabilitiesMask
PrlVmCfg_SetCapabilitiesMask function
PrlVmCfg_SetCloseAppOnShutdown
PrlVmCfg_SetCloseAppOnShutdown function
PrlVmCfg_SetCoherenceButtonVisibility
PrlVmCfg_SetCoherenceButtonVisibility function
PrlVmCfg_SetConfirmationsList
PrlVmCfg_SetConfirmationsList function
PrlVmCfg_SetCpuAccelLevel
PrlVmCfg_SetCpuAccelLevel function
PrlVmCfg_SetCpuCount
PrlVmCfg_SetCpuCount function
PrlVmCfg_SetCpuHotplugEnabled
PrlVmCfg_SetCpuHotplugEnabled function
PrlVmCfg_SetCpuLimit
PrlVmCfg_SetCpuLimit function
PrlVmCfg_SetCpuLimitEx
PrlVmCfg_SetCpuLimitEx function
PrlVmCfg_SetCpuMask
PrlVmCfg_SetCpuMask function
PrlVmCfg_SetCpuMode
PrlVmCfg_SetCpuMode function
PrlVmCfg_SetCpuUnits
PrlVmCfg_SetCpuUnits function
PrlVmCfg_SetCustomProperty
PrlVmCfg_SetCustomProperty function
PrlVmCfg_SetDefaultConfig
PrlVmCfg_SetDefaultConfig function
PrlVmCfg_SetDescription
PrlVmCfg_SetDescription function
PrlVmCfg_SetDisableAPICSign
PrlVmCfg_SetDisableAPICSign function
PrlVmCfg_SetDisableSpeakerSign
PrlVmCfg_SetDisableSpeakerSign function
PrlVmCfg_SetDiskCacheWriteBack
PrlVmCfg_SetDiskCacheWriteBack function
PrlVmCfg_SetDnsServers
PrlVmCfg_SetDnsServers function
PrlVmCfg_SetDockIconType
PrlVmCfg_SetDockIconType function
PrlVmCfg_SetEfiEnabled
PrlVmCfg_SetEfiEnabled function
PrlVmCfg_SetExcludeDock
PrlVmCfg_SetExcludeDock function
PrlVmCfg_SetExpirationDate
PrlVmCfg_SetExpirationDate function
PrlVmCfg_SetExpirationDateEnabled
PrlVmCfg_SetExpirationDateEnabled function
PrlVmCfg_SetExpirationNote
PrlVmCfg_SetExpirationNote function
PrlVmCfg_SetExpirationOfflineTimeToLive
PrlVmCfg_SetExpirationOfflineTimeToLive function
PrlVmCfg_SetExpirationTimeCheckInterval
PrlVmCfg_SetExpirationTimeCheckInterval function
PrlVmCfg_SetExpirationTrustedTimeServer
PrlVmCfg_SetExpirationTrustedTimeServer function
PrlVmCfg_SetExternalBootDevice
PrlVmCfg_SetExternalBootDevice function
PrlVmCfg_SetFeaturesMask
PrlVmCfg_SetFeaturesMask function
PrlVmCfg_SetForegroundPriority
PrlVmCfg_SetForegroundPriority function
PrlVmCfg_SetFreeDiskSpaceRatio
PrlVmCfg_SetFreeDiskSpaceRatio function
PrlVmCfg_SetGuestSharingAutoMount
PrlVmCfg_SetGuestSharingAutoMount function
PrlVmCfg_SetGuestSharingEnabled
PrlVmCfg_SetGuestSharingEnabled function
PrlVmCfg_SetGuestSharingEnableSpotlight
PrlVmCfg_SetGuestSharingEnableSpotlight function
PrlVmCfg_SetHideMinimizedWindowsEnabled
PrlVmCfg_SetHideMinimizedWindowsEnabled function
PrlVmCfg_SetHighAvailabilityEnabled
PrlVmCfg_SetHighAvailabilityEnabled function
PrlVmCfg_SetHighAvailabilityPriority
PrlVmCfg_SetHighAvailabilityPriority function
PrlVmCfg_SetHighResolutionEnabled
PrlVmCfg_SetHighResolutionEnabled function
PrlVmCfg_SetHostMemAutoQuota
PrlVmCfg_SetHostMemAutoQuota function
PrlVmCfg_SetHostMemQuotaMax
PrlVmCfg_SetHostMemQuotaMax function
PrlVmCfg_SetHostMemQuotaMin
PrlVmCfg_SetHostMemQuotaMin function
PrlVmCfg_SetHostMemQuotaPriority
PrlVmCfg_SetHostMemQuotaPriority function
PrlVmCfg_SetHostname
PrlVmCfg_SetHostname function
PrlVmCfg_SetHostSharingEnabled
PrlVmCfg_SetHostSharingEnabled function
PrlVmCfg_SetIcon
PrlVmCfg_SetIcon function
PrlVmCfg_SetIoLimit
PrlVmCfg_SetIoLimit function
PrlVmCfg_SetIoPriority
PrlVmCfg_SetIoPriority function
PrlVmCfg_SetIopsLimit
PrlVmCfg_SetIopsLimit function
PrlVmCfg_SetIsolatedVmEnabled
PrlVmCfg_SetIsolatedVmEnabled function
PrlVmCfg_SetLockGuestOnSuspendEnabled
PrlVmCfg_SetLockGuestOnSuspendEnabled function
PrlVmCfg_SetLockInFullScreenMode
PrlVmCfg_SetLockInFullScreenMode function
PrlVmCfg_SetLongerBatteryLifeEnabled
PrlVmCfg_SetLongerBatteryLifeEnabled function
PrlVmCfg_SetMapSharedFoldersOnLetters
PrlVmCfg_SetMapSharedFoldersOnLetters function
PrlVmCfg_SetMaxBalloonSize
PrlVmCfg_SetMaxBalloonSize function
PrlVmCfg_SetMultiDisplay
PrlVmCfg_SetMultiDisplay function
PrlVmCfg_SetName
PrlVmCfg_SetName function
PrlVmCfg_SetNestedVirtualizationEnabled
PrlVmCfg_SetNestedVirtualizationEnabled function
PrlVmCfg_SetNetfilterMode
PrlVmCfg_SetNetfilterMode function
PrlVmCfg_SetNetworkRateList
PrlVmCfg_SetNetworkRateList function
PrlVmCfg_SetOfflineManagementEnabled
PrlVmCfg_SetOfflineManagementEnabled function
PrlVmCfg_SetOfflineServices
PrlVmCfg_SetOfflineServices function
PrlVmCfg_SetOptimizeModifiersMode
PrlVmCfg_SetOptimizeModifiersMode function
PrlVmCfg_SetOsResInFullScrMode
PrlVmCfg_SetOsResInFullScrMode function
PrlVmCfg_SetOsTemplate
PrlVmCfg_SetOsTemplate function
PrlVmCfg_SetOsVersion
PrlVmCfg_SetOsVersion function
PrlVmCfg_SetPauseWhenIdle
PrlVmCfg_SetPauseWhenIdle function
PrlVmCfg_SetPMUVirtualizationEnabled
PrlVmCfg_SetPMUVirtualizationEnabled function
PrlVmCfg_SetProfile
PrlVmCfg_SetProfile function
PrlVmCfg_SetRamHotplugEnabled
PrlVmCfg_SetRamHotplugEnabled function
PrlVmCfg_SetRamSize
PrlVmCfg_SetRamSize function
PrlVmCfg_SetRateBound
PrlVmCfg_SetRateBound function
PrlVmCfg_SetRelocateTaskBar
PrlVmCfg_SetRelocateTaskBar function
PrlVmCfg_SetResource
PrlVmCfg_SetResource function
PrlVmCfg_SetScrResEnabled
PrlVmCfg_SetScrResEnabled function
PrlVmCfg_SetSearchDomains
PrlVmCfg_SetSearchDomains function
PrlVmCfg_SetShareAllHostDisks
PrlVmCfg_SetShareAllHostDisks function
PrlVmCfg_SetShareClipboard
PrlVmCfg_SetShareClipboard function
PrlVmCfg_SetSharedAppsGuestToHost
PrlVmCfg_SetSharedAppsGuestToHost function
PrlVmCfg_SetSharedAppsHostToGuest
PrlVmCfg_SetSharedAppsHostToGuest function
PrlVmCfg_SetSharedBluetoothEnabled
PrlVmCfg_SetSharedBluetoothEnabled function
PrlVmCfg_SetSharedCameraEnabled
PrlVmCfg_SetSharedCameraEnabled function
PrlVmCfg_SetSharedCloudEnabled
PrlVmCfg_SetSharedCloudEnabled function
PrlVmCfg_SetSharedProfileEnabled
PrlVmCfg_SetSharedProfileEnabled function
PrlVmCfg_SetShareUserHomeDir
PrlVmCfg_SetShareUserHomeDir function
PrlVmCfg_SetShowTaskBar
PrlVmCfg_SetShowTaskBar function
PrlVmCfg_SetShowWindowsAppInDock
PrlVmCfg_SetShowWindowsAppInDock function
PrlVmCfg_SetSmartGuardEnabled
PrlVmCfg_SetSmartGuardEnabled function
PrlVmCfg_SetSmartGuardInterval
PrlVmCfg_SetSmartGuardInterval function
PrlVmCfg_SetSmartGuardMaxSnapshotsCount
PrlVmCfg_SetSmartGuardMaxSnapshotsCount function
PrlVmCfg_SetSmartGuardNotifyBeforeCreation
PrlVmCfg_SetSmartGuardNotifyBeforeCreation function
PrlVmCfg_SetSmartMountDVDsEnabled
PrlVmCfg_SetSmartMountDVDsEnabled function
PrlVmCfg_SetSmartMountEnabled
PrlVmCfg_SetSmartMountEnabled function
PrlVmCfg_SetSmartMountNetworkSharesEnabled
PrlVmCfg_SetSmartMountNetworkSharesEnabled function
PrlVmCfg_SetSmartMountRemovableDrivesEnabled
PrlVmCfg_SetSmartMountRemovableDrivesEnabled function
PrlVmCfg_SetSmartMouseEnabled
PrlVmCfg_SetSmartMouseEnabled function
PrlVmCfg_SetStartInDetachedWindowEnabled
PrlVmCfg_SetStartInDetachedWindowEnabled function
PrlVmCfg_SetStartLoginMode
PrlVmCfg_SetStartLoginMode function
PrlVmCfg_SetStartUserCreds
PrlVmCfg_SetStartUserCreds function
PrlVmCfg_SetStickyMouseEnabled
PrlVmCfg_SetStickyMouseEnabled function
PrlVmCfg_SetSupportUsb30Enabled
PrlVmCfg_SetSupportUsb30Enabled function
PrlVmCfg_SetSwitchOffAeroEnabled
PrlVmCfg_SetSwitchOffAeroEnabled function
PrlVmCfg_SetSwitchOffWindowsLogoEnabled
PrlVmCfg_SetSwitchOffWindowsLogoEnabled function
PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled
PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled function
PrlVmCfg_SetSyncDefaultPrinter
PrlVmCfg_SetSyncDefaultPrinter function
PrlVmCfg_SetSystemFlags
PrlVmCfg_SetSystemFlags function
PrlVmCfg_SetTemplateSign
PrlVmCfg_SetTemplateSign function
PrlVmCfg_SetTimeSynchronizationEnabled
PrlVmCfg_SetTimeSynchronizationEnabled function
PrlVmCfg_SetTimeSyncInterval
PrlVmCfg_SetTimeSyncInterval function
PrlVmCfg_SetTimeSyncSmartModeEnabled
PrlVmCfg_SetTimeSyncSmartModeEnabled function
PrlVmCfg_SetToolsAutoUpdateEnabled
PrlVmCfg_SetToolsAutoUpdateEnabled function
PrlVmCfg_SetUnattendedInstallEdition
PrlVmCfg_SetUnattendedInstallEdition function
PrlVmCfg_SetUnattendedInstallLocale
PrlVmCfg_SetUnattendedInstallLocale function
PrlVmCfg_SetUndoDisksMode
PrlVmCfg_SetUndoDisksMode function
PrlVmCfg_SetUseDefaultAnswers
PrlVmCfg_SetUseDefaultAnswers function
PrlVmCfg_SetUseDesktop
PrlVmCfg_SetUseDesktop function
PrlVmCfg_SetUseDocuments
PrlVmCfg_SetUseDocuments function
PrlVmCfg_SetUseDownloads
PrlVmCfg_SetUseDownloads function
PrlVmCfg_SetUseHostPrinters
PrlVmCfg_SetUseHostPrinters function
PrlVmCfg_SetUseMovies
PrlVmCfg_SetUseMovies function
PrlVmCfg_SetUseMusic
PrlVmCfg_SetUseMusic function
PrlVmCfg_SetUsePictures
PrlVmCfg_SetUsePictures function
PrlVmCfg_SetUserDefinedSharedFoldersEnabled
PrlVmCfg_SetUserDefinedSharedFoldersEnabled function
PrlVmCfg_SetUuid
PrlVmCfg_SetUuid function
PrlVmCfg_SetVerticalSynchronizationEnabled
PrlVmCfg_SetVerticalSynchronizationEnabled function
PrlVmCfg_SetVideoRamSize
PrlVmCfg_SetVideoRamSize function
PrlVmCfg_SetVirtualLinksEnabled
PrlVmCfg_SetVirtualLinksEnabled function
PrlVmCfg_SetVmType
PrlVmCfg_SetVmType function
PrlVmCfg_SetVNCHostName
PrlVmCfg_SetVNCHostName function
PrlVmCfg_SetVNCMode
PrlVmCfg_SetVNCMode function
PrlVmCfg_SetVNCPassword
PrlVmCfg_SetVNCPassword function
PrlVmCfg_SetVNCPort
PrlVmCfg_SetVNCPort function
PrlVmCfg_SetWindowMode
PrlVmCfg_SetWindowMode function
PrlVmCfg_SetWinSystrayInMacMenuEnabled
PrlVmCfg_SetWinSystrayInMacMenuEnabled function
PrlVmDev_Connect
PrlVmDev_Connect function
PrlVmDev_CopyImage
PrlVmDev_CopyImage function
PrlVmDev_Create
PrlVmDev_Create function
PrlVmDev_CreateImage
PrlVmDev_CreateImage function
PrlVmDev_Disconnect
PrlVmDev_Disconnect function
PrlVmDev_GetDescription
PrlVmDev_GetDescription function
PrlVmDev_GetEmulatedType
PrlVmDev_GetEmulatedType function
PrlVmDev_GetFriendlyName
PrlVmDev_GetFriendlyName function
PrlVmDev_GetIfaceType
PrlVmDev_GetIfaceType function
PrlVmDev_GetImagePath
PrlVmDev_GetImagePath function
PrlVmDev_GetIndex
PrlVmDev_GetIndex function
PrlVmDev_GetOutputFile
PrlVmDev_GetOutputFile function
PrlVmDev_GetStackIndex
PrlVmDev_GetStackIndex function
PrlVmDev_GetSubType
PrlVmDev_GetSubType function
PrlVmDev_GetSysName
PrlVmDev_GetSysName function
PrlVmDev_GetType
PrlVmDev_GetType function
PrlVmDev_IsConnected
PrlVmDev_IsConnected function
PrlVmDev_IsEnabled
PrlVmDev_IsEnabled function
PrlVmDev_IsPassthrough
PrlVmDev_IsPassthrough function
PrlVmDev_IsRemote
PrlVmDev_IsRemote function
PrlVmDev_Remove
PrlVmDev_Remove function
PrlVmDev_ResizeImage
PrlVmDev_ResizeImage function
PrlVmDev_SetConnected
PrlVmDev_SetConnected function
PrlVmDev_SetDefaultStackIndex
PrlVmDev_SetDefaultStackIndex function
PrlVmDev_SetDescription
PrlVmDev_SetDescription function
PrlVmDev_SetEmulatedType
PrlVmDev_SetEmulatedType function
PrlVmDev_SetEnabled
PrlVmDev_SetEnabled function
PrlVmDev_SetFriendlyName
PrlVmDev_SetFriendlyName function
PrlVmDev_SetIfaceType
PrlVmDev_SetIfaceType function
PrlVmDev_SetImagePath
PrlVmDev_SetImagePath function
PrlVmDev_SetIndex
PrlVmDev_SetIndex function
PrlVmDev_SetOutputFile
PrlVmDev_SetOutputFile function
PrlVmDev_SetPassthrough
PrlVmDev_SetPassthrough function
PrlVmDev_SetRemote
PrlVmDev_SetRemote function
PrlVmDev_SetStackIndex
PrlVmDev_SetStackIndex function
PrlVmDev_SetSubType
PrlVmDev_SetSubType function
PrlVmDev_SetSysName
PrlVmDev_SetSysName function
PrlVmDevHd_AddPartition
PrlVmDevHd_AddPartition function
PrlVmDevHd_CheckPassword
PrlVmDevHd_CheckPassword function
PrlVmDevHd_GetDiskSize
PrlVmDevHd_GetDiskSize function
PrlVmDevHd_GetDiskType
PrlVmDevHd_GetDiskType function
PrlVmDevHd_GetMountPoint
PrlVmDevHd_GetMountPoint function
PrlVmDevHd_GetPartition
PrlVmDevHd_GetPartition function
PrlVmDevHd_GetPartitionsCount
PrlVmDevHd_GetPartitionsCount function
PrlVmDevHd_GetSizeOnDisk
PrlVmDevHd_GetSizeOnDisk function
PrlVmDevHd_GetStorageURL
PrlVmDevHd_GetStorageURL function
PrlVmDevHd_IsAutoCompressEnabled
PrlVmDevHd_IsAutoCompressEnabled function
PrlVmDevHd_IsEncrypted
PrlVmDevHd_IsEncrypted function
PrlVmDevHd_IsSplitted
PrlVmDevHd_IsSplitted function
PrlVmDevHd_SetAutoCompressEnabled
PrlVmDevHd_SetAutoCompressEnabled function
PrlVmDevHd_SetDiskSize
PrlVmDevHd_SetDiskSize function
PrlVmDevHd_SetDiskType
PrlVmDevHd_SetDiskType function
PrlVmDevHd_SetMountPoint
PrlVmDevHd_SetMountPoint function
PrlVmDevHd_SetPassword
PrlVmDevHd_SetPassword function
PrlVmDevHd_SetSplitted
PrlVmDevHd_SetSplitted function
PrlVmDevHd_SetStorageURL
PrlVmDevHd_SetStorageURL function
PrlVmDevHdPart_GetSysName
PrlVmDevHdPart_GetSysName function
PrlVmDevHdPart_Remove
PrlVmDevHdPart_Remove function
PrlVmDevHdPart_SetSysName
PrlVmDevHdPart_SetSysName function
PrlVmDevNet_GenerateMacAddr
PrlVmDevNet_GenerateMacAddr function
PrlVmDevNet_GetAdapterType
PrlVmDevNet_GetAdapterType function
PrlVmDevNet_GetBoundAdapterIndex
PrlVmDevNet_GetBoundAdapterIndex function
PrlVmDevNet_GetBoundAdapterName
PrlVmDevNet_GetBoundAdapterName function
PrlVmDevNet_GetDefaultGateway
PrlVmDevNet_GetDefaultGateway function
PrlVmDevNet_GetDefaultGatewayIPv6
PrlVmDevNet_GetDefaultGatewayIPv6 function
PrlVmDevNet_GetDnsServers
PrlVmDevNet_GetDnsServers function
PrlVmDevNet_GetFirewallDefaultPolicy
PrlVmDevNet_GetFirewallDefaultPolicy function
PrlVmDevNet_GetFirewallRuleList
PrlVmDevNet_GetFirewallRuleList function
PrlVmDevNet_GetHostInterfaceName
PrlVmDevNet_GetHostInterfaceName function
PrlVmDevNet_GetMacAddress
PrlVmDevNet_GetMacAddress function
PrlVmDevNet_GetMacAddressCanonical
PrlVmDevNet_GetMacAddressCanonical function
PrlVmDevNet_GetNetAddresses
PrlVmDevNet_GetNetAddresses function
PrlVmDevNet_GetSearchDomains
PrlVmDevNet_GetSearchDomains function
PrlVmDevNet_GetVirtualNetworkId
PrlVmDevNet_GetVirtualNetworkId function
PrlVmDevNet_IsAutoApply
PrlVmDevNet_IsAutoApply function
PrlVmDevNet_IsConfigureWithDhcp
PrlVmDevNet_IsConfigureWithDhcp function
PrlVmDevNet_IsConfigureWithDhcpIPv6
PrlVmDevNet_IsConfigureWithDhcpIPv6 function
PrlVmDevNet_IsFirewallEnabled
PrlVmDevNet_IsFirewallEnabled function
PrlVmDevNet_IsPktFilterPreventIpSpoof
PrlVmDevNet_IsPktFilterPreventIpSpoof function
PrlVmDevNet_IsPktFilterPreventMacSpoof
PrlVmDevNet_IsPktFilterPreventMacSpoof function
PrlVmDevNet_SetAdapterType
PrlVmDevNet_SetAdapterType function
PrlVmDevNet_SetAutoApply
PrlVmDevNet_SetAutoApply function
PrlVmDevNet_SetBoundAdapterIndex
PrlVmDevNet_SetBoundAdapterIndex function
PrlVmDevNet_SetBoundAdapterName
PrlVmDevNet_SetBoundAdapterName function
PrlVmDevNet_SetConfigureWithDhcp
PrlVmDevNet_SetConfigureWithDhcp function
PrlVmDevNet_SetConfigureWithDhcpIPv6
PrlVmDevNet_SetConfigureWithDhcpIPv6 function
PrlVmDevNet_SetDefaultGateway
PrlVmDevNet_SetDefaultGateway function
PrlVmDevNet_SetDefaultGatewayIPv6
PrlVmDevNet_SetDefaultGatewayIPv6 function
PrlVmDevNet_SetDnsServers
PrlVmDevNet_SetDnsServers function
PrlVmDevNet_SetFirewallDefaultPolicy
PrlVmDevNet_SetFirewallDefaultPolicy function
PrlVmDevNet_SetFirewallEnabled
PrlVmDevNet_SetFirewallEnabled function
PrlVmDevNet_SetFirewallRuleList
PrlVmDevNet_SetFirewallRuleList function
PrlVmDevNet_SetHostInterfaceName
PrlVmDevNet_SetHostInterfaceName function
PrlVmDevNet_SetMacAddress
PrlVmDevNet_SetMacAddress function
PrlVmDevNet_SetNetAddresses
PrlVmDevNet_SetNetAddresses function
PrlVmDevNet_SetPktFilterPreventIpSpoof
PrlVmDevNet_SetPktFilterPreventIpSpoof function
PrlVmDevNet_SetPktFilterPreventMacSpoof
PrlVmDevNet_SetPktFilterPreventMacSpoof function
PrlVmDevNet_SetPktFilterPreventPromisc
PrlVmDevNet_SetPktFilterPreventPromisc function
PrlVmDevNet_SetSearchDomains
PrlVmDevNet_SetSearchDomains function
PrlVmDevNet_SetVirtualNetworkId
PrlVmDevNet_SetVirtualNetworkId function
PrlVmDevSerial_GetSocketMode
PrlVmDevSerial_GetSocketMode function
PrlVmDevSerial_SetSocketMode
PrlVmDevSerial_SetSocketMode function
PrlVmDevSound_GetMixerDev
PrlVmDevSound_GetMixerDev function
PrlVmDevSound_GetOutputDev
PrlVmDevSound_GetOutputDev function
PrlVmDevSound_SetMixerDev
PrlVmDevSound_SetMixerDev function
PrlVmDevSound_SetOutputDev
PrlVmDevSound_SetOutputDev function
PrlVmDevUsb_GetAutoconnectOption
PrlVmDevUsb_GetAutoconnectOption function
PrlVmDevUsb_SetAutoconnectOption
PrlVmDevUsb_SetAutoconnectOption function
PrlVmGuest_GetNetworkSettings
PrlVmGuest_GetNetworkSettings function
PrlVmGuest_Logout
PrlVmGuest_Logout function
PrlVmGuest_RunProgram
PrlVmGuest_RunProgram function
PrlVmGuest_SetUserPasswd
PrlVmGuest_SetUserPasswd function
PrlVmInfo_GetAccessRights
PrlVmInfo_GetAccessRights function
PrlVmInfo_GetAdditionState
PrlVmInfo_GetAdditionState function
PrlVmInfo_GetState
PrlVmInfo_GetState function
PrlVmInfo_IsInvalid
PrlVmInfo_IsInvalid function
PrlVmInfo_IsInvalidEx
PrlVmInfo_IsInvalidEx function
PrlVmInfo_IsVmWaitingForAnswer
PrlVmInfo_IsVmWaitingForAnswer function
PrlVmInfo_IsVncServerStarted
PrlVmInfo_IsVncServerStarted function
PrlVmToolsInfo_GetState
PrlVmToolsInfo_GetState function
PrlVmToolsInfo_GetVersion
PrlVmToolsInfo_GetVersion function
PRN_LPT_DEVICE enumeration member
PRN_UNKNOWN_DEVICE enumeration member
PRN_USB_DEVICE enumeration member
PRNVM_ALLOW_TO_AUTO_DECREASE_HDD_SIZE enumeration member
PRNVM_CREATE_FROM_LION_RECOVERY_PARTITION enumeration member
PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY enumeration member
PRPM_RUN_PROGRAM_ENTER enumeration member
PRPM_RUN_PROGRAM_IN_SHELL enumeration member
PRR_BACKUP enumeration member
PRR_BOOT_CAMP enumeration member
PRR_CONNECTION enumeration member
PRR_HANG_LOCKUP enumeration member
PRR_KEYBOARD enumeration member
PRR_LAST enumeration member
PRR_MIGRATION enumeration member
PRR_NETWORK enumeration member
PRR_OTHER enumeration member
PRR_PARALLELS_TOOLS enumeration member
PRR_PERFORMANCE enumeration member
PRR_PRODUCT_REGISTRATION enumeration member
PRR_SNAPSHOTS enumeration member
PRR_SOUND enumeration member
PRR_SUPPORT_REQUEST enumeration member
PRR_UNKNOWN enumeration member
PRR_USB enumeration member
PRR_VIDEO_3D_GRAPHICS enumeration member
PRS_NEW_PACKED enumeration member
PRS_OLD_XML_BASED enumeration member
PRT_AUTOMATIC_DETECTED_REPORT enumeration member
PRT_AUTOMATIC_DISPATCHER_GENERATED_REPORT enumeration member
PRT_AUTOMATIC_GUEST_GENERATED_REPORT enumeration member
PRT_AUTOMATIC_INSTALLED_SOFTWARE_REPORT enumeration member
PRT_AUTOMATIC_STATISTICS_REPORT enumeration member
PRT_AUTOMATIC_TRANSPORTER_REPORT enumeration member
PRT_AUTOMATIC_UTW7AGENT_POST_MIGRATION enumeration member
PRT_AUTOMATIC_UTW7AGENT_PRE_MIGRATION enumeration member
PRT_AUTOMATIC_VM_GENERATED_REPORT enumeration member
PRT_AUTOMATIC_VZ_STATISTICS_REPORT enumeration member
PRT_LAST enumeration member
PRT_REPORT_TYPE_UNDEFINED enumeration member
PRT_USER_DEFINED_ON_CONNECTED_SERVER enumeration member
PRT_USER_DEFINED_ON_CONTAINER_REPORT enumeration member
PRT_USER_DEFINED_ON_DISCONNECTED_SERVER enumeration member
PRT_USER_DEFINED_ON_MOBILE_FEEDBACK_REPORT enumeration member
PRT_USER_DEFINED_ON_MOBILE_REPORT enumeration member
PRT_USER_DEFINED_ON_NOT_RESPONDING_VM_REPORT enumeration member
PRT_USER_DEFINED_ON_RUNNING_VM_REPORT enumeration member
PRT_USER_DEFINED_ON_STOPPED_VM_REPORT enumeration member
PRT_USER_DEFINED_TRANSPORTER_REPORT enumeration member
PRVF_IGNORE_HA_CLUSTER enumeration member
PRVF_KEEP_OTHERS_PERMISSIONS enumeration member
PRVF_REGENERATE_SRC_VM_UUID enumeration member
PRVF_REGENERATE_VM_UUID enumeration member
PSCT_AUTO enumeration member
PSCT_STEREO enumeration member
PSCT_SURROUND_5_1 enumeration member
PSE_DIRECTORY enumeration member
PSE_DRIVE enumeration member
PSE_FILE enumeration member
PSF_FORCE enumeration member
PSF_NOFORCE enumeration member
PSHF_DONT_WAIT_TO_COMPLETE enumeration member
PSHF_FORCE_SHUTDOWN enumeration member
PSHF_SUSPEND_VM_TO_PRAM enumeration member
PSIA_OPEN_DEFAULT enumeration member
PSIA_OPEN_IN_GUEST enumeration member
PSIA_OPEN_IN_HOST enumeration member
PSL_HIGH_SECURITY enumeration member
PSL_LOW_SECURITY enumeration member
PSL_NORMAL_SECURITY enumeration member
PSM_ACPI enumeration member
PSM_KILL enumeration member
PSM_LAST enumeration member
PSM_SHUTDOWN enumeration member
PSM_VM_SAFE_START enumeration member
PSM_VM_START enumeration member
PSM_VM_START_FOR_COMPACT enumeration member
PSM_VM_START_LAST_ITEM enumeration member
PSP_SERIAL_SOCKET_CLIENT enumeration member
PSP_SERIAL_SOCKET_SERVER enumeration member
PSPCF_CLEANUP_CREDS enumeration member
PSPCF_DO_NOT_CLEAN_CREDS enumeration member
PSPCF_REGISTER_HOST_ONLY enumeration member
PSPCF_REUSE_AVAILABLE_CREDS enumeration member
PSPCF_USE_DEPLOY_ID enumeration member
PSPCF_USE_FACEBOOK_TOKEN enumeration member
PSPCF_USE_GOOGLE_TOKEN enumeration member
PSPF_PASSWD_CRYPTED enumeration member
PSS_NOT_INSTALLED enumeration member
PSS_STARTED enumeration member
PSS_STOPPED enumeration member
PSS_UNKNOWN enumeration member
PSSF_SKIP_RESUME enumeration member
PST_VM_HIBERNATE enumeration member
PST_VM_REBOOT enumeration member
PST_VM_SHUTDOWN enumeration member
PST_VM_SUSPEND enumeration member
PSV_CALC_BOOT_CAMP_SIZE enumeration member
PSVM_AUTO enumeration member
PSVM_IGNORE_ASPECT_RATIO enumeration member
PSVM_KEEP_ASPECT_RATIO enumeration member
PSVM_KEEP_ASPECT_RATIO_BY_EXPANDING enumeration member
PSVM_OFF enumeration member
PTBS_DEFAULT enumeration member
PTBS_HIDE enumeration member
PTBS_SHOW enumeration member
PTBS_UNKNOWN enumeration member
PTIS_RECORD_ACTIVE enumeration member
PTIS_RECORD_CANCELED enumeration member
PTIS_RECORD_CLEARED enumeration member
PTIS_RECORD_DATA enumeration member
PTIS_RECORD_EMPTY enumeration member
PTIS_RECORD_FLAGS enumeration member
PTIS_RECORD_INFO enumeration member
PTIS_RECORD_NAME enumeration member
PTIS_RECORD_OWNER enumeration member
PTIS_RECORD_REMOVED enumeration member
PTIS_RECORD_STATE enumeration member
PTIS_RECORD_TEXT enumeration member
PTIS_RECORD_TIME enumeration member
PTIS_RECORD_UID enumeration member
PTS_ABSOLUTE_MOUSE enumeration member
PTS_INSTALLED enumeration member
PTS_MOVING_CURSOR enumeration member
PTS_NO_CURSOR enumeration member
PTS_NOT_INSTALLED enumeration member
PTS_OUTDATED enumeration member
PTS_POSSIBLY_INSTALLED enumeration member
PTS_RELATIVE_MOUSE enumeration member
PTS_SLIDING_CURSOR enumeration member
PTS_SLIDING_MOUSE enumeration member
PTS_UNKNOWN enumeration member
PTU_CMD_INVALID enumeration member
PTU_CMD_PTU_ALIVE enumeration member
PTU_FLG_ZERO enumeration member
PUD_ASK_USER_WHAT_TODO enumeration member
PUD_COMMIT_CHANGES enumeration member
PUD_CONNECT_TO_GUEST_OS enumeration member
PUD_CONNECT_TO_PRIMARY_OS enumeration member
PUD_CONNECTED_AUTOMATICALLY enumeration member
PUD_CONNECTED_MANUALLY enumeration member
PUD_DISABLE_UNDO_DISKS enumeration member
PUD_PROMPT_BEHAVIOUR enumeration member
PUD_REVERSE_CHANGES enumeration member
PUDT_APPLE_IETH enumeration member
PUDT_APPLE_IPAD enumeration member
PUDT_APPLE_IPHONE enumeration member
PUDT_APPLE_IPOD enumeration member
PUDT_ATAPI_STORAGE enumeration member
PUDT_AUDIO enumeration member
PUDT_BLUETOOTH enumeration member
PUDT_COMMUNICATION enumeration member
PUDT_DISK_STORAGE enumeration member
PUDT_FOTO enumeration member
PUDT_GARMIN_GPS enumeration member
PUDT_HUB enumeration member
PUDT_KEYBOARD enumeration member
PUDT_MOUSE enumeration member
PUDT_OTHER enumeration member
PUDT_PRINTER enumeration member
PUDT_RIM_BLACKBERRY enumeration member
PUDT_SCANNER enumeration member
PUDT_SMART_CARD enumeration member
PUDT_VIDEO enumeration member
PUDT_WIRELESS enumeration member
PUMHRT_IMAGE enumeration member
PUMHRT_TEXT enumeration member
PUPLF_ACTIVATE_PERMANENT_LICENSE_OFFLINE enumeration member
PUPLF_ACTIVATE_PERMANENT_LICENSE_ONLINE enumeration member
PUPLF_ACTIVATE_PRECACHED_KEY enumeration member
PUPLF_CHECK_KEY_ONLY enumeration member
PUPLF_CHECK_KEY_ONLY_VOLUME enumeration member
PUPLF_DEACTIVATE_CURRENT_LICENSE enumeration member
PUPLF_DEACTIVATE_CURRENT_LICENSE_OFFLINE_ALLOWED enumeration member
PUPLF_KICK_TO_UDPATE_CURR_FILE_LICENSE enumeration member
PUPLF_PROLONGATE_LICENSE enumeration member
PUPLF_REGISTER_CURRENT_LICENSE enumeration member
PUPLF_REMOVE_PRECACHED_KEY enumeration member
PUPLF_STORE_PRECACHED_KEY enumeration member
PVA_ACCELERATION_DISABLED enumeration member
PVA_ACCELERATION_HIGH enumeration member
PVA_ACCELERATION_NORMAL enumeration member
PVA_POSTSTART enumeration member
PVA_POSTSTOP enumeration member
PVA_PRESTART enumeration member
PVA_PRESTOP enumeration member
PVBT_CT_PLOOP enumeration member
PVBT_CT_VZFS enumeration member
PVBT_CT_VZWIN enumeration member
PVBT_VM enumeration member
PVC_ALL enumeration member
PVC_BOOT_OPTION enumeration member
PVC_CD_DVD_ROM enumeration member
PVC_COLOR_BLUE enumeration member
PVC_COLOR_GREEN enumeration member
PVC_COLOR_GREY enumeration member
PVC_COLOR_ORANGE enumeration member
PVC_COLOR_PURPLE enumeration member
PVC_COLOR_RED enumeration member
PVC_COLOR_YELLOW enumeration member
PVC_CPU enumeration member
PVC_FLOPPY_DISK enumeration member
PVC_GENERAL_PARAMETERS enumeration member
PVC_GENERIC_PCI enumeration member
PVC_HARD_DISK enumeration member
PVC_IDE_DEVICES enumeration member
PVC_LAST_SECTION enumeration member
PVC_LICENSE_RESTRICTIONS enumeration member
PVC_MAIN_MEMORY enumeration member
PVC_NETWORK_ADAPTER enumeration member
PVC_NO_COLOR enumeration member
PVC_OFFLINE_MANAGEMENT_SETTINGS enumeration member
PVC_PARALLEL_PORT enumeration member
PVC_REMOTE_DISPLAY enumeration member
PVC_SATA_DEVICES enumeration member
PVC_SCSI_DEVICES enumeration member
PVC_SERIAL_PORT enumeration member
PVC_SHARED_FOLDERS enumeration member
PVC_SOUND enumeration member
PVC_VALIDATE_CHANGES_ONLY enumeration member
PVC_VIDEO_MEMORY enumeration member
PVCF_DESTROY_HDD_BUNDLE enumeration member
PVCF_DESTROY_HDD_BUNDLE_FORCE enumeration member
PVCF_DETACH_HDD_BUNDLE enumeration member
PVCF_RENAME_EXT_DISKS enumeration member
PVCF_WAIT_FOR_APPLY enumeration member
PVL_FIREWIRE_DRIVE enumeration member
PVL_LOCAL_FS enumeration member
PVL_REMOTE_FS enumeration member
PVL_UNKNOWN enumeration member
PVL_USB_DRIVE enumeration member
PVM_DONT_RESUME_VM enumeration member
PVM_GET_SECURITY_LEVEL
PVM_GET_SECURITY_LEVEL macro
PVMSF_GUEST_OS_INFORMATION_ONLY enumeration member
PVMSF_HOST_DISK_SPACE_USAGE_ONLY enumeration member
PVMSL_HIGH_SECURITY enumeration member
PVMSL_LOW_SECURITY enumeration member
PVMSL_NORMAL_SECURITY enumeration member
PVMT_CHANGE_SID enumeration member
PVMT_CLONE_MODE enumeration member
PVMT_COLD_MIGRATION enumeration member
PVMT_DONT_RESUME_VM enumeration member
PVMT_HOT_MIGRATION enumeration member
PVMT_IGNORE_EXISTING_BUNDLE enumeration member
PVMT_REMOVE_SOURCE_BUNDLE enumeration member
PVMT_SWITCH_TEMPLATE enumeration member
PVMT_WARM_MIGRATION enumeration member
PVN_BRIDGED_ETHERNET enumeration member
PVN_HOST_ONLY enumeration member
PVR_PRIORITY_HIGH enumeration member
PVR_PRIORITY_LOW enumeration member
PVR_PRIORITY_NORMAL enumeration member
PVRCS_CONNECTED enumeration member
PVRCS_CONNECTING enumeration member
PVRCS_DISCONNECTED enumeration member
PVRCS_NO_CONNECTION enumeration member
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_NUMBER macro
PVS_GET_GUEST_TYPE
PVS_GET_GUEST_TYPE macro
PVS_GUEST Macros
PVS_GUEST_ARCH_I386
PVS_GUEST_ARCH_I386 macro
PVS_GUEST_ARCH_OTHER
PVS_GUEST_ARCH_OTHER macro
PVS_GUEST_ARCH_X86_64
PVS_GUEST_ARCH_X86_64 macro
PVS_GUEST_TYPE_ANDROID
PVS_GUEST_TYPE_ANDROID macro
PVS_GUEST_TYPE_CHROMEOS
PVS_GUEST_TYPE_CHROMEOS macro
PVS_GUEST_TYPE_FREEBSD
PVS_GUEST_TYPE_FREEBSD macro
PVS_GUEST_TYPE_LINUX
PVS_GUEST_TYPE_LINUX macro
PVS_GUEST_TYPE_MACOS
PVS_GUEST_TYPE_MACOS macro
PVS_GUEST_TYPE_MSDOS
PVS_GUEST_TYPE_MSDOS macro
PVS_GUEST_TYPE_NAME_ANDROID
PVS_GUEST_TYPE_NAME_ANDROID macro
PVS_GUEST_TYPE_NAME_CHROMEOS
PVS_GUEST_TYPE_NAME_CHROMEOS macro
PVS_GUEST_TYPE_NAME_FREEBSD
PVS_GUEST_TYPE_NAME_FREEBSD macro
PVS_GUEST_TYPE_NAME_LINUX
PVS_GUEST_TYPE_NAME_LINUX macro
PVS_GUEST_TYPE_NAME_MACOS
PVS_GUEST_TYPE_NAME_MACOS macro
PVS_GUEST_TYPE_NAME_MSDOS
PVS_GUEST_TYPE_NAME_MSDOS macro
PVS_GUEST_TYPE_NAME_NETWARE
PVS_GUEST_TYPE_NAME_NETWARE macro
PVS_GUEST_TYPE_NAME_OS2
PVS_GUEST_TYPE_NAME_OS2 macro
PVS_GUEST_TYPE_NAME_OTHER
PVS_GUEST_TYPE_NAME_OTHER macro
PVS_GUEST_TYPE_NAME_SOLARIS
PVS_GUEST_TYPE_NAME_SOLARIS macro
PVS_GUEST_TYPE_NAME_WINDOWS
PVS_GUEST_TYPE_NAME_WINDOWS macro
PVS_GUEST_TYPE_NETWARE
PVS_GUEST_TYPE_NETWARE macro
PVS_GUEST_TYPE_OS2
PVS_GUEST_TYPE_OS2 macro
PVS_GUEST_TYPE_OTHER
PVS_GUEST_TYPE_OTHER macro
PVS_GUEST_TYPE_SOLARIS
PVS_GUEST_TYPE_SOLARIS macro
PVS_GUEST_TYPE_WINDOWS
PVS_GUEST_TYPE_WINDOWS macro
PVS_GUEST_VER_ANDROID_2_x
PVS_GUEST_VER_ANDROID_2_x macro
PVS_GUEST_VER_ANDROID_3_x
PVS_GUEST_VER_ANDROID_3_x macro
PVS_GUEST_VER_ANDROID_4_0
PVS_GUEST_VER_ANDROID_4_0 macro
PVS_GUEST_VER_ANDROID_LAST
PVS_GUEST_VER_ANDROID_LAST macro
PVS_GUEST_VER_ANDROID_OTHER
PVS_GUEST_VER_ANDROID_OTHER macro
PVS_GUEST_VER_BSD_4X
PVS_GUEST_VER_BSD_4X macro
PVS_GUEST_VER_BSD_5X
PVS_GUEST_VER_BSD_5X macro
PVS_GUEST_VER_BSD_6X
PVS_GUEST_VER_BSD_6X macro
PVS_GUEST_VER_BSD_7X
PVS_GUEST_VER_BSD_7X macro
PVS_GUEST_VER_BSD_8X
PVS_GUEST_VER_BSD_8X macro
PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_LAST macro
PVS_GUEST_VER_BSD_OTHER
PVS_GUEST_VER_BSD_OTHER macro
PVS_GUEST_VER_CHROMEOS_1x
PVS_GUEST_VER_CHROMEOS_1x macro
PVS_GUEST_VER_CHROMEOS_LAST
PVS_GUEST_VER_CHROMEOS_LAST macro
PVS_GUEST_VER_CHROMEOS_OTHER
PVS_GUEST_VER_CHROMEOS_OTHER macro
PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_LAST macro
PVS_GUEST_VER_DOS_MS622
PVS_GUEST_VER_DOS_MS622 macro
PVS_GUEST_VER_DOS_OTHER
PVS_GUEST_VER_DOS_OTHER macro
PVS_GUEST_VER_FREE_BSD
PVS_GUEST_VER_FREE_BSD macro
PVS_GUEST_VER_LIN_CENTOS
PVS_GUEST_VER_LIN_CENTOS macro
PVS_GUEST_VER_LIN_CENTOS_7
PVS_GUEST_VER_LIN_CENTOS_7 macro
PVS_GUEST_VER_LIN_DEBIAN
PVS_GUEST_VER_LIN_DEBIAN macro
PVS_GUEST_VER_LIN_FEDORA
PVS_GUEST_VER_LIN_FEDORA macro
PVS_GUEST_VER_LIN_FEDORA_5
PVS_GUEST_VER_LIN_FEDORA_5 macro
PVS_GUEST_VER_LIN_KRNL_24
PVS_GUEST_VER_LIN_KRNL_24 macro
PVS_GUEST_VER_LIN_KRNL_26
PVS_GUEST_VER_LIN_KRNL_26 macro
PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_LAST macro
PVS_GUEST_VER_LIN_MAGEIA
PVS_GUEST_VER_LIN_MAGEIA macro
PVS_GUEST_VER_LIN_MANDRAKE
PVS_GUEST_VER_LIN_MANDRAKE macro
PVS_GUEST_VER_LIN_MINT
PVS_GUEST_VER_LIN_MINT macro
PVS_GUEST_VER_LIN_OPENSUSE
PVS_GUEST_VER_LIN_OPENSUSE macro
PVS_GUEST_VER_LIN_OTHER
PVS_GUEST_VER_LIN_OTHER macro
PVS_GUEST_VER_LIN_PSBM
PVS_GUEST_VER_LIN_PSBM macro
PVS_GUEST_VER_LIN_REDHAT
PVS_GUEST_VER_LIN_REDHAT macro
PVS_GUEST_VER_LIN_REDHAT_7
PVS_GUEST_VER_LIN_REDHAT_7 macro
PVS_GUEST_VER_LIN_RH_LEGACY
PVS_GUEST_VER_LIN_RH_LEGACY macro
PVS_GUEST_VER_LIN_RHLES3
PVS_GUEST_VER_LIN_RHLES3 macro
PVS_GUEST_VER_LIN_SLES9
PVS_GUEST_VER_LIN_SLES9 macro
PVS_GUEST_VER_LIN_SUSE
PVS_GUEST_VER_LIN_SUSE macro
PVS_GUEST_VER_LIN_UBUNTU
PVS_GUEST_VER_LIN_UBUNTU macro
PVS_GUEST_VER_LIN_XANDROS
PVS_GUEST_VER_LIN_XANDROS macro
PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LAST macro
PVS_GUEST_VER_MACOS_LEOPARD
PVS_GUEST_VER_MACOS_LEOPARD macro
PVS_GUEST_VER_MACOS_SNOW_LEOPARD
PVS_GUEST_VER_MACOS_SNOW_LEOPARD macro
PVS_GUEST_VER_MACOS_TIGER
PVS_GUEST_VER_MACOS_TIGER macro
PVS_GUEST_VER_MACOS_UNIVERSAL
PVS_GUEST_VER_MACOS_UNIVERSAL macro
PVS_GUEST_VER_NAME_ANDROID_4_0
PVS_GUEST_VER_NAME_ANDROID_4_0 macro
PVS_GUEST_VER_NAME_ANDROID_OTHER
PVS_GUEST_VER_NAME_ANDROID_OTHER macro
PVS_GUEST_VER_NAME_BSD_4X
PVS_GUEST_VER_NAME_BSD_4X macro
PVS_GUEST_VER_NAME_BSD_5X
PVS_GUEST_VER_NAME_BSD_5X macro
PVS_GUEST_VER_NAME_BSD_6X
PVS_GUEST_VER_NAME_BSD_6X macro
PVS_GUEST_VER_NAME_BSD_7X
PVS_GUEST_VER_NAME_BSD_7X macro
PVS_GUEST_VER_NAME_BSD_8X
PVS_GUEST_VER_NAME_BSD_8X macro
PVS_GUEST_VER_NAME_BSD_OTHER
PVS_GUEST_VER_NAME_BSD_OTHER macro
PVS_GUEST_VER_NAME_CHROMEOS_1x
PVS_GUEST_VER_NAME_CHROMEOS_1x macro
PVS_GUEST_VER_NAME_CHROMEOS_OTHER
PVS_GUEST_VER_NAME_CHROMEOS_OTHER macro
PVS_GUEST_VER_NAME_DOS_MS622
PVS_GUEST_VER_NAME_DOS_MS622 macro
PVS_GUEST_VER_NAME_DOS_OTHER
PVS_GUEST_VER_NAME_DOS_OTHER macro
PVS_GUEST_VER_NAME_FREE_BSD
PVS_GUEST_VER_NAME_FREE_BSD macro
PVS_GUEST_VER_NAME_LIN_CENTOS
PVS_GUEST_VER_NAME_LIN_CENTOS macro
PVS_GUEST_VER_NAME_LIN_DEBIAN
PVS_GUEST_VER_NAME_LIN_DEBIAN macro
PVS_GUEST_VER_NAME_LIN_FEDORA
PVS_GUEST_VER_NAME_LIN_FEDORA macro
PVS_GUEST_VER_NAME_LIN_FEDORA_5
PVS_GUEST_VER_NAME_LIN_FEDORA_5 macro
PVS_GUEST_VER_NAME_LIN_KRNL_24
PVS_GUEST_VER_NAME_LIN_KRNL_24 macro
PVS_GUEST_VER_NAME_LIN_KRNL_26
PVS_GUEST_VER_NAME_LIN_KRNL_26 macro
PVS_GUEST_VER_NAME_LIN_MAGEIA
PVS_GUEST_VER_NAME_LIN_MAGEIA macro
PVS_GUEST_VER_NAME_LIN_MANDRAKE
PVS_GUEST_VER_NAME_LIN_MANDRAKE macro
PVS_GUEST_VER_NAME_LIN_MINT
PVS_GUEST_VER_NAME_LIN_MINT macro
PVS_GUEST_VER_NAME_LIN_OPENSUSE
PVS_GUEST_VER_NAME_LIN_OPENSUSE macro
PVS_GUEST_VER_NAME_LIN_OTHER
PVS_GUEST_VER_NAME_LIN_OTHER macro
PVS_GUEST_VER_NAME_LIN_PSBM
PVS_GUEST_VER_NAME_LIN_PSBM macro
PVS_GUEST_VER_NAME_LIN_REDHAT
PVS_GUEST_VER_NAME_LIN_REDHAT macro
PVS_GUEST_VER_NAME_LIN_RH_LEGACY
PVS_GUEST_VER_NAME_LIN_RH_LEGACY macro
PVS_GUEST_VER_NAME_LIN_RHLES3
PVS_GUEST_VER_NAME_LIN_RHLES3 macro
PVS_GUEST_VER_NAME_LIN_SLES9
PVS_GUEST_VER_NAME_LIN_SLES9 macro
PVS_GUEST_VER_NAME_LIN_SUSE
PVS_GUEST_VER_NAME_LIN_SUSE macro
PVS_GUEST_VER_NAME_LIN_UBUNTU
PVS_GUEST_VER_NAME_LIN_UBUNTU macro
PVS_GUEST_VER_NAME_LIN_XANDROS
PVS_GUEST_VER_NAME_LIN_XANDROS macro
PVS_GUEST_VER_NAME_MACOS_LEOPARD
PVS_GUEST_VER_NAME_MACOS_LEOPARD macro
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD macro
PVS_GUEST_VER_NAME_MACOS_TIGER
PVS_GUEST_VER_NAME_MACOS_TIGER macro
PVS_GUEST_VER_NAME_NET_4X
PVS_GUEST_VER_NAME_NET_4X macro
PVS_GUEST_VER_NAME_NET_5X
PVS_GUEST_VER_NAME_NET_5X macro
PVS_GUEST_VER_NAME_NET_6X
PVS_GUEST_VER_NAME_NET_6X macro
PVS_GUEST_VER_NAME_NET_BSD
PVS_GUEST_VER_NAME_NET_BSD macro
PVS_GUEST_VER_NAME_NET_OTHER
PVS_GUEST_VER_NAME_NET_OTHER macro
PVS_GUEST_VER_NAME_OPEN_BSD
PVS_GUEST_VER_NAME_OPEN_BSD macro
PVS_GUEST_VER_NAME_OS2_ECS11
PVS_GUEST_VER_NAME_OS2_ECS11 macro
PVS_GUEST_VER_NAME_OS2_ECS12
PVS_GUEST_VER_NAME_OS2_ECS12 macro
PVS_GUEST_VER_NAME_OS2_OTHER
PVS_GUEST_VER_NAME_OS2_OTHER macro
PVS_GUEST_VER_NAME_OS2_WARP3
PVS_GUEST_VER_NAME_OS2_WARP3 macro
PVS_GUEST_VER_NAME_OS2_WARP4
PVS_GUEST_VER_NAME_OS2_WARP4 macro
PVS_GUEST_VER_NAME_OS2_WARP45
PVS_GUEST_VER_NAME_OS2_WARP45 macro
PVS_GUEST_VER_NAME_OTH_OPENSTEP
PVS_GUEST_VER_NAME_OTH_OPENSTEP macro
PVS_GUEST_VER_NAME_OTH_OTHER
PVS_GUEST_VER_NAME_OTH_OTHER macro
PVS_GUEST_VER_NAME_OTH_QNX
PVS_GUEST_VER_NAME_OTH_QNX macro
PVS_GUEST_VER_NAME_SOL_10
PVS_GUEST_VER_NAME_SOL_10 macro
PVS_GUEST_VER_NAME_SOL_11
PVS_GUEST_VER_NAME_SOL_11 macro
PVS_GUEST_VER_NAME_SOL_9
PVS_GUEST_VER_NAME_SOL_9 macro
PVS_GUEST_VER_NAME_SOL_OPEN
PVS_GUEST_VER_NAME_SOL_OPEN macro
PVS_GUEST_VER_NAME_SOL_OTHER
PVS_GUEST_VER_NAME_SOL_OTHER macro
PVS_GUEST_VER_NAME_TRUSTED_BSD
PVS_GUEST_VER_NAME_TRUSTED_BSD macro
PVS_GUEST_VER_NAME_WIN_2003
PVS_GUEST_VER_NAME_WIN_2003 macro
PVS_GUEST_VER_NAME_WIN_2008
PVS_GUEST_VER_NAME_WIN_2008 macro
PVS_GUEST_VER_NAME_WIN_2012
PVS_GUEST_VER_NAME_WIN_2012 macro
PVS_GUEST_VER_NAME_WIN_2K
PVS_GUEST_VER_NAME_WIN_2K macro
PVS_GUEST_VER_NAME_WIN_311
PVS_GUEST_VER_NAME_WIN_311 macro
PVS_GUEST_VER_NAME_WIN_95
PVS_GUEST_VER_NAME_WIN_95 macro
PVS_GUEST_VER_NAME_WIN_98
PVS_GUEST_VER_NAME_WIN_98 macro
PVS_GUEST_VER_NAME_WIN_ME
PVS_GUEST_VER_NAME_WIN_ME macro
PVS_GUEST_VER_NAME_WIN_NT
PVS_GUEST_VER_NAME_WIN_NT macro
PVS_GUEST_VER_NAME_WIN_OTHER
PVS_GUEST_VER_NAME_WIN_OTHER macro
PVS_GUEST_VER_NAME_WIN_VISTA
PVS_GUEST_VER_NAME_WIN_VISTA macro
PVS_GUEST_VER_NAME_WIN_WINDOWS_10
PVS_GUEST_VER_NAME_WIN_WINDOWS_10 macro
PVS_GUEST_VER_NAME_WIN_WINDOWS7
PVS_GUEST_VER_NAME_WIN_WINDOWS7 macro
PVS_GUEST_VER_NAME_WIN_WINDOWS8
PVS_GUEST_VER_NAME_WIN_WINDOWS8 macro
PVS_GUEST_VER_NAME_WIN_WINDOWS8_1
PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 macro
PVS_GUEST_VER_NAME_WIN_XP
PVS_GUEST_VER_NAME_WIN_XP macro
PVS_GUEST_VER_NET_4X
PVS_GUEST_VER_NET_4X macro
PVS_GUEST_VER_NET_5X
PVS_GUEST_VER_NET_5X macro
PVS_GUEST_VER_NET_6X
PVS_GUEST_VER_NET_6X macro
PVS_GUEST_VER_NET_BSD
PVS_GUEST_VER_NET_BSD macro
PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_LAST macro
PVS_GUEST_VER_NET_OTHER
PVS_GUEST_VER_NET_OTHER macro
PVS_GUEST_VER_OPEN_BSD
PVS_GUEST_VER_OPEN_BSD macro
PVS_GUEST_VER_OS2_ECS11
PVS_GUEST_VER_OS2_ECS11 macro
PVS_GUEST_VER_OS2_ECS12
PVS_GUEST_VER_OS2_ECS12 macro
PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_LAST macro
PVS_GUEST_VER_OS2_OTHER
PVS_GUEST_VER_OS2_OTHER macro
PVS_GUEST_VER_OS2_WARP3
PVS_GUEST_VER_OS2_WARP3 macro
PVS_GUEST_VER_OS2_WARP4
PVS_GUEST_VER_OS2_WARP4 macro
PVS_GUEST_VER_OS2_WARP45
PVS_GUEST_VER_OS2_WARP45 macro
PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_LAST macro
PVS_GUEST_VER_OTH_OPENSTEP
PVS_GUEST_VER_OTH_OPENSTEP macro
PVS_GUEST_VER_OTH_OTHER
PVS_GUEST_VER_OTH_OTHER macro
PVS_GUEST_VER_OTH_QNX
PVS_GUEST_VER_OTH_QNX macro
PVS_GUEST_VER_SOL_10
PVS_GUEST_VER_SOL_10 macro
PVS_GUEST_VER_SOL_11
PVS_GUEST_VER_SOL_11 macro
PVS_GUEST_VER_SOL_9
PVS_GUEST_VER_SOL_9 macro
PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_LAST macro
PVS_GUEST_VER_SOL_OPEN
PVS_GUEST_VER_SOL_OPEN macro
PVS_GUEST_VER_SOL_OTHER
PVS_GUEST_VER_SOL_OTHER macro
PVS_GUEST_VER_TRUSTED_BSD
PVS_GUEST_VER_TRUSTED_BSD macro
PVS_GUEST_VER_WIN_2003
PVS_GUEST_VER_WIN_2003 macro
PVS_GUEST_VER_WIN_2008
PVS_GUEST_VER_WIN_2008 macro
PVS_GUEST_VER_WIN_2012
PVS_GUEST_VER_WIN_2012 macro
PVS_GUEST_VER_WIN_2K
PVS_GUEST_VER_WIN_2K macro
PVS_GUEST_VER_WIN_311
PVS_GUEST_VER_WIN_311 macro
PVS_GUEST_VER_WIN_95
PVS_GUEST_VER_WIN_95 macro
PVS_GUEST_VER_WIN_98
PVS_GUEST_VER_WIN_98 macro
PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_LAST macro
PVS_GUEST_VER_WIN_ME
PVS_GUEST_VER_WIN_ME macro
PVS_GUEST_VER_WIN_NT
PVS_GUEST_VER_WIN_NT macro
PVS_GUEST_VER_WIN_OTHER
PVS_GUEST_VER_WIN_OTHER macro
PVS_GUEST_VER_WIN_VISTA
PVS_GUEST_VER_WIN_VISTA macro
PVS_GUEST_VER_WIN_WINDOWS_10
PVS_GUEST_VER_WIN_WINDOWS_10 macro
PVS_GUEST_VER_WIN_WINDOWS7
PVS_GUEST_VER_WIN_WINDOWS7 macro
PVS_GUEST_VER_WIN_WINDOWS8
PVS_GUEST_VER_WIN_WINDOWS8 macro
PVS_GUEST_VER_WIN_WINDOWS8_1
PVS_GUEST_VER_WIN_WINDOWS8_1 macro
PVS_GUEST_VER_WIN_XP
PVS_GUEST_VER_WIN_XP macro
PVS_MAKE_GUEST_VER
PVS_MAKE_GUEST_VER macro
PVSC_ACPI_ERROR enumeration member
PVSC_DMAR_ERROR enumeration member
PVSC_DMAR_NOT_FOUND enumeration member
PVSC_ENABLED enumeration member
PVSC_HARDWARE_ERROR enumeration member
PVSC_INTERNAL_ERROR enumeration member
PVSC_NOT_PRESENT enumeration member
PVSS_CUSTOM enumeration member
PVSS_OPTIMIZED_FOR_TIME_MACHINE enumeration member
PVT_CT enumeration member
PVT_VM enumeration member
PVTF_CT enumeration member
PVTF_VM enumeration member
PWC_BOTTOM_LEFT_CORNER enumeration member
PWC_BOTTOM_RIGHT_CORNER enumeration member
PWC_TOP_LEFT_CORNER enumeration member
PWC_TOP_RIGHT_CORNER enumeration member
PWC_VM_ASK_USER enumeration member
PWC_VM_DO_NOTHING enumeration member
PWC_VM_PAUSE enumeration member
PWC_VM_SHUTDOWN enumeration member
PWC_VM_STOP enumeration member
PWC_VM_SUSPEND enumeration member
PWC_VM_UNKNOWN_ACTION enumeration member
PWM_COHERENCE_WINDOW_MODE enumeration member
PWM_DEFAULT_WINDOW_MODE enumeration member
PWM_FULL_SCREEN_WINDOW_MODE enumeration member
PWM_MODALITY_WINDOW_MODE enumeration member
PWM_WINDOWED_WINDOW_MODE enumeration member
R
Remote Desktop Access
RTT_RUNNING_TASK_CLONE_VM enumeration member
RTT_RUNNING_TASK_COPY_IMAGE enumeration member
RTT_RUNNING_TASK_CREATE_IMAGE enumeration member
RTT_RUNNING_TASK_CREATE_VM enumeration member
RTT_RUNNING_TASK_DELETE_VM enumeration member
RTT_RUNNING_TASK_MIGRATE_VM enumeration member
RTT_RUNNING_TASK_REGISTER_VM enumeration member
RTT_RUNNING_TASK_RESTORE_VM enumeration member
RTT_RUNNING_TASK_UNKNOWN enumeration member
RTT_RUNNING_TASK_UNREG_VM enumeration member
S
Secondary Display Capture
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_DISABLED macro
SET_FS_EXECUTE_ENABLED
SET_FS_EXECUTE_ENABLED macro
SET_FS_READ_DISABLED
SET_FS_READ_DISABLED macro
SET_FS_READ_ENABLED
SET_FS_READ_ENABLED macro
SET_FS_WRITE_DISABLED
SET_FS_WRITE_DISABLED macro
SET_FS_WRITE_ENABLED
SET_FS_WRITE_ENABLED macro
Structs, Records, Enums
System Functions
T
TEV_CONNECTED enumeration member
TEV_DATA_RECEIVED enumeration member
TEV_DISCONNECTED enumeration member
Types
U
Unknown or Unneeded
V
Virtual Device Functions
VIRTUAL_MACHINE_ADDITION_STATE
VIRTUAL_MACHINE_ADDITION_STATE enumeration
VIRTUAL_MACHINE_ADDITION_STATE_PTR
VIRTUAL_MACHINE_ADDITION_STATE_PTR type
VIRTUAL_MACHINE_STATE
VIRTUAL_MACHINE_STATE enumeration
VIRTUAL_MACHINE_STATE_PTR
VIRTUAL_MACHINE_STATE_PTR type
VMAS_BACKUPING enumeration member
VMAS_CLONING enumeration member
VMAS_DECRYPTING enumeration member
VMAS_ENCRYPTING enumeration member
VMAS_MAX enumeration member
VMAS_MOVING enumeration member
VMAS_NOSTATE enumeration member
VMAS_RESTORING_FROM_BACKUP enumeration member
VMP_DESIGNER enumeration member
VMP_GAMES enumeration member
VMP_PRODUCTIVITY enumeration member
VMP_SOFTWARE_DEVELOPER enumeration member
VMS_COMPACTING enumeration member
VMS_CONTINUING enumeration member
VMS_DELETING_STATE enumeration member
VMS_MIGRATING enumeration member
VMS_MOUNTED enumeration member
VMS_PAUSED enumeration member
VMS_PAUSING enumeration member
VMS_RECONNECTING enumeration member
VMS_RESETTING enumeration member
VMS_RESTORING enumeration member
VMS_RESUMING enumeration member
VMS_RUNNING enumeration member
VMS_SNAPSHOTING enumeration member
VMS_STARTING enumeration member
VMS_STOPPED enumeration member
VMS_STOPPING enumeration member
VMS_SUSPENDED enumeration member
VMS_SUSPENDING enumeration member
VMS_SUSPENDING_SYNC enumeration member
VMS_UNKNOWN enumeration member
W
WINDOW_ALL_EDGE_MASK enumeration member
WINDOW_BOTTOM_EDGE_MASK enumeration member
WINDOW_LEFT_EDGE_MASK enumeration member
WINDOW_RIGHT_EDGE_MASK enumeration member
WINDOW_TOP_EDGE_MASK enumeration member


About This Guide

About This Guide

This document is a part of the Parallels Virtualization SDK. It contains the Parallels C API reference including information about handles (classes), functions, types, structures, enumerations, and other technical information.

Please note that this document does not provide general information on how to use the Parallels Virtualization SDK. For the detailed explanation of how to start using the SDK and how to create your own programs using the provided APIs, please read the Parallels Virtualization SDK Programmer's Guide, which is a companion book to this one.

To understand the material provided in this guide, you should have a basic knowledge of the ANSI C programming language and some experience working with application programming interfaces (API) written in C.


IPluginInfoPtr Type

IPluginInfoPtr Type
Other Types
Syntax
typedef IPluginInfo* IPluginInfoPtr;
File

PrlPluginClasses.h

Links
Other Types


IS_ANDROID Macro

IS_ANDROID Macro
Other Macros
Syntax
#define IS_ANDROID(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_ANDROID))
File

PrlOses.h

Links
Other Macros


IS_CHROMEOS Macro

IS_CHROMEOS Macro
Other Macros
Syntax
#define IS_CHROMEOS(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_CHROMEOS))
File

PrlOses.h

Links
Other Macros


IS_FREEBSD Macro

IS_FREEBSD Macro
Other Macros
Syntax
#define IS_FREEBSD(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_FREEBSD))
File

PrlOses.h

Links
Other Macros


IS_FS_EXECUTE_PERMITTED Macro

IS_FS_EXECUTE_PERMITTED Macro
Other Macros
Syntax
#define IS_FS_EXECUTE_PERMITTED(x) ( (x) & FS_PERM_EXECUTE ?1:0 )
File

PrlFs.h

Links
Other Macros


IS_FS_READ_PERMITTED Macro

IS_FS_READ_PERMITTED Macro
Other Macros
Syntax
#define IS_FS_READ_PERMITTED(x) ( (x) & FS_PERM_READ ?1:0 )
File

PrlFs.h

Links
Other Macros


IS_FS_WRITE_PERMITTED Macro

IS_FS_WRITE_PERMITTED Macro
Other Macros
Syntax
#define IS_FS_WRITE_PERMITTED(x) ( (x) & FS_PERM_WRITE ?1:0 )
File

PrlFs.h

Links
Other Macros


IS_LINUX Macro

IS_LINUX Macro
Other Macros
Syntax
#define IS_LINUX(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_LINUX) ||    \
                                 IS_CHROMEOS(x) || IS_ANDROID(x))
File

PrlOses.h

Links
Other Macros


IS_MACOS Macro

IS_MACOS Macro
Other Macros
Syntax
#define IS_MACOS(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_MACOS))
File

PrlOses.h

Links
Other Macros


IS_MSDOS Macro

IS_MSDOS Macro
Other Macros
Syntax
#define IS_MSDOS(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_MSDOS))
File

PrlOses.h

Links
Other Macros


IS_NETWARE Macro

IS_NETWARE Macro
Other Macros
Syntax
#define IS_NETWARE(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_NETWARE))
File

PrlOses.h

Links
Other Macros


IS_OS2 Macro

IS_OS2 Macro
Other Macros
Syntax
#define IS_OS2(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_OS2))
File

PrlOses.h

Links
Other Macros


IS_OTHER Macro

IS_OTHER Macro
Other Macros
Syntax
#define IS_OTHER(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_OTHER))
File

PrlOses.h

Links
Other Macros


IS_SOLARIS Macro

IS_SOLARIS Macro
Other Macros
Syntax
#define IS_SOLARIS(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_SOLARIS))
File

PrlOses.h

Links
Other Macros


IS_VALID_ANDROID_VERSION Macro

IS_VALID_ANDROID_VERSION Macro
Other Macros
Syntax
#define IS_VALID_ANDROID_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_ANDROID_2_x &&                            \
      (ver) <= PVS_GUEST_VER_ANDROID_LAST) ||                        \
      (ver) == PVS_GUEST_VER_ANDROID_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_CHROMEOS_VERSION Macro

IS_VALID_CHROMEOS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_CHROMEOS_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_CHROMEOS_1x &&                            \
      (ver) <= PVS_GUEST_VER_CHROMEOS_LAST) ||                        \
      (ver) == PVS_GUEST_VER_CHROMEOS_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_FREEBSD_VERSION Macro

IS_VALID_FREEBSD_VERSION Macro
Other Macros
Syntax
#define IS_VALID_FREEBSD_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_BSD_4X && (ver) <= PVS_GUEST_VER_BSD_LAST) ||    \
     (ver) == PVS_GUEST_VER_BSD_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_LINUX_VERSION Macro

IS_VALID_LINUX_VERSION Macro
Other Macros
Syntax
#define IS_VALID_LINUX_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_LIN_REDHAT && (ver) <= PVS_GUEST_VER_LIN_LAST) ||\
     (ver) == PVS_GUEST_VER_LIN_OTHER || IS_VALID_CHROMEOS_VERSION(ver) ||\
     IS_VALID_ANDROID_VERSION(ver))
File

PrlOses.h

Links
Other Macros


IS_VALID_MACOS_VERSION Macro

IS_VALID_MACOS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_MACOS_VERSION(ver) \
    ((ver) >= PVS_GUEST_VER_MACOS_TIGER && (ver) <= PVS_GUEST_VER_MACOS_LAST)
File

PrlOses.h

Links
Other Macros


IS_VALID_MSDOS_VERSION Macro

IS_VALID_MSDOS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_MSDOS_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_DOS_MS622 && (ver) <= PVS_GUEST_VER_DOS_LAST)||\
     (ver) == PVS_GUEST_VER_DOS_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_NETWARE_VERSION Macro

IS_VALID_NETWARE_VERSION Macro
Other Macros
Syntax
#define IS_VALID_NETWARE_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_NET_4X && (ver) <= PVS_GUEST_VER_NET_LAST) ||    \
     (ver) == PVS_GUEST_VER_NET_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_OS2_VERSION Macro

IS_VALID_OS2_VERSION Macro
Other Macros
Syntax
#define IS_VALID_OS2_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_OS2_WARP3 && (ver) <= PVS_GUEST_VER_OS2_LAST)||\
     (ver) == PVS_GUEST_VER_OS2_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_OTHER_OS_VERSION Macro

IS_VALID_OTHER_OS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_OTHER_OS_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_OTH_QNX && (ver) <= PVS_GUEST_VER_OTH_LAST) ||    \
     (ver) == PVS_GUEST_VER_OTH_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_SOLARIS_VERSION Macro

IS_VALID_SOLARIS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_SOLARIS_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_SOL_9 && (ver) <= PVS_GUEST_VER_SOL_LAST) ||    \
     (ver) == PVS_GUEST_VER_SOL_OTHER)
File

PrlOses.h

Links
Other Macros


IS_VALID_WINDOWS_VERSION Macro

IS_VALID_WINDOWS_VERSION Macro
Other Macros
Syntax
#define IS_VALID_WINDOWS_VERSION(ver) \
    (((ver) >= PVS_GUEST_VER_WIN_311 && (ver) <= PVS_GUEST_VER_WIN_LAST) ||    \
     (ver) == PVS_GUEST_VER_WIN_OTHER)
File

PrlOses.h

Links
Other Macros


IS_WIN_VER_BELOW Macro

IS_WIN_VER_BELOW Macro
Other Macros

PVS_GUEST_VER_WIN_OTHER is used for legacy guest OS (9x and below), but has maximal number 0xFF.

Syntax
#define IS_WIN_VER_BELOW(ver1, ver2) ((ver1 < ver2) || (ver1 == PVS_GUEST_VER_WIN_OTHER))
File

PrlOses.h

Links
Other Macros


IS_WINDOWS Macro

IS_WINDOWS Macro
Other Macros
Syntax
#define IS_WINDOWS(x) (!(((x) >> 8) ^ PVS_GUEST_TYPE_WINDOWS))
File

PrlOses.h

Links
Other Macros


PET_ANSWER_APPEND Macro

PET_ANSWER_APPEND Macro
PET Macros
Syntax
#define PET_ANSWER_APPEND PRL_RESULT_DECLARE_SUCCESS(16011)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_BREAK Macro

PET_ANSWER_BREAK Macro
PET Macros
Syntax
#define PET_ANSWER_BREAK PRL_RESULT_DECLARE_SUCCESS(16004)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_BROWSE Macro

PET_ANSWER_BROWSE Macro
PET Macros
Syntax
#define PET_ANSWER_BROWSE PRL_RESULT_DECLARE_SUCCESS(16028)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_CANCEL Macro

PET_ANSWER_CANCEL Macro
PET Macros
Syntax
#define PET_ANSWER_CANCEL PRL_RESULT_DECLARE_SUCCESS(16001)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_CHANGE Macro

PET_ANSWER_CHANGE Macro
PET Macros
Syntax
#define PET_ANSWER_CHANGE PRL_RESULT_DECLARE_SUCCESS(16032)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_COMMIT Macro

PET_ANSWER_COMMIT Macro
PET Macros
Syntax
#define PET_ANSWER_COMMIT PRL_RESULT_DECLARE_SUCCESS(16016)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_COMPACT Macro

PET_ANSWER_COMPACT Macro
PET Macros
Syntax
#define PET_ANSWER_COMPACT PRL_RESULT_DECLARE_SUCCESS(16024)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_CONTINUE Macro

PET_ANSWER_CONTINUE Macro
PET Macros
Syntax
#define PET_ANSWER_CONTINUE PRL_RESULT_DECLARE_SUCCESS(16008)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_COPIED Macro

PET_ANSWER_COPIED Macro
PET Macros
Syntax
#define PET_ANSWER_COPIED PRL_RESULT_DECLARE_SUCCESS(16013)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_CREATE Macro

PET_ANSWER_CREATE Macro
PET Macros
Syntax
#define PET_ANSWER_CREATE PRL_RESULT_DECLARE_SUCCESS(16019)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_CREATE_NEW Macro

PET_ANSWER_CREATE_NEW Macro
PET Macros
Syntax
#define PET_ANSWER_CREATE_NEW PRL_RESULT_DECLARE_SUCCESS(16009)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_DISCONNECT_ANYWAY Macro

PET_ANSWER_DISCONNECT_ANYWAY Macro
PET Macros
Syntax
#define PET_ANSWER_DISCONNECT_ANYWAY PRL_RESULT_DECLARE_SUCCESS(16018)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_DONT_CHANGE Macro

PET_ANSWER_DONT_CHANGE Macro
PET Macros
Syntax
#define PET_ANSWER_DONT_CHANGE PRL_RESULT_DECLARE_SUCCESS(16033)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_LATER Macro

PET_ANSWER_LATER Macro
PET Macros
Syntax
#define PET_ANSWER_LATER PRL_RESULT_DECLARE_SUCCESS(16023)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_MOVED Macro

PET_ANSWER_MOVED Macro
PET Macros
Syntax
#define PET_ANSWER_MOVED PRL_RESULT_DECLARE_SUCCESS(16014)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_NO Macro

PET_ANSWER_NO Macro
PET Macros
Syntax
#define PET_ANSWER_NO PRL_RESULT_DECLARE_SUCCESS(16003)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_OK Macro

PET_ANSWER_OK Macro
PET Macros
  • Answers

+++ ALIGNED VALUE TO 16000

Syntax
#define PET_ANSWER_OK PRL_RESULT_DECLARE_SUCCESS(16000)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_OVERIDE Macro

PET_ANSWER_OVERIDE Macro
PET Macros
Syntax
#define PET_ANSWER_OVERIDE PRL_RESULT_DECLARE_SUCCESS(16005)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_REPLACE Macro

PET_ANSWER_REPLACE Macro
PET Macros
Syntax
#define PET_ANSWER_REPLACE PRL_RESULT_DECLARE_SUCCESS(16012)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_RESTART Macro

PET_ANSWER_RESTART Macro
PET Macros
Syntax
#define PET_ANSWER_RESTART PRL_RESULT_DECLARE_SUCCESS(16030)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_RESTART_NOW Macro

PET_ANSWER_RESTART_NOW Macro
PET Macros
Syntax
#define PET_ANSWER_RESTART_NOW PRL_RESULT_DECLARE_SUCCESS(16022)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_RESTORE Macro

PET_ANSWER_RESTORE Macro
PET Macros
Syntax
#define PET_ANSWER_RESTORE PRL_RESULT_DECLARE_SUCCESS(16027)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_RESUME Macro

PET_ANSWER_RESUME Macro
PET Macros
Syntax
#define PET_ANSWER_RESUME PRL_RESULT_DECLARE_SUCCESS(16031)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_RETRY Macro

PET_ANSWER_RETRY Macro
PET Macros
Syntax
#define PET_ANSWER_RETRY PRL_RESULT_DECLARE_SUCCESS(16029)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_REVERT Macro

PET_ANSWER_REVERT Macro
PET Macros
Syntax
#define PET_ANSWER_REVERT PRL_RESULT_DECLARE_SUCCESS(16017)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_SET_RECOMMENDED Macro

PET_ANSWER_SET_RECOMMENDED Macro
PET Macros
Syntax
#define PET_ANSWER_SET_RECOMMENDED PRL_RESULT_DECLARE_SUCCESS(16035)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_SHUTDOWN Macro

PET_ANSWER_SHUTDOWN Macro
PET Macros
Syntax
#define PET_ANSWER_SHUTDOWN PRL_RESULT_DECLARE_SUCCESS(16006)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_SKIP Macro

PET_ANSWER_SKIP Macro
PET Macros
Syntax
#define PET_ANSWER_SKIP PRL_RESULT_DECLARE_SUCCESS(16020)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_STARTVM Macro

PET_ANSWER_STARTVM Macro
PET Macros
Syntax
#define PET_ANSWER_STARTVM PRL_RESULT_DECLARE_SUCCESS(16015)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_STOP Macro

PET_ANSWER_STOP Macro
PET Macros
Syntax
#define PET_ANSWER_STOP PRL_RESULT_DECLARE_SUCCESS(16007)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_STOP_AND_RESTORE Macro

PET_ANSWER_STOP_AND_RESTORE Macro
PET Macros
Syntax
#define PET_ANSWER_STOP_AND_RESTORE PRL_RESULT_DECLARE_SUCCESS(16026)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_SUSPEND Macro

PET_ANSWER_SUSPEND Macro
PET Macros
Syntax
#define PET_ANSWER_SUSPEND PRL_RESULT_DECLARE_SUCCESS(16025)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_SUSPEND_ANYWAY Macro

PET_ANSWER_SUSPEND_ANYWAY Macro
PET Macros
Syntax
#define PET_ANSWER_SUSPEND_ANYWAY PRL_RESULT_DECLARE_SUCCESS(16021)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_USE_CURRENT Macro

PET_ANSWER_USE_CURRENT Macro
PET Macros
Syntax
#define PET_ANSWER_USE_CURRENT PRL_RESULT_DECLARE_SUCCESS(16010)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_USE_MAX_ALLOWED Macro

PET_ANSWER_USE_MAX_ALLOWED Macro
PET Macros
Syntax
#define PET_ANSWER_USE_MAX_ALLOWED PRL_RESULT_DECLARE_SUCCESS(16034)
File

PrlErrorsValues.h

Links
PET Macros


PET_ANSWER_YES Macro

PET_ANSWER_YES Macro
PET Macros
Syntax
#define PET_ANSWER_YES PRL_RESULT_DECLARE_SUCCESS(16002)
File

PrlErrorsValues.h

Links
PET Macros


PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro

PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro
PET Macros
Syntax
#define PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM PRL_RESULT_DECLARE_SUCCESS(441)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK Macro

PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK Macro
PET Macros
Syntax
#define PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK PRL_RESULT_DECLARE_SUCCESS(13022)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION Macro

PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION Macro
PET Macros
Syntax
#define PET_QUESTION_APPLIANCE_CORRUPTED_INSTALLATION PRL_RESULT_DECLARE_SUCCESS(13037)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM Macro

PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM Macro
PET Macros
Syntax
#define PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM PRL_RESULT_DECLARE_SUCCESS(13021)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE Macro

PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE Macro
PET Macros
Syntax
#define PET_QUESTION_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE PRL_RESULT_DECLARE_ERROR(13036)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE Macro

PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE Macro
PET Macros
Syntax
#define PET_QUESTION_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE PRL_RESULT_DECLARE_ERROR(13035)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE Macro

PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE Macro
PET Macros
Syntax
#define PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE PRL_RESULT_DECLARE_SUCCESS(13015)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED Macro

PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED Macro
PET Macros
Syntax
#define PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED PRL_RESULT_DECLARE_SUCCESS(13016)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CANCEL_CLONE_OPERATION Macro

PET_QUESTION_CANCEL_CLONE_OPERATION Macro
PET Macros
Syntax
#define PET_QUESTION_CANCEL_CLONE_OPERATION PRL_RESULT_DECLARE_SUCCESS(13024)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro

PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro
PET Macros
Syntax
#define PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION PRL_RESULT_DECLARE_SUCCESS(13025)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION Macro

PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION Macro
PET Macros
Syntax
#define PET_QUESTION_CANCEL_CONVERT_3RD_VM_OPERATION PRL_RESULT_DECLARE_SUCCESS(13046)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CANCEL_DEPLOY_OPERATION Macro

PET_QUESTION_CANCEL_DEPLOY_OPERATION Macro
PET Macros
Syntax
#define PET_QUESTION_CANCEL_DEPLOY_OPERATION PRL_RESULT_DECLARE_SUCCESS(13026)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION Macro

PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION Macro
PET Macros
Syntax
#define PET_QUESTION_CANCEL_IMPORT_BOOTCAMP_OPERATION PRL_RESULT_DECLARE_SUCCESS(13044)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CHANGE_VM_MIGRATION_TYPE Macro

PET_QUESTION_CHANGE_VM_MIGRATION_TYPE Macro
PET Macros
Syntax
#define PET_QUESTION_CHANGE_VM_MIGRATION_TYPE PRL_RESULT_DECLARE_SUCCESS(13012)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_COMMON_HDD_ERROR Macro

PET_QUESTION_COMMON_HDD_ERROR Macro
PET Macros
Syntax
#define PET_QUESTION_COMMON_HDD_ERROR PRL_RESULT_DECLARE_SUCCESS(13047)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_COMPACT_VM_DISKS Macro

PET_QUESTION_COMPACT_VM_DISKS Macro
PET Macros
Syntax
#define PET_QUESTION_COMPACT_VM_DISKS PRL_RESULT_DECLARE_SUCCESS(13030)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CONTINUE_IF_HVT_DISABLED Macro

PET_QUESTION_CONTINUE_IF_HVT_DISABLED Macro
PET Macros
Syntax
#define PET_QUESTION_CONTINUE_IF_HVT_DISABLED PRL_RESULT_DECLARE_SUCCESS(13031)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CREATE_NEW_MAC_ADDRESS Macro

PET_QUESTION_CREATE_NEW_MAC_ADDRESS Macro
PET Macros
Syntax
#define PET_QUESTION_CREATE_NEW_MAC_ADDRESS PRL_RESULT_DECLARE_SUCCESS(13011)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE Macro

PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE Macro
PET Macros
Syntax
#define PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE PRL_RESULT_DECLARE_SUCCESS(13020)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART Macro

PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART Macro
PET Macros
Syntax
#define PET_QUESTION_CREATE_VM_FROM_LION_RECOVERY_PART PRL_RESULT_DECLARE_SUCCESS(13052)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_DELAYED_COMPACT_VM_DISKS Macro

PET_QUESTION_DELAYED_COMPACT_VM_DISKS Macro
PET Macros
Syntax
#define PET_QUESTION_DELAYED_COMPACT_VM_DISKS PRL_RESULT_DECLARE_SUCCESS(13032)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR Macro

PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR Macro
PET Macros
Syntax
#define PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR PRL_RESULT_DECLARE_SUCCESS(13006)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR Macro

PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR Macro
PET Macros
Syntax
#define PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR PRL_RESULT_DECLARE_SUCCESS(13007)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG Macro

PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG Macro
PET Macros
Syntax
#define PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG PRL_RESULT_DECLARE_SUCCESS(13009)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE Macro

PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE Macro
PET Macros
Syntax
#define PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE PRL_RESULT_DECLARE_SUCCESS(13002)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_FORCE_COMPACT_VM_DISKS Macro

PET_QUESTION_FORCE_COMPACT_VM_DISKS Macro
PET Macros
Syntax
#define PET_QUESTION_FORCE_COMPACT_VM_DISKS PRL_RESULT_DECLARE_SUCCESS(13034)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro

PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro
PET Macros
Syntax
#define PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK PRL_RESULT_DECLARE_SUCCESS(13005)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG Macro

PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG Macro
PET Macros
Syntax
#define PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG PRL_RESULT_DECLARE_SUCCESS(13019)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_OLD_CONFIG_CONVERTION Macro

PET_QUESTION_OLD_CONFIG_CONVERTION Macro
PET Macros
Syntax
#define PET_QUESTION_OLD_CONFIG_CONVERTION PRL_RESULT_DECLARE_SUCCESS(13004)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_ON_QUERY_END_SESSION Macro

PET_QUESTION_ON_QUERY_END_SESSION Macro
PET Macros
Syntax
#define PET_QUESTION_ON_QUERY_END_SESSION PRL_RESULT_DECLARE_SUCCESS(13038)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED Macro

PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED Macro
PET Macros
Syntax
#define PET_QUESTION_ON_QUERY_END_SESSION_RESTRICTED PRL_RESULT_DECLARE_SUCCESS(13039)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_REACH_OVERCOMMIT_STATE Macro

PET_QUESTION_REACH_OVERCOMMIT_STATE Macro
PET Macros
Syntax
#define PET_QUESTION_REACH_OVERCOMMIT_STATE PRL_RESULT_DECLARE_SUCCESS(13014)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro

PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro
PET Macros
Syntax
#define PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM PRL_RESULT_DECLARE_SUCCESS(13017)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT Macro

PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT Macro
PET Macros
Syntax
#define PET_QUESTION_REBOOT_HOST_ON_PCI_DRIVER_INSTALL_OR_REVERT PRL_RESULT_DECLARE_SUCCESS(13027)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_REGISTER_USED_VM Macro

PET_QUESTION_REGISTER_USED_VM Macro
PET Macros
Syntax
#define PET_QUESTION_REGISTER_USED_VM PRL_RESULT_DECLARE_SUCCESS(13010)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_REGISTER_VM_TEMPLATE Macro

PET_QUESTION_REGISTER_VM_TEMPLATE Macro
PET Macros
Syntax
#define PET_QUESTION_REGISTER_VM_TEMPLATE PRL_RESULT_DECLARE_SUCCESS(13008)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT Macro

PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT Macro
PET Macros
Syntax
#define PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT PRL_RESULT_DECLARE_SUCCESS(13029)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP Macro

PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP Macro
PET Macros
Syntax
#define PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP PRL_RESULT_DECLARE_SUCCESS(13023)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SAMPLE_1 Macro

PET_QUESTION_SAMPLE_1 Macro
PET Macros
  • Questions

+++ ALIGNED VALUE TO 13000

Syntax
#define PET_QUESTION_SAMPLE_1 PRL_RESULT_DECLARE_SUCCESS(13000)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SAMPLE_2 Macro

PET_QUESTION_SAMPLE_2 Macro
PET Macros
Syntax
#define PET_QUESTION_SAMPLE_2 PRL_RESULT_DECLARE_SUCCESS(13001)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE Macro

PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE Macro
PET Macros
Syntax
#define PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE PRL_RESULT_DECLARE_SUCCESS(13054)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU Macro

PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU Macro
PET Macros
Syntax
#define PET_QUESTION_SNAPSHOT_STATE_INCOMPATIBLE_CPU PRL_RESULT_DECLARE_SUCCESS(13051)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_STOP_VM_TO_COMPACT Macro

PET_QUESTION_STOP_VM_TO_COMPACT Macro
PET Macros
Syntax
#define PET_QUESTION_STOP_VM_TO_COMPACT PET_QUESTION_RESTART_VM_GUEST_TO_COMPACT
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE Macro

PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE Macro
PET Macros
Syntax
#define PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE PRL_RESULT_DECLARE_SUCCESS(13053)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU Macro

PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU Macro
PET Macros
Syntax
#define PET_QUESTION_SUSPEND_STATE_INCOMPATIBLE_CPU PRL_RESULT_DECLARE_SUCCESS(13050)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS Macro

PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS Macro
PET Macros
Syntax
#define PET_QUESTION_SWITCH_OFF_AUTO_COMPRESS PRL_RESULT_DECLARE_SUCCESS(13033)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_TXT_ERROR Macro

PET_QUESTION_TXT_ERROR Macro
PET Macros
Syntax
#define PET_QUESTION_TXT_ERROR PRL_RESULT_DECLARE_SUCCESS(13003)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_UNDO_DISKS_MODE Macro

PET_QUESTION_UNDO_DISKS_MODE Macro
PET Macros
Syntax
#define PET_QUESTION_UNDO_DISKS_MODE PRL_RESULT_DECLARE_SUCCESS(13018)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_VM_COPY_OR_MOVE Macro

PET_QUESTION_VM_COPY_OR_MOVE Macro
PET Macros
Syntax
#define PET_QUESTION_VM_COPY_OR_MOVE PRL_RESULT_DECLARE_SUCCESS(13013)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS Macro

PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS Macro
PET Macros
Syntax
#define PET_QUESTION_VM_REBOOT_REQUIRED_BY_PRL_TOOLS PRL_RESULT_DECLARE_SUCCESS(13041)
File

PrlErrorsValues.h

Links
PET Macros


PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS Macro

PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS Macro
Other Macros
Syntax
#define PET_QUESTION_VM_ROOT_DIRECTORY_NOT_EXISTS PRL_RESULT_DECLARE_SUCCESS(13028)
File

PrlErrorsValues.h

Links
Other Macros


PRL_ADAPTER_INDEX Enumeration

PRL_ADAPTER_INDEX Enumeration
Other Structs

Parallels adapter index reserved values: PAI_INVALID_ADAPTER: parallels adapter in general is not available PAI_GENERATE_INDEX: calculate a new parallels adapter index

Syntax
typedef enum _PRL_ADAPTER_INDEX {
  PAI_INVALID_ADAPTER = -1,
  PAI_GENERATE_INDEX = -2
} PRL_ADAPTER_INDEX;
File

PrlEnums.h

Links
Other Structs


PRL_ALLOWED_VM_COMMAND Enumeration

PRL_ALLOWED_VM_COMMAND Enumeration
Other Structs

Allowed vm commands enumeration

Syntax
typedef enum _PRL_ALLOWED_VM_COMMAND {
  PAR_VM_START_ACCESS = 0,
  PAR_VM_STOP_ACCESS = 1,
  PAR_VM_PAUSE_ACCESS = 2,
  PAR_VM_RESET_ACCESS = 3,
  PAR_VM_SUSPEND_ACCESS = 4,
  PAR_VM_RESUME_ACCESS = 5,
  PAR_VM_DROPSUSPENDEDSTATE_ACCESS = 6,
  PAR_VM_CLONE_ACCESS = 7,
  PAR_VM_DELETE_ACCESS = 8,
  PAR_VM_GETPROBLEMREPORT_ACCESS = 9,
  PAR_VM_GETCONFIG_ACCESS = 10,
  PAR_VM_GETSTATISTICS_ACCESS = 11,
  PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS = 12,
  PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNREG_ACCESS = 13,
  PAR_VM_COMMIT_ACCESS = 14,
  PAR_VM_EDITING_ACCESS = PAR_VM_COMMIT_ACCESS,
  PAR_VMDEV_CONNECT_ACCESS = 15,
  PAR_VMDEV_DISCONNECT_ACCESS = 16,
  PAR_VMDEV_CREATEIMAGE_ACCESS = 17,
  PAR_VM_SEND_ANSWER_ACCESS = 18,
  PAR_VM_GET_VMINFO_ACCESS = 19,
  PAR_VM_INSTALL_TOOLS_ACCESS = 20,
  PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS = 21,
  PAR_VM_UPDATE_SECURITY_ACCESS = 22,
  PAR_VM_CANCEL_COMPACT_ACCESS = 23,
  PAR_VM_REGISTER_ACCESS = 24,
  PAR_VM_MIGRATE_ACCESS = 25,
  PAR_VM_START_STOP_VNC_SERVER = 26,
  PAR_VM_GET_SUSPENDED_SCREEN_ACCESS = 27,
  PAR_VM_PERFSTAT_ACCESS = 28,
  PAR_VM_LOCK_ACCESS = 29,
  PAR_VM_MIGRATE_CANCEL_ACCESS = PAR_VM_MIGRATE_ACCESS,
  PAR_VM_RUN_COMPRESSOR_ACCESS = 31,
  PAR_VM_CANCEL_COMPRESSOR_ACCESS = 32,
  PAR_VM_CREATE_SNAPSHOT_ACCESS = 33,
  PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS = 34,
  PAR_VM_DELETE_SNAPSHOT_ACCESS = 35,
  PAR_VM_START_EX_ACCESS = 36,
  PAR_VM_UNLOCK_ACCESS = 37,
  PAR_VM_RESTART_GUEST_ACCESS = 38,
  PAR_VM_INSTALL_UTILITY_ACCESS = 39,
  PAR_VM_UPDATE_TOOLS_SECTION = 40,
  PAR_VM_RESTORE_ACCESS = 41,
  PAR_VM_CREATE_BACKUP_ACCESS = 42,
  PAR_VM_RESIZE_DISK_ACCESS = 43,
  PAR_VM_CREATE_ACCESS = 44,
  PAR_SRV_USER_PROFILE_BEGINEDIT_ACCESS = 45,
  PAR_SRV_USER_PROFILE_COMMIT_ACCESS = 46,
  PAR_SRV_SERVER_PROFILE_BEGINEDIT_ACCESS = 47,
  PAR_SRV_SERVER_PROFILE_COMMIT_ACCESS = 48,
  PAR_VM_GUI_VIEW_MODE_CHANGE_ACCESS = 49,
  PAR_VM_BEGINEDIT_ACCESS = 50,
  PAR_VM_RESTORE_BACKUP_ACCESS = 51,
  PAR_VM_COMPACT_ACCESS = 52,
  PAR_VM_CHANGE_SID_ACCESS = 53,
  PAR_VM_RESET_UPTIME_ACCESS = 54,
  PAR_VM_INTERNAL_CMD_ACCESS = 55,
  PAR_VM_GET_VIRT_DEV_INFO = 56,
  PAR_VM_GET_TOOLS_INFO = 57,
  PAR_VM_CONVERT_DISKS_ACCESS = 58,
  PAR_VM_ENCRYPT_OPERATION_ACCESS = 59,
  PAR_VM_CHANGE_PASSWORD_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_ENCRYPT_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_DECRYPT_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_SET_PROTECTION_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_REMOVE_PROTECTION_ACCESS = PAR_VM_ENCRYPT_OPERATION_ACCESS,
  PAR_VM_AUTHORISE_ACCESS = 60,
  PAR_VMDEV_COPY_IMAGE_ACCESS = 61,
  PAR_VM_MOUNT_ACCESS = 62,
  PAR_VM_MOVE_ACCESS = 63,
  PAR_VM_CHANGE_GUEST_OS_PASSWORD_ACCESS = 64,
  PAR_SRV_SENDPROBLEMREPORT_ACCESS = 65,
  PAR_MAX
} PRL_ALLOWED_VM_COMMAND;
File

PrlEnums.h

Members

PAR_MAX
should be the last

Links
Other Structs


PRL_ALLOWED_VM_COMMAND_PTR Type

PRL_ALLOWED_VM_COMMAND_PTR Type
Other Types
Syntax
typedef PRL_ALLOWED_VM_COMMAND* PRL_ALLOWED_VM_COMMAND_PTR;
File

PrlEnums.h

Links
Other Types


PRL_API_COMMAND_FLAGS Enumeration

PRL_API_COMMAND_FLAGS Enumeration
Other Structs

Common operations flags set.

Syntax
typedef enum _PRL_API_COMMAND_FLAGS {
  PACF_NORMAL_SECURITY = PSL_NORMAL_SECURITY,
  PACF_HIGH_SECURITY = PSL_HIGH_SECURITY,
  PACF_NON_INTERACTIVE_MODE = 1<<2,
  PACF_CANCEL_TASK_ON_END_SESSION = 1<<3,
  PACF_MAX = 10,
  PACF_LAST = 1<<PACF_MAX
} PRL_API_COMMAND_FLAGS;
File

PrlCommandsFlags.h

Members

PACF_NORMAL_SECURITY
Client connection security mode
PACF_NON_INTERACTIVE_MODE
Session interactive mode
PACF_CANCEL_TASK_ON_END_SESSION
Cancel long-term operation by session disconnect
PACF_MAX
Interval from here to PACF_LAST reserved for further purposes.

Remarks

Please do not override values

Links
Other Structs


PRL_API_COMMAND_FLAGS_PTR Type

PRL_API_COMMAND_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_API_COMMAND_FLAGS* PRL_API_COMMAND_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_API_INIT_FLAGS Enumeration

PRL_API_INIT_FLAGS Enumeration
Other Structs

Parallels API initialization flags: PrlApi_InitEx command flags set PAIF_USE_GRAPHIC_MODE : specifies create SDK session which has access to the graphic mode

Syntax
typedef enum _PRL_API_INIT_FLAGS {
  PAIF_USE_GRAPHIC_MODE = 1<<(PACF_MAX+1),
  PAIF_INIT_AS_APPSTORE_CLIENT = 1<<(PACF_MAX+2)
} PRL_API_INIT_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_API_INIT_FLAGS_PTR Type

PRL_API_INIT_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_API_INIT_FLAGS* PRL_API_INIT_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_API_METHOD_PTR Type

PRL_API_METHOD_PTR Type
Other Types
Syntax
typedef PRL_API_METHOD* PRL_API_METHOD_PTR;
File

PrlTypes.h

Links
Other Types


PRL_APP_IN_DOCK_MODE Enumeration

PRL_APP_IN_DOCK_MODE Enumeration
Other Structs

VM application in Dock mode

Syntax
typedef enum _PRL_APP_IN_DOCK_MODE {
  PDM_APP_IN_DOCK_NEVER = 0,
  PDM_APP_IN_DOCK_COHERENCE_ONLY = 1,
  PDM_APP_IN_DOCK_ALWAYS = 2
} PRL_APP_IN_DOCK_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_APP_IN_DOCK_MODE_PTR Type

PRL_APP_IN_DOCK_MODE_PTR Type
Other Types
Syntax
typedef PRL_APP_IN_DOCK_MODE* PRL_APP_IN_DOCK_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_APPLIANCE_DOWNLOAD_STATUS Enumeration

PRL_APPLIANCE_DOWNLOAD_STATUS Enumeration
Other Structs

Appliance download status

Syntax
typedef enum _PRL_APPLIANCE_DOWNLOAD_STATUS {
  PADS_NOT_STARTED = 1,
  PADS_STOPPED = 2,
  PADS_DOWNLOADING = 3,
  PADS_DOWNLOADED = 4,
  PADS_UNPACKED = 5,
  PADS_MOVED = 6,
  PADS_REGISTERED = 7,
  PADS_CANCELED = 8
} PRL_APPLIANCE_DOWNLOAD_STATUS;
File

PrlEnums.h

Links
Other Structs


PRL_APPLIANCE_DOWNLOAD_STATUS_PTR Type

PRL_APPLIANCE_DOWNLOAD_STATUS_PTR Type
Other Types
Syntax
typedef PRL_APPLIANCE_DOWNLOAD_STATUS* PRL_APPLIANCE_DOWNLOAD_STATUS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_APPLICATION_MODE Enumeration

PRL_APPLICATION_MODE Enumeration
Other Structs

Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP_MAC : SDK should working at Parallels Desktop for Mac application mode PAM_WORKSTATION_EXTREME : SDK should working at Parallels Workstation Extreme application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_DESKTOP_WL : SDK should working at Parallels Desktop for Windows/Linux application mode PAM_MOBILE : SDK should work at Parallels Mobile application mode

Syntax
typedef enum _PRL_APPLICATION_MODE {
  PAM_UNKNOWN = 0xffff,
  PAM_SERVER = 0,
  PAM_DESKTOP_MAC = 1,
  PAM_WORKSTATION_EXTREME = 2,
  PAM_PLAYER = 3,
  PAM_DESKTOP_STM = PAM_DESKTOP_MAC,
  PAM_DESKTOP_WL = 5,
  PAM_MOBILE = 6,
  PAM_LAST = PAM_MOBILE,
  PAM_DESKTOP_STM_OBSOLETE = 4,
  PAM_DESKTOP = PAM_DESKTOP_MAC,
  PAM_WORKSTATION = PAM_WORKSTATION_EXTREME,
  PAM_STM = PAM_DESKTOP_STM_OBSOLETE
} PRL_APPLICATION_MODE;
File

PrlEnums.h

Members

PAM_LAST
PAM_LAST should be always last entry in enum !
PAM_DESKTOP_STM_OBSOLETE
OBSOLETE CONSTANTS (for compatibility only)

Links
Other Structs


PRL_APPLICATION_MODE_PTR Type

PRL_APPLICATION_MODE_PTR Type
Other Types
Syntax
typedef PRL_APPLICATION_MODE* PRL_APPLICATION_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_ASYNC_METHOD Macro

PRL_ASYNC_METHOD Macro
Other Macros
Syntax
#define PRL_ASYNC_METHOD( func ) PRL_EXTERN __declspec(dllexport) PRL_HANDLE PRL_CALL func
File

PrlTypes.h

Links
Other Macros


PRL_ASYNC_METHOD_DECL Macro

PRL_ASYNC_METHOD_DECL Macro
Other Macros
Syntax
#define PRL_ASYNC_METHOD_DECL( version, name, args ) \
    PRL_ASYNC_METHOD( name ) args;    \
    typedef PRL_ASYNC_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
Other Macros


PRL_ASYNC_METHOD_PTR Macro

PRL_ASYNC_METHOD_PTR Macro
Other Macros
Syntax
#define PRL_ASYNC_METHOD_PTR( func_type ) PRL_HANDLE ( PRL_CALL * func_type )
File

PrlTypes.h

Links
Other Macros


PRL_ASYNC_SRV_METHOD_DECL Macro

PRL_ASYNC_SRV_METHOD_DECL Macro
Other Macros
Syntax
#define PRL_ASYNC_SRV_METHOD_DECL( version, name, args ) \
    PRL_ASYNC_METHOD( name ) args;    \
    typedef PRL_ASYNC_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
Other Macros


PRL_AUDIO_STREAM_TYPE Enumeration

PRL_AUDIO_STREAM_TYPE Enumeration
Other Structs

Audio stream type

Syntax
enum PRL_AUDIO_STREAM_TYPE {
  PAUST_PLAYOUT = 0,
  PAUST_RECORDING = 1
};
File

PrlEnums.h

Links
Other Structs


PRL_AUDIO_STREAM_TYPE_PTR Type

PRL_AUDIO_STREAM_TYPE_PTR Type
Other Types
Syntax
typedef PRL_AUDIO_STREAM_TYPE* PRL_AUDIO_STREAM_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_BIOS_TYPE Enumeration

PRL_BIOS_TYPE Enumeration
Other Structs

BIOS type

Syntax
typedef enum _PRL_BIOS_TYPE {
  PBT_LEGACY = 0,
  PBT_EFI = 1
} PRL_BIOS_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_BIOS_TYPE_PTR Type

PRL_BIOS_TYPE_PTR Type
Other Types
Syntax
typedef PRL_BIOS_TYPE* PRL_BIOS_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_BOOL Type

PRL_BOOL Type
PRL_BOOL Types

Boolean value (32 bit integer), zero means FALSE or TRUE otherwise

Syntax
typedef unsigned int PRL_BOOL;
File

PrlTypes.h

Links
PRL_BOOL Types


PRL_BOOL_PTR Type

PRL_BOOL_PTR Type
PRL_BOOL Types
Syntax
typedef PRL_BOOL* PRL_BOOL_PTR;
File

PrlTypes.h

Links
PRL_BOOL Types


PRL_BSD_PARTITION Macro

PRL_BSD_PARTITION Macro
Other Macros

Free BSD partition.

Syntax
#define PRL_BSD_PARTITION 0xA5
File

PrlDisk.h

Links
Other Macros


PRL_CHAR Type

PRL_CHAR Type
PRL_CHAR Types

All strings are UTF8 encoded

Syntax
typedef char PRL_CHAR;
File

PrlTypes.h

Links
PRL_CHAR Types


PRL_CHAR_PTR Type

PRL_CHAR_PTR Type
PRL_CHAR Types
Syntax
typedef PRL_CHAR* PRL_CHAR_PTR;
File

PrlTypes.h

Links
PRL_CHAR Types


PRL_CHECKED_DISK_INVALID Macro

PRL_CHECKED_DISK_INVALID Macro
Other Macros
Syntax
#define PRL_CHECKED_DISK_INVALID PRL_RESULT_DECLARE_SUCCESS(25002)
File

PrlErrorsValues.h

Links
Other Macros


PRL_CHECKED_DISK_OLD_VERSION Macro

PRL_CHECKED_DISK_OLD_VERSION Macro
Other Macros
Syntax
#define PRL_CHECKED_DISK_OLD_VERSION PRL_RESULT_DECLARE_SUCCESS(25001)
File

PrlErrorsValues.h

Links
Other Macros


PRL_CHECKED_DISK_VALID Macro

PRL_CHECKED_DISK_VALID Macro
Other Macros
  • Disk validation errors

+++ ALIGNED VALUE TO 25000

Syntax
#define PRL_CHECKED_DISK_VALID PRL_RESULT_DECLARE_SUCCESS(25000)
File

PrlErrorsValues.h

Links
Other Macros


PRL_CHS Structure

PRL_CHS Structure
Other Structs

CHS format of disk

Syntax
typedef struct _PRL_CHS {
  PRL_UINT32 Sectors;
  PRL_UINT32 Heads;
  PRL_UINT32 Cylinders;
} PRL_CHS;
File

PrlDisk.h

Links
Other Structs


PRL_CHS_PTR Type

PRL_CHS_PTR Type
Other Types
Syntax
typedef PRL_CHS* PRL_CHS_PTR;
File

PrlDisk.h

Links
Other Types


PRL_CLONE_VM_FLAGS Enumeration

PRL_CLONE_VM_FLAGS Enumeration
Other Structs

PrlVm_CloneEx command flags set

PCVF_DETACH_EXTERNAL_VIRTUAL_HDD

  • to remove link to Virtual Hdd which located outside of VM.pvm directory from cloned vm configuration.
Syntax
typedef enum _PRL_CLONE_VM_FLAGS {
  PCVF_CLONE_TO_TEMPLATE = 1<<(PACF_MAX+1),
  PCVF_CHANGE_SID = 1<<(PACF_MAX+2),
  PCVF_LINKED_CLONE = 1<<(PACF_MAX+3),
  PCVF_IMPORT_BOOT_CAMP = 1<<(PACF_MAX+4),
  PCVF_DETACH_EXTERNAL_VIRTUAL_HDD = 1<<(PACF_MAX+5),
  PCVF_REGENERATE_SRC_VM_UUID = 1<<(PACF_MAX+6)
} PRL_CLONE_VM_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_CLONE_VM_FLAGS_PTR Type

PRL_CLONE_VM_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_CLONE_VM_FLAGS* PRL_CLONE_VM_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_CLUSTERED_DEVICE_SUBTYPE Enumeration

PRL_CLUSTERED_DEVICE_SUBTYPE Enumeration
Other Structs

Clustered device subtype

Syntax
typedef enum _PRL_CLUSTERED_DEVICE_SUBTYPE {
  PCD_BUSLOGIC = 0,
  PCD_LSI_SPI = 1,
  PCD_LSI_SAS = 2,
  PCD_UNKNOWN_DEVICE = 255
} PRL_CLUSTERED_DEVICE_SUBTYPE;
File

PrlEnums.h

Links
Other Structs


PRL_CLUSTERED_DEVICE_SUBTYPE_PTR Type

PRL_CLUSTERED_DEVICE_SUBTYPE_PTR Type
Other Types
Syntax
typedef PRL_CLUSTERED_DEVICE_SUBTYPE* PRL_CLUSTERED_DEVICE_SUBTYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_COMPACT_MODE Enumeration

PRL_COMPACT_MODE Enumeration
Other Structs

Compact mode: PCM_COMPACT_WITH_HARD_DISKS_INFO : show question before compacting with size disks info PCM_HARD_DISKS_INFO : just get disk info PCM_FULL_CLEAN_UP_VM : compact all disks and delete all unneccessary files

Syntax
typedef enum _PRL_COMPACT_MODE {
  PCM_COMPACT_WITH_HARD_DISKS_INFO = 1<<(PACF_MAX+1),
  PCM_HARD_DISKS_INFO = 1<<(PACF_MAX+2),
  PCM_FULL_CLEAN_UP_VM = 1<<(PACF_MAX+3)
} PRL_COMPACT_MODE;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_COMPACT_MODE_PTR Type

PRL_COMPACT_MODE_PTR Type
Other Types
Syntax
typedef PRL_COMPACT_MODE* PRL_COMPACT_MODE_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_CONST_API_METHOD_PTR Type

PRL_CONST_API_METHOD_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_API_METHOD* PRL_CONST_API_METHOD_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_BOOL_PTR Type

PRL_CONST_BOOL_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_BOOL* PRL_CONST_BOOL_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_CARET_INFO_PTR Type

PRL_CONST_CARET_INFO_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_CARET_INFO* PRL_CONST_CARET_INFO_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_CPU_FEATURES_MASK_PTR Type

PRL_CONST_CPU_FEATURES_MASK_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_CPU_FEATURES_MASK* PRL_CONST_CPU_FEATURES_MASK_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_CPULIMIT_DATA_PTR Type

PRL_CONST_CPULIMIT_DATA_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_CPULIMIT_DATA* PRL_CONST_CPULIMIT_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_CVSRC_OPEN_MODE Type

PRL_CONST_CVSRC_OPEN_MODE Type
PRL_CONST Types
Syntax
typedef const PRL_CVSRC_OPEN_MODE* PRL_CONST_CVSRC_OPEN_MODE;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_DISK_OPEN_FLAGS_PTR Type

PRL_CONST_DISK_OPEN_FLAGS_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_DISK_OPEN_FLAGS* PRL_CONST_DISK_OPEN_FLAGS_PTR;
File

PrlDisk.h

Links
PRL_CONST Types


PRL_CONST_DISK_PARAMETERS_PTR Type

PRL_CONST_DISK_PARAMETERS_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_DISK_PARAMETERS* PRL_CONST_DISK_PARAMETERS_PTR;
File

PrlDisk.h

Links
PRL_CONST Types


PRL_CONST_DOUBLE_PTR Type

PRL_CONST_DOUBLE_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_DOUBLE* PRL_CONST_DOUBLE_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR Type

PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_GET_VM_CONFIG_PARAM_DATA* PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_GUID_PTR Type

PRL_CONST_GUID_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_GUID* PRL_CONST_GUID_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_HANDLE_PTR Type

PRL_CONST_HANDLE_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_HANDLE* PRL_CONST_HANDLE_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_INT8_PTR Type

PRL_CONST_INT8_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_INT8* PRL_CONST_INT8_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_INT16_PTR Type

PRL_CONST_INT16_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_INT16* PRL_CONST_INT16_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_INT32_PTR Type

PRL_CONST_INT32_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_INT32* PRL_CONST_INT32_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_INT64_PTR Type

PRL_CONST_INT64_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_INT64* PRL_CONST_INT64_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_IOLIMIT_DATA_PTR Type

PRL_CONST_IOLIMIT_DATA_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_IOLIMIT_DATA* PRL_CONST_IOLIMIT_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_MAKEUP_HINTING_RGN_PTR Type

PRL_CONST_MAKEUP_HINTING_RGN_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_MAKEUP_HINTING_RGN* PRL_CONST_MAKEUP_HINTING_RGN_PTR;
File

PrlApiHinting.h

Links
PRL_CONST Types


PRL_CONST_SELECTION_HINTING_RGN_PTR Type

PRL_CONST_SELECTION_HINTING_RGN_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_SELECTION_HINTING_RGN* PRL_CONST_SELECTION_HINTING_RGN_PTR;
File

PrlApiHinting.h

Links
PRL_CONST Types


PRL_CONST_SIZE_PTR Type

PRL_CONST_SIZE_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_SIZE* PRL_CONST_SIZE_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_SNAPSHOT_ELEMENT_PTR Type

PRL_CONST_SNAPSHOT_ELEMENT_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_SNAPSHOT_ELEMENT* PRL_CONST_SNAPSHOT_ELEMENT_PTR;
File

PrlDisk.h

Links
PRL_CONST Types


PRL_CONST_STR Type

PRL_CONST_STR Type
PRL_CONST Types
Syntax
typedef const char* PRL_CONST_STR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_STR_PTR Type

PRL_CONST_STR_PTR Type
PRL_CONST Types
Syntax
typedef PRL_CONST_STR* PRL_CONST_STR_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_AUTOKEYBOARD_PTR Type

PRL_CONST_UIEMU_AUTOKEYBOARD_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_AUTOKEYBOARD* PRL_CONST_UIEMU_AUTOKEYBOARD_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_CURSOR_DESC_PTR Type

PRL_CONST_UIEMU_CURSOR_DESC_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_CURSOR_DESC* PRL_CONST_UIEMU_CURSOR_DESC_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_CURSOR_FORMAT_PTR Type

PRL_CONST_UIEMU_CURSOR_FORMAT_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_CURSOR_FORMAT* PRL_CONST_UIEMU_CURSOR_FORMAT_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_CURSOR_POS_PTR Type

PRL_CONST_UIEMU_CURSOR_POS_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_CURSOR_POS* PRL_CONST_UIEMU_CURSOR_POS_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR Type

PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_ELEMENT_AT_POS* PRL_CONST_UIEMU_ELEMENT_AT_POS_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR Type

PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_GESTURE_DATA_PINCH* PRL_CONST_UIEMU_GESTURE_DATA_PINCH_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR Type

PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_GESTURE_DATA_SMARTZOOM* PRL_CONST_UIEMU_GESTURE_DATA_SMARTZOOM_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_GESTURE_EVENT_PTR Type

PRL_CONST_UIEMU_GESTURE_EVENT_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_GESTURE_EVENT* PRL_CONST_UIEMU_GESTURE_EVENT_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_INPUT_INFO_PTR Type

PRL_CONST_UIEMU_INPUT_INFO_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_INPUT_INFO* PRL_CONST_UIEMU_INPUT_INFO_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UIEMU_VKEY_PTR Type

PRL_CONST_UIEMU_VKEY_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UIEMU_VKEY* PRL_CONST_UIEMU_VKEY_PTR;
File

PrlIoStructs.h

Links
PRL_CONST Types


PRL_CONST_UINT8_PTR Type

PRL_CONST_UINT8_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UINT8* PRL_CONST_UINT8_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_UINT16_PTR Type

PRL_CONST_UINT16_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UINT16* PRL_CONST_UINT16_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_UINT32_PTR Type

PRL_CONST_UINT32_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UINT32* PRL_CONST_UINT32_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_UINT64_PTR Type

PRL_CONST_UINT64_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_UINT64* PRL_CONST_UINT64_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR Type

PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_VIDEO_RECEIVER_CONFIG* PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR;
File

PrlApiVideoReceiver.h

Links
PRL_CONST Types


PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR Type

PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY* PRL_CONST_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR;
File

PrlApiVideoReceiver.h

Links
PRL_CONST Types


PRL_CONST_VOID_PTR Type

PRL_CONST_VOID_PTR Type
PRL_CONST Types
Syntax
typedef const PRL_VOID* PRL_CONST_VOID_PTR;
File

PrlTypes.h

Links
PRL_CONST Types


PRL_CONVERT_VIRTUAL_DISK Enumeration

PRL_CONVERT_VIRTUAL_DISK Enumeration
Other Structs

Convert virtual disk

  • PCVD_CANCEL : cancel disk conversion
  • PCVD_TO_PLAIN_DISK : convert disk from expanding to plain disk
  • PCVD_TO_EXPANDING_DISK : convert disk from plain to expanding disk
  • PCVD_TO_SPLIT_DISK : convert disk from non-split to split disk
  • PCVD_TO_NON_SPLIT_DISK : convert disk from split to non-split disk
  • PCVD_MERGE_ALL_SNAPSHOTS : merge all disk snapshots
Syntax
typedef enum _PRL_CONVERT_VIRTUAL_DISK {
  PCVD_CANCEL = 1<<(PACF_MAX+1),
  PCVD_TO_PLAIN_DISK = 1<<(PACF_MAX+2),
  PCVD_TO_EXPANDING_DISK = 1<<(PACF_MAX+3),
  PCVD_TO_SPLIT_DISK = 1<<(PACF_MAX+4),
  PCVD_TO_NON_SPLIT_DISK = 1<<(PACF_MAX+5),
  PCVD_MERGE_ALL_SNAPSHOTS = 1<<(PACF_MAX+6)
} PRL_CONVERT_VIRTUAL_DISK;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_COPY_CT_TEMPLATE_FLAGS Enumeration

PRL_COPY_CT_TEMPLATE_FLAGS Enumeration
Other Structs

copy of CT templates functionality flags set

Syntax
typedef enum _PRL_COPY_CT_TEMPLATE_FLAGS {
  PCTMP_LOW_SECURITY = PSL_LOW_SECURITY,
  PCTMP_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PCTMP_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PCTMPL_FORCE = 1<<(PACF_MAX+1)
} PRL_COPY_CT_TEMPLATE_FLAGS;
File

PrlCommandsFlags.h

Type Parameters

PCTMPL_FORCE
force template copy

Links
Other Structs


PRL_CORNER_ACTIONS Enumeration

PRL_CORNER_ACTIONS Enumeration
Other Structs

Window corner actions

Syntax
typedef enum _PRL_CORNER_ACTIONS {
  PCA_NO_ACTION = 0,
  PCA_WINDOWED = 1,
  PCA_COHERENCE = 2,
  PCA_SEAMLESS = 3,
  PCA_MODALITY = 4,
  PCA_HIDE_APPLICATION = 5,
  PCA_UNGRAB_INPUT = 6,
  PCA_CRYSTAL = 7
} PRL_CORNER_ACTIONS;
File

PrlEnums.h

Links
Other Structs


PRL_CORNER_ACTIONS_PTR Type

PRL_CORNER_ACTIONS_PTR Type
Other Types
Syntax
typedef PRL_CORNER_ACTIONS* PRL_CORNER_ACTIONS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CPU_FEATURES Structure

PRL_CPU_FEATURES Structure
Other Structs
Syntax
typedef struct _PRL_CPU_FEATURES {
  PRL_UINT32 nFEATURES;
  PRL_UINT32 nEXT_FEATURES;
  PRL_UINT32 nEXT_00000007_EBX;
  PRL_UINT32 nEXT_80000001_ECX;
  PRL_UINT32 nEXT_80000001_EDX;
  PRL_UINT32 nEXT_80000007_EDX;
  PRL_UINT32 nEXT_80000008_EAX;
  PRL_UINT32 nEXT_0000000D_EAX;
} PRL_CPU_FEATURES;
File

PrlIoStructs.h

Links
Other Structs


PRL_CPU_FEATURES_EX Enumeration

PRL_CPU_FEATURES_EX Enumeration
Other Structs
Syntax
typedef enum _PRL_CPU_FEATURES_EX {
  PCFE_FEATURES = 0,
  PCFE_EXT_FEATURES = 1,
  PCFE_EXT_00000007_EBX = 2,
  PCFE_EXT_80000001_ECX = 3,
  PCFE_EXT_80000001_EDX = 4,
  PCFE_EXT_80000007_EDX = 5,
  PCFE_EXT_80000008_EAX = 6,
  PCFE_EXT_0000000D_EAX = 7,
  PCFE_MAX
} PRL_CPU_FEATURES_EX;
File

PrlEnums.h

Members

PCFE_MAX
have to be the last.

Links
Other Structs


PRL_CPU_FEATURES_MASK Structure

PRL_CPU_FEATURES_MASK Structure
Other Structs
Syntax
typedef struct _PRL_CPU_FEATURES_MASK {
  PRL_UINT32 nFEATURES_MASK;
  PRL_UINT32 nEXT_FEATURES_MASK;
  PRL_UINT32 nEXT_00000007_EBX_MASK;
  PRL_UINT32 nEXT_80000001_ECX_MASK;
  PRL_UINT32 nEXT_80000001_EDX_MASK;
  PRL_UINT32 nEXT_80000007_EDX_MASK;
  PRL_UINT32 nEXT_80000008_EAX;
  PRL_UINT32 nEXT_0000000D_EAX_MASK;
  PRL_UINT32 bIsValid;
} PRL_CPU_FEATURES_MASK;
File

PrlIoStructs.h

Links
Other Structs


PRL_CPU_FEATURES_MASK_PTR Type

PRL_CPU_FEATURES_MASK_PTR Type
Other Types
Syntax
typedef PRL_CPU_FEATURES_MASK* PRL_CPU_FEATURES_MASK_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_CPU_FEATURES_PTR Type

PRL_CPU_FEATURES_PTR Type
Other Types
Syntax
typedef PRL_CPU_FEATURES* PRL_CPU_FEATURES_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_CPU_HVT Enumeration

PRL_CPU_HVT Enumeration
Other Structs

CPU mode

Syntax
typedef enum _PRL_CPU_HVT {
  PCM_CPU_NONE_HV = 0,
  PCM_CPU_INTEL_VT_X,
  PCM_CPU_AMD_V
} PRL_CPU_HVT;
File

PrlEnums.h

Links
Other Structs


PRL_CPU_HVT_PTR Type

PRL_CPU_HVT_PTR Type
Other Types
Syntax
typedef PRL_CPU_HVT* PRL_CPU_HVT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CPU_MODE Enumeration

PRL_CPU_MODE Enumeration
Other Structs

CPU mode

Syntax
typedef enum _PRL_CPU_MODE {
  PCM_CPU_MODE_32 = 0,
  PCM_CPU_MODE_64 = 1
} PRL_CPU_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_CPU_MODE_PTR Type

PRL_CPU_MODE_PTR Type
Other Types
Syntax
typedef PRL_CPU_MODE* PRL_CPU_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CPU_UNLIMITED Macro

PRL_CPU_UNLIMITED Macro
PET Macros

constant for unlimited CPU number

Syntax
#define PRL_CPU_UNLIMITED 0xffffffff
File

PrlEnums.h

Links
PET Macros


PRL_CPU_VTX_MODE Type

PRL_CPU_VTX_MODE Type
Other Types
Syntax
typedef enum _PRL_CPU_HVT PRL_CPU_VTX_MODE;
File

PrlEnums.h

Links
Other Types


PRL_CPU_VTX_MODE_PTR Type

PRL_CPU_VTX_MODE_PTR Type
Other Types
Syntax
typedef PRL_CPU_HVT* PRL_CPU_VTX_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CPULIMIT_DATA Structure

PRL_CPULIMIT_DATA Structure
Other Structs
Syntax
typedef struct _PRL_CPULIMIT_DATA {
  PRL_UINT32 value;
  PRL_CPULIMIT_TYPE type;
} PRL_CPULIMIT_DATA;
File

PrlIoStructs.h

Links
Other Structs


PRL_CPULIMIT_DATA_PTR Type

PRL_CPULIMIT_DATA_PTR Type
Other Types
Syntax
typedef PRL_CPULIMIT_DATA* PRL_CPULIMIT_DATA_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_CPULIMIT_TYPE Enumeration

PRL_CPULIMIT_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_CPULIMIT_TYPE {
  PRL_CPULIMIT_PERCENTS100 = 1,
  PRL_CPULIMIT_MHZ = 2,
  PRL_CPULIMIT_PERCENTS = 3,
  PRL_CPULIMIT_PERCENTS_TO_MHZ = 4
} PRL_CPULIMIT_TYPE;
File

PrlEnums.h

Members

PRL_CPULIMIT_PERCENTS100
cpulimit 0-100
PRL_CPULIMIT_PERCENTS
cpulimit 0-100 * nCpu
PRL_CPULIMIT_PERCENTS_TO_MHZ
The limit in % convert to Mhz

Links
Other Structs


PRL_CPUUITS Enumeration

PRL_CPUUITS Enumeration
Other Structs
Syntax
typedef enum _PRL_CPUUNITS {
  PRL_CPUUNITS_MIN = 10,
  PRL_CPUUNITS_DEFAULT = 1000,
  PRL_CPUUNITS_MAX = 500000
} PRL_CPUUITS;
File

PrlEnums.h

Links
Other Structs


PRL_CREATE_DISK_IMAGE_FLAGS Enumeration

PRL_CREATE_DISK_IMAGE_FLAGS Enumeration
Other Structs

Create image flags

Syntax
typedef enum _PRL_CREATE_DISK_IMAGE_FLAGS {
  PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION = 1<<(PACF_MAX+1)
} PRL_CREATE_DISK_IMAGE_FLAGS;
File

PrlCommandsFlags.h

Members

PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION
create from lion recovery

Links
Other Structs


PRL_CREATE_DISK_IMAGE_FLAGS_PTR Type

PRL_CREATE_DISK_IMAGE_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_CREATE_DISK_IMAGE_FLAGS* PRL_CREATE_DISK_IMAGE_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_CREATE_SNAPSHOT_FLAGS Enumeration

PRL_CREATE_SNAPSHOT_FLAGS Enumeration
Other Structs

VM snapshot creation flags set

Syntax
typedef enum _PRL_CREATE_SNAPSHOT_FLAGS {
  PCSF_DISK_ONLY = 1<<(PACF_MAX+1),
  PCSF_BACKUP = 1<<(PACF_MAX+2)
} PRL_CREATE_SNAPSHOT_FLAGS;
File

PrlCommandsFlags.h

Members

PCSF_DISK_ONLY
internal flag
PCSF_BACKUP
internal flag

Type Parameters

PCSF_DISK_ONLY
to snapshot hdd's only for running Vm
PCSF_BACKUP
create snapshot for backup

Links
Other Structs


PRL_CT_CAPMASK Enumeration

PRL_CT_CAPMASK Enumeration
Other Structs

Capabilities list

Syntax
typedef enum _PRL_CT_CAPMASK {
  PCC_CHOWN = (1 << 0),
  PCC_FS_MASK = PCC_CHOWN,
  PCC_DAC_OVERRIDE = (1 << 1),
  PCC_DAC_READ_SEARCH = (1 << 2),
  PCC_FOWNER = (1 << 3),
  PCC_FSETID = (1 << 4),
  PCC_KILL = (1 << 5),
  PCC_SETGID = (1 << 6),
  PCC_SETUID = (1 << 7),
  PCC_SETPCAP = (1 << 8),
  PCC_LINUX_IMMUTABLE = (1 << 9),
  PCC_NET_BIND_SERVICE = (1 << 10),
  PCC_NET_BROADCAST = (1 << 11),
  PCC_NET_ADMIN = (1 << 12),
  PCC_NET_RAW = (1 << 13),
  PCC_IPC_LOCK = (1 << 14),
  PCC_IPC_OWNER = (1 << 15),
  PCC_SYS_MODULE = (1 << 16),
  PCC_SYS_RAWIO = (1 << 17),
  PCC_SYS_CHROOT = (1 << 18),
  PCC_SYS_PTRACE = (1 << 19),
  PCC_SYS_PACCT = (1 << 20),
  PCC_SYS_ADMIN = (1 << 21),
  PCC_SYS_BOOT = (1 << 22),
  PCC_SYS_NICE = (1 << 23),
  PCC_SYS_RESOURCE = (1 << 24),
  PCC_SYS_TIME = (1 << 25),
  PCC_SYS_TTY_CONFIG = (1 << 26),
  PCC_MKNOD = (1 << 27),
  PCC_LEASE = (1 << 28),
  PCC_AUDIT_WRITE = (1 << 29),
  PCC_VE_ADMIN = (1 << 30),
  PCC_SETFCAP = (1 << 31)
} PRL_CT_CAPMASK;
File

PrlEnums.h

Members

PCC_FS_MASK
FIXME: real value of PCC_FS_MASK?

Links
Other Structs


PRL_CT_CAPMASK_PTR Type

PRL_CT_CAPMASK_PTR Type
Other Types
Syntax
typedef PRL_CT_CAPMASK* PRL_CT_CAPMASK_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CT_FEATURES Enumeration

PRL_CT_FEATURES Enumeration
Other Structs

CT Features

Syntax
typedef enum _PRL_CT_FEATURES {
  PCF_FEATURE_SYSFS = (1 << 0),
  PCF_FEATURE_NFS = (1 << 1),
  PCF_FEATURE_DEF_PERM = (1 << 2),
  PCF_FEATURE_SIT = (1 << 3),
  PCF_FEATURE_IPIP = (1 << 4),
  PCF_FEATURE_PPP = (1 << 5),
  PCF_FEATURE_IPGRE = (1 << 6),
  PCF_FEATURE_BRIDGE = (1 << 7),
  PCF_FEATURE_NFSD = (1 << 8)
} PRL_CT_FEATURES;
File

PrlEnums.h

Links
Other Structs


PRL_CT_RESOURCE Enumeration

PRL_CT_RESOURCE Enumeration
Other Structs
Syntax
typedef enum _PRL_CT_RESOURCE {
  PCR_KMEMSIZE = 1,
  PCR_LOCKEDPAGES = 2,
  PCR_PRIVVMPAGES = 3,
  PCR_SHMPAGES = 4,
  PCR_NUMPROC = 5,
  PCR_PHYSPAGES = 6,
  PCR_VMGUARPAGES = 7,
  PCR_OOMGUARPAGES = 8,
  PCR_NUMTCPSOCK = 9,
  PCR_NUMFLOCK = 10,
  PCR_NUMPTY = 11,
  PCR_NUMSIGINFO = 12,
  PCR_TCPSNDBUF = 13,
  PCR_TCPRCVBUF = 14,
  PCR_OTHERSOCKBUF = 15,
  PCR_DGRAMRCVBUF = 16,
  PCR_NUMOTHERSOCK = 17,
  PCR_DCACHESIZE = 18,
  PCR_NUMFILE = 19,
  PCR_NUMIPTENT = 20,
  PCR_SWAPPAGES = 21,
  PCR_QUOTAUGIDLIMIT = 22,
  PCR_LAST = PCR_QUOTAUGIDLIMIT
} PRL_CT_RESOURCE;
File

PrlEnums.h

Links
Other Structs


PRL_CT_TEMPLATE_TYPE Enumeration

PRL_CT_TEMPLATE_TYPE Enumeration
Other Structs

Container templates types

Syntax
typedef enum _PRL_CT_TEMPLATE_TYPE {
  PCT_TYPE_EZ_OS = 0,
  PCT_TYPE_EZ_APP = 1
} PRL_CT_TEMPLATE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_CT_TEMPLATE_TYPE_PTR Type

PRL_CT_TEMPLATE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_CT_TEMPLATE_TYPE* PRL_CT_TEMPLATE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_CURRENT_GUEST_OS_SESSION Macro

PRL_CURRENT_GUEST_OS_SESSION Macro
Other Macros
Syntax
#define PRL_CURRENT_GUEST_OS_SESSION "4a5533a7-31c6-4d7a-a400-1f330dc57a9d"
File

PrlEnums.h

Links
Other Macros


PRL_CVSRC_OPEN_MODE Structure

PRL_CVSRC_OPEN_MODE Structure
Other Structs
Syntax
typedef struct _PRL_CVSRC_OPEN_MODE {
  PRL_UINT32 sessionId;
  PRL_UINT32 frameFormat;
  PRL_UINT32 frameWidth;
  PRL_UINT32 frameHeight;
  PRL_UINT32 frameBytesPerRow;
} PRL_CVSRC_OPEN_MODE;
File

PrlIoStructs.h

Links
Other Structs


PRL_CVSRC_OPEN_MODE_PTR Type

PRL_CVSRC_OPEN_MODE_PTR Type
Other Types
Syntax
typedef PRL_CVSRC_OPEN_MODE* PRL_CVSRC_OPEN_MODE_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_DATA_PARTITION Macro

PRL_DATA_PARTITION Macro
Other Macros

Special handle for data partition from GPT (can be linux, windows, any type).

Syntax
#define PRL_DATA_PARTITION 0xd8
File

PrlDisk.h

Links
Other Macros


PRL_DATA_STATISTIC_SEGMENTS Enumeration

PRL_DATA_STATISTIC_SEGMENTS Enumeration
Other Structs

Data statistic segments

Syntax
typedef enum _PRL_DATA_STATISTIC_SEGMENTS {
  PDSS_UNKNOWN = 0,
  PDSS_VM_MISCELLANEOUS_SPACE = 1,
  PDSS_VM_RECLAIM_SPACE = 2,
  PDSS_VM_SNAPSHOTS_SPACE = 3,
  PDSS_VM_DISK_DATA_SPACE = 4,
  PDSS_VM_FULL_SPACE = 5
} PRL_DATA_STATISTIC_SEGMENTS;
File

PrlEnums.h

Links
Other Structs


PRL_DATA_STATISTIC_SEGMENTS_PTR Type

PRL_DATA_STATISTIC_SEGMENTS_PTR Type
Other Types
Syntax
typedef PRL_DATA_STATISTIC_SEGMENTS* PRL_DATA_STATISTIC_SEGMENTS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_DELETE_SNAPSHOT_FLAGS Enumeration

PRL_DELETE_SNAPSHOT_FLAGS Enumeration
Other Structs
  • PrlVm_DeleteSnapshotEx flags PDSF_BACKUP - delete snapshot for backup
Syntax
typedef enum _PRL_DELETE_SNAPSHOT_FLAGS {
  PDSF_SKIP_SPACE_CHECK = 1<<(PACF_MAX+1),
  PDSF_BACKUP = 1<<(PACF_MAX+2)
} PRL_DELETE_SNAPSHOT_FLAGS;
File

PrlCommandsFlags.h

Members

PDSF_SKIP_SPACE_CHECK
skip space check
PDSF_BACKUP
internal flag

Links
Other Structs


PRL_DEVICE_ACTION Enumeration

PRL_DEVICE_ACTION Enumeration
Other Structs

Device in use Action

Syntax
typedef enum _PRL_DEVICE_ACTION {
  PDA_DEVICE_IDLE = 0,
  PDA_DEVICE_READ = 1,
  PDA_DEVICE_WRITE = 2
} PRL_DEVICE_ACTION;
File

PrlEnums.h

Links
Other Structs


PRL_DEVICE_ACTION_PTR Type

PRL_DEVICE_ACTION_PTR Type
PRL_DEVICE Types
Syntax
typedef PRL_DEVICE_ACTION* PRL_DEVICE_ACTION_PTR;
File

PrlEnums.h

Links
PRL_DEVICE Types


PRL_DEVICE_TYPE Enumeration

PRL_DEVICE_TYPE Enumeration
Other Structs

Device type

Syntax
typedef enum _PRL_DEVICE_TYPE {
  PDE_GENERIC_DEVICE = 0,
  PDE_CLUSTERED_DEVICE = 1,
  PDE_STORAGE_DEVICE = 2,
  PDE_FLOPPY_DISK = 3,
  PDE_MASSSTORAGE_DEVICE = 4,
  PDE_OPTICAL_DISK = 5,
  PDE_HARD_DISK = 6,
  PDE_GENERIC_NETWORK_ADAPTER = 8,
  PDE_GENERIC_PORT = 9,
  PDE_SERIAL_PORT = 10,
  PDE_PARALLEL_PORT = 11,
  PDE_SOUND_DEVICE = 12,
  PDE_MIXER_DEVICE = 13,
  PDE_USB_DEVICE = 15,
  PDE_PRINTER = 16,
  PDE_GENERIC_PCI_DEVICE = 17,
  PDE_GENERIC_SCSI_DEVICE = 18,
  PDE_VIRTUAL_SNAPSHOT_DEVICE = 19,
  PDE_PCI_VIDEO_ADAPTER = 20,
  PDE_VIRTUAL_SHARED_FOLDERS_DEVICE = 21,
  PDE_MAX
} PRL_DEVICE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_DEVICE_TYPE_PTR Type

PRL_DEVICE_TYPE_PTR Type
PRL_DEVICE Types
Syntax
typedef PRL_DEVICE_TYPE* PRL_DEVICE_TYPE_PTR;
File

PrlEnums.h

Links
PRL_DEVICE Types


PRL_DISK_ALIGN_REQUESTS Macro

PRL_DISK_ALIGN_REQUESTS Macro
PRL_DISK Macros

Incoming requests to read/write async must be gathered and aligned

Syntax
#define PRL_DISK_ALIGN_REQUESTS 0x00020000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_ALLOW_DATA_MODIFY Macro

PRL_DISK_ALLOW_DATA_MODIFY Macro
PRL_DISK Macros

Allow inplace data modification to reduce memory copying and allocation

Syntax
#define PRL_DISK_ALLOW_DATA_MODIFY 0x00010000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_CACHE_DEFAULT Macro

PRL_DISK_CACHE_DEFAULT Macro
PRL_DISK Macros

Disk cache default.

Syntax
#define PRL_DISK_CACHE_DEFAULT 0
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_CACHE_DISABLED Macro

PRL_DISK_CACHE_DISABLED Macro
PRL_DISK Macros

Uncached access to disk image.

Syntax
#define PRL_DISK_CACHE_DISABLED 2
File

PrlDisk.h

Remarks

Slow read/write always, but host OS cache is not used, so it's good for host applications.

Links
PRL_DISK Macros


PRL_DISK_CACHE_ENABLED Macro

PRL_DISK_CACHE_ENABLED Macro
PRL_DISK Macros

Cached access to disk image.

Syntax
#define PRL_DISK_CACHE_ENABLED 1
File

PrlDisk.h

Remarks

Fast write() and read() in case of all data can be fit in OS cache. But in the other hand host cache will be partially duplicated in guest OS cache, so in this mode memory usage may be ineffective.

Links
PRL_DISK Macros


PRL_DISK_CACHE_UNCACHED_READ Macro

PRL_DISK_CACHE_UNCACHED_READ Macro
PRL_DISK Macros

Cached write/uncached read.

Syntax
#define PRL_DISK_CACHE_UNCACHED_READ 3
File

PrlDisk.h

Remarks

Like DISK_CACHE_ENABLED, but read data does not duplicated in host OS RAM, so you have more RAM for host applications. On Mac you may also see performance gain when you read data that were just written before and held in OS cache - data will be read from cache even with F_NOCACHE read(). This may help guest OS with stuff like pagefile.sys for example.

Links
PRL_DISK Macros


PRL_DISK_CACHE_UNCACHED_SEQ_READ Macro

PRL_DISK_CACHE_UNCACHED_SEQ_READ Macro
PRL_DISK Macros

Like PRL_DISK_CACHE_UNCACHED_READ, but cache is enabled for

  • small and random/reordered requests.

Syntax
#define PRL_DISK_CACHE_UNCACHED_SEQ_READ 4
File

PrlDisk.h

Remarks

This let fix some

  • performance problems when guest read data sequentially, but
  • by small buffers.

    • Links
    PRL_DISK Macros


PRL_DISK_DEFAULT_FLAG Macro

PRL_DISK_DEFAULT_FLAG Macro
PRL_DISK Macros

Default (writelock always on at write on).

Syntax
#define PRL_DISK_DEFAULT_FLAG (PRL_DISK_READ | PRL_DISK_WRITE | PRL_DISK_FOPS_DEFAULT)
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FAKE_OPEN Macro

PRL_DISK_FAKE_OPEN Macro
PRL_DISK Macros

Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).

Syntax
#define PRL_DISK_FAKE_OPEN 0x00000008
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_DEFAULT Macro

PRL_DISK_FOPS_DEFAULT Macro
PRL_DISK Macros

Default access mode that compiled in Parallels itself.

Syntax
#define PRL_DISK_FOPS_DEFAULT 0x00000000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_MASK Macro

PRL_DISK_FOPS_MASK Macro
PRL_DISK Macros

Type of the file access to use (15 file accessors is enough).

Syntax
#define PRL_DISK_FOPS_MASK 0x000003C0
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_MERGING Macro

PRL_DISK_FOPS_MERGING Macro
PRL_DISK Macros

DEPRECATED! Access mode with requests merging.

Syntax
#define PRL_DISK_FOPS_MERGING 0x000000C0
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_NONCACHED Macro

PRL_DISK_FOPS_NONCACHED Macro
PRL_DISK Macros

DEPRECATED! Access mode with file caching turned off.

Syntax
#define PRL_DISK_FOPS_NONCACHED 0x00000080
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_NORMAL Macro

PRL_DISK_FOPS_NORMAL Macro
PRL_DISK Macros

DEPRECATED! Normal access mode (default os)

Syntax
#define PRL_DISK_FOPS_NORMAL 0x00000040
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_FOPS_PCS Macro

PRL_DISK_FOPS_PCS Macro
PRL_DISK Macros

DEPRECATED! Access mode to files on PCS storage

Syntax
#define PRL_DISK_FOPS_PCS 0x000001C0
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_IGNORE_PROTECTION Macro

PRL_DISK_IGNORE_PROTECTION Macro
PRL_DISK Macros

Ignore storages read only flag (useful at disk creation)

Syntax
#define PRL_DISK_IGNORE_PROTECTION 0x00040000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_INVALID Macro

PRL_DISK_INVALID Macro
PRL_DISK Macros

Last (invalid).

Syntax
#define PRL_DISK_INVALID
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_NO_ERROR_CHECKING Macro

PRL_DISK_NO_ERROR_CHECKING Macro
PRL_DISK Macros

Force open of disk for reading without error checking

Syntax
#define PRL_DISK_NO_ERROR_CHECKING 0x00000400
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_NO_IMAGE_CREATION Macro

PRL_DISK_NO_IMAGE_CREATION Macro
Other Macros

So not create image when creating disk, just put reference to file in XML

Syntax
#define PRL_DISK_NO_IMAGE_CREATION 0x00001000
File

PrlDisk.h

Links
Other Macros


PRL_DISK_NO_SPACE_CHECKS Macro

PRL_DISK_NO_SPACE_CHECKS Macro
PRL_DISK Macros

Do not check host free space

Syntax
#define PRL_DISK_NO_SPACE_CHECKS 0x00008000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_NOT_LIMIT_HANDLES Macro

PRL_DISK_NOT_LIMIT_HANDLES Macro
PRL_DISK Macros

Do not use handle pool for disk image handles

Syntax
#define PRL_DISK_NOT_LIMIT_HANDLES 0x00004000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_NOTHING Macro

PRL_DISK_NOTHING Macro
PRL_DISK Macros

Nothing.

Syntax
#define PRL_DISK_NOTHING 0x00000000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_OPEN_FLAGS Type

PRL_DISK_OPEN_FLAGS Type
PRL_DISK Types

Storage/image/disk open parameters

Syntax
typedef PRL_UINT32 PRL_DISK_OPEN_FLAGS;
File

PrlDisk.h

Links
PRL_DISK Types


PRL_DISK_OPEN_FLAGS_PTR Type

PRL_DISK_OPEN_FLAGS_PTR Type
PRL_DISK Types
Syntax
typedef PRL_DISK_OPEN_FLAGS* PRL_DISK_OPEN_FLAGS_PTR;
File

PrlDisk.h

Links
PRL_DISK Types


PRL_DISK_PARAMETERS Structure

PRL_DISK_PARAMETERS Structure
Other Structs

Parallels disk parameters.

Syntax
typedef struct __PRL_DISK_PARAMETERS {
  PRL_UINT32 m_Heads;
  PRL_UINT32 m_Cylinders;
  PRL_UINT32 m_Sectors;
  PRL_UINT64 m_SizeInSectors;
  PRL_UINT32 m_BlockSize;
  PRL_UINT32 m_Parts;
  PRL_IMAGE_PARAMETERS_PTR m_Storages;
  PRL_GUID Uid;
  PRL_CHAR_PTR Name;
} PRL_DISK_PARAMETERS;
File

PrlDisk.h

Members

m_Storages
Following parameters are available only at SDK v3.

Remarks

Differs from internal due to lists classes

Links
Other Structs


PRL_DISK_PARAMETERS_PTR Type

PRL_DISK_PARAMETERS_PTR Type
PRL_DISK Types
Syntax
typedef PRL_DISK_PARAMETERS* PRL_DISK_PARAMETERS_PTR;
File

PrlDisk.h

Links
PRL_DISK Types


PRL_DISK_PROGRESS_COMPLETED Macro

PRL_DISK_PROGRESS_COMPLETED Macro
PRL_DISK Macros
Syntax
#define PRL_DISK_PROGRESS_COMPLETED 1005
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_PROGRESS_MAX Macro

PRL_DISK_PROGRESS_MAX Macro
PRL_DISK Macros
Syntax
#define PRL_DISK_PROGRESS_MAX 1000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_PROGRESS_MIN Macro

PRL_DISK_PROGRESS_MIN Macro
PRL_DISK Macros

States progress definition.

Syntax
#define PRL_DISK_PROGRESS_MIN 0
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_READ Macro

PRL_DISK_READ Macro
PRL_DISK Macros

Read

Syntax
#define PRL_DISK_READ 0x00000001
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_READ_LOCK Macro

PRL_DISK_READ_LOCK Macro
PRL_DISK Macros

ReadLock

Syntax
#define PRL_DISK_READ_LOCK 0x00000004
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_USE_RAW_DISK Macro

PRL_DISK_USE_RAW_DISK Macro
PRL_DISK Macros

Use raw disk for BootCamp partition (/dev/rdisk instead of /dev/disk)

Syntax
#define PRL_DISK_USE_RAW_DISK 0x00002000
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_WRITE Macro

PRL_DISK_WRITE Macro
PRL_DISK Macros

Write

Syntax
#define PRL_DISK_WRITE 0x00000002
File

PrlDisk.h

Links
PRL_DISK Macros


PRL_DISK_XML_CHANGE Macro

PRL_DISK_XML_CHANGE Macro
PRL_DISK Macros

This parameter is used when user need to change XML data but not access to the drive itself.

Syntax
#define PRL_DISK_XML_CHANGE 0x00000020
File

PrlDisk.h

Remarks

It can prevent situations when VirtualDisk library should unmount drive from host system to store small amount of data to the XML descriptor.

Links
PRL_DISK Macros


PRL_DISPATCHER_LISTEN_PORT Macro

PRL_DISPATCHER_LISTEN_PORT Macro
Other Macros
Syntax
#define PRL_DISPATCHER_LISTEN_PORT 64000
File

PrlPorts.h

Links
Other Macros


PRL_DISPATCHER_LISTEN_PORT_PMOBILE Macro

PRL_DISPATCHER_LISTEN_PORT_PMOBILE Macro
Other Macros
Syntax
#define PRL_DISPATCHER_LISTEN_PORT_PMOBILE 62319
File

PrlPorts.h

Links
Other Macros


PRL_DISPLAY_BUFFER_FORMAT Enumeration

PRL_DISPLAY_BUFFER_FORMAT Enumeration
Other Structs

Format of display buffer

Syntax
typedef enum _PRL_DISPLAY_BUFFER_FORMAT {
  PDBF_NO_CONVERSION = 0,
  PDBF_INDEX8 = 1,
  PDBF_RGB15 = 2,
  PDBF_RGB16 = 3,
  PDBF_RGB24 = 4,
  PDBF_BGR32 = 5,
  PDBF_RGB32 = 6,
  PDBF_YUV422x8 = 10,
  PDBF_YUV422x6 = 11,
  PDBF_YUV422x4 = 12,
  PDBF_YUV420 = 16
} PRL_DISPLAY_BUFFER_FORMAT;
File

PrlEnums.h

Links
Other Structs


PRL_DISPLAY_BUFFER_FORMAT_PTR Type

PRL_DISPLAY_BUFFER_FORMAT_PTR Type
Other Types
Syntax
typedef PRL_DISPLAY_BUFFER_FORMAT* PRL_DISPLAY_BUFFER_FORMAT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_DISPLAY_CODEC_COMPRESSION Enumeration

PRL_DISPLAY_CODEC_COMPRESSION Enumeration
Other Structs

Obsolete enum.

Syntax
typedef enum _PRL_DISPLAY_CODEC_COMPRESSION {
  PDCC_HIGH_COMPRESSION = 1<<15,
  PDCC_MEDIUM_COMPRESSION = 1<<16,
  PDCC_LOW_COMPRESSION = 1<<17,
  PDCC_NO_COMPRESSION = 1<<18
} PRL_DISPLAY_CODEC_COMPRESSION;
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec compression

Links
Other Structs


PRL_DISPLAY_CODEC_QUALITY Enumeration

PRL_DISPLAY_CODEC_QUALITY Enumeration
Other Structs

Obsolete enum.

Syntax
typedef enum _PRL_DISPLAY_CODEC_QUALITY {
  PDCQ_HIGH_QUALITY = 1<<0,
  PDCQ_MEDIUM_QUALITY = 1<<1,
  PDCQ_LOW_QUALITY = 1<<2
} PRL_DISPLAY_CODEC_QUALITY;
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec quality.

Links
Other Structs


PRL_DISPLAY_CODEC_TYPE Enumeration

PRL_DISPLAY_CODEC_TYPE Enumeration
Other Structs

Obsolete enum.

Syntax
typedef enum _PRL_DISPLAY_CODEC_TYPE {
  PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_HIGH_QUALITY_WITH_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITH_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_LOW_QUALITY_WITHOUT_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_LOW_QUALITY_WITH_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_MEDIUM_COMPRESSION
} PRL_DISPLAY_CODEC_TYPE;
File

PrlEnums.h

Remarks

Use display encodings at runtime for connection with new server

Notes

#PrlSrv_GetDisplayEncodingList Display codec types

Links
Other Structs


PRL_DISPLAY_CONFIG_MODE Enumeration

PRL_DISPLAY_CONFIG_MODE Enumeration
Other Structs

Display(s) configuration mode

Syntax
typedef enum _PRL_DISPLAY_CONFIG_MODE {
  PDCM_CLIENT_DISPLAY_INFO = (1 << 0),
  PDCM_HAS_HIDPI_DISPLAY = (1 << 1),
  PDCM_DO_NOT_RESTORE = (1 << 2),
  PDCM_RESTORE_DEFAULT = (1 << 3),
  PDCM_DISABLE_HIDPI_ADJUSTMENT = (1 << 4),
  PDCM_RETINA_MODE = (1 << 5),
  PDCM_ENABLE_HEADS = (1 << 6)
} PRL_DISPLAY_CONFIG_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_DISPLAY_CONFIG_MODE_PTR Type

PRL_DISPLAY_CONFIG_MODE_PTR Type
Other Types
Syntax
typedef PRL_DISPLAY_CONFIG_MODE* PRL_DISPLAY_CONFIG_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_DISTRO_MEDIA_TYPE Enumeration

PRL_DISTRO_MEDIA_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_DISTRO_MEDIA_TYPE {
  DMT_DISTRO = 0,
  DMT_LIVE_CD,
  DMT_MBR
} PRL_DISTRO_MEDIA_TYPE;
File

PrlEnums.h

Members

DMT_DISTRO
Ordinary distro
DMT_LIVE_CD
LiveCD
DMT_MBR
Media has Master Boot Record

Links
Other Structs


PRL_DISTRO_MEDIA_TYPE_PTR Type

PRL_DISTRO_MEDIA_TYPE_PTR Type
Other Types
Syntax
typedef PRL_DISTRO_MEDIA_TYPE* PRL_DISTRO_MEDIA_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_DOCK_ICON_TYPE Enumeration

PRL_DOCK_ICON_TYPE Enumeration
Other Structs

VM application icon type in Dock

Syntax
typedef enum _PRL_DOCK_ICON_TYPE {
  PIT_DOCK_ICON_SYSTEM = 0,
  PIT_DOCK_ICON_LIVE_SCREEN_SHOT = 1,
  PIT_DOCK_ICON_START_MENU = 2
} PRL_DOCK_ICON_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_DOCK_ICON_TYPE_PTR Type

PRL_DOCK_ICON_TYPE_PTR Type
Other Types
Syntax
typedef PRL_DOCK_ICON_TYPE* PRL_DOCK_ICON_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_DOUBLE Type

PRL_DOUBLE Type
PRL_DOUBLE Types

Double type

Syntax
typedef double PRL_DOUBLE;
File

PrlTypes.h

Links
PRL_DOUBLE Types


PRL_DOUBLE_PTR Type

PRL_DOUBLE_PTR Type
PRL_DOUBLE Types
Syntax
typedef PRL_DOUBLE* PRL_DOUBLE_PTR;
File

PrlTypes.h

Links
PRL_DOUBLE Types


PRL_DOUBLE_PTR_PTR Type

PRL_DOUBLE_PTR_PTR Type
PRL_DOUBLE Types
Syntax
typedef PRL_DOUBLE_PTR* PRL_DOUBLE_PTR_PTR;
File

PrlTypes.h

Links
PRL_DOUBLE Types


PRL_EFI_PARTITION Macro

PRL_EFI_PARTITION Macro
Other Macros
Syntax
#define PRL_EFI_PARTITION 0xEF
File

PrlDisk.h

Links
Other Macros


PRL_EFI_PARTITION_GPT Macro

PRL_EFI_PARTITION_GPT Macro
Other Macros

EFI system partition

Syntax
#define PRL_EFI_PARTITION_GPT 0xEE
File

PrlDisk.h

Links
Other Macros


PRL_EMPTY_PARTITION Macro

PRL_EMPTY_PARTITION Macro
Other Macros
Syntax
#define PRL_EMPTY_PARTITION 0x00
File

PrlDisk.h

Links
Other Macros


PRL_ENCRYPTION_FLAGS Enumeration

PRL_ENCRYPTION_FLAGS Enumeration
Other Structs

Encryption operations: Uses for PrlVm_Encrypt() / PrlVm_Decrypt operations

Syntax
typedef enum _PRL_ENCRYPTION_FLAGS {
  PEF_CHECK_PRECONDITIONS_ONLY = 1<<(PACF_MAX+1)
} PRL_ENCRYPTION_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_ENCRYPTION_FLAGS_PTR Type

PRL_ENCRYPTION_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_ENCRYPTION_FLAGS* PRL_ENCRYPTION_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR Macro

PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR PRL_RESULT_DECLARE_ERROR(100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_DENIED Macro

PRL_ERR_ACCESS_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_DENIED PRL_RESULT_DECLARE_ERROR(5)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS Macro

PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(381)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE Macro

PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE PRL_RESULT_DECLARE_ERROR(78)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD Macro

PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD PRL_RESULT_DECLARE_ERROR(360)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED Macro

PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_TO_CLONE_VM_DEVICE_DENIED PRL_RESULT_DECLARE_ERROR(509)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_TO_VM_DENIED Macro

PRL_ERR_ACCESS_TO_VM_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_TO_VM_DENIED PRL_RESULT_DECLARE_ERROR(239)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_TO_VM_HDD_DENIED Macro

PRL_ERR_ACCESS_TO_VM_HDD_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_TO_VM_HDD_DENIED PRL_RESULT_DECLARE_ERROR(508)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACCESS_TOKEN_INVALID Macro

PRL_ERR_ACCESS_TOKEN_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACCESS_TOKEN_INVALID PRL_RESULT_DECLARE_ERROR(60)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT Macro

PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTION_NOT_SUPPORTED_FOR_CT PRL_RESULT_DECLARE_ERROR(44003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE Macro

PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATE_NO_INSTALLED_LICENSE PRL_RESULT_DECLARE_ERROR(11704)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATE_TRIAL_LICENSE Macro

PRL_ERR_ACTIVATE_TRIAL_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATE_TRIAL_LICENSE PRL_RESULT_DECLARE_ERROR(11705)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE Macro

PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE PRL_RESULT_DECLARE_ERROR(11703)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR Macro

PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_COMMON_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(11718)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED Macro

PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_HTTP_REQUEST_FAILED PRL_RESULT_DECLARE_ERROR(11713)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED Macro

PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_OFFLINE_PERIOD_EXPIRED PRL_RESULT_DECLARE_ERROR(11717)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID Macro

PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID PRL_RESULT_DECLARE_ERROR(11707)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_SERVER_ERROR Macro

PRL_ERR_ACTIVATION_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(11706)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED Macro

PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_SERVER_HWIDS_AMOUNT_REACHED PRL_RESULT_DECLARE_ERROR(11710)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED Macro

PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_SERVER_KEY_IS_BLACKLISTED PRL_RESULT_DECLARE_ERROR(11709)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID Macro

PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_SERVER_KEY_IS_INVALID PRL_RESULT_DECLARE_ERROR(11708)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST Macro

PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_UNABLE_TO_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(11712)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_UPDATE_FAILED Macro

PRL_ERR_ACTIVATION_UPDATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_UPDATE_FAILED PRL_RESULT_DECLARE_ERROR(11716)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT Macro

PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT Macro
PRL_ERR Macros

  • license activation errors
* +++ ALIGNED VALUE TO 11700

Syntax
#define PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_FORMAT PRL_RESULT_DECLARE_ERROR(11700)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE Macro

PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_MESSAGE PRL_RESULT_DECLARE_ERROR(11701)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE Macro

PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_WRONG_CONFIRMATION_SIGNATURE PRL_RESULT_DECLARE_ERROR(11702)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE Macro

PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ACTIVATION_WRONG_SERVER_RESPONSE PRL_RESULT_DECLARE_ERROR(11711)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM Macro

PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ADD_ENCRYPTED_HDD_TO_NON_ENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44215)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED Macro

PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED PRL_RESULT_DECLARE_ERROR(317)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED Macro

PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED PRL_RESULT_DECLARE_ERROR(319)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION Macro

PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_OPERATION PRL_RESULT_DECLARE_ERROR(41103)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION Macro

PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ADMIN_CONFIRMATION_IS_REQUIRED_FOR_VM_OPERATION PRL_RESULT_DECLARE_ERROR(41104)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ALIGN_ON_4 Macro

PRL_ERR_ALIGN_ON_4 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ALIGN_ON_4 PRL_RESULT_DECLARE_ERROR(203)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER Macro

PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(252)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT Macro

PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT Macro
PRL_ERR Macros

Dispatcher service mode errors codes

Syntax
#define PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT PRL_RESULT_DECLARE_ERROR(361)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_API_INCOMPATIBLE Macro

PRL_ERR_API_INCOMPATIBLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_API_INCOMPATIBLE PRL_RESULT_DECLARE_ERROR(422)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_API_WASNT_INITIALIZED Macro

PRL_ERR_API_WASNT_INITIALIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_API_WASNT_INITIALIZED PRL_RESULT_DECLARE_ERROR(287)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5 Macro

PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_CANNOT_CALCULATE_MD5 PRL_RESULT_DECLARE_ERROR(41514)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER Macro

PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_CANNOT_CHANGE_OWNER PRL_RESULT_DECLARE_ERROR(41510)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM Macro

PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_CANNOT_EXTRACT_VM PRL_RESULT_DECLARE_ERROR(41508)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE Macro

PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_CANNOT_MOVE_VM_BUNDLE PRL_RESULT_DECLARE_ERROR(41512)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR Macro

PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_DIR PRL_RESULT_DECLARE_ERROR(41502)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS Macro

PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_DOWNLOAD_PARENT_PATH_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(41503)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE Macro

PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_DOWNLOAD_PATH_CANNOT_CREATE PRL_RESULT_DECLARE_ERROR(41504)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND Macro

PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_FOUND PRL_RESULT_DECLARE_ERROR(41505)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED Macro

PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_DOWNLOAD_UTILITY_NOT_STARTED PRL_RESULT_DECLARE_ERROR(41506)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_EXIT_WITH_ERROR Macro

PRL_ERR_APPLIANCE_EXIT_WITH_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_EXIT_WITH_ERROR PRL_RESULT_DECLARE_ERROR(41507)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS Macro

PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_INSTALL_ALREADY_IN_PROCESS PRL_RESULT_DECLARE_ERROR(41509)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED Macro

PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_INSTALL_WAS_NOT_STARTED PRL_RESULT_DECLARE_ERROR(41513)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_INVALID_CONFIG Macro

PRL_ERR_APPLIANCE_INVALID_CONFIG Macro
PRL_ERR Macros

Install appliance task errors +++ ALIGNED VALUE TO 41500

Syntax
#define PRL_ERR_APPLIANCE_INVALID_CONFIG PRL_RESULT_DECLARE_ERROR(41500)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_MISMATCH_MD5 Macro

PRL_ERR_APPLIANCE_MISMATCH_MD5 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_MISMATCH_MD5 PRL_RESULT_DECLARE_ERROR(41515)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE Macro

PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE PRL_RESULT_DECLARE_ERROR(41511)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_NO_VM_BUNDLE Macro

PRL_ERR_APPLIANCE_NO_VM_BUNDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_NO_VM_BUNDLE PRL_ERR_APPLIANCE_NAME_NOT_MATCH_VM_BUNDLE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_APPLIANCE_USER_NOT_FOUND Macro

PRL_ERR_APPLIANCE_USER_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_APPLIANCE_USER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(41501)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED Macro

PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_ALREADY_ATTACHED PRL_RESULT_DECLARE_ERROR(54005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED Macro

PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_BUSE_NOT_MOUNTED PRL_RESULT_DECLARE_ERROR(54006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED Macro

PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_CUSTOM_BACKUP_SERVER_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(54002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED Macro

PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_FORMAT_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(54004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR Macro

PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR Macro
PRL_ERR Macros

Attach backup as a block device errors +++ ALIGNED VALUE TO 54000

Syntax
#define PRL_ERR_ATTACH_BACKUP_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(54000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL Macro

PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_INVALID_STORAGE_URL PRL_RESULT_DECLARE_ERROR(54001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_PROTO_ERROR Macro

PRL_ERR_ATTACH_BACKUP_PROTO_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_PROTO_ERROR PRL_RESULT_DECLARE_ERROR(54003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED Macro

PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_BACKUP_URL_CHANGE_PROHIBITED PRL_RESULT_DECLARE_ERROR(54007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ATTACH_TO_TASK_BAD_SESSION Macro

PRL_ERR_ATTACH_TO_TASK_BAD_SESSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ATTACH_TO_TASK_BAD_SESSION PRL_RESULT_DECLARE_ERROR(349)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED Macro

PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(543)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM Macro

PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_AUTH_REQUIRED_TO_ENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44203)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_AUTHENTICATION_FAILED Macro

PRL_ERR_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(330)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED Macro

PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_ACCESS_TO_VM_DENIED PRL_RESULT_DECLARE_ERROR(37003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_ACRONIS_ERR Macro

PRL_ERR_BACKUP_ACRONIS_ERR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_ACRONIS_ERR PRL_RESULT_DECLARE_ERROR(37016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_BACKUP_CMD_FAILED Macro

PRL_ERR_BACKUP_BACKUP_CMD_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_BACKUP_CMD_FAILED PRL_RESULT_DECLARE_ERROR(37018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_BACKUP_NOT_FOUND Macro

PRL_ERR_BACKUP_BACKUP_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_BACKUP_NOT_FOUND PRL_RESULT_DECLARE_ERROR(37011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND Macro

PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_BACKUP_UUID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(37004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY Macro

PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CANNOT_CREATE_DIRECTORY PRL_RESULT_DECLARE_ERROR(37009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY Macro

PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CANNOT_REMOVE_DIRECTORY PRL_RESULT_DECLARE_ERROR(37012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS Macro

PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CANNOT_SET_PERMISSIONS PRL_RESULT_DECLARE_ERROR(37024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE Macro

PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CREATE_NOT_ENOUGH_FREE_DISK_SPACE PRL_RESULT_DECLARE_ERROR(37028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED Macro

PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CREATE_SNAPSHOT_FAILED PRL_RESULT_DECLARE_ERROR(37005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST Macro

PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_CT_ID_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(37033)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST Macro

PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_DIRECTORY_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(37008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_INTERNAL_ERROR Macro

PRL_ERR_BACKUP_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(37001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR Macro

PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR Macro
PRL_ERR Macros

VM Backup errors +++ ALIGNED VALUE TO 37000

Syntax
#define PRL_ERR_BACKUP_INTERNAL_PROTO_ERROR PRL_RESULT_DECLARE_ERROR(37000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_LOCKED_FOR_READING Macro

PRL_ERR_BACKUP_LOCKED_FOR_READING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_LOCKED_FOR_READING PRL_RESULT_DECLARE_ERROR(37013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_LOCKED_FOR_WRITING Macro

PRL_ERR_BACKUP_LOCKED_FOR_WRITING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_LOCKED_FOR_WRITING PRL_RESULT_DECLARE_ERROR(37014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_REGISTER_VM_FAILED Macro

PRL_ERR_BACKUP_REGISTER_VM_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_REGISTER_VM_FAILED PRL_RESULT_DECLARE_ERROR(37007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED Macro

PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_REMOVE_PERMISSIONS_DENIED PRL_RESULT_DECLARE_ERROR(37034)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD Macro

PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_REQUIRE_LOGIN_PASSWORD PRL_RESULT_DECLARE_ERROR(37015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY Macro

PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_CANNOT_CREATE_DIRECTORY PRL_RESULT_DECLARE_ERROR(37041)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_CMD_FAILED Macro

PRL_ERR_BACKUP_RESTORE_CMD_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_CMD_FAILED PRL_RESULT_DECLARE_ERROR(37019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST Macro

PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_DIRECTORY_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(37040)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR Macro

PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(37038)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR Macro

PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_INTERNAL_PROTO_ERROR PRL_RESULT_DECLARE_ERROR(37039)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE Macro

PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_NOT_ENOUGH_FREE_DISK_SPACE PRL_RESULT_DECLARE_ERROR(37027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED Macro

PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_PROHIBIT_WHEN_ATTACHED PRL_RESULT_DECLARE_ERROR(37042)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_RESTORE_VM_RUNNING Macro

PRL_ERR_BACKUP_RESTORE_VM_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_RESTORE_VM_RUNNING PRL_RESULT_DECLARE_ERROR(37010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM Macro

PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_SNAPSHOT_OF_PAUSED_VM PRL_RESULT_DECLARE_ERROR(37021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED Macro

PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_SWITCH_TO_SNAPSHOT_FAILED PRL_RESULT_DECLARE_ERROR(37006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_TIMEOUT_EXCEEDED Macro

PRL_ERR_BACKUP_TIMEOUT_EXCEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_TIMEOUT_EXCEEDED PRL_RESULT_DECLARE_ERROR(37002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BACKUP_TOOL_CANNOT_START Macro

PRL_ERR_BACKUP_TOOL_CANNOT_START Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BACKUP_TOOL_CANNOT_START PRL_RESULT_DECLARE_ERROR(37032)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(20)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BAD_PARAMETERS Macro

PRL_ERR_BAD_PARAMETERS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BAD_PARAMETERS PRL_RESULT_DECLARE_ERROR(83)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(32)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(27)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUFFER_OVERRUN Macro

PRL_ERR_BUFFER_OVERRUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUFFER_OVERRUN PRL_RESULT_DECLARE_ERROR(6)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_ENTRY_ALREADY_EXIST Macro

PRL_ERR_BUSE_ENTRY_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUSE_ENTRY_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(52003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED Macro

PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUSE_ENTRY_ALREADY_INITIALIZED PRL_RESULT_DECLARE_ERROR(52004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_ENTRY_INVALID Macro

PRL_ERR_BUSE_ENTRY_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUSE_ENTRY_INVALID PRL_RESULT_DECLARE_ERROR(52002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_ENTRY_IO_ERROR Macro

PRL_ERR_BUSE_ENTRY_IO_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUSE_ENTRY_IO_ERROR PRL_RESULT_DECLARE_ERROR(52005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_INTERNAL_ERROR Macro

PRL_ERR_BUSE_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_BUSE_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(52001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_BUSE_NOT_MOUNTED Macro

PRL_ERR_BUSE_NOT_MOUNTED Macro
PRL_ERR Macros

BUSE filesystem errors +++ ALIGNED VALUE TO 52000

Syntax
#define PRL_ERR_BUSE_NOT_MOUNTED PRL_RESULT_DECLARE_ERROR(52000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE Macro

PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE PRL_RESULT_DECLARE_ERROR(306)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM Macro

PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_CREATE_LINKED_CLONE_FOR_NOT_STOPPED_VM PRL_RESULT_DECLARE_ERROR(15469)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE Macro

PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_EDIT_FIREWALL_AT_TRANS_VM_STATE PRL_RESULT_DECLARE_ERROR(540)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM Macro

PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_EDIT_HARDWARE_FOR_PAUSED_VM PRL_RESULT_DECLARE_ERROR(535)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM Macro

PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM PRL_RESULT_DECLARE_ERROR(445)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM Macro

PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM PRL_RESULT_DECLARE_ERROR(444)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM Macro

PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_RUN_LINKED_CLONE_FOR_NOT_STOPPED_VM PRL_RESULT_DECLARE_ERROR(15465)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE Macro

PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANNOT_SAVE_REMOTE_DEVICE_STATE PRL_RESULT_DECLARE_ERROR(479)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_ALOCA_MEM_FILE_COPY Macro

PRL_ERR_CANT_ALOCA_MEM_FILE_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_ALOCA_MEM_FILE_COPY PRL_RESULT_DECLARE_ERROR(109)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN Macro

PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_DEFAULT_PLUGIN_BY_NON_ADMIN PRL_RESULT_DECLARE_ERROR(44223)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS Macro

PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(339)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_HOST_ID Macro

PRL_ERR_CANT_CHANGE_HOST_ID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_HOST_ID PRL_RESULT_DECLARE_ERROR(561)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE PRL_RESULT_DECLARE_ERROR(394)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_FILE PRL_RESULT_DECLARE_ERROR(281)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE PRL_RESULT_DECLARE_ERROR(393)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL Macro

PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL PRL_RESULT_DECLARE_ERROR(560)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER Macro

PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_PROXY_MANAGER_URL_BY_NON_PRIVILEGED_USER PRL_RESULT_DECLARE_ERROR(562)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN Macro

PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN PRL_RESULT_DECLARE_ERROR(574)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER Macro

PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CHANGE_WEB_PORTAL_DOMAIN_BY_NON_PRIVILEGED_USER PRL_RESULT_DECLARE_ERROR(575)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONFIGURE_PARTITION_HDD Macro

PRL_ERR_CANT_CONFIGURE_PARTITION_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONFIGURE_PARTITION_HDD PRL_RESULT_DECLARE_ERROR(419)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD Macro

PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD PRL_RESULT_DECLARE_ERROR(338)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONNECT_TO_DISPATCHER Macro

PRL_ERR_CANT_CONNECT_TO_DISPATCHER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONNECT_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(249)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY Macro

PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONNECT_TO_DISPATCHER_ITERATIVELY PRL_RESULT_DECLARE_ERROR(510)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_CONFIG Macro

PRL_ERR_CANT_CONVERT_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_CONFIG PRL_RESULT_DECLARE_ERROR(45002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE Macro

PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE PRL_RESULT_DECLARE_ERROR(310)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS Macro

PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS PRL_RESULT_DECLARE_ERROR(385)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD Macro

PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_OTHER_VENDOR_HDD PRL_RESULT_DECLARE_ERROR(45004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM Macro

PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_OTHER_VENDOR_VM PRL_RESULT_DECLARE_ERROR(45003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT Macro

PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT PRL_RESULT_DECLARE_ERROR(308)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT Macro

PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT PRL_RESULT_DECLARE_ERROR(309)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_DISK_IMAGE Macro

PRL_ERR_CANT_CREATE_DISK_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_DISK_IMAGE PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_FLOPPY_IMAGE Macro

PRL_ERR_CANT_CREATE_FLOPPY_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_FLOPPY_IMAGE PRL_RESULT_DECLARE_ERROR(99)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_HDD_IMAGE Macro

PRL_ERR_CANT_CREATE_HDD_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_HDD_IMAGE PRL_RESULT_DECLARE_ERROR(98)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE Macro

PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE PRL_RESULT_DECLARE_ERROR(389)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE Macro

PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE PRL_RESULT_DECLARE_ERROR(101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE Macro

PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE PRL_RESULT_DECLARE_ERROR(400)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_DELETE_FILE Macro

PRL_ERR_CANT_DELETE_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_DELETE_FILE PRL_RESULT_DECLARE_ERROR(282)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED Macro

PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_EDIT_EXPIRATION_VM_IS_PROTECTED PRL_RESULT_DECLARE_ERROR(44245)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_EDIT_SUSPENDED_VM Macro

PRL_ERR_CANT_EDIT_SUSPENDED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_EDIT_SUSPENDED_VM PRL_RESULT_DECLARE_ERROR(104)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_GET_FILE_PERMISSIONS Macro

PRL_ERR_CANT_GET_FILE_PERMISSIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_GET_FILE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(382)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_INIT_REAL_CPUS_INFO Macro

PRL_ERR_CANT_INIT_REAL_CPUS_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_INIT_REAL_CPUS_INFO PRL_RESULT_DECLARE_ERROR(272)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_PARSE_DISP_EVENT Macro

PRL_ERR_CANT_PARSE_DISP_EVENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_PARSE_DISP_EVENT PRL_RESULT_DECLARE_ERROR(244)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_PARSE_VM_CONFIG Macro

PRL_ERR_CANT_PARSE_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_PARSE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(229)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_PREPARE_RECONFIG_DATA Macro

PRL_ERR_CANT_PREPARE_RECONFIG_DATA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_PREPARE_RECONFIG_DATA PRL_RESULT_DECLARE_ERROR(45006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE Macro

PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_PROTECT_VM_WRONG_EXPIRATION_DATE PRL_RESULT_DECLARE_ERROR(44251)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RECONFIG_GUEST_OS Macro

PRL_ERR_CANT_RECONFIG_GUEST_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RECONFIG_GUEST_OS PRL_RESULT_DECLARE_ERROR(45005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RECREATE_HDD Macro

PRL_ERR_CANT_RECREATE_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RECREATE_HDD PRL_RESULT_DECLARE_ERROR(329)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_REMOVE_DIR_ENTRY Macro

PRL_ERR_CANT_REMOVE_DIR_ENTRY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_REMOVE_DIR_ENTRY PRL_RESULT_DECLARE_ERROR(408)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_REMOVE_ENTRY Macro

PRL_ERR_CANT_REMOVE_ENTRY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_REMOVE_ENTRY PRL_RESULT_DECLARE_ERROR(82)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN Macro

PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN PRL_RESULT_DECLARE_ERROR(383)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RENAME_DIR_ENTRY Macro

PRL_ERR_CANT_RENAME_DIR_ENTRY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RENAME_DIR_ENTRY PRL_RESULT_DECLARE_ERROR(409)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RENAME_ENTRY Macro

PRL_ERR_CANT_RENAME_ENTRY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RENAME_ENTRY PRL_RESULT_DECLARE_ERROR(81)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE Macro

PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE PRL_RESULT_DECLARE_ERROR(333)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RESIZE_HDD Macro

PRL_ERR_CANT_RESIZE_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RESIZE_HDD PRL_RESULT_DECLARE_ERROR(484)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_RESOLVE_HOSTNAME Macro

PRL_ERR_CANT_RESOLVE_HOSTNAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_RESOLVE_HOSTNAME PRL_RESULT_DECLARE_ERROR(511)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED Macro

PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_REVERT_VM_SINCE_VTD_DEVICE_ALREADY_USED PRL_RESULT_DECLARE_ERROR(469)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN Macro

PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN PRL_RESULT_DECLARE_ERROR(44224)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT Macro

PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_SET_DEFAULT_ENCRYPTION_PLUGIN_BY_WRONG_FORMAT PRL_RESULT_DECLARE_ERROR(44225)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER Macro

PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_START_VM_SINCE_NO_VTD_DRIVER PRL_RESULT_DECLARE_ERROR(461)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED Macro

PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_START_VM_SINCE_VTD_DEVICE_ALREADY_USED PRL_RESULT_DECLARE_ERROR(463)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP Macro

PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_ERROR(20010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION Macro

PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION PRL_RESULT_DECLARE_ERROR(417)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_TO_START_VM_TEMPLATE Macro

PRL_ERR_CANT_TO_START_VM_TEMPLATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_TO_START_VM_TEMPLATE PRL_RESULT_DECLARE_ERROR(368)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_UNPACK_ARCHIVE Macro

PRL_ERR_CANT_UNPACK_ARCHIVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_UNPACK_ARCHIVE PRL_RESULT_DECLARE_ERROR(45001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANT_UPDATE_DEVICE_INFO Macro

PRL_ERR_CANT_UPDATE_DEVICE_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANT_UPDATE_DEVICE_INFO PRL_RESULT_DECLARE_ERROR(332)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT Macro

PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT PRL_RESULT_DECLARE_ERROR(386)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 Macro

PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 PRL_RESULT_DECLARE_ERROR(387)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_CDD_IMAGE_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(208)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CHANGESID_FAILED Macro

PRL_ERR_CHANGESID_FAILED Macro
PRL_ERR Macros

Vm changeSID errors +++ ALIGNED VALUE TO 41200

Syntax
#define PRL_ERR_CHANGESID_FAILED PRL_RESULT_DECLARE_ERROR(41200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE Macro

PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CHANGESID_GUEST_TOOLS_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(41201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CHANGESID_NOT_AVAILABLE Macro

PRL_ERR_CHANGESID_NOT_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CHANGESID_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(41204)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CHANGESID_NOT_SUPPORTED Macro

PRL_ERR_CHANGESID_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CHANGESID_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(41203)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CHANGESID_VM_START_FAILED Macro

PRL_ERR_CHANGESID_VM_START_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CHANGESID_VM_START_FAILED PRL_RESULT_DECLARE_ERROR(41202)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM Macro

PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CI_CANNOT_COPY_IMAGE_NON_STOPPED_VM PRL_RESULT_DECLARE_ERROR(46701)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL Macro

PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL Macro
PRL_ERR Macros

Copy device image errors +++ ALIGNED VALUE TO 46700

Syntax
#define PRL_ERR_CI_DEVICE_IS_NOT_VIRTUAL PRL_RESULT_DECLARE_ERROR(46700)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CI_PERMISSIONS_DENIED Macro

PRL_ERR_CI_PERMISSIONS_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CI_PERMISSIONS_DENIED PRL_RESULT_DECLARE_ERROR(46702)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CLONE_OPERATION_CANCELED Macro

PRL_ERR_CLONE_OPERATION_CANCELED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CLONE_OPERATION_CANCELED PRL_RESULT_DECLARE_ERROR(107)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CLUSTER_RESOURCE_ERROR Macro

PRL_ERR_CLUSTER_RESOURCE_ERROR Macro
PRL_ERR Macros

Cluster resource manipulation errors +++ ALIGNED VALUE TO 46900

Syntax
#define PRL_ERR_CLUSTER_RESOURCE_ERROR PRL_RESULT_DECLARE_ERROR(46900)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COM_DEVICE_ALREADY_EXIST Macro

PRL_ERR_COM_DEVICE_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COM_DEVICE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(254)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED Macro

PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(215)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST Macro

PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(217)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE Macro

PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE PRL_RESULT_DECLARE_ERROR(421)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE Macro

PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE PRL_RESULT_DECLARE_ERROR(271)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED Macro

PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED PRL_RESULT_DECLARE_ERROR(122)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COMPACT_ALREADY_SWITCHED_ON Macro

PRL_ERR_COMPACT_ALREADY_SWITCHED_ON Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COMPACT_ALREADY_SWITCHED_ON PRL_RESULT_DECLARE_SUCCESS(494)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COMPACT_WRONG_VM_STATE Macro

PRL_ERR_COMPACT_WRONG_VM_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COMPACT_WRONG_VM_STATE PRL_RESULT_DECLARE_ERROR(489)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONCURRENT_COMMAND_EXECUTING Macro

PRL_ERR_CONCURRENT_COMMAND_EXECUTING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONCURRENT_COMMAND_EXECUTING PRL_RESULT_DECLARE_ERROR(242)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID Macro

PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID PRL_RESULT_DECLARE_ERROR(346)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID Macro

PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID PRL_RESULT_DECLARE_ERROR(347)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIG_EDIT_COLLISION Macro

PRL_ERR_CONFIG_EDIT_COLLISION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIG_EDIT_COLLISION PRL_RESULT_DECLARE_ERROR(323)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIG_FILE_NOT_SET Macro

PRL_ERR_CONFIG_FILE_NOT_SET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIG_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(38)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN Macro

PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIGURE_GENERIC_PCI_TASK_ALREADY_RUN PRL_RESULT_DECLARE_ERROR(459)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED Macro

PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIRMATION_MODE_ALREADY_DISABLED PRL_RESULT_DECLARE_ERROR(41102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED Macro

PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONFIRMATION_MODE_ALREADY_ENABLED PRL_RESULT_DECLARE_ERROR(41101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN Macro

PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN Macro
PRL_ERR Macros

confirmation errors +++ ALIGNED VALUE TO 41100

Syntax
#define PRL_ERR_CONFIRMATION_MODE_UNABLE_CHANGE_BY_NOT_ADMIN PRL_RESULT_DECLARE_ERROR(41100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED Macro

PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_CLIENT_CERTIFICATE_EXPIRED PRL_RESULT_DECLARE_ERROR(607)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID Macro

PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_CLIENT_CERTIFICATE_INVALID PRL_RESULT_DECLARE_ERROR(606)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED Macro

PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_CLIENT_CERTIFICATE_REVOKED PRL_RESULT_DECLARE_ERROR(608)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED Macro

PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_SERVER_CERTIFICATE_EXPIRED PRL_RESULT_DECLARE_ERROR(610)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID Macro

PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_SERVER_CERTIFICATE_INVALID PRL_RESULT_DECLARE_ERROR(609)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED Macro

PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_SERVER_CERTIFICATE_REVOKED PRL_RESULT_DECLARE_ERROR(611)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL Macro

PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONN_UNABLE_TO_ESTABLISH_TRUSTED_CHANNEL PRL_RESULT_DECLARE_ERROR(605)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONNECT_TO_MOUNTER Macro

PRL_ERR_CONNECT_TO_MOUNTER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONNECT_TO_MOUNTER PRL_RESULT_DECLARE_ERROR(46602)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONV_HD_CONFLICT Macro

PRL_ERR_CONV_HD_CONFLICT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONV_HD_CONFLICT PRL_RESULT_DECLARE_ERROR(41604)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED Macro

PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONV_HD_DISK_TOOL_NOT_STARTED PRL_RESULT_DECLARE_ERROR(41603)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONV_HD_EXIT_WITH_ERROR Macro

PRL_ERR_CONV_HD_EXIT_WITH_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONV_HD_EXIT_WITH_ERROR PRL_RESULT_DECLARE_ERROR(41601)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION Macro

PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONV_HD_NO_ONE_DISK_FOR_CONVERSION PRL_RESULT_DECLARE_ERROR(41602)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONV_HD_WRONG_VM_STATE Macro

PRL_ERR_CONV_HD_WRONG_VM_STATE Macro
PRL_ERR Macros

Convert disks task errors +++ ALIGNED VALUE TO 41600

Syntax
#define PRL_ERR_CONV_HD_WRONG_VM_STATE PRL_RESULT_DECLARE_ERROR(41600)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED Macro

PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED Macro
PRL_ERR Macros

Vm convert errors +++ ALIGNED VALUE TO 41300

Syntax
#define PRL_ERR_CONVERT_3RD_PARTY_VM_FAILED PRL_RESULT_DECLARE_ERROR(41300)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE Macro

PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_3RD_PARTY_VM_NO_SPACE PRL_RESULT_DECLARE_ERROR(41301)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_EFI_CONFIG_INVALID Macro

PRL_ERR_CONVERT_EFI_CONFIG_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_EFI_CONFIG_INVALID PRL_RESULT_DECLARE_ERROR(41305)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED Macro

PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_EFI_GUEST_OS_UNSUPPORTED PRL_RESULT_DECLARE_ERROR(41306)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED Macro

PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_GUEST_OS_IS_HIBERNATED PRL_RESULT_DECLARE_ERROR(41307)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND Macro

PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_HDD_NO_GUEST_OS_FOUND PRL_RESULT_DECLARE_ERROR(41308)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CONVERT_NO_GUEST_OS_FOUND Macro

PRL_ERR_CONVERT_NO_GUEST_OS_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CONVERT_NO_GUEST_OS_FOUND PRL_RESULT_DECLARE_ERROR(41304)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR Macro

PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COPY_CT_TMPL_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(31036)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COPY_VM_INFO_FILE Macro

PRL_ERR_COPY_VM_INFO_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COPY_VM_INFO_FILE PRL_RESULT_DECLARE_ERROR(548)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_CANCELLED Macro

PRL_ERR_CORE_STATE_CANCELLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_CANCELLED PRL_RESULT_DECLARE_ERROR(20018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG Macro

PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(20004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE Macro

PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE PRL_RESULT_DECLARE_ERROR(20003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE Macro

PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE PRL_RESULT_DECLARE_ERROR(20002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_ERROR_COMMON Macro

PRL_ERR_CORE_STATE_ERROR_COMMON Macro
PRL_ERR Macros

  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

Syntax
#define PRL_ERR_CORE_STATE_ERROR_COMMON PRL_RESULT_DECLARE_ERROR(20000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_INV_SAV_VERSION Macro

PRL_ERR_CORE_STATE_INV_SAV_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_INV_SAV_VERSION PRL_RESULT_DECLARE_ERROR(20001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_NO_FILE Macro

PRL_ERR_CORE_STATE_NO_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_NO_FILE PRL_RESULT_DECLARE_ERROR(20017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_VM_WOULD_RESTART Macro

PRL_ERR_CORE_STATE_VM_WOULD_RESTART Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_VM_WOULD_RESTART PRL_RESULT_DECLARE_ERROR(20019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CORE_STATE_VM_WOULD_STOP Macro

PRL_ERR_CORE_STATE_VM_WOULD_STOP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CORE_STATE_VM_WOULD_STOP PRL_RESULT_DECLARE_ERROR(20012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COULD_NOT_START_FIREWALL_TOOL Macro

PRL_ERR_COULD_NOT_START_FIREWALL_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COULD_NOT_START_FIREWALL_TOOL PRL_RESULT_DECLARE_ERROR(533)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE Macro

PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(295)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE Macro

PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(296)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE Macro

PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_COULDNT_TO_CREATE_HDD_LINKED_CLONE PRL_RESULT_DECLARE_ERROR(514)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CPU_RESTART Macro

PRL_ERR_CPU_RESTART Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CPU_RESTART PRL_RESULT_DECLARE_ERROR(380)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CPU_SHUTDOWN Macro

PRL_ERR_CPU_SHUTDOWN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CPU_SHUTDOWN PRL_RESULT_DECLARE_ERROR(379)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_BOOTABLE_ISO Macro

PRL_ERR_CREATE_BOOTABLE_ISO Macro
PRL_ERR Macros

Unattended ISO errors +++ ALIGNED VALUE TO 40000

Syntax
#define PRL_ERR_CREATE_BOOTABLE_ISO PRL_RESULT_DECLARE_ERROR(40000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE Macro

PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_HARD_DISK_WITH_ZERO_SIZE PRL_RESULT_DECLARE_ERROR(2003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_PRIVELEGED_PROCESS Macro

PRL_ERR_CREATE_PRIVELEGED_PROCESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_PRIVELEGED_PROCESS PRL_RESULT_DECLARE_ERROR(17002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT PRL_RESULT_DECLARE_ERROR(36005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_PAUSED PRL_RESULT_DECLARE_ERROR(36003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS PRL_RESULT_DECLARE_ERROR(36026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CREATE_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CT_IS_RUNNING Macro

PRL_ERR_CT_IS_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CT_IS_RUNNING PRL_RESULT_DECLARE_ERROR(44008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST Macro

PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CT_MIGRATE_ID_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(31044)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CT_MIGRATE_INTERNAL_ERROR Macro

PRL_ERR_CT_MIGRATE_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CT_MIGRATE_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(31035)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS Macro

PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CT_MIGRATE_TARGET_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(31049)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CT_NOT_FOUND Macro

PRL_ERR_CT_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CT_NOT_FOUND PRL_RESULT_DECLARE_ERROR(27027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CVSRC_IO_ERROR Macro

PRL_ERR_CVSRC_IO_ERROR Macro
PRL_ERR Macros

Captured Video Source errors +++ ALIGNED VALUE TO 46800

Syntax
#define PRL_ERR_CVSRC_IO_ERROR PRL_RESULT_DECLARE_ERROR(46800)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CVSRC_NO_CHANNEL Macro

PRL_ERR_CVSRC_NO_CHANNEL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CVSRC_NO_CHANNEL PRL_RESULT_DECLARE_ERROR(46802)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_CVSRC_NO_OPEN_REQUEST Macro

PRL_ERR_CVSRC_NO_OPEN_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_CVSRC_NO_OPEN_REQUEST PRL_RESULT_DECLARE_ERROR(46801)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE Macro

PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATE_NO_INSTALLED_LICENSE PRL_RESULT_DECLARE_ERROR(11720)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATE_TRIAL_LICENSE Macro

PRL_ERR_DEACTIVATE_TRIAL_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATE_TRIAL_LICENSE PRL_RESULT_DECLARE_ERROR(11721)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE Macro

PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATE_WRONG_TYPE_OF_ACTIVE_LICENSE PRL_RESULT_DECLARE_ERROR(11719)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR Macro

PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_COMMON_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(11729)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED Macro

PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_HTTP_REQUEST_FAILED PRL_RESULT_DECLARE_ERROR(11728)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND Macro

PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_OLD_HWID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(11730)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID Macro

PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_SERVER_ACTIVATION_ID_IS_INVALID PRL_RESULT_DECLARE_ERROR(11723)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_SERVER_ERROR Macro

PRL_ERR_DEACTIVATION_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(11722)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED Macro

PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_SERVER_KEY_IS_BLACKLISTED PRL_RESULT_DECLARE_ERROR(11725)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID Macro

PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_SERVER_KEY_IS_INVALID PRL_RESULT_DECLARE_ERROR(11724)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST Macro

PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_UNABLE_TO_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(11727)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE Macro

PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEACTIVATION_WRONG_SERVER_RESPONSE PRL_RESULT_DECLARE_ERROR(11726)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DELETE_UNFINISHED_STATE_FAILED Macro

PRL_ERR_DELETE_UNFINISHED_STATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DELETE_UNFINISHED_STATE_FAILED PRL_RESULT_DECLARE_ERROR(577)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DELETING_VM_FROM_CATALOGUE Macro

PRL_ERR_DELETING_VM_FROM_CATALOGUE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DELETING_VM_FROM_CATALOGUE PRL_RESULT_DECLARE_ERROR(253)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_ALREADY_CONNECTED Macro

PRL_ERR_DEV_ALREADY_CONNECTED Macro
PRL_ERR Macros

  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

Syntax
#define PRL_ERR_DEV_ALREADY_CONNECTED PRL_RESULT_DECLARE_ERROR(9000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_ALREADY_DISCONNECTED Macro

PRL_ERR_DEV_ALREADY_DISCONNECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_ALREADY_DISCONNECTED PRL_RESULT_DECLARE_ERROR(9001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_DISABLE_AFTER_LOST Macro

PRL_ERR_DEV_DISABLE_AFTER_LOST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_DISABLE_AFTER_LOST PRL_RESULT_DECLARE_ERROR(343)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_FLOPPY_CONNECT_FAILED Macro

PRL_ERR_DEV_FLOPPY_CONNECT_FAILED Macro
PRL_ERR Macros

ALIGNED VALUE TO 1000

Syntax
#define PRL_ERR_DEV_FLOPPY_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(1000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII Macro

PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_MAX_CD_EXCEEDED_WITH_DISABLED_CLIENT_SCSII PRL_RESULT_DECLARE_ERROR(10014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED Macro

PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED PRL_RESULT_DECLARE_ERROR(10001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_MAX_NUMBER_EXCEEDED Macro

PRL_ERR_DEV_MAX_NUMBER_EXCEEDED Macro
PRL_ERR Macros

  • Other

+++ ALIGNED VALUE TO 10000

Syntax
#define PRL_ERR_DEV_MAX_NUMBER_EXCEEDED PRL_RESULT_DECLARE_ERROR(10000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED Macro
PRL_ERR Macros

  • Parallel Port

+++ ALIGNED VALUE TO 7000

Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_PRINTER_OVERFLOW Macro

PRL_ERR_DEV_PRINTER_OVERFLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_PRINTER_OVERFLOW PRL_RESULT_DECLARE_ERROR(9003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED Macro
PRL_ERR Macros

  • Serial Port

+++ ALIGNED VALUE TO 6000

Syntax
#define PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_BUSY Macro

PRL_ERR_DEV_USB_BUSY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_BUSY PRL_RESULT_DECLARE_ERROR(8005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_CHANGEPID Macro

PRL_ERR_DEV_USB_CHANGEPID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_CHANGEPID PRL_RESULT_DECLARE_ERROR(8007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_CONNECT_DENIED Macro

PRL_ERR_DEV_USB_CONNECT_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_CONNECT_DENIED PRL_RESULT_DECLARE_ERROR(587)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED Macro

PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED PRL_RESULT_DECLARE_ERROR(8003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2 Macro

PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED2 PRL_RESULT_DECLARE_ERROR(8004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED Macro

PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED PRL_RESULT_DECLARE_ERROR(8001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_NO_FREE_PORTS Macro

PRL_ERR_DEV_USB_NO_FREE_PORTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_NO_FREE_PORTS PRL_RESULT_DECLARE_ERROR(8002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_NOT_CONFIGURED Macro

PRL_ERR_DEV_USB_NOT_CONFIGURED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(8008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED Macro

PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED Macro
PRL_ERR Macros

  • USB

+++ ALIGNED VALUE TO 8000

Syntax
#define PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED PRL_RESULT_DECLARE_ERROR(8000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DEV_USB_REUSE Macro

PRL_ERR_DEV_USB_REUSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DEV_USB_REUSE PRL_RESULT_DECLARE_ERROR(8006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DIRECTORY_DOES_NOT_EXIST Macro

PRL_ERR_DIRECTORY_DOES_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DIRECTORY_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(75)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_BLOCK_CREATED Macro

PRL_ERR_DISK_BLOCK_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_BLOCK_CREATED PRL_RESULT_DECLARE_ERROR(21045)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED Macro

PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED PRL_RESULT_DECLARE_ERROR(21019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_BLOCK_SEARCH_FAILED Macro

PRL_ERR_DISK_BLOCK_SEARCH_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_BLOCK_SEARCH_FAILED PRL_RESULT_DECLARE_ERROR(22003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_BLOCK_SKIPPED Macro

PRL_ERR_DISK_BLOCK_SKIPPED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_BLOCK_SKIPPED PRL_RESULT_DECLARE_ERROR(21018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_BOOTCAMP_WRITE_MBR Macro

PRL_ERR_DISK_BOOTCAMP_WRITE_MBR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_BOOTCAMP_WRITE_MBR PRL_RESULT_DECLARE_ERROR(21059)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_CANT_INITIALIZE_IMAGE Macro

PRL_ERR_DISK_CANT_INITIALIZE_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_CANT_INITIALIZE_IMAGE PRL_RESULT_DECLARE_ERROR(21049)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_COMPRESSED_FILE_EMPTY Macro

PRL_ERR_DISK_COMPRESSED_FILE_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_COMPRESSED_FILE_EMPTY PRL_RESULT_DECLARE_ERROR(22001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_CREATE_IMAGE_ERROR Macro

PRL_ERR_DISK_CREATE_IMAGE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_CREATE_IMAGE_ERROR PRL_RESULT_DECLARE_ERROR(21016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_DATA_NOT_FOUND Macro

PRL_ERR_DISK_DATA_NOT_FOUND Macro
PRL_ERR Macros

  • User parameters errors
* +++ ALIGNED VALUE TO 23000

Syntax
#define PRL_ERR_DISK_DATA_NOT_FOUND PRL_RESULT_DECLARE_ERROR(23000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_DIR_CREATE_ERROR Macro

PRL_ERR_DISK_DIR_CREATE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_DIR_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(21015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_DISK_NOT_OPENED Macro

PRL_ERR_DISK_DISK_NOT_OPENED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_DISK_NOT_OPENED PRL_RESULT_DECLARE_ERROR(21021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_ENLARGE_FAILED Macro

PRL_ERR_DISK_ENLARGE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_ENLARGE_FAILED PRL_RESULT_DECLARE_ERROR(21057)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FAT32_SIZE_EXCEEDED Macro

PRL_ERR_DISK_FAT32_SIZE_EXCEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FAT32_SIZE_EXCEEDED PRL_RESULT_DECLARE_ERROR(21023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FILE_CREATE_ERROR Macro

PRL_ERR_DISK_FILE_CREATE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FILE_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(21013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FILE_EXISTS Macro

PRL_ERR_DISK_FILE_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FILE_EXISTS PRL_RESULT_DECLARE_ERROR(21012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FILE_OPEN_ERROR Macro

PRL_ERR_DISK_FILE_OPEN_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FILE_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(21014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FSYNC_FAILED Macro

PRL_ERR_DISK_FSYNC_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FSYNC_FAILED PRL_RESULT_DECLARE_ERROR(21031)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_FULLFSYNC_FAILED Macro

PRL_ERR_DISK_FULLFSYNC_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_FULLFSYNC_FAILED PRL_RESULT_DECLARE_ERROR(21032)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GENERIC_ERROR Macro

PRL_ERR_DISK_GENERIC_ERROR Macro
PRL_ERR Macros

  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

Syntax
#define PRL_ERR_DISK_GENERIC_ERROR PRL_RESULT_DECLARE_ERROR(21000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GET_MOUNTPATH_FAILED Macro

PRL_ERR_DISK_GET_MOUNTPATH_FAILED Macro
PRL_ERR Macros

  • Bootcamp errors
* +++ ALIGNED VALUE TO 24000

Syntax
#define PRL_ERR_DISK_GET_MOUNTPATH_FAILED PRL_RESULT_DECLARE_ERROR(24000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GET_PARAMS_FAILED Macro

PRL_ERR_DISK_GET_PARAMS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_GET_PARAMS_FAILED PRL_RESULT_DECLARE_ERROR(24003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GET_SIZE_FAILED Macro

PRL_ERR_DISK_GET_SIZE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_GET_SIZE_FAILED PRL_RESULT_DECLARE_ERROR(21064)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GPT_MBR_NOT_EQUAL Macro

PRL_ERR_DISK_GPT_MBR_NOT_EQUAL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_GPT_MBR_NOT_EQUAL PRL_RESULT_DECLARE_ERROR(21065)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_GROUP_INTERSECT Macro

PRL_ERR_DISK_GROUP_INTERSECT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_GROUP_INTERSECT PRL_RESULT_DECLARE_ERROR(21046)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_IDENTIFY_FAILED Macro

PRL_ERR_DISK_IDENTIFY_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_IDENTIFY_FAILED PRL_RESULT_DECLARE_ERROR(24004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_IMAGE_BUSY Macro

PRL_ERR_DISK_IMAGE_BUSY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_IMAGE_BUSY PRL_RESULT_DECLARE_ERROR(21044)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_IMAGES_CORRUPTED Macro

PRL_ERR_DISK_IMAGES_CORRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_IMAGES_CORRUPTED PRL_RESULT_DECLARE_ERROR(21008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_IMPERSONATE_FAILED Macro

PRL_ERR_DISK_IMPERSONATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(21060)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INCORRECTLY_CLOSED Macro

PRL_ERR_DISK_INCORRECTLY_CLOSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INCORRECTLY_CLOSED PRL_RESULT_DECLARE_ERROR(21047)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INSUFFICIENT_SPACE Macro

PRL_ERR_DISK_INSUFFICIENT_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INSUFFICIENT_SPACE PRL_RESULT_DECLARE_ERROR(21022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INTERNAL_CLASS_ERROR Macro

PRL_ERR_DISK_INTERNAL_CLASS_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INTERNAL_CLASS_ERROR PRL_RESULT_DECLARE_ERROR(21025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INVALID_BLOCKSIZE Macro

PRL_ERR_DISK_INVALID_BLOCKSIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INVALID_BLOCKSIZE PRL_RESULT_DECLARE_ERROR(21009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INVALID_FORMAT Macro

PRL_ERR_DISK_INVALID_FORMAT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INVALID_FORMAT PRL_RESULT_DECLARE_ERROR(21033)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_INVALID_PARAMETERS Macro

PRL_ERR_DISK_INVALID_PARAMETERS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_INVALID_PARAMETERS PRL_RESULT_DECLARE_ERROR(21011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_MEMORY_ERROR Macro

PRL_ERR_DISK_MEMORY_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_MEMORY_ERROR PRL_RESULT_DECLARE_ERROR(21020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_MOUNT_FAILED Macro

PRL_ERR_DISK_MOUNT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_MOUNT_FAILED PRL_RESULT_DECLARE_ERROR(24001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_MOUNTED_OVERLAP Macro

PRL_ERR_DISK_MOUNTED_OVERLAP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_MOUNTED_OVERLAP PRL_RESULT_DECLARE_ERROR(21063)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_NOT_IMPLEMENTED Macro

PRL_ERR_DISK_NOT_IMPLEMENTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_NOT_IMPLEMENTED PRL_RESULT_DECLARE_ERROR(21042)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_NOT_PERMITTED Macro

PRL_ERR_DISK_NOT_PERMITTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(21024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_NOT_VALID_OFFSET Macro

PRL_ERR_DISK_NOT_VALID_OFFSET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_NOT_VALID_OFFSET PRL_RESULT_DECLARE_ERROR(21056)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_NULL_PART_SIZE Macro

PRL_ERR_DISK_NULL_PART_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_NULL_PART_SIZE PRL_RESULT_DECLARE_ERROR(21051)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_OFFSETS_FIXED Macro

PRL_ERR_DISK_OFFSETS_FIXED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_OFFSETS_FIXED PRL_RESULT_DECLARE_ERROR(21048)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_OPERATION_ABORTED Macro

PRL_ERR_DISK_OPERATION_ABORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_OPERATION_ABORTED PRL_RESULT_DECLARE_ERROR(21036)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_OPERATION_IN_PROGRESS Macro

PRL_ERR_DISK_OPERATION_IN_PROGRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_OPERATION_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(21017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_OPERATION_NOT_ALLOWED Macro

PRL_ERR_DISK_OPERATION_NOT_ALLOWED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_OPERATION_NOT_ALLOWED PRL_RESULT_DECLARE_ERROR(21035)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_PARTITION_INVALID_NAME Macro

PRL_ERR_DISK_PARTITION_INVALID_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_PARTITION_INVALID_NAME PRL_RESULT_DECLARE_ERROR(21054)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_PARTITION_NOT_FOUND Macro

PRL_ERR_DISK_PARTITION_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_PARTITION_NOT_FOUND PRL_RESULT_DECLARE_ERROR(21053)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE Macro

PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE PRL_RESULT_DECLARE_ERROR(21043)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_POINTERS_MIXED_UP Macro

PRL_ERR_DISK_POINTERS_MIXED_UP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_POINTERS_MIXED_UP PRL_RESULT_DECLARE_ERROR(22004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_POSSIBLE_OVERRUN Macro

PRL_ERR_DISK_POSSIBLE_OVERRUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_POSSIBLE_OVERRUN PRL_RESULT_DECLARE_ERROR(21058)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_READ_FAILED Macro

PRL_ERR_DISK_READ_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_READ_FAILED PRL_RESULT_DECLARE_ERROR(21029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_READ_OUT_DISK Macro

PRL_ERR_DISK_READ_OUT_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_READ_OUT_DISK PRL_RESULT_DECLARE_ERROR(21028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RENAME_ERROR Macro

PRL_ERR_DISK_RENAME_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_RENAME_ERROR PRL_RESULT_DECLARE_ERROR(21034)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RESERVED_WORD Macro

PRL_ERR_DISK_RESERVED_WORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_RESERVED_WORD PRL_RESULT_DECLARE_ERROR(23001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RESIZE_FAILED Macro

PRL_ERR_DISK_RESIZE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_RESIZE_FAILED PRL_RESULT_DECLARE_ERROR(41003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW Macro

PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_RESIZE_SIZE_TOO_LOW PRL_RESULT_DECLARE_ERROR(41002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED Macro

PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_RESIZE_WITH_SNAPSHOTS_NOT_ALLOWED PRL_RESULT_DECLARE_ERROR(41001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_RESIZER_NOT_FOUND Macro

PRL_ERR_DISK_RESIZER_NOT_FOUND Macro
PRL_ERR Macros

VM image resizer errors +++ ALIGNED VALUE TO 41000

Syntax
#define PRL_ERR_DISK_RESIZER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(41000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SET_CACHING_FAILED Macro

PRL_ERR_DISK_SET_CACHING_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_SET_CACHING_FAILED PRL_RESULT_DECLARE_ERROR(21030)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SET_FILE_SIZE_FAILED Macro

PRL_ERR_DISK_SET_FILE_SIZE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_SET_FILE_SIZE_FAILED PRL_RESULT_DECLARE_ERROR(22005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SHARED_BLOCK Macro

PRL_ERR_DISK_SHARED_BLOCK Macro
PRL_ERR Macros

  • Compressing errors
* +++ ALIGNED VALUE TO 22000

Syntax
#define PRL_ERR_DISK_SHARED_BLOCK PRL_RESULT_DECLARE_ERROR(22000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SHARING_VIOLATION Macro

PRL_ERR_DISK_SHARING_VIOLATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_SHARING_VIOLATION PRL_RESULT_DECLARE_ERROR(21037)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SMALL_IMAGE_SIZE Macro

PRL_ERR_DISK_SMALL_IMAGE_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_SMALL_IMAGE_SIZE PRL_RESULT_DECLARE_ERROR(21050)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_SNAPSHOTS_CORRUPTED Macro

PRL_ERR_DISK_SNAPSHOTS_CORRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_SNAPSHOTS_CORRUPTED PRL_RESULT_DECLARE_ERROR(21006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_STATES_ERROR Macro

PRL_ERR_DISK_STATES_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_STATES_ERROR PRL_RESULT_DECLARE_ERROR(21010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_STORAGE_CORRUPTED Macro

PRL_ERR_DISK_STORAGE_CORRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_STORAGE_CORRUPTED PRL_RESULT_DECLARE_ERROR(21007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_TOOL_NOT_FOUND Macro

PRL_ERR_DISK_TOOL_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_TOOL_NOT_FOUND PRL_RESULT_DECLARE_ERROR(492)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_TOOL_PROCESS_ERROR Macro

PRL_ERR_DISK_TOOL_PROCESS_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_TOOL_PROCESS_ERROR PRL_RESULT_DECLARE_ERROR(491)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_TRUNCATE_FAILED Macro

PRL_ERR_DISK_TRUNCATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_TRUNCATE_FAILED PRL_RESULT_DECLARE_ERROR(22002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_UNALIGNED Macro

PRL_ERR_DISK_UNALIGNED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_UNALIGNED PRL_RESULT_DECLARE_ERROR(21055)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_UNCOMMITED_OPERATION Macro

PRL_ERR_DISK_UNCOMMITED_OPERATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_UNCOMMITED_OPERATION PRL_RESULT_DECLARE_ERROR(21062)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_UNMOUNT_FAILED Macro

PRL_ERR_DISK_UNMOUNT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_UNMOUNT_FAILED PRL_RESULT_DECLARE_ERROR(24002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_USER_INTERRUPTED Macro

PRL_ERR_DISK_USER_INTERRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_USER_INTERRUPTED PRL_RESULT_DECLARE_ERROR(21038)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_WRITE_FAILED Macro

PRL_ERR_DISK_WRITE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(21027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_WRITE_OUT_DISK Macro

PRL_ERR_DISK_WRITE_OUT_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_WRITE_OUT_DISK PRL_RESULT_DECLARE_ERROR(21026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_WRITE_REAL_FAILED Macro

PRL_ERR_DISK_WRITE_REAL_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_WRITE_REAL_FAILED PRL_RESULT_DECLARE_ERROR(21041)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_DIFFERS_FROM_REAL Macro

PRL_ERR_DISK_XML_DIFFERS_FROM_REAL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_DIFFERS_FROM_REAL PRL_RESULT_DECLARE_ERROR(21066)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_INVALID Macro

PRL_ERR_DISK_XML_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_INVALID PRL_RESULT_DECLARE_ERROR(21002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_INVALID_VERSION Macro

PRL_ERR_DISK_XML_INVALID_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_INVALID_VERSION PRL_RESULT_DECLARE_ERROR(21003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_LARGE_FILE Macro

PRL_ERR_DISK_XML_LARGE_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_LARGE_FILE PRL_RESULT_DECLARE_ERROR(21005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_LOCKED Macro

PRL_ERR_DISK_XML_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_LOCKED PRL_RESULT_DECLARE_ERROR(21052)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_MISSING Macro

PRL_ERR_DISK_XML_MISSING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_MISSING PRL_RESULT_DECLARE_ERROR(21061)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_OPEN_FAILED Macro

PRL_ERR_DISK_XML_OPEN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(21001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_PARTITION_NOT_FOUND Macro

PRL_ERR_DISK_XML_PARTITION_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_PARTITION_NOT_FOUND PRL_RESULT_DECLARE_ERROR(21067)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_ERROR Macro

PRL_ERR_DISK_XML_SAVE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_SAVE_ERROR PRL_RESULT_DECLARE_ERROR(21004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR Macro

PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR PRL_RESULT_DECLARE_ERROR(21039)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_RENAME_ERROR Macro

PRL_ERR_DISK_XML_SAVE_RENAME_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISK_XML_SAVE_RENAME_ERROR PRL_RESULT_DECLARE_ERROR(21040)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED Macro

PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED Macro
PRL_ERR Macros

Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000

Syntax
#define PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED PRL_RESULT_DECLARE_ERROR(30000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID Macro

PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID PRL_RESULT_DECLARE_ERROR(30001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE Macro

PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_AUTO_COMPRESS_PERIOD_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(488)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK Macro

PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_CANNOT_COMPACT_VM_HARD_DISK PRL_RESULT_DECLARE_ERROR(493)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_DISP_CONFIG_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(25)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_CONFIG_FILE_NOT_SET Macro

PRL_ERR_DISP_CONFIG_FILE_NOT_SET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_CONFIG_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(40)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_CONFIG_WRITE_ERR Macro

PRL_ERR_DISP_CONFIG_WRITE_ERR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_CONFIG_WRITE_ERR PRL_RESULT_DECLARE_ERROR(66)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT Macro

PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT PRL_RESULT_DECLARE_ERROR(415)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_SHUTDOWN_IN_PROCESS Macro

PRL_ERR_DISP_SHUTDOWN_IN_PROCESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_SHUTDOWN_IN_PROCESS PRL_RESULT_DECLARE_ERROR(404)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED Macro

PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_START_VM_FOR_COMPACT_FAILED PRL_RESULT_DECLARE_ERROR(486)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING Macro

PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_TIME_MACHINE_IS_RUNNING PRL_RESULT_DECLARE_ERROR(504)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED Macro

PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED PRL_RESULT_DECLARE_ERROR(416)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_VM_IS_NOT_STARTED Macro

PRL_ERR_DISP_VM_IS_NOT_STARTED Macro
PRL_ERR Macros

Dispatcher errors codes

Syntax
#define PRL_ERR_DISP_VM_IS_NOT_STARTED PRL_RESULT_DECLARE_ERROR(377)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISP_VM_IS_NOT_STOPPED Macro

PRL_ERR_DISP_VM_IS_NOT_STOPPED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISP_VM_IS_NOT_STOPPED PRL_RESULT_DECLARE_ERROR(557)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISPATCHER_SERVICE_MODE Macro

PRL_ERR_DISPATCHER_SERVICE_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISPATCHER_SERVICE_MODE PRL_RESULT_DECLARE_ERROR(364)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED Macro

PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(526)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED Macro

PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(549)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DOUBLE_INIT Macro

PRL_ERR_DOUBLE_INIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DOUBLE_INIT PRL_RESULT_DECLARE_ERROR(11)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST Macro

PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST PRL_RESULT_DECLARE_ERROR(405)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED Macro

PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_DISABLE_PLUGINS_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(44237)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED Macro

PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_ENABLE_PLUGINS_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(44236)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_HDD_CANT_OPEN Macro

PRL_ERR_ENC_HDD_CANT_OPEN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_HDD_CANT_OPEN PRL_RESULT_DECLARE_ERROR(44240)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED Macro

PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_HDD_IS_ALREADY_ENCRYPTED PRL_RESULT_DECLARE_ERROR(44241)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_HDD_IS_UNENCRYPTED Macro

PRL_ERR_ENC_HDD_IS_UNENCRYPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_HDD_IS_UNENCRYPTED PRL_RESULT_DECLARE_ERROR(44242)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE Macro

PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_HDD_WRONG_ENCRYPTION_ENGINE PRL_RESULT_DECLARE_ERROR(44243)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_KEY_NOT_SET Macro

PRL_ERR_ENC_KEY_NOT_SET Macro
PRL_ERR Macros

  • Encryption engine errors

+++ ALIGNED VALUE TO 43000

Syntax
#define PRL_ERR_ENC_KEY_NOT_SET PRL_RESULT_DECLARE_ERROR(43000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND Macro

PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_PLUGIN_UUID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(44233)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED Macro

PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_DISABLED PRL_RESULT_DECLARE_ERROR(44231)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED Macro

PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_PLUGINS_FEATURE_IS_ALREADY_ENABLED PRL_RESULT_DECLARE_ERROR(44234)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED Macro

PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_PLUGINS_FEATURE_IS_DISABLED PRL_RESULT_DECLARE_ERROR(44232)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY Macro

PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_PLUGINS_UNABLE_LOAD_DIR_ALREADY PRL_RESULT_DECLARE_ERROR(44235)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED Macro

PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_RESCAN_PLUGINS_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(44238)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE Macro

PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_UNABLE_UNLOAD_PLUGINS_IN_USE PRL_RESULT_DECLARE_ERROR(44230)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_WRONG_HDD_PASSWORD Macro

PRL_ERR_ENC_WRONG_HDD_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_WRONG_HDD_PASSWORD PRL_RESULT_DECLARE_ERROR(44244)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENC_WRONG_KEY Macro

PRL_ERR_ENC_WRONG_KEY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENC_WRONG_KEY PRL_RESULT_DECLARE_ERROR(43001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENTRY_ALREADY_EXISTS Macro

PRL_ERR_ENTRY_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENTRY_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(80)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENTRY_DIR_ALREADY_EXISTS Macro

PRL_ERR_ENTRY_DIR_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENTRY_DIR_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(410)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST Macro

PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(411)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ENTRY_DOES_NOT_EXIST Macro

PRL_ERR_ENTRY_DOES_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ENTRY_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(79)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS Macro

PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS PRL_RESULT_DECLARE_ERROR(388)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_EXCEED_MEMORY_LIMIT Macro

PRL_ERR_EXCEED_MEMORY_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_EXCEED_MEMORY_LIMIT PRL_RESULT_DECLARE_ERROR(205)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_EXT_DISK_ALREADY_EXISTS Macro

PRL_ERR_EXT_DISK_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_EXT_DISK_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(579)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_EXT_DISK_CANT_RENAME Macro

PRL_ERR_EXT_DISK_CANT_RENAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_EXT_DISK_CANT_RENAME PRL_RESULT_DECLARE_ERROR(580)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER Macro

PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILED_TO_AUTH_ON_BACKUP_SERVER PRL_RESULT_DECLARE_ERROR(37023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER Macro

PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILED_TO_CONNECT_TO_BACKUP_SERVER PRL_RESULT_DECLARE_ERROR(37022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILED_TO_START_VNC_SERVER Macro

PRL_ERR_FAILED_TO_START_VNC_SERVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILED_TO_START_VNC_SERVER PRL_RESULT_DECLARE_ERROR(35003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILED_TO_STOP_VNC_SERVER Macro

PRL_ERR_FAILED_TO_STOP_VNC_SERVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILED_TO_STOP_VNC_SERVER PRL_RESULT_DECLARE_ERROR(35004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILURE Macro

PRL_ERR_FAILURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILURE PRL_RESULT_DECLARE_ERROR(9)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FAILURE_ON_VM_DESTROYED Macro

PRL_ERR_FAILURE_ON_VM_DESTROYED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FAILURE_ON_VM_DESTROYED PRL_RESULT_DECLARE_ERROR(462)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FDD_IMAGE_CLONE_TO_SELF Macro

PRL_ERR_FDD_IMAGE_CLONE_TO_SELF Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FDD_IMAGE_CLONE_TO_SELF PRL_RESULT_DECLARE_ERROR(315)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FDD_IMAGE_COPY Macro

PRL_ERR_FDD_IMAGE_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FDD_IMAGE_COPY PRL_RESULT_DECLARE_ERROR(314)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_FDD_IMAGE_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(209)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_DISK_SPACE_ERROR Macro

PRL_ERR_FILE_DISK_SPACE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_DISK_SPACE_ERROR PRL_RESULT_DECLARE_ERROR(373)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF Macro

PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF Macro
PRL_ERR Macros

File Manager errors +++ ALIGNED VALUE TO 51000

Syntax
#define PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_ITSELF PRL_RESULT_DECLARE_ERROR(51000)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION Macro

PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_MANAGER_CANT_PASTE_AN_ITEM_INTO_THIS_DESTINATION PRL_RESULT_DECLARE_ERROR(51001)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_NOT_EXIST Macro

PRL_ERR_FILE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(322)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_NOT_FOUND Macro

PRL_ERR_FILE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(10)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS Macro

PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(355)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_READ_ERROR Macro

PRL_ERR_FILE_READ_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_READ_ERROR PRL_RESULT_DECLARE_ERROR(110)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE PRL_RESULT_DECLARE_ERROR(26004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE PRL_RESULT_DECLARE_ERROR(26001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE PRL_RESULT_DECLARE_ERROR(26002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE PRL_RESULT_DECLARE_ERROR(26005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED Macro

PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED Macro
PRL_ERR Macros

  • File Transfer errors

+++ ALIGNED VALUE TO 26000

Syntax
#define PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED PRL_RESULT_DECLARE_ERROR(26000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST Macro

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(26006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS Macro

PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS PRL_RESULT_DECLARE_ERROR(26009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS Macro

PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS PRL_RESULT_DECLARE_ERROR(26003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED Macro

PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(26007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER Macro

PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER PRL_RESULT_DECLARE_ERROR(26008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILE_WRITE_ERROR Macro

PRL_ERR_FILE_WRITE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILE_WRITE_ERROR PRL_RESULT_DECLARE_ERROR(372)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_CANT_CREATE_DIR Macro

PRL_ERR_FILECOPY_CANT_CREATE_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_CANT_CREATE_DIR PRL_RESULT_DECLARE_ERROR(31021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_CANT_OPEN_FILE Macro

PRL_ERR_FILECOPY_CANT_OPEN_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_CANT_OPEN_FILE PRL_RESULT_DECLARE_ERROR(31022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_CANT_WRITE Macro

PRL_ERR_FILECOPY_CANT_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_CANT_WRITE PRL_RESULT_DECLARE_ERROR(31023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_DIR_EXIST Macro

PRL_ERR_FILECOPY_DIR_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_DIR_EXIST PRL_RESULT_DECLARE_ERROR(31019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_FILE_EXIST Macro

PRL_ERR_FILECOPY_FILE_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_FILE_EXIST PRL_RESULT_DECLARE_ERROR(31020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_INTERNAL Macro

PRL_ERR_FILECOPY_INTERNAL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_INTERNAL PRL_RESULT_DECLARE_ERROR(31024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FILECOPY_PROTOCOL Macro

PRL_ERR_FILECOPY_PROTOCOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FILECOPY_PROTOCOL PRL_RESULT_DECLARE_ERROR(31018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR Macro

PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FIREWALL_TOOL_EXECUTED_WITH_ERROR PRL_RESULT_DECLARE_ERROR(534)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FIXME Macro

PRL_ERR_FIXME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FIXME PRL_RESULT_DECLARE_ERROR(227)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FLOPPY_DRIVE_INVALID Macro

PRL_ERR_FLOPPY_DRIVE_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FLOPPY_DRIVE_INVALID PRL_RESULT_DECLARE_ERROR(226)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST Macro

PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(256)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FLOPPY_IMAGE_NOT_EXIST Macro

PRL_ERR_FLOPPY_IMAGE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FLOPPY_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(95)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED Macro

PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FORCE_REG_ON_SHARED_STORAGE_IS_NEEDED PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FREE_DISC_SPACE_FOR_CLONE Macro

PRL_ERR_FREE_DISC_SPACE_FOR_CLONE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FREE_DISC_SPACE_FOR_CLONE PRL_RESULT_DECLARE_ERROR(371)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT Macro

PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT PRL_RESULT_DECLARE_ERROR(442)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT Macro

PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT PRL_RESULT_DECLARE_ERROR(443)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_DISK_FREE_SPACE_FAILED Macro

PRL_ERR_GET_DISK_FREE_SPACE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_DISK_FREE_SPACE_FAILED PRL_RESULT_DECLARE_ERROR(556)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_LICENSE_INVALID_ARG Macro

PRL_ERR_GET_LICENSE_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_LICENSE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(137)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_MON_STATE_INVALID_ARG Macro

PRL_ERR_GET_MON_STATE_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_MON_STATE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(128)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED Macro

PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(129)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_MON_STATE_VM_NOT_CREATED Macro

PRL_ERR_GET_MON_STATE_VM_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_MON_STATE_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(127)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_NET_SERVICE_STATUS_FAILED Macro

PRL_ERR_GET_NET_SERVICE_STATUS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_NET_SERVICE_STATUS_FAILED PRL_RESULT_DECLARE_ERROR(353)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG Macro

PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG PRL_RESULT_DECLARE_ERROR(176)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED Macro

PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED PRL_RESULT_DECLARE_ERROR(175)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GET_USER_HOME_DIR Macro

PRL_ERR_GET_USER_HOME_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GET_USER_HOME_DIR PRL_RESULT_DECLARE_ERROR(243)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_MAC_INVALID_VERSION Macro

PRL_ERR_GUEST_MAC_INVALID_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_MAC_INVALID_VERSION PRL_RESULT_DECLARE_ERROR(359)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY Macro

PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY PRL_RESULT_DECLARE_ERROR(358)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST Macro

PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST PRL_RESULT_DECLARE_ERROR(397)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED Macro

PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_PROGRAM_EXECUTION_FAILED PRL_RESULT_DECLARE_ERROR(34004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_TOOLS_NOT_INSTALLED Macro

PRL_ERR_GUEST_TOOLS_NOT_INSTALLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_TOOLS_NOT_INSTALLED PRL_RESULT_DECLARE_ERROR(423)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_GUEST_USB_REQUIRED Macro

PRL_ERR_GUEST_USB_REQUIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_GUEST_USB_REQUIRED PRL_RESULT_DECLARE_ERROR(578)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HANDSHAKE_FAILED Macro

PRL_ERR_HANDSHAKE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HANDSHAKE_FAILED PRL_RESULT_DECLARE_ERROR(412)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HARD_DISK_IMAGE_CORRUPTED Macro

PRL_ERR_HARD_DISK_IMAGE_CORRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HARD_DISK_IMAGE_CORRUPTED PRL_RESULT_DECLARE_ERROR(2002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED Macro

PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HARD_DISK_NOT_VIRTUAL_OR_DISABLED PRL_RESULT_DECLARE_ERROR(499)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HDD_IMAGE_CLONE_TO_SELF Macro

PRL_ERR_HDD_IMAGE_CLONE_TO_SELF Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HDD_IMAGE_CLONE_TO_SELF PRL_RESULT_DECLARE_ERROR(94)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HDD_IMAGE_COPY Macro

PRL_ERR_HDD_IMAGE_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HDD_IMAGE_COPY PRL_RESULT_DECLARE_ERROR(237)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST Macro

PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(288)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HDD_IMAGE_NOT_EXIST Macro

PRL_ERR_HDD_IMAGE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(93)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_HDD_IMAGE_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(206)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HOST_AMD_GUEST_MAC Macro

PRL_ERR_HOST_AMD_GUEST_MAC Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HOST_AMD_GUEST_MAC PRL_RESULT_DECLARE_ERROR(348)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_AUTH_REQUIRED Macro

PRL_ERR_HTTP_AUTH_REQUIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_AUTH_REQUIRED PRL_RESULT_DECLARE_ERROR(38006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_CONNECTION_REFUSED Macro

PRL_ERR_HTTP_CONNECTION_REFUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_CONNECTION_REFUSED PRL_RESULT_DECLARE_ERROR(38001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_HOST_NOT_FOUND Macro

PRL_ERR_HTTP_HOST_NOT_FOUND Macro
PRL_ERR Macros

Problem report send errors set +++ ALIGNED VALUE TO 38000

Syntax
#define PRL_ERR_HTTP_HOST_NOT_FOUND PRL_RESULT_DECLARE_ERROR(38000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_INVALID_RESPONSE_HEADER Macro

PRL_ERR_HTTP_INVALID_RESPONSE_HEADER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_INVALID_RESPONSE_HEADER PRL_RESULT_DECLARE_ERROR(38003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE Macro

PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_PROBLEM_REPORT_SEND_FAILURE PRL_RESULT_DECLARE_ERROR(38007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_PROXY_AUTH_REQUIRED Macro

PRL_ERR_HTTP_PROXY_AUTH_REQUIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_PROXY_AUTH_REQUIRED PRL_RESULT_DECLARE_ERROR(38005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_REQUEST_FAILED Macro

PRL_ERR_HTTP_REQUEST_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_REQUEST_FAILED PRL_RESULT_DECLARE_ERROR(11715)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_UNEXPECTED_CLOSE Macro

PRL_ERR_HTTP_UNEXPECTED_CLOSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_UNEXPECTED_CLOSE PRL_RESULT_DECLARE_ERROR(38002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HTTP_WRONG_CONTENT_LENGTH Macro

PRL_ERR_HTTP_WRONG_CONTENT_LENGTH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HTTP_WRONG_CONTENT_LENGTH PRL_RESULT_DECLARE_ERROR(38004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_DISABLED Macro

PRL_ERR_HVT_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_DISABLED PRL_RESULT_DECLARE_ERROR(341)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_DISABLED_WARNING Macro

PRL_ERR_HVT_DISABLED_WARNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_DISABLED_WARNING PRL_RESULT_DECLARE_ERROR(507)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_NOT_AVAILABLE_WARNING Macro

PRL_ERR_HVT_NOT_AVAILABLE_WARNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_NOT_AVAILABLE_WARNING PRL_RESULT_DECLARE_ERROR(483)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_NOT_PRESENT Macro

PRL_ERR_HVT_NOT_PRESENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_NOT_PRESENT PRL_RESULT_DECLARE_ERROR(336)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_NOT_PRESENT_WARNING Macro

PRL_ERR_HVT_NOT_PRESENT_WARNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_NOT_PRESENT_WARNING PRL_RESULT_DECLARE_ERROR(36028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HVT_TURNED_OFF_IN_CONFIG Macro

PRL_ERR_HVT_TURNED_OFF_IN_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HVT_TURNED_OFF_IN_CONFIG PRL_RESULT_DECLARE_ERROR(367)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_HYP_ALLOC_VMS_MEMORY Macro

PRL_ERR_HYP_ALLOC_VMS_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_HYP_ALLOC_VMS_MEMORY PRL_RESULT_DECLARE_ERROR(431)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_INVALID_PRODUCT_ID Macro

PRL_ERR_IAP_INVALID_PRODUCT_ID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_INVALID_PRODUCT_ID PRL_RESULT_DECLARE_ERROR(48001)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_FAILED Macro

PRL_ERR_IAP_PAYMENT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_FAILED PRL_RESULT_DECLARE_ERROR(48002)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED Macro

PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_RECEIPT_ALREDY_REGISTERED PRL_RESULT_DECLARE_SUCCESS(48006)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED Macro

PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_RECEIPT_EXPIRED PRL_RESULT_DECLARE_ERROR(48007)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID Macro

PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_RECEIPT_INVALID PRL_RESULT_DECLARE_ERROR(48005)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED Macro

PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_RECEIPT_REGISTRATION_FAILED PRL_RESULT_DECLARE_ERROR(48004)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED Macro

PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PAYMENT_TRANSACTIONS_RESTORE_FAILED PRL_RESULT_DECLARE_ERROR(48003)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED Macro

PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IAP_PRODUCT_PURCHASE_RESTRICTED PRL_RESULT_DECLARE_ERROR(48008)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IAP_STORE_NO_CONNECTION Macro

PRL_ERR_IAP_STORE_NO_CONNECTION Macro
PRL_ERR Macros

InApp purchase errors +++ ALIGNED VALUE TO 48000

Syntax
#define PRL_ERR_IAP_STORE_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(48000)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IMAGE_NEED_TO_CONVERT Macro

PRL_ERR_IMAGE_NEED_TO_CONVERT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IMAGE_NEED_TO_CONVERT PRL_RESULT_DECLARE_ERROR(2001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IMPERSONATE_FAILED Macro

PRL_ERR_IMPERSONATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(350)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED Macro

PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IMPORT_BOOTCAMP_VM_FAILED PRL_RESULT_DECLARE_ERROR(41302)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE Macro

PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IMPORT_BOOTCAMP_VM_NO_SPACE PRL_RESULT_DECLARE_ERROR(41303)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INCONSISTENCY_VM_CONFIG Macro

PRL_ERR_INCONSISTENCY_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INCONSISTENCY_VM_CONFIG PRL_RESULT_DECLARE_ERROR(106)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INCORRECT_CDROM_PATH Macro

PRL_ERR_INCORRECT_CDROM_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INCORRECT_CDROM_PATH PRL_RESULT_DECLARE_ERROR(1001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INCORRECT_FDD_PATH Macro

PRL_ERR_INCORRECT_FDD_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INCORRECT_FDD_PATH PRL_RESULT_DECLARE_ERROR(335)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INCORRECT_PATH Macro

PRL_ERR_INCORRECT_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INCORRECT_PATH PRL_RESULT_DECLARE_ERROR(324)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INSERTING_VM_TO_CATALOGUE Macro

PRL_ERR_INSERTING_VM_TO_CATALOGUE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INSERTING_VM_TO_CATALOGUE PRL_RESULT_DECLARE_ERROR(238)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INSTALLATION_PROBLEM Macro

PRL_ERR_INSTALLATION_PROBLEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INSTALLATION_PROBLEM PRL_RESULT_DECLARE_ERROR(284)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED Macro

PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED PRL_RESULT_DECLARE_ERROR(245)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_ACTION_REQUESTED Macro

PRL_ERR_INVALID_ACTION_REQUESTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_ACTION_REQUESTED PRL_RESULT_DECLARE_ERROR(516)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_ARG Macro

PRL_ERR_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_ARG PRL_RESULT_DECLARE_ERROR(3)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_CONFIGURATION Macro

PRL_ERR_INVALID_CONFIGURATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_CONFIGURATION PRL_RESULT_DECLARE_ERROR(365)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS Macro

PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_CREATE_FLOPPY_IMAGE_PARAMETERS PRL_RESULT_DECLARE_ERROR(551)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_HANDLE Macro

PRL_ERR_INVALID_HANDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_HANDLE PRL_RESULT_DECLARE_ERROR(4)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_HDD_GEOMETRY Macro

PRL_ERR_INVALID_HDD_GEOMETRY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_HDD_GEOMETRY PRL_RESULT_DECLARE_ERROR(207)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED Macro

PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED PRL_RESULT_DECLARE_ERROR(430)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_MEMORY_GUARANTEE Macro

PRL_ERR_INVALID_MEMORY_GUARANTEE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_MEMORY_GUARANTEE PRL_RESULT_DECLARE_ERROR(537)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_MEMORY_QUOTA Macro

PRL_ERR_INVALID_MEMORY_QUOTA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_MEMORY_QUOTA PRL_RESULT_DECLARE_ERROR(536)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_MEMORY_SIZE Macro

PRL_ERR_INVALID_MEMORY_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_MEMORY_SIZE PRL_RESULT_DECLARE_ERROR(204)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_OS_TYPE Macro

PRL_ERR_INVALID_OS_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_OS_TYPE PRL_RESULT_DECLARE_ERROR(10018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_PARALLELS_DISK Macro

PRL_ERR_INVALID_PARALLELS_DISK Macro
PRL_ERR Macros

  • Hard Drive

+++ ALIGNED VALUE TO 2000

Syntax
#define PRL_ERR_INVALID_PARALLELS_DISK PRL_RESULT_DECLARE_ERROR(2000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_PARAM Macro

PRL_ERR_INVALID_PARAM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_PARAM PRL_RESULT_DECLARE_ERROR(18)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_INVALID_TOTAL_LIMIT Macro

PRL_ERR_INVALID_TOTAL_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_INVALID_TOTAL_LIMIT PRL_RESULT_DECLARE_ERROR(542)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_AUTHENTICATION_FAILED Macro

PRL_ERR_IO_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(304)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_CONNECTION_TIMEOUT Macro

PRL_ERR_IO_CONNECTION_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_CONNECTION_TIMEOUT PRL_RESULT_DECLARE_ERROR(303)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_DISABLED Macro

PRL_ERR_IO_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_DISABLED PRL_RESULT_DECLARE_ERROR(340)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_INVALID_POINTER_ACCESS Macro

PRL_ERR_IO_INVALID_POINTER_ACCESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_INVALID_POINTER_ACCESS PRL_RESULT_DECLARE_ERROR(452)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_NO_CONNECTION Macro

PRL_ERR_IO_NO_CONNECTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(401)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_SEND_QUEUE_IS_FULL Macro

PRL_ERR_IO_SEND_QUEUE_IS_FULL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_SEND_QUEUE_IS_FULL PRL_RESULT_DECLARE_ERROR(300)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_STOPPED Macro

PRL_ERR_IO_STOPPED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_STOPPED PRL_RESULT_DECLARE_ERROR(301)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IO_UNKNOWN_VM_ID Macro

PRL_ERR_IO_UNKNOWN_VM_ID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IO_UNKNOWN_VM_ID PRL_RESULT_DECLARE_ERROR(302)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IOSERVICE_COMPRESS Macro

PRL_ERR_IOSERVICE_COMPRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IOSERVICE_COMPRESS PRL_RESULT_DECLARE_ERROR(550)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPC_ATTACH_FAILED Macro

PRL_ERR_IPC_ATTACH_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPC_ATTACH_FAILED PRL_RESULT_DECLARE_ERROR(29010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPC_CREATE_MAP_FAILED Macro

PRL_ERR_IPC_CREATE_MAP_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPC_CREATE_MAP_FAILED PRL_RESULT_DECLARE_ERROR(29009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPC_FTOK_FAILED Macro

PRL_ERR_IPC_FTOK_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPC_FTOK_FAILED PRL_RESULT_DECLARE_ERROR(29011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_INVALID_MODE Macro

PRL_ERR_IPFO_INVALID_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_INVALID_MODE PRL_RESULT_DECLARE_ERROR(29006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_RECEIVE_FAILED Macro

PRL_ERR_IPFO_RECEIVE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_RECEIVE_FAILED PRL_RESULT_DECLARE_ERROR(29008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SEND_FAILED Macro

PRL_ERR_IPFO_SEND_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SEND_FAILED PRL_RESULT_DECLARE_ERROR(29007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED Macro

PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED PRL_RESULT_DECLARE_ERROR(29003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_BIND_FAILED Macro

PRL_ERR_IPFO_SOCKET_BIND_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SOCKET_BIND_FAILED PRL_RESULT_DECLARE_ERROR(29001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_CONNECT_FAILED Macro

PRL_ERR_IPFO_SOCKET_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SOCKET_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(29004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_CREATE_FAILED Macro

PRL_ERR_IPFO_SOCKET_CREATE_FAILED Macro
PRL_ERR Macros

  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

Syntax
#define PRL_ERR_IPFO_SOCKET_CREATE_FAILED PRL_RESULT_DECLARE_ERROR(29000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_LISTEN_FAILED Macro

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SOCKET_LISTEN_FAILED PRL_RESULT_DECLARE_ERROR(29002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_NOT_OPENED Macro

PRL_ERR_IPFO_SOCKET_NOT_OPENED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPFO_SOCKET_NOT_OPENED PRL_RESULT_DECLARE_ERROR(29005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_ALREADY_STARTED Macro

PRL_ERR_IPHONE_PROXY_ALREADY_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPHONE_PROXY_ALREADY_STARTED PRL_RESULT_DECLARE_ERROR(32002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_CANNOT_START Macro

PRL_ERR_IPHONE_PROXY_CANNOT_START Macro
PRL_ERR Macros

iPhone proxy errors +++ ALIGNED VALUE TO 32000

Syntax
#define PRL_ERR_IPHONE_PROXY_CANNOT_START PRL_RESULT_DECLARE_ERROR(32000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_CANNOT_STOP Macro

PRL_ERR_IPHONE_PROXY_CANNOT_STOP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IPHONE_PROXY_CANNOT_STOP PRL_RESULT_DECLARE_ERROR(32001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED Macro

PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_ALREADY_REGISTERED PRL_RESULT_DECLARE_ERROR(44413)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT Macro

PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_CANNOT_CREATE_MOUNT_POINT PRL_RESULT_DECLARE_ERROR(44414)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_CREATE Macro

PRL_ERR_ISCSI_STORAGE_CREATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_CREATE PRL_RESULT_DECLARE_ERROR(44402)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_EXTEND Macro

PRL_ERR_ISCSI_STORAGE_EXTEND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_EXTEND PRL_RESULT_DECLARE_ERROR(44406)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_GET_STATE Macro

PRL_ERR_ISCSI_STORAGE_GET_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_GET_STATE PRL_RESULT_DECLARE_ERROR(44407)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE Macro

PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_INVALID_FSTYPE PRL_RESULT_DECLARE_ERROR(44411)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_LIBRARY Macro

PRL_ERR_ISCSI_STORAGE_LIBRARY Macro
PRL_ERR Macros

iscsi storages errors +++ ALIGNED VALUE TO 44400

Syntax
#define PRL_ERR_ISCSI_STORAGE_LIBRARY PRL_RESULT_DECLARE_ERROR(44400)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_MOUNT Macro

PRL_ERR_ISCSI_STORAGE_MOUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_MOUNT PRL_RESULT_DECLARE_ERROR(44404)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS Macro

PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_MOUNT_POINT_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(44415)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_MOUNTED Macro

PRL_ERR_ISCSI_STORAGE_MOUNTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_MOUNTED PRL_RESULT_DECLARE_ERROR(44408)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_NOT_FOUND Macro

PRL_ERR_ISCSI_STORAGE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(44412)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED Macro

PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_NOT_MOUNTED PRL_RESULT_DECLARE_ERROR(44409)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED Macro

PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(44410)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_REMOVE Macro

PRL_ERR_ISCSI_STORAGE_REMOVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_REMOVE PRL_RESULT_DECLARE_ERROR(44403)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_START Macro

PRL_ERR_ISCSI_STORAGE_START Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_START PRL_RESULT_DECLARE_ERROR(44401)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ISCSI_STORAGE_UMOUNT Macro

PRL_ERR_ISCSI_STORAGE_UMOUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ISCSI_STORAGE_UMOUNT PRL_RESULT_DECLARE_ERROR(44405)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_COMPACT Macro

PRL_ERR_IT_CANT_COMPACT Macro
PRL_ERR Macros

compact

Syntax
#define PRL_ERR_IT_CANT_COMPACT PRL_RESULT_DECLARE_ERROR(46219)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_COMPACT_LDM_DISK Macro

PRL_ERR_IT_CANT_COMPACT_LDM_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_COMPACT_LDM_DISK PRL_RESULT_DECLARE_ERROR(46220)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK Macro

PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_COMPACT_PLAIN_DISK PRL_RESULT_DECLARE_ERROR(46222)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_GET_BITMAP Macro

PRL_ERR_IT_CANT_GET_BITMAP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_GET_BITMAP PRL_RESULT_DECLARE_ERROR(46221)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE Macro

PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_GET_PARAMS_FROM_OLD_IMAGE PRL_RESULT_DECLARE_ERROR(46204)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_OPEN_IMAGE Macro

PRL_ERR_IT_CANT_OPEN_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_OPEN_IMAGE PRL_RESULT_DECLARE_ERROR(46203)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA Macro

PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_PREPARE_RECONFIG_DATA PRL_RESULT_DECLARE_ERROR(46209)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_RECONFIG Macro

PRL_ERR_IT_CANT_RECONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_RECONFIG PRL_RESULT_DECLARE_ERROR(46207)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP Macro

PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_RECONFIG_BOOTCAMP PRL_RESULT_DECLARE_ERROR(46208)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_RESIZE_LDM_DISK Macro

PRL_ERR_IT_CANT_RESIZE_LDM_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_CANT_RESIZE_LDM_DISK PRL_RESULT_DECLARE_ERROR(46217)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_RESIZE_VOLUME Macro

PRL_ERR_IT_CANT_RESIZE_VOLUME Macro
PRL_ERR Macros

resize

Syntax
#define PRL_ERR_IT_CANT_RESIZE_VOLUME PRL_RESULT_DECLARE_ERROR(46216)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP Macro

PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP Macro
PRL_ERR Macros

reconfig

Syntax
#define PRL_ERR_IT_CANT_VALIDATE_BOOTCAMP PRL_RESULT_DECLARE_ERROR(46206)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR Macro

PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR Macro
PRL_ERR Macros

convert

Syntax
#define PRL_ERR_IT_CONVERT_TO_CURRENT_ERROR PRL_RESULT_DECLARE_ERROR(46214)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_DISK_SMALL_FOR_SPLIT Macro

PRL_ERR_IT_DISK_SMALL_FOR_SPLIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_DISK_SMALL_FOR_SPLIT PRL_RESULT_DECLARE_ERROR(46215)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_FAST_RESIZE_FAILURE Macro

PRL_ERR_IT_FAST_RESIZE_FAILURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_FAST_RESIZE_FAILURE PRL_RESULT_DECLARE_ERROR(46101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_FIRST_ERROR Macro

PRL_ERR_IT_FIRST_ERROR Macro
PRL_ERR Macros

ALIGNED VALUE TO 46200

Syntax
#define PRL_ERR_IT_FIRST_ERROR PRL_RESULT_DECLARE_ERROR(46200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_FIRST_FAILURE Macro

PRL_ERR_IT_FIRST_FAILURE Macro
PRL_ERR Macros

ALIGNED VALUE TO 46100

Syntax
#define PRL_ERR_IT_FIRST_FAILURE PRL_RESULT_DECLARE_ERROR(46100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE Macro

PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_FS_NOT_SUPPORTED_FOR_RESIZE PRL_RESULT_DECLARE_ERROR(46218)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE Macro

PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE Macro
PRL_ERR Macros

guest tools

Syntax
#define PRL_ERR_IT_GUEST_TOOLS_UNKNOWN_STATE PRL_RESULT_DECLARE_ERROR(46205)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_HAL_NOT_FOUND Macro

PRL_ERR_IT_HAL_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_HAL_NOT_FOUND PRL_RESULT_DECLARE_ERROR(46212)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_RECONFIG_PATH_NEEDED Macro

PRL_ERR_IT_RECONFIG_PATH_NEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_RECONFIG_PATH_NEEDED PRL_RESULT_DECLARE_ERROR(46210)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_ROLLBACK_FAILURE Macro

PRL_ERR_IT_ROLLBACK_FAILURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_ROLLBACK_FAILURE PRL_RESULT_DECLARE_ERROR(46102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_SIZE_CHANGED Macro

PRL_ERR_IT_SIZE_CHANGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_SIZE_CHANGED PRL_RESULT_DECLARE_ERROR(46202)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED Macro

PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED Macro
PRL_ERR Macros

merge

Syntax
#define PRL_ERR_IT_SNAPSHOTS_MERGE_IS_NEEDED PRL_RESULT_DECLARE_ERROR(46213)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_UNKNOWN_OS Macro

PRL_ERR_IT_UNKNOWN_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_UNKNOWN_OS PRL_RESULT_DECLARE_ERROR(46211)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_IT_USER_INTERRUPTED Macro

PRL_ERR_IT_USER_INTERRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_IT_USER_INTERRUPTED PRL_RESULT_DECLARE_ERROR(46201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LIC_REGISTRATION_COMMON_ERROR Macro

PRL_ERR_LIC_REGISTRATION_COMMON_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LIC_REGISTRATION_COMMON_ERROR PRL_RESULT_DECLARE_ERROR(11731)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_AUTH_FAILED Macro

PRL_ERR_LICENSE_AUTH_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_AUTH_FAILED PRL_RESULT_DECLARE_ERROR(11007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT Macro

PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT PRL_RESULT_DECLARE_ERROR(11011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_BLACKLISTED Macro

PRL_ERR_LICENSE_BLACKLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_BLACKLISTED PRL_RESULT_DECLARE_ERROR(11015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION Macro

PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_BLACKLISTED_TO_VM_OPERATION PRL_RESULT_DECLARE_ERROR(11061)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND Macro

PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_DEFERRED_LICENSE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(11071)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_EXPIRED Macro

PRL_ERR_LICENSE_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_EXPIRED PRL_RESULT_DECLARE_ERROR(11001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_FILE_WRITE_FAILED Macro

PRL_ERR_LICENSE_FILE_WRITE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_FILE_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(11010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_GRACED Macro

PRL_ERR_LICENSE_GRACED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_GRACED PRL_RESULT_DECLARE_ERROR(11058)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_IS_NOT_VOLUME Macro

PRL_ERR_LICENSE_IS_NOT_VOLUME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_IS_NOT_VOLUME PRL_RESULT_DECLARE_ERROR(11073)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_NOT_STARTED Macro

PRL_ERR_LICENSE_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_NOT_STARTED PRL_RESULT_DECLARE_ERROR(11014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_NOT_VALID Macro

PRL_ERR_LICENSE_NOT_VALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_NOT_VALID PRL_RESULT_DECLARE_ERROR(11000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT Macro

PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT PRL_RESULT_DECLARE_ERROR(11013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT Macro

PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_CPU_COUNT PRL_RESULT_DECLARE_ERROR(11059)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_GUEST_OS Macro

PRL_ERR_LICENSE_RESTRICTED_GUEST_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_GUEST_OS PRL_RESULT_DECLARE_ERROR(11041)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_CLONE_VM PRL_RESULT_DECLARE_ERROR(11046)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_FROM_TEMPLATE PRL_RESULT_DECLARE_ERROR(11048)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_CONVERT_TO_TEMPLATE PRL_RESULT_DECLARE_ERROR(11047)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_CREATE_VM PRL_RESULT_DECLARE_ERROR(11043)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_PAUSE_VM PRL_RESULT_DECLARE_ERROR(11050)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_3RD_PARTY_VM PRL_RESULT_DECLARE_ERROR(11045)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_REGISTER_VM PRL_RESULT_DECLARE_ERROR(11044)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT Macro

PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT PRL_RESULT_DECLARE_ERROR(11042)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER Macro

PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_RUNNING_VMS_LIMIT_PER_USER PRL_RESULT_DECLARE_ERROR(11060)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SAFEMODE_FEATURE PRL_RESULT_DECLARE_ERROR(11056)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SMARTGUARD_FEATURE PRL_RESULT_DECLARE_ERROR(11057)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_CREATE PRL_RESULT_DECLARE_ERROR(11051)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_DELETE PRL_RESULT_DECLARE_ERROR(11053)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SHOW_TREE PRL_RESULT_DECLARE_ERROR(11054)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SNAPSHOT_SWITCH PRL_RESULT_DECLARE_ERROR(11052)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM Macro

PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_SUSPEND_VM PRL_RESULT_DECLARE_ERROR(11049)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE Macro

PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_RESTRICTED_TO_UNDODISK_FEATURE PRL_RESULT_DECLARE_ERROR(11055)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_TOO_MANY_MEMORY Macro

PRL_ERR_LICENSE_TOO_MANY_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_TOO_MANY_MEMORY PRL_RESULT_DECLARE_ERROR(11016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_TOO_MANY_VCPUS Macro

PRL_ERR_LICENSE_TOO_MANY_VCPUS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_TOO_MANY_VCPUS PRL_RESULT_DECLARE_ERROR(11012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION Macro

PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_UNSUPPORTED_LICENSE_TYPE_TO_DEACTIVATION PRL_RESULT_DECLARE_ERROR(11070)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE Macro

PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_UPGRADE_NO_ACCEPTABLE_LICENSE PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE Macro

PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE PRL_RESULT_DECLARE_ERROR(11009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_VALID Macro

PRL_ERR_LICENSE_VALID Macro
PRL_ERR Macros

  • License

+++ ALIGNED VALUE TO 11000

Syntax
#define PRL_ERR_LICENSE_VALID PRL_ERR_SUCCESS
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES Macro

PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_VM_HAS_VTD_DEVICES PRL_RESULT_DECLARE_ERROR(11017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD Macro

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD PRL_RESULT_DECLARE_ERROR(11008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_DISTRIBUTOR Macro

PRL_ERR_LICENSE_WRONG_DISTRIBUTOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_DISTRIBUTOR PRL_RESULT_DECLARE_ERROR(11006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_LANGUAGE Macro

PRL_ERR_LICENSE_WRONG_LANGUAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_LANGUAGE PRL_RESULT_DECLARE_ERROR(11005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_PLATFORM Macro

PRL_ERR_LICENSE_WRONG_PLATFORM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_PLATFORM PRL_RESULT_DECLARE_ERROR(11004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_PRODUCT Macro

PRL_ERR_LICENSE_WRONG_PRODUCT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_PRODUCT PRL_RESULT_DECLARE_ERROR(11003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_VERSION Macro

PRL_ERR_LICENSE_WRONG_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LICENSE_WRONG_VERSION PRL_RESULT_DECLARE_ERROR(11002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM Macro

PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LINKED_CLONE_FOR_ENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(586)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM Macro

PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LINKED_CLONE_INVALID_ORIGINAL_VM PRL_RESULT_DECLARE_ERROR(585)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND Macro

PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LINKED_CLONE_ORIGINAL_VM_UUID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(584)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE Macro

PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LINKED_CLONE_WRONG_SNAPSHOT_STATE PRL_RESULT_DECLARE_ERROR(583)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LOCAL_AUTHENTICATION_FAILED Macro

PRL_ERR_LOCAL_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LOCAL_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(331)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE Macro

PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LOGIN_BY_MISMATCH_CLIENT_MODE PRL_RESULT_DECLARE_ERROR(475)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LOW_MEMORY_LIMIT Macro

PRL_ERR_LOW_MEMORY_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LOW_MEMORY_LIMIT PRL_RESULT_DECLARE_ERROR(539)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LPT_DEVICE_ALREADY_EXIST Macro

PRL_ERR_LPT_DEVICE_ALREADY_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LPT_DEVICE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(255)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED Macro

PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(216)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST Macro

PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(218)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH Macro

PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH PRL_RESULT_DECLARE_ERROR(211)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_INCORRECT Macro

PRL_ERR_MAC_ADDRESS_INCORRECT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_INCORRECT PRL_RESULT_DECLARE_ERROR(328)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_IS_EMPTY Macro

PRL_ERR_MAC_ADDRESS_IS_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_IS_EMPTY PRL_RESULT_DECLARE_ERROR(210)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START Macro

PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START PRL_RESULT_DECLARE_ERROR(212)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS Macro

PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS PRL_RESULT_DECLARE_ERROR(213)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS Macro

PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS PRL_RESULT_DECLARE_ERROR(214)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MAKE_DIRECTORY Macro

PRL_ERR_MAKE_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MAKE_DIRECTORY PRL_RESULT_DECLARE_ERROR(232)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MEM_EXCEED_PHY_SPACE Macro

PRL_ERR_MEM_EXCEED_PHY_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MEM_EXCEED_PHY_SPACE PRL_RESULT_DECLARE_ERROR(555)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MEMFILE_DECRYPT_FAILED Macro

PRL_ERR_MEMFILE_DECRYPT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MEMFILE_DECRYPT_FAILED PRL_RESULT_DECLARE_ERROR(44221)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MEMFILE_ENCRYPT_FAILED Macro

PRL_ERR_MEMFILE_ENCRYPT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MEMFILE_ENCRYPT_FAILED PRL_RESULT_DECLARE_ERROR(44220)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MEMORY_ALLOC_ERROR Macro

PRL_ERR_MEMORY_ALLOC_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MEMORY_ALLOC_ERROR PRL_RESULT_DECLARE_ERROR(10013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT Macro

PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MERGE_XML_DOCUMENT_CONFLICT PRL_RESULT_DECLARE_ERROR(515)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE Macro

PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE Macro
PRL_ERR Macros

  • MobileFileSharing (MFS) errors

+++ ALIGNED VALUE TO 55000

Syntax
#define PRL_ERR_MFS_GOOGLE_DRIVE_DOCUMENT_IS_NON_DOWNLOADABLE PRL_RESULT_DECLARE_ERROR(55000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED Macro

PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MOBILE_ADVANCED_AUTH_REQUIRED PRL_RESULT_DECLARE_ERROR(558)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MOUNTER_LIST_NO_OBJECT Macro

PRL_ERR_MOUNTER_LIST_NO_OBJECT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MOUNTER_LIST_NO_OBJECT PRL_RESULT_DECLARE_ERROR(46604)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST Macro

PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_MSG_START_32BIT_VM_ON_64BIT_HOST PRL_RESULT_DECLARE_ERROR(544)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NEED_KILL_PREV_SETTING Macro

PRL_ERR_NEED_KILL_PREV_SETTING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NEED_KILL_PREV_SETTING PRL_RESULT_DECLARE_SUCCESS(426)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NETWORK_ADAPTER_NOT_FOUND Macro

PRL_ERR_NETWORK_ADAPTER_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NETWORK_ADAPTER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(485)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NETWORK_ROLLBACK_FAILED Macro

PRL_ERR_NETWORK_ROLLBACK_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NETWORK_ROLLBACK_FAILED PRL_RESULT_DECLARE_ERROR(270)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_BOOTING_DEVICE_SELECTED Macro

PRL_ERR_NO_BOOTING_DEVICE_SELECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_BOOTING_DEVICE_SELECTED PRL_RESULT_DECLARE_ERROR(334)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_CD_DRIVE_AVAILABLE Macro

PRL_ERR_NO_CD_DRIVE_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_CD_DRIVE_AVAILABLE PRL_RESULT_DECLARE_ERROR(418)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_DATA Macro

PRL_ERR_NO_DATA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_DATA PRL_RESULT_DECLARE_ERROR(14)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_DISP_CONFIG_FOUND Macro

PRL_ERR_NO_DISP_CONFIG_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_DISP_CONFIG_FOUND PRL_RESULT_DECLARE_ERROR(19)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_GUEST_OS_FOUND Macro

PRL_ERR_NO_GUEST_OS_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_GUEST_OS_FOUND PRL_RESULT_DECLARE_ERROR(45007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS Macro

PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS PRL_RESULT_DECLARE_ERROR(369)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS Macro

PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_ONE_HARD_DISK_TO_COMPRESS PRL_RESULT_DECLARE_SUCCESS(490)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_PROBLEM_REPORT_FOUND Macro

PRL_ERR_NO_PROBLEM_REPORT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_PROBLEM_REPORT_FOUND PRL_RESULT_DECLARE_ERROR(85)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED Macro

PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED PRL_RESULT_DECLARE_ERROR(407)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_TARGET_PATH_SPECIFIED Macro

PRL_ERR_NO_TARGET_PATH_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_TARGET_PATH_SPECIFIED PRL_RESULT_DECLARE_ERROR(74)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_UNATTENDED_DISK Macro

PRL_ERR_NO_UNATTENDED_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_UNATTENDED_DISK PRL_ERR_FLOPPY_DRIVE_INVALID
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NO_VM_DIR_CONFIG_FOUND Macro

PRL_ERR_NO_VM_DIR_CONFIG_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NO_VM_DIR_CONFIG_FOUND PRL_RESULT_DECLARE_ERROR(26)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ALL_FILES_WAS_DELETED Macro

PRL_ERR_NOT_ALL_FILES_WAS_DELETED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ALL_FILES_WAS_DELETED PRL_RESULT_DECLARE_ERROR(102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_CONNECTED_TO_DISPATCHER Macro

PRL_ERR_NOT_CONNECTED_TO_DISPATCHER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_CONNECTED_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(251)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER Macro

PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_CONNECTED_TO_PROXY_MANAGER PRL_RESULT_DECLARE_ERROR(564)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE Macro

PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE PRL_RESULT_DECLARE_ERROR(307)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_DECRYPT_VM PRL_RESULT_DECLARE_ERROR(44213)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_HDD PRL_RESULT_DECLARE_ERROR(44217)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_ENCRYPT_VM PRL_RESULT_DECLARE_ERROR(44212)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM PRL_RESULT_DECLARE_ERROR(456)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE PRL_RESULT_DECLARE_ERROR(453)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE Macro

PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(298)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE Macro

PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_ENOUGH_RIGHTS_FOR_LINKED_CLONE PRL_RESULT_DECLARE_ERROR(513)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK Macro

PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NOT_LOCK_OWNER_SESSION_TRIES_TO_UNLOCK PRL_RESULT_DECLARE_ERROR(478)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NOT_SENTILLION_CLIENT Macro

PRL_ERR_NOT_SENTILLION_CLIENT Macro
PRL_ERR Macros

Sentillion errors +++ ALIGNED VALUE TO 39000

Syntax
#define PRL_ERR_NOT_SENTILLION_CLIENT PRL_RESULT_DECLARE_ERROR(39000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_NVRAM_FILE_COPY Macro

PRL_ERR_NVRAM_FILE_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_NVRAM_FILE_COPY PRL_RESULT_DECLARE_ERROR(436)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_BAD_INTERFACE Macro

PRL_ERR_OBJECT_BAD_INTERFACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_BAD_INTERFACE PRL_RESULT_DECLARE_ERROR(42004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_CLASS_NOT_FOUND Macro

PRL_ERR_OBJECT_CLASS_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_CLASS_NOT_FOUND PRL_RESULT_DECLARE_ERROR(42008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_DUPLICATE_CLASS Macro

PRL_ERR_OBJECT_DUPLICATE_CLASS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_DUPLICATE_CLASS PRL_RESULT_DECLARE_ERROR(42007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_DUPLICATE_UID Macro

PRL_ERR_OBJECT_DUPLICATE_UID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_DUPLICATE_UID PRL_RESULT_DECLARE_ERROR(42003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_LIB_CANT_GET_PERMS Macro

PRL_ERR_OBJECT_LIB_CANT_GET_PERMS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_LIB_CANT_GET_PERMS PRL_RESULT_DECLARE_ERROR(42006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_LIB_LOAD_ERROR Macro

PRL_ERR_OBJECT_LIB_LOAD_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_LIB_LOAD_ERROR PRL_RESULT_DECLARE_ERROR(42001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_LIB_NO_FUNCTIONS Macro

PRL_ERR_OBJECT_LIB_NO_FUNCTIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_LIB_NO_FUNCTIONS PRL_RESULT_DECLARE_ERROR(42002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_LIB_WRONG_PERMS Macro

PRL_ERR_OBJECT_LIB_WRONG_PERMS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_LIB_WRONG_PERMS PRL_RESULT_DECLARE_ERROR(42005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_NOT_FOUND Macro

PRL_ERR_OBJECT_NOT_FOUND Macro
PRL_ERR Macros

  • Shared objects manipulation errors

+++ ALIGNED VALUE TO 42000

Syntax
#define PRL_ERR_OBJECT_NOT_FOUND PRL_RESULT_DECLARE_ERROR(42000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OBJECT_WAS_REMOVED Macro

PRL_ERR_OBJECT_WAS_REMOVED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OBJECT_WAS_REMOVED PRL_RESULT_DECLARE_ERROR(406)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT Macro

PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT PRL_RESULT_DECLARE_ERROR(395)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING Macro

PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_ONLY_ADMIN_CAN_SET_VERBOSE_LOGGING PRL_RESULT_DECLARE_ERROR(527)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION Macro

PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION Macro
PRL_ERR Macros

VM guest operations errors +++ ALIGNED VALUE TO 34000

Syntax
#define PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION PRL_RESULT_DECLARE_ERROR(34000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_DISP_CONFIG_READ Macro

PRL_ERR_OPEN_DISP_CONFIG_READ Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_DISP_CONFIG_READ PRL_RESULT_DECLARE_ERROR(21)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_DISP_CONFIG_WRITE Macro

PRL_ERR_OPEN_DISP_CONFIG_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_DISP_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(22)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_FAILED Macro

PRL_ERR_OPEN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(520)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_PROBLEM_REPORT_READ Macro

PRL_ERR_OPEN_PROBLEM_REPORT_READ Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_PROBLEM_REPORT_READ PRL_RESULT_DECLARE_ERROR(86)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_VM_CONFIG_READ Macro

PRL_ERR_OPEN_VM_CONFIG_READ Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_VM_CONFIG_READ PRL_RESULT_DECLARE_ERROR(33)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_VM_CONFIG_WRITE Macro

PRL_ERR_OPEN_VM_CONFIG_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_VM_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(34)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_VM_DIR_CONFIG_READ Macro

PRL_ERR_OPEN_VM_DIR_CONFIG_READ Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_VM_DIR_CONFIG_READ PRL_RESULT_DECLARE_ERROR(28)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE Macro

PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(29)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPERATION_FAILED Macro

PRL_ERR_OPERATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(16)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPERATION_PENDING Macro

PRL_ERR_OPERATION_PENDING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPERATION_PENDING PRL_RESULT_DECLARE_ERROR(13)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OPERATION_WAS_CANCELED Macro

PRL_ERR_OPERATION_WAS_CANCELED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OPERATION_WAS_CANCELED PRL_RESULT_DECLARE_ERROR(275)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OS_RECONFIG_DATA_ABSENT Macro

PRL_ERR_OS_RECONFIG_DATA_ABSENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OS_RECONFIG_DATA_ABSENT PRL_RESULT_DECLARE_ERROR(45010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OUT_OF_DISK_SPACE Macro

PRL_ERR_OUT_OF_DISK_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OUT_OF_DISK_SPACE PRL_RESULT_DECLARE_ERROR(297)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_OUT_OF_MEMORY Macro

PRL_ERR_OUT_OF_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_OUT_OF_MEMORY PRL_RESULT_DECLARE_ERROR(2)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST Macro

PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(97)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARALLEL_PORT_IMG_COPY Macro

PRL_ERR_PARALLEL_PORT_IMG_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARALLEL_PORT_IMG_COPY PRL_RESULT_DECLARE_ERROR(236)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARALLEL_PORT_NO_RASTERIZER Macro

PRL_ERR_PARALLEL_PORT_NO_RASTERIZER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARALLEL_PORT_NO_RASTERIZER PRL_RESULT_DECLARE_ERROR(512)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARAM_NOT_FOUND Macro

PRL_ERR_PARAM_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARAM_NOT_FOUND PRL_RESULT_DECLARE_ERROR(17)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST Macro

PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARENT_LINKED_VM_CONFIG_DOESNT_EXIST PRL_RESULT_DECLARE_ERROR(581)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_CLIENT_PREFS Macro

PRL_ERR_PARSE_CLIENT_PREFS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_CLIENT_PREFS PRL_RESULT_DECLARE_ERROR(117)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_COMMON_SERVER_PREFS Macro

PRL_ERR_PARSE_COMMON_SERVER_PREFS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_COMMON_SERVER_PREFS PRL_RESULT_DECLARE_ERROR(121)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_DISP_CONFIG Macro

PRL_ERR_PARSE_DISP_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_DISP_CONFIG PRL_RESULT_DECLARE_ERROR(23)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_FILESYSTEM_INFO Macro

PRL_ERR_PARSE_FILESYSTEM_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_FILESYSTEM_INFO PRL_RESULT_DECLARE_ERROR(72)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_HARD_DISK_HW_INFO Macro

PRL_ERR_PARSE_HARD_DISK_HW_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_HARD_DISK_HW_INFO PRL_RESULT_DECLARE_ERROR(71)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_HOST_HW_INFO Macro

PRL_ERR_PARSE_HOST_HW_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_HOST_HW_INFO PRL_RESULT_DECLARE_ERROR(70)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_PROBLEM_REPORT Macro

PRL_ERR_PARSE_PROBLEM_REPORT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_PROBLEM_REPORT PRL_RESULT_DECLARE_ERROR(84)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_STATISTICS Macro

PRL_ERR_PARSE_STATISTICS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_STATISTICS PRL_RESULT_DECLARE_ERROR(276)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_USER_PROFILE Macro

PRL_ERR_PARSE_USER_PROFILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_USER_PROFILE PRL_RESULT_DECLARE_ERROR(73)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_VM_CONFIG Macro

PRL_ERR_PARSE_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(36)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSE_VM_DIR_CONFIG Macro

PRL_ERR_PARSE_VM_DIR_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSE_VM_DIR_CONFIG PRL_RESULT_DECLARE_ERROR(30)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PARSING_EVENT Macro

PRL_ERR_PARSING_EVENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PARSING_EVENT PRL_RESULT_DECLARE_ERROR(24)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED Macro

PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PASSWORD_FOR_ENCRYPTED_VM_WAS_CHANGED PRL_RESULT_DECLARE_ERROR(44211)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PATH_IS_NOT_DIRECTORY Macro

PRL_ERR_PATH_IS_NOT_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PATH_IS_NOT_DIRECTORY PRL_RESULT_DECLARE_ERROR(37031)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PAX_ACCESS_FORBIDDEN Macro

PRL_ERR_PAX_ACCESS_FORBIDDEN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PAX_ACCESS_FORBIDDEN PRL_RESULT_DECLARE_ERROR(612)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED Macro

PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PAX_HOST_LIMIT_WAS_EXCEEDED PRL_RESULT_DECLARE_ERROR(604)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PAX_LOGIN_MISMATCH_ERROR Macro

PRL_ERR_PAX_LOGIN_MISMATCH_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PAX_LOGIN_MISMATCH_ERROR PRL_RESULT_DECLARE_ERROR(49008)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_EXEC_FAILED Macro

PRL_ERR_PCMOVER_EXEC_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_EXEC_FAILED PRL_RESULT_DECLARE_ERROR(43103)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_MIGRATE_FAILED Macro

PRL_ERR_PCMOVER_MIGRATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_MIGRATE_FAILED PRL_RESULT_DECLARE_ERROR(43102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_NOT_INSTALLED Macro

PRL_ERR_PCMOVER_NOT_INSTALLED Macro
PRL_ERR Macros

PCmover managment library errors +++ ALIGNED VALUE TO 43100

Syntax
#define PRL_ERR_PCMOVER_NOT_INSTALLED PRL_RESULT_DECLARE_ERROR(43100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR Macro

PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_POLICY_FILE_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(43105)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR Macro

PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_POLICY_FILE_WRITE_ERROR PRL_RESULT_DECLARE_ERROR(43104)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR Macro

PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_VAN_FILE_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(43106)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR Macro

PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_VAN_FILE_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(43107)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED Macro

PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_VAN_FILE_PREPARE_FAILED PRL_RESULT_DECLARE_ERROR(43101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST Macro

PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PCMOVER_WINDOWS_DIR_NOT_EXIST PRL_RESULT_DECLARE_ERROR(43108)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PERFORM_MOUNTER_COMMAND Macro

PRL_ERR_PERFORM_MOUNTER_COMMAND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PERFORM_MOUNTER_COMMAND PRL_RESULT_DECLARE_ERROR(46603)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE Macro

PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PLAYER_CANT_SUSPEND_IN_PAUSE PRL_RESULT_DECLARE_ERROR(481)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PPC_INVALID_CREDENTIALS Macro

PRL_ERR_PPC_INVALID_CREDENTIALS Macro
PRL_ERR Macros

  • Proxy connection errors

+++ ALIGNED VALUE TO 600

Syntax
#define PRL_ERR_PPC_INVALID_CREDENTIALS PRL_RESULT_DECLARE_ERROR(600)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT Macro

PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PPC_INVALID_CREDENTIALS_ON_RECONNECT PRL_RESULT_DECLARE_ERROR(601)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PPC_SERVER_BUSY Macro

PRL_ERR_PPC_SERVER_BUSY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PPC_SERVER_BUSY PRL_RESULT_DECLARE_ERROR(602)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PPC_UNABLE_TO_CONNECT Macro

PRL_ERR_PPC_UNABLE_TO_CONNECT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PPC_UNABLE_TO_CONNECT PRL_RESULT_DECLARE_ERROR(603)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN Macro

PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PREPARE_FOR_HIBERNATE_TASK_ALREADY_RUN PRL_RESULT_DECLARE_ERROR(464)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY Macro

PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PREPARE_FOR_HIBERNATE_VM_CANNOT_STAND_BY PRL_RESULT_DECLARE_ERROR(467)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS Macro

PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WITHOUT_TOOLS PRL_RESULT_DECLARE_ERROR(466)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE Macro

PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PREPARE_FOR_HIBERNATE_VM_WRONG_STATE PRL_RESULT_DECLARE_ERROR(465)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PREV_SESSION_IS_ACTIVE Macro

PRL_ERR_PREV_SESSION_IS_ACTIVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PREV_SESSION_IS_ACTIVE PRL_RESULT_DECLARE_ERROR(64)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS Macro

PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(88)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_FILE_NOTSET Macro

PRL_ERR_PROBLEM_REPORT_FILE_NOTSET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROBLEM_REPORT_FILE_NOTSET PRL_RESULT_DECLARE_ERROR(87)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_WRITE Macro

PRL_ERR_PROBLEM_REPORT_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROBLEM_REPORT_WRITE PRL_RESULT_DECLARE_ERROR(89)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROXY_HANDSHAKE_FAILED Macro

PRL_ERR_PROXY_HANDSHAKE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROXY_HANDSHAKE_FAILED PRL_RESULT_DECLARE_ERROR(522)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROXY_PEER_NOT_FOUND Macro

PRL_ERR_PROXY_PEER_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROXY_PEER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(525)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROXY_WRONG_PORT_NUMBER Macro

PRL_ERR_PROXY_WRONG_PORT_NUMBER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROXY_WRONG_PORT_NUMBER PRL_RESULT_DECLARE_ERROR(524)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION Macro

PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_PROXY_WRONG_PROTOCOL_VERSION PRL_RESULT_DECLARE_ERROR(523)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_CONNECT_DESKTOP_ERROR Macro

PRL_ERR_RCC_CONNECT_DESKTOP_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_CONNECT_DESKTOP_ERROR PRL_RESULT_DECLARE_ERROR(49004)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_CONNECT_SERVER_ERROR Macro

PRL_ERR_RCC_CONNECT_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_CONNECT_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(49002)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_DESKTOP_SUSPENDED Macro

PRL_ERR_RCC_DESKTOP_SUSPENDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_DESKTOP_SUSPENDED PRL_RESULT_DECLARE_ERROR(49007)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_DEVICE_BLACKLISTED Macro

PRL_ERR_RCC_DEVICE_BLACKLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_DEVICE_BLACKLISTED PRL_RESULT_DECLARE_ERROR(49009)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_DEVICE_GREYLISTED Macro

PRL_ERR_RCC_DEVICE_GREYLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_DEVICE_GREYLISTED PRL_RESULT_DECLARE_ERROR(49010)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_OPEN_APP_ERROR Macro

PRL_ERR_RCC_OPEN_APP_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_OPEN_APP_ERROR PRL_RESULT_DECLARE_ERROR(49005)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED Macro

PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_PAX_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(49001)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_PAX_LOGIN_ERROR Macro

PRL_ERR_RCC_PAX_LOGIN_ERROR Macro
PRL_ERR Macros

RCC errors +++ ALIGNED VALUE TO 49000

Syntax
#define PRL_ERR_RCC_PAX_LOGIN_ERROR PRL_RESULT_DECLARE_ERROR(49000)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED Macro

PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_SERVER_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(49003)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE Macro

PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_VIDEO_STREAM_UNAVAILABLE PRL_RESULT_DECLARE_ERROR(49006)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RCC_WAKEUP_SERVER_ERROR Macro

PRL_ERR_RCC_WAKEUP_SERVER_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RCC_WAKEUP_SERVER_ERROR PRL_RESULT_DECLARE_ERROR(49011)
File

PrlPrivateErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_READ_FAILED Macro

PRL_ERR_READ_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_READ_FAILED PRL_RESULT_DECLARE_ERROR(518)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_READ_XML_CONTENT Macro

PRL_ERR_READ_XML_CONTENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_READ_XML_CONTENT PRL_RESULT_DECLARE_ERROR(35)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_READONLY_FILESYSTEM Macro

PRL_ERR_READONLY_FILESYSTEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_READONLY_FILESYSTEM PRL_RESULT_DECLARE_ERROR(356)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REBOOT_HOST Macro

PRL_ERR_REBOOT_HOST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REBOOT_HOST PRL_RESULT_DECLARE_ERROR(352)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS Macro

PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REG_PSTORAGE_REVOKE_IS_NEEDS PRL_RESULT_DECLARE_ERROR(46901)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_EXIST Macro

PRL_ERR_REMOTE_DEVICE_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REMOTE_DEVICE_EXIST PRL_RESULT_DECLARE_ERROR(279)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_NOT_EXIST Macro

PRL_ERR_REMOTE_DEVICE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REMOTE_DEVICE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(280)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED Macro

PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED Macro
PRL_ERR Macros

Device of this type cannot be remote device type is not registered

Syntax
#define PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED PRL_RESULT_DECLARE_ERROR(278)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD Macro

PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REMOTE_DISPLAY_EMPTY_PASSWORD PRL_RESULT_DECLARE_ERROR(487)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED Macro

PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(344)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER Macro

PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER PRL_RESULT_DECLARE_ERROR(345)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS Macro

PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RESUME_BOOTCAMP_CHANGED_DISK_CONTENTS PRL_RESULT_DECLARE_ERROR(20014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM Macro

PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RESUME_BOOTCAMP_CORRUPT_DISK_STATE_PARAM PRL_RESULT_DECLARE_ERROR(20013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RETRIEVE_VM_CONFIG Macro

PRL_ERR_RETRIEVE_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RETRIEVE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(240)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RETURN_CODE_RANG_EEND Macro

PRL_ERR_RETURN_CODE_RANG_EEND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RETURN_CODE_RANG_EEND PRL_RESULT_DECLARE_ERROR(113)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_IMPERSONATE_FAILED Macro

PRL_ERR_REVERT_IMPERSONATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(351)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_BY_GUEST_SLEEP_TIMEOUT PRL_RESULT_DECLARE_ERROR(36011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_PAUSED PRL_RESULT_DECLARE_ERROR(36010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_CAPS PRL_RESULT_DECLARE_ERROR(36027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_REVERT_SNAPSHOT_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_RUN_VM_ACTION_SCRIPT Macro

PRL_ERR_RUN_VM_ACTION_SCRIPT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_RUN_VM_ACTION_SCRIPT PRL_RESULT_DECLARE_ERROR(552)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC Macro

PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SAFE_MODE_START_DURING_SUSPENDING_SYNC PRL_RESULT_DECLARE_ERROR(20011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SAMPLE_CONFIG_NOT_FOUND Macro

PRL_ERR_SAMPLE_CONFIG_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SAMPLE_CONFIG_NOT_FOUND PRL_RESULT_DECLARE_ERROR(27029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SAVE_VM_CATALOG Macro

PRL_ERR_SAVE_VM_CATALOG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SAVE_VM_CATALOG PRL_RESULT_DECLARE_ERROR(90)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SAVE_VM_CONFIG Macro

PRL_ERR_SAVE_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SAVE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(234)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SDK_TRY_AGAIN Macro

PRL_ERR_SDK_TRY_AGAIN Macro
PRL_ERR Macros

SDK errors +++ ALIGNED VALUE TO 50000

Syntax
#define PRL_ERR_SDK_TRY_AGAIN PRL_RESULT_DECLARE_ERROR(50000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED Macro

PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED PRL_RESULT_DECLARE_ERROR(108)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SEND_COMMAND_TOWS_FAILED Macro

PRL_ERR_SEND_COMMAND_TOWS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SEND_COMMAND_TOWS_FAILED PRL_RESULT_DECLARE_ERROR(250)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERIAL_IMG_COPY Macro

PRL_ERR_SERIAL_IMG_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERIAL_IMG_COPY PRL_RESULT_DECLARE_ERROR(235)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERIAL_IMG_NOT_FOUND Macro

PRL_ERR_SERIAL_IMG_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERIAL_IMG_NOT_FOUND PRL_RESULT_DECLARE_ERROR(233)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST Macro

PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(96)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERVER_GOES_DOWN Macro

PRL_ERR_SERVER_GOES_DOWN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERVER_GOES_DOWN PRL_RESULT_DECLARE_ERROR(248)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERVER_PREFS_EDIT_COLLISION Macro

PRL_ERR_SERVER_PREFS_EDIT_COLLISION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERVER_PREFS_EDIT_COLLISION PRL_RESULT_DECLARE_ERROR(326)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SERVICE_BUSY Macro

PRL_ERR_SERVICE_BUSY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SERVICE_BUSY PRL_RESULT_DECLARE_ERROR(521)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_CPULIMIT Macro

PRL_ERR_SET_CPULIMIT Macro
PRL_ERR Macros

Virtuozzo specific error +++ ALIGNED VALUE TO 44000

Syntax
#define PRL_ERR_SET_CPULIMIT PRL_RESULT_DECLARE_ERROR(44000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_CPUMASK Macro

PRL_ERR_SET_CPUMASK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_CPUMASK PRL_RESULT_DECLARE_ERROR(44005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_CPUUNITS Macro

PRL_ERR_SET_CPUUNITS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_CPUUNITS PRL_RESULT_DECLARE_ERROR(44001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED Macro

PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_DEFAULT_ENCRYPTION_PLUGIN_FEATURE_DISABLED PRL_RESULT_DECLARE_ERROR(44239)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_IOLIMIT Macro

PRL_ERR_SET_IOLIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_IOLIMIT PRL_RESULT_DECLARE_ERROR(44004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_IOPRIO Macro

PRL_ERR_SET_IOPRIO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_IOPRIO PRL_RESULT_DECLARE_ERROR(44002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_LICENSE_INVALID_ARG Macro

PRL_ERR_SET_LICENSE_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_LICENSE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(138)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_LICENSE_INVALID_KEY Macro

PRL_ERR_SET_LICENSE_INVALID_KEY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_LICENSE_INVALID_KEY PRL_RESULT_DECLARE_ERROR(139)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SET_NETWORK_SETTINGS_FAILED Macro

PRL_ERR_SET_NETWORK_SETTINGS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SET_NETWORK_SETTINGS_FAILED PRL_RESULT_DECLARE_ERROR(34005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE Macro

PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE PRL_RESULT_DECLARE_ERROR(247)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SMC_ERROR Macro

PRL_ERR_SMC_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SMC_ERROR PRL_RESULT_DECLARE_ERROR(111)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED Macro

PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SMP_NOT_SUPPORTED_HVT_DISABLED PRL_RESULT_DECLARE_ERROR(505)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT Macro

PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SMP_NOT_SUPPORTED_HVT_NOT_PRESENT PRL_RESULT_DECLARE_ERROR(506)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SNAPSHOTS_COPY Macro

PRL_ERR_SNAPSHOTS_COPY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SNAPSHOTS_COPY PRL_RESULT_DECLARE_ERROR(437)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOME_TASKS_PRESENT Macro

PRL_ERR_SOME_TASKS_PRESENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOME_TASKS_PRESENT PRL_RESULT_DECLARE_ERROR(363)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOME_VMS_RUNNING Macro

PRL_ERR_SOME_VMS_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOME_VMS_RUNNING PRL_RESULT_DECLARE_ERROR(362)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOUND_BAD_EMULATION_TYPE Macro

PRL_ERR_SOUND_BAD_EMULATION_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOUND_BAD_EMULATION_TYPE PRL_RESULT_DECLARE_ERROR(5003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOUND_DEVICE_WRITE_FAILED Macro

PRL_ERR_SOUND_DEVICE_WRITE_FAILED Macro
PRL_ERR Macros

  • Sound

+++ ALIGNED VALUE TO 5000

Syntax
#define PRL_ERR_SOUND_DEVICE_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(5000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED Macro

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(5002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED Macro

PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(5001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK Macro

PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SOURCE_ISNT_BOOTCAMP_DISK PRL_RESULT_DECLARE_ERROR(45009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SSL_HANDSHAKE_FAILED Macro

PRL_ERR_SSL_HANDSHAKE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SSL_HANDSHAKE_FAILED PRL_RESULT_DECLARE_ERROR(414)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT Macro

PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STAND_BY_VM_BY_GUEST_SLEEP_TIMEOUT PRL_RESULT_DECLARE_ERROR(36019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STAND_BY_VM_PAUSED Macro

PRL_ERR_STAND_BY_VM_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STAND_BY_VM_PAUSED PRL_RESULT_DECLARE_ERROR(36015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL Macro

PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STAND_BY_VM_WITH_OUTDATED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL Macro

PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STAND_BY_VM_WITH_UNLOADED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STAND_BY_VM_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_START_SAFE_MODE_UNSUPPORTED Macro

PRL_ERR_START_SAFE_MODE_UNSUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_START_SAFE_MODE_UNSUPPORTED PRL_RESULT_DECLARE_ERROR(547)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_START_VM_BY_NOT_AUTH_USER Macro

PRL_ERR_START_VM_BY_NOT_AUTH_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_START_VM_BY_NOT_AUTH_USER PRL_RESULT_DECLARE_ERROR(530)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_START_VM_BY_NOT_DEFINED_USER Macro

PRL_ERR_START_VM_BY_NOT_DEFINED_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_START_VM_BY_NOT_DEFINED_USER PRL_RESULT_DECLARE_ERROR(529)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_ALREADY_EXISTS Macro

PRL_ERR_STATE_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(19015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG Macro

PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG PRL_RESULT_DECLARE_ERROR(19024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_FOR_WRITE Macro

PRL_ERR_STATE_CANT_OPEN_FOR_WRITE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_CANT_OPEN_FOR_WRITE PRL_RESULT_DECLARE_ERROR(19010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_IMAGE Macro

PRL_ERR_STATE_CANT_OPEN_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_CANT_OPEN_IMAGE PRL_RESULT_DECLARE_ERROR(19009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_LOCKED Macro

PRL_ERR_STATE_CANT_OPEN_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_CANT_OPEN_LOCKED PRL_RESULT_DECLARE_ERROR(19011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_CANT_SAVE_LOCKED Macro

PRL_ERR_STATE_CANT_SAVE_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_CANT_SAVE_LOCKED PRL_RESULT_DECLARE_ERROR(19012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_DELETE_NONCLOSED Macro

PRL_ERR_STATE_DELETE_NONCLOSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_DELETE_NONCLOSED PRL_RESULT_DECLARE_ERROR(19023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_ERROR_CREATE_IMAGE Macro

PRL_ERR_STATE_ERROR_CREATE_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_ERROR_CREATE_IMAGE PRL_RESULT_DECLARE_ERROR(19007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_ERROR_RENAMING_IMAGE Macro

PRL_ERR_STATE_ERROR_RENAMING_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_ERROR_RENAMING_IMAGE PRL_RESULT_DECLARE_ERROR(19008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_FULL_DELETE_FAILED Macro

PRL_ERR_STATE_FULL_DELETE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_FULL_DELETE_FAILED PRL_RESULT_DECLARE_ERROR(19018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_GETFREESPACE_FAILED Macro

PRL_ERR_STATE_GETFREESPACE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_GETFREESPACE_FAILED PRL_RESULT_DECLARE_ERROR(19025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_INT_CORRUPTED Macro

PRL_ERR_STATE_INT_CORRUPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_INT_CORRUPTED PRL_RESULT_DECLARE_ERROR(19013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_INVALID_IMAGE_TYPE Macro

PRL_ERR_STATE_INVALID_IMAGE_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_INVALID_IMAGE_TYPE PRL_RESULT_DECLARE_ERROR(19022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_INVALID_PARAMETERS Macro

PRL_ERR_STATE_INVALID_PARAMETERS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_INVALID_PARAMETERS PRL_RESULT_DECLARE_ERROR(19006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_MEMORY_ERROR Macro

PRL_ERR_STATE_MEMORY_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_MEMORY_ERROR PRL_RESULT_DECLARE_ERROR(19021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_MERGE_FAILED Macro

PRL_ERR_STATE_MERGE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_MERGE_FAILED PRL_RESULT_DECLARE_ERROR(19019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_MERGE_NO_SPACE Macro

PRL_ERR_STATE_MERGE_NO_SPACE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_MERGE_NO_SPACE PRL_RESULT_DECLARE_ERROR(19020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_NO_DISKS Macro

PRL_ERR_STATE_NO_DISKS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_NO_DISKS PRL_RESULT_DECLARE_ERROR(19001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_NO_STATE Macro

PRL_ERR_STATE_NO_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_NO_STATE PRL_RESULT_DECLARE_ERROR(19014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_NOT_OPENED Macro

PRL_ERR_STATE_NOT_OPENED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_NOT_OPENED PRL_RESULT_DECLARE_ERROR(19016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_NOT_PERMITTED Macro

PRL_ERR_STATE_NOT_PERMITTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(19017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_NOT_RELEASED Macro

PRL_ERR_STATE_NOT_RELEASED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_NOT_RELEASED PRL_RESULT_DECLARE_ERROR(19027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_PROCESS_RUNNING Macro

PRL_ERR_STATE_PROCESS_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_PROCESS_RUNNING PRL_RESULT_DECLARE_ERROR(19002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_ROLLBACK_ERROR Macro

PRL_ERR_STATE_ROLLBACK_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_ROLLBACK_ERROR PRL_RESULT_DECLARE_ERROR(19005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_ROLLBACK_IN_PROGRESS Macro

PRL_ERR_STATE_ROLLBACK_IN_PROGRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_ROLLBACK_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(19004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_STATFS_FAILED Macro

PRL_ERR_STATE_STATFS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_STATFS_FAILED PRL_RESULT_DECLARE_ERROR(19026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_STOPPING_STATE Macro

PRL_ERR_STATE_STOPPING_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_STATE_STOPPING_STATE PRL_RESULT_DECLARE_ERROR(19003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_STATE_UNEXPECTED_ERROR Macro

PRL_ERR_STATE_UNEXPECTED_ERROR Macro
PRL_ERR Macros

  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

Syntax
#define PRL_ERR_STATE_UNEXPECTED_ERROR PRL_RESULT_DECLARE_ERROR(19000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUCCESS Macro

PRL_ERR_SUCCESS Macro
PRL_ERR Macros

All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.

Syntax
#define PRL_ERR_SUCCESS PRL_RESULT_DECLARE_SUCCESS(0)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK Macro

PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_BOOTCAMP_NOT_NTFS_ONLY_DISK PRL_RESULT_DECLARE_ERROR(20015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED Macro

PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_BOOTCAMP_NTFS_RW_MOUNTERS_DETECTED PRL_RESULT_DECLARE_ERROR(20016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_REJECTED_BY_GUEST Macro

PRL_ERR_SUSPEND_REJECTED_BY_GUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_REJECTED_BY_GUEST PRL_RESULT_DECLARE_ERROR(480)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro

PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_VM_VTD_BY_GUEST_SLEEP_TIMEOUT PRL_RESULT_DECLARE_ERROR(36002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_PAUSED Macro

PRL_ERR_SUSPEND_VM_VTD_PAUSED Macro
PRL_ERR Macros

VM error codes +++ ALIGNED VALUE TO 36000

Syntax
#define PRL_ERR_SUSPEND_VM_VTD_PAUSED PRL_RESULT_DECLARE_ERROR(36000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro

PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_VM_VTD_WITH_OUTDATED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro

PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_VM_VTD_WITH_UNLOADED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS Macro

PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_CAPS PRL_RESULT_DECLARE_ERROR(36025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_ERROR(36001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SUSPEND_WITH_USB_BOOTDISK Macro

PRL_ERR_SUSPEND_WITH_USB_BOOTDISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SUSPEND_WITH_USB_BOOTDISK PRL_RESULT_DECLARE_ERROR(36029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SYMBOL_NOT_FOUND Macro

PRL_ERR_SYMBOL_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SYMBOL_NOT_FOUND PRL_RESULT_DECLARE_ERROR(12)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED Macro

PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_SYSTEM_OVERCOMMIT_PROHIBITED PRL_RESULT_DECLARE_ERROR(582)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED Macro

PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED PRL_RESULT_DECLARE_ERROR(77)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY Macro

PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY PRL_RESULT_DECLARE_ERROR(76)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TASK_NOT_FOUND Macro

PRL_ERR_TASK_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TASK_NOT_FOUND PRL_RESULT_DECLARE_ERROR(92)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TEMPLATE_HAS_APPS Macro

PRL_ERR_TEMPLATE_HAS_APPS Macro
PRL_ERR Macros

containers templates errors +++ ALIGNED VALUE TO 46400

Syntax
#define PRL_ERR_TEMPLATE_HAS_APPS PRL_RESULT_DECLARE_ERROR(46400)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TEMPLATE_NOT_FOUND Macro

PRL_ERR_TEMPLATE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TEMPLATE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(46401)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TEST_TEXT_MESSAGES Macro

PRL_ERR_TEST_TEXT_MESSAGES Macro
PRL_ERR Macros

Test errors +++ ALIGNED VALUE TO 43200

Syntax
#define PRL_ERR_TEST_TEXT_MESSAGES PRL_RESULT_DECLARE_ERROR(43200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TEST_TEXT_MESSAGES_PS Macro

PRL_ERR_TEST_TEXT_MESSAGES_PS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TEST_TEXT_MESSAGES_PS PRL_RESULT_DECLARE_ERROR(43201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP Macro

PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TIME_MACHINE_EXCLUDED_LIST_OP PRL_RESULT_DECLARE_ERROR(546)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TIMEOUT Macro

PRL_ERR_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TIMEOUT PRL_RESULT_DECLARE_ERROR(15)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TIS_INVALID_UID Macro

PRL_ERR_TIS_INVALID_UID Macro
PRL_ERR Macros

  • TIS errors

+++ ALIGNED VALUE TO 27800

Syntax
#define PRL_ERR_TIS_INVALID_UID PRL_RESULT_DECLARE_ERROR(27800)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TOO_LOW_HDD_SIZE Macro

PRL_ERR_TOO_LOW_HDD_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TOO_LOW_HDD_SIZE PRL_RESULT_DECLARE_ERROR(260)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TOOLS_UNSUPPORTED_GUEST Macro

PRL_ERR_TOOLS_UNSUPPORTED_GUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TOOLS_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_ERROR(370)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_TRY_AGAIN Macro

PRL_ERR_TRY_AGAIN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_TRY_AGAIN PRL_RESULT_DECLARE_ERROR(450)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE Macro

PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_APPLY_MEMORY_GUARANTEE PRL_RESULT_DECLARE_ERROR(538)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT Macro

PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_APPLY_TOTAL_LIMIT PRL_RESULT_DECLARE_ERROR(541)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_DROP_SUSPENDED_STATE Macro

PRL_ERR_UNABLE_DROP_SUSPENDED_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_DROP_SUSPENDED_STATE PRL_RESULT_DECLARE_ERROR(103)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_SEND_REQUEST Macro

PRL_ERR_UNABLE_SEND_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(172)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS Macro

PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_CLEANUP_BROKEN_TRANSACTIONS PRL_RESULT_DECLARE_ERROR(44227)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION Macro

PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_COMMIT_BROKEN_TRANSACTION PRL_RESULT_DECLARE_ERROR(44228)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION Macro

PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_COMMIT_TRANSACTION PRL_RESULT_DECLARE_ERROR(44209)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED Macro

PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_CONTINUE_VM_LIFETIME_IS_EXPIRED PRL_RESULT_DECLARE_ERROR(573)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM Macro

PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_CREATE_ENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM Macro

PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_DECRYPT_LINKED_CLONE_VM PRL_RESULT_DECLARE_ERROR(44255)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM Macro

PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_DECRYPT_PROTECTED_VM PRL_RESULT_DECLARE_ERROR(44253)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM Macro

PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_DECRYPT_UNENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44219)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM Macro

PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_ENCRYPT_LINKED_CLONE_VM PRL_RESULT_DECLARE_ERROR(44254)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION Macro

PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_FINALIZE_TRANSACTION PRL_RESULT_DECLARE_ERROR(44210)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE Macro

PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_PATCH_CONFIG_FILE PRL_RESULT_DECLARE_ERROR(44207)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM Macro

PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_PROTECT_UNENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44250)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED Macro

PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_PROTECT_VM_IS_ALREADY_PROTECTED PRL_RESULT_DECLARE_ERROR(44246)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD Macro

PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_REGISTER_ENCRYPTED_VM_WO_PASSWD PRL_RESULT_DECLARE_ERROR(44202)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION Macro

PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_ROLLBACK_BROKEN_TRANSACTION PRL_RESULT_DECLARE_ERROR(44229)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION Macro

PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_ROLLBACK_TRANSACTION PRL_RESULT_DECLARE_ERROR(44208)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_SEND_REQUEST Macro

PRL_ERR_UNABLE_TO_SEND_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(11714)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE Macro

PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE PRL_RESULT_DECLARE_ERROR(566)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER Macro

PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_SETUP_HEADLESS_MODE_BY_NON_PRIVILEGED_USER PRL_RESULT_DECLARE_ERROR(567)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED Macro

PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNABLE_TO_UNPROTECT_VM_IS_NOT_PROTECTED PRL_RESULT_DECLARE_ERROR(44247)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST Macro

PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNATTENDED_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_ERROR(40001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNDER_OLD_HYPERVISOR Macro

PRL_ERR_UNDER_OLD_HYPERVISOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNDER_OLD_HYPERVISOR PRL_RESULT_DECLARE_ERROR(258)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNEXPECTED Macro

PRL_ERR_UNEXPECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNEXPECTED PRL_RESULT_DECLARE_ERROR(1)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNIMPLEMENTED Macro

PRL_ERR_UNIMPLEMENTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNIMPLEMENTED PRL_RESULT_DECLARE_ERROR(8)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNINITIALIZED Macro

PRL_ERR_UNINITIALIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNINITIALIZED PRL_RESULT_DECLARE_ERROR(7)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNNAMED_CT_MOVE Macro

PRL_ERR_UNNAMED_CT_MOVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNNAMED_CT_MOVE PRL_RESULT_DECLARE_ERROR(44009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNRECOGNIZED_REQUEST Macro

PRL_ERR_UNRECOGNIZED_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNRECOGNIZED_REQUEST PRL_RESULT_DECLARE_ERROR(91)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNSUPPORTED_DEVICE_TYPE Macro

PRL_ERR_UNSUPPORTED_DEVICE_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNSUPPORTED_DEVICE_TYPE PRL_RESULT_DECLARE_ERROR(1002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNSUPPORTED_FILE_SYSTEM Macro

PRL_ERR_UNSUPPORTED_FILE_SYSTEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNSUPPORTED_FILE_SYSTEM PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE Macro

PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNSUPPORTED_LAYOUTS_STRUCTURE PRL_RESULT_DECLARE_ERROR(45008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM Macro

PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM PRL_RESULT_DECLARE_ERROR(399)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE Macro

PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE Macro
PRL_ERR Macros

VI convert errors +++ ALIGNED VALUE TO 45000

Syntax
#define PRL_ERR_UNSUPPORTED_VIRTUAL_SOURCE PRL_RESULT_DECLARE_ERROR(45000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED Macro

PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(174)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED Macro

PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(173)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UPD_UPDATER_CONFIG Macro

PRL_ERR_UPD_UPDATER_CONFIG Macro
PRL_ERR Macros

  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

Syntax
#define PRL_ERR_UPD_UPDATER_CONFIG PRL_RESULT_DECLARE_ERROR(17000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UPD_UPDATES Macro

PRL_ERR_UPD_UPDATES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UPD_UPDATES PRL_RESULT_DECLARE_ERROR(17001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_UPDATE_MEM_VM_NOT_CREATED Macro

PRL_ERR_UPDATE_MEM_VM_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_UPDATE_MEM_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(171)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE Macro

PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE PRL_RESULT_DECLARE_ERROR(119)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART Macro

PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART PRL_RESULT_DECLARE_ERROR(259)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE Macro

PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE PRL_RESULT_DECLARE_ERROR(120)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_DIRECTORY_NOT_SET Macro

PRL_ERR_USER_DIRECTORY_NOT_SET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_DIRECTORY_NOT_SET PRL_RESULT_DECLARE_ERROR(67)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_IS_ALREADY_LOGGED Macro

PRL_ERR_USER_IS_ALREADY_LOGGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_IS_ALREADY_LOGGED PRL_RESULT_DECLARE_ERROR(61)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR Macro

PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_CREATE_ROOT_VM_DIR PRL_RESULT_DECLARE_ERROR(468)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR Macro

PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR PRL_RESULT_DECLARE_ERROR(316)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS Macro

PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS PRL_RESULT_DECLARE_ERROR(257)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_EDIT_VM Macro

PRL_ERR_USER_NO_AUTH_TO_EDIT_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_EDIT_VM PRL_RESULT_DECLARE_ERROR(321)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES Macro

PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_SAVE_BACKUP_FILES PRL_RESULT_DECLARE_ERROR(37030)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES Macro

PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES PRL_RESULT_DECLARE_ERROR(313)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_NOT_FOUND Macro

PRL_ERR_USER_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(390)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_OPERATION_NOT_AUTHORISED Macro

PRL_ERR_USER_OPERATION_NOT_AUTHORISED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_OPERATION_NOT_AUTHORISED PRL_RESULT_DECLARE_ERROR(59)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_USER_PROFILE_WAS_CHANGED Macro

PRL_ERR_USER_PROFILE_WAS_CHANGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_USER_PROFILE_WAS_CHANGED PRL_RESULT_DECLARE_ERROR(118)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VA_CONFIG Macro

PRL_ERR_VA_CONFIG Macro
PRL_ERR Macros

  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

Syntax
#define PRL_ERR_VA_CONFIG PRL_RESULT_DECLARE_ERROR(18000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ABORT Macro

PRL_ERR_VM_ABORT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ABORT PRL_RESULT_DECLARE_ERROR(325)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED Macro

PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED PRL_RESULT_DECLARE_ERROR(184)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALLOC_VM_MEMORY Macro

PRL_ERR_VM_ALLOC_VM_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALLOC_VM_MEMORY PRL_RESULT_DECLARE_ERROR(185)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_CONNECTED Macro

PRL_ERR_VM_ALREADY_CONNECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_CONNECTED PRL_RESULT_DECLARE_ERROR(391)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_CREATED Macro

PRL_ERR_VM_ALREADY_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_CREATED PRL_RESULT_DECLARE_ERROR(124)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_ENCRYPTED Macro

PRL_ERR_VM_ALREADY_ENCRYPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_ENCRYPTED PRL_RESULT_DECLARE_ERROR(44218)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED Macro

PRL_ERR_VM_ALREADY_REGISTERED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED PRL_RESULT_DECLARE_ERROR(447)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS Macro

PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS PRL_RESULT_DECLARE_ERROR(114)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME PRL_RESULT_DECLARE_ERROR(115)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH PRL_RESULT_DECLARE_ERROR(63)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID PRL_RESULT_DECLARE_ERROR(62)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_RESUMED Macro

PRL_ERR_VM_ALREADY_RESUMED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_RESUMED PRL_RESULT_DECLARE_ERROR(52)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_RUNNING Macro

PRL_ERR_VM_ALREADY_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(402)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ALREADY_SUSPENDED Macro

PRL_ERR_VM_ALREADY_SUSPENDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ALREADY_SUSPENDED PRL_RESULT_DECLARE_ERROR(50)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ANOTHER_TOOLS_IN_USE Macro

PRL_ERR_VM_ANOTHER_TOOLS_IN_USE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ANOTHER_TOOLS_IN_USE PRL_RESULT_DECLARE_ERROR(425)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_APPLY_CHANGES_PENDING Macro

PRL_ERR_VM_APPLY_CHANGES_PENDING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_APPLY_CHANGES_PENDING PRL_RESULT_DECLARE_ERROR(366)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_APPLY_CONFIG_FAILED Macro

PRL_ERR_VM_APPLY_CONFIG_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_APPLY_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(290)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT Macro

PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT PRL_RESULT_DECLARE_ERROR(291)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR Macro

PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR PRL_RESULT_DECLARE_ERROR(180)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN Macro

PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_AUTO_COMPRESS_TASK_ALREADY_RUN PRL_RESULT_DECLARE_ERROR(497)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE Macro

PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_BACKUP_HDD_IMAGE_OUT_OF_BUNDLE PRL_RESULT_DECLARE_ERROR(37035)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE Macro

PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_BACKUP_INVALID_DISK_TYPE PRL_RESULT_DECLARE_ERROR(37036)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_BAD_OS_TYPE Macro

PRL_ERR_VM_BAD_OS_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_BAD_OS_TYPE PRL_RESULT_DECLARE_ERROR(202)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CANT_CLONE_HDD_MISSING Macro

PRL_ERR_VM_CANT_CLONE_HDD_MISSING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CANT_CLONE_HDD_MISSING PRL_RESULT_DECLARE_ERROR(320)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CANT_CLONE_RUNNING Macro

PRL_ERR_VM_CANT_CLONE_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CANT_CLONE_RUNNING PRL_RESULT_DECLARE_ERROR(292)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CANT_DELETE_RUNNING Macro

PRL_ERR_VM_CANT_DELETE_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CANT_DELETE_RUNNING PRL_RESULT_DECLARE_ERROR(293)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CANT_UNREG_RUNNING Macro

PRL_ERR_VM_CANT_UNREG_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CANT_UNREG_RUNNING PRL_RESULT_DECLARE_ERROR(294)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_COMPACT_HARD_DISK_FAILED Macro

PRL_ERR_VM_COMPACT_HARD_DISK_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_COMPACT_HARD_DISK_FAILED PRL_RESULT_DECLARE_ERROR(496)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS Macro

PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_COMPACT_NOT_SUPPORTED_GUEST_OS PRL_RESULT_DECLARE_ERROR(500)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_COMPACT_PROCESSING Macro

PRL_ERR_VM_COMPACT_PROCESSING Macro
PRL_ERR Macros

  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

Syntax
#define PRL_ERR_VM_COMPACT_PROCESSING PRL_RESULT_DECLARE_ERROR(28000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_INVALID_ARG Macro

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONF_CHANGED_INVALID_ARG PRL_RESULT_DECLARE_ERROR(134)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_NOT_CREATED Macro

PRL_ERR_VM_CONF_CHANGED_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONF_CHANGED_NOT_CREATED PRL_RESULT_DECLARE_ERROR(133)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_NOT_STARTED Macro

PRL_ERR_VM_CONF_CHANGED_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONF_CHANGED_NOT_STARTED PRL_RESULT_DECLARE_ERROR(135)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV Macro

PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV PRL_RESULT_DECLARE_ERROR(136)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_VM_CONFIG_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(37)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_CAN_BE_RESTORED Macro

PRL_ERR_VM_CONFIG_CAN_BE_RESTORED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_CAN_BE_RESTORED PRL_RESULT_DECLARE_ERROR(454)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_DOESNT_EXIST Macro

PRL_ERR_VM_CONFIG_DOESNT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_DOESNT_EXIST PRL_RESULT_DECLARE_ERROR(283)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID Macro

PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID PRL_RESULT_DECLARE_ERROR(375)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_INVALID_VM_UUID Macro

PRL_ERR_VM_CONFIG_INVALID_VM_UUID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_INVALID_VM_UUID PRL_RESULT_DECLARE_ERROR(374)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_IS_ALREADY_VALID Macro

PRL_ERR_VM_CONFIG_IS_ALREADY_VALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_IS_ALREADY_VALID PRL_RESULT_DECLARE_ERROR(455)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CONFIG_WAS_CHANGED Macro

PRL_ERR_VM_CONFIG_WAS_CHANGED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CONFIG_WAS_CHANGED PRL_RESULT_DECLARE_ERROR(112)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER Macro

PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER PRL_RESULT_DECLARE_ERROR(398)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG Macro

PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(167)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE Macro

PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE PRL_RESULT_DECLARE_ERROR(168)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CREATE_INVALID_ARG Macro

PRL_ERR_VM_CREATE_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CREATE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(123)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_CREATE_SNAPSHOT_FAILED Macro

PRL_ERR_VM_CREATE_SNAPSHOT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_CREATE_SNAPSHOT_FAILED PRL_ERR_VM_SAVE_STATE_FAILED
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DELETE_STATE_FAILED Macro

PRL_ERR_VM_DELETE_STATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DELETE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(427)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED Macro

PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED PRL_RESULT_DECLARE_ERROR(57)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DEV_CONNECT_FAILED Macro

PRL_ERR_VM_DEV_CONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DEV_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(55)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DEV_DISCONNECT_FAILED Macro

PRL_ERR_VM_DEV_DISCONNECT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DEV_DISCONNECT_FAILED PRL_RESULT_DECLARE_ERROR(56)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED Macro

PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED PRL_RESULT_DECLARE_ERROR(273)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DEVICES_TERMINATION_FAILED Macro

PRL_ERR_VM_DEVICES_TERMINATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DEVICES_TERMINATION_FAILED PRL_RESULT_DECLARE_ERROR(274)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(31)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DIR_FILE_NOT_SET Macro

PRL_ERR_VM_DIR_FILE_NOT_SET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DIR_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(39)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST Macro

PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST PRL_RESULT_DECLARE_ERROR(449)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_NOT_EXIST Macro

PRL_ERR_VM_DIRECTORY_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DIRECTORY_NOT_EXIST PRL_RESULT_DECLARE_ERROR(327)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED Macro

PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED PRL_RESULT_DECLARE_ERROR(65)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DOES_NOT_STOPPED Macro

PRL_ERR_VM_DOES_NOT_STOPPED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DOES_NOT_STOPPED PRL_RESULT_DECLARE_ERROR(241)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED Macro

PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED PRL_RESULT_DECLARE_ERROR(434)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS Macro

PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(457)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE Macro

PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_CONVERT_TO_TEMPLATE PRL_RESULT_DECLARE_ERROR(576)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE Macro

PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(451)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE Macro

PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(435)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EMPTY_NAME_OF_CLONE Macro

PRL_ERR_VM_EMPTY_NAME_OF_CLONE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EMPTY_NAME_OF_CLONE PRL_RESULT_DECLARE_ERROR(231)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE Macro

PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(34001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND Macro

PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND PRL_RESULT_DECLARE_ERROR(34003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED Macro

PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXPIRATION_HOST_DATETIME_SKEWED PRL_RESULT_DECLARE_ERROR(570)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED Macro

PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXPIRATION_OFFLINE_GRACE_PERIOD_EXPIRED PRL_RESULT_DECLARE_ERROR(569)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE Macro

PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXPIRATION_TIME_CHECK_INTERVAL_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(568)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE Macro

PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXPIRATION_VM_IS_ABOUT_TO_EXPIRE PRL_RESULT_DECLARE_ERROR(572)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD Macro

PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_EXPIRATION_VM_IS_IN_OFFLINE_GRACE_PERIOD PRL_RESULT_DECLARE_ERROR(571)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_FILES_ALREADY_REMOVED Macro

PRL_ERR_VM_FILES_ALREADY_REMOVED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_FILES_ALREADY_REMOVED PRL_RESULT_DECLARE_ERROR(305)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_FREE_VM_MEMORY Macro

PRL_ERR_VM_FREE_VM_MEMORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_FREE_VM_MEMORY PRL_RESULT_DECLARE_ERROR(186)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_FAILED Macro

PRL_ERR_VM_GET_CONFIG_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(49)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_INVALID_ARG Macro

PRL_ERR_VM_GET_CONFIG_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_CONFIG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(130)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED Macro

PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(131)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_DEVICE_STATE_FAILED Macro

PRL_ERR_VM_GET_DEVICE_STATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_DEVICE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(58)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG Macro

PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(169)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN Macro

PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN PRL_RESULT_DECLARE_ERROR(170)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_INVALID_ARG Macro

PRL_ERR_VM_GET_INDICATORS_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_INDICATORS_INVALID_ARG PRL_RESULT_DECLARE_ERROR(165)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_NOT_CREATED Macro

PRL_ERR_VM_GET_INDICATORS_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_INDICATORS_NOT_CREATED PRL_RESULT_DECLARE_ERROR(164)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING Macro

PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(166)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED Macro

PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED PRL_RESULT_DECLARE_ERROR(48)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED Macro

PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(148)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED Macro

PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED PRL_RESULT_DECLARE_ERROR(149)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING Macro

PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(150)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_STATUS_FAILED Macro

PRL_ERR_VM_GET_STATUS_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_STATUS_FAILED PRL_RESULT_DECLARE_ERROR(47)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GET_STATUS_INVALID_ARG Macro

PRL_ERR_VM_GET_STATUS_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GET_STATUS_INVALID_ARG PRL_RESULT_DECLARE_ERROR(126)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GUEST_SESSION_EXPIRED Macro

PRL_ERR_VM_GUEST_SESSION_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GUEST_SESSION_EXPIRED PRL_RESULT_DECLARE_ERROR(34002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_GUESTMEM_FAIL Macro

PRL_ERR_VM_GUESTMEM_FAIL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_GUESTMEM_FAIL PRL_RESULT_DECLARE_ERROR(392)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE Macro

PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HARD_DISK_NOT_COMPACTABLE PRL_RESULT_DECLARE_ERROR(498)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED Macro

PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HDD_DISCONNECT_FAILED_LOCKED PRL_RESULT_DECLARE_ERROR(528)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HDD_SIZE Macro

PRL_ERR_VM_HDD_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HDD_SIZE PRL_RESULT_DECLARE_ERROR(177)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY Macro

PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY PRL_RESULT_DECLARE_ERROR(228)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH Macro

PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HYPERVISOR_HVT_ENABLED_ON_HYPERSWITCH PRL_RESULT_DECLARE_ERROR(559)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_HYPERVIZOR_COMM Macro

PRL_ERR_VM_HYPERVIZOR_COMM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_HYPERVIZOR_COMM PRL_RESULT_DECLARE_ERROR(198)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IN_FROZEN_STATE Macro

PRL_ERR_VM_IN_FROZEN_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IN_FROZEN_STATE PRL_RESULT_DECLARE_ERROR(554)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IN_HDD_CONSTRUCTOR Macro

PRL_ERR_VM_IN_HDD_CONSTRUCTOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IN_HDD_CONSTRUCTOR PRL_RESULT_DECLARE_ERROR(178)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IN_WAKING_UP_STATE Macro

PRL_ERR_VM_IN_WAKING_UP_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IN_WAKING_UP_STATE PRL_RESULT_DECLARE_ERROR(553)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_INIT_MONITOR Macro

PRL_ERR_VM_INIT_MONITOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_INIT_MONITOR PRL_RESULT_DECLARE_ERROR(190)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_INIT_VCPU Macro

PRL_ERR_VM_INIT_VCPU Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_INIT_VCPU PRL_RESULT_DECLARE_ERROR(191)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_INTERACT_PRLS_DRIVER Macro

PRL_ERR_VM_INTERACT_PRLS_DRIVER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_INTERACT_PRLS_DRIVER PRL_RESULT_DECLARE_ERROR(187)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_INTERNAL_OS_ERROR Macro

PRL_ERR_VM_INTERNAL_OS_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_INTERNAL_OS_ERROR PRL_RESULT_DECLARE_ERROR(269)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_INVALID_SWAP_REGION Macro

PRL_ERR_VM_INVALID_SWAP_REGION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_INVALID_SWAP_REGION PRL_RESULT_DECLARE_ERROR(378)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED Macro

PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IS_EXCLUSIVELY_LOCKED PRL_RESULT_DECLARE_ERROR(476)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IS_NOT_LOCKED Macro

PRL_ERR_VM_IS_NOT_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IS_NOT_LOCKED PRL_RESULT_DECLARE_ERROR(477)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_IS_NOT_SUSPENDED Macro

PRL_ERR_VM_IS_NOT_SUSPENDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_IS_NOT_SUSPENDED PRL_RESULT_DECLARE_ERROR(420)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LIFETIME_IS_EXPIRED Macro

PRL_ERR_VM_LIFETIME_IS_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LIFETIME_IS_EXPIRED PRL_RESULT_DECLARE_ERROR(565)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOAD_BINARY_FAILED Macro

PRL_ERR_VM_LOAD_BINARY_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOAD_BINARY_FAILED PRL_RESULT_DECLARE_ERROR(403)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOAD_MONITOR Macro

PRL_ERR_VM_LOAD_MONITOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOAD_MONITOR PRL_RESULT_DECLARE_ERROR(195)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP Macro

PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_CTL_FOR_BACKUP PRL_RESULT_DECLARE_ERROR(38115)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_BACKUP Macro

PRL_ERR_VM_LOCKED_FOR_BACKUP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_BACKUP PRL_RESULT_DECLARE_ERROR(38113)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL Macro

PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_CHANGE_FIREWALL PRL_RESULT_DECLARE_ERROR(38122)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD Macro

PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_CHANGE_PASSWORD PRL_RESULT_DECLARE_ERROR(38121)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CLONE Macro

PRL_ERR_VM_LOCKED_FOR_CLONE Macro
PRL_ERR Macros

Dispatcher 'locked' error codes +++ ALIGNED VALUE TO 38100

Syntax
#define PRL_ERR_VM_LOCKED_FOR_CLONE PRL_RESULT_DECLARE_ERROR(38100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE Macro

PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_COPY_IMAGE PRL_RESULT_DECLARE_ERROR(38123)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT PRL_RESULT_DECLARE_ERROR(38110)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DECRYPT Macro

PRL_ERR_VM_LOCKED_FOR_DECRYPT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DECRYPT PRL_RESULT_DECLARE_ERROR(38120)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DELETE Macro

PRL_ERR_VM_LOCKED_FOR_DELETE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DELETE PRL_RESULT_DECLARE_ERROR(38101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT PRL_RESULT_DECLARE_ERROR(38112)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT Macro

PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DISK_COMPACT PRL_RESULT_DECLARE_ERROR(38117)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT Macro

PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DISK_CONVERT PRL_RESULT_DECLARE_ERROR(38118)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE Macro

PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DISK_RESIZE PRL_RESULT_DECLARE_ERROR(38116)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT Macro

PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT PRL_RESULT_DECLARE_ERROR(38103)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME Macro

PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME PRL_RESULT_DECLARE_ERROR(38107)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_ENCRYPT Macro

PRL_ERR_VM_LOCKED_FOR_ENCRYPT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_ENCRYPT PRL_RESULT_DECLARE_ERROR(38119)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EXECUTE Macro

PRL_ERR_VM_LOCKED_FOR_EXECUTE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EXECUTE PRL_RESULT_DECLARE_ERROR(38104)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX Macro

PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX PRL_RESULT_DECLARE_ERROR(38105)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON Macro

PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON PRL_RESULT_DECLARE_ERROR(38106)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_MIGRATE Macro

PRL_ERR_VM_LOCKED_FOR_MIGRATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_MIGRATE PRL_RESULT_DECLARE_ERROR(38109)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_MOVE Macro

PRL_ERR_VM_LOCKED_FOR_MOVE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_MOVE PRL_RESULT_DECLARE_ERROR(38124)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION Macro

PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_REMOVE_PROTECTION PRL_RESULT_DECLARE_ERROR(38126)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP Macro

PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_RESTORE_FROM_BACKUP PRL_RESULT_DECLARE_ERROR(38114)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION Macro

PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_SET_PROTECTION PRL_RESULT_DECLARE_ERROR(38125)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT PRL_RESULT_DECLARE_ERROR(38111)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_UNREGISTER Macro

PRL_ERR_VM_LOCKED_FOR_UNREGISTER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_UNREGISTER PRL_RESULT_DECLARE_ERROR(38102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY Macro

PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY PRL_RESULT_DECLARE_ERROR(38108)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MAP_VM_MEM0 Macro

PRL_ERR_VM_MAP_VM_MEM0 Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MAP_VM_MEM0 PRL_RESULT_DECLARE_ERROR(189)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS Macro

PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(20009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED Macro

PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_ACCESS_TO_VM_DENIED PRL_RESULT_DECLARE_ERROR(31046)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION Macro

PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_BREAK_BY_DISK_CONDITION PRL_RESULT_DECLARE_ERROR(31039)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY Macro

PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_CANNOT_CREATE_DIRECTORY PRL_RESULT_DECLARE_ERROR(31052)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM Macro

PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_CANNOT_REMOTE_CLONE_SHARED_VM PRL_RESULT_DECLARE_ERROR(31037)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED Macro

PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED Macro
PRL_ERR Macros

VM migration errors codes set +++ ALIGNED VALUE TO 31000

Syntax
#define PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED PRL_RESULT_DECLARE_ERROR(31000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED Macro

PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_CONTINUE_START_FAILED PRL_RESULT_DECLARE_ERROR(31038)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION Macro

PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION PRL_RESULT_DECLARE_ERROR(31016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE Macro

PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_DEVICE_IMAGE_OUT_OF_BUNDLE PRL_RESULT_DECLARE_ERROR(31041)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM Macro

PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_ERROR_DELETE_VM PRL_RESULT_DECLARE_ERROR(31047)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM Macro

PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_ERROR_UNREGISTER_VM PRL_RESULT_DECLARE_ERROR(31048)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_EXT_DISK_DIR_ALREADY_EXISTS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31051)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED Macro

PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_EXTERNAL_DISKS_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(31050)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE Macro

PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_INVALID_DISK_TYPE PRL_RESULT_DECLARE_ERROR(31042)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET PRL_RESULT_DECLARE_ERROR(31005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT Macro

PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET_SHORT PRL_RESULT_DECLARE_ERROR(31043)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE PRL_RESULT_DECLARE_ERROR(31001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET PRL_RESULT_DECLARE_ERROR(31015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET PRL_RESULT_DECLARE_ERROR(31002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED Macro

PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_REGISTER_VM_FAILED PRL_RESULT_DECLARE_ERROR(31031)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED Macro

PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_REMOTE_DEVICE_IS_ATTACHED PRL_RESULT_DECLARE_ERROR(31027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_RESUME_FAILED Macro

PRL_ERR_VM_MIGRATE_RESUME_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_RESUME_FAILED PRL_RESULT_DECLARE_ERROR(31029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED Macro

PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_RESUME_VM_FAILED PRL_RESULT_DECLARE_ERROR(31033)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE Macro

PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_STORAGE_INFO_PARSE PRL_RESULT_DECLARE_ERROR(31030)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED Macro

PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_SUSPEND_VM_FAILED PRL_RESULT_DECLARE_ERROR(31032)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE Macro

PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_TARGET_INSIDE_SHARED_VM_PRIVATE PRL_RESULT_DECLARE_ERROR(31053)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS Macro

PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(31003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE Macro

PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_TO_THE_SAME_NODE PRL_RESULT_DECLARE_ERROR(31045)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE Macro

PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_UNSUITABLE_VM_STATE PRL_RESULT_DECLARE_ERROR(31017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_VM_ALREADY_MIGRATE_ON_TARGET PRL_RESULT_DECLARE_ERROR(31034)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_VM_HOME_ALREADY_EXISTS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_VM_UUID_ALREADY_EXISTS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED Macro

PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MIGRATE_WARM_MODE_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(31040)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MONITOR Macro

PRL_ERR_VM_MONITOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MONITOR PRL_RESULT_DECLARE_ERROR(200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MOUNT Macro

PRL_ERR_VM_MOUNT Macro
PRL_ERR Macros

VM hdd mount/umount +++ ALIGNED VALUE TO 46600

Syntax
#define PRL_ERR_VM_MOUNT PRL_RESULT_DECLARE_ERROR(46600)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING Macro

PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING PRL_RESULT_DECLARE_ERROR(376)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES Macro

PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES PRL_RESULT_DECLARE_ERROR(384)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_NAME_IS_EMPTY Macro

PRL_ERR_VM_NAME_IS_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(116)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_NOT_CREATED Macro

PRL_ERR_VM_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(125)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_OPERATION_FAILED Macro

PRL_ERR_VM_OPERATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(69)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PAUSE_ALREADY_PAUSED Macro

PRL_ERR_VM_PAUSE_ALREADY_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PAUSE_ALREADY_PAUSED PRL_RESULT_DECLARE_ERROR(147)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PAUSE_FAILED Macro

PRL_ERR_VM_PAUSE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PAUSE_FAILED PRL_RESULT_DECLARE_ERROR(51)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PAUSE_NOT_CREATED Macro

PRL_ERR_VM_PAUSE_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PAUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(145)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PAUSE_NOT_STARTED Macro

PRL_ERR_VM_PAUSE_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PAUSE_NOT_STARTED PRL_RESULT_DECLARE_ERROR(146)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_POWER_OFF_FAILED Macro

PRL_ERR_VM_POWER_OFF_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_POWER_OFF_FAILED PRL_RESULT_DECLARE_ERROR(45)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_POWER_ON_FAILED Macro

PRL_ERR_VM_POWER_ON_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_POWER_ON_FAILED PRL_RESULT_DECLARE_ERROR(44)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM Macro

PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM PRL_RESULT_DECLARE_ERROR(199)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PROCESS_IS_NOT_STARTED Macro

PRL_ERR_VM_PROCESS_IS_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PROCESS_IS_NOT_STARTED PRL_RESULT_DECLARE_ERROR(68)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW Macro

PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PROCESS_IS_NOT_STARTED_BY_WRONG_HOST_SW PRL_RESULT_DECLARE_ERROR(502)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY Macro

PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_PROTECT_PASSWORD_IS_EMPTY PRL_RESULT_DECLARE_ERROR(44252)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_REQUEST_NOT_SUPPORTED Macro

PRL_ERR_VM_REQUEST_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_REQUEST_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESET_FAILED Macro

PRL_ERR_VM_RESET_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESET_FAILED PRL_RESULT_DECLARE_ERROR(46)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESTART_GUEST_FAILED Macro

PRL_ERR_VM_RESTART_GUEST_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESTART_GUEST_FAILED PRL_RESULT_DECLARE_ERROR(438)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESTART_NOT_CREATED Macro

PRL_ERR_VM_RESTART_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESTART_NOT_CREATED PRL_RESULT_DECLARE_ERROR(143)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESTART_NOT_STARTED Macro

PRL_ERR_VM_RESTART_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESTART_NOT_STARTED PRL_RESULT_DECLARE_ERROR(144)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESTORE_STATE_FAILED Macro

PRL_ERR_VM_RESTORE_STATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESTORE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(54)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED Macro

PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESTORE_STATE_FAILED_VM_STOPPED PRL_RESULT_DECLARE_ERROR(503)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESUME_FAILED Macro

PRL_ERR_VM_RESUME_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESUME_FAILED PRL_RESULT_DECLARE_ERROR(20006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME Macro

PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME PRL_RESULT_DECLARE_SUCCESS(20007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SAVE_STATE_FAILED Macro

PRL_ERR_VM_SAVE_STATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SAVE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(53)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED Macro

PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(158)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING Macro

PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(159)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED Macro

PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED PRL_RESULT_DECLARE_ERROR(160)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED Macro

PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED PRL_RESULT_DECLARE_ERROR(161)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING Macro

PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(162)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_PAUSED Macro

PRL_ERR_VM_SEND_KEYBOARD_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_PAUSED PRL_RESULT_DECLARE_ERROR(163)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED Macro

PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(155)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING Macro

PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(156)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_PAUSED Macro

PRL_ERR_VM_SEND_REL_MOUSE_PAUSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_PAUSED PRL_RESULT_DECLARE_ERROR(157)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SET_CONFIG_FAILED Macro

PRL_ERR_VM_SET_CONFIG_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SET_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(43)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SET_CONFIG_INVALID_ARG Macro

PRL_ERR_VM_SET_CONFIG_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SET_CONFIG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(132)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SET_LICENSE_FAILED Macro

PRL_ERR_VM_SET_LICENSE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SET_LICENSE_FAILED PRL_RESULT_DECLARE_ERROR(42)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SET_VISIBLE_NOT_CREATED Macro

PRL_ERR_VM_SET_VISIBLE_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SET_VISIBLE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(151)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SHUTDOWN_FAILED Macro

PRL_ERR_VM_SHUTDOWN_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SHUTDOWN_FAILED PRL_RESULT_DECLARE_ERROR(36020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED Macro

PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SHUTDOWN_HIBERNATE_FAILED PRL_RESULT_DECLARE_ERROR(36024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED Macro

PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SHUTDOWN_HIBERNATE_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(36022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED Macro

PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SHUTDOWN_MACHINE_LOCKED PRL_RESULT_DECLARE_ERROR(36021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED Macro

PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SHUTDOWN_SUSPEND_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(36023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG Macro

PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG PRL_RESULT_DECLARE_ERROR(428)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE Macro

PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE PRL_RESULT_DECLARE_ERROR(440)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE Macro

PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(429)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_NOT_FOUND Macro

PRL_ERR_VM_SNAPSHOT_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SNAPSHOT_NOT_FOUND PRL_RESULT_DECLARE_ERROR(472)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND Macro

PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SNAPSHOTS_CONFIG_NOT_FOUND PRL_RESULT_DECLARE_ERROR(473)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES Macro

PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES PRL_RESULT_DECLARE_ERROR(299)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_START_FAILED Macro

PRL_ERR_VM_START_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_START_FAILED PRL_RESULT_DECLARE_ERROR(41)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_START_NOT_CONFIGURED Macro

PRL_ERR_VM_START_NOT_CONFIGURED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_START_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(141)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_START_NOT_CREATED Macro

PRL_ERR_VM_START_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_START_NOT_CREATED PRL_RESULT_DECLARE_ERROR(140)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_STOP_NOT_CREATED Macro

PRL_ERR_VM_STOP_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_STOP_NOT_CREATED PRL_RESULT_DECLARE_ERROR(142)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG Macro

PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG PRL_RESULT_DECLARE_ERROR(20008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_SUSPEND_FAILED Macro

PRL_ERR_VM_SUSPEND_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_SUSPEND_FAILED PRL_RESULT_DECLARE_ERROR(20005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED Macro

PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(337)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_TOOL_NOT_AVAILABLE Macro

PRL_ERR_VM_TOOL_NOT_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_TOOL_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(33002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS Macro

PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS Macro
PRL_ERR Macros

VM tools erros codes set +++ ALIGNED VALUE TO 33000

Syntax
#define PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS PRL_RESULT_DECLARE_ERROR(33000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART Macro

PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART PRL_RESULT_DECLARE_ERROR(33001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_ALLOC_MEM Macro

PRL_ERR_VM_UNABLE_ALLOC_MEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_ALLOC_MEM PRL_RESULT_DECLARE_ERROR(188)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR Macro

PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR PRL_RESULT_DECLARE_ERROR(196)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_CREATE_TIMER Macro

PRL_ERR_VM_UNABLE_CREATE_TIMER Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_CREATE_TIMER PRL_RESULT_DECLARE_ERROR(197)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_GET_GUEST_CPU Macro

PRL_ERR_VM_UNABLE_GET_GUEST_CPU Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_GET_GUEST_CPU PRL_RESULT_DECLARE_ERROR(192)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE Macro

PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE PRL_RESULT_DECLARE_ERROR(181)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_SEND_REQUEST Macro

PRL_ERR_VM_UNABLE_SEND_REQUEST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(183)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE Macro

PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE PRL_RESULT_DECLARE_ERROR(179)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNDEFINED_API_CALL Macro

PRL_ERR_VM_UNDEFINED_API_CALL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNDEFINED_API_CALL PRL_RESULT_DECLARE_ERROR(182)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNMOUNT Macro

PRL_ERR_VM_UNMOUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNMOUNT PRL_RESULT_DECLARE_ERROR(46601)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UNPAUSE_FAILED Macro

PRL_ERR_VM_UNPAUSE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UNPAUSE_FAILED PRL_RESULT_DECLARE_ERROR(517)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED Macro

PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED PRL_RESULT_DECLARE_ERROR(432)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_USER_AUTHENTICATION_FAILED Macro

PRL_ERR_VM_USER_AUTHENTICATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_USER_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(396)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UUID_EMPTY Macro

PRL_ERR_VM_UUID_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UUID_EMPTY PRL_RESULT_DECLARE_ERROR(230)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_UUID_NOT_FOUND Macro

PRL_ERR_VM_UUID_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_UUID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(105)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_VALLOC_MON_BODY Macro

PRL_ERR_VM_VALLOC_MON_BODY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_VALLOC_MON_BODY PRL_RESULT_DECLARE_ERROR(193)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_VALLOC_PE_IMG Macro

PRL_ERR_VM_VALLOC_PE_IMG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_VALLOC_PE_IMG PRL_RESULT_DECLARE_ERROR(194)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_INVALID_ARG Macro

PRL_ERR_VM_VIEW_SCR_INVALID_ARG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_VIEW_SCR_INVALID_ARG PRL_RESULT_DECLARE_ERROR(153)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_NOT_CREATED Macro

PRL_ERR_VM_VIEW_SCR_NOT_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_VIEW_SCR_NOT_CREATED PRL_RESULT_DECLARE_ERROR(152)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_NOT_RUNNING Macro

PRL_ERR_VM_VIEW_SCR_NOT_RUNNING Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VM_VIEW_SCR_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(154)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN Macro

PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN Macro
PRL_ERR Macros

Unused PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN

Syntax
#define PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN PRL_RESULT_DECLARE_ERROR(27053)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS Macro

PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(27052)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE Macro

PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE PRL_RESULT_DECLARE_ERROR(27051)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE Macro

PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE Macro
PRL_ERR Macros

ALIGNED VALUE TO 27050

Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE PRL_RESULT_DECLARE_ERROR(27050)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME Macro

PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME PRL_RESULT_DECLARE_ERROR(27401)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27402)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET Macro

PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_OLD_CHIPSET PRL_RESULT_DECLARE_ERROR(27405)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS Macro

PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_SET_SATA_FOR_UNSUPPORTED_OS PRL_RESULT_DECLARE_ERROR(27404)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY Macro
PRL_ERR Macros

ALIGNED VALUE TO 27400

Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27400)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME Macro

PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_URL_FORMAT_SYS_NAME PRL_RESULT_DECLARE_ERROR(27403)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT Macro

PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT PRL_RESULT_DECLARE_ERROR(27202)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT Macro

PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT PRL_RESULT_DECLARE_ERROR(27201)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPU_MASK_INVALID Macro

PRL_ERR_VMCONF_CPU_MASK_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPU_MASK_INVALID PRL_RESULT_DECLARE_ERROR(27203)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM Macro

PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPU_MASK_INVALID_CPU_NUM PRL_RESULT_DECLARE_ERROR(27204)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPU_ZERO_COUNT Macro

PRL_ERR_VMCONF_CPU_ZERO_COUNT Macro
PRL_ERR Macros

ALIGNED VALUE TO 27200

Syntax
#define PRL_ERR_VMCONF_CPU_ZERO_COUNT PRL_RESULT_DECLARE_ERROR(27200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPULIMIT_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_CPUUNITS_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES Macro

PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES PRL_RESULT_DECLARE_ERROR(27006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS Macro

PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_DUPLICATE_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27507)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27351)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID PRL_RESULT_DECLARE_ERROR(27353)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE PRL_RESULT_DECLARE_ERROR(27352)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27354)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY Macro
PRL_ERR Macros

ALIGNED VALUE TO 27350

Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27350)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME Macro

PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_URL_FORMAT_SYS_NAME PRL_RESULT_DECLARE_ERROR(27355)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED Macro

PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED Macro
PRL_ERR Macros

ALIGNED VALUE TO 27760

Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED PRL_RESULT_DECLARE_ERROR(27760)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM Macro

PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_DUPLICATE_IN_ANOTHER_VM PRL_RESULT_DECLARE_ERROR(27764)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED Macro

PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_CONNECTED PRL_RESULT_DECLARE_ERROR(27762)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND Macro

PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(27761)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME Macro

PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DUPLICATE_SYS_NAME PRL_RESULT_DECLARE_ERROR(27766)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE Macro

PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE Macro
PRL_ERR Macros

PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE is unused

Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_DEVICE_IS_ONE PRL_RESULT_DECLARE_ERROR(27763)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE Macro

PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE PRL_RESULT_DECLARE_ERROR(27767)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT Macro

PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_WRONG_COUNT PRL_ERR_VMCONF_GENERIC_PCI_VIDEO_NOT_SINGLE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE Macro

PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_WRONG_DEVICE PRL_RESULT_DECLARE_ERROR(27765)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME Macro

PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME PRL_RESULT_DECLARE_ERROR(27453)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27451)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID Macro

PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID PRL_RESULT_DECLARE_ERROR(27452)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION Macro

PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_MISS_BOOTCAMP_PARTITION PRL_RESULT_DECLARE_ERROR(27457)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK Macro

PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_NOT_ENOUGH_SPACE_FOR_ENCRYPT_DISK PRL_RESULT_DECLARE_ERROR(27459)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET Macro

PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_OLD_CHIPSET PRL_RESULT_DECLARE_ERROR(27461)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS Macro

PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SET_SATA_FOR_UNSUPPORTED_OS PRL_RESULT_DECLARE_ERROR(27460)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27454)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY Macro
PRL_ERR Macros

ALIGNED VALUE TO 27450

Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27450)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS Macro

PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_UNABLE_DELETE_DISK_WITH_SNAPSHOTS PRL_RESULT_DECLARE_ERROR(27462)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME Macro

PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_URL_FORMAT_SYS_NAME PRL_RESULT_DECLARE_ERROR(27455)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION Macro

PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_BOOTCAMP_PARTITION PRL_RESULT_DECLARE_ERROR(27456)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM Macro

PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_WRONG_TYPE_FOR_ENCRYPTRED_VM PRL_RESULT_DECLARE_ERROR(27458)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE Macro
PRL_ERR Macros

ALIGNED VALUE TO 27700

Syntax
#define PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27700)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX Macro

PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX PRL_RESULT_DECLARE_ERROR(27701)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX Macro

PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX PRL_RESULT_DECLARE_ERROR(27005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_IOLIMIT_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_IOPRIO_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_IOPSLIMIT_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MAX_BALLOON_SIZE_MORE_100_PERCENT PRL_RESULT_DECLARE_ERROR(27254)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MQ_INVALID_RANGE PRL_RESULT_DECLARE_ERROR(27257)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_LESS_VMM_OVERHEAD_VALUE PRL_RESULT_DECLARE_ERROR(27258)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MQ_MIN_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27259)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27256)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO Macro

PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_MQ_PRIOR_ZERO PRL_RESULT_DECLARE_ERROR(27255)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE PRL_RESULT_DECLARE_ERROR(27252)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27251)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX Macro

PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_ABOVE_MAX PRL_RESULT_DECLARE_ERROR(27260)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED Macro

PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED PRL_RESULT_DECLARE_SUCCESS(27253)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE Macro
PRL_ERR Macros

ALIGNED VALUE TO 27250

Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE PRL_RESULT_DECLARE_ERROR(27250)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART Macro

PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTART PRL_RESULT_DECLARE_ERROR(27030)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP Macro

PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_AUTOSTOP PRL_RESULT_DECLARE_ERROR(27031)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT Macro

PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NEED_HEADLESS_MODE_FOR_KEEP_VM_ALIVE_ON_GUI_EXIT PRL_RESULT_DECLARE_ERROR(27032)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_BROADCAST_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27509)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27503)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS PRL_RESULT_DECLARE_ERROR(27502)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(27504)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_GATEWAY_NOT_IN_SUBNET PRL_RESULT_DECLARE_ERROR(27511)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_GUEST_TOOLS_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(27506)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX Macro
PRL_ERR Macros

ALIGNED VALUE TO 27500

Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX PRL_RESULT_DECLARE_ERROR(27500)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_DNS_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27512)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_GATEWAY_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27510)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27505)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS PRL_RESULT_DECLARE_ERROR(27501)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_SEARCH_DOMAIN_NAME PRL_RESULT_DECLARE_ERROR(27513)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_MULTICAST_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27508)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_ROUTED_NO_STATIC_ADDRESS PRL_RESULT_DECLARE_ERROR(27514)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD Macro

PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_SMART_GUARD PRL_RESULT_DECLARE_ERROR(27020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS Macro

PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_AUTO_COMPRESS_WITH_UNDO_DISKS PRL_RESULT_DECLARE_ERROR(27019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS Macro

PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_CONFIGURED_TOTALRATE_FOR_NETWORK_CLASS PRL_RESULT_DECLARE_ERROR(27772)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE Macro

PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE PRL_RESULT_DECLARE_ERROR(27015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE Macro

PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(27014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT Macro

PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT Macro
PRL_ERR Macros

ALIGNED VALUE TO 27770

Syntax
#define PRL_ERR_VMCONF_NO_IP_ADDRESSES_SPECIFIED_FOR_OFFLINE_MANAGEMENT PRL_RESULT_DECLARE_ERROR(27770)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS Macro

PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_NO_SMART_GUARD_WITH_UNDO_DISKS PRL_RESULT_DECLARE_ERROR(27021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27651)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27652)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY Macro
PRL_ERR Macros

ALIGNED VALUE TO 27650

Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27650)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME Macro

PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_URL_FORMAT_SYS_NAME PRL_RESULT_DECLARE_ERROR(27653)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_EMPTY_PASSWORD PRL_RESULT_DECLARE_ERROR(27103)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO PRL_RESULT_DECLARE_ERROR(27101)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27102)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_PASSWORD_TOO_LONG PRL_RESULT_DECLARE_ERROR(27104)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO Macro
PRL_ERR Macros

ALIGNED VALUE TO 27100

Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO PRL_RESULT_DECLARE_ERROR(27100)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT Macro

PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_RESTRICTED_CPU_COUNT PRL_RESULT_DECLARE_ERROR(26501)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE Macro

PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_RESTRICTED_MEMORY_SIZE PRL_RESULT_DECLARE_ERROR(26502)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_RESTRICTED_OS_VERSION Macro

PRL_ERR_VMCONF_RESTRICTED_OS_VERSION Macro
PRL_ERR Macros

  • Validation VM configuration error

+++ ALIGNED VALUE TO 26500

Syntax
#define PRL_ERR_VMCONF_RESTRICTED_OS_VERSION PRL_RESULT_DECLARE_ERROR(26500)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD Macro

PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_RESTRICTED_SMART_GUARD PRL_RESULT_DECLARE_ERROR(26504)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS Macro

PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_RESTRICTED_UNDO_DISKS PRL_RESULT_DECLARE_ERROR(26503)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SATA_DEVICES_COUNT_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27702)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX Macro

PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SATA_DEVICES_DUPLICATE_STACK_INDEX PRL_RESULT_DECLARE_ERROR(27703)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED Macro

PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SCSI_BUSLOGIC_WITH_EFI_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(27752)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE Macro
PRL_ERR Macros

ALIGNED VALUE TO 27750

Syntax
#define PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27750)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX Macro

PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX PRL_RESULT_DECLARE_ERROR(27751)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27601)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27602)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY Macro
PRL_ERR Macros

ALIGNED VALUE TO 27600

Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27600)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME Macro

PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_URL_FORMAT_SYS_NAME PRL_RESULT_DECLARE_ERROR(27603)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME PRL_RESULT_DECLARE_ERROR(27151)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH PRL_RESULT_DECLARE_ERROR(27153)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME Macro
PRL_ERR Macros

ALIGNED VALUE TO 27150

Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME PRL_RESULT_DECLARE_ERROR(27150)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH PRL_RESULT_DECLARE_ERROR(27152)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY Macro

PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY Macro
PRL_ERR Macros

+++ ALIGNED VALUE TO 27550 +++ Unused PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY

Syntax
#define PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27550)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY Macro

PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY Macro
PRL_ERR Macros

Unused PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY

Syntax
#define PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27551)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_UNKNOWN_OS_TYPE Macro

PRL_ERR_VMCONF_UNKNOWN_OS_TYPE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_UNKNOWN_OS_TYPE PRL_RESULT_DECLARE_ERROR(27002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_UNKNOWN_OS_VERSION Macro

PRL_ERR_VMCONF_UNKNOWN_OS_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_UNKNOWN_OS_VERSION PRL_RESULT_DECLARE_ERROR(27003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VALIDATION_FAILED Macro

PRL_ERR_VMCONF_VALIDATION_FAILED Macro
PRL_ERR Macros

ALIGNED VALUE TO 27000

Syntax
#define PRL_ERR_VMCONF_VALIDATION_FAILED PRL_RESULT_DECLARE_ERROR(27000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE Macro
PRL_ERR Macros

ALIGNED VALUE TO 27300

Syntax
#define PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27300)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX Macro

PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_ABOVE_MAX PRL_RESULT_DECLARE_ERROR(27302)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED Macro

PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_VIDEO_MEMORY_SIZE_NOT_EQUAL_RECOMMENDED PRL_RESULT_DECLARE_SUCCESS(27301)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VIDEO_NOT_ENABLED Macro

PRL_ERR_VMCONF_VIDEO_NOT_ENABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_VIDEO_NOT_ENABLED PRL_RESULT_DECLARE_ERROR(27018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMCONF_VM_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_VM_NAME_IS_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMCONF_VM_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMDIR_INVALID_PATH Macro

PRL_ERR_VMDIR_INVALID_PATH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMDIR_INVALID_PATH PRL_RESULT_DECLARE_ERROR(285)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE Macro

PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE PRL_RESULT_DECLARE_ERROR(286)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMHELPER_CREATEVM_FAILED Macro

PRL_ERR_VMHELPER_CREATEVM_FAILED Macro
PRL_ERR Macros

STW7 VmHelper errors +++ ALIGNED VALUE TO 41400

Syntax
#define PRL_ERR_VMHELPER_CREATEVM_FAILED PRL_RESULT_DECLARE_ERROR(41400)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMHELPER_DIR_PATH_INVALID Macro

PRL_ERR_VMHELPER_DIR_PATH_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMHELPER_DIR_PATH_INVALID PRL_RESULT_DECLARE_ERROR(41404)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMHELPER_DISK_MOUNT_FAILED Macro

PRL_ERR_VMHELPER_DISK_MOUNT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMHELPER_DISK_MOUNT_FAILED PRL_RESULT_DECLARE_ERROR(41402)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED Macro

PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMHELPER_DISK_UNMOUNT_FAILED PRL_RESULT_DECLARE_ERROR(41403)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED Macro

PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VMHELPER_GETTING_AVAILABLE_DRIVE_FAILED PRL_RESULT_DECLARE_ERROR(41401)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VNC_SERVER_ALREADY_STARTED Macro

PRL_ERR_VNC_SERVER_ALREADY_STARTED Macro
PRL_ERR Macros

VNC server operations errors +++ ALIGNED VALUE TO 35000

Syntax
#define PRL_ERR_VNC_SERVER_ALREADY_STARTED PRL_RESULT_DECLARE_ERROR(35000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED Macro

PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED PRL_RESULT_DECLARE_ERROR(35002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VNC_SERVER_DISABLED Macro

PRL_ERR_VNC_SERVER_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VNC_SERVER_DISABLED PRL_RESULT_DECLARE_ERROR(35001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VNC_SERVER_NOT_STARTED Macro

PRL_ERR_VNC_SERVER_NOT_STARTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VNC_SERVER_NOT_STARTED PRL_RESULT_DECLARE_ERROR(35005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT Macro

PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VOLUME_LICENSE_EXCEEDED_LIMIT PRL_RESULT_DECLARE_ERROR(11062)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_ALREADY_HOOKED_FAILED Macro

PRL_ERR_VTD_ALREADY_HOOKED_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_ALREADY_HOOKED_FAILED PRL_RESULT_DECLARE_ERROR(10003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST Macro

PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_DEVICE_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(460)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_DEVICE_NOT_MAPPED Macro

PRL_ERR_VTD_DEVICE_NOT_MAPPED Macro
PRL_ERR Macros

  • VT-d

+++ ALIGNED VALUE TO 12000

Syntax
#define PRL_ERR_VTD_DEVICE_NOT_MAPPED PRL_RESULT_DECLARE_ERROR(12000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_DEVICE_TROUBLESHOOT Macro

PRL_ERR_VTD_DEVICE_TROUBLESHOOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_DEVICE_TROUBLESHOOT PRL_RESULT_DECLARE_ERROR(10017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT Macro

PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_AFTER_INSTALL_NEED_REBOOT PRL_RESULT_DECLARE_ERROR(10007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT Macro

PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_AFTER_REVERT_NEED_REBOOT PRL_RESULT_DECLARE_ERROR(10008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE Macro

PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_DEVICE_CURRENTLY_IN_USE PRL_RESULT_DECLARE_ERROR(10012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_FAILED Macro

PRL_ERR_VTD_HOOK_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_FAILED PRL_RESULT_DECLARE_ERROR(10004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_INSTALLATION_FAILED Macro

PRL_ERR_VTD_HOOK_INSTALLATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_INSTALLATION_FAILED PRL_RESULT_DECLARE_ERROR(10009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_INVALID_CONFIG Macro

PRL_ERR_VTD_HOOK_INVALID_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_INVALID_CONFIG PRL_RESULT_DECLARE_ERROR(10011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED Macro

PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED PRL_RESULT_DECLARE_ERROR(10005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_REVERT_FAILED Macro

PRL_ERR_VTD_HOOK_REVERT_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_REVERT_FAILED PRL_RESULT_DECLARE_ERROR(10010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE Macro

PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_HOOK_UPDATE_SCRIPT_EXECUTE PRL_RESULT_DECLARE_ERROR(10019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_INITIALIZATION_FAILED Macro

PRL_ERR_VTD_INITIALIZATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_INITIALIZATION_FAILED PRL_RESULT_DECLARE_ERROR(10002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTD_WAIT_ASR Macro

PRL_ERR_VTD_WAIT_ASR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTD_WAIT_ASR PRL_RESULT_DECLARE_ERROR(10006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VTX_ENABLED_ONLY_IN_SMX Macro

PRL_ERR_VTX_ENABLED_ONLY_IN_SMX Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VTX_ENABLED_ONLY_IN_SMX PRL_RESULT_DECLARE_ERROR(342)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZ_API_NOT_INITIALIZED Macro

PRL_ERR_VZ_API_NOT_INITIALIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZ_API_NOT_INITIALIZED PRL_RESULT_DECLARE_ERROR(27026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZ_OPERATION_FAILED Macro

PRL_ERR_VZ_OPERATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZ_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(44006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND Macro

PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZ_OSTEMPLATE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(44007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZCTL_OPERATION_FAILED Macro

PRL_ERR_VZCTL_OPERATION_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZCTL_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(44010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_ACTIVATION_KEY Macro

PRL_ERR_VZLICENSE_ACTIVATION_KEY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_ACTIVATION_KEY PRL_RESULT_DECLARE_ERROR(11037)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_CANCEL Macro

PRL_ERR_VZLICENSE_CANCEL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_CANCEL PRL_RESULT_DECLARE_ERROR(11019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_EACCES Macro

PRL_ERR_VZLICENSE_EACCES Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_EACCES PRL_RESULT_DECLARE_ERROR(11028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_ERR_KA Macro

PRL_ERR_VZLICENSE_ERR_KA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_ERR_KA PRL_RESULT_DECLARE_ERROR(11026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_EXIST Macro

PRL_ERR_VZLICENSE_EXIST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_EXIST PRL_RESULT_DECLARE_ERROR(11031)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_FATAL Macro

PRL_ERR_VZLICENSE_FATAL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_FATAL PRL_RESULT_DECLARE_ERROR(11035)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_INVAL Macro

PRL_ERR_VZLICENSE_INVAL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_INVAL PRL_RESULT_DECLARE_ERROR(11033)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_INVALID_HWID Macro

PRL_ERR_VZLICENSE_INVALID_HWID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_INVALID_HWID PRL_RESULT_DECLARE_ERROR(11036)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_IO Macro

PRL_ERR_VZLICENSE_IO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_IO PRL_RESULT_DECLARE_ERROR(11032)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED Macro

PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_ACTIVATION_LIMIT_REACHED PRL_RESULT_DECLARE_ERROR(11066)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH Macro

PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_HWID_DOES_NOT_MATCH PRL_RESULT_DECLARE_ERROR(11067)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED Macro

PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED PRL_RESULT_DECLARE_ERROR(11065)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET Macro

PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_LICENSE_IS_NOT_PROLONGATED_YET PRL_RESULT_DECLARE_ERROR(11064)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED Macro

PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_LICENSE_IS_TERMINATED PRL_RESULT_DECLARE_ERROR(11068)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE Macro

PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_KA_LICENSE_IS_UP_TO_DATE PRL_RESULT_DECLARE_ERROR(11063)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_LOCK Macro

PRL_ERR_VZLICENSE_LOCK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_LOCK PRL_RESULT_DECLARE_ERROR(11027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NETWORK Macro

PRL_ERR_VZLICENSE_NETWORK Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NETWORK PRL_RESULT_DECLARE_ERROR(11022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NODATA Macro

PRL_ERR_VZLICENSE_NODATA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NODATA PRL_RESULT_DECLARE_ERROR(11025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NOENT Macro

PRL_ERR_VZLICENSE_NOENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NOENT PRL_RESULT_DECLARE_ERROR(11029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NOINIT Macro

PRL_ERR_VZLICENSE_NOINIT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NOINIT PRL_RESULT_DECLARE_ERROR(11030)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NOMEM Macro

PRL_ERR_VZLICENSE_NOMEM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NOMEM PRL_RESULT_DECLARE_ERROR(11034)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_NOTSUP Macro

PRL_ERR_VZLICENSE_NOTSUP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_NOTSUP PRL_RESULT_DECLARE_ERROR(11023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_PROXY Macro

PRL_ERR_VZLICENSE_PROXY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_PROXY PRL_RESULT_DECLARE_ERROR(11021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_PROXY_AUTH Macro

PRL_ERR_VZLICENSE_PROXY_AUTH Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_PROXY_AUTH PRL_RESULT_DECLARE_ERROR(11020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_TASK_ALREADY_RUN Macro

PRL_ERR_VZLICENSE_TASK_ALREADY_RUN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_TASK_ALREADY_RUN PRL_RESULT_DECLARE_ERROR(11040)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_TIMEOUT Macro

PRL_ERR_VZLICENSE_TIMEOUT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_TIMEOUT PRL_RESULT_DECLARE_ERROR(11018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE Macro

PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE PRL_RESULT_DECLARE_ERROR(11039)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_UNSUPPORTED_MODE Macro

PRL_ERR_VZLICENSE_UNSUPPORTED_MODE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_UNSUPPORTED_MODE PRL_ERR_VZLICENSE_UNSUPPORTED_APP_MODE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP Macro

PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_UNSUPPORTED_UPDATE_OP PRL_RESULT_DECLARE_ERROR(11072)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED Macro

PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_VMS_LIMIT_EXCEEDED PRL_RESULT_DECLARE_ERROR(11038)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_VZLICENSE_WRONG Macro

PRL_ERR_VZLICENSE_WRONG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_VZLICENSE_WRONG PRL_RESULT_DECLARE_ERROR(11024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_ACCEPTED Macro

PRL_ERR_WEB_PORTAL_ACCEPTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_ACCEPTED PRL_RESULT_DECLARE_SUCCESS(47001)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS Macro

PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_ACCOUNT_ALREADY_EXISTS PRL_ERR_WEB_PORTAL_CONFLICT
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_BAD_REQUEST Macro

PRL_ERR_WEB_PORTAL_BAD_REQUEST Macro
PRL_ERR Macros

errors

Syntax
#define PRL_ERR_WEB_PORTAL_BAD_REQUEST PRL_RESULT_DECLARE_ERROR(47002)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_CONFLICT Macro

PRL_ERR_WEB_PORTAL_CONFLICT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_CONFLICT PRL_RESULT_DECLARE_ERROR(47006)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_CREATED Macro

PRL_ERR_WEB_PORTAL_CREATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_CREATED PRL_RESULT_DECLARE_SUCCESS(47000)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_FORBIDDEN Macro

PRL_ERR_WEB_PORTAL_FORBIDDEN Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_FORBIDDEN PRL_RESULT_DECLARE_ERROR(47010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_INVALID_EMAIL Macro

PRL_ERR_WEB_PORTAL_INVALID_EMAIL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_INVALID_EMAIL PRL_RESULT_DECLARE_ERROR(47008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS Macro

PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_INVALID_PARAMETERS PRL_RESULT_DECLARE_ERROR(47005)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_INVALID_PASSWORD Macro

PRL_ERR_WEB_PORTAL_INVALID_PASSWORD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_INVALID_PASSWORD PRL_ERR_WEB_PORTAL_BAD_REQUEST
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR Macro

PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_COMMON_ERROR PRL_RESULT_DECLARE_ERROR(47026)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED Macro

PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_HOST_IS_BLOCKED PRL_RESULT_DECLARE_ERROR(47021)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED Macro

PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_HOST_IS_DEACTIVATED PRL_RESULT_DECLARE_ERROR(47022)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID Macro

PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_KA_MASTER_KEY_INVALID PRL_RESULT_DECLARE_ERROR(47028)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID Macro

PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_KA_TEMP_KEY_INVALID PRL_RESULT_DECLARE_ERROR(47029)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE Macro

PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_KEY_IS_UP_TO_DATE PRL_RESULT_DECLARE_ERROR(47024)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED Macro

PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_BLACKLISTED PRL_RESULT_DECLARE_ERROR(47019)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED Macro

PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_EXPIRED PRL_RESULT_DECLARE_ERROR(47018)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID Macro

PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_INVALID PRL_RESULT_DECLARE_ERROR(47017)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED Macro

PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_MASTER_KEY_LIMIT_REACHED PRL_RESULT_DECLARE_ERROR(47020)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID Macro

PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_LIC_TEMP_KEY_INVALID PRL_RESULT_DECLARE_ERROR(47023)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_NO_CONTENT Macro

PRL_ERR_WEB_PORTAL_NO_CONTENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_NO_CONTENT PRL_RESULT_DECLARE_SUCCESS(47009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_NOT_FOUND Macro

PRL_ERR_WEB_PORTAL_NOT_FOUND Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_NOT_FOUND PRL_RESULT_DECLARE_ERROR(47003)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_OK Macro

PRL_ERR_WEB_PORTAL_OK Macro
PRL_ERR Macros

success

Syntax
#define PRL_ERR_WEB_PORTAL_OK PRL_ERR_SUCCESS
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE Macro

PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SERVICE_UNAVAILABLE PRL_RESULT_DECLARE_ERROR(47007)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED Macro

PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_APP_DENIED PRL_RESULT_DECLARE_ERROR(47013)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT Macro

PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_CONFIRM_EMAIL_SENT PRL_RESULT_DECLARE_ERROR(47011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL Macro

PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_NO_EMAIL PRL_RESULT_DECLARE_ERROR(47027)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA Macro

PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_PROHIBITED_FOR_BA PRL_RESULT_DECLARE_ERROR(47016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE Macro

PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_BAD_RESPONSE PRL_RESULT_DECLARE_ERROR(47014)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE Macro

PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_SERVICE_UNAVAILABLE PRL_RESULT_DECLARE_ERROR(47015)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT Macro

PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_SOCIAL_UNCONFIRMED_ACCOUNT PRL_RESULT_DECLARE_ERROR(47012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_UNAUTHORIZED Macro

PRL_ERR_WEB_PORTAL_UNAUTHORIZED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_UNAUTHORIZED PRL_RESULT_DECLARE_ERROR(47004)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WEB_PORTAL_UNEXPECTED Macro

PRL_ERR_WEB_PORTAL_UNEXPECTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WEB_PORTAL_UNEXPECTED PRL_RESULT_DECLARE_ERROR(47025)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WIN_AERO_DISABLED Macro

PRL_ERR_WIN_AERO_DISABLED Macro
PRL_ERR Macros

isn't used now

Syntax
#define PRL_ERR_WIN_AERO_DISABLED PRL_RESULT_DECLARE_ERROR(10016)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY Macro

PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY PRL_RESULT_DECLARE_ERROR(318)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRITE_FAILED Macro

PRL_ERR_WRITE_FAILED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(519)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_CIPHER_ID_FORMAT Macro

PRL_ERR_WRONG_CIPHER_ID_FORMAT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_CIPHER_ID_FORMAT PRL_RESULT_DECLARE_ERROR(44205)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG Macro

PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_CIPHER_ID_FORMAT_IN_CONFIG PRL_RESULT_DECLARE_ERROR(44226)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL Macro

PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL PRL_RESULT_DECLARE_ERROR(277)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT Macro

PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_ENCRYPTED_CONFIG_FORMAT PRL_RESULT_DECLARE_ERROR(44214)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT Macro

PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_HDD_TYPE_FOR_ENCRYPT PRL_RESULT_DECLARE_ERROR(44222)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD Macro

PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_HDD PRL_RESULT_DECLARE_ERROR(44216)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM Macro

PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM Macro
PRL_ERR Macros

Encryption Vm errors +++ ALIGNED VALUE TO 44200

Syntax
#define PRL_ERR_WRONG_PASSWORD_TO_ENCRYPTED_VM PRL_RESULT_DECLARE_ERROR(44200)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM Macro

PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_PASSWORD_TO_PROTECTED_VM PRL_RESULT_DECLARE_ERROR(44248)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_PROTOCOL_VERSION Macro

PRL_ERR_WRONG_PROTOCOL_VERSION Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_PROTOCOL_VERSION PRL_RESULT_DECLARE_ERROR(413)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_TRANSACTION_STATE Macro

PRL_ERR_WRONG_TRANSACTION_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_TRANSACTION_STATE PRL_RESULT_DECLARE_ERROR(44206)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_VM_STATE Macro

PRL_ERR_WRONG_VM_STATE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_VM_STATE PRL_ERR_COMPACT_WRONG_VM_STATE
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP Macro

PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_VM_STATE_OF_PROTECTION_OP PRL_RESULT_DECLARE_ERROR(44249)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP Macro

PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WRONG_VM_STATE_TO_ENCRYPTED_OP PRL_RESULT_DECLARE_ERROR(44204)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_WS_DISP_CONNECTION_CLOSED Macro

PRL_ERR_WS_DISP_CONNECTION_CLOSED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_WS_DISP_CONNECTION_CLOSED PRL_RESULT_DECLARE_ERROR(246)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_X64GUEST_ON_X32HOST Macro

PRL_ERR_X64GUEST_ON_X32HOST Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_X64GUEST_ON_X32HOST PRL_RESULT_DECLARE_ERROR(354)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED Macro

PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED PRL_RESULT_DECLARE_ERROR(357)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XML_WRITE_FILE Macro

PRL_ERR_XML_WRITE_FILE Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XML_WRITE_FILE PRL_RESULT_DECLARE_ERROR(424)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XMLRPC_INTERNAL_ERROR Macro

PRL_ERR_XMLRPC_INTERNAL_ERROR Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XMLRPC_INTERNAL_ERROR PRL_RESULT_DECLARE_ERROR(38012)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XMLRPC_INVALID_CREDENTIALS Macro

PRL_ERR_XMLRPC_INVALID_CREDENTIALS Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XMLRPC_INVALID_CREDENTIALS PRL_RESULT_DECLARE_ERROR(38009)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XMLRPC_INVALID_REQUEST_INFO Macro

PRL_ERR_XMLRPC_INVALID_REQUEST_INFO Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XMLRPC_INVALID_REQUEST_INFO PRL_RESULT_DECLARE_ERROR(38011)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XMLRPC_LIMITS_EXHAUSTED Macro

PRL_ERR_XMLRPC_LIMITS_EXHAUSTED Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XMLRPC_LIMITS_EXHAUSTED PRL_RESULT_DECLARE_ERROR(38010)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_ERR_XMLRPC_WRONG_METHOD_CALL Macro

PRL_ERR_XMLRPC_WRONG_METHOD_CALL Macro
PRL_ERR Macros
Syntax
#define PRL_ERR_XMLRPC_WRONG_METHOD_CALL PRL_RESULT_DECLARE_ERROR(38008)
File

PrlErrorsValues.h

Links
PRL_ERR Macros


PRL_EVENT_ISSUER_TYPE Enumeration

PRL_EVENT_ISSUER_TYPE Enumeration
Other Structs

Event issuer type

Syntax
typedef enum _PRL_EVENT_ISSUER_TYPE {
  PIE_VIRTUAL_MACHINE = 0,
  PIE_DISPATCHER = 1,
  PIE_IO_SERVICE = 2,
  PIE_WEB_SERVICE = 3,
  PIE_UNKNOWN = 0xFF
} PRL_EVENT_ISSUER_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_EVENT_ISSUER_TYPE_PTR Type

PRL_EVENT_ISSUER_TYPE_PTR Type
Other Types
Syntax
typedef PRL_EVENT_ISSUER_TYPE* PRL_EVENT_ISSUER_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_EVENT_TYPE Enumeration

PRL_EVENT_TYPE Enumeration
Other Structs

Different event types are identified by these event codes.

Syntax
typedef enum _PRL_EVENT_TYPE {
  PET_VM_INF_UNINITIALIZED_EVENT_CODE = 100000,
  PET_DSP_EVT_VM_STATE_CHANGED = 100001,
  PET_DSP_EVT_VM_CONFIG_CHANGED = 100002,
  PET_DSP_EVT_VM_DEV_STATE_CHANGED = 100003,
  PET_DSP_EVT_VM_CREATED = 100004,
  PET_DSP_EVT_VM_ADDED = 100005,
  PET_DSP_EVT_VM_DELETED = 100006,
  PET_DSP_EVT_VM_STARTED = 100007,
  PET_DSP_EVT_VM_STOPPED = 100008,
  PET_DSP_EVT_VM_ABORTED = 100009,
  PET_DSP_EVT_VM_RESETED = 100010,
  PET_DSP_EVT_VM_SUSPENDING = 100011,
  PET_DSP_EVT_VM_SUSPENDED = 100012,
  PET_DSP_EVT_VM_RESUMING = 100013,
  PET_DSP_EVT_VM_RESUMED = 100014,
  PET_DSP_EVT_VM_START_IO_FLOW = 100015,
  PET_DSP_EVT_VM_SNAPSHOTED = 100016,
  PET_DSP_EVT_VM_STATESAVED = PET_DSP_EVT_VM_SNAPSHOTED,
  PET_DSP_EVT_VM_RESTORED = 100017,
  PET_DSP_EVT_VM_STATERESTORED = PET_DSP_EVT_VM_RESTORED,
  PET_DSP_EVT_VM_NET_RECONNECTED = 100018,
  PET_DSP_EVT_VM_PAUSED = 100019,
  PET_DSP_EVT_VM_CONTINUED = 100020,
  PET_DSP_EVT_VM_CONFIG_APPLIED = 100021,
  PET_DSP_EVT_VM_STATISTICS_UPDATED = 100022,
  PET_DSP_EVT_VM_PROBLEM_REPORT_CREATED = 100023,
  PET_DSP_EVT_VM_ABOUT_TO_RESET = 100024,
  PET_DSP_EVT_VM_SECURITY_CHANGED = 100025,
  PET_DSP_EVT_VM_UNREGISTERED = 100026,
  PET_DSP_EVT_VM_REMOTE_DEV_READY_TO_START = 100027,
  PET_VM_EVT_VM_CONFIG_CHANGED = 100028,
  PET_VM_EVT_REQUEST_FILE_OPEN = 100029,
  PET_DSP_EVT_VM_MIGRATE_STARTED = 100030,
  PET_DSP_EVT_VM_MIGRATE_CANCELLED = 100031,
  PET_DSP_EVT_VM_MIGRATE_FINISHED = 100032,
  PET_DSP_EVT_VM_MIGRATE_PROGRESS_CHANGED = 100033,
  PET_DSP_EVT_VM_SNAPSHOTING = 100034,
  PET_DSP_EVT_VM_RESTORING = 100035,
  PET_DSP_EVT_VM_SNAPSHOTS_TREE_CHANGED = 100036,
  PET_DSP_EVT_VM_DELETING_STATE = 100037,
  PET_DSP_EVT_VM_STATE_DELETED = 100038,
  PET_DSP_EVT_VM_ABOUT_TO_START_DEINIT = 100039,
  PET_DSP_EVT_VM_ABOUT_TO_START_INIT = 100040,
  PET_DSP_EVT_VM_MEMORY_SWAPPING_STARTED = 100041,
  PET_DSP_EVT_VM_MEMORY_SWAPPING_FINISHED = 100042,
  PET_VM_EVT_UNMOUNT = 100043,
  PET_VM_EVT_MOUNT = 100044,
  PET_DSP_EVT_REBOOT_HOST = 100045,
  PET_DSP_EVT_REBOOT_HOST_MANUAL_TO_INIT_VTD_DEVICES = 100046,
  PET_DSP_EVT_BACKUP_STARTED = 100047,
  PET_DSP_EVT_BACKUP_CANCELLED = 100048,
  PET_DSP_EVT_CREATE_BACKUP_FINISHED = 100049,
  PET_DSP_EVT_BACKUP_PROGRESS_CHANGED = 100050,
  PET_DSP_EVT_JOB_PROGRESS_CHANGED = 100051,
  PET_DSP_EVT_RESTORE_PROGRESS_CHANGED = 100052,
  PET_DSP_EVT_DISK_RESIZE_STARTED = 100053,
  PET_DSP_EVT_DISK_RESIZE_FINISHED = 100054,
  PET_DSP_EVT_DISK_RESIZE_PROGRESS_CHANGED = 100055,
  PET_DSP_EVT_VM_ADDITION_STATE_CHANGED = 100056,
  PET_DSP_EVT_RESTORE_BACKUP_FINISHED = 100057,
  PET_DSP_EVT_REMOVE_BACKUP_FINISHED = 100058,
  PET_DSP_EVT_VM_MIGRATE_CANCELLED_DISP = 100059,
  PET_DSP_EVT_VM_MIGRATE_FINISHED_DISP = 100060,
  PET_DSP_EVT_TIME_MACHINE_BACKUP_IS_OVER = 100061,
  PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_CHANGED = 100062,
  PET_DSP_EVT_CONVERSION_DISKS_PROGRESS_FINISHED = 100063,
  PET_DSP_EVT_CONVERT_THIRD_PARTY_PROGRESS_CHANGED = 100064,
  PET_DSP_EVT_CONNECTED_TO_PROXY = 100065,
  PET_DSP_EVT_DISCONNECTED_FROM_PROXY = 100066,
  PET_DSP_EVT_CONNECTING_TO_PROXY = 100067,
  PET_DSP_EVT_RECONFIG_VM_PROGRESS_CHANGED = 100068,
  PET_DSP_EVT_VM_MIGRATE_WAIT_REMOUNT = 100069,
  PET_DSP_EVT_VM_CONFIG_APPLY_FINISHED = 100070,
  PET_DSP_EVT_VM_IO_CLIENT_STATISTICTS = 100071,
  PET_DSP_EVT_VM_SET_HOST_TIME = 100072,
  PET_DSP_EVT_VM_LOW_HOST_MEMORY = 100073,
  PET_DSP_EVT_VM_MAC_OS_VER = 100074,
  PET_DSP_EVT_VM_PAUSED_BY_HOST_SLEEP = 100075,
  PET_DSP_EVT_VM_CONTINUED_BY_HOST_WAKEUP = 100076,
  PET_DSP_EVT_VM_FROZEN = 100077,
  PET_DSP_EVT_VM_UNFROZEN = 100078,
  PET_DSP_EVT_CONNECTION_CLIENT_INFO_WAS_SET = 100079,
  PET_DSP_EVT_CONNECTION_WAS_CLOSED = 100080,
  PET_DSP_EVT_HOST_CLEANUP = 100081,
  PET_DSP_EVT_HTTP_PROXY_AUTH_REQUIRED = 100082,
  PET_DSP_EVT_OP_ACCEPTED = 100100,
  PET_DSP_EVT_OP_REJECTED = 100101,
  PET_DSP_EVT_OP_RESULT = 100102,
  PET_DSP_EVT_DIR_STATE_CHANGED = 100200,
  PET_DSP_EVT_HOST_STATISTICS_UPDATED = 100201,
  PET_DSP_EVT_HW_CONFIG_CHANGED = 100202,
  PET_DSP_EVT_CLIENT_CONNECTED = 100300,
  PET_DSP_EVT_CLIENT_DISCONNECTED = 100301,
  PET_DSP_EVT_CLIENT_REJECTED = 100302,
  PET_DSP_EVT_FOUND_LOST_VM_CONFIG = 100400,
  PET_DSP_EVT_HAS_EVENT = 100401,
  PET_DSP_EVT_RECONNECT = 100402,
  PET_DSP_EVT_DISP_CONNECTION_CLOSED = 100403,
  PET_DSP_EVT_DISP_SHUTDOWN = 100404,
  PET_DSP_EVT_USER_PROFILE_CHANGED = 100500,
  PET_DSP_EVT_COMMON_PREFS_CHANGED = 100501,
  PET_DSP_EVT_VM_MESSAGE = 100502,
  PET_DSP_EVT_VM_QUESTION = 100503,
  PET_JOB_DELETE_VM_PROGRESS_CHANGED = 100504,
  PET_VM_INF_START_FILE_COPYING = 100505,
  PET_VM_INF_END_FILE_COPYING = 100506,
  PET_DSP_EVT_ERROR_MESSAGE = 100507,
  PET_DSP_EVT_WARNING_MESSAGE = 100508,
  PET_JOB_HDD_CREATE_PROGRESS_CHANGED = 100509,
  PET_JOB_FILE_COPY_PROGRESS_CHANGED = 100510,
  PET_JOB_SUSPEND_PROGRESS_CHANGED = 100511,
  PET_JOB_RESUME_PROGRESS_CHANGED = 100512,
  PET_DSP_EVT_ANSWER_TO_VM_WAS_DONE = 100513,
  PET_DSP_EVT_LICENSE_CHANGED = 100514,
  PET_JOB_CREATE_SNAPSHOT_PROGRESS_CHANGED = 100515,
  PET_JOB_SWITCH_TO_SNAPSHOT_PROGRESS_CHANGED = 100516,
  PET_JOB_DELETE_SNAPSHOT_PROGRESS_CHANGED = 100517,
  PET_JOB_COMMIT_UNFINISHED_DISK_OP_PROGRESS_CHANGED = 100518,
  PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_STARTED = 100519,
  PET_DSP_EVT_COMMIT_UNFINISHED_DISK_OP_FINISHED = 100520,
  PET_DSP_EVT_VM_ENCRYPT_PROGRESS_CHANGED = 100521,
  PET_DSP_EVT_VM_DECRYPT_PROGRESS_CHANGED = 100522,
  PET_JOB_STAGE_PROGRESS_CHANGED = 100523,
  PET_VM_INF_START_BUNCH_COPYING = 100524,
  PET_VM_INF_END_BUNCH_COPYING = 100525,
  PET_DSP_EVT_LICENSE_WAS_DEACTIVATED = 100526,
  PET_DSP_EVT_SMC_USER_FORCE_DISCONNECTED = 100600,
  PET_DSP_EVT_SMC_CANCEL_USER_COMMAND = 100601,
  PET_DSP_EVT_SMC_DISPATCHER_SHUTDOWN = 100602,
  PET_IO_SCREEN_SIZE = 100700,
  PET_IO_SLIDING_MOUSE_FLAG = 100702,
  PET_IO_DEVICE_IS_IN_USE = 100703,
  PET_IO_KEYBOARD_LEDS = 100704,
  PET_IO_STATE = 100705,
  PET_IO_SCREEN_CAPTURED = 100706,
  PET_IO_BEFORE_SCREEN_SIZE = 100707,
  PET_IO_REMOTE_COMMAND = 100708,
  PET_IO_MOUSE_CURSOR_CHANGED = 100709,
  PET_IO_MOUSE_CURSOR_HID = 100710,
  PET_IO_MOUSE_CURSOR_SET = 100711,
  PET_IO_DYNRES_TOOL_STATUS = 100712,
  PET_IO_TOOLS_UTILITY_COMMAND = 100713,
  PET_IO_TOOLS_VM_SHUTDOWN = 100714,
  PET_IO_TOOLS_CLIPBOARD_DATA = 100715,
  PET_IO_SCREEN_SURFACE_DETACHED = 100716,
  PET_IO_TOOLS_SIA_DATA = 100717,
  PET_IO_TOOLS_VMCTG_COMMAND = 100718,
  PET_IO_TOOLS_DRAGDROP_DATA = 100719,
  PET_IO_TOOLS_GENERAL_COMMAND = 100720,
  PET_IO_TOOLS_DESKTOP_UTILITY_STATE = 100721,
  PET_IO_DISPLAY_SCREEN_SIZE = 100722,
  PET_IO_DISPLAY_BEFORE_SCREEN_SIZE = 100723,
  PET_IO_DISPLAY_SCREEN_CAPTURED = 100724,
  PET_IO_SWITCH_VESA_MODE = 100725,
  PET_IO_TOOLS_LANGUAGE_HOTKEY_CHANGED = 100726,
  PET_IO_AVAILABLE_DISPLAYS = 100727,
  PET_IO_SCREEN_SURFACE_ATTACHED = 100728,
  PET_IO_UIEMU_ELEMENT_AT_POS = 100729,
  PET_IO_AUDIO_OUTPUT_DATA = 100730,
  PET_IO_AUDIO_OUTPUT_ENCODING_SET = 100731,
  PET_IO_AUDIO_OUTPUT_STREAM_STARTED = 100732,
  PET_IO_AUDIO_OUTPUT_STOP = 100734,
  PET_IO_CVSRC_OPEN = 100735,
  PET_IO_CVSRC_CLOSE = 100736,
  PET_IO_SSO_GET_CREDENTIALS = 100737,
  PET_IO_MOUSE_CURSOR_MOVED = 100738,
  PET_IO_UIEMU_CARET_INFO = 100739,
  PET_IO_DISPLAY_GAMMA_CHANGED = 100740,
  PET_DSP_EVT_VM_TOOLS_STATE_CHANGED = 100800,
  PET_DSP_EVT_VM_COMPACT_PROCESSING = 100801,
  PET_DSP_EVT_VM_COMPACT_FINISHED = 100802,
  PET_DSP_EVT_VM_COMPRESSOR_FINISHED = 100803,
  PET_DSP_EVT_VM_COMPRESSOR_CONTINUED = 100804,
  PET_DSP_EVT_VM_SOFTWARE_INSTALLED = 100805,
  PET_DSP_EVT_VM_PIS_NOTIFICATION_ASK_TO_INSTALL = 100806,
  PET_DSP_EVT_VM_VIRTUAL_DEVICES_STATE_CHANGED = 100807,
  PET_DSP_EVT_PERFSTATS = 100900,
  PET_DSP_EVT_VM_PERFSTATS = 100901,
  PET_DSP_EVT_VM_UPGRADE_INIT = 101000,
  PET_DSP_EVT_VM_UPGRADE_INIT_TIMEOUT = 101001,
  PET_DSP_EVT_VM_UPGRADE_STAGE_1 = 101002,
  PET_DSP_EVT_VM_UPGRADE_STAGE_2 = 101003,
  PET_DSP_EVT_VM_UPGRADE_STAGE_3 = 101004,
  PET_DSP_EVT_VM_UPGRADE_COMPLETED = 101005,
  PET_DSP_EVT_VM_UPGRADE_UNKNOWN_ERROR = 101006,
  PET_DSP_EVT_VM_UPGRADE_INIT_VMW = 101007,
  PET_DSP_EVT_VM_UPGRADE_INIT_PHY = 101008,
  PET_IO_READY_TO_ACCEPT_STDIN_PKGS = 101100,
  PET_VM_READY_TO_BOOT = 101200,
  PET_VM_READY_TO_PRINT = 101201,
  PET_VM_DEFAULT_SOUND_RECONNECTED = 101202,
  PET_VM_EVT_UNMOUNT_USB_MEDIA = 101203,
  PET_VM_EVT_UNMOUNT_DVD_MEDIA = 101204,
  PET_DSP_EVT_APPLIANCE_DOWNLOAD_PROGRESS_CHANGED = 101300,
  PET_DSP_EVT_APPLIANCE_DOWNLOAD_FINISHED = 101301,
  PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_STARTED = 101302,
  PET_DSP_EVT_APPLIANCE_ARCHIVE_UNPACK_FINISHED = 101303,
  PET_DSP_EVT_APPLIANCE_REGISTER_VM_STARTED = 101304,
  PET_DSP_EVT_APPLIANCE_REGISTER_VM_FINISHED = 101305,
  PET_DSP_EVT_CEP_WRITE_STRING = 101400,
  PET_DSP_COHERENCE_FAKE_STUB_NOTIFICATION = 101401,
  PET_DSP_EVT_VM_WAS_ENCRYPTED = 101500,
  PET_DSP_EVT_VM_WAS_DECRYPTED = 101501,
  PET_DSP_EVT_ENCRYPTED_VM_PASSWORD_CHANGED = 101502,
  PET_DSP_EVT_ENCRYPTED_VM_NEED_AUTH_AGAIN = 101503,
  PET_DSP_EVT_VM_WAS_PROTECTED = 101504,
  PET_DSP_EVT_VM_WAS_UNPROTECTED = 101505,
  PET_VM_EVT_TIS_BACKUP_WRITE = 101600,
  PET_IO_EVT_DISCONNECT_WITH_REASON = 101700,
  PET_VIDEO_RECEIVER_FORMAT = 101800,
  PET_VIDEO_RECEIVER_FRAME = 101801,
  PET_VIDEO_RECEIVER_CLOSED = 101802,
  PET_VIDEO_CAPTURE_GEOMETRY = 101803,
  PET_VIDEO_RECEIVER_CONNECTION_STATE = 101804,
  PET_PTM_EVT_PROPERTY_CHANGED = 101900,
  PET_PTM_EVT_OBJECT_DELETED = 101901,
  PET_PTM_EVT_OBJECT_CREATED = 101902,
  PET_PTM_EVT_SUBSCRIBED = 101903,
  PET_PTM_EVT_RPC_COMPLETED = 101904
} PRL_EVENT_TYPE;
File

PrlEventsValues.h

Members

PET_VM_INF_UNINITIALIZED_EVENT_CODE
BASE VALUE SET TO 100000
PET_DSP_EVT_OP_ACCEPTED
ALIGNED VALUE TO 100100
PET_DSP_EVT_DIR_STATE_CHANGED
ALIGNED VALUE TO 100200
PET_DSP_EVT_CLIENT_CONNECTED
ALIGNED VALUE TO 100300
PET_DSP_EVT_FOUND_LOST_VM_CONFIG
ALIGNED VALUE TO 100400
PET_DSP_EVT_USER_PROFILE_CHANGED
ALIGNED VALUE TO 100500
PET_DSP_EVT_SMC_USER_FORCE_DISCONNECTED
ALIGNED VALUE TO 100600
PET_IO_SCREEN_SIZE
ALIGNED VALUE TO 100700
PET_DSP_EVT_VM_TOOLS_STATE_CHANGED
ALIGNED VALUE TO 100800
PET_DSP_EVT_PERFSTATS
ALIGNED VALUE TO 100900
PET_DSP_EVT_VM_UPGRADE_INIT
ALIGNED VALUE TO 101000
PET_IO_READY_TO_ACCEPT_STDIN_PKGS
ALIGNED VALUE TO 101100
PET_VM_READY_TO_BOOT
ALIGNED VALUE TO 101200
PET_DSP_EVT_APPLIANCE_DOWNLOAD_PROGRESS_CHANGED
ALIGNED VALUE TO 101300
PET_DSP_EVT_CEP_WRITE_STRING
ALIGNED VALUE TO 101400
PET_DSP_EVT_VM_WAS_ENCRYPTED
ALIGNED VALUE TO 101500
PET_VM_EVT_TIS_BACKUP_WRITE
ALIGNED VALUE TO 101600
PET_IO_EVT_DISCONNECT_WITH_REASON
ALIGNED VALUE TO 101700
PET_VIDEO_RECEIVER_FORMAT
ALIGNED VALUE TO 101800
PET_PTM_EVT_PROPERTY_CHANGED
ALIGNED VALUE TO 101900

Remarks

Client can query event handle with the PrlEvent_GetType call to get this code. @see PrlEvent_GetType

Links
Other Structs


PRL_EVENT_TYPE_PTR Type

PRL_EVENT_TYPE_PTR Type
Other Types
Syntax
typedef PRL_EVENT_TYPE* PRL_EVENT_TYPE_PTR;
File

PrlEventsValues.h

Links
Other Types


PRL_EXTERNAL_VM_TYPE Enumeration

PRL_EXTERNAL_VM_TYPE Enumeration
Other Structs

External VM type for supporting native VM

Syntax
typedef enum _PRL_EXTERNAL_VM_TYPE {
  PEVT_VM_UNKNOWN = 0,
  PEVT_NATIVE_VM = PEVT_VM_UNKNOWN,
  PEVT_VMWARE = 1
} PRL_EXTERNAL_VM_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_EXTERNAL_VM_TYPE_PTR Type

PRL_EXTERNAL_VM_TYPE_PTR Type
Other Types
Syntax
typedef PRL_EXTERNAL_VM_TYPE* PRL_EXTERNAL_VM_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_FAILED Macro

PRL_FAILED Macro
Other Macros
Syntax
#define PRL_FAILED( err ) ( ( PRL_RESULT )( err ) < 0 )
File

PrlErrors.h

Links
Other Macros


PRL_FALSE Macro

PRL_FALSE Macro
Other Macros
Syntax
#define PRL_FALSE (0)
File

PrlTypes.h

Links
Other Macros


PRL_FEATURES_MATRIX Enumeration

PRL_FEATURES_MATRIX Enumeration
Other Structs

Features matrix list

Syntax
typedef enum _PRL_FEATURES_MATRIX {
  PFSM_UNKNOWN_FEATURE = 0,
  PFSM_SATA_HOTPLUG_SUPPORT = 1,
  PFSM_DEFAULT_SATA_ALLOWED = PFSM_SATA_HOTPLUG_SUPPORT,
  PFSM_VM_CONFIG_MERGE_SUPPORT = 2,
  PFSM_PSBM5 = 3,
  PFSM_AUTOSTART_VM_AS_OWNER = 4,
  PFSM_DEFAULT_PLAINDISK_ALLOWED = 5,
  PFSM_NO_SHARED_NETWORKING = 6,
  PFSM_DISK_IO_LIMITS = 7,
  PFSM_FINE_CPU_LIMITS = 8,
  PFSM_ROUTED_NETWORKING = 9,
  PFSM_RAM_HOTPLUG_SUPPORT = 10,
  PFSM_CPU_HOTPLUG_SUPPORT = 11,
  PFSM_IPV6_SUPPORT = 12,
  PFSM_USB_PRINTER_SUPPORT = 13,
  PFSM_NIC_CHANGE_ALLOWED = 14,
  PFSM_DESKTOP_CONTROL_SUPPORT = 15,
  PFSM_PAX_FEATURE_RANGE_START = 1000,
  PFSM_PAX_FEATURE_MATRIX_SUPPORT = PFSM_PAX_FEATURE_RANGE_START,
  PFSM_PAX_FEATURE_RANGE_END
} PRL_FEATURES_MATRIX;
File

PrlEnums.h

Links
Other Structs


PRL_FEATURES_MATRIX_PTR Type

PRL_FEATURES_MATRIX_PTR Type
Other Types
Syntax
typedef PRL_FEATURES_MATRIX* PRL_FEATURES_MATRIX_PTR;
File

PrlEnums.h

Links
Other Types


PRL_FILE_DESC Type

PRL_FILE_DESC Type
PRL_FILE Types

File descriptor type

Syntax
typedef PRL_VOID_PTR PRL_FILE_DESC;
File

PrlTypes.h

Links
PRL_FILE Types


PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration

PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration
Other Structs

File system element type

Syntax
typedef enum _PRL_FILE_SYSTEM_ELEMENT_TYPE {
  PSE_DRIVE = 0,
  PSE_DIRECTORY = 1,
  PSE_FILE = 2
} PRL_FILE_SYSTEM_ELEMENT_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR Type

PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR Type
PRL_FILE Types
Syntax
typedef PRL_FILE_SYSTEM_ELEMENT_TYPE* PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR;
File

PrlEnums.h

Links
PRL_FILE Types


PRL_FILE_SYSTEM_FS_TYPE Enumeration

PRL_FILE_SYSTEM_FS_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_FILE_SYSTEM_FS_TYPE {
  PRL_FS_INVALID = 0,
  PRL_FS_FAT = 1,
  PRL_FS_FAT32 = 2,
  PRL_FS_NTFS = 3,
  PRL_FS_HFS = 4,
  PRL_FS_ADFS = 5,
  PRL_FS_AFFS = 6,
  PRL_FS_AFS = 7,
  PRL_FS_AUTOFS = 8,
  PRL_FS_CODA = 9,
  PRL_FS_EFS = 10,
  PRL_FS_EXTFS = 11,
  PRL_FS_HPFS = 12,
  PRL_FS_ISOFS = 13,
  PRL_FS_JFFS2 = 14,
  PRL_FS_NFS = 15,
  PRL_FS_QNX4 = 16,
  PRL_FS_REISERFS = 17,
  PRL_FS_SMBFS = 18,
  PRL_FS_GFS = 19,
  PRL_FS_FUSE = 20,
  PRL_FS_UNSPECIFIED = 0xFF
} PRL_FILE_SYSTEM_FS_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_FILE_SYSTEM_FS_TYPE_PTR Type

PRL_FILE_SYSTEM_FS_TYPE_PTR Type
PRL_FILE Types
Syntax
typedef PRL_FILE_SYSTEM_FS_TYPE* PRL_FILE_SYSTEM_FS_TYPE_PTR;
File

PrlEnums.h

Links
PRL_FILE Types


PRL_FILE_SYSTEM_TYPE Enumeration

PRL_FILE_SYSTEM_TYPE Enumeration
Other Structs

File system general type

Syntax
typedef enum _PRL_FILE_SYSTEM_TYPE {
  PFS_WINDOWS_LIKE_FS = 0,
  PFS_UNIX_LIKE_FS = 1
} PRL_FILE_SYSTEM_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_FILE_SYSTEM_TYPE_PTR Type

PRL_FILE_SYSTEM_TYPE_PTR Type
PRL_FILE Types
Syntax
typedef PRL_FILE_SYSTEM_TYPE* PRL_FILE_SYSTEM_TYPE_PTR;
File

PrlEnums.h

Links
PRL_FILE Types


PRL_FIREWALL_DIRECTION Enumeration

PRL_FIREWALL_DIRECTION Enumeration
Other Structs

Firewall direction

Syntax
typedef enum _PRL_FIREWALL_DIRECTION {
  PFD_INCOMING = 0,
  PFD_OUTGOING = 1
} PRL_FIREWALL_DIRECTION;
File

PrlEnums.h

Links
Other Structs


PRL_FIREWALL_DIRECTION_PTR Type

PRL_FIREWALL_DIRECTION_PTR Type
Other Types
Syntax
typedef PRL_FIREWALL_DIRECTION* PRL_FIREWALL_DIRECTION_PTR;
File

PrlEnums.h

Links
Other Types


PRL_FIREWALL_POLICY Enumeration

PRL_FIREWALL_POLICY Enumeration
Other Structs

Firewall policy

Syntax
typedef enum _PRL_FIREWALL_POLICY {
  PFP_ACCEPT = 0,
  PFP_DENY = 1
} PRL_FIREWALL_POLICY;
File

PrlEnums.h

Links
Other Structs


PRL_FIREWALL_POLICY_PTR Type

PRL_FIREWALL_POLICY_PTR Type
Other Types
Syntax
typedef PRL_FIREWALL_POLICY* PRL_FIREWALL_POLICY_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GENERIC_DEVICE_STATE Enumeration

PRL_GENERIC_DEVICE_STATE Enumeration
Other Structs

Generic device state PGS_CONNECTED_TO_HOST : device is used by host PGS_CONNECTED_TO_VM : device is used by VM PGS_RESERVED : reserved value PGS_NON_CONTROLLED_USB : USB device is not controlled PGS_CONNECTING_TO_VM : device belong to VM, but prl_usb_dev still not started

Syntax
typedef enum _PRL_GENERIC_DEVICE_STATE {
  PGS_CONNECTED_TO_HOST = 0,
  PGS_CONNECTED_TO_VM = 1,
  PGS_RESERVED = 2,
  PGS_NON_CONTROLLED_USB = PGS_RESERVED,
  PGS_CONNECTING_TO_VM = 3
} PRL_GENERIC_DEVICE_STATE;
File

PrlEnums.h

Links
Other Structs


PRL_GENERIC_DEVICE_STATE_PTR Type

PRL_GENERIC_DEVICE_STATE_PTR Type
Other Types
Syntax
typedef PRL_GENERIC_DEVICE_STATE* PRL_GENERIC_DEVICE_STATE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GENERIC_PCI_DEVICE_CLASS Enumeration

PRL_GENERIC_PCI_DEVICE_CLASS Enumeration
Other Structs

Generic PCI device class: PGD_PCI_NETWORK : generic PCI network device PGD_PCI_DISPLAY : generic PCI display device PGD_PCI_SOUND : generic PCI sound device PGD_PCI_OTHER : another generic PCI device

Syntax
typedef enum _PRL_GENERIC_PCI_DEVICE_CLASS {
  PGD_PCI_NETWORK = 0,
  PGD_PCI_DISPLAY = 1,
  PGD_PCI_SOUND = 2,
  PGD_PCI_OTHER = 3
} PRL_GENERIC_PCI_DEVICE_CLASS;
File

PrlEnums.h

Links
Other Structs


PRL_GENERIC_PCI_DEVICE_CLASS_PTR Type

PRL_GENERIC_PCI_DEVICE_CLASS_PTR Type
Other Types
Syntax
typedef PRL_GENERIC_PCI_DEVICE_CLASS* PRL_GENERIC_PCI_DEVICE_CLASS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GET_SNAPSHOT_TREE_FLAGS Enumeration

PRL_GET_SNAPSHOT_TREE_FLAGS Enumeration
Other Structs

PrlVm_GetSnapshotsTreeEx flags

Syntax
typedef enum _PRL_GET_SNAPSHOT_TREE_FLAGS {
  PGST_FULL_SIZE_SCREENSHOTS = 1<<(PACF_MAX+1),
  PGST_WITHOUT_SCREENSHOTS = 1<<(PACF_MAX+2)
} PRL_GET_SNAPSHOT_TREE_FLAGS;
File

PrlCommandsFlags.h

Members

PGST_FULL_SIZE_SCREENSHOTS
return screenshots in full size
PGST_WITHOUT_SCREENSHOTS
fast way to request snapshots tree

Links
Other Structs


PRL_GET_VM_CONFIG_FLAGS Enumeration

PRL_GET_VM_CONFIG_FLAGS Enumeration
Other Structs

Find VM operations:

Syntax
typedef enum _PRL_GET_VM_CONFIG_FLAGS {
  PGVC_SEARCH_BY_UUID = 1<<(PACF_MAX+1),
  PGVC_SEARCH_BY_NAME = 1<<(PACF_MAX+2)
} PRL_GET_VM_CONFIG_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_GET_VM_CONFIG_FLAGS_PTR Type

PRL_GET_VM_CONFIG_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_GET_VM_CONFIG_FLAGS* PRL_GET_VM_CONFIG_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_GET_VM_CONFIG_PARAM_DATA Structure

PRL_GET_VM_CONFIG_PARAM_DATA Structure
Other Structs
Syntax
typedef struct _PRL_GET_VM_CONFIG_PARAM_DATA {
  PRL_VM_TYPE nVmType;
  PRL_CONST_STR sConfigSample;
  PRL_UINT32 nOsVersion;
} PRL_GET_VM_CONFIG_PARAM_DATA;
File

PrlIoStructs.h

Links
Other Structs


PRL_GET_VM_CONFIG_PARAM_DATA_PTR Type

PRL_GET_VM_CONFIG_PARAM_DATA_PTR Type
Other Types
Syntax
typedef PRL_GET_VM_CONFIG_PARAM_DATA* PRL_GET_VM_CONFIG_PARAM_DATA_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_GET_VM_LIST_FLAGS Enumeration

PRL_GET_VM_LIST_FLAGS Enumeration
Other Structs

List operations: Uses for PrlSrv_GetVmListEx operation

Syntax
typedef enum _PRL_GET_VM_LIST_FLAGS {
  PGVLF_GET_ONLY_VM = PVTF_VM,
  PGVLF_GET_ONLY_CT = PVTF_CT,
  PGVLF_GET_ONLY_IDENTITY_INFO = 1<<(PACF_MAX+3),
  PGVLF_GET_STATE_INFO = 1<<(PACF_MAX+4)
} PRL_GET_VM_LIST_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_GET_VM_LIST_FLAGS_PTR Type

PRL_GET_VM_LIST_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_GET_VM_LIST_FLAGS* PRL_GET_VM_LIST_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_GRACEFUL_SHUTDOWN_CAPABILITIES Enumeration

PRL_GRACEFUL_SHUTDOWN_CAPABILITIES Enumeration
Other Structs
Syntax
typedef enum _PRL_GRACEFUL_SHUTDOWN_CAPABILITIES {
  PGST_CAPABILITY_SHUTDOWN = 0x1,
  PGST_CAPABILITY_REBOOT = 0x2,
  PGST_CAPABILITY_SUSPEND = 0x4,
  PGST_CAPABILITY_HIBERNATE = 0x8
} PRL_GRACEFUL_SHUTDOWN_CAPABILITIES;
File

PrlEnums.h

Links
Other Structs


PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR Type

PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR Type
Other Types
Syntax
typedef PRL_GRACEFUL_SHUTDOWN_CAPABILITIES* PRL_GRACEFUL_SHUTDOWN_CAPABILITIES_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GRACEFUL_SHUTDOWN_KIND Enumeration

PRL_GRACEFUL_SHUTDOWN_KIND Enumeration
Other Structs

Graceful Shutdown types

Syntax
typedef enum _PRL_GRACEFUL_SHUTDOWN_KIND {
  PST_VM_SHUTDOWN = 0,
  PST_VM_REBOOT = 1,
  PST_VM_HIBERNATE = 2,
  PST_VM_SUSPEND = 3
} PRL_GRACEFUL_SHUTDOWN_KIND;
File

PrlEnums.h

Links
Other Structs


PRL_GRACEFUL_SHUTDOWN_KIND_PTR Type

PRL_GRACEFUL_SHUTDOWN_KIND_PTR Type
Other Types
Syntax
typedef PRL_GRACEFUL_SHUTDOWN_KIND* PRL_GRACEFUL_SHUTDOWN_KIND_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GUEST_CPU_USAGE_PTRN Macro

PRL_GUEST_CPU_USAGE_PTRN Macro
PVS_GUEST Macros

Guest OS CPU usage in percents (modulated to 100%)

Syntax
#define PRL_GUEST_CPU_USAGE_PTRN "guest.cpu.usage"
File

PrlPerfCounters.h

Links
PVS_GUEST Macros


PRL_GUEST_DISTRO_VERSION_ENUM Enumeration

PRL_GUEST_DISTRO_VERSION_ENUM Enumeration
Other Structs

Windows installation distributive type.

Syntax
typedef enum _PRL_GUEST_DISTRO_VERSION_ENUM {
  PGD_UNKNOWN = 0,
  PGD_WINDOWS_VISTA = 1,
  PGD_WINDOWS_XP = 2,
  PGD_WINDOWS_XP_32 = PGD_WINDOWS_XP,
  PGD_WINDOWS_XP_64 = 3,
  PGD_WINDOWS_VISTA_32 = PGD_WINDOWS_VISTA,
  PGD_WINDOWS_VISTA_64 = 4,
  PGD_WINDOWS_10_32 = 5,
  PGD_WINDOWS_10_64 = 6
} PRL_GUEST_DISTRO_VERSION_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_GUEST_DISTRO_VERSION_ENUM_PTR Type

PRL_GUEST_DISTRO_VERSION_ENUM_PTR Type
Other Types
Syntax
typedef PRL_GUEST_DISTRO_VERSION_ENUM* PRL_GUEST_DISTRO_VERSION_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_GUEST_RAM_CACHED_PTRN Macro

PRL_GUEST_RAM_CACHED_PTRN Macro
PVS_GUEST Macros
Syntax
#define PRL_GUEST_RAM_CACHED_PTRN "guest.ram.cached"
File

PrlPerfCounters.h

Links
PVS_GUEST Macros


PRL_GUEST_RAM_USAGE_PTRN Macro

PRL_GUEST_RAM_USAGE_PTRN Macro
PVS_GUEST Macros

Guest OS RAM usage in megabytes

Syntax
#define PRL_GUEST_RAM_USAGE_PTRN "guest.ram.usage"
File

PrlPerfCounters.h

Links
PVS_GUEST Macros


PRL_GUID_PTR Type

PRL_GUID_PTR Type
Other Types
Syntax
typedef PRL_GUID* PRL_GUID_PTR;
File

PrlTypes.h

Links
Other Types


PRL_HANDLE Type

PRL_HANDLE Type
Other Types

Handle representation

Syntax
typedef int* PRL_HANDLE;
File

PrlTypes.h

Links
Other Types


PRL_HANDLE_PTR Type

PRL_HANDLE_PTR Type
Other Types
Syntax
typedef PRL_HANDLE* PRL_HANDLE_PTR;
File

PrlTypes.h

Links
Other Types


PRL_HANDLE_TYPE Enumeration

PRL_HANDLE_TYPE Enumeration
Other Structs

The _PRL_HANDLE_TYPE enumeration defines handle types.

Syntax
typedef enum _PRL_HANDLE_TYPE {
  PHT_ERROR = 0,
  PHT_SERVER = 0x10000001,
  PHT_SERVER_CONFIG = 0x10000002,
  PHT_REMOTE_FILESYSTEM_INFO = 0x10000003,
  PHT_REMOTE_FILESYSTEM_ENTRY = 0x10000004,
  PHT_VIRTUAL_MACHINE = 0x10000005,
  PHT_VIRTUAL_DEV_DISPLAY = 0x10000006,
  PHT_VIRTUAL_DEV_KEYBOARD = 0x10000007,
  PHT_VIRTUAL_DEV_MOUSE = 0x10000008,
  PHT_VIRTUAL_DEV_FLOPPY = 0x10000009,
  PHT_VIRTUAL_DEV_HARD_DISK = 0x1000000A,
  PHT_VIRTUAL_DEV_NET_ADAPTER = 0x1000000B,
  PHT_VIRTUAL_DEV_PARALLEL_PORT = 0x1000000C,
  PHT_VIRTUAL_DEV_SERIAL_PORT = 0x1000000D,
  PHT_VIRTUAL_DEV_OPTICAL_DISK = 0x1000000E,
  PHT_VIRTUAL_DEV_USB_DEVICE = 0x1000000F,
  PHT_VIRTUAL_DEV_SOUND = 0x10000010,
  PHT_JOB = 0x10000011,
  PHT_EVENT = 0x10000012,
  PHT_RESULT = 0x10000013,
  PHT_VM_INFO = 0x10000014,
  PHT_USER_PROFILE = 0x10000015,
  PHT_DISP_CONFIG = 0x10000016,
  PHT_SHARE = 0x10000017,
  PHT_SCREEN_RESOLUTION = 0x10000018,
  PHT_DISP_NET_ADAPTER = 0x10000019,
  PHT_HW_GENERIC_DEVICE = 0x1000001A,
  PHT_HW_HARD_DISK = 0x1000001B,
  PHT_HW_HARD_DISK_PARTITION = 0x1000001C,
  PHT_HW_NET_ADAPTER = 0x1000001D,
  PHT_EVENT_PARAMETER = 0x1000001E,
  PHT_REMOTEDEV_CMD = 0x1000001F,
  PHT_SYSTEM_STATISTICS = 0x10000020,
  PHT_SYSTEM_STATISTICS_CPU = 0x10000021,
  PHT_SYSTEM_STATISTICS_IFACE = 0x10000022,
  PHT_SYSTEM_STATISTICS_USER_SESSION = 0x10000023,
  PHT_SYSTEM_STATISTICS_DISK = 0x10000024,
  PHT_SYSTEM_STATISTICS_DISK_PARTITION = 0x10000025,
  PHT_SYSTEM_STATISTICS_PROCESS = 0x10000026,
  PHT_LICENSE = 0x10000027,
  PHT_SERVER_INFO = 0x10000028,
  PHT_BOOT_DEVICE = 0x10000029,
  PHT_STRINGS_LIST = 0x1000002A,
  PHT_LOGIN_RESPONSE = 0x1000002B,
  PHT_RUNNING_TASK = 0x1000002C,
  PHT_NET_SERVICE_STATUS = 0x1000002D,
  PHT_HANDLES_LIST = 0x1000002E,
  PHT_VIRTUAL_DISK = 0x1000002F,
  PHT_ACCESS_RIGHTS = 0x10000030,
  PHT_VM_TOOLS_INFO = 0x10000031,
  PHT_FOUND_VM_INFO = 0x10000032,
  PHT_TIS_RECORD = 0x10000033,
  PHT_USER_INFO = 0x10000034,
  PHT_VM_CONFIGURATION = PHT_VIRTUAL_MACHINE,
  PHT_TIS_EMITTER = 0x10000036,
  PHT_TOOL = 0x10000037,
  PHT_VIRTUAL_DEV_HD_PARTITION = 0x10000038,
  PHT_VIRTUAL_DEV_GENERIC_PCI = 0x10000039,
  PHT_VIRTUAL_DEV_GENERIC_SCSI = 0x1000003A,
  PHT_VM_GUEST_SESSION = 0x1000003B,
  PHT_VIRTUAL_NETWORK = 0x1000003C,
  PHT_PORT_FORWARDING = 0x1000003D,
  PHT_HW_GENERIC_PCI_DEVICE = 0x1000003E,
  PHT_OPAQUE_TYPE_LIST = 0x1000003F,
  PHT_GUEST_OSES_MATRIX = 0x10000040,
  PHT_PROBLEM_REPORT = 0x10000041,
  PHT_APPLIANCE_CONFIG = 0x10000042,
  PHT_OFFLINE_SERVICE = 0x10000043,
  PHT_VM_VIRTUAL_DEVICES_INFO = 0x10000044,
  PHT_NETWORK_CLASS = 0x10000045,
  PHT_NETWORK_SHAPING = 0x10000046,
  PHT_NETWORK_RATE = 0x10000047,
  PHT_ISCSI_LUN = 0x10000048,
  PHT_CT_TEMPLATE = 0x10000049,
  PHT_UIEMU_INPUT = 0x10000050,
  PHT_USB_IDENTITY = 0x10000051,
  PHT_FIREWALL_RULE = 0x10000052,
  PHT_IPPRIV_NET = 0x10000053,
  PHT_PLUGIN_INFO = 0x10000054,
  PHT_CVSRC = 0x10000055,
  PHT_DESKTOP_CONTROL = 0x10000056,
  PHT_BACKUP_RESULT = 0x10000057,
  PHT_NETWORK_SHAPING_CONFIG = 0x10000058,
  PHT_NETWORK_SHAPING_BANDWIDTH = 0x10000059,
  PHT_SYSTEM_STATISTICS_VM_DATA = 0x1000005A,
  PHT_VIDEO_RECEIVER = 0x1000005B,
  PHT_SESSION_INFO = 0x1000005C,
  PHT_CPU_FEATURES = 0x1000005D,
  PHT_LAST = PHT_CPU_FEATURES
} PRL_HANDLE_TYPE;
File

PrlEnums.h

Members

PHT_LAST
should be set to last

Remarks

Each handle type and the functions that operate on it is described in detail in the "Functions by Handle" chapter of the Parallels C API Reference guide.

Links
Other Structs


PRL_HANDLE_TYPE_PTR Type

PRL_HANDLE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_HANDLE_TYPE* PRL_HANDLE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_HARD_DISK_IFACE_MASK Enumeration

PRL_HARD_DISK_IFACE_MASK Enumeration
Other Structs

Hard disk interfce mask enum

Syntax
typedef enum _PRL_HARD_DISK_IFACE_MASK {
  PIM_IDE_0_0 = (0x1L<<0),
  PIM_IDE_0_1 = (0x1L<<1),
  PIM_IDE_1_0 = (0x1L<<2),
  PIM_IDE_1_1 = (0x1L<<3),
  PIM_SCSI_0_0 = (0x1L<<4),
  PIM_SCSI_1_0 = (0x1L<<5),
  PIM_SCSI_2_0 = (0x1L<<6),
  PIM_SCSI_3_0 = (0x1L<<7),
  PIM_SCSI_4_0 = (0x1L<<8),
  PIM_SCSI_5_0 = (0x1L<<9),
  PIM_SCSI_6_0 = (0x1L<<10),
  PIM_SCSI_7_0 = (0x1L<<11),
  PIM_SCSI_8_0 = (0x1L<<12),
  PIM_SCSI_9_0 = (0x1L<<13),
  PIM_SCSI_10_0 = (0x1L<<14),
  PIM_SCSI_11_0 = (0x1L<<15),
  PIM_SCSI_12_0 = (0x1L<<16),
  PIM_SCSI_13_0 = (0x1L<<17),
  PIM_SCSI_14_0 = (0x1L<<18),
  PIM_SCSI_15_0 = (0x1L<<19),
  PIM_SATA_0_0 = (0x1L<<20),
  PIM_SATA_0_1 = (0x1L<<21),
  PIM_SATA_0_2 = (0x1L<<22),
  PIM_SATA_0_3 = (0x1L<<23),
  PIM_SATA_0_4 = (0x1L<<24),
  PIM_SATA_0_5 = (0x1L<<25),
  PIM_ALL_DISKS = ((0x1L<<26) - 1),
  PIM_COMPACT_DELAYED = (0x1L<<31),
  PIM_IDE_MASK_OFFSET = PIM_IDE_0_0,
  PIM_SCSI_MASK_OFFSET = PIM_SCSI_0_0,
  PIM_SATA_MASK_OFFSET = PIM_SATA_0_0
} PRL_HARD_DISK_IFACE_MASK;
File

PrlEnums.h

Links
Other Structs


PRL_HARD_DISK_IFACE_MASK_PTR Type

PRL_HARD_DISK_IFACE_MASK_PTR Type
Other Types
Syntax
typedef PRL_HARD_DISK_IFACE_MASK* PRL_HARD_DISK_IFACE_MASK_PTR;
File

PrlEnums.h

Links
Other Types


PRL_HARD_DISK_INTERNAL_FORMAT Enumeration

PRL_HARD_DISK_INTERNAL_FORMAT Enumeration
Other Structs

Hard disk image type

Syntax
typedef enum _PRL_HARD_DISK_INTERNAL_FORMAT {
  PHD_PLAIN_HARD_DISK = 0,
  PHD_EXPANDING_HARD_DISK = 1
} PRL_HARD_DISK_INTERNAL_FORMAT;
File

PrlEnums.h

Links
Other Structs


PRL_HARD_DISK_INTERNAL_FORMAT_PTR Type

PRL_HARD_DISK_INTERNAL_FORMAT_PTR Type
Other Types
Syntax
typedef PRL_HARD_DISK_INTERNAL_FORMAT* PRL_HARD_DISK_INTERNAL_FORMAT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_HDD_FIRMWARE_LEN Macro

PRL_HDD_FIRMWARE_LEN Macro
Other Macros
Syntax
#define PRL_HDD_FIRMWARE_LEN 9
File

PrlDisk.h

Links
Other Macros


PRL_HDD_MODEL_LEN Macro

PRL_HDD_MODEL_LEN Macro
Other Macros

Definitions of length of incoming strings to PrlDisk_GetIdentify function.

Syntax
#define PRL_HDD_MODEL_LEN 41
File

PrlDisk.h

Remarks

The length includes c-string end '0' symbol

Links
Other Macros


PRL_HDD_SERIAL_LEN Macro

PRL_HDD_SERIAL_LEN Macro
Other Macros
Syntax
#define PRL_HDD_SERIAL_LEN 21
File

PrlDisk.h

Links
Other Macros


PRL_HOST_OS_INFO Structure

PRL_HOST_OS_INFO Structure
Other Structs
Syntax
typedef struct _PRL_HOST_OS_INFO {
  PRL_UINT32 hostOSType;
} PRL_HOST_OS_INFO;
File

PrlIoStructs.h

Links
Other Structs


PRL_HOST_OS_INFO_PTR Type

PRL_HOST_OS_INFO_PTR Type
Other Types
Syntax
typedef PRL_HOST_OS_INFO* PRL_HOST_OS_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_HOST_OS_TYPE Enumeration

PRL_HOST_OS_TYPE Enumeration
Other Structs

Host OS type

Syntax
typedef enum _PRL_HOST_OS_TYPE {
  PHO_MAC = 0,
  PHO_LIN = 1,
  PHO_WIN = 2,
  PHO_UNKNOWN = 0xFF
} PRL_HOST_OS_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_HOST_OS_TYPE_PTR Type

PRL_HOST_OS_TYPE_PTR Type
Other Types
Syntax
typedef PRL_HOST_OS_TYPE* PRL_HOST_OS_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration

PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration
Other Structs

Network adapter types in hardware info list

Syntax
typedef enum _PRL_HW_INFO_NET_ADAPTER_TYPE {
  PHI_REAL_NET_ADAPTER = 0,
  PHI_VIRTUAL_NET_ADAPTER = 1,
  PHY_WIFI_REAL_NET_ADAPTER = 2
} PRL_HW_INFO_NET_ADAPTER_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_HW_INFO_NET_ADAPTER_TYPE_PTR Type

PRL_HW_INFO_NET_ADAPTER_TYPE_PTR Type
Other Types
Syntax
typedef PRL_HW_INFO_NET_ADAPTER_TYPE* PRL_HW_INFO_NET_ADAPTER_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_IDE_READ_REQUESTS_PTRN Macro

PRL_IDE_READ_REQUESTS_PTRN Macro
Other Macros

Total count of read requests to IDE controller

Syntax
#define PRL_IDE_READ_REQUESTS_PTRN "devices.ide#.read_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_IDE_READ_TOTAL_PTRN Macro

PRL_IDE_READ_TOTAL_PTRN Macro
Other Macros

Total count of read bytes through IDE controller

Syntax
#define PRL_IDE_READ_TOTAL_PTRN "devices.ide#.read_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_IDE_WRITE_REQUESTS_PTRN Macro

PRL_IDE_WRITE_REQUESTS_PTRN Macro
Other Macros

Total count of write requests to IDE controller

Syntax
#define PRL_IDE_WRITE_REQUESTS_PTRN "devices.ide#.write_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_IDE_WRITE_TOTAL_PTRN Macro

PRL_IDE_WRITE_TOTAL_PTRN Macro
Other Macros

Total count of write bytes through IDE controller

Syntax
#define PRL_IDE_WRITE_TOTAL_PTRN "devices.ide#.write_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_IMAGE_BOOTCAMP Macro

PRL_IMAGE_BOOTCAMP Macro
Other Macros

Bootcamp

Syntax
#define PRL_IMAGE_BOOTCAMP 6
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_BOOTCAMP_FAKE Macro

PRL_IMAGE_BOOTCAMP_FAKE Macro
Other Macros

FAKE Bootcamp, for test purposes

Syntax
#define PRL_IMAGE_BOOTCAMP_FAKE 8
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_BOOTCAMP_UID Macro

PRL_IMAGE_BOOTCAMP_UID Macro
Other Macros

Bootcamp set by UID

Syntax
#define PRL_IMAGE_BOOTCAMP_UID 7
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_COMPRESSED Macro

PRL_IMAGE_COMPRESSED Macro
Other Macros

Compressed disk (version 1)

Syntax
#define PRL_IMAGE_COMPRESSED 2
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_FORMAT Enumeration

PRL_IMAGE_FORMAT Enumeration
Other Structs
Syntax
typedef enum _PRL_IMAGE_FORMAT {
  PIF_RAW = 0x50000008,
  PIF_BMP = 0x50000009,
  PIF_JPG = 0x5000000A,
  PIF_PNG = 0x5000000B
} PRL_IMAGE_FORMAT;
File

PrlEnums.h

Links
Other Structs


PRL_IMAGE_FORMAT_PTR Type

PRL_IMAGE_FORMAT_PTR Type
Other Types
Syntax
typedef PRL_IMAGE_FORMAT* PRL_IMAGE_FORMAT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_IMAGE_INVALID Macro

PRL_IMAGE_INVALID Macro
Other Macros

Invalid type

Syntax
#define PRL_IMAGE_INVALID 0
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_LAST_INVALID Macro

PRL_IMAGE_LAST_INVALID Macro
Other Macros

Last (invalid)

Syntax
#define PRL_IMAGE_LAST_INVALID 0x80000000
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_PARAMETERS Structure

PRL_IMAGE_PARAMETERS Structure
Other Structs

Parallels storage parameters

Syntax
typedef struct __PRL_IMAGE_PARAMETERS {
  PRL_IMAGE_TYPE Type;
  PRL_UINT64 uStart;
  PRL_UINT64 uSize;
  PRL_CHAR_PTR pFileName;
} PRL_IMAGE_PARAMETERS;
File

PrlDisk.h

Links
Other Structs


PRL_IMAGE_PARAMETERS_PTR Type

PRL_IMAGE_PARAMETERS_PTR Type
Other Types
Syntax
typedef PRL_IMAGE_PARAMETERS* PRL_IMAGE_PARAMETERS_PTR;
File

PrlDisk.h

Links
Other Types


PRL_IMAGE_PARTITION Macro

PRL_IMAGE_PARTITION Macro
Other Macros

Partition from disk

Syntax
#define PRL_IMAGE_PARTITION 5
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_PHYSICAL Macro

PRL_IMAGE_PHYSICAL Macro
Other Macros

Real disk (full)

Syntax
#define PRL_IMAGE_PHYSICAL 4
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_PLAIN Macro

PRL_IMAGE_PLAIN Macro
Other Macros

Plain disk

Syntax
#define PRL_IMAGE_PLAIN 1
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_TRY_GUESS Macro

PRL_IMAGE_TRY_GUESS Macro
Other Macros

Software should guess what kind of disk it is

Syntax
#define PRL_IMAGE_TRY_GUESS 100
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_TYPE Type

PRL_IMAGE_TYPE Type
Other Types

Parallels images types

Syntax
typedef PRL_UINT32 PRL_IMAGE_TYPE;
File

PrlDisk.h

Links
Other Types


PRL_IMAGE_TYPE_PTR Type

PRL_IMAGE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_IMAGE_TYPE* PRL_IMAGE_TYPE_PTR;
File

PrlDisk.h

Links
Other Types


PRL_IMAGE_VHD_DIFF Macro

PRL_IMAGE_VHD_DIFF Macro
Other Macros
Syntax
#define PRL_IMAGE_VHD_DIFF 84
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VHD_DYNAMIC Macro

PRL_IMAGE_VHD_DYNAMIC Macro
Other Macros
Syntax
#define PRL_IMAGE_VHD_DYNAMIC 81
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VHD_DYNAMIC_PART Macro

PRL_IMAGE_VHD_DYNAMIC_PART Macro
Other Macros
Syntax
#define PRL_IMAGE_VHD_DYNAMIC_PART 83
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VHD_PLAIN Macro

PRL_IMAGE_VHD_PLAIN Macro
Other Macros

Limited Microsoft VHD support

Syntax
#define PRL_IMAGE_VHD_PLAIN 80
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VHD_PLAIN_PART Macro

PRL_IMAGE_VHD_PLAIN_PART Macro
Other Macros
Syntax
#define PRL_IMAGE_VHD_PLAIN_PART 82
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VMDK_EXTENT_2GB_FLAT Macro

PRL_IMAGE_VMDK_EXTENT_2GB_FLAT Macro
Other Macros
Syntax
#define PRL_IMAGE_VMDK_EXTENT_2GB_FLAT 92
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE Macro

PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE Macro
Other Macros
Syntax
#define PRL_IMAGE_VMDK_EXTENT_2GB_SPARSE 93
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VMDK_MONOLITHIC_FLAT Macro

PRL_IMAGE_VMDK_MONOLITHIC_FLAT Macro
Other Macros

VMware VMDK support

Syntax
#define PRL_IMAGE_VMDK_MONOLITHIC_FLAT 90
File

PrlDisk.h

Links
Other Macros


PRL_IMAGE_VMDK_MONOLITHIC_SPARSE Macro

PRL_IMAGE_VMDK_MONOLITHIC_SPARSE Macro
Other Macros
Syntax
#define PRL_IMAGE_VMDK_MONOLITHIC_SPARSE 91
File

PrlDisk.h

Links
Other Macros


PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED Macro

PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED Macro
Other Macros
Syntax
#define PRL_INFO_VM_MIGRATE_STORAGE_IS_SHARED PRL_RESULT_DECLARE_SUCCESS(31028)
File

PrlErrorsValues.h

Links
Other Macros


PRL_INSTALL_APPLIANCE_FLAGS Enumeration

PRL_INSTALL_APPLIANCE_FLAGS Enumeration
Other Structs

Install appliance options

  • PIAF_CANCEL : cancel appliance installation
  • PIAF_FORCE : do not cancel installation and begin a new one
  • if the previous installation became corrupted outside.
  • PIAF_STOP : temporary stop appliance downloading
Syntax
typedef enum _PRL_INSTALL_APPLIANCE_FLAGS {
  PIAF_CANCEL = 1<<(PACF_MAX+1),
  PIAF_FORCE = 1<<(PACF_MAX+2),
  PIAF_STOP = 1<<(PACF_MAX+3)
} PRL_INSTALL_APPLIANCE_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_INT8 Type

PRL_INT8 Type
PRL_INT Types

Signed 8 bit integer value

Syntax
typedef signed char PRL_INT8;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT8_PTR Type

PRL_INT8_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT8* PRL_INT8_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT8_PTR_PTR Type

PRL_INT8_PTR_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT8** PRL_INT8_PTR_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT16 Type

PRL_INT16 Type
PRL_INT Types

Signed 16 bit integer value

Syntax
typedef short PRL_INT16;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT16_PTR Type

PRL_INT16_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT16* PRL_INT16_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT16_PTR_PTR Type

PRL_INT16_PTR_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT16** PRL_INT16_PTR_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT32 Type

PRL_INT32 Type
PRL_INT Types

Signed 32 bit integer value

Syntax
typedef int PRL_INT32;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT32_PTR Type

PRL_INT32_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT32* PRL_INT32_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT32_PTR_PTR Type

PRL_INT32_PTR_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT32** PRL_INT32_PTR_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT64 Type

PRL_INT64 Type
PRL_INT Types

Signed 64 bit integer value Use _MSC_VER macros for MinGW use

Syntax
typedef long long PRL_INT64;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT64_PTR Type

PRL_INT64_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT64* PRL_INT64_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INT64_PTR_PTR Type

PRL_INT64_PTR_PTR Type
PRL_INT Types
Syntax
typedef PRL_INT64** PRL_INT64_PTR_PTR;
File

PrlTypes.h

Links
PRL_INT Types


PRL_INVALID_FILE_DESCRIPTOR Macro

PRL_INVALID_FILE_DESCRIPTOR Macro
Other Macros

Invalid file descriptor

Syntax
#define PRL_INVALID_FILE_DESCRIPTOR (0)
File

PrlTypes.h

Links
Other Macros


PRL_INVALID_HANDLE Macro

PRL_INVALID_HANDLE Macro
Other Macros
Syntax
#define PRL_INVALID_HANDLE ( 0 )
File

PrlTypes.h

Links
Other Macros


PRL_INVALID_PARTITION Macro

PRL_INVALID_PARTITION Macro
Other Macros

Invalid partition

Syntax
#define PRL_INVALID_PARTITION 0xFF
File

PrlDisk.h

Links
Other Macros


PRL_INVALID_VLAN_TAG Macro

PRL_INVALID_VLAN_TAG Macro
Other Macros

constant for invalid VLAN tag

Syntax
#define PRL_INVALID_VLAN_TAG 0xffff
File

PrlEnums.h

Links
Other Macros


PRL_IO_ATTACH_REQUEST Structure

PRL_IO_ATTACH_REQUEST Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_ATTACH_REQUEST {
  PRL_UINT32 isClientLocal;
  PRL_UINT32 encodingType;
  PRL_UINT8 vmUuid[16];
  PRL_UINT32 attachFlags;
} PRL_IO_ATTACH_REQUEST;
File

PrlIoStructs.h

Members

attachFlags
Since 6.4 IO protocol version

Links
PRL_IO Structs


PRL_IO_ATTACH_REQUEST_PTR Type

PRL_IO_ATTACH_REQUEST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_ATTACH_REQUEST* PRL_IO_ATTACH_REQUEST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_ATTACH_RESPONSE Structure

PRL_IO_ATTACH_RESPONSE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_ATTACH_RESPONSE {
  PRL_UINT32 attachResult;
  PRL_UINT32 encodingResult;
} PRL_IO_ATTACH_RESPONSE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_ATTACH_RESPONSE_PTR Type

PRL_IO_ATTACH_RESPONSE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_ATTACH_RESPONSE* PRL_IO_ATTACH_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUDIO_DATA Structure

PRL_IO_AUDIO_DATA Structure
PRL_IO Structs

Audio support since 6.6 IO protocol version.

Syntax
typedef struct _PRL_IO_AUDIO_DATA {
  PRL_UINT64 framesCounter;
  PRL_UINT16 framesNum;
  PRL_UINT16* frameSize;
  PRL_VOID* frameData;
} PRL_IO_AUDIO_DATA;
File

PrlIoStructs.h

Notes

this struct is visible only on client side and nobody sends/reads it from network.

Links
PRL_IO Structs


PRL_IO_AUDIO_DATA_PTR Type

PRL_IO_AUDIO_DATA_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUDIO_DATA* PRL_IO_AUDIO_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUDIO_ENCODING Structure

PRL_IO_AUDIO_ENCODING Structure
PRL_IO Structs

Audio support since 6.6 IO protocol version.

Syntax
typedef struct _PRL_IO_AUDIO_ENCODING {
  PRL_UINT32 encodingType;
  PRL_UINT32 encodingQuality;
  PRL_UINT32 inout_bitRate;
  PRL_UINT32 inout_channelsNum;
  PRL_UINT32 inout_sampleRate;
  PRL_UINT32 inout_bitsPerChannel;
  PRL_UINT32 unused1;
  PRL_UINT32 unused2;
  PRL_UINT32 out_magicCookieSize;
  PRL_CHAR out_magicCookie[4];
} PRL_IO_AUDIO_ENCODING;
File

PrlIoStructs.h

Members

inout_bitRate
< if 0 in request - correct value should be choosen by Vm side
inout_channelsNum
< if 0 in request - correct value should be choosen by Vm side
inout_sampleRate
< if 0 in request - correct value should be choosen by Vm side
inout_bitsPerChannel
< if 0 in request - correct value should be choosen by Vm side

Links
PRL_IO Structs


PRL_IO_AUDIO_ENCODING_LIST Structure

PRL_IO_AUDIO_ENCODING_LIST Structure
PRL_IO Structs

Audio support since 6.6 IO protocol version.

Syntax
typedef struct _PRL_IO_AUDIO_ENCODING_LIST {
  PRL_UINT32 encodingListSz;
  PRL_UINT32 defaultEncodingIdx;
  PRL_IO_AUDIO_ENCODING encodingList[PRL_IO_MAX_AUDIO_ENCODINGS];
} PRL_IO_AUDIO_ENCODING_LIST;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AUDIO_ENCODING_LIST_PTR Type

PRL_IO_AUDIO_ENCODING_LIST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUDIO_ENCODING_LIST* PRL_IO_AUDIO_ENCODING_LIST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUDIO_ENCODING_PTR Type

PRL_IO_AUDIO_ENCODING_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUDIO_ENCODING* PRL_IO_AUDIO_ENCODING_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUDIO_ENCODING_RESPONSE Structure

PRL_IO_AUDIO_ENCODING_RESPONSE Structure
PRL_IO Structs

Audio support since 6.6 IO protocol version.

Syntax
typedef struct _PRL_IO_AUDIO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
  PRL_IO_AUDIO_ENCODING encoding;
} PRL_IO_AUDIO_ENCODING_RESPONSE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AUDIO_ENCODING_RESPONSE_PTR Type

PRL_IO_AUDIO_ENCODING_RESPONSE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUDIO_ENCODING_RESPONSE* PRL_IO_AUDIO_ENCODING_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUTH_EXEC_REQUEST Structure

PRL_IO_AUTH_EXEC_REQUEST Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_AUTH_EXEC_REQUEST {
  PRL_UINT8 sessionUuid[16];
} PRL_IO_AUTH_EXEC_REQUEST;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AUTH_EXEC_REQUEST_PTR Type

PRL_IO_AUTH_EXEC_REQUEST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUTH_EXEC_REQUEST* PRL_IO_AUTH_EXEC_REQUEST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUTH_REQUEST Structure

PRL_IO_AUTH_REQUEST Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_AUTH_REQUEST {
  PRL_UINT8 sessionUuid[16];
} PRL_IO_AUTH_REQUEST;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AUTH_REQUEST_PTR Type

PRL_IO_AUTH_REQUEST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUTH_REQUEST* PRL_IO_AUTH_REQUEST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AUTH_RESPONSE Structure

PRL_IO_AUTH_RESPONSE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_AUTH_RESPONSE {
  PRL_UINT32 authResult;
} PRL_IO_AUTH_RESPONSE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AUTH_RESPONSE_PTR Type

PRL_IO_AUTH_RESPONSE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AUTH_RESPONSE* PRL_IO_AUTH_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_AVAILABLE_DISPLAYS Structure

PRL_IO_AVAILABLE_DISPLAYS Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_AVAILABLE_DISPLAYS {
  PRL_UINT32 availableDisplays;
} PRL_IO_AVAILABLE_DISPLAYS;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_AVAILABLE_DISPLAYS_PTR Type

PRL_IO_AVAILABLE_DISPLAYS_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_AVAILABLE_DISPLAYS* PRL_IO_AVAILABLE_DISPLAYS_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_CHANNEL_STAT Structure

PRL_IO_CHANNEL_STAT Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_CHANNEL_STAT {
  PRL_UINT32 delay;
  PRL_UINT32 upload;
  PRL_UINT32 download;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
  PRL_UINT32 reserved3;
} PRL_IO_CHANNEL_STAT;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_CHANNEL_STAT_PTR Type

PRL_IO_CHANNEL_STAT_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_CHANNEL_STAT* PRL_IO_CHANNEL_STAT_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_CLIENT_FLAGS Enumeration

PRL_IO_CLIENT_FLAGS Enumeration
PRL_IO Structs

Flags which determines peer client while login to dispatcher and while attach to vm.

Syntax
typedef enum _PRL_IO_CLIENT_FLAGS {
  PCF_ORIGINAL_CLIENT = 1<<(PACF_MAX+1),
  PCF_LIGHTWEIGHT_CLIENT = 1<<(PACF_MAX+2),
  PCF_TRUSTED_CHANNEL = 1<<(PACF_MAX+3)
} PRL_IO_CLIENT_FLAGS;
File

PrlCommandsFlags.h

Members

PCF_ORIGINAL_CLIENT
Client with all features
PCF_LIGHTWEIGHT_CLIENT

  • Lightweight client (iPhone/iPad) which

does not subscribe on heavy packages

PCF_TRUSTED_CHANNEL

  • Login over trusted channel

(no need in username/password)

Links
PRL_IO Structs


PRL_IO_DESKTOP_UTILITIES_STATE Structure

PRL_IO_DESKTOP_UTILITIES_STATE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DESKTOP_UTILITIES_STATE {
  PRL_UINT32 bDesktopShown;
  PRL_UINT32 bTaskbarShown;
} PRL_IO_DESKTOP_UTILITIES_STATE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DESKTOP_UTILITIES_STATE_PTR Type

PRL_IO_DESKTOP_UTILITIES_STATE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DESKTOP_UTILITIES_STATE* PRL_IO_DESKTOP_UTILITIES_STATE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DEVICE_USED Structure

PRL_IO_DEVICE_USED Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DEVICE_USED {
  PRL_UINT32 devType;
  PRL_UINT32 devIndex;
  PRL_UINT32 devAction;
} PRL_IO_DEVICE_USED;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DEVICE_USED_PTR Type

PRL_IO_DEVICE_USED_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DEVICE_USED* PRL_IO_DEVICE_USED_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISCONNECT_REASON Enumeration

PRL_IO_DISCONNECT_REASON Enumeration
Other Structs

Specifies the reason of closing IO connection

Syntax
typedef enum _PRL_IO_DISCONNECT_REASON {
  PDR_UNSPECIFIED = 0,
  PDR_RECONNECT = 1,
  PDR_HOST_USER_LOGGED_IN = 2,
  PDR_HOST_USER_INPUT_DETECTED = 3,
  PDR_ANOTHER_CLIENT_CONNECTED = 4,
  PDR_SESSION_BECOME_INACTIVE = 5
} PRL_IO_DISCONNECT_REASON;
File

PrlEnums.h

Links
Other Structs


PRL_IO_DISCONNECT_REASON_PTR Type

PRL_IO_DISCONNECT_REASON_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISCONNECT_REASON* PRL_IO_DISCONNECT_REASON_PTR;
File

PrlEnums.h

Links
PRL_IO Types


PRL_IO_DISPLAY_ENCODING Structure

PRL_IO_DISPLAY_ENCODING Structure
PRL_IO Structs

Since 6.3 IO protocol version.

Syntax
typedef struct _PRL_IO_DISPLAY_ENCODING {
  PRL_UINT32 encodingType;
  PRL_UINT32 encodingQuality;
  PRL_CHAR encodingName[32];
} PRL_IO_DISPLAY_ENCODING;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_ENCODING_LIST Structure

PRL_IO_DISPLAY_ENCODING_LIST Structure
PRL_IO Structs

Since 6.3 IO protocol version.

Syntax
typedef struct _PRL_IO_DISPLAY_ENCODING_LIST {
  PRL_UINT32 encodingListSz;
  PRL_UINT32 defaultEncodingIdx;
  PRL_IO_DISPLAY_ENCODING encodingList[PRL_IO_MAX_ENCODINGS];
} PRL_IO_DISPLAY_ENCODING_LIST;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_ENCODING_LIST_PTR Type

PRL_IO_DISPLAY_ENCODING_LIST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_ENCODING_LIST* PRL_IO_DISPLAY_ENCODING_LIST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISPLAY_ENCODING_PTR Type

PRL_IO_DISPLAY_ENCODING_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_ENCODING* PRL_IO_DISPLAY_ENCODING_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISPLAY_GAMMA Structure

PRL_IO_DISPLAY_GAMMA Structure
Other Structs
Syntax
typedef struct _PRL_IO_DISPLAY_GAMMA {
  PRL_UINT32 display;
  PRL_UINT32 type;
  PRL_UINT32 gammaSize;
  PRL_UINT32 reserved;
} PRL_IO_DISPLAY_GAMMA;
File

PrlIoStructs.h

Links
Other Structs


PRL_IO_DISPLAY_GAMMA_PTR Type

PRL_IO_DISPLAY_GAMMA_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_GAMMA* PRL_IO_DISPLAY_GAMMA_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISPLAY_PALETTE Structure

PRL_IO_DISPLAY_PALETTE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DISPLAY_PALETTE {
  PRL_IO_PALETTE palette;
  PRL_UINT32 display;
} PRL_IO_DISPLAY_PALETTE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_PALETTE_PTR Type

PRL_IO_DISPLAY_PALETTE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_PALETTE* PRL_IO_DISPLAY_PALETTE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION Structure

PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION {
  PRL_BOOL success;
  PRL_UINT32 flags;
} PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX Structure

PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX Structure
Other Structs
Syntax
typedef struct _PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX {
  PRL_BOOL success;
  PRL_UINT32 flags;
  PRL_UINT64 timestamp;
  PRL_UINT8 reserved[64];
} PRL_IO_DISPLAY_RESOLUTION_CONFIRMATION_EX;
File

PrlIoStructs.h

Links
Other Structs


PRL_IO_DISPLAY_SCREEN_REGION Structure

PRL_IO_DISPLAY_SCREEN_REGION Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DISPLAY_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_DISPLAY_SCREEN_REGION;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_SCREEN_REGION_PTR Type

PRL_IO_DISPLAY_SCREEN_REGION_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_SCREEN_REGION* PRL_IO_DISPLAY_SCREEN_REGION_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DISPLAY_SCREEN_SIZE Structure

PRL_IO_DISPLAY_SCREEN_SIZE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DISPLAY_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
  PRL_UINT32 display;
  PRL_INT32 displayX;
  PRL_INT32 displayY;
} PRL_IO_DISPLAY_SCREEN_SIZE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DISPLAY_SCREEN_SIZE_PTR Type

PRL_IO_DISPLAY_SCREEN_SIZE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DISPLAY_SCREEN_SIZE* PRL_IO_DISPLAY_SCREEN_SIZE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DPI_DISPLAY_SCREEN_SIZE Structure

PRL_IO_DPI_DISPLAY_SCREEN_SIZE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DPI_DISPLAY_SCREEN_SIZE {
  PRL_IO_DISPLAY_SCREEN_SIZE display;
  PRL_INT32 dpi;
  PRL_UINT32 flags;
} PRL_IO_DPI_DISPLAY_SCREEN_SIZE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR Type

PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DPI_DISPLAY_SCREEN_SIZE* PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_DYNRES_TOOLS_STATUS Structure

PRL_IO_DYNRES_TOOLS_STATUS Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_DYNRES_TOOLS_STATUS {
  PRL_UINT32 status;
} PRL_IO_DYNRES_TOOLS_STATUS;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_DYNRES_TOOLS_STATUS_PTR Type

PRL_IO_DYNRES_TOOLS_STATUS_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_DYNRES_TOOLS_STATUS* PRL_IO_DYNRES_TOOLS_STATUS_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_ENCODING_REQUEST Structure

PRL_IO_ENCODING_REQUEST Structure
PRL_IO Structs

This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.

Syntax
typedef struct _PRL_IO_ENCODING_REQUEST {
  PRL_UINT32 encodingType;
} PRL_IO_ENCODING_REQUEST;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_ENCODING_REQUEST_PTR Type

PRL_IO_ENCODING_REQUEST_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_ENCODING_REQUEST* PRL_IO_ENCODING_REQUEST_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_ENCODING_RESPONSE Structure

PRL_IO_ENCODING_RESPONSE Structure
PRL_IO Structs

This struct was implemented earlier 6.3 IO protocol version but actually it was never used, so we can safely change it and use for 6.3 version.

Syntax
typedef struct _PRL_IO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
  PRL_UINT32 requestedEncodingType;
} PRL_IO_ENCODING_RESPONSE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_ENCODING_RESPONSE_PTR Type

PRL_IO_ENCODING_RESPONSE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_ENCODING_RESPONSE* PRL_IO_ENCODING_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_GAMMARAMP_DEFAULT Macro

PRL_IO_GAMMARAMP_DEFAULT Macro
Other Macros
Syntax
#define PRL_IO_GAMMARAMP_DEFAULT 1
File

PrlIoStructs.h

Links
Other Macros


PRL_IO_GAMMARAMP_RGB256x3x16 Macro

PRL_IO_GAMMARAMP_RGB256x3x16 Macro
Other Macros
Syntax
#define PRL_IO_GAMMARAMP_RGB256x3x16 2
File

PrlIoStructs.h

Links
Other Macros


PRL_IO_GENERIC_BUFFER Structure

PRL_IO_GENERIC_BUFFER Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_GENERIC_BUFFER {
  PRL_UINT32 size;
  PRL_VOID_PTR data;
} PRL_IO_GENERIC_BUFFER;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_GENERIC_BUFFER_PTR Type

PRL_IO_GENERIC_BUFFER_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_GENERIC_BUFFER* PRL_IO_GENERIC_BUFFER_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_GRACEFUL_SHUTDOWN Structure

PRL_IO_GRACEFUL_SHUTDOWN Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_GRACEFUL_SHUTDOWN {
  PRL_UINT32 kind;
} PRL_IO_GRACEFUL_SHUTDOWN;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_GRACEFUL_SHUTDOWN_PTR Type

PRL_IO_GRACEFUL_SHUTDOWN_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_GRACEFUL_SHUTDOWN* PRL_IO_GRACEFUL_SHUTDOWN_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_GUEST_NOTIFY_COHERENCE_STATE Structure

PRL_IO_GUEST_NOTIFY_COHERENCE_STATE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_GUEST_NOTIFY_COHERENCE_STATE {
  PRL_UINT32 bCoherenceDisabled;
} PRL_IO_GUEST_NOTIFY_COHERENCE_STATE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR Type

PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_GUEST_NOTIFY_COHERENCE_STATE* PRL_IO_GUEST_NOTIFY_COHERENCE_STATE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_KEYBOARD_LEDS Structure

PRL_IO_KEYBOARD_LEDS Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_KEYBOARD_LEDS {
  PRL_UINT32 ledsState;
} PRL_IO_KEYBOARD_LEDS;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_KEYBOARD_LEDS_PTR Type

PRL_IO_KEYBOARD_LEDS_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_KEYBOARD_LEDS* PRL_IO_KEYBOARD_LEDS_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_KEYBOARD_SCANCODE Structure

PRL_IO_KEYBOARD_SCANCODE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_KEYBOARD_SCANCODE {
  PRL_UINT16 key;
} PRL_IO_KEYBOARD_SCANCODE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_KEYBOARD_SCANCODE_PTR Type

PRL_IO_KEYBOARD_SCANCODE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_KEYBOARD_SCANCODE* PRL_IO_KEYBOARD_SCANCODE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_LANGUAGE_HOTKEYS Structure

PRL_IO_LANGUAGE_HOTKEYS Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_LANGUAGE_HOTKEYS {
  PRL_UINT32 LanguageHotkey;
  PRL_UINT32 LayoutHotkey;
} PRL_IO_LANGUAGE_HOTKEYS;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_LANGUAGE_HOTKEYS_PTR Type

PRL_IO_LANGUAGE_HOTKEYS_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_LANGUAGE_HOTKEYS* PRL_IO_LANGUAGE_HOTKEYS_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_MAX_AUDIO_ENCODINGS Macro

PRL_IO_MAX_AUDIO_ENCODINGS Macro
Other Macros
Syntax
#define PRL_IO_MAX_AUDIO_ENCODINGS 8
File

PrlIoStructs.h

Links
Other Macros


PRL_IO_MAX_DISPLAYS Macro

PRL_IO_MAX_DISPLAYS Macro
Other Macros
Syntax
#define PRL_IO_MAX_DISPLAYS 16
File

PrlIoStructs.h

Links
Other Macros


PRL_IO_MAX_ENCODINGS Macro

PRL_IO_MAX_ENCODINGS Macro
Other Macros
Syntax
#define PRL_IO_MAX_ENCODINGS 32
File

PrlIoStructs.h

Links
Other Macros


PRL_IO_MEMORY_INFO Structure

PRL_IO_MEMORY_INFO Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_MEMORY_INFO {
  PRL_UINT64 ramOffset;
  PRL_UINT64 ramSize;
  PRL_UINT64 vramOffset;
  PRL_UINT64 vramSize;
  PRL_UINT32 filenameSize;
} PRL_IO_MEMORY_INFO;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_MEMORY_INFO_PTR Type

PRL_IO_MEMORY_INFO_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_MEMORY_INFO* PRL_IO_MEMORY_INFO_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_MOUSE_CURSOR Structure

PRL_IO_MOUSE_CURSOR Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_MOUSE_CURSOR {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 hotSpotX;
  PRL_UINT32 hotSpotY;
  PRL_UINT32 width;
  PRL_UINT32 height;
} PRL_IO_MOUSE_CURSOR;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_MOUSE_CURSOR_PTR Type

PRL_IO_MOUSE_CURSOR_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_MOUSE_CURSOR* PRL_IO_MOUSE_CURSOR_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_MOUSE_EVENT Structure

PRL_IO_MOUSE_EVENT Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_MOUSE_EVENT {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
} PRL_IO_MOUSE_EVENT;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_MOUSE_EVENT_EX Structure

PRL_IO_MOUSE_EVENT_EX Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_MOUSE_EVENT_EX {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
  PRL_INT32 w;
} PRL_IO_MOUSE_EVENT_EX;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_MOUSE_EVENT_EX2 Structure

PRL_IO_MOUSE_EVENT_EX2 Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_MOUSE_EVENT_EX2 {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
  PRL_INT32 w;
  PRL_INT32 z120;
  PRL_INT32 w120;
} PRL_IO_MOUSE_EVENT_EX2;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_MOUSE_EVENT_EX2_PTR Type

PRL_IO_MOUSE_EVENT_EX2_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_MOUSE_EVENT_EX2* PRL_IO_MOUSE_EVENT_EX2_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_MOUSE_EVENT_EX_PTR Type

PRL_IO_MOUSE_EVENT_EX_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_MOUSE_EVENT_EX* PRL_IO_MOUSE_EVENT_EX_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_MOUSE_EVENT_PTR Type

PRL_IO_MOUSE_EVENT_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_MOUSE_EVENT* PRL_IO_MOUSE_EVENT_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_PALETTE Type

PRL_IO_PALETTE Type
PRL_IO Types
Syntax
typedef PRL_UINT32 PRL_IO_PALETTE[256];
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SCREEN_BUFFER_REGION Structure

PRL_IO_SCREEN_BUFFER_REGION Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SCREEN_BUFFER_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 scaleWidth;
  PRL_UINT32 scaleHeight;
  PRL_UINT32 display;
} PRL_IO_SCREEN_BUFFER_REGION;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SCREEN_BUFFER_REGION_PTR Type

PRL_IO_SCREEN_BUFFER_REGION_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SCREEN_BUFFER_REGION* PRL_IO_SCREEN_BUFFER_REGION_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SCREEN_REGION Structure

PRL_IO_SCREEN_REGION Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
} PRL_IO_SCREEN_REGION;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SCREEN_REGION_PTR Type

PRL_IO_SCREEN_REGION_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SCREEN_REGION* PRL_IO_SCREEN_REGION_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SCREEN_SIZE Structure

PRL_IO_SCREEN_SIZE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
} PRL_IO_SCREEN_SIZE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SCREEN_SIZE_PTR Type

PRL_IO_SCREEN_SIZE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SCREEN_SIZE* PRL_IO_SCREEN_SIZE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SCREEN_SURFACE Structure

PRL_IO_SCREEN_SURFACE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SCREEN_SURFACE {
  PRL_UINT32 windowId;
  PRL_UINT32 surfaceId;
  PRL_INT32 scrollX;
  PRL_INT32 scrollY;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_SCREEN_SURFACE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SCREEN_SURFACE_PTR Type

PRL_IO_SCREEN_SURFACE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SCREEN_SURFACE* PRL_IO_SCREEN_SURFACE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SCREEN_UPDATE Structure

PRL_IO_SCREEN_UPDATE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SCREEN_UPDATE {
  PRL_UINT32 offset;
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_SCREEN_UPDATE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SCREEN_UPDATE_PTR Type

PRL_IO_SCREEN_UPDATE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SCREEN_UPDATE* PRL_IO_SCREEN_UPDATE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SET_TASKBAR_VISIBILITY Structure

PRL_IO_SET_TASKBAR_VISIBILITY Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SET_TASKBAR_VISIBILITY {
  PRL_UINT32 visibility;
} PRL_IO_SET_TASKBAR_VISIBILITY;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SET_TASKBAR_VISIBILITY_PTR Type

PRL_IO_SET_TASKBAR_VISIBILITY_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SET_TASKBAR_VISIBILITY* PRL_IO_SET_TASKBAR_VISIBILITY_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SHUTDOWN_RESULT Structure

PRL_IO_SHUTDOWN_RESULT Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SHUTDOWN_RESULT {
  PRL_UINT32 uRefused;
  PRL_UINT32 uResult;
} PRL_IO_SHUTDOWN_RESULT;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SHUTDOWN_RESULT_PTR Type

PRL_IO_SHUTDOWN_RESULT_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SHUTDOWN_RESULT* PRL_IO_SHUTDOWN_RESULT_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SLIDING_MOUSE Structure

PRL_IO_SLIDING_MOUSE Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SLIDING_MOUSE {
  PRL_UINT32 state;
} PRL_IO_SLIDING_MOUSE;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SLIDING_MOUSE_PTR Type

PRL_IO_SLIDING_MOUSE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SLIDING_MOUSE* PRL_IO_SLIDING_MOUSE_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_SSO_CLIENT_VM_PACKET Structure

PRL_IO_SSO_CLIENT_VM_PACKET Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_SSO_CLIENT_VM_PACKET {
  PRL_UINT8 credentialsRequestUUID[16];
  PRL_UINT32 reserved[12];
} PRL_IO_SSO_CLIENT_VM_PACKET;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_SSO_CLIENT_VM_PACKET_PTR Type

PRL_IO_SSO_CLIENT_VM_PACKET_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_SSO_CLIENT_VM_PACKET* PRL_IO_SSO_CLIENT_VM_PACKET_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_STATE Enumeration

PRL_IO_STATE Enumeration
PRL_IO Structs
Syntax
typedef enum _PRL_IO_STATE {
  IOS_DISABLED = 0,
  IOS_STARTED = 1,
  IOS_STOPPED = 2,
  IOS_UNKNOWN_VM_UUID = 3,
  IOS_CONNECTION_TIMEOUT = 4,
  IOS_AUTH_FAILED = 5
} PRL_IO_STATE;
File

PrlEnums.h

Members

IOS_DISABLED
< Desktop has not been enabled
IOS_STARTED
< Successfully started.(local and remote)
IOS_STOPPED
< Is stopped.
IOS_UNKNOWN_VM_UUID
< Unknown uuid.
IOS_CONNECTION_TIMEOUT
< Connection timeout.
IOS_AUTH_FAILED
< Authentication failed.

Links
PRL_IO Structs


PRL_IO_STATE_PTR Type

PRL_IO_STATE_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_STATE* PRL_IO_STATE_PTR;
File

PrlEnums.h

Links
PRL_IO Types


PRL_IO_TOOLS_ADJUST_WORKING_AREA Structure

PRL_IO_TOOLS_ADJUST_WORKING_AREA Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_TOOLS_ADJUST_WORKING_AREA {
  PRL_UINT32 bIsOn;
  PRL_UINT32 uDockEdge;
  PRL_INT32 iDockLeft;
  PRL_INT32 iDockTop;
  PRL_INT32 iDockRight;
  PRL_INT32 iDockBottom;
} PRL_IO_TOOLS_ADJUST_WORKING_AREA;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR Type

PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_TOOLS_ADJUST_WORKING_AREA* PRL_IO_TOOLS_ADJUST_WORKING_AREA_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_TOOLS_DISPLAY_INDENT Structure

PRL_IO_TOOLS_DISPLAY_INDENT Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_TOOLS_DISPLAY_INDENT {
  PRL_INT32 displayX;
  PRL_INT32 displayY;
  PRL_UINT32 leftIndentSize;
  PRL_UINT32 topIndentSize;
  PRL_UINT32 rightIndentSize;
  PRL_UINT32 bottomIndentSize;
} PRL_IO_TOOLS_DISPLAY_INDENT;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_TOOLS_DISPLAY_INDENT_PTR Type

PRL_IO_TOOLS_DISPLAY_INDENT_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_TOOLS_DISPLAY_INDENT* PRL_IO_TOOLS_DISPLAY_INDENT_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_TOOLS_MOVE_TASKBAR Structure

PRL_IO_TOOLS_MOVE_TASKBAR Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IO_TOOLS_MOVE_TASKBAR {
  PRL_BOOL bCoherenceOn;
  PRL_BOOL bRelocateTaskBar;
  PRL_UINT32 uDockEdge;
  PRL_UINT32 uEdgeMask;
} PRL_IO_TOOLS_MOVE_TASKBAR;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_TOOLS_MOVE_TASKBAR_PTR Type

PRL_IO_TOOLS_MOVE_TASKBAR_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_TOOLS_MOVE_TASKBAR* PRL_IO_TOOLS_MOVE_TASKBAR_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_TOOLS_SIA_DATA Structure

PRL_IO_TOOLS_SIA_DATA Structure
PRL_IO Structs

@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
Syntax
typedef struct _PRL_IO_TOOLS_SIA_DATA {
  PRL_UINT32 ver;
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 size;
} PRL_IO_TOOLS_SIA_DATA;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_TOOLS_SIA_DATA_PTR Type

PRL_IO_TOOLS_SIA_DATA_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_TOOLS_SIA_DATA* PRL_IO_TOOLS_SIA_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IO_TOOLS_UTILITY_COMMAND Structure

PRL_IO_TOOLS_UTILITY_COMMAND Structure
PRL_IO Structs

@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
Syntax
typedef struct _PRL_IO_TOOLS_UTILITY_COMMAND {
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 dataSize;
} PRL_IO_TOOLS_UTILITY_COMMAND;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IO_TOOLS_UTILITY_COMMAND_PTR Type

PRL_IO_TOOLS_UTILITY_COMMAND_PTR Type
PRL_IO Types
Syntax
typedef PRL_IO_TOOLS_UTILITY_COMMAND* PRL_IO_TOOLS_UTILITY_COMMAND_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IOLIMIT_DATA Structure

PRL_IOLIMIT_DATA Structure
PRL_IO Structs
Syntax
typedef struct _PRL_IOLIMIT_DATA {
  PRL_UINT32 value;
  PRL_IOLIMIT_TYPE type;
} PRL_IOLIMIT_DATA;
File

PrlIoStructs.h

Links
PRL_IO Structs


PRL_IOLIMIT_DATA_PTR Type

PRL_IOLIMIT_DATA_PTR Type
PRL_IO Types
Syntax
typedef PRL_IOLIMIT_DATA* PRL_IOLIMIT_DATA_PTR;
File

PrlIoStructs.h

Links
PRL_IO Types


PRL_IOLIMIT_TYPE Enumeration

PRL_IOLIMIT_TYPE Enumeration
PRL_IO Structs
Syntax
typedef enum _PRL_IOLIMIT_TYPE {
  PRL_IOLIMIT_BS = 1
} PRL_IOLIMIT_TYPE;
File

PrlEnums.h

Links
PRL_IO Structs


PRL_IOPRIO Enumeration

PRL_IOPRIO Enumeration
Other Structs
Syntax
typedef enum _PRL_IOPRIO {
  PRL_IOPRIO_MIN = 0,
  PRL_IOPRIO_DEFAULT = 4,
  PRL_IOPRIO_MAX = 7
} PRL_IOPRIO;
File

PrlEnums.h

Links
Other Structs


PRL_ISCSI_STORAGE_CMD_FLAGS Enumeration

PRL_ISCSI_STORAGE_CMD_FLAGS Enumeration
Other Structs

iSCSI storage management flags

Syntax
typedef enum _PRL_ISCSI_STORAGE_CMD_FLAGS {
  PISCSI_STORAGE_CREATE = 1<<(PACF_MAX+1),
  PISCSI_STORAGE_REMOVE = 1<<(PACF_MAX+2),
  PISCSI_STORAGE_MOUNT_RDONLY = 1<<(PACF_MAX+3),
  PISCSI_STORAGE_REMOUNT = 1<<(PACF_MAX+4),
  PISCSI_STORAGE_MOUNT = 1<<(PACF_MAX+5)
} PRL_ISCSI_STORAGE_CMD_FLAGS;
File

PrlCommandsFlags.h

Members

PISCSI_STORAGE_CREATE
To create storage on register
PISCSI_STORAGE_REMOVE
To remove storage on unregister
PISCSI_STORAGE_MOUNT_RDONLY
To mount storage by read-only
PISCSI_STORAGE_REMOUNT
To remount storage
PISCSI_STORAGE_MOUNT
To mount storage on register

Links
Other Structs


PRL_ISCSI_STORAGE_FSTYPE_FLAGS Enumeration

PRL_ISCSI_STORAGE_FSTYPE_FLAGS Enumeration
Other Structs

iSCSI storage filesystem type

Syntax
typedef enum _PRL_ISCSI_STORAGE_FSTYPE_FLAGS {
  PISCSI_STORAGE_EXT3 = 1<<(PACF_MAX+1),
  PISCSI_STORAGE_EXT4 = 1<<(PACF_MAX+2),
  PISCSI_STORAGE_NTFS = 1<<(PACF_MAX+3)
} PRL_ISCSI_STORAGE_FSTYPE_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_JOB_OPERATION_CODE Enumeration

PRL_JOB_OPERATION_CODE Enumeration
Other Structs

Job operation codes

Syntax
typedef enum _PRL_JOB_OPERATION_CODE {
  PJOC_UNKNOWN = 0,
  PJOC_JOB_CANCEL = 1,
  PJOC_SRV_LOOKUP_PARALLELS_SERVERS = 2,
  PJOC_SRV_LOGIN = 3,
  PJOC_SRV_LOGIN_LOCAL = 4,
  PJOC_SRV_LOGOFF = 5,
  PJOC_SRV_GET_SRV_CONFIG = 6,
  PJOC_SRV_GET_COMMON_PREFS = 7,
  PJOC_SRV_COMMON_PREFS_BEGIN_EDIT = 8,
  PJOC_SRV_COMMON_PREFS_COMMIT = 9,
  PJOC_SRV_GET_USER_PROFILE = 10,
  PJOC_SRV_GET_STATISTICS = 11,
  PJOC_SRV_USER_PROFILE_BEGIN_EDIT = 12,
  PJOC_SRV_USER_PROFILE_COMMIT = 13,
  PJOC_SRV_REGISTER_VM = 14,
  PJOC_SRV_REGISTER_VM_EX = PJOC_SRV_REGISTER_VM,
  PJOC_SRV_GET_VM_LIST = 15,
  PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS = 16,
  PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS = 17,
  PJOC_SRV_SHUTDOWN = 18,
  PJOC_SRV_FS_GET_DISK_LIST = 19,
  PJOC_SRV_FS_GET_DIR_ENTRIES = 20,
  PJOC_SRV_FS_CREATE_DIR = 21,
  PJOC_SRV_FS_REMOVE_ENTRY = 22,
  PJOC_SRV_FS_CAN_CREATE_FILE = 23,
  PJOC_SRV_FS_RENAME_ENTRY = 24,
  PJOC_SRV_FS_GENERATE_ENTRY_NAME = 25,
  PJOC_SRV_UPDATE_LICENSE = 26,
  PJOC_SRV_GET_LICENSE_INFO = 27,
  PJOC_SRV_SEND_ANSWER = 28,
  PJOC_SRV_START_SEARCH_VMS = 29,
  PJOC_SRV_NET_SERVICE_START = 30,
  PJOC_SRV_NET_SERVICE_STOP = 31,
  PJOC_SRV_NET_SERVICE_RESTART = 32,
  PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS = 33,
  PJOC_SRV_GET_NET_SERVICE_STATUS = 34,
  PJOC_SRV_ADD_NET_ADAPTER = 35,
  PJOC_SRV_DELETE_NET_ADAPTER = 36,
  PJOC_SRV_UPDATE_NET_ADAPTER = 37,
  PJOC_SRV_GET_PROBLEM_REPORT = 38,
  PJOC_SRV_ATTACH_TO_LOST_TASK = 39,
  PJOC_SRV_GET_USER_INFO_LIST = 40,
  PJOC_SRV_GET_USER_INFO = 41,
  PJOC_VM_START = 42,
  PJOC_VM_STOP = 43,
  PJOC_VM_PAUSE = 44,
  PJOC_VM_RESET = 45,
  PJOC_VM_SUSPEND = 46,
  PJOC_VM_RESUME = PJOC_VM_START,
  PJOC_VM_DROP_SUSPENDED_STATE = 49,
  PJOC_VM_CLONE = 50,
  PJOC_VM_DELETE = 51,
  PJOC_VM_GET_PROBLEM_REPORT = 52,
  PJOC_VM_GET_STATE = 53,
  PJOC_VM_GENERATE_VM_DEV_FILENAME = 54,
  PJOC_VM_GET_TOOLS_STATE = 55,
  PJOC_VM_REFRESH_CONFIG = 56,
  PJOC_VM_GET_STATISTICS = 57,
  PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS = 58,
  PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS = 59,
  PJOC_VM_REG = 60,
  PJOC_VM_UNREG = 61,
  PJOC_VM_BEGIN_EDIT = 62,
  PJOC_VM_COMMIT = 63,
  PJOC_VM_CREATE_UNATTENDED_FLOPPY = 64,
  PJOC_VM_CREATE_UNATTENDED_DISK = PJOC_VM_CREATE_UNATTENDED_FLOPPY,
  PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS = 65,
  PJOC_VM_UPDATE_SECURITY = 66,
  PJOC_VM_VALIDATE_CONFIG = 67,
  PJOC_VM_DEV_CONNECT = 68,
  PJOC_VM_DEV_DISCONNECT = 69,
  PJOC_VM_DEV_CREATE_IMAGE = 70,
  PJOC_VM_INSTALL_TOOLS = 71,
  PJOC_VM_SEND_SHUTDOWN_COMMAND = 72,
  PJOC_VM_SEND_CLIPBOARD_REQUEST = 73,
  PJOC_VM_CONNECT_TO_VM = 74,
  PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN = 75,
  PJOC_VM_MIGRATE = 76,
  PJOC_VM_SEND_DRAGDROP_COMMAND = 77,
  PJOC_VM_GUEST_RUN_PROGRAM = 78,
  PJOC_VM_GUEST_LOGOUT = 79,
  PJOC_SRV_SUBSCRIBE_PERFSTATS = 80,
  PJOC_SRV_UNSUBSCRIBE_PERFSTATS = 81,
  PJOC_SRV_GET_PERFSTATS = 82,
  PJOC_VM_SUBSCRIBE_PERFSTATS = 83,
  PJOC_VM_UNSUBSCRIBE_PERFSTATS = 84,
  PJOC_VM_GET_PERFSTATS = 85,
  PJOC_VM_GET_SUSPENDED_SCREEN = 86,
  PJOC_VM_MIGRATE_CANCEL = 87,
  PJOC_VM_RUN_COMPRESSOR = 88,
  PJOC_VM_CANCEL_COMPRESSOR = 89,
  PJOC_VM_CREATE_SNAPSHOT = 90,
  PJOC_VM_SWITCH_TO_SNAPSHOT = 91,
  PJOC_VM_DELETE_SNAPSHOT = 92,
  PJOC_VM_GET_SNAPSHOTS_TREE = 93,
  PJOC_VM_START_EX = 94,
  PJOC_VM_LOGIN_IN_GUEST = 95,
  PJOC_VM_UPDATE_SNAPSHOT_DATA = 96,
  PJOC_VM_RESTART = 97,
  PJOC_VM_INSTALL_UTILITY = 98,
  PJOC_VM_UPDATE_TOOLS_SECTION = 99,
  PJOC_SRV_GET_ALL_HOST_USERS = 100,
  PJOC_VM_RESTORE = 101,
  PJOC_VM_START_VNC_SERVER = 102,
  PJOC_VM_STOP_VNC_SERVER = 103,
  PJOC_VM_GUEST_GET_NETWORK_SETTINGS = 104,
  PJOC_SRV_GET_VIRTUAL_NETWORK_LIST = 105,
  PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB = 106,
  PJOC_VM_GUEST_SET_USER_PASSWD = 107,
  PJOC_SRV_ADD_VIRTUAL_NETWORK = 108,
  PJOC_SRV_UPDATE_VIRTUAL_NETWORK = 109,
  PJOC_SRV_DELETE_VIRTUAL_NETWORK = 110,
  PJOC_SRV_CONFIGURE_GENERIC_PCI = 111,
  PJOC_SRV_PREPARE_FOR_HIBERNATE = 112,
  PJOC_SRV_AFTER_HOST_RESUME = 113,
  PJOC_SRV_GET_BACKUP_TREE = 114,
  PJOC_SRV_CREATE_VM_BACKUP = 115,
  PJOC_SRV_RESTORE_VM_BACKUP = 116,
  PJOC_API_SEND_PROBLEM_REPORT = 117,
  PJOC_VM_LOCK = 118,
  PJOC_VM_UNLOCK = 119,
  PJOC_SRV_SET_NON_INTERACTIVE_SESSION = 120,
  PJOC_SRV_CREATE_UNATTENDED_CD = 121,
  PJOC_SRV_REMOVE_VM_BACKUP = 122,
  PJOC_VM_RESIZE_DISK_IMAGE = 123,
  PJOC_SRV_SET_SESSION_CONFIRMATION_MODE = 124,
  PJOC_SRV_STORE_VALUE_BY_KEY = 125,
  PJOC_VM_STORE_VALUE_BY_KEY = 126,
  PJOC_VM_COMPACT = 127,
  PJOC_VM_CANCEL_COMPACT = 128,
  PJOC_SRV_SEND_CLIENT_STATISTICS = 129,
  PJOC_VM_GET_PACKED_PROBLEM_REPORT = 130,
  PJOC_SRV_GET_PACKED_PROBLEM_REPORT = 131,
  PJOC_API_SEND_PACKED_PROBLEM_REPORT = 132,
  PJOC_SRV_UPDATE_USB_ASSOC_LIST = 133,
  PJOC_SRV_REGISTER_3RD_PARTY_VM = 134,
  PJOC_VM_CHANGE_SID = 135,
  PJOC_VM_RESET_UPTIME = 136,
  PJOC_REPORT_ASSEMBLY = 137,
  PJOC_SRV_INSTALL_APPLIANCE = 138,
  PJOC_SRV_UPDATE_OFFLINE_SERVICE = 139,
  PJOC_SRV_DELETE_OFFLINE_SERVICE = 140,
  PJOC_SRV_GET_OFFLINE_SERVICES_LIST = 141,
  PJOC_SRV_START_CLUSTER_SERVICE = 142,
  PJOC_SRV_STOP_CLUSTER_SERVICE = 143,
  PJOC_VM_CMD_INTERNAL = 144,
  PJOC_VM_GET_VIRTUAL_DEVICES_INFO = 145,
  PJOC_VM_CONVERT_DISKS = 146,
  PJOC_VM_DEV_HD_CHECK_PASSWORD = 147,
  PJOC_VM_AUTHORISE = 148,
  PJOC_VM_CHANGE_PASSWORD = 149,
  PJOC_VM_ENCRYPT = 150,
  PJOC_VM_DECRYPT = 151,
  PJOC_SRV_UPDATE_NETWORK_CLASSES_CONFIG = 152,
  PJOC_SRV_GET_NETWORK_CLASSES_LIST = 153,
  PJOC_SRV_UPDATE_NETWORK_SHAPING_CONFIG = 154,
  PJOC_SRV_GET_NETWORK_SHAPING_CONFIG = 155,
  PJOC_SRV_RESTART_NETWORK_SHAPING = 156,
  PJOC_SRV_PROXY_GET_REGISTERED_HOSTS = 157,
  PJOC_SRV_REGISTER_ISCSI_STORAGE = 158,
  PJOC_SRV_UNREGISTER_ISCSI_STORAGE = 159,
  PJOC_SRV_EXTEND_ISCSI_STORAGE = 160,
  PJOC_SRV_GET_CT_TEMPLATE_LIST = 161,
  PJOC_SRV_CHECK_ALIVE = 162,
  PJOC_SRV_GET_DEFAULT_VM_CONFIG = 163,
  PJOC_SRV_REMOVE_CT_TEMPLATE = 164,
  PJOC_SRV_COPY_CT_TEMPLATE = 165,
  PJOC_SRV_ADD_IPPRIVATE_NETWORK = 166,
  PJOC_SRV_REMOVE_IPPRIVATE_NETWORK = 167,
  PJOC_SRV_UPDATE_IPPRIVATE_NETWORK = 168,
  PJOC_SRV_GET_IPPRIVATE_NETWORKS_LIST = 169,
  PJOC_VM_DEV_COPY_IMAGE = 170,
  PJOC_SRV_REFRESH_PLUGINS = 171,
  PJOC_VM_MOUNT = 172,
  PJOC_VM_UMOUNT = 173,
  PJOC_SRV_GET_PLUGINS_LIST = 174,
  PJOC_SRV_GET_DISK_FREE_SPACE = 175,
  PJOC_DESKTOP_CONTROL_CONNECT = 176,
  PJOC_VM_MOVE = 177,
  PJOC_SRV_GENERATE_CSR = 178,
  PJOC_SRV_SIGN_CERTIFICATION_REQUEST = 179,
  PJOC_SRV_GET_VM_CONFIG = 180,
  PJOC_PTM_RPC = 181,
  PJOC_API_PUT_USER_DATA = 182,
  PJOC_API_GET_USER_DATA = 183,
  PJOC_API_GET_USER_KEYS = 184,
  PJOC_API_REMOVE_USER_DATA = 185,
  PJOC_API_PUT_ICON = 186,
  PJOC_API_VALIDATE_IN_CACHE = 187,
  PJOC_SRV_UPDATE_SESSION_INFO = 188,
  PJOC_API_SUBSCRIBE_ON_REGISTRATION = 189,
  PJOC_SRV_SEND_PROBLEM_REPORT = 190,
  PJOC_VM_SEND_PROBLEM_REPORT = 191,
  PJOC_VM_SET_PROTECTION = 192,
  PJOC_VM_REMOVE_PROTECTION = 193
} PRL_JOB_OPERATION_CODE;
File

PrlEnums.h

Links
Other Structs


PRL_JOB_OPERATION_CODE_PTR Type

PRL_JOB_OPERATION_CODE_PTR Type
Other Types
Syntax
typedef PRL_JOB_OPERATION_CODE* PRL_JOB_OPERATION_CODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_JOB_STATUS Enumeration

PRL_JOB_STATUS Enumeration
Other Structs

Job status enumeration

Syntax
typedef enum _PRL_JOB_STATUS {
  PJS_UNKNOWN = 0,
  PJS_RUNNING = 0xD0000001,
  PJS_FINISHED = 0xD0000002
} PRL_JOB_STATUS;
File

PrlEnums.h

Links
Other Structs


PRL_JOB_STATUS_PTR Type

PRL_JOB_STATUS_PTR Type
Other Types
Syntax
typedef PRL_JOB_STATUS* PRL_JOB_STATUS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_KEY Enumeration

PRL_KEY Enumeration
Other Structs

Parallels virtual keycodes.

Syntax
typedef enum _PRL_KEY {
  PRL_KEY_INVALID = 0,
  PRL_KEY_WILDCARD_ANY = 1,
  PRL_KEY_WILDCARD_KEYBOARD = 2,
  PRL_KEY_WILDCARD_MOUSE = 3,
  PRL_KEY_WILDCARD_SHIFT = 4,
  PRL_KEY_WILDCARD_CTRL = 5,
  PRL_KEY_WILDCARD_ALT = 6,
  PRL_KEY_WILDCARD_WIN = 7,
  PRL_KEY_ESCAPE = 9,
  PRL_KEY_1 = 10,
  PRL_KEY_2 = 11,
  PRL_KEY_3 = 12,
  PRL_KEY_4 = 13,
  PRL_KEY_5 = 14,
  PRL_KEY_6 = 15,
  PRL_KEY_7 = 16,
  PRL_KEY_8 = 17,
  PRL_KEY_9 = 18,
  PRL_KEY_0 = 19,
  PRL_KEY_MINUS = 20,
  PRL_KEY_EQUAL = 21,
  PRL_KEY_BACKSPACE = 22,
  PRL_KEY_TAB = 23,
  PRL_KEY_Q = 24,
  PRL_KEY_W = 25,
  PRL_KEY_E = 26,
  PRL_KEY_R = 27,
  PRL_KEY_T = 28,
  PRL_KEY_Y = 29,
  PRL_KEY_U = 30,
  PRL_KEY_I = 31,
  PRL_KEY_O = 32,
  PRL_KEY_P = 33,
  PRL_KEY_LEFT_BRACKET = 34,
  PRL_KEY_RIGHT_BRACKET = 35,
  PRL_KEY_ENTER = 36,
  PRL_KEY_LEFT_CONTROL = 37,
  PRL_KEY_A = 38,
  PRL_KEY_S = 39,
  PRL_KEY_D = 40,
  PRL_KEY_F = 41,
  PRL_KEY_G = 42,
  PRL_KEY_H = 43,
  PRL_KEY_J = 44,
  PRL_KEY_K = 45,
  PRL_KEY_L = 46,
  PRL_KEY_SEMICOLON = 47,
  PRL_KEY_QUOTE = 48,
  PRL_KEY_TILDA = 49,
  PRL_KEY_LEFT_SHIFT = 50,
  PRL_KEY_BACKSLASH = 51,
  PRL_KEY_Z = 52,
  PRL_KEY_X = 53,
  PRL_KEY_C = 54,
  PRL_KEY_V = 55,
  PRL_KEY_B = 56,
  PRL_KEY_N = 57,
  PRL_KEY_M = 58,
  PRL_KEY_COMMA = 59,
  PRL_KEY_DOT = 60,
  PRL_KEY_SLASH = 61,
  PRL_KEY_RIGHT_SHIFT = 62,
  PRL_KEY_NP_STAR = 63,
  PRL_KEY_LEFT_ALT = 64,
  PRL_KEY_SPACE = 65,
  PRL_KEY_CAPS_LOCK = 66,
  PRL_KEY_F1 = 67,
  PRL_KEY_F2 = 68,
  PRL_KEY_F3 = 69,
  PRL_KEY_F4 = 70,
  PRL_KEY_F5 = 71,
  PRL_KEY_F6 = 72,
  PRL_KEY_F7 = 73,
  PRL_KEY_F8 = 74,
  PRL_KEY_F9 = 75,
  PRL_KEY_F10 = 76,
  PRL_KEY_NUM_LOCK = 77,
  PRL_KEY_SCROLL_LOCK = 78,
  PRL_KEY_NP_7 = 79,
  PRL_KEY_NP_8 = 80,
  PRL_KEY_NP_9 = 81,
  PRL_KEY_NP_MINUS = 82,
  PRL_KEY_NP_4 = 83,
  PRL_KEY_NP_5 = 84,
  PRL_KEY_NP_6 = 85,
  PRL_KEY_NP_PLUS = 86,
  PRL_KEY_NP_1 = 87,
  PRL_KEY_NP_2 = 88,
  PRL_KEY_NP_3 = 89,
  PRL_KEY_NP_0 = 90,
  PRL_KEY_NP_DELETE = 91,
  PRL_KEY_PRINT = 92,
  PRL_KEY_EUROPE_1 = 93,
  PRL_KEY_EUROPE_2 = 94,
  PRL_KEY_F11 = 95,
  PRL_KEY_F12 = 96,
  PRL_KEY_HOME = 97,
  PRL_KEY_UP = 98,
  PRL_KEY_PAGE_UP = 99,
  PRL_KEY_LEFT = 100,
  PRL_KEY_RIGHT = 102,
  PRL_KEY_END = 103,
  PRL_KEY_DOWN = 104,
  PRL_KEY_PAGE_DOWN = 105,
  PRL_KEY_INSERT = 106,
  PRL_KEY_DELETE = 107,
  PRL_KEY_NP_ENTER = 108,
  PRL_KEY_RIGHT_CONTROL = 109,
  PRL_KEY_PAUSE = 110,
  PRL_KEY_NP_SLASH = 112,
  PRL_KEY_RIGHT_ALT = 113,
  PRL_KEY_LEFT_WIN = 115,
  PRL_KEY_RIGHT_WIN = 116,
  PRL_KEY_MENU = 117,
  PRL_KEY_MEDIA_NEXT_TRACK = 118,
  PRL_KEY_MEDIA_PREV_TRACK = 119,
  PRL_KEY_MEDIA_STOP = 120,
  PRL_KEY_MEDIA_PLAY_PAUSE = 121,
  PRL_KEY_MUTE = 122,
  PRL_KEY_VOLUME_UP = 123,
  PRL_KEY_VOLUME_DOWN = 124,
  PRL_KEY_MEDIA_SELECT = 125,
  PRL_KEY_APP_MAIL = 126,
  PRL_KEY_APP_CALCULATOR = 127,
  PRL_KEY_APP_MY_COMPUTER = 128,
  PRL_KEY_WWW_SEARCH = 129,
  PRL_KEY_WWW_HOME = 130,
  PRL_KEY_WWW_BACK = 131,
  PRL_KEY_WWW_FORWARD = 132,
  PRL_KEY_WWW_STOP = 133,
  PRL_KEY_WWW_REFRESH = 134,
  PRL_KEY_WWW_FAVORITES = 135,
  PRL_KEY_EJECT = 136,
  PRL_KEY_SYSTEM_POWER = 137,
  PRL_KEY_SYSTEM_SLEEP = 138,
  PRL_KEY_SYSTEM_WAKE = 139,
  PRL_KEY_BRAZILIAN_KEYPAD = 140,
  PRL_KEY_RO = 141,
  PRL_KEY_HIRAGANA_KATAKANA = 142,
  PRL_KEY_YEN = 143,
  PRL_KEY_HENKAN = 144,
  PRL_KEY_MUHENKAN = 145,
  PRL_KEY_PC9800_KEYPAD = 146,
  PRL_KEY_HANGUEL = 147,
  PRL_KEY_HANJA = 148,
  PRL_KEY_KATAKANA = 149,
  PRL_KEY_HIRAGANA = 150,
  PRL_KEY_ZENKAKU_HANKAKU = 151,
  PRL_KEY_F13 = 152,
  PRL_KEY_F14 = 153,
  PRL_KEY_F15 = 154,
  PRL_KEY_F16 = 155,
  PRL_KEY_F17 = 156,
  PRL_KEY_F18 = 157,
  PRL_KEY_F19 = 158,
  PRL_KEY_F20 = 159,
  PRL_KEY_F21 = 160,
  PRL_KEY_F22 = 161,
  PRL_KEY_F23 = 162,
  PRL_KEY_F24 = 163,
  PRL_KEY_NP_EQUAL = 164,
  PRL_KEY_BREAK = 165,
  PRL_KEY_PRINT_WITH_MODIFIER = 166,
  PRL_KEY_SYSRQ = 167,
  PRL_KEY_FN = 168,
  PRL_KEY_EURO = 169,
  PRL_KEY_DOLLAR = 170,
  PRL_KEY_MON_BRIGHTNESS_DOWN = 171,
  PRL_KEY_MON_BRIGHTNESS_UP = 172,
  PRL_KEY_APP_EXPOSE = 173,
  PRL_KEY_APP_DASHBOARD = 174,
  PRL_KEY_KBD_BRIGHTNESS_DOWN = 175,
  PRL_KEY_KBD_BRIGHTNESS_UP = 176,
  PRL_KEY_MAC129 = 177,
  PRL_KEY_LEFT_BUTTON = 178,
  PRL_KEY_MIDDLE_BUTTON = 179,
  PRL_KEY_RIGHT_BUTTON = 180,
  PRL_KEY_MOVE_UP_LEFT = 181,
  PRL_KEY_MOVE_UP = 182,
  PRL_KEY_MOVE_UP_RIGHT = 183,
  PRL_KEY_MOVE_LEFT = 184,
  PRL_KEY_MOVE_RIGHT = 185,
  PRL_KEY_MOVE_DOWN_LEFT = 186,
  PRL_KEY_MOVE_DOWN = 187,
  PRL_KEY_MOVE_DOWN_RIGHT = 188,
  PRL_KEY_WHEEL_UP = 189,
  PRL_KEY_WHEEL_DOWN = 190,
  PRL_KEY_WHEEL_LEFT = 191,
  PRL_KEY_WHEEL_RIGHT = 192,
  PRL_KEY_MAX = 193
} PRL_KEY;
File

PrlKeys.h

Links
Other Structs


PRL_KEY_EVENT Enumeration

PRL_KEY_EVENT Enumeration
Other Structs
Syntax
typedef enum _PRL_KEY_EVENT {
  PKE_PRESS = 0x0,
  PKE_RELEASE = 0x80
} PRL_KEY_EVENT;
File

PrlEnums.h

Links
Other Structs


PRL_KEY_EVENT_PTR Type

PRL_KEY_EVENT_PTR Type
Other Types
Syntax
typedef PRL_KEY_EVENT* PRL_KEY_EVENT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_LICENSE_IS_EXPIRED Macro

PRL_LICENSE_IS_EXPIRED Macro
Other Macros
Syntax
#define PRL_LICENSE_IS_EXPIRED( x ) \
    ( ( x == PRL_ERR_LICENSE_EXPIRED ) || \
        ( x == PRL_ERR_VZLICENSE_KA_LICENSE_EXPIRED ) )
File

PrlErrors.h

Links
Other Macros


PRL_LICENSE_IS_VALID Macro

PRL_LICENSE_IS_VALID Macro
Other Macros

Success license state

Syntax
#define PRL_LICENSE_IS_VALID(x) \
    ( (PRL_RESULT) ( ( x == PRL_ERR_LICENSE_VALID ) || \
        ( x == PRL_ERR_LICENSE_GRACED ) ) )
File

PrlErrors.h

Links
Other Macros


PRL_LICENSE_RESTRICTION_KEY Enumeration

PRL_LICENSE_RESTRICTION_KEY Enumeration
Other Structs

License restriction options

Syntax
typedef enum _PRL_LICENSE_RESTRICTION_KEY {
  PLRK_UNKNOWN = 0,
  PLRK_VM_CPU_LIMIT = 1,
  PLRK_VM_MEMORY_LIMIT = 2,
  PLRK_VM_VTD_AVAILABLE = 3,
  PLRK_ALLOWED_GUEST_OS_VERSIONS = 4,
  PLRK_RUNNING_VMS_LIMIT = 5,
  PLRK_VM_CREATE = 6,
  PLRK_VM_REGISTER = 7,
  PLRK_VM_IMPORT_3RD_PARTY = 8,
  PLRK_VM_CLONE = 9,
  PLRK_VM_CONVERT_TO_TEMPLATE = 10,
  PLRK_VM_CONVERT_FROM_TEMPLATE = 11,
  PLRK_VM_DOWNLOAD = 12,
  PLRK_VM_SUSPEND = 13,
  PLRK_VM_PAUSE = 14,
  PLRK_VM_SNAPSHOT_CREATE = 15,
  PLRK_VM_SNAPSHOT_SWITCH = 16,
  PLRK_VM_SNAPSHOT_DELETE = 17,
  PLRK_VM_SNAPSHOT_TREE = 18,
  PLRK_VM_UNDODISK_FEATURE = 19,
  PLRK_VM_SAFEMODE_FEATURE = 20,
  PLRK_VM_SMARTGUARD_FEATURE = 21,
  PLRK_VM_SHOW_FULLSCREEN = 22,
  PLRK_RUNNING_VMS_LIMIT_PER_USER = 23
} PRL_LICENSE_RESTRICTION_KEY;
File

PrlEnums.h

Members

PLRK_UNKNOWN
NOTE to Parallels Developers:

  • DO NOT CHANGE ANY MEMBER NAME BECAUSE IT USES IN INTERNAL PROTOCOL( ParallelsDomModel.h )

PLRK_VM_CPU_LIMIT
Value is PRL_UINT32
PLRK_VM_MEMORY_LIMIT
Value is PRL_UINT32 in Mb
PLRK_VM_VTD_AVAILABLE
Value is PRL_UINT32
PLRK_ALLOWED_GUEST_OS_VERSIONS
Value is PHT_OPAQUE_TYPE_LIST of Os version values from PrlOses.h
PLRK_RUNNING_VMS_LIMIT
Value is PRL_UINT32 (max count on the host)
PLRK_VM_CREATE
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_REGISTER
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_IMPORT_3RD_PARTY
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_CLONE
Value is PRL_UINT32 - max count of Vm in system after this operation
PLRK_VM_CONVERT_TO_TEMPLATE
Value is PRL_UINT32
PLRK_VM_CONVERT_FROM_TEMPLATE
Value is PRL_UINT32
PLRK_VM_DOWNLOAD
Value is PRL_UINT32
PLRK_VM_SUSPEND
Value is PRL_UINT32
PLRK_VM_PAUSE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_CREATE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_SWITCH
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_DELETE
Value is PRL_UINT32
PLRK_VM_SNAPSHOT_TREE
Value is PRL_UINT32
PLRK_VM_UNDODISK_FEATURE
Value is PRL_UINT32
PLRK_VM_SAFEMODE_FEATURE
Value is PRL_UINT32
PLRK_VM_SMARTGUARD_FEATURE
Value is PRL_UINT32
PLRK_VM_SHOW_FULLSCREEN
Value is PRL_UINT32
PLRK_RUNNING_VMS_LIMIT_PER_USER
Value is PRL_UINT32 Look also at PLRK_RUNNING_VMS_LIMIT

Links
Other Structs


PRL_LICENSE_RESTRICTION_KEY_PTR Type

PRL_LICENSE_RESTRICTION_KEY_PTR Type
Other Types
Syntax
typedef PRL_LICENSE_RESTRICTION_KEY* PRL_LICENSE_RESTRICTION_KEY_PTR;
File

PrlEnums.h

Links
Other Types


PRL_LINUX_EXTENDED_PARTITION Macro

PRL_LINUX_EXTENDED_PARTITION Macro
Other Macros
Syntax
#define PRL_LINUX_EXTENDED_PARTITION 0x85
File

PrlDisk.h

Links
Other Macros


PRL_LINUX_PARTITION_DATA Macro

PRL_LINUX_PARTITION_DATA Macro
Other Macros
Syntax
#define PRL_LINUX_PARTITION_DATA 0x83
File

PrlDisk.h

Links
Other Macros


PRL_LINUX_PARTITION_SWAP Macro

PRL_LINUX_PARTITION_SWAP Macro
Other Macros

Linux partitions

Syntax
#define PRL_LINUX_PARTITION_SWAP 0x82
File

PrlDisk.h

Links
Other Macros


PRL_LOGIN_LOCAL_FLAGS Enumeration

PRL_LOGIN_LOCAL_FLAGS Enumeration
Other Structs

PrlSrv_LoginLocal flags

Syntax
typedef enum _PRL_LOGIN_LOCAL_FLAGS {
  PLLF_LOGIN_WITH_DELAYED_CONNECTION = 1<<(PACF_MAX+1)
} PRL_LOGIN_LOCAL_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_LOGIN_LOCAL_FLAGS_PTR Type

PRL_LOGIN_LOCAL_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_LOGIN_LOCAL_FLAGS* PRL_LOGIN_LOCAL_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_MACOS_BOOT_PARTITION Macro

PRL_MACOS_BOOT_PARTITION Macro
Other Macros
Syntax
#define PRL_MACOS_BOOT_PARTITION 0xAB
File

PrlDisk.h

Links
Other Macros


PRL_MACOS_PARTITION Macro

PRL_MACOS_PARTITION Macro
Other Macros

Mac OS

Syntax
#define PRL_MACOS_PARTITION 0xAF
File

PrlDisk.h

Links
Other Macros


PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration

PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration
Other Structs

Mass storage device interface type

Syntax
typedef enum _PRL_MASS_STORAGE_INTERFACE_TYPE {
  PMS_IDE_DEVICE = 0,
  PMS_SCSI_DEVICE = 1,
  PMS_SATA_DEVICE = 2,
  PMS_UNKNOWN_DEVICE = 255
} PRL_MASS_STORAGE_INTERFACE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_MASS_STORAGE_INTERFACE_TYPE_PTR Type

PRL_MASS_STORAGE_INTERFACE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_MASS_STORAGE_INTERFACE_TYPE* PRL_MASS_STORAGE_INTERFACE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_MAX_VLAN_TAG Macro

PRL_MAX_VLAN_TAG Macro
Other Macros

constant for maximum valid VLAN tag (4095)

Syntax
#define PRL_MAX_VLAN_TAG 0xfff
File

PrlEnums.h

Links
Other Macros


PRL_MESSAGE_TYPE_ENUM Enumeration

PRL_MESSAGE_TYPE_ENUM Enumeration
Other Structs

Message type enumeration.

Syntax
typedef enum _PRL_MESSAGE_TYPE_ENUM {
  PMT_WARNING = 0,
  PMT_INFORMATION = 1,
  PMT_CRITICAL = 2,
  PMT_QUESTION = 3,
  PMT_ANSWER = 4
} PRL_MESSAGE_TYPE_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_MESSAGE_TYPE_ENUM_PTR Type

PRL_MESSAGE_TYPE_ENUM_PTR Type
Other Types
Syntax
typedef PRL_MESSAGE_TYPE_ENUM* PRL_MESSAGE_TYPE_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_METHOD Macro

PRL_METHOD Macro
Other Macros

Default method decoration

Syntax
#define PRL_METHOD( func ) PRL_EXTERN __declspec(dllexport) PRL_RESULT PRL_CALL func
File

PrlTypes.h

Links
Other Macros


PRL_METHOD_DECL Macro

PRL_METHOD_DECL Macro
Other Macros

Default method declaration for the header files

Syntax
#define PRL_METHOD_DECL( version, name, args ) \
    PRL_METHOD( name ) args;    \
    typedef PRL_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
Other Macros


PRL_METHOD_PTR Macro

PRL_METHOD_PTR Macro
Other Macros
Syntax
#define PRL_METHOD_PTR( func_type ) PRL_RESULT ( PRL_CALL * func_type )
File

PrlTypes.h

Links
Other Macros


PRL_MOBILE_ADVANCED_AUTH_MODE Enumeration

PRL_MOBILE_ADVANCED_AUTH_MODE Enumeration
Other Structs

Authorization mode, when mobile client establishing remote access to the host.

Syntax
typedef enum _PRL_MOBILE_ADVANCED_AUTH_MODE {
  PMAA_NO_ADVANCED_AUTH_NEEDED = 0,
  PMAA_USE_SYSTEM_CREDENTIALS = 1
} PRL_MOBILE_ADVANCED_AUTH_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_MOBILE_ADVANCED_AUTH_MODE_PTR Type

PRL_MOBILE_ADVANCED_AUTH_MODE_PTR Type
Other Types
Syntax
typedef PRL_MOBILE_ADVANCED_AUTH_MODE* PRL_MOBILE_ADVANCED_AUTH_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_MOUNT_VIRTUAL_DISK Enumeration

PRL_MOUNT_VIRTUAL_DISK Enumeration
Other Structs

Mount virtual disk flags

Syntax
typedef enum _PRL_MOUNT_VIRTUAL_DISK {
  PMVD_READ_ONLY = 1<<(PACF_MAX+1),
  PMVD_READ_WRITE = 1<<(PACF_MAX+2),
  PMVD_INFO = 1<<(PACF_MAX+3)
} PRL_MOUNT_VIRTUAL_DISK;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_MOUSE_BUTTON Enumeration

PRL_MOUSE_BUTTON Enumeration
Other Structs
Syntax
typedef enum _PRL_MOUSE_BUTTON {
  PMB_NOBUTTON = 0,
  PMB_LEFT_BUTTON = 1<<0,
  PMB_RIGHT_BUTTON = 1<<1,
  PMB_MIDDLE_BUTTON = 1<<2,
  PMB_XBUTTON1 = 1<<3,
  PMB_XBUTTON2 = 1<<4,
  PMB_XBUTTON3 = 1<<5,
  PMB_XBUTTON4 = 1<<6,
  PMB_XBUTTON5 = 1<<7
} PRL_MOUSE_BUTTON;
File

PrlEnums.h

Links
Other Structs


PRL_MOUSE_BUTTON_PTR Type

PRL_MOUSE_BUTTON_PTR Type
Other Types
Syntax
typedef PRL_MOUSE_BUTTON* PRL_MOUSE_BUTTON_PTR;
File

PrlEnums.h

Links
Other Types


PRL_MSDOS_EXTENDED_PARTITION Macro

PRL_MSDOS_EXTENDED_PARTITION Macro
Other Macros
  • Disk partition types

Extended partitions

Syntax
#define PRL_MSDOS_EXTENDED_PARTITION 0x05
File

PrlDisk.h

Links
Other Macros


PRL_NET_ADAPTER_ALREADY_USED Macro

PRL_NET_ADAPTER_ALREADY_USED Macro
Other Macros

Unable to use adapter because it is already used by another virtual network

Syntax
#define PRL_NET_ADAPTER_ALREADY_USED PRL_RESULT_DECLARE_ERROR(4027)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_ADAPTER_EMULATED_TYPE Enumeration

PRL_NET_ADAPTER_EMULATED_TYPE Enumeration
Other Structs

Network adapter emulated type

Syntax
typedef enum _PRL_NET_ADAPTER_EMULATED_TYPE {
  PNA_HOST_ONLY = 0,
  PNA_SHARED = 1,
  PNA_BRIDGED_ETHERNET = 2,
  PNA_DIRECT_ASSIGN = 4,
  PNA_ROUTED = 5
} PRL_NET_ADAPTER_EMULATED_TYPE;
File

PrlEnums.h

Members

PNA_DIRECT_ASSIGN
PNA_CUSTOM= 3 // not currently supported!

Links
Other Structs


PRL_NET_ADAPTER_EMULATED_TYPE_PTR Type

PRL_NET_ADAPTER_EMULATED_TYPE_PTR Type
Other Types
Syntax
typedef PRL_NET_ADAPTER_EMULATED_TYPE* PRL_NET_ADAPTER_EMULATED_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_NET_ADAPTER_NOT_EXIST Macro

PRL_NET_ADAPTER_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_NET_ADAPTER_NOT_EXIST PRL_RESULT_DECLARE_ERROR(4004)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_BIND_FAILED Macro

PRL_NET_BIND_FAILED Macro
Other Macros
Syntax
#define PRL_NET_BIND_FAILED PRL_RESULT_DECLARE_ERROR(4009)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_BYTES_IN_PTRN Macro

PRL_NET_BYTES_IN_PTRN Macro
Other Macros
Syntax
#define PRL_NET_BYTES_IN_PTRN "net.nic#.bytes_in"
File

PrlPerfCounters.h

Links
Other Macros


PRL_NET_BYTES_OUT_PTRN Macro

PRL_NET_BYTES_OUT_PTRN Macro
Other Macros
Syntax
#define PRL_NET_BYTES_OUT_PTRN "net.nic#.bytes_out"
File

PrlPerfCounters.h

Links
Other Macros


PRL_NET_CABLE_DISCONNECTED Macro

PRL_NET_CABLE_DISCONNECTED Macro
Other Macros
Syntax
#define PRL_NET_CABLE_DISCONNECTED PRL_RESULT_DECLARE_ERROR(4010)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_CLASSFUL_TRAFFIC_PTRN Macro

PRL_NET_CLASSFUL_TRAFFIC_PTRN Macro
Other Macros

Classful network traffic counting info.

Syntax
#define PRL_NET_CLASSFUL_TRAFFIC_PTRN "net.classful.traffic"
File

PrlPerfCounters.h

Remarks

Result parameter provides as binary buffer contains structure PRL_STAT_NET_TRAFFIC. See PrlIOStructs.h for more info

Links
Other Macros


PRL_NET_CONNECTION_SHARING_CONFLICT Macro

PRL_NET_CONNECTION_SHARING_CONFLICT Macro
Other Macros
Syntax
#define PRL_NET_CONNECTION_SHARING_CONFLICT PRL_RESULT_DECLARE_ERROR(4015)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME Macro

PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME Macro
Other Macros
Syntax
#define PRL_NET_DUPLICATE_IPPRIVATE_NETWORK_NAME PRL_RESULT_DECLARE_ERROR(4031)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID Macro

PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID Macro
Other Macros
Syntax
#define PRL_NET_DUPLICATE_VIRTUAL_NETWORK_ID PRL_RESULT_DECLARE_ERROR(4024)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_ERR_ADAPTER_CONFIG Macro

PRL_NET_ERR_ADAPTER_CONFIG Macro
Other Macros
Syntax
#define PRL_NET_ERR_ADAPTER_CONFIG PRL_RESULT_DECLARE_ERROR(4005)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER Macro

PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER Macro
Other Macros
Syntax
#define PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER PRL_RESULT_DECLARE_ERROR(4006)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER Macro

PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER Macro
Other Macros
Syntax
#define PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER PRL_RESULT_DECLARE_ERROR(4007)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_ETHLIST_CREATE_ERROR Macro

PRL_NET_ETHLIST_CREATE_ERROR Macro
Other Macros
  • Network

+++ ALIGNED VALUE TO 4000

Syntax
#define PRL_NET_ETHLIST_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(4000)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_INSTALL_FAILED Macro

PRL_NET_INSTALL_FAILED Macro
Other Macros
Syntax
#define PRL_NET_INSTALL_FAILED PRL_RESULT_DECLARE_ERROR(4013)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_INSTALL_TIMEOUT Macro

PRL_NET_INSTALL_TIMEOUT Macro
Other Macros
Syntax
#define PRL_NET_INSTALL_TIMEOUT PRL_RESULT_DECLARE_ERROR(4012)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING Macro

PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING Macro
Other Macros

Operation succeeded, but failed to change Network Adapter IP-address.

Syntax
#define PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING PRL_RESULT_DECLARE_SUCCESS(4022)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST Macro

PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_NET_IPPRIVATE_NETWORK_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(4032)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_IPPRIVATE_NETWORK_INVALID_IP Macro

PRL_NET_IPPRIVATE_NETWORK_INVALID_IP Macro
Other Macros
Syntax
#define PRL_NET_IPPRIVATE_NETWORK_INVALID_IP PRL_RESULT_DECLARE_ERROR(4033)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_OFFMGMT_ERROR Macro

PRL_NET_OFFMGMT_ERROR Macro
Other Macros

Failed to setup offline-management configuration for VM

Syntax
#define PRL_NET_OFFMGMT_ERROR PRL_RESULT_DECLARE_ERROR(4029)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_PKTFILTER_ERROR Macro

PRL_NET_PKTFILTER_ERROR Macro
Other Macros

Failed to setup packet filter for VM Adapter.

Syntax
#define PRL_NET_PKTFILTER_ERROR PRL_RESULT_DECLARE_ERROR(4023)
File

PrlErrorsValues.h

Remarks

Adapter will be disconnected.

Links
Other Macros


PRL_NET_PKTS_IN_PTRN Macro

PRL_NET_PKTS_IN_PTRN Macro
Other Macros
Syntax
#define PRL_NET_PKTS_IN_PTRN "net.nic#.pkts_in"
File

PrlPerfCounters.h

Links
Other Macros


PRL_NET_PKTS_OUT_PTRN Macro

PRL_NET_PKTS_OUT_PTRN Macro
Other Macros
Syntax
#define PRL_NET_PKTS_OUT_PTRN "net.nic#.pkts_out"
File

PrlPerfCounters.h

Links
Other Macros


PRL_NET_PRLNET_OPEN_FAILED Macro

PRL_NET_PRLNET_OPEN_FAILED Macro
Other Macros
Syntax
#define PRL_NET_PRLNET_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(4008)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_RENAME_FAILED Macro

PRL_NET_RENAME_FAILED Macro
Other Macros
Syntax
#define PRL_NET_RENAME_FAILED PRL_RESULT_DECLARE_ERROR(4011)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS Macro

PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS Macro
Other Macros
Syntax
#define PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS PRL_RESULT_DECLARE_ERROR(4016)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_SRV_NOTIFY_ERROR Macro

PRL_NET_SRV_NOTIFY_ERROR Macro
Other Macros
Syntax
#define PRL_NET_SRV_NOTIFY_ERROR PRL_RESULT_DECLARE_ERROR(4003)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_SYSTEM_ERROR Macro

PRL_NET_SYSTEM_ERROR Macro
Other Macros
Syntax
#define PRL_NET_SYSTEM_ERROR PRL_RESULT_DECLARE_ERROR(4001)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_UNINSTALL_FAILED Macro

PRL_NET_UNINSTALL_FAILED Macro
Other Macros
Syntax
#define PRL_NET_UNINSTALL_FAILED PRL_RESULT_DECLARE_ERROR(4014)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS Macro

PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS Macro
Other Macros

Invalid DHCP scope ip addresses format

Syntax
#define PRL_NET_VALID_DHCP_RANGE_WRONG_IP_ADDRS PRL_RESULT_DECLARE_ERROR(4204)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN Macro

PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN Macro
Other Macros

Minimum ip addresses in scope range are 16

Syntax
#define PRL_NET_VALID_DHCP_SCOPE_RANGE_LESS_MIN PRL_RESULT_DECLARE_ERROR(4206)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_FAILURE Macro

PRL_NET_VALID_FAILURE Macro
Other Macros

+++ ALIGNED VALUE TO 4200 +++ Broken network config

Syntax
#define PRL_NET_VALID_FAILURE PRL_RESULT_DECLARE_ERROR(4200)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK Macro

PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK Macro
Other Macros

Mask must match DHCP scope ip addresses

Syntax
#define PRL_NET_VALID_MISMATCH_DHCP_SCOPE_MASK PRL_RESULT_DECLARE_ERROR(4205)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_WRONG_DHCP_IP_ADDR Macro

PRL_NET_VALID_WRONG_DHCP_IP_ADDR Macro
Other Macros

Invalid DHCP ip address format

Syntax
#define PRL_NET_VALID_WRONG_DHCP_IP_ADDR PRL_RESULT_DECLARE_ERROR(4203)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_WRONG_HOST_IP_ADDR Macro

PRL_NET_VALID_WRONG_HOST_IP_ADDR Macro
Other Macros

Invalid host ip address format

Syntax
#define PRL_NET_VALID_WRONG_HOST_IP_ADDR PRL_RESULT_DECLARE_ERROR(4202)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VALID_WRONG_NET_MASK Macro

PRL_NET_VALID_WRONG_NET_MASK Macro
Other Macros

Invalid network mask format

Syntax
#define PRL_NET_VALID_WRONG_NET_MASK PRL_RESULT_DECLARE_ERROR(4201)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS Macro

PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS Macro
Other Macros
Syntax
#define PRL_NET_VIRTUAL_NETWORK_ID_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(4025)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VIRTUAL_NETWORK_NOT_FOUND Macro

PRL_NET_VIRTUAL_NETWORK_NOT_FOUND Macro
Other Macros
Syntax
#define PRL_NET_VIRTUAL_NETWORK_NOT_FOUND PRL_RESULT_DECLARE_ERROR(4026)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS Macro

PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS Macro
Other Macros

Unable to add shared network because it is already exists

Syntax
#define PRL_NET_VIRTUAL_NETWORK_SHARED_EXISTS PRL_RESULT_DECLARE_ERROR(4028)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED Macro

PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED Macro
Other Macros

Shared network prohibited on server

Syntax
#define PRL_NET_VIRTUAL_NETWORK_SHARED_PROHIBITED PRL_RESULT_DECLARE_ERROR(4030)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration

PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration
Other Structs

Virtual Network type.

Syntax
typedef enum _PRL_NET_VIRTUAL_NETWORK_TYPE {
  PVN_BRIDGED_ETHERNET = 0,
  PVN_HOST_ONLY = 1
} PRL_NET_VIRTUAL_NETWORK_TYPE;
File

PrlEnums.h

Remarks

Should match values in LibrariesPrlNetworkingprl_netconfig.h

Links
Other Structs


PRL_NET_VIRTUAL_NETWORK_TYPE_PTR Type

PRL_NET_VIRTUAL_NETWORK_TYPE_PTR Type
Other Types
Syntax
typedef PRL_NET_VIRTUAL_NETWORK_TYPE* PRL_NET_VIRTUAL_NETWORK_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION Macro

PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION Macro
Other Macros
Syntax
#define PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION PRL_RESULT_DECLARE_ERROR(4017)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR Macro
Other Macros

Error while connect VMDevice: Misconfiguration in virtual network.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR PRL_RESULT_DECLARE_ERROR(4020)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED Macro
Other Macros

Error while connect VMDevice: Specified virtual network is disabled.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED PRL_RESULT_DECLARE_ERROR(4021)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER Macro
Other Macros

Error while connect VMDevice: Adapter for virtual network does not exist.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER PRL_RESULT_DECLARE_ERROR(4019)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST Macro
Other Macros

Error while connect VMDevice: network for VM Network Adapter does not exist.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST PRL_RESULT_DECLARE_ERROR(4018)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NET_WINSCM_OPEN_ERROR Macro

PRL_NET_WINSCM_OPEN_ERROR Macro
Other Macros
Syntax
#define PRL_NET_WINSCM_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(4002)
File

PrlErrorsValues.h

Links
Other Macros


PRL_NETFILTER_MODE Enumeration

PRL_NETFILTER_MODE Enumeration
Other Structs

Netfilter modes list

Syntax
typedef enum _PRL_NETFILTER_MODE {
  PCNM_NOT_SET = 0,
  PCNM_DISABLED = 1,
  PCNM_STATELESS = 2,
  PCNM_STATEFUL = 3,
  PCNM_FULL = 4
} PRL_NETFILTER_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_NETFILTER_MODE_PTR Type

PRL_NETFILTER_MODE_PTR Type
Other Types
Syntax
typedef PRL_NETFILTER_MODE* PRL_NETFILTER_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_NULL Macro

PRL_NULL Macro
Other Macros

NULL (invalid) handle

Syntax
#define PRL_NULL ( (PRL_VOID_PTR) 0 )
File

PrlTypes.h

Links
Other Macros


PRL_ONLINE_COMPACT_MODE Enumeration

PRL_ONLINE_COMPACT_MODE Enumeration
Other Structs

Online compact mode for virtual machine disks

Syntax
typedef enum _PRL_ONLINE_COMPACT_MODE {
  POCM_DISABLED = 0,
  POCM_ENABLED = 1,
  POCM_AUTO = 2
} PRL_ONLINE_COMPACT_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_ONLINE_COMPACT_MODE_PTR Type

PRL_ONLINE_COMPACT_MODE_PTR Type
Other Types
Syntax
typedef PRL_ONLINE_COMPACT_MODE* PRL_ONLINE_COMPACT_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_OPTIMIZE_MODIFIERS_MODE Enumeration

PRL_OPTIMIZE_MODIFIERS_MODE Enumeration
Other Structs

Determines the mode of modifiers handling inside the guest

Syntax
typedef enum _PRL_OPTIMIZE_MODIFIERS_MODE {
  POD_STANDARD = 0,
  POD_OPTIMIZE_FOR_GAMES = 1,
  POD_OPTIMIZE_FOR_ACCESSIBILITY = 2
} PRL_OPTIMIZE_MODIFIERS_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_OPTIMIZE_MODIFIERS_MODE_PTR Type

PRL_OPTIMIZE_MODIFIERS_MODE_PTR Type
Other Types
Syntax
typedef PRL_OPTIMIZE_MODIFIERS_MODE* PRL_OPTIMIZE_MODIFIERS_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PARAM_FIELD_DATA_TYPE Enumeration

PRL_PARAM_FIELD_DATA_TYPE Enumeration
Other Structs

Event parameters fields types

Syntax
typedef enum _PRL_PARAM_FIELD_DATA_TYPE {
  PFD_UINT32 = 0,
  PFD_STRING = 1,
  PFD_INT32 = 2,
  PFD_CDATA = 3,
  PFD_BOOLEAN = 4,
  PFD_ENTITY = 5,
  PFD_ENUMERATION = 6,
  PFD_INT64 = 7,
  PFD_UINT64 = 8,
  PFD_BINARY = 9,
  PFD_UNKNOWN = 0xFF
} PRL_PARAM_FIELD_DATA_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_PARAM_FIELD_DATA_TYPE_PTR Type

PRL_PARAM_FIELD_DATA_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PARAM_FIELD_DATA_TYPE* PRL_PARAM_FIELD_DATA_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PORT_FORWARDING_TYPE Enumeration

PRL_PORT_FORWARDING_TYPE Enumeration
Other Structs

Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding

Syntax
typedef enum _PRL_PORT_FORWARDING_TYPE {
  PPF_TCP = 0,
  PPF_UDP = 1
} PRL_PORT_FORWARDING_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_PORT_FORWARDING_TYPE_PTR Type

PRL_PORT_FORWARDING_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PORT_FORWARDING_TYPE* PRL_PORT_FORWARDING_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PRINTER_INTERFACE_TYPE Enumeration

PRL_PRINTER_INTERFACE_TYPE Enumeration
Other Structs

Printer device interface type

Syntax
typedef enum _PRL_PRINTER_INTERFACE_TYPE {
  PRN_LPT_DEVICE = 0,
  PRN_USB_DEVICE = 1,
  PRN_UNKNOWN_DEVICE = 255
} PRL_PRINTER_INTERFACE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_PRINTER_INTERFACE_TYPE_PTR Type

PRL_PRINTER_INTERFACE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PRINTER_INTERFACE_TYPE* PRL_PRINTER_INTERFACE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PRIVATE_EVENT_TYPE Enumeration

PRL_PRIVATE_EVENT_TYPE Enumeration
Other Structs

Private event types.

Syntax
typedef enum _PRL_PRIVATE_EVENT_TYPE {
  PET_IO_DISPLAY_PALETTE_CHANGED = 200000,
  PET_IO_TOOLS_TIS_QUERY = 200001,
  PET_IO_SCREEN_UPDATED = 200002,
  PET_IO_AUTH_RESPONSE = 200003,
  PET_IO_ATTACH_RESPONSE = 200004,
  PET_IO_ENCODING_RESPONSE = 200005,
  PET_IO_MEMORY_INFO = 200006,
  PET_IO_SCREEN_CAPTURED_BUFFER = 200007,
  PET_IO_TOOLS_TIS_SUBSCRIBE = 200008,
  PET_IO_TOOLS_TIS_UNSUBSCRIBE = 200009,
  PET_IO_CLI_AUTHENTICATE_SESSION = 200100,
  PET_IO_CLI_ATTACH_TO_VM = 200101,
  PET_IO_CLI_ENCODING_REQUEST = 200102,
  PET_IO_CLI_SCREEN_WATCH_UPDATES = 200103,
  PET_IO_CLI_SCREEN_CAPTURE_BUFFER = 200104,
  PET_IO_CLI_SCREEN_SIZE = 200105,
  PET_IO_CLI_KEYBOARD_SCANCODE = 200106,
  PET_IO_CLI_MOUSE_SETPOS = 200107,
  PET_IO_CLI_MOUSE_MOVE = 200108,
  PET_IO_CLI_MOUSE_NEED_CURSOR = 200109,
  PET_IO_CLI_GRACEFUL_SHUTDOWN = 200110,
  PET_IO_CLI_SCREEN_SET_SURFACE = 200111,
  PET_IO_CLI_REMOTE_COMMAND = 200112,
  PET_IO_CLI_TOOLS_UTILITY_COMMAND = 200113,
  PET_IO_CLI_TOOLS_TIS_QUERY = 200114,
  PET_IO_CLI_TOOLS_CLIPBOARD_DATA = 200115,
  PET_IO_CLI_TOOLS_SIA_DATA = 200116,
  PET_IO_CLI_TOOLS_VMCTG_COMMAND = 200117,
  PET_IO_CLI_TOOLS_GENERAL_COMMAND = 200118,
  PET_IO_CLI_TOOLS_EMPTY_RECYCLE_BIN = 200119,
  PET_IO_CLI_TOOLS_SET_TASKBAR_VISIBILITY = 200120,
  PET_IO_CLI_TOOLS_TOGGLE_DESKTOP = 200121,
  PET_IO_CLI_TOOLS_MOVE_TASKBAR = 200122,
  PET_IO_CLI_TOOLS_SHOW_RECYCLE_BIN = 200123,
  PET_IO_CLI_TOOLS_NOTIFY_COHERENCE_STATE = 200124,
  PET_IO_CLI_TOOLS_ADJUST_WORKING_AREA = 200125,
  PET_IO_CLI_KEYBOARD_KEY = 200126,
  PET_IO_CLI_TOOLS_UIEMU = 200127,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_START = 200128,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_STREAM_STOP = 200129,
  DEPRECATED_PET_IO_CLI_AUDIO_OUTPUT_SET_ENCODING = 200130,
  PET_IO_CLI_CVSRC_CONNECT = 200131,
  PET_IO_CLI_CVSRC_DISCONNECT = 200132,
  PET_IO_CLI_AUTHENTICATE_EXEC_SESSION = 200133,
  PET_IO_CLI_SWITCH_SLIDING_MOUSE = 200134,
  PET_IO_CLI_SSO_SET_CREDENTIALS = 200135,
  PET_IO_CLI_SSO_SET_CREDENTIALS_ASYNC = 200136,
  PET_IO_CLI_SSO_LOCKED = 200137,
  PET_IO_CLI_SSO_UNLOCKED = 200138,
  PET_IO_CLI_DPI_SCREEN_SIZE = 200139,
  PET_IO_CLI_TOOLS_SET_INDENTS = 200140,
  PET_IO_CLI_AUDIO_RECORDING_STREAM_START = 200141,
  PET_IO_CLI_AUDIO_RECORDING_STREAM_STOP = 200142,
  PET_IO_CLI_AUDIO_PLAYOUT_STREAM_START = 200143,
  PET_IO_CLI_AUDIO_PLAYOUT_STREAM_STOP = 200144,
  PET_IO_CLI_TOOLS_OPEN_FILE_BROWSER = 200145,
  PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS = 200146,
  PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS_RESPONSE = 200147,
  PET_IO_CLI_SET_AUDIO_SWITCH_SETTINGS = 200148,
  PET_IO_STDIN_PORTION = 200200,
  PET_IO_STDOUT_PORTION = 200201,
  PET_IO_STDERR_PORTION = 200202,
  PET_IO_READY_TO_ACCEPT_STDOUT_STDERR_PKGS = 200203,
  PET_IO_FIN_TO_TRANSMIT_STDOUT_STDERR = 200204,
  PET_IO_CLIENT_PROCESSED_ALL_DESCS_DATA = 200205,
  PET_IO_TTY_SETTINGS_REQUIRED = 200206,
  PET_IO_TTY_SETTINGS_PROVIDED = 200207,
  PET_IO_STDIN_WAS_CLOSED = 200208,
  PET_IT_RECONFIG_BOOTCAMP_START = 200300,
  PET_IT_VALIDATE_BOOTCAMP_START = 200301,
  PET_IT_CONVERT_TO_OLD_START = 200302,
  PET_IT_CONVERT_TO_CURRENT_START = 200303,
  PET_IT_RECONFIG_START = 200304,
  PET_IT_MERGE_SNAPSHOTS_START = 200305,
  PET_IT_MAKE_PLAIN_START = 200306,
  PET_IT_MAKE_EXPANDING_START = 200307,
  PET_IT_MAKE_SPLIT_START = 200308,
  PET_IT_MAKE_NON_SPLIT_START = 200309,
  PET_IT_GET_RESIZE_INFORMATION_START = 200310,
  PET_IT_INCREASE_LAST_VOLUME_START = 200311,
  PET_IT_RESIZING_START = 200312,
  PET_IT_DECREASING_START = 200313,
  PET_IT_COMPACTING_START = 200314,
  PET_IT_FIX_CONSISTENCY_START = 200315,
  PET_IT_CONVERT_TO_EXTEND_START = 200316,
  PET_DESKCTL_SESSION_AUTH = 200400,
  PET_DESKCTL_SESSION_AUTH_FIN = 200401,
  PET_DESKCTL_ATTACH = 200402,
  PET_DESKCTL_ATTACH_FIN = 200403,
  PET_DESKCTL_LOCAL_AUTH = 200404,
  PET_DESKCTL_LOCAL_AUTH_QUEST = 200405,
  PET_DESKCTL_LOCAL_AUTH_ANSWER = 200406,
  PET_DESKCTL_LOCAL_AUTH_FIN = 200407,
  PET_DESKCTL_ACCEPT_CLIENTS = 200408,
  PET_DESKCTL_REJECT_CLIENTS = 200409,
  PET_DESKCTL_CONFIG = 200410,
  PET_DESKCTL_CONFIG_QUERY = 200411,
  PET_DESKCTL_SEND_SAS = 200412,
  PET_DESKCTL_STATUS_CHANGE = 200413,
  PET_DESKCTL_SHARES_SHARE = 200414,
  PET_DESKCTL_SHARES_UNSHARE = 200415,
  PET_DESKCTL_SHARES_ENUMERATE = 200416,
  PET_IO_DISCONNECT_WITH_REASON = 200500,
  PET_IO_DISPLAY_RESOLUTION_SET = 200510,
  PET_VIDEO_STREAM_START = 200600,
  PET_VIDEO_STREAM_CLOSE = 200601,
  PET_VIDEO_STREAM_FORMAT = 200602,
  PET_VIDEO_STREAM_DATA = 200603,
  PET_VIDEO_STREAM_CLOSED = 200604,
  PET_VIDEO_STREAM_ACK_FRAME = 200605,
  PET_VIDEO_STREAM_OPEN = 200606,
  PET_VIDEO_DATA_CHANNEL_CTL = 200607,
  PET_VIDEO_STREAM_STOP = 200608,
  PET_IO_PTM_PROTOCOL = 200700,
  PET_IO_IOSERVICE_CHANNELS_PROTOCOL = 200800
} PRL_PRIVATE_EVENT_TYPE;
File

PrlEventsValues.h

Members

PET_IO_DISPLAY_PALETTE_CHANGED
BASE VALUE SET TO 200000
PET_IO_CLI_AUTHENTICATE_SESSION
ALIGNED VALUE TO 200100
PET_IO_STDIN_PORTION
ALIGNED VALUE TO 200200
PET_IT_RECONFIG_BOOTCAMP_START
ALIGNED VALUE TO 200300
PET_DESKCTL_SESSION_AUTH
ALIGNED VALUE TO 200400
PET_IO_DISCONNECT_WITH_REASON
ALIGNED VALUE TO 200500
PET_IO_DISPLAY_RESOLUTION_SET
ALIGNED VALUE TO 200510
PET_VIDEO_STREAM_START
ALIGNED VALUE TO 200600
PET_IO_PTM_PROTOCOL
ALIGNED VALUE TO 200700
PET_IO_IOSERVICE_CHANNELS_PROTOCOL
ALIGNED VALUE TO 200800

Remarks

Is NOT a part of public API.

Links
Other Structs


PRL_PRIVATE_EVENT_TYPE_PTR Type

PRL_PRIVATE_EVENT_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PRIVATE_EVENT_TYPE* PRL_PRIVATE_EVENT_TYPE_PTR;
File

PrlEventsValues.h

Links
Other Types


PRL_PRIVILEGED_GUEST_OS_SESSION Macro

PRL_PRIVILEGED_GUEST_OS_SESSION Macro
Other Macros

Guest OS sessions types and constants declarations

Syntax
#define PRL_PRIVILEGED_GUEST_OS_SESSION "531582ac-3dce-446f-8c26-dd7e3384dcf4"
File

PrlEnums.h

Links
Other Macros


PRL_PROBLEM_REPORT_FLAGS Enumeration

PRL_PROBLEM_REPORT_FLAGS Enumeration
Other Structs

Parallels problem report flags functionality: PPRF_ADD_CLIENT_PART : specifies to add client information to problem report PPRF_ADD_SERVER_PART : specifies to add server information to problem report PPRF_DO_NOT_CREATE_HOST_SCREENSHOT : specifies do not create and add host screenshot to generating problem report

Syntax
typedef enum _PRL_PROBLEM_REPORT_FLAGS {
  PPRF_ADD_CLIENT_PART = 1<<(PACF_MAX+1),
  PPRF_ADD_SERVER_PART = 1<<(PACF_MAX+2),
  PPRF_DO_NOT_CREATE_HOST_SCREENSHOT = 1<<(PACF_MAX+3)
} PRL_PROBLEM_REPORT_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_PROBLEM_REPORT_FLAGS_PTR Type

PRL_PROBLEM_REPORT_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_PROBLEM_REPORT_FLAGS* PRL_PROBLEM_REPORT_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_PROBLEM_REPORT_REASON Enumeration

PRL_PROBLEM_REPORT_REASON Enumeration
Other Structs

Problem report reason enumeration

Syntax
typedef enum _PRL_PROBLEM_REPORT_REASON {
  PRR_UNKNOWN = 0,
  PRR_BOOT_CAMP = 1,
  PRR_HANG_LOCKUP = 2,
  PRR_KEYBOARD = 3,
  PRR_NETWORK = 4,
  PRR_PARALLELS_TOOLS = 5,
  PRR_PERFORMANCE = 6,
  PRR_PRODUCT_REGISTRATION = 7,
  PRR_SNAPSHOTS = 8,
  PRR_SOUND = 9,
  PRR_SUPPORT_REQUEST = 10,
  PRR_USB = 11,
  PRR_VIDEO_3D_GRAPHICS = 12,
  PRR_OTHER = 13,
  PRR_BACKUP = 14,
  PRR_MIGRATION = 15,
  PRR_CONNECTION = 16,
  PRR_LAST = PRR_CONNECTION
} PRL_PROBLEM_REPORT_REASON;
File

PrlEnums.h

Members

PRR_LAST
Should equals to the last item

Links
Other Structs


PRL_PROBLEM_REPORT_REASON_PTR Type

PRL_PROBLEM_REPORT_REASON_PTR Type
Other Types
Syntax
typedef PRL_PROBLEM_REPORT_REASON* PRL_PROBLEM_REPORT_REASON_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PROBLEM_REPORT_SCHEME Enumeration

PRL_PROBLEM_REPORT_SCHEME Enumeration
Other Structs

Problem report scheme enumaration

Syntax
typedef enum _PRL_PROBLEM_REPORT_SCHEME {
  PRS_OLD_XML_BASED = 0,
  PRS_NEW_PACKED = 1
} PRL_PROBLEM_REPORT_SCHEME;
File

PrlEnums.h

Links
Other Structs


PRL_PROBLEM_REPORT_SCHEME_PTR Type

PRL_PROBLEM_REPORT_SCHEME_PTR Type
Other Types
Syntax
typedef PRL_PROBLEM_REPORT_SCHEME* PRL_PROBLEM_REPORT_SCHEME_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PROBLEM_REPORT_TYPE Enumeration

PRL_PROBLEM_REPORT_TYPE Enumeration
Other Structs

Problem report type enumeration

Syntax
typedef enum _PRL_PROBLEM_REPORT_TYPE {
  PRT_REPORT_TYPE_UNDEFINED = 0,
  PRT_AUTOMATIC_VM_GENERATED_REPORT = 1,
  PRT_AUTOMATIC_DISPATCHER_GENERATED_REPORT = 2,
  PRT_USER_DEFINED_ON_STOPPED_VM_REPORT = 3,
  PRT_USER_DEFINED_ON_RUNNING_VM_REPORT = 4,
  PRT_USER_DEFINED_ON_CONNECTED_SERVER = 5,
  PRT_USER_DEFINED_ON_DISCONNECTED_SERVER = 6,
  PRT_USER_DEFINED_ON_NOT_RESPONDING_VM_REPORT = 7,
  PRT_AUTOMATIC_DETECTED_REPORT = 8,
  PRT_AUTOMATIC_STATISTICS_REPORT = 9,
  PRT_AUTOMATIC_INSTALLED_SOFTWARE_REPORT = 10,
  PRT_AUTOMATIC_VZ_STATISTICS_REPORT = 11,
  PRT_AUTOMATIC_UTW7AGENT_PRE_MIGRATION = 12,
  PRT_AUTOMATIC_UTW7AGENT_POST_MIGRATION = 13,
  PRT_AUTOMATIC_TRANSPORTER_REPORT = 14,
  PRT_USER_DEFINED_TRANSPORTER_REPORT = 15,
  PRT_AUTOMATIC_GUEST_GENERATED_REPORT = 16,
  PRT_USER_DEFINED_ON_CONTAINER_REPORT = 17,
  PRT_USER_DEFINED_ON_MOBILE_REPORT = 18,
  PRT_USER_DEFINED_ON_MOBILE_FEEDBACK_REPORT = 19,
  PRT_LAST = PRT_USER_DEFINED_ON_MOBILE_FEEDBACK_REPORT
} PRL_PROBLEM_REPORT_TYPE;
File

PrlEnums.h

Members

PRT_LAST
Should equals to the last item

Links
Other Structs


PRL_PROBLEM_REPORT_TYPE_PTR Type

PRL_PROBLEM_REPORT_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PROBLEM_REPORT_TYPE* PRL_PROBLEM_REPORT_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PROCESS_STATE_TYPE Enumeration

PRL_PROCESS_STATE_TYPE Enumeration
Other Structs

Process state element

Syntax
typedef enum _PRL_PROCESS_STATE_TYPE {
  PPS_PROC_SLEEP = 0,
  PPS_PROC_RUN = 1,
  PPS_PROC_STOP = 2,
  PPS_PROC_ZOMBIE = 3,
  PPS_PROC_IDLE = 4
} PRL_PROCESS_STATE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_PROCESS_STATE_TYPE_PTR Type

PRL_PROCESS_STATE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_PROCESS_STATE_TYPE* PRL_PROCESS_STATE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PRODUCT_ENUM Enumeration

PRL_PRODUCT_ENUM Enumeration
Other Structs

Parallels license products enumeration.

Syntax
typedef enum _PRL_PRODUCT_ENUM {
  PRL_PRODUCT_ANY = 0,
  PRL_PRODUCT_DESKTOP = 1,
  PRL_PRODUCT_SERVER = 2,
  PRL_PRODUCT_WORKSTATION = 3,
  PRL_PRODUCT_STM = 4,
  PRL_PRODUCT_PLAYER = 5,
  PRL_PRODUCT_DESKTOP_WL = 6,
  PRL_PRODUCT_DESKTOP_PDE = 7
} PRL_PRODUCT_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_PRODUCT_ENUM_PTR Type

PRL_PRODUCT_ENUM_PTR Type
Other Types
Syntax
typedef PRL_PRODUCT_ENUM* PRL_PRODUCT_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PROXY_CLIENT_INFO Structure

PRL_PROXY_CLIENT_INFO Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_CLIENT_INFO {
  PRL_UINT32 structSize;
  PRL_CHAR clientOptions[64];
  PRL_UINT8 customerSupportUUID[16];
  PRL_CHAR managerURL[256];
} PRL_PROXY_CLIENT_INFO;
File

PrlIoStructs.h

Members

structSize
< Should be filled by the caller with actual structure size
clientOptions
< Reserved
customerSupportUUID
< Reserved
managerURL
< Reserved

Links
Other Structs


PRL_PROXY_CLIENT_INFO_PTR Type

PRL_PROXY_CLIENT_INFO_PTR Type
Other Types
Syntax
typedef PRL_PROXY_CLIENT_INFO* PRL_PROXY_CLIENT_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_CONNECTION_STATUS Enumeration

PRL_PROXY_CONNECTION_STATUS Enumeration
Other Structs

Proxy connection status

Syntax
typedef enum _PRL_PROXY_CONNECTION_STATUS {
  PCS_DISCONNECTED = 0,
  PCS_CONNECTED = 1,
  PCS_CONNECTING = 2
} PRL_PROXY_CONNECTION_STATUS;
File

PrlEnums.h

Links
Other Structs


PRL_PROXY_CONNECTION_STATUS_PTR Type

PRL_PROXY_CONNECTION_STATUS_PTR Type
Other Types
Syntax
typedef PRL_PROXY_CONNECTION_STATUS* PRL_PROXY_CONNECTION_STATUS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_PROXY_DATA_KEY Structure

PRL_PROXY_DATA_KEY Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_DATA_KEY {
  PRL_STR dataKey;
  PRL_INT32 dataVersion;
  struct _PRL_PROXY_DATA_KEY * next;
} PRL_PROXY_DATA_KEY;
File

PrlIoStructs.h

Members

dataKey
< Data identifier
dataVersion
< Data version
next
< Pointer to the next element

Links
Other Structs


PRL_PROXY_DATA_KEY_PTR Type

PRL_PROXY_DATA_KEY_PTR Type
Other Types
Syntax
typedef PRL_PROXY_DATA_KEY* PRL_PROXY_DATA_KEY_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_GEO_INFO Structure

PRL_PROXY_GEO_INFO Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_GEO_INFO {
  PRL_CHAR countryName[64];
  PRL_CHAR countryCode[3];
  PRL_CHAR region[3];
  PRL_CHAR city[64];
  PRL_CHAR postalCode[10];
} PRL_PROXY_GEO_INFO;
File

PrlIoStructs.h

Links
Other Structs


PRL_PROXY_GEO_INFO_PTR Type

PRL_PROXY_GEO_INFO_PTR Type
Other Types
Syntax
typedef PRL_PROXY_GEO_INFO* PRL_PROXY_GEO_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_HOST_INFO Structure

PRL_PROXY_HOST_INFO Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_HOST_INFO {
  PRL_UINT8 hostUUID[16];
  PRL_CHAR brokerAddresses[PRL_PROXY_MAX_HOSTS][64];
  PRL_INT32 brokerAddressesSz;
  PRL_PROXY_REGISTRATION_INFO info;
} PRL_PROXY_HOST_INFO;
File

PrlIoStructs.h

Members

hostUUID
< Proxy host uuid
brokerAddresses
< Broker addresses to which connection should be established
brokerAddressesSz
< Broker addresses size
info
< Host registration info

Links
Other Structs


PRL_PROXY_HOST_INFO_EXT Structure

PRL_PROXY_HOST_INFO_EXT Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_HOST_INFO_EXT {
  PRL_PROXY_HOST_INFO hostInfo;
  PRL_BOOL isOnline;
  PRL_PROXY_GEO_INFO_PTR geoInfo;
  struct _PRL_PROXY_HOST_INFO_EXT * next;
} PRL_PROXY_HOST_INFO_EXT;
File

PrlIoStructs.h

Members

isOnline
Sign which specifies whether appropriate host online

Links
Other Structs


PRL_PROXY_HOST_INFO_EXT_PTR Type

PRL_PROXY_HOST_INFO_EXT_PTR Type
Other Types
Syntax
typedef PRL_PROXY_HOST_INFO_EXT* PRL_PROXY_HOST_INFO_EXT_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_HOST_INFO_PTR Type

PRL_PROXY_HOST_INFO_PTR Type
Other Types
Syntax
typedef PRL_PROXY_HOST_INFO* PRL_PROXY_HOST_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_MAX_HOSTS Macro

PRL_PROXY_MAX_HOSTS Macro
Other Macros
Syntax
#define PRL_PROXY_MAX_HOSTS 16
File

PrlIoStructs.h

Links
Other Macros


PRL_PROXY_REGISTRATION_INFO Structure

PRL_PROXY_REGISTRATION_INFO Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_REGISTRATION_INFO {
  PRL_CHAR hostAddresses[PRL_PROXY_MAX_HOSTS][64];
  PRL_INT32 hostAddressesSz;
  PRL_CHAR hostName[64];
  PRL_UINT8 appUUID[16];
  PRL_CHAR appVersion[32];
  PRL_CHAR hostOptions[33];
  PRL_CHAR hostOsName[63];
  PRL_CHAR isoTimestamp[32];
} PRL_PROXY_REGISTRATION_INFO;
File

PrlIoStructs.h

Members

hostAddresses
< Host addresses which host listens to
hostAddressesSz
< Size of host addresses
hostName
< Short host name
appUUID
< Application uuid
appVersion
< Application version
hostOptions
< Using for host icon hash transport
hostOsName
< Reserved
isoTimestamp
< Reserved

Links
Other Structs


PRL_PROXY_REGISTRATION_INFO_PTR Type

PRL_PROXY_REGISTRATION_INFO_PTR Type
Other Types
Syntax
typedef PRL_PROXY_REGISTRATION_INFO* PRL_PROXY_REGISTRATION_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PROXY_USER_DATA Structure

PRL_PROXY_USER_DATA Structure
Other Structs
Syntax
typedef struct _PRL_PROXY_USER_DATA {
  PRL_STR dataKey;
  PRL_INT32 dataVersion;
  PRL_VOID_PTR data;
  PRL_UINT32 dataSize;
  struct _PRL_PROXY_USER_DATA * next;
} PRL_PROXY_USER_DATA;
File

PrlIoStructs.h

Members

dataKey
< Data identifier
dataVersion
< Data version
data
< Pointer to the data buffer
dataSize
< Data size
next
< Pointer to the next element

Links
Other Structs


PRL_PROXY_USER_DATA_PTR Type

PRL_PROXY_USER_DATA_PTR Type
Other Types
Syntax
typedef PRL_PROXY_USER_DATA* PRL_PROXY_USER_DATA_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_PTM_CONST_OBJECT_PTR Type

PRL_PTM_CONST_OBJECT_PTR Type
Other Types
Syntax
typedef const PRL_PTM_OBJECT* PRL_PTM_CONST_OBJECT_PTR;
File

PrlApiPtmTypes.h

Links
Other Types


PRL_PTM_CONST_PROPERTY_PTR Type

PRL_PTM_CONST_PROPERTY_PTR Type
Other Types
Syntax
typedef const PRL_PTM_PROPERTY* PRL_PTM_CONST_PROPERTY_PTR;
File

PrlApiPtmTypes.h

Links
Other Types


PRL_PTM_DECLARE_PROPERTY Macro

PRL_PTM_DECLARE_PROPERTY Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_DECLARE_PROPERTY( structName, fieldType, fieldName, fieldAccess, fieldId ) \
    PTM_##structName##_##fieldType##_##fieldName = \
      __PTM_TYPE_##fieldType | __PTM_ACCESS_##fieldAccess | (fieldId)
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_INIT_PROPERTY Macro

PRL_PTM_INIT_PROPERTY Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_INIT_PROPERTY( propid, valuePtr, valueSize ) \
    { (PRL_UINT32) (propid), (PRL_VOID_PTR) (valuePtr), (PRL_UINT32) (valueSize) }
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS Macro

PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS Macro
PRL_PTM Macros

Objects Section

Syntax
#define PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS "/applications"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_CHANNELS Macro

PRL_PTM_NAMESPACE_APPMNG_CHANNELS Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_CHANNELS "/ch"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM Macro

PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM "/fs"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS Macro

PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM_ROOTS \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/roots"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_IMAGES Macro

PRL_PTM_NAMESPACE_APPMNG_IMAGES Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_IMAGES "/images"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_OPERATIONS Macro

PRL_PTM_NAMESPACE_APPMNG_OPERATIONS Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_OPERATIONS "/operations"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS Macro

PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_PRIVATE_CHANNELS \
    PRL_PTM_NAMESPACE_PRIVATE \
    PRL_PTM_NAMESPACE_APPMNG_CHANNELS
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM Macro

PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_PRIVATE_FILESYSTEM \
    PRL_PTM_NAMESPACE_PRIVATE \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES Macro

PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_PRIVATE_SHARES \
    PRL_PTM_NAMESPACE_PRIVATE \
    PRL_PTM_NAMESPACE_APPMNG_SHARES
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_PROCESSES Macro

PRL_PTM_NAMESPACE_APPMNG_PROCESSES Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_PROCESSES "/processes"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_APPLICATIONS_CLOSE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_APPLICATIONS \
    "/close"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CLOSECHANNEL \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/closechannel"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CONTROLCHANNEL \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/chctl"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_COPY \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/copy"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_CREATE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/create"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_DELETE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/delete"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_GETICON \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/geticon"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_INFO \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/info"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_MOUNT \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/mount"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPEN \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/open"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_OPENCHANNEL \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/openchannel"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_RENAME \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/rename"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SEARCH \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/search"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/share"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_MOUNT \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/shmount"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_SHARES_UNMOUNT \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/shumount"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNMOUNT \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/unmount"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_FILESYSTEM_UNSHARE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_FILESYSTEM \
    "/unshare"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON Macro
PRL_PTM Macros

RPC section

Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_IMAGES_GETICON \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_IMAGES \
    "/geticon"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_OPERATIONS_CONTROL \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_OPERATIONS \
    "/control"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_CLOSE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_PROCESSES \
    "/close"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_PROCESSES_KILL \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_PROCESSES \
    "/kill"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_ACTIVATE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_WINDOWS \
    "/activate"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_CLOSE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_WINDOWS \
    "/close"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT Macro

PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_RPC_WINDOWS_SCREENSHOT \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_APPMNG_WINDOWS \
    "/screenshot"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_APPMNG_SHARES Macro

PRL_PTM_NAMESPACE_APPMNG_SHARES Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_APPMNG_SHARES "/shares"
File

PrlApiAppManagerEnums.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP Macro

PRL_PTM_NAMESPACE_DESKTOP Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP "/desktop"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP_CLIENT Macro

PRL_PTM_NAMESPACE_DESKTOP_CLIENT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP_CLIENT PRL_PTM_NAMESPACE_DESKTOP "/client"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP_MENU Macro

PRL_PTM_NAMESPACE_DESKTOP_MENU Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP_MENU PRL_PTM_NAMESPACE_DESKTOP "/menu"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP_SESSION Macro

PRL_PTM_NAMESPACE_DESKTOP_SESSION Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP_SESSION PRL_PTM_NAMESPACE_DESKTOP "/session"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP_UI Macro

PRL_PTM_NAMESPACE_DESKTOP_UI Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP_UI PRL_PTM_NAMESPACE_DESKTOP "/ui"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES Macro

PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_DESKTOP_VIDEOMODES PRL_PTM_NAMESPACE_DESKTOP "/videomodes"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_HINTING Macro

PRL_PTM_NAMESPACE_HINTING Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_HINTING \
    "/hinting"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_HINTING_SELECTION Macro

PRL_PTM_NAMESPACE_HINTING_SELECTION Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_HINTING_SELECTION \
    PRL_PTM_NAMESPACE_HINTING "/selection"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_INPUT Macro

PRL_PTM_NAMESPACE_INPUT Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_INPUT "/input"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD Macro

PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_INPUT_AUTOKEYBOARD "/input/autokeyboard"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_INPUT_CARET Macro

PRL_PTM_NAMESPACE_INPUT_CARET Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_INPUT_CARET "/input/caret"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_INPUT_CURSOR Macro

PRL_PTM_NAMESPACE_INPUT_CURSOR Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_INPUT_CURSOR "/input/cursor"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_INPUT_INFO Macro

PRL_PTM_NAMESPACE_INPUT_INFO Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_INPUT_INFO "/input/info"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_PRIVATE Macro

PRL_PTM_NAMESPACE_PRIVATE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_PRIVATE "/~"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC Macro

PRL_PTM_NAMESPACE_RPC Macro
PRL_PTM Macros

namespace definitions

Syntax
#define PRL_PTM_NAMESPACE_RPC "/rpc"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_CANCEL Macro

PRL_PTM_NAMESPACE_RPC_CANCEL Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_CANCEL \
    PRL_PTM_NAMESPACE_RPC "/cancel"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER Macro

PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_REGISTER \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_DESKTOP_CLIENT \
    "/register"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE Macro

PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_DESKTOP_CLIENT_SEND_STATE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_DESKTOP_CLIENT  \
    "/send_state"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW Macro

PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_DESKTOP_MENU_SHOW \
PRL_PTM_NAMESPACE_RPC \
PRL_PTM_NAMESPACE_DESKTOP_MENU \
"/show"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE Macro

PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_DESKTOP_UI_MSOFFICE_TOUCHMODE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_DESKTOP_UI \
    "/msoffice_touchmode"
File

PrlApiDesktopParameters.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_HINTING_CARET Macro

PRL_PTM_NAMESPACE_RPC_HINTING_CARET Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_HINTING_CARET \
    PRL_PTM_NAMESPACE_RPC PRL_PTM_NAMESPACE_HINTING "/caret"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP Macro

PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_HINTING_MAKEUP \
    PRL_PTM_NAMESPACE_RPC PRL_PTM_NAMESPACE_HINTING "/makeup"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON Macro

PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_HINTING_RIBBON \
    PRL_PTM_NAMESPACE_RPC PRL_PTM_NAMESPACE_HINTING "/ribbon"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION Macro

PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_HINTING_SELECTION \
    PRL_PTM_NAMESPACE_RPC PRL_PTM_NAMESPACE_HINTING "/selection"
File

PrlApiHinting.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE Macro

PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_INPUT_CURSOR_GETIMAGE \
    PRL_PTM_NAMESPACE_RPC \
    PRL_PTM_NAMESPACE_INPUT \
    "/cursor.getimage"
File

PrlApiInputEmu.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_QUERY Macro

PRL_PTM_NAMESPACE_RPC_QUERY Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_QUERY \
    PRL_PTM_NAMESPACE_RPC "/query"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_SET Macro

PRL_PTM_NAMESPACE_RPC_SET Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_SET \
    PRL_PTM_NAMESPACE_RPC "/set"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_NAMESPACE_RPC_SUBSCRIBE Macro

PRL_PTM_NAMESPACE_RPC_SUBSCRIBE Macro
PRL_PTM Macros
Syntax
#define PRL_PTM_NAMESPACE_RPC_SUBSCRIBE \
    PRL_PTM_NAMESPACE_RPC "/subscribe"
File

PrlApiPtmTypes.h

Links
PRL_PTM Macros


PRL_PTM_OBJECT_PTR Type

PRL_PTM_OBJECT_PTR Type
Other Types
Syntax
typedef PRL_PTM_OBJECT* PRL_PTM_OBJECT_PTR;
File

PrlApiPtmTypes.h

Links
Other Types


PRL_PTM_PROPERTY_PTR Type

PRL_PTM_PROPERTY_PTR Type
Other Types
Syntax
typedef PRL_PTM_PROPERTY* PRL_PTM_PROPERTY_PTR;
File

PrlApiPtmTypes.h

Links
Other Types


PRL_QUERY_ELEMENT_FLAGS Enumeration

PRL_QUERY_ELEMENT_FLAGS Enumeration
Other Structs

Query element flags

Syntax
typedef enum _PRL_QUERY_ELEMENT_FLAGS {
  PRL_UIEMU_ELEMENT_SEARCH_AREA_WINDOW = 0,
  PRL_UIEMU_ELEMENT_SEARCH_AREA_GLOBAL = 1
} PRL_QUERY_ELEMENT_FLAGS;
File

PrlEnums.h

Links
Other Structs


PRL_QUERY_ELEMENT_FLAGS_PTR Type

PRL_QUERY_ELEMENT_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_QUERY_ELEMENT_FLAGS* PRL_QUERY_ELEMENT_FLAGS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_QUEST_CD_DRIVE_NOT_EXIST Macro

PRL_QUEST_CD_DRIVE_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_QUEST_CD_DRIVE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(221)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_CDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_CDD_IMAGE_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_QUEST_CDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(220)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_EXCEED_RECOMMENDED_MEMORY Macro

PRL_QUEST_EXCEED_RECOMMENDED_MEMORY Macro
Other Macros
Syntax
#define PRL_QUEST_EXCEED_RECOMMENDED_MEMORY PRL_RESULT_DECLARE_ERROR(219)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_FDD_DRIVE_NOT_EXIST Macro

PRL_QUEST_FDD_DRIVE_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_QUEST_FDD_DRIVE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(225)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_FDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_FDD_IMAGE_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_QUEST_FDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(224)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_HDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_HDD_IMAGE_NOT_EXIST Macro
Other Macros
Syntax
#define PRL_QUEST_HDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(223)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_HDD_SAME_IMAGE Macro

PRL_QUEST_HDD_SAME_IMAGE Macro
Other Macros
Syntax
#define PRL_QUEST_HDD_SAME_IMAGE PRL_RESULT_DECLARE_ERROR(222)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_POWER_OFF Macro

PRL_QUEST_POWER_OFF Macro
Other Macros
Syntax
#define PRL_QUEST_POWER_OFF PRL_RESULT_DECLARE_ERROR(311)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_RESET Macro

PRL_QUEST_RESET Macro
Other Macros
Syntax
#define PRL_QUEST_RESET PRL_RESULT_DECLARE_ERROR(312)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUEST_RESTART Macro

PRL_QUEST_RESTART Macro
Other Macros
Syntax
#define PRL_QUEST_RESTART PRL_RESULT_DECLARE_SUCCESS(15076)
File

PrlPrivateErrorsValues.h

Links
Other Macros


PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD Macro

PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD Macro
Other Macros
Syntax
#define PRL_QUESTION_ASK_ENCRYPTED_VM_PASSWORD PRL_RESULT_DECLARE_SUCCESS(13043)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE Macro

PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE Macro
Other Macros
Syntax
#define PRL_QUESTION_CAN_NOT_GET_DISK_FREE_SPACE PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE Macro

PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE Macro
Other Macros
Syntax
#define PRL_QUESTION_CONVERT_3RD_PARTY_CANNOT_MIGRATE PRL_RESULT_DECLARE_SUCCESS(13040)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED Macro

PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED Macro
Other Macros
Syntax
#define PRL_QUESTION_CONVERT_GUEST_OS_IS_HIBERNATED PRL_RESULT_DECLARE_SUCCESS(13055)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS Macro

PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS Macro
Other Macros
Syntax
#define PRL_QUESTION_CONVERT_VM_CANT_DETECT_OS PRL_RESULT_DECLARE_SUCCESS(13045)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH Macro

PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH Macro
Other Macros
Syntax
#define PRL_QUESTION_CONVERT_VM_SPECIFY_DISTRO_PATH PRL_RESULT_DECLARE_SUCCESS(13042)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_FINALIZE_VM_PROCESS Macro

PRL_QUESTION_FINALIZE_VM_PROCESS Macro
Other Macros
Syntax
#define PRL_QUESTION_FINALIZE_VM_PROCESS PRL_RESULT_DECLARE_SUCCESS(13049)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_REVERT_TOO_LARGE_MEM Macro

PRL_QUESTION_REVERT_TOO_LARGE_MEM Macro
Other Macros
Syntax
#define PRL_QUESTION_REVERT_TOO_LARGE_MEM PRL_RESULT_DECLARE_SUCCESS(13057)
File

PrlErrorsValues.h

Links
Other Macros


PRL_QUESTION_SETUP_YANDEX_SEARCH Macro

PRL_QUESTION_SETUP_YANDEX_SEARCH Macro
Other Macros
Syntax
#define PRL_QUESTION_SETUP_YANDEX_SEARCH PRL_RESULT_DECLARE_SUCCESS(13056)
File

PrlErrorsValues.h

Links
Other Macros


PRL_REGISTER_3PARTY_VM_FLAGS Enumeration

PRL_REGISTER_3PARTY_VM_FLAGS Enumeration
Other Structs

PrlSrv_Register3rdPartyVm command flags set

Syntax
typedef enum _PRL_REGISTER_3PARTY_VM_FLAGS {
  PR3F_ALLOW_UNKNOWN_OS = 1<<(PACF_MAX+1),
  PR3F_CREATE_SHADOW_VM = 1<<(PACF_MAX+2)
} PRL_REGISTER_3PARTY_VM_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_REGISTER_3PARTY_VM_FLAGS_PTR Type

PRL_REGISTER_3PARTY_VM_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_REGISTER_3PARTY_VM_FLAGS* PRL_REGISTER_3PARTY_VM_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_REGISTER_NEW_VM Enumeration

PRL_REGISTER_NEW_VM Enumeration
Other Structs

PrlVm_RegEx flags

Syntax
typedef enum _PRL_REGISTER_NEW_VM {
  PRNVM_CREATE_FROM_LION_RECOVERY_PARTITION = PCDIF_CREATE_FROM_LION_RECOVERY_PARTITION,
  PRNVM_ALLOW_TO_AUTO_DECREASE_HDD_SIZE = 1<<(PACF_MAX+2)
} PRL_REGISTER_NEW_VM;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_REGISTER_NEW_VM_PTR Type

PRL_REGISTER_NEW_VM_PTR Type
Other Types
Syntax
typedef PRL_REGISTER_NEW_VM* PRL_REGISTER_NEW_VM_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_REGISTER_VM_FLAGS Enumeration

PRL_REGISTER_VM_FLAGS Enumeration
Other Structs

PrlSrv_RegisterVmEx command flags set

Syntax
typedef enum _PRL_REGISTER_VM_FLAGS {
  PRVF_REGENERATE_VM_UUID = 1<<(PACF_MAX+1),
  PRVF_KEEP_OTHERS_PERMISSIONS = 1<<(PACF_MAX+2),
  PRCF_FORCE = 1<<(PACF_MAX+3),
  PRVF_REGENERATE_SRC_VM_UUID = 1<<(PACF_MAX+4),
  PRVF_IGNORE_HA_CLUSTER = 1<<(PACF_MAX+5),
  PRCF_UNREG_PRESERVE = 1<<(PACF_MAX+6)
} PRL_REGISTER_VM_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_REGISTER_VM_FLAGS_PTR Type

PRL_REGISTER_VM_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_REGISTER_VM_FLAGS* PRL_REGISTER_VM_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_RESIZE_IMAGE_FLAGS Enumeration

PRL_RESIZE_IMAGE_FLAGS Enumeration
Other Structs

PrlVmDev_ResizeImage command flags set

Syntax
typedef enum _PRL_RESIZE_IMAGE_FLAGS {
  PRIF_RESIZE_LAST_PARTITION = 1<<(PACF_MAX+1),
  PRIF_DISK_INFO = 1<<(PACF_MAX+2),
  PRIF_RESIZE_OFFLINE = 1<<(PACF_MAX+3)
} PRL_RESIZE_IMAGE_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_RESIZE_IMAGE_FLAGS_PTR Type

PRL_RESIZE_IMAGE_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_RESIZE_IMAGE_FLAGS* PRL_RESIZE_IMAGE_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_RESULT Type

PRL_RESULT Type
Other Types

Unified result error code for each and every method

Syntax
typedef int PRL_RESULT;
File

PrlTypes.h

Links
Other Types


PRL_RESULT_DECLARE_ERROR Macro

PRL_RESULT_DECLARE_ERROR Macro
Other Macros

Declaration of the error value goes here

Syntax
#define PRL_RESULT_DECLARE_ERROR( err ) ( (PRL_RESULT) (0x80000000 + 0x##err) )
File

PrlErrors.h

Links
Other Macros


PRL_RESULT_DECLARE_SUCCESS Macro

PRL_RESULT_DECLARE_SUCCESS Macro
Other Macros
Syntax
#define PRL_RESULT_DECLARE_SUCCESS( err ) ( (PRL_RESULT) (err) )
File

PrlErrors.h

Links
Other Macros


PRL_RESULT_PTR Type

PRL_RESULT_PTR Type
Other Types
Syntax
typedef PRL_RESULT* PRL_RESULT_PTR;
File

PrlTypes.h

Links
Other Types


prl_result_to_string Function

prl_result_to_string Function
API Debug Functions

This inline function returns a readable string representation of the PRL_RESULT value.

Syntax
static inline const char * prl_result_to_string(
    PRL_RESULT value
);
File

PrlApiCore.h

Parameters

value
A variable of type PRL_RESULT.

Links
API Debug Functions


PRL_RUNNING_TASK_TYPE_ENUM Enumeration

PRL_RUNNING_TASK_TYPE_ENUM Enumeration
Other Structs

Running task type enumeration.

Syntax
typedef enum _PRL_RUNNING_TASK_TYPE_ENUM {
  RTT_RUNNING_TASK_UNKNOWN = 0,
  RTT_RUNNING_TASK_CREATE_VM = 1,
  RTT_RUNNING_TASK_REGISTER_VM = 2,
  RTT_RUNNING_TASK_CLONE_VM = 3,
  RTT_RUNNING_TASK_DELETE_VM = 4,
  RTT_RUNNING_TASK_UNREG_VM = 5,
  RTT_RUNNING_TASK_CREATE_IMAGE = 6,
  RTT_RUNNING_TASK_RESTORE_VM = 7,
  RTT_RUNNING_TASK_MIGRATE_VM = 8,
  RTT_RUNNING_TASK_COPY_IMAGE = 9
} PRL_RUNNING_TASK_TYPE_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_RUNNING_TASK_TYPE_ENUM_PTR Type

PRL_RUNNING_TASK_TYPE_ENUM_PTR Type
Other Types
Syntax
typedef PRL_RUNNING_TASK_TYPE_ENUM* PRL_RUNNING_TASK_TYPE_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_SATA_READ_REQUESTS_PTRN Macro

PRL_SATA_READ_REQUESTS_PTRN Macro
Other Macros

Total count of read requests to SATA controller

Syntax
#define PRL_SATA_READ_REQUESTS_PTRN "devices.sata#.read_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SATA_READ_TOTAL_PTRN Macro

PRL_SATA_READ_TOTAL_PTRN Macro
Other Macros

Total count of read bytes through SATA controller

Syntax
#define PRL_SATA_READ_TOTAL_PTRN "devices.sata#.read_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SATA_WRITE_REQUESTS_PTRN Macro

PRL_SATA_WRITE_REQUESTS_PTRN Macro
Other Macros

Total count of write requests to SATA controller

Syntax
#define PRL_SATA_WRITE_REQUESTS_PTRN "devices.sata#.write_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SATA_WRITE_TOTAL_PTRN Macro

PRL_SATA_WRITE_TOTAL_PTRN Macro
Other Macros

Total count of write bytes through SATA controller

Syntax
#define PRL_SATA_WRITE_TOTAL_PTRN "devices.sata#.write_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SCALE_VIEW_MODE Enumeration

PRL_SCALE_VIEW_MODE Enumeration
Other Structs

Aspect ratio mode

Syntax
typedef enum _PRL_SCALE_VIEW_MODE {
  PSVM_OFF = 0,
  PSVM_AUTO = 1,
  PSVM_KEEP_ASPECT_RATIO = 2,
  PSVM_KEEP_ASPECT_RATIO_BY_EXPANDING = 3,
  PSVM_IGNORE_ASPECT_RATIO = 4
} PRL_SCALE_VIEW_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_SCALE_VIEW_MODE_PTR Type

PRL_SCALE_VIEW_MODE_PTR Type
Other Types
Syntax
typedef PRL_SCALE_VIEW_MODE* PRL_SCALE_VIEW_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_SCAN_CODE_0 Macro

PRL_SCAN_CODE_0 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_0 {11}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_1 Macro

PRL_SCAN_CODE_1 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_1 {2}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_2 Macro

PRL_SCAN_CODE_2 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_2 {3}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_3 Macro

PRL_SCAN_CODE_3 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_3 {4}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_4 Macro

PRL_SCAN_CODE_4 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_4 {5}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_5 Macro

PRL_SCAN_CODE_5 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_5 {6}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_6 Macro

PRL_SCAN_CODE_6 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_6 {7}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_7 Macro

PRL_SCAN_CODE_7 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_7 {8}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_8 Macro

PRL_SCAN_CODE_8 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_8 {9}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_9 Macro

PRL_SCAN_CODE_9 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_9 {10}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_A Macro

PRL_SCAN_CODE_A Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_A {30}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ALT_LEFT Macro

PRL_SCAN_CODE_ALT_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_ALT_LEFT {56}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ALT_RIGHT Macro

PRL_SCAN_CODE_ALT_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_ALT_RIGHT {224,56}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_APP_CALCULATOR Macro

PRL_SCAN_CODE_APP_CALCULATOR Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_APP_CALCULATOR {224,33}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_APP_MAIL Macro

PRL_SCAN_CODE_APP_MAIL Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_APP_MAIL {224,108}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_APP_MY_COMPUTER Macro

PRL_SCAN_CODE_APP_MY_COMPUTER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_APP_MY_COMPUTER {224,107}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_B Macro

PRL_SCAN_CODE_B Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_B {48}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BACKSLASH Macro

PRL_SCAN_CODE_BACKSLASH Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_BACKSLASH {43}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BACKSPACE Macro

PRL_SCAN_CODE_BACKSPACE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_BACKSPACE {14}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BRAZILIAN_KEYPAD Macro

PRL_SCAN_CODE_BRAZILIAN_KEYPAD Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_BRAZILIAN_KEYPAD {126}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BREAK Macro

PRL_SCAN_CODE_BREAK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_BREAK {224,70,224,198}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_C Macro

PRL_SCAN_CODE_C Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_C {46}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CAPS_LOCK Macro

PRL_SCAN_CODE_CAPS_LOCK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CAPS_LOCK {58}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CBRACE_LEFT Macro

PRL_SCAN_CODE_CBRACE_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CBRACE_LEFT {26}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CBRACE_RIGHT Macro

PRL_SCAN_CODE_CBRACE_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CBRACE_RIGHT {27}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CMD_LEFT Macro

PRL_SCAN_CODE_CMD_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CMD_LEFT {224,91}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CMD_RIGHT Macro

PRL_SCAN_CODE_CMD_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CMD_RIGHT {224,92}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_COLON Macro

PRL_SCAN_CODE_COLON Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_COLON {39}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CTRL_LEFT Macro

PRL_SCAN_CODE_CTRL_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CTRL_LEFT {29}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CTRL_RIGHT Macro

PRL_SCAN_CODE_CTRL_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_CTRL_RIGHT {224,29}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_D Macro

PRL_SCAN_CODE_D Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_D {32}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_DELETE Macro

PRL_SCAN_CODE_DELETE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_DELETE {224,83}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_DOLLAR Macro

PRL_SCAN_CODE_DOLLAR Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_DOLLAR {224,52}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_DOWN Macro

PRL_SCAN_CODE_DOWN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_DOWN {224,80}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_E Macro

PRL_SCAN_CODE_E Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_E {18}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_EJECT Macro

PRL_SCAN_CODE_EJECT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_EJECT {224,99}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_END Macro

PRL_SCAN_CODE_END Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_END {224,79}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ENTER Macro

PRL_SCAN_CODE_ENTER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_ENTER {28}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ESC Macro

PRL_SCAN_CODE_ESC Macro
PRL_SCAN_CODE Macros

PS/2 scan codes symbolical names for the SDK purposes.

Syntax
#define PRL_SCAN_CODE_ESC {1}
File

PrlKeys.h

Notes

scancode usage is deprecated, use PRL_KEY_* declared below

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_EURO Macro

PRL_SCAN_CODE_EURO Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_EURO {224,51}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_EUROPE_1 Macro

PRL_SCAN_CODE_EUROPE_1 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_EUROPE_1 {43}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F Macro

PRL_SCAN_CODE_F Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F {33}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F1 Macro

PRL_SCAN_CODE_F1 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F1 {59}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F2 Macro

PRL_SCAN_CODE_F2 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F2 {60}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F3 Macro

PRL_SCAN_CODE_F3 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F3 {61}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F4 Macro

PRL_SCAN_CODE_F4 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F4 {62}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F5 Macro

PRL_SCAN_CODE_F5 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F5 {63}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F6 Macro

PRL_SCAN_CODE_F6 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F6 {64}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F7 Macro

PRL_SCAN_CODE_F7 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F7 {65}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F8 Macro

PRL_SCAN_CODE_F8 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F8 {66}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F9 Macro

PRL_SCAN_CODE_F9 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F9 {67}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F10 Macro

PRL_SCAN_CODE_F10 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F10 {68}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F11 Macro

PRL_SCAN_CODE_F11 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F11 {87}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F12 Macro

PRL_SCAN_CODE_F12 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F12 {88}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F13 Macro

PRL_SCAN_CODE_F13 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F13 {100}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F14 Macro

PRL_SCAN_CODE_F14 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F14 {101}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F15 Macro

PRL_SCAN_CODE_F15 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F15 {102}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F16 Macro

PRL_SCAN_CODE_F16 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F16 {103}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F17 Macro

PRL_SCAN_CODE_F17 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F17 {104}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F18 Macro

PRL_SCAN_CODE_F18 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F18 {105}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F19 Macro

PRL_SCAN_CODE_F19 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F19 {106}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F20 Macro

PRL_SCAN_CODE_F20 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F20 {107}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F21 Macro

PRL_SCAN_CODE_F21 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F21 {108}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F22 Macro

PRL_SCAN_CODE_F22 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F22 {109}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F23 Macro

PRL_SCAN_CODE_F23 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F23 {110}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F24 Macro

PRL_SCAN_CODE_F24 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_F24 {118}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_G Macro

PRL_SCAN_CODE_G Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_G {34}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_GREATER Macro

PRL_SCAN_CODE_GREATER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_GREATER {52}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_H Macro

PRL_SCAN_CODE_H Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_H {35}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HANGUEL Macro

PRL_SCAN_CODE_HANGUEL Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HANGUEL {242}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HANJA Macro

PRL_SCAN_CODE_HANJA Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HANJA {241}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HENKAN Macro

PRL_SCAN_CODE_HENKAN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HENKAN {121}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HIRAGANA Macro

PRL_SCAN_CODE_HIRAGANA Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HIRAGANA {119}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HIRAGANA_KATAKANA Macro

PRL_SCAN_CODE_HIRAGANA_KATAKANA Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HIRAGANA_KATAKANA {112}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_HOME Macro

PRL_SCAN_CODE_HOME Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_HOME {224,71}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_I Macro

PRL_SCAN_CODE_I Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_I {23}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_INSERT Macro

PRL_SCAN_CODE_INSERT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_INSERT {224,82}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_J Macro

PRL_SCAN_CODE_J Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_J {36}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_K Macro

PRL_SCAN_CODE_K Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_K {37}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_KATAKANA Macro

PRL_SCAN_CODE_KATAKANA Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_KATAKANA {120}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_L Macro

PRL_SCAN_CODE_L Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_L {38}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_LEFT Macro

PRL_SCAN_CODE_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_LEFT {224,75}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_LESS Macro

PRL_SCAN_CODE_LESS Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_LESS {51}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_LESS_GREATER Macro

PRL_SCAN_CODE_LESS_GREATER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_LESS_GREATER {86}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_M Macro

PRL_SCAN_CODE_M Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_M {50}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MEDIA_NEXT_TRACK Macro

PRL_SCAN_CODE_MEDIA_NEXT_TRACK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MEDIA_NEXT_TRACK {224,25}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MEDIA_PLAY_PAUSE Macro

PRL_SCAN_CODE_MEDIA_PLAY_PAUSE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MEDIA_PLAY_PAUSE {224,34}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MEDIA_PREV_TRACK Macro

PRL_SCAN_CODE_MEDIA_PREV_TRACK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MEDIA_PREV_TRACK {224,16}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MEDIA_SELECT Macro

PRL_SCAN_CODE_MEDIA_SELECT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MEDIA_SELECT {224,109}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MEDIA_STOP Macro

PRL_SCAN_CODE_MEDIA_STOP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MEDIA_STOP {224,36}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MENU Macro

PRL_SCAN_CODE_MENU Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MENU {224,93}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MINUS Macro

PRL_SCAN_CODE_MINUS Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MINUS {12}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MUHENKAN Macro

PRL_SCAN_CODE_MUHENKAN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MUHENKAN {123}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MUTE Macro

PRL_SCAN_CODE_MUTE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_MUTE {224,32}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_N Macro

PRL_SCAN_CODE_N Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_N {49}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_NUM_LOCK Macro

PRL_SCAN_CODE_NUM_LOCK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_NUM_LOCK {69}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_O Macro

PRL_SCAN_CODE_O Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_O {24}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_P Macro

PRL_SCAN_CODE_P Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_P {25}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_0 Macro

PRL_SCAN_CODE_PAD_0 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_0 {82}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_1 Macro

PRL_SCAN_CODE_PAD_1 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_1 {79}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_2 Macro

PRL_SCAN_CODE_PAD_2 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_2 {80}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_3 Macro

PRL_SCAN_CODE_PAD_3 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_3 {81}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_4 Macro

PRL_SCAN_CODE_PAD_4 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_4 {75}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_5 Macro

PRL_SCAN_CODE_PAD_5 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_5 {76}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_6 Macro

PRL_SCAN_CODE_PAD_6 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_6 {77}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_7 Macro

PRL_SCAN_CODE_PAD_7 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_7 {71}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_8 Macro

PRL_SCAN_CODE_PAD_8 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_8 {72}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_9 Macro

PRL_SCAN_CODE_PAD_9 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_9 {73}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_DEL Macro

PRL_SCAN_CODE_PAD_DEL Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_DEL {83}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_ENTER Macro

PRL_SCAN_CODE_PAD_ENTER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_ENTER {224,28}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_EQUAL Macro

PRL_SCAN_CODE_PAD_EQUAL Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_EQUAL {89}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_MINUS Macro

PRL_SCAN_CODE_PAD_MINUS Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_MINUS {74}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_PLUS Macro

PRL_SCAN_CODE_PAD_PLUS Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_PLUS {78}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_SLASH Macro

PRL_SCAN_CODE_PAD_SLASH Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_SLASH {224,53}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_STAR Macro

PRL_SCAN_CODE_PAD_STAR Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAD_STAR {55}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAGE_DOWN Macro

PRL_SCAN_CODE_PAGE_DOWN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAGE_DOWN {224,81}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAGE_UP Macro

PRL_SCAN_CODE_PAGE_UP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAGE_UP {224,73}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAUSE_BREAK Macro

PRL_SCAN_CODE_PAUSE_BREAK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PAUSE_BREAK {225,29,69,225,157,197}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PC9800_KEYPAD Macro

PRL_SCAN_CODE_PC9800_KEYPAD Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PC9800_KEYPAD {92}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PLUS Macro

PRL_SCAN_CODE_PLUS Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PLUS {13}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PRINT_SCREEN Macro

PRL_SCAN_CODE_PRINT_SCREEN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PRINT_SCREEN {224,42,224,55}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PRINT_SCREEN2 Macro

PRL_SCAN_CODE_PRINT_SCREEN2 Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_PRINT_SCREEN2 {224,55}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Q Macro

PRL_SCAN_CODE_Q Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_Q {16}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_QUOTE Macro

PRL_SCAN_CODE_QUOTE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_QUOTE {40}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_R Macro

PRL_SCAN_CODE_R Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_R {19}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_RIGHT Macro

PRL_SCAN_CODE_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_RIGHT {224,77}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_RO Macro

PRL_SCAN_CODE_RO Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_RO {115}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_S Macro

PRL_SCAN_CODE_S Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_S {31}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SCROLL_LOCK Macro

PRL_SCAN_CODE_SCROLL_LOCK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SCROLL_LOCK {70}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SHIFT_LEFT Macro

PRL_SCAN_CODE_SHIFT_LEFT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SHIFT_LEFT {42}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SHIFT_RIGHT Macro

PRL_SCAN_CODE_SHIFT_RIGHT Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SHIFT_RIGHT {54}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SLASH Macro

PRL_SCAN_CODE_SLASH Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SLASH {53}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SPACE Macro

PRL_SCAN_CODE_SPACE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SPACE {57}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SYSRQ Macro

PRL_SCAN_CODE_SYSRQ Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SYSRQ {84}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SYSTEM_POWER Macro

PRL_SCAN_CODE_SYSTEM_POWER Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SYSTEM_POWER {224,94}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SYSTEM_SLEEP Macro

PRL_SCAN_CODE_SYSTEM_SLEEP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SYSTEM_SLEEP {224,95}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SYSTEM_WAKE Macro

PRL_SCAN_CODE_SYSTEM_WAKE Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_SYSTEM_WAKE {224,99}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_T Macro

PRL_SCAN_CODE_T Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_T {20}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_TAB Macro

PRL_SCAN_CODE_TAB Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_TAB {15}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_TILDA Macro

PRL_SCAN_CODE_TILDA Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_TILDA {41}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_U Macro

PRL_SCAN_CODE_U Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_U {22}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_UP Macro

PRL_SCAN_CODE_UP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_UP {224,72}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_V Macro

PRL_SCAN_CODE_V Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_V {47}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_VOLUME_DOWN Macro

PRL_SCAN_CODE_VOLUME_DOWN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_VOLUME_DOWN {224,46}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_VOLUME_UP Macro

PRL_SCAN_CODE_VOLUME_UP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_VOLUME_UP {224,48}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_W Macro

PRL_SCAN_CODE_W Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_W {17}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_BACK Macro

PRL_SCAN_CODE_WWW_BACK Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_BACK {224,106}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_FAVORITES Macro

PRL_SCAN_CODE_WWW_FAVORITES Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_FAVORITES {224,102}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_FORWARD Macro

PRL_SCAN_CODE_WWW_FORWARD Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_FORWARD {224,105}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_HOME Macro

PRL_SCAN_CODE_WWW_HOME Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_HOME {224,50}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_REFRESH Macro

PRL_SCAN_CODE_WWW_REFRESH Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_REFRESH {224,103}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_SEARCH Macro

PRL_SCAN_CODE_WWW_SEARCH Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_SEARCH {224,101}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_WWW_STOP Macro

PRL_SCAN_CODE_WWW_STOP Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_WWW_STOP {224,104}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_X Macro

PRL_SCAN_CODE_X Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_X {45}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Y Macro

PRL_SCAN_CODE_Y Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_Y {21}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_YEN Macro

PRL_SCAN_CODE_YEN Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_YEN {125}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Z Macro

PRL_SCAN_CODE_Z Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_Z {44}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ZENKAKU_HANKAKU Macro

PRL_SCAN_CODE_ZENKAKU_HANKAKU Macro
PRL_SCAN_CODE Macros
Syntax
#define PRL_SCAN_CODE_ZENKAKU_HANKAKU {118}
File

PrlKeys.h

Links
PRL_SCAN_CODE Macros


PRL_SCSI_READ_REQUESTS_PTRN Macro

PRL_SCSI_READ_REQUESTS_PTRN Macro
Other Macros

Total count of read requests to SCSI controller

Syntax
#define PRL_SCSI_READ_REQUESTS_PTRN "devices.scsi#.read_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SCSI_READ_TOTAL_PTRN Macro

PRL_SCSI_READ_TOTAL_PTRN Macro
Other Macros

Total count of read bytes through SCSI controller

Syntax
#define PRL_SCSI_READ_TOTAL_PTRN "devices.scsi#.read_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SCSI_WRITE_REQUESTS_PTRN Macro

PRL_SCSI_WRITE_REQUESTS_PTRN Macro
Other Macros

Total count of write requests to SCSI controller

Syntax
#define PRL_SCSI_WRITE_REQUESTS_PTRN "devices.scsi#.write_requests"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SCSI_WRITE_TOTAL_PTRN Macro

PRL_SCSI_WRITE_TOTAL_PTRN Macro
Other Macros

Total count of write bytes through SCSI controller

Syntax
#define PRL_SCSI_WRITE_TOTAL_PTRN "devices.scsi#.write_total"
File

PrlPerfCounters.h

Links
Other Macros


PRL_SDK_WRAP_FOR_EACH_MANAGER Macro

PRL_SDK_WRAP_FOR_EACH_MANAGER Macro
Other Macros
Syntax
#define PRL_SDK_WRAP_FOR_EACH_MANAGER \
PRL_SDK_WRAP_FOR_EACH_ITERATOR( PrlSrv_CreateDesktopControl ) \
PRL_SDK_WRAP_FOR_EACH_ITERATOR( PrlSrv_GetAllHostUsers ) \
PRL_SDK_WRAP_FOR_EACH_ITERATOR( PrlApi_SwitchConsoleLogging ) \
PRL_SDK_WRAP_FOR_EACH_ITERATOR( PrlSrv_SetCertificateRevocationDateTime ) \
PRL_SDK_WRAP_FOR_EACH_ITERATOR( PrlSrv_SetGlobalDateTime ) \
File

PrlApiMgrMacro.h

Links
Other Macros


PRL_SECURITY_LEVEL Enumeration

PRL_SECURITY_LEVEL Enumeration
Other Structs

Security level enumeration.

Syntax
typedef enum _PRL_SECURITY_LEVEL {
  PSL_LOW_SECURITY = 0,
  PSL_NORMAL_SECURITY = 1<<0,
  PSL_HIGH_SECURITY = 1<<1
} PRL_SECURITY_LEVEL;
File

PrlCommandsFlags.h

Type Parameters

PSL_LOW_SECURITY
Plain TCP/IP (no encryption).
PSL_NORMAL_SECURITY
Most important data is sent and received using SSL over TCP/IP (user credentials during login, guest OS clipboard, etc.) Other data is sent and receive using plain TCP/IP with no encryption.
PSL_HIGH_SECURITY
All of the data is sent and received using SSL.

Remarks

Defines levels of security that can be used in client/server communications.

Links
Other Structs


PRL_SECURITY_LEVEL_PTR Type

PRL_SECURITY_LEVEL_PTR Type
Other Types
Syntax
typedef PRL_SECURITY_LEVEL* PRL_SECURITY_LEVEL_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration

PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration
Other Structs

Serial port operation mode when on socket

Syntax
typedef enum _PRL_SERIAL_PORT_SOCKET_OPERATION_MODE {
  PSP_SERIAL_SOCKET_SERVER = 0,
  PSP_SERIAL_SOCKET_CLIENT = 1
} PRL_SERIAL_PORT_SOCKET_OPERATION_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR Type

PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR Type
Other Types
Syntax
typedef PRL_SERIAL_PORT_SOCKET_OPERATION_MODE* PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_SERVICE_STATUS_ENUM Enumeration

PRL_SERVICE_STATUS_ENUM Enumeration
Other Structs

Parallels service statuses

Syntax
typedef enum _PRL_SERVICE_STATUS_ENUM {
  PSS_STARTED = 0,
  PSS_STOPPED = 1,
  PSS_NOT_INSTALLED = 2,
  PSS_UNKNOWN
} PRL_SERVICE_STATUS_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_SERVICE_STATUS_ENUM_PTR Type

PRL_SERVICE_STATUS_ENUM_PTR Type
Other Types
Syntax
typedef PRL_SERVICE_STATUS_ENUM* PRL_SERVICE_STATUS_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_SET_PROXY_CONNECTION_FLAGS Enumeration

PRL_SET_PROXY_CONNECTION_FLAGS Enumeration
Other Structs

PrlDispCfg_SetProxyConnectionCreds flags

Syntax
typedef enum _PRL_SET_PROXY_CONNECTION_FLAGS {
  PSPCF_DO_NOT_CLEAN_CREDS = 1<<(PACF_MAX+1),
  PSPCF_REUSE_AVAILABLE_CREDS = 1<<(PACF_MAX+2),
  PSPCF_CLEANUP_CREDS = 1<<(PACF_MAX+3),
  PSPCF_USE_DEPLOY_ID = 1<<(PACF_MAX+4),
  PSPCF_REGISTER_HOST_ONLY = 1<<(PACF_MAX+5),
  PSPCF_USE_FACEBOOK_TOKEN = 1<<(PACF_MAX+6),
  PSPCF_USE_GOOGLE_TOKEN = 1<<(PACF_MAX+7)
} PRL_SET_PROXY_CONNECTION_FLAGS;
File

PrlCommandsFlags.h

Links
Other Structs


PRL_SET_PROXY_CONNECTION_FLAGS_PTR Type

PRL_SET_PROXY_CONNECTION_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_SET_PROXY_CONNECTION_FLAGS* PRL_SET_PROXY_CONNECTION_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_SET_USERPASSWD_FLAGS Enumeration

PRL_SET_USERPASSWD_FLAGS Enumeration
Other Structs

PrlVmGuest_SetUserPasswd flags

Syntax
typedef enum _PRL_SET_USERPASSWD_FLAGS {
  PSPF_PASSWD_CRYPTED = 1<<(PACF_MAX+1)
} PRL_SET_USERPASSWD_FLAGS;
File

PrlCommandsFlags.h

Members

PSPF_PASSWD_CRYPTED
passwords are encrypted

Links
Other Structs


PRL_SET_USERPASSWD_FLAGS_PTR Type

PRL_SET_USERPASSWD_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_SET_USERPASSWD_FLAGS* PRL_SET_USERPASSWD_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_SIZE Type

PRL_SIZE Type
Other Types

Unsigned integer type of the result of the sizeof operator

Syntax
typedef unsigned int PRL_SIZE;
File

PrlTypes.h

Links
Other Types


PRL_SIZE_PTR Type

PRL_SIZE_PTR Type
Other Types
Syntax
typedef PRL_SIZE* PRL_SIZE_PTR;
File

PrlTypes.h

Links
Other Types


PRL_SIZE_PTR_PTR Type

PRL_SIZE_PTR_PTR Type
Other Types
Syntax
typedef PRL_SIZE_PTR* PRL_SIZE_PTR_PTR;
File

PrlTypes.h

Links
Other Types


PRL_SNAPSHOT_ELEMENT Structure

PRL_SNAPSHOT_ELEMENT Structure
Other Structs

Parallels snapshot tree element

Syntax
typedef struct __PRL_SNAPSHOT_ELEMENT {
  PRL_GUID m_GUID;
  struct __PRL_SNAPSHOT_ELEMENT* m_pNext;
  struct __PRL_SNAPSHOT_ELEMENT* m_pChild;
} PRL_SNAPSHOT_ELEMENT;
File

PrlDisk.h

Links
Other Structs


PRL_SNAPSHOT_ELEMENT_PTR Type

PRL_SNAPSHOT_ELEMENT_PTR Type
Other Types
Syntax
typedef PRL_SNAPSHOT_ELEMENT* PRL_SNAPSHOT_ELEMENT_PTR;
File

PrlDisk.h

Links
Other Types


PRL_SOUND_CHANNEL_TYPE Enumeration

PRL_SOUND_CHANNEL_TYPE Enumeration
Other Structs

Sound channel type

Syntax
typedef enum _PRL_SOUND_CHANNEL_TYPE {
  PSCT_AUTO = 0,
  PSCT_STEREO = 1,
  PSCT_SURROUND_5_1 = 2
} PRL_SOUND_CHANNEL_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_SOUND_CHANNEL_TYPE_PTR Type

PRL_SOUND_CHANNEL_TYPE_PTR Type
Other Types
Syntax
typedef PRL_SOUND_CHANNEL_TYPE* PRL_SOUND_CHANNEL_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_SRV_METHOD_DECL Macro

PRL_SRV_METHOD_DECL Macro
Other Macros
Syntax
#define PRL_SRV_METHOD_DECL( version, name, args ) \
    PRL_METHOD( name ) args;    \
    typedef PRL_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
Other Macros


PRL_SRV_SHUTDOWN_FLAGS Enumeration

PRL_SRV_SHUTDOWN_FLAGS Enumeration
Other Structs

PrlSrv_ShutdownEx flags

Syntax
typedef enum _PRL_SRV_SHUTDOWN_FLAGS {
  PSHF_FORCE_SHUTDOWN = 1<<(PACF_MAX+1),
  PSHF_DONT_WAIT_TO_COMPLETE = 1<<(PACF_MAX+2),
  PSHF_SUSPEND_VM_TO_PRAM = 1<<(PACF_MAX+3)
} PRL_SRV_SHUTDOWN_FLAGS;
File

PrlCommandsFlags.h

Members

PSHF_FORCE_SHUTDOWN
Allow shutdown with active users sessions and running vms
PSHF_DONT_WAIT_TO_COMPLETE
Send response immediately when shutdown started
PSHF_SUSPEND_VM_TO_PRAM
Use PRAM to suspend/resume VM if available

Links
Other Structs


PRL_SRV_SHUTDOWN_FLAGS_PTR Type

PRL_SRV_SHUTDOWN_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_SRV_SHUTDOWN_FLAGS* PRL_SRV_SHUTDOWN_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_STAT_NET_TRAFFIC Structure

PRL_STAT_NET_TRAFFIC Structure
Other Structs
Syntax
typedef struct _PRL_STAT_NET_TRAFFIC {
  PRL_UINT64 incoming[PRL_TC_CLASS_MAX];
  PRL_UINT64 outgoing[PRL_TC_CLASS_MAX];
  PRL_UINT32 incoming_pkt[PRL_TC_CLASS_MAX];
  PRL_UINT32 outgoing_pkt[PRL_TC_CLASS_MAX];
} PRL_STAT_NET_TRAFFIC;
File

PrlIoStructs.h

Links
Other Structs


PRL_STAT_NET_TRAFFIC_PTR Type

PRL_STAT_NET_TRAFFIC_PTR Type
Other Types
Syntax
typedef PRL_STAT_NET_TRAFFIC* PRL_STAT_NET_TRAFFIC_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_STATE_CALLBACK_INVALID Macro

PRL_STATE_CALLBACK_INVALID Macro
Other Macros

Invalid callback

Syntax
#define PRL_STATE_CALLBACK_INVALID 0x1005
File

PrlDisk.h

Links
Other Macros


PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK Macro

PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK Macro
Other Macros

Core callback completed

Syntax
#define PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK 0x1001
File

PrlDisk.h

Links
Other Macros


PRL_STATE_CORE_FULL_COMPLETE_CALLBACK Macro

PRL_STATE_CORE_FULL_COMPLETE_CALLBACK Macro
Other Macros

Operation fully completed

Syntax
#define PRL_STATE_CORE_FULL_COMPLETE_CALLBACK 0x1002
File

PrlDisk.h

Links
Other Macros


PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK Macro

PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK Macro
Other Macros

Disk operation started

Syntax
#define PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK 0x1003
File

PrlDisk.h

Links
Other Macros


PRL_STATE_DISK_CALLBACK Macro

PRL_STATE_DISK_CALLBACK Macro
Other Macros

Ordinary callback that disk process going.

Syntax
#define PRL_STATE_DISK_CALLBACK 0x1000
File

PrlDisk.h

Links
Other Macros


PRL_STATE_DISK_CALLBACK_STAGE_CPL Macro

PRL_STATE_DISK_CALLBACK_STAGE_CPL Macro
Other Macros

At remove all states this callback indicates that one more stage complete in states removal

Syntax
#define PRL_STATE_DISK_CALLBACK_STAGE_CPL 0x1004
File

PrlDisk.h

Links
Other Macros


PRL_STATE_PROGRESS_COMPLETED Macro

PRL_STATE_PROGRESS_COMPLETED Macro
Other Macros
Syntax
#define PRL_STATE_PROGRESS_COMPLETED 1005
File

PrlDisk.h

Links
Other Macros


PRL_STATE_PROGRESS_MAX Macro

PRL_STATE_PROGRESS_MAX Macro
Other Macros
Syntax
#define PRL_STATE_PROGRESS_MAX 1000
File

PrlDisk.h

Links
Other Macros


PRL_STATE_PROGRESS_MIN Macro

PRL_STATE_PROGRESS_MIN Macro
Other Macros

States progress definition

Syntax
#define PRL_STATE_PROGRESS_MIN 0
File

PrlDisk.h

Links
Other Macros


PRL_STATES_CALLBACK_TYPE Type

PRL_STATES_CALLBACK_TYPE Type
Other Types

Saved states callback types

@author antonz@

Syntax
typedef PRL_INT32 PRL_STATES_CALLBACK_TYPE;
File

PrlDisk.h

Links
Other Types


PRL_STATES_CALLBACK_TYPE_PTR Type

PRL_STATES_CALLBACK_TYPE_PTR Type
Other Types
Syntax
typedef PRL_STATES_CALLBACK_TYPE* PRL_STATES_CALLBACK_TYPE_PTR;
File

PrlDisk.h

Links
Other Types


PRL_STR Type

PRL_STR Type
Other Types
Syntax
typedef PRL_CHAR_PTR PRL_STR;
File

PrlTypes.h

Links
Other Types


PRL_STRUCT Macro

PRL_STRUCT Macro
Other Macros

Default structure definition

Syntax
#define PRL_STRUCT( struct_name ) struct_name
File

PrlTypes.h

Links
Other Macros


PRL_SUCCEEDED Macro

PRL_SUCCEEDED Macro
Other Macros

Success and failure result codes

Syntax
#define PRL_SUCCEEDED( err ) ( ( PRL_RESULT )( err ) >= 0 )
File

PrlErrors.h

Links
Other Macros


PRL_SWITCH_SNAPSHOT_FLAGS Enumeration

PRL_SWITCH_SNAPSHOT_FLAGS Enumeration
Other Structs

PrlVm_SwitchSnapshotEx flags

Syntax
typedef enum _PRL_SWITCH_SNAPSHOT_FLAGS {
  PSSF_SKIP_RESUME = 1<<(PACF_MAX+1)
} PRL_SWITCH_SNAPSHOT_FLAGS;
File

PrlCommandsFlags.h

Members

PSSF_SKIP_RESUME
skip resume stage for Vm in the

  • running/paused state in the snapshot

Links
Other Structs


PRL_TASKBAR_STATES Enumeration

PRL_TASKBAR_STATES Enumeration
Other Structs

Taskbar states

Syntax
typedef enum _PRL_TASKBAR_STATES {
  PTBS_UNKNOWN = -1,
  PTBS_HIDE = 0,
  PTBS_SHOW = 1,
  PTBS_DEFAULT = 2
} PRL_TASKBAR_STATES;
File

PrlEnums.h

Links
Other Structs


PRL_TC_CLASS_MAX Macro

PRL_TC_CLASS_MAX Macro
Other Macros
Syntax
#define PRL_TC_CLASS_MAX 16
File

PrlIoStructs.h

Links
Other Macros


PRL_TERNARY_FALSE Macro

PRL_TERNARY_FALSE Macro
Other Macros
Syntax
#define PRL_TERNARY_FALSE (3)
File

PrlTypes.h

Links
Other Macros


PRL_TERNARY_TRUE Macro

PRL_TERNARY_TRUE Macro
Other Macros
Syntax
#define PRL_TERNARY_TRUE (2)
File

PrlTypes.h

Links
Other Macros


PRL_TERNARY_UNDEF Macro

PRL_TERNARY_UNDEF Macro
Other Macros
Syntax
#define PRL_TERNARY_UNDEF (0)
File

PrlTypes.h

Links
Other Macros


PRL_TIS_INT_VERSION Structure

PRL_TIS_INT_VERSION Structure
Other Structs

@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
Syntax
typedef struct _PRL_TIS_INT_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
} PRL_TIS_INT_VERSION;
File

PrlIoStructs.h

Links
Other Structs


PRL_TIS_INT_VERSION_PTR Type

PRL_TIS_INT_VERSION_PTR Type
PRL_TIS Types
Syntax
typedef PRL_TIS_INT_VERSION* PRL_TIS_INT_VERSION_PTR;
File

PrlIoStructs.h

Links
PRL_TIS Types


PRL_TIS_RECORD_FIELD Enumeration

PRL_TIS_RECORD_FIELD Enumeration
Other Structs

Parallels Tools Information Service record fields

Syntax
typedef enum _PRL_TIS_RECORD_FIELD {
  PTIS_RECORD_UID = 1<<0,
  PTIS_RECORD_NAME = 1<<1,
  PTIS_RECORD_INFO = 1<<2,
  PTIS_RECORD_TEXT = 1<<3,
  PTIS_RECORD_DATA = 1<<4,
  PTIS_RECORD_STATE = 1<<5,
  PTIS_RECORD_TIME = 1<<6,
  PTIS_RECORD_OWNER = 1<<7,
  PTIS_RECORD_FLAGS = 1<<8,
  PTIS_RECORD_REMOVED = 1<<30,
  PTIS_RECORD_CLEARED = 1<<31
} PRL_TIS_RECORD_FIELD;
File

PrlEnums.h

Members

PTIS_RECORD_REMOVED
set when record removed
PTIS_RECORD_CLEARED
set only with PTIS_RECORD_REMOVED bit when entire database was cleared

Links
Other Structs


PRL_TIS_RECORD_FIELD_PTR Type

PRL_TIS_RECORD_FIELD_PTR Type
PRL_TIS Types
Syntax
typedef PRL_TIS_RECORD_FIELD* PRL_TIS_RECORD_FIELD_PTR;
File

PrlEnums.h

Links
PRL_TIS Types


PRL_TIS_RECORD_INFO Structure

PRL_TIS_RECORD_INFO Structure
Other Structs

@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
Syntax
typedef struct _PRL_TIS_RECORD_INFO {
  PRL_TIS_VERSION version;
  PRL_TIS_INT_VERSION intVersion;
} PRL_TIS_RECORD_INFO;
File

PrlIoStructs.h

Links
Other Structs


PRL_TIS_RECORD_INFO_PTR Type

PRL_TIS_RECORD_INFO_PTR Type
PRL_TIS Types
Syntax
typedef PRL_TIS_RECORD_INFO* PRL_TIS_RECORD_INFO_PTR;
File

PrlIoStructs.h

Links
PRL_TIS Types


PRL_TIS_RECORD_STATE Enumeration

PRL_TIS_RECORD_STATE Enumeration
Other Structs

Parallels Tools Information Service record states

Syntax
typedef enum _PRL_TIS_RECORD_STATE {
  PTIS_RECORD_EMPTY = 0,
  PTIS_RECORD_ACTIVE = 1,
  PTIS_RECORD_CANCELED = 2
} PRL_TIS_RECORD_STATE;
File

PrlEnums.h

Links
Other Structs


PRL_TIS_RECORD_STATE_PTR Type

PRL_TIS_RECORD_STATE_PTR Type
PRL_TIS Types
Syntax
typedef PRL_TIS_RECORD_STATE* PRL_TIS_RECORD_STATE_PTR;
File

PrlEnums.h

Links
PRL_TIS Types


PRL_TIS_VERSION Structure

PRL_TIS_VERSION Structure
Other Structs

@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
Syntax
typedef struct _PRL_TIS_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
  PRL_UINT32 bld;
  PRL_UINT32 rev;
} PRL_TIS_VERSION;
File

PrlIoStructs.h

Links
Other Structs


PRL_TIS_VERSION_PTR Type

PRL_TIS_VERSION_PTR Type
PRL_TIS Types
Syntax
typedef PRL_TIS_VERSION* PRL_TIS_VERSION_PTR;
File

PrlIoStructs.h

Links
PRL_TIS Types


PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration

PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration
Other Structs

Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;

Syntax
typedef enum _PRL_TOOLS_SIA_OPEN_IN_TYPES {
  PSIA_OPEN_DEFAULT = 0,
  PSIA_OPEN_IN_GUEST = 1,
  PSIA_OPEN_IN_HOST = 2
} PRL_TOOLS_SIA_OPEN_IN_TYPES;
File

PrlEnums.h

Links
Other Structs


PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR Type

PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR Type
PRL_TOOLS Types
Syntax
typedef PRL_TOOLS_SIA_OPEN_IN_TYPES* PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR;
File

PrlEnums.h

Links
PRL_TOOLS Types


PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration

PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration
Other Structs

Parallels Tools Utility command flags

Syntax
typedef enum _PRL_TOOLS_UTILITY_COMMAND_FLAG {
  PTU_FLG_ZERO = (1 << 0)
} PRL_TOOLS_UTILITY_COMMAND_FLAG;
File

PrlCommandsFlags.h

Members

PTU_FLG_ZERO
@brief Flag is useless now, but placed here to show how and where it must be

Links
Other Structs


PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR Type

PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR Type
PRL_TOOLS Types
Syntax
typedef PRL_TOOLS_UTILITY_COMMAND_FLAG* PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR;
File

PrlCommandsFlags.h

Links
PRL_TOOLS Types


PRL_TOOLS_UTILITY_COMMAND_ID Enumeration

PRL_TOOLS_UTILITY_COMMAND_ID Enumeration
Other Structs

Parallels Tools Utility commands identifiers

Syntax
typedef enum _PRL_TOOLS_UTILITY_COMMAND_ID {
  PTU_CMD_INVALID = 0,
  PTU_CMD_PTU_ALIVE = 1
} PRL_TOOLS_UTILITY_COMMAND_ID;
File

PrlEnums.h

Members

PTU_CMD_INVALID
brief Identifier of invalid command
PTU_CMD_PTU_ALIVE
@brief Can be sent to indicate that Parallels Tools Utility subsystem is alive and ready to work

Links
Other Structs


PRL_TOOLS_UTILITY_COMMAND_ID_PTR Type

PRL_TOOLS_UTILITY_COMMAND_ID_PTR Type
PRL_TOOLS Types
Syntax
typedef PRL_TOOLS_UTILITY_COMMAND_ID* PRL_TOOLS_UTILITY_COMMAND_ID_PTR;
File

PrlEnums.h

Links
PRL_TOOLS Types


PRL_TRUE Macro

PRL_TRUE Macro
Other Macros
Syntax
#define PRL_TRUE (1)
File

PrlTypes.h

Links
Other Macros


PRL_UIEMU_AUTOKEYBOARD Structure

PRL_UIEMU_AUTOKEYBOARD Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_AUTOKEYBOARD {
  PRL_UINT8 showKeyboardState;
  PRL_UINT8 reserved[3+4*4];
} PRL_UIEMU_AUTOKEYBOARD;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_AUTOKEYBOARD_PTR Type

PRL_UIEMU_AUTOKEYBOARD_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_AUTOKEYBOARD* PRL_UIEMU_AUTOKEYBOARD_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_CARET_INFO Structure

PRL_UIEMU_CARET_INFO Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_CARET_INFO {
  PRL_INT32 queryId;
  PRL_UINT32 queryFlags;
  PRL_UINT32 caretRectIsAvailable;
  PRL_UINT32 caretIsOutOfView;
  PRL_INT32 caretRectLeft;
  PRL_INT32 caretRectTop;
  PRL_INT32 caretRectRight;
  PRL_INT32 caretRectBottom;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
} PRL_UIEMU_CARET_INFO;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_CARET_INFO_PTR Type

PRL_UIEMU_CARET_INFO_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_CARET_INFO* PRL_UIEMU_CARET_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_CURSOR_DESC Structure

PRL_UIEMU_CURSOR_DESC Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_CURSOR_DESC {
  PRL_DOUBLE width;
  PRL_DOUBLE height;
  PRL_DOUBLE hotx;
  PRL_DOUBLE hoty;
  PRL_UINT8 imageHash[8];
  PRL_UINT8 reserved[6*4];
} PRL_UIEMU_CURSOR_DESC;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_CURSOR_DESC_PTR Type

PRL_UIEMU_CURSOR_DESC_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_CURSOR_DESC* PRL_UIEMU_CURSOR_DESC_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_CURSOR_FORMAT Structure

PRL_UIEMU_CURSOR_FORMAT Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_CURSOR_FORMAT {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 alphaXor;
  PRL_UINT32 frames;
  PRL_UINT32 framet;
  PRL_UINT8 reserved[3*4];
} PRL_UIEMU_CURSOR_FORMAT;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_CURSOR_FORMAT_PTR Type

PRL_UIEMU_CURSOR_FORMAT_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_CURSOR_FORMAT* PRL_UIEMU_CURSOR_FORMAT_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_CURSOR_POS Structure

PRL_UIEMU_CURSOR_POS Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_CURSOR_POS {
  PRL_DOUBLE x;
  PRL_DOUBLE y;
  PRL_UINT8 reserved[4*4];
} PRL_UIEMU_CURSOR_POS;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_CURSOR_POS_PTR Type

PRL_UIEMU_CURSOR_POS_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_CURSOR_POS* PRL_UIEMU_CURSOR_POS_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_ELEMENT_AT_POS Structure

PRL_UIEMU_ELEMENT_AT_POS Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_ELEMENT_AT_POS {
  PRL_INT32 queryId;
  PRL_UINT32 queryFlags;
  PRL_INT32 posX;
  PRL_INT32 posY;
  PRL_INT32 propRectLeft;
  PRL_INT32 propRectTop;
  PRL_INT32 propRectRight;
  PRL_INT32 propRectBottom;
  PRL_UINT32 propControlType;
  PRL_UINT8 propIsControl;
  PRL_UINT8 propIsKbdFocusable;
  PRL_UINT8 propIsEnabled;
  PRL_UINT8 propValueIsReadOnly;
  PRL_UINT8 propRngValueIsReadOnly;
  PRL_UINT8 propIsTextEdit;
  PRL_UINT8 propCanInputTextGlobal;
} PRL_UIEMU_ELEMENT_AT_POS;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_ELEMENT_AT_POS_PTR Type

PRL_UIEMU_ELEMENT_AT_POS_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_ELEMENT_AT_POS* PRL_UIEMU_ELEMENT_AT_POS_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_ELEMENT_CONTROL_TYPE Enumeration

PRL_UIEMU_ELEMENT_CONTROL_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_ELEMENT_CONTROL_TYPE {
  PRL_UIEMU_ELEMENT_CONTROL_NONE = 0,
  PRL_UIEMU_ELEMENT_CONTROL_OTHER = 1,
  PRL_UIEMU_ELEMENT_CONTROL_EDIT = 2
} PRL_UIEMU_ELEMENT_CONTROL_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR Type

PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_ELEMENT_CONTROL_TYPE* PRL_UIEMU_ELEMENT_CONTROL_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_GESTURE_DATA_PINCH Structure

PRL_UIEMU_GESTURE_DATA_PINCH Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_GESTURE_DATA_PINCH {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_DOUBLE scale;
  PRL_DOUBLE velocity;
} PRL_UIEMU_GESTURE_DATA_PINCH;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_GESTURE_DATA_PINCH_PTR Type

PRL_UIEMU_GESTURE_DATA_PINCH_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_GESTURE_DATA_PINCH* PRL_UIEMU_GESTURE_DATA_PINCH_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_GESTURE_DATA_SMARTZOOM Structure

PRL_UIEMU_GESTURE_DATA_SMARTZOOM Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_GESTURE_DATA_SMARTZOOM {
  PRL_INT32 x;
  PRL_INT32 y;
} PRL_UIEMU_GESTURE_DATA_SMARTZOOM;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR Type

PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_GESTURE_DATA_SMARTZOOM* PRL_UIEMU_GESTURE_DATA_SMARTZOOM_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_GESTURE_EVENT Structure

PRL_UIEMU_GESTURE_EVENT Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_GESTURE_EVENT {
  PRL_UIEMU_GESTURE_TYPE type;
  PRL_UIEMU_GESTURE_STATE state;
  PRL_UINT32 reserved1;
  PRL_UINT32 reserved2;
  PRL_UINT8 gestureData[48];
} PRL_UIEMU_GESTURE_EVENT;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_GESTURE_EVENT_PTR Type

PRL_UIEMU_GESTURE_EVENT_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_GESTURE_EVENT* PRL_UIEMU_GESTURE_EVENT_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_GESTURE_STATE Enumeration

PRL_UIEMU_GESTURE_STATE Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_GESTURE_STATE {
  PRL_UIEMU_GESTURE_STATE_BEGIN = 1,
  PRL_UIEMU_GESTURE_STATE_CHANGE = 2,
  PRL_UIEMU_GESTURE_STATE_END = 3,
  PRL_UIEMU_GESTURE_STATE_CANCEL = 4
} PRL_UIEMU_GESTURE_STATE;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_GESTURE_STATE_PTR Type

PRL_UIEMU_GESTURE_STATE_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_GESTURE_STATE* PRL_UIEMU_GESTURE_STATE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_GESTURE_TYPE Enumeration

PRL_UIEMU_GESTURE_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_GESTURE_TYPE {
  PRL_UIEMU_GESTURE_TYPE_PINCH = 1,
  PRL_UIEMU_GESTURE_TYPE_SMARTZOOM = 2
} PRL_UIEMU_GESTURE_TYPE;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_GESTURE_TYPE_PTR Type

PRL_UIEMU_GESTURE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_GESTURE_TYPE* PRL_UIEMU_GESTURE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_INPUT_INFO Structure

PRL_UIEMU_INPUT_INFO Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_INPUT_INFO {
  PRL_UINT32 keyboardInputAvailable;
  PRL_UINT32 focusVersion;
  PRL_INT32 focusElemRectLeft;
  PRL_INT32 focusElemRectTop;
  PRL_INT32 focusElemRectRight;
  PRL_INT32 focusElemRectBottom;
  PRL_UINT8 reserved[4+4*4];
} PRL_UIEMU_INPUT_INFO;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_INPUT_INFO_PTR Type

PRL_UIEMU_INPUT_INFO_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_INPUT_INFO* PRL_UIEMU_INPUT_INFO_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UIEMU_MAKEUP_HINTING_RGN_PTR Type

PRL_UIEMU_MAKEUP_HINTING_RGN_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_MAKEUP_HINTING_RGN* PRL_UIEMU_MAKEUP_HINTING_RGN_PTR;
File

PrlApiHinting.h

Links
Other Types


PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE Enumeration

PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE {
  PUMHRT_TEXT = 0,
  PUMHRT_IMAGE = 1
} PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE;
File

PrlApiHinting.h

Links
Other Structs


PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR Type

PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE* PRL_UIEMU_MAKEUP_HINTING_RGN_TYPE_PTR;
File

PrlApiHinting.h

Links
Other Types


PRL_UIEMU_MMKEY Enumeration

PRL_UIEMU_MMKEY Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_MMKEY {
  PRL_UIEMU_MMKEY_SWIPE_LEFT_EDGE = 19,
  PRL_UIEMU_MMKEY_SWIPE_RIGHT_EDGE = 20,
  PRL_UIEMU_MMKEY_SWIPE_TOP_EDGE = 21,
  PRL_UIEMU_MMKEY_SWIPE_BOTTOM_EDGE = 22
} PRL_UIEMU_MMKEY;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_MMKEY_PTR Type

PRL_UIEMU_MMKEY_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_MMKEY* PRL_UIEMU_MMKEY_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_MOUSE_CLICK Enumeration

PRL_UIEMU_MOUSE_CLICK Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_MOUSE_CLICK {
  PMB_UIEMU_SINGLE_CLICK = 1,
  PMB_UIEMU_DOUBLE_CLICK = 2,
  PMB_UIEMU_TRIPLE_CLICK = 3
} PRL_UIEMU_MOUSE_CLICK;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_MOUSE_CLICK_PTR Type

PRL_UIEMU_MOUSE_CLICK_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_MOUSE_CLICK* PRL_UIEMU_MOUSE_CLICK_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_SCROLL_FLAGS Enumeration

PRL_UIEMU_SCROLL_FLAGS Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_SCROLL_FLAGS {
  PRL_UIEMU_SCROLL_FLAG_APPEND = 0,
  PRL_UIEMU_SCROLL_FLAG_NEW = 1
} PRL_UIEMU_SCROLL_FLAGS;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_SCROLL_FLAGS_PTR Type

PRL_UIEMU_SCROLL_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_SCROLL_FLAGS* PRL_UIEMU_SCROLL_FLAGS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_SCROLL_UNITS Enumeration

PRL_UIEMU_SCROLL_UNITS Enumeration
Other Structs
Syntax
typedef enum _PRL_UIEMU_SCROLL_UNITS {
  PRL_UIEMU_SCROLL_PIXELS = 1,
  PRL_UIEMU_SCROLL_LINES = 2,
  PRL_UIEMU_SCROLL_POINTS = 3
} PRL_UIEMU_SCROLL_UNITS;
File

PrlEnums.h

Links
Other Structs


PRL_UIEMU_SCROLL_UNITS_PTR Type

PRL_UIEMU_SCROLL_UNITS_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_SCROLL_UNITS* PRL_UIEMU_SCROLL_UNITS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UIEMU_SELECTION_HINTING_RGN_PTR Type

PRL_UIEMU_SELECTION_HINTING_RGN_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_SELECTION_HINTING_RGN* PRL_UIEMU_SELECTION_HINTING_RGN_PTR;
File

PrlApiHinting.h

Links
Other Types


PRL_UIEMU_VKEY Structure

PRL_UIEMU_VKEY Structure
Other Structs
Syntax
typedef struct _PRL_UIEMU_VKEY {
  PRL_UINT16 key;
  PRL_UINT16 ev;
  PRL_UINT32 reserved;
} PRL_UIEMU_VKEY;
File

PrlIoStructs.h

Links
Other Structs


PRL_UIEMU_VKEY_PTR Type

PRL_UIEMU_VKEY_PTR Type
Other Types
Syntax
typedef PRL_UIEMU_VKEY* PRL_UIEMU_VKEY_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_UINT8 Type

PRL_UINT8 Type
PRL_UINT Types

Unsigned 8 bit integer value

Syntax
typedef unsigned char PRL_UINT8;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT8_PTR Type

PRL_UINT8_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT8* PRL_UINT8_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT8_PTR_PTR Type

PRL_UINT8_PTR_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT8** PRL_UINT8_PTR_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT16 Type

PRL_UINT16 Type
PRL_UINT Types

Unsigned 16 bit integer value

Syntax
typedef unsigned short PRL_UINT16;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT16_PTR Type

PRL_UINT16_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT16* PRL_UINT16_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT16_PTR_PTR Type

PRL_UINT16_PTR_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT16** PRL_UINT16_PTR_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT32 Type

PRL_UINT32 Type
PRL_UINT Types

Unsigned 32 bit integer value

Syntax
typedef unsigned int PRL_UINT32;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT32_PTR Type

PRL_UINT32_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT32* PRL_UINT32_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT32_PTR_PTR Type

PRL_UINT32_PTR_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT32** PRL_UINT32_PTR_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT64 Type

PRL_UINT64 Type
PRL_UINT Types

Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use

Syntax
typedef unsigned long long PRL_UINT64;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT64_PTR Type

PRL_UINT64_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT64* PRL_UINT64_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UINT64_PTR_PTR Type

PRL_UINT64_PTR_PTR Type
PRL_UINT Types
Syntax
typedef PRL_UINT64** PRL_UINT64_PTR_PTR;
File

PrlTypes.h

Links
PRL_UINT Types


PRL_UNDO_DISKS_MODE Enumeration

PRL_UNDO_DISKS_MODE Enumeration
Other Structs

VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied

Syntax
typedef enum _PRL_UNDO_DISKS_MODE {
  PUD_DISABLE_UNDO_DISKS = 0,
  PUD_REVERSE_CHANGES = 1,
  PUD_COMMIT_CHANGES = 2,
  PUD_PROMPT_BEHAVIOUR = 3
} PRL_UNDO_DISKS_MODE;
File

PrlEnums.h

Links
Other Structs


PRL_UNDO_DISKS_MODE_PTR Type

PRL_UNDO_DISKS_MODE_PTR Type
Other Types
Syntax
typedef PRL_UNDO_DISKS_MODE* PRL_UNDO_DISKS_MODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_UPDATE_LICENSE_FLAGS Enumeration

PRL_UPDATE_LICENSE_FLAGS Enumeration
Other Structs

Update/Install license operations: Uses for PrlSrv_UpdateLicenseEx operation

Syntax
typedef enum _PRL_UPDATE_LICENSE_FLAGS {
  PUPLF_PROLONGATE_LICENSE = 1<<(PACF_MAX+1),
  PUPLF_KICK_TO_UDPATE_CURR_FILE_LICENSE = PUPLF_PROLONGATE_LICENSE,
  PUPLF_ACTIVATE_PERMANENT_LICENSE_ONLINE = 1<<(PACF_MAX+2),
  PUPLF_ACTIVATE_PERMANENT_LICENSE_OFFLINE = 1<<(PACF_MAX+3),
  PUPLF_CHECK_KEY_ONLY = 1<<(PACF_MAX+4),
  PUPLF_DEACTIVATE_CURRENT_LICENSE = 1<<(PACF_MAX+5),
  PUPLF_ACTIVATE_PRECACHED_KEY = 1<<(PACF_MAX+6),
  PUPLF_STORE_PRECACHED_KEY = 1<<(PACF_MAX+7),
  PUPLF_REMOVE_PRECACHED_KEY = 1<<(PACF_MAX+8),
  PUPLF_DEACTIVATE_CURRENT_LICENSE_OFFLINE_ALLOWED = 1<<(PACF_MAX+9),
  PUPLF_CHECK_KEY_ONLY_VOLUME = 1<<(PACF_MAX+10),
  PUPLF_REGISTER_CURRENT_LICENSE = 1<<(PACF_MAX+11)
} PRL_UPDATE_LICENSE_FLAGS;
File

PrlCommandsFlags.h

Members

PUPLF_KICK_TO_UDPATE_CURR_FILE_LICENSE
obsolete

Links
Other Structs


PRL_UPDATE_LICENSE_FLAGS_PTR Type

PRL_UPDATE_LICENSE_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_UPDATE_LICENSE_FLAGS* PRL_UPDATE_LICENSE_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration

PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration
Other Structs

USB autoconnect devices options

Syntax
typedef enum _PRL_USB_DEVICE_AUTO_CONNECT_OPTION {
  PUD_CONNECT_TO_PRIMARY_OS = 0,
  PUD_CONNECT_TO_GUEST_OS = 1,
  PUD_ASK_USER_WHAT_TODO = 2
} PRL_USB_DEVICE_AUTO_CONNECT_OPTION;
File

PrlEnums.h

Links
Other Structs


PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR Type

PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR Type
Other Types
Syntax
typedef PRL_USB_DEVICE_AUTO_CONNECT_OPTION* PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR;
File

PrlEnums.h

Links
Other Types


PRL_USB_DEVICE_CONNECT_REASON Enumeration

PRL_USB_DEVICE_CONNECT_REASON Enumeration
Other Structs

USB device connect/disconnect reason

Syntax
typedef enum _PRL_USB_DEVICE_CONNECT_REASON {
  PUD_CONNECTED_MANUALLY = 0,
  PUD_CONNECTED_AUTOMATICALLY = 1
} PRL_USB_DEVICE_CONNECT_REASON;
File

PrlEnums.h

Links
Other Structs


PRL_USB_DEVICE_CONNECT_REASON_PTR Type

PRL_USB_DEVICE_CONNECT_REASON_PTR Type
Other Types
Syntax
typedef PRL_USB_DEVICE_CONNECT_REASON* PRL_USB_DEVICE_CONNECT_REASON_PTR;
File

PrlEnums.h

Links
Other Types


PRL_USB_DEVICE_TYPE Enumeration

PRL_USB_DEVICE_TYPE Enumeration
Other Structs

USB device type

Syntax
typedef enum _PRL_USB_DEVICE_TYPE {
  PUDT_OTHER = 0,
  PUDT_HUB = 1,
  PUDT_VIDEO = 2,
  PUDT_FOTO = 3,
  PUDT_AUDIO = 4,
  PUDT_PRINTER = 5,
  PUDT_SCANNER = 6,
  PUDT_BLUETOOTH = 7,
  PUDT_WIRELESS = 8,
  PUDT_COMMUNICATION = 9,
  PUDT_KEYBOARD = 10,
  PUDT_MOUSE = 11,
  PUDT_SMART_CARD = 12,
  PUDT_DISK_STORAGE = 13,
  PUDT_ATAPI_STORAGE = 14,
  PUDT_APPLE_IPHONE = 1000,
  PUDT_APPLE_IPOD = 1001,
  PUDT_APPLE_IPAD = 1002,
  PUDT_APPLE_IETH = 1003,
  PUDT_RIM_BLACKBERRY = 2000,
  PUDT_GARMIN_GPS = 3000
} PRL_USB_DEVICE_TYPE;
File

PrlEnums.h

Members

PUDT_OTHER
unknown device type
PUDT_HUB
usb hub
PUDT_VIDEO
streaming usb video device
PUDT_FOTO
still image usb video device
PUDT_AUDIO
usb audio device
PUDT_PRINTER
usb printer
PUDT_SCANNER
usb scaner
PUDT_BLUETOOTH
usb bluetooth
PUDT_WIRELESS
usb wireless device
PUDT_COMMUNICATION
other usb communication device
PUDT_KEYBOARD
usb keyboard
PUDT_MOUSE
usb mouse
PUDT_SMART_CARD
usb smartcard reader
PUDT_DISK_STORAGE
usb storage
PUDT_ATAPI_STORAGE
usb CD/DVD-ROMs Some vendor specific usb device classes
PUDT_APPLE_IPHONE
apple iphone
PUDT_APPLE_IPOD
apple ipod
PUDT_APPLE_IPAD
apple ipad
PUDT_APPLE_IETH
apple ieth
PUDT_RIM_BLACKBERRY
rim blackberry
PUDT_GARMIN_GPS
garmin gps

Links
Other Structs


PRL_USB_DEVICE_TYPE_PTR Type

PRL_USB_DEVICE_TYPE_PTR Type
Other Types
Syntax
typedef PRL_USB_DEVICE_TYPE* PRL_USB_DEVICE_TYPE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VERSION_ENUM Enumeration

PRL_VERSION_ENUM Enumeration
Other Structs

Parallels license versions enumeration.

Syntax
typedef enum _PRL_VERSION_ENUM {
  PRL_VERSION_ANY = 0,
  PRL_VERSION_3X = 1,
  PRL_VERSION_4X = 2,
  PRL_VERSION_5X = 3,
  PRL_VERSION_6X = 4,
  PRL_VERSION_7X = 5,
  PRL_VERSION_8X = 6,
  PRL_VERSION_9X = 7,
  PRL_VERSION_10X = 8,
  PRL_VERSION_11X = 9
} PRL_VERSION_ENUM;
File

PrlEnums.h

Links
Other Structs


PRL_VERSION_ENUM_PTR Type

PRL_VERSION_ENUM_PTR Type
Other Types
Syntax
typedef PRL_VERSION_ENUM* PRL_VERSION_ENUM_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VIDEO_3D_ACCELERATION Enumeration

PRL_VIDEO_3D_ACCELERATION Enumeration
Other Structs

Video 3D acceleration

Syntax
typedef enum _PRL_VIDEO_3D_ACCELERATION {
  P3D_DISABLED = 0,
  P3D_ENABLED_HIGHEST = 1,
  P3D_ENABLED_DX9 = 2
} PRL_VIDEO_3D_ACCELERATION;
File

PrlEnums.h

Links
Other Structs


PRL_VIDEO_3D_ACCELERATION_PTR Type

PRL_VIDEO_3D_ACCELERATION_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_3D_ACCELERATION* PRL_VIDEO_3D_ACCELERATION_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VIDEO_RECEIVER_CONFIG Structure

PRL_VIDEO_RECEIVER_CONFIG Structure
Other Structs
Syntax
struct PRL_VIDEO_RECEIVER_CONFIG {
  PRL_CONST_STR streamerTransport;
  PRL_CONST_STR encoder;
  PRL_CONST_STR streamerOptions;
  PRL_INT32 fps;
  PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY geometry;
};
File

PrlApiVideoReceiver.h

Links
Other Structs


PRL_VIDEO_RECEIVER_CONFIG_PTR Type

PRL_VIDEO_RECEIVER_CONFIG_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_CONFIG* PRL_VIDEO_RECEIVER_CONFIG_PTR;
File

PrlApiVideoReceiver.h

Links
Other Types


PRL_VIDEO_RECEIVER_CONNECTION_STATE Enumeration

PRL_VIDEO_RECEIVER_CONNECTION_STATE Enumeration
Other Structs

Streaming connection status enum

Syntax
enum PRL_VIDEO_RECEIVER_CONNECTION_STATE {
  PVRCS_CONNECTED = 0,
  PVRCS_DISCONNECTED = 1,
  PVRCS_NO_CONNECTION = 2,
  PVRCS_CONNECTING = 3
};
File

PrlEnums.h

Links
Other Structs


PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR Type

PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_CONNECTION_STATE* PRL_VIDEO_RECEIVER_CONNECTION_STATE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VIDEO_RECEIVER_FRAME Structure

PRL_VIDEO_RECEIVER_FRAME Structure
Other Structs
Syntax
struct PRL_VIDEO_RECEIVER_FRAME {
  PRL_UINT64 no;
  PRL_INT64 pts;
  PRL_DISPLAY_BUFFER_FORMAT format;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 scale;
  PRL_UINT32 stride;
  PRL_UINT8 * data;
};
File

PrlApiVideoReceiver.h

Links
Other Structs


PRL_VIDEO_RECEIVER_FRAME_DESC Structure

PRL_VIDEO_RECEIVER_FRAME_DESC Structure
Other Structs
Syntax
struct PRL_VIDEO_RECEIVER_FRAME_DESC {
  PRL_UINT64 no;
  PRL_INT64 pts;
};
File

PrlApiVideoReceiver.h

Links
Other Structs


PRL_VIDEO_RECEIVER_FRAME_DESC_PTR Type

PRL_VIDEO_RECEIVER_FRAME_DESC_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_FRAME_DESC* PRL_VIDEO_RECEIVER_FRAME_DESC_PTR;
File

PrlApiVideoReceiver.h

Links
Other Types


PRL_VIDEO_RECEIVER_FRAME_PTR Type

PRL_VIDEO_RECEIVER_FRAME_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_FRAME* PRL_VIDEO_RECEIVER_FRAME_PTR;
File

PrlApiVideoReceiver.h

Links
Other Types


PRL_VIDEO_RECEIVER_STATISTICS Structure

PRL_VIDEO_RECEIVER_STATISTICS Structure
Other Structs
Syntax
struct PRL_VIDEO_RECEIVER_STATISTICS {
  PRL_UINT64 rtt;
  PRL_UINT64 recvTotalBytes;
  PRL_UINT64 recvBytesPerSecond;
  PRL_UINT64 packetsReceived;
  PRL_UINT64 packetsLost;
  PRL_UINT64 recvFramerate;
  PRL_UINT64 outputFramerate;
};
File

PrlApiVideoReceiver.h

Links
Other Structs


PRL_VIDEO_RECEIVER_STATISTICS_PTR Type

PRL_VIDEO_RECEIVER_STATISTICS_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_STATISTICS* PRL_VIDEO_RECEIVER_STATISTICS_PTR;
File

PrlApiVideoReceiver.h

Links
Other Types


PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY Structure

PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY Structure
Other Structs
Syntax
struct PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY {
  PRL_UINT32 maxWidth;
  PRL_UINT32 maxHeight;
  PRL_UINT32 maxPixels;
};
File

PrlApiVideoReceiver.h

Links
Other Structs


PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR Type

PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR Type
Other Types
Syntax
typedef PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY* PRL_VIDEO_RECEIVER_VIEWPORT_GEOMETRY_PTR;
File

PrlApiVideoReceiver.h

Links
Other Types


PRL_VIRTUAL_MACHINE_PROFILE Enumeration

PRL_VIRTUAL_MACHINE_PROFILE Enumeration
Other Structs

Virtual machine profiles enum

Syntax
typedef enum _PRL_VIRTUAL_MACHINE_PROFILE {
  VMP_PRODUCTIVITY = 0,
  VMP_GAMES = 1,
  VMP_SOFTWARE_DEVELOPER = 2,
  VMP_DESIGNER = 3
} PRL_VIRTUAL_MACHINE_PROFILE;
File

PrlEnums.h

Links
Other Structs


PRL_VIRTUAL_MACHINE_PROFILE_PTR Type

PRL_VIRTUAL_MACHINE_PROFILE_PTR Type
Other Types
Syntax
typedef PRL_VIRTUAL_MACHINE_PROFILE* PRL_VIRTUAL_MACHINE_PROFILE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VM_ACCELERATION_LEVEL Enumeration

PRL_VM_ACCELERATION_LEVEL Enumeration
PRL_VM Structs

Acceleration level

Syntax
typedef enum _PRL_VM_ACCELERATION_LEVEL {
  PVA_ACCELERATION_DISABLED = 0,
  PVA_ACCELERATION_NORMAL = 1,
  PVA_ACCELERATION_HIGH = 2
} PRL_VM_ACCELERATION_LEVEL;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_ACCELERATION_LEVEL_PTR Type

PRL_VM_ACCELERATION_LEVEL_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_ACCELERATION_LEVEL* PRL_VM_ACCELERATION_LEVEL_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_ACCESS_FOR_OTHERS Enumeration

PRL_VM_ACCESS_FOR_OTHERS Enumeration
PRL_VM Structs

Specifies virtual machine access rights.

Syntax
typedef enum _PRL_VM_ACCESS_FOR_OTHERS {
  PAO_VM_NOT_SHARED = 0,
  PAO_VM_SHARED_ON_VIEW,
  PAO_VM_SHARED_ON_VIEW_AND_RUN,
  PAO_VM_SHARED_ON_FULL_ACCESS
} PRL_VM_ACCESS_FOR_OTHERS;
File

PrlEnums.h

Type Parameters

PAO_VM_NOT_SHARED
Only the owner of the virtual machine has access to it. The machine will be hidden from all other users.
PAO_VM_SHARED_ON_VIEW
Other users can see the machine but they cannot run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_VIEW_AND_RUN
Other users can see the machine and they can also run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_FULL_ACCESS
Other users have full access to the virtual machine.

Links
PRL_VM Structs


PRL_VM_ACCESS_FOR_OTHERS_PTR Type

PRL_VM_ACCESS_FOR_OTHERS_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_ACCESS_FOR_OTHERS* PRL_VM_ACCESS_FOR_OTHERS_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_ACTION Enumeration

PRL_VM_ACTION Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_ACTION {
  PVA_PRESTART = 0,
  PVA_POSTSTART = 1,
  PVA_PRESTOP = 2,
  PVA_POSTSTOP = 3
} PRL_VM_ACTION;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_ACTION_ON_STOP Enumeration

PRL_VM_ACTION_ON_STOP Enumeration
PRL_VM Structs

Action when VM gets stopped

Syntax
typedef enum _PRL_VM_ACTION_ON_STOP {
  PAS_KEEP_VM_WINDOW_OPEN = 0,
  PAS_CLOSE_VM_WINDOW = 1,
  PAS_QUIT_APPLICATION = 2
} PRL_VM_ACTION_ON_STOP;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_ACTION_ON_STOP_PTR Type

PRL_VM_ACTION_ON_STOP_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_ACTION_ON_STOP* PRL_VM_ACTION_ON_STOP_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration

PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration
PRL_VM Structs

Action on VM when VM window gets closed

Syntax
typedef enum _PRL_VM_ACTION_ON_WINDOW_CLOSE {
  PWC_VM_UNKNOWN_ACTION = 0xffff,
  PWC_VM_STOP = 0,
  PWC_VM_SUSPEND = 1,
  PWC_VM_ASK_USER = 2,
  PWC_VM_PAUSE = 3,
  PWC_VM_SHUTDOWN = 4,
  PWC_VM_DO_NOTHING = 5
} PRL_VM_ACTION_ON_WINDOW_CLOSE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR Type

PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_ACTION_ON_WINDOW_CLOSE* PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_ACTION_PTR Type

PRL_VM_ACTION_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_ACTION* PRL_VM_ACTION_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_AUTOSTART_OPTION Enumeration

PRL_VM_AUTOSTART_OPTION Enumeration
PRL_VM Structs

VM autostart options

Syntax
typedef enum _PRL_VM_AUTOSTART_OPTION {
  PAO_VM_START_MANUAL = 0,
  PAO_VM_START_ON_LOAD = 1,
  PAO_VM_START_ON_RELOAD = 2,
  PAO_VM_START_ON_GUI_APP_STARTUP = 3,
  PAO_VM_START_ON_GUI_VM_WINDOW_OPEN = 4,
  PAO_VM_START_ON_GUI_WINDOW_LOAD = PAO_VM_START_ON_GUI_APP_STARTUP
} PRL_VM_AUTOSTART_OPTION;
File

PrlEnums.h

Members

PAO_VM_START_ON_GUI_WINDOW_LOAD
OBSOLETE CONSTANTS

Links
PRL_VM Structs


PRL_VM_AUTOSTART_OPTION_PTR Type

PRL_VM_AUTOSTART_OPTION_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_AUTOSTART_OPTION* PRL_VM_AUTOSTART_OPTION_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_AUTOSTOP_OPTION Enumeration

PRL_VM_AUTOSTOP_OPTION Enumeration
PRL_VM Structs

VM autostop options

Syntax
typedef enum _PRL_VM_AUTOSTOP_OPTION {
  PAO_VM_STOP = 0,
  PAO_VM_SUSPEND = 1,
  PAO_VM_SHUTDOWN = 2
} PRL_VM_AUTOSTOP_OPTION;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_AUTOSTOP_OPTION_PTR Type

PRL_VM_AUTOSTOP_OPTION_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_AUTOSTOP_OPTION* PRL_VM_AUTOSTOP_OPTION_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_BACKUP_FLAGS Enumeration

PRL_VM_BACKUP_FLAGS Enumeration
PRL_VM Structs

VM backup functionality flags set

Syntax
typedef enum _PRL_VM_BACKUP_FLAGS {
  PBSL_LOW_SECURITY = PSL_LOW_SECURITY,
  PBSL_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PBSL_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PBT_FULL = 1<<(PACF_MAX+1),
  PBT_INCREMENTAL = 1<<(PACF_MAX+2),
  PBT_DIFFERENTIAL = 1<<(PACF_MAX+3),
  PBT_RESTORE_TO_COPY = 1<<(PACF_MAX+4),
  PBT_IGNORE_NOT_EXISTS = 1<<(PACF_MAX+5),
  PBT_UNCOMPRESSED = 1<<(PACF_MAX+6),
  PBT_VM = 1<<(PACF_MAX+7),
  PBT_CT = 1<<(PACF_MAX+8),
  PBT_BACKUP_ID = 1<<(PACF_MAX+9),
  PBT_CHAIN = 1<<(PACF_MAX+10)
} PRL_VM_BACKUP_FLAGS;
File

PrlCommandsFlags.h

Type Parameters

PBT_FULL
full backup
PBT_INCREMENTAL
incremental backup
PBT_DIFFERENTAL
differental backup
PBT_RESTORE_TO_COPY
change Vm name/uuid/MAC address on restore
PBT_UNCOMPRESSED
uncompressed backup
PBT_VM
for virtual mashines
PBT_CT
for containers
PBT_BACKUP_ID
get information about a certain backup
PBT_CHAIN
get information about the whole backup chain for a certain backup

Links
PRL_VM Structs


PRL_VM_BACKUP_TYPE Enumeration

PRL_VM_BACKUP_TYPE Enumeration
PRL_VM Structs

Hint about the type of VE inside a backup archive

Syntax
typedef enum _PRL_VM_BACKUP_TYPE {
  PVBT_VM = 0,
  PVBT_CT_VZFS = 1,
  PVBT_CT_PLOOP = 2,
  PVBT_CT_VZWIN = 3
} PRL_VM_BACKUP_TYPE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_BACKUP_TYPE_PTR Type

PRL_VM_BACKUP_TYPE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_BACKUP_TYPE* PRL_VM_BACKUP_TYPE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_BOOT_ORDER Enumeration

PRL_VM_BOOT_ORDER Enumeration
PRL_VM Structs

VM boot order

Syntax
typedef enum _PRL_VM_BOOT_ORDER {
  PBO_HDD_CD_FLOPPY = 0,
  PBO_FLOPPY_HDD_CD = 1,
  PBO_CD_HDD_FLOPPY = 2
} PRL_VM_BOOT_ORDER;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_BOOT_ORDER_PTR Type

PRL_VM_BOOT_ORDER_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_BOOT_ORDER* PRL_VM_BOOT_ORDER_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_COLOR Enumeration

PRL_VM_COLOR Enumeration
PRL_VM Structs

VM colors

Syntax
typedef enum _PRL_VM_COLOR {
  PVC_COLOR_RED = 0x00FA645A,
  PVC_COLOR_ORANGE = 0x00F6AA44,
  PVC_COLOR_YELLOW = 0x00EFDB47,
  PVC_COLOR_GREEN = 0x00B4D747,
  PVC_COLOR_BLUE = 0x005AA3FF,
  PVC_COLOR_PURPLE = 0x00C08ED8,
  PVC_COLOR_GREY = 0x00808080,
  PVC_NO_COLOR = 0x00000000
} PRL_VM_COLOR;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_COLOR_PTR Type

PRL_VM_COLOR_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_COLOR* PRL_VM_COLOR_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_COMMIT_FLAGS Enumeration

PRL_VM_COMMIT_FLAGS Enumeration
PRL_VM Structs

PrlVm_CommitEx flags

Syntax
typedef enum _PRL_VM_COMMIT_FLAGS {
  PVCF_DESTROY_HDD_BUNDLE = 1<<(PACF_MAX+1),
  PVCF_WAIT_FOR_APPLY = 1<<(PACF_MAX+2),
  PEVF_WAIT_FOR_APPLY = PVCF_WAIT_FOR_APPLY,
  PVCF_DESTROY_HDD_BUNDLE_FORCE = 1<<(PACF_MAX+3),
  PVCF_DETACH_HDD_BUNDLE = 1<<(PACF_MAX+4),
  PVCF_RENAME_EXT_DISKS = 1<<(PACF_MAX+5)
} PRL_VM_COMMIT_FLAGS;
File

PrlCommandsFlags.h

Members

PVCF_DESTROY_HDD_BUNDLE
specifies to destroy HDD bundle physically on hard disk remove operation
PVCF_WAIT_FOR_APPLY
wait for apply
PEVF_WAIT_FOR_APPLY
to provide compatibility
PVCF_DESTROY_HDD_BUNDLE_FORCE
destroy HDD bundle physically even if used in snapshots

Links
PRL_VM Structs


PRL_VM_CONFIG_SECTIONS Enumeration

PRL_VM_CONFIG_SECTIONS Enumeration
PRL_VM Structs

VM configuration sections

Syntax
typedef enum _PRL_VM_CONFIG_SECTIONS {
  PVC_VALIDATE_CHANGES_ONLY = 0,
  PVC_ALL = 1,
  PVC_GENERAL_PARAMETERS = 2,
  PVC_BOOT_OPTION = 3,
  PVC_REMOTE_DISPLAY = 4,
  PVC_SHARED_FOLDERS = 5,
  PVC_CPU = 6,
  PVC_MAIN_MEMORY = 7,
  PVC_VIDEO_MEMORY = 8,
  PVC_FLOPPY_DISK = 9,
  PVC_CD_DVD_ROM = 10,
  PVC_HARD_DISK = 11,
  PVC_NETWORK_ADAPTER = 12,
  PVC_SOUND = 13,
  PVC_SERIAL_PORT = 14,
  PVC_PARALLEL_PORT = 15,
  PVC_IDE_DEVICES = 16,
  PVC_SCSI_DEVICES = 17,
  PVC_GENERIC_PCI = 18,
  PVC_OFFLINE_MANAGEMENT_SETTINGS = 19,
  PVC_LICENSE_RESTRICTIONS = 20,
  PVC_SATA_DEVICES = 21,
  PVC_LAST_SECTION = PVC_SATA_DEVICES
} PRL_VM_CONFIG_SECTIONS;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_CONFIG_SECTIONS_PTR Type

PRL_VM_CONFIG_SECTIONS_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_CONFIG_SECTIONS* PRL_VM_CONFIG_SECTIONS_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_DEV_EMULATION_TYPE Enumeration

PRL_VM_DEV_EMULATION_TYPE Enumeration
PRL_VM Structs

VM device emulation type

Syntax
typedef enum _PRL_VM_DEV_EMULATION_TYPE {
  PDT_ANY_TYPE = 0xffff,
  PDT_USE_REAL_DEVICE = 0,
  PDT_USE_IMAGE_FILE = 1,
  PDT_USE_OUTPUT_FILE = 2,
  PDT_USE_OTHER = 3,
  PDT_USE_DIRECT_ASSIGN = 4,
  PDT_USE_FILE_SYSTEM = 5,
  PDT_USE_REAL_FLOPPY = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_HDD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_CDDVD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_SERIAL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_SERIAL_PORT_SOCKET_MODE = PDT_USE_OTHER,
  PDT_USE_REAL_PARALLEL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_PARALLEL_PORT_PRINTER_MODE = PDT_USE_OTHER,
  PDT_USE_PARALLEL_PORT_PRINT_TO_PDF_MODE = PDT_USE_IMAGE_FILE,
  PDT_USE_HOST_ONLY_NETWORK = PDT_USE_REAL_DEVICE,
  PDT_USE_SHARED_NETWORK = PDT_USE_IMAGE_FILE,
  PDT_USE_BRIDGE_ETHERNET = PDT_USE_OUTPUT_FILE,
  PDT_USE_AC97_SOUND = PDT_USE_REAL_DEVICE,
  PDT_USE_CREATIVE_SB16_SOUND = PDT_USE_IMAGE_FILE,
  PDT_USE_REAL_USB_CONTROLLER = PDT_USE_REAL_DEVICE,
  PDT_USE_BOOTCAMP = PDT_USE_OTHER
} PRL_VM_DEV_EMULATION_TYPE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_DEV_EMULATION_TYPE_PTR Type

PRL_VM_DEV_EMULATION_TYPE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_DEV_EMULATION_TYPE* PRL_VM_DEV_EMULATION_TYPE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration

PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration
PRL_VM Structs

App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app

Syntax
typedef enum _PRL_VM_EXEC_APP_FILE_DESCRIPTOR {
  PFD_STDOUT = 1<<(PACF_MAX+1),
  PFD_STDERR = 1<<(PACF_MAX+2),
  PFD_STDIN = 1<<(PACF_MAX+3),
  PFD_ALL = (PFD_STDOUT | PFD_STDERR | PFD_STDIN)
} PRL_VM_EXEC_APP_FILE_DESCRIPTOR;
File

PrlCommandsFlags.h

Links
PRL_VM Structs


PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR Type

PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_EXEC_APP_FILE_DESCRIPTOR* PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR;
File

PrlCommandsFlags.h

Links
PRL_VM Types


PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration

PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration
PRL_VM Structs

Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result PRPM_RUN_PROGRAM_IN_SHELL : run program via shell and in shell environment PRPM_RUN_PROGRAM_ENTER : run shell in guest

Syntax
typedef enum _PRL_VM_EXEC_RUN_PROGRAM_MODES {
  PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY = 1<<(PACF_MAX+4),
  PRPM_RUN_PROGRAM_IN_SHELL = 1<<(PACF_MAX+5),
  PRPM_RUN_PROGRAM_ENTER = 1<<(PACF_MAX+6)
} PRL_VM_EXEC_RUN_PROGRAM_MODES;
File

PrlCommandsFlags.h

Links
PRL_VM Structs


PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR Type

PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_EXEC_RUN_PROGRAM_MODES* PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR;
File

PrlCommandsFlags.h

Links
PRL_VM Types


PRL_VM_LOCATION Enumeration

PRL_VM_LOCATION Enumeration
PRL_VM Structs

VM files location set PVL_UNKNOWN : VM files location unknown (mostly for invalid VMs) PVL_LOCAL_FS : VM files placed on local file system PVL_REMOTE_FS : VM files placed on remote file system PVL_USB_DRIVE : VM files placed on external USB drive PVL_FIREWIRE_DRIVE : VM files placed on external FireWire drive

Syntax
typedef enum _PRL_VM_LOCATION {
  PVL_UNKNOWN = 0,
  PVL_LOCAL_FS = 1,
  PVL_REMOTE_FS = 2,
  PVL_USB_DRIVE = 3,
  PVL_FIREWIRE_DRIVE = 4
} PRL_VM_LOCATION;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_LOCATION_PTR Type

PRL_VM_LOCATION_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_LOCATION* PRL_VM_LOCATION_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_MIGRATION_FLAGS Enumeration

PRL_VM_MIGRATION_FLAGS Enumeration
PRL_VM Structs

VM migration functionality flags set

Syntax
typedef enum _PRL_VM_MIGRATION_FLAGS {
  PVMSL_LOW_SECURITY = PSL_LOW_SECURITY,
  PVMSL_NORMAL_SECURITY = PACF_NORMAL_SECURITY,
  PVMSL_HIGH_SECURITY = PACF_HIGH_SECURITY,
  PVMT_COLD_MIGRATION = 1<<(PACF_MAX+1),
  PVMT_WARM_MIGRATION = 1<<(PACF_MAX+2),
  PVMT_HOT_MIGRATION = 1<<(PACF_MAX+3),
  PVM_DONT_RESUME_VM = 1<<(PACF_MAX+4),
  PVMT_DONT_RESUME_VM = PVM_DONT_RESUME_VM,
  PVMT_CLONE_MODE = 1<<(PACF_MAX+5),
  PVMT_SWITCH_TEMPLATE = 1<<(PACF_MAX+6),
  PVMT_CHANGE_SID = 1<<(PACF_MAX+7),
  PVMT_IGNORE_EXISTING_BUNDLE = 1<<(PACF_MAX+8),
  PVMT_REMOVE_SOURCE_BUNDLE = 1<<(PACF_MAX+9)
} PRL_VM_MIGRATION_FLAGS;
File

PrlCommandsFlags.h

Type Parameters

PVMT_COLD_MIGRATION
VM migration with interruption of VM services (VM will be stopped on migration time).
PVMT_WARM_MIGRATION
VM services will have quite long downtime during migration but won't be interrupted.
PVMT_HOT_MIGRATION
VM services will have short downtime during migration without any interruption.
PVMT_DONT_RESUME_VM
do not start running VM after migration
PVMT_CLONE_MODE
preserves source VM
PVMT_SWITCH_TEMPLATE
applable just in clone mode - lets to clone remotely VM to template
PVMT_CHANGE_SID
for Windows VMs/containers lets to change SID after remote clone
PVMT_IGNORE_EXISTING_BUNDLE
do not fail if Vm bundle exist. For clone Vm on mounted iSCSI storage

Links
PRL_VM Structs


PRL_VM_MOUSE_CURSOR_STATE Enumeration

PRL_VM_MOUSE_CURSOR_STATE Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_MOUSE_CURSOR_STATE {
  PTS_NO_CURSOR = 0,
  PTS_SLIDING_CURSOR = 1,
  PTS_MOVING_CURSOR = 2
} PRL_VM_MOUSE_CURSOR_STATE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_MOUSE_CURSOR_STATE_PTR Type

PRL_VM_MOUSE_CURSOR_STATE_PTR Type
Other Types
Syntax
typedef PRL_VM_MOUSE_CURSOR_STATE* PRL_VM_MOUSE_CURSOR_STATE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VM_MOUSE_STATE Enumeration

PRL_VM_MOUSE_STATE Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_MOUSE_STATE {
  PTS_RELATIVE_MOUSE = 0,
  PTS_SLIDING_MOUSE = 1,
  PTS_ABSOLUTE_MOUSE = 2
} PRL_VM_MOUSE_STATE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_MOUSE_STATE_PTR Type

PRL_VM_MOUSE_STATE_PTR Type
Other Types
Syntax
typedef PRL_VM_MOUSE_STATE* PRL_VM_MOUSE_STATE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VM_NET_ADAPTER_TYPE Enumeration

PRL_VM_NET_ADAPTER_TYPE Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_NET_ADAPTER_TYPE {
  PNT_UNDEFINED = 0,
  PNT_RTL = 1,
  PNT_E1000 = 2,
  PNT_VIRTIO = 3,
  PNT_E1000E = 4
} PRL_VM_NET_ADAPTER_TYPE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_NET_ADAPTER_TYPE_PTR Type

PRL_VM_NET_ADAPTER_TYPE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_NET_ADAPTER_TYPE* PRL_VM_NET_ADAPTER_TYPE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_NET_ADAPTER_WIFI_RULE Enumeration

PRL_VM_NET_ADAPTER_WIFI_RULE Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_NET_ADAPTER_WIFI_RULE {
  PNWR_GENERATED_MAC = 0,
  PNWR_HOST_MAC = 1,
  PNWR_AUTO = 2
} PRL_VM_NET_ADAPTER_WIFI_RULE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_NET_ADAPTER_WIFI_RULE_PTR Type

PRL_VM_NET_ADAPTER_WIFI_RULE_PTR Type
Other Types
Syntax
typedef PRL_VM_NET_ADAPTER_WIFI_RULE* PRL_VM_NET_ADAPTER_WIFI_RULE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VM_NORMAL_START_FLAGS Enumeration

PRL_VM_NORMAL_START_FLAGS Enumeration
PRL_VM Structs

VM normal-mode start flags: PSM_VM_START_IGNORE_HA_CLUSTER : do not register VM on HA cluster in any case (for server mode only)

Syntax
typedef enum _PRL_VM_NORMAL_START_FLAGS {
  PNSF_VM_START_WAIT = 1<<(PACF_MAX+2)
} PRL_VM_NORMAL_START_FLAGS;
File

PrlCommandsFlags.h

Members

PNSF_VM_START_WAIT
PNSF_VM_START_IGNORE_HA_CLUSTER = 1<<(PACF_MAX+1), This flag is unused

Links
PRL_VM Structs


PRL_VM_NORMAL_START_FLAGS_PTR Type

PRL_VM_NORMAL_START_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_VM_NORMAL_START_FLAGS* PRL_VM_NORMAL_START_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_VM_PRIORITY Enumeration

PRL_VM_PRIORITY Enumeration
PRL_VM Structs

Background/foreground VM processes priority

Syntax
typedef enum _PRL_VM_PRIORITY {
  PVR_PRIORITY_LOW = 0,
  PVR_PRIORITY_NORMAL = 1,
  PVR_PRIORITY_HIGH = 2
} PRL_VM_PRIORITY;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_PRIORITY_PTR Type

PRL_VM_PRIORITY_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_PRIORITY* PRL_VM_PRIORITY_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_REMOTE_DISPLAY_MODE Enumeration

PRL_VM_REMOTE_DISPLAY_MODE Enumeration
PRL_VM Structs

Parallels remote desktop modes

Syntax
typedef enum _PRL_VM_REMOTE_DISPLAY_MODE {
  PRD_DISABLED = 0,
  PRD_AUTO,
  PRD_MANUAL
} PRL_VM_REMOTE_DISPLAY_MODE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_REMOTE_DISPLAY_MODE_PTR Type

PRL_VM_REMOTE_DISPLAY_MODE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_REMOTE_DISPLAY_MODE* PRL_VM_REMOTE_DISPLAY_MODE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_SMARTGUARD_SCHEMA Enumeration

PRL_VM_SMARTGUARD_SCHEMA Enumeration
PRL_VM Structs

SmartGuard schema

Syntax
typedef enum _PRL_VM_SMARTGUARD_SCHEMA {
  PVSS_OPTIMIZED_FOR_TIME_MACHINE = 1,
  PVSS_CUSTOM = 2
} PRL_VM_SMARTGUARD_SCHEMA;
File

PrlEnums.h

Members

PVSS_OPTIMIZED_FOR_TIME_MACHINE
Automatic schema for time machine
PVSS_CUSTOM
User defined schema

Links
PRL_VM Structs


PRL_VM_SMARTGUARD_SCHEMA_PTR Type

PRL_VM_SMARTGUARD_SCHEMA_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_SMARTGUARD_SCHEMA* PRL_VM_SMARTGUARD_SCHEMA_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_START_LOGIN_MODE Enumeration

PRL_VM_START_LOGIN_MODE Enumeration
PRL_VM Structs

VM start login mode

Syntax
typedef enum _PRL_VM_START_LOGIN_MODE {
  PLM_START_ACCOUNT = 0,
  PLM_ROOT_ACCOUNT = 1,
  PLM_USER_ACCOUNT = 2,
  PLM_START_ACOUNT = PLM_START_ACCOUNT,
  PLM_ROOT_ACOUNT = PLM_ROOT_ACCOUNT,
  PLM_USER_ACOUNT = PLM_USER_ACCOUNT
} PRL_VM_START_LOGIN_MODE;
File

PrlEnums.h

Members

PLM_START_ACOUNT
Obsolete values for compatibility

Links
PRL_VM Structs


PRL_VM_START_LOGIN_MODE_PTR Type

PRL_VM_START_LOGIN_MODE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_START_LOGIN_MODE* PRL_VM_START_LOGIN_MODE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_START_MODE Enumeration

PRL_VM_START_MODE Enumeration
PRL_VM Structs

VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode PSM_VM_START_FOR_COMPACT : start VM only for compacting disk operation

Syntax
typedef enum _PRL_VM_START_MODE {
  PSM_VM_START = 1<<(PACF_MAX+1),
  PSM_VM_SAFE_START = 1<<(PACF_MAX+2),
  PSM_VM_START_FOR_COMPACT = 1<<(PACF_MAX+3),
  PSM_VM_START_LAST_ITEM = PSM_VM_START_FOR_COMPACT
} PRL_VM_START_MODE;
File

PrlCommandsFlags.h

Members

PSM_VM_START_LAST_ITEM
PSM_VM_START_LAST_ITEM has to be equal the last mode

Links
PRL_VM Structs


PRL_VM_START_MODE_PTR Type

PRL_VM_START_MODE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_START_MODE* PRL_VM_START_MODE_PTR;
File

PrlCommandsFlags.h

Links
PRL_VM Types


PRL_VM_STATISTICS_FLAGS Enumeration

PRL_VM_STATISTICS_FLAGS Enumeration
PRL_VM Structs

PrlVm_GetStatisticsEx flags

Syntax
typedef enum _PRL_VM_STATISTICS_FLAGS {
  PVMSF_HOST_DISK_SPACE_USAGE_ONLY = 1<<(PACF_MAX+1),
  PVMSF_GUEST_OS_INFORMATION_ONLY = 1<<(PACF_MAX+2)
} PRL_VM_STATISTICS_FLAGS;
File

PrlCommandsFlags.h

Links
PRL_VM Structs


PRL_VM_STATISTICS_FLAGS_PTR Type

PRL_VM_STATISTICS_FLAGS_PTR Type
Other Types
Syntax
typedef PRL_VM_STATISTICS_FLAGS* PRL_VM_STATISTICS_FLAGS_PTR;
File

PrlCommandsFlags.h

Links
Other Types


PRL_VM_STOP_FLAGS Enumeration

PRL_VM_STOP_FLAGS Enumeration
PRL_VM Structs

Virtual machine shutdown options.

Syntax
typedef enum _PRL_VM_STOP_FLAGS {
  PSF_FORCE = 1<<(PACF_MAX+1),
  PSF_NOFORCE = 1<<(PACF_MAX+2)
} PRL_VM_STOP_FLAGS;
File

PrlCommandsFlags.h

Remarks
  • PSF_FORCE : forcibly stop the virtual machine if shutdown timed out.
  • PSF_NOFORCE : do nothing if the virtual machine shutdown timed out.
Links
PRL_VM Structs


PRL_VM_STOP_MODE Enumeration

PRL_VM_STOP_MODE Enumeration
PRL_VM Structs

Vm stop modes

Syntax
typedef enum _PRL_VM_STOP_MODE {
  PSM_KILL = 0,
  PSM_SHUTDOWN = 1,
  PSM_ACPI = 2,
  PSM_LAST = PSM_ACPI
} PRL_VM_STOP_MODE;
File

PrlEnums.h

Members

PSM_LAST
Should equals to the last item

Links
PRL_VM Structs


PRL_VM_STOP_MODE_MASK Macro

PRL_VM_STOP_MODE_MASK Macro
Other Macros
Syntax
#define PRL_VM_STOP_MODE_MASK 0xff
File

PrlEnums.h

Links
Other Macros


PRL_VM_STORE_VALUE_FLAGS Enumeration

PRL_VM_STORE_VALUE_FLAGS Enumeration
PRL_VM Structs

Store value by specified keys on server options.

Syntax
typedef enum _PRL_VM_STORE_VALUE_FLAGS {
  PSV_CALC_BOOT_CAMP_SIZE = 1<<(PACF_MAX+1)
} PRL_VM_STORE_VALUE_FLAGS;
File

PrlCommandsFlags.h

Remarks
  • PSV_CALC_BOOT_CAMP : calculate VM size with Boot Camp disks
Links
PRL_VM Structs


PRL_VM_TOOLS_STATE Enumeration

PRL_VM_TOOLS_STATE Enumeration
PRL_VM Structs

Virtual machine tools states enumeration

Syntax
typedef enum _PRL_VM_TOOLS_STATE {
  PTS_UNKNOWN = 0,
  PTS_POSSIBLY_INSTALLED = PTS_UNKNOWN,
  PTS_NOT_INSTALLED = 1,
  PTS_INSTALLED = 2,
  PTS_OUTDATED = 3
} PRL_VM_TOOLS_STATE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_TOOLS_STATE_PTR Type

PRL_VM_TOOLS_STATE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_TOOLS_STATE* PRL_VM_TOOLS_STATE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_TYPE Enumeration

PRL_VM_TYPE Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_TYPE {
  PVT_VM = 0,
  PVT_CT = 1
} PRL_VM_TYPE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_TYPE_FLAGS Enumeration

PRL_VM_TYPE_FLAGS Enumeration
PRL_VM Structs
Syntax
typedef enum _PRL_VM_TYPE_FLAGS {
  PVTF_VM = 1<<(PACF_MAX+1),
  PVTF_CT = 1<<(PACF_MAX+2)
} PRL_VM_TYPE_FLAGS;
File

PrlCommandsFlags.h

Links
PRL_VM Structs


PRL_VM_TYPE_PTR Type

PRL_VM_TYPE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_TYPE* PRL_VM_TYPE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VM_WINDOW_MODE Enumeration

PRL_VM_WINDOW_MODE Enumeration
PRL_VM Structs

VM window mode

Syntax
typedef enum _PRL_VM_WINDOW_MODE {
  PWM_DEFAULT_WINDOW_MODE = 0,
  PWM_WINDOWED_WINDOW_MODE = 1,
  PWM_FULL_SCREEN_WINDOW_MODE = 2,
  PWM_COHERENCE_WINDOW_MODE = 3,
  PWM_MODALITY_WINDOW_MODE = 4
} PRL_VM_WINDOW_MODE;
File

PrlEnums.h

Links
PRL_VM Structs


PRL_VM_WINDOW_MODE_PTR Type

PRL_VM_WINDOW_MODE_PTR Type
PRL_VM Types
Syntax
typedef PRL_VM_WINDOW_MODE* PRL_VM_WINDOW_MODE_PTR;
File

PrlEnums.h

Links
PRL_VM Types


PRL_VMCTG_EVENT Enumeration

PRL_VMCTG_EVENT Enumeration
Other Structs

Tools events, passed to the callback (see PRL_VMCTG_TOOL_DESC and PRL_TOOL_HANDLER_PTR above)

Syntax
typedef enum _PRL_VMCTG_EVENT {
  TEV_DATA_RECEIVED,
  TEV_CONNECTED,
  TEV_DISCONNECTED
} PRL_VMCTG_EVENT;
File

PrlEnums.h

Members

TEV_DATA_RECEIVED
pData is PRL_TOOL_DATA_RECEIVED
TEV_CONNECTED
pData is null
TEV_DISCONNECTED
pData is null

Links
Other Structs


PRL_VMCTG_EVENT_PTR Type

PRL_VMCTG_EVENT_PTR Type
Other Types
Syntax
typedef PRL_VMCTG_EVENT* PRL_VMCTG_EVENT_PTR;
File

PrlEnums.h

Links
Other Types


PRL_VMCTG_TOOL_DATA_RECEIVED Structure

PRL_VMCTG_TOOL_DATA_RECEIVED Structure
Other Structs
Syntax
typedef struct _PRL_VMCTG_TOOL_DATA_RECEIVED {
  PRL_SIZE uSize;
  PRL_VOID_PTR pData;
  PRL_BOOL bKeepBuffer;
} PRL_VMCTG_TOOL_DATA_RECEIVED;
File

PrlIoStructs.h

Links
Other Structs


PRL_VMCTG_TOOL_DATA_RECEIVED_PTR Type

PRL_VMCTG_TOOL_DATA_RECEIVED_PTR Type
Other Types
Syntax
typedef PRL_VMCTG_TOOL_DATA_RECEIVED* PRL_VMCTG_TOOL_DATA_RECEIVED_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_VMCTG_TOOL_DESC Structure

PRL_VMCTG_TOOL_DESC Structure
Other Structs

Describes the tool to be registered @see PrlVm_RegisterTool()

Syntax
typedef struct _PRL_VMCTG_TOOL_DESC {
  PRL_SIZE uSize;
  PRL_UINT32 nToolId;
  PRL_VMCTG_TOOL_HANDLER_PTR pCallBack;
  PRL_VOID_PTR pUserData;
} PRL_VMCTG_TOOL_DESC;
File

PrlIoStructs.h

Links
Other Structs


PRL_VMCTG_TOOL_DESC_PTR Type

PRL_VMCTG_TOOL_DESC_PTR Type
Other Types
Syntax
typedef PRL_VMCTG_TOOL_DESC* PRL_VMCTG_TOOL_DESC_PTR;
File

PrlIoStructs.h

Links
Other Types


PRL_VOID Type

PRL_VOID Type
PRL_VOID Types

Void pointers (for unified naming)

Syntax
typedef void PRL_VOID;
File

PrlTypes.h

Links
PRL_VOID Types


PRL_VOID_PTR Type

PRL_VOID_PTR Type
PRL_VOID Types
Syntax
typedef PRL_VOID* PRL_VOID_PTR;
File

PrlTypes.h

Links
PRL_VOID Types


PRL_VOID_PTR_PTR Type

PRL_VOID_PTR_PTR Type
PRL_VOID Types
Syntax
typedef PRL_VOID_PTR* PRL_VOID_PTR_PTR;
File

PrlTypes.h

Links
PRL_VOID Types


PRL_VTD_STATUS_CODE Enumeration

PRL_VTD_STATUS_CODE Enumeration
Other Structs

VTD status code

Syntax
typedef enum _PRL_VTD_STATUS_CODE {
  PVSC_DMAR_NOT_FOUND = -5,
  PVSC_DMAR_ERROR = -4,
  PVSC_ACPI_ERROR = -3,
  PVSC_HARDWARE_ERROR = -2,
  PVSC_INTERNAL_ERROR = -1,
  PVSC_NOT_PRESENT = 0,
  PVSC_ENABLED = 1
} PRL_VTD_STATUS_CODE;
File

PrlEnums.h

Links
Other Structs


PRL_VTD_STATUS_CODE_PTR Type

PRL_VTD_STATUS_CODE_PTR Type
Other Types
Syntax
typedef PRL_VTD_STATUS_CODE* PRL_VTD_STATUS_CODE_PTR;
File

PrlEnums.h

Links
Other Types


PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND Macro

PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND Macro
Other Macros

PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND is keep only for compatibility with previous versions of dispatcher (PSBM)

Syntax
#define PRL_WARN_BACKUP_DEVICE_IMAGE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(37025)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED Macro

PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED Macro
Other Macros
Syntax
#define PRL_WARN_BACKUP_GUEST_SYNCHRONIZATION_FAILED PRL_RESULT_DECLARE_SUCCESS(37020)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE Macro

PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE Macro
Other Macros
Syntax
#define PRL_WARN_BACKUP_GUEST_UNABLE_TO_SYNCHRONIZE PRL_RESULT_DECLARE_SUCCESS(37029)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP Macro

PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP Macro
Other Macros
Syntax
#define PRL_WARN_BACKUP_HAS_NOT_FULL_BACKUP PRL_RESULT_DECLARE_SUCCESS(37017)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_BACKUP_NON_IMAGE_HDD Macro

PRL_WARN_BACKUP_NON_IMAGE_HDD Macro
Other Macros
Syntax
#define PRL_WARN_BACKUP_NON_IMAGE_HDD PRL_RESULT_DECLARE_SUCCESS(37037)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED Macro

PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED Macro
Other Macros
Syntax
#define PRL_WARN_BACKUP_SP_GUEST_SYNCHRONIZATION_FAILED PRL_RESULT_DECLARE_SUCCESS(37026)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_CANNOT_MOUNT_BACK_PARTITION Macro

PRL_WARN_CANNOT_MOUNT_BACK_PARTITION Macro
Other Macros
Syntax
#define PRL_WARN_CANNOT_MOUNT_BACK_PARTITION PRL_RESULT_DECLARE_ERROR(501)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_CANT_CONNECT_VOLUME Macro

PRL_WARN_CANT_CONNECT_VOLUME Macro
Other Macros
Syntax
#define PRL_WARN_CANT_CONNECT_VOLUME PRL_RESULT_DECLARE_ERROR(458)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_COMPACT_DESTRUCTIVE Macro

PRL_WARN_COMPACT_DESTRUCTIVE Macro
Other Macros
Syntax
#define PRL_WARN_COMPACT_DESTRUCTIVE PRL_RESULT_DECLARE_ERROR(28002)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_COMPACT_THROUGH_COPY Macro

PRL_WARN_COMPACT_THROUGH_COPY Macro
Other Macros
Syntax
#define PRL_WARN_COMPACT_THROUGH_COPY PRL_RESULT_DECLARE_ERROR(28001)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_DEV_USB_CONNECT_FAILED Macro

PRL_WARN_DEV_USB_CONNECT_FAILED Macro
Other Macros
Syntax
#define PRL_WARN_DEV_USB_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(471)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_DEV_USB_OPEN_FAILED Macro

PRL_WARN_DEV_USB_OPEN_FAILED Macro
Other Macros
Syntax
#define PRL_WARN_DEV_USB_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(474)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_FAILED_TO_START_VNC_SERVER Macro

PRL_WARN_FAILED_TO_START_VNC_SERVER Macro
Other Macros
Syntax
#define PRL_WARN_FAILED_TO_START_VNC_SERVER PRL_RESULT_DECLARE_SUCCESS(35006)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_FAT32_FILE_OVERRUN Macro

PRL_WARN_FAT32_FILE_OVERRUN Macro
Other Macros
Syntax
#define PRL_WARN_FAT32_FILE_OVERRUN PRL_RESULT_DECLARE_ERROR(267)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro

PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro
Other Macros
Syntax
#define PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT PRL_RESULT_DECLARE_ERROR(446)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_HDD_ERROR Macro

PRL_WARN_HDD_ERROR Macro
Other Macros
Syntax
#define PRL_WARN_HDD_ERROR PRL_RESULT_DECLARE_ERROR(268)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_IMAGE_IS_STOLEN Macro

PRL_WARN_IMAGE_IS_STOLEN Macro
Other Macros
Syntax
#define PRL_WARN_IMAGE_IS_STOLEN PRL_RESULT_DECLARE_ERROR(264)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_LAN_NOT_CONNECTED Macro

PRL_WARN_LAN_NOT_CONNECTED Macro
Other Macros
Syntax
#define PRL_WARN_LAN_NOT_CONNECTED PRL_RESULT_DECLARE_ERROR(261)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_LICENSE_RESTRICTED_RKU Macro

PRL_WARN_LICENSE_RESTRICTED_RKU Macro
Other Macros
Syntax
#define PRL_WARN_LICENSE_RESTRICTED_RKU PRL_RESULT_DECLARE_ERROR(11069)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE Macro

PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE Macro
Other Macros
Syntax
#define PRL_WARN_LINK_TO_OUTSIDED_HDD_WILL_BE_DROPPED_AFTER_CLONE PRL_RESULT_DECLARE_ERROR(531)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT Macro

PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT Macro
Other Macros
Syntax
#define PRL_WARN_NO_SHARED_NETWORK_FOR_OFFLINE_MANAGEMENT PRL_RESULT_DECLARE_SUCCESS(27771)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_NOT_SYMMETRIC_CPU Macro

PRL_WARN_NOT_SYMMETRIC_CPU Macro
Other Macros
Syntax
#define PRL_WARN_NOT_SYMMETRIC_CPU PRL_RESULT_DECLARE_ERROR(470)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE Macro

PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE Macro
Other Macros
Syntax
#define PRL_WARN_OUTSIDED_HDD_WILL_BE_ONLY_LINKED_AFTER_CLONE PRL_RESULT_DECLARE_ERROR(532)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP Macro

PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP Macro
Other Macros
Syntax
#define PRL_WARN_PREPARE_FOR_HIBERNATE_UNABLE_SUSPEND_DO_STOP PRL_RESULT_DECLARE_SUCCESS(482)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_TARGET_HOST_DISK_IS_FULL Macro

PRL_WARN_TARGET_HOST_DISK_IS_FULL Macro
Other Macros
Syntax
#define PRL_WARN_TARGET_HOST_DISK_IS_FULL PRL_RESULT_DECLARE_ERROR(265)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_TOO_LOW_HDD_SIZE Macro

PRL_WARN_TOO_LOW_HDD_SIZE Macro
Other Macros
Syntax
#define PRL_WARN_TOO_LOW_HDD_SIZE PRL_RESULT_DECLARE_ERROR(289)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_UNABLE_OPEN_DEVICE Macro

PRL_WARN_UNABLE_OPEN_DEVICE Macro
Other Macros
Syntax
#define PRL_WARN_UNABLE_OPEN_DEVICE PRL_RESULT_DECLARE_ERROR(263)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_UNABLE_OPEN_DEVICE_NAME Macro

PRL_WARN_UNABLE_OPEN_DEVICE_NAME Macro
Other Macros
Syntax
#define PRL_WARN_UNABLE_OPEN_DEVICE_NAME PRL_RESULT_DECLARE_ERROR(262)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM Macro

PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM Macro
Other Macros
Syntax
#define PRL_WARN_UNABLE_OPEN_DEVICE_ON_START_VM PRL_RESULT_DECLARE_ERROR(9002)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE Macro

PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE Macro
Other Macros
Syntax
#define PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE PRL_RESULT_DECLARE_ERROR(266)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VERBOSE_LOGGING Macro

PRL_WARN_VERBOSE_LOGGING Macro
Other Macros
Syntax
#define PRL_WARN_VERBOSE_LOGGING PRL_RESULT_DECLARE_SUCCESS(495)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_BOOTCAMP_MODE Macro

PRL_WARN_VM_BOOTCAMP_MODE Macro
Other Macros
Syntax
#define PRL_WARN_VM_BOOTCAMP_MODE PRL_RESULT_DECLARE_ERROR(1004)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_DISCONNECT_SATA_HDD Macro

PRL_WARN_VM_DISCONNECT_SATA_HDD Macro
Other Macros
Syntax
#define PRL_WARN_VM_DISCONNECT_SATA_HDD PRL_RESULT_DECLARE_ERROR(13048)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV Macro

PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV Macro
Other Macros
Syntax
#define PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV PRL_RESULT_DECLARE_ERROR(433)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST Macro

PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST Macro
Other Macros
Syntax
#define PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST PRL_RESULT_DECLARE_ERROR(448)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_PD3_COMPAT_MODE Macro

PRL_WARN_VM_PD3_COMPAT_MODE Macro
Other Macros
Syntax
#define PRL_WARN_VM_PD3_COMPAT_MODE PRL_RESULT_DECLARE_ERROR(1003)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_PD3_COMPAT_NO_MOUSE Macro

PRL_WARN_VM_PD3_COMPAT_NO_MOUSE Macro
Other Macros
Syntax
#define PRL_WARN_VM_PD3_COMPAT_NO_MOUSE PRL_RESULT_DECLARE_ERROR(1005)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED Macro

PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED Macro
Other Macros
Syntax
#define PRL_WARN_VM_SYNC_DEFAULT_PRINTER_DISABLED PRL_RESULT_DECLARE_ERROR(545)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WARN_WINDOWS_UPDATE_WORKING Macro

PRL_WARN_WINDOWS_UPDATE_WORKING Macro
Other Macros
Syntax
#define PRL_WARN_WINDOWS_UPDATE_WORKING PRL_RESULT_DECLARE_ERROR(563)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WIN_EXTENDED_PARTITION Macro

PRL_WIN_EXTENDED_PARTITION Macro
Other Macros
Syntax
#define PRL_WIN_EXTENDED_PARTITION 0x0F
File

PrlDisk.h

Links
Other Macros


PRL_WINDOW_CORNERS Enumeration

PRL_WINDOW_CORNERS Enumeration
Other Structs

Window corners

Syntax
typedef enum _PRL_WINDOW_CORNERS {
  PWC_TOP_LEFT_CORNER = 0,
  PWC_TOP_RIGHT_CORNER = 1,
  PWC_BOTTOM_LEFT_CORNER = 2,
  PWC_BOTTOM_RIGHT_CORNER = 3
} PRL_WINDOW_CORNERS;
File

PrlEnums.h

Links
Other Structs


PRL_WINDOW_CORNERS_PTR Type

PRL_WINDOW_CORNERS_PTR Type
Other Types
Syntax
typedef PRL_WINDOW_CORNERS* PRL_WINDOW_CORNERS_PTR;
File

PrlEnums.h

Links
Other Types


PRL_WINDOW_EDGE_MASK Enumeration

PRL_WINDOW_EDGE_MASK Enumeration
Other Structs

Edges where taskbar can be placed (in coherence mode).

Syntax
typedef enum _PRL_WINDOW_EDGE_MASK {
  WINDOW_LEFT_EDGE_MASK = (0x1L << 0),
  WINDOW_TOP_EDGE_MASK = (0x1L << 1),
  WINDOW_RIGHT_EDGE_MASK = (0x1L << 2),
  WINDOW_BOTTOM_EDGE_MASK = (0x1L << 3),
  WINDOW_ALL_EDGE_MASK = WINDOW_LEFT_EDGE_MASK|WINDOW_TOP_EDGE_MASK|WINDOW_RIGHT_EDGE_MASK|WINDOW_BOTTOM_EDGE_MASK
} PRL_WINDOW_EDGE_MASK;
File

PrlEnums.h

Links
Other Structs


PRL_WINDOW_EDGE_MASK_PTR Type

PRL_WINDOW_EDGE_MASK_PTR Type
Other Types
Syntax
typedef PRL_WINDOW_EDGE_MASK * PRL_WINDOW_EDGE_MASK_PTR;
File

PrlEnums.h

Links
Other Types


PRL_WINDOWS_PARTITION_FAT Macro

PRL_WINDOWS_PARTITION_FAT Macro
Other Macros
Syntax
#define PRL_WINDOWS_PARTITION_FAT 0x06
File

PrlDisk.h

Links
Other Macros


PRL_WINDOWS_PARTITION_FAT32 Macro

PRL_WINDOWS_PARTITION_FAT32 Macro
Other Macros
Syntax
#define PRL_WINDOWS_PARTITION_FAT32 0x0B
File

PrlDisk.h

Links
Other Macros


PRL_WINDOWS_PARTITION_FAT32_LBA Macro

PRL_WINDOWS_PARTITION_FAT32_LBA Macro
Other Macros
Syntax
#define PRL_WINDOWS_PARTITION_FAT32_LBA 0x0C
File

PrlDisk.h

Links
Other Macros


PRL_WINDOWS_PARTITION_NTFS Macro

PRL_WINDOWS_PARTITION_NTFS Macro
Other Macros

Windows partitions

Syntax
#define PRL_WINDOWS_PARTITION_NTFS 0x07
File

PrlDisk.h

Links
Other Macros


PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED Macro

PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED Macro
Other Macros
Syntax
#define PRL_WNG_NO_OPERATION_SYSTEM_INSTALLED PRL_RESULT_DECLARE_ERROR(10015)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WNG_START_VM_ON_MOUNTED_DISK Macro

PRL_WNG_START_VM_ON_MOUNTED_DISK Macro
Other Macros
Syntax
#define PRL_WNG_START_VM_ON_MOUNTED_DISK PRL_RESULT_DECLARE_SUCCESS(439)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WRN_IT_CANT_RESIZE_LDM_DISK Macro

PRL_WRN_IT_CANT_RESIZE_LDM_DISK Macro
Other Macros
Syntax
#define PRL_WRN_IT_CANT_RESIZE_LDM_DISK PRL_RESULT_DECLARE_ERROR(46004)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WRN_IT_CANT_RESIZE_VOLUME Macro

PRL_WRN_IT_CANT_RESIZE_VOLUME Macro
Other Macros
Syntax
#define PRL_WRN_IT_CANT_RESIZE_VOLUME PRL_RESULT_DECLARE_ERROR(46003)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WRN_IT_EMPTY_MBR Macro

PRL_WRN_IT_EMPTY_MBR Macro
Other Macros
Syntax
#define PRL_WRN_IT_EMPTY_MBR PRL_RESULT_DECLARE_ERROR(46001)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WRN_IT_FIRST_WARNING Macro

PRL_WRN_IT_FIRST_WARNING Macro
Other Macros

vi disk tool errors +++ ALIGNED VALUE TO 46000

Syntax
#define PRL_WRN_IT_FIRST_WARNING PRL_RESULT_DECLARE_ERROR(46000)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WRN_IT_VOLUME_RESIZING Macro

PRL_WRN_IT_VOLUME_RESIZING Macro
Other Macros
Syntax
#define PRL_WRN_IT_VOLUME_RESIZING PRL_RESULT_DECLARE_ERROR(46002)
File

PrlErrorsValues.h

Links
Other Macros


PRL_WS_RECLAIMABLE_PTRN Macro

PRL_WS_RECLAIMABLE_PTRN Macro
Other Macros
Syntax
#define PRL_WS_RECLAIMABLE_PTRN "ws.reclaimable"
File

PrlPerfCounters.h

Links
Other Macros


PrlAcl_GetAccessForOthers Function

PrlAcl_GetAccessForOthers Function
PHT_ACCESS_RIGHTS See Also

Obtains the virtual machine access rights information.

Syntax
PRL_RESULT PrlAcl_GetAccessForOthers(
    PRL_HANDLE hAcl,
    PRL_VM_ACCESS_FOR_OTHERS_PTR pnAccessForOthers
);
File

PrlApiVm.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
pnAccessForOthers
[out] A pointer to a variable that receives the virtual machine access level information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function determines whether other users besides the owner can view, run, or have full access to a virtual machine.

See Also

PrlAcl_SetAccessForOthers

Links
PHT_ACCESS_RIGHTS, See Also


PrlAcl_GetOwnerName Function

PrlAcl_GetOwnerName Function
PHT_ACCESS_RIGHTS See Also

Determines the virtual machine owner name.

Syntax
PRL_RESULT PrlAcl_GetOwnerName(
    PRL_HANDLE hAcl,
    PRL_STR sOwnerNameBuf,
    PRL_UINT32_PTR pnOwnerNameBufLength
);
File

PrlApiVm.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
sOwnerNameBuf
[out] A pointer to a buffer that receives the virtual machine owner name (a UTF-8 encoded, null-terminated string).
pnOwnerNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlAcl_IsCurrentSessionOwner

Links
PHT_ACCESS_RIGHTS, See Also


PrlAcl_IsAllowed Function

PrlAcl_IsAllowed Function
PHT_ACCESS_RIGHTS

Determines if the current user is authorized to perform a specified task on a virtual machine.

Syntax
PRL_RESULT PrlAcl_IsAllowed(
    PRL_HANDLE hAcl,
    PRL_ALLOWED_VM_COMMAND nPermission,
    PRL_BOOL_PTR pbAllowed
);
File

PrlApiVm.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
nPermission
Task type.
pbAllowed
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allowed to perform the task. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_ACCESS_RIGHTS


PrlAcl_IsCurrentSessionOwner Function

PrlAcl_IsCurrentSessionOwner Function
PHT_ACCESS_RIGHTS

Determines if the current user is the owner of the specified virtual machine.

Syntax
PRL_RESULT PrlAcl_IsCurrentSessionOwner(
    PRL_HANDLE hAcl,
    PRL_BOOL_PTR pbIsOwner
);
File

PrlApiVm.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
pbIsOwner
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is the owner of the virtual machine. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_ACCESS_RIGHTS


PrlAcl_SetAccessForOthers Function

PrlAcl_SetAccessForOthers Function
PHT_ACCESS_RIGHTS See Also

Sets access rights on a virtual machine.

Syntax
PRL_RESULT PrlAcl_SetAccessForOthers(
    PRL_HANDLE hAcl,
    PRL_VM_ACCESS_FOR_OTHERS nAccessForOthers
);
File

PrlApiVm.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
nAccessForOthers
The access rights to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The owner of a virtual machine can use this function to grant or deny access rights for the virtual machine to other users. The access rights will be applied to all users. The call will only update the local copy of the PHT_ACCESS_RIGHTS object passed to the function (you will have to properly obtain the object prior to calling this function). To apply the changes to the virtual machine, call the PrlVm_UpdateSecurity function after making this calls and pass the same PHT_ACCESS_RIGHTS handle to it.

See Also

PrlAcl_GetAccessForOthers

Links
PHT_ACCESS_RIGHTS, See Also


PrlApi_AddRemoteDevCommandBuffer@PRL_HANDLE@PRL_VOID_PTR@PRL_UINT32

PrlApi_AddRemoteDevCommandBuffer@PRL_HANDLE@PRL_VOID_PTR@PRL_UINT32
System Functions
Links
System Functions


PrlApi_AddRemoteDevCommandParam@PRL_HANDLE@PRL_UINT32

PrlApi_AddRemoteDevCommandParam@PRL_HANDLE@PRL_UINT32
System Functions
Links
System Functions


PrlApi_CalcIconHash Function

PrlApi_CalcIconHash Function
System Functions

Calculates hash for specified icon data which can be used later in PrlApi_ValidateInCache.

Syntax
PRL_RESULT PrlApi_CalcIconHash(
    PRL_VOID_PTR iconData,
    PRL_UINT32 iconDataSize,
    PRL_VOID_PTR_PTR pCalculatedHash
);
File

PrlApiManager.h

Parameters

iconData
Pointer to the buffer containing the icon data.
iconDataSize
Size of the data.
pCalculatedHash
Buffer to calculated hash. Null terminated UTF8 string. Use PrlBuffer_Free call in order to free memory allocated for hash buffer.

Returns

PRL_RESULT. Possible values: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_INVALID_ARG - wrong pointer or data size was provided PRL_ERR_OUT_OF_MEMORY - not enough memory to complete operation

Links
System Functions


PrlApi_CreateCredentials Function

PrlApi_CreateCredentials Function
System Functions See Also

Create credentials (certificate signing request / private key) for user.

Syntax
PRL_HANDLE PrlApi_CreateCredentials(
    PRL_CONST_STR userId,
    PRL_CONST_STR certRole,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiSecurity.h

Parameters

userId
User id for witch certificate will be created (a UTF-8 encoded, null-terminated string).
certRole
Role for certificate (a UTF-8 encoded, null-terminated string).
handler
Optional. A pointer to a user callback function (event handler) that will be called when operation become complete.
userData
Optional. A pointer to a user data that will be passed to the optional callback function. flags Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamByIndexAsString function to obtain a string containing user signing certificate request from first param.

3 Use the PrlResult_GetParamByIndexAsString function to obtain a string containing user private key from second param.

See Also

PrlSrv_SignCertificate

Links
System Functions, See Also


PrlApi_CreateHandlesList Function

PrlApi_CreateHandlesList Function
System Functions

Creates a new handle of type PRL_HANDLES_LIST.

Syntax
PRL_RESULT PrlApi_CreateHandlesList(
    PRL_HANDLE_PTR phHandlesList
);
File

PrlApiCore.h

Parameters

phHandlesList
A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - inavlid (NULL) pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the new handle.

PRL_ERR_SUCCESS - operation completed successfully.

Links
System Functions


PrlApi_CreateOpTypeList Function

PrlApi_CreateOpTypeList Function
System Functions

Creates a new handle of type PHT_OPAQUE_TYPE_LIST.

Syntax
PRL_RESULT PrlApi_CreateOpTypeList(
    PRL_HANDLE_PTR phOpTypeList,
    PRL_SIZE nTypeSize
);
File

PrlApiCore.h

Parameters

phOpTypeList
[out] A pointer to a variable that receives the handle.
nTypeSize
size of opaque type for which list should be instantiated

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed or size of not supported opaque type was passed. In order to determine list of supported opaque types please refer with PrlTypes.h.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Simple sample of method usage follow:

PrlApi_CreateOpTypeList(&hOpTypeList, sizeof(PRL_UINT32));

Links
System Functions


PrlApi_CreateProblemReport Function

PrlApi_CreateProblemReport Function
System Functions

Creates and returns a handle of type PHT_PROBLEM_REPORT, which is used to obtain and manage Parallels problem reports.

Syntax
PRL_RESULT PrlApi_CreateProblemReport(
    PRL_PROBLEM_REPORT_SCHEME nReportScheme,
    PRL_HANDLE_PTR phProblemReport
);
File

PrlApiCore.h

Parameters

nReportScheme
[in] the type of report that will be generated (XML based or new packed form).
phProblemReport
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or unknown report scheme was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the problem report object.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_CreateRemoteCommand Function

PrlApi_CreateRemoteCommand Function
System Functions
Syntax
PRL_RESULT PrlApi_CreateRemoteCommand(
    PRL_DEVICE_TYPE uTargetType,
    PRL_UINT32 uTargetIndex,
    PRL_UINT16 uCommandCode,
    PRL_VOID_PTR pData,
    PRL_SIZE uDataSize,
    PRL_HANDLE_PTR phCommand
);
File

PrlApiRemoteDev.h

Parameters

uTargetType
_nt_
uTargetIndex
_nt_
uCommandCode
_nt_
pData
_nt_
uDataSize
_nt_
phCommand
_nt_

Links
System Functions


PrlApi_CreateStringsList Function

PrlApi_CreateStringsList Function
System Functions

Creates a new handle of type PHT_STRINGS_LIST.

Syntax
PRL_RESULT PrlApi_CreateStringsList(
    PRL_HANDLE_PTR phStringsList
);
File

PrlApiCore.h

Parameters

phStringsList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_Deinit Function

PrlApi_Deinit Function
System Functions See Also

De-initializes the library.

Syntax
PRL_RESULT PrlApi_Deinit();
File

PrlApiCore.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_UNINITIALIZED - the library was not initialized.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

Before exiting a client program, this function must be called to perform internal library de-initialization. Internally, this call will lead to the destruction of the internal event-loop and de-initialization of the library state.

See Also

PrlApi_Init

Links
System Functions, See Also


PrlApi_GetAppMode Function

PrlApi_GetAppMode Function
System Functions

Returns the Parallels API application mode.

Syntax
PRL_RESULT PrlApi_GetAppMode(
    PRL_APPLICATION_MODE_PTR app_mode
);
File

PrlApiCore.h

Parameters

app_mode
[out] Current application mode of the API.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetCrashDumpsPath Function

PrlApi_GetCrashDumpsPath Function
System Functions

Returns the name and path of the directory where Parallels crash dumps are stored.

Syntax
PRL_RESULT PrlApi_GetCrashDumpsPath(
    PRL_STR sPath,
    PRL_UINT32_PTR pnPathBufLength
);
File

PrlApiCore.h

Parameters

sPath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnPathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - null pointer to the buffer size was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetDefaultOsVersion Function

PrlApi_GetDefaultOsVersion Function
System Functions

Returns default guest OS version for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).

Syntax
PRL_RESULT PrlApi_GetDefaultOsVersion(
    PRL_UINT8 nGuestOsType,
    PRL_UINT16_PTR pnOsVersion
);
File

PrlApiVm.h

Parameters

nGuestOsType
requesting guest OS type. In order to determine list of supported guests types please refer PrlOses.h
pnOsVersion
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or unknown OS type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetMessageType Function

PrlApi_GetMessageType Function
System Functions

Evaluates the specified error code and returns its classification (warning, question, information, etc.).

Syntax
PRL_RESULT PrlApi_GetMessageType(
    PRL_RESULT nErrCode,
    PRL_MESSAGE_TYPE_ENUM_PTR pnMsgType
);
File

PrlApiCore.h

Parameters

nErrCode
The error code to evaluate.
pnMsgType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetRecommendMinVmMem Function

PrlApi_GetRecommendMinVmMem Function
System Functions

The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.

Syntax
PRL_RESULT PrlApi_GetRecommendMinVmMem(
    PRL_UINT32 nOsVersion,
    PRL_UINT32_PTR pnMinMemSize
);
File

PrlApiVm.h

Parameters

nOsVersion
OS version
pnMinMemSize
[out] A pointer to a variable that receives the result. Result is the recommend minimal memory size for guest OS.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetRemoteCommandBuffer Function

PrlApi_GetRemoteCommandBuffer Function
System Functions
Syntax
PRL_RESULT PrlApi_GetRemoteCommandBuffer(
    PRL_HANDLE hCommand,
    PRL_IO_GENERIC_BUFFER_PTR pBuffer
);
File

PrlApiRemoteDev.h

Parameters

hCommand
_nt_
pBuffer
_nt_

Links
System Functions


PrlApi_GetRemoteCommandCode Function

PrlApi_GetRemoteCommandCode Function
System Functions
Syntax
PRL_RESULT PrlApi_GetRemoteCommandCode(
    PRL_HANDLE hCommand,
    PRL_UINT16_PTR pCode
);
File

PrlApiRemoteDev.h

Parameters

hCommand
_nt_
pCode
_nt_

Links
System Functions


PrlApi_GetRemoteCommandIndex Function

PrlApi_GetRemoteCommandIndex Function
System Functions
Syntax
PRL_RESULT PrlApi_GetRemoteCommandIndex(
    PRL_HANDLE hCommand,
    PRL_UINT32_PTR pIndex
);
File

PrlApiRemoteDev.h

Parameters

hCommand
_nt_
pIndex
_nt_

Links
System Functions


PrlApi_GetRemoteCommandTarget Function

PrlApi_GetRemoteCommandTarget Function
System Functions
Syntax
PRL_RESULT PrlApi_GetRemoteCommandTarget(
    PRL_HANDLE hCommand,
    PRL_DEVICE_TYPE_PTR pType
);
File

PrlApiRemoteDev.h

Parameters

hCommand
_nt_
pType
_nt_

Links
System Functions


PrlApi_GetRemoteDeviceRegistration Function

PrlApi_GetRemoteDeviceRegistration Function
System Functions

Obtains current registration of the remote devices of specified type

Syntax
PRL_RESULT PrlApi_GetRemoteDeviceRegistration(
    PRL_DEVICE_TYPE device_type,
    PREMOTE_DEVICE_CREATE_HANDLER* ppCreateHandler,
    PRL_VOID_PTR* pCreateCtx,
    PREMOTE_DEVICE_DESTROY_HANDLER* ppDestroyHandler,
    PREMOTE_DEVICE_COMMAND_HANDLER* ppCommandHandler
);
File

PrlApiRemoteDev.h

Parameters

device_type
[in] Type of the devices to register as capable to be remote
ppCreateHandler
[out] Function that creates remote device instances
pCreateCtx
[out] Context to pass to the REMOTE_DEVICE_CREATE_HANDLER
ppDestroyHandler
[out] Function that destroys device instance
ppCommandHandler
[out] Function that handles commands to the remote device

Returns

PRL_ERR_SUCCESS - parameters were obtained. Other values means error

Links
System Functions


PrlApi_GetResultDescription Function

PrlApi_GetResultDescription Function
System Functions

Evaluates a return code and returns a description of the problem.

Syntax
PRL_RESULT PrlApi_GetResultDescription(
    PRL_RESULT nErrCode,
    PRL_BOOL bIsBriefMessage,
    PRL_BOOL bFormated,
    PRL_STR sErrString,
    PRL_UINT32_PTR pnErrStringBufLength
);
File

PrlApiCore.h

Parameters

nErrCode
A return code to get the description for.
bIsBriefMessage
Specifies whether to obtain a long or a brief description of the problem. PRL_TRUE specifies to obtain a brief message. PRL_FALSE specifies to obtain a long message.
bFormated
Specifies whether HTML tags used for text formatting should be included in the resulting string.
sErrString
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnErrStringBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
PRL_TRUE
include HTML tags; PRL_FALSE - do not include the tags.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

All synchronous functions in the Parallels API return PRL_RESULT - a numeric return code used to evaluate the success or failure of the operation. If the return code indicates a failure, the PrlApi_GetResultDescription function can be used to obtain the description of the problem.

Links
System Functions


PrlApi_GetSupportedOsesTypes Function

PrlApi_GetSupportedOsesTypes Function
System Functions

Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list for current API mode (see PrlApi_InitEx for more info about API mode).

Syntax
PRL_RESULT PrlApi_GetSupportedOsesTypes(
    PRL_HOST_OS_TYPE nHostOsType,
    PRL_HANDLE_PTR phOsesTypesList
);
File

PrlApiVm.h

Parameters

nHostOsType
type of host system (remote or local) for which supported OSes list should be retrieved. In remote work mode please determine at first remote side host type (please use PrlSrvCfg_GetHostOsType for this). In local work mode PHO_UNKNOWN can be passed - host OS type will be automatically detected by API call in this case.
phOsesTypesList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list object.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetSupportedOsesVersions Function

PrlApi_GetSupportedOsesVersions Function
System Functions

Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type at current API mode (see PrlApi_InitEx for more info about API mode).

Syntax
PRL_RESULT PrlApi_GetSupportedOsesVersions(
    PRL_HOST_OS_TYPE nHostOsType,
    PRL_UINT8 nGuestOsType,
    PRL_HANDLE_PTR phGuestsList
);
File

PrlApiVm.h

Parameters

nHostOsType
type of host system (remote or local) for which supported OSes list should be retrieved. In remote work mode please determine at first remote side host type (please use PrlSrvCfg_GetHostOsType for this). In local work mode PHO_UNKNOWN can be passed - host OS type will be automatically detected by API call in this case.
nGuestOsType
requesting guest OS type. In order to determine list of supported guests types please refer PrlOses.h
phOsesTypesList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or unknown OS type was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list object.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_GetUserData Function

PrlApi_GetUserData Function
System Functions

Allows to get arbitrary data from the cloud user storage.

Syntax
PRL_HANDLE PrlApi_GetUserData(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR regExp,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
regExp
A regular expression which matches to correspond required data identifiers.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

To get the results from the PHT_JOB object use PrlJob_GetDataPtr. Result will be represented as a set of PRL_PROXY_USER_DATA structures.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side

Links
System Functions


PrlApi_GetUserKeys Function

PrlApi_GetUserKeys Function
System Functions

Allows to get arbitrary data keys from the cloud user storage.

Syntax
PRL_HANDLE PrlApi_GetUserKeys(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

To get the results from the PHT_JOB object use PrlJob_GetDataPtr. Result will be represented as a set of PRL_PROXY_DATA_KEY structures.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side

Links
System Functions


PrlApi_GetVersion Function

PrlApi_GetVersion Function
System Functions

Returns the Parallels API version number.

Syntax
PRL_RESULT PrlApi_GetVersion(
    PRL_UINT32_PTR current_version
);
File

PrlApiCore.h

Parameters

current_version
[out] Current version of the API.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Version number is incremented each time a public interfaces is changed. Our goal is to achieve full backward compatibility where the changes add new functionality without breaking the existing one.

Links
System Functions


PrlApi_Init Function

PrlApi_Init Function
System Functions Example See Also

Initializes Parallels API library.

Syntax
PRL_RESULT PrlApi_Init(
    PRL_UINT32 version
);
File

PrlApiCore.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_DOUBLE_INIT - library has been already initialized.

PRL_ERR_OUT_OF_MEMORY - not enough memory to initialize the library.

PRL_ERR_API_INCOMPATIBLE - SDK version is incompatible with version in param.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

This function must be called after the dynamic libraries are loaded and before making any of the API calls. Internally, this call creates the internal event-loop and initializes the library state. Before exiting the program, the PrlApi_Deinit function must be called to perform internal library de-initialization.

Version

Library version number. This should be PARALLELS_API_VER.

See Also

PrlApi_Deinit

Example

The following example illustrates how to perform the necessary API library initialization.

The first step is to load the dynamic link library using the SdkWrap_Load function from the supplied wrapper library (SdkWrap is a helper library that contains just two functions for loading and unloading the API dynamic link library; the library is not documented in this guide).

The second step is to initialize the Parallels API using the PrlApi_Init function.

Once the above steps are completed, you are ready to make other API calls, such as PrlSrv_Login and others.

On program exit, you must cal the PrlApi_Deinit function to deinitialize the API, and the SdkWrap_Unload function to unload the dynamic link libraries.

int main(int argc, char* argv[])
{
   // Pick the correct dynamic library depending on the platform.
   #ifdef _WIN_
      #define SDK_LIB_NAME "prl_sdk.dll"
   #elif defined(_LIN_)
      #define SDK_LIB_NAME "libprl_sdk.so"
   #elif defined(_MAC_)
      #define SDK_LIB_NAME "libprl_sdk.dylib"
   #endif

   // Load the dynamic library.
   // If the library cannot be found, try searching for it.
   if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
      PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
   {
      fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
      return -1;
   }

   // Initialize the API.
   PRL_RESULT ret;
   ret = PrlApi_Init(PARALLELS_API_VER);
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Init returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // your program code goes here...

   // Deinitialize the API.
   ret = PrlApi_Deinit();
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Deinit returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // Unload dynamic link libraries.
   SdkWrap_Unload();
   return 0;
}
Links
System Functions, Example, See Also


PrlApi_InitCrashHandler Function

PrlApi_InitCrashHandler Function
System Functions

Initiates the standard Parallels crash dump handler.

Syntax
PRL_RESULT PrlApi_InitCrashHandler(
    PRL_CONST_STR sCrashDumpFileSuffix
);
File

PrlApiCore.h

Parameters

sCrashDumpFileSuffix
A user-define suffix to add to the crash dump file name (UTF-8 encoded, null-terminated string). The parameter is optional and can be NULL.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Call this function if you would like a dump file to be created on the application crash. The crush dump will be created in the common Parallels crush dump directory (use PrlApi_GetCrashDumpsPath to obtains its name and path). The crash dump file name will begin with the name of the crashed application and can also contain a user-define suffix that is passed a parameter (see the Parameters subsection).

Links
System Functions


PrlApi_InitEx Function

PrlApi_InitEx Function
System Functions See Also

This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.

Syntax
PRL_RESULT PrlApi_InitEx(
    PRL_UINT32 nVersion,
    PRL_APPLICATION_MODE nAppMode,
    PRL_UINT32 nFlags,
    PRL_UINT32 nReserved
);
File

PrlApiCore.h

Parameters

nVersion
Library version number. This should be PARALLELS_API_VER.
nAppMode
API library application mode.
nFlags
Flags as mask ( from enums PRL_API_INIT_FLAGS and PRL_API_COMMAND_FLAGS )
nReserved
reserved parameter for future purposes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_DOUBLE_INIT - library has been already initialized.

PRL_ERR_OUT_OF_MEMORY - not enough memory to initialize the library.

PRL_ERR_API_INCOMPATIBLE - SDK version is incompatible with version in param.

PRL_ERR_SUCCESS - operation completed successfully.

See Also

PrlApi_Deinit PrlApi_Init

Links
System Functions, See Also


PrlApi_MsgCanBeIgnored Function

PrlApi_MsgCanBeIgnored Function
System Functions

The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.

Syntax
PRL_RESULT PrlApi_MsgCanBeIgnored(
    PRL_RESULT nErrCode,
    PRL_BOOL_PTR pbCanBeIgnored
);
File

PrlApiCore.h

Parameters

nErrCode
Error code to evaluate.
pbCanBeIgnored
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the error is not critical. PBL_FALSE indicates that the error is critical and should be properly handled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

whether it can be ignored).

Links
System Functions


PrlApi_PutIcon Function

PrlApi_PutIcon Function
System Functions

Allows to put arbitrary icon to the cloud user storage.

Syntax
PRL_HANDLE PrlApi_PutIcon(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_VOID_PTR iconData,
    PRL_UINT32 dataSize,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
iconData
Pointer to the buffer containing the icon data.
dataSize
Size of the data.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side

Links
System Functions


PrlApi_PutUserData Function

PrlApi_PutUserData Function
System Functions

Allows to put arbitrary data to the cloud user storage.

Syntax
PRL_HANDLE PrlApi_PutUserData(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR dataKey,
    PRL_INT32 dataVersion,
    PRL_VOID_PTR data,
    PRL_UINT32 dataSize,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
dataKey
A key identifying the data in the user storage.
dataVersion
Version of data (aka revision).
data
Pointer to the buffer containing the data.
dataSize
Size of the data.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side

Links
System Functions


PrlApi_RegisterRemoteDevice Function

PrlApi_RegisterRemoteDevice Function
System Functions

Registers remote devices of specified type

Syntax
PRL_RESULT PrlApi_RegisterRemoteDevice(
    PRL_DEVICE_TYPE device_type,
    PREMOTE_DEVICE_CREATE_HANDLER pCreateHandler,
    PRL_VOID_PTR createCtx,
    PREMOTE_DEVICE_DESTROY_HANDLER pDestroyHandler,
    PREMOTE_DEVICE_COMMAND_HANDLER pCommandHandler
);
File

PrlApiRemoteDev.h

Parameters

device_type
[in] Type of the devices to register as capable to be remote
pCreateHandler
[in] Function that creates remote device instances
createCtx
[in] Context to pass to the REMOTE_DEVICE_CREATE_HANDLER
pDestroyHandler
[in] Function that destroys device instance
pCommandHandler
[in] Function that handles commands to the remote device

Returns

PRL_ERR_SUCCESS - device was registered. Other values means some error

Links
System Functions


PrlApi_RemoveUserData Function

PrlApi_RemoveUserData Function
System Functions

Allows to remove arbitrary data from the cloud user storage.

Syntax
PRL_HANDLE PrlApi_RemoveUserData(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR dataKey,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
dataKey
A key identifying the data in the user storage.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side (no such key for example)

Links
System Functions


PrlApi_ScaleImage Function

PrlApi_ScaleImage Function
System Functions

The PrlApi_ScaleImage scales image and put a new image to a buffer.

Syntax
PRL_RESULT PrlApi_ScaleImage(
    PRL_CONST_VOID_PTR pOriginalImage,
    PRL_UINT32 nOriginalImageSize,
    PRL_IMAGE_FORMAT nFormat,
    PRL_INT32 nQuality,
    PRL_UINT32 nScaleWidth,
    PRL_UINT32 nScaleHeight,
    PRL_VOID_PTR pNewImage,
    PRL_UINT32_PTR pnNewImageSize
);
File

PrlApiCore.h

Parameters

pOriginalImage
[in] Original image raw data.
nOriginalImageSize
Original image data size.
nFormat
Image format to use.
nQuality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
nScaleWidth
The width of the area to scale (pixels).
nScaleHeight
The height of the area to scale (pixels).
pNewImage
[out] New image raw data.
pnNewImageSize
New image data size. [in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - incorrect image format.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_SendPackedProblemReport Function

PrlApi_SendPackedProblemReport Function
System Functions

The PrlApi_SendPackedProblemReport lets to send previously extracted with PrlSrv_GetPackedProblemReport or PrlVm_GetPackedProblemReport calls problem report to the Parallels support server.

Syntax
PRL_HANDLE PrlApi_SendPackedProblemReport(
    PRL_HANDLE hProblemReport,
    PRL_BOOL bUseProxy,
    PRL_CONST_STR sProxyHost,
    PRL_UINT32 nProxyPort,
    PRL_CONST_STR sProxyUserLogin,
    PRL_CONST_STR sProxyUserPasswd,
    PRL_UINT32 nProblemSendTimeout,
    PRL_UINT32 nReserved,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR pUserData
);
File

PrlApiCore.h

Parameters

hProblemReport
handle of PHT_EVENT type contains packed problem report data
bUseProxy
sign specifies whether proxy settings should be used. Either system proxy settings can be automatically by API call retrieved and used or custom settings can be specified by follow params (note that custom values override correspond system settings)
sProxyHost
[optional] if using proxy this param lets to specify proxy server host address/name (can be null or empty)
nProxyPort
[optional] if using proxy this param lets to specify proxy server port (should be 0 in order to specify to use system settings)
sProxyUserLogin
[optional] if using proxy this param lets to specify user login if last one not specified at system proxy settings or need to be overridden (can be null or empty)
sProxyUserPasswd
[optional] if using proxy this param lets to specify user password if last one not specified at system proxy settings (can be null or empty)
nProblemSendTimeout
timeout in milliseconds which specifies maximal awaiting problem report send time (0 value not limiting problem report send operation at all)
nReserved
[unused] reserved parameter for further purposes
handler
[optional] A pointer to a user callback function (event handler) that will be called every time a problem report sending progress changed or job completed.
pUserData
[optional] A pointer to a user data that will be passed to the optional callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_SendProblemReport Function

PrlApi_SendProblemReport Function
System Functions

The PrlApi_SendProblemReport lets to send previously extracted with PrlSrv_GetProblemReport or PrlVm_GetProblemReport calls problem report to the Parallels support server.

Syntax
PRL_HANDLE PrlApi_SendProblemReport(
    PRL_CONST_STR sProblemReport,
    PRL_BOOL bUseProxy,
    PRL_CONST_STR sProxyHost,
    PRL_UINT32 nProxyPort,
    PRL_CONST_STR sProxyUserLogin,
    PRL_CONST_STR sProxyUserPasswd,
    PRL_UINT32 nProblemSendTimeout,
    PRL_UINT32 nReserved,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR pUserData
);
File

PrlApiCore.h

Parameters

sProblemReport
problem report string representation (expected null terminated string in UTF-8 encoding)
bUseProxy
sign specifies whether proxy settings should be used. Either system proxy settings can be automatically by API call retrieved and used or custom settings can be specified by follow params (note that custom values override correspond system settings)
sProxyHost
[optional] if using proxy this param lets to specify proxy server host address/name (can be null or empty)
nProxyPort
[optional] if using proxy this param lets to specify proxy server port (should be 0 in order to specify to use system settings)
sProxyUserLogin
[optional] if using proxy this param lets to specify user login if last one not specified at system proxy settings or need to be overridden (can be null or empty)
sProxyUserPasswd
[optional] if using proxy this param lets to specify user password if last one not specified at system proxy settings (can be null or empty)
nProblemSendTimeout
timeout in milliseconds which specifies maximal awaiting problem report send time (0 value not limiting problem report send operation at all)
nReserved
[unused] reserved parameter for further purposes
handler
[optional] A pointer to a user callback function (event handler) that will be called every time a problem report sending progress changed or job completed.
pUserData
[optional] A pointer to a user data that will be passed to the optional callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
System Functions


PrlApi_SendRemoteCommand Function

PrlApi_SendRemoteCommand Function
System Functions
Syntax
PRL_HANDLE PrlApi_SendRemoteCommand(
    PRL_HANDLE hVm,
    PRL_HANDLE hCommand
);
File

PrlApiRemoteDev.h

Parameters

hVm
_nt_
hCommand
_nt_

Links
System Functions


PrlApi_SignCertificate Function

PrlApi_SignCertificate Function
System Functions

Sign user certificate on manager CA .

Syntax
PRL_HANDLE PrlApi_SignCertificate(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_CONST_STR hostUuid,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR signingRequest,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account.
accountPass
Parallels account password. hostUuid Parallels host UUID.
cliInfo
Additional client information. signingRequest Certifiate signing request.
timeout
Timeout in milliseconds. The authenticate operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called when operation become complete.
userData
Optional. A pointer to a user data that will be passed to the optional callback function. flags Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamByIndexAsString function to obtain a string containing user signed certificate from first param.

See Also PrlSrv_CreateCredentials.....................

Remarks

PRL_ERR_INVALID_ARG - null pointer was passed.

Links
System Functions


PrlApi_SignCertificateEx Function

PrlApi_SignCertificateEx Function
System Functions

Sign user certificate on manager CA.

Syntax
PRL_HANDLE PrlApi_SignCertificateEx(
    PRL_CONST_STR managerToken,
    PRL_CONST_STR hostUuid,
    const PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR signingRequest,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

managerToken
Parallels Manager token. hostUuid Parallels host UUID.
cliInfo
Additional client information. signingRequest Certifiate signing request.
timeout
Timeout in milliseconds. The authenticate operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called when operation become complete.
userData
Optional. A pointer to a user data that will be passed to the optional callback function. flags Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamByIndexAsString function to obtain a string containing user signed certificate from first param.

See Also PrlSrv_CreateCredentials.....................

Remarks

Alternative form of PrlApi_SignCertificate method with authorization via Manager's token.

PRL_ERR_INVALID_ARG - null pointer was passed.

Links
System Functions


PrlApi_SubscribeOnRegistration Function

PrlApi_SubscribeOnRegistration Function
System Functions

Allows to sign for postponed notification about desired host registration on Manager.

Syntax
PRL_HANDLE PrlApi_SubscribeOnRegistration(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_CONST_STR hostUuid,
    PRL_CONST_STR deviceToken,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
hostUuid
Desired host UUID.
deviceToken
Specific mobile device token which will be used by Manager for push notification.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side

Links
System Functions


PrlApi_SwitchConsoleLogging Function

PrlApi_SwitchConsoleLogging Function
System Functions

Turn on/off print logging messages on console

PRL_ERR_SUCCESS - function completed successfully.

Syntax
PRL_RESULT PrlApi_SwitchConsoleLogging(
    PRL_BOOL bSwitchOn
);
File

PrlApiManager.h

Links
System Functions


PrlApi_UnregisterRemoteDevice Function

PrlApi_UnregisterRemoteDevice Function
System Functions

Unregisters remote device.

Syntax
PRL_RESULT PrlApi_UnregisterRemoteDevice(
    PRL_DEVICE_TYPE device_type
);
File

PrlApiRemoteDev.h

Parameters

device_type
type of the device to unregister,

Returns

PRL_ERR_SUCCESS - device was unregistered. Other values means some error

Remarks

This function will delete any registration done for the device type.

Links
System Functions


PrlApi_ValidateInCache Function

PrlApi_ValidateInCache Function
System Functions

Allows to check whether the specified icon hashes are present in the cache.

Syntax
PRL_HANDLE PrlApi_ValidateInCache(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_HANDLE hHandlesList,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData,
    PRL_UINT32 flags
);
File

PrlApiManager.h

Parameters

account
Parallels account ID.
accountPass
Parallels account password.
cliInfo
Additional client information (e.g. alternative manager URL). Can be null for default settings.
timeout
Timeout in milliseconds. The authentication operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called on operation completion.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.
flags
Optional. Reserved for future needs.
hHashesList
list of icons hashes (object of type PHT_STRINGS_LIST)

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object. Use PrlJob_GetResult method to retrieve result with icons hashes which are not present in cache. Use PrlResult_GetParamsCount to determine how many hashes in result. Use PrlResult_GetParamByIndexAsString to retrieve each hash from result.

Possible return codes: PRL_ERR_SUCCESS - operation completed successfully PRL_ERR_INVALID_ARG - wrong parameter was passed PRL_ERR_XMLRPC_INVALID_CREDENTIALS - wrong user credentials were provided PRL_ERR_XMLRPC_LIMITS_EXHAUSTED - remote server is busy for now - analogue of EAGAIN PRL_ERR_XMLRPC_INTERNAL_ERROR - error occurred during XML RPC interoperation PRL_ERR_FAILURE - operation failed on remote side (no such key for example)

Remarks

Returns hashes that are not present in the cache.

Links
System Functions


PrlAppliance_Create Function

PrlAppliance_Create Function
System Functions

Creates a new handle of type PHT_APPLIANCE_CONFIG.

Syntax
PRL_RESULT PrlAppliance_Create(
    PRL_HANDLE_PTR phAppCfg
);
File

PrlApiVm.h

Parameters

phAppCfg
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to create and configure an appliance download configuration. If you would like to create a new appliance download configuration, use this function to create the handle first and then use the handle functions to configure the appliance info.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
System Functions


PrlBackupResult_GetBackupUuid Function

PrlBackupResult_GetBackupUuid Function
PHT_BACKUP_RESULT

Returns the UUID (universally unique ID) of the created backup

Syntax
PRL_RESULT PrlBackupResult_GetBackupUuid(
    PRL_HANDLE hBackupResult,
    PRL_STR sBackupUuid,
    PRL_UINT32_PTR pnBackupUuidBufLength
);
File

PrlApiDisp.h

Parameters

hBackupResult
A handle of type PHT_BACKUP_RESULT identifying the information about created backup.
sBackupUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBackupUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_BACKUP_RESULT


PrlBootDev_GetIndex Function

PrlBootDev_GetIndex Function
PHT_BOOT_DEVICE See Also

Obtains the boot device index.

Syntax
PRL_RESULT PrlBootDev_GetIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32_PTR pnDevIndex
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnDevIndex
[out] A pointer to a variable that receives the device index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device index is a property that, together with device type, is used to uniquely identify a device in the boot priority list of a virtual machine. The index should be the same index the device has in the main virtual machine configuration, which is determined using the PrlVmDev_GetIndex function.

See Also

PrlBootDev_SetIndex

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_GetSequenceIndex Function

PrlBootDev_GetSequenceIndex Function
PHT_BOOT_DEVICE See Also

Obtains the boot device sequence index.

Syntax
PRL_RESULT PrlBootDev_GetSequenceIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32_PTR pnSequenceIndex
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnSequenceIndex
[out] A pointer to a variable that receives the device sequence index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The boot device sequence index starts with 0. When a virtual machine is powered on, it will first try to boot from the boot device that has a sequence index of 0. If it cannot boot from the device, it will try to boot from the device with sequence index 1, and so forth.

See Also

PrlBootDev_SetSequenceIndex

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_GetType Function

PrlBootDev_GetType Function
PHT_BOOT_DEVICE See Also

Returns the boot device type.

Syntax
PRL_RESULT PrlBootDev_GetType(
    PRL_HANDLE hVmBootDev,
    PRL_DEVICE_TYPE_PTR pnDevType
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnDevType
[out] A pointer to a variable that receives the device type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device type is a property that, together with device index, is used to uniquely identify a device in the virtual machine boot list. The supported device types are defined in the PRL_DEVICE_TYPE enumeration.

See Also

PrlBootDev_SetType

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_IsInUse Function

PrlBootDev_IsInUse Function
PHT_BOOT_DEVICE See Also

Determines whether the boot device is enabled or disabled.

Syntax
PRL_RESULT PrlBootDev_IsInUse(
    PRL_HANDLE hVmBootDev,
    PRL_BOOL_PTR pbInUse
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pbInUse
[out] Pointer to a variable that receives the result PRL_TRUE indicates that the device is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A boot device can be either enabled or disabled. If a device is disabled, it is ignored during the boot operation. To change the status of a device, use the PrlBootDev_SetInUse function.

See Also

PrlBootDev_SetInUse

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_Remove Function

PrlBootDev_Remove Function
PHT_BOOT_DEVICE

Removes the boot device from the boot priority list.

Syntax
PRL_RESULT PrlBootDev_Remove(
    PRL_HANDLE hVmBootDev
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function permanently removes a devices from the list. If you would like to temporarily disable a device, use the PrlBootDev_SetInUse function. To add a device back to the list, use PrlVmCfg_CreateBootDev and then call the necessary functions of the PHT_BOOT_DEVICE handle to set the necessary properties.

Links
PHT_BOOT_DEVICE


PrlBootDev_SetIndex Function

PrlBootDev_SetIndex Function
PHT_BOOT_DEVICE See Also

Sets the boot device index.

Syntax
PRL_RESULT PrlBootDev_SetIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32 nDevIndex
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nDevIndex
The index of the device of interest as it exists in the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device index is a property that, together with device type, is used to uniquely identify a device in the virtual machine boot priority list. The index must be the same index the device has in the main virtual machine configuration or it will not be recognized during the boot procedure. To obtain a virtual device index from the virtual machine configuration, use the PrlVmDev_GetIndex function.

See Also

PrlBootDev_GetIndex

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_SetInUse Function

PrlBootDev_SetInUse Function
PHT_BOOT_DEVICE See Also

Enables or disables the boot device.

Syntax
PRL_RESULT PrlBootDev_SetInUse(
    PRL_HANDLE hVmBootDev,
    PRL_BOOL bInUse
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
bInUse
A boolean value specifying the action type. PRL_TRUE enables a device, PRL_FALSE disables it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A boot device can be enabled or disabled without being removed from the boot device priority list. If the device is disabled, it is ignored during the boot operation. To obtain the current status of a device, use the PrlBootDev_IsInUse function. To permanently remove a device from the list, use the PrlBootDev_Remove function.

See Also

PrlBootDev_IsInUse

PrlBootDev_Remove

Links
PHT_BOOT_DEVICE, See Also


PrlBootDev_SetSequenceIndex Function

PrlBootDev_SetSequenceIndex Function
PHT_BOOT_DEVICE Example See Also

Assigns a sequence index to a boot device in the boot priority list.

Syntax
PRL_RESULT PrlBootDev_SetSequenceIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32 nSequenceIndex
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nSequenceIndex
The boot sequence index to set for the device. The value of 0 (zero) is the highest boot priority and indicates the first device to boot from. The value of 1 (one) indicates the second device to boot from, and so forth.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The boot device sequence index starts with 0. When a virtual machine is powered on, it will first try to boot from the boot device that has a sequence index of 0. If it cannot boot from the device, it will try to boot from the device with sequence index 1, and so forth.

If you are changing a sequence index for an existing device, this is the only function that you have to call. If you are adding a new boot device to the list, you will have to set all the other properties, including the device index, type, and enabled/disabled flag. Please note that each device in the boot priority list must have a unique sequence index, so if you are modifying a sequence index for an existing device or assigning an index to a new device, you will have to make sure that no two devices have the same index.

See Also

PrlBootDev_GetSequenceIndex

Example
PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);
ret = PrlJob_Wait(hJobBeginEdit, 10000);
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// Modify boot options.
// Set boot device list as follows:
// 0. CD/DVD drive.
// 1. Hard disk.
// 2. Network adapter.
// 3. Floppy disk drive.
//
PRL_UINT32 nDevCount; // Device count.
PRL_HANDLE hDevice;   // A handle to the device.
PRL_DEVICE_TYPE devType; // Device type.

// Get the total number of devices.
ret = PrlVm_GetBootDevCount(hVm, &nDevCount);

// Iterate through the device list.
// Get a handle for each available device.
// Set an index for a device in the boot list.
for (int i = 0; i < nDevCount; ++i)
{
    ret = PrlVm_GetBootDev(hVm, i, &hDevice);
    ret = PrlBootDev_GetType(hDevice, &devType);

    if (devType == PDE_OPTICAL_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 0);
    }
    if (devType == PDE_HARD_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 1);
    }
    else if (devType == PDE_GENERIC_NETWORK_ADAPTER)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 2);
    }
    else if (devType == PDE_FLOPPY_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 3);
    }
    else
    {
        PrlBootDev_Remove(hDevice);
    }
}

// Commit the changes.
hJobCommit = PrlVm_Commit(hVm);

// Check the results of the commit operation.
ret = PrlJob_Wait(hJobCommit, 10000);
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PHT_BOOT_DEVICE, Example, See Also


PrlBootDev_SetType Function

PrlBootDev_SetType Function
PHT_BOOT_DEVICE See Also

Sets the boot device type.

Syntax
PRL_RESULT PrlBootDev_SetType(
    PRL_HANDLE hVmBootDev,
    PRL_DEVICE_TYPE nDevType
);
File

PrlApiVm.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nDevType
The device type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when adding a device to the boot device priority list. Device type is a property that, together with device index, is used to uniquely identify a device in a virtual machine boot list. When adding a device to the boot priority list, these properties must be set correctly or the device will not be recognized. The supported device types are defined in the PRL_DEVICE_TYPE enumeration.

See Also

PrlBootDev_GetType

Links
PHT_BOOT_DEVICE, See Also


PrlBuffer_Free Function

PrlBuffer_Free Function
PrlBuffer

Frees a buffer allocated by the Parallels API library and returned to the client.

Syntax
PRL_RESULT PrlBuffer_Free(
    PRL_VOID_PTR buffer
);
File

PrlApiCore.h

Parameters

buffer
A pointer to a buffer to free.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid pointer to the buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

Every time a pointer to a buffer containing the data is returned to the client, it must be freed using this function. Failure to do so will result in memory leaks.

Links
PrlBuffer


PrlCtTemplate_GetCpuMode Function

PrlCtTemplate_GetCpuMode Function
PHT_CT_TEMPLATE

Determines the specified template CPU mode (32 bit or 64 bit).

Syntax
PRL_RESULT PrlCtTemplate_GetCpuMode(
    PRL_HANDLE hTemplate,
    PRL_CPU_MODE_PTR pnCpuMode
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
pnCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the template object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetDescription Function

PrlCtTemplate_GetDescription Function
PHT_CT_TEMPLATE

Returns description of the Container's template.

Syntax
PRL_RESULT PrlCtTemplate_GetDescription(
    PRL_HANDLE hTemplate,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionLength
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetName Function

PrlCtTemplate_GetName Function
PHT_CT_TEMPLATE

Returns name of the Container's template.

Syntax
PRL_RESULT PrlCtTemplate_GetName(
    PRL_HANDLE hTemplate,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameLength
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
sName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetOsTemplate Function

PrlCtTemplate_GetOsTemplate Function
PHT_CT_TEMPLATE

Returns the version of the operating system template for which the specified application template is.

Syntax
PRL_RESULT PrlCtTemplate_GetOsTemplate(
    PRL_HANDLE hTemplate,
    PRL_STR sOsTemplate,
    PRL_UINT32_PTR pnOsTemplateLength
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
sOsTemplate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOsTemplateLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetOsType Function

PrlCtTemplate_GetOsType Function
PHT_CT_TEMPLATE

Returns the type of the operating system for which the specified template is.

Syntax
PRL_RESULT PrlCtTemplate_GetOsType(
    PRL_HANDLE hTemplate,
    PRL_UINT32_PTR pnOsType
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
pnOsType
[out] A pointer to a variable that receives the OS type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the OS information is not present in the template configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_LINUX).

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetOsVersion Function

PrlCtTemplate_GetOsVersion Function
PHT_CT_TEMPLATE

Returns the version of the operating system for which the specified template is running.

Syntax
PRL_RESULT PrlCtTemplate_GetOsVersion(
    PRL_HANDLE hTemplate,
    PRL_UINT32_PTR pnOsVersion
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
pnOsVersion
[out] A pointer to a variable that receives the OS version.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the OS information is not present in the template configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_LIN_REDHAT).

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetType Function

PrlCtTemplate_GetType Function
PHT_CT_TEMPLATE

Returns the type of the specified template.

Syntax
PRL_RESULT PrlCtTemplate_GetType(
    PRL_HANDLE hTemplate,
    PRL_CT_TEMPLATE_TYPE_PTR pType
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
pnType
[out] A pointer to a variable that receives the type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_GetVersion Function

PrlCtTemplate_GetVersion Function
PHT_CT_TEMPLATE

Returns version of the Container's template.

Syntax
PRL_RESULT PrlCtTemplate_GetVersion(
    PRL_HANDLE hTemplate,
    PRL_STR sVersion,
    PRL_UINT32_PTR pnVersionLength
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
sVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CT_TEMPLATE


PrlCtTemplate_IsCached Function

PrlCtTemplate_IsCached Function
PHT_CT_TEMPLATE

Determines whether the template cached.

Syntax
PRL_RESULT PrlCtTemplate_IsCached(
    PRL_HANDLE hTemplate,
    PRL_BOOL_PTR pbCached
);
File

PrlApiVm.h

Parameters

hTemplate
A handle of type PHT_CT_TEMPLATE.
pbCached
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the template object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Makes sense only for operating system templates.

Links
PHT_CT_TEMPLATE


PrlCVSrc_Close Function

PrlCVSrc_Close Function
PHT_CVSRC

Close channel previously opened with PrlCVSrc_Open().

Syntax
PRL_RESULT PrlCVSrc_Close(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_Connect Function

PrlCVSrc_Connect Function
PHT_CVSRC

Connects source to Vm.

Syntax
PRL_RESULT PrlCVSrc_Connect(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_CVSRC_IO_ERROR - failed to send connect request. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_Disconnect Function

PrlCVSrc_Disconnect Function
PHT_CVSRC

Disconnects source from Vm.

Syntax
PRL_RESULT PrlCVSrc_Disconnect(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_GetBuffer Function

PrlCVSrc_GetBuffer Function
PHT_CVSRC

Returns frame buffer pointer and size.

Syntax
PRL_RESULT PrlCVSrc_GetBuffer(
    PRL_HANDLE hCVSrc,
    PRL_VOID_PTR_PTR pPtr,
    PRL_UINT32_PTR uSize
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.
pPtr
[out] Will receive pointer on frame buffer.
uSize
[out] Will receive size of frame buffer(in bytes).

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Source IO channel must be opened with PrlCVSrc_Open() and buffer must be locked with PrlCVSrc_LockBuffer().

Links
PHT_CVSRC


PrlCVSrc_GetOpenMode Function

PrlCVSrc_GetOpenMode Function
PHT_CVSRC

Returns current mode obtained after call to PrlCVSrc_Open().

Syntax
PRL_RESULT PrlCVSrc_GetOpenMode(
    PRL_HANDLE hCVSrc,
    PRL_CVSRC_OPEN_MODE_PTR pOpenMode
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.
pOpenMode
[out] Receives current mode.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_LockBuffer Function

PrlCVSrc_LockBuffer Function
PHT_CVSRC

Locks access to frame buffer.

Syntax
PRL_RESULT PrlCVSrc_LockBuffer(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_Open Function

PrlCVSrc_Open Function
PHT_CVSRC

Open channel to supply frames to Vm.

Syntax
PRL_RESULT PrlCVSrc_Open(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_CVSRC_NO_OPEN_REQUEST - no pending open request from Vm. PRL_ERR_CVSRC_NO_CHANNEL - failed to establish IO channel for source. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Must be called after receiving PET_IO_CVSRC_OPEN event.

Links
PHT_CVSRC


PrlCVSrc_SetLocalizedName Function

PrlCVSrc_SetLocalizedName Function
PHT_CVSRC

Set source name.

Syntax
PRL_RESULT PrlCVSrc_SetLocalizedName(
    PRL_HANDLE hCVSrc,
    PRL_CONST_STR sLocalizedName
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.
sLocalizedName
[in] Source localized name (UTF-8 encoded).

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_SetUniqueId Function

PrlCVSrc_SetUniqueId Function
PHT_CVSRC

Set source unique id.

Syntax
PRL_RESULT PrlCVSrc_SetUniqueId(
    PRL_HANDLE hCVSrc,
    PRL_CONST_STR sUniqueId
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.
sUniqueId
[in] Source unique id (UTF-8 encoded).

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlCVSrc_UnlockBuffer Function

PrlCVSrc_UnlockBuffer Function
PHT_CVSRC

Unlocks access to frame buffer and submits changes to Vm.

Syntax
PRL_RESULT PrlCVSrc_UnlockBuffer(
    PRL_HANDLE hCVSrc
);
File

PrlApiVm.h

Parameters

hCVSrc
[in] A handle of type PHT_CVSRC identifying the source.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_CVSRC


PrlDbg_EventTypeToString Function

PrlDbg_EventTypeToString Function
API Debug Functions

Returns a readable string representation of the specified event type.

Syntax
PRL_RESULT PrlDbg_EventTypeToString(
    PRL_EVENT_TYPE event_type,
    PRL_CONST_STR_PTR result
);
File

PrlApiCore.h

Parameters

event_type
Event type.
result
[out] Event type as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
API Debug Functions


PrlDbg_GetHandlesNum Function

PrlDbg_GetHandlesNum Function
API Debug Functions

The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.

Syntax
PRL_RESULT PrlDbg_GetHandlesNum(
    PRL_UINT32_PTR handles_num,
    PRL_HANDLE_TYPE type
);
File

PrlApiCore.h

Parameters

handles_num
[out] A pointer to a variable that receives the result.
type
specifies type of handles which instances num necessary to return. If this param has value PHT_ERROR then handle type is ignored and method returns common handles num. Note: using this method in case to get num of handles instances of concrete type may suspends SDK lib functionality on a quite long time.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid (NULL) pointer for storing result was passed PRL_ERR_SUCCESS - operation completed successfully

Links
API Debug Functions


PrlDbg_HandleTypeToString Function

PrlDbg_HandleTypeToString Function
API Debug Functions

Returns a readable string representation of the specified handle type.

Syntax
PRL_RESULT PrlDbg_HandleTypeToString(
    PRL_HANDLE_TYPE handle_type,
    PRL_CONST_STR_PTR result
);
File

PrlApiCore.h

Parameters

handle_type
Handle type.
result
[out] Handle type as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
API Debug Functions


PrlDbg_PrlResultToString Function

PrlDbg_PrlResultToString Function
API Debug Functions

Returns a readable string representation of the PRL_RESULT value.

Syntax
PRL_RESULT PrlDbg_PrlResultToString(
    PRL_RESULT value,
    PRL_CONST_STR_PTR result
);
File

PrlApiCore.h

Parameters

value
A variable of type PRL_RESULT.
result
[out] The PRL_RESULT value as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
API Debug Functions


PrlDevAudio_GetSwitcherState Function

PrlDevAudio_GetSwitcherState Function
Audio Playback

Get state of the audio switcher from host.

Syntax
PRL_RESULT PrlDevAudio_GetSwitcherState(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - audio input stream start request has been sent.

PRL_ERR_FAILURE - send of input start request to Vm has been failed.

PRL_ERR_INVALID_ARG - Vm handle is incorrect or some pointer is invalid.

PRL_ERR_UNINITIALIZED - there is no any valid connection to Vm. #PrlDevDisplay_ConnectToVm wasn't called.

Remarks

If client is not connected to vm with #PrlDevDisplay_ConnectToVm call error will be returned, otherwise start request will be sent, PRL_ERR_SUCCESS returned and event #PET_IO_CLI_GET_AUDIO_SWITCH_SETTINGS_RESPONSE with operation status code should be handled.

Links
Audio Playback


PrlDevAudio_SetSwitcherState Function

PrlDevAudio_SetSwitcherState Function
Audio Playback

Set state of the audio switcher.

Syntax
PRL_RESULT PrlDevAudio_SetSwitcherState(
    PRL_HANDLE hVm,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bEnabled
new state of switcher as boolean. PRL_TRUE means enabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - audio input stream start request has been sent.

PRL_ERR_FAILURE - send of input start request to Vm has been failed.

PRL_ERR_INVALID_ARG - Vm handle is incorrect or some pointer is invalid.

PRL_ERR_UNINITIALIZED - there is no any valid connection to Vm. #PrlDevDisplay_ConnectToVm wasn't called.

Remarks

If client is not connected to vm with #PrlDevDisplay_ConnectToVm call error will be returned, otherwise start request will be sent, PRL_ERR_SUCCESS returned.

Links
Audio Playback


PrlDevAudio_StartStream Function

PrlDevAudio_StartStream Function
Audio Playback

Starts audio stream from client to Vm.

Syntax
PRL_RESULT PrlDevAudio_StartStream(
    PRL_HANDLE hVm,
    PRL_AUDIO_STREAM_TYPE Type
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
Type
Value from PRL_AUDIO_STREAM_TYPE enumeration selecting play or recording stream type

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - audio input stream start request has been sent.

PRL_ERR_FAILURE - send of input start request to Vm has been failed.

PRL_ERR_INVALID_ARG - Vm handle is incorrect or some pointer is invalid.

PRL_ERR_UNINITIALIZED - there is no any valid connection to Vm. #PrlDevDisplay_ConnectToVm wasn't called.

PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED - audio encodings are not supported on the server.

Remarks

If client is not connected to vm with #PrlDevDisplay_ConnectToVm call error will be returned, otherwise start request will be sent, PRL_ERR_SUCCESS returned and event #PET_IO_AUDIO_STREAM_STARTED with operation status code should be handled.

Links
Audio Playback


PrlDevAudio_StopStream Function

PrlDevAudio_StopStream Function
Audio Playback

Stops audio stream.

Syntax
PRL_RESULT PrlDevAudio_StopStream(
    PRL_HANDLE hVm,
    PRL_AUDIO_STREAM_TYPE Type
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
Type
Value from PRL_AUDIO_STREAM_TYPE enumeration selecting play or recording stream type

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - audio input stream was stopped.

PRL_ERR_INVALID_ARG - Vm handle is incorrect.

PRL_ERR_UNINITIALIZED - there is no any valid connection to Vm or audio input stream was never started.

PRL_ERR_AUDIO_ENCODINGS_NOT_SUPPORTED - audio encodings are not supported on the server.

Links
Audio Playback


PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To obtain a pointer to a buffer containing the image, use the PrlJob_GetDataPtr function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer

Links
Primary Display Capture, See Also


PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function

PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile

Links
Primary Display Capture, See Also


PrlDevDisplay_AsyncCaptureScreenRegionToFile Function

PrlDevDisplay_AsyncCaptureScreenRegionToFile Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile

Links
Primary Display Capture, See Also


PrlDevDisplay_ConnectToVm Function

PrlDevDisplay_ConnectToVm Function
Primary Display Capture

Connects to a virtual machine to begin a remote desktop access session.

Syntax
PRL_HANDLE PrlDevDisplay_ConnectToVm(
    PRL_HANDLE hObj,
    PRL_DISPLAY_CODEC_TYPE type
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
type
Codec type to be used during the remote desktop screen capture. If server supports display encodings (use #PrlSrv_GetDisplayEncodingList) your can use encoding type (PRL_IO_DISPLAY_ENCODING.encodingType) instead of PRL_DISPLAY_CODEC_TYPE enum.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function must be called before any other function calls related to the remote desktop access functionality.

Notes

use this call to receive supported server display encodings: PrlSrv_GetDisplayEncodingList also you can receive or change display encoding at runtime: PrlDevDisplay_SetDisplayEncoding PrlDevDisplay_GetDisplayEncoding

Links
Primary Display Capture


PrlDevDisplay_ConnectToVmEx Function

PrlDevDisplay_ConnectToVmEx Function
Primary Display Capture

Connects to a virtual machine to begin a remote desktop access session.

Syntax
PRL_HANDLE PrlDevDisplay_ConnectToVmEx(
    PRL_HANDLE hObj,
    const PRL_IO_DISPLAY_ENCODING_PTR pEnc,
    PRL_DISPLAY_BUFFER_FORMAT format
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pEnc
Codec type to be used during the remote desktop screen capture. If server supports display encodings (use #PrlSrv_GetDisplayEncodingList) your can use pointer to encoder.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object PRL_ERR_DISPLAY_FORMAT_NOT_SUPPORTED if specified format is not supported

Remarks

This function must be called before any other function calls related to the remote desktop access functionality.

Notes

use this call to receive supported server display encodings: PrlSrv_GetDisplayEncodingList also you can receive or change display encoding at runtime: PrlDevDisplay_SetDisplayEncoding PrlDevDisplay_GetDisplayEncoding format : Conversion format of inner display screen buffer. If conversion format is not supported by SDK error will be returned

Links
Primary Display Capture


PrlDevDisplay_DisconnectFromVm Function

PrlDevDisplay_DisconnectFromVm Function
Primary Display Capture

Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.

Syntax
PRL_RESULT PrlDevDisplay_DisconnectFromVm(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Primary Display Capture


PrlDevDisplay_GetAvailableDisplaysCount Function

PrlDevDisplay_GetAvailableDisplaysCount Function
Primary Display Capture

Returns available displays count of a remote virtual machine desktop.

Syntax
PRL_RESULT PrlDevDisplay_GetAvailableDisplaysCount(
    PRL_HANDLE hVm,
    PRL_UINT32_PTR pDisplaysCount
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pDisplaysCount
Refrence to variable that will receive available display count. 0 will be returned if information about displays is not available or Parallels Tools is not started.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_UNINITIALIZED - the library was not initialized. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallells Tools must be installed for retreive real displays count.

Links
Primary Display Capture


PrlDevDisplay_GetDisplayEncoding Function

PrlDevDisplay_GetDisplayEncoding Function
Primary Display Capture

Gets current encoding of specified Vm.

Syntax
PRL_RESULT PrlDevDisplay_GetDisplayEncoding(
    PRL_HANDLE hObj,
    PRL_IO_DISPLAY_ENCODING_PTR pOutEnc
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pOutEnc
Encoding description as out parameter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - out parameter has been filled with current display encoding.

PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED - display encodings are not supported on server, connection is local or remote connection does not exist anymore.

PRL_ERR_INVALID_ARG - pOutEnc pointer is wrong or hVm does not exist.

Links
Primary Display Capture


PrlDevDisplay_GetDynResToolStatus Function

PrlDevDisplay_GetDynResToolStatus Function
Primary Display Capture

Determines whether Dynamic Resolution feature is available in the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_GetDynResToolStatus(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR status
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
status
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that Dynamic Resolution is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Dynamic Resolution is a feature that comes with the Parallels Tools package. It provides facilities for adjusting the guest OS screen resolution on the fly. Use this function to determine whether the Dynamic Resolution feature is installed and running. If the feature is available, you can use the PrlDevDisplay_SendScreenSizeEvent function to programmatically adjust the guest OS screen resolution.

Links
Primary Display Capture


PrlDevDisplay_GetScreenBuffer Function

PrlDevDisplay_GetScreenBuffer Function
Primary Display Capture

Returns the contents of the screen buffer of the primary display.

Syntax
PRL_RESULT PrlDevDisplay_GetScreenBuffer(
    PRL_HANDLE hObj,
    PRL_UINT32_PTR_PTR buffer,
    PRL_INT32_PTR lineSize
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
buffer
[out] A pointer to a buffer that receives the data. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.
lineSize
Line size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that the primary screen buffer can be refreshed at any time from inside the virtual machine. To prevent incomplete or corrupt data, use the PrlDevDisplay_LockForRead function to temporarily suspend refreshing of the screen on the virtual machine side. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.

Links
Primary Display Capture


PrlDevDisplay_GetScreenSize Function

PrlDevDisplay_GetScreenSize Function
Primary Display Capture

Returns the primary display screen size of the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_GetScreenSize(
    PRL_HANDLE hObj,
    PRL_IO_SCREEN_SIZE_PTR size
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
size
[out] A pointer to a structure containing the screen size properties.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Primary Display Capture


PrlDevDisplay_IsSlidingMouseEnabled Function

PrlDevDisplay_IsSlidingMouseEnabled Function
Primary Display Capture

Determines if Sliding Mouse feature is enabled in the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_IsSlidingMouseEnabled(
    PRL_HANDLE hObj,
    PRL_BOOL_PTR flag
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
flag
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that sliding mouse is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Sliding Mouse is a feature that comes with Parallels Tools package. If Sliding Mouse is enabled, the mouse cursor can "slide" from the virtual machine desktop to the host OS desktop without pressing any of the special keys on the keyboard. This function is used when writing remote desktop applications with graphical user interfaces. For more information, see the Mouse Control section in this chapter.

Links
Primary Display Capture


PrlDevDisplay_LockForRead Function

PrlDevDisplay_LockForRead Function
Primary Display Capture

Locks the primary screen buffer disallowing any updates to the data it contains.

Syntax
PRL_RESULT PrlDevDisplay_LockForRead(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When you obtain a screen capture, you should call this function first to prevent all further updates to the screen buffer. This is done in order to minimize the local machine resource usage, to speed up the screen buffer read operations, and to prevent possible data loss. To obtain the data from the buffer, use the PrlDevDisplay_GetScreenBuffer function. When you are done reading the data, call the PrlDevDisplay_Unlock to remove the lock.

Links
Primary Display Capture


PrlDevDisplay_NeedCursorData Function

PrlDevDisplay_NeedCursorData Function
Primary Display Capture

The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_NeedCursorData(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function sends a request to the virtual machine and immediately returns. The data is received as a PHT_EVENT handle via callback.

Links
Primary Display Capture


PrlDevDisplay_SendCaptureScreenRequest Function

PrlDevDisplay_SendCaptureScreenRequest Function
Primary Display Capture

Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.

Syntax
PRL_RESULT PrlDevDisplay_SendCaptureScreenRequest(
    PRL_HANDLE hObj,
    const PRL_IO_SCREEN_REGION_PTR pRect
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pRect
Parameters of the screen region to capture. If negative rectangle is passed, cancellation request will be send.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The screen data is received as an event via callback every time the specified screen region data is modified. This function is used when an efficient optimization of the screen update on the client side is needed.

Links
Primary Display Capture


PrlDevDisplay_SendScreenSizeEvent Function

PrlDevDisplay_SendScreenSizeEvent Function
Primary Display Capture

Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.

Syntax
PRL_RESULT PrlDevDisplay_SendScreenSizeEvent(
    PRL_HANDLE hVm,
    const PRL_IO_SCREEN_SIZE_PTR size
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
size
The new screen resolution parameters.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The guest OS can accept or reject the new resolution depending on compatibility factors. The function does not provide information on whether the new resolution was accepted or not. The PRL_ERR_SECCESS return code means that the function didn't fail but it doesn't mean that the screen resolution was actually changed. To verify the results of the operation, you can capture the guest OS screen before and after executing this function and compare the results. You can use this function only if the Parallels Tools package is installed in the target virtual machine and if the Dynamic Resolution feature is turned on. To determine the status of the Dynamic Resolution feature, use the PrlDevDisplay_GetDynResToolStatus function.

Links
Primary Display Capture


PrlDevDisplay_SetConfiguration Function

PrlDevDisplay_SetConfiguration Function
Primary Display Capture

Sends a request to a virtual machine to set guest display configuration to specified values.

Syntax
PRL_RESULT PrlDevDisplay_SetConfiguration(
    PRL_HANDLE hVm,
    const PRL_IO_DISPLAY_SCREEN_SIZE_PTR displays,
    PRL_INT32 nCount
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nCount
Count of displays in array.
size
Array of display configurations for all guest displays that will be enabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The guest OS can accept or reject the new resolution depending on compatibility factors. The function does not provide information on whether the new resolution was accepted or not. The PRL_ERR_SECCESS return code means that the function didn't fail but it doesn't mean that the screen resolution was actually changed. To verify the results of the operation, you can capture the guest OS screen before and after executing this function and compare the results. You can use this function only if the Parallels Tools package is installed in the target virtual machine and if the Dynamic Resolution feature is turned on. To determine the status of the Dynamic Resolution feature, use the PrlDevDisplay_GetDynResToolStatus function.

Links
Primary Display Capture


PrlDevDisplay_SetDisplayEncoding Function

PrlDevDisplay_SetDisplayEncoding Function
Primary Display Capture

Sets display encoding for specified Vm.

Syntax
PRL_RESULT PrlDevDisplay_SetDisplayEncoding(
    PRL_HANDLE hObj,
    const PRL_IO_DISPLAY_ENCODING_PTR pEnc
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pEnc
Encoding description. Use #PrlSrv_GetDisplayEncodingList to have a list of supported encodings.

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - specified encoding exists, request has been successfully sent to server. Encoding will be changed in few moments.

PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED - display encodings are not supported on server, connection is local or remote connection does not exist anymore.

PRL_ERR_FAILURE - sending operation of encoding request has been failed.

PRL_ERR_INVALID_ARG - pEnc pointer is wrong or hVm does not exist.

Links
Primary Display Capture


PrlDevDisplay_SetDpiConfiguration Function

PrlDevDisplay_SetDpiConfiguration Function
Primary Display Capture

Sends a request to a virtual machine to set guest DPI display configuration to specified values.

Syntax
PRL_RESULT PrlDevDisplay_SetDpiConfiguration(
    PRL_HANDLE hVm,
    const PRL_IO_DPI_DISPLAY_SCREEN_SIZE_PTR displays,
    PRL_INT32 nCount
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
displays
Array of DPI display configurations for all guest displays that will be enabled.
nCount
Count of displays in array.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The guest OS can accept or reject the new resolution depending on compatibility factors. The function does not provide information on whether the new resolution was accepted or not. The PRL_ERR_SECCESS return code means that the function didn't fail but it doesn't mean that the screen resolution was actually changed. To verify the results of the operation, you can capture the guest OS screen before and after executing this function and compare the results. You can use this function only if the Parallels Tools package is installed in the target virtual machine and if the Dynamic Resolution feature is turned on. To determine the status of the Dynamic Resolution feature, use the PrlDevDisplay_GetDynResToolStatus function.

Links
Primary Display Capture


PrlDevDisplay_SetScreenSurface Function

PrlDevDisplay_SetScreenSurface Function
Primary Display Capture
Syntax
PRL_RESULT PrlDevDisplay_SetScreenSurface(
    PRL_HANDLE hVm,
    PRL_UINT32 n1,
    PRL_UINT32 n2,
    PRL_UINT32 n3,
    PRL_INT32 n4,
    PRL_INT32 n5,
    PRL_UINT32 n6,
    PRL_UINT32 n7
);
File

PrlApiVm.h

Links
Primary Display Capture


PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_VOID_PTR_PTR buff,
    PRL_UINT32_PTR buffSize,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
buff
[out] A pointer to a buffer containing the screen data. The buffer must be freed with PrlBuffer_Free when no longer needed.
buffSize
The size of the buffer received in the buff parameter (above).
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer

Links
Primary Display Capture, See Also


PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function

PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScreenRegionToFile. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile

Links
Primary Display Capture, See Also


PrlDevDisplay_SyncCaptureScreenRegionToFile Function

PrlDevDisplay_SyncCaptureScreenRegionToFile Function
Primary Display Capture See Also

Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScreenRegionToFile. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile

Links
Primary Display Capture, See Also


PrlDevDisplay_Unlock Function

PrlDevDisplay_Unlock Function
Primary Display Capture

Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.

Syntax
PRL_RESULT PrlDevDisplay_Unlock(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Primary Display Capture


PrlDevKeyboard_SendKeyEvent Function

PrlDevKeyboard_SendKeyEvent Function
Keyboard Control

Sends a keyboard key event to a virtual machine.

Syntax
PRL_RESULT PrlDevKeyboard_SendKeyEvent(
    PRL_HANDLE hVm,
    PRL_UINT32 key,
    PRL_KEY_EVENT ev
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the virtual machine.
key
Key code. See the PrlKeys.h file for the list of the available key codes.
ev
Event type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To send a single key-pressed event, first call this function passing the desired key code and PKE_PRESS as the event type. Then call the function again passing the same key code and PKE_RELEASE as the event type. To send a key combination event, first call the function passing the code of the first key (usually a modifier key, such as Ctrl, Shift, Alt) and PKE_PRESS as the event type. Then call the function passing the code of the second key with PKE_PRESS. Continue with other keys (if more than two). Then call the function in reverse order for each key passing PKE_RELEASE as the event type.

Links
Keyboard Control


PrlDevKeyboard_SendKeyEventEx Function

PrlDevKeyboard_SendKeyEventEx Function
Keyboard Control

Sends a keyboard key event to a virtual machine.

Syntax
PRL_RESULT PrlDevKeyboard_SendKeyEventEx(
    PRL_HANDLE hVm,
    PRL_KEY key,
    PRL_KEY_EVENT ev
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the virtual machine.
key
Key code. See the PrlKeys.h file for the list of the available key codes.
ev
Event type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To send a single key-pressed event, first call this function passing the desired key code and PKE_PRESS as the event type. Then call the function again passing the same key code and PKE_RELEASE as the event type. To send a key combination event, first call the function passing the code of the first key (usually a modifier key, such as Ctrl, Shift, Alt) and PKE_PRESS as the event type. Then call the function passing the code of the second key with PKE_PRESS. Continue with other keys (if more than two). Then call the function in reverse order for each key passing PKE_RELEASE as the event type.

Links
Keyboard Control


PrlDevKeyboard_SendKeyPressedAndReleased Function

PrlDevKeyboard_SendKeyPressedAndReleased Function
Keyboard Control

Sends a keyboard key pressed and released to a virtual machine.

Syntax
PRL_RESULT PrlDevKeyboard_SendKeyPressedAndReleased(
    PRL_HANDLE hVm,
    PRL_KEY key
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the virtual machine.
key
Key code. See the PrlKeys.h file for the list of the available key codes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Keyboard Control


PrlDevMouse_AsyncMove Function

PrlDevMouse_AsyncMove Function
Mouse Control

Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).

Syntax
PRL_HANDLE PrlDevMouse_AsyncMove(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_INT32 w,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate offset.
y
Y coordinate offset.
z
Z coordinate offset (scroll).
w
W coordinate offset (h-scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_HANDLE. Handle on sending operation

Remarks

This function can only be used if Parallels Tools are NOT installed in the target virtual machine. The position to which you want to move the pointer is always calculated relatively to the center of the screen (as if the center had coordinates X=0; Y=0). When a virtual machine powers up, the cursor in it is automatically positioned at the center of the screen. To move the cursor to the desired absolute coordinates within the virtual machine screen coordinate grid, calculate the offset of the destination point relatively to the center of the virtual machine screen and pass those values to this function as X and Y coordinates. Use positive values when moving the cursor right or down, use negative values when moving the cursor left or up.

Links
Mouse Control


PrlDevMouse_AsyncSetPos Function

PrlDevMouse_AsyncSetPos Function
Mouse Control

Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).

Syntax
PRL_HANDLE PrlDevMouse_AsyncSetPos(
    PRL_HANDLE hObj,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_INT32 w,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
x
X coordinate to move the mouse pointer to.
y
Y coordinate to move the mouse pointer to.
z
Z coordinate to mouse pointer to (scroll).
w
W coordinate to mouse pointer to (h-scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_HANDLE. Handle on sending operation

Remarks

This function can only be used if Parallels Tools package is installed in the target virtual machine and if Sliding Mouse feature is enabled. To find out if Sliding Mouse is enabled, use the PrlDevDisplay_IsSlidingMouseEnabled function.

Links
Mouse Control


PrlDevMouse_Event Function

PrlDevMouse_Event Function
Mouse Control

Sends absolute or relative mouse event with specified parameters within the virtual machine display coordinate grid.

Syntax
PRL_RESULT PrlDevMouse_Event(
    PRL_HANDLE hObj,
    const PRL_IO_MOUSE_EVENT_EX2 * mouse,
    PRL_UINT32 size,
    PRL_BOOL absolute
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
mouse
Mouse event parameters.
size
Parameters structure size.
absolute
Whether event location is absolute.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Absolute event can only be sent if Parallels Tools package is installed in the target virtual machine and if Sliding Mouse feature is enabled. To find out if Sliding Mouse is enabled, use the PrlDevDisplay_IsSlidingMouseEnabled function.

Links
Mouse Control


PrlDevMouse_Move Function

PrlDevMouse_Move Function
Mouse Control

Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_Move(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate offset.
y
Y coordinate offset.
z
Z coordinate offset (scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools are NOT installed in the target virtual machine. The position to which you want to move the pointer is always calculated relatively to the center of the screen (as if the center had coordinates X=0; Y=0). When a virtual machine powers up, the cursor in it is automatically positioned at the center of the screen. To move the cursor to the desired absolute coordinates within the virtual machine screen coordinate grid, calculate the offset of the destination point relatively to the center of the virtual machine screen and pass those values to this function as X and Y coordinates. Use positive values when moving the cursor right or down, use negative values when moving the cursor left or up.

Links
Mouse Control


PrlDevMouse_MoveEx Function

PrlDevMouse_MoveEx Function
Mouse Control

Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_MoveEx(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_INT32 w,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate offset.
y
Y coordinate offset.
z
Z coordinate offset (scroll).
w
W coordinate offset (h-scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools are NOT installed in the target virtual machine. The position to which you want to move the pointer is always calculated relatively to the center of the screen (as if the center had coordinates X=0; Y=0). When a virtual machine powers up, the cursor in it is automatically positioned at the center of the screen. To move the cursor to the desired absolute coordinates within the virtual machine screen coordinate grid, calculate the offset of the destination point relatively to the center of the virtual machine screen and pass those values to this function as X and Y coordinates. Use positive values when moving the cursor right or down, use negative values when moving the cursor left or up.

Links
Mouse Control


PrlDevMouse_SetPos Function

PrlDevMouse_SetPos Function
Mouse Control

Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_SetPos(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate to move the mouse pointer to.
y
Y coordinate to move the mouse pointer to.
z
Z coordinate to mouse pointer to (scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools package is installed in the target virtual machine and if Sliding Mouse feature is enabled. To find out if Sliding Mouse is enabled, use the PrlDevDisplay_IsSlidingMouseEnabled function.

Links
Mouse Control


PrlDevMouse_SetPosEx Function

PrlDevMouse_SetPosEx Function
Mouse Control

Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_SetPosEx(
    PRL_HANDLE hObj,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_INT32 w,
    PRL_UINT32 buttons
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
x
X coordinate to move the mouse pointer to.
y
Y coordinate to move the mouse pointer to.
z
Z coordinate to mouse pointer to (scroll).
w
W coordinate to mouse pointer to (h-scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools package is installed in the target virtual machine and if Sliding Mouse feature is enabled. To find out if Sliding Mouse is enabled, use the PrlDevDisplay_IsSlidingMouseEnabled function.

Links
Mouse Control


PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function

PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
Secondary Display Capture See Also

Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.

Syntax
PRL_HANDLE PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, etc.)
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To obtain a pointer to a buffer containing the image, use the PrlJob_GetDataPtr function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer

Links
Secondary Display Capture, See Also


PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function

PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function
Secondary Display Capture See Also

Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, etc.)
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile

Links
Secondary Display Capture, See Also


PrlDevSecondaryDisplay_GetScreenBuffer Function

PrlDevSecondaryDisplay_GetScreenBuffer Function
Secondary Display Capture

Returns the contents of the screen buffer of the secondary display.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenBuffer(
    PRL_HANDLE hObj,
    PRL_UINT32 display,
    PRL_UINT32_PTR_PTR buffer,
    PRL_INT32_PTR lineSize
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
display
Display ID (0 for primary display, 1, 2, etc.)
buffer
[out] A pointer to a buffer that receives the screen data. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.
lineSize
[out] Line size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that the primary screen buffer can be refreshed at any time from inside the virtual machine. To prevent incomplete or corrupt data, use the PrlDevDisplay_LockForRead function to temporarily suspend refreshing of the screen on the virtual machine side. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.

Links
Secondary Display Capture


PrlDevSecondaryDisplay_GetScreenBufferEx Function

PrlDevSecondaryDisplay_GetScreenBufferEx Function
Secondary Display Capture

Returns the contents of the screen buffer of the secondary display and mapping handle on Windows host (on Unix host hMapping parameter will be always equal to buffer).

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenBufferEx(
    PRL_HANDLE hObj,
    PRL_UINT32 display,
    PRL_UINT32_PTR_PTR buffer,
    PRL_IO_DISPLAY_SCREEN_SIZE_PTR screenSize,
    PRL_VOID_PTR_PTR hMapping,
    PRL_UINT64_PTR mapOffset
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
display
Display ID (0 for primary display, 1, 2, etc.)
buffer
[out] A pointer to a buffer that receives the screen data. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.
screenSize
[out] Screen size.
hMapping
[out] Windows: a handle on screen memory mapping.
mapOffset
[out] Windows: an offset of screen buffer in mapping for specified display. Unix: ignored.
Unix
ignored.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that the primary screen buffer can be refreshed at any time from inside the virtual machine. To prevent incomplete or corrupt data, use the PrlDevDisplay_LockForRead function to temporarily suspend refreshing of the screen on the virtual machine side. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.

Links
Secondary Display Capture


PrlDevSecondaryDisplay_GetScreenBufferFormat Function

PrlDevSecondaryDisplay_GetScreenBufferFormat Function
Secondary Display Capture

Returns format of internal screen buffer.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenBufferFormat(
    PRL_HANDLE hObj,
    PRL_UINT32 display,
    PRL_DISPLAY_BUFFER_FORMAT_PTR format
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
display
Display ID (0 for primary display, 1, 2, etc.)
format
[out] A pointer that receives inner screen buffer format

Links
Secondary Display Capture


PrlDevSecondaryDisplay_GetScreenSize Function

PrlDevSecondaryDisplay_GetScreenSize Function
Secondary Display Capture

Returns the primary display screen size of the specified virtual machine.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenSize(
    PRL_HANDLE hObj,
    PRL_UINT32 display,
    PRL_IO_DISPLAY_SCREEN_SIZE_PTR size
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
size
[out] A pointer to a structure containing the screen size properties.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Secondary Display Capture


PrlDevSecondaryDisplay_SendCaptureScreenRequest Function

PrlDevSecondaryDisplay_SendCaptureScreenRequest Function
Secondary Display Capture

Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SendCaptureScreenRequest(
    PRL_HANDLE hObj,
    const PRL_IO_DISPLAY_SCREEN_REGION_PTR pRect
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pRect
Parameters of the screen region to capture. If negative rectangle is passed, cancellation request will be send.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The screen data is received as an event via callback every time the specified screen region data is modified. This function is used when an efficient optimization of the screen update on the client side is needed.

Links
Secondary Display Capture


PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer Function

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer Function
Secondary Display Capture

Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_VOID_PTR_PTR buff,
    PRL_UINT32_PTR buffSize,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
buff
[out] A pointer to a buffer containing the screen data. The buffer must be freed with PrlBuffer_Free when no longer needed.
buffSize
The size of the buffer received in the buff parameter (above).
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

Links
Secondary Display Capture


PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile Function

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile Function
Secondary Display Capture

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, pixels

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

Links
Secondary Display Capture


PrlDisk_ChangeKey Function

PrlDisk_ChangeKey Function
PHT_VIRTUAL_DISK

This function used to change the key of the encrypted disk

Syntax
PRL_RESULT PrlDisk_ChangeKey(
    const PRL_HANDLE Handle,
    PRL_UINT8_PTR Key,
    PRL_UINT32 Length,
    PRL_UINT8_PTR NewKey,
    PRL_UINT32 NewLength
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Key
Pointer to the raw key data
Length
Key length
NewKey
Pointer to the raw new key data
NewLength
New key length

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_Coagulate Function

PrlDisk_Coagulate Function
PHT_VIRTUAL_DISK See Also

Combines all available disk snapshots into a single entity.

Syntax
PRL_RESULT PrlDisk_Coagulate(
    const PRL_HANDLE Handle,
    const PRL_STATES_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

On operation completion, the data from all existing disk snapshots will be merged and the snapshot tree will seize to exist.

See Also

PrlDisk_GetSnapshotsTree

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_CommitUnfinishedOp Function

PrlDisk_CommitUnfinishedOp Function
PHT_VIRTUAL_DISK

Commits unfinished state operation (interrupted).

Syntax
PRL_RESULT PrlDisk_CommitUnfinishedOp(
    const PRL_HANDLE Handle,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_Compact Function

PrlDisk_Compact Function
PHT_VIRTUAL_DISK See Also

This method is deprecated now.

Syntax
PRL_RESULT PrlDisk_Compact(
    const PRL_HANDLE Handle,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Compacts a virtual disk. A virtual disk may become fragmented similar to a physical disk. As a result, the size that the disk files occupy on the physical hard drive may be larger than the size of the actual data they contain. The PrlDisk_Compact function defragments the specified virtual disk and decreases the size that the virtual disk files occupy on the physical hard disk. The designated size of the virtual disk itself remains unchanged.

Please note that not all disks can be compacted. To determine if a disk can or cannot be compacted use the PrlDisk_IsCompactable function.

See Also

PrlDisk_IsCompactable

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_CompactByBitmap Function

PrlDisk_CompactByBitmap Function
PHT_VIRTUAL_DISK

Compacts a virtual disk with free blocks map.

Syntax
PRL_RESULT PrlDisk_CompactByBitmap(
    const PRL_HANDLE Handle,
    const PRL_UINT8_PTR pBitmap,
    const PRL_UINT32 uBlockSize,
    const PRL_DISK_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pBitmap
A pointer to a bit array of used blocks.
uBlockSize
Sectors per bit, i.e. block size.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_ConvertToCHS Function

PrlDisk_ConvertToCHS Function
PHT_VIRTUAL_DISK

This function used to convert disk size in blocks to the Cylinders-Heads-Sectors (CHS) format, used at disk creation

Syntax
PRL_RESULT PrlDisk_ConvertToCHS(
    PRL_UINT64 Size,
    PRL_CHS_PTR Chs
);
File

PrlDisk.h

Parameters

Size
Disk size in sectors
CHS
Pointer to PRL_CHS structure to fill to

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_ConvertToCurrent Function

PrlDisk_ConvertToCurrent Function
PHT_VIRTUAL_DISK See Also

Converts virtual disks that were created with an older version of Parallels Service to the current version.

Syntax
PRL_RESULT PrlDisk_ConvertToCurrent(
    PRL_CONST_STR pDiskName
);
File

PrlDisk.h

Parameters

pDiskName
Virtual disk file name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can be used to convert disks residing on local and remote machines. A connection to the Parallels Service is required to do both. As a convenience, the PrlDisk_ConvertToCurrent_Local function is provided to convert virtual disks on local machines.

See Also

PrlDisk_ConvertToCurrent_Local

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_ConvertToCurrent_Local Function

PrlDisk_ConvertToCurrent_Local Function
PHT_VIRTUAL_DISK See Also

Converts virtual disks that were created with an older version of Parallels Service to the current version.

Syntax
PRL_RESULT PrlDisk_ConvertToCurrent_Local(
    PRL_CONST_STR pDiskName
);
File

PrlDisk.h

Parameters

pDiskName
File name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used to convert virtual disks residing on the same machine where the client application is running. You do not have to establish a connection with the Parallels Service prior to calling this function. To convert disks on remote machines, use the PrlDisk_ConvertToCurrent function.

See Also

PrlDisk_ConvertToCurrent

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_ConvertToExtendFormat Function

PrlDisk_ConvertToExtendFormat Function
PHT_VIRTUAL_DISK

Convert all Expanding images to Extend_Expanding

Syntax
PRL_RESULT PrlDisk_ConvertToExtendFormat(
    const PRL_HANDLE Handle,
    const PRL_DISK_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function. the virtual disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_CreateDisk Function

PrlDisk_CreateDisk Function
PHT_VIRTUAL_DISK See Also

Creates a new virtual disk.

Syntax
PRL_RESULT PrlDisk_CreateDisk(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pCallback,
    PRL_CONST_VOID_PTR pAdditional
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the new virtual disk. You must always free the handle using the PrlDisk_Free function when the handle is no longer needed. Failure to do so will result in memory leak.
pDiskName
Virtual disk name in UTF-8 format.
pParams
Virtual disk configuration parameters.
pCallback
A pointer to a callback function or NULL pointer. This parameter allows to call the function asynchronously. If this parameter contains a pointer to a user-implemented callback function, the PrlDisk_CreateDisk function will return immediately and the operation will continue in the background thread. The background thread will be calling the callback function passing the operation progress information to it. See PRL_DISK_CALLBACK for more information. Using a callback might be helpful when the disk creation is expected to take a long time. For example, you may want to use a callback when you are creating a large disk and allocating all space for it right away.

If this parameter contains a NULL pointer, the function will be called synchronously.

pAdditional
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function creates a new virtual disk and obtains a handle of type PHT_VIRTUAL_DISK identifying the new disk. The handle can then be used to perform other operations on the disk if necessary (see the complete list of PHT_VIRTUAL_DISK functions). To use this function, you must be connected to the Parallels Service. If you are creating a new virtual disk locally, you can use the PrlDisk_CreateDisk_Local function which doesn't require the Parallels Service connection.

See Also

PrlDisk_CreateDisk_Local

PrlDisk_Free

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_CreateDisk_Local Function

PrlDisk_CreateDisk_Local Function
PHT_VIRTUAL_DISK See Also

This function can be used to create a new virtual disk locally without being connected to the Parallels Service.

Syntax
PRL_RESULT PrlDisk_CreateDisk_Local(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pCallback,
    PRL_CONST_VOID_PTR pAdditional
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the new virtual disk. You must always free the handle using the PrlDisk_Free function when the handle is no longer needed. Failure to do so will result in memory leak.
pDiskName
Disk name in UTF-8 format.
pParams
Disk configuration parameters.
pCallback
A pointer to a callback function or NULL pointer. This parameter allows to call the function asynchronously. If this parameter contains a pointer to a user-implemented callback function, the PrlDisk_CreateDisk function will return immediately and the operation will continue in the background thread. The background thread will be calling the callback function passing the operation progress information to it. See PRL_DISK_CALLBACK for more information. Using a callback might be helpful when the disk creation is expected to take a long time. For example, you may want to use a callback when you are creating a large disk and allocating all space for it right away.

If this parameter contains a NULL pointer, the function will be called synchronously.

pAdditional
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function creates a new virtual disk and obtains a handle of type PHT_VIRTUAL_DISK identifying the new disk. The handle can then be used to perform other operations on the disk if necessary (see other functions from this group). If you would like to create a new virtual disk on a remote host, use the PrlDisk_CreateDisk function.

See Also

PrlDisk_CreateDisk

PrlDisk_Free

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_CreateState Function

PrlDisk_CreateState Function
PHT_VIRTUAL_DISK See Also

Takes a snapshot of the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_CreateState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name. The parameter is not currently used.
pUid
A universally unique ID (UUID) to assign to the new snapshot. You must generate the UUID yourself.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDisk_SwitchToState

PrlDisk_DeleteState

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_DecreaseCapacity Function

PrlDisk_DecreaseCapacity Function
PHT_VIRTUAL_DISK See Also

Allows to decrease the size of an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_DecreaseCapacity(
    const PRL_HANDLE Handle,
    const PRL_UINT64 uiSize,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
uiSize
New overall disk size in sectors.
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Depending on the new disk size, the size of the last storage segment in the virtual disk storage list will be adjusted or one (or more) storages will be deleted from the end of the list.

See Also

PrlDisk_IncreaseCapacity

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_Decrypt Function

PrlDisk_Decrypt Function
PHT_VIRTUAL_DISK

This function used to encrypt whole disk

Syntax
PRL_RESULT PrlDisk_Decrypt(
    const PRL_HANDLE Handle,
    PRL_UINT8_PTR Key,
    PRL_UINT32 Length,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Key
Pointer to the raw key data
Length
Key length
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_DeleteState Function

PrlDisk_DeleteState Function
PHT_VIRTUAL_DISK See Also

Deletes the specified virtual disk snapshot.

Syntax
PRL_RESULT PrlDisk_DeleteState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_BOOL bMerge,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name. The parameter is not currently used.
pUid
Universally unique ID (UUID) of the snapshot to delete.
bMerge
A flag indicating whether the data contained in the snapshot being deleted should be merged with the descending snapshots. PRL_TRUE merges the snapshot data, PRL_FALSE simply deletes the snapshot. If you don't merge the data, all descending snapshots will be lost.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDisk_CreateState

PrlDisk_SwitchToState

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_Encrypt Function

PrlDisk_Encrypt Function
PHT_VIRTUAL_DISK

This function used to encrypt whole disk

Syntax
PRL_RESULT PrlDisk_Encrypt(
    const PRL_HANDLE Handle,
    PRL_GUID_PTR Engine,
    PRL_UINT8_PTR Key,
    PRL_UINT32 Length,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Engine
Encryption engine used to encrypt VM
Key
Pointer to the raw key data
Length
Key length
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_FixConsistency Function

PrlDisk_FixConsistency Function
PHT_VIRTUAL_DISK

Checks and fixes consistency of a virtual disk.

Syntax
PRL_RESULT PrlDisk_FixConsistency(
    const PRL_HANDLE Handle,
    const PRL_DISK_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_FlushCache Function

PrlDisk_FlushCache Function
PHT_VIRTUAL_DISK

Writes data from a virtual disk cache to the real storage.

Syntax
PRL_RESULT PrlDisk_FlushCache(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_Free Function

PrlDisk_Free Function
PHT_VIRTUAL_DISK

Frees the PHT_VIRTUAL_DISK handle.

Syntax
PRL_RESULT PrlDisk_Free(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

This function must be called to free the PHT_VIRTUAL_DISK handle when it is no loner needed. Failure to do so will result in a memory leak.

Links
PHT_VIRTUAL_DISK


PrlDisk_GetDefaultBlockSize Function

PrlDisk_GetDefaultBlockSize Function
PHT_VIRTUAL_DISK

This function used to get default block size of disk

Syntax
PRL_RESULT PrlDisk_GetDefaultBlockSize(
    PRL_UINT32_PTR Size
);
File

PrlDisk.h

Returns

Default block size in sectors.

Links
PHT_VIRTUAL_DISK


PrlDisk_GetDiskInfo Function

PrlDisk_GetDiskInfo Function
PHT_VIRTUAL_DISK

Obtains the information about the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_GetDiskInfo(
    const PRL_HANDLE Handle,
    PRL_DISK_PARAMETERS_PTR pDiskParameters,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskParameters
[out] A pointer to a buffer that receives the disk information.
BufferSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_GetIdentify Function

PrlDisk_GetIdentify Function
PHT_VIRTUAL_DISK

This function used to get HDD identify information as it shown in guest OS

Syntax
PRL_RESULT PrlDisk_GetIdentify(
    const PRL_HANDLE Handle,
    PRL_CHAR_PTR Model,
    PRL_CHAR_PTR Serial,
    PRL_CHAR_PTR Firmware
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Model
Pointer to array of 41 ASCII elements, that will receive HDD model string
Serial
Pointer to array of 21 ASCII elements, that will receive HDD serial number
Firmware
Pointer to array of 9 ASCII elements, that will receive HDD firmware revision

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_GetSnapshotsCount Function

PrlDisk_GetSnapshotsCount Function
PHT_VIRTUAL_DISK See Also

Determines the number of snapshots of the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_GetSnapshotsCount(
    const PRL_HANDLE Handle,
    PRL_UINT32_PTR SnapshotsCount
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
SnapshotsCount
[out] A pointer to a variable that receives the snapshot count.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual disk snapshot is created when a snapshot of a virtual machine is created or manually using the PrlDisk_CreateState function. Snapshots of a given virtual disk are organized into a tree. You can use the PrlDisk_GetSnapshotsTree function to obtain the entire tree and then, knowing the total snapshot count, traverse the tree. Each snapshot is identified using a universally unique ID (UUID). When you know the UUID of a snapshot of interest, you can revert to it or delete it if needed.

See Also

PrlDisk_GetSnapshotsTree

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_GetSnapshotsTree Function

PrlDisk_GetSnapshotsTree Function
PHT_VIRTUAL_DISK See Also

Obtains the entire snapshot tree for the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_GetSnapshotsTree(
    const PRL_HANDLE Handle,
    PRL_SNAPSHOT_ELEMENT_PTR pSnapshotTree,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pSnapshotTree
[out] A pointer to a buffer that receives the result.
BufferSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual disk snapshot is created when a snapshot of a virtual machine is created or manually using the PrlDisk_CreateState function. Each snapshot is identified using a universally unique ID (UUID). Snapshots of a given virtual disk are organized into a tree. You can use the PrlDisk_GetSnapshotsTree function to obtain the entire tree and then traverse it to obtain the UUID of a snapshot of interest. When you know the snapshot UUID, you can revert to it or delete it if needed.

See Also

PrlDisk_GetSnapshotsCount

PrlDisk_CreateState

PrlDisk_SwitchToState

PrlDisk_DeleteState

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_GetSplitPartSize Function

PrlDisk_GetSplitPartSize Function
PHT_VIRTUAL_DISK

This function used to get splitted disk part size

Syntax
PRL_RESULT PrlDisk_GetSplitPartSize(
    PRL_UINT64_PTR Size
);
File

PrlDisk.h

Returns

Default block size in sectors.

Links
PHT_VIRTUAL_DISK


PrlDisk_GetUserParameter Function

PrlDisk_GetUserParameter Function
PHT_VIRTUAL_DISK See Also

Retrieves user-defined parameter values stored on a virtual disk.

Syntax
PRL_RESULT PrlDisk_GetUserParameter(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pParameterName,
    PRL_CHAR_PTR pParameterValue,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParameterName
Parameter name in UTF-8 format.
pParameterValue
[out] A pointer to a buffer that receives the specified parameter value.
BufferSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A user can store arbitrary data on the disk in the parameter/value form. Both the parameter name and the value are user-defined and don't have any specific requirements. The parameters and values are stored using the PrlDisk_SetUserParameter function. Other users cannot access this data.

See Also

PrlDisk_SetUserParameter

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_IncreaseCapacity Function

PrlDisk_IncreaseCapacity Function
PHT_VIRTUAL_DISK See Also

Allows to increase the size of an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_IncreaseCapacity(
    const PRL_HANDLE Handle,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParams
Virtual disk parameters (see Remarks below).
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Disk size can be increased by adding a new storage segment to its configuration or by increasing the size of an existing storage (only the size of the last storage segment in the storage list can be modified). A virtual disk can be comprised of one or more storage segments, which are logical portions of the entire disk. Each storage is contained in a separate file on the physical hard drive. All storages are logically connected in a particular order.

To increase the overall disk capacity, a new storage can be added at the end. In order to do that, the members of the PRL_DISK_PARAMETERS structure that you pass in the pParam parameter must contain the following values:

  • m_Parts The number of storages to add (if adding one storage, pass 1).
  • m_Storages A pointer to an array of PRL_IMAGE_PARAMETERS structures. If adding a single storage, pass a pointer to a single structure. The uSize member of the structure must contain the new storage size. The Type member can be either PRL_IMAGE_PLAIN or PRL_IMAGE_COMPRESSED depending on your preferences.
See Also

PrlDisk_DecreaseCapacity

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_IsBootable_Local Function

PrlDisk_IsBootable_Local Function
PHT_VIRTUAL_DISK

This function used to check is the disk bootable or not

Syntax
PRL_RESULT PrlDisk_IsBootable_Local(
    PRL_CONST_STR pDiskName,
    PRL_BOOL_PTR pBootable
);
File

PrlDisk.h

Parameters

pDiskName
The disk name for which to obtain the handle, in UTF-8 format. Disk name is the same as the bundle name (Mac) or the directory name (Windows, Linux) containing the virtual disk files.
pBootable
Pointer to the value receiving disk status

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_IsCompactable Function

PrlDisk_IsCompactable Function
PHT_VIRTUAL_DISK See Also

Determines if the specified virtual disk can be compacted.

Syntax
PRL_RESULT PrlDisk_IsCompactable(
    const PRL_HANDLE Handle,
    PRL_BOOL_PTR Result
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
Result
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the disk image can be compacted. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See the PrlDisk_Compact function for more information on disk compacting.

See Also

PrlDisk_Compact

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_IsEncrypted Function

PrlDisk_IsEncrypted Function
PHT_VIRTUAL_DISK

This function used to check is the disk encrypted or not

Syntax
PRL_RESULT PrlDisk_IsEncrypted(
    const PRL_HANDLE Handle,
    PRL_BOOL_PTR Out
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Out
Boolean value, that receive status of disk encryption

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_LinkedClone_Local Function

PrlDisk_LinkedClone_Local Function
PHT_VIRTUAL_DISK

This function used to create a linked clone disk

Syntax
PRL_RESULT PrlDisk_LinkedClone_Local(
    const PRL_HANDLE Handle,
    PRL_CONST_GUID_PTR pGUID,
    PRL_CONST_STR pDiskName
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
pDiskName
The new disk name in UTF-8 format. Disk name is the same as the bundle name (Mac) or the directory name (Windows, Linux) containing the virtual disk files.
GUID
Pointer to the source disk snapshot GUID. If the null GUID specified, the new snapshot will be created and the cloned disk will be linked to created GUID.

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_OpenDisk Function

PrlDisk_OpenDisk Function
PHT_VIRTUAL_DISK See Also

Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_OpenDisk(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    const PRL_DISK_OPEN_FLAGS OpenFlags,
    PRL_CONST_VOID_PTR pAdditionalFlags
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the virtual disk. You must always free the handle using the PrlDisk_Free function when the handle is no longer needed. Failure to do so will result in memory leak.
pDiskName
The disk name for which to obtain the handle, in UTF-8 format. Disk name is the same as the bundle name (Mac) or the directory name (Windows, Linux) containing the virtual disk files.
OpenFlags
Disk open parameters. See PRL_DISK Macros for available options.
pAdditionalFlags
Additional flags (not currently used).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you want to view or modify the configuration of an existing virtual disk. Once you obtain the disk handle, use its functions to perform the desired disk manipulations.

See Also

PrlDisk_OpenDisk_Local

PrlDisk_Free

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_OpenDisk_Local Function

PrlDisk_OpenDisk_Local Function
PHT_VIRTUAL_DISK See Also

Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk on a local machine.

Syntax
PRL_RESULT PrlDisk_OpenDisk_Local(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    const PRL_DISK_OPEN_FLAGS OpenFlags,
    PRL_CONST_VOID_PTR pAdditionalFlags
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the virtual disk. You must always free the handle using the PrlDisk_Free function when the handle is no longer needed. Failure to do so will result in memory leak.
pDiskName
The disk name for which to obtain the handle, in UTF-8 format. Disk name is the same as the bundle name (Mac) or the directory name (Windows, Linux) containing the virtual disk files.
OpenFlags
Disk open parameters. See PRL_DISK Macros for available options.
pAdditionalFlags
Additional flags (not currently used).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you want to view or modify the configuration of an existing virtual disk. Once you obtain the disk handle, use its functions to perform the desired disk manipulations. This function can be used locally without a Parallels Service connection.

See Also

PrlDisk_OpenDisk

PrlDisk_Free

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_Read Function

PrlDisk_Read Function
PHT_VIRTUAL_DISK See Also

Reads data from the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_Read(
    const PRL_HANDLE Handle,
    PRL_VOID_PTR pBlock,
    const PRL_UINT32 uiSize,
    const PRL_UINT64 uiBlockOffset
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pBlock
A pointer to sector/page-aligned data to read (depends on the host operating system).
uiSize
The size of the data to read.
uiBlockOffset
Offset of the block on the disk, in sectors.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDisk_Write

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_SetCachingPolicy Function

PrlDisk_SetCachingPolicy Function
PHT_VIRTUAL_DISK

Set the caching policy for a virtual disk.

Syntax
PRL_RESULT PrlDisk_SetCachingPolicy(
    const PRL_HANDLE Handle,
    const PRL_UINT32 Policy
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
Policy
Caching policy to set. Possible values:

PRL_DISK_CACHE_ENABLED - caching enabled.

PRL_DISK_CACHE_DISABLED - caching disabled.

PRL_DISK_CACHE_UNCACHED_READ - cache write operations only. This option is available on Mac hosts only.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DISK


PrlDisk_SetKey Function

PrlDisk_SetKey Function
PHT_VIRTUAL_DISK

This function used to set the key to the encrypted disk

Syntax
PRL_RESULT PrlDisk_SetKey(
    const PRL_HANDLE Handle,
    PRL_UINT8_PTR Key,
    PRL_UINT32 Length
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the source virtual disk.
Key
Pointer to the raw key data
Length
Key length

Returns

PRL_RESULT error code.

Links
PHT_VIRTUAL_DISK


PrlDisk_SetSharedDirectory Function

PrlDisk_SetSharedDirectory Function
PHT_VIRTUAL_DISK See Also

Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.

Syntax
PRL_RESULT PrlDisk_SetSharedDirectory(
    PRL_CONST_STR pDirectoryName
);
File

PrlDisk.h

Parameters

pDirectoryName
Directory name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function sets the read-write-execute (or 666) permission on all files contained in the directory. This makes the virtual disk files contained in the directory (and consequently the virtual disk itself) accessible to other users.

See Also

PrlDisk_SetSharedDirectory_Local

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_SetSharedDirectory_Local Function

PrlDisk_SetSharedDirectory_Local Function
PHT_VIRTUAL_DISK See Also

Sets necessary access permissions on a directory containing a virtual disk to make the disk accessible to other users.

Syntax
PRL_RESULT PrlDisk_SetSharedDirectory_Local(
    PRL_CONST_STR pDirectoryName
);
File

PrlDisk.h

Parameters

pDirectoryName
Directory name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function sets the read-write-execute (or 666) permission on all files contained in the directory. This makes the virtual disk files contained in the directory (and consequently the virtual disk itself) accessible to other users. This function can be used locally, without establishing a Parallels Service connection.

See Also

PrlDisk_SetSharedDirectory

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_SetUserParameter Function

PrlDisk_SetUserParameter Function
PHT_VIRTUAL_DISK See Also

Stores user-defined parameter values on a virtual disk.

Syntax
PRL_RESULT PrlDisk_SetUserParameter(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pParameterName,
    PRL_CONST_STR pParameterValue
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParameterName
Parameter name in UTF-8 format.
pParameterValue
Parameter value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A user can store arbitrary data on the disk in the parameter/value form. Both the parameter name and the value are user-defined and don't have any specific requirements. The parameters and their values can be retrieved by the user using the PrlDisk_GetUserParameter function. Other users cannot access this data.

See Also

PrlDisk_GetUserParameter

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_SwitchToState Function

PrlDisk_SwitchToState Function
PHT_VIRTUAL_DISK See Also

Reverts a virtual disk to the specified snapshot.

Syntax
PRL_RESULT PrlDisk_SwitchToState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name. This parameter is not currently used.
pUid
The universally unique ID (UUID) assigned to the disk. Use the PrlDisk_GetSnapshotsTree function to obtain the snapshot tree with UUIDs of individual snapshots.
pCallback
A pointer to a callback function or NULL pointer. If the parameter contains a valid pointer to the callback, the function will be called asynchronously. If it contains a NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDisk_CreateState

PrlDisk_DeleteState

PrlDisk_GetSnapshotsTree

Links
PHT_VIRTUAL_DISK, See Also


PrlDisk_WaitForCompletion Function

PrlDisk_WaitForCompletion Function
PHT_VIRTUAL_DISK

Waits for the background thread to finish executing before returning control to the client.

Syntax
PRL_RESULT PrlDisk_WaitForCompletion(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function with any of the PHT_VIRTUAL_DISK disk functions that can be executed asynchronously. When a function is called asynchronously, it returns immediately. The actual task that was initiated by the call is performed in the background thread. By calling the PrlDisk_WaitForCompletion function, you will suspend the main thread execution until the background thread is finished processing the task.

Links
PHT_VIRTUAL_DISK


PrlDisk_Write Function

PrlDisk_Write Function
PHT_VIRTUAL_DISK See Also

Writes data to the specified virtual disk.

Syntax
PRL_RESULT PrlDisk_Write(
    const PRL_HANDLE Handle,
    PRL_CONST_VOID_PTR pBlock,
    const PRL_UINT32 uiSize,
    const PRL_UINT64 uiBlockOffset
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pBlock
A pointer to the sector/page-aligned data to write (depends on the host operating system).
uiSize
Size of the data to write.
uiBlockOffset
Offset of the block on the disk, in sectors.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDisk_Read

Links
PHT_VIRTUAL_DISK, See Also


PrlDispCfg_ArePluginsEnabled Function

PrlDispCfg_ArePluginsEnabled Function
PHT_DISP_CONFIG

Determines whether the plugins enabled or not

Syntax
PRL_RESULT PrlDispCfg_ArePluginsEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbIsPluginsAllowed
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbIsPluginsAllowed
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that the plugins support is allowed PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_CanChangeDefaultSettings Function

PrlDispCfg_CanChangeDefaultSettings Function
PHT_DISP_CONFIG See Also

Determines if new users have the right to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlDispCfg_CanChangeDefaultSettings(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbDefaultChangeSettings
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbDefaultChangeSettings
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that new users are allowed to change the Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host machine can modify Parallels Service preferences. When a new Parallels Service user profile is created (this happens automatically when a user logs in to the Parallels Service for the first time), he/she will be granted or denied this privilege based on the flag set in the Parallels Service configuration. This function determines the status of this flag.

See Also

PrlDispCfg_SetCanChangeDefaultSettings

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_EnablePlugins Function

PrlDispCfg_EnablePlugins Function
PHT_DISP_CONFIG

Enable or disable the plugins support

Syntax
PRL_RESULT PrlDispCfg_EnablePlugins(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnablePluginsSupport
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnablePluginsSupport
[in] A value to set. Use PRL_TRUE to enable, PRL_FALSE to disable plugins support.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetBackupTimeout Function

PrlDispCfg_GetBackupTimeout Function
PHT_DISP_CONFIG

Get backup timeout in seconds.

Syntax
PRL_RESULT PrlDispCfg_GetBackupTimeout(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnBackupTimeout
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnTimeout
[out] A pointer to a buffer that receives the result

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetBackupTmpDir Function

PrlDispCfg_GetBackupTmpDir Function
PHT_DISP_CONFIG

Returns the backup temporary directory.

Syntax
PRL_RESULT PrlDispCfg_GetBackupTmpDir(
    PRL_HANDLE hDispConfig,
    PRL_STR sBackupTmpDir,
    PRL_UINT32_PTR pnBackupTmpDirBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupTmpDir
[out] Pointer to a buffer that receives the backup temporary directory (a UTF-8 encoded, null-terminated string).
pnBackupTmpDirBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetBackupUserLogin Function

PrlDispCfg_GetBackupUserLogin Function
PHT_DISP_CONFIG

Returns the backup user login.

Syntax
PRL_RESULT PrlDispCfg_GetBackupUserLogin(
    PRL_HANDLE hDispConfig,
    PRL_STR sUserLogin,
    PRL_UINT32_PTR pnUserLoginBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sUserLogin
[out] Pointer to a buffer that receives the backup user login (a UTF-8 encoded, null-terminated string).
pnUserLoginBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetConfirmationsList Function

PrlDispCfg_GetConfirmationsList Function
PHT_DISP_CONFIG See Also

Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )

Syntax
PRL_RESULT PrlDispCfg_GetConfirmationsList(
    PRL_HANDLE hDispConfig,
    PRL_HANDLE_PTR phConfirmList
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
phConfirmList
[out] A pointer to a variable that receives the handle. The type of the handle is PHT_OPAQUE_TYPE_LIST ( values in list consist in enum PRL_ALLOWED_VM_COMMAND )

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetCpuFeaturesMaskEx Function

PrlDispCfg_GetCpuFeaturesMaskEx Function
PHT_DISP_CONFIG See Also

Allows to get the CPU features masks from dispatcher config.

Syntax
PRL_RESULT PrlDispCfg_GetCpuFeaturesMaskEx(
    PRL_HANDLE hDispConfig,
    PRL_HANDLE_PTR phCpuFeatures
);
File

PrlApiDisp.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate new object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

hDispConfig : A handle of type PHT_DISP_CONFIG. phCpuFeatures : A pointer to a variable that receives a handle of type PHT_CPU_FEATURES.

See Also

PrlDispCfg_SetCpuFeaturesMaskEx

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetDefaultBackupDirectory Function

PrlDispCfg_GetDefaultBackupDirectory Function
PHT_DISP_CONFIG

Returns PATH to the default backup directory.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultBackupDirectory(
    PRL_HANDLE hDispConfig,
    PRL_STR sBackupDirectory,
    PRL_UINT32_PTR pnBackupDirectoryBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupDirectory
[out] Pointer to a buffer that receives PATH to the backup directory (a UTF-8 encoded, null-terminated string).
pnBackupDirectoryBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetDefaultBackupServer Function

PrlDispCfg_GetDefaultBackupServer Function
PHT_DISP_CONFIG

Returns the default backup server host name or IP address.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultBackupServer(
    PRL_HANDLE hDispConfig,
    PRL_STR sBackupServer,
    PRL_UINT32_PTR pnBackupServerBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupServer
[out] Pointer to a buffer that receives the backup server host name or IP address (a UTF-8 encoded, null-terminated string).
pnBackupServerBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetDefaultCtDir Function

PrlDispCfg_GetDefaultCtDir Function
PHT_DISP_CONFIG

Obtains path of the directory in which new Container are created by default.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultCtDir(
    PRL_HANDLE hDispConfig,
    PRL_STR sDefaultDir,
    PRL_UINT32_PTR pnDefaultDirBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sDefaultDir
[out] A pointer to a buffer that receives the directory name (a UTF-8 encoded, null-terminated string).
pnDefaultDirBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetDefaultEncryptionPluginId Function

PrlDispCfg_GetDefaultEncryptionPluginId Function
PHT_DISP_CONFIG

Returns default encryption plugin Id.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultEncryptionPluginId(
    PRL_HANDLE hDispConfig,
    PRL_STR sDefaultPluginId,
    PRL_UINT32_PTR pnDefaultPluginIdBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sDefaultPluginId
[out] Pointer to a buffer that receives default encryption plugin Id (a UTF-8 encoded, null-terminated string). It is empty string for default Parallels encryption plugin

pnDefaultPluginIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetDefaultVmDir Function

PrlDispCfg_GetDefaultVmDir Function
PHT_DISP_CONFIG

Obtains name and path of the directory in which new virtual machines are created by default.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultVmDir(
    PRL_HANDLE hDispConfig,
    PRL_STR sDefaultVmDir,
    PRL_UINT32_PTR pnDefaultVmDirBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sDefaultVmDir
[out] A pointer to a buffer that receives the directory name (a UTF-8 encoded, null-terminated string).
pnDefaultVmDirBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The virtual machine directory returned by this function is the default directory for all users and cannot be modified. Individual users can have their own default virtual machine directories if needed. To set a default directory for a user, use the PrlUsrCfg_SetDefaultVmFolder function. If a user has its own virtual machine directory set up, it takes precedence over the directory returned by this function.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetDefaultVNCHostName Function

PrlDispCfg_GetDefaultVNCHostName Function
PHT_DISP_CONFIG

Returns the default VNC host name for the Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultVNCHostName(
    PRL_HANDLE hDispConfig,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sHostName
[out] Pointer to a buffer that receives the VNC host name (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetMaxReservMemLimit Function

PrlDispCfg_GetMaxReservMemLimit Function
PHT_DISP_CONFIG See Also

Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetMaxReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits and the actual size of the reserved memory are calculated automatically based on the total RAM available on the host machine. If needed, you can modify the default values. When setting the size of the memory reserved for Parallels Service, use this function to find out the maximum allowable size.

See Also

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMaxVmMem Function

PrlDispCfg_GetMaxVmMem Function
PHT_DISP_CONFIG See Also

Determines the maximum memory size that can be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The actual amount of memory for a particular virtual machine is set in the virtual machine configuration and cannot exceed the value returned by this function.

See Also

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinReservMemLimit Function

PrlDispCfg_GetMinReservMemLimit Function
PHT_DISP_CONFIG See Also

Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetMinReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits and the actual size of the reserved memory are calculated automatically based on the total RAM available on the host machine. If needed, you can modify the default values. When setting the size of the memory reserved on the host machine for Parallels Service, use this function to find out the minimum required size.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinSecurityLevel Function

PrlDispCfg_GetMinSecurityLevel Function
PHT_DISP_CONFIG See Also

Determines the lowest allowable security level that can be used to connect to the Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_GetMinSecurityLevel(
    PRL_HANDLE hDispConfig,
    PRL_SECURITY_LEVEL_PTR pnMinSecurityLevel
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMinSecurityLevel
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Service has a configuration parameter that specifies the connection security level that must be used by clients to communicate with it. If a client tries to login using a lower level than the one returned by this function, the connection to the Parallels Service will be refused. Higher security levels are allowed. If the minimum security level is not known in advance, use this function to determine it before establishing a connection with the Service.

See Also

PrlDispCfg_SetMinSecurityLevel

PrlSrv_Login

PrlSrv_LoginLocal

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinVmMem Function

PrlDispCfg_GetMinVmMem Function
PHT_DISP_CONFIG See Also

Determines the minimum required memory size that must be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetMinVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The value returned by this function indicates the minimum amount of memory that is absolutely required for a virtual machine to run. The actual amount of memory for a particular virtual machine is set in the virtual machine configuration and cannot be less than the value returned by this function.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMobileAdvancedAuthMode Function

PrlDispCfg_GetMobileAdvancedAuthMode Function
PHT_DISP_CONFIG See Also

Get the advanced authorization mode for Parallels Access clients.

Syntax
PRL_RESULT PrlDispCfg_GetMobileAdvancedAuthMode(
    PRL_HANDLE hDispConfig,
    PRL_MOBILE_ADVANCED_AUTH_MODE_PTR pnMode
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMode
[out] A pointer to a variable that recives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispCfg_SetMobileAdvancedAuthMode

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetProxyConnectionStatus Function

PrlDispCfg_GetProxyConnectionStatus Function
PHT_DISP_CONFIG

Determines proxy connection status or error code of last proxy operation.

Syntax
PRL_RESULT PrlDispCfg_GetProxyConnectionStatus(
    PRL_HANDLE hDispConfig,
    PRL_PROXY_CONNECTION_STATUS_PTR pProxyConnectionStatus,
    PRL_RESULT_PTR pErrorCode
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pProxyConnectionStatus
[out] A pointer to a variable that receives the result of status.
pErrorCode
[out] A pointer to a variable that receives the result of last proxy operation error code.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer for both pProxyConnectionStatus and pErrorCode were passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetProxyConnectionUser Function

PrlDispCfg_GetProxyConnectionUser Function
PHT_DISP_CONFIG

Returns the name of user associated with current proxy connection.

Syntax
PRL_RESULT PrlDispCfg_GetProxyConnectionUser(
    PRL_HANDLE hDispConfig,
    PRL_STR sUserId,
    PRL_UINT32_PTR pnUserIdLength
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sUserId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUserIdLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_GetRecommendMaxVmMem Function

PrlDispCfg_GetRecommendMaxVmMem Function
PHT_DISP_CONFIG See Also

Determines the recommended memory size for an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetRecommendMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Setting the virtual machine memory size to the value returned by this function is the safest way to do it but is not mandatory. You can use your own value but you have to make sure that it falls within the limits returned by the PrlDispCfg_GetMaxVmMem and PrlDispCfg_GetMinVmMem functions.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetReservedMemLimit Function

PrlDispCfg_GetReservedMemLimit Function
PHT_DISP_CONFIG See Also

Determines the amount of physical memory reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetReservedMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, this memory size is calculated automatically based on the RAM size available on the host machine. If needed, the default value can be modified manually using the PrlDispCfg_SetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_GetUsbIdentity Function

PrlDispCfg_GetUsbIdentity Function
PHT_DISP_CONFIG

Returns handle of type PHT_USB_IDENTITY storing information of USB device with specified index.

Syntax
PRL_RESULT PrlDispCfg_GetUsbIdentity(
    PRL_HANDLE hDispCfg,
    PRL_UINT32 nUsbIdentIndex,
    PRL_HANDLE_PTR phUsbIdent
);
File

PrlApiDisp.h

Parameters

hDispCfg
A handle of type PHT_DISP_CONFIG.
nUsbIdentIndex
A numeric index identifying object with information about USB device. To determine total number of such objects use PrlDispCfg_GetUsbIdentityCount
phUsbIdent
[out] a pointer to a buffer receiving PHT_USB_IDENTITY handle

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle, wrong index or null pointer was passed

PRL_ERR_OUT_OF_MEMORY - insufficient memory to complete operation

PRL_ERR_SUCCESS - function completed successively

Links
PHT_DISP_CONFIG


PrlDispCfg_GetUsbIdentityCount Function

PrlDispCfg_GetUsbIdentityCount Function
PHT_DISP_CONFIG

Determines number of USB devices known to the Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_GetUsbIdentityCount(
    PRL_HANDLE hDispCfg,
    PRL_UINT32_PTR pnUsbIdentityCount
);
File

PrlApiDisp.h

Parameters

hDispCfg
A handle of type PHT_DISP_CONFIG.
pnUsbIdentityCount
[out] A pointer to a variable that receives result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - either hDispCfg is not a valid PHT_DISP_CONFIG

PRL_SUCCESS - function completed successfully

Links
PHT_DISP_CONFIG


PrlDispCfg_GetVNCBasePort Function

PrlDispCfg_GetVNCBasePort Function
PHT_DISP_CONFIG

Obtains the currently set base VNC port number.

Syntax
PRL_RESULT PrlDispCfg_GetVNCBasePort(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnPort
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnPort
[out] A pointer to a variable that receives the port number.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsAdjustMemAuto Function

PrlDispCfg_IsAdjustMemAuto Function
PHT_DISP_CONFIG See Also

Determines whether memory allocation for Parallels Service is performed automatically or manually.

Syntax
PRL_RESULT PrlDispCfg_IsAdjustMemAuto(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbAdjustMemAuto
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbAdjustMemAuto
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the memory is set automatically. PRL_FALSE indicates that the size is set manually.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the amount of memory allocated for Parallels Service is calculated automatically based on the total RAM available on the host. You can allocate a different amount of memory if needed using the PrlDispCfg_SetReservedMemLimit function. Before you do that, you must switch memory allocation to manual mode using the PrlDispCfg_SetAdjustMemAuto function. The amount of currently allocated memory can be retrieved using the PrlDispCfg_GetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_IsAllowAttachScreenshotsEnabled Function

PrlDispCfg_IsAllowAttachScreenshotsEnabled Function
PHT_DISP_CONFIG

Determines whether the allow attach screenshots is enabled for problem report.

Syntax
PRL_RESULT PrlDispCfg_IsAllowAttachScreenshotsEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the allow attach screenshots is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsAllowDirectMobile Function

PrlDispCfg_IsAllowDirectMobile Function
PHT_DISP_CONFIG

Determines whether the Allow Direct Mobile Connections option is enabled.

Syntax
PRL_RESULT PrlDispCfg_IsAllowDirectMobile(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsAllowMobileClients Function

PrlDispCfg_IsAllowMobileClients Function
PHT_DISP_CONFIG

Determines whether the Allow Mobile Clients option is enabled.

Syntax
PRL_RESULT PrlDispCfg_IsAllowMobileClients(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsAllowMultiplePMC Function

PrlDispCfg_IsAllowMultiplePMC Function
PHT_DISP_CONFIG

Determines whether the Allow Multiple PMC option is enabled.

Syntax
PRL_RESULT PrlDispCfg_IsAllowMultiplePMC(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsBackupUserPasswordEnabled Function

PrlDispCfg_IsBackupUserPasswordEnabled Function
PHT_DISP_CONFIG

Returns the backup user password enabling sign.

Syntax
PRL_RESULT PrlDispCfg_IsBackupUserPasswordEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbUserPasswordEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbUserPasswordEnabled
[out] Pointer to a buffer that receives the backup user password enabling sign

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsLogRotationEnabled Function

PrlDispCfg_IsLogRotationEnabled Function
PHT_DISP_CONFIG

Determines whether the log rotation is enabled for dispatcher and virtual machine logs.

Syntax
PRL_RESULT PrlDispCfg_IsLogRotationEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the log rotation is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

Links
PHT_DISP_CONFIG


PrlDispCfg_IsProxyEnabled Function

PrlDispCfg_IsProxyEnabled Function
PHT_DISP_CONFIG See Also

Determines whether dispatcher should connect to the mobile proxy server by default.

Syntax
PRL_RESULT PrlDispCfg_IsProxyEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbProxyEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
[in] A handle of type PHT_DISP_CONFIG.
pbProxyEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the dispatcher should connect to the mobile proxy server by default.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This is read only value, and changes inside depending on user credentials (see PrlDispCfg_SetProxyConnectionCreds ).

See Also

PrlDispCfg_SetProxyConnectionCreds

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_IsSendStatisticReport Function

PrlDispCfg_IsSendStatisticReport Function
PHT_DISP_CONFIG See Also

Determines whether send statistics reports (CEP) mechanism activated.

Syntax
PRL_RESULT PrlDispCfg_IsSendStatisticReport(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbSendStatisticReport
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbSendStatisticReport
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the mechanism is activated. PRL_FALSE indicates that mechanism is switched off (reports do not sending).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this mechanism activated periodically report about Parallels product configuration genrating and sending to the Parallels problem reports server automatically.

See Also

PrlDispCfg_SetSendStatisticReport

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_IsVerboseLogEnabled Function

PrlDispCfg_IsVerboseLogEnabled Function
PHT_DISP_CONFIG

Determines whether the verbose log level is configured for dispatcher and virtual machines processes.

Syntax
PRL_RESULT PrlDispCfg_IsVerboseLogEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the verbose log level is configured. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetAdjustMemAuto Function

PrlDispCfg_SetAdjustMemAuto Function
PHT_DISP_CONFIG See Also

Allows to choose the Parallels Service memory allocation mode from automatic or manual.

Syntax
PRL_RESULT PrlDispCfg_SetAdjustMemAuto(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bAdjustMemAuto
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bAdjustMemAuto
To set the size automatically, set this parameter to PRL_TRUE. To set the size manually, set this parameter to PRL_FALSE and then use the PrlDispCfg_SetReservedMemLimit function to set the size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the amount of memory allocated for Parallels Service operations is calculated automatically based on the total RAM available on the host. You can allocate a different amount of memory if needed using the PrlDispCfg_SetReservedMemLimit function. Before you do that, you must switch memory allocation to manual using this function. The current memory allocation method can be determined using the PrlDispCfg_IsAdjustMemAuto function. The amount of currently allocated memory can be retrieved using the PrlDispCfg_GetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetAllowAttachScreenshotsEnabled Function

PrlDispCfg_SetAllowAttachScreenshotsEnabled Function
PHT_DISP_CONFIG

Enables or disables the allow attach screenshots for problem report.

Syntax
PRL_RESULT PrlDispCfg_SetAllowAttachScreenshotsEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnabled
[in] Action type. Specify PRL_TRUE to enable the log rotation. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetAllowDirectMobile Function

PrlDispCfg_SetAllowDirectMobile Function
PHT_DISP_CONFIG

Enables or disables the Allow Direct Mobile option.

Syntax
PRL_RESULT PrlDispCfg_SetAllowDirectMobile(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnabled
[in] Action type. Specify PRL_TRUE to enable the Allow Direct Mobile option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetAllowMultiplePMC Function

PrlDispCfg_SetAllowMultiplePMC Function
PHT_DISP_CONFIG

Enables or disables the Allow Multiple PMC option.

Syntax
PRL_RESULT PrlDispCfg_SetAllowMultiplePMC(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnabled
[in] Action type. Specify PRL_TRUE to enable the Allow Multiple PMC option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetBackupTimeout Function

PrlDispCfg_SetBackupTimeout Function
PHT_DISP_CONFIG

Set backup timeout in seconds.

Syntax
PRL_RESULT PrlDispCfg_SetBackupTimeout(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nTimeout
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nTimeout
[in] timeout in seconds

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetBackupTmpDir Function

PrlDispCfg_SetBackupTmpDir Function
PHT_DISP_CONFIG

Sets the backup temporary directory.

Syntax
PRL_RESULT PrlDispCfg_SetBackupTmpDir(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sBackupTmpDir
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupTmpDir
[in] The backup temporary directory (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetBackupUserLogin Function

PrlDispCfg_SetBackupUserLogin Function
PHT_DISP_CONFIG

Sets the backup user login.

Syntax
PRL_RESULT PrlDispCfg_SetBackupUserLogin(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sUserLogin
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sUserLogin
[in] The backup user login (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetBackupUserPassword Function

PrlDispCfg_SetBackupUserPassword Function
PHT_DISP_CONFIG

Sets the backup user password.

Syntax
PRL_RESULT PrlDispCfg_SetBackupUserPassword(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sUserPassword
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sUserPassword
[in] The backup user password (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetBackupUserPasswordEnabled Function

PrlDispCfg_SetBackupUserPasswordEnabled Function
PHT_DISP_CONFIG

Sets the backup user password.

Syntax
PRL_RESULT PrlDispCfg_SetBackupUserPasswordEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bUserPasswordEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bUserPasswordEnabled
[in] The backup user password enabling sign

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetCanChangeDefaultSettings Function

PrlDispCfg_SetCanChangeDefaultSettings Function
PHT_DISP_CONFIG See Also

Allows to grant or deny a permission to new users to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlDispCfg_SetCanChangeDefaultSettings(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bDefaultChangeSettings
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bDefaultChangeSettings
If set to PRL_TRUE, new users will be allowed to modify Parallels Service preferences. If set to PRL_FALSE, new users will not be allowed to make such modifications.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host OS can modify Parallels Service preferences. When a new Parallels Service user profile is created (this happens when a user logs on to the Parallels Service for the first time), he/she will be granted or denied this privilege based on the default setting. This function allows to set that default setting. To determine the current behavior, use PrlDispCfg_CanChangeDefaultSettings. Please note that this function only affects the new users (the users that will be created in the future). The profiles of the existing users will not (and cannot) be modified.

See Also

PrlDispCfg_CanChangeDefaultSettings

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetConfirmationsList Function

PrlDispCfg_SetConfirmationsList Function
PHT_DISP_CONFIG See Also

Obtains a handles list of operations which required administrator confirmation ( for all users and for all virtual machines( if operation is applicable to vm) )

Syntax
PRL_RESULT PrlDispCfg_SetConfirmationsList(
    PRL_HANDLE hDispConfig,
    PRL_HANDLE hConfirmList
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
hConfirmList
variable that receives the handle. The type of the handle is PHT_OPAQUE_TYPE_LIST. ( values in list consist in enum PRL_ALLOWED_VM_COMMAND )

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetCpuFeaturesMaskEx Function

PrlDispCfg_SetCpuFeaturesMaskEx Function
PHT_DISP_CONFIG See Also

Allows to set the CPU features masks.

Syntax
PRL_RESULT PrlDispCfg_SetCpuFeaturesMaskEx(
    PRL_HANDLE hDispConfig,
    PRL_HANDLE hCpuFeatures
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
hCpuFeatures
A handle of type PHT_CPU_FEATURES.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This masks will be saved at dispatcher config and will be used on VM start.

See Also

PrlDispCfg_GetCpuFeaturesMaskEx

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetDefaultBackupDirectory Function

PrlDispCfg_SetDefaultBackupDirectory Function
PHT_DISP_CONFIG

Sets PATH to the default backup directory.

Syntax
PRL_RESULT PrlDispCfg_SetDefaultBackupDirectory(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sBackupDirectory
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupDirectory
[in] PATH to the backup directory (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetDefaultBackupServer Function

PrlDispCfg_SetDefaultBackupServer Function
PHT_DISP_CONFIG

Sets the default backup server host name or IP address.

Syntax
PRL_RESULT PrlDispCfg_SetDefaultBackupServer(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sBackupServer
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sBackupServer
[in] The backup server host name or IP address (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetDefaultEncryptionPluginId Function

PrlDispCfg_SetDefaultEncryptionPluginId Function
PHT_DISP_CONFIG

Sets default encryption plugin Id.

Syntax
PRL_RESULT PrlDispCfg_SetDefaultEncryptionPluginId(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sDefaultPluginId
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sDefaultPluginId
[in] default encryption plugin Id (a UTF-8 encoded, null-terminated string). Can be null or empty in case when an empty value should be assigned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetDefaultVNCHostName Function

PrlDispCfg_SetDefaultVNCHostName Function
PHT_DISP_CONFIG

Sets the base VNC host name.

Syntax
PRL_RESULT PrlDispCfg_SetDefaultVNCHostName(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sNewHostName
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sNewHostName
The new VNC host name. The value must be UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetLogRotationEnabled Function

PrlDispCfg_SetLogRotationEnabled Function
PHT_DISP_CONFIG

Enables or disables the log rotation for dispatcher and virtual machine logs.

Syntax
PRL_RESULT PrlDispCfg_SetLogRotationEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnabled
[in] Action type. Specify PRL_TRUE to enable the log rotation. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetMaxReservMemLimit Function

PrlDispCfg_SetMaxReservMemLimit Function
PHT_DISP_CONFIG See Also

Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetMaxReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new maximum memory limit (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits are calculated automatically based on the host machine RAM size. If needed, you can use this function to modify the default value of the maximum reserved memory size. Please note that modifying default memory limits must be done with extreme caution. Unjustified memory limits may result in too much or too little memory reserved for Parallels Service, which in turn may lead to an unstable or inefficient system. While this and other functions allow you to experiment with Parallels Service memory limits, the default values are the ones that should be used in most situations.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMaxVmMem Function

PrlDispCfg_SetMaxVmMem Function
PHT_DISP_CONFIG See Also

Allows to set the maximum memory size that can be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, virtual machine memory limits are calculated automatically. If needed, you can set your own maximum memory limit using this function. Please note that the new value must not exceed the size of the memory reserved for Parallels Service, which can be obtained using the PrlDispCfg_GetReservedMemLimit function. The actual memory size for a virtual machine is set when configuring it and will be validated against the value set here.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinReservMemLimit Function

PrlDispCfg_SetMinReservMemLimit Function
PHT_DISP_CONFIG See Also

Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetMinReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new minimum size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits are calculated automatically based on the host machine RAM size and other parameters. If needed, you can use this function to modify the default value of the minimum required reserved memory size. Please note that modifying default memory limits must be done with extreme caution. Unjustified memory limits may result in too much or too little memory reserved for Parallels Service, which in turn may lead to an unstable or inefficient system. While this and other functions allow you to experiment with Parallels Service memory limits, the default values are should be used in most situations.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinSecurityLevel Function

PrlDispCfg_SetMinSecurityLevel Function
PHT_DISP_CONFIG See Also

Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_SetMinSecurityLevel(
    PRL_HANDLE hDispConfig,
    PRL_SECURITY_LEVEL nMinSecurityLevel
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMinSecurityLevel
Security level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The lowest allowable security level is a setting in the Parallels Service preferences. If a client tries to login using a lower level that the one set by this function, the connection to the Parallels Service will be refused.

See Also

PrlDispCfg_GetMinSecurityLevel

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinVmMem Function

PrlDispCfg_SetMinVmMem Function
PHT_DISP_CONFIG See Also

Allows to set the minimum required memory size that must be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetMinVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new minimum size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, virtual machine memory limits are calculated automatically. If needed, you can set your own minimum memory limit using this function. Please note that the new value must not fall below the size of the minimum memory limit set for Parallels Service, which can be obtained using the PrlDispCfg_GetMinReservMemLimit function. The actual memory size for a virtual machine is set when configuring it and will be validated against the value set here.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMobileAdvancedAuthMode Function

PrlDispCfg_SetMobileAdvancedAuthMode Function
PHT_DISP_CONFIG See Also

Set the advanced authorization mode for Parallels Access clients.

Syntax
PRL_RESULT PrlDispCfg_SetMobileAdvancedAuthMode(
    PRL_HANDLE hDispConfig,
    PRL_MOBILE_ADVANCED_AUTH_MODE nMode
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMode
[in] New advanced authorization mode.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Changing the advanced authorization mode does not affect clients that are already connected.

See Also

PrlDispCfg_GetMobileAdvancedAuthMode

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetProxyConnectionCreds Function

PrlDispCfg_SetProxyConnectionCreds Function
PHT_DISP_CONFIG

Specifies credentials for establishing a proxy connection.

Syntax
PRL_RESULT PrlDispCfg_SetProxyConnectionCreds(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sAccountId,
    PRL_CONST_STR sPassword,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sAccountId
[in] user login (expected null terminated string in UTF-8 encoding).
sPassword
[in] user password (expected null terminated string in UTF-8 encoding).
nFlags
[in] flags mask for advanced proxy connection configuration. Possible values:
PSPCF_DO_NOT_CLEAN_CREDS
close proxy connection but keep user credentials in the dispatcher security storage for later usage.
PSPCF_REUSE_AVAILABLE_CREDS
restore proxy connection using the credentials in the security storage that were previously saved with the PSPCF_DO_NOT_CLEAN_CREDS flag.
PSPCF_CLEANUP_CREDS
delete user credentials from the dispatcher security storage that were previously saved with the PSPCF_DO_NOT_CLEAN_CREDS flag.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

Remarks

To disconnect from the proxy, specify the account or the password as NULL or an empty string. Please note that it is not possible to disconnect from the proxy and reconnect to it with new credentials in a single configuration edit transaction.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetRecommendMaxVmMem Function

PrlDispCfg_SetRecommendMaxVmMem Function
PHT_DISP_CONFIG See Also

Allows to manually set recommended memory size for an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetRecommendMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new recommended memory size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the recommended memory size for a virtual machine is calculated automatically. If needed, you can set your own recommended memory size using this function. The value must be selected from the memory limit range that can be determined using the PrlDispCfg_GetMinVmMem and PrlDispCfg_GetMaxVmMem functions. The value by itself is not used as a constraint of any kind and is just a suggestion that the end user may act on or not.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetReservedMemLimit Function

PrlDispCfg_SetReservedMemLimit Function
PHT_DISP_CONFIG See Also

Allows to set the amount of memory that will be allocated for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetReservedMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new memory size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The memory size must fall within the memory limits that can be determined using the PrlDispCfg_GetMaxReservMemLimit and the PrlDispCfg_GetMinReservMemLimit functions. By default, the memory size is calculated automatically based on the total RAM available on the host. If you are changing the default value, you must also switch the Parallels Service memory allocation to manual mode using the PrlDispCfg_SetAdjustMemAuto function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetSendStatisticReport Function

PrlDispCfg_SetSendStatisticReport Function
PHT_DISP_CONFIG See Also

Allows to switch on/off mechanism of sending statistics reports (CEP).

Syntax
PRL_RESULT PrlDispCfg_SetSendStatisticReport(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bSendStatisticReport
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bSendStatisticReport
To switch mechanism on, set this parameter to PRL_TRUE. To switch off mechanism set this parameter to PRL_FALSE.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispCfg_IsSendStatisticReport

Links
PHT_DISP_CONFIG, See Also


PrlDispCfg_SetUsbIdentAssociation Function

PrlDispCfg_SetUsbIdentAssociation Function
PHT_DISP_CONFIG

(Un)Associates USB device with given Vm.

Syntax
PRL_RESULT PrlDispCfg_SetUsbIdentAssociation(
    PRL_HANDLE hDispCfg,
    PRL_CONST_STR sSystemName,
    PRL_CONST_STR sVmUuid,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hDispCfg
A handle of type PHT_DISP_CONFIG.
sSystemName
System name / id of USB device
sVmUuid
Uuid of Vm to associate USB device with. It could be NULL or empty to clear association.
nFlags
Reserved parameter.

Returns

PRL_RESULT. Posible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid system name was passed.

PRL_ERR_OUT_OF_MEMORY - insufficient memory to complete operation

PRL_ERR_SUCCESS - function completed successfully

Links
PHT_DISP_CONFIG


PrlDispCfg_SetVerboseLogEnabled Function

PrlDispCfg_SetVerboseLogEnabled Function
PHT_DISP_CONFIG

Enables or disables the verbose log level for dispatcher and virtual machines processes.

Syntax
PRL_RESULT PrlDispCfg_SetVerboseLogEnabled(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bEnabled
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bEnabled
[in] Action type. Specify PRL_TRUE to enable the verbose debug log level. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlDispCfg_SetVNCBasePort Function

PrlDispCfg_SetVNCBasePort Function
PHT_DISP_CONFIG

Sets the base VNC port number.

Syntax
PRL_RESULT PrlDispCfg_SetVNCBasePort(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nPort
);
File

PrlApiDisp.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nPort
Port number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_DISP_CONFIG


PrlEvent_CanBeIgnored Function

PrlEvent_CanBeIgnored Function
PHT_EVENT

Determines whether the event is critical or not.

Syntax
PRL_RESULT PrlEvent_CanBeIgnored(
    PRL_HANDLE hEvent,
    PRL_BOOL_PTR pbCanBeIgnored
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pbCanBeIgnored
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the event message is critical and should be investigated. PRL_FALSE indicates that the event message is not critical and can be ignored.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_CreateAnswerEvent Function

PrlEvent_CreateAnswerEvent Function
PHT_EVENT Example

Generates properly formatted and structured answer to a question included in the event.

Syntax
PRL_RESULT PrlEvent_CreateAnswerEvent(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR phEvent,
    PRL_RESULT nAnswer
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
phEvent
[out] A pointer to a variable that receives the result (a handle of type PHT_EVENT containing the answer data).
nAnswer
The code of the answer. The answer object data is assembled based on this value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate event object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

One of the event types that a callback function can receive is PET_DSP_EVT_VM_QUESTION. The event of this type is generated on the Parallels Service side when a user interaction is required. For example, let's say you've sent a request to the Parallels Service to create a virtual machine but specified the size of the virtual hard drive that exceeds the free space available on the physical hard drive. In such a case, the Parallels Service will generate an event containing a question (and possible answers) about how the user would like to proceed. In this particular case, the question will be similar to "The size of the specified disk is larger than the free space available. Would you like to create the disk anyway?" and the possible answers will be "Yes" or "No". The user must choose one of the available options, compose an answer, and send it to the Parallels Service. Based on the answer received, the Parallels Service will take the appropriate action.

To obtain a string containing the question, use the PrlEvent_GetErrString function. Answer choices are acquired by obtaining a handle of type PHT_EVENT_PARAMETER using the PrlEvent_GetParam function (a single object will contain an individual answer choice). After the user selects an answer, the PrlEvent_CreateAnswerEvent function must be called to populate another object of type PHT_EVENT with the properly formatted answer data. The resulting object must then be passed to the PrlSrv_SendAnswer function which will send the answer to the Parallels Service.

Example

The following is a complete example that demonstrates how to handle events and how to answer to Parallels Service questions. In the example, we create a blank virtual machine and try to add a virtual hard drive to it with the size larger than the free disk space available on the physical drive. This will trigger an event on the Parallels Service side and a question will be sent to the client asking if we really want to create a drive like that. The virtual machine creation operation will not continue unless we send an answer to the Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>
#include <stdlib.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

#define MY_JOB_TIMEOUT 10000 // Default timeout to use in the PrlJob_Wait function.
#define MY_HDD_SIZE 70*1024 // The size of the new hard drive.
#define MY_STR_BUF_SIZE 1024 // The default buffer size to use for string output.

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event on the
// Parallels Service, which will result in Service sending us a question.
static PRL_RESULT create_big_hdd(PRL_HANDLE hVm);

// The callback function (event handler).
static PRL_RESULT callback(PRL_HANDLE, PRL_VOID_PTR);

////////////////////////////////////////////////////////////////////////////////

int main(int argc, char* argv[])
{
    // Pick the correct dynamic library file depending on the platform.
    #ifdef _WIN_
        #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
        #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
        #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the dynamic library.
    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        // Error handling goes here...
        return -1;
    }

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;
    PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
    PRL_HANDLE hServer = PRL_INVALID_HANDLE;

    // Initialize API library.
    err = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(err))
    {
        // Error handling goes here...
        return -1;
    }

    // Create server object.
    PrlSrv_Create(&hServer);

    // Log in.
    hJob = PrlSrv_Login(
        hServer, // Server handle
        "10.30.22.82", // Host IP address
        "jdoe", // User
        "secret", // Password
        0, // Previous session ID
        0, // Port number
        0, // Timeout
        PSL_NORMAL_SECURITY); // Security

    ret = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if (PRL_FAILED( nJobResult))
    {
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Create a new virtual machine.
    PRL_HANDLE hVm;
    PrlSrv_CreateVm(hServer, &hVm);
    PrlVm_SetName(hVm, "My simple VM");

    // Register the virtual machine with the Parallels Service.
    hJob = PrlVm_Reg(hVm, "", PRL_FALSE);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    // Register the event handler with the Service.
    // The second parameter is a pointer to our callback function.
    PrlSrv_RegEventHandler(hServer, &callback, NULL);

    // Try creating a virtual hard drive larger than the
    // free space available (increase MY_HDD_SIZE value if needed).
    // This should produce an event that will
    // contain a question from the Parallels Service.
    create_big_hdd(hVm);

    //
    // At this point, the background thread should call the
    // callback function.
    //

    // We can now clean up and exit the program.
    // Unregister the event handler and log off.
    PrlSrv_UnregEventHandler(hServer, &callback, NULL);
    hJob = PrlSrv_Logoff(hServer);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );
    PrlApi_Deinit();
    SdkWrap_Unload();
    return 0;
}

////////////////////////////////////////////////////////////////////////////////
// The callback function implementation.
// The event handling is demonstrated here.
//
static PRL_RESULT callback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType(hEvent, &nHandleType);

    // A callback function will be called more than once.
    // It will be called for every job that we initiate and it
    // will be called for the event that we intentionally trigger.
    // In this example, we are interested in events only.
    if (nHandleType != PHT_EVENT)
    {
        return PrlHandle_Free(hEvent);
    }

    // Get the type of the event received.
    PRL_EVENT_TYPE type;
    PrlEvent_GetType(hEvent, &type);

    // See if the received event is a "question".
    if (type == PET_DSP_EVT_VM_QUESTION)
    {
        PRL_UINT32 nParamsCount = 0;
        PRL_RESULT err = PRL_ERR_UNINITIALIZED;

        // Extract the text of the question and display it on the screen.
        // The question is stored in the object in the "event message" property.
        PRL_BOOL bIsBriefMessage = true;
        char errMsg [MY_STR_BUF_SIZE];
        PRL_UINT32 nBufSize = MY_STR_BUF_SIZE;

        PrlEvent_GetErrString(hEvent, bIsBriefMessage, errMsg, &nBufSize);
        printf("Question: %s\n\n", errMsg);

        // Extract answer choices. They are stored in the
        // hEvent object as event parameters.
        // First, determine the number of parameters.
        err = PrlEvent_GetParamsCount(hEvent, &nParamsCount);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[3]%.8X: %s\n", err,
                PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Declare an array to hold the choices information.
        PRL_UINT32_PTR choices =(PRL_UINT32_PTR)
            malloc(nParamsCount * sizeof(PRL_UINT32));

        // Now, itereate through the parameter list obtaining a
        // handle of type PHT_EVENT_PARAMETER that will contain
        // an individual parameter data.
        for(PRL_UINT32 nParamIndex = 0; nParamIndex < nParamsCount; ++nParamIndex)
        {
            PRL_HANDLE hParam; // this will receive the event parameter handle.
            PRL_RESULT err = PRL_ERR_UNINITIALIZED;

            // The PrlEvent_GetParam function obtains a handle of type
            // PHT_EVENT_PARAMETER containing (in this case) an answer choice.
            err = PrlEvent_GetParam(hEvent, nParamIndex, &hParam);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[4]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Get the answer description that can be shown to the user.
            // First, obtain the event parameter value.
            err = PrlEvtPrm_ToUint32(hParam, &choices[nParamIndex]);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[9]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Now, get the answer description using the
            // event parameter value as input in the following call.
            char sDesc [MY_STR_BUF_SIZE];
            err = PrlApi_GetResultDescription(choices[nParamIndex], true, sDesc, &nBufSize);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[8]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Display the answer choice on the screen.
            printf("Answer choice: %s\n", sDesc);
            PrlHandle_Free(hParam);
        }

        // Select an answer choice (we are using the "No" answer here) and
        // create a valid answer object (hAnswer).
        PRL_HANDLE hAnswer;
        err = PrlEvent_CreateAnswerEvent(hEvent, &hAnswer, choices[1]);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[A]%.8X: %s\n", err, PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Obtain a server handle.
        PRL_HANDLE hServer;
        PrlEvent_GetServer(hEvent, &hServer);

        // Send the answer handle to the Parallels Service.
        PrlSrv_SendAnswer(hServer, hAnswer);

        free(choices);
        PrlHandle_Free(hServer);
        PrlHandle_Free(hAnswer);
    }
    else // other event type
    {
        PrlHandle_Free(hEvent);
    }

    return PRL_ERR_SUCCESS;
}

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event.
PRL_RESULT create_big_hdd(PRL_HANDLE hVm)
{
    PRL_HANDLE hJobBeginEdit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobCommit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;

    // Timestamp the beginning of the configuration changes operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    err = PrlJob_Wait(hJobBeginEdit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[B]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Create a new device handle.
    // This will be our new virtual hard disk.
    PRL_HANDLE hHDD;
    err = PrlVm_CreateVmDev(
            hVm, // Target virtual machine.
            PDE_HARD_DISK, // Device type.
            &hHDD ); // Device handle.

    // Set disk type to "expanding".
    err = PrlVmDevHd_SetDiskType(hHDD, PHD_EXPANDING_HARD_DISK);

    // Set max disk size, in megabytes.
    err = PrlVmDevHd_SetDiskSize(hHDD, MY_HDD_SIZE);

    // This option determines whether the image file will be split
    // into chunks or created as a single file.
    err = PrlVmDevHd_SetSplitted(hHDD, PRL_FALSE);

    // Choose and set the name for the new image file.
    err = PrlVmDev_SetFriendlyName(hHDD, "harddisk4.hdd");
    err = PrlVmDev_SetSysName(hHDD, "harddisk4.hdd");

    // Set the emulation type.
    err = PrlVmDev_SetEmulatedType(hHDD, PDT_USE_IMAGE_FILE);

    // Enable the new disk on successful creation.
    err = PrlVmDev_SetEnabled(hHDD, PRL_TRUE);

    // Create the new image file.
    hJob = PrlVmDev_CreateImage(hHDD,
            PRL_TRUE, // Do not overwrite if file exists.
            PRL_FALSE ); // Use non-interactive mode.

    err = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    if (PRL_FAILED(err))
    {
        fprintf(stderr, "[C]%.8X: %s\n", err,
            PRL_RESULT_TO_STRING(err));
        PrlHandle_Free(hJob);
        return err;
    }

    // Commit the changes.
    hJobCommit = PrlVm_Commit(hVm);
    err = PrlJob_Wait(hJobCommit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[D]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING( nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }
    return PRL_ERR_SUCCESS;
}
Links
PHT_EVENT, Example


PrlEvent_GetDataPtr Function

PrlEvent_GetDataPtr Function
PHT_EVENT

Clients can use this method to receive a data buffer specific to the event type.

Syntax
PRL_RESULT PrlEvent_GetDataPtr(
    PRL_HANDLE hEvent,
    PRL_VOID_PTR_PTR data_ptr
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
data_ptr
[out] A pointer to the event-specific data.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Different event types may provide different data buffers or they may provide none.

Links
PHT_EVENT


PrlEvent_GetErrCode Function

PrlEvent_GetErrCode Function
PHT_EVENT

Returns the code associated with the event.

Syntax
PRL_RESULT PrlEvent_GetErrCode(
    PRL_HANDLE hEvent,
    PRL_RESULT_PTR pnErrCode
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnErrCode
[out] A pointer to a variable that receives the code.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetErrString Function

PrlEvent_GetErrString Function
PHT_EVENT

Returns string representation of the event message.

Syntax
PRL_RESULT PrlEvent_GetErrString(
    PRL_HANDLE hEvent,
    PRL_BOOL bIsBriefMessage,
    PRL_BOOL bFormated,
    PRL_STR sErrString,
    PRL_UINT32_PTR pnErrStringBufLength
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
bIsBriefMessage
Specifies whether to return a brief or a long version of the message. Specify PBL_TRUE to return a brief message. Specify PRL_FALSE to return a long message.
bFormated
Specifies whether the HTML tags used for text formatting should be included in the resulting string. PRL_TRUE - include HTML tags. PRL_FALSE - don't include.
sErrString
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnErrStringBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetIssuerId Function

PrlEvent_GetIssuerId Function
PHT_EVENT

Returns the event issuer ID (host UUID, virtual machine UUID, etc).

Syntax
PRL_RESULT PrlEvent_GetIssuerId(
    PRL_HANDLE hEvent,
    PRL_STR sIssuerId,
    PRL_UINT32_PTR pnIssuerIdBufLength
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
sIssuerId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIssuerIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetIssuerType Function

PrlEvent_GetIssuerType Function
PHT_EVENT

Returns the event issuer type (virtual machine, host, etc.).

Syntax
PRL_RESULT PrlEvent_GetIssuerType(
    PRL_HANDLE hEvent,
    PRL_EVENT_ISSUER_TYPE_PTR pnIssuerType
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnIssuerType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetJob Function

PrlEvent_GetJob Function
PHT_EVENT

Obtains the handle of the job that caused the event.

Syntax
PRL_RESULT PrlEvent_GetJob(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR pJob
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pJob
[out] A pointer to a variable that receives a handle of type PHT_JOB.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetParam Function

PrlEvent_GetParam Function
PHT_EVENT

Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.

Syntax
PRL_RESULT PrlEvent_GetParam(
    PRL_HANDLE hEvent,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phEventParam
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
nIndex
An index identifying the event parameter (beginning with 0). To determine the number of the parameters in the event container, use the PrlEvent_GetParamsCount function.
phEventParam
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

An event container may contain multiple parameters. The meaning of the parameter may be different for different event types.

Links
PHT_EVENT


PrlEvent_GetParamByName Function

PrlEvent_GetParamByName Function
PHT_EVENT

Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.

Syntax
PRL_RESULT PrlEvent_GetParamByName(
    PRL_HANDLE hEvent,
    PRL_CONST_STR sParamName,
    PRL_HANDLE_PTR phEventParam
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
sParamName
Event parameter name.
phEventParam
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_NO_DATA - parameter with specfied name does not exist.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

An event container may contain multiple parameters. The meaning of the parameter may be different for different event types.

Links
PHT_EVENT


PrlEvent_GetParamsCount Function

PrlEvent_GetParamsCount Function
PHT_EVENT

Determines the number of the parameters in the event container.

Syntax
PRL_RESULT PrlEvent_GetParamsCount(
    PRL_HANDLE hEvent,
    PRL_UINT32_PTR pnParamsCount
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnParamsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetServer Function

PrlEvent_GetServer Function
PHT_EVENT

Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.

Syntax
PRL_RESULT PrlEvent_GetServer(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR server
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
server
[out] A pointer to a variable that receives the server handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When processing an event inside a callback function (event handler) this function is the only way to get the server handle.

Links
PHT_EVENT


PrlEvent_GetType Function

PrlEvent_GetType Function
PHT_EVENT

Returns the type of the event.

Syntax
PRL_RESULT PrlEvent_GetType(
    PRL_HANDLE hEvent,
    PRL_EVENT_TYPE_PTR type
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
type
[out] A pointer to a variable that receives the result (event type).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT


PrlEvent_GetVm Function

PrlEvent_GetVm Function
PHT_EVENT

Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.

Syntax
PRL_RESULT PrlEvent_GetVm(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR pVm
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pVm
[out] A pointer to a variable that receives the virtual machine handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When processing an event inside a callback function (event handler) this function is the only way to get the virtual machine handle.

Links
PHT_EVENT


PrlEvent_IsAnswerRequired Function

PrlEvent_IsAnswerRequired Function
PHT_EVENT

Determines whether the event requires a response from the client.

Syntax
PRL_RESULT PrlEvent_IsAnswerRequired(
    PRL_HANDLE hEvent,
    PRL_BOOL_PTR pbIsAnswerRequired
);
File

PrlApiCore.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pbIsAnswerRequired
[out] A pointer to a variable that receives the result. PBL_TRUE indicates that a response is required. PBL_TRUE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See PrlEvent_CreateAnswerEvent for more information about Parallels Service questions.

Links
PHT_EVENT


PrlEvtPrm_GetBuffer Function

PrlEvtPrm_GetBuffer Function
PHT_EVENT_PARAMETER

Returns the event parameter value as binary buffer.

Syntax
PRL_RESULT PrlEvtPrm_GetBuffer(
    PRL_HANDLE hEventParam,
    PRL_VOID_PTR pParamValue,
    PRL_UINT32_PTR pnParamValueBufLength
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pParamValue
[out] A pointer to a buffer that receives the result.
pnParamValueBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_GetName Function

PrlEvtPrm_GetName Function
PHT_EVENT_PARAMETER

Returns the event parameter name.

Syntax
PRL_RESULT PrlEvtPrm_GetName(
    PRL_HANDLE hEventParam,
    PRL_STR sParamName,
    PRL_UINT32_PTR pnParamNameBufLength
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_GetType Function

PrlEvtPrm_GetType Function
PHT_EVENT_PARAMETER

Returns the event parameter data type.

Syntax
PRL_RESULT PrlEvtPrm_GetType(
    PRL_HANDLE hEventParam,
    PRL_PARAM_FIELD_DATA_TYPE_PTR pnParamType
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamType
[out] A pointer to a variable that receives the parameter type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToBoolean Function

PrlEvtPrm_ToBoolean Function
PHT_EVENT_PARAMETER

Returns the event parameter value as boolean (PRL_BOOL).

Syntax
PRL_RESULT PrlEvtPrm_ToBoolean(
    PRL_HANDLE hEventParam,
    PRL_BOOL_PTR pbParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pbParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToCData Function

PrlEvtPrm_ToCData Function
PHT_EVENT_PARAMETER

Returns the event parameter value as CDATA.

Syntax
PRL_RESULT PrlEvtPrm_ToCData(
    PRL_HANDLE hEventParam,
    PRL_STR sParamValue,
    PRL_UINT32_PTR pnParamValueBufLength
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamValue
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamValueBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToHandle Function

PrlEvtPrm_ToHandle Function
PHT_EVENT_PARAMETER

Returns the event parameter value as PRL_HANDLE.

Syntax
PRL_RESULT PrlEvtPrm_ToHandle(
    PRL_HANDLE hEventParam,
    PRL_HANDLE_PTR phParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
phParamValue
[out] A pointer to a variable that receives the handle. The handle type can be determined using the PrlHandle_GetType function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToInt32 Function

PrlEvtPrm_ToInt32 Function
PHT_EVENT_PARAMETER

Returns the event parameter value as PRL_INT32.

Syntax
PRL_RESULT PrlEvtPrm_ToInt32(
    PRL_HANDLE hEventParam,
    PRL_INT32_PTR pnParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToInt64 Function

PrlEvtPrm_ToInt64 Function
PHT_EVENT_PARAMETER

Returns the event parameter value as PRL_INT64.

Syntax
PRL_RESULT PrlEvtPrm_ToInt64(
    PRL_HANDLE hEventParam,
    PRL_INT64_PTR pnParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToString Function

PrlEvtPrm_ToString Function
PHT_EVENT_PARAMETER

Returns the event parameter value as string.

Syntax
PRL_RESULT PrlEvtPrm_ToString(
    PRL_HANDLE hEventParam,
    PRL_STR sParamValue,
    PRL_UINT32_PTR pnParamValueBufLength
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamValue
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamValueBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToUint32 Function

PrlEvtPrm_ToUint32 Function
PHT_EVENT_PARAMETER

Returns the event parameter value as PRL_UINT32.

Syntax
PRL_RESULT PrlEvtPrm_ToUint32(
    PRL_HANDLE hEventParam,
    PRL_UINT32_PTR pnParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlEvtPrm_ToUint64 Function

PrlEvtPrm_ToUint64 Function
PHT_EVENT_PARAMETER

Returns the event parameter value as PRL_UINT64.

Syntax
PRL_RESULT PrlEvtPrm_ToUint64(
    PRL_HANDLE hEventParam,
    PRL_UINT64_PTR pnParamValue
);
File

PrlApiCore.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_EVENT_PARAMETER


PrlFirewallRule_Create Function

PrlFirewallRule_Create Function
PHT_FIREWALL_RULE

Creates a new handle of type PHT_FIREWALL_RULE.

Syntax
PRL_RESULT PrlFirewallRule_Create(
    PRL_HANDLE_PTR phRule
);
File

PrlApiVm.h

Parameters

phRule
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the user to free the handle when it is no longer needed.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_GetLocalNetAddress Function

PrlFirewallRule_GetLocalNetAddress Function
PHT_FIREWALL_RULE

Returns the local address of the specified firewall rule entry.

Syntax
PRL_RESULT PrlFirewallRule_GetLocalNetAddress(
    PRL_HANDLE hRule,
    PRL_STR sAddr,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sAddr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_GetLocalPort Function

PrlFirewallRule_GetLocalPort Function
PHT_FIREWALL_RULE

Returns the local port.

Syntax
PRL_RESULT PrlFirewallRule_GetLocalPort(
    PRL_HANDLE hRule,
    PRL_UINT32_PTR pnPort
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
pnPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_GetProtocol Function

PrlFirewallRule_GetProtocol Function
PHT_FIREWALL_RULE

Returns the protocol of the specified firewall rule entry.

Syntax
PRL_RESULT PrlFirewallRule_GetProtocol(
    PRL_HANDLE hRule,
    PRL_STR sProtocol,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sProtocol
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_GetRemoteNetAddress Function

PrlFirewallRule_GetRemoteNetAddress Function
PHT_FIREWALL_RULE

Returns the remote address of the specified firewall rule entry.

Syntax
PRL_RESULT PrlFirewallRule_GetRemoteNetAddress(
    PRL_HANDLE hRule,
    PRL_STR sAddr,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sAddr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_GetRemotePort Function

PrlFirewallRule_GetRemotePort Function
PHT_FIREWALL_RULE

Returns the remote port.

Syntax
PRL_RESULT PrlFirewallRule_GetRemotePort(
    PRL_HANDLE hRule,
    PRL_UINT32_PTR pnPort
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
pnPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_SetLocalNetAddress Function

PrlFirewallRule_SetLocalNetAddress Function
PHT_FIREWALL_RULE

Sets the specified firewall rule entry local address.

Syntax
PRL_RESULT PrlFirewallRule_SetLocalNetAddress(
    PRL_HANDLE hRule,
    PRL_CONST_STR sAddr
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sAddr
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_SetLocalPort Function

PrlFirewallRule_SetLocalPort Function
PHT_FIREWALL_RULE

Sets the specified local port.

Syntax
PRL_RESULT PrlFirewallRule_SetLocalPort(
    PRL_HANDLE hRule,
    PRL_UINT32 nPort
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
nPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_SetProtocol Function

PrlFirewallRule_SetProtocol Function
PHT_FIREWALL_RULE

Sets the specified firewall rule entry protocol.

Syntax
PRL_RESULT PrlFirewallRule_SetProtocol(
    PRL_HANDLE hRule,
    PRL_CONST_STR sProtocol
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sProtocol
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_SetRemoteNetAddress Function

PrlFirewallRule_SetRemoteNetAddress Function
PHT_FIREWALL_RULE

Sets the specified firewall rule entry remote address.

Syntax
PRL_RESULT PrlFirewallRule_SetRemoteNetAddress(
    PRL_HANDLE hRule,
    PRL_CONST_STR sAddr
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
sAddr
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFirewallRule_SetRemotePort Function

PrlFirewallRule_SetRemotePort Function
PHT_FIREWALL_RULE

Sets the specified remote port.

Syntax
PRL_RESULT PrlFirewallRule_SetRemotePort(
    PRL_HANDLE hRule,
    PRL_UINT32 nPort
);
File

PrlApiVm.h

Parameters

hRule
A handle of type PHT_FIREWALL_RULE identifying the firewall rule.
nPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FIREWALL_RULE


PrlFoundVmInfo_GetConfigPath Function

PrlFoundVmInfo_GetConfigPath Function
PHT_FOUND_VM_INFO

Extracts the virtual machine configuration path from the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetConfigPath(
    PRL_HANDLE handle,
    PRL_STR sPath,
    PRL_UINT32_PTR pnPathBufLength
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
sPath
[out] A pointer to a buffer that receives the path. Pass a null pointer to determine the required buffer size.
pnPathBufLength
[in] The size of the buffer used to receive the output data (in bytes). [out] The required buffer size if the buffer parameter contains a null pointer or if the specified buffer size is not large enough.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FOUND_VM_INFO


PrlFoundVmInfo_GetName Function

PrlFoundVmInfo_GetName Function
PHT_FOUND_VM_INFO

Extracts the virtual machine name form the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetName(
    PRL_HANDLE handle,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
sName
[out] A pointer to a buffer that receives the name. Pass a null pointer to determine the required buffer size.
pnNameBufLength
[in] The size of the buffer used to receive the output data (in bytes). [out] The required buffer size if the buffer parameter contains a null pointer or if the specified buffer size is not large enough.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FOUND_VM_INFO


PrlFoundVmInfo_GetOSVersion Function

PrlFoundVmInfo_GetOSVersion Function
PHT_FOUND_VM_INFO

Extracts the virtual machine's OS version from the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetOSVersion(
    PRL_HANDLE handle,
    PRL_UINT32_PTR pnOSVersion
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pnOSVersion
[out] A pointer to a variable that receives the OS version.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FOUND_VM_INFO


PrlFoundVmInfo_IsOldConfig Function

PrlFoundVmInfo_IsOldConfig Function
PHT_FOUND_VM_INFO

Determines if the virtual machine has an old configuration.

Syntax
PRL_RESULT PrlFoundVmInfo_IsOldConfig(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbOldVersion
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pbOldVersion
[out] A pointer to a variable that receives the result. A value of "true" indicates that the machine has an old configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FOUND_VM_INFO


PrlFoundVmInfo_IsTemplate Function

PrlFoundVmInfo_IsTemplate Function
PHT_FOUND_VM_INFO

Determines of the specified virtual machine is a template.

Syntax
PRL_RESULT PrlFoundVmInfo_IsTemplate(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsTemplate
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pbIsTemplate
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the virtual machine is a template. PRL_TRUE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_FOUND_VM_INFO


PrlFsEntry_GetAbsolutePath Function

PrlFsEntry_GetAbsolutePath Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the specified file system entry absolute path.

Syntax
PRL_RESULT PrlFsEntry_GetAbsolutePath(
    PRL_HANDLE hFsEntry,
    PRL_STR sAbsolutePath,
    PRL_UINT32_PTR pnAbsolutePathBufLength
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sAbsolutePath
[out] A pointer to a buffer that receives the path (a UTF-8 encoded, null-terminated string).
pnAbsolutePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetLastModifiedDate Function

PrlFsEntry_GetLastModifiedDate Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the date on which the specified file system entry was last modified.

Syntax
PRL_RESULT PrlFsEntry_GetLastModifiedDate(
    PRL_HANDLE hFsEntry,
    PRL_STR sFsEntryLastModifiedDate,
    PRL_UINT32_PTR pnFsEntryLastModifiedDateBufLength
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sFsEntryLastModifiedDate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The date is specified as: yyyy-mm-dd hh:mi:ss.
pnFsEntryLastModifiedDateBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returned time is a local time (i.e. the time value is returned already converted to local time zone).

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetPermissions Function

PrlFsEntry_GetPermissions Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the specified file system entry permissions (read, write, execute) for the current user.

Syntax
PRL_RESULT PrlFsEntry_GetPermissions(
    PRL_HANDLE hFsEntry,
    PRL_UINT32_PTR pnPermissions
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnPermissions
[out] A pointer to a variable that receives the permission information. The permissions are specified as bitmasks. For bitmask values see macros in the PrlFs.h file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetRelativeName Function

PrlFsEntry_GetRelativeName Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the file system entry relative name.

Syntax
PRL_RESULT PrlFsEntry_GetRelativeName(
    PRL_HANDLE hFsEntry,
    PRL_STR sRelativeName,
    PRL_UINT32_PTR pnRelativeNameBufLength
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sRelativeName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnRelativeNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetSize Function

PrlFsEntry_GetSize Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the file system entry size.

Syntax
PRL_RESULT PrlFsEntry_GetSize(
    PRL_HANDLE hFsEntry,
    PRL_UINT64_PTR pnSize
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnSize
[out] A pointer to a variable that receives the size (in bytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetType Function

PrlFsEntry_GetType Function
PHT_REMOTE_FILESYSTEM_ENTRY

Returns the file system entry type (file, directory, drive).

Syntax
PRL_RESULT PrlFsEntry_GetType(
    PRL_HANDLE hFsEntry,
    PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR pnFsEntryType
);
File

PrlApiDisp.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnFsEntryType
[out] A pointer to a variable that receives the type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsInfo_GetChildEntriesCount Function

PrlFsInfo_GetChildEntriesCount Function
PHT_REMOTE_FILESYSTEM_INFO

Determines the number of child entries for the specified remote file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetChildEntriesCount(
    PRL_HANDLE hFsInfo,
    PRL_UINT32_PTR pnChildEntriesCount
);
File

PrlApiDisp.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnChildEntriesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetChildEntry Function

PrlFsInfo_GetChildEntry Function
PHT_REMOTE_FILESYSTEM_INFO

Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.

Syntax
PRL_RESULT PrlFsInfo_GetChildEntry(
    PRL_HANDLE hFsInfo,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phChildEntry
);
File

PrlApiDisp.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the parent file system entry.
nIndex
A child entry index. To get the total number of child entries, use the PrlFsInfo_GetChildEntriesCount function.
phChildEntry
[out] A pointer to a variable that receives the child entry handle. The handle type is PHT_REMOTE_FILESYSTEM_ENTRY.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetFsType Function

PrlFsInfo_GetFsType Function
PHT_REMOTE_FILESYSTEM_INFO

Determines the file system type of the specified file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetFsType(
    PRL_HANDLE hFsInfo,
    PRL_FILE_SYSTEM_FS_TYPE_PTR pnFsType
);
File

PrlApiDisp.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnFsType
[out] A pointer to a variable that receives the file entry type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetParentEntry Function

PrlFsInfo_GetParentEntry Function
PHT_REMOTE_FILESYSTEM_INFO

Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetParentEntry(
    PRL_HANDLE hFsInfo,
    PRL_HANDLE_PTR phParentEntry
);
File

PrlApiDisp.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
phParentEntry
[out] A pointer to a variable that receives the handle. The handle type is PHT_REMOTE_FILESYSTEM_ENTRY.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetType Function

PrlFsInfo_GetType Function
PHT_REMOTE_FILESYSTEM_INFO

Determines the basic type of the specified file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetType(
    PRL_HANDLE hFsInfo,
    PRL_FILE_SYSTEM_TYPE_PTR pnFsType
);
File

PrlApiDisp.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnFsType
[out] A pointer to a variable that receives the file entry type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_REMOTE_FILESYSTEM_INFO


PrlHandle_AddRef Function

PrlHandle_AddRef Function
Handle Functions See Also

Increases the specified handle reference count by one.

Syntax
PRL_RESULT PrlHandle_AddRef(
    PRL_HANDLE handle
);
File

PrlApiCore.h

Parameters

handle
Handle to duplicate.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handles used within the Parallels API are thread safe. They can be used in multiple threads at the same time. To maintain the proper reference counting, the count should be increased each time a handle is passed to another thread by calling the PrlHandle_AddRef function. If this is not done, freeing a handle in one thread may destroy it while other threads are still using it.

See Also

PrlHandle_Free

Links
Handle Functions, See Also


PrlHandle_Free Function

PrlHandle_Free Function
Handle Functions

Frees the specified handle.

Syntax
PRL_RESULT PrlHandle_Free(
    PRL_HANDLE handle
);
File

PrlApiCore.h

Parameters

handle
Handle to free.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handles used within the Parallels API are reference counted. Each handle contains a count of the number of references to it held by other objects. A corresponding object stays in memory for as long as the count is greater than zero. A client application is responsible for freeing any handles that are no longer required. A handle can be freed using the PrlHandle_Free function. The function decreases the reference count by one. When the count reaches zero, the object is destroyed. Failing to free a handle after it has been used will result in a memory leak.

Links
Handle Functions


PrlHandle_GetChannelStatistics Function

PrlHandle_GetChannelStatistics Function
Handle Functions

Retrieves IO channel statistics (throughput, delay) for correspond virtual machine or remote desktop control object.

Syntax
PRL_RESULT PrlHandle_GetChannelStatistics(
    PRL_HANDLE hObj,
    PRL_IO_CHANNEL_STAT_PTR channelStat
);
File

PrlApiCore.h

Parameters

hObj
A handle of type PHT_SERVER, PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
channelStat
A pointer to the statistics structure

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_NO_DATA - mostly indicates there is no connection to remote desktop now available. I.e. PrlDevDisplay_ConnectToVm was not called.

PRL_ERR_SUCCESS - function completed successfully.

Links
Handle Functions


PrlHandle_GetPackageId Function

PrlHandle_GetPackageId Function
Handle Functions See Also

Returns the numeric identifier of the package that caused the event.

Syntax
PRL_RESULT PrlHandle_GetPackageId(
    PRL_HANDLE hObj,
    PRL_UINT64_PTR id
);
File

PrlApiCore.h

Parameters

id
[out] A pointer to a variable that receives the result (event id).
hEvent
A handle of type PHT_EVENT or PHT_JOB.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The numeric identifier is a monotonically increasing number. It is reset to one on dispatcher restart. If event or job was not originated in the dispatcher, then the numeric identifier is equal to zero. A triplet of values forms a unique monotonically increasing numeric identifier that could be used for event ordering. See PrlSrvInfo_GetStartTime and PrlSrvInfo_GetStartTimeMonotonic for details on how to obtain (monotonic) dispatcher start time value.

See Also

PrlSrvInfo_GetStartTime PrlSrvInfo_GetStartTimeMonotonic

Links
Handle Functions, See Also


PrlHandle_GetType Function

PrlHandle_GetType Function
Handle Functions

Returns the type of the specified handle.

Syntax
PRL_RESULT PrlHandle_GetType(
    PRL_HANDLE handle,
    PRL_HANDLE_TYPE_PTR type
);
File

PrlApiCore.h

Parameters

handle
Handle to get the type for.
type
[out] A pointer to a variable that receives the result. The type is returned as an enumerator of the PRL_HANDLE_TYPE enumeration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handle is an abstraction that is used to hide an object implementation. While there are many methods used to access functionality of different objects, this method is used to identify object type as one of the PRL_HANDLE_TYPE types.

Links
Handle Functions


PrlHandle_RegEventHandler Function

PrlHandle_RegEventHandler Function
Handle Functions

Registers event handler.

Syntax
PRL_RESULT PrlHandle_RegEventHandler(
    PRL_HANDLE hObj,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiCore.h

Parameters

hObj
[in] A handle of type PHT_SERVER, PHT_VIRTUAL_MACHINE, PHT_DESKTOP_CONTROL or PHT_CVSRC.
handler
[in] User defined function that will be called for each event.
userData
[in] User defined data that will be passed to handler.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
Handle Functions


PrlHandle_UnregEventHandler Function

PrlHandle_UnregEventHandler Function
Handle Functions

Unregisters event handler.

Syntax
PRL_RESULT PrlHandle_UnregEventHandler(
    PRL_HANDLE hObj,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiCore.h

Parameters

hObj
[in] A handle of type PHT_SERVER, PHT_VIRTUAL_MACHINE, PHT_DESKTOP_CONTROL or PHT_CVSRC.
handler
[in] User defined function specified in previous call to PrlHandle_RegEventHandler().
userData
[in] User defined data specified in previous call to PrlHandle_RegEventHandler().

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
Handle Functions


PrlHndlList_AddItem Function

PrlHndlList_AddItem Function
PHT_HANDLES_LIST

Adds the specified handle to the container.

Syntax
PRL_RESULT PrlHndlList_AddItem(
    PRL_HANDLE hHandlesList,
    PRL_HANDLE hItem
);
File

PrlApiCore.h

Parameters

hHandlesList
A handle of type PHT_HANDLES_LIST identifying the container.
hItem
A handle to add to the container. No validation of any kind is performed when adding a handle to the list.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Links
PHT_HANDLES_LIST


PrlHndlList_GetItem Function

PrlHndlList_GetItem Function
PHT_HANDLES_LIST

Retrieves a handle from the container.

Syntax
PRL_RESULT PrlHndlList_GetItem(
    PRL_HANDLE hHandlesList,
    PRL_UINT32 nItemIndex,
    PRL_HANDLE_PTR phItem
);
File

PrlApiCore.h

Parameters

hHandlesList
A handle of type PHT_HANDLES_LIST identifying the container.
nItemIndex
A numeric index of the handle to retrieve (beginning with zero). To get the total number of handles in the container, use the PrlHndlList_GetItemsCount function.
phItem
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or out of range index value was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Links
PHT_HANDLES_LIST


PrlHndlList_GetItemsCount Function

PrlHndlList_GetItemsCount Function
PHT_HANDLES_LIST

Determines the total number of handles in the specified container.

Syntax
PRL_RESULT PrlHndlList_GetItemsCount(
    PRL_HANDLE hHandlesList,
    PRL_UINT32_PTR pnItemsCount
);
File

PrlApiCore.h

Parameters

hHandlesList
A handle of type PHT_HANDLES_LIST identifying the container.
pnItemsCount
[out] A pointer to a variable that receives the result. Handle count begins with zero.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or out of range index value was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

After determining the count, use the PrlHndlList_GetItem function to retrieve the handle from the container.

Links
PHT_HANDLES_LIST


PrlHndlList_RemoveItem Function

PrlHndlList_RemoveItem Function
PHT_HANDLES_LIST

Removes a handle from the container.

Syntax
PRL_RESULT PrlHndlList_RemoveItem(
    PRL_HANDLE hHandlesList,
    PRL_UINT32 nItemIndex
);
File

PrlApiCore.h

Parameters

hHandlesList
A handle of type PHT_HANDLES_LIST identifying the container.
nItemIndex
A numeric index of the handle to remove (beginning with zero). To get the total number of handles in the container, use the PrlHndlList_GetItemsCount function.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or out of range index value was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Links
PHT_HANDLES_LIST


PrlIPPrivNet_Create Function

PrlIPPrivNet_Create Function
PHT_IPPRIV_NET

Creates a new handle of type PHT_IPPRIV_NET.

Syntax
PRL_RESULT PrlIPPrivNet_Create(
    PRL_HANDLE_PTR phPrivNet
);
File

PrlApiNet.h

Parameters

phPrivNet
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to create and configure an IP private network. If you would like to create a new IP private network, use this function to create the handle first and then use the handle functions to configure the network. If you would like to modify the configuration of an existing network, use the PrlSrv_GetIPPrivateNetworksList function to obtain a handle to the private network of interest.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_IPPRIV_NET


PrlIPPrivNet_GetName Function

PrlIPPrivNet_GetName Function
PHT_IPPRIV_NET

Returns the name of the specified private network.

Syntax
PRL_RESULT PrlIPPrivNet_GetName(
    PRL_HANDLE hPrivNet,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
sName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_IPPRIV_NET


PrlIPPrivNet_GetNetAddresses Function

PrlIPPrivNet_GetNetAddresses Function
PHT_IPPRIV_NET

Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a private network.

Syntax
PRL_RESULT PrlIPPrivNet_GetNetAddresses(
    PRL_HANDLE hPrivNet,
    PRL_HANDLE_PTR pNetAddresses
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
phNetAddressesList
[out] A pointer to the PHT_STRINGS_LIST handle containing the IP addresses.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returns the list of pairs "IP address/Subnet mask" which is applied to the private network. The result will be returned as list of strings (PHT_STRINGS_LIST type) of pairs "IP address/Subnet mask".

Links
PHT_IPPRIV_NET


PrlIPPrivNet_IsGlobal Function

PrlIPPrivNet_IsGlobal Function
PHT_IPPRIV_NET

Determines the mode (global or not) of the specified private network.

Syntax
PRL_RESULT PrlIPPrivNet_IsGlobal(
    PRL_HANDLE hPrivNet,
    PRL_BOOL_PTR pbGlobal
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
pbGlobal
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_IPPRIV_NET


PrlIPPrivNet_SetGlobal Function

PrlIPPrivNet_SetGlobal Function
PHT_IPPRIV_NET

Sets the mode (global or not) of the specified private network.

Syntax
PRL_RESULT PrlIPPrivNet_SetGlobal(
    PRL_HANDLE hPrivNet,
    PRL_BOOL bGlobal
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
bGlobal
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_IPPRIV_NET


PrlIPPrivNet_SetName Function

PrlIPPrivNet_SetName Function
PHT_IPPRIV_NET

Sets the specified private network ID.

Syntax
PRL_RESULT PrlIPPrivNet_SetName(
    PRL_HANDLE hPrivNet,
    PRL_CONST_STR sName
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
sNetworkId
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_IPPRIV_NET


PrlIPPrivNet_SetNetAddresses Function

PrlIPPrivNet_SetNetAddresses Function
PHT_IPPRIV_NET

Allows to set IP addresses/Subnet masks to a private network.

Syntax
PRL_RESULT PrlIPPrivNet_SetNetAddresses(
    PRL_HANDLE hPrivNet,
    PRL_HANDLE NetAddresses
);
File

PrlApiNet.h

Parameters

hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network.
hNetAddressesList
A handle of type PHT_STRINGS_LIST containing the list of "IP address/Subnet mask" pairs to be applied to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_IPPRIV_NET


PrlJob_Cancel Function

PrlJob_Cancel Function
PHT_JOB

Cancel the specified job.

Syntax
PRL_HANDLE PrlJob_Cancel(
    PRL_HANDLE hJob
);
File

PrlApiCore.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.

Returns

PRL_HANDLE to the job being canceled.

PRL_INVALID_HANDLE - not enough memory to instantiate asynchronous operation.

The results are retrieved using the PrlJob_GetRetCode function. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_JOB handle was passed.

PRL_ERR_UNINITIALIZED - job instance was not bound to Parallels Service connection.

Remarks

If an asynchronous operation takes a long time to complete, you may cancel it by calling this function. The call does not destroy the job object.

Links
PHT_JOB


PrlJob_GetDataPtr Function

PrlJob_GetDataPtr Function
PHT_JOB

The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.

Syntax
PRL_RESULT PrlJob_GetDataPtr(
    PRL_HANDLE hJob,
    PRL_VOID_PTR data_ptr,
    PRL_UINT32_PTR data_size
);
File

PrlApiCore.h

Parameters

data_ptr
[out] A pointer to a buffer that receives the data. Pass a null pointer to determine the required buffer size.
data_size
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
handle
A handle of type PHT_JOB identifying the job.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Different operations may or may not provide a data buffer as a result of their execution. This function should be used only when an operation results in a buffer populated with the data specific to that operation.

Links
PHT_JOB


PrlJob_GetError Function

PrlJob_GetError Function
PHT_JOB

Provides additional job error information.

Syntax
PRL_RESULT PrlJob_GetError(
    PRL_HANDLE hJob,
    PRL_HANDLE_PTR phError
);
File

PrlApiCore.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
phError
[out] A pointer to a variable that receives a handle of type PHT_EVENT containing the error information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no additional error information is available.

PRL_ERR_UNIMPLEMENTED - the functionality is not available for this job type.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a job returned an error code (see PrlJob_GetRetCode), you may call this function to see if additional error information is available. If the information is available, the function returns with PRL_ERR_SUCCESS and obtains a handle of type PHT_EVENT containing the information. To extract the information from the object, use the PrlEvent_GetErrString function.

Links
PHT_JOB


PrlJob_GetOpCode Function

PrlJob_GetOpCode Function
PHT_JOB

Returns the job operation code.

Syntax
PRL_RESULT PrlJob_GetOpCode(
    PRL_HANDLE hJob,
    PRL_JOB_OPERATION_CODE_PTR pnOpCode
);
File

PrlApiCore.h

Parameters

pnOpCode
[out] A pointer to a variable that receives the result.
handle
A handle of type PHT_JOB identifying the job.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A job operation code can be used to identify the function that started the corresponding operation and to determine the type of the result the job object contains. Use this function in an event handler (callback function) when examining a received job object. For example, the operation code PJOC_SRV_LOGIN means that this job belongs to login operation (PrlSrv_Login, PrlSrv_LoginLocal); the PJOC_SRV_GET_VM_LIST code means that the job was started by the PrlSrv_GetVmList function call and contains a list of virtual machines, etc.

Links
PHT_JOB


PrlJob_GetProgress Function

PrlJob_GetProgress Function
PHT_JOB

Obtains a job progress report.

Syntax
PRL_RESULT PrlJob_GetProgress(
    PRL_HANDLE hJob,
    PRL_UINT32_PTR percentage
);
File

PrlApiCore.h

Parameters

percentage
[out] A pointer to a variable that receives the result (an integer value from 0 to 100).
handle
valid PRL_HANDLE

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The job progress is reported as percentage of completion.

Links
PHT_JOB


PrlJob_GetResult Function

PrlJob_GetResult Function
PHT_JOB Example

Obtains a handle of type PHT_RESULT containing the result returned by the job.

Syntax
PRL_RESULT PrlJob_GetResult(
    PRL_HANDLE hJob,
    PRL_HANDLE_PTR handle
);
File

PrlApiCore.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
handle
[out] pointer to the job result handle

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OPERATION_PENDING - the asynchronous operation that this job refers to is still in progress.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Depending on the job, the PHT_RESULT object may contain a handle, a list of handles, a string, or a list of strings. The description of each asynchronous function in this documentation contains information whether the function returns a PHT_RESULT object or not, and provides instructions on how to obtain it.

Example

The following code illustrates how to obtain a result from the job object using the login operation as an example.

// Log in to a Parallels Service.
hJob =
PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );

// Wait for the job to complete.
PrlJob_Wait( hJob, 10000 );

// Get a handle of type PHT_RESULT containing the results
// of the operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_JOB, Example


PrlJob_GetRetCode Function

PrlJob_GetRetCode Function
PHT_JOB

Obtains the return code from the specified job object.

Syntax
PRL_RESULT PrlJob_GetRetCode(
    PRL_HANDLE hJob,
    PRL_RESULT_PTR retcode
);
File

PrlApiCore.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
retcode
[out] A pointer to a variable that receives the return code.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

On asynchronous operation completion, the job object will contain a return code indicating whether the operation succeeded or failed. Different jobs may return different error codes. The most common codes are: PRL_ERR_INVALID_ARG (invalid input parameters were specified in the asynchronous function call) and PRL_ERR_SUCCESS (function successfully completed).

Links
PHT_JOB


PrlJob_GetStatus Function

PrlJob_GetStatus Function
PHT_JOB

Obtains the current status of the specified job.

Syntax
PRL_RESULT PrlJob_GetStatus(
    PRL_HANDLE hJob,
    PRL_JOB_STATUS_PTR status
);
File

PrlApiCore.h

Parameters

hJob
A handle if type PHT_JOB identifying the job.
status
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_JOB


PrlJob_IsRequestWasSent Function

PrlJob_IsRequestWasSent Function
PHT_JOB

Returns the sign whether request was sent to remote side or was aborted by some local reasons (wrong params passed or something else).

Syntax
PRL_RESULT PrlJob_IsRequestWasSent(
    PRL_HANDLE hJob,
    PRL_BOOL_PTR pbIsRequestWasSent
);
File

PrlApiCore.h

Parameters

handle
A handle of type PHT_JOB identifying the job.
pbIsOwner
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_JOB


PrlJob_Wait Function

PrlJob_Wait Function
PHT_JOB Example

The PrlJob_Wait function allows to use asynchronous functions synchronously.

Syntax
PRL_RESULT PrlJob_Wait(
    PRL_HANDLE hJob,
    PRL_UINT32 msecs
);
File

PrlApiCore.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
msecs
Timeout in milliseconds. The timeout must be long enough for the job to complete. The optimal value is determined empirically. For an infinite timeout, use the UINT_MAX value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - an invalid PHT_JOB handle was passed.

PRL_ERR_TIMEOUT - the specified timeout limit was reached.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

The function should be called immediately after the corresponding asynchronous function call. It suspends the main thread for the specified number of milliseconds and waits for the job to complete. If the job completes before the timeout value is reached, the function returns and the execution of the main thread continues normally. If the function times out, it returns an error. On function return, the job object will not be destroyed and could be queried until its destruction with the call to PrlHandle_Free.

Example
// Log in to Parallels Service.
// This is an asynchronous call.
// Returns a handle to the Job object.
PRL_HANDLE hJob = PrlSrv_Login(
    hServer, "10.30.23.105", "miket", "1q2w3e",
    0, 0, 0, PRL_SECURITY_LEVEL::PSL_LOW_SECURITY);

// Wait for the Job object to receive the results of the operation.
ret = PrlJob_Wait( hJob, 1000 );
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait returned with error (%s)\n",
        PRL_RESULT_TO_STRING(ret));
    return -1;
}

// Get the results from the Job object.
PRL_RESULT nJobResult;
ret = PrlJob_GetRetCode( hJob, &nJobResult );
if (PRL_FAILED( nJobResult ))
{
    printf("login job returned with error (%s)\n",
        PRL_RESULT_TO_STRING( nJobResult ));
    return -1;
}
else
    printf( "Login succeeded.\n" );

// Delete the Job handle.
PrlHandle_Free( hJob );
Links
PHT_JOB, Example


PrlLic_GetCompanyName Function

PrlLic_GetCompanyName Function
PHT_LICENSE

Returns the name of the company to which this license was issued.

Syntax
PRL_RESULT PrlLic_GetCompanyName(
    PRL_HANDLE hLicense,
    PRL_STR sCompanyName,
    PRL_UINT32_PTR pnCompanyNameBufLength
);
File

PrlApiDisp.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sCompanyName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnCompanyNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LICENSE


PrlLic_GetLicenseKey Function

PrlLic_GetLicenseKey Function
PHT_LICENSE

Returns the license key string.

Syntax
PRL_RESULT PrlLic_GetLicenseKey(
    PRL_HANDLE hLicense,
    PRL_STR sLicenseKey,
    PRL_UINT32_PTR pnLicenseKeyBufLength
);
File

PrlApiDisp.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sLicenseKey
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnLicenseKeyBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LICENSE


PrlLic_GetStatus Function

PrlLic_GetStatus Function
PHT_LICENSE

Returns the license status.

Syntax
PRL_RESULT PrlLic_GetStatus(
    PRL_HANDLE hLicense,
    PRL_RESULT_PTR pnValue
);
File

PrlApiDisp.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
pnValue
[out] A pointer to a variable that receives the license status.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LICENSE


PrlLic_GetUserName Function

PrlLic_GetUserName Function
PHT_LICENSE

Returns the license user name.

Syntax
PRL_RESULT PrlLic_GetUserName(
    PRL_HANDLE hLicense,
    PRL_STR sUserName,
    PRL_UINT32_PTR pnUserNameBufLength
);
File

PrlApiDisp.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sUserName
[out] A pointer to a buffer that receives the user name (a UTF-8 encoded, null-terminated string).
pnUserNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LICENSE


PrlLic_IsValid Function

PrlLic_IsValid Function
PHT_LICENSE

Determines if the license is valid.

Syntax
PRL_RESULT PrlLic_IsValid(
    PRL_HANDLE hLicense,
    PRL_BOOL_PTR pbValue
);
File

PrlApiDisp.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
pbValue
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the license is valid. PRL_FALSE indicates that the license is invalid.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LICENSE


PrlLoginResponse_GetHostOsVersion Function

PrlLoginResponse_GetHostOsVersion Function
PHT_LOGIN_RESPONSE

Returns the host OS version.

Syntax
PRL_RESULT PrlLoginResponse_GetHostOsVersion(
    PRL_HANDLE hLoginResp,
    PRL_STR sHostOsVersion,
    PRL_UINT32_PTR pnHostOsVersionBufLength
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sHostOsVersion
[out] A pointer to a buffer that receives the OS version (a UTF-8 encoded, null-terminated string).
pnHostOsVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LOGIN_RESPONSE


PrlLoginResponse_GetProductVersion Function

PrlLoginResponse_GetProductVersion Function
PHT_LOGIN_RESPONSE

Returns the Parallels product version number.

Syntax
PRL_RESULT PrlLoginResponse_GetProductVersion(
    PRL_HANDLE hLoginResp,
    PRL_STR sProductVersion,
    PRL_UINT32_PTR pnProductVersionBufLength
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sProductVersion
[out] A pointer to a buffer that receives the product version (a UTF-8 encoded, null-terminated string).
pnProductVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LOGIN_RESPONSE


PrlLoginResponse_GetRunningTaskByIndex Function

PrlLoginResponse_GetRunningTaskByIndex Function
PHT_LOGIN_RESPONSE

Obtains a handle of type PHT_RUNNING_TASK.

Syntax
PRL_RESULT PrlLoginResponse_GetRunningTaskByIndex(
    PRL_HANDLE hLoginResp,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phRunningTask
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
nIndex
An index of the task to obtain the handle for (starting at 0). To determine the total number of the available tasks, use the PrlLoginResponse_GetRunningTaskCount function.
phRunningTask
[out] A pointer to a variable that receives the handle of type PHT_RUNNING_TASK containing the task information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a previous session ID was passed to the corresponding login operation, the PHT_LOGIN_RESPONSE object will contain a list of the tasks that were initiated during the previous session and are still running (if any). A task ID (that can be retrieved using this function) can be passed to the PrlSrv_AttachToLostTask function to get a handle to the task, thus gaining control to it.

Links
PHT_LOGIN_RESPONSE


PrlLoginResponse_GetRunningTaskCount Function

PrlLoginResponse_GetRunningTaskCount Function
PHT_LOGIN_RESPONSE

Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.

Syntax
PRL_RESULT PrlLoginResponse_GetRunningTaskCount(
    PRL_HANDLE hLoginResp,
    PRL_UINT32_PTR pnCount
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
pnCount
[out] A pointer to a variable that receives the size of the array.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See the PrlLoginResponse_GetRunningTaskByIndex function for more information.

Links
PHT_LOGIN_RESPONSE


PrlLoginResponse_GetServerUuid Function

PrlLoginResponse_GetServerUuid Function
PHT_LOGIN_RESPONSE

Returns the host machine UUID.

Syntax
PRL_RESULT PrlLoginResponse_GetServerUuid(
    PRL_HANDLE hLoginResp,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sServerUuid
[out] A pointer to a buffer that receives the Parallels Service UUID (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LOGIN_RESPONSE


PrlLoginResponse_GetSessionUuid Function

PrlLoginResponse_GetSessionUuid Function
PHT_LOGIN_RESPONSE

Returns session UUID string (used to restore a session).

Syntax
PRL_RESULT PrlLoginResponse_GetSessionUuid(
    PRL_HANDLE hLoginResp,
    PRL_STR sSessionUuid,
    PRL_UINT32_PTR pnSessionUuidBufLength
);
File

PrlApiDisp.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sSessionUuid
[out] A pointer to a buffer that receives the session UUID (a UTF-8 encoded, null-terminated string).
pnSessionUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_LOGIN_RESPONSE


PrlNetSvc_GetStatus Function

PrlNetSvc_GetStatus Function
PHT_NET_SERVICE_STATUS

Returns the Parallels Service network status information.

Syntax
PRL_RESULT PrlNetSvc_GetStatus(
    PRL_HANDLE handle,
    PRL_SERVICE_STATUS_ENUM_PTR pnNetStatus
);
File

PrlApiNet.h

Parameters

handle
A handle of type PHT_NET_SERVICE_STATUS.
pnNetStatus
[out] A pointer to a variable that receives the status information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NET_SERVICE_STATUS


PrlNetworkClass_Create Function

PrlNetworkClass_Create Function
PHT_NETWORK_CLASS

Creates a new handle of type PHT_NETWORK_CLASS.

Syntax
PRL_RESULT PrlNetworkClass_Create(
    PRL_UINT32 nClassId,
    PRL_HANDLE_PTR phNetworkClass
);
File

PrlApiNet.h

Parameters

nClassId
Network class id.
phNetworkClass
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to configure network accounting configuration If you would like to manage network classes configuration, use this function to create the handle first and then use the handle functions to configure the Network class.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_NETWORK_CLASS


PrlNetworkClass_GetClassId Function

PrlNetworkClass_GetClassId Function
PHT_NETWORK_CLASS

Returns the network class id.

Syntax
PRL_RESULT PrlNetworkClass_GetClassId(
    PRL_HANDLE hNetworkClass,
    PRL_UINT32_PTR pnClassId
);
File

PrlApiNet.h

Parameters

hNetworkClass
A handle of type PHT_NETWORK_CLASS identifying the network class entry.
pnClassId
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_CLASS


PrlNetworkClass_GetNetworkList Function

PrlNetworkClass_GetNetworkList Function
PHT_NETWORK_CLASS

Returns the list of networks for specified network class entry.

Syntax
PRL_RESULT PrlNetworkClass_GetNetworkList(
    PRL_HANDLE hNetworkClass,
    PRL_HANDLE_PTR phNetworkList
);
File

PrlApiNet.h

Parameters

hNetworkClass
A handle of type PHT_NETWORK_CLASS identifying the network class entry.
phNetworkList
[out] A pointer to a handle of type PHT_STRINGS_LIST that receives the list of networks

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_CLASS


PrlNetworkClass_SetClassId Function

PrlNetworkClass_SetClassId Function
PHT_NETWORK_CLASS

Sets the network class id.

Syntax
PRL_RESULT PrlNetworkClass_SetClassId(
    PRL_HANDLE hNetworkClass,
    PRL_UINT32 nClassId
);
File

PrlApiNet.h

Parameters

hNetworkClass
A handle of type PHT_NETWORK_CLASS identifying the network class entry.
nClassId
Class id

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_CLASS


PrlNetworkClass_SetNetworkList Function

PrlNetworkClass_SetNetworkList Function
PHT_NETWORK_CLASS

Sets the list of networks for specified network class entry.

Syntax
PRL_RESULT PrlNetworkClass_SetNetworkList(
    PRL_HANDLE hNetworkClass,
    PRL_HANDLE hNetworkList
);
File

PrlApiNet.h

Parameters

hNetworkClass
A handle of type PHT_NETWORK_CLASS identifying the network class entry.
hNetworkList
A handle of type PHT_STRINGS_LIST

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_CLASS


PrlNetworkRate_Create Function

PrlNetworkRate_Create Function
PHT_NETWORK_RATE

Creates a new handle of type PHT_NETWORK_RATE.

Syntax
PRL_RESULT PrlNetworkRate_Create(
    PRL_UINT32 nClassId,
    PRL_UINT32 nRate,
    PRL_HANDLE_PTR phNetworkRate
);
File

PrlApiNet.h

Parameters

nClassId
Network class id
nRate
Specifies bound rate for network class
phNetwork
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to configure Vm output bandwidth.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_NETWORK_RATE


PrlNetworkRate_GetClassId Function

PrlNetworkRate_GetClassId Function
PHT_NETWORK_RATE

Returns the network rate entry class id.

Syntax
PRL_RESULT PrlNetworkRate_GetClassId(
    PRL_HANDLE hNetworkRate,
    PRL_UINT32_PTR pnClassId
);
File

PrlApiNet.h

Parameters

hNetworkRate
A handle of type PHT_NETWORK_RATE identifying the network rate entry.
pnClassId
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_RATE


PrlNetworkRate_GetRate Function

PrlNetworkRate_GetRate Function
PHT_NETWORK_RATE

Returns the network rate entry Rate value.

Syntax
PRL_RESULT PrlNetworkRate_GetRate(
    PRL_HANDLE hNetworkRate,
    PRL_UINT32_PTR pnRate
);
File

PrlApiNet.h

Parameters

hNetworkRate
A handle of type PHT_NETWORK_RATE identifying the network rate entry.
pnRate
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_RATE


PrlNetworkShapingBandwidthEntry_Create Function

PrlNetworkShapingBandwidthEntry_Create Function
PHT_NETWORK_SHAPING_BANDWIDTH

Creates a new handle of type PHT_NETWORK_SHAPING_BANDWIDTH.

Syntax
PRL_RESULT PrlNetworkShapingBandwidthEntry_Create(
    PRL_CONST_STR sDev,
    PRL_UINT32 nBandwidth,
    PRL_HANDLE_PTR phDeviceEntry
);
File

PrlApiNet.h

Parameters

sDev
network device name.
nBandwidth
Network device bandwidth phDeviceEntryN:[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to configure network shaping configuration.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_NETWORK_SHAPING_BANDWIDTH


PrlNetworkShapingBandwidthEntry_GetBandwidth Function

PrlNetworkShapingBandwidthEntry_GetBandwidth Function
PHT_NETWORK_SHAPING_BANDWIDTH

Returns the network device bandwidth for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingBandwidthEntry_GetBandwidth(
    PRL_HANDLE hDeviceEntry,
    PRL_UINT32_PTR pnBandwidth
);
File

PrlApiNet.h

Parameters

hDeviceEntry
A handle of type PHT_NETWORK_SHAPING_BANDWIDTH identifying the network shaping entry.
pnBandwidth
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_BANDWIDTH


PrlNetworkShapingBandwidthEntry_GetDevice Function

PrlNetworkShapingBandwidthEntry_GetDevice Function
PHT_NETWORK_SHAPING_BANDWIDTH

Returns the network device name for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingBandwidthEntry_GetDevice(
    PRL_HANDLE hDeviceEntry,
    PRL_STR sDev,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiNet.h

Parameters

hDeviceEntry
A handle of type PHT_NETWORK_SHAPING_BANDWIDTH identifying the network shaping entry.
sDev
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_BANDWIDTH


PrlNetworkShapingBandwidthEntry_SetBandwidth Function

PrlNetworkShapingBandwidthEntry_SetBandwidth Function
PHT_NETWORK_SHAPING_BANDWIDTH

Sets the network device bandwidth for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingBandwidthEntry_SetBandwidth(
    PRL_HANDLE hDeviceEntry,
    PRL_UINT32 nBandwidth
);
File

PrlApiNet.h

Parameters

hDeviceEntry
A handle of type PHT_NETWORK_SHAPING_BANDWIDTH identifying the network shaping entry.
nBandwidth
Network device bandwidth

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_BANDWIDTH


PrlNetworkShapingBandwidthEntry_SetDevice Function

PrlNetworkShapingBandwidthEntry_SetDevice Function
PHT_NETWORK_SHAPING_BANDWIDTH

Sets the network device name for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingBandwidthEntry_SetDevice(
    PRL_HANDLE hDeviceEntry,
    PRL_CONST_STR sDev
);
File

PrlApiNet.h

Parameters

hDeviceEntry
A handle of type PHT_NETWORK_SHAPING_BANDWIDTH identifying the network shaping entry.
sDev
network device name

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_BANDWIDTH


PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList Function

PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList Function
PHT_NETWORK_SHAPING_CONFIG

Obtains a list of network shaping bandwidth entries represents the network shaping configuration.

Syntax
PRL_RESULT PrlNetworkShapingConfig_GetNetworkDeviceBandwidthList(
    PRL_HANDLE hConfig,
    PRL_HANDLE_PTR phList
);
File

PrlApiNet.h

Parameters

hConfig
A valid handle of type PHT_NETWORK_SHAPING_CONFIG identifying the adapter.
hList
A pointer to a handle of type PHT_HANDLE_LIST which contains the list of handles of type PHT_NETWORK_SHAPING

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingConfig_GetNetworkShapingList Function

PrlNetworkShapingConfig_GetNetworkShapingList Function
PHT_NETWORK_SHAPING_CONFIG

Obtains a list of network shaping entries represents the network shaping configuration.

Syntax
PRL_RESULT PrlNetworkShapingConfig_GetNetworkShapingList(
    PRL_HANDLE hConfig,
    PRL_HANDLE_PTR phList
);
File

PrlApiNet.h

Parameters

hConfig
A valid handle of type PHT_NETWORK_SHAPING_CONFIG identifying the adapter.
hList
A pointer to a handle of type PHT_HANDLE_LIST which contains the list of handles of type PHT_NETWORK_SHAPING

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingConfig_IsEnabled Function

PrlNetworkShapingConfig_IsEnabled Function
PHT_NETWORK_SHAPING_CONFIG

Determines whether the network shaping is enabled or disabled.

Syntax
PRL_RESULT PrlNetworkShapingConfig_IsEnabled(
    PRL_HANDLE hConfig,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hConfig
A valid handle of type PHT_NETWORK_SHAPING_CONFIG identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the network shaping is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingConfig_SetEnabled Function

PrlNetworkShapingConfig_SetEnabled Function
PHT_NETWORK_SHAPING_CONFIG

Allows to enable or disable the network shaping.

Syntax
PRL_RESULT PrlNetworkShapingConfig_SetEnabled(
    PRL_HANDLE hConfig,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hConfig
A handle of type PHT_NETWORK_SHAPING_CONFIG.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the network shaping. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList Function

PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList Function
PHT_NETWORK_SHAPING_CONFIG

Update the list of network device bandwidth represents the network shaping configuration.

Syntax
PRL_RESULT PrlNetworkShapingConfig_SetNetworkDeviceBandwidthList(
    PRL_HANDLE hConfig,
    PRL_HANDLE hList
);
File

PrlApiNet.h

Parameters

hConfig
A valid handle of type PHT_NETWORK_SHAPING_CONFIG identifying the adapter.
hList
A handle of type PHT_HANDLE_LIST contains the list of handles of type PHT_NETWORK_SHAPING

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingConfig_SetNetworkShapingList Function

PrlNetworkShapingConfig_SetNetworkShapingList Function
PHT_NETWORK_SHAPING_CONFIG

Update the list of network shaping entries represents the network shaping configuration.

Syntax
PRL_RESULT PrlNetworkShapingConfig_SetNetworkShapingList(
    PRL_HANDLE hConfig,
    PRL_HANDLE hList
);
File

PrlApiNet.h

Parameters

hConfig
A valid handle of type PHT_NETWORK_SHAPING_CONFIG identifying the adapter.
hList
A handle of type PHT_HANDLE_LIST contains the list of handles of type PHT_NETWORK_SHAPING

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING_CONFIG


PrlNetworkShapingEntry_Create Function

PrlNetworkShapingEntry_Create Function
PHT_NETWORK_SHAPING

Creates a new handle of type PHT_NETWORK_SHAPING.

Syntax
PRL_RESULT PrlNetworkShapingEntry_Create(
    PRL_UINT32 nClassId,
    PRL_UINT32 nTotalRate,
    PRL_HANDLE_PTR phNetworkShapingEntry
);
File

PrlApiNet.h

Parameters

nClassId
Network class id
nTotalRate
Specifies bound rate for network class phNetworkShapingEntry:[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to configure network shaping configuration.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_GetClassId Function

PrlNetworkShapingEntry_GetClassId Function
PHT_NETWORK_SHAPING

Returns the network class id.

Syntax
PRL_RESULT PrlNetworkShapingEntry_GetClassId(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32_PTR pnClassId
);
File

PrlApiNet.h

Parameters

pnClassId
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_GetDevice Function

PrlNetworkShapingEntry_GetDevice Function
PHT_NETWORK_SHAPING

Returns the network device for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingEntry_GetDevice(
    PRL_HANDLE hNetworkShapingEntry,
    PRL_STR sDev,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiNet.h

Parameters

sDev
[out] A pointer to a buffer that receives the result.
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_GetRate Function

PrlNetworkShapingEntry_GetRate Function
PHT_NETWORK_SHAPING

Returns the default rate for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingEntry_GetRate(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32_PTR pnRate
);
File

PrlApiNet.h

Parameters

pnRate
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_GetTotalRate Function

PrlNetworkShapingEntry_GetTotalRate Function
PHT_NETWORK_SHAPING

Returns the total rate for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingEntry_GetTotalRate(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32_PTR pnTotalRate
);
File

PrlApiNet.h

Parameters

pnTotalRate
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_SetClassId Function

PrlNetworkShapingEntry_SetClassId Function
PHT_NETWORK_SHAPING

Sets the network class id for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingEntry_SetClassId(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32 nClassId
);
File

PrlApiNet.h

Parameters

nClassId
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_SetDevice Function

PrlNetworkShapingEntry_SetDevice Function
PHT_NETWORK_SHAPING

Sets the specified network device.

Syntax
PRL_RESULT PrlNetworkShapingEntry_SetDevice(
    PRL_HANDLE hNetworkShapingEntry,
    PRL_CONST_STR sDev
);
File

PrlApiNet.h

Parameters

hNetworkShapingEntry
A handle of type PHT_NETWORK_SHAPING identifying the shaping entry.
sDev
The network device.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_SetRate Function

PrlNetworkShapingEntry_SetRate Function
PHT_NETWORK_SHAPING

Sets the default network guaranteed rate.

Syntax
PRL_RESULT PrlNetworkShapingEntry_SetRate(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32 nRate
);
File

PrlApiNet.h

Parameters

hNetworkShapingEntry
A handle of type PHT_NERWORK_SHAPING identifying the shaping entry.
sRate
The network rate in Kbits.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlNetworkShapingEntry_SetTotalRate Function

PrlNetworkShapingEntry_SetTotalRate Function
PHT_NETWORK_SHAPING

Sets the total rate for specified shaping entry.

Syntax
PRL_RESULT PrlNetworkShapingEntry_SetTotalRate(
    PRL_HANDLE pNetworkShapingEntry,
    PRL_UINT32 nTotalRate
);
File

PrlApiNet.h

Parameters

nTotalRate
The network total rate in Kbits.
hNetworkShapingEntry
A handle of type PHT_NETWORK_SHAPING identifying the shaping entry.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_NETWORK_SHAPING


PrlOffmgmtService_Create Function

PrlOffmgmtService_Create Function
PHT_OFFLINE_SERVICE

Creates a new handle of type PHT_OFFLINE_SRVICE.

Syntax
PRL_RESULT PrlOffmgmtService_Create(
    PRL_HANDLE_PTR phOffmgmtService
);
File

PrlApiNet.h

Parameters

phOffmgmtService
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to configure offline services. If you would like to manage offline service configuration, use this function to create the handle first and then use the handle functions to configure the offline services.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_GetName Function

PrlOffmgmtService_GetName Function
PHT_OFFLINE_SERVICE

Returns the name of the specified offline service.

Syntax
PRL_RESULT PrlOffmgmtService_GetName(
    PRL_HANDLE hOffmgmtService,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
sname
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_GetPort Function

PrlOffmgmtService_GetPort Function
PHT_OFFLINE_SERVICE

Returns the port of the specified offline service.

Syntax
PRL_RESULT PrlOffmgmtService_GetPort(
    PRL_HANDLE hOffmgmtService,
    PRL_UINT32_PTR pnPort
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
sname
[out] A pointer to a buffer that receives the result

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_IsUsedByDefault Function

PrlOffmgmtService_IsUsedByDefault Function
PHT_OFFLINE_SERVICE

Returns the type of the flag of the specified offline service used by default.

Syntax
PRL_RESULT PrlOffmgmtService_IsUsedByDefault(
    PRL_HANDLE hOffmgmtService,
    PRL_BOOL_PTR pbDefault
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
sname
[out] A pointer to a buffer that receives the result

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_SetName Function

PrlOffmgmtService_SetName Function
PHT_OFFLINE_SERVICE

Sets the specified offline service name.

Syntax
PRL_RESULT PrlOffmgmtService_SetName(
    PRL_HANDLE hOffmgmtService,
    PRL_CONST_STR sName
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
sName
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_SetPort Function

PrlOffmgmtService_SetPort Function
PHT_OFFLINE_SERVICE

Sets the specified offline service port.

Syntax
PRL_RESULT PrlOffmgmtService_SetPort(
    PRL_HANDLE hOffmgmtService,
    PRL_UINT32 nPort
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
nPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOffmgmtService_SetUsedByDefault Function

PrlOffmgmtService_SetUsedByDefault Function
PHT_OFFLINE_SERVICE

Sets the default flag type for the specified offline service.

Syntax
PRL_RESULT PrlOffmgmtService_SetUsedByDefault(
    PRL_HANDLE hOffmgmtService,
    PRL_BOOL bDefault
);
File

PrlApiNet.h

Parameters

hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying the offline service.
bDefault
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OFFLINE_SERVICE


PrlOpTypeList_AddItem Function

PrlOpTypeList_AddItem Function
PHT_OPAQUE_TYPE_LIST

Adds a new item to the container.

Syntax
PRL_RESULT PrlOpTypeList_AddItem(
    PRL_HANDLE hOpTypeList,
    PRL_CONST_VOID_PTR pnItem
);
File

PrlApiCore.h

Parameters

hOpTypeList
A handle of type PHT_OPAQUE_TYPE_LIST identifying the opaque type container.
pnItem
A pointer to the item to add to the container. Note that value passing through pointer in order to prevent loosing of precision (for 64 bit types for example).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to value variable was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OPAQUE_TYPE_LIST


PrlOpTypeList_GetItem Function

PrlOpTypeList_GetItem Function
PHT_OPAQUE_TYPE_LIST

Extracts the specified item from the container.

Syntax
PRL_RESULT PrlOpTypeList_GetItem(
    PRL_HANDLE hOpTypeList,
    PRL_UINT32 nItemIndex,
    PRL_VOID_PTR pnItem
);
File

PrlApiCore.h

Parameters

hOpTypeList
A handle of type PHT_OPAQUE_TYPE_LIST identifying the opaque type container.
nItemIndex
A numeric index identifying the item (beginning with 0). To determine the number of items in the container, use the PrlOpTypeList_GetItemsCount function.
pnItem
[in] The pointer to the buffer to extract item value.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer or out of range index was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OPAQUE_TYPE_LIST


PrlOpTypeList_GetItemsCount Function

PrlOpTypeList_GetItemsCount Function
PHT_OPAQUE_TYPE_LIST

Determines the number of items in the container.

Syntax
PRL_RESULT PrlOpTypeList_GetItemsCount(
    PRL_HANDLE hOpTypeList,
    PRL_UINT32_PTR pnItemsCount
);
File

PrlApiCore.h

Parameters

hOpTypeList
A handle of type PHT_OPAQUE_TYPE_LIST identifying the opaque type container.
pnItemsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OPAQUE_TYPE_LIST


PrlOpTypeList_GetTypeSize Function

PrlOpTypeList_GetTypeSize Function
PHT_OPAQUE_TYPE_LIST

Extracts the size of type of items storing in container.

Syntax
PRL_RESULT PrlOpTypeList_GetTypeSize(
    PRL_HANDLE hOpTypeList,
    PRL_SIZE_PTR pnTypeSize
);
File

PrlApiCore.h

Parameters

hOpTypeList
A handle of type PHT_OPAQUE_TYPE_LIST identifying the opaque type container.
pnTypeSize
[out] The pointer to the buffer to extract type size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OPAQUE_TYPE_LIST


PrlOpTypeList_RemoveItem Function

PrlOpTypeList_RemoveItem Function
PHT_OPAQUE_TYPE_LIST

Removes the specified item from the container.

Syntax
PRL_RESULT PrlOpTypeList_RemoveItem(
    PRL_HANDLE hOpTypeList,
    PRL_UINT32 nItemIndex
);
File

PrlApiCore.h

Parameters

hOpTypeList
A handle of type PHT_OPAQUE_TYPE_LIST identifying the opaque type container.
nItemIndex
A numeric index identifying the item. Index is a sequential number assigned to every item in the container. To determine the index of an item, call the PrlOpTypeList_GetItem in a loop (from 0 to PrlOpTypeList_GetItemsCount()). The iteration number is the index of the corresponding item.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or out of range index was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_OPAQUE_TYPE_LIST


PrlOsesMatrix_GetDefaultOsVersion Function

PrlOsesMatrix_GetDefaultOsVersion Function
PHT_GUEST_OSES_MATRIX

Returns default guest OS version for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).

Syntax
PRL_RESULT PrlOsesMatrix_GetDefaultOsVersion(
    PRL_HANDLE hOsesMatrix,
    PRL_UINT8 nGuestOsType,
    PRL_UINT16_PTR pnOsVersion
);
File

PrlApiVm.h

Parameters

hOsesMatrix
[in] handle of type PHT_GUEST_OSES_MATRIX.
nGuestOsType
[in] requesting guest OS type. In order to determine list of supported guests types please refer PrlOses.h
pnOsVersion
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid jandle, null pointer or unknown OS type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_GUEST_OSES_MATRIX


PrlOsesMatrix_GetSupportedOsesTypes Function

PrlOsesMatrix_GetSupportedOsesTypes Function
PHT_GUEST_OSES_MATRIX

Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes types list retrieved from remote server (see PrlSrv_GetSupportedOses).

Syntax
PRL_RESULT PrlOsesMatrix_GetSupportedOsesTypes(
    PRL_HANDLE hOsesMatrix,
    PRL_HANDLE_PTR phOsesTypesList
);
File

PrlApiVm.h

Parameters

hOsesMatrix
[in] handle of type PHT_GUEST_OSES_MATRIX.
phOsesTypesList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or invalid handle was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_GUEST_OSES_MATRIX


PrlOsesMatrix_GetSupportedOsesVersions Function

PrlOsesMatrix_GetSupportedOsesVersions Function
PHT_GUEST_OSES_MATRIX

Returns handle of type PHT_OPAQUE_TYPE_LIST which contains supported guest OSes list for specified guest OS type retrieved from remote server (see PrlSrv_GetSupportedOses).

Syntax
PRL_RESULT PrlOsesMatrix_GetSupportedOsesVersions(
    PRL_HANDLE hOsesMatrix,
    PRL_UINT8 nGuestOsType,
    PRL_HANDLE_PTR phGuestsList
);
File

PrlApiVm.h

Parameters

hOsesMatrix
[in] handle of type PHT_GUEST_OSES_MATRIX.
nGuestOsType
[in] requesting guest OS type. In order to determine list of supported guests types please refer PrlOses.h
phOsesTypesList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle, null pointer or unknown OS type was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_GUEST_OSES_MATRIX


PrlPluginInfo_GetCopyright Function

PrlPluginInfo_GetCopyright Function
PHT_PLUGIN_INFO

Returns copyright of the plugin.

Syntax
PRL_RESULT PrlPluginInfo_GetCopyright(
    PRL_HANDLE hPluginInfo,
    PRL_STR sCopyright,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sCopyright
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPluginInfo_GetId Function

PrlPluginInfo_GetId Function
PHT_PLUGIN_INFO

Returns identificator of the plugin in GUID format.

Syntax
PRL_RESULT PrlPluginInfo_GetId(
    PRL_HANDLE hPluginInfo,
    PRL_STR sId,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPluginInfo_GetLongDescription Function

PrlPluginInfo_GetLongDescription Function
PHT_PLUGIN_INFO

Returns long description about the plugin.

Syntax
PRL_RESULT PrlPluginInfo_GetLongDescription(
    PRL_HANDLE hPluginInfo,
    PRL_STR sDescr,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sDescr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPluginInfo_GetShortDescription Function

PrlPluginInfo_GetShortDescription Function
PHT_PLUGIN_INFO

Returns short description about the plugin.

Syntax
PRL_RESULT PrlPluginInfo_GetShortDescription(
    PRL_HANDLE hPluginInfo,
    PRL_STR sDescr,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sDescr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPluginInfo_GetVendor Function

PrlPluginInfo_GetVendor Function
PHT_PLUGIN_INFO

Returns the vendor of the plugin.

Syntax
PRL_RESULT PrlPluginInfo_GetVendor(
    PRL_HANDLE hPluginInfo,
    PRL_STR sVendor,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sVendor
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPluginInfo_GetVersion Function

PrlPluginInfo_GetVersion Function
PHT_PLUGIN_INFO

Returns the version of the plugin.

Syntax
PRL_RESULT PrlPluginInfo_GetVersion(
    PRL_HANDLE hPluginInfo,
    PRL_STR sVersion,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiDisp.h

Parameters

hPluginInfo
A handle of type PHT_PLUGIN_INFO identifying the plugin info.
sVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). Format version is "Major.Minor.Build".
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no information about this field.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PLUGIN_INFO


PrlPortFwd_Create Function

PrlPortFwd_Create Function
PHT_PORT_FORWARDING

Creates a new handle of type PHT_PORT_FORWARDING.

Syntax
PRL_RESULT PrlPortFwd_Create(
    PRL_HANDLE_PTR phPortFwd
);
File

PrlApiNet.h

Parameters

phPortFwd
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the user to free the handle when it is no longer needed.

Links
PHT_PORT_FORWARDING


PrlPortFwd_GetIncomingPort Function

PrlPortFwd_GetIncomingPort Function
PHT_PORT_FORWARDING

Returns the incoming port.

Syntax
PRL_RESULT PrlPortFwd_GetIncomingPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16_PTR pnIncomingPort
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
pnIncomingPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_GetRedirectIPAddress Function

PrlPortFwd_GetRedirectIPAddress Function
PHT_PORT_FORWARDING

Returns the redirect IP address of the specified port forward entry.

Syntax
PRL_RESULT PrlPortFwd_GetRedirectIPAddress(
    PRL_HANDLE hPortFwd,
    PRL_STR sRedirectIPAddress,
    PRL_UINT32_PTR pnRedirectIPAddressBufLength
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnRedirectIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_GetRedirectPort Function

PrlPortFwd_GetRedirectPort Function
PHT_PORT_FORWARDING

Returns the redirect port.

Syntax
PRL_RESULT PrlPortFwd_GetRedirectPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16_PTR pnRedirectPort
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
pnRedirectPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_GetRedirectVm Function

PrlPortFwd_GetRedirectVm Function
PHT_PORT_FORWARDING

Returns the redirect virtual machine identifier of the specified port forward entry.

Syntax
PRL_RESULT PrlPortFwd_GetRedirectVm(
    PRL_HANDLE hPortFwd,
    PRL_STR sRedirectVm,
    PRL_UINT32_PTR pnRedirectVmBufLength
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectVm
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnRedirectVmBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_GetRuleName Function

PrlPortFwd_GetRuleName Function
PHT_PORT_FORWARDING

Returns the rule name of the specified port forward entry.

Syntax
PRL_RESULT PrlPortFwd_GetRuleName(
    PRL_HANDLE hPortFwd,
    PRL_STR sRuleName,
    PRL_UINT32_PTR pnRuleNameBufLength
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRuleName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnRuleNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_SetIncomingPort Function

PrlPortFwd_SetIncomingPort Function
PHT_PORT_FORWARDING

Sets the specified incoming port.

Syntax
PRL_RESULT PrlPortFwd_SetIncomingPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16 nIncomingPort
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
nIncomingPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_SetRedirectIPAddress Function

PrlPortFwd_SetRedirectIPAddress Function
PHT_PORT_FORWARDING

Sets the specified port forwardi entry redirect IP address.

Syntax
PRL_RESULT PrlPortFwd_SetRedirectIPAddress(
    PRL_HANDLE hPortFwd,
    PRL_CONST_STR sRedirectIPAddress
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_SetRedirectPort Function

PrlPortFwd_SetRedirectPort Function
PHT_PORT_FORWARDING

Sets the specified redirect port.

Syntax
PRL_RESULT PrlPortFwd_SetRedirectPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16 nRedirectPort
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
nRedirectPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_SetRedirectVm Function

PrlPortFwd_SetRedirectVm Function
PHT_PORT_FORWARDING

Sets the specified port forward entry virtual machine identifier.

Syntax
PRL_RESULT PrlPortFwd_SetRedirectVm(
    PRL_HANDLE hPortFwd,
    PRL_CONST_STR sRedirectVm
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectVm
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlPortFwd_SetRuleName Function

PrlPortFwd_SetRuleName Function
PHT_PORT_FORWARDING

Sets the specified port forward entry rule name.

Syntax
PRL_RESULT PrlPortFwd_SetRuleName(
    PRL_HANDLE hPortFwd,
    PRL_CONST_STR sRuleName
);
File

PrlApiNet.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRuleName
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PORT_FORWARDING


PrlReport_Assembly Function

PrlReport_Assembly Function
PHT_PROBLEM_REPORT

Assembles the problem report.

Syntax
PRL_HANDLE PrlReport_Assembly(
    PRL_HANDLE hProblemReport,
    PRL_UINT32 nFlags
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the container.
nFlags
[in] flags bitset (accepts values just from PRL_PROBLEM_REPORT_FLAGS)

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Links
PHT_PROBLEM_REPORT


PrlReport_AsString Function

PrlReport_AsString Function
PHT_PROBLEM_REPORT

Returns XML based string representation of problem report.

Syntax
PRL_RESULT PrlReport_AsString(
    PRL_HANDLE hProblemReport,
    PRL_STR sBuffer,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sBuffer
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetArchiveFileName Function

PrlReport_GetArchiveFileName Function
PHT_PROBLEM_REPORT

Returns problem report archive file name which can be used for further problem report data saving and processing.

Syntax
PRL_RESULT PrlReport_GetArchiveFileName(
    PRL_HANDLE hProblemReport,
    PRL_STR sArchiveFileName,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sArchiveFileName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or old XML based scheme problem report object handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that this data makes sense just for packed problem report scheme.

Links
PHT_PROBLEM_REPORT


PrlReport_GetCombinedReportId Function

PrlReport_GetCombinedReportId Function
PHT_PROBLEM_REPORT See Also

Gets problem report's CombineReportId which is used to match several reports on a server side.

Syntax
PRL_RESULT PrlReport_GetCombinedReportId(
    PRL_HANDLE hProblemReport,
    PRL_STR sCombinedReportId,
    PRL_UINT32_PTR pnCombinedReportIdLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
pnCombinedReportIdLength
[in out] pointer to a size of CombinedReportId string
sReportType
[out] CombineReport id string pointer

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlReport_SetCombinedReportId

Links
PHT_PROBLEM_REPORT, See Also


PrlReport_GetData Function

PrlReport_GetData Function
PHT_PROBLEM_REPORT

Returns the binary representation of problem report.

Syntax
PRL_RESULT PrlReport_GetData(
    PRL_HANDLE hProblemReport,
    PRL_VOID_PTR pBuffer,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the container.
pBuffer
[out] A pointer to a buffer that receives the result.
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetDescription Function

PrlReport_GetDescription Function
PHT_PROBLEM_REPORT

Obtains the problem report description.

Syntax
PRL_RESULT PrlReport_GetDescription(
    PRL_HANDLE hProblemReport,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetRating Function

PrlReport_GetRating Function
PHT_PROBLEM_REPORT See Also

Gets rating of product using.

Syntax
PRL_RESULT PrlReport_GetRating(
    PRL_HANDLE hProblemReport,
    PRL_UINT32_PTR pnRating
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
pnRating
[out] pointer to a rating variable.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlReport_SetRating

Links
PHT_PROBLEM_REPORT, See Also


PrlReport_GetReason Function

PrlReport_GetReason Function
PHT_PROBLEM_REPORT

Obtains the value of the property, identifying the reason for this project report.

Syntax
PRL_RESULT PrlReport_GetReason(
    PRL_HANDLE hProblemReport,
    PRL_PROBLEM_REPORT_REASON_PTR pnReportReason
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
pnReportReason
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetScheme Function

PrlReport_GetScheme Function
PHT_PROBLEM_REPORT

Determines the scheme used by the problem report object.

Syntax
PRL_RESULT PrlReport_GetScheme(
    PRL_HANDLE hProblemReport,
    PRL_PROBLEM_REPORT_SCHEME_PTR pnReportScheme
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] a handle of type PHT_PROBLEM_REPORT.
pnReportScehme
[out] a pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetType Function

PrlReport_GetType Function
PHT_PROBLEM_REPORT

Determines the type of the problem report object.

Syntax
PRL_RESULT PrlReport_GetType(
    PRL_HANDLE hProblemReport,
    PRL_PROBLEM_REPORT_TYPE_PTR pnReportType
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
pnReportType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer or wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetUserEmail Function

PrlReport_GetUserEmail Function
PHT_PROBLEM_REPORT

Obtains the e-mail address of the user on the problem report.

Syntax
PRL_RESULT PrlReport_GetUserEmail(
    PRL_HANDLE hProblemReport,
    PRL_STR sUserEmail,
    PRL_UINT32_PTR pnUserEmailBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sUserEmail
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUserEmailBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_GetUserName Function

PrlReport_GetUserName Function
PHT_PROBLEM_REPORT

Obtains the name of the user on the problem report.

Syntax
PRL_RESULT PrlReport_GetUserName(
    PRL_HANDLE hProblemReport,
    PRL_STR sUserName,
    PRL_UINT32_PTR pnUserNameBufLength
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sUserName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUserNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_Send Function

PrlReport_Send Function
PHT_PROBLEM_REPORT

The PrlReport_Send function is provided for convenience.

Syntax
PRL_HANDLE PrlReport_Send(
    PRL_HANDLE hProblemReport,
    PRL_BOOL bUseProxy,
    PRL_CONST_STR sProxyHost,
    PRL_UINT32 nProxyPort,
    PRL_CONST_STR sProxyUserLogin,
    PRL_CONST_STR sProxyUserPasswd,
    PRL_UINT32 nProblemSendTimeout,
    PRL_UINT32 nReserved,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR pUserData
);
File

PrlApiCore.h

Parameters

hProblemReport
A handle of type PHT_PROBLEM_REPORT containing report data.

bUseProxy
Specifies whether proxy should be used. The call can obtain and use the system proxy settings or you can specify your own settings. Note that custom values override system settings.

sProxyHost
[optional] If using proxy, this parameter allows to specify the proxy server host address/name (can be null or empty).

nProxyPort
[optional] If using proxy, this parameter allows to specify the proxy server port (to use the system setting, set this parameter to 0).

sProxyUserLogin
[optional] If using proxy, this parameter allows to specify user login if itâ€™s not set in the system settings (can be null or empty).

sProxyUserPasswd
[optional] If using proxy, this parameter allows to specify the user password if itâ€™s not specified in the system settings.

nProblemSendTimeout
Timeout in milliseconds. Can be set to 0 for unlimited timeout.

nReserved
[unused] Reserved parameter for future use.

handler
[optional] A pointer to a user callback function (event handler) that will be called every time a problem report sending progress is updated or when the job is completed.

pUserData
[optional] A pointer to a user data that will be passed to the optional callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It allows submitting a previously generated problem report to the Parallels support server. The report could be generated using the PrlSrv_GetPackedProblemReport (PrlSrv_GetProblemReport) or PrlVm_GetProblemReport (PrlVm_GetPackedProblemReport) functions, or created and assembled using PrlApi_CreateProblemReport/PrlReport_Assembly functions.

Links
PHT_PROBLEM_REPORT


PrlReport_SetCombinedReportId Function

PrlReport_SetCombinedReportId Function
PHT_PROBLEM_REPORT

Sets problem report's CombineReportId which is used to match two reports on a server side.

Syntax
PRL_RESULT PrlReport_SetCombinedReportId(
    PRL_HANDLE hProblemReport,
    PRL_CONST_STR sCombinedReportId
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
sReportType
[in] CombineReport id string

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetDescription Function

PrlReport_SetDescription Function
PHT_PROBLEM_REPORT

Sets the specified problem report description.

Syntax
PRL_RESULT PrlReport_SetDescription(
    PRL_HANDLE hProblemReport,
    PRL_CONST_STR sNewDescription
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sNewDescription
[in] The value to set - must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetRating Function

PrlReport_SetRating Function
PHT_PROBLEM_REPORT

Sets rating of product using.

Syntax
PRL_RESULT PrlReport_SetRating(
    PRL_HANDLE hProblemReport,
    PRL_UINT32 nRating
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
nRating
[in] Rating value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetReason Function

PrlReport_SetReason Function
PHT_PROBLEM_REPORT

Sets the value of the object property, identifying the reason for this problem report.

Syntax
PRL_RESULT PrlReport_SetReason(
    PRL_HANDLE hProblemReport,
    PRL_PROBLEM_REPORT_REASON nReportReason
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
nReportReason
[in] The problem report reason value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetType Function

PrlReport_SetType Function
PHT_PROBLEM_REPORT

Sets the problem report object type.

Syntax
PRL_RESULT PrlReport_SetType(
    PRL_HANDLE hProblemReport,
    PRL_PROBLEM_REPORT_TYPE nReportType
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT.
nReportType
[in] The problem report object type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - wrong handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetUserEmail Function

PrlReport_SetUserEmail Function
PHT_PROBLEM_REPORT

Sets the e-mail address of the user on the problem report.

Syntax
PRL_RESULT PrlReport_SetUserEmail(
    PRL_HANDLE hProblemReport,
    PRL_CONST_STR sNewUserEmail
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sNewUserEmail
[in] The value to set - must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlReport_SetUserName Function

PrlReport_SetUserName Function
PHT_PROBLEM_REPORT

Sets the name of the user on the problem report.

Syntax
PRL_RESULT PrlReport_SetUserName(
    PRL_HANDLE hProblemReport,
    PRL_CONST_STR sNewUserName
);
File

PrlApiCore.h

Parameters

hProblemReport
[in] A handle of type PHT_PROBLEM_REPORT identifying the problem report object.
sNewUserName
[in] The value to set - must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_PROBLEM_REPORT


PrlResult_GetParam Function

PrlResult_GetParam Function
PHT_RESULT Example

Obtains a handle to an object containing the results of the corresponding asynchronous operation.

Syntax
PRL_RESULT PrlResult_GetParam(
    PRL_HANDLE hResult,
    PRL_HANDLE_PTR pHandle
);
File

PrlApiCore.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
pHandle
[out] A pointer to a variable that receives the handle. The type of handle returned depends on the corresponding operation. The description of each asynchronous function in this documentation provides information about the type of handle that the function returns.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no result or the result is not a single handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you know that the corresponding function always produces a single object as a result. This function is the equivalent of the PrlResult_GetParamByIndex(hResult, 0, &Handle) call (i.e. zero as the index value).

Example

The following example demonstrates using asynchronous function PrlSrv_GetSrvConfig synchronously, and the steps involved in obtaining a handle to an object of type PHT_SERVER_CONFIG (which is returned by PrlSrv_GetSrvConfig):

PRL_HANDLE hJob = PrlSrv_GetSrvConfig(hServer);

// Step 1 - emulate a synchronous call using PrlJob_Wait.

PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 2 - determine if PrlSrv_GetSrvConfig succeeded or failed
// using PrlJob_GetRetCode.

PrlJob_GetRetCode(hJob, &nJobResult);
if (PRL_FAILED(nJobResult))
{
    printf("PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 3 - Obtain a handle to the result object (a handle
// of type PHT_RESULT) using PrlJob_GetResult.

PRL_HANDLE hResult;
ret = PrlJob_GetResult(hJob, &hResult);
PrlHandle_Free(hJob); // hJob no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlJob_GetResult for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hResult);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 4 - Get a handle to the final result (in this case,
// a handle of type PHT_SERVER_CONFIG) using PrlResult_GetParam.
// For PHT_RESULT handles that contain more than one result, first use
// PrlResult_GetParamsCount, then use PrlResult_GetParamByIndex.

PRL_HANDLE hServerConfig;
ret = PrlResult_GetParam(hResult, &hServerConfig);
PrlHandle_Free(hResult); // hResult no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlResult_GetParam for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hServerConfig);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();

    return -1;
}

// At this point, a handle of type PHT_SERVER_CONFIG is available, and
// functions that operate on PHT_SERVER_CONFIG handles can be used on
// the handle.

PRL_UINT32 nCpuCount = 0;
PrlSrvCfg_GetCpuCount(hServerConfig, &nCpuCount);
printf("Number of CPUs: %d\n", nCpuCount);

PRL_CPU_MODE CpuMode;
PrlSrvCfg_GetCpuMode(hServerConfig, &CpuMode);
printf("CPU Mode: %d bit\n", CpuMode == PCM_CPU_MODE_32 ? 32 : 64);

PRL_CHAR szCpuModel[1024];
PRL_UINT32 nCpuModelSize = sizeof(szCpuModel);
memset(szCpuModel, 0, nCpuModelSize);
PrlSrvCfg_GetCpuModel(hServerConfig, szCpuModel, &nCpuModelSize);
printf("CPU Model: %s\n", szCpuModel);

PRL_UINT32 nCpuSpeed = 0;
PrlSrvCfg_GetCpuSpeed(hServerConfig, &nCpuSpeed);
printf("CPU Speed: %.3f MHz\n", nCpuSpeed / 1000.0);

PRL_CHAR szHostOsString[1024];
PRL_UINT32 nHostOsStringSize = sizeof(szHostOsString);
PrlSrvCfg_GetHostOsStrPresentation(hServerConfig, szHostOsString, &nHostOsStringSize);
printf("Host OS: %s\n", szHostOsString);

PrlHandle_Free(hServerConfig);
Links
PHT_RESULT, Example


PrlResult_GetParamAsString Function

PrlResult_GetParamAsString Function
PHT_RESULT

Obtains a string result from the result object.

Syntax
PRL_RESULT PrlResult_GetParamAsString(
    PRL_HANDLE hResult,
    PRL_STR sParamBuf,
    PRL_UINT32_PTR pnParamBufSize
);
File

PrlApiCore.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
sParamBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you know that the corresponding function always produces a single string as a result. This function is the equivalent of the PrlResult_GetParamByIndexAsString(hResult, 0, &myString) call (i.e. zero as the index value).

Links
PHT_RESULT


PrlResult_GetParamByIndex Function

PrlResult_GetParamByIndex Function
PHT_RESULT Example

Obtains a handle from the result object identified by the index.

Syntax
PRL_RESULT PrlResult_GetParamByIndex(
    PRL_HANDLE hResult,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phParam
);
File

PrlApiCore.h

Parameters

nIndex
An index identifying the handle in the list.
phParam
[out] A pointer to a variable that receives the handle. The type of handle returned depends on the corresponding operation. The description of each asynchronous function in this documentation provides information about the type of handle that the function returns.
handle
A handle of type PHT_RESULT identifying the result object.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when the result contains (or may contain) multiple objects. To obtain multiple handles from the result object, first, determine the number of handles contained in the object using the PrlResult_GetParamsCount function. Then, iterate through the list and use the iteration number as the value of the nIndex parameter.

Example

The following example demonstrates using asynchronous function PrlSrv_GetVmList (getting the list of virtual machines), and the steps involved in obtaining handles to objects of type PHT_VIRTUAL_MACHINE returned by PrlSrv_GetVmList (each object contains information about an individual virtual machine):

PRL_RESULT DisplayVmList(const PRL_HANDLE &hServer)
{
    PRL_HANDLE hResult;
    PRL_RESULT nJobResult;

    // Get a list of virtual machines.
    PRL_HANDLE hJob = PrlSrv_GetVmList(hServer);

    // Wait for the job to complete.
    PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Check the results of PrlSrv_GetVmList.
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Get the results of PrlSrv_GetVmList.
    ret = PrlJob_GetResult(hJob, &hResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetResult returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hResult);
        PrlHandle_Free(hJob);
        return ret;
    }

    // Handle to result object is available,
    // job handle is not longer needed, so free it.
    PrlHandle_Free(hJob);

    // Iteratre through the result list.
    PRL_UINT32 nParamsCount = 0;
    ret = PrlResult_GetParamsCount(hResult, &nParamsCount);

    for (PRL_UINT32 i = 0; i < nParamsCount; ++i)
    {
        PRL_HANDLE hVm;

        // Get a handle to result at index i.
        PrlResult_GetParamByIndex(hResult, i, &hVm);

        // Get the name of the virtual machine for result i.
        char szVmNameReturned[1024];
        PRL_UINT32 nBufSize = sizeof(szVmNameReturned);
        ret = PrlVm_GetName(hVm, szVmNameReturned, &nBufSize);

        if (PRL_FAILED(ret))
        {
            printf("PrlVm_GetName returned with error (%s)\n",
                PRL_RESULT_TO_STRING(ret));
        }
        else
        {
            printf("Virtual machine '%s' is available.\n\n", szVmNameReturned);
        }

        // Free the virtual machine handle.
        PrlHandle_Free(hVm);
    }

    return PRL_ERR_SUCCESS;
}
Links
PHT_RESULT, Example


PrlResult_GetParamByIndexAsString Function

PrlResult_GetParamByIndexAsString Function
PHT_RESULT

Obtains a string result from the result object identified by the index.

Syntax
PRL_RESULT PrlResult_GetParamByIndexAsString(
    PRL_HANDLE hResult,
    PRL_UINT32 nIndex,
    PRL_STR sParamBuf,
    PRL_UINT32_PTR pnParamBufSize
);
File

PrlApiCore.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
nIndex
An index identifying the string item in the list.
sParamBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when the result contains (or may contain) multiple string items. To obtain multiple items from the result object, first, determine the number of items contained in the object using the PrlResult_GetParamsCount function. Then, iterate through the list and use the iteration number as the value of the nIndex parameter.

Links
PHT_RESULT


PrlResult_GetParamsCount Function

PrlResult_GetParamsCount Function
PHT_RESULT

Determines the number of items in the specified result object.

Syntax
PRL_RESULT PrlResult_GetParamsCount(
    PRL_HANDLE hResult,
    PRL_UINT32_PTR pCount
);
File

PrlApiCore.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
pCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_RESULT


PrlRunningTask_GetTaskParametersAsString Function

PrlRunningTask_GetTaskParametersAsString Function
PHT_RUNNING_TASK

Returns task parameters as a string.

Syntax
PRL_RESULT PrlRunningTask_GetTaskParametersAsString(
    PRL_HANDLE hRunningTask,
    PRL_STR sParamsStr,
    PRL_UINT32_PTR pnsParamsStrBufLength
);
File

PrlApiDisp.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
sParamsStr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnsParamsStrBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Value returns in UTF-8 encoding. Null char ('0') adding to the end of string.

Links
PHT_RUNNING_TASK


PrlRunningTask_GetTaskType Function

PrlRunningTask_GetTaskType Function
PHT_RUNNING_TASK

Determines the task type.

Syntax
PRL_RESULT PrlRunningTask_GetTaskType(
    PRL_HANDLE hRunningTask,
    PRL_RUNNING_TASK_TYPE_ENUM_PTR pnType
);
File

PrlApiDisp.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
pnType
[out] A pointer to a variable that receives the task type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_RUNNING_TASK


PrlRunningTask_GetTaskUuid Function

PrlRunningTask_GetTaskUuid Function
PHT_RUNNING_TASK

Returns the task UUID (universally unique ID).

Syntax
PRL_RESULT PrlRunningTask_GetTaskUuid(
    PRL_HANDLE hRunningTask,
    PRL_STR sTaskUuid,
    PRL_UINT32_PTR pnTaskUuidBufLength
);
File

PrlApiDisp.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
sTaskUuid
[out] A pointer to a buffer that receives the task UUID (a UTF-8 encoded, null-terminated string).
pnTaskUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_RUNNING_TASK


PrlScrRes_GetHeight Function

PrlScrRes_GetHeight Function
PHT_SCREEN_RESOLUTION

Returns the height of the specified screen resolution.

Syntax
PRL_RESULT PrlScrRes_GetHeight(
    PRL_HANDLE hVmScrRes,
    PRL_UINT32_PTR pnHeight
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
pnHeight
[out] A pointer to a variable that receives the screen resolution height, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_GetWidth Function

PrlScrRes_GetWidth Function
PHT_SCREEN_RESOLUTION

Returns width of the specified screen resolution.

Syntax
PRL_RESULT PrlScrRes_GetWidth(
    PRL_HANDLE hVmScrRes,
    PRL_UINT32_PTR pnWidth
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
pnWidth
[out] A pointer to a variable that receives the screen resolution width, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_IsEnabled Function

PrlScrRes_IsEnabled Function
PHT_SCREEN_RESOLUTION

Determines whether the screen resolution is enabled or not.

Syntax
PRL_RESULT PrlScrRes_IsEnabled(
    PRL_HANDLE hVmScrRes,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the screen resolution is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_Remove Function

PrlScrRes_Remove Function
PHT_SCREEN_RESOLUTION

Removes the specified screen resolution from the virtual machine.

Syntax
PRL_RESULT PrlScrRes_Remove(
    PRL_HANDLE hVmScrRes
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_SetEnabled Function

PrlScrRes_SetEnabled Function
PHT_SCREEN_RESOLUTION

Enables or disables the specified screen resolution.

Syntax
PRL_RESULT PrlScrRes_SetEnabled(
    PRL_HANDLE hVmScrRes,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
bEnabled
Action type. Set to PRL_TRUE to enable the resolution. Set to PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_SetHeight Function

PrlScrRes_SetHeight Function
PHT_SCREEN_RESOLUTION

Modifies the specified screen resolution height.

Syntax
PRL_RESULT PrlScrRes_SetHeight(
    PRL_HANDLE hVmScrRes,
    PRL_UINT32 nHeight
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
nHeight
The screen resolution height to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlScrRes_SetWidth Function

PrlScrRes_SetWidth Function
PHT_SCREEN_RESOLUTION

Modifies the specified screen resolution width.

Syntax
PRL_RESULT PrlScrRes_SetWidth(
    PRL_HANDLE hVmScrRes,
    PRL_UINT32 nWidth
);
File

PrlApiVm.h

Parameters

hVmScrRes
A handle of type PHT_SCREEN_RESOLUTION identifying the screen resolution.
nWidth
The screen resolution width to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SCREEN_RESOLUTION


PrlSessionInfo_Create Function

PrlSessionInfo_Create Function
Functions

Creates a new handle of type PHT_SESSION_INFO.

Syntax
PRL_RESULT PrlSessionInfo_Create(
    PRL_HANDLE_PTR hSessionInfo
);
File

PrlApiDisp.h

Parameters

hSessionInfo
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Functions


PrlShare_GetDescription Function

PrlShare_GetDescription Function
PHT_SHARE See Also

Returns the shared folder description.

Syntax
PRL_RESULT PrlShare_GetDescription(
    PRL_HANDLE hVmShare,
    PRL_STR sShareDescription,
    PRL_UINT32_PTR pnShareDescriptionBufLength
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sShareDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnShareDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetDescription

Links
PHT_SHARE, See Also


PrlShare_GetName Function

PrlShare_GetName Function
PHT_SHARE See Also

Returns the shared folder name (as it appears in the guest OS).

Syntax
PRL_RESULT PrlShare_GetName(
    PRL_HANDLE hVmShare,
    PRL_STR sShareName,
    PRL_UINT32_PTR pnShareNameBufLength
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sShareName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnShareNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetName

Links
PHT_SHARE, See Also


PrlShare_GetPath Function

PrlShare_GetPath Function
PHT_SHARE See Also

Returns the shared folder path.

Syntax
PRL_RESULT PrlShare_GetPath(
    PRL_HANDLE hVmShare,
    PRL_STR sSharePath,
    PRL_UINT32_PTR pnSharePathBufLength
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sSharePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSharePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetPath

Links
PHT_SHARE, See Also


PrlShare_IsEnabled Function

PrlShare_IsEnabled Function
PHT_SHARE See Also

Determines whether the share is enabled or not.

Syntax
PRL_RESULT PrlShare_IsEnabled(
    PRL_HANDLE hVmShare,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the share is enabled. PRL_FALSE indicates that it is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetEnabled

Links
PHT_SHARE, See Also


PrlShare_IsReadOnly Function

PrlShare_IsReadOnly Function
PHT_SHARE See Also

Determines if the share is read-only.

Syntax
PRL_RESULT PrlShare_IsReadOnly(
    PRL_HANDLE hVmShare,
    PRL_BOOL_PTR pbReadOnly
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
pbReadOnly
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the share is read-only (files can be read and copied but not modified). PRL_FALSE indicates that the folder contents can be modified.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetReadOnly

Links
PHT_SHARE, See Also


PrlShare_Remove Function

PrlShare_Remove Function
PHT_SHARE

Removes the share from the virtual machine configuration.

Syntax
PRL_RESULT PrlShare_Remove(
    PRL_HANDLE hVmShare
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Once a share is removed from the virtual machine configuration, the folder cannot be accessed from the guest OS. Just like any other virtual machine configuration modification, this operation must be performed within the PrlVm_BeginEdit / PrlVm_Commit block.

Links
PHT_SHARE


PrlShare_SetDescription Function

PrlShare_SetDescription Function
PHT_SHARE See Also

Sets the shared folder description.

Syntax
PRL_RESULT PrlShare_SetDescription(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewShareDescription
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewShareDescription
A user-defined share description (must be a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetDescription

Links
PHT_SHARE, See Also


PrlShare_SetEnabled Function

PrlShare_SetEnabled Function
PHT_SHARE See Also

Enables the specified share.

Syntax
PRL_RESULT PrlShare_SetEnabled(
    PRL_HANDLE hVmShare,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
bEnabled
Specify PRL_TRUE to enable the share. Specified PRL_FALSE to disable it. If a share is disabled, it cannot be accessed from the guest OS.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_IsEnabled

Links
PHT_SHARE, See Also


PrlShare_SetName Function

PrlShare_SetName Function
PHT_SHARE See Also

Sets the share name (as it will appear in the guest OS).

Syntax
PRL_RESULT PrlShare_SetName(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewShareName
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewShareName
The user-defined share name (must be a a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetName

Links
PHT_SHARE, See Also


PrlShare_SetPath Function

PrlShare_SetPath Function
PHT_SHARE See Also

Sets the shared folder path.

Syntax
PRL_RESULT PrlShare_SetPath(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewSharePath
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewSharePath
A string containing an absolute path to the folder on the host that you would like to share with the guest OS ( must be a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetPath

Links
PHT_SHARE, See Also


PrlShare_SetReadOnly Function

PrlShare_SetReadOnly Function
PHT_SHARE See Also

Makes the specified shared folder read-only.

Syntax
PRL_RESULT PrlShare_SetReadOnly(
    PRL_HANDLE hVmShare,
    PRL_BOOL bReadOnly
);
File

PrlApiVm.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
bReadOnly
Specify PRL_TRUE to make the share read-only. Specify PRL_FALSE to make the share editable.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_IsReadOnly

Links
PHT_SHARE, See Also


PrlSrv_ActivateInstalledLicenseOffline Function

PrlSrv_ActivateInstalledLicenseOffline Function
PHT_SERVER

Offline activation of installed Parallels license.

Syntax
PRL_HANDLE PrlSrv_ActivateInstalledLicenseOffline(
    PRL_HANDLE hServer,
    PRL_CONST_STR sConfirmationId,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sConfirmationId
A string with confirmation ID which is necessary to offline activation
nFlags
Flags

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to

the PHT_RESULT object.

  2. Use the PrlResult_GetParam function to obtain a handle

of type PHT_LICENSE containing the license information.

Links
PHT_SERVER


PrlSrv_ActivateInstalledLicenseOnline Function

PrlSrv_ActivateInstalledLicenseOnline Function
PHT_SERVER

Online activation of installed Parallels license.

Syntax
PRL_HANDLE PrlSrv_ActivateInstalledLicenseOnline(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Flags

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to

the PHT_RESULT object.

  2. Use the PrlResult_GetParam function to obtain a handle

of type PHT_LICENSE containing the license information.

Links
PHT_SERVER


PrlSrv_AddIPPrivateNetwork Function

PrlSrv_AddIPPrivateNetwork Function
PHT_SERVER See Also

Adds a new private network to the Parallels Service configuration.

Syntax
PRL_HANDLE PrlSrv_AddIPPrivateNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hPrivNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hPrivNet
A handle of type PHT_IPPRIV_NET identifying the private network to add to the Parallels Service configuration.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To create a new private network, first create a handle of type PHT_IPPRIV_NET, configure the network using the handle's functions, and then call this function to add the network to the Parallels Service configuration.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_GetIPPrivateNetworkList

PrlSrv_DeleteIPPrivateNetwork

PrlSrv_UpdateIPPrivateNetwork

Links
PHT_SERVER, See Also


PrlSrv_AddVirtualNetwork Function

PrlSrv_AddVirtualNetwork Function
PHT_SERVER See Also

Adds a new virtual network to the Parallels Service configuration.

Syntax
PRL_HANDLE PrlSrv_AddVirtualNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hVirtNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network to add to the Parallels Service configuration.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To create a new virtual network, first create a handle of type PHT_VIRTUAL_NETWORK, configure the network using the handle's functions, and then call this function to add the network to the Parallels Service configuration.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_GetVirtualNetworkList

PrlSrv_DeleteVirtualNetwork

PrlSrv_UpdateVirtualNetwork

Links
PHT_SERVER, See Also


PrlSrv_AttachToLostTask Function

PrlSrv_AttachToLostTask Function
PHT_SERVER

The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.

Syntax
PRL_HANDLE PrlSrv_AttachToLostTask(
    PRL_HANDLE hServer,
    PRL_CONST_STR sTaskId
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sTaskId
The ID of the task to get a job handle for.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object. The returned PHT_JOB object will be attached to the specified task.

Remarks

If you've started a long asynchronous operation and then lost a connection with the Parallels Service, you may use this function to get a handle to the task after reconnecting to the Parallels Service. In order to do that, log in to the Parallels Service using the PrlSrv_Login or the PrlSrv_LoginLocal function passing the UUID of the session that you've lost. The returned PHT_LOGIN_RESPONSE object will contain the list of the tasks that belong to the lost session and are still running. Select a task that you want to get a handle to and pass its ID to the PrlSrv_AttachToLostTask function. The function will return a handle of type PHT_JOB which you may use to continue controlling and monitoring the task as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CancelInstallAppliance Function

PrlSrv_CancelInstallAppliance Function
PHT_SERVER

Cancels the appliance installation previously started with the PrlSrv_InstallAppliance function call.

Syntax
PRL_HANDLE PrlSrv_CancelInstallAppliance(
    PRL_HANDLE hServer,
    PRL_HANDLE hAppCfg,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hAppCfg
A handle of type PHT_APPLIANCE_CONFIG identifying the appliance. This must be the same handle instance that was passed to the PrlSrv_InstallAppliance function.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CheckParallelsServerAlive Function

PrlSrv_CheckParallelsServerAlive Function
PHT_SERVER

Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.

Syntax
PRL_RESULT PrlSrv_CheckParallelsServerAlive(
    PRL_UINT32 timeout,
    PRL_CONST_STR sServerHostname,
    PRL_BOOL_PTR pbServerIsAlive,
    PRL_HANDLE_PTR phServerInfo
);
File

PrlApiDisp.h

Parameters

timeout
Timeout in milliseconds specifying how long the function should wait for a response from the Parallels Service.
sServerHostname
The name of the host machine for which to get the Parallels Service status. To get the status for the local Parallels Service, the parameter can be null or empty.
pbServerIsAlive
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the Parallels Service is running. PRL_FALSE indicates otherwise.
phServerInfo
[out] A pointer to a variable that receives a handle of type PHT_SERVER_INFO containing the Parallels Service connection information. Pass a null pointer if you don't want to receive the Parallels Service connection information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer (excluding those that can be null) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CheckParallelsServerAliveEx Function

PrlSrv_CheckParallelsServerAliveEx Function
PHT_SERVER

The same functionality as previos version of call except follow things:

  • provides asynch interface;
  • using TCP connection instead of UDP.
Syntax
PRL_HANDLE PrlSrv_CheckParallelsServerAliveEx(
    PRL_CONST_STR sServerHostname,
    PRL_UINT16 nServerPort,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR pUserCallback,
    PRL_VOID_PTR pUserData,
    PRL_UINT32 nReserved
);
File

PrlApiDisp.h

Parameters

sServerHostname
The name of the host machine for which to get the Parallels Service status. The parameter can't be empty or null.
nServerPort
listen port to check. Can be 0 - default Parallels Service port will be used in this case.
timeout
Timeout in milliseconds specifying how long the function should wait for a response from the Parallels Service.
pUserCallback
user callback for asynch work mode.
pUserData
user data which will be passed into the user callback.
nReserved
reserved parameter for further purposes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer (excluding those that can be null) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CommonPrefsBeginEdit Function

PrlSrv_CommonPrefsBeginEdit Function
PHT_SERVER

The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).

Syntax
PRL_HANDLE PrlSrv_CommonPrefsBeginEdit(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlSrv_CommonPrefsBeginEdit and the PrlSrv_CommonPrefsCommit functions are used to detect collisions with other clients trying to modify preferences of the same Parallels Service. The PrlSrv_CommonPrefsBeginEdit call timestamps the beginning of the operation. It does not lock the Parallels Service, so other clients can modify the same Parallels Service settings at the same time. When you are done making the changes, you must call the PrlSrv_CommonPrefsCommit function to apply them to the Parallels Service. The function will verify that the Parallels Service preferences have not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - current user does not have sufficient rights to perform this operation.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CommonPrefsCommit Function

PrlSrv_CommonPrefsCommit Function
PHT_SERVER

The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).

Syntax
PRL_HANDLE PrlSrv_CommonPrefsCommit(
    PRL_HANDLE hServer,
    PRL_HANDLE hDispCfg
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hDispCfg
A handle of type PHT_DISP_CONFIG containing the Parallels Service preferences.
nFlags
Reserved flags

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlSrv_CommonPrefsBeginEdit and the PrlSrv_CommonPrefsCommit functions are used to detect collisions with other clients trying to modify preferences of the same Parallels Service. The PrlSrv_CommonPrefsBeginEdit call timestamps the beginning of the operation. It does not lock the Parallels Service, so other clients can modify the same Parallels Service at the same time. When you are done making the changes, you must call the PrlSrv_CommonPrefsCommit function to apply them to the Parallels Service. The function will verify that the Parallels Service preferences have not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CommonPrefsCommitEx Function

PrlSrv_CommonPrefsCommitEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_CommonPrefsCommitEx(
    PRL_HANDLE hServer,
    PRL_HANDLE hDispCfg,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_ConfigureGenericPci Function

PrlSrv_ConfigureGenericPci Function
PHT_SERVER See Also

Configures the PCI device assignment.

Syntax
PRL_HANDLE PrlSrv_ConfigureGenericPci(
    PRL_HANDLE hServer,
    PRL_HANDLE hDevList,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hDevList
A handle of type PHT_HANDLES_LIST containing a list of handles of type PHT_HW_GENERIC_PCI_DEVICE. Each handle in the list identifies an individual PCI device installed on the host computer.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For more information about generic PCI devices and their usage, see the PHT_HW_GENERIC_PCI_DEVICE handle description.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PHT_HW_GENERIC_PCI_DEVICE

Links
PHT_SERVER, See Also


PrlSrv_CopyCtTemplate Function

PrlSrv_CopyCtTemplate Function
PHT_SERVER

Copy the specified Containers template to the specified server.

Syntax
PRL_HANDLE PrlSrv_CopyCtTemplate(
    PRL_HANDLE hSrv,
    PRL_CONST_STR sName,
    PRL_CONST_STR sOsTmplName,
    PRL_CONST_STR sTargetServerHostname,
    PRL_UINT32 nTargetServerPort,
    PRL_CONST_STR sTargetServerSessionUuid,
    PRL_UINT32 nFlags,
    PRL_UINT32 nReservedFlags
);
File

PrlApiVm.h

Parameters

hSrv
A handle of type PHT_SERVER identifying the Parallels Service.
sName
Name of template to be removed.
sOsTmplName
Name of OS template for which this application template is. Should be filled for application templates.
sTargetServerHostname
target server hostname
nTargetServerPort
target server port
sTargetServerSessionUuid
target server session uuid
nFlags
Command flags.
nReservedFlags
Reserved command flags.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_Create Function

PrlSrv_Create Function
PHT_SERVER Example See Also

Creates a new handle of type PHT_SERVER.

Syntax
PRL_RESULT PrlSrv_Create(
    PRL_HANDLE_PTR handle
);
File

PrlApiDisp.h

Parameters

handle
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In order to establish a connection with a Parallels Service, a handle of type PHT_SERVER must be created and the object that the handle references must be populated with the Parallels Service connection information. Once a connection is established, the handle can be used to access the Parallels Service. It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

See Also

PrlSrv_LoginLocal

PrlSrv_Login

Example

The following example illustrates how to create a handle of type PHT_SERVER.

PRL_HANDLE hServer;

PRL_RESULT ret = PrlSrv_Create( &hServer );
if ( PRL_FAILED(ret) )
{
    printf( "PrlSrv_Create returned with error: %s\n",
    PRL_RESULT_TO_STRING(ret) );
}

// Free hServer handle when it's no longer needed.
PrlHandle_Free( hServer );
Links
PHT_SERVER, Example, See Also


PrlSrv_CreateDesktopControl Function

PrlSrv_CreateDesktopControl Function
PHT_SERVER

Creates Desktop Control object.

Syntax
PRL_RESULT PrlSrv_CreateDesktopControl(
    PRL_HANDLE hSrv,
    PRL_HANDLE_PTR hDeskCtl
);
File

PrlApiManager.h

Parameters

hDeskCtl
[out] On success receives handle of type PHT_DESKTOP_CONTROL.
hVm
[in] A handle of type PHT_SERVER. Created object will control desktop of specified server.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CreateUnattendedCd Function

PrlSrv_CreateUnattendedCd Function
PHT_SERVER

Creates a bootable ISO-image for unattended Linux installation.

Syntax
PRL_HANDLE PrlSrv_CreateUnattendedCd(
    PRL_HANDLE hServer,
    PRL_UINT32 nGuestType,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sPasswd,
    PRL_CONST_STR sFullUserName,
    PRL_CONST_STR sOsDistroPath,
    PRL_CONST_STR sOutImagePath
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sUserName
User name.
sPasswd
Password.
sFullUserName
Full user name.
sOsDistroPath
A full path to the OS distribution image or folder.
sOutImagePath
A full path to output ISO-image file.
nGuestDistroType
Guest OS version from the (PVS_GUEST_VER_...).
sPath
Full path to the OS distribution image or folder.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The following steps describe how to prepare a virtual machine for unattended Linux installation:

  1. Create a virtual machine. The machine should have all the necessary devices, like hard drive and CD drive.
  2. Insert Linux installation CD-ROM into the drive (or mount a disk image).
  3. Execute the PrlVm_CreateUnattendedCd function to create a bootable ISO-image.
  4. Set created ISO-image as boot device.
  5. Start the virtual machine. The machine will boot from the created ISO-image.
  6. Perform unattended Windows installation as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_CreateVm Function

PrlSrv_CreateVm Function
PHT_SERVER Example

Obtains a new handle of type PHT_VIRTUAL_MACHINE.

Syntax
PRL_RESULT PrlSrv_CreateVm(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR phVm
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
phVm
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Obtaining a new PHT_VIRTUAL_MACHINE handle is the first step when creating a virtual machine. The second step is setting the virtual machine configuration parameters. The final step is calling the PrlVm_Reg function, which will create a new virtual machine.

Example
// Create a new virtual machine handle
// (assumes hServer is a valid handle obtained using PrlSrv_Create,
// and a successful Parallels Service login was made using PrlSrv_Login).
PRL_HANDLE hNewVm;
ret = PrlSrv_CreateVm(hServer, &hNewVm);
if (PRL_FAILED(ret))
{
    printf("PrlSvr_CreateVm call failed with: %s.\n", PRL_RESULT_TO_STRING(ret));
    return ret;
}
printf("PrlSvr_CreateVm completed successfully.\n");
Links
PHT_SERVER, Example


PrlSrv_CreateVmBackup Function

PrlSrv_CreateVmBackup Function
PHT_SERVER

Backup an existing virtual machine to backup server.

Syntax
PRL_HANDLE PrlSrv_CreateVmBackup(
    PRL_HANDLE hSourceServer,
    PRL_CONST_STR sVmUuid,
    PRL_CONST_STR sTargetHost,
    PRL_UINT32 nTargetPort,
    PRL_CONST_STR sTargetSessionId,
    PRL_CONST_STR strDescription,
    PRL_UINT32 backup_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hSourceServer
A handle of type PHT_SERVER identifying the source Parallels Service.
sVmUuid
A virtual machine uuid
sTargetHost
The name of the target host machine.
nTargetPort
The port number on the target host.
sTargetSessionId
The target Parallels Service session ID.
backup_flags
Flags that specify backup type and etc. Acceptable flags:
reserved_flags
Reserved flags.
force_operation
Specifies to process VM backup action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).
sDescription
The backup description.
PBT_FULL
full backup
PBT_INCREMENTAL
incremental backup
PBT_DIFFERENTIAL
differental backup
PBT_UNCOMPRESSED
uncompressed backup (by default fast zip compression used) PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Notes

errors are the same as for VmMigrate activity

Links
PHT_SERVER


PrlSrv_DeactivateInstalledLicense Function

PrlSrv_DeactivateInstalledLicense Function
PHT_SERVER

Deactivate installed Parallels license.

Syntax
PRL_HANDLE PrlSrv_DeactivateInstalledLicense(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Flags

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to

the PHT_RESULT object.

  2. Use the PrlResult_GetParam function to obtain a handle

of type PHT_LICENSE containing the license information.

Links
PHT_SERVER


PrlSrv_DeleteOfflineService Function

PrlSrv_DeleteOfflineService Function
PHT_SERVER See Also

Removes an existing offline service configuration.

Syntax
PRL_HANDLE PrlSrv_DeleteOfflineService(
    PRL_HANDLE hServer,
    PRL_HANDLE hOffmgmtService,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying a offline management service

nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_DeleteOfflineService

PrlSrv_GetOfflineServicesList

Links
PHT_SERVER, See Also


PrlSrv_DeleteVirtualNetwork Function

PrlSrv_DeleteVirtualNetwork Function
PHT_SERVER See Also

Removes an existing virtual network from the Parallels Service configuration.

Syntax
PRL_HANDLE PrlSrv_DeleteVirtualNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hVirtNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying a virtual network.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_AddVirtualNetwork

PrlSrv_GetVirtualNetworkList

PrlSrv_UpdateVirtualNetwork

Links
PHT_SERVER, See Also


PrlSrv_DisableConfirmationMode Function

PrlSrv_DisableConfirmationMode Function
PHT_SERVER See Also

Disable administrator confirmation mode for the session.

Syntax
PRL_HANDLE PrlSrv_DisableConfirmationMode(
    PRL_HANDLE hServer,
    PRL_CONST_STR sUser,
    PRL_CONST_STR sPasswd,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
sUser
User name from administrator group (a UTF-8 encoded, null-terminated string).
sPasswd
Password of user (a UTF-8 encoded, null-terminated string).
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_SERVER, See Also


PrlSrv_EnableConfirmationMode Function

PrlSrv_EnableConfirmationMode Function
PHT_SERVER See Also

Enable administrator confirmation mode for the session.

Syntax
PRL_HANDLE PrlSrv_EnableConfirmationMode(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_SERVER, See Also


PrlSrv_FsCanCreateFile Function

PrlSrv_FsCanCreateFile Function
PHT_SERVER

Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.

Syntax
PRL_HANDLE PrlSrv_FsCanCreateFile(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
Full path to the intended file or directory.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_FsCreateDir Function

PrlSrv_FsCreateDir Function
PHT_SERVER

Creates a directory in the specified location on the host.

Syntax
PRL_HANDLE PrlSrv_FsCreateDir(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
The new directory name and path.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

If you are creating a series of directories that relate to each other, you can use the PrlSrv_FsGenerateEntryName function to automatically generate their names.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_FsGenerateEntryName Function

PrlSrv_FsGenerateEntryName Function
PHT_SERVER

Automatically generates a unique name for a new directory.

Syntax
PRL_HANDLE PrlSrv_FsGenerateEntryName(
    PRL_HANDLE hServer,
    PRL_CONST_STR sDirPath,
    PRL_CONST_STR sFilenamePrefix,
    PRL_CONST_STR sFilenameSuffix,
    PRL_CONST_STR sIndexDelimiter
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sDirPath
A full path to the target location (directory).
sFilenamePrefix
Specifies a prefix to use in the directory name. Pass null or empty string to use the default prefix: tmpfile. The name will be generated by adding a number to the prefix (e.g. tmpfile1, tmpfile2, tmpfile3, etc.)
sFilenameSuffix
Specifies a suffix to use in the directory name. Pass null or an empty string value if you don't want to use a suffix.
sIndexDelimiter
A character(s) that will be inserted between the prefix and the index (e.g. tmpfile_1, tmpfile_2, tmpfile_3, etc). You can specify a null pointer or an empty string if you don't want to insert any extra characters there.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function allows to generate directory names using a specified prefix and optionally a suffix. You can specify your own prefix or use the default one. The function will not create the directories on the host. To create the directories, use the PrlSrv_FsCreateDir function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain the file system entry name from the PHT_RESULT object. The directory name is returned as a UTF-8 encoded, null-terminated string.
Links
PHT_SERVER


PrlSrv_FsGetDirEntries Function

PrlSrv_FsGetDirEntries Function
PHT_SERVER

Retrieves information about the specified file system entry residing on the specified host computer.

Syntax
PRL_HANDLE PrlSrv_FsGetDirEntries(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
An absolute directory name and path, or drive letter (e.g. C:\) on the host computer for which to get the information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information retrieved by the PrlSrv_FsGetDirEntries function includes the information about the specified entry and, if the entry is a directory, the information about its immediate child entries (files and subdirectories). On Windows, you can also specify a drive letter, in which case the information about the root directory entries will be retrieved.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO containing the file system entry information.
Links
PHT_SERVER


PrlSrv_FsGetDiskList Function

PrlSrv_FsGetDiskList Function
PHT_SERVER Example

Returns a list of root directories on the host computer.

Syntax
PRL_HANDLE PrlSrv_FsGetDiskList(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

On Windows, the function returns a list of PHT_REMOTE_FILESYSTEM_INFO objects containing the disk volume information (e.g. C:\, D:\, etc.). On other operating systems, it returns a single object containing the root directory.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount to get the number of results.
  3. Use the PrlResult_GetParamByIndex function to get individual results.
Example

The following example illustrates how to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO.

hJob =
PrlSrv_FsGetDiskList( hServer );
PrlJob_Wait( hJob, JOB_TIMEOUT );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_REMOTE_FILESYSTEM_INFO handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_FsRemoveEntry Function

PrlSrv_FsRemoveEntry Function
PHT_SERVER

Removes a file system entry from the host computer.

Syntax
PRL_HANDLE PrlSrv_FsRemoveEntry(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
An absolute path to the file system entry to be removed.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_FsRenameEntry Function

PrlSrv_FsRenameEntry Function
PHT_SERVER

Renames a file system entry on the host.

Syntax
PRL_HANDLE PrlSrv_FsRenameEntry(
    PRL_HANDLE hServer,
    PRL_CONST_STR oldPath,
    PRL_CONST_STR newPath
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
oldPath
An absolute path to the entry to be renamed.
newPath
An absolute path including the new file system entry name.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_GetAllHostUsers Function

PrlSrv_GetAllHostUsers Function
PHT_SERVER

Obtains a list of handles of type PHT_EVENT containing in its parameters information about all registered host users.

Syntax
PRL_HANDLE PrlSrv_GetAllHostUsers(
    PRL_HANDLE hServer
);
File

PrlApiManager.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Notes

this function is used by iPhone proxy only. To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_EVENT containing an individual user information.

Links
PHT_SERVER


PrlSrv_GetBackupTree Function

PrlSrv_GetBackupTree Function
PHT_SERVER

Get backups tree from backup server.

Syntax
PRL_HANDLE PrlSrv_GetBackupTree(
    PRL_HANDLE hSourceServer,
    PRL_CONST_STR sUuid,
    PRL_CONST_STR sTargetHost,
    PRL_UINT32 nTargetPort,
    PRL_CONST_STR sTargetSessionId,
    PRL_UINT32 backup_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hSourceServer
A handle of type PHT_SERVER identifying the source Parallels Service.
sUuid
A virtual machine or a backup ID. If it is empty, the tree will be built for backups of all virtual machines. When PBT_BACKUP_ID or PBT_CHAIN flag is specified in the backup_flags argument, then the value of this argument is treated as a backup ID, otherwise - as a virtual machine UUID.
sTargetHost
The name of the target host machine.
nTargetPort
The port number on the target host.
sTargetSessionId
The target Parallels Service session ID.
backup_flags
Flags that specify backup type and etc. Acceptable flags:
reserved_flags
Reserved flags.
force_operation
Specifies to process VM backup action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).
PBT_VM
include only virtual machine backups (used by default if PBT_VM and PBT_CT flags are not specified)
PBT_CT
include only container backups
PBT_BACKUP_ID
get information about the backup, which identifier is specified in sUuid parameter. Note that if an identifier of an incremental backup is passed in the sUuid parameter, then the output tree would also contain the corresponding full backup element.
PBT_CHAIN
get information about the whole backup chain, which is dependent on the backup identifier, specified in sUuid parameter. Note that if an identifier of an incremental backup is passed in the sUuid parameter, then the output tree would also contain the corresponding full backup element.

PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Some of the important XML elements are:

<VmItem> - root element of a branch containing information about a virtual machine. This element, in turn, may contain a set of elements describing full backups of this virtual machine.

<BackupItem> - root element of a branch containing information about a full backup. This element, in turn, may contain a set of elements describing incremental backups of this full backup.

<PartialBackupItem> - root element of a branch containing information about an incremental backup.

<Id> - the backup ID. The ID is required when performing other operations on a backup.

<DateTime> - the backup creation date and time.

<Type> - backup type {'f' - full, 'i' - incremental}

<Size> Backup size in bytes

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_INVALID_PARAM - invalid combination of backup_flags was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a backup tree from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a string value containing the backup tree XML data.

Please note that no parser is provided to traverse the returned XML. To use this functionality, you will have to parse the returned XML yourself.

Links
PHT_SERVER


PrlSrv_GetCommonPrefs Function

PrlSrv_GetCommonPrefs Function
PHT_SERVER Example

Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.

Syntax
PRL_HANDLE PrlSrv_GetCommonPrefs(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_DISP_CONFIG containing the Parallels Service preferences.
Example

The following example illustrates how to obtain a handle of type PHT_DISP_CONFIG.

hJob =
PrlSrv_GetCommonPrefs( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_DISP_CONFIG handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_GetCtTemplateList Function

PrlSrv_GetCtTemplateList Function
PHT_SERVER

Retrieves a list of Containers templates registered with the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_GetCtTemplateList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information about each template is returned as a handle of type PHT_CT_TEMPLATE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of templates in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each template.
Links
PHT_SERVER


PrlSrv_GetDefaultVmConfig Function

PrlSrv_GetDefaultVmConfig Function
PHT_SERVER

Obtains a new handle of type PHT_VIRTUAL_MACHINE.

Syntax
PRL_HANDLE PrlSrv_GetDefaultVmConfig(
    PRL_HANDLE hServer,
    PRL_CONST_GET_VM_CONFIG_PARAM_DATA_PTR pParam,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
pParam
Pointer to the PRL_GET_VM_CONFIG_PARAM_DATA structure.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Obtaining a new PHT_VIRTUAL_MACHINE handle is the first step when creating a virtual machine. The second step is setting the virtual machine configuration parameters. The final step is calling the PrlVm_Reg function, which will create a new virtual machine.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PHT_SERVER


PrlSrv_GetDiskFreeSpace Function

PrlSrv_GetDiskFreeSpace Function
PHT_SERVER

Get available disk space for path.

Syntax
PRL_HANDLE PrlSrv_GetDiskFreeSpace(
    PRL_HANDLE hServer,
    PRL_CONST_STR sPath,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sPath
Path as pointer of type PRL_CONST_STR_PTR.
nFlags
Flags

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a result as string
Links
PHT_SERVER


PrlSrv_GetDisplayEncodingList Function

PrlSrv_GetDisplayEncodingList Function
PHT_SERVER

Returns currently supported display encodings both by server and client.

Syntax
PRL_RESULT PrlSrv_GetDisplayEncodingList(
    PRL_HANDLE hSrv,
    PRL_IO_DISPLAY_ENCODING_LIST_PTR pEncsOut
);
File

PrlApiDisp.h

Parameters

pEncsOut
Display display encodings structure which is filled by this call.
hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

PRL_RESULT. Possible values:

PRL_ERR_SUCCESS - out list has been filled with supported display encodings.

PRL_ERR_DISPLAY_ENCODINGS_NOT_SUPPORTED - display encodings are not supported on server, connection is local or remote connection does not exist anymore.

PRL_ERR_INVALID_ARG - pEncsOut pointer is wrong or hVm does not exist.

Remarks

If display display encodings are not supported on server connection is local or remote connection does not exist: PRL_ERR_FAILURE will be returned, PRL_ERR_SUCCESS otherwise.

Links
PHT_SERVER


PrlSrv_GetIPPrivateNetworksList Function

PrlSrv_GetIPPrivateNetworksList Function
PHT_SERVER

Obtains a list of handles of type PHT_IPPRIV_NET containing information about all existing private networks.

Syntax
PRL_HANDLE PrlSrv_GetIPPrivateNetworksList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_IPPRIV_NET containing the information about a private network.

Links
PHT_SERVER


PrlSrv_GetLicenseInfo Function

PrlSrv_GetLicenseInfo Function
PHT_SERVER Example

Returns an object of type PHT_LICENSE containing the Parallels license information.

Syntax
PRL_HANDLE PrlSrv_GetLicenseInfo(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LICENSE containing the license information.
Example

The following example illustrates how to obtain a handle of type PHT_LICENSE.

hJob =
PrlSrv_GetLicenseInfo( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LICENSE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_GetNetServiceStatus Function

PrlSrv_GetNetServiceStatus Function
PHT_SERVER Example

Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.

Syntax
PRL_HANDLE PrlSrv_GetNetServiceStatus(
    PRL_HANDLE hServer
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_NET_SERVICE_STATUS containing the NET service status.
Example

The following example illustrates how to obtain a handle of type PHT_NET_SERVICE_STATUS containing the Parallels Service network service status.

hJob =
PrlSrv_GetNetServiceStatus( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_NET_SERVICE_STATUS handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_GetNetworkClassesList Function

PrlSrv_GetNetworkClassesList Function
PHT_SERVER

Obtains a list of handles of type PHT_HANDLES_LIST containing the list of handles of type PHT_NETWORK_CLASS.

Syntax
PRL_HANDLE PrlSrv_GetNetworkClassesList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_HANDLES_LIST

Links
PHT_SERVER


PrlSrv_GetNetworkShapingConfig Function

PrlSrv_GetNetworkShapingConfig Function
PHT_SERVER

Obtains the network shaping configuration.

Syntax
PRL_HANDLE PrlSrv_GetNetworkShapingConfig(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_NETWORK_SHAPING_CONFIG

Links
PHT_SERVER


PrlSrv_GetOfflineServicesList Function

PrlSrv_GetOfflineServicesList Function
PHT_SERVER

Obtains a list of handles of type PHT_OFFLINE_SERVICE containing information about all existing services.

Syntax
PRL_HANDLE PrlSrv_GetOfflineServicesList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_OFFLINE_SERVICE containing the information about an individual offline service.

Links
PHT_SERVER


PrlSrv_GetPackedProblemReport Function

PrlSrv_GetPackedProblemReport Function
PHT_SERVER

Allows to receive a packed problem report from the Parallels Service in the event of a virtual machine operation failure.

Syntax
PRL_HANDLE PrlSrv_GetPackedProblemReport(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service. PRL_UINT32 nFlags - reserved flags parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a report from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to

the PHT_RESULT object.

  2. Use the PrlResult_GetParamAsString function to obtain a

string value containing the packed report dir path.

Links
PHT_SERVER


PrlSrv_GetPerfStats Function

PrlSrv_GetPerfStats Function
PHT_SERVER

Obtains a handle of type PHT_EVENT containing the perfomance statistics.

Syntax
PRL_HANDLE PrlSrv_GetPerfStats(
    PRL_HANDLE hServer,
    PRL_CONST_STR sFilter
);
File

PrlApiStat.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sFilter
String representing statistics filter, use char '*' at the end to get subset of statistic. Could be NULL, to get all statistic. See PrlPerfCounters.h header file in order to determine published performance counters patterns list.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_EVENT.
Links
PHT_SERVER


PrlSrv_GetPluginsList Function

PrlSrv_GetPluginsList Function
PHT_SERVER

Gets plugin list with plugin info entries.

Syntax
PRL_HANDLE PrlSrv_GetPluginsList(
    PRL_HANDLE hServer,
    PRL_CONST_STR sClassId,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sClassId
[optional] Class GUID in text format.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_GetProblemReport Function

PrlSrv_GetProblemReport Function
PHT_SERVER

Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.

Syntax
PRL_HANDLE PrlSrv_GetProblemReport(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a report from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a string value containing the report.
Links
PHT_SERVER


PrlSrv_GetQuestions Function

PrlSrv_GetQuestions Function
PHT_SERVER

The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.

Syntax
PRL_RESULT PrlSrv_GetQuestions(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR pQuestionsList
);
File

PrlApiDisp.h

Parameters

pQuestionsList
[out] A pointer to a handle of type PHT_HANDLES_LIST containing a list of available questions.
handle
A handle of type PHT_SERVER.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_OUT_OF_MEMORY - not enough memory to complete the operation. PRL_ERR_SUCCESS - operation completed successfully.

Remarks

It can be used as an alternative to asynchronous question processing through events. You can use this function at any time to check if a question is awaiting the client response on the Parallels Service.

Links
PHT_SERVER


PrlSrv_GetRegisteredHostsOnProxy Function

PrlSrv_GetRegisteredHostsOnProxy Function
PHT_SERVER

Do authentication on proxy server and returns list of registered hosts on this proxy.

Syntax
PRL_HANDLE PrlSrv_GetRegisteredHostsOnProxy(
    PRL_CONST_STR account,
    PRL_CONST_STR accountPass,
    PRL_PROXY_CLIENT_INFO_PTR cliInfo,
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiManager.h

Parameters

account
Parallels account.
accountPass
Parallels account password.
cliInfo
Additional client information.
timeout
Timeout in milliseconds. The authenticate operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called when operation become complete.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.

Returns

If authentication has been successfully passed, a handle of type PHT_JOB will contain a set of registered hosts on proxy or PRL_ERR_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

PRL_ERR_INVALID_ARG - null pointer was passed.

Links
PHT_SERVER


PrlSrv_GetRestrictionInfo Function

PrlSrv_GetRestrictionInfo Function
PHT_SERVER See Also

Gets restriction info.

Syntax
PRL_RESULT PrlSrv_GetRestrictionInfo(
    PRL_HANDLE hServer,
    PRL_LICENSE_RESTRICTION_KEY nRestrictionKey,
    PRL_HANDLE_PTR phEvtParam
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
nRestrictionKey
Restriction key value form PRL_LICENSE_RESTRICTION_KEY enumeration.
phEvtParam
[out] A pointer to a variable that receives the handle of PHT_EVENT_PARAMETER type.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_NO_DATA - no info for the given restriction or restriction has boolean type. PRL_ERR_SUCCESS - operation completed successfully.

See Also

PrlSrv_HasRestriction

Links
PHT_SERVER, See Also


PrlSrv_GetServerInfo Function

PrlSrv_GetServerInfo Function
PHT_SERVER

Obtains a handle of type PHT_SERVER_INFO containing the host computer information.

Syntax
PRL_RESULT PrlSrv_GetServerInfo(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR phServerInfo
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
phServerInfo
[out] A pointer to a variable that receives a handle to the server info object.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that in order to obtain the complete host info, the function must be called after the login operation is completed and the results of the login operation are received. In all other situations, some of the Parallels Service properties may not be populated.

Links
PHT_SERVER


PrlSrv_GetSrvConfig Function

PrlSrv_GetSrvConfig Function
PHT_SERVER Example

Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.

Syntax
PRL_HANDLE PrlSrv_GetSrvConfig(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SERVER_CONFIG containing the host configuration information.
Example

The following example illustrates how to obtain a handle of type PHT_SERVER_CONFIG from the PHT_SERVER object (the example assumes that you've already obtained a server handle).

hJob =
PrlSrv_GetSrvConfig( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_SERVER_CONFIG handle from the result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_GetStatistics Function

PrlSrv_GetStatistics Function
PHT_SERVER Example

Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.

Syntax
PRL_HANDLE PrlSrv_GetStatistics(
    PRL_HANDLE hServer
);
File

PrlApiStat.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SYSTEM_STATISTICS.
Example

The following example illustrates how to obtain a handle of type PHT_SYSTEM_STATISTICS.

PRL_RESULT err = PRL_ERR_UNINITIALIZED;
PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
PRL_HANDLE hJob = PRL_INVALID_HANDLE;
PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
PRL_HANDLE hServer = PRL_INVALID_HANDLE;

// Initialize API library.
err = PrlApi_Init(PARALLELS_API_VER);
if (PRL_FAILED(err))
{
    // Error handling goes here...
    return -1;
}

// Create server handle.
err = PrlSrv_Create(&hServer);

// if (err != PRL_ERR_SUCCESS), process the error here.

hJob = PrlSrv_Login(
    hServer, // Server handle
    "10.30.21.243", // Server IP address
    "jdoe", // User
    "secret", // Password
    0, // Previous session ID
    0, // Port number
    0, // Timeout
    PSL_LOW_SECURITY); // Security

// Wait for the job to complete.
err = PrlJob_Wait(hJob, 1000);

// if (err != PRL_ERR_SUCCESS), process the error here.

// Get job return code.
err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

// Free job handle.
PrlHandle_Free(hJob);

// Get statistics.
hJob = PrlSrv_GetStatistics(hServer);
err = PrlJob_Wait(hJob, 10000);

// if (err != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

// Get the PHT_SYSTEM_STATISTICS handle.
PRL_HANDLE hHandle = PRL_INVALID_HANDLE;
err = PrlResult_GetParam(hJobResult, &hHandle);

// if (err != PRL_ERR_SUCCESS), process the error here.

PrlHandle_Free(hJobResult);
Links
PHT_SERVER, Example


PrlSrv_GetSupportedOses Function

PrlSrv_GetSupportedOses Function
PHT_SERVER

Extracts supported guest OSes matrix from remote server (it's more proper way instead of using local synch API in case when client and server interoperate remotely).

Syntax
PRL_RESULT PrlSrv_GetSupportedOses(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR phOsesMatrix
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
phOsesMatrix
pointer to the buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_NO_DATA - no supported OSes data (OSes matrix filling just after login procedure completed). Also this field can be empty in case when remote server is not supported this interface.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_GUEST_OSES_MATRIX which will contain complete list of supported guest OSes types, versions and defaults.
Links
PHT_SERVER


PrlSrv_GetUserInfo Function

PrlSrv_GetUserInfo Function
PHT_SERVER See Also

Obtains a handle of type PHT_USER_INFO containing information about the specified user.

Syntax
PRL_HANDLE PrlSrv_GetUserInfo(
    PRL_HANDLE hServer,
    PRL_CONST_STR sUserId
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sUserId
UUID of the user to obtain the information for.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_USER_INFO containing the user information.

See Also

PrlSrv_GetUserInfoList

Links
PHT_SERVER, See Also


PrlSrv_GetUserInfoList Function

PrlSrv_GetUserInfoList Function
PHT_SERVER

Obtains a list of handles of type PHT_USER_INFO containing information about all known users.

Syntax
PRL_HANDLE PrlSrv_GetUserInfoList(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_USER_INFO containing an individual user information.

Links
PHT_SERVER


PrlSrv_GetUserProfile Function

PrlSrv_GetUserProfile Function
PHT_SERVER Example

Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.

Syntax
PRL_HANDLE PrlSrv_GetUserProfile(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_USER_PROFILE.
Example

The following example shows how to obtain a handle of type PHT_USER_PROFILE.

hJob =
PrlSrv_GetUserProfile( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_USER_PROFILE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example


PrlSrv_GetVirtualNetworkList Function

PrlSrv_GetVirtualNetworkList Function
PHT_SERVER

Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.

Syntax
PRL_HANDLE PrlSrv_GetVirtualNetworkList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_VIRTUAL_NETWORK containing the information about a virtual network.

Links
PHT_SERVER


PrlSrv_GetVmConfig Function

PrlSrv_GetVmConfig Function
PHT_SERVER

Get VM config by given UUID or name.

Syntax
PRL_HANDLE PrlSrv_GetVmConfig(
    PRL_HANDLE hServer,
    PRL_CONST_STR sSearchId,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

sSearchId
VM UUID or name.
nFlags
Search by UUID if nFlags is 0 or PGVC_SEARCH_BY_UUID, by name, if nFlags is PGVC_SEARCH_BY_NAME and search first by uuid, then by name if nFlags is PGVC_SEARCH_BY_UUID | PGVC_SEARCH_BY_NAME.
hHandle
A handle of type PHT_SERVER.

Returns

A handle of type PHT_JOB containing the results of operation.

Links
PHT_SERVER


PrlSrv_GetVmList Function

PrlSrv_GetVmList Function
PHT_SERVER Example

Retrieves a list of virtual machines registered with the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_GetVmList(
    PRL_HANDLE hServer
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information about each virtual machine is returned as a handle of type PHT_VIRTUAL_MACHINE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of virtual machine in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each virtual machine.
Example

The following example illustrates how to obtain a list of virtual machine registered on the specified Parallels Service. The examples assumes that we've already obtain a handle of type PHT_SERVER (the hServer variable) identifying the Parallels Service.

hJob =
PrlSrv_GetVmList( hServer );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;

// Get the number of the virtual machines
// in the list.
PrlResult_GetParamsCount( hJobResult, &nCount );

// Iterate through the list.
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    // Get virtual machine name.
    nRetCode =
    PrlVm_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s.\n", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
Links
PHT_SERVER, Example


PrlSrv_GetVmListEx Function

PrlSrv_GetVmListEx Function
PHT_SERVER

Retrieves a list of virtual machines registered with the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_GetVmListEx(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Flags bitset of PRL_VM_TYPE_FLAGS enumerator, filter Vm by Vm type.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information about each virtual machine is returned as a handle of type PHT_VIRTUAL_MACHINE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of virtual machine in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each virtual machine.
Links
PHT_SERVER


PrlSrv_HasRestriction Function

PrlSrv_HasRestriction Function
PHT_SERVER See Also

Determines having restriction.

Syntax
PRL_RESULT PrlSrv_HasRestriction(
    PRL_HANDLE hServer,
    PRL_LICENSE_RESTRICTION_KEY nRestrictionKey,
    PRL_BOOL_PTR pbHasRestriction
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
nRestrictionKey
Restriction key value form PRL_LICENSE_RESTRICTION_KEY enumeration.
pbHasRestriction
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the current license has the given restriction.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_SUCCESS - operation completed successfully.

See Also

PrlSrv_GetRestrictionInfo

Links
PHT_SERVER, See Also


PrlSrv_InstallAppliance Function

PrlSrv_InstallAppliance Function
PHT_SERVER

Sends an appliance configuration to the Parallels Service in order to install the corresponding appliance from Parallels download service.

Syntax
PRL_HANDLE PrlSrv_InstallAppliance(
    PRL_HANDLE hServer,
    PRL_HANDLE hAppCfg,
    PRL_CONST_STR sVmParentPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hAppCfg
A handle of type PHT_APPLIANCE_CONFIG identifying the appliance.
sVmParentPath
Optional. Name and path of the parent directory where the virtual machine appliance should be installed. If this parameter is omitted (null pointer or empty string is passed), the new virtual machine appliance directory will be created in the default directory for this Parallels Service.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_IsConfirmationModeEnabled Function

PrlSrv_IsConfirmationModeEnabled Function
PHT_SERVER See Also

Determines confirmation mode for the session

Syntax
PRL_RESULT PrlSrv_IsConfirmationModeEnabled(
    PRL_HANDLE hServer,
    PRL_BOOL_PTR pbConfirmationModeEnabled
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
pbConfirmationModeEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that confirmation mode is enabled for the session. PRL_FALSE indicates that confirmation mode is disabled for the session.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_SUCCESS - operation completed successfully.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_SERVER, See Also


PrlSrv_IsConnected Function

PrlSrv_IsConnected Function
PHT_SERVER

Determines if the connection to the specified Parallels Service is active.

Syntax
PRL_RESULT PrlSrv_IsConnected(
    PRL_HANDLE hServer,
    PRL_BOOL_PTR pbConnected,
    PRL_BOOL_PTR pbIsConnectionLocal
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
pbConnected
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the connection is active. PRL_FALSE indicates otherwise.
pbIsConnectionLocal
[out] Specifies whether this is a local or remote connection. PRL_TRUE indicates that this is a local connection. PRL_FALSE indicates that this is a remote connection.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_IsFeatureSupported Function

PrlSrv_IsFeatureSupported Function
PHT_SERVER

Checks whether specified feature supported by remote side.

Syntax
PRL_RESULT PrlSrv_IsFeatureSupported(
    PRL_HANDLE hServer,
    PRL_FEATURES_MATRIX nFeatureId,
    PRL_BOOL_PTR pbIsSupported
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
nFeatureId
Requesting feature identifier
pbIsSupported
pointer to the buffer to retrieve result

Returns

PRL_ERR_INVALID_ARG - either invalid/wrong handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that actual data presents just after login to server operation was completed.

Links
PHT_SERVER


PrlSrv_IsNonInteractiveSession Function

PrlSrv_IsNonInteractiveSession Function
PHT_SERVER

Determines if the session is noninteractive or interactive.

Syntax
PRL_RESULT PrlSrv_IsNonInteractiveSession(
    PRL_HANDLE hServer,
    PRL_BOOL_PTR pbNonInteractive
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
pbNonInteractive
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the session is noninteractive. PRL_FALSE indicates interactive session (default).

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_SUCCESS - operation completed successfully.

Links
PHT_SERVER


PrlSrv_IsProxyConnection Function

PrlSrv_IsProxyConnection Function
PHT_SERVER

Determines if the connection to the specified Parallels Service is a proxy connection.

Syntax
PRL_RESULT PrlSrv_IsProxyConnection(
    PRL_HANDLE hServer,
    PRL_BOOL_PTR pbProxyConnection
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
pbProxyConnection
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the connection is proxy. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_Login Function

PrlSrv_Login Function
PHT_SERVER Example See Also

Performs a remote login operation using the specified parameters.

Syntax
PRL_HANDLE PrlSrv_Login(
    PRL_HANDLE hServer,
    PRL_CONST_STR host,
    PRL_CONST_STR user,
    PRL_CONST_STR passwd,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port_cmd,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
host
The name or IP address of the host machine (a UTF-8 encoded, null-terminated string).
user
User name (a UTF-8 encoded, null-terminated string).
passwd
Password (a UTF-8 encoded, null-terminated string).
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
port_cmd
Port number. Pass 0 (zero) to use the default port.
timeout
Timeout value in milliseconds. The operation will be automatically interrupted if a connection is not established within this timeframe. Specify 0 (zero) for infinite timeout.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.
flags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default ( as PrlSrv_Login() )

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A remote login operation logs the user to a Parallels Service running on a remote host. You can also use this function to log to a local host or you can use the PrlSrv_LoginLocal function, which is a simplified version created specifically to perform local host logins.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlDispCfg_GetMinSecurityLevel

Example

The following is a complete sample program that illustrates how to log in to a remote Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szVmName = "Windows XP";
const char *szServer = "127.0.0.1";
const char *szUsername = "SomeUserName";
const char *szPassword = "SomePassword";

int main( int argc, char* argv[] )
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the SDK library.
    if ( PRL_FAILED( SdkWrap_Load( SDK_LIB_NAME ) ) &&
        PRL_FAILED( SdkWrap_Load( "./" SDK_LIB_NAME ) ) )
    {
        fprintf( stderr, "Failed to load " SDK_LIB_NAME "\n" );
        return -1;
    }

    // Initialize the API.
    ret = PrlApi_Init( PARALLELS_API_VER );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create( &hServer );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (asynchronous call).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer,            // PRL_HANDLE of type PHT_SERVER.
            szServer,           // Name and IP address of the host machine.
            szUsername,         // User name.
            szPassword,         // Password.
            0,                  // Previuos session ID (0 if not used).
            0,                  // Port number (0 for default port).
            0,                  // Timeout value (0 for default timeout).
            PSL_LOW_SECURITY ); // Security level.

    // Wait for a maximum of 10 seconds for
    // the job to complete.
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING( ret) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( nJobResult ) )
    {
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Login was successful.\n" );

    // Log off.
    hJob = PrlSrv_Logoff( hServer );
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if ( PRL_FAILED( nJobResult ) )
    {
        fprintf( stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Logoff was successful.\n" );

    // Free handles that are no longer required.
    PrlHandle_Free( hVm );
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    printf( "\n\nEnd of program.\n\n" );
    char c;
    scanf( &c, "%c" );

    return 0;
}
Links
PHT_SERVER, Example, See Also


PrlSrv_LoginEx Function

PrlSrv_LoginEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_LoginEx(
    PRL_HANDLE hServer,
    PRL_CONST_STR host,
    PRL_CONST_STR user,
    PRL_CONST_STR passwd,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port_cmd,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level,
    PRL_UINT32 flags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_LoginLocal Function

PrlSrv_LoginLocal Function
PHT_SERVER Example See Also

Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.

Syntax
PRL_HANDLE PrlSrv_LoginLocal(
    PRL_HANDLE hServer,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port,
    PRL_SECURITY_LEVEL security_level
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
port
Port number. Specify 0 (zero) to use the default port.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.
flags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default ( as PrlSrv_LoginLocal() )

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When performing a local login operation, no password/username is needed. The authentication and authorization will be performed using the current user account.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlDispCfg_GetMinSecurityLevel

Example

The following example illustrates how to log in to locally running Parallels Service and to obtain a handle of type PHT_LOGIN_RESPONSE.

// Log in.
hJob = PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );
PrlJob_Wait( hJob, 10000 );

// Get the results of the login operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_SERVER, Example, See Also


PrlSrv_LoginLocalEx Function

PrlSrv_LoginLocalEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_LoginLocalEx(
    PRL_HANDLE hServer,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port,
    PRL_SECURITY_LEVEL security_level,
    PRL_UINT32 flags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_Logoff Function

PrlSrv_Logoff Function
PHT_SERVER

Logs off the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_Logoff(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function logs of the Parallels Service and ends a session that was started with the PrlSrv_Login or the PrlSrv_LoginLocal function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_LookupParallelsServers Function

PrlSrv_LookupParallelsServers Function
PHT_SERVER Example

Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.

Syntax
PRL_HANDLE PrlSrv_LookupParallelsServers(
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiDisp.h

Parameters

timeout
Timeout in milliseconds. The search operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called every time a Parallels Service is found. The function will receive a handle of type PHT_SERVER_INFO containing the Parallels Service information.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function can be executed asynchronously using the callback functionality, or it can be used synchronously.

To use the function asynchronously, you must implement a callback function and pass a pointer to it to this function as a parameter. The callback function will be called for every Parallels Service found, and a handle of type PHT_SERVER_INFO containing the Parallels Service information will be passed to it.

To use this function synchronously, pass a null pointer instead of the callback function pointer, and use PrlJob_Wait to wait for the job to complete. The returned job object will contain a list of PHT_SERVER_INFO objects.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of servers in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each server object.
Example

The following example illustrates how to call the PrlSrv_LookupParallelsServers synchronously.

hJob =
PrlSrv_LookupParallelsServers(
    10000,  // timeout
    NULL,   // callback function (not used)
    NULL    // user object pointer (not used)
);

printf("Searching for Parallels Services...\n");

nRetCode =
PrlJob_Wait(hJob, 100000);

if (PRL_FAILED(nRetCode))
{
    fprintf(stderr, "PrlJob_Wait returned with error: %s.\n",
        PRL_RESULT_TO_STRING( nRetCode));
    PrlApi_Deinit();
    SdkWrap_Unload();
    return nRetCode;
}

PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount(hJobResult, &nCount);

for (nIndex = 0; nIndex < nCount ; nIndex++)
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex(hJobResult, nIndex, &hParam);

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof(sBuf);

    nRetCode =
    PrlSrvInfo_GetHostName(hParam, sBuf, &nBufSize);

    if (PRL_SUCCEEDED(nRetCode))
        printf("Found Service: %s.\n", &sBuf[0]);
    else
        fprintf(stderr, "PrlSrvInfo_GetHostName failed, error: %s. \n",
            PRL_RESULT_TO_STRING(nRetCode));

    PrlHandle_Free(hParam);
}

PrlHandle_Free(hJobResult);

In the following example, the PrlSrv_LookupParallelsServers is called asynchronously. In order to that, we first have to implement a callback function (let's call it ourCallback):

static PRL_RESULT ourCallback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    printf("%s: ", pUserData);

    // Get the name of the host machine.
    PRL_UINT32 nBufSize = 1024;
    PRL_CHAR sBuf[nBufSize];
    PrlSrvInfo_GetHostName(hEvent, sBuf, &nBufSize);

    // Get the other properties and process them here...

    // The handle must be freed.
    PrlHandle_Free(hEvent);
    return rc;
}

The PrlSrv_LookupParallelsServers function can now be called as follows:

hJob =
PrlSrv_LookupParallelsServers(
    1000,
    &ourCallback,
    (PRL_VOID_PTR)("callback")
);
Links
PHT_SERVER, Example


PrlSrv_NetServiceRestart Function

PrlSrv_NetServiceRestart Function
PHT_SERVER

Restarts the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceRestart(
    PRL_HANDLE hServer
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_NetServiceRestoreDefaults Function

PrlSrv_NetServiceRestoreDefaults Function
PHT_SERVER

Restores the default settings of the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceRestoreDefaults(
    PRL_HANDLE hServer
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_NetServiceStart Function

PrlSrv_NetServiceStart Function
PHT_SERVER

Starts the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceStart(
    PRL_HANDLE hServer
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_NetServiceStop Function

PrlSrv_NetServiceStop Function
PHT_SERVER

Stops the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceStop(
    PRL_HANDLE hServer
);
File

PrlApiNet.h

Parameters

unnamed_param
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_ProxyLogin Function

PrlSrv_ProxyLogin Function
PHT_SERVER See Also

Performs a remote proxy login operation using the specified parameters.

Syntax
PRL_HANDLE PrlSrv_ProxyLogin(
    PRL_HANDLE hServer,
    PRL_CONST_STR user,
    PRL_CONST_STR passwd,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level,
    PRL_PROXY_HOST_INFO_PTR hostInfo
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
user
User name (a UTF-8 encoded, null-terminated string).
passwd
Password (a UTF-8 encoded, null-terminated string).
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
timeout
Timeout value in milliseconds. The operation will be automatically interrupted if a connection is not established within this timeframe. Specify 0 (zero) for infinite timeout.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.
hostInfo
Proxy host information to which we want to connect.
flags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default ( as PrlSrv_ProxyLogin() )

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A remote proxy login operation logs the user to a Parallels Service running on a remote host through proxy server. You can also use this function to log to a local host or you can use the PrlSrv_LoginLocal function, which is a simplified version created specifically to perform local host logins.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlSrv_GetRegisteredHostsOnProxy PrlDispCfg_GetMinSecurityLevel

Links
PHT_SERVER, See Also


PrlSrv_ProxyLoginEx Function

PrlSrv_ProxyLoginEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_ProxyLoginEx(
    PRL_HANDLE hServer,
    PRL_CONST_STR user,
    PRL_CONST_STR passwd,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level,
    PRL_PROXY_HOST_INFO_PTR hostInfo,
    PRL_UINT32 flags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_RefreshPlugins Function

PrlSrv_RefreshPlugins Function
PHT_SERVER

Refreshes states of installed parallels plugins.

Syntax
PRL_HANDLE PrlSrv_RefreshPlugins(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_RegEventHandler Function

PrlSrv_RegEventHandler Function
PHT_SERVER

Registers an event handler.

Syntax
PRL_RESULT PrlSrv_RegEventHandler(
    PRL_HANDLE hServer,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
handler
A pointer to a user callback function (event handler).
userData
Optional. A pointer to a user data that will be passed to the callback function.

Remarks

Asynchronous functions return data to the caller by means of a callback function (or event handler). The callback function could be called at any time, depending on how long the asynchronous function takes to complete. The callback function must have a specific signature. The callback function prototype type is PRL_EVENT_HANDLER_PTR. The PrlSrv_RegEventHandler function is used to register an event handler with the specified Parallels Service, PrlSrv_UnregEventHandler is used to unregister an event handler. When an event handler is registered, it will start receiving all events/jobs generated by the Parallels Service. It is the responsibility of the client application to identify and handle the relevant event(s). For more information on events and asynchronous functions, see the Parallels Virtualization SDK Programmer's Guide.

Links
PHT_SERVER


PrlSrv_Register3rdPartyVm Function

PrlSrv_Register3rdPartyVm Function
PHT_SERVER

Registers an existing 3rd party virtual machine with Parallels Service.

Syntax
PRL_HANDLE PrlSrv_Register3rdPartyVm(
    PRL_HANDLE hServer,
    PRL_CONST_STR strVmConfigPath,
    PRL_CONST_STR strVmRootDirPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
strVmConfigPath
[required] An absolute path to the virtual machine configuration file (*.vmx for example)
strVmRootDirPath
[optional] An absolute path to the virtual machine root directory where virtual machine home directory will be created.
nFlags
Flags bitset: 0 - Default behavior PR3F_ALLOW_UNKNOWN_OS

  • to allow undetectable OS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PHT_SERVER


PrlSrv_RegisterVm Function

PrlSrv_RegisterVm Function
PHT_SERVER Example

Registers an existing virtual machine with Parallels Service.

Syntax
PRL_HANDLE PrlSrv_RegisterVm(
    PRL_HANDLE hServer,
    PRL_CONST_STR strVmDirPath,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
strVmDirPath
An absolute path to the virtual machine directory to register.
bNonInteractiveMode
Set to PRL_TRUE to use non-interactive mode. Set to PRL_FALSE to use interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Example

The following sample function demonstrates how to add an existing virtual machine to the Parallels Service. The function takes a handle of type PHT_SERVER and a string specifying the name and path of the virtual machine directory. It registers the virtual machine with the Service and then modifies the MAC address of every virtual network adapter installed in it.

PRL_RESULT RegisterExistingVM(PRL_HANDLE hServer, PRL_CONST_STR sVmDirectory)
{
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;

    // Register the virtual machine with the Parallels Service.
    hJob = PrlSrv_RegisterVm(
        hServer,
        sVmDirectory,
        PRL_TRUE);  // Using non-interactive mode.

    ret = PrlJob_Wait(hJob, 10000);

    // Check the return code of PrlSrv_RegisterVm.
    PrlJob_GetRetCode(hJob, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        printf("PrlSrv_RegisterVm returned error: %s\n",
            prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJob);
        return -1;
    }

    // Obtain the virtual machine handle from the job object.
    // We will use the handle later to modify the virtual machine
    // configuration.
    PRL_HANDLE hVm = PRL_INVALID_HANDLE;
    ret = PrlJob_GetResult(hJob, &hJobResult);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    ret = PrlResult_GetParam(hJobResult, &hVm);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    PrlHandle_Free(hJob);
    PrlHandle_Free(hJobResult);

    printf("Virtual machine '%s' was successfully registered.",
            sVmDirectory);

    // The following code will generate and set a new MAC address
    // for every virtual network adapter that exists in the virtual machine.
    // This step is optional and should normally be performed when the virtual
    // machine is a copy of another virtual machine.

    PRL_HANDLE hJobBeginEdit;
    PRL_HANDLE hJobCommit;

    // Begin the virtual machine editing operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    ret = PrlJob_Wait(hJobBeginEdit, 10000);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Obtain a handle of type PHT_VM_CONFIGURATION containing the
    // virtual machine configuration data.
    PRL_HANDLE hVmCfg = PRL_INVALID_HANDLE;
    ret = PrlVm_GetConfig(hVm, &hVmCfg);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Determine the number of the network adapters
    // installed in the machine.
    PRL_UINT32 nCount = PRL_ERR_UNINITIALIZED;
    ret = PrlVmCfg_GetNetAdaptersCount(hVmCfg, &nCount);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Itereate through the adapter list.
    PRL_HANDLE hNetAdapter = PRL_INVALID_HANDLE;
    for (PRL_UINT32 i = 0; i < nCount; ++i)
    {
        ret = PrlVmCfg_GetNetAdapter(hVmCfg, i, &hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }

        // Automatically generate new MAC address for the current adapter.
        // The address will be updated in the configuration object.
        ret = PrlVmDevNet_GenerateMacAddr(hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }
    }

    // Commit the changes to the virtual machine.
    hJobCommit = PrlVm_Commit(hVm);

    // Check the results of the commit operation.
    ret = PrlJob_Wait(hJobCommit, 10000);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Commit error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }

    PrlHandle_Free(hNetAdapter);
    PrlHandle_Free(hVm);
    PrlHandle_Free(hVmCfg);
    PrlHandle_Free(hJobCommit);
    PrlHandle_Free(hJobBeginEdit);

    return 0;
}
Links
PHT_SERVER, Example


PrlSrv_RegisterVmEx Function

PrlSrv_RegisterVmEx Function
PHT_SERVER

Registers an existing virtual machine with Parallels Service.

Syntax
PRL_HANDLE PrlSrv_RegisterVmEx(
    PRL_HANDLE hServer,
    PRL_CONST_STR strVmDirPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
strVmDirPath
An absolute path the virtual machine directory to register.
nFlags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default ( as PrlSrv_RegisterVm() )

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

PRVF_REGENERATE_VM_UUID
to generate new VM identity after registration.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PHT_SERVER


PrlSrv_RegisterVmWithUuid Function

PrlSrv_RegisterVmWithUuid Function
PHT_SERVER

Registers an existing virtual machine with custom Vm UUID.

Syntax
PRL_HANDLE PrlSrv_RegisterVmWithUuid(
    PRL_HANDLE hServer,
    PRL_CONST_STR strVmDirPath,
    PRL_CONST_STR strVmUuid,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
strVmDirPath
An absolute path the virtual machine directory to register.
strVmUuid
Assign custom Vm uuid
nFlags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default ( as PrlSrv_RegisterVm() )

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PHT_SERVER


PrlSrv_RemoveCtTemplate Function

PrlSrv_RemoveCtTemplate Function
PHT_SERVER

Removes the specified Containers template.

Syntax
PRL_HANDLE PrlSrv_RemoveCtTemplate(
    PRL_HANDLE hServer,
    PRL_CONST_STR sName,
    PRL_CONST_STR sOsTmplName,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sName
Name of template to be removed.
sOsTmplName
Name of OS template for which this application template is. Should be filled for application templates.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_RemoveIPPrivateNetwork Function

PrlSrv_RemoveIPPrivateNetwork Function
PHT_SERVER See Also

Removes an existing private network from the Parallels Service configuration.

Syntax
PRL_HANDLE PrlSrv_RemoveIPPrivateNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hPrivNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hPrivNet
A handle of type PHT_IPPRIV_NET identifying a private network.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_AddIPPrivateNetwork

PrlSrv_GetIPPrivateNetworkList

PrlSrv_UpdateIPPrivateNetwork

Links
PHT_SERVER, See Also


PrlSrv_RemoveVmBackup Function

PrlSrv_RemoveVmBackup Function
PHT_SERVER

Remove backup of the virtual machine from backup server.

Syntax
PRL_HANDLE PrlSrv_RemoveVmBackup(
    PRL_HANDLE hSourceServer,
    PRL_CONST_STR sVmUuid,
    PRL_CONST_STR sBackupUuid,
    PRL_CONST_STR sTargetHost,
    PRL_UINT32 nTargetPort,
    PRL_CONST_STR sTargetSessionId,
    PRL_UINT32 remove_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hSourceServer
A handle of type PHT_SERVER identifying the source Parallels Service.
sVmUuid
A virtual machine uuid
sBackupUuid
A backup uuid
sTargetHost
The name of the target host machine.
nTargetPort
The port number on the target host.
sTargetSessionId
The target Parallels Service session ID.
remove_flags
Flags that specify remove type and etc. Acceptable flags: PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved flags.
force_operation
Specifies to process VM backup action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Notes

errors are the same as for VmMigrate activity

Links
PHT_SERVER


PrlSrv_RestoreVmBackup Function

PrlSrv_RestoreVmBackup Function
PHT_SERVER

Restore backup of the virtual machine from backup server.

Syntax
PRL_HANDLE PrlSrv_RestoreVmBackup(
    PRL_HANDLE hSourceServer,
    PRL_CONST_STR sVmUuid,
    PRL_CONST_STR sBackupUuid,
    PRL_CONST_STR sTargetHost,
    PRL_UINT32 nTargetPort,
    PRL_CONST_STR sTargetSessionId,
    PRL_CONST_STR sTargetVmHomePath,
    PRL_CONST_STR sTargetVmName,
    PRL_UINT32 restore_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hSourceServer
A handle of type PHT_SERVER identifying the source Parallels Service.
sVmUuid
A virtual machine uuid
sBackupUuid
A backup uuid
sTargetHost
The name of the target host machine.
nTargetPort
The port number on the target host.
sTargetSessionId
The target Parallels Service session ID.
sTargetVmHomePath
Home directory of the target virtual machine.
restore_flags
Flags that specify restore type and etc. Acceptable flags:
reserved_flags
Reserved flags.
force_operation
Specifies to process VM backup action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).
PBT_RESTORE_TO_COPY
change Vm name/uuid/MAC address on restore PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Notes

errors are the same as for VmMigrate activity

Links
PHT_SERVER


PrlSrv_SecureLogin Function

PrlSrv_SecureLogin Function
PHT_SERVER See Also

Performs a remote login operation using the specified parameters.

Syntax
PRL_HANDLE PrlSrv_SecureLogin(
    PRL_HANDLE hServer,
    PRL_CONST_STR host,
    PRL_CONST_STR certificate,
    PRL_CONST_STR privateKey,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port_cmd,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level,
    PRL_UINT32 flags
);
File

PrlApiSecurity.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
host
The name or IP address of the host machine (a UTF-8 encoded, null-terminated string).
certificate
User certificate (base64 encoded) (a UTF-8 encoded, null-terminated string).
privateKey
User private key (a UTF-8 encoded, null-terminated string).
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
port_cmd
Port number. Pass 0 (zero) to use the default port.
timeout
Timeout value in milliseconds. The operation will be automatically interrupted if a connection is not established within this timeframe. Specify 0 (zero) for infinite timeout.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.
flags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default)

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A remote login operation logs the user to a Parallels Service running on a remote host using user credentials .You can use the PrlSrv_LoginLocal function, which is a simplified version created specifically to perform local host logins.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlDispCfg_GetMinSecurityLevel

Links
PHT_SERVER, See Also


PrlSrv_SecureProxyLogin Function

PrlSrv_SecureProxyLogin Function
PHT_SERVER See Also

Performs a remote proxy login operation using the specified parameters.

Syntax
PRL_HANDLE PrlSrv_SecureProxyLogin(
    PRL_HANDLE hServer,
    PRL_CONST_STR certificate,
    PRL_CONST_STR privateKey,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level,
    PRL_PROXY_HOST_INFO_PTR hostInfo,
    PRL_UINT32 flags
);
File

PrlApiSecurity.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
certificate
User certificate (base64 encoded) (a UTF-8 encoded, null-terminated string).
privateKey
User private key (a UTF-8 encoded, null-terminated string).
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
timeout
Timeout value in milliseconds. The operation will be automatically interrupted if a connection is not established within this timeframe. Specify 0 (zero) for infinite timeout.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.
hostInfo
Proxy host information to which we want to connect.
flags
A bitset of flags. Allowed next values:

0 - no flags. It's behaviour by default)

PACF_NON_INTERACTIVE_MODE
to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A remote proxy login operation logs the user to a Parallels Service running on a remote host through proxy server. using user credentials. You can use the PrlSrv_LoginLocal function, which is a simplified version created specifically to perform local host logins.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlSrv_GetRegisteredHostsOnProxy PrlDispCfg_GetMinSecurityLevel

Links
PHT_SERVER, See Also


PrlSrv_SendAnswer Function

PrlSrv_SendAnswer Function
PHT_SERVER

Sends an answer to the Parallels Service in response to a question.

Syntax
PRL_HANDLE PrlSrv_SendAnswer(
    PRL_HANDLE hServer,
    PRL_HANDLE hAnswer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hAnswer
A handle of type PHT_EVENT containing the answer.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Some operations have an option to be carried out in interactive mode. This means that the Parallels Service may interrupt an operation and ask client a question about how it would like to proceed. This function allows to send such an answer to the Parallels Service. The answer must be prepared using the PrlEvent_CreateAnswerEvent function before it can be sent to the Parallels Service using this function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_SendProblemReport Function

PrlSrv_SendProblemReport Function
PHT_SERVER

Requests a server to send a problem report with possibility to append also the problem report assemblied at the client's side.

Syntax
PRL_HANDLE PrlSrv_SendProblemReport(
    PRL_HANDLE hServer,
    PRL_HANDLE hProblemReport,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
handle of type PHT_SERVER of the server
hProblemReport
the report assemblied at the client's side
nFlags
flags associated with the operation (see PRL_PROBLEM_REPORT_FLAGS)

Returns

PRL_HANDLE - handle to the job generated

Remarks

The report should be created as follows: 1) with PrlApi_CreateProblemReport call 2) filled with PrlReport_Assembly

Similar calls are PrlApi_SendProblemReport and PrlApi_SendPackedProblemReport, PrlReport_Send

Async response should normally contain report id.

Links
PHT_SERVER


PrlSrv_SetCertificateRevocationDateTime Function

PrlSrv_SetCertificateRevocationDateTime Function
PHT_SERVER

Sets the revocation date time for SSL certificates, used in trusted channel connection.

Syntax
PRL_RESULT PrlSrv_SetCertificateRevocationDateTime(
    PRL_HANDLE hServer,
    PRL_UINT64 nTimeStampUTC
);
File

PrlApiManager.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nTimeStampUTC
Certificate revocation date and time, represented by the number of seconds that have passed since 1970-01-01T00:00:00, Coordinated Universal Time (UTC).

Returns

PRL_RESULT. Possible values are:

PRL_ERR_SUCCESS - operation completed successfully

PRL_ERR_INVALID_ARG - invalid handle.

Links
PHT_SERVER


PrlSrv_SetGlobalDateTime Function

PrlSrv_SetGlobalDateTime Function
PHT_SERVER

Sets the current trusted time, that will be used for SSL certificate check.

Syntax
PRL_RESULT PrlSrv_SetGlobalDateTime(
    PRL_HANDLE hServer,
    PRL_UINT64 nTimeStampUTC
);
File

PrlApiManager.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nTimeStampUTC
Global date and time, represented by the number of seconds that have passed since 1970-01-01T00:00:00, Coordinated Universal Time (UTC).

Returns

PRL_RESULT. Possible values are:

PRL_ERR_SUCCESS - operation completed successfully

PRL_ERR_INVALID_ARG - invalid handle.

Links
PHT_SERVER


PrlSrv_SetNonInteractiveSession Function

PrlSrv_SetNonInteractiveSession Function
PHT_SERVER

Sets the session in noninteractive or interactive mode.

Syntax
PRL_HANDLE PrlSrv_SetNonInteractiveSession(
    PRL_HANDLE hServer,
    PRL_BOOL bNonInteractive,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER.
bNonInteractive
Noninteractive session mode.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_SetVNCEncryption Function

PrlSrv_SetVNCEncryption Function
PHT_SERVER

Set VNC encryption.

Syntax
PRL_HANDLE PrlSrv_SetVNCEncryption(
    PRL_HANDLE hServer,
    PRL_CONST_STR sPubKey,
    PRL_CONST_STR sPrivKey,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

sPubKey
SSL certificate to encrypt the VNC traffic
sPrivKey
SSL private key to encrypt the VNC traffic
hHandle
A handle of type PHT_SERVER.

Returns

A handle of type PHT_JOB containing the results of operation.

Remarks

To delete sertificate the empty sPubKey and sPrivKey should be specified.

Links
PHT_SERVER


PrlSrv_Shutdown Function

PrlSrv_Shutdown Function
PHT_SERVER

Shuts down the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_Shutdown(
    PRL_HANDLE hServer,
    PRL_BOOL bForceShutdown
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
bForceShutdown
Specifies whether the shutdown operation should be forced. The value of PRL_TRUE will force the shutdown; PRL_FALSE will perform a normal shutdown. If one or more virtual machines are running, clients are connected, or some tasks are currently in progress, then forcing the shutdown will stop all processes automatically and shut down the machine.
nFlags
A flags to select shutdown mode( from enum PRL_SRV_SHUTDOWN_FLAGS )

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The current user must have sufficient privileges to execute the Parallels Service shutdown.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_TOKEN_INVALID - the user doesn't have sufficient privileges.

PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT - another user is currently connected to the Parallels Service, the Parallels Service shutdown aborted.

PRL_ERR_SOME_VMS_RUNNING - running virtual machines found, stop the running machines first.

PRL_ERR_SOME_TASKS_PRESENT - running tasks detected, wait for the tasks to finish or cancel them.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_ShutdownEx Function

PrlSrv_ShutdownEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_ShutdownEx(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_StartSearchVms Function

PrlSrv_StartSearchVms Function
PHT_SERVER Example

Searches for unregistered virtual machines at the specified location(s).

Syntax
PRL_HANDLE PrlSrv_StartSearchVms(
    PRL_HANDLE hServer,
    PRL_HANDLE hStringsList
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hStringsList
A handle of type PHT_STRINGS_LIST containing the list of pathnames to search. If the list is empty, all available drives and directories will be included in search scope.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function can be used to search for virtual machines that are not currently registered with the specified Parallels Service but are otherwise valid machines to be registered with it. The virtual machine information is returned as a list of PHT_FOUND_VM_INFO objects. When the function is executed asynchronously using callback functionality, the callback function receives the information as an event of type PET_DSP_EVT_FOUND_LOST_VM_CONFIG.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of virtual machines in the list.
  3. Use the PrlResult_GetParam function to obtain individual handles of type PHT_FOUND_VM_INFO.
Example
PRL_HANDLE hStringList;
PrlApi_CreateStringsList( &hStringList );
PrlStrList_AddItem( hStringList, "/Users/Shared/Parallels/" );

hJob =
PrlSrv_StartSearchVms( hServer, hStringList );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount( hJobResult, &nCount );
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType( hParam, &nHandleType );

    printf( "Handle Type: %s\n",
        PRL_HANDLE_TYPE_TO_STRING( nHandleType ));

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    nRetCode =
    PrlFoundVmInfo_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s\n.", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
PrlHandle_Free( hStringList );
Links
PHT_SERVER, Example


PrlSrv_StopInstallAppliance Function

PrlSrv_StopInstallAppliance Function
PHT_SERVER

Stops the appliance installation previously started with the PrlSrv_InstallAppliance function call.

Syntax
PRL_HANDLE PrlSrv_StopInstallAppliance(
    PRL_HANDLE hServer,
    PRL_HANDLE hAppCfg,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hAppCfg
A handle of type PHT_APPLIANCE_CONFIG identifying the appliance. This must be the same handle instance that was passed to the PrlSrv_InstallAppliance function.
nFlags
Reserved parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_SubscribeToHostStatistics Function

PrlSrv_SubscribeToHostStatistics Function
PHT_SERVER Example

Allows to subscribe to receive host OS statistics on a periodic basis.

Syntax
PRL_HANDLE PrlSrv_SubscribeToHostStatistics(
    PRL_HANDLE hServer
);
File

PrlApiStat.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_HOST_STATISTICS_UPDATED indicate an event containing statistics data. To access the statistics handle (a handle of type PHT_SYSTEM_STATISTICS), first extract the event parameter using PrlEvent_GetParam, then convert the result (which will be a handle to an object of type PHT_EVENT_PARAMETER) to a handle using PrlEvtPrm_ToHandle. The functions that operate on PHT_SYSTEM_STATISTICS references can then be used to obtain statistics data.

For the event handler to be called, it is necessary to register it with PrlSrv_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlSrv_UnsubscribeFromHostStatistics. When events are no longer required, unregister the event handler using PrlSrv_UnregEventHandler.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following is a complete example that demonstrates how to obtain statistics data asynchronously using PrlSrv_SubscribeToHostStatistics. Note that the same code could be used to receive statistics data for a virtual machine, instead of the host computer, by using PrlVm_SubscribeToGuestStatistics instead of PrlSrv_SubscribeToHostStatistics, and passing it a handle to a virtual machine that is running. This would also require using PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics data for the virtual machine.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szServer = "123.123.123.123";
const char *szUsername = "Your Username";
const char *szPassword = "Your Password";

// -------------------------------------------------------------------------
// Event handler.
// -------------------------------------------------------------------------
// 1. Check for events of type PET_DSP_EVT_HOST_STATISTICS_UPDATES.
// 2. Display a header if first call to this event handler.
// 3. Get the event param (PHT_EVENT_PARAMETER) from the PHT_EVENT handle.
// 4. Convert event param to a handle (will be type PHT_SYSTEM_STATISTICS).
// 5. Use PHT_SYSTEM_STATISTICS handle to obtain CPU usage, memory usage,
// and disk usage data.
// -------------------------------------------------------------------------
static PRL_RESULT OurCallback(PRL_HANDLE handle, void *pData)
{
    PRL_HANDLE_TYPE nHandleType;
    PRL_RESULT ret = PrlHandle_GetType(handle, &nHandleType);

    // Check for PrlHandle_GetType error here.
    if (nHandleType == PHT_EVENT)
    {
        PRL_EVENT_TYPE EventType;
        PrlEvent_GetType(handle, &EventType);

        // Check if the event type is a statistics update.
        if (EventType == PET_DSP_EVT_HOST_STATISTICS_UPDATED)
        {
            // Output a header if first call to this function.
            static PRL_BOOL bHeaderHasBeenPrinted = PRL_FALSE;
            if (!bHeaderHasBeenPrinted)
            {
                bHeaderHasBeenPrinted = PRL_TRUE;
                printf("CPU (%%) Used RAM (MB) Free RAM (MB) Used Disk Space (MB)"
                       " Free Disk Space (MB)\n");
                printf("---------------------------------------------------------"
                       "--------------------\n");
            }

            PRL_HANDLE hEventParameters;
            PRL_HANDLE hServerStatistics;

            // Get the event parameter (PHT_EVENT_PARAMETER) from the event handle.
            PrlEvent_GetParam(handle, 0, &hEventParameters);

            // Convert the event parameter to a handle (PHT_SYSTEM_STATISTICS).
            PrlEvtPrm_ToHandle(hEventParameters, &hServerStatistics);

            // Get CPU statistics (usage in %).
            PRL_HANDLE hCpuStatistics;
            ret = PrlStat_GetCpuStat(hServerStatistics, 0, &hCpuStatistics);
            PRL_UINT32 nCpuUsage = 0;
            ret = PrlStatCpu_GetCpuUsage(hCpuStatistics, &nCpuUsage);

            // Get RAM statistics.
            PRL_UINT64 nUsedRam, nFreeRam;
            PrlStat_GetFreeRamSize(hServerStatistics, &nFreeRam);
            PrlStat_GetUsageRamSize(hServerStatistics, &nUsedRam);
            nUsedRam /= (1024 * 1024);
            nFreeRam /= (1024 * 1024);

            // Get disk space statistics.
            PRL_UINT64 nFreeDiskSpace, nUsedDiskSpace;
            PRL_HANDLE hDiskStatistics;
            PrlStat_GetDiskStat(hServerStatistics, 0, &hDiskStatistics);
            PrlStatDisk_GetFreeDiskSpace(hDiskStatistics, &nFreeDiskSpace);
            PrlStatDisk_GetUsageDiskSpace(hDiskStatistics, &nUsedDiskSpace);
            nUsedDiskSpace /= (1024 * 1024);
            nFreeDiskSpace /= (1024 * 1024);

            printf("%7d %10lld %13lld %20lld %20lld\n",
                nCpuUsage, nUsedRam, nFreeRam, nUsedDiskSpace, nFreeDiskSpace);

            PrlHandle_Free(hDiskStatistics);
            PrlHandle_Free(hCpuStatistics);
            PrlHandle_Free(hServerStatistics);
            PrlHandle_Free(hEventParameters);
        }
    }

    PrlHandle_Free(handle);

    return PRL_ERR_SUCCESS;
}

// -------------------------------
// Program entry point.
// -------------------------------

int main(int argc, char* argv[])
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
        return -1;
    }

    // Initialize the Parallels API.
    ret = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING(ret));
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create(&hServer);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (PrlSrv is asynchronous).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer, // PRL_HANDLE of type PHT_SERVER.
            szServer, // Server hostname or IP address.
            szUsername, // Username.
            szPassword, // Password.
            0, // Deprecated - UUID of previous session.
            0, // Optional - port number (0 for default).
            0, // Optional - timeout value (0 for default).
            PSL_LOW_SECURITY); // Security level

    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        printf("Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Login was successful.\n");
    // ----------------------------------------------------------------------------
    // 1. Register our event handler (OurCallback function).
    // 2. Subscribe to host machine statistics events.
    // 3. Keep receiving events until user presses <enter> key.
    // 4. Unsubscribe from statistics events.
    // 5. Un-register out event handler.
    // ----------------------------------------------------------------------------
    PrlSrv_RegEventHandler(hServer, OurCallback, NULL);
    PrlSrv_SubscribeToHostStatistics(hServer);
    char c;
    scanf(&c, 1);
    PrlSrv_UnsubscribeFromHostStatistics(hServer);
    PrlSrv_UnregEventHandler(hServer, OurCallback, NULL);
    // ----------------------------------------------------------------------------

    // Log off.
    hJob = PrlSrv_Logoff(hServer);
    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Logoff was successful.\n");

    // Free handles that are no longer required.
    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    return 0;
}
Links
PHT_SERVER, Example


PrlSrv_SubscribeToPerfStats Function

PrlSrv_SubscribeToPerfStats Function
PHT_SERVER

Allows to subscribe to periodically receive perfomance statistics.

Syntax
PRL_HANDLE PrlSrv_SubscribeToPerfStats(
    PRL_HANDLE hServer,
    PRL_CONST_STR sFilter
);
File

PrlApiStat.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sFilter
String representing statistics filter, use char '*' at the end to get subset of statistic. Could be NULL, to get all statistic. See PrlPerfCounters.h header file in order to determine published performance counters patterns list.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_PERFSTATS_UPDATED indicate an event containing statistics data. The perfomace statistics repesented by parameters of Event object (a handle of type PHT_EVENT).

For the event handler to be called, it is necessary to register it with PrlSrv_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlSrv_UnsubscribeFromHostPerfStats. When events are no longer required, unregister the event handler using PrlSrv_UnregEventHandler.

If method is called more than once, the 'filter' value is updated each time on the Parallels Service side.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_UnregEventHandler Function

PrlSrv_UnregEventHandler Function
PHT_SERVER

Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.

Syntax
PRL_RESULT PrlSrv_UnregEventHandler(
    PRL_HANDLE hServer,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
handler
A pointer to the callback function (event handler) to unregister. This must be the same pointer that was passed to the PrlSrv_RegEventHandler when the event handler was registered with the virtual machine.
userData
A pointer to the user data. This must also be the same pointer that was passed to the PrlSrv_RegEventHandler when the event handler was registered with the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When using callback functionality with asynchronous functions, a callback function is first registered with Parallels Service. When no longer needed (client doesn't want to receive events anymore), the function must by unregistered using the PrlSrv_UnregEventHandler function. The values of the handler and userData parameters constitute a unique pair which will be used to identify the event handler that will be unregistered. Make sure that you supply the same values as the ones you used when you registered the handler. See PrlSrv_SubscribeToHostStatistics for the complete example illustrating event handlers usage.

Links
PHT_SERVER


PrlSrv_UnsubscribeFromHostStatistics Function

PrlSrv_UnsubscribeFromHostStatistics Function
PHT_SERVER

Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.

Syntax
PRL_HANDLE PrlSrv_UnsubscribeFromHostStatistics(
    PRL_HANDLE hServer
);
File

PrlApiStat.h

Parameters

handle
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_UnsubscribeFromPerfStats Function

PrlSrv_UnsubscribeFromPerfStats Function
PHT_SERVER

Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.

Syntax
PRL_HANDLE PrlSrv_UnsubscribeFromPerfStats(
    PRL_HANDLE hServer
);
File

PrlApiStat.h

Parameters

handle
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_UpdateIPPrivateNetwork Function

PrlSrv_UpdateIPPrivateNetwork Function
PHT_SERVER See Also

Updates parameters of an existing private network.

Syntax
PRL_HANDLE PrlSrv_UpdateIPPrivateNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hPrivNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hPrivNet
A handle of type PHT_IPPRIV_NET identifying a private network.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_AddIPPrivateNetwork

PrlSrv_GetIPPrivateNetworksList

PrlSrv_DeleteIPPrivateNetwork

Links
PHT_SERVER, See Also


PrlSrv_UpdateLicense Function

PrlSrv_UpdateLicense Function
PHT_SERVER

Installs Parallels license on the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_UpdateLicense(
    PRL_HANDLE hServer,
    PRL_CONST_STR sKey,
    PRL_CONST_STR sUser,
    PRL_CONST_STR sCompany
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sKey
License key.
sUser
License user name.
sCompany
License company name.
nFlags
Flags ( from enums PRL_UPDATE_LICENSE_FLAGS + PRL_API_COMMAND_FLAGS)

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to

the PHT_RESULT object.

  2. Use the PrlResult_GetParam function to obtain a handle

of type PHT_LICENSE containing the license information.

Links
PHT_SERVER


PrlSrv_UpdateLicenseEx Function

PrlSrv_UpdateLicenseEx Function
PHT_SERVER
Syntax
PRL_HANDLE PrlSrv_UpdateLicenseEx(
    PRL_HANDLE hServer,
    PRL_CONST_STR sKey,
    PRL_CONST_STR sUser,
    PRL_CONST_STR sCompany,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Links
PHT_SERVER


PrlSrv_UpdateNetworkClassesList Function

PrlSrv_UpdateNetworkClassesList Function
PHT_SERVER See Also

Update network class classes configuration.

Syntax
PRL_HANDLE PrlSrv_UpdateNetworkClassesList(
    PRL_HANDLE hServer,
    PRL_HANDLE hNetworkClassesList,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.
hNetworkClassList
A handle of type PHT_HANDLES_LIST contains the list of handles of type PHT_NETWORK_CLASS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_GetNetworkClassesList

Links
PHT_SERVER, See Also


PrlSrv_UpdateNetworkShapingConfig Function

PrlSrv_UpdateNetworkShapingConfig Function
PHT_SERVER See Also

Update the network shaping configuration.

Syntax
PRL_HANDLE PrlSrv_UpdateNetworkShapingConfig(
    PRL_HANDLE hServer,
    PRL_HANDLE hNetworkShapingConfig,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hNetworkShapingConfig
A handle of type PHT_NETWORK_SHAPING_CONFIG.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_GetNetworkShapingConfig

Links
PHT_SERVER, See Also


PrlSrv_UpdateOfflineService Function

PrlSrv_UpdateOfflineService Function
PHT_SERVER See Also

Add/Updates parameters of an offline management service.

Syntax
PRL_HANDLE PrlSrv_UpdateOfflineService(
    PRL_HANDLE hServer,
    PRL_HANDLE hOffmgmtService,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hOffmgmtService
A handle of type PHT_OFFLINE_SERVICE identifying a offline management service
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_DeleteOfflineService

PrlSrv_GetOfflineServicesList

Links
PHT_SERVER, See Also


PrlSrv_UpdateSessionInfo Function

PrlSrv_UpdateSessionInfo Function
PHT_SERVER

Updates parameters of opened session.

Syntax
PRL_HANDLE PrlSrv_UpdateSessionInfo(
    PRL_HANDLE hServer,
    PRL_HANDLE hSessionInfo,
    PRL_UINT32 nFlags
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hSessionInfo
A handle of type PHT_SESSION_INFO identifying a session info.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_UpdateVirtualNetwork Function

PrlSrv_UpdateVirtualNetwork Function
PHT_SERVER See Also

Updates parameters of an existing virtual network.

Syntax
PRL_HANDLE PrlSrv_UpdateVirtualNetwork(
    PRL_HANDLE hServer,
    PRL_HANDLE hVirtNet,
    PRL_UINT32 nFlags
);
File

PrlApiNet.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying a virtual network.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_AddVirtualNetwork

PrlSrv_GetVirtualNetworkList

PrlSrv_DeleteVirtualNetwork

Links
PHT_SERVER, See Also


PrlSrv_UserProfileBeginEdit Function

PrlSrv_UserProfileBeginEdit Function
PHT_SERVER

Timestamps the beginning of the user profile editing operation.

Syntax
PRL_HANDLE PrlSrv_UserProfileBeginEdit(
    PRL_HANDLE hServer
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Every modification to the user profile (see PHT_USER_PROFILE) must begin with this function call. The function, together with the PrlSrv_UserProfileCommit function, is used to detect collisions with other clients trying to modify the profile of the same user at the same time. The function does not lock the profile being edited. If a collision is detected on commit, the changes are rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - the user does not have sufficient rights to perform this task.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrv_UserProfileCommit Function

PrlSrv_UserProfileCommit Function
PHT_SERVER

Saves (commits) user profile changes to the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_UserProfileCommit(
    PRL_HANDLE hServer,
    PRL_HANDLE hUserProfile
);
File

PrlApiDisp.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hUserProfile
A handle of type PHT_USER_PROFILE containing the user information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Every modification to the user profile (see PHT_USER_PROFILE) must begin with the PrlSrv_UserProfileBeginEdit function call. The function, together with the PrlSrv_UserProfileCommit function, is used to detect collisions with other client trying to modify the profile of the same user at the same time. The function does not lock the profile being edited. If a collision is detected on commit, the changes are rejected. Otherwise, the changes are saved to the Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER


PrlSrvCfg_Create Function

PrlSrvCfg_Create Function
PHT_SERVER_CONFIG

Creates a new handle of type PHT_SERVER_CONFIG.

Syntax
PRL_RESULT PrlSrvCfg_Create(
    PRL_HANDLE_PTR handle
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to create and configure a server hardware information

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuCount Function

PrlSrvCfg_GetCpuCount Function
PHT_SERVER_CONFIG

Determines the number of CPUs on the host machine.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnCpuCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuFeatures Function

PrlSrvCfg_GetCpuFeatures Function
PHT_SERVER_CONFIG

To get the CPU features from server hSrvConfig : A handle of type PRL_HANDLE.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuFeatures(
    PRL_HANDLE hSrvConfig,
    PRL_CPU_FEATURES_PTR pCpuFeatures
);
File

PrlApiDisp.h

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Remarks

pMasks: [out] A pointer structure with processor features set

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuFeaturesEx Function

PrlSrvCfg_GetCpuFeaturesEx Function
PHT_SERVER_CONFIG

Allows to get the CPU features from server.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuFeaturesEx(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phCpuFeatures
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
phCpuFeatures
A pointer to a variable that receives a handle of type PHT_CPU_FEATURES.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate new object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuFeaturesMaskingCapabilities Function

PrlSrvCfg_GetCpuFeaturesMaskingCapabilities Function
PHT_SERVER_CONFIG

Allows to get the CPU features masking capabilities from server

Syntax
PRL_RESULT PrlSrvCfg_GetCpuFeaturesMaskingCapabilities(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phCpuFeatures
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
phCpuFeatures
A pointer to a variable that receives a handle of type PHT_CPU_FEATURES.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate new object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuHvt Function

PrlSrvCfg_GetCpuHvt Function
PHT_SERVER_CONFIG

Determines the hardware virtualization type of the host CPU.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuHvt(
    PRL_HANDLE hSrvConfig,
    PRL_CPU_HVT_PTR pnCpuHvt
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuMode Function

PrlSrvCfg_GetCpuMode Function
PHT_SERVER_CONFIG

Determines the CPU mode (32 bit or 64 bit) on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuMode(
    PRL_HANDLE hSrvConfig,
    PRL_CPU_MODE_PTR pnCpuMode
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuModel Function

PrlSrvCfg_GetCpuModel Function
PHT_SERVER_CONFIG

Determines the model of CPU on the host machine.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuModel(
    PRL_HANDLE hSrvConfig,
    PRL_STR sCpuModel,
    PRL_UINT32_PTR pnCpuModelBufLength
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
sCpuModel
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnCpuModelBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuSpeed Function

PrlSrvCfg_GetCpuSpeed Function
PHT_SERVER_CONFIG

Determines the host machine CPU speed.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuSpeed(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnCpuSpeed
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuSpeed
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetDefaultGateway Function

PrlSrvCfg_GetDefaultGateway Function
PHT_SERVER_CONFIG

Obtains the global default gateway address of the specified host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetDefaultGateway(
    PRL_HANDLE hSrvConfig,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS gateway address, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS gateway address, use the PrlVmGuest_GetNetworkSettings function.
sDefaultGateway
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetDefaultGatewayIPv6 Function

PrlSrvCfg_GetDefaultGatewayIPv6 Function
PHT_SERVER_CONFIG

Obtains the global default IPv6 gateway address of the specified host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetDefaultGatewayIPv6(
    PRL_HANDLE hSrvConfig,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS gateway address, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS gateway address, use the PrlVmGuest_GetNetworkSettings function.
sDefaultGateway
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetDnsServers Function

PrlSrvCfg_GetDnsServers Function
PHT_SERVER_CONFIG

Obtains the list of IP addresses of DNS servers for the specified host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetDnsServers(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS information, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS information, use the PrlVmGuest_GetNetworkSettings function.
phDnsServersList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the IP addresses of DNS servers.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetFloppyDisk Function

PrlSrvCfg_GetFloppyDisk Function
PHT_SERVER_CONFIG

Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetFloppyDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the drive (beginning with 0). The number of drives in the list can be determined by making the PrlSrvCfg_GetFloppyDisksCount function call.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the drive information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetFloppyDisksCount Function

PrlSrvCfg_GetFloppyDisksCount Function
PHT_SERVER_CONFIG

Determines the number of floppy disk drives on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetFloppyDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnFloppyDisksCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnFloppyDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericPciDevice Function

PrlSrvCfg_GetGenericPciDevice Function
PHT_SERVER_CONFIG See Also

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a PCI device installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericPciDevice(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the GenericPciDevice (beginning with 0). To get the number of installed generic PCI devices, use the PrlSrvCfg_GetGenericPciDevicesCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the generic PCI device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrvCfg_GetGenericPciDevicesCount

Links
PHT_SERVER_CONFIG, See Also


PrlSrvCfg_GetGenericPciDevicesCount Function

PrlSrvCfg_GetGenericPciDevicesCount Function
PHT_SERVER_CONFIG See Also

Determines the number of PCI devices installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericPciDevicesCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnGenericPciDevicesCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnGenericPciDevicesCount
[out] A pointer to a variable that receives the number of devices

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrvCfg_GetGenericPciDevice

Links
PHT_SERVER_CONFIG, See Also


PrlSrvCfg_GetGenericScsiDevice Function

PrlSrvCfg_GetGenericScsiDevice Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericScsiDevice(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the GenericScsiDevice (beginning with 0). To get the number of installed generic SCSI devices, use the PrlSrvCfg_GetGenericScsiDevicesCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the generic SCSI device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericScsiDevicesCount Function

PrlSrvCfg_GetGenericScsiDevicesCount Function
PHT_SERVER_CONFIG

Determines the number of generic SCSI devices installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericScsiDevicesCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnGenericScsiDevicesCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnGenericScsiDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHardDisk Function

PrlSrvCfg_GetHardDisk Function
PHT_SERVER_CONFIG

Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHardDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the drive (beginning with 0). The number of drives in the list can be determined by making the PrlSrvCfg_GetHardDisksCount function call.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_HARD_DISK containing the drive information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHardDisksCount Function

PrlSrvCfg_GetHardDisksCount Function
PHT_SERVER_CONFIG

Determines the number of hard disk drives on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHardDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHardDisksCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHardDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostname Function

PrlSrvCfg_GetHostname Function
PHT_SERVER_CONFIG

Returns the hostname of the specified host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetHostname(
    PRL_HANDLE hSrvConfig,
    PRL_STR sHostname,
    PRL_UINT32_PTR pnHostnameBufLength
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS information, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS information, use the PrlVmGuest_GetNetworkSettings function.
sHostname
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostnameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsMajor Function

PrlSrvCfg_GetHostOsMajor Function
PHT_SERVER_CONFIG

Returns the major version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsMajor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsMajor
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsMajor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsMinor Function

PrlSrvCfg_GetHostOsMinor Function
PHT_SERVER_CONFIG

Returns the minor version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsMinor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsMinor
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsMinor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsStrPresentation Function

PrlSrvCfg_GetHostOsStrPresentation Function
PHT_SERVER_CONFIG

Returns the full host operating system information as a single string.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsStrPresentation(
    PRL_HANDLE hSrvConfig,
    PRL_STR sHostOsStrPresentation,
    PRL_UINT32_PTR pnHostOsStrPresentationBufLength
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
sHostOsStrPresentation
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostOsStrPresentationBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsSubMinor Function

PrlSrvCfg_GetHostOsSubMinor Function
PHT_SERVER_CONFIG

Returns the sub-minor version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsSubMinor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsSubMinor
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsSubMinor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsType Function

PrlSrvCfg_GetHostOsType Function
PHT_SERVER_CONFIG

Returns the host operating system type.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsType(
    PRL_HANDLE hSrvConfig,
    PRL_HOST_OS_TYPE_PTR pnHostOsType
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetHostRamSize Function

PrlSrvCfg_GetHostRamSize Function
PHT_SERVER_CONFIG

Determines the amount of memory (RAM) available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHostRamSize(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostRamSize
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostRamSize
[out] A pointer to a variable that receives the result. The memory size is specified in Megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetMaxHostNetAdapters Function

PrlSrvCfg_GetMaxHostNetAdapters Function
PHT_SERVER_CONFIG

Returns max possible Parallels network adapters on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetMaxHostNetAdapters(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnMaxNetAdaptersCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnMaxNetAdaptersCount
[out] A pointer to a variable that receives the result. Null value (0) means that remote Parallels server doesn't supported this interface.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetMaxVmNetAdapters Function

PrlSrvCfg_GetMaxVmNetAdapters Function
PHT_SERVER_CONFIG

Returns max possible Parallels virtual network adapters which can be applied per VM.

Syntax
PRL_RESULT PrlSrvCfg_GetMaxVmNetAdapters(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnMaxNetAdaptersCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnMaxNetAdaptersCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetNetAdapter Function

PrlSrvCfg_GetNetAdapter Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_NET_ADAPTER containing information about a network adapter installed in the host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetNetAdapter(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS information, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS information, use the PrlVmGuest_GetNetworkSettings function.
nIndex
A numeric index identifying the network adapter (beginning with 0). To get the number of adapters available, use the PrlSrvCfg_GetNetAdaptersCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_NET_ADAPTER containing the network adapter information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetNetAdaptersCount Function

PrlSrvCfg_GetNetAdaptersCount Function
PHT_SERVER_CONFIG

Determines the number of network adapters available on the server.

Syntax
PRL_RESULT PrlSrvCfg_GetNetAdaptersCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnNetAdaptersCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnNetAdaptersCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetOpticalDisk Function

PrlSrvCfg_GetOpticalDisk Function
PHT_SERVER_CONFIG

Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetOpticalDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the optical disk (beginning with 0). To get the number of disks available, use the PrlSrvCfg_GetOpticalDisksCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the disk information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetOpticalDisksCount Function

PrlSrvCfg_GetOpticalDisksCount Function
PHT_SERVER_CONFIG

Determines the number of optical disks on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetOpticalDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnOpticalDisksCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnOpticalDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetParallelPort Function

PrlSrvCfg_GetParallelPort Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer port on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetParallelPort(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the port (beginning with 0). To get the number ports available, use the PrlSrvCfg_GetParallelPortsCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the port information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetParallelPortsCount Function

PrlSrvCfg_GetParallelPortsCount Function
PHT_SERVER_CONFIG

Determines the number of printer ports on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetParallelPortsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnParallelPortsCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnParallelPortsCount
[out] A pointer to a variable that receives the result

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetPrinter Function

PrlSrvCfg_GetPrinter Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetPrinter(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the printer (beginning with 0). To get the number of installed printers, use the PrlSrvCfg_GetPrintersCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the printer information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetPrintersCount Function

PrlSrvCfg_GetPrintersCount Function
PHT_SERVER_CONFIG

Determines the number of printers installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetPrintersCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnPrintersCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnPrintersCount
[out] A pointer to a variable that receives the

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSearchDomains Function

PrlSrvCfg_GetSearchDomains Function
PHT_SERVER_CONFIG

Obtains the list of search domains for the specified host or guest.

Syntax
PRL_RESULT PrlSrvCfg_GetSearchDomains(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApiDisp.h

Parameters

phSearchDomainsList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of search domains.
hNetAdapter
A handle of type PHT_SERVER_CONFIG. When obtaining the host OS information, use the PrlSrv_GetSrvConfig to obtain the handle. When obtaining the guest OS information, use the PrlVmGuest_GetNetworkSettings function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSerialPort Function

PrlSrvCfg_GetSerialPort Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSerialPort(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the port (beginning with 0). To get the number of ports available, use the PrlSrvCfg_GetSerialPortsCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the port information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSerialPortsCount Function

PrlSrvCfg_GetSerialPortsCount Function
PHT_SERVER_CONFIG

Determines the number of serial ports available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSerialPortsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSerialPortsCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSerialPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundMixerDev Function

PrlSrvCfg_GetSoundMixerDev Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundMixerDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the sound mixer device (beginning with 0). To get the number of devices available, use the PrlSrvCfg_GetSoundMixerDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundMixerDevsCount Function

PrlSrvCfg_GetSoundMixerDevsCount Function
PHT_SERVER_CONFIG

Determines the number of sound mixer devices available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundMixerDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSoundMixerDevsCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSoundMixerDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundOutputDev Function

PrlSrvCfg_GetSoundOutputDev Function
PHT_SERVER_CONFIG

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundOutputDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the sound device (beginning with 0). To get the number of sound devices available, use the PrlSrvCfg_GetSoundOutputDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundOutputDevsCount Function

PrlSrvCfg_GetSoundOutputDevsCount Function
PHT_SERVER_CONFIG

Determines the number of sound devices available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundOutputDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSoundOutputDevsCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSoundOutputDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetUsbDev Function

PrlSrvCfg_GetUsbDev Function
PHT_SERVER_CONFIG

Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetUsbDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the device (beginning with 0). To get the number of USB devices available, use the PrlSrvCfg_GetUsbDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_GetUsbDevsCount Function

PrlSrvCfg_GetUsbDevsCount Function
PHT_SERVER_CONFIG

Determines the number of USB devices on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetUsbDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnUsbDevsCount
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnUsbDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_IsSoundDefaultEnabled Function

PrlSrvCfg_IsSoundDefaultEnabled Function
PHT_SERVER_CONFIG

Determines whether a sound device on the host is enabled or disabled.

Syntax
PRL_RESULT PrlSrvCfg_IsSoundDefaultEnabled(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbSoundDefaultEnabled
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbSoundDefaultEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the device is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_IsUsbSupported Function

PrlSrvCfg_IsUsbSupported Function
PHT_SERVER_CONFIG

Determines if USB is supported on the host.

Syntax
PRL_RESULT PrlSrvCfg_IsUsbSupported(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbUsbSupported
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbUsbSupported
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that USB is supported. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfg_IsVtdSupported Function

PrlSrvCfg_IsVtdSupported Function
PHT_SERVER_CONFIG

Determines whether VT-d is supported on the host.

Syntax
PRL_RESULT PrlSrvCfg_IsVtdSupported(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbVtdSupported
);
File

PrlApiDisp.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbVtdSupported
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that VT-d is supported. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvCfgDev_GetDeviceState Function

PrlSrvCfgDev_GetDeviceState Function
PHT_HW_GENERIC_DEVICE See Also

Determines whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.

Syntax
PRL_RESULT PrlSrvCfgDev_GetDeviceState(
    PRL_HANDLE hGenericDevice,
    PRL_GENERIC_DEVICE_STATE_PTR pnDeviceState
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pnDeviceState
[out] A pointer to a variable that receives the currently set device access preference.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Intel Vt-d) or a USB device.

See Also

PrlSrvCfgDev_SetDeviceState

Links
PHT_HW_GENERIC_DEVICE, See Also


PrlSrvCfgDev_GetId Function

PrlSrvCfgDev_GetId Function
PHT_HW_GENERIC_DEVICE

Obtains the device ID.

Syntax
PRL_RESULT PrlSrvCfgDev_GetId(
    PRL_HANDLE hGenericDevice,
    PRL_STR sDevId,
    PRL_UINT32_PTR pnDevIdBufLength
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
sDevId
[out] A pointer to a buffer that receives the device ID (a UTF-8 encoded, null-terminated string)
pnDevIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_GetName Function

PrlSrvCfgDev_GetName Function
PHT_HW_GENERIC_DEVICE

Obtains the device name.

Syntax
PRL_RESULT PrlSrvCfgDev_GetName(
    PRL_HANDLE hGenericDevice,
    PRL_STR sDevName,
    PRL_UINT32_PTR pnDevNameBufLength
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
sDevName
[out] A pointer to a buffer that receives the device name (a UTF-8 encoded, null-terminated string).
pnDevNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_GetType Function

PrlSrvCfgDev_GetType Function
PHT_HW_GENERIC_DEVICE

Obtains the device type.

Syntax
PRL_RESULT PrlSrvCfgDev_GetType(
    PRL_HANDLE hGenericDevice,
    PRL_DEVICE_TYPE_PTR pnDevType
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pnDevType
[out] A pointer to a variable that receives the device type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_IsConnectedToVm Function

PrlSrvCfgDev_IsConnectedToVm Function
PHT_HW_GENERIC_DEVICE

Determines whether the device is connected to a virtual machine.

Syntax
PRL_RESULT PrlSrvCfgDev_IsConnectedToVm(
    PRL_HANDLE hGenericDevice,
    PRL_BOOL_PTR pbConnected
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pbConnected
[out] A pointer to a variable that receives the device connection status.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_SetDeviceState Function

PrlSrvCfgDev_SetDeviceState Function
PHT_HW_GENERIC_DEVICE See Also

Allows to specify whether a virtual machine can directly use a device, such as a PCI device through IOMMU technology (e.g.

Syntax
PRL_RESULT PrlSrvCfgDev_SetDeviceState(
    PRL_HANDLE hGenericDevice,
    PRL_GENERIC_DEVICE_STATE nDeviceState
);
File

PrlApiDisp.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pnDeviceState
The device access preference.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Intel Vt-d) or a USB device. When using this function to set a PCI device access, the PrlSrv_ConfigureGenericPci function needs to be called afterwards to apply the changes to the Parallels Service preferences.

See Also

PrlSrvCfgDev_GetDeviceState

Links
PHT_HW_GENERIC_DEVICE, See Also


PrlSrvCfgHdd_GetDevId Function

PrlSrvCfgHdd_GetDevId Function
PHT_HW_HARD_DISK

Returns the hard disk device id.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevId(
    PRL_HANDLE hHardDisk,
    PRL_STR sDevId,
    PRL_UINT32_PTR pnDevIdBufLength
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
sDevId
[out] Pointer to a buffer that receives the device ID (a UTF-8 encoded, null-terminated string).
pnDevIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDevName Function

PrlSrvCfgHdd_GetDevName Function
PHT_HW_HARD_DISK

Returns the hard disk device name.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevName(
    PRL_HANDLE hHardDisk,
    PRL_STR sDevName,
    PRL_UINT32_PTR pnDevNameBufLength
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
sDevName
[out] Pointer to a buffer that receives the device name (a UTF-8 encoded, null-terminated string).
pnDevNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDevSize Function

PrlSrvCfgHdd_GetDevSize Function
PHT_HW_HARD_DISK

Returns the size of the hard disk device.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevSize(
    PRL_HANDLE hHardDisk,
    PRL_UINT64_PTR pnSize
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnSize
[out] Pointer to a variable that receives the hard disk size. The size is specified in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDiskIndex Function

PrlSrvCfgHdd_GetDiskIndex Function
PHT_HW_HARD_DISK

Returns the index of a hard disk device.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDiskIndex(
    PRL_HANDLE hHardDisk,
    PRL_UINT32_PTR pnIndex
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnIndex
[out] Pointer to a variable that receives the hard disk index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetPart Function

PrlSrvCfgHdd_GetPart Function
PHT_HW_HARD_DISK

Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetPart(
    PRL_HANDLE hHardDisk,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPart
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
nIndex
An index of the hard disk partition for which you would like to obtain a handle. Partitions are index beginning with 0 (zero). The total number of partitions can be obtained by calling the PrlSrvCfgHdd_GetPartsCount function.
phPart
[out] A pointer to a handle of type PHT_HW_HARD_DISK_PARTITION identifying the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetPartsCount Function

PrlSrvCfgHdd_GetPartsCount Function
PHT_HW_HARD_DISK

Returns the number of partitions available on a hard drive.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetPartsCount(
    PRL_HANDLE hHardDisk,
    PRL_UINT32_PTR pnPartsCount
);
File

PrlApiDisp.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnPartsCount
[out] A pointer to a variable receiving the number of partitions.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function together with the PrlSrvCfgHdd_GetPart function to obtain a handle to an object containing a hard disk partition information.

Links
PHT_HW_HARD_DISK


PrlSrvCfgHddPart_GetIndex Function

PrlSrvCfgHddPart_GetIndex Function
PHT_HW_HARD_DISK_PARTITION

Returns the index of the specified hard disk partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetIndex(
    PRL_HANDLE hPart,
    PRL_UINT32_PTR pnIndex
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnIndex
[out] Pointer to a variable that receives the partition index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Partition index uniquely identifies a partition on a hard disk.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetName Function

PrlSrvCfgHddPart_GetName Function
PHT_HW_HARD_DISK_PARTITION

Returns a hard disk partition name.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetName(
    PRL_HANDLE hPart,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
sName
[out] Pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetSize Function

PrlSrvCfgHddPart_GetSize Function
PHT_HW_HARD_DISK_PARTITION

Returns the hard disk partition size.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetSize(
    PRL_HANDLE hPart,
    PRL_UINT64_PTR pnSize
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnSize
[out] Pointer to a buffer that receives the partition size. The size is specified in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetSysName Function

PrlSrvCfgHddPart_GetSysName Function
PHT_HW_HARD_DISK_PARTITION

Returns a hard disk partition system name.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetSysName(
    PRL_HANDLE hPart,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApiDisp.h

Parameters

hPart
A handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
sSysName
[out] Pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetType Function

PrlSrvCfgHddPart_GetType Function
PHT_HW_HARD_DISK_PARTITION

Returns a numerical code identifying the type of the specified partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetType(
    PRL_HANDLE hPart,
    PRL_UINT32_PTR pnType
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnType
[out] Pointer to a variable that receives a numerical code identifying the partition type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsActive Function

PrlSrvCfgHddPart_IsActive Function
PHT_HW_HARD_DISK_PARTITION

Determines whether a disk partition is active or inactive.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsActive(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbActive
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbActive
[out] Pointer to a variable that receives the return value. PRL_TRUE indicates that the partition is active. PRL_FALSE indicates that the partition is inactive.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsInUse Function

PrlSrvCfgHddPart_IsInUse Function
PHT_HW_HARD_DISK_PARTITION

Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsInUse(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbInUse
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbInUse
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that the partition is in use. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsLogical Function

PrlSrvCfgHddPart_IsLogical Function
PHT_HW_HARD_DISK_PARTITION

Determines whether the specified partition is a logical partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsLogical(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbLogical
);
File

PrlApiDisp.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbLogical
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that this is a logical partition. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgNet_GetDefaultGateway Function

PrlSrvCfgNet_GetDefaultGateway Function
PHT_HW_NET_ADAPTER

Returns the default gateway address for the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetDefaultGateway(
    PRL_HANDLE hNetAdapter,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
sDefaultGateway
[out] Pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetDefaultGatewayIPv6 Function

PrlSrvCfgNet_GetDefaultGatewayIPv6 Function
PHT_HW_NET_ADAPTER

Returns the default IPv6 gateway address for the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetDefaultGatewayIPv6(
    PRL_HANDLE hNetAdapter,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
sDefaultGateway
[out] Pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetDnsServers Function

PrlSrvCfgNet_GetDnsServers Function
PHT_HW_NET_ADAPTER

Obtains a list of addresses of DNS servers assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetDnsServers(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phDnsServersList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of addresses.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetMacAddress Function

PrlSrvCfgNet_GetMacAddress Function
PHT_HW_NET_ADAPTER

Returns the MAC address of the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetMacAddress(
    PRL_HANDLE hNetAdapter,
    PRL_STR sMacAddress,
    PRL_UINT32_PTR pnMacAddressBufLength
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
sMacAddress
[out] Pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetNetAdapterType Function

PrlSrvCfgNet_GetNetAdapterType Function
PHT_HW_NET_ADAPTER

Returns a network adapter type.

Syntax
PRL_RESULT PrlSrvCfgNet_GetNetAdapterType(
    PRL_HANDLE hNetAdapter,
    PRL_HW_INFO_NET_ADAPTER_TYPE_PTR pnNetAdapterType
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pnNetAdapterType
[out] A pointer to a variable that receives the network adapter type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetNetAddresses Function

PrlSrvCfgNet_GetNetAddresses Function
PHT_HW_NET_ADAPTER

Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetNetAddresses(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phNetAddressesList
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phNetAddressesList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the addresses.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetSearchDomains Function

PrlSrvCfgNet_GetSearchDomains Function
PHT_HW_NET_ADAPTER

Obtains a list of search domains assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetSearchDomains(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phSearchDomainsList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of search domains.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetSysIndex Function

PrlSrvCfgNet_GetSysIndex Function
PHT_HW_NET_ADAPTER

Returns a network adapter system index.

Syntax
PRL_RESULT PrlSrvCfgNet_GetSysIndex(
    PRL_HANDLE hNetAdapter,
    PRL_UINT32_PTR pnSysIndex
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pnSysIndex
[out] A pointer to a variable that receives the adapter index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A system index uniquely identifies an adapter on a physical host.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetVlanTag Function

PrlSrvCfgNet_GetVlanTag Function
PHT_HW_NET_ADAPTER

Returns the VLAN tag of the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetVlanTag(
    PRL_HANDLE hNetAdapter,
    PRL_UINT16_PTR pnVlanTag
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
pnVlanTag
[out] The buffer for storing result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Since the same physical adapter can be used at several virtual networks pair can identify adapter.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_IsConfigureWithDhcp Function

PrlSrvCfgNet_IsConfigureWithDhcp Function
PHT_HW_NET_ADAPTER

Determines whether the adapter network settings are configured through DHCP.

Syntax
PRL_RESULT PrlSrvCfgNet_IsConfigureWithDhcp(
    PRL_HANDLE hNetAdapter,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the adapter settings are configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_IsConfigureWithDhcpIPv6 Function

PrlSrvCfgNet_IsConfigureWithDhcpIPv6 Function
PHT_HW_NET_ADAPTER

Determines whether the adapter IPv6 network settings are configured through DHCP.

Syntax
PRL_RESULT PrlSrvCfgNet_IsConfigureWithDhcpIPv6(
    PRL_HANDLE hNetAdapter,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the adapter settings are configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgNet_IsEnabled Function

PrlSrvCfgNet_IsEnabled Function
PHT_HW_NET_ADAPTER

Determines whether the adapter is enabled or disabled.

Syntax
PRL_RESULT PrlSrvCfgNet_IsEnabled(
    PRL_HANDLE hNetAdapter,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiDisp.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the adapter is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_NET_ADAPTER


PrlSrvCfgPci_GetDeviceClass Function

PrlSrvCfgPci_GetDeviceClass Function
PHT_HW_GENERIC_PCI_DEVICE

Obtains the class of the PCI device (network, display, sound, etc.).

Syntax
PRL_RESULT PrlSrvCfgPci_GetDeviceClass(
    PRL_HANDLE hGenericPci,
    PRL_GENERIC_PCI_DEVICE_CLASS_PTR pnGenericPciClass
);
File

PrlApiDisp.h

Parameters

hGenericPci
A valid handle of type PHT_HW_GENERIC_PCI_DEVICE identifying the adapter.
pnGenericPciClass
[out] A pointer to a variable that receives the PCI device class.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_HW_GENERIC_PCI_DEVICE


PrlSrvCfgPci_IsPrimaryDevice Function

PrlSrvCfgPci_IsPrimaryDevice Function
PHT_SERVER_CONFIG

Determines whether a specified PCI device (network adapter, display adapter, sound card, etc.) is the primary adapter in the system.

Syntax
PRL_RESULT PrlSrvCfgPci_IsPrimaryDevice(
    PRL_HANDLE hGenericPci,
    PRL_BOOL_PTR pbIsPrimaryDevice
);
File

PrlApiDisp.h

Parameters

hGenericPci
A valid handle of type PHT_HW_GENERIC_PCI_DEVICE identifying the adapter.
pbIsPrimaryDevice
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the PCI device is primary.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_CONFIG


PrlSrvInfo_GetApplicationMode Function

PrlSrvInfo_GetApplicationMode Function
PHT_SERVER_INFO

Returns the application mode of server.

Syntax
PRL_RESULT PrlSrvInfo_GetApplicationMode(
    PRL_HANDLE hServerInfo,
    PRL_APPLICATION_MODE_PTR pnApplicationMode
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
pnAppMode
[out] A pointer to a variable that receives the server application mode.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetCmdPort Function

PrlSrvInfo_GetCmdPort Function
PHT_SERVER_INFO

Returns the port number at which the Parallels Service is listening for requests.

Syntax
PRL_RESULT PrlSrvInfo_GetCmdPort(
    PRL_HANDLE hServerInfo,
    PRL_UINT32_PTR pnPort
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
pnPort
[out] A pointer to a variable that receives the port number.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetHostName Function

PrlSrvInfo_GetHostName Function
PHT_SERVER_INFO

Returns the name of the machine hosting the specified Parallels Service.

Syntax
PRL_RESULT PrlSrvInfo_GetHostName(
    PRL_HANDLE hServerInfo,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetOsVersion Function

PrlSrvInfo_GetOsVersion Function
PHT_SERVER_INFO

Returns the version of the host operating system.

Syntax
PRL_RESULT PrlSrvInfo_GetOsVersion(
    PRL_HANDLE hServerInfo,
    PRL_STR sOsVersion,
    PRL_UINT32_PTR pnOsVersionBufLength
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sOsVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOsVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetProductVersion Function

PrlSrvInfo_GetProductVersion Function
PHT_SERVER_INFO

Returns the Parallels product version number.

Syntax
PRL_RESULT PrlSrvInfo_GetProductVersion(
    PRL_HANDLE hServerInfo,
    PRL_STR sProductVersion,
    PRL_UINT32_PTR pnProductVersionBufLength
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sProductVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnProductVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetServerUuid Function

PrlSrvInfo_GetServerUuid Function
PHT_SERVER_INFO

Returns the host machine UUID (universally unique ID).

Syntax
PRL_RESULT PrlSrvInfo_GetServerUuid(
    PRL_HANDLE hServerInfo,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sServerUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SERVER_INFO


PrlSrvInfo_GetStartTime Function

PrlSrvInfo_GetStartTime Function
PHT_SERVER_INFO See Also

Returns the service start time in milliseconds since Epoch (01-01-1970).

Syntax
PRL_RESULT PrlSrvInfo_GetStartTime(
    PRL_HANDLE hServerInfo,
    PRL_UINT64_PTR pnStartTime
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
pnStartTime
[out] A pointer to a variable that receives the service start time in milliseconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrvInfo_GetStartTimeMonotonic PrlHandle_GetPackageId

Links
PHT_SERVER_INFO, See Also


PrlSrvInfo_GetStartTimeMonotonic Function

PrlSrvInfo_GetStartTimeMonotonic Function
PHT_SERVER_INFO See Also

Returns the service start time in milliseconds (monotonic time clock).

Syntax
PRL_RESULT PrlSrvInfo_GetStartTimeMonotonic(
    PRL_HANDLE hServerInfo,
    PRL_UINT64_PTR pnStartTimeMonotonic
);
File

PrlApiDisp.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
pnStartTimeMonotonic
[out] A pointer to a variable that receives the service start time in milliseconds from monotonic time clock.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrvInfo_GetStartTime PrlHandle_GetPackageId

Links
PHT_SERVER_INFO, See Also


PrlStat_GetCpusStatsCount Function

PrlStat_GetCpusStatsCount Function
PHT_SYSTEM_STATISTICS See Also

Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetCpusStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available CPU in the system will have its own PHT_SYSTEM_STATISTICS_CPU object instance.

See Also

PrlStat_GetCpuStat

Links
PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetCpuStat Function

PrlStat_GetCpuStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.

Syntax
PRL_RESULT PrlStat_GetCpuStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phCpuStat
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the CPU statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetCpusStatsCount function.
phCpuStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetDisksStatsCount Function

PrlStat_GetDisksStatsCount Function
PHT_SYSTEM_STATISTICS See Also

Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetDisksStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available disk drive in the system will have its own PHT_SYSTEM_STATISTICS_DISK object instance.

See Also

PrlStat_GetDiskStat

Links
PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetDiskStat Function

PrlStat_GetDiskStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.

Syntax
PRL_RESULT PrlStat_GetDiskStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDiskStat
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the disk statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetDisksStatsCount function.
phDiskStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetDispUptime Function

PrlStat_GetDispUptime Function
PHT_SYSTEM_STATISTICS

Returns the Parallels Service uptime in seconds.

Syntax
PRL_RESULT PrlStat_GetDispUptime(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnUptime
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnUptime
[out] A pointer to a variable that receives the result (Parallels Service uptime in seconds).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetFreeRamSize Function

PrlStat_GetFreeRamSize Function
PHT_SYSTEM_STATISTICS

Returns free RAM size in bytes.

Syntax
PRL_RESULT PrlStat_GetFreeRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result (free RAM size in bytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetFreeSwapSize Function

PrlStat_GetFreeSwapSize Function
PHT_SYSTEM_STATISTICS

Returns free swap size in bytes.

Syntax
PRL_RESULT PrlStat_GetFreeSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result (free swap size in bytes.)

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetIfacesStatsCount Function

PrlStat_GetIfacesStatsCount Function
PHT_SYSTEM_STATISTICS See Also

Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetIfacesStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each network interface will have its own PHT_SYSTEM_STATISTICS_IFACE object instance.

See Also

PrlStat_GetIfaceStat

Links
PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetIfaceStat Function

PrlStat_GetIfaceStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.

Syntax
PRL_RESULT PrlStat_GetIfaceStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phIfaceStat
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the network statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetIfacesStatsCount function.
phIfaceStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetOsUptime Function

PrlStat_GetOsUptime Function
PHT_SYSTEM_STATISTICS

Returns the total virtual machine usage time in seconds.

Syntax
PRL_RESULT PrlStat_GetOsUptime(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnUptime
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnUptime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The virtual machine usage counter is not reset when the virtual machine is stopped and restarted, so it's value reflects the total uptime since the virtual machine was first started.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetProcsStatsCount Function

PrlStat_GetProcsStatsCount Function
PHT_SYSTEM_STATISTICS See Also

Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetProcsStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each system process will have its own PHT_SYSTEM_STATISTICS_PROCESS object instance.

See Also

PrlStat_GetProcStat

Links
PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetProcStat Function

PrlStat_GetProcStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.

Syntax
PRL_RESULT PrlStat_GetProcStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phProcStat
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the system process statistics object instance (beginning with 0). To determine the number of instances, use the PrlStat_GetProcsStatsCount function.
phProcStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetRealRamSize Function

PrlStat_GetRealRamSize Function
PHT_SYSTEM_STATISTICS

Returns the amount of physical memory, in bytes, currently occupied by the virtual machine.

Syntax
PRL_RESULT PrlStat_GetRealRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetTotalRamSize Function

PrlStat_GetTotalRamSize Function
PHT_SYSTEM_STATISTICS

Returns total RAM size in bytes.

Syntax
PRL_RESULT PrlStat_GetTotalRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetTotalSwapSize Function

PrlStat_GetTotalSwapSize Function
PHT_SYSTEM_STATISTICS

Returns total swap size in bytes.

Syntax
PRL_RESULT PrlStat_GetTotalSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetUsageRamSize Function

PrlStat_GetUsageRamSize Function
PHT_SYSTEM_STATISTICS

Returns the size RAM currently in use (in bytes).

Syntax
PRL_RESULT PrlStat_GetUsageRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetUsageSwapSize Function

PrlStat_GetUsageSwapSize Function
PHT_SYSTEM_STATISTICS

Returns the size of swap space currently in use (in bytes).

Syntax
PRL_RESULT PrlStat_GetUsageSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetUsersStatsCount Function

PrlStat_GetUsersStatsCount Function
PHT_SYSTEM_STATISTICS See Also

Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetUsersStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each user session will have its own PHT_SYSTEM_STATISTICS_USER_SESSION object instance.

See Also

PrlStat_GetUserStat

Links
PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetUserStat Function

PrlStat_GetUserStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.

Syntax
PRL_RESULT PrlStat_GetUserStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phUserStat
);
File

PrlApiStat.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the user session statistics object instance (beginning with 0). To determine the number of instances, use the PrlStat_GetUsersStatsCount function.
phUserStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PHT_SYSTEM_STATISTICS


PrlStat_GetVmDataStat Function

PrlStat_GetVmDataStat Function
PHT_SYSTEM_STATISTICS

Obtains a handle of type PHT_SYSTEM_STATISTICS_VM_DATA containing the specified system VM data statistic.

Syntax
PRL_RESULT PrlStat_GetVmDataStat(
    PRL_HANDLE hStat,
    PRL_HANDLE_PTR phVmDataStat
);
File

PrlApiVm.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
phVmDataStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS


PrlStatCpu_GetCpuUsage Function

PrlStatCpu_GetCpuUsage Function
PHT_SYSTEM_STATISTICS_CPU

Returns the CPU usage, in percents.

Syntax
PRL_RESULT PrlStatCpu_GetCpuUsage(
    PRL_HANDLE hCpuStat,
    PRL_UINT32_PTR pnPercents
);
File

PrlApiStat.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnPercents
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetSystemTime Function

PrlStatCpu_GetSystemTime Function
PHT_SYSTEM_STATISTICS_CPU

Returns the CPU system time, in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetSystemTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetTotalTime Function

PrlStatCpu_GetTotalTime Function
PHT_SYSTEM_STATISTICS_CPU

Returns the CPU total time in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetTotalTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetUserTime Function

PrlStatCpu_GetUserTime Function
PHT_SYSTEM_STATISTICS_CPU

Returns the CPU user time in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetUserTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_CPU


PrlStatDisk_GetFreeDiskSpace Function

PrlStatDisk_GetFreeDiskSpace Function
PHT_SYSTEM_STATISTICS_DISK

Returns free disk space, in bytes.

Syntax
PRL_RESULT PrlStatDisk_GetFreeDiskSpace(
    PRL_HANDLE hDiskStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetPartsStatsCount Function

PrlStatDisk_GetPartsStatsCount Function
PHT_SYSTEM_STATISTICS_DISK See Also

Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.

Syntax
PRL_RESULT PrlStatDisk_GetPartsStatsCount(
    PRL_HANDLE hDiskStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApiStat.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available partition will have its own PHT_SYSTEM_STATISTICS_DISK_PARTITION object instance.

See Also

PrlStatDisk_GetPartStat

Links
PHT_SYSTEM_STATISTICS_DISK, See Also


PrlStatDisk_GetPartStat Function

PrlStatDisk_GetPartStat Function
PHT_SYSTEM_STATISTICS_DISK

Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.

Syntax
PRL_RESULT PrlStatDisk_GetPartStat(
    PRL_HANDLE hDiskStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPartStat
);
File

PrlApiStat.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
nIndex
A numeric index identifying the PHT_SYSTEM_STATISTICS_DISK_PARTITION object instance (beginning with 0). To obtain the number of instances, use the PrlStatDisk_GetPartsStatsCount function.
phPartStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetSystemName Function

PrlStatDisk_GetSystemName Function
PHT_SYSTEM_STATISTICS_DISK

Returns the disk device name.

Syntax
PRL_RESULT PrlStatDisk_GetSystemName(
    PRL_HANDLE hDiskStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApiStat.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
sSystemName
[out] A pointer to a buffer that receives the disk name (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetUsageDiskSpace Function

PrlStatDisk_GetUsageDiskSpace Function
PHT_SYSTEM_STATISTICS_DISK

Returns the size of the used space on the specified disk, in bytes.

Syntax
PRL_RESULT PrlStatDisk_GetUsageDiskSpace(
    PRL_HANDLE hDiskStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK


PrlStatDiskPart_GetFreeDiskSpace Function

PrlStatDiskPart_GetFreeDiskSpace Function
PHT_SYSTEM_STATISTICS_DISK_PARTITION

Returns the size of the free space on the specified disk partition, in bytes.

Syntax
PRL_RESULT PrlStatDiskPart_GetFreeDiskSpace(
    PRL_HANDLE hPartStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatDiskPart_GetSystemName Function

PrlStatDiskPart_GetSystemName Function
PHT_SYSTEM_STATISTICS_DISK_PARTITION

Returns disk partition device name.

Syntax
PRL_RESULT PrlStatDiskPart_GetSystemName(
    PRL_HANDLE hPartStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApiStat.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
sSystemName
[out] A pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatDiskPart_GetUsageDiskSpace Function

PrlStatDiskPart_GetUsageDiskSpace Function
PHT_SYSTEM_STATISTICS_DISK_PARTITION

Returns the size of the used space on the specified disk partition, in bytes.

Syntax
PRL_RESULT PrlStatDiskPart_GetUsageDiskSpace(
    PRL_HANDLE hPartStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatIface_GetInDataSize Function

PrlStatIface_GetInDataSize Function
PHT_SYSTEM_STATISTICS_IFACE

Returns the total number of bytes the network interface has received since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetInDataSize(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnDataSize
);
File

PrlApiStat.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnDataSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetInPkgsCount Function

PrlStatIface_GetInPkgsCount Function
PHT_SYSTEM_STATISTICS_IFACE

Returns the total number of packets the network interface has received since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetInPkgsCount(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnPkgsCount
);
File

PrlApiStat.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnPkgsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetOutDataSize Function

PrlStatIface_GetOutDataSize Function
PHT_SYSTEM_STATISTICS_IFACE

Returns the total number of bytes the network interface has sent since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetOutDataSize(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnDataSize
);
File

PrlApiStat.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnDataSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetOutPkgsCount Function

PrlStatIface_GetOutPkgsCount Function
PHT_SYSTEM_STATISTICS_IFACE

Returns the total number of packets the network interface has sent since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetOutPkgsCount(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnPkgsCount
);
File

PrlApiStat.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnPkgsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetSystemName Function

PrlStatIface_GetSystemName Function
PHT_SYSTEM_STATISTICS_IFACE

Returns the network interface system name.

Syntax
PRL_RESULT PrlStatIface_GetSystemName(
    PRL_HANDLE hIfaceStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApiStat.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
sSystemName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_IFACE


PrlStatProc_GetCommandName Function

PrlStatProc_GetCommandName Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns the process command name.

Syntax
PRL_RESULT PrlStatProc_GetCommandName(
    PRL_HANDLE hProcStat,
    PRL_STR sCommandName,
    PRL_UINT32_PTR pnCommandNameBufLength
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
sCommandName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnCommandNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetCpuUsage Function

PrlStatProc_GetCpuUsage Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns process CPU usage in percents.

Syntax
PRL_RESULT PrlStatProc_GetCpuUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT32_PTR pnPercents
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnPercents
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetId Function

PrlStatProc_GetId Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns process system id.

Syntax
PRL_RESULT PrlStatProc_GetId(
    PRL_HANDLE hProcStat,
    PRL_UINT32_PTR pnId
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnId
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetOwnerUserName Function

PrlStatProc_GetOwnerUserName Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns process owner user name.

Syntax
PRL_RESULT PrlStatProc_GetOwnerUserName(
    PRL_HANDLE hProcStat,
    PRL_STR sOwnerName,
    PRL_UINT32_PTR pnOwnerNameBufLength
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
sOwnerName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOwnerNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetRealMemUsage Function

PrlStatProc_GetRealMemUsage Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns real memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetRealMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetStartTime Function

PrlStatProc_GetStartTime Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).

Syntax
PRL_RESULT PrlStatProc_GetStartTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetState Function

PrlStatProc_GetState Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns process state.

Syntax
PRL_RESULT PrlStatProc_GetState(
    PRL_HANDLE hProcStat,
    PRL_PROCESS_STATE_TYPE_PTR pnState
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnState
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetSystemTime Function

PrlStatProc_GetSystemTime Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns system running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetSystemTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetTotalMemUsage Function

PrlStatProc_GetTotalMemUsage Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns total memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetTotalMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetTotalTime Function

PrlStatProc_GetTotalTime Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns total running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetTotalTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetUserTime Function

PrlStatProc_GetUserTime Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns user running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetUserTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetVirtMemUsage Function

PrlStatProc_GetVirtMemUsage Function
PHT_SYSTEM_STATISTICS_PROCESS

Returns virtual memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetVirtMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApiStat.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_PROCESS


PrlStatUser_GetHostName Function

PrlStatUser_GetHostName Function
PHT_SYSTEM_STATISTICS_USER_SESSION

Returns the host name of the client machine from which the session was initiated.

Syntax
PRL_RESULT PrlStatUser_GetHostName(
    PRL_HANDLE hUserStat,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApiStat.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetServiceName Function

PrlStatUser_GetServiceName Function
PHT_SYSTEM_STATISTICS_USER_SESSION

Returns the name of the host system service that created the session.

Syntax
PRL_RESULT PrlStatUser_GetServiceName(
    PRL_HANDLE hUserStat,
    PRL_STR sServiceName,
    PRL_UINT32_PTR pnServiceNameBufLength
);
File

PrlApiStat.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sServiceName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServiceNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetSessionTime Function

PrlStatUser_GetSessionTime Function
PHT_SYSTEM_STATISTICS_USER_SESSION

Returns session duration, in seconds.

Syntax
PRL_RESULT PrlStatUser_GetSessionTime(
    PRL_HANDLE hUserStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApiStat.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetUserName Function

PrlStatUser_GetUserName Function
PHT_SYSTEM_STATISTICS_USER_SESSION

Returns session user name.

Syntax
PRL_RESULT PrlStatUser_GetUserName(
    PRL_HANDLE hUserStat,
    PRL_STR sUserName,
    PRL_UINT32_PTR pnUserNameBufLength
);
File

PrlApiStat.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sUserName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUserNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatVmData_GetSegmentCapacity Function

PrlStatVmData_GetSegmentCapacity Function
Functions

Returns VM data segment capacity in bytes.

Syntax
PRL_RESULT PrlStatVmData_GetSegmentCapacity(
    PRL_HANDLE hVmDataStat,
    PRL_DATA_STATISTIC_SEGMENTS nSegment,
    PRL_UINT64_PTR pnCapacity
);
File

PrlApiVm.h

Parameters

hVmDataStat
A handle of type PHT_SYSTEM_STATISTICS_VM_DATA identifying the system process.
nSegment
Segment id defined in PRL_DATA_STATISTIC_SEGMENTS enum.
pnCapacity
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no data for given segment.

PRL_ERR_SUCCESS - function completed successfully.

Links
Functions


PrlStrList_AddItem Function

PrlStrList_AddItem Function
PHT_STRINGS_LIST

Adds a new string to the container.

Syntax
PRL_RESULT PrlStrList_AddItem(
    PRL_HANDLE hStringsList,
    PRL_CONST_STR sItem
);
File

PrlApiCore.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
sItem
A pointer to the string to add to the container. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_STRINGS_LIST


PrlStrList_GetItem Function

PrlStrList_GetItem Function
PHT_STRINGS_LIST

Extracts the specified string from the container.

Syntax
PRL_RESULT PrlStrList_GetItem(
    PRL_HANDLE hStringsList,
    PRL_UINT32 nItemIndex,
    PRL_STR sItemBuf,
    PRL_UINT32_PTR pnItemBufSize
);
File

PrlApiCore.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
nItemIndex
A numeric index identifying the string (beginning with 0). To determine the number of string in the container, use the PrlStrList_GetItemsCount function.
sItemBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnItemBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_STRINGS_LIST


PrlStrList_GetItemsCount Function

PrlStrList_GetItemsCount Function
PHT_STRINGS_LIST

Determines the number of strings in the container.

Syntax
PRL_RESULT PrlStrList_GetItemsCount(
    PRL_HANDLE hStringsList,
    PRL_UINT32_PTR pnItemsCount
);
File

PrlApiCore.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
pnItemsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_STRINGS_LIST


PrlStrList_RemoveItem Function

PrlStrList_RemoveItem Function
PHT_STRINGS_LIST

Removes the specified string from the container.

Syntax
PRL_RESULT PrlStrList_RemoveItem(
    PRL_HANDLE hStringsList,
    PRL_UINT32 nItemIndex
);
File

PrlApiCore.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
nItemIndex
A numeric index identifying the string. Index is a sequential number assigned to every item in the container. To determine the index of an item, call the PrlStrList_GetItem in a loop (from 0 to PrlStrList_GetItemsCount()). The iteration number is the index of the corresponding item.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_STRINGS_LIST


PrlUIEmuInput_AddText Function

PrlUIEmuInput_AddText Function
PHT_UIEMU_INPUT

Add text to input object.

Syntax
PRL_RESULT PrlUIEmuInput_AddText(
    PRL_HANDLE hInput,
    PRL_CONST_STR text,
    PRL_UINT32 length
);
File

PrlApiVm.h

Parameters

hInput
[in] Handle of type PHT_UIEMU_INPUT. Must be valid.
text
[in] Text (UTF-8 encoded).
length
[in] Text length. Can be 0.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Input object must not be accessed from other thread during this operation.

Links
PHT_UIEMU_INPUT


PrlUIEmuInput_AddVKeys Function

PrlUIEmuInput_AddVKeys Function
PHT_UIEMU_INPUT

Add virtual keys to input object.

Syntax
PRL_RESULT PrlUIEmuInput_AddVKeys(
    PRL_HANDLE hInput,
    PRL_CONST_UIEMU_VKEY_PTR vkeys,
    PRL_UINT32 count,
    PRL_UINT32 repeat
);
File

PrlApiVm.h

Parameters

hInput
[in] Handle of type PHT_UIEMU_INPUT. Must be valid.
vkeys
[in] Virtual keys sequence.
count
[in] Count of virtual keys in vkeys sequence. Must be 1 or greater.
repeat
[in] Sequence repeat count. Must be 1 or greater.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Input object must not be accessed from other thread during this operation.

Links
PHT_UIEMU_INPUT


PrlUIEmuInput_Create Function

PrlUIEmuInput_Create Function
PHT_UIEMU_INPUT

Creates input object.

Syntax
PRL_RESULT PrlUIEmuInput_Create(
    PRL_HANDLE_PTR hInput
);
File

PrlApiVm.h

Parameters

hInput
[out] On success receives handle of type PHT_UIEMU_INPUT.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - hInput is NULL. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Remarks

To add input to created object call any of PrlUIEmuInput_AddXXX() functions. To send input to guest call PrlVm_UIEmuSendInput() function. Created input object must be explicitly disposed with PrlHandle_Free(). Access to input object is not synchronized. Only one thread at a time can modify it. While one thread modifies input object, other threads can not access it (modify or send it). However, it is safe to send input object from different threads at the same time.

Links
PHT_UIEMU_INPUT


PrlUsbIdent_GetFriendlyName Function

PrlUsbIdent_GetFriendlyName Function
PHT_USB_IDENTITY

Returns user friendly name of USB device.

Syntax
PRL_RESULT PrlUsbIdent_GetFriendlyName(
    PRL_HANDLE hUsbIdent,
    PRL_STR sFriendlyName,
    PRL_UINT32_PTR pnFriendlyNameBufLength
);
File

PrlApiDisp.h

Parameters

hUsbIdent
A handle of type PHT_USB_IDENTITY.
sFriendlyName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnFriedlyNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USB_IDENTITY


PrlUsbIdent_GetSystemName Function

PrlUsbIdent_GetSystemName Function
PHT_USB_IDENTITY

Returns system name for USB device.

Syntax
PRL_RESULT PrlUsbIdent_GetSystemName(
    PRL_HANDLE hUsbIdent,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApiDisp.h

Parameters

hUsbIdent
A handle of type PHT_USB_IDENTITY.
sSystemName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USB_IDENTITY


PrlUsbIdent_GetVmUuidAssociation Function

PrlUsbIdent_GetVmUuidAssociation Function
PHT_USB_IDENTITY

Returns Uuid of Vm associated with USB device or empty string if no association is specified.

Syntax
PRL_RESULT PrlUsbIdent_GetVmUuidAssociation(
    PRL_HANDLE hUsbIdent,
    PRL_STR sVmUuid,
    PRL_UINT32_PTR pnVmUuidBufLength
);
File

PrlApiDisp.h

Parameters

hUsbIdent
A handle of type PHT_USB_IDENTITY.
sVmUuid
[out] A pointer to a buffer that receives the result (null-terminated string).
pnVmUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USB_IDENTITY


PrlUsrCfg_CanChangeSrvSets Function

PrlUsrCfg_CanChangeSrvSets Function
PHT_USER_PROFILE See Also

Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).

Syntax
PRL_RESULT PrlUsrCfg_CanChangeSrvSets(
    PRL_HANDLE hUserProfile,
    PRL_BOOL_PTR pbCanChangeSrvSets
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
pbCanChangeSrvSets
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the client can modify Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host machine can modify Parallels Service preferences. Depending on the current Parallels Service settings, other users may also be granted this privilege at the time a user profile is created. To verify the default settings, use the PrlDispCfg_CanChangeDefaultSettings function. Whether the user can or cannot modify Parallels Service preferences, this setting is final and cannot itself be changed through Parallels API.

See Also

PrlDispCfg_CanChangeDefaultSettings

PrlDispCfg_SetCanChangeDefaultSettings

Links
PHT_USER_PROFILE, See Also


PrlUsrCfg_CanUseMngConsole Function

PrlUsrCfg_CanUseMngConsole Function
PHT_USER_PROFILE

Determines if the user is allowed to use the Parallels Service management console utility.

Syntax
PRL_RESULT PrlUsrCfg_CanUseMngConsole(
    PRL_HANDLE hUserProfile,
    PRL_BOOL_PTR pbCanUseMngConsole
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
pbCanUseMngConsole
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allows to use the utility. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_PROFILE


PrlUsrCfg_GetDefaultVmFolder Function

PrlUsrCfg_GetDefaultVmFolder Function
PHT_USER_PROFILE See Also

Returns name and path of the default virtual machine directory for this user.

Syntax
PRL_RESULT PrlUsrCfg_GetDefaultVmFolder(
    PRL_HANDLE hUserProfile,
    PRL_STR sDefaultVmFolder,
    PRL_UINT32_PTR pnDefaultVmFolderBufLength
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sDefaultVmFolder
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultVmFolderBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the user doesn't have a default virtual machine folder (if it was not previously set up by the PrlUsrCfg_SetDefaultVmFolder function call), the function returns an empty string. In such a case, use the PrlUsrCfg_GetVmDirUuid function to get the virtual machine folder for the Parallels Service, which is used by default for all users.

See Also

PrlUsrCfg_SetDefaultVmFolder

Links
PHT_USER_PROFILE, See Also


PrlUsrCfg_GetVmDirUuid Function

PrlUsrCfg_GetVmDirUuid Function
PHT_USER_PROFILE

Returns name and path of the default virtual machine folder for this Parallels Service.

Syntax
PRL_RESULT PrlUsrCfg_GetVmDirUuid(
    PRL_HANDLE hUserProfile,
    PRL_STR sVmDirUuid,
    PRL_UINT32_PTR pnVmDirUuidBufLength
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sVmDirUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmDirUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a default virtual machine folder has been set up for this user with the PrlUsrCfg_SetDefaultVmFolder function, use the PrlUsrCfg_GetDefaultVmFolder to get its name and path.

Links
PHT_USER_PROFILE


PrlUsrCfg_IsLocalAdministrator Function

PrlUsrCfg_IsLocalAdministrator Function
PHT_USER_PROFILE

Determines if the user is a local administrator account on the host where Parallels Service started.

Syntax
PRL_RESULT PrlUsrCfg_IsLocalAdministrator(
    PRL_HANDLE hUserProfile,
    PRL_BOOL_PTR pbIsLocalAdmin
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
pbIsLocalAdmin
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is local administrator. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_PROFILE


PrlUsrCfg_SetDefaultVmFolder Function

PrlUsrCfg_SetDefaultVmFolder Function
PHT_USER_PROFILE

Allows to set a default virtual machine folder for the user.

Syntax
PRL_RESULT PrlUsrCfg_SetDefaultVmFolder(
    PRL_HANDLE hUserProfile,
    PRL_CONST_STR sNewDefaultVmFolder
);
File

PrlApiDisp.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sNewDefaultVmFolder
Name and path of the folder to set as default virtual machine folder for the user. The folder must already exist on the host.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A Parallels Service has a default virtual machine directory (the directory where new virtual machines are created). Individual users can have their own default virtual machine directories if needed. If a user has its own virtual machine directory set up, it takes precedence over the Parallels Service default. To set a default directory for a user, first call the PrlSrv_UserProfileBeginEdit function to mark the beginning of the operation. Then call the PrlUsrCfg_SetDefaultVmFolder function to set the new default virtual machine folder. Finally, call the PrlSrv_UserProfileCommit function to save your changes.

Links
PHT_USER_PROFILE


PrlUsrCfg_SetVmDirUuid Function

PrlUsrCfg_SetVmDirUuid Function
PHT_USER_PROFILE

Sets user default VM dir.

Syntax
PRL_RESULT PrlUsrCfg_SetVmDirUuid(
    PRL_HANDLE hUserProfile,
    PRL_CONST_STR sNewVmDirUuid
);
File

PrlApiDisp.h

Parameters

handle
A handle of type PHT_USER_PROFILE identifying the user.
unnamed_param
new VM dir

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_USER_PROFILE handle or non valid (NULL) pointer to the new VM dir string was specified PRL_ERR_SUCCESS - operation completed successfully

Remarks

Specified string value must be UTF-8 encoding and ends with '0' terminating symbol.

Links
PHT_USER_PROFILE


PrlUsrInfo_CanChangeSrvSets Function

PrlUsrInfo_CanChangeSrvSets Function
PHT_USER_INFO

Determines whether the specified user is allowed to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlUsrInfo_CanChangeSrvSets(
    PRL_HANDLE hUserInfo,
    PRL_BOOL_PTR pbCanChangeSrvSets
);
File

PrlApiDisp.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
pbCanChangeSrvSets
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allowed to modify Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_INFO


PrlUsrInfo_GetDefaultVmFolder Function

PrlUsrInfo_GetDefaultVmFolder Function
PHT_USER_INFO See Also

Returns name and path of the default virtual machine directory for the specified user.

Syntax
PRL_RESULT PrlUsrInfo_GetDefaultVmFolder(
    PRL_HANDLE hUserInfo,
    PRL_STR sDefaultVmFolder,
    PRL_UINT32_PTR pnDefaultVmFolderBufLength
);
File

PrlApiDisp.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sDefaultVmFolder
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultVmFolderBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the user doesn't have a default virtual machine directory, the function will return the name and path of the default directory for this Parallels Service. To set a default virtual machine directory for a user, use the PrlUsrCfg_SetDefaultVmFolder function.

See Also

PrlUsrCfg_SetDefaultVmFolder

Links
PHT_USER_INFO, See Also


PrlUsrInfo_GetName Function

PrlUsrInfo_GetName Function
PHT_USER_INFO

Returns the user name.

Syntax
PRL_RESULT PrlUsrInfo_GetName(
    PRL_HANDLE hUserInfo,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiDisp.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_INFO


PrlUsrInfo_GetSessionCount Function

PrlUsrInfo_GetSessionCount Function
PHT_USER_INFO

Returns the user active session count.

Syntax
PRL_RESULT PrlUsrInfo_GetSessionCount(
    PRL_HANDLE hUserInfo,
    PRL_UINT32_PTR pnSessionCount
);
File

PrlApiDisp.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
pnSessionCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_INFO


PrlUsrInfo_GetUuid Function

PrlUsrInfo_GetUuid Function
PHT_USER_INFO

Returns the user Universally Unique Identifier (UUID).

Syntax
PRL_RESULT PrlUsrInfo_GetUuid(
    PRL_HANDLE hUserInfo,
    PRL_STR sUuid,
    PRL_UINT32_PTR pnUuidBufLength
);
File

PrlApiDisp.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_USER_INFO


PrlVirtNet_Create Function

PrlVirtNet_Create Function
PHT_VIRTUAL_NETWORK

Creates a new handle of type PHT_VIRTUAL_NETWORK.

Syntax
PRL_RESULT PrlVirtNet_Create(
    PRL_HANDLE_PTR phVirtNet
);
File

PrlApiNet.h

Parameters

phVirtNet
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to create and configure a virtual network. If you would like to create a new virtual network, use this function to create the handle first and then use the handle functions to configure the network. If you would like to modify the configuration of an existing virtual network, use the PrlSrv_GetVirtualNetworkList function to obtain a handle to the virtual network of interest.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetAdapterIndex Function

PrlVirtNet_GetAdapterIndex Function
PHT_VIRTUAL_NETWORK

Returns a numeric index assigned to the network adapter in the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetAdapterIndex(
    PRL_HANDLE hVirtNet,
    PRL_UINT32_PTR pnAdapterIndex
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pnAdapterIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Special values for this parameter in PRL_ADAPTER_INDEX enum.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetAdapterName Function

PrlVirtNet_GetAdapterName Function
PHT_VIRTUAL_NETWORK

Returns the name of the network adapter in the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetAdapterName(
    PRL_HANDLE hVirtNet,
    PRL_STR sAdapterName,
    PRL_UINT32_PTR pnAdapterNameBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sAdapterName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnAdapterNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetBoundAdapterInfo Function

PrlVirtNet_GetBoundAdapterInfo Function
PHT_VIRTUAL_NETWORK

Obtains physical adapter info which bound to the virtual network object.

Syntax
PRL_RESULT PrlVirtNet_GetBoundAdapterInfo(
    PRL_HANDLE hVirtNet,
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phNetAdapter
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
hSrvConfig
A handle of type PHT_SERVER_CONFIG which provides host hardware information.
phNetAdapter
[out] A pointer to a variable that receives the new handle of PHT_HW_NET_ADAPTER object.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network object or invalid handle of host hardware info or null pointer was passed.

PRL_ERR_NETWORK_ADAPTER_NOT_FOUND - correspond network adapter is absent at provided host

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the object of network adapter.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This method provided for convenience in order do not create own algorithm of bound to the virtual network physical adapter information.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetBoundCardMac Function

PrlVirtNet_GetBoundCardMac Function
PHT_VIRTUAL_NETWORK

Returns the bound card MAC address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetBoundCardMac(
    PRL_HANDLE hVirtNet,
    PRL_STR sBoundCardMac,
    PRL_UINT32_PTR pnBoundCardMacBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sBoundCardMac
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBoundCardMacBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetDescription Function

PrlVirtNet_GetDescription Function
PHT_VIRTUAL_NETWORK

Returns the description of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetDescription(
    PRL_HANDLE hVirtNet,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetDhcpIP6Address Function

PrlVirtNet_GetDhcpIP6Address Function
PHT_VIRTUAL_NETWORK

Returns the DCHP IPv6 address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetDhcpIP6Address(
    PRL_HANDLE hVirtNet,
    PRL_STR sDhcpIPAddress,
    PRL_UINT32_PTR pnDhcpIPAddressBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDhcpIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetDhcpIPAddress Function

PrlVirtNet_GetDhcpIPAddress Function
PHT_VIRTUAL_NETWORK

Returns the DCHP IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetDhcpIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_STR sDhcpIPAddress,
    PRL_UINT32_PTR pnDhcpIPAddressBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDhcpIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetHostIP6Address Function

PrlVirtNet_GetHostIP6Address Function
PHT_VIRTUAL_NETWORK

Returns the host IPv6 address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetHostIP6Address(
    PRL_HANDLE hVirtNet,
    PRL_STR sHostIPAddress,
    PRL_UINT32_PTR pnHostIPAddressBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetHostIPAddress Function

PrlVirtNet_GetHostIPAddress Function
PHT_VIRTUAL_NETWORK

Returns the host IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetHostIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_STR sHostIPAddress,
    PRL_UINT32_PTR pnHostIPAddressBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIP6NetMask Function

PrlVirtNet_GetIP6NetMask Function
PHT_VIRTUAL_NETWORK

Returns the IPv6 net mask of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIP6NetMask(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPNetMask,
    PRL_UINT32_PTR pnIPNetMaskBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPNetMaskBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIP6ScopeEnd Function

PrlVirtNet_GetIP6ScopeEnd Function
PHT_VIRTUAL_NETWORK

Returns the DHCP end IPv6 address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIP6ScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeEnd,
    PRL_UINT32_PTR pnIPScopeEndBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeEndBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIP6ScopeStart Function

PrlVirtNet_GetIP6ScopeStart Function
PHT_VIRTUAL_NETWORK

Returns the DHCP start IPv6 address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIP6ScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeStart,
    PRL_UINT32_PTR pnIPScopeStartBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeStartBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPNetMask Function

PrlVirtNet_GetIPNetMask Function
PHT_VIRTUAL_NETWORK

Returns the IP net mask of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPNetMask(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPNetMask,
    PRL_UINT32_PTR pnIPNetMaskBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPNetMaskBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPScopeEnd Function

PrlVirtNet_GetIPScopeEnd Function
PHT_VIRTUAL_NETWORK

Returns the DHCP end IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeEnd,
    PRL_UINT32_PTR pnIPScopeEndBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeEndBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPScopeStart Function

PrlVirtNet_GetIPScopeStart Function
PHT_VIRTUAL_NETWORK

Returns the DHCP start IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeStart,
    PRL_UINT32_PTR pnIPScopeStartBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeStartBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetNetworkId Function

PrlVirtNet_GetNetworkId Function
PHT_VIRTUAL_NETWORK

Returns the ID of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetNetworkId(
    PRL_HANDLE hVirtNet,
    PRL_STR sNetworkId,
    PRL_UINT32_PTR pnNetworkIdBufLength
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sNetworkId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNetworkIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetNetworkType Function

PrlVirtNet_GetNetworkType Function
PHT_VIRTUAL_NETWORK

Returns the virtual network type.

Syntax
PRL_RESULT PrlVirtNet_GetNetworkType(
    PRL_HANDLE hVirtNet,
    PRL_NET_VIRTUAL_NETWORK_TYPE_PTR pnNetworkType
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pnNetworkType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Network types are defined in the PRL_NET_VIRTUAL_NETWORK_TYPE enumeration. The following describes network types are used:

  • PVN_BRIDGED_ETHERNET
  • PVN_HOST_ONLY
Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetPortForwardList Function

PrlVirtNet_GetPortForwardList Function
PHT_VIRTUAL_NETWORK

Returns the port forward entries list.

Syntax
PRL_RESULT PrlVirtNet_GetPortForwardList(
    PRL_HANDLE hVirtNet,
    PRL_PORT_FORWARDING_TYPE nPortFwdType,
    PRL_HANDLE_PTR phPortFwdList
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nPortFwdType
A port forward type ( PRL_PORT_FORWARDING_TYPE enumeration ).
phPortFwdList
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list or a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_GetVlanTag Function

PrlVirtNet_GetVlanTag Function
PHT_VIRTUAL_NETWORK

Returns the VLAN tag of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetVlanTag(
    PRL_HANDLE hVirtNet,
    PRL_UINT16_PTR pnVlanTag
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pnVlanTag
[out] The buffer for storing result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Since the same physical adapter can be used at several virtual networks pair can identify adapter.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_IsAdapterEnabled Function

PrlVirtNet_IsAdapterEnabled Function
PHT_VIRTUAL_NETWORK

Determines whether the specified virtual network adapter is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsAdapterEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is enabled. PRL_FALSE indicates that the adapter is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_IsDHCP6ServerEnabled Function

PrlVirtNet_IsDHCP6ServerEnabled Function
PHT_VIRTUAL_NETWORK

Determines whether the specified virtual network DHCPv6 server is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsDHCP6ServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the DHCP server is enabled. PRL_FALSE indicates that the DHCP server is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_IsDHCPServerEnabled Function

PrlVirtNet_IsDHCPServerEnabled Function
PHT_VIRTUAL_NETWORK

Determines whether the specified virtual network DHCP server is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsDHCPServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the DHCP server is enabled. PRL_FALSE indicates that the DHCP server is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_IsEnabled Function

PrlVirtNet_IsEnabled Function
PHT_VIRTUAL_NETWORK

Determines whether the specified virtual network is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the virtual network is enabled. PRL_FALSE indicates that the virtual network is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_IsNATServerEnabled Function

PrlVirtNet_IsNATServerEnabled Function
PHT_VIRTUAL_NETWORK

Determines whether the specified virtual network NAT server is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsNATServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the NAT server is enabled. PRL_FALSE indicates that the NAT server is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterEnabled Function

PrlVirtNet_SetAdapterEnabled Function
PHT_VIRTUAL_NETWORK

Allows to enable or disable a specified virtual network adapter.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the adapter. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterIndex Function

PrlVirtNet_SetAdapterIndex Function
PHT_VIRTUAL_NETWORK

Sets the specified adapter index.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterIndex(
    PRL_HANDLE hVirtNet,
    PRL_UINT32 nAdapterIndex
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nAdapterIndex
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Special values for this parameter in PRL_ADAPTER_INDEX enum.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterName Function

PrlVirtNet_SetAdapterName Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network adapter name.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterName(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sAdapterName
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sAdapterName
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetBoundCardMac Function

PrlVirtNet_SetBoundCardMac Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network bound card MAC address.

Syntax
PRL_RESULT PrlVirtNet_SetBoundCardMac(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sBoundCardMac
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sBoundCardMac
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

MAC address gets by PrlSrvCfgNet_GetMacAddress functions for given network adapter.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDescription Function

PrlVirtNet_SetDescription Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network description.

Syntax
PRL_RESULT PrlVirtNet_SetDescription(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sDescription
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDescription
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDHCP6ServerEnabled Function

PrlVirtNet_SetDHCP6ServerEnabled Function
PHT_VIRTUAL_NETWORK

Allows to enable or disable a specified virtual network DHCPv6 server.

Syntax
PRL_RESULT PrlVirtNet_SetDHCP6ServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the DHCP server. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDhcpIP6Address Function

PrlVirtNet_SetDhcpIP6Address Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP IPv6 address.

Syntax
PRL_RESULT PrlVirtNet_SetDhcpIP6Address(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sDhcpIPAddress
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDhcpIPAddress Function

PrlVirtNet_SetDhcpIPAddress Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP IP address.

Syntax
PRL_RESULT PrlVirtNet_SetDhcpIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sDhcpIPAddress
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDHCPServerEnabled Function

PrlVirtNet_SetDHCPServerEnabled Function
PHT_VIRTUAL_NETWORK

Allows to enable or disable a specified virtual network DHCP server.

Syntax
PRL_RESULT PrlVirtNet_SetDHCPServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the DHCP server. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetEnabled Function

PrlVirtNet_SetEnabled Function
PHT_VIRTUAL_NETWORK

Allows to enable or disable a specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_SetEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the virtual network. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetHostIP6Address Function

PrlVirtNet_SetHostIP6Address Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network host IPv6 address.

Syntax
PRL_RESULT PrlVirtNet_SetHostIP6Address(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sHostIPAddress
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetHostIPAddress Function

PrlVirtNet_SetHostIPAddress Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network host IP address.

Syntax
PRL_RESULT PrlVirtNet_SetHostIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sHostIPAddress
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIP6NetMask Function

PrlVirtNet_SetIP6NetMask Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network IPv6 net mask.

Syntax
PRL_RESULT PrlVirtNet_SetIP6NetMask(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPNetMask
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIP6ScopeEnd Function

PrlVirtNet_SetIP6ScopeEnd Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP end IPv6 address.

Syntax
PRL_RESULT PrlVirtNet_SetIP6ScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeEnd
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIP6ScopeStart Function

PrlVirtNet_SetIP6ScopeStart Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP start IPv6 address.

Syntax
PRL_RESULT PrlVirtNet_SetIP6ScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeStart
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPNetMask Function

PrlVirtNet_SetIPNetMask Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network IP net mask.

Syntax
PRL_RESULT PrlVirtNet_SetIPNetMask(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPNetMask
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPScopeEnd Function

PrlVirtNet_SetIPScopeEnd Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP end IP address.

Syntax
PRL_RESULT PrlVirtNet_SetIPScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeEnd
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPScopeStart Function

PrlVirtNet_SetIPScopeStart Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network DHCP start IP address.

Syntax
PRL_RESULT PrlVirtNet_SetIPScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeStart
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNATServerEnabled Function

PrlVirtNet_SetNATServerEnabled Function
PHT_VIRTUAL_NETWORK

Allows to enable or disable a specified virtual network NAT server.

Syntax
PRL_RESULT PrlVirtNet_SetNATServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the NAT server. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNetworkId Function

PrlVirtNet_SetNetworkId Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network ID.

Syntax
PRL_RESULT PrlVirtNet_SetNetworkId(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sNetworkId
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sNetworkId
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNetworkType Function

PrlVirtNet_SetNetworkType Function
PHT_VIRTUAL_NETWORK

Sets the specified virtual network type.

Syntax
PRL_RESULT PrlVirtNet_SetNetworkType(
    PRL_HANDLE hVirtNet,
    PRL_NET_VIRTUAL_NETWORK_TYPE nNetworkType
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nNetworkType
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Network types are defined in the PRL_NET_VIRTUAL_NETWORK_TYPE enumeration. The following describes network types are used:

  • PVN_BRIDGED_ETHERNET
  • PVN_HOST_ONLY
Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetPortForwardList Function

PrlVirtNet_SetPortForwardList Function
PHT_VIRTUAL_NETWORK

Sets the port forward entries list.

Syntax
PRL_RESULT PrlVirtNet_SetPortForwardList(
    PRL_HANDLE hVirtNet,
    PRL_PORT_FORWARDING_TYPE nPortFwdType,
    PRL_HANDLE hPortFwdList
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nPortFwdType
A port forward type ( PRL_PORT_FORWARDING_TYPE enumeration ).
hPortFwdList
The list of PHT_PORT_FORWARDING handles.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward entry object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_NETWORK


PrlVirtNet_SetVlanTag Function

PrlVirtNet_SetVlanTag Function
PHT_VIRTUAL_NETWORK

Sets the VLAN tag for the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_SetVlanTag(
    PRL_HANDLE hVirtNet,
    PRL_UINT16 nVlanTag
);
File

PrlApiNet.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nVlanTag
[in] Setting value.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Since the same physical adapter can be used at several virtual networks pair can identify adapter.

Links
PHT_VIRTUAL_NETWORK


PrlVm_Authorise Function

PrlVm_Authorise Function
PHT_VIRTUAL_MACHINE

Authorises current session against encrypted virtual machine.

Syntax
PRL_HANDLE PrlVm_Authorise(
    PRL_HANDLE hVm,
    PRL_CONST_STR sPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sPassword
Password which was used earlier to encrypt virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
nFlags
Bitset of flags - reserved parameter for further purposes.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_AuthWithGuestSecurityDb Function

PrlVm_AuthWithGuestSecurityDb Function
PHT_VIRTUAL_MACHINE

Performs an attempt to authenticate the user through the guest OS security database.

Syntax
PRL_HANDLE PrlVm_AuthWithGuestSecurityDb(
    PRL_HANDLE hVm,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sUserPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sUserName
User login name.
sUserPassword
User password (can be an empty string or NULL if the user doesn't have a password).
nFlags
A bitset of flags (should be 0 in the current implementation).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer (empty string) for user name was passed.

PRL_ERR_AUTHENTICATION_FAILED - user authentication failed.

PRL_ERR_SUCCESS - user authenticated successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_BeginEdit Function

PrlVm_BeginEdit Function
PHT_VIRTUAL_MACHINE Example

The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_BeginEdit(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlVm_BeginEdit and the PrlVm_Commit functions are used to detect collisions with other clients trying to modify the same virtual machine at the same time. The PrlVm_BeginEdit call timestamps the beginning of the editing operation. It does not lock the machine, so other clients can modify the same machine at the same time. When you are done making the changes, you must call the PrlVm_Commit function to save them in the virtual machine configuration. The function will verify that the configuration has not been modified by another client. If a collision is detected, your changes will be rejected. To ensure that you always work with the most recent configuration data, the PrlVm_BeginEdit function reloads it when called. If you first modified the data in your program and then called the PrlVm_BeginEdit function, your changes will be lost.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PHT_VIRTUAL_MACHINE, Example


PrlVm_CancelCompact Function

PrlVm_CancelCompact Function
PHT_VIRTUAL_MACHINE

Finishes process of optimization of virtual hard disk.

Syntax
PRL_HANDLE PrlVm_CancelCompact(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
valid PRL_HANDLE describing the virtual machine

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with server connection or non identified VM object

Remarks

The machine should be registered on the server to do that.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CancelConvertDisks Function

PrlVm_CancelConvertDisks Function
PHT_VIRTUAL_MACHINE

Finishes process of conversion of the virtual hard disk(s).

Syntax
PRL_HANDLE PrlVm_CancelConvertDisks(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
valid PRL_HANDLE describing the virtual machine
nFlags
Reserved.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with server connection or non identified VM object

Remarks

The machine should be registered on the server to do that.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ChangePassword Function

PrlVm_ChangePassword Function
PHT_VIRTUAL_MACHINE

Changes current password of encrypted virtual machine on new one.

Syntax
PRL_HANDLE PrlVm_ChangePassword(
    PRL_HANDLE hVm,
    PRL_CONST_STR sOldPassword,
    PRL_CONST_STR sNewPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sOldPassword
Password which was used earlier to encrypt virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
sNewPassword
New setting password. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
nFlags
Bitset of flags - reserved parameter for further purposes.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ChangeSid Function

PrlVm_ChangeSid Function
PHT_VIRTUAL_MACHINE

Generates and assigns a new Windows SID to the specified virtual machine running Windows guest OS.

Syntax
PRL_HANDLE PrlVm_ChangeSid(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nFlags
Reserved for future use.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object. To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully. PRL_ERR_UNINITIALIZED â€“ unknown PHT_VIRTUAL_MACHINE handle or invalid binding to server connection.

Remarks

This function is useful when cloning or migrating a virtual machine to another host to avoid conflicts. Please note that this functionality is applicable to Windows guests only. Parallels Tools must be installed in the virtual machine. The machine must be stopped before calling this function.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Clone Function

PrlVm_Clone Function
PHT_VIRTUAL_MACHINE

Clones an existing virtual machine.

Syntax
PRL_HANDLE PrlVm_Clone(
    PRL_HANDLE hVm,
    PRL_CONST_STR new_vm_name,
    PRL_CONST_STR new_vm_root_path,
    PRL_BOOL bCreateTemplate
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
new_vm_name
The name to use for the new virtual machine.
new_vm_root_path
Name and path of the directory where the new virtual machine should be created. To create the machine in a default directory, pass an empty string.
bCreateTemplate
Specifies whether the clone should be created as a virtual machine or as a template. To create a template, set this parameter value to PRL_TRUE. To create a virtual machine, set it to PRL_FALSE. When creating a virtual machine from a template, set the parameter value to PRL_FALSE.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function creates an exact copy of the specified virtual machine on the same host using the specified new name and location. In order to perform a clone operation, the original machine must be registered with the Parallels Service. A clone can be created as a virtual machine or as a template. To create a template, set the bCreateTemplate parameter value to PRL_TRUE. The function can also be used to create new virtual machines from templates. In order to that, the hVm parameter must contain a handle to a template, the name and the path parameters must be set to desired values, and the bCreateTemplate parameter must be set to PRL_FALSE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CloneEx Function

PrlVm_CloneEx Function
PHT_VIRTUAL_MACHINE

Clones an existing virtual machine.

Syntax
PRL_HANDLE PrlVm_CloneEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR new_vm_name,
    PRL_CONST_STR new_vm_root_path,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
new_vm_name
The name to use for the new virtual machine.
new_vm_root_path
Name and path of the directory where the new virtual machine should be created. To create the machine in a default directory, pass an empty string.
nFlags
Clone flags (PCVF_CLONE_TO_TEMPLATE, PCVF_CHANGE_SID, PCVF_LINKED_CLONE, PCVF_IMPORT_BOOT_CAMP). Also PACF_NON_INTERACTIVE_MODE can be used to specify non interactive session working mode (remote side won't ask questions during operation progress in this case). Please note that clone operation can take it's own exclusive lock of virtual machine (in change SID or linked clone modes) - so VM shouldn't be exclusively locked with PrlVm_Lock call before clone operation performed.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function creates an exact copy of the specified virtual machine on the same host using the specified new name and location. In order to perform a clone operation, the original machine must be registered with the Parallels Service. A clone can be created as a virtual machine or as a template. To create a template, set the nFlags parameter to PACF_CLONEVM_TO_TEMPLATE value. The function can also be used to create new virtual machines from templates. In order to that, the hVm parameter must contain a handle to a template, the name and the path parameters must be set to desired values, and the bCreateTemplate parameter must be set to PRL_FALSE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Commit Function

PrlVm_Commit Function
PHT_VIRTUAL_MACHINE Example

The PrlVm_Commit function is used in modifying a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_Commit(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlVm_BeginEdit and the PrlVm_Commit functions are used to detect collisions with other clients trying to modify the same virtual machine at the same time. The PrlVm_BeginEdit call timestamps the beginning of the editing operation. It does not lock the machine, so other clients can modify the same machine at the same time. When you are done making the changes, you must call the PrlVm_Commit function to save them in the virtual machine configuration. The function will verify that the configuration has not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PHT_VIRTUAL_MACHINE, Example


PrlVm_CommitEx Function

PrlVm_CommitEx Function
PHT_VIRTUAL_MACHINE

The PrlVm_CommitEx function is the same as PrlVm_Commit function but with the flags

Syntax
PRL_HANDLE PrlVm_CommitEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nFlags
Bitset of flags - from enum PRL_API_COMMAND_FLAGS

Links
PHT_VIRTUAL_MACHINE


PrlVm_Compact Function

PrlVm_Compact Function
PHT_VIRTUAL_MACHINE

Start process of optimization of virtual hard disk.

Syntax
PRL_HANDLE PrlVm_Compact(
    PRL_HANDLE hVm,
    PRL_UINT32 uMask,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
valid PRL_HANDLE describing the virtual machine
uMask
bit mask of really hard disk devices (little endian order). See PRL_HARD_DISK_IFACE_MASK enumeration for all bits.
nFlags
only bit PACF_NON_INTERACTIVE_MODE is used. Others bits are reserved

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with server connection or non identified VM object

Remarks

The machine should be registered on the server to do that.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Connect Function

PrlVm_Connect Function
PHT_VIRTUAL_MACHINE

Connect to remote desktop.

Syntax
PRL_HANDLE PrlVm_Connect(
    PRL_HANDLE hObj,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
nFlags
Flags, must be 0.

Returns

A handle of type PHT_JOB containing the results of operation.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ConvertDisks Function

PrlVm_ConvertDisks Function
PHT_VIRTUAL_MACHINE

Start process conversion of the virtual hard disk(s).

Syntax
PRL_HANDLE PrlVm_ConvertDisks(
    PRL_HANDLE hVm,
    PRL_UINT32 uMask,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
valid PRL_HANDLE describing the virtual machine
uMask
bit mask of really hard disk devices (little endian order). See PRL_HARD_DISK_IFACE_MASK enumeration for all bits.
nFlags
See PRL_CONVERT_VIRTUAL_DISK enumeration for using bits.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with server connection or non identified VM object

Remarks

The machine should be registered on the server to do that.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CreateCVSrc Function

PrlVm_CreateCVSrc Function
PHT_VIRTUAL_MACHINE

Creates video source object.

Syntax
PRL_RESULT PrlVm_CreateCVSrc(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR hCVSrc
);
File

PrlApiVm.h

Parameters

hVm
[in] A handle of type PHT_VIRTUAL_MACHINE identifying the Vm. Created video source will be linked to that Vm.
hCVSrc
[out] On success receives handle of type PHT_CVSRC.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_UNIMPLEMENTED - if featue is not implemented for specified Vm. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CreateEvent Function

PrlVm_CreateEvent Function
PHT_VIRTUAL_MACHINE

Creates VM event that bint to current VM.

Syntax
PRL_RESULT PrlVm_CreateEvent(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phEvent
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
buffer for storing result

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (null) pointer to buffer was specified PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate VM event object PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VIRTUAL_MACHINE


PrlVm_CreateP2PTransport Function

PrlVm_CreateP2PTransport Function
PHT_VIRTUAL_MACHINE

Create handle of type PHT_VIDEO_RECEIVER.

Syntax
PRL_RESULT PrlVm_CreateP2PTransport(
    PRL_HANDLE hObj,
    PRL_CONST_VIDEO_RECEIVER_CONFIG_PTR pConfig,
    PRL_HANDLE_PTR phVideoReceiver
);
File

PrlApiVideoReceiver.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
pConfig
Configuration.
phVideoReceiver
Will receive created handle of type PHT_VIDEO_RECEIVER.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_HANDLE - invalid handle or null pointer was passed. PRL_ERR_INVALID_ARG - handle of unsupported type was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CreateSnapshot Function

PrlVm_CreateSnapshot Function
PHT_VIRTUAL_MACHINE See Also

Creates a virtual machine snapshot.

Syntax
PRL_HANDLE PrlVm_CreateSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sName,
    PRL_CONST_STR sDescription
);
File

PrlApiVm.h

Parameters

sName
Snapshot name.
sDescription
Snapshot description.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_CreateUnattendedDisk Function

PrlVm_CreateUnattendedDisk Function
PHT_VIRTUAL_MACHINE

Creates a disk image in the virtual machine home directory for unattended Windows installation.

Syntax
PRL_HANDLE PrlVm_CreateUnattendedDisk(
    PRL_HANDLE hVm,
    PRL_GUEST_DISTRO_VERSION_ENUM nGuestDistroType,
    PRL_CONST_STR sUsername,
    PRL_CONST_STR sCompanyName,
    PRL_CONST_STR sSerialKey
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nGuestDistroType
Windows version.
sUsername
User name.
sCompanyName
Company name.
sSerialKey
Serial number.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The following steps describe how to prepare a virtual machine for unattended Windows installation:

  1. Create a virtual machine. The machine should have all the necessary devices, like hard drive and CD drive.
  2. Execute the PrlVm_CreateUnattendedDisk function to create a disk image.
  3. Insert Windows installation CD-ROM into the drive (or mount a disk image).
  4. Start the virtual machine. The machine will boot from the CD.
  5. Perform unattended Windows installation as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_CreateUnattendedFloppy Function

PrlVm_CreateUnattendedFloppy Function
PHT_VIRTUAL_MACHINE

Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.

Syntax
PRL_HANDLE PrlVm_CreateUnattendedFloppy(
    PRL_HANDLE hVm,
    PRL_GUEST_DISTRO_VERSION_ENUM nGuestDistroType,
    PRL_CONST_STR sUsername,
    PRL_CONST_STR sCompanyName,
    PRL_CONST_STR sSerialKey
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nGuestDistroType
Windows version.
sUsername
User name.
sCompanyName
Company name.
sSerialKey
Serial number.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The following steps describe how to prepare a virtual machine for unattended Windows installation:

  1. Create a virtual machine. The machine should have all the necessary devices, like hard drive and CD drive.
  2. Execute the PrlVm_CreateUnattendedFloppy function to create a floppy disk image.
  3. Insert Windows installation CD-ROM into the drive (or mount a disk image).
  4. Start the virtual machine. The machine will boot from the CD.
  5. Perform unattended Windows installation as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Decrypt Function

PrlVm_Decrypt Function
PHT_VIRTUAL_MACHINE

Decrypts earlier encrypted with some secret password phrase virtual machine.

Syntax
PRL_HANDLE PrlVm_Decrypt(
    PRL_HANDLE hVm,
    PRL_CONST_STR sPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sPassword
Password which was used earlier to encrypt virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
nFlags
Bitset of flags - flags from enums PRL_ENCRYPTION_FLAGS and PRL_API_COMMAND_FLAGS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Delete Function

PrlVm_Delete Function
PHT_VIRTUAL_MACHINE

Deletes the specified virtual machine from the host.

Syntax
PRL_HANDLE PrlVm_Delete(
    PRL_HANDLE hVm,
    PRL_HANDLE hDevicesList
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hDevicesList
A handle of type PHT_STRINGS_LIST containing a list of files (devices) to be deleted from the virtual machine directory. If the list is empty or the parameter contains a null pointer, the entire virtual machine directory will be deleted from the host. If the list contains one or more items, only the specified files will be delete (the rest of the virtual machines files will remain on the host in the original directory).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function un-registers the machine from the Parallels Service and deletes all its files. This operation cannot be undone. The specified machine must be registered with the Parallels Service. To un-register a machine from the Parallels Service without deleting any of its file, use the PrlVm_Unreg function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_DeleteSnapshot Function

PrlVm_DeleteSnapshot Function
PHT_VIRTUAL_MACHINE See Also

Deleted the specified virtual machine snapshot.

Syntax
PRL_HANDLE PrlVm_DeleteSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid,
    PRL_BOOL bChild
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sSnapshotUuid
Snapshot ID. To obtain a snapshot ID use the PrlVm_GetSnapshotsTreeEx function.
bChild
Specifies whether snapshots derived from the specified snapshot should be deleted or not. True - delete child snapshots. False - don't delete child snapshots.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_CreateSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_Disconnect Function

PrlVm_Disconnect Function
PHT_VIRTUAL_MACHINE

Disconnect from remote desktop.

Syntax
PRL_RESULT PrlVm_Disconnect(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Links
PHT_VIRTUAL_MACHINE


PrlVm_DropSuspendedState Function

PrlVm_DropSuspendedState Function
PHT_VIRTUAL_MACHINE

Resets a suspended virtual machine.

Syntax
PRL_HANDLE PrlVm_DropSuspendedState(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When a virtual machine is suspended with the PrlVm_Suspend call, the current state of the virtual machine processes is saved into a temporary file on the hard disk, and the virtual machine is stopped. When a suspended virtual machine is resumed with the PrlVm_Resume call, the data in the temp file is used to restore the state of the virtual machine processes. The PrlVm_DropSuspendedState function resets a suspended virtual machine by deleting the temp file from the drive Once the function successfully completes, the virtual machine can no longer be resumed with the PrlVm_Resume call. It still can be started normally, however.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Encrypt Function

PrlVm_Encrypt Function
PHT_VIRTUAL_MACHINE

Encrypts virtual machine data using specified secret password phrase.

Syntax
PRL_HANDLE PrlVm_Encrypt(
    PRL_HANDLE hVm,
    PRL_CONST_STR sPassword,
    PRL_CONST_STR sCipherPluginUuid,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sPassword
Password to encrypt virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
sCipherPluginUuid
Parameter reserved for further purposes - currently 0 should be specified.
nFlags
Bitset of flags - flags from enums PRL_ENCRYPTION_FLAGS and PRL_API_COMMAND_FLAGS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GenerateVmDevFilename Function

PrlVm_GenerateVmDevFilename Function
PHT_VIRTUAL_MACHINE

Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_GenerateVmDevFilename(
    PRL_HANDLE hVm,
    PRL_CONST_STR sFilenamePrefix,
    PRL_CONST_STR sFilenameSuffix,
    PRL_CONST_STR sIndexDelimiter
);
File

PrlApiVm.h

Parameters

sFilenamePrefix
A prefix to add to the name. Pass a null pointer to use a default value: "tmpfile". The name will be generated by adding a number to the prefix (e.g. tmpfile1, tmpfile2, tmpfile3, etc.)
sFilenameSuffix
A suffix to add to the name. Pass a null pointer for no suffix.
sIndexDelimiter
A character(s) that will be inserted between the prefix and the index (e.g. tmpfile_1, tmpfile_2, tmpfile_3, etc). You can specify a null pointer or an empty string if you don't want to insert any extra characters there.
hVM
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the home directory information is missing in the specified virtual machine object. If this is a new virtual machine, try updating the local object by calling the PrlVm_RefreshConfig or PrlSrv_GetVmList function.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetConfig Function

PrlVm_GetConfig Function
PHT_VIRTUAL_MACHINE

Obtains a handle of type PHT_VM_CONFIGURATION.

Syntax
PRL_RESULT PrlVm_GetConfig(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phVmCfg
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
phVmCfg
[out] A pointer to a variable that receives the handle of type PHT_VM_CONFIGURATION.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetPackedProblemReport Function

PrlVm_GetPackedProblemReport Function
PHT_VIRTUAL_MACHINE

The PrlVm_GetPackedProblemReport function obtains a Packed problem report on abnormal virtual machine termination.

Syntax
PRL_HANDLE PrlVm_GetPackedProblemReport(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine. PRL_UINT32 nFlags - reserved flags parameter

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

If a virtual machine stops running abnormally, you call this function to obtain a report from the Parallels Service describing the problem.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamAsString function to obtain a string containing path to the report directory.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetPerfStats Function

PrlVm_GetPerfStats Function
PHT_VIRTUAL_MACHINE

Obtains a handle of type PHT_EVENT containing the virtual machine performance statistics.

Syntax
PRL_HANDLE PrlVm_GetPerfStats(
    PRL_HANDLE hVm,
    PRL_CONST_STR sFilter
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sFilter
String representing statistics filter, use char '*' at the end to get subset of statistic. Could be NULL, to get all statistic.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_EVENT.
Links
PHT_VIRTUAL_MACHINE


PrlVm_GetProblemReport Function

PrlVm_GetProblemReport Function
PHT_VIRTUAL_MACHINE

The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.

Syntax
PRL_HANDLE PrlVm_GetProblemReport(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

If a virtual machine stops running abnormally, you call this function to obtain a report from the Parallels Service describing the problem.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamAsString function to obtain a string containing the report.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetQuestions Function

PrlVm_GetQuestions Function
PHT_VIRTUAL_MACHINE

The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.

Syntax
PRL_RESULT PrlVm_GetQuestions(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR pQuestionsList
);
File

PrlApiVm.h

Parameters

pQuestionsList
[out] A handle of type PHT_HANDLES_LIST containing a list of available questions.
handle
A handle of type PHT_VIRTUAL_MACHINE.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_SUCCESS - operation completed successfully.

Remarks

It can be used as an alternative to asynchronous question processing through events. You can use this function at any time to check if a question is awaiting the client response on the Parallels Service side.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetSnapshotsTree Function

PrlVm_GetSnapshotsTree Function
PHT_VIRTUAL_MACHINE See Also

Retrieves snapshot information for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_GetSnapshotsTree(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
flags
A flags from enum PRL_GET_SNAPSHOT_TREE_FLAGS and PRL_API_COMMAND_FLAGS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Snapshot information is returned as an XML file containing the snapshot tree. Some of the important XML elements are:

SavedStateItem -- the root element of the branch containing information about an individual snapshot. The element has an attribute "guid" containing the snapshot ID. The ID is required when performing other operations on a snapshot.

Name -- contains the snapshot name.

DateTime -- the snapshot creation date and time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a snapshot tree from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a string value containing the snapshots tree XML data.

Please note that no parser is provided to traverse the returned XML. To use this functionality, you will have to parse the returned XML yourself. This function will be replaced in the future releases of the Parallels SDK.

See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_SwitchToSnapshot

PrlVm_UpdateSnapshotData

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_GetSnapshotsTreeEx Function

PrlVm_GetSnapshotsTreeEx Function
PHT_VIRTUAL_MACHINE
Syntax
PRL_HANDLE PrlVm_GetSnapshotsTreeEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetState Function

PrlVm_GetState Function
PHT_VIRTUAL_MACHINE Example

Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.

Syntax
PRL_HANDLE PrlVm_GetState(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain the PHT_VM_INFO handle.

Example
hJob =
PrlVm_GetState( hVm );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the handle from job
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PHT_VIRTUAL_MACHINE, Example


PrlVm_GetStatistics Function

PrlVm_GetStatistics Function
PHT_VIRTUAL_MACHINE

Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.

Syntax
PRL_HANDLE PrlVm_GetStatistics(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_SYSTEM_STATISTICS containing the resource usage data.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetStatisticsEx Function

PrlVm_GetStatisticsEx Function
PHT_VIRTUAL_MACHINE

The PrlVm_GetStatisticsEx function is the same as PrlVm_GetStatistics function but with the flags

Syntax
PRL_HANDLE PrlVm_GetStatisticsEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nFlags
Bitset of flags - from enum PRL_API_COMMAND_FLAGS

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetSuspendedScreen Function

PrlVm_GetSuspendedScreen Function
PHT_VIRTUAL_MACHINE

Retrieves the virtual machine screen state before it was suspending.

Syntax
PRL_HANDLE PrlVm_GetSuspendedScreen(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_VM_IS_NOT_SUSPENDED - the virtual machine is not in the suspended state.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_GetToolsState Function

PrlVm_GetToolsState Function
PHT_VIRTUAL_MACHINE Example

Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.

Syntax
PRL_HANDLE PrlVm_GetToolsState(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Example

The following example illustrates how to obtain a handle of type PHT_VM_TOOLS_INFO. The hVm variable is a handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

PRL_HANDLE hJob, hResult, hVmToolsInfo;

hJob = PrlVm_GetToolsState( hVm );
PrlJob_Wait( hJob, 1000 );

PrlJob_GetResult( hJob, &hResult );
PrlHandle_Free( hJob );

PrlResult_GetParam( hJobResult, &hVmToolsInfo );
PrlHandle_Free( hJobResult );
Links
PHT_VIRTUAL_MACHINE, Example


PrlVm_InitiateDevStateNotifications Function

PrlVm_InitiateDevStateNotifications Function
PHT_VIRTUAL_MACHINE

This method lets to initiate sending notifications about devices states by VM.

Syntax
PRL_HANDLE PrlVm_InitiateDevStateNotifications(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with the Parallels Service connection or non identified VM object

Remarks

Those notifications have to be same as notifications after changing a device state

Links
PHT_VIRTUAL_MACHINE


PrlVm_InstallTools Function

PrlVm_InstallTools Function
PHT_VIRTUAL_MACHINE

Begin the Parallels Tools installation process.

Syntax
PRL_HANDLE PrlVm_InstallTools(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with Parallels Service connection or non identified VM object

Remarks

The machine must be registered with the Parallels Service to perform this operation.

Links
PHT_VIRTUAL_MACHINE


PrlVm_InstallUtility Function

PrlVm_InstallUtility Function
PHT_VIRTUAL_MACHINE

Installs a specified utility in a virtual machine.

Syntax
PRL_HANDLE PrlVm_InstallUtility(
    PRL_HANDLE hVm,
    PRL_CONST_STR strId
);
File

PrlApiVm.h

Parameters

strId
A string identifying the utility to install.
hServer
A handle of type PHT_VIRTUAL_MACHINE identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This functions is a part of the Parallels Tools functionality.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_LinkedClone Function

PrlVm_LinkedClone Function
PHT_VIRTUAL_MACHINE

Clones an existing virtual machine based on given snapshot.

Syntax
PRL_HANDLE PrlVm_LinkedClone(
    PRL_HANDLE hVm,
    PRL_CONST_STR new_vm_name,
    PRL_CONST_STR new_vm_root_path,
    PRL_CONST_STR snapshot_id,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
new_vm_name
The name to use for the new virtual machine.
new_vm_root_path
Name and path of the directory where the new virtual machine should be created. To create the machine in a default directory, pass an empty string.
snapshot_id
[optional] Snapshot UUID. If string is empty, then function behaves the same as PrlVm_CloneEx with flag PCVF_LINKED_CLONE.
nFlags
Clone flags (PCVF_CLONE_TO_TEMPLATE, PCVF_CHANGE_SID, PCVF_LINKED_CLONE, PCVF_IMPORT_BOOT_CAMP). Also PACF_NON_INTERACTIVE_MODE can be used to specify non interactive session working mode (remote side won't ask questions during operation progress in this case). Please note that clone operation can take it's own exclusive lock of virtual machine (in change SID or linked clone modes) - so VM shouldn't be exclusively locked with PrlVm_Lock call before clone operation performed.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function creates an exact copy of the specified virtual machine on the same host using the specified new name and location. In order to perform a clone operation, the original machine must be registered with the Parallels Service. A clone can be created as a virtual machine or as a template. To create a template, set the nFlags parameter to PACF_CLONEVM_TO_TEMPLATE value. The function can also be used to create new virtual machines from templates. In order to that, the hVm parameter must contain a handle to a template, the name and the path parameters must be set to desired values, and the bCreateTemplate parameter must be set to PRL_FALSE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Lock Function

PrlVm_Lock Function
PHT_VIRTUAL_MACHINE

Lets to exclusively lock VM for current session.

Syntax
PRL_HANDLE PrlVm_Lock(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

nReserved
reserved param for further purposes
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

After this call just current sesiion be able to operate with locked VM until PrlVm_Unlock will be called or current session will be closed. If VM was already locked by some another session (or the same one) then lock operation will fail.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are: PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_LoginInGuest Function

PrlVm_LoginInGuest Function
PHT_VIRTUAL_MACHINE See Also

Creates a new console session or binds to an existing GUI session in a virtual machine.

Syntax
PRL_HANDLE PrlVm_LoginInGuest(
    PRL_HANDLE hVm,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sUserPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sUserName
User name. This parameter must contain a valid guest OS user name or one of the following constants:

PRL_CURRENT_GUEST_OS_SESSION -- binds to an existing GUI session in a virtual machine.

PRL_PRIVILEGED_GUEST_OS_SESSION -- binds to an existing session under which Parallels Service is running. This session belongs to a privileged user (e.g. root on Linux or LocalSystem on Windows), so it can be used to perform administrative tasks.

Note that in order to use the constants above, the current user must be an administrator of the host OS or be the owner of the target virtual machine.

sUserPassword
User password. If the sUserName parameter contains one of the constants (see above) then this parameter can contain an empty string.
nFlags
A bitset of flags. Must be 0 in the current API implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Note: To use this function, Parallels Tools must be installed in the target virtual machine.

This function is used when you want to run a program in a virtual machine or perform an administrative task that require native guest operating system login. Depending on the type of the program that you would like to run, the login must be performed using one of the following methods:

  • To run a GUI application, call this function passing the PRL_CURRENT_GUEST_OS_SESSION constant in the sUserName parameter. The reason is the function can only bind to an existing GUI session and cannot create a new one. Prior to calling this function, a GUI session must already be open in a virtual machine (the machine must be running and a user must be logged in to it). The user password parameter can be blank.
  • To run a console program, the sUserName parameter can contain the PRL_PRIVILEGED_GUEST_OS_SESSION constant or a valid user name and password. When using PRL_PRIVILEGED_GUEST_OS_SESSION, the function will bind to an existing session under which Parallels Service is running. This session belongs to a privileged user (e.g. root on Linux or LocalSystem on Windows), so it can be used to perform administrative tasks. When specifying a user name and password, a new session will be created in the virtual machine.

On successful login, the function obtains a handle of type PHT_VM_GUEST_SESSION (see below for the instructions on how to get the handle from the PHT_JOB object). You can use the handle functions to run programs in a virtual machine and to perform other supported operations. See the PHT_VM_GUEST_SESSION handle description for a complete list of functions.

When the session is no longer needed, it should be closed using the PrlVmGuest_Logout function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the PHT_VM_GUEST_SESSION handle from the returned PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain the PHT_RESULT handle.
  2. Use the PrlResult_GetParam to obtain the PHT_VM_GUEST_SESSION handle.
See Also

PrlVmGuest_RunProgram

PrlVmGuest_Logout

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_Migrate Function

PrlVm_Migrate Function
PHT_VIRTUAL_MACHINE

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_Migrate(
    PRL_HANDLE hVm,
    PRL_HANDLE hTargetServer,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hTargetServer
A handle of type PHT_SERVER identifying the target Parallels Service.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVMT_COLD_MIGRATION, PVMT_WARM_MIGRATION, PVMT_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_MigrateCancel Function

PrlVm_MigrateCancel Function
PHT_VIRTUAL_MACHINE

Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.

Syntax
PRL_HANDLE PrlVm_MigrateCancel(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_MigrateEx Function

PrlVm_MigrateEx Function
PHT_VIRTUAL_MACHINE

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_MigrateEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR target_host,
    PRL_UINT32 target_port,
    PRL_CONST_STR target_session_id,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
target_host
The name of the target host machine.
target_port
The port number on the target host.
target_session_id
The target Parallels Service session ID. This ID can be retrieved with PrlLoginResponse_GetSessionUuid from the response of the login request.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVMT_COLD_MIGRATION, PVMT_WARM_MIGRATION, PVMT_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This is an extended version of PrlVm_Migrate function that allows to initiate VM migration process without active connection to target Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_MigrateWithRename Function

PrlVm_MigrateWithRename Function
PHT_VIRTUAL_MACHINE

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_MigrateWithRename(
    PRL_HANDLE hVm,
    PRL_HANDLE hTargetServer,
    PRL_CONST_STR target_name,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hTargetServer
A handle of type PHT_SERVER identifying the target Parallels Service.
target_name
Target VM name (i.e. what name will be given to VM on target system). Specify empty string to preserve VM name from source system.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVMT_COLD_MIGRATION, PVMT_WARM_MIGRATION, PVMT_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Mount Function

PrlVm_Mount Function
PHT_VIRTUAL_MACHINE

Mount the specified virtual machine Virtual Disks.

Syntax
PRL_HANDLE PrlVm_Mount(
    PRL_HANDLE hVm,
    PRL_CONST_STR sMntPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sMntPath
not used
nFlags
Mount flags of type PRL_MOUNT_VIRTUAL_DISK

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Move Function

PrlVm_Move Function
PHT_VIRTUAL_MACHINE

Move bundle of virtual machine or private area of container.

Syntax
PRL_HANDLE PrlVm_Move(
    PRL_HANDLE hVm,
    PRL_CONST_STR sNewHomePath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine or container.
sNewHomePath
Target path for Vm bundle or CT private
nFlags
Flags that specify move type. Not used yet.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function move all content of bundle to specify location. This function will move only stopped or suspended Vm/Ct.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Pause Function

PrlVm_Pause Function
PHT_VIRTUAL_MACHINE See Also

Pauses the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Pause(
    PRL_HANDLE hVm,
    PRL_BOOL bAcpi
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bAcpi
Specifies if ACPI should be used to pause the virtual machine. If set to PRL_FALSE, ACPI will not be used. In this case, all processes of the virtual machine will simply be stopped. If the parameter is set to PRL_TRUE, ACPI will be used to pause the machine. With ACPI, the machine will be paused using a method supported by the guest operating system (sleep, hibernate, etc.). The actual method used depends on the type and configuration of the guest OS.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A paused virtual machine can be resumed using the PrlVm_Start function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_Start

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_PtmExec Function

PrlVm_PtmExec Function
PHT_VIRTUAL_MACHINE

Executes an remote procedure.

Syntax
PRL_HANDLE PrlVm_PtmExec(
    PRL_HANDLE hVm,
    PRL_PTM_CONST_OBJECT_PTR pMethod
);
File

PrlApiPtm.h

Parameters

hVm
[in] A handle of type PHT_DESKTOP_CONTROL.
pMethod
[in] A pointer to an PRL_PTM_OBJECT structure the object name shall indicate RPC object to invoke the property values are used as RPC input parameters

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Routine invokes remote procedure method passing number of arguments to it.

Links
PHT_VIRTUAL_MACHINE


PrlVm_PtmQuery Function

PrlVm_PtmQuery Function
PHT_VIRTUAL_MACHINE

Query object properties .

Syntax
PRL_RESULT PrlVm_PtmQuery(
    PRL_HANDLE hVm,
    PRL_CONST_STR szObject,
    PRL_UINT32 * pPropertiesId,
    PRL_UINT32 cProperties
);
File

PrlApiPtm.h

Parameters

hVm
[in] A handle of type PHT_DESKTOP_CONTROL.
szObject
[in] An object name in PTM namespace
pPropertiesId
[in] point to an array of UINT32 elements containing PropertyId's. Specified properties values will be retrieved and delivered to client within PRL_PTM_OBJECT structure by PET_PTM_EVT_PROPERTY_CHANGED event. cProperties [in] number of elements in array pointed by pPropertiesId Zero is valid argument. In this case routine queries for object existence. If object does exist, object name with no properties will be received.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_HANDLE - invalid handle passed PRL_ERR_INVALID_ARG - invalid argument(s) have been passed PRL_ERR_UNIMPLEMENTED - feature is not implemented for specified handle. PRL_ERR_FAILURE - failed to send command. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_PtmSet Function

PrlVm_PtmSet Function
PHT_VIRTUAL_MACHINE

Set object properties .

Syntax
PRL_RESULT PrlVm_PtmSet(
    PRL_HANDLE hVm,
    PRL_PTM_CONST_OBJECT_PTR pObjects,
    PRL_UINT32 cObjects
);
File

PrlApiPtm.h

Parameters

hVm
[in] A handle of type PHT_DESKTOP_CONTROL.
pObjects
[in] A pointer to an array PRL_PTM_OBJECT structures
cObjects
[in] number of elements pointed by pObjectsList pointer Zero value is not a valid argument, in this case function returns PRL_ERR_INVALID_ARG

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_HANDLE - invalid handle passed PRL_ERR_INVALID_ARG - invalid argument(s) have been passed PRL_ERR_UNIMPLEMENTED - feature is not implemented for specified handle. PRL_ERR_FAILURE - failed to send command. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Routine allows atomically updating multiple properties of multiple objects

Links
PHT_VIRTUAL_MACHINE


PrlVm_PtmSubscribe Function

PrlVm_PtmSubscribe Function
PHT_VIRTUAL_MACHINE

Subscribe on object properties changes.

Syntax
PRL_RESULT PrlVm_PtmSubscribe(
    PRL_HANDLE hVm,
    PRL_CONST_STR szObject,
    PRL_UINT32 * pValuePropertiesId,
    PRL_UINT32 cValue,
    PRL_UINT32 * pNotifyPropertiesId,
    PRL_UINT32 cNotify
);
File

PrlApiPtm.h

Parameters

hVm
[in] A handle of type PHT_DESKTOP_CONTROL.
szObject
[in] An object name in PTM namespace to subscribe notifications with.
pValuePropertiesId
[in] point to an array of UINT32 elements containing PropertyId's. Values of specified properties will be automatically sent back to client whenever they are changed. Can be NULL only when cValues is zero, otherwise must point to valid array.
cValue
[in] number of elements in array pointed by pValuePropertiesId Zero is a valid argument, see Notes.
pNotifyPropertiesId
[in] point to an array of UINT32 elements containin PropertyId's PTM will notify about those properties changes, but the values of those changed properties will be NOT sent to client. Client may query value of a changed property explicitly using PrlVm_PtmQuery. Can be NULL only when cNotify is zero, otherwise must point to valid array.
cNotify
[in] number of elements in array pointed by pNotifyPropertiesId Zero is a valid argument, see Notes.

Notes
Subscription is not cumulative. Value and Notification IDs are immediatelly overwrite previous subscription. Therefore, when both cValue and cNotify are zero, this routine performs complete Unsubscribe.

Properties values and change notifications are delivered to client within PRL_PTM_OBJECT structure by PET_PTM_EVT_PROPERTY_CHANGED event

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_HANDLE - invalid handle passed PRL_ERR_INVALID_ARG - invalid argument(s) have been passed PRL_ERR_UNIMPLEMENTED - feature is not implemented for specified handle. PRL_ERR_OPERATION_FAILED - client already subscribed PRL_ERR_FAILURE - failed to send command. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_RefreshConfig Function

PrlVm_RefreshConfig Function
PHT_VIRTUAL_MACHINE

The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).

Syntax
PRL_HANDLE PrlVm_RefreshConfig(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine. This is the object that will be updated.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When you obtain a virtual machine handle that refers to an existing virtual machine, it is populated with the virtual machine configuration data. When working with configuration data, you always work with this local copy. Naturally, the configuration can change on the Parallels Service side at any time. The PrlVm_RefreshConfig function allows to re-retrieve the configuration data from the Parallels Service. The function can be used when an event of type PET_DSP_EVT_VM_CONFIG_CHANGED is triggered (the event notifies the client that the virtual machine configuration has been modified), or on unsuccessful PrlVm_Commit operation, or at any time you want to synchronize your local virtual machine object with the Parallels Service. Please note that the function replaces the local data, so if you made any modification to it, the changes will be lost.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Reg Function

PrlVm_Reg Function
PHT_VIRTUAL_MACHINE Example

See also PrlVm_RegEx

Syntax
PRL_HANDLE PrlVm_Reg(
    PRL_HANDLE hVm,
    PRL_CONST_STR sVmParentPath,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApiVm.h

Example

The following example shows how to create a new virtual machine. The sample assumes that the client program has already obtained a server object handle (hServer) and performed the Parallels Service login operation.

PRL_HANDLE hVm;
PRL_HANDLE hResult;
PRL_RESULT nJobRetCode;
PRL_RESULT ret;

// Obtain a new virtual machine handle.
ret = PrlSrv_CreateVm(hServer, &hVm);
if (PRL_FAILED(ret))
{
    // Error handling goes here...
    return ret;
}

// Get the host config info.
hJob = PrlSrv_GetSrvConfig(hServer);
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlSrv_GetSrvConfig.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Get a handle to the object containing the result of PrlSrv_GetSrvConfig,
// and then get a handle to the server configuration object from it.
ret = PrlJob_GetResult(hJob, &hResult);
PRL_HANDLE hSrvCfg;
PrlResult_GetParam(hResult, &hSrvCfg);

// Delete the job and the result handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hResult);

// Now that we have the host machine configuration data,
// we can set the default configuration for the new virtual machine.
ret = PrlVm_SetDefaultConfig(
                hVm, // VM handle.
                hSrvCfg, // Host config data.
                PVS_GUEST_TYPE_WINDOWS, // Target OS type.
                PVS_GUEST_VER_WIN_2003, // Target OS version.
                PRL_TRUE); // Create and connect devices.

if (PRL_FAILED(ret))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hSrvCfg);
    PrlHandle_Free(hVm);
    return ret;
}

PrlHandle_Free(hSrvCfg);

// Set the virtual machine name.
ret = PrlVm_SetName(hVm, "My Windows Server 2003");

// The following two calls demonstrate how to modify
// some of the default values of the virtual machine configuration.
// These calls are optional. You may remove them to use the default values.

// Set the RAM size for the machine to 256 MB.
ret = PrlVm_SetRamSize(hVm, 256);

// Set the virtual hard disk size to 20 GB.
// First, get the handle to the hard disk object using the
// PrlVm_GetHardDisk function. The index of 0 is used
// because the default configuration has just one virtual hard disk.
// After that, use the handle to set the disk size to the desired value.

PRL_HANDLE hHDD;
ret = PrlVm_GetHardDisk(hVm, 0, &hHDD);
ret = PrlVmDevHd_SetDiskSize(hHDD, 20000);

// Create and register the machine with the Parallels Service.
hJob = PrlVm_Reg(hVm, // VM handle.
                 "", // VM root directory (using default).
                 PRL_TRUE); // Using non-interactive mode.

// Wait for the operation to complete.
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlVm_Reg.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Delete handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hVm);
Links
PHT_VIRTUAL_MACHINE, Example


PrlVm_RegEventHandler Function

PrlVm_RegEventHandler Function
PHT_VIRTUAL_MACHINE

Registers an event handler (callback function) with the virtual machine.

Syntax
PRL_RESULT PrlVm_RegEventHandler(
    PRL_HANDLE hObj,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
handler
A pointer to the callback function that will handle events.
userData
A pointer to a user data that will be passed to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To use the callback functionality, you first have to implement a callback function. The callback function must have a specific signature (see PRL_METHOD_PTR for the prototype). After you register an event handler with a virtual machine, the callback function will be called every time an event is generated in the machine.

You can also register an event handler with a Parallels Service (instead of a particular virtual machine) using the PrlSrv_RegEventHandler function. If you register the event handler with the Parallels Service, you will be able to receive events from all of the virtual machines registered with that Parallels Service. For more information on events and asynchronous functions, see the Parallels Virtualization SDK Programmer's Guide.

Links
PHT_VIRTUAL_MACHINE


PrlVm_RegEx Function

PrlVm_RegEx Function
PHT_VIRTUAL_MACHINE

Creates a new virtual machine and registers it with the Parallels Service.

Syntax
PRL_HANDLE PrlVm_RegEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR sVmParentPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sVmParentPath
Optional. Name and path of the parent directory where the virtual machine directory should be created. If this parameter is omitted (null pointer or empty string is passed), the new virtual machine directory will be created in the default directory for this Parallels Service.
nFlags
Flags set which specifies way of virtual machine creation. Use PACF_NON_INTERACTIVE_MODE flag here instead of deprecated bNonInteractiveMode parameter. Other bitset of flags - from enum PRL_CREATE_DISK_IMAGE_FLAGS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The steps involved in creating a typical virtual machine are:

  1. Obtain a handle to a new virtual machine object using the PrlSrv_CreateVm function.
  2. Populate the object with the desired configuration data.
  3. Choose a name for the virtual machine and set it using the PrlVmCfg_SetName function.
  4. Create and register the new machine with a Parallels Service using the PrlVm_Reg function. This step will create the necessary virtual machine files on the host and will add the machine to the Parallels Service VM registry. The directory containing the virtual machine files will have the same name as the name you've chosen for your virtual machine. The directory will be created in the default VM root directory for this Parallels Service. If you would like to create the virtual machine directory in a different location, you may specify the desired parent directory name and path.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_RemoveProtection Function

PrlVm_RemoveProtection Function
PHT_VIRTUAL_MACHINE

Removes protection from virtual machine.

Syntax
PRL_HANDLE PrlVm_RemoveProtection(
    PRL_HANDLE hVm,
    PRL_CONST_STR sProtectionPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sProtectionPassword
Password which was used earlier to protect virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
nFlags
Reserved

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Reset Function

PrlVm_Reset Function
PHT_VIRTUAL_MACHINE

Resets the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Reset(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function is an equivalent of PrlVm_Stop and PrlVm_Start functions executed in succession. The stop operation will NOT use ACPI, so the entire reset operation will resemble the "Reset" button pressed on a physical box.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ResetUptime Function

PrlVm_ResetUptime Function
PHT_VIRTUAL_MACHINE

Resets the virtual machine uptime counter (start date and counter itself).

Syntax
PRL_HANDLE PrlVm_ResetUptime(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nFlags
Reserved for future use.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object. To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully. PRL_ERR_UNINITIALIZED â€“ unknown PHT_VIRTUAL_MACHINE handle or invalid binding to server connection.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Restart Function

PrlVm_Restart Function
PHT_VIRTUAL_MACHINE

Restarts the operating system of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Restart(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or start mode of virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Restore Function

PrlVm_Restore Function
PHT_VIRTUAL_MACHINE

Restores the registered virtual machine.

Syntax
PRL_HANDLE PrlVm_Restore(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PHT_VIRTUAL_MACHINE


PrlVm_Resume Function

PrlVm_Resume Function
PHT_VIRTUAL_MACHINE See Also

Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.

Syntax
PRL_HANDLE PrlVm_Resume(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_Suspend

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_SendClipboardRequest Function

PrlVm_SendClipboardRequest Function
PHT_VIRTUAL_MACHINE

@brief Requests clipboard buffer from Vm

@note This call is intended to be asynchronious with possibility to be synchroneous.

Syntax
PRL_RESULT PrlVm_SendClipboardRequest(
    PRL_HANDLE hVm,
    PRL_UINT32 command,
    PRL_UINT32 flags,
    PRL_CONST_VOID_PTR data,
    PRL_UINT32 dataSize
);
File

PrlApiVm.h

Returns

PRL_RESULT.

Possible values: PRL_ERR_INVALID_ARG - non valid VM device PRL_INVALID_HANDLE - invalid handle or valid handle if success.

Remarks

It can be used when it's necessary to wait for Vm answer.

Links
PHT_VIRTUAL_MACHINE


PrlVm_SetConfig Function

PrlVm_SetConfig Function
PHT_VIRTUAL_MACHINE

The PrlVm_SetConfig is reserved and does nothing.

Syntax
PRL_RESULT PrlVm_SetConfig(
    PRL_HANDLE hVm,
    PRL_HANDLE hVmCfg
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_SetProtection Function

PrlVm_SetProtection Function
PHT_VIRTUAL_MACHINE

Protects virtual machine using specified secret password phrase.

Syntax
PRL_HANDLE PrlVm_SetProtection(
    PRL_HANDLE hVm,
    PRL_CONST_STR sProtectionPassword,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine object.
sProtectionPassword
Password to protect virtual machine. UTF-8 encoded string ending with null (0) symbol. Can be null (0) in case of empty password.
nFlags
Reserved

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_MACHINE type) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Start Function

PrlVm_Start Function
PHT_VIRTUAL_MACHINE See Also

Start the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Start(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.s

Remarks

This function can be used to start a stopped or paused virtual machine.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_Pause

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_StartEx Function

PrlVm_StartEx Function
PHT_VIRTUAL_MACHINE

Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).

Syntax
PRL_HANDLE PrlVm_StartEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nStartMode,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nStartMode
Virtual machine start mode.
nReserved
This is a reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Use this function instead of the PrlVm_Start function to start the virtual machine in a normal or safe mode. Other modes may be added in the future.

If VM is starting in PSM_VM_START_FOR_COMPACT mode then flags (third argument) have to be equal PRL_HARD_DISK_IFACE_MASK enum.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or start mode of virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_StartVncServer Function

PrlVm_StartVncServer Function
PHT_VIRTUAL_MACHINE See Also

Starts a VNC server for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_StartVncServer(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nReserved
Reserved parameter for future purposes. Must contain 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer for user name was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StopVncServer

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_Stop Function

PrlVm_Stop Function
PHT_VIRTUAL_MACHINE

Stop the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Stop(
    PRL_HANDLE hVm,
    PRL_BOOL bGraceful
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bGraceful
If graceful shutdown is used, the machine will be properly shutdown by means of Guest tools (if available), or by ACPI request, If shutdown timeout expired the Vm will be forcebly stopped. If graceful shutdown is not used, the machine will be simply "unplugged"

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_StopEx Function

PrlVm_StopEx Function
PHT_VIRTUAL_MACHINE

Stop the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_StopEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nStopMode,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nStopMode
Virtual machine stop mode, an enumerator from the PRL_VM_STOP_MODE enumeration.
nFlags
Virtual machine stop option, an enumerator from the PRL_VM_STOP_FLAGS enumeration.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_StopVncServer Function

PrlVm_StopVncServer Function
PHT_VIRTUAL_MACHINE See Also

Stops the VNC server that was previously started for a virtual machine.

Syntax
PRL_HANDLE PrlVm_StopVncServer(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nReserved
Reserved parameter for future purposes. Must be 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer for user name was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StartVncServer

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_SubscribeToGuestStatistics Function

PrlVm_SubscribeToGuestStatistics Function
PHT_VIRTUAL_MACHINE See Also

Subscribes to receive the specified virtual machine performance statistics on a periodic basis.

Syntax
PRL_HANDLE PrlVm_SubscribeToGuestStatistics(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_VM_STATISTICS_UPDATED indicate an event containing performance data. To access the statistics handle (a handle of type PHT_SYSTEM_STATISTICS), first extract the event parameter using PrlEvent_GetParam, then convert the result (which will be a handle to an object of type PHT_EVENT_PARAMETER) to a handle using PrlEvtPrm_ToHandle. The functions that operate on PHT_SYSTEM_STATISTICS references can then be used to obtain statistics data.

For the event handler to be called, it is necessary to register it with PrlVm_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlVm_UnsubscribeFromGuestStatistics. When events are no longer required, unregister the event handler using PrlVm_UnregEventHandler.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_SubscribeToHostStatistics

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_SubscribeToPerfStats Function

PrlVm_SubscribeToPerfStats Function
PHT_VIRTUAL_MACHINE

Allows to subscribe to periodicaly receive virtual machine perfomance statistics.

Syntax
PRL_HANDLE PrlVm_SubscribeToPerfStats(
    PRL_HANDLE hVm,
    PRL_CONST_STR sFilter
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sFilter
String representing statistics filter, use char '*' at the end to get subset of statistic. Could be NULL, to get all statistic.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_VM_PERFSTATS indicate an event containing statistics data. The perfomace statistics repesented by parameters of Event object (a handle of type PHT_EVENT).

For the event handler to be called, it is necessary to register it with PrlSrv_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlVm_UnsubscribeFromHostPerfStats. When events are no longer required, unregister the event handler using PrlVm_UnregEventHandler.

If method is called mutliple times, the 'filter' value is updated each time on the Parallels Service side.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Suspend Function

PrlVm_Suspend Function
PHT_VIRTUAL_MACHINE See Also

Suspends the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Suspend(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When a running virtual machine is suspended, the state of the virtual machine processes is saved into a file on the host and after that the machine is stopped. To resume the machine, use the PrlVm_Resume function. If, after suspending a machine, you don't want to resume it but would like to return to the previous state, you may call the PrlVm_DropSuspendedState function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_Resume

PrlVm_DropSuspendedState

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_SwitchToSnapshot Function

PrlVm_SwitchToSnapshot Function
PHT_VIRTUAL_MACHINE See Also

Reverts the specified virtual machine to the specified snapshot.

Syntax
PRL_HANDLE PrlVm_SwitchToSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid
);
File

PrlApiVm.h

Parameters

sSnapshotUuid
The ID of a snapshot to revert to. To obtain a list of the available snapshots and their IDs, use the PrlVm_GetSnapshotsTreeEx function.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_UpdateSnapshotData

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_SwitchToSnapshotEx Function

PrlVm_SwitchToSnapshotEx Function
PHT_VIRTUAL_MACHINE See Also

Reverts the specified virtual machine to the specified snapshot.

Syntax
PRL_HANDLE PrlVm_SwitchToSnapshotEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

sSnapshotUuid
The ID of a snapshot to revert to. To obtain a list of the available snapshots and their IDs, use the PrlVm_GetSnapshotsTreeEx function.
nFlags
Bitset of flags - from enum PRL_SWITCH_SNAPSHOT_FLAGS
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_UpdateSnapshotData

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_TisGetIdentifiers Function

PrlVm_TisGetIdentifiers Function
PHT_VIRTUAL_MACHINE See Also

Retrieves a list of identifiers from the Tools Information Service database.

Syntax
PRL_RESULT PrlVm_TisGetIdentifiers(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phUidsList
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
phUidsList
[out] A handle of type PHT_STRINGS_LIST containing the identifiers.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_STRINGS_LIST object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_TisGetRecord

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_TisGetRecord Function

PrlVm_TisGetRecord Function
PHT_VIRTUAL_MACHINE See Also

Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.

Syntax
PRL_RESULT PrlVm_TisGetRecord(
    PRL_HANDLE hVm,
    PRL_CONST_STR sUid,
    PRL_HANDLE_PTR phRecord
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sUid
TIS database record identifier. The list of identifiers can be retrieved from the TIS database with PrlVm_TisGetIdentifiers.
phRecord
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_TIS_RECORD object.

PRL_ERR_TIS_INVALID_UID - specified record not found.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_TisGetIdentifiers

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_TisSubscribe Function

PrlVm_TisSubscribe Function
PHT_VIRTUAL_MACHINE

Subscribe on TIS database updates.

Syntax
PRL_RESULT PrlVm_TisSubscribe(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_TisUnsubscribe Function

PrlVm_TisUnsubscribe Function
PHT_VIRTUAL_MACHINE

Unsubscribe from TIS database updates.

Syntax
PRL_RESULT PrlVm_TisUnsubscribe(
    PRL_HANDLE hObj
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ToolsGetShutdownCapabilities Function

PrlVm_ToolsGetShutdownCapabilities Function
PHT_VIRTUAL_MACHINE

Obtains the available capabilities of a graceful virtual machine shutdown using Parallels Tools.

Syntax
PRL_RESULT PrlVm_ToolsGetShutdownCapabilities(
    PRL_HANDLE hVm,
    PRL_UINT32_PTR pCapsMask
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pCapsMask
[out] A bitmask containing the supported graceful shutdown capabilities. See the PRL_GRACEFUL_SHUTDOWN_CAPABILITIES enumeration for available options.

Returns

PRL_RESULT. Possible values:

PRL_ERR_FAILURE - means that for some reason capabilities of graceful shutdown tool can't be obtained.

PRL_ERR_INVALID_ARG - invalid vm handle or null pointer was passed.

PRL_ERR_UNINITIALIZED - Desktop object is not accessible

PRL_ERR_UNIMPLEMENTED - guest OS shutdown isn't supported

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When the Parallels Tools package is installed in a virtual machine, a graceful shutdown can be performed from the outside. The available shutdown capabilities depend on the guest operating system and can be obtained using this function.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ToolsSendShutdown Function

PrlVm_ToolsSendShutdown Function
PHT_VIRTUAL_MACHINE

Initiates graceful shutdown of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_ToolsSendShutdown(
    PRL_HANDLE hVm,
    PRL_GRACEFUL_SHUTDOWN_KIND kind
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
kind
Specifies the type of the shutdown.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_ToolsSetTaskBarVisibility Function

PrlVm_ToolsSetTaskBarVisibility Function
PHT_VIRTUAL_MACHINE

brief Show/Hide task bar in guest.

Syntax
PRL_RESULT PrlVm_ToolsSetTaskBarVisibility(
    PRL_HANDLE hVm,
    PRL_UINT32 uVisibility
);
File

PrlApiVm.h

Remarks

param[in] A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine. param[in] uVisibility - values of PRL_TASKBAR_STATES enum

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuQueryCaretInfo Function

PrlVm_UIEmuQueryCaretInfo Function
PHT_VIRTUAL_MACHINE

Posts "get caret info" query to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuQueryCaretInfo(
    PRL_HANDLE hVm,
    PRL_INT32 queryId,
    PRL_UINT32 queryFlags
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
queryId
[in] user-defined value that will be in response.
quertFlags
[in] additional options.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Response will be received via PET_IO_UIEMU_CARET_INFO event with PRL_UIEMU_CARET_INFO structure on board. Note, that guest tool will not always reply with PET_IO_UIEMU_CARET_INFO event. It will reply only when it got some information on caret. Since not all versions of User Input Emulation tool support this request and not all guest OS can supply required functionality, use TIS uuid "parallels.UserInputEmulation.guest.cross.plugin.CaretInfo" to get status of that feature. If this uuid is in active state in TIS database, this function can be used.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuQueryElementAtPos Function

PrlVm_UIEmuQueryElementAtPos Function
PHT_VIRTUAL_MACHINE

Posts "get info on element at specified position" query to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuQueryElementAtPos(
    PRL_HANDLE hVm,
    PRL_INT32 posX,
    PRL_INT32 posY,
    PRL_INT32 queryId,
    PRL_UINT32 queryFlags
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
posX
[in] x coordinate within guest screen.
posY
[in] y coordinate within guest screen.
queryId
[in] user-defined value that will be in response.
queryFlags
[in] additional options.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Response will be received via PET_IO_UIEMU_ELEMENT_AT_POS event with PRL_UIEMU_ELEMENT_AT_POS structure on board. Note, that guest tool will not always reply with PET_IO_UIEMU_ELEMENT_AT_POS event. It will reply only when it got some information on UI element at specified position. Since not all versions of User Input Emulation tool support this request and not all guest OS can supply required functionality, use TIS uuid "parallels.UserInputEmulation.guest.win.plugin.UIElement" to get status of that feature. If this uuid is in active state in TIS database, this function can be used. Note, that the lowest version of User Input Emulation tool (TIS uuid "parallels.UserInputEmulation.guest.win.plugin") that can support that request is 1.2 (but it is always enough to check only for "parallels.UserInputEmulation.guest.win.plugin.UIElement").

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuQueryNearestElementAtPos Function

PrlVm_UIEmuQueryNearestElementAtPos Function
PHT_VIRTUAL_MACHINE

Posts "get info on nearest element at specified position" query to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuQueryNearestElementAtPos(
    PRL_HANDLE hVm,
    PRL_INT32 queryId,
    PRL_INT32 posX,
    PRL_INT32 posY,
    PRL_UINT32 searchDiameter,
    PRL_UINT32 queryFlags
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
queryId
[in] user-defined value that will be in response.
posX
[in] x coordinate within guest screen.
posY
[in] y coordinate within guest screen.
searchDiameter
[in] diameter of search nearest element area.
queryFlags
[in] additional options. One of PRL_QUERY_ELEMENT_FLAGS.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Response will be received via PET_IO_UIEMU_ELEMENT_AT_POS event with PRL_UIEMU_ELEMENT_AT_POS structure on board. Guest tool will always reply. Since not all versions of User Input Emulation tool support this request and not all guest OS can supply required functionality, use TIS uuid TIS_UID_UIEMU_GUEST_CROSS_PLUGIN_NEAREST_ELEMENT ("parallels.UserInputEmulation.guest.cross.plugin.NearestElement") to get status of that feature. If this uuid is in active state in TIS database, this function can be used.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendClick Function

PrlVm_UIEmuSendClick Function
PHT_VIRTUAL_MACHINE

Send mouse click event to User Input Emulation.

Syntax
PRL_RESULT PrlVm_UIEmuSendClick(
    PRL_HANDLE hVm,
    PRL_INT32 posX,
    PRL_INT32 posY,
    PRL_UINT32 count,
    PRL_UINT32 button
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
posX
[in] x coordinate within guest screen.
posY
[in] y coordinate within guest screen.
count
[in] Click count. One of PRL_UIEMU_MOUSE_CLICK.
button
[in] Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. Don't use PMB_NOBUTTON, because in this case no button to click.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Click mouse button at the specified absolute position.

Since not all versions of User Input Emulation tool support this request and not all guest OS can supply required functionality, use TIS uuid TIS_UID_UIEMU_GUEST_CROSS_CLICK ("parallels.UserInputEmulation.guest.cross.Click") to get status of that feature. If this uuid is in active state in TIS database, this function can be used.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendGestureEvent Function

PrlVm_UIEmuSendGestureEvent Function
PHT_VIRTUAL_MACHINE

Sends a gesture event to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuSendGestureEvent(
    PRL_HANDLE hVm,
    PRL_CONST_UIEMU_GESTURE_EVENT_PTR pGestureEvent
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
pGestureEvent
[in] Gesture event description struct

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendInput Function

PrlVm_UIEmuSendInput Function
PHT_VIRTUAL_MACHINE

Send input to guest.

Syntax
PRL_RESULT PrlVm_UIEmuSendInput(
    PRL_HANDLE hVm,
    PRL_HANDLE hInput,
    PRL_UINT32 reserved
);
File

PrlApiVm.h

Parameters

hVm
[in] Vm handle. Must be valid.
hInput
[in] Handle of type PHT_UIEMU_INPUT. Must be valid.
reserved
[in] Must be 0.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - not enough memory. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Input object must not be modified from other thread during this operation.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendMultimediaKey Function

PrlVm_UIEmuSendMultimediaKey Function
PHT_VIRTUAL_MACHINE

Sends a multimedia key to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuSendMultimediaKey(
    PRL_HANDLE hVm,
    PRL_UIEMU_MMKEY mmkey,
    PRL_UINT32 flags
);
File

PrlApiVm.h

Parameters

hVm
[in] Handle of type PHT_VIRTUAL_MACHINE. Must be valid.
mmkey
[in] multimedia key id
flags
[in] additional options.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - specified arguments are invalid. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Remarks

Check "parallels.UserInputEmulation.guest.cross.EdgeSwipes" in TIS to detect whether Windows 8 edge swipes are available

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendScroll Function

PrlVm_UIEmuSendScroll Function
PHT_VIRTUAL_MACHINE

Send scroll event to User Input Emulation.

Syntax
PRL_RESULT PrlVm_UIEmuSendScroll(
    PRL_HANDLE hObj,
    PRL_UIEMU_SCROLL_UNITS scrollUnits,
    PRL_INT32 scrollX,
    PRL_INT32 scrollY,
    PRL_UINT32 flags
);
File

PrlApiVm.h

Parameters

hObj
[in] A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
scrollUnits
[in] Scroll units.
scrollX
[in] Amount of scroll along X axis.
scrollY
[in] Amount of scroll along Y axis.
flags
[in] Flags. One of PRL_UIEMU_SCROLL_FLAGS.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - hVm is invalid, uiEmuVersion or text is 0. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_FAILURE - failed to send event.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UIEmuSendText Function

PrlVm_UIEmuSendText Function
PHT_VIRTUAL_MACHINE

Send specified UTF8 text to guest User Input Emulation tool.

Syntax
PRL_RESULT PrlVm_UIEmuSendText(
    PRL_HANDLE hObj,
    PRL_CONST_STR text,
    PRL_UINT32 textLength,
    PRL_UINT32 flags,
    PRL_UINT32_PTR textSent
);
File

PrlApiVm.h

Parameters

hObj
[in] A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
text
[in] text to send. Must be UTF8 encoded. Can't be 0.
textLength
[in] text length. Can be 0 - in that case text must be zero terminated. Use PrlApi_UIEmuSendTextMaxLength() to get maximum text length for specified version.
flags
[in] Flags. Must be 0 now.
textSent
[out] On success receives length of text that was actually sent. Can be 0.
uiEmuVersion
[in] Guest tool version that can be returned by TIS. Can't be 0.

Returns

PRL_RESULT. Possible values: PRL_ERR_UNINITIALIZED - SDK was not properly initialized. PRL_ERR_INVALID_ARG - hVm is invalid, uiEmuVersion or text is 0. PRL_ERR_VM_TOOL_NOT_AVAILABLE - required OS Integration tool not present. PRL_ERR_UNIMPLEMENTED - operation is not supported by current tool version. PRL_ERR_OUT_OF_MEMORY - memory allocation error during send. PRL_ERR_SUCCESS - function completed successfully.

Remarks

This will have the same affect as user typed specified text from keyboard.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Umount Function

PrlVm_Umount Function
PHT_VIRTUAL_MACHINE

Unmount the specified virtual machine Virtual Disks.

Syntax
PRL_HANDLE PrlVm_Umount(
    PRL_HANDLE hVm,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Unlock Function

PrlVm_Unlock Function
PHT_VIRTUAL_MACHINE

Lets to unlock previously locked with PrlVm_Lock call VM.

Syntax
PRL_HANDLE PrlVm_Unlock(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

nReserved
reserved param for further purposes
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Note that just VM lock owner session can unlock VM.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_Unreg Function

PrlVm_Unreg Function
PHT_VIRTUAL_MACHINE

Unregisters the specified virtual machine from the Parallels Service.

Syntax
PRL_HANDLE PrlVm_Unreg(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This call removes the virtual machine from the Parallels Service registry, but does not delete the virtual machine files from the hard drive. You can re-register a machine with the Parallels Service at any time using the PrlSrv_RegisterVm or PrlSrv_RegisterVmEx functions call.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UnregEventHandler Function

PrlVm_UnregEventHandler Function
PHT_VIRTUAL_MACHINE

Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.

Syntax
PRL_RESULT PrlVm_UnregEventHandler(
    PRL_HANDLE hObj,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApiVm.h

Parameters

hObj
A handle of type PHT_VIRTUAL_MACHINE or PHT_DESKTOP_CONTROL.
handler
A pointer to the callback function. This must be the same pointer that was passed to the PrlVm_RegEventHandler when the event handler was registered with the virtual machine.
userData
A pointer to the user data. This must also be the same pointer that was passed to the PrlVm_RegEventHandler when the event handler was registered with the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you no longer want to receive event notifications from the virtual machine. The values of the handler and userData parameter constitute a unique pair which will be used to identify the event handler that will be unregistered. Make sure that you supply the same values as the ones you used when you registered the handler.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UnsubscribeFromGuestStatistics Function

PrlVm_UnsubscribeFromGuestStatistics Function
PHT_VIRTUAL_MACHINE

Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.

Syntax
PRL_HANDLE PrlVm_UnsubscribeFromGuestStatistics(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UnsubscribeFromPerfStats Function

PrlVm_UnsubscribeFromPerfStats Function
PHT_VIRTUAL_MACHINE

Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.

Syntax
PRL_HANDLE PrlVm_UnsubscribeFromPerfStats(
    PRL_HANDLE hVm
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UpdateSecurity Function

PrlVm_UpdateSecurity Function
PHT_VIRTUAL_MACHINE

Updates access level for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_UpdateSecurity(
    PRL_HANDLE hVm,
    PRL_HANDLE hAccessRights
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hAccessRights
A handle of type PHT_ACCESS_RIGHTS containing the virtual machine access level information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

By default, only the owner of a virtual machine has full access to it. All other users are completely unaware of the machine (it will not even appear in the list of the available virtual machines for them). The owner of the virtual machine can change that by setting one of the predefined access levels for the machine. Depending on the level of access set by the owner, other users will be able to see the machine and to perform tasks on it.

To update the access level, obtain a handle of type PHT_ACCESS_RIGHTS, set the desired level using the PrlAcl_SetAccessForOthers function, and then call this function to apply the changes to the virtual machine. The caller must be the owner of the machine to perform this operation. The PrlAcl_IsCurrentSessionOwner function can be used to determine if the current user is the owner of the virtual machine.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - current user is not the owner of the target virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_MACHINE


PrlVm_UpdateSnapshotData Function

PrlVm_UpdateSnapshotData Function
PHT_VIRTUAL_MACHINE See Also

Modifies the specified virtual machine snapshot name and description.

Syntax
PRL_HANDLE PrlVm_UpdateSnapshotData(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid,
    PRL_CONST_STR sNewName,
    PRL_CONST_STR sNewDescription
);
File

PrlApiVm.h

Parameters

sSnapshotUuid
The ID of the snapshot to modify. To obtain a list of the available snapshots and their ID's, use the PrlVm_GetSnapshotsTreeEx function.
sNewName
New snapshot name.
sNewDescription
New snapshot description.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_CreateSnapshot

PrlVm_DeleteSnapshot

PrlVm_GetSnapshotsTreeEx

PrlVm_SwitchToSnapshot

Links
PHT_VIRTUAL_MACHINE, See Also


PrlVm_ValidateConfig Function

PrlVm_ValidateConfig Function
PHT_VIRTUAL_MACHINE

Validates the specified section of a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_ValidateConfig(
    PRL_HANDLE hVm,
    PRL_VM_CONFIG_SECTIONS nSection
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nSection
The section in the virtual machine configuration to verify.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When creating or modifying a virtual machine configuration, this function can be used to verify that a particular section of the configuration is valid. Use this function before sending the virtual machine object containing the configuration information to the Parallels Service. If the configuration is valid, you can commit the changes. If the configuration is not valid, make the necessary modifications and retry.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or the specified configuration section doesn't exist.

PRL_ERR_PARSE_VM_CONFIG - error parsing configuration data.

PRL_ERR_VMCONF_VALIDATION_FAILED - invalid configuration; the description of the problem can be retrieved from from the PHT_JOB object (see below).

PRL_ERR_SUCCESS - specified configuration is valid.

In the event of validation failure, the PHT_JOB object will contain the description of the problem. To get the description:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to obtain the result count.
  3. Use the PrlResult_GetParamByIndex to obtain a handle of type PHT_EVENT (if there are multiple results, call the function for each one).
  4. Use the PrlEvent_GetErrString function to get the validation error description.
Links
PHT_VIRTUAL_MACHINE


PrlVmCfg_AddDefaultDevice Function

PrlVmCfg_AddDefaultDevice Function
PHT_VM_CONFIGURATION

The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_AddDefaultDevice(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_DEVICE_TYPE deviceType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG containing the host machine configuration information. If this parameter is set to PRL_INVALID_HANDLE, the device of the specified type will be configured as pure virtual (i.e. it will not be mapped to a physical device on the host).
deviceType
The type of the device to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OPERATION_FAILED - unable to set a device of the specified type.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating or modifying a virtual machine configuration, one must choose if a device of a particular type will be a pure virtual device or if it will be mapped to a physical device on the host. To make a device pure virtual, set the hSrvConfig parameter value to PRL_INVALID_HANDLE. To map a virtual device to a physical device, obtain an object of type PHT_SERVER_CONFIG and pass it to the function using the hSrvConfig parameter. If multiple physical devices of the specified type exist on the host, the destination physical device will be chosen randomly by the function.

The virtual devices that can be mapped to physical devices include floppy disk drives, CD drives, serial and parallel ports, and sound devices. The devices that can exist only as pure virtual include hard disk drives, network adapters, and USB devices. To determine if a device of particular type must be added to a virtual machine, use the PrlVmCfg_IsDefaultDeviceNeeded function.

Before calling this function, you must execute the PrlVm_BeginEdit function. After the PrlVmCfg_AddDefaultDevice function returns, you must call the PrlVm_Commit to save the changes in the virtual machine configuration.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_AddDefaultDeviceEx Function

PrlVmCfg_AddDefaultDeviceEx Function
PHT_VM_CONFIGURATION

The PrlVmCfg_AddDefaultDeviceEx function automates the task of setting devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_AddDefaultDeviceEx(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_DEVICE_TYPE deviceType,
    PRL_HANDLE_PTR phVmDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG containing the host machine configuration information. If this parameter is set to PRL_INVALID_HANDLE, the device of the specified type will be configured as pure virtual (i.e. it will not be mapped to a physical device on the host).
deviceType
The type of the device to set.
phVmDevice
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OPERATION_FAILED - unable to set a device of the specified type.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating or modifying a virtual machine configuration, one must choose if a device of a particular type will be a pure virtual device or if it will be mapped to a physical device on the host. To make a device pure virtual, set the hSrvConfig parameter value to PRL_INVALID_HANDLE. To map a virtual device to a physical device, obtain an object of type PHT_SERVER_CONFIG and pass it to the function using the hSrvConfig parameter. If multiple physical devices of the specified type exist on the host, the destination physical device will be chosen randomly by the function.

The virtual devices that can be mapped to physical devices include floppy disk drives, CD drives, serial and parallel ports, and sound devices. The devices that can exist only as pure virtual include hard disk drives, network adapters, and USB devices. To determine if a device of particular type must be added to a virtual machine, use the PrlVmCfg_IsDefaultDeviceNeeded function.

Before calling this function, you must execute the PrlVm_BeginEdit function. After the PrlVmCfg_AddDefaultDeviceEx function returns, you must call the PrlVm_Commit to save the changes in the virtual machine configuration.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_ApplyConfigSample Function

PrlVmCfg_ApplyConfigSample Function
PHT_VM_CONFIGURATION

Specify the Configuration sample file

Syntax
PRL_RESULT PrlVmCfg_ApplyConfigSample(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sConfigSample
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. ConfigSample Configurationsample name name.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_CreateBootDev Function

PrlVmCfg_CreateBootDev Function
PHT_VM_CONFIGURATION

Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.

Syntax
PRL_RESULT PrlVmCfg_CreateBootDev(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmBootDev
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmBootDev
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the caller to free the handle when it is no longer needed.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_CreateScrRes Function

PrlVmCfg_CreateScrRes Function
PHT_VM_CONFIGURATION See Also

Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.

Syntax
PRL_RESULT PrlVmCfg_CreateScrRes(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmScrRes
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmScrRes
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you want to add an additional screen resolution to the virtual machine. Once you obtain the handle, use its functions to set the screen resolution parameters, such as width and height. It is the responsibility of the caller to free the handle when it is no longer needed.

See Also

PrlVmCfg_IsScrResEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_CreateShare Function

PrlVmCfg_CreateShare Function
PHT_VM_CONFIGURATION

Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.

Syntax
PRL_RESULT PrlVmCfg_CreateShare(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmShare
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmShare
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the caller to free the handle when it is no longer needed.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_CreateVmDev Function

PrlVmCfg_CreateVmDev Function
PHT_VM_CONFIGURATION

Creates a new virtual device handle of the specified type.

Syntax
PRL_RESULT PrlVmCfg_CreateVmDev(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE nDeviceType,
    PRL_HANDLE_PTR phVmDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nDeviceType
The type of the device to create a handle for.
phVmDevice
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The names of the virtual device handles are prefixed with PHT_VIRTUAL_DEV_ (you may search this documentation for their definitions or see the _PRL_HANDLE_TYPE enumeration for a complete list of handles). It is the responsibility of the user to free the handle when it is no longer needed.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_Get3DAccelerationMode Function

PrlVmCfg_Get3DAccelerationMode Function
PHT_VM_CONFIGURATION

Gets 3D graphical acceleration technology mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_Get3DAccelerationMode(
    PRL_HANDLE hVmCfg,
    PRL_VIDEO_3D_ACCELERATION_PTR pn3DAccelerationMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pn3DAccelerationMode
A pointer to a variable that receives the result. See PRL_VIDEO_3D_ACCELERATION enum.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAccessRights Function

PrlVmCfg_GetAccessRights Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_ACCESS_RIGHTS.

Syntax
PRL_RESULT PrlVmCfg_GetAccessRights(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmAcl
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmAcl
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetActionOnStopMode Function

PrlVmCfg_GetActionOnStopMode Function
PHT_VM_CONFIGURATION

Gets action on stop mode.

Syntax
PRL_RESULT PrlVmCfg_GetActionOnStopMode(
    PRL_HANDLE hVm,
    PRL_VM_ACTION_ON_STOP_PTR pnMode
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetActionOnWindowClose Function

PrlVmCfg_GetActionOnWindowClose Function
PHT_VM_CONFIGURATION

Determines the action on Parallels Application window close for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetActionOnWindowClose(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR pnActionOnWindowClose
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnActionOnWindowCloase
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAllDevices Function

PrlVmCfg_GetAllDevices Function
PHT_VM_CONFIGURATION

Obtains a handles list of all virtual devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetAllDevices(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phDevsList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phDevsList
[out] A pointer to a variable that receives the handle. The type of the handles list is PHT_HANDLES_LIST.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAppInDockMode Function

PrlVmCfg_GetAppInDockMode Function
PHT_VM_CONFIGURATION

Determines the current dock mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetAppInDockMode(
    PRL_HANDLE hVmCfg,
    PRL_APP_IN_DOCK_MODE_PTR pnVmAppInDockMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAppInDockMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAppTemplateList Function

PrlVmCfg_GetAppTemplateList Function
PHT_VM_CONFIGURATION

Returns the list of application templates installed for the specified Container.

Syntax
PRL_RESULT PrlVmCfg_GetAppTemplateList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phAppList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phAppList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of application templates.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a string object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This option acceptable for Virtual Machine of PVT_CT only.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAssetId Function

PrlVmCfg_GetAssetId Function
PHT_VM_CONFIGURATION

Returns the specified virtual machine asset id.

Syntax
PRL_RESULT PrlVmCfg_GetAssetId(
    PRL_HANDLE hVmCfg,
    PRL_STR sAssetId,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sAssetId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoCompressInterval Function

PrlVmCfg_GetAutoCompressInterval Function
PHT_VM_CONFIGURATION See Also

Determines the interval at which compacting virtual disks are doing by Automatic HDD compress.

Syntax
PRL_RESULT PrlVmCfg_GetAutoCompressInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnInterval
[out] A pointer to a variable the receives the automatic compress interval, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is a facility that allows to make automatic compress of a virtual machine disks at predefined time intervals. The currently set time interval can be obtained using this function.

See Also

PrlVmCfg_SetAutoCompressInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetAutoStart Function

PrlVmCfg_GetAutoStart Function
PHT_VM_CONFIGURATION

Determines if the specified virtual machine is set to start automatically on Parallels Service startup.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStart(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTART_OPTION_PTR pnVmAutoStart
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStart
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoStartDelay Function

PrlVmCfg_GetAutoStartDelay Function
PHT_VM_CONFIGURATION

Returns the time delay used during the virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStartDelay(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmAutoStartDelay
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStartDelay
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoStop Function

PrlVmCfg_GetAutoStop Function
PHT_VM_CONFIGURATION

Determines the mode of the automatic shutdown for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStop(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTOP_OPTION_PTR pnVmAutoStop
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStop
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetBackgroundPriority Function

PrlVmCfg_GetBackgroundPriority Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine background process priority type.

Syntax
PRL_RESULT PrlVmCfg_GetBackgroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY_PTR pnVmBackgroundPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmBackgroundPriority
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetBootDev Function

PrlVmCfg_GetBootDev Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.

Syntax
PRL_RESULT PrlVmCfg_GetBootDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nBootDevIndex,
    PRL_HANDLE_PTR phVmBootDev
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nBootDevIndex
An index identifying the device (beginning with 0). To determine the number of the devices in the boot device list, use the PrlVmCfg_GetBootDevCount function.
phVmBootDev
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the called to free the handle when it is no longer needed.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetBootDevCount Function

PrlVmCfg_GetBootDevCount Function
PHT_VM_CONFIGURATION

Determines the number of devices in the virtual machine boot device priority list.

Syntax
PRL_RESULT PrlVmCfg_GetBootDevCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnBootDevCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnBootDevCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCapabilitiesMask Function

PrlVmCfg_GetCapabilitiesMask Function
PHT_VM_CONFIGURATION See Also

Returns a capabilities mask specified inside the CT.

Syntax
PRL_RESULT PrlVmCfg_GetCapabilitiesMask(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnCapMask
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnCapMask
[out] A pointer to a bitmask containing the supported capabilities. For available options see the PRL_CT_CAPMASK enumeration and CAPDEFAULTMASK defined in PrlEnums.h as macros.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetCapabilitiesMask

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetCoherenceButtonVisibility Function

PrlVmCfg_GetCoherenceButtonVisibility Function
PHT_VM_CONFIGURATION

Determines if a "Coherence Button" for the specified virtual machine should be shown when a user points to a Windows Start button

Syntax
PRL_RESULT PrlVmCfg_GetCoherenceButtonVisibility(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCoherenceButtonVisibility
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmCoherenceButtonVisibility
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that Coherence Button appears. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetConfigValidity Function

PrlVmCfg_GetConfigValidity Function
PHT_VM_CONFIGURATION

The PrlVmCfg_GetConfigValidity function returns an error code.

Syntax
PRL_RESULT PrlVmCfg_GetConfigValidity(
    PRL_HANDLE hVmCfg,
    PRL_RESULT_PTR pnErrCode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnErrCode
[out] A pointer to a variable that receives the error code as PRL_RESULT.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The error code indicates the status of the config: config doesn't exist, parsing error, config can be restored and others errors.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetConfirmationsList Function

PrlVmCfg_GetConfirmationsList Function
PHT_VM_CONFIGURATION See Also

Obtains a handles list of operations with virtual machine which required administrator confirmation

Syntax
PRL_RESULT PrlVmCfg_GetConfirmationsList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phConfirmList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phConfirmList
[out] A pointer to a variable that receives the handle. The type of the handle is PHT_OPAQUE_TYPE_LIST. ( values in list consist in enum PRL_ALLOWED_VM_COMMAND )

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetCpuAccelLevel Function

PrlVmCfg_GetCpuAccelLevel Function
PHT_VM_CONFIGURATION

Determines the virtual machine CPU acceleration level.

Syntax
PRL_RESULT PrlVmCfg_GetCpuAccelLevel(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACCELERATION_LEVEL_PTR pnVmCpuAccelLevel
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuAccelLevel
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuCount Function

PrlVmCfg_GetCpuCount Function
PHT_VM_CONFIGURATION

Determines the number of CPUs in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetCpuCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmCpuCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuLimit Function

PrlVmCfg_GetCpuLimit Function
PHT_VM_CONFIGURATION See Also

Determines the CPU usage limit of a virtual machine, in percent.

Syntax
PRL_RESULT PrlVmCfg_GetCpuLimit(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR nVmCpuLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuLimit
[out] A pointer to a variable that receives CPU usage limit, in percent.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetCpuLimit

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetCpuLimitEx Function

PrlVmCfg_GetCpuLimitEx Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine CPU limit.

Syntax
PRL_RESULT PrlVmCfg_GetCpuLimitEx(
    PRL_HANDLE hVmCfg,
    PRL_CPULIMIT_DATA_PTR pVmCpuLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuLimit
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuMask Function

PrlVmCfg_GetCpuMask Function
PHT_VM_CONFIGURATION

Returns the specified virtual machine CPU affinity mask

Syntax
PRL_RESULT PrlVmCfg_GetCpuMask(
    PRL_HANDLE hVmCfg,
    PRL_STR sMask,
    PRL_UINT32_PTR pnMaskBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sMask
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuMode Function

PrlVmCfg_GetCpuMode Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine CPU mode (32 bit or 64 bit).

Syntax
PRL_RESULT PrlVmCfg_GetCpuMode(
    PRL_HANDLE hVmCfg,
    PRL_CPU_MODE_PTR pnVmCpuMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuUnits Function

PrlVmCfg_GetCpuUnits Function
PHT_VM_CONFIGURATION See Also

Determines the number of CPU units allocated to a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetCpuUnits(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR nVmCpuUnits
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuUnits
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetCpuUnits

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetCustomProperty Function

PrlVmCfg_GetCustomProperty Function
PHT_VM_CONFIGURATION See Also

Returns the virtual machine custom property information.

Syntax
PRL_RESULT PrlVmCfg_GetCustomProperty(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmCustomProperty,
    PRL_UINT32_PTR pnVmCustomPropertyBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmCustomProperty
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The custom property information is stored in CDATA format.
pnVmCustomPropertyBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is too small. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If you have some custom data which relates to a virtual machine in some way, you can save it in the virtual machine configuration for future retrieval. This can be any data that your client application requires. The data is stored in CDATA format.

See Also

PrlVmCfg_SetCustomProperty

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDefaultHddSize Function

PrlVmCfg_GetDefaultHddSize Function
PHT_VM_CONFIGURATION

The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.

Syntax
PRL_RESULT PrlVmCfg_GetDefaultHddSize(
    PRL_UINT32 guestOsVersion,
    PRL_UINT32_PTR pnHddSize
);
File

PrlApiVm.h

Parameters

guestOsVersion
Operating system version. See PrlOses.h for version definitions.
pnHddSize
[out] A pointer to a variable that receives the hard disk size, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine using a default configuration, the default hard disk is defined for every supported operating system type and version. The default HDD sizes can be retrieved using this function. The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS). The OS versions can be found in the same file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetDefaultMemSize Function

PrlVmCfg_GetDefaultMemSize Function
PHT_VM_CONFIGURATION

The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.

Syntax
PRL_RESULT PrlVmCfg_GetDefaultMemSize(
    PRL_UINT32 guestOsVersion,
    PRL_UINT32 hostRam,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApiVm.h

Parameters

guestOsVersion
Operating system version. See PrlOses.h for type definitions.
hostRam
Optional. The amount of memory (RAM) available on the host system. For some operating system, this parameter may be used to calculate the default the RAM size more precisely.
pnMemSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine using a default configuration, the default memory size is defined for every supported operating system type and version. The default sizes can be retrieved using this function. The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS). The OS versions can be found in the same file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetDefaultVideoRamSize Function

PrlVmCfg_GetDefaultVideoRamSize Function
PHT_VM_CONFIGURATION

The PrlVmCfg_GetDefaultVideoRamSize function returns the default video RAM size for the specified OS type and version.

Syntax
PRL_RESULT PrlVmCfg_GetDefaultVideoRamSize(
    PRL_UINT32 guestOsVersion,
    PRL_HANDLE hSrvConfig,
    PRL_BOOL bIs3DSupportEnabled,
    PRL_UINT32_PTR pnVideoRamSize
);
File

PrlApiVm.h

Parameters

guestOsVersion
Operating system version. See PrlOses.h for type definitions.
hSrvConfig
Optional. The host hardware info object handle (PHT_SERVER_CONFIG type) contains necessary information about host hardware configuration (amount of RAM, host type and etc.). For some operating system, this parameter may be used to calculate the default video RAM size more precisely.
bIs3DSupportEnabled
sign which specifies whether 3D support will be enabled at creating VM. 3D support require at least 128 Mb of video RAM in common case.
pnVideoRamSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine using a default configuration, the default video memory size is defined for every supported operating system type and version. The default sizes can be retrieved using this function. The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS). The OS versions can be found in the same file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetDescription Function

PrlVmCfg_GetDescription Function
PHT_VM_CONFIGURATION

Returns the specified virtual machine description.

Syntax
PRL_RESULT PrlVmCfg_GetDescription(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmDescription,
    PRL_UINT32_PTR pnVmDescriptionBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetDevByType Function

PrlVmCfg_GetDevByType Function
PHT_VM_CONFIGURATION See Also

Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.

Syntax
PRL_RESULT PrlVmCfg_GetDevByType(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE vmDeviceType,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmDeviceType
The device type.
nIndex
An index identifying the device instance (beginning with 0). To determine the number of the devices of the specified type available in the virtual machine, use the PrlVmCfg_GetDevsCountByType function.
phDevice
[out] A pointer to a variable that receives the handle. The type of the handle can be determined using the PrlHandle_GetType function. You should also "know" the handle type based on the device type for which you are obtaining a handle. Search this documentation for topics with PHT_VIRTUAL_DEV_ prefix in their names for the list of the available virtual device handles.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevsCountByType

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDevsCount Function

PrlVmCfg_GetDevsCount Function
PHT_VM_CONFIGURATION See Also

Determines the total number of devices of any type installed in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR vmdev_handles_count
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmdev_handles_count
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevsList

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDevsCountByType Function

PrlVmCfg_GetDevsCountByType Function
PHT_VM_CONFIGURATION See Also

Obtains the number of virtual devices of the specified type available in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDevsCountByType(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE vmDeviceType,
    PRL_UINT32_PTR pnDevicesCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmDeviceType
Device type.
pnDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevByType

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDisplayDev Function

PrlVmCfg_GetDisplayDev Function
PHT_VM_CONFIGURATION See Also

Obtains a handle of type PHT_VIRTUAL_DEV_DISPLAY containing information about a display device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDisplayDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the display device (beginning with 0). To obtain the number of display devices in a virtual machine, use the PrlVmCfg_GetDisplayDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDisplayDevsCount

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDisplayDevsCount Function

PrlVmCfg_GetDisplayDevsCount Function
PHT_VM_CONFIGURATION See Also

Determines the number of display devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDisplayDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnDisplayDevsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnGenericScsiDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDisplayDev

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDnsServers Function

PrlVmCfg_GetDnsServers Function
PHT_VM_CONFIGURATION

Obtains the list of of globally defined DNS servers which is assigned to a Virtuozzo Container.

Syntax
PRL_RESULT PrlVmCfg_GetDnsServers(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phDnsServersList
[out] A pointer to the PHT_STRINGS_LIST handle that receives the list of DNS servers.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetDockIconType Function

PrlVmCfg_GetDockIconType Function
PHT_VM_CONFIGURATION

Returns the virtual machine dock icon type.

Syntax
PRL_RESULT PrlVmCfg_GetDockIconType(
    PRL_HANDLE hVmCfg,
    PRL_DOCK_ICON_TYPE_PTR pnVmDockIconType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmDockIconType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This functionality is part of the Parallels Tools package. See PHT_VM_TOOLS_INFO.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetEnvId Function

PrlVmCfg_GetEnvId Function
PHT_VM_CONFIGURATION

Returns the Container id of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetEnvId(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnEnvId
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnEnvId
[out] Container id

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExpirationDate Function

PrlVmCfg_GetExpirationDate Function
PHT_VM_CONFIGURATION

Gets expiration date.

Syntax
PRL_RESULT PrlVmCfg_GetExpirationDate(
    PRL_HANDLE hVmCfg,
    PRL_STR sExpirationDateBuf,
    PRL_UINT32_PTR pnExpirationDateBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sExpirationDate
Date and time in "yyyy-mm-dd hh:mm:ss" format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExpirationNote Function

PrlVmCfg_GetExpirationNote Function
PHT_VM_CONFIGURATION

Gets expiration note.

Syntax
PRL_RESULT PrlVmCfg_GetExpirationNote(
    PRL_HANDLE hVmCfg,
    PRL_STR sNote,
    PRL_UINT32_PTR pnNoteBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNote
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNoteBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExpirationOfflineTimeToLive Function

PrlVmCfg_GetExpirationOfflineTimeToLive Function
PHT_VM_CONFIGURATION

Gets the offline time of working with virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetExpirationOfflineTimeToLive(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnTime
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnTime
[out] A pointer to a variable the receives the time interval, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExpirationTimeCheckInterval Function

PrlVmCfg_GetExpirationTimeCheckInterval Function
PHT_VM_CONFIGURATION

Gets the time interval to check on expiration date.

Syntax
PRL_RESULT PrlVmCfg_GetExpirationTimeCheckInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnInterval
[out] A pointer to a variable the receives the time interval, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExpirationTrustedTimeServer Function

PrlVmCfg_GetExpirationTrustedTimeServer Function
PHT_VM_CONFIGURATION

Gets trusted time server.

Syntax
PRL_RESULT PrlVmCfg_GetExpirationTrustedTimeServer(
    PRL_HANDLE hVmCfg,
    PRL_STR sUrl,
    PRL_UINT32_PTR pnUrlBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sUrl
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUrlBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetExternalBootDevice Function

PrlVmCfg_GetExternalBootDevice Function
PHT_VM_CONFIGURATION

Returns an external boot device system name.

Syntax
PRL_RESULT PrlVmCfg_GetExternalBootDevice(
    PRL_HANDLE hVmCfg,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sSysName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetFeaturesMask Function

PrlVmCfg_GetFeaturesMask Function
PHT_VM_CONFIGURATION See Also

Returns a features mask specified inside the CT.

Syntax
PRL_RESULT PrlVmCfg_GetFeaturesMask(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnOn,
    PRL_UINT32_PTR pnOff
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnOn
[out] A pointer to a bitmask containing the enabled features. For available options see the PRL_CT_FEATURES enumeration.
pnOff
[out] A pointer to a bitmask containing the disabled features. For available options see the PRL_CT_FEATURES enumeration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetCapabilitiesMask

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetFloppyDisk Function

PrlVmCfg_GetFloppyDisk Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetFloppyDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the floppy disk drive instance (beginning with 0). To get the number of floppy disk drives in the virtual machine, use the PrlVmCfg_GetFloppyDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetFloppyDisksCount Function

PrlVmCfg_GetFloppyDisksCount Function
PHT_VM_CONFIGURATION

Determines the number of floppy disk drives in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetFloppyDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnFloppyDisksCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnFloppyDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetForegroundPriority Function

PrlVmCfg_GetForegroundPriority Function
PHT_VM_CONFIGURATION

Returns foreground processes priority for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetForegroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY_PTR pnVmForegroundPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmForegroundPriority
[out] A pointer to a variable that receives the result

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetFreeDiskSpaceRatio Function

PrlVmCfg_GetFreeDiskSpaceRatio Function
PHT_VM_CONFIGURATION See Also

Determines the free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.

Syntax
PRL_RESULT PrlVmCfg_GetFreeDiskSpaceRatio(
    PRL_HANDLE hVmCfg,
    PRL_DOUBLE_PTR pdFreeDiskSpaceRatio
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pdFreeDiskSpaceRatio
[out] A pointer to a variable the receives the automatic compress space ratio, in percents.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is a facility that allows to make automatic compress of a virtual machine disks at predefined space ratio. The currently set space ratio can be obtained using this function.

See Also

PrlVmCfg_SetFreeDiskSpaceRatio

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericPciDev Function

PrlVmCfg_GetGenericPciDev Function
PHT_VM_CONFIGURATION See Also

Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericPciDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the generic PCI device (beginning with 0). To obtain the number of generic PCI devices in a virtual machine, use the PrlVmCfg_GetGenericPciDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericPciDevsCount

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericPciDevsCount Function

PrlVmCfg_GetGenericPciDevsCount Function
PHT_VM_CONFIGURATION See Also

Determines the number of generic PCI devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericPciDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnGenericPciDevsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnGenericPciDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericPciDev

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericScsiDev Function

PrlVmCfg_GetGenericScsiDev Function
PHT_VM_CONFIGURATION See Also

Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericScsiDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the generic SCSI device (beginning with 0). To obtain the number of generic SCSI devices in a virtual machine, use the PrlVmCfg_GetGenericScsiDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericScsiDevsCount

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericScsiDevsCount Function

PrlVmCfg_GetGenericScsiDevsCount Function
PHT_VM_CONFIGURATION See Also

Determines the number of generic SCSI devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericScsiDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnGenericScsiDevsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnGenericScsiDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericScsiDev

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetHardDisk Function

PrlVmCfg_GetHardDisk Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.

Syntax
PRL_RESULT PrlVmCfg_GetHardDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the hard disk instance (beginning with 0). To get the number of hard disks installed in the virtual machine, use the PrlVmCfg_GetHardDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHardDisksCount Function

PrlVmCfg_GetHardDisksCount Function
PHT_VM_CONFIGURATION

Determines the number of virtual hard disks in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetHardDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnHardDisksCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnHardDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHighAvailabilityPriority Function

PrlVmCfg_GetHighAvailabilityPriority Function
PHT_VM_CONFIGURATION See Also

Determines the priority of the virtual machine in the High Availability Cluster.

Syntax
PRL_RESULT PrlVmCfg_GetHighAvailabilityPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnPriority
[out] A pointer to a variable the receives the priority value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetHighAvailabilityPriority

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetHomePath Function

PrlVmCfg_GetHomePath Function
PHT_VM_CONFIGURATION

Returns the virtual machine home directory name and path.

Syntax
PRL_RESULT PrlVmCfg_GetHomePath(
    PRL_HANDLE hVmCfg,
    PRL_STR sHomePath,
    PRL_UINT32_PTR pnHomePathBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sHomePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHomePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHostMemQuotaMax Function

PrlVmCfg_GetHostMemQuotaMax Function
PHT_VM_CONFIGURATION

Returns the maximal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.

Syntax
PRL_RESULT PrlVmCfg_GetHostMemQuotaMax(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnHostMemQuotaMax
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnHostMemQuotaMax
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHostMemQuotaMin Function

PrlVmCfg_GetHostMemQuotaMin Function
PHT_VM_CONFIGURATION

Returns the minimal size of the host's memory (RAM) consumption by the virtual machine, in megabytes.

Syntax
PRL_RESULT PrlVmCfg_GetHostMemQuotaMin(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnHostMemQuotaMin
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnHostMemQuotaMin
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHostMemQuotaPriority Function

PrlVmCfg_GetHostMemQuotaPriority Function
PHT_VM_CONFIGURATION

Returns the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.

Syntax
PRL_RESULT PrlVmCfg_GetHostMemQuotaPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnHostMemQuotaPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnHostMemQuotaPriority
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetHostname Function

PrlVmCfg_GetHostname Function
PHT_VM_CONFIGURATION

Obtains the hostname of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetHostname(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmHostname,
    PRL_UINT32_PTR pnVmHostnameBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The pnVmNameBufLength parameter will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetIcon Function

PrlVmCfg_GetIcon Function
PHT_VM_CONFIGURATION

Returns the name of the icon file used by the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetIcon(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmIcon,
    PRL_UINT32_PTR pnVmIconBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmIcon
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmIconBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetIoLimit Function

PrlVmCfg_GetIoLimit Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine I/O limit.

Syntax
PRL_RESULT PrlVmCfg_GetIoLimit(
    PRL_HANDLE hVmCfg,
    PRL_IOLIMIT_DATA_PTR pVmIoLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmIoLimit
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetIoPriority Function

PrlVmCfg_GetIoPriority Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine I/O priority.

Syntax
PRL_RESULT PrlVmCfg_GetIoPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmIoPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmIoPriority
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetIopsLimit Function

PrlVmCfg_GetIopsLimit Function
PHT_VM_CONFIGURATION

Determines the specified virtual machine IOPS limit.

Syntax
PRL_RESULT PrlVmCfg_GetIopsLimit(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmIopsLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmIopsLimit
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetLastModifiedDate Function

PrlVmCfg_GetLastModifiedDate Function
PHT_VM_CONFIGURATION

Returns the date and time when the specified virtual machine was last modified.

Syntax
PRL_RESULT PrlVmCfg_GetLastModifiedDate(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmLastModifiedDate,
    PRL_UINT32_PTR pnVmLastModifiedDateBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmLastModifiedDate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The date is returned using the "yyyy-mm-dd hh:mi:ss" format.
pnVmLastModifiedDateBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returned time is a local time (i.e. the time value is already converted to local time zone).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetLastModifierName Function

PrlVmCfg_GetLastModifierName Function
PHT_VM_CONFIGURATION

Returns the name of the user who last modified the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetLastModifierName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmLastModifierName,
    PRL_UINT32_PTR pnVmLastModifierNameBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmLastModifierName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmLastModifierNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetLinkedVmUuid Function

PrlVmCfg_GetLinkedVmUuid Function
PHT_VM_CONFIGURATION

Returns the UUID (universally unique ID) of the parent virtual machine which was used to create current linked cloned virtual machine (if last one is linked clone of some virtual machine - this value will be empty otherwise).

Syntax
PRL_RESULT PrlVmCfg_GetLinkedVmUuid(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmUuid,
    PRL_UINT32_PTR pnVmUuidBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetLocation Function

PrlVmCfg_GetLocation Function
PHT_VM_CONFIGURATION

Returns the virtual machine files location type.

Syntax
PRL_RESULT PrlVmCfg_GetLocation(
    PRL_HANDLE hVmCfg,
    PRL_VM_LOCATION_PTR pnVmLocation
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmLocation
[out] A pointer to a buffer that receives the result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that this parameter is runtime and read only.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetMaxBalloonSize Function

PrlVmCfg_GetMaxBalloonSize Function
PHT_VM_CONFIGURATION

Returns the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.

Syntax
PRL_RESULT PrlVmCfg_GetMaxBalloonSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnMaxBalloonSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnMaxBalloonSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetName Function

PrlVmCfg_GetName Function
PHT_VM_CONFIGURATION

Returns the name of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmName,
    PRL_UINT32_PTR pnVmNameBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetNetAdapter Function

PrlVmCfg_GetNetAdapter Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetNetAdapter(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the network adapter instance (beginning with 0). To determine the number of network adapters in the machine, use the PrlVmCfg_GetNetAdaptersCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetNetAdaptersCount Function

PrlVmCfg_GetNetAdaptersCount Function
PHT_VM_CONFIGURATION

Determines the number of network adapters in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetNetAdaptersCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnNetAdaptersCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnNetAdaptersCount
specifies a pointer to the count of devices

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetNetfilterMode Function

PrlVmCfg_GetNetfilterMode Function
PHT_VM_CONFIGURATION See Also

Returns netfilter mode specified inside the CT.

Syntax
PRL_RESULT PrlVmCfg_GetNetfilterMode(
    PRL_HANDLE hVmCfg,
    PRL_NETFILTER_MODE_PTR pnMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetNetfilterMode

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetNetworkRateList Function

PrlVmCfg_GetNetworkRateList Function
PHT_VM_CONFIGURATION See Also

Obtains the list of shaping rated

Syntax
PRL_RESULT PrlVmCfg_GetNetworkRateList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phNetworkRateList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phNetworkRateList
[out] A pointer to the PHT_HANDLES_LIST handle containing the list of handle sof type PHT_NETWORK_RATE.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate the object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetSearchDomains

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetOfflineServices Function

PrlVmCfg_GetOfflineServices Function
PHT_VM_CONFIGURATION See Also

Obtains the list of services available in the virtual machine offline management.

Syntax
PRL_RESULT PrlVmCfg_GetOfflineServices(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phOfflineServicesList
);
File

PrlApiVm.h

Parameters

phOfflineServicesList
[out] A pointer to the PHT_STRINGS_LIST handle containing the list of offline services.
hVmDev
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate the string list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetOfflineManagementEnabled

PrlVmCfg_SetOfflineServices

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetOpticalDisk Function

PrlVmCfg_GetOpticalDisk Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetOpticalDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the optical disk instance (beginning with 0). To determine the number of optical disks in a virtual machine, use the PrlVmCfg_GetOpticalDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetOpticalDisksCount Function

PrlVmCfg_GetOpticalDisksCount Function
PHT_VM_CONFIGURATION

Determines the number of optical disks in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetOpticalDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnOpticalDisksCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnOpticalDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetOptimizeModifiersMode Function

PrlVmCfg_GetOptimizeModifiersMode Function
PHT_VM_CONFIGURATION

Gets optimize modifiers mode.

Syntax
PRL_RESULT PrlVmCfg_GetOptimizeModifiersMode(
    PRL_HANDLE hVm,
    PRL_OPTIMIZE_MODIFIERS_MODE_PTR pnMode
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetOsTemplate Function

PrlVmCfg_GetOsTemplate Function
PHT_VM_CONFIGURATION

Returns Operation System template name the Parallels Virtuozzo Container were created on.

Syntax
PRL_RESULT PrlVmCfg_GetOsTemplate(
    PRL_HANDLE hVmCfg,
    PRL_STR sOsTemplate,
    PRL_UINT32_PTR pnBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sOsTemplate
[out] A pointer to a buffer that receives the result.
pnBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetOsType Function

PrlVmCfg_GetOsType Function
PHT_VM_CONFIGURATION

Returns the type of the operating system that the specified virtual machine is running.

Syntax
PRL_RESULT PrlVmCfg_GetOsType(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmOsType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmOsType
[out] A pointer to a variable that receives the OS type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - VM - the OS information is not present in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetOsVersion Function

PrlVmCfg_GetOsVersion Function
PHT_VM_CONFIGURATION

Returns the version of the operating system that the specified virtual machine is running.

Syntax
PRL_RESULT PrlVmCfg_GetOsVersion(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmOsVersion
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmOsVersion
[out] A pointer to a variable that receives the OS version.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - VM - the OS information is not present in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetParallelPort Function

PrlVmCfg_GetParallelPort Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual printer port in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetParallelPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the printer port instance (beginning with 0). To determine the number of printer ports in a virtual machine, use the PrlVmCfg_GetParallelPortsCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetParallelPortsCount Function

PrlVmCfg_GetParallelPortsCount Function
PHT_VM_CONFIGURATION

Determines the number of virtual printer ports in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetParallelPortsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnParallelPortsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnParallelPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetProfile Function

PrlVmCfg_GetProfile Function
PHT_VM_CONFIGURATION

Get current VM profile.

Syntax
PRL_RESULT PrlVmCfg_GetProfile(
    PRL_HANDLE hVm,
    PRL_VIRTUAL_MACHINE_PROFILE_PTR pnVmProfile
);
File

PrlApiVm.h

Parameters

pnVmProfile
[out] A predefined settings profile. See the PRL_VIRTUAL_MACHINE_PROFILE enumeration for available options.
hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use PrlVmCfg_IsCustomProfile to detect if settings were modified after profile application.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetRamSize Function

PrlVmCfg_GetRamSize Function
PHT_VM_CONFIGURATION

Returns the virtual machine memory (RAM) size, in megabytes.

Syntax
PRL_RESULT PrlVmCfg_GetRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmRamSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRamSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetResource Function

PrlVmCfg_GetResource Function
PHT_VM_CONFIGURATION

Returns beancounters barrier and limit for specified resource id.

Syntax
PRL_RESULT PrlVmCfg_GetResource(
    PRL_HANDLE hVmCfg,
    PRL_CT_RESOURCE nResourceId,
    PRL_UINT64_PTR pnBarrirer,
    PRL_UINT64_PTR pnLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. nResourceId The resource id (Only PCR_SWAPPAGES supported for now). pnBarrirer [out]The resource barrier. pnLimit [out]The resource limit

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_PARAM_NOT_FOUND - resource not found. PRL_ERR_SUCCESS - function completed successfully.

Remarks

were created on.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetScrRes Function

PrlVmCfg_GetScrRes Function
PHT_VM_CONFIGURATION See Also

Obtains a handle of type PHT_SCREEN_RESOLUTION identifying the specified virtual machine screen resolution.

Syntax
PRL_RESULT PrlVmCfg_GetScrRes(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nScrResIndex,
    PRL_HANDLE_PTR phVmScrRes
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nScrResIndex
A numeric index identifying the screen resolution (beginning with 0). To determine the number of the available resolutions, use PrlVmCfg_GetScrResCount.
phVmScrRes
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Once you obtain the handle, you can use its functions to modify the screen resolution settings.

See Also

PrlVmCfg_GetScrResCount

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetScrResCount Function

PrlVmCfg_GetScrResCount Function
PHT_VM_CONFIGURATION See Also

Determines the total number of screen resolutions available in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetScrResCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnScrResCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnScrResCount
[out] A pointer to a variable that receives the screen resolution count.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetScrRes

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetSearchDomains Function

PrlVmCfg_GetSearchDomains Function
PHT_VM_CONFIGURATION See Also

Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.

Syntax
PRL_RESULT PrlVmCfg_GetSearchDomains(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phSearchDomainsList
[out] A pointer to the PHT_STRINGS_LIST handle containing the list of search domains.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate the string list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetSearchDomains

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetSerialPort Function

PrlVmCfg_GetSerialPort Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSerialPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the serial port instance.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSerialPortsCount Function

PrlVmCfg_GetSerialPortsCount Function
PHT_VM_CONFIGURATION

Determines the number of serial ports in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSerialPortsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSerialPortsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSerialPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetServerHost Function

PrlVmCfg_GetServerHost Function
PHT_VM_CONFIGURATION

Returns the hostname of the machine hosting the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetServerHost(
    PRL_HANDLE hVmCfg,
    PRL_STR sServerHost,
    PRL_UINT32_PTR pnServerHostBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnServerHostBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
unnamsServerHosted_param
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetServerUuid Function

PrlVmCfg_GetServerUuid Function
PHT_VM_CONFIGURATION

Returns the UUID of the machine hosting the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetServerUuid(
    PRL_HANDLE hVmCfg,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sServerUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetShare Function

PrlVmCfg_GetShare Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_SHARE containing information about a shared folder.

Syntax
PRL_RESULT PrlVmCfg_GetShare(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nShareIndex,
    PRL_HANDLE_PTR phVmShare
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nShareIndex
An index identifying the shared folder (beginning with 0). To determine the number of shared folders in a virtual machine, use the PrlVmCfg_GetSharesCount function.
phVmShare
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A shared folder is a folder in the host OS which is shared with a given virtual machine. To obtain its information, first determine the number of the available shared folders using the PrlVmCfg_GetSharesCount function. Then iterate through the list using the iteration number as the nShareIndex parameter value.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSharesCount Function

PrlVmCfg_GetSharesCount Function
PHT_VM_CONFIGURATION

Determines the number of shared folders in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSharesCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSharesCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSharesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A shared folder is a folder in the host OS which is shared with a given virtual machine. To obtain its information, first determine the number of the available shared folders using the PrlVmCfg_GetSharesCount function. Then obtain information about an individual folder using the PrlVmCfg_GetShare function.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSmartGuardInterval Function

PrlVmCfg_GetSmartGuardInterval Function
PHT_VM_CONFIGURATION See Also

Determines the interval at which snapshots are taken by SmartGuard.

Syntax
PRL_RESULT PrlVmCfg_GetSmartGuardInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnInterval
[out] A pointer to a variable the receives the snapshot creation interval, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is a facility that allows to make automatic snapshots of a virtual machine at predefined time intervals. The currently set time interval can be obtained using this function.

See Also

PrlVmCfg_SetSmartGuardInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetSmartGuardMaxSnapshotsCount Function

PrlVmCfg_GetSmartGuardMaxSnapshotsCount Function
PHT_VM_CONFIGURATION

Determines the maximum snapshot count, a SmartGuard setting.

Syntax
PRL_RESULT PrlVmCfg_GetSmartGuardMaxSnapshotsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnMaxSnapshotsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is a facility that allows to make automatic snapshots of a virtual machine at predefined time intervals. The snapshot count setting specifies how many snapshots taken by SmartGuard will be kept on the hard drive (maximum is 100). As soon as the maximum number is exceeded, the oldest snapshot is deleted.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSoundDev Function

PrlVmCfg_GetSoundDev Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSoundDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the sound device (beginning with 0). To obtain the number of sound devices in a virtual machine, use the PrlVmCfg_GetSoundDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSoundDevsCount Function

PrlVmCfg_GetSoundDevsCount Function
PHT_VM_CONFIGURATION

Determines the number of sound devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSoundDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSoundDevsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSoundDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetStartLoginMode Function

PrlVmCfg_GetStartLoginMode Function
PHT_VM_CONFIGURATION

Returns the automatic startup login mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetStartLoginMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_START_LOGIN_MODE_PTR pnVmStartLoginMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmStartLoginMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetStartUserLogin Function

PrlVmCfg_GetStartUserLogin Function
PHT_VM_CONFIGURATION

Returns the user name used during the specified virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_GetStartUserLogin(
    PRL_HANDLE hVmCfg,
    PRL_STR sStartUserLogin,
    PRL_UINT32_PTR pnStartUserLoginBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. the virtual machine.
sStartUserLogin
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnStartUserLoginBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetSystemFlags Function

PrlVmCfg_GetSystemFlags Function
PHT_VM_CONFIGURATION

Returns the virtual machine system flags.

Syntax
PRL_RESULT PrlVmCfg_GetSystemFlags(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmSystemFlags,
    PRL_UINT32_PTR pnVmSystemFlagsBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmSystemFlags
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmSystemFlagsBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetTimeSyncInterval Function

PrlVmCfg_GetTimeSyncInterval Function
PHT_VM_CONFIGURATION See Also

Obtains the time synchronization interval between the host and a guest OS.

Syntax
PRL_RESULT PrlVmCfg_GetTimeSyncInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnTimeSyncInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnTimeSyncInterval
[out] A pointer to a variable that receive the time synchronization value, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See PrlVmCfg_SetTimeSynchronizationEnabled for more information.

See Also

PrlVmCfg_SetTimeSyncInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetUnattendedInstallEdition Function

PrlVmCfg_GetUnattendedInstallEdition Function
PHT_VM_CONFIGURATION

Returns edition for unattended installation.

Syntax
PRL_RESULT PrlVmCfg_GetUnattendedInstallEdition(
    PRL_HANDLE hVmCfg,
    PRL_STR sEdition,
    PRL_UINT32_PTR pnEditionBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sEdition
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnEditionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUnattendedInstallLocale Function

PrlVmCfg_GetUnattendedInstallLocale Function
PHT_VM_CONFIGURATION

Returns locale for unattended installation.

Syntax
PRL_RESULT PrlVmCfg_GetUnattendedInstallLocale(
    PRL_HANDLE hVmCfg,
    PRL_STR sLocale,
    PRL_UINT32_PTR pnLocaleBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sLocale
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnLocaleBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUndoDisksMode Function

PrlVmCfg_GetUndoDisksMode Function
PHT_VM_CONFIGURATION

Determines the current undo-disks mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUndoDisksMode(
    PRL_HANDLE hVmCfg,
    PRL_UNDO_DISKS_MODE_PTR pnUndoDisksMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnUndoDisksMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUptime Function

PrlVmCfg_GetUptime Function
PHT_VM_CONFIGURATION

Returns the virtual machine uptime in seconds since some datetime (see PrlVmCfg_GetUptimeStartDate).

Syntax
PRL_RESULT PrlVmCfg_GetUptime(
    PRL_HANDLE hVmCfg,
    PRL_UINT64_PTR pnVmUptime
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmUptime
[out] The buffer for storing result.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully. See also PrlVmCfg_GetUptimeStartDate PrlStat_GetOsUptime

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUptimeStartDate Function

PrlVmCfg_GetUptimeStartDate Function
PHT_VM_CONFIGURATION

Returns the date and time when uptime counter calculation was started for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUptimeStartDate(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmUptimeStartDate,
    PRL_UINT32_PTR pnVmUptimeStartDateBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmUptimeStartDate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The date is returned using the "yyyy-mm-dd hh:mi:ss" format.
pnVmUptimeStartDateBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully. See also PrlVmCfg_GetUptime

Remarks

Returned time is a local time (i.e. the time value is already converted to local time zone).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUsbDevice Function

PrlVmCfg_GetUsbDevice Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUsbDevice(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the USB device (beginning with 0). To determine the number of USB devices in a virtual machine, use the PrlVmCfg_GetUsbDevicesCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUsbDevicesCount Function

PrlVmCfg_GetUsbDevicesCount Function
PHT_VM_CONFIGURATION

Determines the number of USB devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUsbDevicesCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnUsbDevicesCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnUsbDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetUuid Function

PrlVmCfg_GetUuid Function
PHT_VM_CONFIGURATION

Returns the UUID (universally unique ID) of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUuid(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmUuid,
    PRL_UINT32_PTR pnVmUuidBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVideoRamSize Function

PrlVmCfg_GetVideoRamSize Function
PHT_VM_CONFIGURATION

Returns the video memory size of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVideoRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmVideoRamSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmVideoRamSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the video memory size information is missing in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVmInfo Function

PrlVmCfg_GetVmInfo Function
PHT_VM_CONFIGURATION

Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.

Syntax
PRL_RESULT PrlVmCfg_GetVmInfo(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmInfo
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmInfo
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate object

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Possible values are:

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVmType Function

PrlVmCfg_GetVmType Function
PHT_VM_CONFIGURATION

Get the Virtual Machine type.

Syntax
PRL_RESULT PrlVmCfg_GetVmType(
    PRL_HANDLE hVmCfg,
    PRL_VM_TYPE_PTR pnType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCHostName Function

PrlVmCfg_GetVNCHostName Function
PHT_VM_CONFIGURATION

Returns the VNC hostname of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCHostName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmRemoteDisplayHostName,
    PRL_UINT32_PTR pnVmRemoteDisplayHostNameBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmRemoteDisplayHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmRemoteDisplayHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCMode Function

PrlVmCfg_GetVNCMode Function
PHT_VM_CONFIGURATION

Returns the VNC mode of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_REMOTE_DISPLAY_MODE_PTR pnVmRemoteDisplayMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRemoteDisplayMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCPassword Function

PrlVmCfg_GetVNCPassword Function
PHT_VM_CONFIGURATION

Returns the VNC password for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCPassword(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmRemoteDisplayPassword,
    PRL_UINT32_PTR pnVmRemoteDisplayPasswordBufLength
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmRemoteDisplayPassword
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmRemoteDisplayPasswordBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCPort Function

PrlVmCfg_GetVNCPort Function
PHT_VM_CONFIGURATION

Returns the VNC port number for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmRemoteDisplayPort
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRemoteDisplayPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_GetWindowMode Function

PrlVmCfg_GetWindowMode Function
PHT_VM_CONFIGURATION

Returns the current window mode the specified virtual machine is in.

Syntax
PRL_RESULT PrlVmCfg_GetWindowMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_WINDOW_MODE_PTR pnVmWindowMode
);
File

PrlApiVm.h

Parameters

pnVmWindowMode
[out] A pointer to a variable that receives the result.
hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsAdaptiveHypervisorEnabled Function

PrlVmCfg_IsAdaptiveHypervisorEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable adaptive hypervisor.

Syntax
PRL_RESULT PrlVmCfg_IsAdaptiveHypervisorEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsAllowSelectBootDevice Function

PrlVmCfg_IsAllowSelectBootDevice Function
PHT_VM_CONFIGURATION See Also

Determines whether select boot device should be shown on virtual machine startup.

Syntax
PRL_RESULT PrlVmCfg_IsAllowSelectBootDevice(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbAllowed
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbAllowed
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that select boot device will be show. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetAllowSelectBootDevice

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsAutoApplyIpOnly Function

PrlVmCfg_IsAutoApplyIpOnly Function
PHT_VM_CONFIGURATION

Determines if the Guest configured to automatically apply IP addrs network settings inside guest.

Syntax
PRL_RESULT PrlVmCfg_IsAutoApplyIpOnly(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbAutoApplyIpOnly
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual network adapter.
pbAutoApplyIpOnly
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is configured to automatically apply network settings. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsAutoCaptureReleaseMouse Function

PrlVmCfg_IsAutoCaptureReleaseMouse Function
PHT_VM_CONFIGURATION

Determines whether the automatic capture and release of the mouse pointer is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsAutoCaptureReleaseMouse(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates that it is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this feature is enabled, the mouse input is automatically redirected from the host OS to the virtual machine and vise versa as soon as the mouse pointer is positioned over the host OS or the virtual machine desktop. This feature requires Parallels Tools installed in a virtual machine.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsAutoCompressEnabled Function

PrlVmCfg_IsAutoCompressEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the Automatic HDD compress feature is enabled or not in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsAutoCompressEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that Automatic HDD compress is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is feature that allows to make automatic compacting of a virtual machine disks at predefined time intervals. The feature recommends Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetAutoCompressEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsBatteryStatusEnabled Function

PrlVmCfg_IsBatteryStatusEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable battery status.

Syntax
PRL_RESULT PrlVmCfg_IsBatteryStatusEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsCloseAppOnShutdown Function

PrlVmCfg_IsCloseAppOnShutdown Function
PHT_VM_CONFIGURATION

Determines whether the Parallels application (such as Parallels Desktop) will be automatically closed on the virtual machine shutdown.

Syntax
PRL_RESULT PrlVmCfg_IsCloseAppOnShutdown(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCloseAppOnShutdown
);
File

PrlApiVm.h

Parameters

pbVmCloseAppOnShutdown
[out] A pointer to a variable that receives the result. PLR_TRUE indicates that applications will be closed. PRL_FALSE indicates otherwise.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - operation successfully completed.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsConfigInvalid Function

PrlVmCfg_IsConfigInvalid Function
PHT_VM_CONFIGURATION

The PrlVmCfg_IsConfigInvalid function is used to check the

  • error code of PrlVmCfg_GetConfigValidity function that
  • indicates the invalid status of the config:
  • config doesn't exist, parsing error, invalid server uuid,
  • invalid VM uuid.
  • Parameters
  • nErrCode : The nErrCode value from PrlVmCfg_GetConfigValidity()
  • pbInvalid : [out] validity sign.
Syntax
PRL_RESULT PrlVmCfg_IsConfigInvalid(
    PRL_RESULT nErrCode,
    PRL_BOOL_PTR pbInvalid
);
File

PrlApiVm.h

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsCpuHotplugEnabled Function

PrlVmCfg_IsCpuHotplugEnabled Function
PHT_VM_CONFIGURATION

Determines whether the CPU hotplug is available in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsCpuHotplugEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCpuHotplugEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmCpuHotplugEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsCpuVtxEnabled Function

PrlVmCfg_IsCpuVtxEnabled Function
PHT_VM_CONFIGURATION

Determines whether the x86 virtualization (such as Vt-x) is available in the virtual machine CPU.

Syntax
PRL_RESULT PrlVmCfg_IsCpuVtxEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCpuVtxEnabled
);
File

PrlApiVm.h

Parameters

pbVmCpuVtxEnabled
A pointer to a variable that receives the result. PRL_TRUE indicates that the x86 virtualization is available. PRL_FALSE indicates otherwise.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_NO_DATA - virtual machine configuration does not have necessary data.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsCustomProfile Function

PrlVmCfg_IsCustomProfile Function
PHT_VM_CONFIGURATION

Determines were settings modified after profile was applied or not.

Syntax
PRL_RESULT PrlVmCfg_IsCustomProfile(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbCustom
);
File

PrlApiVm.h

Parameters

pbCustom
[out] A pointer to variable that indicates that settings were modified after profile was applied.
hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsDefaultDeviceNeeded Function

PrlVmCfg_IsDefaultDeviceNeeded Function
PHT_VM_CONFIGURATION

Determines whether the virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.

Syntax
PRL_RESULT PrlVmCfg_IsDefaultDeviceNeeded(
    PRL_UINT32 guestOsVersion,
    PRL_DEVICE_TYPE deviceType,
    PRL_BOOL_PTR pbNeeded
);
File

PrlApiVm.h

Parameters

guestOsVersion
Target OS version. The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).
deviceType
Device type.
pbNeeded
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the device of specified type is required. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function accepts the target operating system type, version, and a device type identifier. Using these parameters, it determines if the specified device is required in order for the projected virtual machine to run properly. If the device is required, you must add it to the virtual machine using the PrlVmCfg_AddDefaultDevice function. If the device is not required, you don't have to add it (i.e. it will not affect the operation of a virtual machine).

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsDisableAPIC Function

PrlVmCfg_IsDisableAPIC Function
PHT_VM_CONFIGURATION

Determines whether the APIC is enabled or disabled during the virtual machine runtime.

Syntax
PRL_RESULT PrlVmCfg_IsDisableAPIC(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbDisableAPIC
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbDisableAPIC
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the APIC is disabled. PBL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsDisableSpeaker Function

PrlVmCfg_IsDisableSpeaker Function
PHT_VM_CONFIGURATION

Determines whether the speaker is enabled or disabled during the virtual machine runtime.

Syntax
PRL_RESULT PrlVmCfg_IsDisableSpeaker(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbDisableSpeaker
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbDisableSpeaker
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the speaker is disabled. PBL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsDiskCacheWriteBack Function

PrlVmCfg_IsDiskCacheWriteBack Function
PHT_VM_CONFIGURATION See Also

Determines if disk cache write-back is enabled in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsDiskCacheWriteBack(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmDiskCacheWriteBack
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmDiskCacheWriteBack
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that cache write-back is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetDiskCacheWriteBack

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsEfiEnabled Function

PrlVmCfg_IsEfiEnabled Function
PHT_VM_CONFIGURATION

Determines whether EFI boot is switched on.

Syntax
PRL_RESULT PrlVmCfg_IsEfiEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEfiEnabled
);
File

PrlApiVm.h

Parameters

pbEfiEnabled
A pointer to a variable that receives the result. PRL_TRUE indicates that the EFI boot is switched on. PRL_FALSE indicates otherwise.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsEncrypted Function

PrlVmCfg_IsEncrypted Function
PHT_VM_CONFIGURATION See Also

Determines whether the virtual machine is in encrypted state

Syntax
PRL_RESULT PrlVmCfg_IsEncrypted(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEncrypted
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEncrypted
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that virtual machine is encrypted. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetSmartGuardEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsExcludeDock Function

PrlVmCfg_IsExcludeDock Function
PHT_VM_CONFIGURATION

Determines the guest OS window behavior in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsExcludeDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmExcludeDock
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmExcludeDock
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that dock is excluded. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When a virtual machine is running in coherence mode, you can make the dock stay always below the virtual machine window. If the window is moved below the dock, the portion of it that crossed that boundary will be cut (will not be redrawn). In order to do that, call this function passing PRL_TRUE in the bVmExcludeDock parameter. If the parameter is set to PRL_FALSE, the virtual machine window will be able to move below the dock.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsExpirationDateEnabled Function

PrlVmCfg_IsExpirationDateEnabled Function
PHT_VM_CONFIGURATION

Gets expiration date status.

Syntax
PRL_RESULT PrlVmCfg_IsExpirationDateEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Set restriction enabled or disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingAutoMount Function

PrlVmCfg_IsGuestSharingAutoMount Function
PHT_VM_CONFIGURATION

Determines if host shared folders are mounted automatically in a given virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingAutoMount(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingAutoMount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingAutoMount
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that shares are mounted automatically. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If shares are mounted automatically, then shared folders will be mapped and appear in the guest OS on startup.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingEnabled Function

PrlVmCfg_IsGuestSharingEnabled Function
PHT_VM_CONFIGURATION

Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that guest sharing is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingEnableSpotlight Function

PrlVmCfg_IsGuestSharingEnableSpotlight Function
PHT_VM_CONFIGURATION

Determines if the virtual disks in a virtual machine will be added to Spotlight search subsystem (OS X feature).

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingEnableSpotlight(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingEnableSpotlight
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingEnableSpotlight
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that virtual disks are added to Spotlight search subsystem. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsHideMinimizedWindowsEnabled Function

PrlVmCfg_IsHideMinimizedWindowsEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable hiding minimized windows.

Syntax
PRL_RESULT PrlVmCfg_IsHideMinimizedWindowsEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsHighAvailabilityEnabled Function

PrlVmCfg_IsHighAvailabilityEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the High Availability feature is enabled or not for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsHighAvailabilityEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that High Availability is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetHighAvailabilityEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsHighResolutionEnabled Function

PrlVmCfg_IsHighResolutionEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable high resolution video mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsHighResolutionEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pbEnabled
A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsHostMemAutoQuota Function

PrlVmCfg_IsHostMemAutoQuota Function
PHT_VM_CONFIGURATION

Determines whether the automatic calculation of the host's memory (RAM) consumption parameters enabled for the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsHostMemAutoQuota(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbHostMemAutoQuota
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbHostMemAutoQuota
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsHostSharingEnabled Function

PrlVmCfg_IsHostSharingEnabled Function
PHT_VM_CONFIGURATION

Determines if host sharing is enabled (host shared folders are visible in the guest OS).

Syntax
PRL_RESULT PrlVmCfg_IsHostSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmHostSharingEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmHostSharingEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that sharing is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsIsolatedVmEnabled Function

PrlVmCfg_IsIsolatedVmEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable isolated VM.

Syntax
PRL_RESULT PrlVmCfg_IsIsolatedVmEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsLockGuestOnSuspendEnabled Function

PrlVmCfg_IsLockGuestOnSuspendEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable lock guest on suspend.

Syntax
PRL_RESULT PrlVmCfg_IsLockGuestOnSuspendEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsLockInFullScreenMode Function

PrlVmCfg_IsLockInFullScreenMode Function
PHT_VM_CONFIGURATION See Also

Determines whether the lock in screen mode sign is set or not in a virtual machine configuration.

Syntax
PRL_RESULT PrlVmCfg_IsLockInFullScreenMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbValue
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbValue
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Lock in screen mode is feature of Parallels Player product that allows to mandatory apply full screen mode for Parallels GUI until guest OS started and go to the windowed mode just after guest OS will be stopped.

See Also

PrlVmCfg_SetLockInFullScreenMode

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsLongerBatteryLifeEnabled Function

PrlVmCfg_IsLongerBatteryLifeEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable longer battery life.

Syntax
PRL_RESULT PrlVmCfg_IsLongerBatteryLifeEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsMapSharedFoldersOnLetters Function

PrlVmCfg_IsMapSharedFoldersOnLetters Function
PHT_VM_CONFIGURATION

Determines whether host disks shared with the guest Windows OS will be mapped to drive letters.

Syntax
PRL_RESULT PrlVmCfg_IsMapSharedFoldersOnLetters(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbMapSharedFoldersOnLetters
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbMapSharedFoldersOnLetters
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that host disks will be mapped to drive letters. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsMultiDisplay Function

PrlVmCfg_IsMultiDisplay Function
PHT_VM_CONFIGURATION

Determines if the specified virtual machine uses a multi-display mode.

Syntax
PRL_RESULT PrlVmCfg_IsMultiDisplay(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmMultiDisplay
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmMultiDisplay
[out] A pointer to a variable that receives the result. PRL_TRUE indicates multi-display. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsNestedVirtualizationEnabled Function

PrlVmCfg_IsNestedVirtualizationEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable nested virtualization.

Syntax
PRL_RESULT PrlVmCfg_IsNestedVirtualizationEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsOfflineManagementEnabled Function

PrlVmCfg_IsOfflineManagementEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the offline management feature is enabled for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsOfflineManagementEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that offline management is available. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetOfflineManagementEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsOsResInFullScrMode Function

PrlVmCfg_IsOsResInFullScrMode Function
PHT_VM_CONFIGURATION

Determines wether the virtual machine OS resolution is in full screen mode.

Syntax
PRL_RESULT PrlVmCfg_IsOsResInFullScrMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmOsResInFullScrMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmOsResInFullScrMode
[out] A pointer to a variable that receives the result. PRL_TRUE indicates full screen mode. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsPauseWhenIdle Function

PrlVmCfg_IsPauseWhenIdle Function
PHT_VM_CONFIGURATION

Determines if the VM pauses automatically when it becomes idle (i.e.

Syntax
PRL_RESULT PrlVmCfg_IsPauseWhenIdle(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmPauseWhenIdle
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmPauseWhenIdle
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that VM will be paused when it becomes idle. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

when no applications is running in the VM)

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsPMUVirtualizationEnabled Function

PrlVmCfg_IsPMUVirtualizationEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable PMU virtualization.

Syntax
PRL_RESULT PrlVmCfg_IsPMUVirtualizationEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsProtected Function

PrlVmCfg_IsProtected Function
PHT_VM_CONFIGURATION

Determines whether the virtual machine is in protected state

Syntax
PRL_RESULT PrlVmCfg_IsProtected(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbProtected
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbProtected
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that virtual machine is protected. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsRamHotplugEnabled Function

PrlVmCfg_IsRamHotplugEnabled Function
PHT_VM_CONFIGURATION

Determines whether the memory (RAM) hotplug is available in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsRamHotplugEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmRamHotplugEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmRamHotplugEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsRateBound Function

PrlVmCfg_IsRateBound Function
PHT_VM_CONFIGURATION

Determines whether the ratebound is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsRateBound(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsRelocateTaskBar Function

PrlVmCfg_IsRelocateTaskBar Function
PHT_VM_CONFIGURATION

Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsRelocateTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmRelocateTaskBar
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmRelocateTaskBar
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsScrResEnabled Function

PrlVmCfg_IsScrResEnabled Function
PHT_VM_CONFIGURATION

Determines if additional screen resolution support is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsScrResEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmScrResEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmScrResEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsShareAllHostDisks Function

PrlVmCfg_IsShareAllHostDisks Function
PHT_VM_CONFIGURATION

Determines whether all host disks will be present at guest OS as shares.

Syntax
PRL_RESULT PrlVmCfg_IsShareAllHostDisks(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbShareAllHostDisks
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbShareAllHostDisks
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that all host disks will be. shared into guest OS. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsShareClipboard Function

PrlVmCfg_IsShareClipboard Function
PHT_VM_CONFIGURATION

Determines whether the clipboard sharing feature is enabled or disabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsShareClipboard(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates that it is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When clipboard sharing is enabled, you can copy and paste text and files from the host to a virtual machine or vise versa, or from one virtual machine to another. This feature requires Parallels Tools installed in a virtual machine.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedAppsGuestToHost Function

PrlVmCfg_IsSharedAppsGuestToHost Function
PHT_VM_CONFIGURATION

Determines whether the guest applications shared to host or not.

Syntax
PRL_RESULT PrlVmCfg_IsSharedAppsGuestToHost(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedAppsHostToGuest Function

PrlVmCfg_IsSharedAppsHostToGuest Function
PHT_VM_CONFIGURATION

Determines whether the host applications shared to guest or not.

Syntax
PRL_RESULT PrlVmCfg_IsSharedAppsHostToGuest(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedBluetoothEnabled Function

PrlVmCfg_IsSharedBluetoothEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable bluetooth camera.

Syntax
PRL_RESULT PrlVmCfg_IsSharedBluetoothEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedCameraEnabled Function

PrlVmCfg_IsSharedCameraEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable shared camera.

Syntax
PRL_RESULT PrlVmCfg_IsSharedCameraEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedCloudEnabled Function

PrlVmCfg_IsSharedCloudEnabled Function
PHT_VM_CONFIGURATION

Determines whether shared cloud is enabled or disabled.

Syntax
PRL_RESULT PrlVmCfg_IsSharedCloudEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedProfileEnabled Function

PrlVmCfg_IsSharedProfileEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the Shared Profile feature is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsSharedProfileEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the shred profile is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsSharedProfileEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsShareUserHomeDir Function

PrlVmCfg_IsShareUserHomeDir Function
PHT_VM_CONFIGURATION

Determines whether the host user home directory will be available in the guest OS as a share.

Syntax
PRL_RESULT PrlVmCfg_IsShareUserHomeDir(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbShareUserHomeDir
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbShareUserHomeDir
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that host user home directory will be shared with the guest OS. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsShowTaskBar Function

PrlVmCfg_IsShowTaskBar Function
PHT_VM_CONFIGURATION

Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsShowTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmShowTaskBar
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmShowTaskBar
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the option is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsShowWindowsAppInDock Function

PrlVmCfg_IsShowWindowsAppInDock Function
PHT_VM_CONFIGURATION

Determines whether the "Show Windows Applications folder in Dock" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsShowWindowsAppInDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartGuardEnabled Function

PrlVmCfg_IsSmartGuardEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the SmartGuard feature is enabled or not in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsSmartGuardEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that SmartGuard is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is feature that allows to make automatic snapshots of a virtual machine at predefined time intervals. The feature requires Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetSmartGuardEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsSmartGuardNotifyBeforeCreation Function

PrlVmCfg_IsSmartGuardNotifyBeforeCreation Function
PHT_VM_CONFIGURATION See Also

Determines whether the user will be notified on automatic snapshot creation, a SmartGaurd setting.

Syntax
PRL_RESULT PrlVmCfg_IsSmartGuardNotifyBeforeCreation(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbNotifyBeforeCreation
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbNotifyBeforeCreation
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user will be automatically notified. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See PrlVmCfg_SetSmartGuardNotifyBeforeCreation for more information.

See Also

PrlVmCfg_SetSmartGuardNotifyBeforeCreation

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsSmartMountDVDsEnabled Function

PrlVmCfg_IsSmartMountDVDsEnabled Function
PHT_VM_CONFIGURATION

Determines whether the SmartMount CD/DVD drives is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsSmartMountDVDsEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartMountEnabled Function

PrlVmCfg_IsSmartMountEnabled Function
PHT_VM_CONFIGURATION

Determines whether the SmartMount feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsSmartMountEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartMountNetworkSharesEnabled Function

PrlVmCfg_IsSmartMountNetworkSharesEnabled Function
PHT_VM_CONFIGURATION

Determines whether the SmartMount network shares is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsSmartMountNetworkSharesEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartMountRemovableDrivesEnabled Function

PrlVmCfg_IsSmartMountRemovableDrivesEnabled Function
PHT_VM_CONFIGURATION

Determines whether the SmartMount removable drives is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsSmartMountRemovableDrivesEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartMouseEnabled Function

PrlVmCfg_IsSmartMouseEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable smart mouse.

Syntax
PRL_RESULT PrlVmCfg_IsSmartMouseEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsStartInDetachedWindowEnabled Function

PrlVmCfg_IsStartInDetachedWindowEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable start in detached window.

Syntax
PRL_RESULT PrlVmCfg_IsStartInDetachedWindowEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsStickyMouseEnabled Function

PrlVmCfg_IsStickyMouseEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable sticky mouse.

Syntax
PRL_RESULT PrlVmCfg_IsStickyMouseEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSupportUsb30Enabled Function

PrlVmCfg_IsSupportUsb30Enabled Function
PHT_VM_CONFIGURATION

Gets support status USB 3.0.

Syntax
PRL_RESULT PrlVmCfg_IsSupportUsb30Enabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSwitchOffAeroEnabled Function

PrlVmCfg_IsSwitchOffAeroEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable switching off aero.

Syntax
PRL_RESULT PrlVmCfg_IsSwitchOffAeroEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSwitchOffWindowsLogoEnabled Function

PrlVmCfg_IsSwitchOffWindowsLogoEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable Windows logo.

Syntax
PRL_RESULT PrlVmCfg_IsSwitchOffWindowsLogoEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled Function

PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable switching to full screen on demand.

Syntax
PRL_RESULT PrlVmCfg_IsSwitchToFullscreenOnDemandEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsSyncDefaultPrinter Function

PrlVmCfg_IsSyncDefaultPrinter Function
PHT_VM_CONFIGURATION

Gets synchronization default printer option.

Syntax
PRL_RESULT PrlVmCfg_IsSyncDefaultPrinter(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbSync
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbSync
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsTemplate Function

PrlVmCfg_IsTemplate Function
PHT_VM_CONFIGURATION

Determines if the specified virtual machine object contains a virtual machine or a template configuration information.

Syntax
PRL_RESULT PrlVmCfg_IsTemplate(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmIsTemplate
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmIsTemplate
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the machine is a template. PBL_FALE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the object contains a template configuration, it can be used to create new virtual machines from it. See PrlVm_Clone for the information on how to create virtual machines from templates.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsTimeSynchronizationEnabled Function

PrlVmCfg_IsTimeSynchronizationEnabled Function
PHT_VM_CONFIGURATION See Also

Determines whether the time synchronization feature is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsTimeSynchronizationEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
A pointer to a variable that receives the result. PRL_TRUE indicates that the time synchronization is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetTimeSynchronizationEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsTimeSyncSmartModeEnabled Function

PrlVmCfg_IsTimeSyncSmartModeEnabled Function
PHT_VM_CONFIGURATION

Determines whether the smart time synchronization is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsTimeSyncSmartModeEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
A pointer to a variable that receive the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For more information, see PrlVmCfg_SetTimeSyncSmartModeEnabled.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsToolsAutoUpdateEnabled Function

PrlVmCfg_IsToolsAutoUpdateEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsToolsAutoUpdateEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable the AutoUpdate feature. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseDefaultAnswers Function

PrlVmCfg_IsUseDefaultAnswers Function
PHT_VM_CONFIGURATION See Also

Determines whether the use default answers mechanism active for the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsUseDefaultAnswers(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbUseDefaultAnswers
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbUseDefaultAnswers
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that mehanism is active. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetUseDefaultAnswers

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsUseDesktop Function

PrlVmCfg_IsUseDesktop Function
PHT_VM_CONFIGURATION

Determines whether the "use desktop in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUseDesktop(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseDocuments Function

PrlVmCfg_IsUseDocuments Function
PHT_VM_CONFIGURATION

Determines whether "use documents in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUseDocuments(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseDownloads Function

PrlVmCfg_IsUseDownloads Function
PHT_VM_CONFIGURATION

Determines whether the "used downloads in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUseDownloads(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseHostPrinters Function

PrlVmCfg_IsUseHostPrinters Function
PHT_VM_CONFIGURATION

Gets use host printers option.

Syntax
PRL_RESULT PrlVmCfg_IsUseHostPrinters(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbUse
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbUse
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseMovies Function

PrlVmCfg_IsUseMovies Function
PHT_VM_CONFIGURATION

Determines whether the "used movies in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUseMovies(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUseMusic Function

PrlVmCfg_IsUseMusic Function
PHT_VM_CONFIGURATION

Determines whether the "use music in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUseMusic(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUsePictures Function

PrlVmCfg_IsUsePictures Function
PHT_VM_CONFIGURATION

Determines whether the "used pictures in shared profile" feature is enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUsePictures(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsUserDefinedSharedFoldersEnabled Function

PrlVmCfg_IsUserDefinedSharedFoldersEnabled Function
PHT_VM_CONFIGURATION

Determines whether the user-defined shared folders are enabled or not.

Syntax
PRL_RESULT PrlVmCfg_IsUserDefinedSharedFoldersEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsVerticalSynchronizationEnabled Function

PrlVmCfg_IsVerticalSynchronizationEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable vertical synchronization video mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsVerticalSynchronizationEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pbEnabled
A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsVirtualLinksEnabled Function

PrlVmCfg_IsVirtualLinksEnabled Function
PHT_VM_CONFIGURATION

Determines whether the Virtual Links feature is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsVirtualLinksEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the shred profile is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_IsWinSystrayInMacMenuEnabled Function

PrlVmCfg_IsWinSystrayInMacMenuEnabled Function
PHT_VM_CONFIGURATION

Determines disable or enable Windows systray in Mac menu.

Syntax
PRL_RESULT PrlVmCfg_IsWinSystrayInMacMenuEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR pbEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnable
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_Set3DAccelerationMode Function

PrlVmCfg_Set3DAccelerationMode Function
PHT_VM_CONFIGURATION

Sets 3D graphical acceleration technology mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_Set3DAccelerationMode(
    PRL_HANDLE hVmCfg,
    PRL_VIDEO_3D_ACCELERATION n3DAccelerationMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
n3DAccelerationMode
Setting value. See PRL_VIDEO_3D_ACCELERATION enum.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetActionOnStopMode Function

PrlVmCfg_SetActionOnStopMode Function
PHT_VM_CONFIGURATION

Sets action on stop mode.

Syntax
PRL_RESULT PrlVmCfg_SetActionOnStopMode(
    PRL_HANDLE hVm,
    PRL_VM_ACTION_ON_STOP nMode
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nMode
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetActionOnWindowClose Function

PrlVmCfg_SetActionOnWindowClose Function
PHT_VM_CONFIGURATION

Allows to set the action on Parallels Application window close for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetActionOnWindowClose(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACTION_ON_WINDOW_CLOSE nActionOnWindowClose
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nActionOnWindowClose
Action on Parallels window close to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAdaptiveHypervisorEnabled Function

PrlVmCfg_SetAdaptiveHypervisorEnabled Function
PHT_VM_CONFIGURATION

Disables or enables adaptive hypervisor.

Syntax
PRL_RESULT PrlVmCfg_SetAdaptiveHypervisorEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAllowSelectBootDevice Function

PrlVmCfg_SetAllowSelectBootDevice Function
PHT_VM_CONFIGURATION See Also

Switches on/off select boot device dialog on virtual machine startup.

Syntax
PRL_RESULT PrlVmCfg_SetAllowSelectBootDevice(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bAllowed
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bAllowed
Action type. Specify PRL_TRUE to enable select boot device dialog. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsAllowSelectBootDevice

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetAppInDockMode Function

PrlVmCfg_SetAppInDockMode Function
PHT_VM_CONFIGURATION

Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).

Syntax
PRL_RESULT PrlVmCfg_SetAppInDockMode(
    PRL_HANDLE hVmCfg,
    PRL_APP_IN_DOCK_MODE nVmAppInDockMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAppInDockMode
The applications in dock mode option to set. See the PRL_APP_IN_DOCK_MODE enumeration for the list of options.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAppTemplateList Function

PrlVmCfg_SetAppTemplateList Function
PHT_VM_CONFIGURATION

Specify application templates list which will be used in the specified Parallels Virtuozzo Container.

Syntax
PRL_RESULT PrlVmCfg_SetAppTemplateList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hAppList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hAppList
A handle of type PHT_STRINGS_LIST that specifies the list of application templates

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This option acceptable for Virtual Machine of PVT_CT only.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAssetId Function

PrlVmCfg_SetAssetId Function
PHT_VM_CONFIGURATION

Sets the virtual machine asset id.

Syntax
PRL_RESULT PrlVmCfg_SetAssetId(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewAssetId
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine connfiguration.
sNewAssetId
The virtual machine asset id to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoApplyIpOnly Function

PrlVmCfg_SetAutoApplyIpOnly Function
PHT_VM_CONFIGURATION

Allows to specify whether a virtual machine should be automatically configured for IP addrs.

Syntax
PRL_RESULT PrlVmCfg_SetAutoApplyIpOnly(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bAutoApplyIpOnly
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual network adapter.
bAutoApplyIpOnly
Specify PRL_TRUE to configure the adapter automatically. Specified PRL_FALSE to configure the network settings manually in a virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In comparison with PrlVmDevNet_SetAutoApply(), dns servers and searchdomains settings will be skipped.

Notes

for changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoCaptureReleaseMouse Function

PrlVmCfg_SetAutoCaptureReleaseMouse Function
PHT_VM_CONFIGURATION

Enables or disables the automatic capture and release of the mouse pointer in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoCaptureReleaseMouse(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable the feature or PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this feature is enabled, the mouse input is automatically redirected from the host OS to the virtual machine and vise versa as soon as the mouse pointer is positioned over the host OS or the virtual machine desktop. This feature requires Parallels Tools installed in a virtual machine.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoCompressEnabled Function

PrlVmCfg_SetAutoCompressEnabled Function
PHT_VM_CONFIGURATION See Also

Enables the Automatic HDD compress feature in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoCompressEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable Automatic HDD compress. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is feature that allows to make automatic compress of a virtual machine disks at predefined time intervals. The feature recommends Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetAutoCompressdInterval PrlVmCfg_SetFreeDiskSpaceRatio

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetAutoCompressInterval Function

PrlVmCfg_SetAutoCompressInterval Function
PHT_VM_CONFIGURATION See Also

Sets the time interval at which compacting virtual disks are doing by Automatic HDD compress.

Syntax
PRL_RESULT PrlVmCfg_SetAutoCompressInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nInterval
The time interval to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is feature that allows to make automatic compress of a virtual machine disks at predefined time intervals. This function allows to set the interval at which the automatic compress are taken.

See Also

PrlVmCfg_GetAutoCompressInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetAutoStart Function

PrlVmCfg_SetAutoStart Function
PHT_VM_CONFIGURATION

Allows to sets the automatic startup option for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStart(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTART_OPTION nVmAutoStart
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStart
The automatic startup option to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoStartDelay Function

PrlVmCfg_SetAutoStartDelay Function
PHT_VM_CONFIGURATION

Sets the time delay that will be used during the virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStartDelay(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmAutoStartDelay
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStartDelay
Time delay to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoStop Function

PrlVmCfg_SetAutoStop Function
PHT_VM_CONFIGURATION

Allows to set the automatic shutdown mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStop(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTOP_OPTION nVmAutoStop
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStop
Automatic shutdown mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetBackgroundPriority Function

PrlVmCfg_SetBackgroundPriority Function
PHT_VM_CONFIGURATION

Sets the virtual machine background processes priority.

Syntax
PRL_RESULT PrlVmCfg_SetBackgroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY nVmBackgroundPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmBackgroundPriority
The priority level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetBatteryStatusEnabled Function

PrlVmCfg_SetBatteryStatusEnabled Function
PHT_VM_CONFIGURATION

Disables or enables battery status.

Syntax
PRL_RESULT PrlVmCfg_SetBatteryStatusEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCapabilitiesMask Function

PrlVmCfg_SetCapabilitiesMask Function
PHT_VM_CONFIGURATION See Also

Sets a capabilities inside the CT.

Syntax
PRL_RESULT PrlVmCfg_SetCapabilitiesMask(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nCapMask
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nCapMask
[in] A bitmask containing the supported capabilities. For available options see the PRL_CT_CAPMASK enumeration and CAPDEFAULTMASK defined in PrlEnums.h as macros.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetCapabilitiesMask

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCloseAppOnShutdown Function

PrlVmCfg_SetCloseAppOnShutdown Function
PHT_VM_CONFIGURATION See Also

Allows to specify whether the Parallels application (such Parallels Desktop) will be closed on the virtual machine shutdown.

Syntax
PRL_RESULT PrlVmCfg_SetCloseAppOnShutdown(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmCloseAppOnShutdown
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bVmCloseAppOnShutdown
Action type. Specify PRL_TRUE to close the application. Specify PRL_FALSE to keep it running.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsCloseAppOnShutdown

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCoherenceButtonVisibility Function

PrlVmCfg_SetCoherenceButtonVisibility Function
PHT_VM_CONFIGURATION

Sets the virtual machine "Coherence Button visibility" option.

Syntax
PRL_RESULT PrlVmCfg_SetCoherenceButtonVisibility(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmCoherenceButtonVisibility
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmCoherenceButtonVisibility
The value to set. Specify PRL_TRUE to show Coherence Button when a user points to a Windows Start button. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetConfirmationsList Function

PrlVmCfg_SetConfirmationsList Function
PHT_VM_CONFIGURATION See Also

Determines a list of operations with virtual machine which required administrator confirmation

Syntax
PRL_RESULT PrlVmCfg_SetConfirmationsList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hConfirmList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hConfirmList
A handle of type is PHT_OPAQUE_TYPE_LIST contains new list of operations( values in enum PRL_ALLOWED_VM_COMMAND ) that required administrator's confirmation.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

See Also

PrlSrv_DisableConfirmationMode() PrlSrv_EnableConfirmationMode() PrlSrv_IsConfirmationModeEnabled() PrlVmCfg_GetConfirmationsList() PrlVmCfg_SetConfirmationsList() PrlDispCfg_GetConfirmationsList() PrlDispCfg_SetConfirmationsList()

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCpuAccelLevel Function

PrlVmCfg_SetCpuAccelLevel Function
PHT_VM_CONFIGURATION

Sets CPU acceleration level for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuAccelLevel(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACCELERATION_LEVEL nVmCpuAccelLevel
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuAccelLevel
The CPU acceleration level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuCount Function

PrlVmCfg_SetCpuCount Function
PHT_VM_CONFIGURATION

Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).

Syntax
PRL_RESULT PrlVmCfg_SetCpuCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmCpuCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuCount
The number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuHotplugEnabled Function

PrlVmCfg_SetCpuHotplugEnabled Function
PHT_VM_CONFIGURATION

Sets CPU hotplug mode (enabled or disabled) for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuHotplugEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmCpuHotplugEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmCpuHotplugEnabled
The CPU hotplug mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuLimit Function

PrlVmCfg_SetCpuLimit Function
PHT_VM_CONFIGURATION See Also

Sets the CPU usage limit (in percent) for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuLimit(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmCpuLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuLimit
CPU usage limit from the range of 0-100%.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetCpuLimit

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCpuLimitEx Function

PrlVmCfg_SetCpuLimitEx Function
PHT_VM_CONFIGURATION

Sets limit of CPU usage for the virtual machine in Mhz.

Syntax
PRL_RESULT PrlVmCfg_SetCpuLimitEx(
    PRL_HANDLE hVmCfg,
    PRL_CONST_CPULIMIT_DATA_PTR pVmCpuLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. cpulimit A cpulimit data of PRL_CPULIMIT_DATA type

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuMask Function

PrlVmCfg_SetCpuMask Function
PHT_VM_CONFIGURATION See Also

Sets the CPU affinity for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuMask(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sMask
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sMask
CPU affinity mask is represented by an cpu number or cpu range separated by the comma. (0,2,3-10)

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetCpuLimit

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCpuMode Function

PrlVmCfg_SetCpuMode Function
PHT_VM_CONFIGURATION

Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuMode(
    PRL_HANDLE hVmCfg,
    PRL_CPU_MODE nVmCpuMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuMode
The CPU mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuUnits Function

PrlVmCfg_SetCpuUnits Function
PHT_VM_CONFIGURATION See Also

Sets the number of CPU units that will be allocated to a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuUnits(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmCpuUnits
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuUnits
The number of CPU units to allocate.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each virtual machine on the same host can be allocated a number of CPU units from the range of 8 to 500000. The larger the number is, the more CPU time the virtual machine will get.

See Also

PrlVmCfg_GetCpuUnits

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCustomProperty Function

PrlVmCfg_SetCustomProperty Function
PHT_VM_CONFIGURATION

Sets the virtual machine custom property information.

Syntax
PRL_RESULT PrlVmCfg_SetCustomProperty(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmCustomProperty
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmCustomProperty
A pointer to a buffer containing the custom information. The data must be in CDATA format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If you have some custom data, which relates to a virtual machine in some way, you can save it in the virtual machine configuration for future retrieval. This can be any data that your client application requires. The data is stored in CDATA format.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetDefaultConfig Function

PrlVmCfg_SetDefaultConfig Function
PHT_VM_CONFIGURATION

The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.

Syntax
PRL_RESULT PrlVmCfg_SetDefaultConfig(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 guestOsVersion,
    PRL_BOOL needCreateDevices
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG.
guestOsVersion
The version of the operating system that the virtual machine will be running. The OS versions can be found in the PrlOses.h file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).
needCreateDevices
A flag indicating whether default virtual machine devices should be created or not. Specify PRL_TRUE to create default devices, or PRL_FALSE to skip the device creation.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The default configuration information is obtained from the host machine configuration, which is passed to the function as a parameter. Using a default configuration for a new virtual machine is the simplest and safest way to configure a new virtual machine. For the example on how to create a new virtual machine using a default configuration, see the PrlVm_Reg function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetDescription Function

PrlVmCfg_SetDescription Function
PHT_VM_CONFIGURATION

Sets the virtual machine description.

Syntax
PRL_RESULT PrlVmCfg_SetDescription(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmDescription
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmDescription
The virtual machine description to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetDisableAPICSign Function

PrlVmCfg_SetDisableAPICSign Function
PHT_VM_CONFIGURATION See Also

Allows to specify whether the virtual machine should be using APIC during runtime.

Syntax
PRL_RESULT PrlVmCfg_SetDisableAPICSign(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bDisableAPIC
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bDisableAPIC
The value to set. Specify PRL_TRUE to enable the APIC. Specify PRL_FALSE disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsDisableAPIC

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetDisableSpeakerSign Function

PrlVmCfg_SetDisableSpeakerSign Function
PHT_VM_CONFIGURATION See Also

Allows to specify whether the virtual machine should be using speaker during runtime.

Syntax
PRL_RESULT PrlVmCfg_SetDisableSpeakerSign(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bDisableSpeaker
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bDisableSpeaker
The value to set. Specify PRL_TRUE to enable the speaker. Specify PRL_FALSE disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsDisableSpeaker

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetDiskCacheWriteBack Function

PrlVmCfg_SetDiskCacheWriteBack Function
PHT_VM_CONFIGURATION

Sets the virtual machine disk cache write-back option.

Syntax
PRL_RESULT PrlVmCfg_SetDiskCacheWriteBack(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmDiskCacheWriteBack
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmDiskCacheWriteBack
The disk cache write-back option to set. Specify PRL_TRUE to enable the disk cache write-back. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetDnsServers Function

PrlVmCfg_SetDnsServers Function
PHT_VM_CONFIGURATION

Allows to manually assign DNS servers a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetDnsServers(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hDnsServersList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hDnsServersList
A handle of type PHT_STRINGS_LIST containing the list of DNS servers to be assigned to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetDockIconType Function

PrlVmCfg_SetDockIconType Function
PHT_VM_CONFIGURATION

Sets the virtual machine dock icon type.

Syntax
PRL_RESULT PrlVmCfg_SetDockIconType(
    PRL_HANDLE hVmCfg,
    PRL_DOCK_ICON_TYPE nVmDockIconType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmDockIconType
The icon type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetEfiEnabled Function

PrlVmCfg_SetEfiEnabled Function
PHT_VM_CONFIGURATION

Sets EFI boot for the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetEfiEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEfiEnabled
);
File

PrlApiVm.h

Parameters

bEfiEnabled
Setting value. Perform PRL_TRUE to switch on EFI boot. Perform PRL_FALSE to switch off last one.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Remarks

for the specified virtual machine.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExcludeDock Function

PrlVmCfg_SetExcludeDock Function
PHT_VM_CONFIGURATION

Sets the exclude dock option.

Syntax
PRL_RESULT PrlVmCfg_SetExcludeDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmExcludeDock
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmExcludeDock
The value to set. Specify PRL_TRUE to exclude the dock. Specify PRL_FALSE to include the dock.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When a virtual machine is running in coherence mode, you can make the dock stay always below the virtual machine window. If the window is moved below the dock, the portion of it that crossed that boundary will be cut (will not be redrawn). In order to do that, call this function passing PRL_TRUE in the bVmExcludeDock parameter. If the parameter is set to PRL_FALSE, the virtual machine window will be able to move below the dock.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationDate Function

PrlVmCfg_SetExpirationDate Function
PHT_VM_CONFIGURATION

Sets expiration date.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationDate(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sExpirationDate
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sExpirationDate
Date and time in "yyyy-mm-dd hh:mm:ss" format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationDateEnabled Function

PrlVmCfg_SetExpirationDateEnabled Function
PHT_VM_CONFIGURATION

Sets expiration date enabled/disabled.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationDateEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Set restriction enabled or disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationNote Function

PrlVmCfg_SetExpirationNote Function
PHT_VM_CONFIGURATION

Sets expiration note.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationNote(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNote
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNote
The note to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationOfflineTimeToLive Function

PrlVmCfg_SetExpirationOfflineTimeToLive Function
PHT_VM_CONFIGURATION

Sets the offline time of working with virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationOfflineTimeToLive(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nTime
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nTime
The time interval to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationTimeCheckInterval Function

PrlVmCfg_SetExpirationTimeCheckInterval Function
PHT_VM_CONFIGURATION

Sets the time interval to check on expiration date.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationTimeCheckInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nInterval
The time interval to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExpirationTrustedTimeServer Function

PrlVmCfg_SetExpirationTrustedTimeServer Function
PHT_VM_CONFIGURATION

Sets trusted time server.

Syntax
PRL_RESULT PrlVmCfg_SetExpirationTrustedTimeServer(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sUrl
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sUrl
The URL to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetExternalBootDevice Function

PrlVmCfg_SetExternalBootDevice Function
PHT_VM_CONFIGURATION

Sets an external boot device system name.

Syntax
PRL_RESULT PrlVmCfg_SetExternalBootDevice(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewSysName
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewSysName
The name to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetFeaturesMask Function

PrlVmCfg_SetFeaturesMask Function
PHT_VM_CONFIGURATION See Also

Sets a features inside the CT.

Syntax
PRL_RESULT PrlVmCfg_SetFeaturesMask(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nOn,
    PRL_UINT32 nOff
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nOn
[in] A bitmask of enabled features. For available options see the PRL_CT_FEATURES enumeration
nOff
[in] A bitmask of disabled features. For available options see the PRL_CT_FEATURES enumeration

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetCapabilitiesMask

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetForegroundPriority Function

PrlVmCfg_SetForegroundPriority Function
PHT_VM_CONFIGURATION

Sets the virtual machine foreground processes priority.

Syntax
PRL_RESULT PrlVmCfg_SetForegroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY nVmForegroundPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmForegroundPriority
The priority level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetFreeDiskSpaceRatio Function

PrlVmCfg_SetFreeDiskSpaceRatio Function
PHT_VM_CONFIGURATION See Also

Sets the time free disk space ratio at which compacting virtual disks are doing by Automatic HDD compress.

Syntax
PRL_RESULT PrlVmCfg_SetFreeDiskSpaceRatio(
    PRL_HANDLE hVmCfg,
    PRL_DOUBLE dFreeDiskSpaceRatio
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
dFreeDiskSpaceRatio
The space ratio to set, in percents.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Automatic HDD compress is feature that allows to make automatic compress of a virtual machine disks at predefined space ratio. This function allows to set the space ratio at which the automatic compress are taken.

See Also

PrlVmCfg_GetFreeDiskSpaceRatio

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetGuestSharingAutoMount Function

PrlVmCfg_SetGuestSharingAutoMount Function
PHT_VM_CONFIGURATION

Sets the guest OS sharing auto-mount option.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingAutoMount(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingAutoMount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingAutoMount
Auto-mount option to set. Specify PRL_TRUE to enable sharing auto-mount. Specify PRL_FALSE to disable auto-mount.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled (see PrlVmCfg_SetGuestSharingEnabled) and auto-mount is turned on, the guest OS disk drives will appear as icons on the host desktop. If sharing is enabled but auto-mount is not, you will not see the drives in the host OS but Smart Select feature will still work.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetGuestSharingEnabled Function

PrlVmCfg_SetGuestSharingEnabled Function
PHT_VM_CONFIGURATION

Enables the guest sharing feature.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingEnabled
The value to set. Specify PRL_TRUE to enable guest sharing. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled, the guest OS disk drives will be accessible in the host OS. If, in addition, the auto-mount feature is turned on, the guest OS disk drives will appear as icons on the host desktop. If sharing is enabled but auto-mount is not, you will not see the drives in the host OS but Smart Select feature will still work.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetGuestSharingEnableSpotlight Function

PrlVmCfg_SetGuestSharingEnableSpotlight Function
PHT_VM_CONFIGURATION

Sets the VM virtual disks added to Spotlight search subsystem sign.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingEnableSpotlight(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingEnableSpotlight
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingEnableSpotlight
Enable Spotlight option to set. Specify PRL_TRUE to enable using virtual harddisks at Spotlight search subsystem. Specify PRL_FALSE to disable virtual hard disks from Spotlight.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled (see PrlVmCfg_SetGuestSharingEnabled) and Spotlight enable sign is turned on, the search through Spotlight subsystem will be using VM virtual hardisks too.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHideMinimizedWindowsEnabled Function

PrlVmCfg_SetHideMinimizedWindowsEnabled Function
PHT_VM_CONFIGURATION

Disables or enables hiding minimized windows.

Syntax
PRL_RESULT PrlVmCfg_SetHideMinimizedWindowsEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHighAvailabilityEnabled Function

PrlVmCfg_SetHighAvailabilityEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the High Availability feature for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHighAvailabilityEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable the High Availability feature. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsHighAvailabilityEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetHighAvailabilityPriority Function

PrlVmCfg_SetHighAvailabilityPriority Function
PHT_VM_CONFIGURATION See Also

Sets the priority of the virtual machine in the High Availability Cluster.

Syntax
PRL_RESULT PrlVmCfg_SetHighAvailabilityPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nPriority
The priority value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetHighAvailabilityPriority

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetHighResolutionEnabled Function

PrlVmCfg_SetHighResolutionEnabled Function
PHT_VM_CONFIGURATION

Disables or enables high resolution video mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHighResolutionEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bEnabled
Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostMemAutoQuota Function

PrlVmCfg_SetHostMemAutoQuota Function
PHT_VM_CONFIGURATION

Enables or disables the automatic calculation of the host's memory (RAM) consumption parameters for the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHostMemAutoQuota(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bHostMemAutoQuota
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bHostMemAutoQuota
The value to set. Specify PRL_TRUE to enable the automatic calculation or PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostMemQuotaMax Function

PrlVmCfg_SetHostMemQuotaMax Function
PHT_VM_CONFIGURATION

Sets the maximal size of the host's memory (RAM) consumption by the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHostMemQuotaMax(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nHostMemQuotaMax
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nHostMemQuotaMax
The maximal RAM size to set, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostMemQuotaMin Function

PrlVmCfg_SetHostMemQuotaMin Function
PHT_VM_CONFIGURATION

Sets the minimal size of the host's memory (RAM) consumption by the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHostMemQuotaMin(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nHostMemQuotaMin
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nHostMemQuotaMin
The minimal RAM size to set, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostMemQuotaPriority Function

PrlVmCfg_SetHostMemQuotaPriority Function
PHT_VM_CONFIGURATION

Sets the relative priority of the virtual machine in host's memory (RAM) distribution mechanism.

Syntax
PRL_RESULT PrlVmCfg_SetHostMemQuotaPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nHostMemQuotaPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nHostMemQuotaPriority
The priority to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostname Function

PrlVmCfg_SetHostname Function
PHT_VM_CONFIGURATION

Sets the specified virtual machine hostname.

Syntax
PRL_RESULT PrlVmCfg_SetHostname(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmHostname
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmName
The hostname to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetHostSharingEnabled Function

PrlVmCfg_SetHostSharingEnabled Function
PHT_VM_CONFIGURATION

Enables host sharing for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHostSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmHostSharingEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmHostSharingEnabled
The value to set. Specify PRL_TRUE to enable sharing. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When host sharing is enabled, the host OS shared folders will be visible in the guest OS. To use the host sharing feature, the shared folders must be set up first using the functionality provided by the PHT_SHARE object.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetIcon Function

PrlVmCfg_SetIcon Function
PHT_VM_CONFIGURATION

Sets the virtual machine icon.

Syntax
PRL_RESULT PrlVmCfg_SetIcon(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmIcon
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmIcon
The new icon file name.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetIoLimit Function

PrlVmCfg_SetIoLimit Function
PHT_VM_CONFIGURATION

Sets limit of I/O usage for the virtual machine in Bytes/s.

Syntax
PRL_RESULT PrlVmCfg_SetIoLimit(
    PRL_HANDLE hVmCfg,
    PRL_CONST_IOLIMIT_DATA_PTR pVmIoLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. pVmIoLimit A I/O limit data of PRL_IOLIMIT_DATA type

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetIoPriority Function

PrlVmCfg_SetIoPriority Function
PHT_VM_CONFIGURATION

Sets the specified virtual machine I/O priority.

Syntax
PRL_RESULT PrlVmCfg_SetIoPriority(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmIoPriority
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmIoPriority
io priority 0-7.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Priority range is [PRL_IOPRIO_MIN - PRL_IOPRIO_MAX]. The greater priority is, the more time for I/O activity Vm has. By default each Vm has priority of IO_PRIO_DEFAULT.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetIopsLimit Function

PrlVmCfg_SetIopsLimit Function
PHT_VM_CONFIGURATION

Sets the specified virtual machine IOPS limit.

Syntax
PRL_RESULT PrlVmCfg_SetIopsLimit(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmIopsLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. nVmIopsLimit IOPS limit.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetIsolatedVmEnabled Function

PrlVmCfg_SetIsolatedVmEnabled Function
PHT_VM_CONFIGURATION

Disables or enables shared camera isolated VM.

Syntax
PRL_RESULT PrlVmCfg_SetIsolatedVmEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetLockGuestOnSuspendEnabled Function

PrlVmCfg_SetLockGuestOnSuspendEnabled Function
PHT_VM_CONFIGURATION

Disables or enables shared camera lock guest on suspend.

Syntax
PRL_RESULT PrlVmCfg_SetLockGuestOnSuspendEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetLockInFullScreenMode Function

PrlVmCfg_SetLockInFullScreenMode Function
PHT_VM_CONFIGURATION See Also

Enables or disables the lock in screen mode feature in a virtual machine configuration.

Syntax
PRL_RESULT PrlVmCfg_SetLockInFullScreenMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bValue
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bValue
Action type. Specify PRL_TRUE to enable feature. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Lock in screen mode is feature of Parallels Player product that allows to mandatory apply full screen mode for Parallels GUI until guest OS started and go to the windowed mode just after guest OS will be stopped.

See Also

PrlVmCfg_IsLockInFullScreenMode

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetLongerBatteryLifeEnabled Function

PrlVmCfg_SetLongerBatteryLifeEnabled Function
PHT_VM_CONFIGURATION

Disables or enables longer battery life.

Syntax
PRL_RESULT PrlVmCfg_SetLongerBatteryLifeEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetMapSharedFoldersOnLetters Function

PrlVmCfg_SetMapSharedFoldersOnLetters Function
PHT_VM_CONFIGURATION

Enables mapping of shared host disks on drive letters for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetMapSharedFoldersOnLetters(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bMapSharedFoldersOnLetters
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bMapSharedFoldersOnLetters
The value to set. Specify PRL_TRUE to map shared host disks on drive letters. Specify PRL_FALSE to not share it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this sign switched on host disks shared into guest Windows OS will be maped on correspond drive letters. Note that host sharing should be switched on to enable this functionality.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetMaxBalloonSize Function

PrlVmCfg_SetMaxBalloonSize Function
PHT_VM_CONFIGURATION

Sets the maximum memory limit which can be locked by balloon in the virtual machine, in percent of guest RAM.

Syntax
PRL_RESULT PrlVmCfg_SetMaxBalloonSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nMaxBalloonSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nMaxBalloonSize
The maximum balloon size to set, in percent.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetMultiDisplay Function

PrlVmCfg_SetMultiDisplay Function
PHT_VM_CONFIGURATION

Sets the virtual machine multi-display option.

Syntax
PRL_RESULT PrlVmCfg_SetMultiDisplay(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmMultiDisplay
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmMultiDisplay
The value to set. Specify PRL_TRUE to enable the multi-display option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetName Function

PrlVmCfg_SetName Function
PHT_VM_CONFIGURATION

Sets the specified virtual machine name.

Syntax
PRL_RESULT PrlVmCfg_SetName(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmName
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmName
The name to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetNestedVirtualizationEnabled Function

PrlVmCfg_SetNestedVirtualizationEnabled Function
PHT_VM_CONFIGURATION

Disables or enables nested virtualization.

Syntax
PRL_RESULT PrlVmCfg_SetNestedVirtualizationEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetNetfilterMode Function

PrlVmCfg_SetNetfilterMode Function
PHT_VM_CONFIGURATION See Also

Allows to set netfilter mode inside the CT.

Syntax
PRL_RESULT PrlVmCfg_SetNetfilterMode(
    PRL_HANDLE hVmCfg,
    PRL_NETFILTER_MODE nMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nMode
[in] The netfilter mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetNetfilterMode

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetNetworkRateList Function

PrlVmCfg_SetNetworkRateList Function
PHT_VM_CONFIGURATION See Also

Add the specified rates list to the Vm configuration.

Syntax
PRL_RESULT PrlVmCfg_SetNetworkRateList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hNetworkRateList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phNetworkRateList
A handle of type PHT_HANDLES_LIST contains the list of handle sof type PHT_NETWORK_RATE.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_GetNetworkShapingConfig

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetOfflineManagementEnabled Function

PrlVmCfg_SetOfflineManagementEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the offline management feature for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetOfflineManagementEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable the offline management feature. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetOfflineServices Function

PrlVmCfg_SetOfflineServices Function
PHT_VM_CONFIGURATION See Also

Allows to manually set offline services that will be available in the virtual machine offline management.

Syntax
PRL_RESULT PrlVmCfg_SetOfflineServices(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hOfflineServicesList
);
File

PrlApiVm.h

Parameters

hOfflineServicesList
A handle of type PHT_STRINGS_LIST containing the list of offline services. Specify PRL_INVALID_HANDLE to assign the default list of services.
hVmDev
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual machine specified.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetOfflineServices

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetOptimizeModifiersMode Function

PrlVmCfg_SetOptimizeModifiersMode Function
PHT_VM_CONFIGURATION

Sets optimize modifiers mode.

Syntax
PRL_RESULT PrlVmCfg_SetOptimizeModifiersMode(
    PRL_HANDLE hVm,
    PRL_OPTIMIZE_MODIFIERS_MODE nMode
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nMode
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetOsResInFullScrMode Function

PrlVmCfg_SetOsResInFullScrMode Function
PHT_VM_CONFIGURATION

Sets the virtual machine OS resolution in full screen mode option.

Syntax
PRL_RESULT PrlVmCfg_SetOsResInFullScrMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmOsResInFullScrMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmOsResInFullScrMode
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetOsTemplate Function

PrlVmCfg_SetOsTemplate Function
PHT_VM_CONFIGURATION

Specify the Virtual Machine Operation System template name which will be used to create new Parallels Virtuozzo Container.

Syntax
PRL_RESULT PrlVmCfg_SetOsTemplate(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sOsTemplate
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. sOsTemplate ostemplate name.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This option acceptable for Virtual Machine of PVT_CT only.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetOsVersion Function

PrlVmCfg_SetOsVersion Function
PHT_VM_CONFIGURATION

Sets the virtual machine guest OS version.

Syntax
PRL_RESULT PrlVmCfg_SetOsVersion(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmOsVersion
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmOsVersion
The guest OS version to set. The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetPauseWhenIdle Function

PrlVmCfg_SetPauseWhenIdle Function
PHT_VM_CONFIGURATION

Sets the virtual machine "Pause Idle VM" option.

Syntax
PRL_RESULT PrlVmCfg_SetPauseWhenIdle(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmPauseWhenIdle
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmPauseWhenIdle
The value to set. Specify PRL_TRUE to enable autopause when the VM becomes idle. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetPMUVirtualizationEnabled Function

PrlVmCfg_SetPMUVirtualizationEnabled Function
PHT_VM_CONFIGURATION

Disables or enables PMU virtualization.

Syntax
PRL_RESULT PrlVmCfg_SetPMUVirtualizationEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetProfile Function

PrlVmCfg_SetProfile Function
PHT_VM_CONFIGURATION

Set one of predefined VM profiles.

Syntax
PRL_RESULT PrlVmCfg_SetProfile(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_VIRTUAL_MACHINE_PROFILE nVmProfile
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nVmProfile
[in] A predefined settings profile. See the PRL_VIRTUAL_MACHINE_PROFILE enumeration for available options.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetRamHotplugEnabled Function

PrlVmCfg_SetRamHotplugEnabled Function
PHT_VM_CONFIGURATION

Sets the virtual machine memory (RAM) hotplug mode (enabled or disabled).

Syntax
PRL_RESULT PrlVmCfg_SetRamHotplugEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmRamHotplugEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmRamHotplugEnabled
The RAM hotplug mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetRamSize Function

PrlVmCfg_SetRamSize Function
PHT_VM_CONFIGURATION

Sets the virtual machine memory (RAM) size.

Syntax
PRL_RESULT PrlVmCfg_SetRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmRamSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRamSize
The RAM size to set, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetRateBound Function

PrlVmCfg_SetRateBound Function
PHT_VM_CONFIGURATION

Sets the ratebound flag.

Syntax
PRL_RESULT PrlVmCfg_SetRateBound(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
If this parameter is set to PRL_TRUE then Vm output bandwidth specified by rate will be bandwidth limit and guarantee. Otherwise rate sets Vm output bandwidth guarantee for traffic and limit is set by TOTALRATE in the network shaping Configuratio,.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetRelocateTaskBar Function

PrlVmCfg_SetRelocateTaskBar Function
PHT_VM_CONFIGURATION

Allows to enable or disable the Windows task bar relocation feature.

Syntax
PRL_RESULT PrlVmCfg_SetRelocateTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmRelocateTaskBar
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmRelocateTaskBar
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetResource Function

PrlVmCfg_SetResource Function
PHT_VM_CONFIGURATION

Sets barrier and limit for various user beancounters.

Syntax
PRL_RESULT PrlVmCfg_SetResource(
    PRL_HANDLE hVmCfg,
    PRL_CT_RESOURCE nResourceId,
    PRL_UINT64 nBarrirer,
    PRL_UINT64 nLimit
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. nResourceIdThe resource id (Only PCR_SWAPPAGES supported for now). nBarrirerThe resource barrier. nLimit The resource limit

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed. PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetScrResEnabled Function

PrlVmCfg_SetScrResEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the additional screen resolution support in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetScrResEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmScrResEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmScrResEnabled
Action type. Specify PRL_TRUE to enable the additional screen resolution support. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsScrResEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetSearchDomains Function

PrlVmCfg_SetSearchDomains Function
PHT_VM_CONFIGURATION See Also

Allows to manually set the global search domain list that will be assigned to the Virtuozzo Container.

Syntax
PRL_RESULT PrlVmCfg_SetSearchDomains(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSearchDomainsList
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSearchDomainsList
A handle of type PHT_STRINGS_LIST containing the list of search domains to be applied to the global network settings of the virtual machine operating system. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmCfg_GetSearchDomains

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetShareAllHostDisks Function

PrlVmCfg_SetShareAllHostDisks Function
PHT_VM_CONFIGURATION

Enables sharing of all host disks for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetShareAllHostDisks(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bShareAllHostDisks
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bShareAllHostDisks
The value to set. Specify PRL_TRUE to share all host disks to guest OS. Specify PRL_FALSE to not share them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this sign switched on all host disks will be shared into guest OS. Note that host sharing should be switched on to enable this functionality.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetShareClipboard Function

PrlVmCfg_SetShareClipboard Function
PHT_VM_CONFIGURATION

Enables or disables the clipboard sharing feature.

Syntax
PRL_RESULT PrlVmCfg_SetShareClipboard(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Set to PRL_TRUE to enabled clipboard sharing. Set to PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When clipboard sharing is enabled, you can copy and paste text and files from the host to a virtual machine or vise versa, or from one virtual machine to another. This feature requires Parallels Tools installed in a virtual machine.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedAppsGuestToHost Function

PrlVmCfg_SetSharedAppsGuestToHost Function
PHT_VM_CONFIGURATION

Lets to share the guest applications to host.

Syntax
PRL_RESULT PrlVmCfg_SetSharedAppsGuestToHost(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedAppsHostToGuest Function

PrlVmCfg_SetSharedAppsHostToGuest Function
PHT_VM_CONFIGURATION

Lets to share the host applications to guest.

Syntax
PRL_RESULT PrlVmCfg_SetSharedAppsHostToGuest(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedBluetoothEnabled Function

PrlVmCfg_SetSharedBluetoothEnabled Function
PHT_VM_CONFIGURATION

Disables or enables bluetooth camera.

Syntax
PRL_RESULT PrlVmCfg_SetSharedBluetoothEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedCameraEnabled Function

PrlVmCfg_SetSharedCameraEnabled Function
PHT_VM_CONFIGURATION

Disables or enables shared camera.

Syntax
PRL_RESULT PrlVmCfg_SetSharedCameraEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedCloudEnabled Function

PrlVmCfg_SetSharedCloudEnabled Function
PHT_VM_CONFIGURATION

Enables or disables shared cloud.

Syntax
PRL_RESULT PrlVmCfg_SetSharedCloudEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedProfileEnabled Function

PrlVmCfg_SetSharedProfileEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the Shared Profile feature in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetSharedProfileEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable the Shared Profile. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsSharedProfileEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetShareUserHomeDir Function

PrlVmCfg_SetShareUserHomeDir Function
PHT_VM_CONFIGURATION

Enables or disables sharing of the host user home directory in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetShareUserHomeDir(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bShareUserHomeDir
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bShareUserHomeDir
The value to set. Specify PRL_TRUE to share the host user home directory. Specify PRL_FALSE not to share it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this feature is enabled, the host user home directory will be shared in the virtual machine. Note that host sharing should be enabled to use this functionality. Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetShowTaskBar Function

PrlVmCfg_SetShowTaskBar Function
PHT_VM_CONFIGURATION

Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_SetShowTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmShowTaskBar
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmShowTaskBar
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetShowWindowsAppInDock Function

PrlVmCfg_SetShowWindowsAppInDock Function
PHT_VM_CONFIGURATION

Lets to set show windows applications folder in Dock enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetShowWindowsAppInDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartGuardEnabled Function

PrlVmCfg_SetSmartGuardEnabled Function
PHT_VM_CONFIGURATION See Also

Enables the SmartGuard feature in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetSmartGuardEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable SmartGuard. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is feature that allows to make automatic snapshots of a virtual machine at predefined time intervals. The feature requires Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetSmartGuardInterval

PrlVmCfg_SetSmartGuardMaxSnapshotsCount

PrlVmCfg_SetSmartGuardNotifyBeforeCreation

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetSmartGuardInterval Function

PrlVmCfg_SetSmartGuardInterval Function
PHT_VM_CONFIGURATION See Also

Sets the time interval at which snapshots are taken by SmartGuard.

Syntax
PRL_RESULT PrlVmCfg_SetSmartGuardInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nInterval
The time interval to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is feature that allows to make automatic snapshots of a virtual machine at predefined time intervals. This function allows to set the interval at which the automatic snapshots are taken.

See Also

PrlVmCfg_GetSmartGuardInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetSmartGuardMaxSnapshotsCount Function

PrlVmCfg_SetSmartGuardMaxSnapshotsCount Function
PHT_VM_CONFIGURATION

Sets the maximum snapshot count, a SmartGuard feature.

Syntax
PRL_RESULT PrlVmCfg_SetSmartGuardMaxSnapshotsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nMaxSnapshotsCount
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nMaxSnapshotsCount
Maximum snapshot count to set. The maximum allowable value is 100.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is a facility that allows to make automatic snapshots of a virtual machine at predefined time intervals. The snapshot count setting specifies how many snapshots taken by SmartGuard will be kept on the hard drive (maximum is 100). As soon as the maximum number is exceeded, the oldest snapshot is deleted.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartGuardNotifyBeforeCreation Function

PrlVmCfg_SetSmartGuardNotifyBeforeCreation Function
PHT_VM_CONFIGURATION See Also

Enables or disables notification of automatic snapshot creation, a SmartGuard feature.

Syntax
PRL_RESULT PrlVmCfg_SetSmartGuardNotifyBeforeCreation(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bNotifyBeforeCreation
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bNotifyBeforeCreation
Action type. Specify PRL_TRUE if you want the user to be notified. Specify PRL_FALSE if you want to create snapshots silently.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

SmartGuard is a facility that allows to make automatic snapshots of a virtual machine at predefined time intervals. By default, the snapshots are creating transparently to the user. If needed, Parallels Service can notify the user that a snapshot is about to be created. The user can then choose to proceed with snapshot creation or cancel it. This function allows to enabled or disable this feature. The notifications are received by the client via the PHT_EVENT handle received by a callback function. See PHT_EVENT and PrlEvent_CreateAnswerEvent for more information and code samples.

See Also

PrlVmCfg_IsSmartGuardNotifyBeforeCreation

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetSmartMountDVDsEnabled Function

PrlVmCfg_SetSmartMountDVDsEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the SmartMount CD/DVD drives.

Syntax
PRL_RESULT PrlVmCfg_SetSmartMountDVDsEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartMountEnabled Function

PrlVmCfg_SetSmartMountEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the SmartMount feature.

Syntax
PRL_RESULT PrlVmCfg_SetSmartMountEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartMountNetworkSharesEnabled Function

PrlVmCfg_SetSmartMountNetworkSharesEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the SmartMount network shares.

Syntax
PRL_RESULT PrlVmCfg_SetSmartMountNetworkSharesEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartMountRemovableDrivesEnabled Function

PrlVmCfg_SetSmartMountRemovableDrivesEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the SmartMount removable drives.

Syntax
PRL_RESULT PrlVmCfg_SetSmartMountRemovableDrivesEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartMouseEnabled Function

PrlVmCfg_SetSmartMouseEnabled Function
PHT_VM_CONFIGURATION

Disables or enables smart mouse.

Syntax
PRL_RESULT PrlVmCfg_SetSmartMouseEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetStartInDetachedWindowEnabled Function

PrlVmCfg_SetStartInDetachedWindowEnabled Function
PHT_VM_CONFIGURATION

Disables or enables start in detached window.

Syntax
PRL_RESULT PrlVmCfg_SetStartInDetachedWindowEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetStartLoginMode Function

PrlVmCfg_SetStartLoginMode Function
PHT_VM_CONFIGURATION

Allows to set the automatic startup login mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetStartLoginMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_START_LOGIN_MODE nVmStartLoginMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmStartLoginMode
Automatic startup login mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetStartUserCreds Function

PrlVmCfg_SetStartUserCreds Function
PHT_VM_CONFIGURATION

Allows to set the automatic startup user login and password for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetStartUserCreds(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sStartUserLogin,
    PRL_CONST_STR sPassword
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sStartUserLogin
User login. Must be a a UTF-8 encoded, null-terminated string.
sPassword
User password. Must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetStickyMouseEnabled Function

PrlVmCfg_SetStickyMouseEnabled Function
PHT_VM_CONFIGURATION

Disables or enables sticky mouse.

Syntax
PRL_RESULT PrlVmCfg_SetStickyMouseEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSupportUsb30Enabled Function

PrlVmCfg_SetSupportUsb30Enabled Function
PHT_VM_CONFIGURATION

Sets support status USB 3.0.

Syntax
PRL_RESULT PrlVmCfg_SetSupportUsb30Enabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSwitchOffAeroEnabled Function

PrlVmCfg_SetSwitchOffAeroEnabled Function
PHT_VM_CONFIGURATION

Disables or enables switching off aero.

Syntax
PRL_RESULT PrlVmCfg_SetSwitchOffAeroEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSwitchOffWindowsLogoEnabled Function

PrlVmCfg_SetSwitchOffWindowsLogoEnabled Function
PHT_VM_CONFIGURATION

Disables or enables Windows logo.

Syntax
PRL_RESULT PrlVmCfg_SetSwitchOffWindowsLogoEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled Function

PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled Function
PHT_VM_CONFIGURATION

Disables or enables switching to full screen on demand.

Syntax
PRL_RESULT PrlVmCfg_SetSwitchToFullscreenOnDemandEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSyncDefaultPrinter Function

PrlVmCfg_SetSyncDefaultPrinter Function
PHT_VM_CONFIGURATION

Sets synchronization default printer option.

Syntax
PRL_RESULT PrlVmCfg_SetSyncDefaultPrinter(
    PRL_HANDLE hVm,
    PRL_BOOL bSync
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bSync
If this parameter is set to PRL_TRUE then VM synchronizes default printer with host one. Otherwise VM does not synchronize it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetSystemFlags Function

PrlVmCfg_SetSystemFlags Function
PHT_VM_CONFIGURATION

Sets the virtual machine system flags.

Syntax
PRL_RESULT PrlVmCfg_SetSystemFlags(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmSystemFlags
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
New virtual machine system flags, a UTF-8 encoded null terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetTemplateSign Function

PrlVmCfg_SetTemplateSign Function
PHT_VM_CONFIGURATION

Allows to modify a regular virtual machine to become a template, and vise versa.

Syntax
PRL_RESULT PrlVmCfg_SetTemplateSign(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmIsTemplate
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmIsTemplate
The value to set. Specify PRL_TRUE to make the virtual machine a template. Specify PRL_FALSE to switch a template to a regular virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A template is very similar to a regular virtual machine with the major exception being it cannot be started. Templates are used to create new virtual machines as exact copies of them. To create a virtual machine from a template, use the PrlVm_Clone function specifying the template as the source.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetTimeSynchronizationEnabled Function

PrlVmCfg_SetTimeSynchronizationEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the time synchronization feature in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetTimeSynchronizationEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

You can synchronize the time in a virtual machine with the time in the host OS. To do so, the time synchronization feature must be enabled using the PrlVmCfg_SetTimeSynchronizationEnabled function. The time will be synchronized at predefined time intervals. To set the time interval, use the PrlVmCfg_SetSmartGuardInterval function. This feature requires Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetTimeSyncSmartModeEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetTimeSyncInterval Function

PrlVmCfg_SetTimeSyncInterval Function
PHT_VM_CONFIGURATION See Also

Allows to set the time interval at which the time in the virtual machine will be synchronized with the time in the host OS.

Syntax
PRL_RESULT PrlVmCfg_SetTimeSyncInterval(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nTimeSyncInterval
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nTimeSyncInterval
Setting interval in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Before this function can be used, the time synchronization feature must be enabled in the virtual machine using the PrlVmCfg_SetTimeSynchronizationEnabled function.

See Also

PrlVmCfg_GetTimeSyncInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetTimeSyncSmartModeEnabled Function

PrlVmCfg_SetTimeSyncSmartModeEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the smart time-synchronization mode in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetTimeSyncSmartModeEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

You can automatically synchronize the time in a virtual machine with the time in the OS by using the PrlVmCfg_SetTimeSynchronizationEnabled function. That functionality will keep the time in the virtual machine in a perfect synch with the time in the host OS. You can also set different time zones in the host and the guest OS and still synchronize the time. To do so, use the PrlVmCfg_SetTimeSyncSmartModeEnabled function. This feature requires Parallels Tools installed in a virtual machine.

See Also

PrlVmCfg_SetTimeSynchronizationEnabled

PrlVmCfg_SetTimeSyncInterval

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetToolsAutoUpdateEnabled Function

PrlVmCfg_SetToolsAutoUpdateEnabled Function
PHT_VM_CONFIGURATION

Enables or disables the Parallels Tools AutoUpdate feature for a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetToolsAutoUpdateEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable the AutoUpdate feature. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUnattendedInstallEdition Function

PrlVmCfg_SetUnattendedInstallEdition Function
PHT_VM_CONFIGURATION

Sets edition for unattended installation.

Syntax
PRL_RESULT PrlVmCfg_SetUnattendedInstallEdition(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sEdition
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sEdition
The locale to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUnattendedInstallLocale Function

PrlVmCfg_SetUnattendedInstallLocale Function
PHT_VM_CONFIGURATION

Sets locale for unattended installation.

Syntax
PRL_RESULT PrlVmCfg_SetUnattendedInstallLocale(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sLocale
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sLocale
The locale to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUndoDisksMode Function

PrlVmCfg_SetUndoDisksMode Function
PHT_VM_CONFIGURATION

Sets the undo-disks mode for the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetUndoDisksMode(
    PRL_HANDLE hVmCfg,
    PRL_UNDO_DISKS_MODE nUndoDisksMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nUndoDisksMode
The undo disks mode option to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseDefaultAnswers Function

PrlVmCfg_SetUseDefaultAnswers Function
PHT_VM_CONFIGURATION See Also

Enables the use default answers mechanism in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetUseDefaultAnswers(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bUseDefaultAnswers
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Action type. Specify PRL_TRUE to enable mechanism. In this case system won't passing questions from virtual machine to client side and answering on them automatically. Specify PRL_FALSE to disable mechanism and processing virtual machine questions explicitly.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsUseDefaultAnswers

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetUseDesktop Function

PrlVmCfg_SetUseDesktop Function
PHT_VM_CONFIGURATION

Enables or disables the "undo-desktop" feature in the shared profile.

Syntax
PRL_RESULT PrlVmCfg_SetUseDesktop(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseDocuments Function

PrlVmCfg_SetUseDocuments Function
PHT_VM_CONFIGURATION

Lets to set use documents in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseDocuments(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseDownloads Function

PrlVmCfg_SetUseDownloads Function
PHT_VM_CONFIGURATION

Lets to set use downloads in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseDownloads(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseHostPrinters Function

PrlVmCfg_SetUseHostPrinters Function
PHT_VM_CONFIGURATION

Sets use host printers option.

Syntax
PRL_RESULT PrlVmCfg_SetUseHostPrinters(
    PRL_HANDLE hVm,
    PRL_BOOL bUse
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bUse
If this parameter is set to PRL_TRUE then VM uses host printers. Otherwise VM uses virtual parallel port devices as printers.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseMovies Function

PrlVmCfg_SetUseMovies Function
PHT_VM_CONFIGURATION

Lets to set use movies in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseMovies(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUseMusic Function

PrlVmCfg_SetUseMusic Function
PHT_VM_CONFIGURATION

Lets to set use music in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseMusic(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUsePictures Function

PrlVmCfg_SetUsePictures Function
PHT_VM_CONFIGURATION

Lets to set use pictures in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUsePictures(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUserDefinedSharedFoldersEnabled Function

PrlVmCfg_SetUserDefinedSharedFoldersEnabled Function
PHT_VM_CONFIGURATION

Enables or disables user-defined shared folders.

Syntax
PRL_RESULT PrlVmCfg_SetUserDefinedSharedFoldersEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable shared folder. Specify PRL_FALSE to disable them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetUuid Function

PrlVmCfg_SetUuid Function
PHT_VM_CONFIGURATION

Sets the virtual machine UUID (universally unique ID).

Syntax
PRL_RESULT PrlVmCfg_SetUuid(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmUuid
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmUuid
The UUID to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A UUID is assigned to a virtual machine automatically when it is created. Before using this function, make sure that you understand what UUID is, and that you have a good reason for changing it.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVerticalSynchronizationEnabled Function

PrlVmCfg_SetVerticalSynchronizationEnabled Function
PHT_VM_CONFIGURATION

Disables or enables vertical synchronization video mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetVerticalSynchronizationEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bEnabled
Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_VIRTUAL_MACHINE handle or NULL pointer to the output buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVideoRamSize Function

PrlVmCfg_SetVideoRamSize Function
PHT_VM_CONFIGURATION

Sets the virtual machine video memory size.

Syntax
PRL_RESULT PrlVmCfg_SetVideoRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmVideoRamSize
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmVideoRamSize
The new memory size, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVirtualLinksEnabled Function

PrlVmCfg_SetVirtualLinksEnabled Function
PHT_VM_CONFIGURATION See Also

Enables or disables the Virtual Links feature in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetVirtualLinksEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
The value to set. Specify PRL_TRUE to enable the Shared Profile. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_IsVirtualLinksEnabled

Links
PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetVmType Function

PrlVmCfg_SetVmType Function
PHT_VM_CONFIGURATION

Specify the Virtual Machine type on create action.

Syntax
PRL_RESULT PrlVmCfg_SetVmType(
    PRL_HANDLE hVmCfg,
    PRL_VM_TYPE nType
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. nType Virtuam Machine type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCHostName Function

PrlVmCfg_SetVNCHostName Function
PHT_VM_CONFIGURATION

Sets the virtual machine VNC host name.

Syntax
PRL_RESULT PrlVmCfg_SetVNCHostName(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmRemoteDisplayHostName
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmRemoteDisplayHostName
The new VNC host name. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCMode Function

PrlVmCfg_SetVNCMode Function
PHT_VM_CONFIGURATION

Sets the virtual machine VNC mode.

Syntax
PRL_RESULT PrlVmCfg_SetVNCMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_REMOTE_DISPLAY_MODE nVmRemoteDisplayMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRemoteDisplayMode
The VNC mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCPassword Function

PrlVmCfg_SetVNCPassword Function
PHT_VM_CONFIGURATION

Sets the virtual machine VNC password.

Syntax
PRL_RESULT PrlVmCfg_SetVNCPassword(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmRemoteDisplayPassword
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmRemoteDisplayPassword
The VNC password to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCPort Function

PrlVmCfg_SetVNCPort Function
PHT_VM_CONFIGURATION

Sets the virtual machine VNC port number.

Syntax
PRL_RESULT PrlVmCfg_SetVNCPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmRemoteDisplayPort
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRemoteDisplayPort
The port number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetWindowMode Function

PrlVmCfg_SetWindowMode Function
PHT_VM_CONFIGURATION

Sets the virtual machine window mode.

Syntax
PRL_RESULT PrlVmCfg_SetWindowMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_WINDOW_MODE nVmWindowMode
);
File

PrlApiVm.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmWindowMode
The window mode to set. See the PRL_VM_WINDOW_MODE enumeration for the list of modes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmCfg_SetWinSystrayInMacMenuEnabled Function

PrlVmCfg_SetWinSystrayInMacMenuEnabled Function
PHT_VM_CONFIGURATION

Disables or enables Windows systray in Mac menu.

Syntax
PRL_RESULT PrlVmCfg_SetWinSystrayInMacMenuEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL bEnable
);
File

PrlApiVm.h

Parameters

hVm
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnable
[in] Setting value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_CONFIGURATION


PrlVmDev_Connect Function

PrlVmDev_Connect Function
Virtual Device Functions

The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.

Syntax
PRL_HANDLE PrlVmDev_Connect(
    PRL_HANDLE hVmDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_CopyImage Function

PrlVmDev_CopyImage Function
Virtual Device Functions

Copies a virtual device image to another custom location.

Syntax
PRL_HANDLE PrlVmDev_CopyImage(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewImageName,
    PRL_CONST_STR sTargetPath,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewImageName
New image short name.
sTargetPath
New custom location.
nFlags
Reserved

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_Create Function

PrlVmDev_Create Function
Virtual Device Functions

Creates a new virtual device handle not bound to any virtual machine.

Syntax
PRL_RESULT PrlVmDev_Create(
    PRL_DEVICE_TYPE nDeviceType,
    PRL_HANDLE_PTR phVmDevice
);
File

PrlApiVm.h

Parameters

nDeviceType
The type of handle to create.
phVmDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is necessary to call PrlHandle_Free after the handle usage.

Links
Virtual Device Functions


PrlVmDev_CreateImage Function

PrlVmDev_CreateImage Function
Virtual Device Functions

Physically creates a virtual device image on the host.

Syntax
PRL_HANDLE PrlVmDev_CreateImage(
    PRL_HANDLE hVmDev,
    PRL_BOOL bRecreateIsAllowed,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
bRecreateIsAllowed
Specifies wether the existing image should be replaced. If set to PRL_TRUE, the existing image will be replaced. If set to PRL_FALSE, the operation will be aborted if image already exists.
bNonInteractiveMode
Specifies wether the operation should be carried out in interactive mode (where the Parallels Service may ask questions and the client will have to send answers). If set to PRL_TRUE, non-interactive mode will be used (the Parallels Service will make decisions on its own). If set to PRL_FALSE, interactive mode will be used.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_Disconnect Function

PrlVmDev_Disconnect Function
Virtual Device Functions

Allows to disconnect a device while the virtual machine is running.

Syntax
PRL_HANDLE PrlVmDev_Disconnect(
    PRL_HANDLE hVmDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetDescription Function

PrlVmDev_GetDescription Function
Virtual Device Functions See Also

Returns the description of a specified virtual device.

Syntax
PRL_RESULT PrlVmDev_GetDescription(
    PRL_HANDLE hVmDev,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The pnDescriptionBufLength parameter will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDev_SetDescription

Links
Virtual Device Functions, See Also


PrlVmDev_GetEmulatedType Function

PrlVmDev_GetEmulatedType Function
Virtual Device Functions

Returns the virtual device emulation type.

Syntax
PRL_RESULT PrlVmDev_GetEmulatedType(
    PRL_HANDLE hVmDev,
    PRL_VM_DEV_EMULATION_TYPE_PTR pnEmulatedType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
pnEmulatedType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Emulation types are defined in the PRL_VM_DEV_EMULATION_TYPE enumeration. The following describes emulation types used for different types of virtual devices:

  • PHT_VIRTUAL_DEV_FLOPPY: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_HARD_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_OPTICAL_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_SERIAL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for socket mode).
  • PHT_VIRTUAL_DEV_PARALLEL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for printer mode).
  • PHT_VIRTUAL_DEV_NET_ADAPTER: PDT_USE_REAL_DEVICE (host-only network), PDT_USE_IMAGE_FILE (shared network), PDT_USE_OUTPUT_FILE (bridget ethernet)
  • PHT_VIRTUAL_DEV_SOUND: PDT_USE_REAL_DEVICE (AC'97), PDT_USE_IMAGE_FILE (Creative).
  • PHT_VIRTUAL_DEV_USB_DEVICE: PDT_USE_REAL_DEVICE
Links
Virtual Device Functions


PrlVmDev_GetFriendlyName Function

PrlVmDev_GetFriendlyName Function
Virtual Device Functions

Returns the virtual device user friendly name.

Syntax
PRL_RESULT PrlVmDev_GetFriendlyName(
    PRL_HANDLE hVmDev,
    PRL_STR sFriendlyName,
    PRL_UINT32_PTR pnFriendlyNameBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sFriendlyName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnFriendlyNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetIfaceType Function

PrlVmDev_GetIfaceType Function
Virtual Device Functions

Returns the virtual device interface type (IDE or SCSI).

Syntax
PRL_RESULT PrlVmDev_GetIfaceType(
    PRL_HANDLE hVmDev,
    PRL_MASS_STORAGE_INTERFACE_TYPE_PTR pnIfaceType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
pnIfaceType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetImagePath Function

PrlVmDev_GetImagePath Function
Virtual Device Functions

Returns virtual device image path.

Syntax
PRL_RESULT PrlVmDev_GetImagePath(
    PRL_HANDLE hVmDev,
    PRL_STR sImagePath,
    PRL_UINT32_PTR pnImagePathBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
sImagePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnImagePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetIndex Function

PrlVmDev_GetIndex Function
Virtual Device Functions

Returns an index identifying the virtual device.

Syntax
PRL_RESULT PrlVmDev_GetIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT, PHT_VIRTUAL_DEV_NET_ADAPTER.
pnIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetOutputFile Function

PrlVmDev_GetOutputFile Function
Virtual Device Functions

Returns the virtual device output file.

Syntax
PRL_RESULT PrlVmDev_GetOutputFile(
    PRL_HANDLE hVmDev,
    PRL_STR sOutputFile,
    PRL_UINT32_PTR pnOutputFileBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT.
sOutputFile
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOutputFileBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetStackIndex Function

PrlVmDev_GetStackIndex Function
Virtual Device Functions

Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).

Syntax
PRL_RESULT PrlVmDev_GetStackIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnStackIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI, PHT_VIRTUAL_DEV_GENERIC_PCI.
pnStackIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetSubType Function

PrlVmDev_GetSubType Function
Virtual Device Functions

Returns the virtual device subtype.

Syntax
PRL_RESULT PrlVmDev_GetSubType(
    PRL_HANDLE hVmDev,
    PRL_CLUSTERED_DEVICE_SUBTYPE_PTR pnSubType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
pnSubType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetSysName Function

PrlVmDev_GetSysName Function
Virtual Device Functions

Returns the virtual device system name.

Syntax
PRL_RESULT PrlVmDev_GetSysName(
    PRL_HANDLE hVmDev,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sSysName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_GetType Function

PrlVmDev_GetType Function
Virtual Device Functions

Returns the type of the specified device.

Syntax
PRL_RESULT PrlVmDev_GetType(
    PRL_HANDLE hVmDev,
    PRL_DEVICE_TYPE_PTR pnDeviceType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
pnDeviceType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_IsConnected Function

PrlVmDev_IsConnected Function
Virtual Device Functions

Checks if the specified virtual device is connected.

Syntax
PRL_RESULT PrlVmDev_IsConnected(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbConnected
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
pbConnected
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid device handle or non valid (NULL) pointer to storing result, or handle of already removed VM device was passed. PRL_ERR_SUCCESS - operation completed successfully

Links
Virtual Device Functions


PrlVmDev_IsEnabled Function

PrlVmDev_IsEnabled Function
Virtual Device Functions

Determines if the specified device is enabled.

Syntax
PRL_RESULT PrlVmDev_IsEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_IsPassthrough Function

PrlVmDev_IsPassthrough Function
Virtual Device Functions

Determines if the passthrough mode is enabled for the specified mass storage device.

Syntax
PRL_RESULT PrlVmDev_IsPassthrough(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbPassthrough
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the device. This can be one of the following: PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_HARD_DISK.
pbPassthrough
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the passthrough mode is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_IsRemote Function

PrlVmDev_IsRemote Function
Virtual Device Functions

Determines if the specified virtual device is a remote device.

Syntax
PRL_RESULT PrlVmDev_IsRemote(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbRemote
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
pbRemote
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that this is a remote device. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_Remove Function

PrlVmDev_Remove Function
Virtual Device Functions

Removes the specified virtual device handle from the parent virtual machine list.

Syntax
PRL_RESULT PrlVmDev_Remove(
    PRL_HANDLE hVmDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_ResizeImage Function

PrlVmDev_ResizeImage Function
Virtual Device Functions

Resize a virtual device image.

Syntax
PRL_HANDLE PrlVmDev_ResizeImage(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nNewSize,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.

nNewSize
Specifies a new image size in Mbytes.

nFlags
bitset of (PRIF_DISK_INFO, PRIF_RESIZE_LAST_PARTITION). Also PACF_NON_INTERACTIVE_MODE can be used in order to specify non interactive session working mode (remote side won't ask questions during operation progress in this case).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetConnected Function

PrlVmDev_SetConnected Function
Virtual Device Functions

Connects the specified virtual device.

Syntax
PRL_RESULT PrlVmDev_SetConnected(
    PRL_HANDLE hVmDev,
    PRL_BOOL bConnected
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
bConnected
Value to set. PRL_TRUE to connect the device. PRL_FALSE to disconnect it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetDefaultStackIndex Function

PrlVmDev_SetDefaultStackIndex Function
Virtual Device Functions

Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).

Syntax
PRL_RESULT PrlVmDev_SetDefaultStackIndex(
    PRL_HANDLE hVmDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI or PHT_VIRTUAL_DEV_GENERIC_PCI.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS - there are no free slots left.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetDescription Function

PrlVmDev_SetDescription Function
Virtual Device Functions See Also

Sets the description for a specified virtual device.

Syntax
PRL_RESULT PrlVmDev_SetDescription(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewDescription
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewDescription
The new description to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDev_GetDescription

Links
Virtual Device Functions, See Also


PrlVmDev_SetEmulatedType Function

PrlVmDev_SetEmulatedType Function
Virtual Device Functions

Sets the specified virtual device emulation type.

Syntax
PRL_RESULT PrlVmDev_SetEmulatedType(
    PRL_HANDLE hVmDev,
    PRL_VM_DEV_EMULATION_TYPE nEmulatedType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
nEmulatedType
The emulation type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Emulation types are defined in the PRL_VM_DEV_EMULATION_TYPE enumeration. The following describes emulation types used for different types of virtual devices:

  • PHT_VIRTUAL_DEV_FLOPPY: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_HARD_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_OPTICAL_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_SERIAL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for socket mode).
  • PHT_VIRTUAL_DEV_PARALLEL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for printer mode).
  • PHT_VIRTUAL_DEV_NET_ADAPTER: PDT_USE_REAL_DEVICE (host only network), PDT_USE_IMAGE_FILE (shared network). PDT_USE_OUTPUT_FILE (bridget ethernet)
  • PHT_VIRTUAL_DEV_SOUND: PDT_USE_REAL_DEVICE (AC'97), PDT_USE_IMAGE_FILE (Creative).
  • PHT_VIRTUAL_DEV_USB_DEVICE: PDT_USE_REAL_DEVICE
Links
Virtual Device Functions


PrlVmDev_SetEnabled Function

PrlVmDev_SetEnabled Function
Virtual Device Functions

Enables the specified virtual device..

Syntax
PRL_RESULT PrlVmDev_SetEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
bEnabled
Specify PRL_TRUE to enable the device. Specified PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetFriendlyName Function

PrlVmDev_SetFriendlyName Function
Virtual Device Functions

Sets virtual device user-friendly name.

Syntax
PRL_RESULT PrlVmDev_SetFriendlyName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewFriendlyName
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewFriendlyName
The user-friendly name to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetIfaceType Function

PrlVmDev_SetIfaceType Function
Virtual Device Functions

Sets the virtual device interface type (IDE or SCSI).

Syntax
PRL_RESULT PrlVmDev_SetIfaceType(
    PRL_HANDLE hVmDev,
    PRL_MASS_STORAGE_INTERFACE_TYPE nIfaceType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI.
nIfaceType
The interface type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or PMS_IDE_DEVICE for PHT_VIRTUAL_DEV_GENERIC_SCSI handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetImagePath Function

PrlVmDev_SetImagePath Function
Virtual Device Functions

Sets the virtual device image path.

Syntax
PRL_RESULT PrlVmDev_SetImagePath(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewImagePath
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
sNewImagePath
The image path to set. The value must be a UTF-8 encoded, null-terminated string

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetIndex Function

PrlVmDev_SetIndex Function
Virtual Device Functions

Sets an index identifying the virtual device.

Syntax
PRL_RESULT PrlVmDev_SetIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT, PHT_VIRTUAL_DEV_NET_ADAPTER.
nIndex
The new index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetOutputFile Function

PrlVmDev_SetOutputFile Function
Virtual Device Functions

Sets the virtual device output file.

Syntax
PRL_RESULT PrlVmDev_SetOutputFile(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewOutputFile
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT.
sNewOutputFile
Name and path of the new output file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetPassthrough Function

PrlVmDev_SetPassthrough Function
Virtual Device Functions

Enables the passthrough mode for the specified mass storage device (optical ot hard disk).

Syntax
PRL_RESULT PrlVmDev_SetPassthrough(
    PRL_HANDLE hVmDev,
    PRL_BOOL bPassthrough
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the device. This can be one of the following: PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_HARD_DISK.
bPassthrough
Specify PRL_TRUE to enable the passthrough mode. Specify PRL_FALSE to disab;e it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetRemote Function

PrlVmDev_SetRemote Function
Virtual Device Functions

Changes the "remote" flag for the specified device.

Syntax
PRL_RESULT PrlVmDev_SetRemote(
    PRL_HANDLE hVmDev,
    PRL_BOOL bRemote
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
bRemote
Specify PRL_TRUE to make the device appear as remote. Specify PRL_FALSE to make the device appear as local.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid virtual device handle or handle of already removed VM device was passed PRL_ERR_SUCCESS - operation completed successfully

Links
Virtual Device Functions


PrlVmDev_SetStackIndex Function

PrlVmDev_SetStackIndex Function
Virtual Device Functions

Sets the virtual device stack index (position at the IDE or SCSI controller bus).

Syntax
PRL_RESULT PrlVmDev_SetStackIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nStackIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI, PHT_VIRTUAL_DEV_GENERIC_PCI.
nStackIndex
A new index to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetSubType Function

PrlVmDev_SetSubType Function
Virtual Device Functions

Sets the virtual device subtype.

Syntax
PRL_RESULT PrlVmDev_SetSubType(
    PRL_HANDLE hVmDev,
    PRL_CLUSTERED_DEVICE_SUBTYPE nSubType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI.
nSubType
The subtype to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDev_SetSysName Function

PrlVmDev_SetSysName Function
Virtual Device Functions

Sets virtual device system name.

Syntax
PRL_RESULT PrlVmDev_SetSysName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewSysName
);
File

PrlApiVm.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewSysName
The new system name to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
Virtual Device Functions


PrlVmDevHd_AddPartition Function

PrlVmDevHd_AddPartition Function
PHT_VIRTUAL_DEV_HARD_DISK

Assigns a boot camp partition to the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_AddPartition(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phPartition
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
phPartition
[out] A pointer to a variable that receives a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing the new partition information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine based on a boot camp partition, this function must be used to obtain a handle of type PHT_VIRTUAL_DEV_HD_PARTITION. The handle can then be used to set the system name of the boot camp partition that you would like to use.

Links
PHT_VIRTUAL_DEV_HARD_DISK


PrlVmDevHd_CheckPassword Function

PrlVmDevHd_CheckPassword Function
PHT_VIRTUAL_DEV_HARD_DISK

Checks whether specified for encrypted virtual hard disk password matched to the current one.

Syntax
PRL_HANDLE PrlVmDevHd_CheckPassword(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk object.
nFlags
Bitset of flags - reserved parameter for further purposes.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - can be returned in follow cases: invalid handle (NULL or not of PHT_VIRTUAL_DEV_HARD_DISK type) was passed; virtual hard disk device object isn't bound to any VM object (was created with PrlVmDev_Create call for example); PrlVmDevHd_SetPassword wasn't called before this call - nothing to check then.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_HARD_DISK


PrlVmDevHd_GetDiskSize Function

PrlVmDevHd_GetDiskSize Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Returns the hard disk size.

Syntax
PRL_RESULT PrlVmDevHd_GetDiskSize(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnDiskSize
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnDiskSize
[out] Pointer to a variable that receives the hard disk size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_SetDiskSize

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetDiskType Function

PrlVmDevHd_GetDiskType Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Returns the hard disk type.

Syntax
PRL_RESULT PrlVmDevHd_GetDiskType(
    PRL_HANDLE hVmDev,
    PRL_HARD_DISK_INTERNAL_FORMAT_PTR pnDiskType
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnDiskType
[out] Pointer to a variable that receives the disk type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual hard disk can be one of two types: expanding or fixed. The size of an expanding hard disk is expanded dynamically up to a predefined limit. The size of a fixed hard disk is set to the specified value at the time of creation.

See Also

PrlVmDevHd_SetDiskType

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetMountPoint Function

PrlVmDevHd_GetMountPoint Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Returns the mount point of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetMountPoint(
    PRL_HANDLE hVmDev,
    PRL_STR sMountPoint,
    PRL_UINT32_PTR pnMountPointBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
sMountPoint
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnMountPointBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_SetMountPoint,

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetPartition Function

PrlVmDevHd_GetPartition Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetPartition(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPartition
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nIndex
An index identifying the partition instance (beginning with 0). To get the number of partitions of the virtual hard disk, use the PrlVmDevHd_GetPartitionsCount function.
phPartition
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_GetPartitionsCount

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetPartitionsCount Function

PrlVmDevHd_GetPartitionsCount Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Determines the number of partitions on the virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetPartitionsCount(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnPartitionsCount
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnPartitionsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_GetPartition

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetSizeOnDisk Function

PrlVmDevHd_GetSizeOnDisk Function
PHT_VIRTUAL_DEV_HARD_DISK

Returns the size of the occupied space on the hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetSizeOnDisk(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnOnDiskSize
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnOnDiskSize
[out] Pointer to a variable that receives the size. The size is specified in bytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_HARD_DISK


PrlVmDevHd_GetStorageURL Function

PrlVmDevHd_GetStorageURL Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Return custom storage URL.

Syntax
PRL_RESULT PrlVmDevHd_GetStorageURL(
    PRL_HANDLE hVmDev,
    PRL_STR sURL,
    PRL_UINT32_PTR pnURLBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
sURL
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnURLBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_SetStorageURL

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_IsAutoCompressEnabled Function

PrlVmDevHd_IsAutoCompressEnabled Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Returns the auto compress flag of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_IsAutoCompressEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

(for Virtuozzo Container only)

See Also

PrlVmDevHd_IsAutoCompressEnabled,

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_IsEncrypted Function

PrlVmDevHd_IsEncrypted Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Returns sign whether virtual hard disk device is encrypted.

Syntax
PRL_RESULT PrlVmDevHd_IsEncrypted(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbIsEncrypted
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pbIsEncrypted
[out] buffer to retrieve result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

You can use PrlVmDev_UpdateInfo call in order to request information about virtual hard disk device remotely.

See Also

PrlVmDevHd_CheckPassword PrlVmDev_UpdateInfo PrlVm_Commit

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_IsSplitted Function

PrlVmDevHd_IsSplitted Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Determines if the virtual hard disk is split into multiple files.

Syntax
PRL_RESULT PrlVmDevHd_IsSplitted(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbSplitted
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pbSplitted
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that the disk is split into multiple files. PRL_FALSE indicates that a single file is used.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When adding a virtual hard disk to a virtual machine, you have an option of splitting the disk into multiple files. By using this function, you can determine whether this options was used or not.

See Also

PrlVmDevHd_SetSplitted

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetAutoCompressEnabled Function

PrlVmDevHd_SetAutoCompressEnabled Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Sets the auto compress sign flag of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetAutoCompressEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
bEnabled
Specify PRL_FALSE to disable auto compress

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

(for Virtuozzo Container only)

See Also

PrlVmDevHd_GetMountPoint

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetDiskSize Function

PrlVmDevHd_SetDiskSize Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Sets the size of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetDiskSize(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nDiskSize
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nDiskSize
The new size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when adding a new virtual hard disk or when modifying the size of an existing disk.

See Also

PrlVmDevHd_GetDiskSize

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetDiskType Function

PrlVmDevHd_SetDiskType Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Sets the type of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetDiskType(
    PRL_HANDLE hVmDev,
    PRL_HARD_DISK_INTERNAL_FORMAT nDiskType
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nDiskType
The hard disk type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual hard disk can be one of the two types: expanding or fixed-size. The size of an expanding hard disk is expanded dynamically up to a predefined limit. The size of a fixed-size hard disk is set to the specified value at the time of creation. The function can be used with both new and existing virtual hard disks.

See Also

PrlVmDevHd_GetDiskType

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetMountPoint Function

PrlVmDevHd_SetMountPoint Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Sets the mount point of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetMountPoint(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sMountPoint
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
sMountPoint
Mount point path

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

(for Virtuozzo Container only)

See Also

PrlVmDevHd_GetMountPoint

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetPassword Function

PrlVmDevHd_SetPassword Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Lets to setup password for virtual hard disk device in case if last one is encrypted (this password uses then at calls PrlVmDevHd_CheckPassword and PrlVm_Commit)

Syntax
PRL_RESULT PrlVmDevHd_SetPassword(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sPassword
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
sPasswd
[in] Setting password - an UTF-8 encoded string with null 0 symbol at the end. In case to specify an empty password just pass 0 or "".

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_CheckPassword PrlVm_Commit

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetSplitted Function

PrlVmDevHd_SetSplitted Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.

Syntax
PRL_RESULT PrlVmDevHd_SetSplitted(
    PRL_HANDLE hVmDev,
    PRL_BOOL bSplitted
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
bSplitted
Hard disk file option. Specify PRL_TRUE to split the disk into multiple files. Specify PRL_FALSE to use a single file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_IsSplitted

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetStorageURL Function

PrlVmDevHd_SetStorageURL Function
PHT_VIRTUAL_DEV_HARD_DISK See Also

Set custom storage URL.

Syntax
PRL_RESULT PrlVmDevHd_SetStorageURL(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sURL
);
File

PrlApiVm.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
sURL
[in] Storage URL - an UTF-8 encoded string with null '0' symbol at the end. The following URL types are supported: "backup://backup_server/backup_UUID/disk_number" - use disk backup, identified by "backup_UUID/disk_number" from server "backup_server".

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A storage URL is required when actual data of a virtual hard disk is accessed using some external tool or protocol. For example, a VM disk backup, which resides on a remote server, could be attached as a data source using the following storage URL: "backup://backup_server/backup_UUID/disk_number". Here, instead of reading data from the locally stored disk image, a VM will connect to the "backup_server" and read data from the "backup_UUID/disk_number" backup.

See Also

PrlVmDevHd_GetStorageURL

Links
PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHdPart_GetSysName Function

PrlVmDevHdPart_GetSysName Function
PHT_VIRTUAL_DEV_HD_PARTITION See Also

Returns the system name of the specified disk partition.

Syntax
PRL_RESULT PrlVmDevHdPart_GetSysName(
    PRL_HANDLE hPartition,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApiVm.h

Parameters

hPartition
A handle of type PHT_VIRTUAL_DEV_HD_PARTITION identifying the disk partition.
sSysName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHdPart_SetSysName

Links
PHT_VIRTUAL_DEV_HD_PARTITION, See Also


PrlVmDevHdPart_Remove Function

PrlVmDevHdPart_Remove Function
PHT_VIRTUAL_DEV_HD_PARTITION

Removes the specified partition handle from the virtual hard disk list.

Syntax
PRL_RESULT PrlVmDevHdPart_Remove(
    PRL_HANDLE hPartition
);
File

PrlApiVm.h

Parameters

hPartition
A handle identifying the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_HD_PARTITION


PrlVmDevHdPart_SetSysName Function

PrlVmDevHdPart_SetSysName Function
PHT_VIRTUAL_DEV_HD_PARTITION See Also

Sets system name for the specified disk partition.

Syntax
PRL_RESULT PrlVmDevHdPart_SetSysName(
    PRL_HANDLE hPartition,
    PRL_CONST_STR sSysName
);
File

PrlApiVm.h

Parameters

hPartition
A handle of type PHT_VIRTUAL_DEV_HD_PARTITION identifying the disk partition.
sSysName
A system name to set for the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHdPart_GetSysName

Links
PHT_VIRTUAL_DEV_HD_PARTITION, See Also


PrlVmDevNet_GenerateMacAddr Function

PrlVmDevNet_GenerateMacAddr Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Generates a unique MAC address for a virtual network adapter on a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GenerateMacAddr(
    PRL_HANDLE hVmDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the network adapter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function will generate a new MAC address and will automatically assign it to the adapter. The function does not return the address to the caller. To retrieve the address, use the PrlVmDevNet_GetMacAddress function.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_GetAdapterType Function

PrlVmDevNet_GetAdapterType Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtain the adapter type assigned to a virtual network adapter.

Syntax
PRL_RESULT PrlVmDevNet_GetAdapterType(
    PRL_HANDLE hVmDev,
    PRL_VM_NET_ADAPTER_TYPE_PTR pnAdapterType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pnAdapterType
[out] A pointer to a buffer that receives the adapter type

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetAdapterType

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetBoundAdapterIndex Function

PrlVmDevNet_GetBoundAdapterIndex Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Returns the index of the adapter to which the specified virtual adapter is bound.

Syntax
PRL_RESULT PrlVmDevNet_GetBoundAdapterIndex(
    PRL_HANDLE hVmDev,
    PRL_INT32_PTR pnIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pnIndex
[out] A pointer to a variable that receives the index. A returned value of -1 (negative one) indicates that the virtual network adapter is bound to the default adapter on the host.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to retrieve the index of the adapter from the host.

See Also

PrlVmDevNet_SetBoundAdapterIndex

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetBoundAdapterName Function

PrlVmDevNet_GetBoundAdapterName Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Returns the name of the adapter to which the specified virtual adapter is bound.

Syntax
PRL_RESULT PrlVmDevNet_GetBoundAdapterName(
    PRL_HANDLE hVmDev,
    PRL_STR sBoundAdapterName,
    PRL_UINT32_PTR pnBoundAdapterNameBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sBoundAdapterName
[out] Pointer to a buffer that receives the physical adapter name (a UTF-8 encoded, null-terminated string).
pnBoundAdapterNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to retrieve the name of the adapter from the host.

See Also

PrlVmDevNet_SetBoundAdapterName

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetDefaultGateway Function

PrlVmDevNet_GetDefaultGateway Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains the default gateway assigned to a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GetDefaultGateway(
    PRL_HANDLE hVmDev,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sDefaultGateway
[out] A pointer to a buffer that receives the default gateway address (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetDefaultGateway

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetDefaultGatewayIPv6 Function

PrlVmDevNet_GetDefaultGatewayIPv6 Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains the default gateway (IPv6) assigned to a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GetDefaultGatewayIPv6(
    PRL_HANDLE hVmDev,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sDefaultGateway
[out] A pointer to a buffer that receives the default gateway address (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetDefaultGateway

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetDnsServers Function

PrlVmDevNet_GetDnsServers Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetDnsServers(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phDnsServersList
[out] A pointer to the PHT_STRINGS_LIST handle that receives the list of DNS servers.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetDnsServers

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetFirewallDefaultPolicy Function

PrlVmDevNet_GetFirewallDefaultPolicy Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Gets an adapter firewall default policy.

Syntax
PRL_RESULT PrlVmDevNet_GetFirewallDefaultPolicy(
    PRL_HANDLE hVmDev,
    PRL_FIREWALL_DIRECTION nDirection,
    PRL_FIREWALL_POLICY_PTR pnPolicy
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nDirection
Direction of a firewall - to/from the virtual network adapter
pnPolicy
[out] A pointer to a buffer that receives the adapter firewall default policy.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Policy values are defined in the PRL_FIREWALL_POLICY enumeration.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_GetFirewallRuleList Function

PrlVmDevNet_GetFirewallRuleList Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Returns the firewall rule entries list.

Syntax
PRL_RESULT PrlVmDevNet_GetFirewallRuleList(
    PRL_HANDLE hVmDev,
    PRL_FIREWALL_DIRECTION nDirection,
    PRL_HANDLE_PTR phRuleList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nDirection
Direction of a firewall - to/from the virtual network adapter
phRuleList
[out] A pointer to a variable that receives the new handle of PHT_HANDLES_LIST type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list or a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_GetHostInterfaceName Function

PrlVmDevNet_GetHostInterfaceName Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Obtains the custom host adapter name.

Syntax
PRL_RESULT PrlVmDevNet_GetHostInterfaceName(
    PRL_HANDLE hVmDev,
    PRL_STR sHostInterfaceName,
    PRL_UINT32_PTR pnHostInterfaceNameBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sHostInterfaceName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_GetMacAddress Function

PrlVmDevNet_GetMacAddress Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Returns the MAC address of a virtual network adapter inside a virtual machine (in Parallels format XXXXXXXXXXXX).

Syntax
PRL_RESULT PrlVmDevNet_GetMacAddress(
    PRL_HANDLE hVmDev,
    PRL_STR sMacAddress,
    PRL_UINT32_PTR pnMacAddressBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sMacAddress
[out] Pointer to a buffer that receives the MAC address (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_GetMacAddressCanonical, PrlVmDevNet_SetMacAddress

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetMacAddressCanonical Function

PrlVmDevNet_GetMacAddressCanonical Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Returns the MAC address of a virtual network adapter inside a virtual machine (in human-friendly format xx:xx:xx:xx:xx:xx).

Syntax
PRL_RESULT PrlVmDevNet_GetMacAddressCanonical(
    PRL_HANDLE hVmDev,
    PRL_STR sMacAddress,
    PRL_UINT32_PTR pnMacAddressBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sMacAddress
[out] Pointer to a buffer that receives the MAC address (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetMacAddress

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetNetAddresses Function

PrlVmDevNet_GetNetAddresses Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetNetAddresses(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phNetAddressesList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phNetAddressesList
[out] A pointer to the PHT_STRINGS_LIST handle containing the IP addresses.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returns the list of pairs "IP address/Subnet mask" which will be applied to the network adapter on the guest OS side (on guest start or immediately on config commit if guest already working and Parallels tools with necessary functionality are installed). The result will be returned as list of strings (PHT_STRINGS_LIST type) of pairs "IP address/Subnet mask".

See Also

PrlVmDevNet_SetNetAddresses

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetSearchDomains Function

PrlVmDevNet_GetSearchDomains Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetSearchDomains(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phSearchDomainsList
[out] A pointer to the PHT_STRINGS_LIST handle containing the results.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetSearchDomains

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetVirtualNetworkId Function

PrlVmDevNet_GetVirtualNetworkId Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Obtains the virtual network ID assigned to a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GetVirtualNetworkId(
    PRL_HANDLE hVmDev,
    PRL_STR sVirtualNetworkId,
    PRL_UINT32_PTR pnVirtualNetworkIdBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sVirtualNetworkId
[out] A pointer to a buffer that receives the virtual network ID (a UTF-8 encoded, null-terminated string).
pnVirtNetIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetVirtualNetworkId

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_IsAutoApply Function

PrlVmDevNet_IsAutoApply Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Determines if the specified network adapter is configured to automatically apply network settings inside guest.

Syntax
PRL_RESULT PrlVmDevNet_IsAutoApply(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbAutoApply
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbAutoApply
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is configured to automatically apply network settings. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_IsConfigureWithDhcp Function

PrlVmDevNet_IsConfigureWithDhcp Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Determines if the specified network adapter is configured through DHCP on the guest OS side.

Syntax
PRL_RESULT PrlVmDevNet_IsConfigureWithDhcp(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbConfigureWithDhcp
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_IsConfigureWithDhcpIPv6 Function

PrlVmDevNet_IsConfigureWithDhcpIPv6 Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Determines if the specified network adapter is configured through DHCP (IPv6) on the guest OS side.

Syntax
PRL_RESULT PrlVmDevNet_IsConfigureWithDhcpIPv6(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbConfigureWithDhcp
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_IsFirewallEnabled Function

PrlVmDevNet_IsFirewallEnabled Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Gets state switched on or off of the adapter firewall.

Syntax
PRL_RESULT PrlVmDevNet_IsFirewallEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbEnabled
[out] A pointer to a buffer that receives the adapter firewall state.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_IsPktFilterPreventIpSpoof Function

PrlVmDevNet_IsPktFilterPreventIpSpoof Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Determines if the specified network adapter is configured to filter net packages and send packages only from IP addresses in the adapter NetAdrresses list.

Syntax
PRL_RESULT PrlVmDevNet_IsPktFilterPreventIpSpoof(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbPktFilterPreventIpSpoof
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbPktFilterPreventMacSpoof
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that adapter is allowed to send packages only from IP addresses in the adapter NetAdrresses list. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_IsPktFilterPreventMacSpoof Function

PrlVmDevNet_IsPktFilterPreventMacSpoof Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Determines if the specified network adapter is configured to filter net packages and send packages only from its own MAC address.

Syntax
PRL_RESULT PrlVmDevNet_IsPktFilterPreventMacSpoof(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbPktFilterPreventMacSpoof
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbPktFilterPreventMacSpoof
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that adapter is allowed to send packages only from its own MAC address. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetAdapterType Function

PrlVmDevNet_SetAdapterType Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually assign adapter type to a network adapter.

Syntax
PRL_RESULT PrlVmDevNet_SetAdapterType(
    PRL_HANDLE hVmDev,
    PRL_VM_NET_ADAPTER_TYPE nAdapterType
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nAdapterType
The new network adapter type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_GetAdapterType

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetAutoApply Function

PrlVmDevNet_SetAutoApply Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Allows to specify whether a network adapter in a virtual machine should be automatically configured.

Syntax
PRL_RESULT PrlVmDevNet_SetAutoApply(
    PRL_HANDLE hVmDev,
    PRL_BOOL bAutoApply
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bAutoApply
Specify PRL_TRUE to configure the adapter automatically. Specified PRL_FALSE to configure the network settings manually in a virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetBoundAdapterIndex Function

PrlVmDevNet_SetBoundAdapterIndex Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Sets the index of the adapter to which the specified virtual adapter should be bound.

Syntax
PRL_RESULT PrlVmDevNet_SetBoundAdapterIndex(
    PRL_HANDLE hVmDev,
    PRL_INT32 nIndex
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nIndex
The index of the adapter to which the specified virtual adapter should be bound. If you would like to bind the virtual adapter to the default adapter, specify -1 (negative one).

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid net VM device handle or handle of already removed net VM device was passed PRL_ERR_SUCCESS - operation successfully completed

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to set the index of the adapter from the host.

See Also

PrlVmDevNet_GetBoundAdapterIndex

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetBoundAdapterName Function

PrlVmDevNet_SetBoundAdapterName Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.

Syntax
PRL_RESULT PrlVmDevNet_SetBoundAdapterName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewBoundAdapterName
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewBoundAdapterName
The name of the adapter to bind to. The adapter must exist on the host. To get the names of the available adapters from the host, use the PrlSrvCfg_GetNetAdapter function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to set the name of the adapter to bind to.

See Also

PrlVmDevNet_GetBoundAdapterName

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetConfigureWithDhcp Function

PrlVmDevNet_SetConfigureWithDhcp Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.

Syntax
PRL_RESULT PrlVmDevNet_SetConfigureWithDhcp(
    PRL_HANDLE hVmDev,
    PRL_BOOL bConfigureWithDhcp
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bConfigureWithDhcp
Specify PRL_TRUE to configure the adapter through DHCP. Specified PRL_FALSE to configure the network settings manually.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetConfigureWithDhcpIPv6 Function

PrlVmDevNet_SetConfigureWithDhcpIPv6 Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to specify whether a network adapter in a virtual machine should be configured through DHCP (IPv6) or manually.

Syntax
PRL_RESULT PrlVmDevNet_SetConfigureWithDhcpIPv6(
    PRL_HANDLE hVmDev,
    PRL_BOOL bConfigureWithDhcp
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bConfigureWithDhcp
Specify PRL_TRUE to configure the adapter through DHCP. Specified PRL_FALSE to configure the network settings manually.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetDefaultGateway Function

PrlVmDevNet_SetDefaultGateway Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually set the default gateway address for a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetDefaultGateway(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewDefaultGateway
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewDefaultGateway
The new default gateway address. The specified string must be encoded using UTF-8 and must be terminated with the binary zero character.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetDefaultGateway PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetDefaultGatewayIPv6 Function

PrlVmDevNet_SetDefaultGatewayIPv6 Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually set the default gateway address (IPv6) for a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetDefaultGatewayIPv6(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewDefaultGateway
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewDefaultGateway
The new default gateway address. The specified string must be encoded using UTF-8 and must be terminated with the binary zero character.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetDefaultGateway PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetDnsServers Function

PrlVmDevNet_SetDnsServers Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually assign DNS servers to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetDnsServers(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hDnsServersList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hDnsServersList
A handle of type PHT_STRINGS_LIST containing the list of DNS servers to be assigned to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetFirewallDefaultPolicy Function

PrlVmDevNet_SetFirewallDefaultPolicy Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Sets an adapter firewall default policy.

Syntax
PRL_RESULT PrlVmDevNet_SetFirewallDefaultPolicy(
    PRL_HANDLE hVmDev,
    PRL_FIREWALL_DIRECTION nDirection,
    PRL_FIREWALL_POLICY nPolicy
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nDirection
Direction of a firewall - to/from the virtual network adapter
nPolicy
An adapter firewall default policy.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Policy values are defined in the PRL_FIREWALL_POLICY enumeration.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetFirewallEnabled Function

PrlVmDevNet_SetFirewallEnabled Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Sets state switched on or off of the adapter firewall.

Syntax
PRL_RESULT PrlVmDevNet_SetFirewallEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL bEnabled
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bEnabled
The adapter firewall state.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetFirewallRuleList Function

PrlVmDevNet_SetFirewallRuleList Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Sets the firewall rule entries list.

Syntax
PRL_RESULT PrlVmDevNet_SetFirewallRuleList(
    PRL_HANDLE hVmDev,
    PRL_FIREWALL_DIRECTION nDirection,
    PRL_HANDLE hRuleList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nDirection
Direction of a firewall - to/from the virtual network adapter
hRuleList
The list of PHT_FIREWALL_RULE handles.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward entry object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetHostInterfaceName Function

PrlVmDevNet_SetHostInterfaceName Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Sets the custom host adapter name in a bridged networking mode, (autogenerated if not set) hVmDev : A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.

Syntax
PRL_RESULT PrlVmDevNet_SetHostInterfaceName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewHostInterfaceName
);
File

PrlApiVm.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

sNewHostInterfaceName : Host interface name.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetMacAddress Function

PrlVmDevNet_SetMacAddress Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually set MAC address to a network adapter inside a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetMacAddress(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewMacAddress
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewMacAddress
The new MAC address. The specified string must be encoded using UTF-8 and must be terminated with a binary zero character. The MAC address value cannot contain any delimiters. The following is an example of a valid MAC address: "001731EE6FBC".

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function if you would like to set a specific MAC address to an adapter. To generate an address and to set it to an adapter automatically, use the PrlVmDevNet_GenerateMacAddr function.

See Also

PrlVmDevNet_GetMacAddress

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetNetAddresses Function

PrlVmDevNet_SetNetAddresses Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetNetAddresses(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hNetAddressesList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hNetAddressesList
A handle of type PHT_STRINGS_LIST containing the list of "IP address/Subnet mask" pairs to be applied to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetPktFilterPreventIpSpoof Function

PrlVmDevNet_SetPktFilterPreventIpSpoof Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Allows to specify whether a network adapter in a virtual machine should perform the filtration by IP addresses.

Syntax
PRL_RESULT PrlVmDevNet_SetPktFilterPreventIpSpoof(
    PRL_HANDLE hVmDev,
    PRL_BOOL bPktFilterPreventIpSpoof
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bPktFilterPreventMacSpoof
Specify PRL_TRUE to send packages only from addresses in the adapter NetAdrresses list. Specify PRL_FALSE to switch off filtration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetPktFilterPreventMacSpoof Function

PrlVmDevNet_SetPktFilterPreventMacSpoof Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Allows to specify whether a network adapter in a virtual machine should filter packets through MAC address spoofing.

Syntax
PRL_RESULT PrlVmDevNet_SetPktFilterPreventMacSpoof(
    PRL_HANDLE hVmDev,
    PRL_BOOL bPktFilterPreventMacSpoof
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bPktFilterPreventMacSpoof
Specify PRL_TRUE to send packages only from its own MAC address. Specify PRL_FALSE to turn off filtration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetPktFilterPreventPromisc Function

PrlVmDevNet_SetPktFilterPreventPromisc Function
PHT_VIRTUAL_DEV_NET_ADAPTER

Allows to specify whether a network adapter in a virtual machine should receive packets sent not to VM.

Syntax
PRL_RESULT PrlVmDevNet_SetPktFilterPreventPromisc(
    PRL_HANDLE hVmDev,
    PRL_BOOL bPktFilterPreventPromisc
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bPktFilterPreventPromisc
Specify PRL_TRUE to prevent VM to receive packets that were sent not to VM. Specify PRL_FALSE to switch off filtration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetSearchDomains Function

PrlVmDevNet_SetSearchDomains Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to manually assign search domains to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetSearchDomains(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hSearchDomainsList
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hSearchDomainsList
A handle of type PHT_STRINGS_LIST containing the list of search domains to be assigned to the network adapter. Can be PRL_INVALID_HANDLE iif it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in the target virtual machine, and its network adapter settings should be configured to change automatically.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_SetAutoApply

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetVirtualNetworkId Function

PrlVmDevNet_SetVirtualNetworkId Function
PHT_VIRTUAL_DEV_NET_ADAPTER See Also

Allows to set the virtual network ID for a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetVirtualNetworkId(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewVirtualNetworkId
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewVirtualNetworkId
The new virtual network ID. The specified string must be encoded using UTF-8 and must be terminated with the binary zero character. Can be null or empty in order to drop virtual network ID device field.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_GetVirtualNetworkId

Links
PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevSerial_GetSocketMode Function

PrlVmDevSerial_GetSocketMode Function
PHT_VIRTUAL_DEV_SERIAL_PORT See Also

Returns the socket mode of a virtual serial port.

Syntax
PRL_RESULT PrlVmDevSerial_GetSocketMode(
    PRL_HANDLE hVmDev,
    PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR pnSocketMode
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SERIAL_PORT identifying the serial port.
pnSocketMode
[out] Pointer to a variable that receives the socket mode.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function to get the socket mode when the emulation type of the port is "socket". To get the port's emulation type, use the PrlVmDev_GetEmulatedType function.

See Also

PrlVmDevSerial_SetSocketMode

Links
PHT_VIRTUAL_DEV_SERIAL_PORT, See Also


PrlVmDevSerial_SetSocketMode Function

PrlVmDevSerial_SetSocketMode Function
PHT_VIRTUAL_DEV_SERIAL_PORT See Also

Sets the socket mode for a virtual serial port.

Syntax
PRL_RESULT PrlVmDevSerial_SetSocketMode(
    PRL_HANDLE hVmDev,
    PRL_SERIAL_PORT_SOCKET_OPERATION_MODE nSocketMode
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SERIAL_PORT identifying the serial port.
nSocketMode
The socket mode emulation type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function to set the socket mode when the emulation type of the port is "socket". To get the port's emulation type, use the PrlVmDev_GetEmulatedType function.

See Also

PrlVmDevSerial_GetSocketMode

Links
PHT_VIRTUAL_DEV_SERIAL_PORT, See Also


PrlVmDevSound_GetMixerDev Function

PrlVmDevSound_GetMixerDev Function
PHT_VIRTUAL_DEV_SOUND See Also

Returns mixer device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_GetMixerDev(
    PRL_HANDLE hVmDev,
    PRL_STR sMixerDev,
    PRL_UINT32_PTR pnMixerDevBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sMixerDev
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnMixerDevBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_SetMixerDev

Links
PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_GetOutputDev Function

PrlVmDevSound_GetOutputDev Function
PHT_VIRTUAL_DEV_SOUND See Also

Returns output device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_GetOutputDev(
    PRL_HANDLE hVmDev,
    PRL_STR sOutputDev,
    PRL_UINT32_PTR pnOutputDevBufLength
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sOutputDev
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOutputDevBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_SetOutputDev

Links
PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_SetMixerDev Function

PrlVmDevSound_SetMixerDev Function
PHT_VIRTUAL_DEV_SOUND See Also

Sets mixer device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_SetMixerDev(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewMixerDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sNewMixerDev
Mixer device string to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_GetMixerDev

Links
PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_SetOutputDev Function

PrlVmDevSound_SetOutputDev Function
PHT_VIRTUAL_DEV_SOUND See Also

Sets output device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_SetOutputDev(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewOutputDev
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sNewOutputDev
Output device string to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_GetOutputDev

Links
PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevUsb_GetAutoconnectOption Function

PrlVmDevUsb_GetAutoconnectOption Function
PHT_VIRTUAL_DEV_USB_DEVICE See Also

Obtains USB controller autoconnect device option.

Syntax
PRL_RESULT PrlVmDevUsb_GetAutoconnectOption(
    PRL_HANDLE hVmDev,
    PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR pnAutoconnectOption
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_USB_DEVICE identifying the USB device.
pnAutoconnectOption
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevUsb_SetAutoconnectOption

Links
PHT_VIRTUAL_DEV_USB_DEVICE, See Also


PrlVmDevUsb_SetAutoconnectOption Function

PrlVmDevUsb_SetAutoconnectOption Function
PHT_VIRTUAL_DEV_USB_DEVICE See Also

Sets USB controller autoconnect device option.

Syntax
PRL_RESULT PrlVmDevUsb_SetAutoconnectOption(
    PRL_HANDLE hVmDev,
    PRL_USB_DEVICE_AUTO_CONNECT_OPTION nAutoconnectOption
);
File

PrlApiVm.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_USB_DEVICE identifying the USB device.
nAutoconnectOption
Autoconnect option to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevUsb_GetAutoconnectOption

Links
PHT_VIRTUAL_DEV_USB_DEVICE, See Also


PrlVmGuest_GetNetworkSettings Function

PrlVmGuest_GetNetworkSettings Function
PHT_VM_GUEST_SESSION

Obtains network settings of a guest operating system running in a virtual machine.

Syntax
PRL_HANDLE PrlVmGuest_GetNetworkSettings(
    PRL_HANDLE hVmGuest,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
nReserved
Reserved parameter for future purposes. Must be 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The network settings are obtained using a user session in the guest operating system. Prior to calling this function, a handle to a user session in the virtual machine must be obtained using the PrlVm_LoginInGuest function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the results from the returned PHT_JOB object, use the following steps:

  1. Use the PrlJob_GetResult function to obtain a handle of type PHT_RESULT.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SERVER_CONFIG. The handle will contain the guest OS network settings.

Once you obtain the PHT_SERVER_CONFIG handle, you can use the following functions to obtain individual network settings of the guest OS:

PrlSrvCfg_GetDnsServers

PrlSrvCfg_GetHostname

PrlSrvCfg_GetSearchDomains

PrlSrvCfg_GetNetAdapter

PrlSrvCfg_GetDefaultGateway

Links
PHT_VM_GUEST_SESSION


PrlVmGuest_Logout Function

PrlVmGuest_Logout Function
PHT_VM_GUEST_SESSION See Also

Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.

Syntax
PRL_HANDLE PrlVmGuest_Logout(
    PRL_HANDLE hVmGuest,
    PRL_UINT32 nReserved
);
File

PrlApiVm.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the session.
nReserved
Reserved parameter for future purposes. Must contain 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_LoginInGuest

Links
PHT_VM_GUEST_SESSION, See Also


PrlVmGuest_RunProgram Function

PrlVmGuest_RunProgram Function
PHT_VM_GUEST_SESSION

Executes a program in a virtual machine.

Syntax
PRL_HANDLE PrlVmGuest_RunProgram(
    PRL_HANDLE hVmGuest,
    PRL_CONST_STR sAppName,
    PRL_HANDLE hArgsList,
    PRL_HANDLE hEnvsList,
    PRL_UINT32 nFlags,
    PRL_FILE_DESC nStdin,
    PRL_FILE_DESC nStdout,
    PRL_FILE_DESC nStderr
);
File

PrlApiVm.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
sAppName
An absolute path to the program that you would like to execute.
hArgsList
A handle of type PHT_STRINGS_LIST specifying the list of arguments to pass to the program. Each token must be a separate list item.
hEnvsList
A handle of type PHT_STRINGS_LIST specifying the list of environment variables to add to the program execution environment. Each variable must be a separate list item in the var_name=var_value format.
nFlags
Modificators of the program execution. Acceptable values:

PFD_STDOUT - return stdout.

PFD_STDERR - return stderr.

PFD_ALL - return both stdout and stderr (a blank nFlags parameter yields the same result).

PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY - run the program and return immediately without waiting for the program execution results.

nStdin
file descriptor on standard input (PRL_INVALID_FILE_DESCRIPTOR should be passed if you don't want to use file descriptors. Please note that IO channel between client and VM should be established before using file descriptors. Please call PrlDevDisplay_ConnectToVm in order to do it).
nStdout
file descriptor on standard output (PRL_INVALID_FILE_DESCRIPTOR should be passed if you don't want to use file descriptors. Please note that IO channel between client and VM should be established before using file descriptors. Please call PrlDevDisplay_ConnectToVm in order to do it).
nStderr
file descriptor on standard errors output (PRL_INVALID_FILE_DESCRIPTOR should be passed if you don't want to use file descriptors. Please note that IO channel between client and VM should be established before using file descriptors. Please call PrlDevDisplay_ConnectToVm in order to do it).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Prior to calling this function, a handle to a user session in a virtual machine must be obtained using the PrlVm_LoginInGuest function. Once you obtain a session handle, you can use this function to run programs in the virtual machine. Depending on the options that were used during login, you will be able to run GUI applications and/or console programs. See the PrlVm_LoginInGuest function for more info.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND - the specified program at the specified path was not found.

PRL_ERR_UNINITIALIZED - file descriptors interface tried to use but PrlDevDisplay_ConnectToVm wasn't call.

PRL_ERR_SUCCESS - program executed successfully.

Links
PHT_VM_GUEST_SESSION


PrlVmGuest_SetUserPasswd Function

PrlVmGuest_SetUserPasswd Function
PHT_VM_GUEST_SESSION See Also

Allows to change the password of a guest operating system user.

Syntax
PRL_HANDLE PrlVmGuest_SetUserPasswd(
    PRL_HANDLE hVmGuest,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sUserPasswd,
    PRL_UINT32 nFlags
);
File

PrlApiVm.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
sUserName
Guest operating system user name. Can be null or empty string when setting the administrator password.
sUserPasswd
New password. Can be null when setting an empty password.
nFlags
Bitset of flags - from enum PRL_SET_USERPASSWD_FLAGS

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Prior to calling this function, a handle to a user session in a virtual machine must be obtained using the PrlVm_LoginInGuest function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_LoginInGuest

Links
PHT_VM_GUEST_SESSION, See Also


PrlVmInfo_GetAccessRights Function

PrlVmInfo_GetAccessRights Function
PHT_VM_INFO

Obtains a handle of type PHT_ACCESS_RIGHTS.

Syntax
PRL_RESULT PrlVmInfo_GetAccessRights(
    PRL_HANDLE hVmInfo,
    PRL_HANDLE_PTR phVmAcl
);
File

PrlApiVm.h

Parameters

hVmInfo
A handle of type PHT_VM_INFO.
phVmAcl
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_ACCESS_RIGHTS object.

PRL_ERR_NO_DATA - the virtual machine access rights information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_INFO


PrlVmInfo_GetAdditionState Function

PrlVmInfo_GetAdditionState Function
PHT_VM_INFO

Returns the virtual machine addition state information.

Syntax
PRL_RESULT PrlVmInfo_GetAdditionState(
    PRL_HANDLE handle,
    VIRTUAL_MACHINE_ADDITION_STATE_PTR pVmState
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmState
[out] A pointer to a variable that receives the virtual machine addition state information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_INFO


PrlVmInfo_GetState Function

PrlVmInfo_GetState Function
PHT_VM_INFO

Returns the virtual machine state information.

Syntax
PRL_RESULT PrlVmInfo_GetState(
    PRL_HANDLE handle,
    VIRTUAL_MACHINE_STATE_PTR pVmState
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmState
[out] A pointer to a variable that receives the virtual machine state information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_INFO


PrlVmInfo_IsInvalid Function

PrlVmInfo_IsInvalid Function
PHT_VM_INFO

Determines if the specified virtual machine is invalid.

Syntax
PRL_RESULT PrlVmInfo_IsInvalid(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsInvalid
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmIsInvalid
[out] A pointer to a variable that receives result. PRL_TRUE - the virtual machine is invalid. PRL_FALSE - the virtual machine is fully operational.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the status of the virtual machine cannot be determined.

RL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual machine can be reported as invalid by the function if its configuration has been corrupted, it's been removed from the virtual machine, and for other similar reasons.

Links
PHT_VM_INFO


PrlVmInfo_IsInvalidEx Function

PrlVmInfo_IsInvalidEx Function
PHT_VM_INFO

Determines if the specified virtual machine is invalid.

Syntax
PRL_RESULT PrlVmInfo_IsInvalidEx(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsInvalid,
    PRL_RESULT_PTR pnInvalidReason
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmIsInvalid
[out] A pointer to a variable that receives result. PRL_TRUE - the virtual machine is invalid. PRL_FALSE - the virtual machine is fully operational.

pVmInvalidReason
[out] A pointer to a variable that receives reason of invalidity as error code.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the status of the virtual machine cannot be determined.

RL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual machine can be reported as invalid by the function if its configuration has been corrupted, it's been removed from the virtual machine, and for other similar reasons.

Links
PHT_VM_INFO


PrlVmInfo_IsVmWaitingForAnswer Function

PrlVmInfo_IsVmWaitingForAnswer Function
PHT_VM_INFO

Determines if the specified virtual machine is waiting for answer on self question.

Syntax
PRL_RESULT PrlVmInfo_IsVmWaitingForAnswer(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsVmWaitingForAnswer
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pbIsVmWaitingForAnswer
[out] A pointer to a variable that receives result. PRL_TRUE - the virtual machine is waiting for answer. PRL_FALSE - the virtual machine is working normal.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the status of the virtual machine cannot be determined.

RL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_INFO


PrlVmInfo_IsVncServerStarted Function

PrlVmInfo_IsVncServerStarted Function
PHT_VM_INFO See Also

Determines whether a VNC server is running for the specified virtual machine.

Syntax
PRL_RESULT PrlVmInfo_IsVncServerStarted(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsVncServerStarted
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_INFO.
pbIsVncServerStarted
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that a VNC server is running. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the VNC server state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StartVncServer

PrlVm_StopVncServer

Links
PHT_VM_INFO, See Also


PrlVmToolsInfo_GetState Function

PrlVmToolsInfo_GetState Function
PHT_VM_TOOLS_INFO

Returns the Parallels Tools package state information.

Syntax
PRL_RESULT PrlVmToolsInfo_GetState(
    PRL_HANDLE handle,
    PRL_VM_TOOLS_STATE_PTR pVmToolsState
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_TOOLS_INFO.
pVmToolsState
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the Parallels Tools package state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PHT_VM_TOOLS_INFO


PrlVmToolsInfo_GetVersion Function

PrlVmToolsInfo_GetVersion Function
PHT_VM_TOOLS_INFO

Returns version information of the Parallels Tools package installed in a given virtual machine.

Syntax
PRL_RESULT PrlVmToolsInfo_GetVersion(
    PRL_HANDLE handle,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApiVm.h

Parameters

handle
A handle of type PHT_VM_TOOLS_INFO.
sName
[out] A pointer to a buffer that receives the version information (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the Parallels Tools package version information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Before calling this function, make sure that the Parallels Tools package is installed in the virtual machine by calling the PrlVmToolsInfo_GetState function.

Links
PHT_VM_TOOLS_INFO


PVM_GET_SECURITY_LEVEL Macro

PVM_GET_SECURITY_LEVEL Macro
Other Macros
Syntax
#define PVM_GET_SECURITY_LEVEL(flags) \
    (PRL_SECURITY_LEVEL)(flags&(PSL_LOW_SECURITY|PSL_NORMAL_SECURITY|PSL_HIGH_SECURITY))
File

PrlEnums.h

Links
Other Macros


PVS_GET_GUEST_NUMBER Macro

PVS_GET_GUEST_NUMBER Macro
Other Macros
Syntax
#define PVS_GET_GUEST_NUMBER(v) ((v) & 0xff)
File

PrlOses.h

Links
Other Macros


PVS_GET_GUEST_TYPE Macro

PVS_GET_GUEST_TYPE Macro
Other Macros
Syntax
#define PVS_GET_GUEST_TYPE(v) (((v) >> 8) & 0xff)
File

PrlOses.h

Links
Other Macros


PVS_GUEST_ARCH_I386 Macro

PVS_GUEST_ARCH_I386 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_ARCH_I386 (1)
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_ARCH_OTHER Macro

PVS_GUEST_ARCH_OTHER Macro
PVS_GUEST Macros

Autodetected OS Architecture

Syntax
#define PVS_GUEST_ARCH_OTHER (0)
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_ARCH_X86_64 Macro

PVS_GUEST_ARCH_X86_64 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_ARCH_X86_64 (2)
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_ANDROID Macro

PVS_GUEST_TYPE_ANDROID Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_ANDROID 0x10
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_CHROMEOS Macro

PVS_GUEST_TYPE_CHROMEOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_CHROMEOS 0x0F
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_FREEBSD Macro

PVS_GUEST_TYPE_FREEBSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_FREEBSD 0x0A
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_LINUX Macro

PVS_GUEST_TYPE_LINUX Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_LINUX 0x09
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_MACOS Macro

PVS_GUEST_TYPE_MACOS Macro
PVS_GUEST Macros

Guest OS types enumeration

Syntax
#define PVS_GUEST_TYPE_MACOS 0x07
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_MSDOS Macro

PVS_GUEST_TYPE_MSDOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_MSDOS 0x0C
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_ANDROID Macro

PVS_GUEST_TYPE_NAME_ANDROID Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_ANDROID "Android"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_CHROMEOS Macro

PVS_GUEST_TYPE_NAME_CHROMEOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_CHROMEOS "Chrome OS"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_FREEBSD Macro

PVS_GUEST_TYPE_NAME_FREEBSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_FREEBSD "FreeBSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_LINUX Macro

PVS_GUEST_TYPE_NAME_LINUX Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_LINUX "Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_MACOS Macro

PVS_GUEST_TYPE_NAME_MACOS Macro
PVS_GUEST Macros

Guest OS type names

Syntax
#define PVS_GUEST_TYPE_NAME_MACOS "OS X"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_MSDOS Macro

PVS_GUEST_TYPE_NAME_MSDOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_MSDOS "MS-DOS"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_NETWARE Macro

PVS_GUEST_TYPE_NAME_NETWARE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_NETWARE "NetWare"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_OS2 Macro

PVS_GUEST_TYPE_NAME_OS2 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_OS2 "OS/2"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_OTHER Macro

PVS_GUEST_TYPE_NAME_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_OTHER "Other"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_SOLARIS Macro

PVS_GUEST_TYPE_NAME_SOLARIS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_SOLARIS "Solaris"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_WINDOWS Macro

PVS_GUEST_TYPE_NAME_WINDOWS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NAME_WINDOWS "Windows"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_NETWARE Macro

PVS_GUEST_TYPE_NETWARE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_NETWARE 0x0D
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_OS2 Macro

PVS_GUEST_TYPE_OS2 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_OS2 0x0B
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_OTHER Macro

PVS_GUEST_TYPE_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_OTHER 0xFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_SOLARIS Macro

PVS_GUEST_TYPE_SOLARIS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_SOLARIS 0x0E
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_TYPE_WINDOWS Macro

PVS_GUEST_TYPE_WINDOWS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_TYPE_WINDOWS 0x08
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_ANDROID_2_x Macro

PVS_GUEST_VER_ANDROID_2_x Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_ANDROID_2_x 0x1000
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_ANDROID_3_x Macro

PVS_GUEST_VER_ANDROID_3_x Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_ANDROID_3_x 0x1001
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_ANDROID_4_0 Macro

PVS_GUEST_VER_ANDROID_4_0 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_ANDROID_4_0 0x1002
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_ANDROID_LAST Macro

PVS_GUEST_VER_ANDROID_LAST Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_ANDROID_LAST PVS_GUEST_VER_ANDROID_4_0
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_ANDROID_OTHER Macro

PVS_GUEST_VER_ANDROID_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_ANDROID_OTHER 0x10FF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_4X Macro

PVS_GUEST_VER_BSD_4X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_4X 0x0A01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_5X Macro

PVS_GUEST_VER_BSD_5X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_5X 0x0A02
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_6X Macro

PVS_GUEST_VER_BSD_6X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_6X 0x0A03
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_7X Macro

PVS_GUEST_VER_BSD_7X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_7X 0x0A04
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_8X Macro

PVS_GUEST_VER_BSD_8X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_8X 0x0A05
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_LAST Macro

PVS_GUEST_VER_BSD_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST

Syntax
#define PVS_GUEST_VER_BSD_LAST PVS_GUEST_VER_TRUSTED_BSD
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_BSD_OTHER Macro

PVS_GUEST_VER_BSD_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_BSD_OTHER 0x0AFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_CHROMEOS_1x Macro

PVS_GUEST_VER_CHROMEOS_1x Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_CHROMEOS_1x 0x0F01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_CHROMEOS_LAST Macro

PVS_GUEST_VER_CHROMEOS_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST

Syntax
#define PVS_GUEST_VER_CHROMEOS_LAST PVS_GUEST_VER_CHROMEOS_1x
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_CHROMEOS_OTHER Macro

PVS_GUEST_VER_CHROMEOS_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_CHROMEOS_OTHER 0x0FFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_DOS_LAST Macro

PVS_GUEST_VER_DOS_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST

Syntax
#define PVS_GUEST_VER_DOS_LAST PVS_GUEST_VER_DOS_MS622
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_DOS_MS622 Macro

PVS_GUEST_VER_DOS_MS622 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_DOS_MS622 0x0C01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_DOS_OTHER Macro

PVS_GUEST_VER_DOS_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_DOS_OTHER 0x0CFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_FREE_BSD Macro

PVS_GUEST_VER_FREE_BSD Macro
Other Macros
Syntax
#define PVS_GUEST_VER_FREE_BSD 0x0A06
File

PrlOses.h

Links
Other Macros


PVS_GUEST_VER_LIN_CENTOS Macro

PVS_GUEST_VER_LIN_CENTOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_CENTOS 0x090D
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_CENTOS_7 Macro

PVS_GUEST_VER_LIN_CENTOS_7 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_CENTOS_7 0x0914
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_DEBIAN Macro

PVS_GUEST_VER_LIN_DEBIAN Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_DEBIAN 0x0906
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_FEDORA Macro

PVS_GUEST_VER_LIN_FEDORA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_FEDORA 0x0907
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_FEDORA_5 Macro

PVS_GUEST_VER_LIN_FEDORA_5 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_FEDORA_5 0x0908
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_KRNL_24 Macro

PVS_GUEST_VER_LIN_KRNL_24 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_KRNL_24 0x0904
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_KRNL_26 Macro

PVS_GUEST_VER_LIN_KRNL_26 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_KRNL_26 0x0905
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_LAST Macro

PVS_GUEST_VER_LIN_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST

Syntax
#define PVS_GUEST_VER_LIN_LAST PVS_GUEST_VER_LIN_CENTOS_7
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_MAGEIA Macro

PVS_GUEST_VER_LIN_MAGEIA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_MAGEIA 0x0911
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_MANDRAKE Macro

PVS_GUEST_VER_LIN_MANDRAKE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_MANDRAKE 0x0903
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_MINT Macro

PVS_GUEST_VER_LIN_MINT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_MINT 0x0912
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_OPENSUSE Macro

PVS_GUEST_VER_LIN_OPENSUSE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_OPENSUSE 0x090F
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_OTHER Macro

PVS_GUEST_VER_LIN_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_OTHER 0x09FF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_PSBM Macro

PVS_GUEST_VER_LIN_PSBM Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_PSBM 0x0910
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_REDHAT Macro

PVS_GUEST_VER_LIN_REDHAT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_REDHAT 0x0901
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_REDHAT_7 Macro

PVS_GUEST_VER_LIN_REDHAT_7 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_REDHAT_7 0x0913
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_RH_LEGACY Macro

PVS_GUEST_VER_LIN_RH_LEGACY Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_RH_LEGACY 0x090E
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_RHLES3 Macro

PVS_GUEST_VER_LIN_RHLES3 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_RHLES3 0x090C
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_SLES9 Macro

PVS_GUEST_VER_LIN_SLES9 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_SLES9 0x090B
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_SUSE Macro

PVS_GUEST_VER_LIN_SUSE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_SUSE 0x0902
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_UBUNTU Macro

PVS_GUEST_VER_LIN_UBUNTU Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_UBUNTU 0x090A
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_LIN_XANDROS Macro

PVS_GUEST_VER_LIN_XANDROS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_LIN_XANDROS 0x0909
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_MACOS_LAST Macro

PVS_GUEST_VER_MACOS_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST

Syntax
#define PVS_GUEST_VER_MACOS_LAST PVS_GUEST_VER_MACOS_UNIVERSAL
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_MACOS_LEOPARD Macro

PVS_GUEST_VER_MACOS_LEOPARD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_MACOS_LEOPARD 0x0702
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_MACOS_SNOW_LEOPARD Macro

PVS_GUEST_VER_MACOS_SNOW_LEOPARD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_MACOS_SNOW_LEOPARD 0x0703
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_MACOS_TIGER Macro

PVS_GUEST_VER_MACOS_TIGER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_MACOS_TIGER 0x0701
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_MACOS_UNIVERSAL Macro

PVS_GUEST_VER_MACOS_UNIVERSAL Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_MACOS_UNIVERSAL PVS_GUEST_VER_MACOS_SNOW_LEOPARD
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_ANDROID_4_0 Macro

PVS_GUEST_VER_NAME_ANDROID_4_0 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_ANDROID_4_0 "Android"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_ANDROID_OTHER Macro

PVS_GUEST_VER_NAME_ANDROID_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_ANDROID_OTHER "Other Android"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_4X Macro

PVS_GUEST_VER_NAME_BSD_4X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_4X "FreeBSD 4.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_5X Macro

PVS_GUEST_VER_NAME_BSD_5X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_5X "FreeBSD 5.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_6X Macro

PVS_GUEST_VER_NAME_BSD_6X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_6X "FreeBSD 6.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_7X Macro

PVS_GUEST_VER_NAME_BSD_7X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_7X "FreeBSD 7.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_8X Macro

PVS_GUEST_VER_NAME_BSD_8X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_8X "FreeBSD 8.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_OTHER Macro

PVS_GUEST_VER_NAME_BSD_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_BSD_OTHER "Other BSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_CHROMEOS_1x Macro

PVS_GUEST_VER_NAME_CHROMEOS_1x Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_CHROMEOS_1x "Chrome OS"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_CHROMEOS_OTHER Macro

PVS_GUEST_VER_NAME_CHROMEOS_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_CHROMEOS_OTHER "Other Chrome OS"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_DOS_MS622 Macro

PVS_GUEST_VER_NAME_DOS_MS622 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_DOS_MS622 "MS-DOS 6.22"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_DOS_OTHER Macro

PVS_GUEST_VER_NAME_DOS_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_DOS_OTHER "Other DOS"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_FREE_BSD Macro

PVS_GUEST_VER_NAME_FREE_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_FREE_BSD "FreeBSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_CENTOS Macro

PVS_GUEST_VER_NAME_LIN_CENTOS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_CENTOS "CentOS Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_DEBIAN Macro

PVS_GUEST_VER_NAME_LIN_DEBIAN Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_DEBIAN "Debian GNU/Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_FEDORA Macro

PVS_GUEST_VER_NAME_LIN_FEDORA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_FEDORA "Fedora Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_FEDORA_5 Macro

PVS_GUEST_VER_NAME_LIN_FEDORA_5 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_FEDORA_5 "Fedora Core 5 Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_KRNL_24 Macro

PVS_GUEST_VER_NAME_LIN_KRNL_24 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_KRNL_24 "Other Linux kernel 2.4"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_KRNL_26 Macro

PVS_GUEST_VER_NAME_LIN_KRNL_26 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_KRNL_26 "Other Linux kernel 2.6"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_MAGEIA Macro

PVS_GUEST_VER_NAME_LIN_MAGEIA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_MAGEIA "Mageia Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_MANDRAKE Macro

PVS_GUEST_VER_NAME_LIN_MANDRAKE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_MANDRAKE "Mandriva Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_MINT Macro

PVS_GUEST_VER_NAME_LIN_MINT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_MINT "Mint Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_OPENSUSE Macro

PVS_GUEST_VER_NAME_LIN_OPENSUSE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_OPENSUSE "OpenSUSE Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_OTHER Macro

PVS_GUEST_VER_NAME_LIN_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_OTHER "Other Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_PSBM Macro

PVS_GUEST_VER_NAME_LIN_PSBM Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_PSBM "Parallels Cloud Server"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_REDHAT Macro

PVS_GUEST_VER_NAME_LIN_REDHAT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_REDHAT "Red Hat Enterprise Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_RH_LEGACY Macro

PVS_GUEST_VER_NAME_LIN_RH_LEGACY Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_RH_LEGACY "Red Hat Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_RHLES3 Macro

PVS_GUEST_VER_NAME_LIN_RHLES3 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_RHLES3 "Red Hat Enterprise Server 3"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_SLES9 Macro

PVS_GUEST_VER_NAME_LIN_SLES9 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_SLES9 "SUSE Linux Enterprise Server 9"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_SUSE Macro

PVS_GUEST_VER_NAME_LIN_SUSE Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_SUSE "SUSE Linux Enterprise"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_UBUNTU Macro

PVS_GUEST_VER_NAME_LIN_UBUNTU Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_UBUNTU "Ubuntu Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_XANDROS Macro

PVS_GUEST_VER_NAME_LIN_XANDROS Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_LIN_XANDROS "Xandros Linux"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_LEOPARD Macro

PVS_GUEST_VER_NAME_MACOS_LEOPARD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_MACOS_LEOPARD "OS X"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD Macro

PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD "OS X"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_TIGER Macro

PVS_GUEST_VER_NAME_MACOS_TIGER Macro
PVS_GUEST Macros

Guest OS version names

Syntax
#define PVS_GUEST_VER_NAME_MACOS_TIGER "OS X"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_4X Macro

PVS_GUEST_VER_NAME_NET_4X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_NET_4X "NetWare 4.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_5X Macro

PVS_GUEST_VER_NAME_NET_5X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_NET_5X "NetWare 5.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_6X Macro

PVS_GUEST_VER_NAME_NET_6X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_NET_6X "NetWare 6.x"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_BSD Macro

PVS_GUEST_VER_NAME_NET_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_NET_BSD "NetBSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_OTHER Macro

PVS_GUEST_VER_NAME_NET_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_NET_OTHER "Other NetWare"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OPEN_BSD Macro

PVS_GUEST_VER_NAME_OPEN_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OPEN_BSD "OpenBSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_ECS11 Macro

PVS_GUEST_VER_NAME_OS2_ECS11 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_ECS11 "eComStation 1.1"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_ECS12 Macro

PVS_GUEST_VER_NAME_OS2_ECS12 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_ECS12 "eComStation 1.2"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_OTHER Macro

PVS_GUEST_VER_NAME_OS2_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_OTHER "Other OS/2"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP3 Macro

PVS_GUEST_VER_NAME_OS2_WARP3 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP3 "OS/2 Warp 3"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP4 Macro

PVS_GUEST_VER_NAME_OS2_WARP4 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP4 "OS/2 Warp 4"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP45 Macro

PVS_GUEST_VER_NAME_OS2_WARP45 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP45 "OS/2 Warp 4.5"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_OPENSTEP Macro

PVS_GUEST_VER_NAME_OTH_OPENSTEP Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OTH_OPENSTEP "OpenStep"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_OTHER Macro

PVS_GUEST_VER_NAME_OTH_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OTH_OTHER "Other"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_QNX Macro

PVS_GUEST_VER_NAME_OTH_QNX Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_OTH_QNX "QNX"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_9 Macro

PVS_GUEST_VER_NAME_SOL_9 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_SOL_9 "Solaris 9"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_10 Macro

PVS_GUEST_VER_NAME_SOL_10 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_SOL_10 "Solaris 10"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_11 Macro

PVS_GUEST_VER_NAME_SOL_11 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_SOL_11 "Solaris 11"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_OPEN Macro

PVS_GUEST_VER_NAME_SOL_OPEN Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_SOL_OPEN "OpenSolaris"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_OTHER Macro

PVS_GUEST_VER_NAME_SOL_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_SOL_OTHER "Other Solaris"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_TRUSTED_BSD Macro

PVS_GUEST_VER_NAME_TRUSTED_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_TRUSTED_BSD "TrustedBSD"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2K Macro

PVS_GUEST_VER_NAME_WIN_2K Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_2K "Windows 2000"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_95 Macro

PVS_GUEST_VER_NAME_WIN_95 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_95 "Windows 95"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_98 Macro

PVS_GUEST_VER_NAME_WIN_98 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_98 "Windows 98"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_311 Macro

PVS_GUEST_VER_NAME_WIN_311 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_311 "Windows 3.11"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2003 Macro

PVS_GUEST_VER_NAME_WIN_2003 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_2003 "Windows Server 2003"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2008 Macro

PVS_GUEST_VER_NAME_WIN_2008 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_2008 "Windows Server 2008"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2012 Macro

PVS_GUEST_VER_NAME_WIN_2012 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_2012 "Windows Server 2012"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_ME Macro

PVS_GUEST_VER_NAME_WIN_ME Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_ME "Windows ME"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_NT Macro

PVS_GUEST_VER_NAME_WIN_NT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_NT "Windows NT"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_OTHER Macro

PVS_GUEST_VER_NAME_WIN_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_OTHER "Other Windows"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_VISTA Macro

PVS_GUEST_VER_NAME_WIN_VISTA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_VISTA "Windows Vista"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_WINDOWS7 Macro

PVS_GUEST_VER_NAME_WIN_WINDOWS7 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_WINDOWS7 "Windows 7"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_WINDOWS8 Macro

PVS_GUEST_VER_NAME_WIN_WINDOWS8 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_WINDOWS8 "Windows 8"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 Macro

PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_WINDOWS8_1 "Windows 8.1"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_WINDOWS_10 Macro

PVS_GUEST_VER_NAME_WIN_WINDOWS_10 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_WINDOWS_10 "Windows 10"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_XP Macro

PVS_GUEST_VER_NAME_WIN_XP Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NAME_WIN_XP "Windows XP"
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_4X Macro

PVS_GUEST_VER_NET_4X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NET_4X 0x0D01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_5X Macro

PVS_GUEST_VER_NET_5X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NET_5X 0x0D02
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_6X Macro

PVS_GUEST_VER_NET_6X Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NET_6X 0x0D03
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_BSD Macro

PVS_GUEST_VER_NET_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NET_BSD 0x0A07
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_LAST Macro

PVS_GUEST_VER_NET_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST

Syntax
#define PVS_GUEST_VER_NET_LAST PVS_GUEST_VER_NET_6X
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_NET_OTHER Macro

PVS_GUEST_VER_NET_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_NET_OTHER 0x0DFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OPEN_BSD Macro

PVS_GUEST_VER_OPEN_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OPEN_BSD 0x0A08
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_ECS11 Macro

PVS_GUEST_VER_OS2_ECS11 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_ECS11 0x0B04
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_ECS12 Macro

PVS_GUEST_VER_OS2_ECS12 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_ECS12 0x0B05
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_LAST Macro

PVS_GUEST_VER_OS2_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST

Syntax
#define PVS_GUEST_VER_OS2_LAST PVS_GUEST_VER_OS2_ECS12
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_OTHER Macro

PVS_GUEST_VER_OS2_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_OTHER 0x0BFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP3 Macro

PVS_GUEST_VER_OS2_WARP3 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_WARP3 0x0B01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP4 Macro

PVS_GUEST_VER_OS2_WARP4 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_WARP4 0x0B02
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP45 Macro

PVS_GUEST_VER_OS2_WARP45 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OS2_WARP45 0x0B03
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OTH_LAST Macro

PVS_GUEST_VER_OTH_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST

Syntax
#define PVS_GUEST_VER_OTH_LAST PVS_GUEST_VER_OTH_OPENSTEP
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OTH_OPENSTEP Macro

PVS_GUEST_VER_OTH_OPENSTEP Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OTH_OPENSTEP 0xFF02
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OTH_OTHER Macro

PVS_GUEST_VER_OTH_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OTH_OTHER 0xFFFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_OTH_QNX Macro

PVS_GUEST_VER_OTH_QNX Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_OTH_QNX 0xFF01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_9 Macro

PVS_GUEST_VER_SOL_9 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_SOL_9 0x0E01
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_10 Macro

PVS_GUEST_VER_SOL_10 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_SOL_10 0x0E02
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_11 Macro

PVS_GUEST_VER_SOL_11 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_SOL_11 0x0E03
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_LAST Macro

PVS_GUEST_VER_SOL_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST

Syntax
#define PVS_GUEST_VER_SOL_LAST PVS_GUEST_VER_SOL_OPEN
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_OPEN Macro

PVS_GUEST_VER_SOL_OPEN Macro
PVS_GUEST Macros

OpenSolaris

Syntax
#define PVS_GUEST_VER_SOL_OPEN 0x0E04 // OpenSolaris
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_SOL_OTHER Macro

PVS_GUEST_VER_SOL_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_SOL_OTHER 0x0EFF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_TRUSTED_BSD Macro

PVS_GUEST_VER_TRUSTED_BSD Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_TRUSTED_BSD 0x0A09
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_2K Macro

PVS_GUEST_VER_WIN_2K Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_2K 0x0806
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_95 Macro

PVS_GUEST_VER_WIN_95 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_95 0x0802
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_98 Macro

PVS_GUEST_VER_WIN_98 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_98 0x0803
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_311 Macro

PVS_GUEST_VER_WIN_311 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_311 0x0801
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_2003 Macro

PVS_GUEST_VER_WIN_2003 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_2003 0x0808
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_2008 Macro

PVS_GUEST_VER_WIN_2008 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_2008 0x080A
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_2012 Macro

PVS_GUEST_VER_WIN_2012 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_2012 0x080D
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_LAST Macro

PVS_GUEST_VER_WIN_LAST Macro
PVS_GUEST Macros

Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST

Syntax
#define PVS_GUEST_VER_WIN_LAST PVS_GUEST_VER_WIN_WINDOWS_10
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_ME Macro

PVS_GUEST_VER_WIN_ME Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_ME 0x0804
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_NT Macro

PVS_GUEST_VER_WIN_NT Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_NT 0x0805
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_OTHER Macro

PVS_GUEST_VER_WIN_OTHER Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_OTHER 0x08FF
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_VISTA Macro

PVS_GUEST_VER_WIN_VISTA Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_VISTA 0x0809
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_WINDOWS7 Macro

PVS_GUEST_VER_WIN_WINDOWS7 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_WINDOWS7 0x080B
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_WINDOWS8 Macro

PVS_GUEST_VER_WIN_WINDOWS8 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_WINDOWS8 0x080C
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_WINDOWS8_1 Macro

PVS_GUEST_VER_WIN_WINDOWS8_1 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_WINDOWS8_1 0x080E
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_WINDOWS_10 Macro

PVS_GUEST_VER_WIN_WINDOWS_10 Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_WINDOWS_10 0x080F
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_GUEST_VER_WIN_XP Macro

PVS_GUEST_VER_WIN_XP Macro
PVS_GUEST Macros
Syntax
#define PVS_GUEST_VER_WIN_XP 0x0807
File

PrlOses.h

Links
PVS_GUEST Macros


PVS_MAKE_GUEST_VER Macro

PVS_MAKE_GUEST_VER Macro
Other Macros
Syntax
#define PVS_MAKE_GUEST_VER(t,n) ((((t) << 8) & 0xff00) | ((n) & 0xff))
File

PrlOses.h

Links
Other Macros


SET_FS_EXECUTE_DISABLED Macro

SET_FS_EXECUTE_DISABLED Macro
Other Macros
Syntax
#define SET_FS_EXECUTE_DISABLED(x) (x) & ~FS_PERM_EXECUTE;
File

PrlFs.h

Links
Other Macros


SET_FS_EXECUTE_ENABLED Macro

SET_FS_EXECUTE_ENABLED Macro
Other Macros
Syntax
#define SET_FS_EXECUTE_ENABLED(x) (x) | FS_PERM_EXECUTE;
File

PrlFs.h

Links
Other Macros


SET_FS_READ_DISABLED Macro

SET_FS_READ_DISABLED Macro
Other Macros
Syntax
#define SET_FS_READ_DISABLED(x) (x) & ~FS_PERM_READ;
File

PrlFs.h

Links
Other Macros


SET_FS_READ_ENABLED Macro

SET_FS_READ_ENABLED Macro
Other Macros
Syntax
#define SET_FS_READ_ENABLED(x) (x) | FS_PERM_READ;
File

PrlFs.h

Links
Other Macros


SET_FS_WRITE_DISABLED Macro

SET_FS_WRITE_DISABLED Macro
Other Macros
Syntax
#define SET_FS_WRITE_DISABLED(x) (x) & ~FS_PERM_WRITE;
File

PrlFs.h

Links
Other Macros


SET_FS_WRITE_ENABLED Macro

SET_FS_WRITE_ENABLED Macro
Other Macros
Syntax
#define SET_FS_WRITE_ENABLED(x) (x) | FS_PERM_WRITE;
File

PrlFs.h

Links
Other Macros


Unknown or Unneeded

Unknown or Unneeded
Functions
Links
Functions


VIRTUAL_MACHINE_ADDITION_STATE Enumeration

VIRTUAL_MACHINE_ADDITION_STATE Enumeration
Other Structs

Virtual machine addition states enumeration, may be combined with bitwise

Syntax
typedef enum _VIRTUAL_MACHINE_ADDITION_STATE {
  VMAS_NOSTATE = 1<<0,
  VMAS_BACKUPING = 1<<1,
  VMAS_RESTORING_FROM_BACKUP = 1<<2,
  VMAS_ENCRYPTING = 1<<3,
  VMAS_DECRYPTING = 1<<4,
  VMAS_CLONING = 1<<5,
  VMAS_MOVING = 1<<6,
  VMAS_MAX = 1<<31
} VIRTUAL_MACHINE_ADDITION_STATE;
File

PrlEnums.h

Links
Other Structs


VIRTUAL_MACHINE_ADDITION_STATE_PTR Type

VIRTUAL_MACHINE_ADDITION_STATE_PTR Type
Other Types
Syntax
typedef VIRTUAL_MACHINE_ADDITION_STATE* VIRTUAL_MACHINE_ADDITION_STATE_PTR;
File

PrlEnums.h

Links
Other Types


VIRTUAL_MACHINE_STATE Enumeration

VIRTUAL_MACHINE_STATE Enumeration
Other Structs

Virtual machine states enumeration

Syntax
typedef enum _VIRTUAL_MACHINE_STATE {
  VMS_UNKNOWN = 0,
  VMS_STOPPED = 0x30000001,
  VMS_STARTING = 0x30000002,
  VMS_RESTORING = 0x30000003,
  VMS_RUNNING = 0x30000004,
  VMS_PAUSED = 0x30000005,
  VMS_SUSPENDING = 0x30000006,
  VMS_STOPPING = 0x30000007,
  VMS_COMPACTING = 0x30000008,
  VMS_SUSPENDED = 0x30000009,
  VMS_SNAPSHOTING = 0x3000000A,
  VMS_RESETTING = 0x3000000B,
  VMS_PAUSING = 0x3000000C,
  VMS_CONTINUING = 0x3000000D,
  VMS_MIGRATING = 0x3000000E,
  VMS_DELETING_STATE = 0x3000000F,
  VMS_RESUMING = 0x30000010,
  VMS_SUSPENDING_SYNC = 0x30000011,
  VMS_RECONNECTING = 0x30000012,
  VMS_MOUNTED = 0x30000013
} VIRTUAL_MACHINE_STATE;
File

PrlEnums.h

Links
Other Structs


VIRTUAL_MACHINE_STATE_PTR Type

VIRTUAL_MACHINE_STATE_PTR Type
Other Types
Syntax
typedef VIRTUAL_MACHINE_STATE* VIRTUAL_MACHINE_STATE_PTR;
File

PrlEnums.h

Links
Other Types