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Congratulations on purchasing Parallels Workstation. Now you can install and work with multiple 
operating systems together at the same time on your computer. 

Use this guide to quickly set up and start using Parallels Workstation. 

 

In This Chapter 

About Virtual Machines and Guest Operating Systems ............................................. 5 
What You Can Do .................................................................................................... 5 
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Welcome to Parallels Workstation 
 

About Virtual Machines and Guest Operating 
Systems 
To add an additional operating system to your computer, Parallels Workstation creates a "virtual 
machine," or a software implementation of a computer, inside your computer. You can install any 
supported operating system, or "guest OS," in the virtual machine. 

Just like with a regular computer, you can turn virtual machines on and off, configure them, and 
install and use programs. 

You can use Parallels Workstation to install several virtual machines, with various operating systems 
installed in them. 

In this guide, your actual computer and its operating system are sometimes referred to as the "host 
computer" and "host OS." 
 

What You Can Do 
With Parallels Workstation, you can: 

• Install and use 32-bit and 64-bit guest operating systems on your host computer 

• Easily share files, devices, and other resources between operating systems 

• Run host OS and guest OS programs seamlessly on one desktop 

• Copy and paste text and drag and drop objects between host OS and guest OS programs 

• Transfer the operating system and all your data from a remote Windows or Linux computer and 
use them on your host computer 

• If you have Parallels Workstation Extreme and your computer supports Intel VT-d, assign 
physical PCI Express (PCIe) devices directly to virtual machines 

• And much more 
 



 

 

Follow the instructions in this chapter to install and activate Parallels Workstation. 

In This Chapter 

What You Need........................................................................................................ 7 
Install Parallels Workstation ...................................................................................... 9 
Activate and Register Parallels Workstation .............................................................. 12 
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Install Parallels Workstation 
 

What You Need 
To install and set up Parallels Workstation 6, you need: 

A computer with: 

• Minimum 1.66 GHz x86 (32-bit) or x64 (64-bit) CPU. 

To run 64-bit guest operating systems, you need a processor that supports the Intel VT-x 
hardware virtualization technology. 

To assign PCI Express (PCIe) devices directly to your virtual machines (Parallels Workstation 
Extreme only), you need a processor that supports the Intel VT-d technology. 

The support for Intel VT-x and VT-d may be disabled by default in some computers that actually 
support them. To enable these features, in most cases enter BIOS, go to System Settings > 
Virtualization Support, and select the Enable Intel Virtualization and Enable Intel VT for 
Direct I/O check boxes. 

For detailed information on enabling the Intel VT-x and VT-d features in BIOS, refer to the OEM 
supplier's documentation. 

Important: VT-d features are supported by Parallels Workstation Extreme only. 

• 2 GB RAM minimum. 4 GB RAM or more is recommended. 

The recommended amount of memory assigned to a virtual machine is 1-2 GB. You can assign 
up to 8 GB of RAM if Parallels Workstation is installed in the 32-bit host OS and up to 64 GB if 
in the 64-bit. 

• 350 MB of hard disk space for the Parallels Workstation installation. 

• About 30 GB of hard disk space for each virtual machine. 

To store a virtual machine's temporary files, you need to have twice as much free disk space as 
the overall amount of this virtual machine's memory: (memory + video memory) +150 MB. 

• DVD-ROM drive. 

• Ethernet network adapter. 

If you want to use a directly connected PCIe video card in your virtual machine, you need: 

• Two PCIe video cards. One video card for your host computer and the other – for the virtual 
machine. 

Parallels Workstation officially supports the NVIDIA Quadro® FX 1800, 3800, 4800, 5800, 
Q4000, Q5000, (Q2000? and Q6000?) video cards for virtual machines. For these video cards, 
use the latest drivers (starting from 182.65 for Windows and 180.51 for Linux ?) available on the 
manufacturer's website. 
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Direct assignment of PCIe video cards requires an NVIDIA Video BIOS version of 
62.00.62.00.01 or later. If you have a supported video card which does not have this BIOS 
level, please contact your OEM supplier. 

Software Requirements 

Parallels Workstation 6 officially supports the following host operating systems: 

Host Operating Systems 32-
bit 

64-
bit 

Windows 7   

Windows Vista SP1, SP2   

Windows XP Pro SP3   

Windows XP Home SP3   

Windows XP Pro SP2   

Debian 6.0   

Fedora 14, 15   

RHEL 6, 6.1   

SLED 11 SP1   

Ubuntu 10.10, 11.04, 11.10   

Parallels Workstation 6 Extreme officially supports the following host operating systems: 

Host Operating Systems 32-
bit 

64-
bit 

Windows 7   

Windows Vista SP2   

Windows XP SP2   

RHEL 5.7, 6, 6.1   

In Linux operating systems, make sure the following software packages are installed: 

• kernel development packages 
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Note: In RedHat-based systems, such packages are called kernel-<kernel_version>-devel, in 
Debian-based systems - linux-headers-<kernel_version>. 

• gcc of the version with which the host kernel was compiled 

• 32-bit version of glibc 2.3.6 or later 

• make or gmake 

• the 32-bit version of the alsa-plugins-pulseaudio package in the Fedora 10 (64-bit) operating 
system 

For 64-bit systems, it is also desired to have 32-bit alsa-lib installed in RedHat-based systems or 
lib32asound in Debian-based systems. 

If you do not have any of the aforementioned packages installed on your Linux-based physical 
computer, the Parallels Workstation installer tries to install it automatically. 
 

Install Parallels Workstation 
Before installing Parallels Workstation, make sure your computer meets the system requirements. 
 

Install Parallels Workstation in Windows 

You can be up and running with Parallels Workstation in a few easy steps. 

Note: To install Parallels Workstation in Windows, you must have administrator's rights. 

To install Parallels Workstation: 

1 Locate the Parallels Workstation setup file (ParallelsWorkstation-parallels-en_US-
6.0.xxxxx.xxxxxx.exe) and double-click it. You can find this file: 

• On the Parallels Workstation installation disc included with the boxed version of Parallels 
Workstation 

• On the Parallels website 

2 If your computer is connected to the Internet, Parallels Workstation checks for available 
updates. If an update is available, click "Download and Install New Version" to get the latest 
version of Parallels Workstation. 

3 Follow the onscreen instructions to install Parallels Workstation. 

Note: When you're presented with information about the Parallels Customer Experience program, you 
can choose whether you want to participate. If you choose not to, you can join the program later using 
the Feedback pane of Parallels Workstation Preferences. 
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Install Parallels Workstation in Linux 

Before installing Parallels Workstation on a Linux computer, make sure that the packages and 
libraries listed in the system requirements (p. 7) for Linux host operating systems are installed in 
your system. 

Note: You must have the root privileges to be able to install Parallels Workstation in a Linux operating 
system. 

To install Parallels Workstation in Linux, you need a RUN installation package. It is available on the 
Parallels Workstation installation disc included in the boxed version of Parallels Workstation or can 
be downloaded from the Parallels website. 

To install Parallels Workstation in Linux: 

1 Disable SELinux in the host operating system (you can enable it again after the installation is 
complete). For the detailed information on how to do this, please refer to your Linux distribution 
documentation and/or support resources. 

2 Locate the .run installation package in a terminal and make sure it is executable. To do this, 
use the following command: 

# chmod +x parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run 

where parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run is the 
name of your .run installation package. 

3 Start the Parallels Workstation installation by executing the following command: 
# ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run 

4 Parallels Workstation connects to the Parallels update server and checks for available updates. 
If there is a newer version of Parallels Workstation available, you will be offered to install the 
most recent version of Parallels Workstation. If you do not want to install the most recent 
version, you can choose to install the version from the installation media. 

Note: If the host computer is accessing the Internet only via a proxy server, configure the proxy server 
settings to allow Parallels Workstation to check for available updates during the installation process. For 
more information on how to configure the proxy server settings, refer to the corresponding subsection 
below. 

If there are no updates available or your host computer is not connected to the Internet, 
Parallels Workstation will be installed from the current installation source. 

5 Parallels Workstation Installer starts. In the Welcome screen, click Next. 

6 In the License Agreement screen, read the license agreement scrolling it by pressing 
Spacebar on your keyboard. To accept the agreement, click the Accept button. 

7 In the CEP Agreement screen, you can choose to participate in the program that will help us 
improve Parallels Workstation according to your experience. Read carefully the information 
about the program and click the Agree button if you want to participate in it. Otherwise click 
Disagree. 
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8 When the installation is complete, click Exit. 

9 To exit the terminal, enter: 
exit 

Configure Proxy Server Settings 

If the host computer is accessing the Internet only via a proxy server, you should configure the 
proxy server settings to allow Parallels Workstation to check for available updates during the 
installation process. To this effect, start the Parallels Workstation installation as follows: 

1 Execute the following command to start the installation: 
sudo ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run -- -p 
proxy_server_host_name:port 

or 
sudo ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run -- -p ip_address:port 

where proxy_server_host_name stands for the proxy server host name, ip_address 
stands for the proxy server IP address, and port stands for the proxy server port. 

2 Continue the installation as it was described above. 

If the proxy-server requires authentication, you will be prompted to enter your name and 
password in one of the steps. 
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Activate and Register Parallels Workstation 

Activate Parallels Workstation 

Once the installation is finished, you must activate Parallels Workstation to use all of its features. 

1 Open Parallels Workstation. 

2 Click Activate Product. 

3 Enter your Product Activation Key. 

Note: If you bypass the activation dialog, you can activate Parallels Workstation later by choosing Help 
> Activate product and entering your Product Activation Key. 

If You Don't Have A Product Activation Key 

If you don't have a key already, you can get one by choosing Help > Activate Product. Then, to 
get a free trial Product Activation Key so you can try out Parallels Workstation for a limited time, 
click obtain a free trial activation key. Or to purchase a key that lets you use Parallels 
Workstation permanently, click purchase a permanent activation key. 

Registering Parallels Workstation 

During installation, you're presented with the opportunity to register Parallels Workstation. 
Registering allows you to: 

• Download and install the latest Parallels Workstation updates. 

• Create a backup copy of the product key on the Parallels web server and restore it at any time. 

• Easily contact the Parallels support team, using the support code. 

• Stay informed about Parallels news and announcements. 

Note: If you choose not to register Parallels Workstation during installation, you can register anytime by 
choosing Help > Register product when the program is open. 

 



 

 

There are a few ways you can get started using one or more guest operating systems alongside the 
host operating system: 

• Install a new guest operating system in a Parallels Workstation virtual machine from a disc or 
image 

• Import a virtual machine from a previous version of Parallels Workstation or from VMware, 
Microsoft Virtual PC, or VirtualBox 

• Transfer an operating system and all your data from a remote PC to a Parallels Workstation 
virtual machine on your host computer 

Read on to learn how. 

In This Chapter 

Supported Guest Operating Systems ....................................................................... 14 
Install a Guest OS from a Disc or Image ................................................................... 15 
Import from an Earlier Parallels Workstation or Other Virtualization Application.......... 16 
Import Your Data from a PC ..................................................................................... 17 
Install and Update Parallels Tools ............................................................................. 18 
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Supported Guest Operating Systems 
Parallels Workstation 6 officially supports the following guest operating systems: 

Guest Operating Systems 32-
bit 

64-
bit 

Express 
installation 

Windows 7    

Windows Vista SP1, SP2    

Windows XP Pro SP3    

Windows XP Home SP3    

Windows XP Pro SP2    

Debian 6.0    

Fedora 14, 15    

OpenSUSE 11.1    

RHEL 6, 6.1    

SLED 11 SP1    

Ubuntu 10.10, 11.04, 11.10    

Parallels Workstation 6 Extreme officially supports the following guest operating systems: 

Guest Operating Systems 32-
bit 

64-
bit 

Express 
installation 

Windows 7    

Windows Vista SP2    

Windows XP SP3    

Windows XP SP2    

Fedora 14, 15    

RHEL 5.7, 6, 6.1    
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Install a Guest OS from a Disc or Image 
If this is your first time using Parallels Workstation, or if you simply want to start with a fresh 
installation, you can install any supported guest operating system into a new Parallels Workstation 
virtual machine. 

You need one of the following: 

• An operating system installation disc 

• An image file of such an installation disc 

You can use any of the following modes to install a guest OS: 

• Express Windows. Installs Windows 7, Vista, or XP and Parallels Tools (software that makes 
your work with the guest operating system as seamless as possible) automatically. 

• Typical. Creates a virtual machine with a typical configuration for the selected guest OS. 

• Custom. Allows you to customize the virtual machine configuration while creating it. 

This guide provides you with the instructions on how to create a virtual machine and install a guest 
OS in the Typical mode. For the instructions on creating virtual machines in the Custom or Express 
Windows modes, refer to the Parallels Workstation User's Guide. 

To create a typical virtual machine: 

1 Start Parallels Workstation: 

• In Windows: Choose Start > All programs > Parallels > Parallels Workstation Extreme > 
Parallels Workstation Extreme. 

• In Linux: Choose System Tools > Parallels Workstation from the Applications menu. 

2 In the Parallels Workstation window click Create a New Virtual Machine or choose File > 
New. 

3 Do one of the following: 

• If you're installing from a disc, insert the disc. 

• If you're installing from an image file on another hard disk, connect the disk to the host 
computer. 

4 Select the operating system you want to install. 

5 In the Virtual Machine Type window, select Typical and click Next. 

6 Click Choose and specify where you want to store the virtual machine. 

By default, Parallels Workstation stores the virtual machine in your Documents > My 
Parallels folder. 

When ready, click Next. The wizard creates a virtual machine. 
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7 In the Install Operating System window, select the source of the installation files from the 
Source menu. 

8 Click Start to begin installing the guest operating system in the virtual machine or click Done if 
you want to install it later. 

 

Import from an Earlier Parallels Workstation or 
Other Virtualization Application 
If you already have a virtual machine stored on the host computer but it is missing from the list of 
virtual machines registered in Parallels Workstation, you can easily add it. 

To add an existing virtual machine 

1 Choose File > Add Existing. 

2 Locate the virtual machines you want to add by doing one of the following: 

• To add a specific virtual machine's configuration file (config.pvs), select Add a specific 
virtual machine and type the path in the File field, or click the Choose button and navigate 
to the file you want. Then click Next. 

• To find all virtual machines in a specific folder, select Search for virtual machines in this 
folder. Then type the path to the folder you want in the Start from field, or click the Choose 
button and navigate to the folder. Then click Search. 
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3 If you chose Search for virtual machines in this folder, in the next window the wizard 
displays all the virtual machines found in the specified folder that are not registered in Parallels 
Workstation. Select the virtual machines you want to add. 

To select all items at a time, click the Select All button  displayed below the list. 

To clear all items at a time, click the Clear All button  displayed below the list. 

Review the selection and click Add. 

 
 

Import Your Data from a PC 
Parallels Transporter allows you to import all your data from a remote PC to Parallels Workstation 
on the host computer. Then you can continue to work with all your programs, files, and data, side-
by-side with the host OS. 

To learn how to work with Parallels Transporter, please refer to Parallels Transporter 
User's Guide available on the Parallels website. 
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Install and Update Parallels Tools 
Parallels Tools are a set of utilities that help you use guest operating systems in the most 
comfortable and cohesive way. For example, with Parallels Tools you can move the mouse 
seamlessly between your host and guest operating systems, change the virtual machine's screen 
resolution by simply resizing its window, view synchronized time and date settings between your 
host and guest operating systems, and more. 

If you installed a Windows guest operating system using Express Installation, Parallels Tools were 
installed automatically and you don't have to do anything else. Otherwise, it's recommended that 
you install Parallels Tools to get the most out of Parallels Workstation. 

To install or update Parallels Tools: 

1 Start the virtual machine in which you want to install Parallels Tools and log in to the guest 
operating system. 

2 Choose Virtual Machine > Install Parallels Tools to install Parallels Tools for the first time, or 
Virtual Machine > Update Parallels Tools to update to the latest version. 

Note: If the Install Parallels Tools option is unavailable, Parallels Tools may not support your guest 
operating system. To see the list of guest operating systems supported by Parallels Tools, choose Help 
> Parallels Workstation Help and see the Parallels Tools Overview section. 

The Parallels Tools installation wizard opens. 

3 Click Install. 

4 When the installation is complete, click Reboot to restart the virtual machine. 

For detailed information about Parallels Tools, choose Help > Parallels Workstation Help. 

 



 

 

Read this chapter to learn the basics of using a guest operating system on your host computer. 

In This Chapter 

Start Up and Shut Down a Guest OS ....................................................................... 19 
Set the View Mode ................................................................................................... 20 
Install Programs in a Guest Operating System.......................................................... 21 
Save a Snapshot of a Virtual Machine....................................................................... 22 
 
 

Start Up and Shut Down a Guest OS 

Start a Guest OS 

1 In Parallels Workstation, select the virtual machine with the guest OS you want to start. 

2 Choose Start from the Virtual Machine menu. 

Shutting Down a guest OS 

You can shut down the guest operating system the way you would normally shut it down. For 
example, in Windows choose Shut Down from the Start menu. 

You can also choose an option from the Virtual Machine State menu  at the bottom of the 
Parallels Workstation window: 
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• Choose Suspend to freeze the guest operating system in its current state. You can safely quit 
Parallels Workstation, open it again later, and resume everything right from where you left off. 

• Choose Pause to stop using the guest operating system and allow its resources to be used by 
the host computer or other virtual machines. 

• Choose Shut Down to shut down the guest operating system the way it would normally shut 
down. 

• Choose Stop to stop the guest operating system without going through the normal shut down 
procedures. Stopping a virtual machine is like unplugging a computer while it is running. None 
of your data is saved. 

 

Set the View Mode 
While running a guest operating system you can switch between the following view modes: 

• Window mode. The guest operating system desktop and its programs appear together in a 
separate window. This is the default view mode. 

• Full Screen mode. The guest operating system is expanded to occupy the whole of your 
physical computer's screen. The host operating system is hidden. 

• Coherence mode. Programs from the guest and host operating systems appear together on 
the host OS desktop. The desktop of the guest operating system is invisible. 

Note: The Coherence view mode is available only for Windows 7/Vista/XP guest operating systems with 
Parallels Tools installed (p. 18). 

To switch a virtual machine working in the Window view mode to any other view mode, use the 
View Mode menu in the lower right corner of the virtual machine window. 

 

Note: You can change the virtual machine view mode only when the virtual machine is running. 
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Install Programs in a Guest Operating System 
You can install programs in a guest OS using the following media: 

• CD and DVD discs 

• Images of CD or DVD discs made with the help of third-party imaging products 

Note: Parallels Workstation supports ISO image files. 

To install a program using a CD or DVD disc: 

1 Insert the disc. 

2 Do one of the following: 

• Click the CD/DVD icon  in the virtual machine status bar and choose Real CD/DVD from 
the shortcut menu. 

• Choose CD/DVD 1 > Real CD/DVD from the Devices menu. 

To use an image of a disc: 

3 Do one of the following: 

• Click the CD/DVD icon  in the virtual machine status bar and choose Connect Image 
from the shortcut menu. 

• Choose CD/DVD 1 > Connect Image from the Devices menu. 

4 Specify the image file. 

For further installation steps, refer to the documentation of the program you are installing. 
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Save a Snapshot of a Virtual Machine 
A snapshot is a saved state of a virtual machine. After you save a snapshot, you can continue 
working with the virtual machine and revert to the snapshot at any time. All of your settings and 
data revert to the saved state. 

You can create a snapshot when the virtual machine is running, paused, or stopped. 

To save a snapshot: 

1 Choose Virtual Machine > Take Snapshot. 

2 Type a name for the snapshot and, if desired, provide a short description. 

To access the snapshot, choose Virtual Machine > Manage Snapshots. 

For more information about snapshots, choose Help > Parallels Workstation Help and search for 
"snapshots." 

 



 

 

For detailed instructions on how to use all the features of Parallels Workstation, see the Parallels 
Workstation User's Guide, available online. 

To download the Parallels Workstation User's Guide: 

1 In Parallels Workstation, choose Help > Online Documentation (you must be connected to the 
Internet). 

A web page opens with access to all of the Parallels Workstation manuals. 

2 Click the PDF link next to Parallels Workstation User's Guide. 

In the Parallels Workstation Users Guide, you can find information on things like: 

• Sharing files 

• Connecting devices 

• Configuring virtual machine settings 

• Configuring network settings 

• Protecting your virtual machines 

• Optimizing virtual machines 

• And much more 

There are also many other ways to get help and information on using Parallels Workstation: 

• Parallels Workstation Help: For detailed instructions on using all of the Parallels Workstation 
features, open Parallels Workstation and choose Help > Parallels Workstation Help. This 
resource has all of the same information as the Parallels Workstation User's Guide.  

• Context-sensitive help: In Windows, press F1 to get information relating the active window. 

• Parallels Command Line Reference Guide: This document, available on the Parallels Online 
documentation page, has information on using the prlctl command line utility to manage 
Parallels Workstation and its virtual machines from a terminal. 

• Parallels API references and the SDK programmer's guide: These guides for IT-
professionals can be found on the Parallels Online documentation page. 

• Parallels support website: The Parallels support website (http://www.parallels.com/support/) 
includes product help files and a FAQ section. 

• Parallels Knowledge Base: This online resource (http://kb.parallels.com/) comprises valuable 
articles about using Parallels Workstation and other Parallels products. 
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• Parallels forums: The Parallels forums 
(http://forum.swsoft.com/forumdisplay.php?s=&forumid=239) are a great place to search for 
answers, post questions, or answer other users' questions. 

Feedback 

Parallels welcomes your feedback on how to make our documentation more helpful. You can 
submit feedback using the Documentation Feedback form on our website 
(http://www.parallels.com/en/support/usersdoc/). 

 

http://forum.swsoft.com/forumdisplay.php?s=&forumid=239�
http://www.parallels.com/en/support/usersdoc/�
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