About This Guide

Parallels C API Reference Guide
About This Guide
Send Feedback

This document is a part of the Parallels Virtualization SDK. It contains a detailed Parallels C API reference including information about handles (objects), functions, types, structures, enumerations, and other technical information.

Please note that this document does not provide general information on how to use the Parallels Virtualization SDK. For a detailed explanation of how to start using the SDK and how to create your own programs using the provided APIs, please read the Parallels Virtualization SDK Programmer's Guide, which is a companion book to this one.

To understand the material provided in this guide, you should have a basic knowledge of the ANSI C programming language and some experience working with application programming interfaces (API) written in C. You should also be familiar with one of the Parallels virtualization products, such as Parallels Server, Parallels Desktop, or Parallels Workstation.

Copyright (c) 1999-2008 Parallels Software International Inc.
Contents | Index
What do you think about this topic? Send feedback!


Organization of This Guide

Organization of This Guide
Send Feedback

This guide is organized into the following chapters:

Functions by Handle. Contains sections describing handles, each of which contains a list of functions that can operate on that handle. Each section contains information about the purpose of a handle and how to obtain a reference to it. Function subsections contain the usual reference information such as syntax, parameters, return codes, and remarks. You can search the guide for a specific function or a keyword or you can scroll through the handle list, find the handle providing the functionality of interest, and then look for a specific function in its function list.

Common Functions. Contains information about common and system functions.

Remote Desktop Access. Contains information about functions that can be used to remotely capture screenshots of a virtual machine desktop and to send keyboard and mouse commands to it.

Types. Contains a list of types used throughout the API.

Structs, Records, Enums. Contains information about structures, records, and enumerations used throughout the API.

Macros. Describes macros used in the API.

Callback Prototypes. Describes callback function prototypes that are used to implement your own callback functions for use in asynchronous calls.

Files. Contains a list of the Parallels C API header files. You can look at individual files in this chapter and see the functions, types (etc.) that they contain.


How to Use This Guide

How to Use This Guide
Send Feedback

As a demonstration, let's select a task and see how we can use this guide to find the technical information that will help us to implement it. We will use the task of starting a virtual machine. Follow these steps:

  1. Everything in the Parallels C API begins with a handle. If you want to perform a task, you need to know the name of the handle that provides the corresponding functionality (you can browse the Functions by Handle chapter and read the summary for each handle). In our case, the name of the handle is PHT_VIRTUAL_MACHINE.
  2. Read the handle description and find the information about how to obtain it. That's what it says: "A handle is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function." Follow the link to the PrlSrv_GetVmList function.
  3. When the topic describing the PrlSrv_GetVmList function displays, you will see a detailed description of the function and a sample demonstrating how to use it. The function accepts a handle of type PHT_SERVER as parameter. Follow its link to see how it is obtained (or see the included code sample). The PHT_JOB object that the PrlSrv_GetVmList function returns will contain the PHT_VIRTUAL_MACHINE handle that we want. The information on how to extract the handle from the Job object is included in the function description. You can also follow the PHT_JOB link and see more info about it if you wish.
  4. Now that you know how to obtain the PHT_VIRTUAL_MACHINE handle, go back to its topic (use the document viewer options or click the link if it's available on the current page).
  5. In the PHT_VIRTUAL_MACHINE function list, find the PrlVm_Start function (functions are listed alphabetically). This is the function that starts a virtual machine. Follow its link and see the syntax, parameters, and return codes. As you can see, the function accepts a single parameter, which is a handle of type PHT_VIRTUAL_MACHINE that we've obtained in the previous steps. You now have all the information needed to implement the task in your program.

Once again, if you are just starting with the Parallels Virtualization SDK, your best source of information is Parallels Virtualization SDK Programmer's Guide. It explain the concepts and provides descriptions and step-by-step instructions on how to use the API to perform the most common tasks. Once you are familiar with the basic principles of the SDK design, you will find it very easy to work with both guides and the API itself.


Functions by Handle

Functions by Handle
Topics Send Feedback

This chapter contains a list of handles. Each section describes a handle and contains subsections describing functions that can operate on the handle. Handle types are defined in the PRL_HANDLE_TYPE enumeration.

Topics
Name | Description
PHT_ACCESS_RIGHTS | The PHT_ACCESS_RIGHTS handle is a container containing the virtual machine access rights information.
PHT_BOOT_DEVICE | The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.
PHT_DISP_CONFIG | The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.
PHT_DISP_NET_ADAPTER | The PHT_DISP_NET_ADAPTER handle is used to manage virtual network adapters. The handle is obtained by calling the PrlDispCfg_GetDispNet or the PrlDispCfg_CreateDispNet function.
PHT_EVENT | The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.
PHT_EVENT_PARAMETER | The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.
PHT_FOUND_VM_INFO | The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.
PHT_HW_GENERIC_DEVICE | PHT_HW_GENERIC_DEVICE is a base object that provides methods for getting information about physical devices on the host machine.
PHT_HW_HARD_DISK | The PHT_HW_HARD_DISK handle provides methods for getting the information about a physical hard disk on the host machine. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional device management methods.
PHT_HW_HARD_DISK_PARTITION | The PHT_HW_HARD_DISK_PARTITION handle provides methods for getting the information about a physical hard disk partition. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional device management methods.
PHT_HW_NET_ADAPTER | The PHT_HW_NET_ADAPTER handle provides methods for getting the information about a network adapter on the host or in a virtual machine as seen by the guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional device management methods.
PHT_JOB | The PHT_JOB handle provides methods for managing asynchronous operations.
PHT_LICENSE | The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.
PHT_LOGIN_RESPONSE | The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.
PHT_NET_SERVICE_STATUS | The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.
PHT_PORT_FORWARDING | The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP port on the host machine to a specified port on a specified virtual machine.
PHT_REMOTE_FILESYSTEM_ENTRY | The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.
PHT_REMOTE_FILESYSTEM_INFO | The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.
PHT_RESULT | The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.
PHT_RUNNING_TASK | The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.
PHT_SERVER | At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.
PHT_SERVER_CONFIG | The PHT_SERVER_CONFIG handle is used to retrieve the host configuration information and some of the virtual machine configuration parameters as seen by the operating system running on a virtual machine. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call.
PHT_SERVER_INFO | The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.
PHT_SHARE | The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.
PHT_STRINGS_LIST | The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.
PHT_SYSTEM_STATISTICS | The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.
PHT_SYSTEM_STATISTICS_CPU | The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.
PHT_SYSTEM_STATISTICS_DISK | The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.
PHT_SYSTEM_STATISTICS_DISK_PARTITION | The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.
PHT_SYSTEM_STATISTICS_IFACE | The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.
PHT_SYSTEM_STATISTICS_PROCESS | The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.
PHT_SYSTEM_STATISTICS_USER_SESSION | The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.
PHT_USER_INFO | The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.
PHT_USER_PROFILE | The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.
PHT_VIRTUAL_DEV_FLOPPY | The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.
PHT_VIRTUAL_DEV_HARD_DISK | The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.
PHT_VIRTUAL_DEV_HD_PARTITION | The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.
PHT_VIRTUAL_DEV_NET_ADAPTER | The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.
PHT_VIRTUAL_DEV_OPTICAL_DISK | The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.
PHT_VIRTUAL_DEV_PARALLEL_PORT | The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.
PHT_VIRTUAL_DEV_SERIAL_PORT | The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.
PHT_VIRTUAL_DEV_SOUND | The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.
PHT_VIRTUAL_DEV_USB_DEVICE | The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.
PHT_VIRTUAL_DISK | The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files. There's a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and there are files that are used for data storage. Once created, a virtual disk can be attached to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk... more
PHT_VIRTUAL_MACHINE | PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.
PHT_VIRTUAL_NETWORK | The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.
PHT_VM_CONFIGURATION | The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.
PHT_VM_GUEST_SESSION | The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
PHT_VM_INFO | The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.
PHT_VM_TOOLS_INFO | The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.
Links
Topics


PHT_ACCESS_RIGHTS

PHT_ACCESS_RIGHTS
Functions Functions by Handle Legend Send Feedback

The PHT_ACCESS_RIGHTS handle is a container containing the virtual machine access rights information.

Description

By default, only the owner of a virtual machine has full access to it. All other users are completely unaware of the machine (it will not even appear in the list of the available virtual machines for them). The owner of the virtual machine can change that by setting the virtual machine access rights for other users. The access rights include no access, view, run, full access (see PRL_VM_ACCESS_FOR_OTHERS for a complete list).

The PHT_ACCESS_RIGHTS handle is obtained by calling the PrlVmCfg_GetAccessRights or the PrlVmInfo_GetAccessRights function. An object returned by either function will contain access rights information for a specific virtual machine. You can use either function to obtain a handle depending on the application logic.

Functions
Name | Description
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.
Links
Functions, Functions by Handle, Legend


PHT_BOOT_DEVICE

PHT_BOOT_DEVICE
Functions Functions by Handle Legend Send Feedback

The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.

Description

A virtual machine can boot from a variety of devices, such as hard disk drives, floppy drives, removable drives, network interfaces etc. The PHT_BOOT_DEVICE object provides functions that can be used to obtain the information about and to modify a device in the boot priority list.

Each device in the boot priority list is uniquely identified by type (see PRL_DEVICE_TYPE) and index (a numeric ID). This allows to include more than one device of a particular type in the list, such as more than one hard drive for example. Please note that each virtual device has an index assigned to it in the main virtual machine configuration. The same index is used to identify a device in the boot priority list.

The position of the device in the list is determined by a sequence index assigned to it, starting from 0 and up. The highest boot priority index (the first device to boot from) is 0.

When creating a virtual machine using a default configuration, the boot device priority list is configured automatically.

Note: Any boot device list modification must begin with the PrlVm_BeginEdit and end with the PrlVm_Commit call. These two functions are used to detect collisions with other clients trying to make similar modifications to the same virtual machine. See PrlBootDev_SetSequenceIndex for code sample.
Functions
Name | Description
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.
Links
Functions, Functions by Handle, Legend


PHT_DISP_CONFIG

PHT_DISP_CONFIG
Functions Functions by Handle Legend Send Feedback

The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.

Description

Parallels Service preferences include memory, network, default virtual machine folder, and some other settings. The following describes how to modify the memory and network settings as a demonstration of the handle usage.

First, you have to obtain a handle of type PHT_DISP_CONFIG by making the PrlSrv_GetCommonPrefs function call.

To make the memory modification:

  1. Call PrlSrv_CommonPrefsBeginEdit to mark the beginning of the operation.
  2. Call one or more of the memory management functions from the PHT_DISP_CONFIG group to modify the desired settings.
  3. Call PrlSrv_CommonPrefsCommit to save the changes to the Parallels Service configuration.

The network adapter changes are performed outside of the begin/commit block. To modify an existing or to create a new virtual network adapter, use the following steps:

  1. First, obtain a handle of type PHT_DISP_NET_ADAPTER by calling the PrlDispCfg_GetDispNet or the PrlDispCfg_CreateDispNet function. The first function obtains a handle to an existing adapter and is used when modifying an adapter. The second function creates and returns a new handle and is used when adding a new virtual adapter to the Parallels Service configuration.
  2. Populate or modify the necessary network adapter properties using functions from the PHT_DISP_NET_ADAPTER group.
  3. If you are creating a new adapter, call PrlSrv_AddNetAdapter to add the adapter to the Parallels Service configuration. If you are modifying an existing adapter, call PrlSrv_UpdateNetAdapter to save the changes. If you would like to delete an adapter from the Parallels Service configuration, call the PrlSrv_DeleteNetAdapter function.
Functions
Name | Description
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_CreateDispNet | Creates a new virtual network adapter object and adds it to the network adapters list.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetDispNet | Obtains information about a virtual network adapter from the Parallels Service configuration.
PrlDispCfg_GetDispNetCount | Determines the total number of the virtual network adapters in the Parallels Service configuration.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.
Links
Functions, Functions by Handle, Legend


PHT_DISP_NET_ADAPTER

PHT_DISP_NET_ADAPTER
Functions Functions by Handle Legend Send Feedback

The PHT_DISP_NET_ADAPTER handle is used to manage virtual network adapters. The handle is obtained by calling the PrlDispCfg_GetDispNet or the PrlDispCfg_CreateDispNet function.

Functions
Name | Description
PrlDispNet_GetDhcpScopeEndIp | Returns the end IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeMask | Returns the subnet mask of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeStartIp | Returns the start IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetIndex | Returns the index identifying the specified adapter on the Parallels Service.
PrlDispNet_GetName | Returns the name of the specified virtual network adapter.
PrlDispNet_GetNetworkType | Returns the virtual network adapter network type (host-only or shared).
PrlDispNet_GetSysName | Returns the name of the physical network adapter to which the specified virtual network adapter is bound.
PrlDispNet_GetUuid | Returns the specified virtual network adapter UUID.
PrlDispNet_IsDhcpEnabled | Determines if DHCP scope is enabled for the specified virtual network adapter.
PrlDispNet_IsEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlDispNet_Remove | Removes the specified virtual network adapter object from memory.
PrlDispNet_SetDhcpEnabled | Allows to enable or disable the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeEndIp | Sets the end IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeMask | Sets the subnet mask of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeStartIp | Sets the start IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetEnabled | Allows to enable or disable a specified virtual network adapter.
PrlDispNet_SetIndex | Sets the specified virtual network adapter index (from 0 to 5).
PrlDispNet_SetName | Sets the specified virtual network adapter name.
PrlDispNet_SetNetworkType | Allows to set a network type for the specified virtual network adapter.
PrlDispNet_SetSysName | Sets the specified virtual network adapter system name.
Links
Functions, Functions by Handle, Legend


PHT_EVENT

PHT_EVENT
Functions Functions by Handle Legend Send Feedback

The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.

Description

When the PHT_EVENT object is used as an event data container, a handle to it is obtained through callback functionality (a handle is passed as a parameter to a callback function). When the object is used as an extended error information container in asynchronous functions, a handle to it is obtained from the PHT_JOB object returned by a function by calling the PrlJob_GetError function.

The common steps in processing an event in a callback function are as follows:

  1. Determine the type of the event by calling the PrlEvent_GetType function passing the event handle to it. The event types are defined in the PRL_EVENT_TYPE enumeration. This will tell you what happened on the Parallels Service side. For example, a virtual machine state has changed, the host configuration has been updated, etc.
  2. Determine the event source by calling the PrlEvent_GetIssuerType function. The function returns the event issuer type that you can look up in the PRL_EVENT_ISSUER_TYPE enumeration. This will tell you if the event was generated by the host, a virtual machine, a web service, etc.
  3. If an event was generated by the Parallels Service or a virtual machine, you can obtain the server or the virtual machine handle by using the PrlEvent_GetServer or the PrlEvent_GetVm function respectively. Depending on the event type, you may use a handle to access the Parallels Service or a virtual machine and perform some operations on them if needed.
  4. An event object may contain additional parameters, which can be retrieved from it using the PrlEvent_GetParam function. The function returns a handle of type PHT_EVENT_PARAMETER containing an individual parameter data. There may be multiple parameters in a given event object, so the function must be called once for each of the available parameters. To determine the number of parameters, use the PrlEvent_GetParamsCount function. Once you've obtained a PHT_EVENT_PARAMETER handle, you can use its functions to retrieve the parameter values.
Functions
Name | Description
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.
Links
Functions, Functions by Handle, Legend


PHT_EVENT_PARAMETER

PHT_EVENT_PARAMETER
Functions Functions by Handle Legend Send Feedback

The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.

Description

The event parameter container contains the following information:

  1. Parameter name. To retrieve the name, use the PrlEvtPrm_GetName function.
  2. Parameter data type. Depending on the event type, a parameter can be of any type defined in the PRL_PARAM_FIELD_DATA_TYPE_PTR enumeration. To retrieve the parameter data type, use the PrlEvtPrm_GetType function.
  3. Parameter value. Depending on the parameter data type, the value must be retrieved using an appropriate function from the PHT_EVENT_PARAMETER group (see the function list below). For example, a boolean value must be retrieved using the PrlEvtPrm_ToBoolean function, the string value must be retrieved using the PrlEvtPrm_ToString function, if a parameter contains a handle, it must be obtained using the PrlEvtPrm_ToHandle, etc. The meaning of the value is usually different for different event types.
Functions
Name | Description
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.
Links
Functions, Functions by Handle, Legend


PHT_FOUND_VM_INFO

PHT_FOUND_VM_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.

Functions
Name | Description
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.
Links
Functions, Functions by Handle, Legend


PHT_HW_GENERIC_DEVICE

PHT_HW_GENERIC_DEVICE
Functions Functions by Handle Legend Send Feedback

PHT_HW_GENERIC_DEVICE is a base object that provides methods for getting information about physical devices on the host machine.

Description

The object has descendants, each providing methods for managing a particular device type. The functions provided by the PHT_HW_GENERIC_DEVICE object can also be used with them. This basically means that any of the PHT_HW_GENERIC_DEVICE functions can accept a PRL_HANDLE of any type derived from the PHT_HW_GENERIC_DEVICE type.

The following is the list of objects that are derived from PHT_HW_GENERIC_DEVICE:

PHT_HW_HARD_DISK

PHT_HW_HARD_DISK_PARTITION

PHT_HW_NET_ADAPTER

Functions
Name | Description
PrlSrvCfgDev_GetId | Returns the system device ID.
PrlSrvCfgDev_GetName | Returns the system device name.
PrlSrvCfgDev_GetType | Returns the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to the virtual machine.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.
Links
Functions, Functions by Handle, Legend


PHT_HW_HARD_DISK

PHT_HW_HARD_DISK
Functions Functions by Handle Legend Send Feedback

The PHT_HW_HARD_DISK handle provides methods for getting the information about a physical hard disk on the host machine. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional device management methods.

Functions
Name | Description
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.
Links
Functions, Functions by Handle, Legend


PHT_HW_HARD_DISK_PARTITION

PHT_HW_HARD_DISK_PARTITION
Functions Functions by Handle Legend Send Feedback

The PHT_HW_HARD_DISK_PARTITION handle provides methods for getting the information about a physical hard disk partition. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional device management methods.

Functions
Name | Description
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.
Links
Functions, Functions by Handle, Legend


PHT_HW_NET_ADAPTER

PHT_HW_NET_ADAPTER
Functions Functions by Handle Legend Send Feedback

The PHT_HW_NET_ADAPTER handle provides methods for getting the information about a network adapter on the host or in a virtual machine as seen by the guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional device management methods.

Functions
Name | Description
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.
Links
Functions, Functions by Handle, Legend


PHT_JOB

PHT_JOB
Functions Functions by Handle Legend Send Feedback

The PHT_JOB handle provides methods for managing asynchronous operations.

Description

Every asynchronous function in the Parallels API returns a handle of type PHT_JOB. An asynchronous function returns immediately and the corresponding task is processed in a background thread. The returned job object is used as a reference to the job. While the operation is running, the job object can be used to find out the status of the operation, to get a progress report, or to cancel the job if needed. When the job completes, the job object is populated with the operation return code and the operation result (where applicable). The methods provided by the object can be used to extract this information. Once you are done processing the results, you must destroy the job object using the PrlHandle_Free function. For detailed information about jobs and asynchronous functions, please also see the Parallels Virtualization SDK Programmer's Guide.

Functions
Name | Description
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.
Links
Functions, Functions by Handle, Legend


PHT_LICENSE

PHT_LICENSE
Functions Functions by Handle Legend Send Feedback

The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.

Functions
Name | Description
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.
Links
Functions, Functions by Handle, Legend


PHT_LOGIN_RESPONSE

PHT_LOGIN_RESPONSE
Functions Functions by Handle Legend Send Feedback

The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.

Functions
Name | Description
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).
Links
Functions, Functions by Handle, Legend


PHT_NET_SERVICE_STATUS

PHT_NET_SERVICE_STATUS
Functions Functions by Handle Legend Send Feedback

The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.

Functions
Name | Description
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.
Links
Functions, Functions by Handle, Legend


PHT_PORT_FORWARDING

PHT_PORT_FORWARDING
Functions Functions by Handle Legend Send Feedback

The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP port on the host machine to a specified port on a specified virtual machine.

Functions
Name | Description
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.
Links
Functions, Functions by Handle, Legend


PHT_REMOTE_FILESYSTEM_ENTRY

PHT_REMOTE_FILESYSTEM_ENTRY
Functions Functions by Handle Legend Send Feedback

The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.

Functions
Name | Description
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).
Links
Functions, Functions by Handle, Legend


PHT_REMOTE_FILESYSTEM_INFO

PHT_REMOTE_FILESYSTEM_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.

Description

To browse the file system on the host, first obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO using PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function. The object will contain the information about the specified file system entry and all its child entries. Use the functions provided by the PHT_REMOTE_FILESYSTEM_INFO object to obtain a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing the detailed information about the parent entry or any of its child entries. Use the functions provided by the PHT_REMOTE_FILESYSTEM_ENTRY to get the individual properties of the entry.

Functions
Name | Description
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.
Links
Functions, Functions by Handle, Legend


PHT_RESULT

PHT_RESULT
Functions Functions by Handle Legend Send Feedback

The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.

Description

To obtain a handle, use the PrlJob_GetResult function call after the job completes. Once you have the handle, use functions from this group to extract the results of the corresponding asynchronous operation. The PHT_RESULT object can contain a string, an array of strings, a handle, or an array of handles.

If you are expecting a single result, then, depending on the result type (a string or a handle), use the PrlResult_GetParamAsString or the PrlResult_GetParam function respectively.

If the function returns multiple results, first, use the PrlResult_GetParamsCount function to get the number of the results. Then use the PrlResult_GetParamByIndex or the PrlResult_GetParamByIndexAsString function to get individual results. The index of the array begins at 0.

For more information, please also see the Parallels Virtualization SDK Programmer's Guide.

Functions
Name | Description
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.
Links
Functions, Functions by Handle, Legend


PHT_RUNNING_TASK

PHT_RUNNING_TASK
Functions Functions by Handle Legend Send Feedback

The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.

Functions
Name | Description
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).
Links
Functions, Functions by Handle, Legend


PHT_SERVER

PHT_SERVER
Functions Functions by Handle Legend Send Feedback

At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.

Functions
Name | Description
PrlSrv_AddNetAdapter | Adds a new virtual network adapter to the specified Parallels Service.
PrlSrv_AttachToLostTask | The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CheckParallelsServerAlive | Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CommonPrefsBeginEdit | The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit | The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_Create | Creates a new handle of type PHT_SERVER.
PrlSrv_CreateVm | Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_DeleteNetAdapter | Removes a virtual network adapter from the Parallels Service configuration.
PrlSrv_FsCanCreateFile | Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir | Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName | Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries | Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList | Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry | Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry | Renames a file system entry on the host.
PrlSrv_GetCommonPrefs | Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetLicenseInfo | Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus | Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetProblemReport | Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions | The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetServerInfo | Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig | Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetUserInfo | Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList | Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile | Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList | Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmList | Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_IsConnected | Determines if the connection to the specified Parallels Service is active.
PrlSrv_Login | Performs a remote login operation using the specified parameters.
PrlSrv_LoginLocal | Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_Logoff | Logs off the Parallels Service.
PrlSrv_LookupParallelsServers | Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart | Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults | Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart | Starts the Parallels network service.
PrlSrv_NetServiceStop | Stops the Parallels network service.
PrlSrv_RegEventHandler | Registers an event handler.
PrlSrv_RegisterVm | Registers an existing virtual machine with Parallels Service.
PrlSrv_SendAnswer | Sends an answer to the Parallels Service in response to a question.
PrlSrv_Shutdown | Shuts down the Parallels Service.
PrlSrv_StartSearchVms | Searches for unregistered virtual machines at the specified location(s).
PrlSrv_SubscribeToHostStatistics | Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_UnregEventHandler | Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics | Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats | Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateLicense | Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateNetAdapter | Updates an existing virtual network adapter in the specified Parallels Service.
PrlSrv_UserProfileBeginEdit | Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit | Saves (commits) user profile changes to the Parallels Service.
Links
Functions, Functions by Handle, Legend


PHT_SERVER_CONFIG

PHT_SERVER_CONFIG
Functions Functions by Handle Legend Send Feedback

The PHT_SERVER_CONFIG handle is used to retrieve the host configuration information and some of the virtual machine configuration parameters as seen by the operating system running on a virtual machine. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call.

Functions
Name | Description
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of generic PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the server hostname.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetNetAdapter | Obtains an object of type PHT_HW_NET_ADAPTER containing information about a network adapter.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a parallel port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of parallel ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.
Links
Functions, Functions by Handle, Legend


PHT_SERVER_INFO

PHT_SERVER_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.

Functions
Name | Description
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).
Links
Functions, Functions by Handle, Legend


PHT_SHARE

PHT_SHARE
Functions Functions by Handle Legend Send Feedback

The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.

Description

To create a new share:

  1. Call the PrlVm_BeginEdit function to mark the beginning of the operation (this is essentially a virtual machine configuration modification, so it must be done within the begin/commit block).
  2. Use the PrlVmCfg_CreateShare function to obtain the handle.
  3. Use functions provided by this object to set the desired new share properties.
  4. Call the PrlVm_Commit to finalize the changes.
  5. Enabled the host sharing feature in the virtual machine by calling the PrlVm_SetHostSharingEnabled function.

To modify an existing share, use the PrlVmCfg_GetShare function to obtain a handle containing the share information. Then repeat the steps described above.

Functions
Name | Description
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.
Links
Functions, Functions by Handle, Legend


PHT_STRINGS_LIST

PHT_STRINGS_LIST
Functions Functions by Handle Legend Send Feedback

The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.

Functions
Name | Description
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS

PHT_SYSTEM_STATISTICS
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.

Description

There are two main methods for obtaining a handle of type PHT_SYSTEM_STATISTICS:

  1. Using PrlSrv_GetStatistics (for host statistics) or PrlVm_GetStatistics (for virtual machine statistics).
  2. Using PrlSrv_SubscribeToHostStatistics (for host statistics) or PrlVm_SubscribeToGuestStatistics (for virtual machine statistics) to receive statistics events, and PrlSrv_UnsubscribeFromHostStatistics or PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics events. A callback function (event handler) implementation is required to use subscriptions.

The PHT_SYSTEM_STATISTICS object provides methods for obtaining handles to objects containing the performance data of a specific type. It also provides methods for obtaining memory statistics directly from it. The steps in obtaining the performance data are as follows:

  1. Obtain a handle of type PHT_SYSTEM_STATISTICS.
  2. To obtain memory statistics, use the functions provided by the object.
  3. For other statistics (CPU, disk, network, etc.), first use a corresponding function to obtain a handle of a particular type, and then use the functions of the received object to get the statistics.
Functions
Name | Description
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns operating system uptime in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_CPU

PHT_SYSTEM_STATISTICS_CPU
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.

Functions
Name | Description
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_DISK

PHT_SYSTEM_STATISTICS_DISK
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.

Functions
Name | Description
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_DISK_PARTITION

PHT_SYSTEM_STATISTICS_DISK_PARTITION
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.

Functions
Name | Description
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_IFACE

PHT_SYSTEM_STATISTICS_IFACE
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.

Functions
Name | Description
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_PROCESS

PHT_SYSTEM_STATISTICS_PROCESS
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.

Functions
Name | Description
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.
Links
Functions, Functions by Handle, Legend


PHT_SYSTEM_STATISTICS_USER_SESSION

PHT_SYSTEM_STATISTICS_USER_SESSION
Functions Functions by Handle Legend Send Feedback

The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.

Functions
Name | Description
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.
Links
Functions, Functions by Handle, Legend


PHT_USER_INFO

PHT_USER_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.

Functions
Name | Description
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).
Links
Functions, Functions by Handle, Legend


PHT_USER_PROFILE

PHT_USER_PROFILE
Functions Functions by Handle Legend Send Feedback

The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.

Description

All modifications to the user profile must begin with the PrlSrv_UserProfileBeginEdit function call and end with the PrlSrv_UserProfileCommit function call. The functions are used to detect collisions with other clients trying to modify the profile of the same user at the same time. The functions do not lock the profile being edited. If a collision is detected on commit, the changes are rejected.

Functions
Name | Description
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_DEV_FLOPPY

PHT_VIRTUAL_DEV_FLOPPY
Functions by Handle See Also Send Feedback

The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_HARD_DISK

PHT_VIRTUAL_DEV_HARD_DISK
Functions Functions by Handle Legend See Also Send Feedback

The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.

Functions
Name | Description
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_HD_PARTITION

PHT_VIRTUAL_DEV_HD_PARTITION
Functions Functions by Handle Legend Send Feedback

The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.

Functions
Name | Description
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_DEV_NET_ADAPTER

PHT_VIRTUAL_DEV_NET_ADAPTER
Functions Functions by Handle Legend See Also Send Feedback

The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.

Functions
Name | Description
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine.
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_OPTICAL_DISK

PHT_VIRTUAL_DEV_OPTICAL_DISK
Functions by Handle See Also Send Feedback

The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_PARALLEL_PORT

PHT_VIRTUAL_DEV_PARALLEL_PORT
Functions by Handle See Also Send Feedback

The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.

See Also

Common Virtual Device Functions

Links
Functions by Handle, See Also


PHT_VIRTUAL_DEV_SERIAL_PORT

PHT_VIRTUAL_DEV_SERIAL_PORT
Functions Functions by Handle Legend See Also Send Feedback

The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.

Description

The following describes how to create new or modify an existing serial port on a virtual machine.

First, you have to set the emulation type using the PrlVmDev_SetEmulatedType function. The available types are:

  • PDT_USE_REAL_DEVICE - real port.
  • PDT_USE_OUTPUT_FILE - output file.
  • PDT_USE_OTHER - socket.

Second, you must call the PrlVmDev_SetSysName and the PrlVmDev_SetFriendlyName functions. These functions are used differently depending on the emulation type that you chose in the first step.

Real port

  1. Choose a real port and pass its ID to the PrlVmDev_SetSysName function.
  2. Pass the physical port name to the PrlVmDev_SetFriendlyName function.

Output file

  1. Choose an output file name and path, then pass it to both functions as a parameter.

Socket

  1. Choose a socket name and path, then pass it to both functions as a parameter.
  2. Call the PrlVmDevSerial_SetSocketMode function to set the socket mode.
Functions
Name | Description
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_SOUND

PHT_VIRTUAL_DEV_SOUND
Functions Functions by Handle Legend See Also Send Feedback

The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.

Functions
Name | Description
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DEV_USB_DEVICE

PHT_VIRTUAL_DEV_USB_DEVICE
Functions Functions by Handle Legend See Also Send Feedback

The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.

Functions
Name | Description
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.
See Also

Common Virtual Device Functions

Links
Functions, Functions by Handle, Legend, See Also


PHT_VIRTUAL_DISK

PHT_VIRTUAL_DISK
Functions Functions by Handle Legend Send Feedback

The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files. There's a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and there are files that are used for data storage. Once created, a virtual disk can be attached to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk or PrlDisk_OpenDisk_Local.

Notes

The functionality provided by this handle offers more low-level control over new and existing virtual disks. You can use it to create new disks and then decide on the virtual machine to which the disk should be connected. You can also manage existing disks, including those used by virtual machines. If, however, all you want to do is create a virtual machine and a virtual disk at the same time, or add a virtual disk to a virtual machine in a few easy steps, you can use the functionality provided by the PHT_VIRTUAL_MACHINE and PHT_VM_CONFIGURATION handles. You can also consult Virtualization SDK Programmer's Guide for a detailed explanation and code samples on how to create a new virtual machine and how to add a virtual disk to an existing virtual machine.

Functions
Name | Description
PrlDisk_Coagulate | Merges all snapshots.
PrlDisk_Compact | Compacts a virtual disk.
PrlDisk_ConvertToCurrent | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_ConvertToCurrent_Local | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Start creation procedure of the new state
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_DeleteState | Start delete state procedure.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | This method is used to free the disk reference with closing.
PrlDisk_GetDiskInfo | Get disk information.
PrlDisk_GetSnapshotsCount | Get snapshots count.
PrlDisk_GetSnapshotsTree | Get snapshots tree.
PrlDisk_GetUserParameter | Get user parameter for disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsCompactable | Check is image compactable.
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Method let to open disk and return handle This function can be used locally, without a Parallels Service connection.
PrlDisk_Read | Write data to disk.
PrlDisk_SetCachingPolicy | Set caching policy for disk.
PrlDisk_SetSharedDirectory | Set shared directory (all files created somewhere in this directory will have 666 permissions).
PrlDisk_SetSharedDirectory_Local | Set shared directory (all files created somewhere in this directory will have 666 permissions) This function can be used locally, without a Parallels Service connection.
PrlDisk_SetUserParameter | Set user parameter for disk.
PrlDisk_SwitchToState | Start switching to state procedure.
PrlDisk_WaitForCompletion | Wait for completion of the work.
PrlDisk_Write | Write data to disk.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_MACHINE

PHT_VIRTUAL_MACHINE
Functions Functions by Handle Legend Send Feedback

PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.

Functions
Name | Description
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompressor | Cancels the running Compressor operation that was started with PrlVm_RunCompressor.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_RunCompressor | Initiates the Compressor process.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.
Links
Functions, Functions by Handle, Legend


PHT_VIRTUAL_NETWORK

PHT_VIRTUAL_NETWORK
Functions Functions by Handle Legend Send Feedback

The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.

Functions
Name | Description
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.
Links
Functions, Functions by Handle, Legend


PHT_VM_CONFIGURATION

PHT_VM_CONFIGURATION
Functions Functions by Handle Legend Send Feedback

The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.

Functions
Name | Description
PrlVmCfg_AddDefaultDevice | The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_CreateBootDev | Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes | Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare | Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev | Creates a new virtual device handle of the specified type.
PrlVmCfg_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetAppInDockMode | Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAutoStart | Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay | Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop | Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority | Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev | Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount | Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetConfigValidity | The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetCpuAccelLevel | Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount | Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuMode | Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits | Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty | Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize | The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize | The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDescription | Returns the specified virtual machine description.
PrlVmCfg_GetDevByType | Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount | Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType | Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDevsList | Returns a pointer to a buffer containing handles to the virtual devices installed in a virtual machine.
PrlVmCfg_GetDnsServers | Obtains the list of globally defined DNS servers that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetDockIconType | Returns the virtual machine dock icon type.
PrlVmCfg_GetFloppyDisk | Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount | Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority | Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetGenericPciDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount | Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount | Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk | Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount | Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHomePath | Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostname | Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon | Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetLastModifiedDate | Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName | Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetName | Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter | Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount | Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetOpticalDisk | Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount | Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOsType | Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion | Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort | Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual parallel port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount | Determines the number of virtual parallel ports in the specified virtual machine.
PrlVmCfg_GetRamSize | Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetScrRes | Returns the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount | Returns the virtual machine screen resolutions count.
PrlVmCfg_GetSearchDomains | Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort | Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount | Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost | Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid | Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare | Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount | Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSoundDev | Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount | Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode | Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin | Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags | Returns the virtual machine system flags.
PrlVmCfg_GetUndoDisksMode | Determines the current undo disks mode for the specified virtual machine.
PrlVmCfg_GetUsbDevice | Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount | Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid | Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize | Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVNCHostName | Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode | Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword | Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort | Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode | Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsCloseAppOnShutdown | Returns Virtual Machine close app on shutdown sign.
PrlVmCfg_IsCpuVtxEnabled | Returns Virtual Machine CPU VTx support enabling sign.
PrlVmCfg_IsDefaultDeviceNeeded | Determines if a virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC | Gets the APIC using for virtual machine in runtime.
PrlVmCfg_IsDiskCacheWriteBack | Determines if disk cache write-back is enabled for the specified virtual machine.
PrlVmCfg_IsExcludeDock | Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsGuestSharingAutoMount | Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled | Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight | Determines if VM virtual disks will be added to Spotlight search subsystem.
PrlVmCfg_IsHostSharingEnabled | Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsMapSharedFoldersOnLetters | Determines whether host disks shared into guest Windows OS will be maped on drive letters.
PrlVmCfg_IsMultiDisplay | Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsOsResInFullScrMode | Determines if a virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsRelocateTaskBar | Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled | Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks | Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsSharedProfileEnabled | Returns sign whether shared profile is enabled.
PrlVmCfg_IsShareUserHomeDir | Determines whether host user home dir will be present at guest OS as share.
PrlVmCfg_IsShowTaskBar | Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsSmartGuardEnabled | Returns sign whether smart guard is enabled.
PrlVmCfg_IsTemplate | Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsUseDesktop | Returns sign whether use desktop in shared profile is enabled.
PrlVmCfg_IsUseDocuments | Returns sign whether use documents in shared profile is enabled.
PrlVmCfg_IsUseMusic | Returns sign whether use music in shared profile is enabled.
PrlVmCfg_IsUsePictures | Returns sign whether use pictures in shared profile is enabled.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled | Returns sign whether user defined shared folders enabled.
PrlVmCfg_SetAppInDockMode | Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAutoStart | Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay | Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop | Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority | Sets virtual machine background processes priority.
PrlVmCfg_SetCloseAppOnShutdown | Sets Virtual Machine close app on shutdown sign.
PrlVmCfg_SetCpuAccelLevel | Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount | Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuMode | Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits | Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty | Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig | The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription | Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign | Sets the APIC using for virtual machine in runtime.
PrlVmCfg_SetDiskCacheWriteBack | Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers | Allows to manually set the global DNS server list that will assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetDockIconType | Sets the virtual machine dock icon type.
PrlVmCfg_SetExcludeDock | Sets the exclude dock option.
PrlVmCfg_SetForegroundPriority | Sets the virtual machine foreground processes priority.
PrlVmCfg_SetGuestSharingAutoMount | Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled | Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight | Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHostname | Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled | Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon | Sets the virtual machine icon.
PrlVmCfg_SetMapSharedFoldersOnLetters | Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMultiDisplay | Sets the virtual machine multi-display option.
PrlVmCfg_SetName | Sets the specified virtual machine name.
PrlVmCfg_SetOsResInFullScrMode | Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsVersion | Sets the virtual machine guest OS version.
PrlVmCfg_SetRamSize | Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRelocateTaskBar | Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetScrResEnabled | Sets the additional screen resolution support option in the specified virtual machine
PrlVmCfg_SetSearchDomains | Allows to manually set the global search domain list that will be assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetShareAllHostDisks | Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetSharedProfileEnabled | Lets to set shared profile enabling sign.
PrlVmCfg_SetShareUserHomeDir | Enables sharing of host user home dir for the specified virtual machine.
PrlVmCfg_SetShowTaskBar | Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetSmartGuardEnabled | Lets to set smart guard enabling sign.
PrlVmCfg_SetStartLoginMode | Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds | Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetSystemFlags | Sets Virtual Machine system flags.
PrlVmCfg_SetTemplateSign | Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetUndoDisksMode | Sets the undo disks mode for the virtual machine (see PRL_UNDO_DISKS_MODE for available options).
PrlVmCfg_SetUseDesktop | Lets to set use desktop in shared profile enabling sign.
PrlVmCfg_SetUseDocuments | Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseMusic | Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures | Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled | Lets to set user defined shared folders enabling sign.
PrlVmCfg_SetUuid | Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVideoRamSize | Sets the virtual machine video memory size.
PrlVmCfg_SetVNCHostName | Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode | Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword | Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort | Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode | Sets the virtual machine window mode.
Links
Functions, Functions by Handle, Legend


PHT_VM_GUEST_SESSION

PHT_VM_GUEST_SESSION
Functions Functions by Handle Legend Send Feedback

The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.

Functions
Name | Description
PrlVmGuest_GetNetworkSettings | Obtains network settings of an operating system running on a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.
Links
Functions, Functions by Handle, Legend


PHT_VM_INFO

PHT_VM_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.

Functions
Name | Description
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.
Links
Functions, Functions by Handle, Legend


PHT_VM_TOOLS_INFO

PHT_VM_TOOLS_INFO
Functions Functions by Handle Legend Send Feedback

The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.

Functions
Name | Description
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.
Links
Functions, Functions by Handle, Legend


Common Functions

Common Functions
Topics Send Feedback

This chapter contains information about common API functions.

Topics
Name | Description
System Functions | Common Parallels API system functions.
API Debug Functions | API debug functions.
Handle Functions | Functions that perform operations on handles.
Virtual Device Functions | This section describes common virtual device management functions.
PrlBuffer |
Links
Topics


System Functions

System Functions
Functions Common Functions Legend Send Feedback

Common Parallels API system functions.

Functions
Name | Description
PrlApi_AddRemoteDevCommandBuffer | Adds buffer to the remote command.
PrlApi_AddRemoteDevCommandParam | Adds unsigned int parameter to the command.
PrlApi_CreateHandlesList | Creates SDK object represents handles list
PrlApi_CreateRemoteCommand |
PrlApi_CreateRemoteDevCommand | Creates command to the remote device.
PrlApi_CreateStringsList | Creates a handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendRemoteCommand |
PrlApi_SendRemoteDeviceCommand | Sends remote device command to the Virtual Machine.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.
Links
Functions, Common Functions, Legend


API Debug Functions

API Debug Functions
Functions Common Functions Legend Send Feedback

API debug functions.

Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.
Links
Functions, Common Functions, Legend


Handle Functions

Handle Functions
Functions Common Functions Legend Send Feedback

Functions that perform operations on handles.

Functions
Name | Description
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetType | Returns the type of the specified handle.
Links
Functions, Common Functions, Legend


Virtual Device Functions

Virtual Device Functions
Functions Common Functions Legend Send Feedback

This section describes common virtual device management functions.

Description

Common virtual device management functions can operate on virtual devices of the following types:

PHT_VIRTUAL_DEV_FLOPPY

PHT_VIRTUAL_DEV_HARD_DISK

PHT_VIRTUAL_DEV_NET_ADAPTER

PHT_VIRTUAL_DEV_OPTICAL_DISK

PHT_VIRTUAL_DEV_PARALLEL_PORT

PHT_VIRTUAL_DEV_SERIAL_PORT

PHT_VIRTUAL_DEV_SOUND

PHT_VIRTUAL_DEV_USB_DEVICE

Each common function accepts a handle of type PRL_HANDLE identifying the virtual device to operate on. The actual handle passed can be of any type from the list above. In addition to common function described here, most of the individual virtual devices have functions specific to their respective types. For device-type specific functions, follow links to virtual device handles in the list above.

Functions
Name | Description
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSysName | Sets virtual device system name.
Links
Functions, Common Functions, Legend


PrlBuffer

PrlBuffer
Functions Common Functions Legend Send Feedback
Functions
Name | Description
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.
Links
Functions, Common Functions, Legend


Remote Desktop Access

Remote Desktop Access
Topics Send Feedback

This chapter contains information about functions that can be used to remotely capture screen shots of a virtual machine desktop and to send keyboard and mouse commands to it.

Description

With this functionality, you can programmatically connect to a remote virtual machine and run its applications as if you were sitting at the virtual machine's console. The typical uses of the Remote Desktop Access functionality are:

  1. Creating automation scripts for unattended operating system and other software installations.
  2. Creating your own remote desktop applications with graphical user interfaces.

There are four groups of functions comprising the Remote Desktop Access API :

  1. Primary display capture. These functions allow to capture a region or an entire screen of the remote virtual machine. In scripts, you can take a snapshot of a particular screen in advance and then compare it to the screen captured at runtime. If comparison operation determines that you've got the screen of interest, you can interact with it by sending mouse or keyboard commands (pressing buttons, making selections, etc.). In a GUI application, you can constantly capture screens (or screen regions) and display them to the user of your application, thus providing a real-time remote desktop access to a virtual machine.
  2. Secondary display capture. This group of functions is almost identical to the Primary Display Capture group with the exception that it operates on a secondary display(s) if one is installed in a virtual machine.
  3. Mouse control. These functions provide control over the mouse in a virtual machine. You can change the position of the mouse pointer, press and release mouse buttons, and use a scroll wheel. In GUI applications, you can capture mouse events in the host OS where the application is running and then transmit those events to the virtual machine. In scripts, you can move a mouse pointer to the coordinates you know in advance (coordinates of a button, an edit control, etc.) and perform an action.
  4. Keyboard control. These functions simply send a key/action code combination to the virtual machine. In scripts, you can use these functions to interact with controls on a window opened inside a virtual machine (pressing buttons, selecting options, etc.). In a typical GUI application, essential visual controls usually have keyboard shortcuts (accelerator keys) assigned to them. If a control doesn't have a shortcut, then you will have to use mouse control functions to position a mouse pointer over the control to select it.

Every remote desktop access session must begin with PrlDevDisplay_ConnectToVm function call and end with the PrlDevDisplay_DisconnectFromVm call.

For more information and code samples, please see Parallels Virtualization SDK Programmer's Guide.

Topics
Name | Description
Primary Display Capture | Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.
Secondary Display Capture | Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.
Keyboard Control | Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.
Mouse Control | Functions in this group provide functionality for sending mouse commands to a remote virtual machine.
Links
Topics


Primary Display Capture

Primary Display Capture
Functions Remote Desktop Access Legend Send Feedback

Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.

Functions
Name | Description
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetScreenSurface | Sets CoreGraphics surface for fast server-side display updates.
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.
Links
Functions, Remote Desktop Access, Legend


Secondary Display Capture

Secondary Display Capture
Functions Remote Desktop Access Legend Send Feedback

Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.

Functions
Name | Description
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the secondary display of the guest OS to specified values.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
Links
Functions, Remote Desktop Access, Legend


Keyboard Control

Keyboard Control
Functions Remote Desktop Access Legend Send Feedback

Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.

Functions
Name | Description
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.
Links
Functions, Remote Desktop Access, Legend


Mouse Control

Mouse Control
Functions Remote Desktop Access Legend Send Feedback

Functions in this group provide functionality for sending mouse commands to a remote virtual machine.

Functions
Name | Description
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
Links
Functions, Remote Desktop Access, Legend


Callback Prototypes

Callback Prototypes
Topics Send Feedback

This chapter describes callback function prototypes that are used to implement your own callback functions for use in asynchronous calls.

Topics
Name | Description
PRL_DISK_CALLBACK | PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
PRL_EVENT_HANDLER_PTR | PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.
PRL_STATES_CALLBACK | PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
Links
Topics


PRL_DISK_CALLBACK

PRL_DISK_CALLBACK
Callback Prototypes Send Feedback

PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.

Syntax
typedef PRL_BOOL (PRL_CALL *PRL_DISK_CALLBACK)(PRL_INT32 iComplete, PRL_INT32 iTotal, PRL_VOID_PTR pParam);
Parameters

iComplete
An integer value indicating the state of the disk operation completion. Values range from 0 max, which is contained in the iTotal parameter. A value greater than 0 and less than iTotal indicates that the operation is still in progress. The value can be used to determine the state of completion. A value greater than iTotal indicates that the operation completed successfully. A negative value indicates an error.
iTotal
An integer value indicating the upper bound of the disk operation completion range.
pParam
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


PRL_EVENT_HANDLER_PTR

PRL_EVENT_HANDLER_PTR
Callback Prototypes Send Feedback

PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.

Syntax
typedef PRL_METHOD_PTR( PRL_EVENT_HANDLER_PTR ) ( PRL_HANDLE hEvent, PRL_VOID_PTR data );
Parameters

hEvent
A handle of type PHT_EVENT or PHT_JOB. The PHT_EVENT type indicates that the callback function was called by a system event. If the type is PHT_JOB then the callback function was called by an asynchronous job. The type can be determined using the PrlHandle_GetType function. For more information and code samples see Parallels Virtualization SDK Programmer's Guide.

Note: You must always free the handle before exiting from the function regardless of whether you actually used it or not. Failure to do so will result in a memory leak.

data
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


PRL_STATES_CALLBACK

PRL_STATES_CALLBACK
Callback Prototypes Send Feedback

PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.

Syntax
typedef PRL_BOOL (PRL_CALL *PRL_STATES_CALLBACK)(PRL_STATES_CALLBACK_TYPE iCallbackType, PRL_INT32 iProgress, PRL_VOID_PTR pParameter);
Parameters

iCallbackType
Callback type. At the time of this writing the only supported callback type is PRL_STATE_DISK_CALLBACK.
iProgress
An integer value indicating the state of the disk operation completion. Compare the received value to one of the following:

PRL_STATE_PROGRESS_MIN -- The lower bound of the operation completion range.

PRL_STATE_PROGRESS_MAX -- The upper bound of the operation completion range.

PRL_STATE_PROGRESS_COMPLETED -- Indicates that the operation completed successfully.

A value between PRL_STATE_PROGRESS_MIN and PRL_STATE_PROGRESS_MAX indicates that the operation is still in progress. The value can be used to determine the state of the operation completion. A value that is equal to PRL_STATE_PROGRESS_COMPLETED indicates that the operation completed successfully. A negative value indicates an error.

pParameter
A pointer to a buffer containing user-defined data.

Remarks

A pointer to a callback function can be passed to another function that accepts it as a parameter. The operation initiated by that function will be performed in the background thread, which will call the callback function (possibly more than once) passing to it intermediate results or the final result of the operation.

Links
Callback Prototypes


Types

Types
Topics Send Feedback
Topics
Name | Description
PRL_BOOL Types |
PRL_CHAR Types |
PRL_CONST Types |
PRL_DEVICE Types |
PRL_DISK Types |
PRL_FILE Types |
PRL_INT Types |
PRL_IO Types |
PRL_TIS Types |
PRL_TOOLS Types |
PRL_UINT Types |
PRL_VM Types |
PRL_VOID Types |
Other Types |
Links
Topics


PRL_BOOL Types

PRL_BOOL Types
Types Types Send Feedback
Types
Name | Description
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |
Links
Types, Types


PRL_CHAR Types

PRL_CHAR Types
Types Types Send Feedback
Types
Name | Description
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |
Links
Types, Types


PRL_CONST Types

PRL_CONST Types
Types Types Send Feedback
Types
Name | Description
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VOID_PTR |
Links
Types, Types


PRL_DEVICE Types

PRL_DEVICE Types
Types Types Send Feedback
Types
Name | Description
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |
Links
Types, Types


PRL_DISK Types

PRL_DISK Types
Types Types Send Feedback
Types
Name | Description
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |
Links
Types, Types


PRL_FILE Types

PRL_FILE Types
Types Types Send Feedback
Types
Name | Description
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |
Links
Types, Types


PRL_INT Types

PRL_INT Types
Types Types Send Feedback
Types
Name | Description
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |
Links
Types, Types


PRL_IO Types

PRL_IO Types
Types Types Send Feedback
Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_SCREENSAVER_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_STATE_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |
Links
Types, Types


PRL_TIS Types

PRL_TIS Types
Types Types Send Feedback
Types
Name | Description
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_ACTION_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TIS_VERSION_PTR |
Links
Types, Types


PRL_TOOLS Types

PRL_TOOLS Types
Types Types Send Feedback
Types
Name | Description
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |
Links
Types, Types


PRL_UINT Types

PRL_UINT Types
Types Types Send Feedback
Types
Name | Description
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |
Links
Types, Types


PRL_VM Types

PRL_VM Types
Types Types Send Feedback
Types
Name | Description
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR |
PRL_VM_MIGRATION_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_WINDOW_MODE_PTR |
Links
Types, Types


PRL_VOID Types

PRL_VOID Types
Types Types Send Feedback
Types
Name | Description
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |
Links
Types, Types


Other Types

Other Types
Types Types Send Feedback
Types
Name | Description
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |
PRL_STR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_STATE_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_VERSION_ENUM_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_API_METHOD_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLICATION_MODE_PTR |
Links
Types, Types


Structs, Records, Enums

Structs, Records, Enums
Topics Send Feedback
Topics
Name | Description
PRL_IO Structs |
PRL_VM Structs |
Other Structs |
Links
Topics


PRL_IO Structs

PRL_IO Structs
Enumerations Structs, Records, Enums Structures Send Feedback
Enumerations
Name | Description
PRL_IO_STATE |
Structures
Name
Description
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_RESPONSE
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_SCREENSAVER_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SLIDING_MOUSE
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.

PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.

Links
Enumerations, Structs, Records, Enums, Structures


PRL_VM Structs

PRL_VM Structs
Enumerations Structs, Records, Enums Send Feedback
Enumerations
Name | Description
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_WINDOW_MODE | VM window mode
Links
Enumerations, Structs, Records, Enums


Other Structs

Other Structs
Enumerations Structs, Records, Enums Legend Structures Send Feedback
Enumerations
Name | Description
_PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
_PRL_APP_IN_DOCK_MODE | VM application in Dock mode
_PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
_PRL_CPU_HVT | CPU mode
_PRL_CPU_MODE | CPU mode
_PRL_DEVICE_ACTION | Device in use Action
_PRL_DEVICE_TYPE | Device type
_PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
_PRL_DISPLAY_CODEC_QUALITY | Display codec quality
_PRL_DISPLAY_CODEC_TYPE | Display codec types
_PRL_DOCK_ICON_TYPE | VM application icon type in Dock
_PRL_EVENT_ISSUER_TYPE | Event issuer type
_PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
_PRL_FILE_SYSTEM_FS_TYPE |
_PRL_FILE_SYSTEM_TYPE | File system general type
_PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
_PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
_PRL_HOST_OS_TYPE | Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
_PRL_IMAGE_FORMAT |
_PRL_IO_STATE |
_PRL_JOB_OPERATION_CODE | Job operation codes
_PRL_JOB_STATUS | Job status enumeration
_PRL_KEY_EVENT |
_PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
_PRL_MOUSE_BUTTON |
_PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
_PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
_PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PROCESS_STATE_TYPE | Process state element
_PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
_PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
_PRL_SECURITY_LEVEL | Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM | Parallels service statuses
_PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
_PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
_PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
_PRL_VERSION_ENUM | Parallels license versions enumeration.
_PRL_VM_ACCELERATION_LEVEL | Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
_PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION | VM autostart options
_PRL_VM_AUTOSTOP_OPTION | VM autostop options
_PRL_VM_BOOT_ORDER | VM boot order
_PRL_VM_CONFIG_SECTIONS | VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
_PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
_PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
_PRL_VM_PRIORITY | Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE | VM start login mode
_PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
_PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
_PRL_VM_WINDOW_MODE | VM window mode
_PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
PRL_APP_IN_DOCK_MODE | VM application in Dock mode
PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
PRL_CPU_HVT | CPU mode
PRL_CPU_MODE | CPU mode
PRL_DEVICE_ACTION | Device in use Action
PRL_DEVICE_TYPE | Device type
PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
PRL_DISPLAY_CODEC_QUALITY | Display codec quality
PRL_DISPLAY_CODEC_TYPE | Display codec types
PRL_DOCK_ICON_TYPE | VM application icon type in Dock
PRL_EVENT_ISSUER_TYPE | Event issuer type
PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
PRL_FILE_SYSTEM_FS_TYPE |
PRL_FILE_SYSTEM_TYPE | File system general type
PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
PRL_HOST_OS_TYPE | Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
PRL_IMAGE_FORMAT |
PRL_JOB_OPERATION_CODE | Job operation codes
PRL_JOB_STATUS | Job status enumeration
PRL_KEY_EVENT |
PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
PRL_MOUSE_BUTTON |
PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PROCESS_STATE_TYPE | Process state element
PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
PRL_SECURITY_LEVEL | Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM | Parallels service statuses
PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
PRL_VERSION_ENUM | Parallels license versions enumeration.
PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
Structures
Name
Description
__PRL_DISK_PARAMETERS
Parallels disk parameters.
__PRL_IMAGE_PARAMETERS
Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
_PRL_API_METHOD
Parallels API method
_PRL_GUID
Global unique identifier
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GUEST_SCREENSAVER_STATE
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SLIDING_MOUSE
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_DISK_PARAMETERS
Parallels disk parameters.
PRL_IMAGE_PARAMETERS
Parallels storage parameters
PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO

Links
Enumerations, Structs, Records, Enums, Legend, Structures


Macros

Macros
Topics Send Feedback
Topics
Name | Description
GUI_ERR Macros |
PET Macros |
PRL_DISK Macros |
PRL_ERR Macros |
PRL_SCAN_CODE Macros |
PVS_GUEST Macros |
Other Macros |
Links
Topics


GUI_ERR Macros

GUI_ERR Macros
Macros Macros Send Feedback
Macros
Name
Description
GUI_ERR_CANT_ADD_PCI_INSTANTLY

  • Gui messages

+++ ALIGNED VALUE TO 15000

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
Links
Macros, Macros


PET Macros

PET Macros
Macros Macros Send Feedback
Macros
Name
Description
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_CANCEL
PET_ANSWER_COMMIT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK

  • Answers

+++ ALIGNED VALUE TO 16000

PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_REVERT
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1

  • Questions

+++ ALIGNED VALUE TO 13000

PET_QUESTION_SAMPLE_2
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE
Links
Macros, Macros


PRL_DISK Macros

PRL_DISK Macros
Macros Macros Send Feedback
Macros
Name | Description
PRL_DISK_CACHE_DEFAULT | Disk cache default.
PRL_DISK_CACHE_DISABLED | Uncached access to disk image.
PRL_DISK_CACHE_ENABLED | Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ | Cached write/uncached read.
PRL_DISK_DEFAULT_FLAG | Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN | Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT | Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK | Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING | Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED | Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL | Normal access mode (default os)
PRL_DISK_INVALID | Last (invalid).
PRL_DISK_NOTHING | Nothing.
PRL_DISK_PROGRESS_COMPLETED |
PRL_DISK_PROGRESS_MAX |
PRL_DISK_PROGRESS_MIN | States progress definition.
PRL_DISK_READ | Read
PRL_DISK_READ_LOCK | ReadLock
PRL_DISK_WRITE | Write
PRL_DISK_WRITE_THROUGH | Write through, disable caching
PRL_DISK_XML_CHANGE | This parameter is used when user need to change XML data but not access to the drive itself.
Links
Macros, Macros


PRL_ERR Macros

PRL_ERR Macros
Macros Macros Send Feedback
Macros
Name
Description
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON

  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED

  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED

  • Other

+++ ALIGNED VALUE TO 10000

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED

  • Parallel Port

+++ ALIGNED VALUE TO 7000

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED

  • Serial Port

+++ ALIGNED VALUE TO 6000

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED

  • USB

+++ ALIGNED VALUE TO 8000

PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND

  • User parameters errors

* +++ ALIGNED VALUE TO 23000

PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR

  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

PRL_ERR_DISK_GET_MOUNTPATH_FAILED

  • Bootcamp errors

* +++ ALIGNED VALUE TO 24000

PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SHARED_BLOCK

  • Compressing errors

* +++ ALIGNED VALUE TO 22000

PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED

  • File Transfer errors

+++ ALIGNED VALUE TO 26000

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_PARALLELS_DISK

  • Hard Drive

+++ ALIGNED VALUE TO 2000

PRL_ERR_INVALID_PARAM
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED

  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID

  • License

+++ ALIGNED VALUE TO 11000

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_DEVICE_WRITE_FAILED

  • Sound

+++ ALIGNED VALUE TO 5000

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR

  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID

  • TIS errors

+++ ALIGNED VALUE TO 27800

PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG

  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG

  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_PROCESSING

  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS
PRL_ERR_VM_LOCKED_FOR_CLONE
FIXME: all constants like 'PRL_ERR_VM_LOCKED_FOR_***' should be changed to 'PRL_ERR_CONCURRENT_COMMAND_EXECUTING' until fix bug #6370 ( http://bugzilla/show_bug.cgi?id=6370 )
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
ALIGNED VALUE TO 27550
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED

  • Validation VM configuration error

+++ ALIGNED VALUE TO 27000

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_NOT_MAPPED

  • VT-d

+++ ALIGNED VALUE TO 12000

PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE
Links
Macros, Macros


PRL_SCAN_CODE Macros

PRL_SCAN_CODE Macros
Macros Macros Send Feedback
Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | Scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_Z |
Links
Macros, Macros


PVS_GUEST Macros

PVS_GUEST Macros
Macros Macros Send Feedback
Macros
Name | Description
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_XP |
Links
Macros, Macros


Other Macros

Other Macros
Macros Macros Send Feedback
Macros
Name
Description
FROM_PARALLELS_API_VER
FS_PERM_EXECUTE
FS_PERM_READ
FS_PERM_WRITE
IS_FREEBSD
IS_FS_EXECUTE_PERMITTED
IS_FS_READ_PERMITTED
IS_FS_WRITE_PERMITTED
IS_LINUX
IS_MACOS
IS_MSDOS
IS_NETWARE
IS_OS2
IS_OTHER
IS_SOLARIS
IS_VALID_FREEBSD_VERSION
IS_VALID_LINUX_VERSION
IS_VALID_MACOS_VERSION
IS_VALID_MSDOS_VERSION
IS_VALID_NETWARE_VERSION
IS_VALID_OS2_VERSION
IS_VALID_OTHER_OS_VERSION
IS_VALID_SOLARIS_VERSION
IS_VALID_WINDOWS_VERSION
IS_WINDOWS
PARALLELS_API_VER
Current Parallels API version.
PARALLELS_API_VER_1
PARALLELS_API_VER_2
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_SRV_METHOD_DECL
PRL_BSD_PARTITION
Free BSD partition.
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID

  • Disk validation errors

+++ ALIGNED VALUE TO 25000

PRL_CURRENT_GUEST_OS_SESSION
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_FAILED
PRL_FALSE
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_COMPRESSED_V2
Compressed disk (version 2)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_INVALID_HANDLE
PRL_INVALID_PARTITION
Invalid partition
PRL_IO_MAX_DISPLAYS
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_PARTITION
Mac OS
PRL_METHOD
Default method decoration
PRL_METHOD_DECL
Default method declaration for the header files
PRL_METHOD_PTR
PRL_MSDOS_EXTENDED_PARTITION

  • Disk partition types

Extended partitions

PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR

  • Network

+++ ALIGNED VALUE TO 4000

PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_NULL
NULL (invalid) handle
PRL_PRIVILEGED_GUEST_OS_SESSION
Guest OS sessions types and constants declarations
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_RESULT_DECLARE_ERROR
Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS
PRL_SRV_METHOD_DECL
PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_STRUCT
Default structure definition
PRL_SUCCEEDED
Success and failure result codes
PRL_TRUE
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions
PRL_WNG_START_VM_ON_MOUNTED_DISK
PVM_GET_MIGRATION_SECURITY_LEVEL
Macro for extracting VM migration security level value from flags mask
PVM_GET_MIGRATION_TYPE
Macro for extracting VM migration type value from flags mask
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_TYPE
PVS_MAKE_GUEST_VER
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_ENABLED
SET_FS_READ_DISABLED
SET_FS_READ_ENABLED
SET_FS_WRITE_DISABLED
SET_FS_WRITE_ENABLED
TO_PARALLELS_API_VER
Links
Macros, Macros


Files

Files
Files Send Feedback
Files
Name | Description
Parallels.h | Parallels.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlApi.h | PrlApi.h This file is the part of parallels public SDK library.
PrlApiMacro.h | PrlApiMacro.h In some situations we need a complete list of the API library functions to be accessible in one easy step.
PrlDisk.h | PrlDITypes.h SDK Disk image types Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlEnums.h | PrlEnums.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlErrors.h | PrlErrors.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlErrorsValues.h | @file PrlErrorsValues.h DO NOT EDIT THIS FILE !!! it generated automatically from PrlErrorsValues.txt Please, do not modify header directly - instead use description text file.
PrlFs.h | PrlFs.h This file is the part of parallels public sdk library Remote file system specific definitions Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlIoStructs.h | PrlIOStructs.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlKeys.h | PrlKeys.h This file is the part of parallels public sdk library Declarations of keyboard related constants.
PrlOses.h | PrlOses.h This file is the part of parallels public sdk library Declarations of OSes constants Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlTypes.h | PrlTypes.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
Links
Files


PrlErrorsValues.h

PrlErrorsValues.h
Files Macros Send Feedback

@file PrlErrorsValues.h

DO NOT EDIT THIS FILE !!! it generated automatically from PrlErrorsValues.txt Please, do not modify header directly - instead use description text file.

Remarks

call Sources/Gen.py or Sources/SDK/GenSdk.py to generate

@author maximk

Copyright (c) 2005-2007 Parallels Software International, Inc. All rights reserved. http://www.parallels.com

Macros
Name
Description
GUI_ERR_CANT_ADD_PCI_INSTANTLY

  • Gui messages

+++ ALIGNED VALUE TO 15000

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_CANCEL
PET_ANSWER_COMMIT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK

  • Answers

+++ ALIGNED VALUE TO 16000

PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_REVERT
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1

  • Questions

+++ ALIGNED VALUE TO 13000

PET_QUESTION_SAMPLE_2
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID

  • Disk validation errors

+++ ALIGNED VALUE TO 25000

PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON

  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED

  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED

  • Other

+++ ALIGNED VALUE TO 10000

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED

  • Parallel Port

+++ ALIGNED VALUE TO 7000

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED

  • Serial Port

+++ ALIGNED VALUE TO 6000

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED

  • USB

+++ ALIGNED VALUE TO 8000

PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND

  • User parameters errors

* +++ ALIGNED VALUE TO 23000

PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR

  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

PRL_ERR_DISK_GET_MOUNTPATH_FAILED

  • Bootcamp errors

* +++ ALIGNED VALUE TO 24000

PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SHARED_BLOCK

  • Compressing errors

* +++ ALIGNED VALUE TO 22000

PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED

  • File Transfer errors

+++ ALIGNED VALUE TO 26000

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_PARALLELS_DISK

  • Hard Drive

+++ ALIGNED VALUE TO 2000

PRL_ERR_INVALID_PARAM
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED

  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID

  • License

+++ ALIGNED VALUE TO 11000

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_DEVICE_WRITE_FAILED

  • Sound

+++ ALIGNED VALUE TO 5000

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR

  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID

  • TIS errors

+++ ALIGNED VALUE TO 27800

PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG

  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG

  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_PROCESSING

  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS
PRL_ERR_VM_LOCKED_FOR_CLONE
FIXME: all constants like 'PRL_ERR_VM_LOCKED_FOR_***' should be changed to 'PRL_ERR_CONCURRENT_COMMAND_EXECUTING' until fix bug #6370 ( http://bugzilla/show_bug.cgi?id=6370 )
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
ALIGNED VALUE TO 27550
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED

  • Validation VM configuration error

+++ ALIGNED VALUE TO 27000

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_NOT_MAPPED

  • VT-d

+++ ALIGNED VALUE TO 12000

PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR

  • Network

+++ ALIGNED VALUE TO 4000

PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WNG_START_VM_ON_MOUNTED_DISK
Links
Files, Macros


Files

Files
Files
Files
Name | Description
Parallels.h | Parallels.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlApi.h | PrlApi.h This file is the part of parallels public SDK library.
PrlApiMacro.h | PrlApiMacro.h In some situations we need a complete list of the API library functions to be accessible in one easy step.
PrlDisk.h | PrlDITypes.h SDK Disk image types Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlEnums.h | PrlEnums.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlErrors.h | PrlErrors.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlErrorsValues.h | @file PrlErrorsValues.h DO NOT EDIT THIS FILE !!! it generated automatically from PrlErrorsValues.txt Please, do not modify header directly - instead use description text file.
PrlFs.h | PrlFs.h This file is the part of parallels public sdk library Remote file system specific definitions Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlIoStructs.h | PrlIOStructs.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlKeys.h | PrlKeys.h This file is the part of parallels public sdk library Declarations of keyboard related constants.
PrlOses.h | PrlOses.h This file is the part of parallels public sdk library Declarations of OSes constants Copyright (c) 2005-2008 Parallels Software International, Inc.
PrlTypes.h | PrlTypes.h This file is the part of parallels public sdk library Copyright (c) 2005-2008 Parallels Software International, Inc.


Topics

Topics
Macros
Topics
Name | Description
GUI_ERR Macros |
PET Macros |
PRL_DISK Macros |
PRL_ERR Macros |
PRL_SCAN_CODE Macros |
PVS_GUEST Macros |
Other Macros |


Topics

Topics
Structs, Records, Enums
Topics
Name | Description
PRL_IO Structs |
PRL_VM Structs |
Other Structs |


Topics

Topics
Types
Topics
Name | Description
PRL_BOOL Types |
PRL_CHAR Types |
PRL_CONST Types |
PRL_DEVICE Types |
PRL_DISK Types |
PRL_FILE Types |
PRL_INT Types |
PRL_IO Types |
PRL_TIS Types |
PRL_TOOLS Types |
PRL_UINT Types |
PRL_VM Types |
PRL_VOID Types |
Other Types |


__PRL_DISK_PARAMETERS Structure

__PRL_DISK_PARAMETERS Structure
PrlDisk.h Other Structs Send Feedback

Parallels disk parameters.

Syntax
struct __PRL_DISK_PARAMETERS {
  PRL_UINT32 m_Heads;
  PRL_UINT32 m_Cylinders;
  PRL_UINT32 m_Sectors;
  PRL_UINT64 m_SizeInSectors;
  PRL_UINT32 m_BlockSize;
  PRL_UINT32 m_Parts;
  PRL_IMAGE_PARAMETERS_PTR m_Storages;
};
File

PrlDisk.h

Remarks

Differs from internal due to lists classes

Links
PrlDisk.h, Other Structs


__PRL_IMAGE_PARAMETERS Structure

__PRL_IMAGE_PARAMETERS Structure
PrlDisk.h Other Structs Send Feedback

Parallels storage parameters

Syntax
struct __PRL_IMAGE_PARAMETERS {
  PRL_IMAGE_TYPE Type;
  PRL_UINT64 uStart;
  PRL_UINT64 uSize;
  PRL_CHAR_PTR pFileName;
};
File

PrlDisk.h

Links
PrlDisk.h, Other Structs


__PRL_SNAPSHOT_ELEMENT Structure

__PRL_SNAPSHOT_ELEMENT Structure
PrlDisk.h Other Structs Send Feedback

Parallels snapshot tree element

Syntax
struct __PRL_SNAPSHOT_ELEMENT {
  PRL_GUID m_GUID;
  struct __PRL_SNAPSHOT_ELEMENT* m_pNext;
  struct __PRL_SNAPSHOT_ELEMENT* m_pChild;
};
File

PrlDisk.h

Links
PrlDisk.h, Other Structs


API Debug Functions Functions

API Debug Functions Functions
API Debug Functions Legend
Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.


Functions

Legend
Legend
Method


Legend

Legend
API Debug Functions
Legend
Method


Topics

Topics
Callback Prototypes
Topics
Name | Description
PRL_DISK_CALLBACK | PRL_DISK_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.
PRL_EVENT_HANDLER_PTR | PRL_EVENT_HANDLER_PTR is a function prototype for implementing callback functions for use in asynchronous calls.
PRL_STATES_CALLBACK | PRL_STATES_CALLBACK is a function prototype for implementing callback functions for use in PHT_VIRTUAL_DISK calls.


Topics

Topics
Common Functions
Topics
Name | Description
System Functions | Common Parallels API system functions.
API Debug Functions | API debug functions.
Handle Functions | Functions that perform operations on handles.
Virtual Device Functions | This section describes common virtual device management functions.
PrlBuffer |


Topics

Topics
Functions by Handle
Topics
Name | Description
PHT_ACCESS_RIGHTS | The PHT_ACCESS_RIGHTS handle is a container containing the virtual machine access rights information.
PHT_BOOT_DEVICE | The PHT_BOOT_DEVICE handle is used to manage boot devices in a virtual machine. The handle is obtained by calling the PrlVmCfg_GetBootDev or the PrlVmCfg_CreateBootDev function. The first function is used to obtain a handle to an existing device in the boot priority list. The second function creates a new handle and is used to add a new device to the list.
PHT_DISP_CONFIG | The PHT_DISP_CONFIG handle is used to manage Parallels Service preferences. The handle is obtained by calling the PrlSrv_GetCommonPrefs function.
PHT_DISP_NET_ADAPTER | The PHT_DISP_NET_ADAPTER handle is used to manage virtual network adapters. The handle is obtained by calling the PrlDispCfg_GetDispNet or the PrlDispCfg_CreateDispNet function.
PHT_EVENT | The PHT_EVENT handle is a container that can contain information about system events or extended error information in asynchronous functions.
PHT_EVENT_PARAMETER | The PHT_EVENT_PARAMETER handle is a container that contains system event parameter data. The handle is obtained by calling the PrlEvent_GetParam function.
PHT_FOUND_VM_INFO | The PHT_FOUND_VM_INFO handle is a container that contains information about a virtual machine as a result of a search operation. The handle is obtained by calling the PrlSrv_StartSearchVms function.
PHT_HW_GENERIC_DEVICE | PHT_HW_GENERIC_DEVICE is a base object that provides methods for getting information about physical devices on the host machine.
PHT_HW_HARD_DISK | The PHT_HW_HARD_DISK handle provides methods for getting the information about a physical hard disk on the host machine. The handle is obtained by calling the PrlSrvCfg_GetHardDisk function. The handle is derived from PHT_HW_GENERIC_DEVICE, which provides additional device management methods.
PHT_HW_HARD_DISK_PARTITION | The PHT_HW_HARD_DISK_PARTITION handle provides methods for getting the information about a physical hard disk partition. The handle is obtained by calling the PrlSrvCfgHdd_GetPart function. The handle is derived from PHT_HW_GENERIC_DEVICEt, which provides additional device management methods.
PHT_HW_NET_ADAPTER | The PHT_HW_NET_ADAPTER handle provides methods for getting the information about a network adapter on the host or in a virtual machine as seen by the guest operating system. The handle is obtained by calling the PrlSrvCfg_GetNetAdapter function. The handle is derived from the PHT_HW_GENERIC_DEVICE handle, which provides additional device management methods.
PHT_JOB | The PHT_JOB handle provides methods for managing asynchronous operations.
PHT_LICENSE | The PHT_LICENSE handle provides methods for retrieving the Parallels license information. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetLicenseInfo function.
PHT_LOGIN_RESPONSE | The PHT_LOGIN_RESPONSE handle is a container that contains information pertinent to a successful Parallels Service login operation. The handle is obtained from the PHT_JOB object returned by the PrlSrv_Login or the PrlSrv_LoginLocal function.
PHT_NET_SERVICE_STATUS | The PHT_NET_SERVICE_STATUS handle provides methods for retrieving the Parallels Service network status information. A handle to it is obtained from the PHT_JOB object returned by the PrlSrv_GetNetServiceStatus function.
PHT_PORT_FORWARDING | The PHT_PORT_FORWARDING handle provides access to the Port Forwarding functionality. Using this functionality, you can redirect all incoming data from a specific TCP port on the host machine to a specified port on a specified virtual machine.
PHT_REMOTE_FILESYSTEM_ENTRY | The PHT_REMOTE_FILESYSTEM_ENTRY handle, together with the PHT_REMOTE_FILESYSTEM_INFO handle, is used to obtain information about the file system on the host machine.The PHT_REMOTE_FILESYSTEM_ENTRY handle is a container that contains information about a single file system entry. The handle is obtained by making the PrlFsInfo_GetChildEntry call.
PHT_REMOTE_FILESYSTEM_INFO | The PHT_REMOTE_FILESYSTEM_INFO handle is a container that contains information about a file system entry and its immediate child elements (e.g. directory/files). The handle is obtained from a PHT_JOB object returned by the PrlSrv_FsGetDirEntries or the PrlSrv_FsGetDiskList function.
PHT_RESULT | The PHT_RESULT handle is a container that contains results of an asynchronous operation. The handle is obtained from the PHT_JOB object returned by the asynchronous function.
PHT_RUNNING_TASK | The PHT_RUNNING_TASK handle is used to recover from the lost Parallels Service connection. It allows to attach to an existing task that was started in the previous session and is still running inside the Parallels Service. The handle is obtained using the PrlLoginResponse_GetRunningTaskByIndex function. Only a limited number of tasks is supported by this functionality. They are defined in the PRL_RUNNING_TASK_TYPE_ENUM enumeration. For more information, please also see the PrlSrv_AttachToLostTask function.
PHT_SERVER | At the root of the Parallels API class hierarchy is a handle of type PHT_SERVER. The handle can be obtained using the PrlSrv_Create function. The PHT_SERVER handle is required to use most of the functionality within the Parallels API.
PHT_SERVER_CONFIG | The PHT_SERVER_CONFIG handle is used to retrieve the host configuration information and some of the virtual machine configuration parameters as seen by the operating system running on a virtual machine. The handle is obtained from the PHT_JOB object returned by the PrlSrv_GetSrvConfig function call.
PHT_SERVER_INFO | The PHT_SERVER_INFO handle is a container that contains information about a host machine. The information includes the Parallels Service port number, host name, OS version, product version, and host machine UUID. To obtain this information for the specified Parallels Service, use the PrlSrv_GetServerInfo function. You can also search for Parallels Services running on your network by executing the PrlSrv_LookupParallelsServers function. The function returns a list of PHT_SERVER_INFO handles for the Parallels Services that it finds. The returned information can be used to establish a connection with the Parallels Service of interest.
PHT_SHARE | The PHT_SHARE handle is used to manage host shares. With this handle, you can make a host OS folder visible and accessible in a virtual machine. The handle is obtained by making the PrlVmCfg_GetShare or the PrlVmCfg_CreateShare function call.
PHT_STRINGS_LIST | The PHT_STRING_LIST handle is a generic string container. A new handle is created by making the PrlApi_CreateStringsList function call.
PHT_SYSTEM_STATISTICS | The PHT_SYSTEM_STATISTICS handle is used to obtain performance statistics for the host computer or an individual virtual machine.
PHT_SYSTEM_STATISTICS_CPU | The PHT_SYSTEM_STATISTICS_CPU handle is used to obtain CPU statistics. The handle is obtained by making the PrlStat_GetCpuStat function call.
PHT_SYSTEM_STATISTICS_DISK | The PHT_SYSTEM_STATISTICS_DISK object is used to obtain disk statistics. The handle is obtained by making the PrlStat_GetDiskStat function call.
PHT_SYSTEM_STATISTICS_DISK_PARTITION | The PHT_SYSTEM_STATISTICS_DISK_PARTITION handle is used to obtain disk partition statistics. The handle is obtained by making the PrlStatDisk_GetPartStat function call.
PHT_SYSTEM_STATISTICS_IFACE | The PHT_SYSTEM_STATISTICS_IFACE handle is used to obtain network interface statistics. The handle is obtained by making the PrlStat_GetIfaceStat function call.
PHT_SYSTEM_STATISTICS_PROCESS | The PHT_SYSTEM_STATISTICS_PROCESS handle is used to obtain system process statistics. The handle is obtained by making the PrlStat_GetProcStat function call.
PHT_SYSTEM_STATISTICS_USER_SESSION | The PHT_SYSTEM_STATISTICS_USER_SESSION handle is used to obtain user session statistics. The handle is obtained by making the PrlStat_GetUserStat function call.
PHT_USER_INFO | The PHT_USER_INFO handle is a container that contains information about an individual user. The handle is obtained by making the PrlSrv_GetUserInfo or the PrlSrv_GetUserInfoList function call. The handle can be obtained for any user (not just the currently logged in user). To obtain the information for the currently logged in user, see the PHT_USER_PROFILE handle.
PHT_USER_PROFILE | The PHT_USER_PROFILE handle is used to obtain information about the currently logged in user and for setting the user preferences. The handle is obtained by calling the PrlSrv_GetUserProfile function. To obtain information about any user (not just the currently logged on user), see the PHT_USER_INFO handle.
PHT_VIRTUAL_DEV_FLOPPY | The PHT_VIRTUAL_DEV_FLOPPY handle contains information about a virtual floppy disk in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetFloppyDisk function call.
PHT_VIRTUAL_DEV_HARD_DISK | The PHT_VIRTUAL_DEV_HARD_DISK handle is used to manage virtual hard disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetHardDisk function call.
PHT_VIRTUAL_DEV_HD_PARTITION | The PHT_VIRTUAL_DEV_HD_PARTITION handle is used to manage partitions of a virtual hard disk in a virtual machine. The handle is obtained by making the PrlVmDevHd_AddPartition or the PrlVmDevHd_GetPartition function call.
PHT_VIRTUAL_DEV_NET_ADAPTER | The PHT_VIRTUAL_DEV_NET_ADAPTER handle is used to manage network adapters in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetNetAdapter function call.
PHT_VIRTUAL_DEV_OPTICAL_DISK | The PHT_VIRTUAL_DEV_OPTICAL_DISK handle contains information about a virtual optical disks in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetOpticalDisk function call.
PHT_VIRTUAL_DEV_PARALLEL_PORT | The PHT_VIRTUAL_DEV_PARALLEL_PORT handle contains information about a virtual parallel port in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetParallelPort function call.
PHT_VIRTUAL_DEV_SERIAL_PORT | The PHT_VIRTUAL_DEV_SERIAL_PORT handle is used to manage serial ports in a virtual machine. The handle is obtained by making the PrlVmCfg_CreateVmDev or the PrlVmCfg_GetSerialPort function call.
PHT_VIRTUAL_DEV_SOUND | The PHT_VIRTUAL_DEV_SOUND handle is used to manage sound devices in a virtual machine.
PHT_VIRTUAL_DEV_USB_DEVICE | The PHT_VIRTUAL_DEV_USB handle is used to managing USB devices in a virtual machine.
PHT_VIRTUAL_DISK | The PHT_VIRTUAL_DISK handle is used to create, configure, and manage Parallels virtual disks. A virtual disk is comprised of a set of files. There's a configuration file containing information about the disk parameters (number of heads, cylinders, sectors, etc.) and there are files that are used for data storage. Once created, a virtual disk can be attached to a virtual machine and recognized by it, just like a physical hard disk can be installed in a physical box. To create a new virtual disk use PrlDisk_CreateDisk or PrlDisk_CreateDisk_Local. To obtain a handle to an existing virtual disk, use PrlDisk_OpenDisk... more
PHT_VIRTUAL_MACHINE | PHT_VIRTUAL_MACHINE is the main virtual machine management handle. A handle to an existing virtual machine is obtained from the PHT_JOB object returned by the PrlSrv_GetVmList function. To create a new handle, call the PrlSrv_CreateVm function.
PHT_VIRTUAL_NETWORK | The PHT_VIRTUAL_NETWORK handle is used to manage virtual networks. A new handle is obtained by calling the PrlVirtNet_Create function. A handle to an existing virtual network is obtained by calling the PrlSrv_GetVirtualNetworkList function.
PHT_VM_CONFIGURATION | The PHT_VM_CONFIGURATION handle is used to manage the virtual machine configuration. The handle is obtained by calling the PrlVm_GetConfig function.
PHT_VM_GUEST_SESSION | The PHT_VM_GUEST_SESSION handle is used to run programs and execute administrative tasks in the virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
PHT_VM_INFO | The PHT_VM_INFO handle is a container that contains the virtual machine state, access rights, and other information. The handle is obtained by making the PrlVm_GetState function call.
PHT_VM_TOOLS_INFO | The PHT_VM_TOOLS_INFO handle is used to determine whether the Parallels Tools package is installed in the specified virtual machine and for obtaining its status and version information. The handle is obtained from the job object returned by the PrlVm_GetToolsState function.


GUI_ERR Macros Macros

GUI_ERR Macros Macros
GUI_ERR Macros
Macros
Name
Description
GUI_ERR_CANT_ADD_PCI_INSTANTLY

  • Gui messages

+++ ALIGNED VALUE TO 15000

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS


Handle Functions Functions

Handle Functions Functions
Handle Functions Legend
Functions
Name | Description
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetType | Returns the type of the specified handle.


Legend

Legend
Handle Functions
Legend
Method


Keyboard Control Functions

Keyboard Control Functions
Keyboard Control Legend
Functions
Name | Description
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.


Legend

Legend
Keyboard Control
Legend
Method


Mouse Control Functions

Mouse Control Functions
Mouse Control Legend
Functions
Name | Description
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).


Legend

Legend
Mouse Control
Legend
Method


Other Macros Macros

Other Macros Macros
Other Macros
Macros
Name
Description
FROM_PARALLELS_API_VER
FS_PERM_EXECUTE
FS_PERM_READ
FS_PERM_WRITE
IS_FREEBSD
IS_FS_EXECUTE_PERMITTED
IS_FS_READ_PERMITTED
IS_FS_WRITE_PERMITTED
IS_LINUX
IS_MACOS
IS_MSDOS
IS_NETWARE
IS_OS2
IS_OTHER
IS_SOLARIS
IS_VALID_FREEBSD_VERSION
IS_VALID_LINUX_VERSION
IS_VALID_MACOS_VERSION
IS_VALID_MSDOS_VERSION
IS_VALID_NETWARE_VERSION
IS_VALID_OS2_VERSION
IS_VALID_OTHER_OS_VERSION
IS_VALID_SOLARIS_VERSION
IS_VALID_WINDOWS_VERSION
IS_WINDOWS
PARALLELS_API_VER
Current Parallels API version.
PARALLELS_API_VER_1
PARALLELS_API_VER_2
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_SRV_METHOD_DECL
PRL_BSD_PARTITION
Free BSD partition.
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID

  • Disk validation errors

+++ ALIGNED VALUE TO 25000

PRL_CURRENT_GUEST_OS_SESSION
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_FAILED
PRL_FALSE
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_COMPRESSED_V2
Compressed disk (version 2)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_INVALID_HANDLE
PRL_INVALID_PARTITION
Invalid partition
PRL_IO_MAX_DISPLAYS
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_PARTITION
Mac OS
PRL_METHOD
Default method decoration
PRL_METHOD_DECL
Default method declaration for the header files
PRL_METHOD_PTR
PRL_MSDOS_EXTENDED_PARTITION

  • Disk partition types

Extended partitions

PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR

  • Network

+++ ALIGNED VALUE TO 4000

PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_NULL
NULL (invalid) handle
PRL_PRIVILEGED_GUEST_OS_SESSION
Guest OS sessions types and constants declarations
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_RESULT_DECLARE_ERROR
Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS
PRL_SRV_METHOD_DECL
PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_STRUCT
Default structure definition
PRL_SUCCEEDED
Success and failure result codes
PRL_TRUE
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions
PRL_WNG_START_VM_ON_MOUNTED_DISK
PVM_GET_MIGRATION_SECURITY_LEVEL
Macro for extracting VM migration security level value from flags mask
PVM_GET_MIGRATION_TYPE
Macro for extracting VM migration type value from flags mask
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_TYPE
PVS_MAKE_GUEST_VER
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_ENABLED
SET_FS_READ_DISABLED
SET_FS_READ_ENABLED
SET_FS_WRITE_DISABLED
SET_FS_WRITE_ENABLED
TO_PARALLELS_API_VER


Other Structs Enumerations

Other Structs Enumerations
Other Structs Legend
Enumerations
Name | Description
_PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
_PRL_APP_IN_DOCK_MODE | VM application in Dock mode
_PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
_PRL_CPU_HVT | CPU mode
_PRL_CPU_MODE | CPU mode
_PRL_DEVICE_ACTION | Device in use Action
_PRL_DEVICE_TYPE | Device type
_PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
_PRL_DISPLAY_CODEC_QUALITY | Display codec quality
_PRL_DISPLAY_CODEC_TYPE | Display codec types
_PRL_DOCK_ICON_TYPE | VM application icon type in Dock
_PRL_EVENT_ISSUER_TYPE | Event issuer type
_PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
_PRL_FILE_SYSTEM_FS_TYPE |
_PRL_FILE_SYSTEM_TYPE | File system general type
_PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
_PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
_PRL_HOST_OS_TYPE | Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
_PRL_IMAGE_FORMAT |
_PRL_IO_STATE |
_PRL_JOB_OPERATION_CODE | Job operation codes
_PRL_JOB_STATUS | Job status enumeration
_PRL_KEY_EVENT |
_PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
_PRL_MOUSE_BUTTON |
_PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
_PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
_PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PROCESS_STATE_TYPE | Process state element
_PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
_PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
_PRL_SECURITY_LEVEL | Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM | Parallels service statuses
_PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
_PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
_PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
_PRL_VERSION_ENUM | Parallels license versions enumeration.
_PRL_VM_ACCELERATION_LEVEL | Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
_PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION | VM autostart options
_PRL_VM_AUTOSTOP_OPTION | VM autostop options
_PRL_VM_BOOT_ORDER | VM boot order
_PRL_VM_CONFIG_SECTIONS | VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
_PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
_PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
_PRL_VM_PRIORITY | Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE | VM start login mode
_PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
_PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
_PRL_VM_WINDOW_MODE | VM window mode
_PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
PRL_APP_IN_DOCK_MODE | VM application in Dock mode
PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
PRL_CPU_HVT | CPU mode
PRL_CPU_MODE | CPU mode
PRL_DEVICE_ACTION | Device in use Action
PRL_DEVICE_TYPE | Device type
PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
PRL_DISPLAY_CODEC_QUALITY | Display codec quality
PRL_DISPLAY_CODEC_TYPE | Display codec types
PRL_DOCK_ICON_TYPE | VM application icon type in Dock
PRL_EVENT_ISSUER_TYPE | Event issuer type
PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
PRL_FILE_SYSTEM_FS_TYPE |
PRL_FILE_SYSTEM_TYPE | File system general type
PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
PRL_HOST_OS_TYPE | Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
PRL_IMAGE_FORMAT |
PRL_JOB_OPERATION_CODE | Job operation codes
PRL_JOB_STATUS | Job status enumeration
PRL_KEY_EVENT |
PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
PRL_MOUSE_BUTTON |
PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PROCESS_STATE_TYPE | Process state element
PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
PRL_SECURITY_LEVEL | Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM | Parallels service statuses
PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
PRL_VERSION_ENUM | Parallels license versions enumeration.
PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_STATE | Virtual machine states enumeration


Enumerations

Legend
Legend
Enumeration


Legend

Legend
Other Structs
Legend
Structure
Enumeration


Other Structs Structures

Other Structs Structures
Other Structs Legend
Structures
Name
Description
__PRL_DISK_PARAMETERS
Parallels disk parameters.
__PRL_IMAGE_PARAMETERS
Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
_PRL_API_METHOD
Parallels API method
_PRL_GUID
Global unique identifier
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GUEST_SCREENSAVER_STATE
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SLIDING_MOUSE
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_DISK_PARAMETERS
Parallels disk parameters.
PRL_IMAGE_PARAMETERS
Parallels storage parameters
PRL_SNAPSHOT_ELEMENT
Parallels snapshot tree element
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO


Structures

Legend
Legend
Structure


Other Types Types

Other Types Types
Other Types
Types
Name | Description
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |
PRL_STR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_STATE_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_VERSION_ENUM_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_API_METHOD_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLICATION_MODE_PTR |


PET Macros Macros

PET Macros Macros
PET Macros
Macros
Name
Description
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_CANCEL
PET_ANSWER_COMMIT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK

  • Answers

+++ ALIGNED VALUE TO 16000

PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_REVERT
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1

  • Questions

+++ ALIGNED VALUE TO 13000

PET_QUESTION_SAMPLE_2
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE


PHT_ACCESS_RIGHTS Functions

PHT_ACCESS_RIGHTS Functions
PHT_ACCESS_RIGHTS Legend
Functions
Name | Description
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.


Legend

Legend
PHT_ACCESS_RIGHTS
Legend
Method


PHT_BOOT_DEVICE Functions

PHT_BOOT_DEVICE Functions
PHT_BOOT_DEVICE Legend
Functions
Name | Description
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.


Legend

Legend
PHT_BOOT_DEVICE
Legend
Method


PHT_DISP_CONFIG Functions

PHT_DISP_CONFIG Functions
PHT_DISP_CONFIG Legend
Functions
Name | Description
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_CreateDispNet | Creates a new virtual network adapter object and adds it to the network adapters list.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetDispNet | Obtains information about a virtual network adapter from the Parallels Service configuration.
PrlDispCfg_GetDispNetCount | Determines the total number of the virtual network adapters in the Parallels Service configuration.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.


Legend

Legend
PHT_DISP_CONFIG
Legend
Method


PHT_DISP_NET_ADAPTER Functions

PHT_DISP_NET_ADAPTER Functions
PHT_DISP_NET_ADAPTER Legend
Functions
Name | Description
PrlDispNet_GetDhcpScopeEndIp | Returns the end IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeMask | Returns the subnet mask of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeStartIp | Returns the start IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetIndex | Returns the index identifying the specified adapter on the Parallels Service.
PrlDispNet_GetName | Returns the name of the specified virtual network adapter.
PrlDispNet_GetNetworkType | Returns the virtual network adapter network type (host-only or shared).
PrlDispNet_GetSysName | Returns the name of the physical network adapter to which the specified virtual network adapter is bound.
PrlDispNet_GetUuid | Returns the specified virtual network adapter UUID.
PrlDispNet_IsDhcpEnabled | Determines if DHCP scope is enabled for the specified virtual network adapter.
PrlDispNet_IsEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlDispNet_Remove | Removes the specified virtual network adapter object from memory.
PrlDispNet_SetDhcpEnabled | Allows to enable or disable the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeEndIp | Sets the end IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeMask | Sets the subnet mask of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeStartIp | Sets the start IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetEnabled | Allows to enable or disable a specified virtual network adapter.
PrlDispNet_SetIndex | Sets the specified virtual network adapter index (from 0 to 5).
PrlDispNet_SetName | Sets the specified virtual network adapter name.
PrlDispNet_SetNetworkType | Allows to set a network type for the specified virtual network adapter.
PrlDispNet_SetSysName | Sets the specified virtual network adapter system name.


Legend

Legend
PHT_DISP_NET_ADAPTER
Legend
Method


PHT_EVENT Functions

PHT_EVENT Functions
PHT_EVENT Legend
Functions
Name | Description
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.


Legend

Legend
PHT_EVENT
Legend
Method


PHT_EVENT_PARAMETER Functions

PHT_EVENT_PARAMETER Functions
PHT_EVENT_PARAMETER Legend
Functions
Name | Description
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.


Legend

Legend
PHT_EVENT_PARAMETER
Legend
Method


PHT_FOUND_VM_INFO Functions

PHT_FOUND_VM_INFO Functions
PHT_FOUND_VM_INFO Legend
Functions
Name | Description
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.


Legend

Legend
PHT_FOUND_VM_INFO
Legend
Method


PHT_HW_GENERIC_DEVICE Functions

PHT_HW_GENERIC_DEVICE Functions
PHT_HW_GENERIC_DEVICE Legend
Functions
Name | Description
PrlSrvCfgDev_GetId | Returns the system device ID.
PrlSrvCfgDev_GetName | Returns the system device name.
PrlSrvCfgDev_GetType | Returns the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to the virtual machine.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.


Legend

Legend
PHT_HW_GENERIC_DEVICE
Legend
Method


PHT_HW_HARD_DISK Functions

PHT_HW_HARD_DISK Functions
PHT_HW_HARD_DISK Legend
Functions
Name | Description
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.


Legend

Legend
PHT_HW_HARD_DISK
Legend
Method


PHT_HW_HARD_DISK_PARTITION Functions

PHT_HW_HARD_DISK_PARTITION Functions
PHT_HW_HARD_DISK_PARTITION Legend
Functions
Name | Description
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.


Legend

Legend
PHT_HW_HARD_DISK_PARTITION
Legend
Method


PHT_HW_NET_ADAPTER Functions

PHT_HW_NET_ADAPTER Functions
PHT_HW_NET_ADAPTER Legend
Functions
Name | Description
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.


Legend

Legend
PHT_HW_NET_ADAPTER
Legend
Method


PHT_JOB Functions

PHT_JOB Functions
PHT_JOB Legend
Functions
Name | Description
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.


Legend

Legend
PHT_JOB
Legend
Method


PHT_LICENSE Functions

PHT_LICENSE Functions
PHT_LICENSE Legend
Functions
Name | Description
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.


Legend

Legend
PHT_LICENSE
Legend
Method


PHT_LOGIN_RESPONSE Functions

PHT_LOGIN_RESPONSE Functions
PHT_LOGIN_RESPONSE Legend
Functions
Name | Description
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).


Legend

Legend
PHT_LOGIN_RESPONSE
Legend
Method


PHT_NET_SERVICE_STATUS Functions

PHT_NET_SERVICE_STATUS Functions
PHT_NET_SERVICE_STATUS Legend
Functions
Name | Description
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.


Legend

Legend
PHT_NET_SERVICE_STATUS
Legend
Method


PHT_PORT_FORWARDING Functions

PHT_PORT_FORWARDING Functions
PHT_PORT_FORWARDING Legend
Functions
Name | Description
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.


Legend

Legend
PHT_PORT_FORWARDING
Legend
Method


PHT_REMOTE_FILESYSTEM_ENTRY Functions

PHT_REMOTE_FILESYSTEM_ENTRY Functions
PHT_REMOTE_FILESYSTEM_ENTRY Legend
Functions
Name | Description
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).


Legend

Legend
PHT_REMOTE_FILESYSTEM_ENTRY
Legend
Method


PHT_REMOTE_FILESYSTEM_INFO Functions

PHT_REMOTE_FILESYSTEM_INFO Functions
PHT_REMOTE_FILESYSTEM_INFO Legend
Functions
Name | Description
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.


Legend

Legend
PHT_REMOTE_FILESYSTEM_INFO
Legend
Method


PHT_RESULT Functions

PHT_RESULT Functions
PHT_RESULT Legend
Functions
Name | Description
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.


Legend

Legend
PHT_RESULT
Legend
Method


PHT_RUNNING_TASK Functions

PHT_RUNNING_TASK Functions
PHT_RUNNING_TASK Legend
Functions
Name | Description
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).


Legend

Legend
PHT_RUNNING_TASK
Legend
Method


PHT_SERVER Functions

PHT_SERVER Functions
PHT_SERVER Legend
Functions
Name | Description
PrlSrv_AddNetAdapter | Adds a new virtual network adapter to the specified Parallels Service.
PrlSrv_AttachToLostTask | The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CheckParallelsServerAlive | Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CommonPrefsBeginEdit | The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit | The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_Create | Creates a new handle of type PHT_SERVER.
PrlSrv_CreateVm | Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_DeleteNetAdapter | Removes a virtual network adapter from the Parallels Service configuration.
PrlSrv_FsCanCreateFile | Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir | Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName | Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries | Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList | Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry | Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry | Renames a file system entry on the host.
PrlSrv_GetCommonPrefs | Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetLicenseInfo | Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus | Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetProblemReport | Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions | The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetServerInfo | Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig | Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetUserInfo | Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList | Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile | Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList | Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmList | Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_IsConnected | Determines if the connection to the specified Parallels Service is active.
PrlSrv_Login | Performs a remote login operation using the specified parameters.
PrlSrv_LoginLocal | Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_Logoff | Logs off the Parallels Service.
PrlSrv_LookupParallelsServers | Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart | Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults | Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart | Starts the Parallels network service.
PrlSrv_NetServiceStop | Stops the Parallels network service.
PrlSrv_RegEventHandler | Registers an event handler.
PrlSrv_RegisterVm | Registers an existing virtual machine with Parallels Service.
PrlSrv_SendAnswer | Sends an answer to the Parallels Service in response to a question.
PrlSrv_Shutdown | Shuts down the Parallels Service.
PrlSrv_StartSearchVms | Searches for unregistered virtual machines at the specified location(s).
PrlSrv_SubscribeToHostStatistics | Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_UnregEventHandler | Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics | Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats | Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateLicense | Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateNetAdapter | Updates an existing virtual network adapter in the specified Parallels Service.
PrlSrv_UserProfileBeginEdit | Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit | Saves (commits) user profile changes to the Parallels Service.


Legend

Legend
PHT_SERVER
Legend
Method


PHT_SERVER_CONFIG Functions

PHT_SERVER_CONFIG Functions
PHT_SERVER_CONFIG Legend
Functions
Name | Description
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of generic PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the server hostname.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetNetAdapter | Obtains an object of type PHT_HW_NET_ADAPTER containing information about a network adapter.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a parallel port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of parallel ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.


Legend

Legend
PHT_SERVER_CONFIG
Legend
Method


PHT_SERVER_INFO Functions

PHT_SERVER_INFO Functions
PHT_SERVER_INFO Legend
Functions
Name | Description
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).


Legend

Legend
PHT_SERVER_INFO
Legend
Method


PHT_SHARE Functions

PHT_SHARE Functions
PHT_SHARE Legend
Functions
Name | Description
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.


Legend

Legend
PHT_SHARE
Legend
Method


PHT_STRINGS_LIST Functions

PHT_STRINGS_LIST Functions
PHT_STRINGS_LIST Legend
Functions
Name | Description
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.


Legend

Legend
PHT_STRINGS_LIST
Legend
Method


PHT_SYSTEM_STATISTICS Functions

PHT_SYSTEM_STATISTICS Functions
PHT_SYSTEM_STATISTICS Legend
Functions
Name | Description
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns operating system uptime in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.


Legend

Legend
PHT_SYSTEM_STATISTICS
Legend
Method


PHT_SYSTEM_STATISTICS_CPU Functions

PHT_SYSTEM_STATISTICS_CPU Functions
PHT_SYSTEM_STATISTICS_CPU Legend
Functions
Name | Description
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.


Legend

Legend
PHT_SYSTEM_STATISTICS_CPU
Legend
Method


PHT_SYSTEM_STATISTICS_DISK Functions

PHT_SYSTEM_STATISTICS_DISK Functions
PHT_SYSTEM_STATISTICS_DISK Legend
Functions
Name | Description
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_DISK
Legend
Method


PHT_SYSTEM_STATISTICS_DISK_PARTITION Functions

PHT_SYSTEM_STATISTICS_DISK_PARTITION Functions
PHT_SYSTEM_STATISTICS_DISK_PARTITION Legend
Functions
Name | Description
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_DISK_PARTITION
Legend
Method


PHT_SYSTEM_STATISTICS_IFACE Functions

PHT_SYSTEM_STATISTICS_IFACE Functions
PHT_SYSTEM_STATISTICS_IFACE Legend
Functions
Name | Description
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.


Legend

Legend
PHT_SYSTEM_STATISTICS_IFACE
Legend
Method


PHT_SYSTEM_STATISTICS_PROCESS Functions

PHT_SYSTEM_STATISTICS_PROCESS Functions
PHT_SYSTEM_STATISTICS_PROCESS Legend
Functions
Name | Description
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.


Legend

Legend
PHT_SYSTEM_STATISTICS_PROCESS
Legend
Method


PHT_SYSTEM_STATISTICS_USER_SESSION Functions

PHT_SYSTEM_STATISTICS_USER_SESSION Functions
PHT_SYSTEM_STATISTICS_USER_SESSION Legend
Functions
Name | Description
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.


Legend

Legend
PHT_SYSTEM_STATISTICS_USER_SESSION
Legend
Method


PHT_USER_INFO Functions

PHT_USER_INFO Functions
PHT_USER_INFO Legend
Functions
Name | Description
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).


Legend

Legend
PHT_USER_INFO
Legend
Method


PHT_USER_PROFILE Functions

PHT_USER_PROFILE Functions
PHT_USER_PROFILE Legend
Functions
Name | Description
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.


Legend

Legend
PHT_USER_PROFILE
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_FLOPPY
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_HARD_DISK
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_HARD_DISK Functions

PHT_VIRTUAL_DEV_HARD_DISK Functions
PHT_VIRTUAL_DEV_HARD_DISK Legend
Functions
Name | Description
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.


Legend

Legend
PHT_VIRTUAL_DEV_HARD_DISK
Legend
Method


PHT_VIRTUAL_DEV_HD_PARTITION Functions

PHT_VIRTUAL_DEV_HD_PARTITION Functions
PHT_VIRTUAL_DEV_HD_PARTITION Legend
Functions
Name | Description
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.


Legend

Legend
PHT_VIRTUAL_DEV_HD_PARTITION
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_NET_ADAPTER
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_NET_ADAPTER Functions

PHT_VIRTUAL_DEV_NET_ADAPTER Functions
PHT_VIRTUAL_DEV_NET_ADAPTER Legend
Functions
Name | Description
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine.
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.


Legend

Legend
PHT_VIRTUAL_DEV_NET_ADAPTER
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_OPTICAL_DISK
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_PARALLEL_PORT
See Also

Common Virtual Device Functions


See Also

See Also
PHT_VIRTUAL_DEV_SERIAL_PORT
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_SERIAL_PORT Functions

PHT_VIRTUAL_DEV_SERIAL_PORT Functions
PHT_VIRTUAL_DEV_SERIAL_PORT Legend
Functions
Name | Description
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.


Legend

Legend
PHT_VIRTUAL_DEV_SERIAL_PORT
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_SOUND
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_SOUND Functions

PHT_VIRTUAL_DEV_SOUND Functions
PHT_VIRTUAL_DEV_SOUND Legend
Functions
Name | Description
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.


Legend

Legend
PHT_VIRTUAL_DEV_SOUND
Legend
Method


See Also

See Also
PHT_VIRTUAL_DEV_USB_DEVICE
See Also

Common Virtual Device Functions


PHT_VIRTUAL_DEV_USB_DEVICE Functions

PHT_VIRTUAL_DEV_USB_DEVICE Functions
PHT_VIRTUAL_DEV_USB_DEVICE Legend
Functions
Name | Description
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.


Legend

Legend
PHT_VIRTUAL_DEV_USB_DEVICE
Legend
Method


PHT_VIRTUAL_DISK Functions

PHT_VIRTUAL_DISK Functions
PHT_VIRTUAL_DISK Legend
Functions
Name | Description
PrlDisk_Coagulate | Merges all snapshots.
PrlDisk_Compact | Compacts a virtual disk.
PrlDisk_ConvertToCurrent | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_ConvertToCurrent_Local | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Start creation procedure of the new state
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_DeleteState | Start delete state procedure.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | This method is used to free the disk reference with closing.
PrlDisk_GetDiskInfo | Get disk information.
PrlDisk_GetSnapshotsCount | Get snapshots count.
PrlDisk_GetSnapshotsTree | Get snapshots tree.
PrlDisk_GetUserParameter | Get user parameter for disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsCompactable | Check is image compactable.
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Method let to open disk and return handle This function can be used locally, without a Parallels Service connection.
PrlDisk_Read | Write data to disk.
PrlDisk_SetCachingPolicy | Set caching policy for disk.
PrlDisk_SetSharedDirectory | Set shared directory (all files created somewhere in this directory will have 666 permissions).
PrlDisk_SetSharedDirectory_Local | Set shared directory (all files created somewhere in this directory will have 666 permissions) This function can be used locally, without a Parallels Service connection.
PrlDisk_SetUserParameter | Set user parameter for disk.
PrlDisk_SwitchToState | Start switching to state procedure.
PrlDisk_WaitForCompletion | Wait for completion of the work.
PrlDisk_Write | Write data to disk.


Legend

Legend
PHT_VIRTUAL_DISK
Legend
Method


PHT_VIRTUAL_MACHINE Functions

PHT_VIRTUAL_MACHINE Functions
PHT_VIRTUAL_MACHINE Legend
Functions
Name | Description
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompressor | Cancels the running Compressor operation that was started with PrlVm_RunCompressor.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_RunCompressor | Initiates the Compressor process.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.


Legend

Legend
PHT_VIRTUAL_MACHINE
Legend
Method


PHT_VIRTUAL_NETWORK Functions

PHT_VIRTUAL_NETWORK Functions
PHT_VIRTUAL_NETWORK Legend
Functions
Name | Description
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.


Legend

Legend
PHT_VIRTUAL_NETWORK
Legend
Method


PHT_VM_CONFIGURATION Functions

PHT_VM_CONFIGURATION Functions
PHT_VM_CONFIGURATION Legend
Functions
Name | Description
PrlVmCfg_AddDefaultDevice | The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_CreateBootDev | Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes | Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare | Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev | Creates a new virtual device handle of the specified type.
PrlVmCfg_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetAppInDockMode | Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAutoStart | Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay | Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop | Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority | Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev | Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount | Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetConfigValidity | The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetCpuAccelLevel | Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount | Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuMode | Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits | Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty | Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize | The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize | The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDescription | Returns the specified virtual machine description.
PrlVmCfg_GetDevByType | Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount | Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType | Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDevsList | Returns a pointer to a buffer containing handles to the virtual devices installed in a virtual machine.
PrlVmCfg_GetDnsServers | Obtains the list of globally defined DNS servers that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetDockIconType | Returns the virtual machine dock icon type.
PrlVmCfg_GetFloppyDisk | Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount | Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority | Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetGenericPciDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount | Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount | Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk | Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount | Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHomePath | Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostname | Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon | Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetLastModifiedDate | Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName | Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetName | Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter | Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount | Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetOpticalDisk | Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount | Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOsType | Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion | Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort | Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual parallel port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount | Determines the number of virtual parallel ports in the specified virtual machine.
PrlVmCfg_GetRamSize | Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetScrRes | Returns the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount | Returns the virtual machine screen resolutions count.
PrlVmCfg_GetSearchDomains | Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort | Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount | Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost | Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid | Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare | Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount | Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSoundDev | Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount | Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode | Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin | Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags | Returns the virtual machine system flags.
PrlVmCfg_GetUndoDisksMode | Determines the current undo disks mode for the specified virtual machine.
PrlVmCfg_GetUsbDevice | Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount | Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid | Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize | Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVNCHostName | Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode | Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword | Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort | Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode | Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsCloseAppOnShutdown | Returns Virtual Machine close app on shutdown sign.
PrlVmCfg_IsCpuVtxEnabled | Returns Virtual Machine CPU VTx support enabling sign.
PrlVmCfg_IsDefaultDeviceNeeded | Determines if a virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC | Gets the APIC using for virtual machine in runtime.
PrlVmCfg_IsDiskCacheWriteBack | Determines if disk cache write-back is enabled for the specified virtual machine.
PrlVmCfg_IsExcludeDock | Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsGuestSharingAutoMount | Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled | Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight | Determines if VM virtual disks will be added to Spotlight search subsystem.
PrlVmCfg_IsHostSharingEnabled | Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsMapSharedFoldersOnLetters | Determines whether host disks shared into guest Windows OS will be maped on drive letters.
PrlVmCfg_IsMultiDisplay | Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsOsResInFullScrMode | Determines if a virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsRelocateTaskBar | Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled | Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks | Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsSharedProfileEnabled | Returns sign whether shared profile is enabled.
PrlVmCfg_IsShareUserHomeDir | Determines whether host user home dir will be present at guest OS as share.
PrlVmCfg_IsShowTaskBar | Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsSmartGuardEnabled | Returns sign whether smart guard is enabled.
PrlVmCfg_IsTemplate | Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsUseDesktop | Returns sign whether use desktop in shared profile is enabled.
PrlVmCfg_IsUseDocuments | Returns sign whether use documents in shared profile is enabled.
PrlVmCfg_IsUseMusic | Returns sign whether use music in shared profile is enabled.
PrlVmCfg_IsUsePictures | Returns sign whether use pictures in shared profile is enabled.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled | Returns sign whether user defined shared folders enabled.
PrlVmCfg_SetAppInDockMode | Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAutoStart | Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay | Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop | Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority | Sets virtual machine background processes priority.
PrlVmCfg_SetCloseAppOnShutdown | Sets Virtual Machine close app on shutdown sign.
PrlVmCfg_SetCpuAccelLevel | Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount | Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuMode | Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits | Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty | Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig | The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription | Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign | Sets the APIC using for virtual machine in runtime.
PrlVmCfg_SetDiskCacheWriteBack | Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers | Allows to manually set the global DNS server list that will assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetDockIconType | Sets the virtual machine dock icon type.
PrlVmCfg_SetExcludeDock | Sets the exclude dock option.
PrlVmCfg_SetForegroundPriority | Sets the virtual machine foreground processes priority.
PrlVmCfg_SetGuestSharingAutoMount | Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled | Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight | Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHostname | Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled | Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon | Sets the virtual machine icon.
PrlVmCfg_SetMapSharedFoldersOnLetters | Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMultiDisplay | Sets the virtual machine multi-display option.
PrlVmCfg_SetName | Sets the specified virtual machine name.
PrlVmCfg_SetOsResInFullScrMode | Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsVersion | Sets the virtual machine guest OS version.
PrlVmCfg_SetRamSize | Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRelocateTaskBar | Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetScrResEnabled | Sets the additional screen resolution support option in the specified virtual machine
PrlVmCfg_SetSearchDomains | Allows to manually set the global search domain list that will be assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetShareAllHostDisks | Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetSharedProfileEnabled | Lets to set shared profile enabling sign.
PrlVmCfg_SetShareUserHomeDir | Enables sharing of host user home dir for the specified virtual machine.
PrlVmCfg_SetShowTaskBar | Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetSmartGuardEnabled | Lets to set smart guard enabling sign.
PrlVmCfg_SetStartLoginMode | Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds | Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetSystemFlags | Sets Virtual Machine system flags.
PrlVmCfg_SetTemplateSign | Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetUndoDisksMode | Sets the undo disks mode for the virtual machine (see PRL_UNDO_DISKS_MODE for available options).
PrlVmCfg_SetUseDesktop | Lets to set use desktop in shared profile enabling sign.
PrlVmCfg_SetUseDocuments | Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseMusic | Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures | Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled | Lets to set user defined shared folders enabling sign.
PrlVmCfg_SetUuid | Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVideoRamSize | Sets the virtual machine video memory size.
PrlVmCfg_SetVNCHostName | Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode | Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword | Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort | Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode | Sets the virtual machine window mode.


Legend

Legend
PHT_VM_CONFIGURATION
Legend
Method


PHT_VM_GUEST_SESSION Functions

PHT_VM_GUEST_SESSION Functions
PHT_VM_GUEST_SESSION Legend
Functions
Name | Description
PrlVmGuest_GetNetworkSettings | Obtains network settings of an operating system running on a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.


Legend

Legend
PHT_VM_GUEST_SESSION
Legend
Method


PHT_VM_INFO Functions

PHT_VM_INFO Functions
PHT_VM_INFO Legend
Functions
Name | Description
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.


Legend

Legend
PHT_VM_INFO
Legend
Method


PHT_VM_TOOLS_INFO Functions

PHT_VM_TOOLS_INFO Functions
PHT_VM_TOOLS_INFO Legend
Functions
Name | Description
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.


Legend

Legend
PHT_VM_TOOLS_INFO
Legend
Method


Primary Display Capture Functions

Primary Display Capture Functions
Primary Display Capture Legend
Functions
Name | Description
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetScreenSurface | Sets CoreGraphics surface for fast server-side display updates.
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.


Legend

Legend
Primary Display Capture
Legend
Method


_PRL_ALLOWED_VM_COMMAND Enumeration

_PRL_ALLOWED_VM_COMMAND Enumeration
PrlEnums.h Other Structs Send Feedback

Allowed vm commands enumeration

Syntax
enum _PRL_ALLOWED_VM_COMMAND {
  PAR_VM_START_ACCESS = 0,
  PAR_VM_STOP_ACCESS = 1,
  PAR_VM_PAUSE_ACCESS = 2,
  PAR_VM_RESET_ACCESS = 3,
  PAR_VM_SUSPEND_ACCESS = 4,
  PAR_VM_RESUME_ACCESS = 5,
  PAR_VM_DROPSUSPENDEDSTATE_ACCESS = 6,
  PAR_VM_CLONE_ACCESS = 7,
  PAR_VM_DELETE_ACCESS = 8,
  PAR_VM_GETPROBLEMREPORT_ACCESS = 9,
  PAR_VM_GETCONFIG_ACCESS = 10,
  PAR_VM_GETSTATISTICS_ACCESS = 11,
  PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS = 12,
  PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNREG_ACCESS = 13,
  PAR_VM_EDITING_ACCESS = 14,
  PAR_VM_BEGINEDIT_ACCESS = PAR_VM_EDITING_ACCESS,
  PAR_VM_COMMIT_ACCESS = PAR_VM_EDITING_ACCESS,
  PAR_VMDEV_CONNECT_ACCESS = 15,
  PAR_VMDEV_DISCONNECT_ACCESS = 16,
  PAR_VMDEV_CREATEIMAGE_ACCESS = 17,
  PAR_VM_SEND_ANSWER_ACCESS = 18,
  PAR_VM_GET_VMINFO_ACCESS = 19,
  PAR_VM_INSTALL_TOOLS_ACCESS = 20,
  PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS = 21,
  PAR_VM_UPDATE_SECURITY_ACCESS = 22,
  PAR_VM_CANCEL_COMPACT_ACCESS = 23,
  PAR_VM_REGISTER_ACCESS = 24,
  PAR_VM_MIGRATE_ACCESS = 25,
  PAR_VM_START_STOP_VNC_SERVER = 26,
  PAR_VM_GET_SUSPENDED_SCREEN_ACCESS = 27,
  PAR_VM_PERFSTAT_ACCESS = 28,
  PAR_VM_MIGRATE_CANCEL_ACCESS = 30,
  PAR_VM_RUN_COMPRESSOR_ACCESS = 31,
  PAR_VM_CANCEL_COMPRESSOR_ACCESS = 32,
  PAR_VM_CREATE_SNAPSHOT_ACCESS = 33,
  PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS = 34,
  PAR_VM_DELETE_SNAPSHOT_ACCESS = 35,
  PAR_VM_START_EX_ACCESS = 36,
  PAR_VM_RESTART_GUEST_ACCESS = 38,
  PAR_VM_INSTALL_UTILITY_ACCESS = 39,
  PAR_VM_UPDATE_TOOLS_SECTION = 40,
  PAR_VM_RESTORE_ACCESS = 41,
  PAR_MAX
};
File

PrlEnums.h

Members

PAR_VM_MIGRATE_CANCEL_ACCESS
PAR_VM_UPDATE_COHERENCE = 29,
PAR_VM_RESTART_GUEST_ACCESS
PAR_VM_UPDATE_SHARED_PROFILES = 37,
PAR_MAX
should be the last

Links
PrlEnums.h, Other Structs


_PRL_API_METHOD Structure

_PRL_API_METHOD Structure
PrlTypes.h Other Structs Send Feedback

Parallels API method

Syntax
struct _PRL_API_METHOD {
  PRL_CONST_STR MethodName;
  PRL_UINT32 MethodAPIVersion;
  PRL_VOID_PTR MethodPtr;
  PRL_BOOL MethodIsDeprecated;
  PRL_BOOL MethodIsAsync;
  PRL_BOOL MethodIsSrv;
  PRL_UINT32 ReservedA;
  PRL_UINT32 ReservedB;
  PRL_UINT32 ReservedC;
  PRL_UINT32 ReservedD;
};
File

PrlTypes.h

Members

ReservedA
Reserved for future use

Links
PrlTypes.h, Other Structs


_PRL_APP_IN_DOCK_MODE Enumeration

_PRL_APP_IN_DOCK_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM application in Dock mode

Syntax
enum _PRL_APP_IN_DOCK_MODE {
  PDM_APP_IN_DOCK_NEVER = 0,
  PDM_APP_IN_DOCK_COHERENCE_ONLY = 1,
  PDM_APP_IN_DOCK_ALWAYS = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_APPLICATION_MODE Enumeration

_PRL_APPLICATION_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode

Syntax
enum _PRL_APPLICATION_MODE {
  PAM_UNKNOWN = 0xffff,
  PAM_SERVER = 0,
  PAM_DESKTOP = 1,
  PAM_WORKSTATION = 2,
  PAM_PLAYER = 3,
  PAM_STM = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_BOOL Types Types

PRL_BOOL Types Types
PRL_BOOL Types
Types
Name | Description
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |


PRL_CHAR Types Types

PRL_CHAR Types Types
PRL_CHAR Types
Types
Name | Description
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |


PRL_CONST Types Types

PRL_CONST Types Types
PRL_CONST Types
Types
Name | Description
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VOID_PTR |


_PRL_CPU_HVT Enumeration

_PRL_CPU_HVT Enumeration
PrlEnums.h Other Structs Send Feedback

CPU mode

Syntax
enum _PRL_CPU_HVT {
  PCM_CPU_NONE_HV = 0,
  PCM_CPU_INTEL_VT_X,
  PCM_CPU_AMD_V
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_CPU_MODE Enumeration

_PRL_CPU_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

CPU mode

Syntax
enum _PRL_CPU_MODE {
  PCM_CPU_MODE_32 = 0,
  PCM_CPU_MODE_64 = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_DEVICE_ACTION Enumeration

_PRL_DEVICE_ACTION Enumeration
PrlEnums.h Other Structs Send Feedback

Device in use Action

Syntax
enum _PRL_DEVICE_ACTION {
  PDA_DEVICE_IDLE = 0,
  PDA_DEVICE_READ = 1,
  PDA_DEVICE_WRITE = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_DEVICE_TYPE Enumeration

_PRL_DEVICE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Device type

Syntax
enum _PRL_DEVICE_TYPE {
  PDE_GENERIC_DEVICE = 0,
  PDE_CLUSTERED_DEVICE = 1,
  PDE_STORAGE_DEVICE = 2,
  PDE_FLOPPY_DISK = 3,
  PDE_MASSSTORAGE_DEVICE = 4,
  PDE_OPTICAL_DISK = 5,
  PDE_HARD_DISK = 6,
  PDE_GENERIC_NETWORK_ADAPTER = 8,
  PDE_GENERIC_PORT = 9,
  PDE_SERIAL_PORT = 10,
  PDE_PARALLEL_PORT = 11,
  PDE_SOUND_DEVICE = 12,
  PDE_MIXER_DEVICE = 13,
  PDE_USB_DEVICE = 15,
  PDE_PRINTER = 16,
  PDE_GENERIC_PCI_DEVICE = 17,
  PDE_GENERIC_SCSI_DEVICE = 18,
  PDE_VIRTUAL_SNAPSHOT_DEVICE = 19,
  PDE_MAX
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DEVICE Types Types

PRL_DEVICE Types Types
PRL_DEVICE Types
Types
Name | Description
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |


PRL_DISK Macros Macros

PRL_DISK Macros Macros
PRL_DISK Macros
Macros
Name | Description
PRL_DISK_CACHE_DEFAULT | Disk cache default.
PRL_DISK_CACHE_DISABLED | Uncached access to disk image.
PRL_DISK_CACHE_ENABLED | Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ | Cached write/uncached read.
PRL_DISK_DEFAULT_FLAG | Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN | Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT | Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK | Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING | Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED | Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL | Normal access mode (default os)
PRL_DISK_INVALID | Last (invalid).
PRL_DISK_NOTHING | Nothing.
PRL_DISK_PROGRESS_COMPLETED |
PRL_DISK_PROGRESS_MAX |
PRL_DISK_PROGRESS_MIN | States progress definition.
PRL_DISK_READ | Read
PRL_DISK_READ_LOCK | ReadLock
PRL_DISK_WRITE | Write
PRL_DISK_WRITE_THROUGH | Write through, disable caching
PRL_DISK_XML_CHANGE | This parameter is used when user need to change XML data but not access to the drive itself.


PRL_DISK Types Types

PRL_DISK Types Types
PRL_DISK Types
Types
Name | Description
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |


_PRL_DISPLAY_CODEC_COMPRESSION Enumeration

_PRL_DISPLAY_CODEC_COMPRESSION Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec compression

Syntax
enum _PRL_DISPLAY_CODEC_COMPRESSION {
  PDCC_HIGH_COMPRESSION = 1<<15,
  PDCC_MEDIUM_COMPRESSION = 1<<16,
  PDCC_LOW_COMPRESSION = 1<<17,
  PDCC_NO_COMPRESSION = 1<<18
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_DISPLAY_CODEC_QUALITY Enumeration

_PRL_DISPLAY_CODEC_QUALITY Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec quality

Syntax
enum _PRL_DISPLAY_CODEC_QUALITY {
  PDCQ_HIGH_QUALITY = 1<<0,
  PDCQ_MEDIUM_QUALITY = 1<<1,
  PDCQ_LOW_QUALITY = 1<<2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_DISPLAY_CODEC_TYPE Enumeration

_PRL_DISPLAY_CODEC_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec types

Syntax
enum _PRL_DISPLAY_CODEC_TYPE {
  PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_HIGH_QUALITY_WITH_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITH_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_LOW_QUALITY_WITHOUT_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_LOW_QUALITY_WITH_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_MEDIUM_COMPRESSION
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_DOCK_ICON_TYPE Enumeration

_PRL_DOCK_ICON_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

VM application icon type in Dock

Syntax
enum _PRL_DOCK_ICON_TYPE {
  PIT_DOCK_ICON_SYSTEM = 0,
  PIT_DOCK_ICON_LIVE_SCREEN_SHOT = 1,
  PIT_DOCK_ICON_START_MENU = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_ERR Macros Macros

PRL_ERR Macros Macros
PRL_ERR Macros
Macros
Name
Description
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON

  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED

  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED

  • Other

+++ ALIGNED VALUE TO 10000

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED

  • Parallel Port

+++ ALIGNED VALUE TO 7000

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED

  • Serial Port

+++ ALIGNED VALUE TO 6000

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED

  • USB

+++ ALIGNED VALUE TO 8000

PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND

  • User parameters errors

* +++ ALIGNED VALUE TO 23000

PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR

  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

PRL_ERR_DISK_GET_MOUNTPATH_FAILED

  • Bootcamp errors

* +++ ALIGNED VALUE TO 24000

PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SHARED_BLOCK

  • Compressing errors

* +++ ALIGNED VALUE TO 22000

PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED

  • File Transfer errors

+++ ALIGNED VALUE TO 26000

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_PARALLELS_DISK

  • Hard Drive

+++ ALIGNED VALUE TO 2000

PRL_ERR_INVALID_PARAM
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED

  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID

  • License

+++ ALIGNED VALUE TO 11000

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_DEVICE_WRITE_FAILED

  • Sound

+++ ALIGNED VALUE TO 5000

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR

  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID

  • TIS errors

+++ ALIGNED VALUE TO 27800

PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG

  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG

  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_PROCESSING

  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS
PRL_ERR_VM_LOCKED_FOR_CLONE
FIXME: all constants like 'PRL_ERR_VM_LOCKED_FOR_***' should be changed to 'PRL_ERR_CONCURRENT_COMMAND_EXECUTING' until fix bug #6370 ( http://bugzilla/show_bug.cgi?id=6370 )
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
ALIGNED VALUE TO 27550
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED

  • Validation VM configuration error

+++ ALIGNED VALUE TO 27000

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_NOT_MAPPED

  • VT-d

+++ ALIGNED VALUE TO 12000

PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE


_PRL_EVENT_ISSUER_TYPE Enumeration

_PRL_EVENT_ISSUER_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Event issuer type

Syntax
enum _PRL_EVENT_ISSUER_TYPE {
  PIE_VIRTUAL_MACHINE = 0,
  PIE_DISPATCHER = 1,
  PIE_IO_SERVICE = 2,
  PIE_WEB_SERVICE = 3
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration

_PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

File system element type

Syntax
enum _PRL_FILE_SYSTEM_ELEMENT_TYPE {
  PSE_DRIVE = 0,
  PSE_DIRECTORY = 1,
  PSE_FILE = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_FILE_SYSTEM_FS_TYPE Enumeration

_PRL_FILE_SYSTEM_FS_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
enum _PRL_FILE_SYSTEM_FS_TYPE {
  PRL_FS_INVALID = 0,
  PRL_FS_FAT = 1,
  PRL_FS_FAT32 = 2,
  PRL_FS_NTFS = 3,
  PRL_FS_HFS = 4,
  PRL_FS_ADFS = 5,
  PRL_FS_AFFS = 6,
  PRL_FS_AFS = 7,
  PRL_FS_AUTOFS = 8,
  PRL_FS_CODA = 9,
  PRL_FS_EFS = 10,
  PRL_FS_EXTFS = 11,
  PRL_FS_HPFS = 12,
  PRL_FS_ISOFS = 13,
  PRL_FS_JFFS2 = 14,
  PRL_FS_NFS = 15,
  PRL_FS_QNX4 = 16,
  PRL_FS_REISERFS = 17,
  PRL_FS_SMBFS = 18,
  PRL_FS_UNSPECIFIED = 0xFF
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_FILE_SYSTEM_TYPE Enumeration

_PRL_FILE_SYSTEM_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

File system general type

Syntax
enum _PRL_FILE_SYSTEM_TYPE {
  PFS_WINDOWS_LIKE_FS = 0,
  PFS_UNIX_LIKE_FS = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_FILE Types Types

PRL_FILE Types Types
PRL_FILE Types
Types
Name | Description
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |


_PRL_GRACEFUL_SHUTDOWN_KIND Enumeration

_PRL_GRACEFUL_SHUTDOWN_KIND Enumeration
PrlEnums.h Other Structs Send Feedback

Graceful Shutdown types

Syntax
enum _PRL_GRACEFUL_SHUTDOWN_KIND {
  PST_VM_SHUTDOWN = 0,
  PST_VM_REBOOT = 1,
  PST_VM_HIBERNATE = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_GUEST_DISTRO_VERSION_ENUM Enumeration

_PRL_GUEST_DISTRO_VERSION_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Windows installation distributive type.

Syntax
enum _PRL_GUEST_DISTRO_VERSION_ENUM {
  PGD_UNKNOWN = 0,
  PGD_WINDOWS_VISTA = 1,
  PGD_WINDOWS_XP = 2,
  PGD_WINDOWS_XP_32 = PGD_WINDOWS_XP,
  PGD_WINDOWS_XP_64 = 3,
  PGD_WINDOWS_VISTA_32 = PGD_WINDOWS_VISTA,
  PGD_WINDOWS_VISTA_64 = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_GUID Structure

_PRL_GUID Structure
PrlTypes.h Other Structs Send Feedback

Global unique identifier

Syntax
struct _PRL_GUID {
  PRL_UINT32 Data1;
  PRL_UINT16 Data2;
  PRL_UINT16 Data3;
  PRL_UINT8 Data4[8];
};
File

PrlTypes.h

Links
PrlTypes.h, Other Structs


_PRL_HANDLE_TYPE Enumeration

_PRL_HANDLE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

The _PRL_HANDLE_TYPE enumeration defines handle types.

Syntax
enum _PRL_HANDLE_TYPE {
  PHT_ERROR = 0,
  PHT_SERVER = 0x10000001,
  PHT_SERVER_CONFIG = 0x10000002,
  PHT_REMOTE_FILESYSTEM_INFO = 0x10000003,
  PHT_REMOTE_FILESYSTEM_ENTRY = 0x10000004,
  PHT_VIRTUAL_MACHINE = 0x10000005,
  PHT_VIRTUAL_DEV_DISPLAY = 0x10000006,
  PHT_VIRTUAL_DEV_KEYBOARD = 0x10000007,
  PHT_VIRTUAL_DEV_MOUSE = 0x10000008,
  PHT_VIRTUAL_DEV_FLOPPY = 0x10000009,
  PHT_VIRTUAL_DEV_HARD_DISK = 0x1000000A,
  PHT_VIRTUAL_DEV_NET_ADAPTER = 0x1000000B,
  PHT_VIRTUAL_DEV_PARALLEL_PORT = 0x1000000C,
  PHT_VIRTUAL_DEV_SERIAL_PORT = 0x1000000D,
  PHT_VIRTUAL_DEV_OPTICAL_DISK = 0x1000000E,
  PHT_VIRTUAL_DEV_USB_DEVICE = 0x1000000F,
  PHT_VIRTUAL_DEV_SOUND = 0x10000010,
  PHT_JOB = 0x10000011,
  PHT_EVENT = 0x10000012,
  PHT_RESULT = 0x10000013,
  PHT_VM_INFO = 0x10000014,
  PHT_USER_PROFILE = 0x10000015,
  PHT_DISP_CONFIG = 0x10000016,
  PHT_SHARE = 0x10000017,
  PHT_SCREEN_RESOLUTION = 0x10000018,
  PHT_DISP_NET_ADAPTER = 0x10000019,
  PHT_HW_GENERIC_DEVICE = 0x1000001A,
  PHT_HW_HARD_DISK = 0x1000001B,
  PHT_HW_HARD_DISK_PARTITION = 0x1000001C,
  PHT_HW_NET_ADAPTER = 0x1000001D,
  PHT_EVENT_PARAMETER = 0x1000001E,
  PHT_REMOTEDEV_CMD = 0x1000001F,
  PHT_SYSTEM_STATISTICS = 0x10000020,
  PHT_SYSTEM_STATISTICS_CPU = 0x10000021,
  PHT_SYSTEM_STATISTICS_IFACE = 0x10000022,
  PHT_SYSTEM_STATISTICS_USER_SESSION = 0x10000023,
  PHT_SYSTEM_STATISTICS_DISK = 0x10000024,
  PHT_SYSTEM_STATISTICS_DISK_PARTITION = 0x10000025,
  PHT_SYSTEM_STATISTICS_PROCESS = 0x10000026,
  PHT_LICENSE = 0x10000027,
  PHT_SERVER_INFO = 0x10000028,
  PHT_BOOT_DEVICE = 0x10000029,
  PHT_STRINGS_LIST = 0x1000002A,
  PHT_LOGIN_RESPONSE = 0x1000002B,
  PHT_RUNNING_TASK = 0x1000002C,
  PHT_NET_SERVICE_STATUS = 0x1000002D,
  PHT_HANDLES_LIST = 0x1000002E,
  PHT_VIRTUAL_DISK = 0x1000002F,
  PHT_ACCESS_RIGHTS = 0x10000030,
  PHT_VM_TOOLS_INFO = 0x10000031,
  PHT_FOUND_VM_INFO = 0x10000032,
  PHT_TIS_RECORD = 0x10000033,
  PHT_USER_INFO = 0x10000034,
  PHT_VM_CONFIGURATION = PHT_VIRTUAL_MACHINE,
  PHT_TIS_EMITTER = 0x10000036,
  PHT_TOOL = 0x10000037,
  PHT_VIRTUAL_DEV_HD_PARTITION = 0x10000038,
  PHT_VIRTUAL_DEV_GENERIC_PCI = 0x10000039,
  PHT_VIRTUAL_DEV_GENERIC_SCSI = 0x1000003A,
  PHT_VM_GUEST_SESSION = 0x1000003B,
  PHT_VIRTUAL_NETWORK = 0x1000003C,
  PHT_PORT_FORWARDING = 0x1000003D,
  PHT_LAST = PHT_PORT_FORWARDING
};
File

PrlEnums.h

Members

PHT_LAST
sould be set to last

Remarks

Each handle type and the functions that operate on it is described in detail in the "Functions by Handle" chapter of the Parallels C API Reference guide.

Links
PrlEnums.h, Other Structs


_PRL_HARD_DISK_INTERNAL_FORMAT Enumeration

_PRL_HARD_DISK_INTERNAL_FORMAT Enumeration
PrlEnums.h Other Structs Send Feedback

Hard disk image type

Syntax
enum _PRL_HARD_DISK_INTERNAL_FORMAT {
  PHD_PLAIN_HARD_DISK = 0,
  PHD_EXPANDING_HARD_DISK = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_HOST_OS_TYPE Enumeration

_PRL_HOST_OS_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Host OS type

Syntax
enum _PRL_HOST_OS_TYPE {
  PHO_MAC = 0,
  PHO_LIN = 1,
  PHO_WIN = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration

_PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Network adapter types in hardware info list

Syntax
enum _PRL_HW_INFO_NET_ADAPTER_TYPE {
  PHI_REAL_NET_ADAPTER = 0,
  PHI_VIRTUAL_NET_ADAPTER = 1,
  PHY_WIFI_REAL_NET_ADAPTER = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_IMAGE_FORMAT Enumeration

_PRL_IMAGE_FORMAT Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
enum _PRL_IMAGE_FORMAT {
  PIF_RAW = 0x50000008,
  PIF_BMP = 0x50000009,
  PIF_JPG = 0x5000000A,
  PIF_PNG = 0x5000000B
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_INT Types Types

PRL_INT Types Types
PRL_INT Types
Types
Name | Description
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |


_PRL_IO_ATTACH_REQUEST Structure

_PRL_IO_ATTACH_REQUEST Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_ATTACH_REQUEST {
  PRL_UINT32 isClientLocal;
  PRL_UINT32 encodingType;
  PRL_UINT8 vmUuid[16];
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_ATTACH_RESPONSE Structure

_PRL_IO_ATTACH_RESPONSE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_ATTACH_RESPONSE {
  PRL_UINT32 attachResult;
  PRL_UINT32 encodingResult;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_AUTH_REQUEST Structure

_PRL_IO_AUTH_REQUEST Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_AUTH_REQUEST {
  PRL_UINT8 sessionUuid[16];
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_AUTH_RESPONSE Structure

_PRL_IO_AUTH_RESPONSE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_AUTH_RESPONSE {
  PRL_UINT32 authResult;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DESKTOP_UTILITIES_STATE Structure

_PRL_IO_DESKTOP_UTILITIES_STATE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DESKTOP_UTILITIES_STATE {
  PRL_UINT32 bDesktopShown;
  PRL_UINT32 bTaskbarShown;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DEVICE_USED Structure

_PRL_IO_DEVICE_USED Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DEVICE_USED {
  PRL_UINT32 devType;
  PRL_UINT32 devIndex;
  PRL_UINT32 devAction;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DISPLAY_PALETTE Structure

_PRL_IO_DISPLAY_PALETTE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DISPLAY_PALETTE {
  PRL_IO_PALETTE palette;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DISPLAY_SCREEN_REGION Structure

_PRL_IO_DISPLAY_SCREEN_REGION Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DISPLAY_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DISPLAY_SCREEN_SIZE Structure

_PRL_IO_DISPLAY_SCREEN_SIZE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DISPLAY_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
  PRL_UINT32 display;
  PRL_INT32 displayX;
  PRL_INT32 displayY;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_DYNRES_TOOLS_STATUS Structure

_PRL_IO_DYNRES_TOOLS_STATUS Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_DYNRES_TOOLS_STATUS {
  PRL_UINT32 status;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_ENCODING_REQUEST Structure

_PRL_IO_ENCODING_REQUEST Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_ENCODING_REQUEST {
  PRL_UINT32 encodingType;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_ENCODING_RESPONSE Structure

_PRL_IO_ENCODING_RESPONSE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_GENERIC_BUFFER Structure

_PRL_IO_GENERIC_BUFFER Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_GENERIC_BUFFER {
  PRL_UINT32 size;
  PRL_VOID_PTR data;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_GRACEFUL_SHUTDOWN Structure

_PRL_IO_GRACEFUL_SHUTDOWN Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_GRACEFUL_SHUTDOWN {
  PRL_UINT32 kind;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_GUEST_SCREENSAVER_STATE Structure

_PRL_IO_GUEST_SCREENSAVER_STATE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_GUEST_SCREENSAVER_STATE {
  PRL_UINT32 bEnabled;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_KEYBOARD_LEDS Structure

_PRL_IO_KEYBOARD_LEDS Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_KEYBOARD_LEDS {
  PRL_UINT32 ledsState;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_KEYBOARD_SCANCODE Structure

_PRL_IO_KEYBOARD_SCANCODE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_KEYBOARD_SCANCODE {
  PRL_UINT16 key;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_MEMORY_INFO Structure

_PRL_IO_MEMORY_INFO Structure
PrlIoStructs.h Other Structs Send Feedback

PRIVATE STRUCTS

Syntax
struct _PRL_IO_MEMORY_INFO {
  PRL_UINT64 ramOffset;
  PRL_UINT64 ramSize;
  PRL_UINT64 vramOffset;
  PRL_UINT64 vramSize;
  PRL_UINT32 filenameSize;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_MOUSE_CURSOR Structure

_PRL_IO_MOUSE_CURSOR Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_MOUSE_CURSOR {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 hotSpotX;
  PRL_UINT32 hotSpotY;
  PRL_UINT32 width;
  PRL_UINT32 height;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_MOUSE_EVENT Structure

_PRL_IO_MOUSE_EVENT Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_MOUSE_EVENT {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SCREEN_BUFFER_REGION Structure

_PRL_IO_SCREEN_BUFFER_REGION Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SCREEN_BUFFER_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 scaleWidth;
  PRL_UINT32 scaleHeight;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SCREEN_REGION Structure

_PRL_IO_SCREEN_REGION Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SCREEN_SIZE Structure

_PRL_IO_SCREEN_SIZE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SCREEN_SURFACE Structure

_PRL_IO_SCREEN_SURFACE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SCREEN_SURFACE {
  PRL_UINT32 windowId;
  PRL_UINT32 surfaceId;
  PRL_INT32 scrollX;
  PRL_INT32 scrollY;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SCREEN_UPDATE Structure

_PRL_IO_SCREEN_UPDATE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SCREEN_UPDATE {
  PRL_UINT32 offset;
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SET_TASKBAR_VISIBILITY Structure

_PRL_IO_SET_TASKBAR_VISIBILITY Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SET_TASKBAR_VISIBILITY {
  PRL_UINT32 visibility;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_SLIDING_MOUSE Structure

_PRL_IO_SLIDING_MOUSE Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_SLIDING_MOUSE {
  PRL_UINT32 enable;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_STATE Enumeration

_PRL_IO_STATE Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
enum _PRL_IO_STATE {
  IOS_DISABLED = 0,
  IOS_STARTED = 1,
  IOS_STOPPED = 2,
  IOS_UNKNOWN_VM_UUID = 3,
  IOS_CONNECTION_TIMEOUT = 4,
  IOS_AUTH_FAILED = 5
};
File

PrlEnums.h

Members

IOS_DISABLED
< Desktop has not been enabled
IOS_STARTED
< Successfully started.(local and remote)
IOS_STOPPED
< Is stopped.
IOS_UNKNOWN_VM_UUID
< Unknown uuid.
IOS_CONNECTION_TIMEOUT
< Connection timeout.
IOS_AUTH_FAILED
< Authentication failed.

Links
PrlEnums.h, Other Structs


PRL_IO Structs Enumerations

PRL_IO Structs Enumerations
PRL_IO Structs
Enumerations
Name | Description
PRL_IO_STATE |


PRL_IO Structs Structures

PRL_IO Structs Structures
PRL_IO Structs
Structures
Name
Description
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_RESPONSE
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_SCREENSAVER_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SLIDING_MOUSE
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.

PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.


_PRL_IO_TOOLS_MOVE_TASKBAR Structure

_PRL_IO_TOOLS_MOVE_TASKBAR Structure
PrlIoStructs.h Other Structs Send Feedback
Syntax
struct _PRL_IO_TOOLS_MOVE_TASKBAR {
  PRL_BOOL bCoherenceOn;
  PRL_BOOL bRelocateTaskBar;
  PRL_UINT32 uDockEdge;
  PRL_UINT32 uEdgeMask;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_TOOLS_SIA_DATA Structure

_PRL_IO_TOOLS_SIA_DATA Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
Syntax
struct _PRL_IO_TOOLS_SIA_DATA {
  PRL_UINT32 ver;
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 size;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_IO_TOOLS_UTILITY_COMMAND Structure

_PRL_IO_TOOLS_UTILITY_COMMAND Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
Syntax
struct _PRL_IO_TOOLS_UTILITY_COMMAND {
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 dataSize;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


PRL_IO Types Types

PRL_IO Types Types
PRL_IO Types
Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_SCREENSAVER_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_STATE_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |


_PRL_JOB_OPERATION_CODE Enumeration

_PRL_JOB_OPERATION_CODE Enumeration
PrlEnums.h Other Structs Send Feedback

Job operation codes

Syntax
enum _PRL_JOB_OPERATION_CODE {
  PJOC_UNKNOWN = 0,
  PJOC_JOB_CANCEL = 1,
  PJOC_SRV_LOOKUP_PARALLELS_SERVERS = 2,
  PJOC_SRV_LOGIN = 3,
  PJOC_SRV_LOGIN_LOCAL = 4,
  PJOC_SRV_LOGOFF = 5,
  PJOC_SRV_GET_SRV_CONFIG = 6,
  PJOC_SRV_GET_COMMON_PREFS = 7,
  PJOC_SRV_COMMON_PREFS_BEGIN_EDIT = 8,
  PJOC_SRV_COMMON_PREFS_COMMIT = 9,
  PJOC_SRV_GET_USER_PROFILE = 10,
  PJOC_SRV_GET_STATISTICS = 11,
  PJOC_SRV_USER_PROFILE_BEGIN_EDIT = 12,
  PJOC_SRV_USER_PROFILE_COMMIT = 13,
  PJOC_SRV_REGISTER_VM = 14,
  PJOC_SRV_GET_VM_LIST = 15,
  PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS = 16,
  PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS = 17,
  PJOC_SRV_SHUTDOWN = 18,
  PJOC_SRV_FS_GET_DISK_LIST = 19,
  PJOC_SRV_FS_GET_DIR_ENTRIES = 20,
  PJOC_SRV_FS_CREATE_DIR = 21,
  PJOC_SRV_FS_REMOVE_ENTRY = 22,
  PJOC_SRV_FS_CAN_CREATE_FILE = 23,
  PJOC_SRV_FS_RENAME_ENTRY = 24,
  PJOC_SRV_FS_GENERATE_ENTRY_NAME = 25,
  PJOC_SRV_UPDATE_LICENSE = 26,
  PJOC_SRV_GET_LICENSE_INFO = 27,
  PJOC_SRV_SEND_ANSWER = 28,
  PJOC_SRV_START_SEARCH_VMS = 29,
  PJOC_SRV_NET_SERVICE_START = 30,
  PJOC_SRV_NET_SERVICE_STOP = 31,
  PJOC_SRV_NET_SERVICE_RESTART = 32,
  PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS = 33,
  PJOC_SRV_GET_NET_SERVICE_STATUS = 34,
  PJOC_SRV_ADD_NET_ADAPTER = 35,
  PJOC_SRV_DELETE_NET_ADAPTER = 36,
  PJOC_SRV_UPDATE_NET_ADAPTER = 37,
  PJOC_SRV_GET_PROBLEM_REPORT = 38,
  PJOC_SRV_ATTACH_TO_LOST_TASK = 39,
  PJOC_SRV_GET_USER_INFO_LIST = 40,
  PJOC_SRV_GET_USER_INFO = 41,
  PJOC_VM_START = 42,
  PJOC_VM_STOP = 43,
  PJOC_VM_PAUSE = 44,
  PJOC_VM_RESET = 45,
  PJOC_VM_SUSPEND = 46,
  PJOC_VM_RESUME = PJOC_VM_START,
  PJOC_VM_DROP_SUSPENDED_STATE = 49,
  PJOC_VM_CLONE = 50,
  PJOC_VM_DELETE = 51,
  PJOC_VM_GET_PROBLEM_REPORT = 52,
  PJOC_VM_GET_STATE = 53,
  PJOC_VM_GENERATE_VM_DEV_FILENAME = 54,
  PJOC_VM_GET_TOOLS_STATE = 55,
  PJOC_VM_REFRESH_CONFIG = 56,
  PJOC_VM_GET_STATISTICS = 57,
  PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS = 58,
  PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS = 59,
  PJOC_VM_REG = 60,
  PJOC_VM_UNREG = 61,
  PJOC_VM_BEGIN_EDIT = 62,
  PJOC_VM_COMMIT = 63,
  PJOC_VM_CREATE_UNATTENDED_FLOPPY = 64,
  PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS = 65,
  PJOC_VM_UPDATE_SECURITY = 66,
  PJOC_VM_VALIDATE_CONFIG = 67,
  PJOC_VM_DEV_CONNECT = 68,
  PJOC_VM_DEV_DISCONNECT = 69,
  PJOC_VM_DEV_CREATE_IMAGE = 70,
  PJOC_VM_INSTALL_TOOLS = 71,
  PJOC_VM_SEND_SHUTDOWN_COMMAND = 72,
  PJOC_VM_SEND_CLIPBOARD_REQUEST = 73,
  PJOC_VM_CONNECT_TO_VM = 74,
  PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN = 75,
  PJOC_VM_MIGRATE = 76,
  PJOC_VM_SEND_DRAGDROP_COMMAND = 77,
  PJOC_VM_GUEST_RUN_PROGRAM = 78,
  PJOC_VM_GUEST_LOGOUT = 79,
  PJOC_SRV_SUBSCRIBE_PERFSTATS = 80,
  PJOC_SRV_UNSUBSCRIBE_PERFSTATS = 81,
  PJOC_SRV_GET_PERFSTATS = 82,
  PJOC_VM_SUBSCRIBE_PERFSTATS = 83,
  PJOC_VM_UNSUBSCRIBE_PERFSTATS = 84,
  PJOC_VM_GET_PERFSTATS = 85,
  PJOC_VM_GET_SUSPENDED_SCREEN = 86,
  PJOC_VM_MIGRATE_CANCEL = 87,
  PJOC_VM_RUN_COMPRESSOR = 88,
  PJOC_VM_CANCEL_COMPRESSOR = 89,
  PJOC_VM_CREATE_SNAPSHOT = 90,
  PJOC_VM_SWITCH_TO_SNAPSHOT = 91,
  PJOC_VM_DELETE_SNAPSHOT = 92,
  PJOC_VM_GET_SNAPSHOTS_TREE = 93,
  PJOC_VM_START_EX = 94,
  PJOC_VM_LOGIN_IN_GUEST = 95,
  PJOC_VM_UPDATE_SNAPSHOT_DATA = 96,
  PJOC_VM_RESTART = 97,
  PJOC_VM_INSTALL_UTILITY = 98,
  PJOC_VM_UPDATE_TOOLS_SECTION = 99,
  PJOC_SRV_GET_ALL_HOST_USERS = 100,
  PJOC_VM_RESTORE = 101,
  PJOC_VM_START_VNC_SERVER = 102,
  PJOC_VM_STOP_VNC_SERVER = 103,
  PJOC_VM_GUEST_GET_NETWORK_SETTINGS = 104,
  PJOC_SRV_GET_VIRTUAL_NETWORK_LIST = 105,
  PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB = 106
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_JOB_STATUS Enumeration

_PRL_JOB_STATUS Enumeration
PrlEnums.h Other Structs Send Feedback

Job status enumeration

Syntax
enum _PRL_JOB_STATUS {
  PJS_UNKNOWN = 0,
  PJS_RUNNING = 0xD0000001,
  PJS_FINISHED = 0xD0000002
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_KEY_EVENT Enumeration

_PRL_KEY_EVENT Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
enum _PRL_KEY_EVENT {
  PKE_PRESS = 0x0,
  PKE_RELEASE = 0x80
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration

_PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Mass storage device interface type

Syntax
enum _PRL_MASS_STORAGE_INTERFACE_TYPE {
  PMS_IDE_DEVICE = 0,
  PMS_SCSI_DEVICE = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_MESSAGE_TYPE_ENUM Enumeration

_PRL_MESSAGE_TYPE_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Message type enumeration.

Syntax
enum _PRL_MESSAGE_TYPE_ENUM {
  PMT_WARNING = 0,
  PMT_INFORMATION = 1,
  PMT_CRITICAL = 2,
  PMT_QUESTION = 3,
  PMT_ANSWER = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_MOUSE_BUTTON Enumeration

_PRL_MOUSE_BUTTON Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
enum _PRL_MOUSE_BUTTON {
  PMB_NOBUTTON = 0,
  PMB_LEFT_BUTTON = 1,
  PMB_RIGHT_BUTTON = 2,
  PMB_MIDDLE_BUTTON = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_NET_ADAPTER_EMULATED_TYPE Enumeration

_PRL_NET_ADAPTER_EMULATED_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Network adapter emulated type

Syntax
enum _PRL_NET_ADAPTER_EMULATED_TYPE {
  PNA_HOST_ONLY = 0,
  PNA_SHARED = 1,
  PNA_BRIDGED_ETHERNET = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration

_PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Virtual Network type.

Syntax
enum _PRL_NET_VIRTUAL_NETWORK_TYPE {
  PVN_BRIDGED_ETHERNET = 0,
  PVN_HOST_ONLY = 1
};
File

PrlEnums.h

Remarks

Should match values in LibrariesNetworkConfigprl_netconfigprl_netconfig.h

Links
PrlEnums.h, Other Structs


_PRL_PARAM_FIELD_DATA_TYPE Enumeration

_PRL_PARAM_FIELD_DATA_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Event parameters fields types

Syntax
enum _PRL_PARAM_FIELD_DATA_TYPE {
  PFD_UINT32 = 0,
  PFD_STRING = 1,
  PFD_INT32 = 2,
  PFD_CDATA = 3,
  PFD_BOOLEAN = 4,
  PFD_ENTITY = 5,
  PFD_ENUMERATION = 6,
  PFD_INT64 = 7,
  PFD_UINT64 = 8
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_PORT_FORWARDING_TYPE Enumeration

_PRL_PORT_FORWARDING_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding

Syntax
enum _PRL_PORT_FORWARDING_TYPE {
  PPF_TCP = 0,
  PPF_UDP = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_PROCESS_STATE_TYPE Enumeration

_PRL_PROCESS_STATE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Process state element

Syntax
enum _PRL_PROCESS_STATE_TYPE {
  PPS_PROC_SLEEP = 0,
  PPS_PROC_RUN = 1,
  PPS_PROC_STOP = 2,
  PPS_PROC_ZOMBIE = 3,
  PPS_PROC_IDLE = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_PRODUCT_ENUM Enumeration

_PRL_PRODUCT_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels lilcense products enumeration.

Syntax
enum _PRL_PRODUCT_ENUM {
  PRL_PRODUCT_ANY = 0,
  PRL_PRODUCT_DESKTOP = 1,
  PRL_PRODUCT_SERVER = 2,
  PRL_PRODUCT_WORKSTATION = 3,
  PRL_PRODUCT_STM = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_RUNNING_TASK_TYPE_ENUM Enumeration

_PRL_RUNNING_TASK_TYPE_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Running task type enumeration.

Syntax
enum _PRL_RUNNING_TASK_TYPE_ENUM {
  RTT_RUNNING_TASK_UNKNOWN = 0,
  RTT_RUNNING_TASK_CREATE_VM = 1,
  RTT_RUNNING_TASK_REGISTER_VM = 2,
  RTT_RUNNING_TASK_CLONE_VM = 3,
  RTT_RUNNING_TASK_DELETE_VM = 4,
  RTT_RUNNING_TASK_UNREG_VM = 5,
  RTT_RUNNING_TASK_CREATE_IMAGE = 6,
  RTT_RUNNING_TASK_RESTORE_VM = 7
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_SCAN_CODE Macros Macros

PRL_SCAN_CODE Macros Macros
PRL_SCAN_CODE Macros
Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | Scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_Z |


_PRL_SECURITY_LEVEL Enumeration

_PRL_SECURITY_LEVEL Enumeration
PrlEnums.h Other Structs Send Feedback

Security level enumeration.

Syntax
enum _PRL_SECURITY_LEVEL {
  PSL_LOW_SECURITY = 0,
  PSL_NORMAL_SECURITY = 1,
  PSL_HIGH_SECURITY = 2
};
File

PrlEnums.h

Type Parameters

PSL_LOW_SECURITY
Plain TCP/IP (no encryption).
PSL_NORMAL_SECURITY
Most important data is sent and received using SSL over TCP/IP (user credentials during login, guest OS clipboard, etc.) Other data is sent and receive using plain TCP/IP with no encryption.
PSL_HIGH_SECURITY
All of the data is sent and received using SSL.

Remarks

Defines levels of security that can be used in client/server communications.

Links
PrlEnums.h, Other Structs


_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration

_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

Serial port operation mode when on socket

Syntax
enum _PRL_SERIAL_PORT_SOCKET_OPERATION_MODE {
  PSP_SERIAL_SOCKET_SERVER = 0,
  PSP_SERIAL_SOCKET_CLIENT = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_SERVICE_STATUS_ENUM Enumeration

_PRL_SERVICE_STATUS_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels service statuses

Syntax
enum _PRL_SERVICE_STATUS_ENUM {
  PSS_STARTED = 0,
  PSS_STOPPED = 1,
  PSS_NOT_INSTALLED = 2,
  PSS_UNKNOWN
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_TIS_INT_VERSION Structure

_PRL_TIS_INT_VERSION Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
Syntax
struct _PRL_TIS_INT_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_TIS_RECORD_ACTION Enumeration

_PRL_TIS_RECORD_ACTION Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Information Service record actions

Syntax
enum _PRL_TIS_RECORD_ACTION {
  PTIS_RECORD_CHANGED = 1,
  PTIS_RECORD_REMOVED = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_TIS_RECORD_INFO Structure

_PRL_TIS_RECORD_INFO Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
Syntax
struct _PRL_TIS_RECORD_INFO {
  PRL_TIS_VERSION version;
  PRL_TIS_INT_VERSION intVersion;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_TIS_RECORD_STATE Enumeration

_PRL_TIS_RECORD_STATE Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Information Service record states

Syntax
enum _PRL_TIS_RECORD_STATE {
  PTIS_RECORD_EMPTY = 0,
  PTIS_RECORD_ACTIVE = 1,
  PTIS_RECORD_CANCELED = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_TIS Types Types

PRL_TIS Types Types
PRL_TIS Types
Types
Name | Description
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_ACTION_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TIS_VERSION_PTR |


_PRL_TIS_VERSION Structure

_PRL_TIS_VERSION Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
Syntax
struct _PRL_TIS_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
  PRL_UINT32 bld;
  PRL_UINT32 rev;
};
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


_PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration

_PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration
PrlEnums.h Other Structs Send Feedback

Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;

Syntax
enum _PRL_TOOLS_SIA_OPEN_IN_TYPES {
  PSIA_OPEN_DEFAULT = 0,
  PSIA_OPEN_IN_GUEST = 1,
  PSIA_OPEN_IN_HOST = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_TOOLS Types Types

PRL_TOOLS Types Types
PRL_TOOLS Types
Types
Name | Description
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |


_PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration

_PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Utility command flags

Syntax
enum _PRL_TOOLS_UTILITY_COMMAND_FLAG {
  PTU_FLG_ZERO = (1 << 0)
};
File

PrlEnums.h

Members

PTU_FLG_ZERO
@brief Flag is useless now, but placed here to show how and where it must be

Links
PrlEnums.h, Other Structs


_PRL_TOOLS_UTILITY_COMMAND_ID Enumeration

_PRL_TOOLS_UTILITY_COMMAND_ID Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Utility commands identifiers

Syntax
enum _PRL_TOOLS_UTILITY_COMMAND_ID {
  PTU_CMD_INVALID = 0,
  PTU_CMD_PTU_ALIVE = 1
};
File

PrlEnums.h

Members

PTU_CMD_INVALID
brief Identifier of invalid command
PTU_CMD_PTU_ALIVE
@brief Can be sent to indicate that Parallels Tools Utility subsystem is alive and ready to work

Links
PrlEnums.h, Other Structs


PRL_UINT Types Types

PRL_UINT Types Types
PRL_UINT Types
Types
Name | Description
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |


_PRL_UNDO_DISKS_MODE Enumeration

_PRL_UNDO_DISKS_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied

Syntax
enum _PRL_UNDO_DISKS_MODE {
  PUD_DISABLE_UNDO_DISKS = 0,
  PUD_REVERSE_CHANGES = 1,
  PUD_COMMIT_CHANGES = 2,
  PUD_PROMPT_BEHAVIOUR = 3
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration

_PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration
PrlEnums.h Other Structs Send Feedback

USB autoconnect devices options

Syntax
enum _PRL_USB_DEVICE_AUTO_CONNECT_OPTION {
  PUD_CONNECT_TO_PRIMARY_OS = 0,
  PUD_CONNECT_TO_GUEST_OS = 1,
  PUD_ASK_USER_WHAT_TODO = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_USB_DEVICE_CONNECT_REASON Enumeration

_PRL_USB_DEVICE_CONNECT_REASON Enumeration
PrlEnums.h Other Structs Send Feedback

USB device connect/disconnect reason

Syntax
enum _PRL_USB_DEVICE_CONNECT_REASON {
  PUD_CONNECTED_MANUALLY = 0,
  PUD_CONNECTED_AUTOMATICALLY = 1
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VERSION_ENUM Enumeration

_PRL_VERSION_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels license versions enumeration.

Syntax
enum _PRL_VERSION_ENUM {
  PRL_VERSION_ANY = 0,
  PRL_VERSION_3X = 1,
  PRL_VERSION_4X = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_ACCELERATION_LEVEL Enumeration

_PRL_VM_ACCELERATION_LEVEL Enumeration
PrlEnums.h Other Structs Send Feedback

Acceleration level

Syntax
enum _PRL_VM_ACCELERATION_LEVEL {
  PVA_ACCELERATION_DISABLED = 0,
  PVA_ACCELERATION_NORMAL = 1,
  PVA_ACCELERATION_HIGH = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_ACCESS_FOR_OTHERS Enumeration

_PRL_VM_ACCESS_FOR_OTHERS Enumeration
PrlEnums.h Other Structs Send Feedback

Specifies virtual machine access rights.

Syntax
enum _PRL_VM_ACCESS_FOR_OTHERS {
  PAO_VM_NOT_SHARED = 0,
  PAO_VM_SHARED_ON_VIEW,
  PAO_VM_SHARED_ON_VIEW_AND_RUN,
  PAO_VM_SHARED_ON_FULL_ACCESS
};
File

PrlEnums.h

Type Parameters

PAO_VM_NOT_SHARED
Only the owner of the virtual machine has access to it. The machine will be hidden from all other users.
PAO_VM_SHARED_ON_VIEW
Other users can see the machine but they cannot run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_VIEW_AND_RUN
Other users can see the machine and they can also run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_FULL_ACCESS
Other users have full access to the virtual machine.

Links
PrlEnums.h, Other Structs


_PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration

_PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration
PrlEnums.h Other Structs Send Feedback

Action on VM when VM window gets closed

Syntax
enum _PRL_VM_ACTION_ON_WINDOW_CLOSE {
  PWC_VM_STOP = 0,
  PWC_VM_SUSPEND = 1,
  PWC_VM_ASK_USER = 2,
  PWC_VM_PAUSE = 3,
  PWC_VM_SHUTDOWN = 4,
  PWC_VM_DO_NOTHING = 5
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_AUTOSTART_OPTION Enumeration

_PRL_VM_AUTOSTART_OPTION Enumeration
PrlEnums.h Other Structs Send Feedback

VM autostart options

Syntax
enum _PRL_VM_AUTOSTART_OPTION {
  PAO_VM_START_MANUAL = 0,
  PAO_VM_START_ON_LOAD = 1,
  PAO_VM_START_ON_RELOAD = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_AUTOSTOP_OPTION Enumeration

_PRL_VM_AUTOSTOP_OPTION Enumeration
PrlEnums.h Other Structs Send Feedback

VM autostop options

Syntax
enum _PRL_VM_AUTOSTOP_OPTION {
  PAO_VM_STOP = 0,
  PAO_VM_SUSPEND = 1,
  PAO_VM_SHUTDOWN = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_BOOT_ORDER Enumeration

_PRL_VM_BOOT_ORDER Enumeration
PrlEnums.h Other Structs Send Feedback

VM boot order

Syntax
enum _PRL_VM_BOOT_ORDER {
  PBO_HDD_CD_FLOPPY = 0,
  PBO_FLOPPY_HDD_CD = 1,
  PBO_CD_HDD_FLOPPY = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_CONFIG_SECTIONS Enumeration

_PRL_VM_CONFIG_SECTIONS Enumeration
PrlEnums.h Other Structs Send Feedback

VM configuration sections

Syntax
enum _PRL_VM_CONFIG_SECTIONS {
  PVC_ALL = 1,
  PVC_GENERAL_PARAMETERS,
  PVC_BOOT_OPTION,
  PVC_REMOTE_DISPLAY,
  PVC_SHARED_FOLDERS,
  PVC_CPU,
  PVC_MAIN_MEMORY,
  PVC_VIDEO_MEMORY,
  PVC_FLOPPY_DISK,
  PVC_CD_DVD_ROM,
  PVC_HARD_DISK,
  PVC_NETWORK_ADAPTER,
  PVC_SOUND,
  PVC_SERIAL_PORT,
  PVC_PARALLEL_PORT,
  PVC_IDE_DEVICES,
  PVC_SCSI_DEVICES,
  PVC_GENERIC_PCI,
  PVC_LAST_SECTION = PVC_GENERIC_PCI
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_DEV_EMULATION_TYPE Enumeration

_PRL_VM_DEV_EMULATION_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

VM device emulation type

Syntax
enum _PRL_VM_DEV_EMULATION_TYPE {
  PDT_ANY_TYPE = 0xffff,
  PDT_USE_REAL_DEVICE = 0,
  PDT_USE_IMAGE_FILE = 1,
  PDT_USE_OUTPUT_FILE = 2,
  PDT_USE_OTHER = 3,
  PDT_USE_REAL_FLOPPY = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_HDD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_CDDVD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_SERIAL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_SERIAL_PORT_SOCKET_MODE = PDT_USE_OTHER,
  PDT_USE_REAL_PARALLEL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_PARALLEL_PORT_PRINTER_MODE = PDT_USE_OTHER,
  PDT_USE_HOST_ONLY_NETWORK = PDT_USE_REAL_DEVICE,
  PDT_USE_SHARED_NETWORK = PDT_USE_IMAGE_FILE,
  PDT_USE_BRIDGE_ETHERNET = PDT_USE_OUTPUT_FILE,
  PDT_USE_AC97_SOUND = PDT_USE_REAL_DEVICE,
  PDT_USE_CREATIVE_SB16_SOUND = PDT_USE_IMAGE_FILE,
  PDT_USE_REAL_USB_CONTROLLER = PDT_USE_REAL_DEVICE,
  PDT_USE_BOOTCAMP = PDT_USE_OTHER
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration

_PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration
PrlEnums.h Other Structs Send Feedback

App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app

Syntax
enum _PRL_VM_EXEC_APP_FILE_DESCRIPTOR {
  PFD_STDOUT = (1 << 0),
  PFD_STDERR = (1 << 1),
  PFD_ALL = (PFD_STDOUT | PFD_STDERR)
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration

_PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration
PrlEnums.h Other Structs Send Feedback

Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result

Syntax
enum _PRL_VM_EXEC_RUN_PROGRAM_MODES {
  PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY = (1 << 2)
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_MIGRATION_SECURITY_LEVEL Enumeration

_PRL_VM_MIGRATION_SECURITY_LEVEL Enumeration
PrlEnums.h Other Structs Send Feedback

VM migration security level - specifies security level of VM migration connection

Syntax
enum _PRL_VM_MIGRATION_SECURITY_LEVEL {
  PVMSL_LOW_SECURITY = 0,
  PVMSL_NORMAL_SECURITY = 1<<3,
  PVMSL_HIGH_SECURITY = 1<<4
};
File

PrlEnums.h

Type Parameters

PVMSL_LOW_SECURITY
flag matches to PSL_LOW_SECURITY connection type.
PVMSL_NORMAL_SECURITY
flag matches to PSL_NORMAL_SECURITY connection type.
PVMSL_HIGH_SECURITY
flag matches to PSL_HIGH_SECURITY connection type.

Links
PrlEnums.h, Other Structs


_PRL_VM_MIGRATION_TYPE Enumeration

_PRL_VM_MIGRATION_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

VM migration type - specifies method of VM migration

Syntax
enum _PRL_VM_MIGRATION_TYPE {
  PVMT_COLD_MIGRATION = 1<<0,
  PVMT_WARM_MIGRATION = 1<<1,
  PVMT_HOT_MIGRATION = 1<<2
};
File

PrlEnums.h

Type Parameters

PVM_COLD_MIGRATION
VM migration with interruption of VM services (VM will be stopped on migration time).
PVM_WARM_MIGRATION
VM services will have quite long downtime during migration but won't be interrupted.
PVM_HOT_MIGRATION
VM services will have short downtime during migration without any interruption.

Links
PrlEnums.h, Other Structs


_PRL_VM_PRIORITY Enumeration

_PRL_VM_PRIORITY Enumeration
PrlEnums.h Other Structs Send Feedback

Background/foreground VM processes priority

Syntax
enum _PRL_VM_PRIORITY {
  PVR_PRIORITY_LOW = 0,
  PVR_PRIORITY_NORMAL = 1,
  PVR_PRIORITY_HIGH = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_REMOTE_DISPLAY_MODE Enumeration

_PRL_VM_REMOTE_DISPLAY_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels remote desktop modes

Syntax
enum _PRL_VM_REMOTE_DISPLAY_MODE {
  PRD_DISABLED = 0,
  PRD_AUTO,
  PRD_MANUAL
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_START_LOGIN_MODE Enumeration

_PRL_VM_START_LOGIN_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM start login mode

Syntax
enum _PRL_VM_START_LOGIN_MODE {
  PLM_START_ACOUNT = 0,
  PLM_ROOT_ACOUNT = 1,
  PLM_USER_ACOUNT = 2
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


_PRL_VM_START_MODE Enumeration

_PRL_VM_START_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode

Syntax
enum _PRL_VM_START_MODE {
  PSM_VM_START = (1 << 0),
  PSM_VM_SAFE_START = (1 << 1),
  PSM_VM_START_LAST_ITEM = PSM_VM_SAFE_START
};
File

PrlEnums.h

Members

PSM_VM_START_LAST_ITEM
PSM_VM_START_LAST_ITEM has to be equal the last mode

Links
PrlEnums.h, Other Structs


PRL_VM Structs Enumerations

PRL_VM Structs Enumerations
PRL_VM Structs
Enumerations
Name | Description
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_WINDOW_MODE | VM window mode


_PRL_VM_TOOLS_STATE Enumeration

_PRL_VM_TOOLS_STATE Enumeration
PrlEnums.h Other Structs Send Feedback

Virtual machine tools states enumeration

Syntax
enum _PRL_VM_TOOLS_STATE {
  PTS_UNKNOWN = 0x0,
  PTS_POSSIBLY_INSTALLED = PTS_UNKNOWN,
  PTS_NOT_INSTALLED = 0x1,
  PTS_INSTALLED = 0x2,
  PTS_OUTDATED = 0x3
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_VM Types Types

PRL_VM Types Types
PRL_VM Types
Types
Name | Description
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR |
PRL_VM_MIGRATION_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_WINDOW_MODE_PTR |


_PRL_VM_WINDOW_MODE Enumeration

_PRL_VM_WINDOW_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM window mode

Syntax
enum _PRL_VM_WINDOW_MODE {
  PWM_DEFAULT_WINDOW_MODE = 0,
  PWM_WINDOWED_WINDOW_MODE = 1,
  PWM_FULL_SCREEN_WINDOW_MODE = 2,
  PWM_COHERENCE_WINDOW_MODE = 3,
  PWM_MODALITY_WINDOW_MODE = 4
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_VOID Types Types

PRL_VOID Types Types
PRL_VOID Types
Types
Name | Description
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |


_PRL_WINDOW_EDGE_MASK Enumeration

_PRL_WINDOW_EDGE_MASK Enumeration
PrlEnums.h Other Structs Send Feedback

Edges where taskbar can be placed (in coherence mode).

Syntax
enum _PRL_WINDOW_EDGE_MASK {
  WINDOW_LEFT_EDGE_MASK = (0x1L << 0),
  WINDOW_TOP_EDGE_MASK = (0x1L << 1),
  WINDOW_RIGHT_EDGE_MASK = (0x1L << 2),
  WINDOW_BOTTOM_EDGE_MASK = (0x1L << 3),
  WINDOW_ALL_EDGE_MASK = WINDOW_LEFT_EDGE_MASK|WINDOW_TOP_EDGE_MASK|WINDOW_RIGHT_EDGE_MASK|WINDOW_BOTTOM_EDGE_MASK
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


See Also

See Also
PrlAcl_GetAccessForOthers Function
See Also

PrlAcl_SetAccessForOthers


See Also

See Also
PrlAcl_GetOwnerName Function
See Also

PrlAcl_IsCurrentSessionOwner


See Also

See Also
PrlAcl_SetAccessForOthers Function
See Also

PrlAcl_GetAccessForOthers


See Also

See Also
PrlApi_Deinit Function
See Also

PrlApi_Init


PrlApi.h Functions

PrlApi.h Functions
PrlApi.h Legend
Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.
PrlApi_AddRemoteDevCommandBuffer | Adds buffer to the remote command.
PrlApi_AddRemoteDevCommandParam | Adds unsigned int parameter to the command.
PrlApi_CreateHandlesList | Creates SDK object represents handles list
PrlApi_CreateRemoteCommand |
PrlApi_CreateRemoteDevCommand | Creates command to the remote device.
PrlApi_CreateStringsList | Creates a handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendRemoteCommand |
PrlApi_SendRemoteDeviceCommand | Sends remote device command to the Virtual Machine.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetScreenSurface | Sets CoreGraphics surface for fast server-side display updates.
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the secondary display of the guest OS to specified values.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_CreateDispNet | Creates a new virtual network adapter object and adds it to the network adapters list.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetDispNet | Obtains information about a virtual network adapter from the Parallels Service configuration.
PrlDispCfg_GetDispNetCount | Determines the total number of the virtual network adapters in the Parallels Service configuration.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.
PrlDispNet_GetDhcpScopeEndIp | Returns the end IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeMask | Returns the subnet mask of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeStartIp | Returns the start IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetIndex | Returns the index identifying the specified adapter on the Parallels Service.
PrlDispNet_GetName | Returns the name of the specified virtual network adapter.
PrlDispNet_GetNetworkType | Returns the virtual network adapter network type (host-only or shared).
PrlDispNet_GetSysName | Returns the name of the physical network adapter to which the specified virtual network adapter is bound.
PrlDispNet_GetUuid | Returns the specified virtual network adapter UUID.
PrlDispNet_IsDhcpEnabled | Determines if DHCP scope is enabled for the specified virtual network adapter.
PrlDispNet_IsEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlDispNet_Remove | Removes the specified virtual network adapter object from memory.
PrlDispNet_SetDhcpEnabled | Allows to enable or disable the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeEndIp | Sets the end IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeMask | Sets the subnet mask of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeStartIp | Sets the start IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetEnabled | Allows to enable or disable a specified virtual network adapter.
PrlDispNet_SetIndex | Sets the specified virtual network adapter index (from 0 to 5).
PrlDispNet_SetName | Sets the specified virtual network adapter name.
PrlDispNet_SetNetworkType | Allows to set a network type for the specified virtual network adapter.
PrlDispNet_SetSysName | Sets the specified virtual network adapter system name.
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetType | Returns the type of the specified handle.
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.
PrlSrv_AddNetAdapter | Adds a new virtual network adapter to the specified Parallels Service.
PrlSrv_AttachToLostTask | The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CheckParallelsServerAlive | Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CommonPrefsBeginEdit | The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit | The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_Create | Creates a new handle of type PHT_SERVER.
PrlSrv_CreateVm | Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_DeleteNetAdapter | Removes a virtual network adapter from the Parallels Service configuration.
PrlSrv_FsCanCreateFile | Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir | Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName | Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries | Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList | Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry | Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry | Renames a file system entry on the host.
PrlSrv_GetCommonPrefs | Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetLicenseInfo | Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus | Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetProblemReport | Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions | The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetServerInfo | Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig | Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetUserInfo | Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList | Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile | Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList | Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmList | Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_IsConnected | Determines if the connection to the specified Parallels Service is active.
PrlSrv_Login | Performs a remote login operation using the specified parameters.
PrlSrv_LoginLocal | Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_Logoff | Logs off the Parallels Service.
PrlSrv_LookupParallelsServers | Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart | Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults | Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart | Starts the Parallels network service.
PrlSrv_NetServiceStop | Stops the Parallels network service.
PrlSrv_RegEventHandler | Registers an event handler.
PrlSrv_RegisterVm | Registers an existing virtual machine with Parallels Service.
PrlSrv_SendAnswer | Sends an answer to the Parallels Service in response to a question.
PrlSrv_Shutdown | Shuts down the Parallels Service.
PrlSrv_StartSearchVms | Searches for unregistered virtual machines at the specified location(s).
PrlSrv_SubscribeToHostStatistics | Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_UnregEventHandler | Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics | Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats | Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateLicense | Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateNetAdapter | Updates an existing virtual network adapter in the specified Parallels Service.
PrlSrv_UserProfileBeginEdit | Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit | Saves (commits) user profile changes to the Parallels Service.
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of generic PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the server hostname.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetNetAdapter | Obtains an object of type PHT_HW_NET_ADAPTER containing information about a network adapter.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a parallel port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of parallel ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.
PrlSrvCfgDev_GetId | Returns the system device ID.
PrlSrvCfgDev_GetName | Returns the system device name.
PrlSrvCfgDev_GetType | Returns the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to the virtual machine.
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns operating system uptime in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompressor | Cancels the running Compressor operation that was started with PrlVm_RunCompressor.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_RunCompressor | Initiates the Compressor process.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.
PrlVmCfg_AddDefaultDevice | The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_CreateBootDev | Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes | Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare | Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev | Creates a new virtual device handle of the specified type.
PrlVmCfg_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetAppInDockMode | Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAutoStart | Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay | Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop | Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority | Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev | Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount | Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetConfigValidity | The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetCpuAccelLevel | Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount | Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuMode | Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits | Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty | Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize | The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize | The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDescription | Returns the specified virtual machine description.
PrlVmCfg_GetDevByType | Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount | Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType | Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDevsList | Returns a pointer to a buffer containing handles to the virtual devices installed in a virtual machine.
PrlVmCfg_GetDnsServers | Obtains the list of globally defined DNS servers that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetDockIconType | Returns the virtual machine dock icon type.
PrlVmCfg_GetFloppyDisk | Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount | Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority | Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetGenericPciDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount | Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount | Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk | Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount | Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHomePath | Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostname | Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon | Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetLastModifiedDate | Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName | Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetName | Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter | Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount | Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetOpticalDisk | Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount | Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOsType | Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion | Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort | Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual parallel port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount | Determines the number of virtual parallel ports in the specified virtual machine.
PrlVmCfg_GetRamSize | Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetScrRes | Returns the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount | Returns the virtual machine screen resolutions count.
PrlVmCfg_GetSearchDomains | Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort | Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount | Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost | Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid | Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare | Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount | Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSoundDev | Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount | Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode | Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin | Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags | Returns the virtual machine system flags.
PrlVmCfg_GetUndoDisksMode | Determines the current undo disks mode for the specified virtual machine.
PrlVmCfg_GetUsbDevice | Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount | Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid | Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize | Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVNCHostName | Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode | Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword | Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort | Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode | Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsCloseAppOnShutdown | Returns Virtual Machine close app on shutdown sign.
PrlVmCfg_IsCpuVtxEnabled | Returns Virtual Machine CPU VTx support enabling sign.
PrlVmCfg_IsDefaultDeviceNeeded | Determines if a virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC | Gets the APIC using for virtual machine in runtime.
PrlVmCfg_IsDiskCacheWriteBack | Determines if disk cache write-back is enabled for the specified virtual machine.
PrlVmCfg_IsExcludeDock | Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsGuestSharingAutoMount | Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled | Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight | Determines if VM virtual disks will be added to Spotlight search subsystem.
PrlVmCfg_IsHostSharingEnabled | Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsMapSharedFoldersOnLetters | Determines whether host disks shared into guest Windows OS will be maped on drive letters.
PrlVmCfg_IsMultiDisplay | Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsOsResInFullScrMode | Determines if a virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsRelocateTaskBar | Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled | Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks | Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsSharedProfileEnabled | Returns sign whether shared profile is enabled.
PrlVmCfg_IsShareUserHomeDir | Determines whether host user home dir will be present at guest OS as share.
PrlVmCfg_IsShowTaskBar | Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsSmartGuardEnabled | Returns sign whether smart guard is enabled.
PrlVmCfg_IsTemplate | Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsUseDesktop | Returns sign whether use desktop in shared profile is enabled.
PrlVmCfg_IsUseDocuments | Returns sign whether use documents in shared profile is enabled.
PrlVmCfg_IsUseMusic | Returns sign whether use music in shared profile is enabled.
PrlVmCfg_IsUsePictures | Returns sign whether use pictures in shared profile is enabled.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled | Returns sign whether user defined shared folders enabled.
PrlVmCfg_SetAppInDockMode | Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAutoStart | Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay | Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop | Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority | Sets virtual machine background processes priority.
PrlVmCfg_SetCloseAppOnShutdown | Sets Virtual Machine close app on shutdown sign.
PrlVmCfg_SetCpuAccelLevel | Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount | Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuMode | Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits | Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty | Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig | The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription | Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign | Sets the APIC using for virtual machine in runtime.
PrlVmCfg_SetDiskCacheWriteBack | Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers | Allows to manually set the global DNS server list that will assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetDockIconType | Sets the virtual machine dock icon type.
PrlVmCfg_SetExcludeDock | Sets the exclude dock option.
PrlVmCfg_SetForegroundPriority | Sets the virtual machine foreground processes priority.
PrlVmCfg_SetGuestSharingAutoMount | Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled | Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight | Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHostname | Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled | Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon | Sets the virtual machine icon.
PrlVmCfg_SetMapSharedFoldersOnLetters | Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMultiDisplay | Sets the virtual machine multi-display option.
PrlVmCfg_SetName | Sets the specified virtual machine name.
PrlVmCfg_SetOsResInFullScrMode | Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsVersion | Sets the virtual machine guest OS version.
PrlVmCfg_SetRamSize | Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRelocateTaskBar | Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetScrResEnabled | Sets the additional screen resolution support option in the specified virtual machine
PrlVmCfg_SetSearchDomains | Allows to manually set the global search domain list that will be assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetShareAllHostDisks | Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetSharedProfileEnabled | Lets to set shared profile enabling sign.
PrlVmCfg_SetShareUserHomeDir | Enables sharing of host user home dir for the specified virtual machine.
PrlVmCfg_SetShowTaskBar | Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetSmartGuardEnabled | Lets to set smart guard enabling sign.
PrlVmCfg_SetStartLoginMode | Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds | Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetSystemFlags | Sets Virtual Machine system flags.
PrlVmCfg_SetTemplateSign | Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetUndoDisksMode | Sets the undo disks mode for the virtual machine (see PRL_UNDO_DISKS_MODE for available options).
PrlVmCfg_SetUseDesktop | Lets to set use desktop in shared profile enabling sign.
PrlVmCfg_SetUseDocuments | Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseMusic | Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures | Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled | Lets to set user defined shared folders enabling sign.
PrlVmCfg_SetUuid | Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVideoRamSize | Sets the virtual machine video memory size.
PrlVmCfg_SetVNCHostName | Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode | Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword | Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort | Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode | Sets the virtual machine window mode.
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSysName | Sets virtual device system name.
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine.
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.
PrlVmGuest_GetNetworkSettings | Obtains network settings of an operating system running on a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.


Legend

Legend
PrlApi.h
Legend
Method


PrlApi.h Macros

PrlApi.h Macros
PrlApi.h
Macros
Name | Description
FROM_PARALLELS_API_VER |
PARALLELS_API_VER | Current Parallels API version.
PARALLELS_API_VER_1 |
PARALLELS_API_VER_2 |
TO_PARALLELS_API_VER |


Example

Example
PrlApi_Init Function

The following example illustrates how to perform the necessary API library initialization.

The first step is to load the dynamic link library using the SdkWrap_Load function from the supplied wrapper library (SdkWrap is a helper library that contains just two functions for loading and unloading the API dynamic link library; the library is not documented in this guide).

The second step is to initialize the Parallels API using the PrlApi_Init function.

Once the above steps are completed, you are ready to make other API calls, such as PrlSrv_Login and others.

On program exit, you must cal the PrlApi_Deinit function to deinitialize the API, and the SdkWrap_Unload function to unload the dynamic link libraries.

int main(int argc, char* argv[])
{
   // Pick the correct dynamic library depending on the platform.
   #ifdef _WIN_
      #define SDK_LIB_NAME "prl_sdk.dll"
   #elif defined(_LIN_)
      #define SDK_LIB_NAME "libprl_sdk.so"
   #elif defined(_MAC_)
      #define SDK_LIB_NAME "libprl_sdk.dylib"
   #endif

   // Load the dynamic library.
   // If the library cannot be found, try searching for it.
   if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
      PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
   {
      fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
      return -1;
   }

   // Initialize the API.
   PRL_RESULT ret;
   ret = PrlApi_Init(PARALLELS_API_VER);
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Init returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // your program code goes here...

   // Deinitialize the API.
   ret = PrlApi_Deinit();
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Deinit returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // Unload dynamic link libraries.
   SdkWrap_Unload();
   return 0;
}


See Also

See Also
PrlApi_Init Function
See Also

PrlApi_Deinit


See Also

See Also
PrlApi_InitEx Function
See Also

PrlApi_Deinit PrlApi_Init


See Also

See Also
PrlBootDev_GetIndex Function
See Also

PrlBootDev_SetIndex


See Also

See Also
PrlBootDev_GetSequenceIndex Function
See Also

PrlBootDev_SetSequenceIndex


See Also

See Also
PrlBootDev_GetType Function
See Also

PrlBootDev_SetType


See Also

See Also
PrlBootDev_IsInUse Function
See Also

PrlBootDev_SetInUse


See Also

See Also
PrlBootDev_SetIndex Function
See Also

PrlBootDev_GetIndex


See Also

See Also
PrlBootDev_SetInUse Function
See Also

PrlBootDev_IsInUse

PrlBootDev_Remove


Example

Example
PrlBootDev_SetSequenceIndex Function
PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);
ret = PrlJob_Wait(hJobBeginEdit, 10000);
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// Modify boot options.
// Set boot device list as follows:
// 0. CD/DVD drive.
// 1. Hard disk.
// 2. Network adapter.
// 3. Floppy disk drive.
//
PRL_UINT32 nDevCount; // Device count.
PRL_HANDLE hDevice;   // A handle to the device.
PRL_DEVICE_TYPE devType; // Device type.

// Get the total number of devices.
ret = PrlVm_GetBootDevCount(hVm, &nDevCount);

// Iterate through the device list.
// Get a handle for each available device.
// Set an index for a device in the boot list.
for (int i = 0; i < nDevCount; ++i)
{
    ret = PrlVm_GetBootDev(hVm, i, &hDevice);
    ret = PrlBootDev_GetType(hDevice, &devType);

    if (devType == PDE_OPTICAL_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 0);
    }
    if (devType == PDE_HARD_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 1);
    }
    else if (devType == PDE_GENERIC_NETWORK_ADAPTER)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 2);
    }
    else if (devType == PDE_FLOPPY_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 3);
    }
    else
    {
        PrlBootDev_Remove(hDevice);
    }
}

// Commit the changes.
hJobCommit = PrlVm_Commit(hVm);

// Check the results of the commit operation.
ret = PrlJob_Wait(hJobCommit, 10000);
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


See Also

See Also
PrlBootDev_SetSequenceIndex Function
See Also

PrlBootDev_GetSequenceIndex


See Also

See Also
PrlBootDev_SetType Function
See Also

PrlBootDev_GetType


PrlBuffer Functions

PrlBuffer Functions
PrlBuffer Legend
Functions
Name | Description
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.


Legend

Legend
PrlBuffer
Legend
Method


See Also

See Also
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_AsyncCaptureScreenRegionToFile Function
See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile


See Also

See Also
PrlDevDisplay_SyncCaptureScreenRegionToFile Function
See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile


See Also

See Also
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer


See Also

See Also
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function
See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile


See Also

See Also
PrlDisk_CreateDisk Function
See Also

PrlDisk_CreateDisk_Local


See Also

See Also
PrlDisk_CreateDisk_Local Function
See Also

PrlDisk_CreateDisk


PrlDisk.h Functions

PrlDisk.h Functions
PrlDisk.h Legend
Functions
Name | Description
PrlDisk_Coagulate | Merges all snapshots.
PrlDisk_Compact | Compacts a virtual disk.
PrlDisk_ConvertToCurrent | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_ConvertToCurrent_Local | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Start creation procedure of the new state
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_DeleteState | Start delete state procedure.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | This method is used to free the disk reference with closing.
PrlDisk_GetDiskInfo | Get disk information.
PrlDisk_GetSnapshotsCount | Get snapshots count.
PrlDisk_GetSnapshotsTree | Get snapshots tree.
PrlDisk_GetUserParameter | Get user parameter for disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsCompactable | Check is image compactable.
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Method let to open disk and return handle This function can be used locally, without a Parallels Service connection.
PrlDisk_Read | Write data to disk.
PrlDisk_SetCachingPolicy | Set caching policy for disk.
PrlDisk_SetSharedDirectory | Set shared directory (all files created somewhere in this directory will have 666 permissions).
PrlDisk_SetSharedDirectory_Local | Set shared directory (all files created somewhere in this directory will have 666 permissions) This function can be used locally, without a Parallels Service connection.
PrlDisk_SetUserParameter | Set user parameter for disk.
PrlDisk_SwitchToState | Start switching to state procedure.
PrlDisk_WaitForCompletion | Wait for completion of the work.
PrlDisk_Write | Write data to disk.


Legend

Legend
PrlDisk.h
Legend
Structure
Method


PrlDisk.h Macros

PrlDisk.h Macros
PrlDisk.h
Macros
Name
Description
PRL_BSD_PARTITION
Free BSD partition.
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_DISK_CACHE_DEFAULT
Disk cache default.
PRL_DISK_CACHE_DISABLED
Uncached access to disk image.
PRL_DISK_CACHE_ENABLED
Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ
Cached write/uncached read.
PRL_DISK_DEFAULT_FLAG
Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN
Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT
Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK
Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING
Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED
Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL
Normal access mode (default os)
PRL_DISK_INVALID
Last (invalid).
PRL_DISK_NOTHING
Nothing.
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MIN
States progress definition.
PRL_DISK_READ
Read
PRL_DISK_READ_LOCK
ReadLock
PRL_DISK_WRITE
Write
PRL_DISK_WRITE_THROUGH
Write through, disable caching
PRL_DISK_XML_CHANGE
This parameter is used when user need to change XML data but not access to the drive itself.
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_COMPRESSED_V2
Compressed disk (version 2)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_INVALID_PARTITION
Invalid partition
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_PARTITION
Mac OS
PRL_MSDOS_EXTENDED_PARTITION

  • Disk partition types

Extended partitions

PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions


PrlDisk.h Structures

PrlDisk.h Structures
PrlDisk.h Legend
Structures
Name | Description
__PRL_DISK_PARAMETERS | Parallels disk parameters.
__PRL_IMAGE_PARAMETERS | Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT | Parallels snapshot tree element
PRL_DISK_PARAMETERS | Parallels disk parameters.
PRL_IMAGE_PARAMETERS | Parallels storage parameters
PRL_SNAPSHOT_ELEMENT | Parallels snapshot tree element


PrlDisk.h Types

PrlDisk.h Types
PrlDisk.h
Types
Name | Description
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |


See Also

See Also
PrlDispCfg_CanChangeDefaultSettings Function
See Also

PrlDispCfg_SetCanChangeDefaultSettings


See Also

See Also
PrlDispCfg_GetMaxReservMemLimit Function
See Also

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_GetMaxVmMem Function
See Also

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetMinReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_GetMinSecurityLevel Function
See Also

PrlDispCfg_SetMinSecurityLevel

PrlSrv_Login

PrlSrv_LoginLocal


See Also

See Also
PrlDispCfg_GetMinVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetRecommendMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_GetReservedMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_IsAdjustMemAuto Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetAdjustMemAuto Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto


See Also

See Also
PrlDispCfg_SetCanChangeDefaultSettings Function
See Also

PrlDispCfg_CanChangeDefaultSettings


See Also

See Also
PrlDispCfg_SetMaxReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_SetMinReservMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispCfg_SetMinSecurityLevel Function
See Also

PrlDispCfg_GetMinSecurityLevel


See Also

See Also
PrlDispCfg_SetMinVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem


See Also

See Also
PrlDispCfg_SetRecommendMaxVmMem Function
See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem


See Also

See Also
PrlDispCfg_SetReservedMemLimit Function
See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto


See Also

See Also
PrlDispNet_GetDhcpScopeEndIp Function
See Also

PrlDispNet_SetDhcpScopeEndIp


See Also

See Also
PrlDispNet_GetDhcpScopeMask Function
See Also

PrlDispNet_SetDhcpScopeMask


See Also

See Also
PrlDispNet_GetDhcpScopeStartIp Function
See Also

PrlDispNet_SetDhcpScopeStartIp


See Also

See Also
PrlDispNet_GetIndex Function
See Also

PrlDispNet_SetIndex


See Also

See Also
PrlDispNet_GetName Function
See Also

PrlDispNet_SetName


See Also

See Also
PrlDispNet_GetNetworkType Function
See Also

PrlDispNet_SetNetworkType


See Also

See Also
PrlDispNet_GetSysName Function
See Also

PrlDispNet_SetSysName


See Also

See Also
PrlDispNet_IsDhcpEnabled Function
See Also

PrlDispNet_SetDhcpEnabled


See Also

See Also
PrlDispNet_IsEnabled Function
See Also

PrlDispNet_SetEnabled


See Also

See Also
PrlDispNet_SetDhcpEnabled Function
See Also

PrlDispNet_IsDhcpEnabled


See Also

See Also
PrlDispNet_SetDhcpScopeEndIp Function
See Also

PrlDispNet_GetDhcpScopeEndIp


See Also

See Also
PrlDispNet_SetDhcpScopeMask Function
See Also

PrlDispNet_GetDhcpScopeMask


See Also

See Also
PrlDispNet_SetDhcpScopeStartIp Function
See Also

PrlDispNet_GetDhcpScopeStartIp


See Also

See Also
PrlDispNet_SetEnabled Function
See Also

PrlDispNet_IsEnabled


See Also

See Also
PrlDispNet_SetIndex Function
See Also

PrlDispNet_GetIndex


See Also

See Also
PrlDispNet_SetName Function
See Also

PrlDispNet_GetName


See Also

See Also
PrlDispNet_SetNetworkType Function
See Also

PrlDispNet_GetNetworkType


See Also

See Also
PrlDispNet_SetSysName Function
See Also

PrlDispNet_GetSysName


PrlEnums.h Enumerations

PrlEnums.h Enumerations
PrlEnums.h Legend
Enumerations
Name | Description
_PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
_PRL_APP_IN_DOCK_MODE | VM application in Dock mode
_PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
_PRL_CPU_HVT | CPU mode
_PRL_CPU_MODE | CPU mode
_PRL_DEVICE_ACTION | Device in use Action
_PRL_DEVICE_TYPE | Device type
_PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
_PRL_DISPLAY_CODEC_QUALITY | Display codec quality
_PRL_DISPLAY_CODEC_TYPE | Display codec types
_PRL_DOCK_ICON_TYPE | VM application icon type in Dock
_PRL_EVENT_ISSUER_TYPE | Event issuer type
_PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
_PRL_FILE_SYSTEM_FS_TYPE |
_PRL_FILE_SYSTEM_TYPE | File system general type
_PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
_PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
_PRL_HOST_OS_TYPE | Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
_PRL_IMAGE_FORMAT |
_PRL_IO_STATE |
_PRL_JOB_OPERATION_CODE | Job operation codes
_PRL_JOB_STATUS | Job status enumeration
_PRL_KEY_EVENT |
_PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
_PRL_MOUSE_BUTTON |
_PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
_PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
_PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PROCESS_STATE_TYPE | Process state element
_PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
_PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
_PRL_SECURITY_LEVEL | Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM | Parallels service statuses
_PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
_PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
_PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
_PRL_VERSION_ENUM | Parallels license versions enumeration.
_PRL_VM_ACCELERATION_LEVEL | Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
_PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION | VM autostart options
_PRL_VM_AUTOSTOP_OPTION | VM autostop options
_PRL_VM_BOOT_ORDER | VM boot order
_PRL_VM_CONFIG_SECTIONS | VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
_PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
_PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
_PRL_VM_PRIORITY | Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE | VM start login mode
_PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
_PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
_PRL_VM_WINDOW_MODE | VM window mode
_PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
PRL_APP_IN_DOCK_MODE | VM application in Dock mode
PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
PRL_CPU_HVT | CPU mode
PRL_CPU_MODE | CPU mode
PRL_DEVICE_ACTION | Device in use Action
PRL_DEVICE_TYPE | Device type
PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
PRL_DISPLAY_CODEC_QUALITY | Display codec quality
PRL_DISPLAY_CODEC_TYPE | Display codec types
PRL_DOCK_ICON_TYPE | VM application icon type in Dock
PRL_EVENT_ISSUER_TYPE | Event issuer type
PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
PRL_FILE_SYSTEM_FS_TYPE |
PRL_FILE_SYSTEM_TYPE | File system general type
PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
PRL_HOST_OS_TYPE | Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
PRL_IMAGE_FORMAT |
PRL_IO_STATE |
PRL_JOB_OPERATION_CODE | Job operation codes
PRL_JOB_STATUS | Job status enumeration
PRL_KEY_EVENT |
PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
PRL_MOUSE_BUTTON |
PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PROCESS_STATE_TYPE | Process state element
PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
PRL_SECURITY_LEVEL | Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM | Parallels service statuses
PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
PRL_VERSION_ENUM | Parallels license versions enumeration.
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_WINDOW_MODE | VM window mode
PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_STATE | Virtual machine states enumeration


Legend

Legend
PrlEnums.h
Legend
Enumeration


PrlEnums.h Macros

PrlEnums.h Macros
PrlEnums.h
Macros
Name | Description
PRL_CURRENT_GUEST_OS_SESSION |
PRL_PRIVILEGED_GUEST_OS_SESSION | Guest OS sessions types and constants declarations
PVM_GET_MIGRATION_SECURITY_LEVEL | Macro for extracting VM migration security level value from flags mask
PVM_GET_MIGRATION_TYPE | Macro for extracting VM migration type value from flags mask


PrlEnums.h Types

PrlEnums.h Types
PrlEnums.h
Types
Name | Description
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLICATION_MODE_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IO_STATE_PTR |
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_TIS_RECORD_ACTION_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_VERSION_ENUM_PTR |
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR |
PRL_VM_MIGRATION_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_WINDOW_MODE_PTR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_STATE_PTR |


PrlErrors.h Macros

PrlErrors.h Macros
PrlErrors.h
Macros
Name | Description
PRL_FAILED |
PRL_RESULT_DECLARE_ERROR | Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS |
PRL_SUCCEEDED | Success and failure result codes


PrlErrors.h Types

PrlErrors.h Types
PrlErrors.h
Types
Name | Description
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |


PrlErrorsValues.h Macros

PrlErrorsValues.h Macros
PrlErrorsValues.h
Macros
Name
Description
GUI_ERR_CANT_ADD_PCI_INSTANTLY

  • Gui messages

+++ ALIGNED VALUE TO 15000

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
PET_ANSWER_APPEND
PET_ANSWER_BREAK
PET_ANSWER_CANCEL
PET_ANSWER_COMMIT
PET_ANSWER_CONTINUE
PET_ANSWER_COPIED
PET_ANSWER_CREATE
PET_ANSWER_CREATE_NEW
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_MOVED
PET_ANSWER_NO
PET_ANSWER_OK

  • Answers

+++ ALIGNED VALUE TO 16000

PET_ANSWER_OVERIDE
PET_ANSWER_REPLACE
PET_ANSWER_REVERT
PET_ANSWER_SHUTDOWN
PET_ANSWER_SKIP
PET_ANSWER_STARTVM
PET_ANSWER_STOP
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_USE_CURRENT
PET_ANSWER_YES
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_SAMPLE_1

  • Questions

+++ ALIGNED VALUE TO 13000

PET_QUESTION_SAMPLE_2
PET_QUESTION_TXT_ERROR
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_VM_COPY_OR_MOVE
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_VALID

  • Disk validation errors

+++ ALIGNED VALUE TO 25000

PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
Dispatcher service mode errors codes
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_ERROR_COMMON

  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DEV_ALREADY_CONNECTED

  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
ALIGNED VALUE TO 1000
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED

  • Other

+++ ALIGNED VALUE TO 10000

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED

  • Parallel Port

+++ ALIGNED VALUE TO 7000

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED

  • Serial Port

+++ ALIGNED VALUE TO 6000

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED

  • USB

+++ ALIGNED VALUE TO 8000

PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_DATA_NOT_FOUND

  • User parameters errors

* +++ ALIGNED VALUE TO 23000

PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_GENERIC_ERROR

  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

PRL_ERR_DISK_GET_MOUNTPATH_FAILED

  • Bootcamp errors

* +++ ALIGNED VALUE TO 24000

PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SHARED_BLOCK

  • Compressing errors

* +++ ALIGNED VALUE TO 22000

PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_IS_NOT_STARTED
Dispatcher errors codes
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DOUBLE_INIT
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILURE
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED

  • File Transfer errors

+++ ALIGNED VALUE TO 26000

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FIXME
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_PATH
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_PARALLELS_DISK

  • Hard Drive

+++ ALIGNED VALUE TO 2000

PRL_ERR_INVALID_PARAM
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_DISABLED
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_STOPPED
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED

  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_CANNOT_START
iPhone proxy errors +++ ALIGNED VALUE TO 32000
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_VALID

  • License

+++ ALIGNED VALUE TO 11000

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_DATA
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
VM guest operations errors +++ ALIGNED VALUE TO 34000
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSING_EVENT
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_REBOOT_HOST
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
Device of this type cannot be remote device type is not registered
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SMC_ERROR
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOUND_DEVICE_WRITE_FAILED

  • Sound

+++ ALIGNED VALUE TO 5000

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_UNEXPECTED_ERROR

  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

PRL_ERR_SUCCESS
All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TIMEOUT
PRL_ERR_TIS_INVALID_UID

  • TIS errors

+++ ALIGNED VALUE TO 27800

PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TRY_AGAIN
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNEXPECTED
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNINITIALIZED
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_UPDATER_CONFIG

  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

PRL_ERR_UPD_UPDATES
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_VA_CONFIG

  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

PRL_ERR_VM_ABORT
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_COMPACT_PROCESSING

  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS
PRL_ERR_VM_LOCKED_FOR_CLONE
FIXME: all constants like 'PRL_ERR_VM_LOCKED_FOR_***' should be changed to 'PRL_ERR_CONCURRENT_COMMAND_EXECUTING' until fix bug #6370 ( http://bugzilla/show_bug.cgi?id=6370 )
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
VM migration errors codes set +++ ALIGNED VALUE TO 31000
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
VM tools erros codes set +++ ALIGNED VALUE TO 33000
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
ALIGNED VALUE TO 27050
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27400
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT
ALIGNED VALUE TO 27200
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27350
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
ALIGNED VALUE TO 27760
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27450
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27700
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
ALIGNED VALUE TO 27250
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
ALIGNED VALUE TO 27500
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27650
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
ALIGNED VALUE TO 27100
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
ALIGNED VALUE TO 27750
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
ALIGNED VALUE TO 27600
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
ALIGNED VALUE TO 27150
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
ALIGNED VALUE TO 27550
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_VALIDATION_FAILED

  • Validation VM configuration error

+++ ALIGNED VALUE TO 27000

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
ALIGNED VALUE TO 27300
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VNC_SERVER_ALREADY_STARTED
VNC server operations errors +++ ALIGNED VALUE TO 35000
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_DEVICE_NOT_MAPPED

  • VT-d

+++ ALIGNED VALUE TO 12000

PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_XML_WRITE_FILE
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_BIND_FAILED
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ETHLIST_CREATE_ERROR

  • Network

+++ ALIGNED VALUE TO 4000

PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_TIMEOUT
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
Operation succeeded, but failed to change Network Adapter IP-address.
PRL_NET_PKTFILTER_ERROR
Failed to setup packet filter for VM Adapter.
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_RENAME_FAILED
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SYSTEM_ERROR
PRL_NET_UNINSTALL_FAILED
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
Error while connect VMDevice: Misconfiguration in virtual network.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
Error while connect VMDevice: Specified virtual network is disabled.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
Error while connect VMDevice: Adapter for virtual network does not exist.
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
Error while connect VMDevice: network for VM Network Adapter does not exist.
PRL_NET_WINSCM_OPEN_ERROR
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_POWER_OFF
PRL_QUEST_RESET
PRL_QUEST_RESTART
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_HDD_ERROR
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WNG_START_VM_ON_MOUNTED_DISK


Example

Example
PrlEvent_CreateAnswerEvent Function

The following is a complete example that demonstrates how to handle events and how to answer to Parallels Service questions. In the example, we create a blank virtual machine and try to add a virtual hard drive to it with the size larger than the free disk space available on the physical drive. This will trigger an event on the Parallels Service side and a question will be sent to the client asking if we really want to create a drive like that. The virtual machine creation operation will not continue unless we send an answer to the Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>
#include <stdlib.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

#define MY_JOB_TIMEOUT 10000 // Default timeout to use in the PrlJob_Wait function.
#define MY_HDD_SIZE 70*1024 // The size of the new hard drive.
#define MY_STR_BUF_SIZE 1024 // The default buffer size to use for string output.

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event on the
// Parallels Service, which will result in Service sending us a question.
static PRL_RESULT create_big_hdd(PRL_HANDLE hVm);

// The callback function (event handler).
static PRL_RESULT callback(PRL_HANDLE, PRL_VOID_PTR);

////////////////////////////////////////////////////////////////////////////////

int main(int argc, char* argv[])
{
    // Pick the correct dynamic library file depending on the platform.
    #ifdef _WIN_
        #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
        #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
        #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the dynamic library.
    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        // Error handling goes here...
        return -1;
    }

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;
    PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
    PRL_HANDLE hServer = PRL_INVALID_HANDLE;

    // Initialize API library.
    err = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(err))
    {
        // Error handling goes here...
        return -1;
    }

    // Create server object.
    PrlSrv_Create(&hServer);

    // Log in.
    hJob = PrlSrv_Login(
        hServer, // Server handle
        "10.30.22.82", // Host IP address
        "jdoe", // User
        "secret", // Password
        0, // Previous session ID
        0, // Port number
        0, // Timeout
        PSL_NORMAL_SECURITY); // Security

    ret = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if (PRL_FAILED( nJobResult))
    {
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Create a new virtual machine.
    PRL_HANDLE hVm;
    PrlSrv_CreateVm(hServer, &hVm);
    PrlVm_SetName(hVm, "My simple VM");

    // Register the virtual machine with the Parallels Service.
    hJob = PrlVm_Reg(hVm, "", PRL_FALSE);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    // Register the event handler with the Service.
    // The second parameter is a pointer to our callback function.
    PrlSrv_RegEventHandler(hServer, &callback, NULL);

    // Try creating a virtual hard drive larger than the
    // free space available (increase MY_HDD_SIZE value if needed).
    // This should produce an event that will
    // contain a question from the Parallels Service.
    create_big_hdd(hVm);

    //
    // At this point, the background thread should call the
    // callback function.
    //

    // We can now clean up and exit the program.
    // Unregister the event handler and log off.
    PrlSrv_UnregEventHandler(hServer, &callback, NULL);
    hJob = PrlSrv_Logoff(hServer);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );
    PrlApi_Deinit();
    SdkWrap_Unload();
    return 0;
}

////////////////////////////////////////////////////////////////////////////////
// The callback function implementation.
// The event handling is demonstrated here.
//
static PRL_RESULT callback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType(hEvent, &nHandleType);

    // A callback function will be called more than once.
    // It will be called for every job that we initiate and it
    // will be called for the event that we intentionally trigger.
    // In this example, we are interested in events only.
    if (nHandleType != PHT_EVENT)
    {
        return PrlHandle_Free(hEvent);
    }

    // Get the type of the event received.
    PRL_EVENT_TYPE type;
    PrlEvent_GetType(hEvent, &type);

    // See if the received event is a "question".
    if (type == PET_DSP_EVT_VM_QUESTION)
    {
        PRL_UINT32 nParamsCount = 0;
        PRL_RESULT err = PRL_ERR_UNINITIALIZED;

        // Extract the text of the question and display it on the screen.
        // The question is stored in the object in the "event message" property.
        PRL_BOOL bIsBriefMessage = true;
        char errMsg [MY_STR_BUF_SIZE];
        PRL_UINT32 nBufSize = MY_STR_BUF_SIZE;

        PrlEvent_GetErrString(hEvent, bIsBriefMessage, errMsg, &nBufSize);
        printf("Question: %s\n\n", errMsg);

        // Extract answer choices. They are stored in the
        // hEvent object as event parameters.
        // First, determine the number of parameters.
        err = PrlEvent_GetParamsCount(hEvent, &nParamsCount);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[3]%.8X: %s\n", err,
                PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Declare an array to hold the choices information.
        PRL_UINT32_PTR choices =(PRL_UINT32_PTR)
            malloc(nParamsCount * sizeof(PRL_UINT32));

        // Now, itereate through the parameter list obtaining a
        // handle of type PHT_EVENT_PARAMETER that will contain
        // an individual parameter data.
        for(PRL_UINT32 nParamIndex = 0; nParamIndex < nParamsCount; ++nParamIndex)
        {
            PRL_HANDLE hParam; // this will receive the event parameter handle.
            PRL_RESULT err = PRL_ERR_UNINITIALIZED;

            // The PrlEvent_GetParam function obtains a handle of type
            // PHT_EVENT_PARAMETER containing (in this case) an answer choice.
            err = PrlEvent_GetParam(hEvent, nParamIndex, &hParam);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[4]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Get the answer description that can be shown to the user.
            // First, obtain the event parameter value.
            err = PrlEvtPrm_ToUint32(hParam, &choices[nParamIndex]);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[9]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Now, get the answer description using the
            // event parameter value as input in the following call.
            char sDesc [MY_STR_BUF_SIZE];
            err = PrlApi_GetResultDescription(choices[nParamIndex], true, sDesc, &nBufSize);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[8]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Display the answer choice on the screen.
            printf("Answer choice: %s\n", sDesc);
            PrlHandle_Free(hParam);
        }

        // Select an answer choice (we are using the "No" answer here) and
        // create a valid answer object (hAnswer).
        PRL_HANDLE hAnswer;
        err = PrlEvent_CreateAnswerEvent(hEvent, &hAnswer, choices[1]);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[A]%.8X: %s\n", err, PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Obtain a server handle.
        PRL_HANDLE hServer;
        PrlEvent_GetServer(hEvent, &hServer);

        // Send the answer handle to the Parallels Service.
        PrlSrv_SendAnswer(hServer, hAnswer);

        free(choices);
        PrlHandle_Free(hServer);
        PrlHandle_Free(hAnswer);
    }
    else // other event type
    {
        PrlHandle_Free(hEvent);
    }

    return PRL_ERR_SUCCESS;
}

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event.
PRL_RESULT create_big_hdd(PRL_HANDLE hVm)
{
    PRL_HANDLE hJobBeginEdit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobCommit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;

    // Timestamp the beginning of the configuration changes operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    err = PrlJob_Wait(hJobBeginEdit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[B]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Create a new device handle.
    // This will be our new virtual hard disk.
    PRL_HANDLE hHDD;
    err = PrlVm_CreateVmDev(
            hVm, // Target virtual machine.
            PDE_HARD_DISK, // Device type.
            &hHDD ); // Device handle.

    // Set disk type to "expanding".
    err = PrlVmDevHd_SetDiskType(hHDD, PHD_EXPANDING_HARD_DISK);

    // Set max disk size, in megabytes.
    err = PrlVmDevHd_SetDiskSize(hHDD, MY_HDD_SIZE);

    // This option determines whether the image file will be split
    // into chunks or created as a single file.
    err = PrlVmDevHd_SetSplitted(hHDD, PRL_FALSE);

    // Choose and set the name for the new image file.
    err = PrlVmDev_SetFriendlyName(hHDD, "harddisk4.hdd");
    err = PrlVmDev_SetSysName(hHDD, "harddisk4.hdd");

    // Set the emulation type.
    err = PrlVmDev_SetEmulatedType(hHDD, PDT_USE_IMAGE_FILE);

    // Enable the new disk on successful creation.
    err = PrlVmDev_SetEnabled(hHDD, PRL_TRUE);

    // Create the new image file.
    hJob = PrlVmDev_CreateImage(hHDD,
            PRL_TRUE, // Do not overwrite if file exists.
            PRL_FALSE ); // Use non-interactive mode.

    err = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    if (PRL_FAILED(err))
    {
        fprintf(stderr, "[C]%.8X: %s\n", err,
            PRL_RESULT_TO_STRING(err));
        PrlHandle_Free(hJob);
        return err;
    }

    // Commit the changes.
    hJobCommit = PrlVm_Commit(hVm);
    err = PrlJob_Wait(hJobCommit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[D]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING( nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }
    return PRL_ERR_SUCCESS;
}


PrlFs.h Macros

PrlFs.h Macros
PrlFs.h
Macros
Name | Description
FS_PERM_EXECUTE |
FS_PERM_READ |
FS_PERM_WRITE |
IS_FS_EXECUTE_PERMITTED |
IS_FS_READ_PERMITTED |
IS_FS_WRITE_PERMITTED |
SET_FS_EXECUTE_DISABLED |
SET_FS_EXECUTE_ENABLED |
SET_FS_READ_DISABLED |
SET_FS_READ_ENABLED |
SET_FS_WRITE_DISABLED |
SET_FS_WRITE_ENABLED |


See Also

See Also
PrlHandle_AddRef Function
See Also

PrlHandle_Free


Legend

Legend
PrlIoStructs.h
Legend
Structure


PrlIoStructs.h Macros

PrlIoStructs.h Macros
PrlIoStructs.h
Macros
Name | Description
PRL_IO_MAX_DISPLAYS |


PrlIoStructs.h Structures

PrlIoStructs.h Structures
PrlIoStructs.h Legend
Structures
Name
Description
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GUEST_SCREENSAVER_STATE
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SLIDING_MOUSE
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_RESPONSE
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_SCREENSAVER_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SLIDING_MOUSE
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO


PrlIoStructs.h Types

PrlIoStructs.h Types
PrlIoStructs.h
Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_SCREENSAVER_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_VERSION_PTR |


Example

Example
PrlJob_GetResult Function

The following code illustrates how to obtain a result from the job object using the login operation as an example.

// Log in to a Parallels Service.
hJob =
PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );

// Wait for the job to complete.
PrlJob_Wait( hJob, 10000 );

// Get a handle of type PHT_RESULT containing the results
// of the operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlJob_Wait Function
// Log in to Parallels Service.
// This is an asynchronous call.
// Returns a handle to the Job object.
PRL_HANDLE hJob = PrlSrv_Login(
    hServer, "10.30.23.105", "miket", "1q2w3e",
    0, 0, 0, PRL_SECURITY_LEVEL::PSL_LOW_SECURITY);

// Wait for the Job object to receive the results of the operation.
ret = PrlJob_Wait( hJob, 1000 );
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait returned with error (%s)\n",
        PRL_RESULT_TO_STRING(ret));
    return -1;
}

// Get the results from the Job object.
PRL_RESULT nJobResult;
ret = PrlJob_GetRetCode( hJob, &nJobResult );
if (PRL_FAILED( nJobResult ))
{
    printf("login job returned with error (%s)\n",
        PRL_RESULT_TO_STRING( nJobResult ));
    return -1;
}
else
    printf( "Login succeeded.\n" );

// Delete the Job handle.
PrlHandle_Free( hJob );


PrlKeys.h Macros

PrlKeys.h Macros
PrlKeys.h
Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | Scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_Z |


PrlOses.h Macros

PrlOses.h Macros
PrlOses.h
Macros
Name | Description
IS_FREEBSD |
IS_LINUX |
IS_MACOS |
IS_MSDOS |
IS_NETWARE |
IS_OS2 |
IS_OTHER |
IS_SOLARIS |
IS_VALID_FREEBSD_VERSION |
IS_VALID_LINUX_VERSION |
IS_VALID_MACOS_VERSION |
IS_VALID_MSDOS_VERSION |
IS_VALID_NETWARE_VERSION |
IS_VALID_OS2_VERSION |
IS_VALID_OTHER_OS_VERSION |
IS_VALID_SOLARIS_VERSION |
IS_VALID_WINDOWS_VERSION |
IS_WINDOWS |
PVS_GET_GUEST_NUMBER |
PVS_GET_GUEST_TYPE |
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_XP |
PVS_MAKE_GUEST_VER |


Example

Example
PrlResult_GetParam Function

The following example demonstrates using asynchronous function PrlSrv_GetSrvConfig synchronously, and the steps involved in obtaining a handle to an object of type PHT_SERVER_CONFIG (which is returned by PrlSrv_GetSrvConfig):

PRL_HANDLE hJob = PrlSrv_GetSrvConfig(hServer);

// Step 1 - emulate a synchronous call using PrlJob_Wait.

PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 2 - determine if PrlSrv_GetSrvConfig succeeded or failed
// using PrlJob_GetRetCode.

PrlJob_GetRetCode(hJob, &nJobResult);
if (PRL_FAILED(nJobResult))
{
    printf("PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 3 - Obtain a handle to the result object (a handle
// of type PHT_RESULT) using PrlJob_GetResult.

PRL_HANDLE hResult;
ret = PrlJob_GetResult(hJob, &hResult);
PrlHandle_Free(hJob); // hJob no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlJob_GetResult for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hResult);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 4 - Get a handle to the final result (in this case,
// a handle of type PHT_SERVER_CONFIG) using PrlResult_GetParam.
// For PHT_RESULT handles that contain more than one result, first use
// PrlResult_GetParamsCount, then use PrlResult_GetParamByIndex.

PRL_HANDLE hServerConfig;
ret = PrlResult_GetParam(hResult, &hServerConfig);
PrlHandle_Free(hResult); // hResult no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlResult_GetParam for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hServerConfig);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();

    return -1;
}

// At this point, a handle of type PHT_SERVER_CONFIG is available, and
// functions that operate on PHT_SERVER_CONFIG handles can be used on
// the handle.

PRL_UINT32 nCpuCount = 0;
PrlSrvCfg_GetCpuCount(hServerConfig, &nCpuCount);
printf("Number of CPUs: %d\n", nCpuCount);

PRL_CPU_MODE CpuMode;
PrlSrvCfg_GetCpuMode(hServerConfig, &CpuMode);
printf("CPU Mode: %d bit\n", CpuMode == PCM_CPU_MODE_32 ? 32 : 64);

PRL_CHAR szCpuModel[1024];
PRL_UINT32 nCpuModelSize = sizeof(szCpuModel);
memset(szCpuModel, 0, nCpuModelSize);
PrlSrvCfg_GetCpuModel(hServerConfig, szCpuModel, &nCpuModelSize);
printf("CPU Model: %s\n", szCpuModel);

PRL_UINT32 nCpuSpeed = 0;
PrlSrvCfg_GetCpuSpeed(hServerConfig, &nCpuSpeed);
printf("CPU Speed: %.3f MHz\n", nCpuSpeed / 1000.0);

PRL_CHAR szHostOsString[1024];
PRL_UINT32 nHostOsStringSize = sizeof(szHostOsString);
PrlSrvCfg_GetHostOsStrPresentation(hServerConfig, szHostOsString, &nHostOsStringSize);
printf("Host OS: %s\n", szHostOsString);

PrlHandle_Free(hServerConfig);


Example

Example
PrlResult_GetParamByIndex Function

The following example demonstrates using asynchronous function PrlSrv_GetVmList (getting the list of virtual machines), and the steps involved in obtaining handles to objects of type PHT_VIRTUAL_MACHINE returned by PrlSrv_GetVmList (each object contains information about an individual virtual machine):

PRL_RESULT DisplayVmList(const PRL_HANDLE &hServer)
{
    PRL_HANDLE hResult;
    PRL_RESULT nJobResult;

    // Get a list of virtual machines.
    PRL_HANDLE hJob = PrlSrv_GetVmList(hServer);

    // Wait for the job to complete.
    PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Check the results of PrlSrv_GetVmList.
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Get the results of PrlSrv_GetVmList.
    ret = PrlJob_GetResult(hJob, &hResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetResult returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hResult);
        PrlHandle_Free(hJob);
        return ret;
    }

    // Handle to result object is available,
    // job handle is not longer needed, so free it.
    PrlHandle_Free(hJob);

    // Iteratre through the result list.
    PRL_UINT32 nParamsCount = 0;
    ret = PrlResult_GetParamsCount(hResult, &nParamsCount);

    for (PRL_UINT32 i = 0; i < nParamsCount; ++i)
    {
        PRL_HANDLE hVm;

        // Get a handle to result at index i.
        PrlResult_GetParamByIndex(hResult, i, &hVm);

        // Get the name of the virtual machine for result i.
        char szVmNameReturned[1024];
        PRL_UINT32 nBufSize = sizeof(szVmNameReturned);
        ret = PrlVm_GetName(hVm, szVmNameReturned, &nBufSize);

        if (PRL_FAILED(ret))
        {
            printf("PrlVm_GetName returned with error (%s)\n",
                PRL_RESULT_TO_STRING(ret));
        }
        else
        {
            printf("Virtual machine '%s' is available.\n\n", szVmNameReturned);
        }

        // Free the virtual machine handle.
        PrlHandle_Free(hVm);
    }

    return PRL_ERR_SUCCESS;
}


See Also

See Also
PrlShare_GetDescription Function
See Also

PrlShare_SetDescription


See Also

See Also
PrlShare_GetName Function
See Also

PrlShare_SetName


See Also

See Also
PrlShare_GetPath Function
See Also

PrlShare_SetPath


See Also

See Also
PrlShare_IsEnabled Function
See Also

PrlShare_SetEnabled


See Also

See Also
PrlShare_IsReadOnly Function
See Also

PrlShare_SetReadOnly


See Also

See Also
PrlShare_SetDescription Function
See Also

PrlShare_GetDescription


See Also

See Also
PrlShare_SetEnabled Function
See Also

PrlShare_IsEnabled


See Also

See Also
PrlShare_SetName Function
See Also

PrlShare_GetName


See Also

See Also
PrlShare_SetPath Function
See Also

PrlShare_GetPath


See Also

See Also
PrlShare_SetReadOnly Function
See Also

PrlShare_IsReadOnly


Example

Example
PrlSrv_Create Function

The following example illustrates how to create a handle of type PHT_SERVER.

PRL_HANDLE hServer;

PRL_RESULT ret = PrlSrv_Create( &hServer );
if ( PRL_FAILED(ret) )
{
    printf( "PrlSrv_Create returned with error: %s\n",
    PRL_RESULT_TO_STRING(ret) );
}

// Free hServer handle when it's no longer needed.
PrlHandle_Free( hServer );


See Also

See Also
PrlSrv_Create Function
See Also

PrlSrv_LoginLocal

PrlSrv_Login


Example

Example
PrlSrv_CreateVm Function
// Create a new virtual machine handle
// (assumes hServer is a valid handle obtained using PrlSrv_Create,
// and a successful Parallels Service login was made using PrlSrv_Login).
PRL_HANDLE hNewVm;
ret = PrlSrv_CreateVm(hServer, &hNewVm);
if (PRL_FAILED(ret))
{
    printf("PrlSvr_CreateVm call failed with: %s.\n", PRL_RESULT_TO_STRING(ret));
    return ret;
}
printf("PrlSvr_CreateVm completed successfully.\n");


Example

Example
PrlSrv_FsGetDiskList Function

The following example illustrates how to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO.

hJob =
PrlSrv_FsGetDiskList( hServer );
PrlJob_Wait( hJob, JOB_TIMEOUT );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_REMOTE_FILESYSTEM_INFO handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetCommonPrefs Function

The following example illustrates how to obtain a handle of type PHT_DISP_CONFIG.

hJob =
PrlSrv_GetCommonPrefs( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_DISP_CONFIG handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetLicenseInfo Function

The following example illustrates how to obtain a handle of type PHT_LICENSE.

hJob =
PrlSrv_GetLicenseInfo( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LICENSE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetNetServiceStatus Function

The following example illustrates how to obtain a handle of type PHT_NET_SERVICE_STATUS containing the Parallels Service network service status.

hJob =
PrlSrv_GetNetServiceStatus( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_NET_SERVICE_STATUS handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetSrvConfig Function

The following example illustrates how to obtain a handle of type PHT_SERVER_CONFIG from the PHT_SERVER object (the example assumes that you've already obtained a server handle).

hJob =
PrlSrv_GetSrvConfig( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_SERVER_CONFIG handle from the result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetStatistics Function

The following example illustrates how to obtain a handle of type PHT_SYSTEM_STATISTICS.

PRL_RESULT err = PRL_ERR_UNINITIALIZED;
PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
PRL_HANDLE hJob = PRL_INVALID_HANDLE;
PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
PRL_HANDLE hServer = PRL_INVALID_HANDLE;

// Initialize API library.
err = PrlApi_Init(PARALLELS_API_VER);
if (PRL_FAILED(err))
{
    // Error handling goes here...
    return -1;
}

// Create server handle.
err = PrlSrv_Create(&hServer);

// if (err != PRL_ERR_SUCCESS), process the error here.

hJob = PrlSrv_Login(
    hServer, // Server handle
    "10.30.21.243", // Server IP address
    "jdoe", // User
    "secret", // Password
    0, // Previous session ID
    0, // Port number
    0, // Timeout
    PSL_LOW_SECURITY); // Security

// Wait for the job to complete.
err = PrlJob_Wait(hJob, 1000);

// if (err != PRL_ERR_SUCCESS), process the error here.

// Get job return code.
err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

// Free job handle.
PrlHandle_Free(hJob);

// Get statistics.
hJob = PrlSrv_GetStatistics(hServer);
err = PrlJob_Wait(hJob, 10000);

// if (err != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

// Get the PHT_SYSTEM_STATISTICS handle.
PRL_HANDLE hHandle = PRL_INVALID_HANDLE;
err = PrlResult_GetParam(hJobResult, &hHandle);

// if (err != PRL_ERR_SUCCESS), process the error here.

PrlHandle_Free(hJobResult);


See Also

See Also
PrlSrv_GetUserInfo Function
See Also

PrlSrv_GetUserInfoList


Example

Example
PrlSrv_GetUserProfile Function

The following example shows how to obtain a handle of type PHT_USER_PROFILE.

hJob =
PrlSrv_GetUserProfile( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_USER_PROFILE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlSrv_GetVmList Function

The following example illustrates how to obtain a list of virtual machine registered on the specified Parallels Service. The examples assumes that we've already obtain a handle of type PHT_SERVER (the hServer variable) identifying the Parallels Service.

hJob =
PrlSrv_GetVmList( hServer );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;

// Get the number of the virtual machines
// in the list.
PrlResult_GetParamsCount( hJobResult, &nCount );

// Iterate through the list.
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    // Get virtual machine name.
    nRetCode =
    PrlVm_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s.\n", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );


Example

Example
PrlSrv_Login Function

The following is a complete sample program that illustrates how to log in to a remote Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szVmName = "Windows XP";
const char *szServer = "127.0.0.1";
const char *szUsername = "SomeUserName";
const char *szPassword = "SomePassword";

int main( int argc, char* argv[] )
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the SDK library.
    if ( PRL_FAILED( SdkWrap_Load( SDK_LIB_NAME ) ) &&
        PRL_FAILED( SdkWrap_Load( "./" SDK_LIB_NAME ) ) )
    {
        fprintf( stderr, "Failed to load " SDK_LIB_NAME "\n" );
        return -1;
    }

    // Initialize the API.
    ret = PrlApi_Init( PARALLELS_API_VER );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create( &hServer );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (asynchronous call).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer,            // PRL_HANDLE of type PHT_SERVER.
            szServer,           // Name and IP address of the host machine.
            szUsername,         // User name.
            szPassword,         // Password.
            0,                  // Previuos session ID (0 if not used).
            0,                  // Port number (0 for default port).
            0,                  // Timeout value (0 for default timeout).
            PSL_LOW_SECURITY ); // Security level.

    // Wait for a maximum of 10 seconds for
    // the job to complete.
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING( ret) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( nJobResult ) )
    {
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Login was successful.\n" );

    // Log off.
    hJob = PrlSrv_Logoff( hServer );
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if ( PRL_FAILED( nJobResult ) )
    {
        fprintf( stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Logoff was successful.\n" );

    // Free handles that are no longer required.
    PrlHandle_Free( hVm );
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    printf( "\n\nEnd of program.\n\n" );
    char c;
    scanf( &c, "%c" );

    return 0;
}


See Also

See Also
PrlSrv_Login Function
See Also

PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_LoginLocal Function

The following example illustrates how to log in to locally running Parallels Service and to obtain a handle of type PHT_LOGIN_RESPONSE.

// Log in.
hJob = PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );
PrlJob_Wait( hJob, 10000 );

// Get the results of the login operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


See Also

See Also
PrlSrv_LoginLocal Function
See Also

PrlDispCfg_GetMinSecurityLevel


Example

Example
PrlSrv_LookupParallelsServers Function

The following example illustrates how to call the PrlSrv_LookupParallelsServers synchronously.

hJob =
PrlSrv_LookupParallelsServers(
    10000,  // timeout
    NULL,   // callback function (not used)
    NULL    // user object pointer (not used)
);

printf("Searching for Parallels Services...\n");

nRetCode =
PrlJob_Wait(hJob, 100000);

if (PRL_FAILED(nRetCode))
{
    fprintf(stderr, "PrlJob_Wait returned with error: %s.\n",
        PRL_RESULT_TO_STRING( nRetCode));
    PrlApi_Deinit();
    SdkWrap_Unload();
    return nRetCode;
}

PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount(hJobResult, &nCount);

for (nIndex = 0; nIndex < nCount ; nIndex++)
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex(hJobResult, nIndex, &hParam);

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof(sBuf);

    nRetCode =
    PrlSrvInfo_GetHostName(hParam, sBuf, &nBufSize);

    if (PRL_SUCCEEDED(nRetCode))
        printf("Found Service: %s.\n", &sBuf[0]);
    else
        fprintf(stderr, "PrlSrvInfo_GetHostName failed, error: %s. \n",
            PRL_RESULT_TO_STRING(nRetCode));

    PrlHandle_Free(hParam);
}

PrlHandle_Free(hJobResult);

In the following example, the PrlSrv_LookupParallelsServers is called asynchronously. In order to that, we first have to implement a callback function (let's call it ourCallback):

static PRL_RESULT ourCallback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    printf("%s: ", pUserData);

    // Get the name of the host machine.
    PRL_UINT32 nBufSize = 1024;
    PRL_CHAR sBuf[nBufSize];
    PrlSrvInfo_GetHostName(hEvent, sBuf, &nBufSize);

    // Get the other properties and process them here...

    // The handle must be freed.
    PrlHandle_Free(hEvent);
    return rc;
}

The PrlSrv_LookupParallelsServers function can now be called as follows:

hJob =
PrlSrv_LookupParallelsServers(
    1000,
    &ourCallback,
    (PRL_VOID_PTR)("callback")
);


Example

Example
PrlSrv_RegisterVm Function

The following sample function demonstrates how to add an existing virtual machine to the Parallels Service. The function takes a handle of type PHT_SERVER and a string specifying the name and path of the virtual machine directory. It registers the virtual machine with the Service and then modifies the MAC address of every virtual network adapter installed in it.

PRL_RESULT RegisterExistingVM(PRL_HANDLE hServer, PRL_CONST_STR sVmDirectory)
{
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;

    // Register the virtual machine with the Parallels Service.
    hJob = PrlSrv_RegisterVm(
        hServer,
        sVmDirectory,
        PRL_TRUE);  // Using non-interactive mode.

    ret = PrlJob_Wait(hJob, 10000);

    // Check the return code of PrlSrv_RegisterVm.
    PrlJob_GetRetCode(hJob, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        printf("PrlSrv_RegisterVm returned error: %s\n",
            prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJob);
        return -1;
    }

    // Obtain the virtual machine handle from the job object.
    // We will use the handle later to modify the virtual machine
    // configuration.
    PRL_HANDLE hVm = PRL_INVALID_HANDLE;
    ret = PrlJob_GetResult(hJob, &hJobResult);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    ret = PrlResult_GetParam(hJobResult, &hVm);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    PrlHandle_Free(hJob);
    PrlHandle_Free(hJobResult);

    printf("Virtual machine '%s' was successfully registered.",
            sVmDirectory);

    // The following code will generate and set a new MAC address
    // for every virtual network adapter that exists in the virtual machine.
    // This step is optional and should normally be performed when the virtual
    // machine is a copy of another virtual machine.

    PRL_HANDLE hJobBeginEdit;
    PRL_HANDLE hJobCommit;

    // Begin the virtual machine editing operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    ret = PrlJob_Wait(hJobBeginEdit, 10000);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Obtain a handle of type PHT_VM_CONFIGURATION containing the
    // virtual machine configuration data.
    PRL_HANDLE hVmCfg = PRL_INVALID_HANDLE;
    ret = PrlVm_GetConfig(hVm, &hVmCfg);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Determine the number of the network adapters
    // installed in the machine.
    PRL_UINT32 nCount = PRL_ERR_UNINITIALIZED;
    ret = PrlVmCfg_GetNetAdaptersCount(hVmCfg, &nCount);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Itereate through the adapter list.
    PRL_HANDLE hNetAdapter = PRL_INVALID_HANDLE;
    for (PRL_UINT32 i = 0; i < nCount; ++i)
    {
        ret = PrlVmCfg_GetNetAdapter(hVmCfg, i, &hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }

        // Automatically generate new MAC address for the current adapter.
        // The address will be updated in the configuration object.
        ret = PrlVmDevNet_GenerateMacAddr(hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }
    }

    // Commit the changes to the virtual machine.
    hJobCommit = PrlVm_Commit(hVm);

    // Check the results of the commit operation.
    ret = PrlJob_Wait(hJobCommit, 10000);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Commit error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }

    PrlHandle_Free(hNetAdapter);
    PrlHandle_Free(hVm);
    PrlHandle_Free(hVmCfg);
    PrlHandle_Free(hJobCommit);
    PrlHandle_Free(hJobBeginEdit);

    return 0;
}


Example

Example
PrlSrv_StartSearchVms Function
PRL_HANDLE hStringList;
PrlApi_CreateStringsList( &hStringList );
PrlStrList_AddItem( hStringList, "/Users/Shared/Parallels/" );

hJob =
PrlSrv_StartSearchVms( hServer, hStringList );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount( hJobResult, &nCount );
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType( hParam, &nHandleType );

    printf( "Handle Type: %s\n",
        PRL_HANDLE_TYPE_TO_STRING( nHandleType ));

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    nRetCode =
    PrlFoundVmInfo_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s\n.", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
PrlHandle_Free( hStringList );


Example

Example
PrlSrv_SubscribeToHostStatistics Function

The following is a complete example that demonstrates how to obtain statistics data asynchronously using PrlSrv_SubscribeToHostStatistics. Note that the same code could be used to receive statistics data for a virtual machine, instead of the host computer, by using PrlVm_SubscribeToGuestStatistics instead of PrlSrv_SubscribeToHostStatistics, and passing it a handle to a virtual machine that is running. This would also require using PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics data for the virtual machine.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szServer = "123.123.123.123";
const char *szUsername = "Your Username";
const char *szPassword = "Your Password";

// -------------------------------------------------------------------------
// Event handler.
// -------------------------------------------------------------------------
// 1. Check for events of type PET_DSP_EVT_HOST_STATISTICS_UPDATES.
// 2. Display a header if first call to this event handler.
// 3. Get the event param (PHT_EVENT_PARAMETER) from the PHT_EVENT handle.
// 4. Convert event param to a handle (will be type PHT_SYSTEM_STATISTICS).
// 5. Use PHT_SYSTEM_STATISTICS handle to obtain CPU usage, memory usage,
// and disk usage data.
// -------------------------------------------------------------------------
static PRL_RESULT OurCallback(PRL_HANDLE handle, void *pData)
{
    PRL_HANDLE_TYPE nHandleType;
    PRL_RESULT ret = PrlHandle_GetType(handle, &nHandleType);

    // Check for PrlHandle_GetType error here.
    if (nHandleType == PHT_EVENT)
    {
        PRL_EVENT_TYPE EventType;
        PrlEvent_GetType(handle, &EventType);

        // Check if the event type is a statistics update.
        if (EventType == PET_DSP_EVT_HOST_STATISTICS_UPDATED)
        {
            // Output a header if first call to this function.
            static PRL_BOOL bHeaderHasBeenPrinted = PRL_FALSE;
            if (!bHeaderHasBeenPrinted)
            {
                bHeaderHasBeenPrinted = PRL_TRUE;
                printf("CPU (%%) Used RAM (MB) Free RAM (MB) Used Disk Space (MB)"
                       " Free Disk Space (MB)\n");
                printf("---------------------------------------------------------"
                       "--------------------\n");
            }

            PRL_HANDLE hEventParameters;
            PRL_HANDLE hServerStatistics;

            // Get the event parameter (PHT_EVENT_PARAMETER) from the event handle.
            PrlEvent_GetParam(handle, 0, &hEventParameters);

            // Convert the event parameter to a handle (PHT_SYSTEM_STATISTICS).
            PrlEvtPrm_ToHandle(hEventParameters, &hServerStatistics);

            // Get CPU statistics (usage in %).
            PRL_HANDLE hCpuStatistics;
            ret = PrlStat_GetCpuStat(hServerStatistics, 0, &hCpuStatistics);
            PRL_UINT32 nCpuUsage = 0;
            ret = PrlStatCpu_GetCpuUsage(hCpuStatistics, &nCpuUsage);

            // Get RAM statistics.
            PRL_UINT64 nUsedRam, nFreeRam;
            PrlStat_GetFreeRamSize(hServerStatistics, &nFreeRam);
            PrlStat_GetUsageRamSize(hServerStatistics, &nUsedRam);
            nUsedRam /= (1024 * 1024);
            nFreeRam /= (1024 * 1024);

            // Get disk space statistics.
            PRL_UINT64 nFreeDiskSpace, nUsedDiskSpace;
            PRL_HANDLE hDiskStatistics;
            PrlStat_GetDiskStat(hServerStatistics, 0, &hDiskStatistics);
            PrlStatDisk_GetFreeDiskSpace(hDiskStatistics, &nFreeDiskSpace);
            PrlStatDisk_GetUsageDiskSpace(hDiskStatistics, &nUsedDiskSpace);
            nUsedDiskSpace /= (1024 * 1024);
            nFreeDiskSpace /= (1024 * 1024);

            printf("%7d %10lld %13lld %20lld %20lld\n",
                nCpuUsage, nUsedRam, nFreeRam, nUsedDiskSpace, nFreeDiskSpace);

            PrlHandle_Free(hDiskStatistics);
            PrlHandle_Free(hCpuStatistics);
            PrlHandle_Free(hServerStatistics);
            PrlHandle_Free(hEventParameters);
        }
    }

    PrlHandle_Free(handle);

    return PRL_ERR_SUCCESS;
}

// -------------------------------
// Program entry point.
// -------------------------------

int main(int argc, char* argv[])
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
        return -1;
    }

    // Initialize the Parallels API.
    ret = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING(ret));
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create(&hServer);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (PrlSrv is asynchronous).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer, // PRL_HANDLE of type PHT_SERVER.
            szServer, // Server hostname or IP address.
            szUsername, // Username.
            szPassword, // Password.
            0, // Deprecated - UUID of previous session.
            0, // Optional - port number (0 for default).
            0, // Optional - timeout value (0 for default).
            PSL_LOW_SECURITY); // Security level

    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        printf("Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Login was successful.\n");
    // ----------------------------------------------------------------------------
    // 1. Register our event handler (OurCallback function).
    // 2. Subscribe to host machine statistics events.
    // 3. Keep receiving events until user presses <enter> key.
    // 4. Unsubscribe from statistics events.
    // 5. Un-register out event handler.
    // ----------------------------------------------------------------------------
    PrlSrv_RegEventHandler(hServer, OurCallback, NULL);
    PrlSrv_SubscribeToHostStatistics(hServer);
    char c;
    scanf(&c, 1);
    PrlSrv_UnsubscribeFromHostStatistics(hServer);
    PrlSrv_UnregEventHandler(hServer, OurCallback, NULL);
    // ----------------------------------------------------------------------------

    // Log off.
    hJob = PrlSrv_Logoff(hServer);
    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Logoff was successful.\n");

    // Free handles that are no longer required.
    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    return 0;
}


See Also

See Also
PrlStat_GetCpusStatsCount Function
See Also

PrlStat_GetCpuStat


See Also

See Also
PrlStat_GetDisksStatsCount Function
See Also

PrlStat_GetDiskStat


See Also

See Also
PrlStat_GetIfacesStatsCount Function
See Also

PrlStat_GetIfaceStat


See Also

See Also
PrlStat_GetProcsStatsCount Function
See Also

PrlStat_GetProcStat


See Also

See Also
PrlStat_GetUsersStatsCount Function
See Also

PrlStat_GetUserStat


See Also

See Also
PrlStatDisk_GetPartsStatsCount Function
See Also

PrlStatDisk_GetPartStat


Legend

Legend
PrlTypes.h
Legend
Structure


PrlTypes.h Macros

PrlTypes.h Macros
PrlTypes.h
Macros
Name | Description
PRL_ASYNC_METHOD |
PRL_ASYNC_METHOD_DECL |
PRL_ASYNC_METHOD_PTR |
PRL_ASYNC_SRV_METHOD_DECL |
PRL_FALSE |
PRL_INVALID_HANDLE |
PRL_METHOD | Default method decoration
PRL_METHOD_DECL | Default method declaration for the header files
PRL_METHOD_PTR |
PRL_NULL | NULL (invalid) handle
PRL_SRV_METHOD_DECL |
PRL_STRUCT | Default structure definition
PRL_TRUE |


PrlTypes.h Structures

PrlTypes.h Structures
PrlTypes.h Legend
Structures
Name | Description
_PRL_API_METHOD | Parallels API method
_PRL_GUID | Global unique identifier


PrlTypes.h Types

PrlTypes.h Types
PrlTypes.h
Types
Name | Description
PRL_API_METHOD_PTR |
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VOID_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_STR |
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |


See Also

See Also
PrlUsrCfg_CanChangeSrvSets Function
See Also

PrlDispCfg_CanChangeDefaultSettings

PrlDispCfg_SetCanChangeDefaultSettings


See Also

See Also
PrlUsrCfg_GetDefaultVmFolder Function
See Also

PrlUsrCfg_SetDefaultVmFolder


See Also

See Also
PrlUsrInfo_GetDefaultVmFolder Function
See Also

PrlUsrCfg_SetDefaultVmFolder


Example

Example
PrlVm_BeginEdit Function

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


Example

Example
PrlVm_Commit Function

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}


Example

Example
PrlVm_GetState Function
hJob =
PrlVm_GetState( hVm );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the handle from job
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );


Example

Example
PrlVm_GetToolsState Function

The following example illustrates how to obtain a handle of type PHT_VM_TOOLS_INFO. The hVm variable is a handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

PRL_HANDLE hJob, hResult, hVmToolsInfo;

hJob = PrlVm_GetToolsState( hVm );
PrlJob_Wait( hJob, 1000 );

PrlJob_GetResult( hJob, &hResult );
PrlHandle_Free( hJob );

PrlResult_GetParam( hJobResult, &hVmToolsInfo );
PrlHandle_Free( hJobResult );


See Also

See Also
PrlVm_LoginInGuest Function
See Also

PrlVmGuest_RunProgram

PrlVmGuest_Logout


See Also

See Also
PrlVm_Pause Function
See Also

PrlVm_Resume


Example

Example
PrlVm_Reg Function

The following example shows how to create a new virtual machine. The sample assumes that the client program has already obtained a server object handle (hServer) and performed the Parallels Service login operation.

PRL_HANDLE hVm;
PRL_HANDLE hResult;
PRL_RESULT nJobRetCode;
PRL_RESULT ret;

// Obtain a new virtual machine handle.
ret = PrlSrv_CreateVm(hServer, &hVm);
if (PRL_FAILED(ret))
{
    // Error handling goes here...
    return ret;
}

// Get the host config info.
hJob = PrlSrv_GetSrvConfig(hServer);
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlSrv_GetSrvConfig.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Get a handle to the object containing the result of PrlSrv_GetSrvConfig,
// and then get a handle to the server configuration object from it.
ret = PrlJob_GetResult(hJob, &hResult);
PRL_HANDLE hSrvCfg;
PrlResult_GetParam(hResult, &hSrvCfg);

// Delete the job and the result handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hResult);

// Now that we have the host machine configuration data,
// we can set the default configuration for the new virtual machine.
ret = PrlVm_SetDefaultConfig(
                hVm, // VM handle.
                hSrvCfg, // Host config data.
                PVS_GUEST_TYPE_WINDOWS, // Target OS type.
                PVS_GUEST_VER_WIN_2003, // Target OS version.
                PRL_TRUE); // Create and connect devices.

if (PRL_FAILED(ret))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hSrvCfg);
    PrlHandle_Free(hVm);
    return ret;
}

PrlHandle_Free(hSrvCfg);

// Set the virtual machine name.
ret = PrlVm_SetName(hVm, "My Windows Server 2003");

// The following two calls demonstrate how to modify
// some of the default values of the virtual machine configuration.
// These calls are optional. You may remove them to use the default values.

// Set the RAM size for the machine to 256 MB.
ret = PrlVm_SetRamSize(hVm, 256);

// Set the virtual hard disk size to 20 GB.
// First, get the handle to the hard disk object using the
// PrlVm_GetHardDisk function. The index of 0 is used
// because the default configuration has just one virtual hard disk.
// After that, use the handle to set the disk size to the desired value.

PRL_HANDLE hHDD;
ret = PrlVm_GetHardDisk(hVm, 0, &hHDD);
ret = PrlVmDevHd_SetDiskSize(hHDD, 20000);

// Create and register the machine with the Parallels Service.
hJob = PrlVm_Reg(hVm, // VM handle.
                 "", // VM root directory (using default).
                 PRL_TRUE); // Using non-interactive mode.

// Wait for the operation to complete.
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlVm_Reg.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Delete handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hVm);


See Also

See Also
PrlVm_StartVncServer Function
See Also

PrlVm_StopVncServer


See Also

See Also
PrlVm_StopVncServer Function
See Also

PrlVm_StartVncServer


See Also

See Also
PrlVm_SubscribeToGuestStatistics Function
See Also

PrlSrv_SubscribeToHostStatistics


See Also

See Also
PrlVm_TisGetIdentifiers Function
See Also

PrlVm_TisGetRecord


See Also

See Also
PrlVm_TisGetRecord Function
See Also

PrlVm_TisGetIdentifiers


See Also

See Also
PrlVmCfg_GetCpuUnits Function
See Also

PrlVmCfg_SetCpuUnits


See Also

See Also
PrlVmCfg_GetCustomProperty Function
See Also

PrlVmCfg_SetCustomProperty


See Also

See Also
PrlVmCfg_GetDevByType Function
See Also

PrlVmCfg_GetDevsCountByType


See Also

See Also
PrlVmCfg_GetDevsCount Function
See Also

PrlVmCfg_GetDevsList


See Also

See Also
PrlVmCfg_GetDevsCountByType Function
See Also

PrlVmCfg_GetDevByType


See Also

See Also
PrlVmCfg_GetDnsServers Function
See Also

PrlVmCfg_SetDnsServers


See Also

See Also
PrlVmCfg_GetGenericPciDev Function
See Also

PrlVmCfg_GetGenericPciDevsCount


See Also

See Also
PrlVmCfg_GetGenericPciDevsCount Function
See Also

PrlVmCfg_GetGenericPciDev


See Also

See Also
PrlVmCfg_GetGenericScsiDev Function
See Also

PrlVmCfg_GetGenericScsiDevsCount


See Also

See Also
PrlVmCfg_GetGenericScsiDevsCount Function
See Also

PrlVmCfg_GetGenericScsiDev


See Also

See Also
PrlVmCfg_GetSearchDomains Function
See Also

PrlVmCfg_SetSearchDomains


See Also

See Also
PrlVmCfg_IsDiskCacheWriteBack Function
See Also

PrlVmCfg_SetDiskCacheWriteBack


See Also

See Also
PrlVmCfg_SetCpuUnits Function
See Also

PrlVmCfg_GetCpuUnits


See Also

See Also
PrlVmCfg_SetDnsServers Function
See Also

PrlVmCfg_GetDnsServers


See Also

See Also
PrlVmCfg_SetSearchDomains Function
See Also

PrlVmCfg_GetSearchDomains


See Also

See Also
PrlVmDev_GetDescription Function
See Also

PrlVmDev_SetDescription


See Also

See Also
PrlVmDev_SetDescription Function
See Also

PrlVmDev_GetDescription


See Also

See Also
PrlVmDevHd_GetDiskSize Function
See Also

PrlVmDevHd_SetDiskSize


See Also

See Also
PrlVmDevHd_GetDiskType Function
See Also

PrlVmDevHd_SetDiskType


See Also

See Also
PrlVmDevHd_GetPartition Function
See Also

PrlVmDevHd_GetPartitionsCount


See Also

See Also
PrlVmDevHd_GetPartitionsCount Function
See Also

PrlVmDevHd_GetPartition


See Also

See Also
PrlVmDevHd_IsSplitted Function
See Also

PrlVmDevHd_SetSplitted


See Also

See Also
PrlVmDevHd_SetDiskSize Function
See Also

PrlVmDevHd_GetDiskSize


See Also

See Also
PrlVmDevHd_SetDiskType Function
See Also

PrlVmDevHd_GetDiskType


See Also

See Also
PrlVmDevHd_SetSplitted Function
See Also

PrlVmDevHd_IsSplitted


See Also

See Also
PrlVmDevHdPart_GetSysName Function
See Also

PrlVmDevHdPart_SetSysName


See Also

See Also
PrlVmDevHdPart_SetSysName Function
See Also

PrlVmDevHdPart_GetSysName


See Also

See Also
PrlVmDevNet_GetBoundAdapterIndex Function
See Also

PrlVmDevNet_SetBoundAdapterIndex


See Also

See Also
PrlVmDevNet_GetBoundAdapterName Function
See Also

PrlVmDevNet_SetBoundAdapterName


See Also

See Also
PrlVmDevNet_GetDefaultGateway Function
See Also

PrlVmDevNet_SetDefaultGateway


See Also

See Also
PrlVmDevNet_GetDnsServers Function
See Also

PrlVmDevNet_SetDnsServers


See Also

See Also
PrlVmDevNet_GetMacAddress Function
See Also

PrlVmDevNet_SetMacAddress


See Also

See Also
PrlVmDevNet_GetNetAddresses Function
See Also

PrlVmDevNet_SetNetAddresses


See Also

See Also
PrlVmDevNet_GetSearchDomains Function
See Also

PrlVmDevNet_SetSearchDomains


See Also

See Also
PrlVmDevNet_SetBoundAdapterIndex Function
See Also

PrlVmDevNet_GetBoundAdapterIndex


See Also

See Also
PrlVmDevNet_SetBoundAdapterName Function
See Also

PrlVmDevNet_GetBoundAdapterName


See Also

See Also
PrlVmDevNet_SetDefaultGateway Function
See Also

PrlVmDevNet_GetDefaultGateway


See Also

See Also
PrlVmDevNet_SetDnsServers Function
See Also

PrlVmDevNet_GetIPAddress


See Also

See Also
PrlVmDevNet_SetMacAddress Function
See Also

PrlVmDevNet_GetMacAddress


See Also

See Also
PrlVmDevNet_SetNetAddresses Function
See Also

PrlVmDevNet_GetIPAddress


See Also

See Also
PrlVmDevNet_SetSearchDomains Function
See Also

PrlVmDevNet_GetIPAddress


See Also

See Also
PrlVmDevSerial_GetSocketMode Function
See Also

PrlVmDevSerial_SetSocketMode


See Also

See Also
PrlVmDevSerial_SetSocketMode Function
See Also

PrlVmDevSerial_GetSocketMode


See Also

See Also
PrlVmDevSound_GetMixerDev Function
See Also

PrlVmDevSound_SetMixerDev


See Also

See Also
PrlVmDevSound_GetOutputDev Function
See Also

PrlVmDevSound_SetOutputDev


See Also

See Also
PrlVmDevSound_SetMixerDev Function
See Also

PrlVmDevSound_GetMixerDev


See Also

See Also
PrlVmDevSound_SetOutputDev Function
See Also

PrlVmDevSound_GetOutputDev


See Also

See Also
PrlVmDevUsb_GetAutoconnectOption Function
See Also

PrlVmDevUsb_SetAutoconnectOption


See Also

See Also
PrlVmDevUsb_SetAutoconnectOption Function
See Also

PrlVmDevUsb_GetAutoconnectOption


See Also

See Also
PrlVmGuest_Logout Function
See Also

PrlVm_LoginInGuest


See Also

See Also
PrlVmGuest_SetUserPasswd Function
See Also

PrlVm_LoginInGuest


See Also

See Also
PrlVmInfo_IsVncServerStarted Function
See Also

PrlVm_StartVncServer

PrlVm_StopVncServer


PVS_GUEST Macros Macros

PVS_GUEST Macros Macros
PVS_GUEST Macros
Macros
Name | Description
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_XP |


Topics

Topics
Remote Desktop Access
Topics
Name | Description
Primary Display Capture | Functions in this group provide functionality for capturing screen shots of a remote virtual machine desktop.
Secondary Display Capture | Functions in this group provide functionality for capturing screen shots of a secondary display if one is installed in a virtual machine.
Keyboard Control | Functions in this group provide functionality for sending keyboard commands to a remote virtual machine.
Mouse Control | Functions in this group provide functionality for sending mouse commands to a remote virtual machine.


Secondary Display Capture Functions

Secondary Display Capture Functions
Secondary Display Capture Legend
Functions
Name | Description
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the secondary display of the guest OS to specified values.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.


Legend

Legend
Secondary Display Capture
Legend
Method


System Functions Functions

System Functions Functions
System Functions Legend
Functions
Name | Description
PrlApi_AddRemoteDevCommandBuffer | Adds buffer to the remote command.
PrlApi_AddRemoteDevCommandParam | Adds unsigned int parameter to the command.
PrlApi_CreateHandlesList | Creates SDK object represents handles list
PrlApi_CreateRemoteCommand |
PrlApi_CreateRemoteDevCommand | Creates command to the remote device.
PrlApi_CreateStringsList | Creates a handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendRemoteCommand |
PrlApi_SendRemoteDeviceCommand | Sends remote device command to the Virtual Machine.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.


Legend

Legend
System Functions
Legend
Method


Virtual Device Functions Functions

Virtual Device Functions Functions
Virtual Device Functions Legend
Functions
Name | Description
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSysName | Sets virtual device system name.


Legend

Legend
Virtual Device Functions
Legend
Method


_VIRTUAL_MACHINE_STATE Enumeration

_VIRTUAL_MACHINE_STATE Enumeration
PrlEnums.h Other Structs Send Feedback

Virtual machine states enumeration

Syntax
enum _VIRTUAL_MACHINE_STATE {
  VMS_UNKNOWN = 0,
  VMS_STOPPED = 0x30000001,
  VMS_STARTING = 0x30000002,
  VMS_RESTORING = 0x30000003,
  VMS_RUNNING = 0x30000004,
  VMS_PAUSED = 0x30000005,
  VMS_SUSPENDING = 0x30000006,
  VMS_STOPPING = 0x30000007,
  VMS_COMPACTING = 0x30000008,
  VMS_SUSPENDED = 0x30000009,
  VMS_SNAPSHOTING = 0x3000000A,
  VMS_RESETTING = 0x3000000B,
  VMS_PAUSING = 0x3000000C,
  VMS_CONTINUING = 0x3000000D,
  VMS_MIGRATING = 0x3000000E,
  VMS_DELETING_STATE = 0x3000000F,
  VMS_RESUMING = 0x30000010
};
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


Contents

Contents
Introduction
About This Guide
Organization of This Guide
How to Use This Guide
Functions by Handle
PHT_ACCESS_RIGHTS
PHT_BOOT_DEVICE
PHT_DISP_CONFIG
PHT_DISP_NET_ADAPTER
PHT_EVENT
PHT_EVENT_PARAMETER
PHT_FOUND_VM_INFO
PHT_HW_GENERIC_DEVICE
PHT_HW_HARD_DISK
PHT_HW_HARD_DISK_PARTITION
PHT_HW_NET_ADAPTER
PHT_JOB
PHT_LICENSE
PHT_LOGIN_RESPONSE
PHT_NET_SERVICE_STATUS
PHT_PORT_FORWARDING
PHT_REMOTE_FILESYSTEM_ENTRY
PHT_REMOTE_FILESYSTEM_INFO
PHT_RESULT
PHT_RUNNING_TASK
PHT_SERVER
PHT_SERVER_CONFIG
PHT_SERVER_INFO
PHT_SHARE
PHT_STRINGS_LIST
PHT_SYSTEM_STATISTICS
PHT_SYSTEM_STATISTICS_CPU
PHT_SYSTEM_STATISTICS_DISK
PHT_SYSTEM_STATISTICS_DISK_PARTITION
PHT_SYSTEM_STATISTICS_IFACE
PHT_SYSTEM_STATISTICS_PROCESS
PHT_SYSTEM_STATISTICS_USER_SESSION
PHT_USER_INFO
PHT_USER_PROFILE
PHT_VIRTUAL_DEV_FLOPPY
PHT_VIRTUAL_DEV_HARD_DISK
PHT_VIRTUAL_DEV_HD_PARTITION
PHT_VIRTUAL_DEV_NET_ADAPTER
PHT_VIRTUAL_DEV_OPTICAL_DISK
PHT_VIRTUAL_DEV_PARALLEL_PORT
PHT_VIRTUAL_DEV_SERIAL_PORT
PHT_VIRTUAL_DEV_SOUND
PHT_VIRTUAL_DEV_USB_DEVICE
PHT_VIRTUAL_DISK
PHT_VIRTUAL_MACHINE
PHT_VIRTUAL_NETWORK
PHT_VM_CONFIGURATION
PHT_VM_GUEST_SESSION
PHT_VM_INFO
PHT_VM_TOOLS_INFO
Common Functions
System Functions
API Debug Functions
Handle Functions
Virtual Device Functions
PrlBuffer
Remote Desktop Access
Primary Display Capture
Secondary Display Capture
Keyboard Control
Mouse Control
Callback Prototypes
PRL_DISK_CALLBACK
PRL_EVENT_HANDLER_PTR
PRL_STATES_CALLBACK
Types
PRL_BOOL Types
PRL_CHAR Types
PRL_CONST Types
PRL_DEVICE Types
PRL_DISK Types
PRL_FILE Types
PRL_INT Types
PRL_IO Types
PRL_TIS Types
PRL_TOOLS Types
PRL_UINT Types
PRL_VM Types
PRL_VOID Types
Other Types
Structs, Records, Enums
PRL_IO Structs
PRL_VM Structs
Other Structs
Macros
GUI_ERR Macros
PET Macros
PRL_DISK Macros
PRL_ERR Macros
PRL_SCAN_CODE Macros
PVS_GUEST Macros
Other Macros
Files
PrlErrorsValues.h


event_type_to_string Function

event_type_to_string Function
PrlApi.h API Debug Functions Send Feedback

This inline function returns a readable string representation of the specified event type.

Syntax
inline const char * event_type_to_string(
    PRL_EVENT_TYPE value
);
File

PrlApi.h

Parameters

value
The event type.

Links
PrlApi.h, API Debug Functions


FROM_PARALLELS_API_VER Macro

FROM_PARALLELS_API_VER Macro
PrlApi.h Other Macros Send Feedback
Syntax
#define FROM_PARALLELS_API_VER(version, majorV, minorV) \
     majorV = ((PRL_UINT32)version) >> 16; \
     minorV = ((PRL_UINT32)version) & 0x0000FFFF
File

PrlApi.h

Links
PrlApi.h, Other Macros


FS_PERM_EXECUTE Macro

FS_PERM_EXECUTE Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define FS_PERM_EXECUTE 0x1
File

PrlFs.h

Links
PrlFs.h, Other Macros


FS_PERM_READ Macro

FS_PERM_READ Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define FS_PERM_READ 0x2
File

PrlFs.h

Links
PrlFs.h, Other Macros


FS_PERM_WRITE Macro

FS_PERM_WRITE Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define FS_PERM_WRITE 0x4
File

PrlFs.h

Links
PrlFs.h, Other Macros


GUI_ERR_CANT_ADD_PCI_INSTANTLY Macro

GUI_ERR_CANT_ADD_PCI_INSTANTLY Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
  • Gui messages

+++ ALIGNED VALUE TO 15000

Syntax
#define GUI_ERR_CANT_ADD_PCI_INSTANTLY PRL_RESULT_DECLARE_SUCCESS(15000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION Macro

GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION PRL_RESULT_DECLARE_SUCCESS(15038)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_CANT_CHANGE_SHARED_FOLDER Macro

GUI_ERR_CANT_CHANGE_SHARED_FOLDER Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_CANT_CHANGE_SHARED_FOLDER PRL_RESULT_DECLARE_SUCCESS(15036)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_CANT_CLONE_SUSPENDED_VM Macro

GUI_ERR_CANT_CLONE_SUSPENDED_VM Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_CANT_CLONE_SUSPENDED_VM PRL_RESULT_DECLARE_SUCCESS(15033)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED Macro

GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED PRL_RESULT_DECLARE_ERROR(15042)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST Macro

GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_SUCCESS(15068)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_END_IP Macro

GUI_ERR_DHCP_INCORRECT_END_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_INCORRECT_END_IP PRL_RESULT_DECLARE_SUCCESS(15048)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_MASK_IP Macro

GUI_ERR_DHCP_INCORRECT_MASK_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_INCORRECT_MASK_IP PRL_RESULT_DECLARE_SUCCESS(15049)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_INCORRECT_START_IP Macro

GUI_ERR_DHCP_INCORRECT_START_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_INCORRECT_START_IP PRL_RESULT_DECLARE_SUCCESS(15047)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET Macro

GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET PRL_RESULT_DECLARE_SUCCESS(15056)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP Macro

GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP PRL_RESULT_DECLARE_SUCCESS(15055)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP PRL_RESULT_DECLARE_SUCCESS(15051)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP PRL_RESULT_DECLARE_SUCCESS(15052)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP Macro

GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP PRL_RESULT_DECLARE_SUCCESS(15050)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP Macro

GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP PRL_RESULT_DECLARE_SUCCESS(15054)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP Macro

GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP PRL_RESULT_DECLARE_SUCCESS(15053)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_IMAGE_PATH_NOT_SPECIFIED Macro

GUI_ERR_IMAGE_PATH_NOT_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_IMAGE_PATH_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15028)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INCORRECT_SHARED_FOLDER_NAME Macro

GUI_ERR_INCORRECT_SHARED_FOLDER_NAME Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INCORRECT_SHARED_FOLDER_NAME PRL_RESULT_DECLARE_SUCCESS(15044)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INCORRECT_SHARED_FOLDER_PATH Macro

GUI_ERR_INCORRECT_SHARED_FOLDER_PATH Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INCORRECT_SHARED_FOLDER_PATH PRL_RESULT_DECLARE_SUCCESS(15064)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INVALID_MAC_ADDRESS Macro

GUI_ERR_INVALID_MAC_ADDRESS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INVALID_MAC_ADDRESS PRL_RESULT_DECLARE_SUCCESS(15060)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INVALID_OUTPUT_PATH Macro

GUI_ERR_INVALID_OUTPUT_PATH Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INVALID_OUTPUT_PATH PRL_RESULT_DECLARE_SUCCESS(15026)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INVALID_SHARED_FOLDER_PATH Macro

GUI_ERR_INVALID_SHARED_FOLDER_PATH Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INVALID_SHARED_FOLDER_PATH PRL_RESULT_DECLARE_SUCCESS(15035)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_INVALID_VM_NAME_SPECIFIED Macro

GUI_ERR_INVALID_VM_NAME_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_INVALID_VM_NAME_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15045)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS Macro

GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS PRL_RESULT_DECLARE_SUCCESS(15039)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH Macro

GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH PRL_RESULT_DECLARE_SUCCESS(15040)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE Macro

GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE PRL_RESULT_DECLARE_SUCCESS(15041)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID Macro

GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID PRL_RESULT_DECLARE_SUCCESS(15091)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR Macro

GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR PRL_RESULT_DECLARE_SUCCESS(15090)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE Macro

GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE PRL_RESULT_DECLARE_SUCCESS(15089)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED Macro

GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15030)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE Macro

GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE PRL_RESULT_DECLARE_SUCCESS(15097)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SERVER_CUSTOM_NAME_EMPTY Macro

GUI_ERR_SERVER_CUSTOM_NAME_EMPTY Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SERVER_CUSTOM_NAME_EMPTY PRL_RESULT_DECLARE_SUCCESS(15031)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SERVER_CUSTOM_NAME_EXISTS Macro

GUI_ERR_SERVER_CUSTOM_NAME_EXISTS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SERVER_CUSTOM_NAME_EXISTS PRL_RESULT_DECLARE_SUCCESS(15027)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SERVER_WRONG_CUSTOM_NAME Macro

GUI_ERR_SERVER_WRONG_CUSTOM_NAME Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SERVER_WRONG_CUSTOM_NAME PRL_RESULT_DECLARE_SUCCESS(15037)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_EXISTS Macro

GUI_ERR_SHARED_FOLDER_NAME_EXISTS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_EXISTS PRL_RESULT_DECLARE_SUCCESS(15017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED Macro

GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15062)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM Macro

GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM PRL_RESULT_DECLARE_SUCCESS(15046)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_PATH_EXISTS Macro

GUI_ERR_SHARED_FOLDER_PATH_EXISTS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHARED_FOLDER_PATH_EXISTS PRL_RESULT_DECLARE_SUCCESS(15018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED Macro

GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15063)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS Macro

GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS PRL_RESULT_DECLARE_SUCCESS(15024)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP Macro

GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_SUCCESS(15073)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SNAPSHOT_VM_WITH_VTD Macro

GUI_ERR_SNAPSHOT_VM_WITH_VTD Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SNAPSHOT_VM_WITH_VTD PRL_RESULT_DECLARE_SUCCESS(15094)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SOCKET_NOT_SPECIFIED Macro

GUI_ERR_SOCKET_NOT_SPECIFIED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SOCKET_NOT_SPECIFIED PRL_RESULT_DECLARE_SUCCESS(15029)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST Macro

GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_SUCCESS(15095)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro

GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL PRL_RESULT_DECLARE_SUCCESS(15096)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT Macro

GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT PRL_RESULT_DECLARE_SUCCESS(15082)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR Macro

GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR PRL_RESULT_DECLARE_SUCCESS(15081)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT Macro

GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT PRL_RESULT_DECLARE_SUCCESS(15086)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR Macro

GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR PRL_RESULT_DECLARE_SUCCESS(15085)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_ERR_WRONG_NUMBER_OF_CPU Macro

GUI_ERR_WRONG_NUMBER_OF_CPU Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_ERR_WRONG_NUMBER_OF_CPU PRL_RESULT_DECLARE_ERROR(15020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_CANT_DISPLAY_HELP_TOPIC Macro

GUI_INFO_CANT_DISPLAY_HELP_TOPIC Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_CANT_DISPLAY_HELP_TOPIC PRL_RESULT_DECLARE_SUCCESS(15043)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD Macro

GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD PRL_RESULT_DECLARE_SUCCESS(15019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD Macro

GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD PRL_RESULT_DECLARE_SUCCESS(15066)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_LIN Macro

GUI_INFO_INSTALL_TOOLS_LIN Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_INSTALL_TOOLS_LIN PRL_RESULT_DECLARE_SUCCESS(15023)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_MAC Macro

GUI_INFO_INSTALL_TOOLS_MAC Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_INSTALL_TOOLS_MAC PRL_RESULT_DECLARE_SUCCESS(15022)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_INSTALL_TOOLS_WIN Macro

GUI_INFO_INSTALL_TOOLS_WIN Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_INSTALL_TOOLS_WIN PRL_RESULT_DECLARE_SUCCESS(15021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED Macro

GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED PRL_RESULT_DECLARE_SUCCESS(15092)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_RUN_COMPRESSOR_WIN Macro

GUI_INFO_RUN_COMPRESSOR_WIN Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_RUN_COMPRESSOR_WIN PRL_RESULT_DECLARE_SUCCESS(15067)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_SERVER_RESTART_IS_NEEDED Macro

GUI_INFO_SERVER_RESTART_IS_NEEDED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_SERVER_RESTART_IS_NEEDED PRL_RESULT_DECLARE_SUCCESS(15034)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_SWITCH_TO_FULLSCREEN Macro

GUI_INFO_SWITCH_TO_FULLSCREEN Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_SWITCH_TO_FULLSCREEN PRL_RESULT_DECLARE_SUCCESS(15065)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_TOOLS_INSTALL_OTHER Macro

GUI_INFO_TOOLS_INSTALL_OTHER Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_TOOLS_INSTALL_OTHER PRL_RESULT_DECLARE_SUCCESS(15075)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_VM_HW_UPGRADE_COMPLETED Macro

GUI_INFO_VM_HW_UPGRADE_COMPLETED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_VM_HW_UPGRADE_COMPLETED PRL_RESULT_DECLARE_SUCCESS(15080)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED Macro

GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED PRL_RESULT_DECLARE_SUCCESS(15084)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_INFO_VM_SHUTDOWN_CONDITIONS Macro

GUI_INFO_VM_SHUTDOWN_CONDITIONS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_INFO_VM_SHUTDOWN_CONDITIONS PRL_RESULT_DECLARE_SUCCESS(15025)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro

GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback

GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION not used now

Syntax
#define GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION PRL_RESULT_DECLARE_SUCCESS(15057)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_CANCEL_DEPLOY_OPERATION Macro

GUI_QUESTION_CANCEL_DEPLOY_OPERATION Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback

GUI_QUESTION_CANCEL_DEPLOY_OPERATION not used now

Syntax
#define GUI_QUESTION_CANCEL_DEPLOY_OPERATION PRL_RESULT_DECLARE_SUCCESS(14010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST Macro

GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST PRL_RESULT_DECLARE_SUCCESS(15061)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_COHERENCE_NOTIFICATION Macro

GUI_QUESTION_COHERENCE_NOTIFICATION Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_COHERENCE_NOTIFICATION PRL_RESULT_DECLARE_SUCCESS(15077)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE Macro

GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE PRL_RESULT_DECLARE_SUCCESS(14011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME Macro

GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME PRL_RESULT_DECLARE_SUCCESS(14020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR Macro

GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR PRL_RESULT_DECLARE_SUCCESS(15058)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS Macro

GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS PRL_RESULT_DECLARE_SUCCESS(15059)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_EDIT_SUSPENDED_VM Macro

GUI_QUESTION_EDIT_SUSPENDED_VM Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_EDIT_SUSPENDED_VM PRL_RESULT_DECLARE_SUCCESS(15093)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING Macro

GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING PRL_RESULT_DECLARE_SUCCESS(14013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING Macro

GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING PRL_RESULT_DECLARE_SUCCESS(14014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP Macro

GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP PRL_RESULT_DECLARE_SUCCESS(14017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING Macro

GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING PRL_RESULT_DECLARE_SUCCESS(15078)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY Macro

GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY PRL_RESULT_DECLARE_SUCCESS(15087)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_LOST_TASK_CONTINUE Macro

GUI_QUESTION_LOST_TASK_CONTINUE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_LOST_TASK_CONTINUE PRL_RESULT_DECLARE_SUCCESS(14012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE Macro

GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE PRL_RESULT_DECLARE_SUCCESS(14018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER Macro

GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER PRL_RESULT_DECLARE_SUCCESS(14019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_OVERWRITE_HDD_IMAGE Macro

GUI_QUESTION_OVERWRITE_HDD_IMAGE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_OVERWRITE_HDD_IMAGE PRL_RESULT_DECLARE_SUCCESS(14008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_REMOVE_SERVER_FROM_LIST Macro

GUI_QUESTION_REMOVE_SERVER_FROM_LIST Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_REMOVE_SERVER_FROM_LIST PRL_RESULT_DECLARE_SUCCESS(14009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT Macro

GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT Macro

GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT PRL_RESULT_DECLARE_SUCCESS(14015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST Macro

GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST PRL_RESULT_DECLARE_SUCCESS(15071)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WNG_AUTOCONNECT_HID_USB_DEVICE Macro

GUI_WNG_AUTOCONNECT_HID_USB_DEVICE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WNG_AUTOCONNECT_HID_USB_DEVICE PRL_RESULT_DECLARE_SUCCESS(15070)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WNG_CONNECT_HID_USB_DEVICE Macro

GUI_WNG_CONNECT_HID_USB_DEVICE Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WNG_CONNECT_HID_USB_DEVICE PRL_RESULT_DECLARE_SUCCESS(15069)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WNG_STOP_VM_WITH_BOOTCAMP Macro

GUI_WNG_STOP_VM_WITH_BOOTCAMP Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WNG_STOP_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_SUCCESS(15072)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WRN_SNAPSHOT_NAME_IS_EMPTY Macro

GUI_WRN_SNAPSHOT_NAME_IS_EMPTY Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WRN_SNAPSHOT_NAME_IS_EMPTY PRL_RESULT_DECLARE_SUCCESS(15083)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW Macro

GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW PRL_RESULT_DECLARE_SUCCESS(15074)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS Macro

GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS PRL_RESULT_DECLARE_SUCCESS(15079)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS Macro

GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS Macro
PrlErrorsValues.h GUI_ERR Macros Send Feedback
Syntax
#define GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS PRL_RESULT_DECLARE_SUCCESS(15088)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, GUI_ERR Macros


handle_type_to_string Function

handle_type_to_string Function
PrlApi.h API Debug Functions Send Feedback

This inline function returns a readable string representation of the specified handle type.

Syntax
inline const char * handle_type_to_string(
    PRL_HANDLE_TYPE value
);
File

PrlApi.h

Parameters

value
The handle type.

Links
PrlApi.h, API Debug Functions


Index

Index
_ | A | C | E | F | G | H | I | K | M | O | P | R | S | T | V | W
_
__PRL_DISK_PARAMETERS
__PRL_DISK_PARAMETERS structure
__PRL_IMAGE_PARAMETERS
__PRL_IMAGE_PARAMETERS structure
__PRL_SNAPSHOT_ELEMENT
__PRL_SNAPSHOT_ELEMENT structure
_PRL_ALLOWED_VM_COMMAND
_PRL_ALLOWED_VM_COMMAND enumeration
_PRL_API_METHOD
_PRL_API_METHOD structure
_PRL_APP_IN_DOCK_MODE
_PRL_APP_IN_DOCK_MODE enumeration
_PRL_APPLICATION_MODE
_PRL_APPLICATION_MODE enumeration
_PRL_CPU_HVT
_PRL_CPU_HVT enumeration
_PRL_CPU_MODE
_PRL_CPU_MODE enumeration
_PRL_DEVICE_ACTION
_PRL_DEVICE_ACTION enumeration
_PRL_DEVICE_TYPE
_PRL_DEVICE_TYPE enumeration
_PRL_DISPLAY_CODEC_COMPRESSION
_PRL_DISPLAY_CODEC_COMPRESSION enumeration
_PRL_DISPLAY_CODEC_QUALITY
_PRL_DISPLAY_CODEC_QUALITY enumeration
_PRL_DISPLAY_CODEC_TYPE
_PRL_DISPLAY_CODEC_TYPE enumeration
_PRL_DOCK_ICON_TYPE
_PRL_DOCK_ICON_TYPE enumeration
_PRL_EVENT_ISSUER_TYPE
_PRL_EVENT_ISSUER_TYPE enumeration
_PRL_FILE_SYSTEM_ELEMENT_TYPE
_PRL_FILE_SYSTEM_ELEMENT_TYPE enumeration
_PRL_FILE_SYSTEM_FS_TYPE
_PRL_FILE_SYSTEM_FS_TYPE enumeration
_PRL_FILE_SYSTEM_TYPE
_PRL_FILE_SYSTEM_TYPE enumeration
_PRL_GRACEFUL_SHUTDOWN_KIND
_PRL_GRACEFUL_SHUTDOWN_KIND enumeration
_PRL_GUEST_DISTRO_VERSION_ENUM
_PRL_GUEST_DISTRO_VERSION_ENUM enumeration
_PRL_GUID
_PRL_GUID structure
_PRL_HANDLE_TYPE
_PRL_HANDLE_TYPE enumeration
_PRL_HARD_DISK_INTERNAL_FORMAT
_PRL_HARD_DISK_INTERNAL_FORMAT enumeration
_PRL_HOST_OS_TYPE
_PRL_HOST_OS_TYPE enumeration
_PRL_HW_INFO_NET_ADAPTER_TYPE
_PRL_HW_INFO_NET_ADAPTER_TYPE enumeration
_PRL_IMAGE_FORMAT
_PRL_IMAGE_FORMAT enumeration
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_REQUEST structure
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_ATTACH_RESPONSE structure
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_REQUEST structure
_PRL_IO_AUTH_RESPONSE
_PRL_IO_AUTH_RESPONSE structure
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DESKTOP_UTILITIES_STATE structure
_PRL_IO_DEVICE_USED
_PRL_IO_DEVICE_USED structure
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_PALETTE structure
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_REGION structure
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DISPLAY_SCREEN_SIZE structure
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_DYNRES_TOOLS_STATUS structure
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_REQUEST structure
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_ENCODING_RESPONSE structure
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GENERIC_BUFFER structure
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GRACEFUL_SHUTDOWN structure
_PRL_IO_GUEST_SCREENSAVER_STATE
_PRL_IO_GUEST_SCREENSAVER_STATE structure
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_LEDS structure
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_KEYBOARD_SCANCODE structure
_PRL_IO_MEMORY_INFO
_PRL_IO_MEMORY_INFO structure
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_CURSOR structure
_PRL_IO_MOUSE_EVENT
_PRL_IO_MOUSE_EVENT structure
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_BUFFER_REGION structure
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_REGION structure
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SIZE structure
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_SURFACE structure
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SCREEN_UPDATE structure
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SET_TASKBAR_VISIBILITY structure
_PRL_IO_SLIDING_MOUSE
_PRL_IO_SLIDING_MOUSE structure
_PRL_IO_STATE
_PRL_IO_STATE enumeration
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_MOVE_TASKBAR structure
_PRL_IO_TOOLS_SIA_DATA
_PRL_IO_TOOLS_SIA_DATA structure
_PRL_IO_TOOLS_UTILITY_COMMAND
_PRL_IO_TOOLS_UTILITY_COMMAND structure
_PRL_JOB_OPERATION_CODE
_PRL_JOB_OPERATION_CODE enumeration
_PRL_JOB_STATUS
_PRL_JOB_STATUS enumeration
_PRL_KEY_EVENT
_PRL_KEY_EVENT enumeration
_PRL_MASS_STORAGE_INTERFACE_TYPE
_PRL_MASS_STORAGE_INTERFACE_TYPE enumeration
_PRL_MESSAGE_TYPE_ENUM
_PRL_MESSAGE_TYPE_ENUM enumeration
_PRL_MOUSE_BUTTON
_PRL_MOUSE_BUTTON enumeration
_PRL_NET_ADAPTER_EMULATED_TYPE
_PRL_NET_ADAPTER_EMULATED_TYPE enumeration
_PRL_NET_VIRTUAL_NETWORK_TYPE
_PRL_NET_VIRTUAL_NETWORK_TYPE enumeration
_PRL_PARAM_FIELD_DATA_TYPE
_PRL_PARAM_FIELD_DATA_TYPE enumeration
_PRL_PORT_FORWARDING_TYPE
_PRL_PORT_FORWARDING_TYPE enumeration
_PRL_PROCESS_STATE_TYPE
_PRL_PROCESS_STATE_TYPE enumeration
_PRL_PRODUCT_ENUM
_PRL_PRODUCT_ENUM enumeration
_PRL_RUNNING_TASK_TYPE_ENUM
_PRL_RUNNING_TASK_TYPE_ENUM enumeration
_PRL_SECURITY_LEVEL
_PRL_SECURITY_LEVEL enumeration
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE enumeration
_PRL_SERVICE_STATUS_ENUM
_PRL_SERVICE_STATUS_ENUM enumeration
_PRL_TIS_INT_VERSION
_PRL_TIS_INT_VERSION structure
_PRL_TIS_RECORD_ACTION
_PRL_TIS_RECORD_ACTION enumeration
_PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO structure
_PRL_TIS_RECORD_STATE
_PRL_TIS_RECORD_STATE enumeration
_PRL_TIS_VERSION
_PRL_TIS_VERSION structure
_PRL_TOOLS_SIA_OPEN_IN_TYPES
_PRL_TOOLS_SIA_OPEN_IN_TYPES enumeration
_PRL_TOOLS_UTILITY_COMMAND_FLAG
_PRL_TOOLS_UTILITY_COMMAND_FLAG enumeration
_PRL_TOOLS_UTILITY_COMMAND_ID
_PRL_TOOLS_UTILITY_COMMAND_ID enumeration
_PRL_UNDO_DISKS_MODE
_PRL_UNDO_DISKS_MODE enumeration
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION enumeration
_PRL_USB_DEVICE_CONNECT_REASON
_PRL_USB_DEVICE_CONNECT_REASON enumeration
_PRL_VERSION_ENUM
_PRL_VERSION_ENUM enumeration
_PRL_VM_ACCELERATION_LEVEL
_PRL_VM_ACCELERATION_LEVEL enumeration
_PRL_VM_ACCESS_FOR_OTHERS
_PRL_VM_ACCESS_FOR_OTHERS enumeration
_PRL_VM_ACTION_ON_WINDOW_CLOSE
_PRL_VM_ACTION_ON_WINDOW_CLOSE enumeration
_PRL_VM_AUTOSTART_OPTION
_PRL_VM_AUTOSTART_OPTION enumeration
_PRL_VM_AUTOSTOP_OPTION
_PRL_VM_AUTOSTOP_OPTION enumeration
_PRL_VM_BOOT_ORDER
_PRL_VM_BOOT_ORDER enumeration
_PRL_VM_CONFIG_SECTIONS
_PRL_VM_CONFIG_SECTIONS enumeration
_PRL_VM_DEV_EMULATION_TYPE
_PRL_VM_DEV_EMULATION_TYPE enumeration
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR enumeration
_PRL_VM_EXEC_RUN_PROGRAM_MODES
_PRL_VM_EXEC_RUN_PROGRAM_MODES enumeration
_PRL_VM_MIGRATION_SECURITY_LEVEL
_PRL_VM_MIGRATION_SECURITY_LEVEL enumeration
_PRL_VM_MIGRATION_TYPE
_PRL_VM_MIGRATION_TYPE enumeration
_PRL_VM_PRIORITY
_PRL_VM_PRIORITY enumeration
_PRL_VM_REMOTE_DISPLAY_MODE
_PRL_VM_REMOTE_DISPLAY_MODE enumeration
_PRL_VM_START_LOGIN_MODE
_PRL_VM_START_LOGIN_MODE enumeration
_PRL_VM_START_MODE
_PRL_VM_START_MODE enumeration
_PRL_VM_TOOLS_STATE
_PRL_VM_TOOLS_STATE enumeration
_PRL_VM_WINDOW_MODE
_PRL_VM_WINDOW_MODE enumeration
_PRL_WINDOW_EDGE_MASK
_PRL_WINDOW_EDGE_MASK enumeration
_VIRTUAL_MACHINE_STATE
_VIRTUAL_MACHINE_STATE enumeration
A
About This Guide
API Debug Functions
C
Callback Prototypes
Common Functions
E
event_type_to_string
event_type_to_string function
F
Files
FROM_PARALLELS_API_VER
FROM_PARALLELS_API_VER macro
FS_PERM_EXECUTE
FS_PERM_EXECUTE macro
FS_PERM_READ
FS_PERM_READ macro
FS_PERM_WRITE
FS_PERM_WRITE macro
Functions by Handle
G
GUI_ERR Macros
GUI_ERR_CANT_ADD_PCI_INSTANTLY
GUI_ERR_CANT_ADD_PCI_INSTANTLY macro
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION
GUI_ERR_CANT_CHANGE_CLIENT_CDROM_CONNECT_OPTION macro
GUI_ERR_CANT_CHANGE_SHARED_FOLDER
GUI_ERR_CANT_CHANGE_SHARED_FOLDER macro
GUI_ERR_CANT_CLONE_SUSPENDED_VM
GUI_ERR_CANT_CLONE_SUSPENDED_VM macro
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED
GUI_ERR_CANT_SAVE_CONFIG_AS_VM_WAS_DELETED macro
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST
GUI_ERR_COMPRESSOR_UNSUPPORTED_GUEST macro
GUI_ERR_DHCP_INCORRECT_END_IP
GUI_ERR_DHCP_INCORRECT_END_IP macro
GUI_ERR_DHCP_INCORRECT_MASK_IP
GUI_ERR_DHCP_INCORRECT_MASK_IP macro
GUI_ERR_DHCP_INCORRECT_START_IP
GUI_ERR_DHCP_INCORRECT_START_IP macro
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET
GUI_ERR_DHCP_SCOPE_END_OUT_OF_SUBNET macro
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP
GUI_ERR_DHCP_START_IP_IS_LESS_THAN_END_IP macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_END_IP macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_MASK_IP macro
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_FIRST_OCTET_IN_START_IP macro
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_END_IP macro
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP
GUI_ERR_DHCP_ZERO_LAST_OCTET_IN_START_IP macro
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED
GUI_ERR_IMAGE_PATH_NOT_SPECIFIED macro
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME
GUI_ERR_INCORRECT_SHARED_FOLDER_NAME macro
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH
GUI_ERR_INCORRECT_SHARED_FOLDER_PATH macro
GUI_ERR_INVALID_MAC_ADDRESS
GUI_ERR_INVALID_MAC_ADDRESS macro
GUI_ERR_INVALID_OUTPUT_PATH
GUI_ERR_INVALID_OUTPUT_PATH macro
GUI_ERR_INVALID_SHARED_FOLDER_PATH
GUI_ERR_INVALID_SHARED_FOLDER_PATH macro
GUI_ERR_INVALID_VM_NAME_SPECIFIED
GUI_ERR_INVALID_VM_NAME_SPECIFIED macro
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS macro
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH
GUI_ERR_NEED_TO_RESET_DISK_PRM_ON_FAT_FS_ON_CUSTOM_BRANCH macro
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE
GUI_ERR_NEED_TO_SET_SPLIT_ON_FAT_FS_WITH_RECREATE macro
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID
GUI_ERR_OLD_VERSION_LICENSE_NOT_VALID macro
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR
GUI_ERR_OLD_VERSION_LICENSE_WRONG_DISTRIBUTOR macro
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE
GUI_ERR_OLD_VERSION_LICENSE_WRONG_LANGUAGE macro
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED
GUI_ERR_OUTPUT_PATH_NOT_SPECIFIED macro
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE
GUI_ERR_REGISTERED_VM_PATH_NOT_AVAILABLE macro
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY
GUI_ERR_SERVER_CUSTOM_NAME_EMPTY macro
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS
GUI_ERR_SERVER_CUSTOM_NAME_EXISTS macro
GUI_ERR_SERVER_WRONG_CUSTOM_NAME
GUI_ERR_SERVER_WRONG_CUSTOM_NAME macro
GUI_ERR_SHARED_FOLDER_NAME_EXISTS
GUI_ERR_SHARED_FOLDER_NAME_EXISTS macro
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_NAME_IS_NOT_SPECIFIED macro
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM
GUI_ERR_SHARED_FOLDER_NAME_IS_RESERVED_BY_SYSTEM macro
GUI_ERR_SHARED_FOLDER_PATH_EXISTS
GUI_ERR_SHARED_FOLDER_PATH_EXISTS macro
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED
GUI_ERR_SHARED_FOLDER_PATH_IS_NOT_SPECIFIED macro
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS
GUI_ERR_SHORTCUT_HAS_EMPTY_MODIFIERS macro
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP
GUI_ERR_SNAPSHOT_VM_WITH_BOOTCAMP macro
GUI_ERR_SNAPSHOT_VM_WITH_VTD
GUI_ERR_SNAPSHOT_VM_WITH_VTD macro
GUI_ERR_SOCKET_NOT_SPECIFIED
GUI_ERR_SOCKET_NOT_SPECIFIED macro
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_GUEST macro
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL
GUI_ERR_SUSPEND_VM_VTD_WITH_UNSUPPORTED_SHUTDOWN_TOOL macro
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_INIT_TIMEOUT macro
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_UNKNOWN_ERROR macro
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT
GUI_ERR_VM_HW_UPGRADE_VMXPHY_INIT_TIMEOUT macro
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR
GUI_ERR_VM_HW_UPGRADE_VMXPHY_UNKNOWN_ERROR macro
GUI_ERR_WRONG_NUMBER_OF_CPU
GUI_ERR_WRONG_NUMBER_OF_CPU macro
GUI_INFO_CANT_DISPLAY_HELP_TOPIC
GUI_INFO_CANT_DISPLAY_HELP_TOPIC macro
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD
GUI_INFO_CANT_INSTALL_TOOLS_WITHOUT_CD macro
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD
GUI_INFO_CANT_RUN_COMPRESSOR_WITHOUT_CD macro
GUI_INFO_INSTALL_TOOLS_LIN
GUI_INFO_INSTALL_TOOLS_LIN macro
GUI_INFO_INSTALL_TOOLS_MAC
GUI_INFO_INSTALL_TOOLS_MAC macro
GUI_INFO_INSTALL_TOOLS_WIN
GUI_INFO_INSTALL_TOOLS_WIN macro
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED
GUI_INFO_NETWORK_MISCONFIGURATION_REPAIRED macro
GUI_INFO_RUN_COMPRESSOR_WIN
GUI_INFO_RUN_COMPRESSOR_WIN macro
GUI_INFO_SERVER_RESTART_IS_NEEDED
GUI_INFO_SERVER_RESTART_IS_NEEDED macro
GUI_INFO_SWITCH_TO_FULLSCREEN
GUI_INFO_SWITCH_TO_FULLSCREEN macro
GUI_INFO_TOOLS_INSTALL_OTHER
GUI_INFO_TOOLS_INSTALL_OTHER macro
GUI_INFO_VM_HW_UPGRADE_COMPLETED
GUI_INFO_VM_HW_UPGRADE_COMPLETED macro
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED
GUI_INFO_VM_HW_UPGRADE_VMXPHY_COMPLETED macro
GUI_INFO_VM_SHUTDOWN_CONDITIONS
GUI_INFO_VM_SHUTDOWN_CONDITIONS macro
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
GUI_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION macro
GUI_QUESTION_CANCEL_DEPLOY_OPERATION
GUI_QUESTION_CANCEL_DEPLOY_OPERATION macro
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST
GUI_QUESTION_CANT_USE_DEVICE_CLIENT_OPTION_ON_HOST macro
GUI_QUESTION_COHERENCE_NOTIFICATION
GUI_QUESTION_COHERENCE_NOTIFICATION macro
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE
GUI_QUESTION_COMPRESSED_DISK_IN_EXPRESS_MODE macro
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME
GUI_QUESTION_DISABLING_SHARED_FOLDERS_RUNTIME macro
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_CFG_EDITOR macro
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS
GUI_QUESTION_DROP_SUSPEND_FOR_HDD_QUEST_WIZARDS macro
GUI_QUESTION_EDIT_SUSPENDED_VM
GUI_QUESTION_EDIT_SUSPENDED_VM macro
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING
GUI_QUESTION_ENABLE_GLOBAL_HOST_SHARING macro
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING
GUI_QUESTION_ENABLE_LOCAL_HOST_SHARING macro
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP
GUI_QUESTION_ENABLE_MOUNT_ON_DESKTOP macro
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING macro
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY
GUI_QUESTION_LEAVE_AUTO_HW_UPGRADING_VMXPHY macro
GUI_QUESTION_LOST_TASK_CONTINUE
GUI_QUESTION_LOST_TASK_CONTINUE macro
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE
GUI_QUESTION_NEED_TO_DISABLE_SHARED_PROFILE macro
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER
GUI_QUESTION_NEED_TO_SHARE_HOME_FOLDER macro
GUI_QUESTION_OVERWRITE_HDD_IMAGE
GUI_QUESTION_OVERWRITE_HDD_IMAGE macro
GUI_QUESTION_REMOVE_SERVER_FROM_LIST
GUI_QUESTION_REMOVE_SERVER_FROM_LIST macro
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT
GUI_QUESTION_REVERT_TO_LAST_SNAPSHOT macro
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT
GUI_QUESTION_REVERT_TO_SPECIFIED_SNAPSHOT macro
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST
GUI_WNG_ADD_HID_USB_DEVICE_TO_UDP_LIST macro
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE
GUI_WNG_AUTOCONNECT_HID_USB_DEVICE macro
GUI_WNG_CONNECT_HID_USB_DEVICE
GUI_WNG_CONNECT_HID_USB_DEVICE macro
GUI_WNG_STOP_VM_WITH_BOOTCAMP
GUI_WNG_STOP_VM_WITH_BOOTCAMP macro
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY
GUI_WRN_SNAPSHOT_NAME_IS_EMPTY macro
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW
GUI_WRN_VIDEO_MEMORY_IS_TOO_LOW macro
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_IN_PROGRESS macro
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS
GUI_WRN_VM_HW_UPGRADING_VMXPHY_IN_PROGRESS macro
H
Handle Functions
handle_type_to_string
handle_type_to_string function
How to Use This Guide
I
IOS_AUTH_FAILED enumeration member
IOS_CONNECTION_TIMEOUT enumeration member
IOS_DISABLED enumeration member
IOS_STARTED enumeration member
IOS_STOPPED enumeration member
IOS_UNKNOWN_VM_UUID enumeration member
IS_FREEBSD
IS_FREEBSD macro
IS_FS_EXECUTE_PERMITTED
IS_FS_EXECUTE_PERMITTED macro
IS_FS_READ_PERMITTED
IS_FS_READ_PERMITTED macro
IS_FS_WRITE_PERMITTED
IS_FS_WRITE_PERMITTED macro
IS_LINUX
IS_LINUX macro
IS_MACOS
IS_MACOS macro
IS_MSDOS
IS_MSDOS macro
IS_NETWARE
IS_NETWARE macro
IS_OS2
IS_OS2 macro
IS_OTHER
IS_OTHER macro
IS_SOLARIS
IS_SOLARIS macro
IS_VALID_FREEBSD_VERSION
IS_VALID_FREEBSD_VERSION macro
IS_VALID_LINUX_VERSION
IS_VALID_LINUX_VERSION macro
IS_VALID_MACOS_VERSION
IS_VALID_MACOS_VERSION macro
IS_VALID_MSDOS_VERSION
IS_VALID_MSDOS_VERSION macro
IS_VALID_NETWARE_VERSION
IS_VALID_NETWARE_VERSION macro
IS_VALID_OS2_VERSION
IS_VALID_OS2_VERSION macro
IS_VALID_OTHER_OS_VERSION
IS_VALID_OTHER_OS_VERSION macro
IS_VALID_SOLARIS_VERSION
IS_VALID_SOLARIS_VERSION macro
IS_VALID_WINDOWS_VERSION
IS_VALID_WINDOWS_VERSION macro
IS_WINDOWS
IS_WINDOWS macro
K
Keyboard Control
M
Macros
Mouse Control
O
Organization of This Guide
Other Macros
Other Structs
Other Types
P
PAM_DESKTOP enumeration member
PAM_PLAYER enumeration member
PAM_SERVER enumeration member
PAM_STM enumeration member
PAM_UNKNOWN enumeration member
PAM_WORKSTATION enumeration member
PAO_VM_NOT_SHARED enumeration member
PAO_VM_SHARED_ON_FULL_ACCESS enumeration member
PAO_VM_SHARED_ON_VIEW enumeration member
PAO_VM_SHARED_ON_VIEW_AND_RUN enumeration member
PAO_VM_SHUTDOWN enumeration member
PAO_VM_START_MANUAL enumeration member
PAO_VM_START_ON_LOAD enumeration member
PAO_VM_START_ON_RELOAD enumeration member
PAO_VM_STOP enumeration member
PAO_VM_SUSPEND enumeration member
PAR_MAX enumeration member
PAR_VM_BEGINEDIT_ACCESS enumeration member
PAR_VM_CANCEL_COMPACT_ACCESS enumeration member
PAR_VM_CANCEL_COMPRESSOR_ACCESS enumeration member
PAR_VM_CLONE_ACCESS enumeration member
PAR_VM_COMMIT_ACCESS enumeration member
PAR_VM_CREATE_SNAPSHOT_ACCESS enumeration member
PAR_VM_DELETE_ACCESS enumeration member
PAR_VM_DELETE_SNAPSHOT_ACCESS enumeration member
PAR_VM_DROPSUSPENDEDSTATE_ACCESS enumeration member
PAR_VM_EDITING_ACCESS enumeration member
PAR_VM_GET_SUSPENDED_SCREEN_ACCESS enumeration member
PAR_VM_GET_VMINFO_ACCESS enumeration member
PAR_VM_GETCONFIG_ACCESS enumeration member
PAR_VM_GETPROBLEMREPORT_ACCESS enumeration member
PAR_VM_GETSTATISTICS_ACCESS enumeration member
PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS enumeration member
PAR_VM_INSTALL_TOOLS_ACCESS enumeration member
PAR_VM_INSTALL_UTILITY_ACCESS enumeration member
PAR_VM_MIGRATE_ACCESS enumeration member
PAR_VM_MIGRATE_CANCEL_ACCESS enumeration member
PAR_VM_PAUSE_ACCESS enumeration member
PAR_VM_PERFSTAT_ACCESS enumeration member
PAR_VM_REGISTER_ACCESS enumeration member
PAR_VM_RESET_ACCESS enumeration member
PAR_VM_RESTART_GUEST_ACCESS enumeration member
PAR_VM_RESTORE_ACCESS enumeration member
PAR_VM_RESUME_ACCESS enumeration member
PAR_VM_RUN_COMPRESSOR_ACCESS enumeration member
PAR_VM_SEND_ANSWER_ACCESS enumeration member
PAR_VM_START_ACCESS enumeration member
PAR_VM_START_EX_ACCESS enumeration member
PAR_VM_START_STOP_VNC_SERVER enumeration member
PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS enumeration member
PAR_VM_STOP_ACCESS enumeration member
PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS enumeration member
PAR_VM_SUSPEND_ACCESS enumeration member
PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS enumeration member
PAR_VM_UNREG_ACCESS enumeration member
PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS enumeration member
PAR_VM_UPDATE_SECURITY_ACCESS enumeration member
PAR_VM_UPDATE_TOOLS_SECTION enumeration member
PAR_VMDEV_CONNECT_ACCESS enumeration member
PAR_VMDEV_CREATEIMAGE_ACCESS enumeration member
PAR_VMDEV_DISCONNECT_ACCESS enumeration member
Parallels.h
PARALLELS_API_VER
PARALLELS_API_VER macro
PARALLELS_API_VER_1
PARALLELS_API_VER_1 macro
PARALLELS_API_VER_2
PARALLELS_API_VER_2 macro
PBO_CD_HDD_FLOPPY enumeration member
PBO_FLOPPY_HDD_CD enumeration member
PBO_HDD_CD_FLOPPY enumeration member
PCM_CPU_AMD_V enumeration member
PCM_CPU_INTEL_VT_X enumeration member
PCM_CPU_MODE_32 enumeration member
PCM_CPU_MODE_64 enumeration member
PCM_CPU_NONE_HV enumeration member
PDA_DEVICE_IDLE enumeration member
PDA_DEVICE_READ enumeration member
PDA_DEVICE_WRITE enumeration member
PDCC_HIGH_COMPRESSION enumeration member
PDCC_LOW_COMPRESSION enumeration member
PDCC_MEDIUM_COMPRESSION enumeration member
PDCC_NO_COMPRESSION enumeration member
PDCQ_HIGH_QUALITY enumeration member
PDCQ_LOW_QUALITY enumeration member
PDCQ_MEDIUM_QUALITY enumeration member
PDCT_HIGH_QUALITY_WITH_COMPRESSION enumeration member
PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION enumeration member
PDCT_LOW_QUALITY_WITH_COMPRESSION enumeration member
PDCT_LOW_QUALITY_WITHOUT_COMPRESSION enumeration member
PDCT_MEDIUM_QUALITY_WITH_COMPRESSION enumeration member
PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION enumeration member
PDE_CLUSTERED_DEVICE enumeration member
PDE_FLOPPY_DISK enumeration member
PDE_GENERIC_DEVICE enumeration member
PDE_GENERIC_NETWORK_ADAPTER enumeration member
PDE_GENERIC_PCI_DEVICE enumeration member
PDE_GENERIC_PORT enumeration member
PDE_GENERIC_SCSI_DEVICE enumeration member
PDE_HARD_DISK enumeration member
PDE_MASSSTORAGE_DEVICE enumeration member
PDE_MAX enumeration member
PDE_MIXER_DEVICE enumeration member
PDE_OPTICAL_DISK enumeration member
PDE_PARALLEL_PORT enumeration member
PDE_PRINTER enumeration member
PDE_SERIAL_PORT enumeration member
PDE_SOUND_DEVICE enumeration member
PDE_STORAGE_DEVICE enumeration member
PDE_USB_DEVICE enumeration member
PDE_VIRTUAL_SNAPSHOT_DEVICE enumeration member
PDM_APP_IN_DOCK_ALWAYS enumeration member
PDM_APP_IN_DOCK_COHERENCE_ONLY enumeration member
PDM_APP_IN_DOCK_NEVER enumeration member
PDT_ANY_TYPE enumeration member
PDT_USE_AC97_SOUND enumeration member
PDT_USE_BOOTCAMP enumeration member
PDT_USE_BRIDGE_ETHERNET enumeration member
PDT_USE_CREATIVE_SB16_SOUND enumeration member
PDT_USE_HOST_ONLY_NETWORK enumeration member
PDT_USE_IMAGE_FILE enumeration member
PDT_USE_OTHER enumeration member
PDT_USE_OUTPUT_FILE enumeration member
PDT_USE_PARALLEL_PORT_PRINTER_MODE enumeration member
PDT_USE_REAL_CDDVD enumeration member
PDT_USE_REAL_DEVICE enumeration member
PDT_USE_REAL_FLOPPY enumeration member
PDT_USE_REAL_HDD enumeration member
PDT_USE_REAL_PARALLEL_PORT enumeration member
PDT_USE_REAL_SERIAL_PORT enumeration member
PDT_USE_REAL_USB_CONTROLLER enumeration member
PDT_USE_SERIAL_PORT_SOCKET_MODE enumeration member
PDT_USE_SHARED_NETWORK enumeration member
PET Macros
PET_ANSWER_APPEND
PET_ANSWER_APPEND macro
PET_ANSWER_BREAK
PET_ANSWER_BREAK macro
PET_ANSWER_CANCEL
PET_ANSWER_CANCEL macro
PET_ANSWER_COMMIT
PET_ANSWER_COMMIT macro
PET_ANSWER_CONTINUE
PET_ANSWER_CONTINUE macro
PET_ANSWER_COPIED
PET_ANSWER_COPIED macro
PET_ANSWER_CREATE
PET_ANSWER_CREATE macro
PET_ANSWER_CREATE_NEW
PET_ANSWER_CREATE_NEW macro
PET_ANSWER_DISCONNECT_ANYWAY
PET_ANSWER_DISCONNECT_ANYWAY macro
PET_ANSWER_MOVED
PET_ANSWER_MOVED macro
PET_ANSWER_NO
PET_ANSWER_NO macro
PET_ANSWER_OK
PET_ANSWER_OK macro
PET_ANSWER_OVERIDE
PET_ANSWER_OVERIDE macro
PET_ANSWER_REPLACE
PET_ANSWER_REPLACE macro
PET_ANSWER_REVERT
PET_ANSWER_REVERT macro
PET_ANSWER_SHUTDOWN
PET_ANSWER_SHUTDOWN macro
PET_ANSWER_SKIP
PET_ANSWER_SKIP macro
PET_ANSWER_STARTVM
PET_ANSWER_STARTVM macro
PET_ANSWER_STOP
PET_ANSWER_STOP macro
PET_ANSWER_SUSPEND_ANYWAY
PET_ANSWER_SUSPEND_ANYWAY macro
PET_ANSWER_USE_CURRENT
PET_ANSWER_USE_CURRENT macro
PET_ANSWER_YES
PET_ANSWER_YES macro
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM macro
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK
PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK macro
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM
PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM macro
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE
PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE macro
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED
PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED macro
PET_QUESTION_CANCEL_CLONE_OPERATION
PET_QUESTION_CANCEL_CLONE_OPERATION macro
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION
PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION macro
PET_QUESTION_CANCEL_DEPLOY_OPERATION
PET_QUESTION_CANCEL_DEPLOY_OPERATION macro
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE
PET_QUESTION_CHANGE_VM_MIGRATION_TYPE macro
PET_QUESTION_CREATE_NEW_MAC_ADDRESS
PET_QUESTION_CREATE_NEW_MAC_ADDRESS macro
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE
PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE macro
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR
PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR macro
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR
PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR macro
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG
PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG macro
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE
PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE macro
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK
PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK macro
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG
PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG macro
PET_QUESTION_OLD_CONFIG_CONVERTION
PET_QUESTION_OLD_CONFIG_CONVERTION macro
PET_QUESTION_REACH_OVERCOMMIT_STATE
PET_QUESTION_REACH_OVERCOMMIT_STATE macro
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM
PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM macro
PET_QUESTION_REGISTER_USED_VM
PET_QUESTION_REGISTER_USED_VM macro
PET_QUESTION_REGISTER_VM_TEMPLATE
PET_QUESTION_REGISTER_VM_TEMPLATE macro
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP
PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP macro
PET_QUESTION_SAMPLE_1
PET_QUESTION_SAMPLE_1 macro
PET_QUESTION_SAMPLE_2
PET_QUESTION_SAMPLE_2 macro
PET_QUESTION_TXT_ERROR
PET_QUESTION_TXT_ERROR macro
PET_QUESTION_UNDO_DISKS_MODE
PET_QUESTION_UNDO_DISKS_MODE macro
PET_QUESTION_VM_COPY_OR_MOVE
PET_QUESTION_VM_COPY_OR_MOVE macro
PFD_ALL enumeration member
PFD_BOOLEAN enumeration member
PFD_CDATA enumeration member
PFD_ENTITY enumeration member
PFD_ENUMERATION enumeration member
PFD_INT32 enumeration member
PFD_INT64 enumeration member
PFD_STDERR enumeration member
PFD_STDOUT enumeration member
PFD_STRING enumeration member
PFD_UINT32 enumeration member
PFD_UINT64 enumeration member
PFS_UNIX_LIKE_FS enumeration member
PFS_WINDOWS_LIKE_FS enumeration member
PGD_UNKNOWN enumeration member
PGD_WINDOWS_VISTA enumeration member
PGD_WINDOWS_VISTA_32 enumeration member
PGD_WINDOWS_VISTA_64 enumeration member
PGD_WINDOWS_XP enumeration member
PGD_WINDOWS_XP_32 enumeration member
PGD_WINDOWS_XP_64 enumeration member
PHD_EXPANDING_HARD_DISK enumeration member
PHD_PLAIN_HARD_DISK enumeration member
PHI_REAL_NET_ADAPTER enumeration member
PHI_VIRTUAL_NET_ADAPTER enumeration member
PHO_LIN enumeration member
PHO_MAC enumeration member
PHO_WIN enumeration member
PHT_ACCESS_RIGHTS
PHT_ACCESS_RIGHTS enumeration member
PHT_BOOT_DEVICE
PHT_BOOT_DEVICE enumeration member
PHT_DISP_CONFIG
PHT_DISP_CONFIG enumeration member
PHT_DISP_NET_ADAPTER
PHT_DISP_NET_ADAPTER enumeration member
PHT_ERROR enumeration member
PHT_EVENT
PHT_EVENT enumeration member
PHT_EVENT_PARAMETER
PHT_EVENT_PARAMETER enumeration member
PHT_FOUND_VM_INFO
PHT_FOUND_VM_INFO enumeration member
PHT_HANDLES_LIST enumeration member
PHT_HW_GENERIC_DEVICE
PHT_HW_GENERIC_DEVICE enumeration member
PHT_HW_HARD_DISK
PHT_HW_HARD_DISK enumeration member
PHT_HW_HARD_DISK_PARTITION
PHT_HW_HARD_DISK_PARTITION enumeration member
PHT_HW_NET_ADAPTER
PHT_HW_NET_ADAPTER enumeration member
PHT_JOB
PHT_JOB enumeration member
PHT_LAST enumeration member
PHT_LICENSE
PHT_LICENSE enumeration member
PHT_LOGIN_RESPONSE
PHT_LOGIN_RESPONSE enumeration member
PHT_NET_SERVICE_STATUS
PHT_NET_SERVICE_STATUS enumeration member
PHT_PORT_FORWARDING
PHT_PORT_FORWARDING enumeration member
PHT_REMOTE_FILESYSTEM_ENTRY
PHT_REMOTE_FILESYSTEM_ENTRY enumeration member
PHT_REMOTE_FILESYSTEM_INFO
PHT_REMOTE_FILESYSTEM_INFO enumeration member
PHT_REMOTEDEV_CMD enumeration member
PHT_RESULT
PHT_RESULT enumeration member
PHT_RUNNING_TASK
PHT_RUNNING_TASK enumeration member
PHT_SCREEN_RESOLUTION enumeration member
PHT_SERVER
PHT_SERVER enumeration member
PHT_SERVER_CONFIG
PHT_SERVER_CONFIG enumeration member
PHT_SERVER_INFO
PHT_SERVER_INFO enumeration member
PHT_SHARE
PHT_SHARE enumeration member
PHT_STRINGS_LIST
PHT_STRINGS_LIST enumeration member
PHT_SYSTEM_STATISTICS
PHT_SYSTEM_STATISTICS enumeration member
PHT_SYSTEM_STATISTICS_CPU
PHT_SYSTEM_STATISTICS_CPU enumeration member
PHT_SYSTEM_STATISTICS_DISK
PHT_SYSTEM_STATISTICS_DISK enumeration member
PHT_SYSTEM_STATISTICS_DISK_PARTITION
PHT_SYSTEM_STATISTICS_DISK_PARTITION enumeration member
PHT_SYSTEM_STATISTICS_IFACE
PHT_SYSTEM_STATISTICS_IFACE enumeration member
PHT_SYSTEM_STATISTICS_PROCESS
PHT_SYSTEM_STATISTICS_PROCESS enumeration member
PHT_SYSTEM_STATISTICS_USER_SESSION
PHT_SYSTEM_STATISTICS_USER_SESSION enumeration member
PHT_TIS_EMITTER enumeration member
PHT_TIS_RECORD enumeration member
PHT_TOOL enumeration member
PHT_USER_INFO
PHT_USER_INFO enumeration member
PHT_USER_PROFILE
PHT_USER_PROFILE enumeration member
PHT_VIRTUAL_DEV_DISPLAY enumeration member
PHT_VIRTUAL_DEV_FLOPPY
PHT_VIRTUAL_DEV_FLOPPY enumeration member
PHT_VIRTUAL_DEV_GENERIC_PCI enumeration member
PHT_VIRTUAL_DEV_GENERIC_SCSI enumeration member
PHT_VIRTUAL_DEV_HARD_DISK
PHT_VIRTUAL_DEV_HARD_DISK enumeration member
PHT_VIRTUAL_DEV_HD_PARTITION
PHT_VIRTUAL_DEV_HD_PARTITION enumeration member
PHT_VIRTUAL_DEV_KEYBOARD enumeration member
PHT_VIRTUAL_DEV_MOUSE enumeration member
PHT_VIRTUAL_DEV_NET_ADAPTER
PHT_VIRTUAL_DEV_NET_ADAPTER enumeration member
PHT_VIRTUAL_DEV_OPTICAL_DISK
PHT_VIRTUAL_DEV_OPTICAL_DISK enumeration member
PHT_VIRTUAL_DEV_PARALLEL_PORT
PHT_VIRTUAL_DEV_PARALLEL_PORT enumeration member
PHT_VIRTUAL_DEV_SERIAL_PORT
PHT_VIRTUAL_DEV_SERIAL_PORT enumeration member
PHT_VIRTUAL_DEV_SOUND
PHT_VIRTUAL_DEV_SOUND enumeration member
PHT_VIRTUAL_DEV_USB_DEVICE
PHT_VIRTUAL_DEV_USB_DEVICE enumeration member
PHT_VIRTUAL_DISK
PHT_VIRTUAL_DISK enumeration member
PHT_VIRTUAL_MACHINE
PHT_VIRTUAL_MACHINE enumeration member
PHT_VIRTUAL_NETWORK
PHT_VIRTUAL_NETWORK enumeration member
PHT_VM_CONFIGURATION
PHT_VM_CONFIGURATION enumeration member
PHT_VM_GUEST_SESSION
PHT_VM_GUEST_SESSION enumeration member
PHT_VM_INFO
PHT_VM_INFO enumeration member
PHT_VM_TOOLS_INFO
PHT_VM_TOOLS_INFO enumeration member
PHY_WIFI_REAL_NET_ADAPTER enumeration member
PIE_DISPATCHER enumeration member
PIE_IO_SERVICE enumeration member
PIE_VIRTUAL_MACHINE enumeration member
PIE_WEB_SERVICE enumeration member
PIF_BMP enumeration member
PIF_JPG enumeration member
PIF_PNG enumeration member
PIF_RAW enumeration member
PIT_DOCK_ICON_LIVE_SCREEN_SHOT enumeration member
PIT_DOCK_ICON_START_MENU enumeration member
PIT_DOCK_ICON_SYSTEM enumeration member
PJOC_JOB_CANCEL enumeration member
PJOC_SRV_ADD_NET_ADAPTER enumeration member
PJOC_SRV_ATTACH_TO_LOST_TASK enumeration member
PJOC_SRV_COMMON_PREFS_BEGIN_EDIT enumeration member
PJOC_SRV_COMMON_PREFS_COMMIT enumeration member
PJOC_SRV_DELETE_NET_ADAPTER enumeration member
PJOC_SRV_FS_CAN_CREATE_FILE enumeration member
PJOC_SRV_FS_CREATE_DIR enumeration member
PJOC_SRV_FS_GENERATE_ENTRY_NAME enumeration member
PJOC_SRV_FS_GET_DIR_ENTRIES enumeration member
PJOC_SRV_FS_GET_DISK_LIST enumeration member
PJOC_SRV_FS_REMOVE_ENTRY enumeration member
PJOC_SRV_FS_RENAME_ENTRY enumeration member
PJOC_SRV_GET_ALL_HOST_USERS enumeration member
PJOC_SRV_GET_COMMON_PREFS enumeration member
PJOC_SRV_GET_LICENSE_INFO enumeration member
PJOC_SRV_GET_NET_SERVICE_STATUS enumeration member
PJOC_SRV_GET_PERFSTATS enumeration member
PJOC_SRV_GET_PROBLEM_REPORT enumeration member
PJOC_SRV_GET_SRV_CONFIG enumeration member
PJOC_SRV_GET_STATISTICS enumeration member
PJOC_SRV_GET_USER_INFO enumeration member
PJOC_SRV_GET_USER_INFO_LIST enumeration member
PJOC_SRV_GET_USER_PROFILE enumeration member
PJOC_SRV_GET_VIRTUAL_NETWORK_LIST enumeration member
PJOC_SRV_GET_VM_LIST enumeration member
PJOC_SRV_LOGIN enumeration member
PJOC_SRV_LOGIN_LOCAL enumeration member
PJOC_SRV_LOGOFF enumeration member
PJOC_SRV_LOOKUP_PARALLELS_SERVERS enumeration member
PJOC_SRV_NET_SERVICE_RESTART enumeration member
PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS enumeration member
PJOC_SRV_NET_SERVICE_START enumeration member
PJOC_SRV_NET_SERVICE_STOP enumeration member
PJOC_SRV_REGISTER_VM enumeration member
PJOC_SRV_SEND_ANSWER enumeration member
PJOC_SRV_SHUTDOWN enumeration member
PJOC_SRV_START_SEARCH_VMS enumeration member
PJOC_SRV_SUBSCRIBE_PERFSTATS enumeration member
PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS enumeration member
PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS enumeration member
PJOC_SRV_UNSUBSCRIBE_PERFSTATS enumeration member
PJOC_SRV_UPDATE_LICENSE enumeration member
PJOC_SRV_UPDATE_NET_ADAPTER enumeration member
PJOC_SRV_USER_PROFILE_BEGIN_EDIT enumeration member
PJOC_SRV_USER_PROFILE_COMMIT enumeration member
PJOC_UNKNOWN enumeration member
PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB enumeration member
PJOC_VM_BEGIN_EDIT enumeration member
PJOC_VM_CANCEL_COMPRESSOR enumeration member
PJOC_VM_CLONE enumeration member
PJOC_VM_COMMIT enumeration member
PJOC_VM_CONNECT_TO_VM enumeration member
PJOC_VM_CREATE_SNAPSHOT enumeration member
PJOC_VM_CREATE_UNATTENDED_FLOPPY enumeration member
PJOC_VM_DELETE enumeration member
PJOC_VM_DELETE_SNAPSHOT enumeration member
PJOC_VM_DEV_CONNECT enumeration member
PJOC_VM_DEV_CREATE_IMAGE enumeration member
PJOC_VM_DEV_DISCONNECT enumeration member
PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN enumeration member
PJOC_VM_DROP_SUSPENDED_STATE enumeration member
PJOC_VM_GENERATE_VM_DEV_FILENAME enumeration member
PJOC_VM_GET_PERFSTATS enumeration member
PJOC_VM_GET_PROBLEM_REPORT enumeration member
PJOC_VM_GET_SNAPSHOTS_TREE enumeration member
PJOC_VM_GET_STATE enumeration member
PJOC_VM_GET_STATISTICS enumeration member
PJOC_VM_GET_SUSPENDED_SCREEN enumeration member
PJOC_VM_GET_TOOLS_STATE enumeration member
PJOC_VM_GUEST_GET_NETWORK_SETTINGS enumeration member
PJOC_VM_GUEST_LOGOUT enumeration member
PJOC_VM_GUEST_RUN_PROGRAM enumeration member
PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS enumeration member
PJOC_VM_INSTALL_TOOLS enumeration member
PJOC_VM_INSTALL_UTILITY enumeration member
PJOC_VM_LOGIN_IN_GUEST enumeration member
PJOC_VM_MIGRATE enumeration member
PJOC_VM_MIGRATE_CANCEL enumeration member
PJOC_VM_PAUSE enumeration member
PJOC_VM_REFRESH_CONFIG enumeration member
PJOC_VM_REG enumeration member
PJOC_VM_RESET enumeration member
PJOC_VM_RESTART enumeration member
PJOC_VM_RESTORE enumeration member
PJOC_VM_RESUME enumeration member
PJOC_VM_RUN_COMPRESSOR enumeration member
PJOC_VM_SEND_CLIPBOARD_REQUEST enumeration member
PJOC_VM_SEND_DRAGDROP_COMMAND enumeration member
PJOC_VM_SEND_SHUTDOWN_COMMAND enumeration member
PJOC_VM_START enumeration member
PJOC_VM_START_EX enumeration member
PJOC_VM_START_VNC_SERVER enumeration member
PJOC_VM_STOP enumeration member
PJOC_VM_STOP_VNC_SERVER enumeration member
PJOC_VM_SUBSCRIBE_PERFSTATS enumeration member
PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS enumeration member
PJOC_VM_SUSPEND enumeration member
PJOC_VM_SWITCH_TO_SNAPSHOT enumeration member
PJOC_VM_UNREG enumeration member
PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS enumeration member
PJOC_VM_UNSUBSCRIBE_PERFSTATS enumeration member
PJOC_VM_UPDATE_SECURITY enumeration member
PJOC_VM_UPDATE_SNAPSHOT_DATA enumeration member
PJOC_VM_UPDATE_TOOLS_SECTION enumeration member
PJOC_VM_VALIDATE_CONFIG enumeration member
PJS_FINISHED enumeration member
PJS_RUNNING enumeration member
PJS_UNKNOWN enumeration member
PKE_PRESS enumeration member
PKE_RELEASE enumeration member
PLM_ROOT_ACOUNT enumeration member
PLM_START_ACOUNT enumeration member
PLM_USER_ACOUNT enumeration member
PMB_LEFT_BUTTON enumeration member
PMB_MIDDLE_BUTTON enumeration member
PMB_NOBUTTON enumeration member
PMB_RIGHT_BUTTON enumeration member
PMS_IDE_DEVICE enumeration member
PMS_SCSI_DEVICE enumeration member
PMT_ANSWER enumeration member
PMT_CRITICAL enumeration member
PMT_INFORMATION enumeration member
PMT_QUESTION enumeration member
PMT_WARNING enumeration member
PNA_BRIDGED_ETHERNET enumeration member
PNA_HOST_ONLY enumeration member
PNA_SHARED enumeration member
PPF_TCP enumeration member
PPF_UDP enumeration member
PPS_PROC_IDLE enumeration member
PPS_PROC_RUN enumeration member
PPS_PROC_SLEEP enumeration member
PPS_PROC_STOP enumeration member
PPS_PROC_ZOMBIE enumeration member
PRD_AUTO enumeration member
PRD_DISABLED enumeration member
PRD_MANUAL enumeration member
Primary Display Capture
PRL_ALLOWED_VM_COMMAND
PRL_ALLOWED_VM_COMMAND enumeration
PRL_ALLOWED_VM_COMMAND_PTR
PRL_ALLOWED_VM_COMMAND_PTR type
PRL_API_METHOD_PTR
PRL_API_METHOD_PTR type
PRL_APP_IN_DOCK_MODE
PRL_APP_IN_DOCK_MODE enumeration
PRL_APP_IN_DOCK_MODE_PTR
PRL_APP_IN_DOCK_MODE_PTR type
PRL_APPLICATION_MODE
PRL_APPLICATION_MODE enumeration
PRL_APPLICATION_MODE_PTR
PRL_APPLICATION_MODE_PTR type
PRL_ASYNC_METHOD
PRL_ASYNC_METHOD macro
PRL_ASYNC_METHOD_DECL
PRL_ASYNC_METHOD_DECL macro
PRL_ASYNC_METHOD_PTR
PRL_ASYNC_METHOD_PTR macro
PRL_ASYNC_SRV_METHOD_DECL
PRL_ASYNC_SRV_METHOD_DECL macro
PRL_BOOL
PRL_BOOL type
PRL_BOOL Types
PRL_BOOL_PTR
PRL_BOOL_PTR type
PRL_BSD_PARTITION
PRL_BSD_PARTITION macro
PRL_CHAR
PRL_CHAR type
PRL_CHAR Types
PRL_CHAR_PTR
PRL_CHAR_PTR type
PRL_CHECKED_DISK_INVALID
PRL_CHECKED_DISK_INVALID macro
PRL_CHECKED_DISK_OLD_VERSION
PRL_CHECKED_DISK_OLD_VERSION macro
PRL_CHECKED_DISK_VALID
PRL_CHECKED_DISK_VALID macro
PRL_CONST Types
PRL_CONST_API_METHOD_PTR
PRL_CONST_API_METHOD_PTR type
PRL_CONST_BOOL_PTR
PRL_CONST_BOOL_PTR type
PRL_CONST_DISK_OPEN_FLAGS_PTR
PRL_CONST_DISK_OPEN_FLAGS_PTR type
PRL_CONST_DISK_PARAMETERS_PTR
PRL_CONST_DISK_PARAMETERS_PTR type
PRL_CONST_GUID_PTR
PRL_CONST_GUID_PTR type
PRL_CONST_HANDLE_PTR
PRL_CONST_HANDLE_PTR type
PRL_CONST_INT16_PTR
PRL_CONST_INT16_PTR type
PRL_CONST_INT32_PTR
PRL_CONST_INT32_PTR type
PRL_CONST_INT64_PTR
PRL_CONST_INT64_PTR type
PRL_CONST_INT8_PTR
PRL_CONST_INT8_PTR type
PRL_CONST_SIZE_PTR
PRL_CONST_SIZE_PTR type
PRL_CONST_SNAPSHOT_ELEMENT_PTR
PRL_CONST_SNAPSHOT_ELEMENT_PTR type
PRL_CONST_STR
PRL_CONST_STR type
PRL_CONST_STR_PTR
PRL_CONST_STR_PTR type
PRL_CONST_UINT16_PTR
PRL_CONST_UINT16_PTR type
PRL_CONST_UINT32_PTR
PRL_CONST_UINT32_PTR type
PRL_CONST_UINT64_PTR
PRL_CONST_UINT64_PTR type
PRL_CONST_UINT8_PTR
PRL_CONST_UINT8_PTR type
PRL_CONST_VOID_PTR
PRL_CONST_VOID_PTR type
PRL_CPU_HVT
PRL_CPU_HVT enumeration
PRL_CPU_HVT_PTR
PRL_CPU_HVT_PTR type
PRL_CPU_MODE
PRL_CPU_MODE enumeration
PRL_CPU_MODE_PTR
PRL_CPU_MODE_PTR type
PRL_CURRENT_GUEST_OS_SESSION
PRL_CURRENT_GUEST_OS_SESSION macro
PRL_DATA_PARTITION
PRL_DATA_PARTITION macro
PRL_DEVICE Types
PRL_DEVICE_ACTION
PRL_DEVICE_ACTION enumeration
PRL_DEVICE_ACTION_PTR
PRL_DEVICE_ACTION_PTR type
PRL_DEVICE_TYPE
PRL_DEVICE_TYPE enumeration
PRL_DEVICE_TYPE_PTR
PRL_DEVICE_TYPE_PTR type
PRL_DISK Macros
PRL_DISK Types
PRL_DISK_CACHE_DEFAULT
PRL_DISK_CACHE_DEFAULT macro
PRL_DISK_CACHE_DISABLED
PRL_DISK_CACHE_DISABLED macro
PRL_DISK_CACHE_ENABLED
PRL_DISK_CACHE_ENABLED macro
PRL_DISK_CACHE_UNCACHED_READ
PRL_DISK_CACHE_UNCACHED_READ macro
PRL_DISK_CALLBACK
PRL_DISK_DEFAULT_FLAG
PRL_DISK_DEFAULT_FLAG macro
PRL_DISK_FAKE_OPEN
PRL_DISK_FAKE_OPEN macro
PRL_DISK_FOPS_DEFAULT
PRL_DISK_FOPS_DEFAULT macro
PRL_DISK_FOPS_MASK
PRL_DISK_FOPS_MASK macro
PRL_DISK_FOPS_MERGING
PRL_DISK_FOPS_MERGING macro
PRL_DISK_FOPS_NONCACHED
PRL_DISK_FOPS_NONCACHED macro
PRL_DISK_FOPS_NORMAL
PRL_DISK_FOPS_NORMAL macro
PRL_DISK_INVALID
PRL_DISK_INVALID macro
PRL_DISK_NOTHING
PRL_DISK_NOTHING macro
PRL_DISK_OPEN_FLAGS
PRL_DISK_OPEN_FLAGS type
PRL_DISK_OPEN_FLAGS_PTR
PRL_DISK_OPEN_FLAGS_PTR type
PRL_DISK_PARAMETERS
PRL_DISK_PARAMETERS structure
PRL_DISK_PARAMETERS_PTR
PRL_DISK_PARAMETERS_PTR type
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_COMPLETED macro
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MAX macro
PRL_DISK_PROGRESS_MIN
PRL_DISK_PROGRESS_MIN macro
PRL_DISK_READ
PRL_DISK_READ macro
PRL_DISK_READ_LOCK
PRL_DISK_READ_LOCK macro
PRL_DISK_WRITE
PRL_DISK_WRITE macro
PRL_DISK_WRITE_THROUGH
PRL_DISK_WRITE_THROUGH macro
PRL_DISK_XML_CHANGE
PRL_DISK_XML_CHANGE macro
PRL_DISPLAY_CODEC_COMPRESSION
PRL_DISPLAY_CODEC_COMPRESSION enumeration
PRL_DISPLAY_CODEC_QUALITY
PRL_DISPLAY_CODEC_QUALITY enumeration
PRL_DISPLAY_CODEC_TYPE
PRL_DISPLAY_CODEC_TYPE enumeration
PRL_DOCK_ICON_TYPE
PRL_DOCK_ICON_TYPE enumeration
PRL_DOCK_ICON_TYPE_PTR
PRL_DOCK_ICON_TYPE_PTR type
PRL_EFI_PARTITION
PRL_EFI_PARTITION macro
PRL_EFI_PARTITION_GPT
PRL_EFI_PARTITION_GPT macro
PRL_EMPTY_PARTITION
PRL_EMPTY_PARTITION macro
PRL_ERR Macros
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR
PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR macro
PRL_ERR_ACCESS_DENIED
PRL_ERR_ACCESS_DENIED macro
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS
PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS macro
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE
PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE macro
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD
PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD macro
PRL_ERR_ACCESS_TO_VM_DENIED
PRL_ERR_ACCESS_TO_VM_DENIED macro
PRL_ERR_ACCESS_TOKEN_INVALID
PRL_ERR_ACCESS_TOKEN_INVALID macro
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED
PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED macro
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED
PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED macro
PRL_ERR_ALIGN_ON_4
PRL_ERR_ALIGN_ON_4 macro
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER
PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER macro
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT
PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT macro
PRL_ERR_API_INCOMPATIBLE
PRL_ERR_API_INCOMPATIBLE macro
PRL_ERR_API_WASNT_INITIALIZED
PRL_ERR_API_WASNT_INITIALIZED macro
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION
PRL_ERR_ATTACH_TO_TASK_BAD_SESSION macro
PRL_ERR_AUTHENTICATION_FAILED
PRL_ERR_AUTHENTICATION_FAILED macro
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BAD_PARAMETERS
PRL_ERR_BAD_PARAMETERS macro
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED
PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED macro
PRL_ERR_BUFFER_OVERRUN
PRL_ERR_BUFFER_OVERRUN macro
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE
PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE macro
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM macro
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM
PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM macro
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY
PRL_ERR_CANT_ALOCA_MEM_FILE_COPY macro
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS
PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS macro
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE macro
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_FILE macro
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE
PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE macro
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD
PRL_ERR_CANT_CONFIGURE_PARTITION_HDD macro
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD
PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD macro
PRL_ERR_CANT_CONNECT_TO_DISPATCHER
PRL_ERR_CANT_CONNECT_TO_DISPATCHER macro
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE
PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE macro
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS
PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS macro
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT macro
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT
PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT macro
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE
PRL_ERR_CANT_CREATE_FLOPPY_IMAGE macro
PRL_ERR_CANT_CREATE_HDD_IMAGE
PRL_ERR_CANT_CREATE_HDD_IMAGE macro
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE
PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE macro
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE
PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE macro
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE
PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE macro
PRL_ERR_CANT_DELETE_FILE
PRL_ERR_CANT_DELETE_FILE macro
PRL_ERR_CANT_EDIT_SUSPENDED_VM
PRL_ERR_CANT_EDIT_SUSPENDED_VM macro
PRL_ERR_CANT_GET_FILE_PERMISSIONS
PRL_ERR_CANT_GET_FILE_PERMISSIONS macro
PRL_ERR_CANT_INIT_REAL_CPUS_INFO
PRL_ERR_CANT_INIT_REAL_CPUS_INFO macro
PRL_ERR_CANT_PARSE_DISP_EVENT
PRL_ERR_CANT_PARSE_DISP_EVENT macro
PRL_ERR_CANT_PARSE_VM_CONFIG
PRL_ERR_CANT_PARSE_VM_CONFIG macro
PRL_ERR_CANT_RECREATE_HDD
PRL_ERR_CANT_RECREATE_HDD macro
PRL_ERR_CANT_REMOVE_DIR_ENTRY
PRL_ERR_CANT_REMOVE_DIR_ENTRY macro
PRL_ERR_CANT_REMOVE_ENTRY
PRL_ERR_CANT_REMOVE_ENTRY macro
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN
PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN macro
PRL_ERR_CANT_RENAME_DIR_ENTRY
PRL_ERR_CANT_RENAME_DIR_ENTRY macro
PRL_ERR_CANT_RENAME_ENTRY
PRL_ERR_CANT_RENAME_ENTRY macro
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE
PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE macro
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP
PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP macro
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION
PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION macro
PRL_ERR_CANT_TO_START_VM_TEMPLATE
PRL_ERR_CANT_TO_START_VM_TEMPLATE macro
PRL_ERR_CANT_UPDATE_DEVICE_INFO
PRL_ERR_CANT_UPDATE_DEVICE_INFO macro
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT macro
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32
PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 macro
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED
PRL_ERR_CDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_CLONE_OPERATION_CANCELED
PRL_ERR_CLONE_OPERATION_CANCELED macro
PRL_ERR_COM_DEVICE_ALREADY_EXIST
PRL_ERR_COM_DEVICE_ALREADY_EXIST macro
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED macro
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST
PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST macro
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE
PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE macro
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE
PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE macro
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED
PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED macro
PRL_ERR_CONCURRENT_COMMAND_EXECUTING
PRL_ERR_CONCURRENT_COMMAND_EXECUTING macro
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID macro
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID
PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID macro
PRL_ERR_CONFIG_EDIT_COLLISION
PRL_ERR_CONFIG_EDIT_COLLISION macro
PRL_ERR_CONFIG_FILE_NOT_SET
PRL_ERR_CONFIG_FILE_NOT_SET macro
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG
PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG macro
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE
PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE macro
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE
PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE macro
PRL_ERR_CORE_STATE_ERROR_COMMON
PRL_ERR_CORE_STATE_ERROR_COMMON macro
PRL_ERR_CORE_STATE_INV_SAV_VERSION
PRL_ERR_CORE_STATE_INV_SAV_VERSION macro
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE
PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE macro
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE
PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE macro
PRL_ERR_CPU_RESTART
PRL_ERR_CPU_RESTART macro
PRL_ERR_CPU_SHUTDOWN
PRL_ERR_CPU_SHUTDOWN macro
PRL_ERR_CREATE_PRIVELEGED_PROCESS
PRL_ERR_CREATE_PRIVELEGED_PROCESS macro
PRL_ERR_DELETING_VM_FROM_CATALOGUE
PRL_ERR_DELETING_VM_FROM_CATALOGUE macro
PRL_ERR_DEV_ALREADY_CONNECTED
PRL_ERR_DEV_ALREADY_CONNECTED macro
PRL_ERR_DEV_ALREADY_DISCONNECTED
PRL_ERR_DEV_ALREADY_DISCONNECTED macro
PRL_ERR_DEV_DISABLE_AFTER_LOST
PRL_ERR_DEV_DISABLE_AFTER_LOST macro
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED
PRL_ERR_DEV_FLOPPY_CONNECT_FAILED macro
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED
PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED macro
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED
PRL_ERR_DEV_MAX_NUMBER_EXCEEDED macro
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED macro
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED macro
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED
PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED macro
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED
PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED macro
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED
PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED macro
PRL_ERR_DEV_USB_NO_FREE_PORTS
PRL_ERR_DEV_USB_NO_FREE_PORTS macro
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED
PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED macro
PRL_ERR_DIRECTORY_DOES_NOT_EXIST
PRL_ERR_DIRECTORY_DOES_NOT_EXIST macro
PRL_ERR_DISK_BLOCK_CREATED
PRL_ERR_DISK_BLOCK_CREATED macro
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED
PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED macro
PRL_ERR_DISK_BLOCK_SEARCH_FAILED
PRL_ERR_DISK_BLOCK_SEARCH_FAILED macro
PRL_ERR_DISK_BLOCK_SKIPPED
PRL_ERR_DISK_BLOCK_SKIPPED macro
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR
PRL_ERR_DISK_BOOTCAMP_WRITE_MBR macro
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE
PRL_ERR_DISK_CANT_INITIALIZE_IMAGE macro
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY
PRL_ERR_DISK_COMPRESSED_FILE_EMPTY macro
PRL_ERR_DISK_CREATE_IMAGE_ERROR
PRL_ERR_DISK_CREATE_IMAGE_ERROR macro
PRL_ERR_DISK_DATA_NOT_FOUND
PRL_ERR_DISK_DATA_NOT_FOUND macro
PRL_ERR_DISK_DIR_CREATE_ERROR
PRL_ERR_DISK_DIR_CREATE_ERROR macro
PRL_ERR_DISK_DISK_NOT_OPENED
PRL_ERR_DISK_DISK_NOT_OPENED macro
PRL_ERR_DISK_ENLARGE_FAILED
PRL_ERR_DISK_ENLARGE_FAILED macro
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED
PRL_ERR_DISK_FAT32_SIZE_EXCEEDED macro
PRL_ERR_DISK_FILE_CREATE_ERROR
PRL_ERR_DISK_FILE_CREATE_ERROR macro
PRL_ERR_DISK_FILE_EXISTS
PRL_ERR_DISK_FILE_EXISTS macro
PRL_ERR_DISK_FILE_OPEN_ERROR
PRL_ERR_DISK_FILE_OPEN_ERROR macro
PRL_ERR_DISK_FSYNC_FAILED
PRL_ERR_DISK_FSYNC_FAILED macro
PRL_ERR_DISK_FULLFSYNC_FAILED
PRL_ERR_DISK_FULLFSYNC_FAILED macro
PRL_ERR_DISK_GENERIC_ERROR
PRL_ERR_DISK_GENERIC_ERROR macro
PRL_ERR_DISK_GET_MOUNTPATH_FAILED
PRL_ERR_DISK_GET_MOUNTPATH_FAILED macro
PRL_ERR_DISK_GET_PARAMS_FAILED
PRL_ERR_DISK_GET_PARAMS_FAILED macro
PRL_ERR_DISK_GROUP_INTERSECT
PRL_ERR_DISK_GROUP_INTERSECT macro
PRL_ERR_DISK_IDENTIFY_FAILED
PRL_ERR_DISK_IDENTIFY_FAILED macro
PRL_ERR_DISK_IMAGE_BUSY
PRL_ERR_DISK_IMAGE_BUSY macro
PRL_ERR_DISK_IMAGES_CORRUPTED
PRL_ERR_DISK_IMAGES_CORRUPTED macro
PRL_ERR_DISK_IMPERSONATE_FAILED
PRL_ERR_DISK_IMPERSONATE_FAILED macro
PRL_ERR_DISK_INCORRECTLY_CLOSED
PRL_ERR_DISK_INCORRECTLY_CLOSED macro
PRL_ERR_DISK_INSUFFICIENT_SPACE
PRL_ERR_DISK_INSUFFICIENT_SPACE macro
PRL_ERR_DISK_INTERNAL_CLASS_ERROR
PRL_ERR_DISK_INTERNAL_CLASS_ERROR macro
PRL_ERR_DISK_INVALID_BLOCKSIZE
PRL_ERR_DISK_INVALID_BLOCKSIZE macro
PRL_ERR_DISK_INVALID_FORMAT
PRL_ERR_DISK_INVALID_FORMAT macro
PRL_ERR_DISK_INVALID_PARAMETERS
PRL_ERR_DISK_INVALID_PARAMETERS macro
PRL_ERR_DISK_MEMORY_ERROR
PRL_ERR_DISK_MEMORY_ERROR macro
PRL_ERR_DISK_MOUNT_FAILED
PRL_ERR_DISK_MOUNT_FAILED macro
PRL_ERR_DISK_NOT_IMPLEMENTED
PRL_ERR_DISK_NOT_IMPLEMENTED macro
PRL_ERR_DISK_NOT_PERMITTED
PRL_ERR_DISK_NOT_PERMITTED macro
PRL_ERR_DISK_NOT_VALID_OFFSET
PRL_ERR_DISK_NOT_VALID_OFFSET macro
PRL_ERR_DISK_NULL_PART_SIZE
PRL_ERR_DISK_NULL_PART_SIZE macro
PRL_ERR_DISK_OFFSETS_FIXED
PRL_ERR_DISK_OFFSETS_FIXED macro
PRL_ERR_DISK_OPERATION_ABORTED
PRL_ERR_DISK_OPERATION_ABORTED macro
PRL_ERR_DISK_OPERATION_IN_PROGRESS
PRL_ERR_DISK_OPERATION_IN_PROGRESS macro
PRL_ERR_DISK_OPERATION_NOT_ALLOWED
PRL_ERR_DISK_OPERATION_NOT_ALLOWED macro
PRL_ERR_DISK_PARTITION_INVALID_NAME
PRL_ERR_DISK_PARTITION_INVALID_NAME macro
PRL_ERR_DISK_PARTITION_NOT_FOUND
PRL_ERR_DISK_PARTITION_NOT_FOUND macro
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE
PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE macro
PRL_ERR_DISK_POINTERS_MIXED_UP
PRL_ERR_DISK_POINTERS_MIXED_UP macro
PRL_ERR_DISK_POSSIBLE_OVERRUN
PRL_ERR_DISK_POSSIBLE_OVERRUN macro
PRL_ERR_DISK_READ_FAILED
PRL_ERR_DISK_READ_FAILED macro
PRL_ERR_DISK_READ_OUT_DISK
PRL_ERR_DISK_READ_OUT_DISK macro
PRL_ERR_DISK_RENAME_ERROR
PRL_ERR_DISK_RENAME_ERROR macro
PRL_ERR_DISK_RESERVED_WORD
PRL_ERR_DISK_RESERVED_WORD macro
PRL_ERR_DISK_SET_CACHING_FAILED
PRL_ERR_DISK_SET_CACHING_FAILED macro
PRL_ERR_DISK_SHARED_BLOCK
PRL_ERR_DISK_SHARED_BLOCK macro
PRL_ERR_DISK_SHARING_VIOLATION
PRL_ERR_DISK_SHARING_VIOLATION macro
PRL_ERR_DISK_SMALL_IMAGE_SIZE
PRL_ERR_DISK_SMALL_IMAGE_SIZE macro
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED
PRL_ERR_DISK_SNAPSHOTS_CORRUPTED macro
PRL_ERR_DISK_STATES_ERROR
PRL_ERR_DISK_STATES_ERROR macro
PRL_ERR_DISK_STORAGE_CORRUPTED
PRL_ERR_DISK_STORAGE_CORRUPTED macro
PRL_ERR_DISK_TRUNCATE_FAILED
PRL_ERR_DISK_TRUNCATE_FAILED macro
PRL_ERR_DISK_UNALIGNED
PRL_ERR_DISK_UNALIGNED macro
PRL_ERR_DISK_UNMOUNT_FAILED
PRL_ERR_DISK_UNMOUNT_FAILED macro
PRL_ERR_DISK_USER_INTERRUPTED
PRL_ERR_DISK_USER_INTERRUPTED macro
PRL_ERR_DISK_WRITE_FAILED
PRL_ERR_DISK_WRITE_FAILED macro
PRL_ERR_DISK_WRITE_OUT_DISK
PRL_ERR_DISK_WRITE_OUT_DISK macro
PRL_ERR_DISK_WRITE_REAL_FAILED
PRL_ERR_DISK_WRITE_REAL_FAILED macro
PRL_ERR_DISK_XML_INVALID
PRL_ERR_DISK_XML_INVALID macro
PRL_ERR_DISK_XML_INVALID_VERSION
PRL_ERR_DISK_XML_INVALID_VERSION macro
PRL_ERR_DISK_XML_LARGE_FILE
PRL_ERR_DISK_XML_LARGE_FILE macro
PRL_ERR_DISK_XML_LOCKED
PRL_ERR_DISK_XML_LOCKED macro
PRL_ERR_DISK_XML_OPEN_FAILED
PRL_ERR_DISK_XML_OPEN_FAILED macro
PRL_ERR_DISK_XML_SAVE_ERROR
PRL_ERR_DISK_XML_SAVE_ERROR macro
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR
PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR macro
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR
PRL_ERR_DISK_XML_SAVE_RENAME_ERROR macro
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS
PRL_ERR_DISP_CONFIG_ALREADY_EXISTS macro
PRL_ERR_DISP_CONFIG_FILE_NOT_SET
PRL_ERR_DISP_CONFIG_FILE_NOT_SET macro
PRL_ERR_DISP_CONFIG_WRITE_ERR
PRL_ERR_DISP_CONFIG_WRITE_ERR macro
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT
PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT macro
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS
PRL_ERR_DISP_SHUTDOWN_IN_PROCESS macro
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED
PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED macro
PRL_ERR_DISP_VM_IS_NOT_STARTED
PRL_ERR_DISP_VM_IS_NOT_STARTED macro
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED
PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED macro
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID
PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID macro
PRL_ERR_DISPATCHER_SERVICE_MODE
PRL_ERR_DISPATCHER_SERVICE_MODE macro
PRL_ERR_DOUBLE_INIT
PRL_ERR_DOUBLE_INIT macro
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST
PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST macro
PRL_ERR_ENTRY_ALREADY_EXISTS
PRL_ERR_ENTRY_ALREADY_EXISTS macro
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS
PRL_ERR_ENTRY_DIR_ALREADY_EXISTS macro
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST
PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST macro
PRL_ERR_ENTRY_DOES_NOT_EXIST
PRL_ERR_ENTRY_DOES_NOT_EXIST macro
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS
PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS macro
PRL_ERR_EXCEED_MEMORY_LIMIT
PRL_ERR_EXCEED_MEMORY_LIMIT macro
PRL_ERR_FAILED_TO_START_VNC_SERVER
PRL_ERR_FAILED_TO_START_VNC_SERVER macro
PRL_ERR_FAILED_TO_STOP_VNC_SERVER
PRL_ERR_FAILED_TO_STOP_VNC_SERVER macro
PRL_ERR_FAILURE
PRL_ERR_FAILURE macro
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF
PRL_ERR_FDD_IMAGE_CLONE_TO_SELF macro
PRL_ERR_FDD_IMAGE_COPY
PRL_ERR_FDD_IMAGE_COPY macro
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED
PRL_ERR_FDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_FILE_DISK_SPACE_ERROR
PRL_ERR_FILE_DISK_SPACE_ERROR macro
PRL_ERR_FILE_NOT_EXIST
PRL_ERR_FILE_NOT_EXIST macro
PRL_ERR_FILE_NOT_FOUND
PRL_ERR_FILE_NOT_FOUND macro
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS
PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS macro
PRL_ERR_FILE_READ_ERROR
PRL_ERR_FILE_READ_ERROR macro
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE
PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE macro
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE
PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE macro
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED
PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED macro
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST
PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST macro
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS
PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS macro
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS
PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS macro
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED
PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED macro
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER
PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER macro
PRL_ERR_FILE_WRITE_ERROR
PRL_ERR_FILE_WRITE_ERROR macro
PRL_ERR_FIXME
PRL_ERR_FIXME macro
PRL_ERR_FLOPPY_DRIVE_INVALID
PRL_ERR_FLOPPY_DRIVE_INVALID macro
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST
PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST macro
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST
PRL_ERR_FLOPPY_IMAGE_NOT_EXIST macro
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE
PRL_ERR_FREE_DISC_SPACE_FOR_CLONE macro
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT macro
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT
PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT macro
PRL_ERR_GET_LICENSE_INVALID_ARG
PRL_ERR_GET_LICENSE_INVALID_ARG macro
PRL_ERR_GET_MON_STATE_INVALID_ARG
PRL_ERR_GET_MON_STATE_INVALID_ARG macro
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED
PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED macro
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED
PRL_ERR_GET_MON_STATE_VM_NOT_CREATED macro
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED
PRL_ERR_GET_NET_SERVICE_STATUS_FAILED macro
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG
PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG macro
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED
PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED macro
PRL_ERR_GET_USER_HOME_DIR
PRL_ERR_GET_USER_HOME_DIR macro
PRL_ERR_GUEST_MAC_INVALID_VERSION
PRL_ERR_GUEST_MAC_INVALID_VERSION macro
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY
PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY macro
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST
PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST macro
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED
PRL_ERR_GUEST_TOOLS_NOT_INSTALLED macro
PRL_ERR_HANDSHAKE_FAILED
PRL_ERR_HANDSHAKE_FAILED macro
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED
PRL_ERR_HARD_DISK_IMAGE_CORRUPTED macro
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF
PRL_ERR_HDD_IMAGE_CLONE_TO_SELF macro
PRL_ERR_HDD_IMAGE_COPY
PRL_ERR_HDD_IMAGE_COPY macro
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST
PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST macro
PRL_ERR_HDD_IMAGE_NOT_EXIST
PRL_ERR_HDD_IMAGE_NOT_EXIST macro
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED
PRL_ERR_HDD_IMAGE_NOT_SPECIFIED macro
PRL_ERR_HOST_AMD_GUEST_MAC
PRL_ERR_HOST_AMD_GUEST_MAC macro
PRL_ERR_HVT_DISABLED
PRL_ERR_HVT_DISABLED macro
PRL_ERR_HVT_NOT_PRESENT
PRL_ERR_HVT_NOT_PRESENT macro
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG
PRL_ERR_HVT_TURNED_OFF_IN_CONFIG macro
PRL_ERR_HYP_ALLOC_VMS_MEMORY
PRL_ERR_HYP_ALLOC_VMS_MEMORY macro
PRL_ERR_IMAGE_NEED_TO_CONVERT
PRL_ERR_IMAGE_NEED_TO_CONVERT macro
PRL_ERR_IMPERSONATE_FAILED
PRL_ERR_IMPERSONATE_FAILED macro
PRL_ERR_INCONSISTENCY_VM_CONFIG
PRL_ERR_INCONSISTENCY_VM_CONFIG macro
PRL_ERR_INCORRECT_CDROM_PATH
PRL_ERR_INCORRECT_CDROM_PATH macro
PRL_ERR_INCORRECT_FDD_PATH
PRL_ERR_INCORRECT_FDD_PATH macro
PRL_ERR_INCORRECT_PATH
PRL_ERR_INCORRECT_PATH macro
PRL_ERR_INSERTING_VM_TO_CATALOGUE
PRL_ERR_INSERTING_VM_TO_CATALOGUE macro
PRL_ERR_INSTALLATION_PROBLEM
PRL_ERR_INSTALLATION_PROBLEM macro
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED
PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED macro
PRL_ERR_INVALID_ARG
PRL_ERR_INVALID_ARG macro
PRL_ERR_INVALID_CONFIGURATION
PRL_ERR_INVALID_CONFIGURATION macro
PRL_ERR_INVALID_HANDLE
PRL_ERR_INVALID_HANDLE macro
PRL_ERR_INVALID_HDD_GEOMETRY
PRL_ERR_INVALID_HDD_GEOMETRY macro
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED
PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED macro
PRL_ERR_INVALID_MEMORY_SIZE
PRL_ERR_INVALID_MEMORY_SIZE macro
PRL_ERR_INVALID_PARALLELS_DISK
PRL_ERR_INVALID_PARALLELS_DISK macro
PRL_ERR_INVALID_PARAM
PRL_ERR_INVALID_PARAM macro
PRL_ERR_IO_AUTHENTICATION_FAILED
PRL_ERR_IO_AUTHENTICATION_FAILED macro
PRL_ERR_IO_CONNECTION_TIMEOUT
PRL_ERR_IO_CONNECTION_TIMEOUT macro
PRL_ERR_IO_DISABLED
PRL_ERR_IO_DISABLED macro
PRL_ERR_IO_INVALID_POINTER_ACCESS
PRL_ERR_IO_INVALID_POINTER_ACCESS macro
PRL_ERR_IO_NO_CONNECTION
PRL_ERR_IO_NO_CONNECTION macro
PRL_ERR_IO_SEND_QUEUE_IS_FULL
PRL_ERR_IO_SEND_QUEUE_IS_FULL macro
PRL_ERR_IO_STOPPED
PRL_ERR_IO_STOPPED macro
PRL_ERR_IO_UNKNOWN_VM_ID
PRL_ERR_IO_UNKNOWN_VM_ID macro
PRL_ERR_IPFO_INVALID_MODE
PRL_ERR_IPFO_INVALID_MODE macro
PRL_ERR_IPFO_RECEIVE_FAILED
PRL_ERR_IPFO_RECEIVE_FAILED macro
PRL_ERR_IPFO_SEND_FAILED
PRL_ERR_IPFO_SEND_FAILED macro
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED
PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED macro
PRL_ERR_IPFO_SOCKET_BIND_FAILED
PRL_ERR_IPFO_SOCKET_BIND_FAILED macro
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED
PRL_ERR_IPFO_SOCKET_CONNECT_FAILED macro
PRL_ERR_IPFO_SOCKET_CREATE_FAILED
PRL_ERR_IPFO_SOCKET_CREATE_FAILED macro
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED
PRL_ERR_IPFO_SOCKET_LISTEN_FAILED macro
PRL_ERR_IPFO_SOCKET_NOT_OPENED
PRL_ERR_IPFO_SOCKET_NOT_OPENED macro
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED
PRL_ERR_IPHONE_PROXY_ALREADY_STARTED macro
PRL_ERR_IPHONE_PROXY_CANNOT_START
PRL_ERR_IPHONE_PROXY_CANNOT_START macro
PRL_ERR_IPHONE_PROXY_CANNOT_STOP
PRL_ERR_IPHONE_PROXY_CANNOT_STOP macro
PRL_ERR_LICENSE_AUTH_FAILED
PRL_ERR_LICENSE_AUTH_FAILED macro
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT
PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT macro
PRL_ERR_LICENSE_EXPIRED
PRL_ERR_LICENSE_EXPIRED macro
PRL_ERR_LICENSE_FILE_WRITE_FAILED
PRL_ERR_LICENSE_FILE_WRITE_FAILED macro
PRL_ERR_LICENSE_NOT_STARTED
PRL_ERR_LICENSE_NOT_STARTED macro
PRL_ERR_LICENSE_NOT_VALID
PRL_ERR_LICENSE_NOT_VALID macro
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT
PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT macro
PRL_ERR_LICENSE_TOO_MANY_VCPUS
PRL_ERR_LICENSE_TOO_MANY_VCPUS macro
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE macro
PRL_ERR_LICENSE_VALID
PRL_ERR_LICENSE_VALID macro
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD
PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD macro
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR
PRL_ERR_LICENSE_WRONG_DISTRIBUTOR macro
PRL_ERR_LICENSE_WRONG_LANGUAGE
PRL_ERR_LICENSE_WRONG_LANGUAGE macro
PRL_ERR_LICENSE_WRONG_PLATFORM
PRL_ERR_LICENSE_WRONG_PLATFORM macro
PRL_ERR_LICENSE_WRONG_PRODUCT
PRL_ERR_LICENSE_WRONG_PRODUCT macro
PRL_ERR_LICENSE_WRONG_VERSION
PRL_ERR_LICENSE_WRONG_VERSION macro
PRL_ERR_LOCAL_AUTHENTICATION_FAILED
PRL_ERR_LOCAL_AUTHENTICATION_FAILED macro
PRL_ERR_LPT_DEVICE_ALREADY_EXIST
PRL_ERR_LPT_DEVICE_ALREADY_EXIST macro
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED
PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED macro
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST
PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST macro
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH
PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH macro
PRL_ERR_MAC_ADDRESS_INCORRECT
PRL_ERR_MAC_ADDRESS_INCORRECT macro
PRL_ERR_MAC_ADDRESS_IS_EMPTY
PRL_ERR_MAC_ADDRESS_IS_EMPTY macro
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START
PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START macro
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS
PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS macro
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS
PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS macro
PRL_ERR_MAKE_DIRECTORY
PRL_ERR_MAKE_DIRECTORY macro
PRL_ERR_NEED_KILL_PREV_SETTING
PRL_ERR_NEED_KILL_PREV_SETTING macro
PRL_ERR_NETWORK_ROLLBACK_FAILED
PRL_ERR_NETWORK_ROLLBACK_FAILED macro
PRL_ERR_NO_BOOTING_DEVICE_SELECTED
PRL_ERR_NO_BOOTING_DEVICE_SELECTED macro
PRL_ERR_NO_CD_DRIVE_AVAILABLE
PRL_ERR_NO_CD_DRIVE_AVAILABLE macro
PRL_ERR_NO_DATA
PRL_ERR_NO_DATA macro
PRL_ERR_NO_DISP_CONFIG_FOUND
PRL_ERR_NO_DISP_CONFIG_FOUND macro
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS
PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS macro
PRL_ERR_NO_PROBLEM_REPORT_FOUND
PRL_ERR_NO_PROBLEM_REPORT_FOUND macro
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED
PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED macro
PRL_ERR_NO_TARGET_PATH_SPECIFIED
PRL_ERR_NO_TARGET_PATH_SPECIFIED macro
PRL_ERR_NO_VM_DIR_CONFIG_FOUND
PRL_ERR_NO_VM_DIR_CONFIG_FOUND macro
PRL_ERR_NOT_ALL_FILES_WAS_DELETED
PRL_ERR_NOT_ALL_FILES_WAS_DELETED macro
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER
PRL_ERR_NOT_CONNECTED_TO_DISPATCHER macro
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE
PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM macro
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE
PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE macro
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE
PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE macro
PRL_ERR_NVRAM_FILE_COPY
PRL_ERR_NVRAM_FILE_COPY macro
PRL_ERR_OBJECT_WAS_REMOVED
PRL_ERR_OBJECT_WAS_REMOVED macro
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT
PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT macro
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION
PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION macro
PRL_ERR_OPEN_DISP_CONFIG_READ
PRL_ERR_OPEN_DISP_CONFIG_READ macro
PRL_ERR_OPEN_DISP_CONFIG_WRITE
PRL_ERR_OPEN_DISP_CONFIG_WRITE macro
PRL_ERR_OPEN_PROBLEM_REPORT_READ
PRL_ERR_OPEN_PROBLEM_REPORT_READ macro
PRL_ERR_OPEN_VM_CONFIG_READ
PRL_ERR_OPEN_VM_CONFIG_READ macro
PRL_ERR_OPEN_VM_CONFIG_WRITE
PRL_ERR_OPEN_VM_CONFIG_WRITE macro
PRL_ERR_OPEN_VM_DIR_CONFIG_READ
PRL_ERR_OPEN_VM_DIR_CONFIG_READ macro
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE
PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE macro
PRL_ERR_OPERATION_FAILED
PRL_ERR_OPERATION_FAILED macro
PRL_ERR_OPERATION_PENDING
PRL_ERR_OPERATION_PENDING macro
PRL_ERR_OPERATION_WAS_CANCELED
PRL_ERR_OPERATION_WAS_CANCELED macro
PRL_ERR_OUT_OF_DISK_SPACE
PRL_ERR_OUT_OF_DISK_SPACE macro
PRL_ERR_OUT_OF_MEMORY
PRL_ERR_OUT_OF_MEMORY macro
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST
PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST macro
PRL_ERR_PARALLEL_PORT_IMG_COPY
PRL_ERR_PARALLEL_PORT_IMG_COPY macro
PRL_ERR_PARAM_NOT_FOUND
PRL_ERR_PARAM_NOT_FOUND macro
PRL_ERR_PARSE_CLIENT_PREFS
PRL_ERR_PARSE_CLIENT_PREFS macro
PRL_ERR_PARSE_COMMON_SERVER_PREFS
PRL_ERR_PARSE_COMMON_SERVER_PREFS macro
PRL_ERR_PARSE_DISP_CONFIG
PRL_ERR_PARSE_DISP_CONFIG macro
PRL_ERR_PARSE_FILESYSTEM_INFO
PRL_ERR_PARSE_FILESYSTEM_INFO macro
PRL_ERR_PARSE_HARD_DISK_HW_INFO
PRL_ERR_PARSE_HARD_DISK_HW_INFO macro
PRL_ERR_PARSE_HOST_HW_INFO
PRL_ERR_PARSE_HOST_HW_INFO macro
PRL_ERR_PARSE_PROBLEM_REPORT
PRL_ERR_PARSE_PROBLEM_REPORT macro
PRL_ERR_PARSE_STATISTICS
PRL_ERR_PARSE_STATISTICS macro
PRL_ERR_PARSE_USER_PROFILE
PRL_ERR_PARSE_USER_PROFILE macro
PRL_ERR_PARSE_VM_CONFIG
PRL_ERR_PARSE_VM_CONFIG macro
PRL_ERR_PARSE_VM_DIR_CONFIG
PRL_ERR_PARSE_VM_DIR_CONFIG macro
PRL_ERR_PARSING_EVENT
PRL_ERR_PARSING_EVENT macro
PRL_ERR_PREV_SESSION_IS_ACTIVE
PRL_ERR_PREV_SESSION_IS_ACTIVE macro
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS
PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS macro
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET
PRL_ERR_PROBLEM_REPORT_FILE_NOTSET macro
PRL_ERR_PROBLEM_REPORT_WRITE
PRL_ERR_PROBLEM_REPORT_WRITE macro
PRL_ERR_READ_XML_CONTENT
PRL_ERR_READ_XML_CONTENT macro
PRL_ERR_READONLY_FILESYSTEM
PRL_ERR_READONLY_FILESYSTEM macro
PRL_ERR_REBOOT_HOST
PRL_ERR_REBOOT_HOST macro
PRL_ERR_REMOTE_DEVICE_EXIST
PRL_ERR_REMOTE_DEVICE_EXIST macro
PRL_ERR_REMOTE_DEVICE_NOT_EXIST
PRL_ERR_REMOTE_DEVICE_NOT_EXIST macro
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED
PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED macro
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED
PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED macro
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER
PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER macro
PRL_ERR_RETRIEVE_VM_CONFIG
PRL_ERR_RETRIEVE_VM_CONFIG macro
PRL_ERR_RETURN_CODE_RANG_EEND
PRL_ERR_RETURN_CODE_RANG_EEND macro
PRL_ERR_REVERT_IMPERSONATE_FAILED
PRL_ERR_REVERT_IMPERSONATE_FAILED macro
PRL_ERR_SAVE_VM_CATALOG
PRL_ERR_SAVE_VM_CATALOG macro
PRL_ERR_SAVE_VM_CONFIG
PRL_ERR_SAVE_VM_CONFIG macro
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED
PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED macro
PRL_ERR_SEND_COMMAND_TOWS_FAILED
PRL_ERR_SEND_COMMAND_TOWS_FAILED macro
PRL_ERR_SERIAL_IMG_COPY
PRL_ERR_SERIAL_IMG_COPY macro
PRL_ERR_SERIAL_IMG_NOT_FOUND
PRL_ERR_SERIAL_IMG_NOT_FOUND macro
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST
PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST macro
PRL_ERR_SERVER_GOES_DOWN
PRL_ERR_SERVER_GOES_DOWN macro
PRL_ERR_SERVER_PREFS_EDIT_COLLISION
PRL_ERR_SERVER_PREFS_EDIT_COLLISION macro
PRL_ERR_SET_LICENSE_INVALID_ARG
PRL_ERR_SET_LICENSE_INVALID_ARG macro
PRL_ERR_SET_LICENSE_INVALID_KEY
PRL_ERR_SET_LICENSE_INVALID_KEY macro
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE
PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE macro
PRL_ERR_SMC_ERROR
PRL_ERR_SMC_ERROR macro
PRL_ERR_SNAPSHOTS_COPY
PRL_ERR_SNAPSHOTS_COPY macro
PRL_ERR_SOME_TASKS_PRESENT
PRL_ERR_SOME_TASKS_PRESENT macro
PRL_ERR_SOME_VMS_RUNNING
PRL_ERR_SOME_VMS_RUNNING macro
PRL_ERR_SOUND_DEVICE_WRITE_FAILED
PRL_ERR_SOUND_DEVICE_WRITE_FAILED macro
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED macro
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED
PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED macro
PRL_ERR_SSL_HANDSHAKE_FAILED
PRL_ERR_SSL_HANDSHAKE_FAILED macro
PRL_ERR_STATE_ALREADY_EXISTS
PRL_ERR_STATE_ALREADY_EXISTS macro
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG
PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG macro
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE
PRL_ERR_STATE_CANT_OPEN_FOR_WRITE macro
PRL_ERR_STATE_CANT_OPEN_IMAGE
PRL_ERR_STATE_CANT_OPEN_IMAGE macro
PRL_ERR_STATE_CANT_OPEN_LOCKED
PRL_ERR_STATE_CANT_OPEN_LOCKED macro
PRL_ERR_STATE_CANT_SAVE_LOCKED
PRL_ERR_STATE_CANT_SAVE_LOCKED macro
PRL_ERR_STATE_DELETE_NONCLOSED
PRL_ERR_STATE_DELETE_NONCLOSED macro
PRL_ERR_STATE_ERROR_CREATE_IMAGE
PRL_ERR_STATE_ERROR_CREATE_IMAGE macro
PRL_ERR_STATE_ERROR_RENAMING_IMAGE
PRL_ERR_STATE_ERROR_RENAMING_IMAGE macro
PRL_ERR_STATE_FULL_DELETE_FAILED
PRL_ERR_STATE_FULL_DELETE_FAILED macro
PRL_ERR_STATE_GETFREESPACE_FAILED
PRL_ERR_STATE_GETFREESPACE_FAILED macro
PRL_ERR_STATE_INT_CORRUPTED
PRL_ERR_STATE_INT_CORRUPTED macro
PRL_ERR_STATE_INVALID_IMAGE_TYPE
PRL_ERR_STATE_INVALID_IMAGE_TYPE macro
PRL_ERR_STATE_INVALID_PARAMETERS
PRL_ERR_STATE_INVALID_PARAMETERS macro
PRL_ERR_STATE_MEMORY_ERROR
PRL_ERR_STATE_MEMORY_ERROR macro
PRL_ERR_STATE_MERGE_FAILED
PRL_ERR_STATE_MERGE_FAILED macro
PRL_ERR_STATE_MERGE_NO_SPACE
PRL_ERR_STATE_MERGE_NO_SPACE macro
PRL_ERR_STATE_NO_DISKS
PRL_ERR_STATE_NO_DISKS macro
PRL_ERR_STATE_NO_STATE
PRL_ERR_STATE_NO_STATE macro
PRL_ERR_STATE_NOT_OPENED
PRL_ERR_STATE_NOT_OPENED macro
PRL_ERR_STATE_NOT_PERMITTED
PRL_ERR_STATE_NOT_PERMITTED macro
PRL_ERR_STATE_NOT_RELEASED
PRL_ERR_STATE_NOT_RELEASED macro
PRL_ERR_STATE_PROCESS_RUNNING
PRL_ERR_STATE_PROCESS_RUNNING macro
PRL_ERR_STATE_ROLLBACK_ERROR
PRL_ERR_STATE_ROLLBACK_ERROR macro
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS
PRL_ERR_STATE_ROLLBACK_IN_PROGRESS macro
PRL_ERR_STATE_STATFS_FAILED
PRL_ERR_STATE_STATFS_FAILED macro
PRL_ERR_STATE_STOPPING_STATE
PRL_ERR_STATE_STOPPING_STATE macro
PRL_ERR_STATE_UNEXPECTED_ERROR
PRL_ERR_STATE_UNEXPECTED_ERROR macro
PRL_ERR_SUCCESS
PRL_ERR_SUCCESS macro
PRL_ERR_SYMBOL_NOT_FOUND
PRL_ERR_SYMBOL_NOT_FOUND macro
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED
PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED macro
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY
PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY macro
PRL_ERR_TASK_NOT_FOUND
PRL_ERR_TASK_NOT_FOUND macro
PRL_ERR_TIMEOUT
PRL_ERR_TIMEOUT macro
PRL_ERR_TIS_INVALID_UID
PRL_ERR_TIS_INVALID_UID macro
PRL_ERR_TOO_LOW_HDD_SIZE
PRL_ERR_TOO_LOW_HDD_SIZE macro
PRL_ERR_TOOLS_UNSUPPORTED_GUEST
PRL_ERR_TOOLS_UNSUPPORTED_GUEST macro
PRL_ERR_TRY_AGAIN
PRL_ERR_TRY_AGAIN macro
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE
PRL_ERR_UNABLE_DROP_SUSPENDED_STATE macro
PRL_ERR_UNABLE_SEND_REQUEST
PRL_ERR_UNABLE_SEND_REQUEST macro
PRL_ERR_UNDER_OLD_HYPERVISOR
PRL_ERR_UNDER_OLD_HYPERVISOR macro
PRL_ERR_UNEXPECTED
PRL_ERR_UNEXPECTED macro
PRL_ERR_UNIMPLEMENTED
PRL_ERR_UNIMPLEMENTED macro
PRL_ERR_UNINITIALIZED
PRL_ERR_UNINITIALIZED macro
PRL_ERR_UNRECOGNIZED_REQUEST
PRL_ERR_UNRECOGNIZED_REQUEST macro
PRL_ERR_UNSUPPORTED_DEVICE_TYPE
PRL_ERR_UNSUPPORTED_DEVICE_TYPE macro
PRL_ERR_UNSUPPORTED_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_FILE_SYSTEM macro
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM macro
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED macro
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED
PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED macro
PRL_ERR_UPD_UPDATER_CONFIG
PRL_ERR_UPD_UPDATER_CONFIG macro
PRL_ERR_UPD_UPDATES
PRL_ERR_UPD_UPDATES macro
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED
PRL_ERR_UPDATE_MEM_VM_NOT_CREATED macro
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE
PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE macro
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART
PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART macro
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE
PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE macro
PRL_ERR_USER_DIRECTORY_NOT_SET
PRL_ERR_USER_DIRECTORY_NOT_SET macro
PRL_ERR_USER_IS_ALREADY_LOGGED
PRL_ERR_USER_IS_ALREADY_LOGGED macro
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR
PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR macro
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS
PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS macro
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM
PRL_ERR_USER_NO_AUTH_TO_EDIT_VM macro
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES
PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES macro
PRL_ERR_USER_NOT_FOUND
PRL_ERR_USER_NOT_FOUND macro
PRL_ERR_USER_OPERATION_NOT_AUTHORISED
PRL_ERR_USER_OPERATION_NOT_AUTHORISED macro
PRL_ERR_USER_PROFILE_WAS_CHANGED
PRL_ERR_USER_PROFILE_WAS_CHANGED macro
PRL_ERR_VA_CONFIG
PRL_ERR_VA_CONFIG macro
PRL_ERR_VM_ABORT
PRL_ERR_VM_ABORT macro
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED
PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED macro
PRL_ERR_VM_ALLOC_VM_MEMORY
PRL_ERR_VM_ALLOC_VM_MEMORY macro
PRL_ERR_VM_ALREADY_CONNECTED
PRL_ERR_VM_ALREADY_CONNECTED macro
PRL_ERR_VM_ALREADY_CREATED
PRL_ERR_VM_ALREADY_CREATED macro
PRL_ERR_VM_ALREADY_REGISTERED
PRL_ERR_VM_ALREADY_REGISTERED macro
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS
PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME
PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH
PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH macro
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID
PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID macro
PRL_ERR_VM_ALREADY_RESUMED
PRL_ERR_VM_ALREADY_RESUMED macro
PRL_ERR_VM_ALREADY_RUNNING
PRL_ERR_VM_ALREADY_RUNNING macro
PRL_ERR_VM_ALREADY_SUSPENDED
PRL_ERR_VM_ALREADY_SUSPENDED macro
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE
PRL_ERR_VM_ANOTHER_TOOLS_IN_USE macro
PRL_ERR_VM_APPLY_CHANGES_PENDING
PRL_ERR_VM_APPLY_CHANGES_PENDING macro
PRL_ERR_VM_APPLY_CONFIG_FAILED
PRL_ERR_VM_APPLY_CONFIG_FAILED macro
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT
PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT macro
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR
PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR macro
PRL_ERR_VM_BAD_OS_TYPE
PRL_ERR_VM_BAD_OS_TYPE macro
PRL_ERR_VM_CANT_CLONE_HDD_MISSING
PRL_ERR_VM_CANT_CLONE_HDD_MISSING macro
PRL_ERR_VM_CANT_CLONE_RUNNING
PRL_ERR_VM_CANT_CLONE_RUNNING macro
PRL_ERR_VM_CANT_DELETE_RUNNING
PRL_ERR_VM_CANT_DELETE_RUNNING macro
PRL_ERR_VM_CANT_UNREG_RUNNING
PRL_ERR_VM_CANT_UNREG_RUNNING macro
PRL_ERR_VM_COMPACT_PROCESSING
PRL_ERR_VM_COMPACT_PROCESSING macro
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG
PRL_ERR_VM_CONF_CHANGED_INVALID_ARG macro
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED
PRL_ERR_VM_CONF_CHANGED_NOT_CREATED macro
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED
PRL_ERR_VM_CONF_CHANGED_NOT_STARTED macro
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV
PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV macro
PRL_ERR_VM_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_CONFIG_ALREADY_EXISTS macro
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED
PRL_ERR_VM_CONFIG_CAN_BE_RESTORED macro
PRL_ERR_VM_CONFIG_DOESNT_EXIST
PRL_ERR_VM_CONFIG_DOESNT_EXIST macro
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID
PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID macro
PRL_ERR_VM_CONFIG_INVALID_VM_UUID
PRL_ERR_VM_CONFIG_INVALID_VM_UUID macro
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID
PRL_ERR_VM_CONFIG_IS_ALREADY_VALID macro
PRL_ERR_VM_CONFIG_WAS_CHANGED
PRL_ERR_VM_CONFIG_WAS_CHANGED macro
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER
PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER macro
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG macro
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE
PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE macro
PRL_ERR_VM_CREATE_INVALID_ARG
PRL_ERR_VM_CREATE_INVALID_ARG macro
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED
PRL_ERR_VM_CREATE_SNAPSHOT_FAILED macro
PRL_ERR_VM_DELETE_STATE_FAILED
PRL_ERR_VM_DELETE_STATE_FAILED macro
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED
PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED macro
PRL_ERR_VM_DEV_CONNECT_FAILED
PRL_ERR_VM_DEV_CONNECT_FAILED macro
PRL_ERR_VM_DEV_DISCONNECT_FAILED
PRL_ERR_VM_DEV_DISCONNECT_FAILED macro
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED
PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED macro
PRL_ERR_VM_DEVICES_TERMINATION_FAILED
PRL_ERR_VM_DEVICES_TERMINATION_FAILED macro
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS
PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS macro
PRL_ERR_VM_DIR_FILE_NOT_SET
PRL_ERR_VM_DIR_FILE_NOT_SET macro
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST
PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST macro
PRL_ERR_VM_DIRECTORY_NOT_EXIST
PRL_ERR_VM_DIRECTORY_NOT_EXIST macro
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED
PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED macro
PRL_ERR_VM_DOES_NOT_STOPPED
PRL_ERR_VM_DOES_NOT_STOPPED macro
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED
PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED macro
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS
PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS macro
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE macro
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE
PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE macro
PRL_ERR_VM_EMPTY_NAME_OF_CLONE
PRL_ERR_VM_EMPTY_NAME_OF_CLONE macro
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE
PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE macro
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND
PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND macro
PRL_ERR_VM_FILES_ALREADY_REMOVED
PRL_ERR_VM_FILES_ALREADY_REMOVED macro
PRL_ERR_VM_FREE_VM_MEMORY
PRL_ERR_VM_FREE_VM_MEMORY macro
PRL_ERR_VM_GET_CONFIG_FAILED
PRL_ERR_VM_GET_CONFIG_FAILED macro
PRL_ERR_VM_GET_CONFIG_INVALID_ARG
PRL_ERR_VM_GET_CONFIG_INVALID_ARG macro
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED
PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED macro
PRL_ERR_VM_GET_DEVICE_STATE_FAILED
PRL_ERR_VM_GET_DEVICE_STATE_FAILED macro
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG
PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG macro
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN
PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN macro
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG
PRL_ERR_VM_GET_INDICATORS_INVALID_ARG macro
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED
PRL_ERR_VM_GET_INDICATORS_NOT_CREATED macro
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING
PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING macro
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED
PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED macro
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED
PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED macro
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED
PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED macro
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING
PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING macro
PRL_ERR_VM_GET_STATUS_FAILED
PRL_ERR_VM_GET_STATUS_FAILED macro
PRL_ERR_VM_GET_STATUS_INVALID_ARG
PRL_ERR_VM_GET_STATUS_INVALID_ARG macro
PRL_ERR_VM_GUEST_SESSION_EXPIRED
PRL_ERR_VM_GUEST_SESSION_EXPIRED macro
PRL_ERR_VM_GUESTMEM_FAIL
PRL_ERR_VM_GUESTMEM_FAIL macro
PRL_ERR_VM_HDD_SIZE
PRL_ERR_VM_HDD_SIZE macro
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY
PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY macro
PRL_ERR_VM_HYPERVIZOR_COMM
PRL_ERR_VM_HYPERVIZOR_COMM macro
PRL_ERR_VM_IN_HDD_CONSTRUCTOR
PRL_ERR_VM_IN_HDD_CONSTRUCTOR macro
PRL_ERR_VM_INIT_MONITOR
PRL_ERR_VM_INIT_MONITOR macro
PRL_ERR_VM_INIT_VCPU
PRL_ERR_VM_INIT_VCPU macro
PRL_ERR_VM_INTERACT_PRLS_DRIVER
PRL_ERR_VM_INTERACT_PRLS_DRIVER macro
PRL_ERR_VM_INTERNAL_OS_ERROR
PRL_ERR_VM_INTERNAL_OS_ERROR macro
PRL_ERR_VM_INVALID_SWAP_REGION
PRL_ERR_VM_INVALID_SWAP_REGION macro
PRL_ERR_VM_IS_NOT_SUSPENDED
PRL_ERR_VM_IS_NOT_SUSPENDED macro
PRL_ERR_VM_LOAD_BINARY_FAILED
PRL_ERR_VM_LOAD_BINARY_FAILED macro
PRL_ERR_VM_LOAD_MONITOR
PRL_ERR_VM_LOAD_MONITOR macro
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS
PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS macro
PRL_ERR_VM_LOCKED_FOR_CLONE
PRL_ERR_VM_LOCKED_FOR_CLONE macro
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_DELETE
PRL_ERR_VM_LOCKED_FOR_DELETE macro
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT macro
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME
PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME macro
PRL_ERR_VM_LOCKED_FOR_EXECUTE
PRL_ERR_VM_LOCKED_FOR_EXECUTE macro
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX
PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX macro
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON
PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON macro
PRL_ERR_VM_LOCKED_FOR_MIGRATE
PRL_ERR_VM_LOCKED_FOR_MIGRATE macro
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT
PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT macro
PRL_ERR_VM_LOCKED_FOR_UNREGISTER
PRL_ERR_VM_LOCKED_FOR_UNREGISTER macro
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY
PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY macro
PRL_ERR_VM_MAP_VM_MEM0
PRL_ERR_VM_MAP_VM_MEM0 macro
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS
PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS macro
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED
PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED macro
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION
PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION macro
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET
PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE macro
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET
PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET macro
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET
PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET macro
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS
PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS macro
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET
PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET macro
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET
PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET macro
PRL_ERR_VM_MONITOR
PRL_ERR_VM_MONITOR macro
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING
PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING macro
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES
PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES macro
PRL_ERR_VM_NAME_IS_EMPTY
PRL_ERR_VM_NAME_IS_EMPTY macro
PRL_ERR_VM_NOT_CREATED
PRL_ERR_VM_NOT_CREATED macro
PRL_ERR_VM_OPERATION_FAILED
PRL_ERR_VM_OPERATION_FAILED macro
PRL_ERR_VM_PAUSE_ALREADY_PAUSED
PRL_ERR_VM_PAUSE_ALREADY_PAUSED macro
PRL_ERR_VM_PAUSE_FAILED
PRL_ERR_VM_PAUSE_FAILED macro
PRL_ERR_VM_PAUSE_NOT_CREATED
PRL_ERR_VM_PAUSE_NOT_CREATED macro
PRL_ERR_VM_PAUSE_NOT_STARTED
PRL_ERR_VM_PAUSE_NOT_STARTED macro
PRL_ERR_VM_POWER_OFF_FAILED
PRL_ERR_VM_POWER_OFF_FAILED macro
PRL_ERR_VM_POWER_ON_FAILED
PRL_ERR_VM_POWER_ON_FAILED macro
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM
PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM macro
PRL_ERR_VM_PROCESS_IS_NOT_STARTED
PRL_ERR_VM_PROCESS_IS_NOT_STARTED macro
PRL_ERR_VM_REQUEST_NOT_SUPPORTED
PRL_ERR_VM_REQUEST_NOT_SUPPORTED macro
PRL_ERR_VM_RESET_FAILED
PRL_ERR_VM_RESET_FAILED macro
PRL_ERR_VM_RESTART_GUEST_FAILED
PRL_ERR_VM_RESTART_GUEST_FAILED macro
PRL_ERR_VM_RESTART_NOT_CREATED
PRL_ERR_VM_RESTART_NOT_CREATED macro
PRL_ERR_VM_RESTART_NOT_STARTED
PRL_ERR_VM_RESTART_NOT_STARTED macro
PRL_ERR_VM_RESTORE_STATE_FAILED
PRL_ERR_VM_RESTORE_STATE_FAILED macro
PRL_ERR_VM_RESUME_FAILED
PRL_ERR_VM_RESUME_FAILED macro
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME
PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME macro
PRL_ERR_VM_SAVE_STATE_FAILED
PRL_ERR_VM_SAVE_STATE_FAILED macro
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED macro
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING macro
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED
PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED macro
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED
PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED macro
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING
PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING macro
PRL_ERR_VM_SEND_KEYBOARD_PAUSED
PRL_ERR_VM_SEND_KEYBOARD_PAUSED macro
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED
PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED macro
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING
PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING macro
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED
PRL_ERR_VM_SEND_REL_MOUSE_PAUSED macro
PRL_ERR_VM_SET_CONFIG_FAILED
PRL_ERR_VM_SET_CONFIG_FAILED macro
PRL_ERR_VM_SET_CONFIG_INVALID_ARG
PRL_ERR_VM_SET_CONFIG_INVALID_ARG macro
PRL_ERR_VM_SET_LICENSE_FAILED
PRL_ERR_VM_SET_LICENSE_FAILED macro
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED
PRL_ERR_VM_SET_VISIBLE_NOT_CREATED macro
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG
PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG macro
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE
PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE macro
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE
PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE macro
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES
PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES macro
PRL_ERR_VM_START_FAILED
PRL_ERR_VM_START_FAILED macro
PRL_ERR_VM_START_NOT_CONFIGURED
PRL_ERR_VM_START_NOT_CONFIGURED macro
PRL_ERR_VM_START_NOT_CREATED
PRL_ERR_VM_START_NOT_CREATED macro
PRL_ERR_VM_STOP_NOT_CREATED
PRL_ERR_VM_STOP_NOT_CREATED macro
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG
PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG macro
PRL_ERR_VM_SUSPEND_FAILED
PRL_ERR_VM_SUSPEND_FAILED macro
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED
PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED macro
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS
PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS macro
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART
PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART macro
PRL_ERR_VM_UNABLE_ALLOC_MEM
PRL_ERR_VM_UNABLE_ALLOC_MEM macro
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR
PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR macro
PRL_ERR_VM_UNABLE_CREATE_TIMER
PRL_ERR_VM_UNABLE_CREATE_TIMER macro
PRL_ERR_VM_UNABLE_GET_GUEST_CPU
PRL_ERR_VM_UNABLE_GET_GUEST_CPU macro
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE
PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE macro
PRL_ERR_VM_UNABLE_SEND_REQUEST
PRL_ERR_VM_UNABLE_SEND_REQUEST macro
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE
PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE macro
PRL_ERR_VM_UNDEFINED_API_CALL
PRL_ERR_VM_UNDEFINED_API_CALL macro
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED
PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED macro
PRL_ERR_VM_USER_AUTHENTICATION_FAILED
PRL_ERR_VM_USER_AUTHENTICATION_FAILED macro
PRL_ERR_VM_UUID_EMPTY
PRL_ERR_VM_UUID_EMPTY macro
PRL_ERR_VM_UUID_NOT_FOUND
PRL_ERR_VM_UUID_NOT_FOUND macro
PRL_ERR_VM_VALLOC_MON_BODY
PRL_ERR_VM_VALLOC_MON_BODY macro
PRL_ERR_VM_VALLOC_PE_IMG
PRL_ERR_VM_VALLOC_PE_IMG macro
PRL_ERR_VM_VIEW_SCR_INVALID_ARG
PRL_ERR_VM_VIEW_SCR_INVALID_ARG macro
PRL_ERR_VM_VIEW_SCR_NOT_CREATED
PRL_ERR_VM_VIEW_SCR_NOT_CREATED macro
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING
PRL_ERR_VM_VIEW_SCR_NOT_RUNNING macro
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN
PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN macro
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS
PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS macro
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE
PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE macro
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE
PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME macro
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT macro
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT
PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT macro
PRL_ERR_VMCONF_CPU_ZERO_COUNT
PRL_ERR_VMCONF_CPU_ZERO_COUNT macro
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES
PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES macro
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID macro
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE
PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE macro
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED
PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED macro
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME
PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME macro
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID
PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID macro
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE macro
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX macro
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW macro
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX
PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX macro
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE macro
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE macro
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED
PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED macro
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE
PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR
PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX macro
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS
PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS macro
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE macro
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE
PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE macro
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW macro
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW
PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS
PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS macro
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO
PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO macro
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE
PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE macro
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX
PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX macro
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST
PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST macro
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY
PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY macro
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME macro
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH macro
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME
PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME macro
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH
PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH macro
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY
PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY macro
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY
PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY macro
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE
PRL_ERR_VMCONF_UNKNOWN_OS_TYPE macro
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION
PRL_ERR_VMCONF_UNKNOWN_OS_VERSION macro
PRL_ERR_VMCONF_VALIDATION_FAILED
PRL_ERR_VMCONF_VALIDATION_FAILED macro
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE
PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE macro
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL
PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL macro
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY
PRL_ERR_VMCONF_VM_NAME_IS_EMPTY macro
PRL_ERR_VMDIR_INVALID_PATH
PRL_ERR_VMDIR_INVALID_PATH macro
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE
PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE macro
PRL_ERR_VNC_SERVER_ALREADY_STARTED
PRL_ERR_VNC_SERVER_ALREADY_STARTED macro
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED
PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED macro
PRL_ERR_VNC_SERVER_DISABLED
PRL_ERR_VNC_SERVER_DISABLED macro
PRL_ERR_VNC_SERVER_NOT_STARTED
PRL_ERR_VNC_SERVER_NOT_STARTED macro
PRL_ERR_VTD_ALREADY_HOOKED_FAILED
PRL_ERR_VTD_ALREADY_HOOKED_FAILED macro
PRL_ERR_VTD_DEVICE_NOT_MAPPED
PRL_ERR_VTD_DEVICE_NOT_MAPPED macro
PRL_ERR_VTD_HOOK_FAILED
PRL_ERR_VTD_HOOK_FAILED macro
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED
PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED macro
PRL_ERR_VTD_INITIALIZATION_FAILED
PRL_ERR_VTD_INITIALIZATION_FAILED macro
PRL_ERR_VTD_WAIT_ASR
PRL_ERR_VTD_WAIT_ASR macro
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX
PRL_ERR_VTX_ENABLED_ONLY_IN_SMX macro
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY
PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY macro
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL
PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL macro
PRL_ERR_WRONG_PROTOCOL_VERSION
PRL_ERR_WRONG_PROTOCOL_VERSION macro
PRL_ERR_WS_DISP_CONNECTION_CLOSED
PRL_ERR_WS_DISP_CONNECTION_CLOSED macro
PRL_ERR_X64GUEST_ON_X32HOST
PRL_ERR_X64GUEST_ON_X32HOST macro
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED
PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED macro
PRL_ERR_XML_WRITE_FILE
PRL_ERR_XML_WRITE_FILE macro
PRL_EVENT_HANDLER_PTR
PRL_EVENT_ISSUER_TYPE
PRL_EVENT_ISSUER_TYPE enumeration
PRL_EVENT_ISSUER_TYPE_PTR
PRL_EVENT_ISSUER_TYPE_PTR type
PRL_FAILED
PRL_FAILED macro
PRL_FALSE
PRL_FALSE macro
PRL_FILE Types
PRL_FILE_SYSTEM_ELEMENT_TYPE
PRL_FILE_SYSTEM_ELEMENT_TYPE enumeration
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR type
PRL_FILE_SYSTEM_FS_TYPE
PRL_FILE_SYSTEM_FS_TYPE enumeration
PRL_FILE_SYSTEM_FS_TYPE_PTR
PRL_FILE_SYSTEM_FS_TYPE_PTR type
PRL_FILE_SYSTEM_TYPE
PRL_FILE_SYSTEM_TYPE enumeration
PRL_FILE_SYSTEM_TYPE_PTR
PRL_FILE_SYSTEM_TYPE_PTR type
PRL_FS_ADFS enumeration member
PRL_FS_AFFS enumeration member
PRL_FS_AFS enumeration member
PRL_FS_AUTOFS enumeration member
PRL_FS_CODA enumeration member
PRL_FS_EFS enumeration member
PRL_FS_EXTFS enumeration member
PRL_FS_FAT enumeration member
PRL_FS_FAT32 enumeration member
PRL_FS_HFS enumeration member
PRL_FS_HPFS enumeration member
PRL_FS_INVALID enumeration member
PRL_FS_ISOFS enumeration member
PRL_FS_JFFS2 enumeration member
PRL_FS_NFS enumeration member
PRL_FS_NTFS enumeration member
PRL_FS_QNX4 enumeration member
PRL_FS_REISERFS enumeration member
PRL_FS_SMBFS enumeration member
PRL_FS_UNSPECIFIED enumeration member
PRL_GRACEFUL_SHUTDOWN_KIND
PRL_GRACEFUL_SHUTDOWN_KIND enumeration
PRL_GRACEFUL_SHUTDOWN_KIND_PTR
PRL_GRACEFUL_SHUTDOWN_KIND_PTR type
PRL_GUEST_DISTRO_VERSION_ENUM
PRL_GUEST_DISTRO_VERSION_ENUM enumeration
PRL_GUEST_DISTRO_VERSION_ENUM_PTR
PRL_GUEST_DISTRO_VERSION_ENUM_PTR type
PRL_GUID_PTR
PRL_GUID_PTR type
PRL_HANDLE
PRL_HANDLE type
PRL_HANDLE_PTR
PRL_HANDLE_PTR type
PRL_HANDLE_TYPE
PRL_HANDLE_TYPE enumeration
PRL_HANDLE_TYPE_PTR
PRL_HANDLE_TYPE_PTR type
PRL_HARD_DISK_INTERNAL_FORMAT
PRL_HARD_DISK_INTERNAL_FORMAT enumeration
PRL_HARD_DISK_INTERNAL_FORMAT_PTR
PRL_HARD_DISK_INTERNAL_FORMAT_PTR type
PRL_HOST_OS_TYPE
PRL_HOST_OS_TYPE enumeration
PRL_HOST_OS_TYPE_PTR
PRL_HOST_OS_TYPE_PTR type
PRL_HW_INFO_NET_ADAPTER_TYPE
PRL_HW_INFO_NET_ADAPTER_TYPE enumeration
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR type
PRL_IMAGE_BOOTCAMP
PRL_IMAGE_BOOTCAMP macro
PRL_IMAGE_COMPRESSED
PRL_IMAGE_COMPRESSED macro
PRL_IMAGE_COMPRESSED_V2
PRL_IMAGE_COMPRESSED_V2 macro
PRL_IMAGE_FORMAT
PRL_IMAGE_FORMAT enumeration
PRL_IMAGE_FORMAT_PTR
PRL_IMAGE_FORMAT_PTR type
PRL_IMAGE_INVALID
PRL_IMAGE_INVALID macro
PRL_IMAGE_LAST_INVALID
PRL_IMAGE_LAST_INVALID macro
PRL_IMAGE_PARAMETERS
PRL_IMAGE_PARAMETERS structure
PRL_IMAGE_PARAMETERS_PTR
PRL_IMAGE_PARAMETERS_PTR type
PRL_IMAGE_PARTITION
PRL_IMAGE_PARTITION macro
PRL_IMAGE_PHYSICAL
PRL_IMAGE_PHYSICAL macro
PRL_IMAGE_PLAIN
PRL_IMAGE_PLAIN macro
PRL_IMAGE_TRY_GUESS
PRL_IMAGE_TRY_GUESS macro
PRL_IMAGE_TYPE
PRL_IMAGE_TYPE type
PRL_IMAGE_TYPE_PTR
PRL_IMAGE_TYPE_PTR type
PRL_INT Types
PRL_INT16
PRL_INT16 type
PRL_INT16_PTR
PRL_INT16_PTR type
PRL_INT16_PTR_PTR
PRL_INT16_PTR_PTR type
PRL_INT32
PRL_INT32 type
PRL_INT32_PTR
PRL_INT32_PTR type
PRL_INT32_PTR_PTR
PRL_INT32_PTR_PTR type
PRL_INT64
PRL_INT64 type
PRL_INT64_PTR
PRL_INT64_PTR type
PRL_INT64_PTR_PTR
PRL_INT64_PTR_PTR type
PRL_INT8
PRL_INT8 type
PRL_INT8_PTR
PRL_INT8_PTR type
PRL_INT8_PTR_PTR
PRL_INT8_PTR_PTR type
PRL_INVALID_HANDLE
PRL_INVALID_HANDLE macro
PRL_INVALID_PARTITION
PRL_INVALID_PARTITION macro
PRL_IO Structs
PRL_IO Types
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_REQUEST structure
PRL_IO_ATTACH_REQUEST_PTR
PRL_IO_ATTACH_REQUEST_PTR type
PRL_IO_ATTACH_RESPONSE
PRL_IO_ATTACH_RESPONSE structure
PRL_IO_ATTACH_RESPONSE_PTR
PRL_IO_ATTACH_RESPONSE_PTR type
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_REQUEST structure
PRL_IO_AUTH_REQUEST_PTR
PRL_IO_AUTH_REQUEST_PTR type
PRL_IO_AUTH_RESPONSE
PRL_IO_AUTH_RESPONSE structure
PRL_IO_AUTH_RESPONSE_PTR
PRL_IO_AUTH_RESPONSE_PTR type
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DESKTOP_UTILITIES_STATE structure
PRL_IO_DESKTOP_UTILITIES_STATE_PTR
PRL_IO_DESKTOP_UTILITIES_STATE_PTR type
PRL_IO_DEVICE_USED
PRL_IO_DEVICE_USED structure
PRL_IO_DEVICE_USED_PTR
PRL_IO_DEVICE_USED_PTR type
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_PALETTE structure
PRL_IO_DISPLAY_PALETTE_PTR
PRL_IO_DISPLAY_PALETTE_PTR type
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_REGION structure
PRL_IO_DISPLAY_SCREEN_REGION_PTR
PRL_IO_DISPLAY_SCREEN_REGION_PTR type
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DISPLAY_SCREEN_SIZE structure
PRL_IO_DISPLAY_SCREEN_SIZE_PTR
PRL_IO_DISPLAY_SCREEN_SIZE_PTR type
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_DYNRES_TOOLS_STATUS structure
PRL_IO_DYNRES_TOOLS_STATUS_PTR
PRL_IO_DYNRES_TOOLS_STATUS_PTR type
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_REQUEST structure
PRL_IO_ENCODING_REQUEST_PTR
PRL_IO_ENCODING_REQUEST_PTR type
PRL_IO_ENCODING_RESPONSE
PRL_IO_ENCODING_RESPONSE structure
PRL_IO_ENCODING_RESPONSE_PTR
PRL_IO_ENCODING_RESPONSE_PTR type
PRL_IO_GENERIC_BUFFER
PRL_IO_GENERIC_BUFFER structure
PRL_IO_GENERIC_BUFFER_PTR
PRL_IO_GENERIC_BUFFER_PTR type
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GRACEFUL_SHUTDOWN structure
PRL_IO_GRACEFUL_SHUTDOWN_PTR
PRL_IO_GRACEFUL_SHUTDOWN_PTR type
PRL_IO_GUEST_SCREENSAVER_STATE
PRL_IO_GUEST_SCREENSAVER_STATE structure
PRL_IO_GUEST_SCREENSAVER_STATE_PTR
PRL_IO_GUEST_SCREENSAVER_STATE_PTR type
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_LEDS structure
PRL_IO_KEYBOARD_LEDS_PTR
PRL_IO_KEYBOARD_LEDS_PTR type
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_KEYBOARD_SCANCODE structure
PRL_IO_KEYBOARD_SCANCODE_PTR
PRL_IO_KEYBOARD_SCANCODE_PTR type
PRL_IO_MAX_DISPLAYS
PRL_IO_MAX_DISPLAYS macro
PRL_IO_MEMORY_INFO
PRL_IO_MEMORY_INFO structure
PRL_IO_MEMORY_INFO_PTR
PRL_IO_MEMORY_INFO_PTR type
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_CURSOR structure
PRL_IO_MOUSE_CURSOR_PTR
PRL_IO_MOUSE_CURSOR_PTR type
PRL_IO_MOUSE_EVENT
PRL_IO_MOUSE_EVENT structure
PRL_IO_MOUSE_EVENT_PTR
PRL_IO_MOUSE_EVENT_PTR type
PRL_IO_PALETTE
PRL_IO_PALETTE type
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_BUFFER_REGION structure
PRL_IO_SCREEN_BUFFER_REGION_PTR
PRL_IO_SCREEN_BUFFER_REGION_PTR type
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_REGION structure
PRL_IO_SCREEN_REGION_PTR
PRL_IO_SCREEN_REGION_PTR type
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SIZE structure
PRL_IO_SCREEN_SIZE_PTR
PRL_IO_SCREEN_SIZE_PTR type
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_SURFACE structure
PRL_IO_SCREEN_SURFACE_PTR
PRL_IO_SCREEN_SURFACE_PTR type
PRL_IO_SCREEN_UPDATE
PRL_IO_SCREEN_UPDATE structure
PRL_IO_SCREEN_UPDATE_PTR
PRL_IO_SCREEN_UPDATE_PTR type
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SET_TASKBAR_VISIBILITY structure
PRL_IO_SET_TASKBAR_VISIBILITY_PTR
PRL_IO_SET_TASKBAR_VISIBILITY_PTR type
PRL_IO_SLIDING_MOUSE
PRL_IO_SLIDING_MOUSE structure
PRL_IO_SLIDING_MOUSE_PTR
PRL_IO_SLIDING_MOUSE_PTR type
PRL_IO_STATE
PRL_IO_STATE enumeration
PRL_IO_STATE_PTR
PRL_IO_STATE_PTR type
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_MOVE_TASKBAR structure
PRL_IO_TOOLS_MOVE_TASKBAR_PTR
PRL_IO_TOOLS_MOVE_TASKBAR_PTR type
PRL_IO_TOOLS_SIA_DATA
PRL_IO_TOOLS_SIA_DATA structure
PRL_IO_TOOLS_SIA_DATA_PTR
PRL_IO_TOOLS_SIA_DATA_PTR type
PRL_IO_TOOLS_UTILITY_COMMAND
PRL_IO_TOOLS_UTILITY_COMMAND structure
PRL_IO_TOOLS_UTILITY_COMMAND_PTR
PRL_IO_TOOLS_UTILITY_COMMAND_PTR type
PRL_JOB_OPERATION_CODE
PRL_JOB_OPERATION_CODE enumeration
PRL_JOB_OPERATION_CODE_PTR
PRL_JOB_OPERATION_CODE_PTR type
PRL_JOB_STATUS
PRL_JOB_STATUS enumeration
PRL_JOB_STATUS_PTR
PRL_JOB_STATUS_PTR type
PRL_KEY_EVENT
PRL_KEY_EVENT enumeration
PRL_KEY_EVENT_PTR
PRL_KEY_EVENT_PTR type
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_EXTENDED_PARTITION macro
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_DATA macro
PRL_LINUX_PARTITION_SWAP
PRL_LINUX_PARTITION_SWAP macro
PRL_MACOS_PARTITION
PRL_MACOS_PARTITION macro
PRL_MASS_STORAGE_INTERFACE_TYPE
PRL_MASS_STORAGE_INTERFACE_TYPE enumeration
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR type
PRL_MESSAGE_TYPE_ENUM
PRL_MESSAGE_TYPE_ENUM enumeration
PRL_MESSAGE_TYPE_ENUM_PTR
PRL_MESSAGE_TYPE_ENUM_PTR type
PRL_METHOD
PRL_METHOD macro
PRL_METHOD_DECL
PRL_METHOD_DECL macro
PRL_METHOD_PTR
PRL_METHOD_PTR macro
PRL_MOUSE_BUTTON
PRL_MOUSE_BUTTON enumeration
PRL_MOUSE_BUTTON_PTR
PRL_MOUSE_BUTTON_PTR type
PRL_MSDOS_EXTENDED_PARTITION
PRL_MSDOS_EXTENDED_PARTITION macro
PRL_NET_ADAPTER_EMULATED_TYPE
PRL_NET_ADAPTER_EMULATED_TYPE enumeration
PRL_NET_ADAPTER_EMULATED_TYPE_PTR
PRL_NET_ADAPTER_EMULATED_TYPE_PTR type
PRL_NET_ADAPTER_NOT_EXIST
PRL_NET_ADAPTER_NOT_EXIST macro
PRL_NET_BIND_FAILED
PRL_NET_BIND_FAILED macro
PRL_NET_CABLE_DISCONNECTED
PRL_NET_CABLE_DISCONNECTED macro
PRL_NET_CONNECTION_SHARING_CONFLICT
PRL_NET_CONNECTION_SHARING_CONFLICT macro
PRL_NET_ERR_ADAPTER_CONFIG
PRL_NET_ERR_ADAPTER_CONFIG macro
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER
PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER macro
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER
PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER macro
PRL_NET_ETHLIST_CREATE_ERROR
PRL_NET_ETHLIST_CREATE_ERROR macro
PRL_NET_INSTALL_FAILED
PRL_NET_INSTALL_FAILED macro
PRL_NET_INSTALL_TIMEOUT
PRL_NET_INSTALL_TIMEOUT macro
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING
PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING macro
PRL_NET_PKTFILTER_ERROR
PRL_NET_PKTFILTER_ERROR macro
PRL_NET_PRLNET_OPEN_FAILED
PRL_NET_PRLNET_OPEN_FAILED macro
PRL_NET_RENAME_FAILED
PRL_NET_RENAME_FAILED macro
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS
PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS macro
PRL_NET_SRV_NOTIFY_ERROR
PRL_NET_SRV_NOTIFY_ERROR macro
PRL_NET_SYSTEM_ERROR
PRL_NET_SYSTEM_ERROR macro
PRL_NET_UNINSTALL_FAILED
PRL_NET_UNINSTALL_FAILED macro
PRL_NET_VIRTUAL_NETWORK_TYPE
PRL_NET_VIRTUAL_NETWORK_TYPE enumeration
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR type
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION
PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER macro
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST
PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST macro
PRL_NET_WINSCM_OPEN_ERROR
PRL_NET_WINSCM_OPEN_ERROR macro
PRL_NULL
PRL_NULL macro
PRL_PARAM_FIELD_DATA_TYPE
PRL_PARAM_FIELD_DATA_TYPE enumeration
PRL_PARAM_FIELD_DATA_TYPE_PTR
PRL_PARAM_FIELD_DATA_TYPE_PTR type
PRL_PORT_FORWARDING_TYPE
PRL_PORT_FORWARDING_TYPE enumeration
PRL_PORT_FORWARDING_TYPE_PTR
PRL_PORT_FORWARDING_TYPE_PTR type
PRL_PRIVILEGED_GUEST_OS_SESSION
PRL_PRIVILEGED_GUEST_OS_SESSION macro
PRL_PROCESS_STATE_TYPE
PRL_PROCESS_STATE_TYPE enumeration
PRL_PROCESS_STATE_TYPE_PTR
PRL_PROCESS_STATE_TYPE_PTR type
PRL_PRODUCT_ANY enumeration member
PRL_PRODUCT_DESKTOP enumeration member
PRL_PRODUCT_ENUM
PRL_PRODUCT_ENUM enumeration
PRL_PRODUCT_ENUM_PTR
PRL_PRODUCT_ENUM_PTR type
PRL_PRODUCT_SERVER enumeration member
PRL_PRODUCT_STM enumeration member
PRL_PRODUCT_WORKSTATION enumeration member
PRL_QUEST_CD_DRIVE_NOT_EXIST
PRL_QUEST_CD_DRIVE_NOT_EXIST macro
PRL_QUEST_CDD_IMAGE_NOT_EXIST
PRL_QUEST_CDD_IMAGE_NOT_EXIST macro
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY
PRL_QUEST_EXCEED_RECOMMENDED_MEMORY macro
PRL_QUEST_FDD_DRIVE_NOT_EXIST
PRL_QUEST_FDD_DRIVE_NOT_EXIST macro
PRL_QUEST_FDD_IMAGE_NOT_EXIST
PRL_QUEST_FDD_IMAGE_NOT_EXIST macro
PRL_QUEST_HDD_IMAGE_NOT_EXIST
PRL_QUEST_HDD_IMAGE_NOT_EXIST macro
PRL_QUEST_HDD_SAME_IMAGE
PRL_QUEST_HDD_SAME_IMAGE macro
PRL_QUEST_POWER_OFF
PRL_QUEST_POWER_OFF macro
PRL_QUEST_RESET
PRL_QUEST_RESET macro
PRL_QUEST_RESTART
PRL_QUEST_RESTART macro
PRL_RESULT
PRL_RESULT type
PRL_RESULT_DECLARE_ERROR
PRL_RESULT_DECLARE_ERROR macro
PRL_RESULT_DECLARE_SUCCESS
PRL_RESULT_DECLARE_SUCCESS macro
PRL_RESULT_PTR
PRL_RESULT_PTR type
prl_result_to_string
prl_result_to_string function
PRL_RUNNING_TASK_TYPE_ENUM
PRL_RUNNING_TASK_TYPE_ENUM enumeration
PRL_RUNNING_TASK_TYPE_ENUM_PTR
PRL_RUNNING_TASK_TYPE_ENUM_PTR type
PRL_SCAN_CODE Macros
PRL_SCAN_CODE_0
PRL_SCAN_CODE_0 macro
PRL_SCAN_CODE_1
PRL_SCAN_CODE_1 macro
PRL_SCAN_CODE_2
PRL_SCAN_CODE_2 macro
PRL_SCAN_CODE_3
PRL_SCAN_CODE_3 macro
PRL_SCAN_CODE_4
PRL_SCAN_CODE_4 macro
PRL_SCAN_CODE_5
PRL_SCAN_CODE_5 macro
PRL_SCAN_CODE_6
PRL_SCAN_CODE_6 macro
PRL_SCAN_CODE_7
PRL_SCAN_CODE_7 macro
PRL_SCAN_CODE_8
PRL_SCAN_CODE_8 macro
PRL_SCAN_CODE_9
PRL_SCAN_CODE_9 macro
PRL_SCAN_CODE_A
PRL_SCAN_CODE_A macro
PRL_SCAN_CODE_ALT_LEFT
PRL_SCAN_CODE_ALT_LEFT macro
PRL_SCAN_CODE_ALT_RIGHT
PRL_SCAN_CODE_ALT_RIGHT macro
PRL_SCAN_CODE_B
PRL_SCAN_CODE_B macro
PRL_SCAN_CODE_BACKSLASH
PRL_SCAN_CODE_BACKSLASH macro
PRL_SCAN_CODE_BACKSPACE
PRL_SCAN_CODE_BACKSPACE macro
PRL_SCAN_CODE_C
PRL_SCAN_CODE_C macro
PRL_SCAN_CODE_CAPS_LOCK
PRL_SCAN_CODE_CAPS_LOCK macro
PRL_SCAN_CODE_CBRACE_LEFT
PRL_SCAN_CODE_CBRACE_LEFT macro
PRL_SCAN_CODE_CBRACE_RIGHT
PRL_SCAN_CODE_CBRACE_RIGHT macro
PRL_SCAN_CODE_CMD_LEFT
PRL_SCAN_CODE_CMD_LEFT macro
PRL_SCAN_CODE_CMD_RIGHT
PRL_SCAN_CODE_CMD_RIGHT macro
PRL_SCAN_CODE_COLON
PRL_SCAN_CODE_COLON macro
PRL_SCAN_CODE_CTRL_LEFT
PRL_SCAN_CODE_CTRL_LEFT macro
PRL_SCAN_CODE_CTRL_RIGHT
PRL_SCAN_CODE_CTRL_RIGHT macro
PRL_SCAN_CODE_D
PRL_SCAN_CODE_D macro
PRL_SCAN_CODE_DELETE
PRL_SCAN_CODE_DELETE macro
PRL_SCAN_CODE_DOWN
PRL_SCAN_CODE_DOWN macro
PRL_SCAN_CODE_E
PRL_SCAN_CODE_E macro
PRL_SCAN_CODE_ENTER
PRL_SCAN_CODE_ENTER macro
PRL_SCAN_CODE_ESC
PRL_SCAN_CODE_ESC macro
PRL_SCAN_CODE_F
PRL_SCAN_CODE_F macro
PRL_SCAN_CODE_F1
PRL_SCAN_CODE_F1 macro
PRL_SCAN_CODE_F10
PRL_SCAN_CODE_F10 macro
PRL_SCAN_CODE_F11
PRL_SCAN_CODE_F11 macro
PRL_SCAN_CODE_F12
PRL_SCAN_CODE_F12 macro
PRL_SCAN_CODE_F2
PRL_SCAN_CODE_F2 macro
PRL_SCAN_CODE_F3
PRL_SCAN_CODE_F3 macro
PRL_SCAN_CODE_F4
PRL_SCAN_CODE_F4 macro
PRL_SCAN_CODE_F5
PRL_SCAN_CODE_F5 macro
PRL_SCAN_CODE_F6
PRL_SCAN_CODE_F6 macro
PRL_SCAN_CODE_F7
PRL_SCAN_CODE_F7 macro
PRL_SCAN_CODE_F8
PRL_SCAN_CODE_F8 macro
PRL_SCAN_CODE_F9
PRL_SCAN_CODE_F9 macro
PRL_SCAN_CODE_G
PRL_SCAN_CODE_G macro
PRL_SCAN_CODE_GREATER
PRL_SCAN_CODE_GREATER macro
PRL_SCAN_CODE_H
PRL_SCAN_CODE_H macro
PRL_SCAN_CODE_I
PRL_SCAN_CODE_I macro
PRL_SCAN_CODE_INSERT
PRL_SCAN_CODE_INSERT macro
PRL_SCAN_CODE_J
PRL_SCAN_CODE_J macro
PRL_SCAN_CODE_K
PRL_SCAN_CODE_K macro
PRL_SCAN_CODE_L
PRL_SCAN_CODE_L macro
PRL_SCAN_CODE_LEFT
PRL_SCAN_CODE_LEFT macro
PRL_SCAN_CODE_LESS
PRL_SCAN_CODE_LESS macro
PRL_SCAN_CODE_M
PRL_SCAN_CODE_M macro
PRL_SCAN_CODE_MENU
PRL_SCAN_CODE_MENU macro
PRL_SCAN_CODE_MINUS
PRL_SCAN_CODE_MINUS macro
PRL_SCAN_CODE_N
PRL_SCAN_CODE_N macro
PRL_SCAN_CODE_NUM_LOCK
PRL_SCAN_CODE_NUM_LOCK macro
PRL_SCAN_CODE_O
PRL_SCAN_CODE_O macro
PRL_SCAN_CODE_P
PRL_SCAN_CODE_P macro
PRL_SCAN_CODE_PAD_0
PRL_SCAN_CODE_PAD_0 macro
PRL_SCAN_CODE_PAD_1
PRL_SCAN_CODE_PAD_1 macro
PRL_SCAN_CODE_PAD_2
PRL_SCAN_CODE_PAD_2 macro
PRL_SCAN_CODE_PAD_3
PRL_SCAN_CODE_PAD_3 macro
PRL_SCAN_CODE_PAD_4
PRL_SCAN_CODE_PAD_4 macro
PRL_SCAN_CODE_PAD_5
PRL_SCAN_CODE_PAD_5 macro
PRL_SCAN_CODE_PAD_6
PRL_SCAN_CODE_PAD_6 macro
PRL_SCAN_CODE_PAD_7
PRL_SCAN_CODE_PAD_7 macro
PRL_SCAN_CODE_PAD_8
PRL_SCAN_CODE_PAD_8 macro
PRL_SCAN_CODE_PAD_9
PRL_SCAN_CODE_PAD_9 macro
PRL_SCAN_CODE_PAD_DEL
PRL_SCAN_CODE_PAD_DEL macro
PRL_SCAN_CODE_PAD_ENTER
PRL_SCAN_CODE_PAD_ENTER macro
PRL_SCAN_CODE_PAD_MINUS
PRL_SCAN_CODE_PAD_MINUS macro
PRL_SCAN_CODE_PAD_PLUS
PRL_SCAN_CODE_PAD_PLUS macro
PRL_SCAN_CODE_PAD_SLASH
PRL_SCAN_CODE_PAD_SLASH macro
PRL_SCAN_CODE_PAD_STAR
PRL_SCAN_CODE_PAD_STAR macro
PRL_SCAN_CODE_PAUSE_BREAK
PRL_SCAN_CODE_PAUSE_BREAK macro
PRL_SCAN_CODE_PLUS
PRL_SCAN_CODE_PLUS macro
PRL_SCAN_CODE_PRINT_SCREEN
PRL_SCAN_CODE_PRINT_SCREEN macro
PRL_SCAN_CODE_Q
PRL_SCAN_CODE_Q macro
PRL_SCAN_CODE_QUOTE
PRL_SCAN_CODE_QUOTE macro
PRL_SCAN_CODE_R
PRL_SCAN_CODE_R macro
PRL_SCAN_CODE_RIGHT
PRL_SCAN_CODE_RIGHT macro
PRL_SCAN_CODE_S
PRL_SCAN_CODE_S macro
PRL_SCAN_CODE_SCROLL_LOCK
PRL_SCAN_CODE_SCROLL_LOCK macro
PRL_SCAN_CODE_SHIFT_LEFT
PRL_SCAN_CODE_SHIFT_LEFT macro
PRL_SCAN_CODE_SHIFT_RIGHT
PRL_SCAN_CODE_SHIFT_RIGHT macro
PRL_SCAN_CODE_SLASH
PRL_SCAN_CODE_SLASH macro
PRL_SCAN_CODE_SPACE
PRL_SCAN_CODE_SPACE macro
PRL_SCAN_CODE_T
PRL_SCAN_CODE_T macro
PRL_SCAN_CODE_TAB
PRL_SCAN_CODE_TAB macro
PRL_SCAN_CODE_TILDA
PRL_SCAN_CODE_TILDA macro
PRL_SCAN_CODE_U
PRL_SCAN_CODE_U macro
PRL_SCAN_CODE_UP
PRL_SCAN_CODE_UP macro
PRL_SCAN_CODE_V
PRL_SCAN_CODE_V macro
PRL_SCAN_CODE_W
PRL_SCAN_CODE_W macro
PRL_SCAN_CODE_X
PRL_SCAN_CODE_X macro
PRL_SCAN_CODE_Y
PRL_SCAN_CODE_Y macro
PRL_SCAN_CODE_Z
PRL_SCAN_CODE_Z macro
PRL_SECURITY_LEVEL
PRL_SECURITY_LEVEL enumeration
PRL_SECURITY_LEVEL_PTR
PRL_SECURITY_LEVEL_PTR type
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE enumeration
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR type
PRL_SERVICE_STATUS_ENUM
PRL_SERVICE_STATUS_ENUM enumeration
PRL_SERVICE_STATUS_ENUM_PTR
PRL_SERVICE_STATUS_ENUM_PTR type
PRL_SIZE
PRL_SIZE type
PRL_SIZE_PTR
PRL_SIZE_PTR type
PRL_SIZE_PTR_PTR
PRL_SIZE_PTR_PTR type
PRL_SNAPSHOT_ELEMENT
PRL_SNAPSHOT_ELEMENT structure
PRL_SNAPSHOT_ELEMENT_PTR
PRL_SNAPSHOT_ELEMENT_PTR type
PRL_SRV_METHOD_DECL
PRL_SRV_METHOD_DECL macro
PRL_STATE_CALLBACK_INVALID
PRL_STATE_CALLBACK_INVALID macro
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK macro
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK macro
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK macro
PRL_STATE_DISK_CALLBACK
PRL_STATE_DISK_CALLBACK macro
PRL_STATE_DISK_CALLBACK_STAGE_CPL
PRL_STATE_DISK_CALLBACK_STAGE_CPL macro
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_COMPLETED macro
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MAX macro
PRL_STATE_PROGRESS_MIN
PRL_STATE_PROGRESS_MIN macro
PRL_STATES_CALLBACK
PRL_STATES_CALLBACK_TYPE
PRL_STATES_CALLBACK_TYPE type
PRL_STATES_CALLBACK_TYPE_PTR
PRL_STATES_CALLBACK_TYPE_PTR type
PRL_STR
PRL_STR type
PRL_STRUCT
PRL_STRUCT macro
PRL_SUCCEEDED
PRL_SUCCEEDED macro
PRL_TIS Types
PRL_TIS_INT_VERSION
PRL_TIS_INT_VERSION structure
PRL_TIS_INT_VERSION_PTR
PRL_TIS_INT_VERSION_PTR type
PRL_TIS_RECORD_ACTION
PRL_TIS_RECORD_ACTION enumeration
PRL_TIS_RECORD_ACTION_PTR
PRL_TIS_RECORD_ACTION_PTR type
PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO structure
PRL_TIS_RECORD_INFO_PTR
PRL_TIS_RECORD_INFO_PTR type
PRL_TIS_RECORD_STATE
PRL_TIS_RECORD_STATE enumeration
PRL_TIS_RECORD_STATE_PTR
PRL_TIS_RECORD_STATE_PTR type
PRL_TIS_VERSION
PRL_TIS_VERSION structure
PRL_TIS_VERSION_PTR
PRL_TIS_VERSION_PTR type
PRL_TOOLS Types
PRL_TOOLS_SIA_OPEN_IN_TYPES
PRL_TOOLS_SIA_OPEN_IN_TYPES enumeration
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR type
PRL_TOOLS_UTILITY_COMMAND_FLAG
PRL_TOOLS_UTILITY_COMMAND_FLAG enumeration
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR type
PRL_TOOLS_UTILITY_COMMAND_ID
PRL_TOOLS_UTILITY_COMMAND_ID enumeration
PRL_TOOLS_UTILITY_COMMAND_ID_PTR
PRL_TOOLS_UTILITY_COMMAND_ID_PTR type
PRL_TRUE
PRL_TRUE macro
PRL_UINT Types
PRL_UINT16
PRL_UINT16 type
PRL_UINT16_PTR
PRL_UINT16_PTR type
PRL_UINT16_PTR_PTR
PRL_UINT16_PTR_PTR type
PRL_UINT32
PRL_UINT32 type
PRL_UINT32_PTR
PRL_UINT32_PTR type
PRL_UINT32_PTR_PTR
PRL_UINT32_PTR_PTR type
PRL_UINT64
PRL_UINT64 type
PRL_UINT64_PTR
PRL_UINT64_PTR type
PRL_UINT64_PTR_PTR
PRL_UINT64_PTR_PTR type
PRL_UINT8
PRL_UINT8 type
PRL_UINT8_PTR
PRL_UINT8_PTR type
PRL_UINT8_PTR_PTR
PRL_UINT8_PTR_PTR type
PRL_UNDO_DISKS_MODE
PRL_UNDO_DISKS_MODE enumeration
PRL_UNDO_DISKS_MODE_PTR
PRL_UNDO_DISKS_MODE_PTR type
PRL_USB_DEVICE_AUTO_CONNECT_OPTION
PRL_USB_DEVICE_AUTO_CONNECT_OPTION enumeration
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR type
PRL_USB_DEVICE_CONNECT_REASON
PRL_USB_DEVICE_CONNECT_REASON enumeration
PRL_USB_DEVICE_CONNECT_REASON_PTR
PRL_USB_DEVICE_CONNECT_REASON_PTR type
PRL_VERSION_3X enumeration member
PRL_VERSION_4X enumeration member
PRL_VERSION_ANY enumeration member
PRL_VERSION_ENUM
PRL_VERSION_ENUM enumeration
PRL_VERSION_ENUM_PTR
PRL_VERSION_ENUM_PTR type
PRL_VM Structs
PRL_VM Types
PRL_VM_ACCELERATION_LEVEL
PRL_VM_ACCELERATION_LEVEL enumeration
PRL_VM_ACCELERATION_LEVEL_PTR
PRL_VM_ACCELERATION_LEVEL_PTR type
PRL_VM_ACCESS_FOR_OTHERS
PRL_VM_ACCESS_FOR_OTHERS enumeration
PRL_VM_ACCESS_FOR_OTHERS_PTR
PRL_VM_ACCESS_FOR_OTHERS_PTR type
PRL_VM_ACTION_ON_WINDOW_CLOSE
PRL_VM_ACTION_ON_WINDOW_CLOSE enumeration
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR type
PRL_VM_AUTOSTART_OPTION
PRL_VM_AUTOSTART_OPTION enumeration
PRL_VM_AUTOSTART_OPTION_PTR
PRL_VM_AUTOSTART_OPTION_PTR type
PRL_VM_AUTOSTOP_OPTION
PRL_VM_AUTOSTOP_OPTION enumeration
PRL_VM_AUTOSTOP_OPTION_PTR
PRL_VM_AUTOSTOP_OPTION_PTR type
PRL_VM_BOOT_ORDER
PRL_VM_BOOT_ORDER enumeration
PRL_VM_BOOT_ORDER_PTR
PRL_VM_BOOT_ORDER_PTR type
PRL_VM_CONFIG_SECTIONS
PRL_VM_CONFIG_SECTIONS enumeration
PRL_VM_CONFIG_SECTIONS_PTR
PRL_VM_CONFIG_SECTIONS_PTR type
PRL_VM_DEV_EMULATION_TYPE
PRL_VM_DEV_EMULATION_TYPE enumeration
PRL_VM_DEV_EMULATION_TYPE_PTR
PRL_VM_DEV_EMULATION_TYPE_PTR type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR
PRL_VM_EXEC_APP_FILE_DESCRIPTOR enumeration
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR type
PRL_VM_EXEC_RUN_PROGRAM_MODES
PRL_VM_EXEC_RUN_PROGRAM_MODES enumeration
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR type
PRL_VM_MIGRATION_SECURITY_LEVEL
PRL_VM_MIGRATION_SECURITY_LEVEL enumeration
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR type
PRL_VM_MIGRATION_TYPE
PRL_VM_MIGRATION_TYPE enumeration
PRL_VM_MIGRATION_TYPE_PTR
PRL_VM_MIGRATION_TYPE_PTR type
PRL_VM_PRIORITY
PRL_VM_PRIORITY enumeration
PRL_VM_PRIORITY_PTR
PRL_VM_PRIORITY_PTR type
PRL_VM_REMOTE_DISPLAY_MODE
PRL_VM_REMOTE_DISPLAY_MODE enumeration
PRL_VM_REMOTE_DISPLAY_MODE_PTR
PRL_VM_REMOTE_DISPLAY_MODE_PTR type
PRL_VM_START_LOGIN_MODE
PRL_VM_START_LOGIN_MODE enumeration
PRL_VM_START_LOGIN_MODE_PTR
PRL_VM_START_LOGIN_MODE_PTR type
PRL_VM_START_MODE
PRL_VM_START_MODE enumeration
PRL_VM_START_MODE_PTR
PRL_VM_START_MODE_PTR type
PRL_VM_TOOLS_STATE
PRL_VM_TOOLS_STATE enumeration
PRL_VM_TOOLS_STATE_PTR
PRL_VM_TOOLS_STATE_PTR type
PRL_VM_WINDOW_MODE
PRL_VM_WINDOW_MODE enumeration
PRL_VM_WINDOW_MODE_PTR
PRL_VM_WINDOW_MODE_PTR type
PRL_VOID
PRL_VOID type
PRL_VOID Types
PRL_VOID_PTR
PRL_VOID_PTR type
PRL_VOID_PTR_PTR
PRL_VOID_PTR_PTR type
PRL_WARN_COMPACT_DESTRUCTIVE
PRL_WARN_COMPACT_DESTRUCTIVE macro
PRL_WARN_COMPACT_THROUGH_COPY
PRL_WARN_COMPACT_THROUGH_COPY macro
PRL_WARN_FAILED_TO_START_VNC_SERVER
PRL_WARN_FAILED_TO_START_VNC_SERVER macro
PRL_WARN_FAT32_FILE_OVERRUN
PRL_WARN_FAT32_FILE_OVERRUN macro
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT
PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT macro
PRL_WARN_HDD_ERROR
PRL_WARN_HDD_ERROR macro
PRL_WARN_IMAGE_IS_STOLEN
PRL_WARN_IMAGE_IS_STOLEN macro
PRL_WARN_LAN_NOT_CONNECTED
PRL_WARN_LAN_NOT_CONNECTED macro
PRL_WARN_TARGET_HOST_DISK_IS_FULL
PRL_WARN_TARGET_HOST_DISK_IS_FULL macro
PRL_WARN_TOO_LOW_HDD_SIZE
PRL_WARN_TOO_LOW_HDD_SIZE macro
PRL_WARN_UNABLE_OPEN_DEVICE
PRL_WARN_UNABLE_OPEN_DEVICE macro
PRL_WARN_UNABLE_OPEN_DEVICE_NAME
PRL_WARN_UNABLE_OPEN_DEVICE_NAME macro
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE
PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE macro
PRL_WARN_VM_BOOTCAMP_MODE
PRL_WARN_VM_BOOTCAMP_MODE macro
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV
PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV macro
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST
PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST macro
PRL_WARN_VM_PD3_COMPAT_MODE
PRL_WARN_VM_PD3_COMPAT_MODE macro
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE
PRL_WARN_VM_PD3_COMPAT_NO_MOUSE macro
PRL_WIN_EXTENDED_PARTITION
PRL_WIN_EXTENDED_PARTITION macro
PRL_WINDOW_EDGE_MASK
PRL_WINDOW_EDGE_MASK enumeration
PRL_WINDOW_EDGE_MASK_PTR
PRL_WINDOW_EDGE_MASK_PTR type
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT macro
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32 macro
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_FAT32_LBA macro
PRL_WINDOWS_PARTITION_NTFS
PRL_WINDOWS_PARTITION_NTFS macro
PRL_WNG_START_VM_ON_MOUNTED_DISK
PRL_WNG_START_VM_ON_MOUNTED_DISK macro
PrlAcl_GetAccessForOthers
PrlAcl_GetAccessForOthers function
PrlAcl_GetOwnerName
PrlAcl_GetOwnerName function
PrlAcl_IsAllowed
PrlAcl_IsAllowed function
PrlAcl_IsCurrentSessionOwner
PrlAcl_IsCurrentSessionOwner function
PrlAcl_SetAccessForOthers
PrlAcl_SetAccessForOthers function
PrlApi.h
PrlApi_AddRemoteDevCommandBuffer
PrlApi_AddRemoteDevCommandBuffer function
PrlApi_AddRemoteDevCommandParam
PrlApi_AddRemoteDevCommandParam function
PrlApi_CreateHandlesList
PrlApi_CreateHandlesList function
PrlApi_CreateRemoteCommand
PrlApi_CreateRemoteCommand function
PrlApi_CreateRemoteDevCommand
PrlApi_CreateRemoteDevCommand function
PrlApi_CreateStringsList
PrlApi_CreateStringsList function
PrlApi_Deinit
PrlApi_Deinit function
PrlApi_GetAppMode
PrlApi_GetAppMode function
PrlApi_GetMessageType
PrlApi_GetMessageType function
PrlApi_GetRecommendMinVmMem
PrlApi_GetRecommendMinVmMem function
PrlApi_GetRemoteCommandBuffer
PrlApi_GetRemoteCommandBuffer function
PrlApi_GetRemoteCommandCode
PrlApi_GetRemoteCommandCode function
PrlApi_GetRemoteCommandIndex
PrlApi_GetRemoteCommandIndex function
PrlApi_GetRemoteCommandTarget
PrlApi_GetRemoteCommandTarget function
PrlApi_GetRemoteDeviceRegistration
PrlApi_GetRemoteDeviceRegistration function
PrlApi_GetResultDescription
PrlApi_GetResultDescription function
PrlApi_GetVersion
PrlApi_GetVersion function
PrlApi_Init
PrlApi_Init function
PrlApi_InitEx
PrlApi_InitEx function
PrlApi_MsgCanBeIgnored
PrlApi_MsgCanBeIgnored function
PrlApi_RegisterRemoteDevice
PrlApi_RegisterRemoteDevice function
PrlApi_ScaleImage
PrlApi_ScaleImage function
PrlApi_SendRemoteCommand
PrlApi_SendRemoteCommand function
PrlApi_SendRemoteDeviceCommand
PrlApi_SendRemoteDeviceCommand function
PrlApi_UnregisterRemoteDevice
PrlApi_UnregisterRemoteDevice function
PrlApiMacro.h
PrlBootDev_GetIndex
PrlBootDev_GetIndex function
PrlBootDev_GetSequenceIndex
PrlBootDev_GetSequenceIndex function
PrlBootDev_GetType
PrlBootDev_GetType function
PrlBootDev_IsInUse
PrlBootDev_IsInUse function
PrlBootDev_Remove
PrlBootDev_Remove function
PrlBootDev_SetIndex
PrlBootDev_SetIndex function
PrlBootDev_SetInUse
PrlBootDev_SetInUse function
PrlBootDev_SetSequenceIndex
PrlBootDev_SetSequenceIndex function
PrlBootDev_SetType
PrlBootDev_SetType function
PrlBuffer
PrlBuffer_Free
PrlBuffer_Free function
PrlDbg_EventTypeToString
PrlDbg_EventTypeToString function
PrlDbg_GetHandlesNum
PrlDbg_GetHandlesNum function
PrlDbg_HandleTypeToString
PrlDbg_HandleTypeToString function
PrlDbg_PrlResultToString
PrlDbg_PrlResultToString function
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer function
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile function
PrlDevDisplay_AsyncCaptureScreenRegionToFile
PrlDevDisplay_AsyncCaptureScreenRegionToFile function
PrlDevDisplay_ConnectToVm
PrlDevDisplay_ConnectToVm function
PrlDevDisplay_DisconnectFromVm
PrlDevDisplay_DisconnectFromVm function
PrlDevDisplay_GetDynResToolStatus
PrlDevDisplay_GetDynResToolStatus function
PrlDevDisplay_GetScreenBuffer
PrlDevDisplay_GetScreenBuffer function
PrlDevDisplay_GetScreenSize
PrlDevDisplay_GetScreenSize function
PrlDevDisplay_IsSlidingMouseEnabled
PrlDevDisplay_IsSlidingMouseEnabled function
PrlDevDisplay_LockForRead
PrlDevDisplay_LockForRead function
PrlDevDisplay_NeedCursorData
PrlDevDisplay_NeedCursorData function
PrlDevDisplay_SendCaptureScreenRequest
PrlDevDisplay_SendCaptureScreenRequest function
PrlDevDisplay_SendScreenSizeEvent
PrlDevDisplay_SendScreenSizeEvent function
PrlDevDisplay_SetScreenSurface
PrlDevDisplay_SetScreenSurface function
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer function
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile function
PrlDevDisplay_SyncCaptureScreenRegionToFile
PrlDevDisplay_SyncCaptureScreenRegionToFile function
PrlDevDisplay_Unlock
PrlDevDisplay_Unlock function
PrlDevKeyboard_SendKeyEvent
PrlDevKeyboard_SendKeyEvent function
PrlDevMouse_Move
PrlDevMouse_Move function
PrlDevMouse_SetPos
PrlDevMouse_SetPos function
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer function
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile function
PrlDevSecondaryDisplay_GetScreenBuffer
PrlDevSecondaryDisplay_GetScreenBuffer function
PrlDevSecondaryDisplay_GetScreenSize
PrlDevSecondaryDisplay_GetScreenSize function
PrlDevSecondaryDisplay_SendCaptureScreenRequest
PrlDevSecondaryDisplay_SendCaptureScreenRequest function
PrlDevSecondaryDisplay_SendScreenSizeEvent
PrlDevSecondaryDisplay_SendScreenSizeEvent function
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer function
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile function
PrlDisk.h
PrlDisk_Coagulate
PrlDisk_Coagulate function
PrlDisk_Compact
PrlDisk_Compact function
PrlDisk_ConvertToCurrent
PrlDisk_ConvertToCurrent function
PrlDisk_ConvertToCurrent_Local
PrlDisk_ConvertToCurrent_Local function
PrlDisk_CreateDisk
PrlDisk_CreateDisk function
PrlDisk_CreateDisk_Local
PrlDisk_CreateDisk_Local function
PrlDisk_CreateState
PrlDisk_CreateState function
PrlDisk_DecreaseCapacity
PrlDisk_DecreaseCapacity function
PrlDisk_DeleteState
PrlDisk_DeleteState function
PrlDisk_FlushCache
PrlDisk_FlushCache function
PrlDisk_Free
PrlDisk_Free function
PrlDisk_GetDiskInfo
PrlDisk_GetDiskInfo function
PrlDisk_GetSnapshotsCount
PrlDisk_GetSnapshotsCount function
PrlDisk_GetSnapshotsTree
PrlDisk_GetSnapshotsTree function
PrlDisk_GetUserParameter
PrlDisk_GetUserParameter function
PrlDisk_IncreaseCapacity
PrlDisk_IncreaseCapacity function
PrlDisk_IsCompactable
PrlDisk_IsCompactable function
PrlDisk_OpenDisk
PrlDisk_OpenDisk function
PrlDisk_OpenDisk_Local
PrlDisk_OpenDisk_Local function
PrlDisk_Read
PrlDisk_Read function
PrlDisk_SetCachingPolicy
PrlDisk_SetCachingPolicy function
PrlDisk_SetSharedDirectory
PrlDisk_SetSharedDirectory function
PrlDisk_SetSharedDirectory_Local
PrlDisk_SetSharedDirectory_Local function
PrlDisk_SetUserParameter
PrlDisk_SetUserParameter function
PrlDisk_SwitchToState
PrlDisk_SwitchToState function
PrlDisk_WaitForCompletion
PrlDisk_WaitForCompletion function
PrlDisk_Write
PrlDisk_Write function
PrlDispCfg_CanChangeDefaultSettings
PrlDispCfg_CanChangeDefaultSettings function
PrlDispCfg_CreateDispNet
PrlDispCfg_CreateDispNet function
PrlDispCfg_GetDefaultVmDir
PrlDispCfg_GetDefaultVmDir function
PrlDispCfg_GetDefaultVNCHostName
PrlDispCfg_GetDefaultVNCHostName function
PrlDispCfg_GetDispNet
PrlDispCfg_GetDispNet function
PrlDispCfg_GetDispNetCount
PrlDispCfg_GetDispNetCount function
PrlDispCfg_GetMaxReservMemLimit
PrlDispCfg_GetMaxReservMemLimit function
PrlDispCfg_GetMaxVmMem
PrlDispCfg_GetMaxVmMem function
PrlDispCfg_GetMinReservMemLimit
PrlDispCfg_GetMinReservMemLimit function
PrlDispCfg_GetMinSecurityLevel
PrlDispCfg_GetMinSecurityLevel function
PrlDispCfg_GetMinVmMem
PrlDispCfg_GetMinVmMem function
PrlDispCfg_GetRecommendMaxVmMem
PrlDispCfg_GetRecommendMaxVmMem function
PrlDispCfg_GetReservedMemLimit
PrlDispCfg_GetReservedMemLimit function
PrlDispCfg_GetVNCBasePort
PrlDispCfg_GetVNCBasePort function
PrlDispCfg_IsAdjustMemAuto
PrlDispCfg_IsAdjustMemAuto function
PrlDispCfg_SetAdjustMemAuto
PrlDispCfg_SetAdjustMemAuto function
PrlDispCfg_SetCanChangeDefaultSettings
PrlDispCfg_SetCanChangeDefaultSettings function
PrlDispCfg_SetDefaultVNCHostName
PrlDispCfg_SetDefaultVNCHostName function
PrlDispCfg_SetMaxReservMemLimit
PrlDispCfg_SetMaxReservMemLimit function
PrlDispCfg_SetMaxVmMem
PrlDispCfg_SetMaxVmMem function
PrlDispCfg_SetMinReservMemLimit
PrlDispCfg_SetMinReservMemLimit function
PrlDispCfg_SetMinSecurityLevel
PrlDispCfg_SetMinSecurityLevel function
PrlDispCfg_SetMinVmMem
PrlDispCfg_SetMinVmMem function
PrlDispCfg_SetRecommendMaxVmMem
PrlDispCfg_SetRecommendMaxVmMem function
PrlDispCfg_SetReservedMemLimit
PrlDispCfg_SetReservedMemLimit function
PrlDispCfg_SetVNCBasePort
PrlDispCfg_SetVNCBasePort function
PrlDispNet_GetDhcpScopeEndIp
PrlDispNet_GetDhcpScopeEndIp function
PrlDispNet_GetDhcpScopeMask
PrlDispNet_GetDhcpScopeMask function
PrlDispNet_GetDhcpScopeStartIp
PrlDispNet_GetDhcpScopeStartIp function
PrlDispNet_GetIndex
PrlDispNet_GetIndex function
PrlDispNet_GetName
PrlDispNet_GetName function
PrlDispNet_GetNetworkType
PrlDispNet_GetNetworkType function
PrlDispNet_GetSysName
PrlDispNet_GetSysName function
PrlDispNet_GetUuid
PrlDispNet_GetUuid function
PrlDispNet_IsDhcpEnabled
PrlDispNet_IsDhcpEnabled function
PrlDispNet_IsEnabled
PrlDispNet_IsEnabled function
PrlDispNet_Remove
PrlDispNet_Remove function
PrlDispNet_SetDhcpEnabled
PrlDispNet_SetDhcpEnabled function
PrlDispNet_SetDhcpScopeEndIp
PrlDispNet_SetDhcpScopeEndIp function
PrlDispNet_SetDhcpScopeMask
PrlDispNet_SetDhcpScopeMask function
PrlDispNet_SetDhcpScopeStartIp
PrlDispNet_SetDhcpScopeStartIp function
PrlDispNet_SetEnabled
PrlDispNet_SetEnabled function
PrlDispNet_SetIndex
PrlDispNet_SetIndex function
PrlDispNet_SetName
PrlDispNet_SetName function
PrlDispNet_SetNetworkType
PrlDispNet_SetNetworkType function
PrlDispNet_SetSysName
PrlDispNet_SetSysName function
PrlEnums.h
PrlErrors.h
PrlErrorsValues.h
PrlEvent_CanBeIgnored
PrlEvent_CanBeIgnored function
PrlEvent_CreateAnswerEvent
PrlEvent_CreateAnswerEvent function
PrlEvent_GetDataPtr
PrlEvent_GetDataPtr function
PrlEvent_GetErrCode
PrlEvent_GetErrCode function
PrlEvent_GetErrString
PrlEvent_GetErrString function
PrlEvent_GetIssuerId
PrlEvent_GetIssuerId function
PrlEvent_GetIssuerType
PrlEvent_GetIssuerType function
PrlEvent_GetJob
PrlEvent_GetJob function
PrlEvent_GetParam
PrlEvent_GetParam function
PrlEvent_GetParamByName
PrlEvent_GetParamByName function
PrlEvent_GetParamsCount
PrlEvent_GetParamsCount function
PrlEvent_GetServer
PrlEvent_GetServer function
PrlEvent_GetType
PrlEvent_GetType function
PrlEvent_GetVm
PrlEvent_GetVm function
PrlEvent_IsAnswerRequired
PrlEvent_IsAnswerRequired function
PrlEvtPrm_GetName
PrlEvtPrm_GetName function
PrlEvtPrm_GetType
PrlEvtPrm_GetType function
PrlEvtPrm_ToBoolean
PrlEvtPrm_ToBoolean function
PrlEvtPrm_ToCData
PrlEvtPrm_ToCData function
PrlEvtPrm_ToHandle
PrlEvtPrm_ToHandle function
PrlEvtPrm_ToInt32
PrlEvtPrm_ToInt32 function
PrlEvtPrm_ToString
PrlEvtPrm_ToString function
PrlEvtPrm_ToUint32
PrlEvtPrm_ToUint32 function
PrlFoundVmInfo_GetConfigPath
PrlFoundVmInfo_GetConfigPath function
PrlFoundVmInfo_GetName
PrlFoundVmInfo_GetName function
PrlFoundVmInfo_GetOSVersion
PrlFoundVmInfo_GetOSVersion function
PrlFoundVmInfo_IsOldConfig
PrlFoundVmInfo_IsOldConfig function
PrlFoundVmInfo_IsTemplate
PrlFoundVmInfo_IsTemplate function
PrlFs.h
PrlFsEntry_GetAbsolutePath
PrlFsEntry_GetAbsolutePath function
PrlFsEntry_GetLastModifiedDate
PrlFsEntry_GetLastModifiedDate function
PrlFsEntry_GetPermissions
PrlFsEntry_GetPermissions function
PrlFsEntry_GetRelativeName
PrlFsEntry_GetRelativeName function
PrlFsEntry_GetSize
PrlFsEntry_GetSize function
PrlFsEntry_GetType
PrlFsEntry_GetType function
PrlFsInfo_GetChildEntriesCount
PrlFsInfo_GetChildEntriesCount function
PrlFsInfo_GetChildEntry
PrlFsInfo_GetChildEntry function
PrlFsInfo_GetFsType
PrlFsInfo_GetFsType function
PrlFsInfo_GetParentEntry
PrlFsInfo_GetParentEntry function
PrlFsInfo_GetType
PrlFsInfo_GetType function
PrlHandle_AddRef
PrlHandle_AddRef function
PrlHandle_Free
PrlHandle_Free function
PrlHandle_GetType
PrlHandle_GetType function
PrlIoStructs.h
PrlJob_Cancel
PrlJob_Cancel function
PrlJob_GetDataPtr
PrlJob_GetDataPtr function
PrlJob_GetError
PrlJob_GetError function
PrlJob_GetOpCode
PrlJob_GetOpCode function
PrlJob_GetProgress
PrlJob_GetProgress function
PrlJob_GetResult
PrlJob_GetResult function
PrlJob_GetRetCode
PrlJob_GetRetCode function
PrlJob_GetStatus
PrlJob_GetStatus function
PrlJob_Wait
PrlJob_Wait function
PrlKeys.h
PrlLic_GetCompanyName
PrlLic_GetCompanyName function
PrlLic_GetLicenseKey
PrlLic_GetLicenseKey function
PrlLic_GetStatus
PrlLic_GetStatus function
PrlLic_GetUserName
PrlLic_GetUserName function
PrlLic_IsValid
PrlLic_IsValid function
PrlLoginResponse_GetHostOsVersion
PrlLoginResponse_GetHostOsVersion function
PrlLoginResponse_GetProductVersion
PrlLoginResponse_GetProductVersion function
PrlLoginResponse_GetRunningTaskByIndex
PrlLoginResponse_GetRunningTaskByIndex function
PrlLoginResponse_GetRunningTaskCount
PrlLoginResponse_GetRunningTaskCount function
PrlLoginResponse_GetServerUuid
PrlLoginResponse_GetServerUuid function
PrlLoginResponse_GetSessionUuid
PrlLoginResponse_GetSessionUuid function
PrlNetSvc_GetStatus
PrlNetSvc_GetStatus function
PrlOses.h
PrlPortFwd_Create
PrlPortFwd_Create function
PrlPortFwd_GetIncomingPort
PrlPortFwd_GetIncomingPort function
PrlPortFwd_GetRedirectIPAddress
PrlPortFwd_GetRedirectIPAddress function
PrlPortFwd_GetRedirectPort
PrlPortFwd_GetRedirectPort function
PrlPortFwd_SetIncomingPort
PrlPortFwd_SetIncomingPort function
PrlPortFwd_SetRedirectIPAddress
PrlPortFwd_SetRedirectIPAddress function
PrlPortFwd_SetRedirectPort
PrlPortFwd_SetRedirectPort function
PrlResult_GetParam
PrlResult_GetParam function
PrlResult_GetParamAsString
PrlResult_GetParamAsString function
PrlResult_GetParamByIndex
PrlResult_GetParamByIndex function
PrlResult_GetParamByIndexAsString
PrlResult_GetParamByIndexAsString function
PrlResult_GetParamsCount
PrlResult_GetParamsCount function
PrlRunningTask_GetTaskParametersAsString
PrlRunningTask_GetTaskParametersAsString function
PrlRunningTask_GetTaskType
PrlRunningTask_GetTaskType function
PrlRunningTask_GetTaskUuid
PrlRunningTask_GetTaskUuid function
PrlShare_GetDescription
PrlShare_GetDescription function
PrlShare_GetName
PrlShare_GetName function
PrlShare_GetPath
PrlShare_GetPath function
PrlShare_IsEnabled
PrlShare_IsEnabled function
PrlShare_IsReadOnly
PrlShare_IsReadOnly function
PrlShare_Remove
PrlShare_Remove function
PrlShare_SetDescription
PrlShare_SetDescription function
PrlShare_SetEnabled
PrlShare_SetEnabled function
PrlShare_SetName
PrlShare_SetName function
PrlShare_SetPath
PrlShare_SetPath function
PrlShare_SetReadOnly
PrlShare_SetReadOnly function
PrlSrv_AddNetAdapter
PrlSrv_AddNetAdapter function
PrlSrv_AttachToLostTask
PrlSrv_AttachToLostTask function
PrlSrv_CheckParallelsServerAlive
PrlSrv_CheckParallelsServerAlive function
PrlSrv_CommonPrefsBeginEdit
PrlSrv_CommonPrefsBeginEdit function
PrlSrv_CommonPrefsCommit
PrlSrv_CommonPrefsCommit function
PrlSrv_Create
PrlSrv_Create function
PrlSrv_CreateVm
PrlSrv_CreateVm function
PrlSrv_DeleteNetAdapter
PrlSrv_DeleteNetAdapter function
PrlSrv_FsCanCreateFile
PrlSrv_FsCanCreateFile function
PrlSrv_FsCreateDir
PrlSrv_FsCreateDir function
PrlSrv_FsGenerateEntryName
PrlSrv_FsGenerateEntryName function
PrlSrv_FsGetDirEntries
PrlSrv_FsGetDirEntries function
PrlSrv_FsGetDiskList
PrlSrv_FsGetDiskList function
PrlSrv_FsRemoveEntry
PrlSrv_FsRemoveEntry function
PrlSrv_FsRenameEntry
PrlSrv_FsRenameEntry function
PrlSrv_GetCommonPrefs
PrlSrv_GetCommonPrefs function
PrlSrv_GetLicenseInfo
PrlSrv_GetLicenseInfo function
PrlSrv_GetNetServiceStatus
PrlSrv_GetNetServiceStatus function
PrlSrv_GetProblemReport
PrlSrv_GetProblemReport function
PrlSrv_GetQuestions
PrlSrv_GetQuestions function
PrlSrv_GetServerInfo
PrlSrv_GetServerInfo function
PrlSrv_GetSrvConfig
PrlSrv_GetSrvConfig function
PrlSrv_GetStatistics
PrlSrv_GetStatistics function
PrlSrv_GetUserInfo
PrlSrv_GetUserInfo function
PrlSrv_GetUserInfoList
PrlSrv_GetUserInfoList function
PrlSrv_GetUserProfile
PrlSrv_GetUserProfile function
PrlSrv_GetVirtualNetworkList
PrlSrv_GetVirtualNetworkList function
PrlSrv_GetVmList
PrlSrv_GetVmList function
PrlSrv_IsConnected
PrlSrv_IsConnected function
PrlSrv_Login
PrlSrv_Login function
PrlSrv_LoginLocal
PrlSrv_LoginLocal function
PrlSrv_Logoff
PrlSrv_Logoff function
PrlSrv_LookupParallelsServers
PrlSrv_LookupParallelsServers function
PrlSrv_NetServiceRestart
PrlSrv_NetServiceRestart function
PrlSrv_NetServiceRestoreDefaults
PrlSrv_NetServiceRestoreDefaults function
PrlSrv_NetServiceStart
PrlSrv_NetServiceStart function
PrlSrv_NetServiceStop
PrlSrv_NetServiceStop function
PrlSrv_RegEventHandler
PrlSrv_RegEventHandler function
PrlSrv_RegisterVm
PrlSrv_RegisterVm function
PrlSrv_SendAnswer
PrlSrv_SendAnswer function
PrlSrv_Shutdown
PrlSrv_Shutdown function
PrlSrv_StartSearchVms
PrlSrv_StartSearchVms function
PrlSrv_SubscribeToHostStatistics
PrlSrv_SubscribeToHostStatistics function
PrlSrv_UnregEventHandler
PrlSrv_UnregEventHandler function
PrlSrv_UnsubscribeFromHostStatistics
PrlSrv_UnsubscribeFromHostStatistics function
PrlSrv_UnsubscribeFromPerfStats
PrlSrv_UnsubscribeFromPerfStats function
PrlSrv_UpdateLicense
PrlSrv_UpdateLicense function
PrlSrv_UpdateNetAdapter
PrlSrv_UpdateNetAdapter function
PrlSrv_UserProfileBeginEdit
PrlSrv_UserProfileBeginEdit function
PrlSrv_UserProfileCommit
PrlSrv_UserProfileCommit function
PrlSrvCfg_GetCpuCount
PrlSrvCfg_GetCpuCount function
PrlSrvCfg_GetCpuHvt
PrlSrvCfg_GetCpuHvt function
PrlSrvCfg_GetCpuMode
PrlSrvCfg_GetCpuMode function
PrlSrvCfg_GetCpuModel
PrlSrvCfg_GetCpuModel function
PrlSrvCfg_GetCpuSpeed
PrlSrvCfg_GetCpuSpeed function
PrlSrvCfg_GetDnsServers
PrlSrvCfg_GetDnsServers function
PrlSrvCfg_GetFloppyDisk
PrlSrvCfg_GetFloppyDisk function
PrlSrvCfg_GetFloppyDisksCount
PrlSrvCfg_GetFloppyDisksCount function
PrlSrvCfg_GetGenericPciDevice
PrlSrvCfg_GetGenericPciDevice function
PrlSrvCfg_GetGenericPciDevicesCount
PrlSrvCfg_GetGenericPciDevicesCount function
PrlSrvCfg_GetGenericScsiDevice
PrlSrvCfg_GetGenericScsiDevice function
PrlSrvCfg_GetGenericScsiDevicesCount
PrlSrvCfg_GetGenericScsiDevicesCount function
PrlSrvCfg_GetHardDisk
PrlSrvCfg_GetHardDisk function
PrlSrvCfg_GetHardDisksCount
PrlSrvCfg_GetHardDisksCount function
PrlSrvCfg_GetHostname
PrlSrvCfg_GetHostname function
PrlSrvCfg_GetHostOsMajor
PrlSrvCfg_GetHostOsMajor function
PrlSrvCfg_GetHostOsMinor
PrlSrvCfg_GetHostOsMinor function
PrlSrvCfg_GetHostOsStrPresentation
PrlSrvCfg_GetHostOsStrPresentation function
PrlSrvCfg_GetHostOsSubMinor
PrlSrvCfg_GetHostOsSubMinor function
PrlSrvCfg_GetHostOsType
PrlSrvCfg_GetHostOsType function
PrlSrvCfg_GetHostRamSize
PrlSrvCfg_GetHostRamSize function
PrlSrvCfg_GetNetAdapter
PrlSrvCfg_GetNetAdapter function
PrlSrvCfg_GetNetAdaptersCount
PrlSrvCfg_GetNetAdaptersCount function
PrlSrvCfg_GetOpticalDisk
PrlSrvCfg_GetOpticalDisk function
PrlSrvCfg_GetOpticalDisksCount
PrlSrvCfg_GetOpticalDisksCount function
PrlSrvCfg_GetParallelPort
PrlSrvCfg_GetParallelPort function
PrlSrvCfg_GetParallelPortsCount
PrlSrvCfg_GetParallelPortsCount function
PrlSrvCfg_GetPrinter
PrlSrvCfg_GetPrinter function
PrlSrvCfg_GetPrintersCount
PrlSrvCfg_GetPrintersCount function
PrlSrvCfg_GetSearchDomains
PrlSrvCfg_GetSearchDomains function
PrlSrvCfg_GetSerialPort
PrlSrvCfg_GetSerialPort function
PrlSrvCfg_GetSerialPortsCount
PrlSrvCfg_GetSerialPortsCount function
PrlSrvCfg_GetSoundMixerDev
PrlSrvCfg_GetSoundMixerDev function
PrlSrvCfg_GetSoundMixerDevsCount
PrlSrvCfg_GetSoundMixerDevsCount function
PrlSrvCfg_GetSoundOutputDev
PrlSrvCfg_GetSoundOutputDev function
PrlSrvCfg_GetSoundOutputDevsCount
PrlSrvCfg_GetSoundOutputDevsCount function
PrlSrvCfg_GetUsbDev
PrlSrvCfg_GetUsbDev function
PrlSrvCfg_GetUsbDevsCount
PrlSrvCfg_GetUsbDevsCount function
PrlSrvCfg_IsSoundDefaultEnabled
PrlSrvCfg_IsSoundDefaultEnabled function
PrlSrvCfg_IsUsbSupported
PrlSrvCfg_IsUsbSupported function
PrlSrvCfg_IsVtdSupported
PrlSrvCfg_IsVtdSupported function
PrlSrvCfgDev_GetId
PrlSrvCfgDev_GetId function
PrlSrvCfgDev_GetName
PrlSrvCfgDev_GetName function
PrlSrvCfgDev_GetType
PrlSrvCfgDev_GetType function
PrlSrvCfgDev_IsConnectedToVm
PrlSrvCfgDev_IsConnectedToVm function
PrlSrvCfgHdd_GetDevId
PrlSrvCfgHdd_GetDevId function
PrlSrvCfgHdd_GetDevName
PrlSrvCfgHdd_GetDevName function
PrlSrvCfgHdd_GetDevSize
PrlSrvCfgHdd_GetDevSize function
PrlSrvCfgHdd_GetDiskIndex
PrlSrvCfgHdd_GetDiskIndex function
PrlSrvCfgHdd_GetPart
PrlSrvCfgHdd_GetPart function
PrlSrvCfgHdd_GetPartsCount
PrlSrvCfgHdd_GetPartsCount function
PrlSrvCfgHddPart_GetIndex
PrlSrvCfgHddPart_GetIndex function
PrlSrvCfgHddPart_GetName
PrlSrvCfgHddPart_GetName function
PrlSrvCfgHddPart_GetSize
PrlSrvCfgHddPart_GetSize function
PrlSrvCfgHddPart_GetSysName
PrlSrvCfgHddPart_GetSysName function
PrlSrvCfgHddPart_GetType
PrlSrvCfgHddPart_GetType function
PrlSrvCfgHddPart_IsActive
PrlSrvCfgHddPart_IsActive function
PrlSrvCfgHddPart_IsInUse
PrlSrvCfgHddPart_IsInUse function
PrlSrvCfgHddPart_IsLogical
PrlSrvCfgHddPart_IsLogical function
PrlSrvCfgNet_GetDefaultGateway
PrlSrvCfgNet_GetDefaultGateway function
PrlSrvCfgNet_GetDnsServers
PrlSrvCfgNet_GetDnsServers function
PrlSrvCfgNet_GetMacAddress
PrlSrvCfgNet_GetMacAddress function
PrlSrvCfgNet_GetNetAdapterType
PrlSrvCfgNet_GetNetAdapterType function
PrlSrvCfgNet_GetNetAddresses
PrlSrvCfgNet_GetNetAddresses function
PrlSrvCfgNet_GetSearchDomains
PrlSrvCfgNet_GetSearchDomains function
PrlSrvCfgNet_GetSysIndex
PrlSrvCfgNet_GetSysIndex function
PrlSrvCfgNet_IsConfigureWithDhcp
PrlSrvCfgNet_IsConfigureWithDhcp function
PrlSrvCfgNet_IsEnabled
PrlSrvCfgNet_IsEnabled function
PrlSrvInfo_GetCmdPort
PrlSrvInfo_GetCmdPort function
PrlSrvInfo_GetHostName
PrlSrvInfo_GetHostName function
PrlSrvInfo_GetOsVersion
PrlSrvInfo_GetOsVersion function
PrlSrvInfo_GetProductVersion
PrlSrvInfo_GetProductVersion function
PrlSrvInfo_GetServerUuid
PrlSrvInfo_GetServerUuid function
PrlStat_GetCpusStatsCount
PrlStat_GetCpusStatsCount function
PrlStat_GetCpuStat
PrlStat_GetCpuStat function
PrlStat_GetDisksStatsCount
PrlStat_GetDisksStatsCount function
PrlStat_GetDiskStat
PrlStat_GetDiskStat function
PrlStat_GetDispUptime
PrlStat_GetDispUptime function
PrlStat_GetFreeRamSize
PrlStat_GetFreeRamSize function
PrlStat_GetFreeSwapSize
PrlStat_GetFreeSwapSize function
PrlStat_GetIfacesStatsCount
PrlStat_GetIfacesStatsCount function
PrlStat_GetIfaceStat
PrlStat_GetIfaceStat function
PrlStat_GetOsUptime
PrlStat_GetOsUptime function
PrlStat_GetProcsStatsCount
PrlStat_GetProcsStatsCount function
PrlStat_GetProcStat
PrlStat_GetProcStat function
PrlStat_GetTotalRamSize
PrlStat_GetTotalRamSize function
PrlStat_GetTotalSwapSize
PrlStat_GetTotalSwapSize function
PrlStat_GetUsageRamSize
PrlStat_GetUsageRamSize function
PrlStat_GetUsageSwapSize
PrlStat_GetUsageSwapSize function
PrlStat_GetUsersStatsCount
PrlStat_GetUsersStatsCount function
PrlStat_GetUserStat
PrlStat_GetUserStat function
PrlStatCpu_GetCpuUsage
PrlStatCpu_GetCpuUsage function
PrlStatCpu_GetSystemTime
PrlStatCpu_GetSystemTime function
PrlStatCpu_GetTotalTime
PrlStatCpu_GetTotalTime function
PrlStatCpu_GetUserTime
PrlStatCpu_GetUserTime function
PrlStatDisk_GetFreeDiskSpace
PrlStatDisk_GetFreeDiskSpace function
PrlStatDisk_GetPartsStatsCount
PrlStatDisk_GetPartsStatsCount function
PrlStatDisk_GetPartStat
PrlStatDisk_GetPartStat function
PrlStatDisk_GetSystemName
PrlStatDisk_GetSystemName function
PrlStatDisk_GetUsageDiskSpace
PrlStatDisk_GetUsageDiskSpace function
PrlStatDiskPart_GetFreeDiskSpace
PrlStatDiskPart_GetFreeDiskSpace function
PrlStatDiskPart_GetSystemName
PrlStatDiskPart_GetSystemName function
PrlStatDiskPart_GetUsageDiskSpace
PrlStatDiskPart_GetUsageDiskSpace function
PrlStatIface_GetInDataSize
PrlStatIface_GetInDataSize function
PrlStatIface_GetInPkgsCount
PrlStatIface_GetInPkgsCount function
PrlStatIface_GetOutDataSize
PrlStatIface_GetOutDataSize function
PrlStatIface_GetOutPkgsCount
PrlStatIface_GetOutPkgsCount function
PrlStatIface_GetSystemName
PrlStatIface_GetSystemName function
PrlStatProc_GetCommandName
PrlStatProc_GetCommandName function
PrlStatProc_GetCpuUsage
PrlStatProc_GetCpuUsage function
PrlStatProc_GetId
PrlStatProc_GetId function
PrlStatProc_GetOwnerUserName
PrlStatProc_GetOwnerUserName function
PrlStatProc_GetRealMemUsage
PrlStatProc_GetRealMemUsage function
PrlStatProc_GetStartTime
PrlStatProc_GetStartTime function
PrlStatProc_GetState
PrlStatProc_GetState function
PrlStatProc_GetSystemTime
PrlStatProc_GetSystemTime function
PrlStatProc_GetTotalMemUsage
PrlStatProc_GetTotalMemUsage function
PrlStatProc_GetTotalTime
PrlStatProc_GetTotalTime function
PrlStatProc_GetUserTime
PrlStatProc_GetUserTime function
PrlStatProc_GetVirtMemUsage
PrlStatProc_GetVirtMemUsage function
PrlStatUser_GetHostName
PrlStatUser_GetHostName function
PrlStatUser_GetServiceName
PrlStatUser_GetServiceName function
PrlStatUser_GetSessionTime
PrlStatUser_GetSessionTime function
PrlStatUser_GetUserName
PrlStatUser_GetUserName function
PrlStrList_AddItem
PrlStrList_AddItem function
PrlStrList_GetItem
PrlStrList_GetItem function
PrlStrList_GetItemsCount
PrlStrList_GetItemsCount function
PrlStrList_RemoveItem
PrlStrList_RemoveItem function
PrlTypes.h
PrlUsrCfg_CanChangeSrvSets
PrlUsrCfg_CanChangeSrvSets function
PrlUsrCfg_CanUseMngConsole
PrlUsrCfg_CanUseMngConsole function
PrlUsrCfg_GetDefaultVmFolder
PrlUsrCfg_GetDefaultVmFolder function
PrlUsrCfg_GetVmDirUuid
PrlUsrCfg_GetVmDirUuid function
PrlUsrCfg_SetDefaultVmFolder
PrlUsrCfg_SetDefaultVmFolder function
PrlUsrCfg_SetVmDirUuid
PrlUsrCfg_SetVmDirUuid function
PrlUsrInfo_CanChangeSrvSets
PrlUsrInfo_CanChangeSrvSets function
PrlUsrInfo_GetDefaultVmFolder
PrlUsrInfo_GetDefaultVmFolder function
PrlUsrInfo_GetName
PrlUsrInfo_GetName function
PrlUsrInfo_GetSessionCount
PrlUsrInfo_GetSessionCount function
PrlUsrInfo_GetUuid
PrlUsrInfo_GetUuid function
PrlVirtNet_Create
PrlVirtNet_Create function
PrlVirtNet_GetAdapterIndex
PrlVirtNet_GetAdapterIndex function
PrlVirtNet_GetAdapterName
PrlVirtNet_GetAdapterName function
PrlVirtNet_GetBoundCardMac
PrlVirtNet_GetBoundCardMac function
PrlVirtNet_GetDescription
PrlVirtNet_GetDescription function
PrlVirtNet_GetDhcpIPAddress
PrlVirtNet_GetDhcpIPAddress function
PrlVirtNet_GetHostIPAddress
PrlVirtNet_GetHostIPAddress function
PrlVirtNet_GetIPNetMask
PrlVirtNet_GetIPNetMask function
PrlVirtNet_GetIPScopeEnd
PrlVirtNet_GetIPScopeEnd function
PrlVirtNet_GetIPScopeStart
PrlVirtNet_GetIPScopeStart function
PrlVirtNet_GetNetworkId
PrlVirtNet_GetNetworkId function
PrlVirtNet_GetNetworkType
PrlVirtNet_GetNetworkType function
PrlVirtNet_GetPortForwardList
PrlVirtNet_GetPortForwardList function
PrlVirtNet_IsAdapterEnabled
PrlVirtNet_IsAdapterEnabled function
PrlVirtNet_IsDHCPServerEnabled
PrlVirtNet_IsDHCPServerEnabled function
PrlVirtNet_IsEnabled
PrlVirtNet_IsEnabled function
PrlVirtNet_IsNATServerEnabled
PrlVirtNet_IsNATServerEnabled function
PrlVirtNet_SetAdapterEnabled
PrlVirtNet_SetAdapterEnabled function
PrlVirtNet_SetAdapterIndex
PrlVirtNet_SetAdapterIndex function
PrlVirtNet_SetAdapterName
PrlVirtNet_SetAdapterName function
PrlVirtNet_SetBoundCardMac
PrlVirtNet_SetBoundCardMac function
PrlVirtNet_SetDescription
PrlVirtNet_SetDescription function
PrlVirtNet_SetDhcpIPAddress
PrlVirtNet_SetDhcpIPAddress function
PrlVirtNet_SetDHCPServerEnabled
PrlVirtNet_SetDHCPServerEnabled function
PrlVirtNet_SetEnabled
PrlVirtNet_SetEnabled function
PrlVirtNet_SetHostIPAddress
PrlVirtNet_SetHostIPAddress function
PrlVirtNet_SetIPNetMask
PrlVirtNet_SetIPNetMask function
PrlVirtNet_SetIPScopeEnd
PrlVirtNet_SetIPScopeEnd function
PrlVirtNet_SetIPScopeStart
PrlVirtNet_SetIPScopeStart function
PrlVirtNet_SetNATServerEnabled
PrlVirtNet_SetNATServerEnabled function
PrlVirtNet_SetNetworkId
PrlVirtNet_SetNetworkId function
PrlVirtNet_SetNetworkType
PrlVirtNet_SetNetworkType function
PrlVirtNet_SetPortForwardList
PrlVirtNet_SetPortForwardList function
PrlVm_BeginEdit
PrlVm_BeginEdit function
PrlVm_CancelCompressor
PrlVm_CancelCompressor function
PrlVm_Clone
PrlVm_Clone function
PrlVm_Commit
PrlVm_Commit function
PrlVm_CreateEvent
PrlVm_CreateEvent function
PrlVm_CreateSnapshot
PrlVm_CreateSnapshot function
PrlVm_CreateUnattendedFloppy
PrlVm_CreateUnattendedFloppy function
PrlVm_Delete
PrlVm_Delete function
PrlVm_DeleteSnapshot
PrlVm_DeleteSnapshot function
PrlVm_DropSuspendedState
PrlVm_DropSuspendedState function
PrlVm_GenerateVmDevFilename
PrlVm_GenerateVmDevFilename function
PrlVm_GetConfig
PrlVm_GetConfig function
PrlVm_GetProblemReport
PrlVm_GetProblemReport function
PrlVm_GetQuestions
PrlVm_GetQuestions function
PrlVm_GetSnapshotsTree
PrlVm_GetSnapshotsTree function
PrlVm_GetState
PrlVm_GetState function
PrlVm_GetStatistics
PrlVm_GetStatistics function
PrlVm_GetSuspendedScreen
PrlVm_GetSuspendedScreen function
PrlVm_GetToolsState
PrlVm_GetToolsState function
PrlVm_InitiateDevStateNotifications
PrlVm_InitiateDevStateNotifications function
PrlVm_InstallTools
PrlVm_InstallTools function
PrlVm_InstallUtility
PrlVm_InstallUtility function
PrlVm_LoginInGuest
PrlVm_LoginInGuest function
PrlVm_Migrate
PrlVm_Migrate function
PrlVm_MigrateCancel
PrlVm_MigrateCancel function
PrlVm_MigrateEx
PrlVm_MigrateEx function
PrlVm_Pause
PrlVm_Pause function
PrlVm_RefreshConfig
PrlVm_RefreshConfig function
PrlVm_Reg
PrlVm_Reg function
PrlVm_RegEventHandler
PrlVm_RegEventHandler function
PrlVm_Reset
PrlVm_Reset function
PrlVm_Restart
PrlVm_Restart function
PrlVm_Restore
PrlVm_Restore function
PrlVm_Resume
PrlVm_Resume function
PrlVm_RunCompressor
PrlVm_RunCompressor function
PrlVm_SetConfig
PrlVm_SetConfig function
PrlVm_Start
PrlVm_Start function
PrlVm_StartEx
PrlVm_StartEx function
PrlVm_StartVncServer
PrlVm_StartVncServer function
PrlVm_Stop
PrlVm_Stop function
PrlVm_StopVncServer
PrlVm_StopVncServer function
PrlVm_SubscribeToGuestStatistics
PrlVm_SubscribeToGuestStatistics function
PrlVm_Suspend
PrlVm_Suspend function
PrlVm_SwitchToSnapshot
PrlVm_SwitchToSnapshot function
PrlVm_TisGetIdentifiers
PrlVm_TisGetIdentifiers function
PrlVm_TisGetRecord
PrlVm_TisGetRecord function
PrlVm_ToolsSendShutdown
PrlVm_ToolsSendShutdown function
PrlVm_Unreg
PrlVm_Unreg function
PrlVm_UnregEventHandler
PrlVm_UnregEventHandler function
PrlVm_UnsubscribeFromGuestStatistics
PrlVm_UnsubscribeFromGuestStatistics function
PrlVm_UnsubscribeFromPerfStats
PrlVm_UnsubscribeFromPerfStats function
PrlVm_UpdateSecurity
PrlVm_UpdateSecurity function
PrlVm_UpdateSnapshotData
PrlVm_UpdateSnapshotData function
PrlVm_ValidateConfig
PrlVm_ValidateConfig function
PrlVmCfg_AddDefaultDevice
PrlVmCfg_AddDefaultDevice function
PrlVmCfg_CreateBootDev
PrlVmCfg_CreateBootDev function
PrlVmCfg_CreateScrRes
PrlVmCfg_CreateScrRes function
PrlVmCfg_CreateShare
PrlVmCfg_CreateShare function
PrlVmCfg_CreateVmDev
PrlVmCfg_CreateVmDev function
PrlVmCfg_GetAccessRights
PrlVmCfg_GetAccessRights function
PrlVmCfg_GetAppInDockMode
PrlVmCfg_GetAppInDockMode function
PrlVmCfg_GetAutoStart
PrlVmCfg_GetAutoStart function
PrlVmCfg_GetAutoStartDelay
PrlVmCfg_GetAutoStartDelay function
PrlVmCfg_GetAutoStop
PrlVmCfg_GetAutoStop function
PrlVmCfg_GetBackgroundPriority
PrlVmCfg_GetBackgroundPriority function
PrlVmCfg_GetBootDev
PrlVmCfg_GetBootDev function
PrlVmCfg_GetBootDevCount
PrlVmCfg_GetBootDevCount function
PrlVmCfg_GetConfigValidity
PrlVmCfg_GetConfigValidity function
PrlVmCfg_GetCpuAccelLevel
PrlVmCfg_GetCpuAccelLevel function
PrlVmCfg_GetCpuCount
PrlVmCfg_GetCpuCount function
PrlVmCfg_GetCpuMode
PrlVmCfg_GetCpuMode function
PrlVmCfg_GetCpuUnits
PrlVmCfg_GetCpuUnits function
PrlVmCfg_GetCustomProperty
PrlVmCfg_GetCustomProperty function
PrlVmCfg_GetDefaultHddSize
PrlVmCfg_GetDefaultHddSize function
PrlVmCfg_GetDefaultMemSize
PrlVmCfg_GetDefaultMemSize function
PrlVmCfg_GetDescription
PrlVmCfg_GetDescription function
PrlVmCfg_GetDevByType
PrlVmCfg_GetDevByType function
PrlVmCfg_GetDevsCount
PrlVmCfg_GetDevsCount function
PrlVmCfg_GetDevsCountByType
PrlVmCfg_GetDevsCountByType function
PrlVmCfg_GetDevsList
PrlVmCfg_GetDevsList function
PrlVmCfg_GetDnsServers
PrlVmCfg_GetDnsServers function
PrlVmCfg_GetDockIconType
PrlVmCfg_GetDockIconType function
PrlVmCfg_GetFloppyDisk
PrlVmCfg_GetFloppyDisk function
PrlVmCfg_GetFloppyDisksCount
PrlVmCfg_GetFloppyDisksCount function
PrlVmCfg_GetForegroundPriority
PrlVmCfg_GetForegroundPriority function
PrlVmCfg_GetGenericPciDev
PrlVmCfg_GetGenericPciDev function
PrlVmCfg_GetGenericPciDevsCount
PrlVmCfg_GetGenericPciDevsCount function
PrlVmCfg_GetGenericScsiDev
PrlVmCfg_GetGenericScsiDev function
PrlVmCfg_GetGenericScsiDevsCount
PrlVmCfg_GetGenericScsiDevsCount function
PrlVmCfg_GetHardDisk
PrlVmCfg_GetHardDisk function
PrlVmCfg_GetHardDisksCount
PrlVmCfg_GetHardDisksCount function
PrlVmCfg_GetHomePath
PrlVmCfg_GetHomePath function
PrlVmCfg_GetHostname
PrlVmCfg_GetHostname function
PrlVmCfg_GetIcon
PrlVmCfg_GetIcon function
PrlVmCfg_GetLastModifiedDate
PrlVmCfg_GetLastModifiedDate function
PrlVmCfg_GetLastModifierName
PrlVmCfg_GetLastModifierName function
PrlVmCfg_GetName
PrlVmCfg_GetName function
PrlVmCfg_GetNetAdapter
PrlVmCfg_GetNetAdapter function
PrlVmCfg_GetNetAdaptersCount
PrlVmCfg_GetNetAdaptersCount function
PrlVmCfg_GetOpticalDisk
PrlVmCfg_GetOpticalDisk function
PrlVmCfg_GetOpticalDisksCount
PrlVmCfg_GetOpticalDisksCount function
PrlVmCfg_GetOsType
PrlVmCfg_GetOsType function
PrlVmCfg_GetOsVersion
PrlVmCfg_GetOsVersion function
PrlVmCfg_GetParallelPort
PrlVmCfg_GetParallelPort function
PrlVmCfg_GetParallelPortsCount
PrlVmCfg_GetParallelPortsCount function
PrlVmCfg_GetRamSize
PrlVmCfg_GetRamSize function
PrlVmCfg_GetScrRes
PrlVmCfg_GetScrRes function
PrlVmCfg_GetScrResCount
PrlVmCfg_GetScrResCount function
PrlVmCfg_GetSearchDomains
PrlVmCfg_GetSearchDomains function
PrlVmCfg_GetSerialPort
PrlVmCfg_GetSerialPort function
PrlVmCfg_GetSerialPortsCount
PrlVmCfg_GetSerialPortsCount function
PrlVmCfg_GetServerHost
PrlVmCfg_GetServerHost function
PrlVmCfg_GetServerUuid
PrlVmCfg_GetServerUuid function
PrlVmCfg_GetShare
PrlVmCfg_GetShare function
PrlVmCfg_GetSharesCount
PrlVmCfg_GetSharesCount function
PrlVmCfg_GetSoundDev
PrlVmCfg_GetSoundDev function
PrlVmCfg_GetSoundDevsCount
PrlVmCfg_GetSoundDevsCount function
PrlVmCfg_GetStartLoginMode
PrlVmCfg_GetStartLoginMode function
PrlVmCfg_GetStartUserLogin
PrlVmCfg_GetStartUserLogin function
PrlVmCfg_GetSystemFlags
PrlVmCfg_GetSystemFlags function
PrlVmCfg_GetUndoDisksMode
PrlVmCfg_GetUndoDisksMode function
PrlVmCfg_GetUsbDevice
PrlVmCfg_GetUsbDevice function
PrlVmCfg_GetUsbDevicesCount
PrlVmCfg_GetUsbDevicesCount function
PrlVmCfg_GetUuid
PrlVmCfg_GetUuid function
PrlVmCfg_GetVideoRamSize
PrlVmCfg_GetVideoRamSize function
PrlVmCfg_GetVNCHostName
PrlVmCfg_GetVNCHostName function
PrlVmCfg_GetVNCMode
PrlVmCfg_GetVNCMode function
PrlVmCfg_GetVNCPassword
PrlVmCfg_GetVNCPassword function
PrlVmCfg_GetVNCPort
PrlVmCfg_GetVNCPort function
PrlVmCfg_GetWindowMode
PrlVmCfg_GetWindowMode function
PrlVmCfg_IsCloseAppOnShutdown
PrlVmCfg_IsCloseAppOnShutdown function
PrlVmCfg_IsCpuVtxEnabled
PrlVmCfg_IsCpuVtxEnabled function
PrlVmCfg_IsDefaultDeviceNeeded
PrlVmCfg_IsDefaultDeviceNeeded function
PrlVmCfg_IsDisableAPIC
PrlVmCfg_IsDisableAPIC function
PrlVmCfg_IsDiskCacheWriteBack
PrlVmCfg_IsDiskCacheWriteBack function
PrlVmCfg_IsExcludeDock
PrlVmCfg_IsExcludeDock function
PrlVmCfg_IsGuestSharingAutoMount
PrlVmCfg_IsGuestSharingAutoMount function
PrlVmCfg_IsGuestSharingEnabled
PrlVmCfg_IsGuestSharingEnabled function
PrlVmCfg_IsGuestSharingEnableSpotlight
PrlVmCfg_IsGuestSharingEnableSpotlight function
PrlVmCfg_IsHostSharingEnabled
PrlVmCfg_IsHostSharingEnabled function
PrlVmCfg_IsMapSharedFoldersOnLetters
PrlVmCfg_IsMapSharedFoldersOnLetters function
PrlVmCfg_IsMultiDisplay
PrlVmCfg_IsMultiDisplay function
PrlVmCfg_IsOsResInFullScrMode
PrlVmCfg_IsOsResInFullScrMode function
PrlVmCfg_IsRelocateTaskBar
PrlVmCfg_IsRelocateTaskBar function
PrlVmCfg_IsScrResEnabled
PrlVmCfg_IsScrResEnabled function
PrlVmCfg_IsShareAllHostDisks
PrlVmCfg_IsShareAllHostDisks function
PrlVmCfg_IsSharedProfileEnabled
PrlVmCfg_IsSharedProfileEnabled function
PrlVmCfg_IsShareUserHomeDir
PrlVmCfg_IsShareUserHomeDir function
PrlVmCfg_IsShowTaskBar
PrlVmCfg_IsShowTaskBar function
PrlVmCfg_IsSmartGuardEnabled
PrlVmCfg_IsSmartGuardEnabled function
PrlVmCfg_IsTemplate
PrlVmCfg_IsTemplate function
PrlVmCfg_IsUseDesktop
PrlVmCfg_IsUseDesktop function
PrlVmCfg_IsUseDocuments
PrlVmCfg_IsUseDocuments function
PrlVmCfg_IsUseMusic
PrlVmCfg_IsUseMusic function
PrlVmCfg_IsUsePictures
PrlVmCfg_IsUsePictures function
PrlVmCfg_IsUserDefinedSharedFoldersEnabled
PrlVmCfg_IsUserDefinedSharedFoldersEnabled function
PrlVmCfg_SetAppInDockMode
PrlVmCfg_SetAppInDockMode function
PrlVmCfg_SetAutoStart
PrlVmCfg_SetAutoStart function
PrlVmCfg_SetAutoStartDelay
PrlVmCfg_SetAutoStartDelay function
PrlVmCfg_SetAutoStop
PrlVmCfg_SetAutoStop function
PrlVmCfg_SetBackgroundPriority
PrlVmCfg_SetBackgroundPriority function
PrlVmCfg_SetCloseAppOnShutdown
PrlVmCfg_SetCloseAppOnShutdown function
PrlVmCfg_SetCpuAccelLevel
PrlVmCfg_SetCpuAccelLevel function
PrlVmCfg_SetCpuCount
PrlVmCfg_SetCpuCount function
PrlVmCfg_SetCpuMode
PrlVmCfg_SetCpuMode function
PrlVmCfg_SetCpuUnits
PrlVmCfg_SetCpuUnits function
PrlVmCfg_SetCustomProperty
PrlVmCfg_SetCustomProperty function
PrlVmCfg_SetDefaultConfig
PrlVmCfg_SetDefaultConfig function
PrlVmCfg_SetDescription
PrlVmCfg_SetDescription function
PrlVmCfg_SetDisableAPICSign
PrlVmCfg_SetDisableAPICSign function
PrlVmCfg_SetDiskCacheWriteBack
PrlVmCfg_SetDiskCacheWriteBack function
PrlVmCfg_SetDnsServers
PrlVmCfg_SetDnsServers function
PrlVmCfg_SetDockIconType
PrlVmCfg_SetDockIconType function
PrlVmCfg_SetExcludeDock
PrlVmCfg_SetExcludeDock function
PrlVmCfg_SetForegroundPriority
PrlVmCfg_SetForegroundPriority function
PrlVmCfg_SetGuestSharingAutoMount
PrlVmCfg_SetGuestSharingAutoMount function
PrlVmCfg_SetGuestSharingEnabled
PrlVmCfg_SetGuestSharingEnabled function
PrlVmCfg_SetGuestSharingEnableSpotlight
PrlVmCfg_SetGuestSharingEnableSpotlight function
PrlVmCfg_SetHostname
PrlVmCfg_SetHostname function
PrlVmCfg_SetHostSharingEnabled
PrlVmCfg_SetHostSharingEnabled function
PrlVmCfg_SetIcon
PrlVmCfg_SetIcon function
PrlVmCfg_SetMapSharedFoldersOnLetters
PrlVmCfg_SetMapSharedFoldersOnLetters function
PrlVmCfg_SetMultiDisplay
PrlVmCfg_SetMultiDisplay function
PrlVmCfg_SetName
PrlVmCfg_SetName function
PrlVmCfg_SetOsResInFullScrMode
PrlVmCfg_SetOsResInFullScrMode function
PrlVmCfg_SetOsVersion
PrlVmCfg_SetOsVersion function
PrlVmCfg_SetRamSize
PrlVmCfg_SetRamSize function
PrlVmCfg_SetRelocateTaskBar
PrlVmCfg_SetRelocateTaskBar function
PrlVmCfg_SetScrResEnabled
PrlVmCfg_SetScrResEnabled function
PrlVmCfg_SetSearchDomains
PrlVmCfg_SetSearchDomains function
PrlVmCfg_SetShareAllHostDisks
PrlVmCfg_SetShareAllHostDisks function
PrlVmCfg_SetSharedProfileEnabled
PrlVmCfg_SetSharedProfileEnabled function
PrlVmCfg_SetShareUserHomeDir
PrlVmCfg_SetShareUserHomeDir function
PrlVmCfg_SetShowTaskBar
PrlVmCfg_SetShowTaskBar function
PrlVmCfg_SetSmartGuardEnabled
PrlVmCfg_SetSmartGuardEnabled function
PrlVmCfg_SetStartLoginMode
PrlVmCfg_SetStartLoginMode function
PrlVmCfg_SetStartUserCreds
PrlVmCfg_SetStartUserCreds function
PrlVmCfg_SetSystemFlags
PrlVmCfg_SetSystemFlags function
PrlVmCfg_SetTemplateSign
PrlVmCfg_SetTemplateSign function
PrlVmCfg_SetUndoDisksMode
PrlVmCfg_SetUndoDisksMode function
PrlVmCfg_SetUseDesktop
PrlVmCfg_SetUseDesktop function
PrlVmCfg_SetUseDocuments
PrlVmCfg_SetUseDocuments function
PrlVmCfg_SetUseMusic
PrlVmCfg_SetUseMusic function
PrlVmCfg_SetUsePictures
PrlVmCfg_SetUsePictures function
PrlVmCfg_SetUserDefinedSharedFoldersEnabled
PrlVmCfg_SetUserDefinedSharedFoldersEnabled function
PrlVmCfg_SetUuid
PrlVmCfg_SetUuid function
PrlVmCfg_SetVideoRamSize
PrlVmCfg_SetVideoRamSize function
PrlVmCfg_SetVNCHostName
PrlVmCfg_SetVNCHostName function
PrlVmCfg_SetVNCMode
PrlVmCfg_SetVNCMode function
PrlVmCfg_SetVNCPassword
PrlVmCfg_SetVNCPassword function
PrlVmCfg_SetVNCPort
PrlVmCfg_SetVNCPort function
PrlVmCfg_SetWindowMode
PrlVmCfg_SetWindowMode function
PrlVmDev_Connect
PrlVmDev_Connect function
PrlVmDev_Create
PrlVmDev_Create function
PrlVmDev_CreateImage
PrlVmDev_CreateImage function
PrlVmDev_Disconnect
PrlVmDev_Disconnect function
PrlVmDev_GetDescription
PrlVmDev_GetDescription function
PrlVmDev_GetEmulatedType
PrlVmDev_GetEmulatedType function
PrlVmDev_GetFriendlyName
PrlVmDev_GetFriendlyName function
PrlVmDev_GetIfaceType
PrlVmDev_GetIfaceType function
PrlVmDev_GetImagePath
PrlVmDev_GetImagePath function
PrlVmDev_GetIndex
PrlVmDev_GetIndex function
PrlVmDev_GetOutputFile
PrlVmDev_GetOutputFile function
PrlVmDev_GetStackIndex
PrlVmDev_GetStackIndex function
PrlVmDev_GetSysName
PrlVmDev_GetSysName function
PrlVmDev_GetType
PrlVmDev_GetType function
PrlVmDev_IsConnected
PrlVmDev_IsConnected function
PrlVmDev_IsEnabled
PrlVmDev_IsEnabled function
PrlVmDev_IsPassthrough
PrlVmDev_IsPassthrough function
PrlVmDev_IsRemote
PrlVmDev_IsRemote function
PrlVmDev_Remove
PrlVmDev_Remove function
PrlVmDev_SetConnected
PrlVmDev_SetConnected function
PrlVmDev_SetDefaultStackIndex
PrlVmDev_SetDefaultStackIndex function
PrlVmDev_SetDescription
PrlVmDev_SetDescription function
PrlVmDev_SetEmulatedType
PrlVmDev_SetEmulatedType function
PrlVmDev_SetEnabled
PrlVmDev_SetEnabled function
PrlVmDev_SetFriendlyName
PrlVmDev_SetFriendlyName function
PrlVmDev_SetIfaceType
PrlVmDev_SetIfaceType function
PrlVmDev_SetImagePath
PrlVmDev_SetImagePath function
PrlVmDev_SetIndex
PrlVmDev_SetIndex function
PrlVmDev_SetOutputFile
PrlVmDev_SetOutputFile function
PrlVmDev_SetPassthrough
PrlVmDev_SetPassthrough function
PrlVmDev_SetRemote
PrlVmDev_SetRemote function
PrlVmDev_SetStackIndex
PrlVmDev_SetStackIndex function
PrlVmDev_SetSysName
PrlVmDev_SetSysName function
PrlVmDevHd_AddPartition
PrlVmDevHd_AddPartition function
PrlVmDevHd_GetDiskSize
PrlVmDevHd_GetDiskSize function
PrlVmDevHd_GetDiskType
PrlVmDevHd_GetDiskType function
PrlVmDevHd_GetPartition
PrlVmDevHd_GetPartition function
PrlVmDevHd_GetPartitionsCount
PrlVmDevHd_GetPartitionsCount function
PrlVmDevHd_GetSizeOnDisk
PrlVmDevHd_GetSizeOnDisk function
PrlVmDevHd_IsSplitted
PrlVmDevHd_IsSplitted function
PrlVmDevHd_SetDiskSize
PrlVmDevHd_SetDiskSize function
PrlVmDevHd_SetDiskType
PrlVmDevHd_SetDiskType function
PrlVmDevHd_SetSplitted
PrlVmDevHd_SetSplitted function
PrlVmDevHdPart_GetSysName
PrlVmDevHdPart_GetSysName function
PrlVmDevHdPart_Remove
PrlVmDevHdPart_Remove function
PrlVmDevHdPart_SetSysName
PrlVmDevHdPart_SetSysName function
PrlVmDevNet_GenerateMacAddr
PrlVmDevNet_GenerateMacAddr function
PrlVmDevNet_GetBoundAdapterIndex
PrlVmDevNet_GetBoundAdapterIndex function
PrlVmDevNet_GetBoundAdapterName
PrlVmDevNet_GetBoundAdapterName function
PrlVmDevNet_GetDefaultGateway
PrlVmDevNet_GetDefaultGateway function
PrlVmDevNet_GetDnsServers
PrlVmDevNet_GetDnsServers function
PrlVmDevNet_GetMacAddress
PrlVmDevNet_GetMacAddress function
PrlVmDevNet_GetNetAddresses
PrlVmDevNet_GetNetAddresses function
PrlVmDevNet_GetSearchDomains
PrlVmDevNet_GetSearchDomains function
PrlVmDevNet_IsConfigureWithDhcp
PrlVmDevNet_IsConfigureWithDhcp function
PrlVmDevNet_SetBoundAdapterIndex
PrlVmDevNet_SetBoundAdapterIndex function
PrlVmDevNet_SetBoundAdapterName
PrlVmDevNet_SetBoundAdapterName function
PrlVmDevNet_SetConfigureWithDhcp
PrlVmDevNet_SetConfigureWithDhcp function
PrlVmDevNet_SetDefaultGateway
PrlVmDevNet_SetDefaultGateway function
PrlVmDevNet_SetDnsServers
PrlVmDevNet_SetDnsServers function
PrlVmDevNet_SetMacAddress
PrlVmDevNet_SetMacAddress function
PrlVmDevNet_SetNetAddresses
PrlVmDevNet_SetNetAddresses function
PrlVmDevNet_SetSearchDomains
PrlVmDevNet_SetSearchDomains function
PrlVmDevSerial_GetSocketMode
PrlVmDevSerial_GetSocketMode function
PrlVmDevSerial_SetSocketMode
PrlVmDevSerial_SetSocketMode function
PrlVmDevSound_GetMixerDev
PrlVmDevSound_GetMixerDev function
PrlVmDevSound_GetOutputDev
PrlVmDevSound_GetOutputDev function
PrlVmDevSound_SetMixerDev
PrlVmDevSound_SetMixerDev function
PrlVmDevSound_SetOutputDev
PrlVmDevSound_SetOutputDev function
PrlVmDevUsb_GetAutoconnectOption
PrlVmDevUsb_GetAutoconnectOption function
PrlVmDevUsb_SetAutoconnectOption
PrlVmDevUsb_SetAutoconnectOption function
PrlVmGuest_GetNetworkSettings
PrlVmGuest_GetNetworkSettings function
PrlVmGuest_Logout
PrlVmGuest_Logout function
PrlVmGuest_RunProgram
PrlVmGuest_RunProgram function
PrlVmGuest_SetUserPasswd
PrlVmGuest_SetUserPasswd function
PrlVmInfo_GetAccessRights
PrlVmInfo_GetAccessRights function
PrlVmInfo_GetState
PrlVmInfo_GetState function
PrlVmInfo_IsInvalid
PrlVmInfo_IsInvalid function
PrlVmInfo_IsVncServerStarted
PrlVmInfo_IsVncServerStarted function
PrlVmToolsInfo_GetState
PrlVmToolsInfo_GetState function
PrlVmToolsInfo_GetVersion
PrlVmToolsInfo_GetVersion function
PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY enumeration member
PSE_DIRECTORY enumeration member
PSE_DRIVE enumeration member
PSE_FILE enumeration member
PSIA_OPEN_DEFAULT enumeration member
PSIA_OPEN_IN_GUEST enumeration member
PSIA_OPEN_IN_HOST enumeration member
PSL_HIGH_SECURITY enumeration member
PSL_LOW_SECURITY enumeration member
PSL_NORMAL_SECURITY enumeration member
PSM_VM_SAFE_START enumeration member
PSM_VM_START enumeration member
PSM_VM_START_LAST_ITEM enumeration member
PSP_SERIAL_SOCKET_CLIENT enumeration member
PSP_SERIAL_SOCKET_SERVER enumeration member
PSS_NOT_INSTALLED enumeration member
PSS_STARTED enumeration member
PSS_STOPPED enumeration member
PSS_UNKNOWN enumeration member
PST_VM_HIBERNATE enumeration member
PST_VM_REBOOT enumeration member
PST_VM_SHUTDOWN enumeration member
PTIS_RECORD_ACTIVE enumeration member
PTIS_RECORD_CANCELED enumeration member
PTIS_RECORD_CHANGED enumeration member
PTIS_RECORD_EMPTY enumeration member
PTIS_RECORD_REMOVED enumeration member
PTS_INSTALLED enumeration member
PTS_NOT_INSTALLED enumeration member
PTS_OUTDATED enumeration member
PTS_POSSIBLY_INSTALLED enumeration member
PTS_UNKNOWN enumeration member
PTU_CMD_INVALID enumeration member
PTU_CMD_PTU_ALIVE enumeration member
PTU_FLG_ZERO enumeration member
PUD_ASK_USER_WHAT_TODO enumeration member
PUD_COMMIT_CHANGES enumeration member
PUD_CONNECT_TO_GUEST_OS enumeration member
PUD_CONNECT_TO_PRIMARY_OS enumeration member
PUD_CONNECTED_AUTOMATICALLY enumeration member
PUD_CONNECTED_MANUALLY enumeration member
PUD_DISABLE_UNDO_DISKS enumeration member
PUD_PROMPT_BEHAVIOUR enumeration member
PUD_REVERSE_CHANGES enumeration member
PVA_ACCELERATION_DISABLED enumeration member
PVA_ACCELERATION_HIGH enumeration member
PVA_ACCELERATION_NORMAL enumeration member
PVC_ALL enumeration member
PVC_BOOT_OPTION enumeration member
PVC_CD_DVD_ROM enumeration member
PVC_CPU enumeration member
PVC_FLOPPY_DISK enumeration member
PVC_GENERAL_PARAMETERS enumeration member
PVC_GENERIC_PCI enumeration member
PVC_HARD_DISK enumeration member
PVC_IDE_DEVICES enumeration member
PVC_LAST_SECTION enumeration member
PVC_MAIN_MEMORY enumeration member
PVC_NETWORK_ADAPTER enumeration member
PVC_PARALLEL_PORT enumeration member
PVC_REMOTE_DISPLAY enumeration member
PVC_SCSI_DEVICES enumeration member
PVC_SERIAL_PORT enumeration member
PVC_SHARED_FOLDERS enumeration member
PVC_SOUND enumeration member
PVC_VIDEO_MEMORY enumeration member
PVM_GET_MIGRATION_SECURITY_LEVEL
PVM_GET_MIGRATION_SECURITY_LEVEL macro
PVM_GET_MIGRATION_TYPE
PVM_GET_MIGRATION_TYPE macro
PVMSL_HIGH_SECURITY enumeration member
PVMSL_LOW_SECURITY enumeration member
PVMSL_NORMAL_SECURITY enumeration member
PVMT_COLD_MIGRATION enumeration member
PVMT_HOT_MIGRATION enumeration member
PVMT_WARM_MIGRATION enumeration member
PVN_BRIDGED_ETHERNET enumeration member
PVN_HOST_ONLY enumeration member
PVR_PRIORITY_HIGH enumeration member
PVR_PRIORITY_LOW enumeration member
PVR_PRIORITY_NORMAL enumeration member
PVS_GET_GUEST_NUMBER
PVS_GET_GUEST_NUMBER macro
PVS_GET_GUEST_TYPE
PVS_GET_GUEST_TYPE macro
PVS_GUEST Macros
PVS_GUEST_ARCH_I386
PVS_GUEST_ARCH_I386 macro
PVS_GUEST_ARCH_OTHER
PVS_GUEST_ARCH_OTHER macro
PVS_GUEST_ARCH_X86_64
PVS_GUEST_ARCH_X86_64 macro
PVS_GUEST_TYPE_FREEBSD
PVS_GUEST_TYPE_FREEBSD macro
PVS_GUEST_TYPE_LINUX
PVS_GUEST_TYPE_LINUX macro
PVS_GUEST_TYPE_MACOS
PVS_GUEST_TYPE_MACOS macro
PVS_GUEST_TYPE_MSDOS
PVS_GUEST_TYPE_MSDOS macro
PVS_GUEST_TYPE_NAME_FREEBSD
PVS_GUEST_TYPE_NAME_FREEBSD macro
PVS_GUEST_TYPE_NAME_LINUX
PVS_GUEST_TYPE_NAME_LINUX macro
PVS_GUEST_TYPE_NAME_MACOS
PVS_GUEST_TYPE_NAME_MACOS macro
PVS_GUEST_TYPE_NAME_MSDOS
PVS_GUEST_TYPE_NAME_MSDOS macro
PVS_GUEST_TYPE_NAME_NETWARE
PVS_GUEST_TYPE_NAME_NETWARE macro
PVS_GUEST_TYPE_NAME_OS2
PVS_GUEST_TYPE_NAME_OS2 macro
PVS_GUEST_TYPE_NAME_OTHER
PVS_GUEST_TYPE_NAME_OTHER macro
PVS_GUEST_TYPE_NAME_SOLARIS
PVS_GUEST_TYPE_NAME_SOLARIS macro
PVS_GUEST_TYPE_NAME_WINDOWS
PVS_GUEST_TYPE_NAME_WINDOWS macro
PVS_GUEST_TYPE_NETWARE
PVS_GUEST_TYPE_NETWARE macro
PVS_GUEST_TYPE_OS2
PVS_GUEST_TYPE_OS2 macro
PVS_GUEST_TYPE_OTHER
PVS_GUEST_TYPE_OTHER macro
PVS_GUEST_TYPE_SOLARIS
PVS_GUEST_TYPE_SOLARIS macro
PVS_GUEST_TYPE_WINDOWS
PVS_GUEST_TYPE_WINDOWS macro
PVS_GUEST_VER_BSD_4X
PVS_GUEST_VER_BSD_4X macro
PVS_GUEST_VER_BSD_5X
PVS_GUEST_VER_BSD_5X macro
PVS_GUEST_VER_BSD_6X
PVS_GUEST_VER_BSD_6X macro
PVS_GUEST_VER_BSD_7X
PVS_GUEST_VER_BSD_7X macro
PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_LAST macro
PVS_GUEST_VER_BSD_OTHER
PVS_GUEST_VER_BSD_OTHER macro
PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_LAST macro
PVS_GUEST_VER_DOS_MS622
PVS_GUEST_VER_DOS_MS622 macro
PVS_GUEST_VER_DOS_OTHER
PVS_GUEST_VER_DOS_OTHER macro
PVS_GUEST_VER_LIN_CENTOS
PVS_GUEST_VER_LIN_CENTOS macro
PVS_GUEST_VER_LIN_DEBIAN
PVS_GUEST_VER_LIN_DEBIAN macro
PVS_GUEST_VER_LIN_FEDORA
PVS_GUEST_VER_LIN_FEDORA macro
PVS_GUEST_VER_LIN_FEDORA_5
PVS_GUEST_VER_LIN_FEDORA_5 macro
PVS_GUEST_VER_LIN_KRNL_24
PVS_GUEST_VER_LIN_KRNL_24 macro
PVS_GUEST_VER_LIN_KRNL_26
PVS_GUEST_VER_LIN_KRNL_26 macro
PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_LAST macro
PVS_GUEST_VER_LIN_MANDRAKE
PVS_GUEST_VER_LIN_MANDRAKE macro
PVS_GUEST_VER_LIN_OPENSUSE
PVS_GUEST_VER_LIN_OPENSUSE macro
PVS_GUEST_VER_LIN_OTHER
PVS_GUEST_VER_LIN_OTHER macro
PVS_GUEST_VER_LIN_REDHAT
PVS_GUEST_VER_LIN_REDHAT macro
PVS_GUEST_VER_LIN_RH_LEGACY
PVS_GUEST_VER_LIN_RH_LEGACY macro
PVS_GUEST_VER_LIN_RHLES3
PVS_GUEST_VER_LIN_RHLES3 macro
PVS_GUEST_VER_LIN_SLES9
PVS_GUEST_VER_LIN_SLES9 macro
PVS_GUEST_VER_LIN_SUSE
PVS_GUEST_VER_LIN_SUSE macro
PVS_GUEST_VER_LIN_UBUNTU
PVS_GUEST_VER_LIN_UBUNTU macro
PVS_GUEST_VER_LIN_XANDROS
PVS_GUEST_VER_LIN_XANDROS macro
PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LAST macro
PVS_GUEST_VER_MACOS_LEOPARD
PVS_GUEST_VER_MACOS_LEOPARD macro
PVS_GUEST_VER_MACOS_SNOW_LEOPARD
PVS_GUEST_VER_MACOS_SNOW_LEOPARD macro
PVS_GUEST_VER_MACOS_TIGER
PVS_GUEST_VER_MACOS_TIGER macro
PVS_GUEST_VER_NAME_BSD_4X
PVS_GUEST_VER_NAME_BSD_4X macro
PVS_GUEST_VER_NAME_BSD_5X
PVS_GUEST_VER_NAME_BSD_5X macro
PVS_GUEST_VER_NAME_BSD_6X
PVS_GUEST_VER_NAME_BSD_6X macro
PVS_GUEST_VER_NAME_BSD_7X
PVS_GUEST_VER_NAME_BSD_7X macro
PVS_GUEST_VER_NAME_BSD_OTHER
PVS_GUEST_VER_NAME_BSD_OTHER macro
PVS_GUEST_VER_NAME_DOS_MS622
PVS_GUEST_VER_NAME_DOS_MS622 macro
PVS_GUEST_VER_NAME_DOS_OTHER
PVS_GUEST_VER_NAME_DOS_OTHER macro
PVS_GUEST_VER_NAME_LIN_CENTOS
PVS_GUEST_VER_NAME_LIN_CENTOS macro
PVS_GUEST_VER_NAME_LIN_DEBIAN
PVS_GUEST_VER_NAME_LIN_DEBIAN macro
PVS_GUEST_VER_NAME_LIN_FEDORA
PVS_GUEST_VER_NAME_LIN_FEDORA macro
PVS_GUEST_VER_NAME_LIN_FEDORA_5
PVS_GUEST_VER_NAME_LIN_FEDORA_5 macro
PVS_GUEST_VER_NAME_LIN_KRNL_24
PVS_GUEST_VER_NAME_LIN_KRNL_24 macro
PVS_GUEST_VER_NAME_LIN_KRNL_26
PVS_GUEST_VER_NAME_LIN_KRNL_26 macro
PVS_GUEST_VER_NAME_LIN_MANDRAKE
PVS_GUEST_VER_NAME_LIN_MANDRAKE macro
PVS_GUEST_VER_NAME_LIN_OPENSUSE
PVS_GUEST_VER_NAME_LIN_OPENSUSE macro
PVS_GUEST_VER_NAME_LIN_OTHER
PVS_GUEST_VER_NAME_LIN_OTHER macro
PVS_GUEST_VER_NAME_LIN_REDHAT
PVS_GUEST_VER_NAME_LIN_REDHAT macro
PVS_GUEST_VER_NAME_LIN_RH_LEGACY
PVS_GUEST_VER_NAME_LIN_RH_LEGACY macro
PVS_GUEST_VER_NAME_LIN_RHLES3
PVS_GUEST_VER_NAME_LIN_RHLES3 macro
PVS_GUEST_VER_NAME_LIN_SLES9
PVS_GUEST_VER_NAME_LIN_SLES9 macro
PVS_GUEST_VER_NAME_LIN_SUSE
PVS_GUEST_VER_NAME_LIN_SUSE macro
PVS_GUEST_VER_NAME_LIN_UBUNTU
PVS_GUEST_VER_NAME_LIN_UBUNTU macro
PVS_GUEST_VER_NAME_LIN_XANDROS
PVS_GUEST_VER_NAME_LIN_XANDROS macro
PVS_GUEST_VER_NAME_MACOS_LEOPARD
PVS_GUEST_VER_NAME_MACOS_LEOPARD macro
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD macro
PVS_GUEST_VER_NAME_MACOS_TIGER
PVS_GUEST_VER_NAME_MACOS_TIGER macro
PVS_GUEST_VER_NAME_NET_4X
PVS_GUEST_VER_NAME_NET_4X macro
PVS_GUEST_VER_NAME_NET_5X
PVS_GUEST_VER_NAME_NET_5X macro
PVS_GUEST_VER_NAME_NET_6X
PVS_GUEST_VER_NAME_NET_6X macro
PVS_GUEST_VER_NAME_NET_OTHER
PVS_GUEST_VER_NAME_NET_OTHER macro
PVS_GUEST_VER_NAME_OS2_ECS11
PVS_GUEST_VER_NAME_OS2_ECS11 macro
PVS_GUEST_VER_NAME_OS2_ECS12
PVS_GUEST_VER_NAME_OS2_ECS12 macro
PVS_GUEST_VER_NAME_OS2_OTHER
PVS_GUEST_VER_NAME_OS2_OTHER macro
PVS_GUEST_VER_NAME_OS2_WARP3
PVS_GUEST_VER_NAME_OS2_WARP3 macro
PVS_GUEST_VER_NAME_OS2_WARP4
PVS_GUEST_VER_NAME_OS2_WARP4 macro
PVS_GUEST_VER_NAME_OS2_WARP45
PVS_GUEST_VER_NAME_OS2_WARP45 macro
PVS_GUEST_VER_NAME_OTH_OPENSTEP
PVS_GUEST_VER_NAME_OTH_OPENSTEP macro
PVS_GUEST_VER_NAME_OTH_OTHER
PVS_GUEST_VER_NAME_OTH_OTHER macro
PVS_GUEST_VER_NAME_OTH_QNX
PVS_GUEST_VER_NAME_OTH_QNX macro
PVS_GUEST_VER_NAME_SOL_10
PVS_GUEST_VER_NAME_SOL_10 macro
PVS_GUEST_VER_NAME_SOL_11
PVS_GUEST_VER_NAME_SOL_11 macro
PVS_GUEST_VER_NAME_SOL_9
PVS_GUEST_VER_NAME_SOL_9 macro
PVS_GUEST_VER_NAME_SOL_OTHER
PVS_GUEST_VER_NAME_SOL_OTHER macro
PVS_GUEST_VER_NAME_WIN_2003
PVS_GUEST_VER_NAME_WIN_2003 macro
PVS_GUEST_VER_NAME_WIN_2008
PVS_GUEST_VER_NAME_WIN_2008 macro
PVS_GUEST_VER_NAME_WIN_2K
PVS_GUEST_VER_NAME_WIN_2K macro
PVS_GUEST_VER_NAME_WIN_311
PVS_GUEST_VER_NAME_WIN_311 macro
PVS_GUEST_VER_NAME_WIN_95
PVS_GUEST_VER_NAME_WIN_95 macro
PVS_GUEST_VER_NAME_WIN_98
PVS_GUEST_VER_NAME_WIN_98 macro
PVS_GUEST_VER_NAME_WIN_ME
PVS_GUEST_VER_NAME_WIN_ME macro
PVS_GUEST_VER_NAME_WIN_NT
PVS_GUEST_VER_NAME_WIN_NT macro
PVS_GUEST_VER_NAME_WIN_OTHER
PVS_GUEST_VER_NAME_WIN_OTHER macro
PVS_GUEST_VER_NAME_WIN_VISTA
PVS_GUEST_VER_NAME_WIN_VISTA macro
PVS_GUEST_VER_NAME_WIN_WINDOWS7
PVS_GUEST_VER_NAME_WIN_WINDOWS7 macro
PVS_GUEST_VER_NAME_WIN_XP
PVS_GUEST_VER_NAME_WIN_XP macro
PVS_GUEST_VER_NET_4X
PVS_GUEST_VER_NET_4X macro
PVS_GUEST_VER_NET_5X
PVS_GUEST_VER_NET_5X macro
PVS_GUEST_VER_NET_6X
PVS_GUEST_VER_NET_6X macro
PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_LAST macro
PVS_GUEST_VER_NET_OTHER
PVS_GUEST_VER_NET_OTHER macro
PVS_GUEST_VER_OS2_ECS11
PVS_GUEST_VER_OS2_ECS11 macro
PVS_GUEST_VER_OS2_ECS12
PVS_GUEST_VER_OS2_ECS12 macro
PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_LAST macro
PVS_GUEST_VER_OS2_OTHER
PVS_GUEST_VER_OS2_OTHER macro
PVS_GUEST_VER_OS2_WARP3
PVS_GUEST_VER_OS2_WARP3 macro
PVS_GUEST_VER_OS2_WARP4
PVS_GUEST_VER_OS2_WARP4 macro
PVS_GUEST_VER_OS2_WARP45
PVS_GUEST_VER_OS2_WARP45 macro
PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_LAST macro
PVS_GUEST_VER_OTH_OPENSTEP
PVS_GUEST_VER_OTH_OPENSTEP macro
PVS_GUEST_VER_OTH_OTHER
PVS_GUEST_VER_OTH_OTHER macro
PVS_GUEST_VER_OTH_QNX
PVS_GUEST_VER_OTH_QNX macro
PVS_GUEST_VER_SOL_10
PVS_GUEST_VER_SOL_10 macro
PVS_GUEST_VER_SOL_11
PVS_GUEST_VER_SOL_11 macro
PVS_GUEST_VER_SOL_9
PVS_GUEST_VER_SOL_9 macro
PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_LAST macro
PVS_GUEST_VER_SOL_OTHER
PVS_GUEST_VER_SOL_OTHER macro
PVS_GUEST_VER_WIN_2003
PVS_GUEST_VER_WIN_2003 macro
PVS_GUEST_VER_WIN_2008
PVS_GUEST_VER_WIN_2008 macro
PVS_GUEST_VER_WIN_2K
PVS_GUEST_VER_WIN_2K macro
PVS_GUEST_VER_WIN_311
PVS_GUEST_VER_WIN_311 macro
PVS_GUEST_VER_WIN_95
PVS_GUEST_VER_WIN_95 macro
PVS_GUEST_VER_WIN_98
PVS_GUEST_VER_WIN_98 macro
PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_LAST macro
PVS_GUEST_VER_WIN_ME
PVS_GUEST_VER_WIN_ME macro
PVS_GUEST_VER_WIN_NT
PVS_GUEST_VER_WIN_NT macro
PVS_GUEST_VER_WIN_OTHER
PVS_GUEST_VER_WIN_OTHER macro
PVS_GUEST_VER_WIN_VISTA
PVS_GUEST_VER_WIN_VISTA macro
PVS_GUEST_VER_WIN_WINDOWS7
PVS_GUEST_VER_WIN_WINDOWS7 macro
PVS_GUEST_VER_WIN_XP
PVS_GUEST_VER_WIN_XP macro
PVS_MAKE_GUEST_VER
PVS_MAKE_GUEST_VER macro
PWC_VM_ASK_USER enumeration member
PWC_VM_DO_NOTHING enumeration member
PWC_VM_PAUSE enumeration member
PWC_VM_SHUTDOWN enumeration member
PWC_VM_STOP enumeration member
PWC_VM_SUSPEND enumeration member
PWM_COHERENCE_WINDOW_MODE enumeration member
PWM_DEFAULT_WINDOW_MODE enumeration member
PWM_FULL_SCREEN_WINDOW_MODE enumeration member
PWM_MODALITY_WINDOW_MODE enumeration member
PWM_WINDOWED_WINDOW_MODE enumeration member
R
Remote Desktop Access
RTT_RUNNING_TASK_CLONE_VM enumeration member
RTT_RUNNING_TASK_CREATE_IMAGE enumeration member
RTT_RUNNING_TASK_CREATE_VM enumeration member
RTT_RUNNING_TASK_DELETE_VM enumeration member
RTT_RUNNING_TASK_REGISTER_VM enumeration member
RTT_RUNNING_TASK_RESTORE_VM enumeration member
RTT_RUNNING_TASK_UNKNOWN enumeration member
RTT_RUNNING_TASK_UNREG_VM enumeration member
S
Secondary Display Capture
SET_FS_EXECUTE_DISABLED
SET_FS_EXECUTE_DISABLED macro
SET_FS_EXECUTE_ENABLED
SET_FS_EXECUTE_ENABLED macro
SET_FS_READ_DISABLED
SET_FS_READ_DISABLED macro
SET_FS_READ_ENABLED
SET_FS_READ_ENABLED macro
SET_FS_WRITE_DISABLED
SET_FS_WRITE_DISABLED macro
SET_FS_WRITE_ENABLED
SET_FS_WRITE_ENABLED macro
Structs, Records, Enums
System Functions
T
TO_PARALLELS_API_VER
TO_PARALLELS_API_VER macro
Types
V
Virtual Device Functions
VIRTUAL_MACHINE_STATE
VIRTUAL_MACHINE_STATE enumeration
VIRTUAL_MACHINE_STATE_PTR
VIRTUAL_MACHINE_STATE_PTR type
VMS_COMPACTING enumeration member
VMS_CONTINUING enumeration member
VMS_DELETING_STATE enumeration member
VMS_MIGRATING enumeration member
VMS_PAUSED enumeration member
VMS_PAUSING enumeration member
VMS_RESETTING enumeration member
VMS_RESTORING enumeration member
VMS_RESUMING enumeration member
VMS_RUNNING enumeration member
VMS_SNAPSHOTING enumeration member
VMS_STARTING enumeration member
VMS_STOPPED enumeration member
VMS_STOPPING enumeration member
VMS_SUSPENDED enumeration member
VMS_SUSPENDING enumeration member
VMS_UNKNOWN enumeration member
W
WINDOW_ALL_EDGE_MASK enumeration member
WINDOW_BOTTOM_EDGE_MASK enumeration member
WINDOW_LEFT_EDGE_MASK enumeration member
WINDOW_RIGHT_EDGE_MASK enumeration member
WINDOW_TOP_EDGE_MASK enumeration member


About This Guide

About This Guide
Send Feedback

This document is a part of the Parallels Virtualization SDK. It contains a detailed Parallels C API reference including information about handles (objects), functions, types, structures, enumerations, and other technical information.

Please note that this document does not provide general information on how to use the Parallels Virtualization SDK. For a detailed explanation of how to start using the SDK and how to create your own programs using the provided APIs, please read the Parallels Virtualization SDK Programmer's Guide, which is a companion book to this one.

To understand the material provided in this guide, you should have a basic knowledge of the ANSI C programming language and some experience working with application programming interfaces (API) written in C. You should also be familiar with one of the Parallels virtualization products, such as Parallels Server, Parallels Desktop, or Parallels Workstation.


IS_FREEBSD Macro

IS_FREEBSD Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_FREEBSD(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_FREEBSD ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_FS_EXECUTE_PERMITTED Macro

IS_FS_EXECUTE_PERMITTED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define IS_FS_EXECUTE_PERMITTED(x) ( (x) & FS_PERM_EXECUTE ?1:0 )
File

PrlFs.h

Links
PrlFs.h, Other Macros


IS_FS_READ_PERMITTED Macro

IS_FS_READ_PERMITTED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define IS_FS_READ_PERMITTED(x) ( (x) & FS_PERM_READ ?1:0 )
File

PrlFs.h

Links
PrlFs.h, Other Macros


IS_FS_WRITE_PERMITTED Macro

IS_FS_WRITE_PERMITTED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define IS_FS_WRITE_PERMITTED(x) ( (x) & FS_PERM_WRITE ?1:0 )
File

PrlFs.h

Links
PrlFs.h, Other Macros


IS_LINUX Macro

IS_LINUX Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_LINUX(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_LINUX ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_MACOS Macro

IS_MACOS Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_MACOS(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_MACOS ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_MSDOS Macro

IS_MSDOS Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_MSDOS(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_MSDOS ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_NETWARE Macro

IS_NETWARE Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_NETWARE(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_NETWARE ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_OS2 Macro

IS_OS2 Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_OS2(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_OS2 ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_OTHER Macro

IS_OTHER Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_OTHER(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_OTHER ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_SOLARIS Macro

IS_SOLARIS Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_SOLARIS(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_SOLARIS ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_FREEBSD_VERSION Macro

IS_VALID_FREEBSD_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_FREEBSD_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_BSD_4X && nOsVersion <= PVS_GUEST_VER_BSD_LAST)\
            || nOsVersion == PVS_GUEST_VER_BSD_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_LINUX_VERSION Macro

IS_VALID_LINUX_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_LINUX_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_LIN_REDHAT && nOsVersion <= PVS_GUEST_VER_LIN_LAST)\
            || nOsVersion == PVS_GUEST_VER_LIN_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_MACOS_VERSION Macro

IS_VALID_MACOS_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_MACOS_VERSION(nOsVersion) \
    (nOsVersion >= PVS_GUEST_VER_MACOS_TIGER && nOsVersion <= PVS_GUEST_VER_MACOS_LAST)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_MSDOS_VERSION Macro

IS_VALID_MSDOS_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_MSDOS_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_DOS_MS622 && nOsVersion <= PVS_GUEST_VER_DOS_LAST)\
            || nOsVersion == PVS_GUEST_VER_DOS_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_NETWARE_VERSION Macro

IS_VALID_NETWARE_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_NETWARE_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_NET_4X && nOsVersion <= PVS_GUEST_VER_NET_LAST)\
            || nOsVersion == PVS_GUEST_VER_NET_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_OS2_VERSION Macro

IS_VALID_OS2_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_OS2_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_OS2_WARP3 && nOsVersion <= PVS_GUEST_VER_OS2_LAST)\
            || nOsVersion == PVS_GUEST_VER_OS2_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_OTHER_OS_VERSION Macro

IS_VALID_OTHER_OS_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_OTHER_OS_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_OTH_QNX && nOsVersion <= PVS_GUEST_VER_OTH_LAST)\
            || nOsVersion == PVS_GUEST_VER_OTH_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_SOLARIS_VERSION Macro

IS_VALID_SOLARIS_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_SOLARIS_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_SOL_9 && nOsVersion <= PVS_GUEST_VER_SOL_LAST)\
            || nOsVersion == PVS_GUEST_VER_SOL_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_VALID_WINDOWS_VERSION Macro

IS_VALID_WINDOWS_VERSION Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_VALID_WINDOWS_VERSION(nOsVersion) \
    ((nOsVersion >= PVS_GUEST_VER_WIN_311 && nOsVersion <= PVS_GUEST_VER_WIN_LAST)\
                || nOsVersion == PVS_GUEST_VER_WIN_OTHER)
File

PrlOses.h

Links
PrlOses.h, Other Macros


IS_WINDOWS Macro

IS_WINDOWS Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define IS_WINDOWS(x) ( ( ( x >> 8 ) ^ PVS_GUEST_TYPE_WINDOWS ) ? 0 : 1 )
File

PrlOses.h

Links
PrlOses.h, Other Macros


PARALLELS_API_VER Macro

PARALLELS_API_VER Macro
PrlApi.h Other Macros Send Feedback

Current Parallels API version.

Syntax
#define PARALLELS_API_VER PARALLELS_API_VER_2
File

PrlApi.h

Links
PrlApi.h, Other Macros


PARALLELS_API_VER_1 Macro

PARALLELS_API_VER_1 Macro
PrlApi.h Other Macros Send Feedback
Syntax
#define PARALLELS_API_VER_1 TO_PARALLELS_API_VER(0,1)
File

PrlApi.h

Links
PrlApi.h, Other Macros


PARALLELS_API_VER_2 Macro

PARALLELS_API_VER_2 Macro
PrlApi.h Other Macros Send Feedback
Syntax
#define PARALLELS_API_VER_2 TO_PARALLELS_API_VER(2,0)
File

PrlApi.h

Links
PrlApi.h, Other Macros


Parallels.h

Parallels.h
Files Send Feedback

Parallels.h

This file is the part of parallels public sdk library

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Links
Files


PET_ANSWER_APPEND Macro

PET_ANSWER_APPEND Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_APPEND PRL_RESULT_DECLARE_SUCCESS(16011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_BREAK Macro

PET_ANSWER_BREAK Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_BREAK PRL_RESULT_DECLARE_SUCCESS(16004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_CANCEL Macro

PET_ANSWER_CANCEL Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_CANCEL PRL_RESULT_DECLARE_SUCCESS(16001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_COMMIT Macro

PET_ANSWER_COMMIT Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_COMMIT PRL_RESULT_DECLARE_SUCCESS(16016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_CONTINUE Macro

PET_ANSWER_CONTINUE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_CONTINUE PRL_RESULT_DECLARE_SUCCESS(16008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_COPIED Macro

PET_ANSWER_COPIED Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_COPIED PRL_RESULT_DECLARE_SUCCESS(16013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_CREATE Macro

PET_ANSWER_CREATE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_CREATE PRL_RESULT_DECLARE_SUCCESS(16019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_CREATE_NEW Macro

PET_ANSWER_CREATE_NEW Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_CREATE_NEW PRL_RESULT_DECLARE_SUCCESS(16009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_DISCONNECT_ANYWAY Macro

PET_ANSWER_DISCONNECT_ANYWAY Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_DISCONNECT_ANYWAY PRL_RESULT_DECLARE_SUCCESS(16018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_MOVED Macro

PET_ANSWER_MOVED Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_MOVED PRL_RESULT_DECLARE_SUCCESS(16014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_NO Macro

PET_ANSWER_NO Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_NO PRL_RESULT_DECLARE_SUCCESS(16003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_OK Macro

PET_ANSWER_OK Macro
PrlErrorsValues.h PET Macros Send Feedback
  • Answers

+++ ALIGNED VALUE TO 16000

Syntax
#define PET_ANSWER_OK PRL_RESULT_DECLARE_SUCCESS(16000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_OVERIDE Macro

PET_ANSWER_OVERIDE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_OVERIDE PRL_RESULT_DECLARE_SUCCESS(16005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_REPLACE Macro

PET_ANSWER_REPLACE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_REPLACE PRL_RESULT_DECLARE_SUCCESS(16012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_REVERT Macro

PET_ANSWER_REVERT Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_REVERT PRL_RESULT_DECLARE_SUCCESS(16017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_SHUTDOWN Macro

PET_ANSWER_SHUTDOWN Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_SHUTDOWN PRL_RESULT_DECLARE_SUCCESS(16006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_SKIP Macro

PET_ANSWER_SKIP Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_SKIP PRL_RESULT_DECLARE_SUCCESS(16020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_STARTVM Macro

PET_ANSWER_STARTVM Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_STARTVM PRL_RESULT_DECLARE_SUCCESS(16015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_STOP Macro

PET_ANSWER_STOP Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_STOP PRL_RESULT_DECLARE_SUCCESS(16007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_SUSPEND_ANYWAY Macro

PET_ANSWER_SUSPEND_ANYWAY Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_SUSPEND_ANYWAY PRL_RESULT_DECLARE_SUCCESS(16021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_USE_CURRENT Macro

PET_ANSWER_USE_CURRENT Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_USE_CURRENT PRL_RESULT_DECLARE_SUCCESS(16010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ANSWER_YES Macro

PET_ANSWER_YES Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ANSWER_YES PRL_RESULT_DECLARE_SUCCESS(16002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro

PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_ERR_WARN_REACH_OVERCOMMIT_STATE_ON_SETMEM PRL_RESULT_DECLARE_SUCCESS(441)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK Macro

PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_ALLOW_TO_SUSPEND_VM_WITH_BOOTCAMP_DISK PRL_RESULT_DECLARE_SUCCESS(13022)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM Macro

PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_APPLY_WHEN_HYP_CANNOT_ALLOC_VMS_MEM PRL_RESULT_DECLARE_SUCCESS(13021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE Macro

PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_BOOTCAMP_HELPER_INIT_FAILURE PRL_RESULT_DECLARE_SUCCESS(13015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED Macro

PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_BOOTCAMP_HELPER_OS_UNSUPPORTED PRL_RESULT_DECLARE_SUCCESS(13016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CANCEL_CLONE_OPERATION Macro

PET_QUESTION_CANCEL_CLONE_OPERATION Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CANCEL_CLONE_OPERATION PRL_RESULT_DECLARE_SUCCESS(13024)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro

PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CANCEL_CLONE_TO_TEMPLATE_OPERATION PRL_RESULT_DECLARE_SUCCESS(13025)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CANCEL_DEPLOY_OPERATION Macro

PET_QUESTION_CANCEL_DEPLOY_OPERATION Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CANCEL_DEPLOY_OPERATION PRL_RESULT_DECLARE_SUCCESS(13026)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CHANGE_VM_MIGRATION_TYPE Macro

PET_QUESTION_CHANGE_VM_MIGRATION_TYPE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CHANGE_VM_MIGRATION_TYPE PRL_RESULT_DECLARE_SUCCESS(13012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CREATE_NEW_MAC_ADDRESS Macro

PET_QUESTION_CREATE_NEW_MAC_ADDRESS Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CREATE_NEW_MAC_ADDRESS PRL_RESULT_DECLARE_SUCCESS(13011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE Macro

PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_CREATE_OS2_GUEST_WITHOUT_FDD_IMAGE PRL_RESULT_DECLARE_SUCCESS(13020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR Macro

PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_DELETE_FILES_OUT_OF_VM_DIR PRL_RESULT_DECLARE_SUCCESS(13006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR Macro

PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_DELETE_PARALLELS_FILES_IN_VM_DIR PRL_RESULT_DECLARE_SUCCESS(13007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG Macro

PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_DELETE_VM_WITH_CORRUPTED_CONFIG PRL_RESULT_DECLARE_SUCCESS(13009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE Macro

PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_DO_YOU_WANT_TO_OVERWRITE_FILE PRL_RESULT_DECLARE_SUCCESS(13002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro

PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_FREE_SIZE_FOR_COMPRESSED_DISK PRL_RESULT_DECLARE_SUCCESS(13005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG Macro

PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_MAC_PHYSICAL_MEMORY_MAP_BUG PRL_RESULT_DECLARE_SUCCESS(13019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_OLD_CONFIG_CONVERTION Macro

PET_QUESTION_OLD_CONFIG_CONVERTION Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_OLD_CONFIG_CONVERTION PRL_RESULT_DECLARE_SUCCESS(13004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_REACH_OVERCOMMIT_STATE Macro

PET_QUESTION_REACH_OVERCOMMIT_STATE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_REACH_OVERCOMMIT_STATE PRL_RESULT_DECLARE_SUCCESS(13014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro

PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_REACH_OVERCOMMIT_STATE_ON_SETMEM PRL_RESULT_DECLARE_SUCCESS(13017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_REGISTER_USED_VM Macro

PET_QUESTION_REGISTER_USED_VM Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_REGISTER_USED_VM PRL_RESULT_DECLARE_SUCCESS(13010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_REGISTER_VM_TEMPLATE Macro

PET_QUESTION_REGISTER_VM_TEMPLATE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_REGISTER_VM_TEMPLATE PRL_RESULT_DECLARE_SUCCESS(13008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP Macro

PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_RESTORE_VM_CONFIG_FROM_BACKUP PRL_RESULT_DECLARE_SUCCESS(13023)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_SAMPLE_1 Macro

PET_QUESTION_SAMPLE_1 Macro
PrlErrorsValues.h PET Macros Send Feedback
  • Questions

+++ ALIGNED VALUE TO 13000

Syntax
#define PET_QUESTION_SAMPLE_1 PRL_RESULT_DECLARE_SUCCESS(13000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_SAMPLE_2 Macro

PET_QUESTION_SAMPLE_2 Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_SAMPLE_2 PRL_RESULT_DECLARE_SUCCESS(13001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_TXT_ERROR Macro

PET_QUESTION_TXT_ERROR Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_TXT_ERROR PRL_RESULT_DECLARE_SUCCESS(13003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_UNDO_DISKS_MODE Macro

PET_QUESTION_UNDO_DISKS_MODE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_UNDO_DISKS_MODE PRL_RESULT_DECLARE_SUCCESS(13018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PET_QUESTION_VM_COPY_OR_MOVE Macro

PET_QUESTION_VM_COPY_OR_MOVE Macro
PrlErrorsValues.h PET Macros Send Feedback
Syntax
#define PET_QUESTION_VM_COPY_OR_MOVE PRL_RESULT_DECLARE_SUCCESS(13013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PET Macros


PRL_ALLOWED_VM_COMMAND Enumeration

PRL_ALLOWED_VM_COMMAND Enumeration
PrlEnums.h Other Structs Send Feedback

Allowed vm commands enumeration

Syntax
typedef enum _PRL_ALLOWED_VM_COMMAND {
  PAR_VM_START_ACCESS = 0,
  PAR_VM_STOP_ACCESS = 1,
  PAR_VM_PAUSE_ACCESS = 2,
  PAR_VM_RESET_ACCESS = 3,
  PAR_VM_SUSPEND_ACCESS = 4,
  PAR_VM_RESUME_ACCESS = 5,
  PAR_VM_DROPSUSPENDEDSTATE_ACCESS = 6,
  PAR_VM_CLONE_ACCESS = 7,
  PAR_VM_DELETE_ACCESS = 8,
  PAR_VM_GETPROBLEMREPORT_ACCESS = 9,
  PAR_VM_GETCONFIG_ACCESS = 10,
  PAR_VM_GETSTATISTICS_ACCESS = 11,
  PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS = 12,
  PAR_VM_SUBSCRIBETOGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNSUBSCRIBEFROMGUESTSTATISTICS_ACCESS = PAR_VM_STATISTICS_SUBSCRIPTION_ACCESS,
  PAR_VM_UNREG_ACCESS = 13,
  PAR_VM_EDITING_ACCESS = 14,
  PAR_VM_BEGINEDIT_ACCESS = PAR_VM_EDITING_ACCESS,
  PAR_VM_COMMIT_ACCESS = PAR_VM_EDITING_ACCESS,
  PAR_VMDEV_CONNECT_ACCESS = 15,
  PAR_VMDEV_DISCONNECT_ACCESS = 16,
  PAR_VMDEV_CREATEIMAGE_ACCESS = 17,
  PAR_VM_SEND_ANSWER_ACCESS = 18,
  PAR_VM_GET_VMINFO_ACCESS = 19,
  PAR_VM_INSTALL_TOOLS_ACCESS = 20,
  PAR_VM_INITIATE_DEV_STATE_NOTIFICATIONS_ACCESS = 21,
  PAR_VM_UPDATE_SECURITY_ACCESS = 22,
  PAR_VM_CANCEL_COMPACT_ACCESS = 23,
  PAR_VM_REGISTER_ACCESS = 24,
  PAR_VM_MIGRATE_ACCESS = 25,
  PAR_VM_START_STOP_VNC_SERVER = 26,
  PAR_VM_GET_SUSPENDED_SCREEN_ACCESS = 27,
  PAR_VM_PERFSTAT_ACCESS = 28,
  PAR_VM_MIGRATE_CANCEL_ACCESS = 30,
  PAR_VM_RUN_COMPRESSOR_ACCESS = 31,
  PAR_VM_CANCEL_COMPRESSOR_ACCESS = 32,
  PAR_VM_CREATE_SNAPSHOT_ACCESS = 33,
  PAR_VM_SWITCH_TO_SNAPSHOT_ACCESS = 34,
  PAR_VM_DELETE_SNAPSHOT_ACCESS = 35,
  PAR_VM_START_EX_ACCESS = 36,
  PAR_VM_RESTART_GUEST_ACCESS = 38,
  PAR_VM_INSTALL_UTILITY_ACCESS = 39,
  PAR_VM_UPDATE_TOOLS_SECTION = 40,
  PAR_VM_RESTORE_ACCESS = 41,
  PAR_MAX
} PRL_ALLOWED_VM_COMMAND;
File

PrlEnums.h

Members

PAR_VM_MIGRATE_CANCEL_ACCESS
PAR_VM_UPDATE_COHERENCE = 29,
PAR_VM_RESTART_GUEST_ACCESS
PAR_VM_UPDATE_SHARED_PROFILES = 37,
PAR_MAX
should be the last

Links
PrlEnums.h, Other Structs


PRL_ALLOWED_VM_COMMAND_PTR Type

PRL_ALLOWED_VM_COMMAND_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_ALLOWED_VM_COMMAND* PRL_ALLOWED_VM_COMMAND_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_API_METHOD_PTR Type

PRL_API_METHOD_PTR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_API_METHOD* PRL_API_METHOD_PTR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_APP_IN_DOCK_MODE Enumeration

PRL_APP_IN_DOCK_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM application in Dock mode

Syntax
typedef enum _PRL_APP_IN_DOCK_MODE {
  PDM_APP_IN_DOCK_NEVER = 0,
  PDM_APP_IN_DOCK_COHERENCE_ONLY = 1,
  PDM_APP_IN_DOCK_ALWAYS = 2
} PRL_APP_IN_DOCK_MODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_APP_IN_DOCK_MODE_PTR Type

PRL_APP_IN_DOCK_MODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_APP_IN_DOCK_MODE* PRL_APP_IN_DOCK_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_APPLICATION_MODE Enumeration

PRL_APPLICATION_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode

Syntax
typedef enum _PRL_APPLICATION_MODE {
  PAM_UNKNOWN = 0xffff,
  PAM_SERVER = 0,
  PAM_DESKTOP = 1,
  PAM_WORKSTATION = 2,
  PAM_PLAYER = 3,
  PAM_STM = 4
} PRL_APPLICATION_MODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_APPLICATION_MODE_PTR Type

PRL_APPLICATION_MODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_APPLICATION_MODE* PRL_APPLICATION_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_ASYNC_METHOD Macro

PRL_ASYNC_METHOD Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_ASYNC_METHOD( func ) PRL_EXTERN __declspec(dllexport) PRL_HANDLE PRL_CALL func
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_ASYNC_METHOD_DECL Macro

PRL_ASYNC_METHOD_DECL Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_ASYNC_METHOD_DECL( version, name, args ) \
    PRL_ASYNC_METHOD( name ) args;    \
    typedef PRL_ASYNC_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_ASYNC_METHOD_PTR Macro

PRL_ASYNC_METHOD_PTR Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_ASYNC_METHOD_PTR( func_type ) PRL_HANDLE ( PRL_CALL * func_type )
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_ASYNC_SRV_METHOD_DECL Macro

PRL_ASYNC_SRV_METHOD_DECL Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_ASYNC_SRV_METHOD_DECL( version, name, args ) \
    PRL_ASYNC_METHOD( name ) args;    \
    typedef PRL_ASYNC_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_BOOL Type

PRL_BOOL Type
PrlTypes.h PRL_BOOL Types Send Feedback

Boolean value (32 bit integer), zero means FALSE or TRUE otherwise

Syntax
typedef unsigned long PRL_BOOL;
File

PrlTypes.h

Links
PrlTypes.h, PRL_BOOL Types


PRL_BOOL_PTR Type

PRL_BOOL_PTR Type
PrlTypes.h PRL_BOOL Types Send Feedback
Syntax
typedef PRL_BOOL* PRL_BOOL_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_BOOL Types


PRL_BSD_PARTITION Macro

PRL_BSD_PARTITION Macro
PrlDisk.h Other Macros Send Feedback

Free BSD partition.

Syntax
#define PRL_BSD_PARTITION 0xA5
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_CHAR Type

PRL_CHAR Type
PrlTypes.h PRL_CHAR Types Send Feedback

All strings are UTF8 encoded

Syntax
typedef char PRL_CHAR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CHAR Types


PRL_CHAR_PTR Type

PRL_CHAR_PTR Type
PrlTypes.h PRL_CHAR Types Send Feedback
Syntax
typedef PRL_CHAR* PRL_CHAR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CHAR Types


PRL_CHECKED_DISK_INVALID Macro

PRL_CHECKED_DISK_INVALID Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_CHECKED_DISK_INVALID PRL_RESULT_DECLARE_SUCCESS(25002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_CHECKED_DISK_OLD_VERSION Macro

PRL_CHECKED_DISK_OLD_VERSION Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_CHECKED_DISK_OLD_VERSION PRL_RESULT_DECLARE_SUCCESS(25001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_CHECKED_DISK_VALID Macro

PRL_CHECKED_DISK_VALID Macro
PrlErrorsValues.h Other Macros Send Feedback
  • Disk validation errors

+++ ALIGNED VALUE TO 25000

Syntax
#define PRL_CHECKED_DISK_VALID PRL_RESULT_DECLARE_SUCCESS(25000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_CONST_API_METHOD_PTR Type

PRL_CONST_API_METHOD_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_API_METHOD* PRL_CONST_API_METHOD_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_BOOL_PTR Type

PRL_CONST_BOOL_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_BOOL* PRL_CONST_BOOL_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_DISK_OPEN_FLAGS_PTR Type

PRL_CONST_DISK_OPEN_FLAGS_PTR Type
PrlDisk.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_DISK_OPEN_FLAGS* PRL_CONST_DISK_OPEN_FLAGS_PTR;
File

PrlDisk.h

Links
PrlDisk.h, PRL_CONST Types


PRL_CONST_DISK_PARAMETERS_PTR Type

PRL_CONST_DISK_PARAMETERS_PTR Type
PrlDisk.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_DISK_PARAMETERS* PRL_CONST_DISK_PARAMETERS_PTR;
File

PrlDisk.h

Links
PrlDisk.h, PRL_CONST Types


PRL_CONST_GUID_PTR Type

PRL_CONST_GUID_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_GUID* PRL_CONST_GUID_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_HANDLE_PTR Type

PRL_CONST_HANDLE_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_HANDLE* PRL_CONST_HANDLE_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_INT8_PTR Type

PRL_CONST_INT8_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_INT8* PRL_CONST_INT8_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_INT16_PTR Type

PRL_CONST_INT16_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_INT16* PRL_CONST_INT16_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_INT32_PTR Type

PRL_CONST_INT32_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_INT32* PRL_CONST_INT32_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_INT64_PTR Type

PRL_CONST_INT64_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_INT64* PRL_CONST_INT64_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_SIZE_PTR Type

PRL_CONST_SIZE_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_SIZE* PRL_CONST_SIZE_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_SNAPSHOT_ELEMENT_PTR Type

PRL_CONST_SNAPSHOT_ELEMENT_PTR Type
PrlDisk.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_SNAPSHOT_ELEMENT* PRL_CONST_SNAPSHOT_ELEMENT_PTR;
File

PrlDisk.h

Links
PrlDisk.h, PRL_CONST Types


PRL_CONST_STR Type

PRL_CONST_STR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const char* PRL_CONST_STR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_STR_PTR Type

PRL_CONST_STR_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef PRL_CONST_STR* PRL_CONST_STR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_UINT8_PTR Type

PRL_CONST_UINT8_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_UINT8* PRL_CONST_UINT8_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_UINT16_PTR Type

PRL_CONST_UINT16_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_UINT16* PRL_CONST_UINT16_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_UINT32_PTR Type

PRL_CONST_UINT32_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_UINT32* PRL_CONST_UINT32_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_UINT64_PTR Type

PRL_CONST_UINT64_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_UINT64* PRL_CONST_UINT64_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CONST_VOID_PTR Type

PRL_CONST_VOID_PTR Type
PrlTypes.h PRL_CONST Types Send Feedback
Syntax
typedef const PRL_VOID* PRL_CONST_VOID_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_CONST Types


PRL_CPU_HVT Enumeration

PRL_CPU_HVT Enumeration
PrlEnums.h Other Structs Send Feedback

CPU mode

Syntax
typedef enum _PRL_CPU_HVT {
  PCM_CPU_NONE_HV = 0,
  PCM_CPU_INTEL_VT_X,
  PCM_CPU_AMD_V
} PRL_CPU_HVT;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_CPU_HVT_PTR Type

PRL_CPU_HVT_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_CPU_HVT* PRL_CPU_HVT_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_CPU_MODE Enumeration

PRL_CPU_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

CPU mode

Syntax
typedef enum _PRL_CPU_MODE {
  PCM_CPU_MODE_32 = 0,
  PCM_CPU_MODE_64 = 1
} PRL_CPU_MODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_CPU_MODE_PTR Type

PRL_CPU_MODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_CPU_MODE* PRL_CPU_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_CURRENT_GUEST_OS_SESSION Macro

PRL_CURRENT_GUEST_OS_SESSION Macro
PrlEnums.h Other Macros Send Feedback
Syntax
#define PRL_CURRENT_GUEST_OS_SESSION "4a5533a7-31c6-4d7a-a400-1f330dc57a9d"
File

PrlEnums.h

Links
PrlEnums.h, Other Macros


PRL_DATA_PARTITION Macro

PRL_DATA_PARTITION Macro
PrlDisk.h Other Macros Send Feedback

Special handle for data partition from GPT (can be linux, windows, any type).

Syntax
#define PRL_DATA_PARTITION 0xd8
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_DEVICE_ACTION Enumeration

PRL_DEVICE_ACTION Enumeration
PrlEnums.h Other Structs Send Feedback

Device in use Action

Syntax
typedef enum _PRL_DEVICE_ACTION {
  PDA_DEVICE_IDLE = 0,
  PDA_DEVICE_READ = 1,
  PDA_DEVICE_WRITE = 2
} PRL_DEVICE_ACTION;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DEVICE_ACTION_PTR Type

PRL_DEVICE_ACTION_PTR Type
PrlEnums.h PRL_DEVICE Types Send Feedback
Syntax
typedef PRL_DEVICE_ACTION* PRL_DEVICE_ACTION_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_DEVICE Types


PRL_DEVICE_TYPE Enumeration

PRL_DEVICE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Device type

Syntax
typedef enum _PRL_DEVICE_TYPE {
  PDE_GENERIC_DEVICE = 0,
  PDE_CLUSTERED_DEVICE = 1,
  PDE_STORAGE_DEVICE = 2,
  PDE_FLOPPY_DISK = 3,
  PDE_MASSSTORAGE_DEVICE = 4,
  PDE_OPTICAL_DISK = 5,
  PDE_HARD_DISK = 6,
  PDE_GENERIC_NETWORK_ADAPTER = 8,
  PDE_GENERIC_PORT = 9,
  PDE_SERIAL_PORT = 10,
  PDE_PARALLEL_PORT = 11,
  PDE_SOUND_DEVICE = 12,
  PDE_MIXER_DEVICE = 13,
  PDE_USB_DEVICE = 15,
  PDE_PRINTER = 16,
  PDE_GENERIC_PCI_DEVICE = 17,
  PDE_GENERIC_SCSI_DEVICE = 18,
  PDE_VIRTUAL_SNAPSHOT_DEVICE = 19,
  PDE_MAX
} PRL_DEVICE_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DEVICE_TYPE_PTR Type

PRL_DEVICE_TYPE_PTR Type
PrlEnums.h PRL_DEVICE Types Send Feedback
Syntax
typedef PRL_DEVICE_TYPE* PRL_DEVICE_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_DEVICE Types


PRL_DISK_CACHE_DEFAULT Macro

PRL_DISK_CACHE_DEFAULT Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Disk cache default.

Syntax
#define PRL_DISK_CACHE_DEFAULT 0
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_CACHE_DISABLED Macro

PRL_DISK_CACHE_DISABLED Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Uncached access to disk image.

Syntax
#define PRL_DISK_CACHE_DISABLED 2
File

PrlDisk.h

Remarks

Slow read/write always, but host OS cache is not used, so it's good for host applications.

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_CACHE_ENABLED Macro

PRL_DISK_CACHE_ENABLED Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Cached access to disk image.

Syntax
#define PRL_DISK_CACHE_ENABLED 1
File

PrlDisk.h

Remarks

Fast write() and read() in case of all data can be fit in OS cache. But in the other hand host cache will be partially duplicated in guest OS cache, so in this mode memory usage may be ineffective.

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_CACHE_UNCACHED_READ Macro

PRL_DISK_CACHE_UNCACHED_READ Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Cached write/uncached read.

Syntax
#define PRL_DISK_CACHE_UNCACHED_READ 3
File

PrlDisk.h

Remarks

Like DISK_CACHE_ENABLED, but read data does not duplicated in host OS RAM, so you have more RAM for host applications. On Mac you may also see performance gain when you read data that were just written before and held in OS cache - data will be read from cache even with F_NOCACHE read(). This may help guest OS with stuff like pagefile.sys for example.

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_DEFAULT_FLAG Macro

PRL_DISK_DEFAULT_FLAG Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Default (writelock always on at write on).

Syntax
#define PRL_DISK_DEFAULT_FLAG (PRL_DISK_READ | PRL_DISK_WRITE | PRL_DISK_READ_LOCK | PRL_DISK_FOPS_DEFAULT)
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FAKE_OPEN Macro

PRL_DISK_FAKE_OPEN Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).

Syntax
#define PRL_DISK_FAKE_OPEN 0x00000008
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FOPS_DEFAULT Macro

PRL_DISK_FOPS_DEFAULT Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Default access mode that compiled in Parallels itself.

Syntax
#define PRL_DISK_FOPS_DEFAULT 0x00000000
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FOPS_MASK Macro

PRL_DISK_FOPS_MASK Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Type of the file access to use (15 file accessors is enough).

Syntax
#define PRL_DISK_FOPS_MASK 0x000003C0
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FOPS_MERGING Macro

PRL_DISK_FOPS_MERGING Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Access mode with requests merging.

Syntax
#define PRL_DISK_FOPS_MERGING 0x000000C0
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FOPS_NONCACHED Macro

PRL_DISK_FOPS_NONCACHED Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Access mode with file caching turned off.

Syntax
#define PRL_DISK_FOPS_NONCACHED 0x00000080
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_FOPS_NORMAL Macro

PRL_DISK_FOPS_NORMAL Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Normal access mode (default os)

Syntax
#define PRL_DISK_FOPS_NORMAL 0x00000040
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_INVALID Macro

PRL_DISK_INVALID Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Last (invalid).

Syntax
#define PRL_DISK_INVALID
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_NOTHING Macro

PRL_DISK_NOTHING Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Nothing.

Syntax
#define PRL_DISK_NOTHING 0x00000000
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_OPEN_FLAGS Type

PRL_DISK_OPEN_FLAGS Type
PrlDisk.h PRL_DISK Types Send Feedback

Storage/image/disk open parameters

Syntax
typedef PRL_UINT32 PRL_DISK_OPEN_FLAGS;
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Types


PRL_DISK_OPEN_FLAGS_PTR Type

PRL_DISK_OPEN_FLAGS_PTR Type
PrlDisk.h PRL_DISK Types Send Feedback
Syntax
typedef PRL_DISK_OPEN_FLAGS* PRL_DISK_OPEN_FLAGS_PTR;
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Types


PRL_DISK_PARAMETERS Structure

PRL_DISK_PARAMETERS Structure
PrlDisk.h Other Structs Send Feedback

Parallels disk parameters.

Syntax
typedef struct __PRL_DISK_PARAMETERS {
  PRL_UINT32 m_Heads;
  PRL_UINT32 m_Cylinders;
  PRL_UINT32 m_Sectors;
  PRL_UINT64 m_SizeInSectors;
  PRL_UINT32 m_BlockSize;
  PRL_UINT32 m_Parts;
  PRL_IMAGE_PARAMETERS_PTR m_Storages;
} PRL_DISK_PARAMETERS;
File

PrlDisk.h

Remarks

Differs from internal due to lists classes

Links
PrlDisk.h, Other Structs


PRL_DISK_PARAMETERS_PTR Type

PRL_DISK_PARAMETERS_PTR Type
PrlDisk.h PRL_DISK Types Send Feedback
Syntax
typedef PRL_DISK_PARAMETERS* PRL_DISK_PARAMETERS_PTR;
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Types


PRL_DISK_PROGRESS_COMPLETED Macro

PRL_DISK_PROGRESS_COMPLETED Macro
PrlDisk.h PRL_DISK Macros Send Feedback
Syntax
#define PRL_DISK_PROGRESS_COMPLETED 1005
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_PROGRESS_MAX Macro

PRL_DISK_PROGRESS_MAX Macro
PrlDisk.h PRL_DISK Macros Send Feedback
Syntax
#define PRL_DISK_PROGRESS_MAX 1000
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_PROGRESS_MIN Macro

PRL_DISK_PROGRESS_MIN Macro
PrlDisk.h PRL_DISK Macros Send Feedback

States progress definition.

Syntax
#define PRL_DISK_PROGRESS_MIN 0
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_READ Macro

PRL_DISK_READ Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Read

Syntax
#define PRL_DISK_READ 0x00000001
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_READ_LOCK Macro

PRL_DISK_READ_LOCK Macro
PrlDisk.h PRL_DISK Macros Send Feedback

ReadLock

Syntax
#define PRL_DISK_READ_LOCK 0x00000004
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_WRITE Macro

PRL_DISK_WRITE Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Write

Syntax
#define PRL_DISK_WRITE 0x00000002
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_WRITE_THROUGH Macro

PRL_DISK_WRITE_THROUGH Macro
PrlDisk.h PRL_DISK Macros Send Feedback

Write through, disable caching

Syntax
#define PRL_DISK_WRITE_THROUGH 0x00000010
File

PrlDisk.h

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISK_XML_CHANGE Macro

PRL_DISK_XML_CHANGE Macro
PrlDisk.h PRL_DISK Macros Send Feedback

This parameter is used when user need to change XML data but not access to the drive itself.

Syntax
#define PRL_DISK_XML_CHANGE 0x00000020
File

PrlDisk.h

Remarks

It can prevent situations when VirtualDisk library should unmount drive from host system to store small amount of data to the XML descriptor.

Links
PrlDisk.h, PRL_DISK Macros


PRL_DISPLAY_CODEC_COMPRESSION Enumeration

PRL_DISPLAY_CODEC_COMPRESSION Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec compression

Syntax
typedef enum _PRL_DISPLAY_CODEC_COMPRESSION {
  PDCC_HIGH_COMPRESSION = 1<<15,
  PDCC_MEDIUM_COMPRESSION = 1<<16,
  PDCC_LOW_COMPRESSION = 1<<17,
  PDCC_NO_COMPRESSION = 1<<18
} PRL_DISPLAY_CODEC_COMPRESSION;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DISPLAY_CODEC_QUALITY Enumeration

PRL_DISPLAY_CODEC_QUALITY Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec quality

Syntax
typedef enum _PRL_DISPLAY_CODEC_QUALITY {
  PDCQ_HIGH_QUALITY = 1<<0,
  PDCQ_MEDIUM_QUALITY = 1<<1,
  PDCQ_LOW_QUALITY = 1<<2
} PRL_DISPLAY_CODEC_QUALITY;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DISPLAY_CODEC_TYPE Enumeration

PRL_DISPLAY_CODEC_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Display codec types

Syntax
typedef enum _PRL_DISPLAY_CODEC_TYPE {
  PDCT_HIGH_QUALITY_WITHOUT_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_HIGH_QUALITY_WITH_COMPRESSION = PDCQ_HIGH_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITHOUT_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_MEDIUM_QUALITY_WITH_COMPRESSION = PDCQ_MEDIUM_QUALITY|PDCC_MEDIUM_COMPRESSION,
  PDCT_LOW_QUALITY_WITHOUT_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_NO_COMPRESSION,
  PDCT_LOW_QUALITY_WITH_COMPRESSION = PDCQ_LOW_QUALITY|PDCC_MEDIUM_COMPRESSION
} PRL_DISPLAY_CODEC_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DOCK_ICON_TYPE Enumeration

PRL_DOCK_ICON_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

VM application icon type in Dock

Syntax
typedef enum _PRL_DOCK_ICON_TYPE {
  PIT_DOCK_ICON_SYSTEM = 0,
  PIT_DOCK_ICON_LIVE_SCREEN_SHOT = 1,
  PIT_DOCK_ICON_START_MENU = 2
} PRL_DOCK_ICON_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_DOCK_ICON_TYPE_PTR Type

PRL_DOCK_ICON_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_DOCK_ICON_TYPE* PRL_DOCK_ICON_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_EFI_PARTITION Macro

PRL_EFI_PARTITION Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_EFI_PARTITION 0xEF
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_EFI_PARTITION_GPT Macro

PRL_EFI_PARTITION_GPT Macro
PrlDisk.h Other Macros Send Feedback

EFI system partition

Syntax
#define PRL_EFI_PARTITION_GPT 0xEE
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_EMPTY_PARTITION Macro

PRL_EMPTY_PARTITION Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_EMPTY_PARTITION 0x00
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR Macro

PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCES_DENIED_FILE_TO_PARENT_PARENT_DIR PRL_RESULT_DECLARE_ERROR(100)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_DENIED Macro

PRL_ERR_ACCESS_DENIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_DENIED PRL_RESULT_DECLARE_ERROR(5)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS Macro

PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_DENIED_TO_CHANGE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(381)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE Macro

PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_DENIED_TO_DISK_IMAGE PRL_RESULT_DECLARE_ERROR(78)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD Macro

PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_DENINED_TO_RUN_WIZARD PRL_RESULT_DECLARE_ERROR(360)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_TO_VM_DENIED Macro

PRL_ERR_ACCESS_TO_VM_DENIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_TO_VM_DENIED PRL_RESULT_DECLARE_ERROR(239)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ACCESS_TOKEN_INVALID Macro

PRL_ERR_ACCESS_TOKEN_INVALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ACCESS_TOKEN_INVALID PRL_RESULT_DECLARE_ERROR(60)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED Macro

PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ADD_HW_FLOPPY_IMAGE_NOT_SPECIFYED PRL_RESULT_DECLARE_ERROR(317)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED Macro

PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ADD_VM_OPERATION_WAS_CANCELED PRL_RESULT_DECLARE_ERROR(319)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ALIGN_ON_4 Macro

PRL_ERR_ALIGN_ON_4 Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ALIGN_ON_4 PRL_RESULT_DECLARE_ERROR(203)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER Macro

PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ALREADY_CONNECTED_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(252)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT Macro

PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

Dispatcher service mode errors codes

Syntax
#define PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT PRL_RESULT_DECLARE_ERROR(361)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_API_INCOMPATIBLE Macro

PRL_ERR_API_INCOMPATIBLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_API_INCOMPATIBLE PRL_RESULT_DECLARE_ERROR(422)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_API_WASNT_INITIALIZED Macro

PRL_ERR_API_WASNT_INITIALIZED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_API_WASNT_INITIALIZED PRL_RESULT_DECLARE_ERROR(287)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ATTACH_TO_TASK_BAD_SESSION Macro

PRL_ERR_ATTACH_TO_TASK_BAD_SESSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ATTACH_TO_TASK_BAD_SESSION PRL_RESULT_DECLARE_ERROR(349)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_AUTHENTICATION_FAILED Macro

PRL_ERR_AUTHENTICATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(330)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_BAD_DISP_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(20)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_BAD_PARAMETERS Macro

PRL_ERR_BAD_PARAMETERS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_BAD_PARAMETERS PRL_RESULT_DECLARE_ERROR(83)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_BAD_VM_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(32)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED Macro

PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_BAD_VM_DIR_CONFIG_FILE_SPECIFIED PRL_RESULT_DECLARE_ERROR(27)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_BUFFER_OVERRUN Macro

PRL_ERR_BUFFER_OVERRUN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_BUFFER_OVERRUN PRL_RESULT_DECLARE_ERROR(6)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE Macro

PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CAN_NOT_GET_DISK_FREE_SPACE PRL_RESULT_DECLARE_ERROR(306)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM Macro

PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANNOT_PROCESSING_SAFE_MODE_FOR_INVALID_VM PRL_RESULT_DECLARE_ERROR(445)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM Macro

PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANNOT_PROCESSING_UNDO_DISKS_FOR_INVALID_VM PRL_RESULT_DECLARE_ERROR(444)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_ALOCA_MEM_FILE_COPY Macro

PRL_ERR_CANT_ALOCA_MEM_FILE_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_ALOCA_MEM_FILE_COPY PRL_RESULT_DECLARE_ERROR(109)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS Macro

PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CHANGE_FILE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(339)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_DISK_IMAGE_FILE PRL_RESULT_DECLARE_ERROR(394)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_FILE PRL_RESULT_DECLARE_ERROR(281)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE Macro

PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CHANGE_OWNER_OF_VM_FILE PRL_RESULT_DECLARE_ERROR(393)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONFIGURE_PARTITION_HDD Macro

PRL_ERR_CANT_CONFIGURE_PARTITION_HDD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONFIGURE_PARTITION_HDD PRL_RESULT_DECLARE_ERROR(419)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD Macro

PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONFIGURE_PHYSICAL_HDD PRL_RESULT_DECLARE_ERROR(338)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONNECT_TO_DISPATCHER Macro

PRL_ERR_CANT_CONNECT_TO_DISPATCHER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONNECT_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(249)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE Macro

PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONVERT_HDD_IMAGE_FILE PRL_RESULT_DECLARE_ERROR(310)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS Macro

PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONVERT_OLD_VM_WITH_INSTALLED_TOOLS PRL_RESULT_DECLARE_ERROR(385)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT Macro

PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_DISKS_PRESENT PRL_RESULT_DECLARE_ERROR(308)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT Macro

PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CONVERT_VM_CONFIG_DUE_UNDO_SNAPSHOTS_PRESENT PRL_RESULT_DECLARE_ERROR(309)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CREATE_FLOPPY_IMAGE Macro

PRL_ERR_CANT_CREATE_FLOPPY_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CREATE_FLOPPY_IMAGE PRL_RESULT_DECLARE_ERROR(99)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CREATE_HDD_IMAGE Macro

PRL_ERR_CANT_CREATE_HDD_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CREATE_HDD_IMAGE PRL_RESULT_DECLARE_ERROR(98)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE Macro

PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CREATE_HDD_IMAGE_NO_SPACE PRL_RESULT_DECLARE_ERROR(389)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE Macro

PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CREATE_PARALLEL_PORT_IMAGE PRL_RESULT_DECLARE_ERROR(101)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE Macro

PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_CREATE_SERIAL_PORT_IMAGE PRL_RESULT_DECLARE_ERROR(400)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_DELETE_FILE Macro

PRL_ERR_CANT_DELETE_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_DELETE_FILE PRL_RESULT_DECLARE_ERROR(282)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_EDIT_SUSPENDED_VM Macro

PRL_ERR_CANT_EDIT_SUSPENDED_VM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_EDIT_SUSPENDED_VM PRL_RESULT_DECLARE_ERROR(104)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_GET_FILE_PERMISSIONS Macro

PRL_ERR_CANT_GET_FILE_PERMISSIONS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_GET_FILE_PERMISSIONS PRL_RESULT_DECLARE_ERROR(382)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_INIT_REAL_CPUS_INFO Macro

PRL_ERR_CANT_INIT_REAL_CPUS_INFO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_INIT_REAL_CPUS_INFO PRL_RESULT_DECLARE_ERROR(272)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_PARSE_DISP_EVENT Macro

PRL_ERR_CANT_PARSE_DISP_EVENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_PARSE_DISP_EVENT PRL_RESULT_DECLARE_ERROR(244)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_PARSE_VM_CONFIG Macro

PRL_ERR_CANT_PARSE_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_PARSE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(229)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_RECREATE_HDD Macro

PRL_ERR_CANT_RECREATE_HDD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_RECREATE_HDD PRL_RESULT_DECLARE_ERROR(329)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_REMOVE_DIR_ENTRY Macro

PRL_ERR_CANT_REMOVE_DIR_ENTRY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_REMOVE_DIR_ENTRY PRL_RESULT_DECLARE_ERROR(408)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_REMOVE_ENTRY Macro

PRL_ERR_CANT_REMOVE_ENTRY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_REMOVE_ENTRY PRL_RESULT_DECLARE_ERROR(82)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN Macro

PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_REMOVE_INVALID_VM_AS_NON_ADMIN PRL_RESULT_DECLARE_ERROR(383)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_RENAME_DIR_ENTRY Macro

PRL_ERR_CANT_RENAME_DIR_ENTRY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_RENAME_DIR_ENTRY PRL_RESULT_DECLARE_ERROR(409)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_RENAME_ENTRY Macro

PRL_ERR_CANT_RENAME_ENTRY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_RENAME_ENTRY PRL_RESULT_DECLARE_ERROR(81)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE Macro

PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_REPLACE_FLOPPY_IMAGE PRL_RESULT_DECLARE_ERROR(333)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP Macro

PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_SUSPEND_VM_WITH_BOOTCAMP PRL_RESULT_DECLARE_ERROR(20010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION Macro

PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_TO_CHANGE_PERMISSIONS_ON_REMOTE_LOCATION PRL_RESULT_DECLARE_ERROR(417)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_TO_START_VM_TEMPLATE Macro

PRL_ERR_CANT_TO_START_VM_TEMPLATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_TO_START_VM_TEMPLATE PRL_RESULT_DECLARE_ERROR(368)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANT_UPDATE_DEVICE_INFO Macro

PRL_ERR_CANT_UPDATE_DEVICE_INFO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANT_UPDATE_DEVICE_INFO PRL_RESULT_DECLARE_ERROR(332)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT Macro

PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT PRL_RESULT_DECLARE_ERROR(386)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 Macro

PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CANTS_CREATE_DISK_IMAGE_ON_FAT32 PRL_RESULT_DECLARE_ERROR(387)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_CDD_IMAGE_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(208)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CLONE_OPERATION_CANCELED Macro

PRL_ERR_CLONE_OPERATION_CANCELED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CLONE_OPERATION_CANCELED PRL_RESULT_DECLARE_ERROR(107)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COM_DEVICE_ALREADY_EXIST Macro

PRL_ERR_COM_DEVICE_ALREADY_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COM_DEVICE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(254)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED Macro

PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COM_OUTPUT_FILE_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(215)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST Macro

PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COM_OUTPUT_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(217)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE Macro

PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COMMAND_SUPPORTED_ONLY_AT_SERVER_MODE PRL_RESULT_DECLARE_ERROR(421)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE Macro

PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COMMON_SERVER_PREFS_BLOCKED_TO_CHANGE PRL_RESULT_DECLARE_ERROR(271)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED Macro

PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COMMON_SERVER_PREFS_WERE_CHANGED PRL_RESULT_DECLARE_ERROR(122)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CONCURRENT_COMMAND_EXECUTING Macro

PRL_ERR_CONCURRENT_COMMAND_EXECUTING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CONCURRENT_COMMAND_EXECUTING PRL_RESULT_DECLARE_ERROR(242)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID Macro

PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_OBJECT_UUID PRL_RESULT_DECLARE_ERROR(346)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID Macro

PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CONFIG_BEGIN_EDIT_NOT_FOUND_USER_UUID PRL_RESULT_DECLARE_ERROR(347)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CONFIG_EDIT_COLLISION Macro

PRL_ERR_CONFIG_EDIT_COLLISION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CONFIG_EDIT_COLLISION PRL_RESULT_DECLARE_ERROR(323)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CONFIG_FILE_NOT_SET Macro

PRL_ERR_CONFIG_FILE_NOT_SET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CONFIG_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(38)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG Macro

PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CORE_STATE_CHANGE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(20004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE Macro

PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CORE_STATE_CORRUPT_MEM_FILE PRL_RESULT_DECLARE_ERROR(20003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE Macro

PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CORE_STATE_CORRUPT_SAV_FILE PRL_RESULT_DECLARE_ERROR(20002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CORE_STATE_ERROR_COMMON Macro

PRL_ERR_CORE_STATE_ERROR_COMMON Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Suspend/Resume codes

+++ ALIGNED VALUE TO 20000

Syntax
#define PRL_ERR_CORE_STATE_ERROR_COMMON PRL_RESULT_DECLARE_ERROR(20000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CORE_STATE_INV_SAV_VERSION Macro

PRL_ERR_CORE_STATE_INV_SAV_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CORE_STATE_INV_SAV_VERSION PRL_RESULT_DECLARE_ERROR(20001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE Macro

PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COULDNT_CREATE_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(295)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE Macro

PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_COULDNT_SET_PERMISSIONS_TO_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(296)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CPU_RESTART Macro

PRL_ERR_CPU_RESTART Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CPU_RESTART PRL_RESULT_DECLARE_ERROR(380)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CPU_SHUTDOWN Macro

PRL_ERR_CPU_SHUTDOWN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CPU_SHUTDOWN PRL_RESULT_DECLARE_ERROR(379)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_CREATE_PRIVELEGED_PROCESS Macro

PRL_ERR_CREATE_PRIVELEGED_PROCESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_CREATE_PRIVELEGED_PROCESS PRL_RESULT_DECLARE_ERROR(17002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DELETING_VM_FROM_CATALOGUE Macro

PRL_ERR_DELETING_VM_FROM_CATALOGUE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DELETING_VM_FROM_CATALOGUE PRL_RESULT_DECLARE_ERROR(253)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_ALREADY_CONNECTED Macro

PRL_ERR_DEV_ALREADY_CONNECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Common Devices Errors

+++ ALIGNED VALUE TO 9000

Syntax
#define PRL_ERR_DEV_ALREADY_CONNECTED PRL_RESULT_DECLARE_ERROR(9000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_ALREADY_DISCONNECTED Macro

PRL_ERR_DEV_ALREADY_DISCONNECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_ALREADY_DISCONNECTED PRL_RESULT_DECLARE_ERROR(9001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_DISABLE_AFTER_LOST Macro

PRL_ERR_DEV_DISABLE_AFTER_LOST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_DISABLE_AFTER_LOST PRL_RESULT_DECLARE_ERROR(343)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_FLOPPY_CONNECT_FAILED Macro

PRL_ERR_DEV_FLOPPY_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 1000

Syntax
#define PRL_ERR_DEV_FLOPPY_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(1000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED Macro

PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_MAX_CD_HDD_EXCEEDED PRL_RESULT_DECLARE_ERROR(10001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_MAX_NUMBER_EXCEEDED Macro

PRL_ERR_DEV_MAX_NUMBER_EXCEEDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Other

+++ ALIGNED VALUE TO 10000

Syntax
#define PRL_ERR_DEV_MAX_NUMBER_EXCEEDED PRL_RESULT_DECLARE_ERROR(10000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_FILE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Parallel Port

+++ ALIGNED VALUE TO 7000

Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_PHYSICAL_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_PRINTER_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED Macro

PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_PARALLEL_PORT_REMOTE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(7003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_FILE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Serial Port

+++ ALIGNED VALUE TO 6000

Syntax
#define PRL_ERR_DEV_SERIAL_PORT_PHYSICAL_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_PIPE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED Macro

PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_SERIAL_PORT_REMOTE_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(6003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED Macro

PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_USB_HARD_DEVICE_INSERTED PRL_RESULT_DECLARE_ERROR(8003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED Macro

PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_USB_INSTALL_DRIVER_FAILED PRL_RESULT_DECLARE_ERROR(8001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_USB_NO_FREE_PORTS Macro

PRL_ERR_DEV_USB_NO_FREE_PORTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DEV_USB_NO_FREE_PORTS PRL_RESULT_DECLARE_ERROR(8002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED Macro

PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • USB

+++ ALIGNED VALUE TO 8000

Syntax
#define PRL_ERR_DEV_USB_OPEN_MANAGER_FAILED PRL_RESULT_DECLARE_ERROR(8000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DIRECTORY_DOES_NOT_EXIST Macro

PRL_ERR_DIRECTORY_DOES_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DIRECTORY_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(75)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_BLOCK_CREATED Macro

PRL_ERR_DISK_BLOCK_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_BLOCK_CREATED PRL_RESULT_DECLARE_ERROR(21045)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED Macro

PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_BLOCK_PARTIALLY_PROCESSED PRL_RESULT_DECLARE_ERROR(21019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_BLOCK_SEARCH_FAILED Macro

PRL_ERR_DISK_BLOCK_SEARCH_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_BLOCK_SEARCH_FAILED PRL_RESULT_DECLARE_ERROR(22003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_BLOCK_SKIPPED Macro

PRL_ERR_DISK_BLOCK_SKIPPED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_BLOCK_SKIPPED PRL_RESULT_DECLARE_ERROR(21018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_BOOTCAMP_WRITE_MBR Macro

PRL_ERR_DISK_BOOTCAMP_WRITE_MBR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_BOOTCAMP_WRITE_MBR PRL_RESULT_DECLARE_ERROR(21059)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_CANT_INITIALIZE_IMAGE Macro

PRL_ERR_DISK_CANT_INITIALIZE_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_CANT_INITIALIZE_IMAGE PRL_RESULT_DECLARE_ERROR(21049)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_COMPRESSED_FILE_EMPTY Macro

PRL_ERR_DISK_COMPRESSED_FILE_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_COMPRESSED_FILE_EMPTY PRL_RESULT_DECLARE_ERROR(22001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_CREATE_IMAGE_ERROR Macro

PRL_ERR_DISK_CREATE_IMAGE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_CREATE_IMAGE_ERROR PRL_RESULT_DECLARE_ERROR(21016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_DATA_NOT_FOUND Macro

PRL_ERR_DISK_DATA_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • User parameters errors

* +++ ALIGNED VALUE TO 23000

Syntax
#define PRL_ERR_DISK_DATA_NOT_FOUND PRL_RESULT_DECLARE_ERROR(23000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_DIR_CREATE_ERROR Macro

PRL_ERR_DISK_DIR_CREATE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_DIR_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(21015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_DISK_NOT_OPENED Macro

PRL_ERR_DISK_DISK_NOT_OPENED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_DISK_NOT_OPENED PRL_RESULT_DECLARE_ERROR(21021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_ENLARGE_FAILED Macro

PRL_ERR_DISK_ENLARGE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_ENLARGE_FAILED PRL_RESULT_DECLARE_ERROR(21057)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FAT32_SIZE_EXCEEDED Macro

PRL_ERR_DISK_FAT32_SIZE_EXCEEDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FAT32_SIZE_EXCEEDED PRL_RESULT_DECLARE_ERROR(21023)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FILE_CREATE_ERROR Macro

PRL_ERR_DISK_FILE_CREATE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FILE_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(21013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FILE_EXISTS Macro

PRL_ERR_DISK_FILE_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FILE_EXISTS PRL_RESULT_DECLARE_ERROR(21012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FILE_OPEN_ERROR Macro

PRL_ERR_DISK_FILE_OPEN_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FILE_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(21014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FSYNC_FAILED Macro

PRL_ERR_DISK_FSYNC_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FSYNC_FAILED PRL_RESULT_DECLARE_ERROR(21031)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_FULLFSYNC_FAILED Macro

PRL_ERR_DISK_FULLFSYNC_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_FULLFSYNC_FAILED PRL_RESULT_DECLARE_ERROR(21032)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_GENERIC_ERROR Macro

PRL_ERR_DISK_GENERIC_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Range reserved for different disk errors

+++ ALIGNED VALUE TO 21000

Syntax
#define PRL_ERR_DISK_GENERIC_ERROR PRL_RESULT_DECLARE_ERROR(21000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_GET_MOUNTPATH_FAILED Macro

PRL_ERR_DISK_GET_MOUNTPATH_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Bootcamp errors

* +++ ALIGNED VALUE TO 24000

Syntax
#define PRL_ERR_DISK_GET_MOUNTPATH_FAILED PRL_RESULT_DECLARE_ERROR(24000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_GET_PARAMS_FAILED Macro

PRL_ERR_DISK_GET_PARAMS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_GET_PARAMS_FAILED PRL_RESULT_DECLARE_ERROR(24003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_GROUP_INTERSECT Macro

PRL_ERR_DISK_GROUP_INTERSECT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_GROUP_INTERSECT PRL_RESULT_DECLARE_ERROR(21046)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_IDENTIFY_FAILED Macro

PRL_ERR_DISK_IDENTIFY_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_IDENTIFY_FAILED PRL_RESULT_DECLARE_ERROR(24004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_IMAGE_BUSY Macro

PRL_ERR_DISK_IMAGE_BUSY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_IMAGE_BUSY PRL_RESULT_DECLARE_ERROR(21044)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_IMAGES_CORRUPTED Macro

PRL_ERR_DISK_IMAGES_CORRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_IMAGES_CORRUPTED PRL_RESULT_DECLARE_ERROR(21008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_IMPERSONATE_FAILED Macro

PRL_ERR_DISK_IMPERSONATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(21060)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INCORRECTLY_CLOSED Macro

PRL_ERR_DISK_INCORRECTLY_CLOSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INCORRECTLY_CLOSED PRL_RESULT_DECLARE_ERROR(21047)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INSUFFICIENT_SPACE Macro

PRL_ERR_DISK_INSUFFICIENT_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INSUFFICIENT_SPACE PRL_RESULT_DECLARE_ERROR(21022)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INTERNAL_CLASS_ERROR Macro

PRL_ERR_DISK_INTERNAL_CLASS_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INTERNAL_CLASS_ERROR PRL_RESULT_DECLARE_ERROR(21025)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INVALID_BLOCKSIZE Macro

PRL_ERR_DISK_INVALID_BLOCKSIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INVALID_BLOCKSIZE PRL_RESULT_DECLARE_ERROR(21009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INVALID_FORMAT Macro

PRL_ERR_DISK_INVALID_FORMAT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INVALID_FORMAT PRL_RESULT_DECLARE_ERROR(21033)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_INVALID_PARAMETERS Macro

PRL_ERR_DISK_INVALID_PARAMETERS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_INVALID_PARAMETERS PRL_RESULT_DECLARE_ERROR(21011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_MEMORY_ERROR Macro

PRL_ERR_DISK_MEMORY_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_MEMORY_ERROR PRL_RESULT_DECLARE_ERROR(21020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_MOUNT_FAILED Macro

PRL_ERR_DISK_MOUNT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_MOUNT_FAILED PRL_RESULT_DECLARE_ERROR(24001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_NOT_IMPLEMENTED Macro

PRL_ERR_DISK_NOT_IMPLEMENTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_NOT_IMPLEMENTED PRL_RESULT_DECLARE_ERROR(21042)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_NOT_PERMITTED Macro

PRL_ERR_DISK_NOT_PERMITTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(21024)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_NOT_VALID_OFFSET Macro

PRL_ERR_DISK_NOT_VALID_OFFSET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_NOT_VALID_OFFSET PRL_RESULT_DECLARE_ERROR(21056)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_NULL_PART_SIZE Macro

PRL_ERR_DISK_NULL_PART_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_NULL_PART_SIZE PRL_RESULT_DECLARE_ERROR(21051)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_OFFSETS_FIXED Macro

PRL_ERR_DISK_OFFSETS_FIXED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_OFFSETS_FIXED PRL_RESULT_DECLARE_ERROR(21048)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_OPERATION_ABORTED Macro

PRL_ERR_DISK_OPERATION_ABORTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_OPERATION_ABORTED PRL_RESULT_DECLARE_ERROR(21036)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_OPERATION_IN_PROGRESS Macro

PRL_ERR_DISK_OPERATION_IN_PROGRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_OPERATION_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(21017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_OPERATION_NOT_ALLOWED Macro

PRL_ERR_DISK_OPERATION_NOT_ALLOWED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_OPERATION_NOT_ALLOWED PRL_RESULT_DECLARE_ERROR(21035)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_PARTITION_INVALID_NAME Macro

PRL_ERR_DISK_PARTITION_INVALID_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_PARTITION_INVALID_NAME PRL_RESULT_DECLARE_ERROR(21054)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_PARTITION_NOT_FOUND Macro

PRL_ERR_DISK_PARTITION_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_PARTITION_NOT_FOUND PRL_RESULT_DECLARE_ERROR(21053)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE Macro

PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_PARTITIONS_TABLE_CYCLE PRL_RESULT_DECLARE_ERROR(21043)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_POINTERS_MIXED_UP Macro

PRL_ERR_DISK_POINTERS_MIXED_UP Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_POINTERS_MIXED_UP PRL_RESULT_DECLARE_ERROR(22004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_POSSIBLE_OVERRUN Macro

PRL_ERR_DISK_POSSIBLE_OVERRUN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_POSSIBLE_OVERRUN PRL_RESULT_DECLARE_ERROR(21058)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_READ_FAILED Macro

PRL_ERR_DISK_READ_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_READ_FAILED PRL_RESULT_DECLARE_ERROR(21029)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_READ_OUT_DISK Macro

PRL_ERR_DISK_READ_OUT_DISK Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_READ_OUT_DISK PRL_RESULT_DECLARE_ERROR(21028)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_RENAME_ERROR Macro

PRL_ERR_DISK_RENAME_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_RENAME_ERROR PRL_RESULT_DECLARE_ERROR(21034)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_RESERVED_WORD Macro

PRL_ERR_DISK_RESERVED_WORD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_RESERVED_WORD PRL_RESULT_DECLARE_ERROR(23001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_SET_CACHING_FAILED Macro

PRL_ERR_DISK_SET_CACHING_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_SET_CACHING_FAILED PRL_RESULT_DECLARE_ERROR(21030)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_SHARED_BLOCK Macro

PRL_ERR_DISK_SHARED_BLOCK Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Compressing errors

* +++ ALIGNED VALUE TO 22000

Syntax
#define PRL_ERR_DISK_SHARED_BLOCK PRL_RESULT_DECLARE_ERROR(22000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_SHARING_VIOLATION Macro

PRL_ERR_DISK_SHARING_VIOLATION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_SHARING_VIOLATION PRL_RESULT_DECLARE_ERROR(21037)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_SMALL_IMAGE_SIZE Macro

PRL_ERR_DISK_SMALL_IMAGE_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_SMALL_IMAGE_SIZE PRL_RESULT_DECLARE_ERROR(21050)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_SNAPSHOTS_CORRUPTED Macro

PRL_ERR_DISK_SNAPSHOTS_CORRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_SNAPSHOTS_CORRUPTED PRL_RESULT_DECLARE_ERROR(21006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_STATES_ERROR Macro

PRL_ERR_DISK_STATES_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_STATES_ERROR PRL_RESULT_DECLARE_ERROR(21010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_STORAGE_CORRUPTED Macro

PRL_ERR_DISK_STORAGE_CORRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_STORAGE_CORRUPTED PRL_RESULT_DECLARE_ERROR(21007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_TRUNCATE_FAILED Macro

PRL_ERR_DISK_TRUNCATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_TRUNCATE_FAILED PRL_RESULT_DECLARE_ERROR(22002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_UNALIGNED Macro

PRL_ERR_DISK_UNALIGNED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_UNALIGNED PRL_RESULT_DECLARE_ERROR(21055)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_UNMOUNT_FAILED Macro

PRL_ERR_DISK_UNMOUNT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_UNMOUNT_FAILED PRL_RESULT_DECLARE_ERROR(24002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_USER_INTERRUPTED Macro

PRL_ERR_DISK_USER_INTERRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_USER_INTERRUPTED PRL_RESULT_DECLARE_ERROR(21038)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_WRITE_FAILED Macro

PRL_ERR_DISK_WRITE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(21027)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_WRITE_OUT_DISK Macro

PRL_ERR_DISK_WRITE_OUT_DISK Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_WRITE_OUT_DISK PRL_RESULT_DECLARE_ERROR(21026)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_WRITE_REAL_FAILED Macro

PRL_ERR_DISK_WRITE_REAL_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_WRITE_REAL_FAILED PRL_RESULT_DECLARE_ERROR(21041)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_INVALID Macro

PRL_ERR_DISK_XML_INVALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_INVALID PRL_RESULT_DECLARE_ERROR(21002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_INVALID_VERSION Macro

PRL_ERR_DISK_XML_INVALID_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_INVALID_VERSION PRL_RESULT_DECLARE_ERROR(21003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_LARGE_FILE Macro

PRL_ERR_DISK_XML_LARGE_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_LARGE_FILE PRL_RESULT_DECLARE_ERROR(21005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_LOCKED Macro

PRL_ERR_DISK_XML_LOCKED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_LOCKED PRL_RESULT_DECLARE_ERROR(21052)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_OPEN_FAILED Macro

PRL_ERR_DISK_XML_OPEN_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(21001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_ERROR Macro

PRL_ERR_DISK_XML_SAVE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_SAVE_ERROR PRL_RESULT_DECLARE_ERROR(21004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR Macro

PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_SAVE_REMOVE_ERROR PRL_RESULT_DECLARE_ERROR(21039)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISK_XML_SAVE_RENAME_ERROR Macro

PRL_ERR_DISK_XML_SAVE_RENAME_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISK_XML_SAVE_RENAME_ERROR PRL_RESULT_DECLARE_ERROR(21040)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED Macro

PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

Dispatcher-dispatcher protocol errors codes +++ ALIGNED VALUE TO 30000

Syntax
#define PRL_ERR_DISP2DISP_SESSION_ALREADY_AUTHORIZED PRL_RESULT_DECLARE_ERROR(30000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID Macro

PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP2DISP_WRONG_USER_SESSION_UUID PRL_RESULT_DECLARE_ERROR(30001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_DISP_CONFIG_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(25)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_CONFIG_FILE_NOT_SET Macro

PRL_ERR_DISP_CONFIG_FILE_NOT_SET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_CONFIG_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(40)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_CONFIG_WRITE_ERR Macro

PRL_ERR_DISP_CONFIG_WRITE_ERR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_CONFIG_WRITE_ERR PRL_RESULT_DECLARE_ERROR(66)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT Macro

PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_LOGON_ACTIONS_REACHED_UP_LIMIT PRL_RESULT_DECLARE_ERROR(415)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_SHUTDOWN_IN_PROCESS Macro

PRL_ERR_DISP_SHUTDOWN_IN_PROCESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_SHUTDOWN_IN_PROCESS PRL_RESULT_DECLARE_ERROR(404)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED Macro

PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISP_VM_COMMAND_CANT_BE_EXECUTED PRL_RESULT_DECLARE_ERROR(416)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISP_VM_IS_NOT_STARTED Macro

PRL_ERR_DISP_VM_IS_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

Dispatcher errors codes

Syntax
#define PRL_ERR_DISP_VM_IS_NOT_STARTED PRL_RESULT_DECLARE_ERROR(377)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DISPATCHER_SERVICE_MODE Macro

PRL_ERR_DISPATCHER_SERVICE_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DISPATCHER_SERVICE_MODE PRL_RESULT_DECLARE_ERROR(364)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DOUBLE_INIT Macro

PRL_ERR_DOUBLE_INIT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DOUBLE_INIT PRL_RESULT_DECLARE_ERROR(11)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST Macro

PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_DROP_SUSPEND_FOR_HDD_QUEST PRL_RESULT_DECLARE_ERROR(405)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ENTRY_ALREADY_EXISTS Macro

PRL_ERR_ENTRY_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ENTRY_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(80)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ENTRY_DIR_ALREADY_EXISTS Macro

PRL_ERR_ENTRY_DIR_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ENTRY_DIR_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(410)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST Macro

PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ENTRY_DIR_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(411)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ENTRY_DOES_NOT_EXIST Macro

PRL_ERR_ENTRY_DOES_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ENTRY_DOES_NOT_EXIST PRL_RESULT_DECLARE_ERROR(79)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS Macro

PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_EXCEED_LIMIT_MAX_RUNNING_VMS PRL_RESULT_DECLARE_ERROR(388)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_EXCEED_MEMORY_LIMIT Macro

PRL_ERR_EXCEED_MEMORY_LIMIT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_EXCEED_MEMORY_LIMIT PRL_RESULT_DECLARE_ERROR(205)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FAILED_TO_START_VNC_SERVER Macro

PRL_ERR_FAILED_TO_START_VNC_SERVER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FAILED_TO_START_VNC_SERVER PRL_RESULT_DECLARE_ERROR(35003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FAILED_TO_STOP_VNC_SERVER Macro

PRL_ERR_FAILED_TO_STOP_VNC_SERVER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FAILED_TO_STOP_VNC_SERVER PRL_RESULT_DECLARE_ERROR(35004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FAILURE Macro

PRL_ERR_FAILURE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FAILURE PRL_RESULT_DECLARE_ERROR(9)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FDD_IMAGE_CLONE_TO_SELF Macro

PRL_ERR_FDD_IMAGE_CLONE_TO_SELF Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FDD_IMAGE_CLONE_TO_SELF PRL_RESULT_DECLARE_ERROR(315)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FDD_IMAGE_COPY Macro

PRL_ERR_FDD_IMAGE_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FDD_IMAGE_COPY PRL_RESULT_DECLARE_ERROR(314)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_FDD_IMAGE_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(209)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_DISK_SPACE_ERROR Macro

PRL_ERR_FILE_DISK_SPACE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_DISK_SPACE_ERROR PRL_RESULT_DECLARE_ERROR(373)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_NOT_EXIST Macro

PRL_ERR_FILE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(322)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_NOT_FOUND Macro

PRL_ERR_FILE_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_NOT_FOUND PRL_RESULT_DECLARE_ERROR(10)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS Macro

PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_OR_DIR_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(355)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_READ_ERROR Macro

PRL_ERR_FILE_READ_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_READ_ERROR PRL_RESULT_DECLARE_ERROR(110)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_CREATE_DST_FILE PRL_RESULT_DECLARE_ERROR(26004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_LOCATE_SRC_FILE PRL_RESULT_DECLARE_ERROR(26001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_READ_SRC_FILE PRL_RESULT_DECLARE_ERROR(26002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE Macro

PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_CANT_WRITE_DATA_TO_DST_FILE PRL_RESULT_DECLARE_ERROR(26005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED Macro

PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • File Transfer errors

+++ ALIGNED VALUE TO 26000

Syntax
#define PRL_ERR_FILE_TRANSFER_CLIENT_NOT_CONNECTED PRL_RESULT_DECLARE_ERROR(26000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST Macro

PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_DST_FILE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(26006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS Macro

PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_INVALID_ARGUMENTS PRL_RESULT_DECLARE_ERROR(26009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS Macro

PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_INVALID_CREDENTIALS PRL_RESULT_DECLARE_ERROR(26003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED Macro

PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_OPERATION_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(26007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER Macro

PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_TRANSFER_UPLOAD_CANCELED_BY_USER PRL_RESULT_DECLARE_ERROR(26008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FILE_WRITE_ERROR Macro

PRL_ERR_FILE_WRITE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FILE_WRITE_ERROR PRL_RESULT_DECLARE_ERROR(372)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FIXME Macro

PRL_ERR_FIXME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FIXME PRL_RESULT_DECLARE_ERROR(227)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FLOPPY_DRIVE_INVALID Macro

PRL_ERR_FLOPPY_DRIVE_INVALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FLOPPY_DRIVE_INVALID PRL_RESULT_DECLARE_ERROR(226)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST Macro

PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FLOPPY_IMAGE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(256)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FLOPPY_IMAGE_NOT_EXIST Macro

PRL_ERR_FLOPPY_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FLOPPY_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(95)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FREE_DISC_SPACE_FOR_CLONE Macro

PRL_ERR_FREE_DISC_SPACE_FOR_CLONE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FREE_DISC_SPACE_FOR_CLONE PRL_RESULT_DECLARE_ERROR(371)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT Macro

PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FREE_DISK_SPACE_FOR_CREATE_SNAPSHOT PRL_RESULT_DECLARE_ERROR(442)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT Macro

PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_FREE_DISK_SPACE_FOR_REVERT_TO_SNAPSHOT PRL_RESULT_DECLARE_ERROR(443)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_LICENSE_INVALID_ARG Macro

PRL_ERR_GET_LICENSE_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_LICENSE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(137)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_MON_STATE_INVALID_ARG Macro

PRL_ERR_GET_MON_STATE_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_MON_STATE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(128)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED Macro

PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_MON_STATE_VM_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(129)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_MON_STATE_VM_NOT_CREATED Macro

PRL_ERR_GET_MON_STATE_VM_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_MON_STATE_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(127)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_NET_SERVICE_STATUS_FAILED Macro

PRL_ERR_GET_NET_SERVICE_STATUS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_NET_SERVICE_STATUS_FAILED PRL_RESULT_DECLARE_ERROR(353)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG Macro

PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_RESOLUTION_TOOL_INVALID_ARG PRL_RESULT_DECLARE_ERROR(176)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED Macro

PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_RESOLUTION_TOOL_VMNOTCREATED PRL_RESULT_DECLARE_ERROR(175)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GET_USER_HOME_DIR Macro

PRL_ERR_GET_USER_HOME_DIR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GET_USER_HOME_DIR PRL_RESULT_DECLARE_ERROR(243)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GUEST_MAC_INVALID_VERSION Macro

PRL_ERR_GUEST_MAC_INVALID_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GUEST_MAC_INVALID_VERSION PRL_RESULT_DECLARE_ERROR(359)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY Macro

PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GUEST_MAC_NOT_ENOUGH_MEMORY PRL_RESULT_DECLARE_ERROR(358)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST Macro

PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GUEST_MAC_NOT_MACSERVER_HOST PRL_RESULT_DECLARE_ERROR(397)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_GUEST_TOOLS_NOT_INSTALLED Macro

PRL_ERR_GUEST_TOOLS_NOT_INSTALLED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_GUEST_TOOLS_NOT_INSTALLED PRL_RESULT_DECLARE_ERROR(423)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HANDSHAKE_FAILED Macro

PRL_ERR_HANDSHAKE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HANDSHAKE_FAILED PRL_RESULT_DECLARE_ERROR(412)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HARD_DISK_IMAGE_CORRUPTED Macro

PRL_ERR_HARD_DISK_IMAGE_CORRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HARD_DISK_IMAGE_CORRUPTED PRL_RESULT_DECLARE_ERROR(2002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HDD_IMAGE_CLONE_TO_SELF Macro

PRL_ERR_HDD_IMAGE_CLONE_TO_SELF Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HDD_IMAGE_CLONE_TO_SELF PRL_RESULT_DECLARE_ERROR(94)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HDD_IMAGE_COPY Macro

PRL_ERR_HDD_IMAGE_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HDD_IMAGE_COPY PRL_RESULT_DECLARE_ERROR(237)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST Macro

PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HDD_IMAGE_IS_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(288)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HDD_IMAGE_NOT_EXIST Macro

PRL_ERR_HDD_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(93)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HDD_IMAGE_NOT_SPECIFIED Macro

PRL_ERR_HDD_IMAGE_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HDD_IMAGE_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(206)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HOST_AMD_GUEST_MAC Macro

PRL_ERR_HOST_AMD_GUEST_MAC Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HOST_AMD_GUEST_MAC PRL_RESULT_DECLARE_ERROR(348)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HVT_DISABLED Macro

PRL_ERR_HVT_DISABLED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HVT_DISABLED PRL_RESULT_DECLARE_ERROR(341)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HVT_NOT_PRESENT Macro

PRL_ERR_HVT_NOT_PRESENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HVT_NOT_PRESENT PRL_RESULT_DECLARE_ERROR(336)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HVT_TURNED_OFF_IN_CONFIG Macro

PRL_ERR_HVT_TURNED_OFF_IN_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HVT_TURNED_OFF_IN_CONFIG PRL_RESULT_DECLARE_ERROR(367)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_HYP_ALLOC_VMS_MEMORY Macro

PRL_ERR_HYP_ALLOC_VMS_MEMORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_HYP_ALLOC_VMS_MEMORY PRL_RESULT_DECLARE_ERROR(431)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IMAGE_NEED_TO_CONVERT Macro

PRL_ERR_IMAGE_NEED_TO_CONVERT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IMAGE_NEED_TO_CONVERT PRL_RESULT_DECLARE_ERROR(2001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IMPERSONATE_FAILED Macro

PRL_ERR_IMPERSONATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(350)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INCONSISTENCY_VM_CONFIG Macro

PRL_ERR_INCONSISTENCY_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INCONSISTENCY_VM_CONFIG PRL_RESULT_DECLARE_ERROR(106)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INCORRECT_CDROM_PATH Macro

PRL_ERR_INCORRECT_CDROM_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INCORRECT_CDROM_PATH PRL_RESULT_DECLARE_ERROR(1001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INCORRECT_FDD_PATH Macro

PRL_ERR_INCORRECT_FDD_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INCORRECT_FDD_PATH PRL_RESULT_DECLARE_ERROR(335)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INCORRECT_PATH Macro

PRL_ERR_INCORRECT_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INCORRECT_PATH PRL_RESULT_DECLARE_ERROR(324)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INSERTING_VM_TO_CATALOGUE Macro

PRL_ERR_INSERTING_VM_TO_CATALOGUE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INSERTING_VM_TO_CATALOGUE PRL_RESULT_DECLARE_ERROR(238)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INSTALLATION_PROBLEM Macro

PRL_ERR_INSTALLATION_PROBLEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INSTALLATION_PROBLEM PRL_RESULT_DECLARE_ERROR(284)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED Macro

PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_ACCESS_TOKEN_RECEIVED PRL_RESULT_DECLARE_ERROR(245)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_ARG Macro

PRL_ERR_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_ARG PRL_RESULT_DECLARE_ERROR(3)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_CONFIGURATION Macro

PRL_ERR_INVALID_CONFIGURATION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_CONFIGURATION PRL_RESULT_DECLARE_ERROR(365)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_HANDLE Macro

PRL_ERR_INVALID_HANDLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_HANDLE PRL_RESULT_DECLARE_ERROR(4)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_HDD_GEOMETRY Macro

PRL_ERR_INVALID_HDD_GEOMETRY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_HDD_GEOMETRY PRL_RESULT_DECLARE_ERROR(207)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED Macro

PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_KEXT_REBOOT_REQUIRED PRL_RESULT_DECLARE_ERROR(430)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_MEMORY_SIZE Macro

PRL_ERR_INVALID_MEMORY_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_MEMORY_SIZE PRL_RESULT_DECLARE_ERROR(204)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_PARALLELS_DISK Macro

PRL_ERR_INVALID_PARALLELS_DISK Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Hard Drive

+++ ALIGNED VALUE TO 2000

Syntax
#define PRL_ERR_INVALID_PARALLELS_DISK PRL_RESULT_DECLARE_ERROR(2000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_INVALID_PARAM Macro

PRL_ERR_INVALID_PARAM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_INVALID_PARAM PRL_RESULT_DECLARE_ERROR(18)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_AUTHENTICATION_FAILED Macro

PRL_ERR_IO_AUTHENTICATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(304)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_CONNECTION_TIMEOUT Macro

PRL_ERR_IO_CONNECTION_TIMEOUT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_CONNECTION_TIMEOUT PRL_RESULT_DECLARE_ERROR(303)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_DISABLED Macro

PRL_ERR_IO_DISABLED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_DISABLED PRL_RESULT_DECLARE_ERROR(340)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_INVALID_POINTER_ACCESS Macro

PRL_ERR_IO_INVALID_POINTER_ACCESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_INVALID_POINTER_ACCESS PRL_RESULT_DECLARE_ERROR(452)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_NO_CONNECTION Macro

PRL_ERR_IO_NO_CONNECTION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_NO_CONNECTION PRL_RESULT_DECLARE_ERROR(401)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_SEND_QUEUE_IS_FULL Macro

PRL_ERR_IO_SEND_QUEUE_IS_FULL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_SEND_QUEUE_IS_FULL PRL_RESULT_DECLARE_ERROR(300)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_STOPPED Macro

PRL_ERR_IO_STOPPED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_STOPPED PRL_RESULT_DECLARE_ERROR(301)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IO_UNKNOWN_VM_ID Macro

PRL_ERR_IO_UNKNOWN_VM_ID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IO_UNKNOWN_VM_ID PRL_RESULT_DECLARE_ERROR(302)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_INVALID_MODE Macro

PRL_ERR_IPFO_INVALID_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_INVALID_MODE PRL_RESULT_DECLARE_ERROR(29006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_RECEIVE_FAILED Macro

PRL_ERR_IPFO_RECEIVE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_RECEIVE_FAILED PRL_RESULT_DECLARE_ERROR(29008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SEND_FAILED Macro

PRL_ERR_IPFO_SEND_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SEND_FAILED PRL_RESULT_DECLARE_ERROR(29007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED Macro

PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SOCKET_ACCEPT_FAILED PRL_RESULT_DECLARE_ERROR(29003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_BIND_FAILED Macro

PRL_ERR_IPFO_SOCKET_BIND_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SOCKET_BIND_FAILED PRL_RESULT_DECLARE_ERROR(29001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_CONNECT_FAILED Macro

PRL_ERR_IPFO_SOCKET_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SOCKET_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(29004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_CREATE_FAILED Macro

PRL_ERR_IPFO_SOCKET_CREATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Errors for IPC file open library

+++ ALIGNED VALUE TO 29000

Syntax
#define PRL_ERR_IPFO_SOCKET_CREATE_FAILED PRL_RESULT_DECLARE_ERROR(29000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_LISTEN_FAILED Macro

PRL_ERR_IPFO_SOCKET_LISTEN_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SOCKET_LISTEN_FAILED PRL_RESULT_DECLARE_ERROR(29002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPFO_SOCKET_NOT_OPENED Macro

PRL_ERR_IPFO_SOCKET_NOT_OPENED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPFO_SOCKET_NOT_OPENED PRL_RESULT_DECLARE_ERROR(29005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_ALREADY_STARTED Macro

PRL_ERR_IPHONE_PROXY_ALREADY_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPHONE_PROXY_ALREADY_STARTED PRL_RESULT_DECLARE_ERROR(32002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_CANNOT_START Macro

PRL_ERR_IPHONE_PROXY_CANNOT_START Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

iPhone proxy errors +++ ALIGNED VALUE TO 32000

Syntax
#define PRL_ERR_IPHONE_PROXY_CANNOT_START PRL_RESULT_DECLARE_ERROR(32000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_IPHONE_PROXY_CANNOT_STOP Macro

PRL_ERR_IPHONE_PROXY_CANNOT_STOP Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_IPHONE_PROXY_CANNOT_STOP PRL_RESULT_DECLARE_ERROR(32001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_AUTH_FAILED Macro

PRL_ERR_LICENSE_AUTH_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_AUTH_FAILED PRL_RESULT_DECLARE_ERROR(11007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT Macro

PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_BETA_KEY_RELEASE_PRODUCT PRL_RESULT_DECLARE_ERROR(11011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_EXPIRED Macro

PRL_ERR_LICENSE_EXPIRED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_EXPIRED PRL_RESULT_DECLARE_ERROR(11001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_FILE_WRITE_FAILED Macro

PRL_ERR_LICENSE_FILE_WRITE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_FILE_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(11010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_NOT_STARTED Macro

PRL_ERR_LICENSE_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_NOT_STARTED PRL_RESULT_DECLARE_ERROR(11014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_NOT_VALID Macro

PRL_ERR_LICENSE_NOT_VALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_NOT_VALID PRL_RESULT_DECLARE_ERROR(11000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT Macro

PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_RELEASE_KEY_BETA_PRODUCT PRL_RESULT_DECLARE_ERROR(11013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_TOO_MANY_VCPUS Macro

PRL_ERR_LICENSE_TOO_MANY_VCPUS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_TOO_MANY_VCPUS PRL_RESULT_DECLARE_ERROR(11012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE Macro

PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE PRL_RESULT_DECLARE_ERROR(11009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_VALID Macro

PRL_ERR_LICENSE_VALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • License

+++ ALIGNED VALUE TO 11000

Syntax
#define PRL_ERR_LICENSE_VALID PRL_ERR_SUCCESS
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD Macro

PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_ADVANCED_FIELD PRL_RESULT_DECLARE_ERROR(11008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_DISTRIBUTOR Macro

PRL_ERR_LICENSE_WRONG_DISTRIBUTOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_DISTRIBUTOR PRL_RESULT_DECLARE_ERROR(11006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_LANGUAGE Macro

PRL_ERR_LICENSE_WRONG_LANGUAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_LANGUAGE PRL_RESULT_DECLARE_ERROR(11005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_PLATFORM Macro

PRL_ERR_LICENSE_WRONG_PLATFORM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_PLATFORM PRL_RESULT_DECLARE_ERROR(11004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_PRODUCT Macro

PRL_ERR_LICENSE_WRONG_PRODUCT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_PRODUCT PRL_RESULT_DECLARE_ERROR(11003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LICENSE_WRONG_VERSION Macro

PRL_ERR_LICENSE_WRONG_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LICENSE_WRONG_VERSION PRL_RESULT_DECLARE_ERROR(11002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LOCAL_AUTHENTICATION_FAILED Macro

PRL_ERR_LOCAL_AUTHENTICATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LOCAL_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(331)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LPT_DEVICE_ALREADY_EXIST Macro

PRL_ERR_LPT_DEVICE_ALREADY_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LPT_DEVICE_ALREADY_EXIST PRL_RESULT_DECLARE_ERROR(255)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED Macro

PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LPT_OUTPUT_FILE_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(216)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST Macro

PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_LPT_OUTPUT_FILE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(218)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH Macro

PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_IN_CORRECT_LENGTH PRL_RESULT_DECLARE_ERROR(211)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_INCORRECT Macro

PRL_ERR_MAC_ADDRESS_INCORRECT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_INCORRECT PRL_RESULT_DECLARE_ERROR(328)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_IS_EMPTY Macro

PRL_ERR_MAC_ADDRESS_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_IS_EMPTY PRL_RESULT_DECLARE_ERROR(210)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START Macro

PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_WITH_2_ZERO_START PRL_RESULT_DECLARE_ERROR(212)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS Macro

PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_WITH_ALL_ZEROS PRL_RESULT_DECLARE_ERROR(213)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS Macro

PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAC_ADDRESS_WITHIN_CORRECT_SYMBOLS PRL_RESULT_DECLARE_ERROR(214)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_MAKE_DIRECTORY Macro

PRL_ERR_MAKE_DIRECTORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_MAKE_DIRECTORY PRL_RESULT_DECLARE_ERROR(232)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NEED_KILL_PREV_SETTING Macro

PRL_ERR_NEED_KILL_PREV_SETTING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NEED_KILL_PREV_SETTING PRL_RESULT_DECLARE_SUCCESS(426)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NETWORK_ROLLBACK_FAILED Macro

PRL_ERR_NETWORK_ROLLBACK_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NETWORK_ROLLBACK_FAILED PRL_RESULT_DECLARE_ERROR(270)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_BOOTING_DEVICE_SELECTED Macro

PRL_ERR_NO_BOOTING_DEVICE_SELECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_BOOTING_DEVICE_SELECTED PRL_RESULT_DECLARE_ERROR(334)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_CD_DRIVE_AVAILABLE Macro

PRL_ERR_NO_CD_DRIVE_AVAILABLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_CD_DRIVE_AVAILABLE PRL_RESULT_DECLARE_ERROR(418)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_DATA Macro

PRL_ERR_NO_DATA Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_DATA PRL_RESULT_DECLARE_ERROR(14)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_DISP_CONFIG_FOUND Macro

PRL_ERR_NO_DISP_CONFIG_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_DISP_CONFIG_FOUND PRL_RESULT_DECLARE_ERROR(19)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS Macro

PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS PRL_RESULT_DECLARE_ERROR(369)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_PROBLEM_REPORT_FOUND Macro

PRL_ERR_NO_PROBLEM_REPORT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_PROBLEM_REPORT_FOUND PRL_RESULT_DECLARE_ERROR(85)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED Macro

PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_TARGET_DIR_PATH_SPECIFIED PRL_RESULT_DECLARE_ERROR(407)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_TARGET_PATH_SPECIFIED Macro

PRL_ERR_NO_TARGET_PATH_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_TARGET_PATH_SPECIFIED PRL_RESULT_DECLARE_ERROR(74)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NO_VM_DIR_CONFIG_FOUND Macro

PRL_ERR_NO_VM_DIR_CONFIG_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NO_VM_DIR_CONFIG_FOUND PRL_RESULT_DECLARE_ERROR(26)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_ALL_FILES_WAS_DELETED Macro

PRL_ERR_NOT_ALL_FILES_WAS_DELETED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_ALL_FILES_WAS_DELETED PRL_RESULT_DECLARE_ERROR(102)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_CONNECTED_TO_DISPATCHER Macro

PRL_ERR_NOT_CONNECTED_TO_DISPATCHER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_CONNECTED_TO_DISPATCHER PRL_RESULT_DECLARE_ERROR(251)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE Macro

PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_FREE_SPACE PRL_RESULT_DECLARE_ERROR(307)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_START_VM PRL_RESULT_DECLARE_ERROR(456)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE Macro

PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_ENOUGH_DISK_SPACE_TO_XML_SAVE PRL_RESULT_DECLARE_ERROR(453)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE Macro

PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NOT_ENOUGH_PERMS_TO_OPEN_AUTHORIZATION_FILE PRL_RESULT_DECLARE_ERROR(298)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_NVRAM_FILE_COPY Macro

PRL_ERR_NVRAM_FILE_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_NVRAM_FILE_COPY PRL_RESULT_DECLARE_ERROR(436)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OBJECT_WAS_REMOVED Macro

PRL_ERR_OBJECT_WAS_REMOVED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OBJECT_WAS_REMOVED PRL_RESULT_DECLARE_ERROR(406)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT Macro

PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_ONLY_ADMIN_CAN_SET_PARAMETER_STARTLOGINMODE_ROOT PRL_RESULT_DECLARE_ERROR(395)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION Macro

PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

VM guest operations errors +++ ALIGNED VALUE TO 34000

Syntax
#define PRL_ERR_ONLY_ADMIN_OR_VM_OWNER_CAN_OPEN_THIS_SESSION PRL_RESULT_DECLARE_ERROR(34000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_DISP_CONFIG_READ Macro

PRL_ERR_OPEN_DISP_CONFIG_READ Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_DISP_CONFIG_READ PRL_RESULT_DECLARE_ERROR(21)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_DISP_CONFIG_WRITE Macro

PRL_ERR_OPEN_DISP_CONFIG_WRITE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_DISP_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(22)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_PROBLEM_REPORT_READ Macro

PRL_ERR_OPEN_PROBLEM_REPORT_READ Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_PROBLEM_REPORT_READ PRL_RESULT_DECLARE_ERROR(86)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_VM_CONFIG_READ Macro

PRL_ERR_OPEN_VM_CONFIG_READ Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_VM_CONFIG_READ PRL_RESULT_DECLARE_ERROR(33)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_VM_CONFIG_WRITE Macro

PRL_ERR_OPEN_VM_CONFIG_WRITE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_VM_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(34)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_VM_DIR_CONFIG_READ Macro

PRL_ERR_OPEN_VM_DIR_CONFIG_READ Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_VM_DIR_CONFIG_READ PRL_RESULT_DECLARE_ERROR(28)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE Macro

PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPEN_VM_DIR_CONFIG_WRITE PRL_RESULT_DECLARE_ERROR(29)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPERATION_FAILED Macro

PRL_ERR_OPERATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(16)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPERATION_PENDING Macro

PRL_ERR_OPERATION_PENDING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPERATION_PENDING PRL_RESULT_DECLARE_ERROR(13)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OPERATION_WAS_CANCELED Macro

PRL_ERR_OPERATION_WAS_CANCELED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OPERATION_WAS_CANCELED PRL_RESULT_DECLARE_ERROR(275)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OUT_OF_DISK_SPACE Macro

PRL_ERR_OUT_OF_DISK_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OUT_OF_DISK_SPACE PRL_RESULT_DECLARE_ERROR(297)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_OUT_OF_MEMORY Macro

PRL_ERR_OUT_OF_MEMORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_OUT_OF_MEMORY PRL_RESULT_DECLARE_ERROR(2)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST Macro

PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARALLEL_PORT_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(97)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARALLEL_PORT_IMG_COPY Macro

PRL_ERR_PARALLEL_PORT_IMG_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARALLEL_PORT_IMG_COPY PRL_RESULT_DECLARE_ERROR(236)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARAM_NOT_FOUND Macro

PRL_ERR_PARAM_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARAM_NOT_FOUND PRL_RESULT_DECLARE_ERROR(17)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_CLIENT_PREFS Macro

PRL_ERR_PARSE_CLIENT_PREFS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_CLIENT_PREFS PRL_RESULT_DECLARE_ERROR(117)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_COMMON_SERVER_PREFS Macro

PRL_ERR_PARSE_COMMON_SERVER_PREFS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_COMMON_SERVER_PREFS PRL_RESULT_DECLARE_ERROR(121)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_DISP_CONFIG Macro

PRL_ERR_PARSE_DISP_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_DISP_CONFIG PRL_RESULT_DECLARE_ERROR(23)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_FILESYSTEM_INFO Macro

PRL_ERR_PARSE_FILESYSTEM_INFO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_FILESYSTEM_INFO PRL_RESULT_DECLARE_ERROR(72)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_HARD_DISK_HW_INFO Macro

PRL_ERR_PARSE_HARD_DISK_HW_INFO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_HARD_DISK_HW_INFO PRL_RESULT_DECLARE_ERROR(71)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_HOST_HW_INFO Macro

PRL_ERR_PARSE_HOST_HW_INFO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_HOST_HW_INFO PRL_RESULT_DECLARE_ERROR(70)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_PROBLEM_REPORT Macro

PRL_ERR_PARSE_PROBLEM_REPORT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_PROBLEM_REPORT PRL_RESULT_DECLARE_ERROR(84)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_STATISTICS Macro

PRL_ERR_PARSE_STATISTICS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_STATISTICS PRL_RESULT_DECLARE_ERROR(276)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_USER_PROFILE Macro

PRL_ERR_PARSE_USER_PROFILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_USER_PROFILE PRL_RESULT_DECLARE_ERROR(73)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_VM_CONFIG Macro

PRL_ERR_PARSE_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(36)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSE_VM_DIR_CONFIG Macro

PRL_ERR_PARSE_VM_DIR_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSE_VM_DIR_CONFIG PRL_RESULT_DECLARE_ERROR(30)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PARSING_EVENT Macro

PRL_ERR_PARSING_EVENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PARSING_EVENT PRL_RESULT_DECLARE_ERROR(24)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PREV_SESSION_IS_ACTIVE Macro

PRL_ERR_PREV_SESSION_IS_ACTIVE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PREV_SESSION_IS_ACTIVE PRL_RESULT_DECLARE_ERROR(64)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS Macro

PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PROBLEM_REPORT_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(88)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_FILE_NOTSET Macro

PRL_ERR_PROBLEM_REPORT_FILE_NOTSET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PROBLEM_REPORT_FILE_NOTSET PRL_RESULT_DECLARE_ERROR(87)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_PROBLEM_REPORT_WRITE Macro

PRL_ERR_PROBLEM_REPORT_WRITE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_PROBLEM_REPORT_WRITE PRL_RESULT_DECLARE_ERROR(89)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_READ_XML_CONTENT Macro

PRL_ERR_READ_XML_CONTENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_READ_XML_CONTENT PRL_RESULT_DECLARE_ERROR(35)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_READONLY_FILESYSTEM Macro

PRL_ERR_READONLY_FILESYSTEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_READONLY_FILESYSTEM PRL_RESULT_DECLARE_ERROR(356)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REBOOT_HOST Macro

PRL_ERR_REBOOT_HOST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REBOOT_HOST PRL_RESULT_DECLARE_ERROR(352)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_EXIST Macro

PRL_ERR_REMOTE_DEVICE_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REMOTE_DEVICE_EXIST PRL_RESULT_DECLARE_ERROR(279)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_NOT_EXIST Macro

PRL_ERR_REMOTE_DEVICE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REMOTE_DEVICE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(280)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED Macro

PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

Device of this type cannot be remote device type is not registered

Syntax
#define PRL_ERR_REMOTE_DEVICE_NOT_REGISTERED PRL_RESULT_DECLARE_ERROR(278)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED Macro

PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REMOTE_DISPLAY_HOST_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(344)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER Macro

PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REMOTE_DISPLAY_WRONG_PORT_NUMBER PRL_RESULT_DECLARE_ERROR(345)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_RETRIEVE_VM_CONFIG Macro

PRL_ERR_RETRIEVE_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_RETRIEVE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(240)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_RETURN_CODE_RANG_EEND Macro

PRL_ERR_RETURN_CODE_RANG_EEND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_RETURN_CODE_RANG_EEND PRL_RESULT_DECLARE_ERROR(113)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_REVERT_IMPERSONATE_FAILED Macro

PRL_ERR_REVERT_IMPERSONATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_REVERT_IMPERSONATE_FAILED PRL_RESULT_DECLARE_ERROR(351)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SAVE_VM_CATALOG Macro

PRL_ERR_SAVE_VM_CATALOG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SAVE_VM_CATALOG PRL_RESULT_DECLARE_ERROR(90)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SAVE_VM_CONFIG Macro

PRL_ERR_SAVE_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SAVE_VM_CONFIG PRL_RESULT_DECLARE_ERROR(234)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED Macro

PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SEARCH_CONFIG_OPERATION_CANCELED PRL_RESULT_DECLARE_ERROR(108)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SEND_COMMAND_TOWS_FAILED Macro

PRL_ERR_SEND_COMMAND_TOWS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SEND_COMMAND_TOWS_FAILED PRL_RESULT_DECLARE_ERROR(250)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SERIAL_IMG_COPY Macro

PRL_ERR_SERIAL_IMG_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SERIAL_IMG_COPY PRL_RESULT_DECLARE_ERROR(235)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SERIAL_IMG_NOT_FOUND Macro

PRL_ERR_SERIAL_IMG_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SERIAL_IMG_NOT_FOUND PRL_RESULT_DECLARE_ERROR(233)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST Macro

PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SERIAL_PORT_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(96)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SERVER_GOES_DOWN Macro

PRL_ERR_SERVER_GOES_DOWN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SERVER_GOES_DOWN PRL_RESULT_DECLARE_ERROR(248)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SERVER_PREFS_EDIT_COLLISION Macro

PRL_ERR_SERVER_PREFS_EDIT_COLLISION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SERVER_PREFS_EDIT_COLLISION PRL_RESULT_DECLARE_ERROR(326)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SET_LICENSE_INVALID_ARG Macro

PRL_ERR_SET_LICENSE_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SET_LICENSE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(138)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SET_LICENSE_INVALID_KEY Macro

PRL_ERR_SET_LICENSE_INVALID_KEY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SET_LICENSE_INVALID_KEY PRL_RESULT_DECLARE_ERROR(139)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE Macro

PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SHUT_DOWN_NOT_IFICATION_SERVICE PRL_RESULT_DECLARE_ERROR(247)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SMC_ERROR Macro

PRL_ERR_SMC_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SMC_ERROR PRL_RESULT_DECLARE_ERROR(111)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SNAPSHOTS_COPY Macro

PRL_ERR_SNAPSHOTS_COPY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SNAPSHOTS_COPY PRL_RESULT_DECLARE_ERROR(437)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SOME_TASKS_PRESENT Macro

PRL_ERR_SOME_TASKS_PRESENT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SOME_TASKS_PRESENT PRL_RESULT_DECLARE_ERROR(363)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SOME_VMS_RUNNING Macro

PRL_ERR_SOME_VMS_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SOME_VMS_RUNNING PRL_RESULT_DECLARE_ERROR(362)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SOUND_DEVICE_WRITE_FAILED Macro

PRL_ERR_SOUND_DEVICE_WRITE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Sound

+++ ALIGNED VALUE TO 5000

Syntax
#define PRL_ERR_SOUND_DEVICE_WRITE_FAILED PRL_RESULT_DECLARE_ERROR(5000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED Macro

PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SOUND_IN_DEVICE_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(5002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED Macro

PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SOUND_OUT_DEVICE_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(5001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SSL_HANDSHAKE_FAILED Macro

PRL_ERR_SSL_HANDSHAKE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SSL_HANDSHAKE_FAILED PRL_RESULT_DECLARE_ERROR(414)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_ALREADY_EXISTS Macro

PRL_ERR_STATE_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(19015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG Macro

PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_CANT_LOAD_SPECIFIED_CFG PRL_RESULT_DECLARE_ERROR(19024)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_FOR_WRITE Macro

PRL_ERR_STATE_CANT_OPEN_FOR_WRITE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_CANT_OPEN_FOR_WRITE PRL_RESULT_DECLARE_ERROR(19010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_IMAGE Macro

PRL_ERR_STATE_CANT_OPEN_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_CANT_OPEN_IMAGE PRL_RESULT_DECLARE_ERROR(19009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_CANT_OPEN_LOCKED Macro

PRL_ERR_STATE_CANT_OPEN_LOCKED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_CANT_OPEN_LOCKED PRL_RESULT_DECLARE_ERROR(19011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_CANT_SAVE_LOCKED Macro

PRL_ERR_STATE_CANT_SAVE_LOCKED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_CANT_SAVE_LOCKED PRL_RESULT_DECLARE_ERROR(19012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_DELETE_NONCLOSED Macro

PRL_ERR_STATE_DELETE_NONCLOSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_DELETE_NONCLOSED PRL_RESULT_DECLARE_ERROR(19023)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_ERROR_CREATE_IMAGE Macro

PRL_ERR_STATE_ERROR_CREATE_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_ERROR_CREATE_IMAGE PRL_RESULT_DECLARE_ERROR(19007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_ERROR_RENAMING_IMAGE Macro

PRL_ERR_STATE_ERROR_RENAMING_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_ERROR_RENAMING_IMAGE PRL_RESULT_DECLARE_ERROR(19008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_FULL_DELETE_FAILED Macro

PRL_ERR_STATE_FULL_DELETE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_FULL_DELETE_FAILED PRL_RESULT_DECLARE_ERROR(19018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_GETFREESPACE_FAILED Macro

PRL_ERR_STATE_GETFREESPACE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_GETFREESPACE_FAILED PRL_RESULT_DECLARE_ERROR(19025)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_INT_CORRUPTED Macro

PRL_ERR_STATE_INT_CORRUPTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_INT_CORRUPTED PRL_RESULT_DECLARE_ERROR(19013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_INVALID_IMAGE_TYPE Macro

PRL_ERR_STATE_INVALID_IMAGE_TYPE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_INVALID_IMAGE_TYPE PRL_RESULT_DECLARE_ERROR(19022)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_INVALID_PARAMETERS Macro

PRL_ERR_STATE_INVALID_PARAMETERS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_INVALID_PARAMETERS PRL_RESULT_DECLARE_ERROR(19006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_MEMORY_ERROR Macro

PRL_ERR_STATE_MEMORY_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_MEMORY_ERROR PRL_RESULT_DECLARE_ERROR(19021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_MERGE_FAILED Macro

PRL_ERR_STATE_MERGE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_MERGE_FAILED PRL_RESULT_DECLARE_ERROR(19019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_MERGE_NO_SPACE Macro

PRL_ERR_STATE_MERGE_NO_SPACE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_MERGE_NO_SPACE PRL_RESULT_DECLARE_ERROR(19020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_NO_DISKS Macro

PRL_ERR_STATE_NO_DISKS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_NO_DISKS PRL_RESULT_DECLARE_ERROR(19001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_NO_STATE Macro

PRL_ERR_STATE_NO_STATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_NO_STATE PRL_RESULT_DECLARE_ERROR(19014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_NOT_OPENED Macro

PRL_ERR_STATE_NOT_OPENED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_NOT_OPENED PRL_RESULT_DECLARE_ERROR(19016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_NOT_PERMITTED Macro

PRL_ERR_STATE_NOT_PERMITTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_NOT_PERMITTED PRL_RESULT_DECLARE_ERROR(19017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_NOT_RELEASED Macro

PRL_ERR_STATE_NOT_RELEASED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_NOT_RELEASED PRL_RESULT_DECLARE_ERROR(19027)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_PROCESS_RUNNING Macro

PRL_ERR_STATE_PROCESS_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_PROCESS_RUNNING PRL_RESULT_DECLARE_ERROR(19002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_ROLLBACK_ERROR Macro

PRL_ERR_STATE_ROLLBACK_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_ROLLBACK_ERROR PRL_RESULT_DECLARE_ERROR(19005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_ROLLBACK_IN_PROGRESS Macro

PRL_ERR_STATE_ROLLBACK_IN_PROGRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_ROLLBACK_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(19004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_STATFS_FAILED Macro

PRL_ERR_STATE_STATFS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_STATFS_FAILED PRL_RESULT_DECLARE_ERROR(19026)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_STOPPING_STATE Macro

PRL_ERR_STATE_STOPPING_STATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_STATE_STOPPING_STATE PRL_RESULT_DECLARE_ERROR(19003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_STATE_UNEXPECTED_ERROR Macro

PRL_ERR_STATE_UNEXPECTED_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Range reserved for different states error

+++ ALIGNED VALUE TO 19000

Syntax
#define PRL_ERR_STATE_UNEXPECTED_ERROR PRL_RESULT_DECLARE_ERROR(19000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SUCCESS Macro

PRL_ERR_SUCCESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

All parallels error values should go here in order to be maintained in one place We're taking approach of HRESULT windows notation error codes here.

Syntax
#define PRL_ERR_SUCCESS PRL_RESULT_DECLARE_SUCCESS(0)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_SYMBOL_NOT_FOUND Macro

PRL_ERR_SYMBOL_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_SYMBOL_NOT_FOUND PRL_RESULT_DECLARE_ERROR(12)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED Macro

PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TARGET_NAME_ALREADY_OCCUPIED PRL_RESULT_DECLARE_ERROR(77)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY Macro

PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TARGET_PATH_IS_NOT_DIRECTORY PRL_RESULT_DECLARE_ERROR(76)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TASK_NOT_FOUND Macro

PRL_ERR_TASK_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TASK_NOT_FOUND PRL_RESULT_DECLARE_ERROR(92)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TIMEOUT Macro

PRL_ERR_TIMEOUT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TIMEOUT PRL_RESULT_DECLARE_ERROR(15)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TIS_INVALID_UID Macro

PRL_ERR_TIS_INVALID_UID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • TIS errors

+++ ALIGNED VALUE TO 27800

Syntax
#define PRL_ERR_TIS_INVALID_UID PRL_RESULT_DECLARE_ERROR(27800)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TOO_LOW_HDD_SIZE Macro

PRL_ERR_TOO_LOW_HDD_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TOO_LOW_HDD_SIZE PRL_RESULT_DECLARE_ERROR(260)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TOOLS_UNSUPPORTED_GUEST Macro

PRL_ERR_TOOLS_UNSUPPORTED_GUEST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TOOLS_UNSUPPORTED_GUEST PRL_RESULT_DECLARE_ERROR(370)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_TRY_AGAIN Macro

PRL_ERR_TRY_AGAIN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_TRY_AGAIN PRL_RESULT_DECLARE_ERROR(450)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNABLE_DROP_SUSPENDED_STATE Macro

PRL_ERR_UNABLE_DROP_SUSPENDED_STATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNABLE_DROP_SUSPENDED_STATE PRL_RESULT_DECLARE_ERROR(103)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNABLE_SEND_REQUEST Macro

PRL_ERR_UNABLE_SEND_REQUEST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNABLE_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(172)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNDER_OLD_HYPERVISOR Macro

PRL_ERR_UNDER_OLD_HYPERVISOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNDER_OLD_HYPERVISOR PRL_RESULT_DECLARE_ERROR(258)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNEXPECTED Macro

PRL_ERR_UNEXPECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNEXPECTED PRL_RESULT_DECLARE_ERROR(1)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNIMPLEMENTED Macro

PRL_ERR_UNIMPLEMENTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNIMPLEMENTED PRL_RESULT_DECLARE_ERROR(8)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNINITIALIZED Macro

PRL_ERR_UNINITIALIZED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNINITIALIZED PRL_RESULT_DECLARE_ERROR(7)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNRECOGNIZED_REQUEST Macro

PRL_ERR_UNRECOGNIZED_REQUEST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNRECOGNIZED_REQUEST PRL_RESULT_DECLARE_ERROR(91)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNSUPPORTED_DEVICE_TYPE Macro

PRL_ERR_UNSUPPORTED_DEVICE_TYPE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNSUPPORTED_DEVICE_TYPE PRL_RESULT_DECLARE_ERROR(1002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNSUPPORTED_FILE_SYSTEM Macro

PRL_ERR_UNSUPPORTED_FILE_SYSTEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNSUPPORTED_FILE_SYSTEM PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM Macro

PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UNSUPPORTED_NETWORK_FILE_SYSTEM PRL_RESULT_DECLARE_ERROR(399)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED Macro

PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UPD_TOOLS_VER_VM_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(174)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED Macro

PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UPD_TOOLS_VER_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(173)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UPD_UPDATER_CONFIG Macro

PRL_ERR_UPD_UPDATER_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Range reserved for updater errors

+++ ALIGNED VALUE TO 17000

Syntax
#define PRL_ERR_UPD_UPDATER_CONFIG PRL_RESULT_DECLARE_ERROR(17000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UPD_UPDATES Macro

PRL_ERR_UPD_UPDATES Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UPD_UPDATES PRL_RESULT_DECLARE_ERROR(17001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_UPDATE_MEM_VM_NOT_CREATED Macro

PRL_ERR_UPDATE_MEM_VM_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_UPDATE_MEM_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(171)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE Macro

PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_CANT_CHANGE_ACCESS_PROFILE PRL_RESULT_DECLARE_ERROR(119)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART Macro

PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_CANT_CHANGE_PROFILE_ACCESS_PART PRL_RESULT_DECLARE_ERROR(259)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE Macro

PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_CANT_CHANGE_READ_ONLY_VALUE PRL_RESULT_DECLARE_ERROR(120)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_DIRECTORY_NOT_SET Macro

PRL_ERR_USER_DIRECTORY_NOT_SET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_DIRECTORY_NOT_SET PRL_RESULT_DECLARE_ERROR(67)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_IS_ALREADY_LOGGED Macro

PRL_ERR_USER_IS_ALREADY_LOGGED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_IS_ALREADY_LOGGED PRL_RESULT_DECLARE_ERROR(61)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR Macro

PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_CREATE_VM_IN_DIR PRL_RESULT_DECLARE_ERROR(316)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS Macro

PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_EDIT_SERVER_SETTINGS PRL_RESULT_DECLARE_ERROR(257)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_EDIT_VM Macro

PRL_ERR_USER_NO_AUTH_TO_EDIT_VM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_EDIT_VM PRL_RESULT_DECLARE_ERROR(321)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES Macro

PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_NO_AUTH_TO_SAVE_FILES PRL_RESULT_DECLARE_ERROR(313)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_NOT_FOUND Macro

PRL_ERR_USER_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_NOT_FOUND PRL_RESULT_DECLARE_ERROR(390)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_OPERATION_NOT_AUTHORISED Macro

PRL_ERR_USER_OPERATION_NOT_AUTHORISED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_OPERATION_NOT_AUTHORISED PRL_RESULT_DECLARE_ERROR(59)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_USER_PROFILE_WAS_CHANGED Macro

PRL_ERR_USER_PROFILE_WAS_CHANGED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_USER_PROFILE_WAS_CHANGED PRL_RESULT_DECLARE_ERROR(118)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VA_CONFIG Macro

PRL_ERR_VA_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Virtual Application Configuration errors

+++ ALIGNED VALUE TO 18000

Syntax
#define PRL_ERR_VA_CONFIG PRL_RESULT_DECLARE_ERROR(18000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ABORT Macro

PRL_ERR_VM_ABORT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ABORT PRL_RESULT_DECLARE_ERROR(325)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED Macro

PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALLOC_MEM_DRV_NOT_STARTED PRL_RESULT_DECLARE_ERROR(184)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALLOC_VM_MEMORY Macro

PRL_ERR_VM_ALLOC_VM_MEMORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALLOC_VM_MEMORY PRL_RESULT_DECLARE_ERROR(185)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_CONNECTED Macro

PRL_ERR_VM_ALREADY_CONNECTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_CONNECTED PRL_RESULT_DECLARE_ERROR(391)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_CREATED Macro

PRL_ERR_VM_ALREADY_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_CREATED PRL_RESULT_DECLARE_ERROR(124)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED Macro

PRL_ERR_VM_ALREADY_REGISTERED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED PRL_RESULT_DECLARE_ERROR(447)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS Macro

PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_UNIQUE_PARAMS PRL_RESULT_DECLARE_ERROR(114)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_NAME PRL_RESULT_DECLARE_ERROR(115)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_PATH PRL_RESULT_DECLARE_ERROR(63)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID Macro

PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_REGISTERED_VM_UUID PRL_RESULT_DECLARE_ERROR(62)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_RESUMED Macro

PRL_ERR_VM_ALREADY_RESUMED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_RESUMED PRL_RESULT_DECLARE_ERROR(52)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_RUNNING Macro

PRL_ERR_VM_ALREADY_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_RUNNING PRL_RESULT_DECLARE_ERROR(402)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ALREADY_SUSPENDED Macro

PRL_ERR_VM_ALREADY_SUSPENDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ALREADY_SUSPENDED PRL_RESULT_DECLARE_ERROR(50)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ANOTHER_TOOLS_IN_USE Macro

PRL_ERR_VM_ANOTHER_TOOLS_IN_USE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ANOTHER_TOOLS_IN_USE PRL_RESULT_DECLARE_ERROR(425)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_APPLY_CHANGES_PENDING Macro

PRL_ERR_VM_APPLY_CHANGES_PENDING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_APPLY_CHANGES_PENDING PRL_RESULT_DECLARE_ERROR(366)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_APPLY_CONFIG_FAILED Macro

PRL_ERR_VM_APPLY_CONFIG_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_APPLY_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(290)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT Macro

PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_APPLY_CONFIG_NEEDS_REBOOT PRL_RESULT_DECLARE_ERROR(291)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR Macro

PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_ASYNC_CD_CONSTRUCTOR PRL_RESULT_DECLARE_ERROR(180)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_BAD_OS_TYPE Macro

PRL_ERR_VM_BAD_OS_TYPE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_BAD_OS_TYPE PRL_RESULT_DECLARE_ERROR(202)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CANT_CLONE_HDD_MISSING Macro

PRL_ERR_VM_CANT_CLONE_HDD_MISSING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CANT_CLONE_HDD_MISSING PRL_RESULT_DECLARE_ERROR(320)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CANT_CLONE_RUNNING Macro

PRL_ERR_VM_CANT_CLONE_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CANT_CLONE_RUNNING PRL_RESULT_DECLARE_ERROR(292)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CANT_DELETE_RUNNING Macro

PRL_ERR_VM_CANT_DELETE_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CANT_DELETE_RUNNING PRL_RESULT_DECLARE_ERROR(293)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CANT_UNREG_RUNNING Macro

PRL_ERR_VM_CANT_UNREG_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CANT_UNREG_RUNNING PRL_RESULT_DECLARE_ERROR(294)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_COMPACT_PROCESSING Macro

PRL_ERR_VM_COMPACT_PROCESSING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Optimization of virtual HDD Devices error

+++ ALIGNED VALUE TO 28000

Syntax
#define PRL_ERR_VM_COMPACT_PROCESSING PRL_RESULT_DECLARE_ERROR(28000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_INVALID_ARG Macro

PRL_ERR_VM_CONF_CHANGED_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONF_CHANGED_INVALID_ARG PRL_RESULT_DECLARE_ERROR(134)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_NOT_CREATED Macro

PRL_ERR_VM_CONF_CHANGED_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONF_CHANGED_NOT_CREATED PRL_RESULT_DECLARE_ERROR(133)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_NOT_STARTED Macro

PRL_ERR_VM_CONF_CHANGED_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONF_CHANGED_NOT_STARTED PRL_RESULT_DECLARE_ERROR(135)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV Macro

PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONF_CHANGED_UNSUPPORTED_DEV PRL_RESULT_DECLARE_ERROR(136)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_VM_CONFIG_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(37)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_CAN_BE_RESTORED Macro

PRL_ERR_VM_CONFIG_CAN_BE_RESTORED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_CAN_BE_RESTORED PRL_RESULT_DECLARE_ERROR(454)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_DOESNT_EXIST Macro

PRL_ERR_VM_CONFIG_DOESNT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_DOESNT_EXIST PRL_RESULT_DECLARE_ERROR(283)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID Macro

PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_INVALID_SERVER_UUID PRL_RESULT_DECLARE_ERROR(375)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_INVALID_VM_UUID Macro

PRL_ERR_VM_CONFIG_INVALID_VM_UUID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_INVALID_VM_UUID PRL_RESULT_DECLARE_ERROR(374)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_IS_ALREADY_VALID Macro

PRL_ERR_VM_CONFIG_IS_ALREADY_VALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_IS_ALREADY_VALID PRL_RESULT_DECLARE_ERROR(455)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CONFIG_WAS_CHANGED Macro

PRL_ERR_VM_CONFIG_WAS_CHANGED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CONFIG_WAS_CHANGED PRL_RESULT_DECLARE_ERROR(112)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER Macro

PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_COULDNT_BE_STARTED_UNDER_SPECIFIED_USER PRL_RESULT_DECLARE_ERROR(398)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG Macro

PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CREATE_HDD_IMG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(167)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE Macro

PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CREATE_HDD_IMG_INVALID_CREATE PRL_RESULT_DECLARE_ERROR(168)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CREATE_INVALID_ARG Macro

PRL_ERR_VM_CREATE_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CREATE_INVALID_ARG PRL_RESULT_DECLARE_ERROR(123)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_CREATE_SNAPSHOT_FAILED Macro

PRL_ERR_VM_CREATE_SNAPSHOT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_CREATE_SNAPSHOT_FAILED PRL_ERR_VM_SAVE_STATE_FAILED
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DELETE_STATE_FAILED Macro

PRL_ERR_VM_DELETE_STATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DELETE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(427)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED Macro

PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DEV_CHANGE_MEDIA_FAILED PRL_RESULT_DECLARE_ERROR(57)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DEV_CONNECT_FAILED Macro

PRL_ERR_VM_DEV_CONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DEV_CONNECT_FAILED PRL_RESULT_DECLARE_ERROR(55)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DEV_DISCONNECT_FAILED Macro

PRL_ERR_VM_DEV_DISCONNECT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DEV_DISCONNECT_FAILED PRL_RESULT_DECLARE_ERROR(56)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED Macro

PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DEVICES_INITIALIZATION_FAILED PRL_RESULT_DECLARE_ERROR(273)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DEVICES_TERMINATION_FAILED Macro

PRL_ERR_VM_DEVICES_TERMINATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DEVICES_TERMINATION_FAILED PRL_RESULT_DECLARE_ERROR(274)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS Macro

PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DIR_CONFIG_ALREADY_EXISTS PRL_RESULT_DECLARE_ERROR(31)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DIR_FILE_NOT_SET Macro

PRL_ERR_VM_DIR_FILE_NOT_SET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DIR_FILE_NOT_SET PRL_RESULT_DECLARE_ERROR(39)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST Macro

PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DIRECTORY_FOLDER_DOESNT_EXIST PRL_RESULT_DECLARE_ERROR(449)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_NOT_EXIST Macro

PRL_ERR_VM_DIRECTORY_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DIRECTORY_NOT_EXIST PRL_RESULT_DECLARE_ERROR(327)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED Macro

PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DIRECTORY_NOT_INITIALIZED PRL_RESULT_DECLARE_ERROR(65)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DOES_NOT_STOPPED Macro

PRL_ERR_VM_DOES_NOT_STOPPED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DOES_NOT_STOPPED PRL_RESULT_DECLARE_ERROR(241)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED Macro

PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_DVD_DISCONNECT_FAILED_LOCKED PRL_RESULT_DECLARE_ERROR(434)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS Macro

PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_CHANGE_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(457)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE Macro

PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_SWITCH_OFF_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(451)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE Macro

PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EDIT_UNABLE_SWITCH_ON_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(435)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EMPTY_NAME_OF_CLONE Macro

PRL_ERR_VM_EMPTY_NAME_OF_CLONE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EMPTY_NAME_OF_CLONE PRL_RESULT_DECLARE_ERROR(231)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE Macro

PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EXEC_GUEST_TOOL_NOT_AVAILABLE PRL_RESULT_DECLARE_ERROR(34001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND Macro

PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND PRL_RESULT_DECLARE_ERROR(34003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_FILES_ALREADY_REMOVED Macro

PRL_ERR_VM_FILES_ALREADY_REMOVED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_FILES_ALREADY_REMOVED PRL_RESULT_DECLARE_ERROR(305)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_FREE_VM_MEMORY Macro

PRL_ERR_VM_FREE_VM_MEMORY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_FREE_VM_MEMORY PRL_RESULT_DECLARE_ERROR(186)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_FAILED Macro

PRL_ERR_VM_GET_CONFIG_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(49)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_INVALID_ARG Macro

PRL_ERR_VM_GET_CONFIG_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_CONFIG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(130)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED Macro

PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_CONFIG_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(131)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_DEVICE_STATE_FAILED Macro

PRL_ERR_VM_GET_DEVICE_STATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_DEVICE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(58)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG Macro

PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_HDD_IMG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(169)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN Macro

PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_HDD_IMG_NOT_OPEN PRL_RESULT_DECLARE_ERROR(170)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_INVALID_ARG Macro

PRL_ERR_VM_GET_INDICATORS_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_INDICATORS_INVALID_ARG PRL_RESULT_DECLARE_ERROR(165)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_NOT_CREATED Macro

PRL_ERR_VM_GET_INDICATORS_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_INDICATORS_NOT_CREATED PRL_RESULT_DECLARE_ERROR(164)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING Macro

PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_INDICATORS_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(166)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED Macro

PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_PROBLEM_REPORT_FAILED PRL_RESULT_DECLARE_ERROR(48)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED Macro

PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_SCR_SIZE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(148)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED Macro

PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_SCR_UPDATED_NOT_CREATED PRL_RESULT_DECLARE_ERROR(149)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING Macro

PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_SCR_UPDATED_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(150)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_STATUS_FAILED Macro

PRL_ERR_VM_GET_STATUS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_STATUS_FAILED PRL_RESULT_DECLARE_ERROR(47)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GET_STATUS_INVALID_ARG Macro

PRL_ERR_VM_GET_STATUS_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GET_STATUS_INVALID_ARG PRL_RESULT_DECLARE_ERROR(126)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GUEST_SESSION_EXPIRED Macro

PRL_ERR_VM_GUEST_SESSION_EXPIRED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GUEST_SESSION_EXPIRED PRL_RESULT_DECLARE_ERROR(34002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_GUESTMEM_FAIL Macro

PRL_ERR_VM_GUESTMEM_FAIL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_GUESTMEM_FAIL PRL_RESULT_DECLARE_ERROR(392)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_HDD_SIZE Macro

PRL_ERR_VM_HDD_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_HDD_SIZE PRL_RESULT_DECLARE_ERROR(177)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY Macro

PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_HOME_PATH_IS_NOT_EMPTY PRL_RESULT_DECLARE_ERROR(228)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_HYPERVIZOR_COMM Macro

PRL_ERR_VM_HYPERVIZOR_COMM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_HYPERVIZOR_COMM PRL_RESULT_DECLARE_ERROR(198)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_IN_HDD_CONSTRUCTOR Macro

PRL_ERR_VM_IN_HDD_CONSTRUCTOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_IN_HDD_CONSTRUCTOR PRL_RESULT_DECLARE_ERROR(178)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_INIT_MONITOR Macro

PRL_ERR_VM_INIT_MONITOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_INIT_MONITOR PRL_RESULT_DECLARE_ERROR(190)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_INIT_VCPU Macro

PRL_ERR_VM_INIT_VCPU Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_INIT_VCPU PRL_RESULT_DECLARE_ERROR(191)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_INTERACT_PRLS_DRIVER Macro

PRL_ERR_VM_INTERACT_PRLS_DRIVER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_INTERACT_PRLS_DRIVER PRL_RESULT_DECLARE_ERROR(187)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_INTERNAL_OS_ERROR Macro

PRL_ERR_VM_INTERNAL_OS_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_INTERNAL_OS_ERROR PRL_RESULT_DECLARE_ERROR(269)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_INVALID_SWAP_REGION Macro

PRL_ERR_VM_INVALID_SWAP_REGION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_INVALID_SWAP_REGION PRL_RESULT_DECLARE_ERROR(378)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_IS_NOT_SUSPENDED Macro

PRL_ERR_VM_IS_NOT_SUSPENDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_IS_NOT_SUSPENDED PRL_RESULT_DECLARE_ERROR(420)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOAD_BINARY_FAILED Macro

PRL_ERR_VM_LOAD_BINARY_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOAD_BINARY_FAILED PRL_RESULT_DECLARE_ERROR(403)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOAD_MONITOR Macro

PRL_ERR_VM_LOAD_MONITOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOAD_MONITOR PRL_RESULT_DECLARE_ERROR(195)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS Macro

PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_CHANGE_IP_ADDRESS PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CLONE Macro

PRL_ERR_VM_LOCKED_FOR_CLONE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

FIXME: all constants like 'PRL_ERR_VM_LOCKED_FOR_***' should be changed to 'PRL_ERR_CONCURRENT_COMMAND_EXECUTING' until fix bug #6370 ( http://bugzilla/show_bug.cgi?id=6370 )

Syntax
#define PRL_ERR_VM_LOCKED_FOR_CLONE PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_CREATE_SNAPSHOT PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DELETE Macro

PRL_ERR_VM_LOCKED_FOR_DELETE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DELETE PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_DELETE_TO_SNAPSHOT PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT Macro

PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME Macro

PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EDIT_COMMIT_WITH_RENAME PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EXECUTE Macro

PRL_ERR_VM_LOCKED_FOR_EXECUTE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EXECUTE PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX Macro

PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_EXECUTE_EX PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON Macro

PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_INTERNAL_REASON PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_MIGRATE Macro

PRL_ERR_VM_LOCKED_FOR_MIGRATE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_MIGRATE PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT Macro

PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_SWITCH_TO_SNAPSHOT PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_UNREGISTER Macro

PRL_ERR_VM_LOCKED_FOR_UNREGISTER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_UNREGISTER PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY Macro

PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_LOCKED_FOR_UPDATE_SECURITY PRL_ERR_CONCURRENT_COMMAND_EXECUTING
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MAP_VM_MEM0 Macro

PRL_ERR_VM_MAP_VM_MEM0 Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MAP_VM_MEM0 PRL_RESULT_DECLARE_ERROR(189)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS Macro

PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MEMORY_SWAPPING_IN_PROGRESS PRL_RESULT_DECLARE_ERROR(20009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED Macro

PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

VM migration errors codes set +++ ALIGNED VALUE TO 31000

Syntax
#define PRL_ERR_VM_MIGRATE_CHECKING_PRECONDITIONS_FAILED PRL_RESULT_DECLARE_ERROR(31000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION Macro

PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_COULDNT_DETACH_TARGET_CONNECTION PRL_RESULT_DECLARE_ERROR(31016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_FLOPPY_DISK_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NETWORK_ADAPTER_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NETWORK_SHARE_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NON_COMPATIBLE_CPU_ON_TARGET PRL_RESULT_DECLARE_ERROR(31005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_CPUS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_SOURCE PRL_RESULT_DECLARE_ERROR(31001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_NOT_ENOUGH_DISK_SPACE_ON_TARGET PRL_RESULT_DECLARE_ERROR(31015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_OPTICAL_DISK_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_OUT_OF_MEMORY_ON_TARGET PRL_RESULT_DECLARE_ERROR(31002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_PARALLEL_PORT_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_SERIAL_PORT_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_SOUND_DEVICE_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS Macro

PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_TARGET_VM_HOME_PATH_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(31003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_USB_CONTROLLER_IS_ABSENT_ON_TARGET PRL_RESULT_DECLARE_ERROR(31012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET Macro

PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MIGRATE_VM_ALREADY_EXISTS_ON_TARGET PRL_RESULT_DECLARE_ERROR(31014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MONITOR Macro

PRL_ERR_VM_MONITOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MONITOR PRL_RESULT_DECLARE_ERROR(200)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING Macro

PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MUST_BE_STOPPED_BEFORE_RENAMING PRL_RESULT_DECLARE_ERROR(376)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES Macro

PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_MUST_BE_STOPPED_FOR_CHANGE_DEVICES PRL_RESULT_DECLARE_ERROR(384)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_NAME_IS_EMPTY Macro

PRL_ERR_VM_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(116)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_NOT_CREATED Macro

PRL_ERR_VM_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_NOT_CREATED PRL_RESULT_DECLARE_ERROR(125)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_OPERATION_FAILED Macro

PRL_ERR_VM_OPERATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_OPERATION_FAILED PRL_RESULT_DECLARE_ERROR(69)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PAUSE_ALREADY_PAUSED Macro

PRL_ERR_VM_PAUSE_ALREADY_PAUSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PAUSE_ALREADY_PAUSED PRL_RESULT_DECLARE_ERROR(147)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PAUSE_FAILED Macro

PRL_ERR_VM_PAUSE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PAUSE_FAILED PRL_RESULT_DECLARE_ERROR(51)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PAUSE_NOT_CREATED Macro

PRL_ERR_VM_PAUSE_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PAUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(145)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PAUSE_NOT_STARTED Macro

PRL_ERR_VM_PAUSE_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PAUSE_NOT_STARTED PRL_RESULT_DECLARE_ERROR(146)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_POWER_OFF_FAILED Macro

PRL_ERR_VM_POWER_OFF_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_POWER_OFF_FAILED PRL_RESULT_DECLARE_ERROR(45)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_POWER_ON_FAILED Macro

PRL_ERR_VM_POWER_ON_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_POWER_ON_FAILED PRL_RESULT_DECLARE_ERROR(44)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM Macro

PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PRLS_DESCTOP_ALLOC_PHYS_MEM PRL_RESULT_DECLARE_ERROR(199)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_PROCESS_IS_NOT_STARTED Macro

PRL_ERR_VM_PROCESS_IS_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_PROCESS_IS_NOT_STARTED PRL_RESULT_DECLARE_ERROR(68)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_REQUEST_NOT_SUPPORTED Macro

PRL_ERR_VM_REQUEST_NOT_SUPPORTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_REQUEST_NOT_SUPPORTED PRL_RESULT_DECLARE_ERROR(201)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESET_FAILED Macro

PRL_ERR_VM_RESET_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESET_FAILED PRL_RESULT_DECLARE_ERROR(46)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESTART_GUEST_FAILED Macro

PRL_ERR_VM_RESTART_GUEST_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESTART_GUEST_FAILED PRL_RESULT_DECLARE_ERROR(438)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESTART_NOT_CREATED Macro

PRL_ERR_VM_RESTART_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESTART_NOT_CREATED PRL_RESULT_DECLARE_ERROR(143)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESTART_NOT_STARTED Macro

PRL_ERR_VM_RESTART_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESTART_NOT_STARTED PRL_RESULT_DECLARE_ERROR(144)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESTORE_STATE_FAILED Macro

PRL_ERR_VM_RESTORE_STATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESTORE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(54)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESUME_FAILED Macro

PRL_ERR_VM_RESUME_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESUME_FAILED PRL_RESULT_DECLARE_ERROR(20006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME Macro

PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_RESUME_INV_SAV_VERSION_CANCEL_RESUME PRL_RESULT_DECLARE_SUCCESS(20007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SAVE_STATE_FAILED Macro

PRL_ERR_VM_SAVE_STATE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SAVE_STATE_FAILED PRL_RESULT_DECLARE_ERROR(53)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED Macro

PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(158)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING Macro

PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(159)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED Macro

PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_ABS_MOUSE_PAUSED PRL_RESULT_DECLARE_ERROR(160)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED Macro

PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_NOT_CREATED PRL_RESULT_DECLARE_ERROR(161)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING Macro

PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(162)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_KEYBOARD_PAUSED Macro

PRL_ERR_VM_SEND_KEYBOARD_PAUSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_KEYBOARD_PAUSED PRL_RESULT_DECLARE_ERROR(163)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED Macro

PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(155)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING Macro

PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(156)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SEND_REL_MOUSE_PAUSED Macro

PRL_ERR_VM_SEND_REL_MOUSE_PAUSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SEND_REL_MOUSE_PAUSED PRL_RESULT_DECLARE_ERROR(157)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SET_CONFIG_FAILED Macro

PRL_ERR_VM_SET_CONFIG_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SET_CONFIG_FAILED PRL_RESULT_DECLARE_ERROR(43)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SET_CONFIG_INVALID_ARG Macro

PRL_ERR_VM_SET_CONFIG_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SET_CONFIG_INVALID_ARG PRL_RESULT_DECLARE_ERROR(132)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SET_LICENSE_FAILED Macro

PRL_ERR_VM_SET_LICENSE_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SET_LICENSE_FAILED PRL_RESULT_DECLARE_ERROR(42)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SET_VISIBLE_NOT_CREATED Macro

PRL_ERR_VM_SET_VISIBLE_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SET_VISIBLE_NOT_CREATED PRL_RESULT_DECLARE_ERROR(151)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG Macro

PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SNAPSHOT_CHANGED_VM_CONFIG PRL_RESULT_DECLARE_ERROR(428)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE Macro

PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SNAPSHOT_IN_SAFE_MODE PRL_RESULT_DECLARE_ERROR(440)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE Macro

PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SNAPSHOT_IN_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(429)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES Macro

PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SPECIFY_GUEST_INSTALL_FILES PRL_RESULT_DECLARE_ERROR(299)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_START_FAILED Macro

PRL_ERR_VM_START_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_START_FAILED PRL_RESULT_DECLARE_ERROR(41)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_START_NOT_CONFIGURED Macro

PRL_ERR_VM_START_NOT_CONFIGURED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_START_NOT_CONFIGURED PRL_RESULT_DECLARE_ERROR(141)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_START_NOT_CREATED Macro

PRL_ERR_VM_START_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_START_NOT_CREATED PRL_RESULT_DECLARE_ERROR(140)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_STOP_NOT_CREATED Macro

PRL_ERR_VM_STOP_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_STOP_NOT_CREATED PRL_RESULT_DECLARE_ERROR(142)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG Macro

PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SUSPEND_CHANGED_VM_CONFIG PRL_RESULT_DECLARE_ERROR(20008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_SUSPEND_FAILED Macro

PRL_ERR_VM_SUSPEND_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_SUSPEND_FAILED PRL_RESULT_DECLARE_ERROR(20005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED Macro

PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_TO_REGISTER_IS_NOT_SPECIFIED PRL_RESULT_DECLARE_ERROR(337)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS Macro

PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

VM tools erros codes set +++ ALIGNED VALUE TO 33000

Syntax
#define PRL_ERR_VM_TOOLS_CANT_PARSE_UPDATE_PARAMETERS PRL_RESULT_DECLARE_ERROR(33000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART Macro

PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_TOOLS_CANT_UPDATE_WITHOUT_RESTART PRL_RESULT_DECLARE_ERROR(33001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_ALLOC_MEM Macro

PRL_ERR_VM_UNABLE_ALLOC_MEM Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_ALLOC_MEM PRL_RESULT_DECLARE_ERROR(188)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR Macro

PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_ALLOC_MEM_MONITOR PRL_RESULT_DECLARE_ERROR(196)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_CREATE_TIMER Macro

PRL_ERR_VM_UNABLE_CREATE_TIMER Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_CREATE_TIMER PRL_RESULT_DECLARE_ERROR(197)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_GET_GUEST_CPU Macro

PRL_ERR_VM_UNABLE_GET_GUEST_CPU Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_GET_GUEST_CPU PRL_RESULT_DECLARE_ERROR(192)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE Macro

PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_OPEN_DISK_IMAGE PRL_RESULT_DECLARE_ERROR(181)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_SEND_REQUEST Macro

PRL_ERR_VM_UNABLE_SEND_REQUEST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_SEND_REQUEST PRL_RESULT_DECLARE_ERROR(183)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE Macro

PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNABLE_TO_OPEN_VIRTUAL_BRIDGE PRL_RESULT_DECLARE_ERROR(179)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UNDEFINED_API_CALL Macro

PRL_ERR_VM_UNDEFINED_API_CALL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UNDEFINED_API_CALL PRL_RESULT_DECLARE_ERROR(182)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED Macro

PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UPDATE_SNAPSHOT_DATA_FAILED PRL_RESULT_DECLARE_ERROR(432)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_USER_AUTHENTICATION_FAILED Macro

PRL_ERR_VM_USER_AUTHENTICATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_USER_AUTHENTICATION_FAILED PRL_RESULT_DECLARE_ERROR(396)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UUID_EMPTY Macro

PRL_ERR_VM_UUID_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UUID_EMPTY PRL_RESULT_DECLARE_ERROR(230)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_UUID_NOT_FOUND Macro

PRL_ERR_VM_UUID_NOT_FOUND Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_UUID_NOT_FOUND PRL_RESULT_DECLARE_ERROR(105)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_VALLOC_MON_BODY Macro

PRL_ERR_VM_VALLOC_MON_BODY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_VALLOC_MON_BODY PRL_RESULT_DECLARE_ERROR(193)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_VALLOC_PE_IMG Macro

PRL_ERR_VM_VALLOC_PE_IMG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_VALLOC_PE_IMG PRL_RESULT_DECLARE_ERROR(194)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_INVALID_ARG Macro

PRL_ERR_VM_VIEW_SCR_INVALID_ARG Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_VIEW_SCR_INVALID_ARG PRL_RESULT_DECLARE_ERROR(153)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_NOT_CREATED Macro

PRL_ERR_VM_VIEW_SCR_NOT_CREATED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_VIEW_SCR_NOT_CREATED PRL_RESULT_DECLARE_ERROR(152)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VM_VIEW_SCR_NOT_RUNNING Macro

PRL_ERR_VM_VIEW_SCR_NOT_RUNNING Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VM_VIEW_SCR_NOT_RUNNING PRL_RESULT_DECLARE_ERROR(154)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN Macro

PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_AUTOSTART_FROM_CURRENT_USER_FORBIDDEN PRL_RESULT_DECLARE_ERROR(27053)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS Macro

PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_DEVICE_NOT_EXISTS PRL_RESULT_DECLARE_ERROR(27052)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE Macro

PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_DUPLICATE_DEVICE PRL_RESULT_DECLARE_ERROR(27051)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE Macro

PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27050

Syntax
#define PRL_ERR_VMCONF_BOOT_OPTION_INVALID_DEVICE_TYPE PRL_RESULT_DECLARE_ERROR(27050)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_DISK_SMART_GUARD_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_SNAPSHOTS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_BOOTCAMP_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME Macro

PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_DUPLICATE_SYS_NAME PRL_RESULT_DECLARE_ERROR(27401)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27402)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27400

Syntax
#define PRL_ERR_VMCONF_CD_DVD_ROM_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27400)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT Macro

PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_CPU_COUNT_MORE_HOST_CPU_COUNT PRL_RESULT_DECLARE_ERROR(27202)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT Macro

PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_CPU_COUNT_MORE_MAX_CPU_COUNT PRL_RESULT_DECLARE_ERROR(27201)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_CPU_ZERO_COUNT Macro

PRL_ERR_VMCONF_CPU_ZERO_COUNT Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27200

Syntax
#define PRL_ERR_VMCONF_CPU_ZERO_COUNT PRL_RESULT_DECLARE_ERROR(27200)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES Macro

PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_DESKTOP_MODE_REMOTE_DEVICES PRL_RESULT_DECLARE_ERROR(27006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27351)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IMAGE_IS_NOT_VALID PRL_RESULT_DECLARE_ERROR(27353)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE Macro

PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_IS_NOT_ACCESSIBLE PRL_RESULT_DECLARE_ERROR(27352)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27354)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27350

Syntax
#define PRL_ERR_VMCONF_FLOPPY_DISK_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27350)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED Macro

PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27760

Syntax
#define PRL_ERR_VMCONF_GENERIC_PCI_DEVICE_CANNOT_BE_ADDED PRL_RESULT_DECLARE_ERROR(27760)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME Macro

PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_DUPLICATE_SYS_NAME PRL_RESULT_DECLARE_ERROR(27453)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27451)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID Macro

PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_IMAGE_IS_NOT_VALID PRL_RESULT_DECLARE_ERROR(27452)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27454)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27450

Syntax
#define PRL_ERR_VMCONF_HARD_DISK_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27450)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27700

Syntax
#define PRL_ERR_VMCONF_IDE_DEVICES_COUNT_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27700)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX Macro

PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_IDE_DEVICES_DUPLICATE_STACK_INDEX PRL_RESULT_DECLARE_ERROR(27701)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_HARD_DISK_SMART_GUARD_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_INCOMPAT_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX Macro

PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_INVALID_DEVICE_MAIN_INDEX PRL_RESULT_DECLARE_ERROR(27005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_NOT_4_RATIO_SIZE PRL_RESULT_DECLARE_ERROR(27252)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27251)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED Macro

PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_SIZE_NOT_EAQUAL_RECOMMENDED PRL_RESULT_DECLARE_SUCCESS(27253)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE Macro

PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27250

Syntax
#define PRL_ERR_VMCONF_MAIN_MEMORY_ZERO_SIZE PRL_RESULT_DECLARE_ERROR(27250)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27503)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_DUPLICATE_MAC_ADDRESS PRL_RESULT_DECLARE_ERROR(27502)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_ETHLIST_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(27504)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27500

Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_BOUND_INDEX PRL_RESULT_DECLARE_ERROR(27500)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS Macro

PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NETWORK_ADAPTER_INVALID_MAC_ADDRESS PRL_RESULT_DECLARE_ERROR(27501)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE Macro

PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NO_HD_IMAGES_IN_SAFE_MODE PRL_RESULT_DECLARE_ERROR(27015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE Macro

PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_NO_HD_IMAGES_IN_UNDO_DISKS_MODE PRL_RESULT_DECLARE_ERROR(27014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27651)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27652)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27650

Syntax
#define PRL_ERR_VMCONF_PARALLEL_PORT_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27650)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW Macro

PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_REAL_HARD_SAFE_MODE_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW Macro

PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_REAL_HARD_UNDO_DISKS_NOT_ALLOW PRL_RESULT_DECLARE_ERROR(27007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_HOST_IP_ADDRESS_IS_ZERO PRL_RESULT_DECLARE_ERROR(27101)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_INVALID_HOST_IP_ADDRESS PRL_RESULT_DECLARE_ERROR(27102)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO Macro

PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27100

Syntax
#define PRL_ERR_VMCONF_REMOTE_DISPLAY_PORT_NUMBER_IS_ZERO PRL_RESULT_DECLARE_ERROR(27100)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27750

Syntax
#define PRL_ERR_VMCONF_SCSI_DEVICES_COUNT_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27750)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX Macro

PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SCSI_DEVICES_DUPLICATE_STACK_INDEX PRL_RESULT_DECLARE_ERROR(27751)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST Macro

PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_IMAGE_IS_NOT_EXIST PRL_RESULT_DECLARE_ERROR(27601)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27602)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27600

Syntax
#define PRL_ERR_VMCONF_SERIAL_PORT_SYS_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27600)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_NAME PRL_RESULT_DECLARE_ERROR(27151)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_DUPLICATE_FOLDER_PATH PRL_RESULT_DECLARE_ERROR(27153)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27150

Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_EMPTY_FOLDER_NAME PRL_RESULT_DECLARE_ERROR(27150)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH Macro

PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SHARED_FOLDERS_INVALID_FOLDER_PATH PRL_RESULT_DECLARE_ERROR(27152)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY Macro

PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27550

Syntax
#define PRL_ERR_VMCONF_SOUND_MIXER_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27550)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY Macro

PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_SOUND_OUTPUT_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27551)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_UNKNOWN_OS_TYPE Macro

PRL_ERR_VMCONF_UNKNOWN_OS_TYPE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_UNKNOWN_OS_TYPE PRL_RESULT_DECLARE_ERROR(27002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_UNKNOWN_OS_VERSION Macro

PRL_ERR_VMCONF_UNKNOWN_OS_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_UNKNOWN_OS_VERSION PRL_RESULT_DECLARE_ERROR(27003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_VALIDATION_FAILED Macro

PRL_ERR_VMCONF_VALIDATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • Validation VM configuration error

+++ ALIGNED VALUE TO 27000

Syntax
#define PRL_ERR_VMCONF_VALIDATION_FAILED PRL_RESULT_DECLARE_ERROR(27000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE Macro

PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

ALIGNED VALUE TO 27300

Syntax
#define PRL_ERR_VMCONF_VIDEO_MEMORY_OUT_OF_RANGE PRL_RESULT_DECLARE_ERROR(27300)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL Macro

PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_VM_NAME_HAS_INVALID_SYMBOL PRL_RESULT_DECLARE_ERROR(27004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMCONF_VM_NAME_IS_EMPTY Macro

PRL_ERR_VMCONF_VM_NAME_IS_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMCONF_VM_NAME_IS_EMPTY PRL_RESULT_DECLARE_ERROR(27001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMDIR_INVALID_PATH Macro

PRL_ERR_VMDIR_INVALID_PATH Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMDIR_INVALID_PATH PRL_RESULT_DECLARE_ERROR(285)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE Macro

PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VMDIR_PATH_IS_NOT_ABSOLUTE PRL_RESULT_DECLARE_ERROR(286)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VNC_SERVER_ALREADY_STARTED Macro

PRL_ERR_VNC_SERVER_ALREADY_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback

VNC server operations errors +++ ALIGNED VALUE TO 35000

Syntax
#define PRL_ERR_VNC_SERVER_ALREADY_STARTED PRL_RESULT_DECLARE_ERROR(35000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED Macro

PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VNC_SERVER_AUTOSET_PORT_FAILED PRL_RESULT_DECLARE_ERROR(35002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VNC_SERVER_DISABLED Macro

PRL_ERR_VNC_SERVER_DISABLED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VNC_SERVER_DISABLED PRL_RESULT_DECLARE_ERROR(35001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VNC_SERVER_NOT_STARTED Macro

PRL_ERR_VNC_SERVER_NOT_STARTED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VNC_SERVER_NOT_STARTED PRL_RESULT_DECLARE_ERROR(35005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_ALREADY_HOOKED_FAILED Macro

PRL_ERR_VTD_ALREADY_HOOKED_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTD_ALREADY_HOOKED_FAILED PRL_RESULT_DECLARE_ERROR(10003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_DEVICE_NOT_MAPPED Macro

PRL_ERR_VTD_DEVICE_NOT_MAPPED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
  • VT-d

+++ ALIGNED VALUE TO 12000

Syntax
#define PRL_ERR_VTD_DEVICE_NOT_MAPPED PRL_RESULT_DECLARE_ERROR(12000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_HOOK_FAILED Macro

PRL_ERR_VTD_HOOK_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTD_HOOK_FAILED PRL_RESULT_DECLARE_ERROR(10004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED Macro

PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTD_HOOK_NEED_REBOOT_FAILED PRL_RESULT_DECLARE_ERROR(10005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_INITIALIZATION_FAILED Macro

PRL_ERR_VTD_INITIALIZATION_FAILED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTD_INITIALIZATION_FAILED PRL_RESULT_DECLARE_ERROR(10002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTD_WAIT_ASR Macro

PRL_ERR_VTD_WAIT_ASR Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTD_WAIT_ASR PRL_RESULT_DECLARE_ERROR(10006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_VTX_ENABLED_ONLY_IN_SMX Macro

PRL_ERR_VTX_ENABLED_ONLY_IN_SMX Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_VTX_ENABLED_ONLY_IN_SMX PRL_RESULT_DECLARE_ERROR(342)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY Macro

PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_WINDOWS_EXPRESS_INSTALL_USER_NAME_EMPTY PRL_RESULT_DECLARE_ERROR(318)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL Macro

PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_WRONG_CONNECTION_SECURITY_LEVEL PRL_RESULT_DECLARE_ERROR(277)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_WRONG_PROTOCOL_VERSION Macro

PRL_ERR_WRONG_PROTOCOL_VERSION Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_WRONG_PROTOCOL_VERSION PRL_RESULT_DECLARE_ERROR(413)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_WS_DISP_CONNECTION_CLOSED Macro

PRL_ERR_WS_DISP_CONNECTION_CLOSED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_WS_DISP_CONNECTION_CLOSED PRL_RESULT_DECLARE_ERROR(246)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_X64GUEST_ON_X32HOST Macro

PRL_ERR_X64GUEST_ON_X32HOST Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_X64GUEST_ON_X32HOST PRL_RESULT_DECLARE_ERROR(354)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED Macro

PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_X64GUEST_ON_X64VM_HVT_DISABLED PRL_RESULT_DECLARE_ERROR(357)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_ERR_XML_WRITE_FILE Macro

PRL_ERR_XML_WRITE_FILE Macro
PrlErrorsValues.h PRL_ERR Macros Send Feedback
Syntax
#define PRL_ERR_XML_WRITE_FILE PRL_RESULT_DECLARE_ERROR(424)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, PRL_ERR Macros


PRL_EVENT_ISSUER_TYPE Enumeration

PRL_EVENT_ISSUER_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Event issuer type

Syntax
typedef enum _PRL_EVENT_ISSUER_TYPE {
  PIE_VIRTUAL_MACHINE = 0,
  PIE_DISPATCHER = 1,
  PIE_IO_SERVICE = 2,
  PIE_WEB_SERVICE = 3
} PRL_EVENT_ISSUER_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_EVENT_ISSUER_TYPE_PTR Type

PRL_EVENT_ISSUER_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_EVENT_ISSUER_TYPE* PRL_EVENT_ISSUER_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_FAILED Macro

PRL_FAILED Macro
PrlErrors.h Other Macros Send Feedback
Syntax
#define PRL_FAILED( err ) ( ( PRL_RESULT )( err ) < 0 )
File

PrlErrors.h

Links
PrlErrors.h, Other Macros


PRL_FALSE Macro

PRL_FALSE Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_FALSE (0)
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration

PRL_FILE_SYSTEM_ELEMENT_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

File system element type

Syntax
typedef enum _PRL_FILE_SYSTEM_ELEMENT_TYPE {
  PSE_DRIVE = 0,
  PSE_DIRECTORY = 1,
  PSE_FILE = 2
} PRL_FILE_SYSTEM_ELEMENT_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR Type

PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR Type
PrlEnums.h PRL_FILE Types Send Feedback
Syntax
typedef PRL_FILE_SYSTEM_ELEMENT_TYPE* PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_FILE Types


PRL_FILE_SYSTEM_FS_TYPE Enumeration

PRL_FILE_SYSTEM_FS_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
typedef enum _PRL_FILE_SYSTEM_FS_TYPE {
  PRL_FS_INVALID = 0,
  PRL_FS_FAT = 1,
  PRL_FS_FAT32 = 2,
  PRL_FS_NTFS = 3,
  PRL_FS_HFS = 4,
  PRL_FS_ADFS = 5,
  PRL_FS_AFFS = 6,
  PRL_FS_AFS = 7,
  PRL_FS_AUTOFS = 8,
  PRL_FS_CODA = 9,
  PRL_FS_EFS = 10,
  PRL_FS_EXTFS = 11,
  PRL_FS_HPFS = 12,
  PRL_FS_ISOFS = 13,
  PRL_FS_JFFS2 = 14,
  PRL_FS_NFS = 15,
  PRL_FS_QNX4 = 16,
  PRL_FS_REISERFS = 17,
  PRL_FS_SMBFS = 18,
  PRL_FS_UNSPECIFIED = 0xFF
} PRL_FILE_SYSTEM_FS_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_FILE_SYSTEM_FS_TYPE_PTR Type

PRL_FILE_SYSTEM_FS_TYPE_PTR Type
PrlEnums.h PRL_FILE Types Send Feedback
Syntax
typedef PRL_FILE_SYSTEM_FS_TYPE* PRL_FILE_SYSTEM_FS_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_FILE Types


PRL_FILE_SYSTEM_TYPE Enumeration

PRL_FILE_SYSTEM_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

File system general type

Syntax
typedef enum _PRL_FILE_SYSTEM_TYPE {
  PFS_WINDOWS_LIKE_FS = 0,
  PFS_UNIX_LIKE_FS = 1
} PRL_FILE_SYSTEM_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_FILE_SYSTEM_TYPE_PTR Type

PRL_FILE_SYSTEM_TYPE_PTR Type
PrlEnums.h PRL_FILE Types Send Feedback
Syntax
typedef PRL_FILE_SYSTEM_TYPE* PRL_FILE_SYSTEM_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_FILE Types


PRL_GRACEFUL_SHUTDOWN_KIND Enumeration

PRL_GRACEFUL_SHUTDOWN_KIND Enumeration
PrlEnums.h Other Structs Send Feedback

Graceful Shutdown types

Syntax
typedef enum _PRL_GRACEFUL_SHUTDOWN_KIND {
  PST_VM_SHUTDOWN = 0,
  PST_VM_REBOOT = 1,
  PST_VM_HIBERNATE = 2
} PRL_GRACEFUL_SHUTDOWN_KIND;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_GRACEFUL_SHUTDOWN_KIND_PTR Type

PRL_GRACEFUL_SHUTDOWN_KIND_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_GRACEFUL_SHUTDOWN_KIND* PRL_GRACEFUL_SHUTDOWN_KIND_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_GUEST_DISTRO_VERSION_ENUM Enumeration

PRL_GUEST_DISTRO_VERSION_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Windows installation distributive type.

Syntax
typedef enum _PRL_GUEST_DISTRO_VERSION_ENUM {
  PGD_UNKNOWN = 0,
  PGD_WINDOWS_VISTA = 1,
  PGD_WINDOWS_XP = 2,
  PGD_WINDOWS_XP_32 = PGD_WINDOWS_XP,
  PGD_WINDOWS_XP_64 = 3,
  PGD_WINDOWS_VISTA_32 = PGD_WINDOWS_VISTA,
  PGD_WINDOWS_VISTA_64 = 4
} PRL_GUEST_DISTRO_VERSION_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_GUEST_DISTRO_VERSION_ENUM_PTR Type

PRL_GUEST_DISTRO_VERSION_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_GUEST_DISTRO_VERSION_ENUM* PRL_GUEST_DISTRO_VERSION_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_GUID_PTR Type

PRL_GUID_PTR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_GUID* PRL_GUID_PTR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_HANDLE Type

PRL_HANDLE Type
PrlTypes.h Other Types Send Feedback

Handle representation

Syntax
typedef int* PRL_HANDLE;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_HANDLE_PTR Type

PRL_HANDLE_PTR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_HANDLE* PRL_HANDLE_PTR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_HANDLE_TYPE Enumeration

PRL_HANDLE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

The _PRL_HANDLE_TYPE enumeration defines handle types.

Syntax
typedef enum _PRL_HANDLE_TYPE {
  PHT_ERROR = 0,
  PHT_SERVER = 0x10000001,
  PHT_SERVER_CONFIG = 0x10000002,
  PHT_REMOTE_FILESYSTEM_INFO = 0x10000003,
  PHT_REMOTE_FILESYSTEM_ENTRY = 0x10000004,
  PHT_VIRTUAL_MACHINE = 0x10000005,
  PHT_VIRTUAL_DEV_DISPLAY = 0x10000006,
  PHT_VIRTUAL_DEV_KEYBOARD = 0x10000007,
  PHT_VIRTUAL_DEV_MOUSE = 0x10000008,
  PHT_VIRTUAL_DEV_FLOPPY = 0x10000009,
  PHT_VIRTUAL_DEV_HARD_DISK = 0x1000000A,
  PHT_VIRTUAL_DEV_NET_ADAPTER = 0x1000000B,
  PHT_VIRTUAL_DEV_PARALLEL_PORT = 0x1000000C,
  PHT_VIRTUAL_DEV_SERIAL_PORT = 0x1000000D,
  PHT_VIRTUAL_DEV_OPTICAL_DISK = 0x1000000E,
  PHT_VIRTUAL_DEV_USB_DEVICE = 0x1000000F,
  PHT_VIRTUAL_DEV_SOUND = 0x10000010,
  PHT_JOB = 0x10000011,
  PHT_EVENT = 0x10000012,
  PHT_RESULT = 0x10000013,
  PHT_VM_INFO = 0x10000014,
  PHT_USER_PROFILE = 0x10000015,
  PHT_DISP_CONFIG = 0x10000016,
  PHT_SHARE = 0x10000017,
  PHT_SCREEN_RESOLUTION = 0x10000018,
  PHT_DISP_NET_ADAPTER = 0x10000019,
  PHT_HW_GENERIC_DEVICE = 0x1000001A,
  PHT_HW_HARD_DISK = 0x1000001B,
  PHT_HW_HARD_DISK_PARTITION = 0x1000001C,
  PHT_HW_NET_ADAPTER = 0x1000001D,
  PHT_EVENT_PARAMETER = 0x1000001E,
  PHT_REMOTEDEV_CMD = 0x1000001F,
  PHT_SYSTEM_STATISTICS = 0x10000020,
  PHT_SYSTEM_STATISTICS_CPU = 0x10000021,
  PHT_SYSTEM_STATISTICS_IFACE = 0x10000022,
  PHT_SYSTEM_STATISTICS_USER_SESSION = 0x10000023,
  PHT_SYSTEM_STATISTICS_DISK = 0x10000024,
  PHT_SYSTEM_STATISTICS_DISK_PARTITION = 0x10000025,
  PHT_SYSTEM_STATISTICS_PROCESS = 0x10000026,
  PHT_LICENSE = 0x10000027,
  PHT_SERVER_INFO = 0x10000028,
  PHT_BOOT_DEVICE = 0x10000029,
  PHT_STRINGS_LIST = 0x1000002A,
  PHT_LOGIN_RESPONSE = 0x1000002B,
  PHT_RUNNING_TASK = 0x1000002C,
  PHT_NET_SERVICE_STATUS = 0x1000002D,
  PHT_HANDLES_LIST = 0x1000002E,
  PHT_VIRTUAL_DISK = 0x1000002F,
  PHT_ACCESS_RIGHTS = 0x10000030,
  PHT_VM_TOOLS_INFO = 0x10000031,
  PHT_FOUND_VM_INFO = 0x10000032,
  PHT_TIS_RECORD = 0x10000033,
  PHT_USER_INFO = 0x10000034,
  PHT_VM_CONFIGURATION = PHT_VIRTUAL_MACHINE,
  PHT_TIS_EMITTER = 0x10000036,
  PHT_TOOL = 0x10000037,
  PHT_VIRTUAL_DEV_HD_PARTITION = 0x10000038,
  PHT_VIRTUAL_DEV_GENERIC_PCI = 0x10000039,
  PHT_VIRTUAL_DEV_GENERIC_SCSI = 0x1000003A,
  PHT_VM_GUEST_SESSION = 0x1000003B,
  PHT_VIRTUAL_NETWORK = 0x1000003C,
  PHT_PORT_FORWARDING = 0x1000003D,
  PHT_LAST = PHT_PORT_FORWARDING
} PRL_HANDLE_TYPE;
File

PrlEnums.h

Members

PHT_LAST
sould be set to last

Remarks

Each handle type and the functions that operate on it is described in detail in the "Functions by Handle" chapter of the Parallels C API Reference guide.

Links
PrlEnums.h, Other Structs


PRL_HANDLE_TYPE_PTR Type

PRL_HANDLE_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_HANDLE_TYPE* PRL_HANDLE_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_HARD_DISK_INTERNAL_FORMAT Enumeration

PRL_HARD_DISK_INTERNAL_FORMAT Enumeration
PrlEnums.h Other Structs Send Feedback

Hard disk image type

Syntax
typedef enum _PRL_HARD_DISK_INTERNAL_FORMAT {
  PHD_PLAIN_HARD_DISK = 0,
  PHD_EXPANDING_HARD_DISK = 1
} PRL_HARD_DISK_INTERNAL_FORMAT;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_HARD_DISK_INTERNAL_FORMAT_PTR Type

PRL_HARD_DISK_INTERNAL_FORMAT_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_HARD_DISK_INTERNAL_FORMAT* PRL_HARD_DISK_INTERNAL_FORMAT_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_HOST_OS_TYPE Enumeration

PRL_HOST_OS_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Host OS type

Syntax
typedef enum _PRL_HOST_OS_TYPE {
  PHO_MAC = 0,
  PHO_LIN = 1,
  PHO_WIN = 2
} PRL_HOST_OS_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_HOST_OS_TYPE_PTR Type

PRL_HOST_OS_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_HOST_OS_TYPE* PRL_HOST_OS_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration

PRL_HW_INFO_NET_ADAPTER_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Network adapter types in hardware info list

Syntax
typedef enum _PRL_HW_INFO_NET_ADAPTER_TYPE {
  PHI_REAL_NET_ADAPTER = 0,
  PHI_VIRTUAL_NET_ADAPTER = 1,
  PHY_WIFI_REAL_NET_ADAPTER = 2
} PRL_HW_INFO_NET_ADAPTER_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_HW_INFO_NET_ADAPTER_TYPE_PTR Type

PRL_HW_INFO_NET_ADAPTER_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_HW_INFO_NET_ADAPTER_TYPE* PRL_HW_INFO_NET_ADAPTER_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_IMAGE_BOOTCAMP Macro

PRL_IMAGE_BOOTCAMP Macro
PrlDisk.h Other Macros Send Feedback

Bootcamp

Syntax
#define PRL_IMAGE_BOOTCAMP 6
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_COMPRESSED Macro

PRL_IMAGE_COMPRESSED Macro
PrlDisk.h Other Macros Send Feedback

Compressed disk (version 1)

Syntax
#define PRL_IMAGE_COMPRESSED 2
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_COMPRESSED_V2 Macro

PRL_IMAGE_COMPRESSED_V2 Macro
PrlDisk.h Other Macros Send Feedback

Compressed disk (version 2)

Syntax
#define PRL_IMAGE_COMPRESSED_V2 3
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_FORMAT Enumeration

PRL_IMAGE_FORMAT Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
typedef enum _PRL_IMAGE_FORMAT {
  PIF_RAW = 0x50000008,
  PIF_BMP = 0x50000009,
  PIF_JPG = 0x5000000A,
  PIF_PNG = 0x5000000B
} PRL_IMAGE_FORMAT;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_IMAGE_FORMAT_PTR Type

PRL_IMAGE_FORMAT_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_IMAGE_FORMAT* PRL_IMAGE_FORMAT_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_IMAGE_INVALID Macro

PRL_IMAGE_INVALID Macro
PrlDisk.h Other Macros Send Feedback

Invalid type

Syntax
#define PRL_IMAGE_INVALID 0
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_LAST_INVALID Macro

PRL_IMAGE_LAST_INVALID Macro
PrlDisk.h Other Macros Send Feedback

Last (invalid)

Syntax
#define PRL_IMAGE_LAST_INVALID 0x80000000
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_PARAMETERS Structure

PRL_IMAGE_PARAMETERS Structure
PrlDisk.h Other Structs Send Feedback

Parallels storage parameters

Syntax
typedef struct __PRL_IMAGE_PARAMETERS {
  PRL_IMAGE_TYPE Type;
  PRL_UINT64 uStart;
  PRL_UINT64 uSize;
  PRL_CHAR_PTR pFileName;
} PRL_IMAGE_PARAMETERS;
File

PrlDisk.h

Links
PrlDisk.h, Other Structs


PRL_IMAGE_PARAMETERS_PTR Type

PRL_IMAGE_PARAMETERS_PTR Type
PrlDisk.h Other Types Send Feedback
Syntax
typedef PRL_IMAGE_PARAMETERS* PRL_IMAGE_PARAMETERS_PTR;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_IMAGE_PARTITION Macro

PRL_IMAGE_PARTITION Macro
PrlDisk.h Other Macros Send Feedback

Partition from disk

Syntax
#define PRL_IMAGE_PARTITION 5
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_PHYSICAL Macro

PRL_IMAGE_PHYSICAL Macro
PrlDisk.h Other Macros Send Feedback

Real disk (full)

Syntax
#define PRL_IMAGE_PHYSICAL 4
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_PLAIN Macro

PRL_IMAGE_PLAIN Macro
PrlDisk.h Other Macros Send Feedback

Plain disk

Syntax
#define PRL_IMAGE_PLAIN 1
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_TRY_GUESS Macro

PRL_IMAGE_TRY_GUESS Macro
PrlDisk.h Other Macros Send Feedback

Software should guess what kind of disk it is

Syntax
#define PRL_IMAGE_TRY_GUESS 100
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IMAGE_TYPE Type

PRL_IMAGE_TYPE Type
PrlDisk.h Other Types Send Feedback

Parallels images types

Syntax
typedef PRL_UINT32 PRL_IMAGE_TYPE;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_IMAGE_TYPE_PTR Type

PRL_IMAGE_TYPE_PTR Type
PrlDisk.h Other Types Send Feedback
Syntax
typedef PRL_IMAGE_TYPE* PRL_IMAGE_TYPE_PTR;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_INT8 Type

PRL_INT8 Type
PrlTypes.h PRL_INT Types Send Feedback

Signed 8 bit integer value

Syntax
typedef signed char PRL_INT8;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT8_PTR Type

PRL_INT8_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT8* PRL_INT8_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT8_PTR_PTR Type

PRL_INT8_PTR_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT8** PRL_INT8_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT16 Type

PRL_INT16 Type
PrlTypes.h PRL_INT Types Send Feedback

Signed 16 bit integer value

Syntax
typedef short PRL_INT16;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT16_PTR Type

PRL_INT16_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT16* PRL_INT16_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT16_PTR_PTR Type

PRL_INT16_PTR_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT16** PRL_INT16_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT32 Type

PRL_INT32 Type
PrlTypes.h PRL_INT Types Send Feedback

Signed 32 bit integer value

Syntax
typedef int PRL_INT32;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT32_PTR Type

PRL_INT32_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT32* PRL_INT32_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT32_PTR_PTR Type

PRL_INT32_PTR_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT32** PRL_INT32_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT64 Type

PRL_INT64 Type
PrlTypes.h PRL_INT Types Send Feedback

Signed 64 bit integer value Use _MSC_VER macros for MinGW use

Syntax
typedef long long PRL_INT64;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT64_PTR Type

PRL_INT64_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT64* PRL_INT64_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INT64_PTR_PTR Type

PRL_INT64_PTR_PTR Type
PrlTypes.h PRL_INT Types Send Feedback
Syntax
typedef PRL_INT64** PRL_INT64_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_INT Types


PRL_INVALID_HANDLE Macro

PRL_INVALID_HANDLE Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_INVALID_HANDLE ( 0 )
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_INVALID_PARTITION Macro

PRL_INVALID_PARTITION Macro
PrlDisk.h Other Macros Send Feedback

Invalid partition

Syntax
#define PRL_INVALID_PARTITION 0xFF
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_IO_ATTACH_REQUEST Structure

PRL_IO_ATTACH_REQUEST Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_ATTACH_REQUEST {
  PRL_UINT32 isClientLocal;
  PRL_UINT32 encodingType;
  PRL_UINT8 vmUuid[16];
} PRL_IO_ATTACH_REQUEST;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_ATTACH_REQUEST_PTR Type

PRL_IO_ATTACH_REQUEST_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_ATTACH_REQUEST* PRL_IO_ATTACH_REQUEST_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_ATTACH_RESPONSE Structure

PRL_IO_ATTACH_RESPONSE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_ATTACH_RESPONSE {
  PRL_UINT32 attachResult;
  PRL_UINT32 encodingResult;
} PRL_IO_ATTACH_RESPONSE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_ATTACH_RESPONSE_PTR Type

PRL_IO_ATTACH_RESPONSE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_ATTACH_RESPONSE* PRL_IO_ATTACH_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_AUTH_REQUEST Structure

PRL_IO_AUTH_REQUEST Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_AUTH_REQUEST {
  PRL_UINT8 sessionUuid[16];
} PRL_IO_AUTH_REQUEST;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_AUTH_REQUEST_PTR Type

PRL_IO_AUTH_REQUEST_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_AUTH_REQUEST* PRL_IO_AUTH_REQUEST_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_AUTH_RESPONSE Structure

PRL_IO_AUTH_RESPONSE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_AUTH_RESPONSE {
  PRL_UINT32 authResult;
} PRL_IO_AUTH_RESPONSE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_AUTH_RESPONSE_PTR Type

PRL_IO_AUTH_RESPONSE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_AUTH_RESPONSE* PRL_IO_AUTH_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DESKTOP_UTILITIES_STATE Structure

PRL_IO_DESKTOP_UTILITIES_STATE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DESKTOP_UTILITIES_STATE {
  PRL_UINT32 bDesktopShown;
  PRL_UINT32 bTaskbarShown;
} PRL_IO_DESKTOP_UTILITIES_STATE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DESKTOP_UTILITIES_STATE_PTR Type

PRL_IO_DESKTOP_UTILITIES_STATE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DESKTOP_UTILITIES_STATE* PRL_IO_DESKTOP_UTILITIES_STATE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DEVICE_USED Structure

PRL_IO_DEVICE_USED Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DEVICE_USED {
  PRL_UINT32 devType;
  PRL_UINT32 devIndex;
  PRL_UINT32 devAction;
} PRL_IO_DEVICE_USED;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DEVICE_USED_PTR Type

PRL_IO_DEVICE_USED_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DEVICE_USED* PRL_IO_DEVICE_USED_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DISPLAY_PALETTE Structure

PRL_IO_DISPLAY_PALETTE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DISPLAY_PALETTE {
  PRL_IO_PALETTE palette;
  PRL_UINT32 display;
} PRL_IO_DISPLAY_PALETTE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DISPLAY_PALETTE_PTR Type

PRL_IO_DISPLAY_PALETTE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DISPLAY_PALETTE* PRL_IO_DISPLAY_PALETTE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DISPLAY_SCREEN_REGION Structure

PRL_IO_DISPLAY_SCREEN_REGION Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DISPLAY_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_DISPLAY_SCREEN_REGION;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DISPLAY_SCREEN_REGION_PTR Type

PRL_IO_DISPLAY_SCREEN_REGION_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DISPLAY_SCREEN_REGION* PRL_IO_DISPLAY_SCREEN_REGION_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DISPLAY_SCREEN_SIZE Structure

PRL_IO_DISPLAY_SCREEN_SIZE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DISPLAY_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
  PRL_UINT32 display;
  PRL_INT32 displayX;
  PRL_INT32 displayY;
} PRL_IO_DISPLAY_SCREEN_SIZE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DISPLAY_SCREEN_SIZE_PTR Type

PRL_IO_DISPLAY_SCREEN_SIZE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DISPLAY_SCREEN_SIZE* PRL_IO_DISPLAY_SCREEN_SIZE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_DYNRES_TOOLS_STATUS Structure

PRL_IO_DYNRES_TOOLS_STATUS Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_DYNRES_TOOLS_STATUS {
  PRL_UINT32 status;
} PRL_IO_DYNRES_TOOLS_STATUS;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_DYNRES_TOOLS_STATUS_PTR Type

PRL_IO_DYNRES_TOOLS_STATUS_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_DYNRES_TOOLS_STATUS* PRL_IO_DYNRES_TOOLS_STATUS_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_ENCODING_REQUEST Structure

PRL_IO_ENCODING_REQUEST Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_ENCODING_REQUEST {
  PRL_UINT32 encodingType;
} PRL_IO_ENCODING_REQUEST;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_ENCODING_REQUEST_PTR Type

PRL_IO_ENCODING_REQUEST_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_ENCODING_REQUEST* PRL_IO_ENCODING_REQUEST_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_ENCODING_RESPONSE Structure

PRL_IO_ENCODING_RESPONSE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_ENCODING_RESPONSE {
  PRL_UINT32 encodingResult;
} PRL_IO_ENCODING_RESPONSE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_ENCODING_RESPONSE_PTR Type

PRL_IO_ENCODING_RESPONSE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_ENCODING_RESPONSE* PRL_IO_ENCODING_RESPONSE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_GENERIC_BUFFER Structure

PRL_IO_GENERIC_BUFFER Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_GENERIC_BUFFER {
  PRL_UINT32 size;
  PRL_VOID_PTR data;
} PRL_IO_GENERIC_BUFFER;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_GENERIC_BUFFER_PTR Type

PRL_IO_GENERIC_BUFFER_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_GENERIC_BUFFER* PRL_IO_GENERIC_BUFFER_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_GRACEFUL_SHUTDOWN Structure

PRL_IO_GRACEFUL_SHUTDOWN Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_GRACEFUL_SHUTDOWN {
  PRL_UINT32 kind;
} PRL_IO_GRACEFUL_SHUTDOWN;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_GRACEFUL_SHUTDOWN_PTR Type

PRL_IO_GRACEFUL_SHUTDOWN_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_GRACEFUL_SHUTDOWN* PRL_IO_GRACEFUL_SHUTDOWN_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_GUEST_SCREENSAVER_STATE Structure

PRL_IO_GUEST_SCREENSAVER_STATE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_GUEST_SCREENSAVER_STATE {
  PRL_UINT32 bEnabled;
} PRL_IO_GUEST_SCREENSAVER_STATE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_GUEST_SCREENSAVER_STATE_PTR Type

PRL_IO_GUEST_SCREENSAVER_STATE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_GUEST_SCREENSAVER_STATE* PRL_IO_GUEST_SCREENSAVER_STATE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_KEYBOARD_LEDS Structure

PRL_IO_KEYBOARD_LEDS Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_KEYBOARD_LEDS {
  PRL_UINT32 ledsState;
} PRL_IO_KEYBOARD_LEDS;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_KEYBOARD_LEDS_PTR Type

PRL_IO_KEYBOARD_LEDS_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_KEYBOARD_LEDS* PRL_IO_KEYBOARD_LEDS_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_KEYBOARD_SCANCODE Structure

PRL_IO_KEYBOARD_SCANCODE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_KEYBOARD_SCANCODE {
  PRL_UINT16 key;
} PRL_IO_KEYBOARD_SCANCODE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_KEYBOARD_SCANCODE_PTR Type

PRL_IO_KEYBOARD_SCANCODE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_KEYBOARD_SCANCODE* PRL_IO_KEYBOARD_SCANCODE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_MAX_DISPLAYS Macro

PRL_IO_MAX_DISPLAYS Macro
PrlIoStructs.h Other Macros Send Feedback
Syntax
#define PRL_IO_MAX_DISPLAYS 16
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Macros


PRL_IO_MEMORY_INFO Structure

PRL_IO_MEMORY_INFO Structure
PrlIoStructs.h PRL_IO Structs Send Feedback

PRIVATE STRUCTS

Syntax
typedef struct _PRL_IO_MEMORY_INFO {
  PRL_UINT64 ramOffset;
  PRL_UINT64 ramSize;
  PRL_UINT64 vramOffset;
  PRL_UINT64 vramSize;
  PRL_UINT32 filenameSize;
} PRL_IO_MEMORY_INFO;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_MEMORY_INFO_PTR Type

PRL_IO_MEMORY_INFO_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_MEMORY_INFO* PRL_IO_MEMORY_INFO_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_MOUSE_CURSOR Structure

PRL_IO_MOUSE_CURSOR Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_MOUSE_CURSOR {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 hotSpotX;
  PRL_UINT32 hotSpotY;
  PRL_UINT32 width;
  PRL_UINT32 height;
} PRL_IO_MOUSE_CURSOR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_MOUSE_CURSOR_PTR Type

PRL_IO_MOUSE_CURSOR_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_MOUSE_CURSOR* PRL_IO_MOUSE_CURSOR_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_MOUSE_EVENT Structure

PRL_IO_MOUSE_EVENT Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_MOUSE_EVENT {
  PRL_INT32 x;
  PRL_INT32 y;
  PRL_INT32 z;
  PRL_UINT32 buttons;
} PRL_IO_MOUSE_EVENT;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_MOUSE_EVENT_PTR Type

PRL_IO_MOUSE_EVENT_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_MOUSE_EVENT* PRL_IO_MOUSE_EVENT_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_PALETTE Type

PRL_IO_PALETTE Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_UINT32 PRL_IO_PALETTE[256];
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SCREEN_BUFFER_REGION Structure

PRL_IO_SCREEN_BUFFER_REGION Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SCREEN_BUFFER_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 scaleWidth;
  PRL_UINT32 scaleHeight;
  PRL_UINT32 display;
} PRL_IO_SCREEN_BUFFER_REGION;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SCREEN_BUFFER_REGION_PTR Type

PRL_IO_SCREEN_BUFFER_REGION_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SCREEN_BUFFER_REGION* PRL_IO_SCREEN_BUFFER_REGION_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SCREEN_REGION Structure

PRL_IO_SCREEN_REGION Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SCREEN_REGION {
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
} PRL_IO_SCREEN_REGION;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SCREEN_REGION_PTR Type

PRL_IO_SCREEN_REGION_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SCREEN_REGION* PRL_IO_SCREEN_REGION_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SCREEN_SIZE Structure

PRL_IO_SCREEN_SIZE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SCREEN_SIZE {
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 depth;
  PRL_INT32 lineBytes;
} PRL_IO_SCREEN_SIZE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SCREEN_SIZE_PTR Type

PRL_IO_SCREEN_SIZE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SCREEN_SIZE* PRL_IO_SCREEN_SIZE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SCREEN_SURFACE Structure

PRL_IO_SCREEN_SURFACE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SCREEN_SURFACE {
  PRL_UINT32 windowId;
  PRL_UINT32 surfaceId;
  PRL_INT32 scrollX;
  PRL_INT32 scrollY;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_SCREEN_SURFACE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SCREEN_SURFACE_PTR Type

PRL_IO_SCREEN_SURFACE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SCREEN_SURFACE* PRL_IO_SCREEN_SURFACE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SCREEN_UPDATE Structure

PRL_IO_SCREEN_UPDATE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SCREEN_UPDATE {
  PRL_UINT32 offset;
  PRL_UINT32 x;
  PRL_UINT32 y;
  PRL_UINT32 width;
  PRL_UINT32 height;
  PRL_UINT32 display;
} PRL_IO_SCREEN_UPDATE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SCREEN_UPDATE_PTR Type

PRL_IO_SCREEN_UPDATE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SCREEN_UPDATE* PRL_IO_SCREEN_UPDATE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SET_TASKBAR_VISIBILITY Structure

PRL_IO_SET_TASKBAR_VISIBILITY Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SET_TASKBAR_VISIBILITY {
  PRL_UINT32 visibility;
} PRL_IO_SET_TASKBAR_VISIBILITY;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SET_TASKBAR_VISIBILITY_PTR Type

PRL_IO_SET_TASKBAR_VISIBILITY_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SET_TASKBAR_VISIBILITY* PRL_IO_SET_TASKBAR_VISIBILITY_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_SLIDING_MOUSE Structure

PRL_IO_SLIDING_MOUSE Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_SLIDING_MOUSE {
  PRL_UINT32 enable;
} PRL_IO_SLIDING_MOUSE;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_SLIDING_MOUSE_PTR Type

PRL_IO_SLIDING_MOUSE_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_SLIDING_MOUSE* PRL_IO_SLIDING_MOUSE_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_STATE Enumeration

PRL_IO_STATE Enumeration
PrlEnums.h PRL_IO Structs Send Feedback
Syntax
typedef enum _PRL_IO_STATE {
  IOS_DISABLED = 0,
  IOS_STARTED = 1,
  IOS_STOPPED = 2,
  IOS_UNKNOWN_VM_UUID = 3,
  IOS_CONNECTION_TIMEOUT = 4,
  IOS_AUTH_FAILED = 5
} PRL_IO_STATE;
File

PrlEnums.h

Members

IOS_DISABLED
< Desktop has not been enabled
IOS_STARTED
< Successfully started.(local and remote)
IOS_STOPPED
< Is stopped.
IOS_UNKNOWN_VM_UUID
< Unknown uuid.
IOS_CONNECTION_TIMEOUT
< Connection timeout.
IOS_AUTH_FAILED
< Authentication failed.

Links
PrlEnums.h, PRL_IO Structs


PRL_IO_STATE_PTR Type

PRL_IO_STATE_PTR Type
PrlEnums.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_STATE* PRL_IO_STATE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_IO Types


PRL_IO_TOOLS_MOVE_TASKBAR Structure

PRL_IO_TOOLS_MOVE_TASKBAR Structure
PrlIoStructs.h PRL_IO Structs Send Feedback
Syntax
typedef struct _PRL_IO_TOOLS_MOVE_TASKBAR {
  PRL_BOOL bCoherenceOn;
  PRL_BOOL bRelocateTaskBar;
  PRL_UINT32 uDockEdge;
  PRL_UINT32 uEdgeMask;
} PRL_IO_TOOLS_MOVE_TASKBAR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_TOOLS_MOVE_TASKBAR_PTR Type

PRL_IO_TOOLS_MOVE_TASKBAR_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_TOOLS_MOVE_TASKBAR* PRL_IO_TOOLS_MOVE_TASKBAR_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_TOOLS_SIA_DATA Structure

PRL_IO_TOOLS_SIA_DATA Structure
PrlIoStructs.h PRL_IO Structs Send Feedback

@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
Syntax
typedef struct _PRL_IO_TOOLS_SIA_DATA {
  PRL_UINT32 ver;
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 size;
} PRL_IO_TOOLS_SIA_DATA;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_TOOLS_SIA_DATA_PTR Type

PRL_IO_TOOLS_SIA_DATA_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_TOOLS_SIA_DATA* PRL_IO_TOOLS_SIA_DATA_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_IO_TOOLS_UTILITY_COMMAND Structure

PRL_IO_TOOLS_UTILITY_COMMAND Structure
PrlIoStructs.h PRL_IO Structs Send Feedback

@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
Syntax
typedef struct _PRL_IO_TOOLS_UTILITY_COMMAND {
  PRL_UINT32 command;
  PRL_UINT32 flags;
  PRL_UINT32 dataSize;
} PRL_IO_TOOLS_UTILITY_COMMAND;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Structs


PRL_IO_TOOLS_UTILITY_COMMAND_PTR Type

PRL_IO_TOOLS_UTILITY_COMMAND_PTR Type
PrlIoStructs.h PRL_IO Types Send Feedback
Syntax
typedef PRL_IO_TOOLS_UTILITY_COMMAND* PRL_IO_TOOLS_UTILITY_COMMAND_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_IO Types


PRL_JOB_OPERATION_CODE Enumeration

PRL_JOB_OPERATION_CODE Enumeration
PrlEnums.h Other Structs Send Feedback

Job operation codes

Syntax
typedef enum _PRL_JOB_OPERATION_CODE {
  PJOC_UNKNOWN = 0,
  PJOC_JOB_CANCEL = 1,
  PJOC_SRV_LOOKUP_PARALLELS_SERVERS = 2,
  PJOC_SRV_LOGIN = 3,
  PJOC_SRV_LOGIN_LOCAL = 4,
  PJOC_SRV_LOGOFF = 5,
  PJOC_SRV_GET_SRV_CONFIG = 6,
  PJOC_SRV_GET_COMMON_PREFS = 7,
  PJOC_SRV_COMMON_PREFS_BEGIN_EDIT = 8,
  PJOC_SRV_COMMON_PREFS_COMMIT = 9,
  PJOC_SRV_GET_USER_PROFILE = 10,
  PJOC_SRV_GET_STATISTICS = 11,
  PJOC_SRV_USER_PROFILE_BEGIN_EDIT = 12,
  PJOC_SRV_USER_PROFILE_COMMIT = 13,
  PJOC_SRV_REGISTER_VM = 14,
  PJOC_SRV_GET_VM_LIST = 15,
  PJOC_SRV_SUBSCRIBE_TO_HOST_STATISTICS = 16,
  PJOC_SRV_UNSUBSCRIBE_FROM_HOST_STATISTICS = 17,
  PJOC_SRV_SHUTDOWN = 18,
  PJOC_SRV_FS_GET_DISK_LIST = 19,
  PJOC_SRV_FS_GET_DIR_ENTRIES = 20,
  PJOC_SRV_FS_CREATE_DIR = 21,
  PJOC_SRV_FS_REMOVE_ENTRY = 22,
  PJOC_SRV_FS_CAN_CREATE_FILE = 23,
  PJOC_SRV_FS_RENAME_ENTRY = 24,
  PJOC_SRV_FS_GENERATE_ENTRY_NAME = 25,
  PJOC_SRV_UPDATE_LICENSE = 26,
  PJOC_SRV_GET_LICENSE_INFO = 27,
  PJOC_SRV_SEND_ANSWER = 28,
  PJOC_SRV_START_SEARCH_VMS = 29,
  PJOC_SRV_NET_SERVICE_START = 30,
  PJOC_SRV_NET_SERVICE_STOP = 31,
  PJOC_SRV_NET_SERVICE_RESTART = 32,
  PJOC_SRV_NET_SERVICE_RESTORE_DEFAULTS = 33,
  PJOC_SRV_GET_NET_SERVICE_STATUS = 34,
  PJOC_SRV_ADD_NET_ADAPTER = 35,
  PJOC_SRV_DELETE_NET_ADAPTER = 36,
  PJOC_SRV_UPDATE_NET_ADAPTER = 37,
  PJOC_SRV_GET_PROBLEM_REPORT = 38,
  PJOC_SRV_ATTACH_TO_LOST_TASK = 39,
  PJOC_SRV_GET_USER_INFO_LIST = 40,
  PJOC_SRV_GET_USER_INFO = 41,
  PJOC_VM_START = 42,
  PJOC_VM_STOP = 43,
  PJOC_VM_PAUSE = 44,
  PJOC_VM_RESET = 45,
  PJOC_VM_SUSPEND = 46,
  PJOC_VM_RESUME = PJOC_VM_START,
  PJOC_VM_DROP_SUSPENDED_STATE = 49,
  PJOC_VM_CLONE = 50,
  PJOC_VM_DELETE = 51,
  PJOC_VM_GET_PROBLEM_REPORT = 52,
  PJOC_VM_GET_STATE = 53,
  PJOC_VM_GENERATE_VM_DEV_FILENAME = 54,
  PJOC_VM_GET_TOOLS_STATE = 55,
  PJOC_VM_REFRESH_CONFIG = 56,
  PJOC_VM_GET_STATISTICS = 57,
  PJOC_VM_SUBSCRIBE_TO_GUEST_STATISTICS = 58,
  PJOC_VM_UNSUBSCRIBE_FROM_GUEST_STATISTICS = 59,
  PJOC_VM_REG = 60,
  PJOC_VM_UNREG = 61,
  PJOC_VM_BEGIN_EDIT = 62,
  PJOC_VM_COMMIT = 63,
  PJOC_VM_CREATE_UNATTENDED_FLOPPY = 64,
  PJOC_VM_INITIATE_DEV_STATE_NOTIFICATIONS = 65,
  PJOC_VM_UPDATE_SECURITY = 66,
  PJOC_VM_VALIDATE_CONFIG = 67,
  PJOC_VM_DEV_CONNECT = 68,
  PJOC_VM_DEV_DISCONNECT = 69,
  PJOC_VM_DEV_CREATE_IMAGE = 70,
  PJOC_VM_INSTALL_TOOLS = 71,
  PJOC_VM_SEND_SHUTDOWN_COMMAND = 72,
  PJOC_VM_SEND_CLIPBOARD_REQUEST = 73,
  PJOC_VM_CONNECT_TO_VM = 74,
  PJOC_VM_DEV_DISPLAY_CAPTURE_SCREEN = 75,
  PJOC_VM_MIGRATE = 76,
  PJOC_VM_SEND_DRAGDROP_COMMAND = 77,
  PJOC_VM_GUEST_RUN_PROGRAM = 78,
  PJOC_VM_GUEST_LOGOUT = 79,
  PJOC_SRV_SUBSCRIBE_PERFSTATS = 80,
  PJOC_SRV_UNSUBSCRIBE_PERFSTATS = 81,
  PJOC_SRV_GET_PERFSTATS = 82,
  PJOC_VM_SUBSCRIBE_PERFSTATS = 83,
  PJOC_VM_UNSUBSCRIBE_PERFSTATS = 84,
  PJOC_VM_GET_PERFSTATS = 85,
  PJOC_VM_GET_SUSPENDED_SCREEN = 86,
  PJOC_VM_MIGRATE_CANCEL = 87,
  PJOC_VM_RUN_COMPRESSOR = 88,
  PJOC_VM_CANCEL_COMPRESSOR = 89,
  PJOC_VM_CREATE_SNAPSHOT = 90,
  PJOC_VM_SWITCH_TO_SNAPSHOT = 91,
  PJOC_VM_DELETE_SNAPSHOT = 92,
  PJOC_VM_GET_SNAPSHOTS_TREE = 93,
  PJOC_VM_START_EX = 94,
  PJOC_VM_LOGIN_IN_GUEST = 95,
  PJOC_VM_UPDATE_SNAPSHOT_DATA = 96,
  PJOC_VM_RESTART = 97,
  PJOC_VM_INSTALL_UTILITY = 98,
  PJOC_VM_UPDATE_TOOLS_SECTION = 99,
  PJOC_SRV_GET_ALL_HOST_USERS = 100,
  PJOC_VM_RESTORE = 101,
  PJOC_VM_START_VNC_SERVER = 102,
  PJOC_VM_STOP_VNC_SERVER = 103,
  PJOC_VM_GUEST_GET_NETWORK_SETTINGS = 104,
  PJOC_SRV_GET_VIRTUAL_NETWORK_LIST = 105,
  PJOC_VM_AUTH_WITH_GUEST_SECURITY_DB = 106
} PRL_JOB_OPERATION_CODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_JOB_OPERATION_CODE_PTR Type

PRL_JOB_OPERATION_CODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_JOB_OPERATION_CODE* PRL_JOB_OPERATION_CODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_JOB_STATUS Enumeration

PRL_JOB_STATUS Enumeration
PrlEnums.h Other Structs Send Feedback

Job status enumeration

Syntax
typedef enum _PRL_JOB_STATUS {
  PJS_UNKNOWN = 0,
  PJS_RUNNING = 0xD0000001,
  PJS_FINISHED = 0xD0000002
} PRL_JOB_STATUS;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_JOB_STATUS_PTR Type

PRL_JOB_STATUS_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_JOB_STATUS* PRL_JOB_STATUS_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_KEY_EVENT Enumeration

PRL_KEY_EVENT Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
typedef enum _PRL_KEY_EVENT {
  PKE_PRESS = 0x0,
  PKE_RELEASE = 0x80
} PRL_KEY_EVENT;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_KEY_EVENT_PTR Type

PRL_KEY_EVENT_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_KEY_EVENT* PRL_KEY_EVENT_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_LINUX_EXTENDED_PARTITION Macro

PRL_LINUX_EXTENDED_PARTITION Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_LINUX_EXTENDED_PARTITION 0x85
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_LINUX_PARTITION_DATA Macro

PRL_LINUX_PARTITION_DATA Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_LINUX_PARTITION_DATA 0x83
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_LINUX_PARTITION_SWAP Macro

PRL_LINUX_PARTITION_SWAP Macro
PrlDisk.h Other Macros Send Feedback

Linux partitions

Syntax
#define PRL_LINUX_PARTITION_SWAP 0x82
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_MACOS_PARTITION Macro

PRL_MACOS_PARTITION Macro
PrlDisk.h Other Macros Send Feedback

Mac OS

Syntax
#define PRL_MACOS_PARTITION 0xAF
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration

PRL_MASS_STORAGE_INTERFACE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Mass storage device interface type

Syntax
typedef enum _PRL_MASS_STORAGE_INTERFACE_TYPE {
  PMS_IDE_DEVICE = 0,
  PMS_SCSI_DEVICE = 1
} PRL_MASS_STORAGE_INTERFACE_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_MASS_STORAGE_INTERFACE_TYPE_PTR Type

PRL_MASS_STORAGE_INTERFACE_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_MASS_STORAGE_INTERFACE_TYPE* PRL_MASS_STORAGE_INTERFACE_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_MESSAGE_TYPE_ENUM Enumeration

PRL_MESSAGE_TYPE_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Message type enumeration.

Syntax
typedef enum _PRL_MESSAGE_TYPE_ENUM {
  PMT_WARNING = 0,
  PMT_INFORMATION = 1,
  PMT_CRITICAL = 2,
  PMT_QUESTION = 3,
  PMT_ANSWER = 4
} PRL_MESSAGE_TYPE_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_MESSAGE_TYPE_ENUM_PTR Type

PRL_MESSAGE_TYPE_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_MESSAGE_TYPE_ENUM* PRL_MESSAGE_TYPE_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_METHOD Macro

PRL_METHOD Macro
PrlTypes.h Other Macros Send Feedback

Default method decoration

Syntax
#define PRL_METHOD( func ) PRL_EXTERN __declspec(dllexport) PRL_RESULT PRL_CALL func
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_METHOD_DECL Macro

PRL_METHOD_DECL Macro
PrlTypes.h Other Macros Send Feedback

Default method declaration for the header files

Syntax
#define PRL_METHOD_DECL( version, name, args ) \
    PRL_METHOD( name ) args;    \
    typedef PRL_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_METHOD_PTR Macro

PRL_METHOD_PTR Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_METHOD_PTR( func_type ) PRL_RESULT ( PRL_CALL * func_type )
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_MOUSE_BUTTON Enumeration

PRL_MOUSE_BUTTON Enumeration
PrlEnums.h Other Structs Send Feedback
Syntax
typedef enum _PRL_MOUSE_BUTTON {
  PMB_NOBUTTON = 0,
  PMB_LEFT_BUTTON = 1,
  PMB_RIGHT_BUTTON = 2,
  PMB_MIDDLE_BUTTON = 4
} PRL_MOUSE_BUTTON;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_MOUSE_BUTTON_PTR Type

PRL_MOUSE_BUTTON_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_MOUSE_BUTTON* PRL_MOUSE_BUTTON_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_MSDOS_EXTENDED_PARTITION Macro

PRL_MSDOS_EXTENDED_PARTITION Macro
PrlDisk.h Other Macros Send Feedback
  • Disk partition types

Extended partitions

Syntax
#define PRL_MSDOS_EXTENDED_PARTITION 0x05
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_NET_ADAPTER_EMULATED_TYPE Enumeration

PRL_NET_ADAPTER_EMULATED_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Network adapter emulated type

Syntax
typedef enum _PRL_NET_ADAPTER_EMULATED_TYPE {
  PNA_HOST_ONLY = 0,
  PNA_SHARED = 1,
  PNA_BRIDGED_ETHERNET = 2
} PRL_NET_ADAPTER_EMULATED_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_NET_ADAPTER_EMULATED_TYPE_PTR Type

PRL_NET_ADAPTER_EMULATED_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_NET_ADAPTER_EMULATED_TYPE* PRL_NET_ADAPTER_EMULATED_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_NET_ADAPTER_NOT_EXIST Macro

PRL_NET_ADAPTER_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_ADAPTER_NOT_EXIST PRL_RESULT_DECLARE_ERROR(4004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_BIND_FAILED Macro

PRL_NET_BIND_FAILED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_BIND_FAILED PRL_RESULT_DECLARE_ERROR(4009)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_CABLE_DISCONNECTED Macro

PRL_NET_CABLE_DISCONNECTED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_CABLE_DISCONNECTED PRL_RESULT_DECLARE_ERROR(4010)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_CONNECTION_SHARING_CONFLICT Macro

PRL_NET_CONNECTION_SHARING_CONFLICT Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_CONNECTION_SHARING_CONFLICT PRL_RESULT_DECLARE_ERROR(4015)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_ERR_ADAPTER_CONFIG Macro

PRL_NET_ERR_ADAPTER_CONFIG Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_ERR_ADAPTER_CONFIG PRL_RESULT_DECLARE_ERROR(4005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER Macro

PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_ERR_ETH_NO_BINDABLE_ADAPTER PRL_RESULT_DECLARE_ERROR(4006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER Macro

PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_ERR_PRL_NO_BINDABLE_ADAPTER PRL_RESULT_DECLARE_ERROR(4007)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_ETHLIST_CREATE_ERROR Macro

PRL_NET_ETHLIST_CREATE_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback
  • Network

+++ ALIGNED VALUE TO 4000

Syntax
#define PRL_NET_ETHLIST_CREATE_ERROR PRL_RESULT_DECLARE_ERROR(4000)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_INSTALL_FAILED Macro

PRL_NET_INSTALL_FAILED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_INSTALL_FAILED PRL_RESULT_DECLARE_ERROR(4013)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_INSTALL_TIMEOUT Macro

PRL_NET_INSTALL_TIMEOUT Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_INSTALL_TIMEOUT PRL_RESULT_DECLARE_ERROR(4012)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING Macro

PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING Macro
PrlErrorsValues.h Other Macros Send Feedback

Operation succeeded, but failed to change Network Adapter IP-address.

Syntax
#define PRL_NET_IPADDRESS_MODIFY_FAILED_WARNING PRL_RESULT_DECLARE_SUCCESS(4022)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_PKTFILTER_ERROR Macro

PRL_NET_PKTFILTER_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback

Failed to setup packet filter for VM Adapter.

Syntax
#define PRL_NET_PKTFILTER_ERROR PRL_RESULT_DECLARE_ERROR(4023)
File

PrlErrorsValues.h

Remarks

Adapter will be disconnected.

Links
PrlErrorsValues.h, Other Macros


PRL_NET_PRLNET_OPEN_FAILED Macro

PRL_NET_PRLNET_OPEN_FAILED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_PRLNET_OPEN_FAILED PRL_RESULT_DECLARE_ERROR(4008)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_RENAME_FAILED Macro

PRL_NET_RENAME_FAILED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_RENAME_FAILED PRL_RESULT_DECLARE_ERROR(4011)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS Macro

PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_RESTORE_DEFAULTS_PARTITIAL_SUCCESS PRL_RESULT_DECLARE_ERROR(4016)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_SRV_NOTIFY_ERROR Macro

PRL_NET_SRV_NOTIFY_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_SRV_NOTIFY_ERROR PRL_RESULT_DECLARE_ERROR(4003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_SYSTEM_ERROR Macro

PRL_NET_SYSTEM_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_SYSTEM_ERROR PRL_RESULT_DECLARE_ERROR(4001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_UNINSTALL_FAILED Macro

PRL_NET_UNINSTALL_FAILED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_UNINSTALL_FAILED PRL_RESULT_DECLARE_ERROR(4014)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration

PRL_NET_VIRTUAL_NETWORK_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Virtual Network type.

Syntax
typedef enum _PRL_NET_VIRTUAL_NETWORK_TYPE {
  PVN_BRIDGED_ETHERNET = 0,
  PVN_HOST_ONLY = 1
} PRL_NET_VIRTUAL_NETWORK_TYPE;
File

PrlEnums.h

Remarks

Should match values in LibrariesNetworkConfigprl_netconfigprl_netconfig.h

Links
PrlEnums.h, Other Structs


PRL_NET_VIRTUAL_NETWORK_TYPE_PTR Type

PRL_NET_VIRTUAL_NETWORK_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_NET_VIRTUAL_NETWORK_TYPE* PRL_NET_VIRTUAL_NETWORK_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION Macro

PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_VLAN_UNSUPPORTED_IN_THIS_VERSION PRL_RESULT_DECLARE_ERROR(4017)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback

Error while connect VMDevice: Misconfiguration in virtual network.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_CONFIG_ERROR PRL_RESULT_DECLARE_ERROR(4020)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED Macro
PrlErrorsValues.h Other Macros Send Feedback

Error while connect VMDevice: Specified virtual network is disabled.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_DISABLED PRL_RESULT_DECLARE_ERROR(4021)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER Macro
PrlErrorsValues.h Other Macros Send Feedback

Error while connect VMDevice: Adapter for virtual network does not exist.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NO_ADAPTER PRL_RESULT_DECLARE_ERROR(4019)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST Macro

PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback

Error while connect VMDevice: network for VM Network Adapter does not exist.

Syntax
#define PRL_NET_VMDEVICE_VIRTUAL_NETWORK_NOT_EXIST PRL_RESULT_DECLARE_ERROR(4018)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NET_WINSCM_OPEN_ERROR Macro

PRL_NET_WINSCM_OPEN_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_NET_WINSCM_OPEN_ERROR PRL_RESULT_DECLARE_ERROR(4002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_NULL Macro

PRL_NULL Macro
PrlTypes.h Other Macros Send Feedback

NULL (invalid) handle

Syntax
#define PRL_NULL ( (PRL_VOID_PTR) 0 )
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_PARAM_FIELD_DATA_TYPE Enumeration

PRL_PARAM_FIELD_DATA_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Event parameters fields types

Syntax
typedef enum _PRL_PARAM_FIELD_DATA_TYPE {
  PFD_UINT32 = 0,
  PFD_STRING = 1,
  PFD_INT32 = 2,
  PFD_CDATA = 3,
  PFD_BOOLEAN = 4,
  PFD_ENTITY = 5,
  PFD_ENUMERATION = 6,
  PFD_INT64 = 7,
  PFD_UINT64 = 8
} PRL_PARAM_FIELD_DATA_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_PARAM_FIELD_DATA_TYPE_PTR Type

PRL_PARAM_FIELD_DATA_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_PARAM_FIELD_DATA_TYPE* PRL_PARAM_FIELD_DATA_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_PORT_FORWARDING_TYPE Enumeration

PRL_PORT_FORWARDING_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding

Syntax
typedef enum _PRL_PORT_FORWARDING_TYPE {
  PPF_TCP = 0,
  PPF_UDP = 1
} PRL_PORT_FORWARDING_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_PORT_FORWARDING_TYPE_PTR Type

PRL_PORT_FORWARDING_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_PORT_FORWARDING_TYPE* PRL_PORT_FORWARDING_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_PRIVILEGED_GUEST_OS_SESSION Macro

PRL_PRIVILEGED_GUEST_OS_SESSION Macro
PrlEnums.h Other Macros Send Feedback

Guest OS sessions types and constants declarations

Syntax
#define PRL_PRIVILEGED_GUEST_OS_SESSION "531582ac-3dce-446f-8c26-dd7e3384dcf4"
File

PrlEnums.h

Links
PrlEnums.h, Other Macros


PRL_PROCESS_STATE_TYPE Enumeration

PRL_PROCESS_STATE_TYPE Enumeration
PrlEnums.h Other Structs Send Feedback

Process state element

Syntax
typedef enum _PRL_PROCESS_STATE_TYPE {
  PPS_PROC_SLEEP = 0,
  PPS_PROC_RUN = 1,
  PPS_PROC_STOP = 2,
  PPS_PROC_ZOMBIE = 3,
  PPS_PROC_IDLE = 4
} PRL_PROCESS_STATE_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_PROCESS_STATE_TYPE_PTR Type

PRL_PROCESS_STATE_TYPE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_PROCESS_STATE_TYPE* PRL_PROCESS_STATE_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_PRODUCT_ENUM Enumeration

PRL_PRODUCT_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels lilcense products enumeration.

Syntax
typedef enum _PRL_PRODUCT_ENUM {
  PRL_PRODUCT_ANY = 0,
  PRL_PRODUCT_DESKTOP = 1,
  PRL_PRODUCT_SERVER = 2,
  PRL_PRODUCT_WORKSTATION = 3,
  PRL_PRODUCT_STM = 4
} PRL_PRODUCT_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_PRODUCT_ENUM_PTR Type

PRL_PRODUCT_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_PRODUCT_ENUM* PRL_PRODUCT_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_QUEST_CD_DRIVE_NOT_EXIST Macro

PRL_QUEST_CD_DRIVE_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_CD_DRIVE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(221)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_CDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_CDD_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_CDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(220)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_EXCEED_RECOMMENDED_MEMORY Macro

PRL_QUEST_EXCEED_RECOMMENDED_MEMORY Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_EXCEED_RECOMMENDED_MEMORY PRL_RESULT_DECLARE_ERROR(219)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_FDD_DRIVE_NOT_EXIST Macro

PRL_QUEST_FDD_DRIVE_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_FDD_DRIVE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(225)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_FDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_FDD_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_FDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(224)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_HDD_IMAGE_NOT_EXIST Macro

PRL_QUEST_HDD_IMAGE_NOT_EXIST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_HDD_IMAGE_NOT_EXIST PRL_RESULT_DECLARE_ERROR(223)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_HDD_SAME_IMAGE Macro

PRL_QUEST_HDD_SAME_IMAGE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_HDD_SAME_IMAGE PRL_RESULT_DECLARE_ERROR(222)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_POWER_OFF Macro

PRL_QUEST_POWER_OFF Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_POWER_OFF PRL_RESULT_DECLARE_ERROR(311)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_RESET Macro

PRL_QUEST_RESET Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_RESET PRL_RESULT_DECLARE_ERROR(312)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_QUEST_RESTART Macro

PRL_QUEST_RESTART Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_QUEST_RESTART PRL_RESULT_DECLARE_SUCCESS(15076)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_RESULT Type

PRL_RESULT Type
PrlErrors.h Other Types Send Feedback

Unified result error code for each and every method

Syntax
typedef int PRL_RESULT;
File

PrlErrors.h

Links
PrlErrors.h, Other Types


PRL_RESULT_DECLARE_ERROR Macro

PRL_RESULT_DECLARE_ERROR Macro
PrlErrors.h Other Macros Send Feedback

Declaration of the error value goes here

Syntax
#define PRL_RESULT_DECLARE_ERROR( err ) ( (PRL_RESULT) (0x80000000 + 0x##err) )
File

PrlErrors.h

Links
PrlErrors.h, Other Macros


PRL_RESULT_DECLARE_SUCCESS Macro

PRL_RESULT_DECLARE_SUCCESS Macro
PrlErrors.h Other Macros Send Feedback
Syntax
#define PRL_RESULT_DECLARE_SUCCESS( err ) ( (PRL_RESULT) (err) )
File

PrlErrors.h

Links
PrlErrors.h, Other Macros


PRL_RESULT_PTR Type

PRL_RESULT_PTR Type
PrlErrors.h Other Types Send Feedback
Syntax
typedef PRL_RESULT* PRL_RESULT_PTR;
File

PrlErrors.h

Links
PrlErrors.h, Other Types


prl_result_to_string Function

prl_result_to_string Function
PrlApi.h API Debug Functions Send Feedback

This inline function returns a readable string representation of the PRL_RESULT value.

Syntax
inline const char * prl_result_to_string(
    PRL_RESULT value
);
File

PrlApi.h

Parameters

value
A variable of type PRL_RESULT.

Links
PrlApi.h, API Debug Functions


PRL_RUNNING_TASK_TYPE_ENUM Enumeration

PRL_RUNNING_TASK_TYPE_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Running task type enumeration.

Syntax
typedef enum _PRL_RUNNING_TASK_TYPE_ENUM {
  RTT_RUNNING_TASK_UNKNOWN = 0,
  RTT_RUNNING_TASK_CREATE_VM = 1,
  RTT_RUNNING_TASK_REGISTER_VM = 2,
  RTT_RUNNING_TASK_CLONE_VM = 3,
  RTT_RUNNING_TASK_DELETE_VM = 4,
  RTT_RUNNING_TASK_UNREG_VM = 5,
  RTT_RUNNING_TASK_CREATE_IMAGE = 6,
  RTT_RUNNING_TASK_RESTORE_VM = 7
} PRL_RUNNING_TASK_TYPE_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_RUNNING_TASK_TYPE_ENUM_PTR Type

PRL_RUNNING_TASK_TYPE_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_RUNNING_TASK_TYPE_ENUM* PRL_RUNNING_TASK_TYPE_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_SCAN_CODE_0 Macro

PRL_SCAN_CODE_0 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_0 {11}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_1 Macro

PRL_SCAN_CODE_1 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_1 {2}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_2 Macro

PRL_SCAN_CODE_2 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_2 {3}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_3 Macro

PRL_SCAN_CODE_3 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_3 {4}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_4 Macro

PRL_SCAN_CODE_4 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_4 {5}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_5 Macro

PRL_SCAN_CODE_5 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_5 {6}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_6 Macro

PRL_SCAN_CODE_6 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_6 {7}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_7 Macro

PRL_SCAN_CODE_7 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_7 {8}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_8 Macro

PRL_SCAN_CODE_8 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_8 {9}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_9 Macro

PRL_SCAN_CODE_9 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_9 {10}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_A Macro

PRL_SCAN_CODE_A Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_A {30}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ALT_LEFT Macro

PRL_SCAN_CODE_ALT_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_ALT_LEFT {56}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ALT_RIGHT Macro

PRL_SCAN_CODE_ALT_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_ALT_RIGHT {224, 56}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_B Macro

PRL_SCAN_CODE_B Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_B {48}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BACKSLASH Macro

PRL_SCAN_CODE_BACKSLASH Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_BACKSLASH {43}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_BACKSPACE Macro

PRL_SCAN_CODE_BACKSPACE Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_BACKSPACE {14}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_C Macro

PRL_SCAN_CODE_C Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_C {46}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CAPS_LOCK Macro

PRL_SCAN_CODE_CAPS_LOCK Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CAPS_LOCK {58}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CBRACE_LEFT Macro

PRL_SCAN_CODE_CBRACE_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CBRACE_LEFT {26}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CBRACE_RIGHT Macro

PRL_SCAN_CODE_CBRACE_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CBRACE_RIGHT {27}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CMD_LEFT Macro

PRL_SCAN_CODE_CMD_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CMD_LEFT {224, 91}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CMD_RIGHT Macro

PRL_SCAN_CODE_CMD_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CMD_RIGHT {224, 92}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_COLON Macro

PRL_SCAN_CODE_COLON Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_COLON {39}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CTRL_LEFT Macro

PRL_SCAN_CODE_CTRL_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CTRL_LEFT {29}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_CTRL_RIGHT Macro

PRL_SCAN_CODE_CTRL_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_CTRL_RIGHT {224, 29}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_D Macro

PRL_SCAN_CODE_D Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_D {32}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_DELETE Macro

PRL_SCAN_CODE_DELETE Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_DELETE {224, 83}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_DOWN Macro

PRL_SCAN_CODE_DOWN Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_DOWN {224, 80}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_E Macro

PRL_SCAN_CODE_E Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_E {18}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ENTER Macro

PRL_SCAN_CODE_ENTER Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_ENTER {28}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_ESC Macro

PRL_SCAN_CODE_ESC Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback

Scan codes symbolical names for the SDK purposes.

Syntax
#define PRL_SCAN_CODE_ESC {1}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F Macro

PRL_SCAN_CODE_F Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F {33}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F1 Macro

PRL_SCAN_CODE_F1 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F1 {59}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F2 Macro

PRL_SCAN_CODE_F2 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F2 {60}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F3 Macro

PRL_SCAN_CODE_F3 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F3 {61}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F4 Macro

PRL_SCAN_CODE_F4 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F4 {62}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F5 Macro

PRL_SCAN_CODE_F5 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F5 {63}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F6 Macro

PRL_SCAN_CODE_F6 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F6 {64}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F7 Macro

PRL_SCAN_CODE_F7 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F7 {65}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F8 Macro

PRL_SCAN_CODE_F8 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F8 {66}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F9 Macro

PRL_SCAN_CODE_F9 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F9 {67}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F10 Macro

PRL_SCAN_CODE_F10 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F10 {68}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F11 Macro

PRL_SCAN_CODE_F11 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F11 {87}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_F12 Macro

PRL_SCAN_CODE_F12 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_F12 {88}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_G Macro

PRL_SCAN_CODE_G Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_G {34}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_GREATER Macro

PRL_SCAN_CODE_GREATER Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_GREATER {52}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_H Macro

PRL_SCAN_CODE_H Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_H {35}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_I Macro

PRL_SCAN_CODE_I Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_I {23}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_INSERT Macro

PRL_SCAN_CODE_INSERT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_INSERT {224, 82}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_J Macro

PRL_SCAN_CODE_J Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_J {36}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_K Macro

PRL_SCAN_CODE_K Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_K {37}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_L Macro

PRL_SCAN_CODE_L Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_L {38}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_LEFT Macro

PRL_SCAN_CODE_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_LEFT {224, 75}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_LESS Macro

PRL_SCAN_CODE_LESS Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_LESS {51}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_M Macro

PRL_SCAN_CODE_M Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_M {50}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MENU Macro

PRL_SCAN_CODE_MENU Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_MENU {224, 93}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_MINUS Macro

PRL_SCAN_CODE_MINUS Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_MINUS {12}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_N Macro

PRL_SCAN_CODE_N Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_N {49}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_NUM_LOCK Macro

PRL_SCAN_CODE_NUM_LOCK Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_NUM_LOCK {69}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_O Macro

PRL_SCAN_CODE_O Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_O {24}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_P Macro

PRL_SCAN_CODE_P Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_P {25}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_0 Macro

PRL_SCAN_CODE_PAD_0 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_0 {82}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_1 Macro

PRL_SCAN_CODE_PAD_1 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_1 {79}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_2 Macro

PRL_SCAN_CODE_PAD_2 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_2 {80}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_3 Macro

PRL_SCAN_CODE_PAD_3 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_3 {81}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_4 Macro

PRL_SCAN_CODE_PAD_4 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_4 {75}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_5 Macro

PRL_SCAN_CODE_PAD_5 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_5 {76}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_6 Macro

PRL_SCAN_CODE_PAD_6 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_6 {77}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_7 Macro

PRL_SCAN_CODE_PAD_7 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_7 {71}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_8 Macro

PRL_SCAN_CODE_PAD_8 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_8 {72}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_9 Macro

PRL_SCAN_CODE_PAD_9 Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_9 {73}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_DEL Macro

PRL_SCAN_CODE_PAD_DEL Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_DEL {83}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_ENTER Macro

PRL_SCAN_CODE_PAD_ENTER Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_ENTER {224, 28}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_MINUS Macro

PRL_SCAN_CODE_PAD_MINUS Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_MINUS {74}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_PLUS Macro

PRL_SCAN_CODE_PAD_PLUS Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_PLUS {78}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_SLASH Macro

PRL_SCAN_CODE_PAD_SLASH Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_SLASH {224, 53}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAD_STAR Macro

PRL_SCAN_CODE_PAD_STAR Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAD_STAR {55}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PAUSE_BREAK Macro

PRL_SCAN_CODE_PAUSE_BREAK Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PAUSE_BREAK {225, 29, 69, 225, 157, 197}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PLUS Macro

PRL_SCAN_CODE_PLUS Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PLUS {13}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_PRINT_SCREEN Macro

PRL_SCAN_CODE_PRINT_SCREEN Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_PRINT_SCREEN {224, 42, 224, 55}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Q Macro

PRL_SCAN_CODE_Q Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_Q {16}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_QUOTE Macro

PRL_SCAN_CODE_QUOTE Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_QUOTE {40}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_R Macro

PRL_SCAN_CODE_R Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_R {19}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_RIGHT Macro

PRL_SCAN_CODE_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_RIGHT {224, 77}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_S Macro

PRL_SCAN_CODE_S Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_S {31}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SCROLL_LOCK Macro

PRL_SCAN_CODE_SCROLL_LOCK Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_SCROLL_LOCK {224, 82}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SHIFT_LEFT Macro

PRL_SCAN_CODE_SHIFT_LEFT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_SHIFT_LEFT {42}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SHIFT_RIGHT Macro

PRL_SCAN_CODE_SHIFT_RIGHT Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_SHIFT_RIGHT {54}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SLASH Macro

PRL_SCAN_CODE_SLASH Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_SLASH {53}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_SPACE Macro

PRL_SCAN_CODE_SPACE Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_SPACE {57}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_T Macro

PRL_SCAN_CODE_T Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_T {20}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_TAB Macro

PRL_SCAN_CODE_TAB Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_TAB {15}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_TILDA Macro

PRL_SCAN_CODE_TILDA Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_TILDA {41}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_U Macro

PRL_SCAN_CODE_U Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_U {22}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_UP Macro

PRL_SCAN_CODE_UP Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_UP {224, 72}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_V Macro

PRL_SCAN_CODE_V Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_V {47}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_W Macro

PRL_SCAN_CODE_W Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_W {17}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_X Macro

PRL_SCAN_CODE_X Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_X {45}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Y Macro

PRL_SCAN_CODE_Y Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_Y {21}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SCAN_CODE_Z Macro

PRL_SCAN_CODE_Z Macro
PrlKeys.h PRL_SCAN_CODE Macros Send Feedback
Syntax
#define PRL_SCAN_CODE_Z {44}
File

PrlKeys.h

Links
PrlKeys.h, PRL_SCAN_CODE Macros


PRL_SECURITY_LEVEL Enumeration

PRL_SECURITY_LEVEL Enumeration
PrlEnums.h Other Structs Send Feedback

Security level enumeration.

Syntax
typedef enum _PRL_SECURITY_LEVEL {
  PSL_LOW_SECURITY = 0,
  PSL_NORMAL_SECURITY = 1,
  PSL_HIGH_SECURITY = 2
} PRL_SECURITY_LEVEL;
File

PrlEnums.h

Type Parameters

PSL_LOW_SECURITY
Plain TCP/IP (no encryption).
PSL_NORMAL_SECURITY
Most important data is sent and received using SSL over TCP/IP (user credentials during login, guest OS clipboard, etc.) Other data is sent and receive using plain TCP/IP with no encryption.
PSL_HIGH_SECURITY
All of the data is sent and received using SSL.

Remarks

Defines levels of security that can be used in client/server communications.

Links
PrlEnums.h, Other Structs


PRL_SECURITY_LEVEL_PTR Type

PRL_SECURITY_LEVEL_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_SECURITY_LEVEL* PRL_SECURITY_LEVEL_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration

PRL_SERIAL_PORT_SOCKET_OPERATION_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

Serial port operation mode when on socket

Syntax
typedef enum _PRL_SERIAL_PORT_SOCKET_OPERATION_MODE {
  PSP_SERIAL_SOCKET_SERVER = 0,
  PSP_SERIAL_SOCKET_CLIENT = 1
} PRL_SERIAL_PORT_SOCKET_OPERATION_MODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR Type

PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_SERIAL_PORT_SOCKET_OPERATION_MODE* PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_SERVICE_STATUS_ENUM Enumeration

PRL_SERVICE_STATUS_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels service statuses

Syntax
typedef enum _PRL_SERVICE_STATUS_ENUM {
  PSS_STARTED = 0,
  PSS_STOPPED = 1,
  PSS_NOT_INSTALLED = 2,
  PSS_UNKNOWN
} PRL_SERVICE_STATUS_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_SERVICE_STATUS_ENUM_PTR Type

PRL_SERVICE_STATUS_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_SERVICE_STATUS_ENUM* PRL_SERVICE_STATUS_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_SIZE Type

PRL_SIZE Type
PrlTypes.h Other Types Send Feedback

Unsigned integer type of the result of the sizeof operator

Syntax
typedef unsigned int PRL_SIZE;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_SIZE_PTR Type

PRL_SIZE_PTR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_SIZE* PRL_SIZE_PTR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_SIZE_PTR_PTR Type

PRL_SIZE_PTR_PTR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_SIZE_PTR* PRL_SIZE_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_SNAPSHOT_ELEMENT Structure

PRL_SNAPSHOT_ELEMENT Structure
PrlDisk.h Other Structs Send Feedback

Parallels snapshot tree element

Syntax
typedef struct __PRL_SNAPSHOT_ELEMENT {
  PRL_GUID m_GUID;
  struct __PRL_SNAPSHOT_ELEMENT* m_pNext;
  struct __PRL_SNAPSHOT_ELEMENT* m_pChild;
} PRL_SNAPSHOT_ELEMENT;
File

PrlDisk.h

Links
PrlDisk.h, Other Structs


PRL_SNAPSHOT_ELEMENT_PTR Type

PRL_SNAPSHOT_ELEMENT_PTR Type
PrlDisk.h Other Types Send Feedback
Syntax
typedef PRL_SNAPSHOT_ELEMENT* PRL_SNAPSHOT_ELEMENT_PTR;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_SRV_METHOD_DECL Macro

PRL_SRV_METHOD_DECL Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_SRV_METHOD_DECL( version, name, args ) \
    PRL_METHOD( name ) args;    \
    typedef PRL_METHOD_PTR( name##_Ptr ) args;
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_STATE_CALLBACK_INVALID Macro

PRL_STATE_CALLBACK_INVALID Macro
PrlDisk.h Other Macros Send Feedback

Invalid callback

Syntax
#define PRL_STATE_CALLBACK_INVALID 0x1005
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK Macro

PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK Macro
PrlDisk.h Other Macros Send Feedback

Core callback completed

Syntax
#define PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK 0x1001
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_CORE_FULL_COMPLETE_CALLBACK Macro

PRL_STATE_CORE_FULL_COMPLETE_CALLBACK Macro
PrlDisk.h Other Macros Send Feedback

Operation fully completed

Syntax
#define PRL_STATE_CORE_FULL_COMPLETE_CALLBACK 0x1002
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK Macro

PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK Macro
PrlDisk.h Other Macros Send Feedback

Disk operation started

Syntax
#define PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK 0x1003
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_DISK_CALLBACK Macro

PRL_STATE_DISK_CALLBACK Macro
PrlDisk.h Other Macros Send Feedback

Ordinary callback that disk process going.

Syntax
#define PRL_STATE_DISK_CALLBACK 0x1000
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_DISK_CALLBACK_STAGE_CPL Macro

PRL_STATE_DISK_CALLBACK_STAGE_CPL Macro
PrlDisk.h Other Macros Send Feedback

At remove all states this callback indicates that one more stage complete in states removal

Syntax
#define PRL_STATE_DISK_CALLBACK_STAGE_CPL 0x1004
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_PROGRESS_COMPLETED Macro

PRL_STATE_PROGRESS_COMPLETED Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_STATE_PROGRESS_COMPLETED 1005
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_PROGRESS_MAX Macro

PRL_STATE_PROGRESS_MAX Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_STATE_PROGRESS_MAX 1000
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATE_PROGRESS_MIN Macro

PRL_STATE_PROGRESS_MIN Macro
PrlDisk.h Other Macros Send Feedback

States progress definition

Syntax
#define PRL_STATE_PROGRESS_MIN 0
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_STATES_CALLBACK_TYPE Type

PRL_STATES_CALLBACK_TYPE Type
PrlDisk.h Other Types Send Feedback

Saved states callback types

@author antonz@

Syntax
typedef PRL_INT32 PRL_STATES_CALLBACK_TYPE;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_STATES_CALLBACK_TYPE_PTR Type

PRL_STATES_CALLBACK_TYPE_PTR Type
PrlDisk.h Other Types Send Feedback
Syntax
typedef PRL_STATES_CALLBACK_TYPE* PRL_STATES_CALLBACK_TYPE_PTR;
File

PrlDisk.h

Links
PrlDisk.h, Other Types


PRL_STR Type

PRL_STR Type
PrlTypes.h Other Types Send Feedback
Syntax
typedef PRL_CHAR_PTR PRL_STR;
File

PrlTypes.h

Links
PrlTypes.h, Other Types


PRL_STRUCT Macro

PRL_STRUCT Macro
PrlTypes.h Other Macros Send Feedback

Default structure definition

Syntax
#define PRL_STRUCT( struct_name ) struct_name
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_SUCCEEDED Macro

PRL_SUCCEEDED Macro
PrlErrors.h Other Macros Send Feedback

Success and failure result codes

Syntax
#define PRL_SUCCEEDED( err ) ( ( PRL_RESULT )( err ) >= 0 )
File

PrlErrors.h

Links
PrlErrors.h, Other Macros


PRL_TIS_INT_VERSION Structure

PRL_TIS_INT_VERSION Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
Syntax
typedef struct _PRL_TIS_INT_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
} PRL_TIS_INT_VERSION;
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


PRL_TIS_INT_VERSION_PTR Type

PRL_TIS_INT_VERSION_PTR Type
PrlIoStructs.h PRL_TIS Types Send Feedback
Syntax
typedef PRL_TIS_INT_VERSION* PRL_TIS_INT_VERSION_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_TIS Types


PRL_TIS_RECORD_ACTION Enumeration

PRL_TIS_RECORD_ACTION Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Information Service record actions

Syntax
typedef enum _PRL_TIS_RECORD_ACTION {
  PTIS_RECORD_CHANGED = 1,
  PTIS_RECORD_REMOVED = 2
} PRL_TIS_RECORD_ACTION;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_TIS_RECORD_ACTION_PTR Type

PRL_TIS_RECORD_ACTION_PTR Type
PrlEnums.h PRL_TIS Types Send Feedback
Syntax
typedef PRL_TIS_RECORD_ACTION* PRL_TIS_RECORD_ACTION_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_TIS Types


PRL_TIS_RECORD_INFO Structure

PRL_TIS_RECORD_INFO Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
Syntax
typedef struct _PRL_TIS_RECORD_INFO {
  PRL_TIS_VERSION version;
  PRL_TIS_INT_VERSION intVersion;
} PRL_TIS_RECORD_INFO;
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


PRL_TIS_RECORD_INFO_PTR Type

PRL_TIS_RECORD_INFO_PTR Type
PrlIoStructs.h PRL_TIS Types Send Feedback
Syntax
typedef PRL_TIS_RECORD_INFO* PRL_TIS_RECORD_INFO_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_TIS Types


PRL_TIS_RECORD_STATE Enumeration

PRL_TIS_RECORD_STATE Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Information Service record states

Syntax
typedef enum _PRL_TIS_RECORD_STATE {
  PTIS_RECORD_EMPTY = 0,
  PTIS_RECORD_ACTIVE = 1,
  PTIS_RECORD_CANCELED = 2
} PRL_TIS_RECORD_STATE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_TIS_RECORD_STATE_PTR Type

PRL_TIS_RECORD_STATE_PTR Type
PrlEnums.h PRL_TIS Types Send Feedback
Syntax
typedef PRL_TIS_RECORD_STATE* PRL_TIS_RECORD_STATE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_TIS Types


PRL_TIS_VERSION Structure

PRL_TIS_VERSION Structure
PrlIoStructs.h Other Structs Send Feedback

@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
Syntax
typedef struct _PRL_TIS_VERSION {
  PRL_UINT32 maj;
  PRL_UINT32 min;
  PRL_UINT32 bld;
  PRL_UINT32 rev;
} PRL_TIS_VERSION;
File

PrlIoStructs.h

Links
PrlIoStructs.h, Other Structs


PRL_TIS_VERSION_PTR Type

PRL_TIS_VERSION_PTR Type
PrlIoStructs.h PRL_TIS Types Send Feedback
Syntax
typedef PRL_TIS_VERSION* PRL_TIS_VERSION_PTR;
File

PrlIoStructs.h

Links
PrlIoStructs.h, PRL_TIS Types


PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration

PRL_TOOLS_SIA_OPEN_IN_TYPES Enumeration
PrlEnums.h Other Structs Send Feedback

Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;

Syntax
typedef enum _PRL_TOOLS_SIA_OPEN_IN_TYPES {
  PSIA_OPEN_DEFAULT = 0,
  PSIA_OPEN_IN_GUEST = 1,
  PSIA_OPEN_IN_HOST = 2
} PRL_TOOLS_SIA_OPEN_IN_TYPES;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR Type

PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR Type
PrlEnums.h PRL_TOOLS Types Send Feedback
Syntax
typedef PRL_TOOLS_SIA_OPEN_IN_TYPES* PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_TOOLS Types


PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration

PRL_TOOLS_UTILITY_COMMAND_FLAG Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Utility command flags

Syntax
typedef enum _PRL_TOOLS_UTILITY_COMMAND_FLAG {
  PTU_FLG_ZERO = (1 << 0)
} PRL_TOOLS_UTILITY_COMMAND_FLAG;
File

PrlEnums.h

Members

PTU_FLG_ZERO
@brief Flag is useless now, but placed here to show how and where it must be

Links
PrlEnums.h, Other Structs


PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR Type

PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR Type
PrlEnums.h PRL_TOOLS Types Send Feedback
Syntax
typedef PRL_TOOLS_UTILITY_COMMAND_FLAG* PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_TOOLS Types


PRL_TOOLS_UTILITY_COMMAND_ID Enumeration

PRL_TOOLS_UTILITY_COMMAND_ID Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels Tools Utility commands identifiers

Syntax
typedef enum _PRL_TOOLS_UTILITY_COMMAND_ID {
  PTU_CMD_INVALID = 0,
  PTU_CMD_PTU_ALIVE = 1
} PRL_TOOLS_UTILITY_COMMAND_ID;
File

PrlEnums.h

Members

PTU_CMD_INVALID
brief Identifier of invalid command
PTU_CMD_PTU_ALIVE
@brief Can be sent to indicate that Parallels Tools Utility subsystem is alive and ready to work

Links
PrlEnums.h, Other Structs


PRL_TOOLS_UTILITY_COMMAND_ID_PTR Type

PRL_TOOLS_UTILITY_COMMAND_ID_PTR Type
PrlEnums.h PRL_TOOLS Types Send Feedback
Syntax
typedef PRL_TOOLS_UTILITY_COMMAND_ID* PRL_TOOLS_UTILITY_COMMAND_ID_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_TOOLS Types


PRL_TRUE Macro

PRL_TRUE Macro
PrlTypes.h Other Macros Send Feedback
Syntax
#define PRL_TRUE (1)
File

PrlTypes.h

Links
PrlTypes.h, Other Macros


PRL_UINT8 Type

PRL_UINT8 Type
PrlTypes.h PRL_UINT Types Send Feedback

Unsigned 8 bit integer value

Syntax
typedef unsigned char PRL_UINT8;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT8_PTR Type

PRL_UINT8_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT8* PRL_UINT8_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT8_PTR_PTR Type

PRL_UINT8_PTR_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT8** PRL_UINT8_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT16 Type

PRL_UINT16 Type
PrlTypes.h PRL_UINT Types Send Feedback

Unsigned 16 bit integer value

Syntax
typedef unsigned short PRL_UINT16;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT16_PTR Type

PRL_UINT16_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT16* PRL_UINT16_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT16_PTR_PTR Type

PRL_UINT16_PTR_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT16** PRL_UINT16_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT32 Type

PRL_UINT32 Type
PrlTypes.h PRL_UINT Types Send Feedback

Unsigned 32 bit integer value

Syntax
typedef unsigned int PRL_UINT32;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT32_PTR Type

PRL_UINT32_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT32* PRL_UINT32_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT32_PTR_PTR Type

PRL_UINT32_PTR_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT32** PRL_UINT32_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT64 Type

PRL_UINT64 Type
PrlTypes.h PRL_UINT Types Send Feedback

Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use

Syntax
typedef unsigned long long PRL_UINT64;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT64_PTR Type

PRL_UINT64_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT64* PRL_UINT64_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UINT64_PTR_PTR Type

PRL_UINT64_PTR_PTR Type
PrlTypes.h PRL_UINT Types Send Feedback
Syntax
typedef PRL_UINT64** PRL_UINT64_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_UINT Types


PRL_UNDO_DISKS_MODE Enumeration

PRL_UNDO_DISKS_MODE Enumeration
PrlEnums.h Other Structs Send Feedback

VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied

Syntax
typedef enum _PRL_UNDO_DISKS_MODE {
  PUD_DISABLE_UNDO_DISKS = 0,
  PUD_REVERSE_CHANGES = 1,
  PUD_COMMIT_CHANGES = 2,
  PUD_PROMPT_BEHAVIOUR = 3
} PRL_UNDO_DISKS_MODE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_UNDO_DISKS_MODE_PTR Type

PRL_UNDO_DISKS_MODE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_UNDO_DISKS_MODE* PRL_UNDO_DISKS_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration

PRL_USB_DEVICE_AUTO_CONNECT_OPTION Enumeration
PrlEnums.h Other Structs Send Feedback

USB autoconnect devices options

Syntax
typedef enum _PRL_USB_DEVICE_AUTO_CONNECT_OPTION {
  PUD_CONNECT_TO_PRIMARY_OS = 0,
  PUD_CONNECT_TO_GUEST_OS = 1,
  PUD_ASK_USER_WHAT_TODO = 2
} PRL_USB_DEVICE_AUTO_CONNECT_OPTION;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR Type

PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_USB_DEVICE_AUTO_CONNECT_OPTION* PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_USB_DEVICE_CONNECT_REASON Enumeration

PRL_USB_DEVICE_CONNECT_REASON Enumeration
PrlEnums.h Other Structs Send Feedback

USB device connect/disconnect reason

Syntax
typedef enum _PRL_USB_DEVICE_CONNECT_REASON {
  PUD_CONNECTED_MANUALLY = 0,
  PUD_CONNECTED_AUTOMATICALLY = 1
} PRL_USB_DEVICE_CONNECT_REASON;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_USB_DEVICE_CONNECT_REASON_PTR Type

PRL_USB_DEVICE_CONNECT_REASON_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_USB_DEVICE_CONNECT_REASON* PRL_USB_DEVICE_CONNECT_REASON_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_VERSION_ENUM Enumeration

PRL_VERSION_ENUM Enumeration
PrlEnums.h Other Structs Send Feedback

Parallels license versions enumeration.

Syntax
typedef enum _PRL_VERSION_ENUM {
  PRL_VERSION_ANY = 0,
  PRL_VERSION_3X = 1,
  PRL_VERSION_4X = 2
} PRL_VERSION_ENUM;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_VERSION_ENUM_PTR Type

PRL_VERSION_ENUM_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_VERSION_ENUM* PRL_VERSION_ENUM_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_VM_ACCELERATION_LEVEL Enumeration

PRL_VM_ACCELERATION_LEVEL Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Acceleration level

Syntax
typedef enum _PRL_VM_ACCELERATION_LEVEL {
  PVA_ACCELERATION_DISABLED = 0,
  PVA_ACCELERATION_NORMAL = 1,
  PVA_ACCELERATION_HIGH = 2
} PRL_VM_ACCELERATION_LEVEL;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_ACCELERATION_LEVEL_PTR Type

PRL_VM_ACCELERATION_LEVEL_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_ACCELERATION_LEVEL* PRL_VM_ACCELERATION_LEVEL_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_ACCESS_FOR_OTHERS Enumeration

PRL_VM_ACCESS_FOR_OTHERS Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Specifies virtual machine access rights.

Syntax
typedef enum _PRL_VM_ACCESS_FOR_OTHERS {
  PAO_VM_NOT_SHARED = 0,
  PAO_VM_SHARED_ON_VIEW,
  PAO_VM_SHARED_ON_VIEW_AND_RUN,
  PAO_VM_SHARED_ON_FULL_ACCESS
} PRL_VM_ACCESS_FOR_OTHERS;
File

PrlEnums.h

Type Parameters

PAO_VM_NOT_SHARED
Only the owner of the virtual machine has access to it. The machine will be hidden from all other users.
PAO_VM_SHARED_ON_VIEW
Other users can see the machine but they cannot run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_VIEW_AND_RUN
Other users can see the machine and they can also run it. Other access rights can be determined using methods from the PHT_ACCESS_RIGHTS object.
PAO_VM_SHARED_ON_FULL_ACCESS
Other users have full access to the virtual machine.

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_ACCESS_FOR_OTHERS_PTR Type

PRL_VM_ACCESS_FOR_OTHERS_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_ACCESS_FOR_OTHERS* PRL_VM_ACCESS_FOR_OTHERS_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration

PRL_VM_ACTION_ON_WINDOW_CLOSE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Action on VM when VM window gets closed

Syntax
typedef enum _PRL_VM_ACTION_ON_WINDOW_CLOSE {
  PWC_VM_STOP = 0,
  PWC_VM_SUSPEND = 1,
  PWC_VM_ASK_USER = 2,
  PWC_VM_PAUSE = 3,
  PWC_VM_SHUTDOWN = 4,
  PWC_VM_DO_NOTHING = 5
} PRL_VM_ACTION_ON_WINDOW_CLOSE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR Type

PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_ACTION_ON_WINDOW_CLOSE* PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_AUTOSTART_OPTION Enumeration

PRL_VM_AUTOSTART_OPTION Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM autostart options

Syntax
typedef enum _PRL_VM_AUTOSTART_OPTION {
  PAO_VM_START_MANUAL = 0,
  PAO_VM_START_ON_LOAD = 1,
  PAO_VM_START_ON_RELOAD = 2
} PRL_VM_AUTOSTART_OPTION;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_AUTOSTART_OPTION_PTR Type

PRL_VM_AUTOSTART_OPTION_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_AUTOSTART_OPTION* PRL_VM_AUTOSTART_OPTION_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_AUTOSTOP_OPTION Enumeration

PRL_VM_AUTOSTOP_OPTION Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM autostop options

Syntax
typedef enum _PRL_VM_AUTOSTOP_OPTION {
  PAO_VM_STOP = 0,
  PAO_VM_SUSPEND = 1,
  PAO_VM_SHUTDOWN = 2
} PRL_VM_AUTOSTOP_OPTION;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_AUTOSTOP_OPTION_PTR Type

PRL_VM_AUTOSTOP_OPTION_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_AUTOSTOP_OPTION* PRL_VM_AUTOSTOP_OPTION_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_BOOT_ORDER Enumeration

PRL_VM_BOOT_ORDER Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM boot order

Syntax
typedef enum _PRL_VM_BOOT_ORDER {
  PBO_HDD_CD_FLOPPY = 0,
  PBO_FLOPPY_HDD_CD = 1,
  PBO_CD_HDD_FLOPPY = 2
} PRL_VM_BOOT_ORDER;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_BOOT_ORDER_PTR Type

PRL_VM_BOOT_ORDER_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_BOOT_ORDER* PRL_VM_BOOT_ORDER_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_CONFIG_SECTIONS Enumeration

PRL_VM_CONFIG_SECTIONS Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM configuration sections

Syntax
typedef enum _PRL_VM_CONFIG_SECTIONS {
  PVC_ALL = 1,
  PVC_GENERAL_PARAMETERS,
  PVC_BOOT_OPTION,
  PVC_REMOTE_DISPLAY,
  PVC_SHARED_FOLDERS,
  PVC_CPU,
  PVC_MAIN_MEMORY,
  PVC_VIDEO_MEMORY,
  PVC_FLOPPY_DISK,
  PVC_CD_DVD_ROM,
  PVC_HARD_DISK,
  PVC_NETWORK_ADAPTER,
  PVC_SOUND,
  PVC_SERIAL_PORT,
  PVC_PARALLEL_PORT,
  PVC_IDE_DEVICES,
  PVC_SCSI_DEVICES,
  PVC_GENERIC_PCI,
  PVC_LAST_SECTION = PVC_GENERIC_PCI
} PRL_VM_CONFIG_SECTIONS;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_CONFIG_SECTIONS_PTR Type

PRL_VM_CONFIG_SECTIONS_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_CONFIG_SECTIONS* PRL_VM_CONFIG_SECTIONS_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_DEV_EMULATION_TYPE Enumeration

PRL_VM_DEV_EMULATION_TYPE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM device emulation type

Syntax
typedef enum _PRL_VM_DEV_EMULATION_TYPE {
  PDT_ANY_TYPE = 0xffff,
  PDT_USE_REAL_DEVICE = 0,
  PDT_USE_IMAGE_FILE = 1,
  PDT_USE_OUTPUT_FILE = 2,
  PDT_USE_OTHER = 3,
  PDT_USE_REAL_FLOPPY = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_HDD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_CDDVD = PDT_USE_REAL_DEVICE,
  PDT_USE_REAL_SERIAL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_SERIAL_PORT_SOCKET_MODE = PDT_USE_OTHER,
  PDT_USE_REAL_PARALLEL_PORT = PDT_USE_REAL_DEVICE,
  PDT_USE_PARALLEL_PORT_PRINTER_MODE = PDT_USE_OTHER,
  PDT_USE_HOST_ONLY_NETWORK = PDT_USE_REAL_DEVICE,
  PDT_USE_SHARED_NETWORK = PDT_USE_IMAGE_FILE,
  PDT_USE_BRIDGE_ETHERNET = PDT_USE_OUTPUT_FILE,
  PDT_USE_AC97_SOUND = PDT_USE_REAL_DEVICE,
  PDT_USE_CREATIVE_SB16_SOUND = PDT_USE_IMAGE_FILE,
  PDT_USE_REAL_USB_CONTROLLER = PDT_USE_REAL_DEVICE,
  PDT_USE_BOOTCAMP = PDT_USE_OTHER
} PRL_VM_DEV_EMULATION_TYPE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_DEV_EMULATION_TYPE_PTR Type

PRL_VM_DEV_EMULATION_TYPE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_DEV_EMULATION_TYPE* PRL_VM_DEV_EMULATION_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration

PRL_VM_EXEC_APP_FILE_DESCRIPTOR Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app

Syntax
typedef enum _PRL_VM_EXEC_APP_FILE_DESCRIPTOR {
  PFD_STDOUT = (1 << 0),
  PFD_STDERR = (1 << 1),
  PFD_ALL = (PFD_STDOUT | PFD_STDERR)
} PRL_VM_EXEC_APP_FILE_DESCRIPTOR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR Type

PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_EXEC_APP_FILE_DESCRIPTOR* PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration

PRL_VM_EXEC_RUN_PROGRAM_MODES Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result

Syntax
typedef enum _PRL_VM_EXEC_RUN_PROGRAM_MODES {
  PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY = (1 << 2)
} PRL_VM_EXEC_RUN_PROGRAM_MODES;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR Type

PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_EXEC_RUN_PROGRAM_MODES* PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_MIGRATION_SECURITY_LEVEL Enumeration

PRL_VM_MIGRATION_SECURITY_LEVEL Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM migration security level - specifies security level of VM migration connection

Syntax
typedef enum _PRL_VM_MIGRATION_SECURITY_LEVEL {
  PVMSL_LOW_SECURITY = 0,
  PVMSL_NORMAL_SECURITY = 1<<3,
  PVMSL_HIGH_SECURITY = 1<<4
} PRL_VM_MIGRATION_SECURITY_LEVEL;
File

PrlEnums.h

Type Parameters

PVMSL_LOW_SECURITY
flag matches to PSL_LOW_SECURITY connection type.
PVMSL_NORMAL_SECURITY
flag matches to PSL_NORMAL_SECURITY connection type.
PVMSL_HIGH_SECURITY
flag matches to PSL_HIGH_SECURITY connection type.

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_MIGRATION_SECURITY_LEVEL_PTR Type

PRL_VM_MIGRATION_SECURITY_LEVEL_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_MIGRATION_SECURITY_LEVEL* PRL_VM_MIGRATION_SECURITY_LEVEL_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_MIGRATION_TYPE Enumeration

PRL_VM_MIGRATION_TYPE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM migration type - specifies method of VM migration

Syntax
typedef enum _PRL_VM_MIGRATION_TYPE {
  PVMT_COLD_MIGRATION = 1<<0,
  PVMT_WARM_MIGRATION = 1<<1,
  PVMT_HOT_MIGRATION = 1<<2
} PRL_VM_MIGRATION_TYPE;
File

PrlEnums.h

Type Parameters

PVM_COLD_MIGRATION
VM migration with interruption of VM services (VM will be stopped on migration time).
PVM_WARM_MIGRATION
VM services will have quite long downtime during migration but won't be interrupted.
PVM_HOT_MIGRATION
VM services will have short downtime during migration without any interruption.

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_MIGRATION_TYPE_PTR Type

PRL_VM_MIGRATION_TYPE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_MIGRATION_TYPE* PRL_VM_MIGRATION_TYPE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_PRIORITY Enumeration

PRL_VM_PRIORITY Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Background/foreground VM processes priority

Syntax
typedef enum _PRL_VM_PRIORITY {
  PVR_PRIORITY_LOW = 0,
  PVR_PRIORITY_NORMAL = 1,
  PVR_PRIORITY_HIGH = 2
} PRL_VM_PRIORITY;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_PRIORITY_PTR Type

PRL_VM_PRIORITY_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_PRIORITY* PRL_VM_PRIORITY_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_REMOTE_DISPLAY_MODE Enumeration

PRL_VM_REMOTE_DISPLAY_MODE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Parallels remote desktop modes

Syntax
typedef enum _PRL_VM_REMOTE_DISPLAY_MODE {
  PRD_DISABLED = 0,
  PRD_AUTO,
  PRD_MANUAL
} PRL_VM_REMOTE_DISPLAY_MODE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_REMOTE_DISPLAY_MODE_PTR Type

PRL_VM_REMOTE_DISPLAY_MODE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_REMOTE_DISPLAY_MODE* PRL_VM_REMOTE_DISPLAY_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_START_LOGIN_MODE Enumeration

PRL_VM_START_LOGIN_MODE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM start login mode

Syntax
typedef enum _PRL_VM_START_LOGIN_MODE {
  PLM_START_ACOUNT = 0,
  PLM_ROOT_ACOUNT = 1,
  PLM_USER_ACOUNT = 2
} PRL_VM_START_LOGIN_MODE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_START_LOGIN_MODE_PTR Type

PRL_VM_START_LOGIN_MODE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_START_LOGIN_MODE* PRL_VM_START_LOGIN_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_START_MODE Enumeration

PRL_VM_START_MODE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode

Syntax
typedef enum _PRL_VM_START_MODE {
  PSM_VM_START = (1 << 0),
  PSM_VM_SAFE_START = (1 << 1),
  PSM_VM_START_LAST_ITEM = PSM_VM_SAFE_START
} PRL_VM_START_MODE;
File

PrlEnums.h

Members

PSM_VM_START_LAST_ITEM
PSM_VM_START_LAST_ITEM has to be equal the last mode

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_START_MODE_PTR Type

PRL_VM_START_MODE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_START_MODE* PRL_VM_START_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_TOOLS_STATE Enumeration

PRL_VM_TOOLS_STATE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

Virtual machine tools states enumeration

Syntax
typedef enum _PRL_VM_TOOLS_STATE {
  PTS_UNKNOWN = 0x0,
  PTS_POSSIBLY_INSTALLED = PTS_UNKNOWN,
  PTS_NOT_INSTALLED = 0x1,
  PTS_INSTALLED = 0x2,
  PTS_OUTDATED = 0x3
} PRL_VM_TOOLS_STATE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_TOOLS_STATE_PTR Type

PRL_VM_TOOLS_STATE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_TOOLS_STATE* PRL_VM_TOOLS_STATE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VM_WINDOW_MODE Enumeration

PRL_VM_WINDOW_MODE Enumeration
PrlEnums.h PRL_VM Structs Send Feedback

VM window mode

Syntax
typedef enum _PRL_VM_WINDOW_MODE {
  PWM_DEFAULT_WINDOW_MODE = 0,
  PWM_WINDOWED_WINDOW_MODE = 1,
  PWM_FULL_SCREEN_WINDOW_MODE = 2,
  PWM_COHERENCE_WINDOW_MODE = 3,
  PWM_MODALITY_WINDOW_MODE = 4
} PRL_VM_WINDOW_MODE;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Structs


PRL_VM_WINDOW_MODE_PTR Type

PRL_VM_WINDOW_MODE_PTR Type
PrlEnums.h PRL_VM Types Send Feedback
Syntax
typedef PRL_VM_WINDOW_MODE* PRL_VM_WINDOW_MODE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, PRL_VM Types


PRL_VOID Type

PRL_VOID Type
PrlTypes.h PRL_VOID Types Send Feedback

Void pointers (for unified naming)

Syntax
typedef void PRL_VOID;
File

PrlTypes.h

Links
PrlTypes.h, PRL_VOID Types


PRL_VOID_PTR Type

PRL_VOID_PTR Type
PrlTypes.h PRL_VOID Types Send Feedback
Syntax
typedef PRL_VOID* PRL_VOID_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_VOID Types


PRL_VOID_PTR_PTR Type

PRL_VOID_PTR_PTR Type
PrlTypes.h PRL_VOID Types Send Feedback
Syntax
typedef PRL_VOID_PTR* PRL_VOID_PTR_PTR;
File

PrlTypes.h

Links
PrlTypes.h, PRL_VOID Types


PRL_WARN_COMPACT_DESTRUCTIVE Macro

PRL_WARN_COMPACT_DESTRUCTIVE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_COMPACT_DESTRUCTIVE PRL_RESULT_DECLARE_ERROR(28002)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_COMPACT_THROUGH_COPY Macro

PRL_WARN_COMPACT_THROUGH_COPY Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_COMPACT_THROUGH_COPY PRL_RESULT_DECLARE_ERROR(28001)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_FAILED_TO_START_VNC_SERVER Macro

PRL_WARN_FAILED_TO_START_VNC_SERVER Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_FAILED_TO_START_VNC_SERVER PRL_RESULT_DECLARE_SUCCESS(35006)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_FAT32_FILE_OVERRUN Macro

PRL_WARN_FAT32_FILE_OVERRUN Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_FAT32_FILE_OVERRUN PRL_RESULT_DECLARE_ERROR(267)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro

PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_GOING_TO_TAKE_SMART_GUARD_SNAPSHOT PRL_RESULT_DECLARE_ERROR(446)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_HDD_ERROR Macro

PRL_WARN_HDD_ERROR Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_HDD_ERROR PRL_RESULT_DECLARE_ERROR(268)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_IMAGE_IS_STOLEN Macro

PRL_WARN_IMAGE_IS_STOLEN Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_IMAGE_IS_STOLEN PRL_RESULT_DECLARE_ERROR(264)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_LAN_NOT_CONNECTED Macro

PRL_WARN_LAN_NOT_CONNECTED Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_LAN_NOT_CONNECTED PRL_RESULT_DECLARE_ERROR(261)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_TARGET_HOST_DISK_IS_FULL Macro

PRL_WARN_TARGET_HOST_DISK_IS_FULL Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_TARGET_HOST_DISK_IS_FULL PRL_RESULT_DECLARE_ERROR(265)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_TOO_LOW_HDD_SIZE Macro

PRL_WARN_TOO_LOW_HDD_SIZE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_TOO_LOW_HDD_SIZE PRL_RESULT_DECLARE_ERROR(289)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_UNABLE_OPEN_DEVICE Macro

PRL_WARN_UNABLE_OPEN_DEVICE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_UNABLE_OPEN_DEVICE PRL_RESULT_DECLARE_ERROR(263)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_UNABLE_OPEN_DEVICE_NAME Macro

PRL_WARN_UNABLE_OPEN_DEVICE_NAME Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_UNABLE_OPEN_DEVICE_NAME PRL_RESULT_DECLARE_ERROR(262)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE Macro

PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_UNKNOWN_HDD_REQUEST_TYPE PRL_RESULT_DECLARE_ERROR(266)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_VM_BOOTCAMP_MODE Macro

PRL_WARN_VM_BOOTCAMP_MODE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_VM_BOOTCAMP_MODE PRL_RESULT_DECLARE_ERROR(1004)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV Macro

PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_VM_DVD_DISCONNECT_LOCKED_DEV PRL_RESULT_DECLARE_ERROR(433)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST Macro

PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_VM_DVD_DISCONNECTED_BY_GUEST PRL_RESULT_DECLARE_ERROR(448)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_VM_PD3_COMPAT_MODE Macro

PRL_WARN_VM_PD3_COMPAT_MODE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_VM_PD3_COMPAT_MODE PRL_RESULT_DECLARE_ERROR(1003)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WARN_VM_PD3_COMPAT_NO_MOUSE Macro

PRL_WARN_VM_PD3_COMPAT_NO_MOUSE Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WARN_VM_PD3_COMPAT_NO_MOUSE PRL_RESULT_DECLARE_ERROR(1005)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PRL_WIN_EXTENDED_PARTITION Macro

PRL_WIN_EXTENDED_PARTITION Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_WIN_EXTENDED_PARTITION 0x0F
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_WINDOW_EDGE_MASK Enumeration

PRL_WINDOW_EDGE_MASK Enumeration
PrlEnums.h Other Structs Send Feedback

Edges where taskbar can be placed (in coherence mode).

Syntax
typedef enum _PRL_WINDOW_EDGE_MASK {
  WINDOW_LEFT_EDGE_MASK = (0x1L << 0),
  WINDOW_TOP_EDGE_MASK = (0x1L << 1),
  WINDOW_RIGHT_EDGE_MASK = (0x1L << 2),
  WINDOW_BOTTOM_EDGE_MASK = (0x1L << 3),
  WINDOW_ALL_EDGE_MASK = WINDOW_LEFT_EDGE_MASK|WINDOW_TOP_EDGE_MASK|WINDOW_RIGHT_EDGE_MASK|WINDOW_BOTTOM_EDGE_MASK
} PRL_WINDOW_EDGE_MASK;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


PRL_WINDOW_EDGE_MASK_PTR Type

PRL_WINDOW_EDGE_MASK_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef PRL_WINDOW_EDGE_MASK * PRL_WINDOW_EDGE_MASK_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types


PRL_WINDOWS_PARTITION_FAT Macro

PRL_WINDOWS_PARTITION_FAT Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_WINDOWS_PARTITION_FAT 0x06
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_WINDOWS_PARTITION_FAT32 Macro

PRL_WINDOWS_PARTITION_FAT32 Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_WINDOWS_PARTITION_FAT32 0x0B
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_WINDOWS_PARTITION_FAT32_LBA Macro

PRL_WINDOWS_PARTITION_FAT32_LBA Macro
PrlDisk.h Other Macros Send Feedback
Syntax
#define PRL_WINDOWS_PARTITION_FAT32_LBA 0x0C
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_WINDOWS_PARTITION_NTFS Macro

PRL_WINDOWS_PARTITION_NTFS Macro
PrlDisk.h Other Macros Send Feedback

Windows partitions

Syntax
#define PRL_WINDOWS_PARTITION_NTFS 0x07
File

PrlDisk.h

Links
PrlDisk.h, Other Macros


PRL_WNG_START_VM_ON_MOUNTED_DISK Macro

PRL_WNG_START_VM_ON_MOUNTED_DISK Macro
PrlErrorsValues.h Other Macros Send Feedback
Syntax
#define PRL_WNG_START_VM_ON_MOUNTED_DISK PRL_RESULT_DECLARE_SUCCESS(439)
File

PrlErrorsValues.h

Links
PrlErrorsValues.h, Other Macros


PrlAcl_GetAccessForOthers Function

PrlAcl_GetAccessForOthers Function
PrlApi.h PHT_ACCESS_RIGHTS See Also Send Feedback

Obtains the virtual machine access rights information.

Syntax
PRL_RESULT PrlAcl_GetAccessForOthers(
    PRL_HANDLE hAcl,
    PRL_VM_ACCESS_FOR_OTHERS_PTR pnAccessForOthers
);
File

PrlApi.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
pnAccessForOthers
[out] A pointer to a variable that receives the virtual machine access level information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function determines whether other users besides the owner can view, run, or have full access to a virtual machine.

See Also

PrlAcl_SetAccessForOthers

Links
PrlApi.h, PHT_ACCESS_RIGHTS, See Also


PrlAcl_GetOwnerName Function

PrlAcl_GetOwnerName Function
PrlApi.h PHT_ACCESS_RIGHTS See Also Send Feedback

Determines the virtual machine owner name.

Syntax
PRL_RESULT PrlAcl_GetOwnerName(
    PRL_HANDLE hAcl,
    PRL_STR sOwnerNameBuf,
    PRL_UINT32_PTR pnOwnerNameBufLength
);
File

PrlApi.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
sOwnerNameBuf
[out] A pointer to a buffer that receives the virtual machine owner name (a UTF-8 encoded, null-terminated string).
pnOwnerNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlAcl_IsCurrentSessionOwner

Links
PrlApi.h, PHT_ACCESS_RIGHTS, See Also


PrlAcl_IsAllowed Function

PrlAcl_IsAllowed Function
PrlApi.h PHT_ACCESS_RIGHTS Send Feedback

Determines if the current user is authorized to perform a specified task on a virtual machine.

Syntax
PRL_RESULT PrlAcl_IsAllowed(
    PRL_HANDLE hAcl,
    PRL_ALLOWED_VM_COMMAND nPermission,
    PRL_BOOL_PTR pbAllowed
);
File

PrlApi.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
nPermission
Task type.
pbAllowed
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allowed to perform the task. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_ACCESS_RIGHTS


PrlAcl_IsCurrentSessionOwner Function

PrlAcl_IsCurrentSessionOwner Function
PrlApi.h PHT_ACCESS_RIGHTS Send Feedback

Determines if the current user is the owner of the specified virtual machine.

Syntax
PRL_RESULT PrlAcl_IsCurrentSessionOwner(
    PRL_HANDLE hAcl,
    PRL_BOOL_PTR pbIsOwner
);
File

PrlApi.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
pbIsOwner
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is the owner of the virtual machine. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_ACCESS_RIGHTS


PrlAcl_SetAccessForOthers Function

PrlAcl_SetAccessForOthers Function
PrlApi.h PHT_ACCESS_RIGHTS See Also Send Feedback

Sets access rights on a virtual machine.

Syntax
PRL_RESULT PrlAcl_SetAccessForOthers(
    PRL_HANDLE hAcl,
    PRL_VM_ACCESS_FOR_OTHERS nAccessForOthers
);
File

PrlApi.h

Parameters

hAcl
A handle of type PHT_ACCESS_RIGHTS containing the access rights information for a virtual machine.
nAccessForOthers
The access rights to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The owner of a virtual machine can use this function to grant or deny access rights for the virtual machine to other users. The access rights will be applied to all users. The call will only update the local copy of the PHT_ACCESS_RIGHTS object passed to the function (you will have to properly obtain the object prior to calling this function). To apply the changes to the virtual machine, call the PrlVm_UpdateSecurity function after making this calls and pass the same PHT_ACCESS_RIGHTS handle to it.

See Also

PrlAcl_GetAccessForOthers

Links
PrlApi.h, PHT_ACCESS_RIGHTS, See Also


PrlApi_AddRemoteDevCommandBuffer Function

PrlApi_AddRemoteDevCommandBuffer Function
PrlApi.h System Functions Send Feedback

Adds buffer to the remote command.

Syntax
PRL_RESULT PrlApi_AddRemoteDevCommandBuffer(
    PRL_HANDLE hCommand,
    PRL_VOID_PTR pBuffer,
    PRL_UINT32 size
);
File

PrlApi.h

Parameters

hCommand
_nt_
pBuffer
_nt_
size
_nt_

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was specified PRL_ERR_SUCCESS - operation completed successfully other values could also be returned.

Links
PrlApi.h, System Functions


PrlApi_AddRemoteDevCommandParam Function

PrlApi_AddRemoteDevCommandParam Function
PrlApi.h System Functions Send Feedback

Adds unsigned int parameter to the command.

Syntax
PRL_RESULT PrlApi_AddRemoteDevCommandParam(
    PRL_HANDLE hCommand,
    PRL_UINT32 param
);
File

PrlApi.h

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was specified PRL_ERR_SUCCESS - operation completed successfully other values could also be returned.

Links
PrlApi.h, System Functions


PrlApi_CreateHandlesList Function

PrlApi_CreateHandlesList Function
PrlApi.h System Functions Send Feedback

Creates SDK object represents handles list

Syntax
PRL_RESULT PrlApi_CreateHandlesList(
    PRL_HANDLE_PTR phHandlesList
);
File

PrlApi.h

Parameters

phHandlesList
pointer to buffer for storing result object handle

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid (NULL) pointer to buffer for storing result was passed PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate handles list object PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, System Functions


PrlApi_CreateRemoteCommand Function

PrlApi_CreateRemoteCommand Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_RESULT PrlApi_CreateRemoteCommand(
    PRL_DEVICE_TYPE uTargetType,
    PRL_UINT32 uTargetIndex,
    PRL_UINT16 uCommandCode,
    PRL_VOID_PTR pData,
    PRL_SIZE uDataSize,
    PRL_HANDLE_PTR phCommand
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_CreateRemoteDevCommand Function

PrlApi_CreateRemoteDevCommand Function
PrlApi.h System Functions Send Feedback

Creates command to the remote device.

Syntax
PRL_RESULT PrlApi_CreateRemoteDevCommand(
    PRL_HANDLE hVm,
    PRL_DEVICE_TYPE device_type,
    PRL_UINT32 device_index,
    PRL_HANDLE_PTR phCommand
);
File

PrlApi.h

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was specified PRL_ERR_SUCCESS - operation completed successfully other values could also be returned.

Links
PrlApi.h, System Functions


PrlApi_CreateStringsList Function

PrlApi_CreateStringsList Function
PrlApi.h System Functions Send Feedback

Creates a handle of type PHT_STRINGS_LIST.

Syntax
PRL_RESULT PrlApi_CreateStringsList(
    PRL_HANDLE_PTR phStringsList
);
File

PrlApi.h

Parameters

phStringsList
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, System Functions


PrlApi_Deinit Function

PrlApi_Deinit Function
PrlApi.h System Functions See Also Send Feedback

De-initializes the library.

Syntax
PRL_RESULT PrlApi_Deinit();
File

PrlApi.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_UNINITIALIZED - the library was not initialized.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

Before exiting a client program, this function must be called to perform internal library de-initialization. Internally, this call will lead to the destruction of the internal event-loop and de-initialization of the library state.

See Also

PrlApi_Init

Links
PrlApi.h, System Functions, See Also


PrlApi_GetAppMode Function

PrlApi_GetAppMode Function
PrlApi.h System Functions Send Feedback

Returns the Parallels API application mode.

Syntax
PRL_RESULT PrlApi_GetAppMode(
    PRL_APPLICATION_MODE_PTR app_mode
);
File

PrlApi.h

Parameters

app_mode
[out] Current application mode of the API.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, System Functions


PrlApi_GetMessageType Function

PrlApi_GetMessageType Function
PrlApi.h System Functions Send Feedback

Evaluates the specified error code and returns its classification (warning, question, information, etc.).

Syntax
PRL_RESULT PrlApi_GetMessageType(
    PRL_RESULT nErrCode,
    PRL_MESSAGE_TYPE_ENUM_PTR pnMsgType
);
File

PrlApi.h

Parameters

nErrCode
The error code to evaluate.
pnMsgType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, System Functions


PrlApi_GetRecommendMinVmMem Function

PrlApi_GetRecommendMinVmMem Function
PrlApi.h System Functions Send Feedback

The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.

Syntax
PRL_RESULT PrlApi_GetRecommendMinVmMem(
    PRL_UINT32 nOsVersion,
    PRL_UINT32_PTR pnMinMemSize
);
File

PrlApi.h

Parameters

nOsVersion
OS version
pnMinMemSize
[out] A pointer to a variable that receives the result. Result is the recommend minimal memory size for guest OS.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, System Functions


PrlApi_GetRemoteCommandBuffer Function

PrlApi_GetRemoteCommandBuffer Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_RESULT PrlApi_GetRemoteCommandBuffer(
    PRL_HANDLE hCommand,
    PRL_IO_GENERIC_BUFFER_PTR pBuffer
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_GetRemoteCommandCode Function

PrlApi_GetRemoteCommandCode Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_RESULT PrlApi_GetRemoteCommandCode(
    PRL_HANDLE hCommand,
    PRL_UINT16_PTR pCode
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_GetRemoteCommandIndex Function

PrlApi_GetRemoteCommandIndex Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_RESULT PrlApi_GetRemoteCommandIndex(
    PRL_HANDLE hCommand,
    PRL_UINT32_PTR pIndex
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_GetRemoteCommandTarget Function

PrlApi_GetRemoteCommandTarget Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_RESULT PrlApi_GetRemoteCommandTarget(
    PRL_HANDLE hCommand,
    PRL_DEVICE_TYPE_PTR pType
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_GetRemoteDeviceRegistration Function

PrlApi_GetRemoteDeviceRegistration Function
PrlApi.h System Functions Send Feedback

Obtains current registration of the remote devices of specified type

Syntax
PRL_RESULT PrlApi_GetRemoteDeviceRegistration(
    PRL_DEVICE_TYPE device_type,
    PREMOTE_DEVICE_CREATE_HANDLER* ppCreateHandler,
    PRL_VOID_PTR* pCreateCtx,
    PREMOTE_DEVICE_DESTROY_HANDLER* ppDestroyHandler,
    PREMOTE_DEVICE_COMMAND_HANDLER* ppCommandHandler
);
File

PrlApi.h

Parameters

device_type
[in] Type of the devices to register as capable to be remote
ppCreateHandler
[out] Function that creates remote device instances
pCreateCtx
[out] Context to pass to the REMOTE_DEVICE_CREATE_HANDLER
ppDestroyHandler
[out] Function that destroys device instance
ppCommandHandler
[out] Function that handles commands to the remote device

Returns

PRL_ERR_SUCCESS - parameters were obtained. Other values means error

Links
PrlApi.h, System Functions


PrlApi_GetResultDescription Function

PrlApi_GetResultDescription Function
PrlApi.h System Functions Send Feedback

Evaluates a return code and returns a description of the problem.

Syntax
PRL_RESULT PrlApi_GetResultDescription(
    PRL_RESULT nErrCode,
    PRL_BOOL bIsBriefMessage,
    PRL_BOOL bFormated,
    PRL_STR sErrString,
    PRL_UINT32_PTR pnErrStringBufLength
);
File

PrlApi.h

Parameters

nErrCode
A return code to get the description for.
bIsBriefMessage
Specifies whether to obtain a long or a brief description of the problem. PRL_TRUE specifies to obtain a brief message. PRL_FALSE specifies to obtain a long message.
bFormated
Specifies whether HTML tags used for text formatting should be included in the resulting string.
sErrString
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnErrStringBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
PRL_TRUE
include HTML tags; PRL_FALSE - do not include the tags.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

All synchronous functions in the Parallels API return PRL_RESULT - a numeric return code used to evaluate the success or failure of the operation. If the return code indicates a failure, the PrlApi_GetResultDescription function can be used to obtain the description of the problem.

Links
PrlApi.h, System Functions


PrlApi_GetVersion Function

PrlApi_GetVersion Function
PrlApi.h System Functions Send Feedback

Returns the Parallels API version number.

Syntax
PRL_RESULT PrlApi_GetVersion(
    PRL_UINT32_PTR current_version
);
File

PrlApi.h

Parameters

current_version
[out] Current version of the API.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Version number is incremented each time a public interfaces is changed. Our goal is to achieve full backward compatibility where the changes add new functionality without breaking the existing one.

Links
PrlApi.h, System Functions


PrlApi.h

PrlApi.h
Functions Files Legend Macros Send Feedback

PrlApi.h

This file is the part of parallels public SDK library.

Remarks

Copyright (c) 2005-2008 Parallels Software International, Inc. All rights reserved. http://www.parallels.com

Functions
Name | Description
event_type_to_string | This inline function returns a readable string representation of the specified event type.
handle_type_to_string | This inline function returns a readable string representation of the specified handle type.
prl_result_to_string | This inline function returns a readable string representation of the PRL_RESULT value.
PrlAcl_GetAccessForOthers | Obtains the virtual machine access rights information.
PrlAcl_GetOwnerName | Determines the virtual machine owner name.
PrlAcl_IsAllowed | Determines if the current user is authorized to perform a specified task on a virtual machine.
PrlAcl_IsCurrentSessionOwner | Determines if the current user is the owner of the specified virtual machine.
PrlAcl_SetAccessForOthers | Sets access rights on a virtual machine.
PrlApi_AddRemoteDevCommandBuffer | Adds buffer to the remote command.
PrlApi_AddRemoteDevCommandParam | Adds unsigned int parameter to the command.
PrlApi_CreateHandlesList | Creates SDK object represents handles list
PrlApi_CreateRemoteCommand |
PrlApi_CreateRemoteDevCommand | Creates command to the remote device.
PrlApi_CreateStringsList | Creates a handle of type PHT_STRINGS_LIST.
PrlApi_Deinit | De-initializes the library.
PrlApi_GetAppMode | Returns the Parallels API application mode.
PrlApi_GetMessageType | Evaluates the specified error code and returns its classification (warning, question, information, etc.).
PrlApi_GetRecommendMinVmMem | The PrlApi_GetRecommendMinVmMem returns recommend minimal memory size for guest OS defined in the OS version parameter.
PrlApi_GetRemoteCommandBuffer |
PrlApi_GetRemoteCommandCode |
PrlApi_GetRemoteCommandIndex |
PrlApi_GetRemoteCommandTarget |
PrlApi_GetRemoteDeviceRegistration | Obtains current registration of the remote devices of specified type
PrlApi_GetResultDescription | Evaluates a return code and returns a description of the problem.
PrlApi_GetVersion | Returns the Parallels API version number.
PrlApi_Init | Initializes Parallels API library.
PrlApi_InitEx | This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.
PrlApi_MsgCanBeIgnored | The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.
PrlApi_RegisterRemoteDevice | Registers remote devices of specified type
PrlApi_ScaleImage | The PrlApi_ScaleImage scales image and put a new image to a buffer.
PrlApi_SendRemoteCommand |
PrlApi_SendRemoteDeviceCommand | Sends remote device command to the Virtual Machine.
PrlApi_UnregisterRemoteDevice | Unregisters remote device.
PrlBootDev_GetIndex | Obtains the boot device index.
PrlBootDev_GetSequenceIndex | Obtains the boot device sequence index.
PrlBootDev_GetType | Returns the boot device type.
PrlBootDev_IsInUse | Determines whether the boot device is enabled or disabled.
PrlBootDev_Remove | Removes the boot device from the boot priority list.
PrlBootDev_SetIndex | Sets the boot device index.
PrlBootDev_SetInUse | Enables or disables the boot device.
PrlBootDev_SetSequenceIndex | Assigns a sequence index to a boot device in the boot priority list.
PrlBootDev_SetType | Sets the boot device type.
PrlBuffer_Free | Frees a buffer allocated by the Parallels API library and returned to the client.
PrlDbg_EventTypeToString | Returns a readable string representation of the specified event type.
PrlDbg_GetHandlesNum | The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.
PrlDbg_HandleTypeToString | Returns a readable string representation of the specified handle type.
PrlDbg_PrlResultToString | Returns a readable string representation of the PRL_RESULT value.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.
PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_AsyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_ConnectToVm | Connects to a virtual machine to begin a remote desktop access session.
PrlDevDisplay_DisconnectFromVm | Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.
PrlDevDisplay_GetDynResToolStatus | Determines whether Dynamic Resolution feature is available in the specified virtual machine.
PrlDevDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the primary display.
PrlDevDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevDisplay_IsSlidingMouseEnabled | Determines if Sliding Mouse feature is enabled in the specified virtual machine.
PrlDevDisplay_LockForRead | Locks the primary screen buffer disallowing any updates to the data it contains.
PrlDevDisplay_NeedCursorData | The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.
PrlDevDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.
PrlDevDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.
PrlDevDisplay_SetScreenSurface | Sets CoreGraphics surface for fast server-side display updates.
PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevDisplay_SyncCaptureScreenRegionToFile | Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.
PrlDevDisplay_Unlock | Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.
PrlDevKeyboard_SendKeyEvent | Sends a keyboard key event to a virtual machine.
PrlDevMouse_Move | Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).
PrlDevMouse_SetPos | Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.
PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile | Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.
PrlDevSecondaryDisplay_GetScreenBuffer | Returns the contents of the screen buffer of the secondary display.
PrlDevSecondaryDisplay_GetScreenSize | Returns the primary display screen size of the specified virtual machine.
PrlDevSecondaryDisplay_SendCaptureScreenRequest | Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.
PrlDevSecondaryDisplay_SendScreenSizeEvent | Sends a request to a virtual machine to adjust the screen resolution of the secondary display of the guest OS to specified values.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer | Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.
PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile | Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.
PrlDispCfg_CanChangeDefaultSettings | Determines if new users have the right to modify Parallels Service preferences.
PrlDispCfg_CreateDispNet | Creates a new virtual network adapter object and adds it to the network adapters list.
PrlDispCfg_GetDefaultVmDir | Obtains name and path of the directory in which new virtual machines are created by default.
PrlDispCfg_GetDefaultVNCHostName | Returns the default VNC host name for the Parallels Service.
PrlDispCfg_GetDispNet | Obtains information about a virtual network adapter from the Parallels Service configuration.
PrlDispCfg_GetDispNetCount | Determines the total number of the virtual network adapters in the Parallels Service configuration.
PrlDispCfg_GetMaxReservMemLimit | Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.
PrlDispCfg_GetMaxVmMem | Determines the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_GetMinReservMemLimit | Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.
PrlDispCfg_GetMinSecurityLevel | Determines the lowest allowable security level that can be used to connect to the Parallels Service.
PrlDispCfg_GetMinVmMem | Determines the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_GetRecommendMaxVmMem | Determines the recommended memory size for an individual virtual machine.
PrlDispCfg_GetReservedMemLimit | Determines the amount of physical memory reserved for Parallels Service operation.
PrlDispCfg_GetVNCBasePort | Obtains the currently set base VNC port number.
PrlDispCfg_IsAdjustMemAuto | Determines whether memory allocation for Parallels Service is performed automatically or manually.
PrlDispCfg_SetAdjustMemAuto | Allows to choose the Parallels Service memory allocation mode from automatic or manual.
PrlDispCfg_SetCanChangeDefaultSettings | Allows to grant or deny a permission to new users to modify Parallels Service preferences.
PrlDispCfg_SetDefaultVNCHostName | Sets the base VNC host name.
PrlDispCfg_SetMaxReservMemLimit | Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.
PrlDispCfg_SetMaxVmMem | Allows to set the maximum memory size that can be allocated to an individual virtual machine.
PrlDispCfg_SetMinReservMemLimit | Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.
PrlDispCfg_SetMinSecurityLevel | Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.
PrlDispCfg_SetMinVmMem | Allows to set the minimum required memory size that must be allocated to an individual virtual machine.
PrlDispCfg_SetRecommendMaxVmMem | Allows to manually set recommended memory size for an individual virtual machine.
PrlDispCfg_SetReservedMemLimit | Allows to set the amount of memory that will be allocated for Parallels Service operation.
PrlDispCfg_SetVNCBasePort | Sets the base VNC port number.
PrlDispNet_GetDhcpScopeEndIp | Returns the end IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeMask | Returns the subnet mask of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetDhcpScopeStartIp | Returns the start IP address of DHCP scope for the specified virtual network adapter.
PrlDispNet_GetIndex | Returns the index identifying the specified adapter on the Parallels Service.
PrlDispNet_GetName | Returns the name of the specified virtual network adapter.
PrlDispNet_GetNetworkType | Returns the virtual network adapter network type (host-only or shared).
PrlDispNet_GetSysName | Returns the name of the physical network adapter to which the specified virtual network adapter is bound.
PrlDispNet_GetUuid | Returns the specified virtual network adapter UUID.
PrlDispNet_IsDhcpEnabled | Determines if DHCP scope is enabled for the specified virtual network adapter.
PrlDispNet_IsEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlDispNet_Remove | Removes the specified virtual network adapter object from memory.
PrlDispNet_SetDhcpEnabled | Allows to enable or disable the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeEndIp | Sets the end IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeMask | Sets the subnet mask of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetDhcpScopeStartIp | Sets the start IP address of the DHCP scope for the specified virtual network adapter.
PrlDispNet_SetEnabled | Allows to enable or disable a specified virtual network adapter.
PrlDispNet_SetIndex | Sets the specified virtual network adapter index (from 0 to 5).
PrlDispNet_SetName | Sets the specified virtual network adapter name.
PrlDispNet_SetNetworkType | Allows to set a network type for the specified virtual network adapter.
PrlDispNet_SetSysName | Sets the specified virtual network adapter system name.
PrlEvent_CanBeIgnored | Determines whether the event is critical or not.
PrlEvent_CreateAnswerEvent | Generates properly formatted and structured answer to a question included in the event.
PrlEvent_GetDataPtr | Clients can use this method to receive a data buffer specific to the event type.
PrlEvent_GetErrCode | Returns the code associated with the event.
PrlEvent_GetErrString | Returns string representation of the event message.
PrlEvent_GetIssuerId | Returns the event issuer ID (host UUID, virtual machine UUID, etc).
PrlEvent_GetIssuerType | Returns the event issuer type (virtual machine, host, etc.).
PrlEvent_GetJob | Obtains the handle of the job that caused the event.
PrlEvent_GetParam | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.
PrlEvent_GetParamByName | Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.
PrlEvent_GetParamsCount | Determines the number of the parameters in the event container.
PrlEvent_GetServer | Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.
PrlEvent_GetType | Returns the type of the event.
PrlEvent_GetVm | Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.
PrlEvent_IsAnswerRequired | Determines whether the event requires a response from the client.
PrlEvtPrm_GetName | Returns the event parameter name.
PrlEvtPrm_GetType | Returns the event parameter data type.
PrlEvtPrm_ToBoolean | Returns the event parameter value as boolean (PRL_BOOL).
PrlEvtPrm_ToCData | Returns the event parameter value as CDATA.
PrlEvtPrm_ToHandle | Returns the event parameter value as PRL_HANDLE.
PrlEvtPrm_ToInt32 | Returns the event parameter value as PRL_INT32.
PrlEvtPrm_ToString | Returns the event parameter value as string.
PrlEvtPrm_ToUint32 | Returns the event parameter value as PRL_UINT32.
PrlFoundVmInfo_GetConfigPath | Extracts the virtual machine configuration path from the container.
PrlFoundVmInfo_GetName | Extracts the virtual machine name form the container.
PrlFoundVmInfo_GetOSVersion | Extracts the virtual machine's OS version from the container.
PrlFoundVmInfo_IsOldConfig | Determines if the virtual machine has an old configuration.
PrlFoundVmInfo_IsTemplate | Determines of the specified virtual machine is a template.
PrlFsEntry_GetAbsolutePath | Returns the specified file system entry absolute path.
PrlFsEntry_GetLastModifiedDate | Returns the date on which the specified file system entry was last modified.
PrlFsEntry_GetPermissions | Returns the specified file system entry permissions (read, write, execute) for the current user.
PrlFsEntry_GetRelativeName | Returns the file system entry relative name.
PrlFsEntry_GetSize | Returns the file system entry size.
PrlFsEntry_GetType | Returns the file system entry type (file, directory, drive).
PrlFsInfo_GetChildEntriesCount | Determines the number of child entries for the specified remote file system entry.
PrlFsInfo_GetChildEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.
PrlFsInfo_GetFsType | Determines the file system type of the specified file system entry.
PrlFsInfo_GetParentEntry | Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.
PrlFsInfo_GetType | Determines the basic type of the specified file system entry.
PrlHandle_AddRef | Increases the specified handle reference count by one.
PrlHandle_Free | Frees the specified handle.
PrlHandle_GetType | Returns the type of the specified handle.
PrlJob_Cancel | Cancel the specified job.
PrlJob_GetDataPtr | The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.
PrlJob_GetError | Provides additional job error information.
PrlJob_GetOpCode | Returns the job operation code.
PrlJob_GetProgress | Obtains a job progress report.
PrlJob_GetResult | Obtains a handle of type PHT_RESULT containing the result returned by the job.
PrlJob_GetRetCode | Obtains the return code from the specified job object.
PrlJob_GetStatus | Obtains the current status of the specified job.
PrlJob_Wait | The PrlJob_Wait function allows to use asynchronous functions synchronously.
PrlLic_GetCompanyName | Returns the name of the company to which this license was issued.
PrlLic_GetLicenseKey | Returns the license key string.
PrlLic_GetStatus | Returns the license status.
PrlLic_GetUserName | Returns the license user name.
PrlLic_IsValid | Determines if the license is valid.
PrlLoginResponse_GetHostOsVersion | Returns the host OS version.
PrlLoginResponse_GetProductVersion | Returns the Parallels product version number.
PrlLoginResponse_GetRunningTaskByIndex | Obtains a handle of type PHT_RUNNING_TASK.
PrlLoginResponse_GetRunningTaskCount | Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.
PrlLoginResponse_GetServerUuid | Returns the host machine UUID.
PrlLoginResponse_GetSessionUuid | Returns session UUID string (used to restore a session).
PrlNetSvc_GetStatus | Returns the Parallels Service network status information.
PrlPortFwd_Create | Creates a new handle of type PHT_PORT_FORWARDING.
PrlPortFwd_GetIncomingPort | Returns the incoming port.
PrlPortFwd_GetRedirectIPAddress | Returns the redirect IP address of the specified port forward entry.
PrlPortFwd_GetRedirectPort | Returns the redirect port.
PrlPortFwd_SetIncomingPort | Sets the specified incoming port.
PrlPortFwd_SetRedirectIPAddress | Sets the specified port forwardi entry redirect IP address.
PrlPortFwd_SetRedirectPort | Sets the specified redirect port.
PrlResult_GetParam | Obtains a handle to an object containing the results of the corresponding asynchronous operation.
PrlResult_GetParamAsString | Obtains a string result from the result object.
PrlResult_GetParamByIndex | Obtains a handle from the result object identified by the index.
PrlResult_GetParamByIndexAsString | Obtains a string result from the result object identified by the index.
PrlResult_GetParamsCount | Determines the number of items in the specified result object.
PrlRunningTask_GetTaskParametersAsString | Returns task parameters as a string.
PrlRunningTask_GetTaskType | Determines the task type.
PrlRunningTask_GetTaskUuid | Returns the task UUID (universally unique ID).
PrlShare_GetDescription | Returns the shared folder description.
PrlShare_GetName | Returns the shared folder name (as it appears in the guest OS).
PrlShare_GetPath | Returns the shared folder path.
PrlShare_IsEnabled | Determines whether the share is enabled or not.
PrlShare_IsReadOnly | Determines if the share is read-only.
PrlShare_Remove | Removes the share from the virtual machine configuration.
PrlShare_SetDescription | Sets the shared folder description.
PrlShare_SetEnabled | Enables the specified share.
PrlShare_SetName | Sets the share name (as it will appear in the guest OS).
PrlShare_SetPath | Sets the shared folder path.
PrlShare_SetReadOnly | Makes the specified shared folder read-only.
PrlSrv_AddNetAdapter | Adds a new virtual network adapter to the specified Parallels Service.
PrlSrv_AttachToLostTask | The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.
PrlSrv_CheckParallelsServerAlive | Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.
PrlSrv_CommonPrefsBeginEdit | The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_CommonPrefsCommit | The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).
PrlSrv_Create | Creates a new handle of type PHT_SERVER.
PrlSrv_CreateVm | Obtains a new handle of type PHT_VIRTUAL_MACHINE.
PrlSrv_DeleteNetAdapter | Removes a virtual network adapter from the Parallels Service configuration.
PrlSrv_FsCanCreateFile | Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.
PrlSrv_FsCreateDir | Creates a directory in the specified location on the host.
PrlSrv_FsGenerateEntryName | Automatically generates a unique name for a new directory.
PrlSrv_FsGetDirEntries | Retrieves information about the specified file system entry residing on the specified host computer.
PrlSrv_FsGetDiskList | Returns a list of root directories on the host computer.
PrlSrv_FsRemoveEntry | Removes a file system entry from the host computer.
PrlSrv_FsRenameEntry | Renames a file system entry on the host.
PrlSrv_GetCommonPrefs | Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.
PrlSrv_GetLicenseInfo | Returns an object of type PHT_LICENSE containing the Parallels license information.
PrlSrv_GetNetServiceStatus | Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.
PrlSrv_GetProblemReport | Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.
PrlSrv_GetQuestions | The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlSrv_GetServerInfo | Obtains a handle of type PHT_SERVER_INFO containing the host computer information.
PrlSrv_GetSrvConfig | Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.
PrlSrv_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.
PrlSrv_GetUserInfo | Obtains a handle of type PHT_USER_INFO containing information about the specified user.
PrlSrv_GetUserInfoList | Obtains a list of handles of type PHT_USER_INFO containing information about all known users.
PrlSrv_GetUserProfile | Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.
PrlSrv_GetVirtualNetworkList | Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.
PrlSrv_GetVmList | Retrieves a list of virtual machines registered with the specified Parallels Service.
PrlSrv_IsConnected | Determines if the connection to the specified Parallels Service is active.
PrlSrv_Login | Performs a remote login operation using the specified parameters.
PrlSrv_LoginLocal | Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.
PrlSrv_Logoff | Logs off the Parallels Service.
PrlSrv_LookupParallelsServers | Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.
PrlSrv_NetServiceRestart | Restarts the Parallels network service.
PrlSrv_NetServiceRestoreDefaults | Restores the default settings of the Parallels network service.
PrlSrv_NetServiceStart | Starts the Parallels network service.
PrlSrv_NetServiceStop | Stops the Parallels network service.
PrlSrv_RegEventHandler | Registers an event handler.
PrlSrv_RegisterVm | Registers an existing virtual machine with Parallels Service.
PrlSrv_SendAnswer | Sends an answer to the Parallels Service in response to a question.
PrlSrv_Shutdown | Shuts down the Parallels Service.
PrlSrv_StartSearchVms | Searches for unregistered virtual machines at the specified location(s).
PrlSrv_SubscribeToHostStatistics | Allows to subscribe to receive host OS statistics on a periodic basis.
PrlSrv_UnregEventHandler | Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.
PrlSrv_UnsubscribeFromHostStatistics | Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.
PrlSrv_UnsubscribeFromPerfStats | Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.
PrlSrv_UpdateLicense | Installs Parallels license on the specified Parallels Service.
PrlSrv_UpdateNetAdapter | Updates an existing virtual network adapter in the specified Parallels Service.
PrlSrv_UserProfileBeginEdit | Timestamps the beginning of the user profile editing operation.
PrlSrv_UserProfileCommit | Saves (commits) user profile changes to the Parallels Service.
PrlSrvCfg_GetCpuCount | Determines the number of CPUs on the host machine.
PrlSrvCfg_GetCpuHvt | Determines the hardware virtualization type of the host CPU.
PrlSrvCfg_GetCpuMode | Determines the CPU mode (32 bit or 64 bit) on the host.
PrlSrvCfg_GetCpuModel | Determines the model of CPU on the host machine.
PrlSrvCfg_GetCpuSpeed | Determines the host machine CPU speed.
PrlSrvCfg_GetDnsServers | Obtains the list of IP addresses of DNS servers.
PrlSrvCfg_GetFloppyDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.
PrlSrvCfg_GetFloppyDisksCount | Determines the number of floppy disk drives on the host.
PrlSrvCfg_GetGenericPciDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic PCI device installed on the host.
PrlSrvCfg_GetGenericPciDevicesCount | Determines the number of generic PCI devices installed on the host.
PrlSrvCfg_GetGenericScsiDevice | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.
PrlSrvCfg_GetGenericScsiDevicesCount | Determines the number of generic SCSI devices installed on the host.
PrlSrvCfg_GetHardDisk | Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.
PrlSrvCfg_GetHardDisksCount | Determines the number of hard disk drives on the host.
PrlSrvCfg_GetHostname | Returns the server hostname.
PrlSrvCfg_GetHostOsMajor | Returns the major version number of the host operating system.
PrlSrvCfg_GetHostOsMinor | Returns the minor version number of the host operating system.
PrlSrvCfg_GetHostOsStrPresentation | Returns the full host operating system information as a single string.
PrlSrvCfg_GetHostOsSubMinor | Returns the sub-minor version number of the host operating system.
PrlSrvCfg_GetHostOsType | Returns the host operating system type.
PrlSrvCfg_GetHostRamSize | Determines the amount of memory (RAM) available on the host.
PrlSrvCfg_GetNetAdapter | Obtains an object of type PHT_HW_NET_ADAPTER containing information about a network adapter.
PrlSrvCfg_GetNetAdaptersCount | Determines the number of network adapters available on the server.
PrlSrvCfg_GetOpticalDisk | Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.
PrlSrvCfg_GetOpticalDisksCount | Determines the number of optical disks on the host.
PrlSrvCfg_GetParallelPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a parallel port on the host.
PrlSrvCfg_GetParallelPortsCount | Determines the number of parallel ports on the host.
PrlSrvCfg_GetPrinter | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.
PrlSrvCfg_GetPrintersCount | Determines the number of printers installed on the host.
PrlSrvCfg_GetSearchDomains | Obtains the list of search domains.
PrlSrvCfg_GetSerialPort | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.
PrlSrvCfg_GetSerialPortsCount | Determines the number of serial ports available on the host.
PrlSrvCfg_GetSoundMixerDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.
PrlSrvCfg_GetSoundMixerDevsCount | Determines the number of sound mixer devices available on the host.
PrlSrvCfg_GetSoundOutputDev | Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.
PrlSrvCfg_GetSoundOutputDevsCount | Determines the number of sound devices available on the host.
PrlSrvCfg_GetUsbDev | Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.
PrlSrvCfg_GetUsbDevsCount | Determines the number of USB devices on the host.
PrlSrvCfg_IsSoundDefaultEnabled | Determines whether a sound device on the host is enabled or disabled.
PrlSrvCfg_IsUsbSupported | Determines if USB is supported on the host.
PrlSrvCfg_IsVtdSupported | Determines whether VT-d is supported on the host.
PrlSrvCfgDev_GetId | Returns the system device ID.
PrlSrvCfgDev_GetName | Returns the system device name.
PrlSrvCfgDev_GetType | Returns the device type.
PrlSrvCfgDev_IsConnectedToVm | Determines whether the device is connected to the virtual machine.
PrlSrvCfgHdd_GetDevId | Returns the hard disk device id.
PrlSrvCfgHdd_GetDevName | Returns the hard disk device name.
PrlSrvCfgHdd_GetDevSize | Returns the size of the hard disk device.
PrlSrvCfgHdd_GetDiskIndex | Returns the index of a hard disk device.
PrlSrvCfgHdd_GetPart | Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.
PrlSrvCfgHdd_GetPartsCount | Returns the number of partitions available on a hard drive.
PrlSrvCfgHddPart_GetIndex | Returns the index of the specified hard disk partition.
PrlSrvCfgHddPart_GetName | Returns a hard disk partition name.
PrlSrvCfgHddPart_GetSize | Returns the hard disk partition size.
PrlSrvCfgHddPart_GetSysName | Returns a hard disk partition system name.
PrlSrvCfgHddPart_GetType | Returns a numerical code identifying the type of the specified partition.
PrlSrvCfgHddPart_IsActive | Determines whether a disk partition is active or inactive.
PrlSrvCfgHddPart_IsInUse | Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.
PrlSrvCfgHddPart_IsLogical | Determines whether the specified partition is a logical partition.
PrlSrvCfgNet_GetDefaultGateway | Returns the default gateway address for the specified network adapter.
PrlSrvCfgNet_GetDnsServers | Obtains a list of addresses of DNS servers assigned to the specified network adapter.
PrlSrvCfgNet_GetMacAddress | Returns the MAC address of the specified network adapter.
PrlSrvCfgNet_GetNetAdapterType | Returns a network adapter type.
PrlSrvCfgNet_GetNetAddresses | Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.
PrlSrvCfgNet_GetSearchDomains | Obtains a list of search domains assigned to the specified network adapter.
PrlSrvCfgNet_GetSysIndex | Returns a network adapter system index.
PrlSrvCfgNet_IsConfigureWithDhcp | Determines whether the adapter network settings are configured through DHCP.
PrlSrvCfgNet_IsEnabled | Determines whether the adapter is enabled or disabled.
PrlSrvInfo_GetCmdPort | Returns the port number at which the Parallels Service is listening for requests.
PrlSrvInfo_GetHostName | Returns the name of the machine hosting the specified Parallels Service.
PrlSrvInfo_GetOsVersion | Returns the version of the host operating system.
PrlSrvInfo_GetProductVersion | Returns the Parallels product version number.
PrlSrvInfo_GetServerUuid | Returns the host machine UUID (universally unique ID).
PrlStat_GetCpusStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetCpuStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.
PrlStat_GetDisksStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetDiskStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.
PrlStat_GetDispUptime | Returns the Parallels Service uptime in seconds.
PrlStat_GetFreeRamSize | Returns free RAM size in bytes.
PrlStat_GetFreeSwapSize | Returns free swap size in bytes.
PrlStat_GetIfacesStatsCount | Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetIfaceStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.
PrlStat_GetOsUptime | Returns operating system uptime in seconds.
PrlStat_GetProcsStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetProcStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.
PrlStat_GetTotalRamSize | Returns total RAM size in bytes.
PrlStat_GetTotalSwapSize | Returns total swap size in bytes.
PrlStat_GetUsageRamSize | Returns the size RAM currently in use (in bytes).
PrlStat_GetUsageSwapSize | Returns the size of swap space currently in use (in bytes).
PrlStat_GetUsersStatsCount | Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.
PrlStat_GetUserStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.
PrlStatCpu_GetCpuUsage | Returns the CPU usage, in percents.
PrlStatCpu_GetSystemTime | Returns the CPU system time, in seconds.
PrlStatCpu_GetTotalTime | Returns the CPU total time in seconds.
PrlStatCpu_GetUserTime | Returns the CPU user time in seconds.
PrlStatDisk_GetFreeDiskSpace | Returns free disk space, in bytes.
PrlStatDisk_GetPartsStatsCount | Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.
PrlStatDisk_GetPartStat | Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.
PrlStatDisk_GetSystemName | Returns the disk device name.
PrlStatDisk_GetUsageDiskSpace | Returns the size of the used space on the specified disk, in bytes.
PrlStatDiskPart_GetFreeDiskSpace | Returns the size of the free space on the specified disk partition, in bytes.
PrlStatDiskPart_GetSystemName | Returns disk partition device name.
PrlStatDiskPart_GetUsageDiskSpace | Returns the size of the used space on the specified disk partition, in bytes.
PrlStatIface_GetInDataSize | Returns the total number of bytes the network interface has received since the Parallels Service was last started.
PrlStatIface_GetInPkgsCount | Returns the total number of packets the network interface has received since the Parallels Service was last started.
PrlStatIface_GetOutDataSize | Returns the total number of bytes the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetOutPkgsCount | Returns the total number of packets the network interface has sent since the Parallels Service was last started.
PrlStatIface_GetSystemName | Returns the network interface system name.
PrlStatProc_GetCommandName | Returns the process command name.
PrlStatProc_GetCpuUsage | Returns process CPU usage in percents.
PrlStatProc_GetId | Returns process system id.
PrlStatProc_GetOwnerUserName | Returns process owner user name.
PrlStatProc_GetRealMemUsage | Returns real memory usage size in bytes.
PrlStatProc_GetStartTime | Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).
PrlStatProc_GetState | Returns process state.
PrlStatProc_GetSystemTime | Returns system running time of the process, in seconds.
PrlStatProc_GetTotalMemUsage | Returns total memory usage size in bytes.
PrlStatProc_GetTotalTime | Returns total running time of the process, in seconds.
PrlStatProc_GetUserTime | Returns user running time of the process, in seconds.
PrlStatProc_GetVirtMemUsage | Returns virtual memory usage size in bytes.
PrlStatUser_GetHostName | Returns the host name of the client machine from which the session was initiated.
PrlStatUser_GetServiceName | Returns the name of the host system service that created the session.
PrlStatUser_GetSessionTime | Returns session duration, in seconds.
PrlStatUser_GetUserName | Returns session user name.
PrlStrList_AddItem | Adds a new string to the container.
PrlStrList_GetItem | Extracts the specified string from the container.
PrlStrList_GetItemsCount | Determines the number of strings in the container.
PrlStrList_RemoveItem | Removes the specified string from the container.
PrlUsrCfg_CanChangeSrvSets | Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).
PrlUsrCfg_CanUseMngConsole | Determines if the user is allowed to use the Parallels Service management console utility.
PrlUsrCfg_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for this user.
PrlUsrCfg_GetVmDirUuid | Returns name and path of the default virtual machine folder for this Parallels Service.
PrlUsrCfg_SetDefaultVmFolder | Allows to set a default virtual machine folder for the user.
PrlUsrCfg_SetVmDirUuid | Sets user default VM dir.
PrlUsrInfo_CanChangeSrvSets | Determines whether the specified user is allowed to modify Parallels Service preferences.
PrlUsrInfo_GetDefaultVmFolder | Returns name and path of the default virtual machine directory for the specified user.
PrlUsrInfo_GetName | Returns the user name.
PrlUsrInfo_GetSessionCount | Returns the user active session count.
PrlUsrInfo_GetUuid | Returns the user Universally Unique Identifier (UUID).
PrlVirtNet_Create | Creates a new handle of type PHT_VIRTUAL_NETWORK.
PrlVirtNet_GetAdapterIndex | Returns a numeric index assigned to the network adapter in the specified virtual network.
PrlVirtNet_GetAdapterName | Returns the name of the network adapter in the specified virtual network.
PrlVirtNet_GetBoundCardMac | Returns the bound card MAC address of the specified virtual network.
PrlVirtNet_GetDescription | Returns the description of the specified virtual network.
PrlVirtNet_GetDhcpIPAddress | Returns the DCHP IP address of the specified virtual network.
PrlVirtNet_GetHostIPAddress | Returns the host IP address of the specified virtual network.
PrlVirtNet_GetIPNetMask | Returns the IP net mask of the specified virtual network.
PrlVirtNet_GetIPScopeEnd | Returns the DHCP end IP address of the specified virtual network.
PrlVirtNet_GetIPScopeStart | Returns the DHCP start IP address of the specified virtual network.
PrlVirtNet_GetNetworkId | Returns the ID of the specified virtual network.
PrlVirtNet_GetNetworkType | Returns the virtual network type.
PrlVirtNet_GetPortForwardList | Returns the port forward entries list.
PrlVirtNet_IsAdapterEnabled | Determines whether the specified virtual network adapter is enabled or disabled.
PrlVirtNet_IsDHCPServerEnabled | Determines whether the specified virtual network DHCP server is enabled or disabled.
PrlVirtNet_IsEnabled | Determines whether the specified virtual network is enabled or disabled.
PrlVirtNet_IsNATServerEnabled | Determines whether the specified virtual network NAT server is enabled or disabled.
PrlVirtNet_SetAdapterEnabled | Allows to enable or disable a specified virtual network adapter.
PrlVirtNet_SetAdapterIndex | Sets the specified adapter index.
PrlVirtNet_SetAdapterName | Sets the specified virtual network adapter name.
PrlVirtNet_SetBoundCardMac | Sets the specified virtual network bound card MAC address.
PrlVirtNet_SetDescription | Sets the specified virtual network description.
PrlVirtNet_SetDhcpIPAddress | Sets the specified virtual network DHCP IP address.
PrlVirtNet_SetDHCPServerEnabled | Allows to enable or disable a specified virtual network DHCP server.
PrlVirtNet_SetEnabled | Allows to enable or disable a specified virtual network.
PrlVirtNet_SetHostIPAddress | Sets the specified virtual network host IP address.
PrlVirtNet_SetIPNetMask | Sets the specified virtual network IP net mask.
PrlVirtNet_SetIPScopeEnd | Sets the specified virtual network DHCP end IP address.
PrlVirtNet_SetIPScopeStart | Sets the specified virtual network DHCP start IP address.
PrlVirtNet_SetNATServerEnabled | Allows to enable or disable a specified virtual network NAT server.
PrlVirtNet_SetNetworkId | Sets the specified virtual network ID.
PrlVirtNet_SetNetworkType | Sets the specified virtual network type.
PrlVirtNet_SetPortForwardList | Sets the port forward entries list.
PrlVm_BeginEdit | The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.
PrlVm_CancelCompressor | Cancels the running Compressor operation that was started with PrlVm_RunCompressor.
PrlVm_Clone | Clones an existing virtual machine.
PrlVm_Commit | The PrlVm_Commit function is used in modifying a virtual machine configuration.
PrlVm_CreateEvent | Creates VM event that bint to current VM.
PrlVm_CreateSnapshot | Creates a virtual machine snapshot.
PrlVm_CreateUnattendedFloppy | Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.
PrlVm_Delete | Deletes the specified virtual machine from the host.
PrlVm_DeleteSnapshot | Deleted the specified virtual machine snapshot.
PrlVm_DropSuspendedState | Resets a suspended virtual machine.
PrlVm_GenerateVmDevFilename | Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.
PrlVm_GetConfig | Obtains a handle of type PHT_VM_CONFIGURATION.
PrlVm_GetProblemReport | The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.
PrlVm_GetQuestions | The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.
PrlVm_GetSnapshotsTree | Retrieves snapshot information for the specified virtual machine.
PrlVm_GetState | Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.
PrlVm_GetStatistics | Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.
PrlVm_GetSuspendedScreen | Retrieves the virtual machine screen state before it was suspending.
PrlVm_GetToolsState | Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.
PrlVm_InitiateDevStateNotifications | This method lets to initiate sending notifications about devices states by VM.
PrlVm_InstallTools | Begin the Parallels Tools installation process.
PrlVm_InstallUtility | Installs a specified utility in a virtual machine.
PrlVm_LoginInGuest | Creates a new console session or binds to an existing GUI session in a virtual machine.
PrlVm_Migrate | Migrates an existing virtual machine to another host.
PrlVm_MigrateCancel | Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.
PrlVm_MigrateEx | Migrates an existing virtual machine to another host.
PrlVm_Pause | Pauses the specified virtual machine.
PrlVm_RefreshConfig | The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).
PrlVm_Reg | Creates a new virtual machine and registers it with the Parallels Service.
PrlVm_RegEventHandler | Registers an event handler (callback function) with the virtual machine.
PrlVm_Reset | Resets the specified virtual machine.
PrlVm_Restart | Restarts the operating system of the specified virtual machine.
PrlVm_Restore | Restores the registered virtual machine.
PrlVm_Resume | Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.
PrlVm_RunCompressor | Initiates the Compressor process.
PrlVm_SetConfig | The PrlVm_SetConfig is reserved and does nothing.
PrlVm_Start | Start the specified virtual machine.
PrlVm_StartEx | Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).
PrlVm_StartVncServer | Starts a VNC server for the specified virtual machine.
PrlVm_Stop | Stop the specified virtual machine.
PrlVm_StopVncServer | Stops the VNC server that was previously started for a virtual machine.
PrlVm_SubscribeToGuestStatistics | Subscribes to receive the specified virtual machine performance statistics on a periodic basis.
PrlVm_Suspend | Suspends the specified virtual machine.
PrlVm_SwitchToSnapshot | Reverts the specified virtual machine to the specified snapshot.
PrlVm_TisGetIdentifiers | Retrieves a list of identifiers from the Tools Information Service database.
PrlVm_TisGetRecord | Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.
PrlVm_ToolsSendShutdown | Initiates graceful shutdown of the specified virtual machine.
PrlVm_Unreg | Unregisters the specified virtual machine from the Parallels Service.
PrlVm_UnregEventHandler | Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.
PrlVm_UnsubscribeFromGuestStatistics | Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.
PrlVm_UnsubscribeFromPerfStats | Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.
PrlVm_UpdateSecurity | Updates access level for the specified virtual machine.
PrlVm_UpdateSnapshotData | Modifies the specified virtual machine snapshot name and description.
PrlVm_ValidateConfig | Validates the specified section of a virtual machine configuration.
PrlVmCfg_AddDefaultDevice | The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.
PrlVmCfg_CreateBootDev | Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.
PrlVmCfg_CreateScrRes | Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.
PrlVmCfg_CreateShare | Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.
PrlVmCfg_CreateVmDev | Creates a new virtual device handle of the specified type.
PrlVmCfg_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmCfg_GetAppInDockMode | Determines the current dock mode for the specified virtual machine.
PrlVmCfg_GetAutoStart | Determines if the specified virtual machine is set to start automatically on Parallels Service startup.
PrlVmCfg_GetAutoStartDelay | Returns the time delay used during the virtual machine automatic startup.
PrlVmCfg_GetAutoStop | Determines the mode of the automatic shutdown for the specified virtual machine.
PrlVmCfg_GetBackgroundPriority | Determines the specified virtual machine background process priority type.
PrlVmCfg_GetBootDev | Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.
PrlVmCfg_GetBootDevCount | Determines the number of devices in the virtual machine boot device priority list.
PrlVmCfg_GetConfigValidity | The PrlVmCfg_GetConfigValidity function returns an error code.
PrlVmCfg_GetCpuAccelLevel | Determines the virtual machine CPU acceleration level.
PrlVmCfg_GetCpuCount | Determines the number of CPUs in the virtual machine.
PrlVmCfg_GetCpuMode | Determines the specified virtual machine CPU mode (32 bit or 64 bit).
PrlVmCfg_GetCpuUnits | Determines the number of CPU units allocated to a virtual machine.
PrlVmCfg_GetCustomProperty | Returns the virtual machine custom property information.
PrlVmCfg_GetDefaultHddSize | The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.
PrlVmCfg_GetDefaultMemSize | The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.
PrlVmCfg_GetDescription | Returns the specified virtual machine description.
PrlVmCfg_GetDevByType | Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.
PrlVmCfg_GetDevsCount | Determines the total number of devices of any type installed in the virtual machine.
PrlVmCfg_GetDevsCountByType | Obtains the number of virtual devices of the specified type available in the specified virtual machine.
PrlVmCfg_GetDevsList | Returns a pointer to a buffer containing handles to the virtual devices installed in a virtual machine.
PrlVmCfg_GetDnsServers | Obtains the list of globally defined DNS servers that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetDockIconType | Returns the virtual machine dock icon type.
PrlVmCfg_GetFloppyDisk | Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.
PrlVmCfg_GetFloppyDisksCount | Determines the number of floppy disk drives in a virtual machine.
PrlVmCfg_GetForegroundPriority | Returns foreground processes priority for the specified virtual machine.
PrlVmCfg_GetGenericPciDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.
PrlVmCfg_GetGenericPciDevsCount | Determines the number of generic PCI devices in a virtual machine.
PrlVmCfg_GetGenericScsiDev | Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.
PrlVmCfg_GetGenericScsiDevsCount | Determines the number of generic SCSI devices in a virtual machine.
PrlVmCfg_GetHardDisk | Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.
PrlVmCfg_GetHardDisksCount | Determines the number of virtual hard disks in a virtual machine.
PrlVmCfg_GetHomePath | Returns the virtual machine home directory name and path.
PrlVmCfg_GetHostname | Obtains the hostname of the specified virtual machine.
PrlVmCfg_GetIcon | Returns the name of the icon file used by the specified virtual machine.
PrlVmCfg_GetLastModifiedDate | Returns the date and time when the specified virtual machine was last modified.
PrlVmCfg_GetLastModifierName | Returns the name of the user who last modified the specified virtual machine.
PrlVmCfg_GetName | Returns the name of the specified virtual machine.
PrlVmCfg_GetNetAdapter | Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.
PrlVmCfg_GetNetAdaptersCount | Determines the number of network adapters in a virtual machine.
PrlVmCfg_GetOpticalDisk | Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.
PrlVmCfg_GetOpticalDisksCount | Determines the number of optical disks in the specified virtual machine.
PrlVmCfg_GetOsType | Returns the type of the operating system that the specified virtual machine is running.
PrlVmCfg_GetOsVersion | Returns the version of the operating system that the specified virtual machine is running.
PrlVmCfg_GetParallelPort | Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual parallel port in the specified virtual machine.
PrlVmCfg_GetParallelPortsCount | Determines the number of virtual parallel ports in the specified virtual machine.
PrlVmCfg_GetRamSize | Returns the virtual machine memory (RAM) size, in megabytes.
PrlVmCfg_GetScrRes | Returns the specified virtual machine screen resolution.
PrlVmCfg_GetScrResCount | Returns the virtual machine screen resolutions count.
PrlVmCfg_GetSearchDomains | Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.
PrlVmCfg_GetSerialPort | Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.
PrlVmCfg_GetSerialPortsCount | Determines the number of serial ports in a virtual machine.
PrlVmCfg_GetServerHost | Returns the hostname of the machine hosting the specified virtual machine.
PrlVmCfg_GetServerUuid | Returns the UUID of the machine hosting the specified virtual machine.
PrlVmCfg_GetShare | Obtains a handle of type PHT_SHARE containing information about a shared folder.
PrlVmCfg_GetSharesCount | Determines the number of shared folders in a virtual machine.
PrlVmCfg_GetSoundDev | Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.
PrlVmCfg_GetSoundDevsCount | Determines the number of sound devices in a virtual machine.
PrlVmCfg_GetStartLoginMode | Returns the automatic startup login mode for the specified virtual machine.
PrlVmCfg_GetStartUserLogin | Returns the user name used during the specified virtual machine automatic startup.
PrlVmCfg_GetSystemFlags | Returns the virtual machine system flags.
PrlVmCfg_GetUndoDisksMode | Determines the current undo disks mode for the specified virtual machine.
PrlVmCfg_GetUsbDevice | Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.
PrlVmCfg_GetUsbDevicesCount | Determines the number of USB devices in a virtual machine.
PrlVmCfg_GetUuid | Returns the UUID (universally unique ID) of the specified virtual machine.
PrlVmCfg_GetVideoRamSize | Returns the video memory size of the specified virtual machine.
PrlVmCfg_GetVNCHostName | Returns the VNC hostname of the specified virtual machine.
PrlVmCfg_GetVNCMode | Returns the VNC mode of the specified virtual machine.
PrlVmCfg_GetVNCPassword | Returns the VNC password for the specified virtual machine.
PrlVmCfg_GetVNCPort | Returns the VNC port number for the specified virtual machine.
PrlVmCfg_GetWindowMode | Returns the current window mode the specified virtual machine is in.
PrlVmCfg_IsCloseAppOnShutdown | Returns Virtual Machine close app on shutdown sign.
PrlVmCfg_IsCpuVtxEnabled | Returns Virtual Machine CPU VTx support enabling sign.
PrlVmCfg_IsDefaultDeviceNeeded | Determines if a virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.
PrlVmCfg_IsDisableAPIC | Gets the APIC using for virtual machine in runtime.
PrlVmCfg_IsDiskCacheWriteBack | Determines if disk cache write-back is enabled for the specified virtual machine.
PrlVmCfg_IsExcludeDock | Determines the guest OS window behavior in coherence mode.
PrlVmCfg_IsGuestSharingAutoMount | Determines if host shared folders are mounted automatically in a given virtual machine.
PrlVmCfg_IsGuestSharingEnabled | Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).
PrlVmCfg_IsGuestSharingEnableSpotlight | Determines if VM virtual disks will be added to Spotlight search subsystem.
PrlVmCfg_IsHostSharingEnabled | Determines if host sharing is enabled (host shared folders are visible in the guest OS).
PrlVmCfg_IsMapSharedFoldersOnLetters | Determines whether host disks shared into guest Windows OS will be maped on drive letters.
PrlVmCfg_IsMultiDisplay | Determines if the specified virtual machine uses a multi-display mode.
PrlVmCfg_IsOsResInFullScrMode | Determines if a virtual machine OS resolution is in full screen mode.
PrlVmCfg_IsRelocateTaskBar | Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.
PrlVmCfg_IsScrResEnabled | Determines if additional screen resolution support is enabled in a virtual machine.
PrlVmCfg_IsShareAllHostDisks | Determines whether all host disks will be present at guest OS as shares.
PrlVmCfg_IsSharedProfileEnabled | Returns sign whether shared profile is enabled.
PrlVmCfg_IsShareUserHomeDir | Determines whether host user home dir will be present at guest OS as share.
PrlVmCfg_IsShowTaskBar | Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.
PrlVmCfg_IsSmartGuardEnabled | Returns sign whether smart guard is enabled.
PrlVmCfg_IsTemplate | Determines if the specified virtual machine object contains a virtual machine or a template configuration information.
PrlVmCfg_IsUseDesktop | Returns sign whether use desktop in shared profile is enabled.
PrlVmCfg_IsUseDocuments | Returns sign whether use documents in shared profile is enabled.
PrlVmCfg_IsUseMusic | Returns sign whether use music in shared profile is enabled.
PrlVmCfg_IsUsePictures | Returns sign whether use pictures in shared profile is enabled.
PrlVmCfg_IsUserDefinedSharedFoldersEnabled | Returns sign whether user defined shared folders enabled.
PrlVmCfg_SetAppInDockMode | Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).
PrlVmCfg_SetAutoStart | Allows to sets the automatic startup option for the specified virtual machine.
PrlVmCfg_SetAutoStartDelay | Sets the time delay that will be used during the virtual machine automatic startup.
PrlVmCfg_SetAutoStop | Allows to set the automatic shutdown mode for the specified virtual machine.
PrlVmCfg_SetBackgroundPriority | Sets virtual machine background processes priority.
PrlVmCfg_SetCloseAppOnShutdown | Sets Virtual Machine close app on shutdown sign.
PrlVmCfg_SetCpuAccelLevel | Sets CPU acceleration level for the specified virtual machine.
PrlVmCfg_SetCpuCount | Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).
PrlVmCfg_SetCpuMode | Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.
PrlVmCfg_SetCpuUnits | Sets the number of CPU units that will be allocated to a virtual machine.
PrlVmCfg_SetCustomProperty | Sets the virtual machine custom property information.
PrlVmCfg_SetDefaultConfig | The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.
PrlVmCfg_SetDescription | Sets the virtual machine description.
PrlVmCfg_SetDisableAPICSign | Sets the APIC using for virtual machine in runtime.
PrlVmCfg_SetDiskCacheWriteBack | Sets the virtual machine disk cache write-back option.
PrlVmCfg_SetDnsServers | Allows to manually set the global DNS server list that will assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetDockIconType | Sets the virtual machine dock icon type.
PrlVmCfg_SetExcludeDock | Sets the exclude dock option.
PrlVmCfg_SetForegroundPriority | Sets the virtual machine foreground processes priority.
PrlVmCfg_SetGuestSharingAutoMount | Sets the guest OS sharing auto-mount option.
PrlVmCfg_SetGuestSharingEnabled | Enables the guest sharing feature.
PrlVmCfg_SetGuestSharingEnableSpotlight | Sets the VM virtual disks added to Spotlight search subsystem sign.
PrlVmCfg_SetHostname | Sets the specified virtual machine hostname.
PrlVmCfg_SetHostSharingEnabled | Enables host sharing for the specified virtual machine.
PrlVmCfg_SetIcon | Sets the virtual machine icon.
PrlVmCfg_SetMapSharedFoldersOnLetters | Enables mapping of shared host disks on drive letters for the specified virtual machine.
PrlVmCfg_SetMultiDisplay | Sets the virtual machine multi-display option.
PrlVmCfg_SetName | Sets the specified virtual machine name.
PrlVmCfg_SetOsResInFullScrMode | Sets the virtual machine OS resolution in full screen mode option.
PrlVmCfg_SetOsVersion | Sets the virtual machine guest OS version.
PrlVmCfg_SetRamSize | Sets the virtual machine memory (RAM) size.
PrlVmCfg_SetRelocateTaskBar | Allows to enable or disable the Windows task bar relocation feature.
PrlVmCfg_SetScrResEnabled | Sets the additional screen resolution support option in the specified virtual machine
PrlVmCfg_SetSearchDomains | Allows to manually set the global search domain list that will be assigned to the virtual machine on the guest OS side.
PrlVmCfg_SetShareAllHostDisks | Enables sharing of all host disks for the specified virtual machine.
PrlVmCfg_SetSharedProfileEnabled | Lets to set shared profile enabling sign.
PrlVmCfg_SetShareUserHomeDir | Enables sharing of host user home dir for the specified virtual machine.
PrlVmCfg_SetShowTaskBar | Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.
PrlVmCfg_SetSmartGuardEnabled | Lets to set smart guard enabling sign.
PrlVmCfg_SetStartLoginMode | Allows to set the automatic startup login mode for the specified virtual machine.
PrlVmCfg_SetStartUserCreds | Allows to set the automatic startup user login and password for the specified virtual machine.
PrlVmCfg_SetSystemFlags | Sets Virtual Machine system flags.
PrlVmCfg_SetTemplateSign | Allows to modify a regular virtual machine to become a template, and vise versa.
PrlVmCfg_SetUndoDisksMode | Sets the undo disks mode for the virtual machine (see PRL_UNDO_DISKS_MODE for available options).
PrlVmCfg_SetUseDesktop | Lets to set use desktop in shared profile enabling sign.
PrlVmCfg_SetUseDocuments | Lets to set use documents in shared profile enabling sign.
PrlVmCfg_SetUseMusic | Lets to set use music in shared profile enabling sign.
PrlVmCfg_SetUsePictures | Lets to set use pictures in shared profile enabling sign.
PrlVmCfg_SetUserDefinedSharedFoldersEnabled | Lets to set user defined shared folders enabling sign.
PrlVmCfg_SetUuid | Sets the virtual machine UUID (universally unique ID).
PrlVmCfg_SetVideoRamSize | Sets the virtual machine video memory size.
PrlVmCfg_SetVNCHostName | Sets the virtual machine VNC host name.
PrlVmCfg_SetVNCMode | Sets the virtual machine VNC mode.
PrlVmCfg_SetVNCPassword | Sets the virtual machine VNC password.
PrlVmCfg_SetVNCPort | Sets the virtual machine VNC port number.
PrlVmCfg_SetWindowMode | Sets the virtual machine window mode.
PrlVmDev_Connect | The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.
PrlVmDev_Create | Creates a new virtual device handle not bound to any virtual machine.
PrlVmDev_CreateImage | Physically creates a virtual device image on the host.
PrlVmDev_Disconnect | Allows to disconnect a device while the virtual machine is running.
PrlVmDev_GetDescription | Returns the description of a specified virtual device.
PrlVmDev_GetEmulatedType | Returns the virtual device emulation type.
PrlVmDev_GetFriendlyName | Returns the virtual device user friendly name.
PrlVmDev_GetIfaceType | Returns the virtual device interface type (IDE or SCSI).
PrlVmDev_GetImagePath | Returns virtual device image path.
PrlVmDev_GetIndex | Returns an index identifying the virtual device.
PrlVmDev_GetOutputFile | Returns the virtual device output file.
PrlVmDev_GetStackIndex | Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).
PrlVmDev_GetSysName | Returns the virtual device system name.
PrlVmDev_GetType | Returns the type of the specified device.
PrlVmDev_IsConnected | Checks if the specified virtual device is connected.
PrlVmDev_IsEnabled | Determines if the specified device is enabled.
PrlVmDev_IsPassthrough | Determines if the passthrough mode is enabled for the specified mass storage device.
PrlVmDev_IsRemote | Determines if the specified virtual device is a remote device.
PrlVmDev_Remove | Removes the specified virtual device handle from the parent virtual machine list.
PrlVmDev_SetConnected | Connects the specified virtual device.
PrlVmDev_SetDefaultStackIndex | Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).
PrlVmDev_SetDescription | Sets the description for a specified virtual device.
PrlVmDev_SetEmulatedType | Sets the specified virtual device emulation type.
PrlVmDev_SetEnabled | Enables the specified virtual device..
PrlVmDev_SetFriendlyName | Sets virtual device user-friendly name.
PrlVmDev_SetIfaceType | Sets the virtual device interface type (IDE or SCSI).
PrlVmDev_SetImagePath | Sets the virtual device image path.
PrlVmDev_SetIndex | Sets an index identifying the virtual device.
PrlVmDev_SetOutputFile | Sets the virtual device output file.
PrlVmDev_SetPassthrough | Enables the passthrough mode for the specified mass storage device (optical ot hard disk).
PrlVmDev_SetRemote | Changes the "remote" flag for the specified device.
PrlVmDev_SetStackIndex | Sets the virtual device stack index (position at the IDE or SCSI controller bus).
PrlVmDev_SetSysName | Sets virtual device system name.
PrlVmDevHd_AddPartition | Assigns a boot camp partition to the specified virtual hard disk.
PrlVmDevHd_GetDiskSize | Returns the hard disk size.
PrlVmDevHd_GetDiskType | Returns the hard disk type.
PrlVmDevHd_GetPartition | Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.
PrlVmDevHd_GetPartitionsCount | Determines the number of partitions on the virtual hard disk.
PrlVmDevHd_GetSizeOnDisk | Returns the size of the occupied space on the hard disk.
PrlVmDevHd_IsSplitted | Determines if the virtual hard disk is split into multiple files.
PrlVmDevHd_SetDiskSize | Sets the size of the specified virtual hard disk.
PrlVmDevHd_SetDiskType | Sets the type of the specified virtual hard disk.
PrlVmDevHd_SetSplitted | Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.
PrlVmDevHdPart_GetSysName | Returns the system name of the specified disk partition.
PrlVmDevHdPart_Remove | Removes the specified partition handle from the virtual hard disk list.
PrlVmDevHdPart_SetSysName | Sets system name for the specified disk partition.
PrlVmDevNet_GenerateMacAddr | Generates a unique MAC address for a virtual network adapter on a virtual machine.
PrlVmDevNet_GetBoundAdapterIndex | Returns the index of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetBoundAdapterName | Returns the name of the adapter to which the specified virtual adapter is bound.
PrlVmDevNet_GetDefaultGateway | Obtains the default gateway assigned to a virtual network adapter in a virtual machine.
PrlVmDevNet_GetDnsServers | Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetMacAddress | Returns the MAC address of a virtual network adapter inside a virtual machine.
PrlVmDevNet_GetNetAddresses | Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_GetSearchDomains | Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.
PrlVmDevNet_IsConfigureWithDhcp | Determines if the specified network adapter is configured through DHCP on the guest OS side.
PrlVmDevNet_SetBoundAdapterIndex | Sets the index of the adapter to which the specified virtual adapter should be bound.
PrlVmDevNet_SetBoundAdapterName | Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.
PrlVmDevNet_SetConfigureWithDhcp | Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.
PrlVmDevNet_SetDefaultGateway | Allows to manually set the default gateway address for a network adapter in a virtual machine.
PrlVmDevNet_SetDnsServers | Allows to manually assign DNS servers to a network adapter in a virtual machine.
PrlVmDevNet_SetMacAddress | Allows to manually set MAC address to a network adapter inside a virtual machine.
PrlVmDevNet_SetNetAddresses | Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.
PrlVmDevNet_SetSearchDomains | Allows to manually assign search domains to a network adapter in a virtual machine.
PrlVmDevSerial_GetSocketMode | Returns the socket mode of a virtual serial port.
PrlVmDevSerial_SetSocketMode | Sets the socket mode for a virtual serial port.
PrlVmDevSound_GetMixerDev | Returns mixer device string for the specified sound device.
PrlVmDevSound_GetOutputDev | Returns output device string for the specified sound device.
PrlVmDevSound_SetMixerDev | Sets mixer device string for the specified sound device.
PrlVmDevSound_SetOutputDev | Sets output device string for the specified sound device.
PrlVmDevUsb_GetAutoconnectOption | Obtains USB controller autoconnect device option.
PrlVmDevUsb_SetAutoconnectOption | Sets USB controller autoconnect device option.
PrlVmGuest_GetNetworkSettings | Obtains network settings of an operating system running on a virtual machine.
PrlVmGuest_Logout | Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.
PrlVmGuest_RunProgram | Executes a program in a virtual machine.
PrlVmGuest_SetUserPasswd | Allows to change the password of a guest operating system user.
PrlVmInfo_GetAccessRights | Obtains a handle of type PHT_ACCESS_RIGHTS.
PrlVmInfo_GetState | Returns the virtual machine state information.
PrlVmInfo_IsInvalid | Determines if the specified virtual machine is invalid.
PrlVmInfo_IsVncServerStarted | Determines whether a VNC server is running for the specified virtual machine.
PrlVmToolsInfo_GetState | Returns the Parallels Tools package state information.
PrlVmToolsInfo_GetVersion | Returns version information of the Parallels Tools package installed in a given virtual machine.
Macros
Name | Description
FROM_PARALLELS_API_VER |
PARALLELS_API_VER | Current Parallels API version.
PARALLELS_API_VER_1 |
PARALLELS_API_VER_2 |
TO_PARALLELS_API_VER |
Links
Functions, Files, Legend, Macros


PrlApi_Init Function

PrlApi_Init Function
PrlApi.h System Functions Example See Also Send Feedback

Initializes Parallels API library.

Syntax
PRL_RESULT PrlApi_Init(
    PRL_UINT32 version
);
File

PrlApi.h

Returns

PRL_RESULT. Possible values:

PRL_ERR_DOUBLE_INIT - library has been already initialized.

PRL_ERR_OUT_OF_MEMORY - not enough memory to initialize the library.

PRL_ERR_API_INCOMPATIBLE - SDK version is incompatible with version in param.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

This function must be called after the dynamic libraries are loaded and before making any of the API calls. Internally, this call creates the internal event-loop and initializes the library state. Before exiting the program, the PrlApi_Deinit function must be called to perform internal library de-initialization.

Version

Library version number. This should be PARALLELS_API_VER.

See Also

PrlApi_Deinit

Example

The following example illustrates how to perform the necessary API library initialization.

The first step is to load the dynamic link library using the SdkWrap_Load function from the supplied wrapper library (SdkWrap is a helper library that contains just two functions for loading and unloading the API dynamic link library; the library is not documented in this guide).

The second step is to initialize the Parallels API using the PrlApi_Init function.

Once the above steps are completed, you are ready to make other API calls, such as PrlSrv_Login and others.

On program exit, you must cal the PrlApi_Deinit function to deinitialize the API, and the SdkWrap_Unload function to unload the dynamic link libraries.

int main(int argc, char* argv[])
{
   // Pick the correct dynamic library depending on the platform.
   #ifdef _WIN_
      #define SDK_LIB_NAME "prl_sdk.dll"
   #elif defined(_LIN_)
      #define SDK_LIB_NAME "libprl_sdk.so"
   #elif defined(_MAC_)
      #define SDK_LIB_NAME "libprl_sdk.dylib"
   #endif

   // Load the dynamic library.
   // If the library cannot be found, try searching for it.
   if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
      PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
   {
      fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
      return -1;
   }

   // Initialize the API.
   PRL_RESULT ret;
   ret = PrlApi_Init(PARALLELS_API_VER);
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Init returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // your program code goes here...

   // Deinitialize the API.
   ret = PrlApi_Deinit();
   if (PRL_FAILED(ret))
   {
      printf("PrlApi_Deinit returned with error (%s)\n",
      PRL_RESULT_TO_STRING(ret));
      return -1;
   }

   // Unload dynamic link libraries.
   SdkWrap_Unload();
   return 0;
}
Links
PrlApi.h, System Functions, Example, See Also


PrlApi_InitEx Function

PrlApi_InitEx Function
PrlApi.h System Functions See Also Send Feedback

This is extended version of PrlApi_Init call that can be used to specify explicitly application mode in which the API library should function.

Syntax
PRL_RESULT PrlApi_InitEx(
    PRL_UINT32 nVersion,
    PRL_APPLICATION_MODE nAppMode,
    PRL_UINT32 nReserved1,
    PRL_UINT32 nReserved2
);
File

PrlApi.h

Parameters

nVersion
Library version number. This should be PARALLELS_API_VER.
nAppMode
API library application mode.
nReserved1
reserved parameter for future purposes.
nReserved2
reserved parameter for future purposes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_DOUBLE_INIT - library has been already initialized.

PRL_ERR_OUT_OF_MEMORY - not enough memory to initialize the library.

PRL_ERR_API_INCOMPATIBLE - SDK version is incompatible with version in param.

PRL_ERR_SUCCESS - operation completed successfully.

See Also

PrlApi_Deinit PrlApi_Init

Links
PrlApi.h, System Functions, See Also


PrlApi_MsgCanBeIgnored Function

PrlApi_MsgCanBeIgnored Function
PrlApi.h System Functions Send Feedback

The PrlApi_MsgCanBeIgnored function allows to evaluate an error code and determine if the error is critical (i.e.

Syntax
PRL_RESULT PrlApi_MsgCanBeIgnored(
    PRL_RESULT nErrCode,
    PRL_BOOL_PTR pbCanBeIgnored
);
File

PrlApi.h

Parameters

nErrCode
Error code to evaluate.
pbCanBeIgnored
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the error is not critical. PBL_FALSE indicates that the error is critical and should be properly handled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

whether it can be ignored).

Links
PrlApi.h, System Functions


PrlApi_RegisterRemoteDevice Function

PrlApi_RegisterRemoteDevice Function
PrlApi.h System Functions Send Feedback

Registers remote devices of specified type

Syntax
PRL_RESULT PrlApi_RegisterRemoteDevice(
    PRL_DEVICE_TYPE device_type,
    PREMOTE_DEVICE_CREATE_HANDLER pCreateHandler,
    PRL_VOID_PTR createCtx,
    PREMOTE_DEVICE_DESTROY_HANDLER pDestroyHandler,
    PREMOTE_DEVICE_COMMAND_HANDLER pCommandHandler
);
File

PrlApi.h

Parameters

device_type
[in] Type of the devices to register as capable to be remote
pCreateHandler
[in] Function that creates remote device instances
createCtx
[in] Context to pass to the REMOTE_DEVICE_CREATE_HANDLER
pDestroyHandler
[in] Function that destroys device instance
pCommandHandler
[in] Function that handles commands to the remote device

Returns

PRL_ERR_SUCCESS - device was registered. Other values means some error

Links
PrlApi.h, System Functions


PrlApi_ScaleImage Function

PrlApi_ScaleImage Function
PrlApi.h System Functions Send Feedback

The PrlApi_ScaleImage scales image and put a new image to a buffer.

Syntax
PRL_RESULT PrlApi_ScaleImage(
    PRL_CONST_VOID_PTR pOriginalImage,
    PRL_UINT32 nOriginalImageSize,
    PRL_IMAGE_FORMAT nFormat,
    PRL_INT32 nQuality,
    PRL_UINT32 nScaleWidth,
    PRL_UINT32 nScaleHeight,
    PRL_VOID_PTR pNewImage,
    PRL_UINT32_PTR pnNewImageSize
);
File

PrlApi.h

Parameters

pOriginalImage
[in] Original image raw data.
nOriginalImageSize
Original image data size.
nFormat
Image format to use.
nQuality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
nScaleWidth
The width of the area to scale (pixels).
nScaleHeight
The height of the area to scale (pixels).
pNewImage
[out] New image raw data.
pnNewImageSize
New image data size. [in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - incorrect image format.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, System Functions


PrlApi_SendRemoteCommand Function

PrlApi_SendRemoteCommand Function
PrlApi.h System Functions Send Feedback
Syntax
PRL_HANDLE PrlApi_SendRemoteCommand(
    PRL_HANDLE hVm,
    PRL_HANDLE hCommand
);
File

PrlApi.h

Links
PrlApi.h, System Functions


PrlApi_SendRemoteDeviceCommand Function

PrlApi_SendRemoteDeviceCommand Function
PrlApi.h System Functions Send Feedback

Sends remote device command to the Virtual Machine.

Syntax
PRL_HANDLE PrlApi_SendRemoteDeviceCommand(
    PRL_HANDLE hCommand
);
File

PrlApi.h

Parameters

hCommand
valid PRL_HANDLE describing Handle to the command

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was specified PRL_ERR_SUCCESS - operation completed successfully other values could also be returned.

Notes

Caller must not dereference hCommand after call. Handle will be dereferenced automatically.

Links
PrlApi.h, System Functions


PrlApi_UnregisterRemoteDevice Function

PrlApi_UnregisterRemoteDevice Function
PrlApi.h System Functions Send Feedback

Unregisters remote device.

Syntax
PRL_RESULT PrlApi_UnregisterRemoteDevice(
    PRL_DEVICE_TYPE device_type
);
File

PrlApi.h

Parameters

device_type
type of the device to unregister,

Returns

PRL_ERR_SUCCESS - device was unregistered. Other values means some error

Remarks

This function will delete any registration done for the device type.

Links
PrlApi.h, System Functions


PrlApiMacro.h

PrlApiMacro.h
Files Send Feedback

PrlApiMacro.h

In some situations we need a complete list of the API library functions to be accessible in one easy step.

Remarks

A good example would be the dynamic loading of the library. It seems like a good idea to keep such a list declared in a single file. This will make the future code support easier. The PrlApiMacro.h file serves this purpose. The following steps illustrate how this file can be used:

  1. Define your own PRL_SDK_WRAP_FOR_EACH_ITERATOR:

#define PRL_SDK_WRAP_FOR_EACH_ITERATOR( method )

  2. Include the PrlApiMacro.h file in your source:

#include "PrlApiMacro.h"

  3. Instantiate the PRL_SDK_WRAP_FOR_EACH( ) macro to execute your specific action for each API method.
Notes

This file contains just a list of names. No static/dynamic type information declared here at all.

Copyright (c ) 2005-2008 Parallels Software International, Inc. All rights reserved. http://www.parallels.com

Links
Files


PrlBootDev_GetIndex Function

PrlBootDev_GetIndex Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Obtains the boot device index.

Syntax
PRL_RESULT PrlBootDev_GetIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32_PTR pnDevIndex
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnDevIndex
[out] A pointer to a variable that receives the device index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device index is a property that, together with device type, is used to uniquely identify a device in the boot priority list of a virtual machine. The index should be the same index the device has in the main virtual machine configuration, which is determined using the PrlVmDev_GetIndex function.

See Also

PrlBootDev_SetIndex

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_GetSequenceIndex Function

PrlBootDev_GetSequenceIndex Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Obtains the boot device sequence index.

Syntax
PRL_RESULT PrlBootDev_GetSequenceIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32_PTR pnSequenceIndex
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnSequenceIndex
[out] A pointer to a variable that receives the device sequence index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The boot device sequence index starts with 0. When a virtual machine is powered on, it will first try to boot from the boot device that has a sequence index of 0. If it cannot boot from the device, it will try to boot from the device with sequence index 1, and so forth.

See Also

PrlBootDev_SetSequenceIndex

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_GetType Function

PrlBootDev_GetType Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Returns the boot device type.

Syntax
PRL_RESULT PrlBootDev_GetType(
    PRL_HANDLE hVmBootDev,
    PRL_DEVICE_TYPE_PTR pnDevType
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pnDevType
[out] A pointer to a variable that receives the device type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device type is a property that, together with device index, is used to uniquely identify a device in the virtual machine boot list. The supported device types are defined in the PRL_DEVICE_TYPE enumeration.

See Also

PrlBootDev_SetType

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_IsInUse Function

PrlBootDev_IsInUse Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Determines whether the boot device is enabled or disabled.

Syntax
PRL_RESULT PrlBootDev_IsInUse(
    PRL_HANDLE hVmBootDev,
    PRL_BOOL_PTR pbInUse
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
pbInUse
[out] Pointer to a variable that receives the result PRL_TRUE indicates that the device is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A boot device can be either enabled or disabled. If a device is disabled, it is ignored during the boot operation. To change the status of a device, use the PrlBootDev_SetInUse function.

See Also

PrlBootDev_SetInUse

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_Remove Function

PrlBootDev_Remove Function
PrlApi.h PHT_BOOT_DEVICE Send Feedback

Removes the boot device from the boot priority list.

Syntax
PRL_RESULT PrlBootDev_Remove(
    PRL_HANDLE hVmBootDev
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function permanently removes a devices from the list. If you would like to temporarily disable a device, use the PrlBootDev_SetInUse function. To add a device back to the list, use PrlVmCfg_CreateBootDev and then call the necessary functions of the PHT_BOOT_DEVICE handle to set the necessary properties.

Links
PrlApi.h, PHT_BOOT_DEVICE


PrlBootDev_SetIndex Function

PrlBootDev_SetIndex Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Sets the boot device index.

Syntax
PRL_RESULT PrlBootDev_SetIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32 nDevIndex
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nDevIndex
The index of the device of interest as it exists in the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Device index is a property that, together with device type, is used to uniquely identify a device in the virtual machine boot priority list. The index must be the same index the device has in the main virtual machine configuration or it will not be recognized during the boot procedure. To obtain a virtual device index from the virtual machine configuration, use the PrlVmDev_GetIndex function.

See Also

PrlBootDev_GetIndex

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_SetInUse Function

PrlBootDev_SetInUse Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Enables or disables the boot device.

Syntax
PRL_RESULT PrlBootDev_SetInUse(
    PRL_HANDLE hVmBootDev,
    PRL_BOOL bInUse
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
bInUse
A boolean value specifying the action type. PRL_TRUE enables a device, PRL_FALSE disables it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A boot device can be enabled or disabled without being removed from the boot device priority list. If the device is disabled, it is ignored during the boot operation. To obtain the current status of a device, use the PrlBootDev_IsInUse function. To permanently remove a device from the list, use the PrlBootDev_Remove function.

See Also

PrlBootDev_IsInUse

PrlBootDev_Remove

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBootDev_SetSequenceIndex Function

PrlBootDev_SetSequenceIndex Function
PrlApi.h PHT_BOOT_DEVICE Example See Also Send Feedback

Assigns a sequence index to a boot device in the boot priority list.

Syntax
PRL_RESULT PrlBootDev_SetSequenceIndex(
    PRL_HANDLE hVmBootDev,
    PRL_UINT32 nSequenceIndex
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nSequenceIndex
The boot sequence index to set for the device. The value of 0 (zero) is the highest boot priority and indicates the first device to boot from. The value of 1 (one) indicates the second device to boot from, and so forth.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The boot device sequence index starts with 0. When a virtual machine is powered on, it will first try to boot from the boot device that has a sequence index of 0. If it cannot boot from the device, it will try to boot from the device with sequence index 1, and so forth.

If you are changing a sequence index for an existing device, this is the only function that you have to call. If you are adding a new boot device to the list, you will have to set all the other properties, including the device index, type, and enabled/disabled flag. Please note that each device in the boot priority list must have a unique sequence index, so if you are modifying a sequence index for an existing device or assigning an index to a new device, you will have to make sure that no two devices have the same index.

See Also

PrlBootDev_GetSequenceIndex

Example
PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);
ret = PrlJob_Wait(hJobBeginEdit, 10000);
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// Modify boot options.
// Set boot device list as follows:
// 0. CD/DVD drive.
// 1. Hard disk.
// 2. Network adapter.
// 3. Floppy disk drive.
//
PRL_UINT32 nDevCount; // Device count.
PRL_HANDLE hDevice;   // A handle to the device.
PRL_DEVICE_TYPE devType; // Device type.

// Get the total number of devices.
ret = PrlVm_GetBootDevCount(hVm, &nDevCount);

// Iterate through the device list.
// Get a handle for each available device.
// Set an index for a device in the boot list.
for (int i = 0; i < nDevCount; ++i)
{
    ret = PrlVm_GetBootDev(hVm, i, &hDevice);
    ret = PrlBootDev_GetType(hDevice, &devType);

    if (devType == PDE_OPTICAL_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 0);
    }
    if (devType == PDE_HARD_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 1);
    }
    else if (devType == PDE_GENERIC_NETWORK_ADAPTER)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 2);
    }
    else if (devType == PDE_FLOPPY_DISK)
    {
        PrlBootDev_SetSequenceIndex(hDevice, 3);
    }
    else
    {
        PrlBootDev_Remove(hDevice);
    }
}

// Commit the changes.
hJobCommit = PrlVm_Commit(hVm);

// Check the results of the commit operation.
ret = PrlJob_Wait(hJobCommit, 10000);
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PrlApi.h, PHT_BOOT_DEVICE, Example, See Also


PrlBootDev_SetType Function

PrlBootDev_SetType Function
PrlApi.h PHT_BOOT_DEVICE See Also Send Feedback

Sets the boot device type.

Syntax
PRL_RESULT PrlBootDev_SetType(
    PRL_HANDLE hVmBootDev,
    PRL_DEVICE_TYPE nDevType
);
File

PrlApi.h

Parameters

hVmBootDev
A handle of type PHT_BOOT_DEVICE identifying the boot device.
nDevType
The device type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or the device has been removed from the boot list.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when adding a device to the boot device priority list. Device type is a property that, together with device index, is used to uniquely identify a device on a virtual machine. When adding a device to the boot priority list, these properties must be set correctly or the device will not be recognized. The supported device types are defined in the PRL_DEVICE_TYPE enumeration.

See Also

PrlBootDev_GetType

Links
PrlApi.h, PHT_BOOT_DEVICE, See Also


PrlBuffer_Free Function

PrlBuffer_Free Function
PrlApi.h PrlBuffer Send Feedback

Frees a buffer allocated by the Parallels API library and returned to the client.

Syntax
PRL_RESULT PrlBuffer_Free(
    PRL_VOID_PTR buffer
);
File

PrlApi.h

Parameters

buffer
A pointer to a buffer to free.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid pointer to the buffer was specified.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

Every time a pointer to a buffer containing the data is returned to the client, it must be freed using this function. Failure to do so will result in memory leaks.

Links
PrlApi.h, PrlBuffer


PrlDbg_EventTypeToString Function

PrlDbg_EventTypeToString Function
PrlApi.h API Debug Functions Send Feedback

Returns a readable string representation of the specified event type.

Syntax
PRL_RESULT PrlDbg_EventTypeToString(
    PRL_EVENT_TYPE event_type,
    PRL_CONST_STR_PTR result
);
File

PrlApi.h

Parameters

event_type
Event type.
result
[out] Event type as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
PrlApi.h, API Debug Functions


PrlDbg_GetHandlesNum Function

PrlDbg_GetHandlesNum Function
PrlApi.h API Debug Functions Send Feedback

The PrlDbg_GetHandlesNum function determines how many handles were instantiated in the API library.

Syntax
PRL_RESULT PrlDbg_GetHandlesNum(
    PRL_UINT32_PTR handles_num,
    PRL_HANDLE_TYPE type
);
File

PrlApi.h

Parameters

handles_num
[out] A pointer to a variable that receives the result.
type
specifies type of handles which instances num necessary to return. If this param has value PHT_ERROR then handle type is ignored and method returns common handles num. Note: using this method in case to get num of handles instances of concrete type may suspends SDK lib functionality on a quite long time.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid (NULL) pointer for storing result was passed PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, API Debug Functions


PrlDbg_HandleTypeToString Function

PrlDbg_HandleTypeToString Function
PrlApi.h API Debug Functions Send Feedback

Returns a readable string representation of the specified handle type.

Syntax
PRL_RESULT PrlDbg_HandleTypeToString(
    PRL_HANDLE_TYPE handle_type,
    PRL_CONST_STR_PTR result
);
File

PrlApi.h

Parameters

handle_type
Handle type.
result
[out] Handle type as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
PrlApi.h, API Debug Functions


PrlDbg_PrlResultToString Function

PrlDbg_PrlResultToString Function
PrlApi.h API Debug Functions Send Feedback

Returns a readable string representation of the PRL_RESULT value.

Syntax
PRL_RESULT PrlDbg_PrlResultToString(
    PRL_RESULT value,
    PRL_CONST_STR_PTR result
);
File

PrlApi.h

Parameters

value
A variable of type PRL_RESULT.
result
[out] The PRL_RESULT value as a string.

Returns

PRL_ERR_SUCCESS

Remarks

Helpful for logging.

Links
PrlApi.h, API Debug Functions


PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To obtain a pointer to a buffer containing the image, use the PrlJob_GetDataPtr function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function

PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_AsyncCaptureScreenRegionToFile Function

PrlDevDisplay_AsyncCaptureScreenRegionToFile Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevDisplay_AsyncCaptureScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevDisplay_SyncCaptureScreenRegionToFile

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_ConnectToVm Function

PrlDevDisplay_ConnectToVm Function
PrlApi.h Primary Display Capture Send Feedback

Connects to a virtual machine to begin a remote desktop access session.

Syntax
PRL_HANDLE PrlDevDisplay_ConnectToVm(
    PRL_HANDLE hVm,
    PRL_DISPLAY_CODEC_TYPE type
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
type
Codec type to be used during the remote desktop screen capture.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function must be called before any other function calls related to the remote desktop access functionality.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_DisconnectFromVm Function

PrlDevDisplay_DisconnectFromVm Function
PrlApi.h Primary Display Capture Send Feedback

Closes the virtual machine connection that was previously established using the PrlDevDisplay_ConnectToVm function call.

Syntax
PRL_RESULT PrlDevDisplay_DisconnectFromVm(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_GetDynResToolStatus Function

PrlDevDisplay_GetDynResToolStatus Function
PrlApi.h Primary Display Capture Send Feedback

Determines whether Dynamic Resolution feature is available in the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_GetDynResToolStatus(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR status
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
status
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that Dynamic Resolution is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Dynamic Resolution is a feature that comes with the Parallels Tools package. It provides facilities for adjusting the guest OS screen resolution on the fly. Use this function to determine whether the Dynamic Resolution feature is installed and running. If the feature is available, you can use the PrlDevDisplay_SendScreenSizeEvent function to programmatically adjust the guest OS screen resolution.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_GetScreenBuffer Function

PrlDevDisplay_GetScreenBuffer Function
PrlApi.h Primary Display Capture Send Feedback

Returns the contents of the screen buffer of the primary display.

Syntax
PRL_RESULT PrlDevDisplay_GetScreenBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32_PTR_PTR buffer,
    PRL_INT32_PTR lineSize
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
buffer
[out] A pointer to a buffer that receives the data. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.
lineSize
Line size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that the primary screen buffer can be refreshed at any time from inside the virtual machine. To prevent incomplete or corrupt data, use the PrlDevDisplay_LockForRead function to temporarily suspend refreshing of the screen on the virtual machine side. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_GetScreenSize Function

PrlDevDisplay_GetScreenSize Function
PrlApi.h Primary Display Capture Send Feedback

Returns the primary display screen size of the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_GetScreenSize(
    PRL_HANDLE hVm,
    PRL_IO_SCREEN_SIZE_PTR size
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
size
[out] A pointer to a structure containing the screen size properties.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_IsSlidingMouseEnabled Function

PrlDevDisplay_IsSlidingMouseEnabled Function
PrlApi.h Primary Display Capture Send Feedback

Determines if Sliding Mouse feature is enabled in the specified virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_IsSlidingMouseEnabled(
    PRL_HANDLE hVm,
    PRL_BOOL_PTR flag
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
flag
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that sliding mouse is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Sliding Mouse is a feature that comes with Parallels Tools package. If Sliding Mouse is enabled, the mouse cursor can "slide" from the virtual machine desktop to the host OS desktop without pressing any of the special keys on the keyboard. This function is used when writing remote desktop applications with graphical user interfaces. For more information, see the Mouse Control section in this chapter.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_LockForRead Function

PrlDevDisplay_LockForRead Function
PrlApi.h Primary Display Capture Send Feedback

Locks the primary screen buffer disallowing any updates to the data it contains.

Syntax
PRL_RESULT PrlDevDisplay_LockForRead(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When you obtain a screen capture, you should call this function first to prevent all further updates to the screen buffer. This is done in order to minimize the local machine resource usage, to speed up the screen buffer read operations, and to prevent possible data loss. To obtain the data from the buffer, use the PrlDevDisplay_GetScreenBuffer function. When you are done reading the data, call the PrlDevDisplay_Unlock to remove the lock.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_NeedCursorData Function

PrlDevDisplay_NeedCursorData Function
PrlApi.h Primary Display Capture Send Feedback

The PrlDevDisplay_NeedCursorData function allows to obtain cursor data from the virtual machine.

Syntax
PRL_RESULT PrlDevDisplay_NeedCursorData(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function sends a request to the virtual machine and immediately returns. The data is received as a PHT_EVENT handle via callback.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_SendCaptureScreenRequest Function

PrlDevDisplay_SendCaptureScreenRequest Function
PrlApi.h Primary Display Capture Send Feedback

Sends a request to capture the specified screen region of the specified virtual machine on a periodic basis.

Syntax
PRL_RESULT PrlDevDisplay_SendCaptureScreenRequest(
    PRL_HANDLE hVm,
    const PRL_IO_SCREEN_REGION_PTR pRect
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pRect
Parameters of the screen region to capture. If negative rectangle is passed, cancellation request will be send.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The screen data is received as an event via callback every time the specified screen region data is modified. This function is used when an efficient optimization of the screen update on the client side is needed.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_SendScreenSizeEvent Function

PrlDevDisplay_SendScreenSizeEvent Function
PrlApi.h Primary Display Capture Send Feedback

Sends a request to a virtual machine to adjust the screen resolution of the guest OS to specified values.

Syntax
PRL_RESULT PrlDevDisplay_SendScreenSizeEvent(
    PRL_HANDLE hVm,
    const PRL_IO_SCREEN_SIZE_PTR size
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
size
The new screen resolution parameters.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The guest OS can accept or reject the new resolution depending on compatibility factors. The function does not provide information on whether the new resolution was accepted or not. The PRL_ERR_SECCESS return code means that the function didn't fail but it doesn't mean that the screen resolution was actually changed. To verify the results of the operation, you can capture the guest OS screen before and after executing this function and compare the results. You can use this function only if the Parallels Tools package is installed in the target virtual machine and if the Dynamic Resolution feature is turned on. To determine the status of the Dynamic Resolution feature, use the PrlDevDisplay_GetDynResToolStatus function.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_SetScreenSurface Function

PrlDevDisplay_SetScreenSurface Function
PrlApi.h Primary Display Capture Send Feedback

Sets CoreGraphics surface for fast server-side display updates.

Syntax
PRL_RESULT PrlDevDisplay_SetScreenSurface(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_UINT32 windowId,
    PRL_UINT32 surfaceId,
    PRL_INT32 scrollX,
    PRL_INT32 scrollY,
    PRL_UINT32 width,
    PRL_UINT32 height
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID.
windowId
Window ID.
surfaceId
Surface ID.
scrollX
X coordinate value.
scrollY
Y coordinate value.
width
Width.
height
Height.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function applies to Mac OS X local clients only.

Links
PrlApi.h, Primary Display Capture


PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function

PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_VOID_PTR_PTR buff,
    PRL_UINT32_PTR buffSize,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
buff
[out] A pointer to a buffer containing the screen data. The buffer must be freed with PrlBuffer_Free when no longer needed.
buffSize
The size of the buffer received in the buff parameter (above).
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScaledScreenRegionToBuffer

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function

PrlDevDisplay_SyncCaptureScaledScreenRegionToFile Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScreenRegionToFile. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_SyncCaptureScreenRegionToFile Function

PrlDevDisplay_SyncCaptureScreenRegionToFile Function
PrlApi.h Primary Display Capture See Also Send Feedback

Captures a screen area of a remote virtual machine desktop and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevDisplay_SyncCaptureScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time. This synchronous function is an equivalent of the asynchronous function PrlDevDisplay_AsyncCaptureScreenRegionToFile. You can use either function in your programs depending on your application needs.

See Also

PrlDevDisplay_AsyncCaptureScreenRegionToFile

Links
PrlApi.h, Primary Display Capture, See Also


PrlDevDisplay_Unlock Function

PrlDevDisplay_Unlock Function
PrlApi.h Primary Display Capture Send Feedback

Unlocks the virtual machine screen buffer that was previously locked with the PrlDevDisplay_LockForRead function call.

Syntax
PRL_RESULT PrlDevDisplay_Unlock(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Primary Display Capture


PrlDevKeyboard_SendKeyEvent Function

PrlDevKeyboard_SendKeyEvent Function
PrlApi.h Keyboard Control Send Feedback

Sends a keyboard key event to a virtual machine.

Syntax
PRL_RESULT PrlDevKeyboard_SendKeyEvent(
    PRL_HANDLE hVm,
    PRL_UINT32 key,
    PRL_KEY_EVENT ev
);
File

PrlApi.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the virtual machine.
key
Key code. See the PrlKeys.h file for the list of the available key codes.
ev
Event type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To send a single key-pressed event, first call this function passing the desired key code and PKE_PRESS as the event type. Then call the function again passing the same key code and PKE_RELEASE as the event type. To send a key combination event, first call the function passing the code of the first key (usually a modifier key, such as Ctrl, Shift, Alt) and PKE_PRESS as the event type. Then call the function passing the code of the second key with PKE_PRESS. Continue with other keys (if more than two). Then call the function in reverse order for each key passing PKE_RELEASE as the event type.

Links
PrlApi.h, Keyboard Control


PrlDevMouse_Move Function

PrlDevMouse_Move Function
PrlApi.h Mouse Control Send Feedback

Moves a mouse pointer to a relative position and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_Move(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_UINT32 buttons
);
File

PrlApi.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate offset.
y
Y coordinate offset.
z
Z coordinate offset (scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools are NOT installed in the target virtual machine. The position to which you want to move the pointer is always calculated relatively to the center of the screen (as if the center had coordinates X=0; Y=0). When a virtual machine powers up, the cursor in it is automatically positioned at the center of the screen. To move the cursor to the desired absolute coordinates within the virtual machine screen coordinate grid, calculate the offset of the destination point relatively to the center of the virtual machine screen and pass those values to this function as X and Y coordinates. Use positive values when moving the cursor right or down, use negative values when moving the cursor left or up.

Links
PrlApi.h, Mouse Control


PrlDevMouse_SetPos Function

PrlDevMouse_SetPos Function
PrlApi.h Mouse Control Send Feedback

Moves a mouse pointer to the specified absolute position within the virtual machine display coordinate grid and sends a mouse event (presses or releases the specified button).

Syntax
PRL_RESULT PrlDevMouse_SetPos(
    PRL_HANDLE hVm,
    PRL_INT32 x,
    PRL_INT32 y,
    PRL_INT32 z,
    PRL_UINT32 buttons
);
File

PrlApi.h

Parameters

hVm
A handle of type of PHT_VIRTUAL_MACHINE identifying the machine.
x
X coordinate to move the mouse pointer to.
y
Y coordinate to move the mouse pointer to.
z
Z coordinate to mouse pointer to (scroll).
buttons
Mouse button identifier. See the PRL_MOUSE_BUTTON enumeration for available choices. The values can be combined using the binary OR operator |. To press a button, specify the value identifying the button. To release a button, specify PMB_NOBUTTON. To move the mouse pointer without pressing any buttons, specify PMB_NOBUTTON.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can only be used if Parallels Tools package is installed in the target virtual machine and if Sliding Mouse feature is enabled. To find out if Sliding Mouse is enabled, use the PrlDevDisplay_IsSlidingMouseEnabled function.

Links
PrlApi.h, Mouse Control


PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function

PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer Function
PrlApi.h Secondary Display Capture See Also Send Feedback

Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and puts it into a buffer.

Syntax
PRL_HANDLE PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, etc.)
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To obtain a pointer to a buffer containing the image, use the PrlJob_GetDataPtr function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer

Links
PrlApi.h, Secondary Display Capture, See Also


PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function

PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile Function
PrlApi.h Secondary Display Capture See Also Send Feedback

Captures a screen area of a secondary display of a remote virtual machine, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_HANDLE PrlDevSecondaryDisplay_AsyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, etc.)
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the screen area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile

Links
PrlApi.h, Secondary Display Capture, See Also


PrlDevSecondaryDisplay_GetScreenBuffer Function

PrlDevSecondaryDisplay_GetScreenBuffer Function
PrlApi.h Secondary Display Capture Send Feedback

Returns the contents of the screen buffer of the secondary display.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_UINT32_PTR_PTR buffer,
    PRL_INT32_PTR lineSize
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, etc.)
buffer
[out] A pointer to a buffer that receives the screen data. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.
lineSize
Line size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that the primary screen buffer can be refreshed at any time from inside the virtual machine. To prevent incomplete or corrupt data, use the PrlDevDisplay_LockForRead function to temporarily suspend refreshing of the screen on the virtual machine side. The screen data is always returned as 32-bit RGBA with the alpha channel containing the value of 0.

Links
PrlApi.h, Secondary Display Capture


PrlDevSecondaryDisplay_GetScreenSize Function

PrlDevSecondaryDisplay_GetScreenSize Function
PrlApi.h Secondary Display Capture Send Feedback

Returns the primary display screen size of the specified virtual machine.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_GetScreenSize(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_IO_DISPLAY_SCREEN_SIZE_PTR size
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
size
[out] A pointer to a structure containing the screen size properties.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Secondary Display Capture


PrlDevSecondaryDisplay_SendCaptureScreenRequest Function

PrlDevSecondaryDisplay_SendCaptureScreenRequest Function
PrlApi.h Secondary Display Capture Send Feedback

Sends a request to capture the specified screen region of the secondary display of the specified virtual machine on a periodic basis.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SendCaptureScreenRequest(
    PRL_HANDLE hVm,
    const PRL_IO_DISPLAY_SCREEN_REGION_PTR pRect
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
pRect
Parameters of the screen region to capture. If negative rectangle is passed, cancellation request will be send.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The screen data is received as an event via callback every time the specified screen region data is modified. This function is used when an efficient optimization of the screen update on the client side is needed.

Links
PrlApi.h, Secondary Display Capture


PrlDevSecondaryDisplay_SendScreenSizeEvent Function

PrlDevSecondaryDisplay_SendScreenSizeEvent Function
PrlApi.h Secondary Display Capture Send Feedback

Sends a request to a virtual machine to adjust the screen resolution of the secondary display of the guest OS to specified values.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SendScreenSizeEvent(
    PRL_HANDLE hVm,
    const PRL_IO_DISPLAY_SCREEN_SIZE_PTR size
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
size
The new screen resolution parameters.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The guest OS can accept or reject the new resolution depending on compatibility factors. The function does not provide information on whether the new resolution was accepted or not. The PRL_ERR_SECCESS return code means that the function didn't fail but it doesn't mean that the screen resolution was actually changed. To verify the results of the operation, you can capture the guest OS screen before and after executing this function and compare the results. You can use this function only if the Parallels Tools package is installed in the target virtual machine and if the Dynamic Resolution feature is turned on. To determine the status of the Dynamic Resolution feature, use the PrlDevDisplay_GetDynResToolStatus function.

Links
PrlApi.h, Secondary Display Capture


PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer Function

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer Function
PrlApi.h Secondary Display Capture Send Feedback

Captures a screen area of a secondary display of a remote virtual machine desktop, scales is down to the specified size, and puts it into a buffer which is then returned to the client.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToBuffer(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_VOID_PTR_PTR buff,
    PRL_UINT32_PTR buffSize,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
buff
[out] A pointer to a buffer containing the screen data. The buffer must be freed with PrlBuffer_Free when no longer needed.
buffSize
The size of the buffer received in the buff parameter (above).
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the screen area to capture.
y
The Y coordinate of the upper-left corner of the screen area to capture.
width
The width of the screen area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, in pixels.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

Links
PrlApi.h, Secondary Display Capture


PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile Function

PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile Function
PrlApi.h Secondary Display Capture Send Feedback

Captures a screen area of a remote virtual machine desktop, scales is down to the specified size, and saves it to a file on the client machine.

Syntax
PRL_RESULT PrlDevSecondaryDisplay_SyncCaptureScaledScreenRegionToFile(
    PRL_HANDLE hVm,
    PRL_UINT32 display,
    PRL_CONST_STR fileName,
    PRL_IMAGE_FORMAT format,
    PRL_INT32 quality,
    PRL_UINT32 x,
    PRL_UINT32 y,
    PRL_UINT32 width,
    PRL_UINT32 height,
    PRL_UINT32 scaleWidth,
    PRL_UINT32 scaleHeight
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
display
Display ID (0 for primary display, 1, 2, 3, etc.)
fileName
Name and path of the file to save the image to.
format
Image format to use.
quality
Image quality factor. Must be in the range from 0 to 100, or -1. Specify 0 to use the highest data compression, 100 for no compression, and -1 for default.
x
The X coordinate of the upper-left corner of the area to capture.
y
The Y coordinate of the upper-left corner of the area to capture.
width
The width of the area to capture, in pixels.
height
The height of the area to capture, in pixels.
scaleWidth
The width of the scaled down image, in pixels.
scaleHeight
The height of the scaled down image, pixels

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

For local connections, the capture works almost instantly. For remote connections, the data must be transferred over network to the client machine, so it may take some time.

Links
PrlApi.h, Secondary Display Capture


PrlDisk_Coagulate Function

PrlDisk_Coagulate Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Merges all snapshots.

Syntax
PRL_RESULT PrlDisk_Coagulate(
    const PRL_HANDLE Handle,
    const PRL_STATES_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskCallback
Callback to signal progress/completion. If it is equal to NULL function will not return until completion.
pParameter
Callback parameter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_Compact Function

PrlDisk_Compact Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Compacts a virtual disk.

Syntax
PRL_RESULT PrlDisk_Compact(
    const PRL_HANDLE Handle,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual disk may become fragmented just like a physical disk. As a result, the size that the disk files occupy on the host's hard drive may be larger than the size of the actual data they contain. The PrlDisk_Compact function defragments the specified virtual disk and decreases the size that the virtual disk files occupy on the physical hard disk. The size of the virtual disk itself (if it is an expanding disk) remains unchanged.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_ConvertToCurrent Function

PrlDisk_ConvertToCurrent Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Converts pre-Atlantis disk to Sumer and later.

Syntax
PRL_RESULT PrlDisk_ConvertToCurrent(
    PRL_CONST_STR pDiskName
);
File

PrlDisk.h

Parameters

pDiskName
File name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_ConvertToCurrent_Local Function

PrlDisk_ConvertToCurrent_Local Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Converts pre-Atlantis disk to Sumer and later.

Syntax
PRL_RESULT PrlDisk_ConvertToCurrent_Local(
    PRL_CONST_STR pDiskName
);
File

PrlDisk.h

Parameters

pDiskName
File name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function can be used locally without a Parallels Service connection.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_CreateDisk Function

PrlDisk_CreateDisk Function
PrlDisk.h PHT_VIRTUAL_DISK See Also Send Feedback

Creates a new virtual disk.

Syntax
PRL_RESULT PrlDisk_CreateDisk(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pCallback,
    PRL_CONST_VOID_PTR pAdditional
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the new virtual disk.
pDiskName
Virtual disk name in UTF-8 format.
pParams
Virtual disk configuration parameters.
pCallback
A pointer to a callback function or NULL pointer. This parameter allows to call the function asynchronously. If this parameter contains a pointer to a user-implemented callback function, the PrlDisk_CreateDisk function will return immediately and the operation will continue in the background thread. The background thread will be calling the callback function passing the operation progress information to it. See PRL_DISK_CALLBACK for more information. Using a callback might be helpful when the disk creation is expected to take a long time. For example, you may want to use a callback when you are creating a large disk and allocating all space for it right away.

If this parameter contains a NULL pointer, the function will be called synchronously.

pAdditional
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function creates a new virtual disk and obtains a handle of type PHT_VIRTUAL_DISK identifying the new disk. The handle can then be used to perform other operations on the disk if necessary (see other functions from this group). To use this function you must be connected to the Parallels Service. If you are creating a new virtual disk locally, you can use the PrlDisk_CreateDisk_Local function which doesn't require the Parallels Service connection.

See Also

PrlDisk_CreateDisk_Local

Links
PrlDisk.h, PHT_VIRTUAL_DISK, See Also


PrlDisk_CreateDisk_Local Function

PrlDisk_CreateDisk_Local Function
PrlDisk.h PHT_VIRTUAL_DISK See Also Send Feedback

This function can be used to create a new virtual disk locally without being connected to the Parallels Service.

Syntax
PRL_RESULT PrlDisk_CreateDisk_Local(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pCallback,
    PRL_CONST_VOID_PTR pAdditional
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the new virtual disk.
pDiskName
Disk name in UTF-8 format.
pParams
Disk configuration parameters.
pCallback
A pointer to a callback function or NULL pointer. This parameter allows to call the function asynchronously. If this parameter contains a pointer to a user-implemented callback function, the PrlDisk_CreateDisk function will return immediately and the operation will continue in the background thread. The background thread will be calling the callback function passing the operation progress information to it. See PRL_DISK_CALLBACK for more information. Using a callback might be helpful when the disk creation is expected to take a long time. For example, you may want to use a callback when you are creating a large disk and allocating all space for it right away.

If this parameter contains a NULL pointer, the function will be called synchronously.

pAdditional
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function creates a new virtual disk and obtains a handle of type PHT_VIRTUAL_DISK identifying the new disk. The handle can then be used to perform other operations on the disk if necessary (see other functions from this group). If you would like to create a new virtual disk on a remote host, use the PrlDisk_CreateDisk function.

See Also

PrlDisk_CreateDisk

Links
PrlDisk.h, PHT_VIRTUAL_DISK, See Also


PrlDisk_CreateState Function

PrlDisk_CreateState Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Start creation procedure of the new state

Syntax
PRL_RESULT PrlDisk_CreateState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name (ignored now).
pUid
New state UID.
pCallback
Callback to signal progress/completion, if it is equal to NULL function will not return until completion.
pParameter
Callback parameter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_DecreaseCapacity Function

PrlDisk_DecreaseCapacity Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Allows to decrease the size of an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_DecreaseCapacity(
    const PRL_HANDLE Handle,
    const PRL_UINT64 uiSize,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
uiSize
New overall disk size in sectors.
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Depending on the new size (the value of the uiSize parameter), the size of the last storage in the virtual disk storage list will be adjusted or one (or more) storages will be deleted from the end of the list.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_DeleteState Function

PrlDisk_DeleteState Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Start delete state procedure.

Syntax
PRL_RESULT PrlDisk_DeleteState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_BOOL bMerge,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name (ignored now).
pUid
UID of the state to delete.
bMerge
Merge snapshot or pure delete.
pCallback
Callback to signal progress/completion, if it is equal to NULL function will not return until completion.
pParameter
Callback parameter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_FlushCache Function

PrlDisk_FlushCache Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Writes data from a virtual disk cache to the real storage.

Syntax
PRL_RESULT PrlDisk_FlushCache(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_Free Function

PrlDisk_Free Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

This method is used to free the disk reference with closing.

Syntax
PRL_RESULT PrlDisk_Free(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - operation completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_GetDiskInfo Function

PrlDisk_GetDiskInfo Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Get disk information.

Syntax
PRL_RESULT PrlDisk_GetDiskInfo(
    const PRL_HANDLE Handle,
    PRL_DISK_PARAMETERS_PTR pDiskParameters,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskParameters
[out] Pointer to the result.
BufferSize
[in] [out] Pointer to parameter value buffer size, if specified size is lower than needed, here will be returned corrected size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_GetSnapshotsCount Function

PrlDisk_GetSnapshotsCount Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Get snapshots count.

Syntax
PRL_RESULT PrlDisk_GetSnapshotsCount(
    const PRL_HANDLE Handle,
    PRL_UINT32_PTR SnapshotsCount
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
SnapshotsCount
[out] Pointer to the variable to receive count of the shots on disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_GetSnapshotsTree Function

PrlDisk_GetSnapshotsTree Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Get snapshots tree.

Syntax
PRL_RESULT PrlDisk_GetSnapshotsTree(
    const PRL_HANDLE Handle,
    PRL_SNAPSHOT_ELEMENT_PTR pSnapshotTree,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pSnapshotTree
[out] Pointer to the result buffer.
BufferSize
[in] [out] Pointer to parameter value buffer size, if specified size is lower than needed, here will be returned corrected size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_GetUserParameter Function

PrlDisk_GetUserParameter Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Get user parameter for disk.

Syntax
PRL_RESULT PrlDisk_GetUserParameter(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pParameterName,
    PRL_CHAR_PTR pParameterValue,
    PRL_UINT32_PTR BufferSize
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParameterName
Parameter name in UTF-8 format.
pParameterValue
[out] Pointer to parameter value buffer.
BufferSize
[in] [out] Pointer to parameter value buffer size, if specified size is lower than needed, here will be returned corrected size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk.h

PrlDisk.h
Functions Files Legend Macros Structures Types Send Feedback

PrlDITypes.h

SDK Disk image types

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Functions
Name | Description
PrlDisk_Coagulate | Merges all snapshots.
PrlDisk_Compact | Compacts a virtual disk.
PrlDisk_ConvertToCurrent | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_ConvertToCurrent_Local | Converts pre-Atlantis disk to Sumer and later.
PrlDisk_CreateDisk | Creates a new virtual disk.
PrlDisk_CreateDisk_Local | This function can be used to create a new virtual disk locally without being connected to the Parallels Service.
PrlDisk_CreateState | Start creation procedure of the new state
PrlDisk_DecreaseCapacity | Allows to decrease the size of an existing virtual disk.
PrlDisk_DeleteState | Start delete state procedure.
PrlDisk_FlushCache | Writes data from a virtual disk cache to the real storage.
PrlDisk_Free | This method is used to free the disk reference with closing.
PrlDisk_GetDiskInfo | Get disk information.
PrlDisk_GetSnapshotsCount | Get snapshots count.
PrlDisk_GetSnapshotsTree | Get snapshots tree.
PrlDisk_GetUserParameter | Get user parameter for disk.
PrlDisk_IncreaseCapacity | Allows to increase the size of an existing virtual disk.
PrlDisk_IsCompactable | Check is image compactable.
PrlDisk_OpenDisk | Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.
PrlDisk_OpenDisk_Local | Method let to open disk and return handle This function can be used locally, without a Parallels Service connection.
PrlDisk_Read | Write data to disk.
PrlDisk_SetCachingPolicy | Set caching policy for disk.
PrlDisk_SetSharedDirectory | Set shared directory (all files created somewhere in this directory will have 666 permissions).
PrlDisk_SetSharedDirectory_Local | Set shared directory (all files created somewhere in this directory will have 666 permissions) This function can be used locally, without a Parallels Service connection.
PrlDisk_SetUserParameter | Set user parameter for disk.
PrlDisk_SwitchToState | Start switching to state procedure.
PrlDisk_WaitForCompletion | Wait for completion of the work.
PrlDisk_Write | Write data to disk.
Macros
Name
Description
PRL_BSD_PARTITION
Free BSD partition.
PRL_DATA_PARTITION
Special handle for data partition from GPT (can be linux, windows, any type).
PRL_DISK_CACHE_DEFAULT
Disk cache default.
PRL_DISK_CACHE_DISABLED
Uncached access to disk image.
PRL_DISK_CACHE_ENABLED
Cached access to disk image.
PRL_DISK_CACHE_UNCACHED_READ
Cached write/uncached read.
PRL_DISK_DEFAULT_FLAG
Default (writelock always on at write on).
PRL_DISK_FAKE_OPEN
Fake open, just for parameters get (processed by real disks that need administrative privileges to work with).
PRL_DISK_FOPS_DEFAULT
Default access mode that compiled in Parallels itself.
PRL_DISK_FOPS_MASK
Type of the file access to use (15 file accessors is enough).
PRL_DISK_FOPS_MERGING
Access mode with requests merging.
PRL_DISK_FOPS_NONCACHED
Access mode with file caching turned off.
PRL_DISK_FOPS_NORMAL
Normal access mode (default os)
PRL_DISK_INVALID
Last (invalid).
PRL_DISK_NOTHING
Nothing.
PRL_DISK_PROGRESS_COMPLETED
PRL_DISK_PROGRESS_MAX
PRL_DISK_PROGRESS_MIN
States progress definition.
PRL_DISK_READ
Read
PRL_DISK_READ_LOCK
ReadLock
PRL_DISK_WRITE
Write
PRL_DISK_WRITE_THROUGH
Write through, disable caching
PRL_DISK_XML_CHANGE
This parameter is used when user need to change XML data but not access to the drive itself.
PRL_EFI_PARTITION
PRL_EFI_PARTITION_GPT
EFI system partition
PRL_EMPTY_PARTITION
PRL_IMAGE_BOOTCAMP
Bootcamp
PRL_IMAGE_COMPRESSED
Compressed disk (version 1)
PRL_IMAGE_COMPRESSED_V2
Compressed disk (version 2)
PRL_IMAGE_INVALID
Invalid type
PRL_IMAGE_LAST_INVALID
Last (invalid)
PRL_IMAGE_PARTITION
Partition from disk
PRL_IMAGE_PHYSICAL
Real disk (full)
PRL_IMAGE_PLAIN
Plain disk
PRL_IMAGE_TRY_GUESS
Software should guess what kind of disk it is
PRL_INVALID_PARTITION
Invalid partition
PRL_LINUX_EXTENDED_PARTITION
PRL_LINUX_PARTITION_DATA
PRL_LINUX_PARTITION_SWAP
Linux partitions
PRL_MACOS_PARTITION
Mac OS
PRL_MSDOS_EXTENDED_PARTITION

  • Disk partition types

Extended partitions

PRL_STATE_CALLBACK_INVALID
Invalid callback
PRL_STATE_CORE_FIRST_COMPLETE_CALLBACK
Core callback completed
PRL_STATE_CORE_FULL_COMPLETE_CALLBACK
Operation fully completed
PRL_STATE_CORE_START_DISK_PROCESS_CALLBACK
Disk operation started
PRL_STATE_DISK_CALLBACK
Ordinary callback that disk process going.
PRL_STATE_DISK_CALLBACK_STAGE_CPL
At remove all states this callback indicates that one more stage complete in states removal
PRL_STATE_PROGRESS_COMPLETED
PRL_STATE_PROGRESS_MAX
PRL_STATE_PROGRESS_MIN
States progress definition
PRL_WIN_EXTENDED_PARTITION
PRL_WINDOWS_PARTITION_FAT
PRL_WINDOWS_PARTITION_FAT32
PRL_WINDOWS_PARTITION_FAT32_LBA
PRL_WINDOWS_PARTITION_NTFS
Windows partitions
Structures
Name | Description
__PRL_DISK_PARAMETERS | Parallels disk parameters.
__PRL_IMAGE_PARAMETERS | Parallels storage parameters
__PRL_SNAPSHOT_ELEMENT | Parallels snapshot tree element
PRL_DISK_PARAMETERS | Parallels disk parameters.
PRL_IMAGE_PARAMETERS | Parallels storage parameters
PRL_SNAPSHOT_ELEMENT | Parallels snapshot tree element
Types
Name | Description
PRL_CONST_DISK_OPEN_FLAGS_PTR |
PRL_CONST_DISK_PARAMETERS_PTR |
PRL_CONST_SNAPSHOT_ELEMENT_PTR |
PRL_DISK_OPEN_FLAGS | Storage/image/disk open parameters
PRL_DISK_OPEN_FLAGS_PTR |
PRL_DISK_PARAMETERS_PTR |
PRL_IMAGE_PARAMETERS_PTR |
PRL_IMAGE_TYPE | Parallels images types
PRL_IMAGE_TYPE_PTR |
PRL_SNAPSHOT_ELEMENT_PTR |
PRL_STATES_CALLBACK_TYPE | Saved states callback types @author antonz@
PRL_STATES_CALLBACK_TYPE_PTR |
Links
Functions, Files, Legend, Macros, Structures, Types


PrlDisk_IncreaseCapacity Function

PrlDisk_IncreaseCapacity Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Allows to increase the size of an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_IncreaseCapacity(
    const PRL_HANDLE Handle,
    PRL_CONST_DISK_PARAMETERS_PTR pParams,
    const PRL_DISK_CALLBACK pDiskCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParams
Virtual disk parameters (see Remarks below).
pDiskCallback
A pointer to a callback function or NULL pointer. If the parameter contains a pointer to a callback, the function will be called asynchronously. If it contains NULL pointer, the function will be called synchronously.
pParameter
A pointer to a buffer containing user-defined data to pass to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Disk size can be increased by adding a new storage to its configuration or by increasing the size of an existing storage (only the size of the last storage in the storage list can be modified). A virtual disk can be comprised of one or more storages, which are logical portions of the entire disk. Each storage is contained in a separate file on the host's physical hard drive. All storages are logically connected in a particular order.

To increase the overall disk capacity, a new storage can be added at the end. In order to do that, the members of the PRL_DISK_PARAMETERS structure that you pass in the pParam parameter must contain the following values:

  • m_Parts The number of storages to add (if adding one storage, pass 1).
  • m_Storages A pointer to an array of PRL_IMAGE_PARAMETERS structures. If adding a single storage, pass a pointer to a single structure. The uSize member of the structure must contain the new storage size. The Type member can be either PRL_IMAGE_PLAIN or PRL_IMAGE_COMPRESSED depending on your preferences.
Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_IsCompactable Function

PrlDisk_IsCompactable Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Check is image compactable.

Syntax
PRL_RESULT PrlDisk_IsCompactable(
    const PRL_HANDLE Handle,
    PRL_BOOL_PTR Result
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
Result
[out] Pointer to the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_OpenDisk Function

PrlDisk_OpenDisk Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Obtains a handle of type PHT_VIRTUAL_DISK identifying an existing virtual disk.

Syntax
PRL_RESULT PrlDisk_OpenDisk(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    const PRL_DISK_OPEN_FLAGS OpenFlags,
    PRL_CONST_VOID_PTR pAdditionalFlags
);
File

PrlDisk.h

Parameters

pHandle
[out] A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskName
The disk name for which to obtain the handle, in UTF-8 format. Disk name is the same as the bundle name (Mac) or the directory name (Windows, Linux) containing the virtual disk files.
OpenFlags
Disk open parameters. See PRL_DISK Macros for available options.
pAdditionalFlags
Additional flags (not currently used).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you want to view or modify the configuration of an existing virtual disk. Once you obtain the disk handle, use its functions to perform the desired disk manipulations.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_OpenDisk_Local Function

PrlDisk_OpenDisk_Local Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Method let to open disk and return handle This function can be used locally, without a Parallels Service connection.

Syntax
PRL_RESULT PrlDisk_OpenDisk_Local(
    PRL_HANDLE_PTR pHandle,
    PRL_CONST_STR pDiskName,
    const PRL_DISK_OPEN_FLAGS OpenFlags,
    PRL_CONST_VOID_PTR pAdditionalFlags
);
File

PrlDisk.h

Parameters

pHandle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDiskName
File name in UTF-8 format.
OpenFlags
Disk open parameters.
pAdditionalFlags
Additional flags.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_Read Function

PrlDisk_Read Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Write data to disk.

Syntax
PRL_RESULT PrlDisk_Read(
    const PRL_HANDLE Handle,
    PRL_VOID_PTR pBlock,
    const PRL_UINT32 uiSize,
    const PRL_UINT64 uiBlockOffset
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pBlock
Pointer to sector/page aligned data to write (depends from host OS).
uiSize
Size of data to write.
uiBlockOffset
Offset of the block on the disk in sectors.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_SetCachingPolicy Function

PrlDisk_SetCachingPolicy Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Set caching policy for disk.

Syntax
PRL_RESULT PrlDisk_SetCachingPolicy(
    const PRL_HANDLE Handle,
    const PRL_UINT32 Policy
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
Policy
Caching policy value. Possible values:

PRL_DISK_CACHE_ENABLED - caching enabled.

PRL_DISK_CACHE_DISABLED - caching disabled.

PRL_DISK_CACHE_UNCACHED_READ - cache only write operations.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_SetSharedDirectory Function

PrlDisk_SetSharedDirectory Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Set shared directory (all files created somewhere in this directory will have 666 permissions).

Syntax
PRL_RESULT PrlDisk_SetSharedDirectory(
    PRL_CONST_STR pDirectoryName
);
File

PrlDisk.h

Parameters

pDirectoryName
Directory name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_SetSharedDirectory_Local Function

PrlDisk_SetSharedDirectory_Local Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Set shared directory (all files created somewhere in this directory will have 666 permissions) This function can be used locally, without a Parallels Service connection.

Syntax
PRL_RESULT PrlDisk_SetSharedDirectory_Local(
    PRL_CONST_STR pDirectoryName
);
File

PrlDisk.h

Parameters

pDirectoryName
Directory name in UTF-8 format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_SetUserParameter Function

PrlDisk_SetUserParameter Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Set user parameter for disk.

Syntax
PRL_RESULT PrlDisk_SetUserParameter(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pParameterName,
    PRL_CONST_STR pParameterValue
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pParameterName
Parameter name in UTF-8 format.
pParameterValue
Parameter value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_SwitchToState Function

PrlDisk_SwitchToState Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Start switching to state procedure.

Syntax
PRL_RESULT PrlDisk_SwitchToState(
    const PRL_HANDLE Handle,
    PRL_CONST_STR pDirectoryName,
    PRL_CONST_GUID_PTR pUid,
    const PRL_STATES_CALLBACK pCallback,
    PRL_VOID_PTR pParameter
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pDirectoryName
Directory name (ignored now).
pUid
UID of the state to switch to.
pCallback
Callback to signal progress/completion, if it is equal to NULL function will not return until completion.
pParameter
Callback parameter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_WaitForCompletion Function

PrlDisk_WaitForCompletion Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Wait for completion of the work.

Syntax
PRL_RESULT PrlDisk_WaitForCompletion(
    const PRL_HANDLE Handle
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDisk_Write Function

PrlDisk_Write Function
PrlDisk.h PHT_VIRTUAL_DISK Send Feedback

Write data to disk.

Syntax
PRL_RESULT PrlDisk_Write(
    const PRL_HANDLE Handle,
    PRL_CONST_VOID_PTR pBlock,
    const PRL_UINT32 uiSize,
    const PRL_UINT64 uiBlockOffset
);
File

PrlDisk.h

Parameters

Handle
A handle of type PHT_VIRTUAL_DISK identifying the virtual disk.
pBlock
Pointer to sector/page aligned data to write (depends from host OS).
uiSize
Size of data to write.
uiBlockOffset
Offset of the block on the disk in sectors.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid argument values.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlDisk.h, PHT_VIRTUAL_DISK


PrlDispCfg_CanChangeDefaultSettings Function

PrlDispCfg_CanChangeDefaultSettings Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines if new users have the right to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlDispCfg_CanChangeDefaultSettings(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbDefaultChangeSettings
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbDefaultChangeSettings
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that new users are allowed to change the Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host machine can modify Parallels Service preferences. When a new Parallels Service user profile is created (this happens automatically when a user logs in to the Parallels Service for the first time), he/she will be granted or denied this privilege based on the flag set in the Parallels Service configuration. This function determines the status of this flag.

See Also

PrlDispCfg_SetCanChangeDefaultSettings

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_CreateDispNet Function

PrlDispCfg_CreateDispNet Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Creates a new virtual network adapter object and adds it to the network adapters list.

Syntax
PRL_RESULT PrlDispCfg_CreateDispNet(
    PRL_HANDLE hDispConfig,
    PRL_HANDLE_PTR phDispNet
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
phDispNet
[out] A pointer to a new handle of type PHT_DISP_NET_ADAPTER.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function merely creates a new virtual network adapter object in the local memory. To add a network adapter to the Parallels Service, populate the necessary network adapter properties using functions from the PHT_DISP_NET_ADAPTER group and then call PrlSrv_AddNetAdapter to add the adapter to the Parallels Service configuration.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_GetDefaultVmDir Function

PrlDispCfg_GetDefaultVmDir Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Obtains name and path of the directory in which new virtual machines are created by default.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultVmDir(
    PRL_HANDLE hDispConfig,
    PRL_STR sDefaultVmDir,
    PRL_UINT32_PTR pnDefaultVmDirBufLength
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sDefaultVmDir
[out] A pointer to a buffer that receives the directory name (a UTF-8 encoded, null-terminated string).
pnDefaultVmDirBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The virtual machine directory returned by this function is the default directory for all users and cannot be modified. Individual users can have their own default virtual machine directories if needed. To set a default directory for a user, use the PrlUsrCfg_SetDefaultVmFolder function. If a user has its own virtual machine directory set up, it takes precedence over the directory returned by this function.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_GetDefaultVNCHostName Function

PrlDispCfg_GetDefaultVNCHostName Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Returns the default VNC host name for the Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_GetDefaultVNCHostName(
    PRL_HANDLE hDispConfig,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sHostName
[out] Pointer to a buffer that receives the VNC host name (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_GetDispNet Function

PrlDispCfg_GetDispNet Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Obtains information about a virtual network adapter from the Parallels Service configuration.

Syntax
PRL_RESULT PrlDispCfg_GetDispNet(
    PRL_HANDLE hDispCfg,
    PRL_UINT32 nDispNetIndex,
    PRL_HANDLE_PTR phDispNet
);
File

PrlApi.h

Parameters

hDispCfg
A handle of type PHT_DISP_CONFIG.
nDispNetIndex
An index identifying the adapter in the adapter list starting with 0 and up. To obtain the total number of the available adapters, use the PrlDispCfg_GetDispNetCount function.
phDispNet
[out] A pointer to a handle of type PHT_DISP_NET_ADAPTER. On function return, the object will contain the specified net adapter information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Service can have multiple network adapters, each identified by a numeric index starting with 0 and up. Use PrlDispCfg_GetDispNetCount to determine the total adapter count and then obtain each adapter information by calling this function in a loop, passing an index counter in each iteration.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_GetDispNetCount Function

PrlDispCfg_GetDispNetCount Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Determines the total number of the virtual network adapters in the Parallels Service configuration.

Syntax
PRL_RESULT PrlDispCfg_GetDispNetCount(
    PRL_HANDLE hDispCfg,
    PRL_UINT32_PTR pnDispNetCount
);
File

PrlApi.h

Parameters

hDispCfg
A handle of type PHT_DISP_CONFIG.
pnDispNetCount
[out] A pointer to a variable that receives the total adapter count.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_GetMaxReservMemLimit Function

PrlDispCfg_GetMaxReservMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the maximum amount of physical memory that can be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetMaxReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits and the actual size of the reserved memory are calculated automatically based on the total RAM available on the host machine. If needed, you can modify the default values. When setting the size of the memory reserved for Parallels Service, use this function to find out the maximum allowable size.

See Also

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMaxVmMem Function

PrlDispCfg_GetMaxVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the maximum memory size that can be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The actual amount of memory for a particular virtual machine is set in the virtual machine configuration and cannot exceed the value returned by this function.

See Also

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinReservMemLimit Function

PrlDispCfg_GetMinReservMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the minimum amount of physical memory that must be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetMinReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits and the actual size of the reserved memory are calculated automatically based on the total RAM available on the host machine. If needed, you can modify the default values. When setting the size of the memory reserved on the host machine for Parallels Service, use this function to find out the minimum required size.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinSecurityLevel Function

PrlDispCfg_GetMinSecurityLevel Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the lowest allowable security level that can be used to connect to the Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_GetMinSecurityLevel(
    PRL_HANDLE hDispConfig,
    PRL_SECURITY_LEVEL_PTR pnMinSecurityLevel
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMinSecurityLevel
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Service has a configuration parameter that specifies the connection security level that must be used by clients to communicate with it. If a client tries to login using a lower level than the one returned by this function, the connection to the Parallels Service will be refused. Higher security levels are allowed. If the minimum security level is not known in advance, use this function to determine it before establishing a connection with the Service.

See Also

PrlDispCfg_SetMinSecurityLevel

PrlSrv_Login

PrlSrv_LoginLocal

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetMinVmMem Function

PrlDispCfg_GetMinVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the minimum required memory size that must be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetMinVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The value returned by this function indicates the minimum amount of memory that is absolutely required for a virtual machine to run. The actual amount of memory for a particular virtual machine is set in the virtual machine configuration and cannot be less than the value returned by this function.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetRecommendMaxVmMem Function

PrlDispCfg_GetRecommendMaxVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the recommended memory size for an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_GetRecommendMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Setting the virtual machine memory size to the value returned by this function is the safest way to do it but is not mandatory. You can use your own value but you have to make sure that it falls within the limits returned by the PrlDispCfg_GetMaxVmMem and PrlDispCfg_GetMinVmMem functions.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetReservedMemLimit Function

PrlDispCfg_GetReservedMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines the amount of physical memory reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_GetReservedMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnMemSize
[out] A pointer to a variable that receives the memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, this memory size is calculated automatically based on the RAM size available on the host machine. If needed, the default value can be modified manually using the PrlDispCfg_SetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_GetVNCBasePort Function

PrlDispCfg_GetVNCBasePort Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Obtains the currently set base VNC port number.

Syntax
PRL_RESULT PrlDispCfg_GetVNCBasePort(
    PRL_HANDLE hDispConfig,
    PRL_UINT32_PTR pnPort
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pnPort
[out] A pointer to a variable that receives the port number.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_IsAdjustMemAuto Function

PrlDispCfg_IsAdjustMemAuto Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Determines whether memory allocation for Parallels Service is performed automatically or manually.

Syntax
PRL_RESULT PrlDispCfg_IsAdjustMemAuto(
    PRL_HANDLE hDispConfig,
    PRL_BOOL_PTR pbAdjustMemAuto
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
pbAdjustMemAuto
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the memory is set automatically. PRL_FALSE indicates that the size is set manually.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the amount of memory allocated for Parallels Service is calculated automatically based on the total RAM available on the host. You can allocate a different amount of memory if needed using the PrlDispCfg_SetReservedMemLimit function. Before you do that, you must switch memory allocation to manual mode using the PrlDispCfg_SetAdjustMemAuto function. The amount of currently allocated memory can be retrieved using the PrlDispCfg_GetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetAdjustMemAuto Function

PrlDispCfg_SetAdjustMemAuto Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to choose the Parallels Service memory allocation mode from automatic or manual.

Syntax
PRL_RESULT PrlDispCfg_SetAdjustMemAuto(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bAdjustMemAuto
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bAdjustMemAuto
To set the size automatically, set this parameter to PRL_TRUE. To set the size manually, set this parameter to PRL_FALSE and then use the PrlDispCfg_SetReservedMemLimit function to set the size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the amount of memory allocated for Parallels Service operations is calculated automatically based on the total RAM available on the host. You can allocate a different amount of memory if needed using the PrlDispCfg_SetReservedMemLimit function. Before you do that, you must switch memory allocation to manual using this function. The current memory allocation method can be determined using the PrlDispCfg_IsAdjustMemAuto function. The amount of currently allocated memory can be retrieved using the PrlDispCfg_GetReservedMemLimit function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetCanChangeDefaultSettings Function

PrlDispCfg_SetCanChangeDefaultSettings Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to grant or deny a permission to new users to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlDispCfg_SetCanChangeDefaultSettings(
    PRL_HANDLE hDispConfig,
    PRL_BOOL bDefaultChangeSettings
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
bDefaultChangeSettings
If set to PRL_TRUE, new users will be allowed to modify Parallels Service preferences. If set to PRL_FALSE, new users will not be allowed to make such modifications.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host OS can modify Parallels Service preferences. When a new Parallels Service user profile is created (this happens when a user logs on to the Parallels Service for the first time), he/she will be granted or denied this privilege based on the default setting. This function allows to set that default setting. To determine the current behavior, use PrlDispCfg_CanChangeDefaultSettings. Please note that this function only affects the new users (the users that will be created in the future). The profiles of the existing users will not (and cannot) be modified.

See Also

PrlDispCfg_CanChangeDefaultSettings

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetDefaultVNCHostName Function

PrlDispCfg_SetDefaultVNCHostName Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Sets the base VNC host name.

Syntax
PRL_RESULT PrlDispCfg_SetDefaultVNCHostName(
    PRL_HANDLE hDispConfig,
    PRL_CONST_STR sNewHostName
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
sNewHostName
The new VNC host name. The value must be UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispCfg_SetMaxReservMemLimit Function

PrlDispCfg_SetMaxReservMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to manually set the upper limit of the memory size that can be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetMaxReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new maximum memory limit (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits are calculated automatically based on the host machine RAM size. If needed, you can use this function to modify the default value of the maximum reserved memory size. Please note that modifying default memory limits must be done with extreme caution. Unjustified memory limits may result in too much or too little memory reserved for Parallels Service, which in turn may lead to an unstable or inefficient system. While this and other functions allow you to experiment with Parallels Service memory limits, the default values are the ones that should be used in most situations.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMaxVmMem Function

PrlDispCfg_SetMaxVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to set the maximum memory size that can be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new memory size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, virtual machine memory limits are calculated automatically. If needed, you can set your own maximum memory limit using this function. Please note that the new value must not exceed the size of the memory reserved for Parallels Service, which can be obtained using the PrlDispCfg_GetReservedMemLimit function. The actual memory size for a virtual machine is set when configuring it and will be validated against the value set here.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinReservMemLimit Function

PrlDispCfg_SetMinReservMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to manually set the lower limit of the memory size that must be reserved for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetMinReservMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new minimum size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, memory limits are calculated automatically based on the host machine RAM size and other parameters. If needed, you can use this function to modify the default value of the minimum required reserved memory size. Please note that modifying default memory limits must be done with extreme caution. Unjustified memory limits may result in too much or too little memory reserved for Parallels Service, which in turn may lead to an unstable or inefficient system. While this and other functions allow you to experiment with Parallels Service memory limits, the default values are should be used in most situations.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetReservedMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinSecurityLevel Function

PrlDispCfg_SetMinSecurityLevel Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to set the lowest allowable security level that can be used to connect to the specified Parallels Service.

Syntax
PRL_RESULT PrlDispCfg_SetMinSecurityLevel(
    PRL_HANDLE hDispConfig,
    PRL_SECURITY_LEVEL nMinSecurityLevel
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMinSecurityLevel
Security level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The lowest allowable security level is a setting in the Parallels Service preferences. If a client tries to login using a lower level that the one set by this function, the connection to the Parallels Service will be refused.

See Also

PrlDispCfg_GetMinSecurityLevel

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetMinVmMem Function

PrlDispCfg_SetMinVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to set the minimum required memory size that must be allocated to an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetMinVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new minimum size (in megabytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, virtual machine memory limits are calculated automatically. If needed, you can set your own minimum memory limit using this function. Please note that the new value must not fall below the size of the minimum memory limit set for Parallels Service, which can be obtained using the PrlDispCfg_GetMinReservMemLimit function. The actual memory size for a virtual machine is set when configuring it and will be validated against the value set here.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

PrlDispCfg_SetRecommendMaxVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetRecommendMaxVmMem Function

PrlDispCfg_SetRecommendMaxVmMem Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to manually set recommended memory size for an individual virtual machine.

Syntax
PRL_RESULT PrlDispCfg_SetRecommendMaxVmMem(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new recommended memory size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, the recommended memory size for a virtual machine is calculated automatically. If needed, you can set your own recommended memory size using this function. The value must be selected from the memory limit range that can be determined using the PrlDispCfg_GetMinVmMem and PrlDispCfg_GetMaxVmMem functions. The value by itself is not used as a constraint of any kind and is just a suggestion that the end user may act on or not.

See Also

PrlDispCfg_GetMaxVmMem

PrlDispCfg_GetMinVmMem

PrlDispCfg_GetRecommendMaxVmMem

PrlDispCfg_SetMaxVmMem

PrlDispCfg_SetMinVmMem

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetReservedMemLimit Function

PrlDispCfg_SetReservedMemLimit Function
PrlApi.h PHT_DISP_CONFIG See Also Send Feedback

Allows to set the amount of memory that will be allocated for Parallels Service operation.

Syntax
PRL_RESULT PrlDispCfg_SetReservedMemLimit(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nMemSize
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nMemSize
The new memory size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The memory size must fall within the memory limits that can be determined using the PrlDispCfg_GetMaxReservMemLimit and the PrlDispCfg_GetMinReservMemLimit functions. By default, the memory size is calculated automatically based on the total RAM available on the host. If you are changing the default value, you must also switch the Parallels Service memory allocation to manual mode using the PrlDispCfg_SetAdjustMemAuto function.

See Also

PrlDispCfg_GetMaxReservMemLimit

PrlDispCfg_GetMinReservMemLimit

PrlDispCfg_GetReservedMemLimit

PrlDispCfg_SetMaxReservMemLimit

PrlDispCfg_SetMinReservMemLimit

PrlDispCfg_IsAdjustMemAuto

PrlDispCfg_SetAdjustMemAuto

Links
PrlApi.h, PHT_DISP_CONFIG, See Also


PrlDispCfg_SetVNCBasePort Function

PrlDispCfg_SetVNCBasePort Function
PrlApi.h PHT_DISP_CONFIG Send Feedback

Sets the base VNC port number.

Syntax
PRL_RESULT PrlDispCfg_SetVNCBasePort(
    PRL_HANDLE hDispConfig,
    PRL_UINT32 nPort
);
File

PrlApi.h

Parameters

hDispConfig
A handle of type PHT_DISP_CONFIG.
nPort
Port number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_CONFIG


PrlDispNet_GetDhcpScopeEndIp Function

PrlDispNet_GetDhcpScopeEndIp Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the end IP address of DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_GetDhcpScopeEndIp(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetDhcpScopeEndIp,
    PRL_UINT32_PTR pnDispNetDhcpScopeEndIpBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetDhcpScopeEndIp
[out] A pointer to a buffer that receives the IP address (a UTF-8 encoded, null-terminated string).
pnDispNetDhcpScopeEndIpBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetDhcpScopeEndIp

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetDhcpScopeMask Function

PrlDispNet_GetDhcpScopeMask Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the subnet mask of DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_GetDhcpScopeMask(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetDhcpScopeMask,
    PRL_UINT32_PTR pnDispNetDhcpScopeMaskBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetDhcpScopeMask
[out] A pointer to a buffer that receives the subnet mask (a UTF-8 encoded, null-terminated string).
pnDispNetDhcpScopeMaskBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetDhcpScopeMask

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetDhcpScopeStartIp Function

PrlDispNet_GetDhcpScopeStartIp Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the start IP address of DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_GetDhcpScopeStartIp(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetDhcpScopeStartIp,
    PRL_UINT32_PTR pnDispNetDhcpScopeStartIpBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetDhcpScopeStartIp
[out] A pointer to a buffer that receives the IP address (a UTF-8 encoded, null-terminated string).
pnDispNetDhcpScopeStartIpBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetDhcpScopeStartIp

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetIndex Function

PrlDispNet_GetIndex Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the index identifying the specified adapter on the Parallels Service.

Syntax
PRL_RESULT PrlDispNet_GetIndex(
    PRL_HANDLE hDispNet,
    PRL_UINT32_PTR pnIndex
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
pnIndex
[out] A pointer to a variable that receives the index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetIndex

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetName Function

PrlDispNet_GetName Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the name of the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_GetName(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetName,
    PRL_UINT32_PTR pnDispNetNameBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnDispNetNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetName

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetNetworkType Function

PrlDispNet_GetNetworkType Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the virtual network adapter network type (host-only or shared).

Syntax
PRL_RESULT PrlDispNet_GetNetworkType(
    PRL_HANDLE hDispNet,
    PRL_NET_ADAPTER_EMULATED_TYPE_PTR pnNetworkType
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
pnNetworkType
[out] A pointer to a variable that receives the network type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetNetworkType

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetSysName Function

PrlDispNet_GetSysName Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Returns the name of the physical network adapter to which the specified virtual network adapter is bound.

Syntax
PRL_RESULT PrlDispNet_GetSysName(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetSysName,
    PRL_UINT32_PTR pnDispNetSysNameBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetSysName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnDispNetSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetSysName

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_GetUuid Function

PrlDispNet_GetUuid Function
PrlApi.h PHT_DISP_NET_ADAPTER Send Feedback

Returns the specified virtual network adapter UUID.

Syntax
PRL_RESULT PrlDispNet_GetUuid(
    PRL_HANDLE hDispNet,
    PRL_STR sDispNetUuid,
    PRL_UINT32_PTR pnDispNetUuidBufLength
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sDispNetUuid
[out] A pointer to a buffer that receives the UUID (a UTF-8 encoded, null-terminated string).
pnDispNetUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_DISP_NET_ADAPTER


PrlDispNet_IsDhcpEnabled Function

PrlDispNet_IsDhcpEnabled Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Determines if DHCP scope is enabled for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_IsDhcpEnabled(
    PRL_HANDLE hDispNet,
    PRL_BOOL_PTR pbDhcpEnabled
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
pbDhcpEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the DHCP scope is enabled, PRL_FALSE indicates that it is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetDhcpEnabled

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_IsEnabled Function

PrlDispNet_IsEnabled Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Determines whether the specified virtual network adapter is enabled or disabled.

Syntax
PRL_RESULT PrlDispNet_IsEnabled(
    PRL_HANDLE hDispNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is enabled. PRL_FALSE indicates that the adapter is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_SetEnabled

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_Remove Function

PrlDispNet_Remove Function
PrlApi.h PHT_DISP_NET_ADAPTER Send Feedback

Removes the specified virtual network adapter object from memory.

Syntax
PRL_RESULT PrlDispNet_Remove(
    PRL_HANDLE hDispNet
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This function does not delete the adapter from the Parallels Service configuration. Use this function if you would like to cancel the changes that you've made to the object properties so far. The function must be called before calling the PrlSrv_AddNetAdapter or the PrlSrv_UpdateNetAdapter function (the calls that update the Parallels Service configuration and make the changes permanent). To delete an existing adapter from the configuration, use the PrlSrv_DeleteNetAdapter function.

Links
PrlApi.h, PHT_DISP_NET_ADAPTER


PrlDispNet_SetDhcpEnabled Function

PrlDispNet_SetDhcpEnabled Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Allows to enable or disable the DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetDhcpEnabled(
    PRL_HANDLE hDispNet,
    PRL_BOOL bDhcpEnabled
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
bDhcpEnabled
Specifies the action to perform. PRL_TRUE enables the DHCP scope. PRL_FALSE disables it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_IsDhcpEnabled

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetDhcpScopeEndIp Function

PrlDispNet_SetDhcpScopeEndIp Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the end IP address of the DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetDhcpScopeEndIp(
    PRL_HANDLE hDispNet,
    PRL_CONST_STR sNewDispNetDhcpScopeEndIp
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sNewDispNetDhcpScopeEndIp
The IP address. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetDhcpScopeEndIp

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetDhcpScopeMask Function

PrlDispNet_SetDhcpScopeMask Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the subnet mask of the DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetDhcpScopeMask(
    PRL_HANDLE hDispNet,
    PRL_CONST_STR sNewDispNetDhcpScopeMask
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sNewDispNetDhcpScopeMask
The subnet mask. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetDhcpScopeMask

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetDhcpScopeStartIp Function

PrlDispNet_SetDhcpScopeStartIp Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the start IP address of the DHCP scope for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetDhcpScopeStartIp(
    PRL_HANDLE hDispNet,
    PRL_CONST_STR sNewDispNetDhcpScopeStartIp
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sNewDispNetDhcpScopeStartIp
The IP address. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetDhcpScopeStartIp

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetEnabled Function

PrlDispNet_SetEnabled Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Allows to enable or disable a specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetEnabled(
    PRL_HANDLE hDispNet,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the adapter. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_IsEnabled

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetIndex Function

PrlDispNet_SetIndex Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the specified virtual network adapter index (from 0 to 5).

Syntax
PRL_RESULT PrlDispNet_SetIndex(
    PRL_HANDLE hDispNet,
    PRL_UINT32 nIndex
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
nIndex
An index to set. The value cannot be less then 0 and greater than 5.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function to set a unique number for a virtual network adapter for easy identification in your client applications.

See Also

PrlDispNet_GetIndex

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetName Function

PrlDispNet_SetName Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the specified virtual network adapter name.

Syntax
PRL_RESULT PrlDispNet_SetName(
    PRL_HANDLE hDispNet,
    PRL_CONST_STR sNewDispNetName
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sNewDispNetName
A name to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetName

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetNetworkType Function

PrlDispNet_SetNetworkType Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Allows to set a network type for the specified virtual network adapter.

Syntax
PRL_RESULT PrlDispNet_SetNetworkType(
    PRL_HANDLE hDispNet,
    PRL_NET_ADAPTER_EMULATED_TYPE nNetworkType
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
nNetworkType
A network type to set. NOTE: You can only use PNA_HOST_ONLY and PNA_SHARED types here. You CANNOT use the PNA_BRIDGED_ETHERNET type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetNetworkType

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlDispNet_SetSysName Function

PrlDispNet_SetSysName Function
PrlApi.h PHT_DISP_NET_ADAPTER See Also Send Feedback

Sets the specified virtual network adapter system name.

Syntax
PRL_RESULT PrlDispNet_SetSysName(
    PRL_HANDLE hDispNet,
    PRL_CONST_STR sNewDispNetSysName
);
File

PrlApi.h

Parameters

hDispNet
A handle of type PHT_DISP_NET_ADAPTER identifying the network adapter.
sNewDispNetSysName
A system name to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlDispNet_GetSysName

Links
PrlApi.h, PHT_DISP_NET_ADAPTER, See Also


PrlEnums.h

PrlEnums.h
Enumerations Files Legend Macros Types Send Feedback

PrlEnums.h

This file is the part of parallels public sdk library

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Enumerations
Name | Description
_PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
_PRL_APP_IN_DOCK_MODE | VM application in Dock mode
_PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
_PRL_CPU_HVT | CPU mode
_PRL_CPU_MODE | CPU mode
_PRL_DEVICE_ACTION | Device in use Action
_PRL_DEVICE_TYPE | Device type
_PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
_PRL_DISPLAY_CODEC_QUALITY | Display codec quality
_PRL_DISPLAY_CODEC_TYPE | Display codec types
_PRL_DOCK_ICON_TYPE | VM application icon type in Dock
_PRL_EVENT_ISSUER_TYPE | Event issuer type
_PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
_PRL_FILE_SYSTEM_FS_TYPE |
_PRL_FILE_SYSTEM_TYPE | File system general type
_PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
_PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
_PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
_PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
_PRL_HOST_OS_TYPE | Host OS type
_PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
_PRL_IMAGE_FORMAT |
_PRL_IO_STATE |
_PRL_JOB_OPERATION_CODE | Job operation codes
_PRL_JOB_STATUS | Job status enumeration
_PRL_KEY_EVENT |
_PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
_PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
_PRL_MOUSE_BUTTON |
_PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
_PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
_PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
_PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
_PRL_PROCESS_STATE_TYPE | Process state element
_PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
_PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
_PRL_SECURITY_LEVEL | Security level enumeration.
_PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
_PRL_SERVICE_STATUS_ENUM | Parallels service statuses
_PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
_PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
_PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
_PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
_PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
_PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
_PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
_PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
_PRL_VERSION_ENUM | Parallels license versions enumeration.
_PRL_VM_ACCELERATION_LEVEL | Acceleration level
_PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
_PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
_PRL_VM_AUTOSTART_OPTION | VM autostart options
_PRL_VM_AUTOSTOP_OPTION | VM autostop options
_PRL_VM_BOOT_ORDER | VM boot order
_PRL_VM_CONFIG_SECTIONS | VM configuration sections
_PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
_PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
_PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
_PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
_PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
_PRL_VM_PRIORITY | Background/foreground VM processes priority
_PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
_PRL_VM_START_LOGIN_MODE | VM start login mode
_PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
_PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
_PRL_VM_WINDOW_MODE | VM window mode
_PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
_VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
PRL_ALLOWED_VM_COMMAND | Allowed vm commands enumeration
PRL_APP_IN_DOCK_MODE | VM application in Dock mode
PRL_APPLICATION_MODE | Parallels application mode in which SDK should work PAM_SERVER : SDK should working at Parallels Service application mode PAM_DESKTOP : SDK should working at Parallels Desktop application mode PAM_WORKSTATION : SDK should working at Parallels Workstation application mode PAM_PLAYER : SDK should working at Parallels Player application mode (not supported) PAM_STM : SDK should working at Parallels STM application mode
PRL_CPU_HVT | CPU mode
PRL_CPU_MODE | CPU mode
PRL_DEVICE_ACTION | Device in use Action
PRL_DEVICE_TYPE | Device type
PRL_DISPLAY_CODEC_COMPRESSION | Display codec compression
PRL_DISPLAY_CODEC_QUALITY | Display codec quality
PRL_DISPLAY_CODEC_TYPE | Display codec types
PRL_DOCK_ICON_TYPE | VM application icon type in Dock
PRL_EVENT_ISSUER_TYPE | Event issuer type
PRL_FILE_SYSTEM_ELEMENT_TYPE | File system element type
PRL_FILE_SYSTEM_FS_TYPE |
PRL_FILE_SYSTEM_TYPE | File system general type
PRL_GRACEFUL_SHUTDOWN_KIND | Graceful Shutdown types
PRL_GUEST_DISTRO_VERSION_ENUM | Windows installation distributive type.
PRL_HANDLE_TYPE | The _PRL_HANDLE_TYPE enumeration defines handle types.
PRL_HARD_DISK_INTERNAL_FORMAT | Hard disk image type
PRL_HOST_OS_TYPE | Host OS type
PRL_HW_INFO_NET_ADAPTER_TYPE | Network adapter types in hardware info list
PRL_IMAGE_FORMAT |
PRL_IO_STATE |
PRL_JOB_OPERATION_CODE | Job operation codes
PRL_JOB_STATUS | Job status enumeration
PRL_KEY_EVENT |
PRL_MASS_STORAGE_INTERFACE_TYPE | Mass storage device interface type
PRL_MESSAGE_TYPE_ENUM | Message type enumeration.
PRL_MOUSE_BUTTON |
PRL_NET_ADAPTER_EMULATED_TYPE | Network adapter emulated type
PRL_NET_VIRTUAL_NETWORK_TYPE | Virtual Network type.
PRL_PARAM_FIELD_DATA_TYPE | Event parameters fields types
PRL_PORT_FORWARDING_TYPE | Port forwarding type: PPF_TCP : TCP port forwarding PPF_UDP : UDP port forwarding
PRL_PROCESS_STATE_TYPE | Process state element
PRL_PRODUCT_ENUM | Parallels lilcense products enumeration.
PRL_RUNNING_TASK_TYPE_ENUM | Running task type enumeration.
PRL_SECURITY_LEVEL | Security level enumeration.
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE | Serial port operation mode when on socket
PRL_SERVICE_STATUS_ENUM | Parallels service statuses
PRL_TIS_RECORD_ACTION | Parallels Tools Information Service record actions
PRL_TIS_RECORD_STATE | Parallels Tools Information Service record states
PRL_TOOLS_SIA_OPEN_IN_TYPES | Shared Internet Applications 'open in' type PSIA_OPEN_DEFAULT : Open host link with host app; Open guest link with guest app PSIA_OPEN_IN_GUEST : Open all links with guest apps; PSIA_OPEN_IN_HOST : Open all links with host apps;
PRL_TOOLS_UTILITY_COMMAND_FLAG | Parallels Tools Utility command flags
PRL_TOOLS_UTILITY_COMMAND_ID | Parallels Tools Utility commands identifiers
PRL_UNDO_DISKS_MODE | VM undo disks mode: PUD_DISABLE_UNDO_DISKS : disbale undo disks PUD_REVERSE_CHANGES : at stopping VM revert all disk changes PUD_COMMIT_CHANGES : at stopping VM apply all disk changes PUD_PROMPT_BEHAVIOUR : ask user which mode reverse or commit will be applied
PRL_USB_DEVICE_AUTO_CONNECT_OPTION | USB autoconnect devices options
PRL_USB_DEVICE_CONNECT_REASON | USB device connect/disconnect reason
PRL_VERSION_ENUM | Parallels license versions enumeration.
PRL_VM_ACCELERATION_LEVEL | Acceleration level
PRL_VM_ACCESS_FOR_OTHERS | Specifies virtual machine access rights.
PRL_VM_ACTION_ON_WINDOW_CLOSE | Action on VM when VM window gets closed
PRL_VM_AUTOSTART_OPTION | VM autostart options
PRL_VM_AUTOSTOP_OPTION | VM autostop options
PRL_VM_BOOT_ORDER | VM boot order
PRL_VM_CONFIG_SECTIONS | VM configuration sections
PRL_VM_DEV_EMULATION_TYPE | VM device emulation type
PRL_VM_EXEC_APP_FILE_DESCRIPTOR | App execution result extraction moderators: PFD_STDOUT : request stdout of executed in guest OS app PFD_STDERR : request stderr of executed in guest OS app
PRL_VM_EXEC_RUN_PROGRAM_MODES | Run app in guest modes: PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY : just run program in guest OS and do not wait result
PRL_VM_MIGRATION_SECURITY_LEVEL | VM migration security level - specifies security level of VM migration connection
PRL_VM_MIGRATION_TYPE | VM migration type - specifies method of VM migration
PRL_VM_PRIORITY | Background/foreground VM processes priority
PRL_VM_REMOTE_DISPLAY_MODE | Parallels remote desktop modes
PRL_VM_START_LOGIN_MODE | VM start login mode
PRL_VM_START_MODE | VM start mode: PSM_VM_START : start VM PSM_VM_SAFE_START : start VM in the safe mode
PRL_VM_TOOLS_STATE | Virtual machine tools states enumeration
PRL_VM_WINDOW_MODE | VM window mode
PRL_WINDOW_EDGE_MASK | Edges where taskbar can be placed (in coherence mode).
VIRTUAL_MACHINE_STATE | Virtual machine states enumeration
Macros
Name | Description
PRL_CURRENT_GUEST_OS_SESSION |
PRL_PRIVILEGED_GUEST_OS_SESSION | Guest OS sessions types and constants declarations
PVM_GET_MIGRATION_SECURITY_LEVEL | Macro for extracting VM migration security level value from flags mask
PVM_GET_MIGRATION_TYPE | Macro for extracting VM migration type value from flags mask
Types
Name | Description
PRL_ALLOWED_VM_COMMAND_PTR |
PRL_APP_IN_DOCK_MODE_PTR |
PRL_APPLICATION_MODE_PTR |
PRL_CPU_HVT_PTR |
PRL_CPU_MODE_PTR |
PRL_DEVICE_ACTION_PTR |
PRL_DEVICE_TYPE_PTR |
PRL_DOCK_ICON_TYPE_PTR |
PRL_EVENT_ISSUER_TYPE_PTR |
PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR |
PRL_FILE_SYSTEM_FS_TYPE_PTR |
PRL_FILE_SYSTEM_TYPE_PTR |
PRL_GRACEFUL_SHUTDOWN_KIND_PTR |
PRL_GUEST_DISTRO_VERSION_ENUM_PTR |
PRL_HANDLE_TYPE_PTR |
PRL_HARD_DISK_INTERNAL_FORMAT_PTR |
PRL_HOST_OS_TYPE_PTR |
PRL_HW_INFO_NET_ADAPTER_TYPE_PTR |
PRL_IMAGE_FORMAT_PTR |
PRL_IO_STATE_PTR |
PRL_JOB_OPERATION_CODE_PTR |
PRL_JOB_STATUS_PTR |
PRL_KEY_EVENT_PTR |
PRL_MASS_STORAGE_INTERFACE_TYPE_PTR |
PRL_MESSAGE_TYPE_ENUM_PTR |
PRL_MOUSE_BUTTON_PTR |
PRL_NET_ADAPTER_EMULATED_TYPE_PTR |
PRL_NET_VIRTUAL_NETWORK_TYPE_PTR |
PRL_PARAM_FIELD_DATA_TYPE_PTR |
PRL_PORT_FORWARDING_TYPE_PTR |
PRL_PROCESS_STATE_TYPE_PTR |
PRL_PRODUCT_ENUM_PTR |
PRL_RUNNING_TASK_TYPE_ENUM_PTR |
PRL_SECURITY_LEVEL_PTR |
PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR |
PRL_SERVICE_STATUS_ENUM_PTR |
PRL_TIS_RECORD_ACTION_PTR |
PRL_TIS_RECORD_STATE_PTR |
PRL_TOOLS_SIA_OPEN_IN_TYPES_PTR |
PRL_TOOLS_UTILITY_COMMAND_FLAG_PTR |
PRL_TOOLS_UTILITY_COMMAND_ID_PTR |
PRL_UNDO_DISKS_MODE_PTR |
PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR |
PRL_USB_DEVICE_CONNECT_REASON_PTR |
PRL_VERSION_ENUM_PTR |
PRL_VM_ACCELERATION_LEVEL_PTR |
PRL_VM_ACCESS_FOR_OTHERS_PTR |
PRL_VM_ACTION_ON_WINDOW_CLOSE_PTR |
PRL_VM_AUTOSTART_OPTION_PTR |
PRL_VM_AUTOSTOP_OPTION_PTR |
PRL_VM_BOOT_ORDER_PTR |
PRL_VM_CONFIG_SECTIONS_PTR |
PRL_VM_DEV_EMULATION_TYPE_PTR |
PRL_VM_EXEC_APP_FILE_DESCRIPTOR_PTR |
PRL_VM_EXEC_RUN_PROGRAM_MODES_PTR |
PRL_VM_MIGRATION_SECURITY_LEVEL_PTR |
PRL_VM_MIGRATION_TYPE_PTR |
PRL_VM_PRIORITY_PTR |
PRL_VM_REMOTE_DISPLAY_MODE_PTR |
PRL_VM_START_LOGIN_MODE_PTR |
PRL_VM_START_MODE_PTR |
PRL_VM_TOOLS_STATE_PTR |
PRL_VM_WINDOW_MODE_PTR |
PRL_WINDOW_EDGE_MASK_PTR |
VIRTUAL_MACHINE_STATE_PTR |
Links
Enumerations, Files, Legend, Macros, Types


PrlErrors.h

PrlErrors.h
Files Macros Types Send Feedback

PrlErrors.h

This file is the part of parallels public sdk library

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Macros
Name | Description
PRL_FAILED |
PRL_RESULT_DECLARE_ERROR | Declaration of the error value goes here
PRL_RESULT_DECLARE_SUCCESS |
PRL_SUCCEEDED | Success and failure result codes
Types
Name | Description
PRL_RESULT | Unified result error code for each and every method
PRL_RESULT_PTR |
Links
Files, Macros, Types


PrlEvent_CanBeIgnored Function

PrlEvent_CanBeIgnored Function
PrlApi.h PHT_EVENT Send Feedback

Determines whether the event is critical or not.

Syntax
PRL_RESULT PrlEvent_CanBeIgnored(
    PRL_HANDLE hEvent,
    PRL_BOOL_PTR pbCanBeIgnored
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pbCanBeIgnored
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the event message is critical and should be investigated. PRL_FALSE indicates that the event message is not critical and can be ignored.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_CreateAnswerEvent Function

PrlEvent_CreateAnswerEvent Function
PrlApi.h PHT_EVENT Example Send Feedback

Generates properly formatted and structured answer to a question included in the event.

Syntax
PRL_RESULT PrlEvent_CreateAnswerEvent(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR phEvent,
    PRL_RESULT nAnswer
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
phEvent
[out] A pointer to a variable that receives the result (a handle of type PHT_EVENT containing the answer data).
nAnswer
The code of the answer. The answer object data is assembled based on this value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate event object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

One of the event types that a callback function can receive is PET_DSP_EVT_VM_QUESTION. The event of this type is generated on the Parallels Service side when a user interaction is required. For example, let's say you've sent a request to the Parallels Service to create a virtual machine but specified the size of the virtual hard drive that exceeds the free space available on the physical hard drive. In such a case, the Parallels Service will generate an event containing a question (and possible answers) about how the user would like to proceed. In this particular case, the question will be similar to "The size of the specified disk is larger than the free space available. Would you like to create the disk anyway?" and the possible answers will be "Yes" or "No". The user must choose one of the available options, compose an answer, and send it to the Parallels Service. Based on the answer received, the Parallels Service will take the appropriate action.

To obtain a string containing the question, use the PrlEvent_GetErrString function. Answer choices are acquired by obtaining a handle of type PHT_EVENT_PARAMETER using the PrlEvent_GetParam function (a single object will contain an individual answer choice). After the user selects an answer, the PrlEvent_CreateAnswerEvent function must be called to populate another object of type PHT_EVENT with the properly formatted answer data. The resulting object must then be passed to the PrlSrv_SendAnswer function which will send the answer to the Parallels Service.

Example

The following is a complete example that demonstrates how to handle events and how to answer to Parallels Service questions. In the example, we create a blank virtual machine and try to add a virtual hard drive to it with the size larger than the free disk space available on the physical drive. This will trigger an event on the Parallels Service side and a question will be sent to the client asking if we really want to create a drive like that. The virtual machine creation operation will not continue unless we send an answer to the Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>
#include <stdlib.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

#define MY_JOB_TIMEOUT 10000 // Default timeout to use in the PrlJob_Wait function.
#define MY_HDD_SIZE 70*1024 // The size of the new hard drive.
#define MY_STR_BUF_SIZE 1024 // The default buffer size to use for string output.

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event on the
// Parallels Service, which will result in Service sending us a question.
static PRL_RESULT create_big_hdd(PRL_HANDLE hVm);

// The callback function (event handler).
static PRL_RESULT callback(PRL_HANDLE, PRL_VOID_PTR);

////////////////////////////////////////////////////////////////////////////////

int main(int argc, char* argv[])
{
    // Pick the correct dynamic library file depending on the platform.
    #ifdef _WIN_
        #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
        #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
        #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the dynamic library.
    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        // Error handling goes here...
        return -1;
    }

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;
    PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
    PRL_HANDLE hServer = PRL_INVALID_HANDLE;

    // Initialize API library.
    err = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(err))
    {
        // Error handling goes here...
        return -1;
    }

    // Create server object.
    PrlSrv_Create(&hServer);

    // Log in.
    hJob = PrlSrv_Login(
        hServer, // Server handle
        "10.30.22.82", // Host IP address
        "jdoe", // User
        "secret", // Password
        0, // Previous session ID
        0, // Port number
        0, // Timeout
        PSL_NORMAL_SECURITY); // Security

    ret = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if (PRL_FAILED( nJobResult))
    {
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Create a new virtual machine.
    PRL_HANDLE hVm;
    PrlSrv_CreateVm(hServer, &hVm);
    PrlVm_SetName(hVm, "My simple VM");

    // Register the virtual machine with the Parallels Service.
    hJob = PrlVm_Reg(hVm, "", PRL_FALSE);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free(hJob);

    // Register the event handler with the Service.
    // The second parameter is a pointer to our callback function.
    PrlSrv_RegEventHandler(hServer, &callback, NULL);

    // Try creating a virtual hard drive larger than the
    // free space available (increase MY_HDD_SIZE value if needed).
    // This should produce an event that will
    // contain a question from the Parallels Service.
    create_big_hdd(hVm);

    //
    // At this point, the background thread should call the
    // callback function.
    //

    // We can now clean up and exit the program.
    // Unregister the event handler and log off.
    PrlSrv_UnregEventHandler(hServer, &callback, NULL);
    hJob = PrlSrv_Logoff(hServer);
    PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );
    PrlApi_Deinit();
    SdkWrap_Unload();
    return 0;
}

////////////////////////////////////////////////////////////////////////////////
// The callback function implementation.
// The event handling is demonstrated here.
//
static PRL_RESULT callback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType(hEvent, &nHandleType);

    // A callback function will be called more than once.
    // It will be called for every job that we initiate and it
    // will be called for the event that we intentionally trigger.
    // In this example, we are interested in events only.
    if (nHandleType != PHT_EVENT)
    {
        return PrlHandle_Free(hEvent);
    }

    // Get the type of the event received.
    PRL_EVENT_TYPE type;
    PrlEvent_GetType(hEvent, &type);

    // See if the received event is a "question".
    if (type == PET_DSP_EVT_VM_QUESTION)
    {
        PRL_UINT32 nParamsCount = 0;
        PRL_RESULT err = PRL_ERR_UNINITIALIZED;

        // Extract the text of the question and display it on the screen.
        // The question is stored in the object in the "event message" property.
        PRL_BOOL bIsBriefMessage = true;
        char errMsg [MY_STR_BUF_SIZE];
        PRL_UINT32 nBufSize = MY_STR_BUF_SIZE;

        PrlEvent_GetErrString(hEvent, bIsBriefMessage, errMsg, &nBufSize);
        printf("Question: %s\n\n", errMsg);

        // Extract answer choices. They are stored in the
        // hEvent object as event parameters.
        // First, determine the number of parameters.
        err = PrlEvent_GetParamsCount(hEvent, &nParamsCount);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[3]%.8X: %s\n", err,
                PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Declare an array to hold the choices information.
        PRL_UINT32_PTR choices =(PRL_UINT32_PTR)
            malloc(nParamsCount * sizeof(PRL_UINT32));

        // Now, itereate through the parameter list obtaining a
        // handle of type PHT_EVENT_PARAMETER that will contain
        // an individual parameter data.
        for(PRL_UINT32 nParamIndex = 0; nParamIndex < nParamsCount; ++nParamIndex)
        {
            PRL_HANDLE hParam; // this will receive the event parameter handle.
            PRL_RESULT err = PRL_ERR_UNINITIALIZED;

            // The PrlEvent_GetParam function obtains a handle of type
            // PHT_EVENT_PARAMETER containing (in this case) an answer choice.
            err = PrlEvent_GetParam(hEvent, nParamIndex, &hParam);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[4]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Get the answer description that can be shown to the user.
            // First, obtain the event parameter value.
            err = PrlEvtPrm_ToUint32(hParam, &choices[nParamIndex]);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[9]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Now, get the answer description using the
            // event parameter value as input in the following call.
            char sDesc [MY_STR_BUF_SIZE];
            err = PrlApi_GetResultDescription(choices[nParamIndex], true, sDesc, &nBufSize);
            if (PRL_FAILED(err))
            {
                fprintf(stderr, "[8]%.8X: %s\n", err,
                    PRL_RESULT_TO_STRING(err));
                PrlHandle_Free(hParam);
                PrlHandle_Free(hEvent);
                return err;
            }

            // Display the answer choice on the screen.
            printf("Answer choice: %s\n", sDesc);
            PrlHandle_Free(hParam);
        }

        // Select an answer choice (we are using the "No" answer here) and
        // create a valid answer object (hAnswer).
        PRL_HANDLE hAnswer;
        err = PrlEvent_CreateAnswerEvent(hEvent, &hAnswer, choices[1]);
        if (PRL_FAILED(err))
        {
            fprintf(stderr, "[A]%.8X: %s\n", err, PRL_RESULT_TO_STRING(err));
            PrlHandle_Free(hEvent);
            return err;
        }

        // Obtain a server handle.
        PRL_HANDLE hServer;
        PrlEvent_GetServer(hEvent, &hServer);

        // Send the answer handle to the Parallels Service.
        PrlSrv_SendAnswer(hServer, hAnswer);

        free(choices);
        PrlHandle_Free(hServer);
        PrlHandle_Free(hAnswer);
    }
    else // other event type
    {
        PrlHandle_Free(hEvent);
    }

    return PRL_ERR_SUCCESS;
}

////////////////////////////////////////////////////////////////////////////////

// A helper function that will attempt to crate a hard drive larger
// than the free space available, thus triggering an event.
PRL_RESULT create_big_hdd(PRL_HANDLE hVm)
{
    PRL_HANDLE hJobBeginEdit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobCommit = PRL_INVALID_HANDLE;
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;
    PRL_RESULT err = PRL_ERR_UNINITIALIZED;

    // Timestamp the beginning of the configuration changes operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    err = PrlJob_Wait(hJobBeginEdit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[B]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Create a new device handle.
    // This will be our new virtual hard disk.
    PRL_HANDLE hHDD;
    err = PrlVm_CreateVmDev(
            hVm, // Target virtual machine.
            PDE_HARD_DISK, // Device type.
            &hHDD ); // Device handle.

    // Set disk type to "expanding".
    err = PrlVmDevHd_SetDiskType(hHDD, PHD_EXPANDING_HARD_DISK);

    // Set max disk size, in megabytes.
    err = PrlVmDevHd_SetDiskSize(hHDD, MY_HDD_SIZE);

    // This option determines whether the image file will be split
    // into chunks or created as a single file.
    err = PrlVmDevHd_SetSplitted(hHDD, PRL_FALSE);

    // Choose and set the name for the new image file.
    err = PrlVmDev_SetFriendlyName(hHDD, "harddisk4.hdd");
    err = PrlVmDev_SetSysName(hHDD, "harddisk4.hdd");

    // Set the emulation type.
    err = PrlVmDev_SetEmulatedType(hHDD, PDT_USE_IMAGE_FILE);

    // Enable the new disk on successful creation.
    err = PrlVmDev_SetEnabled(hHDD, PRL_TRUE);

    // Create the new image file.
    hJob = PrlVmDev_CreateImage(hHDD,
            PRL_TRUE, // Do not overwrite if file exists.
            PRL_FALSE ); // Use non-interactive mode.

    err = PrlJob_Wait(hJob, MY_JOB_TIMEOUT);
    if (PRL_FAILED(err))
    {
        fprintf(stderr, "[C]%.8X: %s\n", err,
            PRL_RESULT_TO_STRING(err));
        PrlHandle_Free(hJob);
        return err;
    }

    // Commit the changes.
    hJobCommit = PrlVm_Commit(hVm);
    err = PrlJob_Wait(hJobCommit, MY_JOB_TIMEOUT);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "[D]%.8X: %s\n", nJobRetCode,
            PRL_RESULT_TO_STRING( nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }
    return PRL_ERR_SUCCESS;
}
Links
PrlApi.h, PHT_EVENT, Example


PrlEvent_GetDataPtr Function

PrlEvent_GetDataPtr Function
PrlApi.h PHT_EVENT Send Feedback

Clients can use this method to receive a data buffer specific to the event type.

Syntax
PRL_RESULT PrlEvent_GetDataPtr(
    PRL_HANDLE hEvent,
    PRL_VOID_PTR_PTR data_ptr
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
data_ptr
[out] A pointer to the event-specific data.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Different event types may provide different data buffers or they may provide none.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetErrCode Function

PrlEvent_GetErrCode Function
PrlApi.h PHT_EVENT Send Feedback

Returns the code associated with the event.

Syntax
PRL_RESULT PrlEvent_GetErrCode(
    PRL_HANDLE hEvent,
    PRL_RESULT_PTR pnErrCode
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnErrCode
[out] A pointer to a variable that receives the code.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetErrString Function

PrlEvent_GetErrString Function
PrlApi.h PHT_EVENT Send Feedback

Returns string representation of the event message.

Syntax
PRL_RESULT PrlEvent_GetErrString(
    PRL_HANDLE hEvent,
    PRL_BOOL bIsBriefMessage,
    PRL_BOOL bFormated,
    PRL_STR sErrString,
    PRL_UINT32_PTR pnErrStringBufLength
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
bIsBriefMessage
Specifies whether to return a brief or a long version of the message. Specify PBL_TRUE to return a brief message. Specify PRL_FALSE to return a long message.
bFormated
Specifies whether the HTML tags used for text formatting should be included in the resulting string. PRL_TRUE - include HTML tags. PRL_FALSE - don't include.
sErrString
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnErrStringBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetIssuerId Function

PrlEvent_GetIssuerId Function
PrlApi.h PHT_EVENT Send Feedback

Returns the event issuer ID (host UUID, virtual machine UUID, etc).

Syntax
PRL_RESULT PrlEvent_GetIssuerId(
    PRL_HANDLE hEvent,
    PRL_STR sIssuerId,
    PRL_UINT32_PTR pnIssuerIdBufLength
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
sIssuerId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIssuerIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetIssuerType Function

PrlEvent_GetIssuerType Function
PrlApi.h PHT_EVENT Send Feedback

Returns the event issuer type (virtual machine, host, etc.).

Syntax
PRL_RESULT PrlEvent_GetIssuerType(
    PRL_HANDLE hEvent,
    PRL_EVENT_ISSUER_TYPE_PTR pnIssuerType
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnIssuerType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetJob Function

PrlEvent_GetJob Function
PrlApi.h PHT_EVENT Send Feedback

Obtains the handle of the job that caused the event.

Syntax
PRL_RESULT PrlEvent_GetJob(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR pJob
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pJob
[out] A pointer to a variable that receives a handle of type PHT_JOB.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetParam Function

PrlEvent_GetParam Function
PrlApi.h PHT_EVENT Send Feedback

Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data.

Syntax
PRL_RESULT PrlEvent_GetParam(
    PRL_HANDLE hEvent,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phEventParam
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
nIndex
An index identifying the event parameter (beginning with 0). To determine the number of the parameters in the event container, use the PrlEvent_GetParamsCount function.
phEventParam
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

An event container may contain multiple parameters. The meaning of the parameter may be different for different event types.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetParamByName Function

PrlEvent_GetParamByName Function
PrlApi.h PHT_EVENT Send Feedback

Obtains a handle of type PHT_EVENT_PARAMETER containing an event parameter data by specified parameter name.

Syntax
PRL_RESULT PrlEvent_GetParamByName(
    PRL_HANDLE hEvent,
    PRL_CONST_STR sParamName,
    PRL_HANDLE_PTR phEventParam
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
sParamName
Event parameter name.
phEventParam
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_NO_DATA - parameter with specfied name does not exist.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

An event container may contain multiple parameters. The meaning of the parameter may be different for different event types.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetParamsCount Function

PrlEvent_GetParamsCount Function
PrlApi.h PHT_EVENT Send Feedback

Determines the number of the parameters in the event container.

Syntax
PRL_RESULT PrlEvent_GetParamsCount(
    PRL_HANDLE hEvent,
    PRL_UINT32_PTR pnParamsCount
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pnParamsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_UNIMPLEMENTED - the event object does not support this functionality.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetServer Function

PrlEvent_GetServer Function
PrlApi.h PHT_EVENT Send Feedback

Obtains a handle of type PHT_SERVER identifying the Parallels Service that generated the event.

Syntax
PRL_RESULT PrlEvent_GetServer(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR server
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
server
[out] A pointer to a variable that receives the server handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When processing an event inside a callback function (event handler) this function is the only way to get the server handle.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetType Function

PrlEvent_GetType Function
PrlApi.h PHT_EVENT Send Feedback

Returns the type of the event.

Syntax
PRL_RESULT PrlEvent_GetType(
    PRL_HANDLE hEvent,
    PRL_EVENT_TYPE_PTR type
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
type
[out] A pointer to a variable that receives the result (event type).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT


PrlEvent_GetVm Function

PrlEvent_GetVm Function
PrlApi.h PHT_EVENT Send Feedback

Obtains a handle of type PHT_VIRTUAL_MACHINE referencing the virtual machine that generated the event.

Syntax
PRL_RESULT PrlEvent_GetVm(
    PRL_HANDLE hEvent,
    PRL_HANDLE_PTR pVm
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pVm
[out] A pointer to a variable that receives the virtual machine handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When processing an event inside a callback function (event handler) this function is the only way to get the virtual machine handle.

Links
PrlApi.h, PHT_EVENT


PrlEvent_IsAnswerRequired Function

PrlEvent_IsAnswerRequired Function
PrlApi.h PHT_EVENT Send Feedback

Determines whether the event requires a response from the client.

Syntax
PRL_RESULT PrlEvent_IsAnswerRequired(
    PRL_HANDLE hEvent,
    PRL_BOOL_PTR pbIsAnswerRequired
);
File

PrlApi.h

Parameters

hEvent
A handle of type PHT_EVENT identifying the event.
pbIsAnswerRequired
[out] A pointer to a variable that receives the result. PBL_TRUE indicates that a response is required. PBL_TRUE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See PrlEvent_CreateAnswerEvent for more information about Parallels Service questions.

Links
PrlApi.h, PHT_EVENT


PrlEvtPrm_GetName Function

PrlEvtPrm_GetName Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter name.

Syntax
PRL_RESULT PrlEvtPrm_GetName(
    PRL_HANDLE hEventParam,
    PRL_STR sParamName,
    PRL_UINT32_PTR pnParamNameBufLength
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_GetType Function

PrlEvtPrm_GetType Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter data type.

Syntax
PRL_RESULT PrlEvtPrm_GetType(
    PRL_HANDLE hEventParam,
    PRL_PARAM_FIELD_DATA_TYPE_PTR pnParamType
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamType
[out] A pointer to a variable that receives the parameter type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToBoolean Function

PrlEvtPrm_ToBoolean Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as boolean (PRL_BOOL).

Syntax
PRL_RESULT PrlEvtPrm_ToBoolean(
    PRL_HANDLE hEventParam,
    PRL_BOOL_PTR pbParamValue
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pbParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToCData Function

PrlEvtPrm_ToCData Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as CDATA.

Syntax
PRL_RESULT PrlEvtPrm_ToCData(
    PRL_HANDLE hEventParam,
    PRL_STR sParamValue,
    PRL_UINT32_PTR pnParamValueBufLength
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamValue
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamValueBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToHandle Function

PrlEvtPrm_ToHandle Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as PRL_HANDLE.

Syntax
PRL_RESULT PrlEvtPrm_ToHandle(
    PRL_HANDLE hEventParam,
    PRL_HANDLE_PTR phParamValue
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
phParamValue
[out] A pointer to a variable that receives the handle. The handle type can be determined using the PrlHandle_GetType function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToInt32 Function

PrlEvtPrm_ToInt32 Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as PRL_INT32.

Syntax
PRL_RESULT PrlEvtPrm_ToInt32(
    PRL_HANDLE hEventParam,
    PRL_INT32_PTR pnParamValue
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToString Function

PrlEvtPrm_ToString Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as string.

Syntax
PRL_RESULT PrlEvtPrm_ToString(
    PRL_HANDLE hEventParam,
    PRL_STR sParamValue,
    PRL_UINT32_PTR pnParamValueBufLength
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
sParamValue
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamValueBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlEvtPrm_ToUint32 Function

PrlEvtPrm_ToUint32 Function
PrlApi.h PHT_EVENT_PARAMETER Send Feedback

Returns the event parameter value as PRL_UINT32.

Syntax
PRL_RESULT PrlEvtPrm_ToUint32(
    PRL_HANDLE hEventParam,
    PRL_UINT32_PTR pnParamValue
);
File

PrlApi.h

Parameters

hEventParam
A handle of type PHT_EVENT_PARAMETER identifying the container.
pnParamValue
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_EVENT_PARAMETER


PrlFoundVmInfo_GetConfigPath Function

PrlFoundVmInfo_GetConfigPath Function
PrlApi.h PHT_FOUND_VM_INFO Send Feedback

Extracts the virtual machine configuration path from the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetConfigPath(
    PRL_HANDLE handle,
    PRL_STR sPath,
    PRL_UINT32_PTR pnPathBufLength
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
sPath
[out] A pointer to a buffer that receives the path. Pass a null pointer to determine the required buffer size.
pnPathBufLength
[in] The size of the buffer used to receive the output data (in bytes). [out] The required buffer size if the buffer parameter contains a null pointer or if the specified buffer size is not large enough.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_FOUND_VM_INFO


PrlFoundVmInfo_GetName Function

PrlFoundVmInfo_GetName Function
PrlApi.h PHT_FOUND_VM_INFO Send Feedback

Extracts the virtual machine name form the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetName(
    PRL_HANDLE handle,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
sName
[out] A pointer to a buffer that receives the name. Pass a null pointer to determine the required buffer size.
pnNameBufLength
[in] The size of the buffer used to receive the output data (in bytes). [out] The required buffer size if the buffer parameter contains a null pointer or if the specified buffer size is not large enough.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_FOUND_VM_INFO


PrlFoundVmInfo_GetOSVersion Function

PrlFoundVmInfo_GetOSVersion Function
PrlApi.h PHT_FOUND_VM_INFO Send Feedback

Extracts the virtual machine's OS version from the container.

Syntax
PRL_RESULT PrlFoundVmInfo_GetOSVersion(
    PRL_HANDLE handle,
    PRL_UINT32_PTR pnOSVersion
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pnOSVersion
[out] A pointer to a variable that receives the OS version.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_FOUND_VM_INFO


PrlFoundVmInfo_IsOldConfig Function

PrlFoundVmInfo_IsOldConfig Function
PrlApi.h PHT_FOUND_VM_INFO Send Feedback

Determines if the virtual machine has an old configuration.

Syntax
PRL_RESULT PrlFoundVmInfo_IsOldConfig(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbOldVersion
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pbOldVersion
[out] A pointer to a variable that receives the result. A value of "true" indicates that the machine has an old configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_FOUND_VM_INFO


PrlFoundVmInfo_IsTemplate Function

PrlFoundVmInfo_IsTemplate Function
PrlApi.h PHT_FOUND_VM_INFO Send Feedback

Determines of the specified virtual machine is a template.

Syntax
PRL_RESULT PrlFoundVmInfo_IsTemplate(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsTemplate
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_FOUND_VM_INFO identifying the container.
pbIsTemplate
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the virtual machine is a template. PRL_TRUE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_FOUND_VM_INFO


PrlFs.h

PrlFs.h
Files Macros Send Feedback

PrlFs.h

This file is the part of parallels public sdk library

Remote file system specific definitions

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Macros
Name | Description
FS_PERM_EXECUTE |
FS_PERM_READ |
FS_PERM_WRITE |
IS_FS_EXECUTE_PERMITTED |
IS_FS_READ_PERMITTED |
IS_FS_WRITE_PERMITTED |
SET_FS_EXECUTE_DISABLED |
SET_FS_EXECUTE_ENABLED |
SET_FS_READ_DISABLED |
SET_FS_READ_ENABLED |
SET_FS_WRITE_DISABLED |
SET_FS_WRITE_ENABLED |
Links
Files, Macros


PrlFsEntry_GetAbsolutePath Function

PrlFsEntry_GetAbsolutePath Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the specified file system entry absolute path.

Syntax
PRL_RESULT PrlFsEntry_GetAbsolutePath(
    PRL_HANDLE hFsEntry,
    PRL_STR sAbsolutePath,
    PRL_UINT32_PTR pnAbsolutePathBufLength
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sAbsolutePath
[out] A pointer to a buffer that receives the path (a UTF-8 encoded, null-terminated string).
pnAbsolutePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetLastModifiedDate Function

PrlFsEntry_GetLastModifiedDate Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the date on which the specified file system entry was last modified.

Syntax
PRL_RESULT PrlFsEntry_GetLastModifiedDate(
    PRL_HANDLE hFsEntry,
    PRL_STR sFsEntryLastModifiedDate,
    PRL_UINT32_PTR pnFsEntryLastModifiedDateBufLength
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sFsEntryLastModifiedDate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The date is specified as: yyyy-mm-dd hh:mi:ss.
pnFsEntryLastModifiedDateBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returned time is a local time (i.e. the time value is returned already converted to local time zone).

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetPermissions Function

PrlFsEntry_GetPermissions Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the specified file system entry permissions (read, write, execute) for the current user.

Syntax
PRL_RESULT PrlFsEntry_GetPermissions(
    PRL_HANDLE hFsEntry,
    PRL_UINT32_PTR pnPermissions
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnPermissions
[out] A pointer to a variable that receives the permission information. The permissions are specified as bitmasks. For bitmask values see macros in the PrlFs.h file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetRelativeName Function

PrlFsEntry_GetRelativeName Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the file system entry relative name.

Syntax
PRL_RESULT PrlFsEntry_GetRelativeName(
    PRL_HANDLE hFsEntry,
    PRL_STR sRelativeName,
    PRL_UINT32_PTR pnRelativeNameBufLength
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
sRelativeName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnRelativeNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetSize Function

PrlFsEntry_GetSize Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the file system entry size.

Syntax
PRL_RESULT PrlFsEntry_GetSize(
    PRL_HANDLE hFsEntry,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnSize
[out] A pointer to a variable that receives the size (in bytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsEntry_GetType Function

PrlFsEntry_GetType Function
PrlApi.h PHT_REMOTE_FILESYSTEM_ENTRY Send Feedback

Returns the file system entry type (file, directory, drive).

Syntax
PRL_RESULT PrlFsEntry_GetType(
    PRL_HANDLE hFsEntry,
    PRL_FILE_SYSTEM_ELEMENT_TYPE_PTR pnFsEntryType
);
File

PrlApi.h

Parameters

hFsEntry
A handle of type PHT_REMOTE_FILESYSTEM_ENTRY identifying the file system entry.
pnFsEntryType
[out] A pointer to a variable that receives the type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_ENTRY


PrlFsInfo_GetChildEntriesCount Function

PrlFsInfo_GetChildEntriesCount Function
PrlApi.h PHT_REMOTE_FILESYSTEM_INFO Send Feedback

Determines the number of child entries for the specified remote file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetChildEntriesCount(
    PRL_HANDLE hFsInfo,
    PRL_UINT32_PTR pnChildEntriesCount
);
File

PrlApi.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnChildEntriesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetChildEntry Function

PrlFsInfo_GetChildEntry Function
PrlApi.h PHT_REMOTE_FILESYSTEM_INFO Send Feedback

Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY containing a child entry information.

Syntax
PRL_RESULT PrlFsInfo_GetChildEntry(
    PRL_HANDLE hFsInfo,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phChildEntry
);
File

PrlApi.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the parent file system entry.
nIndex
A child entry index. To get the total number of child entries, use the PrlFsInfo_GetChildEntriesCount function.
phChildEntry
[out] A pointer to a variable that receives the child entry handle. The handle type is PHT_REMOTE_FILESYSTEM_ENTRY.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetFsType Function

PrlFsInfo_GetFsType Function
PrlApi.h PHT_REMOTE_FILESYSTEM_INFO Send Feedback

Determines the file system type of the specified file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetFsType(
    PRL_HANDLE hFsInfo,
    PRL_FILE_SYSTEM_FS_TYPE_PTR pnFsType
);
File

PrlApi.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnFsType
[out] A pointer to a variable that receives the file entry type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetParentEntry Function

PrlFsInfo_GetParentEntry Function
PrlApi.h PHT_REMOTE_FILESYSTEM_INFO Send Feedback

Obtains a handle of type PHT_REMOTE_FILESYSTEM_ENTRY to the parent file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetParentEntry(
    PRL_HANDLE hFsInfo,
    PRL_HANDLE_PTR phParentEntry
);
File

PrlApi.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
phParentEntry
[out] A pointer to a variable that receives the handle. The handle type is PHT_REMOTE_FILESYSTEM_ENTRY.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_INFO


PrlFsInfo_GetType Function

PrlFsInfo_GetType Function
PrlApi.h PHT_REMOTE_FILESYSTEM_INFO Send Feedback

Determines the basic type of the specified file system entry.

Syntax
PRL_RESULT PrlFsInfo_GetType(
    PRL_HANDLE hFsInfo,
    PRL_FILE_SYSTEM_TYPE_PTR pnFsType
);
File

PrlApi.h

Parameters

hFsInfo
A handle of type PHT_REMOTE_FILESYSTEM_INFO identifying the remote file system entry.
pnFsType
[out] A pointer to a variable that receives the file entry type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_REMOTE_FILESYSTEM_INFO


PrlHandle_AddRef Function

PrlHandle_AddRef Function
PrlApi.h Handle Functions See Also Send Feedback

Increases the specified handle reference count by one.

Syntax
PRL_RESULT PrlHandle_AddRef(
    PRL_HANDLE handle
);
File

PrlApi.h

Parameters

handle
Handle to duplicate.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handles used within the Parallels API are thread safe. They can be used in multiple threads at the same time. To maintain the proper reference counting, the count should be increased each time a handle is passed to another thread by calling the PrlHandle_AddRef function. If this is not done, freeing a handle in one thread may destroy it while other threads are still using it.

See Also

PrlHandle_Free

Links
PrlApi.h, Handle Functions, See Also


PrlHandle_Free Function

PrlHandle_Free Function
PrlApi.h Handle Functions Send Feedback

Frees the specified handle.

Syntax
PRL_RESULT PrlHandle_Free(
    PRL_HANDLE handle
);
File

PrlApi.h

Parameters

handle
Handle to free.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handles used within the Parallels API are reference counted. Each handle contains a count of the number of references to it held by other objects. A corresponding object stays in memory for as long as the count is greater than zero. A client application is responsible for freeing any handles that are no longer required. A handle can be freed using the PrlHandle_Free function. The function decreases the reference count by one. When the count reaches zero, the object is destroyed. Failing to free a handle after it has been used will result in a memory leak.

Links
PrlApi.h, Handle Functions


PrlHandle_GetType Function

PrlHandle_GetType Function
PrlApi.h Handle Functions Send Feedback

Returns the type of the specified handle.

Syntax
PRL_RESULT PrlHandle_GetType(
    PRL_HANDLE handle,
    PRL_HANDLE_TYPE_PTR type
);
File

PrlApi.h

Parameters

handle
Handle to get the type for.
type
[out] A pointer to a variable that receives the result. The type is returned as an enumerator of the PRL_HANDLE_TYPE enumeration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Handle is an abstraction that is used to hide an object implementation. While there are many methods used to access functionality of different objects, this method is used to identify object type as one of the PRL_HANDLE_TYPE types.

Links
PrlApi.h, Handle Functions


PrlIoStructs.h

PrlIoStructs.h
Files Legend Macros Structures Types Send Feedback

PrlIOStructs.h

This file is the part of parallels public sdk library

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Macros
Name | Description
PRL_IO_MAX_DISPLAYS |
Structures
Name
Description
_PRL_IO_ATTACH_REQUEST
_PRL_IO_ATTACH_RESPONSE
_PRL_IO_AUTH_REQUEST
_PRL_IO_AUTH_RESPONSE
_PRL_IO_DESKTOP_UTILITIES_STATE
_PRL_IO_DEVICE_USED
_PRL_IO_DISPLAY_PALETTE
_PRL_IO_DISPLAY_SCREEN_REGION
_PRL_IO_DISPLAY_SCREEN_SIZE
_PRL_IO_DYNRES_TOOLS_STATUS
_PRL_IO_ENCODING_REQUEST
_PRL_IO_ENCODING_RESPONSE
_PRL_IO_GENERIC_BUFFER
_PRL_IO_GRACEFUL_SHUTDOWN
_PRL_IO_GUEST_SCREENSAVER_STATE
_PRL_IO_KEYBOARD_LEDS
_PRL_IO_KEYBOARD_SCANCODE
_PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
_PRL_IO_MOUSE_CURSOR
_PRL_IO_MOUSE_EVENT
_PRL_IO_SCREEN_BUFFER_REGION
_PRL_IO_SCREEN_REGION
_PRL_IO_SCREEN_SIZE
_PRL_IO_SCREEN_SURFACE
_PRL_IO_SCREEN_UPDATE
_PRL_IO_SET_TASKBAR_VISIBILITY
_PRL_IO_SLIDING_MOUSE
_PRL_IO_TOOLS_MOVE_TASKBAR
_PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
_PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
_PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
_PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
_PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO
PRL_IO_ATTACH_REQUEST
PRL_IO_ATTACH_RESPONSE
PRL_IO_AUTH_REQUEST
PRL_IO_AUTH_RESPONSE
PRL_IO_DESKTOP_UTILITIES_STATE
PRL_IO_DEVICE_USED
PRL_IO_DISPLAY_PALETTE
PRL_IO_DISPLAY_SCREEN_REGION
PRL_IO_DISPLAY_SCREEN_SIZE
PRL_IO_DYNRES_TOOLS_STATUS
PRL_IO_ENCODING_REQUEST
PRL_IO_ENCODING_RESPONSE
PRL_IO_GENERIC_BUFFER
PRL_IO_GRACEFUL_SHUTDOWN
PRL_IO_GUEST_SCREENSAVER_STATE
PRL_IO_KEYBOARD_LEDS
PRL_IO_KEYBOARD_SCANCODE
PRL_IO_MEMORY_INFO
PRIVATE STRUCTS
PRL_IO_MOUSE_CURSOR
PRL_IO_MOUSE_EVENT
PRL_IO_SCREEN_BUFFER_REGION
PRL_IO_SCREEN_REGION
PRL_IO_SCREEN_SIZE
PRL_IO_SCREEN_SURFACE
PRL_IO_SCREEN_UPDATE
PRL_IO_SET_TASKBAR_VISIBILITY
PRL_IO_SLIDING_MOUSE
PRL_IO_TOOLS_MOVE_TASKBAR
PRL_IO_TOOLS_SIA_DATA
@brief Structure that represents Parallels Tools Shared Internet Applications data

  • This structure is used to handle message of PET_IO_TOOLS_SIA_DATA type.
PRL_IO_TOOLS_UTILITY_COMMAND
@brief Structure that represents Parallels Tools Utility command

  • This structure is used to handle PET_IO_TOOLS_UTILITY_COMMAND.
PRL_TIS_INT_VERSION
@brief Structure that is used in TIS to represent internal versions

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_RECORD_INFO
PRL_TIS_RECORD_INFO
@brief Fixed size information about TIS record

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_VERSION, PRL_TIS_INT_VERSION
PRL_TIS_VERSION
@brief Structure that is used in TIS to represent versions *

  • TIS - Tools Information Service

*

  • @sa PRL_TIS_INT_VERSION, PRL_TIS_RECORD_INFO

Types
Name | Description
PRL_IO_ATTACH_REQUEST_PTR |
PRL_IO_ATTACH_RESPONSE_PTR |
PRL_IO_AUTH_REQUEST_PTR |
PRL_IO_AUTH_RESPONSE_PTR |
PRL_IO_DESKTOP_UTILITIES_STATE_PTR |
PRL_IO_DEVICE_USED_PTR |
PRL_IO_DISPLAY_PALETTE_PTR |
PRL_IO_DISPLAY_SCREEN_REGION_PTR |
PRL_IO_DISPLAY_SCREEN_SIZE_PTR |
PRL_IO_DYNRES_TOOLS_STATUS_PTR |
PRL_IO_ENCODING_REQUEST_PTR |
PRL_IO_ENCODING_RESPONSE_PTR |
PRL_IO_GENERIC_BUFFER_PTR |
PRL_IO_GRACEFUL_SHUTDOWN_PTR |
PRL_IO_GUEST_SCREENSAVER_STATE_PTR |
PRL_IO_KEYBOARD_LEDS_PTR |
PRL_IO_KEYBOARD_SCANCODE_PTR |
PRL_IO_MEMORY_INFO_PTR |
PRL_IO_MOUSE_CURSOR_PTR |
PRL_IO_MOUSE_EVENT_PTR |
PRL_IO_PALETTE |
PRL_IO_SCREEN_BUFFER_REGION_PTR |
PRL_IO_SCREEN_REGION_PTR |
PRL_IO_SCREEN_SIZE_PTR |
PRL_IO_SCREEN_SURFACE_PTR |
PRL_IO_SCREEN_UPDATE_PTR |
PRL_IO_SET_TASKBAR_VISIBILITY_PTR |
PRL_IO_SLIDING_MOUSE_PTR |
PRL_IO_TOOLS_MOVE_TASKBAR_PTR |
PRL_IO_TOOLS_SIA_DATA_PTR |
PRL_IO_TOOLS_UTILITY_COMMAND_PTR |
PRL_TIS_INT_VERSION_PTR |
PRL_TIS_RECORD_INFO_PTR |
PRL_TIS_VERSION_PTR |
Links
Files, Legend, Macros, Structures, Types


PrlJob_Cancel Function

PrlJob_Cancel Function
PrlApi.h PHT_JOB Send Feedback

Cancel the specified job.

Syntax
PRL_HANDLE PrlJob_Cancel(
    PRL_HANDLE hJob
);
File

PrlApi.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.

Returns

PRL_HANDLE to the job being canceled.

PRL_INVALID_HANDLE - not enough memory to instantiate asynchronous operation.

The results are retrieved using the PrlJob_GetRetCode function. Possible values:

PRL_ERR_INVALID_ARG - invalid PHT_JOB handle was passed.

PRL_ERR_UNINITIALIZED - job instance was not bound to Parallels Service connection.

Remarks

If an asynchronous operation takes a long time to complete, you may cancel it by calling this function. The call does not destroy the job object.

Links
PrlApi.h, PHT_JOB


PrlJob_GetDataPtr Function

PrlJob_GetDataPtr Function
PrlApi.h PHT_JOB Send Feedback

The PrlJob_GetDataPtr function is used to obtain a pointer to a buffer containing the results of an asynchronous operation.

Syntax
PRL_RESULT PrlJob_GetDataPtr(
    PRL_HANDLE hJob,
    PRL_VOID_PTR data_ptr,
    PRL_UINT32_PTR data_size
);
File

PrlApi.h

Parameters

data_ptr
[out] A pointer to a buffer that receives the data. Pass a null pointer to determine the required buffer size.
data_size
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
handle
A handle of type PHT_JOB identifying the job.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Different operations may or may not provide a data buffer as a result of their execution. This function should be used only when an operation results in a buffer populated with the data specific to that operation.

Links
PrlApi.h, PHT_JOB


PrlJob_GetError Function

PrlJob_GetError Function
PrlApi.h PHT_JOB Send Feedback

Provides additional job error information.

Syntax
PRL_RESULT PrlJob_GetError(
    PRL_HANDLE hJob,
    PRL_HANDLE_PTR phError
);
File

PrlApi.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
phError
[out] A pointer to a variable that receives a handle of type PHT_EVENT containing the error information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no additional error information is available.

PRL_ERR_UNIMPLEMENTED - the functionality is not available for this job type.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a job returned an error code (see PrlJob_GetRetCode), you may call this function to see if additional error information is available. If the information is available, the function returns with PRL_ERR_SUCCESS and obtains a handle of type PHT_EVENT containing the information. To extract the information from the object, use the PrlEvent_GetErrString function.

Links
PrlApi.h, PHT_JOB


PrlJob_GetOpCode Function

PrlJob_GetOpCode Function
PrlApi.h PHT_JOB Send Feedback

Returns the job operation code.

Syntax
PRL_RESULT PrlJob_GetOpCode(
    PRL_HANDLE hJob,
    PRL_JOB_OPERATION_CODE_PTR pnOpCode
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_JOB identifying the job.
phError
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A job operation code can be used to identify the function that started the corresponding operation and to determine the type of the result the job object contains. Use this function in an event handler (callback function) when examining a received job object. For example, the operation code PJOC_SRV_LOGIN means that this job belongs to login operation (PrlSrv_Login, PrlSrv_LoginLocal); the PJOC_SRV_GET_VM_LIST code means that the job was started by the PrlSrv_GetVmList function call and contains a list of virtual machines, etc.

Links
PrlApi.h, PHT_JOB


PrlJob_GetProgress Function

PrlJob_GetProgress Function
PrlApi.h PHT_JOB Send Feedback

Obtains a job progress report.

Syntax
PRL_RESULT PrlJob_GetProgress(
    PRL_HANDLE hJob,
    PRL_UINT32_PTR percentage
);
File

PrlApi.h

Parameters

percentage
[out] A pointer to a variable that receives the result (an integer value from 0 to 100).
handle
valid PRL_HANDLE

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The job progress is reported as percentage of completion.

Links
PrlApi.h, PHT_JOB


PrlJob_GetResult Function

PrlJob_GetResult Function
PrlApi.h PHT_JOB Example Send Feedback

Obtains a handle of type PHT_RESULT containing the result returned by the job.

Syntax
PRL_RESULT PrlJob_GetResult(
    PRL_HANDLE hJob,
    PRL_HANDLE_PTR handle
);
File

PrlApi.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
handle
[out] pointer to the job result handle

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OPERATION_PENDING - the asynchronous operation that this job refers to is still in progress.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Depending on the job, the PHT_RESULT object may contain a handle, a list of handles, a string, or a list of strings. The description of each asynchronous function in this documentation contains information whether the function returns a PHT_RESULT object or not, and provides instructions on how to obtain it.

Example

The following code illustrates how to obtain a result from the job object using the login operation as an example.

// Log in to a Parallels Service.
hJob =
PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );

// Wait for the job to complete.
PrlJob_Wait( hJob, 10000 );

// Get a handle of type PHT_RESULT containing the results
// of the operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_JOB, Example


PrlJob_GetRetCode Function

PrlJob_GetRetCode Function
PrlApi.h PHT_JOB Send Feedback

Obtains the return code from the specified job object.

Syntax
PRL_RESULT PrlJob_GetRetCode(
    PRL_HANDLE hJob,
    PRL_RESULT_PTR retcode
);
File

PrlApi.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
retcode
[out] A pointer to a variable that receives the return code.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

On asynchronous operation completion, the job object will contain a return code indicating whether the operation succeeded or failed. Different jobs may return different error codes. The most common codes are: PRL_ERR_INVALID_ARG (invalid input parameters were specified in the asynchronous function call) and PRL_ERR_SUCCESS (function successfully completed).

Links
PrlApi.h, PHT_JOB


PrlJob_GetStatus Function

PrlJob_GetStatus Function
PrlApi.h PHT_JOB Send Feedback

Obtains the current status of the specified job.

Syntax
PRL_RESULT PrlJob_GetStatus(
    PRL_HANDLE hJob,
    PRL_JOB_STATUS_PTR status
);
File

PrlApi.h

Parameters

hJob
A handle if type PHT_JOB identifying the job.
status
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_JOB


PrlJob_Wait Function

PrlJob_Wait Function
PrlApi.h PHT_JOB Example Send Feedback

The PrlJob_Wait function allows to use asynchronous functions synchronously.

Syntax
PRL_RESULT PrlJob_Wait(
    PRL_HANDLE hJob,
    PRL_UINT32 msecs
);
File

PrlApi.h

Parameters

hJob
A handle of type PHT_JOB identifying the job.
msecs
Timeout in milliseconds. The timeout must be long enough for the job to complete. The optimal value is determined empirically. For an infinite timeout, use the UINT_MAX value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - an invalid PHT_JOB handle was passed.

PRL_ERR_TIMEOUT - the specified timeout limit was reached.

PRL_ERR_SUCCESS - operation completed successfully.

Remarks

The function should be called immediately after the corresponding asynchronous function call. It suspends the main thread for the specified number of milliseconds and waits for the job to complete. If the job completes before the timeout value is reached, the function returns and the execution of the main thread continues normally. If the function times out, it returns an error. On function return, the job object will not be destroyed and could be queried until its destruction with the call to PrlHandle_Free.

Example
// Log in to Parallels Service.
// This is an asynchronous call.
// Returns a handle to the Job object.
PRL_HANDLE hJob = PrlSrv_Login(
    hServer, "10.30.23.105", "miket", "1q2w3e",
    0, 0, 0, PRL_SECURITY_LEVEL::PSL_LOW_SECURITY);

// Wait for the Job object to receive the results of the operation.
ret = PrlJob_Wait( hJob, 1000 );
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait returned with error (%s)\n",
        PRL_RESULT_TO_STRING(ret));
    return -1;
}

// Get the results from the Job object.
PRL_RESULT nJobResult;
ret = PrlJob_GetRetCode( hJob, &nJobResult );
if (PRL_FAILED( nJobResult ))
{
    printf("login job returned with error (%s)\n",
        PRL_RESULT_TO_STRING( nJobResult ));
    return -1;
}
else
    printf( "Login succeeded.\n" );

// Delete the Job handle.
PrlHandle_Free( hJob );
Links
PrlApi.h, PHT_JOB, Example


PrlKeys.h

PrlKeys.h
Files Macros Send Feedback

PrlKeys.h

This file is the part of parallels public sdk library

Declarations of keyboard related constants.

Remarks

Copyright {c} 2005-2008 Parallels Software International, Inc. All rights reserved. http://www.parallels.com

Macros
Name | Description
PRL_SCAN_CODE_0 |
PRL_SCAN_CODE_1 |
PRL_SCAN_CODE_2 |
PRL_SCAN_CODE_3 |
PRL_SCAN_CODE_4 |
PRL_SCAN_CODE_5 |
PRL_SCAN_CODE_6 |
PRL_SCAN_CODE_7 |
PRL_SCAN_CODE_8 |
PRL_SCAN_CODE_9 |
PRL_SCAN_CODE_A |
PRL_SCAN_CODE_ALT_LEFT |
PRL_SCAN_CODE_ALT_RIGHT |
PRL_SCAN_CODE_B |
PRL_SCAN_CODE_BACKSLASH |
PRL_SCAN_CODE_BACKSPACE |
PRL_SCAN_CODE_C |
PRL_SCAN_CODE_CAPS_LOCK |
PRL_SCAN_CODE_CBRACE_LEFT |
PRL_SCAN_CODE_CBRACE_RIGHT |
PRL_SCAN_CODE_CMD_LEFT |
PRL_SCAN_CODE_CMD_RIGHT |
PRL_SCAN_CODE_COLON |
PRL_SCAN_CODE_CTRL_LEFT |
PRL_SCAN_CODE_CTRL_RIGHT |
PRL_SCAN_CODE_D |
PRL_SCAN_CODE_DELETE |
PRL_SCAN_CODE_DOWN |
PRL_SCAN_CODE_E |
PRL_SCAN_CODE_ENTER |
PRL_SCAN_CODE_ESC | Scan codes symbolical names for the SDK purposes.
PRL_SCAN_CODE_F |
PRL_SCAN_CODE_F1 |
PRL_SCAN_CODE_F10 |
PRL_SCAN_CODE_F11 |
PRL_SCAN_CODE_F12 |
PRL_SCAN_CODE_F2 |
PRL_SCAN_CODE_F3 |
PRL_SCAN_CODE_F4 |
PRL_SCAN_CODE_F5 |
PRL_SCAN_CODE_F6 |
PRL_SCAN_CODE_F7 |
PRL_SCAN_CODE_F8 |
PRL_SCAN_CODE_F9 |
PRL_SCAN_CODE_G |
PRL_SCAN_CODE_GREATER |
PRL_SCAN_CODE_H |
PRL_SCAN_CODE_I |
PRL_SCAN_CODE_INSERT |
PRL_SCAN_CODE_J |
PRL_SCAN_CODE_K |
PRL_SCAN_CODE_L |
PRL_SCAN_CODE_LEFT |
PRL_SCAN_CODE_LESS |
PRL_SCAN_CODE_M |
PRL_SCAN_CODE_MENU |
PRL_SCAN_CODE_MINUS |
PRL_SCAN_CODE_N |
PRL_SCAN_CODE_NUM_LOCK |
PRL_SCAN_CODE_O |
PRL_SCAN_CODE_P |
PRL_SCAN_CODE_PAD_0 |
PRL_SCAN_CODE_PAD_1 |
PRL_SCAN_CODE_PAD_2 |
PRL_SCAN_CODE_PAD_3 |
PRL_SCAN_CODE_PAD_4 |
PRL_SCAN_CODE_PAD_5 |
PRL_SCAN_CODE_PAD_6 |
PRL_SCAN_CODE_PAD_7 |
PRL_SCAN_CODE_PAD_8 |
PRL_SCAN_CODE_PAD_9 |
PRL_SCAN_CODE_PAD_DEL |
PRL_SCAN_CODE_PAD_ENTER |
PRL_SCAN_CODE_PAD_MINUS |
PRL_SCAN_CODE_PAD_PLUS |
PRL_SCAN_CODE_PAD_SLASH |
PRL_SCAN_CODE_PAD_STAR |
PRL_SCAN_CODE_PAUSE_BREAK |
PRL_SCAN_CODE_PLUS |
PRL_SCAN_CODE_PRINT_SCREEN |
PRL_SCAN_CODE_Q |
PRL_SCAN_CODE_QUOTE |
PRL_SCAN_CODE_R |
PRL_SCAN_CODE_RIGHT |
PRL_SCAN_CODE_S |
PRL_SCAN_CODE_SCROLL_LOCK |
PRL_SCAN_CODE_SHIFT_LEFT |
PRL_SCAN_CODE_SHIFT_RIGHT |
PRL_SCAN_CODE_SLASH |
PRL_SCAN_CODE_SPACE |
PRL_SCAN_CODE_T |
PRL_SCAN_CODE_TAB |
PRL_SCAN_CODE_TILDA |
PRL_SCAN_CODE_U |
PRL_SCAN_CODE_UP |
PRL_SCAN_CODE_V |
PRL_SCAN_CODE_W |
PRL_SCAN_CODE_X |
PRL_SCAN_CODE_Y |
PRL_SCAN_CODE_Z |
Links
Files, Macros


PrlLic_GetCompanyName Function

PrlLic_GetCompanyName Function
PrlApi.h PHT_LICENSE Send Feedback

Returns the name of the company to which this license was issued.

Syntax
PRL_RESULT PrlLic_GetCompanyName(
    PRL_HANDLE hLicense,
    PRL_STR sCompanyName,
    PRL_UINT32_PTR pnCompanyNameBufLength
);
File

PrlApi.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sCompanyName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnCompanyNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LICENSE


PrlLic_GetLicenseKey Function

PrlLic_GetLicenseKey Function
PrlApi.h PHT_LICENSE Send Feedback

Returns the license key string.

Syntax
PRL_RESULT PrlLic_GetLicenseKey(
    PRL_HANDLE hLicense,
    PRL_STR sLicenseKey,
    PRL_UINT32_PTR pnLicenseKeyBufLength
);
File

PrlApi.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sLicenseKey
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnLicenseKeyBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LICENSE


PrlLic_GetStatus Function

PrlLic_GetStatus Function
PrlApi.h PHT_LICENSE Send Feedback

Returns the license status.

Syntax
PRL_RESULT PrlLic_GetStatus(
    PRL_HANDLE hLicense,
    PRL_RESULT_PTR pnValue
);
File

PrlApi.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
pnValue
[out] A pointer to a variable that receives the license status.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LICENSE


PrlLic_GetUserName Function

PrlLic_GetUserName Function
PrlApi.h PHT_LICENSE Send Feedback

Returns the license user name.

Syntax
PRL_RESULT PrlLic_GetUserName(
    PRL_HANDLE hLicense,
    PRL_STR sUserName,
    PRL_UINT32_PTR pnUserNameBufLength
);
File

PrlApi.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
sUserName
[out] A pointer to a buffer that receives the user name (a UTF-8 encoded, null-terminated string).
pnUserNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LICENSE


PrlLic_IsValid Function

PrlLic_IsValid Function
PrlApi.h PHT_LICENSE Send Feedback

Determines if the license is valid.

Syntax
PRL_RESULT PrlLic_IsValid(
    PRL_HANDLE hLicense,
    PRL_BOOL_PTR pbValue
);
File

PrlApi.h

Parameters

hLicense
A handle of type PHT_LICENSE identifying the license.
pbValue
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the license is valid. PRL_FALSE indicates that the license is invalid.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the specified license object does not contain license data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LICENSE


PrlLoginResponse_GetHostOsVersion Function

PrlLoginResponse_GetHostOsVersion Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Returns the host OS version.

Syntax
PRL_RESULT PrlLoginResponse_GetHostOsVersion(
    PRL_HANDLE hLoginResp,
    PRL_STR sHostOsVersion,
    PRL_UINT32_PTR pnHostOsVersionBufLength
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sHostOsVersion
[out] A pointer to a buffer that receives the OS version (a UTF-8 encoded, null-terminated string).
pnHostOsVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlLoginResponse_GetProductVersion Function

PrlLoginResponse_GetProductVersion Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Returns the Parallels product version number.

Syntax
PRL_RESULT PrlLoginResponse_GetProductVersion(
    PRL_HANDLE hLoginResp,
    PRL_STR sProductVersion,
    PRL_UINT32_PTR pnProductVersionBufLength
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sProductVersion
[out] A pointer to a buffer that receives the product version (a UTF-8 encoded, null-terminated string).
pnProductVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlLoginResponse_GetRunningTaskByIndex Function

PrlLoginResponse_GetRunningTaskByIndex Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Obtains a handle of type PHT_RUNNING_TASK.

Syntax
PRL_RESULT PrlLoginResponse_GetRunningTaskByIndex(
    PRL_HANDLE hLoginResp,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phRunningTask
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
nIndex
An index of the task to obtain the handle for (starting at 0). To determine the total number of the available tasks, use the PrlLoginResponse_GetRunningTaskCount function.
phRunningTask
[out] A pointer to a variable that receives the handle of type PHT_RUNNING_TASK containing the task information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a previous session ID was passed to the corresponding login operation, the PHT_LOGIN_RESPONSE object will contain a list of the tasks that were initiated during the previous session and are still running (if any). A task ID (that can be retrieved using this function) can be passed to the PrlSrv_AttachToLostTask function to get a handle to the task, thus gaining control to it.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlLoginResponse_GetRunningTaskCount Function

PrlLoginResponse_GetRunningTaskCount Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Returns the total number of PHT_RUNNING_TASK handles contained in the PHT_LOGIN_RESPONSE object.

Syntax
PRL_RESULT PrlLoginResponse_GetRunningTaskCount(
    PRL_HANDLE hLoginResp,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
pnCount
[out] A pointer to a variable that receives the size of the array.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

See the PrlLoginResponse_GetRunningTaskByIndex function for more information.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlLoginResponse_GetServerUuid Function

PrlLoginResponse_GetServerUuid Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Returns the host machine UUID.

Syntax
PRL_RESULT PrlLoginResponse_GetServerUuid(
    PRL_HANDLE hLoginResp,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sServerUuid
[out] A pointer to a buffer that receives the Parallels Service UUID (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlLoginResponse_GetSessionUuid Function

PrlLoginResponse_GetSessionUuid Function
PrlApi.h PHT_LOGIN_RESPONSE Send Feedback

Returns session UUID string (used to restore a session).

Syntax
PRL_RESULT PrlLoginResponse_GetSessionUuid(
    PRL_HANDLE hLoginResp,
    PRL_STR sSessionUuid,
    PRL_UINT32_PTR pnSessionUuidBufLength
);
File

PrlApi.h

Parameters

hLoginResp
A handle of type PHT_LOGIN_RESPONSE containing the login response info.
sSessionUuid
[out] A pointer to a buffer that receives the session UUID (a UTF-8 encoded, null-terminated string).
pnSessionUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_LOGIN_RESPONSE


PrlNetSvc_GetStatus Function

PrlNetSvc_GetStatus Function
PrlApi.h PHT_NET_SERVICE_STATUS Send Feedback

Returns the Parallels Service network status information.

Syntax
PRL_RESULT PrlNetSvc_GetStatus(
    PRL_HANDLE handle,
    PRL_SERVICE_STATUS_ENUM_PTR pnNetStatus
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_NET_SERVICE_STATUS.
pnNetStatus
[out] A pointer to a variable that receives the status information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_NET_SERVICE_STATUS


PrlOses.h

PrlOses.h
Files Macros Send Feedback

PrlOses.h

This file is the part of parallels public sdk library

Declarations of OSes constants

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Macros
Name | Description
IS_FREEBSD |
IS_LINUX |
IS_MACOS |
IS_MSDOS |
IS_NETWARE |
IS_OS2 |
IS_OTHER |
IS_SOLARIS |
IS_VALID_FREEBSD_VERSION |
IS_VALID_LINUX_VERSION |
IS_VALID_MACOS_VERSION |
IS_VALID_MSDOS_VERSION |
IS_VALID_NETWARE_VERSION |
IS_VALID_OS2_VERSION |
IS_VALID_OTHER_OS_VERSION |
IS_VALID_SOLARIS_VERSION |
IS_VALID_WINDOWS_VERSION |
IS_WINDOWS |
PVS_GET_GUEST_NUMBER |
PVS_GET_GUEST_TYPE |
PVS_GUEST_ARCH_I386 |
PVS_GUEST_ARCH_OTHER | Autodetected OS Architecture
PVS_GUEST_ARCH_X86_64 |
PVS_GUEST_TYPE_FREEBSD |
PVS_GUEST_TYPE_LINUX |
PVS_GUEST_TYPE_MACOS | Guest OS types enumeration
PVS_GUEST_TYPE_MSDOS |
PVS_GUEST_TYPE_NAME_FREEBSD |
PVS_GUEST_TYPE_NAME_LINUX |
PVS_GUEST_TYPE_NAME_MACOS | Guest OS type names
PVS_GUEST_TYPE_NAME_MSDOS |
PVS_GUEST_TYPE_NAME_NETWARE |
PVS_GUEST_TYPE_NAME_OS2 |
PVS_GUEST_TYPE_NAME_OTHER |
PVS_GUEST_TYPE_NAME_SOLARIS |
PVS_GUEST_TYPE_NAME_WINDOWS |
PVS_GUEST_TYPE_NETWARE |
PVS_GUEST_TYPE_OS2 |
PVS_GUEST_TYPE_OTHER |
PVS_GUEST_TYPE_SOLARIS |
PVS_GUEST_TYPE_WINDOWS |
PVS_GUEST_VER_BSD_4X |
PVS_GUEST_VER_BSD_5X |
PVS_GUEST_VER_BSD_6X |
PVS_GUEST_VER_BSD_7X |
PVS_GUEST_VER_BSD_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST
PVS_GUEST_VER_BSD_OTHER |
PVS_GUEST_VER_DOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST
PVS_GUEST_VER_DOS_MS622 |
PVS_GUEST_VER_DOS_OTHER |
PVS_GUEST_VER_LIN_CENTOS |
PVS_GUEST_VER_LIN_DEBIAN |
PVS_GUEST_VER_LIN_FEDORA |
PVS_GUEST_VER_LIN_FEDORA_5 |
PVS_GUEST_VER_LIN_KRNL_24 |
PVS_GUEST_VER_LIN_KRNL_26 |
PVS_GUEST_VER_LIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST
PVS_GUEST_VER_LIN_MANDRAKE |
PVS_GUEST_VER_LIN_OPENSUSE |
PVS_GUEST_VER_LIN_OTHER |
PVS_GUEST_VER_LIN_REDHAT |
PVS_GUEST_VER_LIN_RH_LEGACY |
PVS_GUEST_VER_LIN_RHLES3 |
PVS_GUEST_VER_LIN_SLES9 |
PVS_GUEST_VER_LIN_SUSE |
PVS_GUEST_VER_LIN_UBUNTU |
PVS_GUEST_VER_LIN_XANDROS |
PVS_GUEST_VER_MACOS_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST
PVS_GUEST_VER_MACOS_LEOPARD |
PVS_GUEST_VER_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_MACOS_TIGER |
PVS_GUEST_VER_NAME_BSD_4X |
PVS_GUEST_VER_NAME_BSD_5X |
PVS_GUEST_VER_NAME_BSD_6X |
PVS_GUEST_VER_NAME_BSD_7X |
PVS_GUEST_VER_NAME_BSD_OTHER |
PVS_GUEST_VER_NAME_DOS_MS622 |
PVS_GUEST_VER_NAME_DOS_OTHER |
PVS_GUEST_VER_NAME_LIN_CENTOS |
PVS_GUEST_VER_NAME_LIN_DEBIAN |
PVS_GUEST_VER_NAME_LIN_FEDORA |
PVS_GUEST_VER_NAME_LIN_FEDORA_5 |
PVS_GUEST_VER_NAME_LIN_KRNL_24 |
PVS_GUEST_VER_NAME_LIN_KRNL_26 |
PVS_GUEST_VER_NAME_LIN_MANDRAKE |
PVS_GUEST_VER_NAME_LIN_OPENSUSE |
PVS_GUEST_VER_NAME_LIN_OTHER |
PVS_GUEST_VER_NAME_LIN_REDHAT |
PVS_GUEST_VER_NAME_LIN_RH_LEGACY |
PVS_GUEST_VER_NAME_LIN_RHLES3 |
PVS_GUEST_VER_NAME_LIN_SLES9 |
PVS_GUEST_VER_NAME_LIN_SUSE |
PVS_GUEST_VER_NAME_LIN_UBUNTU |
PVS_GUEST_VER_NAME_LIN_XANDROS |
PVS_GUEST_VER_NAME_MACOS_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD |
PVS_GUEST_VER_NAME_MACOS_TIGER | Guest OS version names
PVS_GUEST_VER_NAME_NET_4X |
PVS_GUEST_VER_NAME_NET_5X |
PVS_GUEST_VER_NAME_NET_6X |
PVS_GUEST_VER_NAME_NET_OTHER |
PVS_GUEST_VER_NAME_OS2_ECS11 |
PVS_GUEST_VER_NAME_OS2_ECS12 |
PVS_GUEST_VER_NAME_OS2_OTHER |
PVS_GUEST_VER_NAME_OS2_WARP3 |
PVS_GUEST_VER_NAME_OS2_WARP4 |
PVS_GUEST_VER_NAME_OS2_WARP45 |
PVS_GUEST_VER_NAME_OTH_OPENSTEP |
PVS_GUEST_VER_NAME_OTH_OTHER |
PVS_GUEST_VER_NAME_OTH_QNX |
PVS_GUEST_VER_NAME_SOL_10 |
PVS_GUEST_VER_NAME_SOL_11 |
PVS_GUEST_VER_NAME_SOL_9 |
PVS_GUEST_VER_NAME_SOL_OTHER |
PVS_GUEST_VER_NAME_WIN_2003 |
PVS_GUEST_VER_NAME_WIN_2008 |
PVS_GUEST_VER_NAME_WIN_2K |
PVS_GUEST_VER_NAME_WIN_311 |
PVS_GUEST_VER_NAME_WIN_95 |
PVS_GUEST_VER_NAME_WIN_98 |
PVS_GUEST_VER_NAME_WIN_ME |
PVS_GUEST_VER_NAME_WIN_NT |
PVS_GUEST_VER_NAME_WIN_OTHER |
PVS_GUEST_VER_NAME_WIN_VISTA |
PVS_GUEST_VER_NAME_WIN_WINDOWS7 |
PVS_GUEST_VER_NAME_WIN_XP |
PVS_GUEST_VER_NET_4X |
PVS_GUEST_VER_NET_5X |
PVS_GUEST_VER_NET_6X |
PVS_GUEST_VER_NET_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST
PVS_GUEST_VER_NET_OTHER |
PVS_GUEST_VER_OS2_ECS11 |
PVS_GUEST_VER_OS2_ECS12 |
PVS_GUEST_VER_OS2_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST
PVS_GUEST_VER_OS2_OTHER |
PVS_GUEST_VER_OS2_WARP3 |
PVS_GUEST_VER_OS2_WARP4 |
PVS_GUEST_VER_OS2_WARP45 |
PVS_GUEST_VER_OTH_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST
PVS_GUEST_VER_OTH_OPENSTEP |
PVS_GUEST_VER_OTH_OTHER |
PVS_GUEST_VER_OTH_QNX |
PVS_GUEST_VER_SOL_10 |
PVS_GUEST_VER_SOL_11 |
PVS_GUEST_VER_SOL_9 |
PVS_GUEST_VER_SOL_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST
PVS_GUEST_VER_SOL_OTHER |
PVS_GUEST_VER_WIN_2003 |
PVS_GUEST_VER_WIN_2008 |
PVS_GUEST_VER_WIN_2K |
PVS_GUEST_VER_WIN_311 |
PVS_GUEST_VER_WIN_95 |
PVS_GUEST_VER_WIN_98 |
PVS_GUEST_VER_WIN_LAST | Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST
PVS_GUEST_VER_WIN_ME |
PVS_GUEST_VER_WIN_NT |
PVS_GUEST_VER_WIN_OTHER |
PVS_GUEST_VER_WIN_VISTA |
PVS_GUEST_VER_WIN_WINDOWS7 |
PVS_GUEST_VER_WIN_XP |
PVS_MAKE_GUEST_VER |
Links
Files, Macros


PrlPortFwd_Create Function

PrlPortFwd_Create Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Creates a new handle of type PHT_PORT_FORWARDING.

Syntax
PRL_RESULT PrlPortFwd_Create(
    PRL_HANDLE_PTR phPortFwd
);
File

PrlApi.h

Parameters

phPortFwd
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the user to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_GetIncomingPort Function

PrlPortFwd_GetIncomingPort Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Returns the incoming port.

Syntax
PRL_RESULT PrlPortFwd_GetIncomingPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16_PTR pnIncomingPort
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
pnIncomingPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_GetRedirectIPAddress Function

PrlPortFwd_GetRedirectIPAddress Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Returns the redirect IP address of the specified port forward entry.

Syntax
PRL_RESULT PrlPortFwd_GetRedirectIPAddress(
    PRL_HANDLE hPortFwd,
    PRL_STR sRedirectIPAddress,
    PRL_UINT32_PTR pnRedirectIPAddressBufLength
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnRedirectIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_GetRedirectPort Function

PrlPortFwd_GetRedirectPort Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Returns the redirect port.

Syntax
PRL_RESULT PrlPortFwd_GetRedirectPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16_PTR pnRedirectPort
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
pnRedirectPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_SetIncomingPort Function

PrlPortFwd_SetIncomingPort Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Sets the specified incoming port.

Syntax
PRL_RESULT PrlPortFwd_SetIncomingPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16 nIncomingPort
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
nIncomingPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_SetRedirectIPAddress Function

PrlPortFwd_SetRedirectIPAddress Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Sets the specified port forwardi entry redirect IP address.

Syntax
PRL_RESULT PrlPortFwd_SetRedirectIPAddress(
    PRL_HANDLE hPortFwd,
    PRL_CONST_STR sRedirectIPAddress
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
sRedirectIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlPortFwd_SetRedirectPort Function

PrlPortFwd_SetRedirectPort Function
PrlApi.h PHT_PORT_FORWARDING Send Feedback

Sets the specified redirect port.

Syntax
PRL_RESULT PrlPortFwd_SetRedirectPort(
    PRL_HANDLE hPortFwd,
    PRL_UINT16 nRedirectPort
);
File

PrlApi.h

Parameters

hPortFwd
A handle of type PHT_PORT_FORWARDING identifying the port forwarding.
nRedirectPort
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_PORT_FORWARDING


PrlResult_GetParam Function

PrlResult_GetParam Function
PrlApi.h PHT_RESULT Example Send Feedback

Obtains a handle to an object containing the results of the corresponding asynchronous operation.

Syntax
PRL_RESULT PrlResult_GetParam(
    PRL_HANDLE hResult,
    PRL_HANDLE_PTR pHandle
);
File

PrlApi.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
pHandle
[out] A pointer to a variable that receives the handle. The type of handle returned depends on the corresponding operation. The description of each asynchronous function in this documentation provides information about the type of handle that the function returns.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - no result or the result is not a single handle.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you know that the corresponding function always produces a single object as a result. This function is the equivalent of the PrlResult_GetParamByIndex(hResult, 0, &Handle) call (i.e. zero as the index value).

Example

The following example demonstrates using asynchronous function PrlSrv_GetSrvConfig synchronously, and the steps involved in obtaining a handle to an object of type PHT_SERVER_CONFIG (which is returned by PrlSrv_GetSrvConfig):

PRL_HANDLE hJob = PrlSrv_GetSrvConfig(hServer);

// Step 1 - emulate a synchronous call using PrlJob_Wait.

PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
if (PRL_FAILED(ret))
{
    printf("PrlJob_Wait for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 2 - determine if PrlSrv_GetSrvConfig succeeded or failed
// using PrlJob_GetRetCode.

PrlJob_GetRetCode(hJob, &nJobResult);
if (PRL_FAILED(nJobResult))
{
    printf("PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 3 - Obtain a handle to the result object (a handle
// of type PHT_RESULT) using PrlJob_GetResult.

PRL_HANDLE hResult;
ret = PrlJob_GetResult(hJob, &hResult);
PrlHandle_Free(hJob); // hJob no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlJob_GetResult for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hResult);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();
    return -1;
}

// Step 4 - Get a handle to the final result (in this case,
// a handle of type PHT_SERVER_CONFIG) using PrlResult_GetParam.
// For PHT_RESULT handles that contain more than one result, first use
// PrlResult_GetParamsCount, then use PrlResult_GetParamByIndex.

PRL_HANDLE hServerConfig;
ret = PrlResult_GetParam(hResult, &hServerConfig);
PrlHandle_Free(hResult); // hResult no longer needed, free it.

if (PRL_FAILED(ret))
{
    printf("PrlResult_GetParam for job PrlSrv_GetSrvConfig returned error: %s\n",
        PRL_RESULT_TO_STRING(ret));

    PrlHandle_Free(hServerConfig);
    PrlHandle_Free(hServer);
    PrlApi_Deinit();
    SdkWrap_Unload();

    return -1;
}

// At this point, a handle of type PHT_SERVER_CONFIG is available, and
// functions that operate on PHT_SERVER_CONFIG handles can be used on
// the handle.

PRL_UINT32 nCpuCount = 0;
PrlSrvCfg_GetCpuCount(hServerConfig, &nCpuCount);
printf("Number of CPUs: %d\n", nCpuCount);

PRL_CPU_MODE CpuMode;
PrlSrvCfg_GetCpuMode(hServerConfig, &CpuMode);
printf("CPU Mode: %d bit\n", CpuMode == PCM_CPU_MODE_32 ? 32 : 64);

PRL_CHAR szCpuModel[1024];
PRL_UINT32 nCpuModelSize = sizeof(szCpuModel);
memset(szCpuModel, 0, nCpuModelSize);
PrlSrvCfg_GetCpuModel(hServerConfig, szCpuModel, &nCpuModelSize);
printf("CPU Model: %s\n", szCpuModel);

PRL_UINT32 nCpuSpeed = 0;
PrlSrvCfg_GetCpuSpeed(hServerConfig, &nCpuSpeed);
printf("CPU Speed: %.3f MHz\n", nCpuSpeed / 1000.0);

PRL_CHAR szHostOsString[1024];
PRL_UINT32 nHostOsStringSize = sizeof(szHostOsString);
PrlSrvCfg_GetHostOsStrPresentation(hServerConfig, szHostOsString, &nHostOsStringSize);
printf("Host OS: %s\n", szHostOsString);

PrlHandle_Free(hServerConfig);
Links
PrlApi.h, PHT_RESULT, Example


PrlResult_GetParamAsString Function

PrlResult_GetParamAsString Function
PrlApi.h PHT_RESULT Send Feedback

Obtains a string result from the result object.

Syntax
PRL_RESULT PrlResult_GetParamAsString(
    PRL_HANDLE hResult,
    PRL_STR sParamBuf,
    PRL_UINT32_PTR pnParamBufSize
);
File

PrlApi.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
sParamBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you know that the corresponding function always produces a single string as a result. This function is the equivalent of the PrlResult_GetParamByIndexAsString(hResult, 0, &myString) call (i.e. zero as the index value).

Links
PrlApi.h, PHT_RESULT


PrlResult_GetParamByIndex Function

PrlResult_GetParamByIndex Function
PrlApi.h PHT_RESULT Example Send Feedback

Obtains a handle from the result object identified by the index.

Syntax
PRL_RESULT PrlResult_GetParamByIndex(
    PRL_HANDLE hResult,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phParam
);
File

PrlApi.h

Parameters

nIndex
An index identifying the handle in the list.
phParam
[out] A pointer to a variable that receives the handle. The type of handle returned depends on the corresponding operation. The description of each asynchronous function in this documentation provides information about the type of handle that the function returns.
handle
A handle of type PHT_RESULT identifying the result object.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when the result contains (or may contain) multiple objects. To obtain multiple handles from the result object, first, determine the number of handles contained in the object using the PrlResult_GetParamsCount function. Then, iterate through the list and use the iteration number as the value of the nIndex parameter.

Example

The following example demonstrates using asynchronous function PrlSrv_GetVmList (getting the list of virtual machines), and the steps involved in obtaining handles to objects of type PHT_VIRTUAL_MACHINE returned by PrlSrv_GetVmList (each object contains information about an individual virtual machine):

PRL_RESULT DisplayVmList(const PRL_HANDLE &hServer)
{
    PRL_HANDLE hResult;
    PRL_RESULT nJobResult;

    // Get a list of virtual machines.
    PRL_HANDLE hJob = PrlSrv_GetVmList(hServer);

    // Wait for the job to complete.
    PRL_RESULT ret = PrlJob_Wait(hJob, 10000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Check the results of PrlSrv_GetVmList.
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_GetVmList returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        return ret;
    }

    // Get the results of PrlSrv_GetVmList.
    ret = PrlJob_GetResult(hJob, &hResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetResult returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hResult);
        PrlHandle_Free(hJob);
        return ret;
    }

    // Handle to result object is available,
    // job handle is not longer needed, so free it.
    PrlHandle_Free(hJob);

    // Iteratre through the result list.
    PRL_UINT32 nParamsCount = 0;
    ret = PrlResult_GetParamsCount(hResult, &nParamsCount);

    for (PRL_UINT32 i = 0; i < nParamsCount; ++i)
    {
        PRL_HANDLE hVm;

        // Get a handle to result at index i.
        PrlResult_GetParamByIndex(hResult, i, &hVm);

        // Get the name of the virtual machine for result i.
        char szVmNameReturned[1024];
        PRL_UINT32 nBufSize = sizeof(szVmNameReturned);
        ret = PrlVm_GetName(hVm, szVmNameReturned, &nBufSize);

        if (PRL_FAILED(ret))
        {
            printf("PrlVm_GetName returned with error (%s)\n",
                PRL_RESULT_TO_STRING(ret));
        }
        else
        {
            printf("Virtual machine '%s' is available.\n\n", szVmNameReturned);
        }

        // Free the virtual machine handle.
        PrlHandle_Free(hVm);
    }

    return PRL_ERR_SUCCESS;
}
Links
PrlApi.h, PHT_RESULT, Example


PrlResult_GetParamByIndexAsString Function

PrlResult_GetParamByIndexAsString Function
PrlApi.h PHT_RESULT Send Feedback

Obtains a string result from the result object identified by the index.

Syntax
PRL_RESULT PrlResult_GetParamByIndexAsString(
    PRL_HANDLE hResult,
    PRL_UINT32 nIndex,
    PRL_STR sParamBuf,
    PRL_UINT32_PTR pnParamBufSize
);
File

PrlApi.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
nIndex
An index identifying the string item in the list.
sParamBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnParamBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when the result contains (or may contain) multiple string items. To obtain multiple items from the result object, first, determine the number of items contained in the object using the PrlResult_GetParamsCount function. Then, iterate through the list and use the iteration number as the value of the nIndex parameter.

Links
PrlApi.h, PHT_RESULT


PrlResult_GetParamsCount Function

PrlResult_GetParamsCount Function
PrlApi.h PHT_RESULT Send Feedback

Determines the number of items in the specified result object.

Syntax
PRL_RESULT PrlResult_GetParamsCount(
    PRL_HANDLE hResult,
    PRL_UINT32_PTR pCount
);
File

PrlApi.h

Parameters

hResult
A handle of type PHT_RESULT identifying the result object.
pCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_RESULT


PrlRunningTask_GetTaskParametersAsString Function

PrlRunningTask_GetTaskParametersAsString Function
PrlApi.h PHT_RUNNING_TASK Send Feedback

Returns task parameters as a string.

Syntax
PRL_RESULT PrlRunningTask_GetTaskParametersAsString(
    PRL_HANDLE hRunningTask,
    PRL_STR sParamsStr,
    PRL_UINT32_PTR pnsParamsStrBufLength
);
File

PrlApi.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
sParamsStr
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnsParamsStrBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Value returns in UTF-8 encoding. Null char ('0') adding to the end of string.

Links
PrlApi.h, PHT_RUNNING_TASK


PrlRunningTask_GetTaskType Function

PrlRunningTask_GetTaskType Function
PrlApi.h PHT_RUNNING_TASK Send Feedback

Determines the task type.

Syntax
PRL_RESULT PrlRunningTask_GetTaskType(
    PRL_HANDLE hRunningTask,
    PRL_RUNNING_TASK_TYPE_ENUM_PTR pnType
);
File

PrlApi.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
pnType
[out] A pointer to a variable that receives the task type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_RUNNING_TASK


PrlRunningTask_GetTaskUuid Function

PrlRunningTask_GetTaskUuid Function
PrlApi.h PHT_RUNNING_TASK Send Feedback

Returns the task UUID (universally unique ID).

Syntax
PRL_RESULT PrlRunningTask_GetTaskUuid(
    PRL_HANDLE hRunningTask,
    PRL_STR sTaskUuid,
    PRL_UINT32_PTR pnTaskUuidBufLength
);
File

PrlApi.h

Parameters

hRunningTask
A handle of type PHT_RUNNING_TASK identifying the task.
sTaskUuid
[out] A pointer to a buffer that receives the task UUID (a UTF-8 encoded, null-terminated string).
pnTaskUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_RUNNING_TASK


PrlShare_GetDescription Function

PrlShare_GetDescription Function
PrlApi.h PHT_SHARE See Also Send Feedback

Returns the shared folder description.

Syntax
PRL_RESULT PrlShare_GetDescription(
    PRL_HANDLE hVmShare,
    PRL_STR sShareDescription,
    PRL_UINT32_PTR pnShareDescriptionBufLength
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sShareDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnShareDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetDescription

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_GetName Function

PrlShare_GetName Function
PrlApi.h PHT_SHARE See Also Send Feedback

Returns the shared folder name (as it appears in the guest OS).

Syntax
PRL_RESULT PrlShare_GetName(
    PRL_HANDLE hVmShare,
    PRL_STR sShareName,
    PRL_UINT32_PTR pnShareNameBufLength
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sShareName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnShareNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetName

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_GetPath Function

PrlShare_GetPath Function
PrlApi.h PHT_SHARE See Also Send Feedback

Returns the shared folder path.

Syntax
PRL_RESULT PrlShare_GetPath(
    PRL_HANDLE hVmShare,
    PRL_STR sSharePath,
    PRL_UINT32_PTR pnSharePathBufLength
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sSharePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSharePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetPath

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_IsEnabled Function

PrlShare_IsEnabled Function
PrlApi.h PHT_SHARE See Also Send Feedback

Determines whether the share is enabled or not.

Syntax
PRL_RESULT PrlShare_IsEnabled(
    PRL_HANDLE hVmShare,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the share is enabled. PRL_FALSE indicates that it is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetEnabled

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_IsReadOnly Function

PrlShare_IsReadOnly Function
PrlApi.h PHT_SHARE See Also Send Feedback

Determines if the share is read-only.

Syntax
PRL_RESULT PrlShare_IsReadOnly(
    PRL_HANDLE hVmShare,
    PRL_BOOL_PTR pbReadOnly
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
pbReadOnly
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the share is read-only (files can be read and copied but not modified). PRL_FALSE indicates that the folder contents can be modified.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_SetReadOnly

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_Remove Function

PrlShare_Remove Function
PrlApi.h PHT_SHARE Send Feedback

Removes the share from the virtual machine configuration.

Syntax
PRL_RESULT PrlShare_Remove(
    PRL_HANDLE hVmShare
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Once a share is removed from the virtual machine configuration, the folder cannot be accessed from the guest OS. Just like any other virtual machine configuration modification, this operation must be performed within the PrlVm_BeginEdit / PrlVm_Commit block.

Links
PrlApi.h, PHT_SHARE


PrlShare_SetDescription Function

PrlShare_SetDescription Function
PrlApi.h PHT_SHARE See Also Send Feedback

Sets the shared folder description.

Syntax
PRL_RESULT PrlShare_SetDescription(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewShareDescription
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewShareDescription
A user-defined share description (must be a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetDescription

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_SetEnabled Function

PrlShare_SetEnabled Function
PrlApi.h PHT_SHARE See Also Send Feedback

Enables the specified share.

Syntax
PRL_RESULT PrlShare_SetEnabled(
    PRL_HANDLE hVmShare,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
bEnabled
Specify PRL_TRUE to enable the share. Specified PRL_FALSE to disable it. If a share is disabled, it cannot be accessed from the guest OS.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_IsEnabled

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_SetName Function

PrlShare_SetName Function
PrlApi.h PHT_SHARE See Also Send Feedback

Sets the share name (as it will appear in the guest OS).

Syntax
PRL_RESULT PrlShare_SetName(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewShareName
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewShareName
The user-defined share name (must be a a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetName

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_SetPath Function

PrlShare_SetPath Function
PrlApi.h PHT_SHARE See Also Send Feedback

Sets the shared folder path.

Syntax
PRL_RESULT PrlShare_SetPath(
    PRL_HANDLE hVmShare,
    PRL_CONST_STR sNewSharePath
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
sNewSharePath
A string containing an absolute path to the folder on the host that you would like to share with the guest OS ( must be a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_GetPath

Links
PrlApi.h, PHT_SHARE, See Also


PrlShare_SetReadOnly Function

PrlShare_SetReadOnly Function
PrlApi.h PHT_SHARE See Also Send Feedback

Makes the specified shared folder read-only.

Syntax
PRL_RESULT PrlShare_SetReadOnly(
    PRL_HANDLE hVmShare,
    PRL_BOOL bReadOnly
);
File

PrlApi.h

Parameters

hVmShare
A handle of type PHT_SHARE identifying the shared folder.
bReadOnly
Specify PRL_TRUE to make the share read-only. Specify PRL_FALSE to make the share editable.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlShare_IsReadOnly

Links
PrlApi.h, PHT_SHARE, See Also


PrlSrv_AddNetAdapter Function

PrlSrv_AddNetAdapter Function
PrlApi.h PHT_SERVER Send Feedback

Adds a new virtual network adapter to the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_AddNetAdapter(
    PRL_HANDLE hServer,
    PRL_HANDLE hNetAdapter
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hNetAdapter
A handle of type PHT_DISP_NET_ADAPTER containing the new adapter information. For the details on how to create the handle and how to set the adapter properties, see PHT_DISP_CONFIG.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_AttachToLostTask Function

PrlSrv_AttachToLostTask Function
PrlApi.h PHT_SERVER Send Feedback

The PrlSrv_AttachToLostTask function allows to obtain a handle to a running task after the connection to the Parallels Service was lost.

Syntax
PRL_HANDLE PrlSrv_AttachToLostTask(
    PRL_HANDLE hServer,
    PRL_CONST_STR sTaskId
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sTaskId
The ID of the task to get a job handle for.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object. The returned PHT_JOB object will be attached to the specified task.

Remarks

If you've started a long asynchronous operation and then lost a connection with the Parallels Service, you may use this function to get a handle to the task after reconnecting to the Parallels Service. In order to do that, log in to the Parallels Service using the PrlSrv_Login or the PrlSrv_LoginLocal function passing the UUID of the session that you've lost. The returned PHT_LOGIN_RESPONSE object will contain the list of the tasks that belong to the lost session and are still running. Select a task that you want to get a handle to and pass its ID to the PrlSrv_AttachToLostTask function. The function will return a handle of type PHT_JOB which you may use to continue controlling and monitoring the task as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_CheckParallelsServerAlive Function

PrlSrv_CheckParallelsServerAlive Function
PrlApi.h PHT_SERVER Send Feedback

Determines if the Parallels Service on the specified host is running and allows to retrieve its connection information.

Syntax
PRL_RESULT PrlSrv_CheckParallelsServerAlive(
    PRL_UINT32 timeout,
    PRL_CONST_STR sServerHostname,
    PRL_BOOL_PTR pbServerIsAlive,
    PRL_HANDLE_PTR phServerInfo
);
File

PrlApi.h

Parameters

timeout
Timeout in milliseconds specifying how long the function should wait for a response from the Parallels Service.
sServerHostname
The name of the host machine for which to get the Parallels Service status. To get the status for the local Parallels Service, the parameter can be null or empty.
pbServerIsAlive
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the Parallels Service is running. PRL_FALSE indicates otherwise.
phServerInfo
[out] A pointer to a variable that receives a handle of type PHT_SERVER_INFO containing the Parallels Service connection information. Pass a null pointer if you don't want to receive the Parallels Service connection information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer (excluding those that can be null) was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_CommonPrefsBeginEdit Function

PrlSrv_CommonPrefsBeginEdit Function
PrlApi.h PHT_SERVER Send Feedback

The PrlSrv_CommonPrefsBeginEdit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).

Syntax
PRL_HANDLE PrlSrv_CommonPrefsBeginEdit(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlSrv_CommonPrefsBeginEdit and the PrlSrv_CommonPrefsCommit functions are used to detect collisions with other clients trying to modify preferences of the same Parallels Service. The PrlSrv_CommonPrefsBeginEdit call timestamps the beginning of the operation. It does not lock the Parallels Service, so other clients can modify the same Parallels Service settings at the same time. When you are done making the changes, you must call the PrlSrv_CommonPrefsCommit function to apply them to the Parallels Service. The function will verify that the Parallels Service preferences have not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - current user does not have sufficient rights to perform this operation.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_CommonPrefsCommit Function

PrlSrv_CommonPrefsCommit Function
PrlApi.h PHT_SERVER Send Feedback

The PrlSrv_CommonPrefsCommit function is used in modifying Parallels Service preferences (see PHT_DISP_CONFIG).

Syntax
PRL_HANDLE PrlSrv_CommonPrefsCommit(
    PRL_HANDLE hServer,
    PRL_HANDLE hDispCfg
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hDispCfg
A handle of type PHT_DISP_CONFIG containing the Parallels Service preferences.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlSrv_CommonPrefsBeginEdit and the PrlSrv_CommonPrefsCommit functions are used to detect collisions with other clients trying to modify preferences of the same Parallels Service. The PrlSrv_CommonPrefsBeginEdit call timestamps the beginning of the operation. It does not lock the Parallels Service, so other clients can modify the same Parallels Service at the same time. When you are done making the changes, you must call the PrlSrv_CommonPrefsCommit function to apply them to the Parallels Service. The function will verify that the Parallels Service preferences have not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_Create Function

PrlSrv_Create Function
PrlApi.h PHT_SERVER Example See Also Send Feedback

Creates a new handle of type PHT_SERVER.

Syntax
PRL_RESULT PrlSrv_Create(
    PRL_HANDLE_PTR handle
);
File

PrlApi.h

Parameters

handle
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In order to establish a connection with a Parallels Service, a handle of type PHT_SERVER must be created and the object that the handle references must be populated with the Parallels Service connection information. Once a connection is established, the handle can be used to access the Parallels Service. It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

See Also

PrlSrv_LoginLocal

PrlSrv_Login

Example

The following example illustrates how to create a handle of type PHT_SERVER.

PRL_HANDLE hServer;

PRL_RESULT ret = PrlSrv_Create( &hServer );
if ( PRL_FAILED(ret) )
{
    printf( "PrlSrv_Create returned with error: %s\n",
    PRL_RESULT_TO_STRING(ret) );
}

// Free hServer handle when it's no longer needed.
PrlHandle_Free( hServer );
Links
PrlApi.h, PHT_SERVER, Example, See Also


PrlSrv_CreateVm Function

PrlSrv_CreateVm Function
PrlApi.h PHT_SERVER Example Send Feedback

Obtains a new handle of type PHT_VIRTUAL_MACHINE.

Syntax
PRL_RESULT PrlSrv_CreateVm(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR phVm
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
phVm
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Obtaining a new PHT_VIRTUAL_MACHINE handle is the first step when creating a virtual machine. The second step is setting the virtual machine configuration parameters. The final step is calling the PrlVm_Reg function, which will create a new virtual machine.

Example
// Create a new virtual machine handle
// (assumes hServer is a valid handle obtained using PrlSrv_Create,
// and a successful Parallels Service login was made using PrlSrv_Login).
PRL_HANDLE hNewVm;
ret = PrlSrv_CreateVm(hServer, &hNewVm);
if (PRL_FAILED(ret))
{
    printf("PrlSvr_CreateVm call failed with: %s.\n", PRL_RESULT_TO_STRING(ret));
    return ret;
}
printf("PrlSvr_CreateVm completed successfully.\n");
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_DeleteNetAdapter Function

PrlSrv_DeleteNetAdapter Function
PrlApi.h PHT_SERVER Send Feedback

Removes a virtual network adapter from the Parallels Service configuration.

Syntax
PRL_HANDLE PrlSrv_DeleteNetAdapter(
    PRL_HANDLE hServer,
    PRL_UINT32 nIndex
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nIndex
An index of the virtual network adapter to remove.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

See PHT_DISP_CONFIG and PHT_DISP_NET_ADAPTER for more information about Parallels Service preferences and virtual network adapters.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or adapter index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_FsCanCreateFile Function

PrlSrv_FsCanCreateFile Function
PrlApi.h PHT_SERVER Send Feedback

Determines if the current user has sufficient rights to create a file or a directory in the specified location on the host.

Syntax
PRL_HANDLE PrlSrv_FsCanCreateFile(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
Full path to the intended file or directory.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_FsCreateDir Function

PrlSrv_FsCreateDir Function
PrlApi.h PHT_SERVER Send Feedback

Creates a directory in the specified location on the host.

Syntax
PRL_HANDLE PrlSrv_FsCreateDir(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
The new directory name and path.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

If you are creating a series of directories that relate to each other, you can use the PrlSrv_FsGenerateEntryName function to automatically generate their names.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_FsGenerateEntryName Function

PrlSrv_FsGenerateEntryName Function
PrlApi.h PHT_SERVER Send Feedback

Automatically generates a unique name for a new directory.

Syntax
PRL_HANDLE PrlSrv_FsGenerateEntryName(
    PRL_HANDLE hServer,
    PRL_CONST_STR sDirPath,
    PRL_CONST_STR sFilenamePrefix,
    PRL_CONST_STR sFilenameSuffix,
    PRL_CONST_STR sIndexDelimiter
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sDirPath
A full path to the target location (directory).
sFilenamePrefix
Specifies a prefix to use in the directory name. Pass null or empty string to use the default prefix: tmpfile. The name will be generated by adding a number to the prefix (e.g. tmpfile1, tmpfile2, tmpfile3, etc.)
sFilenameSuffix
Specifies a suffix to use in the directory name. Pass null or an empty string value if you don't want to use a suffix.
sIndexDelimiter
A character(s) that will be inserted between the prefix and the index (e.g. tmpfile_1, tmpfile_2, tmpfile_3, etc). You can specify a null pointer or an empty string if you don't want to insert any extra characters there.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function allows to generate directory names using a specified prefix and optionally a suffix. You can specify your own prefix or use the default one. The function will not create the directories on the host. To create the directories, use the PrlSrv_FsCreateDir function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain the file system entry name from the PHT_RESULT object. The directory name is returned as a UTF-8 encoded, null-terminated string.
Links
PrlApi.h, PHT_SERVER


PrlSrv_FsGetDirEntries Function

PrlSrv_FsGetDirEntries Function
PrlApi.h PHT_SERVER Send Feedback

Retrieves information about the specified file system entry residing on the specified host computer.

Syntax
PRL_HANDLE PrlSrv_FsGetDirEntries(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
An absolute directory name and path, or drive letter (e.g. C:\) on the host computer for which to get the information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information retrieved by the PrlSrv_FsGetDirEntries function includes the information about the specified entry and, if the entry is a directory, the information about its immediate child entries (files and subdirectories). On Windows, you can also specify a drive letter, in which case the information about the root directory entries will be retrieved.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed or invalid path was specified.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO containing the file system entry information.
Links
PrlApi.h, PHT_SERVER


PrlSrv_FsGetDiskList Function

PrlSrv_FsGetDiskList Function
PrlApi.h PHT_SERVER Example Send Feedback

Returns a list of root directories on the host computer.

Syntax
PRL_HANDLE PrlSrv_FsGetDiskList(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

On Windows, the function returns a list of PHT_REMOTE_FILESYSTEM_INFO objects containing the disk volume information (e.g. C:\, D:\, etc.). On other operating systems, it returns a single object containing the root directory.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid server handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount to get the number of results.
  3. Use the PrlResult_GetParamByIndex function to get individual results.
Example

The following example illustrates how to obtain a handle of type PHT_REMOTE_FILESYSTEM_INFO.

hJob =
PrlSrv_FsGetDiskList( hServer );
PrlJob_Wait( hJob, JOB_TIMEOUT );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_REMOTE_FILESYSTEM_INFO handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_FsRemoveEntry Function

PrlSrv_FsRemoveEntry Function
PrlApi.h PHT_SERVER Send Feedback

Removes a file system entry from the host computer.

Syntax
PRL_HANDLE PrlSrv_FsRemoveEntry(
    PRL_HANDLE hServer,
    PRL_CONST_STR path
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
path
An absolute path to the file system entry to be removed.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_FsRenameEntry Function

PrlSrv_FsRenameEntry Function
PrlApi.h PHT_SERVER Send Feedback

Renames a file system entry on the host.

Syntax
PRL_HANDLE PrlSrv_FsRenameEntry(
    PRL_HANDLE hServer,
    PRL_CONST_STR oldPath,
    PRL_CONST_STR newPath
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
oldPath
An absolute path to the entry to be renamed.
newPath
An absolute path including the new file system entry name.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_GetCommonPrefs Function

PrlSrv_GetCommonPrefs Function
PrlApi.h PHT_SERVER Example Send Feedback

Returns a handle of type PHT_DISP_CONFIG containing the specified Parallels Service preferences information.

Syntax
PRL_HANDLE PrlSrv_GetCommonPrefs(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_DISP_CONFIG containing the Parallels Service preferences.
Example

The following example illustrates how to obtain a handle of type PHT_DISP_CONFIG.

hJob =
PrlSrv_GetCommonPrefs( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_DISP_CONFIG handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetLicenseInfo Function

PrlSrv_GetLicenseInfo Function
PrlApi.h PHT_SERVER Example Send Feedback

Returns an object of type PHT_LICENSE containing the Parallels license information.

Syntax
PRL_HANDLE PrlSrv_GetLicenseInfo(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LICENSE containing the license information.
Example

The following example illustrates how to obtain a handle of type PHT_LICENSE.

hJob =
PrlSrv_GetLicenseInfo( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LICENSE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetNetServiceStatus Function

PrlSrv_GetNetServiceStatus Function
PrlApi.h PHT_SERVER Example Send Feedback

Returns an object of type PHT_NET_SERVICE_STATUS containing the Parallels network service status information.

Syntax
PRL_HANDLE PrlSrv_GetNetServiceStatus(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_NET_SERVICE_STATUS containing the NET service status.
Example

The following example illustrates how to obtain a handle of type PHT_NET_SERVICE_STATUS containing the Parallels Service network service status.

hJob =
PrlSrv_GetNetServiceStatus( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_NET_SERVICE_STATUS handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetProblemReport Function

PrlSrv_GetProblemReport Function
PrlApi.h PHT_SERVER Send Feedback

Allows to receive a problem report from the Parallels Service in the event of a virtual machine operation failure.

Syntax
PRL_HANDLE PrlSrv_GetProblemReport(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a report from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a string value containing the report.
Links
PrlApi.h, PHT_SERVER


PrlSrv_GetQuestions Function

PrlSrv_GetQuestions Function
PrlApi.h PHT_SERVER Send Feedback

The PrlSrv_GetQuestions function allows to synchronously receive questions from a Parallels Service.

Syntax
PRL_RESULT PrlSrv_GetQuestions(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR pQuestionsList
);
File

PrlApi.h

Parameters

pQuestionsList
[out] A pointer to a handle of type PHT_HANDLES_LIST containing a list of available questions.
handle
A handle of type PHT_SERVER.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_SERVER handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_OUT_OF_MEMORY - not enough memory to complete the operation. PRL_ERR_SUCCESS - operation completed successfully.

Remarks

It can be used as an alternative to asynchronous question processing through events. You can use this function at any time to check if a question is awaiting the client response on the Parallels Service.

Links
PrlApi.h, PHT_SERVER


PrlSrv_GetServerInfo Function

PrlSrv_GetServerInfo Function
PrlApi.h PHT_SERVER Send Feedback

Obtains a handle of type PHT_SERVER_INFO containing the host computer information.

Syntax
PRL_RESULT PrlSrv_GetServerInfo(
    PRL_HANDLE hServer,
    PRL_HANDLE_PTR phServerInfo
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
phServerInfo
[out] A pointer to a variable that receives a handle to the server info object.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Please note that in order to obtain the complete host info, the function must be called after the login operation is completed and the results of the login operation are received. In all other situations, some of the Parallels Service properties may not be populated.

Links
PrlApi.h, PHT_SERVER


PrlSrv_GetSrvConfig Function

PrlSrv_GetSrvConfig Function
PrlApi.h PHT_SERVER Example Send Feedback

Obtains a handle of type PHT_SERVER_CONFIG containing the host configuration information.

Syntax
PRL_HANDLE PrlSrv_GetSrvConfig(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SERVER_CONFIG containing the host configuration information.
Example

The following example illustrates how to obtain a handle of type PHT_SERVER_CONFIG from the PHT_SERVER object (the example assumes that you've already obtained a server handle).

hJob =
PrlSrv_GetSrvConfig( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_SERVER_CONFIG handle from the result object.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetStatistics Function

PrlSrv_GetStatistics Function
PrlApi.h PHT_SERVER Example Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS containing the host resource usage statistics.

Syntax
PRL_HANDLE PrlSrv_GetStatistics(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SYSTEM_STATISTICS.
Example

The following example illustrates how to obtain a handle of type PHT_SYSTEM_STATISTICS.

PRL_RESULT err = PRL_ERR_UNINITIALIZED;
PRL_RESULT rc = PRL_ERR_UNINITIALIZED;
PRL_HANDLE hJob = PRL_INVALID_HANDLE;
PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;
PRL_HANDLE hServer = PRL_INVALID_HANDLE;

// Initialize API library.
err = PrlApi_Init(PARALLELS_API_VER);
if (PRL_FAILED(err))
{
    // Error handling goes here...
    return -1;
}

// Create server handle.
err = PrlSrv_Create(&hServer);

// if (err != PRL_ERR_SUCCESS), process the error here.

hJob = PrlSrv_Login(
    hServer, // Server handle
    "10.30.21.243", // Server IP address
    "jdoe", // User
    "secret", // Password
    0, // Previous session ID
    0, // Port number
    0, // Timeout
    PSL_LOW_SECURITY); // Security

// Wait for the job to complete.
err = PrlJob_Wait(hJob, 1000);

// if (err != PRL_ERR_SUCCESS), process the error here.

// Get job return code.
err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

// Free job handle.
PrlHandle_Free(hJob);

// Get statistics.
hJob = PrlSrv_GetStatistics(hServer);
err = PrlJob_Wait(hJob, 10000);

// if (err != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetRetCode(hJob, &rc);

// if (err != PRL_ERR_SUCCESS), process the error here.
// if (rc != PRL_ERR_SUCCESS), process the error here.

err = PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

// Get the PHT_SYSTEM_STATISTICS handle.
PRL_HANDLE hHandle = PRL_INVALID_HANDLE;
err = PrlResult_GetParam(hJobResult, &hHandle);

// if (err != PRL_ERR_SUCCESS), process the error here.

PrlHandle_Free(hJobResult);
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetUserInfo Function

PrlSrv_GetUserInfo Function
PrlApi.h PHT_SERVER See Also Send Feedback

Obtains a handle of type PHT_USER_INFO containing information about the specified user.

Syntax
PRL_HANDLE PrlSrv_GetUserInfo(
    PRL_HANDLE hServer,
    PRL_CONST_STR sUserId
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sUserId
UUID of the user to obtain the information for.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_USER_INFO containing the user information.

See Also

PrlSrv_GetUserInfoList

Links
PrlApi.h, PHT_SERVER, See Also


PrlSrv_GetUserInfoList Function

PrlSrv_GetUserInfoList Function
PrlApi.h PHT_SERVER Send Feedback

Obtains a list of handles of type PHT_USER_INFO containing information about all known users.

Syntax
PRL_HANDLE PrlSrv_GetUserInfoList(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_USER_INFO containing an individual user information.

Links
PrlApi.h, PHT_SERVER


PrlSrv_GetUserProfile Function

PrlSrv_GetUserProfile Function
PrlApi.h PHT_SERVER Example Send Feedback

Obtains a handle of type PHT_USER_PROFILE containing the profile data of the currently logged in user.

Syntax
PRL_HANDLE PrlSrv_GetUserProfile(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_USER_PROFILE.
Example

The following example shows how to obtain a handle of type PHT_USER_PROFILE.

hJob =
PrlSrv_GetUserProfile( hServer );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_USER_PROFILE handle.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_GetVirtualNetworkList Function

PrlSrv_GetVirtualNetworkList Function
PrlApi.h PHT_SERVER Send Feedback

Obtains a list of handles of type PHT_VIRTUAL_NETWORK containing information about all existing virtual networks.

Syntax
PRL_HANDLE PrlSrv_GetVirtualNetworkList(
    PRL_HANDLE hServer,
    PRL_UINT32 nFlags
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
nFlags
Reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamByIndex function to obtain a handle of type PHT_VIRTUAL_NETWORK containing the information about a virtual network.

Links
PrlApi.h, PHT_SERVER


PrlSrv_GetVmList Function

PrlSrv_GetVmList Function
PrlApi.h PHT_SERVER Example Send Feedback

Retrieves a list of virtual machines registered with the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_GetVmList(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The information about each virtual machine is returned as a handle of type PHT_VIRTUAL_MACHINE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the result from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of virtual machine in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each virtual machine.
Example

The following example illustrates how to obtain a list of virtual machine registered on the specified Parallels Service. The examples assumes that we've already obtain a handle of type PHT_SERVER (the hServer variable) identifying the Parallels Service.

hJob =
PrlSrv_GetVmList( hServer );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;

// Get the number of the virtual machines
// in the list.
PrlResult_GetParamsCount( hJobResult, &nCount );

// Iterate through the list.
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    // Get virtual machine name.
    nRetCode =
    PrlVm_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s.\n", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_IsConnected Function

PrlSrv_IsConnected Function
PrlApi.h PHT_SERVER Send Feedback

Determines if the connection to the specified Parallels Service is active.

Syntax
PRL_RESULT PrlSrv_IsConnected(
    PRL_HANDLE hServer,
    PRL_BOOL_PTR pbConnected,
    PRL_BOOL_PTR pbIsConnectionLocal
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
pbConnected
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the connection is active. PRL_FALSE indicates otherwise.
pbIsConnectionLocal
[out] Specifies whether this is a local or remote connection. PRL_TRUE indicates that this is a local connection. PRL_FALSE indicates that this is a remote connection.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_Login Function

PrlSrv_Login Function
PrlApi.h PHT_SERVER Example See Also Send Feedback

Performs a remote login operation using the specified parameters.

Syntax
PRL_HANDLE PrlSrv_Login(
    PRL_HANDLE hServer,
    PRL_CONST_STR host,
    PRL_CONST_STR user,
    PRL_CONST_STR passwd,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port_cmd,
    PRL_UINT32 timeout,
    PRL_SECURITY_LEVEL security_level
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
host
The name or IP address of the host machine (a UTF-8 encoded, null-terminated string).
user
User name (a UTF-8 encoded, null-terminated string).
passwd
Password (a UTF-8 encoded, null-terminated string).
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
port_cmd
Port number. Pass 0 (zero) to use the default port.
timeout
Timeout value in milliseconds. The operation will be automatically interrupted if a connection is not established within this timeframe. Specify 0 (zero) for infinite timeout.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

A remote login operation logs the user to a Parallels Service running on a remote host. You can also use this function to log to a local host or you can use the PrlSrv_LoginLocal function, which is a simplified version created specifically to perform local host logins.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlDispCfg_GetMinSecurityLevel

Example

The following is a complete sample program that illustrates how to log in to a remote Parallels Service.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szVmName = "Windows XP";
const char *szServer = "127.0.0.1";
const char *szUsername = "SomeUserName";
const char *szPassword = "SomePassword";

int main( int argc, char* argv[] )
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    // Load the SDK library.
    if ( PRL_FAILED( SdkWrap_Load( SDK_LIB_NAME ) ) &&
        PRL_FAILED( SdkWrap_Load( "./" SDK_LIB_NAME ) ) )
    {
        fprintf( stderr, "Failed to load " SDK_LIB_NAME "\n" );
        return -1;
    }

    // Initialize the API.
    ret = PrlApi_Init( PARALLELS_API_VER );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create( &hServer );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (asynchronous call).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer,            // PRL_HANDLE of type PHT_SERVER.
            szServer,           // Name and IP address of the host machine.
            szUsername,         // User name.
            szPassword,         // Password.
            0,                  // Previuos session ID (0 if not used).
            0,                  // Port number (0 for default port).
            0,                  // Timeout value (0 for default timeout).
            PSL_LOW_SECURITY ); // Security level.

    // Wait for a maximum of 10 seconds for
    // the job to complete.
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING( ret) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( nJobResult ) )
    {
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        printf( "Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Login was successful.\n" );

    // Log off.
    hJob = PrlSrv_Logoff( hServer );
    ret = PrlJob_Wait( hJob, 1000 );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode( hJob, &nJobResult );
    if ( PRL_FAILED( ret ) )
    {
        fprintf( stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING( ret ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if ( PRL_FAILED( nJobResult ) )
    {
        fprintf( stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING( nJobResult ) );
        PrlHandle_Free( hVm );
        PrlHandle_Free( hJob );
        PrlHandle_Free( hServer );
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf( "Logoff was successful.\n" );

    // Free handles that are no longer required.
    PrlHandle_Free( hVm );
    PrlHandle_Free( hJob );
    PrlHandle_Free( hServer );

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    printf( "\n\nEnd of program.\n\n" );
    char c;
    scanf( &c, "%c" );

    return 0;
}
Links
PrlApi.h, PHT_SERVER, Example, See Also


PrlSrv_LoginLocal Function

PrlSrv_LoginLocal Function
PrlApi.h PHT_SERVER Example See Also Send Feedback

Allows to log in to the local Parallels Service (the Parallels Service running on this host) using the current user credentials.

Syntax
PRL_HANDLE PrlSrv_LoginLocal(
    PRL_HANDLE hServer,
    PRL_CONST_STR sPrevSessionUuid,
    PRL_UINT32 port,
    PRL_SECURITY_LEVEL security_level
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sPrevSessionUuid
Previous session ID. This is an optional parameter that can be used in recovering from a lost Parallels Service connection. The ID will be used to restore references to the tasks that were initiated in the previous session and are still running inside the Parallels Service. You can pass a null or an empty string value if you are not restoring any references. See PrlSrv_AttachToLostTask for more information.
port
Port number. Specify 0 (zero) to use the default port.
security_level
Communication security level to use for this connection. The security level set here will be used for all communications with the Parallels Service for the duration of this session. The minimum allowable security level can be determined using the PrlDispCfg_GetMinSecurityLevel function.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_LOGIN_RESPONSE, containing an additional Parallels Service information.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When performing a local login operation, no password/username is needed. The authentication and authorization will be performed using the current user account.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_LOGIN_RESPONSE.
See Also

PrlDispCfg_GetMinSecurityLevel

Example

The following example illustrates how to log in to locally running Parallels Service and to obtain a handle of type PHT_LOGIN_RESPONSE.

// Log in.
hJob = PrlSrv_LoginLocal( hServer, NULL, 0, PSL_LOW_SECURITY );
PrlJob_Wait( hJob, 10000 );

// Get the results of the login operation.
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the PHT_LOGIN_RESPONSE handle from the job result.
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_SERVER, Example, See Also


PrlSrv_Logoff Function

PrlSrv_Logoff Function
PrlApi.h PHT_SERVER Send Feedback

Logs off the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_Logoff(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function logs of the Parallels Service and ends a session that was started with the PrlSrv_Login or the PrlSrv_LoginLocal function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_LookupParallelsServers Function

PrlSrv_LookupParallelsServers Function
PrlApi.h PHT_SERVER Example Send Feedback

Searches the network for running Parallels Services and returns a handle of type PHT_SERVER_INFO for every Parallels Service that it finds.

Syntax
PRL_HANDLE PrlSrv_LookupParallelsServers(
    PRL_UINT32 timeout,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApi.h

Parameters

timeout
Timeout in milliseconds. The search operation will stop once this limit is reached.
handler
Optional. A pointer to a user callback function (event handler) that will be called every time a Parallels Service is found. The function will receive a handle of type PHT_SERVER_INFO containing the Parallels Service information.
userData
Optional. A pointer to a user data that will be passed to the optional callback function.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function can be executed asynchronously using the callback functionality, or it can be used synchronously.

To use the function asynchronously, you must implement a callback function and pass a pointer to it to this function as a parameter. The callback function will be called for every Parallels Service found, and a handle of type PHT_SERVER_INFO containing the Parallels Service information will be passed to it.

To use this function synchronously, pass a null pointer instead of the callback function pointer, and use PrlJob_Wait to wait for the job to complete. The returned job object will contain a list of PHT_SERVER_INFO objects.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of servers in the result set.
  3. Use the PrlResult_GetParamByIndex function in a loop, or by passing a specific index, to obtain a handle to each server object.
Example

The following example illustrates how to call the PrlSrv_LookupParallelsServers synchronously.

hJob =
PrlSrv_LookupParallelsServers(
    10000,  // timeout
    NULL,   // callback function (not used)
    NULL    // user object pointer (not used)
);

printf("Searching for Parallels Services...\n");

nRetCode =
PrlJob_Wait(hJob, 100000);

if (PRL_FAILED(nRetCode))
{
    fprintf(stderr, "PrlJob_Wait returned with error: %s.\n",
        PRL_RESULT_TO_STRING( nRetCode));
    PrlApi_Deinit();
    SdkWrap_Unload();
    return nRetCode;
}

PrlJob_GetResult(hJob, &hJobResult);
PrlHandle_Free(hJob);

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount(hJobResult, &nCount);

for (nIndex = 0; nIndex < nCount ; nIndex++)
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex(hJobResult, nIndex, &hParam);

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof(sBuf);

    nRetCode =
    PrlSrvInfo_GetHostName(hParam, sBuf, &nBufSize);

    if (PRL_SUCCEEDED(nRetCode))
        printf("Found Service: %s.\n", &sBuf[0]);
    else
        fprintf(stderr, "PrlSrvInfo_GetHostName failed, error: %s. \n",
            PRL_RESULT_TO_STRING(nRetCode));

    PrlHandle_Free(hParam);
}

PrlHandle_Free(hJobResult);

In the following example, the PrlSrv_LookupParallelsServers is called asynchronously. In order to that, we first have to implement a callback function (let's call it ourCallback):

static PRL_RESULT ourCallback(PRL_HANDLE hEvent, PRL_VOID_PTR pUserData)
{
    printf("%s: ", pUserData);

    // Get the name of the host machine.
    PRL_UINT32 nBufSize = 1024;
    PRL_CHAR sBuf[nBufSize];
    PrlSrvInfo_GetHostName(hEvent, sBuf, &nBufSize);

    // Get the other properties and process them here...

    // The handle must be freed.
    PrlHandle_Free(hEvent);
    return rc;
}

The PrlSrv_LookupParallelsServers function can now be called as follows:

hJob =
PrlSrv_LookupParallelsServers(
    1000,
    &ourCallback,
    (PRL_VOID_PTR)("callback")
);
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_NetServiceRestart Function

PrlSrv_NetServiceRestart Function
PrlApi.h PHT_SERVER Send Feedback

Restarts the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceRestart(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_NetServiceRestoreDefaults Function

PrlSrv_NetServiceRestoreDefaults Function
PrlApi.h PHT_SERVER Send Feedback

Restores the default settings of the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceRestoreDefaults(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_NetServiceStart Function

PrlSrv_NetServiceStart Function
PrlApi.h PHT_SERVER Send Feedback

Starts the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceStart(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_NetServiceStop Function

PrlSrv_NetServiceStop Function
PrlApi.h PHT_SERVER Send Feedback

Stops the Parallels network service.

Syntax
PRL_HANDLE PrlSrv_NetServiceStop(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

unnamed_param
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_RegEventHandler Function

PrlSrv_RegEventHandler Function
PrlApi.h PHT_SERVER Send Feedback

Registers an event handler.

Syntax
PRL_RESULT PrlSrv_RegEventHandler(
    PRL_HANDLE hServer,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
handler
A pointer to a user callback function (event handler).
userData
Optional. A pointer to a user data that will be passed to the callback function.

Remarks

Asynchronous functions return data to the caller by means of a callback function (or event handler). The callback function could be called at any time, depending on how long the asynchronous function takes to complete. The callback function must have a specific signature. The callback function prototype type is PRL_EVENT_HANDLER_PTR. The PrlSrv_RegEventHandler function is used to register an event handler with the specified Parallels Service, PrlSrv_UnregEventHandler is used to unregister an event handler. When an event handler is registered, it will start receiving all events/jobs generated by the Parallels Service. It is the responsibility of the client application to identify and handle the relevant event(s). For more information on events and asynchronous functions, see the Parallels Virtualization SDK Programmer's Guide.

Links
PrlApi.h, PHT_SERVER


PrlSrv_RegisterVm Function

PrlSrv_RegisterVm Function
PrlApi.h PHT_SERVER Example Send Feedback

Registers an existing virtual machine with Parallels Service.

Syntax
PRL_HANDLE PrlSrv_RegisterVm(
    PRL_HANDLE hServer,
    PRL_CONST_STR strVmDirPath,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
strVmDirPath
An absolute path the virtual machine directory to register.
bNonInteractiveMode
Set to PRL_TRUE to use interactive mode. Set to PRL_FALSE to use non-interactive mode. In interactive mode, a client may receive questions from the Parallels Service, which it is expected to answer in order for the operation to continue. In non-interactive mode, the Parallels Service will make decisions on its own.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Example

The following sample function demonstrates how to add an existing virtual machine to the Parallels Service. The function takes a handle of type PHT_SERVER and a string specifying the name and path of the virtual machine directory. It registers the virtual machine with the Service and then modifies the MAC address of every virtual network adapter installed in it.

PRL_RESULT RegisterExistingVM(PRL_HANDLE hServer, PRL_CONST_STR sVmDirectory)
{
    PRL_HANDLE hJob = PRL_INVALID_HANDLE;
    PRL_HANDLE hJobResult = PRL_INVALID_HANDLE;

    PRL_RESULT ret = PRL_ERR_UNINITIALIZED;
    PRL_RESULT nJobRetCode = PRL_ERR_UNINITIALIZED;

    // Register the virtual machine with the Parallels Service.
    hJob = PrlSrv_RegisterVm(
        hServer,
        sVmDirectory,
        PRL_TRUE);  // Using non-interactive mode.

    ret = PrlJob_Wait(hJob, 10000);

    // Check the return code of PrlSrv_RegisterVm.
    PrlJob_GetRetCode(hJob, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        printf("PrlSrv_RegisterVm returned error: %s\n",
            prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJob);
        return -1;
    }

    // Obtain the virtual machine handle from the job object.
    // We will use the handle later to modify the virtual machine
    // configuration.
    PRL_HANDLE hVm = PRL_INVALID_HANDLE;
    ret = PrlJob_GetResult(hJob, &hJobResult);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    ret = PrlResult_GetParam(hJobResult, &hVm);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    PrlHandle_Free(hJob);
    PrlHandle_Free(hJobResult);

    printf("Virtual machine '%s' was successfully registered.",
            sVmDirectory);

    // The following code will generate and set a new MAC address
    // for every virtual network adapter that exists in the virtual machine.
    // This step is optional and should normally be performed when the virtual
    // machine is a copy of another virtual machine.

    PRL_HANDLE hJobBeginEdit;
    PRL_HANDLE hJobCommit;

    // Begin the virtual machine editing operation.
    hJobBeginEdit = PrlVm_BeginEdit(hVm);
    ret = PrlJob_Wait(hJobBeginEdit, 10000);
    PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobBeginEdit);
        return nJobRetCode;
    }

    // Obtain a handle of type PHT_VM_CONFIGURATION containing the
    // virtual machine configuration data.
    PRL_HANDLE hVmCfg = PRL_INVALID_HANDLE;
    ret = PrlVm_GetConfig(hVm, &hVmCfg);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Determine the number of the network adapters
    // installed in the machine.
    PRL_UINT32 nCount = PRL_ERR_UNINITIALIZED;
    ret = PrlVmCfg_GetNetAdaptersCount(hVmCfg, &nCount);
    if (PRL_FAILED(ret))
    {
        // Handle the error...
        return ret;
    }

    // Itereate through the adapter list.
    PRL_HANDLE hNetAdapter = PRL_INVALID_HANDLE;
    for (PRL_UINT32 i = 0; i < nCount; ++i)
    {
        ret = PrlVmCfg_GetNetAdapter(hVmCfg, i, &hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }

        // Automatically generate new MAC address for the current adapter.
        // The address will be updated in the configuration object.
        ret = PrlVmDevNet_GenerateMacAddr(hNetAdapter);
        if (PRL_FAILED(ret))
        {
            // Handle the error...
            return ret;
        }
    }

    // Commit the changes to the virtual machine.
    hJobCommit = PrlVm_Commit(hVm);

    // Check the results of the commit operation.
    ret = PrlJob_Wait(hJobCommit, 10000);
    PrlJob_GetRetCode(hJobCommit, &nJobRetCode);
    if (PRL_FAILED(nJobRetCode))
    {
        fprintf(stderr, "Commit error: %s\n", prl_result_to_string(nJobRetCode));
        PrlHandle_Free(hJobCommit);
        return nJobRetCode;
    }

    PrlHandle_Free(hNetAdapter);
    PrlHandle_Free(hVm);
    PrlHandle_Free(hVmCfg);
    PrlHandle_Free(hJobCommit);
    PrlHandle_Free(hJobBeginEdit);

    return 0;
}
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_SendAnswer Function

PrlSrv_SendAnswer Function
PrlApi.h PHT_SERVER Send Feedback

Sends an answer to the Parallels Service in response to a question.

Syntax
PRL_HANDLE PrlSrv_SendAnswer(
    PRL_HANDLE hServer,
    PRL_HANDLE hAnswer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hAnswer
A handle of type PHT_EVENT containing the answer.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Some operations have an option to be carried out in interactive mode. This means that the Parallels Service may interrupt an operation and ask client a question about how it would like to proceed. This function allows to send such an answer to the Parallels Service. The answer must be prepared using the PrlEvent_CreateAnswerEvent function before it can be sent to the Parallels Service using this function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_Shutdown Function

PrlSrv_Shutdown Function
PrlApi.h PHT_SERVER Send Feedback

Shuts down the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_Shutdown(
    PRL_HANDLE hServer,
    PRL_BOOL bForceShutdown
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
bForceShutdown
Specifies whether the shutdown operation should be forced. The value of PRL_TRUE will force the shutdown; PRL_FALSE will perform a normal shutdown. If one or more virtual machines are running, clients are connected, or some tasks are currently in progress, then forcing the shutdown will stop all processes automatically and shut down the machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The current user must have sufficient privileges to execute the Parallels Service shutdown.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_TOKEN_INVALID - the user doesn't have sufficient privileges.

PRL_ERR_ANOTHER_USER_SESSIONS_PRESENT - another user is currently connected to the Parallels Service, the Parallels Service shutdown aborted.

PRL_ERR_SOME_VMS_RUNNING - running virtual machines found, stop the running machines first.

PRL_ERR_SOME_TASKS_PRESENT - running tasks detected, wait for the tasks to finish or cancel them.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_StartSearchVms Function

PrlSrv_StartSearchVms Function
PrlApi.h PHT_SERVER Example Send Feedback

Searches for unregistered virtual machines at the specified location(s).

Syntax
PRL_HANDLE PrlSrv_StartSearchVms(
    PRL_HANDLE hServer,
    PRL_HANDLE hStringsList
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hStringsList
A handle of type PHT_STRINGS_LIST containing the list of pathnames to search. If the list is empty, all available drives and directories will be included in search scope.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function can be used to search for virtual machines that are not currently registered with the specified Parallels Service but are otherwise valid machines to be registered with it. The virtual machine information is returned as a list of PHT_FOUND_VM_INFO objects. When the function is executed asynchronously using callback functionality, the callback function receives the information as an event of type PET_DSP_EVT_FOUND_LOST_VM_CONFIG.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to get the number of virtual machines in the list.
  3. Use the PrlResult_GetParam function to obtain individual handles of type PHT_FOUND_VM_INFO.
Example
PRL_HANDLE hStringList;
PrlApi_CreateStringsList( &hStringList );
PrlStrList_AddItem( hStringList, "/Users/Shared/Parallels/" );

hJob =
PrlSrv_StartSearchVms( hServer, hStringList );
PrlJob_Wait( hJob, 10000 );

PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

PRL_UINT32 nIndex, nCount;
PrlResult_GetParamsCount( hJobResult, &nCount );
for( nIndex = 0; nIndex < nCount ; nIndex++ )
{
    PRL_HANDLE hParam;
    PrlResult_GetParamByIndex( hJobResult, nIndex, &hParam );

    PRL_HANDLE_TYPE nHandleType;
    PrlHandle_GetType( hParam, &nHandleType );

    printf( "Handle Type: %s\n",
        PRL_HANDLE_TYPE_TO_STRING( nHandleType ));

    PRL_CHAR sBuf[1024];
    PRL_UINT32 nBufSize = sizeof( sBuf );

    nRetCode =
    PrlFoundVmInfo_GetName( hParam, sBuf, &nBufSize );

    if ( PRL_SUCCEEDED( nRetCode ))
        printf( "VM name: %s\n.", sBuf );
    else
        fprintf( stderr, "PrlFoundVmInfo_GetName failed, error: %s. \n",
            PRL_RESULT_TO_STRING( nRetCode ));

    PrlHandle_Free( hParam );
}
PrlHandle_Free( hJobResult );
PrlHandle_Free( hStringList );
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_SubscribeToHostStatistics Function

PrlSrv_SubscribeToHostStatistics Function
PrlApi.h PHT_SERVER Example Send Feedback

Allows to subscribe to receive host OS statistics on a periodic basis.

Syntax
PRL_HANDLE PrlSrv_SubscribeToHostStatistics(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_HOST_STATISTICS_UPDATED indicate an event containing statistics data. To access the statistics handle (a handle of type PHT_SYSTEM_STATISTICS), first extract the event parameter using PrlEvent_GetParam, then convert the result (which will be a handle to an object of type PHT_EVENT_PARAMETER) to a handle using PrlEvtPrm_ToHandle. The functions that operate on PHT_SYSTEM_STATISTICS references can then be used to obtain statistics data.

For the event handler to be called, it is necessary to register it with PrlSrv_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlSrv_UnsubscribeFromHostStatistics. When events are no longer required, unregister the event handler using PrlSrv_UnregEventHandler.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following is a complete example that demonstrates how to obtain statistics data asynchronously using PrlSrv_SubscribeToHostStatistics. Note that the same code could be used to receive statistics data for a virtual machine, instead of the host computer, by using PrlVm_SubscribeToGuestStatistics instead of PrlSrv_SubscribeToHostStatistics, and passing it a handle to a virtual machine that is running. This would also require using PrlVm_UnsubscribeFromGuestStatistics to stop receiving statistics data for the virtual machine.

#include "Parallels.h"
#include "Wrappers/SdkWrap/SdkWrap.h"
#include <stdio.h>

#ifdef _WIN_
#include <windows.h>
#else
#include <unistd.h>
#endif

const char *szServer = "123.123.123.123";
const char *szUsername = "Your Username";
const char *szPassword = "Your Password";

// -------------------------------------------------------------------------
// Event handler.
// -------------------------------------------------------------------------
// 1. Check for events of type PET_DSP_EVT_HOST_STATISTICS_UPDATES.
// 2. Display a header if first call to this event handler.
// 3. Get the event param (PHT_EVENT_PARAMETER) from the PHT_EVENT handle.
// 4. Convert event param to a handle (will be type PHT_SYSTEM_STATISTICS).
// 5. Use PHT_SYSTEM_STATISTICS handle to obtain CPU usage, memory usage,
// and disk usage data.
// -------------------------------------------------------------------------
static PRL_RESULT OurCallback(PRL_HANDLE handle, void *pData)
{
    PRL_HANDLE_TYPE nHandleType;
    PRL_RESULT ret = PrlHandle_GetType(handle, &nHandleType);

    // Check for PrlHandle_GetType error here.
    if (nHandleType == PHT_EVENT)
    {
        PRL_EVENT_TYPE EventType;
        PrlEvent_GetType(handle, &EventType);

        // Check if the event type is a statistics update.
        if (EventType == PET_DSP_EVT_HOST_STATISTICS_UPDATED)
        {
            // Output a header if first call to this function.
            static PRL_BOOL bHeaderHasBeenPrinted = PRL_FALSE;
            if (!bHeaderHasBeenPrinted)
            {
                bHeaderHasBeenPrinted = PRL_TRUE;
                printf("CPU (%%) Used RAM (MB) Free RAM (MB) Used Disk Space (MB)"
                       " Free Disk Space (MB)\n");
                printf("---------------------------------------------------------"
                       "--------------------\n");
            }

            PRL_HANDLE hEventParameters;
            PRL_HANDLE hServerStatistics;

            // Get the event parameter (PHT_EVENT_PARAMETER) from the event handle.
            PrlEvent_GetParam(handle, 0, &hEventParameters);

            // Convert the event parameter to a handle (PHT_SYSTEM_STATISTICS).
            PrlEvtPrm_ToHandle(hEventParameters, &hServerStatistics);

            // Get CPU statistics (usage in %).
            PRL_HANDLE hCpuStatistics;
            ret = PrlStat_GetCpuStat(hServerStatistics, 0, &hCpuStatistics);
            PRL_UINT32 nCpuUsage = 0;
            ret = PrlStatCpu_GetCpuUsage(hCpuStatistics, &nCpuUsage);

            // Get RAM statistics.
            PRL_UINT64 nUsedRam, nFreeRam;
            PrlStat_GetFreeRamSize(hServerStatistics, &nFreeRam);
            PrlStat_GetUsageRamSize(hServerStatistics, &nUsedRam);
            nUsedRam /= (1024 * 1024);
            nFreeRam /= (1024 * 1024);

            // Get disk space statistics.
            PRL_UINT64 nFreeDiskSpace, nUsedDiskSpace;
            PRL_HANDLE hDiskStatistics;
            PrlStat_GetDiskStat(hServerStatistics, 0, &hDiskStatistics);
            PrlStatDisk_GetFreeDiskSpace(hDiskStatistics, &nFreeDiskSpace);
            PrlStatDisk_GetUsageDiskSpace(hDiskStatistics, &nUsedDiskSpace);
            nUsedDiskSpace /= (1024 * 1024);
            nFreeDiskSpace /= (1024 * 1024);

            printf("%7d %10lld %13lld %20lld %20lld\n",
                nCpuUsage, nUsedRam, nFreeRam, nUsedDiskSpace, nFreeDiskSpace);

            PrlHandle_Free(hDiskStatistics);
            PrlHandle_Free(hCpuStatistics);
            PrlHandle_Free(hServerStatistics);
            PrlHandle_Free(hEventParameters);
        }
    }

    PrlHandle_Free(handle);

    return PRL_ERR_SUCCESS;
}

// -------------------------------
// Program entry point.
// -------------------------------

int main(int argc, char* argv[])
{
    PRL_HANDLE hServer;
    PRL_RESULT ret;

    // Use the correct dynamic library depending on the platform.
    #ifdef _WIN_
    #define SDK_LIB_NAME "prl_sdk.dll"
    #elif defined(_LIN_)
    #define SDK_LIB_NAME "libprl_sdk.so"
    #elif defined(_MAC_)
    #define SDK_LIB_NAME "libprl_sdk.dylib"
    #endif

    if (PRL_FAILED(SdkWrap_Load(SDK_LIB_NAME)) &&
        PRL_FAILED(SdkWrap_Load("./" SDK_LIB_NAME)))
    {
        fprintf(stderr, "Failed to load " SDK_LIB_NAME "\n");
        return -1;
    }

    // Initialize the Parallels API.
    ret = PrlApi_Init(PARALLELS_API_VER);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlApi_Init returned with error: %s.\n",
            PRL_RESULT_TO_STRING(ret));
        PrlApi_Deinit();
        SdkWrap_Unload();
        return ret;
    }

    // Create a server handle.
    ret = PrlSrv_Create(&hServer);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlSvr_Create failed, error: %s",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Log in (PrlSrv is asynchronous).
    PRL_HANDLE hJob = PrlSrv_Login(
            hServer, // PRL_HANDLE of type PHT_SERVER.
            szServer, // Server hostname or IP address.
            szUsername, // Username.
            szPassword, // Password.
            0, // Deprecated - UUID of previous session.
            0, // Optional - port number (0 for default).
            0, // Optional - timeout value (0 for default).
            PSL_LOW_SECURITY); // Security level

    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Login returned with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Analyze the result of PrlSrv_Login.
    PRL_RESULT nJobResult;
    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(nJobResult))
    {
        printf("Login job returned with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Login was successful.\n");
    // ----------------------------------------------------------------------------
    // 1. Register our event handler (OurCallback function).
    // 2. Subscribe to host machine statistics events.
    // 3. Keep receiving events until user presses <enter> key.
    // 4. Unsubscribe from statistics events.
    // 5. Un-register out event handler.
    // ----------------------------------------------------------------------------
    PrlSrv_RegEventHandler(hServer, OurCallback, NULL);
    PrlSrv_SubscribeToHostStatistics(hServer);
    char c;
    scanf(&c, 1);
    PrlSrv_UnsubscribeFromHostStatistics(hServer);
    PrlSrv_UnregEventHandler(hServer, OurCallback, NULL);
    // ----------------------------------------------------------------------------

    // Log off.
    hJob = PrlSrv_Logoff(hServer);
    ret = PrlJob_Wait(hJob, 1000);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_Wait for PrlSrv_Logoff returned error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    ret = PrlJob_GetRetCode(hJob, &nJobResult);
    if (PRL_FAILED(ret))
    {
        fprintf(stderr, "PrlJob_GetRetCode failed for PrlSrv_Logoff with error: %s\n",
            PRL_RESULT_TO_STRING(ret));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }

    // Report success or failure of PrlSrv_Logoff.
    if (PRL_FAILED(nJobResult))
    {
        fprintf(stderr, "PrlSrv_Logoff failed with error: %s\n",
            PRL_RESULT_TO_STRING(nJobResult));
        PrlHandle_Free(hJob);
        PrlHandle_Free(hServer);
        PrlApi_Deinit();
        SdkWrap_Unload();
        return -1;
    }
    else
        printf("Logoff was successful.\n");

    // Free handles that are no longer required.
    PrlHandle_Free(hJob);
    PrlHandle_Free(hServer);

    // De-initialize the Parallels API, and unload the SDK.
    PrlApi_Deinit();
    SdkWrap_Unload();

    return 0;
}
Links
PrlApi.h, PHT_SERVER, Example


PrlSrv_UnregEventHandler Function

PrlSrv_UnregEventHandler Function
PrlApi.h PHT_SERVER Send Feedback

Unregisters the specified event handler (callback function) that was previously registered with the PrlSrv_RegEventHandler function.

Syntax
PRL_RESULT PrlSrv_UnregEventHandler(
    PRL_HANDLE hServer,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
handler
A pointer to the callback function (event handler) to unregister. This must be the same pointer that was passed to the PrlSrv_RegEventHandler when the event handler was registered with the virtual machine.
userData
A pointer to the user data. This must also be the same pointer that was passed to the PrlSrv_RegEventHandler when the event handler was registered with the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When using callback functionality with asynchronous functions, a callback function is first registered with Parallels Service. When no longer needed (client doesn't want to receive events anymore), the function must by unregistered using the PrlSrv_UnregEventHandler function. The values of the handler and userData parameters constitute a unique pair which will be used to identify the event handler that will be unregistered. Make sure that you supply the same values as the ones you used when you registered the handler. See PrlSrv_SubscribeToHostStatistics for the complete example illustrating event handlers usage.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UnsubscribeFromHostStatistics Function

PrlSrv_UnsubscribeFromHostStatistics Function
PrlApi.h PHT_SERVER Send Feedback

Cancels the Parallels Service statistics subscription that was started using the PrlSrv_SubscribeToHostStatistics function.

Syntax
PRL_HANDLE PrlSrv_UnsubscribeFromHostStatistics(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UnsubscribeFromPerfStats Function

PrlSrv_UnsubscribeFromPerfStats Function
PrlApi.h PHT_SERVER Send Feedback

Cancels the Parallels Service perfomace statistics subscription that was started using the PrlSrv_SubscribeToPerfStats function.

Syntax
PRL_HANDLE PrlSrv_UnsubscribeFromPerfStats(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UpdateLicense Function

PrlSrv_UpdateLicense Function
PrlApi.h PHT_SERVER Send Feedback

Installs Parallels license on the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_UpdateLicense(
    PRL_HANDLE hServer,
    PRL_CONST_STR sKey,
    PRL_CONST_STR sUser,
    PRL_CONST_STR sCompany
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
sKey
License key.
sUser
License user name.
sCompany
License company name.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UpdateNetAdapter Function

PrlSrv_UpdateNetAdapter Function
PrlApi.h PHT_SERVER Send Feedback

Updates an existing virtual network adapter in the specified Parallels Service.

Syntax
PRL_HANDLE PrlSrv_UpdateNetAdapter(
    PRL_HANDLE hServer,
    PRL_HANDLE hNetAdapter
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hNetAdapter
A handle of PHT_DISP_NET_ADAPTER containing the new adapter information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UserProfileBeginEdit Function

PrlSrv_UserProfileBeginEdit Function
PrlApi.h PHT_SERVER Send Feedback

Timestamps the beginning of the user profile editing operation.

Syntax
PRL_HANDLE PrlSrv_UserProfileBeginEdit(
    PRL_HANDLE hServer
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Every modification to the user profile (see PHT_USER_PROFILE) must begin with this function call. The function, together with the PrlSrv_UserProfileCommit function, is used to detect collisions with other clients trying to modify the profile of the same user at the same time. The function does not lock the profile being edited. If a collision is detected on commit, the changes are rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - the user does not have sufficient rights to perform this task.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrv_UserProfileCommit Function

PrlSrv_UserProfileCommit Function
PrlApi.h PHT_SERVER Send Feedback

Saves (commits) user profile changes to the Parallels Service.

Syntax
PRL_HANDLE PrlSrv_UserProfileCommit(
    PRL_HANDLE hServer,
    PRL_HANDLE hUserProfile
);
File

PrlApi.h

Parameters

hServer
A handle of type PHT_SERVER identifying the Parallels Service.
hUserProfile
A handle of type PHT_USER_PROFILE containing the user information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Every modification to the user profile (see PHT_USER_PROFILE) must begin with the PrlSrv_UserProfileBeginEdit function call. The function, together with the PrlSrv_UserProfileCommit function, is used to detect collisions with other client trying to modify the profile of the same user at the same time. The function does not lock the profile being edited. If a collision is detected on commit, the changes are rejected. Otherwise, the changes are saved to the Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER


PrlSrvCfg_GetCpuCount Function

PrlSrvCfg_GetCpuCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of CPUs on the host machine.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnCpuCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuHvt Function

PrlSrvCfg_GetCpuHvt Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the hardware virtualization type of the host CPU.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuHvt(
    PRL_HANDLE hSrvConfig,
    PRL_CPU_HVT_PTR pnCpuHvt
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuMode Function

PrlSrvCfg_GetCpuMode Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the CPU mode (32 bit or 64 bit) on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuMode(
    PRL_HANDLE hSrvConfig,
    PRL_CPU_MODE_PTR pnCpuMode
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuModel Function

PrlSrvCfg_GetCpuModel Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the model of CPU on the host machine.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuModel(
    PRL_HANDLE hSrvConfig,
    PRL_STR sCpuModel,
    PRL_UINT32_PTR pnCpuModelBufLength
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
sCpuModel
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnCpuModelBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetCpuSpeed Function

PrlSrvCfg_GetCpuSpeed Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the host machine CPU speed.

Syntax
PRL_RESULT PrlSrvCfg_GetCpuSpeed(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnCpuSpeed
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnCpuSpeed
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetDnsServers Function

PrlSrvCfg_GetDnsServers Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains the list of IP addresses of DNS servers.

Syntax
PRL_RESULT PrlSrvCfg_GetDnsServers(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApi.h

Parameters

hSrvConfig
A valid handle of type PHT_SERVER_CONFIG.
phDnsServersList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the IP addresses of DNS servers.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetFloppyDisk Function

PrlSrvCfg_GetFloppyDisk Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about a floppy disk drive on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetFloppyDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the drive (beginning with 0). The number of drives in the list can be determined by making the PrlSrvCfg_GetFloppyDisksCount function call.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the drive information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetFloppyDisksCount Function

PrlSrvCfg_GetFloppyDisksCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of floppy disk drives on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetFloppyDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnFloppyDisksCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnFloppyDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericPciDevice Function

PrlSrvCfg_GetGenericPciDevice Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic PCI device installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericPciDevice(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the GenericPciDevice (beginning with 0). To get the number of installed generic PCI devices, use the PrlSrvCfg_GetGenericPciDevicesCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the generic PCI device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericPciDevicesCount Function

PrlSrvCfg_GetGenericPciDevicesCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of generic PCI devices installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericPciDevicesCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnGenericPciDevicesCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnGenericPciDevicesCount
[out] A pointer to a variable that receives the number of devices

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericScsiDevice Function

PrlSrvCfg_GetGenericScsiDevice Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a generic SCSI device installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericScsiDevice(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the GenericScsiDevice (beginning with 0). To get the number of installed generic SCSI devices, use the PrlSrvCfg_GetGenericScsiDevicesCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the generic SCSI device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetGenericScsiDevicesCount Function

PrlSrvCfg_GetGenericScsiDevicesCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of generic SCSI devices installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetGenericScsiDevicesCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnGenericScsiDevicesCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnGenericScsiDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHardDisk Function

PrlSrvCfg_GetHardDisk Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains an object of type PHT_HW_HARD_DISK containing information about a hard disks drive on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHardDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the drive (beginning with 0). The number of drives in the list can be determined by making the PrlSrvCfg_GetHardDisksCount function call.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_HARD_DISK containing the drive information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHardDisksCount Function

PrlSrvCfg_GetHardDisksCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of hard disk drives on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHardDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHardDisksCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHardDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostname Function

PrlSrvCfg_GetHostname Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the server hostname.

Syntax
PRL_RESULT PrlSrvCfg_GetHostname(
    PRL_HANDLE hSrvConfig,
    PRL_STR sHostname,
    PRL_UINT32_PTR pnHostnameBufLength
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
sHostname
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostnameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsMajor Function

PrlSrvCfg_GetHostOsMajor Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the major version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsMajor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsMajor
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsMajor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsMinor Function

PrlSrvCfg_GetHostOsMinor Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the minor version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsMinor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsMinor
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsMinor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsStrPresentation Function

PrlSrvCfg_GetHostOsStrPresentation Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the full host operating system information as a single string.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsStrPresentation(
    PRL_HANDLE hSrvConfig,
    PRL_STR sHostOsStrPresentation,
    PRL_UINT32_PTR pnHostOsStrPresentationBufLength
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
sHostOsStrPresentation
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostOsStrPresentationBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsSubMinor Function

PrlSrvCfg_GetHostOsSubMinor Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the sub-minor version number of the host operating system.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsSubMinor(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostOsSubMinor
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsSubMinor
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostOsType Function

PrlSrvCfg_GetHostOsType Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Returns the host operating system type.

Syntax
PRL_RESULT PrlSrvCfg_GetHostOsType(
    PRL_HANDLE hSrvConfig,
    PRL_HOST_OS_TYPE_PTR pnHostOsType
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostOsType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetHostRamSize Function

PrlSrvCfg_GetHostRamSize Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the amount of memory (RAM) available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetHostRamSize(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnHostRamSize
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnHostRamSize
[out] A pointer to a variable that receives the result. The memory size is specified in Megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetNetAdapter Function

PrlSrvCfg_GetNetAdapter Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains an object of type PHT_HW_NET_ADAPTER containing information about a network adapter.

Syntax
PRL_RESULT PrlSrvCfg_GetNetAdapter(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the network adapter (beginning with 0). To get the number of adapters available, use the PrlSrvCfg_GetNetAdaptersCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_NET_ADAPTER containing the network adapter information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetNetAdaptersCount Function

PrlSrvCfg_GetNetAdaptersCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of network adapters available on the server.

Syntax
PRL_RESULT PrlSrvCfg_GetNetAdaptersCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnNetAdaptersCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnNetAdaptersCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetOpticalDisk Function

PrlSrvCfg_GetOpticalDisk Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains an object of type PHT_HW_GENERIC_DEVICE containing information about an optical disk on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetOpticalDisk(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the optical disk (beginning with 0). To get the number of disks available, use the PrlSrvCfg_GetOpticalDisksCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the disk information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetOpticalDisksCount Function

PrlSrvCfg_GetOpticalDisksCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of optical disks on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetOpticalDisksCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnOpticalDisksCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnOpticalDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetParallelPort Function

PrlSrvCfg_GetParallelPort Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a parallel port on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetParallelPort(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the port (beginning with 0). To get the number ports available, use the PrlSrvCfg_GetParallelPortsCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the port information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetParallelPortsCount Function

PrlSrvCfg_GetParallelPortsCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of parallel ports on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetParallelPortsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnParallelPortsCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnParallelPortsCount
[out] A pointer to a variable that receives the result

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetPrinter Function

PrlSrvCfg_GetPrinter Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a printer installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetPrinter(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the printer (beginning with 0). To get the number of installed printers, use the PrlSrvCfg_GetPrintersCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the printer information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetPrintersCount Function

PrlSrvCfg_GetPrintersCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of printers installed on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetPrintersCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnPrintersCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnPrintersCount
[out] A pointer to a variable that receives the

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSearchDomains Function

PrlSrvCfg_GetSearchDomains Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains the list of search domains.

Syntax
PRL_RESULT PrlSrvCfg_GetSearchDomains(
    PRL_HANDLE hSrvConfig,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApi.h

Parameters

phSearchDomainsList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of search domains.
hNetAdapter
A handle of type PHT_SERVER_CONFIG.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSerialPort Function

PrlSrvCfg_GetSerialPort Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a serial port on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSerialPort(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the port (beginning with 0). To get the number of ports available, use the PrlSrvCfg_GetSerialPortsCount function.
phDevice
[out] A pointer to a variable that receives a handle of type PHT_HW_GENERIC_DEVICE containing the port information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSerialPortsCount Function

PrlSrvCfg_GetSerialPortsCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of serial ports available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSerialPortsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSerialPortsCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSerialPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundMixerDev Function

PrlSrvCfg_GetSoundMixerDev Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound mixer device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundMixerDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the sound mixer device (beginning with 0). To get the number of devices available, use the PrlSrvCfg_GetSoundMixerDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundMixerDevsCount Function

PrlSrvCfg_GetSoundMixerDevsCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of sound mixer devices available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundMixerDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSoundMixerDevsCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSoundMixerDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundOutputDev Function

PrlSrvCfg_GetSoundOutputDev Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a handle of type PHT_HW_GENERIC_DEVICE containing information about a sound device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundOutputDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the sound device (beginning with 0). To get the number of sound devices available, use the PrlSrvCfg_GetSoundOutputDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetSoundOutputDevsCount Function

PrlSrvCfg_GetSoundOutputDevsCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of sound devices available on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetSoundOutputDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnSoundOutputDevsCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnSoundOutputDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetUsbDev Function

PrlSrvCfg_GetUsbDev Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Obtains a pointer of type PHT_HW_GENERIC_DEVICE containing information about a USB device on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetUsbDev(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
nIndex
A numeric index identifying the device (beginning with 0). To get the number of USB devices available, use the PrlSrvCfg_GetUsbDevsCount function.
phDevice
[out] A pointer to a variable that receives a pointer of type PHT_HW_GENERIC_DEVICE containing the device information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_GetUsbDevsCount Function

PrlSrvCfg_GetUsbDevsCount Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines the number of USB devices on the host.

Syntax
PRL_RESULT PrlSrvCfg_GetUsbDevsCount(
    PRL_HANDLE hSrvConfig,
    PRL_UINT32_PTR pnUsbDevsCount
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pnUsbDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_IsSoundDefaultEnabled Function

PrlSrvCfg_IsSoundDefaultEnabled Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines whether a sound device on the host is enabled or disabled.

Syntax
PRL_RESULT PrlSrvCfg_IsSoundDefaultEnabled(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbSoundDefaultEnabled
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbSoundDefaultEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the device is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_IsUsbSupported Function

PrlSrvCfg_IsUsbSupported Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines if USB is supported on the host.

Syntax
PRL_RESULT PrlSrvCfg_IsUsbSupported(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbUsbSupported
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbUsbSupported
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that USB is supported. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfg_IsVtdSupported Function

PrlSrvCfg_IsVtdSupported Function
PrlApi.h PHT_SERVER_CONFIG Send Feedback

Determines whether VT-d is supported on the host.

Syntax
PRL_RESULT PrlSrvCfg_IsVtdSupported(
    PRL_HANDLE hSrvConfig,
    PRL_BOOL_PTR pbVtdSupported
);
File

PrlApi.h

Parameters

hSrvConfig
A handle of type PHT_SERVER_CONFIG.
pbVtdSupported
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that VT-d is supported. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_CONFIG


PrlSrvCfgDev_GetId Function

PrlSrvCfgDev_GetId Function
PrlApi.h PHT_HW_GENERIC_DEVICE Send Feedback

Returns the system device ID.

Syntax
PRL_RESULT PrlSrvCfgDev_GetId(
    PRL_HANDLE hGenericDevice,
    PRL_STR sDevId,
    PRL_UINT32_PTR pnDevIdBufLength
);
File

PrlApi.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
sDevId
[out] A pointer to a buffer that receives the device ID (a UTF-8 encoded, null-terminated string)
pnDevIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_GetName Function

PrlSrvCfgDev_GetName Function
PrlApi.h PHT_HW_GENERIC_DEVICE Send Feedback

Returns the system device name.

Syntax
PRL_RESULT PrlSrvCfgDev_GetName(
    PRL_HANDLE hGenericDevice,
    PRL_STR sDevName,
    PRL_UINT32_PTR pnDevNameBufLength
);
File

PrlApi.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
sDevName
[out] A pointer to a buffer that receives the device name (a UTF-8 encoded, null-terminated string).
pnDevNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_GetType Function

PrlSrvCfgDev_GetType Function
PrlApi.h PHT_HW_GENERIC_DEVICE Send Feedback

Returns the device type.

Syntax
PRL_RESULT PrlSrvCfgDev_GetType(
    PRL_HANDLE hGenericDevice,
    PRL_DEVICE_TYPE_PTR pnDevType
);
File

PrlApi.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pnDevType
[out] A pointer to a variable that receives the device type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_GENERIC_DEVICE


PrlSrvCfgDev_IsConnectedToVm Function

PrlSrvCfgDev_IsConnectedToVm Function
PrlApi.h PHT_HW_GENERIC_DEVICE Send Feedback

Determines whether the device is connected to the virtual machine.

Syntax
PRL_RESULT PrlSrvCfgDev_IsConnectedToVm(
    PRL_HANDLE hGenericDevice,
    PRL_BOOL_PTR pbConnected
);
File

PrlApi.h

Parameters

hGenericDevice
A handle of type PHT_HW_GENERIC_DEVICE, or one of the descendant types, identifying the device.
pbConnected
[out] A pointer to a variable that receives the device type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_GENERIC_DEVICE


PrlSrvCfgHdd_GetDevId Function

PrlSrvCfgHdd_GetDevId Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Returns the hard disk device id.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevId(
    PRL_HANDLE hHardDisk,
    PRL_STR sDevId,
    PRL_UINT32_PTR pnDevIdBufLength
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
sDevId
[out] Pointer to a buffer that receives the device ID (a UTF-8 encoded, null-terminated string).
pnDevIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDevName Function

PrlSrvCfgHdd_GetDevName Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Returns the hard disk device name.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevName(
    PRL_HANDLE hHardDisk,
    PRL_STR sDevName,
    PRL_UINT32_PTR pnDevNameBufLength
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
sDevName
[out] Pointer to a buffer that receives the device name (a UTF-8 encoded, null-terminated string).
pnDevNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDevSize Function

PrlSrvCfgHdd_GetDevSize Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Returns the size of the hard disk device.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDevSize(
    PRL_HANDLE hHardDisk,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnSize
[out] Pointer to a variable that receives the hard disk size. The size is specified in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetDiskIndex Function

PrlSrvCfgHdd_GetDiskIndex Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Returns the index of a hard disk device.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetDiskIndex(
    PRL_HANDLE hHardDisk,
    PRL_UINT32_PTR pnIndex
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnIndex
[out] Pointer to a variable that receives the hard disk index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetPart Function

PrlSrvCfgHdd_GetPart Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Obtains a handle of type PHT_HW_HARD_DISK_PARTITION identifying the specified hard disk partition.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetPart(
    PRL_HANDLE hHardDisk,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPart
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
nIndex
An index of the hard disk partition for which you would like to obtain a handle. Partitions are index beginning with 0 (zero). The total number of partitions can be obtained by calling the PrlSrvCfgHdd_GetPartsCount function.
phPart
[out] A pointer to a handle of type PHT_HW_HARD_DISK_PARTITION identifying the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHdd_GetPartsCount Function

PrlSrvCfgHdd_GetPartsCount Function
PrlApi.h PHT_HW_HARD_DISK Send Feedback

Returns the number of partitions available on a hard drive.

Syntax
PRL_RESULT PrlSrvCfgHdd_GetPartsCount(
    PRL_HANDLE hHardDisk,
    PRL_UINT32_PTR pnPartsCount
);
File

PrlApi.h

Parameters

hHardDisk
A handle of type PHT_HW_HARD_DISK, identifying the hard disk.
pnPartsCount
[out] A pointer to a variable receiving the number of partitions.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function together with the PrlSrvCfgHdd_GetPart function to obtain a handle to an object containing a hard disk partition information.

Links
PrlApi.h, PHT_HW_HARD_DISK


PrlSrvCfgHddPart_GetIndex Function

PrlSrvCfgHddPart_GetIndex Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Returns the index of the specified hard disk partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetIndex(
    PRL_HANDLE hPart,
    PRL_UINT32_PTR pnIndex
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnIndex
[out] Pointer to a variable that receives the partition index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Partition index uniquely identifies a partition on a hard disk.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetName Function

PrlSrvCfgHddPart_GetName Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Returns a hard disk partition name.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetName(
    PRL_HANDLE hPart,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
sName
[out] Pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetSize Function

PrlSrvCfgHddPart_GetSize Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Returns the hard disk partition size.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetSize(
    PRL_HANDLE hPart,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnSize
[out] Pointer to a buffer that receives the partition size. The size is specified in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_GetSysName Function

PrlSrvCfgHddPart_GetSysName Function
PrlApi.h PHT_HW_GENERIC_DEVICE Send Feedback

Returns a hard disk partition system name.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetSysName(
    PRL_HANDLE hPart,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApi.h

Parameters

hPart
A handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
sSysName
[out] Pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_GENERIC_DEVICE


PrlSrvCfgHddPart_GetType Function

PrlSrvCfgHddPart_GetType Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Returns a numerical code identifying the type of the specified partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_GetType(
    PRL_HANDLE hPart,
    PRL_UINT32_PTR pnType
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pnType
[out] Pointer to a variable that receives a numerical code identifying the partition type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsActive Function

PrlSrvCfgHddPart_IsActive Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Determines whether a disk partition is active or inactive.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsActive(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbActive
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbActive
[out] Pointer to a variable that receives the return value. PRL_TRUE indicates that the partition is active. PRL_FALSE indicates that the partition is inactive.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsInUse Function

PrlSrvCfgHddPart_IsInUse Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Determines whether a disk partition is in use, that is, whether it contains a valid file system, being used for swap or by a database, etc.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsInUse(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbInUse
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbInUse
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that the partition is in use. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgHddPart_IsLogical Function

PrlSrvCfgHddPart_IsLogical Function
PrlApi.h PHT_HW_HARD_DISK_PARTITION Send Feedback

Determines whether the specified partition is a logical partition.

Syntax
PRL_RESULT PrlSrvCfgHddPart_IsLogical(
    PRL_HANDLE hPart,
    PRL_BOOL_PTR pbLogical
);
File

PrlApi.h

Parameters

hPart
A valid handle of type PHT_HW_HARD_DISK_PARTITION identifying the hard disk partition.
pbLogical
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that this is a logical partition. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_HARD_DISK_PARTITION


PrlSrvCfgNet_GetDefaultGateway Function

PrlSrvCfgNet_GetDefaultGateway Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Returns the default gateway address for the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetDefaultGateway(
    PRL_HANDLE hNetAdapter,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
sDefaultGateway
[out] Pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultGatewayBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetDnsServers Function

PrlSrvCfgNet_GetDnsServers Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Obtains a list of addresses of DNS servers assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetDnsServers(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phDnsServersList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of addresses.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetMacAddress Function

PrlSrvCfgNet_GetMacAddress Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Returns the MAC address of the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetMacAddress(
    PRL_HANDLE hNetAdapter,
    PRL_STR sMacAddress,
    PRL_UINT32_PTR pnMacAddressBufLength
);
File

PrlApi.h

Parameters

hNetAdapter
A handle of type PHT_HW_NET_ADAPTER identifying the network adapter.
sMacAddress
[out] Pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetNetAdapterType Function

PrlSrvCfgNet_GetNetAdapterType Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Returns a network adapter type.

Syntax
PRL_RESULT PrlSrvCfgNet_GetNetAdapterType(
    PRL_HANDLE hNetAdapter,
    PRL_HW_INFO_NET_ADAPTER_TYPE_PTR pnNetAdapterType
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pnNetAdapterType
[out] A pointer to a variable that receives the network adapter type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetNetAddresses Function

PrlSrvCfgNet_GetNetAddresses Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Obtains a list of network addresses (IP address/Subnet mask pairs) assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetNetAddresses(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phNetAddressesList
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phNetAddressesList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the addresses.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetSearchDomains Function

PrlSrvCfgNet_GetSearchDomains Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Obtains a list of search domains assigned to the specified network adapter.

Syntax
PRL_RESULT PrlSrvCfgNet_GetSearchDomains(
    PRL_HANDLE hNetAdapter,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
phSearchDomainsList
[out] A pointer to a variable that receives the PHT_STRINGS_LIST handle containing the list of search domains.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate strings list object

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_GetSysIndex Function

PrlSrvCfgNet_GetSysIndex Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Returns a network adapter system index.

Syntax
PRL_RESULT PrlSrvCfgNet_GetSysIndex(
    PRL_HANDLE hNetAdapter,
    PRL_UINT32_PTR pnSysIndex
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pnSysIndex
[out] A pointer to a variable that receives the adapter index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A system index uniquely identifies an adapter on a physical host.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_IsConfigureWithDhcp Function

PrlSrvCfgNet_IsConfigureWithDhcp Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Determines whether the adapter network settings are configured through DHCP.

Syntax
PRL_RESULT PrlSrvCfgNet_IsConfigureWithDhcp(
    PRL_HANDLE hNetAdapter,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the adapter settings are configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvCfgNet_IsEnabled Function

PrlSrvCfgNet_IsEnabled Function
PrlApi.h PHT_HW_NET_ADAPTER Send Feedback

Determines whether the adapter is enabled or disabled.

Syntax
PRL_RESULT PrlSrvCfgNet_IsEnabled(
    PRL_HANDLE hNetAdapter,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hNetAdapter
A valid handle of type PHT_HW_NET_ADAPTER identifying the adapter.
pbEnabled
[out] A pointer to a variable that receives the return value. PRL_TRUE indicates that the adapter is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_HW_NET_ADAPTER


PrlSrvInfo_GetCmdPort Function

PrlSrvInfo_GetCmdPort Function
PrlApi.h PHT_SERVER_INFO Send Feedback

Returns the port number at which the Parallels Service is listening for requests.

Syntax
PRL_RESULT PrlSrvInfo_GetCmdPort(
    PRL_HANDLE hServerInfo,
    PRL_UINT32_PTR pnPort
);
File

PrlApi.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
pnPort
[out] A pointer to a variable that receives the port number.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_INFO


PrlSrvInfo_GetHostName Function

PrlSrvInfo_GetHostName Function
PrlApi.h PHT_SERVER_INFO Send Feedback

Returns the name of the machine hosting the specified Parallels Service.

Syntax
PRL_RESULT PrlSrvInfo_GetHostName(
    PRL_HANDLE hServerInfo,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApi.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_INFO


PrlSrvInfo_GetOsVersion Function

PrlSrvInfo_GetOsVersion Function
PrlApi.h PHT_SERVER_INFO Send Feedback

Returns the version of the host operating system.

Syntax
PRL_RESULT PrlSrvInfo_GetOsVersion(
    PRL_HANDLE hServerInfo,
    PRL_STR sOsVersion,
    PRL_UINT32_PTR pnOsVersionBufLength
);
File

PrlApi.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sOsVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOsVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_INFO


PrlSrvInfo_GetProductVersion Function

PrlSrvInfo_GetProductVersion Function
PrlApi.h PHT_SERVER_INFO Send Feedback

Returns the Parallels product version number.

Syntax
PRL_RESULT PrlSrvInfo_GetProductVersion(
    PRL_HANDLE hServerInfo,
    PRL_STR sProductVersion,
    PRL_UINT32_PTR pnProductVersionBufLength
);
File

PrlApi.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sProductVersion
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnProductVersionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_INFO


PrlSrvInfo_GetServerUuid Function

PrlSrvInfo_GetServerUuid Function
PrlApi.h PHT_SERVER_INFO Send Feedback

Returns the host machine UUID (universally unique ID).

Syntax
PRL_RESULT PrlSrvInfo_GetServerUuid(
    PRL_HANDLE hServerInfo,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApi.h

Parameters

hServerInfo
A handle of type PHT_SERVER_INFO containing the Parallels Service information.
sServerUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the PHT_SERVER_INFO object does not contain any data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SERVER_INFO


PrlStat_GetCpusStatsCount Function

PrlStat_GetCpusStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS See Also Send Feedback

Determines the number of handles of type PHT_SYSTEM_STATISTICS_CPU contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetCpusStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available CPU in the system will have its own PHT_SYSTEM_STATISTICS_CPU object instance.

See Also

PrlStat_GetCpuStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetCpuStat Function

PrlStat_GetCpuStat Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_CPU containing the specified CPU statistics.

Syntax
PRL_RESULT PrlStat_GetCpuStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phCpuStat
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the CPU statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetCpusStatsCount function.
phCpuStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetDisksStatsCount Function

PrlStat_GetDisksStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS See Also Send Feedback

Determines the number of handles of type PHT_SYSTEM_STATISTICS_DISK contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetDisksStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available disk drive in the system will have its own PHT_SYSTEM_STATISTICS_DISK object instance.

See Also

PrlStat_GetDiskStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetDiskStat Function

PrlStat_GetDiskStat Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK containing the specified disk statistics.

Syntax
PRL_RESULT PrlStat_GetDiskStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDiskStat
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the disk statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetDisksStatsCount function.
phDiskStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetDispUptime Function

PrlStat_GetDispUptime Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns the Parallels Service uptime in seconds.

Syntax
PRL_RESULT PrlStat_GetDispUptime(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnUptime
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnUptime
[out] A pointer to a variable that receives the result (Parallels Service uptime in seconds).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetFreeRamSize Function

PrlStat_GetFreeRamSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns free RAM size in bytes.

Syntax
PRL_RESULT PrlStat_GetFreeRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result (free RAM size in bytes).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetFreeSwapSize Function

PrlStat_GetFreeSwapSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns free swap size in bytes.

Syntax
PRL_RESULT PrlStat_GetFreeSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result (free swap size in bytes.)

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetIfacesStatsCount Function

PrlStat_GetIfacesStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS See Also Send Feedback

Determines the number of objects of type PHT_SYSTEM_STATISTICS_IFACE contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetIfacesStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each network interface will have its own PHT_SYSTEM_STATISTICS_IFACE object instance.

See Also

PrlStat_GetIfaceStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetIfaceStat Function

PrlStat_GetIfaceStat Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_IFACE containing the specified network interface statistics.

Syntax
PRL_RESULT PrlStat_GetIfaceStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phIfaceStat
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the network statistics object instance (beginning with 0). To get the number of instances, use the PrlStat_GetIfacesStatsCount function.
phIfaceStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetOsUptime Function

PrlStat_GetOsUptime Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns operating system uptime in seconds.

Syntax
PRL_RESULT PrlStat_GetOsUptime(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnUptime
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnUptime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetProcsStatsCount Function

PrlStat_GetProcsStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS See Also Send Feedback

Determines the number of handles of type PHT_SYSTEM_STATISTICS_PROCESS contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetProcsStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each system process will have its own PHT_SYSTEM_STATISTICS_PROCESS object instance.

See Also

PrlStat_GetProcStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetProcStat Function

PrlStat_GetProcStat Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_PROCESS containing the specified system process statistics.

Syntax
PRL_RESULT PrlStat_GetProcStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phProcStat
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the system process statistics object instance (beginning with 0). To determine the number of instances, use the PrlStat_GetProcsStatsCount function.
phProcStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetTotalRamSize Function

PrlStat_GetTotalRamSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns total RAM size in bytes.

Syntax
PRL_RESULT PrlStat_GetTotalRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetTotalSwapSize Function

PrlStat_GetTotalSwapSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns total swap size in bytes.

Syntax
PRL_RESULT PrlStat_GetTotalSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetUsageRamSize Function

PrlStat_GetUsageRamSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns the size RAM currently in use (in bytes).

Syntax
PRL_RESULT PrlStat_GetUsageRamSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetUsageSwapSize Function

PrlStat_GetUsageSwapSize Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Returns the size of swap space currently in use (in bytes).

Syntax
PRL_RESULT PrlStat_GetUsageSwapSize(
    PRL_HANDLE hStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStat_GetUsersStatsCount Function

PrlStat_GetUsersStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS See Also Send Feedback

Determines the number of handles of type PHT_SYSTEM_STATISTICS_USER_SESSION contained in the specified PHT_SYSTEM_STATISTICS object.

Syntax
PRL_RESULT PrlStat_GetUsersStatsCount(
    PRL_HANDLE hStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each user session will have its own PHT_SYSTEM_STATISTICS_USER_SESSION object instance.

See Also

PrlStat_GetUserStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS, See Also


PrlStat_GetUserStat Function

PrlStat_GetUserStat Function
PrlApi.h PHT_SYSTEM_STATISTICS Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_USER_SESSION containing the specified user session statistics.

Syntax
PRL_RESULT PrlStat_GetUserStat(
    PRL_HANDLE hStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phUserStat
);
File

PrlApi.h

Parameters

hStat
A handle of type PHT_SYSTEM_STATISTICS.
nIndex
A numeric index identifying the user session statistics object instance (beginning with 0). To determine the number of instances, use the PrlStat_GetUsersStatsCount function.
phUserStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.d

Links
PrlApi.h, PHT_SYSTEM_STATISTICS


PrlStatCpu_GetCpuUsage Function

PrlStatCpu_GetCpuUsage Function
PrlApi.h PHT_SYSTEM_STATISTICS_CPU Send Feedback

Returns the CPU usage, in percents.

Syntax
PRL_RESULT PrlStatCpu_GetCpuUsage(
    PRL_HANDLE hCpuStat,
    PRL_UINT32_PTR pnPercents
);
File

PrlApi.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnPercents
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetSystemTime Function

PrlStatCpu_GetSystemTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_CPU Send Feedback

Returns the CPU system time, in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetSystemTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetTotalTime Function

PrlStatCpu_GetTotalTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_CPU Send Feedback

Returns the CPU total time in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetTotalTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_CPU


PrlStatCpu_GetUserTime Function

PrlStatCpu_GetUserTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_CPU Send Feedback

Returns the CPU user time in seconds.

Syntax
PRL_RESULT PrlStatCpu_GetUserTime(
    PRL_HANDLE hCpuStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hCpuStat
A handle of type PHT_SYSTEM_STATISTICS_CPU identifying the CPU.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_CPU


PrlStatDisk_GetFreeDiskSpace Function

PrlStatDisk_GetFreeDiskSpace Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK Send Feedback

Returns free disk space, in bytes.

Syntax
PRL_RESULT PrlStatDisk_GetFreeDiskSpace(
    PRL_HANDLE hDiskStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetPartsStatsCount Function

PrlStatDisk_GetPartsStatsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK See Also Send Feedback

Determines the number of the handles of type PHT_SYSTEM_STATISTICS_DISK_PARTITION contained in the specified PHT_SYSTEM_STATISTICS_DISK object.

Syntax
PRL_RESULT PrlStatDisk_GetPartsStatsCount(
    PRL_HANDLE hDiskStat,
    PRL_UINT32_PTR pnCount
);
File

PrlApi.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each available partition will have its own PHT_SYSTEM_STATISTICS_DISK_PARTITION object instance.

See Also

PrlStatDisk_GetPartStat

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK, See Also


PrlStatDisk_GetPartStat Function

PrlStatDisk_GetPartStat Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION containing the specified disk partition statistics.

Syntax
PRL_RESULT PrlStatDisk_GetPartStat(
    PRL_HANDLE hDiskStat,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPartStat
);
File

PrlApi.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
nIndex
A numeric index identifying the PHT_SYSTEM_STATISTICS_DISK_PARTITION object instance (beginning with 0). To obtain the number of instances, use the PrlStatDisk_GetPartsStatsCount function.
phPartStat
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetSystemName Function

PrlStatDisk_GetSystemName Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK Send Feedback

Returns the disk device name.

Syntax
PRL_RESULT PrlStatDisk_GetSystemName(
    PRL_HANDLE hDiskStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApi.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
sSystemName
[out] A pointer to a buffer that receives the disk name (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK


PrlStatDisk_GetUsageDiskSpace Function

PrlStatDisk_GetUsageDiskSpace Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK Send Feedback

Returns the size of the used space on the specified disk, in bytes.

Syntax
PRL_RESULT PrlStatDisk_GetUsageDiskSpace(
    PRL_HANDLE hDiskStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hDiskStat
A handle of type PHT_SYSTEM_STATISTICS_DISK identifying the disk.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK


PrlStatDiskPart_GetFreeDiskSpace Function

PrlStatDiskPart_GetFreeDiskSpace Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK_PARTITION Send Feedback

Returns the size of the free space on the specified disk partition, in bytes.

Syntax
PRL_RESULT PrlStatDiskPart_GetFreeDiskSpace(
    PRL_HANDLE hPartStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatDiskPart_GetSystemName Function

PrlStatDiskPart_GetSystemName Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK_PARTITION Send Feedback

Returns disk partition device name.

Syntax
PRL_RESULT PrlStatDiskPart_GetSystemName(
    PRL_HANDLE hPartStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApi.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
sSystemName
[out] A pointer to a buffer that receives the partition name (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatDiskPart_GetUsageDiskSpace Function

PrlStatDiskPart_GetUsageDiskSpace Function
PrlApi.h PHT_SYSTEM_STATISTICS_DISK_PARTITION Send Feedback

Returns the size of the used space on the specified disk partition, in bytes.

Syntax
PRL_RESULT PrlStatDiskPart_GetUsageDiskSpace(
    PRL_HANDLE hPartStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hPartStat
A handle of type PHT_SYSTEM_STATISTICS_DISK_PARTITION identifying the disk partition.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_DISK_PARTITION


PrlStatIface_GetInDataSize Function

PrlStatIface_GetInDataSize Function
PrlApi.h PHT_SYSTEM_STATISTICS_IFACE Send Feedback

Returns the total number of bytes the network interface has received since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetInDataSize(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnDataSize
);
File

PrlApi.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnDataSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetInPkgsCount Function

PrlStatIface_GetInPkgsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS_IFACE Send Feedback

Returns the total number of packets the network interface has received since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetInPkgsCount(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnPkgsCount
);
File

PrlApi.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnPkgsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetOutDataSize Function

PrlStatIface_GetOutDataSize Function
PrlApi.h PHT_SYSTEM_STATISTICS_IFACE Send Feedback

Returns the total number of bytes the network interface has sent since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetOutDataSize(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnDataSize
);
File

PrlApi.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnDataSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetOutPkgsCount Function

PrlStatIface_GetOutPkgsCount Function
PrlApi.h PHT_SYSTEM_STATISTICS_IFACE Send Feedback

Returns the total number of packets the network interface has sent since the Parallels Service was last started.

Syntax
PRL_RESULT PrlStatIface_GetOutPkgsCount(
    PRL_HANDLE hIfaceStat,
    PRL_UINT64_PTR pnPkgsCount
);
File

PrlApi.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
pnPkgsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_IFACE


PrlStatIface_GetSystemName Function

PrlStatIface_GetSystemName Function
PrlApi.h PHT_SYSTEM_STATISTICS_IFACE Send Feedback

Returns the network interface system name.

Syntax
PRL_RESULT PrlStatIface_GetSystemName(
    PRL_HANDLE hIfaceStat,
    PRL_STR sSystemName,
    PRL_UINT32_PTR pnSystemNameBufLength
);
File

PrlApi.h

Parameters

hIfaceStat
A handle of type of PHT_SYSTEM_STATISTICS_IFACE identifying the network interface.
sSystemName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSystemNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_IFACE


PrlStatProc_GetCommandName Function

PrlStatProc_GetCommandName Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns the process command name.

Syntax
PRL_RESULT PrlStatProc_GetCommandName(
    PRL_HANDLE hProcStat,
    PRL_STR sCommandName,
    PRL_UINT32_PTR pnCommandNameBufLength
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
sCommandName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnCommandNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetCpuUsage Function

PrlStatProc_GetCpuUsage Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns process CPU usage in percents.

Syntax
PRL_RESULT PrlStatProc_GetCpuUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT32_PTR pnPercents
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnPercents
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetId Function

PrlStatProc_GetId Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns process system id.

Syntax
PRL_RESULT PrlStatProc_GetId(
    PRL_HANDLE hProcStat,
    PRL_UINT32_PTR pnId
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnId
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetOwnerUserName Function

PrlStatProc_GetOwnerUserName Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns process owner user name.

Syntax
PRL_RESULT PrlStatProc_GetOwnerUserName(
    PRL_HANDLE hProcStat,
    PRL_STR sOwnerName,
    PRL_UINT32_PTR pnOwnerNameBufLength
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
sOwnerName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOwnerNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetRealMemUsage Function

PrlStatProc_GetRealMemUsage Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns real memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetRealMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetStartTime Function

PrlStatProc_GetStartTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns start time of the process, in seconds (number of seconds since January 1, 1601 (UTC)).

Syntax
PRL_RESULT PrlStatProc_GetStartTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetState Function

PrlStatProc_GetState Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns process state.

Syntax
PRL_RESULT PrlStatProc_GetState(
    PRL_HANDLE hProcStat,
    PRL_PROCESS_STATE_TYPE_PTR pnState
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnState
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetSystemTime Function

PrlStatProc_GetSystemTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns system running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetSystemTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetTotalMemUsage Function

PrlStatProc_GetTotalMemUsage Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns total memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetTotalMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetTotalTime Function

PrlStatProc_GetTotalTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns total running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetTotalTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetUserTime Function

PrlStatProc_GetUserTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns user running time of the process, in seconds.

Syntax
PRL_RESULT PrlStatProc_GetUserTime(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatProc_GetVirtMemUsage Function

PrlStatProc_GetVirtMemUsage Function
PrlApi.h PHT_SYSTEM_STATISTICS_PROCESS Send Feedback

Returns virtual memory usage size in bytes.

Syntax
PRL_RESULT PrlStatProc_GetVirtMemUsage(
    PRL_HANDLE hProcStat,
    PRL_UINT64_PTR pnSize
);
File

PrlApi.h

Parameters

hProcStat
A handle of type PHT_SYSTEM_STATISTICS_PROCESS identifying the system process.
pnSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_PROCESS


PrlStatUser_GetHostName Function

PrlStatUser_GetHostName Function
PrlApi.h PHT_SYSTEM_STATISTICS_USER_SESSION Send Feedback

Returns the host name of the client machine from which the session was initiated.

Syntax
PRL_RESULT PrlStatUser_GetHostName(
    PRL_HANDLE hUserStat,
    PRL_STR sHostName,
    PRL_UINT32_PTR pnHostNameBufLength
);
File

PrlApi.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetServiceName Function

PrlStatUser_GetServiceName Function
PrlApi.h PHT_SYSTEM_STATISTICS_USER_SESSION Send Feedback

Returns the name of the host system service that created the session.

Syntax
PRL_RESULT PrlStatUser_GetServiceName(
    PRL_HANDLE hUserStat,
    PRL_STR sServiceName,
    PRL_UINT32_PTR pnServiceNameBufLength
);
File

PrlApi.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sServiceName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServiceNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetSessionTime Function

PrlStatUser_GetSessionTime Function
PrlApi.h PHT_SYSTEM_STATISTICS_USER_SESSION Send Feedback

Returns session duration, in seconds.

Syntax
PRL_RESULT PrlStatUser_GetSessionTime(
    PRL_HANDLE hUserStat,
    PRL_UINT64_PTR pnTime
);
File

PrlApi.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
pnTime
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStatUser_GetUserName Function

PrlStatUser_GetUserName Function
PrlApi.h PHT_SYSTEM_STATISTICS_USER_SESSION Send Feedback

Returns session user name.

Syntax
PRL_RESULT PrlStatUser_GetUserName(
    PRL_HANDLE hUserStat,
    PRL_STR sUserName,
    PRL_UINT32_PTR pnUserNameBufLength
);
File

PrlApi.h

Parameters

hUserStat
A handle of type PHT_SYSTEM_STATISTICS_USER_SESSION identifying the user session.
sUserName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUserNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_SYSTEM_STATISTICS_USER_SESSION


PrlStrList_AddItem Function

PrlStrList_AddItem Function
PrlApi.h PHT_STRINGS_LIST Send Feedback

Adds a new string to the container.

Syntax
PRL_RESULT PrlStrList_AddItem(
    PRL_HANDLE hStringsList,
    PRL_CONST_STR sItem
);
File

PrlApi.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
sItem
A pointer to the string to add to the container. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_STRINGS_LIST


PrlStrList_GetItem Function

PrlStrList_GetItem Function
PrlApi.h PHT_STRINGS_LIST Send Feedback

Extracts the specified string from the container.

Syntax
PRL_RESULT PrlStrList_GetItem(
    PRL_HANDLE hStringsList,
    PRL_UINT32 nItemIndex,
    PRL_STR sItemBuf,
    PRL_UINT32_PTR pnItemBufSize
);
File

PrlApi.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
nItemIndex
A numeric index identifying the string (beginning with 0). To determine the number of string in the container, use the PrlStrList_GetItemsCount function.
sItemBuf
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnItemBufSize
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_STRINGS_LIST


PrlStrList_GetItemsCount Function

PrlStrList_GetItemsCount Function
PrlApi.h PHT_STRINGS_LIST Send Feedback

Determines the number of strings in the container.

Syntax
PRL_RESULT PrlStrList_GetItemsCount(
    PRL_HANDLE hStringsList,
    PRL_UINT32_PTR pnItemsCount
);
File

PrlApi.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
pnItemsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_STRINGS_LIST


PrlStrList_RemoveItem Function

PrlStrList_RemoveItem Function
PrlApi.h PHT_STRINGS_LIST Send Feedback

Removes the specified string from the container.

Syntax
PRL_RESULT PrlStrList_RemoveItem(
    PRL_HANDLE hStringsList,
    PRL_UINT32 nItemIndex
);
File

PrlApi.h

Parameters

hStringsList
A handle of type PHT_STRINGS_LIST identifying the string container.
nItemIndex
A numeric index identifying the string. Index is a sequential number assigned to every item in the container. To determine the index of an item, call the PrlStrList_GetItem in a loop (from 0 to PrlStrList_GetItemsCount()). The iteration number is the index of the corresponding item.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_STRINGS_LIST


PrlTypes.h

PrlTypes.h
Files Legend Macros Structures Types Send Feedback

PrlTypes.h

This file is the part of parallels public sdk library

Copyright (c) 2005-2008 Parallels Software International, Inc.

Remarks

All rights reserved. http://www.parallels.com

Macros
Name | Description
PRL_ASYNC_METHOD |
PRL_ASYNC_METHOD_DECL |
PRL_ASYNC_METHOD_PTR |
PRL_ASYNC_SRV_METHOD_DECL |
PRL_FALSE |
PRL_INVALID_HANDLE |
PRL_METHOD | Default method decoration
PRL_METHOD_DECL | Default method declaration for the header files
PRL_METHOD_PTR |
PRL_NULL | NULL (invalid) handle
PRL_SRV_METHOD_DECL |
PRL_STRUCT | Default structure definition
PRL_TRUE |
Structures
Name | Description
_PRL_API_METHOD | Parallels API method
_PRL_GUID | Global unique identifier
Types
Name | Description
PRL_API_METHOD_PTR |
PRL_BOOL | Boolean value (32 bit integer), zero means FALSE or TRUE otherwise
PRL_BOOL_PTR |
PRL_CHAR | All strings are UTF8 encoded
PRL_CHAR_PTR |
PRL_CONST_API_METHOD_PTR |
PRL_CONST_BOOL_PTR |
PRL_CONST_GUID_PTR |
PRL_CONST_HANDLE_PTR |
PRL_CONST_INT16_PTR |
PRL_CONST_INT32_PTR |
PRL_CONST_INT64_PTR |
PRL_CONST_INT8_PTR |
PRL_CONST_SIZE_PTR |
PRL_CONST_STR |
PRL_CONST_STR_PTR |
PRL_CONST_UINT16_PTR |
PRL_CONST_UINT32_PTR |
PRL_CONST_UINT64_PTR |
PRL_CONST_UINT8_PTR |
PRL_CONST_VOID_PTR |
PRL_GUID_PTR |
PRL_HANDLE | Handle representation
PRL_HANDLE_PTR |
PRL_INT16 | Signed 16 bit integer value
PRL_INT16_PTR |
PRL_INT16_PTR_PTR |
PRL_INT32 | Signed 32 bit integer value
PRL_INT32_PTR |
PRL_INT32_PTR_PTR |
PRL_INT64 | Signed 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_INT64_PTR |
PRL_INT64_PTR_PTR |
PRL_INT8 | Signed 8 bit integer value
PRL_INT8_PTR |
PRL_INT8_PTR_PTR |
PRL_SIZE | Unsigned integer type of the result of the sizeof operator
PRL_SIZE_PTR |
PRL_SIZE_PTR_PTR |
PRL_STR |
PRL_UINT16 | Unsigned 16 bit integer value
PRL_UINT16_PTR |
PRL_UINT16_PTR_PTR |
PRL_UINT32 | Unsigned 32 bit integer value
PRL_UINT32_PTR |
PRL_UINT32_PTR_PTR |
PRL_UINT64 | Unsigned 64 bit integer value Use _MSC_VER macros for MinGW use
PRL_UINT64_PTR |
PRL_UINT64_PTR_PTR |
PRL_UINT8 | Unsigned 8 bit integer value
PRL_UINT8_PTR |
PRL_UINT8_PTR_PTR |
PRL_VOID | Void pointers (for unified naming)
PRL_VOID_PTR |
PRL_VOID_PTR_PTR |
Links
Files, Legend, Macros, Structures, Types


PrlUsrCfg_CanChangeSrvSets Function

PrlUsrCfg_CanChangeSrvSets Function
PrlApi.h PHT_USER_PROFILE See Also Send Feedback

Determines if the current user can modify Parallels Service preferences (PHT_DISP_CONFIG).

Syntax
PRL_RESULT PrlUsrCfg_CanChangeSrvSets(
    PRL_HANDLE hUserProfile,
    PRL_BOOL_PTR pbCanChangeSrvSets
);
File

PrlApi.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
pbCanChangeSrvSets
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the client can modify Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

By default, only administrators of the host machine can modify Parallels Service preferences. Depending on the current Parallels Service settings, other users may also be granted this privilege at the time a user profile is created. To verify the default settings, use the PrlDispCfg_CanChangeDefaultSettings function. Whether the user can or cannot modify Parallels Service preferences, this setting is final and cannot itself be changed through Parallels API.

See Also

PrlDispCfg_CanChangeDefaultSettings

PrlDispCfg_SetCanChangeDefaultSettings

Links
PrlApi.h, PHT_USER_PROFILE, See Also


PrlUsrCfg_CanUseMngConsole Function

PrlUsrCfg_CanUseMngConsole Function
PrlApi.h PHT_USER_PROFILE Send Feedback

Determines if the user is allowed to use the Parallels Service management console utility.

Syntax
PRL_RESULT PrlUsrCfg_CanUseMngConsole(
    PRL_HANDLE hUserProfile,
    PRL_BOOL_PTR pbCanUseMngConsole
);
File

PrlApi.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
pbCanUseMngConsole
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allows to use the utility. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_USER_PROFILE


PrlUsrCfg_GetDefaultVmFolder Function

PrlUsrCfg_GetDefaultVmFolder Function
PrlApi.h PHT_USER_PROFILE See Also Send Feedback

Returns name and path of the default virtual machine directory for this user.

Syntax
PRL_RESULT PrlUsrCfg_GetDefaultVmFolder(
    PRL_HANDLE hUserProfile,
    PRL_STR sDefaultVmFolder,
    PRL_UINT32_PTR pnDefaultVmFolderBufLength
);
File

PrlApi.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sDefaultVmFolder
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultVmFolderBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the user doesn't have a default virtual machine folder (if it was not previously set up by the PrlUsrCfg_SetDefaultVmFolder function call), the function returns an empty string. In such a case, use the PrlUsrCfg_GetVmDirUuid function to get the virtual machine folder for the Parallels Service, which is used by default for all users.

See Also

PrlUsrCfg_SetDefaultVmFolder

Links
PrlApi.h, PHT_USER_PROFILE, See Also


PrlUsrCfg_GetVmDirUuid Function

PrlUsrCfg_GetVmDirUuid Function
PrlApi.h PHT_USER_PROFILE Send Feedback

Returns name and path of the default virtual machine folder for this Parallels Service.

Syntax
PRL_RESULT PrlUsrCfg_GetVmDirUuid(
    PRL_HANDLE hUserProfile,
    PRL_STR sVmDirUuid,
    PRL_UINT32_PTR pnVmDirUuidBufLength
);
File

PrlApi.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sVmDirUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmDirUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If a default virtual machine folder has been set up for this user with the PrlUsrCfg_SetDefaultVmFolder function, use the PrlUsrCfg_GetDefaultVmFolder to get its name and path.

Links
PrlApi.h, PHT_USER_PROFILE


PrlUsrCfg_SetDefaultVmFolder Function

PrlUsrCfg_SetDefaultVmFolder Function
PrlApi.h PHT_USER_PROFILE Send Feedback

Allows to set a default virtual machine folder for the user.

Syntax
PRL_RESULT PrlUsrCfg_SetDefaultVmFolder(
    PRL_HANDLE hUserProfile,
    PRL_CONST_STR sNewDefaultVmFolder
);
File

PrlApi.h

Parameters

hUserProfile
A handle of type PHT_USER_PROFILE identifying the user.
sNewDefaultVmFolder
Name and path of the folder to set as default virtual machine folder for the user. The folder must already exist on the host.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A Parallels Service has a default virtual machine directory (the directory where new virtual machines are created). Individual users can have their own default virtual machine directories if needed. If a user has its own virtual machine directory set up, it takes precedence over the Parallels Service default. To set a default directory for a user, first call the PrlSrv_UserProfileBeginEdit function to mark the beginning of the operation. Then call the PrlUsrCfg_SetDefaultVmFolder function to set the new default virtual machine folder. Finally, call the PrlSrv_UserProfileCommit function to save your changes.

Links
PrlApi.h, PHT_USER_PROFILE


PrlUsrCfg_SetVmDirUuid Function

PrlUsrCfg_SetVmDirUuid Function
PrlApi.h PHT_USER_PROFILE Send Feedback

Sets user default VM dir.

Syntax
PRL_RESULT PrlUsrCfg_SetVmDirUuid(
    PRL_HANDLE hUserProfile,
    PRL_CONST_STR sNewVmDirUuid
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_USER_PROFILE identifying the user.
unnamed_param
new VM dir

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_USER_PROFILE handle or non valid (NULL) pointer to the new VM dir string was specified PRL_ERR_SUCCESS - operation completed successfully

Remarks

Specified string value must be UTF-8 encoding and ends with '0' terminating symbol.

Links
PrlApi.h, PHT_USER_PROFILE


PrlUsrInfo_CanChangeSrvSets Function

PrlUsrInfo_CanChangeSrvSets Function
PrlApi.h PHT_USER_INFO Send Feedback

Determines whether the specified user is allowed to modify Parallels Service preferences.

Syntax
PRL_RESULT PrlUsrInfo_CanChangeSrvSets(
    PRL_HANDLE hUserInfo,
    PRL_BOOL_PTR pbCanChangeSrvSets
);
File

PrlApi.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
pbCanChangeSrvSets
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the user is allowed to modify Parallels Service preferences. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_USER_INFO


PrlUsrInfo_GetDefaultVmFolder Function

PrlUsrInfo_GetDefaultVmFolder Function
PrlApi.h PHT_USER_INFO See Also Send Feedback

Returns name and path of the default virtual machine directory for the specified user.

Syntax
PRL_RESULT PrlUsrInfo_GetDefaultVmFolder(
    PRL_HANDLE hUserInfo,
    PRL_STR sDefaultVmFolder,
    PRL_UINT32_PTR pnDefaultVmFolderBufLength
);
File

PrlApi.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sDefaultVmFolder
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDefaultVmFolderBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the user doesn't have a default virtual machine directory, the function will return the name and path of the default directory for this Parallels Service. To set a default virtual machine directory for a user, use the PrlUsrCfg_SetDefaultVmFolder function.

See Also

PrlUsrCfg_SetDefaultVmFolder

Links
PrlApi.h, PHT_USER_INFO, See Also


PrlUsrInfo_GetName Function

PrlUsrInfo_GetName Function
PrlApi.h PHT_USER_INFO Send Feedback

Returns the user name.

Syntax
PRL_RESULT PrlUsrInfo_GetName(
    PRL_HANDLE hUserInfo,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApi.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_USER_INFO


PrlUsrInfo_GetSessionCount Function

PrlUsrInfo_GetSessionCount Function
PrlApi.h PHT_USER_INFO Send Feedback

Returns the user active session count.

Syntax
PRL_RESULT PrlUsrInfo_GetSessionCount(
    PRL_HANDLE hUserInfo,
    PRL_UINT32_PTR pnSessionCount
);
File

PrlApi.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
pnSessionCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_USER_INFO


PrlUsrInfo_GetUuid Function

PrlUsrInfo_GetUuid Function
PrlApi.h PHT_USER_INFO Send Feedback

Returns the user Universally Unique Identifier (UUID).

Syntax
PRL_RESULT PrlUsrInfo_GetUuid(
    PRL_HANDLE hUserInfo,
    PRL_STR sUuid,
    PRL_UINT32_PTR pnUuidBufLength
);
File

PrlApi.h

Parameters

hUserInfo
A handle of type PHT_USER_INFO identifying the user.
sUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_USER_INFO


PrlVirtNet_Create Function

PrlVirtNet_Create Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Creates a new handle of type PHT_VIRTUAL_NETWORK.

Syntax
PRL_RESULT PrlVirtNet_Create(
    PRL_HANDLE_PTR phVirtNet
);
File

PrlApi.h

Parameters

phVirtNet
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a virtual network object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The handle is necessary to create and configure virtual networks. If you would like to create a new virtual network, use this function to create the handle first and then use its functions to configure the network. If you would like to modify the configuration of an existing virtual network, use the PrlSrv_GetVirtualNetworkList function to obtain a handle to the virtual network of interest.

It is the responsibility of the caller to free the handle with the PrlHandle_Free call when it is no longer needed.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetAdapterIndex Function

PrlVirtNet_GetAdapterIndex Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns a numeric index assigned to the network adapter in the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetAdapterIndex(
    PRL_HANDLE hVirtNet,
    PRL_UINT32_PTR pnAdapterIndex
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pnAdapterIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetAdapterName Function

PrlVirtNet_GetAdapterName Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the name of the network adapter in the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetAdapterName(
    PRL_HANDLE hVirtNet,
    PRL_STR sAdapterName,
    PRL_UINT32_PTR pnAdapterNameBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sAdapterName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnAdapterNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetBoundCardMac Function

PrlVirtNet_GetBoundCardMac Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the bound card MAC address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetBoundCardMac(
    PRL_HANDLE hVirtNet,
    PRL_STR sBoundCardMac,
    PRL_UINT32_PTR pnBoundCardMacBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sBoundCardMac
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnBoundCardMacBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetDescription Function

PrlVirtNet_GetDescription Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the description of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetDescription(
    PRL_HANDLE hVirtNet,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetDhcpIPAddress Function

PrlVirtNet_GetDhcpIPAddress Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the DCHP IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetDhcpIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_STR sDhcpIPAddress,
    PRL_UINT32_PTR pnDhcpIPAddressBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDhcpIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetHostIPAddress Function

PrlVirtNet_GetHostIPAddress Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the host IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetHostIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_STR sHostIPAddress,
    PRL_UINT32_PTR pnHostIPAddressBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHostIPAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPNetMask Function

PrlVirtNet_GetIPNetMask Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the IP net mask of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPNetMask(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPNetMask,
    PRL_UINT32_PTR pnIPNetMaskBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPNetMaskBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPScopeEnd Function

PrlVirtNet_GetIPScopeEnd Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the DHCP end IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeEnd,
    PRL_UINT32_PTR pnIPScopeEndBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeEndBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetIPScopeStart Function

PrlVirtNet_GetIPScopeStart Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the DHCP start IP address of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetIPScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_STR sIPScopeStart,
    PRL_UINT32_PTR pnIPScopeStartBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnIPScopeStartBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetNetworkId Function

PrlVirtNet_GetNetworkId Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the ID of the specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_GetNetworkId(
    PRL_HANDLE hVirtNet,
    PRL_STR sNetworkId,
    PRL_UINT32_PTR pnNetworkIdBufLength
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sNetworkId
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnNetworkIdBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetNetworkType Function

PrlVirtNet_GetNetworkType Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the virtual network type.

Syntax
PRL_RESULT PrlVirtNet_GetNetworkType(
    PRL_HANDLE hVirtNet,
    PRL_NET_VIRTUAL_NETWORK_TYPE_PTR pnNetworkType
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pnNetworkType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Network types are defined in the PRL_NET_VIRTUAL_NETWORK_TYPE enumeration. The following describes network types are used:

  • PVN_BRIDGED_ETHERNET
  • PVN_HOST_ONLY
Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_GetPortForwardList Function

PrlVirtNet_GetPortForwardList Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Returns the port forward entries list.

Syntax
PRL_RESULT PrlVirtNet_GetPortForwardList(
    PRL_HANDLE hVirtNet,
    PRL_PORT_FORWARDING_TYPE nPortFwdType,
    PRL_HANDLE_PTR phPortFwdList
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nPortFwdType
A port forward type ( PRL_PORT_FORWARDING_TYPE enumeration ).
phPortFwdList
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create the list or a port forward handle object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_IsAdapterEnabled Function

PrlVirtNet_IsAdapterEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Determines whether the specified virtual network adapter is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsAdapterEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is enabled. PRL_FALSE indicates that the adapter is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_IsDHCPServerEnabled Function

PrlVirtNet_IsDHCPServerEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Determines whether the specified virtual network DHCP server is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsDHCPServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the DHCP server is enabled. PRL_FALSE indicates that the DHCP server is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_IsEnabled Function

PrlVirtNet_IsEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Determines whether the specified virtual network is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the virtual network is enabled. PRL_FALSE indicates that the virtual network is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_IsNATServerEnabled Function

PrlVirtNet_IsNATServerEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Determines whether the specified virtual network NAT server is enabled or disabled.

Syntax
PRL_RESULT PrlVirtNet_IsNATServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
pbEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the NAT server is enabled. PRL_FALSE indicates that the NAT server is disabled.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterEnabled Function

PrlVirtNet_SetAdapterEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Allows to enable or disable a specified virtual network adapter.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the adapter. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterIndex Function

PrlVirtNet_SetAdapterIndex Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified adapter index.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterIndex(
    PRL_HANDLE hVirtNet,
    PRL_UINT32 nAdapterIndex
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nAdapterIndex
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetAdapterName Function

PrlVirtNet_SetAdapterName Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network adapter name.

Syntax
PRL_RESULT PrlVirtNet_SetAdapterName(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sAdapterName
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sAdapterName
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetBoundCardMac Function

PrlVirtNet_SetBoundCardMac Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network bound card MAC address.

Syntax
PRL_RESULT PrlVirtNet_SetBoundCardMac(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sBoundCardMac
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sBoundCardMac
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

MAC address gets by PrlSrvCfgNet_GetMacAddress functions for given network adapter.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDescription Function

PrlVirtNet_SetDescription Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network description.

Syntax
PRL_RESULT PrlVirtNet_SetDescription(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sDescription
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDescription
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDhcpIPAddress Function

PrlVirtNet_SetDhcpIPAddress Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network DHCP IP address.

Syntax
PRL_RESULT PrlVirtNet_SetDhcpIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sDhcpIPAddress
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sDhcpIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetDHCPServerEnabled Function

PrlVirtNet_SetDHCPServerEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Allows to enable or disable a specified virtual network DHCP server.

Syntax
PRL_RESULT PrlVirtNet_SetDHCPServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the DHCP server. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetEnabled Function

PrlVirtNet_SetEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Allows to enable or disable a specified virtual network.

Syntax
PRL_RESULT PrlVirtNet_SetEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the virtual network. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetHostIPAddress Function

PrlVirtNet_SetHostIPAddress Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network host IP address.

Syntax
PRL_RESULT PrlVirtNet_SetHostIPAddress(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sHostIPAddress
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sHostIPAddress
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPNetMask Function

PrlVirtNet_SetIPNetMask Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network IP net mask.

Syntax
PRL_RESULT PrlVirtNet_SetIPNetMask(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPNetMask
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPNetMask
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPScopeEnd Function

PrlVirtNet_SetIPScopeEnd Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network DHCP end IP address.

Syntax
PRL_RESULT PrlVirtNet_SetIPScopeEnd(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeEnd
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeEnd
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetIPScopeStart Function

PrlVirtNet_SetIPScopeStart Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network DHCP start IP address.

Syntax
PRL_RESULT PrlVirtNet_SetIPScopeStart(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sIPScopeStart
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sIPScopeStart
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNATServerEnabled Function

PrlVirtNet_SetNATServerEnabled Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Allows to enable or disable a specified virtual network NAT server.

Syntax
PRL_RESULT PrlVirtNet_SetNATServerEnabled(
    PRL_HANDLE hVirtNet,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virual network.
bEnabled
A boolean value indicating the type of action to perform. PRL_TRUE will enable the NAT server. PRL_FALSE will disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNetworkId Function

PrlVirtNet_SetNetworkId Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network ID.

Syntax
PRL_RESULT PrlVirtNet_SetNetworkId(
    PRL_HANDLE hVirtNet,
    PRL_CONST_STR sNetworkId
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
sNetworkId
The value to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetNetworkType Function

PrlVirtNet_SetNetworkType Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the specified virtual network type.

Syntax
PRL_RESULT PrlVirtNet_SetNetworkType(
    PRL_HANDLE hVirtNet,
    PRL_NET_VIRTUAL_NETWORK_TYPE nNetworkType
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nNetworkType
The value to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Network types are defined in the PRL_NET_VIRTUAL_NETWORK_TYPE enumeration. The following describes network types are used:

  • PVN_BRIDGED_ETHERNET
  • PVN_HOST_ONLY
Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVirtNet_SetPortForwardList Function

PrlVirtNet_SetPortForwardList Function
PrlApi.h PHT_VIRTUAL_NETWORK Send Feedback

Sets the port forward entries list.

Syntax
PRL_RESULT PrlVirtNet_SetPortForwardList(
    PRL_HANDLE hVirtNet,
    PRL_PORT_FORWARDING_TYPE nPortFwdType,
    PRL_HANDLE hPortFwdList
);
File

PrlApi.h

Parameters

hVirtNet
A handle of type PHT_VIRTUAL_NETWORK identifying the virtual network.
nPortFwdType
A port forward type ( PRL_PORT_FORWARDING_TYPE enumeration ).
hPortFwdList
The list of PHT_PORT_FORWARDING handles.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a port forward entry object.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_NETWORK


PrlVm_BeginEdit Function

PrlVm_BeginEdit Function
PrlApi.h PHT_VIRTUAL_MACHINE Example Send Feedback

The PrlVm_BeginEdit function is used in modifying a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_BeginEdit(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlVm_BeginEdit and the PrlVm_Commit functions are used to detect collisions with other clients trying to modify the same virtual machine at the same time. The PrlVm_BeginEdit call timestamps the beginning of the editing operation. It does not lock the machine, so other clients can modify the same machine at the same time. When you are done making the changes, you must call the PrlVm_Commit function to save them in the virtual machine configuration. The function will verify that the configuration has not been modified by another client. If a collision is detected, your changes will be rejected. To ensure that you always work with the most recent configuration data, the PrlVm_BeginEdit function reloads it when called. If you first modified the data in your program and then called the PrlVm_BeginEdit function, your changes will be lost.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PrlApi.h, PHT_VIRTUAL_MACHINE, Example


PrlVm_CancelCompressor Function

PrlVm_CancelCompressor Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Cancels the running Compressor operation that was started with PrlVm_RunCompressor.

Syntax
PRL_HANDLE PrlVm_CancelCompressor(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Clone Function

PrlVm_Clone Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Clones an existing virtual machine.

Syntax
PRL_HANDLE PrlVm_Clone(
    PRL_HANDLE hVm,
    PRL_CONST_STR new_vm_name,
    PRL_CONST_STR new_vm_root_path,
    PRL_BOOL bCreateTemplate
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
new_vm_name
The name to use for the new virtual machine.
new_vm_root_path
Name and path of the directory where the new virtual machine should be created. To create the machine in a default directory, pass an empty string.
bCreateTemplate
Specifies whether the clone should be created as a virtual machine or as a template. To create a template, set this parameter value to PRL_TRUE. To create a virtual machine, set it to PRL_FALSE. When creating a virtual machine from a template, set the parameter value to PRL_FALSE.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The function creates an exact copy of the specified virtual machine on the same host using the specified new name and location. In order to perform a clone operation, the original machine must be registered with the Parallels Service. A clone can be created as a virtual machine or as a template. To create a template, set the bCreateTemplate parameter value to PRL_TRUE. The function can also be used to create new virtual machines from templates. In order to that, the hVm parameter must contain a handle to a template, the name and the path parameters must be set to desired values, and the bCreateTemplate parameter must be set to PRL_FALSE.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Commit Function

PrlVm_Commit Function
PrlApi.h PHT_VIRTUAL_MACHINE Example Send Feedback

The PrlVm_Commit function is used in modifying a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_Commit(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The PrlVm_BeginEdit and the PrlVm_Commit functions are used to detect collisions with other clients trying to modify the same virtual machine at the same time. The PrlVm_BeginEdit call timestamps the beginning of the editing operation. It does not lock the machine, so other clients can modify the same machine at the same time. When you are done making the changes, you must call the PrlVm_Commit function to save them in the virtual machine configuration. The function will verify that the configuration has not been modified by another client. If a collision is detected, your changes will be rejected.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following example illustrates how to use PrlVm_BeginEdit and PrlVm_Commit functions.

PRL_HANDLE hJobBeginEdit;
PRL_HANDLE hJobCommit;
PRL_RESULT nJobRetCode;

// Timestamp the beginning of the configuration changes operation.
hJobBeginEdit = PrlVm_BeginEdit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobBeginEdit, 10000);

// Check for errors.
PrlJob_GetRetCode(hJobBeginEdit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobBeginEdit);
    return nJobRetCode;
}

// The code modifying configuration parameters goes here...

// Commit the changes when done.
hJobCommit = PrlVm_Commit(hVm);

// Wait for the job to complete.
ret = PrlJob_Wait(hJobCommit, 10000);

// Check the results of the commit operation.
PrlJob_GetRetCode(hJobCommit, &nJobRetCode);

if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Commit error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJobCommit);
    return nJobRetCode;
}
Links
PrlApi.h, PHT_VIRTUAL_MACHINE, Example


PrlVm_CreateEvent Function

PrlVm_CreateEvent Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Creates VM event that bint to current VM.

Syntax
PRL_RESULT PrlVm_CreateEvent(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phEvent
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
buffer for storing result

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (null) pointer to buffer was specified PRL_ERR_OUT_OF_MEMORY - not enough memory to instantiate VM event object PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_CreateSnapshot Function

PrlVm_CreateSnapshot Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Creates a virtual machine snapshot.

Syntax
PRL_HANDLE PrlVm_CreateSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sName,
    PRL_CONST_STR sDescription
);
File

PrlApi.h

Parameters

sName
Snapshot name.
sDescription
Snapshot description.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_CreateUnattendedFloppy Function

PrlVm_CreateUnattendedFloppy Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Creates a floppy disk image in the virtual machine home directory for unattended Windows installation.

Syntax
PRL_HANDLE PrlVm_CreateUnattendedFloppy(
    PRL_HANDLE hVm,
    PRL_GUEST_DISTRO_VERSION_ENUM nGuestDistroType,
    PRL_CONST_STR sUsername,
    PRL_CONST_STR sCompanyName,
    PRL_CONST_STR sSerialKey
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nGuestDistroType
Windows version.
sUsername
User name.
sCompanyName
Company name.
sSerialKey
Serial number.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The following steps describe how to prepare a virtual machine for unattended Windows installation:

  1. Create a virtual machine. The machine should have all the necessary devices, like hard drive and CD drive.
  2. Execute the PrlVm_CreateUnattendedFloppy function to create a floppy disk image.
  3. Insert Windows installation CD-ROM into the drive (or mount a disk image).
  4. Start the virtual machine. The machine will boot from the CD.
  5. Perform unattended Windows installation as usual.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Delete Function

PrlVm_Delete Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Deletes the specified virtual machine from the host.

Syntax
PRL_HANDLE PrlVm_Delete(
    PRL_HANDLE hVm,
    PRL_HANDLE hDevicesList
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hDevicesList
A handle of type PHT_STRINGS_LIST containing a list of files (devices) to be deleted from the virtual machine directory. If the list is empty or the parameter contains a null pointer, the entire virtual machine directory will be deleted from the host. If the list contains one or more items, only the specified files will be delete (the rest of the virtual machines files will remain on the host in the original directory).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function un-registers the machine from the Parallels Service and deletes all its files. This operation cannot be undone. The specified machine must be registered with the Parallels Service. To un-register a machine from the Parallels Service without deleting any of its file, use the PrlVm_Unreg function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_DeleteSnapshot Function

PrlVm_DeleteSnapshot Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Deleted the specified virtual machine snapshot.

Syntax
PRL_HANDLE PrlVm_DeleteSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid,
    PRL_BOOL bChild
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sSnapshotUuid
Snapshot ID. To obtain a snapshot ID use the PrlVm_GetSnapshotsTree function.
bChild
Specifies whether snapshots derived from the specified snapshot should be deleted or not. True - delete child snapshots. False - don't delete child snapshots.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_DropSuspendedState Function

PrlVm_DropSuspendedState Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Resets a suspended virtual machine.

Syntax
PRL_HANDLE PrlVm_DropSuspendedState(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When a virtual machine is suspended with the PrlVm_Suspend call, the current state of the virtual machine processes is saved into a temporary file on the hard disk, and the virtual machine is stopped. When a suspended virtual machine is resumed with the PrlVm_Resume call, the data in the temp file is used to restore the state of the virtual machine processes. The PrlVm_DropSuspendedState function resets a suspended virtual machine by deleting the temp file from the drive Once the function successfully completes, the virtual machine can no longer be resumed with the PrlVm_Resume call. It still can be started normally, however.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GenerateVmDevFilename Function

PrlVm_GenerateVmDevFilename Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Automatically generates a name for a virtual device which will be unique within a home directory of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_GenerateVmDevFilename(
    PRL_HANDLE hVm,
    PRL_CONST_STR sFilenamePrefix,
    PRL_CONST_STR sFilenameSuffix,
    PRL_CONST_STR sIndexDelimiter
);
File

PrlApi.h

Parameters

sFilenamePrefix
A prefix to add to the name. Pass a null pointer to use a default value: "tmpfile". The name will be generated by adding a number to the prefix (e.g. tmpfile1, tmpfile2, tmpfile3, etc.)
sFilenameSuffix
A suffix to add to the name. Pass a null pointer for no suffix.
sIndexDelimiter
A character(s) that will be inserted between the prefix and the index (e.g. tmpfile_1, tmpfile_2, tmpfile_3, etc). You can specify a null pointer or an empty string if you don't want to insert any extra characters there.
hVM
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the home directory information is missing in the specified virtual machine object. If this is a new virtual machine, try updating the local object by calling the PrlVm_RefreshConfig or PrlSrv_GetVmList function.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetConfig Function

PrlVm_GetConfig Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Obtains a handle of type PHT_VM_CONFIGURATION.

Syntax
PRL_RESULT PrlVm_GetConfig(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phVmCfg
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
phVmCfg
[out] A pointer to a variable that receives the handle of type PHT_VM_CONFIGURATION.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetProblemReport Function

PrlVm_GetProblemReport Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

The PrlVm_GetProblemReport function obtains a problem report on abnormal virtual machine termination.

Syntax
PRL_HANDLE PrlVm_GetProblemReport(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

If a virtual machine stops running abnormally, you call this function to obtain a report from the Parallels Service describing the problem.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParamAsString function to obtain a string containing the report.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetQuestions Function

PrlVm_GetQuestions Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

The PrlVm_GetQuestions function allows to synchronously receive questions from a Parallels Service.

Syntax
PRL_RESULT PrlVm_GetQuestions(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR pQuestionsList
);
File

PrlApi.h

Parameters

pQuestionsList
[out] A handle of type PHT_HANDLES_LIST containing a list of available questions.
handle
A handle of type PHT_VIRTUAL_MACHINE.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (NULL) pointer to the buffer for storing result was passed. PRL_ERR_SUCCESS - operation completed successfully.

Remarks

It can be used as an alternative to asynchronous question processing through events. You can use this function at any time to check if a question is awaiting the client response on the Parallels Service side.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetSnapshotsTree Function

PrlVm_GetSnapshotsTree Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Retrieves snapshot information for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_GetSnapshotsTree(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Snapshot information is returned as an XML file containing the snapshot tree. Some of the important XML elements are:

<SavedStateItem> - root element of a branch containing information about an individual snapshot. The element has an attribute "guid" containing the snapshot ID. The ID is required when performing other operations on a snapshot.

<Name> - contains a snapshot name.

<DateTime> - the snapshot creation date and time.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get a snapshot tree from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamAsString function to obtain a string value containing the snapshots tree XML data.

Please note that no parser is provided to traverse the returned XML. To use this functionality, you will have to parse the returned XML yourself. This function will be replaced in the future releases of the Parallels SDK.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetState Function

PrlVm_GetState Function
PrlApi.h PHT_VIRTUAL_MACHINE Example Send Feedback

Obtains a handle of type PHT_VM_INFO containing the specified virtual machine state and access rights information.

Syntax
PRL_HANDLE PrlVm_GetState(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain the PHT_VM_INFO handle.

Example
hJob =
PrlVm_GetState( hVm );
PrlJob_Wait( hJob, 10000 );
PrlJob_GetResult( hJob, &hJobResult );
PrlHandle_Free( hJob );

// Get the handle from job
PRL_HANDLE hHandle;
PrlResult_GetParam( hJobResult, &hHandle );
Links
PrlApi.h, PHT_VIRTUAL_MACHINE, Example


PrlVm_GetStatistics Function

PrlVm_GetStatistics Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Obtains a handle of type PHT_SYSTEM_STATISTICS containing the virtual machine resource usage information, including CPU(s), memory, disk drives, processes, user session, system uptime, network packets, etc.

Syntax
PRL_HANDLE PrlVm_GetStatistics(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.

Use the PrlResult_GetParam function to obtain a handle of type PHT_SYSTEM_STATISTICS containing the resource usage data.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetSuspendedScreen Function

PrlVm_GetSuspendedScreen Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Retrieves the virtual machine screen state before it was suspending.

Syntax
PRL_HANDLE PrlVm_GetSuspendedScreen(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_VM_IS_NOT_SUSPENDED - the virtual machine is not in the suspended state.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_GetToolsState Function

PrlVm_GetToolsState Function
PrlApi.h PHT_VIRTUAL_MACHINE Example Send Feedback

Obtains a handle of type PHT_VM_TOOLS_INFO containing information about the state of the Parallels Tools package in a virtual machine.

Syntax
PRL_HANDLE PrlVm_GetToolsState(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Example

The following example illustrates how to obtain a handle of type PHT_VM_TOOLS_INFO. The hVm variable is a handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

PRL_HANDLE hJob, hResult, hVmToolsInfo;

hJob = PrlVm_GetToolsState( hVm );
PrlJob_Wait( hJob, 1000 );

PrlJob_GetResult( hJob, &hResult );
PrlHandle_Free( hJob );

PrlResult_GetParam( hJobResult, &hVmToolsInfo );
PrlHandle_Free( hJobResult );
Links
PrlApi.h, PHT_VIRTUAL_MACHINE, Example


PrlVm_InitiateDevStateNotifications Function

PrlVm_InitiateDevStateNotifications Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

This method lets to initiate sending notifications about devices states by VM.

Syntax
PRL_HANDLE PrlVm_InitiateDevStateNotifications(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with the Parallels Service connection or non identified VM object

Remarks

Those notifications have to be same as notifications after changing a device state

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_InstallTools Function

PrlVm_InstallTools Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Begin the Parallels Tools installation process.

Syntax
PRL_HANDLE PrlVm_InstallTools(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_HANDLE to job that describing async operation result (PRL_INVALID_HANDLE means not enough memory to instantiate async job represents object handle). Operation return code can be extracted with @ref PrlJob_GetRetCode() call. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle was passed PRL_ERR_UNINITIALIZED - unexpected error: uninitialized with Parallels Service connection or non identified VM object

Remarks

The machine must be registered with the Parallels Service to perform this operation.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_InstallUtility Function

PrlVm_InstallUtility Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Installs a specified utility in a virtual machine.

Syntax
PRL_HANDLE PrlVm_InstallUtility(
    PRL_HANDLE hVm,
    PRL_CONST_STR strId
);
File

PrlApi.h

Parameters

strId
A string identifying the utility to install.
hServer
A handle of type PHT_VIRTUAL_MACHINE identifying the Parallels Service.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This functions is a part of the Parallels Tools functionality.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_LoginInGuest Function

PrlVm_LoginInGuest Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Creates a new console session or binds to an existing GUI session in a virtual machine.

Syntax
PRL_HANDLE PrlVm_LoginInGuest(
    PRL_HANDLE hVm,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sUserPassword,
    PRL_UINT32 nFlags
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sUserName
User name. This parameter must contain a valid guest OS user name or one of the following constants:

PRL_CURRENT_GUEST_OS_SESSION -- binds to an existing GUI session in a virtual machine.

PRL_PRIVILEGED_GUEST_OS_SESSION -- binds to an existing session under which Parallels Service is running. This session belongs to a privileged user (e.g. root on Linux or LocalSystem on Windows), so it can be used to perform administrative tasks.

Note that in order to use the constants above, the current user must be an administrator of the host OS or be the owner of the target virtual machine.

sUserPassword
User password. If the sUserName parameter contains one of the constants (see above) then this parameter can contain an empty string.
nFlags
A bitset of flags. Must be 0 in the current API implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Note: To use this function, Parallels Tools must be installed in the target virtual machine.

This function is used when you want to run a program in a virtual machine or perform an administrative task that require native guest operating system login. Depending on the type of the program that you would like to run, the login must be performed using one of the following methods:

  • To run a GUI application, call this function passing the PRL_CURRENT_GUEST_OS_SESSION constant in the sUserName parameter. The reason is the function can only bind to an existing GUI session and cannot create a new one. Prior to calling this function, a GUI session must already be open in a virtual machine (the machine must be running and a user must be logged in to it). The user password parameter can be blank.
  • To run a console program, the sUserName parameter can contain the PRL_PRIVILEGED_GUEST_OS_SESSION constant or a valid user name and password. When using PRL_PRIVILEGED_GUEST_OS_SESSION, the function will bind to an existing session under which Parallels Service is running. This session belongs to a privileged user (e.g. root on Linux or LocalSystem on Windows), so it can be used to perform administrative tasks. When specifying a user name and password, a new session will be created in the virtual machine.

On successful login, the function obtains a handle of type PHT_VM_GUEST_SESSION (see below for the instructions on how to get the handle from the PHT_JOB object). You can use the handle functions to run programs in a virtual machine and to perform other supported operations. See the PHT_VM_GUEST_SESSION handle description for a complete list of functions.

When the session is no longer needed, it should be closed using the PrlVmGuest_Logout function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the PHT_VM_GUEST_SESSION handle from the returned PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain the PHT_RESULT handle.
  2. Use the PrlResult_GetParam to obtain the PHT_VM_GUEST_SESSION handle.
See Also

PrlVmGuest_RunProgram

PrlVmGuest_Logout

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_Migrate Function

PrlVm_Migrate Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_Migrate(
    PRL_HANDLE hVm,
    PRL_HANDLE hTargetServer,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hTargetServer
A handle of type PHT_SERVER identifying the target Parallels Service.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVM_COLD_MIGRATION, PVM_WARM_MIGRATION, PVM_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_MigrateCancel Function

PrlVm_MigrateCancel Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Cancels the migration operation that was started with PrlVm_Migrate or PrlVm_MigrateEx.

Syntax
PRL_HANDLE PrlVm_MigrateCancel(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_MigrateEx Function

PrlVm_MigrateEx Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Migrates an existing virtual machine to another host.

Syntax
PRL_HANDLE PrlVm_MigrateEx(
    PRL_HANDLE hVm,
    PRL_CONST_STR target_host,
    PRL_UINT32 target_port,
    PRL_CONST_STR target_session_id,
    PRL_CONST_STR target_home_path,
    PRL_UINT32 migration_flags,
    PRL_UINT32 reserved_flags,
    PRL_BOOL force_operation
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
target_host
The name of the target host machine.
target_port
The port number on the target host.
target_session_id
The target Parallels Service session ID. This ID can be retrieved with PrlLoginResponse_GetSessionUuid from the response of the login request.
target_home_path
Target VM home path (i.e. where VM will be placed on target system). Empty string accounts as default VM directory path
migration_flags
Flags that specify migration type and etc. Acceptable flags: PVM_COLD_MIGRATION, PVM_WARM_MIGRATION, PVM_HOT_MIGRATION, PVMSL_LOW_SECURITY, PVMSL_NORMAL_SECURITY, PVMSL_HIGH_SECURITY
reserved_flags
Reserved parameter for further purposes
force_operation
Specifies to process VM migration action without asking any additional questions from the Parallels Service side (non-interactive clients should use this option).

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This is an extended version of PrlVm_Migrate function that allows to initiate VM migration process without active connection to target Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Pause Function

PrlVm_Pause Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Pauses the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Pause(
    PRL_HANDLE hVm,
    PRL_BOOL bAcpi
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bAcpi
Specifies if ACPI should be used to pause the virtual machine. If set to PRL_FALSE, ACPI will not be used. In this case, all processes of the virtual machine sill be simply be stopped. If the parameter is set to PRL_TRUE, ACPI will be used to pause the machine. With ACPI, the machine will be paused using a method supported by the guest operating system (sleep, hibernate, etc.). The actual method used will depend on the type and configuration of the guest OS.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_Resume

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_RefreshConfig Function

PrlVm_RefreshConfig Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

The PrlVm_RefreshConfig function updates the configuration information contained in the specified virtual machine object (handle).

Syntax
PRL_HANDLE PrlVm_RefreshConfig(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine. This is the object that will be updated.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When you obtain a virtual machine handle that refers to an existing virtual machine, it is populated with the virtual machine configuration data. When working with configuration data, you always work with this local copy. Naturally, the configuration can change on the Parallels Service side at any time. The PrlVm_RefreshConfig function allows to re-retrieve the configuration data from the Parallels Service. The function can be used when an event of type PET_DSP_EVT_VM_CONFIG_CHANGED is triggered (the event notifies the client that the virtual machine configuration has been modified), or on unsuccessful PrlVm_Commit operation, or at any time you want to synchronize your local virtual machine object with the Parallels Service. Please note that the function replaces the local data, so if you made any modification to it, the changes will be lost.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Reg Function

PrlVm_Reg Function
PrlApi.h PHT_VIRTUAL_MACHINE Example Send Feedback

Creates a new virtual machine and registers it with the Parallels Service.

Syntax
PRL_HANDLE PrlVm_Reg(
    PRL_HANDLE hVm,
    PRL_CONST_STR sVmParentPath,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sVmParentPath
Optional. Name and path of the parent directory where the virtual machine directory should be created. If this parameter is omitted (null pointer or empty string is passed), the new virtual machine directory will be created in the default directory for this Parallels Service.
bNonInteractiveMode
Specifies if a non-interactive mode should be used. If set to PRL_TRUE, non-interactive mode will be used. If set to PRL_FALSE, interactive mode will be used. In interactive mode, the Parallels Service may ask client questions. Once a question is asked, the client must create and send a valid answer to the Parallels Service in order for the operation to continue.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The steps involved in creating a typical virtual machine are:

  1. Obtain a handle to a new virtual machine object using the PrlSrv_CreateVm function.
  2. Populate the object with the desired configuration data.
  3. Choose a name for the virtual machine and set it using the PrlVmCfg_SetName function.
  4. Create and register the new machine with a Parallels Service using the PrlVm_Reg function. This step will create the necessary virtual machine files on the host and will add the machine to the Parallels Service VM registry. The directory containing the virtual machine files will have the same name as the name you've chosen for your virtual machine. The directory will be created in the default VM root directory for this Parallels Service. If you would like to create the virtual machine directory in a different location, you may specify the desired parent directory name and path.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Example

The following example shows how to create a new virtual machine. The sample assumes that the client program has already obtained a server object handle (hServer) and performed the Parallels Service login operation.

PRL_HANDLE hVm;
PRL_HANDLE hResult;
PRL_RESULT nJobRetCode;
PRL_RESULT ret;

// Obtain a new virtual machine handle.
ret = PrlSrv_CreateVm(hServer, &hVm);
if (PRL_FAILED(ret))
{
    // Error handling goes here...
    return ret;
}

// Get the host config info.
hJob = PrlSrv_GetSrvConfig(hServer);
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlSrv_GetSrvConfig.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Get a handle to the object containing the result of PrlSrv_GetSrvConfig,
// and then get a handle to the server configuration object from it.
ret = PrlJob_GetResult(hJob, &hResult);
PRL_HANDLE hSrvCfg;
PrlResult_GetParam(hResult, &hSrvCfg);

// Delete the job and the result handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hResult);

// Now that we have the host machine configuration data,
// we can set the default configuration for the new virtual machine.
ret = PrlVm_SetDefaultConfig(
                hVm, // VM handle.
                hSrvCfg, // Host config data.
                PVS_GUEST_TYPE_WINDOWS, // Target OS type.
                PVS_GUEST_VER_WIN_2003, // Target OS version.
                PRL_TRUE); // Create and connect devices.

if (PRL_FAILED(ret))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(ret));
    PrlHandle_Free(hSrvCfg);
    PrlHandle_Free(hVm);
    return ret;
}

PrlHandle_Free(hSrvCfg);

// Set the virtual machine name.
ret = PrlVm_SetName(hVm, "My Windows Server 2003");

// The following two calls demonstrate how to modify
// some of the default values of the virtual machine configuration.
// These calls are optional. You may remove them to use the default values.

// Set the RAM size for the machine to 256 MB.
ret = PrlVm_SetRamSize(hVm, 256);

// Set the virtual hard disk size to 20 GB.
// First, get the handle to the hard disk object using the
// PrlVm_GetHardDisk function. The index of 0 is used
// because the default configuration has just one virtual hard disk.
// After that, use the handle to set the disk size to the desired value.

PRL_HANDLE hHDD;
ret = PrlVm_GetHardDisk(hVm, 0, &hHDD);
ret = PrlVmDevHd_SetDiskSize(hHDD, 20000);

// Create and register the machine with the Parallels Service.
hJob = PrlVm_Reg(hVm, // VM handle.
                 "", // VM root directory (using default).
                 PRL_TRUE); // Using non-interactive mode.

// Wait for the operation to complete.
ret = PrlJob_Wait(hJob, 10000);

// Check the return code of PrlVm_Reg.
PrlJob_GetRetCode(hJob, &nJobRetCode);
if (PRL_FAILED(nJobRetCode))
{
    fprintf(stderr, "Error: %s\n", PRL_RESULT_TO_STRING(nJobRetCode));
    PrlHandle_Free(hJob);
    PrlHandle_Free(hVm);
    return nJobRetCode;
}

// Delete handles.
PrlHandle_Free(hJob);
PrlHandle_Free(hVm);
Links
PrlApi.h, PHT_VIRTUAL_MACHINE, Example


PrlVm_RegEventHandler Function

PrlVm_RegEventHandler Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Registers an event handler (callback function) with the virtual machine.

Syntax
PRL_RESULT PrlVm_RegEventHandler(
    PRL_HANDLE hVm,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
handler
A pointer to the callback function that will handle events.
userData
A pointer to a user data that will be passed to the callback function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To use the callback functionality, you first have to implement a callback function. The callback function must have a specific signature (see PRL_METHOD_PTR for the prototype). After you register an event handler with a virtual machine, the callback function will be called every time an event is generated in the machine.

You can also register an event handler with a Parallels Service (instead of a particular virtual machine) using the PrlSrv_RegEventHandler function. If you register the event handler with the Parallels Service, you will be able to receive events from all of the virtual machines registered with that Parallels Service. For more information on events and asynchronous functions, see the Parallels Virtualization SDK Programmer's Guide.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Reset Function

PrlVm_Reset Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Resets the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Reset(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This function is an equivalent of PrlVm_Stop and PrlVm_Start functions executed in succession. The stop operation will NOT use ACPI, so the entire reset operation will resemble the "Reset" button pressed on a physical box.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Restart Function

PrlVm_Restart Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Restarts the operating system of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Restart(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or start mode of virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Restore Function

PrlVm_Restore Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Restores the registered virtual machine.

Syntax
PRL_HANDLE PrlVm_Restore(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation, including the return code and a handle of type PHT_VIRTUAL_MACHINE containing information about the virtual machine that was registered.

PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

To get the results from the PHT_JOB object:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_VIRTUAL_MACHINE.
Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Resume Function

PrlVm_Resume Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Resumes a virtual machine that was previously suspended with the PrlVm_Suspend call.

Syntax
PRL_HANDLE PrlVm_Resume(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_RunCompressor Function

PrlVm_RunCompressor Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Initiates the Compressor process.

Syntax
PRL_HANDLE PrlVm_RunCompressor(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The virtual machine must be registered with Parallels Service.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_SetConfig Function

PrlVm_SetConfig Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

The PrlVm_SetConfig is reserved and does nothing.

Syntax
PRL_RESULT PrlVm_SetConfig(
    PRL_HANDLE hVm,
    PRL_HANDLE hVmCfg
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Start Function

PrlVm_Start Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Start the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Start(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_StartEx Function

PrlVm_StartEx Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Starts the specified virtual machine using the specified mode (see the PRL_VM_START_MODE enumeration).

Syntax
PRL_HANDLE PrlVm_StartEx(
    PRL_HANDLE hVm,
    PRL_UINT32 nStartMode,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nStartMode
Virtual machine start mode.
nReserved
This is a reserved parameter.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Use this function instead of the PrlVm_Start function to start the virtual machine in a normal or safe mode. Other modes may be added in the future.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or start mode of virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_StartVncServer Function

PrlVm_StartVncServer Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Starts a VNC server for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_StartVncServer(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nReserved
Reserved parameter for future purposes. Must contain 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer for user name was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StopVncServer

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_Stop Function

PrlVm_Stop Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Stop the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Stop(
    PRL_HANDLE hVm,
    PRL_BOOL bAcpi
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
bAcpi
Specifies if ACPI (Advanced Configuration and Power Interface) should be used to stop the machine. If ACPI is used, the machine will be properly shut down (subject to ACPI support in the guest operating system). If ACPI is not used, the machine will be simply "unplugged".

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_StopVncServer Function

PrlVm_StopVncServer Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Stops the VNC server that was previously started for a virtual machine.

Syntax
PRL_HANDLE PrlVm_StopVncServer(
    PRL_HANDLE hVm,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nReserved
Reserved parameter for future purposes. Must be 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer for user name was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StartVncServer

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_SubscribeToGuestStatistics Function

PrlVm_SubscribeToGuestStatistics Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Subscribes to receive the specified virtual machine performance statistics on a periodic basis.

Syntax
PRL_HANDLE PrlVm_SubscribeToGuestStatistics(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To obtain statistics, an event handler (callback function) is required. Within the event handler, first check the type of event. Events of type PET_DSP_EVT_VM_STATISTICS_UPDATED indicate an event containing performance data. To access the statistics handle (a handle of type PHT_SYSTEM_STATISTICS), first extract the event parameter using PrlEvent_GetParam, then convert the result (which will be a handle to an object of type PHT_EVENT_PARAMETER) to a handle using PrlEvtPrm_ToHandle. The functions that operate on PHT_SYSTEM_STATISTICS references can then be used to obtain statistics data.

For the event handler to be called, it is necessary to register it with PrlVm_RegEventHandler. When statistics data is no longer required, unsubscribe from statistics events using PrlVm_UnsubscribeFromGuestStatistics. When events are no longer required, unregister the event handler using PrlVm_UnregEventHandler.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlSrv_SubscribeToHostStatistics

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_Suspend Function

PrlVm_Suspend Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Suspends the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_Suspend(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When a running virtual machine is suspended using this call, the states of the virtual machine processes are saved into a file on the hard disk, and then the machine is stopped. To resume the machine, use the PrlVm_Resume function call. If after suspending a machine you don't want to resume it but would like to return to the previous state, you may call the PrlVm_DropSuspendedState function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_SwitchToSnapshot Function

PrlVm_SwitchToSnapshot Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Reverts the specified virtual machine to the specified snapshot.

Syntax
PRL_HANDLE PrlVm_SwitchToSnapshot(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid
);
File

PrlApi.h

Parameters

sSnapshotUuid
The ID of a snapshot to revert to. To obtain a list of the available snapshots and their IDs, use the PrlVm_GetSnapshotsTree function.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_TisGetIdentifiers Function

PrlVm_TisGetIdentifiers Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Retrieves a list of identifiers from the Tools Information Service database.

Syntax
PRL_RESULT PrlVm_TisGetIdentifiers(
    PRL_HANDLE hVm,
    PRL_HANDLE_PTR phUidsList
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
phUidsList
[out] A handle of type PHT_STRINGS_LIST containing the identifiers.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_STRINGS_LIST object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_TisGetRecord

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_TisGetRecord Function

PrlVm_TisGetRecord Function
PrlApi.h PHT_VIRTUAL_MACHINE See Also Send Feedback

Obtains a handle of type PHT_TIS_RECORD containing a record from the Tools Information Service database.

Syntax
PRL_RESULT PrlVm_TisGetRecord(
    PRL_HANDLE hVm,
    PRL_CONST_STR sUid,
    PRL_HANDLE_PTR phRecord
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
sUid
TIS database record identifier. The list of identifiers can be retrieved from the TIS database with PrlVm_TisGetIdentifiers.
phRecord
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_TIS_RECORD object.

PRL_ERR_TIS_INVALID_UID - specified record not found.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_TisGetIdentifiers

Links
PrlApi.h, PHT_VIRTUAL_MACHINE, See Also


PrlVm_ToolsSendShutdown Function

PrlVm_ToolsSendShutdown Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Initiates graceful shutdown of the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_ToolsSendShutdown(
    PRL_HANDLE hVm,
    PRL_GRACEFUL_SHUTDOWN_KIND kind
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
kind
Specifies the type of the shutdown.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_Unreg Function

PrlVm_Unreg Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Unregisters the specified virtual machine from the Parallels Service.

Syntax
PRL_HANDLE PrlVm_Unreg(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

This call removes the virtual machine from the Parallels Service registry, but does not delete the virtual machine files from the hard drive. You can re-register a machine with the Parallels Service at any time using the PrlSrv_RegisterVm function call.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_UnregEventHandler Function

PrlVm_UnregEventHandler Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Unregisters an event handler (callback function) that was previously registered using the PrlVm_RegEventHandler function.

Syntax
PRL_RESULT PrlVm_UnregEventHandler(
    PRL_HANDLE hVm,
    PRL_EVENT_HANDLER_PTR handler,
    PRL_VOID_PTR userData
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
handler
A pointer to the callback function. This must be the same pointer that was passed to the PrlVm_RegEventHandler when the event handler was registered with the virtual machine.
userData
A pointer to the user data. This must also be the same pointer that was passed to the PrlVm_RegEventHandler when the event handler was registered with the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when you no longer want to receive event notifications from the virtual machine. The values of the handler and userData parameter constitute a unique pair which will be used to identify the event handler that will be unregistered. Make sure that you supply the same values as the ones you used when you registered the handler.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_UnsubscribeFromGuestStatistics Function

PrlVm_UnsubscribeFromGuestStatistics Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Cancels the performance statistics subscription that was previously initiated using the PrlVm_SubscribeToGuestStatistics function.

Syntax
PRL_HANDLE PrlVm_UnsubscribeFromGuestStatistics(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_UnsubscribeFromPerfStats Function

PrlVm_UnsubscribeFromPerfStats Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Cancels the Parallels Service performance statistics subscription that was started using the PrlVm_SubscribeToPerfStats function.

Syntax
PRL_HANDLE PrlVm_UnsubscribeFromPerfStats(
    PRL_HANDLE hVm
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_UpdateSecurity Function

PrlVm_UpdateSecurity Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Updates access level for the specified virtual machine.

Syntax
PRL_HANDLE PrlVm_UpdateSecurity(
    PRL_HANDLE hVm,
    PRL_HANDLE hAccessRights
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
hAccessRights
A handle of type PHT_ACCESS_RIGHTS containing the virtual machine access level information.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

By default, only the owner of a virtual machine has full access to it. All other users are completely unaware of the machine (it will not even appear in the list of the available virtual machines for them). The owner of the virtual machine can change that by setting one of the predefined access levels for the machine. Depending on the level of access set by the owner, other users will be able to see the machine and to perform tasks on it.

To update the access level, obtain a handle of type PHT_ACCESS_RIGHTS, set the desired level using the PrlAcl_SetAccessForOthers function, and then call this function to apply the changes to the virtual machine. The caller must be the owner of the machine to perform this operation. The PrlAcl_IsCurrentSessionOwner function can be used to determine if the current user is the owner of the virtual machine.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_ACCESS_DENIED - current user is not the owner of the target virtual machine.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_UpdateSnapshotData Function

PrlVm_UpdateSnapshotData Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Modifies the specified virtual machine snapshot name and description.

Syntax
PRL_HANDLE PrlVm_UpdateSnapshotData(
    PRL_HANDLE hVm,
    PRL_CONST_STR sSnapshotUuid,
    PRL_CONST_STR sNewName,
    PRL_CONST_STR sNewDescription
);
File

PrlApi.h

Parameters

sSnapshotUuid
The ID of the snapshot to modify. To obtain a list of the available snapshots and their ID's, use the PrlVm_GetSnapshotsTree function.
sNewName
New snapshot name.
sNewDescription
New snapshot description.
handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible value are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVm_ValidateConfig Function

PrlVm_ValidateConfig Function
PrlApi.h PHT_VIRTUAL_MACHINE Send Feedback

Validates the specified section of a virtual machine configuration.

Syntax
PRL_HANDLE PrlVm_ValidateConfig(
    PRL_HANDLE hVm,
    PRL_VM_CONFIG_SECTIONS nSection
);
File

PrlApi.h

Parameters

hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
nSection
The section in the virtual machine configuration to verify.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

When creating or modifying a virtual machine configuration, this function can be used to verify that a particular section of the configuration is valid. Use this function before sending the virtual machine object containing the configuration information to the Parallels Service. If the configuration is valid, you can commit the changes. If the configuration is not valid, make the necessary modifications and retry.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or the specified configuration section doesn't exist.

PRL_ERR_PARSE_VM_CONFIG - error parsing configuration data.

PRL_ERR_VMCONF_VALIDATION_FAILED - invalid configuration; the description of the problem can be retrieved from from the PHT_JOB object (see below).

PRL_ERR_SUCCESS - specified configuration is valid.

In the event of validation failure, the PHT_JOB object will contain the description of the problem. To get the description:

  1. Use the PrlJob_GetResult function to obtain a handle to the PHT_RESULT object.
  2. Use the PrlResult_GetParamsCount function to obtain the result count.
  3. Use the PrlResult_GetParamByIndex to obtain a handle of type PHT_EVENT (if there are multiple results, call the function for each one).
  4. Use the PrlEvent_GetErrString function to get the validation error description.
Links
PrlApi.h, PHT_VIRTUAL_MACHINE


PrlVmCfg_AddDefaultDevice Function

PrlVmCfg_AddDefaultDevice Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

The PrlVmCfg_AddDefaultDevice function automates the task of setting devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_AddDefaultDevice(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_DEVICE_TYPE deviceType
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG containing the host machine configuration information. If this parameter is set to PRL_INVALID_HANDLE, the device of the specified type will be configured as pure virtual (i.e. it will not be mapped to a physical device on the host).
deviceType
The type of the device to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OPERATION_FAILED - unable to set a device of the specified type.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating or modifying a virtual machine configuration, one must choose if a device of a particular type will be a pure virtual device or if it will be mapped to a physical device on the host. To make a device pure virtual, set the hSrvConfig parameter value to PRL_INVALID_HANDLE. To map a virtual device to a physical device, obtain an object of type PHT_SERVER_CONFIG and pass it to the function using the hSrvConfig parameter. If multiple physical devices of the specified type exist on the host, the destination physical device will be chosen randomly by the function.

The virtual devices that can be mapped to physical devices include floppy disk drives, CD drives, serial and parallel ports, and sound devices. The devices that can exist only as pure virtual include hard disk drives, network adapters, and USB devices. To determine if a device of particular type must be added to a virtual machine, use the PrlVmCfg_IsDefaultDeviceNeeded function.

Before calling this function, you must execute the PrlVm_BeginEdit function. After the PrlVmCfg_AddDefaultDevice function returns, you must call the PrlVm_Commit to save the changes in the virtual machine configuration.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_CreateBootDev Function

PrlVmCfg_CreateBootDev Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Creates a new handle of type PHT_BOOT_DEVICE and adds it to the specified virtual machine boot device list.

Syntax
PRL_RESULT PrlVmCfg_CreateBootDev(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmBootDev
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmBootDev
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the caller to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_CreateScrRes Function

PrlVmCfg_CreateScrRes Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Creates a new handle of type PHT_SCREEN_RESOLUTION and adds it to the specified virtual machine resolution list.

Syntax
PRL_RESULT PrlVmCfg_CreateScrRes(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmScrRes
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmScrRes
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the caller to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_CreateShare Function

PrlVmCfg_CreateShare Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Creates a new handle of type PHT_SHARE and adds it to the specified virtual machine list of shares.

Syntax
PRL_RESULT PrlVmCfg_CreateShare(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmShare
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmShare
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the caller to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_CreateVmDev Function

PrlVmCfg_CreateVmDev Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Creates a new virtual device handle of the specified type.

Syntax
PRL_RESULT PrlVmCfg_CreateVmDev(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE nDeviceType,
    PRL_HANDLE_PTR phVmDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nDeviceType
The type of the device to create a handle for.
phVmDevice
[out] A pointer to a variable that receives the new handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The names of the virtual device handles are prefixed with PHT_VIRTUAL_DEV_ (you may search this documentation for their definitions or see the _PRL_HANDLE_TYPE enumeration for a complete list of handles). It is the responsibility of the user to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetAccessRights Function

PrlVmCfg_GetAccessRights Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_ACCESS_RIGHTS.

Syntax
PRL_RESULT PrlVmCfg_GetAccessRights(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phVmAcl
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phVmAcl
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a handle.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetAppInDockMode Function

PrlVmCfg_GetAppInDockMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the current dock mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetAppInDockMode(
    PRL_HANDLE hVmCfg,
    PRL_APP_IN_DOCK_MODE_PTR pnVmAppInDockMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAppInDockMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoStart Function

PrlVmCfg_GetAutoStart Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if the specified virtual machine is set to start automatically on Parallels Service startup.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStart(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTART_OPTION_PTR pnVmAutoStart
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStart
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoStartDelay Function

PrlVmCfg_GetAutoStartDelay Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the time delay used during the virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStartDelay(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmAutoStartDelay
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStartDelay
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetAutoStop Function

PrlVmCfg_GetAutoStop Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the mode of the automatic shutdown for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetAutoStop(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTOP_OPTION_PTR pnVmAutoStop
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmAutoStop
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetBackgroundPriority Function

PrlVmCfg_GetBackgroundPriority Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the specified virtual machine background process priority type.

Syntax
PRL_RESULT PrlVmCfg_GetBackgroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY_PTR pnVmBackgroundPriority
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmBackgroundPriority
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetBootDev Function

PrlVmCfg_GetBootDev Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_BOOT_DEVICE containing information about a specified device from the virtual machine boot device priority list.

Syntax
PRL_RESULT PrlVmCfg_GetBootDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nBootDevIndex,
    PRL_HANDLE_PTR phVmBootDev
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nBootDevIndex
An index identifying the device (beginning with 0). To determine the number of the devices in the boot device list, use the PrlVmCfg_GetBootDevCount function.
phVmBootDev
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is the responsibility of the called to free the handle when it is no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetBootDevCount Function

PrlVmCfg_GetBootDevCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of devices in the virtual machine boot device priority list.

Syntax
PRL_RESULT PrlVmCfg_GetBootDevCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnBootDevCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnBootDevCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetConfigValidity Function

PrlVmCfg_GetConfigValidity Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

The PrlVmCfg_GetConfigValidity function returns an error code.

Syntax
PRL_RESULT PrlVmCfg_GetConfigValidity(
    PRL_HANDLE hVmCfg,
    PRL_RESULT_PTR pnErrCode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnErrCode
[out] A pointer to a variable that receives the error code as PRL_RESULT.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The error code indicates the status of the config: config doesn't exist, parsing error, config can be restored and others errors.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuAccelLevel Function

PrlVmCfg_GetCpuAccelLevel Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the virtual machine CPU acceleration level.

Syntax
PRL_RESULT PrlVmCfg_GetCpuAccelLevel(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACCELERATION_LEVEL_PTR pnVmCpuAccelLevel
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuAccelLevel
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuCount Function

PrlVmCfg_GetCpuCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of CPUs in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetCpuCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmCpuCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuMode Function

PrlVmCfg_GetCpuMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the specified virtual machine CPU mode (32 bit or 64 bit).

Syntax
PRL_RESULT PrlVmCfg_GetCpuMode(
    PRL_HANDLE hVmCfg,
    PRL_CPU_MODE_PTR pnVmCpuMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetCpuUnits Function

PrlVmCfg_GetCpuUnits Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Determines the number of CPU units allocated to a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetCpuUnits(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR nVmCpuUnits
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmCpuUnits
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine object does not contain the necessary data.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetCpuUnits

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetCustomProperty Function

PrlVmCfg_GetCustomProperty Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Returns the virtual machine custom property information.

Syntax
PRL_RESULT PrlVmCfg_GetCustomProperty(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmCustomProperty,
    PRL_UINT32_PTR pnVmCustomPropertyBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmCustomProperty
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The custom property information is stored in CDATA format.
pnVmCustomPropertyBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is too small. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If you have some custom data which relates to a virtual machine in some way, you can save it in the virtual machine configuration for future retrieval. This can be any data that your client application requires. The data is stored in CDATA format.

See Also

PrlVmCfg_SetCustomProperty

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDefaultHddSize Function

PrlVmCfg_GetDefaultHddSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

The PrlVmCfg_GetDefaultHddSize function returns the default hard disk size for to the specified OS type and version.

Syntax
PRL_RESULT PrlVmCfg_GetDefaultHddSize(
    PRL_UINT32 guestOsVersion,
    PRL_UINT32_PTR pnHddSize
);
File

PrlApi.h

Parameters

guestOsVersion
Operating system version. See PrlOses.h for version definitions.
pnHddSize
[out] A pointer to a variable that receives the hard disk size, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine using a default configuration, the default hard disk is defined for every supported operating system type and version. The default HDD sizes can be retrieved using this function. The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS). The OS versions can be found in the same file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetDefaultMemSize Function

PrlVmCfg_GetDefaultMemSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

The PrlVmCfg_GetDefaultMemSize function returns the default RAM size for to the specified OS type and version.

Syntax
PRL_RESULT PrlVmCfg_GetDefaultMemSize(
    PRL_UINT32 guestOsVersion,
    PRL_UINT32 hostRam,
    PRL_UINT32_PTR pnMemSize
);
File

PrlApi.h

Parameters

guestOsVersion
Operating system version. See PrlOses.h for type definitions.
hostRam
Optional. The amount of memory (RAM) available on the host system. For some operating system, this parameter may be used to calculate the default the RAM size more precisely.
pnMemSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine using a default configuration, the default memory size is defined for every supported operating system type and version. The default sizes can be retrieved using this function. The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS). The OS versions can be found in the same file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetDescription Function

PrlVmCfg_GetDescription Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the specified virtual machine description.

Syntax
PRL_RESULT PrlVmCfg_GetDescription(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmDescription,
    PRL_UINT32_PTR pnVmDescriptionBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetDevByType Function

PrlVmCfg_GetDevByType Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains a handle to a virtual device in a virtual machine according to the specified device type and index.

Syntax
PRL_RESULT PrlVmCfg_GetDevByType(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE vmDeviceType,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmDeviceType
The device type.
nIndex
An index identifying the device instance (beginning with 0). To determine the number of the devices of the specified type available in the virtual machine, use the PrlVmCfg_GetDevsCountByType function.
phDevice
[out] A pointer to a variable that receives the handle. The type of the handle can be determined using the PrlHandle_GetType function. You should also "know" the handle type based on the device type for which you are obtaining a handle. Search this documentation for topics with PHT_VIRTUAL_DEV_ prefix in their names for the list of the available virtual device handles.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevsCountByType

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDevsCount Function

PrlVmCfg_GetDevsCount Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Determines the total number of devices of any type installed in the virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR vmdev_handles_count
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmdev_handles_count
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevsList

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDevsCountByType Function

PrlVmCfg_GetDevsCountByType Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains the number of virtual devices of the specified type available in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDevsCountByType(
    PRL_HANDLE hVmCfg,
    PRL_DEVICE_TYPE vmDeviceType,
    PRL_UINT32_PTR pnDevicesCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmDeviceType
Device type.
pnDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetDevByType

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDevsList Function

PrlVmCfg_GetDevsList Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns a pointer to a buffer containing handles to the virtual devices installed in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetDevsList(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR vmdev_handles,
    PRL_UINT32_PTR vmdev_handles_count
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
vmdev_handles
[out] A pointer to a variable that receives the data.
vmdev_handles_count
[in] The number of handles that can be placed into the output buffer. [out] The actual number of handles returned.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle, null pointer, or invalid number of handles.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough to fit all of the available devices.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create a device object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

To determine the number of virtual devices installed in a virtual machine (so that you can allocate the output buffer memory dynamically), use the PrlVmCfg_GetDevsCount function. You can also allocate the memory statically if you wish. When iterating through the returned array, the handle type (essentially the device type) in each iteration can be determined using the PrlHandle_GetType function. You can search this documentation for topics with PHT_VIRTUAL_DEV_ prefix in their names for the list of the available virtual device handles. It is the responsibility of the caller to free the memory when the handles are no longer needed.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetDnsServers Function

PrlVmCfg_GetDnsServers Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains the list of globally defined DNS servers that will be assigned to a virtual machine on the guest operating system side.

Syntax
PRL_RESULT PrlVmCfg_GetDnsServers(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
phDnsServersList
[out] A pointer to the PHT_STRINGS_LIST handle that receives the list of DNS servers.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate the string list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetDnsServers

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetDockIconType Function

PrlVmCfg_GetDockIconType Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the virtual machine dock icon type.

Syntax
PRL_RESULT PrlVmCfg_GetDockIconType(
    PRL_HANDLE hVmCfg,
    PRL_DOCK_ICON_TYPE_PTR pnVmDockIconType
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmDockIconType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

This functionality is part of the Parallels Tools package. See PHT_VM_TOOLS_INFO.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetFloppyDisk Function

PrlVmCfg_GetFloppyDisk Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_FLOPPY containing information about the specified floppy disk drive in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetFloppyDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the floppy disk drive instance (beginning with 0). To get the number of floppy disk drives in the virtual machine, use the PrlVmCfg_GetFloppyDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetFloppyDisksCount Function

PrlVmCfg_GetFloppyDisksCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of floppy disk drives in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetFloppyDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnFloppyDisksCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnFloppyDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetForegroundPriority Function

PrlVmCfg_GetForegroundPriority Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns foreground processes priority for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetForegroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY_PTR pnVmForegroundPriority
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmForegroundPriority
[out] A pointer to a variable that receives the result

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetGenericPciDev Function

PrlVmCfg_GetGenericPciDev Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_PCI containing information about a generic PCI device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericPciDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the generic PCI device (beginning with 0). To obtain the number of generic PCI devices in a virtual machine, use the PrlVmCfg_GetGenericPciDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericPciDevsCount

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericPciDevsCount Function

PrlVmCfg_GetGenericPciDevsCount Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Determines the number of generic PCI devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericPciDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnGenericPciDevsCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnGenericPciDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericPciDev

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericScsiDev Function

PrlVmCfg_GetGenericScsiDev Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_GENERIC_SCSI containing information about a generic SCSI device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericScsiDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the generic SCSI device (beginning with 0). To obtain the number of generic SCSI devices in a virtual machine, use the PrlVmCfg_GetGenericScsiDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericScsiDevsCount

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetGenericScsiDevsCount Function

PrlVmCfg_GetGenericScsiDevsCount Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Determines the number of generic SCSI devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetGenericScsiDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnGenericScsiDevsCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnGenericScsiDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_GetGenericScsiDev

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetHardDisk Function

PrlVmCfg_GetHardDisk Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_HARD_DISK containing the specified virtual hard disk information.

Syntax
PRL_RESULT PrlVmCfg_GetHardDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the hard disk instance (beginning with 0). To get the number of hard disks installed in the virtual machine, use the PrlVmCfg_GetHardDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetHardDisksCount Function

PrlVmCfg_GetHardDisksCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of virtual hard disks in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetHardDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnHardDisksCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnHardDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetHomePath Function

PrlVmCfg_GetHomePath Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the virtual machine home directory name and path.

Syntax
PRL_RESULT PrlVmCfg_GetHomePath(
    PRL_HANDLE hVmCfg,
    PRL_STR sHomePath,
    PRL_UINT32_PTR pnHomePathBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sHomePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnHomePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetHostname Function

PrlVmCfg_GetHostname Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains the hostname of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetHostname(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmHostname,
    PRL_UINT32_PTR pnVmHostnameBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The pnVmNameBufLength parameter will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetIcon Function

PrlVmCfg_GetIcon Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the name of the icon file used by the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetIcon(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmIcon,
    PRL_UINT32_PTR pnVmIconBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmIcon
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmIconBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetLastModifiedDate Function

PrlVmCfg_GetLastModifiedDate Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the date and time when the specified virtual machine was last modified.

Syntax
PRL_RESULT PrlVmCfg_GetLastModifiedDate(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmLastModifiedDate,
    PRL_UINT32_PTR pnVmLastModifiedDateBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmLastModifiedDate
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string). The date is returned using the "yyyy-mm-dd hh:mi:ss" format.
pnVmLastModifiedDateBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returned time is a local time (i.e. the time value is already converted to local time zone).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetLastModifierName Function

PrlVmCfg_GetLastModifierName Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the name of the user who last modified the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetLastModifierName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmLastModifierName,
    PRL_UINT32_PTR pnVmLastModifierNameBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmLastModifierName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmLastModifierNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetName Function

PrlVmCfg_GetName Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the name of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmName,
    PRL_UINT32_PTR pnVmNameBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetNetAdapter Function

PrlVmCfg_GetNetAdapter Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_NET_ADAPTER containing information about a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetNetAdapter(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the network adapter instance (beginning with 0). To determine the number of network adapters in the machine, use the PrlVmCfg_GetNetAdaptersCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetNetAdaptersCount Function

PrlVmCfg_GetNetAdaptersCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of network adapters in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetNetAdaptersCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnNetAdaptersCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnNetAdaptersCount
specifies a pointer to the count of devices

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetOpticalDisk Function

PrlVmCfg_GetOpticalDisk Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_OPTICAL_DISK containing information a virtual optical disk in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetOpticalDisk(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the optical disk instance (beginning with 0). To determine the number of optical disks in a virtual machine, use the PrlVmCfg_GetOpticalDisksCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetOpticalDisksCount Function

PrlVmCfg_GetOpticalDisksCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of optical disks in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetOpticalDisksCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnOpticalDisksCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnOpticalDisksCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetOsType Function

PrlVmCfg_GetOsType Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the type of the operating system that the specified virtual machine is running.

Syntax
PRL_RESULT PrlVmCfg_GetOsType(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmOsType
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmOsType
[out] A pointer to a variable that receives the OS type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - VM - the OS information is not present in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS types are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_TYPE_ (e.g. PVS_GUEST_TYPE_MACOS).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetOsVersion Function

PrlVmCfg_GetOsVersion Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the version of the operating system that the specified virtual machine is running.

Syntax
PRL_RESULT PrlVmCfg_GetOsVersion(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmOsVersion
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmOsVersion
[out] A pointer to a variable that receives the OS version.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - VM - the OS information is not present in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetParallelPort Function

PrlVmCfg_GetParallelPort Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_PARALLEL_PORT containing information about a virtual parallel port in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetParallelPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the parallel port instance (beginning with 0). To determine the number of parallel ports in a virtual machine, use the PrlVmCfg_GetParallelPortsCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetParallelPortsCount Function

PrlVmCfg_GetParallelPortsCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of virtual parallel ports in the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetParallelPortsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnParallelPortsCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnParallelPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetRamSize Function

PrlVmCfg_GetRamSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the virtual machine memory (RAM) size, in megabytes.

Syntax
PRL_RESULT PrlVmCfg_GetRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmRamSize
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRamSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the memory information is not available in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetScrRes Function

PrlVmCfg_GetScrRes Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the specified virtual machine screen resolution.

Syntax
PRL_RESULT PrlVmCfg_GetScrRes(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nScrResIndex,
    PRL_HANDLE_PTR phVmScrRes
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nScrResIndex
The index identifying the resolution.
phVmScrRes
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetScrResCount Function

PrlVmCfg_GetScrResCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the virtual machine screen resolutions count.

Syntax
PRL_RESULT PrlVmCfg_GetScrResCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnScrResCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnScrResCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSearchDomains Function

PrlVmCfg_GetSearchDomains Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Obtains the list of globally defined search domains that will be assigned to a virtual machine on the guest operating system side.

Syntax
PRL_RESULT PrlVmCfg_GetSearchDomains(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApi.h

Parameters

phSearchDomainsList
[out] A pointer to the PHT_STRINGS_LIST handle containing the list of search domains.
hVmDev
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate the string list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetSearchDomains

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_GetSerialPort Function

PrlVmCfg_GetSerialPort Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_SERIAL_PORT containing information about a serial port in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSerialPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the serial port instance.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSerialPortsCount Function

PrlVmCfg_GetSerialPortsCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of serial ports in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSerialPortsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSerialPortsCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSerialPortsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetServerHost Function

PrlVmCfg_GetServerHost Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the hostname of the machine hosting the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetServerHost(
    PRL_HANDLE hVmCfg,
    PRL_STR sServerHost,
    PRL_UINT32_PTR pnServerHostBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnServerHostBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.
unnamsServerHosted_param
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetServerUuid Function

PrlVmCfg_GetServerUuid Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the UUID of the machine hosting the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetServerUuid(
    PRL_HANDLE hVmCfg,
    PRL_STR sServerUuid,
    PRL_UINT32_PTR pnServerUuidBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sServerUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnServerUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetShare Function

PrlVmCfg_GetShare Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_SHARE containing information about a shared folder.

Syntax
PRL_RESULT PrlVmCfg_GetShare(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nShareIndex,
    PRL_HANDLE_PTR phVmShare
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nShareIndex
An index identifying the shared folder (beginning with 0). To determine the number of shared folders in a virtual machine, use the PrlVmCfg_GetSharesCount function.
phVmShare
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A shared folder is a folder in the host OS which is shared with a given virtual machine. To obtain its information, first determine the number of the available shared folders using the PrlVmCfg_GetSharesCount function. Then iterate through the list using the iteration number as the nShareIndex parameter value.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSharesCount Function

PrlVmCfg_GetSharesCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of shared folders in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSharesCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSharesCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSharesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A shared folder is a folder in the host OS which is shared with a given virtual machine. To obtain its information, first determine the number of the available shared folders using the PrlVmCfg_GetSharesCount function. Then obtain information about an individual folder using the PrlVmCfg_GetShare function.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSoundDev Function

PrlVmCfg_GetSoundDev Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_SOUND containing information about a sound device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSoundDev(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the sound device (beginning with 0). To obtain the number of sound devices in a virtual machine, use the PrlVmCfg_GetSoundDevsCount function.
phDevice
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSoundDevsCount Function

PrlVmCfg_GetSoundDevsCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of sound devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetSoundDevsCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnSoundDevsCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnSoundDevsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetStartLoginMode Function

PrlVmCfg_GetStartLoginMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the automatic startup login mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetStartLoginMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_START_LOGIN_MODE_PTR pnVmStartLoginMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmStartLoginMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetStartUserLogin Function

PrlVmCfg_GetStartUserLogin Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the user name used during the specified virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_GetStartUserLogin(
    PRL_HANDLE hVmCfg,
    PRL_STR sStartUserLogin,
    PRL_UINT32_PTR pnStartUserLoginBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration. the virtual machine.
sStartUserLogin
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnStartUserLoginBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetSystemFlags Function

PrlVmCfg_GetSystemFlags Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the virtual machine system flags.

Syntax
PRL_RESULT PrlVmCfg_GetSystemFlags(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmSystemFlags,
    PRL_UINT32_PTR pnVmSystemFlagsBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmSystemFlags
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmSystemFlagsBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetUndoDisksMode Function

PrlVmCfg_GetUndoDisksMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the current undo disks mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUndoDisksMode(
    PRL_HANDLE hVmCfg,
    PRL_UNDO_DISKS_MODE_PTR pnUndoDisksMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnUndoDisksMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetUsbDevice Function

PrlVmCfg_GetUsbDevice Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_USB_DEVICE containing information about a USB device in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUsbDevice(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phDevice
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nIndex
An index identifying the USB device (beginning with 0). To determine the number of USB devices in a virtual machine, use the PrlVmCfg_GetUsbDevicesCount function.
phDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetUsbDevicesCount Function

PrlVmCfg_GetUsbDevicesCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the number of USB devices in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUsbDevicesCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnUsbDevicesCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnUsbDevicesCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetUuid Function

PrlVmCfg_GetUuid Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the UUID (universally unique ID) of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetUuid(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmUuid,
    PRL_UINT32_PTR pnVmUuidBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmUuid
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmUuidBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetVideoRamSize Function

PrlVmCfg_GetVideoRamSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the video memory size of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVideoRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmVideoRamSize
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmVideoRamSize
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the video memory size information is missing in the virtual machine configuration.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCHostName Function

PrlVmCfg_GetVNCHostName Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the VNC hostname of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCHostName(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmRemoteDisplayHostName,
    PRL_UINT32_PTR pnVmRemoteDisplayHostNameBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmRemoteDisplayHostName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmRemoteDisplayHostNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCMode Function

PrlVmCfg_GetVNCMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the VNC mode of the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_REMOTE_DISPLAY_MODE_PTR pnVmRemoteDisplayMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRemoteDisplayMode
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCPassword Function

PrlVmCfg_GetVNCPassword Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the VNC password for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCPassword(
    PRL_HANDLE hVmCfg,
    PRL_STR sVmRemoteDisplayPassword,
    PRL_UINT32_PTR pnVmRemoteDisplayPasswordBufLength
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sVmRemoteDisplayPassword
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnVmRemoteDisplayPasswordBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetVNCPort Function

PrlVmCfg_GetVNCPort Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the VNC port number for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_GetVNCPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32_PTR pnVmRemoteDisplayPort
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pnVmRemoteDisplayPort
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_GetWindowMode Function

PrlVmCfg_GetWindowMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns the current window mode the specified virtual machine is in.

Syntax
PRL_RESULT PrlVmCfg_GetWindowMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_WINDOW_MODE_PTR pnVmWindowMode
);
File

PrlApi.h

Parameters

pnVmWindowMode
[out] A pointer to a variable that receives the result.
hVm
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsCloseAppOnShutdown Function

PrlVmCfg_IsCloseAppOnShutdown Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns Virtual Machine close app on shutdown sign.

Syntax
PRL_RESULT PrlVmCfg_IsCloseAppOnShutdown(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCloseAppOnShutdown
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
buffer for storing result

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (NULL) pointer to the buffer was specified PRL_ERR_SUCCESS - operation successfully completed

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsCpuVtxEnabled Function

PrlVmCfg_IsCpuVtxEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns Virtual Machine CPU VTx support enabling sign.

Syntax
PRL_RESULT PrlVmCfg_IsCpuVtxEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmCpuVtxEnabled
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
buffer for storing result

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid PHT_VIRTUAL_MACHINE handle or non valid (NULL) pointer to the buffer was specified PRL_ERR_NO_DATA - VM configuration do not has necessary data PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsDefaultDeviceNeeded Function

PrlVmCfg_IsDefaultDeviceNeeded Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if a virtual machine requires a default device of the specified type if it's going to run an operating system of the specified type.

Syntax
PRL_RESULT PrlVmCfg_IsDefaultDeviceNeeded(
    PRL_UINT32 guestOsVersion,
    PRL_DEVICE_TYPE deviceType,
    PRL_BOOL_PTR pbNeeded
);
File

PrlApi.h

Parameters

guestOsVersion
Target OS version. The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).
deviceType
Device type.
pbNeeded
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the device of specified type is required. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function accepts the target operating system type, version, and a device type identifier. Using these parameters, it determines if the specified device is required in order for the projected virtual machine to run properly. If a device is required, you must add it to a virtual machine using the PrlVmCfg_AddDefaultDevice function. If a device is not required, you don't have to add it (it will not affect the operation of a virtual machine).

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsDisableAPIC Function

PrlVmCfg_IsDisableAPIC Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Gets the APIC using for virtual machine in runtime.

Syntax
PRL_RESULT PrlVmCfg_IsDisableAPIC(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbDisableAPIC
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbDisableAPIC
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the APIC is switched off. PBL_FALE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsDiskCacheWriteBack Function

PrlVmCfg_IsDiskCacheWriteBack Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Determines if disk cache write-back is enabled for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsDiskCacheWriteBack(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmDiskCacheWriteBack
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmDiskCacheWriteBack
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that cache write-back is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmCfg_SetDiskCacheWriteBack

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_IsExcludeDock Function

PrlVmCfg_IsExcludeDock Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines the guest OS window behavior in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsExcludeDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmExcludeDock
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmExcludeDock
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that dock is excluded. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When a virtual machine is running in coherence mode, you can make the dock stay always below the virtual machine window. If the window is moved below the dock, the portion of it that crossed that boundary will be cut (will not be redrawn). In order to do that, call this function passing PRL_TRUE in the bVmExcludeDock parameter. If the parameter is set to PRL_FALSE, the virtual machine window will be able to move below the dock.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingAutoMount Function

PrlVmCfg_IsGuestSharingAutoMount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if host shared folders are mounted automatically in a given virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingAutoMount(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingAutoMount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingAutoMount
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that shares are mounted automatically. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If shares are mounted automatically, then shared folders will be mapped and appear in the guest OS on startup.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingEnabled Function

PrlVmCfg_IsGuestSharingEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if guest sharing is enabled (the guest OS disk drives are visible in the host OS).

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that guest sharing is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsGuestSharingEnableSpotlight Function

PrlVmCfg_IsGuestSharingEnableSpotlight Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if VM virtual disks will be added to Spotlight search subsystem.

Syntax
PRL_RESULT PrlVmCfg_IsGuestSharingEnableSpotlight(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmGuestSharingEnableSpotlight
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmGuestSharingEnableSpotlight
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that virtual disks are added to Spotlight search subsystem. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsHostSharingEnabled Function

PrlVmCfg_IsHostSharingEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if host sharing is enabled (host shared folders are visible in the guest OS).

Syntax
PRL_RESULT PrlVmCfg_IsHostSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmHostSharingEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmHostSharingEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that sharing is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsMapSharedFoldersOnLetters Function

PrlVmCfg_IsMapSharedFoldersOnLetters Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines whether host disks shared into guest Windows OS will be maped on drive letters.

Syntax
PRL_RESULT PrlVmCfg_IsMapSharedFoldersOnLetters(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbMapSharedFoldersOnLetters
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbMapSharedFoldersOnLetters
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that host disks shared into guest Windows OS will be maped on drive letters. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsMultiDisplay Function

PrlVmCfg_IsMultiDisplay Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if the specified virtual machine uses a multi-display mode.

Syntax
PRL_RESULT PrlVmCfg_IsMultiDisplay(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmMultiDisplay
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmMultiDisplay
[out] A pointer to a variable that receives the result. PRL_TRUE indicates multi-display. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsOsResInFullScrMode Function

PrlVmCfg_IsOsResInFullScrMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if a virtual machine OS resolution is in full screen mode.

Syntax
PRL_RESULT PrlVmCfg_IsOsResInFullScrMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmOsResInFullScrMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmOsResInFullScrMode
[out] A pointer to a variable that receives the result. PRL_TRUE indicates full screen mode. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsRelocateTaskBar Function

PrlVmCfg_IsRelocateTaskBar Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if Windows task bar relocation feature is enabled in a virtual machine when it runs in the coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsRelocateTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmRelocateTaskBar
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmRelocateTaskBar
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsScrResEnabled Function

PrlVmCfg_IsScrResEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if additional screen resolution support is enabled in a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_IsScrResEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmScrResEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmScrResEnabled
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the feature is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsShareAllHostDisks Function

PrlVmCfg_IsShareAllHostDisks Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines whether all host disks will be present at guest OS as shares.

Syntax
PRL_RESULT PrlVmCfg_IsShareAllHostDisks(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbShareAllHostDisks
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbShareAllHostDisks
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that all host disks will be. shared into guest OS. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsSharedProfileEnabled Function

PrlVmCfg_IsSharedProfileEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether shared profile is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsSharedProfileEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsShareUserHomeDir Function

PrlVmCfg_IsShareUserHomeDir Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines whether host user home dir will be present at guest OS as share.

Syntax
PRL_RESULT PrlVmCfg_IsShareUserHomeDir(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbShareUserHomeDir
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbShareUserHomeDir
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that host user home dir will be shared into guest OS. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsShowTaskBar Function

PrlVmCfg_IsShowTaskBar Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if Windows task bar is displayed when the virtual machine runs in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_IsShowTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmShowTaskBar
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmShowTaskBar
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the option is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsSmartGuardEnabled Function

PrlVmCfg_IsSmartGuardEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether smart guard is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsSmartGuardEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsTemplate Function

PrlVmCfg_IsTemplate Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Determines if the specified virtual machine object contains a virtual machine or a template configuration information.

Syntax
PRL_RESULT PrlVmCfg_IsTemplate(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbVmIsTemplate
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbVmIsTemplate
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the machine is a template. PBL_FALE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If the object contains a template configuration, it can be used to create new virtual machines from it. See PrlVm_Clone for the information on how to create virtual machines from templates.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsUseDesktop Function

PrlVmCfg_IsUseDesktop Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether use desktop in shared profile is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsUseDesktop(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsUseDocuments Function

PrlVmCfg_IsUseDocuments Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether use documents in shared profile is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsUseDocuments(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsUseMusic Function

PrlVmCfg_IsUseMusic Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether use music in shared profile is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsUseMusic(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsUsePictures Function

PrlVmCfg_IsUsePictures Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether use pictures in shared profile is enabled.

Syntax
PRL_RESULT PrlVmCfg_IsUsePictures(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_IsUserDefinedSharedFoldersEnabled Function

PrlVmCfg_IsUserDefinedSharedFoldersEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Returns sign whether user defined shared folders enabled.

Syntax
PRL_RESULT PrlVmCfg_IsUserDefinedSharedFoldersEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
pbEnabled
Buffer for storing result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer to buffer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetAppInDockMode Function

PrlVmCfg_SetAppInDockMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the dock mode for the applications (see PRL_APP_IN_DOCK_MODE for available options).

Syntax
PRL_RESULT PrlVmCfg_SetAppInDockMode(
    PRL_HANDLE hVmCfg,
    PRL_APP_IN_DOCK_MODE nVmAppInDockMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAppInDockMode
The applications in dock mode option to set. See the PRL_APP_IN_DOCK_MODE enumeration for the list of options.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoStart Function

PrlVmCfg_SetAutoStart Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to sets the automatic startup option for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStart(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTART_OPTION nVmAutoStart
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStart
The automatic startup option to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoStartDelay Function

PrlVmCfg_SetAutoStartDelay Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the time delay that will be used during the virtual machine automatic startup.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStartDelay(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmAutoStartDelay
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStartDelay
Time delay to set, in seconds.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetAutoStop Function

PrlVmCfg_SetAutoStop Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to set the automatic shutdown mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetAutoStop(
    PRL_HANDLE hVmCfg,
    PRL_VM_AUTOSTOP_OPTION nVmAutoStop
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmAutoStop
Automatic shutdown mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetBackgroundPriority Function

PrlVmCfg_SetBackgroundPriority Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets virtual machine background processes priority.

Syntax
PRL_RESULT PrlVmCfg_SetBackgroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY nVmBackgroundPriority
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmBackgroundPriority
The priority level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetCloseAppOnShutdown Function

PrlVmCfg_SetCloseAppOnShutdown Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets Virtual Machine close app on shutdown sign.

Syntax
PRL_RESULT PrlVmCfg_SetCloseAppOnShutdown(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmCloseAppOnShutdown
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
setting value

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuAccelLevel Function

PrlVmCfg_SetCpuAccelLevel Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets CPU acceleration level for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuAccelLevel(
    PRL_HANDLE hVmCfg,
    PRL_VM_ACCELERATION_LEVEL nVmCpuAccelLevel
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuAccelLevel
The CPU acceleration level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuCount Function

PrlVmCfg_SetCpuCount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the number of CPUs for the specified virtual machine (the CPUs should be present in the machine).

Syntax
PRL_RESULT PrlVmCfg_SetCpuCount(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmCpuCount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuCount
The number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuMode Function

PrlVmCfg_SetCpuMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets CPU mode (32 bit or 64 bit) for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuMode(
    PRL_HANDLE hVmCfg,
    PRL_CPU_MODE nVmCpuMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuMode
The CPU mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetCpuUnits Function

PrlVmCfg_SetCpuUnits Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Sets the number of CPU units that will be allocated to a virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetCpuUnits(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmCpuUnits
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmCpuUnits
The number of CPU units to allocate.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Each virtual machine on the same host can be allocated a number of CPU units from the range of 8 to 500000. The larger the number is, the more CPU time the virtual machine will get.

See Also

PrlVmCfg_GetCpuUnits

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetCustomProperty Function

PrlVmCfg_SetCustomProperty Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine custom property information.

Syntax
PRL_RESULT PrlVmCfg_SetCustomProperty(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmCustomProperty
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmCustomProperty
A pointer to a buffer containing the custom information. The data must be in CDATA format.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If you have some custom data, which relates to a virtual machine in some way, you can save it in the virtual machine configuration for future retrieval. This can be any data that your client application requires. The data is stored in CDATA format.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetDefaultConfig Function

PrlVmCfg_SetDefaultConfig Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

The PrlVmCfg_SetDefaultConfig function selects a default configuration for a new virtual machine based on the operating system that the virtual machine will be running.

Syntax
PRL_RESULT PrlVmCfg_SetDefaultConfig(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSrvConfig,
    PRL_UINT32 guestOsVersion,
    PRL_BOOL needCreateDevices
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
hSrvConfig
A handle of type PHT_SERVER_CONFIG.
guestOsVersion
The version of the operating system that the virtual machine will be running. The OS versions can be found in the PrlOses.h file. The names of the macros are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).
needCreateDevices
A flag indicating whether default virtual machine devices should be created or not. Specify PRL_TRUE to create default devices, or PRL_FALSE to skip the device creation.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The default configuration information is obtained from the host machine configuration, which is passed to the function as a parameter. Using a default configuration for a new virtual machine is the simplest and safest way to configure a new virtual machine. For the example on how to create a new virtual machine using a default configuration, see the PrlVm_Reg function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetDescription Function

PrlVmCfg_SetDescription Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine description.

Syntax
PRL_RESULT PrlVmCfg_SetDescription(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmDescription
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmDescription
The virtual machine description to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetDisableAPICSign Function

PrlVmCfg_SetDisableAPICSign Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the APIC using for virtual machine in runtime.

Syntax
PRL_RESULT PrlVmCfg_SetDisableAPICSign(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bDisableAPIC
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bDisableAPIC
The value to set. Specify PRL_TRUE to make the APIC is switched off. Specify PRL_FALSE to switch an APIC is switched on.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetDiskCacheWriteBack Function

PrlVmCfg_SetDiskCacheWriteBack Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine disk cache write-back option.

Syntax
PRL_RESULT PrlVmCfg_SetDiskCacheWriteBack(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmDiskCacheWriteBack
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmDiskCacheWriteBack
The disk cache write-back option to set. Specify PRL_TRUE to enable the disk cache write-back. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetDnsServers Function

PrlVmCfg_SetDnsServers Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Allows to manually set the global DNS server list that will assigned to the virtual machine on the guest OS side.

Syntax
PRL_RESULT PrlVmCfg_SetDnsServers(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hDnsServersList
);
File

PrlApi.h

Parameters

hDnsServersList
A handle of type PHT_STRINGS_LIST containing the list of DNS servers to be assigned to the global network settings of the virtual machine operating system. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.
hVmDev
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmCfg_GetDnsServers

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetDockIconType Function

PrlVmCfg_SetDockIconType Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine dock icon type.

Syntax
PRL_RESULT PrlVmCfg_SetDockIconType(
    PRL_HANDLE hVmCfg,
    PRL_DOCK_ICON_TYPE nVmDockIconType
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmDockIconType
The icon type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetExcludeDock Function

PrlVmCfg_SetExcludeDock Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the exclude dock option.

Syntax
PRL_RESULT PrlVmCfg_SetExcludeDock(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmExcludeDock
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmExcludeDock
The value to set. Specify PRL_TRUE to exclude the dock. Specify PRL_FALSE to include the dock.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When a virtual machine is running in coherence mode, you can make the dock stay always below the virtual machine window. If the window is moved below the dock, the portion of it that crossed that boundary will be cut (will not be redrawn). In order to do that, call this function passing PRL_TRUE in the bVmExcludeDock parameter. If the parameter is set to PRL_FALSE, the virtual machine window will be able to move below the dock.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetForegroundPriority Function

PrlVmCfg_SetForegroundPriority Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine foreground processes priority.

Syntax
PRL_RESULT PrlVmCfg_SetForegroundPriority(
    PRL_HANDLE hVmCfg,
    PRL_VM_PRIORITY nVmForegroundPriority
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmForegroundPriority
The priority level to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetGuestSharingAutoMount Function

PrlVmCfg_SetGuestSharingAutoMount Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the guest OS sharing auto-mount option.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingAutoMount(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingAutoMount
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingAutoMount
Auto-mount option to set. Specify PRL_TRUE to enable sharing auto-mount. Specify PRL_FALSE to disable auto-mount.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled (see PrlVmCfg_SetGuestSharingEnabled) and auto-mount is turned on, the guest OS disk drives will appear as icons on the host desktop. If sharing is enabled but auto-mount is not, you will not see the drives in the host OS but Smart Select feature will still work.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetGuestSharingEnabled Function

PrlVmCfg_SetGuestSharingEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Enables the guest sharing feature.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingEnabled
The value to set. Specify PRL_TRUE to enable guest sharing. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled, the guest OS disk drives will be accessible in the host OS. If, in addition, the auto-mount feature is turned on, the guest OS disk drives will appear as icons on the host desktop. If sharing is enabled but auto-mount is not, you will not see the drives in the host OS but Smart Select feature will still work.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetGuestSharingEnableSpotlight Function

PrlVmCfg_SetGuestSharingEnableSpotlight Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the VM virtual disks added to Spotlight search subsystem sign.

Syntax
PRL_RESULT PrlVmCfg_SetGuestSharingEnableSpotlight(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmGuestSharingEnableSpotlight
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmGuestSharingEnableSpotlight
Enable Spotlight option to set. Specify PRL_TRUE to enable using virtual harddisks at Spotlight search subsystem. Specify PRL_FALSE to disable virtual hard disks from Spotlight.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

If guest sharing is enabled (see PrlVmCfg_SetGuestSharingEnabled) and Spotlight enable sign is turned on, the search through Spotlight subsystem will be using VM virtual hardisks too.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetHostname Function

PrlVmCfg_SetHostname Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the specified virtual machine hostname.

Syntax
PRL_RESULT PrlVmCfg_SetHostname(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmHostname
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmName
The hostname to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetHostSharingEnabled Function

PrlVmCfg_SetHostSharingEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Enables host sharing for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetHostSharingEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmHostSharingEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmHostSharingEnabled
The value to set. Specify PRL_TRUE to enable sharing. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When host sharing is enabled, the host OS shared folders will be visible in the guest OS. To use the host sharing feature, the shared folders must be set up first using the functionality provided by the PHT_SHARE object.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetIcon Function

PrlVmCfg_SetIcon Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine icon.

Syntax
PRL_RESULT PrlVmCfg_SetIcon(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmIcon
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmIcon
The new icon file name.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetMapSharedFoldersOnLetters Function

PrlVmCfg_SetMapSharedFoldersOnLetters Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Enables mapping of shared host disks on drive letters for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetMapSharedFoldersOnLetters(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bMapSharedFoldersOnLetters
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bMapSharedFoldersOnLetters
The value to set. Specify PRL_TRUE to map shared host disks on drive letters. Specify PRL_FALSE to not share it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this sign switched on host disks shared into guest Windows OS will be maped on correspond drive letters. Note that host sharing should be switched on to enable this functionality.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetMultiDisplay Function

PrlVmCfg_SetMultiDisplay Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine multi-display option.

Syntax
PRL_RESULT PrlVmCfg_SetMultiDisplay(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmMultiDisplay
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmMultiDisplay
The value to set. Specify PRL_TRUE to enable the multi-display option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetName Function

PrlVmCfg_SetName Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the specified virtual machine name.

Syntax
PRL_RESULT PrlVmCfg_SetName(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmName
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmName
The name to set. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetOsResInFullScrMode Function

PrlVmCfg_SetOsResInFullScrMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine OS resolution in full screen mode option.

Syntax
PRL_RESULT PrlVmCfg_SetOsResInFullScrMode(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmOsResInFullScrMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmOsResInFullScrMode
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetOsVersion Function

PrlVmCfg_SetOsVersion Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine guest OS version.

Syntax
PRL_RESULT PrlVmCfg_SetOsVersion(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmOsVersion
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmOsVersion
The guest OS version to set. The OS versions are defined in the PrlOses.h file as macros. Look for the macros that are prefixed with PVS_GUEST_VER_ (e.g. PVS_GUEST_VER_MACOS_LEOPARD).

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetRamSize Function

PrlVmCfg_SetRamSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine memory (RAM) size.

Syntax
PRL_RESULT PrlVmCfg_SetRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmRamSize
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRamSize
The RAM size to set, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetRelocateTaskBar Function

PrlVmCfg_SetRelocateTaskBar Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to enable or disable the Windows task bar relocation feature.

Syntax
PRL_RESULT PrlVmCfg_SetRelocateTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmRelocateTaskBar
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmRelocateTaskBar
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetScrResEnabled Function

PrlVmCfg_SetScrResEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the additional screen resolution support option in the specified virtual machine

Syntax
PRL_RESULT PrlVmCfg_SetScrResEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmScrResEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmScrResEnabled
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetSearchDomains Function

PrlVmCfg_SetSearchDomains Function
PrlApi.h PHT_VM_CONFIGURATION See Also Send Feedback

Allows to manually set the global search domain list that will be assigned to the virtual machine on the guest OS side.

Syntax
PRL_RESULT PrlVmCfg_SetSearchDomains(
    PRL_HANDLE hVmCfg,
    PRL_HANDLE hSearchDomainsList
);
File

PrlApi.h

Parameters

hSearchDomainsList
A handle of type PHT_STRINGS_LIST containing the list of search domains to be applied to the global network settings of the virtual machine operating system. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.
hVmDev
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmCfg_GetSearchDomains

Links
PrlApi.h, PHT_VM_CONFIGURATION, See Also


PrlVmCfg_SetShareAllHostDisks Function

PrlVmCfg_SetShareAllHostDisks Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Enables sharing of all host disks for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetShareAllHostDisks(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bShareAllHostDisks
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bShareAllHostDisks
The value to set. Specify PRL_TRUE to share all host disks to guest OS. Specify PRL_FALSE to not share them.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this sign switched on all host disks will be shared into guest OS. Note that host sharing should be switched on to enable this functionality.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetSharedProfileEnabled Function

PrlVmCfg_SetSharedProfileEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetSharedProfileEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetShareUserHomeDir Function

PrlVmCfg_SetShareUserHomeDir Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Enables sharing of host user home dir for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetShareUserHomeDir(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bShareUserHomeDir
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bShareUserHomeDir
The value to set. Specify PRL_TRUE to share host user home dir to guest OS. Specify PRL_FALSE to not share it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When this sign switched on host user home dir will be shared into guest OS. Note that host sharing should be switched on to enable this functionality.

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetShowTaskBar Function

PrlVmCfg_SetShowTaskBar Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to show or hide the Windows task bar when the virtual machine is running in coherence mode.

Syntax
PRL_RESULT PrlVmCfg_SetShowTaskBar(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmShowTaskBar
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmShowTaskBar
The value to set. Specify PRL_TRUE to enable the option. Specify PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Parallels Tools must be installed to use this feature. To obtain the Parallels Tools status, use the PrlVm_GetToolsState function.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetSmartGuardEnabled Function

PrlVmCfg_SetSmartGuardEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set smart guard enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetSmartGuardEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetStartLoginMode Function

PrlVmCfg_SetStartLoginMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to set the automatic startup login mode for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetStartLoginMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_START_LOGIN_MODE nVmStartLoginMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmStartLoginMode
Automatic startup login mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetStartUserCreds Function

PrlVmCfg_SetStartUserCreds Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to set the automatic startup user login and password for the specified virtual machine.

Syntax
PRL_RESULT PrlVmCfg_SetStartUserCreds(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sStartUserLogin,
    PRL_CONST_STR sPassword
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sStartUserLogin
User login. Must be a a UTF-8 encoded, null-terminated string.
sPassword
User password. Must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetSystemFlags Function

PrlVmCfg_SetSystemFlags Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets Virtual Machine system flags.

Syntax
PRL_RESULT PrlVmCfg_SetSystemFlags(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmSystemFlags
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VIRTUAL_MACHINE identifying the virtual machine.
unnamed_param
new VM system flags

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Specified string value must be UTF-8 encoding and ends with '0' terminating symbol.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetTemplateSign Function

PrlVmCfg_SetTemplateSign Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Allows to modify a regular virtual machine to become a template, and vise versa.

Syntax
PRL_RESULT PrlVmCfg_SetTemplateSign(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bVmIsTemplate
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bVmIsTemplate
The value to set. Specify PRL_TRUE to make the virtual machine a template. Specify PRL_FALSE to switch a template to a regular virtual machine.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A template is very similar to a regular virtual machine with the major exception being it cannot be started. Templates are used to create new virtual machines as exact copies of them. To create a virtual machine from a template, use the PrlVm_Clone function specifying the template as the source.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUndoDisksMode Function

PrlVmCfg_SetUndoDisksMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the undo disks mode for the virtual machine (see PRL_UNDO_DISKS_MODE for available options).

Syntax
PRL_RESULT PrlVmCfg_SetUndoDisksMode(
    PRL_HANDLE hVmCfg,
    PRL_UNDO_DISKS_MODE nUndoDisksMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nUndoDisksMode
The undo disks mode option to set. See the PRL_UNDO_DISKS_MODE enumeration for the list of options.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUseDesktop Function

PrlVmCfg_SetUseDesktop Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set use desktop in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseDesktop(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUseDocuments Function

PrlVmCfg_SetUseDocuments Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set use documents in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseDocuments(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUseMusic Function

PrlVmCfg_SetUseMusic Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set use music in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUseMusic(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUsePictures Function

PrlVmCfg_SetUsePictures Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set use pictures in shared profile enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUsePictures(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUserDefinedSharedFoldersEnabled Function

PrlVmCfg_SetUserDefinedSharedFoldersEnabled Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Lets to set user defined shared folders enabling sign.

Syntax
PRL_RESULT PrlVmCfg_SetUserDefinedSharedFoldersEnabled(
    PRL_HANDLE hVmCfg,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
bEnabled
Setting boolean value.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetUuid Function

PrlVmCfg_SetUuid Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine UUID (universally unique ID).

Syntax
PRL_RESULT PrlVmCfg_SetUuid(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmUuid
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmUuid
The UUID to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A UUID is assigned to a virtual machine automatically when it is created. Before using this function, make sure that you understand what UUID is, and that you have a good reason for changing it.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetVideoRamSize Function

PrlVmCfg_SetVideoRamSize Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine video memory size.

Syntax
PRL_RESULT PrlVmCfg_SetVideoRamSize(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmVideoRamSize
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmVideoRamSize
The new memory size, in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCHostName Function

PrlVmCfg_SetVNCHostName Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine VNC host name.

Syntax
PRL_RESULT PrlVmCfg_SetVNCHostName(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmRemoteDisplayHostName
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmRemoteDisplayHostName
The new VNC host name. The value must be a a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCMode Function

PrlVmCfg_SetVNCMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine VNC mode.

Syntax
PRL_RESULT PrlVmCfg_SetVNCMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_REMOTE_DISPLAY_MODE nVmRemoteDisplayMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRemoteDisplayMode
The VNC mode to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCPassword Function

PrlVmCfg_SetVNCPassword Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine VNC password.

Syntax
PRL_RESULT PrlVmCfg_SetVNCPassword(
    PRL_HANDLE hVmCfg,
    PRL_CONST_STR sNewVmRemoteDisplayPassword
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
sNewVmRemoteDisplayPassword
The VNC password to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetVNCPort Function

PrlVmCfg_SetVNCPort Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine VNC port number.

Syntax
PRL_RESULT PrlVmCfg_SetVNCPort(
    PRL_HANDLE hVmCfg,
    PRL_UINT32 nVmRemoteDisplayPort
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmRemoteDisplayPort
The port number to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmCfg_SetWindowMode Function

PrlVmCfg_SetWindowMode Function
PrlApi.h PHT_VM_CONFIGURATION Send Feedback

Sets the virtual machine window mode.

Syntax
PRL_RESULT PrlVmCfg_SetWindowMode(
    PRL_HANDLE hVmCfg,
    PRL_VM_WINDOW_MODE nVmWindowMode
);
File

PrlApi.h

Parameters

hVmCfg
A handle of type PHT_VM_CONFIGURATION identifying the virtual machine configuration.
nVmWindowMode
The window mode to set. See the PRL_VM_WINDOW_MODE enumeration for the list of modes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_CONFIGURATION


PrlVmDev_Connect Function

PrlVmDev_Connect Function
PrlApi.h Virtual Device Functions Send Feedback

The PrlVmDev_Connect function allows to connect virtual devices while the virtual machine is running.

Syntax
PRL_HANDLE PrlVmDev_Connect(
    PRL_HANDLE hVmDev
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_Create Function

PrlVmDev_Create Function
PrlApi.h Virtual Device Functions Send Feedback

Creates a new virtual device handle not bound to any virtual machine.

Syntax
PRL_RESULT PrlVmDev_Create(
    PRL_DEVICE_TYPE nDeviceType,
    PRL_HANDLE_PTR phVmDevice
);
File

PrlApi.h

Parameters

nDeviceType
The type of handle to create.
phVmDevice
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

It is necessary to call PrlHandle_Free after the handle usage.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_CreateImage Function

PrlVmDev_CreateImage Function
PrlApi.h Virtual Device Functions Send Feedback

Physically creates a virtual device image on the host.

Syntax
PRL_HANDLE PrlVmDev_CreateImage(
    PRL_HANDLE hVmDev,
    PRL_BOOL bRecreateIsAllowed,
    PRL_BOOL bNonInteractiveMode
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
bRecreateIsAllowed
Specifies wether the existing image should be replaced. If set to PRL_TRUE, the existing image will be replaced. If set to PRL_FALSE, the operation will be aborted if image already exists.
bNonInteractiveMode
Specifies wether the operation should be carried out in interactive mode (where the Parallels Service may ask questions and the client will have to send answers). If set to PRL_TRUE, non-interactive mode will be used (the Parallels Service will make decisions on its own). If set to PRL_FALSE, interactive mode will be used.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_Disconnect Function

PrlVmDev_Disconnect Function
PrlApi.h Virtual Device Functions Send Feedback

Allows to disconnect a device while the virtual machine is running.

Syntax
PRL_HANDLE PrlVmDev_Disconnect(
    PRL_HANDLE hVmDev
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetDescription Function

PrlVmDev_GetDescription Function
PrlApi.h Virtual Device Functions See Also Send Feedback

Returns the description of a specified virtual device.

Syntax
PRL_RESULT PrlVmDev_GetDescription(
    PRL_HANDLE hVmDev,
    PRL_STR sDescription,
    PRL_UINT32_PTR pnDescriptionBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sDescription
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnDescriptionBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The pnDescriptionBufLength parameter will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDev_SetDescription

Links
PrlApi.h, Virtual Device Functions, See Also


PrlVmDev_GetEmulatedType Function

PrlVmDev_GetEmulatedType Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device emulation type.

Syntax
PRL_RESULT PrlVmDev_GetEmulatedType(
    PRL_HANDLE hVmDev,
    PRL_VM_DEV_EMULATION_TYPE_PTR pnEmulatedType
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
pnEmulatedType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Emulation types are defined in the PRL_VM_DEV_EMULATION_TYPE enumeration. The following describes emulation types used for different types of virtual devices:

  • PHT_VIRTUAL_DEV_FLOPPY: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_HARD_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_OPTICAL_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_SERIAL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for socket mode).
  • PHT_VIRTUAL_DEV_PARALLEL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for printer mode).
  • PHT_VIRTUAL_DEV_NET_ADAPTER: PDT_USE_REAL_DEVICE (host-only network), PDT_USE_IMAGE_FILE (shared network), PDT_USE_OUTPUT_FILE (bridget ethernet)
  • PHT_VIRTUAL_DEV_SOUND: PDT_USE_REAL_DEVICE (AC'97), PDT_USE_IMAGE_FILE (Creative).
  • PHT_VIRTUAL_DEV_USB_DEVICE: PDT_USE_REAL_DEVICE
Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetFriendlyName Function

PrlVmDev_GetFriendlyName Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device user friendly name.

Syntax
PRL_RESULT PrlVmDev_GetFriendlyName(
    PRL_HANDLE hVmDev,
    PRL_STR sFriendlyName,
    PRL_UINT32_PTR pnFriendlyNameBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sFriendlyName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnFriendlyNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetIfaceType Function

PrlVmDev_GetIfaceType Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device interface type (IDE or SCSI).

Syntax
PRL_RESULT PrlVmDev_GetIfaceType(
    PRL_HANDLE hVmDev,
    PRL_MASS_STORAGE_INTERFACE_TYPE_PTR pnIfaceType
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
pnIfaceType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetImagePath Function

PrlVmDev_GetImagePath Function
PrlApi.h Virtual Device Functions Send Feedback

Returns virtual device image path.

Syntax
PRL_RESULT PrlVmDev_GetImagePath(
    PRL_HANDLE hVmDev,
    PRL_STR sImagePath,
    PRL_UINT32_PTR pnImagePathBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
sImagePath
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnImagePathBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetIndex Function

PrlVmDev_GetIndex Function
PrlApi.h Virtual Device Functions Send Feedback

Returns an index identifying the virtual device.

Syntax
PRL_RESULT PrlVmDev_GetIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT, PHT_VIRTUAL_DEV_NET_ADAPTER.
pnIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetOutputFile Function

PrlVmDev_GetOutputFile Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device output file.

Syntax
PRL_RESULT PrlVmDev_GetOutputFile(
    PRL_HANDLE hVmDev,
    PRL_STR sOutputFile,
    PRL_UINT32_PTR pnOutputFileBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT.
sOutputFile
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOutputFileBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetStackIndex Function

PrlVmDev_GetStackIndex Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device stack index (position at the controller (IDE or SCSI) bus).

Syntax
PRL_RESULT PrlVmDev_GetStackIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnStackIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI, PHT_VIRTUAL_DEV_GENERIC_PCI.
pnStackIndex
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetSysName Function

PrlVmDev_GetSysName Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the virtual device system name.

Syntax
PRL_RESULT PrlVmDev_GetSysName(
    PRL_HANDLE hVmDev,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sSysName
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_GetType Function

PrlVmDev_GetType Function
PrlApi.h Virtual Device Functions Send Feedback

Returns the type of the specified device.

Syntax
PRL_RESULT PrlVmDev_GetType(
    PRL_HANDLE hVmDev,
    PRL_DEVICE_TYPE_PTR pnDeviceType
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
pnDeviceType
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_IsConnected Function

PrlVmDev_IsConnected Function
PrlApi.h Virtual Device Functions Send Feedback

Checks if the specified virtual device is connected.

Syntax
PRL_RESULT PrlVmDev_IsConnected(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbConnected
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
pbConnected
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - invalid device handle or non valid (NULL) pointer to storing result, or handle of already removed VM device was passed. PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_IsEnabled Function

PrlVmDev_IsEnabled Function
PrlApi.h Virtual Device Functions Send Feedback

Determines if the specified device is enabled.

Syntax
PRL_RESULT PrlVmDev_IsEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbEnabled
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
pbEnabled
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_IsPassthrough Function

PrlVmDev_IsPassthrough Function
PrlApi.h Virtual Device Functions Send Feedback

Determines if the passthrough mode is enabled for the specified mass storage device.

Syntax
PRL_RESULT PrlVmDev_IsPassthrough(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbPassthrough
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the device. This can be one of the following: PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_HARD_DISK.
pbPassthrough
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the passthrough mode is enabled. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_IsRemote Function

PrlVmDev_IsRemote Function
PrlApi.h Virtual Device Functions Send Feedback

Determines if the specified virtual device is a remote device.

Syntax
PRL_RESULT PrlVmDev_IsRemote(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbRemote
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
pbRemote
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that this is a remote device. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_Remove Function

PrlVmDev_Remove Function
PrlApi.h Virtual Device Functions Send Feedback

Removes the specified virtual device handle from the parent virtual machine list.

Syntax
PRL_RESULT PrlVmDev_Remove(
    PRL_HANDLE hVmDev
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetConnected Function

PrlVmDev_SetConnected Function
PrlApi.h Virtual Device Functions Send Feedback

Connects the specified virtual device.

Syntax
PRL_RESULT PrlVmDev_SetConnected(
    PRL_HANDLE hVmDev,
    PRL_BOOL bConnected
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
bConnected
Value to set. PRL_TRUE to connect the device. PRL_FALSE to disconnect it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetDefaultStackIndex Function

PrlVmDev_SetDefaultStackIndex Function
PrlApi.h Virtual Device Functions Send Feedback

Automatically generates and assigns a stack index to a virtual device (a corresponding device interface, IDE or SCSI, has to be set in advance).

Syntax
PRL_RESULT PrlVmDev_SetDefaultStackIndex(
    PRL_HANDLE hVmDev
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI or PHT_VIRTUAL_DEV_GENERIC_PCI.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_NO_MORE_FREE_INTERFACE_SLOTS - there are no free slots left.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetDescription Function

PrlVmDev_SetDescription Function
PrlApi.h Virtual Device Functions See Also Send Feedback

Sets the description for a specified virtual device.

Syntax
PRL_RESULT PrlVmDev_SetDescription(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewDescription
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewDescription
The new description to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDev_GetDescription

Links
PrlApi.h, Virtual Device Functions, See Also


PrlVmDev_SetEmulatedType Function

PrlVmDev_SetEmulatedType Function
PrlApi.h Virtual Device Functions Send Feedback

Sets the specified virtual device emulation type.

Syntax
PRL_RESULT PrlVmDev_SetEmulatedType(
    PRL_HANDLE hVmDev,
    PRL_VM_DEV_EMULATION_TYPE nEmulatedType
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
nEmulatedType
The emulation type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Emulation types are defined in the PRL_VM_DEV_EMULATION_TYPE enumeration. The following describes emulation types used for different types of virtual devices:

  • PHT_VIRTUAL_DEV_FLOPPY: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_HARD_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_OPTICAL_DISK: PDT_USE_REAL_DEVICE, PDT_USE_IMAGE_FILE.
  • PHT_VIRTUAL_DEV_SERIAL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for socket mode).
  • PHT_VIRTUAL_DEV_PARALLEL_PORT: PDT_USE_REAL_DEVICE, PDT_USE_OUTPUT_FILE, PDT_USE_OTHER (for printer mode).
  • PHT_VIRTUAL_DEV_NET_ADAPTER: PDT_USE_REAL_DEVICE (host only network), PDT_USE_IMAGE_FILE (shared network). PDT_USE_OUTPUT_FILE (bridget ethernet)
  • PHT_VIRTUAL_DEV_SOUND: PDT_USE_REAL_DEVICE (AC'97), PDT_USE_IMAGE_FILE (Creative).
  • PHT_VIRTUAL_DEV_USB_DEVICE: PDT_USE_REAL_DEVICE
Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetEnabled Function

PrlVmDev_SetEnabled Function
PrlApi.h Virtual Device Functions Send Feedback

Enables the specified virtual device..

Syntax
PRL_RESULT PrlVmDev_SetEnabled(
    PRL_HANDLE hVmDev,
    PRL_BOOL bEnabled
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
bEnabled
Specify PRL_TRUE to enable the device. Specified PRL_FALSE to disable it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetFriendlyName Function

PrlVmDev_SetFriendlyName Function
PrlApi.h Virtual Device Functions Send Feedback

Sets virtual device user-friendly name.

Syntax
PRL_RESULT PrlVmDev_SetFriendlyName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewFriendlyName
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewFriendlyName
The user-friendly name to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetIfaceType Function

PrlVmDev_SetIfaceType Function
PrlApi.h Virtual Device Functions Send Feedback

Sets the virtual device interface type (IDE or SCSI).

Syntax
PRL_RESULT PrlVmDev_SetIfaceType(
    PRL_HANDLE hVmDev,
    PRL_MASS_STORAGE_INTERFACE_TYPE nIfaceType
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI.
nIfaceType
The interface type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or PMS_IDE_DEVICE for PHT_VIRTUAL_DEV_GENERIC_SCSI handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetImagePath Function

PrlVmDev_SetImagePath Function
PrlApi.h Virtual Device Functions Send Feedback

Sets the virtual device image path.

Syntax
PRL_RESULT PrlVmDev_SetImagePath(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewImagePath
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK.
sNewImagePath
The image path to set. The value must be a UTF-8 encoded, null-terminated string

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetIndex Function

PrlVmDev_SetIndex Function
PrlApi.h Virtual Device Functions Send Feedback

Sets an index identifying the virtual device.

Syntax
PRL_RESULT PrlVmDev_SetIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_FLOPPY, PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT, PHT_VIRTUAL_DEV_NET_ADAPTER.
nIndex
The new index.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetOutputFile Function

PrlVmDev_SetOutputFile Function
PrlApi.h Virtual Device Functions Send Feedback

Sets the virtual device output file.

Syntax
PRL_RESULT PrlVmDev_SetOutputFile(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewOutputFile
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_PARALLEL_PORT, PHT_VIRTUAL_DEV_SERIAL_PORT.
sNewOutputFile
Name and path of the new output file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type, or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetPassthrough Function

PrlVmDev_SetPassthrough Function
PrlApi.h Virtual Device Functions Send Feedback

Enables the passthrough mode for the specified mass storage device (optical ot hard disk).

Syntax
PRL_RESULT PrlVmDev_SetPassthrough(
    PRL_HANDLE hVmDev,
    PRL_BOOL bPassthrough
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the device. This can be one of the following: PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_HARD_DISK.
bPassthrough
Specify PRL_TRUE to enable the passthrough mode. Specify PRL_FALSE to disab;e it.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetRemote Function

PrlVmDev_SetRemote Function
PrlApi.h Virtual Device Functions Send Feedback

Changes the "remote" flag for the specified device.

Syntax
PRL_RESULT PrlVmDev_SetRemote(
    PRL_HANDLE hVmDev,
    PRL_BOOL bRemote
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
bRemote
Specify PRL_TRUE to make the device appear as remote. Specify PRL_FALSE to make the device appear as local.

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid virtual device handle or handle of already removed VM device was passed PRL_ERR_SUCCESS - operation completed successfully

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetStackIndex Function

PrlVmDev_SetStackIndex Function
PrlApi.h Virtual Device Functions Send Feedback

Sets the virtual device stack index (position at the IDE or SCSI controller bus).

Syntax
PRL_RESULT PrlVmDev_SetStackIndex(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nStackIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device. This can be one of the following: PHT_VIRTUAL_DEV_HARD_DISK, PHT_VIRTUAL_DEV_OPTICAL_DISK, PHT_VIRTUAL_DEV_GENERIC_SCSI, PHT_VIRTUAL_DEV_GENERIC_PCI.
nStackIndex
A new index to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or invalid handle type was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDev_SetSysName Function

PrlVmDev_SetSysName Function
PrlApi.h Virtual Device Functions Send Feedback

Sets virtual device system name.

Syntax
PRL_RESULT PrlVmDev_SetSysName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewSysName
);
File

PrlApi.h

Parameters

hVmDev
A handle identifying the virtual device.
sNewSysName
The new system name to set. The value must be a UTF-8 encoded, null-terminated string.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, Virtual Device Functions


PrlVmDevHd_AddPartition Function

PrlVmDevHd_AddPartition Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK Send Feedback

Assigns a boot camp partition to the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_AddPartition(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phPartition
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
phPartition
[out] A pointer to a variable that receives a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing the new partition information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When creating a virtual machine based on a boot camp partition, this function must be used to obtain a handle of type PHT_VIRTUAL_DEV_HD_PARTITION. The handle can then be used to set the system name of the boot camp partition that you would like to use.

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK


PrlVmDevHd_GetDiskSize Function

PrlVmDevHd_GetDiskSize Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Returns the hard disk size.

Syntax
PRL_RESULT PrlVmDevHd_GetDiskSize(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnDiskSize
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnDiskSize
[out] Pointer to a variable that receives the hard disk size.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_SetDiskSize

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetDiskType Function

PrlVmDevHd_GetDiskType Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Returns the hard disk type.

Syntax
PRL_RESULT PrlVmDevHd_GetDiskType(
    PRL_HANDLE hVmDev,
    PRL_HARD_DISK_INTERNAL_FORMAT_PTR pnDiskType
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnDiskType
[out] Pointer to a variable that receives the disk type.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual hard disk can be one of two types: expanding or fixed. The size of an expanding hard disk is expanded dynamically up to a predefined limit. The size of a fixed hard disk is set to the specified value at the time of creation.

See Also

PrlVmDevHd_SetDiskType

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetPartition Function

PrlVmDevHd_GetPartition Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Obtains a handle of type PHT_VIRTUAL_DEV_HD_PARTITION containing information about the specified partition of the virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetPartition(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nIndex,
    PRL_HANDLE_PTR phPartition
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nIndex
An index identifying the partition instance (beginning with 0). To get the number of partitions of the virtual hard disk, use the PrlVmDevHd_GetPartitionsCount function.
phPartition
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed, or device index out of bound.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_GetPartitionsCount

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetPartitionsCount Function

PrlVmDevHd_GetPartitionsCount Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Determines the number of partitions on the virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetPartitionsCount(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnPartitionsCount
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnPartitionsCount
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_GetPartition

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_GetSizeOnDisk Function

PrlVmDevHd_GetSizeOnDisk Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK Send Feedback

Returns the size of the occupied space on the hard disk.

Syntax
PRL_RESULT PrlVmDevHd_GetSizeOnDisk(
    PRL_HANDLE hVmDev,
    PRL_UINT32_PTR pnOnDiskSize
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pnOnDiskSize
[out] Pointer to a variable that receives the size. The size is specified in bytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK


PrlVmDevHd_IsSplitted Function

PrlVmDevHd_IsSplitted Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Determines if the virtual hard disk is split into multiple files.

Syntax
PRL_RESULT PrlVmDevHd_IsSplitted(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbSplitted
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
pbSplitted
[out] Pointer to a variable that receives the result. PRL_TRUE indicates that the disk is split into multiple files. PRL_FALSE indicates that a single file is used.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

When adding a virtual hard disk to a virtual machine, you have an option of splitting the disk into multiple files. By using this function, you can determine whether this options was used or not.

See Also

PrlVmDevHd_SetSplitted

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetDiskSize Function

PrlVmDevHd_SetDiskSize Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Sets the size of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetDiskSize(
    PRL_HANDLE hVmDev,
    PRL_UINT32 nDiskSize
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nDiskSize
The new size in megabytes.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function when adding a new virtual hard disk or when modifying the size of an existing disk.

See Also

PrlVmDevHd_GetDiskSize

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetDiskType Function

PrlVmDevHd_SetDiskType Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Sets the type of the specified virtual hard disk.

Syntax
PRL_RESULT PrlVmDevHd_SetDiskType(
    PRL_HANDLE hVmDev,
    PRL_HARD_DISK_INTERNAL_FORMAT nDiskType
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
nDiskType
The hard disk type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual hard disk can be one of the two types: expanding or fixed-size. The size of an expanding hard disk is expanded dynamically up to a predefined limit. The size of a fixed-size hard disk is set to the specified value at the time of creation. The function can be used with both new and existing virtual hard disks.

See Also

PrlVmDevHd_GetDiskType

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHd_SetSplitted Function

PrlVmDevHd_SetSplitted Function
PrlApi.h PHT_VIRTUAL_DEV_HARD_DISK See Also Send Feedback

Allows to specify whether the hard disk should be split into multiple files or if a single file should be used.

Syntax
PRL_RESULT PrlVmDevHd_SetSplitted(
    PRL_HANDLE hVmDev,
    PRL_BOOL bSplitted
);
File

PrlApi.h

Parameters

hVmDev
A valid handle of type PHT_VIRTUAL_DEV_HARD_DISK identifying the virtual hard disk.
bSplitted
Hard disk file option. Specify PRL_TRUE to split the disk into multiple files. Specify PRL_FALSE to use a single file.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHd_IsSplitted

Links
PrlApi.h, PHT_VIRTUAL_DEV_HARD_DISK, See Also


PrlVmDevHdPart_GetSysName Function

PrlVmDevHdPart_GetSysName Function
PrlApi.h PHT_VIRTUAL_DEV_HD_PARTITION See Also Send Feedback

Returns the system name of the specified disk partition.

Syntax
PRL_RESULT PrlVmDevHdPart_GetSysName(
    PRL_HANDLE hPartition,
    PRL_STR sSysName,
    PRL_UINT32_PTR pnSysNameBufLength
);
File

PrlApi.h

Parameters

hPartition
A handle of type PHT_VIRTUAL_DEV_HD_PARTITION identifying the disk partition.
sSysName
[out] A pointer to a buffer that receives the name (a UTF-8 encoded, null-terminated string).
pnSysNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHdPart_SetSysName

Links
PrlApi.h, PHT_VIRTUAL_DEV_HD_PARTITION, See Also


PrlVmDevHdPart_Remove Function

PrlVmDevHdPart_Remove Function
PrlApi.h PHT_VIRTUAL_DEV_HD_PARTITION Send Feedback

Removes the specified partition handle from the virtual hard disk list.

Syntax
PRL_RESULT PrlVmDevHdPart_Remove(
    PRL_HANDLE hPartition
);
File

PrlApi.h

Parameters

hPartition
A handle identifying the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_DEV_HD_PARTITION


PrlVmDevHdPart_SetSysName Function

PrlVmDevHdPart_SetSysName Function
PrlApi.h PHT_VIRTUAL_DEV_HD_PARTITION See Also Send Feedback

Sets system name for the specified disk partition.

Syntax
PRL_RESULT PrlVmDevHdPart_SetSysName(
    PRL_HANDLE hPartition,
    PRL_CONST_STR sSysName
);
File

PrlApi.h

Parameters

hPartition
A handle of type PHT_VIRTUAL_DEV_HD_PARTITION identifying the disk partition.
sSysName
A system name to set for the partition.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevHdPart_GetSysName

Links
PrlApi.h, PHT_VIRTUAL_DEV_HD_PARTITION, See Also


PrlVmDevNet_GenerateMacAddr Function

PrlVmDevNet_GenerateMacAddr Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER Send Feedback

Generates a unique MAC address for a virtual network adapter on a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GenerateMacAddr(
    PRL_HANDLE hVmDev
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the network adapter.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

The function will generate a new MAC address and will automatically assign it to the adapter. The function does not return the address to the caller. To retrieve the address, use the PrlVmDevNet_GetMacAddress function.

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_GetBoundAdapterIndex Function

PrlVmDevNet_GetBoundAdapterIndex Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Returns the index of the adapter to which the specified virtual adapter is bound.

Syntax
PRL_RESULT PrlVmDevNet_GetBoundAdapterIndex(
    PRL_HANDLE hVmDev,
    PRL_INT32_PTR pnIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pnIndex
[out] A pointer to a variable that receives the index. A returned value of -1 (negative one) indicates that the virtual network adapter is bound to the default adapter on the host.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to retrieve the index of the adapter from the host.

See Also

PrlVmDevNet_SetBoundAdapterIndex

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetBoundAdapterName Function

PrlVmDevNet_GetBoundAdapterName Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Returns the name of the adapter to which the specified virtual adapter is bound.

Syntax
PRL_RESULT PrlVmDevNet_GetBoundAdapterName(
    PRL_HANDLE hVmDev,
    PRL_STR sBoundAdapterName,
    PRL_UINT32_PTR pnBoundAdapterNameBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sBoundAdapterName
[out] Pointer to a buffer that receives the physical adapter name (a UTF-8 encoded, null-terminated string).
pnBoundAdapterNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to retrieve the name of the adapter from the host.

See Also

PrlVmDevNet_SetBoundAdapterName

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetDefaultGateway Function

PrlVmDevNet_GetDefaultGateway Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Obtains the default gateway assigned to a virtual network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GetDefaultGateway(
    PRL_HANDLE hVmDev,
    PRL_STR sDefaultGateway,
    PRL_UINT32_PTR pnDefaultGatewayBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sMacAddress
[out] A pointer to a buffer that receives the default gateway address (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetDefaultGateway

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetDnsServers Function

PrlVmDevNet_GetDnsServers Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Obtains the list of DNS servers which is assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetDnsServers(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phDnsServersList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phDnsServersList
[out] A pointer to the PHT_STRINGS_LIST handle that receives the list of DNS servers.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetDnsServers

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetMacAddress Function

PrlVmDevNet_GetMacAddress Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Returns the MAC address of a virtual network adapter inside a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_GetMacAddress(
    PRL_HANDLE hVmDev,
    PRL_STR sMacAddress,
    PRL_UINT32_PTR pnMacAddressBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sMacAddress
[out] Pointer to a buffer that receives the MAC address (a UTF-8 encoded, null-terminated string).
pnMacAddressBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetMacAddress

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetNetAddresses Function

PrlVmDevNet_GetNetAddresses Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Obtains a list of IP addresses in the address/subnet_mask format which is assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetNetAddresses(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phNetAddressesList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phNetAddressesList
[out] A pointer to the PHT_STRINGS_LIST handle containing the IP addresses.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Returns the list of pairs "IP address/Subnet mask" which will be applied to the network adapter on the guest OS side (on guest start or immediately on config commit if guest already working and Parallels tools with necessary functionality are installed). The result will be returned as list of strings (PHT_STRINGS_LIST type) of pairs "IP address/Subnet mask".

See Also

PrlVmDevNet_SetNetAddresses

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_GetSearchDomains Function

PrlVmDevNet_GetSearchDomains Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Obtains a lists of search domains which are assigned to a virtual network adapter on virtual machine startup.

Syntax
PRL_RESULT PrlVmDevNet_GetSearchDomains(
    PRL_HANDLE hVmDev,
    PRL_HANDLE_PTR phSearchDomainsList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
phSearchDomainsList
[out] A pointer to the PHT_STRINGS_LIST handle containing the results.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to allocate strings list object.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevNet_SetSearchDomains

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_IsConfigureWithDhcp Function

PrlVmDevNet_IsConfigureWithDhcp Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER Send Feedback

Determines if the specified network adapter is configured through DHCP on the guest OS side.

Syntax
PRL_RESULT PrlVmDevNet_IsConfigureWithDhcp(
    PRL_HANDLE hVmDev,
    PRL_BOOL_PTR pbConfigureWithDhcp
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
pbConfigureWithDhcp
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that the adapter is configured through DHCP. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetBoundAdapterIndex Function

PrlVmDevNet_SetBoundAdapterIndex Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Sets the index of the adapter to which the specified virtual adapter should be bound.

Syntax
PRL_RESULT PrlVmDevNet_SetBoundAdapterIndex(
    PRL_HANDLE hVmDev,
    PRL_INT32 nIndex
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
nIndex
The index of the adapter to which the specified virtual adapter should be bound. If you would like to bind the virtual adapter to the default adapter, specify -1 (negative one).

Returns

PRL_RESULT. Possible values: PRL_ERR_INVALID_ARG - non valid net VM device handle or handle of already removed net VM device was passed PRL_ERR_SUCCESS - operation successfully completed

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to set the index of the adapter from the host.

See Also

PrlVmDevNet_GetBoundAdapterIndex

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetBoundAdapterName Function

PrlVmDevNet_SetBoundAdapterName Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Sets the name of the network adapter to which a virtual network adapter inside a virtual machine will bind.

Syntax
PRL_RESULT PrlVmDevNet_SetBoundAdapterName(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewBoundAdapterName
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewBoundAdapterName
The name of the adapter to bind to. The adapter must exist on the host. To get the names of the available adapters from the host, use the PrlSrvCfg_GetNetAdapter function.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

In a bridged networking mode, a network adapter inside a virtual machine is bound to an adapter on the host. This function allows to set the name of the adapter to bind to.

See Also

PrlVmDevNet_GetBoundAdapterName

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetConfigureWithDhcp Function

PrlVmDevNet_SetConfigureWithDhcp Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER Send Feedback

Allows to specify whether a network adapter in a virtual machine should be configured through DHCP or manually.

Syntax
PRL_RESULT PrlVmDevNet_SetConfigureWithDhcp(
    PRL_HANDLE hVmDev,
    PRL_BOOL bConfigureWithDhcp
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
bConfigureWithDhcp
Specify PRL_TRUE to configure the adapter through DHCP. Specified PRL_FALSE to configure the network settings manually.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER


PrlVmDevNet_SetDefaultGateway Function

PrlVmDevNet_SetDefaultGateway Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Allows to manually set the default gateway address for a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetDefaultGateway(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewDefaultGateway
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewDefaultGateway
The new default gateway address. The specified string must be encoded using UTF-8 and must be terminated with the binary zero character.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetDefaultGateway

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetDnsServers Function

PrlVmDevNet_SetDnsServers Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Allows to manually assign DNS servers to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetDnsServers(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hDnsServersList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hDnsServersList
A handle of type PHT_STRINGS_LIST containing the list of DNS servers to be assigned to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetIPAddress

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetMacAddress Function

PrlVmDevNet_SetMacAddress Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Allows to manually set MAC address to a network adapter inside a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetMacAddress(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewMacAddress
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
sNewMacAddress
The new MAC address. The specified string must be encoded using UTF-8 and must be terminated with a binary zero character. The MAC address value cannot contain any delimiters. The following is an example of a valid MAC address: "001731EE6FBC".

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function if you would like to set a specific MAC address to an adapter. To generate an address and to set it to an adapter automatically, use the PrlVmDevNet_GenerateMacAddr function.

See Also

PrlVmDevNet_GetMacAddress

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetNetAddresses Function

PrlVmDevNet_SetNetAddresses Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Allows to manually set IP addresses/Subnet masks to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetNetAddresses(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hNetAddressesList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hNetAddressesList
A handle of type PHT_STRINGS_LIST containing the list of "IP address/Subnet mask" pairs to be applied to the network adapter. Can be PRL_INVALID_HANDLE if it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetIPAddress

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevNet_SetSearchDomains Function

PrlVmDevNet_SetSearchDomains Function
PrlApi.h PHT_VIRTUAL_DEV_NET_ADAPTER See Also Send Feedback

Allows to manually assign search domains to a network adapter in a virtual machine.

Syntax
PRL_RESULT PrlVmDevNet_SetSearchDomains(
    PRL_HANDLE hVmDev,
    PRL_HANDLE hSearchDomainsList
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_NET_ADAPTER identifying the virtual network adapter.
hSearchDomainsList
A handle of type PHT_STRINGS_LIST containing the list of search domains to be assigned to the network adapter. Can be PRL_INVALID_HANDLE iif it's necessary to specify an empty list.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle of virtual network adapter specified.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Note: For these changes to take effect, Parallels Tools must be installed in a target virtual machine.

If the changes are applied to a stopped virtual machine, they will take effect the next time the machine is started. If the changes are applied to a running virtual machine, they will take effect on configuration changes commit.

See Also

PrlVmDevNet_GetIPAddress

Links
PrlApi.h, PHT_VIRTUAL_DEV_NET_ADAPTER, See Also


PrlVmDevSerial_GetSocketMode Function

PrlVmDevSerial_GetSocketMode Function
PrlApi.h PHT_VIRTUAL_DEV_SERIAL_PORT See Also Send Feedback

Returns the socket mode of a virtual serial port.

Syntax
PRL_RESULT PrlVmDevSerial_GetSocketMode(
    PRL_HANDLE hVmDev,
    PRL_SERIAL_PORT_SOCKET_OPERATION_MODE_PTR pnSocketMode
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SERIAL_PORT identifying the serial port.
pnSocketMode
[out] Pointer to a variable that receives the socket mode.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function to get the socket mode when the emulation type of the port is "socket". To get the port's emulation type, use the PrlVmDev_GetEmulatedType function.

See Also

PrlVmDevSerial_SetSocketMode

Links
PrlApi.h, PHT_VIRTUAL_DEV_SERIAL_PORT, See Also


PrlVmDevSerial_SetSocketMode Function

PrlVmDevSerial_SetSocketMode Function
PrlApi.h PHT_VIRTUAL_DEV_SERIAL_PORT See Also Send Feedback

Sets the socket mode for a virtual serial port.

Syntax
PRL_RESULT PrlVmDevSerial_SetSocketMode(
    PRL_HANDLE hVmDev,
    PRL_SERIAL_PORT_SOCKET_OPERATION_MODE nSocketMode
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SERIAL_PORT identifying the serial port.
nSocketMode
The socket mode emulation type to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Use this function to set the socket mode when the emulation type of the port is "socket". To get the port's emulation type, use the PrlVmDev_GetEmulatedType function.

See Also

PrlVmDevSerial_GetSocketMode

Links
PrlApi.h, PHT_VIRTUAL_DEV_SERIAL_PORT, See Also


PrlVmDevSound_GetMixerDev Function

PrlVmDevSound_GetMixerDev Function
PrlApi.h PHT_VIRTUAL_DEV_SOUND See Also Send Feedback

Returns mixer device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_GetMixerDev(
    PRL_HANDLE hVmDev,
    PRL_STR sMixerDev,
    PRL_UINT32_PTR pnMixerDevBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sMixerDev
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnMixerDevBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_SetMixerDev

Links
PrlApi.h, PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_GetOutputDev Function

PrlVmDevSound_GetOutputDev Function
PrlApi.h PHT_VIRTUAL_DEV_SOUND See Also Send Feedback

Returns output device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_GetOutputDev(
    PRL_HANDLE hVmDev,
    PRL_STR sOutputDev,
    PRL_UINT32_PTR pnOutputDevBufLength
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sOutputDev
[out] A pointer to a buffer that receives the result (a UTF-8 encoded, null-terminated string).
pnOutputDevBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_SetOutputDev

Links
PrlApi.h, PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_SetMixerDev Function

PrlVmDevSound_SetMixerDev Function
PrlApi.h PHT_VIRTUAL_DEV_SOUND See Also Send Feedback

Sets mixer device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_SetMixerDev(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewMixerDev
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sNewMixerDev
Mixer device string to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_GetMixerDev

Links
PrlApi.h, PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevSound_SetOutputDev Function

PrlVmDevSound_SetOutputDev Function
PrlApi.h PHT_VIRTUAL_DEV_SOUND See Also Send Feedback

Sets output device string for the specified sound device.

Syntax
PRL_RESULT PrlVmDevSound_SetOutputDev(
    PRL_HANDLE hVmDev,
    PRL_CONST_STR sNewOutputDev
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_SOUND identifying the sound device.
sNewOutputDev
Output device string to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevSound_GetOutputDev

Links
PrlApi.h, PHT_VIRTUAL_DEV_SOUND, See Also


PrlVmDevUsb_GetAutoconnectOption Function

PrlVmDevUsb_GetAutoconnectOption Function
PrlApi.h PHT_VIRTUAL_DEV_USB_DEVICE See Also Send Feedback

Obtains USB controller autoconnect device option.

Syntax
PRL_RESULT PrlVmDevUsb_GetAutoconnectOption(
    PRL_HANDLE hVmDev,
    PRL_USB_DEVICE_AUTO_CONNECT_OPTION_PTR pnAutoconnectOption
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_USB_DEVICE identifying the USB device.
pnAutoconnectOption
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevUsb_SetAutoconnectOption

Links
PrlApi.h, PHT_VIRTUAL_DEV_USB_DEVICE, See Also


PrlVmDevUsb_SetAutoconnectOption Function

PrlVmDevUsb_SetAutoconnectOption Function
PrlApi.h PHT_VIRTUAL_DEV_USB_DEVICE See Also Send Feedback

Sets USB controller autoconnect device option.

Syntax
PRL_RESULT PrlVmDevUsb_SetAutoconnectOption(
    PRL_HANDLE hVmDev,
    PRL_USB_DEVICE_AUTO_CONNECT_OPTION nAutoconnectOption
);
File

PrlApi.h

Parameters

hVmDev
A handle of type PHT_VIRTUAL_DEV_USB_DEVICE identifying the USB device.
nAutoconnectOption
Autoconnect option to set.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVmDevUsb_GetAutoconnectOption

Links
PrlApi.h, PHT_VIRTUAL_DEV_USB_DEVICE, See Also


PrlVmGuest_GetNetworkSettings Function

PrlVmGuest_GetNetworkSettings Function
PrlApi.h PHT_VM_GUEST_SESSION Send Feedback

Obtains network settings of an operating system running on a virtual machine.

Syntax
PRL_HANDLE PrlVmGuest_GetNetworkSettings(
    PRL_HANDLE hVmGuest,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
nReserved
Reserved parameter for future purposes. Must be 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

The network settings are obtained using a user session in the guest operating system. Prior to calling this function, a handle to a user session in the virtual machine must be obtained using the PrlVm_LoginInGuest function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed. PRL_ERR_SUCCESS - function completed successfully.

To get the results from the returned PHT_JOB object, use the following steps:

  1. Use the PrlJob_GetResult function to obtain a handle of type PHT_RESULT.
  2. Use the PrlResult_GetParam function to obtain a handle of type PHT_SERVER_CONFIG. The handle will contain the guest OS network settings.

Once you obtain the PHT_SERVER_CONFIG handle, you can use the following functions to obtain individual network settings of the guest OS:

PrlSrvCfg_GetDnsServers

PrlSrvCfg_GetHostname

PrlSrvCfg_GetSearchDomains

PrlSrvCfg_GetNetAdaptersCount, PrlSrvCfg_GetNetAdapter

Links
PrlApi.h, PHT_VM_GUEST_SESSION


PrlVmGuest_Logout Function

PrlVmGuest_Logout Function
PrlApi.h PHT_VM_GUEST_SESSION See Also Send Feedback

Closes a session (or unbinds from a pre-existing session) in a virtual machine that was previously opened with the PrlVm_LoginInGuest function.

Syntax
PRL_HANDLE PrlVmGuest_Logout(
    PRL_HANDLE hVmGuest,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the session.
nReserved
Reserved parameter for future purposes. Must contain 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_LoginInGuest

Links
PrlApi.h, PHT_VM_GUEST_SESSION, See Also


PrlVmGuest_RunProgram Function

PrlVmGuest_RunProgram Function
PrlApi.h PHT_VM_GUEST_SESSION Send Feedback

Executes a program in a virtual machine.

Syntax
PRL_HANDLE PrlVmGuest_RunProgram(
    PRL_HANDLE hVmGuest,
    PRL_CONST_STR sAppName,
    PRL_HANDLE hArgsList,
    PRL_HANDLE hEnvsList,
    PRL_UINT32 nFlags
);
File

PrlApi.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
sAppName
An absolute path to the program that you would like to execute.
hArgsList
A handle of type PHT_STRINGS_LIST specifying the list of arguments to pass to the program. Each token must be a separate list item.
hEnvsList
A handle of type PHT_STRINGS_LIST specifying the list of environment variables to add to the program execution environment. Each variable must be a separate list item in the var_name=var_value format.
nFlags
Modificators of the program execution. Acceptable values:

PFD_STDOUT - return stdout.

PFD_STDERR - return stderr.

PFD_ALL - return both stdout and stderr (a blank nFlags parameter yields the same result).

PRPM_RUN_PROGRAM_AND_RETURN_IMMEDIATELY - run the program and return immediately without waiting for the program execution results.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Prior to calling this function, a handle to a user session in a virtual machine must be obtained using the PrlVm_LoginInGuest function. Once you obtain a session handle, you can use this function to run programs in the virtual machine. Depending on the options that were used during login, you will be able to run GUI applications and/or console programs. See the PrlVm_LoginInGuest function for more info.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_VM_EXEC_PROGRAM_NOT_FOUND - the specified program at the specified path was not found.

PRL_ERR_SUCCESS - program executed successfully.

Links
PrlApi.h, PHT_VM_GUEST_SESSION


PrlVmGuest_SetUserPasswd Function

PrlVmGuest_SetUserPasswd Function
PrlApi.h PHT_VM_GUEST_SESSION See Also Send Feedback

Allows to change the password of a guest operating system user.

Syntax
PRL_HANDLE PrlVmGuest_SetUserPasswd(
    PRL_HANDLE hVmGuest,
    PRL_CONST_STR sUserName,
    PRL_CONST_STR sUserPasswd,
    PRL_UINT32 nReserved
);
File

PrlApi.h

Parameters

hVmGuest
A handle of type PHT_VM_GUEST_SESSION identifying the user session in a virtual machine. The handle is obtained using the PrlVm_LoginInGuest function.
sUserName
Guest operating system user name. Can be null or empty string when setting the administrator password.
sUserPasswd
New password. Can be null when setting an empty password.
nReserved
Reserved parameter for future purposes. Must be 0 in the current implementation.

Returns

A handle of type PHT_JOB containing the results of this asynchronous operation or PRL_INVALID_HANDLE if there's not enough memory to instantiate the job object.

Remarks

Prior to calling this function, a handle to a user session in a virtual machine must be obtained using the PrlVm_LoginInGuest function.

To get the return code from the PHT_JOB object, use the PrlJob_GetRetCode function. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle was passed.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_LoginInGuest

Links
PrlApi.h, PHT_VM_GUEST_SESSION, See Also


PrlVmInfo_GetAccessRights Function

PrlVmInfo_GetAccessRights Function
PrlApi.h PHT_VM_INFO Send Feedback

Obtains a handle of type PHT_ACCESS_RIGHTS.

Syntax
PRL_RESULT PrlVmInfo_GetAccessRights(
    PRL_HANDLE hVmInfo,
    PRL_HANDLE_PTR phVmAcl
);
File

PrlApi.h

Parameters

hVmInfo
A handle of type PHT_VM_INFO.
phVmAcl
[out] A pointer to a variable that receives the handle.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_OUT_OF_MEMORY - not enough memory to create PHT_ACCESS_RIGHTS object.

PRL_ERR_NO_DATA - the virtual machine access rights information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_INFO


PrlVmInfo_GetState Function

PrlVmInfo_GetState Function
PrlApi.h PHT_VM_INFO Send Feedback

Returns the virtual machine state information.

Syntax
PRL_RESULT PrlVmInfo_GetState(
    PRL_HANDLE handle,
    VIRTUAL_MACHINE_STATE_PTR pVmState
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmState
[out] A pointer to a variable that receives the virtual machine state information.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the virtual machine state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_INFO


PrlVmInfo_IsInvalid Function

PrlVmInfo_IsInvalid Function
PrlApi.h PHT_VM_INFO Send Feedback

Determines if the specified virtual machine is invalid.

Syntax
PRL_RESULT PrlVmInfo_IsInvalid(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsInvalid
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VM_INFO.
pVmIsInvalid
[out] A pointer to a variable that receives result. PRL_TRUE - the virtual machine is invalid. PRL_FALSE - the virtual machine is fully operational.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the status of the virtual machine cannot be determined.

RL_ERR_SUCCESS - function completed successfully.

Remarks

A virtual machine can be reported as invalid by the function if its configuration has been corrupted, it's been removed from the virtual machine, and for other similar reasons.

Links
PrlApi.h, PHT_VM_INFO


PrlVmInfo_IsVncServerStarted Function

PrlVmInfo_IsVncServerStarted Function
PrlApi.h PHT_VM_INFO See Also Send Feedback

Determines whether a VNC server is running for the specified virtual machine.

Syntax
PRL_RESULT PrlVmInfo_IsVncServerStarted(
    PRL_HANDLE handle,
    PRL_BOOL_PTR pbIsVncServerStarted
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VM_INFO.
pbIsVncServerStarted
[out] A pointer to a variable that receives the result. PRL_TRUE indicates that a VNC server is running. PRL_FALSE indicates otherwise.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the VNC server state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

See Also

PrlVm_StartVncServer

PrlVm_StopVncServer

Links
PrlApi.h, PHT_VM_INFO, See Also


PrlVmToolsInfo_GetState Function

PrlVmToolsInfo_GetState Function
PrlApi.h PHT_VM_TOOLS_INFO Send Feedback

Returns the Parallels Tools package state information.

Syntax
PRL_RESULT PrlVmToolsInfo_GetState(
    PRL_HANDLE handle,
    PRL_VM_TOOLS_STATE_PTR pVmToolsState
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VM_TOOLS_INFO.
pVmToolsState
[out] A pointer to a variable that receives the result.

Returns

PRL_RESULT. Possible values:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_NO_DATA - the Parallels Tools package state information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Links
PrlApi.h, PHT_VM_TOOLS_INFO


PrlVmToolsInfo_GetVersion Function

PrlVmToolsInfo_GetVersion Function
PrlApi.h PHT_VM_TOOLS_INFO Send Feedback

Returns version information of the Parallels Tools package installed in a given virtual machine.

Syntax
PRL_RESULT PrlVmToolsInfo_GetVersion(
    PRL_HANDLE handle,
    PRL_STR sName,
    PRL_UINT32_PTR pnNameBufLength
);
File

PrlApi.h

Parameters

handle
A handle of type PHT_VM_TOOLS_INFO.
sName
[out] A pointer to a buffer that receives the version information (a UTF-8 encoded, null-terminated string).
pnNameBufLength
[in] The size of the output buffer (in bytes). Set the buffer pointer to null and this parameter's value to zero to receive the required size. [out] The required output buffer size.

Returns

PRL_RESULT. Possible values are:

PRL_ERR_INVALID_ARG - invalid handle or null pointer was passed.

PRL_ERR_BUFFER_OVERRUN - the size of the output buffer is not large enough. The parameter that is used to specify the size will contain the required size.

PRL_ERR_NO_DATA - the Parallels Tools package version information is not available.

PRL_ERR_SUCCESS - function completed successfully.

Remarks

Before calling this function, make sure that the Parallels Tools package is installed in the virtual machine by calling the PrlVmToolsInfo_GetState function.

Links
PrlApi.h, PHT_VM_TOOLS_INFO


PVM_GET_MIGRATION_SECURITY_LEVEL Macro

PVM_GET_MIGRATION_SECURITY_LEVEL Macro
PrlEnums.h Other Macros Send Feedback

Macro for extracting VM migration security level value from flags mask

Syntax
#define PVM_GET_MIGRATION_SECURITY_LEVEL(flags) (PRL_SECURITY_LEVEL)((flags&0x00000018)>>3)
File

PrlEnums.h

Links
PrlEnums.h, Other Macros


PVM_GET_MIGRATION_TYPE Macro

PVM_GET_MIGRATION_TYPE Macro
PrlEnums.h Other Macros Send Feedback

Macro for extracting VM migration type value from flags mask

Syntax
#define PVM_GET_MIGRATION_TYPE(flags) (PRL_VM_MIGRATION_TYPE)(flags&0x00000007)
File

PrlEnums.h

Links
PrlEnums.h, Other Macros


PVS_GET_GUEST_NUMBER Macro

PVS_GET_GUEST_NUMBER Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define PVS_GET_GUEST_NUMBER(v) (v & 0xff)
File

PrlOses.h

Links
PrlOses.h, Other Macros


PVS_GET_GUEST_TYPE Macro

PVS_GET_GUEST_TYPE Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define PVS_GET_GUEST_TYPE(v) ((v >> 8) & 0xff)
File

PrlOses.h

Links
PrlOses.h, Other Macros


PVS_GUEST_ARCH_I386 Macro

PVS_GUEST_ARCH_I386 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_ARCH_I386 (1)
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_ARCH_OTHER Macro

PVS_GUEST_ARCH_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Autodetected OS Architecture

Syntax
#define PVS_GUEST_ARCH_OTHER (0)
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_ARCH_X86_64 Macro

PVS_GUEST_ARCH_X86_64 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_ARCH_X86_64 (2)
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_FREEBSD Macro

PVS_GUEST_TYPE_FREEBSD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_FREEBSD 0x0A
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_LINUX Macro

PVS_GUEST_TYPE_LINUX Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_LINUX 0x09
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_MACOS Macro

PVS_GUEST_TYPE_MACOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Guest OS types enumeration

Syntax
#define PVS_GUEST_TYPE_MACOS 0x07
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_MSDOS Macro

PVS_GUEST_TYPE_MSDOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_MSDOS 0x0C
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_FREEBSD Macro

PVS_GUEST_TYPE_NAME_FREEBSD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_FREEBSD "FreeBSD"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_LINUX Macro

PVS_GUEST_TYPE_NAME_LINUX Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_LINUX "Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_MACOS Macro

PVS_GUEST_TYPE_NAME_MACOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Guest OS type names

Syntax
#define PVS_GUEST_TYPE_NAME_MACOS "Mac OS X"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_MSDOS Macro

PVS_GUEST_TYPE_NAME_MSDOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_MSDOS "MS-DOS"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_NETWARE Macro

PVS_GUEST_TYPE_NAME_NETWARE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_NETWARE "NetWare"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_OS2 Macro

PVS_GUEST_TYPE_NAME_OS2 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_OS2 "OS/2"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_OTHER Macro

PVS_GUEST_TYPE_NAME_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_OTHER "Other"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_SOLARIS Macro

PVS_GUEST_TYPE_NAME_SOLARIS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_SOLARIS "Solaris"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NAME_WINDOWS Macro

PVS_GUEST_TYPE_NAME_WINDOWS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NAME_WINDOWS "Windows"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_NETWARE Macro

PVS_GUEST_TYPE_NETWARE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_NETWARE 0x0D
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_OS2 Macro

PVS_GUEST_TYPE_OS2 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_OS2 0x0B
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_OTHER Macro

PVS_GUEST_TYPE_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_OTHER 0xFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_SOLARIS Macro

PVS_GUEST_TYPE_SOLARIS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_SOLARIS 0x0E
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_TYPE_WINDOWS Macro

PVS_GUEST_TYPE_WINDOWS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_TYPE_WINDOWS 0x08
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_4X Macro

PVS_GUEST_VER_BSD_4X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_BSD_4X 0x0A01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_5X Macro

PVS_GUEST_VER_BSD_5X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_BSD_5X 0x0A02
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_6X Macro

PVS_GUEST_VER_BSD_6X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_BSD_6X 0x0A03
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_7X Macro

PVS_GUEST_VER_BSD_7X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_BSD_7X 0x0A04
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_LAST Macro

PVS_GUEST_VER_BSD_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_BSD_LAST

Syntax
#define PVS_GUEST_VER_BSD_LAST PVS_GUEST_VER_BSD_7X
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_BSD_OTHER Macro

PVS_GUEST_VER_BSD_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_BSD_OTHER 0x0AFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_DOS_LAST Macro

PVS_GUEST_VER_DOS_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_DOS_LAST

Syntax
#define PVS_GUEST_VER_DOS_LAST PVS_GUEST_VER_DOS_MS622
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_DOS_MS622 Macro

PVS_GUEST_VER_DOS_MS622 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_DOS_MS622 0x0C01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_DOS_OTHER Macro

PVS_GUEST_VER_DOS_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_DOS_OTHER 0x0CFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_CENTOS Macro

PVS_GUEST_VER_LIN_CENTOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_CENTOS 0x090D
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_DEBIAN Macro

PVS_GUEST_VER_LIN_DEBIAN Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_DEBIAN 0x0906
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_FEDORA Macro

PVS_GUEST_VER_LIN_FEDORA Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_FEDORA 0x0907
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_FEDORA_5 Macro

PVS_GUEST_VER_LIN_FEDORA_5 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_FEDORA_5 0x0908
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_KRNL_24 Macro

PVS_GUEST_VER_LIN_KRNL_24 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_KRNL_24 0x0904
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_KRNL_26 Macro

PVS_GUEST_VER_LIN_KRNL_26 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_KRNL_26 0x0905
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_LAST Macro

PVS_GUEST_VER_LIN_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_LIN_LAST

Syntax
#define PVS_GUEST_VER_LIN_LAST PVS_GUEST_VER_LIN_OPENSUSE
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_MANDRAKE Macro

PVS_GUEST_VER_LIN_MANDRAKE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_MANDRAKE 0x0903
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_OPENSUSE Macro

PVS_GUEST_VER_LIN_OPENSUSE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_OPENSUSE 0x090F
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_OTHER Macro

PVS_GUEST_VER_LIN_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_OTHER 0x09FF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_REDHAT Macro

PVS_GUEST_VER_LIN_REDHAT Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_REDHAT 0x0901
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_RH_LEGACY Macro

PVS_GUEST_VER_LIN_RH_LEGACY Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_RH_LEGACY 0x090E
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_RHLES3 Macro

PVS_GUEST_VER_LIN_RHLES3 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_RHLES3 0x090C
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_SLES9 Macro

PVS_GUEST_VER_LIN_SLES9 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_SLES9 0x090B
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_SUSE Macro

PVS_GUEST_VER_LIN_SUSE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_SUSE 0x0902
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_UBUNTU Macro

PVS_GUEST_VER_LIN_UBUNTU Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_UBUNTU 0x090A
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_LIN_XANDROS Macro

PVS_GUEST_VER_LIN_XANDROS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_LIN_XANDROS 0x0909
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_MACOS_LAST Macro

PVS_GUEST_VER_MACOS_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_MACOS_LAST

Syntax
#define PVS_GUEST_VER_MACOS_LAST PVS_GUEST_VER_MACOS_SNOW_LEOPARD
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_MACOS_LEOPARD Macro

PVS_GUEST_VER_MACOS_LEOPARD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_MACOS_LEOPARD 0x0702
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_MACOS_SNOW_LEOPARD Macro

PVS_GUEST_VER_MACOS_SNOW_LEOPARD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_MACOS_SNOW_LEOPARD 0x0703
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_MACOS_TIGER Macro

PVS_GUEST_VER_MACOS_TIGER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_MACOS_TIGER 0x0701
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_4X Macro

PVS_GUEST_VER_NAME_BSD_4X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_BSD_4X "FreeBSD 4.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_5X Macro

PVS_GUEST_VER_NAME_BSD_5X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_BSD_5X "FreeBSD 5.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_6X Macro

PVS_GUEST_VER_NAME_BSD_6X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_BSD_6X "FreeBSD 6.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_7X Macro

PVS_GUEST_VER_NAME_BSD_7X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_BSD_7X "FreeBSD 7.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_BSD_OTHER Macro

PVS_GUEST_VER_NAME_BSD_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_BSD_OTHER "Other FreeBSD"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_DOS_MS622 Macro

PVS_GUEST_VER_NAME_DOS_MS622 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_DOS_MS622 "MS-DOS 6.22"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_DOS_OTHER Macro

PVS_GUEST_VER_NAME_DOS_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_DOS_OTHER "Other DOS"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_CENTOS Macro

PVS_GUEST_VER_NAME_LIN_CENTOS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_CENTOS "CentOS Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_DEBIAN Macro

PVS_GUEST_VER_NAME_LIN_DEBIAN Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_DEBIAN "Debian GNU/Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_FEDORA Macro

PVS_GUEST_VER_NAME_LIN_FEDORA Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_FEDORA "Fedora Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_FEDORA_5 Macro

PVS_GUEST_VER_NAME_LIN_FEDORA_5 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_FEDORA_5 "Fedora Core 5 Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_KRNL_24 Macro

PVS_GUEST_VER_NAME_LIN_KRNL_24 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_KRNL_24 "Other Linux kernel 2.4"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_KRNL_26 Macro

PVS_GUEST_VER_NAME_LIN_KRNL_26 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_KRNL_26 "Other Linux kernel 2.6"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_MANDRAKE Macro

PVS_GUEST_VER_NAME_LIN_MANDRAKE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_MANDRAKE "Mandriva Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_OPENSUSE Macro

PVS_GUEST_VER_NAME_LIN_OPENSUSE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_OPENSUSE "OpenSUSE Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_OTHER Macro

PVS_GUEST_VER_NAME_LIN_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_OTHER "Other Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_REDHAT Macro

PVS_GUEST_VER_NAME_LIN_REDHAT Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_REDHAT "Red Hat Enterprise Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_RH_LEGACY Macro

PVS_GUEST_VER_NAME_LIN_RH_LEGACY Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_RH_LEGACY "Red Hat Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_RHLES3 Macro

PVS_GUEST_VER_NAME_LIN_RHLES3 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_RHLES3 "Red Hat Enterprise Server 3"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_SLES9 Macro

PVS_GUEST_VER_NAME_LIN_SLES9 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_SLES9 "SUSE Linux Enterprise Server 9"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_SUSE Macro

PVS_GUEST_VER_NAME_LIN_SUSE Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_SUSE "SUSE Linux Enterprise"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_UBUNTU Macro

PVS_GUEST_VER_NAME_LIN_UBUNTU Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_UBUNTU "Ubuntu Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_LIN_XANDROS Macro

PVS_GUEST_VER_NAME_LIN_XANDROS Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_LIN_XANDROS "Xandros Linux"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_LEOPARD Macro

PVS_GUEST_VER_NAME_MACOS_LEOPARD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_MACOS_LEOPARD "Mac OS X Server v10.5"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD Macro

PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_MACOS_SNOW_LEOPARD "Snow Leopard Server (experimental)"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_MACOS_TIGER Macro

PVS_GUEST_VER_NAME_MACOS_TIGER Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Guest OS version names

Syntax
#define PVS_GUEST_VER_NAME_MACOS_TIGER "Mac OS X Server v10.4"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_4X Macro

PVS_GUEST_VER_NAME_NET_4X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_NET_4X "NetWare 4.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_5X Macro

PVS_GUEST_VER_NAME_NET_5X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_NET_5X "NetWare 5.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_6X Macro

PVS_GUEST_VER_NAME_NET_6X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_NET_6X "NetWare 6.x"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_NET_OTHER Macro

PVS_GUEST_VER_NAME_NET_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_NET_OTHER "Other NetWare"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_ECS11 Macro

PVS_GUEST_VER_NAME_OS2_ECS11 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_ECS11 "eComStation 1.1"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_ECS12 Macro

PVS_GUEST_VER_NAME_OS2_ECS12 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_ECS12 "eComStation 1.2"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_OTHER Macro

PVS_GUEST_VER_NAME_OS2_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_OTHER "Other OS/2"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP3 Macro

PVS_GUEST_VER_NAME_OS2_WARP3 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP3 "OS/2 Warp 3"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP4 Macro

PVS_GUEST_VER_NAME_OS2_WARP4 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP4 "OS/2 Warp 4"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OS2_WARP45 Macro

PVS_GUEST_VER_NAME_OS2_WARP45 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OS2_WARP45 "OS/2 Warp 4.5"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_OPENSTEP Macro

PVS_GUEST_VER_NAME_OTH_OPENSTEP Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OTH_OPENSTEP "OpenStep"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_OTHER Macro

PVS_GUEST_VER_NAME_OTH_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OTH_OTHER "Other"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_OTH_QNX Macro

PVS_GUEST_VER_NAME_OTH_QNX Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_OTH_QNX "QNX"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_9 Macro

PVS_GUEST_VER_NAME_SOL_9 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_SOL_9 "Solaris 9"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_10 Macro

PVS_GUEST_VER_NAME_SOL_10 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_SOL_10 "Solaris 10"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_11 Macro

PVS_GUEST_VER_NAME_SOL_11 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_SOL_11 "Solaris 11"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_SOL_OTHER Macro

PVS_GUEST_VER_NAME_SOL_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_SOL_OTHER "Other Solaris"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2K Macro

PVS_GUEST_VER_NAME_WIN_2K Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_2K "Windows 2000"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_95 Macro

PVS_GUEST_VER_NAME_WIN_95 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_95 "Windows 95"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_98 Macro

PVS_GUEST_VER_NAME_WIN_98 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_98 "Windows 98"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_311 Macro

PVS_GUEST_VER_NAME_WIN_311 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_311 "Windows 3.11"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2003 Macro

PVS_GUEST_VER_NAME_WIN_2003 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_2003 "Windows Server 2003"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_2008 Macro

PVS_GUEST_VER_NAME_WIN_2008 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_2008 "Windows Server 2008"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_ME Macro

PVS_GUEST_VER_NAME_WIN_ME Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_ME "Windows ME"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_NT Macro

PVS_GUEST_VER_NAME_WIN_NT Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_NT "Windows NT"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_OTHER Macro

PVS_GUEST_VER_NAME_WIN_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_OTHER "Other Windows"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_VISTA Macro

PVS_GUEST_VER_NAME_WIN_VISTA Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_VISTA "Windows Vista"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_WINDOWS7 Macro

PVS_GUEST_VER_NAME_WIN_WINDOWS7 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_WINDOWS7 "Windows 7 (experimental)"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NAME_WIN_XP Macro

PVS_GUEST_VER_NAME_WIN_XP Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NAME_WIN_XP "Windows XP"
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NET_4X Macro

PVS_GUEST_VER_NET_4X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NET_4X 0x0D01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NET_5X Macro

PVS_GUEST_VER_NET_5X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NET_5X 0x0D02
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NET_6X Macro

PVS_GUEST_VER_NET_6X Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NET_6X 0x0D03
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NET_LAST Macro

PVS_GUEST_VER_NET_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_NET_LAST

Syntax
#define PVS_GUEST_VER_NET_LAST PVS_GUEST_VER_NET_6X
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_NET_OTHER Macro

PVS_GUEST_VER_NET_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_NET_OTHER 0x0DFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_ECS11 Macro

PVS_GUEST_VER_OS2_ECS11 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_ECS11 0x0B04
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_ECS12 Macro

PVS_GUEST_VER_OS2_ECS12 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_ECS12 0x0B05
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_LAST Macro

PVS_GUEST_VER_OS2_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_OS2_LAST

Syntax
#define PVS_GUEST_VER_OS2_LAST PVS_GUEST_VER_OS2_ECS12
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_OTHER Macro

PVS_GUEST_VER_OS2_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_OTHER 0x0BFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP3 Macro

PVS_GUEST_VER_OS2_WARP3 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_WARP3 0x0B01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP4 Macro

PVS_GUEST_VER_OS2_WARP4 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_WARP4 0x0B02
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OS2_WARP45 Macro

PVS_GUEST_VER_OS2_WARP45 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OS2_WARP45 0x0B03
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OTH_LAST Macro

PVS_GUEST_VER_OTH_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_OTH_LAST

Syntax
#define PVS_GUEST_VER_OTH_LAST PVS_GUEST_VER_OTH_OPENSTEP
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OTH_OPENSTEP Macro

PVS_GUEST_VER_OTH_OPENSTEP Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OTH_OPENSTEP 0xFF02
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OTH_OTHER Macro

PVS_GUEST_VER_OTH_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OTH_OTHER 0xFFFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_OTH_QNX Macro

PVS_GUEST_VER_OTH_QNX Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_OTH_QNX 0xFF01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_SOL_9 Macro

PVS_GUEST_VER_SOL_9 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_SOL_9 0x0E01
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_SOL_10 Macro

PVS_GUEST_VER_SOL_10 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_SOL_10 0x0E02
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_SOL_11 Macro

PVS_GUEST_VER_SOL_11 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_SOL_11 0x0E03
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_SOL_LAST Macro

PVS_GUEST_VER_SOL_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_SOL_LAST

Syntax
#define PVS_GUEST_VER_SOL_LAST PVS_GUEST_VER_SOL_11
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_SOL_OTHER Macro

PVS_GUEST_VER_SOL_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_SOL_OTHER 0x0EFF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_2K Macro

PVS_GUEST_VER_WIN_2K Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_2K 0x0806
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_95 Macro

PVS_GUEST_VER_WIN_95 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_95 0x0802
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_98 Macro

PVS_GUEST_VER_WIN_98 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_98 0x0803
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_311 Macro

PVS_GUEST_VER_WIN_311 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_311 0x0801
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_2003 Macro

PVS_GUEST_VER_WIN_2003 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_2003 0x0808
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_2008 Macro

PVS_GUEST_VER_WIN_2008 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_2008 0x080A
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_LAST Macro

PVS_GUEST_VER_WIN_LAST Macro
PrlOses.h PVS_GUEST Macros Send Feedback

Add here a new OS version and assign it to PVS_GUEST_VER_WIN_LAST

Syntax
#define PVS_GUEST_VER_WIN_LAST PVS_GUEST_VER_WIN_WINDOWS7
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_ME Macro

PVS_GUEST_VER_WIN_ME Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_ME 0x0804
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_NT Macro

PVS_GUEST_VER_WIN_NT Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_NT 0x0805
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_OTHER Macro

PVS_GUEST_VER_WIN_OTHER Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_OTHER 0x08FF
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_VISTA Macro

PVS_GUEST_VER_WIN_VISTA Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_VISTA 0x0809
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_WINDOWS7 Macro

PVS_GUEST_VER_WIN_WINDOWS7 Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_WINDOWS7 0x080B
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_GUEST_VER_WIN_XP Macro

PVS_GUEST_VER_WIN_XP Macro
PrlOses.h PVS_GUEST Macros Send Feedback
Syntax
#define PVS_GUEST_VER_WIN_XP 0x0807
File

PrlOses.h

Links
PrlOses.h, PVS_GUEST Macros


PVS_MAKE_GUEST_VER Macro

PVS_MAKE_GUEST_VER Macro
PrlOses.h Other Macros Send Feedback
Syntax
#define PVS_MAKE_GUEST_VER(t,n) (((t << 8) & 0xff00) | (n & 0xff))
File

PrlOses.h

Links
PrlOses.h, Other Macros


SET_FS_EXECUTE_DISABLED Macro

SET_FS_EXECUTE_DISABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_EXECUTE_DISABLED(x) (x) & ~FS_PERM_EXECUTE;
File

PrlFs.h

Links
PrlFs.h, Other Macros


SET_FS_EXECUTE_ENABLED Macro

SET_FS_EXECUTE_ENABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_EXECUTE_ENABLED(x) (x) | FS_PERM_EXECUTE;
File

PrlFs.h

Links
PrlFs.h, Other Macros


SET_FS_READ_DISABLED Macro

SET_FS_READ_DISABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_READ_DISABLED(x) (x) & ~FS_PERM_READ;
File

PrlFs.h

Links
PrlFs.h, Other Macros


SET_FS_READ_ENABLED Macro

SET_FS_READ_ENABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_READ_ENABLED(x) (x) | FS_PERM_READ;
File

PrlFs.h

Links
PrlFs.h, Other Macros


SET_FS_WRITE_DISABLED Macro

SET_FS_WRITE_DISABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_WRITE_DISABLED(x) (x) & ~FS_PERM_WRITE;
File

PrlFs.h

Links
PrlFs.h, Other Macros


SET_FS_WRITE_ENABLED Macro

SET_FS_WRITE_ENABLED Macro
PrlFs.h Other Macros Send Feedback
Syntax
#define SET_FS_WRITE_ENABLED(x) (x) | FS_PERM_WRITE;
File

PrlFs.h

Links
PrlFs.h, Other Macros


TO_PARALLELS_API_VER Macro

TO_PARALLELS_API_VER Macro
PrlApi.h Other Macros Send Feedback
Syntax
#define TO_PARALLELS_API_VER(majorV, minorV) \
     ((PRL_UINT32)(((PRL_UINT32)majorV) << 16 | ((PRL_UINT16)minorV)))
File

PrlApi.h

Links
PrlApi.h, Other Macros


VIRTUAL_MACHINE_STATE Enumeration

VIRTUAL_MACHINE_STATE Enumeration
PrlEnums.h Other Structs Send Feedback

Virtual machine states enumeration

Syntax
typedef enum _VIRTUAL_MACHINE_STATE {
  VMS_UNKNOWN = 0,
  VMS_STOPPED = 0x30000001,
  VMS_STARTING = 0x30000002,
  VMS_RESTORING = 0x30000003,
  VMS_RUNNING = 0x30000004,
  VMS_PAUSED = 0x30000005,
  VMS_SUSPENDING = 0x30000006,
  VMS_STOPPING = 0x30000007,
  VMS_COMPACTING = 0x30000008,
  VMS_SUSPENDED = 0x30000009,
  VMS_SNAPSHOTING = 0x3000000A,
  VMS_RESETTING = 0x3000000B,
  VMS_PAUSING = 0x3000000C,
  VMS_CONTINUING = 0x3000000D,
  VMS_MIGRATING = 0x3000000E,
  VMS_DELETING_STATE = 0x3000000F,
  VMS_RESUMING = 0x30000010
} VIRTUAL_MACHINE_STATE;
File

PrlEnums.h

Links
PrlEnums.h, Other Structs


VIRTUAL_MACHINE_STATE_PTR Type

VIRTUAL_MACHINE_STATE_PTR Type
PrlEnums.h Other Types Send Feedback
Syntax
typedef VIRTUAL_MACHINE_STATE* VIRTUAL_MACHINE_STATE_PTR;
File

PrlEnums.h

Links
PrlEnums.h, Other Types