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Congratulations on purchasing Parallels Workstation. Now you can create virtual machines, install 
different operating systems, and use them simultaneously on your computer. 

Use this guide to quickly set up and start using Parallels Workstation. 
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Welcome to Parallels Workstation 
 

What You Can Do 
With Parallels Workstation, you can: 

• Install and use 32-bit and 64-bit guest operating systems on your host computer 

• Easily share files, devices, and other resources between operating systems 

• Run host OS and Windows guest OS programs seamlessly on one desktop 

• Copy and paste text and drag and drop objects between host OS and guest OS programs 

• Transfer the operating system and all your data from a remote Windows or Linux computer and 
use them on your host computer 

• If you have Parallels Workstation Extreme and your computer supports Intel VT-d, assign 
physical PCI Express (PCIe) devices directly to virtual machines 

• And much more 
 



 

 

Follow the instructions in this chapter to install and configure Parallels Workstation. 
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What You Need 
To install and set up Parallels Workstation 6, your computer must meet the hardware and software 
requirements listed below: 

Hardware Requirements 

• Minimum 1.66 GHz x86 (32-bit) or x64 (64-bit) CPU. 

To run 64-bit guest operating systems, you need a processor that supports the Intel VT-x 
hardware virtualization technology. 

To assign PCI Express (PCIe) devices directly to your virtual machines, you need a processor 
that supports the Intel VT-d technology. 

The support for Intel VT-x and VT-d may be disabled by default in some computers that actually 
support them. To enable these features, in most cases enter BIOS, go to System Settings > 
Virtualization Support, and select the Enable Intel Virtualization and Enable Intel VT for 
Direct I/O check boxes. 

For detailed information on enabling the Intel VT-x and VT-d features in BIOS, refer to the OEM 
supplier's documentation. 

• 2 GB RAM minimum. 4 GB RAM or more is recommended. 

The recommended amount of memory assigned to a virtual machine is 1-2 GB. You can assign 
up to 8 GB of RAM if Parallels Workstation is installed in the 32-bit host OS and up to 64 GB if 
in the 64-bit. 

• 350 MB of hard disk space for the Parallels Workstation installation. 

• About 30 GB of hard disk space for each virtual machine. 

To store a virtual machine's temporary files, you need to have twice as much free disk space as 
the overall amount of this virtual machine's memory: (memory + video memory) +150 MB. 

• DVD-ROM drive. 

• Ethernet network adapter. 

If you want to use a directly connected PCIe video card in your virtual machine, you need: 

• Two PCIe video cards. One video card for your host computer and the other – for the virtual 
machine. 

Parallels Workstation officially supports the NVIDIA Quadro® FX 1800, 3800, 4800, 5800, 
Q4000, Q5000, (Q2000? and Q6000?) video cards for virtual machines. For these video cards, 
use the latest drivers (starting from 182.65 for Windows and 180.51 for Linux ?) available on the 
manufacturer's website. 

Direct assignment of PCIe video cards requires an NVIDIA Video BIOS version of 
62.00.62.00.01 or later. If you have a supported video card which does not have this BIOS 
level, please contact your OEM supplier. 
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Software Requirements 

Parallels Workstation 6 officially supports the following host operating systems: 

Host Operating Systems 32-
bit 

64-
bit 

Windows 7   

Windows Vista SP1, SP2   

Windows XP Pro SP3   

Windows XP Home SP3   

Windows XP Pro SP2   

Debian 6.0   

Fedora 14, 15   

RHEL 6, 6.1   

SLED 11 SP1   

Ubuntu 10.10, 11.04   

Parallels Workstation 6 Extreme officially supports the following host operating systems: 

Host Operating Systems 32-
bit 

64-
bit 

Windows 7   

Windows Vista SP2   

Windows XP SP2   

RHEL 6   

In Linux operating systems, make sure the following software packages are installed: 

• kernel development packages 

Note: In RedHat-based systems, such packages are called kernel-<kernel_version>-devel, in 
Debian-based systems - linux-headers-<kernel_version>. 

• gcc of the version with which the host kernel was compiled 
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• 32-bit version of glibc 2.3.6 or later 

• make or gmake 

• the 32-bit version of the alsa-plugins-pulseaudio package in the Fedora 10 (64-bit) operating 
system 

For 64-bit systems, it is also desired to have 32-bit alsa-lib installed in RedHat-based systems or 
lib32asound in Debian-based systems. 

If you do not have any of the aforementioned packages installed on your Linux-based physical 
computer, the Parallels Workstation installer tries to install it automatically. 
 

Install Parallels Workstation 
Read this section to learn how to install Parallels Workstation in Windows and Linux operating 
systems. 
 

Install Parallels Workstation in Windows 

You can be up and running with Parallels Workstation in a few easy steps. 

Note: To install Parallels Workstation in Windows, you must have administrator's rights. 

To install Parallels Workstation: 

1 Locate the Parallels Workstation setup file (ParallelsWorkstation-parallels-en_US-
6.0.xxxxx.xxxxxx.exe) and double-click it. This file is available either: 

• on the Parallels Workstation installation disc included in the boxed version of Parallels 
Workstation; or 

• you can download it from the Parallels website. 

2 If your computer is connected to the Internet, Parallels Workstation checks for available 
updates. If an update is available, click "Download and Install New Version" to get the latest 
version of Parallels Workstation. 

3 Follow the onscreen instructions to install Parallels Workstation. 

Note: When you're presented with information about the Parallels Customer Experience program, you 
can choose whether you want to participate. If you choose not to, you can join the program later using 
the Feedback pane (p. 26) of Parallels Workstation Preferences. 
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Install Parallels Workstation in Linux 

Before installing Parallels Workstation on a Linux computer, make sure that the packages and 
libraries listed in the system requirements (p. 10) for Linux host operating systems are installed in 
your system. 

Note: You must have the root privileges to be able to install Parallels Workstation in a Linux operating 
system. 

To install Parallels Workstation in Linux, you need a RUN installation package. It is available on the 
Parallels Workstation installation disc included in the boxed version of Parallels Workstation or can 
be downloaded from the Parallels website. 

To install Parallels Workstation in Linux: 

1 Disable SELinux in the host operating system (you can enable it again after the installation is 
complete). For the detailed information on how to do this, please refer to your Linux distribution 
documentation and/or support resources. 

2 Locate the .run installation package in a terminal and make sure it is executable. To do this, 
use the following command: 

# chmod +x parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run 

where parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run is the 
name of your .run installation package. 

3 Start the Parallels Workstation installation by executing the following command: 
# ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run 

4 Parallels Workstation connects to the Parallels update server and checks for available updates. 
If there is a newer version of Parallels Workstation available, you will be offered to install the 
most recent version of Parallels Workstation. If you do not want to install the most recent 
version, you can choose to install the version from the installation media. 

Note: If the host computer is accessing the Internet only via a proxy server, configure the proxy server 
settings to allow Parallels Workstation to check for available updates during the installation process. For 
more information on how to configure the proxy server settings, refer to the corresponding subsection 
below. 

If there are no updates available or your host computer is not connected to the Internet, 
Parallels Workstation will be installed from the current installation source. 

5 Parallels Workstation Installer starts. In the Welcome screen, click Next. 

6 In the License Agreement screen, read the license agreement scrolling it by pressing 
Spacebar on your keyboard. To accept the agreement, click the Accept button. 

7 In the CEP Agreement screen, you can choose to participate in the program that will help us 
improve Parallels Workstation according to your experience. Read carefully the information 
about the program and click the Agree button if you want to participate in it. Otherwise click 
Disagree. 
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8 When the installation is complete, click Exit. 

9 To exit the terminal, enter: 
exit 

Configure Proxy Server Settings 

If the host computer is accessing the Internet only via a proxy server, you should configure the 
proxy server settings to allow Parallels Workstation to check for available updates during the 
installation process. To this effect, start the Parallels Workstation installation as follows: 

1 Execute the following command to start the installation: 
sudo ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run -- -p 
proxy_server_host_name:port 

or 
sudo ./parallels-workstation-parallels-en_US-6.0.xxxxx.xxxxxx.run -- -p ip_address:port 

where proxy_server_host_name stands for the proxy server host name, ip_address 
stands for the proxy server IP address, and port stands for the proxy server port. 

2 Continue the installation as it was described above. 

If the proxy-server requires authentication, you will be prompted to enter your name and 
password in one of the steps. 
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Activate and Register Parallels Workstation 

Activate Parallels Workstation 

Once the installation is finished, you must activate Parallels Workstation to use all of its features. 

1 Open Parallels Workstation. 

2 Click Activate Product. 

3 Enter your Product Activation Key. 

Note: If you bypass the activation dialog, you can activate Parallels Workstation later by choosing Help 
> Activate product and entering your Product Activation Key. 

If You Don't Have A Product Activation Key 

If you don't have a key already, you can get one by choosing Help > Activate Product. Then, to 
get a free trial Product Activation Key so you can try out Parallels Workstation for a limited time, 
click obtain a free trial activation key. Or to purchase a key that lets you use Parallels 
Workstation permanently, click purchase a permanent activation key. 

Registering Parallels Workstation 

During installation, you're presented with the opportunity to register Parallels Workstation. 
Registering allows you to: 

• Download and install the latest Parallels Workstation updates. 

• Create a backup copy of the product key on the Parallels web server and restore it at any time. 

• Easily contact the Parallels support team, using the support code. 

• Stay informed about Parallels news and announcements. 

Note: If you choose not to register Parallels Workstation during installation, you can register anytime by 
choosing Help > Register product when the program is open. 

 

Configure Parallels Workstation Preferences 
Common preferences for the Parallels Workstation application and its virtual machines can be 
configured using the Preferences dialog. You can open this dialog by choosing Preferences from 
the File menu. 

The preferences on the Memory and Network tabs affect all the users that work on the computer 
and all the virtual machines. The other preferences may be different for each user. 
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General 

In the General pane, you can: 

• change the default location for storing virtual machines; 

• configure Parallels Workstation to become available in tray when you minimize its window; 

• choose to create a more detailed log file; 

• change the sidebar position; and 

• restore hidden messages. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select General in the sidebar. 
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Change Default Folder for Virtual Machines 

The Default folder for virtual machines field displays the default location where Parallels 
Workstation stores the files and folders of all virtual machines you create on the host computer. 
You can change the default location by typing the path to another folder in this field or clicking the 
Choose button and navigating to the necessary folder. After changing the default location, all newly 
created virtual machines will be saved in the specified folder. However, this does not affect the files 
of virtual machines that already exist: their files will remain in the original default folder. 

Manage Parallels Workstation from the tray 

If you want to be able to manage Parallels Workstation and the running or paused virtual machines 
from the tray, select the Show tray icon option. For more details, refer to Parallels Workstation 
Tray Icon (p. 45) and Managing Virtual Machines From the Tray (p. 162). 

If you want Parallels Workstation to become available from the tray when minimized, select 
Minimize to tray. 

Note: Minimizing main window to tray does not quit Parallels Workstation. 

Troubleshooting 

While functioning, Parallels Workstation automatically creates a log file that can be used by the 
Parallels support team for solving problems and improving the product. If you select Use detailed 
log messages, Parallels Workstation starts creating a more detailed log file. It can be helpful for the 
Parallels support team, but uses more hard disk space and may slightly lower the system 
performance. 

Change the sidebar position 

In the Sidebar position list, you can choose the sidebar location. It can be located in the right or in 
the left part of the main window. 

Reset Hidden Messages 

Some Parallels Workstation dialogs and wizard windows are provided with the Do not show this 
message again option. If you select this option, the corresponding dialog will not appear next time 
you perform the same operation. Using the Reset Hidden Messages button, you can reset all 
dialogs and wizard windows with this option selected so that they would be displayed again each 
time you initiate the corresponding operation. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Keyboard 

In the Keyboard pane, you can change keyboard shortcuts for some commands that allow you to 
work with Parallels Workstation in a more convenient way. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Keyboard in the sidebar. 

 

• Grab input from the keyboard and mouse - the default keyboard shortcut is Ctrl + G. 

• Switch a virtual machine to the Coherence view mode and back - the default keyboard shortcut 
is Ctrl+Shift+Enter. 

• Switch a virtual machine to the Full Screen view mode and back - the default keyboard shortcut 
is Ctrl+Alt+Enter. 

• Return the keyboard and mouse input back to the host operating system - the default keyboard 
shortcut is Ctrl + Alt. 

To change a keyboard shortcut, change the modifier keys selected. If you want to add an ordinary 
key, double-click the Key field and press the necessary key on the keyboard. 

Note: If Parallels Tools are installed (p. 60), the keyboard and mouse input is released automatically. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Memory 

In the Memory pane, you can set the maximum amount of memory (RAM) that will be reserved for 
all virtual machines running on the host computer. 

Note: You must have the root privileges to change the memory settings in Parallels Workstation for 
Linux. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Memory in the sidebar. 

 

The Automatically option (selected by default) means that the total amount of memory reserved for 
all running virtual machines is calculated automatically. 

To set this amount manually, select Manually and specify the needed value. 

The allocated memory is shared among all running virtual machines. You can set the amount of 
RAM for a particular virtual machine on the General tab (p. 104) of the Virtual Machine 
Configuration dialog. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Intel VT-d 

In the Intel VT-d pane, you can assign some of the host computer's PCI Express (PCIe) video and 
network adapters to your virtual machines. 

Note: This pane appears in Parallels Workstation Extreme Preferences only if your host computer 
supports the Intel VT-d technology and the Intel VT-d support is enabled in BIOS. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Intel VT-d in the sidebar. 
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The PCIe Devices column of the Specify the PCIe devices assignments table lists all PCIe video 
and network adapters available on the host computer. In the Assignments column, you can see 
these PCIe devices assignments. There are two types of assignments: 

• Host Computer. If you select this assignment, the device will be available to the host computer 
only. 

• Virtual Machines. If you select this assignment and click OK, Parallels Workstation will 
automatically install an appropriate pass-through driver in the host operating system. This driver 
will make the PCIe device invisible to the host operating system. This allows you to assign the 
device directly to one of your virtual machines. To use the device in a virtual machine, you 
should add it to the virtual machine configuration. 

To change the device assignment, select it in the PCI Devices list, double-click the corresponding 
field in the Assignment column and select the necessary assignment. Changing the assignment of 

devices marked by  will require the host computer restart. 

Note: If you have only one PCIe video adapter, its name will be grayed out in the PCI Devices list and 
you will not be able to allocate it to your virtual machines. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
 



22 
 

Install and Configure Parallels Workstation 
 

USB 

In the USB pane, you can specify how to connect USB devices that are plugged into the host 
computer. 

Note: You can connect up to eight USB 2.0 devices and up to eight USB 1.1 devices to each virtual 
machine. [?] 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select USB in the sidebar. 
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Choose a general action to perform when a new USB device is plugged into the host computer: 

• Connect it to my host. If you select this option, the USB device plugged into the host 
computer will be connected to the host computer. 

• Connect it to the active virtual machine. If you select this option, the USB device plugged 
into the host computer will be automatically connected to the virtual machine that is currently 
running. When no virtual machine is running, the USB device will be connected to the host 
computer. 

• Ask me what to do. If you select this option, you will be prompted to choose how to connect 
the USB device each time a new USB device is plugged into the host computer. 

Permanent Assignments 

In the Permanent assignments list, you can set certain USB devices to connect to certain virtual 
machines or to the host computer automatically. 

To add a new assignment: 

1 Click the Add button  below the Permanent assignments list. 

2 Click the device field in the USB Device column to choose a USB device from the list. 

3 In the Connect To column, double-click the destination field to open the list of available 
destinations. Choose the virtual machine to which you want to connect this device. If you want 
to connect the USB device to the host computer, choose Computer. 

After that, the specified USB device will be automatically connected to the specified destination 
each time you plug it in to the host computer. 

Note: To be able to use the USB device in a virtual machine, you may need to install the necessary 
drivers in the guest operating system. By default, such drivers can be obtained from the manufacturers 
of this device. 

You can change an assignment by editing the device and destination in the USB Device and 
Connect To fields. 

To remove an existing assignment, select it in the Permanent assignments list and click the 
Remove button . 

For more information about using USB devices in a virtual machine, refer to Using USB Devices in 
a Virtual Machine. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Proxy Server 

In the Proxy Server pane, you can configure a number of proxy server-related settings. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Proxy Server in the sidebar. 
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If you don't want Parallels Workstation to use a proxy server for network connections, select Do 
not use proxy server. 

If you want to use a proxy server, you can choose one of the following: 

• You can choose the Specify a proxy server option and provide the proxy server settings 
manually. 

Specify the address and port of the proxy server. If it requires authentication, select Proxy 
server requires authentication and type the corresponding credentials in the User Name and 
Password fields. 

If you want to use a SSL proxy server for your secure connections, choose Use a different 
proxy server for SSL connections. Click SSL Proxy and provide the SSL proxy server 
address and port in the SSL Proxy window. In this window, you can also provide the 
credentials for accessing this server if needed. If you clear Use a different proxy server for 
SSL connections, the first proxy server specified in this pane will be used for all connections. 

• In Parallels Workstation for Windows, you can choose the Use Internet Explorer proxy 
settings option to import the proxy sever setting from the connections settings of Internet 
Explorer. 

• In Parallels Workstation for Windows, you can also choose Use automatic configuration 
script and provide the path to this script in the Address field to automatically configure the 
proxy server settings. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Feedback 

In the Feedback pane, you can join the Parallels Customer Experience Program if you didn't do 
that during the Parallels Workstation installation or cancel participation. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Feedback in the sidebar. 
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If you participate in the program, Parallels collects information about the host computer and 
configuration of your virtual machines. The gathered information is used to make the product better 
fit your needs. 

If you join, only the following types of data will be collected: 

• hardware configuration of the host computer; 

• software configuration of the host computer and virtual machines (the names and versions of 
the operating systems and programs installed); and 

• configuration files of your virtual machines. 

Any types of private information such as your name, e-mail, address, phone number, and keyboard 
input will not be collected. 

For more details, visit the Customer Experience Program page at the Parallels website (follow the 
link in the pane). 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Network 

In the Network pane, you can configure network-related settings for Parallels Workstation and your 
virtual machines. [expand] 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Network in the sidebar. 

 

You can configure the range of IP addresses to be assigned to your virtual machines when they are 
operating in the host-only and shared networking modes. 

To edit the settings of the available network adapter, double-click it and make the necessary 
changes. 

To remove a virtual network adapter, select it in the list and click the Remove button . 

To add a virtual network adapter, click the Add button  and configure the necessary settings. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Shared Network Settings 

To make changes the shared networking settings, double-click the Shared network adapter name 
in the Network pane of Parallels Workstation Preferences. 

In the displayed window, you can make the necessary changes to the settings of the Parallels 
DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP 
addresses to your virtual machines operating in the shared networking mode. 

For more information about configuring shared networking, refer to Share Network Settings 
Between the Host Computer and Virtual Machine. 

Port Forwarding 

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from 
external computers. The port forwarding functionality allows computers on your local network and 
on the Internet to transfer data to any of your virtual machines that use the shared networking 
mode. The data sent to a specific port on your host computer will be redirected to a specific port of 
your virtual machine according to the port-forwarding rule. 

To add a port forwarding rule: 

1 Click the Add button  below the Port forwarding rules list. 

2 In the displayed window, do the following: 

• In the Port Type field, specify the port type you want to use for establishing network 
connections. You can choose between the TCP or UDP port types. 

• In the Incoming Port field, type the number of the incoming port on your host computer. 

• In the IP Address field, indicate the IP address of the virtual machine you want to connect. 

• In the Destination Port field, type the port on the virtual machine to which the data will be 
transferred. 
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3 Click OK to add the rule. 

When the rule is added, use the following IP address combination for external connections to your 
virtual machine: <you host PC's IP address>:<Incoming port>. 

 

To edit a rule, select it in the Port forwarding rules list, click the Edit button , modify the 
necessary settings, and click OK to apply them. 

To remove a port forwarding rule, select it in the Port forwarding rules list and click the Remove 
button . 

Click OK to save the changes, otherwise, click Cancel. To restore the default settings, click 
Restore Defaults. 
 

Host-Only Network Settings 

To make changes to the host-only networking settings, double-click the Host-Only network adapter 
name in the Network pane of Parallels Workstation Preferences. 

In the displayed window, you can make the necessary changes to the settings of the Parallels 
DHCP servers for IPv4 and IPv6. These servers, enabled by default, automatically assign IP 
addresses to the virtual machines operating in the host-only networking mode. 

For more information on configuring the host-only networking settings, refer to Use Host-Only 
Network Settings. 

Click OK to save the changes, otherwise, click Cancel. To restore the default settings, click 
Restore Defaults. 
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Update 

In the Update pane, you can check for available updates at any time and disable automatic update 
checks. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Update in the sidebar. 

 

To check for updates, click Check Now. 

The Check for software updates option (selected by default) makes Parallels Workstation 
automatically check for available updates once a week, provided that Parallels Workstation is 
launched and the host computer is connected to the Internet. If you want to disable automatic 
update checks, clear this option. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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iPhone 

In the iPhone pane, you can set up external connections to Parallels Workstation and its virtual 
machines from Parallels Mobile application installed on your iPad, iPhone, or iPod touch. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select iPhone in the sidebar. 

Parallels Mobile lets you:[what about Linux vms?] 

• access any virtual machine running in Parallels Workstation 

• use any application in your virtual machine, from Internet Explorer to Outlook 

• remotely start, stop and reset virtual machines 

• stay connected via WiFi or 3G networks 

• access your applications from anywhere over the Internet 

• optimize for either speed or graphics performance. 

You can download Parallels Mobile for free from the App Store. 
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Download Parallels Mobile 

You can download the Parallels Mobile application for free from the App Store: 

1 In the iPhone pane of Parallels Workstation Preferences, click the black icon in the top right 
corner. The browser window opens and you can see the Parallels Mobile description. 

2 Click View In iTunes. The iTunes window with Parallels Mobile opens.[?] 

3 To download the application, click Free App. 

4 Enter your Apple ID and password, click Get and the download starts. Parallels Mobile is 
downloaded to iTunes > Libraries > Apps. To install Parallels Mobile, you need to sync it with 
your iPad, iPhone, or iPod touch. 

Connect Parallels Mobile to Host Computer and Virtual Machines 

There are two ways to connect Parallels Mobile to the host computer and virtual machines: 

• through the Internet, using Parallels Mobile server, or 

• directly, when the host computer and your iPad, iPhone, or iPod touch are within the same 
network 

It is recommended to use the first mode, as it allows you to access the host computer from almost 
anywhere through the Internet or 3G networks. 

Connect through the Internet 

To connect to your virtual machines from iPad, iPhone, or iPod touch through the Internet, do the 
following: 

1 Make sure you have a Parallels account. This is the account you created when registering 
Parallels Workstation. 

2 On the host computer, open Parallels Workstation > Preferences > iPhone and log in to 
your Parallels account using the email and password you used to register your copy of Parallels 
Workstation. 

3 Install Parallels Mobile on your iPad, iPhone, or iPod touch. 

4 On your iPad, iPhone, or iPod touch, open Parallels Mobile and also log in to your Parallels 
account. 
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You will see your host computer listed in the corresponding section. 

5 Now you need to connect to the host computer. Tap it and enter your user name (this name 
can be found in the Parallels Workstation > Preferences > iPhone pane) and password. After 
that, you will see the list of your virtual machines and will be able to manage them. 

Direct connection 

To connect to your virtual machines directly (if your Apple mobile device and the host computer are 
within the same network), do the following: 

1 Install Parallels Mobile on your iPad, iPhone, or iPod touch. 

2 On your iPad, iPhone, or iPod touch, open Settings, find the Parallels icon (in the Apps 
section), and tap it. In the General section, slide the Direct Connection switch to the ON 
position, and close Settings. 

3 On the host computer, open Parallels Workstation > Preferences > iPhone and select 
Connect Parallels Mobile directly to the host computer. 

4 Use the IP address (specified under this option), your Mac user name, and password to 
connect to your virtual machines from Parallels Mobile.[?] 

For more detailed information about Parallels Mobile, please refer to Parallels Mobile Quick Start 
available here. 

Restoring Default Settings 

The Restore Defaults button allows you to restore the default settings for all options available in 
this pane. 
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Single Sign On 

In the Single Sign On pane, you can configure single sign on settings for your Windows XP virtual 
machines. These settings allow you to: 

• Enable automatic logon to Windows XP: you won't have to enter your user name and password 
every time you start the virtual machine - your user account will log in to Windows XP 
automatically. 

• Configure the guest operating system to lock/unlock automatically when you lock/unlock the 
host operating system. 

To edit these settings: 

1 Open the File menu and click Preferences. 

2 In the Preferences dialog, select Single Sign On in the sidebar. 
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To configure single sign on settings for a Windows XP virtual machine, create a single sign on 
assignment for it: 

1 Click the Add button . 

2 Double-click the virtual machine listed in the Virtual Machine column and choose the 
necessary Windows XP virtual machine from the menu. By default, single sign on settings are 
disabled. 

3 To enable them, click the Edit button . The following window appears: 

 

• To enable automatic logon, select Enable Single Sign On and specify your credentials. 

• To enable the automatic lock/unlock feature, select Synchronize Lock/Unlock. 

4 When ready, click OK. 

To delete a single sign on assignment for a Windows XP virtual machine, select it in the table and 
click the Remove button . 

 



 

 

When you launch Parallels Workstation, the Parallels Workstation window opens. The Parallels 
Workstation window consists of several parts: 

Menus - contain all the controls available for Parallels Workstation and its virtual machines. For 
detailed information, see the Menus subsection (p. 39). 

Toolbar - comprises buttons that can be used to manage the virtual machine and its appearance. 
For detailed information, see the Toolbar subsection (p. 40). 

Sidebar - contains the list of all virtual machines registered in Parallels Workstation. If you right-
click a virtual machine name in the list, you can use a set of commands for managing the virtual 
machine from the virtual machine context menu. 

Virtual Machine window - acts as the virtual machine display or shows the properties and main 
operations of the virtual machine you selected in the sidebar. It consists of three tabs: 

• The Summary tab displays the main information about the virtual machine (its name, location, 
OS, state and description), the main operations you can perform on it, and the virtual machine 
configuration. This tab is always available. 

• The Console tab is available when the virtual machine is running and acts as the virtual 
machine's display. 

• The Performance tab shows the CPU and memory usage when the virtual machine is running. 

Status Bar - displays the devices information when the virtual machine is running. For detailed 
information, see the Status Bar subsection (p. 43). 

C H A P T E R  3  

Interface Basics 
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Menus 
The Parallels Workstation menus contain all the controls available for Parallels Workstation and its 
virtual machines. 

There are the following menus: 

• The File menu allows you to: 

• create a new virtual machine (p. 46) 

• add an existing virtual machine to Parallels Workstation (p. 55) 

• remove the virtual machine from the Parallels Workstation sidebar (p. 163) 

• delete the virtual machine 

• download Parallels Virtual Appliances (p. 57) 

• clone the virtual machine (p. 155) 

• clone the virtual machine to a template 

• convert the virtual machine to a template 

• deploy the template to a virtual machine 

• convert the template to a virtual machine 

• quit Parallels Workstation 

• The View menu includes commands for switching between different view modes: Full Screen, 
Coherence, and Window. You can also customize how you view the Parallels Workstation 
window, enable or disable automatic changes of the virtual machine screen resolution, and 
make screenshots of the guest OS window. 

• The Virtual Machine menu allows you to: 

• manage the virtual machine 

• edit the virtual machine configuration 

• install Parallels Tools (p. 60) 

• update Parallels Tools (p. 68) 

• launch Parallels Compressor 

• The Devices menu is available only when the virtual machine is running. It allows you to 
configure certain devices and shared folders at runtime. 

• The Window menu allows you to choose the application window you want to appear on top. 
This menu simplifies the navigation between the virtual machines. 

• The Applications menu enables you to manage certain elements of the Windows desktop 
such as the Start menu, the Windows taskbar and recycle bin. 

Note: The Applications menu is available only for Windows XP or Windows Vista guest OSs. 
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• The Help menu allows you to: 

• open Parallels Workstation Help 

• activate Parallels Workstation (p. 15) 

• check for updates 

• report problems (p. 166) 

It also displays the About Parallels Workstation dialog. 
 

Toolbar 
The Parallels Workstation toolbar has buttons for the most frequent commands used to start, stop, 
and otherwise manage a virtual machine and its window appearance. 

Most of the toolbar buttons become enabled only when you start the virtual machine. If you click a 
toolbar button, it becomes visibly pressed. 
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The default toolbar buttons: 

 Start. Use this button to start the virtual machine if it is stopped, paused or suspended. 

 Shut Down. Use this button to shut down your guest OS correctly. 

 Suspend. Use this button to put your virtual machine into the sleep mode for a certain 
period of time. If you need to restart the host computer, you may temporarily suspend your virtual 
machines and easily resume them after the restart. 

 Detach Console. Use this button to show the Console tab of the Parallels Workstation 
window in a separate window. 

 Full Screen. Use this button to switch the virtual machine to the Full Screen mode. To return 
back to the Window mode, press Alt+Enter. The key combination for switching to the Full Screen 
mode and back can be changed in the Preferences dialog available from the File menu. 

You can easily add other buttons to the toolbar: just right-click the toolbar, choose Customize 
Toolbar (p. 42) from the shortcut menu, and drag the items you need to the toolbar: 

 Restart. Use this button to restart the fully loaded guest operating system. 

 Pause. Use this button to pause the virtual machine when you need to instantly release the 
Parallels physical server resources used by this virtual machine. 

 Stop. Use this button to stop the virtual machine in cases when the machine does not run 
properly and prevents you from shutting it down. 

Note: If you click this button when the virtual machine is running, you may lose all the unsaved data. To 
turn off the virtual machine, use the shutdown procedure specified for the guest OS installed in it or use 
the Shut Down button. 

 Reset. Use this button for hard reset of your virtual machine in cases when the machine 
does not run properly and prevents you from resetting it properly. 

 Safe Mode. Use this button to run the virtual machine in Safe Mode. 
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 Configure. Use this button to open the Virtual Machine Configuration dialog. 

If you often work with snapshots, you can drag any of the three snapshot buttons to the toolbar as 
well: 

 Take Snapshot. Use this button to create a snapshot for the virtual machine. 

 Revert to Snapshot. Use this button to roll back the changes made to the virtual machine 
since the moment the last snapshot was made. 

 Snapshot Manager. Use this button to open Snapshot Manager. For more information, refer 
to the Working with Snapshots section. 
 

Customize the Toolbar 

To change the appearance of the toolbar, right-click the toolbar and choose one of the following 
options: 

• Icon & Text. Use this command to make the toolbar display both the icon buttons and names. 

• Icon Only. Use this command to make the toolbar display the icon buttons only. 

• Text Only. Use this command to make the toolbar display the name buttons only. 

• Use Small Size. Use this command to reduce the size of toolbar buttons. 

• Remove Item. Use this command to remove items from the toolbar. 

• Customize Toolbar. Use this command to open the toolbar settings pane. See the description 
below. 

To customize the set of toolbar buttons and its appearance, right-click the toolbar, and choose 
Customize Toolbar. The toolbar settings pane opens. In this pane, you can perform the following 
operations: 

• Add new buttons to the toolbar by dragging them from the settings pane to the toolbar. 

• Remove buttons from the toolbar by dragging them from the toolbar to the settings pane. 

• Add separators to the toolbar by dragging them from the settings pane to the toolbar. 

• Add spaces to the toolbar by dragging them from the settings pane to the toolbar. 

• Restore the default toolbar buttons set by dragging it to the toolbar. 

• select the toolbar buttons view mode in the Show list 

To apply the changes you have made to the toolbar settings pane, click Done. 
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Status Bar 
When the virtual machine is running, the status bar of its window displays the information about 
devices connected to the virtual machine. 

 



44 
 

Interface Basics 
 

The following devices have icons in the status bar: 

• keyboard  

• floppy disk drive  

• CD/DVD-ROM  

• hard disk  

• network adapter  

• serial port  

• parallel port  

• sound card  

• USB controller  

• assigned PCIe video adapter  

• shared folders  

If you see the  icon in the status bar, it means that Parallels Tools are installed in your virtual 
machine. 

You can connect or disconnect some of the virtual machine devices at runtime by clicking their 
icons in the status bar and choosing the respective commands from the shortcut menu. The 
picture below shows the shortcut menu for the CD/DVD-ROM drive. 

 

To connect CD/DVD ISO images to the virtual machine's CD/DVD-ROM drive or connect floppy 
images to its floppy disk drive, drag the required image file over the CD/DVD-ROM drive icon or the 
floppy disk drive icon in the status bar. For more information, see Changing Configuration at 
Runtime (p. 160). 
 



45 
 

Interface Basics 
 

Parallels Workstation Tray Icon 
When working with Parallels Workstation, you can use the Parallels Workstation tray icon to: 

• easily manage your running and paused virtual machines. For detailed information, refer to 
Managing Virtual Machines From the Tray (p. 162). 

• bring the Parallels Workstation window to focus. To this effect, double-click the tray icon or 
right-click it and choose Show Main Window. 

• set the Parallels Workstation window to be minimized to the tray. To this effect, right-click the 
tray icon and choose Minimize to tray. Now, if you click the minimize button on the Parallels 
Workstation window, it will be minimized to the tray. 

Note: Minimizing main window to tray does not quit Parallels Workstation. 

• quit Parallels Workstation. To this effect, right-click the tray icon and choose the corresponding 
item. 

To enable the Parallels Workstation tray icon, select Show tray icon option in the General pane (p. 
16) of Parallels Workstation Preferences. 

 



 

 

The process of creating a virtual machine comprises the following steps: 

• creating a virtual machine configuration 

• installing a guest operating system 

• installing Parallels Tools 
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Create a New Virtual Machine 
The process of creating a new virtual machine includes the following basic steps: 

1 Creating a virtual machine configuration. 

2 Installing a guest operating system. To check the list of supported guest operating systems, 
check the user's guide for the respective Parallels product. 

3 Installing Parallels Tools. 

These steps are described in the following sections in detail. 
 

C H A P T E R  4  

Set Up a Virtual Machine 
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Supported Guest Operating Systems 

Parallels Workstation 6 officially supports the following guest operating systems: 

Guest Operating Systems 32-
bit 

64-
bit 

Express 
installation 

Windows 7    

Windows Vista SP1, SP2    

Windows XP Pro SP3    

Windows XP Home SP3    

Windows XP Pro SP2    

Debian 6.0    

Fedora 14, 15    

OpenSUSE 11.1    

RHEL 6, 6.1    

SLED 11 SP1    

Ubuntu 10.10, 11.04    

Parallels Workstation 6 Extreme officially supports the following guest operating systems: 

Guest Operating Systems 32-
bit 

64-
bit 

Express 
installation 

Windows 7    

Windows Vista SP2    

Windows XP SP3    

Windows XP SP2    

Fedora 14, 15    

RHEL 6, 6.1    

RHEL 5.5    
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New Virtual Machine Wizard 

The wizard offers several installation modes. You can choose the mode that better fits your needs 
or your experience with Parallels Workstation. Regardless of what method you select, you will be 
able to change the configuration of your virtual machine later using the Virtual Machine 
Configuration dialog. 

Express Windows Installation 

This installation mode is available only for the following guest operating systems: Windows 7, 
Windows Vista, Windows XP, and Windows Server 2003. 

Note: Not all Parallels products support these guest operating systems. 

New Virtual Machine Wizard not only creates a virtual machine configuration, but also automatically 
installs the corresponding guest OS in it. It is the easiest way to make a new virtual machine: you 
only need to insert a Windows 7, Windows Vista, Windows XP, or Windows Server 2003 installation 
disc or specify the path to its image file, and New Virtual Machine Wizard will do the rest (including 
the installation of Parallels Tools). In this mode, virtual machines are created with typical 
configurations (see Typical Configurations for details) and placed to the default folder (see below). 

For more information on this installation mode, see Express Windows Installation Mode (p. 50). 

Typical Installation 

This installation mode is designed for new users and for fast virtual machine creation. You only have 
to specify the type and version of the guest operating system that you wish to install and where you 
wish to store the virtual machine files. New Virtual Machine Wizard creates a typical (for the 
selected guest OS) virtual machine configuration and starts the installation of the guest OS as 
interactive installation. 

For more information on this installation mode, see Typical Installation Mode (p. 51). 

Custom Installation 

This installation mode is intended for experienced users only. It allows the user to create 
configurations other than the typical ones. In this mode, the user is prompted to specify such 
options for the basic hardware as the amount of RAM, the size and format of a virtual hard disk, 
and networking parameters. Additional devices can be added later, using the Virtual Machine 
Configuration dialog. After New Virtual Machine Wizard creates a virtual machine configuration, it 
starts installing the guest OS if such an option was selected. 

For more information on this installation mode, see Custom Installation Mode (p. 52). 

Default Folders for Virtual Machines 
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By default, Parallels Workstation is configured to create a new virtual machine folder in the home 
folder of the user who created it: 

 In Windows XP: C:\Documents and Settings\<User_Name>\My 
Documents\Parallels\ 

 In Windows Vista: C:\Users\<User_Name>\My Documents\Parallels 

 In Linux: /<User_Name>/Parallels/ 

Where <User_Name> stands for the user's home folder. 

However, you can select another folder that will be used as the default folder for your virtual 
machines. 

To specify another default destination for saving virtual machines, do the following: 

1 Choose Preferences from the File menu. 

2 In the Preferences window, click the General tab, and specify the default destination for new 
virtual machines in the Default folder for virtual machines field. 

Note: You can also specify a folder for a virtual machine during its creation. An existing virtual machine 
can also be moved to a different folder after it is created. 
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Express Windows Installation 
1 Start Parallels Workstation and launch New Virtual Machine Wizard by choosing New from the 

File menu. 

2 In the Select Operating System Type and Version window, select the Windows 7, Windows 
Vista, Windows XP, or Windows Server 2003 guest OS and click Next. 

Note: Not all Parallels products support these guest operating systems. 

3 In the Virtual Machine Type window, select Express Windows and click Next. 

4 In the Name and Location window, define the name and location for your virtual machine: 

• Name. Indicate an arbitrary name to be assigned to the virtual machine. By default, the 
virtual machine gets the same name as the operating system that will be installed inside this 
virtual machine. If a virtual machine with such a name already exists, you will be prompted to 
indicate another name. The name must not exceed 50 characters. 

• Location. Use the Choose button if you want to change the default location of the virtual 
machine-related files. 

5 In the Express Windows Installation window, specify your user details and the Windows 
product key necessary for the Windows guest OS installation. 

Note: If you do not enter the Windows product key in this step, you will have to provide it later when the 
Windows guest OS installation starts. 

If you click the Advanced button, you can set the number of CPUs and the amount of RAM to 
your future virtual machine. 

Click Create. 

• After the virtual machine is created, in the Prepare to Install Operating System window, 
specify the source of installation files and click Start. 

Notes:  

1. OS installation CDs and DVDs are not included with your Parallels product. You must obtain an 
operating system separately. 

2. For a Linux virtual machine, the source installation files may be located on the Parallels server only. 

6 After you click Start, New Virtual Machine Wizard will automatically start the new virtual 
machine and install the guest operating system in it. After the guest OS has been successfully 
installed, Parallels Workstation installs Parallels Tools. 

During the unattended installation, Parallels Workstation creates an administrator account with a 
blank password. When the guest OS installation is complete, we recommend that you change the 
password in order to protect the safety of your data. 

To change the administrator password in Windows Vista: 

1 Click the Start menu, then select Control Panel -> User Accounts and Family Safety -> 
Change your Windows password. 
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To change the administrator password in Windows XP (Professional Edition): 

1 Click the Start menu, then select Control Panel -> Administrative Tools -> Computer 
Management. 

2 In the Computer Management window, open System Tools -> Local Users and Groups -> 
Users. Right-click the Administrator account and choose Set Password from the context 
menu. 

 

Typical Installation Mode 

To create a typical virtual machine: 

1 Start Parallels Workstation and launch New Virtual Machine Wizard by choosing New from the 
File menu. 

2 In the Select Operating System Type and Version window, select the operating system you 
are planning to install inside your virtual machine and click Next. 

3 In the Virtual Machine Type window, select Typical and click Next. 

4 In the Name and Location window, define the name and location for your virtual machine: 

• Name. Indicate an arbitrary name to be assigned to the virtual machine. By default, the 
virtual machine gets the same name as the operating system that is planned to be installed 
inside this virtual machine. If a virtual machine with such a name already exists, you will be 
prompted to indicate another name. The name must not exceed 50 characters. 

• Location. Use the Choose button if you want to change the default location of the virtual 
machine-related files. 

If you click the Advanced button, you can set the number of CPUs, the amount of RAM, and 
the virtual hard disk capacity to your future virtual machine. 

Click Next. 

5 After the virtual machine is created, in the Prepare to Install Operating System window, 
specify the source of installation files and click Start. 

Note: Parallels Workstation does not provide you with operating systems installation media. You should 
purchase an OS installation disc or an image of it if you do not have any. 

If you do not want to install the guest OS and start the virtual machine, click Done. When the 
installation is complete, install Parallels Tools if they are available for the guest OS you have just 
installed. Refer to the Installing Parallels Tools section (p. 60). 
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Custom Installation Mode 

To create a custom virtual machine: 

1 Start Parallels Workstation and launch New Virtual Machine Wizard by choosing New from the 
File menu. 

2 In the Select Operating System Type and Version window, select the guest OS you plan to 
install inside your virtual machine and click Next. 

3 In the Virtual Machine Type window, select Custom and click Next. 

4 In the Name and Location window, define the name and location for your virtual machine: 

• Name. Indicate an arbitrary name to be assigned to the virtual machine. By default, the 
virtual machine gets the same name as the operating system that will be installed inside this 
virtual machine. If a virtual machine with such a name already exists, you will be prompted to 
indicate another name. The name must not exceed 50 characters. 

• Location. Use the Choose button if you want to change the default location of the virtual 
machine-related files. 

5 In the CPU and Memory Options window, specify the number of CPU(s) and the amount of 
RAM for the virtual machine and click Next. You can use the slider or arrow buttons to set the 
value or simply type it into the corresponding field. 

6 In the Hard Disk Options window, select the type of virtual hard disk you want to use and click 
Next. You can create a new hard disk image, use an existing one, or create a virtual machine 
without any hard disk at all. You may need a virtual machine without a hard disk to work with 
live CDs/DVDs (CDs or DVDs containing a bootable operating system). 

7 If you have selected the No hard disk option, go to Step 8. 

If you chose to create a new virtual hard disk in the previous step, in the New Virtual Hard Disk 
window, specify the capacity and type for the disk and click Next. If you have chosen to use an 
existing image file, in the Existing Virtual Hard Disk window, specify the hard disk image to be 
connected, its interface type and position. Click Next. 

8 In the Networking Type window, select the type of networking you want to use in the virtual 
machine and click Next. 

• Shared Networking. If you select this option, the virtual machine will use the host 
computer's network connections and will be visible only for the host computer and other 
virtual machines registered on this server. 

• Bridged Networking. If you select this option, the virtual machine will be visible on the 
network as a separate computer. 

• Host-Only Networking. If you select this option, the virtual machine will access only the 
host computer and the virtual machines running on it. 
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• Direct Assignment (using Intel VT-d). If you select this option, the virtual machine will be 
able to access the local network and Internet through a PCIe network adapter. This option is 
available only if you have a PCIe network adapter and the Intel VT-d technology is enabled in 
your host computer. 

• No Networking. If you select this option, the virtual machine will have no network adapter. 

Note: You may reconfigure the networking settings after the virtual machine is created, using the Virtual 
Machine Configuration dialog. 

9 If you have selected the Shared Networking, Host-Only Networking, or No Networking 
option, go to Step 10. 

If you selected Bridged Networking, on the next step you will need to select the network 
adapter to be used by the virtual machine: 

• Default Adapter. Select this option to use the adapter specified as default in the primary 
OS. 

• Parallels Shared Networking Adapter. Select this option to use Parallels Shared 
Networking adapter installed together with Parallels Workstation. 

• Parallels Host-Only Networking Adapter. Select this option to use Parallels Host-Only 
Networking adapter installed together with Parallels Workstation. 

The host computer network adapters included in this list are also available for selecting. Select 
the Connected option if you want the virtual machine to start up with this network adapter 
connected. 

If you selected the Direct Assignment (using Intel VT-d) option, on the next step select the 
PCIe network adapter you want to use. Before using the PCIe adapter in your virtual machine, 
you will need to assign it to your virtual machines in the Intel VT-d pane (p. 20) of Parallels 
Workstation Preferences and install the manufacturer's driver for this PCIe device inside the 
virtual machine. The driver should support the Intel VT-d technology. For detailed information, 
see Networking Using a PCIe Adapter (p. 95). 

10 In the Optimization Options window, select the optimization mode you prefer and click Next. 
The available options are: 

• Virtual machine (Recommended). Select this option to allocate more host computer 
resources to the virtual machine and its applications. 

• Host Computer. Select this option to allocate more resources to the host computer and its 
applications. 

11 In the Prepare to Install Operating System window, specify the source of installation files and 
click Start. 

Notes:  

1. OS installation CDs and DVDs are not included with your Parallels product. You must obtain an 
operating system separately. 

2. For a Linux virtual machine, the source installation files may be located on the Parallels server only. 

If you do not want to install the guest OS and start the virtual machine now, click Done. 
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When the installation is complete, install Parallels Tools if they are available for the guest OS you 
just installed. Refer to the Installing Parallels Tools section (p. 60). 
 

Using Parallels Transporter 
Parallels Transporter allows you to import all your data from a remote PC to Parallels Workstation 
on the host computer. Then you can continue to work with all your programs, files, and data, side-
by-side with the host OS. 

To learn how to work with Parallels Transporter, please refer to Parallels Transporter 
User's Guide available on the Parallels website. 
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Import from an Earlier Parallels Workstation or 
Other Virtualization Application 
If you already have a virtual machine stored on the host computer but it is missing from the list of 
virtual machines registered in Parallels Workstation, you can easily add it with the help of Add 
Existing Virtual Machine Wizard. 

To add an existing virtual machine 

1 Choose Add Existing from the File menu to start Add Existing Virtual Machine Wizard. 

2 In the Select a Virtual Machine window, locate the virtual machines you want to add: 

• You can set the path to a specific virtual machine's configuration file (config.pvs). Select the 
Add a specific virtual machine option and type the path in the File field or click the 
Choose button and navigate to the necessary file. Click Next to register this virtual machine 
in Parallels Workstation. 

• You can find all virtual machines in a specific folder. Select the Search for virtual machines 
in this folder option, type the path to the necessary folder in the Start from field or click the 
Choose button, and navigate to it. Click Search. 
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3 If you chose Search for virtual machines in this folder, in the next window the wizard 
displays all the virtual machines found in the specified folder that are not registered in Parallels 
Workstation. Select the virtual machines you want to add. 

If you want to select all items at a time, click the Select All button  displayed below the list. 

If you want to clear all items at a time, click the Clear All button  displayed below the list. 

Review the selection and click Add. 
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Download Pre-configured Virtual Appliances 
If you don't have enough time to create a new virtual machine with the required configuration, you 
can download a ready-to-use virtual machine with a predefined configuration. Besides the basic 
configuration, prebuilt virtual machines may have a set of applications installed, so that you can do 
without spending time on installing and setting up the required software. 

Downloading Parallels Virtual Appliances 

Parallels Virtual Appliances are prebuilt Linux virtual machines with preinstalled services and 
applications that were created either by Parallels or by Parallels partners and are available for free 
on the Parallels Technology Network website. 

To download such an appliance from Parallels Workstation: 

1 Choose Download from Website from the File menu. 

2 Find the necessary appliance on the Parallels Technology Network page and click its title to 
view the configuration details and the administrative credentials. 

3 To download the selected appliance, click GET APP and choose the download link with the 
suitable archive file format. 

4 When the download is complete, open the virtual appliance file and double-click the PVS file to 
start the virtual machine. 

 



58 
 

Set Up a Virtual Machine 
 

Installing a Guest Operating System 
You can install a guest operating system in a virtual machine from a CD or DVD, or from a CD/DVD 
image file. Some operating systems are available as CD/DVD disc images only. 

In some cases, the installation cannot be performed from a real CD/DVD disc because of disc 
reading problems. In such cases, it is recommended that you try to install the operating system 
from a CD/DVD disc image of this disc. ISO images of CD/DVD discs can be created using a third 
party imaging utility. 

You can also install the guest operating system using a PXE server via network. 

Some operating systems are installed only from floppy disks. If your computer does not have floppy 
drives, you can install such operating systems using images of installation diskettes or using real 
floppy disk drives inserted into an external USB floppy disk drive. You can create floppy disk 
images using third-party applications. 

Installing from a CD/DVD or its image 

To install a guest OS from a CD/DVD or using an image: 

1 Select the virtual machine, and make sure that it is stopped. 

2 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

3 Open the CD/DVD-ROM settings, and configure the virtual CD/DVD-ROM drive settings. 

• If you are installing from a real CD/DVD, select the Real Device option and specify the real 
drive to connect in the CD/DVD-ROM list. Then insert the CD/DVD disc with the operating 
system files into the appropriate drive of the computer. 

• If you are installing from an image file, select the Image file option, and specify the path to 
the image file in the File field. 

Note: You can use ISO and DMG images for installing the guest operating system. CUE and CCD 
images may be also supported. 

4 Click OK in Virtual Machine Configuration to save the changes. 

5 Start your virtual machine by clicking Start . 

The installation will launch soon after the virtual machine is started. 

Note: If you need to press any keys inside the virtual machine during the guest OS installation, first click 
inside the virtual machine window to capture the keyboard and mouse input and than press the 
corresponding keys. To release the keyboard and mouse input back to the host OS, press Ctrl+Alt. For 
more information, refer to Capturing and Releasing the Keyboard and the Mouse (p. 74). 

Installing from the network 
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1 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

2 Click the Add button  in the bottom part of the Virtual Machine Configuration dialog to 
launch Add Hardware Assistant. 

Note: The Add button is disabled when the virtual machine is running. You need to shut down the 
virtual machine before you can use this button. 

3 Add a network adapter to your virtual machine configuration. 

4 Open the Boot Order pane in Virtual Machine Configuration and change the boot sequence to 
make the virtual network adapter the first device in the sequence. To this effect, select Network 
Adapter in the list and use the arrow buttons to move it to the top of the list. 

5 Click OK to apply the changes. 

6 Start the virtual machine by clicking Start . 

Soon after your virtual machine is started, a list of available PXE servers appears. 

During the installation, when the guest OS reboots for the first time or after the installation, return 
the boot sequence to booting from the hard disk. 

Installing from a floppy disk image 

1 Select the virtual machine and make sure that it is stopped. 

2 To connect the installation medium, open Virtual Machine Configuration by: 

• right-clicking the machine and choosing Configure from the shortcut menu, or 

• choosing Configure from the Virtual Machine menu. 

3 Open the Floppy Disk pane and specify the path to the floppy image disk file in the Image File 
field. 

4 Click OK to apply the changes 

5 Start the virtual machine by clicking Start . 

The installation will launch soon after the virtual machine is started. 

Reinstalling the guest OS 

The procedure for reinstalling the guest OS is the same as the procedure of installing the guest OS: 
provide the installation media or its image, connect it to the virtual machine, and start the virtual 
machine. The reinstallation will launch soon after the virtual machine is started. 

Note: You can reinstall the guest OS of the same type only. However, you are free to choose the guest 
OS version. 

Keep in mind that in some cases, it is easier just to create a new virtual machine, install the guest 
OS, and delete the old machine after moving all the necessary data to the new one. 
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Installing Parallels Tools 
Parallels Workstation includes a set of specially developed utilities that help you use your virtual 
machines in the most convenient and efficient way. 

Parallels Tools are located on disc images that are installed together with Parallels Workstation. 
There is a separate Parallels Tools disc image for each type of the supported guest operating 
systems. 

• prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems. 

• prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems. 

These disc images can be found in the following folder: 

• In 64-bit Windows: C:\Program Files (x86)\Parallels\Parallels 
Workstation\Tools\ 

• In Linux: /usr/share/parallels-workstation/tools/ 
 



61 
 

Set Up a Virtual Machine 
 

Parallels Tools Overview 

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most 
comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly outside 
the guest OS window without pressing any key, change the virtual machine's screen resolution by 
simply resizing its window, synchronize your virtual machine's time and date settings with the time 
settings of the host computer, and share the host computer disks and folders with its virtual 
machines. 

Parallels Tools include the utilities listed below. Many of these utilities are available for the most 
popular Windows and Linux operating systems. 

Mouse Synchronization Tool Windows, 

Linux 

Mouse Synchronization Tool captures the mouse input in 
the virtual machine each time the pointer moves over to 
the guest OS window and automatically releases the 
input when the pointer moves out of the guest OS 
window. 

Time Synchronization Tool Windows, 

Linux 

Time Synchronization Tool enables you to customize your 
virtual machine and the host computer time settings. With 
this tool, you can: 

• Automatically synchronize the time settings of 
your virtual machine with the host computer 
time settings. 

• Set up and maintain the time difference 
between your host computer and the guest OS 
installed in your virtual machine. 

Clipboard Synchronization Tool Windows, 

Linux 

Clipboard Synchronization Tool enables you to easily 
exchange texts between: 

• different virtual machines irrespective of the 
guest operating systems installed in them. 

• a virtual machine and the physical computer 
hosting this virtual machine. 

Dynamic Resolution Tool Windows, 

Linux 

Dynamic Resolution Tool enables you to work with 
dynamic resolution. When you resize the guest OS 
window by dragging its lower right corner, the guest OS 
window resolution changes automatically. 

Note: If dynamic resolution does not work 
when switching to the Full Screen mode in 
virtual machines with Linux guest operating 
system installed, go to the Video pane (p. 127) 
of Virtual Machine Configuration and increase 
the amount of video memory available to the 
virtual machine's video card up to 16 MB. 

Shared Folders Tool Windows, 

Linux 

Shared Folders Tool enables you to share the primary OS 
folders to access them from the guest OS. With this tool, 
you can access the host computer shared folders from 
the virtual machine. 
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Shared Profile Tool Windows Shared Profile Tool enables you to map some of the 
folders in the physical computer home folder to your user 
folders in the virtual machine, which allows you to access 
the physical computer home folders right from your virtual 
machine. 

Parallels Compressor Windows The Parallels Compressor utility enables you to reduce 
the size of your virtual machine's hard disk. 

After the Parallels Tools installation, the following features are available for settings up in Parallels 
Workstation. 

SmartMount Windows, 

Linux 

SmartMount feature enables the automatic detection and 
mounting of removable devices in your virtual machines. 

Parallels Tools can be installed in all Windows and Linux guest operating systems officially 
supported by Parallels Workstation. 
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Installing Parallels Tools in a Windows Guest OS 

If you created your virtual machine using the Express Windows mode (p. 50), Parallels Tools were 
installed automatically after the installation of the Windows guest operating system. 

If your virtual machine was created in the Typical (p. 51) or Custom mode, do the following to install 
Parallels Tools in it: 

1 Start the virtual machine and log in to the guest operating system. 

2 When the guest OS boots up, connect the Parallels Tools ISO image by choosing the Install 
Parallels Tools option from the Virtual Machine menu. 

Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed 
in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the 
Parallels Tools Overview section (p. 61) in Parallels Workstation Help available through the Help 
menu. 

3 In the Welcome window, click Install. The wizard will start the automatic installation. 

4 When the installation is complete, click Reboot to exit the wizard and restart the virtual 
machine. 

If the Parallels Tools installation does not start automatically, you can launch it manually: 

1 Start the virtual machine and log in to the guest operating system. 

2 When the guest OS boots up, connect the Parallels Tools ISO image by right-clicking the 
CD/DVD-ROM icon in the virtual machine's window status bar and choosing Connect Image. 

3 Open the following folder: 

• In 32-bit Windows: C:\Program Files\Parallels\Parallels 
Workstation\Tools\ 

• In 64-bit Windows: C:\Program Files (x86)\Parallels\Parallels 
Workstation\Tools\ 

Select the prl-tools-win.iso file and click Open to connect it to the virtual machine. 

4 In the virtual machine, open My Computer and double-click the Parallels Tools disc icon to 
expand its contents. 

Note: If the installation wizard does not launch automatically, right-click the disc, choose Open from the 
shortcut menu, and double-click Setup.exe to launch the installer. 

5 Follow the wizard's instructions to complete the installation. 

To edit the settings of Parallels Tools installed in your virtual machine, use the Services pane (p. 
123) of the Virtual Machine Configuration dialog. 

How to check if Parallels Tools have been installed 
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To check whether Parallels Tools have been successfully installed, ttart your virtual machine and 
look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse 
and keyboard" appears in the status bar of the virtual machine's window, this means that 
Parallels Tools were not installed. If Parallels Tools are installed, you do not need to press any key 
to release the mouse and keyboard because they are released automatically. 
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Installing Parallels Tools in a Linux Guest OS 

Before installing Parallels Tools in a Linux guest OS, perform the following actions: 

• Close all applications in the guest operating system. 

• Disable the 3D accelerated window manager if you use any. 

• Make sure that you have the gcc package and kernel sources installed. If these packages are 
not installed, the Parallels Tools installer will inform you about this. The kernel sources package 
name depends on the type of Linux operating system you use: it can be kernel-devel, or 
kernel-headers, or something else. For more information about the kernel sources, refer to 
the Installing the GCC package and Kernel Sources in Linux section (p. 170). 

Note: To install Parallels Tools in your virtual machine, you must have the root privileges.  

Installing Parallels Tools in the most recent versions of Linux guest OSs 

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) in your virtual machine, 
the prl-tools-lin.iso image file will be mounted automatically after you connect it to the 
CD/DVD drive. To install Parallels Tools, do the following: 

1 Start the virtual machine. 

2 When the guest OS boots up, click the Virtual Machine menu and choose Install Parallels 
Tools. 

Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed 
in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the 
Parallels Tools Overview section (p. 61) of Parallels Workstation User's Guide. 

3 The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive 
and mounted. 

You can connect and mount the Parallels Tools ISO image file manually. Right-click the 
CD/DVD-ROM icon in the virtual machine's window status bar and choose Connect Image. 
Open the following folder: 

• In 32-bit Windows: C:\Program Files\Parallels\Parallels 
Workstation\Tools\ 

• In 64-bit Windows: C:\Program Files (x86)\Parallels\Parallels 
Workstation\Tools\ 

• In Linux: /usr/share/parallels-workstation/tools/ 

Select the prl-tools-lin.iso file, and click Open to connect it to the virtual machine. 

4 Start a terminal in your Linux guest OS. Type the following command to gain the root 
privileges: 

su 

5 Change the directory to the CD/DVD drive directory using 
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cd /media/cdrom/ 

Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear 
as /media/Parallels\ Tools/. 

6 In the CD/DVD drive directory, enter the following command to launch Parallels Tools 
installation: 

./install 

7 Follow the Parallels Tools Installer instructions to complete the installation. 

8 When the installation of Parallels Tools is complete, restart your virtual machine. 

Installing Parallels Tools in other versions of Linux guest OSs 

To install Parallels Tools in the older versions of Linux OSs, you have to mount the prl-tools-
lin.iso image file manually. Do the following: 

1 Start the virtual machine. 

2 When the guest OS boots up, choose Install Parallels Tools from the Virtual Machine menu. 

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system 
complies with the requirements for Parallels Tools installation. 

The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive. 

3 Start a terminal in your Linux guest OS. Type the following command to gain the root 
privileges: 

su 

4 Check if the Parallels Tools CD image is mounted by entering 
mount | grep iso9660 

If this command does not return anything, proceed to the next step. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0), 

skip the next step and proceed to the following one. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0) 

with the noexec option present in parentheses, you need to unmount the disc using the 
following command and then proceed to the next step: 

umount /dev/cdrom 

5 To mount the Parallels Tools installation disc image, enter the following: 
mount -o exec /dev/cdrom /media/cdrom 

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for 
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb 
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this 
case, you should create the mount point directory manually. 

6 When the installation disc image is mounted, change the directory to the CD/DVD drive 
directory using 
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cd /media/cdrom/ 

7 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation: 
./install 

Note: You must have the root privileges to run this command. 

8 Follow the Parallels Tools Installer instructions to complete the installation. 

9 When the installation of Parallels Tools is complete, restart your virtual machine. 

How to check if Parallels Tools have been installed 

To check whether Parallels Tools have been successfully installed, ttart your virtual machine and 
look at the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse 
and keyboard" appears in the status bar of the virtual machine's window, this means that 
Parallels Tools were not installed. If Parallels Tools are installed, you do not need to press any key 
to release the mouse and keyboard because they are released automatically. 
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Updating Parallels Tools 

The procedure of updating Parallels Tools depends on the guest operating system they are 
installed in. 

In a Windows guest OS 

Parallels Workstation automatically checks for new Parallels Tools updates when you start your 
virtual machine. 

Note: Parallels Tools can be updated only for the Windows 2000 and later guest operating systems. 

If a newer version of Parallels Tools is available, you will see the corresponding message offering 
you to download and update the tools. Click Yes to download Parallels Tools from the Parallels 
Update server and install them into your virtual machine. Updating will start right after the download 
finishes and will prompt you to restart the virtual machine when it is complete. 

If you do not want to update Parallels Tools or want to do it later, click No. You will be able to 
update them later by using the Update Parallels Tools option from the Virtual Machine menu. 

Note: If you revert to a snapshot that was made when you had an earlier version of Parallels Tools in 
your virtual machine, you will also be offered to update them. 

If Parallels Tools are up-to-date but you want to reinstall them, select the Reinstall Parallels Tools 
option from the Virtual Machine menu. 

In a Linux guest OS 

In Linux guest operating systems, you should check for Parallels Tools updates manually from time 
to time. 

To update Parallels Tools: 

1 Start the virtual machine. 

2 Choose Update Parallels Tools from the Virtual Machine menu and follow the instructions. 

3 When the update is complete, restart your virtual machine. 
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Removing Parallels Tools 

Parallels Tools can be removed through a general procedure of removing applications from the 
operating system installed in your virtual machine.  

Removing from a Windows guest OS 

1 Start the virtual machine and log in to the guest OS. 

2 From the Windows Start menu, choose Control Panel > Add or Remove Programs. In 
Windows Vista, choose Control Panel > Programs and Features. 

3 Select Parallels Tools in the list and click Remove. 

4 When Parallels Tools are removed, restart the guest operating system. 

Removing from a Linux guest OS 

1 Start the virtual machine. 

2 To remove Parallels Tools, connect and mount the prl-tools-lin.iso image and launch 
the Parallels Tools installer. For detailed instructions, see Installing Parallels Tools in a Linux 
Guest OS (p. 65). 

3 Follow the on-screen instructions. When prompted to choose the action to perform, select 
Remove and press Enter. 

4 Once Parallels Tools are successfully removed, press Enter to close the window. 
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Get Started 

Start a Virtual Machine 

To use guest OS programs on your host computer, the virtual machine with this guest OS installed 
must be running. 

To start a virtual machine, do the following: 

1 Open Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine you want to start and click Virtual Machine > 
Start. 

The virtual machine starts and you can begin using guest OS programs. 
 

C H A P T E R  5  

Work with a Virtual Machine 
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Install Programs in a Virtual Machine 

You can install programs in a Parallels virtual machine using the following media: 

• CD and DVD discs 

• Images of CD or DVD discs made with the help of third-party imaging products 

Note: Parallels Workstation supports ISO image files. 

To install a program using a CD or DVD disc: 

1 Insert the disc. 

2 Do one of the following: 

• Click the CD/DVD icon  in the virtual machine status bar (p. 43) and choose Real 
CD/DVD from the shortcut menu. 

• Choose CD/DVD 1 > Real CD/DVD from the Devices menu. 

To use an image of a disc: 

3 Do one of the following: 

• Click the CD/DVD icon  in the virtual machine status bar (p. 43) and choose Connect 
Image from the shortcut menu. 

• Choose CD/DVD 1 > Connect Image from the Devices menu. 

4 Specify the image file. 

For further installation steps, refer to the documentation of the program you are installing. 
 



72 
 

Work with a Virtual Machine 
 

Shut Down or Suspend a Virtual Machine 

When you're finished using guest OS programs, you can leave the virtual machine running as you 
work with your host OS applications. Or you may want to stop the virtual machine from running so 
more of your computer's resources are available for your host OS applications. There are a few 
ways to stop the virtual machine. 

Suspend a Virtual Machine 

Suspending a virtual machine conveniently freezes all running guest OS programs and settings in 
their current state. 

To suspend a virtual machine: 

1 Close the Parallels Workstation main window. 

2 Click Suspend. 

The next time you start the virtual machine, you resume your progress from exactly where you left 
off. 

You can also suspend the virtual machine without quitting Parallels Workstation by doing one of the 
following: 

• If the virtual machine is working in Window (p. 76), click Virtual Machine > Suspend in the 
Parallels Workstation main window. 

• If the virtual machine is working in Full Screen (p. 77), press Ctrl + Alt + Enter to switch the 
virtual machine to the Window view mode and click Virtual Machine > Suspend. 

Pause a Virtual Machine 

You can temporarily pause from using the guest OS and free your computer's resources, such as 
RAM and processor cycles, to be used by your host OS programs by doing the following: 

• Choose Virtual Machine > Pause. 

To resume using the virtual machine after pausing it, do the following: 

• Choose Virtual Machine > Resume. 

Shut Down a Virtual Machine 

Shutting down a virtual machine in Parallels Workstation is just like shutting down the guest 
operating system on a PC. All guest OS programs close, giving you the opportunity to save your 
progress if necessary, and the guest OS stops running. 

To shut down a virtual machine, do the following. 
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• Choose Virtual Machine > Shut Down. 

Stop a Virtual Machine 

To stop a virtual machine and all open guest OS programs immediately: 

1 Do the following: 

• Choose File > Quit. 

2 Click Stop. 

Important: When you stop a virtual machine this way, none of your data or progress is saved. 

You can also stop a virtual machine without quitting Parallels Workstation by doing the following: 

• Choose Virtual Machine > Stop. 

Window Menu 

If a virtual machine is set to appear in a separate window, you can also choose any of the above 
options from the menu at the bottom of the window: 
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Keyboard and Mouse 

Capture and Release the Keyboard and Mouse 

To start working in a virtual machine, you need first to capture the keyboard and mouse input in the 
virtual machine. To do this: 

1 Move the mouse pointer over the virtual machine window. 

2 Click in the window. 

When the keyboard and mouse input is captured in the virtual machine, you cannot move the 
pointer out of the virtual machine window and all keystrokes and button clicks go to the virtual 
machine. To release the keyboard and mouse back, press the hot key combination (Ctrl+Alt by 
default). The keyboard and mouse will be released immediately. 

Note: You can change the key combination for releasing the keyboard and mouse input using the 
Keyboard pane of the Preferences dialog. 

If you want to automatically capture and release the keyboard and mouse input, you should install 
Parallels Tools (p. 60) in your virtual machine. After the Parallels Tools installation, you can capture 
and release the mouse and keyboard input more easily: 

• Click anywhere in the virtual machine window to capture the input; and 

• Click anywhere outside the virtual machine window to release the input. 
 

Use Keyboard Shortcuts in a Virtual Machine 

If when working in a virtual machine, you press a special key combination intended for the guest 
OS ( for example, Ctrl+Alt+Del for any of the Windows guest operating systems) the primary 
operating system may intercept such a command. That is why in this version of Parallels 
Workstation, you can apply any of the main Windows and Linux shortcuts to your virtual machine 

with the help of the Keyboard icon  in the virtual machine status bar (p. 43). Just click the icon 
and select the desired key combination from the drop-down list. The corresponding action will take 
place in your guest OS and your primary OS will ignore this event. 
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Set How the Virtual Machine Works with the Host 
OS 
Parallels Workstation 6 allows you to work seamlessly between your host and guest operating 
systems. For example, you can cut and paste text, and share files, between the two. 

There are a number of ways that you can set the level of integration between the host and guest 
operating systems. For example, you may want your Windows guest OS programs to behave just 
like host OS programs, appearing side-by-side with them on the host OS desktop. Or you may 
wish to keep the guest OS desktop and programs in a separate window. 

Read on to learn more about setting how your guest OS works together with the host OS. 
 

Merge the Guest OS and the Host OS 

You can set a Windows virtual machine and the host operating system to work seamlessly 
together, as if they were part of a single operating system. In this mode, called "Coherence" mode, 
the Windows guest OS desktop is hidden and Windows guest OS programs appear on the host 
OS desktop next to your host OS programs. 

Note: To enable the Coherence view mode, Parallels Tools must be installed. 

To switch from Window mode to Coherence mode, do one of the following: 

• Choose View > Coherence. 

• Choose Coherence from the View menu available in the status bar (p. 43). 

To switch from Full Screen mode to Coherence mode, move the pointer to the upper-left corner of 
the screen and click the mouse. The virtual machine switches to the Window view mode (p. 76). 
Then choose View > Coherence. 

Note: In Full Screen, the upper-left corner of the screen is configured to switch to the Window view 
mode (p. 76). You can change the default settings of the screen active corners in the Full Screen pane 
(p. 121) of Virtual Machine Configuration. 

For information on adjusting settings related to Coherence mode, see Coherence (p. 120). 

Windows System Tray 

In Parallels Workstation for Windows, when a Windows virtual machine is working in Coherence 
mode, the Windows guest OS system tray icons are available in the Windows host OS taskbar. 

You can use these system tray icons just as you would from the Windows guest OS desktop. 
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Set the Guest OS to Appear in a Separate Window 

You can set the guest operating system and programs to appear together in a separate window. 
This is the default view mode for virtual machines. 

 

To switch to Window mode from Coherence mode, click the View menu in the Parallels 
Workstation main window and choose Window. 

To switch to Window mode from Full Screen mode, press Ctrl + Alt + Enter. This is the default 
keyboard shortcut to switch to and from Full Screen. You can change it in the Keyboard pane (p. 
18) of Parallels Workstation Preferences. 
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Set the Guest OS to Appear Full Screen 

You can set the virtual machine to occupy your entire screen, so it looks just like it would if you 
were using a physical PC. 

To switch to Full Screen mode, do one of the following: 

• click the Full Screen button  in the toolbar (p. 40); or 

• choose View > Full Screen. 

To exit Full Screen mode, do one of the following:: 

• Move the cursor to the left top corner of the screen and click the mouse. 

You can set any of the four corners to activate Window mode (p. 76), Coherence mode (p. 75), 
or to show the taskbar. For information on adjusting these and other settings related to Full 
Screen mode, see Full Screen (p. 121). 

• Press Ctrl + Alt + Enter. (This is the default keyboard shortcut for switching to and from Full 
Screen. You can change it in the Keyboard pane (p. 18) of Parallels Workstation Preferences.) 

 

Copy and Paste Between the Host and Guest OSs 

Parallels Workstation allows you to copy and paste pictures, formatted text (italic, bold, or 
underlined, of various colors, fonts, and sizes) between the host OS programs and guest OS 
programs. 

If Parallels Tools are installed (p. 60) in the virtual machine, copying and pasting between the host 
computer and virtual machine is already enabled. 

To enable copying and pasting between the host computer and virtual machine: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine and click Virtual Machine > Configure > 
Options > Advanced. 

3 Select Share clipboard. 

4 To preserve text formatting when copying and pasting text, select Preserve text formatting. 

Note: To enable copying and pasting between the host computer and virtual machine, Parallels Tools (p. 
60) must be installed. Copying and pasting between the host computer and virtual machine is unavailable 
if you isolate the guest OS from the host OS (p. 111). 
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Share Items Between the Host Computer and Virtual Machine 

Parallels Workstation allows you to easily access your host OS files using guest OS programs. 

Read on to learn about all the ways you can share folders, files, and applications between your 
virtual machine and the host computer. 
 

Set Internet Links to Always Open in the Host OS or Virtual Machine 

By default, clicking a link (such as a web page URL) in your virtual machine opens the default guest 
OS program for that link type, and clicking a link in the host OS opens the default host OS 
program. 

You can set links of a particular type to always open in the host OS or in your virtual machine. For 
example, you could set web pages to always open in the guest OS, even if the link is clicked in the 
host OS. 

Note: To set Internet links to open in the host OS or in your virtual machine, Parallels Tools (p. 60) must 
be installed. 

To set Internet links to open in the host OS or in your virtual machine: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine and click Virtual Machine > Configure > 
Options > Applications. 

3 Click the menu for the type of link you want to set. If you don't see the link type you want, click 
More Applications. The following types of links can be set: 

• Web pages: Web pages accessible through the HTTP and HTTPS protocols. 

• E-mail: Links in the mailto format that open a pre-addressed email. 

• Newsgroups: Links in the news. format that typically open a newsreader program. 

• FTP: File upload and download locations accessible through the FTP protocol. 

• RSS: Episodic content, such as blogs and podcasts. 

• Remote access: Locations accessible through the Telnet and Secure Shell (SSH) 
protocols. 

4 Choose one of the following: 

• Default: The link opens in the program set as default in the operating system (host OS or 
guest OS) where you click the link. 

• Open in virtual machine: Links clicked in the host OS or guest OS open in the default 
guest OS program for that link type. 

• Open on the host computer: Links clicked in the host OS or guest OS open in the default 
host OS program for that link type. 
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Share External Storage Devices and Volumes 

When you connect an external storage device, such as a USB drive, to the host computer, you can 
access the contents from the host OS applications. 

Using SmartMount, you can set Parallels Workstation to automatically mount storage devices and 
volumes to your virtual machine. That way, you can access the contents from both the host and 
guest OSs. 

With SmartMount enabled, these items are automatically mounted to the virtual machine: 

• Removable drives: External storage devices, such as USB hard disks and USB flash drives. 

• CD/DVD drives: CD and DVD drives or CD/DVD images (files most commonly ending in 
.iso.). 

• Network folders: Folders shared over the network. 

To enable SmartMount: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine for which you want to enable SmartMount and 
click Virtual Machine > Configure > Options > Sharing. 

3 In the Sharing pane, select Map host volumes to virtual machine and click OK. 

When you connect a storage device or volume, it is mounted as a network drive. For example, a 
USB flash drive plugged in to the host computer will be also accessible from the virtual machine. 

Note: Permissions for accessing the mounted device from the virtual machine are the same as 
permission settings for the device in the host OS. For example, if you can read from and write to a USB 
flash drive in the host OS, you can also read from and right to it in the guest OS. 
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Connect USB Devices to a Virtual Machine 
Parallels Workstation allows you to connect up to eight USB 2.0 and eight USB 1.1 devices to a 
single virtual machine. This means that you can plug up to eight USB 2.0 devices and eight USB 
1.1 devices into the host computer and connect them to your virtual machine. To use this feature, 
the virtual machine must have a USB controller. 

By default, when you plug a USB device into the host computer with one or more virtual machines 
running, the New USB device detected dialog appears: 
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In this dialog, you need to specify where the detected USB device will be connected: 

• Point to Computer and click it if you want to use this USB device in the host OS. 

• Point to the virtual machine and click it if you want to use this USB device in the virtual machine 
you are currently working with. 

Note: If you select to connect the detected USB device to the virtual machine and then reboot this 
virtual machine, the New USB Device dialog will not appear again after the reboot. The USB device will 
still be connected to this virtual machine. 

If you want Parallels Workstation to remember your choice, press the Alt button on the keyboard 
and keep holding it when choosing where to connect a USB device. The next time you plug this 
USB device into the host computer, it will be automatically connected to the destination you 
specified in this dialog. To change the destination, use USB pane in the Preferences dialog (p. 15). 

If you do not want Parallels Workstation to display this dialog each time a USB device is plugged 
into the host computer, configure USB Preferences in the Preferences dialog (p. 15). 

To be able to use the USB device in the virtual machine, you may need to install the necessary 
drivers in the guest OS. By default, such drivers can be obtained from the manufacturers of this 
device. 

Note: If you plug a USB 1.1 device into the USB 2.0 port, the port will be identified as USB 1.1. 

To disconnect a USB device from your virtual machine, do one of the following: 

• Right-click the USB controller icon  in the status bar (p. 43) and click this USB device listed 
in the context menu or 

• Click the Devices menu, point to the USB item, and click this USB device in the displayed 
submenu. 

 

Print from a Virtual Machine 
There are four basic ways to set up printing in a virtual machine. You can: 

• Share the host computer printer (p. 82). 

• Set up a network printer (p. 84). 

• Set up a USB printer (p. 88). 

• Set up a printer using the host computer LPT port (p. 88). 
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Share the Host Computer Printer 

You can share any printer connected to the host computer with your Windows or Linux virtual 
machine. The printer will be available through the virtual machine printer port. 

To share the host computer printer: 

1 Launch Parallels Workstation and select a virtual machine. 

2 Open the Virtual Machine Configuration dialog by choosing Configure from the Virtual 
Machine menu. Go to the Hardware tab and make sure the configuration includes a printer 
port. If necessary, add it. See Adding and Removing Devices. 

3 In the Printer Port pane, select Connected if you want the printer to be automatically 
connected on the virtual machine startup. Click the Source field and select the appropriate 
printer from the list. You can use the Default printer option if you want to use the default printer 
set in the primary OS. 

4 Click OK to close the Virtual Machine Configuration dialog. 

5 Start the virtual machine. 

6 In a Windows guest OS, if you have Parallels Tools installed, the HP Color LaserJet 8500 PS or 
Apple Color LW 12/660 PS printer is automatically connected to the virtual machine. You can 
use it at once. In a Linux guest OS, or if you do not have Parallels Tools installed in your 
Windows guest OS, no matter what type of printer you have, install either the HP Color LaserJet 
8500 PS or Apple Color LW 12/660 PS printer driver. Then follow the procedure of adding a 
printer in a guest OS described below. 

Warning: Do not install the driver from the installation CD (supplied with your printer) in the virtual 
machine. 

Adding a printer in a Windows guest operating system 

To add a printer in a Windows 7 or Windows Vista guest operating system: 

1 Start the Windows virtual machine and log in as administrator. 

2 Open the Windows Start menu and select Control Panel. 

3 In the Control Panel window, select Hardware and Sound and click Add a printer in the 
Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens. 

4 In the first wizard window, click Add a local printer. 

5 In the Choose a printer port window, choose LPT1: (Printer Port) (or another port to which 
the printer is connected) from the Use an existing port menu. When ready, click Next. 

6 In the Install the printer driver window, specify the printer manufacturer and model. No matter 
what printer you have, choose either HP Color LaserJet 8500 PS or Apple Color LW 12/660 
PS. When ready, click Next. 
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7 Continue with the printer configuration procedure. When the printer is added to the guest 
operating system, you can use it to print documents from your Windows 7 or Windows Vista 
virtual machine. 

To add a printer in a Windows XP guest operating system: 

1 Start the Windows virtual machine and log in as administrator. 

2 Open the Windows Start menu and select Control Panel. 

3 In the Control Panel window, double-click the Printers and Faxes item. 

4 Click the Add a printer link to open the Add Printer wizard. 

5 In the Welcome to the Add Printer Wizard window, click Next. 

6 In the Local or Network Printer window, select Local printer attached to this computer and 
clear the Automatically detect and install my Plug and Play printer option if it is also 
selected. When ready, click Next. 

7 In the Select a Printer Port window, choose LPT1: (Recommended Printer Port) (or another 
port to which the printer is connected) from the Use the following port menu. When ready, 
click Next. 

8 In the Install Printer Software window, specify the printer manufacturer and model. No matter 
what printer you have, choose either HP Color LaserJet 8500 PS or Apple Color LW 12/660 
PS. When ready, click Next. 

9 Continue with the printer configuration procedure. When the printer is added to the guest 
operating system, you can use it to print documents from your Windows XP virtual machine. 

Adding a printer in a Linux guest operating system 

The procedure of adding a printer in a Linux guest operating system depends on the Linux 
distribution. In this example, we describe how to add a printer to a virtual machine running RHEL 
5.4 Server. However, you can use these guidelines as general instructions on how to add a printer 
to a Linux virtual machine: 

1 Start the Linux virtual machine and log in when the guest operating system boots up. 

Note: You must log in as root or acquire root privileges after successful login. If you don't do that, you 
will be required to enter the root password when starting the system-config-printer 
administration tool in the next step. 

2 Start the system-config-printer administration tool by doing one of the following: 

• Click System > Administration > Printing; or 

• Start the Terminal and enter the following command: 
system-config-printer 

3 In the displayed window, click New Printer. 

4 In the next window, you must type a printer name. Under this name the printer will be displayed 
in your Linux guest operating system. You can also enter the printer description and location. 
When ready, click Forward. 
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5 Now you have to specify how the host computer printer will be shared with the virtual machine. 
As the printer is connected to the virtual machine printer port, select LPT #1 (or another port to 
which the printer is connected) and click Forward. 

6 Then specify the printer manufacturer and model. No matter what printer you have, choose 
either HP Color LaserJet 8500 PS or Apple Color LW 12/660 PS. When ready, click Forward. 

7 Click Apply to finish setting up the printer. 

Now the printer is properly configured and you can use it to print documents from your Linux 
virtual machine. 

 

Set Up a Network Printer 

 You can install a network printer directly into a guest operating system. 

Before installing a network printer in a guest operating system, make sure that: 

• The host computer can access the Internet. 

• The virtual machine can access the Internet too. 

• The user account in the guest OS from which you are going to set up the printer has 
permission to access the network printer. 

• You know the printer IP address. 

After that, you can log in to your guest OS and install a network printer. 

In a Windows Guest Operating System 

Before adding a network printer in Windows, download and install an appropriate printer driver. For 
detailed information on installing the printer driver, refer to the printer manufacturer documentation. 

To add a network printer in a Windows 7 or Windows Vista guest operating system: 

1 Open the Windows Start menu and select Control Panel. 

2 In the Control Panel window, select Hardware and Sound and click Add a printer in the 
Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens. 

3 In the first window, click Add a network, wireless or Bluetooth printer. 

4 In the next window, click The printer that I want isn't listed. 

5 In the Find a printer by name or TCP/IP address window, select Add a printer using a 
TCP/IP address or hostname and click Next. 

6 In the Type a printer hostname or IP address window, do the following: 

1. Select TCP/IP Device from the Device type menu. 

2. Specify the printer IP address in the Hostname or IP address field. 
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3. Clear the Query the printer and automatically select the driver to use option if it is 
selected. 

4. When ready, click Next. 
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7 If prompted to specify additional port information, choose Standard, select Generic Network 
Card from the list, and click Next. 

8 In the Install Printer Software window, specify the manufacturer and model of the network 
printer. 

If the required printer model is not listed, click Have Disk button and specify the path to the 
.inf file located in the folder where you installed the printer driver. 

When ready, click Next. 

9 Continue with the printer configuration procedure. When the printer is added to the guest 
operating system, you can use it to print documents from your virtual machine. 

To add a network printer in a Windows XP guest operating system: 

1 Open the Windows Start menu and select Control Panel. 

2 In the Control Panel window, double-click the Printers and Faxes item. 

3 Click the Add a printer link to open the Add Printer wizard. 

4 In the Welcome to the Add Printer Wizard window, click Next. 

5 In the Local or Network Printer window, select Local printer attached to this computer and 
clear the Automatically detect and install my Plug and Play printer option if it is also 
selected. When ready, click Next. 

6 In the Select a Printer Port window, select Create a new port and specify Standard TCP/IP 
Port as the port type. When ready, click Next. 

7 In the Welcome to the Add Standard TCP/IP Printer Port Wizard window, click Next. 

8 In the Add Port window, specify the network printer IP address and click Next. 

9 If prompted to specify additional port information, choose Standard, select Generic Network 
Card from the list, and click Next. 

10 In the Completing the Add Standard TCP/IP Printer Port Wizard window, click Finish. 

11 In the Install Printer Software window, specify the manufacturer and model of the network 
printer. 

If the required printer model is not listed, click Have Disk button and specify the path to the 
.inf file located in the folder where you installed the printer driver. 

When ready, click Next. 

12 Continue with the printer configuration procedure. When the printer is added to the guest 
operating system, you can use it to print documents from your Windows XP virtual machine. 

In a Linux or FreeBSD Guest Operating System 
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The procedure of setting up a network printer in a Linux or FreeBSD guest operating system 
depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set 
up a network printer in a virtual machine running RHEL 5.4 Server. However, you can use these 
guidelines as general instructions on how to set up a network printer in a Linux or FreeBSD virtual 
machine. 

Note: For more detailed information, refer to the CUPS documentation. 

To set up a network printer: 

1 Start the virtual machine. 

2 Make sure the following components are installed in the guest operating system: 

• Common UNIX Printing System (CUPS). Installation instructions can be found at CUPS site; 

• Samba service. Installation instructions can be found at Samba site; and 

• A Web browser, since we consider controlling CUPS via web interface. 

Note: To set up a network printer, you must have root privileges. 

3 Download and install an appropriate printer driver. For detailed information on installing the 
printer driver, refer to the printer manufacturer's documentation. 

4 Start Common UNIX Printing System. In the Terminal, type the command: 
/etc/init.d/cups start 

5 Start a web browser and type either the IP address of your virtual machine or 
http://127.0.0.1:631. 

6 Click the Add Printer button. 

7 In the Add New Printer window, specify a printer name. Under this name the printer will be 
displayed in the guest operating system. You can also enter the printer description and location. 
When ready, click Forward. 

8 In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click 
Continue. 

9 In the Device URI for <Printer Name> window, specify the printer IP address in the following 
format: 

socket://<printer IP address> 

When ready, click Continue. 

10 In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your 
printer and click Continue. 

11 In the Model/Driver for <Printer Name> window, select the model of your printer and click 
Add Printer. 

12 Enter the root password when prompted. 
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CUPS performs the installation. If the installation is successful, the "Printer <name> has been 
configured successfully" message is displayed. Now you can use this printer to print 
documents from the virtual machine. 
 

Set Up a USB Printer 

To set up a USB printer: 

1 Launch Parallels Workstation and choose the virtual machine. 

2 Open the Virtual Machine Configuration dialog by choosing Configure from the Virtual 
Machine menu. Make sure that the configuration includes a USB controller. If necessary, add it. 

3 Click OK. 

4 Start the virtual machine. 

5 Plug in the USB printer as a USB device. See Connect USB Devices to a Virtual Machine (p. 
80). 

6 Install the native driver for the printer in the guest OS. 
 

Set Up a Printer Using the Host Computer LPT Port 

To set up printing through a printer port of the host computer: 

1 Make sure that a printer is connected to the LPT port of the host computer. 

2 Open the virtual machine configuration, make sure it includes a printer port. If necessary, add it. 

3 Choose the necessary parallel port of the host computer from the drop-down menu. 

4 Click OK and start the guest operating system. 

5 Install the native driver for your printer in the guest OS. 
 

Protect Your Data 

Protect a Virtual Machine From Viruses 

To protect your virtual machine from viruses, you can install any antivirus software you like in the 
guest operating system. 
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Isolate a Virtual Machine from the Host Computer 

You can isolate your virtual machine from the host computer, so that they no longer share folders, 
profiles, and applications, connected external devices are no longer automatically accessible by the 
guest OS, and you can no longer copy or move objects between the host and guest OSs. 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine you want to isolate and click Virtual Machine > 
Configure > Options > Permissions. 

3 Select Isolate host from guest and click OK. 
 

Work with a Virtual Machine Without Saving Changes 

If you don't want your virtual machine to store the changes you make to it during the working 
session (for example, when testing some guest OS programs that may damage the guest OS), you 
can start the virtual machine in Safe Mode: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine that you want to start in Safe Mode and click 
Virtual Machine > Safe Mode. 

Set a Virtual Machine to Always Start in Safe Mode 

If you want your virtual machine to always start in Safe Mode: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine and click Virtual Machine > Configure > 
Options > Permissions. 

3 In the Permissions pane, choose Ask me what to do from the Undo Disks menu and click 
OK. 

Note: If you have the automatic compression of virtual disks enabled in the Optimization pane (p. 109), 
it will become disabled after you enable Undo Disks. 
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Encrypt a Virtual Machine to Protect It from Unauthorized Use 

If you store any important data using guest OS programs, it is highly recommended that you 
encrypt the virtual machine to protect your data from any unauthorized use. 

Encrypt a Virtual Machine 

To encrypt a virtual machine (it must be shut down): 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine you want to encrypt and click Virtual Machine 
> Configure > Options > Permissions. 

3 In the Permissions pane, click Turn On, specify a password, and click OK. 

Warning! The specified password is very important. You must record it. Without this password, 
you can't start the virtual machine. 

Change Your Password 

To change the password for an encrypted virtual machine (it must be shut down): 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine which password you want to change and click 
Virtual Machine > Configure > Options > Permissions. 

3 In the Permissions pane, click Change Password, specify a new password, and click OK. 

Remove Encryption from the Virtual Machine 

To remove encryption from the virtual machine (it must be shut down): 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine which encryption you want to remove and click 
Virtual Machine > Configure > Options > Permissions. 

3 In the Permissions pane, click Turn Off, specify the encryption password, and click OK. 
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Connect to the Internet or a Network 
Parallels Workstation allows you to use the following types of networking with virtual machines: 

• Shared Networking (p. 92): guest OS programs share a network connection with the host OS. 
This is the default setting. 

• Bridged Ethernet (p. 93): guest OS can use one of the host computer network adapters. This 
makes the virtual machine appear as a separate computer on the network. 

• Host-only networking (p. 94): the virtual machine can access only the host computer and 
other virtual machines residing on it. 

• Networking using a PCIe network adapter (p. 95). This type of networking allows the virtual 
machine to access the local network and Internet through an Intel VT-d PCIe network adapter. 

In most cases, you don't need to adjust network settings. If the host computer is set to connect to 
a network or to the Internet, guest OS programs have access to the same network and the 
Internet. 

The Bridged Ethernet networking mode is more complex and you may need to contact your 
system administrator to set it up properly. 

Read on for detailed information on these types of networking and how to configure them. 
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Share Network Settings Between the Host Computer and Virtual 
Machine 

By default, a guest OS is set to share network settings with the host OS. Guest OS programs can 
access other computers on your local network and the Internet by using the host computer IP 
address. Guest OS does not have its own IP address on the network. 

In most cases, you don't need to adjust network settings. If the host computer is set to connect to 
a network or to the Internet, guest OS programs have access to the same network and the 
Internet. 
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You may wish to use Shared Network mode in the following cases: 

• The host computer accesses the Internet via a modem or another non-Ethernet device. 

• You need to access the Internet from inside the guest OS but are concerned about security. 

• You have problems with working in the Bridged Ethernet mode (p. 93). 

To configure the guest OS to use Shared Networking: 

1 In Parallels Workstation, choose Virtual Machine > Configure. 

2 Select Network in the Hardware list. 

3 In the Network pane, make sure that the Connected and Shared Network options are 
selected. 

Note: In the MAC address field, you can change the MAC address currently assigned to the virtual 
machine. MAC addresses are automatically generated when you first set up the guest OS on the host 
computer. However, you can modify the default MAC address by typing another value in the MAC 
address field or clicking the Generate button. When entering a new MAC address, make sure that it is 
unique within your network. 

4 Click OK. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base http://kb.parallels.com/ available at the Parallels website. 
 

Apply Separate Network Settings to the Virtual Machine 

When operating in the Bridged Ethernet mode, the virtual machine appears on the network as a 
stand-alone computer with its own IP address and network name. 

Note: The Bridged Ethernet networking mode is more complex than the Shared Networking mode (p. 
92) and you may need to contact your system administrator to configure it properly. 

 

http://kb.parallels.com/�
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To configure a virtual machine to work in the Bridged Ethernet mode: 

1 In Parallels Workstation, choose Virtual Machine > Configure. 

2 Select Network in the Hardware list. 

3 In the Network pane, make sure that the Connected option is selected. 

4 Select the appropriate network adapter from the list. To connect the virtual machine's adapter 
to the active network adapter of the host computer, choose Default Adapter. 

Note: In the MAC address field, you can change the MAC address currently assigned to the virtual 
machine. MAC addresses are automatically generated when you first set up the guest OS on the host 
computer. However, you can modify the default MAC address by typing another value in the MAC 
address field or clicking the Generate button. When entering a new MAC address, make sure that it is 
unique within your network. 

5 Click OK. 

If you can't configure the virtual machine to function in the Bridged Ethernet mode, consider using 
Shared Networking (p. 92) or Host-Only Networking (p. 94). 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base http://kb.parallels.com/ available at the Parallels website. 
 

Use Host-Only Network Settings 

Parallels Workstation provides a closed network that is accessible only to the host OS and virtual 
machines running on the host computer. The host OS is connected to this network via the Parallels 
Host-Only Networking adapter automatically created on the host computer during the Parallels 
Workstation installation. The addresses for virtual machines are provided by the Parallels DHCP 
server. 

 

http://kb.parallels.com/�
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To configure the virtual machine to use Host-Only Networking: 

1 In Parallels Workstation, choose Virtual Machine > Configure. 

2 Select Network in the Hardware list. 

3 In the Network pane, make sure that the Connected and Host-Only Network options are 
selected. 

Note: In the MAC address field, you can change the MAC address currently assigned to the virtual 
machine. MAC addresses are automatically generated when you first set up the guest OS on the host 
computer. However, you can modify the default MAC address by typing another value in the MAC 
address field or clicking the Generate button. When entering a new MAC address, make sure that it is 
unique within your network. 

4 Click OK. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base http://kb.parallels.com/ available at the Parallels website. 
 

Connect Using a PCIe Network Adapter 

If the host computer has an Intel VT-d chipset and you're using Parallels Workstation 6 Extreme, 
you can use a PCIe network adapter to connect your virtual machine to the local network and 
Internet. The virtual machine will directly access the PCIe network adapter without using the host 
OS resources. Before adding a PCIe network adapter to the virtual machine, assign it to your virtual 
machines in the Intel VT-d pane (p. 20) of Parallels Workstation Preferences. 

 

http://kb.parallels.com/�
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To configure your virtual machine to use the PCIe network adapter: 

1 In Parallels Workstation, choose Virtual Machine > Configure. 

2 Select Network in the Hardware list. 

3 In the Network pane, make sure that the Connected and Direct Assignment (using Intel VT-
d) options are selected. 

4 Select the appropriate PCIe network adapter from the list. Click OK. 

5 Start the virtual machine and install the manufacturer's driver for this PCIe device inside the 
virtual machine. The driver should support the Intel VT-d technology. 

After performing these steps you will be able to use the PCIe network adapter directly from the 
guest OS. 

Note: You can assign one PCIe network adapter to several virtual machines but only one virtual machine 
can use one PCIe network adapter at a time. 

 

Troubleshooting 

In the Windows host OS, you may have problems with the automatic PCI device pass-through 
driver installation. In this case, you should install it manually. 

To install the Parallels network adapter pass-through driver in the Windows host OS 

1. Go to Start > Control Panel > System > Hardware and open Device Manager. 

2. In Device Manager, locate the appropriate network adapter, right-click it, and choose Update 
Driver from the context menu. 

3. In the Hardware Update wizard, choose to install the driver from the specific location. 

4. Choose to specify the driver yourself. 

5. In the next window, select the Have Disk option and specify the following path as the driver’s 
location: C:\Program Files\Parallels\Parallels 
Workstation\Drivers\prl_vtdnet.inf and click Open. 

6. Follow the wizard’s instructions to complete the installation of the driver. 

7. Restart the host computer. 
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Using Multiple Displays 
This version of Parallels Workstation enables you to use separate displays for your host computer 
and your virtual machines and freely move the mouse pointer between them. To be able to use this 
feature, your host computer and virtual machines should comply with the following requirements: 

• The host computer should support the Intel VT-d technology and the Intel VT-d support should 
be enabled in BIOS. 

• The host computer configuration should have at least one free PCIe video adapter (p. 10) (in 
addition to the PCIe video adapter used by the host computer) with a display connected to it. 

• At least one PCIe video adapter should be allocated to virtual machines in Parallels Workstation 
Preferences (p. 20) and included in the configuration of one of your virtual machines. 

Note: To ensure this PCIe video adapter proper functioning, you should install the latest driver into the 
guest OS. The latest drivers are available on the manufacturer's website. 

• An up-to-date version of Parallels Tools (p. 60) should be installed in the virtual machine that 
uses this PCIe video adapter. 

• If you use two monitors with your Linux host computer, enable either the Xinerama or TwinView 
mode in the operating system to ensure the proper multi-monitor support. If you use two 
monitors with your Linux virtual machine, enable either of the two modes in the guest operating 
system. 

You can easily arrange the displays (p. 98) allocated to your host computer and virtual machines 
using Display Manager. To launch Display Manager: 

1 Start the virtual machine that has the directly assigned PCIe video adapter with a separate 
display connected. 

2 Choose Display Manager from the File menu. 
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Display Manager 

If you use separate displays for the host computer and virtual machines, Display Manager allows 
you to specify the order according to which the mouse pointer will flow from one display to another. 

To launch Display Manager, start the virtual machine that has the directly assigned PCIe video 
adapter with a separate display connected and choose Display Manager from the File menu. 

The Parallels Display Manager window shows the displays used by the host computer and virtual 
machines. If you have two displays connected to one PCIe video card, they are joined into one 
display group. 

To make the explanation more vivid, let us assume that you have the "XP x64" and "Vista" 
virtual machines running on the host computer and three displays: one for the host computer, the 
second for "XP x64", the third for "Vista". If you launch Display Manager, its window may look 
like as follows: 
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The displayed arrangement of monitors means the following order of mouse pointer movements: 

• If you are working with the host computer and move the mouse pointer to the right, it will set 
against the border. 

• If you are working with the host computer and move the mouse pointer to the left, it will appear 
on the display used for the "Vista" virtual machine. 

• If you are working with the "Vista" virtual machine and move the mouse pointer to the right, it 
will appear on the display used for the host computer. 

• If you are working with the "Vista" virtual machine and move the mouse pointer to the left, it 
will appear on the display used for the "XP x64" virtual machine. 

This order of mouse pointer movements is inconvenient if, for example, in reality the display used 
for the host computer is betwresolutioneen the displays used for the virtual machines. In this case, 
in the Parallels Display Manager window, you should rearrange the order of displays to place 
them in accordance with the reality. 

To rearrange the displays or display groups: 

1 Click on the display or display group you want to move or select it in the Computer drop-down 
list. 

2 Drag this display or display group to the desired position. 

3 To apply the changes, click OK. Otherwise, click Cancel. 

The positions of displays in a display group cannot be rearranged in Display Manager. You can 
change the layout and  of each display or display group by editing the display settings in the 
operating system of your host computer or the respective virtual machine. 

Before managing your virtual machines via Display Manager, make sure they meet the following 
requirements: 

• They should be running or paused. 

• They should have a PCIe video adapter with a separate display connected. 

• They should have the latest version of Parallels Tools installed. See Updating Parallels Tools 
(p. 68). 
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Using Intel VT-d PCI Devices in Parallels Virtual 
Machines 
If your computer has an Intel VT-d chipset, you can set the physical PCI Express (PCIe) devices 
connected to the physical computer to be directly assigned to your virtual machine. The virtual 
machine will directly access the PCIe devices without using the resources of the primary OS. 

You can connect up to eight PCIe devices of any of the supported types to a single virtual machine. 

To connect a PCIe device to a virtual machine 

1 Assign the device to your virtual machines in the Intel VT-d pane (p. 20) of Parallels 
Workstation Preferences. 

Note: You are recommended to have at least two adapters of the same type (video or network 
adapters): if you reassign one adapter to your virtual machines, the other adapter will be left to the 
physical computer. Keep in mind that if you assign your video or network adapter to a virtual machine, 
this adapter will be invisible to your primary OS. 

2 Add the device to the virtual machine configuration. 

Troubleshooting 

In Windows-based virtual machines, if the pass-through driver cannot be installed automatically 
after a PCIe device has been assigned to virtual machines in Preferences, install it manually by 
doing the following: 

1 Go to Start > Control Panel > System > Hardware and open the Device Manager. 

2 In the Device Manager, locate the appropriate PCIe device, right-click it and choose Update 
Driver from the context menu. 

3 In the Hardware Update wizard, choose to install the driver from the specific location. 

4 Choose to specify the driver yourself. 

5 In the next window, select the Have Disk option and specify the following path to the driver’s 
location: C:\Program Files\Parallels\Parallels 
Workstation\Drivers\prl_vtdvideo.inf or C:\Program 
Files\Parallels\Parallels Workstation\Drivers\prl_vtdnet.inf and click 
Open. 

6 Follow the wizard’s instructions to complete the installation of the driver. 

7 Restart the host computer. 

In rare cases you cannot boot the primary Linux operating system after a PCIe device is added to 
the configuration of a virtual machine. To work around the issue, do the following: 
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1 In the grub loader splash screen, with your primary operating system selected in the list, press 
e on the keyboard to display the boot parameters. 

2 Select the line starting with "kernel" by pressing the down arrow on the keyboard. 

3 Press e to launch an editor for the selected line. 

4 At the end of the line, add 
init=/bin/sh 

5 Press Enter to return to the boot parameters screen. 

6 Press b to boot the kernel. 

7 In the command line window, mount the root partition in read-write mode by entering 
mount /dev/root / -oremount,rw  

Note: If you want your root partition to be mounted to a different location, replace root with this 
location in the command above. 

8 Type the following command and press Enter: 
echo -n "" > /etc/parallels/vtd.hook 

9 Type the following command and press Enter: 
mount /dev/root / -oremount,ro  

10 Type the following command and press Enter: 
reboot 

This procedure will make your primary Linux operating system boot normally. 
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Work with Your Virtual Machines on an iPad, 
iPhone, or iPod touch 
You can use the free Parallels Mobile app to access and control your virtual machines remotely 
from your iPad, iPhone, or iPod touch. 

Parallels Mobile lets you: 

• Use any of your virtual machine programs on your iPad, iPhone, or iPod touch 

• Remotely start, stop, and reset a virtual machine 

• Connect over Wi-Fi or 3G 

• Access your virtual machines from anywhere over the Internet 

Get Started 

Before you can use Parallels Mobile, you must do the following: 

1 Be sure you have registered to use Parallels Workstation (p. 15). 

2 On your iPad, iPhone, or iPod touch, download and install Parallels Mobile from the App Store. 

3 Be sure you have created at least one virtual machine on the host computer. 

4 In Parallels Workstation, click File > Preferences. 

5 In the left pane, click iPhone. 

6 Log in to your Parallels account using the email and password you used to register Parallels 
Workstation. 

You only have to do these steps once. 

Access Your Virtual Machines from Your iPad, iPhone, or iPod touch 

1 Turn on the host computer. 

It must be on for Parallels Mobile to access and use your virtual machines. 

2 Open Parallels Mobile on your iPad, iPhone, or iPod touch and log in to your account using the 
same email and password you used to register Parallels Workstation. 

3 Tap your host computer in the list of available host computers. 

When you access your virtual machines for the first time, you see tips about gestures you can use 
to control them. Tap Close to go to the virtual machine's desktop. 

Connect Directly to the Host Computer for a Faster Experience 
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If the host computer and your iOS device are on the same Wi-Fi network, you can bypass the 
Internet and connect your device directly to the host computer for a faster experience. 

1 In Parallels Workstation on the host computer, choose File > Preferences. 

2 In the left pane, click iPhone. 

3 Make sure Connect Parallels Mobile directly to the host computer is selected, and then 
write down the IP Address listed under the checkbox. 

4 On your iOS device, open the Settings app, and then scroll down and tap Parallels. 

5 Be sure Direct Connection is turned on. 

6 Press the Home button and then open Parallels Mobile on your iOS device. 

7 Tap Direct and tap the plus (+) icon. 

8 Enter a name for the host computer and enter the IP address from the iPhone preferences 
pane. 

9 Enter the user name and password you use for the host computer (your login password). 

10 Tap Connect. 

For more information about using Parallels Mobile, see the Parallels Mobile Quick Start guide, 
available on the Parallels website. 
 

Save a Picture of the Screen 
To save a picture of the guest OS in the Window view mode (p. 76), choose View > Make 
Screenshot. 

A file named Parallels Picture.png is saved on the host OS desktop. 

By default, pictures are saved to the host OS desktop. 

 



 

 

In This Chapter 

General Settings....................................................................................................... 104 
Options .................................................................................................................... 106 
Hardware ................................................................................................................. 125 
Add and Remove Devices ........................................................................................ 145 
 
 

General Settings 
In the General pane, you can view and configure the virtual machine general settings. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration window, click General. 

Note: Some of these settings can be changed only when the virtual machine is not running. 

 

C H A P T E R  6  

Configure a Virtual Machine 
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General Settings include the following: 

• The virtual machine name. The Name field displays the name assigned to the virtual machine. 
The length of this name is limited to 50 characters. The name of the virtual machine is displayed 
in its guest OS window. 

• The guest OS type and version. This field displays the type of the operating system installed in 
the virtual machine or declared to be installed in the future. The OS type and version field should 
reflect the real operating system type and version installed in the virtual machine. 

• The number of processors. The CPUs field allows you to change the number of virtual CPUs 
that will be used to handle the processes running in the virtual machine. The maximum 
allowable number of virtual CPUs is automatically calculated by Parallels Workstation. The 
calculation is based on the number of physical CPUs available to the host computer. 

Note: It is reasonable to use more than one CPU in your guest OS if you are going to use applications 
that perform better under multi-core processors. 

• The memory amount. In the Memory field, you can set the amount of RAM that will be available 
to the virtual machine. To configure the main memory limit, drag the slider or type the value 
directly into the Memory field. 

Note: If the host computer has 1 GB of RAM, it is strongly recommended to assign not more than 512 
MB to a single virtual machine. 
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Options 

Startup and Shutdown 

In the Startup and Shutdown pane, you can define a number of parameters related to the 
procedures of starting and shutting down your virtual machine. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration window, click Options and select Startup and 
Shutdown in the sidebar. 
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Start Virtual Machine Automatically 

The Start Automatically option defines the cases in which the virtual machine can be started 
automatically. 

• Select Never if you do not want your virtual machine to be started automatically in any case. 

• Select When Parallels Workstation starts if you want your virtual machine to start 
automatically when you start Parallels Workstation. 

• Select When host starts if you want your virtual machine to start automatically every time you 
start the host computer. 

In the Startup delay field, you can set the delay time interval. 

Choose the user account under which the virtual machine will run 

From the Start as menu, you can choose the user account under which the virtual machine will 
run. Choose between the following accounts: 

• The current user. The virtual machine will run under the user account used to start the virtual 
machine. 

• System. The virtual machine will run under the administrator user account. 

• A specific user. The virtual machine will run under the specified user account. 

Action on Host Computer Shutdown 

The On host shutdown option defines the operation to be performed when you shut down the 
host computer: 

• Select Stop if you want to stop the virtual machine when you shut down the host computer. 

• Select Shutdown if you want to shut down the virtual machine when you switch off the host 
computer. 

• Select Suspend if you want to suspend the virtual machine when you shut down the host 
computer. 

Startup View 

The Startup View option defines the mode in which the virtual machine will work after you select it 
and start. If the Attached Console, Window, Coherence, or Full screen option is selected, the 
virtual machine will automatically switch to the specified view mode. If the Same as last time 
option is selected, the virtual machine will start in the same mode that was applied to it before it 
was turned off. 

Action on the Virtual Machine Shutdown 
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The On Shutdown option defines the operation to be performed when you stop the virtual 
machine. 

• Select Keep window open if you want the virtual machine window to stay open after the virtual 
machine is stopped. 

• Select Close window if you want the virtual machine window to automatically close after the 
virtual machine is stopped. 

• Select Quit Parallels Workstation if you want Parallels Workstation to quit after the virtual 
machine is stopped. If there are any other running virtual machines, Parallels Workstation will 
ask what to do with them before closing. 

Action on Closing the Virtual Machine Window 

The On Window Close option defines the operation to be performed when you close the virtual 
machine window. 

• Select Suspend if you want the virtual machine to be suspended when you close its window. 

• Select Force to stop if you want the virtual machine to be shut down when you close its 
window. 

• Select Keep running if you want the virtual machine to continue running after you close its 
window. 

If you select Ask me what to do, you will be prompted to choose the operation to perform with the 
virtual machine each time you close its window. 
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Optimization 

In the Optimization pane, you can optimize your virtual machine performance. 

To edit these settings: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration window, click Options and select Optimization in the 
sidebar. 
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Optimize Performance 

The Performance option defines the priority of distributing the host computer memory resources: 

• Select Faster virtual machine to allocate more host computer memory resources to the virtual 
machine and its applications. Selecting this option may significantly increase the virtual machine 
performance; however, this may slow down the productivity of your host OS applications. 

• Select Faster Host computer to allocate more memory resources to the physical computer 
and its applications. In this case, the memory resources usage will be optimized to provide 
better performance of your host OS applications. 

Use Adaptive Hypervisor 

Select Enable Adaptive Hypervisor to automatically allocate the host computer CPU resources 
between the virtual machine and host OS applications depending on what application you are 
working with at the moment. If your virtual machine window is in focus, the priority of this virtual 
machine processes will be set higher than the priority of the host computer processes. As a result, 
more CPU resources will be allocated to the virtual machine. If you switch to the host OS window - 
the priority of its working applications will be set higher and the CPU resources will be relocated to 
the host OS. 

Tune Windows for Speed 

You can make your Windows virtual machine work even faster by selecting Tune Windows for 
speed. This option disables some of the additional Windows features that tend to slow down the 
Windows performance. 

Compress the Disk Automatically 

If you use an expanding (p. 134, p. 148) virtual hard disk, its size increases on the physical hard 
disk as you add new data to it. When you delete some data from this virtual hard disk, free unused 
space appears on it. However, the amount of space the virtual hard disk occupies on the host 
computer's hard disk doesn't reduce. To regularly free the unused space back to the host 
computer, use the Automatically compress virtual disks option. The virtual hard disk in an 
expanding format will be reviewed twice a day and, if the unused space occupies more than 50 
percent of the hard disk image size, it will be compressed and the hard disk image file size will be 
decreased. As a result, there will be more free space on the host computer hard disk. 

Note: Compressing can be performed for virtual machines without snapshots and with the Undo disks 
option disabled. 

In the Hard Disk pane (p. 131), you can compress the disk manually whenever you want. 
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Permissions 

In the Permissions pane, you can set restrictions for performing some actions and make your 
virtual machine isolated from the host OS. 

To edit these settings: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Permissions in the 
sidebar. 
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Isolate Virtual Machine from Host OS 

If you want to isolate your virtual machine from the host OS, select Isolate host from guest. This 
option disables all integration features, including Shared Folders (p. 113), Shared Profile (p. 113), 
Shared Applications, SmartMount (p. 113), etc. You will also not be able to copy or move objects 
between the virtual machine and host OS. 

Work in Virtual Machine Without Saving Changes 

The Undo Disks option allows you to discard or apply the changes you make while working with 
the virtual machine. If you choose to discard them, the changes will be discarded when you shut 
down the virtual machine. When you start this virtual machine again, its virtual hard disk will have 
the same data it contained before you started the previous working session. If you choose to apply 
the changes on the virtual machine shutdown, the next time you start this virtual machine, its virtual 
hard disk will store the changes you made during the previous working session. 

Note: When enabled, the Undo Disks feature is applied to all virtual hard disks this virtual machine uses. 

Choose the action to perform: 

• Discard changes. Select this option if you want to discard the changes when you shut down 
the virtual machine. 

• Ask me what to do. If this option is selected, you will be prompted to choose the action to 
perform with the changes (discard or apply them) each time you shut down the virtual machine. 

Note: You can't create snapshots of virtual machines that have the Undo Disks option enabled. 

Encrypt Virtual Machine 

Encryption allows you to protect your virtual machine from being accessed by unauthorized users. 
To encrypt the virtual machine, click Turn On and specify a password. To access the encrypted 
virtual machine, you have to enter this password every time you open it. 

Warning! The specified password is very important. You must record it. Without this password, 
you will not be able to launch the virtual machine. 
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Sharing 

In the Sharing pane, you can configure a number of integration settings. 

To edit these settings: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration window, click Options and select Sharing in the 
sidebar. 

Note: To be able to edit the Sharing settings, you must have Parallels Tools (p. 60) installed in the virtual 
machine and the Isolate host from guest option disabled in the Permissions pane. 
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Share Host OS Folders With Virtual Machine 

To configure access to the disks and folders on the host computer from inside the virtual machine, 
click the Share Folders menu and select one of the following: 

• Select All disks to provide the virtual machine with access to all disks and folders of the host 
computer. 

• Select Home folder only to provide the virtual machine with access to the Home folder of the 
host computer. 

• Select None to disable the host OS folders sharing. 

Note: When you share the host OS disks or folders with a virtual machine, they still reside and occupy 
space on the hard disk of the host computer. 

Define Host Computer Folder to Be Shared 

To specify one or more host computer folders to be shared with the virtual machine, click Custom 
Folders and choose the folder to share with the virtual machine. 

Share Profile 

The Shared Profile functionality allows you to make host OS desktop and some of the Home folder 
items directly accessible from the Desktop and the corresponding folders in the Windows guest 
OS. 

Note: The Shared Profile functionality is available for Windows guest operating systems only. [?] 

To enable Shared Profile, select Share the user folders with the virtual machine, click 
Configure, and specify the following settings: 

• Select Desktop to use the host OS desktop as the desktop in your Windows guest OS. 

• Select Documents to use the Documents folder on the host computer as the My 
Documents folder in your Windows guest OS. 

• Select Pictures to use the Pictures folder on the host computer as the My Pictures 
folder in your Windows guest OS. 

• Select Music to use the Music folder on the host computer as the My Music folder in your 
Windows guest OS. 

• Select Movies to use the Movies folder on the host computer as the My Videos folder in 
your Windows guest OS (available for Windows XP/Vista/7 only). 

• Select Downloads to use the Downloads folder on the host computer as the Downloads 
folder in your Windows guest OS (available for Windows Vista/7 only). 
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Warning: If you delete any host OS file from the Windows desktop when the host OS desktop 
sharing is enabled, you will not be able to find it in the host OS. The file will be permanently 
deleted from your computer. 

For more information about the Shared Profile functionality, see Using Shared Profile. [?] 

Map Host OS Volumes to Guest OS 

The SmartMount feature allows you to automate the detection and mounting of removable devices 
in your virtual machines. You can automate the detection and mounting of: 

• Removable drives. External storage devices such as USB hard disks and USB flash drives will 
be mounted to your guest OS. 

• CD/DVD drives. CD and DVD drives or CD/DVD images will be mounted to your guest OS. 

• Network folders. Network shares connected to the host OS will be mounted to your guest OS. 

If the SmartMount functionality is enabled and you connect any of these devices to the host OS, 
this device is also automatically mounted to your guest operating system as a network drive. For 
example, a USB flash drive plugged in to the host OS will be accessible in both the host and guest 
OSs. 

The permissions you will have for managing the mounted device from inside the virtual machine will 
coincide with those you have for this device in the host OS. So, if you can read from and write to a 
USB flash drive in the host OS, you will have the same permissions for this drive from inside the 
virtual machine. 

To enable the SmartMount feature, select Map host volumes to virtual machine. 
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Applications 

In the Applications pane, you can configure the applications sharing between the guest and host 
operating systems. 

To edit these settings: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Applications in the 
sidebar. 

Note: These settings are available only when Parallels Tools [link] are installed in the virtual machine and 
the Isolate Mac from Windows option is disabled in the Permissions pane. 
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Select Share guest applications with host operating system to allow using guest OS 
applications for opening the files in the host OS. Before using a guest application in the host OS for 
the first time, you should open it once in the guest OS. If you enabled this option, you can also 
configure the following options: 

• If you select Show guest applications folder in Start menu, the folder with all applications 
installed in the virtual machine will always be displayed in the Start menu. 

• Select Pause guest when no applications are open to save your host OS resources. Pausing 
a virtual machine releases the resources, such as RAM and CPU, currently used by this virtual 
machine. The released resources can then be used by the host computer and its applications 
or by other virtual machines running on the host computer. 

If you select this option, the virtual machine will be automatically paused provided that: 

• the virtual machine is running but the virtual machine window is not active over 30 seconds 

• there are no applications running in the guest operating system 

Internet Applications 

In the Applications pane, you can also specify where you want to open different types of 
hyperlinks - in the guest or host operating system. 

You can specify where you want to open the following types of hyperlinks: 

• Web pages. Web pages accessible through the HTTP and HTTPS protocols. 

• Email. Links in the mailto format. 

If you click More Applications, you will also be able to specify where you want to open: 

• Newsgroups. Links in the news. format. 

• FTP. Locations accessible through the FTP protocol. 

• RSS. RSS feeds. 

• Remote access. Locations accessible through the Telnet and Secure Shell (SSH) 
protocols. 
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Backup 

In the Backup pane, you can automate snapshots creation. You can find detailed information on 
snapshots and how to work with them in Working With Snapshots. 

To edit these settings: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Backup in the sidebar. 
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To enable automatic snapshots creation, choose Custom from the SmartGuard menu. 

Note: The SmartGuard feature is available only when the Undo Disks feature is disabled and the virtual 
machine is not running in Safe Mode. 

If you want to know when it is time to make the next snapshot and to be able to reject the 
snapshot creation, select Notify me before snapshot creation. 

Set the Time Interval 

Set how often snapshots should be taken in the Take a Snapshot Every field. You can set from 
one hour to 48 hours. 

If the time interval is less than 24 hours, SmartGuard allows you to restore the latest hourly, daily 
and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest 
daily, weekly and monthly snapshot. 

To manage the snapshots and restore any of them, use Snapshot Manager. 

Restrict the Snapshots Number 

Use the Snapshots to Keep field to set the maximum number of snapshots that can be stored on 
the host computer. The maximum available value is 100 snapshots. As soon as Snapshots 
Manager reaches the limit for snapshots and needs to make a new one over limit, it deletes the 
oldest snapshot. 
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Coherence 

When your virtual machine is working in the Coherence view mode, you can see only windows of 
running guest OS applications and the guest OS desktop is hidden. In the Coherence pane, you 
can choose the color in which the borders of these windows will be highlighted. This helps to 
distinguish a guest OS application from a host OS application and one virtual machine's application 
from another virtual machine's application. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Coherence in the 
sidebar. 
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Full Screen 

In the Full Screen pane, you can configure the virtual machine appearance and behavior when it is 
running in the Full Screen view mode. In this mode, the guest operating system occupies the whole 
screen and all the host operating system and Parallels Workstation controls are hidden. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Full Screen in the 
sidebar. 

You can configure the Full Screen settings even when the virtual machine is running. 
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Active Screen Corners 

You can set actions for screen corners in the Full Screen view mode. Once you've set an active 
corner, move the mouse to the corresponding corner of your screen in the Full Screen mode to see 
the result. 

To set an action for a screen corner, click the field near this corner and select the desired action 
from the menu: 

• Window. On clicking the corresponding active corner, the virtual machine will switch to the 
Window view mode. 

• Coherence. On clicking the corresponding active corner, the virtual machine will switch to the 
Coherence view mode. 

• Show taskbar. On clicking the corresponding active corner, the host operating system taskbar 
will appear. 

Adjust the Host Computer Screen Resolution to the Virtual Machine Resolution in 
Full Screen 

When you switch the virtual machine to the Full Screen mode, its screen resolution: 

• changes to the physical computer screen resolution if you have Parallels Tools installed, or 

• remains the same. 

In the second case, if the virtual machine screen resolution is lower than that of your physical 
computer, in Full Screen the virtual machine screen will appear on a black background. If the virtual 
machine screen resolution is higher than that of the host computer, in Full Screen the virtual 
machine screen will have scroll bars. 

To adjust the screen resolution of your physical computer to that of the virtual machine, select 
Adjust your computer resolution in full screen. Your computer will change its screen resolution 
each time the virtual machine is switched to the Full Screen mode. 

Use All Displays in Full Screen 

If you have multiple displays connected to the host computer, the guest operating system can use 
all these displays in the Full Screen mode. To enable this feature for the virtual machine, select Use 
all displays in full screen. Now if you change the view mode to Full Screen, your guest operating 
system will occupy all available displays. 
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Advanced 

In the Advanced pane, you can configure the Parallels Workstation additional settings. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and click Configure. 

2 In the Virtual Machine Configuration dialog, click Options and select Advanced in the 
sidebar. 
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SmartMouse 

The SmartMouse option allows the mouse to move smoothly between the virtual machine and the 
host operating system. With this option enabled, Parallels Workstation automatically grabs the 
mouse input when you move the pointer to the virtual machine, and releases it when you move it 
back to the host OS. 

• If you select On, the mouse input will be automatically captured in the virtual machine window 
when the mouse pointer hovers over it and then released when it moves back to the host OS, 
which will make the mouse move seamlessly between the host OS and the virtual machine. 

• If you select Off, you will need to click inside the virtual machine window to capture the mouse 
input, and press Ctrl+Alt to release it back to the host operating system. 

Note: Ctrl+Alt is the default key combination. You can define another key combination for releasing the 
mouse in the Keyboard pane of Parallels Workstation Preferences. 

• If you select Auto, the option will automatically become disabled (Off) each time you use a 
game, graphic application, or any other program that uses its own mouse pointer instead of 
using the operating system pointer. The option will be automatically enabled (On) after you quit 
the program. 

Time Synchronization 

Select Synchronize with host computer to synchronize the time settings of your virtual machine 
with those of the host computer. 

If the time zone set in your virtual machine differs from that of the host computer, you can maintain 
this time difference by selecting Allow a different time than on host computer. 

Copy & Paste 

If you want to copy and paste data between the host and guest operating systems, select Share 
clipboard. If the data you copy and paste between the host OS and your virtual machine is text 
and you want to preserve text formatting, select Preserve text formatting. 

Note: This functionality is available only for virtual machines with Parallels Tools installed (p. 60). 
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Hardware 

Boot Order 

In the Boot Order pane, you can configure the virtual machine boot sequence, that is, the order in 
which the virtual machine tries to load the operating system from different boot devices. 

Note: These settings cannot be changed when the virtual machine is running. 

To edit the Boot Order settings, do the following: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Boot Order in the 
sidebar. 
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Boot Order 

By default, the virtual machine tries to boot from the device specified as the first one in the Boot 
order list. If the virtual machine cannot boot from the first device, it proceeds to the second and so 
on. The following boot devices are available: 

• Hard Disk. Select this device if you want the virtual machine to boot up from its virtual hard 
disk drive. 

• CD/DVD. Select this device if you want the virtual machine to boot up from the media 
connected to its virtual CD/DVD-ROM drive. 

Note: The virtual machine uses the CD/DVD-ROM drive specified as CD/DVD 1 in its configuration. 

• Floppy Disk. Select this device if you want the virtual machine to boot up from a floppy disk 
image connected to its virtual floppy disk drive. 

• Network Adapter. Select this device if you want your virtual machine to boot from a network 
adapter using PXE (Pre-Execution Environment). 

Note: The virtual machine uses the network adapter specified as Network Adapter 1 in its 
configuration. 

To change the default boot sequence, select the device you want the virtual machine to boot from 
and move it up or down using the arrows to the right of the list. 

To remove a device from the sequence, clear the check box next to its name. 

Select Boot Device on Startup 

If you want to select the boot device when your virtual machine starts up, choose Select boot 
device on startup. With this option selected, you will see the following message at the virtual 
machine startup: "Press ESC to select boot device". If you press ESC pending 5 
seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will 
try to boot from the devices specified in the Boot order list. 

Note: Make sure the device you wish to use for your virtual machine booting (hard disk drive, CD-ROM 
drive, floppy disk drive, or network adapter) is available to the virtual machine and properly configured. If 
you do not have any boot devices configured in your virtual machine, you will see the following error 
message after you start the virtual machine: “No boot device is available”. In this case, stop 
the virtual machine and configure at least one boot device for it. 

Boot Flags 

The Boot flags field is intended for specifying the flags that can change the virtual machine system 
behavior. The system flags can be used by the Parallels customer support team in cases when 
something goes wrong in your virtual machine. It is not recommended to type anything into this 
field without being instructed to do so by the customer support staff. 
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Video 

In the Video pane, you can view and configure the amount of video memory available to the virtual 
machine's video card. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Video in the sidebar. 

Note: These settings cannot be changed when the virtual machine is running. 

 

To change the amount of video memory available to the virtual machine's video card, drag the 
slider or type the value directly into the Video memory field. 
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Floppy Disk 

In the Floppy Disk pane, you can view and configure the virtual machine's floppy disk settings. As 
the virtual machine's floppy disk, you can use either a real floppy disk drive connected to the host 
computer or a floppy disk image. 

To edit these settings: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Floppy Disk in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 

 

Select Connected if you want the floppy disk drive or floppy disk image to be automatically 
connected to the virtual machine on its startup. 

In the Source field, specify the source device or image file that will emulate the virtual machine's 
floppy disk: 

• If you want to use a real floppy disk drive, click the Source field and select the real device name 
from the list. 

• If you want to use a floppy disk image, click the Source field, select Choose an image file, and 
specify the path to the desired floppy disk image file. 
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CD-ROM options 

In the CD/DVD pane, you can configure the virtual machine's CD/DVD drive settings. As the virtual 
machine's CD/DVD drive, you can use either a real CD/DVD drive connected to the host computer 
or a CD/DVD image file. 

To edit these settings: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select CD/DVD in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the CD/DVD drive to be automatically connected to the virtual 
machine on its startup. 

In the Connect to field, specify the source device or image file that emulates the virtual machine's 
CD/DVD drive: 

• To use a real CD/DVD drive, click the Connect to field and select the real device from the list. 

• To use a CD/DVD image file, click the Connect to field and choose it from the list, or click 
Choose an image file and choose the necessary image file on the host computer. 

In the Location field, specify the type of interface for connecting the device: 

• IDE. Using this interface type, you can connect up to 4 virtual devices. 

• SATA. Using this interface type, you can connect up to 6 virtual devices. 

• SCSI. Using this interface type, you can connect up to 15 virtual devices. 

Note 1: In the latest Linux distributions (e.g. RHEL 5.3), the SCSI driver may be not installed. In this 
case, you should install this driver in your Linux guest OS to be able to use the SCSI controller. 

Note 2: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller 
itself. 
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Hard Disk 

In the Hard Disk pane, you can view and configure the virtual machine's hard disk settings. As the 
virtual machine's hard disk, you can use either a real hard disk drive connected to the host 
computer or a hard disk image file. 

To emulate the virtual machine's hard disk you can use either a real hard disk drive connected to 
the host computer or a virtual hard disk file. 

To edit the device settings, do the following: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Hard Disk in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the hard disk to be automatically connected to the virtual machine 
on its startup. 

In the Source field, specify the source device or hard disk image file that emulates the virtual 
machine's hard disk: 

• To use a real hard disk, click the Source field and select it from the list. 

• To use a virtual hard disk file, click the Source field and choose it from the list, or click Choose 
an image file and choose the necessary hard disk image file (.hdd) on the host computer. 

In the Location field, specify the type of interface for connecting the device: 

• IDE. Using this interface type, you can connect up to 4 virtual devices. 

• SATA. Using this interface type, you can connect up to 6 virtual devices. 

• SCSI. Using this interface type, you can connect up to 15 virtual devices. 

Note 1: In the latest Linux distributions (e.g. RHEL 5.3), the SCSI driver may be not installed. In this 
case, you should install this driver in your Linux guest OS to be able to use the SCSI controller. 

Note 2: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller 
itself. 

Edit the Disk 

If the capacity of your virtual machine's hard disk does not fit your needs anymore, you can change 
its size. Click the Edit button and the dialog for changing the disk size appears. 

Note: If your virtual machine is running or has snapshots, you cannot resize its hard disk. 
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To change the disk size, drag the slider or type the new size in the Size field. Select Resize file 
system if you want to change the file system size: 

• If you select Resize file system when increasing the disk size, the additional disk space will be 
added to the last volume. If you clear Resize file system, the added space will appear as 
unallocated space and will be invisible to the guest operating system. To allocate this space, 
you will have to either create a new partition or expand an existing partition. For instructions on 
allocating the added space, see Initializing the Newly Added Space (p. 149). 

• If you select Resize file system when decreasing the disk size, the disk will be decreased via 
removing the unallocated space and decreasing the size of the disk partitions. If you clear 
Resize file system when decreasing the disk size, you will be able to remove the unallocated 
space of the disk only and the disk partitions will remain untouched. 

If the format of the virtual hard disk is expanding, you can convert it to plain by clearing Expanding 
disk. 

If you want the virtual hard disk to be split, select Split the disk image into 2 GB files option. 

Note: For more information about virtual hard disk types, please refer to Support for Virtual and Real 
Disks (p. 134, p. 148). 

Compress the Disk 

If you use an expanding (p. 134, p. 148) virtual hard disk, its size increases on the physical hard 
disk as you add new data to it. When you delete some data from this virtual hard disk, free unused 
space appears on it. However, the amount of space the virtual hard disk occupies on the host 
computer's hard disk doesn't reduce. To free the unused space back to the host computer, click 
the Compress button. The virtual hard disk will be compressed and its size decreased. As a result, 
there will be more free space on the host computer's hard disk. 

Note: Compressing can be performed for virtual machines without snapshots and with Undo disks 
disabled. 

In the Optimization pane of the virtual machine's configuration, you can enable regular automatic 
disk compression. 
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Support for Virtual and Real Disks 

This section lists the types of disks that can be used by Parallels virtual machines and provides the 
information about basic operations you can perform on these disks. 

Supported Types of Hard Disks 

Parallels virtual machines use virtual hard disks as their hard disks. 

Virtual Hard Disks 

The capacity of a virtual hard disk can be set from 100 MB to 2 TB. 

Virtual hard disks can be of either plain or expanding format. When you create a virtual machine in 
Express Windows or Typical mode (in the New Virtual Machine wizard (p. 48)), the disk is created 
in the expanding format. 

plain A plain virtual hard disk image file has a fixed size.  The size is determined when the disk is 
created. Plain disks can be created with the help of New Virtual Machine wizard (the Custom 
mode.)  

expandin
g 

An expanding virtual hard disk image file is small initially. Its size grows as you add 
applications and data to the virtual hard disk in the guest OS. 

Split disks 

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB 
pieces and is stored as a single .hdd file. 

CD/DVD Discs and Their Images 

Parallels Workstation can access real CD/DVD discs and images of CD/DVD discs. 

Parallels Workstation has no limitations on using multisession CD/DVD discs. Virtual machine can 
play back audio CDs without any limitations on copy-protected discs. 

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a 
virtual machine. 

Note: To burn CD or DVD discs in a virtual machine, the recordable optical drive should be connected to 
the virtual machine in the passthrough mode (p. 129). 

Parallels Workstation supports CD/DVD disc images in the ISO format. Parallels Workstation may 
also support CD/DVD disc images in the CUE and CCD formats. 

Floppy Disks and Floppy Disk Images 
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Parallels Workstation can use two types of floppy disks: 

• Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine. 

• Floppy disk image files with the .fdd extension connected to the virtual machine. 

Parallels Workstation treats floppy disk images like real diskettes. Parallels Workstation supports 
floppy disk image files that have .fdd extension and 1.44 MB size. 

With Parallels Workstation, you can also create an image of a blank floppy using Floppy Disk pane 
(p. 128) of the Virtual Machine Configuration dialog. 

Note: Parallels Workstation cannot create images of real diskettes. 
 

Serial Port 

In the Serial Port pane, you can view and configure the virtual machine's serial port settings. You 
can connect the virtual machine's serial port to any of the host computer's serial ports, to a socket, 
or to an output file. 

To edit these settings: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Serial Port in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the serial port to be automatically connected to the virtual machine 
on its startup. 

In the Source list, choose where you want to connect the virtual machine's serial port: 

• Real Port. You can connect it to any of the host computer's serial ports. Any device connected 
to this host computer's serial port will be used only by the virtual machine. To return it to the 
host, you need to disconnect it from the virtual machine. To do this, use the virtual machine's 
status bar (p. 43). 

• Socket. If you want to connect two virtual machines with each other, you need to connect their 
serial ports to the same socket. If there are no sockets available, click New socket and specify 
its name. 

If you choose to connect the virtual machine's serial port to a socket, you need to configure the 
virtual machine's role in the connection. If you want to use this virtual machine to direct the 
other one, choose Server in the Mode list. If you want to direct this virtual machine from the 
other one, choose Client from the Mode list. 

Note: If you change the socket mode for one virtual machine, you must also change the socket mode 
for the other. 

• Output File. If you want to log the virtual machine's performance activity or record the data 
from it and use this information later on, you can connect the virtual machine's serial port to an 
output file. Click Choose an output file and select the necessary output file on the host 
computer. You will be able to view and analyze the virtual machine's activity history any time 
you need by exploring this file. 
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Network 

In the Network pane, you can view and change the network type used by the virtual machine. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Network in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the virtual machine to start up with the network adapter connected. 

In the Type list, choose the necessary network type for the virtual machine's network adapter: 

• Shared Network. Select this network type to enable the Network Address Translation (NAT) 
feature for the virtual machine. In this case, your virtual machine shares whatever network 
connection is currently used by the host computer. 

See Shared Network (p. 92) to learn more about this network type. 

• Bridged Network. If you want the virtual machine to access the local network and Internet 
through one of the network adapters available on the host computer, choose this adapter from 
the list below the Bridged Network type. In this case, the virtual machine's network adapter is 
bridged to the selected host computer's network adapter. And the virtual machine is treated as 
a stand-alone computer on the network. 

See Bridged Ethernet Network (p. 93) to learn more about this network type. 

• Host-Only Network. Select this network type if you want the virtual machine to connect only to 
the host computer and the virtual machines residing on it. The virtual machine using this 
network type becomes invisible outside the host computer. 

See Host-Only Network (p. 94) to learn more about this network type. 

In the MAC address field, you can change the MAC address currently assigned to the virtual 
machine. MAC addresses are automatically generated during the virtual machine creation. 
However, you can modify the default MAC address by typing another value in the MAC address 
field or clicking the Generate button. When entering a new MAC address, make sure that it is 
unique within your network. 
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Printer Port 

In the Printer Port pane, you can view and configure the virtual machine's printer port settings. You 
can connect the virtual machine's printer port to any of the host computer's printers, to the host 
computer's printer port, or to an output file. 

To edit these settings: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Printer Port in the 
sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the printer port to be automatically connected to the virtual machine 
on its startup. 

In the Source list, choose where you want to connect the virtual machine's printer port: 

• Printers. You can connect it to any of the host computer's printers. 

For the detailed information on how to set up a printer in a virtual machine, refer to 
[section_name]. 

• Real printer ports. You can connect it to the host computer's printer port. Any device 
connected to this host computer's printer port will be used only by the virtual machine. To 
return it to the host, you need to disconnect it from the virtual machine. To do this, use the 
virtual machine's status bar (p. 43). 

• Output File. You can connect it to an output file. Click Choose an output file and select the 
necessary output file on the host computer. 

Print to Non-PostScript Printers 

If you connect a printer that does not support PostScript to the virtual machine, select Print to 
non-PostScript printers to be able to print to this printer. However, you also need to install 
Ghostscript in Windows 7. For details, please follow the link in the Printer Port pane. 
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Sound 

In the Sound pane, you can view and configure the virtual machine's sound settings. 

To edit these settings, do the following: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Sound in the sidebar. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Select Connected if you want the sound device to be automatically connected to the virtual 
machine on its startup. 

Use the Input list to choose the necessary device: 

• Default. Select this option if you want to use the input device set as default in the primary 
operating system. 

• Null device. Select this option if you want to mute the input device. 

Use the Output list to choose the necessary device: 

• Default. Select this option if you want to use the output device set as default in the primary 
operating system. 

• Null device. Select this option if you want to mute the output device. 

Use the Channels list to choose the type of sound reproduction: 

• Auto. If you select this option, Parallels Workstation checks the sound card connected to the 
host computer and to the virtual machine. If this sound card is 5.1 surround-capable, the virtual 
machine's output device will reproduce 5.1 surround sound. If the sound card does not support 
5.1 surround sound, the virtual machine's output device will reproduce stereo 2.0 sound. 

• Stereo Sound. Select this option if you want the output device to reproduce stereo 2.0 sound. 

• Sound Surround 5.1. Select this option if you have a 5.1 surround-capable sound card 
connected to the host computer and you want to use it in the virtual machine. 

Note 1: If you want to use a 5.1 surround-capable sound card in your virtual machine, make sure it is 
selected in the Output list. 

Note 2: If you choose to use a 5.1 surround-capable sound card in your virtual machine, you may need 
to set up this sound card in the guest operating system. For the detailed information on how to do this, 
please refer to the operating system documentation. 
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USB Controller 

In the USB Controller pane, you can see the USB devices currently connected to the virtual 
machine. 

Note: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 
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Video Adapter 

In the Video Adapter pane, you can view and change the physical video adapter used by the 
virtual machine. 

To edit these settings: 

1 Open the Virtual Machine menu and choose Configure. 

2 In the Virtual Machine Configuration dialog, click Hardware and select Video Adapter in the 
sidebar. 

Note 1: If this device is absent, you can add it to the virtual machine's configuration. For detailed 
information on how to do this, refer to Adding and Removing Devices. 

Note 2: Before adding a PCIe video adapter to the virtual machine, you must first assign it to your virtual 
machines in the Intel VT-d pane (p. 20) of Parallels Workstation Preferences. 

 
 



145 
 

Configure a Virtual Machine 
 

Add and Remove Devices 
Adding new devices to a virtual machine is easier than connecting new devices to a real computer. 
Removing or disconnecting devices is also easy. The following virtual devices can be added to the 
configuration or removed from it: 

• virtual hard disk drive 

• CD/DVD drive 

• floppy disk drive 

• network adapter 

• serial port 

• printer port 

• sound device 

• USB controller 

• PCI video adapter (for Parallels Workstation Extreme only) 

Any of the aforementioned devices can be added to the corresponding virtual machine only when it 
is stopped. 

Note: To be able to connect any virtual device to a real one, you should have system privileges to access 
the real device. Otherwise, the real device will not appear in the list of available devices even though it is 
installed on your computer. 

Adding a New Device to a Virtual Machine 

1 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
pane for editing hardware devices. 

3 Click the Add button  in the bottom part of the Virtual Machine Configuration dialog and 
select the device to be added to your virtual machine. 

Note: The Add button is disabled when the virtual machine is running. You need to stop the virtual 
machine before you can use this button. 
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4 If you selected any device except for a hard disk, the corresponding device with a typical 
configuration is added at once and ready for use. 

If you selected a hard disk, you should specify some parameters: 

• The hard disk type: a new image file or an existing one. 

• The hard disk location. Provide the path on the host computer to the existing image file or 
the path and name for the new image file. By default, Parallels Workstation offers to save the 
new image file in the virtual machine PVM bundle. 

• The hard disk size for the new hard disk image file. 

• For the new hard disk image file, you can choose one of the following formats: Expanding or 
Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk, 
clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split 
the disk image to 2 GB files option. For more information on hard disk formats, refer to 
Support for Virtual and Real Disks (p. 134, p. 148). 
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Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine 
configuration, it will be invisible to the operating system installed inside the virtual machine until 
the moment you initialize it. For detailed information on how to initialize the newly added hard 
disk, see Initializing the Newly Added Disk (p. 150). 

After the new device is added, you can manage its properties as usual and start using it. 

Removing Devices From the Virtual Machine Configuration 

1 Choose Configure from the Virtual Machine menu to open Virtual Machine Configuration. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
pane for editing hardware devices. 

3 Select the device you want to remove and click the Remove button  in the bottom part of 
the Virtual Machine Configuration dialog. 

Note: If you accidentally click the Remove button , click Cancel in Virtual Machine Configuration. 
Once you click OK, the device will be removed. 
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Support for Virtual and Real Disks 

This section lists the types of disks that can be used by Parallels virtual machines and provides the 
information about basic operations you can perform on these disks. 

Supported Types of Hard Disks 

Parallels virtual machines can use virtual hard disks as their hard disks. 

Virtual Hard Disks 

The capacity of a virtual hard disk can be set from 100 MB to 2 TB. 

Virtual hard disks can be of either plain or expanding format. When you create a virtual machine in 
Express Windows or Typical mode (in the New Virtual Machine wizard (p. 48)), the disk is created 
in the expanding format. 

plain A plain virtual hard disk image file has a fixed size.  The size is determined when the disk is 
created. Plain disks can be created with the help of New Virtual Machine wizard (the Custom 
mode.)  

expandin
g 

An expanding virtual hard disk image file is small initially. Its size grows as you add 
applications and data to the virtual hard disk in the guest OS. 

Split disks 

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB 
pieces and is stored as a single .hdd file. 

CD/DVD Discs and Their Images 

Parallels Workstation can access real CD/DVD discs and images of CD/DVD discs. 

Parallels Workstation has no limitations on using multi-session CD/DVD discs. A virtual machine 
can play back audio CDs without any limitations on copy-protected discs. 

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a 
virtual machine. 

Parallels Workstation supports CD/DVD disc images in ISO, CUE, and CCD formats. 

Floppy Disks and Floppy Disk Images 

Parallels Workstation can use two types of floppy disks: 

• Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine. 
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• Floppy disk image files having the .fdd extension and connected to the virtual machine. 

Parallels Workstation treats floppy disk images like real diskettes. Parallels Workstation supports 
floppy disk image files that have the .fdd extension and 1.44 MB size. 
 

Initializing the Newly Added Space 

This section provides some general guidelines on initializing new virtual hard disks or new space 
added to your existing virtual hard disks. 
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Initializing the Newly Added Disk 

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible 
to the operating system installed inside the virtual machine until the moment you initialize it. 

Initializing the New Virtual Hard Disk in Windows 

To initialize a new virtual hard disk in a Windows guest OS, you will need the Disk Management 
utility available. For example, in Windows 7 and Windows XP you can access this utility by doing 
the following: 

• In Windows 7, click Start > Control Panel > System and Security > Administrative Tools > 
Computer Management Storage > Disk Management. 

• In Windows XP, click Start > Control Panel > Administrative Tools > Computer 
Management > Storage > Disk Management. 

When you open the Disk Management utility, it automatically detects that a new hard disk was 
added to the configuration and launches the Initialize and Convert Disk wizard: 

1 In the introduction window, click Next. 

2 In the Select Disks to Initialize window, select the newly added disk and click Next. 

3 In the Select Disks to Convert window, select the newly added disk and click Finish. 

The added disk will appear as a new disk in the Disk Management utility window, but its memory 
space will be unallocated. To allocate the disk memory, right-click this disk name in the Disk 
Management utility window and select New Simple Volume in Windows Vista or New Volume in 
Windows XP. The New Simple Volume Wizard/New Volume Wizard window will appear. Follow 
the steps of the wizard and create a new volume in the newly added disk. 

After that your disk will become visible in Computer/My Computer and you will be able to use it as 
a data disk inside your virtual machine. 

Initializing the New Virtual Hard Disk in Linux 

Initializing a new virtual hard disk in a Linux guest OS comprises two steps: (1) allocating the virtual 
hard disk space and (2) mounting this disk in the guest OS. 

To allocate the space, you need to create a new partition on this virtual hard disk using the fdisk 
utility: 

Note: To use the fdisk utility, you need the root privileges. 

1 Launch a terminal window. 

2 To list the IDE disk devices present in your virtual machine configuration, enter: 
fdisk /dev/hd* 
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Note: If you added a SCSI disk to the virtual machine configuration, use the fdisk /dev/sd* 
command instead. 

3 By default, the second virtual hard disk appears as /dev/hdc in your Linux virtual machine. To 
work with this device, enter: 

fdisk /dev/hdc 

Note: If this is a SCSI disk, use the fdisk /dev/sdc command instead. 

4 To get detailed information about the disk, enter: 
p 

5 To create a new partition, enter: 
n 

6 To create the primary partition, enter: 
p 

7 Specify the partition number. By default, it is 1. 

8 Specify the first cylinder. If you want to create a single partition on this hard disk, use the default 
value. 

9 Specify the last cylinder. If you want to create a single partition on this hard disk, use the default 
value. 

10 To create a partition with the specified settings, enter: 
w 

When you allocated the space on the newly added virtual hard disk, you should format it by 
entering the following command in the terminal: 
mkfs -t <FileSystem> /dev/hdc1 

Note: <FileSystem> stands for the file system you want to use on this disk. It is recommended to 
use ext3 or ext2. 

When the added virtual hard disk is formatted, you can mount it in the guest OS. 

1 To create a mount point for the new virtual hard disk, enter: 
mkdir /mnt/hdc1 

Note: You can specify a different mount point. 

2 To mount the new virtual hard disk to the specified mount point, enter: 
mount /dev/hdc1 /mnt/hdc1 

When you mounted the virtual hard disk, you can use its space in your virtual machine. 
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Creating a New Partition in Windows 

To create a new partition from the unallocated space on your virtual hard disk, you can use Disk 
Management, a Windows built-in utility for partitioning hard disks. The steps below provide 
instructions for creating a new partition in Windows XP. For other Windows operating systems, the 
procedure is very similar. For more details, see the documentation for the respective Windows 
operating system. 

To create a new partition in Windows XP: 

1 Start the virtual machine that uses the virtual disk with unallocated space. 

2 To start the Disk Management utility: 

a Choose Control Panel from the Start menu. 

b Double-click Administrative Tools, and then double-click Computer Management. 

c In the Storage section, select Disk Management. 

3 In the Disk Management window, right-click Unallocated Capacity, and choose New 
Partition. 

4 In the New Partition wizard Introduction window, click Next. 

5 In the Select Partition Type window, select Primary partition, and click Next. 

6 Specify the partition size, and click Next. 

7 Assign a drive letter to the new partition, and click Next. 

8 In the Format partition window, select Format partition with the following settings. Set File 
system to NTFS and Allocation unit size to Default. Type the volume name in the Volume 
label field, and click Next. 

9 Carefully review the settings, and click Finish to start formatting. 

Once the operation is complete, the new volume appears in the Computer Management window 
and in My Computer. 
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Creating a New Partition in Linux 

In most Linux systems, you can use the fdisk utility to create a new partition and perform other 
disk management operations. 

Note: To perform disk management operations using fdisk, you must have the root privileges. 

As a tool with a text interface, fdisk requires typing the commands in the fdisk command line. 
The main fdisk commands are listed below: 

Options Description 

m Displays all available commands for fdisk. 

p Displays the list of existing partitions on your hda drive. Unpartitioned space is 
not listed. 

n Creates a new partition. 

q Exits fdisk without saving your changes. 

l Lists partition types. 

w Writes changes to the partition table. 

To create a new partition: 

1 Start a terminal. 

2 Start fdisk: 
# /sbin/fdisk /dev/hda 

/dev/hda stands for the hard drive you want to partition. 

3 In fdisk, to create a new partition, type the following command: 
n 

• When prompted to specify the Partition type, type p to create a primary partition or e to 
create an extended one. There may be up to four primary partitions. If you want to create 
more than four partitions, extend the last partition, and it will become a container for other 
logical partitions. 

• When prompted for the Number, in most cases, type 3 because a typical Linux virtual 
machine has two partitions by default. 

• When prompted for the Start cylinder, type a starting cylinder number or press Return to 
use the first cylinder available. 

• When prompted for the Last cylinder, press Return to allocate all the available space or 
specify the size of a new partition in cylinders if you do not want to use all the available 
space. 

By default, fdisk creates a partition with a System ID of 83. If you are unsure of the partition’s 
System ID, use the 

l 

command to check it. 
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4 Use the 
w 

command to write the changes to the partition table. 

5 Restart the virtual machine: 
reboot 

6 When restarted, create a file system on the new partition. We recommend that you use the 
same file system as on your other partitions. In most cases it will be either the ext3 or 
ReiserFS file system. For example, to create the ext3 file system, run the following 
command: 

/sbin/mkfs -t ext3 /dev/hda3 

7 Create a directory that will be a mount point for the new partition. For example, to create a new 
directory and assign the name data to it, enter: 

mkdir /data 

8 Mount the new partition to the directory you have just created: 
mount /dev/hda3 /data 

9 Edit the /etc/fstab file to specify the information on the new partition. For example, you can 
add the following string to this file: 

/dev/hda3 /data ext3 defaults 0 0 

In this string, /dev/hda3 is the partition you have just created, /data is a mount point for the 
new partition, ext3 is the file type of the new partition. For the exact meaning of other items in 
this string, consult the Linux documentation for the mount and fstab commands. 
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Manage a Virtual Machine 
Read this section to learn how you can manage your virtual machines. 
 

Clone a Virtual Machine 

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual 
machine fully identical to the original one. To make a clone: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37),select the virtual machine you want to clone (it must be shut down) and 
choose File > Clone. 

3 Choose where you want to store the clone. 

By default, Parallels Workstation stores clones in your Documents > My Parallels folder. 

4 Click Clone to start cloning the virtual machine. 
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Back Up a Virtual Machine 

Most people don't seriously consider regular backups as a necessity until they have experienced a 
significant data loss. You should create your own backup strategy to protect yourself from data 
loss. Virtual machines are as vulnerable to crashes as physical computers. 

You can back up your virtual machine using one or several of the following methods: 

• Configure the regular backup settings in the Backup pane (p. 118) of the Virtual Machine 
Configuration dialog. 

• Clone the virtual machine with the help of Clone Virtual Machine Assistant (p. 155). Give a 
descriptive name to the clone and save it in a location specially designated for backups. 

• Copy the virtual machine files manually. 

Configure Regular Backups 

In the Backup pane (p. 118) of the Virtual Machine Configuration dialog, you can choose how to 
back up your virtual machine regularly. You can configure how the virtual machine snapshots will be 
created. 

Clone the Virtual Machine 

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For 
details, see Clone a Virtual Machine (p. 155). 

Copying the Virtual Machine Files 

You can locate your virtual machine on the host computer and create a backup copy of the virtual 
machine file (PVM). 

1 In the sidebar (p. 37), right-click the virtual machine name and select Open location from the 
context menu. Go to the folder where your virtual machine is stored. 

2 Locate the required virtual machine PVM file. 

Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file 
(HDD), and other files. 

3 Copy the virtual machine's PVM file to a safe location. 
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Create and Use Virtual Machine Templates 

On the basis of your virtual machines you can create templates. Later you can use them to create 
multiple identical virtual machines. To create a virtual machine template, you can: 

• convert a virtual machine to a template; or 

• clone a virtual machine to a template. 

The difference between these two ways is that when you convert a virtual machine to a template, 
you can't run it until you convert the template back to the virtual machine. And when you clone a 
virtual machine to a template, the template appears separately from the virtual machine and you 
can work with both. 

A template, in its turn, can be converted or deployed back to the virtual machine. When you 
convert a template, it turns back to the virtual machine, And when you deploy it, the resulting virtual 
machine appears separately from the template and you can work with both. 

Convert a Virtual Machine to a Template 

To convert a virtual machine to a template: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), right-click the virtual machine you want to convert (it must be shut down) 
and choose Convert to Template. 

Convert a Template to the Virtual Machine 

To convert a template back to the virtual machine: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), right-click the template you want to convert and choose Convert to 
Virtual Machine. 

Clone a Virtual Machine to a Template 

To clone a virtual machine to a template: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), right-click the virtual machine you want to clone (it must be shut down) 
and choose Clone to Template. 

3 Choose where you want to store the resulting template. 

By default, Parallels Workstation stores templates in your Documents > My Parallels 
folder. 

4 Click Clone to start cloning the virtual machine to the template. 
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Deploy a Template to the Virtual Machine 

To deploy a template back to the virtual machine: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), right-click the template you want to deploy and choose Deploy to Virtual 
Machine. 

3 Choose where you want to store the resulting virtual machine. 

By default, Parallels Workstation stores virtual machines in your Documents > My 
Parallels folder. 

4 Click Deploy to start deploying the template to the virtual machine. 
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Save Snapshots of a Virtual Machine 

A snapshot is a saved state of a virtual machine. It's useful to create snapshots, for example, 
before: 

• you're going to run some programs that may damage the guest operating system; 

• you're going to configure some guest OS software that requires a lot of settings; or 

• you want to mark milestones in the development process. 

Note: If your virtual machine has one or more snapshots, you can neither compress nor resize its virtual 
hard disk. 

If something goes wrong, you can revert the changes back to any of your snapshots and continue 
working with the virtual machine. 

Create a Snapshot 

To create a snapshot: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine for which you want to create a snapshot and 
click Virtual Machine > Take Snapshot. 

3 Specify the snapshot name and click OK. 

Revert to a Snapshot 

To revert to a snapshot: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine that you want to revert and click Virtual 
Machine > Manage Snapshots. 

3 Select the snapshot to which you want to revert and click Go To. 

Delete a Snapshot 

To delete a snapshot: 

1 Start Parallels Workstation. 

2 In the sidebar (p. 37), select the virtual machine which snapshot you want to delete and click 
Virtual Machine > Manage Snapshots. 

3 Select the snapshot you want to delete and click Delete. 

When you delete an intermediate snapshot, the information it contains is merged into the next 
snapshot. 
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Change Virtual Machine Configuration at Runtime 

Parallels Workstation allows you to connect or disconnect certain devices at runtime or switch 
some of them for using other media. 

Generally, the following virtual devices can be connected or disconnected at runtime: 

• CD/DVD-ROM drives 

• floppy disk drives 

• network adapters 

• printer ports 

• serial ports 

• sound devices 

• USB devices 

• shared folders 

You can configure any of these devices as follows: 

• Use the necessary command from the Devices menu in the menu bar. This menu is available 
only when the virtual machine is running. 

• Click a device icon on the status bar (p. 43) and choose the command from a device shortcut 
menu. 

The status bar displays the devices information when the virtual machine is running. 

• Drag an image file (*.iso or *.fdd) or a shared folder on the appropriate device icon in the status 
bar. This option is available only for CD/DVD-ROM drives, floppy drives and shared folders. 

CD/DVD-ROM or a Floppy Drives 

If you have several CD/DVD-ROM drives connected to your virtual machine, in the Devices menu 
they are listed in the same order as they were connected. The first CD/DVD-ROM drive will be 
CD/DVD-ROM 1, the second will be CD/DVD-ROM 2, and so on. 

Network Adapters 

You can connect the network adapter to any virtual network created on the host computer. If you 
have several network adapters used by the virtual machine, on the status bar (p. 43) and in the 
Devices menu they are listed in the same order as they were connected. The first network adapter 
will be Network Adapter 1, the second will be Network Adapter 2, and so on. 

Printer Ports 
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To connect or disconnect a printer port or to connect a printer or an output file to a printer port, do 
the following: 

• Click the Devices menu, select the corresponding printer port, and choose the appropriate 
command from the displayed menu. 

• Right-click the printer port icon  in the status bar (p. 43) to display the shortcut menu and 
choose the appropriate command. 

Serial Ports 

To connect or disconnect a serial port, do the following: 

• Click the Devices menu, select the corresponding serial port, and choose the appropriate 
command from the displayed menu. 

• Right-click the serial port icon  in the status bar (p. 43) to display the shortcut menu and 
choose the appropriate command. 

Sound Devices 

To connect or disconnect a sound device, choose the Activate or Mute options respectively. You 
can also choose the type of output and input devices. 

USB Devices 

Parallels Workstation automatically detects all USB devices plugged into the host computer. The 
devices that are currently connected to the virtual machine appear in the list from the Device menu. 
You cannot use a USB device in the host operating system while it is being used by the virtual 
machine. 

Shared Folders 

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine 
Configuration dialog (p. 104). 

You can 

• share all disks of the host computer or Home Folder only with the virtual machine 

• add a new shared folder 
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Manage Virtual Machines from the Tray 

When working with Parallels Workstation, you can use the Parallels Workstation tray icon (p. 45) to 
easily manage your running and paused virtual machines. This may be very useful when the 
Parallels Workstation window is minimized or when you use a separate display for your virtual 
machines. 

You can manage your virtual machines by doing one of the following: 

• Double-click the tray icon to bring the Parallels Workstation window (p. 37) to focus. However, 
it does not bring the detached virtual machine window (p. 37) to focus. 

• Right-click the tray icon to open its context menu where you can see your running and paused 
virtual machines. 

Note: Suspended and stopped virtual machines are not listed in the tray icon context menu. 

Point to a virtual machine and do one of the following: 

• Choose Show Window to bring the virtual machine window to focus. If this window is 
detached, only the detached window will be brought to focus. 

• If the virtual machine is paused, choose the corresponding item to resume, suspend, shut 
down or restart this virtual machine. 

• If the virtual machine is running, choose the corresponding item to pause, suspend, shut 
down or restart this virtual machine. 

 

• If the virtual machine has a PCIe video adapter assigned, you can manage its CD/DVD-ROM 
drive or USB Controller. Point to the corresponding item and choose the necessary 
command. 

• If the virtual machine has a PCIe video adapter assigned, choose Grab Input to grab the 
mouse and keyboard input to the virtual machine. It may be very useful to switch over to the 
virtual machine when you work with two displays: one display for the host computer, the 
other for the virtual machine. 
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Remove a Virtual Machine 

When you launch Parallels Workstation, you can see the currently registered virtual machines in the 
Parallels Workstation sidebar. 

If a virtual machine is not used, you can completely delete it or temporarily remove from the list. If 
you remove a virtual machine from the list, you can add it back later whenever you need. 

To delete a virtual machine or remove it from the list, do the following: 

4 Launch Parallels Workstation, right-click the virtual machine and choose Remove from the 
context menu. 

Note: The virtual machine must be stopped or the Remove option will be disabled. 

5 In the second step, do one of the following: 

• If you want to remove the virtual machine from the list, select Remove from list and click 
Remove. 

• If you want to delete the virtual machine from the host computer, select Delete and click 
Next. In the Files Selection dialog you can see all the files related to this virtual machine. In 
this dialog, you can deselect any of the virtual machine files you don't want to delete. When 
ready, click Delete. 

Note: Make sure you are not going to delete the virtual hard disk that is also used by other virtual 
machines. 

 

6 When the operation is completed, click Done to close the wizard. 
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Remove Parallels Workstation 

From Windows 

To remove Parallels Workstation, remove it like any other Windows program. 

From Linux 

To uninstall Parallels Workstation in Linux: 

1 Launch the Terminal. 

2 To gain the root privileges, enter the following command: 
su 

Enter the password for the root account when prompted. 

3 Locate and launch the installation file that you used to install Parallels Workstation. 

4 Follow the installation wizard instructions. In the Upgrade Components screen, click the 
Remove button. 

5 When the uninstallation is completed, the Parallels Workstation Uninstalation completed 
screen appears. Click the Exit button to close the wizard. 
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Getting Technical Support 
Our friendly technical support team is ready to help. Describe your problem and submit a FREE 
request to Parallels Support Team (http://www.parallels.com/support/). 

To find solutions to common problems, explore Parallels Knowledge Base (http://kb.parallels.com/). 
This online resource includes valuable articles about using Parallels Workstation. 

Telephone support is available on a per incident fee basis. Please visit the support team's page of 
the Parallels web site for details. 
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Reporting a Problem to Parallels Team 
To help improve the quality of Parallels Workstation, you can send problem reports to the Parallels 
support team. If a fatal error occurs in a virtual machine, Parallels Workstation automatically opens 
the Parallels Problem Report window prompting you to send a report. If you notice an unusual 
virtual machine behavior, you can create a report manually by choosing Report a Problem from 
the Help menu and filling out the form. Parallels Workstation will create a status report and make a 
screen shot of the running virtual machine. 

Note: Parallels team collects error reports and uses them for identifying performance issues, but 
does not respond to them. If you need assistance in resolving the issue, visit Parallels forum or 
Support page, or log us a support call. 
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In the Specify the problem type field, you can select your problem from the list. In the next field, 
you can add a short problem description. These two fields are optional. 

The Technical Data option includes the .txt status report file that has been generated for the 
error. The status report contains the product version and activation data, primary and guest OSs 
information, virtual machine configuration and system data information, processor status, etc. Click 
the Technical Data icon to view the .txt file and to choose the sections that will be added to the 
report. The file is saved on the host computer. If you want to locate it, click the Go To File button. 

The Guest OS Screenshot option includes the session screen shot of the guest OS in a .png 
format. This option is available if you create a problem report during the virtual machine session. 
Click the Guest OS Screenshot icon to see the screen shot and the path to its location on the 
host computer. 

The Primary OS Screenshot option includes the session screen shot of the primary OS in a .png 
format. This screen shot is made and put on the primary OS desktop whenever you create a 
problem report. Click the Primary OS Screenshot icon to see the screen shot. 

In the Contact Name and Contact e-mail fields, type your name and e-mail. This information will 
be used by the Parallels support team to address you for more technical details if needed. 

Sending a Report 

After you revise the problem report components, click Send Report. The report will receive its 
unique id number and will be sent to the Parallels support team. 
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Configuring Network in Linux 
When setting up network in Linux, you may need to configure the DHCP client to send the virtual 
machine's ID in DHCP requests. For information on how to configure your DHCP client, refer to the 
DHCP client documentation. 

For example, in Red Hat Linux guest OSs, you need to edit the DHCP client configuration file. 

1 Open the dhclient.conf file and make sure that the following lines are present. 
interface "eth0" { 
 send dhcp-client-identifier 1:<MAC address>; 
}  

2 If there are no such lines, add them manually to the file and save it.  

When the dhclient.conf file contains these lines, DHCP client sends the virtual machine's ID to 
the DHCP server. The DHCP server sends an IP address in response. 

Tip 

To locate the dhclient.conf file, in a terminal, enter: 

strings /sbin/dhclient | grep etc | grep dhclient.conf 

or: 
rpm -ql dhclient 
 

Switching Into the Hibernate Mode 
If your running virtual machine with a Windows guest OS has an Intel PCIe network card in its 
configuration, you may experience problems with putting your primary OS into the Hibernate mode 
(the Sleep mode). To fix these problems, perform the following actions: 

1 In the guest OS,  go to Start > Control Panel > Network Connections and open Local Area 
Connections. 

2 In the Local Area Connections window, click Properties. 

3 In the General tab of the Local Area Connections Properties window, click Configure next 
to the network card name. 

4 In the network card properties window, open the Power Management tab and disable the 
Wake on Direct Packet option in the Wake on LAN settings. 

Note: These actions will help you to put your primary OS into the Hibernate mode only if Parallels Tools 
(p. 60) are installed in the Windows guest OS. 
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Increasing the Virtual Machine Screen Resolution 
In virtual machines with Linux guest operating systems installed, dynamic resolution may not work 
when increasing the size of the guest OS window or switching to Full Screen mode. It happens 
because, by default, only 3 MB of video memory are allocated to such virtual machines' video 
cards. If you need the virtual machine screen resolution more than 1024x768, go to the Video pane 
(p. 127) of Virtual Machine Configuration and increase the amount of video memory available to the 
virtual machine's video card up to 16 MB. 
 

Memory Usage Problems 
The amount of the host computer physical memory required for each virtual machine operation can 
be represented as follows: 

Virtual Machine Memory = Guest OS Memory + Video Memory + Virtual Machine Monitor Memory 

• Guest OS Memory is the amount of RAM available to your guest OS. You can configure the 
guest OS memory amount in the Virtual Machine Configuration dialog. 

• Video Memory is the amount of physical memory available to the virtual machine's video card. 
You can adjust the video memory amount in the Video pane (p. 127) of Virtual Machine 
Configuration. 

• Virtual Machine Monitor is the module responsible for the guest operating system virtualization. 
It consumes memory to perform operations of guest virtual devices and  handle virtual paging 
emulation. The amount of memory required for the Virtual Machine Monitor operation depends 
on the guest OS and varies from 50 MB to 200 MB. 

You can configure the whole amount of physical memory available for all running virtual machines in 
the Memory tab of the application Preferences. 

Memory Overcommitment 

If you have several virtual machines running at a time, and you are trying to start one more virtual 
machine, you can come across the memory over commit. The application will inform you with the 
corresponding message. This means that all your running virtual machines require more memory 
that is configured in the Memory tab of the application Preferences. If you start one more virtual 
machine, this may significantly slow down all your virtual machines. To solve this problem, you can: 

• stop one or several of your running virtual machines, or 

• edit your virtual machines' configurations to make them consume less memory, or 

• edit the application memory preferences to allocate more memory to your virtual machines. 
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Problems with Antivirus Software 
Because of the close integration with the host operating system, some actions performed by the 
Parallels Workstation processes may be detected as malicious by the antivirus software installed on 
the host computer. 

However, such actions are necessary to ensure the proper functioning of Parallels Workstation. 
That is why you should prevent the antivirus software from blocking them. If you do not want the 
alerts to appear in future, perform a full system scan using the antivirus software and add these 
processes to the list of trusted ones if no viruses are detected. To find out how to do this, refer to 
your antivirus software Help. 

Note: The names of Parallels Workstation processes usually start with prl or parallels. 
 

Installing the GCC Package and Kernel Sources 
in Linux 
When installing or upgrading Parallels Tools in a Linux virtual machine, you may need to install the 
gcc package and kernel sources in your Linux guest OS. Kernel sources can be either downloaded 
from the Internet or installed from Linux distribution disks. 

To install the gcc package and kernel sources in the RHEL/Fedora/CentOS Linux distribution, enter 
the following command in a terminal: 
yum install gcc kernel-devel 
make 

To install the gcc package and kernel sources in the Debian/Ubuntu Linux distribution, enter the 
following command in a terminal: 
apt-get install gcc make linux-headers-$(uname -r) 

For information on how to install the gcc package and kernel sources in other Linux distributions, 
refer to the documentation for these distributions. 

If you still experience any problems, try to find a solution in Parallels Knowledge Base 
(http://kb.parallels.com/) or refer to the Parallels support team 
http://www.parallels.com/en/support/desktop/. 
 

http://kb.parallels.com/�
http://www.parallels.com/en/support/desktop/�
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This glossary defines terms and spells out abbreviations used in Parallels Workstation 
documentation. References to terms defined elsewhere in the glossary appear in italics. 
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Administrator. A user with administrative privileges. 

Activation key. A unique set of symbols that activates the Parallels Workstation application on the 
host computer and lets you use the Parallels Workstation functionality to its full extent. 

Active operating system. The operating system where Parallels Transporter Agent is launched. 

Active volume: The volume of the physical source computer that is used as a boot volume for the 
active operating system.  

Bootable hard disk. A disk used by the operating system to boot from, usually a disk that has an 
operating system installed. 

Boot Volume. A hard disk partition from which the operating system boots. 

Boot Camp partition. A partition on the hard disk of the host computer that can be used for 
installing a Windows operating system on it (for Mac host computers only). 

Bridged networking. Virtual machine network connection mode that enables the virtual machine to 
appear as any other computer on the network, with its own IP address and network name. 

Configuration file. A file specifies the virtual machine's hardware configuration, the devices it uses, 
and other settings. It is created automatically when you create a new virtual machine. See also PVS 
file.  

CPU. Stands for central processing unit. It is an internal part of the computer. See also Processor. 

Disks in the old format. Disks of virtual machines that were created in Parallels Desktop 2.5 and 
earlier or Parallels Workstation 2.2. 

Disks in the new format. Disks of virtual machines that were created or used in Parallels hardware 
virtualization products starting from version 3.0. 

Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on 
your host computer and is small initially. Its size grows as you add applications and data to the 
virtual machine. 

FireWire connection. A wired connection that enables a high-speed data transmission between 
computers. 

Guest operating system (guest OS). An operating system installed inside your virtual machine. 

Host computer: The computer that is used to run virtual machines. In case of Parallels Workstation 
for Mac, it is your Mac. In case of Parallels Workstation for Windows or Parallels Workstation for 
Linux, it is the Windows- or Linux-based physical computer where Parallels Workstation is installed. 
In the Parallels Transporter documentation, this term may define the computer that hosts the result 
of migration. 
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Hot key. A user-defined key or combination of keys that provides quick access to applications and 
commands. See also Shortcut. 

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd 
extension. See also virtual hard disk file. 

Host-only networking. Virtual machine network connection mode that creates a private network 
between the host computer and its virtual machines, which makes the virtual machines available 
from the host computer only. 

ISO image. A special file that contains the entire contents of a CD or DVD disc commonly used to 
install an operating system. 

Image file. A single file containing the complete contents and structure of a data storage medium 
or device, such as a hard disk drive, CD, or DVD. 

IP address. A unique address that is assigned to a physical computer or a virtual machine that 
participates in computer networking. 

Linux computer. A physical computer that has a Linux operating system installed. 

Merged disk. A split disk whose parts were merged into a single disk. 

Migration. The process of transferring data from a physical computer or a third-party virtual 
machine into a Parallels virtual machine or virtual disk. 

OS. An operating system. 

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual 
machines on your Mac. 

Parallels Desktop for Windows. An application that enables you to create, manage, and use 
virtual machines on a Windows-based physical computer. 

Parallels Desktop for Linux. An application that enables you to create, manage, and use virtual 
machines on a Linux-based physical computer. 

Parallels Explorer. An application that enables you to browse and manage the contents of your 
virtual machines without starting them. 

Parallels Image Tool. An application that enables you to manage the capacity and properties of 
your virtual machine's hard disk.  

Parallels Mounter. An application that enables you to to browse the contents of your virtual 
machines and virtual hard disks directly in Mac OS X Finder. 

Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the 
primary and the guest operating systems. 
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Parallels Transporter. An application that uses data of a physical or virtual computer for creating a 
Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be used 
with Parallels Workstation. 

Parallels Transporter Agent. An application that collects data on a physical computer and 
transfers it to Parallels Transporter installed on the host computer. 

Parallels Workstation. An application that enables you to create, manage, and use virtual 
machines on a Windows or Linux computer. 

PCIe device. A video or network adapter corresponding to the PCI Express computer expansion 
card standard introduced by Intel in 2004. 

Plain format. A virtual hard disk format. A plain virtual hard disk image file resides on the host 
computer and has a fixed size that cannot be changed. 

Preboot Execution Environment (PXE). An environment to boot computers using a network 
interface independently of available data storage devices (like hard disks) or installed operating 
systems. 

Primary operating system (primary OS). Operating system that controls the I/O devices of the 
computer and that is loaded when the physical computer is turned on. It is the operating system of 
the physical computer where the Parallels Workstation application is installed. 

Processor. The central processing unit, or CPU. It is an internal part of the computer. 

PVS file. A virtual machine configuration file that contains information about the virtual machine 
resources, devices and other settings. 

Shared networking. Virtual machine network connection mode that allows the virtual machine to 
use the host computer network connections. In this mode, the virtual machine is invisible to other 
computers on the network the host computer belongs to. 

Shortcut. A user-defined key or combination of keys that provides quick access to applications 
and commands. See also Hot key. 

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to 
snapshots are stored in a special subfolder in the virtual machine's folder. 

Source computer or source operating system: The computer that you are going to migrate data 
from. On physical source computers, Parallels Transporter Agent should be installed. 

System disk. A floppy disk that allows your computer to load the operating system. 

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow 
you to transfer the data stored on a split disk piece by piece using a USB drive or other media that 
have limited space and cannot store a large virtual hard disk image file. 
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Terminal. In Mac OS and GNU/Linux operating systems, a utility that enables you to access the 
command line.  

Virtual hard disk (virtual disk). A file or group of files that emulates the virtual machine's hard disk. 

Virtual machine. The computer emulated using Parallels Workstation. A virtual machine has its 
own virtual hardware and requires an operating system to control its hardware. The installed 
operating system and its applications are isolated inside the virtual machine and share physical 
hardware resources of the host computer. 

Third-party virtual machine. A virtual machine created in a third-party virtualization product, that 
can be converted to Parallels virtual machines with the help of Parallels Transporter. 

Virtual Machine Configuration. Like any physical computer, a virtual machine has its own 
configuration which is set during the creation and can be later modified. The virtual machine 
configuration settings are stored in a PVS file. 

Virtual machine files. Files stored in a virtual machine folder. A virtual machine has at least two 
files: configuration file and virtual hard disk file. 

Virtual hard disk file. During the creation, the virtual machine acquires a virtual hard disk file with 
the .hdd extension. This file performs the functions of a real hard disk. See also HDD file. 

Virtual machine template. A virtual machine that can be cloned to multiple virtual machines that 
will have the same configuration and data that the virtual machine template had. 

VM. See Virtual Machine. 

Windows computer. A physical computer that has a Windows operating system installed. 
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