# Contents

## Introduction
- About Parallels Transporter ................................................................. 5
- About This Guide .................................................................................. 5
  - Organization of This Guide ................................................................. 6
  - Documentation Conventions ............................................................. 6
- Getting Help ......................................................................................... 7
- Feedback ............................................................................................. 8

## System Requirements
- Mac Requirements ................................................................................ 9
- Source Computer System Requirements ............................................. 10

## Installing Parallels Transporter and Parallels Transporter Agent
- Installing and Removing Parallels Transporter .................................... 12
- Installing Parallels Transporter Agent .................................................. 12
  - Installing Parallels Transporter Agent in Windows ......................... 13
  - Installing Parallels Transporter Agent in Linux ............................. 15
- Removing Parallels Transporter Agent ................................................. 15
  - Removing Parallels Transporter Agent From Windows ................ 15
  - Removing Parallels Transporter Agent From Linux ...................... 16

## Migration Process Overview
- Initiating Migration .............................................................................. 17
- Deciding on the Migration Method ...................................................... 18
- Defining the Name and Location ......................................................... 18
- Finishing Migration ............................................................................ 19

## Working With Parallels Transporter
- Migration Scenarios ........................................................................... 21
- Migrating With Parallels Transporter .................................................. 22
  - Using Parallels USB Cable ............................................................... 23
  - Using Network or FireWire .............................................................. 27
  - Using an External Storage Device .................................................. 31
- Migrating From Boot Camp ............................................................... 35
In This Chapter

About Parallels Transporter .................................................................................................. 5
About This Guide .................................................................................................................. 5
Getting Help ....................................................................................................................... 7
Feedback .............................................................................................................................. 8

About Parallels Transporter

Parallels Transporter allows you to migrate physical computers to Parallels virtual machines.

The Parallels Transporter package includes two applications: Parallels Transporter and Parallels Transporter Agent.

- Parallels Transporter is installed on the computer that will host the resulting virtual machine (the host computer). Parallels Transporter receives data from Parallels Transporter Agent and transfers it to Parallels virtual machines.
- Parallels Transporter Agent is installed on the remote physical computer you are migrating (the source computer). It collects essential system data from the source computer and transfers it to Parallels Transporter over network or using the Parallels USB cable or an external storage device.

About This Guide

This guide is aimed at a wide range of users who want to use Parallels Transporter to transfer their physical computers to Parallels virtual machines. The guide provides both high-level concept descriptions and detailed step-by-step instructions that will help you learn about the product quickly and easily.

Abbreviations Used in the Text

The following abbreviations are used in the guide:

- **OS** is used instead of *operating system* in long sentences where using it will not change the meaning of the sentence.
- **VM** is used instead of *virtual machine* in long sentences where using it will not change the meaning of the sentence.
Organization of This Guide

The present guide comprises the following chapters:

- **Introduction** (p. 5). Provides basic information about the product and this guide.
- **System Requirements** (p. 9). Provides information about the system requirements your computers must meet to ensure successful installation and operation of the product.
- **Installing Parallels Transporter and Parallels Transporter Agent** (p. 12). Provides detailed instructions on the product installation and uninstallation.
- **Migration Process Overview** (p. 17). Provides information on basic Parallels Transporter notions.
- **Working With Parallels Transporter** (p. 20). Provides typical migration scenarios and instructions on how to perform them.
- **Troubleshooting and Limitations** (p. 37). Provides solutions for some problems you may encounter when using Parallels Transporter.

Documentation Conventions

Before you start using this guide, it is important to understand the documentation conventions used in it.

The table below presents the existing formatting conventions.

<table>
<thead>
<tr>
<th>Formatting convention</th>
<th>Type of Information</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Special Bold</strong></td>
<td>Items you must select, such as menu options, command buttons, or items in a list.</td>
<td>Go to the Resources tab.</td>
</tr>
<tr>
<td></td>
<td>Titles of chapters, sections, and subsections.</td>
<td>Read the Basic Administration chapter.</td>
</tr>
</tbody>
</table>
**Italics** Used to emphasize the importance of a point, to introduce a term or to designate a command-line placeholder, which is to be replaced with a real name or value. These are the so-called *EZ templates*. To destroy a Container, type `vzctl destroy ctid`.

**Monospace** The names of commands, files, and directories. Use `vzctl start` to start a Container.

**Preformatted** On-screen computer output in your command-line sessions; source code in XML, C++, or other programming languages. Saved parameters for Container 101

**Monospace Bold** What you type, as contrasted with on-screen computer output. # `rpm -V virtuozzo-release`

**Key+Key** Key combinations for which the user must press and hold down one key and then press another. Ctrl+P, Alt+F4

Besides the formatting conventions, you should also know about the document organization convention applied to Parallels documents: chapters in all guides are divided into sections, which, in their turn, are subdivided into subsections. For example, *About This Guide* is a section, and *Documentation Conventions* is a subsection.

## Getting Help

Parallels Transporter offers several options for accessing the necessary information:

- **Search.** You can use the search field available from the Parallels Transporter Help menu to perform a keyword search in both Parallels Transporter Help and the Parallels knowledge base. In this field, type a keyword and click Show All Help Topics - the related topics will be displayed.

- **Help files for Parallels Transporter.** To access the Parallels Transporter help files, choose Help > Parallels Transporter Help from the menu.

- **Help buttons.** In most windows, you will find a help button opening the corresponding help page.

- **Online documentation.** This page provides PDF documentation for Parallels Transporter and Parallels Desktop. To open the online documentation page, choose Online Documentation from the Help menu.

- **Parallels website** (http://www.parallels.com). Explore the Support web page that includes product help files and the FAQ section.

- **Parallels Knowledge Base** (http://kb.parallels.com/). This online resource provides troubleshooting for problems that may occur when using Parallels Transporter and other Parallels products.
Feedback

If you spot a typo in this guide, or if you have an opinion about how to make this guide more helpful, you can share your comments and suggestions with us by completing the Documentation Feedback form on our website (http://www.parallels.com/en/support/usersdoc/).
This chapter lists system and network requirements for the host and source computers. Before you start migrating, make sure that your computers meet these requirements. If you are migrating locally, your computer must comply with both host and source computer requirements.

**In This Chapter**

Mac Requirements ............................................................................................................... 9
Source Computer System Requirements .............................................................................. 10

---

**Mac Requirements**

Parallels Transporter is installed automatically with Parallels Desktop. To ensure successful installation and proper operation, your Mac must comply with the system requirements for Parallels Desktop. You can find the system requirements in the *Getting Started With Parallels Desktop* guide.

In addition, your Mac should comply with the following requirements:

- Ethernet or WiFi network adapter for migrating over network.
- USB port for migrating using the Parallels USB cable.

**Note:** You should reserve some space on your Mac for your future virtual machines. Your resulting virtual machine will have the same size as the data on the source physical computer.
Source Computer System Requirements

To migrate data from a physical computer, you need to install Parallels Transporter Agent on it. Parallels Transporter Agent can be downloaded from the Parallels Download Center and installed on computers that meet the following requirements.

Hardware Requirements

- 700 (or higher) MHz x86 or x64 processor (Intel or AMD).
- 256 MB or more of RAM.
- 50 MB of hard disk space for installing the Parallels Transporter Agent package.
- Ethernet or WiFi network adapter for migrating over network.
- USB port for migrating using the Parallels USB cable.

Supported Windows Systems

<table>
<thead>
<tr>
<th>OS Name</th>
<th>32-bit</th>
<th>64-bit</th>
<th>Migration Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Windows Vista®</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Ultimate, Enterprise, Business, Home SP0, SP1, SP2</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Standard, Enterprise, Web SP2</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Windows XP</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Home, Professional SP2, SP3</td>
<td>![ ]</td>
<td>![ ]</td>
<td>USB, Network, External Storage</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>![ ]</td>
<td>![ ]</td>
<td>External Storage</td>
</tr>
<tr>
<td>Professional</td>
<td>![ ]</td>
<td>![ ]</td>
<td></td>
</tr>
</tbody>
</table>

Warning! OEM Windows operating systems may not work with Parallels Desktop after you migrate them to virtual machines. OEM operating systems are only distributed when they are sold with computers. The best example of an OEM operating system is the copy of Windows that comes pre-installed when you buy a new PC.

Supported Linux Systems

<table>
<thead>
<tr>
<th>OS Name</th>
<th>32-bit</th>
<th>64-bit</th>
<th>Migration Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Hat® Enterprise Linux 5</td>
<td>![ ]</td>
<td>![ ]</td>
<td>Network, External Storage</td>
</tr>
<tr>
<td>Ubuntu® Linux 8.04</td>
<td>![ ]</td>
<td>![ ]</td>
<td>Network, External Storage</td>
</tr>
</tbody>
</table>

Supported File Systems

- FAT16/32 (Windows only)
- NTFS (Windows only)
- Ext2/Ext3

Parallels Transporter does not support migrating Windows dynamic volumes and Linux logical volumes (LVM). If the file system is not supported, Parallels Transporter copies all disk sectors successively and you may experience problems using the resulting virtual machine.
This chapter provides instructions on installing and removing Parallels Transporter and Parallels Transporter Agent.

**In This Chapter**

- Installing and Removing Parallels Transporter .................................................. 12
- Installing Parallels Transporter Agent................................................................. 12
- Removing Parallels Transporter Agent............................................................... 15

**Installing and Removing Parallels Transporter**

Parallels Transporter is installed and removed automatically when you install or remove Parallels Desktop, respectively. For detailed installation instructions, see the *Getting Started With Parallels Desktop* guide.

**Installing Parallels Transporter Agent**

This section provides instructions on installing Parallels Transporter Agent on your source computer.
Installing Parallels Transporter Agent in Windows

To begin the Parallels Transporter Agent installation, insert the installation DVD in your CD/DVD-ROM drive and the installation will start automatically. If it does not start automatically, locate the Parallels Transporter Agent.exe file on the disk.

If your computer cannot read DVD discs, download Parallels Transporter Agent for Windows from the Parallels Download Center.

Note: You must have administrator rights to install Parallels Transporter Agent.

Installing Parallels Transporter Agent

If the Parallels Transporter Agent installation has not started automatically, double-click the installation file. Parallels Transporter Agent will connect to the Parallels update server and check for available updates. If there is a newer version of Parallels Transporter Agent available, you will be offered the most recent version of Parallels Transporter Agent. If you want to install the most recent version, click Download and install new version. If you want to install the current version, click Install current.

If there is no update available or your computer is not connected to the internet, Parallels Transporter Agent will be installed from the current installation source.

1. In the Welcome window, click Next.
2. In the License Agreement window, carefully read the Parallels end user license agreement. Click the Print button to print the document. If you agree with the stated terms and conditions, select I accept the terms in the license agreement and click Next.
3 In the **Destination Folder** window, specify the folder where Parallels Transporter Agent will be installed and click **Next**. If you do not want to install to the default folder, click the **Change** button and specify your folder.

![Parallel Transporter Agent](image)

4 In the **Ready to Install the Program** window, click **Install** to start the installation.

5 After the installation is complete, click **Finish** to exit the wizard.

**Installing the Parallels USB Cable Driver in Windows XP**

If you are going to migrate the Windows physical computer to a Parallels virtual machine on your Mac using the Parallels USB cable, you need to install the Parallels USB cable driver on your source computer. To install this driver, perform the following actions:

1 Connect your Mac and your source computer with the Parallels USB cable supplied with your **Switch To Mac** kit. The Found New Hardware Wizard will start.

2 In the **Welcome** window, select the **Yes, this time only** option and click **Next**.

3 In the next window, select the **Install the software automatically (Recommended)** option and click **Next**.

4 The **Hardware Installation** warning will appear. Click **Continue Anyway** to start the installation.

5 When the installation is finished, you will see the **Completing the Found New Hardware Wizard** window. Click **Finish** to exit the wizard.
Installing Parallels Transporter Agent in Linux

To begin the Parallels Transporter Agent installation, locate the installation file. There are two ways to do it:

- Insert the Parallels Desktop installation DVD in your CD/DVD-ROM drive and locate the `parallels-transporter-agent.run` file in the `/Linux` directory on the disc.
- If your computer cannot read DVD discs, download Parallels Transporter Agent for Linux from the Parallels Download Center.

**Note:** You must have root privileges to install Parallels Transporter Agent in Linux.

**Installing Parallels Transporter Agent**

1. Execute the Parallels Transporter Agent installation file (with the `.run` extension).
2. In the introduction window, select Next and press Enter.
3. Carefully read the Parallels end user license agreement. If you agree with the terms of the license agreement, select Accept and press Enter to start installing Parallels Transporter Agent on your computer.

   **Note:** Choosing Decline terminates the installation.

4. After Parallels Transporter Agent has been successfully installed, select Exit and press Enter to complete the installation.

**Removing Parallels Transporter Agent**

This section provides instructions on removing Parallels Transporter Agent from your source computer.

**Removing Parallels Transporter Agent From Windows**

Parallels Transporter Agent can be removed in two ways:

- Choose Control Panel > Add or Remove Programs from the Windows Start menu, select Parallels Transporter Agent in the programs list, and click Remove.
- Double-click the Parallels Transporter Agent installation file. This will start the Setup wizard that will help you remove the program.

**Note:** You must have administrator rights to remove Parallels Transporter Agent.
Removing Parallels Transporter Agent From Linux

To remove Parallels Transporter Agent from Linux:

1. Execute the Parallels Transporter Agent installation file (this is the same file you used for installing Parallels Transporter Agent).
2. In the introduction window, select **Next** and press Enter.
3. In the next window, select **Remove** and press Enter.
4. When Parallels Transporter Agent is successfully removed, select **Exit** and press Enter to close the wizard.
This chapter provides information about basic steps you need to perform to migrate data with Parallels Transporter.

In This Chapter

Initiating Migration ................................................................. 17
Deciding on the Migration Method ............................................ 18
Defining the Name and Location .............................................. 18
Finishing Migration ............................................................... 19

Initiating Migration

Before migrating a physical computer to a Parallels virtual machine, you must launch Parallels Transporter on your Mac, i.e. on the computer that will store the resulting virtual machine. You must also start Parallels Transporter Agent on the remote computer.

Starting Parallels Transporter

To start Parallels Transporter on your Mac, do one of the following:

- Choose Import from the Parallels Desktop File menu; or
- Go to Mac HD/Library/Parallels and double-click the Parallels Transporter application.

Starting Parallels Transporter Agent

To start Parallels Transporter Agent in Windows, click the Windows Start menu and choose All Programs > Parallels > Parallels Transporter Agent.

To start Parallels Transporter Agent in Linux, click the Applications menu and choose System Tools > Parallels Transporter Agent.
Deciding on the Migration Method

In the Migration Method window, choose the mode of transfer from the remote physical computer to your Mac:

- **Parallels USB cable.** Transfer the data using a special USB cable supplied with your Switch To Mac kit. This is the easiest way to perform the migration, but in this case the source computer and your Mac must be located close to each other. For detailed information, see Migrating Using the Parallels USB Cable.

- **Network.** Transfer the data using the network connection between your source computer and your Mac. For detailed information, see Migrating Over Network.

- **External storage device.** Migrate the data from your physical computer to a virtual machine and store the virtual machine files on an external storage device. Then, you can connect this device to your Mac and transfer the virtual machine or disk to it. This process requires more time than migrating over network or using the Parallels USB cable, but can be useful if there is no way to connect your source computer to the Mac. For detailed information, see Migrating Using an External Storage Device.

Defining the Name and Location

In the Select Name and Location window, you are supposed to specify the resulting virtual machine name and location on your Mac. You can leave the default path (/Users/Shared/Parallels/) or indicate your own one by using the Other button to locate the folder.

If you are migrating your source computer to an external storage device, make sure that this device is connected to your source computer. Then, specify the path to the desired folder in the Location field. You can specify any location on your source computer. After Parallels Transporter finishes the migration to the specified location, you will have to transfer the virtual machine .pvm file to your Mac using an external storage device, CD or DVD disc, or via the Internet.

When specifying the location, make sure that the destination volume or storage device has enough free space to store the resulting Parallels virtual machine.

**Note:** If you are migrating a Windows source computer, you will see the warning message concerning the Windows activation key at the bottom of the window. Read this warning message and confirm that you read it.
Finishing Migration

After Parallels Transporter has successfully migrated your data to a Parallels virtual machine, the **Migration was completed successfully** window appears. Click **Done** to close the window and quit Parallels Transporter. You can also close the Parallels Transporter Agent window.

After quitting Parallels Transporter, you can start using your virtual machine. Open it in Parallels Desktop and install Parallels Tools.
This chapter provides descriptions of Parallels Transporter typical usage scenarios and detailed instructions on the migration process.

In This Chapter

Migration Scenarios ................................................................. 21
Migrating With Parallels Transporter ............................................. 22
Migration Scenarios

Parallels Transporter offers you several typical migration scenarios depending on the purpose of migration. After you make up your mind and choose the scenario, you can refer to Parallels Transporter Help for further instructions on the selected scenario of migration.

Using Parallels Transporter, you can migrate:

- from a remote computer
- from the Boot Camp partition

When migrating from a remote computer, you can use one of the following ways of transferring the information:

- Using the Parallels USB cable. The cable is sold separately from Parallels Desktop. This is the easiest way to perform the migration but the source computer and your Mac should be located near each other.
- Over Network. During the remote migration over network, your source and host computers should be connected to the same network. You can also connect your computers using the FireWire cable.
- Using an external storage device. This process requires more time than migrating over network or using the Parallels USB cable but can be useful when there is no way to connect your source and host computers.

When migrating data from a remote Windows or Linux computer, Parallels Transporter transfers data from the specified volume(s) of the source computer to a newly created Parallels virtual hard disk (.hdd) and creates a virtual machine configuration file (.pvs). These two files constitute a ready-to-use virtual machine. During the remote migration, only the active volume (the source computer boot volume) is made bootable, and the resulting virtual machine has the same operating system that was active during the migration. If Parallels Transporter is unable to identify the source operating system, all source volumes are migrated as data disks.

Migrating Using the Parallels USB Cable (p. 23)

This is the easiest and fastest mode of migration. Before starting the migration, you connect your host and source computers with the help of the Parallels USB cable. The Parallels USB cable is sold separately from Parallels Desktop. To use this migration scenario, you should buy this cable. On the source computer, you have Parallels Transporter Agent installed, while the host computer has Parallels Transporter installed.

Before you start the migration, you need to start Parallels Transporter Agent on the source computer and Parallels Transporter on the host computer. Parallels Transporter connects to Parallels Transporter Agent. Transporter Agent collects data on the source computer and transfers it to Parallels Transporter. Parallels Transporter saves the source computer data in a Parallels virtual machine on the host computer.

Note: This migration scenario is available for Windows 7, Windows Vista, and Windows XP source physical computers only.

Migrating Over Network (p. 27)
Migrating over network assumes that your source computer and your Mac are connected to the same network. On the source computer, you have Parallels Transporter Agent installed, while your Mac has Parallels Transporter installed.

Before you start the migration, you need to start Parallels Transporter Agent on the source computer and Parallels Transporter on your Mac. Parallels Transporter connects to Parallels Transporter Agent. Transporter Agent collects data on the source computer and transfers it to Parallels Transporter.

**Migrating Using the FireWire Cable (p. 27)**

For migrating the Windows XP source computers, you can also use the FireWire connection. You can try to migrate a source computer with Linux or other Windows operating system using FireWire, but it may require additional drivers installation or setting some parameters. For migrating using FireWire, you should have the FireWire cable and FireWire ports in your source and host computers. The procedure for migrating using FireWire is the same as for migrating over network.

**Migrating From a Boot Camp Partition (p. 35)**

With Parallels Transporter, you can migrate your Boot Camp partition to a bootable Parallels virtual machine for use in Parallels Desktop for Mac. There are two methods you can use when migrating from a Boot Camp partition:

- migrating within the Boot Camp partition (using an external storage device), or
- migrating from the Boot Camp partition of a remote Mac (the standard remote migration procedure using the Parallels USB cable, or an external storage device, or over network).

---

**Migrating With Parallels Transporter**

This section provides detailed instructions for different migration scenarios.
Using Parallels USB Cable

Warning: Product re-activation may be required in order to migrate some software applications.

To perform this type of migration, the source and host physical computers must be connected with each other by means of the Parallels USB cable. The Parallels USB cable is sold with Parallels Desktop Switch to Mac Edition. This migration method is available for Windows 7, Windows Vista, and Windows XP source physical computers only.

Note: If you are going to migrate the source Windows XP computer, you will have to install the Parallels USB cable driver on the physical source computer. For detailed information, see Installing Parallels Transporter Agent in Windows (p. 13).

Migrating From a Remote Computer Using the Parallels USB Cable

1. Turn on your Mac and the source computer, log in, and connect the computers with the Parallels USB cable.

2. On the source Windows computer, start Parallels Transporter Agent by selecting Start > Program Files > Parallels > Parallels Transporter Agent.

The Parallels Transporter Agent window will appear.
Do not close this window until the migration is finished.

3 On your Mac, start Parallels Desktop and choose Import from the File menu to start Parallels Transporter.

4 In the Welcome to Parallels Transporter window, select Parallels Transporter Agent is open on the source PC and click Continue.

5 In the Migration Method window, select the Parallels USB cable option and click Continue.

6 If the Parallels USB cable is plugged in, in the Connect the Source Computer to Your Mac window, you will see the Ready to connect status. Click Continue. Parallels Transporter will connect to Parallels Transporter Agent and collect information about the source computer.
7 In the **Automatic Logon** window, you can enable the automatic logon. If you enable it now, you will not have to provide your user account password each time you start the virtual machine.

If you do not want to enable automatic logon, select **Do not enable Automatic Login**. When finished, click **Continue**.

8 In the next step, choose the level of integration between your Windows and Mac applications and files. You can choose one of the following ways to work with your Windows applications:

- **Like a Mac**: If you select this option, the files located on the desktop, as well as the contents of the documents, pictures, music, videos, and downloads folders of the current user will be copied from the Windows physical computer to the corresponding locations on your Mac. In addition, all of the bookmarks on the Windows physical computer Internet browser(s) will be added to the default Internet browser on your Mac.

- **Like a PC**: If you select this option, your Windows will run in a separate window, and your Mac files will not be shared with Windows, but you will be able to drag and drop files between the systems, as well as copy text.
When finished, click **Continue**.

9. In the **Select Name and Location** window, specify the resulting virtual machine or hard disk name and location on the host computer. When ready, click **Continue**.

10. If you are migrating a Windows source computer, in the next step, you will see the warning message concerning the Windows activation key. To proceed, read this message, select **I want to continue** and click **Migrate**.

11. After the migration is complete, click **Done** in the **Migration was completed successfully** window to quit Parallels Transporter. You can also close the Parallels Transporter Agent window on the source computer.

After quitting Parallels Transporter, you can start using your virtual machine. Open it in Parallels Desktop and install Parallels Tools in it.

**Note:** To be able to install Parallels Tools on a Windows virtual machine, you should log in to its operating system as an administrator.
Using Network or FireWire

**Warning:** Product re-activation may be required in order to migrate some software applications.

When migrating over network, your source and host computers must be connected to the same network.

**Note:** If you are going to migrate a Windows computer, make sure that the Windows Firewall (p. 38) is turned off. You can turn it on after the migration is finished.

For migrating the Windows XP source computers, you can also use the FireWire connection. You can try to migrate a source computer with Linux or other Windows operating systems using FireWire, but it may require installing additional drivers or setting certain parameters. For migrating using FireWire, you should have the FireWire cable and FireWire ports in your source and target computers. The procedure for migrating using FireWire is the same as migrating over network.

**Migrating From a Remote Computer Over Network**

1. Turn on your Mac and the source computer. Make sure that the computers are connected over network.

2. Start Parallels Transporter Agent on the source computer:
   - In Windows, click the Windows **Start** menu and choose **All Programs > Parallels > Parallels Transporter Agent**.
   - In Linux, click the **Applications** menu and choose **System Tools > Parallels Transporter Agent**.

The Parallels Transporter Agent window will appear.
Do not close this window until the migration is finished.

3 On your Mac, choose **Import** from the Parallels Desktop **File** menu to start Parallels Transporter.

4 In the **Introduction** window, select **Parallels Transporter Agent is open on the source PC** and click **Continue**.

5 In the **Migration Method** window, select the **Network** option and click **Continue**.

6 In the **Connecting to Parallels Transporter Agent** window, select your Windows computer name from the list of detected computers and click **Continue**.
7 Provide the source computer administrator credentials when prompted. Parallels Transporter will connect to Parallels Transporter Agent and collect information about the source computer.

8 In the **Automatic Logon** window, you can enable the automatic logon. If you enable it now, you will not have to provide your user account password each time when starting the virtual machine.

   If you do not want to enable automatic logon, select **Do not enable Automatic Logon**. When finished, click **Continue**.

9 In the next step, choose the level of integration between your Windows and Mac applications and files. You can choose one of the following options of working with your Windows applications:

   - **Like a Mac**: If you select this option, the files located on the desktop, as well as the contents of the documents, pictures, music, videos, and downloads folders of the current user will be copied from the Windows physical computer to the corresponding locations on your Mac. In addition, all of the bookmarks on the Windows physical computer Internet browser(s) will be added to the default Internet browser on your Mac.

   - **Like a PC**: If you select this option, your Windows will run in a separate window, and your Mac files will not be shared with Windows, but you will be able to drag and drop files between the systems, as well as copy text.
When finished, click **Continue**.

10 In the **Select Name and Location** window, specify the resulting virtual machine or hard disk name and location on the host computer. When ready, click **Continue**.

![Select Name and Location Window](image)

11 If you are migrating a Windows source computer, in the next step, you will see the warning message concerning the Windows activation key. To proceed, read this message, select **I want to continue** and click **Migrate**.

12 After the migration is complete, click **Done** in the **Migration was completed successfully** window to quit Parallels Transporter. You can also close the Parallels Transporter Agent window on the source computer.

After quitting Parallels Transporter, you can start using your virtual machine. Open it in Parallels Desktop and install Parallels Tools on it.

**Note:** To be able to install Parallels Tools on a Windows virtual machine, you should log in to its operating system as an administrator.
Using an External Storage Device

The migration process using an external storage device consists of three main stages:

1. Migrating the source computer data to a Parallels virtual machine with the help of Parallels Transporter Agent. The virtual machine is saved on a USB drive or another removable storage device connected to the source computer.
2. Disconnecting the storage device from the source computer and connecting it to the host computer (your Mac).
3. Migrating the resulting virtual machine to the host computer from the storage device with the help of Parallels Transporter.

**Warning:** Product re-activation may be required in order to migrate some software applications.

Migrating the Source Computer to the External Storage Device

1. Connect an external storage device to your source computer.
2. Start Parallels Transporter Agent on the physical source physical computer:
   - In Windows, click the Windows Start menu and choose All Programs > Parallels > Parallels Transporter Agent.
   - In Linux, click the Applications menu and choose System Tools > Parallels Transporter Agent.
3. The Parallels Transporter Agent window will appear. Click the external storage device icon to start the Parallels Transporter Agent wizard.
4 In the **Connecting External Storage** window, click **Next**. Parallels Transporter Agent will collect information about the source computer.

5 In the **Automatic Login** window, you can provide your Windows account password (This is the password you use to enter your desktop on a regular basis). If you provide the password now, you will not have to provide it each time you start the Windows virtual machine.

If you want to provide your Windows account password now, type it in the **Password** field. If you do not want to enable automatic logon, select **Do not enable Automatic Logon**. When finished, click **Next**.

6 In the **Select Name and Location** window, specify the virtual machine name and location on the storage device. You can specify any location on your source computer. After Parallels Transporter finishes the migration to the specified location, you will have to transfer the virtual machine `.pvm` file using an external storage device, or CD/DVD disc, or via the Internet to your Mac. When ready, click **Next**.

![Select Name and Location window](image)
7 In the next step, you will see the warning message concerning the Windows activation key. To proceed, read this message, select I want to continue, and click Migrate.

8 After the migration is complete, click Finish to quit Parallels Transporter Agent.

9 Disconnect the storage device from the source computer, and connect it to your Mac.

Migrating the Virtual Machine to Your Mac

1 On your Mac, choose Import from the Parallels Desktop File menu to start Parallels Transporter.

2 In the Introduction window, select Parallels Transporter Agent is open on the source PC and click Continue.

3 In the Migration Method window, select the External storage device option and click Continue.

4 In the Preparing to Copy window, you should provide the path to the resulting virtual machine on the storage device. Click the Choose button and locate the virtual machine's bundle (.pvm). Click Continue.
In the next step, choose the level of integration between your Windows and Mac applications and files. You can choose one of the following ways to work with your Windows applications:

- **Like a Mac**: If you select this option, the files located on the desktop, as well as the contents of the documents, pictures, music, videos, and downloads folders of the current user will be copied from the Windows physical computer to the corresponding locations on your Mac. In addition, all of the bookmarks on the Windows physical computer Internet browser(s) will be added to the default Internet browser on your Mac.

- **Like a PC**: If you select this option, your Windows will run in a separate window, and your Mac files will not be shared with Windows, but you will be able to drag and drop files between the systems, as well as copy text.

When finished, click **Continue**.

6 In the **Select Name and Location** window, specify the resulting virtual machine name and location on the host computer. When ready, click **Migrate**.

7 After the migration is complete, click **Finish** to exit the wizard.

After quitting Parallels Transporter, you can start using your virtual machine. Open it in Parallels Desktop and install Parallels Tools in it.

**Note**: To be able to install Parallels Tools on a Windows virtual machine, you should log in to its operating system as an administrator.
Migrating From Boot Camp

With Parallels Transporter, you can migrate your Boot Camp partition to a bootable Parallels virtual machine for using in Parallels Desktop. There are three methods you can use when migrating from a Boot Camp partition.

Migrating Within the Boot Camp Partition

Migration within the Boot Camp partition is performed using the standard remote migration with the help of an external storage device. In this case, your Boot Camp partition is considered to be the source Windows computer and your Mac with Parallels Desktop installed is considered to be the host computer.

To migrate a Boot Camp partition to a Parallels virtual machine:

1. Launch the Boot Camp partition on your Mac. Make sure that Parallels Transporter Agent is installed.
2. Connect an external storage device to your Mac.
3. Start Parallels Transporter Agent by clicking the Windows Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.
4. Proceed as described in the Migrating From a Remote Computer Using an External Storage Device section (p. 31). Parallels Transporter Agent will migrate the Boot Camp partition files into the Parallels virtual machine bundle (.pvm) and save it on the external storage device.
5. After Parallels Transporter Agent finishes its work, do not remove the external storage device, shut down the Boot Camp partition and start Mac OS X. Migrate the resulting virtual machine to the host computer from the storage device with the help of Parallels Transporter as described in the Migrating From a Remote Computer Using an External Storage Device section (p. 31).

Migrating via the Boot Camp Virtual Machine

Migration via the Boot Camp virtual machine is almost the same as the standard remote migration over network. If you migrate using the virtual machine, the Boot Camp partition is considered as a remote physical computer. In this case, Parallels Transporter migrates the Boot Camp partition to the Parallels virtual machine bundle (.pvm) on your Mac. This bundle constitutes a ready-to-use virtual machine.

For information on how to create a Boot Camp virtual machine, refer to the corresponding sections in the Parallels Desktop User's Guide.

To migrate from a Boot Camp virtual machine directly to your Mac:

1. Start your Boot Camp virtual machine in Parallels Desktop. Make sure that Parallels Transporter Agent is installed in it.
2. Start Parallels Transporter Agent in the Boot Camp virtual machine by clicking the Windows Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.
3. Choose Import from the Parallels Desktop File menu to start Parallels Transporter. Then proceed as described in the Migrating From a Remote Computer over Network or FireWire (p. 27) section.
Migrating From the Boot Camp Partition of a Remote Mac

This migration is performed using the standard remote migration scenarios (using the Parallels USB cable, or an external storage device, or over network). When migrating from a Boot Camp partition of a remote Mac, your Mac with Parallels Desktop installed is considered to be the host computer and the Boot Camp partition of the remote Mac is considered to be the source Windows computer. To perform the migration:

1. On the remote Mac, start the Boot Camp partition with Parallels Transporter Agent installed.

2. Start Parallels Transporter Agent by clicking the Windows Start menu and choosing All Programs > Parallels > Parallels Transporter Agent.

3. In Mac OS X on your host computer, choose Import from the Parallels Desktop File menu to start Parallels Transporter.

4. Perform the migration using one of the standard remote migration scenarios (using the Parallels USB cable (p. 23), or an external storage device (p. 31), or over network (p. 27)).
CHAPTER 6

Troubleshooting and Limitations

This chapter provides troubleshooting scenarios for some known issues. If you encounter an issue not described here, visit the Parallels support team web page (http://www.parallels.com/en/support/).

In This Chapter

Viewing Product Information ................................................................. 37
Firewall Settings ......................................................................................... 38
Migration Errors ......................................................................................... 39
Activation Problems .................................................................................... 39
Reviving Applications ................................................................................. 39

Viewing Product Information

You can find basic product information, such as the build number and trademarks, in the About Parallels Transporter window. To open this window, start Parallels Transporter and choose About Parallels Transporter from the Parallels Transporter menu.
Firewall Settings

Firewall applications may block connections between Parallels Transporter and Parallels Transporter Agent.

**Firewall problems in Mac OS X**

If Parallels Transporter fails to find Parallels Transporter Agent, the reason may be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent.

To enable connections between Parallels Transporter and Parallels Transporter Agent and prevent further blocking, either turn off the firewall or add Transporter and Transporter Agent to the firewall exceptions. For example, you can configure the firewall settings in Mac OS X Leopard by doing the following:

1. From the Apple menu, choose **System Preferences**, and select **Security**.
2. In the **Security** window, choose the **Firewall** tab.
3. Configure the necessary settings.

If you try to search for Parallels Transporter Agent by typing the source computer IP address manually, you may receive a message saying that Parallels Transporter Agent is blocked. Click the **Unblock** button to enable the connection between Parallels Transporter and Parallels Transporter Agent.

**Firewall problems in Windows**

Microsoft Windows operating system has a built-in firewall that blocks connections from and to other computers. When starting Parallels Transporter or Transporter Agent for the first time, you may get the message that Windows Firewall has blocked some features of the program.

Click the **Unblock** button to enable the connection between Parallels Transporter and Parallels Transporter Agent.

To prevent this problem in the future, add Transporter and/or Transporter Agent to the firewall exceptions (the list of applications allowed to communicate through the firewall):

1. From the **Start** menu, choose **Control Panel** > **Network Connections**.
2. In the **Network Tasks** pane, click **Change Windows Firewall Settings**.
3. Add Parallels Transporter and/or Transporter Agent to the firewall exceptions list.
**Migration Errors**

If you experience any problems when migrating a remote Windows computer, make sure that the `snapman.sys` driver is installed in `C:\WINDOWS\system32\drivers\`. If the `snapman.sys` driver is not installed, follow these steps:

1. Uninstall Parallels Transporter Agent.
2. Restart your source Windows computer.
3. Reinstall Parallels Transporter Agent.
4. Restart your source Windows computer again.
5. Ensure that Parallels Transporter and Parallels Transporter Agent run properly and try to migrate the source computer again.

**Activation Problems**

If you migrate from a Windows physical computer to a bootable Parallels virtual machine, the operating system may detect a hardware change and ask for reactivation.

**Reviving Applications**

Applications that severely depend on specific hardware may not work in a virtual machine, because virtual machine hardware is different from the hardware used on the source computer.

Make sure that the application paths are set correctly after migration. If they are not, update them and see if the application works properly. If this didn't help, contact the Parallels support team [http://www.parallels.com/en/support/](http://www.parallels.com/en/support/).
This glossary defines terms and spells out abbreviations used in this guide. References to terms defined elsewhere in the glossary appear in *italics*.

**Administrator.** A user with administrative privileges.

**Active volume.** The volume of the physical source computer that is used as a *boot volume* for the source computer operating system.

**Bootable hard disk.** A disk used by the operating system to boot from, usually a disk that has an operating system installed.

**Boot Volume.** A hard disk partition from which the operating system boots.

**Boot Camp partition.** A partition on the hard disk of the *host computer* that can be used for installing a Windows operating system (for Mac host computers only).

**Configuration file.** A file specifies the virtual machine's hardware configuration, the devices it uses, and other settings. It is created automatically when you create a new virtual machine. See also *PVS* file.

**Disks in the old format.** Disks of virtual machines that were created in Parallels Desktop 2.5 and earlier versions or in Parallels Workstation 2.2.

**Disks in the new format.** Disks of virtual machines that were created or used in Parallels Desktop 3.0, 4, and 5, Parallels Workstation 4.0, and Parallels Server for Mac 3.0 and 4.

**Expanding format.** A virtual hard disk format. An expanding virtual hard disk image file resides on your host computer and is small initially. Its size grows as you add applications and data to the disk.

**FireWire connection.** A wired connection that enables a high-speed data transmission between computers.

**Guest operating system (guest OS).** An operating system installed inside your virtual machine.

**Host computer.** The computer that hosts virtual machines.

**HDD file.** During the creation, the *virtual machine* acquires a virtual hard disk file with the .hdd extension. See also *virtual hard disk file*.

**ISO Image.** A special file that contains the entire contents of a CD or DVD disc commonly used to install an operating system.

**Image file.** A single file containing the complete contents and structure of a data storage medium or device, such as a hard disk drive, CD, or DVD.

**Linux computer.** A physical computer that has a Linux operating system installed.
**Mac.** A physical computer that has an Mac OS X operating system installed.

**Main Parallels application (product).** The Parallels virtualization product that you use on your *host computer.* It can be Parallels Server for Mac, Parallels Desktop for Mac, Parallels Desktop for Windows, Parallels Desktop for Linux, or Parallels Workstation.

**Merged disk.** A *split* disk whose parts were merged into a single disk.

**Migration.** The process of transferring data from a physical computer into a Parallels virtual machine.

**OS.** An operating system.

**Parallels Desktop for Linux.** An application that enables you to create, manage, and use *virtual machines* on a Linux-based physical computer.

**Parallels Desktop for Mac.** An application that enables you to create, manage, and use *virtual machines* on your Mac.

**Parallels Desktop for Windows.** An application that enables you to create, manage, and use *virtual machines* on a Windows-based physical computer.

**Parallels Mounter.** An application that enables you to browse the contents of your *virtual machines* and *virtual hard disks* directly in Mac OS X Finder.

**Parallel Server for Mac.** An application that enables you to create, manage, and use virtual machines on your Mac.

**Parallels Tools.** A set of Parallels utilities that ensures a high level of integration between the *primary* and the *guest* operating systems.

**Parallels Transporter.** An application that uses data of a physical computer for creating a Parallels virtual clone of this computer. The resulting virtual machines can be used with Parallels Desktop.

**Parallels Transporter Agent.** An application that collects data on a physical computer and transfers it to Parallels Transporter installed on the *host computer.*

**Parallels Workstation.** An application that enables you to create, manage, and use *virtual machines* on a Windows or Linux computer.

**Plain format.** A virtual hard disk format. A plain virtual hard disk image file resides on the *host computer* and has a fixed size that cannot be changed.

**Primary operating system (primary OS).** Operating system that controls the I/O devices of the computer and that is loaded when the physical computer is turned on. It is the operating system of the physical computer where the *main application* is installed.

**PVS file.** A virtual machine *configuration file* that contains information about the virtual machine resources, devices and other settings.

**Shortcut.** A user-defined key or combination of keys that provides quick access to applications and commands.
**Snapshot.** A copy of the virtual machine state at a particular point of time. The files related to snapshots are stored in a special subfolder in the virtual machine's folder.

**Source computer:** The computer that you are going to migrate data from. On source computers, Parallels Transporter Agent should be installed.

**Split disk.** A split disk is cut into 2 GB pieces, but is stored as a single **HDD file.** Split disks allow you to transfer the data stored on a split disk piece by piece using a USB drive or other media that have limited space and cannot store a large virtual hard disk image file.

**Virtual hard disk (virtual disk).** A file or group of files that emulates the virtual machine's hard disk.

**Virtual machine.** The computer emulated using Parallels Desktop. A virtual machine has its own virtual hardware and requires an operating system to control its hardware. The installed operating system and its applications are isolated inside the virtual machine and share physical hardware resources of the **host computer.**

**Third-party virtual machine.** A virtual machine created in a third-party virtualization product, that can be converted to a Parallels virtual machine.

**Virtual machine configuration.** Like any physical computer, a **virtual machine** has its own configuration which is set during the creation and can be modified later. The virtual machine configuration settings are stored in a **PVS file.**

**Virtual machine files.** Files stored in a **virtual machine** folder. A virtual machine has at least two files: configuration file and **virtual hard disk file.**

**Virtual hard disk file.** During the creation, the **virtual machine** acquires a virtual hard disk file with the .hdd extension. This file performs the functions of a real hard disk. See also **HDD file.**

**VM.** See **Virtual Machine.**

**Windows computer.** A physical computer that has a Windows operating system installed.
Index

D
Documentation feedback - 8

F
Firewall problems - 38

I
Installing
  Parallels Transporter - 12
  Parallels Transporter Agent - 12

M
Migration
  over network or FireWire - 27
  through USB cable - 23
  using external storage device - 31

S
Supported file systems - 10
System requirements - 9

T
Third-party virtual machines - 21
Transporter Agent
  for Linux - 15
  for Windows - 13
Troubleshooting - 37